This application note describes the usage of Vector Davinci configurator tool. It applies to the RH850 X2x family (E2x and U2x) and X1x family independent of the MCAL release version. This provides a general idea on how to use the DaVinci configurator tool. It does not address specific topics with close dependencies on the user application or potential issues by obvious misconfigurations.

1. **Introduction**  
   1.1 Validation by Configurator Tool  
   1.2 Generation Tool Usage  
   1.3 Information and Warning Messages during Generation

2. **DaVinci Configurator**  
   2.1 Parameter Definition File versus Configuration Description File  
   2.2 How to use DaVinci Configurator tool to create or modify a configuration  
      2.2.1 Usage of PDF in DaVinci  
      2.2.2 How to Launch or open DaVinci tool  
      2.2.3 Create New Project  
      2.2.4 Familiarize all the options present in DaVinci  
      2.2.5 Create a New Configuration using PDF  
      2.2.6 Import & Export functionality  
      2.2.7 Modify an existing/available Configuration  
      2.2.8 Import & Export using single/ multiple configurations  
   2.3 How to Generate using DaVinci Configurator  
      2.3.1 How to add generation step  
      2.3.2 Generation step details  
      2.3.3 How to perform generation for multiple modules  
      2.3.4 Generation Report  
      2.3.5 List of Generated and Output files  
   2.4 Perform Generation and Compilation without using DaVinci Configurator  
      2.4.1 How to generate and compile using Batch file  
      2.4.2 Difference between the argument of BUILD Option

3. **Revision History**
LIST OF FIGURES

Figure 1 : DaVinci Configurator ................................................................................................................................ 4
Figure 2 : Example of Elements of a Container ........................................................................................................ 5
Figure 3 : New Project .............................................................................................................................................. 6
Figure 4 : General Settings ....................................................................................................................................... 6
Figure 5 : DaVinci Project Name and Folder Name ................................................................................................. 7
Figure 6 : File ............................................................................................................................................................ 7
Figure 7 : View .......................................................................................................................................................... 8
Figure 8 : Project ...................................................................................................................................................... 9
Figure 9 : Elements of Basic Editor ........................................................................................................................10
Figure 10 : Basic Editor and Properties of Elements ...............................................................................................10
Figure 11 : Help ......................................................................................................................................................10
Figure 12 : Add Module Definition ........................................................................................................................11
Figure 13 : Create New configuration ....................................................................................................................11
Figure 14 : Import ...................................................................................................................................................12
Figure 15 : Export: Module Configuration Export and Select file window ................................................................13
Figure 16 : Input Filename for Exporting ................................................................................................................13
Figure 17 : Modify an Existing / new Configuration ................................................................................................13
Figure 18 : Properties Window: Description ...........................................................................................................14
Figure 19 : Properties Window: Definition ................................................................................................................14
Figure 20 : Properties Window: Status ....................................................................................................................15
Figure 21 : Copy multiple PDF files to BSWMD folder ............................................................................................16
Figure 22 : Basic Editor with multiple modules .......................................................................................................16
Figure 23 : Export window with multiple modules and checkboxes ........................................................................17
Figure 24 : Add Generation step .............................................................................................................................17
Figure 25 : Generation step details for X2x U2Ax device ..........................................................................................18
Figure 26 : Generation window ...............................................................................................................................18
Figure 27 : Build using SampleApp.bat file .............................................................................................................20

LIST OF ABBREVIATIONS

<table>
<thead>
<tr>
<th>Abbreviation</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>AUTOSAR</td>
<td>Automotive Open System Architecture</td>
</tr>
<tr>
<td>BSWMD</td>
<td>BSW Module Description</td>
</tr>
<tr>
<td>CDF</td>
<td>Configuration Description File</td>
</tr>
<tr>
<td>CFG</td>
<td>Configuration</td>
</tr>
<tr>
<td>ECU</td>
<td>Electronic Control Unit</td>
</tr>
<tr>
<td>IN</td>
<td>INPUT</td>
</tr>
<tr>
<td>OUT</td>
<td>OUTPUT</td>
</tr>
<tr>
<td>PDF</td>
<td>Parameter Definition File</td>
</tr>
<tr>
<td>XML</td>
<td>arxml</td>
</tr>
<tr>
<td>HTML</td>
<td>Hypertext markup Language</td>
</tr>
</tbody>
</table>
1. Introduction

1.1 Validation by Configurator Tool
Configurator tool like Vector DaVinci performs a validation of the entered configuration values. This is based on the Parameter Definition Files (BSWMD) that are delivered by Renesas. These files contain all available containers and parameters, the ranges of values or selectable options. The configurator tool typically marks any detected mismatches by detailed warning and error messages.

Validation is especially important to do when an existing configuration is upgraded to a newer release. An update of a release is done by importing the existing old configuration, based on a new Parameter Definition File. That new Parameter Definition File might have added or removed parameters, or the selectable values could have changed. Therefore, the configuration must be verified carefully after upgrade. All issues notified by the configurator tool must be checked and corrected if needed.

It is important to know that parameter mismatches are not explicitly checked and detected by the Renesas generator tools. Invalid parameters might have unexpected side effects.

1.2 Generation Tool Usage
Generation tool is a command line tool that accepts ECU Configuration Description File(s), BSWMDT file, Translation XML file and Configuration XML file as input, and generates the C source and header files based on the configuration of the module.

1.3 Information and Warning Messages during Generation
The Renesas command line generator tools return three types of messages which are errors, warnings, and information. Errors will abort the generation process and no source files are generated until the faults in the configuration are fixed.

Warnings might occur but the source files are created, nonetheless. It is important to check and justify the given warnings because they could indicate potential issues depending on the application and usage of MCAL functions. It is recommended to solve the warnings by configuration changes if possible.

Information messages like output of calculated frequencies can help the user to identify unintended settings.

2. DaVinci Configurator
DaVinci Configurator is a tool for creating ECU Configuration Descriptions according to the AUTOSAR standard. It includes specific functionality for configuring AUTOSAR basic software modules and the RTE.

DaVinci Configurator is delivered as part of a Vector Software Integration Package (SIP). The available tool functionality depends on the tool license and the SIP license.

A DaVinci Configurator is a tool used by Renesas for configuring MCAL parameters. It can be used to create a new configuration, modify an existing configuration and generate necessary output files.

DaVinci Configurator mainly uses two files for performing its functionalities. It includes a Parameter Definition File (PDF/BSWMD) and a Configuration Description File (CDF).

The Parameter Definition File acts as an input for the generator tool. By using the information present in the PDF, the tool provides a template to the user. By using this template, a user can configure the parameters and thereby create or modify a CDF.
Figure 1 : DaVinci Configurator

2.1 Parameter Definition File versus Configuration Description File

A PDF or Parameter Definition File is a template or a Definition File as its name says. The PDF basically contains the details of all available containers, parameters, the ranges of values or selectable options. This can be considered as a set of rules that needs to be taken care while a user creates or modifies a configuration using a PDF.

A CDF or Configuration Description file is a configuration that a user can create or modify according to the containers or parameters or rules defined in the PDF. A configurator tool like DaVinci can show errors and notify the user that there is a mismatch between the PDF and CDF.

The configuration parameters are sorted into containers and the structure that a tool shows are taken from the PDF/BSWMD file.

A PDF can contain the following elements. Based on these elements type, the user can configure accordingly.

- Containers and Parameters
- Mandatory and Non-Mandatory (Optional) Containers & parameters
- Input fields
- Check boxes.
- Drop Down boxes.
- References
- List
A real-life example can be used to explain the difference of PDF and CDF in a better way.

<table>
<thead>
<tr>
<th>Container</th>
<th>CDF for User1</th>
<th>CDF for User2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Container name (Input any name of the User)</td>
<td>Name: Mikey (Mandatory)</td>
<td>Name: Joseph (Mandatory)</td>
</tr>
<tr>
<td>Mandatory</td>
<td></td>
<td></td>
</tr>
<tr>
<td>List of Parameters</td>
<td>Mandatory parameters</td>
<td>Mandatory parameters</td>
</tr>
<tr>
<td></td>
<td>• Age: 24</td>
<td>• Age: 28</td>
</tr>
<tr>
<td></td>
<td>• Gender: F</td>
<td>• Gender: M</td>
</tr>
<tr>
<td></td>
<td>• Certification: Checkbox disabled.</td>
<td>• Certification: Checkbox enabled.</td>
</tr>
<tr>
<td>Age (21 to 65)</td>
<td>Here, container name and first three parameters are mandatory.</td>
<td>Non-Mandatory</td>
</tr>
<tr>
<td>Mandatory</td>
<td>Since these are mandatory, they should be configured by the user.</td>
<td>Drop Down box</td>
</tr>
<tr>
<td>Gender (M/F)</td>
<td>It cannot be always confirmed that the Configurator will throw error for missing mandatory parameter.</td>
<td>Drop Down box</td>
</tr>
<tr>
<td>Mandatory</td>
<td>However, the tool may show an error cursor while a mandatory parameter is not configured.</td>
<td>Check boxes</td>
</tr>
<tr>
<td>Certification. (If checkbox is checked: means True, if checkbox is not checked means False)</td>
<td>It is expected to be taken care by the user to configure them.</td>
<td>Input fields</td>
</tr>
<tr>
<td>Expected Salary (0-50000)</td>
<td>Last parameter is non mandatory. Hence user can skip this parameter.</td>
<td>Input fields</td>
</tr>
<tr>
<td>Non-Mandatory</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

According to this CDF, the user has configured all the mandatory parameters alone. The user has skipped the non mandatory parameter. But this is not a problem according to the tool.

Figure 2: Example of Elements of a Container
2.2 How to use DaVinci Configurator tool to create or modify a configuration

This section provides step by step guide on how to use a DaVinci Configurator to create a new configuration, import, modify and export an existing configuration.

2.2.1. Usage of PDF in DaVinci

- Copy the PDF and BSWMDT file to the BSWMD folder present in the DaVinci Installation folder.
- Always ensure that PDF file corresponding to the device variant is selected correctly.
- If user wants to configure a device 702300EABA, then always make sure that the PDF file corresponding to 702300EABA itself is copied to the BSWMD folder.
- To configure multiple modules at the same time, PDF corresponding to each of these modules should be copied to the BSWMD folder present in the DaVinci installation folder.
- Always ensure that only a single PDF file corresponding to a module is present in the BSWMD folder, or else, the DaVinci configurator will throw an error for multiple PDF files for a single module.

2.2.2. How to Launch or open DaVinci tool

- Double click on the DaVinciCFG.exe present inside the Installation-> Core folder.
- Once the configurator opens, a disclaimer or warning will be displayed.
- Click on “I accept” to accept the warning and proceed to next step.
- Now DaVinci Configurator SIP.MCAL window will be displayed and ready to use.

2.2.3. Create New Project

After invoking DaVinci configurator, the first step is to create an ECU project.

- Click on File-> New ECU Project…

Please note that all the other options like Save, Close, Import and Export are disabled currently since the Project is not created.

- A New ECU Project-> General Settings window will be displayed, and user needs to input the Project Folder name and the path in which they would like to save the project in this window as shown here.
Guideline for Vector DaVinci configurator tool

- A valid project name must start with a letter [a-z A-Z].
- A project folder can be either given as a manual input or it can be selected/browsed from the folder symbol next to Project Folder display field.
- Until a valid name or Project is not selected, Next and Cancel buttons will also be disabled.
- After providing valid Project name and Project folder, user can click on Next to navigate to next step.
- A Project Folder Structure window will be displayed and again click on Next.
- A Target window will be displayed next and click on Finish button.
- An ECU project will be created, and the details of the Project name and folder will be present on the top of DaVinci Configurator.
- Also, this project will be available in your systems D:\DaVinci_Projects\TEST_DAVINCI folder.
- Inside this D:\DaVinci_Projects\TEST_DAVINCI folder, there is a DPA file which is available in your project’s name, say TestDaVinci_1.dpa.
- A user can open this project dpa using File-> Open and select this location and choose the dpa file.

![Figure 5: DaVinci Project Name and Folder Name](image)

Note: Once the project is successfully created, Import, Export, Open and Close functionality gets enabled.

2.2.4. Familiarize all the options present in DaVinci.

Various options/tabs available in the configurator is File, Edit, Navigate, View, Project and Help.

2.2.4.1. File

![Figure 6: File](image)
• Click on the option “File”:
  - **New ECU Project**: To create a new Project as mentioned in section 2.2.3.
  - **Open**: To open an existing project. User can select an already available project by browsing its location or path.
  - **Close**: Current project will be closed, the configurator window will not close here. User can create a new project from there itself or open an existing project after closing this current project.
  - **Import**: Import an available configuration.
  - **Save**: After importing a configuration, save button gets enabled. User can click on save button to save the project.
  - **Last Imports**: Click on this button to see the list of all the previous Imports done for this project.
  - **Export**: Export the configuration present in the DaVinci configurator to an existing file or a new file.
  - **List of old Projects**: A list of all the recent projects will be shown here. User can open any of the recent projects available here.
  - **Exit**: Click on Exit button and the DaVinci configurator will close.

  - If user clicks on Exit button before saving the project, the configurator will throw a pop-up window to notify the user that the modified project has not been saved.
  - If the user still wants to close the project, then the project will be closed without saving the latest modifications.

### 2.2.4.2. View

- Click on the option “View”:
- The **View** menu provides commands for influencing the views of the main window.
- This displays all the options that is used to view the results, properties, validation, unresolved references, validation, find, element usage.
  - **Generation Result**: Used to view the generation result after successful generation from tool.
  - **Properties**: Click on this option and a properties window will be displayed. This option is used to view the properties of each element and parameters and containers used in the configuration. User can click on this option to invoke the Properties window to identify the origin, multiplicity, definition and status.

![Figure 7: View](image-url)
Guideline for Vector DaVinci configurator tool

- **Validation**: User can click on this option and a validation window will be displayed. It contains the validation result of the current configuration.

- **Unresolved References**: Click on this option to invoke Unresolved references window and it displays the list of unresolved references.

- **Console**: The Console view shows information about the script execution.

- **Find**: The Find view provides the possibility to search parameters, containers or module configurations by several criteria.

- **Element usage**: The Element Usage view displays all configuration objects which reference a specified element in the configuration. The configuration objects include System Description objects as well as ECUC objects.

### 2.2.4.3. Project

The Project menu provides commands for project-related operations.

- It includes On-demand generator validation, Generate, Project settings and Basic Editor.
  - On-demand generator validation: It is used to start the generator validation process.
  - Generate: It is used for generation process. It will generate reports, generated files and output files as per the rules defined in the Project-> Project Settings-> External generation steps.
  - Project Settings: It is used to define the settings of a project.
    - It includes a section named “Modules” that can be used to add or delete a module.
    - It includes a section named “Code Generation” which is used to add External generation steps that can be used to generate outputs using the functionality Generate.

#### 2.2.4.3.1. Basic Editor

Basic Editor: The Basic Editor displays all module configuration of the ECU configuration. This will basically provide an editor for the user to analyse and modify the configuration.

- The configuration that is displayed in the Basic Editor can be either new configuration created in the tool using Project-> Project Settings-> Modules->Add new module as mentioned in the section 2.2.3 or it can be the available configuration imported using File->Import option as mentioned in section 2.2.6.

- There is a tree structure present in the Basic Editor as shown below.
  - **Module**: Represents a module configuration of the ECU configuration.
  - **Container**: Represents a container of a module configuration.
    - If the definition of the container has the upper multiplicity 1, the container is displayed directly under its parent container/module.
- If the definition of the container has the upper multiplicity > 1, the container is displayed under an according Container Group
  
  **Container Group**: Represents a group of containers having the same definition.

The following symbols represents each Elements as shown in the Basic Editor’s tree structure.

---

**Figure 9 : Elements of Basic Editor**

---

2.2.4.4. Help

The Help menu provides commands for help assistance and further information.

- It consists of options that will help the user to Open the help system of the program and make necessary search in the help system.

- Also, “About Davinci Configurator Option...” opens a dialog with technical information about the used Eclipse features and the program configuration.

---

**Figure 10 : Basic Editor and Properties of Elements**

---

**Figure 11 : Help**
2.2.5. Create a New Configuration using PDF.

User can follow the steps provided below to create a new configuration for any module just by using the PDF file.

- Create a Project in DaVinci using the precondition steps mentioned in Section 2.2.
- Go to Project-> Project Settings-> Modules.
- From Modules, click on (+) button to invoke Add Module - Source window.
- From here, select the source of module options.
- Choose the option -> Select from Software Integration package (SIP) and click on Next button.
- Module definition for the modules whose PDF is present in the BSWMD folder will be displayed here.
- Select the modules that user wants to configure and click on the checkbox.
- Click on Next and Finish to complete this.
- The selected module will now be created or added to the Project-> Project Settings-> Modules.
- Open Basic Editor to modify or edit this configuration.
- Use Export option to export this configuration to a new file as mentioned in the section 2.2.6.
- Here the (x) button can be used to delete a module added. Here, if the user wants to delete Port module, then select Port modules and click on (x) button to delete it.
2.2.6. **Import & Export functionality.**

Import functionality is used to import an available configuration into the configurator tool.

- Click on File -> Import.
- Choose the add option (+) from File Selection window.
- The Add option (+) will let the user to browse and select a configuration available in the device.
- Click on Open button to choose that configuration.

Export functionality is used to export a configuration from the tool to a new configuration file or an existing configuration file.

- Once a user has created a configuration or imported an available configuration and completed all the modifications, this file must be exported to user’s desired location.
- Click on File -> Export and Module Configuration Export window will be invoked.
- Click on the target folder symbol to invoke the Select file window.
- Choose the target file and location to which the file must be exported.
- The file name must be given as input while browsing or selecting the location.
- The file name can be a new name, or a user can input an existing file name and then Click on Save button to close the Select file window.
- After selecting the file name and where to export your file, User must enable the checkbox corresponding to the modules that has to be exported.
- Final step is to click on Finish button.
- In the above example, user has imported Port module, after making necessary changes, user can export this port configuration into the available and existing arxml.

![Figure 14: Import](image-url)
2.2.7. Modify an existing/available Configuration.

As already described in the above sections, a user can either create a new configuration using the tool or import, modify and export an available configuration.

Follow the mentioned steps to modify a configuration using the tool:

- Import an available configuration or create a new configuration.
- Invoke Basic Editor from DaVinci configurator.
- As shown in the below figure, tree structure contains containers and parameters.
Here, PortGroup00 is a container and PortPin10 is a sub container.

To modify/edit the properties of PortPin10 sub container, user must click on it.

This container along with all its elements will be displayed on the right side.

If a user wants to change the properties of any element, user can click on that element, for example Pin Direction.

Here, the option selected for Pin Direction is PORT_PIN_IN

User can click on the drop-down arrow and choose any available option.

User can right click on any element or container to delete it.

After making all the changes, user can save the configuration and export it.

2.2.7.1. Details of the Configuration Properties Window

User can view the properties of an element (Parameter/Container) by invoking the properties window.

Let us assume the same example of Port Pin Direction to know about Properties window.

Click on Port Pin Direction and properties of this element will be displayed in the Properties window.

If the Properties window is not displayed automatically, invoke Properties window from View -> properties and click on Port Pin Direction element.

As shown in the figure below, Properties window displays Description, Definition and Status of the selected elements. These properties are displayed based on the description available in the PDF.

- Description defines the functionality of that element and the available options for that element. For example, in this case, user selected Port Pin Direction element. The available option for this element is PORT_PIN_IN and PORT_PIN_OUT

![Properties Window: Description](image18.png)

- Definition: This mentions the type of this element along with its multiplicity. Type defines whether the element is enumeration or Boolean etc. and the multiplicity defines if an element or container is mandatory. This also mentions the origin of an element.

![Properties Window: Definition](image19.png)
Guideline for Vector DaVinci configurator tool

- Multiplicity denotes the lower and upper range of a container. If lower multiplicity is 0 and upper multiplicity is 2, this signifies that there can be a maximum of 2 containers. But it is not necessary to configure at least one since lower multiplicity is 0.

- If lower multiplicity is 1 and upper multiplicity is 2, this signifies that there can be a maximum of 2 containers. But there should be at least one container configured which is must.

  o Status defines the current value and the default value of an element.

<table>
<thead>
<tr>
<th>File Direction</th>
<th>Description</th>
<th>Defined Value</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>Current Value</td>
<td>-</td>
<td>PORT_PIN_IN</td>
<td>-</td>
</tr>
<tr>
<td>Derived Value</td>
<td>-</td>
<td>PORT_PIN_IN</td>
<td>-</td>
</tr>
<tr>
<td>Pre-configured Value</td>
<td>-</td>
<td>-</td>
<td>yes</td>
</tr>
<tr>
<td>Recommended Value</td>
<td>-</td>
<td>-</td>
<td>yes</td>
</tr>
<tr>
<td>Changeable</td>
<td>-</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>Deletable</td>
<td>-</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>Short Name Path</td>
<td>-</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>Location</td>
<td>-</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>PortBuild-Deletable</td>
<td>-</td>
<td>-</td>
<td>-</td>
</tr>
</tbody>
</table>

Figure 20: Properties Window: Status

- User can refer these properties and make necessary changes in the configuration.
- User can right click on any element or container to delete it. But always make sure that the multiplicity of that element or container is 0 or non mandatory before deleting it.

2.2.8. Import & Export using single/multiple configurations.

This section describes how a user can import or export multiple configurations.

Example: Consider a user needs to integrate Port, Mcu, Icu, Pwm.

- **CASE 1: Import multiple configuration files and export it to a single file.**
  - Copy PDF files corresponding to multiple modules in the BSWMD folder.
  - Import the configuration of the first module by using the Import functionality as explained in section 2.2.6 (say Port)
  - Repeat this step for all the other modules. (Mcu, Icu, Pwm)
  - Export all the modules into a single target file and make sure that all the modules’ checkboxes are enabled.
  - By doing this Port, Mcu, Icu, Pwm will be available in a single target file.

- **CASE 2: Import multiple configuration files and export it to multiple files.**
  - Copy PDF files corresponding to multiple modules in the BSWMD folder.
  - Import the configuration of the first module by using the Import functionality as explained in section 2.2.6 (say Port)
  - Repeat this step for all the other modules. (Mcu, Icu, Pwm)
  - Export only the required modules into a single target file and make sure that the checkboxes corresponding to the module’s which needs to be exported are enabled.
  - For example, if a user wishes to export only Port, then user can enable the checkbox of Port and export it to a single target file.
For example, if a user wishes to export Port and Mcu, then user can enable the checkbox of Port and Mcu and export it to a single target file.

- **CASE 3: Import a single configuration containing multiple modules and export it to a single file.**
  - Copy PDF files corresponding to multiple modules in the BSWMD folder.
  - The resulting target file of CASE 1 is a single configuration file containing multiple modules such as Port, Mcu, Icu, Pwm.
  - Import this configuration file containing multiple modules.
  - Export these modules to same or any other single target file after any modifications done using the tool.
  - Ensure that the checkboxes corresponding to the modules which needs to be exported is enabled.

- **CASE 4: Import a single configuration containing multiple modules and export it to multiple files.**
  - Copy PDF files corresponding to multiple modules in the BSWMD folder.
  - The resulting target file of CASE 1 is a single configuration file containing multiple modules such as Port, Mcu, Icu, Pwm.
  - Import this configuration file containing multiple modules.
  - Export these modules to different target files based on the checkboxes enabled.
  - User can export only Port to a single target file or export Port and Mcu to a single target file.
2.3 How to Generate using DaVinci Configurator

The DaVinci Configurator tool can be used to generate source and header files along with output files. So, this configurator can produce outputs in addition to creation or modification of a configuration.

Generation functionality can be performed using Project-> Generate or Generate symbol present in the configurator tool.

To generate, a generation step should be added in Project-> Project settings-> External Generation Steps.

2.3.1. How to add generation step

An external generation step can be added from Project-> Project settings-> External Generation Steps.

- Invoke External Generation Steps and Click on (+) button or Add External Generation step button from the right side.
- After clicking on the (+) button, a New_Step is created. User can provide any name for this step.
- For this generation step, you must provide the following inputs: Command Line Executable, Execution type, Parameters and Working folder.
2.3.2. Generation step details

- For generation step, you must provide the following inputs: Command Line Executable, Execution type, Parameters and Working folder.
  - Command Line Executable: Choose the sample batch file from the MCAL delivery package. Provide the location of batch file here.
  - Execution type:
    - Serial: Each generation steps will be executed one after other.
    - Parallel: Each generation steps will be executed in parallel.
  - Parameters: Provide module name, AUTOSAR version, device name, Multi instance support [Mandatory parameters], compilation mode [Non mandatory] (Example of X2x U2A)
    - Port (mandatory)
    - 4.3.1 (mandatory)
    - 702300EABA (mandatory)
    - Yes/No (mandatory)
    - generate/clean/make/do not enter anything > this means clean, generate and make will be done. (Not mandatory)
  - Working folder: Provide your path of the GHS folder in which the SampleApp.bat file is present in the MCAL delivery package.

![Figure 25: Generation step details for X2x U2Ax device](image)

- Save your project and perform Generate using project-> Generate or using Generate symbol.
- A Generation window is invoked, and it contains all the generation steps that a user has added.
- An HTML report gets generated.
- Also, generated files are created, and output files are created.

![Figure 26: Generation window](image)
2.3.3. How to perform generation for multiple modules

A user can generate for multiple modules using multiple generation steps.

- If you want to perform the build for another module also, then, in External generation Steps -> Add a second-generation process under any name say “Dio”.
- Input all the details as mentioned including Command Line Executable, Execution type, Parameters and Working folder.
- If you have chosen Serial execution type for both generation steps, then first port will be executed and then Dio.
- Save your project and perform Generate from project-> Generate.
- An HTML report gets generated.
- Also, generated files are created, and output files are created.

2.3.4. Generation Report

After performing Generate from DaVinci tool, the generation report will be available in the Generation window itself as an HTML report.

- Click on the HTML link of the generated report and a generated HTML will open in the explorer.
- Also, user can view the generation report in the Log folder of the Project folder in which they have saved the DaVinci project.
- In the above example as mentioned in the section 2.2.3, user has saved this project in D:\Davinci_Projects\TEST_DAVINCI folder.
- The generation report will be available in D:\Davinci_Projects\TEST_DAVINCI\Log\GenerationReport_yyyymmddhhmm\ GenerationReport.HTML.
- Reference or example of a generated HTML file is as shown below:

2.3.5. List of Generated and Output files

Along with the generation report which shows the status of the compilation, there are a list of output files generated if the generation is successful.

- Generated files
  - X2x\U2A\U2Ax\Ver43.02.00\AUTOSAR_RH850_U2Ax_MCAL_Ver43.02.00\X2x\modules\port\ample_application\U2A16\4_3_1.
  - In this mentioned path, a src folder, include folder and a <ModuleName>.txt will be generated.
  - src and include folder contains the generated files and the text file contains the details of generation.
- Output files
  - X2x\U2A\U2Ax\Ver43.02.00\AUTOSAR_RH850_U2Ax_MCAL_Ver43.02.00\X2x\modules\port\ample_application\U2A16\obj.
  - Inside this obj folder, ghs folder will be created and this contains all the output files resulting after successful compilation.
2.4 Perform Generation and Compilation without using DaVinci Configurator

Generation and Compilation can be performed without using the tool. This can be done by using the batch file directly which is available in the MCAL delivery package.

2.4.1. How to generate and compile using Batch file

To generate and compile using the batch file available in the MCAL Delivery package, the user must follow the below mentioned steps:

- Navigate to the path in which the batch file is present.
- Invoke command prompt from this path by just selecting this location and typing cmd.
- Run batch file in the CMD (command prompt window). Also note that it is not possible to use PowerShell instead of CMD.
- If user wants to know the arguments that is required for this command, they can type SampleApp.bat and click on enter.
- This command will show a help screen which displays the option required to run the batch file.

Example of such a command for X1x variant is as follows:

- Syntax: SampleApp.bat Module_Name Autosar_Version Device_Name clean/generate/make/null
- E.g.: SampleApp.bat port 4.2.2 701649
- Note: Here the 4th argument is non mandatory and can be omitted. If the user does not input anything for the 4th argument, then the compiler will clean, generate and make.

Example of such a command for X2x variant is as follows:

- Syntax: SampleApp.bat Module_Name Autosar_Version Device_Name Multiple_Instance clean/generate/make/null
- E.g.: SampleApp.bat port 4.3.1 702300EABA No

Note:

- Here the 4th argument is to select if Multi instance is needed or not. If user inputs Yes, the Multi instance will be generated. If a user selects No, a single instance will be selected. While selecting Multi Instance, the user should ensure if that module supports multi-instances from the help window options.
- Here the 5th argument is non mandatory and can be omitted. If the user does not input anything for the 5th argument, then the compiler will clean, generate and make.
2.4.2. Difference between the argument of BUILD Option

Build option is an argument that is given as input both in the DaVinci tool and SampleApp.bat file for generation and compilation.

Available Build options are:

- **Unset(null):** When the user does not input anything, this option is taken. For this option, the compiler will clean, generate and make.

- **Clean:** If user inputs build option as Clean, the this will delete all the generated files from the src folder and include folder and delete and output files from the ghs folder. (Folders will not be deleted, but only the files present inside this)
  
  o **Src folder:**
    
    $X2x\U2A\U2Ax\Ver43.02.00\AUTOSAR_RH850\U2Ax_MCAL_Ver43.02.00\X2x\modules\port\samle_application\U2A16\4_3_1\src$
  
  o **Include folder:**
    
    $X2x\U2A\U2Ax\Ver43.02.00\AUTOSAR_RH850\U2Ax_MCAL_Ver43.02.00\X2x\modules\port\samle_application\U2A16\4_3_1\include$
  
  o **Ghs folder:**
    
    $X2x\U2A\U2Ax\Ver43.02.00\AUTOSAR_RH850\U2Ax_MCAL_Ver43.02.00\X2x\modules\port\samle_application\U2A16\obj\ghs$

- **Generate:** If user inputs build option as generate, then it will create the generated files in src and include folder. It will not create any compilation output file in the obj\ghs folder.

- **Make:** If user inputs build option as make, then it will create the compilation output files in the obj\ghs folder.
  
  o But for executing make command, the user must ensure that all the generated files are already present in the src and include folder.
  
  o If the generated files are not present, make will fail.
  
  o So, a user can use make option only if they have not made any modification in the configuration and generation files are already created, but they are modifying the sample application only.
## 3. Revision History

<table>
<thead>
<tr>
<th>Revision</th>
<th>Date</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0</td>
<td>June 21, 2023</td>
<td>Initial release.</td>
</tr>
</tbody>
</table>