RENESANS Application Note

RZ/T2, RZ/N2
Getting Started with Flexible Software Package

Introduction

This manual describes how to use the Renesas Flexible Software Package (FSP) for writing applications for the RZ/T2,
RZ/N2 microprocessor series.

Target Device

RZ/T series: RZ/T2M, RZ/T2L, RZ/T2ME
RZ/N series: RZ/N2L

About the video contents

We provide videos about the development tools using the RZ/T and RZ/N FSP. Access the following links:
. How to install the development tools
RZ/T RZ/N FSP Quick Start Guide - FSP Installation and Generating Your First Project for e2 studio
(English, Japanese, Chinese)
RZ/T RZ/N FSP Quick Start Guide - FSP Installation & Generating Your First Project for EWARM & FSP SC
(English, Japanese, Chinese)
. Instructions and usage of each tab in FSP Configuration
RZ/T RZ/N FSP Tutorial - Pin Configuration Function
(English, Japanese, Chinese)
RZ/T RZ/N FSP Tutorial for FSP Configuration (1/2) - Introduction of Tabs
(English, Japanese, Chinese)
(Tutorial for FSP Configuration (2/2) will be released in the second half of 2024.)
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1. Introduction

1.1 Overview

This application note describes how to use the Renesas Flexible Software Package (FSP) running on the Cortex®-R52
(hereinafter referred to as CR52) incorporated on RZ/T2 and RZ/N2.

1.2 Introduction to FSP

1.2.1 Purpose

The Renesas Flexible Software Package (FSP) is an optimized software package designed to provide easy to use,
scalable, high quality software for embedded system design. The primary goal is to provide lightweight, efficient the
hardware abstraction layer (HAL) drivers and the board support package (BSP) that meet common use cases in
embedded systems.

1.2.2 e?studio IDE

FSP provides a host of efficiency enhancing tools for developing projects targeting the Renesas RZ/T2, RZ/N2 series of
MPU devices. The e? studio IDE provides a familiar development cockpit from which the key steps of project creation,
module selection and configuration, code development, code generation, and debugging are all managed.

1.2.3 FSP Smart Configurator

The Renesas FSP Smart Configurator (FSP SC) is a desktop application designed to configure device hardware such as
clock set up and pin assignment as well as initialization of FSP software components when using a 3"-party IDE and
toolchain.

For creating RZ/T2, RZ/N2 project, the FSP SC can currently be used with

e |AR Systems Embedded Workbench for Arm (IAR EWARM) with IAR toolchain for Arm

1.2.4 FSP Documentation

The related file “FSP Documentation” contains HTML documentations describing the features, APIs and usage notes
regarding the BSP and HAL drivers implemented as FSP modules and interfaces. After clicking the “index.html” in
“FSP Documentation” to open the introduction page on your html browser, the reference documents for utilizing each
FSP module and interface can be read from “API Reference” menu.

RO1AN6434EJ0111 Rev.1.11 Page 5 of 120
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1.3 Related Documentation Files
The related documentation files are shown in the following.

1.3.1 Renesas Starter Kit+ User’s Manual
This Getting Started Guide refers to the following “Evaluation Board Kit User’s Manual”.

e  RZ/T series
» RZ/T2M Group Renesas Starter Kit+ for RZ/T2M User’s Manual (RZ/T2M and RZ/T2ME)
- Document No. R20UT4939
» RZ/T2L Group Renesas Starter Kit+ for RZ/T2L User’s Manual
- Document No. R20UT5164
e  RZ/N series
» RZIN2L Group Renesas Starter Kit+ for RZ/N2L User’s Manual
— Document No. R20UT4984

These documents can be found on Renesas web site by inputting their Document No. into search box.
e  URL: https://www.renesas.com/

Renesas xee

Figure 1: Search Box in Renesas Web Page

1.3.2 FSP Documentation

This Getting Started Guide refers to the following “FSP Documentation”. It contains notes on the use of the software
modules packaged with FSP.

These documents are available in Renesas Git repository in GitHub.

o  RZ/T series
» RZ/T2 Flexible Software Package Documentation
- URL: https://github.com/renesas/rzt-fsp/releases
o File name: fsp_documentation_vx.x.X.zip
e  RZ/N series
» RZ/N2 Flexible Software Package Documentation
- URL: https://github.com/renesas/rzn-fsp/releases
o File name: fsp_documentation_vx.x.x.zip

Note:
The “vx.x.X” is the FSP version number such as “v1.0.0”.

Note for RZ/N2L:

The RZ/N2L FSP documentation can also be viewed in a web browser by accessing the following link, but it is
RZ/N2L FSP v1.0.0 content.

e URL: https://renesas.github.io/rzn-fsp/
The latest version of the document should be obtained as a zip file as described above.

RO1AN6434EJ0111 Rev.1.11 Page 6 of 120
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1.4 Starting Development Introduction

FSP application project can be created by e? studio or FSP SC (for IAR EWARM), and this Getting Started includes
tutorial for both tools; the chapters you should read changes.

e2 studio users should read the following chapters:

e  Chapter 2 ”Set up Renesas Starter kit+ for RZ/T2, RZ/N2 CPU Board”
e  Chapter 3 “e? studio Setup”

e  Chapter 4 “Tutorial: Your First RZ/T2, RZ/IN2 MPU Project — Blinky”
e  Chapter 6 “FSP Configuration Users Guide”

FSP SC users (for IAR EWARM users) should read the following chapters:
e  Chapter 2 ”Set up Renesas Starter kit+ for RZ/T2, RZ/N2 CPU Board”

e  Chapter 5 “FSP Smart Configurator User Guide”

e  Chapter 6 “FSP Configuration Users Guide”

The summary of each chapter is shown below.
e  Chapter 2 ”Set up Renesas Starter kit+ for RZ/T2, RZ/N2 CPU Board”

»  Explains how to setup Renesas Starter kit+ for RZT2, RZ/N2 CPU Board to proceed the tutorials in Chapter
4 and 5.

e  Chapter 3 “e? studio Setup”

>  Explains the setup of e? studio for utilizing FSP.
e  Chapter 4 “Tutorial: Your First RZ/T2, RZ/N2 MPU Project — Blinky”

>  Explains the tutorial with minimal steps to create, run, and debug a FSP project by using e? studio.
e  Chapter 5 “FSP Smart Configurator User Guide”

> Explains the tutorial with minimal steps to create an FSP project as IAR EWARM project by using the FSP
Smart Configurator and to run and debug the created IAR EWARM project.

e  Chapter 6 “FSP Configuration Users Guide”
»  Explains how to create and configure an FSP project in detail.

>  The explanation is described based on e? studio, but most of the explanations are applied to the FSP smart
configurator.

RO1AN6434EJ0111 Rev.1.11 Page 7 of 120
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2. Set up Renesas Starter kit+ for RZ/T2, RZ/N2 CPU Board

2.1 Obtaining an Renesas Starter Kit+

To develop applications with RZ/T2 FSP and RZ/N2 FSP, start with Renesas Starter Kit+ (RSK).
The Renesas Starter Kit+ for RZ/T2 and RZ/N2 CPU Board (RSK+RZT2M, RSK+RZ/T2L, RSK+RZT2ME, and

RSK+RZN2L) are designed to seamlessly integrate with the e? studio.

Ordering information, User Manuals, and other related documents for RSK boards are available. Please contact Renesas

to get them.

2.2 System Configuration
Below is an example of a typical system configuration of RSK board.

HOST PC

<y
F— I-Jet I e
or ' Ko 1
 SE— > o 0T S GE,
D J-LiNk™ SANALE T
L y U e s
or

ey

\J ot e
Al 1
[ Wy

micro-USB Type-B (for J-Link OB) ‘CI‘:’U Bo.a.r<‘:lA

-

USB Type-C (for power supply)

Figure 2: System Configuration Example — with RSK Board

For the details, please refer to the related document “Renesas Starter Kit+ User’s Manual”.

RO1AN6434EJ0111 Rev.1.11
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2.3 Supported Emulator

2.3.1 SEGGER J-Link
SEGGER J-Link can be used on Renesas e? studio only for debugging on RZ/T2 and RZ/N2 devices.
Renesas e? studio supports the following emulators.

J-Link EDU V11 and later
J-Link BASE V11 and later
J-Link PLUS V11 and later
J-Link WiFi V1 and later
J-Link ULTRA+ V5 and later
J-Link PRO V5 and later
J-Link OB-S124 V1.00

Renesas has tested debugging RZ/T2 and RZ/N2 devices with J-Link BASE V11 and J-Link OB-S124.
For the details on SEGGER J-Link, please see SEGGER website.

Debugging FSP Project was verified with the following software environment.

Table 1 Verified Operating Environment

Series Device FSP version e? studio version J-Link Software
version
RZ/T RZ/T2M, RZ/T2L, RZ/T2 FSP v2.1.0 2024-04 V7.96j
RZ/T2ME
RZ/N RZ/N2L RZ/N2L FSP v2.0.0 2024-01.1 V7.94h
2.3.2 IAR I-Jet

IAR I-jet can be used on IAR EWARM only for debugging on RZ/T2 and RZ/N2 devices.
For the details on 1AR I-jet, please see IAR Systems website.

RO1AN6434EJ0111 Rev.1.11
Jun.28.24
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2.4 RZIT Series Board Setup
2.4.1 RSK+RZT2M

2.4.1.1 Boot Mode
The operation mode settings for the RSK+RZT2M board are as follows.

Note:

This section shows the settings for running on RAM without external flash memory. For settings to run in other

boot modes, please refer to the manual of the RSK boards listed in chapter 1.3.1. For the sample codes
available on Renesas web site, please refer to the documentation included with each code and implement the

appropriate board settings respectively.

Figure 3: Switch Position of Operation Mode Settings for RSK+RZT2M

Table 2 Operation Mode Switch Settings for RSK+RZT2M

Switch Setting Description
Sw4.1 ON 16-bit bus boot mode (NOR Flash)
SW4.2 OFF
SW4.3 ON
SW4.4 ON JTAG Authentication by Hash is disabled.
SW4.5 ON ATCM 0 wait
Valid for CPU operating frequency equal to or less than 400MHz.

RO1AN6434EJ0111 Rev.1.11
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2.4.1.2 Debugger Connection
If you use JTAG connection with I-Jet or J-Link,

1. Short the jumper pin (J9) for switching the debug connection so that RSK+RZT2M board can use the emulator
connected to JTAG connector (J20).

2. Connect the emulator (J-Link or I-jet) to a free USB port on your computer.
3. Connect the IAR I-Jet to the RSK+RZT2M board ensuring that it is plugged in to the header “J20”.

. RENESAS
" ASK-RIT2M

Figure 4: Jumper Position of JTAG connection for RSK+RZT2M

If you use J-Link OB on RSK+RZT2M board,

1. Open the jumper pin (J9) for switching the debug connection so that RSK+RZT2M can use J-Link OB on the
board.

2. Connect the micro-USB type-B to J-Link OB USB connector (J10), and then the LED4 is lighted.

. RENESAS

2]

Figure 5: J-Link OB Connection Settings for RSK+RZT2M

RO1AN6434EJ0111 Rev.1.11 Page 11 of 120
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2.4.1.3 Power Supply

Power is supplied using a USB cable (Type-C) or an AC / DC adapter.

e When using a USB cable (Type-C), connect it to the USB connector “CN5” of the RSK+RZT2M board.

e  When connecting the AC / DC adapter, connect it to the USB connector “CN6” of the RSK+RZT2M board.

Figure 6: How to Power Supply for RSK+RZT2M

RO1AN6434EJ0111 Rev.1.11 Page 12 of 120
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2.4.2 RSK+RZT2L
2.4.2.1 Boot Mode
The operation mode settings for the RSK+RZT2L board are as follows.

Note:
This section shows the settings for running on RAM without external flash memory. For settings to run in other
boot modes, please refer to the manual of the RSK boards listed in chapter 1.3.1. For the sample codes
available on Renesas web site, please refer to the documentation included with each code and implement the
appropriate board settings respectively.
Figure 7: Switch Position of Operation Mode Settings for RSK+RZT2L
Table 3 Operation Mode Switch Settings for RSK+RZT2L
Switch Setting Description
Sw4.1 ON XSPI10 boot mode (x1 boot serial flash)
SW4.2 ON
SW4.3 ON
SW4.4 ON ATCM wait cycle = 0 wait
SW4.5 ON JTAG mode = Normal mode
RO1AN6434EJ0111 Rev.1.11 Page 13 of 120
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2.4.2.2 Debugger Connection
If you use JTAG connection with I-Jet or J-Link,

1. Short the jumper pin (J9) for switching the debug connection so that RSK+RZT2L board can use the emulator
connected to JTAG connector (J20).

2. Connect the emulator (J-Link or I-jet) to a free USB port on your computer.
3. Connect the IAR I-Jet to the RSK+RZT2L board ensuring that it is plugged in to the header “J20”.

Figure 8: Jumper Position of JTAG connection for RSK+RZT2L

If you use J-Link OB on RSK+RZT2L board,
1. Open the jumper pin (J9) for switching the debug connection so that RSK+RZT2L can use J-Link OB on the board.
2. Connect the micro-USB type-B to J-Link OB USB connector (J10), and then the LEDS is lighted.

Figure 9: J-Link OB Connection Settings for RSK+RZT2L
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2.4.2.3 Power Supply

Power is supplied using a USB cable (Type-C) or an AC / DC adapter.

e  When using a USB cable (Type-C), connect it to the USB connector “CN5” of the RSK+RZT2L board.

e When connecting the AC / DC adapter, connect it to the USB connector “CN6” of the RSK+RZT2L board.
e After connecting to the power (CN5 or CN6), turn on the POWER_SW slide switch to start power supply.

Figure 10: How to Power Supply for RSK+RZT2L

2.4.3 RSK+RZT2ME
For each setting, see 2.4.1 RSK+RZT2M.
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2.5 RZIN Series Board Setup
2.5.1 RSK+RZN2L

2.5.1.1 Boot Mode
The operation mode settings for the RSK+RZN2L board are as follows.

Note:
This section shows the settings for running on RAM without external flash memory. For settings to run in other
boot modes, please refer to the manual of the RSK boards listed in chapter 1.3.1. For the sample codes
available on Renesas web site, please refer to the documentation included with each code and implement the
appropriate board settings respectively.
e RENESAS
Figure 11: Switch Position of Operation Mode Settings for RSK+RZN2L
Table 4 Operation Mode Switch Settings for RSK+RZN2L
Switch Setting Description
Sw4.1 ON 16-bit bus boot mode (NOR flash)
SW4.2 OFF
SW4.3 ON
SW4.4 ON JTAG Authentication by Hash is disabled.
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2.5.1.2 Debugger Connection
If you use JTAG connection with I-Jet or J-Link,

1. Short the jumper pin (J9) for switching the debug connection so that RSK+RZN2L board can use the emulator
connected to JTAG connector (J20).

2. Connect the Emulator (J-Link or I-jet) to a free USB port on your computer.
3. Connect the IAR I-Jet to the RSK+RZN2L board ensuring that it is plugged in to the header “J20”.

The figure below is when a I-jet is used as Emulator.

Figure 12: Jumper Position of JTAG Connection for RSK+RZN2L

If you use J-Link OB on RSK+RZN2L board,
1. Open the jumper pin (J9) for switching the debug connection so that RSK+RZN2L can use J-Link OB on the board.
2. Connect the micro-USB type-B to J-Link OB USB connector (J10), and then the LED4 is lighted.

Figure 13: J-Link OB Connection Settings for RSK+RZN2L
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2.5.1.3 Power Supply

Power is supplied using a USB cable (Type-C) or an AC / DC adapter.

e  When using a USB cable (Type-C), connect it to the USB connector “CN5” of the RSK+RZN2L board.

e When connecting the AC / DC adapter, connect it to the USB connector “CN6” of the RSK+RZN2L board.

=

HRENESAS
(L1 [N Kol

Figure 14: How to Power Supply for RSK+RZN2L
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3. e?studio Setup

3.1 Whatis e? studio?

Renesas e? studio is a development tool encompassing code development, build, and debug. e? studio is based on the
open-source Eclipse IDE and the associated C/C++ Development Tooling (CDT).

When developing for RZ/T2, RZ/N2 MPUs, e? studio hosts the Renesas Flexible Software Package (FSP). FSP provides
a wide range of time saving tools to simplify the selection, configuration, and management of modules and threads, to
easily implement complex applications.

3.2 e?studio Prerequisites
3.2.1 Windows PC Requirements
The following are the Windows PC requirements to use e? studio:
For Windows 64-bit version
e  Windows® 11 (64-bit version)
e  Windows® 10 (64-bit version)
e  Windows® 8.1 (64-bit version)
e  Memory capacity: We recommend 8 GB or more. At least 4 GB.
e  Capacity of hard disk: At least 2 GB of free space.

o Display: Graphics resolution should be at least 1024 x 768, and the mode should display at least 65,536
colors.

e Interface: USB 2.0
e  Microsoft Visual C++ 2010 SP1 runtime library *1
e  Microsoft Visual C++ 2015-2019 runtime library *1
*1. This software will be installed at the same time as the e2 studio.

3.2.2 Installing e? studio, Platform Installer and FSP Package

Detailed installation instructions for the e2 studio and the FSP are available on the Renesas website. Review the release
notes for e? studio to ensure that the e? studio version supports the selected FSP version. The starting version of the
installer includes all features of the RZ/T2, RZ/N2 MPUs.

3.2.3 Choosing a Toolchain
The GNU ARM Embedded Toolchain (version 12.2.1.arm-12-24) is required.

If the version of the toolchain has not been installed, please download the toolchain from ARM Developer website, and
install it.

3.2.4 Licensing
FSP licensing includes full source code, limited to Renesas hardware only.
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4. Tutorial: Your First RZ/T2, RZ/IN2 MPU Project — Blinky

4.1 Tutorial Blinky

The goal of this tutorial is to quickly get acquainted with the Flexible Platform by moving through the steps of creating
a simple application using e? studio and running that application on an RZ/T2, RZ/N2 MPU board. This chapter guides
you through creating projects for a single-core processing and a multiprocessing. Here, the multiprocessing refers to a
process in which CR52 CPUO core is activated first and CR52 CPUL1 core operates after CR52 CPUO core sets up for
CR52 CPUL1 core.

4.2 What Does Blinky Do?

The application used in this tutorial is Blinky, traditionally the first program run in a new embedded development
environment.

Blinky is the “Hello World” of microprocessors. If the LED blinks you know that:
e  The toolchain is setup correctly and builds a working executable image for your chip.
e  The debugger has installed with working drivers and is properly connected to the board.
e  The board is powered up and its jumper and switch settings are probably correct.
e  The microprocessor is alive, the clocks are running, and the memory is initialized.
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4.3 Create a New Project for Blinky

The creation and configuration of an RZ/T and RZ/N C/C++ FSP Project is the first step in the creation of an
application. The base RZ/T2 pack and RZ/N2 packs include a pre-written Blinky example application. In the case of
multiprocessing, two projects with different settings must be created. The CR52 CPUO core project that starts first is
called the primary project and the CR52 CPU1 core project is called the secondary project.

Note for multiprocessing projects:
The primary project and the secondary project should be created in a same workspace.

The secondary project should be created after the primary project is created in 4.3 section and built the primary
project in 4.4 section.

Follow these steps to create an RZ/T2, RZ/N2 MPU project:

1. Ine?studio, click File > New > C/C++ Project.

8 work - € studio

File | Edit Source Refactor Navigate Search Project RenesasViews Run Window Help

New Alt+Shift+N > | Renesas C/C++ Project N B
Open File... [c¥ Makefile Project with Existing Code

4 Open Projects from File System... |c) C/C++ Project N |
Recent Files > [ Project..

Figure 15: New C/C++ Project

2. Select either one depending on your RZ/T2, RZ/N2 MPU and RSK board.
. Renesas RZ > Renesas RZ/T C/C++ FSP Project

e Renesas RZ > Renesas RZ/N C/C++ FSP Project
3. Click Next.

Templates for New C/C++ Project

All GNU for Renesas RZ C/C++ Executable Project )
CMake 'E?\ A C/C++ Executabie Project for Renesas RZ
Make using the GNU ARM Embedded toolchain.

Renesas Debu
m GNU for Renesas RZ C/C++ Library Project

FE== A C/C++ Library Project for Renesas RZ using
the GNU ARM Embedded toolchain.

Renesas RZ/G C/C++ FSP Project
===~ Create an executable or static library C/C++
FSP project for Renesas RZ/G.

Renesas RZ/N C/C+~+ FSP Project
=N Creote an executoble or stotic library C/C++
FSP project for Renesas RZ/N.

Renesas RZ/T C/C++ FSP Project
== Create an executable or static library C/C++

FSP project for Renesas RZ/T. v
(?;‘ < Back Finish Cancel

Figure 16: Renesas RZ C/C++ FSP Project

(Continued on next page)

RO1AN6434EJ0111 Rev.1.11 Page 21 of 120
Jun.28.24 RENESAS




RZ/T2, RZIN2

Getting Started with Flexible Software Package

4. Assign a name to this new project. An example of naming is shown below.

e  Single-core processing
»  Blinky
e  Multiprocessing

»  The primary project: Blinky _cpuO_primary
»  The secondary project: Blinky_cpul_secondary
5. Click Next. The Project Configuration window shows your selection.

B Renesas RZ/TC/C++ FSP Project

Renesas RZ/T C/C++ FSP Project

Project Name and Location

Project name

|Btinky

Use default location

You can download more Renesas packs here

Cancel

Figure 17 : 2 studio Project Configuration Window (Part 1)

(Continued on next page)
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6. Select the board support package by selecting the name of your board from the drop-down list.
In this tutorial, please select either one depending on your device and RSK board.
o  RZ/T series
» RSK+RZT2M (RAM execution without flash memory)
» RSK+RZT2L (RAM execution without flash memory)
» RSK+RZT2ME (RAM execution without flash memory)
e  RZ/N series
» RSK+RZN2L (RAM execution without flash memory)
7. (RZ/T2M, RZ/T2ME ONLY) Select the Core from the drop-down list.
e  Single-core processing
» CR52.0
e  Multiprocessing
»  The primary project: CR52_0
»  The secondary project: CR52_1
8. Select GNU ARM Embedded in Toolchains and version is 12.2.1.arm-12-24 as its toolchain version, and click
Next.
o [Ifthereis NOT the 12.2.1.arm-12-24 version of GNU ARM Embedded Toolchain, please download the
version of the toolchain from ARM Developer website and install it.
8 Renesas RZ/T C/C++ FSP Project m} X
Renesas RZ/T C/C++ FSP Project —
Device and Tools Selection
Device Selection
FSP Version: | <FSP Version> Bl BoanDescription
Renesas Starter Kit+ for RZ/T2M CPU Board (RAM execution
Board: RSK+RZT2M (RAM execution without flash n v‘ i without flash memory)
Device: RIAQ7GOTSM24GBG
Core: Eﬂsz_n ;vI
Llanguages @C (OC++
Device Details
TrustZone No
Pins 320
Toolchains Debugger
[N ARM Embedded | ‘ -Link ARM v
‘\?/ < Back Einish Cancel
Figure 18 : e? studio Project Configuration Window (Part 2)
9. (The secondary project of multiprocessing ONLY) Select a bundle file of the primary project. Built CPUOQ project
names in the same workspace appear as an option in the drop-down list.
Note:

Warnings occur if the FSP version or Board (boot mode) used is different between the primary project and the
secondary project. Use the same FSP version and Board (boot mode).

(Continued on next page)
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g Renesas RZ/T C/C++ FSP Project

m] X
Renesas RZ/T C/C++ FSP Project —
Preceding Project or Smart Bundle Selection |
@ Preceding Project: E""ky <pu0_primary. gl

Choose this option if you have access to the project source code of the preceding processor core or security context.
(O Smart Bundle:

Workspace... | File System... Variables.

Preceding Project/Smart Bundle Details

FSP version =FSP Version>

Toolchain GNU ARM Embedded

Toolchain version =T oolchain Versionz

Board RSK+RZT2M (RAM execution without flash memory)
Device R9A07GO75M24GBG

Core CRS2.0

Zones CRs2_0

@ < Back Finish Cancel

Figure 19 e? studio Project Configuration Window (Part 3)

10. Select the build artifact and RTOS.

« Renesas RZ/T (/C++ FSP

Renesas RZ/T C/C++ FSP Project
Build Artifact and RTOS Selection

Build Artifact Selection

RTOS Selection
@ Executable [ o RTOS 4|
* Project builds to an executable file
O Static Library

® Project builds to a static library file

Figure 20 : e? studio Project Configuration Window (Part 4)

(Continued on next page)
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11. Select the Blinky template for your board and click Finish.

8 Renesas RZ/T C/C++ FSP Project m} bd

Renesas RZ/T C/C++ FSP Project —

Project Template Selection

Project Template Selection

® (-} " Bare Metal - Blinky

Bare metal FSP project that includes BSP and will blink LEDs if available. This project will initialize clocks, pins, stacks, and
the C runtime environment.

[RenesasRZT.  .pack]

o () " Bare Metal - Minimal
. Bare metal FSP project that includes BSR This project will initialize clocks, pins, stacks, and the C runtime envircnment.

[Renesas.RZT.  .pack]

Code Generation Settings
[ Use Renesas Code Formatter

Figure 21 : e? studio Project Configuration Window (Part 5)

Once the project has been created, the name of the project will show up in the Project Explorer window of e? studio.
Now click the Generate Project Content button in the top right corner of the Project Configuration window to

generate your board specific files.

i [Blinky] FSP Configuration; X

Summary

Project Summary

Board:

Device:

Toolchain:
Toolchain Version:
FSP Version:
Project Type:
Location:

Generate Project Content

RENESAS
RSK+RZT2M (RAM execution without flash memory)
RYA07G075M24GBG
GCC for Renesas RZ
<Toolchain Version>
<FSP Version>
Flat
D:/ /Blinky |

Fi

gure 22 : e? studio Project Configuration Tab

Your new project is now created, configured, and ready to build.
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4.3.1 Details about the Blinky Configuration

The Generate Project Content button creates configuration header files, copies source files from templates, and
generally configures the project based on the state of the Project Configuration screen.

For example, if you check a box next to a module in the Components tab and click the Generate Project Content button,
all the files necessary for the inclusion of that module into the project will be copied or created. If that same check box
is then unchecked those files will be deleted.

4.3.2 Configuring the Blinky Clocks
By selecting the Blinky template, the clocks are configured by e? studio for the Blinky application.

The clock configuration tab (see 6.3.3 Configuring Clocks) shows the Blinky clock configuration. The Blinky clock
configuration is stored in the BSP clock configuration file.

4.3.3 Configuring the Blinky Pins

By selecting the Blinky template, the GPIO pins used to toggle some of LEDs are configured by e? studio for the Blinky
application.

The pin configuration tab shows the pin configuration for the Blinky application (see 6.3.4 Configuring Pins). The
Blinky pin configuration is stored in the BSP configuration file.

4.3.4 Configuring the Parameters for Blinky Components
The Blinky project automatically selects the following HAL components in the Components tab:

e r_ioport

To see the configuration parameters for any of the components, check the Properties tab in the HAL window for the
respective drivers (see 6.5 Adding and Configuring HAL Drivers).

4.3.5 Whereis main()?

The main function is located in:
e < RZT2FSP project >/rzt_gen/main.c.
e < RZN2 FSP project >/rzn_gen/main.c.

It is one of the files that are generated during the project creation stage and only contains a call to hal_entry(). For more
information on generated files, see 6.5 Adding and Configuring HAL Drivers.

4.3.6 Blinky Example Code

The blinky application is stored in the hal_entry.c file. This file is generated by e? studio when you select the Blinky
Project template and is located in the project’s folder < project >/src/ folder.

The application performs the following steps:

1.  Getthe LED information for the selected board by bsp_leds_t structure.
Initialize output level for LED pin to LOW using R_BSP_PinClear((bsp_io_region_t) leds.p_leds[i][1],
(bsp_io_port_pin_t) leds.p_leds[i][0]).

3. Use R_BSP_PinToggle ((bsp_io_region_t) leds.p_leds[i][1], (bsp_io_port_pin_t) leds.p_leds[i][0]) to set the
output level to the LED pin.

4. R_BSP_SoftwareDelay(delay, bsp_delay_units) waits for a certain period of time. Then run #3 again.
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4.4 Build the Blinky Project

Highlight the new project in the Project Explorer window by clicking on it and build it.
When multiprocessing, build both the primary and secondary projects.

4.4.1 Build
There are three ways to build a project:

1. Click on Project in the menu bar and select Build Project.
2. Click on the hammer icon.
3. Right-click on the project and select Build Project.

Q workspace - Blinky/configuration.xml - e studio

File Edit Navigate Search enmw'rews Rum—Wirdow Help — a. Project -> Build Project
45 Debug [ Blinky Debug_Flat S-ER B4 v}—_,,,; b. Click hammer icon
Bl Project Explorer X 5% Y B = O | "Blinky] FSP Configuration 32 | ¢ Right click - Build project

......... Summary

Figure 23 : e? studio Project Explorer Window

Once the build is complete a message is displayed in the build Console window that displays the final image file name
and section sizes in that image.

[&:;PinConflicts_ R LGS EE-EE rE-N-= O

ICDT Build Console [Blinky]

'arm-none-eabi-gcc -mcpu=cortex-r52 -mthumb -mfloat-abi=hard -mfpu=neon-fp-armv8 -fdiagnostics-parseable-fixits -0Og -fmessage-length=t #
‘arm-none-eabi-gcc -mcpuscortex-r52 -mthumb -mfloat-abi=hard -mfpu=neon-fp-armvé -fdiagnostics-parseable-fixits -0g -fmessage-length=t
‘arm-none-eabi-gcc -mcpu=cortex-r52 -mthumb -mfloat-abi=hard -mfpu=neon-fp-armv8 -fdiagnostics-parseable-fixits -0Og -fmessage-length=¢
'arm-none-eabi-gcc -mcpu=cortex-r52 -mthumb -mfloat-abi=hard -mfpu=necn-fp-armv8 -fdiagnostics-parseable-fixits -0g -fmessage-length=¢
‘arm-none-eabi-gcc -mcpuscortex-r52 -mthumb -mfloat-abi=hard -mfpu=neon-fp-armvd -fdiagnostics-parseable-fixits -0g -fmessage-length=t
'arm-none-eabi-gce -mcpu=cortex-r52 -mthumb -mfloat-abi=hard -mfpu=neon-fp-armv8 -fdiagnostics-parseable-fixits -Og -fmessage-length=¢
arm-none-eabi-gcc @"Blinky.elf.in”
arm-none-eabi-objcopy -0 srec "Blinky.elf" ™“Blinky.srec”
arm-none-eabi-size --format=berkeley "Blinky.elf"

text data bss dec hex filename

Jped ] 65568 68564 1ebd4 Blinky.elf

11:46:51 Build Finished. @ errors, @ warnings. (took 12s.789ms)

Figure 24 : e2 studio Project Build Console
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4.5 Debug the Blinky Project

45.1 Debug Prerequisites

To debug the project on a board, you need the followings:

e The board to be connected to e? studio.

e  The debugger to be configured to talk to the board.

e  The application to be programmed to the microprocessor.

Applications run from the internal ram of your microprocessor. To run or debug the application, the application must
first be programmed to ram by JTAG debugger.

RSK board has a JTAG header and requires an external JTAG debugger to the header.

45.2 Debug Steps
When multiprocessing, please refer to Section 4.7 Debug and Run for Multiprocessing.

To debug the Blinky application, follow these steps:

1. Configure the debugger for your project by clicking Run > Debugger Configurations ... or by selecting the drop-
down menu next to the bug icon and selecting Debugger Configurations ...

Run Window Help
Renesas Device Partition Manager
@ Tracex >
) Tracealyzer >
Q, Run Ctrl+F11
3% Debug F11
Run History >
Q RunAs >
Run Configurations...
Debug History b
%5 DebugAs >
Debug Configurations...
Q, External Tools >

Figure 25 : e? studio Debug Icon

{;vhv Oy -

Debug As >
Debug Configurations...

Organize Favorites...

Figure 26 : e? studio Debugger Configurations Selection Option

(Continued on next page)
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2.

configuration for your Blinky project.

Select your debugger configuration in the window. If it is not visible, then it must be created by clicking the New
icon in the top left corner of the window. Once selected, the Debug Configuration window displays the Debug

¢ Debug Configurations

BeRX| e
type filter text ]

[€] ¢/C++ Application
[€] ¢/C++ Remote Application

= EASE Script

[£] GDB Hardware Debugging
GDB OpenOCD Debugging
(

Create, manage, and run configurations

Name: [Blinky Debug_Flat

_ %5 Debugger| B> Startup | &

Source | [T Common

[c¥] GDB Simulator D¢ (1
#] Java Applet
[T Java Application

@ Launch Group

T Remote Java Applicati
 [€7] Renesas GDB Hardware Deb

c | Blinky Debug_Flat

[E7 Renesas Simulator Debuggir

< >
Filter matched 13 of 15items

L/

Project:
[Blinky Browse...
C/C++ Application:
[Debug/Blinky.elf
Variables... | | Search Project... Browse...
Build (if required) before launching
Build Configuration: | Use Active v
O Enable auto build O Disable auto build
(@ Use workspace settings Configure Workspace Settings...
Revert App

(Continued on next page)

Figure 27 : e? studio Debugger Configurations Window with Blinky Project
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3. Ifyou use RAM execution without flash memory boot mode, it needs following configuration.

»  Debugger > Connection Settings > Connection

>  Set No to Reset after download (Available in e? studio 2023-07 and later versions)

to avoid resetting MPU after program download
>  (CPUO(CR52_0) ONLY) Set Yes to Set CPSR(5bit) after download (Available in e? studio 2023-04

and later versions)

to set the CPSR register value of CR52 general register before running the application.

@ Debug Configurations

P X E ¥

C/C++ Application

C/C++ Remote Application

EASE Script

GDB Hardware Debugging

€7 GDB Simulator Debugging (RH:
8 Launch Group

v [€7] Renesas GDB Hardware Debuge

[€7] Renesas Simulator Debugging (

161 |2

< >

Filter matched 9 of 11 items

@

Create, manage, and run configurations

MNome: [Blinky Debug_Flat
) Main [ Debugger] & Startup| % Source | (Z] Common

Debug hardware: |J-Link ARM v| Target Device: R9A07GO7SM24 CPL| | ..

GDB Settings Debug Tool Settings

v Connection

Register initialization No v
Reset at the beginning of connection Yes v
Reset at the end of connection No v
Reset before download No v
[ Recotedounions |8 7]
1D Code (Bytes)
Hold reset during connect No v
[ Set CPSR(5bit) after download Yes v]
Prevent Releasing the Reset of the CM3 Core Yes v
Secure Vector Address
Non-secure Vector Address
Hot Plug
Disconnection Mode
v SWv
Core clock (MHz) 0
v TrustZone
Set TrustZone secure/non-secure boundaries ¢
Reyert Apply
oo

Figure 28 : e? studio Debugger Configurations Window with Blinky Project

4. Click Debug to begin debugging the application.

Configuring GDB

& Progress Information [m| X

Preparing launch delegate...

Cancel

Details >

Figure 29: Start Debugging
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4.5.3 Details about the Debug Process

In debug mode, e? studio executes the following tasks:

1. Downloading the application image to the microprocessor and programming the image to the internal memory.
Setting a breakpoint at main().

Setting the stack pointer register to the stack.

Loading the program counter register with the address of the system_init().

Displaying the startup code where the program counter points to.

gk~ wn

{55 [Blinky] FSP Configuration m = 8
384 RFEIA \n" /* Return from system mode tack using RFE. *, A

84 sp! g
t:t "memory”);
}
= BSP_TARGET_ARM BSP_ATTRIBUTE_STACKLESS void system_init (void)
{
__asm volatile (
set_hactlr: \n
MOW r@, ¥[hactlr_bit_1] \n" /* Set HACTLR bits(L) */
MOVT ro, #0 \n"
MCR  p1S, #4, ro, c1, co, #1 \n" /* Write r@ to HACTLR

t:[hactlr_bit_1] "i" (HACTLR_BIT_L) : "memory");

__asm volatile (
"set_hcr: \n"
" MRC  pl15, #4, rl, c1, c1, #0 \n" /*
ORR rl, rl, ¥[hcr_hcd_dis] \n" /
MCR p1S, #4, rl, c1, cl1, #0 \n" /* Write
t:[hcr_hcd_dis] "i" (HCR_HCD_DIS) : “"memory");

__asm volatile (

"set_vbar: \n"

LDR re, =vector_table \n"

MCR p15, #0, r@, cl12, c@, #0 \n" /* Write r@ to VBAR */
11t "memory");

Figure 30 : e? studio Debugger Memory Window

4.6 Run the Blinky Project
While in Debug mode, click Run > Resume or click on the Play icon twice.

b

Figure 31 : e? studio Debugger Play Icon

The following LEDs on the board should how be blinking.
e RZ/T series
» RSK+RZ/T2M: LEDO-1 (CPUO0), LED2-3 (CPUL)
» RSK+RZ/T2L: LEDO-6 (including LEDx_ESC_xxx)
» RSK+RZ/T2ME: LEDO-1 (CPUO), LED2-3 (CPU1)
e RZ/N series
» RSK+RZ/N2L: LEDO-3

(Continued on next page)

RO1AN6434EJ0111 Rev.1.11 Page 31 of 120
Jun.28.24 RENESAS



RZ/T2, RZIN2 Getting Started with Flexible Software Package

To suspend program execution, click Run > Suspend or click on the Pause icon.

Figure 32 : e? studio Debugger Pause Icon

To exit Debug mode and disconnect from the debugger, click Run > Terminate or click on the Stop icon.

Figure 33 : e? studio Debugger Stop Icon

4.7 Debug and Run for Multiprocessing
To debug the Blinky application, follow these steps:
1. Connect the debugger with the primary project using the procedure in 4.5.2 Debug Steps.

2. The primary project in operation, connect the debugger with the secondary project using the procedure in 4.5.2
Debug Steps.

3. When the following dialog box is shown, please click No to start debugging.

a Launcher X

! A Renesas GDB debug session is already active.

Do you want to terminate all currently active debug sessions before starting the new
session? (Note: Selecting No may result in unstable debug functionality)

[[J Remember my decision
4

[ Yes | [ No ] Cancel

Figure 34 Warning Window of Starting Debug Session

4. When Figure 35 is shown, please click Yes to proceed the launch.

@ Proceed with launch? X

The device (R9A07G075M24_CRS2_1) set in the launch configuration does not match
' A the target device (ROA07G075M24GBG) set in the project. The launch may not

function correctly.

Do you wish to proceed with the launch?

No

Figure 35 Warning Window of Device Name

(Continued on next page)
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5. Run the primary project with procedure 4.6 Run the Blinky Project. If the LEDO and LED1 are blinking, proceed to
the next step.

6. Run the secondary project with procedure 4.6 Run the Blinky Project.

7. When exiting Debug mode and disconnect from the debugger, terminate both projects, the primary and the
secondary.

Q - Blinky_cpu1_secondary/rzt_gen/main.c - & studio

File Edit Source Refactor Navigate Search Project RenesasViews Run Wi
| B~ K- LRt T A N

% Debug X | E%|i» § = O

v [ Blinky_cpu0_primary Debug_Flat [Renesas GDB Hardware Debugging]
v .3;' Blinky_cpu0_primary.elf [1] [cores: 0]

hread #1 1 (single core) [core: 0] (Running)

sl [arm-none-eabi-gdb (12.1)

| |[Renesas GDB server (Host)
v Blinky_cpu1_secondary Debug_Flat [Renesas GDB Hardware Debugging]
& Blinky_cpu1_secondary.elf [1] [cores: 0]
E hread #1 1 (single core) [core: 0] (Running)
- Jarm-none-eabi-gdb (12.1)

- |Renesas GDB server (Host)

Figure 36 During Program Execution

Q - Blinky_cpu1_secondary/rzt_gen/main.c - & studio

File Edit Source Refactor Navigate Search Project RenesasViews Run Wi
B/~ e | B 2o | iR Q-

35 Debug X E%|i» § = 0O

v [c7]_<terminated>Blinky_cpu0_primary Debug_Flat [Renesas GDB Hardware Debugging
<terminated, exit value: 0>arm-none-eabi-gdb (12.1)
<terminated, exit value: 0>Renesas GDB server (Host)

v [c7] <terminated>Blinky_cpu1_secondary Debug_Flat [Renesas GDB Hardware Debuggi
<terminated, exit value: 0>arm-none-eabi-gdb (12.1)

<terminated, exit value: 0>Renesas GDB server (Host)

Figure 37 Terminated Program

4.8 Import the Project
The project created, built, and debugged in chapters 4.3 through 4.7 can be imported and run in other workspaces.

Note:
Apply the same version of FSP package used for the project to the other workspace.

(Continued on next page)
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To import the projects, follow these steps:

1. Click File > Import.

@ new_workspace - & studio
Edit Source Refactor Navigate Search Project RenesasViews Run Window

New Alt+Shift+N >
Open File... Bs Y =7
() Open Projects from File System...
Recent Files >
Ctrl+W existing code
Ctrl+Shift+W
Ctrl+S
Ctrl+Shift+S
Rename.. F2
& Refresh Fs
Convert Line Delimiters To >
Print... Ctrl+P
[ Import..
i3 Export..
Properties Alt+Enter
Switch Workspace >
Restart
Exit

Figure 38 €? studio Import

2.  Click General > Existing Projects into Workspace.

& import u]
Select
. . L N
reate new projects from an archive file or directory. g E

Select an import wizard:

“:.‘}:E"\\tfr‘s-t

v (= General I

T Archive File
[/ CMSIS Pack
|g Existing Projects into Workspacel
() File System
Ta» GNUARM-NONE/RZ(DS-5) project conversion to GCC ARM Embedded
[ Preferences
() Projects from Folder or Archive
= Rename & Import Existing C/C++ Project into Workspace
Ta# Renesas CS+ Project for CA78KOR/CA78KO
& Renesas CS+ Project for CC-RX, CC-RL and CC-RH
¥ Renesas GitHub FreeRTOS (with loT libraries) Project
& Sample Projects on Renesas Website
B QC++
o Conel

@ <Bac F [ one

(Continued on next page)

Figure 39 e? studio Select Import Type
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Select root directory or Select archive file where the project you would like to import into the other workspace
resides.

Select projects to import in Projects. When using Select root directory, it is recommended to set Copy projects
into workspace in Options to avoid updating the same project from multiple workspaces.

Q Import a X
Import Projects ==
Select a directory to search for existing Eclipse projects. / "‘
I @ Select root directory: J DS v [ Browse... I
(O Select archive file: Browse.
Projects:
Blinky_cpu0_primary (D¥w5¥%ﬁ%%5/ Blinky_cpu0_primary| Select All
Blinky_cpu_secondary (D:¥ws¥/7777//////7Blinky_cpul_secol
[A Blinky_nor_cpu0_primary (D:¥ws¥7z7z7 77 Deselect All
] Blink, 1 dary (D:¥ws¥777
inky_nor_cpu1_secondary ( ¥ Refresh

<

Options

[[] Search for nested projects

[ Close newly imported projects upon completion
[JHide projects that already exist in the workspace

Working sets
[J Add project to working sets

=
| 9\

Figure 40 e? studio Select Root Directory to Import Project

(Continued on next page)
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O X

Import Projects ——

Select a directory to search for existing Eclipse projects. i “/‘
(O Select root directory: Browse...

I (®) Select archive file: ‘ D:¥ws¥ 7 Blinky.zip v|i Browse. i
Blinky_cpuQ_primary (Blinky_cpu0_primary/) Select All
Blinky_cpu1_secondary (Blinky_cpu1_secondary/)

Blinky_nor_cpu0_primary (Blinky_nor_cpu0_primary/) Deselect All
Blink: 1 dary (Blink: 1 d
inky_nor_cpu_secondary (Blinky_nor_cpui_secondary/) Refresh
[J Clgse newly imported projects upon completion
[JHide projects that already exist in the workspace
Working sets
[ Add project to working sets New...
Select...

Figure 41 e? studio Select Archive File to Import Project

5. The projects have been imported into the other workspace.

& new_workspace - * studio
File Edit Source Refactor Navigate Search Pi

|® -4 - “it-q

55 Project Explorer X
T=% Blinky_cpu0_primary
1% Blinky_cpu1_secondary
=5 Blinky_nor_cpu0_primary
=5 Blinky_nor_cpul_secondary

Note:

Figure 42 e? studio new workspace

The imported project must be clicked the Generate Project Content button and built before debugging.
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5. FSP Smart Configurator User Guide

5.1 What is FSP Smart Configurator?

The Renesas FSP Smart Configurator (FSP SC) is a desktop application designed to configure device hardware such as
clock set up and pin assignment as well as initialization of FSP software components when using a 3™-party IDE and
toolchain.

For creating RZ/T2 and RZ/N2 project, the FSP SC can currently be used with
¢ |AR EWARM with IAR toolchain for Arm

Projects can be configured, and the project content generated in the same way as in e? studio. Please refer to 5.2
Configuring a Project section for more details.

5.2 Tutorial Blinky

The goal of this tutorial is to quickly get acquainted with the Flexible Platform by moving through the steps of creating
a simple application using FSP SC and 3-party IDE and running that application on an RZ/T2, RZ/N2 MPU board.
This chapter guides you through creating projects for a single-core processing and a multiprocessing. Here, the
multiprocessing refers to a process in which CR52 CPUO core is activated first and CR52 CPU1 core operates after
CR52 CPUO core sets up for CR52 CPUL core.

The application used in this tutorial is Blinky, traditionally the first program run in a new embedded development
environment.

Blinky is the “Hello World” of microprocessors. If the LED blinks you know that:

The toolchain is setup correctly and builds a working executable image for your chip.
The debugger has installed with working drivers and is properly connected to the board.
The board is powered up and its jumper and switch settings are probably correct.

The microprocessor is alive, the clocks are running, and the memory is initialized.

5.3 Using Smart Configurator with IAR EWARM

IAR EWARM includes support for Renesas RZ/T2, RZ/N2 devices. These can be set up as bare metal designs within
IAR EWARM. However, most RZ/T2, RZ/N2 developers will want to integrate RZ/T2, RZ/N2 FSP drivers and
middleware into their designs. SC will facilitate this.

FSP SC generates a “Project Connection” file that can be loaded directly into IAR EWARM to update project files.

5.3.1 Prerequisites
e IAR EWARM installed and licensed.
> Please refer to AR systems website regarding IAR EWARM.
e  FSP SC and FSP Pack installed.
>  Please refer to Renesas website regarding to FSP SC and FSP Pack.

Note for RZ/T2ME:
If you use the IAR EWARM 9.60.1 to debug RZ/T2ME FSP project, please apply the following patch file.
. EWARM_Patch_for RZT2ME_rev1.0.zip
Regarding how to apply the patch, please read the readme file in patch file.

RO1AN6434EJ0111 Rev.1.11 Page 37 of 120
Jun.28.24 RENESAS



RZ/T2, RZIN2 Getting Started with Flexible Software Package

5.3.2 Create a New Project

The following steps are required to create a project using IAR EWARM, FSP SC and FSP. In the case of
multiprocessing, two projects with different settings must be created. The CR52 CPUO core project that starts first is
called the primary project and the CR52 CPUL1 core project is called the secondary project.

Note for multiprocessing projects:
The primary project and the secondary project should be created in a same workspace.

The secondary project should be created after the primary project is created in 5.3.2 section and done 1% build
of the primary project in 5.3.3 section.

1.  Start the FSP Smart Configurator.
e  FSP Smart Configurator is installed in the following path as default.
»  For RZIT series, it is installed in C:\Renesas\rzt\sc vYYYY-MM_fsp_vX.X.X\eclipse\rasc.exe
»  For RZ/N series, it is installed in C:\Renesas\rzn\sc_vYYYY-MM_fsp_vX.X.X\eclipse\rasc.exe

2. Select the File > New > FSP Project...
e  This step may be unnecessary depending on old FSP SC version.

[EG FsP Smant Configurator - o X
File | Window Help Run
New > FSP Project... ] = B 45 FSP Visualization =

The active editor element does not use this view

[T Properties [£] Problems e § © 0 B Console o= S =
Property Value No consoles to display at this time.

Figure 43 : FSP SC New Project

(Continued on next page)
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3. Enter a project folder and project name. An example of naming is shown below.

e  Single-core processing
>  Blinky
e  Multiprocessing
»  The primary project: Blinky_cpu0_primary
»  The secondary project: Blinky_cpul_secondary

G New Renesas RZ/T Project

New Renesas RZ/T Project

Project Name and Location

Project name

|Blinky/

Use default location

You can download more Renesas packs here

Cancel

Figure 44 : FSP SC Project Settings

4.  Select the FSP version.
5. Select the Board for your application.

e  You can select an existing RZ/T2, RZ/N2 MPU Evaluation Kit or select Custom User Board for any of the

RZ/T2, RZ/N2 MPU devices with your own BSP definition.

. Here, select either of following boards to create a FSP project for RSK board.

»  RZIT series
-  RSK+RZT2M (RAM execution without flash memory)
- RSK+RZT2L (RAM execution without flash memory)
- RSK+RZT2ME (RAM execution without flash memory)
»  RZIN series
- RSK+RZN2L (RAM execution without flash memory)
6. (RZ/T2M, RZ/T2ME ONLY) Select the Core from the drop-down list.
e  Single-core processing
» CR52.0
e  Multiprocessing
»  The primary project: CR52_0
»  The secondary project: CR52_1
(Continued on next page)
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7. Select IDE Project Type.

o  Here, select IAR EWARM (FSP SC is older than 2024-04 version) or IAR EWARM [v9.40+] (FSP SC is
equal to or newer than 2024-04 version).
»  As the Toolchain, IAR Toolchain for ARM is preselected.
8.  Click Next.

G New Renesas RZ/T Project [m} X
New Renesas RZ/T Project
Device and Tools Selection
Device Selection
rr verrore B ]  Board Description
Renesas Starter Kit+ for RZ/T2M CPU Board (RAM execution
Board: RSK+RZT2M (RAM execution withoutflash r v | | .. |  without flash memory)
Device: RIA07GO75M24GBG
|core: CR52_0 Y Device Details
languages @ C OC++ TrustZone No
Pins 320
Processor Cortex-R52
IDE Project Type
JIAR EWARM [v9.40+] 4|
Toolchains
IAR Toolchain for ARM
v A je Toolchain
< Back Next > Finish Cancel

Figure 45 : Target Device and IDE Selections

9. (The secondary project of multiprocessing ONLY) Select a bundle file of the primary project. Built CPUOQ project

names in the same workspace appear as an option in the drop-down list.

Note:

Warnings occur if the FSP version used is different between the primary project and the secondary project. Use
the FSP same version.

(Continued on next page)
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G New Renesas RZ/T Project [m) x

New Renesas RZ/T Project
Existing Smart Bundle Selection

Smart Bundle: ID:¥ws¥ Blink! <pug grimaz!Debus&xe‘#Bhnkz <puQ, Erimaw‘sbd |iBrowse..J

Select a Smart Bundle (*.sbd) file describing the configuration of the preceding processor core.

Smart Bundle Details

FSP version <FSP Version=

Toclchain IAR Teolchain for ARM

Toolchain version

Board RSK+RZT2M (RAM execution without flash memory)
Device R9AQ7G075M24GBG

Core CRs2_0

Zones CRs2_0

< Back Finish Cancel

Figure 46 e? studio Project Configuration Window (Part 3)

10. Select RTOS.
e  Here, select No RTOS for proceeding the following tutorial.
11. Click Next.

6 New Renesas RZ/T Project a X

New Renesas RZ/T Project

RTOS Selection

RTOS Selection

No RTOS ~

< Back Finist Cancel
Figure 47 : RTOS Selection

(Continued on next page)
RO1AN6434EJ0111 Rev.1.11 Page 41 of 120

Jun.28.24 RENESAS




RZ/T2, RZIN2 Getting Started with Flexible Software Package

12. Select a project template from the list of available templates.
e By default, this screen shows the templates that are included in your current RZ/T MPU Pack.
e  Here, select Bare Metal — Blinky for proceeding the following tutorial.

»  If you want to develop your own application, select the basic template for your board, Bare Metal —
Minimal.

13. Click Finish.

@ New Renesas RZ/T Project o X

New Renesas RZ/T Project

Project Template Selection

Project Template Selection

@® (-} " Bare Metal - Blinky

Bare metal FSP project that includes BSP and will blink LEDs if available. This project will initialize clocks, pins, stacks, and
the C runtime environment.

[Renesas.RZT.  .pack]

o d " Bare Metal - Minimal

Bare metal FSP project that includes BSP. This project will initialize clocks, pins, stacks, and the C runtime environment,
[Renesas.RZT.  .pack]

Figure 48 : Template Selection

14. Configure the FSP configuration by referring to Chapter 6.3 “Configuring a Project”.
e  Here, skips this configuration step for proceeding the following tutorial.

15. On completion of the FSP configuration, click Generate Project Content.

35¢ [Blinky] FSP Configuration X = 8

Summar 0
y Generate Project Content

Project Summary
RENESAS
Board: RSK+RZT2M (RAM execution without flash memory)
Device: RIAD7GOT5M24GBG
FSP Version: <FSP Version>
Project Type: Flat
Location: C:/Users/ /Blinky ==

Figure 49 : FSP Project Configuration and Generation
A new IAR EWARM project file will be generated in the project path.

(Continued on next page)
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16. Double click IAR EWARM Workspace file (.eww) to open IAR EWARM with workspace.

script
src
|| .api_xml
| ] .secure_azone
| | .secure_xml
Blinky.ewd

Blinky.ewp

Blinky.eww

Figure 50 : FSP Project Workspace

5.3.3 Build the Project

5.3.3.1 NOTE: Build settings [Only Multiprocessing]

For multiprocessing, note the build order and build settings.

1.  Create and build the primary project. (1st build of the primary project)
No setting is required, proceed t05.3.3.2 Build.

2. Create the secondary project. Change the project options setting and build it.
Set the following before building:
i)  Click Project > Options....

> Blinky_cpu0_primary - IAR Embedded Workbench IDE - Arm 9.50.1
File Edit View I-jet Tools Window Help

i 0 B @ | [e AddFies.. <O
Workspace [e Add Group...

— | [&] ImportFile List...

Debug
r Add Project Connection...

Files Edit Configurations...

=} |Blinky_cpt

B Flex Softy Add CMakeLists.txt to Project

L— B buildinfo.{ Force Reconfiguration

Add CMake Connector >
X  Remove

O Create New Project...
™ Add Existing Project...

% options.. Alt=F7 I
Version Control System »
M nave F7

Figure 51 IAR EWARM project options

(Continued on next page)
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ii)  Click Debugger > Setup.

iii) Uncheck “Run to".

Options for node "Blinky_cpu1_secondary”

Category:

\General Options A | Factory Settings
General Options ~

Static Analysis

R;n/ch:igo‘::l:s Download Images Multicore Authentication Extra Options Plugins
Assembler
Output Converter Driver
Custom Build
Linker

Buid Actions Setup macros
Retnoge [ Use macro file(s)
Simulator
CADI
CMSIS DAP
E2[E2Lite
Gop senver Device description file
GHINK

I-jet v

Iet [ Override default
J-Link/)-Trace
T1 Stellaris
Nu-Link

PE micro

$TOOLKIT_DIR$¥config¥debugger¥Renesas¥RIA07GO75M24_CP

Figure 52 I1AR EWARM project options for the secondary project (Run to)

iv) Click I-jet > Setup.

v) Select Software as Reset and click OK.

Options for node "Blinky_cpu1_secondary”

Category.

Factory Sellings
General Options ~
Static Analysis
Rg;\: :i i::‘:l:f Interface Trace  Breakpoints
Assembler Reset
Qutput Converter
Custom Build
Linker 300 200
Build Actions : ! -
Delbuggar Target power Emulator
Simulator
P From the probe Always prompt for probe

selection
CMSIS DAP (®) Leave on after debugging
E2/E2 Lite

o s [ |
Switch off after debuggi
GDB Server 2witch oft aiter debugging

GHINK

| software M|

[ Log communication
Iink/J-Trace

T1 Stellaris $PROJ_DIR$¥cspycomm.log
Nu-Link
PE micro

Cancel

Figure 53 IAR EWARM project options for the secondary project (Reset)
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vi) Proceed to 5.3.3.2 Build.

vii) Close the secondary project.

3. Change the project options setting of the primary project and build it. (2nd build of the primary project)
Set the following before building:
i) Click Project > Options....
ii)  Click Debugger > Setup.
iii)  Uncheck “Run to".
iv)  Click Debugger >Multicore.
v)  Set the following contents in Asymmetric multicore.
e  Simple
»  Partner workspace: the path of Blinky_cpul_secondary.eww
»  Partner project: Blinky_cpul secondary
»  Partner configuration: Debug

Options for node "Blinky_cpuQ_primary” X
I Factory Settings
General Options A
Static Analysis
Runtime Checking

CJC++ Compiler Setup  Download Images Authentication Extra Options Plugins
Assembler Symmetric multicore
Output Converter
Custom Build Number of cores: 1
Linker .
Build Actions Asymmetric multicore
O Disabled
Simulator
cADT @ Simple
CMSIS DAP Partner workspace: secondary¥Blinky_cpu Lsecondary.ewv.” -
E2[E2Lite Partner project: Blinky_cpul_secondary I
GDB Server
GHINK Partner configuration: | Debug
Ljet [ Attach partner to running target Partner cores: |1
J-inkf)-Trace
TI Stellaris [[] Override partner debugger location
Nu-Link
PE micro
- v (O Adyanced
Cancel

Figure 54 1AR EWARM project options for the primary project (Multicore)
vi) Click OK and close Options window.

(Continued on next page)
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vii) Click Tools > Options....

> Blinky_cpu0_primary - Master - IAR Embedded Workbench IDE - Arm 9.50.1

File Edit View Project |I-jet | Tools | Window Help

iNoRE & onl®

Options...

Workspace v q
’ Debug N
| Files .|

)-
B @ Blinky_cpul_prima... ¥ *
Bl Flex Software
L— & buildinfo.ipcf

Filename Extensions...
Configure Viewers...
Configure Custom Argument Variables...

Configure Tools...
IAR Project Converter

FSPSC_202401

viii) Click Project.
iX)  Select Never as Make before debugging and click OK.

Figure 55 1AR EWARM project options for the primary project (Tool menu)

|DE Options

- Colors and Fonts
Key Bindings
Language

4. Editor

- Messages

Troubleshooting

| Project |
CMake/CMSIS-Toolbox
- Source Code Control
Debugger
Stack
- Terminal I/O

Stop build operation on: Never v
Save editor windows before building: Always v
Save w and projects before building: Always -
Mok before debugging

4 Reload last workspace at startup

[ Play sound after build operat

[ Generate browse information

Cancel

Browse processes: |4

[ No source browser and build status updates when the IDE is not the foreground process

[4] Enable project connections

[ Enable parallel build

Processes: \:I (8 cores reported by 0S)

Cancel

Figure 56 IAR EWARM project options for the primary project (debug)

X)  Proceed to 4.4.1 Build.
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5.3.3.2 Build

Click on Project -> Make from menu bar or Make button on tool bar to build.

File Edit View I-jet Tools Window Help
: [& AddFiles...
.WMBM . [= Add Group...

Debug

Files

B @ Blinky - Debu
B Flex Softw
D buildinfo.

B Output

[4] import File List...
Add Project Connection...
Edit Configurations...

X | Remove

'O Create New Project...
™ Add Existing Project...

£ Options... Alt-F7

Version Control System

| Birky

@ Make 7
. Compile Ctrl+F7
@ Rebuild All

& Clean

& Batch build... F8

C-STAT Static Analysis

€ | stop Build Ctrl+Break

Figure 57 : Make Button

Build

v Qo X

Messages
50% Generating Secure Bundle100% Generating Secure Bundle

Total number cof errors: 0
Tetal number of warnings: 0

Build succeeded v'

File Line

Ready

Build Debug Log

Errors 0, Warnings 0 Ln 149, Col 5 System CAP NUM OVR =

Figure 58 : Build Message Console

Once the build is completed, the build message is displayed in the Build Console window that displays compilation
target files and the number of error/warnings.
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5.3.4 Download & Debug the Project
When multiprocessing, please refer to Section.5.3.5 Debug for Multiprocessing

Click on Project -> Download and debug from menu bar or Download and Debug button on tool bar to download

and debug.

File Edit View [ Project | Ijet Tools Window Help
: [& AddFites... =
e Add Group...
[4] import File List...
Add Project Connection...

Files

B @ Blinky - Debu

B Flex Softw|
D buildinfo.
Eouput |

o

Edit Configurations...
Remove

Create New Project...
Add Existing Project...

Options...

Version Control System
@ Make
B  compile
@ Rebuild Al
& Clean
& Batch build...

C-STAT Static Analysis

€3 | stop Build

Alt-F7

»

F7
Ctrl«F7

F8

»

Ctrl+Break

a

a

© o d and Debug

Ctrl+D

Messages
r_ioport.c
system.c
vector_data.c
Linking

Total number
Total number

<

Build Debug Log

»  Debug without Downloading
“+)  Attach to Running Target
(&  Make & Restart Debugger

' | Restart Debugger

Download

SFR Setup

| 2B, CMSIS-Pack Manager

Open Device Description File
Save List of Registers...

Ctrl+Shift+R

Ctrl+R

»

Errors 0, Warnings 0 Ln 250, Col 29

system CAP NUM L 8= B

Figure 59 : Download and Debug Button

(Continued on next page)
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Once the download is completed and the debug is started, the program breaks at the beginning of main in main.c.

File Edit View Project Debug Disassembly Iljet Tools Window Help
DOR@ = xE0 OC < Q>%*=E< PO RABEBCO R Ir Nl >0  Tiem
Waorkspace ¥ 0 X | maine x w | Disassembly v QX
Debug  |mainp fo| Goto:
1 /* generated main source file - do not edit */ N
Files o 2  #include "hal_data.h" Disassembly
B @ Blinky - Debug v D30 int main(void) { ??DataTabled_5
|-@ 8 Flex software ; :::G::tgy(); OxBec: @x0004'0800 D
— Dbuildinfo.ipcr : ) g ?2DataTabled_6
i Output z ox6fe: @x8628'1ale D
??DataTabled_7
ox6fd: 0x8128'1a00 D
??DataTabled 8
ox6f8: 0x0000'e874 D
??DataTabled 9
ex6fc: 0x0000' 0860 D
??DataTabled_1
ex7e0: 0xe004'eeos D
__dar_init_vfp
ex7e4: exeell'efse M
Ox708: @xe380'0sfo o
ex7@c: @xeedl'efse L]
0x710: @xe3a@’' 0001 L]
ex714: @xeed7'@fos M
__dar_init_vfp
0x718: @xe3a@'@420 M
ex71c: @xeee8'@ale v
0x720: @xe3a0'0780 "
0x724: @xeeel'@ale i
0x728: @xel2f'ffle B
int main(void) {
hal try();
v
s‘,'*y < > 5 AvT2e- OvE7FF Ovifaa )Fl
Figure 60 : Starting Debug
Click on Debug->Go from menu bar or Go button on tool bar to run this program.
File Edit View Project | Debug | Disassembly I-jet Tools Window Help
NHO @ = X" 6 Fs 14 Q> K=« > QRO = 6c0)n3r il -0 Biom: P
Workspace L) | Break w | Disassembly v o X
Debug 3 Reset 0| Gote:
nerated moin source file - do not edit */
Files ©  stop Debugging e ..,m:ﬂata_nf F Disassembly A
5 @ Blinky - Debug N = int main(void) { ??DataTabled_s
|-@ W Flex Software step Over ¢ hal_entry(); ex6ec: 0x0004'0000 D
F— Dibuildinfo.iper 3| stepinto m ' return 8; ?2DataTabled_6
L@ u output r* step Out ShiftF11 exefo: 9*‘3?;5;1:151 . ;’
. ?2DataTabled_:
o ox6f4: @x8128'1a00 D
*]  Runto Cursor ??DataTabled_5
M Autostep ox6f8: @xeeee’'@s74 o
22DataTabled 9
= Set Next Statement ox6fc: Ox0000'0860 D
??DataTabled_1
e 4 0x700: 0x0004'0004 D
iar_init_vfp
N —dar_init_vfp,
Memory 8x784: exeell'efse M
Refresh 0x708: @xe380'08f0 O
Logging » ex78c: @xeedl'efse M
T ©x710: @xe3a@’' @00l M
Bx714: @xeed7?'@fos M
__iar_init_vfp
©x718: oxe3ad'@44e "
Bx71c: @xeee8'@al® VI
©x720: @xe3al’'0780 M
©@x724: @xeeel'@ale \
©x728: Bxel2f'ffle B
‘ int ma. oid)
d av77m- avF7EF avEfaa R Y
Blinky < > || < >

(Continued on next page)

Figure 61 : Go Button
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The blinky application is stored in the hal_entry.c file. This file is generated by FSP SC when you select the Blinky
Project template and is located in the project’s src/ folder. In IAR EWARM workspace view, the hal_entry.c is
registered Flex Software > Program Entry.

The application performs the following steps:
1.  Getthe LED information for the selected board by bsp_leds_t structure.

2. Initialize output level for LED pin to LOW using R_BSP_PinClear((bsp_io_region_t) leds.p_leds[i][1],
(bsp_io_port_pin_t) leds.p_leds[i][0]).

3. Use R_BSP_PinToggle ((bsp_io_region_t) leds.p_leds[i][1], (bsp_io_port_pin_t) leds.p_leds[i][0]) to set the
output level to the LED pin.

4. R_BSP_SoftwareDelay(delay, bsp_delay_units) waits for a certain period of time. Then run #3 again.

On debugging on IAR EWARM, the break point can be set by click the left space next to line number.

Edit View Projet Debug Disassembly ljet Tools Window Help
DoR@ & K0 DC 5L Q>5»=2< 0 >0 BO®=60c0. .03 il>0 ZiEm z
Workspace v 8 X  mainc halentryc X v | Disassembly v ax
Debug _ hal_entry()::bsp_delay_units fol coto:/
22 ~ ~
Files o 23 void R_BSP_WarmStart(bsp_warm_start_event_t event); Disassembly
B @ Blinky - Debug v 24 Ox654: @x6813 L
}_E] B Flex Software 25 extern bsp_leds_t g_bsp_leds; @x656: Ox4018 A
| |2 W suila configuration ;s [ /oeesessssssessnsesnnssssssssossssssssresserorsessristssonsosstseranioner ox658: oxfase ex4e2s 0
| 8 Components 28 * @brief BLinky example opplication 9?‘6?_‘: 9“5519 " S
| |2 8 Generated Data 29 | = CP(15, @, value, 4, §,
| L@ s program Entry 30 * Blinks all leds ot a rate of 1 second using the software delay function 22R_BSP_PinAcc
| LoEm 31 . ox65e: Oxeedd Ox1f16 M
0 hal_entry.c 32 L ecosesssssssscsssssssssssssssssnssssssssssssssssssssssssssssssssssssnssess
L_E ._;“'t"’";"’ et = \(loid hal_entry (void) ex662: @x477@ 8
utpuf [= d
Elss /* Define the units to
36 const bsp_delay_units_t
= REOPREIEE hal_entry:
38 /* Set the blink frequency (must be <= bsp_delay_units */ Ox664: @xb57c P
39 const uint32_t freq_in_hz const bsp_delay units t bsp
40 ®  ox666: oxfasf ox747a M
41 /* Colculate the deloy in terms of bsp_delay_units */ . t uint32 t freq in hz
:; const uint32_t delay = bsp_delay_units / freq_in_hz; Ox66a: 0x2002 »
aa /* LED type structure * LIHAMOZ At O Ay = OSF
45 bsp_leds_t leds = g_bsp_leds; ox66c: @xfbba afofB; u
46 bsp_leds_t leds = g _bsp_led
47 /* 1f s boord has no LEDs then trop here */ 0x670: @x4821 U
48 | if (0 == leds.led_count) Ox672: 0xe9de 0x2300 L
49 ¢ { . ©x676: @xedcd Ox2300 S
50 while (1) (6 TR e
516 { i Sl
52 ; // There are no LEDs on this boord x678: 9xfobd €x0000, L
530 | } @x67e: ©@x2800 [«
54 | } ox680: @xd100 8
55 le (1 .
EE “ - hal antruv .
Blinky < > vlll< A + |)

Figure 62 : hal_entry.c and Setting Breakpoint

(Continued on next page)
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By using the break point and the Debug menu or Debug tool bar, you can check the behavior of the Blinky application

step by step.

File Edit View Project

Debug | Disassembly ljet Tools Window Help

Blinky

vil<

DOR@ & X o s 1< Q> 52< 0 >NRN RS =60cOoIr sl -0 Gl F
Workspace Break tryc x ~ | Disassembly v o x
Debug 3 Reset sp_delay_units fo| Got:|
~
Files ©  stop Debugging ld R_BSP_WarmStart(bsp_warm_start_event_t event); Disassembly )
£ @ Blinky - Debug 0x654: @x6813 L
|61 8 Flex Software | step Over F10 fern bsp_leds_t g_bsp_leds; G656 oxdais ~
| @ s suila conngurat| ¥ Stepinto Bl Kssssssscasssonssnssssusisisssscussssssassosssssossassssrcrsoiorsriose 0x658: 0xfase ex4025 0
I |- o components [ *  step Out Shift«F11 laprief BLinky example opplication R oocE ORIt s
I Generated Data | »;  Next Statement CP(15 ». value, 4, 6,
| L@ s program Entry ; BLinks oLl Leds ot o rate of 1 second using the software delay function 2?R_BSP_PinAcc
: f16 M
| Lo ™ Runto Curser Ox65e: Oxeed4 Ox1
M Autostep... :
l—}—m it ot i o halentey;i(vedd) ox662: @x4770 B
i Output I Set Next Statement T
/* Define the units to be used with the software delay function */ =
C++ Exceptions » | const bsp_delay_units_t haliéntry:
Memory ol 7* set the blink frequency (must be <= bsp_delay_units */ 0x664: @xb57c P
const uint32_t freq_in_hz t bsp_delay units_t bsy
Refresh
Loggin | 7* catcutate the detay in terms of bsp_delay_units */
99ing const uint32_t delay = bsp_delay_units / freq_in_hz;
3 il .
44 /* LED type structure */ 32_t dela sp
45 bsp_leds_t leds = g_bsp_leds; : : @xfbb4 BfofB. u
46 eds_t leds = g_bsp_led
a7 /* If this boord has no LEDs then trop here */ 0x670: 0x4821 U
48 | if (2 == leds.led_count) 0x672: @xe9d 0x2300 L
‘;Z & —— 0x676: @xedcd @x2300 S
While:(3 @ == leds.led_count
S ¢ ox67a: Oxfsbd 0x0000 L
52 H // There are no LEDs on this board 5
53 | ) ox67e: @x2800 a
54 |- } 0x680: 0xd100 8
ss shile (1

3%hal antry 1 ¥

Figure 63 : Debug Menu

When clinking Go button, the following LEDs on the board should now be blinking.

RZ/T series

» RSK+RZzZ/T2M: LEDO-1 (CPUO0), LED2-3 (CPU1)
» RSK+RZzZ/T2L: LEDO-6 (including LEDX_ESC_xxx)
» RSK+RZ/T2ME: LEDO-1 (CPUO0), LED2-3 (CPU1)

RZ/N series

» RSK+RZ/N2L: LEDO-3

To suspend program execution, click Debug > Break or click on the Pause icon.

(Continued on next page)

Figure 64 IAR EWARM Debugger Pause Icon
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To exit Debug and disconnect from the debugger, click Debug > Stop Debugging or click on the Stop icon.

O

Figure 65 IAR EWARM Debugger Stop Icon

5.3.5 Debug for Multiprocessing

To debug the Blinky application of multiprocessing, follow these steps:

1. Open the primary project and close the secondary project on IAR EWARM.

2. Download of the primary project with procedure 5.3.4 Download & Debug the Project as shown in Figure 59.

3. The secondary project is automatically launched.

4. Run the program of primary project as shown in Figure 61. If the LEDO and LED1 are blinking, proceed to the next
step.

The primary project in operation, run the program of secondary project.

6. When exiting Debug and disconnect from the debugger, if debugging is stopped in one of the projects, either the
primary or the secondary, the other will automatically stop as well.

o

5.4 Re-configuring Project with FSP SC

For proceeding the tutorial with Blinky project, the FSP configuration steps of the Blinky project was skipped in this
chapter. The FSP SC can be launched from IAR EWARM or command prompt, and the FSP project configuration can
be re-configured by FSP SC.

There are two ways to launch FSP Smart Configurator with an exciting project.
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5.4.1 Launch FSP Smart Configurator from IAR EWARM
1. Select “Tools -> Configure Tools...”
2. Select “New” and fill in the fields as follows:

e  Menu Text FSP Smart Configurator
e  Command $RASC_EXE_PATH$
e  Argument --compiler 1AR configuration.xml

e Initial Directory $PROJ_DIR$

Configure Tools

Menu Content:

FSF Smart Configurator
Cancel
Mew
Delete
Menu Text:

| FSP Smart Configurator |

Cammand:
|$Fms C_EXE_PATHS | Browse. .

Argument:

|--u:0mpi|er |&F configuration, =ml |

Iritial Directary:
($PROJ_DIRS |

[T Redirect to Output Window
] Prampt for Command Line

Tool Available:

Alwansg w

Figure 66 : Settings to Launch FSP SC from IAR EWARM

5.4.2 Launch from the Command Prompt.
1. Open command prompt window.
2. Move to the folder where the created project is located.
3. Execute the following command.
e {FSP Smart Configurator installation folder} \ eclipse \ rasc.exe —compiler IAR configuration.xml

5.5 Note when debugging in different workspaces

The project created, built, and debugged in chapters 5.3.2 through 5.3.5 can be run in other workspaces. When
debugging in the other workspace, please note the following two points:

o Apply the same version of FSP package used for the project to the FSP SC.
e  The project must be clicked the Generate Project Content button and built before debugging.
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6. FSP Configuration Users Guide

6.1 What is a Project?

In e? studio, all FSP applications are organized in RZ/T2, RZ/N2 MPU projects. Setting up an RZ/T2, RZ/N2 MPU
project involves:

1. Create a Project
2. Configuring a Project

These steps are described in detail in the next two sections. When you have existing projects already, after you launch
e? studio and select a workspace, all projects previously saved in the selected workspace are loaded and displayed in the
Project Explorer window. Each project has an associated configuration file named configuration.xml, which is located
in the project’s root directory.

5 Project Explorer X = 8

]
15

» == Blinky [Debug]
i Includes
Bzt

2 rzt_gen

E src

(= Debug

(= rzt_cfg

(= scnpt

¥ Blinky Debug_Flat.launch
], configuration.xml

= rzt_cfg.txt

Figure 67 : &2 studio Project Configuration File

Double-click on the configuration.xml file to open the RZ/T2, RZ/N2 MPU Project Editor. To edit the project
configuration, make sure that the FSP Configuration perspective is selected in the upper right-hand corner of the e?
studio window. Once selected, you can use the editor to view or modify the configuration settings associated with this
project.

I-’L"{ B C/Ces | Fsp configuration |

Figure 68 : e? studio FSP Configuration Perspective

(Continued on next page)
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Note:

Whenever the RZ/T2, RZ/N2 project configuration (that is, the configuration.xml file) is saved after
configuring the project, a verbose RZ/T2, RZ/N2 Project Report file (rzt_cfg.txt, or rzn_cfg.txt) with all the
project settings is generated. The format allows differences to be easily viewed using a text comparison tool.
The generated file is located in the project root directory.

{5 Project Explorer X = B ||{} *[Blinky] FSP Configuration [ mtcigt X
0% 7 8 1 [Fsp configuration
~ - 2 Board "RSK+RZT2M (RAM execution without flash memory)"
¥ & Blinky [Debug] 3 RIAD7GO7SM24GBG &
[l Includes 4 part_number: RIAGTGE7SM24GEG
Bm 5 atcm_size_bytes: 524288
(2 rzt_gen 6 btem_size_bytes: 65536
8 sre 7 system_ram_size_bytes: 2097152
Debs 8 package_style: BGA
(& Debug 9 package pins: 32
& it cfg 10 Cortex-R52 CPU core: CPU@
& script 11 Semaphore: Enabled
%] Blinky Debug_Flatlaunch 12

1 confiqurationxml 13 RZT2M Memory Config
4 Master MPU: MPU@ : DMAC Unit@: Enable or disable read control for Reginn @: Disabled
“ Master MPU: MPU@ : DMAC Unit®: Enable or disable write control for Region : Disabled
16 Master MPU: MPU® : DMAC Unit@: ﬁegian @ Start: 0x00200080
17 Master MPU: MPU@ : DMAC Unit@: Region @ End: @xeeeeecoe

Figure 69 : RZ/T2, RZ/N2 Project Report

The RZ/T2, RZ/N2 Project Editor has several tabs. The configuration steps and options for individual tabs are discussed
in the following sections.

Note:

The tabs available in the RZ/T2, RZ/N2 Project Editor depend on the e? studio version and the layout may vary
slightly, however the functionality should be easy to follow.

454 (Blinky] FSP Configuration X = (g

Summar:
y Generate Project Content

Project Summary A
RENESAS

Board: :

Device: I

Toolchain: !

Toolchain Version: : <Project summary information>
FSP Version: 1

Project Type: :

Location: I

software s

Simple application that blinks an LED. No RTOS included
Board Support Package Common Files

Memeory Config Checking

110 Port

<Board>

Arm CMSIS Version 5 - Core

Board support package for <Device>

Board support package for RZT2M

Board support package for RZT2M - FSP Data

o|2[9)

ISumrnary BSP | Clocks | Pins | Interrupts | Event Links | Stacks Componen(sl

<Components version information>

Figure 70 : RZ/T2, RZ/N2 Project Editor Tabs
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6.2 Create a Project
6.2.1 Creating a New Project

For RZ/T2, RZ/N2 MPU applications, generate a new project using the following steps:

1. Click on File > New > C/C++ Project.
work - & studio
Edit Source Refactor Navigate Search Project RenesasViews Run Window Help
[ New Alt+Shift+N > | Renesas (/C++ Project =
Open File... [c%] Makefile Project with Existing Code
(., Open Projects from File System... I-E] C/C++ Project N -
Recent Files > ™ Project...
Figure 71 : New RZ/T2, RZ/N2 MPU Project
2. Thenclick on the Renesas RZ/T C/C++ FSP Project template for the type of project you are creating.

& New C/C++ Project (]
Templates for New C/C++ Project
All Renesas RZ/A C/C++ FSP Project
CMake =N (reste an executable or static library C/C++ FSP
Make project for Renesas RZ/A.
Renesas Debug
Renesas RZ/G C/C++ FSP Project
F==BN. (reate an executable or static library C/C++ FSP
project for Renesas RZ/G.
Renesas RZ/N C/C++ FSP Project
=W (reate an executable or static library C/C++ FSP
project for Renesas RZ/N.
i Renesas RZ/T C/C++ FSP Project
fg\ Create an executable or static library C/C++ FSP
project for Renesas RZ/T.
Renesas RZ/V C/C++ FSP Project
PE=WN (Create an executable or static library C/C++ FSP
I project for Renesas RZ/V.
'@ < Back Finish Cancel

Figure 72 : New Project Templates

(Continued on next page)
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3. Select a project name and location.

4. Click Next.

8 Renesas RZ/T C/C++ FSP Project

Renesas RZ/T C/C++ FSP Project

Project Name and Location

Project name

[Blinky

Use default location

D:¥ ¥Blinky,

You can download more Renesas packs here

®

Cancel

Figure 73 : RZ/T2, RZ/N2 MPU Project Generator (Part 1)
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6.2.2 Selecting a Board and Toolchain
In the Project Configuration window select the hardware and software environment:

1. Select the FSP version.
2. Select the Board and Device for your application.

Note:

You can select an existing RZ/T2, RZ/N2 MPU Evaluation Kit (Such as RSK) or can select Custom User
Board for any of the RZ/T2, RZ/N2 MPU devices with your own BSP definition.

When you use the RZ/T2, RZ/N2 MPU Evaluation Kit,
e  First, please set the Board to the Evaluation Kit and the boot mode which you use.

e Inthis case, please don’t change the Device which is automatically set to the device which RSK board
uses.

When you use Custom User Board,
e  First, please set the Device to your device on your board.
e Second, please set the Board to Custom User Board with the boot mode which you use.

3. The Toolchain selection defaults to GNU Arm Embedded.
e Select the Toolchain version.

4. This should default to the installed toolchain version.
e  Select the Debugger.

5. The J-Link Arm Debugger is preselected.

6. Click Next.

8 Renesas RZ/T C/C++ FSP Project a x
Renesas RZ/T C/C++ FSP Project —
Device and Tools Selection

Device Selection

FSP Version: [ <Fsp versions | [8oerd Description

Renesas Starter Kit+ for RZ/T2M CPU Board (RAM execution

Board: RSK+RZT2M (RAM execution without flashr | | ... without flash memory)

Device: ROAOTGO75M24GBG

Core: @_n i v

languages @ C OC++

Device Details
TrustZone No
Pins 320
Processor Cortex-R52

Toolchains Debugger

| «Joalchain Yersion> vI

@ <Back Next > Finish Cancel

Figure 74 : RZ/T2, RZ/N2 MPU Project Generator (Part 2)
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6.2.3 Selecting a Project Template
In the next window, select the build artifact and RTOS.

& Renesas RZ/T C/C+ + FSP Project m] X

Renesas RZ/T C/C++ FSP Project —,
Build Artifact and RTOS Selection

Build Artifact Selection RTOS Selection

®) Executable No RTOS ~
® Project builds to an executable file

() Static Library

* Project builds to a static library file

(?) < Back Einish Cancel

Figure 75 : RZ/T2, RZ/N2 MPU Project Generator (Part 3)

In the next window, select a project template from the list of available templates. By default, this screen shows the
templates that are included in your current RZ/T2, RZ/N2 MPU Pack. Once you have selected the appropriate template,
click Finish.

Note:
If you want to develop your own application, select the basic template for your board, Bare Metal — Minimal.

18 Renesas RZ/T C/C++ FSP Project [m] x

Renesas RZ/T C/C++ FSP Project .

Project Template Selection

Project Template Selection

® (-} ' Bare Metal - Blinky

Bare metal FSP project that includes BSP and will blink LEDs if available. This project will initialize clocks, pins, stacks, and
the C runtime environment.

[RenesasRZT.  .pack]

o d ' Bare Metal - Minimal
» Bare metal FSP project that includes BSP This project will initialize clocks, pins, stacks, and the C runtime envircnment.
[RenesasRZT.  .pack]

Code Generation Settings
[ Use Renesas Code Formatter

Figure 76 : RZ/T2, RZ/N2 MPU Project Generator (Part 4)
(Continued on next page)
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When the project is created, e? studio displays a summary of the current project configuration in the RZ/T2, RZ/N2
MPU Project Editor.

5% [Blinky] FSP Configuration X =a
Summar
y Generate Project Content
Project Summary A
_______________________ RENESAS

Board: !

Device:

Toolchain:

FSP Version:
Project Type:

1
' 1
1
! 1
) Lo -
Toolchain Version: | <Project summary information> !
. 1
. 1
N 1
Location: 1 !

Selected software components

Simple application that blinks an LED. No RTOS included 1 !
Board Support Package Common Files 1 :
Memory Config Checking : 1
1/0 Port | !
<Board> I <Components version information> :
Arm CMSIS Version 5 - Core H ]
Board support package for <Device> 1 :
Board support package for RZT2M : 1
Board support package for RZT2M - FSP Data 1 !

QHEO

ISummal_'z BSP| Clocks| Pins | Interrupts | Event Links| Stacks Campmnentsl

Figure 77 : RZ/T2, RZ/N2 MPU Project Editor and Available Editor Tabs

On the bottom of the RZ/T2, RZ/N2 MPU Project Editor view, you can find the tabs for configuring multiple aspects of
your project:

With the Summary tab, you can see all they key characteristics of the project: board, device, toolchain, and
more.

With the BSP tab, you can change board specific parameters from the initial project selection.

With the Clocks tab, you can configure the MPU clock settings for your project.

With the Pins tab, you can configure the electrical characteristics and functions of each port pin.

With the Interrupts tab, you can add new user events/interrupts.

With the Event Links tab, you can configure events used by the Event Link Controller.

With the Stacks tab, you can add and configure FSP modules. For each module selected in this tab, the
Properties window provides access to the configuration parameters, interrupt selections.

The Components tab provides an overview of the selected modules. Although you can also add drivers for
specific FSP releases and application sample code here, this tab is normally only used for reference.
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6.3 Configuring a Project

Each of the configurable elements in an FSP project can be edited using the appropriate tab in the RZ/T2, RZ/N2
Configuration editor window. Importantly, the initial configuration of the MPU after reset and before any user code is
executed is set by the configuration settings in the BSP tab. When you select a project template during project creation,
e? studio configures default values that are appropriate for the associated board. You can change those default values as
needed. The following sections detail the process of configuring each of the project elements for each of the associated
tabs.

6.3.1 Summary Tab

¢ [Blinky] FSP Configuration X =0
Summary :
Generate Project Content
Project Summary A
_______________________ RENESAS

Board: !

Device:

Toolchain:

FSP Version:
Project Type:

1
! 1
1
I 1
. 1
Toolchain Version: | <Project summary information> :
! 1
1
| 1
Location: I !

Solected softy

Simple application that blinks an LED. No RTOS included 1 :
Board Support Package Common Files 1 N
Memeory Config Checking : 1
10 Port 1 |
<Board> 1 <Components version information> :
Arm CMSIS Version 5 - Core : !
Board support package for <Device> 1 :
Board support package for RZT2M : |
Board support package for RZT2M - FSP Data I '

Q=0

BSP Clocks| Pins| Interrupts| Event Links| Stacks | Components

Figure 78 : Configuration Summary Tab

The Summary tab, seen in the above figure, identifies all the key elements and components of a project. It shows the
target board, the device, toolchain and FSP version. Additionally, it provides a list of all the selected software
components and modules used by the project. This is a more convenient summary view when compared to the
Components tab.
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6.3.2 Configuring the BSP

The BSP tab shows the currently selected board (if any) and device. The Properties view is located in the lower left of
the Project Configurations view as shown below.

Note:
If the Properties view is not visible, click Window > Show View > Properties in the top menu bar.

{5F [Blinky] FSP Configuration X = 8
Board Support Package Configuration o
PP 9 9 Generate Project Content
IS
B3 Restore Defaults
Device Selection
Board Detail
FSP version: | <FSP Version> ~ oar e
Renesas Starter Kit+ for RZ/T2M CPU Board (RAM execution
Board: RSK+RZT2M (RAM execution without flash memory) v | | |23 without flash memory)
Device: RIAO7GO7SM24GBG
Core: CR52.0 -
RTOS: No RTOS
v
Summary Clocks | Pins| Interrupts| Event Links | Stacks| Components
1 Properties X |[f] Problems| @ Smart Browser %k 3 =g
RSK+RZT2M (RAM execution without flash memory)
Settings  Property Value A
v RIA07GOTSM24GBG
part_number R9A07G075M24GBG
atcm_size_bytes 524288
btcm _size_bytes 65536
system_ram_size_bytes 2097152
package_style BGA
package_pins 320
Cortex-R52 CPU core CPUo
Semaphore Enabled v

Figure 79 : Configuration BSP Tab

The Properties view shows the configurable options available for the BSP. These can be changed as required. The BSP
is the FSP layer above the MPU hardware. e? studio checks the entry fields to flag invalid entries. For example, only
valid numeric values can be entered for the stack size.

When you click the Generate Project Content button, the BSP configuration contents are written to:
o rzt_cfg/fsp_cfg/bsp/bsp_cfg.h, or
o rzn_cfg/fsp_cfg/bsp/bsp_cfg.h

This file is created if it does not already exist.

Warning:
Do not edit this file as it is overwritten whenever the Generate Project Content button is clicked.
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6.3.3 Configuring Clocks

The Clocks tab presents a graphical view of the MPU’s clock tree, allowing the various clock dividers and sources to be

modified.

%% {[Blinky] FSP Configuration; X

Clocks Configuration

Main Clock: 25MHz PLLO 2400MHz

ICLK 200MHz

L CLMAQ Enabled

CLMA3 Enabled

PLL1 is initial state v

!

PLL1 1000MHz —> CLMA1 Enabled

Ethernet Clock src: PLL v

ETHn_REFCLK 25MHz

LOCO Enabled v —> LOCO 240kHz —> CLMA2 Enabled
CLMAOCMPL 1
CLMA1CMPL 1
CLMA2 CMPL 1

CLMA3 CMPL 1

Summary | BSP Pins| Interrupts | Event Links | Stacks Components

~ —> CLMAQ error not mask v
v I Alternative clock: LOC v
CLMAS3 error not mask v

~ —> CLMA1 error mask v

CLMAO CMPH 1.023k
CLMA1 CMPH 1.023k
CLMA2 CMPH 1.023k

CLMA3 CMPH 1.023k

MR

[> PCLKCAN 40MHz v

[> XSPI_CLKO 125MHz v

[> XSPI_CLK1 125MHz v

[ TCLK 100MHz

[> SCIQASYNCCLK: 96MH v

[> SCIHASYNCCLK: 96MH v

[> SCI2ASYNCCLK: 96MH v

[> SCI3ASYNCCLK: 96MH v

[> SCI4ASYNCCLK: 96MH v

[ SCISASYNCCLK: 96MH v

[> SPIOASYNCCLK: 96MH v

[> SPIASYNCCLK: 96MH v

[> SPI2ASYNCCLK: 96MH v

> SPIZASYNCCLK: 96MH v

S s

Generate Project Content

B3 Restore Defaults

—> PCLKGPTL 400MHz

> PCLKH 200MHz

> PCLKM 100MHz

> PCLKL S0MHz

[> PCLKADC 25MHz

> CPUOCLK Mul x1 i
CPUOCLK ZOiMHz

> CPUICLK Mul x1 v

CPU1CLK 200MHz

~> CKIO Div /4 v

CKIO 50MHz

Figure 80 : Configuration Clocks Tab

When you click the Generate Project Content button, the clock configuration contents are written to:

e rzt_gen/bsp_clock cfg.h, or
e rzn_gen/bsp_clock cfg.h
This file will be created if it does not already exist.

Warning:

Do not edit this file as it is overwritten whenever the Generate Project Content button is clicked.
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6.3.4 Configuring Pins

The Pins tab provides flexible configuration of the MPU’s pins. As many pins are able to provide multiple functions,
they can be configured on a peripheral basis. For example, selecting a serial channel via the SCI peripheral offers
multiple options for the location of the receive and transmit pins for that module and channel. Once a pin is configured,
it is shown as green in the Package view.

Note:

If the Package view window is not open in e? studio, select Window > Show View > Pin Configurator >
Package from the top menu bar to open it.

The Pins tab simplifies the configuration of large packages with highly multiplexed pins by highlighting errors and
presenting the options for each pin or for each peripheral. If you selected a project template for a specific board such as
RSK+RZT2M, some peripherals connected on the board are preselected.

(& “[Blinky] FSP Configuration X | =8

Pin Configuration e
g Generate Project Content

Select Pin Configuration [y Export to CSVfile  [£=] Configure Pin Driver Wamings
[ RSK+RZT2M q Mar ations... Generate data: |g_bsp_pin_cfg
Pin Selection i= @ [= % Pin Configuration ~J Cycle Pin Group
[Type fitertext Name Value Lock  Link
o = Pin Group Selection Mixed

v v Peripheraié Operation Mode Asynchronous mode
v Connectivity:CANFD v Input/Output
Connectivity:ETHER_ESC CTso® v P16.2 frui | = |
v Connectivity:ETHER_ETH CTS_RTS0# None
v Connectivity:ETHER_ETHSW DE0 None
Connectivity:ETHER_GMAC RxDo v P16.6 i >
v Connectivity:IIC s o
v v Connectivity:SCI
v scio
SCi
sci2
v SQ3
scu
Sqs
Connectivity:SPI
v Connectivity:USB_HS
v Connectivity:XSPI
Debug:TAG/SWD
v Debug:TRACE
Delta sigmalF:DSMIF
EncoderlFENCIF
ExBus:BSC
Interrupt:IRQ
v SystemiCGC
v System:SYSTEM
TRGADC v

[EinFenction]pin Number

Summary | BSP | Clocks[[Pins ] Interrupts | Event Links| Stacks| Components

TXDO v P16.5 Iy >

<

Module name:  SClo
Usage: In initial register value, when CCRO.TE bit is 0, and the terminal function is TXDn, the terminal outputs high impedance.

Figure 81: Pin Configuration

(Continued on next page)

RO1AN6434EJ0111 Rev.1.11 Page 64 of 120
Jun.28.24 RENESAS




RZ/T2, RZIN2 Getting Started with Flexible Software Package

The pin configurator includes a built-in conflict checker, so if the same pin is allocated to another peripheral or I/O
function the pin will be shown as red in the package view and also with white cross in a red square in the Pin

Selection pane and Pin Configuration pane in the main Pins tab. The Pin Conflicts view provides a list of conflicts, so
conflicts can be quickly identified and fixed.

In the example shown below, port P162 is already used by the GP10, and the attempt to connect this port to the Serial
Communications Interface (SCI) results in a dangling connection error. To fix this error, select another port from the
pin drop-down list or disable the GPIO in the Pin Selection pane on the left side of the tab.

5% *[Blinky] FSP Configuration X = 8

Pin Configuration
e Generate Project Content

Select Pin Configuration [ Export to CSVfile [ Configure Pin Driver Wamnings
[Rsk+RZT2M v| Manage configuratior A Generate data: |g_bsp_pin_cfg
Pin Selection = [ = 13  PinConfiguration ~3 Cycle Pin Group
‘va,:v«,r. text Name Value Lock  Link
T = Pin Group Selection Mixed
S e Operation Mode Asynchronous mode
P P7673 v Input/Output
Pweia CTS0# @ P2
 PiE s CTs_RTS0# None
Y DE0 None
v P66
i RXDO v P166 | =
v P17 - Nane
v P18 A
v P19 = -
4 oos TXDO v P65 i =3
v P21
v P2
v P23
v P24
v Other Pins
v @ Peripherals
v Connectivity:CANFD
Connectivity:ETHER_ESC
v Connectivity:ETHER_ETH
¥ Connectivity:ETHER_ETHSW

v Connectivity:ETHER_ GMAC

v ConnectivityliC
v @ Connectivity:SCl Usage: In initial register value, when CCRO.TE bit is 0, and the terminal function is TXDn, the terminal outputs high impedance.

@ sco
sci
SCI2 2

Pin Number

Summary | BSP Clo:kslnterrup!s Event Links| Stacks| Components

Module name:  SCI0

Figure 82: Conflict Checker in Pin Configuration

(Continued on next page)
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The pin configurator also shows a package view and the selected electrical or functional characteristics of each pin.

% FSP Visualization X

- - .
7 7

=]

»

D ® i
\
X
2
]
(<)
g
D DD

PDOODD '’

e B - o e

» legend

Figure 83: Pin Configurator Package View

When you click the Generate Project Content button, the pin configuration contents are written to:

e rzt_gen\bsp_pin_cfg.h, or
e rzn_gen\bsp_pin_cfg.h
This file will be created if it does not already exist.

Warning:

Do not edit this file as it is overwritten whenever the Generate Project Content button is clicked.
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6.4 Configuring Interrupts from the Stacks Tab

You can use the Properties view in the Stacks tab to enable interrupts by setting the interrupt priority. Select the driver
in the Stacks pane to view and edit its properties.

5% *[Blinky] FSP Configuration X | £ rzt_cfg.txt

Stacks Configuration

Threads %) New Th . ve B

v % HAL/Common
49 g_ioport I/0 Port (r_ioport)

HAL/Common Stacks

=]
Generate Project Content

&) New Stack > =% Extend Stack > 3| Remove

47 g_ioport /0 Port

42 Memory config check

48 Memory config check (rioport)
P g_timer0 Timer, Compare Match W (r_cmtw) @ @
Objects &) New Object > 1) Ren
Summary | BSP | Clocks | Pins | Interrupts | Event LinkComponenu'
[ Properties X (! Problems| @ Smart Browser 2EY ¥ &Y ¥ E|Y ¥ § = 0O
g_timer0 Timer, Compare Match W (r_cmtw)
Settings  Property Value
v Common
Parameter Checking Default (BSP)
Multiplex Interrupt Disabled
v Module g_timer0 Timer, Compare Match W (r_cmtw)
General
Output
> Input
v Interrupts
Callback NULL
Compare Match Interrupt Priority Priority 11
Input Capture 0 Interrupt Priority Disabled
Input Capture 1 Interrupt Priority Disabled
Output Compare 0 Interrupt Priority Disabled
Output Compare 1 Interrupt Priority Disabled

v Pins
CMTWo_TICO
CMTWO_TIC1

<unavailable>
<unavailable>

Figure 84 : Configuring Interrupts in the Stacks Tab
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6.4.1 Creating Interrupts from the Interrupts Tab

On the Interrupts tab, the interrupt of the driver selected in the Stacks tab is registered.

{3} *[Blinky] FSP Configuration X | 5| rzt_cfg.txt

Interrupts Configuration

Generate Project Content

= 8

User Events &) New User Event > 5
Event ISR
Allocations
Interrupt Event ISR
B CMTWO_CMWI (CMTW0 Compare match) cmtw_cm_int_isr |

Summary | BSP | Clocks | Pins| Event Links | Stacks | Components

Figure 85 : Configuring Interrupt in Interrupt Tab

And the user can add a peripheral interrupt created by the user’s own. This can be done by adding a new event via the

New User Event button.
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6.4.2 Viewing Event Links

The Event Links tab can be used to view the Event Link Controller events. The events are sorted by peripheral to make

it easy to find and verify them.

i *[Blinky] FSP Configuration X | (2 rzt_cig.txt

Event Links Configuration

= B8

Generate Project Content

User Events Produced %| New User Event >| 5] User Events Consumed %] New User Event s
Event Peripheral Function Evel

I ADCO_ADI (ADCO A/D scan end interrupt) Single port 0 ADCO_ADI (ADCO A/D scan end interrupt)

Allocations /

Peripheral Function

Input port group 1 (Port 16)

Event

No ation
o allocation

Input port group 2 (Port 18)
Single port 0

ADCO_ADI (ADCO A/D scan end interrupt)

Single port 1
Single port 2

No allocation
No allocation

Summary | BSP | Clocks | Pins Interrupts Stacks | Components

Figure 86 : Viewing Event Links

Like the Interrupts tab, user-defined event sources and destinations (producers and consumers) can be defined by
clicking the relevant New User Event button. Once a consumer is linked to a producer the link will appear in the

Allocations section at the bottom.

Note:

When selecting an ELC event to receive for a module (or when manually defining an event link), only the
events that are made available by the modules configured in the project will be shown.
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6.5 Adding and Configuring HAL Drivers

For applications that run outside or without the RTOS, you can add additional HAL drivers to your application using
the HAL/Common thread. To add drivers, follow these steps:

1.  Click on the HAL/Common icon in the Stacks pane. The Modules pane changes to HAL/Common Stacks.
2. Click New Stack to see a drop-down list of HAL level drivers available in the FSP.
3. Select a driver from the menu New Stack > Driver.

{8 “[Blinky) FSP Configuration X = O || Outiine x =0
Stacks Configuration 0 There is no active editor that provides an outline
Generate Project Cantent
Threads 5 HAL/Comman Stacks Io Mew Stack )
= Analog |
~ m! HAL/Common — — - Connectivity 3
4 g_ioport 110 Port (r_iopart) & g ioport /O Port 4 Memory config check g_timer{ Timer, ;
g (r_iopart) put e
48 Memory config check )
4 g_timer0 Timer, Compare Match W (r_critwe) ® ® Monitoring
Networking
RTOS >
Storag >
System »
>

Port Output Enable 3 for MTUS (r_poes)
Port Output Enable for GPT (r_poeg)
Realtime Clock (r_rtc)

Thies WM {
Thre

Objects

Timer, Compare Match Ti
Timer, Compare Match W (r_cmtw]
Timer, General PWM (r_gpt)

X

Summary | BSP | Clocks |Pins [ Interrupts | Event Links | Stacks| Components

Figure 87 : e? studio Project Configurator — Adding Drivers

4.  Select the driver module in the HAL/Common Modules pane and configure the driver properties in the
Properties view.

e? studio adds the following files when you click the Generate Project Content button:

e The selected driver module and its files to the rzt/fsp or rzn/fsp directory
e The main() function and configuration structures and header files for your application as shown in the table

below.
Table 5 Generate Contents on Smart Configurator
File Contents Overwritten by Generate
Project Content?
rzt_gen/main.c or Contains main() calling generated Yes
rzn_gen/main.c and user code. When called, the BSP
B already has Initialized the MPU.
rzt_gen/hal_data.c or Configuration structures for HAL Yes
rzn_gen/had_data.c Driver only modules.
rzt_gen/hal_data.h or Header file for HAL driver only Yes
rzn_gen/hal_data.h modules.
src/hal_entry.c User entry point for HAL Driver No
only code. Add your code here.

The configuration header files for all included modules are created or overwritten in this folder:
e rzt_cfg/fsp_cfg or
o rzn_cfg/fsp_cfg
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6.6 Reviewing and Adding Components

The Components tab enables the individual modules required by the application to be included or excluded. Modules
common to all RZ MPU projects are preselected. All modules that are necessary for the modules selected in the Stacks
tab are included automatically. You can include or exclude additional modules by ticking the box next to the required

component.

4 *[Blinky] FSP Configuration X | [2] rzt cfg.txt

Ci Confi

[ g

= B oo

Component
v o Arm
v @ CMSIS
v @ CMsISs
V] Core
S, AWS
v &% Renesas
v % BSP
v @ all
v] Memory
v @ Board
| rzt2l_rsk
rzt2]_rsk
| rzt2l_rsk
] rzt2m_custom
] rzt2m_custom
rzt2m_custom
rzt2m_custom
rzt2m_custom
| rzt2m_custom
V| rztam_rsk
] rzt2m_rsk
rzt2m_rsk
@ 2l
v ¢ rzt2m
V] device
[¥] device
device

e, 2.00.
Summary | BSP | Clocks | Pins | Interrupts | Event Links Stacks

Version

5.7.0+renesas.2.fsp.2..

2.0.0

200
200
200

Group by: | Vendor v Filter: | Al

Description

Arm CMSIS Version 5 - Core

Memory Config Checking

RSK+RZT2L Board Support Files (xSPI0 x1 boot mode)

RSK+RZT2L Board Support Files (xSPI1 x1 boot mode)

RSK+RZT2L Board Support Files (RAM execution without flash memory)

RZT Custom Board Support Files (xSPI0 x1 boot mode)

RZT Custom Board Support Files (xSPI0 x8 boot mode)

RZT Custom Board Support Files (xSPI1 x1 boot mode)

RZT Custom Board Support Files (16-bit bus NOR flash boot mode)

RZT Custom Board Support Files (32-bit bus NOR flash boot mode)

RZT Custom Board Support Files (RAM execution without flash memory)
RSK+RZT2M Board Support Files (RAM execution without flash memory)
RSK+RZT2M Board Support Files (xSPI0 x1 boot mode)

RSK+RZT2M Board Support Files (16-bit bus NOR flash boot mode)

Board support package for RIAG7GO7SM24GBG
Board support package for RZT2M
Board support package for ROA07GO7SM28GBG

Danrd cuunnarn aackans far DOANTEOTEMAICCRE

]

Generate Project Content

Variant A

xspi0_x1_boot
xspi1_x1_boot
ram_execution
xspi0_x1_boot
xspi0_x8_boot
xspi1_x1_boot
16bit_nor_boot
32bit_nor_boot
ram_execution
ram_execution
xspi0_x1_boot
16bit_nor_boot

R9A07G075M24GBG

R9A07G075M28GBG

v
ROANTCEATEMIZCREA

Figure 88 : Components Tab

Clicking the Generate Project Content button copies the .c and .h files for each selected component into the following

folders:

e rzt/fsp/inc/api

e rzt/fsp/inc/instances

o rzt/fsp/src/bsp

e rzt/fsp/src/<Driver_Name>
or

e rzn/fsp/inc/api

e rzn/fsp/inc/instances

e rzn/fsp/src/bsp

e rzn/fsp/src/<Driver_Name>

e? studio also creates configuration files in the following folder with configuration options set in the Stacks tab.

e rzt_cfg/fsp_cfg
o rzn_cfg/fsp_cfg
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Appendix. Known Issues

This chapter describes the known issues regarding the current version of FSP and related platform software.

Most of the issues may require users to follow some manual operations to resolve the issues or to avoid the problems
caused by the issues. Please follow the operations in the description of the issues if you use the features related to the
issues. The grayed-out items have been resolved.

The known issues are categorized into two main groups, FSP Configuration and FSP Modules.
o  FSP Configuration
e? studio and FSP SC have various configuration features worked on GUI with FSP.

Regarding the overview of each configuration feature (GUI tab) provided as a part of FSP configuration in e?
studio and FSP SC, please see the chapter 6. “FSP Configuration Users Guide”.

o  FSP Modules
The FSP provides HAL drivers and BSP configured by FSP Configuration on e? studio and FSP SC.
Regarding their features, usage notes and API references, please see the related file “FSP Documentation”.

Table 6 List of Known Issues

No. | Title Target Device Category
T2M | T2L | T2ME | N2L
1 “r_gmac” may be showed as “r_ether” incorrectly. v v | FSP
Configuration,
Stacks
2 “Edge” can be selected as Transfer End Interrupt Detect v v v | FSP
Type in “r_dmac”, but it cannot be used. Configuration,
Stacks
3 When the “Device” or “Board” selection in BSP tab is v v v v FSP
changed, the BSP properties are sometimes configured to Configuration,
incorrect configuration. BSP
4 (FSP SC ONLY) Device name is not output correctly v v FSP
depending on the selected device. Configuration,
BSP
5 Errors occur when changing board settings. v v | FSP
Configuration,
BSP
6 Pin configuration error occurs in MPX-10 16bit operating v v v/ | FSP
mode of “r_bsc”. Configuration,
Pins
7 Build error when using definition name of input/output v v v | FSP
external pins for module. Configuration,
Pins
8 “R_SCI UART BaudCalculate()” of “r_sci_uart” module v v v | FSP Modules,
properly works ONLY when its clock source is SCI UART
SCINASYNCCLK and its frequency is 96MHz.
9 “R_SPI CalculateBitrate()” of “r_spi” module properly v v v | FSP Modules,
works ONLY when its clock source is SPINASYNCCLK SPI
and its frequency is 96MHz.
10 | A warning occurs when building “r_gmac” module with v v FSP Modules,
the gcc compiler. Ethernet
11 | In FSP Documentation, there is incorrect description in. v v | FSP Modules,
“API Reference > Modules > Ethernet PHY” page. Ethernet PHY
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No. | Title Target Device Category
T2M | T2L | T2ME | N2L
12 | The interrupt number cannot be successfully acquired by v | FSP Modules,
the R_FSP_CurrentlrqGet() when multiple interrupt FreeRTOS
occurs.
13 | Block Media Custom Implementation can be selected as v v v v | FSP
Memory Implementation for “rm_freertos_plus_fat” Configuration,
module, but it cannot be used. Stacks
14 | The second argument of “r_mtu3” APIs do not match with v v v v | FSP Modules,
common API. MTU3
15 | In multiprocessing, a configuration error occurs when v v FSP
“r_gpt” module is used for both projects for CPUO and Configuration,
CPUL1. Stacks
16 | Project build error occur when 32-bit bus NOR flash and v FSP
xSPI0 x8 boot modes are selected on RZT Custom User Configuration,
Board. BSP
17 | The secondary project for multiprocessing cannot be v FSP
created when xSPI1 x1 boot modes are selected on RZT Configuration,
Custom User Board. BSP
18 | Anincorrect value is set to a pin select value for MTUO- v FSP Modules,
B/MTU6/MTU7 as MTU3 output pin. POE3
19 | Build error when using DSMIFn_ERR as an additional v FSP Modules,
trigger for “r_poe3” module. POE3
20 | Control setting values for MTU3 output pins in Stacks tab v v v FSP
of FSP Configuration are set to the incorrect pin. Configuration,
Stacks
21 | A bug that prevented the setup of PLL1. v | FSP
Configuration,
Clocks
22 | A section cannot be copied successfully when its size is v | FSP Modules,
not a multiple of the alignment size. BSP
23 | Initial values of data placed in some sections were v | FSP Modules,
overwritten with 0. BSP
24 | Some sections were not initialized in the flash boot v | FSP Modules,
project. BSP
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No.1 Resolved
Title “r_gmac” may be showed as “r_ether” incorrectly.
Target RZ/T2M, RZ/N2L
Category FSP Configuration, Stacks
Description In Stacks tab, “r _gmac” may be showed as “r_ether” incorrectly.
Workaround | Please read the “r_ether” as “r_gmac”.
No.2 Resolved
Title “Edge” can be selected as Transfer End Interrupt Detect Type in “r_dmac”, but it cannot be
used.
Target RZ/T2M, RZ/T2L, RZ/N2L
Category FSP Configuration, Stacks
Description “Edge” of interrupt detect type is not available due to a change in hardware specifications.
Workaround | Please don’t set Edge to Transfer End Interrupt Detect Type
No. 3
Title When the “Device” or “Board” selection in BSP tab is changed, the BSP properties are
sometimes configured to incorrect configuration.
Target RZ/T2M, RZ/T2L, RZ/IT2ME, RZ/N2L
Category FSP Configuration, BSP
Description When the “Device” or “Board” selection in BSP tab is changed, the BSP properties are sometimes
configured for incorrect configuration. Once this issue occurs, the project cannot be fixed to correct
configuration.
Workaround | If changing the “Device” or “Board”, please reselect “FSP Version” from the drop-down list.
If you want to change only the boot mode on the same board, please refer to
Appendix. How to Change Boot Mode of FSP Project

(Continued on next page)
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No. 4

Title (FSP SC ONLY) Device name is not output correctly depending on the selected device.

Target RZ/T2M, RZ/T2ME

Category FSP Configuration, BSP

Description If you create a project by selecting a single core device (ROA07G075M0O1xxX,
RIA07G075M05xxx), the device setting will be “None” when you open the project in IAR
EWARM.

Workaround | Please reselect device name from the device list in IAR EWARM project options.

Options > General Options > Target > Processor variant > Device

Options for node "Blinky" X

Category:
[coeaconrs 8
Static Analysis

Runtime Checking
Library Options 2

C/C++ Compiler
Assembler
Output Converter
Custom Buid
Build Actions
Linker
Debugger

Simulator

CADI

CMSIS DAP

GDB Server

Library Configuration Library Options 1

64-bit

Processor variant

O Core ARM7TDM

Output

None

I @ Device

]

O CMsIS-Pack

Execution mode

Ijet
Jdink/)-Trace

TI Stellaris
Nu-Link

PE micro

STLINK
Third-Party Driver

0K Cancel

(Continued on next page)
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No.5 Deleted due to one of the issues with Known Issues No. 3

Title

Errors occur when changing board settings.

Target

RZ/T2L, RZ/N2L

Category

FSP Configuration, BSP

Description

Errors occur when changing board settings from RSK+RZN2L (RAM execution without flash
memory) to RZN2L Custom User Board (RAM execution without flash memory) and from
RSK+RZN2L (RAM execution without flash memory) to RZN2L Custom User Board (xSPI0 x1
boot mode).

1. Changed from RSK+RZN2L (RAM execution without flash memory) to RZN2L Custom User
Board (RAM execution without flash memory)

In this case, the build is successful. But the following screen is displayed after the build.

[T Properties |/ Problems | @ Smart Browser | B Console | [ Memory Usage
CDT Build Console [rzn2|_minimal]
Building file: ../rzn/fsp/src/r_loport/r_ioport.c
Building file: ../rzn/fsp/src/bsp/meu/rzn2lfbsp_cache.c
Building file: ../rzn_gen/pin_data.c
../rzn_gen/vector_data.c
../rzn/fsp/src/r_ioport/r_ioport.c
../rzn/fsp/src/bsp/meufrzn2l/bsp_cache.c
../rzn_gen/pin_data.c
Building file: ../rzn/fsp/src/bsp/mcu/rzn2l/bsp loader param.c
Building file: ../rzn/fsp/src/bsp/mcu/all/bsp_clocks.c
../rzn/fsp/src/bsp/mcufrzn2l/bsp_loader_param.c
Building file: ../rzn/fsp/src/bsp/mcu/all/bsp_common.c ) Problem Occurred - o X
../rzn/fsp/src/bsp/mcu/all/bsp_clocks.c
Building file: ../rzn/fsp/src/bsp/mcu/all/bsp_delay.c = 0 )
. ‘/rzm’%sp/Sr‘(/bsp/m(u/aﬁl/hsp_(gmmun.( P .Q\ R BT o ErE I @ Tl
../rzn/Fsp/src/bsp/mcu/all/bsp_delay.c :
Building file: ../rzn/fsp/src/bsp/meu/all/bsp_io.c
Building file: ../rzn/fsp/src/bsp/mcufall/bsp_irg.c
../rzn/fsp/src/bsp/meu/all/bsp_io.c oK
Building file: ../rzn/fsp/src/bsp/mcufall/bsp_register_protection.c
../rzn/fsp/src/bsp/meu/all/bsp_irg.c
Building file: ../rzn/fsp/src/bsp/mcu/all/bsp_reset.c Errors occurred during the build.
../rzn/fsp/src/bsp/mcusall/bsp_register_protection.c Errors running builder 'COT Builder' on project
../rzn/fsp/src/bsp/mcu/all/bsp_reset.c ‘rzn2| minimal'
Building file: ../rzn/fsp/src/bsp/mcu/all/bsp_sbrk.c Resource /rzn2|_minimal/Debug/rn/board/rn2l_rsk'
Building file: ../rzn/fsp/src/bsp/cmsis/Device/RENESAS/Source/startup.c does not exist.
../rzn/Fsp/src/bsp/mcu/all/bsp_sbrk.c Resource '/rzn2l_minimal/Debug/rzn/board/rzn2l_rsk’
Building file: ../rzn/fsp/src/bsp/cmsis/Device/RENESAS/Source/system.c does not exist.
../rzn/fsp/src/bsp/emsis/Device/RENESAS/Source/startup.c Resource /rzn2l_minimal/Debug/rzn/board/rzn2l_rsk'
../rzn/fsp/src/bsp/cmsis/Device/RENESAS/Source/system. does not exist,
Building target: rzn2l_minimal.elf Resource '/rzn2|_minimal/Debug/rzn/board/rzn2_rsk'
arm-none-eabi-objcopy -0 srec "rzn2l_minimal.elf" "rzn2l_minimal.srec" does not exist.
arm-none-eabi-size --format=berkeley "rzn2zl_minimal.elf"

text  data bss dec hex filename

49608 ] 15672 20032 4248 rzn2l_minimal.elf

Errars occurred during the build.

13:18:17 Build Finished. @ errors, @ warnings. (took 7s.316ms)

2. Changed from RSK+RZN2L (RAM execution without flash memory) to RZN2L Custom User
Board (xSPI0 x1 boot mode)

bsp_mcu_device_pn_cfg.h is not generated and builds error occurs.

[T Properties [ Problems X | @ Smart Browser| B Console
6 errors, 12 warnings, 227 others (Filter matched 124 of 251 items)
Description - Resource Path Location Trpe
~ @ Errors (6 items)
@ fatal error: bsp_mecu_device_pn_cfg.h: No such file or directory bsp_meu_family_cfg.h frzn2_minimalfrzn... line4 C/Cs+ Probl...
@ make: *** [1zn_gen/subdir.mlc42: rzn_gen/common_data.o] Error 1 rzn2l_minimal C/C+ Probl...
@ make: ™ [1zn_gen/subdir.mke42: rzn_gen/hal_data.o] Error 1 rzn2l_minimal €/C++ Probl...
1zn_gen/subdir.mc42: rzn_gen/main.o] Error 1 rzn2l_minimal C/Ces Probl...
stcfsubdir.mkc26: src/hal_entry.o] Error 1 rzn2l_minimal C/C++ Probl...
@ make: ~** Waiting for unfinished jobs.... rzn2l_minimal C/C++ Probl...

Workaround

Please create a new project to change the board setting to RZN2L Custom User Board.

(Continued on next page)
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No. 6

Resolved

Title

Pin configuration error occurs in MPX-10 16bit operating mode of “r_bsc”.

Target

Rz/T2M, RZ/T2L, RZ/N2L

Category

FSP Configuration, Pins

Description

Pin assignment is an optional specification in MPX-1O 16bit operation mode of “r_bsc”, but an

error will occur if Input/Output A1-A13 is not set.

Pin Configuration

Select Pin Configuration

o
Generate Project Content

I Export to CSV file = Configure Pin Driver Warnings

[RSK+RZN2L

v | Manage configurations..

Pin Selection

|bsc

X

v ¥ Ports
v v Other Pins
v BSCANP
v @ Peripherals
v © ExBus:BSC
@ BSC

Pin Function| Pin Number

EE 8% pin Configuration

Generate data: |g_bsp_pin_cfg

3 Cycle Pin Group

Name
Pin Group Selection
Operation Mode
Vv Input/Output
A0
A1
A2
A3
Ad

<

Value Lock Link A
Mixed

@ MPX-10 16bit

None
®* None
@ * None
v P05_1
@ * None

Module name: BSC

Summary |BSP|Clocks @ Pins| Interrupts Event Links| Stacks Components

Workaround

Please set “Custom” to “Operation Mode” of “r_bsc” in Pins tab when you use MPX-10 16bit

operation mode of “r_bsc”.

(Continued on next page)
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No.7 Resolved

Title

Build error when using definition name of input/output external pins for module.

Target

RZ/T2M, RZ/T2L, RZ/N2L

Category

FSP Configuration, Pins

Description

After code generation, the definition of input/output external pins for the module is generated in
fsp_cfg/bsp/bsp_pin_cfg.h, but the defined values are not defined in FSP. When using the defined
name in a user application, a build error occurs.

{h] bsp_pin_cfg.h X | Ll hal_entry.c lh| bsp_io.h

e e

— ——er =7
#define ETHO_TXCLK (IOPORT_PORT_@9_PIN_7)

) #define ETH@ TXEN (IOPORT PORT 1@ PIN ©
B
52 #define ETHO_RXD1 (IOPORT_PORT_10_PIN_2)
#define ETHO_RXD2 (IOPORT_PORT_1@_PIN_3)

\h| bsp_pin_cfg.h L€ hal_entry.c X | |h] bsp_io.h

2 49 uintl6_t tmp = ETHO_RXDO;

=) Properties | .. Problems & Console X | 4 Search b ‘ v vIE | H a8
CDT Build Console [rzt2m_ether_test]
../src/hal_entry.c: In function 'hal_entry':
D:\ws\rz\t2120\rzt2m_ether_test\rzt_cfg\fsp_cfg\bsp/bsp_pin_cfg.h:51:20: [uelariie el el i)y e (N0 (IS VT (T T | (
51 | #define ETHG_RXD@ (IOPORT_PORT_1@_PIN_1)
~~~~~~~~~~~~~~~~~~~~

Workaround

Please add definition to read IOPORT_PORT_mm_PIN_n as BSP_IO_PORT_mm_PIN_n in
hal_entry. Do NOT edit file fsp_cfg/bsp/bsp_pin_cfg.h because its contents will be overwritten.

An example of a setting:
When using ETHO_RXDO (IOPORT_PORT 10 PIN_1), add definition of #define
IOPORT_PORT 10 PIN_1 (BSP_IO_PORT 10 _PIN_1) in hal_entry.c.

h| bsp_pin_cfg.h 2] hal entrec X | W bsp inkh

+ 4 D d HEnes
ginclude “hal_data.h”

| LE LS LT OPORT PORT 18 PIH 1 (BSP I0 PORT 18 FIN 1)

void BR_B5P WarmStart(bsp warm_start_ewvent_t event) BSP_PLACE IN_SECTION(™.warm_start™);

No.8 Resolved

Issue “R_SCI_UART_BaudCalculate()” of “r_sci_uart” module properly works ONLY when its
clock source is SCINASYNCCLK and its frequency is 96MHz.

Target RZ/T2M, RZ/T2L, RZ/N2L

Category FSP Modules, Serial Communication Interface (SCI) UART

Description The “R_SCI UART BaudCalculate()” of “r_sci_uart” module works ONLY when its clock source
is “SCInASYNCCLK?” and its frequency is “96MHz”; therefore, when the module uses “PCLKM”
as its clock source or the frequency is not 96MHz, the API function will be not work properly.

Workaround | The clock source and frequency are limited in Clocks and Stacks tab; therefore, you can NOT use

the PCLKM clock and can NOT change the clock frequency.

(Continued on next page)
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No.9 Resolved

Issue “R_SPI_CalculateBitrate()” of “r_spi” module properly works ONLY when its clock source
is SPINASYNCCLK and its frequency is 96MHz.

Target RZ/T2M, RZ/T2L, RZ/N2L

Category FSP Modules, Serial Peripheral Interface

Description The “R_SPI BaudCalculate()” of “r_spi” module works ONLY when its clock source is
“SPInASYNCCLK?” and its frequency is “96MHz”; therefore, when the module uses “PCLKM” as
its clock source or the frequency is not 96MHz, the API function will be not work properly.

Workaround | The clock source and frequency are limited in Clocks and Stacks tab; therefore, you can NOT use
the PCLKM clock and can NOT change the clock frequency.

No. 10 Resolved

Issue A warning occurs when building “r_gmac” module with the gcc compiler.

Target RZ/T2M, RZ/T2L

Category FSP Modules, Ethernet

Description The following warning occurs when building “r_gmac” module with the gcc compiler.
../rzt/fsp/src/r_gmac/r_gmac.c:2173:14: warning: the comparison will always evaluate as 'false' for
the pointer operand in 'pp_phy_instance + (sizetype)(port * 12)' must not be NULL [-Waddress]
2173 | if (NULL == pp_phy_instance[port])

| i
Workaround | Please ignore this warning.

No. 11 Resolved

Issue In FSP Documentation, there is incorrect description in. “API Reference > Modules >
Ethernet PHY” page.

Target RZ/T2M, RZ/N2L

Category FSP Modules, Ethernet PHY

Description In the “API Reference > Modules > Ethernet PHY” page in FSP Documentation, the default
column description of “Select PHY's to use” configuration is incorrect.

Workaround | When reading the incorrect description, please replace the reading of it with follows.

[Error]

>  config.driver.ether_phy.phy_lsi.default,config.driver.ether_phy.phy_lIsi.0,config.driver.ether_
phy.phy_lIsi.1,config.driver.ether_phy.phy_lIsi.2,config.driver.ether_phy.phy_Isi.3,config.drive
r.ether_phy.phy_lsi.

[Correction]
»  All check boxes are enabled.

(Continued on next page)
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No. 12 Resolved

Target File: port.c
void vApplicationIRQHandler (uint32_t ulICCIAR)

#if 0
/* Re-enable interrupts. */
__asm(“cpsie i”);

#endif

bsp_common_interrupt_handler(ulICCIAR);

Target File: bsp_irg.c
void bsp_common_interrupt_handler (uint32_t id)

{
uintlé_t gic_intid;

/* Get interruot ID (GIC INTID). */
gic_intid = (uintl6_t) (id & BSP_PRV_ID_MASK);

#if VECTOR_DATA_IRQ_COUNT > ©
if (BSP_CORTEX_VECTOR_TABLE_ENTRIES <= gic_intid)

/* Remain the interrupt number */
g_current_interrupt_num[g_current_interrupt_pointer++] =
(uint16_t) (gic_intid-- BSP_CORTEX_VECTOR_TABLE_ENTRIES);

__asm volatile (“dmb”);

#if 1
/* Enable nested interrupt. */
__asm volatile (“cpsie i”);
__asm volatile (“isb”);
#endif
/* Branch to an interrupt handler. */
g_vector_table[(gic_intid-- BSP_CORTEX_VECTOR_TABLE_ENTRIES)]();
}
else
#endif
{
/* Remain the interrupt number */
g_current_interrupt_num[g_current_interrupt_pointer++] = gic_intid;
__asm volatile (“dmb”);
#if 1
/* Enable nested interrupt. */
__asm volatile (”cpsie i”);
__asm volatile (“isb”);
#tendif
/* Branch to an interrupt handler. */
g_sgi_ppi_vector_table[gic_intid]();
}
#if 1

/* Disable nested interrupt. */
__asm volatile (”cpsid i”);
__asm volatile (”isb”);

#endif

g_current_interrupt_pointer--;

Issue The interrupt number cannot be successfully acquired by the R_FSP_CurrentlrqGet()
when multiple interrupt occurs.

Target RZ/N2L

Category FSP Modules, FreeRTOS

Description The interrupt number cannot be successfully acquired by the R_FSP_CurrentlrqGet() when using
multiple interrupt handlers with different priority levels in FreeRTOS.

Workaround | Please modify the followings for the countermeasure against nested interrupts.
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No. 13
Issue Block Media Custom Implementation can be selected as Memory Implementation for
“rm_freertos_plus_fat” module, but it cannot be used.
Target RZ/T2M, RZ/T2L, RZ/IT2ME, RZ/N2L
Category FSP Configuration, Stacks
Description In Stacks tab of Configuration, Block Media Custom Implementation can be selected as Memory
Implementation for “rm_freertos_plus_fat” module, but it is unsupported and causes build errors.
FreeRTOS+FAT Stacks
4% FreeRTOS+FAT
®
& FreeRTOS+IFAT Port for
RZT (rm_freertos_plus_fat)
®
%+ Add Mem:l)ry
Implementation
[Required]
New > @4 Block Media Custom Implementation (rm_block_media_user)
4 Block Media USB (rm_block_media_usb)
Workaround | Please select Block Media USB as Memory Implementation for “rm_freertos_plus_fat” module.
No. 14
Issue The second argument of “r_mtu3” APIs do not match with common API.
Target RZ/T2M, RZ/T2L, RZ/IT2ME, RZ/N2L
Category FSP Modules, MTU3
Description The second argument of these three APIs "R_MTU3_PeriodSet()", "R_MTU3_InfoGet()", and
"R_MTU3_StatusGet()" of the "r_mtu3" module, do not match with the APl in “r_timer api.h”
header file
Workaround | You cannot call these API by using function pointer

g_timer@.p_api->periodSet()
g_timer@.p_api-> InfoGet()
g_timer@.p_api-> StatusGet()

Please use API by calling them directly

R_MTU3_PeriodSet()
R_MTU3_InfoGet ()
R_MTU3_StatusGet()

For reference how to use these APIs, please refer to MTU3 Examples in ESP documentation.

(Continued on next page)
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No. 15

Issue In multiprocessing, a configuration error occurs when “r_gpt” module is used for both
projects for CPUO and CPUL.

Target RZ/T2M, RZIT2ME

Category FSP Configuration, Stacks

Description When using “r_gpt” module in Stacks tab of both projects for CPUO and CPU1, a configuration
error occurs. “r_gpt” module can only be used with either CPUO or CPU1 in multiprocessing,
regardless of the Unit or Channel number used.

Workaround | Please use “r_gpt” module ONLY with either CPUO or CPU1 in multiprocessing.

No. 16 Resolved

Issue Project build error occur when 32-bit bus NOR flash and XSP10 x8 boot modes are selected
on RZT Custom User Board.

Target RZ/T2M

Category FSP Configuration, BSP

Description When the following boards (boot mode) are selected, the required definitions are not generated and
a build error occurs.
e  RZT Custom User Board (32-bit bus NOR flash boot mode)
e  RZT Custom User Board (xSP10 x8 boot mode)

Workaround | Please don’t select 32-bit bus NOR flash and xSPI0 x8 boot modes on RZT Custom User Board.

No. 17 Resolved

Issue The secondary project for multiprocessing cannot be created when xSPI1 x1 boot modes are
selected on RZT Custom User Board.

Target RZ/T2M

Category FSP Configuration, BSP

Description When the following boards (boot mode) are selected for the primary project of multiprocessing, a
variable required for multiprocessing is not defined and the secondary project cannot be created.
e  RZT Custom User Board (xSP11 x1 boot mode)

Workaround | Please don’t select xXSPI1 x1 boot modes on RZT Custom User Board when multiprocessing.

(Continued on next page)
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No. 18
Issue An incorrect value is set to a pin select value for MTUO-B/MTU6/MTU7 as MTU3 output pin.
Target Rz/T2L
Category FSP Modules, POE3
Description | Pin select value of MTU3 output pins used in FSP do not match with User’s Manual: Hardware.
Therefore, what you want to set up is not correctly described in the generated file of FSP
Configuration.
Workaroun | When using “r_poe3” and MTUQO-B/MTU6/MTU7 as MTU3 output pin, please follow these four
d steps:
1. Add “Port Output Enable 3 for MTU3 (r_poe3)” on Stacks tab of FSP Configuration.
2. Click Generate Project Content button and “r_poe3” code is generated.
3. Disable code generating function.
After this setting, the code cannot be generated.
[For e?studio Smart Configurator]
Use the following settings to suppress the code generating operation.
If this setting is missed, code generating operation is automatically executed at clean build, and
the changes made in step 4 revert to the original.
a. Uncheck “Project Properties > Builders > DDSC Builder”
[apropert;es fov’ . - N - il b ) ><7 |
‘ Builders % v 8
| Resource 3 - .
| P Configure the builders for the project:
| 5 ¢/Co+ Build ..,DDsc Builder New...
C/C++ General [V] b COT Builder
McU [ lsbScanner Configuration Builder Jmport:
Project Natures [¥] l»DDSC Bundle Builder
Project References
Renesas QE
Run/Debug Settings
Task Tags
Validation
Down
‘ 2 Gancal
b. When unchecking it, the following message appears: click OK.
‘ 8 Confirm Disable Builder X
| This is an advanced operation. Disabling a project builder can have many side-effects. Continue? i
Cancel
[For FSP Smart Configurator (IAR EWARM)]
No need setting since code generation is not executed automatically.
4. Modify definitions in rzt_gen/hal_data.c
Change the value of [module name]_ pwm_pin_setting[] or [module
name]_complementary_pwm_setting[1].pin_setting[X](X=0,1,2) according to the MTU3 output
pins used. The tables below show the replacements required for each MTU3 output pins.
File to be modified: rzt_gen/hal_data.c
/* Setting structure for pwm pin. */
static const poe3_pwm_pin_setting_t g poe30_pwm_pin_setting[] =
{
{ .pwm_pin_select = POE3_PIN_SELECT_©, .hiz_output_enable = false },
{ .pwm_pin_select = POE3_PIN_SELECT_©, .hiz_output_enable = false },
{ .pwm_pin_select = POE3_PIN_SELECT_O, .hiz_output_enable = false },
{ .pwm_pin_select = POE3_PIN_SELECT_O, .hiz_output_enable = false }, };
/* Setting structure for complementary pwm pin. */
static const poe3_complementary_pwm_setting_t g_poe30_complementary_pwm_setting[] =
{
{ .pin_setting[@] =
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{ .positive_pwm_pin_select = POE3_PIN_SELECT_®@,
.pin_setting[X] =

{ .positive_pwm_pin_select POE3_PIN_SELECT_@,
.negative_pwm_pin_select = POE3_PIN_SELECT_O,
.positive_pwm_pin_active_level = POE3_ACTIVE_LEVEL_SETTING_NONE,
.negative_pwm_pin_active_level = POE3_ACTIVE_LEVEL_SETTING_NONE,
.hiz_output_enable = false },

For MTUO-B

MTU3 Port Location (Struct [module name]_ Replace with

output pin pwm_pin_setting[])

mtiocOb P14 4 the second pwm_pin_select .pwm_pin_select =
POE3 PIN SELECT 1

mtiocOb P24 0 the second pwm_pin_select .pwm_pin_select =
POE3_PIN_SELECT_2

mtiocOb P13 3 the second pwm_pin_select .pwm_pin_select =
POE3_PIN SELECT_3

For MTU6/MTU7

MTU3 Port Location (Struct [module Replace with

output pin name]_complementary pwm_setting[])

mtioc6b P21 2 the second pin_setting[0] .positive_pwm_pin_select
= POE3_PIN SELECT 1,

mtioc6b P08_5 the second pin_setting[0] .positive_pwm_pin_select
= POE3_PIN SELECT 2,

mtioc6d P21 4 the second pin_setting[0] .negative_pwm_pin_select
= POE3_PIN SELECT 1,

mtiocéd P08_7 the second pin_setting[0] .negative_pwm_pin_select
= POE3_PIN SELECT 2,

mtioc7a P21 5 the second pin_setting[1] .positive_pwm_pin_select
= POE3_PIN SELECT 1,

mtioc7a P09 _0 the second pin_setting[1] .positive_pwm_pin_select
= POE3_PIN SELECT 2,

mtioc7c p21_7 the second pin_setting[1] .negative_pwm_pin_select
= POE3_PIN SELECT 1,

mtioc7c P09_2 the second pin_setting[1] .negative_pwm_pin_select
= POE3_PIN SELECT 2,

mtioc7b P21_6 the second pin_setting[2] .positive_pwm_pin_select
= POE3_PIN SELECT 1,

mtioc7b P09 1 the second pin_setting[2] .positive_pwm_pin_select
= POE3_PIN SELECT 2,

mtioc7d P22_0 the second pin_setting[2] .negative_pwm_pin_select
= POE3_PIN SELECT 1,

mtioc7d P09_3 the second pin_setting[2] .negative_pwm_pin_select
= POE3_PIN SELECT 2,

Note: There are two pin_setting[X] 's with the same number(X); modify the second one, not the
first.

(Continued on next page)
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No. 19

Issue Build error when using DSMIFn_ERR as an additional trigger for “r_poe3” module.
Target RZ/T2L
Category FSP Modules, POE3
Description When using DSMIFn_ERR as an additional trigger in FSP Configuration, after code generation,
values of DSMIFn_ERR additional trigger for the module are generated in rzt_gen/hal_data.c. But
the defined values are not defined in FSP, so a build error occurs.
*  Property of r_poe3 stack
g_poe30 Port Output Enable 3 for MTU3 (r_poe3)
Settings  Property Value
e
o s
~ Adr:gsn;ial‘:l:;t;ﬂ pin centrol request condition (Always enable POE&# Input) .
Fo£10 o -
,—EES;E; = Z
-
. Build error log
I Properties | 1 Problems |@: Smart Browser | B} Console X | X LG8 BE=EE »B-3-=0O
COTBuid Consolelim2]
.‘/rzt_gen/hai_dat;.::76:49: error: *R_POE3_POECRS_DE@ADDMTAZE_Pos' undeclared here (not in a function); did you mean 'R_POE3_POECRS_DBE@ADDMTOZE_Pos'? »
Building file: ../rzt_gen/hal_data.c
78 I .mtud_contrel_channel_mask = ((1U << T:TE53:23Esiz:zigizzjzgis:zii) | (1U << R_POE3_POECR5_DE1ADDMT@ZE_Pos) | au),
fix-it:"../rzt_gen/hal_data.c”:{78:48-70:69}: -Rfaggifaggﬁngagggisgﬂgéfazzf
../rzt_gen/hal_data.c:78:80: error: 'R_POE3_POECRS_DE1ADDMT@ZE Pos' undeclared here (not in a function); did you mean 'R_POE3_POECRS_D@ELADDMT@ZE_Pos'?
78 I .mtud_controel_channel_mask = ((1U << R_POE3_POECRS_DE@ADDMT@ZE_Pos) | (1U << i:EE53:225Siz:ziiizzjzgis::ii) | au),
fix-it:"../rzt_gen/hal_data.c":{70:88-7@:1@9}:"R_POE3_POECRS DBE1ADDMTOZE_Pos” F-FOR3_PORCRS_poELiDITOZE Pos
Workaround | When using “r_poe3” and DSMIFn_ERR(n=0,1) as an additional trigger, please follow these four
steps:
1-3. Refer to the workaround of No. 18.
4. Modify definitions in rzt_gen/hal_data.c
When using DSMIF 0 ERROR, DSMIF 1 ERROR for MTUO additional trigger, modify:
e R_POE3 POECR5 DEOADDMTOZE_Pos to R_POE3_POECR5_DOEOADDMTOZE_Pos
e R_POE3 POECR5 DE1ADDMTOZE_Pos to R_POE3_POECR5 _DOE1ADDMTOZE_Pos
When using DSMIF 0 ERROR, DSMIF 1 ERROR for MTU3/4 additional trigger, modify:
e R_POE3_POECR4_DEOADDMT34ZE_Pos
to R_POE3_POECR4_DOEOADDMT34ZE_Pos
e R_POE3 _POECR4_DE1ADDMT34ZE_Pos to
R_POE3_POECR4_DOE1ADDMT34ZE_Pos
When using DSMIF 0 ERROR, DSMIF 1 ERROR for MTUG6/7 additional trigger, modify:
+ R_POE3 POECR4 DEOADDMT67ZE_Pos to
R_POE3 POECR4_DOEOADDMT67ZE_Pos
* R_POE3 POECR4_DE1ADDMT67ZE_Pos to
R POE3 POECR4 DOE1ADDMT67ZE Pos

(Continued on next page)
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No. 20
Issue Control setting values for MTU3 output pins in Stacks tab of FSP Configuration are set to the
incorrect pin.
Target RZ/T2M, RZ/T2L, RZIT2ME
Category FSP Configuration, Stacks
Description Settings for MTU4-B(MTIOC4B) and MTU4-D(MTIOC4D) in the Stacks tab property would be
treated as settings for MTU4-A(MTIOC4A) and MTU4-C(MTIOC4C) in the generated file by
Smart Configurator. All MTU3 output pins for MTU4 and MTU?7, are the same as above.
Module [module name] Port Output Enable 3 for MTU3 (r_poe3) of Stacks property
Second Category Third Category Used for
MTU3 and MTU4 Pin MTU4-B(MTIOC4B) and MTU4- MTU4-A(MTIOC4A) and MTU4-
Control D(MTIOC4D) C(MTIOC4C)
MTU3 and MTU4 Pin MTU4-A(MTIOC4A) and MTU4- MTU4-B(MTIOC4B) and MTU4-
Control C(MTIOCAC) D(MTIOC4D)
MTUG6 and MTU7 Pin MTU7-B(MTIOC7B) and MTU7- MTU7-A(MTIOC7A) and MTU7-
Control D(MTIOC7D) C(MTIOCT7C)
MTU6 and MTU7 Pin MTU7-A(MTIOC7A) and MTU7- MTU7-B(MTIOC7B) and MTU7-
Control C(MTIOC7C) D(MTIOCT7D)
Workaround | In configuration of MTU4 and MTU?7, please replace B/D and A/C.
¥ MTU3 and MTU4 Pin Control
MTU3-B (MTIOC3B) and MTU3-D (MTIOC3D)
[MTU4 B (MTIOC4B) and MTU4-D (MTIOC4D) ] Use this field to configure for MTU4-A and MTU4-C
[MTUZ-ATMTIOCA] and MTU4-C (MTIOCAT) | Use this field to configure for MTU4-B and MTU4-D
Additional MTU3/4 pin control request condition (Always enable POEO# Input)
v MTU6 and MTU7 Pin Control
MTUG-B (MTIOC6B) and MTUG-D (MTIOC6D)
[MIUJ-B (MTIOCT7B) and MTU7-D (MTIOCTD) ] Use this field to configure for MTU7-A and MTU7-C
[MTU7-A [MTIOC7A] and MTU7-C [MTIOC7C) |  Use this field to configure for MTU7-8 and MTU7-D
Additional MTU6/7 pin control request condition (Always enable POE4# Input)
No. 21
Issue A bug that prevented the setup of PLL1.
Target RZ/N2L
Category FSP Configuration, Clocks
Description The PLL1 state setting in Clocks tab is invalid.
Workaround | Please don’t use PLL1 state setting.

(Continued on next page)
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No. 22
Issue A section may not be copied correctly when it is not aligned and the section size is not a
multiple of the alignment width.
Target RZ/N2L
Category FSP Modules, BSP
Description Depending on a combination of section size and placement address, when the section is copied,
some data from the following section may also be copied with it.
A case that cannot be copied correctly:
The address of .data_noncache section is 0x30190005 and its size is 0x23 bytes. (Alignment size
is 4 bytes.)
.data_noncache
0x30190005 ox23 ./src/hal_entry.o
Workaround | All section sizes must be aligned by 4 bytes and the data size should be a multiple of the number of
bytes in the alignment. Section sizes can be found in the following files:
. gcc: [project name]/Debug/[project name].map
. iccarm: [project name]/Debug/List/[project name].map
No. 23
Issue Initial values of data placed in some sections were overwritten with 0.
Target RZ/N2L
Category FSP Modules, BSP
Description When selecting XXXXX (RAM execution without flash memory) as “Board” in BSP tab of FSP
Configuration, variables placed in the following sections are always cleared to zero.
e .dmac_link_mode
e .shared_noncache_buffer
. .noncache_buffer
Workaround | Do NOT place data with initial values in the above sections.

(Continued on next page)
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No. 24
Issue Some sections were not initialized in the flash boot project.
Target RZ/N2L
Category FSP Modules, BSP
Description When selecting a flash boot mode as “Board” in BSP tab of FSP Configuration, variables placed in
the following sections are NOT initialized.
Boards for flash boot mode
e XXXXX (XSPIO0 x1 boot mode)
e XXXXX (16-bit bus NOR flash boot mode)
. RZN2L Custom User Board (xSPI0 x8 boot mode)
. RZN2L Custom User Board (xSPI1 x1 boot mode)
Sections
. .dmac_link_mode
e .shared_noncache_buffer
. .noncache_buffer
Workaround | Please initialize the variables placed in the above sections in the user application.
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Appendix. Tool Software Limitations

This section describes the limitations regarding the tool software (e? studio, FSP SC) to create and debug FSP projects.

Table 7 List of Tool Software Limitations

No. | Title Target Device Category
T2M | T2L | T2ME | N2L

1 When installing, please install into the default installation folder v v v v SC, FSP
specified by installer. SC

2 Before pressing the reset button on the board, disconnect the e? v v v e? studio
studio connection first.

3 An error has occurred because the program download to the NOR | « v e? studio
flash area has failed. The download is successful on the second
connection.

4 The user program cannot be stopped immediately after the device | v v v v e? studio

boot process.

5 When using e? studio installer, if checking the multiple check v v v e2 studio
boxes such as “View Release Notes” and so on to show
information on browser, the ONLY head item of checked items is
shown.

6 The Memory Region Usage of ATCM displayed in the Memory v e? studio
Usage window of e? studio is smaller than the actual size by
memory region usage of DUMMY.

7 When debugging RAM execution without flash memory project v v v v e? studio
with program written to flash memory, erase flash memory before
debugging.

8 Applying RZ/T2 FSP v.1.2.0 pack to a project that is already v IAR
working with RZ/T2M FSP v.1.1.0 causes an error when EWARM
connecting the debugger.

9 The Device Memory Usage of CPU1 in the Memory Usage v v e? studio
window does not work properly.

10 | When adding the CallbackSet function using the Developer v v v v e? studio,
Assistance feature, the second argument needs to be changed. SC

11 | In IAR EWARM 9.60.1, an error occurs when starting to debug v v IAR
multiprocessing projects of RAM execution without flash EWARM
memory.

No. 1
Limitation When installing, please install into the default installation folder specified by installer.

Target Device | RZ/T2M, RZ/T2L, RZIT2ME, RZ/N2L

Category Smart Configurator, FSP Smart Configurator

Description When sharing a project between different PCs, build errors will occur if the installation folders are
different.

(Continued on next page)
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No.2 Resolved
Limitation Before pressing the reset button on the board, disconnect the e? studio connection first.
Target RZ/T2M, RZ/T2L, RZ/N2L
Category e? studio
Description If the reset button is pressed on the board while connected with e? studio, debugging will not be
able to continue.
No.3 Resolved
Limitation An error has occurred because the program download to the NOR flash area has failed. The
download is successful on the second connection.
Target RZ/T2M, RZ/N2L
Category e? studio
Description If the following error is displayed when connecting the debugger or when downloading the
program, click the [OK] button to close the dialog and try connecting again.
& Error O >
'-.-8..' Exception occurred during launch
"~ Reasom:
Error in final launch sequence:
Failed to execute MI command:
load
Error message from debugger back end:
Could not write register "pc”; remote failure reply 'E..FFFFFFFF*
No. 4
Limitation The user program cannot be stopped immediately after the device boot process.
Target RZ/T2M, RZ/T2L, RZIT2ME, RZ/N2L
Category 2 studio
Description Immediately after the device boot process (boot code), the program cannot be stopped at the
beginning of the user program (loader program).
When debugging, please follows the guide in
Appendix. How to Debug FSP Project with Flash Boot Mode.

(Continued on next page)
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No.5 Invalid

Limitation When using e? studio installer, if checking the multiple check boxes such as “View Release
Notes” and so on to show information on browser, the ONLY head item of checked items is
shown.

Target RZ/T2M, RZ/T2L, RZ/N2L

Category e? studio

Description For example, if checking “View Release Notes” check box and other check boxes on the following

window, the ONLY “Release Notes” is shown, and the other contents are NOT shown.

Welcome
Extra Features

Customise
Features

Additional
Software

Licenses
Shortcuts
Summary

Installing...

@ Results

A Renesas RZ/T Flexible Software Package (FSP) v1.1.0 with & studio 2022-10 Setup O X
Renesas RZ/T Flexible Software Package (FSP) v1.1.0 with e” studio 2022-10 Setup %ﬂ

Installation of Renesas RZ/T Flexible Software Package (FSP) v1.1.0 with e studio 2022-10 is
complete.

Please click OK to close.

[[J Launch €2 studio?
[ View Release Notes? -> “Release Notes” page is shown on browser

[ View What's New? -> Other pages are NOT shown
View Renesas FSP User Manual?

Useful Links:
Renesas FSP: C:\Renesas\rzt\e2studio v2022-10 fsp v1.1.0
zt\e2studio v2022-10 fsp v1.1.0
GCC ARM Embedded: C:\Renesas\rzt\e2studio v2022-10 fsp v1.1.0\toolchains\gcc arm\
9 2019q4

GCC ARM Embedded: C:\Renesas\rzt\e2studio v2022-10 fsp v1.1.0\toolchains\gcc arm\
YRR

Renesas FSP User Manual: C:\Renesa

User: All Users < Back Next > [—O—ﬁ_] Cancel

(Continued on next page)
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No.6 Resolved in RZ/T2 FSP v2.1.0 for RZ/T2M and RZ/T2L

Limitation The Memory Region Usage of ATCM displayed in the Memory Usage window of e? studio is
smaller than the actual size by Memory Region Usage of DUMMY .
Target RZ/N2L
Category e? studio
Description The Memory Region Usage of DUMMY shown in the Memory Usage window is the region used
by the system. The DUMMY is placed in ATCM, however Memory Region Usage of ATCM does
NOT include its size.
Therefore, please note that the Memory Region Usage of ATCM displayed is smaller than the
actual size by the Memory Region Usage of DUMMY.
Virtual Console | 4 Search [ Memory Usage X =X |‘ i o { = e
Memory Region Usage | Device Memory Usage
Memory Region Usage: 2
ATCM 6% 512KB
33KB used
BTCM 44 % 64KB
28KB used
8B used
SYSTEM_RAM 0% 2048KB
0B used
< >
No. 7
Limitation When debugging RAM execution without flash memory project with program written to
flash memory, erase flash memory before debugging.
Target RZ/T2M, RZ/T2L, RZIT2ME, RZ/N2L
Category e? studio
Description If you run a RAM execution without flash memory project with a program written in flash memory,
it may be impossible to debug the project.
When erasing flash memory, please follows the guide in
Appendix. How to Erase Flash Memory

(Continued on next page)
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No. 8
Limitation Applying RZ/T2 FSP v.1.2.0 pack to a project that is already working with RZ/T2M FSP
v.1.1.0 causes an error when connecting the debugger.
Target RZ/T2M
Category IAR EWARM
Description An error occurs when connecting to the debugger because the function name of vector table was

changed in RZ/T2 FSP v.1.2.0.

Change the following command in the “command line options (one per line)” to
e  (Before change) —drv_vector_table_base=vector_table
e  (After change) —drv_vector_table_base=__Vector

Category:

Runtime Checking
C/C++ Compiler
Assembler
QOutput Converter
Custom Build
Build Actions
Linker
Debugger

Simulator
CADI

CMSIS DAP
GDB Server
Tet
JdLinkf3-Trace
T1 Stellaris
Nu-Link

PE micro
ST-LINK
Third-Party Driver
TIMSPFET
TIXDS

Options for node "Blinky"

~

Setup Download Images Multicore | Extra Options | Plugins

[ Use command line options

Command line options: (one per line)

Factory Settings

--drv_vector_table_base=_ Vector I

Cancel

(Continued on next page)
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No. 9
Limitation The Device Memory Usage of CPU1 in the Memory Usage window does not work properly.
Target RZ/T2M, RZ/IT2ME
Category e? studio

Description The Device Memory Usage in the Memory Usage window, it cannot distinguish between CPUOQ
and CPUL.

When debugging CPUL1, the memory area available for CPU1 should be displayed, but the memory
area available for CPUO is incorrectly displayed.

Iger Console| Memory Usage X | 0 Memory‘

Memory Region Usage ‘ Device Memory Usage‘

P 0x00000000

IernaIRam
0x0007FFFF 34040/524288 byte(s) (6.49% )
o _
0x000FFFFF
P 0x00100000
0x0010FFFF byte(s) (44.02% )
o _
OxOFFFFFFF o

No. 10
Limitation When adding the CallbackSet function using the Developer Assistance feature, the second
argument needs to be changed.
Target Rz/T2M, RZ/T2L, RZ/T2ME, RZ/N2L
Category e? studio, Smart Configurator

Description When adding the R_xxx_CallbackSet() function (xxx means any module name) using the
Developer Assistance feature, the second argument does not have the correct value. Please replace
the second argument with "p_callback".

An example of SCI_SPI module, adding CallbackSet() using the Developer Assistance results in
the following.

status = R_SCI_SPI_CallbackSet(&g_spi@_ctrl, spi_callback_args_t, p_context, p_callback_memory);

It needs to replace the second argument with “p_callback”.

status = R_SCI_SPI_CallbackSet(&g_spi@_ctrl, p_callback, p_context, p_callback_memory);

(Continued on next page)
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No. 11
Limitation In IAR EWARM 9.60.1, an error occurs when starting to debug multiprocessing projects of
RAM execution without flash memory.
Target RZ/T2M, RZ/IT2ME
Category IAR EWARM
Description

When IAR EWARM 9.60.1 is used, there is no defined value required for debugging CPU1 project,
and an error occurs when debugging begins.

In EWARM 9.60.1, when debugging projects of multiprocessing, it is necessary to add "--
macro_param cpul_enable=1" in the “command line options (one per line)” of CPU1 project.

Options for node "Blinky_cpul_secondary”

X

Category:

Factory Settings
General Options A

Static Analysis
Runtime Checking

CJC++ Compiler Setup Download Images Multicore Authentication Plugins

Assembler N .
Output Converter [ Use command line options
Custom Build
Lln.ker --drv_vector table base=_ Vectors
Build Actions W
Debugger

Simulator
CADI

CMSIS DAP
E2[E2Lite
GDB Server
GHLINK

T-jet
J4ink/J-Trace
T1 Stellaris
Nu-Link

PE micro

Command line options: (cne per line)

Cancel
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Appendix. How to Debug FSP Project with Flash Boot Mode

When debugging FSP project with flash boot mode (xSPI0 boot, NOR flash boot), the program cannot be stopped at the
beginning of the user program (loader program). Another note on the use of flash debug boot mode is also included in
this section.

Please note the following point depending on your IDE (e? studio or IAR EWARM) to debug the user program from its
beginning.

1. (Both e? studio and IAR EWARM) Insert the loop part in startup.c.

When debugging is started, the debugger stops the user program (loader program) about 100ms after the device boot
process (boot code). If using e? studio 2022-10 or later, the PC (program counter) is replaced at the entry point (first line
in system_init() function) after the debugger stops, otherwise, the PC points the address of somewhere in the user
program.

When debugging the program immediately after the boot process (boot code), insert the loop part in

e [rzt/fsp/src/bsp/cmsis/Device/RENESAS/Source/cr/startup_core.c, or

e /rzn/fsp/src/bsp/cmsis/Device/RENESAS/Source/startup.c

The detailed position, at which the loop part should be inserted, depends on the IDE(Debugger) and Boot mode.

IDE Boot Mode Position at which the loop part should be inserted.
e? studio | xSPIO boot Line after static_constructor_init in mpu_cache_init() function.
2022-04 #if BSP_CFG_C_RUNTIME_INIT
2022-07 /* Initialize static constructors */
__asm volatile (
“static_constructor_init: \n”
«“ ldr re, =bsp_static_constructor_init \n”
« blx re \n”
)5
#endif

#if 1 // Software loops are only needed when debugging.
__asm volatile (

« mov ro, #o0 \n”’
« movw rl, #OxfO7f \n”’

movt ril, #Ox2fa \n”
“software_loop: \n”

adds re, #1 \n”
«“ cmp re, ri \n”
«“ bne software_loop \n”

it “memory”);
#endif

NOR flash boot | First line in system_init() function.
BSP_TARGET_ARM BSP_ATTRIBUTE_STACKLESS void system_init (void)

e? studio | xSPI0 boot

{
2022-10 #if 1 // Software loops are only needed when debugging.
or later NOR flash boot __asm volatile (
« mov ro, #0 \n”
« movw rl, #OxfO7f \n”
movt rl, #Ox2fa \n”
I1AR “software_loop: \n”
«“ adds re, #1 \n”
EWARM “ cmp ro, ri \n”
“  bne software_loop \n”
: “memory”);
#endif
__asm volatile (
“set_hactlr: \n”
“  MOVW re, %[bsp_hactlr_bit_1] \n” /* Set HACTLR bits(L) */
“ MOVT ro, #0 \n”
«“ MCR pl5, #4, ro, cl, ceo, #1 \n” /* Write r@ to HACTLR */
::[bsp_hactlr_bit_1] “i” (BSP_HACTLR_BIT_L) : “memory”);
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Appendix. How to Erase Flash Memory

If you run a RAM execution without flash memory project with a program written in flash memory, it may be

impossible to debug the project.

Please erase flash memory by following steps depending on your IDE (e? studio or IAR EWARM) before running the

project.

1. e?studio
If you would like to erase the flash memory on RSK using J-Link Commander, execute the following steps.
i) Set the switch for boot mode on RSK to correspond to the area to be erased.
i) Open the J-Link Commander.

B J-Link Commander V7.88d

Figure 89 : Launch J-Link Commander

iii) First, type “connect” to establish a target connection and press enter.
Next, specify the connection conditions as follows.
e  Device> (Device type name)

Table 8 Device type name on Renesas Starter Kit+

RSK

Device type name

RSK + RZ/T2M

ROA07G075M24_CPUO

RSK + RZ/T2L ROA07G074M04
RSK + RZ/T2ME ROA07G075M29_CPUO
RSK + RZ/N2L R9A07G084M04

e TIF>S

e  Speed> (Default: press enter without inputting any data)

(Continued on next page)
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EJ J-Link Commander V7.88d - O X

2" for help
4_CPUO

[kHz]. <Default>: 4000 kHz

Figure 90 : Initial setup for connecting to the device

After that, confirm the message “Cortex-R52 identified.” Is displayed.

KX J-Link Commander 7.88d — O *

AP

" MEM-AP

Figure 91 : Message of device core identification
iv) Use the commands below to enable flash erase and erase the flash memory.
e  J-Link>exec EnableEraseAllFlashBanks

o  J-Link>erase (Start address), (Endaddress)

(Continued on next page)
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Table 9 External address space to be used in each boot mode

RSK Boot mode External address Start address End address
space to be used

RSK + RZ/T2M, xSP10 x1 xSP10 CSO 0x60000000 0x63FFFFFF

RSK + RZ/T2ME 16-bit bus CSo 0x70000000 OX71FFFFFF

RSK + RZ/T2L xSP10 x1 xSP10 CSO 0x60000000 0x63FFFFFF
XSPI1 x1 XSPI1 CSO 0x68000000 OX68FFFFFF

RSK + RZ/N2L xSP10 x1 xSP10 CSO 0x60000000 0x63FFFFFF
16-bit bus CSo 0x70000000 OX71FFFFFF

" MEM-A
L MEM-AF

Figure 92 : Specify erase range

After that, confirm the message “Erasing done.” Is displayed.

Bl J-Link Commander V7.36d - O *

Figure 93: Message of flash memory erase complete

V) Enter “q” to exit J-Link Commander.

(Continued on next page)
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2. IAR EWARM

If you want to erase the flash memory on RSK using IAR EWARM, execute the following steps.

i) Set the switch for boot mode on RSK to correspond to the area to be erased.
i) Open the workspace of a project.
XXX.EWW
| Blinky.ewd
| Blinky.ewp

© Blinky.eww

i)

Figure 94 : Open workspace for IAR EWARM

Select “Project” -> “Download” -> “Erase memory”.

© 8iinky - IAR Embedded Workbench IDE - Am 3322

File Edt View [ Project | 1jet Tools Window Help
N ARG |G Addre. S & W T
'm""‘m’“'"'.‘u"'—__T Ce AddGroup...
Det [4] import Fite List...
P Add Project Connection... BerTTETTITTIIIIIIIRISIIRIIRIRI I,
Fles Ed Contiguriions.. 2020-2023] Renesas Electronics |
2 @ Blinky - De
}—E i Flex Softs X Remove re ond documentation are supplis
| = WBuildC h products of Renesgs Electronii
M Compt L) Create New Project... Hucts are sold pursuant to Rene:
} tg .-Gen:‘" O g br and use of Renescs products «
Cadn 3 Add Existing Project... property right is granted by |
ogre bws. Renesos reserves the right
o BIEN & options.. AR-FT E AND DOCUMENTATION IS DELIVEREI
Dbucldmfou EST EXTENT PERMISSIBLE UNDER APl
5§ Output Version Control System ¥ RRRANTIES OF MERCHANTABILITY, F.
DOCUMENTATION. RENESAS SHALL |
@ ke F7 lum EXTENT PERMITTED BY LAW, IN
B compie Ctri-f7 DN (OR ANY PERSON OR ENTITY CLA
NITHOUT LIMITATION, ANY DIRECT,
@ Rebuil A0 5, OTHER ECONOMIC DAMAGE, PROPEI
& Cesn OF SUCH LOSS, DAMAGES, CLAIMS (
PRI TTRNIRNIRNIRINRRNINNINNNRNNDY
& Batchbuid.. 8
Pata.h”
Ciean Browse Information
pStart(bsp_warm_start_event_t e
C-STAT Static Analysis »
5_t g bsp_leds;
Q] Stop Build eak |~ B9%P_ g
bessessessessessesrensssrensens
© Download and Debug Qn-D Ly example application
Debug without Downloading
& eds ot a rote of 1 second usim
») Attach to Running Target
3 Mske & Restart Debugger ief PRREEssEssssssasasssssssssssess
Restart Debugger +Shift-R (void)
Download » Download active application ]
1 3
sFR Downioad file... !
Erase memory | 7]
£t CMSIS-Pack Manager rz_t Yreq In nT & 23 !
Open Device Desaiption Fle ¢ the deloy in terms of bsp_de
Save List of Registers... 2_t delay = bsp_delay units / 1
33
B * LED type structure *
4as bso leds t leds = e bso leds:

(Continued on next page)
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iv) Select erase memory space.

Erase Memory X

Flash loader Range

C:¥Program Files¥IAR Systems¥Embedded Workbench 9,32, 2¥arm/config/flashloader [Renesas /FlashRSK_RZT... 0x60000000 - 0x6 3T
[ c:#¥Program Files¥IAR Systems¥Embedded Workbench 9,32, 2¥arm/confia/fashloader Renesas/FlashRSK_RZT... 0x70000000 - 0x7 LFFFFFF

Erase all t  Frase | Cancel

Figure 96 : Select erase memory space

V) After the following dialog appears, erasing of the flash is complete if no error occurs.

Busy

Starting debugger session: Flashing

Frogramming flash memory

Cancel

Figure 97 : Screen during erasing

Debug Log v R X

Log ~
Wed Sep 06, 2023 09:40:04: Target reset

Wed Sep 06, 2023 09:46:23: Unloaded macro file: CAProgram Files\IAR Systems\Embedded VWorkbench 8.32.2}
arm/configiflashloader/Renesas/FlashRSK_RZT2ZM_SerialFlash.mac

‘ed Sep 06, 2023 09:46:23: Flash memory has heen erased.

Wed Sep 08, 2023 09:46:23: Unloaded macro file: CA\Program Files\|AR Systems\Embedded \Workbench 8,32 2\arm/config/dek [Penasas/RZT2M.dmac

Wed Sep 06, 2023 09:46:24 AR Embedded Workbench 9.32.2 (C\Program Files\AR Systems\Embedded Warkbench 9.32. 2varmibin\armPROC dll)

Wed Sep 08, 2023 09:46:24: Loading the et driver

Build  Debuglog

Figure 98 : Message of flash memory erase complete
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Appendix. How to Change Boot Mode of FSP Project

When the boot mode of the project is changed, the Pin Configuration needs to be recreated.
It also needs to rename and save the pin configuration to retain the original one before changing the boot mode.

For example, one of specific cases in which re-configure is necessary is when a RAM execution without flash memory
project is changed to flash boot mode (xSPI0 x1 boot mode and others).

Please change the boot mode by following steps.

Note for FSP version earlier than v1.3.0:

If the FSP version of your project is earlier than FSP v1.3.0, change it to FSP v1.3.0 before doing the following
steps.

1. Rename and save the current Pin Configuration in the Pins tab.
e  How to rename Pin Configuration: Click “Manage Configurations..."

{?:} [sample] FSP Configuration X = B8
Pin Configuration : G
enerate Project Content
Select Pin Configuration M Export to CSV file LE Configure Pin Driver Warnings
| RSK+RZT2M v | Manage configurations...

[ Generate data: |g_bt 8

Multiple Pin Configuration Management

Pin Selection = = Modify pin configuration list or import/export external file “J Cycle Pin Group
Type filter text ak
RSK+RZT2M (Current) Add...
v ¢ Ports ROA07GO75M24GBG.pincfg
v PO Remove
v PO1
v P02 =
v Po3 & Configuration Name X [
v P0O4 L
s Pos New name: | RSK+RZT2M_OLD) | |
v P06 -
v Po7 >
v P08
. pon ;
E T i L
ETFEE|ETFES -

Summary | BSP | Clocks | Pin

Figure 99: How to rename Pin Configuration

(Continued on next page)
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2. Change the boot mode in the BSP tab. (The board must be the same as before the change.)

Device Selection
FSP version: | 1.3.0 v
Board: RSK+RZT2M (RAM execution without flash memory) v| | ey

. RSK+RZT2L (RAM execution without flash memory)
Device:  |RSK+RZT2L (xSPI0 x1 boot mode)

DO _D7TAl [ COle 2 L e oy
Core: ) 5 OR

RSK+RZT2M (RAM execution without flash memory)
RSK+RZT2M (xSPI0 x1 boot mode)

RSK+RZT2M for CPU1 (RAM execution without flash memory)
yva) Ldmnuly}
RZT Custom User Board (16-bit bus NOR flash boot mode)

RZT Custom User Board (32-bit bus NOR flash boot mode)

RZT Custom User Board (RAM execution without flash memory)
RZT Custom User Board (xSPI0 x1 boot mode)

RZT Custom User Board (xSPI0 x8 boot mode)

RZT Custom User Board (xSPI1 x1 boot mode)

RTOS:

limmary | BSP | Clocks | Pins | Interrupts | Event Links‘ Stacks  Components

Figure 100: Change the boot mode in the BSP tab

3. Reselect “FSP Version” from the drop-down list.
(This operation is necessary even if there is only one version in the list.)

Device Selection

FSP version:

Device: ROAOTGO75M24GEG
Core: CR52 0
RTOS: Mo RTQS

Figure 101: Reselect “FSP Version” from the drop-down list

(Continued on next page)
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4. Uncheck “Generate data” in the Pins tab.

i?,} *[sample] FSP Configuration X

Pin Configuration

Select Pin Configuration

[Rsk+RzT2M_OLD

v | Manage

[[] Generate data:

lg_i;:.p_pm_:‘c_l ‘

Figure 102: Uncheck Generate data in the Pins tab

5. Select the regenerated configuration for the board.

'{,"L} *[sample] FSP Configuration X

Pin Configuration

Select Pin Configuration

RSK+RZT2M_OLD
RSK+RZT2M_OLD

ROAQ7GO75M24GBG.pincfg
RSK+RZT2M

v | Manage

- == =

Figure 103: Select the regenerated configuration for the board

6. Check "Generate data" again and enter "g_bsp_pin_cfg" as the name.

ié} *[sample] FSP Configuration X

Pin Configuration

Select Pin Configuration
| RSK+RZT2M v| Mana
Generate data: |g_bsp_pin_cfg |

Figure 104: Check Generate data again
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Appendix. How to Debug FSP multiprocessing projects with Flash Boot Mode

In the case of multi-processing with flash boot mode(xSP10 boot, NOR flash boot), the debugging procedure is different
from RAM execution without flash memory described in 4.7 Debug and Run for Multiprocessing and 5.3.5 Debug for
Multiprocessing. Please create and debug FSP multiprocessing projects with flash boot mode by following steps.

1. e?studio

i)  Create projects according to the procedures in 4.3 Create a New Project for Blinky. However, select the flash
boot mode to be used in the No. 6 procedure.

. RZ/T series

» RSK+RZT2M (16-bit bus NOR flash boot mode) or RSK+RZT2M (xSP10 x1 boot mode)
» RSK+RZT2ME (16-bit bus NOR flash boot mode) or RSK+RZT2ME (xSP10 x1 boot mode)
Insert the loop part in startup_core.c with reference to Appendix. How to Debug FSP Project with Flash Boot

Mode

ii)  Build the projects using the following steps.

a.  Create and build the primary project. (1st build of the primary project)

No build setting is required, proceed to 4.4.1 Build.

b.  Create the secondary project. Change the project property setting and build it.

Set the following before building:
b-1. Click Project > Properties.

Fie et Navigate Search [Priec Jrenesas vews Run Window tielp

(5 Project Explorer X

v 125 Blinky_cpu0_primary

®-& -

¢ studio

Close Project
Open FSP Configuration

@ Build All

Build Configurations

Build Project

Build Working Set

Clean...

Build Automatically

C/C++ Index

imary C [g#  Update All Dependencies

Change Device

Change Toolchain Version

IR VoA

Cri+Alt+B

Ctri+B

Alt+D

Properties

4

.

>
Pre

’ Bo

De'
To

Tol
>

Fsl
Prc
Lot

Sel

SleAl
§

3

Figure 105 e? studio Project Properties

(Continued on next page)
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b-2. Click C/C++ Build > Settings > Build Steps.
b-3. Add command at Post-build steps.

arm-none-eabi-objcopy -I elf32-littlearm -O binary ${ProjName}.elf secondary.bin && arm-none-

eabi-objcopy -1 binary -O elf32-littlearm -B arm --rename-

section .data=.secondary,alloc,data,readonly,load,contents secondary.bin secondary.o

b-4. Proceed to 4.4.1 Build.

@ Properties for Blinky_cpu1_secondary o X
[type fitter text | | Settings e
Resource
Builders
C/C++ Build Configuration: |Debug [Active] ¥ | | Manage Configurations...
Build Variables
Environme ent
Logging 1) Tool Settings | 3 Toolchain | ) Device | #* Build Steps| " Build Artifact | s} Binary Parsers| ;
Tool Chain Editor Pre-build steps
C/C++ General Command(s):
Project Natures ‘ ol
Project References = ‘
Renesas QF Description:
Run/Debug Settings \ v]
Task Tags
Validation Post-build steps
Command(s):
[ 3rm --rename-section .data=.secondary,alloc,data readonly,load,contents secondary.bin secondary.d |
Description:
Restore Defaults Apply
®@ ‘Apply and Close Cancel

Figure 106 e? studio Build Setting for the Secondary Project

(Continued on next page)
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Change the project property setting of the primary project and build it. (2nd build of the primary

project)

Set the following before building:
c-1. Click Project > Properties.
c-2. Click C/C++ Build > Settings > Tool Settings > Cross ARM C Linker > Miscellaneous.
c-3. Set a file pass of secondary.o in the secondary project to Other objects.
${workspace_loc:/Blinky_cpul_secondary/Debug/secondary.o}

c-4. Click Apply and Close.
Proceed to 4.4.1 Build.

) Properties for Blinky_cpu0_primary o
Settings ¥ ¥
Resource
Builders
Configuration: | Debug [Active] +| | Manage Configurations..
Build Variables
Environment
[ o0l Settings] ) Toolchain| 1) Device| 4 Build Steps| % Build Artifact | 5 Binary Parsers| @ Error Parsers
Tool Chain Editor (&2 Target Processor Linker flags (-Xlinker [option]) an !
C/C++ General (3 Optimization
Project Natures (£ Warnings
Project References (3 Debugging
Refactoring History v ) Cross ARM GNU Assembler
Renesas QF (B Preprocessor
Run/Debug Settings (3 Includes
Task Tags 5 Wamings
Validation (£ Miscellaneous
v ) Cross ARM C Compiler
B
E ::E - Other objects :4
(3 Optimization
& Wamings
(8 Miscellaneous
[ 8 Cross ARM C Linker |
X General
D) "
3 Other
v & Cross ARM GNU Create Flash Image -
(2 General Generate map | "$(!
Cross ARKEER! Bl S [ Cross reference (-Xlinker --cref)
(2 General [J Print link map (-Xlinker --print-map)
[ Use newlib-nano (—-specs=nano.specs)
[ Use fioat with nano printf (-u _printf_float)
[ Use float with nano scanf (-u _scanf_float)
[ Do not use syscalls (--specs=nosys.specs)
[ Verbose (-v)
[4 Use semihosting (--specs=rdi )
Restore Defaults Apply
=

Figure 107 e? studio Build Setting for the Primary Project (Part 1)

& Add file path X
File:
IS{workspaceﬁIoc:/Bl inky_cpu1_secondary/Debug/secondary.o} I

oK

Gancel File system...

Figure 108 e? studio Build Setting for the Primary Project (Part 2)
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iii) Debug the projects according to the procedures in 4.7 Debug and Run for Multiprocessing.
The flash boot mode differs from RAM execution without flash memory in two points.

e  Both the primary and secondary project binaries are downloaded to the device when connecting
debugger with the primary project.

¢  No need to change Debug Configuration from the default settings in the No. 3 procedure in 4.5.2
Debug Steps.

»  Debugger > Connection Settings > Connection
- Reset after download: Yes
- Set CPSR(5bit) after download: No

8 Debug Configurations o X

Create, manage, and run configurations ) g\
5

X BY-~ Name: [Blinky_nor_cpu0_primary Debug_Flat
ype filt [5) Main] %5 Debuager] # Startup | [”] Common | &, Source
[€] /C++ Application

[E] C/Cs + Remote Application Debug hardware: | J-Link ARM v | Target Device: | R9AO7GOTSM24 CRS | | ..
3

< >

Filter matched 12 of 14 items

?

Figure 109 e? studio Debug Configuration Settings for the project in flash boot mode

iv)  When changing the project and debugging it again, follow these steps.
Build the primary project.

Build the secondary project.

Build the primary project again.

Debug the projects as the procedure iii.

oo o

2. |AR EWARM

i)  Create projects according to the procedures in 5.3.2 Create a New Project. However, select the flash boot
mode to be used in the No. 4 procedure.

e  RZ/T series
» RSK+RZT2M (16-bit bus NOR flash boot mode) or RSK+RZT2M (xSP10 x1 boot mode)
» RSK+RZT2ME (16-bit bus NOR flash boot mode) or RSK+RZT2ME (xSP10 x1 boot mode)

Insert the loop part in startup_core.c with reference to Appendix. How to Debug FSP Project with Flash Boot
Mode

(Continued on next page)
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ii)  Build the projects by the following order.
a. Create and build the primary project. (1% build of the primary project)
No setting is required, proceed to 5.3.3.2 Build.
b. Create the secondary project. Change the project options setting and build it.
Set the following before building:
b-1. Click Project > Options....
b-2. Click Debugger > Setup.
b-3. Uncheck “Run to".
b-4. Click Output Converter > Output.
b-5. Set Raw binary to Output format.
b-6. proceed to 5.3.3.2 Build.
b-7. Close the secondary project.

Options for node "Blinky_nor_cpu1_secondary” X

Category: Factory Settings

General Options ~
Static Analysis
Runtime Checking
Output
CfC++ Compiler
Assembler .
[ Generate additional output

Output Converter
Custom Build Output format:
Linker
Raw binal v

Build Actions I 2 I
Debugger QOutput file

Simulator [ Override default

CADI

CMSIS DAP Blinky_nor_cpul_secondary.bin

E2/E2 Lite

GDB Server
G+INK

Ijet
J-link/)-Trace
T1 Stellaris
Nu-Link

PE micro

Cancel

Figure 110 IAR EWARM project options for the secondary project in flash boot mode

(Continued on next page)

RO1AN6434EJ0111 Rev.1.11 Page 109 of 120
Jun.28.24 RENESAS




RZ/T2, RZIN2 Getting Started with Flexible Software Package

c. Change the project options setting of the primary project and build it. (2nd build of the primary
project)
Set the following before building:
c-1. Click Project > Options....
c-2. Click Debugger > Setup.
c-3. Uncheck “Run to".
c-4. Click Linker > Input.
c-5. Set the following contents:
e  Keep symbols: (one per line)
» SECONDARY
e  Raw binary image
»  File: the path of binary file in the secondary project.
e.g.
$I9ROJ_DIR$\..\BIinky_nor_cpu1_secondary\Debug\Exe\BIinky_nor_cpu1_seconda
ry.bin
»  Symbol: SECONDARY
»  Section: SECONDARY
> Align: 4
c-6. Proceed to 5.3.3.2 Build.

Options for node "Blinky_nor_cpu0_primary" X

Category: Factory Settings

General Options ~
Static Analysis
Runtime Checking
C/C++ Compiler #define Diagnostics Checksum Encodings Extra Options
Assembler Config  Library Optimizations Advanced Output List
Output Converter
Custom Build
SECONDARY |
Build Actions
Debugger
Simulator
CADI
CMSIS DAP
E2/E2 Lite
GDB Server
GHLINK
Ijet
J-Link/J-Trace
TI Stellaris
Nu-Link
PE micro File: Symbol: Section: Align:

Bhren | 2

Keep symbols: (one per line)

Raw binary image
File: Symbol: Section: Align:
|,e¥BIinky_nor_cpu1_secondary.bid| ZONDARV] IONDARV‘ 4

Cancel

Figure 111 IAR EWARM project options for the primary project in flash boot mode

(Continued on next page)
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iii) Debug the projects by the following order.
a. Open the primary project and close the secondary project on IAR EWARM.
b. Click Project > Download > Download file....

> Blinky_nor_cpu0_primary - Master - IAR Embedded Workbench IDE - Arm 2.50.1

File Edit v-ewuet Tools Window Help

A R @ | e AddFites.. QD> B =<
Workspace | & Add Group...
4] import File List...
o [ imp:
I H Add Project Connection... b products of Renesas Electronics
Files Edit Configurations... Hucts are sold pursuant to Renesa:
& @ Blinky_nor bn and use of Renesas products ant
-2 W Flex Softy | Add om roject | property right is granted by Re:
i i Build pws. Renesas reserves the right t(
A For figuration E AND DOCUMENTATION IS DELIVERED
| MComp{ {1 CMake Connector » EST EXTENT PERMISSIBLE UNDER APPLI
| 8 Genery BRRANTIES OF MERCHANTABILITY, FITI
L@ liProgre x| pemove DOCUMENTATION. ~RENESAS SHALL HA\
Remov
L— @ buildinfo.i PUe EXTENT PERMITTED BY LAW, IN M
Q) Create New Project... DN (OR ANY PERSON OR ENTITY CLAIM
3 WITHOUT LIMITATION, ANY DIRECT, Ct
@ Add Bxisting Project... 5, OTHER ECONOMIC DAMAGE, PROPERT)
alo £ |OF SUCH LOSS, DAMAGES, CLAINS OR
ptions... Alt=
Version Control System »
kSystem Includes> , "Project Inclu
@ Make F7 prsans P R S
B compile Ctri-F7 ppi.h”
@ Rebuild All
& Clean ftions
| oot S——— P Fr—
@ Batch build... F8
Clean Browse Information Eoicions
b PP rran
C-STAT Static Analysis »
x} Build Cul+Break boot yariables (to be accessed by
| oottt ottt 41
© Download and Debug Ctrl=D
» | Debug without Downloading r
At to Running Torget bal variables and functions
Make & Restart Debugger trl+R
o | Y- S rrxsrasean PO
A DR U S Sutean camhli Lanounne routine tahes |
| oownioad | Download active application ed
SFR Setup Download file... ed
Erase memory -
& CMSIS-Pack Manager BTACKLESS Void r_bsp_sottware_del:
Anan Navica Nacerintinn Fila N

Figure 112 IAR EWARM Download File

c. Select out file of the primary project.
e.g. $PROJ_DIRS\..\Blinky_nor_cpu0_primary\Debug\Exe\Blinky_nor_cpu0_primary.out
d. Change the project options setting of the primary project.
d-1. Click Project > Options....
d-2. Click Debugger > Multicore.
d-3. Set the following contents in Asymmetric multicore.
e Simple
»  Partner workspace: the eww file path of the secondary project.
e.g. $PROJ_DIRS\..\Blinky_nor_cpul_secondary\Blinky_nor_cpul_secondary.eww
»  Partner project: Blinky_nor_cpul_secondary
»  Partner configuration: Debug

(Continued on next page)
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e. Click Project > Debug without Downloading of the primary project.

> Blinky_nor_cpu0_primary - Master - IAR Embedded Workbench IDE - Arm 9.50.1
File Edit View | Project | Ijet Tools Window Help

NoRe [ Add Files... Q> b s
Workspace & Add Group... —_
Debug [4] import File List...

Add Project Connection... h products of Renesas Elect

Files Edit Configurations... Hucts are sold pursuant to
& @ Blinky_no! bn and use of Renesas produ
L2 i Flex Soft st bt to Project property right is granted
| _Bulldd ows. Renesas reserves the r

{ || Force figuration E AND DOCUMENTATION IS DELI
| Comp Add CMake Connector » EST EXTENT PERMISSIBLE UNDE
| Gener BRRANTIES OF MERCHANTABILIT
| Progré x| pemove DOCUMENTATION. ~RENESAS SH

L— B buildinfo WU EXTENT PERMITTED BY LAW
DN (OR ANY PERSON OR ENTITY
VITHOUT LIMITATION, ANY DIR
5, OTHER ECONOMIC DAMAGE, P
OF SUCH LOSS, DAMAGES, CLA

1 create New Project...
™ Add Existing Project...

£+ options... ARSFT hassssssssssarsrsssarsassss
Version Control System [ Y
System Includes> , "Projec
@ make F7 harsssssssssssssssssssssnss
B compite Ctri-F7 Bpi.h”
@ Rebuild All | SN ——
& Clean itions
B rrr R TR
& Batch build... F8
,,,,,, arsrrasserraaansaany
Clean Browse Information Vitiions
e
C-STAT Static Analysis »
Lesssassnsassssnesonsrsesss
| € stop Build Ctrl=Break

bbal variables (to be acces

| @ Download and Debug Ctri+D

Joorrsrssrsrrarrrrrnrnranes

|| » Dpebug without Downloading

%) Attach to Running Target

Make & Res

art Debugger
Restart Debugger Ctrl+s

Download

al variables and functions

B rrrErE IR AR IR RAI IS

" |assembly Language routine

b when the Loop exits. The

bgue/epilogue seauences aen

Figure 113 IAR EWARM Debug without Downloading

f.  The secondary project is automatically launched.
0. Run the program of primary project. If the LEDO and LED1 are blinking, proceed to the next step.
h. The primary project in operation, run the program of secondary project.

i.  When exiting Debug and disconnect from the debugger, if debugging is stopped in one of the projects,
either the primary or the secondary, the other will automatically stop as well.

iv) When changing the project and debugging it again, follow these steps.
a. Disable asymmetric multicore setting.
a-1. Click Project > Options....
a-2. Click Debugger > Multicore.
a-3. Select Disable in Asymmetric multicore.
b. Build the primary project.
c. Build the secondary project.
d. Build the primary project again.
e. Debug the projects as the procedure iii.
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. Removed contents for RZ/T2M FSP v1.1.0.
e  Added contents for RZ/T2L.

p.1

Added video contents website link.

p.9

Updated “2.3.1 SEGGER J-Link” section.
e  Updated the FSP version and J-Link version for RZ/T2M and RZ/T2L.

e  Removed the notification that J-Link OB S124 requires the firmware
update to debug RZ/T2M FSP project.

p.10-12

Updated “2.4.1 RSK+RZT2M” section.

e  Added explanation that other boot mode board settings refer to the RSK
User’s Manual.

¢  Modified figure names and added a table title.

p.13-15

Added “2.4.2 RSK+RZT2L” section

p.16-18

Updated “2.5.1 RSK+RZN2L” section.
° Corrected board name.

e  Added explanation that other boot mode board settings refer to the RSK
User’s Manual.

e  Modified figure names and added a table title.

p.23

Updated “4.3 Create a New Project for Blinky” section.
e  Added RSK+RZT2L Board Setting.

p.26

Updated “4.3.5 Where is main()?” section.
e  Corrected product group name.
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p.32 Updated “4.5.4 Change CPSR Register Value” section.
e  Revised description.
e  Added description of how to automatically change CPSR register value.
p.33 Updated “4.6 Run the Blinky Project” section.
e  Removed LEDs working in CPUL1 project.
p.34 Updated “5.3.1 Prerequisites” section.
e  Added note for RZ/T2L patch file.
p.37 Updated “5.3.2 Create a New Project” section.
e  Added RSK+RZT2L Board Setting.
p.50 Updated “5.3.4 Download & Debug the Project” section.
e  Removed LEDs working in CPU1 project.
p.69 Updated “6.5 Adding and Configuring HAL Drivers” section.
e  Added a table title.
p.71-73 | Updated “Appendix. Known Issues” section.
e  Added a table “List of Known Issues”
e  Numbered each issue.
e  Removed issue of adding "r_dsmif" alone
e  Updated issue contents that the BSP properties are sometimes configured
to incorrect configuration
e  Removed Ethernet SELECTOR issue.
p.74-77 Updated “Appendix. Tool Software Limitations” section.
e  Added a table “List of Tool Software Limitations”
e  Numbered each limitation.
e  Added new limitation of applying RZ/T2 FSP v.1.2.0 pack.
p.78 Updated “Appendix. How to Debug FSP Project with Flash Boot Mode” section
e 1. (Both €? studio and EWARM) Insert the loop part in startup.c.
Added e? studio 2023-01 to the table.
e 3. (e2studio ONLY) Apply a macro file for RZ/N2L FSP v1.1.0 xSPI10 x1
boot mode.
e  Added direct download URL of RZ/N2L patch file.
1.05 Jun.30.23 | All Updated documentation for RZ/N2L FSP v1.2.0.
e  Removed contents for RZ/N2L FSP v1.1.0
p.9 Updated “2.3.1 SEGGER J-Link” section.
e Updated the FSP version and e? studio version for RZ/N2L.
p.30 Updated “4.5.2 Debug Steps” section.
e Added description of how to automatically change CPSR register value for
RZ/N2L and e? studio 2023-04.
p.33 Updated “4.5.4 NOTE: Change CPSR Register Value [RZ/T2M, RZ/T2L]”

section.
e  Changed section title to limit the target device
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p.35 Updated “5.3.1 Prerequisites” section.

Removed EWARM Patch for RZ/N2L

p.72-77 Updated “Appendix. Known Issues” chapter.

e  Updated table “List of Known Issues” to add new issues and add N2L as
target device for No.2

e  Added new issue related to BSP configuration when changing board
setting.

e Added new issue related to FSP module FreeRTOS issue.

p.78 Updated “Appendix. Tool Software Limitations” chapter.
e  Removed some limitations regarding breakpoint
p.82 Updated “Appendix. How to Debug FSP Project with Flash Boot Mode”
e  Updated IDE version in the table for including e? studio 2023-04
1.06 Sep.8.23 All Updated documentation for RZ/T2 FSP v1.3.0.

e  Removed contents for RZ/T2 FSP v1.2.0
e  Changed GNU ARM Embedded Toolchain to version 12.2.1.arm-12-24.

p.6 Updated “1.3.2 FSP Documentation” section.

e  Added note for RZ/N2L FSP documentation.
p.26 Updated “4.3.6 Blinky Example Code” section.

. Changed the processing of blinky template code.
p.28 Updated “4.5.2 Debug Steps” section.

e Added reset setting of debug configuration for RAM execution without
flash memory.

p.43 Removed “5.3.2.2 NOTE: Configure IAR EWARM Project [RZ/T2M,
RZ/T2L]” section.
p.44 Updated “5.3.4 Download & Debug the Project” section.

e Changed the processing of blinky template code.

p.68-73 Updated “Appendix. Known Issues” section.
e Updated table “List of Known Issues” to add new issues.
e  Added new issues related to Pins configuration.

e Added new issue of warning message when building “r_gmac” with gcc
compiler.

p.75 Updated “Appendix. Tool Software Limitations” chapter.
e  Added “Smart Configurator” section.
e  Added new limitation of displaying memory region usage

p.80 Updated “Appendix. How to Debug FSP Project with Flash Boot Mode”
section.

e  Removed limitation related to reset when using e? studio

p.82-86 Added “Appendix. How to Erase Flash Memory” section.

1.07 Sep.29.23 | All Updated documentation for RZ/N2L FSP v1.3.0.
e Removed contents for RZ/N2L FSP v1.2.0

RO1AN6434EJ0111 Rev.1.11 Page 116 of 120
Jun.28.24 RENESAS



RZ/T2, RZIN2

Getting Started with Flexible Software Package

Description
Rev. Date Page Summary
p.9 Updated “2.3.1 SEGGER J-Link” section.
Updated the FSP version and e? studio version for RZ/N2L.
p.80 Updated “Appendix. How to Debug FSP Project with Flash Boot Mode”
section.
e  Change the number of items.
e  Removed limitation related to RZ/N2 FSP v1.2.0 and J-ink VV7.80b only
1.08 Jan.22.24 p.6 Corrected document numbers of RSK+RZ/T2L and RSK+RZ/N2L User’s
Manual
p.68-75 | Updated “Appendix. Known Issues” section.
e  Moved the position of FSP Configurations and FSP Modules descriptions
to the beginning of the chapter.
e  Added column “Category” to the List
. Removed category headings (FSP Configurations, Stacks Configuration,
FSP Module, BSP Configuration, ...)
e  Added item “Category” to description of each Known Issues.
e  Grayed out items where issues have been resolved.
e  Added description to workaround of No. 3.
e  Added RZ/T2L as target device to No. 5
e  Added RZ/T2M and RZ/T2L as target device to No. 6
e  Corrected instructions in the code of No. 14.
p.76-80 | Updated “Appendix. Tool Software Limitations” chapter.
e  Added column “Category” to the List
. Removed category headings (Smart Configurator, FSP Smart
Configurator, €? studio, ...)
e  Added item “Category” to description of each Tool Software Limitations.
e  Grayed out items where limitations have been resolved.
p.87-89 | Added “Appendix. How to Change Boot Mode of FSP Project” section.
1.09 Mar.29.24 | All Updated documentation for RZ/T2 FSP v2.0.0.
e  Removed contents for RZ/T2 FSP v1.3.0
p.1 List Target Device separately for each series.
p. 6 Updated “1.3 Related Documentation Files” section.
. List Target Device separately for each series.
p.9 Updated “2.3.1 SEGGER J-Link” section.
e  List Target Device separately for each series in a table.
p. 10-18 | Updated “2.4 RZ/T Series Board Setup” section and added “2.5 RZ/N Series
Board Setup” section.
e  Each series was divided into separate explanatory chapters.
e  Delete unnecessary figure descriptions
p. 20 Updated “4.1 Tutorial Blinky” section.
e  Added description of a multiprocessing.
p. 21 Updated “4.3 Create a New Project for Blinky” section.
e  Added description of a multiprocessing.
p. 26 Updated “4.3.6 Blinky Example Code” section.

e  Updated Blinky code.
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p. 27 Updated ““4.4 Build the Blinky Project” section.
e  Added description of a multiprocessing.
p. 28 Updated “4.5.2 Debug Steps” section.
e  Added description of a multiprocessing.
p. 31 Updated “4.6 Run the Blinky Project” section.
e  Added LED2-3 of RSK+RZ/T2M for CPU1 core.
e  Added descriptions to suspend program execution and exit debug mode.
p. 32 Added “4.7 Debug and Run for Multiprocessing” section.
p. 33 Added “4.8 Import the Project” section.
p. 37 Updated “5.2 Tutorial Blinky” section.
e  Added description of a multiprocessing.
p. 38 Updated “5.3.2 Create a New Project” section.
e  Added description of a multiprocessing.
p. 43 Added “5.3.2.1 NOTE: Configure IAR EWARM Project [Only RZ/N2L]”
section.
p. 43 Updated “5.3.3 Build the Project” section.
. Moved text to “5.3.3.2 Build” section.
p. 43 Added “5.3.3.1 NOTE: Build settings [Only Multiprocessing]” section.
p. 47 Added “5.3.3.2 Build” section.
p. 48 Updated “5.3.4 Download & Debug the Project” section.
e  Added description of a multiprocessing.
e  Added LED2-3 of RSK+RZ/T2M for CPU1 core.
p. 52 Added “5.3.5 Debug for Multiprocessing” section.
p. 53 Added “5.5 Note when debugging in different workspaces” section.
p. 72 Updated “Appendix. Known Issues” chapter.
e  Resolved issues No. 2, No. 6, No. 8, No. 9, No. 10 and No. 11.
3 Removed RZ/T2M and RZ/T2L as target device from No. 12
e  Added new issue No. 13, No. 14, and No. 15.
p. 89 Updated “Appendix. Tool Software Limitations” chapter.
e  Added new limitation No. 9 and No. 10.
p. 105 Added “Appendix. How to Debug FSP multiprocessing projects with Flash
Boot Mode” chapter.
1.10 May.30.24 | All Updated documentation for RZ/N2L FSP v2.0.0.
. Removed contents for RZ/N2L FSP v1.3.0
p.9 Updated “2.3.1 SEGGER J-Link” section.
e List Target Device separately for each series in a table
p.44 Removed “5.3.2.1 NOTE: Configure IAR EWARM Project [Only RZ/N2L]”
section.
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p.44-46 Updated “5.3.3.1 NOTE: Build settings [Only Multiprocessing]” section.
*  Changed the program execution start position setting.

*  Corrected reset setting.

Added images for the settings screen.

P.73 Updated “Appendix. Known Issues” chapter.

e Resolved issue No. 12

e Added RZ/N2L as target device from No.13 and No.14
e  Added new issues No. 16 and No. 17.

p.84 Updated “Appendix. Tool Software Limitations” chapter.
e  Added RZ/N2L as target device from No. 10.
p.97 Updated “Appendix. How to Change Boot Mode of FSP Project” chapter.
*  Added new step 4
p.99 Updated “Appendix. How to Debug FSP multiprocessing projects with Flash

Boot Mode” section.
*  Changed the program execution start position setting.
. Modified explanation of debugging sequence.

111 Jun.28.24 | All Updated documentation for RZ/T2 FSP v2.1.0.
*  Removed contents for RZ/T2 FSP v2.0.0
All Added the RZ/T2ME device as target device.
p.1 Added video links of FSP Configuration.
p.6 Updated “1.3.2 FSP Documentation” section.
e  Added explanation of notes when using FSP software modules.
p.10 Updated “2.4.1.1 Boot Mode” section.
*  Added note for board setting.
p.13 Updated “2.4.2.1 Boot Mode” section.
*  Added note for board setting.
p.15 Added “2.4.3 RSK+RZT2ME” section.
p.16 Updated “2.5.1.1 Boot Mode” section.
*  Added note for board setting.
p.38 Updated “5.3.2 Create a New Project” section.
*  Added IDE Project Type setting for newer versions of FSP SC.
p.43 Updated “5.3.3.1 NOTE: Build settings [Only Multiprocessing]” section.

. Removed Build Actions setting.
*  Added Make before debugging setting.

p.54 Updated “6 FSP Configuration Users Guide” section.
. Updated figures with new tool screens.

P.74 Updated “Appendix. Known Issues” chapter.
. Resolved issues No. 16 and No. 17
. Added new issues No. 18 to No. 24.

p.85 Updated “Appendix. Tool Software Limitations” chapter.
. Removed RZ/T2M and RZ/T2L as target device from No. 6.
*  Added new issue No. 11.
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p.102 Updated “Appendix. How to Change Boot Mode of FSP Project” section.
*  Added note on FSP version changes
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General Precautions in the Handling of Microprocessing Unit and Microcontroller
Unit Products

The following usage notes are applicable to all Microprocessing unit and Microcontroller unit products from Renesas. For detailed usage notes on the products covered by

this document, refer to the relevant sections of the document as well as any technical updates that have been issued for the products.

1. Precaution against Electrostatic Discharge (ESD)
A strong electrical field, when exposed to a CMOS device, can cause destruction of the gate oxide and ultimately degrade the device operation. Steps
must be taken to stop the generation of static electricity as much as possible, and quickly dissipate it when it occurs. Environmental control must be
adequate. When it is dry, a humidifier should be used. This is recommended to avoid using insulators that can easily build up static electricity.
Semiconductor devices must be stored and transported in an anti-static container, static shielding bag or conductive material. All test and
measurement tools including work benches and floors must be grounded. The operator must also be grounded using a wrist strap. Semiconductor

devices must not be touched with bare hands. Similar precautions must be taken for printed circuit boards with mounted semiconductor devices.
2. Processing at power-on

The state of the product is undefined at the time when power is supplied. The states of internal circuits in the LSI are indeterminate and the states of
register settings and pins are undefined at the time when power is supplied. In a finished product where the reset signal is applied to the external reset
pin, the states of pins are not guaranteed from the time when power is supplied until the reset process is completed. In a similar way, the states of pins
in a product that is reset by an on-chip power-on reset function are not guaranteed from the time when power is supplied until the power reaches the

level at which resetting is specified.
3. Input of signal during power-off state

Do not input signals or an 1/0 pull-up power supply while the device is powered off. The current injection that results from input of such a signal or I/O
pull-up power supply may cause malfunction and the abnormal current that passes in the device at this time may cause degradation of internal

elements. Follow the guideline for input signal during power-off state as described in your product documentation.
4. Handling of unused pins

Handle unused pins in accordance with the directions given under handling of unused pins in the manual. The input pins of CMOS products are
generally in the high-impedance state. In operation with an unused pin in the open-circuit state, extra electromagnetic noise is induced in the vicinity of
the LSI, an associated shoot-through current flows internally, and malfunctions occur due to the false recognition of the pin state as an input signal

become possible.
5. Clock signals

After applying a reset, only release the reset line after the operating clock signal becomes stable. When switching the clock signal during program
execution, wait until the target clock signal is stabilized. When the clock signal is generated with an external resonator or from an external oscillator
during a reset, ensure that the reset line is only released after full stabilization of the clock signal. Additionally, when switching to a clock signal

produced with an external resonator or by an external oscillator while program execution is in progress, wait until the target clock signal is stable.
6. Voltage application waveform at input pin

Waveform distortion due to input noise or a reflected wave may cause malfunction. If the input of the CMOS device stays in the area between V.
(Max.) and Vi (Min.) due to noise, for example, the device may malfunction. Take care to prevent chattering noise from entering the device when the

input level is fixed, and also in the transition period when the input level passes through the area between V. (Max.) and Viu (Min.).
7. Prohibition of access to reserved addresses

Access to reserved addresses is prohibited. The reserved addresses are provided for possible future expansion of functions. Do not access these

addresses as the correct operation of the LS| is not guaranteed.
8. Differences between products

Before changing from one product to another, for example to a product with a different part number, confirm that the change will not lead to problems.
The characteristics of a microprocessing unit or microcontroller unit products in the same group but having a different part number might differ in terms
of internal memory capacity, layout pattern, and other factors, which can affect the ranges of electrical characteristics, such as characteristic values,
operating margins, immunity to noise, and amount of radiated noise. When changing to a product with a different part number, implement a system-
evaluation test for the given product.



Notice

1.

10.

11.

12.

13.
14.

(Notel)

Descriptions of circuits, software and other related information in this document are provided only to illustrate the operation of semiconductor products
and application examples. You are fully responsible for the incorporation or any other use of the circuits, software, and information in the design of your
product or system. Renesas Electronics disclaims any and all liability for any losses and damages incurred by you or third parties arising from the use
of these circuits, software, or information.
Renesas Electronics hereby expressly disclaims any warranties against and liability for infringement or any other claims involving patents, copyrights,
or other intellectual property rights of third parties, by or arising from the use of Renesas Electronics products or technical information described in this
document, including but not limited to, the product data, drawings, charts, programs, algorithms, and application examples.
No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights of Renesas Electronics
or others.
You shall be responsible for determining what licenses are required from any third parties, and obtaining such licenses for the lawful import, export,
manufacture, sales, utilization, distribution or other disposal of any products incorporating Renesas Electronics products, if required.
You shall not alter, modify, copy, or reverse engineer any Renesas Electronics product, whether in whole or in part. Renesas Electronics disclaims any
and all liability for any losses or damages incurred by you or third parties arising from such alteration, modification, copying or reverse engineering.
Renesas Electronics products are classified according to the following two quality grades: “Standard” and “High Quality”. The intended applications for
each Renesas Electronics product depends on the product’s quality grade, as indicated below.

"Standard": Computers; office equipment; communications equipment; test and measurement equipment; audio and visual equipment; home

electronic appliances; machine tools; personal electronic equipment; industrial robots; etc.
"High Quality": Transportation equipment (automobiles, trains, ships, etc.); traffic control (traffic lights); large-scale communication equipment; key
financial terminal systems; safety control equipment; etc.

Unless expressly designated as a high reliability product or a product for harsh environments in a Renesas Electronics data sheet or other Renesas
Electronics document, Renesas Electronics products are not intended or authorized for use in products or systems that may pose a direct threat to
human life or bodily injury (artificial life support devices or systems; surgical implantations; etc.), or may cause serious property damage (space
system; undersea repeaters; nuclear power control systems; aircraft control systems; key plant systems; military equipment; etc.). Renesas Electronics
disclaims any and all liability for any damages or losses incurred by you or any third parties arising from the use of any Renesas Electronics product
that is inconsistent with any Renesas Electronics data sheet, user's manual or other Renesas Electronics document.
No semiconductor product is absolutely secure. Notwithstanding any security measures or features that may be implemented in Renesas Electronics
hardware or software products, Renesas Electronics shall have absolutely no liability arising out of any vulnerability or security breach, including but
not limited to any unauthorized access to or use of a Renesas Electronics product or a system that uses a Renesas Electronics product. RENESAS
ELECTRONICS DOES NOT WARRANT OR GUARANTEE THAT RENESAS ELECTRONICS PRODUCTS, OR ANY SYSTEMS CREATED USING
RENESAS ELECTRONICS PRODUCTS WILL BE INVULNERABLE OR FREE FROM CORRUPTION, ATTACK, VIRUSES, INTERFERENCE,
HACKING, DATA LOSS OR THEFT, OR OTHER SECURITY INTRUSION (“Vulnerability Issues”). RENESAS ELECTRONICS DISCLAIMS ANY AND
ALL RESPONSIBILITY OR LIABILITY ARISING FROM OR RELATED TO ANY VULNERABILITY ISSUES. FURTHERMORE, TO THE EXTENT
PERMITTED BY APPLICABLE LAW, RENESAS ELECTRONICS DISCLAIMS ANY AND ALL WARRANTIES, EXPRESS OR IMPLIED, WITH
RESPECT TO THIS DOCUMENT AND ANY RELATED OR ACCOMPANYING SOFTWARE OR HARDWARE, INCLUDING BUT NOT LIMITED TO
THE IMPLIED WARRANTIES OF MERCHANTABILITY, OR FITNESS FOR A PARTICULAR PURPOSE.
When using Renesas Electronics products, refer to the latest product information (data sheets, user's manuals, application notes, “General Notes for
Handling and Using Semiconductor Devices” in the reliability handbook, etc.), and ensure that usage conditions are within the ranges specified by
Renesas Electronics with respect to maximum ratings, operating power supply voltage range, heat dissipation characteristics, installation, etc. Renesas
Electronics disclaims any and all liability for any malfunctions, failure or accident arising out of the use of Renesas Electronics products outside of such
specified ranges.
Although Renesas Electronics endeavors to improve the quality and reliability of Renesas Electronics products, semiconductor products have specific
characteristics, such as the occurrence of failure at a certain rate and malfunctions under certain use conditions. Unless designated as a high reliability
product or a product for harsh environments in a Renesas Electronics data sheet or other Renesas Electronics document, Renesas Electronics
products are not subject to radiation resistance design. You are responsible for implementing safety measures to guard against the possibility of bodily
injury, injury or damage caused by fire, and/or danger to the public in the event of a failure or malfunction of Renesas Electronics products, such as
safety design for hardware and software, including but not limited to redundancy, fire control and malfunction prevention, appropriate treatment for
aging degradation or any other appropriate measures. Because the evaluation of microcomputer software alone is very difficult and impractical, you are
responsible for evaluating the safety of the final products or systems manufactured by you.
Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental compatibility of each Renesas
Electronics product. You are responsible for carefully and sufficiently investigating applicable laws and regulations that regulate the inclusion or use of
controlled substances, including without limitation, the EU RoHS Directive, and using Renesas Electronics products in compliance with all these
applicable laws and regulations. Renesas Electronics disclaims any and all liability for damages or losses occurring as a result of your noncompliance
with applicable laws and regulations.
Renesas Electronics products and technologies shall not be used for or incorporated into any products or systems whose manufacture, use, or sale is
prohibited under any applicable domestic or foreign laws or regulations. You shall comply with any applicable export control laws and regulations
promulgated and administered by the governments of any countries asserting jurisdiction over the parties or transactions.
It is the responsibility of the buyer or distributor of Renesas Electronics products, or any other party who distributes, disposes of, or otherwise sells or
transfers the product to a third party, to notify such third party in advance of the contents and conditions set forth in this document.
This document shall not be reprinted, reproduced or duplicated in any form, in whole or in part, without prior written consent of Renesas Electronics.
Please contact a Renesas Electronics sales office if you have any questions regarding the information contained in this document or Renesas
Electronics products.

“Renesas Electronics” as used in this document means Renesas Electronics Corporation and also includes its directly or indirectly controlled
subsidiaries.

(Note2)

Corporate Headquarters

TOYOSU FORESIA, 3-2-24 Toyosu,
Koto-ku, Tokyo 135-0061, Japan

www.renesas.com

Trademarks

Renesas and the Renesas logo are trademarks of Renesas Electronics
Corporation. All trademarks and registered trademarks are the property of their
respective owners.

“Renesas Electronics product(s)” means any product developed or manufactured by or for Renesas Electronics.

(Rev.5.0-1 October 2020)

Contact information

For further information on a product, technology, the most up-to-date version
of a document, or your nearest sales office, please visit:
www.renesas.com/contact/.

© 2024 Renesas Electronics Corporation. All rights reserved.
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