Thank you for your interest in the Renesas Demonstration Kit for the RL78/G14 MCU, Version 2.1.

Before you get started please first familiarize yourself with this document.

You can also view and print its electronic copy in the following location on the DVD:

“CD DRIVE\QSG\RL78G14_RDK_V2 1_QSG .pdf”.

This document will guide you through all the steps needed to enjoy the full potential of the Kit.
INTRODUCTION

The Renesas RL78/G14 RDK offers a quick and easy way to demonstrate, evaluate and develop embedded applications based on the RL78/G14 MCU and the GainSpan low-power wireless module and embedded platform software for Wi-Fi networks.

The Wi-Fi module firmware runs an embedded Serial-to-Wi-Fi application that includes a wireless connection and a secure network stack to provide wireless connection. The module supports both being a client connected to a Wi-Fi infrastructure or a limited Access Point (AP) for direct connection to PC or Smart phones.

A standalone demo also operates out-of-the-box without any need for a Wi-Fi connection. The LCD display will show Temperature, Light and orientation of the board.

The various demos are selected at power-up by pressing a combination of the three switches to the left of the LCD display (SWITCH 1, SWITCH 2 and SWITCH 3) while toggling the RESET switch.

<table>
<thead>
<tr>
<th>Demo #</th>
<th>SWITCH 1</th>
<th>SWITCH 2</th>
<th>SWITCH 3</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>Standalone + Webserver demo with limited AP mode (default demo)</td>
<td>3</td>
</tr>
<tr>
<td>2</td>
<td>0</td>
<td>1</td>
<td>0</td>
<td>Webserver demo through shared network (provisioning)</td>
<td>4</td>
</tr>
<tr>
<td>3</td>
<td>1</td>
<td>0</td>
<td>1</td>
<td>Webserver demo with client mode</td>
<td>5</td>
</tr>
<tr>
<td>4</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>BugLabs cloud connectivity demo</td>
<td>6</td>
</tr>
<tr>
<td>5</td>
<td>1</td>
<td>0</td>
<td>0</td>
<td>Exosite cloud connectivity demo</td>
<td>7</td>
</tr>
<tr>
<td>6</td>
<td>0</td>
<td>0</td>
<td>1</td>
<td>Micrium µC/Probe demo (limited AP)</td>
<td>8</td>
</tr>
</tbody>
</table>

* 0: Switch is NOT pressed;  1: Switch is pressed
DEMO #1: DEMO + WEBSERVER DEMO WITH LIMITED AP

By simply powering up the board (or by pressing the RESET button), the board starts in mode where the temperature, the light intensity and the orientation of the board (expressed in degrees) are measured and displayed on the LCD.

At the same time, the board operates in “Limited Access Point” mode, where it acts as a limited Access Point (AP) for direct connection to PC or Smart phones via Wi-Fi.

**STEP 1:** Make sure DIP Switch #2 is in position ON, then provide power to the RDK board via the USB cable provided with the board. The Web Server Application is launched. The LCD displays the SSID of the Wireless Network (Limited AP) generated by the RDK, the IP address of the board, and the URL of a web page.

**STEP 2:** Using a PC or Smart Phone, connect to the “RDK_xxxxxx” wireless network (where xxxxxx are the last six digits of the Wi-Fi module MAC address.)

**STEP 3:** Once connected, open a web browser on your PC or Smart Phone and type in the URL displayed on the LCD: “192.168.240.1/rdk.html”

This opens the web page that is served by the onboard web server. It displays the temperature, accelerometer and light sensor data, and also allows ON/OFF control of the LED wheel on the RDK board. (Note that the X, Y and Z data displayed here are accelerometer raw data expressed in ft/s²).

**GainSpan App for iPhone and Android**

The same Demo can be run using an iPhone (or Android*) native application. Download the GainSpan/Renesas iPhone application from the Apple iTunes store. Search for “Renesas”. Connect the iPhone Wi-Fi to the RDK SSID displayed on the LCD and then launch the application downloaded in previous step. The app communicates with the Wi-Fi module and uses mDNS or Service Discovery to find the device. Select “Renesas 1” to connect to the application. The demo has sensor feedback for light, temperature, and the accelerometer. It is also possible to turn the LED wheel on and off.

*Android application still under development.
DEMO #2: PROVISIONING

In this mode, the wireless connection between the webserver onboard the RDK and the client (web browser on PC or Smartphone) is not direct but it is done over a shared Wi-Fi network. The process involves instructing the RDK to connect to a predefined wireless network.

STEP 1: Keeping SW2 pressed, press and release the RESET button. The LCD will display “Limited AP:” an SSID and two URLs:

STEP 2: On a PC or Smartphone, connect to the same SSID (ex. “RDK_1ca795”) displayed in the LCD. Type in the IP address and URL for the provisioning page (“192.168.240.1/prov.html”) using a web browser. This will launch the provisioning page as shown below. Select the “Wireless and Network Configuration → Select Existing Network” to scan for available Access Points in the vicinity.

STEP 3: Choose a suitable Wi-Fi network from the list and click on the Select button, making sure you select the network with the lowest (absolute) Signal Strength (see red circle):

STEP 4: Complete the setup by entering the wireless password, leaving the other fields at default values. Click on “next”, verify the information and click “Save and Apply” on the next screen to confirm the selection.

STEP 5: You should see “WebProv Done” message displayed on the LCD screen. Beware of changes in Wi-Fi network password, because once a board is provisioned, it will keep the data in its non-volatile memory.
STEP 1: After provisioning (follow steps 1-5 on page 4), press the RESET button while holding down BOTH SWITCH1 and SWITCH3 and then release the RESET button (SW1). After the reset, the LCD will display: “Connected to” and the SSID of the Wi-Fi network provisioned (in this case, the Wi-Fi network is “rea-guest-g”) and an IP address (in this case “192.168.1.50”).

STEP 2: Connect your PC or Smartphone to the same Wi-Fi network, open a browser and type in the IP address followed by “/rdk.html” and you will be able to monitor the RDK. You can also use the GainSpan App: You will only need to manually insert the IP Address shown on the LCD display when a “Discovery has failed!” message appears.
**Cloud Connectivity Demos**

The RL78/G14 RDK comes with two Cloud Connectivity demos provided by Renesas' partners, Exosite and BugLabs. These demos turn the RDK into a real-time internet enabled device. Once the board is registered, the device will automatically connect to the cloud platform and share its peripherals using a standardized API. This enables developers to create applications for the evaluation board in a wide variety of languages, without needing to download an SDK or physical access to the device.

**NOTE:** Make sure to follow the “Provisioning” steps (1 thru 5, page 4) before running these demos.

---

### Demo #4: BugLabs Cloud Connectivity Demo

**STEP 1:** After provisioning (follow steps 1-5 on page 4), press the RESET button while holding down all 3 switches.

**STEP 2:** After rebooting, the device will automatically connect and begin producing data. Note the MAC field on the third line, and keep an eye on the screen for any errors.

**STEP 3:** You will need to re-connect your PC or Smartphone to the provisioned wireless access point (steps 1-5 on page 4) with an internet connection. Navigate to “http://bugcommunity.com/rdknext/”. In the first dropdown box, select the YRDKRL78G14 board and click “Go!”. Click on the second dropdown box. You should see the MAC from the LCD screen in the list. Select that entry and click “Go!”

**NOTE:** if you are using IE10, you might see a long number instead of the MAC address: don’t worry, the long address that you are seeing in IE is actually your board’s Swarm Resource ID. IE’s way of parsing data within certain HTML tags is different from Chrome and Firefox, which is why the address displayed in the dropdown menu does not get updated to the MAC address.

**STEP 4:** Once you hit “Go!” you should now see live data from your Renesas device through the cloud. You can monitor the data coming from the board (X, Y, Z Acceleration, Temperature, Light level, Potentiometer value, Buttons status and Sound Level) and Send text to the LCD, turn on and off the LEDs, and send an Audio signal.

**NOTE:** In order to hear the sound, you need to set JP3 jumper to the 1-2 position.

---

In order to switch the LEDs on and off, click on the 0 or 1 value below the LEDx text.
DEMO #5: EXOSITE CLOUD CONNECTIVITY DEMO

STEP 1: Sign up for a Portal Account at https://renesas.exosite.com/signup

STEP 2: Log in, select “Devices” from the menu on the left (1), click on “+ Add Device” at the top right (2) and choose “YRDKRL78G14 with GainSpan Wi-Fi” from the menu (3) and click “CONTINUE”

STEP 3: Enter your GainSpan Wi-Fi module’s MAC address.

STEP 4: Perform the provisioning sequence (steps 1-5 on page 4). You should see the following message displayed on the LCD screen.

STEP 5: Press the RESET button while holding down the RESET button (SW1).

STEP 6: The Display should now show the parameters (TEMP, POT and RSSI) and “CONNECTED” should blink. At this point, you can view the data on the Portal Dashboard by selecting “Dashboards”

To learn more, go to https://renesas.exosite.com/support/home.
What is μC/Probe?
μC/Probe makes it possible to graphically visualize the internal variables of an embedded system with just a few mouse clicks.

What does it do?
μC/Probe is a Windows application that allows you to read and write the memory of any embedded target processor during runtime, and map those values to a set of virtual controls and indicators placed on a graphical dashboard. Absolutely no programming is required: simply drag and drop the graphic components into place, and watch them go.

μC/Probe works with all Renesas embedded processors and requires communication via J-Link, TCP/IP, RS-232, Wi-Fi or Proxies such as the IAR Systems Embedded Workbench or the Eclipse Plugin for μC/Probe.

Running the μC/Probe demo:

STEP 1: Press and hold down SWITCH3 while resetting the board to start the μC/Probe demo application.

STEP 2: The installation DVD for the RL78 RDK includes a demonstration of μC/Probe. Locate the file 'RL78-WiFi-Demo.wspx' (install_directory\Micrium\uC-Probe\Workspaces\) and double-click the icon.

STEP 3: μC/Probe will be launched and will prompt you for the path to the symbol file 'ADKRenesasRL78G14.elf' in your toolchain's output directory or directly from the CD under “Factory_demo” directory.

STEP 4: Make sure you are connected to the RDK WiFi network (steps 1-2, page 4), and that the communication settings in μC/Probe are set to interface via TCP/IP at IP address 192.168.240.1 and port 9930.

STEP 5: Press the ‘Play’ button in μC/Probe and see the LCD display report the data traffic along with the same sensor readings displayed in the μC/Probe data screen.
**SOFTWARE INSTALLATION**

*NOTE: You need an internet connection in order to install the software included in the DVD*

Insert the companion DVD into the DVD drive and proceed with the automatic installation. If the installer doesn't start automatically, look for the "Autorun.exe" file and launch this file manually.

If you don't have a copy of the DVD or want the latest version, please visit the Renesas web site at: [http://www.renesas.com/RDKRL78G14](http://www.renesas.com/RDKRL78G14) and download the latest installation package (ZIP file). Please note that this file is quite large (around 1.6GB). Extract the file into a temporary directory and launch the "Autorun.exe" file located in the root directory.

At this point you will be required to go through a quick registration online. After logging into or creating a new 'MyRenesas' account and obtaining your activation key, proceed with the installation of the software. We recommend you select the default installation options, unless you have some of the software (same versions) already installed or you are an advanced user. Please be aware that the full installation may take up to 1 hour, depending on the performance of your PC.

At the end of the installation, please check the hardware version of your board on the white sticker right above the RL78 MCU; it should report "YRDKRL78-G14 REV 2.1". If you have an older version, please upgrade the RL78G14 firmware to version 3.7 of the factory demo by following the instructions on page 12 (How to restore Factory Demo).

---

**TOOLCHAIN INSTALLATION (USING THE E² STUDIO ECLIPSE-BASED IDE)**

This section of the Quick Start Guide gets you started with the YRDKRL78G14 using both the IAR and GNU toolchain in the e²studio IDE. Make sure you installed the e²Studio IDE as well as the IAR tools or GNU during the software installation.

If you don't have these components installed, please install them now.

During IAR installation, you will be asked to choose between "Size-limited" or "Time-limited" license: with the first, the license will never expire, but the size of your projects will be limited to 16KB; with the second, you will be able to use the tools with no limitations for 30 days.

**Connection:**

On the RDK, ensure the MCU Mode DIP switch, SW5, is set to "DEBUG" (ON, OFF, ON, ON) as shown on the right.

Connect one end of the included USB cable to your computer and the other end to debugger USB connector of the RDK, the debugger USB connector (J19) is above the LCD between the DB9 for the serial port and the power jack.

This is the debug interface and where we power the board from.

The ‘Found New Hardware’ Wizard may appear. Please follow the steps below to install the drivers. Note that administrator privileges are required for Windows® 2000/XP/Vista/Win7 machines.

**Windows® 2000/XP**

Select option ‘No, not this time’ in “Found New Hardware” Wizard dialog, and click <Next> button.

Verify the “Recommended” option is selected and click <Next>.

If using Windows XP, go to step ‘e”; otherwise, click <Next>.

Click <Next> to install the driver.

Click <Finish> to close the wizard.

**Windows Vista / Windows 7 (32 or 64)**

Select “Locate and install driver software (recommended).”

“User Account Control” dialog box will appear. If applicable, enter administrator password and click <OK>.

Driver installation will start. After couple of minutes, a “Windows security” dialog box will appear. Select “install this driver software anyway.”

“Device driver software installed successfully” pop-up will appear in the windows toolbar and installation will complete.
E²STUDIO WORKSPACE AND DEMONSTRATION PROGRAMS FOR GNU

Renesis e²studio (pronounced e-squared studio) is an Eclipse-based integrated development environment. The example projects included on the installation are built using the GNURL78 compiler, a free compiler with no size limitations. The GNURL78 compiler documentation is located under Start > All Programs > GNURL78v13.02-ELF.

1. Make sure you have installed the GNURL78 toolchain that comes with the installation package for this demonstration kit. Before installing, you will be required to obtain a free registration key from KPIT GNU Tools.

2. Launch “Renesas e²studio” from the Start Menu (All Programs > Renesas Electronics e²studio > Renesas e²studio).

3. In the “Workspace Launcher” dialog box, browse to the location of the sample project workspace: “C:\Workspace\YRDKRRL78G14”

4. If the toolchain integration dialog box pops up, select all available toolchains and click “Register.”

5. Close the Welcome window. If you want to re-open this later to explore the e²studio tutorials, it is located under Help > Welcome.

6. You should see an empty workspace. To import the demo projects, navigate to File > Import.

7. Under the “General” folder, select “Existing projects into workspace.” Click “Next.”

8. On the next page, choose “Select archive file:” and browse to “c:\Renesas\workspace\YRDKRRL78G14\e²studio\e²studio_GCC_examples.zip”. Click “Finish.”

9. To focus on a single project, in the “Project Explorer” window, right click on the project you want to use and select “Close Unrelated Projects.” You can re-open any of these projects later by selecting the project in the “Project Explorer” window and chose Open Project from the right click menu.

10. There are instructions detailing how to use each project in the “README.txt” file in the root of each project.

Build the Project
11. In the “Project Explorer” window right click on the project you want to build and select “Build Project”. The build is successful if you see “Build complete” in the console window at the bottom of the screen.

Connect to the Renesis Demonstration Kit
12. Make sure the RDK is connected to your PC and SW5 is set to “DEBUG” (ON, OFF, ON, ON).

13. Highlight the project you are working on and select Run > Debug Configurations or use the shortcut shown to the right.

14. Select the debug configuration for the project you are working on under “Renesas GDB Hardware Debugging” and click “Debug.”

15. If you are asked to switch to the debug perspective, click “Yes.” You can switch back to the C/C++ perspective using the tabs in the upper right corner.

16. You are connected when the status in the bottom right changes from “Launching” to “Suspended.”

Download and Go!
17. To run the code, click the “Resume icon” until the debugger starts running the code

18. Click the “Suspend” icon to stop code execution; e²studio will display the source code at the current program counter.

When you are finished, click “Terminate” to disconnect

To learn more on how to use e²studio, use the help documentation within e²studio located under “Help > Help Contents.”
E² STUDIO WORKSPACE AND DEMONSTRATION PROGRAMS FOR IAR

Renesas e² studio (pronounced e-squared studio) is an Eclipse-based integrated development environment. The example projects included on the installation CD use the IAR plug-in, which allows projects for the IAR compiler to be built and debugged in e² studio. To learn more on how to use e² studio, use the help documentation within e² studio located under Help > Help Contents.

1. Launch 'Renesas e2studio' from the Start Menu (All Programs > Renesas Electronics e2studio > Renesas e2studio).
2. In the “Workspace Launcher” dialog box, browse to a location for your sample project workspace. We suggest “C:\Workspace\YRDKRL78G14”
3. If the toolchain integration dialog box pops up, select all available toolchains and click “Register.”
4. Close the Welcome window. If you want to re-open this later to explore the e² studio tutorials, it is located under Help > Welcome.
5. You should see an empty workspace. To import the demo projects, navigate to File > Import.
6. Under the “General” folder, select “Existing projects into workspace.” Click “Next.”
7. On the next page, choose “Select archive file:” and browse to “c:Renesasworkspace\YRDKRL78G14\e2studio_IAR_examples.zip.” Click “Finish.”
8. Browse to your IAR installation directory. The default installation is C:\Program Files\IAR Systems\Embedded Workbench 6.5 (or for 64 bit Windows C:\Program Files (x86)\IAR Systems\Embedded Workbench 6.5).
9. To focus on a single project, right click on the project folder and select “Close Unrelated Projects.” You can re-open any of these projects later by selecting the project in the Project Explorer and navigating to Project > Open Project from the top menu bar.

Build the Project
10. From the top menu bar, select “Project” then “Build all” (Ctrl+B). The “Build All” builds all open projects in the workspace, and may take over a minute. The build is successful if you see “Build complete” in the console window at the bottom of the screen.
11. You may encounter build errors if your IAR installation directory is different from the one we used to create the projects. If this happens, select the project folder in the Project Explorer window and navigate to “Project > Select Device”. Select any RL78 - G13 device using the Browse button, then switch back to RL78 - G14 > R5F104PJ and click “OK.” Rebuild the project as described in step 10.

Connect to the Renesas Demonstration Kit
12. Make sure the RDK is connected to your PC as outlined in steps 1 and 2.
13. Highlight the project you are working on and select Run > Debug Configurations or use the shortcut shown to the right.
14. Select the debug configuration for the project you are working on under “Renesas GDB Hardware Debugging” and click “Debug” as shown below.
15. If you are asked to switch to the debug perspective, click “Yes.” You can switch back to the C/C++ perspective using the tabs in the upper right corner.
16. You are connected when the status in the bottom right changes from “Launching” to “Suspended.”

Download and Go!
17. To run the code, click the “Resume icon” until the debugger starts running the code.
18. Click the “Suspend” icon to stop code execution. e² studio will display the source code at the current program counter.
19. When you are finished, click “Terminate” to disconnect.
**HOW TO RESTORE FACTORY DEMO**

Follow these steps in case you need to restore the Factory Demos into the RL78/G14.

**STEP 1:** Make sure you installed e²studio and imported the GCC examples ([Follow steps 1-10 on page 10](#)).

**STEP 2:** Set the Dip-Switch SW5.2 to “OFF” as explained on [page 9](#), connect the board to the USB and open e²studio.

**STEP 2:** Select “FactoryDemoReload” project and right click on it and select “Debug As” ➔ “1 Debug-only”

**STEP 3:** Once the code is downloaded inside the RL78 Flash, note the source window warning about No source available (ignore that) and hit the “Resume” button (F8) or simply, set SW5.2 to ON and reset the board.

---

**SEGGER REAL TIME OPERATING SYSTEM DEMO FOR IAR**

*embOS - Real Time Operating System*

embOS is a priority-controlled real time operating system, designed to be used as foundation for the development of embedded real-time applications. It is a zero interrupt latency, high-performance RTOS that has been optimized for minimum memory consumption in both RAM and ROM, as well as high speed and versatility.

**Main features**

- Preemptive scheduling: Guarantees that of all tasks in READY state, the one with the highest priority executes, except for situations where priority inversion applies.
- Zero interrupt latency time.
- No configuration needed.

To know more go to: [www.segger.com/embos.html](http://www.segger.com/embos.html)

Download Free Demo for RL78G14RDK here: [www.segger.com/renesas-rl78-rdk.html](http://www.segger.com/renesas-rl78-rdk.html)
Partners Information

Micrium's Firmware demos, uC/Probe, RTOS and TCP/IP services, visit [www.micrium.com](http://www.micrium.com)
GainSpan Modules: [www.gainspan.com](http://www.gainspan.com)
Exosite Cloud, visit [www.exosite.com](http://www.exosite.com) or [www.renesas.exosite.com](http://www.renesas.exosite.com)
BugLabs Cloud, visit [www.buglabs.net](http://www.buglabs.net)

Support

RenesasRulz : [renesasrulz.com/app_kits_and_demos_boards/rdk_rl78g14/](http://renesasrulz.com/app_kits_and_demos_boards/rdk_rl78g14/)

Disclaimer

By using this Renesas Demonstration Kit (RDK), the user accepts the following terms. The RDK is not guaranteed to be error free, and the User assumes the entire risk as to the results and performance of the RDK. The RDK is provided by Renesas on an “as is” basis without warranty of any kind whether express or implied, including but not limited to the implied warranties of satisfactory quality, fitness for a particular purpose, title and non-infringement of intellectual property rights with regard to the RDK. Renesas expressly disclaims all such warranties. Renesas or its affiliates shall in no event be liable for any loss of profit, loss of data, loss of contract, loss of business, damage to reputation or goodwill, any economic loss, any reprogramming or recall costs (whether the foregoing losses are direct or indirect) nor shall Renesas or its affiliates be liable for any other direct or indirect special, incidental or consequential damages arising out of or in relation to the use of this RDK, even if Renesas or its affiliates have been advised of the possibility of such damages.

Precautions

This Renesas Demonstration Kit is only intended for use in a laboratory environment under ambient temperature and humidity conditions. A safe separation distance should be used between this and any sensitive equipment. Its use outside the laboratory, classroom, study area or similar such area invalidates conformity with the protection requirements of the Electromagnetic Compatibility Directive and could lead to prosecution.

The product generates, uses, and can radiate radio frequency energy and may cause harmful interference to radio communications. However, there is no guarantee that interference will not occur in a particular installation. If this equipment causes harmful interference to radio or television reception, which can be determined by turning the equipment off or on, you are encouraged to try to correct the interference by one or more of the following measures:
- Ensure attached cables do not lie across the equipment
- Reorient the receiving antenna
- Increase the distance between the equipment and the receiver
- Connect the equipment into an outlet on a circuit different from that which the receiver is connected
- Power down the equipment when not in use
- Consult the dealer or an experienced radio/TV technician for help

NOTE: It is recommended that wherever possible shielded interface cables should be used.

The product is potentially susceptible to certain EMC phenomena. To mitigate against them it is recommended that the following measures be undertaken:
- The user is advised that mobile phones should not be used within 10m of the product when in use.
- The user is advised to take ESD precautions when handling the equipment.

The Renesas Demonstration Kit does not represent an ideal reference design for an end product and does not fulfill the regulatory standards for an end product.
Ecosystem

Renesas Ecosystem page: [www.renesas.com/ecosystem](http://www.renesas.com/ecosystem)

A forum and community site to share technical information, questions and opinions with others who use Renesas devices.

[http://www.renesas.com/partner_information/index.jsp](http://www.renesas.com/partner_information/index.jsp)
The Alliance Partner program provides users of Renesas products the latest information on the wide variety of products, services, and other solutions from our partners.

Create a My Renesas account to use our tool download services, receive e-mail newsletters and update notifications, and take advantage of our other services.