Introduction
This application note describes the basic usage of the RZ/A2M Smart Configurator (hereafter called the Smart Configurator), which is an e² studio plug-in tool.

References to the e² studio integrated development environment in this application note apply to the following versions.
• e² studio 7.3.0 and later

Target Devices and Compilers
Refer to the following URL for the range of supported devices and compilers:
https://www.renesas.com/smart-configurator

Contents

1. Overview ........................................................................................................................................3
  1.1 Purpose ........................................................................................................................................3
  1.2 Features .......................................................................................................................................3
  1.3 RZ/A2M Software Core Package ..............................................................................................3

2. Creating a Project ..........................................................................................................................4

3. Operating the Smart Configurator ...............................................................................................7
  3.1 Procedure for Operations ...........................................................................................................7
  3.2 Displaying the Smart Configurator Perspective .........................................................................8
  3.3 Window ......................................................................................................................................9
    3.3.1 Project Explorer ...................................................................................................................10
    3.3.2 Smart Configurator view ....................................................................................................11
    3.3.3 MCU Package view .............................................................................................................12
    3.3.4 MMU Layout view ...............................................................................................................13
    3.3.5 Console view ......................................................................................................................14
    3.3.6 Configuration Problems view ............................................................................................14

4. Setting of Peripheral Modules .....................................................................................................15
  4.1 Clock Settings ............................................................................................................................15
  4.2 Component Settings ...................................................................................................................16
    4.2.1 Downloading a Software Core Package ............................................................................16
    4.2.2 Adding software component ..............................................................................................19
    4.2.3 Removing a software component .......................................................................................20
    4.2.4 Setting a Software Component ..........................................................................................21
    4.2.5 Changing the name for a software component ....................................................................22
    4.2.6 Changing the resource for a software component .............................................................23
4.2.7 Changing the version of Software Component .......................................................... 25
4.3 Pin Settings .......................................................................................................................... 27
4.3.1 Changing the pin assignment of a software component ............................................. 28
4.3.2 Resolving pin conflicts .................................................................................................. 29
4.3.3 Assigning pins using the MCU Package view .............................................................. 31
4.3.4 Exporting pin settings .................................................................................................. 32
4.3.5 Importing pin settings .................................................................................................. 32
4.4 MMU Settings .................................................................................................................... 33
4.4.1 Add the page table ....................................................................................................... 33
4.4.2 Remove the page table .............................................................................................. 34
4.4.3 Edit the page table ...................................................................................................... 34
4.4.4 Import the memory maps ............................................................................................ 35
4.4.5 Export the memory maps ............................................................................................ 35

5. Generating Source Code ..................................................................................................... 36
5.1 Outputting Generated Source Code ................................................................................ 36
5.2 Configuration of Generated Files and File Names .......................................................... 37

6. Managing Conflicts ............................................................................................................. 38
6.1 Resolving pin conflicts .................................................................................................... 38
6.2 Missing Dependencies ...................................................................................................... 40

7. Generating Reports ........................................................................................................... 41
7.1 Report on All Configurations ........................................................................................ 41
7.2 Configuration of Pin Function List and Pin Number List (in csv Format) ..................... 42
7.3 Image of MCU Package ................................................................................................... 42

8. Help .................................................................................................................................. 43
8.1 Help .................................................................................................................................. 43

9. Documents for Reference .................................................................................................. 44

Website and Support ............................................................................................................. 45
1. Overview

1.1 Purpose

This User’s Guide describes the basic usage of the Smart Configurator and the e² studio integrated development environment, including the procedure for creating a project.

Refer to the User’s Manual of the e² studio for how to use the e² studio.

1.2 Features

The Smart Configurator is a utility for combining software to meet your needs. It handles the following three functions to support the embedding of drivers, middleware and RTOS from Renesas in your systems: importing software package and making pin settings.

1.3 RZ/A2M Software Core Package

The RZ/A2M Software Core Package consists of driver, middleware and RTOS. By using this software package, you can easily use the functions in RZ/A2M.
2. Creating a Project

The following describes the procedure for creating a C project using the Smart Configurator.

1. Start e² studio and launch a workspace. Select [File] → [New] → [C/C++ Project] to activate the project creation wizard.

![Figure 2-1 Creating a New Project](image)

2. In the project creation wizard, please operate until you see the [Select Coding Assistant Settings].
(3) In the [Select Coding Assistant settings] dialog box, select the [Smart Configurator] checkbox and click on the [Finish] button.

![Smart Configurator Settings Dialog](image)

**Figure 2-2** Selecting the Coding Assistant Tool

(4) Wait for completion of project creation.

![Smart Configurator File Generation](image)

**Figure 2-3** Smart Configurator Starts File Generation
After a new C Project is successfully created, the project will be opened in the Smart Configurator perspective.

Figure 2-4  Smart Configurator Perspective
3. Operating the Smart Configurator

3.1 Procedure for Operations

Figure 3-1 shows the procedure for using the Smart Configurator to set up peripheral modules and build the project with the e² studio. Refer to the related documents on the e² studio for the operation of the e² studio.

![Diagram of Procedure for Operations]

Starting the e² studio

Creating and loading an e² studio project

Displaying the Smart Configurator perspective

Setting of peripheral modules

Refer to chapter 4, Setting of Peripheral Modules.

Setting of pins

Refer to section 4.3, Pin Settings.

Generating source code

Refer to chapter 5, Generating Source Code.

Generating reports

Refer to chapter 7, Generating Reports.

Building

Execution and debugging

Figure 3-1 Procedure for Operations
3.2 Displaying the Smart Configurator Perspective

To fully utilize Smart Configurator features, ensure that the Smart Configurator perspective is opened. If it is not opened, select [Window] → [Perspective] → [Open perspective] → [Other…] to open the [Open Perspective] dialog box.

In the [Open Perspective] dialog box, select [Smart Configurator] and click on the [Open] button, change to the Smart Configurator perspective.

Figure 3-2 Opening the Smart Configurator Perspective
3.3 Window

The configuration of the Smart Configurator perspective is shown in Figure 3-3, Smart Configurator Perspective.

Figure 3-3 Smart Configurator Perspective

1) Project Explorer
2) Smart Configurator view
3) MCU Package view
4) MMU Layout view
5) Console view
6) Configuration Problems view
3.3.1 Project Explorer

The structure of the folders in the project is displayed in a tree form.

![Project Explorer](image)

**Figure 3-4 Project Explorer**

When the Project Explorer is not opened, select [Window] → [Show View] → [Other] from the e² studio menu and select [General] → [Project Explorer] on the opened [Show View] dialog box.
3.3.2 Smart Configurator view

The Smart Configurator view consists of six pages: [Overview], [Clocks], [Components], [Pins] and [MMU]. Select a page by clicking on a tab; the displayed page will be changed.

![Smart Configurator View](image)

**Figure 3-5 Smart Configurator View**

When this view is not opened, right-click on the project file (*.scfg) in the Project Explorer and select [Open] from the context menu.
3.3.3 MCU Package view

The states of pins are displayed on the figure of the MCU package. The settings of pins can be modified from here.

![MCU Package View](image)

**Figure 3-6 MCU Package View**

When this view is not opened, select [Renesas Views] → [Smart Configurator] → [MCU Package] from the e² studio menu.
3.3.4 MMU Layout view

The MMU Layout view displays memory map reflected from setting by MMU page.

![Figure 3-7 MMU Layout View](image)

When this view is not opened, select [Renesas Views] → [Smart Configurator] → [MMU Layout] from the e² studio menu.
3.3.5 Console view
The Console view displays details of changes to the configuration made in the Smart Configurator or MCU Package view.

![Figure 3-8 Console View](image)

When this view is not opened, select [Window] → [Show View] → [Other] from the e² studio menu and select [General] → [Console] on the opened [Show View] dialog box.

3.3.6 Configuration Problems view
The Configuration Problems view displays the details of conflicts between pins.

![Figure 3-9 Configuration Problems View](image)

When this view is not opened, select [Renesas Views] → [Smart Configurator] → [Configuration Problems] from the e² studio menu.
4. Setting of Peripheral Modules

You can select peripheral modules from the Smart Configurator view.

4.1 Clock Settings

You can set the system clock on the [Clocks] tabbed page. The settings made on the [Clocks] page are used for software package.

Follow the procedure below to update the device setting in the project properties.

1. Select the MD_CLK input level and set the input clock frequency.
2. Select the dividing ratio on divider 1.
3. Select the dividing ratio on divider 2.
4. Select the clock source for output clock by multiplexer switches.
5. Check the output clock frequency.

![Clock settings](image-url)
4.2 Component Settings

Drivers and middleware can be combined as software components on the [Components] page. Added components are displayed in the Components tree at the left of the page.

![Components tree](image)

**Figure 4-2  [Components] Page**

### 4.2.1 Downloading a Software Core Package

You need to download a desired Software Core Package from the Renesas Electronics website. The Software Core Package can be used as a software component after downloading.

1. Click on the ![Add component] icon.

![Adding a Software Component](image)

**Figure 4-3  Adding a Software Component**
(2) Click the [Download more software components] link in the [Software Component Selection] page of the [New Component] dialog box to download a software core package.

![Figure 4-4 Downloading More Software Components](image)

Figure 4-4 Downloading More Software Components

Note: This service requires login to "My Renesas". If you have not logged in, the following dialog box will prompt you to log in. To register as a new user, click on the [About My Renesas] button.

![Figure 4-5 Login to My Renesas](image)

Figure 4-5 Login to My Renesas
(3) Select the checkbox of the required module in the [Core Software Download] dialog box.

(4) Click on [Browse...] to select the location where the downloaded module is to be stored.

(5) Click on [Download] to start downloading the selected core software.

Figure 4-6  Downloading a core software
4.2.2 Adding software component

(1) Click on the [Add component] icon.

(2) Select components from the list in the [Software Component Selection] page of the [New Component] dialog box (e.g. r_scifa). Two or more components can be selected by clicking with the Ctrl key pressed.

(3) Click on [Next].

(4) Set a configuration name of adding software component and change a resource in the [Add new configuration for selected component] page of the [New Component] dialog box.

(5) Click on [Finish].

The selected software component will be added to the components tree.

By code generating, the source files are added to the project.
4.2.3 Removing a software component

Follow the procedure below to remove a software component from a project.

(1) Select a software component from the Components tree.

(2) Click on the [ ] (Remove component) icon.

Figure 4-9 Removing a Software Component

The selected software component will be removed from the Components tree.

This operation will also remove the source files generated for this component from the Project Explorer.
4.2.4 Setting a Software Component

Follow the procedure below to set up a software component.

(1) Select a software component from the Component tree (e.g. r_scifa).

(2) Setting a software component and select a pin function on configure page.

![Software component configuration](image)

**Figure 4-10 Settings for scifa**

The software component setting will be generated to configuration header files.

(When r_scifa, generate to r_scifa_drv and sc_cfg.h)

The pin function setting will be generated to GPIO configuration header files.

(Generate to r_gpio_drv.h and sc_cfg.h)
4.2.5 Changing the name for a software component

Follow the procedure below to change the name for a software component.

1. Right-click on a software component.
2. Select [Rename] from the context menu.
3. Enter a new name in the [Rename Configuration] dialog box (e.g. change scifa0 to scifa1).
4. Click on [OK].

![Image of renaming a software component]

Figure 4-11 Renaming the Configuration

![Image of the Rename Configuration dialog box]

Figure 4-12 Enter the component name
4.2.6 Changing the resource for a software component

The Smart Configurator enables you to change the resource for a software component (e.g. from SCIFA0 to SCIFA1). Compatible settings can be ported from the current resource to the new resource selected.

Follow the procedure below to change the resource for an existing software component.

1. Right-click on a software component (e.g. scifa0).
2. Select [Change resource] from the context menu.
3. Select a new resource (e.g. SCIFA1) in the [Resource Selection] dialog box.
4. The [Next] button will be active; click on it.

![Figure 4-13 Changing the Resource](image)

![Figure 4-14 Components Page – Selecting a New Resource](image)
(5) Configuration settings will be listed in the [Configuration setting selection] dialog box.

(6) Check the portability of the settings.

(7) Select whether to use the listed or default settings.

(8) Click on [Finish].

Figure 4-15 Checking the Settings of the New Resource
4.2.7 Changing the version of Software Component

Follow the procedure below to change the version for an existing software component.

(1) Right-click on a software component (e.g. scifa0).
(2) Select [Change version] from the context menu.
(3) Select a new version (e.g. 1.01) in the [Version Selection] dialog box.
(4) Click on [Next].
(5) Check the portability of the settings and click in [Finish].

![Information of changing items](image)

Figure 4-18  Information of changing items

(6) Click on [Yes].

![Confirm to change version](image)

Figure 4-19  Confirm to change version

(7) Software component version is changing and code is generated automatically.
4.3 Pin Settings

The [Pins] page is used for assigning pin functions. You can switch the view by clicking on the [Pin Function] and [Pin Number] tabs. The [Pin Function] list shows the pin functions for each of the peripheral functions, and the [Pin Number] list shows all pins in order of pin number.

![Figure 4-20: [Pins] Page ([Pin Function])](image1)

![Figure 4-21: [Pins] Page ([Pin Number])](image2)
4.3.1 Changing the pin assignment of a software component

The Smart Configurator assigns pins to the software components added to the project. Assignment of the pins can be changed on the [Pins] page.

This page provides two lists: Pin Function and Pin Number.

Follow the procedure below to change the assignment of pins to a software component in the Pin Function list.

1. Click on [Show by Hardware Resource or Software Components] to switch to the component view.
2. Select the target software component (e.g. scifa1).
3. Click the [Enabled] header to sort by pins used.
4. In the [Assignment] column on the [Pin Function] list, change the pin assignment (e.g. change from P7_5 to PJ_4).
5. Assignment of a single pin or multiple pins that belong to the same peripheral channel can be changed by clicking on the [Next group of pins for the selected resource] button.

![Figure 4-22 Pin Settings – Assigning Pins on the [Pin Function] List](image)

The [Pins] page can assign to pin not add a software component.
4.3.2 Resolving pin conflicts

If there is a pin conflict, an error mark √ will appear on the tree and [Pin Function] list.

![Figure 4-23 Pin Conflicts]

The detailed information regarding conflicts is displayed in the Configuration Problems view.

![Figure 4-24 Pin Conflict Messages]
To resolve a conflict, right-click on the node with an error mark on the tree and select [Resolve conflict].

![Resolving Pin Conflicts](Figure 4-25 Resolving Pin Conflicts)

The pins of the selected node will be re-assigned to other pins.
4.3.3 Assigning pins using the MCU Package view

The Smart Configurator visualizes the pin assignment in the MCU Package view. You can save the MCU Package view as an image file, rotate it, and zoom in to and out from it.

Follow the procedure below to assign pins in the MCU Package view.

1. Zoom in to the view by clicking the [Zoom in] button or scrolling the view with the mouse wheel.
2. Right-click on the target pin.
3. Select the signal to be assigned to the pin.
4. The color of the pins can be customized through [Preference Setting...].

![Assigning Pins Using the MCU Package View](image)

**Figure 4-26 Assigning Pins Using the MCU Package View**

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Pin Icon" /></td>
<td>Not assigned</td>
</tr>
<tr>
<td><img src="image" alt="Assigned Input Icon" /></td>
<td>Assigned (Input)</td>
</tr>
<tr>
<td><img src="image" alt="Assigned Output Icon" /></td>
<td>Assigned (Output)</td>
</tr>
<tr>
<td><img src="image" alt="Assigned Input/Output Icon" /></td>
<td>Assigned (Input/Output)</td>
</tr>
</tbody>
</table>

**Table 4-1 Pin icons**
4.3.4 Exporting pin settings

The pin settings can be exported for later reference. Follow the procedure below to export the pin settings.

1. Save the `{ProjName}.scfg` file.
2. Click on the [Export board setting] button on the [Pins] page.
3. Select the output location and specify a name for the file to be exported.

The exported XML file can be imported to another project having the same device part number.

![Figure 4-27  Exporting Pin Settings to an XML File](image)

The Smart Configurator can also export the pin settings to a CSV file. Click on the [Save the list to .csv file] button on the [Pins] page.

4.3.5 Importing pin settings

To import pin settings into the current project, click on the [Import board setting] button and select the XML file that contains the desired pin settings. After the settings specified in this file are imported to the project, the settings will be reflected in the [Pin configuration] page.

![Figure 4-28  Importing Pin Settings from an XML File](image)
4.4 MMU Settings

The [MMU] page is used for assigning memory maps. Memory map settings are displayed in the [Page Table] list in virtual address order.

![MMU page screen shot](image)

**Figure 4-29 MMU page**

4.4.1 Add the page table

To add the page table, click on the [Add] button and set it in the dialog box opened.

![Add page table dialog box](image)

**Figure 4-30 Add the page table**
4.4.2 Remove the page table

To remove the page table, select the remove page line and click on the [Remove] button. Two or more page tables can be selected by clicking with the Ctrl key pressed.

![Figure 4-31 Remove the page table](image)

4.4.3 Edit the page table

To edit the page table, select the edit page line and click on the [Edit] button. Edit the memory map in the dialog box opened and click on the [OK] button. Setting is reflecting to the page tables.

![Figure 4-32 Edit the page table](image)
4.4.4 Import the memory maps

To import the memory map to current project, click on the [Import] button. Select the memory map file in the dialog box opened.

You will be using default setting, check the [Use default template] and select a template.

You will be using custom memory map, check the [Use custom template] and select a template.

Click on the [OK] button, setting is reflecting to the page tables.

![Import Memory Map dialog](image)

Figure 4-33 Import the memory maps

---

4.4.5 Export the memory maps

The memory maps can be exported for later reference. Follow the procedure below to export the memory maps:

1. Save the `{ProjName}.scfg` file.
2. Click on the [Export] button on the [MMU] page.
3. Select the output location and specify a name for the file to be exported.

The exported XML file can be imported to another project having the same device part number.

![Export MMU page](image)

Figure 4-34 Export the memory maps
5. Generating Source Code

5.1 Outputting Generated Source Code

Output a source file for the configured details by clicking on the [ ] (Generate Code) button in the Smart Configurator view.

The Smart Configurator generates a source file in `<ProjectDir>\generate\drivers` and `<ProjectDir>\generate\sc_drivers` folders and updates the source file list in the Project Explorer.

![Figure 5-1 Generating a Source File](image1)

![Figure 5-2 Source Files in the Project Explorer](image2)
### 5.2 Configuration of Generated Files and File Names

Figure 5-3, Configuration of Generated Files and File Names, shows the folders and files output by the Smart Configurator.

#### Figure 5-3  Configuration of Generated Files and File Names

<table>
<thead>
<tr>
<th>Folder</th>
<th>File</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>r_cpg</td>
<td>r_cpg_drv_sc.cfg.h</td>
<td>This folder is always generated. It contains header files and source files commonly used by clock pulse generator.</td>
</tr>
<tr>
<td>r_cpg</td>
<td>r_cpg_drv_sc.cfg.h</td>
<td>These files are always generated. It contains macro definitions for setting clock pulse generator. [Clock] page setting is reflecting to this file.</td>
</tr>
<tr>
<td>r_gpio</td>
<td>r_gpio_drv_sc.cfg.h</td>
<td>This folder is always generated. It contains header files and source files commonly set by pin assignment.</td>
</tr>
<tr>
<td>r_gpio</td>
<td>r_gpio_drv_sc.cfg.h</td>
<td>This file is always generated. It contains macro definitions for setting pin assignment. [Pins] page setting is reflecting to this file.</td>
</tr>
<tr>
<td>r_mmu</td>
<td>r_mmu_drv_sc.cfg.h</td>
<td>This folder is always generated. It contains header files and source files commonly used by memory management unit.</td>
</tr>
<tr>
<td>r_mmu</td>
<td>r_mmu_drv_sc.cfg.h</td>
<td>This file is always generated. It contains macro definitions for memory management unit. [MMU] page setting is reflecting to this file.</td>
</tr>
<tr>
<td>sc_drivers</td>
<td></td>
<td>This folder is always generated. It contains header files and source files commonly used by software components.</td>
</tr>
<tr>
<td>r_ostm</td>
<td>r_ostm_drv_sc.cfg.h</td>
<td>This folder is always generated. It contains header files and source files commonly used by OS timer.</td>
</tr>
<tr>
<td>r_ostm</td>
<td>r_ostm_drv_sc.cfg.h</td>
<td>This file is always generated. It contains macro definitions for OS timer. osmt_reserved setting in [Components] page is reflecting to this file.</td>
</tr>
<tr>
<td>r_xxx</td>
<td>r_xxx_drv_sc.cfg.h</td>
<td>This folder is always generated. It contains header files and source files commonly used by added software components.</td>
</tr>
<tr>
<td>r_xxx</td>
<td>r_xxx_drv_sc.cfg.h</td>
<td>This file is always generated. It contains macro definitions for added software components. software component setting in [Components] page is reflecting to this file.</td>
</tr>
</tbody>
</table>
6. Managing Conflicts

6.1 Resolving pin conflicts

If there is a pin conflict, an error mark \( \times \) will appear on the tree and [Pin Function] list.

![Figure 6-1 Pin Conflicts](image)

The detailed information regarding conflicts is displayed in the Configuration Problems view.

![Figure 6-2 Pin Conflict Messages](image)
To resolve a conflict, right-click on the node with an error mark on the tree and select [Resolve conflict].

![Figure 6-3 Resolving Pin Conflicts](image)

The pins of the selected node will be re-assigned to other pins.
6.2 Missing Dependencies

When user adds a component which is dependent on other components, the dependencies should also be added. For example, when a user adds the component `r_scifa`, an error message with the 🟥 mark will be displayed in the Configuration Problems view to inform the user that the dependent component `r_cbuffer` is needed.

![Figure 6-4 Error of Missing Dependency](image)

![Figure 6-5 Missing Dependency Messages](image)

To fix this error, add the dependent component into the project.
7. Generating Reports

The Smart Configurator generates a report on the configurations that the user works on. Follow the procedure below to generate a report.

7.1 Report on All Configurations

A report is output in response to clicking on the [Generate Report] button in the Smart Configurator view.

![Figure 7-1 Output of a Report on the Configuration](image1)

![Figure 7-2 Dialog Box for Output of a Report](image2)
7.2 Configuration of Pin Function List and Pin Number List (in csv Format)

A list of the configuration of pin functions and pin numbers (whichever is selected at the time) is output in response to clicking on the [Save the list to .csv file] button on the [Pins] page of the Smart Configurator view.

![Figure 7-3 Output of a List of Pin Functions or Numbers (in csv Format)](image)

7.3 Image of MCU Package

An image of the MCU package is output in response to clicking on the [Save Package View to external image file] button of the [MCU Package] view.

![Figure 7-4 Outputting a Figure of MCU Package](image)
8. Help

8.1 Help

Refer to the help system from the e² studio menu for detailed information on the Smart Configurator.

![Help Menu](image)

**Figure 8-1** Help Menu

The help system can also be activated from the [Overview information] page.

![Quick Start](image)

**Figure 8-2** Quick Start
9. Documents for Reference

User’s Manual: Hardware
Obtain the latest version of the manual from the Renesas Electronics website.

Technical Update/Technical News
Obtain the latest information from the Renesas Electronics website.

User’s Manual: Development Environment
e2 studio v7.0 Integrated Development Environment User’s Manual: Getting Started Guide (R20UT4374)
RZ/A2M Group Software Core Package (R01AN4583)
(Obtain the latest version from the Renesas Electronics website.)
Website and Support

Renesas Electronics Website
http://www.renesas.com/

Inquiries
http://www.renesas.com/contact/

All trademarks and registered trademarks are the property of their respective owners.
# Revision History

<table>
<thead>
<tr>
<th>Rev.</th>
<th>Date</th>
<th>Page</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.00</td>
<td>Feb 1, 2019</td>
<td>-</td>
<td>First edition issued</td>
</tr>
<tr>
<td>1.01</td>
<td>Sep 13, 2019</td>
<td>4</td>
<td>Modify the missing chapter number</td>
</tr>
<tr>
<td></td>
<td></td>
<td>8</td>
<td>Adjust the position of red box in Figure 2-1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>21</td>
<td>Adjust the position of red box in Figure 4-10</td>
</tr>
</tbody>
</table>
1. Handling of Unused Pins
   Handle unused pins in accordance with the directions given under Handling of Unused Pins in the manual.
   — The input pins of CMOS products are generally in the high-impedance state. In operation with an unused pin in the open-circuit state, extra electromagnetic noise is induced in the vicinity of LSI, an associated shoot-through current flows internally, and malfunctions occur due to the false recognition of the pin state as an input signal become possible. Unused pins should be handled as described under Handling of Unused Pins in the manual.

2. Processing at Power-on
   The state of the product is undefined at the moment when power is supplied.
   — The states of internal circuits in the LSI are indeterminate and the states of register settings and pins are undefined at the moment when power is supplied.
   In a finished product where the reset signal is applied to the external reset pin, the states of pins are not guaranteed from the moment when power is supplied until the reset process is completed.
   In a similar way, the states of pins in a product that is reset by an on-chip power-on reset function are not guaranteed from the moment when power is supplied until the power reaches the level at which resetting has been specified.

3. Prohibition of Access to Reserved Addresses
   Access to reserved addresses is prohibited.
   — The reserved addresses are provided for the possible future expansion of functions. Do not access these addresses; the correct operation of LSI is not guaranteed if they are accessed.

4. Clock Signals
   After applying a reset, only release the reset line after the operating clock signal has become stable. When switching the clock signal during program execution, wait until the target clock signal has stabilized.
   — When the clock signal is generated with an external resonator (or from an external oscillator) during a reset, ensure that the reset line is only released after full stabilization of the clock signal. Moreover, when switching to a clock signal produced with an external resonator (or by an external oscillator) while program execution is in progress, wait until the target clock signal is stable.

5. Differences between Products
   Before changing from one product to another, i.e. to a product with a different part number, confirm that the change will not lead to problems.
   — The characteristics of Microprocessor unit or Microcontroller unit products in the same group but having a different part number may differ in terms of the internal memory capacity, layout pattern, and other factors, which can affect the ranges of electrical characteristics, such as characteristic values, operating margins, immunity to noise, and amount of radiated noise. When changing to a product with a different part number, implement a system-evaluation test for the given product.
Notice

1. Descriptions of circuits, software and other related information in this document are provided only to illustrate the operation of semiconductor products and application examples. You are fully responsible for the incorporation or any other use of the circuits, software, and information in the design of your product or system. Renesas Electronics disclaims any and all liability for any losses and damages incurred by you or third parties arising from the use of these circuits, software, or information.

2. Renesas Electronics hereby expressly disclaims any warranties against and liability for infringement or any other claims involving patents, copyrights, or other intellectual property rights of third parties, by or arising from the use of Renesas Electronics products or technical information described in this document, including but not limited to, the product data, drawings, charts, programs, algorithms, and application examples.

3. No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights of Renesas Electronics or others.

4. You shall not alter, modify, copy, or reverse engineer any Renesas Electronics product, whether in whole or in part. Renesas Electronics disclaims any and all liability for any losses or damages incurred by you or third parties arising from such alteration, modification, copying or reverse engineering.

5. Renesas Electronics products are classified according to the following two quality grades: “Standard” and “High Quality”. The intended applications for each Renesas Electronics product depends on the product’s quality grade, as indicated below.
   - “Standard”: Computers; office equipment; communications equipment; test and measurement equipment; audio and visual equipment; home electronic appliances; machine tools; personal electronic equipment; industrial robots; etc.
   - “High Quality”: Transportation equipment (automobiles, trains, ships, etc.); traffic control (traffic lights); large-scale communication equipment; key financial terminal systems; safety control equipment; etc.

6. Unless expressly designated as a high reliability product or a product for harsh environments in a Renesas Electronics data sheet or other Renesas Electronics document, Renesas Electronics products are not intended or authorized for use in products or systems that may pose a direct threat to human life or bodily injury (artificial life support devices or systems; surgical implantations; etc.), or may cause serious property damage (space system; undersea repeaters; nuclear power control systems; aircraft control systems; key plant systems; military equipment; etc.). Renesas Electronics disclaims any and all liability for any damages or losses incurred by you or any third parties arising from the use of any Renesas Electronics product that is inconsistent with any Renesas Electronics data sheet, user’s manual or other Renesas Electronics document.

7. Although Renesas Electronics endeavors to improve the quality and reliability of Renesas Electronics products, semiconductor products have specific characteristics, such as the occurrence of failure at a certain rate and malfunction under certain use conditions. Unless designated as a high reliability product or a product for harsh environments in a Renesas Electronics data sheet or other Renesas Electronics document, Renesas Electronics products are not subject to radiation resistance design. You are responsible for implementing safety measures to guard against the possibility of bodily injury, injury or damage caused by fire, and/or danger to the public in the event of a failure or malfunction of Renesas Electronics products, such as safety design for hardware and software, including but not limited to redundancy, fire control and malfunction prevention, appropriate treatment for aging degradation or any other appropriate measures. Because the evaluation of microcomputer software alone is very difficult and impractical, you are responsible for evaluating the safety of the final products or systems manufactured by you.

8. Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental compatibility of each Renesas Electronics product. You are responsible for carefully and sufficiently investigating applicable laws and regulations that regulate the inclusion or use of controlled substances, including without limitation, the EU RoHS Directive, and using Renesas Electronics products in compliance with all these applicable laws and regulations. Renesas Electronics disclaims any and all liability for any damages or losses occurring as a result of your noncompliance with applicable laws and regulations.

9. Renesas Electronics products and technologies shall not be used for or incorporated into any products or systems whose manufacture, use, or sale is prohibited under any applicable domestic or foreign laws or regulations. You shall comply with any applicable export control laws and regulations promulgated and administered by the governments of any countries asserting jurisdiction over the parties or transactions.

10. It is the responsibility of the buyer or distributor of Renesas Electronics products, or any other party who distributes, disposes of, or otherwise sells or transfers the product to a third party, to notify such third party in advance of the contents and conditions set forth in this document.

11. This document shall not be reprinted, reproduced or duplicated in any format, in whole or in part, without prior written consent of Renesas Electronics.

12. Please contact a Renesas Electronics sales office if you have any questions regarding the information contained in this document or Renesas Electronics products.

(Note 1) “Renesas Electronics” as used in this document means Renesas Electronics Corporation and also includes its directly or indirectly controlled subsidiaries.

(Note 2) “Renesas Electronics product(s)” means any product developed or manufactured by or for Renesas Electronics.

Revised: 4.0-1  November 2017

SALES OFFICES
Renesas Electronics Corporation

Refer to "http://www.renesas.com" for the latest and detailed information.

Renesas Electronics Corporation

TOYOSU FORRESIA, 3-2-4 Toyosu, Koto-ku, Tokyo 135-0061, Japan

Renesas Electronics America Inc.

1001 Murphy Ranch Road, Milpitas, CA 95035, U.S.A.
Tel: +1-408-434-5511

Renesas Electronics Canada Limited

9521 Yonge Street, Suite 8309 Richmond Hill, Ontario Canada L4C 9T3
Tel: +1-905-237-2004

Renesas Electronics Europe GmbH

Amstellaan 10, 40472 Düsseldorf, Germany
Tel: +49-211-6503-0, Fax: +49-211-6503-1327

Renesas Electronics (China) Co., Ltd.

Room 101-701, Floor 1, Building 7, Yard No. 7, 8th Street, Shangdi, Haidian District, Beijing 100085, China
Tel: +86-10-8235-1155, Fax: +86-10-8235-7679

Renesas Electronics (Shanghai) Co., Ltd.

Unit 301, Tower A, Central Tower, 555 Langao Road, Putuo District, Shanghai 200333, China
Tel: +86-21-2228-8888, Fax: +86-21-2228-9699

Renesas Electronics Hong Kong Limited

Unit 1601-1611, 16/F., Tower 2, Grand Century Place, 193 Prince Edward Road West, Mongkok, Kowloon, Hong Kong
Tel: +852-2265-6688, Fax: +852-2886-9022

Renesas Electronics Taiwan Co., Ltd.

13F., No. 363, Fu Shing North Road, Taipei 10543, Taiwan
Tel: +886-2-8175-9605, Fax: +886 2-8175-9670

Renesas Electronics Singapore Pte. Ltd.

80 Bendemeer Road, Unit I05-02 Huygens Innovation Centre, Singapore 339949
Tel: +65-6213-0200, Fax: +65-6213-0300

Renesas Electronics Malaysia Sdn Bhd

Unit No 3A-1 Level 3A Tower 8 UOA Business Park, No 1 Jalan Pengaturcara U1/51A, Seksyen U1, 40150 Shah Alam, Selangor, Malaysia
Tel: +60-3-9222-1298, Fax: +60-3-9222-1290

Renesas Electronics India Pvt. Ltd.

No 777C, 100 Feet Road, HAL 2nd Slage, Indiranagar, Bangalore 560 038, India
Tel: +91-80-67208700

Renesas Electronics Korea Co., Ltd.

17F., KAMCO Yongje Tower, 262, Gangnam-daero, Gangnam-gu, Seoul 06265 Korea
Tel: +82-2-558-3737, Fax: +82-2-558-3339

© 2019 Renesas Electronics Corporation. All rights reserved.

Colophon 8.0