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Notice

All information included in this document is current as of the date this document isissued. Such information, however, is
subject to change without any prior notice. Before purchasing or using any Renesas Electronics products listed herein, please
confirm the latest product information with a Renesas Electronics sales office. Also, please pay regular and careful atention to
additional and different information to be disclosed by Renesas Electronics such as that disclosed through our website.

Renesas Electronics does not assume any liability for infringement of patents, copyrights, or other intellectual property rights
of third parties by or arising from the use of Renesas Electronics products or technical information described in this document.
No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights
of Renesas Electronics or others.

Y ou should not alter, modify, copy, or otherwise misappropriate any Renesas Electronics product, whether in whole or in part.

Descriptions of circuits, software and other related information in this document are provided only to illustrate the operation of
semiconductor products and application examples. Y ou are fully responsible for the incorporation of these circuits, software,
and information in the design of your equipment. Renesas Electronics assumes no responsibility for any lossesincurred by
you or third parties arising from the use of these circuits, software, or information.

When exporting the products or technology described in this document, you should comply with the applicable export control
laws and regulations and follow the procedures required by such laws and regulations. Y ou should not use Renesas
Electronics products or the technology described in this document for any purpose relating to military applications or use by
the military, including but not limited to the devel opment of weapons of mass destruction. Renesas Electronics products and
technology may not be used for or incorporated into any products or systems whose manufacture, use, or sale is prohibited
under any applicable domestic or foreign laws or regulations.

Renesas Electronics has used reasonable care in preparing the information included in this document, but Renesas Electronics
does not warrant that such information is error free. Renesas Electronics assumes no liability whatsoever for any damages
incurred by you resulting from errorsin or omissions from the information included herein.

Renesas Electronics products are classified according to the following three quality grades: “Standard”, “High Quality”, and
“Specific”. The recommended applications for each Renesas Electronics product depends on the product’ s quality grade, as
indicated below. Y ou must check the quality grade of each Renesas Electronics product before using it in aparticular
application. You may not use any Renesas Electronics product for any application categorized as “ Specific” without the prior
written consent of Renesas Electronics. Further, you may not use any Renesas Electronics product for any application for
which it is not intended without the prior written consent of Renesas Electronics. Renesas Electronics shall not bein any way
liable for any damages or losses incurred by you or third parties arising from the use of any Renesas Electronics product for an
application categorized as “ Specific” or for which the product is not intended where you have failed to obtain the prior written
consent of Renesas Electronics. The quality grade of each Renesas Electronics product is “ Standard” unless otherwise
expressly specified in a Renesas Electronics data sheets or data books, etc.

“Standard”: Computers; office equipment; communications equipment; test and measurement equipment; audio and visual
equipment; home electronic appliances, machine tools; personal electronic equipment; and industrial robots.
“High Quality”: Transportation equipment (automobiles, trains, ships, etc.); traffic control systems; anti-disaster systems; anti-
crime systems; safety equipment; and medical equipment not specifically designed for life support.
“Specific”: Aircraft; aerospace equipment; submersible repeaters; nuclear reactor control systems; medical equipment or
systems for life support (e.g. artificial life support devices or systems), surgical implantations, or heathcare
intervention (e.g. excision, etc.), and any other applications or purposes that pose adirect threat to human life.
Y ou should use the Renesas Electronics products described in this document within the range specified by Renesas Electronics,
especialy with respect to the maximum rating, operating supply voltage range, movement power voltage range, heat radiation
characteristics, installation and other product characteristics. Renesas Electronics shall have no liability for malfunctions or
damages arising out of the use of Renesas Electronics products beyond such specified ranges.
Although Renesas Electronics endeavors to improve the quality and reliability of its products, semiconductor products have
specific characteristics such as the occurrence of failure at a certain rate and malfunctions under certain use conditions. Further,
Renesas Electronics products are not subject to radiation resistance design. Please be sure to implement safety measures to
guard them against the possibility of physica injury, and injury or damage caused by fire in the event of the failure of a
Renesas Electronics product, such as safety design for hardware and software including but not limited to redundancy, fire
control and malfunction prevention, appropriate treatment for aging degradation or any other appropriate measures. Because
the evaluation of microcomputer software alone is very difficult, please evaluate the safety of the final products or system
manufactured by you.

Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental
compatibility of each Renesas Electronics product. Please use Renesas Electronics products in compliance with all applicable
laws and regulations that regulate the inclusion or use of controlled substances, including without limitation, the EU RoHS
Directive. Renesas Electronics assumes no liability for damages or losses occurring as aresult of your noncompliance with
applicable laws and regulations.

This document may not be reproduced or duplicated, in any form, in whole or in part, without prior written consent of Renesas
Electronics.

Please contact a Renesas Electronics sdes office if you have any questions regarding the information contained in this
document or Renesas Electronics products, or if you have any other inquiries.

(Note 1) “Renesas Electronics’ as used in this document means Renesas Electronics Corporation and also includes its majority-

owned subsidiaries.

(Note 2) “Renesas Electronics product(s)” means any product developed or manufactured by or for Renesas Electronics.




To all our customers

Regarding the change of names mentioned in the document, such as Hitachi
Electric and Hitachi XX, to Renesas Technology Corp.

The semiconductor operations of Mitsubishi Electric and Hitachi were transferred to Renesas
Technology Corporation on April 1st 2003. These operations include microcomputer, logic, analog
and discrete devices, and memory chips other than DRAMSs (flash memory, SRAMs €tc.)
Accordingly, although Hitachi, Hitachi, Ltd., Hitachi Semiconductors, and other Hitachi brand
names are mentioned in the document, these names have in fact all been changed to Renesas
Technology Corp. Thank you for your understanding. Except for our corporate trademark, logo and
corporate statement, no changes whatsoever have been made to the contents of the document, and
these changes do not constitute any alteration to the contents of the document itself.

Renesas Technology Home Page: http://www.renesas.com

Renesas Technology Corp.
Customer Support Dept.
April 1, 2003
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Cautions

Keep safety first in your circuit designs!

1

Renesas Technology Corporation puts the maximum effort into making semiconductor products better
and more reliable, but there is aways the possibility that trouble may occur with them. Trouble with
semiconductors may lead to personal injury, fire or property damage.

Remember to give due consideration to safety when making your circuit designs, with appropriate
measures such as (i) placement of substitutive, auxiliary circuits, (ii) use of nonflammable material or
(iii) prevention against any malfunction or mishap.

Notes regarding these materials

1

These materials are intended as areference to assist our customersin the selection of the Renesas
Technology Corporation product best suited to the customer's application; they do not convey any
license under any intellectual property rights, or any other rights, belonging to Renesas Technology
Corporation or athird party.

Renesas Technology Corporation assumes no responsibility for any damage, or infringement of any
third-party'srights, originating in the use of any product data, diagrams, charts, programs, algorithms, or
circuit application examples contained in these materials.

All information contained in these materials, including product data, diagrams, charts, programs and
algorithms represents information on products at the time of publication of these materials, and are
subject to change by Renesas Technology Corporation without notice due to product improvements or
other reasons. It istherefore recommended that customers contact Renesas Technology Corporation
or an authorized Renesas Technology Corporation product distributor for the latest product information
before purchasing a product listed herein.

The information described here may contain technical inaccuracies or typographical errors.

Renesas Technology Corporation assumes no responsibility for any damage, liability, or other loss
rising from these inaccuracies or errors.

Please also pay attention to information published by Renesas Technology Corporation by various
means, including the Renesas Technology Corporation Semiconductor home page
(http://www.renesas.com).

When using any or al of theinformation contained in these materials, including product data, diagrams,
charts, programs, and algorithms, please be sure to evaluate all information as atota system before
making afinal decision on the applicability of the information and products. Renesas Technology
Corporation assumes no responsibility for any damage, liability or other loss resulting from the
information contained herein.

Renesas Technology Corporation semiconductors are not designed or manufactured for usein adevice
or system that is used under circumstances in which human lifeis potentially at stake. Please contact
Renesas Technology Corporation or an authorized Renesas Technology Corporation product distributor
when considering the use of a product contained herein for any specific purposes, such as apparatus or
systems for transportation, vehicular, medical, aerospace, nuclear, or undersea repeater use.

The prior written approval of Renesas Technology Corporation is necessary to reprint or reproduce in
whole or in part these materials.

If these products or technologies are subject to the Japanese export control restrictions, they must be
exported under a license from the Japanese government and cannot be imported into a country other
than the approved destination.

Any diversion or reexport contrary to the export control laws and regulations of Japan and/or the
country of destination is prohibited.

Please contact Renesas Technology Corporation for further details on these materials or the products
contained therein.
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Cautions

Hitachi neither warrants nor grants licenses of any rights of Hitachi’s or any third party

'S

patent, copyright, trademark, or other intellectual property rights for information contained in
this document. Hitachi bears no responsibility for problems that may arise with third party’s

rights, including intellectual property rights, in connection with use of the information
contained in this document.
Products and product specifications may be subject to change without notice. Confirm

that

you have received the latest product standards or specifications before final design, purchas

or use.

Hitachi makes every attempt to ensure that its products are of high quality and reliability.

However, contact Hitachi's sales office before using the product in an application that
demands especially high quality and reliability or where its failure or malfunction may

directly threaten human life or cause risk of bodily injury, such as aerospace, aeronautics,

nuclear power, combustion control, transportation, traffic, safety equipment or medica
equipment for life support.

Design your application so that the product is used within the ranges guaranteed by H
particularly for maximum rating, operating supply voltage range, heat radiation
characteristics, installation conditions and other characteristics. Hitachi bears no

itachi

responsibility for failure or damage when used beyond the guaranteed ranges. Even within

the guaranteed ranges, consider normally foreseeable failure rates or failure modes ir
semiconductor devices and employ systemic measures such as fail-safes, so that the
equipment incorporating Hitachi product does not cause bodily injury, fire or other
consequential damage due to operation of the Hitachi product.

. This product is not designed to be radiation resistant.

No one is permitted to reproduce or duplicate, in any form, the whole or part of this
document without written approval from Hitachi.

. Contact Hitachi's sales office for any questions regarding this document or Hitachi
semiconductor products.




Preface

This tutorial will introduce you to the basic usage of the Hitachi Embedded Workshop 2
(hereafter referred to &EW). The tutorial describes a series of usage such as how to invoke the
HEW, how to create and modify a project, how to build a program, and how to invoke a
simulator/debugger from the HEW. For details on the HEW, the C/C++ compiler, assembler,
optimizing linkage editor, and simulator/debugger, refer to the following manuals.

. H8S, H8/300 Series Hitachi Embedded Workshop 2 User’'s Manual

. H8S, H8/300 Series C/C++ Compiler, Cross Assembler, or Optimizing Linkage Editor
User’s Manual

For details on the H8S, H8/300 Series CPU, refer to a programming manual or a hardware
manual of the corresponding CPU.

Microsoft’, Windows, Windows' 98, Windows M& Windows NT, Windows 2000and
Windows’ XP are registered trademarks of Microsoft Corporation in the United States and/or in
other countries.

All other brand or product names used in this manual are trademarks or registered trademarks c
their respective companies or organizations.
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This tutorial is written assuming that all the tools included in H8S, H8/300 Series C/C++
compiler Package are installed.

If “->" is written inside [ and ], the left hand side of “->” means the menu title and the right hand
side of “->" means a menu option of the menu. For example, in figure 1, the menu option [Exit]
in the [File] menu is described as [File->Exit].
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Figure 1 A Menu of the HEW
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Section 1 Invoking the HEW

After the installation of the HEW, the installer creates a folder whose name is [Hitachi
Embedded Workshop 2] in the [Program] folder of the [Start] menu of the Winddmwthe

[Hitachi Embedded Workshop 2] folder, short cuts of the HEW support files will be registered.
The contents of the [Start] menu and its submenus differ depending on your installation.

E HIM To HEW Project Converter
[ts] Hitachi Callwalker
{63 Hitachi Embedded ;
’ |'_5‘lf_5j Hitachi Embedded ‘Workshop 2 Help

@ Hitachi Embedded “Workshop 2 Read Me
Settings ﬁ Internet Explarer @ Hitachi Mapvisw

& Progiams = Accessoies
Startup
Lizzumenis E Command Prormpt

Windaws NT Espl
Find B Wihaton b B ) Oniine Manuals [SuperH] -English(D1 03]

Administrative Tools [Commaon] — F Eg SuperH RISC engine Simulator Debugager Help
15, Hitachi Embedded Workshop 2 ﬁ ToolUninstaller
Bun... =, Startup

Help

Shut Down...

Figure 1.1 Invoking the HEW from the [Start] Menu

RENESAS



If you click [Hitachi Embedded Workshop 2] from the menu, the HEW will be invoked and the
[Welcome!] dialog box (figure 1.2) will be displayed. You can open the project promptly without
the [Welcome!] dialog box if you change the setting via [Tools->Options]. For details of this
setting, refer to chapter 6, “Customizing the Environment”, of the Hitachi Embedded Workshop
2 User’s Manual.

Welcomel I

— Ophions;
(% Create a new project workspace Facel I
€ Uper & recent prject Workspase, £dministration... |

— | B

=

E‘ " Browse to another project workspace

Figure 1.2 Welcome! Dialog Box

If you use the HEW for the first time or if you want to work on a new project, select the [Create
a new project workspace] radio button and click [OK]. If you want to work on an existing
project, select the [Open a recent project workspace] or [Browse to another project workspace]
radio button and click [OK].

In this tutorial, select the [Create a new project workspace] radio button and click [OK].

10
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Section 2 Creating a Project

2.1 Creating a New Workspace

When you have selected the [Create a new project workspace] radio button and clicked [OK] on
the [Welcome!] dialog box, the [New Project Workspace] dialog box (figure 2.1), which is used
to create a new workspace and project, will be launched. You will specify a workspace name
(When a new workspace is created, the project name is the same as the default), a CPU family,
project type, and so on, on this dialog box.

Enter “tutorial”, for example, in the [Workspace Name] field, then the [Project Name] field will
show “tutorial” and the [Directory] field will show “c:\hew?2\tutorial”. If you want to change the
project name, enter a new project name manually in the [Project Name] field. If you want to
change the directory used for the new workspace, click the [Browse...] button and specify a
directory, or enter a directory path manually in the [Directory] field.

11
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Figure 2.1 New Project Workspace Dialog Box

Table 2.1 Items of [Project type:]

Items of [Project type:] Description

Application

This project is used to create a program that includes the initial

routine files written in C/C++ or assembly language.

Assembly Application

This project is used to create a program that includes the initial

routine files written in assembly language.

Demonstration

This project is used to create the program for demonstration

written in C/C++ or assembly language.

Empty Application

This project is used to set up the toolchain (no file is to be

generated).

Library This project is used to create a library file (no file is to be
generated).

12
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2.2 Selecting the Target CPU

When you click [OK] on the [New Project Workspace] dialog box, the project generator will be
invoked. Start by selecting the CPU that you will be using. CPU types shown in the [CPU Type:]
list are classified into the CPU series shown in the [CPU Series] list.

The selected items in the [CPU Series:] list box and the [CPU Type:] list box specify the files to
be generated. Select the CPU type of the program to be developed. If the CPU type which you
want to select is not displayed in the [CPU Type:] list, select a CPU type with similar hardware
specifications or select [Other].

Clicking [Next>] moves to the next display. Clicking [<Back] moves to the previous display or
the previous dialog box. Clicking [Finish] opens the [Summary] dialog box. Clicking [Cancel]
returns the display to the [New Project Workspace] dialog box. [<Back], [Next>], [Finish], and
[Cancel] are common buttons of all the wizard dialog boxes.

In this tutorial, select [2600] in the [CPU Series:] list and select [2655] in the [CPU Type:] list
(figure 2.2). Then click [Next >].

Mew Project -5tep 1 EHE |

"Which CPU do you want to uge for
this project?

CPL Senes:
200

2000
300H
300

3000

CPU Tope:

2633 =]

2633F
2636

2638
2641
2642
2B43
2653

I‘?Fi?l'l ;I
< Back " [ et = I Finizh | Cancel |

Figure 2.2 Selecting the Target CPU (Step 1)
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2.3 Option Setting
Clicking the [Next>] button on the Step-1 screen opens the dialog box shown in figure 2.3.
On this screen, you can specify options common to all project files.

Settings for these options can be modified in correspondence with the CPU series selected in s
1 screen. To change the option settings after a project has been created, select the CPU page
from the [Options -> Hitachi H8S, H8/300 Standard Toolchain] menu item of the HEW window.

Click the [Next>] button without changing the setting. The Step-3 screen will be displayed.

Mew Project -5tep 2 EHE |

Specify global options.
7 perating Mode: MHarmal -

Srdress Spane | "I
tderit of Library: II:u:u:Ie Size "’I
Stack calculation: IMedium "I

[1Change number of parameter regiz
[ Treat double az float

[ |Pasz struct parameter via register
[JFPazz 4-byte parameter/return walu
[1U=e t, throw and catch of C++

[ |Enable/dizable runtime tppe inform

1] | i
< Back " Mext = I Firizh | Cancel |

Figure 2.3 Option Setting (Step 2)
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2.4 Setting the Contents of Files to be Generated
Click the [Next>] button on the Step-2 screen to display the screen shown in figure 2.4.
On this screen, specify information that is necessary to generate files.

If [Use I/O Library] is checked, the standard 1/O library can be used. Specify the number of 1/O
streams to be used simultaneously in the [Number of I/O Streams] box.

If [Use Heap Memory] is checked, the function sbrk() for heap area management will be
generated. Specify the number of bytes of the heap area in the [Heap Size:] edit box.

Select whether or not to generate a sample code for the main function from the [Generate main|
Function] drop-down list.

If [I/O Register Definition Files] is checked, an I/O register definition file, which is written in C
language, can be created. Then select whether or not to generate a sample code for the progra
that makes initial settings of the 1/O registers from the [Generate Hardware Setup Function]
drop-down list.

In this tutorial, check [Use 1/O Library] and click [Next >].

NOTE

If you want to use an existing main function, uncheck [Generate main() Function], add the file of
the function after generating the project. If the name of the function differs from main, change
the caller of the function in resetprg.c. For the contents of such sample files as a vector table
definition file or 1/O register definition file that will be generated by the project generator, check
the description in the hardware manual for the target CPU.
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Mew Project -Step 3

Whét'kiﬂﬂ of initialization routine
wiould you like o create?

Mumber of 10 Streams:
3

v Use Hee!p Memary
Heap Size: IH'42EI

Generate main(] Function

IE gource file j

W 10 Register Defirition Files

Gernerate Hardware Setup
Function

INn:nne j

< _Eal_:k' |

New> | Finsh |

Cancel |

Figure 2.4 Setting the Contents of Files to be Generated (Step 3)
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2.5 Setting the Standard Library

The screen shown in figure 2.5 is displayed when the [Next>] button is clicked in the Step-3
screen. This screen is used to set details of compilation by the Cétpiler. To change the
standard library configuration after a project has been created, select the CPU page in [Options
> Hitachi H8S, H8/300 Standard Toolchain] of the HEW. In this tutorial, click the [Next>]

button without changing the settings.

Mew Project -5tep 4 EHE |

— Librany :

[Wlruntime © rurkine routines
[w] iz Performs memon allocation and
[Jctwpe.k s Handles and checks charac)
[ Imath.h : Perfarms numenical caloulatiol
[ Imathf.k : Perfarms nurmenical caloulatic
[Jstdarg.h : Supparts access b variable)
[w] ztdic b Performs inputdoutput handliv
[w] ztdlib b . Perfarms C program standard
[w] ztring. b Perfarmz string comparizan, «©
[Jiog[EC++] : Perfarms input/autput proe
[ Joomplex(EC++] : Perfarmz comples nu
[Jztrina[EC++] : Performs string manipuls

KN B

Enableal |  Disableall |

< Back " [ et = I Finizh | I;ancel |

Figure 2.5 Setting the Standard Library (Step 4)
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2.6  Setting the Stack Area

The screen shown in figure 2.6 is displayed when the [Next>] button is clicked in the Step-4
screen.

This screen is used to specify the stack area.

The initial value of the stack area differs depending on [CPU Type:] selected in the Step-1
screen. To change the stack size after a project has been created, select the [Project -> Edit
Project Configuration] menu item of the HEW window. In this tutorial, since 2655 has been
selected for [CPU Type:] in the Step-1 screen, [Stack Pointer Address:] is set to H'FBFO and
[Stack Size:] is set to H'200. In this tutorial, click the [Next>] button without changing the
settings.

Mew Project -5tep 5 EHE |

YWhat are the stack settings?

Stack Painter Address:
[power-on rezet]

HFEFT

Stack Size:
IH'EDEI

< Back " [ et = I Finizh | Cancel

Figure 2.6 Setting the Stack Area (Step 5)

The stack area is defined in stacksct.h that is generated by the HEW. If stacksct.h has been ed
in an editor, its modification after you have selected the [Project -> Edit Project Configuration]
menu item of the HEW will not be available.
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2.7 Setting the Vector

Clicking the [Next>] button in the Step-5 screen displays the screen shown in figure 2.7.
In this screen, a vector is specified.

If [Vector Table Definition Files] is checked, the HEW creates a vector table definition file.

The [Handler] column of [Vector Handlers:] displays the handler program name, and the
[Vector] column displays the vector description. To change the handler program, click the name
of the handler program to be changed, and enter a new name.

If the handler name in the [Vector Handlers:] list is changed, the HEW does not create the rese
program (resetprg.c).

In this tutorial, click the [Next>] button without changing the settings.

Mew Project -5tep 6 EHE |

what supporting files would you
like ta create?

¥ ifector Definition Files

Yector Handlers:

Handler | Wector
PowerOM_Feset 0 Pawer On
b arual_Rezet 1 Manual Re

KN =

< Back " [ et = I Finizh | Cancel

Figure 2.7 Setting the Vector (Step 6)
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2.8 Setting the Target System for Debugging

When the [Next>] button is clicked in the Step-6 screen, the screen shown in figure 2.8 is
displayed. This screen is used to specify the target system for debugging. Select (check) the
target for debugging from the list under [Targets:]. Selection of no target or of multiple targets is

allowed.

In this tutorial, select [H8S/2600N Simulator] and then click the [Next>] button.

Mew Project -Step 7 E Ed |
— Targets :
[ IHE5 /26008 Simulator
EO0MN Sirnulator
1] | ]
Target type : |2EEIEI j
< Back " Mest > I Finizh | I;ancel |

Figure 2.8 Setting the Target System for Debugging (Step 7)

If you change [Target type:], you can specify the other target system for debugging.
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2.9 Setting the Debugger Options

When the [Next>] button is clicked in the Step-7 screen, the screen shown in figure 2.9 is
displayed. This screen is used to specify the optional settings for the selected target for
debugging.

By default, the HEW creates two configurations, [Release] and [Debug]. When a target for
debugging is selected, the HEW creates another configuration (The name of the target is
included). The name of the configuration can be modified in [Configuration name:]. Options to
do with the target for debugging are displayed under [Detail options:]. To change the settings,
select [Item] and then click [Modify]. When items for which modification is not possible are
selected, [Modify] remains grayed even if [Item] is selected.

In this tutorial, click the [Next>] button without changing the settings.

Mew Project -5tep 8 EHE |

T arget name :

[HES /2600M Simulator

Canfiguration name ;
| SimDebug_HBS-2600M

— D etail options
[tem | Setting
Simulator /0 1
Simulator 140 addr. | 0=0
Buz mode 1]

_ it |

< Back " et » I Finizh | Cancel |

Figure 2.9 Setting the Debugger Options (Step 8)
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2.10 Changing the File Names to be Created

When the [Next>] button is clicked in the Step-8 screen, the screen shown in figure 2.10 is
displayed.

The screen displays a list of files created by HEW according to the previous settings. The [File
Name] column in the list shows a file name, [Extension] shows an extension, and [Description]
shows the description of a file. The file name can be changed. To change a file name, select it
clicking it and change it to a new file name.

In this tutorial, click the [Finish] button without changing the settings. When the button is
clicked, the [Summary] dialog box will be displayed.

Mew Project -S5tep 9 E E3 |

The following source files will be

generated:
File Hame | Eut... | Dezcription
dbsct o Setting of B.R Sectian
laalel A1 Program of Low level
lowsrc o Program of 140 Strear
zbrk, s Frogram of zbrk,
indefine b Drefinition of [/0 Beagiz
intprg o [nkerrupt Programm
resetprg o Reset Program
tutonal s b ain Program
lowzre h Header file of 1/0 Stre
zhrk, h Header file of bk file
stackact h Setting of Stack area
1] | R

< Back I flEpt | Finizh | Cancel |

Figure 2.10 Changing the File Names to be Created (Step 9)

NOTE
A file with an extension “h” or “inc” (shown in the [Extension] column) is an include
file. If you change the file name of an include file, the file name at the include directive
have to be modified.
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2.11  Confirming Settings (Summary Dialog Box)

The project generator shows a list of generated files on the [Summary] dialog box (figure 2.11).
Confirm the contents of the dialog box and click [OK].

When [Generate Readme.txt as a summary file in the project directory] checkbox is checked, th
project information displayed on the [Summary] dialog box will be stored in the project directory
under the text file name "Readme.txt".

Summary Ei
Project Summary:
-------- PROJECT GEMERATOR ------- =
PROJECT MAME : tutarial
FROJECT DIRECTORY : C:AHE W 2htutarialhtutarial
CPU SERIES : 2600
CPL T+'FE : 26585
TOOLCHAIM MARE Hitachi H85 H8/300 Standard T
TOOLCHAIM WERSION : 5020

GEMERATIOM FILES : S
CAHE W 2hkutonialstutorialhdbsct. o
Setting of B.R Section
C:AHEYW 2hkutanialstutarialslowlv] s
Frogram of Low lewvel
CAHEW 2htutanialstutarialslowsre. o
Program of 1/0 Stream
C:AHEW 2htutanalstutanialhsbrk. o
Frogram of zbrk,
C:AHEW 2hkutonialstutorialviodefine. h

Definition of 1/0 Register -
4] | b

Click OF. to generate the project or Cancel to abart.

[+ Generate Beadme tst a: a summany file in the project directan

Cancel

Figure 2.11 Summary Dialog Box
Then the HEW will open a project generated by the project generator.
By default, the HEW has:

The [Workspace] window (on the left hand side of the HEW), which shows the contents of the
project, the [Output] window (on the lower side of the HEW), which shows outputs from a build
or a string search, and the editor window (on the right hand side of the window), which is used t
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edit text files. Refer to the Hitachi Embedded Workshop 2 User’'s Manual for how to change the
state of the HEW and how to use each window such as the editor window.

Title bar £ ttorial - Hitachi Embedded Workshop M=

FEile Edit Wiew Project Options Build Tools ‘window Help
Menu bar/_ s e e = —
é i D e o =] |[oefauszsion HreBr||=sxasgs T
Tool bar sE¥rdz s |[EEesia|BEEE G YOS
— |

==

EEY
E-E tutorial
B Aggembly source file

lowilvl. src
Workspace &3 C source fle

Window [f] doscte

— lowsrc.c

[Projects] sheet—T] e

123 Dependencies
. ) lowsich
Editor Window —Z[ R
stackscth
area vecth

" projects [ Inevision |

Output Windo
[ Build] sheet

Find in Files A Version Condrol

Status ba\“ 1o AR
eady ' \ B = N | N,

Figure 2.12 Sub-windows of the HEW

The project generated by the project generator includes minimum options for the C/C++
compiler, the assembler, the inter-module optimizer and the object converter. Thus you can buil
the project (figure 2.13) by selecting [Build->Build]. Selecting the button (shown below) on the
toolbar works in the same way as selecting [Build->Build].

Those minimum options are set by default for each tool. When you add a new file to the project
the minimum options will automatically be added to the file. You do not have to specify options
other than those that are specific to each such file.
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indow  Help

_J;_“.Def_ayl_tSessiq_n__ _j| ?&ﬁk‘@ = ”J b o & | Eﬁ

I El@ MI .' i

E“ﬁ? tutorial

-3 Assembly source
H lulaluwWLwc
A C zource file
[ dbscte
intprg.c
lowsre
resetprg.c
shrk.c

: tutorial o
E1-E3 Dependencies
2] lowsich
5] shikh
-2 stackscth

i C:\HEWZ\ tuktorialltutorial’ lowlvl.sre
T |Phase HE8S,HB/300 Assembler finished

Phaze OptLinker starting
Phase OptLinker finished

Euild Finished
0 Errors, 0 Warnings

4] :_ |\-___nui|d_ &___1__j§éhug__”-)_s‘<:.=ﬁnéli:‘ﬁ:£m -#.ithfmfon-aw{mii_ -'ﬁ:.:i:fhsﬁ-"/f: i
& 1 = = s [ WM

Figure 2.13 The HEW after Building a Project
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Section 3 Modifying the Project

When you create a project using the project generator, basic program such as reset routine and
initialization of RAM area will already be given in the project. This tutorial describes how to
modify a file and how to add a file to the project.

3.1 Editing and Creating a Source Program File

To open and edit a file in the project, double click the file in the [Projects] sheet of the
[Workspace] window. In this tutorial, double click “tutorial.c”. (figure 3.1)

%’Blulolial - Hitachi Embedded Workshop - [tutorial_c]

<7+ File Edit “iew Project Options Buld Toolz Window Help I _X]
al=T=F- N %m{}?mu-@lﬂlléu_m g 2|0 |||l 'lﬂxﬁ % el
Lol Gl Gl o |JJ@ b ”Debug J“DefaultSessmn _J|A Eros ‘@ 3] | |§ E & &) || Eff
s EE 2T

= 2 7 =

— S * 1=

B @ butorial #% FILE stutorial.c *
[l @ tutorial /% DATE ‘Wed, Oct 09, 2002 ®/
- a Azzembly source % DESCEIPTIOH :Hain Program x4
[ ok ERIRARYED: :H8S- 2655 *
C file i =
SOUICE ~% Thiz file is generated by Hitachi Project Generator [(Ver.2.3). *.
dhzct.c % x
intprg.c s s
lowsre o
Tesetprg.c
shik.c #ifdef _ cplusplus
onial extern "C" {
-3 Dependencies #endif ;
lawsrc.h void abort{woid);
bk h glfdef _ cplusplus
stackscth #endif
void main{void)
1
void abort{wvoid)

KN I ¥ .
@ijedx I €|Na\rig | 4 I I »
ﬂJPhase OptLinker starting _:]

T/ |Phase OptLinker finished
Euild Finished
0 Errors, 0 Warnings j

-
Find in Files Verzioh Cortrol
Ready |Read-write 1431 fn [INS NUM 2

Figure 3.1 Opening a Project File
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Then you can edit the file opened. If you edit the file, an asterisk (*) will be added to the file patt
shown on the title bar of the HEW (figure 3.2). If you save the file, the asterisk will disappear.

%’Blulolial - Hitachi Embedded Workshop - [tutorial c*]

<7+ File Edit “iew Project Options Buld Toolz Window Help I _X]
g & %m{}?mu-@lﬂl!éu_m g 2|0 |||l 'lﬂxﬁ % el
L) Gl Gl & | 5 4 ”Debug J“DefaultSessmn J|A Eros ‘@ E‘ | |§ E & &) || Eff
FMA DT

= 2 7 =

—— e ®7 =

B @ butorial #% FILE stutorial.c *

[l @ tutorial #% DATE ‘Wed, Oct 09, 2002 ®/
a Azzembly source % DESCEIPTIOH :Hain Program x4

: [ ok ERIRARYED: :H8S- 2655 *
23 C source file s x

~% Thiz file is generated by Hitachi Project Generator [(Ver.2.3). *.

dhzct % x
intprg.c s s
lowsre o

Tesetprg.c

shik.c #ifdef _ cplusplus
extern "C" {

= a Dependencles #endif

| h void abort{woid);
:;:Ef #ifdef _ cplusplus
stacksct h %‘endif

void main{void)

/% User Program =~

H

void abort{wvoid)

| — w2 -
3] Projects I ‘I naviy | Eif Ll—l

Hlphase OptLinker starting _ﬂ
Phase OptLinker finished

Build Finished
0 Errors, 0 Warnings J

[~

Find in Files

Verzioh Cortrol

eady ead-write
Read Fiead-wi [24/31 4 [INS NUM 2

Figure 3.2 Editing a Project File

If you want to open an existing text file with the editor of the HEW, select [File->Open]. If you
want to edit a new text file with the editor, select [File->New]. In this tutorial, select [File-
>New], input the three lines shown below, select [File->Save As...] and save the file as
“newprog.c”.

void NewProgram(void)
{
}
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3.2

Adding/Removing a File To/From a Project

This section describes how to add a file to a project and how to delete a file from a project. In
this tutorial, add the file, “newprog.c” created in the previous section to the project as follows.
Select [Project->Add Files...], then the [Add File(s)] dialog box (figure 3.3) will be launched.

Select a file, “newprog.c” in this example, to be added and click the [Add] button. Thus
“newprog.c” will be added to the project.

Add File(s) HE|

Lookjn [ e ] s ) =
1 Debug !ﬂ ol 21 E zhirk.h

1 Release @ lowsrc.c @ gtackscth

l:l SimDebug_HB5-2600M @ lowzrz. b ] tutarial o

=] dbzct E REWTg.

@ intprg.c @ resetprg.c

@ indefine. b @ shrk.c

1| | i

File name: Inewpru:ug.u: Add

Files of type: | Project Files

[ Relative Path

LI Cancel |

Figure 3.3 Adding a File To a Project
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The added file will be displayed on the [Projects] sheet of the [Workspace] window as shown in
figure 3.4.

%’Blulolial - Hitachi Embedded Workshop - [newprog._c]
<7+ File Edit “iew Project Options Buld Toolz Window Help I _)Q
g & %m{}?mu-@lﬁl!éu_m g 2|0 |||l 'lﬂxﬁ % el
L) Gl Gl ﬁ | 5 4 ”Debug J“DefaultSessmn J|A Eros ‘@ E‘ | |§ E & &) || Eff
FMA DT
— woid NewProgram(wvoid) j
= @ tutarial §
B- @ tutonial
a Azzembly source
lowalel. 31

I:l e] C source file
:

intprg.c:
lowsre o
NEwpng ¢
regetprg.c

CI Ei Dependenc:|es

lowzrc b
5] shikh
stackscth
Sl —]

@ijedx I “2_| hlavvig | LLI ;I
Hlphase OptLinker starting _ﬂ
T/ |Phase OptLinker finished

Euild Finished

0 Errors, 0 Warnings _I

[~
Find in Files Version Corrol
Ready |Read-write 1343 2 [INS NUM 2
Figure 3.4 Project With a File Added
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Next, how to delete a file from a project will be shown. Select [Project->Remove File...], then
the [Remove Project Files] dialog box (figure 3.5) will be displayed. Select one or more project
files on this dialog box and click the [Remove] button. Then the selected file(s) will disappear
from the list of the dialog box. Clicking [OK] actually removes the file(s) from the project.
Clicking [Cancel] instead will nullify the removal.

You have another way to delete a file from a project. Select the file in the [Projects] sheet of the
[Workspace] window and press the [Delete] key. Then the file will be deleted from the project.

If you want to exclude a file from a build temporarily instead of removing the file from the
project, refer to section 4.4, “Excluding a Project File from Build”.

Remove Project Files |

Project files;
dbzchc [CAHEMW A utonalhtukonal]

intprg. [CAHEW 25tutarialtubarial] Cancel |
[onalel. zre [C:AHEW 2\ tutonialstutonal]

lowzrc. o [C:AHEMW 2\ bukarialkukarial]

NEWRIO0. G [C:NHEMW 2\ butarialkukarial]

resetprg.c [C:AHEW 2\ tutonialstutonal]

shrk. [C:AHEW Z5tutarialtubarial] Remove Al |
tutorial.o [C:AHEW 2\ tutorialstutorial]

Jl | i

Figure 3.5 Remove Project Files Dialog Box
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3.3 File Groups Used in a Project

In this section, dile groupto which a file added to a project belongs is described. For example,
the project generator adds a file described in C language or assembly language to the project. /
file with a file extension “.c” belongs to the [C source file] group, and a file with a file extension
“.src” belongs to the [Assembly source file] group.

The HEW identifies a group to which a file belongs by checking the file extension. Select
[Project->File Extensions...], then the [File Extensions] dialog box (figure 3.6) will be

displayed. File extensions used in the project are shown on this dialog box. Every file extension
belongs to a file group. A file group can be associated to a tool in a build process.

If you want to use your own file extension in the project, define a new file extension by clicking
the [Add...] button.

The icon displayed in the [Extension] column of the [File Extensions] dialog box can show a too
which opens the file. If the icon of a file extension is the same as the icon shown below, a file
with that file extension can be opened by the editor of the HEW.

File Extensions [ 2] |

E stenzion | Group - k. I

D *abs  Abzolute file

@ * inc Azzembly include file Cancel |

EEE Agzembly list file

@ *.mar Agzembly source file Add...
@ *. 5l Agzembly source file
[Jbin  Binary fle .
SR L header file 5:
E=kt  Clistfile M
e L zource file

* hpp C++ hieader file

“Ipp C++ lizt file
*.cpp C++ zource file

L imfarmation fils | _,LI
3

Figure 3.6 File Extensions Dialog Box (Initial Screen)

] [ [

=
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=
&
2
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Click the [Add...] button on the [File Extensions] dialog box, then the [Add File Extension]
dialog box (figure 3.7) will be launched. Enter a new file extension in the [File extension] field
and specify the [File group] group box. If you want to add an extension to an existing file group,
select the [Extension belongs to an existing group] radio button and select a file group from the
drop-down list. If you want to create a new file group, select the [Extension belongs to a new
group] radio button and enter the name of the file group in the edit field.

In this tutorial, enter “asm” in the [File extension] field, select “Assembly source file” from the
drop-down list and click [OK]. Then a file with the extension, “*.asm”, will be treated as a file in
the [Assembly source file] group (figure 3.8).

Add File Extension EHE|

i~ File extenzion: — —
= lazm -
Cancel
i—File group: -

% Eutenszion belongs to an existing group:

" Estenzion belongs to a new group:

—Aszzociated application; -

Open "Azzembly zource file"
Windows default _"’J

Figure 3.7 Add File Extension Dialog Box

33
RENESAS



File Extensions

21|

E=tension |_I__?gr_|:1up i Ok |
D *abs  Abzolute file
S =inc Azzembly include file Cancel |
=l "lis Azzembly list file
@ Add...
E) = mar Agzembly source file .
EREE Agzembly source file Remave |
[ J*hin  Binary file :

“h C header file ,Ml

* Izt  lizt file

e C zource file

* hpp C++ header file

* lpp Co++ list file

. w
[nduin] I—\.-I--l- N [ =) |:||I=h JJ
| »

Figure 3.8 File Extension Dialog Box (After Adding an File Extension)

|
|
(1IN
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3.4 Customizing the Workspace Window

Click the right mouse button on the [Projects] sheet of the [Workspace] window, then a pop-up
menu will be displayed. Select [Configure View...] on this menu, then [Configure View] dialog
box (figure 3.9) will be launched. On this dialog box, you can specify whether the file
dependencies are shown for each file or not, whether a file is shown in a file group folder (figure
3.10) or not, and so on.

Configure Yiew

[T Show dependencies under each file

[T Show standard librany includes Cancel |

Figure 3.9 Configure View Dialog Box
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mlulolial - Hitachi Embedded Workshop - [newprog._c]
<7+ File Edit “iew Project Options Buld Toolz Window Help _!_l- = .)ﬂ
||ET

DeWd|eiee|oral|low|@ac e 2|2 ||w al
0 i ||| i e o ] |[Detouit ession e mr||aae ¢l a||EE
#

PG Es o8|

== void NewProgram(wvoid)
; &

=] @ tutarial ] T
EI@ tutonial

B3 Assembly source fils
CAHEW 2Mutorialtutoriallowlyl. src
{23 C source file
CAHEW 2Mtutariabtutorialhdbsct o
HEW 2 utarialstutarialsintprg.c
CAHEW 2tutariabtutorial\owsre. o
HEW 2 torialstutarialsnewprog.c
HEW 2\ utorialstutarialvresetpg.c
HHEW 2

E1-23 Dependencies
chew2stutarialtutoniallowsrc. b
c:vhew2tutarialtutonialishrk. b
. c:vhew2stutorialutonialystackscth

= @ijedx l €|Navigaﬁnn

Hlphase OptLinker starting _ﬂ
4 Phase OptLinker finished
Euild Finished
0 Errors, 0 Warnings _I
[~
Find in Files Version Corrol
Reary |Readwite (33 [z Mg [ NOM
Figure 3.10 Configuration of the Workspace Window
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Section 4 Building a Project

4.1 Build Overview
The HEW provides two ways of building a project.
1. “Build All” ([Build->Build All])

The series of tools including the compiler, assembler, and linkage editor are applied to all of the
source program files.

2. “Build” [Build->Build]

The series of tools are applied to a source program file updated after the last build. (The update
means not only the update of a source program file, but also an update of a file included by the
source program file and an update of an option applied to the source program file.)

If you want to compile or assemble a single source program file, select the file on the [Projects]
sheet of the [Workspace] window and select [Build->Build File].

If you want to execute “Build” or “Build All” for multiple programs or configurations, specify
the target by selecting the [Build -> Build Multiple] menu item.

CAUTION ON BUILD
1. Depending of the setting of the editor window, a file being edited might be saved
on executing a build. So close a file which you do NOT want to be saved
beforehand. For details of customizing the editor, refer to the Hitachi Embedded
Workshop 2 User’'s Manual.
2. Do not save a file used in a project during the build because doing so might disturk
the build process.

4.2 Setting Options
In this section, overview of the option setting is described.

When the project generator generates a project, the minimum options required for a build are
already specified. If you want to modify the options, however, select [Options-> Hitachi H8S,
H8/300 Standard Toolchain] and set options on the option dialog box.
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Figure 4.1 shows the option dialog box of a C/C++ compiler. On the left hand side of the dialog
box is a file list, and on the right hand side are optional setting controls for each tool divided intc
some pages. If you select a file in the file list, you can specify options only to the selected file. If
you select a file group folder in the file list, you can specify the same option to all the files in the
file group. To specify the same options to specific files, select the files while pressing the [Citrl]
key or the [Shift] key.

If you select [Default Options] in a file group folder, you can specify initial options for the file
group. The HEW automatically adds the options specified to the [Default Options] to a file of the
corresponding file group of the corresponding file extension of the file. For example, if you add
a file with an extension “C” (“*.C") to the project, the settings of the [Default Options] of the [C
source file] group will be added to the file automatically.

For the details of the options refer to the H8S, H8/300 Series C/C++ Compiler, Cross Assemble
or Optimizing Linkage Editor User's Manual.

Hitachi H8S_H8/300 Standard Toolchain I

Configuration ; C/C++ I.-'l'-.sseml:ul_l,ll Link.-"LiI:urar_l,li Standard LiI:urar_l,l! CPU A I *I
IDEI::ug ;] Cateqgony : ISDurDE LI
F"@ Al Ll:l-Eldd Projectsz Eleeies o
= EE tutorial — -
- C source file Ilnclude file directaries j

-2 T+ zource file
- £ Azzembly zource fils
-7 Linkage symbol file

fAEvELE

Optionz CAC++

-cpu=2600M -object="$[COMFIGDIR]$[FILELEAF). obj" _:]
-debug -nolizt -chaincpath -lang=c -nologo

* | ] Ie
Cancel |

Figure 4.1 Option Dialog Box of C/C++ Compiler
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4.3 Customizing the Configuration

In the previous section, how to set options to a project file is described. In this section, how to
create more than one suite of option settings for a build will be described. A suite of option
settings for a build is calledanfiguration

The project generator creates two configurations, [Debug] and [Release]. Difference between
them is only the setting of the debugging option. When a target for debugging is selected, the
configuration for the target is also created. To switch the current configuration to another, launcl
the [Build Configurations] dialog box (figure 4.2) by selecting [Options->Build

Configurations...], select a configuration from the [Current configuration] drop-down list, and
click [OK]. You can also change the current configuration by selecting one from the drop-down
list on the toolbar.

On the [Build Configurations] dialog box, you can create a new configuration or delete a

configuration. For details, refer to chapter 2, “Build Basics”, of the Hitachi Embedded Workshop
2 User’s Manual.

Build Configurations

Build configurations: Ok

Releaze . Cancel
SimD ebug_HA5-2600M

1.

Add...

SN E

Current configuration:

Debug :_1

Figure 4.2 Build Configurations Dialog Box
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4.4 Excluding a Project File from Build

In this section, how to exclude a project file from build will be described. Excluding a project
file from build does not delete the file from a project, but exclude a project file from build in
configuration by configuration basis.

Select a file on the [Projects] sheet of the [Workspace] window, click the right mouse button, an
select [Exclude Build <file>] on the pop-up menu. Then a red cross will be added to the icon of
this file as shown in figure 4.3. This file will be excluded from a build.

To include an excluded file into build, select the file on the [Projects] sheet of the [Workspace]
window, click the right mouse button, and select [Include Build <file>] on the pop-up menu.

=]

=l @ tutarial

= @ tutorial
EJ -"—.,j Azzembly zource file
. ] CAHEW 2\tutarialytutarialblowbd src
= -"—.,j C zource file
] CAHEW2\tutoriahtutorialdbact o
C:AHEW 2tutarialhtutarialsintprg. o
C:AHEW 2 butarial tutorialyowsre. o
utarialhtutarial s newprog. o
C:AHEW 2stutarialhtutanial'resetprg.c
: C:AHEW 2 butarialstutorialhzbrl. o
(] CAHEWMtutarialtutarialtutarial o
=53 Dependencies
-] e vhew2htutonialstutanallowserc. b
5] eMhew2stutarialitutorialshrk b
< (E] crhhew2stutanaltutonalhstacksct b

_IIL:{I-j ||:¢-i|!i-,j|£,-j ||:¢-'

!

@ Projects | “_l Mavigation

Figure 4.3 Excluding a Project File from Build
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4.5 Correcting Errors in a Build

In this section, how to jump to a line of a file which caused an error in compiling or assembling
will be described.

Figure 4.4 shows an example in which a compiler detected a syntax error in a source program
file. When you build a project, messages, including error messages, from a tool in a build will be
displayed on the [Output] window. If you double click the line of the error message on the
[Build] sheet of the [Output] window, the file which caused the error will be opened and the
cursor will be placed on the line which caused the error. (The cursor might not be placed on the
line which caused the error if you have already edited the file.) Placing the cursor on the error
line of the output window and pressing the [F1] key displays help of that error.

E_‘g’%lulolial - Hitachi Embedded ‘Workshop - [newprog.c]
2+ File Edit Miew Project Options Buld Tools ‘wWindow Help _Iﬁ' _)_(]

Neda|/e|icejorTo||lowmEssoe 2 |B||a W g h el
L0 (ot (el i“@l‘_l et ”Debug j“DefauItSession ﬂ|}g s ‘@ [l |“|§¥ | |“|'§];
sAELES D

=l vold NHewProgram{woid) Z]
{

-3 tutcrial P
B @ tutorial T ’
2 Assembly source file
@ CAHEW 2tutorabtutorial\lowlyl sro
-3 C zource file
£] CAHEW2Mtutarialtutorialhdbsct. o

D CAHEWZMutonaltutonialvesetpig.c
CAHEW 2tutariabtutorialvsbrk. o

[ CAHEWZutoiabhutorialhutonial o
Dependencies

=] cihewutorialutorialowsre b
c:shew2stutarialtutonialisbrk. b
covhew2htutarialtutonialistacksct h

T 3] Projects | “=_] Mawigation I _4” S I =

lphaze HAS,HE/300 c/CH Compiler starting o
“iC:\HEL\JZ\tutor:l_al\tutor:l_al\newprog.c:

C:\HEWZ ' tutorialltutorialinewprog.c(3) : ¢2402 (E} Incomplete string
C¢:\HEW2\tutorial'tutoriallnewprog.c (3} : 4]
C:YHEWZ'tutorialltutorialinewprog.c(3) : C2500 (E) Illegal token ™ ;"
C:\HEWZ'\tutorial'\tutorial'\newprog.c(4) : ©¢2500 (E} Illegal token "} "
Phase H8S,HS/300 C/C++ Compiler finished

(E} Undeclared name "error"

Euild Finished
4 Errors, 0 Warnings LI

| 4[5 Build £ Debug A Find in Files A Version Cortrol b, Flash

j (E] Undeclared name "error’ [Readwite |34 11 INs— [ [NOM 2

Figure 4.4 Correcting the Line which Caused an Error
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4.6 Customizing the Session

You can save the options for debugger to the session file.

The project generator creates the session, [Default Session]. When a target for debugging is
selected, the session for the target is also created. To use the a target, launch the [Debug
Sessions] dialog box (figure 4.5) by selecting [Options->Debug Settings...], select a session
[SimSessionH8S-2600N] from the [Current session] drop-down list, and click [OK]. You can
also change the current session by selecting one from the drop-down list on the toolbar.

On the [Debug Sessions] dialog box, you can create a new session or delete a session. For
details, refer to chapter 1.9, “Debugger Sessions”, of the Hitachi Embedded Workshop 2 User’s

Manual Simulator/Debugger Part.

Debug Seszions

Debug zeszions:

D efaults eszion

SimSeszionH35-2600M

Current sezsion:;

SimSeszionH35-2600M

OF.

Cancel

1.

Add...

SEMEVE

|_ |

EAWE ag,

Eraperties

Figure 4.5 Debug Sessions Dialog Box
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Section 5 Debugging

51 Preparation

The basic functions of the simulator/debugger will be described in this section using a sample
program.

NOTE
Note that the contents of usage examples (figures) in this section will differ depending on the
compiler version.

51.1 Sample Program

The HEW demonstration program is used for the sample program and is written in C language |
first sorts ten random data in the ascending order, and then in the descending order. The samp
program:

(1) Generates random data for sorting using the main function.

(2) Inputs the array which stores the random data that is generated by the main function, then
sorts the data in the ascending order using the sort function.

(3) Inputs the array generated by the sort function, and sorts the data in the descending order
using the change function.

(4) Displays the random data and the sorted data using the printf function.

5.1.2 Creating the Sample Program
Create the HEW demonstration program by referring to sections 1 to 4, and note the following.

« Specify [Demonstration] for the [Project Type] in section 2.1, Creating a New Workspace.

e Specify [2600] for the [CPU Series:].

e Specify [H8S/2600N Simulator] for the [Target:].

» Specify [SimDebug_H8S-2600] for the configuration ISimDEt‘“g—HES'EEDDN j on
the toolbar before building the project.

e Specify [SimSession_H8S-2600] for the sessi
toolbar.

O||5imsessic.ans-25mN =] on the

Since section 5 explains the debugging function, [Demonstration] has not been optimized. Do
not change this setting.
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5.2 Settings for Debugging

5.2.1 Allocating the Memory Resource

The allocation of the memory resource is hecessary to run the application being developed.
When using the demonstration project, the memory resource is allocated automatically, so chec
the setting.

» Select [Simulator->Memory Resource...] from the [Option] menu, and display the allocation
of the current memory resource.

Simulator Memory Resource E i
System Configuration kemaomny kap A
CPL-HES/2E00N | [D0000000 ODOGEEFF EXT & 2 —

Diata Area Bit Size: 16 QO00ECO0 DOOOFBFF Rakd 161 M odif
Program Area Bit Size: 16 Q000FCO0 DOOQFESF EXT 8 2 Ty . |
Exec Maode:Stop _"j QO0OFE40 DODOFFO7 1/0 8 2
0000FFOS 0000FF27 EXT & 2 Delate |
System Memory Resource 0000FF28 0000FFFF 140 8 2
EO0000000 DODOFFFF Readwiite Reset |
LCloze |

Figure 5.1 Simulator Memory Resource Dialog Box

The program and stack areas are allocated to the addresses H'00000000 to H'0000FFFF, whicl
can be read from or written to.

» Close the dialog box by clicking [Close].

The memory resource can also be referred to or modified by using the [Simulator] page on the
[Hitachi H8S,H8/300 Standard Toolchain] dialog box. Changes made in either of the dialog
boxes are reflected.
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5.2.2 Downloading the Sample Program

When using the demonstration project, the sample program to be downloaded is automatically
set, so check the settings.

¢ Open the [Debug Setting] dialog box by selecting [Debug Settings...] on the [Option] menu.

Debug Settings E I

| SimSessionHE3-2600M =] Taget | ptions |

- hutarial Target:

I0M Sirnulator

Detault Debug Format:

| Elt/Dwarf2 i
Download Maodules:
File Mame | Offzet Address | Farm: Add...
$COMFIGDIR]$... H'OO000000 EID
Eemove

1 | il
Ok I Cancel

Figure 5.2 Debug Settings Dialog Box

« Files to be downloaded is set in [Download Modules].

¢ Close the [Debug Settings] dialog box by clicking the [OK] button.

* Download the sample program by selecting [Download Modules->All Download Modules]
from the [Debug] menu.
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5.2.3 Displaying the Source Program

The source-level debugging is supported by the HEW. Refer to section 3.1, Editing and Creatin
a Source Program File, and display the source file ("tutorial.c") in the [Source] window.

* Open the [Source] window by double-clicking tutorial.c on the [Workspace] window.

«# tutorial.c H=]
I; I
e *s 2
¥ BILE itutorial .o */
<% DATE ;Tue, Qct 08, 2002 */
~% DESCRIPTION :Main Program *.
<% CPU TYPE (HBS~ */

g */
<% Thi=z file i= generated by Hitachi Project Generator (Ver. 2. 3). *.
P *.
i 5

#include <no float h:
#include <stdioc. h:
#include <math.h>
#include <stdlib. ho>

woid main{wvoid)};

wold =ort(long *a): 1
woild change({long #*a);

extern vold srand{unsigned int):

0=00000blc woid main({woid)
{

long a[10]. min., max:

long j:

int i
0=z00000b24 srand(l]);
0=z00000b2c printf("##4 Data Input #ft~n"):
0=00000b38 for{ i=0; i<10; i++ }<
0=z00000b40 J = rand():
0=z00000b4dc if({3 ¢« 034
0=00000b54 g B Dy

¥

0=z00000b&2 ali]l = 3:
0=00000b7a printf{"a[#d]=%1d\n".1i.a[1]):

H
0=00000bbE sortial): =
|« o

Figure 5.3 Source Window (Displaying the Source Program)
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5.2.4 Setting a PC Breakpoint

Breakpoints can be set easily by the [Source] window. To set a breakpoint on a line that include
the sort function call:

» Place the cursor in the line that includes the sort function call and click the right mouse
button to launch the pop-up menu, and select [Toggle Breakpoint] from the pop-up menu.

< tutonal.c |- [O] =]
#include <no_float h>
#include <stdic.h:
finclude <math h:
#include <stdlib. h:
wold main{woid);
woid =ort(long *a):
woid change(long *a):
extern void srand{unsigned int):
0=z00000blc wold main{wvoid)
£
long a[10]. min, mnax;
long j:
int i
0=00000b24 srand(l};
0=00000b2c printf("##¢ Data Input #&d~n"):
0=00000b38 for{ i=0; 1<10; i++ ){
0=00000b40 J = rand():
0z00000bdc 1f{g ¢« 0){ -
O0=z00000b54 i = =i
¥
O=z00000b&2 ali] = 3.
O0=00000b7a printf("al¥xd]=%1d~n".1i.a[i]):
H
0=z00000bLE [ ] =zortia);
0=00000bc2 | printi("=*% Sorting results =x*.p"):
0=z00000bce for{ i=0; 1<10; i++ ){
0=z00000bd6 printf{"al[#d]=%1ld~n".1i.a[i]):
H
0=x00000c14 min = a[0]:
0=00000=20 max = a[9]:
Oz=00000z22 min = 0;
O0=z00000c34 max = 0;
0=00000=3c changeia):
0=x00000c46 min = a[9]:;
0=00000c52 max = af[0]: Rl
4 I! 3 //E

Figure 5.4 Source Window (Setting the Breakpoint)

A - is displayed at the line that includes the sort function call, indicating that the PC breakpoint
is set at the address.
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525 Setting the Profiler

Open the [Profile] window by selecting [Profile] from the [View->Performance] menu.

Prafile

]
Function/¥ariable F/V | dddress Size | Times Cycle Ext mem I/0 area | Int men

A5 List A Tree

Figure 5.5 Profile Window

Open the pop-up menu by right clicking the mouse on the [Profile] window, and select
[Enable Profiler] to enable acquisition of the profile information.
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5.2.6 Setting the Simulated 1/0

When the demonstration project is used, the simulated 1/O is automatically set, so check the
setting.

Open the [Simulator System] dialog box by selecting [Simulator->System] from the [Option]
menu.

Simulator System

K
CPL: |Has/2600M x| Mema Map: K|
e 00000000 QOO0EEFF EXT &2
Data Area Bit Size: !‘l E QO00ECO0 DO0DOFEFE Rk 16 1 Catcel I
A 0000FCO0 DDOOFE3F EXT &8 2
Program Area Bit Size: 16 O000FE 40 D00OFFO7 140 & 2 fdd.. |
O000FFO8 Q00OFF27 ExT 8 2
SYSCR Address: 0000FF28 QO0OFFFF 140 8 2 Madify... I
|H'0000FF29
System Call Addiess: — Execution Mode ﬂl
iH'DDDDDDDD | &+ Stop " Continue
Response: Bound Mode
040000 & Round Ta Nearest
; " Round Ta Zera

Figure 5.6 Simulator System Dialog Box

¢ Confirm that [Enable] in [System Call Address] is checked.
¢ Click the [OK] button to enable the Simulated 1/O
e Select [Simulated 1/0] from the [View->CPU] menu and open the [Simulated 1/0] window.

The Simulated I/O will not be enabled if the [Simulated I/O] window is not open.
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Simulated /0

Figure 5.7 Simulated I/O Window

5.2.7 Setting the Trace Information Acquisition Conditions

« Select [Trace] from the [View->Code] menu and open the [Trace] window. Open the pop-up
menu by right clicking the mouse on the [Trace] window, and select [Acquisition...] from the
pop-up menu.

The [Trace Acquisition] dialog box below will be displayed.

Trace Acquisition E I

= Trace Start/Stop
" Dizable
i* Enable

Cancel |

= |nztruction Tupe
% |netuction
i~ Subrouting

= Trace Buffer Eull Handling
%' Continue
i~ Break

— Trace Capacity
&+ 1024 records
4096 records
16384 records
" 32768 records

Figure 5.8 Trace Acquisition Dialog Box
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e Set [Trace start/Stop] to [Enable] in the [Trace Acquisition] dialog box, and click the [OK]
button to enable the acquisition of the trace information.

5.2.8 Setting the Stack Pointer and Program Counter

To execute the program, the program counter must be set from the location of the reset vector.
In the reset vector of the sample program, the PC value H'400 is written.

¢ Select [Reset CPU] from the [Debug] menu, or click the [Reset CPU] button on the toolbar.

Set the program counter to H'400 from the reset vector.

=t
Figure 5.9 Reset CPU Button
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5.3 Start Debugging

5.3.1 Executing a Program

» Select [Go] from the [Debug] menu, or click the [Go] button on the toolbar.

El!
Figure 5.10 Go Button

The program halts where a breakpoint is set. An arrow is displayed in the [Source] window,
indicating the location the execution has stopped. As the termination cause, [PC Breakpoint] is
displayed in the [Output] window.

«# tutorial.c [_[O0]
woid change(long #*a): ﬂ
extern void srand{unsigned int): .
0=00000blc wold main{woid)
{
long a[10]. min, max:
long 3:
int i:
0=00000b24 srand(l):
0=00000b2c printf("##4 Data Input #fd~n"):
0=z00000b38 for{ 1=0; 1<10; i++ }{
0=z00000bL40 J = rand():
0=00000bdc if (3 « 034
0=00000b54 g E R
}
0=z00000be2 ali] = 3:
0x00000b7a printf( a[%d]=%ld n".1i.a[i]):
H
0z00000bLS & zortia);
0=z00000bz2 printi("*%* Sorting results =®xwp");
0=00000bce for{ i=0; i<10; i++ ){
0=00000bde printf{"a[xd]=x1ld~n".1i.a[1]):
H
0=00000=14 min = a[0]:
0=00000=20 max = a[9]:
0=00000c2c min = 0; b
0z00000c34 max = 0;
0=z00000c3c change(a);
0=z00000c46 min = a[9]:
0=z00000c52 max = a[0]:
0=z00000cS5e I3
0=z00000cEE wolid =zort(long *a)
{
long t;
int 1. 3. k. gap:
0=z00000c72 gap = 5.
0=z00000=7a while({ gap > 0 3{ e
4” L2l -

Figure 5.11 Source Window (Break Status)

52
RENESAS



The termination cause can be displayed in the [Status] window.

e Select [Status] from the [View->CPU] menu to open the [Status] window, and select the
[Platform] sheet in the [Status] window.

Ttem i Status

Comniectad To HE5 /26000 Simulator
CPU Has /26000

Exec Mode Stop

Pun Status Readsy

EBrealk Cause PC Breakpoint
Execute From RBeszet

Exec Instructions 34855

Cyoles zE0l43

4 | r]
4| - [ beraory 2 Platiorm £ Everts

Figure 5.12 Status Window

The above status window indicates that:

(1) The cause of break is a PC breakpoint

(2) Execution is performed from the reset

(3) The number of executed instructions by the GO command is 34,855
(4) The executed number of cycles from the reset is 250,149

Register values can be checked in the [Register] window.

« Select [Registers] from the [View->CPU] menu.
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Fegister Value *|

H'oo00o0a0h
H'FFFFFFFF
H'oooooooo
H'0o0oooo0o
H'oooooooo
H'oooooooo
H'Q000FEEL
H'O0O00FEE4
H'0O00BES

bl kb -

Figure 5.13 Register Window

Register values when the program is terminated can be checked.

5.3.2 Using the Trace Buffer
The trace buffer can be used to clarify the history of instruction execution.

« Select [Trace] from the [View->Code] menu and open the [Trace] window. Scroll up to the
very top of the window.

Generic Trace

PR | cye1e Address | CCR | mut | Instruction | Access Data | source | Laber | ﬂ
-01023 0000242644 00LDCE  —---m Z-- - ENE Bdiv_1_1:8 PC<-00001DCE

-01022  D0D0Z42645 00LDCE  —---v N — MOV, W EO,RZ R2<-0000

-01021 0D000Z42652 O0LDCA  —---- Z-- - EXTU.L  ERZ ERZ<-00000000

-01020  0000Z42675  00LDCC ces DIVXU.U  R1,ERZ ERZ<-00000000

-0101%  0OD0Z42679  OOLDCE o mas Hov. W EZ,ED E0<-0000

-01018 0000242702 00LDDO  —---m-mm ST DIVXU.U  R1,ER0 ER0<-00000004

-01017 0000242706 00LDDZ  —---- R — Hov. W E0,RL RI1<-0000

-01016 0000242710 00LDDE  —---- R Hov. W RZ,E0 E0<-0000

-01015 0000242716 00LDDE  —---- o mas BRA Breturn:s PC<-00001DFG

-01014 0000242728 O00LDFE  —--—- - HOV. L BER7+,ERZ ER2<-00000000 return

-01013 0000242739 O0OLDFA  —---- g T RTS PC<-00001884

-01012 0000242744 00188h  —---N--=  ——- MOV W BER7,RO RO<-FA84 El

Figure 5.14 Trace Window (Trace Information Display)
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5.3.3 Performing Trace Search

Click the right mouse button on the [Trace] window to launch the pop-up menu, and select
[Find...] to open the [Trace Search] dialog box.

Trace Search |
i~ ltem
= ok
e |
£ Cycle Cancel |
" Address
% |nstiuction

Walue:

ll:urd

Figure 5.15 Trace Search Dialog Box

Setting the item to be searched to [Item] and the contents to be searched to [Value] and clicking
the [OK] button begins the trace search. When the searched item is found, the first line is
highlighted. To continue searching the same contents [Value], click the right mouse button in
the [Trace] window to display the pop-up menu, and select [Find Next] from the pop-up menu.
The next searched line is highlighted.

Generic Trace =]
FTR ! Cycle iddress | CCR | muit | Instruction ! ALccess Data | source | Label !__‘J
01013 0000242739 001DFA smE RT3 PC<-00001554 =
-ololz 0000242744 001884 e HOv. W BER7,RO RO<-FAS4
-01ol1 0000242749 00185C -—- HOV.E R1L,BERO 0000F4AS4-00
-01olo 0000242753 0O0188E RS MOV W E3,RO RO<-Fi&4
-0100% 0000242758 0018590 R HOV. B HERD,ROL ROL<-00
-01008 0000242762 001892 R CHP.E #H'09,ROL
-01007 0000242770 001594 i BGT [H'1840:5 PC<-00001896
-0l006 0000242774 001896 btk HOV. W R3,R0 RO<-FAG2
-01005 0000242778 001898 saT ADD.W R5,RO RO<-FAS4
-0l004 0000242783 001594 oy HOV. B HEROD,R1L R1L<-00
-01003 0000242787 0O0189C  ——---——— e ADD.B #H'30,R1L RlL{-30
01002 0000242795 00189~ ——-—--—- A BRL [H'13E8:3 PC<-000018ES LI
Figure 5.16 Trace Window (Searched Result)
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5.3.4 Checking Simulated I/O

Random data that is displayed by the printf function can be checked in the [Simulated I/O]
window.

Simulated [0

### Data Input ##ﬂ
a[0]=16333
a[1]=5758
a[2]=10113
a[3]=17515
a[4]=31051
a[5]=5627
a[5]=23010
a[7]=7419
a[8]=16212
a[9]=4036

Figure 5.17 Simulated I/O Window

* Do not close the [Simulated I/O] window.
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5.3.5 Checking the Breakpoints

A list of all the breakpoints that are set in the program can be checked in the [Break] window.

e Select [Breakpoints] from the [View -> Code] menu.

Eniahle _I Type ] Condition Aotion
Enable EP PC=H'00000BES [tutorial.c/42) Stop
4 | 2

Figure 5.18 Break Window

A breakpoint can be set, a new breakpoint can be defined, and a breakpoint can be deleted usir
the [Break] window.

¢ Close the [Break] window.

5.3.6 Watching Variables

It is possible to watch the values of variables used in your program and to verify that they chang
in the way that you expected. For example, set a watch on the long-typeadrdagfared at the
beginning of the program, by using the following procedure:

e Select [Watch] from the [View -> Symbol] menu and open the [Watch] window. And click
the right mouse button on the [Watch] window and choose [Add Watch...] from the pop-up
menu.

The following dialog box will be displayed.

Add Watch
Wanable or expression;

Ia LCancel

Figure 5.19 Add Watch Dialog Box

« Type arraya and click thg OK] button.
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The [Watch] window will show the long-type array
You can double-click the + symbol to the left of array ih the [Watch] window to expand the

variable and show the individual elements in the array.

[
(1
[2]
(4
(4]
(5]
[E]
[7]
(8]
(A

H'000071 67 { Oxfbck |
H'00002757 { Oxfbca
H'0000446h | Oxfbce !
H'0000794b | Oxfbd2 }
H'00001 5fb { Oxfbds }
H'000059e2 | Oxfbda }
H'000071 ofb § Oxfbde }
H'00003f54 § Oxfbe? }
H'00000fE { Oxfbek }

Type

(langl10]]

[lang]
[lang]
[long]
[lang]
[lang]
[long]
[lang]
[lang]
[lang]
[lang]

* Close the [Watch] window.

5.3.7

Figure 5.20 Watch Window

Executing the Program in Single Steps

The simulator/debugger has various stepping menus that are useful in debugging the program.

Menu Description

Step In Executes each statement (includes statements within the function)

Step Over | Executes a function call in a single step

Step Out Steps out of a function, and stops at the next statement of the program that called
the function

Step... Executes the specified number of steps at the specified speed

58

RENESAS



[Step In]: Enters the called function and stops at the statement at the start of the called functior

e To step in the sort function, select [Step In] from the [Debug] menu, or click the [Step In]
button on the toolbar.

«#- tutorial.c

0x00000b40
0x00000b4c
0=z00000b54

0z00000b&2
0=z00000b7a

0=z00000ELA
0=z00000bc2
0=x00000bce
O0=x00000bdA

0=00000=14
O0=00000=20
0z00000c2c
O0=00000z24
0=z00000c3c
0=00000c46
O0=00000=52
0=x00000c5e

0z00000cz66

0=z00000=72
0=00000=7a
0=x00000c7e
0=x00000c=88
0=00000c9a
0=z00000cac
O0=00000=d0
0=00000ce2
O=z00000d02

0x00000d1c

0=00000d6c

Ll

#

Figure 5.21 Step In Button

H=l B
i = randi):
if(j < 0){ -
3 el
a[il = i o
printi("a[%d]=%1d~n".1.a[1]};
& sortial:;
printf("#%* Sorting results =xxwn");
for{ i=0; 1<10; i++ 14
printf{"al[xd]=%1d~n".1i.a[i]):
H
min = af[0]:
mnax = a[9]:
min = 0;
max = 0;
change(al:
min = a[3]:
max = a[l];
H
c:froid sort(long *a)
{
long t;
int 1. 3. k. gap:
gap = &5
while{ gap » 0 ){
for{ k=0; kigap: k++)1{
for{ i=k+gap. i1<10: i=it+gap }{
for(j=i-gap: j»=k: j=j-gapl{
if{a[j]rali+gap]){
t =alil:
a[1] = ali+gapl:
ali+gap] = t: b
else
break;
¥
}
b
gap = gap-2; =
v 4

Figure 5.22 Source Window (Step In)

e The PC location display (=>) in the [Source] window moves to the statement at the start of
the sort function.
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[Step Out]: Steps out of the called function and stops at the next statement in the called

program.

« Select [Step Out] from the [Debug] menu to exit the sort function, or click the [Step Out]
button on the toolbar.

«* tutorial.c

0x00000blc

0=00000b24
0z00000b2c

0=z00000b38
0z00000b40
0=00000bdc
0x00000b54

0=00000b62
0z00000b72

0=00000bbA
0=00000bc2
0=x00000bce
0=00000bdA

O0=00000=14
0=00000=z20
0=z00000z2c
0x00000c34
0=x00000c3c
0=00000c46
O0=00000=52
0=00000cz5s

0x00000c66

0=00000c72
0=z00000=7a
0x=00000c7e
ill
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Figure 5.23 Step Out Button

[ [D] X]

extern vold srand{unsigned int): iﬂ

void main(wvoid)

long a[l1l0], min, max;
long 3:
Tk 1

srand(1}:
printf{"### Data Input ##in"):

for{ i=0; i1<10; i++ ){
i = rand();
if(3 < 03f
T T
¥

a[i] = i .
printf{“al[xd]=%x1ld~n".1i.a[1]):

sort{a);
| printfi"=%* Sorting results =*xn"):
for( i=0; i<10; i++ ){
printf{"a[xd]=%1d~n".1.a[1]}:
¥

nin
nax
nin
nax :
change(a):
nin = a[9]:
nax = af[0]:

af0]:
a[9]:
o;

0

H
vold sort(long =a)
long t:
int i, j. k., gap:
gap = &;
while! gap > 0 3{
for{ k=0: k<gap: k++){ hd

-
R

Figure 5.24 Source Window (Step Out)
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[Step Over]: Executes a function call in a single step, and stops at the next statement in the
main program.

Select [Step Over] from the [Debug] menu or click the [Step Over] button on the toolbar to step
over the statements in the printf function.

[

Figure 5.25 Step Over Button

«# tutonal.c Hi= E
0=z00000ble woid main(wvoid) ﬂ‘
{

long a[10]. min. max:

long 3
int 1i:
O0=00000b24 srand(l]):;
0=00000b2c printf{"#tt Data Input #£#~n");
0=00000b38 for{ i=0: 1<10; i++ )4
O=00000Bb40 i = rand():
0=00000b4c if(j « 0){
0x00000b54 g = =ja
+
0=z00000bk2 ali] = 3z
O0=z00000b7a printf {"a[*d]=%1ld~n".i.a[i]):
1
O0x00000bLE & =ortia):
O0=00000bc2 printf ("*%* Sorting results *x*wn"):
0=00000bce (=] for{ i=0; i<10; i++ ){
0=00000bdE printf("a[®d]=xld n". i.a[i]}:
1
0=z00000z14 nin = af[0]:
O0=z00000=20 nax = a[9];
0=z00000c2c nin = 0;
0=z00000c34 nax = 0;
0=z00000c3c change(a);
0x00000c46 nin = a[3]; b
O0=00000=52 nax = all]:
0x00000cke +
0=z00000ckE vold sort{long *a)
{
long t;

int i. j. k. gap:

0=00000cz72 gap = 5;

0x00000c7a while{ gap > 0 J{

0=00000c7e for{ k=0: kigap: k++){

0=z00000=88 for({ i=k+gap; i1<10; i=i+4+gap ){ b
il vl 2

Figure 5.26 Source Window (Step Over)

When the printf function has been executed, *** Sorting results *** will be displayed in the
[Simulated 1/0] window.
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5.3.8 Checking Profile Information
The profile information can be checked in the [Profile] window.

e Clicking the [Go] button and continuing execution from the current PC executes the SLEEP
instruction and stops.

[List] Sheet: Displays the profile information as a list.

« Open the [Profile] window by selecting [Profile] from the [View->Performance] menu. The
[List] sheet will be displayed.

] =]
Function/Variahle F/V | Address Size Times Cycle Ext mem I/0 area | Int mem ol
_PowerON_Reset F H'00000400 H'00000022 1 -1 1 a 5
_ freeptr W H'O000OFO062 H'D0000O01 1 0 1] 0 1]

_ rnext W H'OO000OFOSC H'D0000001 32 0 1] 1} 1]
__errno WV H'0000FOS4 H'0000000L 4 0 0 0 0
_flmod W H'0000EC37? H'D0000O01 4 0 1] 0 1]
_sul bmf v H'0000ECS4 H'00000001 Z a o i} o
__ioh W H'O0O0OECO4 H'DO00O0O01 3 0 1] 0 1]
_ nfiles v H'O000Z1DE H'00000002 g a o 0 o
_ alochuf F H'O000Z078 H'0000008E 1 z1z 1] 0 16
_strlen I H'O0001FES H'00000010 40 3776 o 0 19z
_ flshbuf F H'0O0001DFC H'DO0000L42 255 95338 1] 0 BEZE
sDIVITLES F H'00001DCa H'00000000 230 27140 a a 630
_fputc F H'00001CDC H'00000DOE4 255 61965 1] 0 3060
_ flopen F H'00001BAE H'0000012E 3 1665 15 0 &7 o
flclose I H'O0001EQE  H'000000AC = 0 2] g7
0x0000LAEZ F H'0O00014E2 H'0D0000000 124 9176 1] 1} 744
0x00001ACE I H'00001ACA H'00000000 Z2 1056 o 0 g5
0x00001455 F H'00001458 H'0DO00O0000 10z 40229 143 0 2407
0=00001700 I H'00001700 H'00000000 40 54035 o 0 3206
_ fmtout F H'0O00O0FDE H'000007FZ z2 69639 g31 0 Z677
$MULLs3 F H'00000FCE H'00000000 10 730 a a 50
§DIVLE3 F H'00000FAQ H'0DO0000000 10 G40 1] 0 40
_strcup F H'00000F76 H'00000024 24 3790 118 1} le2
srand F H'00000FSC H'00000004 1 25 0 1] a _L'
AT E T List i Tree £

Figure 5.27 Profile Window (List Sheet)

In above figure, it can be found that the __ flclose function was called six times, the execution
cycle was 1182, and the internal memory was accessed 87 times.

It is possible to search for the critical path, such as a function that is called or accesses the
memory many times, for the program performance.
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[Tree] Sheet: Displays the profile information as a tree diagram.

e Select the [Tree] sheet. Double-clicking the function name in the [Profile] window expands
or minimizes the tree structure.

Profile =]
Function Address | Size | Stack Size Times | Cycle Extmem | /0 area | Int mem
=+ TAHEW 2 hutanialstutonialhSimD ebug HES.
_PowerON_Reset H'0000... H'00000000 66 1 0 5
e IMITSCT H'0000... H'00000000 20815 9 0 1133
main H'0000... H'00000000 4310 i} 0 284
__CLOSEALL H'0000... H'00000000 436 4 0 26
I _felose H'0000... H'00000000 38 i} i} 18
"""" 1] 0

- S HO000...

o s e e o T R e e e
LD L) L — o PERE L — =

_close H'aoa0... H'00000000 285 i i 18
Bl _INIT_IDOLIB H'ooan0... H'00000000 933 4 1] E5
E- _freopen HO000..  H.. HO0000000 525 1] 1] 42
B flelose H'ooan0... H'00000000 366 1] 1] 27

- _close HO000...  H.. HO0000000 1] 1] 1] 1]
B flopen H'o000... H'00000000 1665 15 ] 57

[ATE T List p Tree f

Figure 5.28 Profile Window (Tree Sheet)

In above figure, it can be found that the __flclose function was called three times from the
_fclose function, the execution cycle was 816, and the internal memory was accessed 60 times.
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[Profile-Chart] Window: Displays the relation of calls for a specific function.

« Select the _flclose function on the [Profile] window. Open the pop-up menu by right
clicking the mouse on the [Profile] window, and select [View Profile-Chart] to display the
[Profile-Chart] window.

Profile-Chart

Figure 5.29 Profile-Chart Window

In above figure, it can be found that the __ flclose function was called three times from the
_fclose and _freopen functions, and the _close function was called three times.

This is the end of the tutorial using the simulator/debugger.
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Section 6 Exiting from the HEW

Selecting [File->Exit] will close the HEW. Depending on the setting, the message box

(figure 6.1) which asks you whether to save the session or not will be launched. Not only the
setting like this regarding exiting from the HEW but also setting regarding initiation of the HEW
can to specified via [Tools->Options...]. For details, refer to the Hitachi Embedded Workshop 2
User’s Manual.

The other tools launched from the HEW will not be closed when the HEW is closed. Close the
tools by yourself.

Hitachi Embedded Workzhop |

& Session has been modified - do you want to zave it

Mo I Cancel I

Figure 6.1 Confirmation Dialog Box for Saving Session on Exiting from the HEW
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