To our customers,

Old Company Name in Catalogs and Other Documents

On April 1%, 2010, NEC Electronics Corporation merged with Renesas Technology
Corporation, and Renesas Electronics Corporation took over all the business of both
companies. Therefore, although the old company name remains in this document, it is a valid
Renesas Electronics document. We appreciate your understanding.

Renesas Electronics website: http://www.renesas.com

April 1%, 2010
Renesas Electronics Corporation

Issued by: Renesas Electronics Corporation (http://www.renesas.com)

Send any inquiries to http://www.renesas.com/inquiry.
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Notice

All information included in this document is current as of the date this document isissued. Such information, however, is
subject to change without any prior notice. Before purchasing or using any Renesas Electronics products listed herein, please
confirm the latest product information with a Renesas Electronics sales office. Also, please pay regular and careful atention to
additional and different information to be disclosed by Renesas Electronics such as that disclosed through our website.

Renesas Electronics does not assume any liability for infringement of patents, copyrights, or other intellectual property rights
of third parties by or arising from the use of Renesas Electronics products or technical information described in this document.
No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights
of Renesas Electronics or others.

Y ou should not alter, modify, copy, or otherwise misappropriate any Renesas Electronics product, whether in whole or in part.

Descriptions of circuits, software and other related information in this document are provided only to illustrate the operation of
semiconductor products and application examples. Y ou are fully responsible for the incorporation of these circuits, software,
and information in the design of your equipment. Renesas Electronics assumes no responsibility for any lossesincurred by
you or third parties arising from the use of these circuits, software, or information.

When exporting the products or technology described in this document, you should comply with the applicable export control
laws and regulations and follow the procedures required by such laws and regulations. Y ou should not use Renesas
Electronics products or the technology described in this document for any purpose relating to military applications or use by
the military, including but not limited to the devel opment of weapons of mass destruction. Renesas Electronics products and
technology may not be used for or incorporated into any products or systems whose manufacture, use, or sale is prohibited
under any applicable domestic or foreign laws or regulations.

Renesas Electronics has used reasonable care in preparing the information included in this document, but Renesas Electronics
does not warrant that such information is error free. Renesas Electronics assumes no liability whatsoever for any damages
incurred by you resulting from errorsin or omissions from the information included herein.

Renesas Electronics products are classified according to the following three quality grades: “Standard”, “High Quality”, and
“Specific”. The recommended applications for each Renesas Electronics product depends on the product’ s quality grade, as
indicated below. Y ou must check the quality grade of each Renesas Electronics product before using it in aparticular
application. You may not use any Renesas Electronics product for any application categorized as “ Specific” without the prior
written consent of Renesas Electronics. Further, you may not use any Renesas Electronics product for any application for
which it is not intended without the prior written consent of Renesas Electronics. Renesas Electronics shall not bein any way
liable for any damages or losses incurred by you or third parties arising from the use of any Renesas Electronics product for an
application categorized as “ Specific” or for which the product is not intended where you have failed to obtain the prior written
consent of Renesas Electronics. The quality grade of each Renesas Electronics product is “ Standard” unless otherwise
expressly specified in a Renesas Electronics data sheets or data books, etc.

“Standard”: Computers; office equipment; communications equipment; test and measurement equipment; audio and visual
equipment; home electronic appliances, machine tools; personal electronic equipment; and industrial robots.
“High Quality”: Transportation equipment (automobiles, trains, ships, etc.); traffic control systems; anti-disaster systems; anti-
crime systems; safety equipment; and medical equipment not specifically designed for life support.
“Specific”: Aircraft; aerospace equipment; submersible repeaters; nuclear reactor control systems; medical equipment or
systems for life support (e.g. artificial life support devices or systems), surgical implantations, or heathcare
intervention (e.g. excision, etc.), and any other applications or purposes that pose adirect threat to human life.
Y ou should use the Renesas Electronics products described in this document within the range specified by Renesas Electronics,
especialy with respect to the maximum rating, operating supply voltage range, movement power voltage range, heat radiation
characteristics, installation and other product characteristics. Renesas Electronics shall have no liability for malfunctions or
damages arising out of the use of Renesas Electronics products beyond such specified ranges.
Although Renesas Electronics endeavors to improve the quality and reliability of its products, semiconductor products have
specific characteristics such as the occurrence of failure at a certain rate and malfunctions under certain use conditions. Further,
Renesas Electronics products are not subject to radiation resistance design. Please be sure to implement safety measures to
guard them against the possibility of physica injury, and injury or damage caused by fire in the event of the failure of a
Renesas Electronics product, such as safety design for hardware and software including but not limited to redundancy, fire
control and malfunction prevention, appropriate treatment for aging degradation or any other appropriate measures. Because
the evaluation of microcomputer software alone is very difficult, please evaluate the safety of the final products or system
manufactured by you.

Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental
compatibility of each Renesas Electronics product. Please use Renesas Electronics products in compliance with all applicable
laws and regulations that regulate the inclusion or use of controlled substances, including without limitation, the EU RoHS
Directive. Renesas Electronics assumes no liability for damages or losses occurring as aresult of your noncompliance with
applicable laws and regulations.

This document may not be reproduced or duplicated, in any form, in whole or in part, without prior written consent of Renesas
Electronics.

Please contact a Renesas Electronics sdes office if you have any questions regarding the information contained in this
document or Renesas Electronics products, or if you have any other inquiries.

(Note 1) “Renesas Electronics’ as used in this document means Renesas Electronics Corporation and also includes its majority-

owned subsidiaries.

(Note 2) “Renesas Electronics product(s)” means any product developed or manufactured by or for Renesas Electronics.
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Keep safety first in your circuit designs!

. Renesas Technology Corp. puts the maximum effort into making semiconductor products better and
more reliable, but there is always the possibility that trouble may occur with them. Trouble with
semiconductors may lead to personal injury, fire or property damage.

Remember to give due consideration to safety when making your circuit designs, with appropriate
measures such as (i) placement of substitutive, auxiliary circuits, (ii) use of nonflammable material or
(iii) prevention against any malfunction or mishap.

Notes regarding these materials

. These materials are intended as a reference to assist our customers in the selection of the Renesas
Technology Corp. product best suited to the customer's application; they do not convey any license
under any intellectual property rights, or any other rights, belonging to Renesas Technology Corp. or
a third party.

. Renesas Technology Corp. assumes no responsibility for any damage, or infringement of any third-
party's rights, originating in the use of any product data, diagrams, charts, programs, algorithms, or
circuit application examples contained in these materials.

. All information contained in these materials, including product data, diagrams, charts, programs and
algorithms represents information on products at the time of publication of these materials, and are
subject to change by Renesas Technology Corp. without notice due to product improvements or
other reasons. It is therefore recommended that customers contact Renesas Technology Corp. or
an authorized Renesas Technology Corp. product distributor for the latest product information
before purchasing a product listed herein.

The information described here may contain technical inaccuracies or typographical errors.
Renesas Technology Corp. assumes no responsibility for any damage, liability, or other loss rising
from these inaccuracies or errors.

Please also pay attention to information published by Renesas Technology Corp. by various means,
including the Renesas Technology Corp. Semiconductor home page (http://www.renesas.com).

. When using any or all of the information contained in these materials, including product data,
diagrams, charts, programs, and algorithms, please be sure to evaluate all information as a total
system before making a final decision on the applicability of the information and products. Renesas
Technology Corp. assumes no responsibility for any damage, liability or other loss resulting from the
information contained herein.

. Renesas Technology Corp. semiconductors are not designed or manufactured for use in a device or
system that is used under circumstances in which human life is potentially at stake. Please contact
Renesas Technology Corp. or an authorized Renesas Technology Corp. product distributor when
considering the use of a product contained herein for any specific purposes, such as apparatus or
systems for transportation, vehicular, medical, aerospace, nuclear, or undersea repeater use.

. The prior written approval of Renesas Technology Corp. is necessary to reprint or reproduce in
whole or in part these materials.

. If these products or technologies are subject to the Japanese export control restrictions, they must
be exported under a license from the Japanese government and cannot be imported into a country
other than the approved destination.

Any diversion or reexport contrary to the export control laws and regulations of Japan and/or the
country of destination is prohibited.

. Please contact Renesas Technology Corp. for further details on these materials or the products
contained therein.







IMPORTANT INFORMATION
READ FIRST

* READ thisuser's manual before using thisemulator product.
« KEEP the user's manual handy for futurereference.

Do not attempt to use the emulator product until you fully under stand its mechanism.

Emulator Product:
Throughout this document, the term "emulator product” shall be defined as the following
products produced only by Renesas Technology Corp. excluding all subsidiary products.

e Emulator station

e User system interface cables

e PCinterface board

e Optional SIMM memory module
e Optiona board

The user system or a host computer is not included in this definition.

Purpose of the Emulator Product:

This emulator product is a software and hardware development tool for systems employing the
Renesas microcomputer (hereinafter referred to asthe MCU). This emulator product must only be
used for the above purpose.

Limited Applications:

This emulator product is not authorized for usein MEDICAL, atomic energy, aeronautical or
space technology applications without consent of the appropriate officer of a Renesas sales
company. Such useincludes, but isnot limited to, use in life support systems. Buyers of this
emulator product must notify the relevant Renesas sales offices before planning to use the product
in such applications.

Improvement Policy:

Renesas Technology Corp. (including its subsidiaries, hereafter collectively referred to as
Renesas) pursues a policy of continuing improvement in design, performance, and safety of the
emulator product. Renesas reserves the right to change, wholly or partialy, the specifications,
design, user's manual, and other documentation at any time without notice.

Target User of the Emulator Product:

This emulator product should only be used by those who have carefully read and thoroughly
understood the information and restrictions contained in the user's manual. Do not attempt to use
the emulator product until you fully understand its mechanism.

It is highly recommended that first-time users be instructed by usersthat are well versed in the
operation of the emulator product.
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LIMITED WARRANTY

Renesas warrants its emulator products to be manufactured in
accordance with published specifications and free from defectsin
material and/or workmanship. Renesas, at its option, will repair or
replace any emulator products returned intact to the factory,
transportation charges prepaid, which Renesas, upon inspection,
determine to be defective in material and/or workmanship.

The foregoing shall constitute the sole remedy for any breach of
Renesas warranty. See the Renesas warranty booklet for details on
the warranty period. Thiswarranty extends only to you, the original
Purchaser. It isnot transferable to anyone who subsequently purchases
the emulator product from you. Renesasis not liable for any claim
made by athird party or made by you for athird party.

DISCLAIMER

RENESAS MAKES NO WARRANTIES, EITHER EXPRESS OR
IMPLIED, ORAL OR WRITTEN, EXCEPT AS PROVIDED
HEREIN, INCLUDING WITHOUT LIMITATION THEREOF,
WARRANTIESASTO MARKETABILITY, MERCHANTABILITY,
FITNESS FOR ANY PARTICULAR PURPOSE OR USE, OR
AGAINST INFRINGEMENT OF ANY PATENT. IN NO EVENT
SHALL RENESASBE LIABLE FOR ANY DIRECT, INCIDENTAL
OR CONSEQUENTIAL DAMAGES OF ANY NATURE, OR
LOSSES OR EXPENSES RESULTING FROM ANY DEFECTIVE
EMULATOR PRODUCT, THE USE OF ANY EMULATOR
PRODUCT, OR ITSDOCUMENTATION, EVEN IF ADVISED
OF THE POSSIBILITY OF SUCH DAMAGES. EXCEPT AS
EXPRESSLY STATED OTHERWISE IN THISWARRANTY,
THISEMULATOR PRODUCT ISSOLD "ASIS", AND YOU
MUST ASSUME ALL RISK FOR THE USE AND RESULTS
OBTAINED FROM THE EMULATOR PRODUCT.

RENESAS




State Law:

Some states do not allow the exclusion or limitation of implied warranties or liability for
incidental or consequential damages, so the above limitation or exclusion may not apply to you.
Thiswarranty gives you specific legal rights, and you may have other rights which may vary from
State to state.

The Warranty is Void in the Following Cases:

Renesas shall have no liability or legal responsibility for any problems caused by misuse,
abuse, misapplication, neglect, improper handling, installation, repair or modifications of the
emulator product without Renesas' prior written consent or any problems caused by the user
system.

All Rights Reserved:

This user's manual and emulator product are copyrighted and all rights are reserved by
Renesas. No part of this user's manual, all or part, may be reproduced or duplicated in any form,
in hard-copy or machine-readable form, by any means available without Renesas prior written
consent.

Other Important Things to Keep in Mind:

1. Circuitry and other examples described herein are meant merely to indicate the characteristics
and performance of Renesas' semiconductor products. Renesas assumes no responsibility for
any intellectual property claims or other problems that may result from applications based on
the examples described herein.

2. Nolicenseisgranted by implication or otherwise under any patents or other rights of any third
party or Renesas.
Figures:

Some figures in this user's manua may show items different from your actual system.

Limited Anticipation of Danger:

Renesas cannot anticipate every possible circumstance that might involve a potential hazard.
The warnings in this user's manual and on the emulator product are therefore not all inclusive.
Therefore, you must use the emulator product safely at your own risk.

m
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SAFETY PAGE
READ FIRST

* READ thisuser's manual before using this emulator product.

« KEEP the user's manual handy for futurereference.

Do not attempt to use the emulator product until you fully understand its mechanism.

DEFINITION OF SIGNAL WORDS

A This is the safety alert symbol. Itis used to alert you to potential personal
injury hazards. Obey all safety messages that follow this symbol to avoid
possible injury or death.

A DANGER DANGER indicates an imminently hazardous situation which, if not

avoided, will result in death or serious injury.

A WARNING WARNING indicates a potentially hazardous situation which, if not
avoided, could result in death or serious injury.

|A CAUTION | CAUTION indicates a potentially hazardous situation which, if not
avoided, may result in minor or moderate injury.

| CAUTION | CAUTION used without the safety alert symbol indicates a
potentially hazardous situation which, if not avoided, may result
in property damage.

NOT E emphasizes essentia information.
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AWARNING

Observe the precautions listed below. Failure to do so
will result in a FIRE HAZARD and will damage the user
system and the emulator product or will result in
PERSONAL INJURY. The USER PROGRAM will be
LOST.

1. Do not repair or remodel the emulator product by
yourself for electric shock prevention and quality
assurance.

2. Always switch OFF the E6000 emulator and user system
before connecting or disconnecting any CABLES or
PARTS.

3. Always before connecting any CABLES, make sure that
pin 1 on both sides are correctly aligned.

4. Supply power according to the power specifications and
do not apply an incorrect power voltage. Use only the
provided power cable.

RENESAS




CAUTION

This equipment has been tested and found to comply
with the limits for a Class A digital device, pursuant to part 15
of the FCC Rules. These limits are designed to provide
reasonable protection against harmful interference when the
equipment is operated in a commercial environment. This
equipment generates, uses, and can radiate radio frequency
energy and, if not installed and used in accordance with the
instruction manual, may cause harmful interference to radio
communications. Operation of this equipment in a residential
area is likely to cause harmful interference in which case the
user will be required to correct the interference at his own
expense.

A
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I ntroduction

The E6000 emulator is an advanced realtime in-circuit emulator, which allows programs to be developed and debugged
for the H8 family microcomputers.

The E6000 emulator can either be used without a user system, for developing and debugging software, or connected viaa
user system interface cable to auser system, for debugging user hardware.

High-performance Embedded Workshop (hereafter referred to as HEW) is a Graphical User Interface intended to ease the
development and debugging of applications written in C/C++ programming language and assembly language for Renesas
microcomputers. Itsaim isto provide a powerful yet intuitive way of accessing, observing and modifying the debugging
platform in which the application is running.

HEW is apowerful development environment for embedded applications targeted at Renesas microcontrollers. The main
features are:

* A configurable build engine that allows you to set-up compiler, assembler and linker options via an easy to use
interface.

* Anintegrated text editor with user customizable syntax coloring to improve code readability.
* A configurable environment to run your own tools.

* Anintegrated debugger which allows you to build and debug in the same application.

* Version control support.

HEW has been designed with two key aims; firstly to provide you, the user, with a set of powerful development tools and,
secondly, to unify and present them in away that is easy to use.

RENESAS



About This Manual

Thismanual is comprised of two parts: HEW Part and Emulator Debugger Part.

HEW Part: Information on the basic “look and feel” of the HEW and customizing the HEW environment,
and detail of the HEW’ s build function.

Emulator Debugger Part: Preparation before use, EG000 emulator functions, debugging function, tutorial, and hardware
and software specifications of the E6000 emulator.

Thismanual does not intend to explain how to write C/C++ or assembly language programs, how to use any particular

operating system or how best to tailor code for the individua devices. These issues are left to the respective manuals.

Microsoft”, MS-DOS, Windows”, Windows NT" are registered trademarks of Microsoft Corporation.
Visual SourceSafeisatrademark of Microsoft Corporation.
IBM isaregistered trademark of International Business Machines Corporation.

All brand or product names used in this manual are trademarks or registered trademarks of their respective companies or
organizations.

Document Conventions
This manual uses the following typographic conventions:

Tablel Typographic Conventions

Convention Meaning
[Menu->Menu Option] Bold text with *->’ is used to indicate menu options
(for example, [File->Save As...]).
FILENAME.C Uppercase names are used to indicate filenames.
“enter this string” Used to indicate text that must be entered (excluding the “” quotes).
Key + Key Used to indicate required key presses. For example, CTRL+N means

press the CTRL key and then, whilst holding the CTRL key down,
press the N key.

) When this symbol is used, it is always located in the left hand margin.
It indicates that the text to its immediate right is describing “how to”

(The “how to” symbol) .
do something.

Components

Check all the components described in the component list unpacking. If the components are not complete, contact a
Renesas sdles office.

RENESAS
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1. Overview

The functions for HEW version V.3.01.04 are explained in this manual . This chapter describes the fundamental
concepts of the High-performance Embedded Workshop. It isintended to give users who are new to Windows®
applications, filling in the details that are required by later chapters.

11 Workspaces, Projectsand Files

Just as aword processor allows you to create and modify documents, the High-performance Embedded
Workshop allows you to create and modify workspaces. A workspace can be thought of as a container of
projects and, similarly, a project can be though of as a container of project files. Thus, each workspace contains
one or more projects and each project contains one or more files. Figure 1.1 illustrates this graphically.

WORKSPACE

Figure 1.1: Workspaces, Projectsand Files

Workspaces allow you to group related projects together. For example, you may have an application that needs
to be built for different processors or you may be developing an application and library at the same time. Projects
can also belinked hierarchically within aworkspace, which means that when one project is built al of its“child”
projects are built first.

However, workspaces on their own are not very useful, we need to add a project to a workspace and then add
filesto that project before we can actually do anything.
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1.2 The Main Window

The HEW main window appears as shown in figure 1.2.
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Figure1.2: HEW Main Window

There are three main windows; the workspace window, the editor window and the output window. The
workspace window shows the projects and files which are currently in the workspace, the editor window
provides file viewing and editing facilities and the output window shows the results of a various processes (e.g.
build, version control commands and so on).

121 TheTitle Bar

Thetitle bar displays the name of current activate project and file. It aso contains the standard minimize,
maximize and close buttons. Click the minimize button to minimize the HEW on the Windows® task bar. Click
the maximize button to force HEW to fill the screen. Click the close button to close the HEW (this has the same
effect as selecting [File->EXxit] or pressing AL T+F4).

122 The Menu Bar

The menu bar contains eleven menus: File, Edit, View, Project, Options, Build, Debug, Memory, Tools, Window
and Help. All of the menu options are grouped logically under these headings. For instance, if you wanted to
open afile then the file menu is where you will find the right menu option, if you wanted to set-up atool then the
tools menu is the correct selection. The following sections will cover the functions of the various menu options,
as they become relevant. However, at this stage, it is worth taking a few moments to familiarize yourself with the
options that each menu provides.
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123 TheToolbars

The toolbars provide a shortcut to the options, which you will use the most often. There are ten default toolbars:
Bookmarks, Debug, Debug Run, Editor, Search, Standard, Templates, Version Control, Difference, and Map (as
shown in figure 1.3 to 1.12). Toolbars can be created, modified and removed via the [Tools->Customize...]
menu option (see chapter 6, “Customizing the Environment”, for further information).

Mext Bookmark  Previous Bookmark

Toegle Bookmark Glear All Bookmarks

n&a®

Figure 1.3: Bookmarks T oolbar

TCL Tookit Wiew Disassembly
Command Line Print the Dizassembly window
Enable/Disable Breakpaoint Radix Connect to debue platform

Dizconnect debueg platform

E&(eng z|mm

Togele Breakpoint

X T-IE

Figure 1.4: Debug Toolbar

Rezet CFPU Step Over

Go to Cursor Step Cut
Fezat Go Set PG to Cursor
Glcu Stlep Halt Dlsiplay 2E
|

ETELEIEL & O O @ % 5

Figure 1.5: Debug Run Toolbar

Save File Copy  Match Braces
Open File Save Al Cut Paste Ihzert Template
Mew File ‘ Prirt Toeegle Bookmark,

DEEE & & 2@ To

Figure 1.6: Editor Toolbar

Find in Files Find Mext

| Search String Find ‘ Find Previous
| | |

Cay Istring vl Tt

Figure 1.7: Search Toolbar
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Figure 1.8: Standard Toolbar
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Figure 1.9: Templates Toolbar

Add File (=) Check Out Fileis)
Remove Fileis) Check In File(z)
Get Filets) Show Status
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Figure 1.10: Version Control Toolbar

lgnore white space
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Figure 1.11: Difference Toolbar

M]ap

Figure 1.12: Map Toolbar
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When the Standard toolbar or atoolbar is docked, it has a control bar as shown in figure 1.13 (i). If you want to
move the docked Standard toolbar, click and drag its control bar to the new location. Figure 1.13 (i) showsthe
Standard toolbar when it is docked and figure 1.13 (ii) shows the Standard toolbar when it is floating.

=] |[oebug Hia s |m =

=] |[pebug BIET =Y

Figure 1.13: Standard Toolbar, Docked and Floating

2 Todock atoolbar:

1. Double-click on thetitle bar of afloating toolbar.

or:

2. Dragthetitle bar of afloating toolbar and draw it toward an edge of a docked window, menu bar, toolbar
or the HEW main frame, on whose edge you would like to dock the window, until the shape of the
floating bar changes.

2 Tofloat atoolbar:

1. Double-click on the control bar of a docked toolbar.

or:

2. Drag the control bar of adocked toolbar and draw it away from the edge of the HEW main frame and
from an edge of the other docked windows, toolbar.

124 The Workspace Window

The “Workspace” window has three panes. The “Projects’ tab shows the current workspace, projects and files
(figure 1.14). Y ou can quickly open any project file or dependent file by double clicking on its corresponding
icon.

o Workspace M= ER

E@ Demao

EI@ Demo
=+ Aszembly source file
D[ lowbd s
=23 C source fle
; dbsct.c
Demo.c
intpra.c
lowsrc.c
resetprg.c

n o
B wectthl.c
#-[Z] Dependencies

Mavigation Tab

Templatez Tab

Project Tab —
N @ijects IE Templates J QNa\rigaﬁun I

Figure 1.14: Workspace Window Projects Tab
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The “Navigation” tab provides jumpsto various textual constructs within your project’s files. What is actually
displayed within the navigation tab depends upon what components are currently installed. Figure 1.15 shows
ANSI C functions. See chapter 2, “Build Basics’, for more information on the “Workspace” window.

The“Templates’ tab displays template settings. See 4.12, “ Templates’, for more information about a template.

- Workspace

IS[=] E3
=

=l
=_| Navigation I

@ijecﬁ I @Templates

Figure 1.15: Workspace Window Navigation Tab

2 Toadlow the “Workspace” window or the “ Output” window docking:

Click the right mouse button anywhere inside the “Workspace” window or the “ Output” window. Then a
pop-up menu will be displayed. If [Allow Docking] is checked, docking is allowed; otherwise, docking is not
allowed. Select [Allow Docking] to check or uncheck it.

When [Allow Docking] is checked, you can dock awindow to the edge of the HEW main window or to the edge
of another docked window. Alsoif [Allow Docking] is checked, you can float them “above” the other HEW
windows or outside the HEW main window. Figure 1.16 (i) shows a docked “Workspace” window, and figure
1.16 (ii) shows afloating “Workspace” window.

==l <& Workspace [_[O[x
EI@ Dema - E'@ Dema
5 @ 2
Ea Agzembly saurce file Bl Assembly source file
o[ lowivlsre C [ ol sre
{23 Csource file 23 C souice file
: dbsct.c
Demo.c
intprg.c
lowsre.
resetprg.c resetprg.c
shrk.c i shrk.c
Pl wectthl.c | vecttbl.c
I ) Projects IE Terplates ] “_] Navigation I - Dependercies

| @ijem IE Templates I ] Mavigation

Figure 1.16: Workspace Window, Docked and Floating
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When the “Workspace” window or the “ Output” window is docked, it has a control bar as shown in figure 1.17.
If you want to move a docked window, click and drag its control bar to the new location.

'Close' buthon

1= |

Figure 1.17: Control Bar of Docking Window

2 Todock the “Workspace” window or the “Output” window:

[Allow Docking] must be checked on the pop-up menu of the window to dock the “Workspace” window or

the “QOutput” window. (The pop-up menu will be displayed when you click the right mouse button anywhere

inside the window.) Then you have two ways to dock the window.

1. Double-click on the control bar of afloating window.

or:

2. Dragthetitle bar of afloating window and draw it toward an edge of a docked window, menu bar or
toolbar, or the HEW main frame, on whose edge you would like to dock the window, until the shape of
the floating window changes.

2 Tofloat the “Workspace” window or the “ Output” window:
[Allow Docking] must be checked on the pop-up menu of the window to float the “Workspace” window or
the “QOutput” window. (The pop-up menu will be displayed when you click the right mouse button anywhere
insde the window.) Then you have two waysto float the window.
1. Double-click on the control bar of a docking window.
or:
2. Drag the control bar of adocked window and draw it away from the edge of the HEW main frame and

from an edge of the other docked windows, menu bar or toolbar.

2 To hide the “Workspace” window or the “Output” window:
Click on the close button, which islocated in the top right corner of the window. Or push the right mouse
button anywhere inside a floating window and select [Hide] on the pop-up menu.

2 Todisplay the “Workspace” window or the “ Output” window:
Select [View->Workspace] or [View->Output], respectively.

125 The Editor Window

The editor window is where you will work with the files of your project. The HEW allows you to have many
files open at one time, to switch between them, to arrange them and to edit them in whichever order you want to.
By default, the editor window is displayed in a notebook style, where each text file has a separate tab (as shown
infigure 1.18).

The editor contains a gutter on the left-hand side of the window. The standard column allows the user to
configure the position of bookmarks and software breakpoints quickly and easily.

If you are unsure what purpose a column has or what the information it is displaying isif you place the cursor
over the column atool tip is displayed showing itsidentity.
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#include <stddef h:
#include <stdio h:
#include "sbrk. h"

ssconst size t _sbrk_sizes % Specifie=z the minimum unit of */
<% the defined heap area */

extern char *_slptr;

static union |

long  dummy | <% Dummy for 4-byte boundary *.
char heap[HEAPSIZE]; -#* Declaration of the area managed *.
S by =hrk =~

theap_area
=static char #*brk=i{char *)&heap_area -* End addres= of area assigned

»

S* sbrk:Data write

S Return walus:Start address of the assigned area (Pass)

S -1 (Failurs)

Es

char #*sbrki{unsigned long =ize) <% hAz=zigned area size *

char *p;

if (brk+sizerheap_area. heap+HEAPSIZE) ~# Empty area size EY N
Kaf| v

< resetprge |0+ dbsote olE shrk I

Figure 1.18: Editor Window

The editor window can be customized viathe “Format Views’ diaog box, which can be invoked viathe [Tools-
>Format Views...] menu option. Thisdialog alows you to configure fonts, colors, tabs and so on for the editor
window. It aso alowsthe user to change the ook of other views, which have been installed by HEW. If you
would prefer to use your favorite editor rather than the HEW internal editor then specify your aternativein the
“Options’ dialog box, which can be invoked via the [Tools->Option...] menu option. For further details on how
to use and configure the editor, refer to chapter 4, “Using the Editor”.

126 The Output Window

The “Output” window by default hasfour tabs on display. The “Build” tab shows the output from any build
process (e.g. compiler, assembler and so on). If an error is encountered in a source file then the error will be
displayed in the build tab along with the source file name and line number. To quickly locate a problem, double
click on the error to jump to the source file and line.

x|

E

| 4]+ Build £ Tebug /i Find in Files }, ersion Ganirol /

Figure 1.19: Output Window

The “Debug” tab shows the output from any debugger process. Any debug component that needs to display
information will send its output to this window.

RENESAS




The“Findin Files’ tab displaysthe results of the last “Find in Files” action. To activate find in files, select the
[Edit->Find in Files...] menu option, the toolbar button. For further details on how to use find in files, refer to

chapter 4, “Using the Editor”.

The“Version Control” tab displays the results of version control actions. The tab isonly displayed if aversion
control systemisin use. For further details on version control, refer to chapter 7, “Version Control”.

127 The Status Bar

The status bar displays information as to the current state of the HEW. Figure 1.20 shows the eight sections of
the status bar.

Displays HEW status messages Wirtual desktop Fead-only status Line rumber Insettion mods  Mum Lock
Colurnn rumber | Caps Lock
Ready Fz |Defaultt desktop  Read-write [ezrar [& s LM Al

Figure 1.20: StatusBar

13 TheHelp System

The help menu is the rightmost menu on the HEW menu bar. It contains the menu option “ Contents” which,
when sdlected, takes you to the main HEW help window.

To obtain help on specific dialogs click on the context sensitive help button, which islocated in the top right-
hand corner of each dialog box (as shown in figure 1.21).

jﬂ
Context sensitive help butten

Cancel butten

Figure 1.21: Help Button

When thisis clicked, the mouse pointer will change to a pointer with a question mark above it. Whilst the mouse
pointer isin this state, click on the part of the dialog box that you require assistance on.

Alternatively, select the control that you require help for and then press the F1 key.
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14 Launching the HEW

To run the HEW, open the “ Start” menu of Windows®, select “ Programs’, select “ Renesas High-performance
Embedded Workshop” and then select the shortcut of the HEW. By default, the “Welcome!” dialog box shown
in figure 1.22 will be displayed.

Welcomel E E2
— Options:
] + Create a new project workspace:
Cancel |
= Open a recent project work space: Administration. .. |
% IE:\Hew\demn'\demo.hws ﬂ
=

g ' Browse to another project workspace

Figure 1.22: Welcome! Dialog

To create a new workspace, select “ Create a new project workspace”, and click “OK”. To open one of recent
project workspaces, select “Open arecent project workspace”, select a workspace from the drop-down list, and
click “OK”. The recent project workspace list displays the same information as that seen in the workspace most
recently used filelist. Thislist appears on the file menu. To open aworkspace by specifying aworkspace file
(\HWSfile), select “Browse to another project workspace”, and click “OK”. To register atool to or unregister a
tool from the HEW, click the “ Administration...” button (see chapter 5, “Tool Administration” for details).
Click the “Cancel” button to use the HEW without opening a workspace.

15 Exitingthe HEW

The HEW can be exited by selecting [File->EXxit], pressing AL T+F4 or by selecting the close option from the
system menu. (To open the system menu, click the icon at the upper-left corner of the HEW title bar.) If a
workspace is open then the same workspace closedown procedure is followed as described in the previous
section.

16 Component System Overview

The HEW allows the user to extend the HEW functionality by adding additional components to the system. This
is achieved by registering the component in the Tools Administration dialog box. These components can add
windows, menus and toolbars to the HEW system. Examples of the components are the debugger and builder
components of HEW. The debugger component adds all of the menus and toolbars associated with the debugger
and the builder component does the same for the build functionality. The components you have registered in the
system will modify the look and feel of HEW. In some cases you may not have some of the menus which you
can seeinthismanual. For instance if the debugger component is not installed you will not have the “ Debug”
menu in the HEW main window.

10
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2. Build Basics

This chapter explains the general basic functions of the HEW whilst the more advanced features can be found in
chapter 3, “ Advanced Build Features’.

2.1 The Build Process

Thetypical build processis outlined in figure 2.1. This may not be the exact build process, which your
installation of HEW will use asit depends upon the tools that were provided with your instalation of HEW (e.g.
you may not have a compiler for instance). In any case, the principles are the same - each step or phase of the
build takes a set of project files and then builds them, if al succeeds then the next step or phase is executed.

4 suo EF

COMPILER

Source Files

Iil ﬂ_' ASSEMBLER
T Assembler
/A Source Files

L» LINKER Object
Files

Library
Files ‘

Load
Module

Figure 2.1: Typical Build Process

In the example shown in figure 2.1 the compiler is the first phase, the assembler is the second phase and the
linker isthe third and final phase. During the compiler phase, the C/C++ source files from the project are
compiled in turn, during the assembler phase, the assembler source files are assembled in turn. During the linker
phase all library files and output files from the compiler and assembler phases are linked together to produce the
load module. This module can then be downloaded and used by the debugger functionality in HEW.

The build process can be customized in several ways. For instance, you can add your own phase, disable a phase,
delete phases and so forth. These advanced build issues are left to chapter 3, “ Advanced Build Features’. In this
chapter, only the general principles and basic features will be detailed.

11
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22 Project Files

In order for the HEW to be able to build your application, you must first tell it, which files should be in the
project, and how each file should be built (figure 2.2).

Add Project Files

Remove Project Files

Project
Debug: ON . . :T
Optimize: OFF Set Compiler Options
List File: YES c
Source Files
Debug: OFF
Optimize: OFF Set Assembler Options
List File: YES Assembler
Source Files
Debug: ON —_—
Silent? YES Set Linker options j
Map File: YES Library
Files

Figure 2.2: Editing a Project
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221 Adding Filesto a Project

Before you can build your application you must first inform the High-performance Embedded Workshop, which

filesit is composed of.

2 Toadd afilesto aproject:

1. Select [Project->Add Files...], or click the right mouse button on a project icon in the “Projects’ tab of
the “Workspace” window and select [Add Files...] from the pop-up menu (see figure 2.3), or pressINS

when the “Workspace” window is selected.

Cpen dbsct.c

Build dbsct.c

Build Cptions 4

Add Files., .. IS
Remove Files...

Exclude Build dbsct.c

Wersion Control L4

Configure View. ..

Show Differences. ..

IT Allow Docking
Hide

Properties

Figure 2.3: Projects Tab Pop-up Menu

2. The“Add” dialog will be displayed.
3. Select the file(s), that you want to add and then click “Add”.

RENESAS

13




There are anumber of other waysto add new files to the project. These are described below:

*  Clicking right button on an open file in the editor window displays a pop-up menu option (figure 2.4). If the
fileisalready in the project then the “Add File to Project” menu option isdisabled. Selecting the “Add File
to Project” then adds the file to the current project.

Build File "dbsck.c"

Instant Wakch

Cuk Chrl4n
Copy Chrl+C
Baste (e
Add File To Project 4
Find. .. Chrl+F
Find In Files. .. F4
Replace, .. Zhrl+H
Goko Ling... Chrl+G
1} Match Eraces ShiFt+HCtr (41
Bookmarks 4
Templates L4
Toqgagle Breakpaoink F9
H Emable/isable Brealpoint e ]

Define Column Format, .

Columns L4

o Ta Cursar

Sek PC Here

Display P

G0 To Disassembly

Figure 2.4: Editor Window Pop-up Menu

e Inthe HEW itisalso possibleto “Drag and Drop” files from Windows® Explorer onto the workspace
window. These fileswill be automatically added to the project and are displayed in the folder in which they
were dragged to.

Note: If you add afileto a project when it isan unrecognized file type then it will still be added to the project.
Certain functions will be disabled with reference to thisfile. When thisfile is double clicked in the workspace
window instead of opening the file in the editor the open operation is passed to Windows® operating system.
The default open operation isthen carried out asif the file was opened in Windows® Explorer. To view the
current defined extensions use the “ File Extensions’ dialog (see the section on file extensions later in this
chapter).

14
RENESAS




222 Removing Filesfrom a Project

Files can be individually removed from a project, selections of files can be removed or dl files can be removed.

2 Toremove files from aproject:

1. Select [Project->Remove Files...], or click the right mouse button on a project icon in the “ Projects’ tab

of the “Workspace” window and select [Remove Files...] from the pop-up menu (see figure 2.5). The

“Remove Project Files’ dialog will be displayed (figure 2.6).

Open dbsct.c

Build dbsct.c

Build Options

Add Files. ..

Remove Files. ..

INS

Exclude Build dbsct.c

‘ersion Control

Configure Yiew, .,

Show Differences. .

IT Allow Docking

Hide

Properties

Figure 2.5: Projects Tab Pop-up Menu

Remove Project Files

Project files:

oK

intprg. s
resetprg. sic
shrk.c
stacksct. src
vectthl sz

|

[z:\hewhdema'.demo]
[=:Shewhdemohdemo]
[z:\hewhdema'.demo]
[=:Shewhdemohdemo]
[z:\hewhdema'.demo]

Cancel

Bemove

Uil

Remaove All

3

Figure 2.6: Remove Project Files Dialog
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2. Select the file or files which you want to remove from the “ Project files” list.
3. Click the “Remove” button to remove the selected files or click “Remove All” to remove all project files.
4. Click “OK” to remove the files from the project.
2 Toremove selected files from a project:
1. Select thefiles, which you want to remove, in the “Projects’ tab of the “Workspace” window. Multiple
files can be selected by holding down the SHIFT or CTRL key.
2. Pressthe DEL key. Thefileswill be removed.

223 Excluding a Project File from Build
A filein aproject can beindividually excluded from build on a configuration by configuration basis.

2 Toexcludeafilein aproject from build:
1. Push theright mouse button on afile, which you want to be excluded from build, in the “Projects’ tab of
the “Workspace” window.
2. Select [Exclude Build file], where <file> is the selected file, from the pop-up menu (figure 2.5). Then a
red cross will be put on the file'sicon, and the file will be excluded from build.

224 Including a Project Filein Build
An excluded file can be included in the project again.

2 Toinclude afile which has been excluded from build:
1. Push theright mouse button on afile, which has been excluded from build, on the “Projects’ tab of the
“Workspace” window.
2. Select [Include Build file ], where <file> is the selected file, from the pop-up menu. Then ared cross will
be removed from the file'sicon, and the file will be included in build.

16
RENESAS



23 File Extensions and File Groups

The HEW can identify files by their extension. The system defines certain extens ons depending upon the tools,
which are being used. For example, if you are using a compiler then the .c extension will bein the “C source
file” group and be used as input to the compiler phase (figure 2.1, Typica Build Process). Additionally, the
HEW allows you to define your own extensions. For example, if the project you are devel oping uses assembler
source files the default extension may be .src. If you would like to use a different extension instead of .src

(e.g. .asm) then you can define a new extension and request that the HEW treatsit in the same way asa.srcfile.

File extensions and file groups can be viewed and modified viathe “File Extensions’ dialog (figure 2.7). Thisis
invoked by selecting [Project->File Extensions...]. Thisdiaog displays all of the extensions and file groups,
which are defined within the current workspace.

Extension | Group - Ok I

D *.abs Absalute file

*.inc Aszsembly include file Cancel |

#.lis Assembly list file i

*.zrc Azzembly source fila ==
E*n C header file Femove |
[EEAE G list file =

*.c G source file Open with...
*hpp G+t header file

Gt list file

Figure 2.7: File Extensions Dialog

The “File Extensions’ list shown in figure 2.7 is divided into two columns. On the left are the file extensions
themselves, whilst on the right are the file groups. Many file extensions can belong to the same group. For
example, assembler source files may have several extensionsin asingle project (e.g. .src, .asm, .mar €tc) as

shown in figure 2.8.
.SRC .ASM .MAR ‘ .LIB .LPF

Assembler source files C source files Library files

Figure 2.8: File Extensionsand Groups

When creating a new extension you should consider whether the extension belongs to a group, which is already
defined, or whether you need to create anew file group. If you are adding a completely new type of file then you
will want to create anew file group. This processis described below.
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To create anew file extension in anew file group:

. Select [Project->File Extensions...] from the menu bar. The “File Extensions’ dialog will be displayed

(figure 2.7).

. Click the“Add...” button. The “Add File Extension” diaog will be displayed (figure 2.9).
3. Enter the extension, which you want to define into the “ File extension” field. It is not necessary to type

thedot ( .) character. Thedrop list containsall extensons that are undefined in the current project.
Selecting one of these extensions will add the text to the file extension field automatically.

. Select the “Extension belongs to a new group” option and enter a description, which defines this new file

group.
At thisstageit is possible to change the associated application. There are four available choicesin the
“Open” with drop list. These are listed below:

e Editor
* None
e Other

e Windows default

If the editor is selected, the open file function in the workspace window causes the file to be opened in the
HEW editor. If noneis selected then the open operation is disabled when the open file functionis
attempted. Selecting “Other” allows you to configure an another tool for the open file operation. See“To
associate an application with a file group” for more details. If the “Windows default” option is selected
then the open file function in the workspace window passes the open file to the Windows operating
system. Thisthen selects the default behavior for thisfile extension as defined in Windows® Explorer.

. Click “OK” to add the extension to the “File Extensions’ list.

Add File Extension llﬂ

r Eile extension: I
File extenzion: oK
= It:-tt VI

— File group:

Cancel |

{~ Estension belongs ta an existing group:
| &bsolute file =]

' Extension belongs to a new group:
ITe:-tt

—Aszociated application:
Dpen "Test" with;
wiidowes default j

Sdd...

Fioditp.. |
[aemere |

Bemove
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Figure 2.9: Add File Extension Dialog (New Group)
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If you want to create a new extension because your project uses a different extension from those accepted by the
HEW. For example, aphase might by default use the extension .asm but the HEW only recognizes .src.  Then
you need to create a new extension and add it to an existing file group. This process is described below.

2

To create anew file extension in an exigting file group:

. Select [Project->File Extensions...] from the menu bar. The “File Extensions’ dialog will be displayed

. Click the“Add...” button. The “Add File Extension” dialog will be displayed (figure 2.10).

3. Enter the extension, which you want to define into the “ File extension” field. It is not necessary to type
the period ( . ) character. The drop list contains all extensions that are undefined in the current project.
Selecting one of these extensions will add the text to the file extension field automatically.

. Select the “Extension belongs to an existing group” option and select which group you would like to add
this new extension.

. Click “OK” to add the extension to the “File Extensions’ list.

Add File Extensian

— File extenzion;

# Iasm VI

Cancel |

— File group:

{* Estension belongs ta an existing group:

I.&ssembl_l,l zource file

" Extension belongs to a new group:

=

—Aszociated applization:

Hpem aroum with:

Editor =l

Add)
Todify..

Bemove

Lioity |
[aemere |

Figure 2.10: Add File Extension Dialog (Existing Group)

In addition to opening a file with the editor, the “File Extensions” dialog allows you to associate any application
with any file group so that when you double click on afilein the “Projects’ tab of the “Workspace’ then the
appropriate application is launched with the file. Figure 2.11 shows the association between a word processor
and the extension .DOC.
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File Extensions

Extension | Group AI Ok I

*lpp o list file

Text editor —-@ *.cpp CH+ zource file Cancel |

D*.cpu CPU information file

Werd processer — W+ doc Documents fdd.
*.exp Expanded assembly source file Emeua |
Librarian ——4 lib Library file

E=l Library list file Open with..
*.sct Library section list file
*.map Linkage map file
*.fsy Lirkage symbal filz

Mo applization —— ] #.obj Object file

S Praremraszad C snoeea fils i
4 | I»

Figure 2.11: File Groupsand Applications

2 To associate an application with a file group:
1. Select thefile group to be associated from the “ File Extensions’ dialog (figure 2.11).
2. Click the “Open with...” button. The “Modify File Extension” dialog will be displayed (figure 2.12).

Group:

i i
Linkage map file
—Associated application: Cancel |

Open " Linkage map file™ with:

Mane j

Edlitor

Other
Windows default e clify.

Bemuye

Figure2.12: Modify File Extension Dialog
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3. Select “None” to remove any association, select “Editor” to open thistype of filein the internal/external
editor or select “Other” if you want to open thistype of file with a specific application.

If you select “Other” then you can select from any previously defined application from the drop-down list
or specify anew application.

Click “Add..."” to define anew application. The “Add Application” dialog will be displayed (figure 2.13).
Enter the name of the tool into the “Name” field. Enter the full path to the tool in the “Command” field
(do not include any parameters). Enter the parameters that are required to open afilein the “ Parameters’
field. Be sure to use the $(FULLFILE) placeholder to specify the location file (see appendix C,
“Placeholders’, for more information on placeholders and their uses). Enter theinitial directory, in which
you would like the application to run, into the “Initia directory” field. Click “OK” to create the
application.

Add Application

HE

I Cancel

LCommand [excluding parameters):

I Ll Browsze... |

Paraneters:

! il

nitial directon:

l
I Ll Browsze... |

Figure 2.13; Add Application Dialog
Click “Modify..."” to modify an application. The “Modify Application” dialog will be displayed. This

dialog isthe same asthe “Add Application” dialog described above except that the “Name” field isread
only. Modify the settings as desired and then click “OK”.

4. Click “OK" to set the application for the selected file group.
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24 Specifying How to Build a File

Once you have added the necessary files to the project the next step isto instruct the HEW on how to build each
file. To do this, you will need to select a menu option from the “ Options” menu. The contents of this menu
depend upon which tools you are using.

2 To set options for abuild phase:
1. Select the options menu and find the phase whose options you would like to modify. Select this option.
2. A dialog will be invoked which allows you to specify the options.
3. After making your selections, click “OK” to set them.

To obtain further information, use the context sensitive help button or select the areain which you need
assistance and then press F1.
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25 Build Configurations

The HEW allowsyou to store dl of your build optionsinto a build configuration (figure 2.14). This means that
you can “freeze” all of the options and give them a name. Later on, you can select that configuration and all of

the options for all of the build phaseswill be restored. These build configurations also alow the user to specify
debugger settings for a build configuration. This meansthat each configuration can be targeted at a different end

platform. (See Emulator Debugger Part in this manual, for further information).

Figure 2.14 shows three build configurations; “ Default”, “MyDebug” and “MyOptimized”. In the first
configuration, “ Default”, each of the phases (compile and assemble) are set to their standard settings. In the
second configuration, “MyDebug”, each of the files are being built with debug information switched on. In the
third configuration, “MyOptimized”, each of the files are being built with optimization on full and without any
debug information. The devel oper of this project can select any of those configurations and build them without
having to return to the options dia ogs to set them again.

"Default" "MyDebug" "MyOptimized"
Configuration Configuration Configuration
— Debug: ON Debug: ON Debug: OFF
- 'Optimize: OFF Optimize: OFF Optimize: ON
List File: YES | List File: NO | List File: NO | H
C
Source Files
= Debug: OFF Debug: ON Debug: OFF
Optimize: OFF Optimize: OFF Optimize: ON
List File: YES | [ List File: NO || List File: NO | [
Assembler
Source Files
C:\MyProject\Default C:\MyProject\MyDebug C:\MyProject\MyOptimized

Figure 2.14: Configurationsand File Options
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251 Selecting a Configuration
The current configuration can be select in two ways:
Either:

1. Selectit from the drop down list box (figure 2.15) in the toolbar.
2. Theconfiguration is selected.

IFleIease

Release

Figure 2.15: Toolbar Selection
or:

1. Select [Options->Build Configurations...]. Thiswill invoke the “Build Configurations’ Dialog (figure
2.16).

Build Configurations

Build configurations: Ok
Releazs Cancel |
Add...

HEemayve |

Current configuration;

Debug j

Figure 2.16: Build Configurations Dialog

2. Select the configuration that you want to use from the “ Current configuration” drop down list.
3. Click “OK" to set the configuration.
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252 Adding and Deleting Configurations

Y ou can add a new configuration by copying settings from another configuration or delete a configuration. These
three tasks are described below.

2 To add anew configuration:
1. Select [Options->Build Configurations...] to display the “Build Configurations® dialog (figure 2.16).
2. Click the“Add...” button. The “Add Configuration” dialog will be invoked (figure 2.17).

Add Configuration E2

Configuration name: IM}'CUHHQ
Cancel
Bazed on configuration: IDebug ﬂ —l

Caorfiguration directan: c:ihewhdemohdemohyConfig

Figure 2.17: Add Configuration Dialog

3. Enter the new configuration name into the “Configuration name” field. Asyou enter the new
configuration name, the directory underneath changes to reflect the configuration directory that will be
used. Select one of existing configurations, from which you want to copy aconfiguration, out of the drop-
down list of the “Based on configuration” field. Click “OK" on both dialogs to create the new
configuration.

2 Toremove aconfiguration:
1. Select [Options->Build Configurations...] to display the “Build Configurations® dialog (figure 2.16).
2. Select the configuration that you want to remove and then click the “Remove” button.
3. Click “OK" to close the “Build Configurations® dialog.
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2.6 Building a Project

The outline of the build processis shown in figure 2.1.

26.1 Building a Project

The build option only compiles or assembles those files that have changed since the last build. Additionally, it
will rebuild source files if they depend upon afile that has changed since the last build. For instance, if the file
“test.c” #include' sthe file “header.h” and the latter has changed since the last build, the file “test.c” will be
recompiled.

2 To perform abuild:

Select [Build->Build] or click the build toolbar button () or press F7 or click the right mouse button on a
project icon in the “ Projects’ tab of the “Workspace” window and select [Build] from the pop-up menu.

The build al option compiles and assembles all source files, irrespective of whether they have been modified or
not, and links all of the new object files produced.

2 Toperformabuild al:

Select [Build->Build All], or click the build all toolbar button (), or click the right mouse button on a
project icon in the “Projects’ tab of the “Workspace” window and select [Build All] from the pop-up menu.

262 Building Individual Files
The High-performance Embedded Workshop |ets you build project filesindividually.

2 Tobuild anindividua file:
1. Select the file which you want to build from the project window.

2. Select [Build->Build File], click the build file toolbar button (8) or press CTRL +F7 or click the right
mouse button on afileicon in the “Projects’ tab of the “Workspace” window and select [Build <file>]
from the pop-up menu.

26
RENESAS



26.3 Stopping a Build
The High-performance Embedded Workshop allows you to halt the build process.

2 To sop abuild:

1. Select [Build->Stop Build] or click the stop build toolbar button (#%). The build will be stop after the
current file has been built.

2. Wait until the message “ Compiler Finished” appearsin the “Output” window before continuing.
2 Toforcibly terminate a current tool
1. Select [Build->Terminate Current Tool]. The HEW will attempt to stop the tool immediately.

Note: Do NOT assume that any output from the tool you terminated isvalid. It is recommended that you delete
any output files produced and ensure that the phase is executed again.

26.4 Building Multiple Projects
The High-performance Embedded Workshop |ets you build multiple projects and configurations at once.

2 To build multiple projects:

1. Select [Build->Build Multiple]. Thefigure displayed in figure 2.18.

2. Thebuild multiple gives you the choice of which projects and configurations should be built. To select
which projects and configurations need to be built select the check box next to the project —
configuration combination you want to build. For example, in figure 2.18 if you wanted to build the
entire “hewtest2” project you would check the “hewtest2-Debug” and the “hewtest2-Release” selections
and leave al other check boxes unchecked.

3. When you are happy with your chosen selection click the build button and the HEW will then build the
projects and configurations you have chosen.

4.  If you want to build all the projects, which you choose, you click the build al button.

5. Results from the build are displayed in the build window in the same way as the normal build process.

Build Multiple E

[ |hewtest1-Debug -
[ |hewtzzt1-Release

[ hewtest2-Debug Build Al

[ |hewtzztZ-Release

[ |hewtest3-Debug
C | |
[ |hewtzzt3-Release anee

[ |hewtestd-Debug

[ |hewtzztd-Release

[ |hewtests-Debug

[ |hewtzzth-Release _Ij
4 | | »

Figure 2.18: Build Multiple Dialog
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26.5 The Output Window

When atool executes (i.e. compiler, assembler, linker etc.) its output is displayed in the “ Output” window. If any
of the tools produce any errors or warnings then they are displayed along with the source file name and the line
number at which the error islocated. To quickly locate a specific bug, double click on agiven error/warning to
invoke the current editor.

2.6.6 Contralling the Content of the Output Window

It is often useful to display extrainformation (such as the command line options that are being applied to afile)
during a build. The HEW dlows you to specify whether or not you want such options displayed in the “ Output”
window during abuild, build all or build file operation via the “ Tools Options” dialog.

2 Toview or hide extrainformation during a build:

1. Select [Tools->Options...]. The “Options’ dialog will be displayed.

2. Select the“Build” tab (figure 2.19).

3. Set the three check boxesin the “ Show” group as follows. “Command line” controls whether the
command line is shown as each tool is executed. “ Environment” controls whether the environment is
shown as each tool is executed. “Initial directory” controls whether the current directory is shown as each
tool is executed.

28
RENESAS



Qptions

Buid |Editnl | Wworkspace | Confirmation | Metwark |

— Errarg and warnings:

[ Stop build if the number of emors exceeds: I 0

[ Stop build if the number of warnings exceeds: I i]

= Show:

v i v Initial directorny

¥ Enyironment W Mark out of date files
r— Makefile build

Command [exchuding parameters]:

[ Use makefile build system

[SHEWDIR ek ve L| e, |

I aletile options:

| 2

I akefile path:

™| Generate makefile before build commences

I$[WDF|KSF'DIH]\make'\ﬁS[F'HEIJECTNAME].mak Ll Browse.. |

[ o |

Cancel

Figure 2.19: Options Dialog Build Tab
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26.7 Displaying out of date filesin the workspace window

Files updated later than the file generated by the previous build (i.e. out of date files) are marked in the
workspace window. In figure 2.20 below, file "demo.c" is out of date.

When you click build next time this file will be re-built. Thisis also displayed for dependent projects of the
current project.

The view of thesefilesis updated whenever something that affects the build occurs, e.g. options changing, file
addition, dependencies changing, files modified, etc.

E
= dema
5 gEm
-2 Assembly source file
& intpra.snc
el g1z
vechtbl src
- |&] vhandler.sc
E-423 C source file
- dbsct.c
demo.c
lowsrc.c
= resetprg.c
| ] sbrke

=43 Download modules
demo.abs
Ea D ependencies
env.inc
lowsr.h
B shikh
stackscth
veckinc

_@Prujectsl@Templates J€|Navigati0n ]

Figure 2.20: Displaying out of date files

2 Todisplay out of date filesin the workspace window:
1. Select [Tools->Options...]. The“Options’ dialog will be displayed.
2. Select the“Build” tab (figure 2.19).
3. Check the “Mark out of date files” check box.
4. Click OK.
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27 File Dependencies

A typical project will contain dependencies between files, for example, one C file may “#include” one or more
header files. In complex projects, source files will include (or depend upon) others and this can quickly become
difficult to manage. However, the HEW provides a dependency scanning mechanism whereby all filesin a
project are checked for dependencies. Once complete, the project window will display an up-to-date list with al
the project file dependencies.

2 To update aproject’s dependencies:
Select [Build->Update All Dependencies] or click the right mouse button on a project icon in the “ Projects’
tab of the “Workspace” window and select [Update All Dependencies] from the pop-up menu.

Initially, the dependenciesfor all files are contained within the “ Dependencies’ folder (figure 2.21.i).

2.8 Configuring the Workspace Window

If you click the right mouse button anywhere inside the “ Projects’ tab of the “Workspace” window, a pop-up
menu will be invoked. Select the “Configure View...” menu option to modify the way in which information is
displayed. The following four sections detail the effect of each option on the “Configure View” diaog.

281 Show Dependencies under Each File

If you select “ Show dependencies under each file”, the dependent files are shown under the including source file
asaflat structure, i.e. the files themselves become folders (figure 2.21.ii). If this option is not selected then a
separate folder contains all dependencies (figure 2.21.i).

i i BEIE
E--@ Demo E--@ Demo
E| N Assembly source file = 4 Assembly source file
2] lowikl.sre F [ d) lowiklsre
Ela C zource file EI a Csource file
. dbsct.c dbsct.c
. Demo.c . Demo.c
. intprg.c = ntprg.c
lowsrc.c wecth
esetprg.c =- lowsic.c
shrk.c : lowesrc. b
vecttble =- Iesetpra.c
=23 Dependencies stackscth
lovesic.h =2 shik.c
-2 strkh shik h
stackscth & vectthle
vecth wecth
@ijedx IE Ternplates J “] Mavigation I @ Projects IE Templates J “] Mavigation I

Figure 2.21: Dependencies under Each File
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282 Show Standard Library Includes

By default, any dependent files found in standard include paths will not be shown (figure 2.22.i). For example, in

C code, if you write an include statement such as “#include <stdio.h>" then stdio.h will not be listed asa
dependent file. To view such system include files, select the “ Show standard library includes’ option (figure

2.22.ii).
j L = voivace R
B Bl
=8 I@ Demo B- @ Demo
E| 9 Aszembly source file E| a Assembly zource file
cllzrc cl.zrc
EI a C source file EI a C zource file
hwchg e ] hwefgc
intv.c intv.c:
main. o main.c
shrk.c i shrk.c
4 Dependencies EI a [Dependencies
stddef h
2] stdiak

N ) Projects l ] Termplates | ] Mavigation I N 2] projects l E] Templates | 1 Navigation I

Figure 2.22: Standard Library Includes

283 Show File Paths

If “Show file paths” is selected, al of the filesin the project window are shown with their full path, i.e. from a
drive letter (figure 2.23).

<& Workspace Hi[=] E3

E‘@
El- @ Demo

E| {23 Assembly source file

H [&] C:\Hew2\Demo\Demohel sic
C zource file
C:A\Hew2hDemo\Demaoshwelg.c
C:\Hew2\DemohDemaobinty.c
C:vHew2hDemo\Demotmain.c
- [%] C:\Hew2\DemoDemohsbrk.c
------ L9 Dependencies

N '@ijec‘ts l @ Templates J @Na\tigaﬁon I

Figure 2.23: File Paths Shown
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284 Sort files by time order
When this option is selected the workspace window is then sorted into file time stamp order.
If files are updated after selecting this option, manually update the order of these files.

2 To manualy update the file order:
1. Select “Refresh order” in the pop-up menu on the “ Projects’ tab of the “Workspace” window.

2.9 Setting the Current Project

A workspace can contain more than one project but only one of the projects can be active at any time.  This
active project is the one, which build actions and debug operations can be performed on. It isaso possibleto
change the builder or debugger options for the project. This active project is shown as bold characters.

2 To set aproject asthe current project:
1. Select anon-active project from the “Projects’ tab of the “Workspace” window.
2. Click the right mouse button to display the pop-up menu and select the [Set as Current Project] option.
or:
1. Select the project, which you want to make active from the [Project->Set Current Project] sub-menu.
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210 InsertingaProject into a Workspace

When aworkspace is created, it contains only one project but, after it is created, you can insert new or existing
projects into a workspace.

2 Toinsert anew project into a workspace:

1. Select [Project->Insert Project...]. The “Insert Project” dialog will be displayed (figure 2.24).

2. Setthe“New Project” option.

3. Click OK. The “Insert New Project” dialog will be invoked.

4. Enter the name of the new workspace into the “Name” field. This can be up to 32 charactersin length and
contain |etters, numbers and the underscore character. Asyou enter the project name the HEW will add a
subdirectory for you automatically. This can be deleted if desired.

5. Click the “Browse...” button to graphically select the directory in which you would like to create the
project. Alternatively, you can type the directory into the “Directory” field manually.

6. The“Project type” list displaysall of the available project types (e.g. application, library etc.). Select the
type of project that you want to create from thislist.

7. Click “OK” to create the project and insert it into the workspace.

Insert Project E E2
Inser
; Cancel |

" Esisting project:

Erawse.. |

Figure2.24: Insert Project Dialog

2 Toinsert an existing project into a workspace:
1. Select [Project->Insert Project...]. The “Insert Project” dialog will be displayed.
2. Set the “Existing Project” option.
3. Enter the full path of the project database file ((HWP file) into the edit field or click “Browse...” to
search for it graphically.
4. Click “OK” to insert the existing project into the workspace.
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211  Specifying Dependencies between Projects

The projects within aworkspace can be dependent upon one another so that when one project is built, all its
dependent projects are built first. Thisis useful if another project uses one of the othersin the workspace. For
example, imagine that a workspace contains two projects. Thefirst project isalibrary that is included by an
application project. In this case the library must have been built and up to date before the second application can
build correctly. To achieve this situation we can specify the library as a dependent (i.e. child) project of the
application project. Thiswould then alow the library to be built first if it is out-of-date.

When a dependent project is built the HEW attempts to match the configuration in the dependent project with
that of the current project. This meansthat if the current configuration is “Debug” then the HEW will attempt to
build the “Debug” configuration in the dependent project. If this matched configuration does not exist then the
HEW will use the configuration that was last used in the dependent project.

2 To make projects depend upon another:
1. Select [Project->Dependent Projects]. The “Dependent Projects’ dialog will be displayed.(figure 2.25)
2. Select the project to which you would like to add dependents to. When you do this, the “ Dependent
projects’ list will display al of the projectsin the workspace (excluding the selected project).
3. The“Dependent projects’ list has a check box for each project listed. Set the associated check boxes to
make those projects depend upon the selected project.
4. Click “OK" to confirm the new project dependencies.

Dependent Projects EHE

Froject:
I main_project j

Cancel |

Dependent projects:

|

Figure 2.25: Dependent Projects dialog
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212  Removing a Project from a Workspace

2 To remove aproject from aworkspace:
1. Select the project from the “Projects’ tab of the “Workspace” window and click the right mouse button to
invoke a pop-up menu.
2. Select the [Remove Project] option.
3. Dialog box isdisplayed. You confirm to remove the project. In the “Options’ dialog box of the “Tools”
menu, you can select this confirmation is performed or not.

Note: You cannot remove the current project from the workspace.

213 Loading/unloading a Project into/from a Workspace

2 Toload aproject into a workspace:
1. Select the project from the “Projects’ tab of the “Workspace” window and click the right mouse button to
invoke a pop-up menu.
2. Select the [Load Project] option.

2 To unload a project from aworkspace:

1. Select anon-active project from the “Projects’ tab of the “Workspace” window and click the right mouse
button to invoke a pop-up menu.

2. Select the [Unload Project] option.

Note: You can load or unload plural projects at atime.
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2.14 Relative projects pathsin the workspace

In the High-performance Embedded Workshop when you add a project to the workspace you can choose to add
the project to the workspace using arelative path. This allows you to position a project above the workspace
directory and it will still be relocated correctly if you relocate the HEW workspace. The project is aways
relative to the workspace so if the project is one directory above the workspace before it is moved the HEW will
try to find the project in the same relative location after the relocation procedure. Thisis especialy useful if you
are using a project shared between more than one workspace.

In older versions of the HEW this project would not have been rel ocated and would have still tried to access the
original project path. The older version of the HEW could only relocate the projects, which werein a
subdirectory of the workspace directory. Thisis till the standard behavior for the High-performance Embedded
Workshop.

2 To change a projects rel ative path flag:
1. Select the project in the workspace window.
2. Right click and then select properties.
3. Click the“Project relative file path” checkbox to switch on or off the relative file path feature. (figure

2.26)
4. Click “OK”.

Properties E E
M ame: IDemo 0K I
Location: C:AHewhDemo\DemohDemo. buwp
Lazt modified: 10:19:42, Thurgday, June 12, 2003
P family: SuperH RISC engine
Tool chain: Hitachi SuperH RISC enaine Standard T oolchain
Wersion: 7120
" Froject relative file path

Figure 2.26: Properties Dialog
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215 User foldersin the workspace

In the High-performance Embedded Workshop it is possible to add folders to your workspace window. This
allowsyou to logically group your filesinto certain areas within a project. The folder can be set to any name and
thisis entered in adialog.

2 Toadd auser folder:

1. Select the project on the “Projects” tab of the workspace window.

2. Right click and then add folder.

3. Enter thenameand click OK.

4. You can now drag and drop filesinto this folder to group them logically.
2 Toremove auser folder:

1. Select the folder on the “Projects” tab of the workspace window.

2. Right click and then select Remove folder. Note that the folder must be empty and that the del ete key

can also be used instead of the pop-up.

2 To modify auser folder name:

1. Select the folder on the “Projects’ tab of the workspace window.

2. Right click and then select Modify folder name.

3. Enter the new name in the dialog.

4. Click “OK".
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3.  Advanced Build Features

This chapter explains the advanced build concepts.

31 The Build Process Revisited

Chapter 2, “Build Basics’ began by describing the build process in terms of a compiler, an assembler and a
linker (figure 2.1). Thiswill be the case for most installations of the High-performance Embedded Workshop.
However, if you want to begin changing the build process (e.g. adding and removing phases) then it isimportant
to understand more about the way in which a build functions.

311 What isa Build?

Building a project means applying a set of tools upon certain input filesin order to produce the desired output.
Thus, we apply a compiler upon C/C++ source filesin order to create object files, we apply an assembler upon
assembler source filesin order to create object files and so forth. At each step or “phase” of the build, we apply a
different tool upon a different set of input files. Figure 3.1 presents another view of the build process.

e

Phase 1 Input Files ‘ Phase 1 Output Files
7 PHASEE %
Phase 2 Input Files ‘ Phase 2 Output Files

T = )

Phase 3 Output Files

Phase 3 Input Files

=T
}

Phase X Input Files Phase X Output Files

Figure 3.1: Build Process
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The High-performance Embedded Workshop provides the ability to change this build process viaits“Build
Phases’ dialog, which can be, accessed viathe [Options->Build Phases...] (figure 3.2). On the left-hand side
are the phases that are defined in the current project (Figure 3.2 shows a standard set of build phases). The
remainder of this chapter details the various functions that the “Build Phases’ dialog provides.

Build Phases

Build Order | Build File Order | File Mappinas |

Build phaze order;

[w]SH CAC++ Libram Generator Add.
[w]SH CAC++ Compiler

[w]SH Azgembler Tt
[w] OptLinker

HEmove
fdee (e

Iy o

P I I _,I Impart...

L

ak | Cancel |

Figure 3.2: Build Phases Dialog
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3.2 Creating a Custom Build

Phase

If you want to execute another tool before, during or after a standard build process then this can be achieved by
creating your own (i.e. custom) build phase.

Select [Options->Build Phases...] to invoke the “Build Phases’ diaog (figure 3.2) and then click the“Add...”

button. This will invoke the new build phase wizard dialog (figure 3.3a).

Thefirst step (as shown in figure 3.3a) asks whether you want to create an entirely new phase or whether you
want to add a system phase. A system phaseisa*“ready made”’ phase which is already defined within the
toolchain you are using (e.g. compiler, assembler, linker, librarian, etc.) or a utility phase (e.g. file copy,

complexity analyzer etc.).

The“Add an existing system phase” button isinactive if no more system phases are available. Select the “Create
anew custom phase” button to create your own build phase.

New Build Phase - Step 1 of 4
what tppe of phaze would vou like to add 7
& ‘Create a new custom phase
) g\ an existing system phase:
Suztem Phasze | Werzion
< Hack | Heut » | Cancel

Figure 3.3a: New Build Phase Dialog (Step 1)
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The second step (figure 3.3b) asks what type of phase you would like to create. There are two choices: multiple
or single. When a multiple phase is executed, the command is applied to each file in the project of acertain file
group. For example, if you set the input file group to be C source files then the command will be executed once
for each C sourcefilein the project. A single phase is executed once at most during a build.

Hew Build Phasze - Step 2 of 4 E E2
]
wihat type of phase would you like ta create?

&+ Multiple phaze:

The command iz applied to each file in a file group.
An example of this tepe of tool iz 3 compiler or agzembler.

Select input file group:

" Single phase:

The command iz only ever executed once per build,
An example of this bepe of tool iz a linker,

< Back | Hewt » | Cancel

Figure 3.3b: New Build Phase Dialog (Step 2)

Theinput file group list contains the current file groups defined for the project. It is possible to define multiple
input file groups by selecting the “Multiple Groups...” entry in theinput file group list. Selecting thislist entry
displaysthediadog in figure 3.3c.

Select Groups

[ Azzembly zource file ﬂ
[ 1Binam file

1 header file Cancel
L list file
(v zource file

[ C++ header file

[ C++ list file

ML ++ source file

[ 1CPU information file

[ 1Expanded azzembly source file _ILI
4 I I 3

il

Figure 3.3c: Modify multipleinput file groups

Once this choice has been made the input file group selection is displayed as “Multiple Groups...” Thisdialog
allows the user to choose multiple input file groups for the custom phase being added to the project. To select a
file group check the box next to the file groups name. One or more file groups can be selected in this dialog.
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The third step (figure 3.3d) requests the fundamental information about the new build phase. Enter the name of
the phase into the “ Phase name” field. Enter the location of the program file into the “Command” field (do not
insert any command line options as these options are specified viathe [Options] menu of the HEW menu bar).
Specify the default options for the phase (i.e. what options you would like new files to take when added to the
project) into the “Default options” field. If you have a preferred directory in which you would like this program
to run from (i.e. where you want the current working directory to be set to before the tool is executed) then enter

it into the “Initial directory” field.

Hew Build Phasze - Step 3 of 4
]

Phaze name:

IMyF‘hase

Command [exchuding parameters):

Ic:'\tnnls\mytnnl.er:e{

Default options:

Ll Browsze... |

|$[FULLFILE]

Initial directan:

|$[EDNFIGDIF|]

i
| Browse. |

< Back |

Hewt » |

Cancel |

Figure 3.3d: New Build Phase Dialog (Step 3)
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The fourth and final step (figure 3.3e) allows you to specify any environment variables, which the phase requires.

Mew Build Phase - Step 4 of 4 HE

Does the command require any environment vanables to be zet?

If 20, enter them into the list below:

ENv=1024
ti |
e |
KN i

[~ Eead Output On Fly

< Back | Finizh | Cancel |

Figure 3.3e: New Build Phase Dialog (Step 4)

To add anew environment variable click the“Add...” button (the dialog shown in figure 3.4 will be invoked).
Enter the variable name into the “Variable” field and the variable’ s value into the “Value” field and then click
“OK” to add the new variable to thelist of the fourth step. To modify an environment variables select the
variablein the list and then click the “Modify...” button. Make the required changes to the “Variable” and
“Value’ fields and then click “OK” to add the modified variable to the list. To remove environment variables
select the variable that you want to remove from the list and then click the “Remove” button.

Environment Yariable EHE3

Wariable:

[PaTH

Walle:

Placehsolder
POPUR Menu

Ic: hdog o mptools o windows o Memp [ 3 ||

Figure 3.4: Environment Variable Dialog

If the tool you are adding can display its output as the tool is running then use the ‘ Read Output On Fly’ option.
Thiswill display the tool output as each line of output happens. If thisoption is set to off then the HEW wiill
store al output, which is being displayed by the tool, and display it in the output window when the tool has
finished its operation. This can be a problem when the tool is running an operation that might take many
minutes, asit is difficult to see the progress of the current execution.

Note: Using ‘Read Output On Fly’ can cause problems when using certain tools on certain operating systems.
If you are having problems with tools locking up or freezing in HEW then uncheck the ‘Read Output On
Fly’ option.

Click the “Finish” button to create the new phase. By default the new phase is added to the bottom of the “Build
Phase Order” list in the “Build Order” tab of the “Build Phases’ diaog (Figure 3.2).
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33 Ordering Build Phases

In astandard build (shown in figure 3.5), you could add a phase at four different positions: before the compiler,
before the assembler, before the linker or after the linker. Y ou may place your own custom phases or move
system phases to any position in the build order. It isimportant to remember that if the output of your custom
phase can be input into another phase then the phase order must be correct if the build isto behave as intended.

<

COMPILE

}

ASSEMBLE

}

glz

LINK

[ o]
€0

Figure 3.5: Typical Build Process

The build phase dialog provides facilities for ordering build phases via the “Build Phases’ dialog. It has two tabs,
which are concerned with the ordering of phases. “Build Order” and “Build File Order”. And then you can click
"OK" button.
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331 Build Phase Order

The “Build Order” tab (figure 3.6) displays the current order in which phases will be executed when the build

currently enabled. By clicking this box, the phase can be toggled on or off.

Build Phases

Build Order | Build File Order | File Mappinas |

Build phaze order;

[w]SH CAC++ Libram Generator Add.
[w]SH CAC++ Compiler -
w5H Aszzembler Iy |
fdee (e |
Iy o |
P I I _,I Impart... |
ak | Cancel |

Figure 3.6: Build Phases Dialog Build Order Tab
In addition the following operations can be performed:

2 Toremove aphase:
1. Select the phase that you would like to remove.
2. Click the“Remove” button.
3. Click the"Yes' button, if a confirmation dialog box.
2 Toview the properties of a system phase:
1. Select the system phase that you would like to examine.
2. Click the“Modify..."” button.
3. System properties are shown as dialog box. Click the “OK” button.
2 To moveaphase
1. Select the phase that you would like to move.
2. Click the“Move Up” or “Move Down” button.
2 Toimport aphase:

1. Click theimport button. A dialog isdisplayed which allows the user to browse to an existing project to

import a custom phase from.

2. Choose the location of the project you wish to import a custom phase from.

displayed which lists the custom phases in the imported project.

3. Once you have decided which phase to import highlight it in the list and then click OK. The phase will

then be added to the build phases dialog at the bottom of the build order.
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2 To modify acustom phase:

1. Select the custom phase that you would like to modify.
2. Click the“Moadify..."” button. The modify phase dialog will beinvoked with the “Command” tab selected
(figure 3.7).
3. Change the contents of the fields as appropriate.
4. Setthe“Don’t check for input file(s) existence before executing” check box if you don’t want the HEW
to abort the execution of the phaseif any of the input filesdon't exist.
Set the “Read Output On Fly” check box if you want to display the command output to stdout during
command execution.
Modify MyPhase
Command | Envilonmentl
LCommand [excluding parameters]:
IE:\tnnIs\mytnnl.eHe Ll Browsze... |
Initial directong:
[${CONFIGDIR) Ll Browse... |
™ Don't check for input filefs) existence before executing
[ Bead Dutput On Fly
Ok I Cancel
Figure 3.7: Modify Phase Dialog Command Tab
5. Select the “Environment” tab (figure 3.8) to edit the environment settings for the phase.
6. Usethe“Add...”, “Moadify...” and “Remove’ buttons to add, modify and remove environment variables.
The operation is the same as discussed in the previous section.
7. Click “OK” when all modifications have been made.

47
RENESAS




Modiiy MyPhaze

Corimand — Ervironment |

Ervironment settings:

PATH=c:vdos e vbools
SHOWALL=FALSE
EMv=1024

flmdifi. |
Eemave |

(]9

| Cancel |
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Figure 3.8: Modify Phase Dialog Environment Tab
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332 Build File Phase Order

If you were to select a C source file from the “Workspace” window and then activate [Build->Build File] (or
press &%) you would expect the file to be compiled. Likewise, if you were to select an assembly source file from
the workspace window and then activate [Build->Build File] you would expect the file to be assembled. The
connection between file group and which phase(s) to execute is managed by the “Build File Order” tab of the
“Build Phases’ dialog (figure 3.9).

Build Phazes EHE
Build Order  Build File Order | File Mappings I
File group: Phasze order:
Azzembly source file [v] Compiler ®
y [v]tMyPhase | @
C++ source file i
1
I
|
1
|
1
I
|
¥
| i

ak. I Cahicel |

Figure 3.9: Build Phases Dialog Build File Order Tab

Thelist displaysall of the current phases that will be executed when the build file operation is selected upon the
file group shown in the “File group” list box. In figure 3.9 the “C source file” file group is selected and the
“Compiler” and “MyPhase” phases are associated with it.

Entriesin the “ Phase order” ligt, of the “Build File Order” tab, are added automatically as new entries are added
to the “Build Order” tab. For example, if you were to add a phase which takes C source files asinput then this
phase will be automatically added to the list of phases to execute when a build file operation is appliedtoa C
source file. If you don’t want a certain phase to execute when [Build->Build Fil€] is selected then clear the
check box to theleft of the phase name in the “Phase order” list.
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34 Setting Custom Build Phase Options

Once you have defined a custom phase, you will want to specify the command line options that should be used
when it is executed. Each defined phase has a menu option on the [Options] menu. To specify options for that
phase select it. The dialog that will be invoked depends upon whether the custom phase selected was a multiple
or single phase (according to the selection of phase typein figure 3.3b).

Phasel... Options 2x|
IDebug ﬂ Dptions |Dutput Files | Dependent Files
EII@ hevatest = Command:
5-E3 C source file Ip:\_hew-fileskDns&windows executables\CMDLINE.EXE
hewtest. ¢
initzct c Ol
Ophions:
- FULLFILE
shrk.c $[ )
vecthbl.c
: D Default Options
- hevatest]
- hevtest2

ewtest3
Ea C source file Placehalder:

hevtestd o

- File path + name - Inzert
nitzct.c —

intprg.c

e shrk.c =
1| ' | ¥

ak I Cancel |

Figure 3.10: Custom Options Dialog

Thedialog in figure 3.10 is a custom phase options dialog. The implementation of which is dightly different
depending on whether you are using amultiple or single shot phase. On the left-hand side is the project and file
list. Itispossibleto select multiple projects and filesin the same way as Windows® explorer to modify the
options for more than one selection. On the right-hand side are the 3 options tabs. Thisiswhere you set the
options that you want to apply to the selected file(s). You can aso choose which configuration information is
being viewed from the configuration list on the upper left of the dialog box. Each configurationislisted along
with a special entry named “Multiple configurations...”. If you select multiple configurationsthen adialog is
displayed which allows you to select more than one configuration. This method is used throughout HEW for
modifying multiple configurations at once.
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34.1 Options Tab

The “Options’ tab (figure 3.11) allows you to define the command line options that will be passed to the phase.
The “Command” field displays the command, which was entered when you defined the phase (figure 3.3d).
Enter into the “Options” field the command line arguments that you would like to pass to the command. If you
want to insert a placeholder, select the relevant placeholder from the “ Placeholder” drop-down list box and then
click the “Insert” button. For a detailed description of placeholders see appendix C, “Placeholders’.

Opticrs | Output Filesl Dependant FiIesI

Command:
IEI: “Hewt ToolchainsiHitachinSHYWSTMEIM WL br exe

Dptions:
-sub=$[CONFIGDIRMbuildlib.sub

Placehalder:

" . - | rt bitttes
Configuration directory ﬂ Inzert :l—— f;leacel'o:;er

ak. I Cancel |

Figure 3.11: Custom Options Options Tab

34.2 Output FilesTab

The “Output Files” tab (figure 3.12) is where you can specify the output file or filesthat will be produced by the
phase. Before each fileis passed into this phase, the HEW checks that the output files are of aless recent date
than the input file. If so, the phase will be executed for that file (i.e. input files have been modified since the
output file or files were last produced). If the files are up to date then the phase will not be executed.

Note: If no output files are specified, the phase will execute regardless.
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Options  Dutput Files | Dependent Files

Add...

Maodify... |
Bemove |

KN i
Ok I Cancel

Figure 3.12: Custom Options Output FilesTab

2 Toadd an output file:
1. Click “Add...”. The“Add Output File" dialog will be invoked (figure 3.13).
2. Enter thefile path or browseto it using the “Browse...” button.
3. Click “OK” to add this output file to the list.

Flaceholder popup menu

Add Output File 2x|
File:
[ 3 | Bromsze.. | Cancel |

Figure 3.13: Add Output File Dialog

2 To modify an output file:
1. Select the output file that you would like to modify.

2. Click “Madify..."”. The“Modify Output File" diaog, which isthe same as figure 3.13 except the title,
will be invoked.

3. Modify thefields as required and then click the “OK” button to add the modified entry back to the list.
2 Toremove an output file:

1. Select the output file that you would like to remove.

2. Click the “Remove” button.
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343 Dependent Files Tab

The “Dependent Files” tab (figure 3.14) is where you can specify the dependent files that are needed by the
phase. Before each file is passed into this phase, the HEW checks that the dependent files are of a more recent
date than the input file. If so, the phase will be executed for that file (i.e. dependent files have been modified
since the input file or files were last modified). If not, the phase is not executed for the files.

Elptic-nsl Output Files ~ Dependent Files |

JFIGDIR Y Add...
${CONFIGDIR)\Filet. obj

$[COMFIGDIR ) File?. obj ;
$ICONFIGDIR]AFiles obj sl |
c:WHewWwfork sphProject\Debug'File1. abj

oW Hewbwork zphProjecthDebughFile2. obj Remove |
c:WHewWwfork sphProject\Debug'File3. obj

oW Hewbwork zphProjecthDebughFiled. obj

Figure 3.14: Dependent Files Tab in Custom Options
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To add a dependent file:

1. Click “Add...”. The“Add Dependent File" dialog will be invoked (figure 3.15).
2. Enter thefile path or browseto it using the “Browse...” button.

3. Click “OK” to add this output file to the list.

Placeholder popup menu

Add Dependent File 21x]
File:
[ 3 | Bromsze.. | Cancel |
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Figure 3.15: Add Dependent File Dialog

To modify adependent file:
1. Select the dependent file that you would like to modify.

2. Click “Moadify..."”. The“Modify Dependent File” dialog, which is the same as figure 3.15 except the title,

will be invoked.
3. Modify thefields as required and then click the “OK” button to add the modified entry back to the list.
To remove adependent file:
1. Select the dependent file that you would like to remove.
2. Click the “Remove” button.
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35 File Mappings

By default, the filesinput to a phase are only taken from the project, i.e. al project files of the type specified in
the “ Select input file group” drop-down list on the “New Build Phase” dialog (figure 3.3b). If you would like a
phase to take files output from a previous phase (i.e. intermediate files) then you must define thisin the “File
Mappings’ tab of the “Build Phases’ dialog (figure 3.16).

EBuild Phases 2 x|

Build Order | Build File Order ~ File Mappings |

Intermediate file mappings for build:

Source | D estination | File Group Add. .
SH Agzembler OptLinker Object file
SH C/C++ Compiler SH Assembler  Assembly source file odify...

SH CAC++ Compiler OptLinker Object file

SH CAC++ Library Generator - OptLinker Library file RErove

i

1 i ©

Figure 3.16: Build Phases Dialog File M appings Tab
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A file mapping states that you would like the HEW to pass output files of a certain type produced by one phase
(referred to as the source phase) to another phase (referred to as the destination phase). Such intermediate files
are passed in addition to the project files.

2 To add afile mapping:

1
2.

Click “Add...". The “Define File Mapping” dialog will beinvoked (figure 3.17).

Select the file group, which you want to pass between the phases from the “File group” drop-down list
box.

Select the source phase (i.e. which phase generates the files) from the “ Source phase” drop-down list box.

Select the degtination phase (i.e. which phase takes these files) from the “ Destination phase” drop-down
list box.

Click “OK” to create the new mapping.

Define File Mapping 7] x|

File group: -DK

| Oject file [ Cancel |
Source phase:

ISH Azzembler ﬂ

Diestination phaze:

Figure 3.17: Define File Mapping Dialog

2 To modify afile mapping:

1

56

Select the mapping to be modified.

2. Click “Madify..."” button. The “Define File Mapping” dialog will be invoked (figure 3.17).
3.
4. Click “OK” to commit the changes.

Modify the options as necessary.
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3.6 Controlling the Build

By default, the High-performance Embedded Workshop will execute al of the phasesin a build and only stop if
afatal error is encountered. Y ou can change this behavior by setting the controls on the “Build” tab of the
“Options’ dialog (figure 3.18).

Qptions il ﬂ

Buid |Editnl | Wworkspace | Confirmation | Metwark |

— Errarg and warnings:

[ Stop build if the number of emors exceeds: I 0

¥ Stop build if the number of warnings exceeds: I 10

= Show:

[ Command line [ Initial directory

[ Enwironment [ Mark out of date files
r— Makefile build

Command [exchuding parameters]:

[SHEWDIR ek ve L| e, |

[ Use makefile build system

I aletile options:

| 2

I akefile path:

I$[WDF|KSF'DIH]\make'\ﬁS[F'HEIJECTNAME].mak Ll Browse.. |

™| Generate makefile before build commences

QK. I Cancel

Figure 3.18: Options Dialog Build Tab

Select [Tools->Options...] to invoke the dialog. If you want to stop the build when a certain number of errors
are exceeded then set the “ Stop build if the no. of errors exceed” check box and then specify the error count limit
in the edit field to the right. If you want to stop the build when a certain number of warnings are exceeded then
set the “ Stop build if the no. of warnings exceed” check box and then specify the warning count limit in the edit
field to theright.

Note: Irrespective of what these controls are set to, the build will always halt if afatal error is encountered.

In addition to specifying error and warning count limits, the “Build” tab also alows you to request that the
command line, environment and initial directory of each execution should be displayed. Check the appropriate
check boxes as necessary.
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37 L ogging Build Output

If you would like to write the results of each build to file then invoke the “Customize” dialog by selecting [Tools
-> Customize...] and select the “Log” tab (figure 3.19). Set the “ Generate log file” check box and then enter the
full path of thelog fileinto the “Path” field or browse to it graphicaly by clicking the “Browse...” button.

Customize

Figure 3.19: Tools Customize Dialog Log Tab
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3.8 Changing Toolchain Version

If two or more versions of the same toolchain are registered in the HEW, you can choose a version of the
toolchain on the “Change Toolchain Version” dialog shown in Figure . To invoke the dialog, select [T ools-

>Change Toolchain Version...]. Choose one of the versions from the “ Toolchain versions’ drop-down list and
click the “OK” button to enforce your choice.

Change Toolchain Yersion 2=

Toolchain name: Hitachi SuperH RISG engine
Current version: 7110 Cancel |
GFU Family: SuperH FISG engine Infarmatiar,.. |

Toolchain: IHitachi SuperH RISC engine Standard ;I
Toolchain version: Ig_m N LI
Toolchain build phases:

Build phaze | \ersion |
Cptlinker anoz

5H Azzembler 6.0.00

SH C/C++ Compiler 20

SH C/C++ Library Generatar a0

Figure 3.20: Change Toolchain Version Dialog

To show information of toolchain components select atool from the “Toolchain build phases’ list on the
“Change Toolchain Version” dialog and click the “Information...” button. Then atool information dialog (figure
3.21) will show you the information of the tool. Click the “Close” button to close the dialog.

SH CfC4++ Campiler Information 2 x|
Infarmation:
High-perfarmatnice Embedded Workshop ;l

SuperH RISC engine CAC++ Compiler Wer, 8.0.07
[2]1952 2002 Renezas Technology Corp.
[£]1992.2002 Hitachi Softvare Enginesring Co. Ltd,

Figure 3.21: Toolchain Information Dialog
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39 Using an External Debugger

The High-performance Embedded Workshop can launch an external debugger tool. If you want to use another
debugger then you must add it to the Tools menu.

The “Debugger” tab of the “ Customize” dialog (figure 3.22a, figure 3.22b, figure 3.22c) is where the external
debugger related information is configured. Y ou may wish to use an older version of the debugger if certain
targets are not currently supported in the new environment. Invoke it by selecting [T ools->Customize...] and
then selecting the “Debugger” tab.

Thefirst choice to make is which debug tool you would like to use from the “ External debugger selected” drop-
down list.

“Hitachi Debugger Interface (version 4.x or greater)”: Use the HDI
“Mitsubishi PD debugger”: Use the PD debugger

“Other external debugger”: Use the other debugger

“Non selected”: Not use the external debugger

Once this has been selected the external debugger must be configured.

2 TousetheHDI:

1. Setsthelocation of the HDI executable. This must be version HDI 4.0 or greater, otherwise its behavior
is not guaranteed.

2. Setsthelocation of the session file. Thistellsthe HDI which session to load when it islaunched.
3. Setsthelocation of the download module.

Customize il ﬂ

Toolbarz Cnmmandsl GET] I Flaceholders  Debugger | Log I Help I

Euternal debugaer zelected:

Hita

chi [ ebugger |rterfac

— Debugger zettingz

HOI lozation:

I Ll Browsze. . |
eszioh file:
Ll Browse. . |

s
!

Download module;

Ll Browse. .. |

ak. I Cahicel |

Figure 3.22a: External debugger selected — HDI
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2 To usethe PD debugger:
Sets the location of the PD debugger executable.

1
2.

Setsthe location of the PD profilefile. Thistellsthe PD debugger which session to load whenitis

launched.

Sets the command line option. Thisfield allows additional options to be specified which can modify the
behavior of the external debugger.

Sets the location of the download module.

Customize

Toolbarz Cnmmandsl GET] I Flaceholders  Debugger | Log I Help I

Euternal debugaer zelected:

shi PO debuoger

— Debugger zettingz

PO debugger location:

PD profile file location:

LCommand line options:

Ll Erowse...l
Ll BlDﬂSE...l

2l

Download module;

Ll Browse. .. |

o |

Cahicel |

Figure 3.22b: External debugger selected — PD debugger
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2 To usethe other external debugger except on the HDI or the PD debugger:
1. Setsthelocation of the external debugger executable.

2. Setsthe command line option. Thisfield allows additional options to be specified which can modify the
behavior of the external debugger.

3. Setsthelocation of the download module.

Customize ﬂ ll

Toolbars Cnmmandsl Menu I Placeholders Debugger | Log I Help I

External debugger selected:

— Debugger settings
Exterrnal debugager location:

I Ll Browse. . |

LCommand line options:

! i3

Download module:

Ll Browse. .. |

QK. I Cancel |

Figure 3.22c: External debugger selected — External debugger except on the HDI or the PD debugger

Click the “Launch Externa Debugger” toolbar button to invoke the external debugger:

2

After abuild, if the download module has been updated, the HEW will switch back to the debugger to enable
immediate debugging. Whilst using the debugger, double clicking in any source window will switch back to the
HEW with the source file open at the line, which was double clicked. This operation is not possible with the
“Other external debugger”.
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3.10 Generating a Makefile

The HEW allows you to generate a makefile, which can be used to build parts of your workspace without HEW.
Thisis particularly useful of you want to send a project to a user who does not have the HEW or if you want to
version control an entire build, including the make components.

Thisversion of HEW also supports the integration of the generated makefile and toolsinto the HEW framework.
Thisalowsyou to click build menu or toolbar button and then launch the makefile rather than the normal
internal HEW build process. For further information, refer to the “ Using a makefile inside the HEW system”
section later in this chapter.

2 To generate amakefile:

1. Ensurethat the project, which you want to generate a makefile for, is the current project.

2. Ensure that the build configuration that you want to build the project with is the current configuration.

3. Sdect [Build->Generate Makefile...].

4. Select the radio button, which is relevant for your makefile. (See figure 3.23.)

5. Ensure you have selected the correct makefile format. HEW is capable of generating GNUMake,
HMake and NMake compatiblefiles.

6. The use static sub-command files check box will generate separate command filesin the make
destination directory. Thisisdifferent to the normal style where the sub-command files are generated by
the maketool. In the case of the GNUMake file format this must be switched on.

7. Checking “ Scan dependencies whilst building makefile” will force a dependency scan to ensure the
makefile creation is up to date.

8. Click “OK”.

21

Generate makefile for:

% the cument configuration in the currently active project

Cancel

i

= all configurations in the curently active project

" &l gonfigurations in all loaded projects in the curent workspace

M akefile farmat: |HM ake j

[ Use static sub-command files

¥ Scan dependencies whilst building make file

Figure 3.23: Generate M akefile Dialog
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The HEW will create a subdirectory “make” within the current workspace directory and then generate the
makefileinto it. It is named after the selection, with a.mak extension for example the current project and
configuration (e.g. project_debug.mak). The executable HMAKE.EXE, located in the HEW installation directory,
is provided for you to execute the makefiles generated by the HEW. It is not intended to execute makefiles,
which have been user modified. For further details on HMAKE, refer to Appendix F, “HMAKE User Guide”.

2 To execute amakefile:
1. Open acommand window and change to the “make” directory where the makefile was generated.
2. Execute HMAKE. Itscommand lineis HMAKE.EXE <makefile>.

Note: The degree portability of agenerated makefileis entirely dependent upon how portable the project itself
is. For example, any compiler options, which include full paths to an output directory or include file
directory, will mean that, when given to another user with a different installation, the build will probably
fail. In general use placeholders wherever possible —using a full, specific path should be avoided when
possible.
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311 Using amakefileinsidethe HEW system

The HEW also allows you to configure the internal build to use a particular make file rather than the internal
HEW system when build is clicked.

The standard HEW integrated build should be fine for all of your building requirements. However in some cases
you may feel the need to use makefiles rather than relying on the HEW internal make system. The techniquesto
do this are described below:

=) To set-up the internal makefile execution:

1. Create abase HEW workspace in which to launch your makefilein. It makes senseif thisisthe same
toolchain as the one to be used in your makefile. Although thisis not essential.

2. Click on[Tools->Optiong].

. Click the build tab (figure 3.24).

4.  Select the makefile command, which should be used. By default thisis set to the Renesas make tool
shipped with HEW. Thisiscalled HMAKE.exe and islocated in the HEW installation directory
"$(HEWDIR)".

5. Click the "Use makefile build system" check box. Thistellsthe HEW that when the build button is
clicked that makefile should be executed rather than the interna build.

6.  Setup the makefile path. This defaults to the location, which HEW will generate makefilesto. This
item is configuration based so you can have a different makefile for each configuration.

Note:

Y ou do not need to use a makefile generated by HEW. It can be any format aslong as your make tool
supportsit.

7.  Setup the makefile options. HMAKE allows the user to specify project or configuration selection
options so that different builds can be launched from the samefile. Again thisitem is configuration
based so you can have a different makefile options for each configuration. For further details on
HMAKE, refer to Appendix F, "HMAKE User Guide", "F.1.3 Parameters'.

8. Thefina option isthe generate make file before build. Thiswill launch the default make file creation
utility before the makefile is executed. This means the makefile will always be up to date with the
HEW project system.

9. Click OK to save the changes.
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Rl

Build IEditor | wiorkspace | Confirmation | Metwork |

— Emrars and warnings:

[~ Stop build if the number of erors exceeds: I 0

[ Stop build if the number of wamings exceeds: I a0

 Show:

[~ Command line [ Initial directomy

[~ Envionment [~ Mark out of date files
— Makefile build

Command [excluding parameterz]:

|$[HEWDIH]\hmake.exe Ll Browse... |

v Use makefils build system

M akefile options:
[ i
I akefile path:

[$1w/ORKS PDIR\mak et $PROJECTNAME . mak Ll BaEe. |

¥ Generate makefile before build commences

Ok I Cancel

Figure 3.24: Option Dialog Build tab

Once this system is setup the build button, menu and keyboard shortcuts are linked to the makefile tool
execution. All output is directed to the output window asin the case of the normal build. If you areusing a
toolchain supported by HEW errors and warnings can be double-clicked to jump to the source files. The help
link should & so be supported. Note when using the HM AKE.exe system the build all button will passa
command to HMAKE to force are-build al operation. When using GNUMake thisis not supported.

66
RENESAS




3.12  Customizing the HEW linkage order

Object module are linked as alphabetical order in HEW default. Y ou can specify the linkage order, if you wish to.

> To switch on manual linkage order facilities:
1. Click the[Build->Linkage Order...] menu item.
2. Onthedialog displayed click the Use custom linkage order check box (figure 3.25).

3. Then you can move the objects into whichever order you need. Simply select the module and click the
up and down buttons to position it in the desired location.

4. Each module has adifferent icon depending on where it originated.
5. Click OK to verify and save the settings.

Linkage order

[¥ Use custam linkage order: Ok
Dbject order: Cancel |
D mair.obj
[[7 resetprg.obi Move up |
D (g2 Move down |
Intermediate filei—D runtime_librang. lib
File in project —————— [ %] projectname. ib

|dzer library from options

@ user_edit_optionz.lib

Current configuration;
IDebug ﬂ Copy ...

f

Figure 3.25: Linkage order Dialog

When you are using multiple configurationsit islikely that the linkage order will be very similar. To do this
effectively you can copy the current settingsin the dialog to other configurations. Thisis described below:

2 To copy the linkage order from one configuration to another:
1. Click the[Build->Linkage order...] menu item.

2. Select the configuration you wish to copy in the current configuration list. This defaults to the currently
loaded configuration.

3. Click the Copy to... button this displays a dialog and asks you which one of the configurationsin the
current project you wish to copy the current linkage order to. Select a configuration and click OK.

4. Click OK to verify and save the changes.
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4. Using the Editor

This chapter describes how to use the editor that is provided with the High-performance Embedded Workshop.

41

The Editor Window

The editor window (figure 4.1) contains the file windows that are being viewed or edited. Only one window is
active at anytime. This window is called the active window (or current window) and itstitle bar will appear a
different color from that of the others (“dbsct.c” is the active window in figure 4.1). All text operations such as
typing, pasting text and so forth only affect the active window. To switch to another source file window (i.e. to
make some other window the active window) there are a number of methods:

e Clickonitifitisvisible.

e PressCTRL+TAB to cycle through the windows one after another.

e Select the window by name from the “Window” menu.

e Selectitstab at the bottom of the editor window.

When afile has been edited, an asterisk (*) is appended to the window’ stitle bar. The asterisk remains there
until thefileis saved. The asterisk isalso removed if al of the edited changes are undone in the current window.

Fs
S
Fs
S
Fs
S
Fs
S

FILE ;db=sct . c

DATE :Thu, Jun 26, 2003
LESCREIFTICH :Setting of B.R Section
CFU TYFE :

Thi=s file i= generated by Eenesa=s Froject Generator (Ver.3.0).

#pragma =ection $DSEC
static const struct {

char *rom_s: <% Start addre==s of the initialized data =e
char *rom_e: ~% End address of the initialized data =sect
char *ram_s: <% Start addre==s of the initialized data =e
}DTEL[ 1= { A
KN b
<l resetprgc <D dbscte |0 shike

Figure4.1: Editor Window
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4.2 Working with Multiple Files

Thefile areais where you will work with the files of your project. The editor alows you to have many files open
at one time, to switch between them, to arrange them in different configurations and to edit them in whichever
order you want to. The operations that you can perform upon the windows are typical of most Windows®
applications and they can be found under the [Window] menu:

e [Window->Cascade]
Arrange al open windows so that they overlap, with the top left of each window visible.
e [Window->Tile Horizontally]
Arrange all open windows in sequence (horizontally) so that they occupy the entire editor window with no
overlapping edges.
e [Window->Tile Vertically]
Arrange al open windows in sequence (vertically) so that they occupy the entire editor window with no
overlapping edges.
* [Window->Arrange | cons]
Line up al minimized windows at the bottom of the editor window.
e [Window->Close All]
Close all open editor windows.

The files within the editor can be displayed in a*“notebook” style. This means that each file has a separate tab
associated with it to aid in navigating between files.

2 To show filesin notebook:
1. Select [Tools->Options...]. The “Tools Options’ dialog box will be displayed. Select the “Editor” tab.
2. Set the “Show filesin notebook” check box as appropriate.
3. Click “OK" for the new settings to take effect.

421 TheEditor Toolbars

The editor has four related toolbars: Editor, Search, Bookmarks and Templates. They provide a shortcut to the
functions of the editor, which you will use most often. The following sections describe each buttons function.

4.2.2 Editor Toolbar Buttons

O New File

The new file button creates a new source file window with a default name. When you save the file, you can
specify your own filename.

= Open File

Click this button if you want to open afile. It invokes a standard file chooser - select the file which you want to
open and then click “Open”.
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= SaveFile

Savesthe active source file.

=i} Save All Files

Savesdl of thefilesin the editor.

& Print File

To print the contents of the current window, click this button.

& Cut

Clicking this button will remove the current text selection and place a copy of it onto the Windows® clipboard
(it can be pasted back to a file with a paste operation).

Copy

This button allows you to copy the current text selection into the Windows® clipboard.

2] Paste

The paste button copies the contents of the clipboard into the active window at the position of the insertion
Ccursor.

I Match Braces

The match braces button highlights text between braces of type{ }, [] and (). Thisis particularly useful when
attempting to find out the structure of C/C++ code blocks which are opened with { and closed with }. To useit,
select the open brace to match from, or place the cursor before it, and then click this button. For further
information on brace matching, refer to the “Brace Matching” section later in this chapter.

ar Insert Template

To insert a pre-defined template at the current cursor position, click thistoolbar button. The “Insert Template’
dialog box will be invoked. Select atemplate name and then click OK. For further information on templates,
refer to the “ Templates’ section later in this chapter.

] Toggle Bookmark

The High-performance Embedded Workshop editor provides standard bookmark capabilities. To set a bookmark,
select the line to mark and click this button (a green mark will then appear in the blank on the left side of the
editor window). To remove a bookmark, select the line to remove a bookmark and click this button (the mark in
the blank on the | eft side of the editor window will disappear). For further information on bookmarks, refer to the
“Bookmarks’ section later in this chapter.
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423  Search Toolbar Buttons

= Find in Files

To search several filesfor atext string then click this button. All find results are displayed in the“Find in Files’
tab of the “QOutput” window. For further information, refer to the “ Searching and Navigating Through Files’
section later in this chapter.

iy Find

Click thisbutton if you want to find a certain text string in the current file. It invokes a find dialog box where
you can specify the search parameters.

& Find Next
Finds the next occurrence of the current search string.

ﬂ Find Previous

Finds the previous occurrence of the current search string.

424 Bookmarks Toolbar Buttons

mm) Toggle Bookmarks

Sets abookmark at the current line or clears abookmark at the current line.
& Next Bookmark

Jumps to the next bookmark in the current file from the current line.

|§.‘| Previous Bookmark

Jumps to the previous bookmark in the current file from the current line.

&  Clear All Bookmarks

Clears al bookmarksin the current file.

425 Templates Toolbar Buttons

‘I’ Define Template

Specify template text for subsequent insertion.
T Insert Template

Insert the template selected in the drop-down list at the current cursor position.
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4.3 Standard File Operations

431 Creating a New File

2 To create anew editing window:
Select [File->New] or click the new file toolbar button (1) or press CTRL +N.

The window will be given an arbitrary name by default. Y ou can provide a new name when you save the file.

432 Saving a File

2 To save the contents of an editing window:
1. Ensure that the window, whose contents you want to save, is the active window.
2. Select [File->Save] or click the save file toolbar button (i) or press CTRL +S.

3. If thefile has not been saved before, afile save dialog box will be displayed. Enter afilename, specify a
directory and then click OK to create the file with the name given, in the directory specified.

4. If the file has been saved before, then the file will be updated (no dialog box will be displayed).
2 To save the contents of an editing window under a new name:

1. Ensure that the window, whose contents you want to save, is the active window.

2. Select [File->Save As...].

3. Afilesavediaog box will be displayed. Enter afilename, specify a directory and then click OK to create
the file with the name given, in the directory specified.

433 Saving all Files

2 To save the contents of every open editor window:

1. Select [File->Save All] or click the save all files toolbar button ().

2. If any of thefiles has not been saved before, afile save didog box will be displayed. Enter a filename,
specify adirectory and then click OK to create the file with the name given, in the directory specified.

3. If any of thefiles have been saved before, then the file will be updated (no dialog box will be displayed).
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434 Opening a File

2 Toopen afile:

1. Select [File->Open...] or click the open file toolbar button (&) or press CTRL +O.

2. Anopen filedialog box will be displayed. Use the directory browser (on the right) to navigate to the
directory in which the file you want to open islocated. Use the “Files of type” combo box to select the
type of file you want to open (or set it to “All Files (*.*)" to see every filein adirectory).

3. Onceyou have located the file select it and click “ Open”.

The High-performance Embedded Workshop keeps track of the last four files that you have opened and adds
them to the file menu under the “Recent Files’ sub-menu. This gives you a shortcut to opening files which you
have used recently.

2 Toopen arecently used file:
Select the [File->Recent Files] menu option and from this sub-menu select the desired file.

You can aso open afileviathe “Projects’ tab of the “Workspace” window. Either double click the file you want
to open or select it, click the right mouse button (to invoke a pop-up menu) and then choose the [Open <file>]
menu option (where <file> isthe name of the file selected).

435 Closing Files

2 Tocloseindividua files select one of the following methods:
1. Double click on the editor window’s system menu (located at the top left of each window when not
maximized).
2. Click on the editor window’ s system menu (located at the top left of each window when not maximized)
and select the “Close” menu option.
3. Ensure that the window that you want to close is the active window and then press CTRL +F4.
4. Ensure that the window that you want to close is the active window and then select [File->Close].
5. Click on the close button (located at the top right of each window when not maximized).
2 Tocloseal windows at once:
Select [Window->Close All].
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4.4 Editing a File

The High-performance Embedded Workshop editor supports standard editing functionality. Thisis available
through the usual methods (i.e. the menu, toolbar and keyboard shortcuts) and is additionally supported viaa
pop-up menu (or local menu) that islocal to each editor window. To invoke it, place the pointer in an open

window and click the right mouse button. Table 4.1 outlines the basic operations that are provided by the editor.

Table4.1 Basc Editing Operations
Operation Effect Action
Cut Removes highlighted text and places it on the Click the cut toolbar button
Windows® clipboard Select [Edit->Cut]
Select [Cut] - local menu
Press CTRL+X
Copy Places a copy of the highlighted text into the  Click the copy toolbar button
Windows® clipboard Select [Edit->Copy]
Select [Copy] - local menu
Press CTRL+C
Paste Copies the contents of the Windows® Click the paste toolbar button
clipp_oard into t_he ac_tive window at the Select [Edit->Paste]
position of the insertion cursor
Select [Paste] - local menu
Press CTRL+V
Delete Removes highlighted text (it is not copied to  Select [Edit->Clear]
the Windows® clipboard) Select [Clear] - local menu
Press Delete
Select All Selects (i.e. highlights) the entire contents of  Select [Edit->Select All]
the active window Select [Select All] - local menu
Undo Reverses the last editing operation Select [Edit->Undo]
Select [Undo] - local menu
Press CTRL+Z
Redo Repeats the last “undone” editing operation Select [Edit->Redo]

Select [Redo] - local menu
Press CTRL+Y

RENESAS
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45

Sear ching and Navigating through Files

The High-performance Embedded Workshop editor provides find, replace and file navigation functionality. The
following three sections detail how to use these features.

451

Finding Text

2 To search for text in the current file:

L
2.

3.

Ensure that the window, whose contents you want to search, is the active window.
Position the insertion cursor at the point from which you want to start your search.

Select [Edit->Find...], press CTRL +F, sdlect [Find...] from the editor window’sloca menu or click the
find toolbar button (#}). The “Find” dialog box will be displayed (figure 4.2).

Find HE

Find what, [string =l Eind Nest |
™ Match whole word orlp Direction——— Cancel |

[ Match caze C Up
& Down

™ Regular expression

9.

Figure 4.2: Find Dialog

Enter the text that you want to search for into the “Find what” field, or select a previous search string
from the drop-down list box. If you select text before invoking the find operation, the selected text will be
automatically placed into the “Find what” field.
If you would like to search for character string as a whole word then check the “Match whole word only”
check box. When this option is not selected, the search will be for any string that is matched by the search
string.
If you would like your search to be case sensitive (i.e. to distinguish between upper and lower case
letters) then check the “Match case” check box.
If your search string uses regular expressions then check the “Regular expressions” check box. Refer to
Appendix B, “Regular Expressions’ for further information.
The “Direction” radio buttons allow you to select the direction of the search. Selecting “Down” means
that the search will be performed from the insertion cursor towards the bottom of the file. Selecting “Up”
means that the search will be performed from the insertion cursor towards the top of the file.
Click the “Find Next” button to begin the search. Click “Cancel” to stop the find action.

The High-performance Embedded Workshop editor also allows you to search for a string across many files.
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452

Finding Text in Multiple Files

2 To search for text in many files:

1

Select [Edit->Find in Files...], select [Find in Files...] from the editor window’ s local menu or click the
find in files toolbar button (Gg). The “Find in Files’ dialog box will be displayed (figure 4.3).

Find In Files EHE

Find

Cahicel

Fird: IMyStruct ﬂ
[

In filez/types: I".c;".cpp;".e:-tp;".fs_l,l;".h;".hpp;".inc;".lis;".lp A

4

Directary Ic:'\hew\demn'\demo j Browse...

[ Match caze ¥ Search sub directaries

[ Regular expressions

Figure4.3: Find in Files Dialog

Enter the text that you want to search for into the “Find” field, or select a previous search string from the
drop-down list box. If you select text before invoking the find operation, the selected text will be
automatically placed into the “Find” field.
Enter the file extensions of the files you would like to search into the “In files/types’ field. If severa
extensions are specified be sure to separate them with a semicolon (e.g. *.c;*.h).
Enter the directory in which you would like to search files into the “ Directory” field. Alternatively you
may browse to the desired directory graphically if you click the “Browse...” button.
If you would like to search the directory specified and al directories below it then check the “ Search sub
directories’ check box. If you just want to search the single directory specified in the “ Directory” field
then ensure that this check box is not checked.
If you would like to search for character string as a whole word then check the “Match case” check box.
When this option is not selected, the search will be for any string that is matched by the search string.
If you would like your search to be case sensitive (i.e. to distinguish between upper and lower case
letters) then check the “Match case” check box.
Click “Find” to begin the search. Any matches found will be displayed in the “Find in Files’ tab of the
“Output” window. To jump to an instance of the string, double click on the desired entry in the “Output”
window.
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453 Replacing Text

Replacing text is similar to finding text, as discussed in the previous section. The difference is that when the text
is found you have the option to replace it with other text.

2 Toreplacetextin afile:

1. Ensure that the window, whose contents you want to replace, is the active window.

2. Position theinsertion cursor at the point from which you want to start your search.

3. Select [Edit->Replace...], press CTRL +H or select [Replace...] from the editor window’s local menu. A
replace dialog box will be displayed (figure 4.4).

4. Enter the text that you want to search for into the “Find what” field, or select a previous search string
from the drop-down list box. If you select text before invoking the replace operation, the selected text will
be automatically placed into the “Find what” field.

5. Enter the text that you want to replace the search string with into the “ Replace with” field, or select a
previous replace string from the drop-down list box.

Replace d b

Find what: |string LI Fird Mexct I
Replace with: |numeric x| Replace |
[~ Match whale word only Replace h——— Replace All |

[~ Match caze " Selection

[~ Reeular expression & hale file Cancel |

= all open files

Figure 4.4: Replace Dialog

6. If youwould like to search for character string as awhole word then check the “Match whole word only”
check box. When this option is not selected, the search will be for any string that is matched by the search
string.

7. 1f you would like your search to be case sensitive (i.e. to distinguish between upper and lower case
letters) then check the “Match case” check box.

8. If your search string uses regular expressions then check the “Regular expressions’ check box. Refer to

appendix B, “Regular Expressons’ for further information.

If you clicked “Find Next”, the editor will search for the first occurrence of the search string. Click
“Replace” if you want to replaceit. Click “Replace All” to replace al occurrences or click “Cancel” to
stop the replace action. If you select “Selection” in “Replace In”, selected range of the text is replaced. If
you select “wholefile”’, thewhole files are replaced. If you select all open files, dl filesthat are
currently open in the editor have the replace operation carried out on them.

©
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454

Jumping to a Specified Line

2 Tojumptoalineinafile

1
2.

Ensure that the window, whose contents you want to replace, is the active window.
Select [Edit->Goto Line...], press CTRL+G. or select [Goto Line...] from the editor window’s local
menu. A goto line dialog box will be displayed (figure 4.5).

Enter into the dialog box the number of the line that you want to go to, and then click “OK”.
Theinsertion cursor will be placed at the start of the line number specified.

Line nurmber I'I
ak. I Cahicel |

Figure 4.5: Goto Dialog
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4.6 Bookmarks

When working with many large files at atime, it can become difficult to locate specific lines or areas of interest.
Bookmarks enable you to specify lines that you want to jump back to at a subsequent time. One example of its
useisin alarge C file where you may want to set a bookmark on each function definition. Once a bookmark has
been set, it exists until it is removed or thefileis closed.

2

To set a bookmark:

1. Placetheinsertion cursor on the line to mark.

2. Select [Edit->Bookmar ks->Toggle Bookmark], press CTRL +F2, select [Bookmarks
->Toggle Bookmark] from the local menu or click the toggle bookmark toolbar button (2 ).

3. A green mark appearsin the blank on the left side of the line to indicate the presence of an active
bookmark.

To remove a bookmark:

1. Placetheinsertion cursor on the marked line.

2. Select [Edit->Bookmar ks->Toggle Bookmark], press CTRL +F2, select [Bookmarks
->Toggle Bookmark] from the local menu or click the toggle bookmark toolbar button (3 ).

3. The mark will be removed and the line will return to normal text.

To jump to the next bookmark in afile:

1. Ensurethat the insertion cursor is somewhere within the file to be searched.

2. Select [Edit->Bookmarks->Next Bookmark], press F2 or sdlect [Bookmarks->Next Bookmark] from
the local menu or click the next bookmark toolbar button ( ﬁ ).

To jump to the previous bookmark in afile:

1. Ensurethat the insertion cursor is somewhere within the file to be searched.

2. Select [Edit->Bookmarks->Previous Bookmark], press SHIFT+F2 or select [Bookmar ks->Previous
Bookmark] from the local menu or click the previous bookmark toolbar button ( ﬁﬁ ).

To remove all bookmarksin afile:

1. Ensurethat the window, whose bookmarks you want to remove is the active window.

2. Select [Edit->Bookmarks->Clear All Bookmarks] or select [Bookmar ks->Clear All Bookmarks]
from the local menu or click the clear all bookmarks toolbar button ( & ).

47 Printing aFile

2

80

To print afile:
1. Ensure that the window, whose contents you want to print, is the active window.
2. Select [File->Print...], or click the print toolbar button (&) or press CTRL +P.
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4.8 Configuring Text Layout

The following sections detail how to set-up the layout of the text within the editor windows.

481 Page Set-up

When you print afile from the High-performance Embedded Workshop editor, the settingsin the print dialog
box affect the way in which the file is printed (e.g. double or single sided). Control over how the text is
formatted on the page can a so be controlled via the page set-up option. This allows you to specify the margins
(top, bottom, left and right) of your printouts. It is often necessary to set this because some printers cannot print
to the edges of an A4 page. Furthermore, some users have their own layout requirements (e.g. alarge left hand
margin so that code can be placed in an A4 binder).

2 To set-up the page margins:
1. Select [File->Page Setup...]. The “Page Setup” dialog will be invoked (figure 4.6).
2. Enter into the edit fields the margins reguired (set the “inch” or “mm” radio buttons to set the
measurements).
3. Click “OK” for the new settings to take effect.

b arging

L [T Bigh: [0
Top: ID— B ottan: ID—

& nch ' mm
Header:
i
Footer;
| i
W “wiap Test

ak. I Cancel |

Figure 4.6: Page Setup Dialog
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2 To set-up the page header and footers:

1. Select [File->Page Setup...]. The “Page Setup” dialog will be invoked (figure 4.6).

2. Enter into the header and footer edit fields the text required to be displayed. All norma placeholders are
available along with page numbering, text justification and date fields. These are al expanded before
the pageisto be printed.

3. Click “OK" for the new settings to take effect.

2 To set-up print wrapping
1. Select [File->Page Setup...]. The “Page Setup” dialog will be invoked (figure 4.6).
2. Click the wrap text check box. This switches on the wrap text facility when printing so no text is
truncated and everything isvisible.
3. Click “OK” for the new settings to take effect.
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482 Changing Tabs

2 To changetab size:
1. Select [Tools->Options...]. The“Options’ dialog will be displayed. Select the “Editor” tab (figure 4.7)).
2. Enter into the“Tab size” field the number of desired tabs.
3. Click “OK" for the tab setting specified to take effect.

Build  Editor I\N'olkspacel Eonfirmationl Networkl

— Spacing:

Use spaces a5 tabs Tab sige: | &

v Enable auto indentation

— General:
[ Save files before executing any tools [+ Show files in noteboak
[~ Prompt before saving files ¥ Enable syntax coloring
[V Enable Smart-edit for C++ files [ Enable toaltip watch

— External editar:

™ Use gxternal editar:

| ity |

QK I Cancel

Figure 4.7: Options Dialog Editor Tab

When aTAB key is pressed in the editor a tab character is usually stored in the file. However, sometimesit is
preferable to store spaces instead. The representation of tab characters can be controlled via the “ Options” diaog.

2 To use spaces as tabs:
1. Select [Tools->Options...]. The“Options’ dialog will be displayed. Select the “Editor” tab (figure 4.7).
2. Setthe“Use spaces astabs’ check box as appropriate.
3. Click “OK” for the tab setting specified to take effect.
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483 Auto Indentation

When you press return in a standard editor the insertion cursor will move to the next line down, at the first
column (i.e. against the left hand side of awindow). Auto Indentation is a feature which, when return is pressed,
places the insertion cursor on the next line (as before) but under the first non-white space character of the
previousline. This enables you to type neat C/C++ or assembler code faster as you don’'t have to type leading
spaces or tabs yourself.

Figure 4.8 illustrates two examples. Thefirst (i) shows the effect of pressing return when the auto indentation
feature is disabled - the insertion cursor returns to the left-hand side of the window on the next line. When the
line“int z=20" istyped, it isnot aligned with the previous two lines. The second example (ii) shows the effect of
pressing return when auto indentation is enabled - the insertion cursor drops underneath the “i” of the previous
line. Now, when theline “int z=20" istyped, it is automatically aligned (i.e. automatically indented).

void myfunction(void)
{
int x=5;
inty=10;
=

int z=20;

void myfunction(void)
{
int x=5;
inty=10;

p |
int z=20;

i) Auto Indentation Disabled

ii) Auto Indentation Enabled

Figure 4.8: Effect of Auto Indentation

2 To enable/disable Auto Indentation:
1. Select [Tools->Options...]. The“Options’ dialog will be displayed. Select the “Editor” tab (figure 4.7).
2. Set the “Enable auto indentation” check box accordingly.
3. Click “OK" for the setting of the auto indentation check box to take effect.
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49 Splitting a Window

The High-performance Embedded Workshop editor allows you to split atext window into two. Figure 4.9 shows
the split bar button which islocated just underneath the maximize button at the top right hand corner of any text
window.

Figure 4.9: Split Bar Button

2 To split awindow:
Double click on the split bar button to split the window in half or click on the split bar button, keep the button
pressed, move the mouse down and then rel ease the mouse button at the point you want to split the window.
2 To adjust the position of the split bar:

Click on the split bar itself, keep the button pressed then move the bar to the new position and then release
the button.

2 Toremove the split bar:
Double click on the split bar or move the split bar to the top or bottom of the window.

85
RENESAS




410 Configuring Text

The following sections detail how to change the appearance of the text displayed in the editor windows.

410.1 Changingthe Editor Font

The High-performance Embedded Workshop allows you to specify the font to be used in itsinternal editor. All
editor windows, regardless of thefile type, use the same font.

2 To change the editor font:
1. Select [Tools->Format Views...]. The “Format Views’ dialog will be displayed. Select the Sourceicon
in the tree (figure 4.10).
2. Select the desired font from the “Font” list.
3. Select the size of the font from the “Size” list.
4. Click “OK” to confirm the new editor settings.

Format ¥, llil

E- R Al views
..... [ Selected Text
..... D Te:-:t

Font

| v

[:l Co++ ligt file Fant

C++ gource file :
C++ header file IEouner Mew J

C zource file _—
C header file Paint Size

C list file Iﬁ
Freproceszed C zource file 10

Expanded azzembly zource file
Azgembly zource file

Link.age zumbol file

Azgembly include file
Preprocessed C++ source file HEW Zample Text

Azzambly lizt file -

T ndifyy Hemave | 0K I Cancel

L DDDDDDDDDDDD

Figure 4.10: Format Views Dialog Font Tab
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411  Syntax Coloring

To enhance code readability, the HEW editor can display specific strings (i.e. keywords) in different colors. For
instance, C source code comments could be shown in green and C types (e.g. int) could be shown in blue.

The coloring method used can be specified on afile group by file group basis. For example, you can define
different color schemesfor a C sourcefiles, text files, map files or even your own files.

2 To change exigting colors:
1. Select[Tools->Format Views...]. The “Format Views' dialog will be displayed.
2. Select theitem underneath theicon in the tree you wish to modify the colour for. This should be the file
type (e.g. C sourcefile) and correct keyword group (e.g. identifier or pre-processor).
3. Select the “Colour” tab.

4. Modify the “Foreground” and “Background” color lists as desired. The color “SYSTEM” refersto the
current window foreground and background settings in control panel.

5. Click “OK” for the new colorsto take effect.

2 To create new keyword groups:
1. Select [Tools->Format Views...]. The “Format Views’ dialog will be displayed.
2. Select thefile type in the tree to which you wish to add the new keyword group.
3. Click “Add...” underneath the tree. The “ Add Category” dialog box will be displayed (figure 4.11). Enter
the name of the keyword group in the “ Category Title" field, then click “OK” to create the new keyword
group.

Add Category EHE
Categom Title: QK. I

|| Cancel |

Figure 4.11: Add Category Dialog

2 To create new keywords:
1. Select [Tools->Format Views...]. The “Format Views’ dialog will be displayed.

2. Select theitem underneath the source view icon in the tree you wish to modify the syntax highlighting
for. This should bethefile type (e.g. C sourcefile) and correct keyword group (e.g. identifier or pre-
processor).

3. Select the“Keywords’ tab (figure 4.12).
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=[] Al views | Colow | Font  Kewwords |Enmments
i [N Selected Test
e[ Tet
EHE' Source break
----- [ Selected Text o) :
----- O Text continue
B[ o list il default ﬂl
-2 C++ source file do
) elze
-2 C++ header file — for
=5 D C source file goto
4 Comments ift
[ Contral . Esfv?:rcnh
[ Declaration while
[ Operatar
M PreProcessor
- C header file
- C list file
B Preprocessed C source file HEW Sample Text
- Expanded aszembly source file -
fdd Madify Bemove | ok | Concel |

Figure 4.12: Format Views Dialog K eywords Tab

4. Click the“Add...” button to add a keyword. Then the “Add Keyword” dialog (figure 4.13) will be
launched. Specify akeyword in the “Keyword” field and click “OK” to close the didlog. To remove a
keyword, select the keyword and click the “Remove” button.

Add Kepword HE

Keyword:
I Cancel |

Figure 4.13: Add Keyword Dialog

When you create anew file, syntax coloring will not be active as anew file does not initially have an extension
(new files are named arbitrarily by the editor without an extension). In order to activate syntax coloring, you
must save the new file with a name, which has one of the above extensions.

2 To disable/enable syntax coloring:
1. Select [Tools->Options...]. The“Options’ dialog will be displayed. Select the “Editor” tab (figure 4.7).
2. Set the “Enable syntax coloring” check box as necessary and then click “OK”.
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412 Templates

When developing software it is often necessary to enter the same text repeatedly, for instance, when typing a
function definition, for loop or acomment block for a function. The High-performance Embedded Workshop
editor allows you to specify ablock of text (or template), which can be inserted into the currently active editor
window. Thus, once a template has been defined, it can be automatically inserted without the need to re-enter it
manually.

4121 Defining a Template

2 Todefine atemplate:
1. Select [Edit->Templates->Define Templates...], select [Templates->Define Templates...] from the
local menu, or click on the define template toolbar button ( i ). The dialog shown in figure 4.14 will be
displayed.

Cefine Templates

;I Cancel

Eemave

£t

Lzer nput

-

<
Shortcuts:

| I

Figure 4.14: Define Template Dialog

2. Click “Add". A dialogisdisplayed that asksyou to enter your chosen template name. This name must
be unique otherwise a duplicated template name message will be displayed and the template will not be
added.

3. If you want to modify an existing template use the “ Template name” drop down menu to select which
template you want to modify.

4. Enter the desired text into the “ Template text” text area. Y ou can copy text from another editor window
and then pasteit into thisdialog using CTRL +V.

5. There are 10 shortcut keys reserved for templates. If you want to designate one of these select thekey in
the drop list at the bottom of the edit template dialog. These range from CTRL+0 to CTRL+9.

6. Enter the following placeholder to insert specia information when the template is inserted:
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Table4.2 PlaceholdersUsed in Templates

Menu Entry

Placeholder

Replaced With

File path + name

$(FULLFILE)

Filename (including full path)

File name $(FILENAME) Filename (excluding path including extension)
File leaf $(FILELEAF) Filename (excluding path and extension)
Workspace name $(WORKSPNAME) Workspace name

Project name $(PROJECTNAME) Project name

Line number $(LINE) First line number of template insertion

Time $(TIME) Current time

Date, text $(DATE_TEXT) Current date in text form

Date, day/month/year

$(DATE_DMY)

Current date, in dd/mm/yy form

Date, month/day/year

$(DATE_MDY)

Current date, in mm/dd/yy form

Date, year/month/day

$(DATE_YMD)

Current date, in yy/mm/dd form

User name

$(USER)

Current windows user

Cursor position

$(CURSOR)

Insertion cursor — Positions the cursor in this
position after template has been inserted

7. Enter the $(CURSOR) character to specify where the insertion cursor isto be placed after the template
has been inserted. If thisis not specified then the insertion cursor will be placed after the last character in
the template (asin anorma paste operation).

User Input

When defining atemplateit is possible to define a user input field. Using the following placeholder specifies
this $(USERINPUT<n:1-10>[" <some text>"). Thenisanumber, which identifies the user input identifier.
These placeholders can be added manually but the user input button on the define templates dialog adds these
placeholdersin an automated manner. When the template isinserted into afile adialog is displayed which
allows you to enter some custom text for each of thesefields. Thistext is then inserted instead of the
placeholder. You can define ten of these user input fields.

Figure 4.15 shows alist of templates, which islocated on the “ Templates’ tab of the “Workspace” window.
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B Templates
H Header

ER

@ ToolChain Templates

Project I Templates lNawga‘aon I

Figure 4.15: Templatesview

Any new templates, which have been added to the HEW, are displayed under the templates folder. The
toolchain templates folder is for templates, which are read only and have been provided for use in the HEW
system by the current toolchain. Templatesin thisview can be dragged for insertion into an editor file. Itisaso
possible to drag an area of text from the editor into the templates folder for quick template creation. Right
clicking on this view displays a pop-up so that you can quickly add a new template, remove the current selection
and edit the current selection.

4122 Deletinga Template

2 Toddeteatemplate:

1. Select [Edit->Templates->Define Templates...], select [Templates->Define Templates...] from the
local menu or click on the define template bookmark toolbar button ( I ). The dialog shown in figure
4.14 will be displayed.

2. Use the Template name drop down list to select the name of the template you wish to remove and then
click the “Remove” button.

3. Clicking “OK” saves the template changes and dismisses the dialog.
4123 Insertinga Template

2 Toinsert atemplate:

1. Select atemplate in the toolbar, then click the insert template toolbar button (T ), select [Edit->
Templates->Insert Template...] or select [Templates-> Insert Template...] from the local menu. The
dialog is dismissed and the chosen template is added to the current editor window.

Note: It isalso possible to use the defined keyboard shortcut or drag the template from the templates
view.
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4124 BraceMatching.

Complicated source code can often become unwieldy, especially when blocks of C code are deeply nested within
each other or when complex logic statements are expressed within an ‘if’ clause. To help in such situations, the
High-performance Embedded Workshop editor provides a match brace feature which highlights text between
bracesof type{ }, () and[].

2 Tofind amatching brace:

1. Either highlight the open brace to match from or place the cursor beforeit.

2. Click the match braces toolbar button ({ ), press SHIFT+CTRL +M, select [Edit->Match Braces] or
select [Match Braces] from the local menu.

To check the structure of an entire file, place the cursor at its start and then repeatedly invoke the match brace
operation. The editor will successively highlight each pair of bracesin turn until there are no more to match.
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413  Editor Column management

The editor in HEW has the ability to manage columns apart from the main editor column. These can be added
and used by debugger feature. Y ou can choose the column to display/undisplay.

o tutorial.c 0] x|
#include <no_float.h> ZI
#include <{stdio.h>
#include <math.h>
#include {stdlib.h>
void main{void);
void sort(long =a);
void change{long =a);
extern void srand{unsigned int};
0x00000a0c void main{void)
0x00000a16
long a[18], min, max;
long j;
int i;
0x00000=18 srand{1);
0x00000220 | print£("#itk Data Input ##\n");
0x00000aZc for{ i=8; i<18; i++ ){
0x00000azZe j = rand{};
0x00000a36 iFg(j < 8¢
0x00000a38 i=-i;
0x00000a3a alil = j;
0x00000a44 printf("a[%d]=%ld\n",i,a[i]);
H
0x00000a62 sort(a);
0x00000=266 printF({"=*x Sorting results x=x\n");
000000272 For( i=B; i<10; i++ ){
0x00000a7 4 printf("a[%d]=%1ld\n",i,a[i]);
I8 B
< R v

Figure 4.16: Editor columns

2 To switch off acolumnin al sourcefiles:
1. Right click on the editor window.
2. Click the“Define Column Format...” menu item.
3. The“Globa Editor Column States’ dialog is displayed (figure 4.17).
4. The"Check status’ shows whether the columnis enabled or not. If itischecked it isenabled if the
check box is gray this means that in some files the column is enabled and in other files it is not.
5. Click “OK” for the new column settings to take effect.

2 To switch off acolumn in one sourcefiles:
1. Right click on the editor window, which you wish to remove a column from, and the editor pop-up is
displayed.
2. Click the Columns menu item and a cascaded menu item appears. Each column is displayed in this pop-
up menu. If the column isenabled it hasatick next toitsname. Clicking the entry will toggle whether
the column is displayed or not.
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Global Editor Column States

[w]Cowerage
[w] Editor

[w]Source Address Cancel |

Figure 4.17: Global column state Dialog

414  Enabletooltip watch

Select [Tools->Options...] and then select the “Editor” tab (figure 4.7). By checking “Enable tooltip watch”,
you can use the Tooltip Watch feature, the quickest way to look at avariable in the source program.

2 Toview atooltip watch on the Editor window:
1. Display the source file containing the variable that you want to examine on the Editor window (figure
4.18).
2. Rest the mouse cursor over the variable name that you want to examine - atooltip will appear near the
variable showing avalue of that variable.

0x00002054 sort (&) ; ZI
O0x0000Z205& printf ("¥*F Sorting re:
O0x0000zZ066 for( i=0; i<10; i++ 11
O0x0000Z06e printf (Ma[sd] =% 1d\:
i

O0x0000z2020 mipn =_=l0l -«
Ox00002092 < rasd 2%00000000 J
O0x0000z2094 min = 0;
Ox00002096 max = 0;
O0x00002098 change (&) ;
O0x0000209e min = a[9]:
O0x000020=s0 max = a[0]:

H -
[« _'l_|

% democ l

Figure 4.18: Viewing a tooltip watch
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5.  Tools Administration

Y ou control the components, which can be used by the High-performance Embedded Workshop viathe “Tools
Adminigtration” dialog (figure 5.1), which isinvoked via[Tools->Administration...]. Modification of the
“Tools Administration” dialog box is only possible when no workspace is open, while only reference is possible
when aworkspace is open.

Tools Administration

Registered components:

0K I
Yerzion ;I Cancel |

[k ) Begister... |
Mapview 1.0 Uizt |
----- (23 Utility Phazes P i
=3 Debugger Components ﬂl
#4 Binamy File Object Reader 1.0 o |
ElfDwarf2 object reader 2.0 =~
Gener?c Cache View.EEX 1.0 [ |
Generic Coverage Wiew ECH 1.0
#9 Generic Event Wiew EC 1.0 Taol information...l
Generic Image Wiew EC 1.0

-
I N [ K TN V] in .
« | LI_‘ Uninstaller... |

[ Show all components

Current HEW tools database location:

IC:\HEW Madify. . |

Figure5.1: Tools Administration Dialog
There arefive standard types of component:

* Toolchains - aset of build phases (e.g. compiler, assembler, and linker). These components provide the build
capability.

» System Tool - an application (.EXE), which can be launched from the “Tools” menu. They are often
provided as extra applications, which support the toolchain (e.g. an external debugger like the Hitachi
Debugging Interface (HDI) or an interactive graphical librarian).

» Utility Phase - a“ready made” build phase which supports some specific build functionality (e.g. analyze
complexity of source code, count lines of source code, etc.). These components provide added functionality
to the build that is not toolchain specific.

» Debugger Component —acomponent that supports some specific debugger functionality (e.g. Target
platform, Object reader, etc).

» Extension Component —a component that provides key functionality in a certain area of the HEW system.
These components cannot be unregistered when installed (e.g. The HEW builder, debugger and flash
support).
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5.1 Tool Locations

The HEW maintains the locations of HEW compatible components automatically as each new tool isinstalled.
After installation, the HEW stores information about the component (including itslocation) — thisis referred to
asregistration. Although initia registration is automatic, during the course of development or if you want to
manage the tools being used in your projects more effectively, you may need to register components yourself.
The remainder of this chapter discusses registration and how it affects you.

5.2 HEW Registration Files (*.HRF)

When a HEW compatible component (i.e. toolchain, system tool or utility phase) isinstalled, part of its
installation will include afile with the extension .HRF (figure 5.2.i). Thisfile, named a“HEW Registration File”,
describes the component to the HEW. The process of registration refers to loading a component’s .HRF file into
the tools administration dialog (figure 5.2.ii).

i. INSTALL ii. REGISTER
%7 cA G\
MyTool MyTool
MYTOOL.HRF D MYTOOL.HRF |
. N HEW
bin E bin
- etc e elc
help help

Figure5.2: HRF File L ocation and Registration

In order to use a component with HEW it must first be registered. The “Tools Administration” dialog (figure 5.1)
shows al currently registered components. To access it, ensure no workspaces are open and then select
[Tools->Administration...]. If you attempt to access tools administration when there is aworkspace open the
tools administration dialog is opened but cannot be modified. When HEW isinstalled by default any new tools
are automatically registered.

HEW storestool information in atool database file. By default thisis created in the HEW application directory,
however if you are working in a network environment this directory may be set to another location. Itispossible
to change the tool directory location.

2 To change the tools location:

1. Select [Tools->Administration...].

2. Click the“Modify” button for the “ Current HEW tools database location” field.
3. Select the directory under which the new tool islocated, then click “OK”.
4

Thiswill switch the directory and change the tool location to the new directory. It will be necessary to
scan for any new toolsthat may bein thislocation thisis achieved by using the scan disk or register tool
functionality.
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5.3 Registering Components

The HEW will automatically attempt to register any new componentsinstalled since the last time it was invoked.
However, in some circumstances you may need to register components yourself.

531 Sear ching Drives for Components

In some casesit is useful to search a drive for HEW compatible components. Thisis especially useful if the
HEW installation was deleted or corrupted as it can recreate your tool information instantly.

2 To search for components:

1. Click the*Search Disk..."” button on the “Tools Administration” dialog (figure 5.1). The “ Search Disk for
Components” dialog will be displayed (figure 5.3).

Companents
) : . . LCloze
Select the directony in which to begin the search:;
ID:'\HEWE Browsze.
¥ Include subfolders Start

Located components:

Compaonet Yerzsion | HAF Location  « Register
Generic TCL Toolkit View ECx 1.0 D:%H =1

U

HewT argetS erver 1.0 D \Hew3hSugter Register Al
SuperH RISC engine Standard Toolchain 8.01.0  DiHew3\Toolsh)
M apwiew 1.0 D MHew 34 Tools)
H Series Librarian Interface 1.1 D:vHew W T oolsh
H&5 HE8/300 Standard Toolchain E01.0  D:A\Hew3\Toolshl

Call'walker 1.1 D:'\HEWE'\TDDEIILI
1 | 3

Search Status: 51 file(z] found

Figure5.3: Search Disk for Components Dialog

2. Enter thedirectory in which you would like to search into the top field or browse to it graphically by
clicking the “Browse...” button.

3. Check the “Include subfolders’ check box if you would like to search the directory specified and all
directories below it.

4. Click the“Start” button to begin the search. During the search, the “ Start” button will change to a“ Stop”
button. Click the “ Stop” button to halt the search at any time.

5. Theresults of the search are shown in the “Located components” list. Select a component and click
“Register” to register an individua component or click “Register All” to register all located components.

6. Click “Close” to exit the dialog.
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5.3.2 Registering a Single Component

The HEW allows you to navigate directly to a single component in order to register it. The HEW Registration
File (*.HRF) islocated in the root directory of acomponent’sinstallation.

2 To register acomponent:
1. Click the“Register...” button on the “Tools Administration” dialog. A standard file open dialog will be
launched with itsfile filter set to “HEW Registration Files (*.hrf)”.
2. Navigate to the .HRF file of the component you would like to register, select it and then click “ Select”.
3. A dialog will be invoked which displays information regarding the selected tool. Click “Register” to
confirm that you want to register the tool or click “Close” to abort the operation.

54 Unregistering Components

The components, which are registered with the HEW, affect the way in which it behaves. For example, every
compatible system tool, which isregistered, will be added to the tools menu when anew project is created.
Sometimes this may not be desirable. If so, open the “Tools Administration” dial og, select the component from
the “Registered components’ list and then click the “Unregister” button. A dialog will be invoked which asks
you to confirm thisaction. Click “Yes' to confirm the action.

Note:  Unregistering a component does not remove itsinstallation from hard disk. It smply removes the
information, which the HEW was storing about that component (i.e. it “disconnects’ it from the HEW).
The action can be easily reversed at anytime by registering the tool (see above). If you want to remove a
component from the hard disk (i.e. uninstall a component) then refer to the section “Uninstalling
Components’ later in this chapter.
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5,5  Viewing and Editing Component Properties

To view information regarding a component, select it from the “ Registered components” list and then click the
“Properties’ button. The properties dialog will be displayed with the “ General” tab selected (figure 5.4). Thistab

displays the name, version and location of the selected component. None of the information on thistab is
editable.

SuperH RISC engine Standard Toolchain &.0.1.0 Propert 2=

General | Information | Environment

MHame : SuperH RISC engine Standard Toolchain
Wersion ; 8.0.1.0
Location ; [ Hew A Toolz\RenezashShha 01

Cahicel |

Figure 5.4: Properties Dialog General Tab

Select the “Information” tab to view any information about the component (figure 5.5). This may include
copyright information, enhancements, bug fixes, user notes and so on.

SuperH RISC engine Standard Toolchain §.0.1.0 Properti ﬂll

General  Information | Epviromment

Information;
High-perfarmance Embedded workshop j

SuperH RISC enagine Standard Toolchain [Wer. 8.0.1.0)

SuperH RISC engine C/C++ Library Generator [Wer. 3.0.01]
SuperH RISC engine C/AC++ Compiler Wer, 8.0.02) j

Cancel |

Figure5.5: Properties Dialog I nformation Tab

Notethat if the tool has a compatibility issue the problem may be reported in thisinformation edit field.
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Select the “Environment” tab, if it exists, to view and edit acomponent’s environment settings (figure 5.6). This
dialog ismost commonly used to modify the environment of atoolchain.

2%

General | Information  Environment

Environment wariables:

PATH=D:"Hew 34T oolz\FenesashShiE_0_1%bin Add...
SHC_INC=Dr\Hew\T oolzhRenezazhShhd 0 Thinclude

SHC_LIB=D:\Hew3\T oolz\Renezas\Shha_0_1%bin W odi
SHC_TMP=CA\DOCUME~14ADMINI~T\LOCALS ~14T emp il

. _PI Eemove |

ak. I Cahicel |

Figure5.6: Properties Dialog Environment Tab

To add anew environment variable, click the “Add...” button (the dialog shown in figure 5.7 will be invoked).
Enter the variable nameinto the “Variable” field, the variable’s value into the “Value” field and then click “OK”
to add the new variable to the “ Environment” tab. Placeholder pop-up menus are included to ensure that the
environment can be specified as flexibly as possible. For a detailed description of placeholders see appendix C,
“Placeholders’.

To modify an environment variable, select the variable that you want to modify from the “ Environment” tab and
then click the “Modify...” button. Make the required changesto the “Variable” and “Vaue” fields, and then
click “OK” to add the modified variable to the “ Environment” tab. To remove an environment variable, select it
and then click the “Remove” button.

Environment Yariable EHE3

Wariable:
=
Cancel |

Ic: hdog o mptools o windows o Memp [ 3 || Ectapi';hﬁ_ﬁs;

Walle:

Figure5.7: Environment Variable Dialog
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5.6

Uninstalling Components

The HEW provides abuilt in uninstaller method, which can remove unregistered components.

2 Touninstall acomponent:

1. Select [Tools->Administration...].
2. Click onthe uninstaller button. The “Uninstall HEW Tool” dialog isinvoked (figure 5.8).
Uninstall HEW Tool d |
. . . ) Lloze |
Select the directory in which to begin the search for tools:
Browsze. . |
v Include subfolders
Located Toolz which can be uninztalled:
Component | Werzion | Inztallation Directany Whirztall |
1 | i
Search Status:  Idle
Figure5.8: Uninstall HEW Tool
3. Enter the directory in which you would like to search into the top field or browse to it graphically by

7.

clicking the “Browse...” button.

Check the “Include subfolders” check box if you would like to search the directory specified and all
directories below it.

Click the “Start” button to begin the search. During the search, the “ Start” button will change to a“ Stop”
button. Click the “ Stop” button to halt the search at any time.

The results of the search are shown in the “Located Toolswhich can be uninstalled” list. Select a
component and click “Uningtall” to uninstall a component.

Click “Exit” to exit the dial og.

A component may only be uninstalled if it is not currently registered with the HEW. If you attempt to uningtall a
tool, which isregistered, then the dialog shown in figure 5.9 will be displayed. In such a case, you must return to
the “Tools Adminigtration” dialog via[Tools->Administration...], unregister the tool and then invoke the tool
uninstaller again.
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High-performance Embedded Workshop

&L

Hitachi SuperH RISC engine Standard Toolchain 7.1.2.0is cumently registered; you may not uninstall a bool that is registered with HEW.

Fleaze ugze the adminiztration dialog to unregister the Tool.

Figure5.9: Unable to Uninstall Tool

If atool is not registered with the HEW then the dialog shown in figure 5.10 will be displayed when the
“Unregister” button is clicked. This confirmation dialog displays al of the files and folders that will be deleted.
If you are certain that these files and folders can be deleted then click the “Yes” button. To abort the uninstall
click the “No” or “Cancel” buttons.

Confirmation

The fallowing files and folders will be deleted:

c:hewh T oolchaingyHitachivSHYA1 Dhehe toolchain, bk
c:vhew' T oolchainz \HitachivSHYE1 0N zample
c:hewh T oolchaingHitachivSHYWAT Dhinclude

o vhewt ToolchainsiHitachinSHYWST0Mib

c:hewh ToolchaingyHitachit5HY51 04 bin

o vhewt ToolchainsiHitachinSHYWET DM Rew

c:hewh T oolchaingHitachibSHYE1 DA binhdwichy.exe
o vhewt ToolchainsiHitachinSHYWST DMbinvshic. exe
c:hewh ToolchaingHitachitSHYE1 DAbintshcasm.exe
c:vhew' T oolchains ' HitachitSHYS10Mbinhs ko mag
c:vhewh T oolchaingHitachivSHYWA1 Dhbintshcern, off

o vhewt ToolchainsiHitachinSHYWSTMbinskicfit exe

o vhewt Toolchaing'HitachiySHYET0Mbintshogen. exe
c:vhew' T oolchains ' HitachitSHYET10MBinhshchip. msg
c:hewh ToolchaingHitachibSHYS1 DM binhshcmd] exe
c:vhew' T oolchains \HitachitSHYE10MBinhshopep. exe

Are you sure you want to delete the above files and folders?

[ |

Cahicel |
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Figure5.10: Confirmation Dialog
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57

Technical Support Issues

The “Tools Administration” dialog is aso capable of displaying information regarding “hidden” system
components. These are part of the HEW itself that cannot be unregistered/registered manually. If you check the

“Show all components’ check box on the tools administration dial og, extra component folders are displayed (see
figure 5.11).

Toolz Adminiztration

Registered components:

0K

Component I Yerzion ;I

----- [_3 Utility Phazes

#-[Z3 Debugger Components
-[Z3 Extension Components

----- [Z3 Commurication Tools

-0 System Extension Components
-2 Project Generators

----- 20 Project Generators - Custom
Ela Yergion Control System

Cuztom VCS 2.0
Microsoft Visual Sources afe 5.0/6.0 a0
223 Toolchain Suppart

[=] HES5 HE/300 Toolchain Supparter 25 =

in Supporker

¥ Show all components

Current HEW tools database location:

IC:\HEW

Cahicel

Begister...
Orrearster
Properties. .
Export..
Search disk...
Toal infarmatiarn...

rinztaller...

Maodify...

P ERELRLE K

Figure5.11: All Components Shown

When seeking technical support, you may be asked to give details about some or al of these components. To do
so, open the respective folder, select acomponent and click the “Properties’ button. The properties dialog that
will be invoked behavesin the same way as discussed previoudly in this chapter, with the exception that thereis

no “

Environment” tab.

The HEW aso has a feature, which outputs tool information regarding the registered componentsto afile. This
allowsyou to retrieve information on the entire HEW system. This information can then be sent to your
technical support contact if you are experiencing problems with the HEW.

2 To output tool information:

1. Click the[Tools->Administration] menu item.

Click the “Tool information...” button. A standard windows file save dialog is displayed.

2.
3. Choosethefilelocation and click OK.
4

A fileis created in the chosen location with the current registered tool setup of the HEW.
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If any of the components have problems these can be seen in the tools administration dialog. If theicon hasan
additional icon this explains the problem. There are two additional iconsthat can be displayed. If acomponent
isfound but cannot be used due to it being an old version or another dependent component is not available then
theiconin figure5.12 is used to show this. If the component is not located where the registration file saysitis
then theicon in figure 5.13 is used to show this.

Reaqistered components:

Compaonent

% 1AR TINY-SERIES [H3/300HN)
#. SuperH RISC engine Standard T

EI Iﬁﬁrl—l nl‘:l_\' ﬁl"lﬂil"lﬁ ‘:l':uru'l:urr' Tn'n'.

Figure5.12: Incompatible component found icon

----- H25 HE/300 Senes Simulator Target Platfarm 2.0
----- Hton Embedded Monitar Platform 1.0
Free Intel Hex Recard Obiect Beader 1.0

Figure 5.13; Component not found icon
Note:
If the tool has one of these errorsthen it is possible to get more information by the following method:

2 To get tool error feedback:
1. Click the[Tools->Administration] menu item.

2. Select thetool inthelist that has anissue.
3. Click “Properties...”
4. Select theinformation tab and scroll the edit field to the bottom.
5. Thereason for the problem will be displayed in this area.
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On-Demand components

The HEW version 3.0 onwards has the concept of on-demand components. These components are not
automatically loaded by the application or the debugger component. These components can be loaded by the
user or as part of the project generation process.

2 Toload or unload an on-demand component manually:

1. Click the[Project->Components...] menu item.
2. The component gallery dialog isdisplayed. Thisisdisplayed in figure 5.14.
3. Select the component you wish to load. Click the load button. The componentsimage should change to
the loaded state.
4. If you wish to unload a component. Select the component. Click the unload button. The components
image should change to the unloaded state.
5. Click OK to verify the changes.
x
Project: | U=l
=423 Application Extensions 0k |
Loaded component E ITROM component
-|af) 0SEK componert Cancel |
Unloaded component E";‘,‘ Cuztom memory view component
Intermediate state companent 72 Pin wiew component
LLoad |
Figure 5.14; Component Gallery
Note:

Each project in your workspace can have different components loaded and unloaded. If you have multiple
projects you can use the “Multiple projects...” and “ All projects’ items to change a components |oad status over
more than one project. If you select a combination which means the component is loaded in one project and not
anther then the intermediate state icon is displayed.
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59  Custom Project Types

The [Project->Create Project Type...] menu itemin HEW allows you to create a template for your project.
This menu item takes the settings of the current project and then creates a project type for you. The user can
specify the name of the new type and style of the project generation wizard. Once created these project types
appear in the “Tools Administration” dialog and are initially hidden in the system components part of the tools
administration tree. To export one of the custom project generators select the “ Export” button on the “Tools
Administration” dialog. The execution environments of the custom project generators are packaged on the
execution file that can beinstalled. When thisfile is executed on the target user’s machine, the custom project
generator isinstalled.

Once created custom project type will then appear in the New workspace dialog and can be used to create
identical copies of your project.

2 To create custom project generator:
1. Open the workspace that contains the project you wish to convert into a custom project generator.
2. Setthe project you wish to convert asthe current project.
3. Click the [Project->Create project type...] menu item.
4. Thefollowing didog is displayed:

21X

hat tithe would wou like to be uzed for the new
project type?

CunrentProjectM ame

Projects generated uging the new tpe will

include all of the filez in the project directary

and below, Wwould you like to include the

contents of the configuration directaries?
' Yes please

Mo thanks

Wiew directories ta be included...

Approx. size of generator: 581 63KB

< Back I Hewt » Finizh Cancel

Figure 5.15: New project type wizard — Step 1 Dialog

5. Theedit field is set to the current projects name. Thiswill become the name of the new project

generator project type that will appear in the new workspace dialog. Change the contents of the fields
as appropriate.

6. At thisstage you can choose to include the configuration directories or not. Inthiscaseit isnormal to
not include the contents of these directories because normally these are only intermediate files.

7. Thenclick next. Thefollowing dialog is displayed.
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2l x|
Wwhat tppe of generator would you like?
& Mo dialog

" Information dialog with default bitmap

Browse... |

what loon would pou like to be uzed?

" Information dialog with bitmap:

' The default icon

4 icon contained in the fils:

I Browse... |
Image: I@

Approx. size of generator: 581 63KB

<Back | teas | Einish

Figure 5.16: New project type wizard — Step 2 Dialog

8. At thisstage you can change the wizard graphic and the project icon. By default no dialog is displayed
for thiswizard. When you wish to display “Project information” dialog box, you should either
information dialog with default bitmap or information dialog with bitmap. This selection affects to
show icon in the “Project information” dialog.

9. You can also decide to change the icon for the project type at this stage. The default icon is shown but
you can choose to use your own custom icon and this will be displayed on the new workspace dialog.

10. When you are happy with the setup of the generator click finish. If you click “Next” button, Step 3
dialog box is shown.
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what test would wou like dizplayed on the
generatar dialog?

Dizplaying project information

H o

Approx. size of generator: 581 63KB

< Back | Hewt = | Finizh I Cancel |

Figure5.17: New project type wizard — Step 3 Dialog

11. You can enter project information. It will be shown “Project information” in Project information dialog
box.

12. You can click “Finish” button. Now the generator will be created in the HEW\system\pgc directory in
your HEW installation. It will also automatically appear in the new workspace dialog.
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Y ou can see anew project type (In this example, “Current Project Name”) after creating by custom project
generator.

2lx
Projects I
@ Application i«_\p"orkspace M ame:
= -
Bl emonstlatllon . T
@ Empty Application
T@ Irpart b akefile I
G Library Directorny:
ID:\HewS Browse... |
LCPU Farnily:
ISuperH RISC engine j
Tool chair:
IHitachi SuperH Standard j
Properties... |
QK I Cancel

Figure 5.18: New Project Workspace Dialog
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Y ou can select a project type and enter workspace and project name then click, OK. Thisdialog contents come
from “Project type wizard - Step 2" and step 3 setting.

x

Project information

Project infarmation:

Dizplaying project infarmation

cBack | e | Ensh |

Figure5.19: Project information Dialog
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These can then be exported from the HEW system and be given to other users you need to use your project.

2 To export acustom project generator to another user:

1. Click on[Tools->Administration].
Check the “ Show all components’ checkbox.
Expand the “Project Generators— Custom” folder.
Select the custom project generator you wish to export.
Click the “Export...” button.

S S

Tools Administration

Registered components:

Component WVersion

Cancel
®-[_1 Toolchains
D Syztem Tools
[Z3 Utility Phazes
[C1 Debugger Components
[Z1 Estension Components
D Communication Toals .
23 System Estension Components Broperties...

Z Project Generators . |

EI a Project Generators - Custom

B m IZl_urentF'n:uieu::tr'-larn& 0 Search disk... |
(Z Wersion Contral System

E (9 Teclchain Support T ool information...
[:I Diefintion Parser

4 [ ¥ Uninstallsr... |

Reqister...

Unregister

PR e

j

¥ Show all components

Current HEMW tools database location:

ID:\Hew3 Madify... |

Figure 5.20: Tool Administration Dialog

6. You should enter export directory for custom project generator and click “Export” button. HEW creates
some files. When another HEW usesits project, it needs al files under your specified directory.

2l
Directony to export bo [must be emply or not exist): Export

[r:%Hew 3NE sport Browsze... I
Cancel |

Figure5.21: Export Custom Project Generator Dialog
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Thiswill export the required files along with a“ Setup.exe” file which can be then be executed on another HEW.
Thiswill ask the location of the new users HEW and when Install is clicked the project generator will be added
to their HEW system.

-;'-'.- Install custom generator

What iz the lozation of the HEW executable?
ChHewWHEW?Z exe

Figure5.22; Install custom generator Dialog

Once completed the project type will appear in the new workspace dialog.

Note:

A custom project generator can only be used in a HEW which is the same or greater version. If you attempt to
use the project generator in an old HEW an error message will be reported.

If your project generator contains a different toolchain to the destination HEW then this will be upgraded when
the project isfirst created.
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6.1

6.  Customizing the Environment

Customizing the Toolbar

The High-performance Embedded Workshop provides 2 standard toolbars as detailed in chapter 1, “Overview”.

In addition to these, you may also construct your own toolbarsviathe “ Customize” diaog (figure 6.1).

Cuskornize ﬂ ﬂ

Toalbars |Eommands| Menu | F'Iacehnldersl Debuggerl Log I Help I

¥ Show Toalips Mew...

Beset |

Taalbar name:

Editor

ak. I Canhicel

Figure 6.1: Customize Dialog Toolbars Tab

2 To create anew toolbar:

1

Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed.

2. Click the“New...” button. The dialog shown in figure 6.2 will be displayed.
3.
4. Click “OK" to create the new toolbar.

Enter the name of the new toolbar into the “Toolbar name” field.

Mew Toolbar EHE3

Taolbar narne:
IM T oolbad
Cahicel |

Figure 6.2: New Toolbar Dialog
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When anew toolbar is created it will appear undocked (i.e. “floating”) and empty.

2 To add buttonsto atoolbar:
1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed. Select the “ Commands’
tab (see figure 6.3).
2. Browse the available buttons by selecting the button categories from the “ Categories’ list. Select a button
from the “Buttons’ areato display information on its operation.
3. Click and drag a button from the dialog onto the toolbar.

2%

Toobars  Commands |Menu | F'Iacehnldersl Debuggerl Log I Help I

Cateqaries: — Buttons

|Standald Dﬁnﬁ|§|cﬁng
Debug 0T @

Search

Debug Run
Bookmarks
Templates
Differance
Wergion Control
Map

Select a category, then click a button ta see itz description. Drag the buttan
to arw toolbar

r— Dezcription

ak. I Canhicel

Figure 6.3: Customize Dialog Commands Tab
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To remove buttons from atoolbar:

1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed. Select the “ Commands’

tab (see figure 6.3).
2. Click and drag a button from the toolbar onto the “Buttons’ area.
To remove a user defined toolbar:
1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed.

2. Select the user-defined toolbar from the “ Toolbars” list, and the “Reset” button in figure 6.1 changes to

the “Delete” button. Then click the “Delete” button.

To reset a standard toolbar back to itsoriginal state:

1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed.

2. Select the standard toolbar from the “Toolbars” list and then click the “Reset” button.

To show or hide toolbar tooltips:

1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed.

2. Set the“Show Tooltips” check box as desired.

To modify the toolbar name of a toolbar created by a user:

1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed.

2. Inthe“Toolbars’ list, select atoolbar, which has been created by a user and whose name you want to
modify.

3. Modify the name of the toolbar in the “ Toolbar name” filed.
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6.2

Customizing the Tools Menu

The“Tools’ menu can be customized to include your own menu options.

2 To add anew menu option:

1

Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed. Select the “Menu” tab
(seefigure 6.4). The first thing for you to decide is whether you are adding a global application wide
tool (“Application wide tools.”), which will be available to all of your workspaces. Or whether you wish
to add a workspace wide tool (“Workspace wide tool:”), which isonly valid for the current workspace.
Once you have made the choice choose the relevant section of the dialog.

|-

7| x|

Toolbars | Commands  Menu |F'Iacehnlders| Debuggerl Log I Help I

Cuskornize

Application wide tools:

Hame | Yerzion |

Fdmdify..

Eemowve

I

Wwork space wide toolz:

MHame | W ersion | Add...
Hitachi M aprigw 1.0
Hitachi H Series Librarian Interface 1.1 badify...

Hitachi Call ‘w alker 1.1

Remove

i

ak. I Canhicel |

N o ok~ w
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Figure 6.4: Customize Dialog Menu Tab

Click the“Add..."” button (the dialog shown in figure 6.5 will be invoked). If you would like to add an
existing system tool to the menu then select the “ Select from existing system tools” radio button, choose
the tool from the drop-down list and then click “OK™.

Enter the name of the toal into the “Name” field.

Enter the command, excluding arguments, into the “Command” field.

Enter any arguments that you would like to pass to the command into the “ Arguments” field.
Enter aninitial directory in which you would like the toal to run, into the “Initial directory” field.
Click “OK” to add the menu option to the “Tools’ menu.
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Add Tool E E2

&' Define new user tool QK. |

— T ool details:

Cancel
Mame :
IEr:pInrer
Command ;
|$[WINDIF|]\E:4|:IDrer.e:<e [ 3 | Browse. . |
Arguments
| i3
Initial directony ;
|$[TEMF'DIF|] }l Browse... |

™ Select from existing system tools:

IHitachi M apwiew [wersion 1.0] j

Figure 6.5: Add Tool Dialog

New menu options are added to the bottom of thelist (i.e. bottom of the tools menu). The order of menu options
inthe“Tools” menu can aso be modified.

2 To modify amenu option:
1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed. Select the “Menu” tab
(seefigure 6.4).

2. Select the menu option that you would like to modify and then click the “Modify...” button.
3. Make the desired changes on the “Modify Tool” dialog (figure 6.6) and then click “OK”.

ModifyT ool

Hame :

Cancel |

Carrand :

|$MINDIF|]\E:<p|0rer.e:<e [ 3 | Browse... |
Arguments

| » |

Initial directony ;

[$(TEMPDIR] | Bowse. |

Figure 6.6: Modify Tool Dialog

2 To remove amenu option:

1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed. Select the “Menu” tab
(seefigure 6.4).

2. Select the menu option that you would like to remove and then click the “Remove” button.
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6.3 Configuring the Help System

The High-performance Embedded Workshop provides context sensitive help within the editor window. In other
words, if you select some text in the editor window and then press F1, the High-performance Embedded
Workshop will attempt to locate help on that selected item. The help files, which will be searched, are listed in
the “Help” tab of the “Customize” dialog.

2 Toaddanew help file:
1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed. Select the “Help” tab
(seefigure 6.7).

Cuskornize ﬂ ﬂ

Toolbarsl Eommandsl Menu | Placeholders Debuggerl Log Help |

Help files:
Drescription | File Hame | Add.

C/C++ Standard Library Help  d:%hew3\toolshreresa. .
Bemove |

Diefault help file;
C/C++ Standard Library Help =

ak. I Canhicel |

Figure 6.7: Customize Dialog Help Tab

2. Click the“Add...” button. The“Add Help File” diaog will be displayed (figure 6.8).

3. Enter adescription of the help fileinto the “Title” field.

4. Enter the full path of the help file into the “ Path” field (or browse to it graphically by clicking on the
“Browse..."” button).

5. Click “OK" to define the new helpfile.

Add Help File [ 7] x|

Title:

= Ok

IF'rogramming inAMSIC 4'
Cancel |

Path:

Ic:'\fileskhelp'\ansi.hlp Browsze. I

Figure 6.8: Add Help File Dialog
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To make ahelp file the default choice, select it from the “ Default help file” drop-down list or set it to “(None)” if
you would like to be prompted for a help file when F1 is pressed.

6.4 Specifying Wor kspace Options

The High-performance Embedded Workshop allows you to control several aspects of a workspace viathe
“Options’ dialog (figure 6.9). To invoke it select [T ools->Options...], and select the “Workspace” tab.

21

Ewild I Editor “orkspace |I:anilmatinn| Networkl

[ Open last workspace at start-ug

¥ Bestore files on opening workspace

[ Display workspace information dialog on opening workspace
[ Save workspace before executing any tools

[ Prompt before saving workspace

¥ Prampt before saving session

¥ Save Auto-Recovery info every |1D ﬁ mirutes

Default directary for new workspaces:

IDZ'\HBW3 Browsze. |

QK. I Cancel

Figure 6.9: Options Dialog Workspace Tab

The following sections explain the options available on this tab.
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6.4.1 Open last wor kspace at start-up

Set this check box if you would like the High-performance Embedded Workshop to automatically open the last
workspace you opened when it is launched.

6.4.2 Restor e the files on opening wor kspace

When you close a workspace, the HEW stores, which files were open. When you open a workspace, the HEW
can restore (i.e. open) the same files so that you can continue your session in exactly the same state as when you
left it. If you would like the files associated with a workspace to be opened when you open a workspace then set
this check box.

6.4.3 Display wor kspace information dialog on opening wor kspace

When many workspaces are being used, it is sometimes difficult to remember exactly what was contained within
each workspace. To help resolve this, the High-performance Embedded Workshop allows you to enter atextual
description of each workspace.

2 To enter aworkspace description:
1. Select the workspace icon from the “Projects’ tab of the " Workspace” window.

2. Click the right mouse button to invoke the pop-up menu and then select the “ Properties’ option. The
dialog shown in figure 6.10 will be displayed.

3. Enter the description into the “Information” field.

4. Check the “ Show workspace information on workspace open” check box if you want a workspace
properties dialog to be launched on opening a workspace. This check box has the same role asthe
“Display workspace information dialog on opening workspace” on the “Workspace” tab of the “Options’
dialog.

5. Click “OK" to save the description on the “ Information” dialog. Click the “Cancel” button not to save the
description.
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Workspace Properties EHE

Hame: IDBI‘ﬂD i §
Location: C:hHew2hDemohDemo.hws
- . Cancel |

Lazt modified: 23:06:54, Friday, June 20, 2003
CFU Farnily: SuperH RISC engine
Tool chain; Hitachi SuperH Standard

Information:;

Mo workspace information available ;I

¥ Show warkspace information on workspace open

Figure 6.10: Workspace Properties Dialog

When aworkspace is opened, the High-performance Embedded Workshop can display thisinformation so that it
is possible to determine whether the workspace is the desired workspace. To display thisinformation on opening
aworkspace, set the “ Display workspace information dialog on opening workspace” check box.

6.4.4 Save wor kspace befor e executing any tools

To force the High-performance Embedded Workshop into saving the current workspace before executing any
build phases (i.e. build, build all or build file operations) or version control commands set the “ Save workspace
before executing any phases’ check box.

6.4.5 Prompt befor e saving wor kspace

In addition to the above check box, set thisto prompt before saving.

6.4.6 Prompt before saving session

Checking this option will force the High-performance Embedded Workshop into displaying a prompt before the
session is saved to disk.

121
RENESAS




6.4.7 Save auto-recovery info

When you click this option, every ten minutes (as default) HEW saves workspace, project and session
temporality. Any changesyou have made will be saved to temporary files.

If you open your workspace and the following dialog is displayed it means that the last time the workspace was
used problems were encountered. To recover the files check the checkbox aongside the filenames you wish to
recover and click OK. Clicking cancel will discard the auto-recovery files and load from the original files.

HE" failed to shutdown carrectly the [ast time you used this
workzpace, Would pou like to recover the following files, rather
than uze the saved versions?

Filename | Directony

demanstiationhwe o hhew3hdemonstration
demanstration bwp o hewhdernonstrationsdernonstrat
defaultzesgionhsl  c\hew3hdemonstationsdemonstrati
gimzessionzh-2.hsf  chvhew3hdemonstrationdemaonstrati

Cancel |

Figure 6.11: HEW Workspace Auto-Recovery Dialog

6.4.8 Default directory for new wor kspaces

When anew workspace is created the High-performance Embedded Workshop invokes the “New Workspace”
dialog. One of the fields on this diaog is the directory in which the new workspace will be created. By defaullt,
thisisthe HEW installation directory. However, if you would like to set this default directory to another location
(e.g. “C:\Workspaces') then enter the desired directory into the field or browse to it graphically viathe

“Browse..."” button.
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6.5 Using an External Editor

The High-performance Embedded Workshop allows you to use an external editor. Once an external editor has
been specified, it will be launched when the following actions are performed:

« Doubleclicking on afilein the “Projects’ tab of the “Workspace” window.

» Double clicking on an entry in the “Navigation” tab of the “Workspace” window.
» Double clicking on an error/warning in the “Build” tab of the “Output” window.

» Doubleclicking on an entry inthe “Find in Files’ tab of the “ Qutput” window.

» Selecting the [Open <file>] option from the “Workspace” windows pop-up menu.
e Clicking the “Launch Editor” toolbar button.

2 To secify an external editor:
1. Select [Tools->Options...]. The “Options’ dialog will be displayed. Select the “Editor” tab (figure 6.12).

Build  Editor |Workspace| Eonfirmatinnl Networkl

— Spacing;
i

¥ Enable auta indentation

Tab size: I 4

— General:
¥ Save files before executing any tools ¥ Show files in noteboak:
™ Prompt before saving files ¥ Enable syntax colaring
¥ Enable Smart-edit for C++ files ¥ Enable tooltip watch
r— Extemnal editor:

[ Use gxtemal editorn:

| fdmdify,.. |

ak. I Catizel

Figure 6.12; Options Dialog Editor Tab
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2. Check the “Use external editor” check box.
The “External Editor” dialog will be displayed (figure 6.13).

External Editor E E2

LCormrmand:
IE:\WINDDWS\NDtepad.EHe Browsze. | ok |

Arguments to open file; Cancel |
[$FOLLFILE) b

Arguments to open file at ine:

|$[FULLFILE] M

Figure 6.13: External Editor Dialog

3. Enter the path of the executable (without any arguments) into the “Command” field.
4. Enter the arguments required to open afileinto the “ Arguments to open file” field. Use the $(FULLFILE)
placeholder to represent the path of the file to be opened.

5. Enter the arguments required to open afile at a specific line into the “ Arguments to open file at line” field.
Use the $(FULLFILE) placeholder to represent the path of the file to be opened and the $(LINE)
placeholder to represent the line number at which the cursor should be initially positioned.

6. Click “OK" to define the editor.
Note:  When using an externd editor be aware of the following issues:

» Each time you invoke the external editor, in whichever way, a separate instance of the editor will be launched.
* You must save your own files before you perform abuild file, build or build al operation.
» If debugging the external editor will not be used.

6.6 Customizing File Save

The High-performance Embedded Workshop allows you to customize file save on the “Editor” tab of the
“Options’ dialog (figure 6.12). To open the tab, select [Tools->Options...] and click the “ Editor” tab.

The following sections explain the options related to file save.

6.6.1 Save files befor e executing any tools

To force the High-performance Embedded Workshop into saving edited files before executing any build phases
(i.e. build, build al or build file operations) or version control commands, set the “ Save files before executing
any tools’ check box.

6.6.2 Prompt before saving files

In addition to the above check box, set thisto prompt before saving.
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6.7 Using Custom Placeholders

Throughout the High-performance Embedded Workshop the user can use a number of pre-defined placeholders
for directory definitions. For example the user can use the “$(PROJDIR)” variable to signify the current HEW
project directory. This makesit much easier to relocate projects and keep dl of the paths correct.

The High-performance Embedded Workshop also has the ability to define custom placeholders. This meansyou
can enter your own custom placeholder definition and decide upon its directory value. Once defined this
placeholder becomes avail able throughout the rest of the HEW system.

The placeholders can be defined on an application wide level so the placeholders are available to all workspaces
and projects that use the HEW. The other method of defining the placeholdersis using the workspace wide
custom placeholders this means the placeholders can only be used in the current workspace. Thislistisonly
available when you have a workspace open.

Cuskornize

|-+
[x

Toolbarsl Eommandsl Menu  Flaceholders |Debugger| Log I Help I

Application wide custom placeholders:

Placeholder | Diirectomy |

Fdmdify..

Eemowve

I

Wwork space wide cusztom placeholders:;
Placehalder | Directary | Add...

Modif..

i

Remove

ak. I Canhicel |

Figure 6.14: Customize Dialog Placeholder Tab
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2 Toadd acustom placeholder:

1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed. Select the
“Placeholders’ tab (figure 6.14).

2. Choose whether you need to use an “ Application wide custom placeholder” or “Workspace wide custom
placeholder”. Click “Add” on the adjacent button to the list you require.

3. Thedidog, add “New Custom Placeholder” dialog is displayed. (figure 6.15)

4. Inthefields provided choose a suitable name for the placeholder and a description of what the
placeholder means.

5. Then choose a directory, which relates to this placeholder. It is possible to use placeholders that are
already defined in this field such as $(PROJDIR).

Mew Custom Placeholder [ %]
Placehalder:
I Cancel |
Drescription:
Diirectory:

I Browse... |

Figure 6.15: New Custom Placeholder Dialog

126
RENESAS




6.8 Using the wor kspace and project log facilities

The HEW 3.0 has workspace and project logging facilities integrated into the application. These facilities can be
switched on via the log tab on the Tools customize dialog. Thisoption is especially useful when the network
databaseisin operation. Thisisbecause user names and changes are logged to thisfile. Thisdialogisshownin
figure 6.16.

When the workspace log is clicked any workspace changes will be logged to afile with the same name as the
workspace with a“.log” extension. Thisfilewill be located in the same directory as the workspace file.

When the generate log for projectslog is clicked any projectsin the current workspace that have changes made
to them will be logged to afile with the same name as the project with a“.log” extension. Thisfile will be
located in the same directory as the project file.

Thelog file is updated when the workspace is saved.

Cuskomize il il

Tnnlbalsl Eommandsl Menu | Flaceholders | Debugger  Log |He|p I

Ll Browse,. |

[ Generate workspace log

[ Generate log for projects

QK. I Cancel

Figure 6.16: Tools customize log tab

6.9 Using the virtual desktop

HEW has implemented the concept of the virtual desktop. This alows window configurations to be defined that
can be switched with the click of abutton. When a particular button is clicked the windows are hidden or
displayed depending on the current settings of that window configuration.

It is possible to have a maximum of 4 desktop configurationsin use. When the session is saved the window
positions for each configuration are saved to the session file. Y ou can then switch smply between each
configuration to gain access to the other windows. The toolbars and windows are dependent on the virtual
desktop configuration. Source files are independent of the virtual desktop system and will remain in view.
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= To rename your configuration to a more meaningful name:

Click the [Window->Virtual Desktop] menu item. Select is cascaded menu.

Select the Desktop Manager diaog.

Select the window configuration you wish to change the name for.

Click the rename button. Enter the new meaningful name in the edit field and click OK.
Click OK to keep the changes and revert to the HEW main window.

o~ w DN PE

= To switch desktop configurations:
There are anumber of waysto switch desktop configuration. The first and easiest method is using the virtual
desktop buttons located on the status bar. These are shown in figure 6.17.

0x0000zZ012 for( i=0; i<10; i++ )1
0x0000Z01a J = rand():
0x0000zZ0z22 ifij < 0)4

~ANNNZ N2 A G o= -4 hd
4 3
< demo. I

b Wersion Cantral ,‘
E% |Bwild deskkop [Read-write [zo188 2

Figure 6.17: Desktop button

In this example the selected desktop is number 1. This has been given the name "Build" by the user. Its
description is seen in the edit box to the right on the buttons. Clicking a different desktop selects that button and
changes the description control. Once clicked HEW then loads the windows in the new configurations style.

Another method of changing the desktop configuration is as follows:

1. Click the[Window->Virtual Desktop] menuitem. Select is cascaded menu.
2. Then select the desktop configuration you wish to view on thismenu. The selected item isticked.
3. Select the menu item and the setup is altered automatically.

Note:

If the configuration has never been used then HEW will copy the current window configuration to the new
configuration. Y ou can then modify this setup. When you save the session it will store the positions of your
windows for each window configuration.
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7. Version Control

The High-performance Embedded Workshop provides facilities for connecting to a version control tool. Some of
the reasons why version control tools are used with a project are:

* To maintain theintegrity of aproject.
» To store each stage of aproject.
* Toenabledifferent usersto co-develop a project by controlling revisionsto its source files.

Figure 7.1l illustrates atypica project where aversion control system isin use. This shows three users who al
use the same-shared network drive to exchange source code. The version control system provides access and
updates to the source files.

NETWORK

LOCAL

-

8 |
>

[
PR

Figure7.1: Version Control
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7.1 Selecting a Version Control System

Initialy, the version control sub-menu will appear as shown in figure 7.2. At thistime only the [Version

Control -> Select...] option is available because a version control system is not yet active for the current
workspace.

Tools ‘Window  Help

Administrakion. .. j c
Change Toolchain Yersion. .. ﬂ d
on Cantrol Select...
) L [ [ =0
Customize. ..
optians. .. [ &dd Filefs)

[ﬁ. Eemove Filels)

Earmat Yiews... &
oy Gef Fileds]

)1 Launch External Debugger, .. # Eheck Gut Fels)
% Launch Slave HEW. .. & CheckInFiels)
@ Status of File(s)

Show Differences. ..

Hitachi Maprvigw
Hitachi H Series Librarian Interface
Hitachi Call Whalker

Figure 7.2: Version Control Sub-Menu

2 To select aversion control system:

1. Select [Version Control->Select...]. The diaog shown in figure 7.3 will be displayed. Thisdialog lists
all of the supported version control systems.

2. Select the desired version control system from the “Version control systems’ list and click the “ Select”
button. The “Current version control system” is changed to reflect the new selection.
3. Click the“OK” button to confirm the selection.
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Select Yersion Control System

Werzion control systems; ak
Microzoft Visual SourceSafe 5.0/6.0 Cancel
[Mone]

Select

i,

Current verzion control system:

[Mone)

Figure 7.3: Select Version Control System Dialog

Note:  Only those version control systems, which have been installed with the HEW, will appear in the “ Select
Version Control System” dialog (figure 7.3).

Once aversion control tool is selected you will notice that the [Version Control->Configure...] option has now
become available.

The next chapter discusses the usage of the custom version control system.
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8.  Using the Custom Version Control System

The custom version control system is a configurable addition to the High-performance Embedded Workshop,
which allows you to connect to aversion control system aready installed on your machine. To clarify further,
the High-performance Embedded Workshop does not provide a version control tool itself, only a means by
which you can integrate the version control system, which you use into your workspaces and projects.

8.1 Defining Version Control Menu Options

The custom version control system allows you to invoke a version control command either by selecting an
option from the [Tools-> Version Control] sub-menu or by clicking aversion control toolbar button. When
either of these actions are performed, the associated commands are executed and the output is displayed in the
“Version Control” tab of the “Output” window.

2 To execute aversion control menu option or toolbar button:

1. Select whichever items you would like to apply the version control command to from the “Workspace”
window. This may include a workspace, project(s), folder(s) and file(s). When the command is selected,
all of the fileswill be extracted from the selected items and passed, in turn, to the version control
command. For example, if you select the workspace icon then all of thefilesin all of the projects will be
passed, in turn, to the version control command. Thiswill include any system files. For exampleif you
select the project item then

2. Select the required menu option from the [Tools->Version Control] sub-menu or click the desired
version control toolbar button.

The custom version control support allows you the most flexibility in specifying how aversion control system is
to be used. To configureit, select [Version Control->Configure...]. The“Version Control Setup” dialog will be
displayed (figure 8.1).
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¥ersion Control Setup 2=

Commands |F'n:uiects| General |

Syztem menu options and toolbar buttons:

fedd File(s)

I adify..

Check In File(z)
Check, Qut File(z]
Get File(s]
Femowe Filelz)
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1
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Ok, I Cancel |

Erpoit... | Impot. .. |
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Figure8.1: Version Control Setup Dialog Commands Tab
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The “Commands’ tab contains two lists of menu options. The first list, “ System menu options and toolbar
buttons’, represents those menu options which always appear on the version control sub-menu. These menu
options also have an associated toolbar button on the version control toolbar. The second list, “User menu
options’, represents those additional user defined options which are added to the bottom of the version control
sub-menu. Figure 8.2 shows the structure of the version control sub-menu.

Options... |
Select..
Configure..
[ty 2dd Filets)
@: Remove Filals) Systern
& Get Filals) Drefined
& Check Out Filets) Opticn
B Check In Filels)
@ Status of Filels) \_\"{
. . User
History of Filalzs) Diefined
Undo Check out of Filels) Optien

Figure8.2: Version Control Sub-Menu

811 System menu options and toolbar buttons

In order to invoke commands from the toolbar or the system defined options of the [Tools->Version Control]
sub-menu, you must first define the associated commands that should be executed when they are activated. The
names of the options and their intended action are listed in table 8.1.

Table8.1: System Menu Option

Option Description

Add File(s) Add selected file(s) to version control system.

Remove File(s) Remove selected file(s) from version control system.

Get File(s) Get a read only local copy of the selected file(s) from version control system.

Check In File(s) Put back, i.e. update, the selected file(s) in version control system with the
local copy.

Check Out File(s)  Get a writable local copy of the selected file(s) from version control system.
Status of File(s) View the status of the selected file(s).

135
RENESAS




2 To modify asystem menu/ toolbar option:

1
2.

Select [Version Control->Configure...]. The didog shown in figure 8.1 will be displayed.

Select the option to be modified from the “ System menu options and toolbar buttons” list and then click
the “Madify..."” button. The dialog shown in figure 8.3 will be displayed. This figure shows adialog
when “Add File(s)” has been selected for example.

Commands are added viathe “Add...” button. See the section, “ Defining Version Control Commands’,
later in this chapter for further information.

Close the “ Define Command for “<command>"" dialog by clicking “OK”.
Close the “Version Control Setup” dialog by clicking “OK”.

Define Commands for "Add File[=]"

Commands

Cancel
Add
T adifin.
HEmove

MEvE R

HARA

i o A mT
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Figure 8.3: Modify System Menu Option (Example)
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8.12 User menu options

Y ou can create as many user defined menu options asyou like, name them how you want and define their order
in the menu. User defined menu options do not appear on the version control toolbar.

2 To create anew version control menu option:
1. Select [Version Control->Configure...]. The dialog shown in figure 8.1 will be displayed.
2. Click the“Add..” button. The dialog shown in figure 8.4 will be displayed.
3. Enter the name of the menu option into the “Option” field.
4

. Commands are added to the menu option viathe “Add...” button. See the section, “ Defining Version
Control Commands”, later in this chapter for further information.

Close the “Add Menu Option” dialog by clicking “OK”.
6. Closethe“Version Control Setup” dialog by clicking “OK”.

o

Add Menu Dption EHE
Optian :
= ak.
Cancel |
LCommands:

Add..
T adifin.
HEmove

MEvE R

L

i o A mT

Figure 8.4: Add Menu Option Dialog
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2 Toremove an existing version control menu option:

1
2.

3.

Select [Version Control->Configure...]. The didog shown in figure 8.1 will be displayed.

Select the menu option to be removed from the “User menu options” list and then click the “ Remove’
button.

Close the “Version Control Setup” dialog by clicking “OK”.

2 To modify an existing version control menu option:

1
2.

3.
4.

Select [Version Control->Configure...]. The didog shown in figure 8.1 will be displayed.

Select the menu option to be modified from the “User menu options” list and then click the “Modify...”
button beside the list. The dialog shown in figure 8.4 will be displayed. (Thetitle of the dialog is“Modify
Menu Option™.)

Modify the commands as necessary and then click “OK”.

Close the “Version Control Setup” dialog by clicking “OK”.

2 To change the ordering of version control menu options:

1
2.

138

Select [Version Control->Configure...]. The didlog shown in figure 8.1 will be displayed.
Select the menu option to be moved and then click the “Move up” and “Move down” buttons as
necessary.

Close the “Version Control Setup” dialog by clicking “OK”.
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8.2 Defining Version Control Commands

Commands are defined when the “Add...” or “Modify...” buttons are clicked on the dialogs shown in figure 8.3
and figure 8.4. In either case, the dialog shown in figure 8.5 isinvoked.

Add Command EHE

— Cormmatd ;

Wersion control executable
IVZ'\VSS'\W|N32\SS.EHE Browse... |
— Cancel |

Argunents :
IHistnr_l,l $VCDIR)/$FILENAME) Y $USERMNAME). $(FASS5 ﬂ

Initial directary :

[$iFILEDIF) ﬂ H— |

— Executable return code

* Retun code of executable is not meaningful

" Command has failed if the return codeis [ 1o Equal To j ID

Figure 8.5: Add/Modify Command Dialog

2 To define acommand:
1. Enter the full path of the command into the “Version control executable” field or browse to it graphically
by clicking the “Browse...” button.
2. Enter the arguments for the command into the “ Arguments’ field.
3. Enter theinitial directory in which you would like to run the executable from into the “Initial directory”
field or browse to it graphically by clicking the “Browse...” button. In most cases this should be set to the
“$(FILEDIR)" placeholder, i.e. execute the command from the same directory asthefile.

4. Set the “Executable return code” options as described in the following section.
5. Click “OK” to define the new command.

821 Executablereturn code

If the return code of the command(s) can be used to indicate a failure then you should select the “Command has
failed if the return codeis’ option and set the two fields to the right as required.

If the “Command has failed if the return codeis’ option is selected then the HEW will check the return code of
each command to determine whether a failure occurred. If so, no further commands will be executed and any
other processes which would follow the commands (e.g. build) will not be executed.

If the “Return code of tool is not meaningful” option is selected then the HEW will not check the return code of
each. Consequently, all commandswill execute regardless.
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8.3 Specifying Arguments

It is obvious that arguments must be specified correctly, otherwise the version control tool executed will not
function as intended. However, it is aso important, when using custom version control support, to specify the
argumentsin aflexible way as a single version control command can be applied to more than onefile. To
facilitate this, the “ Arguments’ field has a placeholder button (refer to appendix C, “Placeholders’, for anin
depth discussion of placeholders) which, when clicked on, invokes a pop-up menu of available placeholders
(figure 8.6). An explanation of each placeholder and how their values are derived can be found in table 8.2,
Arguments Field Placeholders.

User login name

User login passward
“ersion contral directary
Cramment
File path + name
Filename
File lzaf
File extension
File directory
Configuration directary
Project directary
Workspace directary
Temp directary
Cammand directary
Windows directory
Windows system directory
Workspace name

Project nams

Configuration name

Figure 8.6: Arguments Field Placeholder Pop-up Menu
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Table 8.2: Arguments Field Placeholders

Placeholder Value and How its Determined

User login name Current user login (“General” tab)

User login password Current user password (“General” tab)

Version control directory “Virtual” version control mapping (“Projects” tab)
Comment Comment specified before command execution
File path + name Full path and name of file involved in operation
Filename Filename (including extension) of file involved
File leaf Filename (excluding extension) of file involved
File extension Extension of file involved in operation

File directory Directory of file involved in operation
Configuration directory Current configuration directory

Project directory Current project directory

Workspace directory Current workspace directory

Temp directory Temporary directory

Command directory Version control executable directory

Windows directory Directory where Windows® is installed
Windows system directory Directory where Windows® system files exist
Workspace name Current workspace name

Project name Current project name

Configuration name Current configuration name

8.3.1 Specifying File L ocations

When referring to afile’ s location, be sure to use a placeholder, otherwise the command will only relate to a
hardwired file. For example, let’simagine that a version control executable has been selected which usesa—-GET
command to obtain aread only copy of afile. The “Arguments’ field could be specified as:

-GET “c:\vc\files\project\main.c”

However, when executed, this command can only ever get the file MAIN.C. To resolve this problem, HEW uses
a system of placeholders and directory mappings. The latter tell the HEW which “working” directories (i.e.
where source files are being worked on) map to which “controlled” directories (i.e. where the source files are
stored in the version control system). Mappings between these two directory systems can be specified via the
“Projects’ tab of the ”Version Control Setup” dialog (figure 8.7).
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¥ersion Control Setup 2=

Commands  Frojects |Genera||

Shove details Far project : I Frojecti j

— Details ;

Yergion control directorny mappings ©

Source Directory | YYerzion Control Directory d

c:mark happlicationhprojectl = \wohawhapphproject]

o mark happlicationhsrc whwchawhapphac b iy,
o hwork hahared whwchawhzhared —

Hemave

Ll

K I— Ll

Enwironment ;

Add...

fel iy,

d

Femove

ok I Cancel Erpoit... Impot. ..

Figure 8.7: Version Control Setup Dialog Projects Tab

2 To define anew mapping:

1. Select [Version Control->Configure...]. The diaog shown in figure 8.1 will be displayed. Select the
“Projects’ tab, and the dialog shown in figure 8.7 will be displayed.

2. Click the“Add...” button that is next to the “Version control directory mappings’ list. The dialog shown
in figure 8.8 will be displayed.

3. Enter the source (i.e. “working”) directory into the “ Source directory” field or browse to it graphically by
clicking the “Browse...” button.

4. Enter theversion control directory (i.e. “controlled”) directory into the “Version control directory”.

Yerzion Control Directory Mapping EHE
Source directary : Ok

Ic:'\work'\shared ﬂ Browise... I Cancel |

Yerzion control directon ©

I:-:Z wechawhshared

Figure 8.8: Version Control Directory Mapping Dialog
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2 To modify an existing mapping:
1. Select [Version Control->Configure...]. The diaog shown in figure 8.1 will be displayed. Select the
“Projects’ tab, the dialog shown in figure 8.7 will be displayed.
2. Select the mapping to be modified from the “Version control directory mappings’ list and then click the
“Modify...” button. The dialog shown in figure 8.8 will be displayed.
3. Make the necessary changes to the two directories and then click “OK” to confirm the edits.
2 To remove an existing mapping:
1. Select [Version Control->Configure...]. The diaog shown in figure 8.1 will be displayed. Select the
“Projects’ tab, the dialog shown in figure 8.7 will be displayed.
2. Select the mapping to be removed from the “Version control directory mappings’ list and then click the
“Remove” button.

Once the mappings have been defined you can use the “Version control directory” placeholder, $(VCDIR), to
represent the directory in which the project file is stored. Consider the scenario shown in figure 8.9. Here are
three directories, which are mapped from a shared version control drive (X:\) to aloca drive where the
development is being done (C:\).

LOCAL - C:\ Mapped To NETWORK - X:\

- =

C:\work\application\project1 X:\we\swapp\project1

-t

L

C:\work\application\src

E<

C:\work\shared

Xi\ve\swishared

Figure 8.9: Example Mappings

Now let’ simagine that a version control executable has been selected which uses a—GET command to obtain a
read only copy of afile. In order to get dl of the filesin a project we need to use the following command:

- GET “$(VCDI R)\ $( FI LENANE)”

When the HEW executes the command for a given project file, it will replace $(VCDIR) for the equivalent
version control directory in the file mapping.

For example, suppose FILEL.C islocated at:
c:\work\application\projectl\filel.c
If the get command is applied to FILEL.C then:

(2) x:\ve\sw\app\projectl is substituted for $(VCDIR) as thisis the version control directory mapping for
c:\work\application\projectl.

(2) FILEL.C is substituted for $(FILENAME).
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Project File: C:\work\application\projectl \ filel.c

Arguments: $(VCDIR) \ $(FI LENAME)
(1) )
Command: X:\vc\swapp\projectl \ filel.c

Figure 8.10: Example of Substitution

8.3.2 Specifying Environment
Select the “Projects” tab of the “Version Control Setup” dialog to view the current settings (figure 8.7).

To add anew environment variable click the“Add...” button beside the “ Environment” lit (the diadlog shown in
Figure will beinvoked). Enter the variable nameinto the “Variable” field, the variable' s value into the “Vaue’
field and then click “OK” to add the new variable to the “ Environment” list.

Environment ¥ariable E E2

i.ralialgle :
Cancel |

Walue

| Placeholder
I » | PopUp MEnu

Figure 8.11: Environment Variable Dialog

To modify an environment variable, select the variable that you want to modify from the “ Environment” list and
then click the“Modify...” button beside it. Make the required changes to the “Variable” and “Vaue” fields and
then click “OK” to add the modified variable back to the list. To remove an environment variable, select the
variable that you want to remove from the “Environment” list and then click the “Remove” button beside it.
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8.3.3 Specifying Comments

If acommand contains the placeholder “ $(COMMENT)” then the HEW will request that you enter the comment
when the command is executed (viathe dialog as shown in figure 8.12).

Pleaze Enter Comment EHE

File: & \heswhdemnohdemat.shirk. o -
ak.
Cancel |
Camment :

™ Apply comment ta all files

Figure 8.12: Please Enter Comment Dialog

Y ou may specify acomment for each file or, if you would like to specify the same comment for al files, check
the “Apply comment to al files’ check box before clicking “OK”.
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8.34 Specifying a User Name and Passwor d

Most version control toolswill require you to pass a user name and password on the command linein order to
keep files secure and to keep a record of which files were changed by which users. The custom version control
support provides two placeholders “ User login name”, §(USERNAME), and “User login password”,
$(PASSWORD). When the command is executed, these placeholders will be replaced with the current settingsin
the “General” tab of the “Version Control Setup” dialog (figure 8.13).

¥ersion Control Setup 2=

Eommandsl Projects General |

— Execution :
¥ Prompt before executing command

[ Funin DOS Window ¥ Cloge DOS window on exit

[ Use forward slash '#* as version contral directary defimiter

— Usger details :
Lzer: JHARK

s

FPassword ;

— Configuration file:
Current verzion contral configuration file:

C:\Hew'Project1WProject] hyve

ok Cancel Erpoit... Impot. ..

Figure 8.13: Version Control Setup Dialog General Tab
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In order to give the $(USERNAME) and $(PASSWORD) fields a value you will first need to login. If you have
not logged in before a command is executed which uses either of these placeholders then you will be prompted
to do so before the command can be executed.

2 Tologin (i.e. specify auser name and password):
1. Clickthe“Login...” button. The dialog shown in figure 8.14 will be displayed.
Enter your user nameinto the “User name” field.
Enter your password into the “ Password” field.
Re-type your password again into the “ Confirm password by retyping it below” field.
Click “OK” to set the new user name and password. If there is any inconsistency between the two
versions of the password which you entered then you will be requested to type your password again.

ok w DN

Log in HE
User name : ok, I
JHARK
I Cancel |

Pazgword

LCanfirm pazsward by retyping it below :

Ixmmxx

Figure 8.14: Login Dialog

147
RENESAS




8.4 Controlling Execution

The “Genera” tab of the“Version Control Setup” dialog (figure 8.13) allows you to control the way in which
the version control tool is executed. It also shows the full path to the current version control configuration file.

84.1 Prompt before executing command

If this check box is set then, before any version control commands are executed, adialog is displayed (figure
8.15) which lists all of the filesinvolved in the operation. Files may be deselected by clearing the associated
check box. Clicking “OK” will apply the command to each of the selected files. Clicking “Cancel” will abort the
operation.

History EHE
Files

= -EIK
[w]demo. o

[=:Shewhdemohdemo]

[w] sbrk. o [=:Shewhdemohdemo] Cancel |
[w]wecttbl zre [ohhewhdemot.demo]

N Ll

Figure 8.15: Command Prompt Dialog

8.4.2 Run in DOS Window

By default, the output of the version control commandsis redirected to the “Version Control” tab of the “ Output”
window. If you would rather run each command in a separate DOS window then set this check box.

843 Useforward slash ‘/' asversion control directory delimiter

By default, when the HEW substitutes the placeholder $(V CDIR) it uses the backward slash character ‘\' to
divide directories. However, if the version control system you are using uses a forward slash character (e.g.
Visual SourceSafe) to divide directories then set the “ Use forward slash /” as version control directory
delimiter”.
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8.5 Importing and exporting a Set-up

Each workspace can have a different version control set-up. The HEW allows you to store the version control
settings independently so that you can import them into other workspaces. This greatly reduces the amount of
timeit takes to configure the same version control settings across several workspaces.

2 To export aversion control set-up:
1. Select [Version Control->Configure...]. The dialog shown in figure 8.1 will be displayed.

2. Click the “Export...” button. A standard file save dialog will be displayed. Browse to the directory in
which you would like to save the configuration.

3. Enter the name of the file and then click “OK”.

2 Toimport aversion control set-up:
1. Select [Version Control->Configure...]. The dialog shown in figure 8.1 will be displayed.

2. Click the“Import...” button. A standard file open dialog will be displayed. Browse to the * .HVC file
which you would like to import.

3. Sdect thefile and then click “OK”.
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9. Using Visual SourceSafe

The High-performance Embedded Workshop provides specific support for the Visua SourceSafe version control
system. At the time of writing, the HEW can only attach to versions 5.0 and 6.0 of Visual SourceSafe.

The Visua SourceSafe version control system associates a project in your workspace with aproject insde a
Visual SourceSafe database. It alows you to quickly invoke the standard commands either by selecting an option
from the [Tools->Version Control] sub-menu or by clicking aversion control toolbar button.

9.1 Attaching Visual SourceSafeto a Workspace

The following sections describe how you can associate Visua SourceSafe with your current workspace.

911 Selecting Visual Sour ceSafe
First, you need to select Visual SourceSafe as the version control system.

2 TouseVisua SourceSafe 5.0 or 6.0:

1. Select [Tools->Version Control->Select...]. The “Select Version Control System” dialog will be
displayed (figure 7.3) which lists all of the supported version control systems.

2. Select the“Visua SourceSafe 5.0/6.0" entry from the Version Control Systems list and click the “ Select”
button.

3. Click “OK" to confirm the selection. The SourceSafe Login dialog is displayed (figure 9.1).

4. Enter your Visual SourceSafe login into “Username” and password into “ Password”.

5. Enter into Database path the full path to the Visual SourceSafe database (i.e. SRCSAFE.INI) into which
you would like to add this project.

6. Click “OK". The“Create SourceSafe Project” dialog isinvoked (figure 9.2).

7. The“Project name” field displays the name of the project (i.e. folder) to be created in the database. If
necessary you can change this name to another.

8. Thetree underneath the “Project name” field shows the structure of the database specified in step 6.
Select the folder into which you would like to create the folder specified in the “ Project name” field.

9. Click “OK".

10. HEW will require you to repeat steps 7-9 for as many projects as are present in the current workspace.

SourceSafe Login EHE3

Usemame: I
Pazzword: I ﬂl

Database path: I Browse. . |

Figure 9.1: SourceSafe L ogin Dialog
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Create Source5afe Project 2 | x|

Project nare:
Iprniect

Cancel |
$/project

-

||

Figure 9.2: Create SourceSafe Project dialog

The HEW has now created the necessary projects within Visual SourceSafe and sets-up the version control
toolbar and menu for immediate access. However, although the Visual SourceSafe projects themselves have
been created, no files have been added to them.

912 Adding filesto Visual SourceSafe

The previous section has only established the mappings between the project directory on your hard disk (i.e. the
working directory) and the project directory in Visual SourceSafe (i.e. the controlled directory). Although the
project directory (and any subdirectories) on your hard disk may contain many source files whereas the directly
its mapped to in Visua SourceSafe will be initially empty.

Firstly, you must select Visual SourceSafe as the version control system.

2 Toadd afileor filesto Visual SourceSafe:

1. Select thefile(s), which you would like to add to Visua SourceSafe. Y ou may also select afile folder,
project folder, a workspace folder or combination thereof. When selecting the project or workspace
folder then the system files will be added to the selected file list. For example, selecting the project folder
will also add the project fileto thefilelist. If the project fileisthen checked out and the version is newer
than when it was last |oaded you will be asked whether you want to reload the project.

2. Click the Add Files toolbar button ( @:‘) or select the [Tools->Version Control->Add Files] menu

option.

When you add filesto Visual SourceSafe the local versionsin your working directory will become read only. To
check that the add files operation was carried out as you expected, or to quickly review the status of all of the
filesin aproject:

1. Select the project folder whose files you want to check.

2. Click the Status of Filestoolbar button ( @ ) or select the [Tools->Version Control->Status of Files]
menu option.

3. Thestatus of each file will be displayed in the “Version Control” tab of the “ Output” window. The
information shown includes whether the file is added to the project, if the file is checked out and, if it is
checked out, who did so.
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9.2 Visual SourceSafe commands
The following 8 operations are available:

* Add afileto version control

» Remove afile from version control

* Get aread only copy of afileor files

» Check out aread/write copy of afileor files (i.e. for editing)

» Check inapreviously checked out file or files (i.e. update Visual SourceSafe with the edits made)
» Undo aprevioudly check out operation on afile or files (i.e. cancel any edits made)*

* View the status of afile

* View the history of afile*

*These commands can only be accessed viathe [Tools->Version Control] sub-menu whereas all of the other
commands can be accessed from both the toolbar and menu.

921 Removing a File from Version Control

Although files appear in your HEW project (in the “Projects’ tab of the “Workspace” window, Visual
SourceSafeis not necessarily controlling them.

2 Toremoveafileor files from Visual SourceSafe:

1. Select thefile(s), which you would like to remove from Visua SourceSafe. Y ou may aso select afile
folder, project folder, aworkspace folder or combination thereof.

2. Click the Remove Filestoolbar button ( @. ) or select the [Tools->Version Control->Remove Files]
menu option.

9.2.2 Getting a Read Only Copy of a Filefrom Version Control

Visual SourceSafe protects your source files and ensures that only one user can have awritable copy of a
controlled file at any one time. However, it is possible for any user to obtain aread only copy of any file.

2 Toget aread only copy of afile or filesfrom Visua SourceSafe:
1. Select thefile(s), which you would like to get from Visual SourceSafe. You may also select afile folder,
project folder, aworkspace folder or combination thereof.

2. Click the Get Filestoolbar button ( % ) or select the [Tools->Version Control->Get Files] menu
option.
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923 Checking Out a Writable Copy of a File from Version Control

Visual SourceSafe protects your source files and ensures that only one user can have awritable copy of a
controlled file at any one time. The check out operation takes awritable copy of thefile from Visua SourceSafe
and placesit on your local drive. Thiscan only be done if another user does not already check out the file or files
in question.

2 To check out awritable copy of afileor files from Visual SourceSafe:
1. Select thefile(s), which you would like to check out from Visual SourceSafe. You may also select afile
folder, project folder, aworkspace folder or combination thereof.
2. Click the Check Out Filestoolbar button ( 5' ) or select the [Tools->Version Control->Check Out
Files] menu option.

3. When the operation is finished the file has ared tick next to itsname. This meansyou as the current
user of HEW has checked it out.

9.24 Checking In a Writable Copy of a Fileinto Version Control

Visual SourceSafe protects your source files and ensures that only one user can have awritable copy of a
controlled file at any one time. The check out operation takes awritable copy of thefile from Visua SourceSafe
and placesit on your local drive. Once afileis checked out it is edited and then checked back in so that the edits
can be made available to other users.

2 Tocheck in edits made to afile or filesin Visua SourceSafe:
1. Select thefile(s) upon which you would like to check back into Visual SourceSafe. You may also select a
file folder, project folder, a workspace folder or combination thereof.

2. Click the Check In Filestoolbar button ( g ) or select the [Tools->Version Control->Check 1n] menu
option.

9.25 Undoing a Check Out Operation

Visual SourceSafe protects your source files and ensures that only one user can have awritable copy of a
controlled file at any one time. The check out operation takes awritable copy of thefile from Visua SourceSafe
and placesit on your local drive. Once afileis checked out it is edited and then checked back in so that the edits
can be made available to other users. However, if the check out operation was carried out by mistake, or perhaps
isno longer required, then the operation can be undone.

2 Toundo acheck out of afileor files from Visual SourceSafe:

1. Select the file(s) upon which you would like to undo a previous check out operation. Y ou may also select
afile folder, project folder, a workspace folder or combination thereof.

2. Select the [Tools->Version Control->Undo Check Out] menu option.
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9.2.6 Viewing the Status of a File

Although files appear in your HEW project (in the Projects tab of the Workspace window), Visual SourceSafeis
not necessarily controlling them. Of those files, which are being controlled by Visual SourceSafe, some will be
checked in and others will be checked out (i.e. being edited by a user). The status command displays the current
status of afile or file(s).

2 Toview the status of afileor filesin Visua SourceSafe:
1. Select the file(s) whose status you would like to view. You may also select afile folder, project folder, a
workspace folder or combination thereof.
2. Click the Status of Filestoolbar button ( @. ) or select the [Tools->Version Control->Status of Files]
menu option.

3. If afilehasabluetick next to it auser different to you has checked it out.

9.2.7 Viewing the History of a File

Visual SourceSafe controlsthe edits to the filesin its projects and allows you to view the complete history of
these edits right back to the time that the file was first added to the project.

2 Toview the history of afileor filesin Visual SourceSafe:

1. Select thefile(s) whose history you would like to view. Y ou may aso select afile folder, project folder, a
workspace folder or combination thereof.

2. Select the [Tools->Version Control->Show History] menu option.
9.3 Visual SourceSafe Integration Options

Y ou can control the way in which the history and status commands are displayed by selecting [Tools->Version
Control->Configure...].

To display the results of a history command in a dialog box then check the “Display dialog box for history”
check box or clear it if you would rather display the output in the “Version Control” tab of the “ Output” window.
To display the results of a status command in adialog box then check the “Display dialog box for file status’
check box or clear it if you would rather display the output in the “Version Control” tab of the “ Output” window.
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10. Network Facilities

10.1  Overview

The High-performance Embedded Workshop is capable of sharing workspaces and projects across a network.
This alows usersto concurrently work on shared projects and see each other’s changes as they happen. This
system can be used in conjunction with version control. The major difference with using this system is that each
user can modify and update the workspace and project without making all of the other users reload their project
and potentially lose all their changes.

This system isimplemented by making one of the machines attached to the network the server machine. All
other client machines then use the service this machineis providing. So if one of the client machines adds a new
file, the server machineisnotified. The server then notifiesall other clients the action hastaken place. This
structure is shown below in figure 10.1.

Metworked workspace and project.

Metwork

Server

=11 Metworked_Data_Example
B3 Wetworked_Data_Example
1 Debug

- SimDebug 5H-2

Metwork access

All files are under the network
gervice's control. These include
the workspace, project, session
and source files.

1 1
| ‘ ‘ | | ‘ Cliert= do not access data directly
with the workspace and project
files on the netwark. The clients cannot
directly communicate with each other
either. Al communicstion is directed
through the zerver machine.

Figure 10. 1: Network database access structure

The network system allows users to be given accessrightsto files. This alows the project administrator to make
sure the only people who can modify the project and source files are allowed to do so. This might allow the
administrator to limit each user to only have write capabilities for their own area of the project, other areas
would be read only. This could limit any potential conflict or damage one user could do to other areas of the
project. These limitations can be set to anumber of different levels. Thisisoutlined later in this section.

Note: Certain operationsarelocked when other clientsare carrying them out. Thismeansthat if one
machineis currently changing the toolchain options all of the other machines can only seeread only
versions of this data.

Note:  The performance of HEW does suffer when using the network facilities. 1f workingin a small
team it might be more suitable to use the single user mode and version contral.
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1011

Enabling network access

2 To use network access:

1
2.
3.

10.1.2

Select [Tools->Options]. The HEW tools options dialog is displayed.
Select the network tab. Thisisdisplayed in figure 10.2.

Click the enable network access checkbox. This should add an administrator to the system without a
password. The administrator isthe only user that can add additional usersto the system and change user
access rights. The administrator has the highest level of access.

Before leaving the network dialog the administrator must set their password. It isnot possible to leave
thisdialog until thisis completed. Thisis described below.

Setting the administrator user’s password

2 To set the password:

1

© N o g~ wDN

158

Continue from the previous sections steps.

Click the password button. This should have been enabled when the network data access was enabled.
The password dialog isdisplayed. Thisisshownin figure 10.3.

The user nameisread only inthetopfield. In thiscaseit should be Admin.

Type the new password into both of the fields and click OK.

This should set the user and password on the [Tools->Options] network tab.

It isnow possible to leave the [Tools->Options] dialog.

When the dialog is closed you are asked if you want to save the workspace and then re-open it. Thisis
because the workspace must be re-opened in the shared access mode. |f the changes are not saved then
they will belost.

When the workspace is re-opened a dialog is displayed which asks you to log back into the system.
Once you havelogged in adidog is displayed which shows your current accessrights. For exampleif
you are the admin user the level will be administrator. When thisdialog is closed the HEW server
window is opened and the network facilities are enabled.
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options 21|
Build I Editor | Workspacel Confirmation  Metwork I
[~ Enable netwaork data access
Metwork database access: Login.. |
Uszer
Eazaward... |
Pagzsword;
fLecezzrights.. |
Select server. . |
ak. I Cancel
Figure 10. 2: Initial setup of Network tab
Change password |
Iﬁdmin
Cancel |
Pagzword:

f
LCaonfirm pazsword by retyping below:

Figure 10. 3: Change password dialog
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10.1.3 Adding new usersto the system

Theinitial setting of the network database adds an administrator user and a guest user to the system. The
following levels of access are possible in the HEW system:

¢ Administrator:

Full access to every aspect of HEW. The user can add and remove users from the projects and
change accessrights. The administration user can change the workspace and project files and also
the source files.

¢ Full read/write access:

The workspace and project files can be modified, as can the source files. But it isnot possible to
change user access rights from this access level.

* Read/writefile access:
Only the source files can be modified. All project settings can only be viewed not modified.
e Readonly:

All sourcefiles and project files can only be viewed as read only. Nothing can be modified.

When any user opens a network-enabled project they must type in their user name and password. Until thisis
done no access can be granted. Once entered the user is given one of the levels of access as seen above.

2 Toadd anew user to the system:

1

ok w DN

Log in with a user who has administrator access rights. The process for doing thisis described above.
Select [Tools->Options]. The HEW tools options dialog is displayed.

Select the network tab. Thisisdisplayed in Figure 10.2.

Click the access rights button. The dialog displayed in Figure 10.4 is displayed.

Click the add button. Thelogin dialog isdisplayed. Thisallowsyou as the administration user to add
anew log in name and password. Normally the password should be set to some default text or left
blank. Then click OK.

Once OK isclicked the user is added with read only rights. To change the access level select the user
you wish to modify and then click the required radio button. Then click OK to save the accessrights
changes.

2 Toremove an existing user to the system:

160

1

N o gk wDd

Log in with a user who has administrator access rights. The process for doing thisis described above.
Select [Tools->Options]. The HEW tools options dialog is displayed.

Select the network tab. Thisisdisplayed in Figure 10.2.

Click the access rights button. The dialog displayed in Figure 10.4 is displayed.

Select the user you wish to removein the userslist.

Press the remove button.

Then click OK to save the access rights changes.
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User access rights 21|

Uzer access rights |

Access level

Admin

Add
Bemave |

—ACcess:
% adrministrator

€ Full read/vrite access
" ReadAwrite file access only

{~ Fead only access

ak. I Cancel

Figure 10. 4: User accessrightsdialog

10.1.4 Changing your password

To change your password:
1. Loginto the HEW network database you are changing your password for. Select [T ools->Options].

The HEW tools options diaog is displayed.

Select the network tab. Thisisdisplayed in Figure 10.2.

Click the password button.

Enter your new password and confirm it in the second edit box.

Click OK.

Then click OK to save the password change.

o ok WD

10.1.5 Usingthenetwork HEW service

When you connect to a networked project for the first time the HEW automatically connects you to the correct
network HEW service. Thisisdefined using machine name. If the service cannot be found using the machine
name in the workspace then the dialog displayed in figure 10.5 is shown. Simply type or browse to the machine
where the serviceislocated and click OK. If you want to be the server machine then leave the radio button on
its default selection, use local machine.
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Select Server Location ﬂ E

£+ ze local machine
= Use network machine Cancel |

Access:
Caomputer narme:

|| Browsze. . |

Figure 10. 5: Select machine name

If you have previoudy been the server of aworkspace then the following message will be displayed when you
attempt connection to another machine. Thisdialog isdisplayed in figure 10.6. Clicking OK then connects your
machine to the new location.

High-Performance Embedded Workshop B

& ‘workspace is registered ta be shared on computer 'PADNSSZ', pou are registered o run server locally, do you want to change your server registration.

Cancel |

Figure 10. 6: Select machine name

Note:  If the network is running multiple HEW workspaces with the network service enabled then a user can
only access one of them a onetime. The only instance when thisis not the case isif the same machineis
serving all of the network workspaces.
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11. Difference View

The High-performance Embedded Workshop has an integrated difference view. Thisview allows detailed
difference comparisons to be made with local files on the drive and aso with filesin the version control system.
In the HEW version 3.0 onwards the Visual SourceSafe component has this facility.

The difference window can be invoked two ways. The first isfrom the show differences menu item on the tools
menu. The second is via the workspace window pop-up with the same name. When using the pop-up menu the
current file selection is automatically added to the edit box. Clicking the show differences menu item displays
the dialog shown below in figure 11.1.

=100
c:Yhewhprojectstmypraject\myprojectydbsct ¢ File in version control
" 14 a|
15 g 15
16 16
1 fpragma section SDBEC 1 #pragma section $DSEC
1 ztatic const struct | 12 gztatic const struct |
18 char *rom_s; /* Start address of tF 18 char *rom_s; /* 8tart address of the :
20 char *rom e; /* End address of the 20 char *rom_e; /* End address of the in:
2 char *ram s; F* 8tart address of tF = char *ram_s; /* gtart address of the :
2 YDTEL[]= {hk ekl
}IDTBL[]= {
2z {__sectop("D"), _ secend("D"), _ sectop(’ = {__sectop("D"), _ secend("D"), _ sectop("R"]
LA {__sectop("$ABZBD"), _ secend("$AE3ED") = // {_ sectop("$AB3BD"), _ secend["$AEBIED"), _
N {__sectop("$ABE1ED") , _ secend("§ABS1e @ S/ {_ sectop("$AES16éD") , _ secend("$ABE1AD"]
w e =
bi
? fipragma section $BSEC ¥ fpragma section $BESEC
% gtatic const struct | % gtatic const struct |
21 char *h_s; F* 8tart address of nc char *b_s; /* gtart address of non—:
e char *b_e; /* Bnd address of non- char *b_e; /* End address of non-in:
» }BTEL[]= { # }BTEL[]= { s
2 g "R 2
: § mmeton i TRTY mrcand (TRTYY e il el

Figure11. 1: Difference view

2 To perform adifference comparison with two files on your local drive:

1

Select [Tools->Show Differences...]. The difference compare files dialog is displayed. Thisis shown
infigure 11.2.

Ensure the compare with file on drive radio button is enabled.

Enter the first and second file to compare. Y ou can either select a previous difference comparison or
browse to anew file.

Clicking the advanced button displaysthe dialog in figure 11.3. Thisalows you to perform the
difference comparison without taking white space into account. Click OK when you are finished with
this options dialog.

Click compare.

The difference view isdisplayed. The two files being compared are loaded into each side of the split
view. Their names are at the top of each window.

2 To perform adifference comparison with alocal file and afile in SourceSafe:
1. Ensurethe SourceSafe component is enabled. Also note that the file must be have been added into the
version control system.
2. Select [Tools->Show Differences...]. The difference compare files dialog is displayed. Thisis shown
infigure 11.2.
3. Ensure the compare with version control radio button is enabled.
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4. Enter thefirst fileto compare. You can either select a previous difference comparison or browse to a
new file.

5. Clicking the advanced button displaysthe dialog in figure 11.3. Thisalows you to perform the
difference comparison without taking white space into account. Click OK when you are finished with this
options dialog.

6. Click Compare.

7. Thedifference view isdisplayed as shown in figure 11.1.

Compare files

Reference file:

|K:\HEW2D\HEW JNEXE VwinhFislease v | Browse.. |

" Compare with file on drive

Compare

Cahicel

Adwanced...

Flel

T arget file:

j Browse, . |

¢ ‘Compare with version controf

Figure 11. 2: Difference compare files dialog

Compare Files - Advanced Options x|
".&dvanced:

Figure 11. 3: Differ ence advanced options dialog

The difference view functionality can be accessed in two different ways. The difference view hasits own
toolbar thisis shown in figure 11.4. Thisfunctionality can also be accessed via the difference window right
mouse button pop-up. Thisis shownin figure 11.5.

|gnore white space
Compare files

Find nest

Find previous
Find previous difference

Find next difference

oot dh oy a T &

Figure 11. 4: Difference toolbar

164
RENESAS




Pl Compare...

Export rezultz to file...

L |gnore whitespace

@ Find
ﬂ Find previous
#a Find next

T+ Previous difference
F Mest difference
Refresh comparizon

Figure 11. 5: Difference popup menu
The functionality for each menu item isdescribed below:

¢ Compare: This opens anew compare window so that some new files can be comapred and the
differences displayed.

« Export resultsto file: This opens a dialog which allows you to choose afile to export the current
difference results to atextual format.

« Ignore white space: Theignore white space option which is on the advanced options dialog can be
toggled viathis menu item.

¢ Find: Displaysastandard find dialog. Thisusesthe same find dialog asthe HEW editor.
¢ Find next: Findsthe next string that meets the find requirements.

¢ Find previous: Finds the next previous string that meets the find requirements.

* Previous Difference: Automatically jumps the view to the next previous difference.

« Next Difference: Automatically jumps the view to the next difference.

¢ Refresh comparison: Refreshs the view to manually run the difference comparison again. This can be
used if either file has been modified since the last comparison.

The difference window also allows the colours in the view to be customised. This procedure is outlined below:

2 To change the colors viewed in the difference window:
1. Select [Tools->Format Views...]. The format views dialog is displayed.
2. Expand the difference view. Thedialog is shown and looks the same as figure 11.6.

3. Select the category you want to change. The color display tab is displayed and allows modification.
The categories available are Left hand side moved lines, Left hand side different lines, Right hand side
moved lines and Right hand side different lines,

4. Click OK to keep the changes.
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= Coverage | Font I
&) 10

‘) Fegizter

&) TCL Toolkit

] Ewent

: Font
LHS Different Lines

LHS Moved Lines | ovaier Neww [
RHS Different Lines
RHS Moved Lines Paint Size
Selected Text

Text I 11 j'
Performance Analysis
Profile

Status

Label

2|

Memary HEW Seample Text
Output

Sdd e odify Eemawve Qk. I Cancel

1]
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Figure 11. 6: Format views dialog
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12. Technical Support

The High-performance Embedded Workshop has a number of integrated technical support features.

2 To check for HEW product updates or service packs:
1. Select [Help->Technical support->Check website for updates)].
2. Your default web browser isinvoked and defaults to the HEW download page for your region.
3. Browsethisareafor HEW updates to fix bugs or add new features.

Occasionally you may experience some unforeseen problems with the HEW application. If a problem does
occur that results in a application crash the HEW bug tracking program will be invoked automatically. This
allows you to compile a bug report and this can then be sent to your technical support contact in avariety of
ways. It isalso possibleto invoke this tracker program manually. Thisis described below:

2 Tocreate and send a HEW bug report:

1. Select [Help->Technical support->Create Bug Report].

2. Detailed information is generated from your HEW system. This may take sometime. The bug report
diaog isthen displayed. Thisisshowninfigure12.1.

3. Itispossibleto then add additional information concerning the exact issue you have found in the large
edit box.

4. Onceyou are happy with your report, you can choose the method of sending the report in the submit
drop list. You can printit, email it, or save it to adisk.

5. Then click submit. Thiswill send the report by the selected method.
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“ou map zubmit a Bug Report through e-mail, or by conventional means.

The box below contains information gathered from pour machine, and any additional information
about the state of the software if a crash occured.

Rk Infarmation :
Load:

Tatal RaM

Free RaM :

Page File :

Page Filz Free
Total Yirual :
“irtual Free :

Project Details :

26%

536,379,392 bytes
391,581 636 bytes
1.309.028.352 bytes
1,204,985.856 bytes
2147 352 576 bytes
250,034,564 bytex

Mo project information available

Fleaze type a description of the problem you wish to repart:

— How would you like to zubmit the report?

Print

=

Submit I

Cancel

5
B
o

|
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Figure 12. 1: Submit bug report dialog
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13. Navigation facilities

The High-performance Embedded Workshop has a number of integrated navigation facilities. The navigation
window islocated alongside the project and templates window. Thisview is shown below in Figure 13.1.

E

Mavigation entries

i) AMIMAL

E‘[:l M avigation categary

= dema Project
B g% CShark

----- &) CShark[]

----- &) "CShark(]

----- &) GetClazsMame(void)

----- &) m_nSharpT eath -
E- g% CCrocodile

----- &) CCrocodilel)

----- &7 "CCrocodile()

----- &) GetClazsMame(void)

----- an) m_nLiveirha/ater

----- &) m_nSharpT eath

- g% CFish Clazs name
..... &7 CFish()
..... &7 ~CFish(]
----- &7 GetClazsM ame(vaid) Class members
----- &0 m_nLiveiriw ater

B g% CGreatuthite

----- &) CGreatwhitel]

----- &) "ChGreatwhite()

----- &) FeedTheShark[CCrocadile® mpGoat]

----- &7 FeedTheShark[CFish* myFishyFood]

----- &7 FeedTheShark[char® pszOtherType]

----- &7 FeedTheShark[CHorze® myHorzeyFood)

----- &) FeedTheShark[CPerzon® myPersonFood) j

Project | Templates Navigation I

Figure 13.1: Navigation view

The navigation view contains categories for al supported navigation types. In HEW 3.0 the following
navigation components are supported as standard:

* C Defines: All #definesfor C and C++ source files are displayed.
e CFunctions: All ANSI C standard functions are for C source files displayed.
e C++ Classes: All classes, functions and members are displayed for C++ sourcefiles.

Each category is displayed in the top level of the view. Underneath each category each project in the workspace
isdisplayed. Then the items belonging to that particular project are displayed below the project icon.
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It is possible to disable scanning for certain navigation categoriesif you do not require the information.

2 To switch off anavigation category:
1. Right click on the Navigation window. The pop-up menu displayed in figure 13.2 is shown.

2. Select the“ Select Categories...” menu item.
3. Thedidogin figure 13.3 isdisplayed.
4. Uncheck any categories you are not interested in seeing definitions for.
5. Click OK.

Go ko Declaration

130 ko Definition

Configure View. .,

Select Categories, .,

IT Allow Docking
Hide
Figure 13. 2: C++ Navigation pop-up menu
Select Categories E2

Pleaze select the categories o zcan for:

[¥IC Defines -
[w|C Functions Cancel |
[w|C++ Clazzes

Figure 13. 3: C++ Navigation select categories dialog

Note: The navigation itemsaredisplayed gradually asthefilesare scanned. Thismeansit may take some
timeif thereare many filesto fully complete the Navigation view update.

Filesarerescanned when they are saved. Thismeansthat navigation information will not be available for
new classes and functions until thefileor filesare saved.
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13.1  C++ Navigation component

The C++ navigation component is the most complicated of the three supported navigation components. It
supports the following structuresin the view for C++ source files. The basic structure of the information is
shown below in figure 13.4.

g

E---DE++ Clazses C++ navigation cateqary title

E@ dema Project name

[ g% CPerson

CCrocodile
CCrocodileShark,
CFizh Clazs name
CHorze
Chd arnnnal
CReptile

. ChGreatwhite
----- &) CGreatwhitel]

----- &) "ChGreatwhite()

----- &) FeedTheShark[CCrocodile® myGoat
----- &7 FeedTheShark[CFish* myFishyFood .
----- &) FeedTheShark[char® psz0therType HO3L SOl
----- &7 FeedTheShark[CHorse® myHorseyF
----- &) FeedTheShark[CPerzon® myPersonl
----- &) FeedTheShark[vaid]
----- &) GetClazsMame(void)
..... &) m_rDangerous Protected member variable
..... &g m_ndaws Private mermber variable

----- &) m_strM ame )
El-[@] Globals Global variables and
¥ funchions folder

----- &) kheap_area

----- &7 FINT “ectars(] bl
4| | 3
Project J Templates Navigation |

Figure 13. 4: C++ Navigation information

The C++ navigation view uses a number of icons to describe the type of function or variable the icon belongs too.
These are listed in the table below:
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Description

Puhlic member function

Frotected member function

Private member function

Public member varable

Protected member vanable

Private member variahle

olefc]ele[ef

Figure 13. 5 C++ Navigation I cons

The navigation view allows you to move around your source code quickly and efficiently. Double clicking on a
navigation item by default jumps you to the associated navigation items definition. Normally the definition is
found in the source file and the declaration is found in the header file.

This default behavior can be modified for this action. This can be achieved via the configure view dialog. The
configure view dialog modifies the way datain the Navigation view is displayed.

2 To configure the C++ navigation views data:

1. Right click on a C++ navigation item in the navigation window. The pop-up menu displayed in figure
13.2 isshown.

2. Select the“Configure view” menuitem.
3. Thedidogin figure 13.6 is displayed.
4. Decide what items you wish to modify and click OK to accept the changes.

Configure Yiew |

v Jump ta definition on double-click,

ak. I Cancel

Figure 13. 6 C++ Configure view dialog

Thefollowing items are available on the configure view dialog.
*  Group by access: This option groups the display of public, protected and private member variables and
functions together in the Navigation view.
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Jump to definition on double click: By default this option is checked. If this option is switched off then
adidog is displayed which asks you where you wish to jump. Y ou rather than HEW resolve the
ambiguity. Thisdialogisshown in figure 13.7.

Select Query Location x|

Select the query ta jump to:

Go to Declaration [Manimal b, line 12)
Go to Definition ["animal.h", line 12)

Cahicel |

Figure 13. 7 Select Query L ocation dialog

Another useful facility isthe capability of viewing the base or derived classes for a certain selection.

2 To view the Base or derived classes

1
2.
3.

Select the class that interests you in the Navigation view.

Right click and view the pop-up menu.

To see the derived classes for the selection click the “ Show Derived Classes’ menu item. To seethe
base classes for the selection click the “ Show Base Classes’ menu item.

Depending on the selection adialog is displayed which shows the class structure selected in an
expanded tree format.

Click Closeto close this dialog once you have the information you require.
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13.2  C Function and #defines navigation components

These components simply add the function and #define definitions to the Navigation view. It isthen possibleto
jump to these definitions by double clicking on the label you wish to view.

B
=[] G Defines ~ C l:tlefine r;_ﬁvigation
E-15] demo — cateqgary title
@@ #ilefine

----- &7 FLMAX

----- &7 FLMIN

----- &7 HEAPSIZE
----- &0 INT.OFFSET
----- &7 IDSTREAM

----- &7 STDOUT ) o

=[] G Functions C function nanvigation
= @ demo categorny title

] wsbrk ANSI C function

----- &7 GLOSEALL

""" a7 INIT IDLIB 7
4| | »

@ijecis I @ Templates J (’:lhlavigaﬁon I_

Figure 13. 8 C Function and #defines navigation infor mation
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14. Smart Editor

Another feature of the High-performance Embedded Workshop isits smart edit facility. Thisisenabled by
default for al C++ sourcefiles. Thisfeature allowsthe HEW editor to access C++ navigation information and

provide auto-completion help when using C++ classes and member functions.

2 Toview the Smart edit status:

1

2.
3.
4

Click on the [T ools->Options] menu item.
Select the “Editor” tab of the tools options dialog.

Thediaogin figure 14.1 isdisplayed. The“Enable Smart-edit for C++ files” should be checked.

Click OK.

Build ~ Editor |W’0rkspace Eonfirmationl Networkl

— Spacing:

21|

1k

[V Enable auto indentation

Tab size: I 4

— General:

¥ Save files before executing any tools V' Show files in notebook

™ Prompt before saving files [V Enable syntax coloring

[+ Enable Smart-edit for C++ files ¥ Enable toaltip watch

— Extemal editar:

™ Use extemal editor:

| iy |

o1

Cancel

Figure 14.1: Options Dialog Editor Tab

With this option switched on if you are working on a C++ file the smart-edit capability should be enabled.

Note: If the C++ Class navigation category has been switched off the Smart-edit capability of HEW will
not be active.

During normal usage the following editor operations will make the smart edit facilities visible.

2

If you are using an object and are trying to access the membersusing the‘.” or *->'. If you do thisa

pop-up will be displayed which may help you select the correct member more efficiently than typing.
Whilst typing the pop-up will keep track of the keys you have pressed to help your selection. If you press
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return then the currently selected member will be added. This pop-up isalso used when using the ‘::’

method and it is displayed in figure 14.2.

2 If you aretrying to use a C++ function then the dialog in Figure 14.3 is displayed when the first open
bracket is entered. Thisdialog allows you to see what functions are available for the current object.

Selecting the function automatically enters the remaining parameters for you.

#include "greatwhite.h"
wold main(void):

wold main{void)

CGreatWhite cJaws:
cJaws.n_n

3 DN -
aglm_nDangerous
Egim_nFins
agim_nlaws
E)m_nlLeqgs
A)m_nLiveiniater
Egim_nlives
“m_n3ea

A - - 1

Figure 14.2: Smart-edit member selection

#include "greatwhite h"

wold main(void):

wold main{void)
CGreatWhite myfish:
myfish.FeedTheShark

int FeedTheshark{CFish* myFishyFood)
int FeedTheshark{“Horse™ myHorseyFood)
int FeedTheshark,_Person™ myvPersonFood)
int FeedTheshark{char* pszther Type)

[
[
=

Figure 14.3: Smart -edit function selection
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Note: Smart-edit auto completion may not pop-up for avariety of reasons. HEW can only provide help
when the file has been scanned by the navigation component. For thisto work thefile must have been
saved.

Another issueisthat #defines are not considered so this means that redundant areas of code may still be
visble.

Another important consideration isif the syntax of your codeisincorrect the smart editor may not be able
to parseyour code correctly and the smart edit functionality will fail. In this case no pop-up will be
displayed.

Please note that Smart-edit does not support macro usage.
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Emulator Debugger Part
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Sectionl Overview

1.1 Features

The breakpoint, memory map, performance, and trace can be set through the dialog box.
O Intuitive user interface

O Online help

0 Common display and operability

Supported host interfaces

The PCI interface, PC card (PCMCIA) interface, USB interface, or LAN interface can be used for connecting
to the host computer.

Realtime emulation
Redltime emulation of the user system is enabled at the maximum operating frequency of the CPU.
Excellent operability

Using the HEW enables user program debugging using a pointing device such asamouse. The HEW
enables high-speed downloading of load module files.

Various debugging functions

Various break and trace functions enable efficient debugging. Breakpoints and break conditions can be set
by the specific window, trace information can be displayed on a window, and command-line functions can be
used.

Memory access during emulation
During emulation, the memory contents can be read and modified.
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12 Warnings

CAUTION

READ the following warnings before using the emulator product.
Incorrect operation will damage the user system and the emulator
product. The USER PROGRAM will be LOST.

1. Check al components against the component list after unpacking the emulator.

2. Never place heavy objects on the casing.

3. Do not place the emulator in places where:

*  Thetemperature becomes high such asin direct sunlight or near a heater. For details, refer to section 1.3,
Environmenta Conditions.

e Thetemperature or humidity changes greatly.

e Thereisalot of dust.

* Thereisalot of vibration. For details, refer to section 1.3, Environmental Conditions.

Protect the emulator from excessive impacts and stresses.

Only supply the specified voltage and power-supply frequency.

When moving the emulator, take care not to vibrate or damageit.

After connecting the cable, check that it is connected correctly. For details, refer to section 2, Preparation

before Use. Supply power to the connected equipment after connecting all cables. For the supplying

procedures, refer to section 2.6, System Check. Cables must not be connected or disconnected while the

power ison.

N o 0k~

180
RENESAS



1.3 Environmental Conditions

CAUTION

Failure to do so will cause illegal operation in the user system, the
emulator product, and the user program.

Observe the conditions listed in table 1.1 when using the emulator.

Tablel.1 Environmental Conditions

Item Specifications

Temperature Operating: +10°C to +35°C
Storage: —10°C to +50°C

Humidity Operating: 35% RH to 80% RH, no condensation
Storage:  35% RH to 80% RH, no condensation
Vibration Operating: 2.45 m/s’* max.
Storage: 4.9 m/s’ max.

Transportation: 14.7 m/s* max.

Ambient gases  No corrosive gases may be present

14 Emulator External Dimensions and M ass

Table1.2 Emulator External Dimensionsand Mass

Item Specifications
Dimensions 219 x 160 x 54 mm
Mass Approximately 970 g

RENESAS
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Section 2 Preparation before Use

21 Emulator Preparation

Unpack the emulator and prepare it for use as follows:

A WARNING

the emulator product. The USER PROGRAM will be LOST.

READ the reference sections shaded in figure 2.1 before using the
emulator product. Incorrect operation will damage the user system and

Reference

Unpack the emulator Component list
I

Check the components against
the component list

Section 3
Set up the emulator

- Insert the optional board
- Install the HEW
- Connect the interface cable

Turn on the user system Section 4
(Only when the user system is connected)

Turn on the emulator
1

Start the HEW

Setup

Activation

Figure2.1 Emulator Preparation Flowchart

22 Installing Emulator’s Software

Toingtal the HEW, refer to the Setup Guide for the E6000 Emulator supplied together with the emulator.
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2.3 Connecting to the User System
To connect the emulator to a user system, proceed as follows:

e Connect the user system interface cable head to the user system.
» Plug the cable body into the emulator.
» Plug the cable body into the cable head.

For details of these steps, refer to the User System Interface Cable User's Manual.

Figure 2.2 gives details of the connectors provided on the emulator.

EBDOD ’» PC interface cable

connector

User system interface —
cable connector

Power connector

| ez | I
External probe __ f— Power switch
connector
Screw Screw

Figure2.2 E6000 Emulator Connectors

231 Example of Connecting the User System Interface Cable Head to the User System

Screw (x 4)

7N
§ ¥

1
1
1
1
| ] User system interface
1 | cable head

1

Figure2.3 Example of Connecting User System | nterface Cable Head to User System

* Ensurethat all power is off to the emulator and the user system.
» Insert the cable head into the socket on the user system.

Note: Depending upon the package, it may be possible to orientate this cable head in any position on the socket,
so care should be taken to correctly identify pin 1 on the emulator and socket when installing.
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Screw the cable head to the socket with the screws provided. Progressively tighten the screws in the sequence
shown in figure 2.4 until all are ‘finger tight’.

© 06

<1

® @

Figure2.4 Sequenceof Screw Tightening

Note: Be careful not to over-tighten the screws as this may result in contact failure on the user system or

damage the cable head. Where provided, use the ‘solder lugs' on the QFP socket to provide extra
strength to the emulator/user system connection.

232 Plugging the User System Interface Cable Body into the Emulator

Plug the cable body into the emulator, taking care to insert it straight, and push it firmly into place.

Cable body

5 =—
/
\ / External probes E6000 emulator

Cable head User system interface cable

Figure2.5 Plugging User System Interface Cable Body to Emulator

233 Plugging the User System I nterface Cable Body into the Cable Head

Plug the cable body into the cable head on the user system.
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24 Power Supply

241  AC Adapter

The AC adapter supplied with the emulator must be used at all times.

242 Polarity

Figure 2.6 shows the polarity of the power-supply plug.

5V (outside)

GND (inside)

Figure2.6 Polarity of Power Supply Plug

243 Power Supply Monitor Circuit

The emulator incorporates a power supply monitor circuit which only lights the red LED when a voltage higher
than 4.75 V is supplied. If this LED isnot illuminated, you should check the emulator voltage level. An input
voltage lessthan 4.75 V could indicate that enough current cannot be supplied to the emulator.

Note: Use the provided AC adapter for the emulator.

25 Hardware I nterface

All signasaredirectly connected to the MCU in the emulator with no buffering with the exception of those
listed in section 7, Hardware Specifications Specific to This Product.

251 Signal Protection on the emulator

All signals are over/under voltage protected by use of diode arrays. The only exceptions being the AV . and
analog port.

All ports have pull-up resistors except for analog port.

All V. pins on the cable head assembly are connected together (with the exception of the AV . pin), and are
then monitored by the emulator to detect powered user system presence.

252 User System Interface Circuits

The interface circuit between the MCU in the emulator and the user system has a signal delay of about 8 nsdue
to the user system interface cable and it includes pull-up resistors. Therefore, high-impedance signals will be
pulled up to the high level. When connecting the emulator to a user system, adjust the user system to compensate
for propagation delays.

The following diagrams show the equivalent circuit examples of the interface signals. The interface circuits
depend on the MCU type. For details, refer to section 7, Hardware Specifications Specific to This Product.
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253 Clock Oscillator

The oscillator circuit has been implemented on the user system interface cable head. For details on the oscillator
circuit, refer to the user's manual for each user system interface cable.

254 External Probe/Trigger Output

An 8-pin connector, marked EXT (on the right under the user system interface cable connector), on the emulator
case accommodates four external probe inputs and two trigger outputs. The pin assignment of this connector is
shownin figure 2.7.

| I I I
[ eno [ anp !

OO0O0O0O0OOO| &
| | |
T

4 Tuvcc  Tsv
- _—)
Input pins Trigger output pins

Figure2.7 External Probe Connector

The interface circuit for the externa probeis shown in figure 2.8.

UVce

10 kQ
HD151015
External probes 1 to 4

22Q

Figure2.8 External Probe Interface Circuit

Thetrigger output is controlled by event channel 8 and islow active. The trigger output is avail able as either
TS5V (probe color: white; within the range from 2.5 to 5.0 V and does not depend on the user V_ level) or TU,
(probe color: yellow; the user V. level). When the TU, . is used, user system cannot be evaluated at the power
voltage of 1.8 V (the voltage must be within the range 2.0t0 5.0 V).
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255 Voltage Follower Circuit

CAUTION

1. Do not connect the user system interface cable to the emulator
without user system connection.
2. Turn on the user system before starting up the emulator.

A voltage follower circuit isimplemented on the emulator which allows the user system voltage level from the
user system to be monitored. This monitored voltage level is automatically supplied to the logic on the emulator
and is derived from the emulator power supply unit. This means that no power istaken from the user system
board.

If no user system interface cable is connected to the emulator, the emulator will operate at a specified voltage
and al clock frequencies will be available to the user. If the user system interface cable is attached, the emulator
will match the voltage supplied to the user target in al cases; i.e. even when the user V. is below the operating
voltage for the MCU. You must be careful not to select an invalid clock frequency. When the emulator is
connected to the user system and the user system is turned off, the voltage follower circuit output voltage level is
0 V. Inthis case, the emulator will not operate correctly.

You can set auser V. threshold in the range Vcc max. —0 V by using the emulator configuration dialog box. If
the user V. drops below thisthreshold, [User System Voltage] in the [Extended Monitor] window will display
Down, otherwise OK is displayed.

threshold

User Vcc level

User V - .o I
threshold oK [

Down - - - - - - -

E6000
Vcc level

The user system interface
cable is not connected.

Figure2.9 VoltageLevel Monitoring (Example for Vcc = 3.3 V)
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2.6 System Check

When the software is executed, use the procedure below to check that the emulator is connected correctly. Here,
use the workspace for a tutorial provided on the product.

Refer to section 2.8, Other Methods for Activating the Emulator, for the other activating method to create a new
project or use a workspace for the HEW of the old version.

Connect the emulator to the host compuiter.

Connect the user system interface cable to the connector of the emulator.
Turn on the emulator.

Activate the HEW from the [Programs] in the [Start] menu (figure 2.10).

> wbdh e

‘Windows Update

L4 @ Tools L4

High-performance Embedd

shop

Accessories 4 |'_§Q High-performance Embedded Workshop Help
Documents 4 ¥ @ High-perfarmance Embedded Workshop Read Me
Ez'% High-performance Embedder

Settings 4

Professional

Search 4

Help

Run...

Shut Down....

CARE RS NN T

Windows 200

Figure2.10 [Start] Menu

Note: If ‘LAN Driver' isnot selected at ingtallation, [Tools] is not displayed.
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5. The[Welcome!] dialog box is displayed.

21x
Rkt
' ‘Cieate a new project workspace Cancel |
") Mpen arecent project workspace; Administration... |
= | ]
= .
g {~ Browse to another project workspace

Figure2.11 [Welcome!] Dialog Box

To use aworkspace for the tutorial, select the [Browse to another project workspace] radio button and click the
[OK] button.

When the [Open Workspace] dialog box is opened, specify the following directory:
HEW installation destination directory\Tool s\Renesas\DebugComp\Pl atform\E6000\xxxx\Tutorial

After the directory has been specified, select the following file and click the [Open] button.

21

Lok, jr: I@ Tutarial j - IC:F -

Debug_H&5_2237_EA000_Emulator _CP
SoUrce

File name: |Tutorial.hws Open I
Files of twpe: IWorkspaces [® hws) j Cancel |
S

Figure2.12 [Open Workspace] Dialog Box
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When no compiler package or that of adifferent version isinstalled, the following message box will be displayed.

Hi|;]h-|:|Er'F|:|r'I'|'|-E|I'||IE Embedd il

Tukorial

there is no compatible koolchain available

"_\ Tool Chain 'Hitachi HES,HE300 Standard Toolchain', version oo is missing Fram the Following project(s)
L

Figure2.13 Message Box

6. The[E6000 Driver Details] dialog box isdisplayed. Thisdialog box isonly displayed at the first initiation.
When only one of interface driversis selected, this dialog box is not displayed.

Criver: IEmuIatDr PCI Card Driver j
— Details
Interface: IPOI j
Channel: IEmuIatnr PCI Card Interface j

—Configuration
Confieure., |

[~ Charnee driver in start up

Figure2.14 [E6000 Driver Details] Dialog Box

* Inthe[Driver] combo box, select the driver to connect the emulator.
» [Interface] displays the name of the interface to be connected.
e Click the [Closg] button.
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7. Set uptheemulator. During this process, the following dialog box is displayed.

Attempting to connect the emulator.

Starting to tranzfer a firmware file.

[~ Charnee driver in start up

The driver program has been initializedEmulator PCI Gard Drwer)

Cloze |

Figure2.15 [Connecting] Dialog Box

8. When "Connected" is displayed in the [Output] window of the HEW, the emulator initiation is completed.

| - High-perfol = O] x|
< File Edt WYiew Project Options Build Debug Memory Tools  ‘Window Help == ZI
2l
= .
& &R e =
=] l@ Tutorial S :Tutorial.cpp

{23 C source file
e [E

shrk.c
{2 G+ source file
resetpra.cpp
sort.cpp
tutarial.cpp

e 3 DESCRIPTION :Main Program

<% Thi= file 1= generated by Hitachi Froject =

#ifdef _ _cplusplus
extern "C" {
#endif

void abort{wvoid):
#ifdef _ cplusplus

a Dependencies % i
Endil
strkch #include "sort. h" =
sorth e ey ST _I_I
- stacksclh 4] d
i 3 Projects IE Templates I = 1 Mavigation ] <L tutorial.epp
? Comnected
A | &I Build A Debug £ Find in Files A “ersion Conirol
Ready [Read-wrice [1/82 [t NS nUM
Figure2.16 HEW Window
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2.7 Communication Problems

The following message box will be displayed when the emulator power isturned off or the PC interface cableis
not correctly connected.

xxxxx E6O00 Enulaktar ﬂ

A verification error has occurred during the transfer of a Firmware File,
This is probably because the emulator has been turned of f or another emulator has been connected,

Figure2.17 Error Message

For information on other errors, refer to the Setup Guide for the E6000 Emulator.
2.8 Other Methodsfor Activating the Emulator
Refer to section 4, Preparation before Use.

29 Uningtalling the Emulator’s Software

For details on uninstallation, refer to the Setup Guide for the E6000 Emulator.
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Section 3 E6000 Emulator Functions

31 Debugging Features

311 Breakpoints

The emulator provides a comprehensive range of alternative types of breakpoints, to give you the maximum
flexibility in debugging applications and user system.

Hardware Break Conditions: Up to 12 break conditions can be defined using the event and range channelsin
the complex event system (CES). For more information about the hardware break conditions, see section 3.2,
Complex Event System (CES).

Program Breakpoints (PC Breakpoints): Up to 256 program breakpoints can be defined. These program
breakpoints are set by replacing the user instruction by aBREAK instruction. In target ROM, only one
breakpoint (on-chip break) can be set.

312 Trace

The emulator incorporates a powerful realtime trace facility which allows you to examine MCU activity in detail.
The realtime trace buffer holds up to 32768 bus cycles, and it is continuousy updated during execution. The
buffer is configured as arolling buffer, which can be stopped during execution and read back by the host
computer without halting emulation.

The data stored in the trace buffer is displayed in both source program and assembly languages for ease of
debugging. However, if trace filtering is used, only assembly language can be displayed.

The buffer can be set up to store all bus cycles or just selected cycles. Thisis called trace acquisition and uses the
complex event system (CES) to select the parts of the program you are interested in.

It isalso possible to store all bus cycles and then just look at selected cycles. Thisis caled trace filtering.

313 Execution Time Measurements

The emulator allows you to measure the total execution time, or to measure the time of execution between
specified eventsin the complex event system. Y ou can set the resolution of the timer to any of the following
vaues:

20 ns, 125 ns, 250 ns, 500 ns, 1 ys, 2 s, 4 s, 8 ps, or 16 ps.

At 20 ns the maximum time that can be measured is about six hours, and at 16us the maximum time is about 200
days.

314 Performance Analysis

The emulator provides functions for measuring the performance of a program. The performance of the specified
program range can be displayed either as a histogram or in percentage form. A timer resolution of 20 ns, 40 ns,
or 160 ns can be selected. In addition, the execution count of the specified program range can be measured (1 to
65535).
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315 Bus Monitoring

The emulator incorporates a bus monitoring function that monitors and displays the contents of the accessed area
in HEW windows without stopping the program execution. Up to eight blocks of 256 bytes can be monitored.

In addition, the emulator can output trigger signals from external probe 2 (EXT2) when specified addresses (four
points max.) are accessed. Note that, however, some products do not support the bus monitoring function.

3.2 Complex Event System (CES)

In most practical debugging applications, the program or hardware errors that you are trying to debug occur
under a certain restricted set of circumstances. For example, a hardware error may only occur after a specific
area of memory has been accessed. Tracking down such problems using simple PC breakpoints can be very
time-consuming.

The emulator provides a very sophisticated system for giving a precise description of the conditions you want to
examine, called the complex event system. This allows you to define events which depend on the state of a
specified combination of the MCU signals.

The complex event system provides a unified way of controlling the trace, break, and timing functions of the
emulator.

321 Event Channels

The event channels dlow you to detect when a specified event has occurred. The event can be defined asa
combination of one or more of the followings:

* Address or address range

* Addressoutsiderange

* Read or Write or either

» Data, with an optional mask

e MCU accesstype (e.g., DMAC and instruction prefetch)

e MCU access area (e.g., internal ROM and internal RAM)
* A signal state on one or more of the four external probes

e A certain number of times that the event must be triggered
» Delay cycles after an event

Up to eight events can be combined into a sequence, in which each event is either activated or deactivated by the
occurrence of the previous event in the sequence. For example, you can cause abreak if an I/O register iswritten
to after a specified area of RAM has been accessed.

322 Range Channels
The range channels can be set up to be triggered on a combination of one or more of the following:

* Address or address range (inside the range)

» Read or Write or either

» Data, with an optional mask

e MCU accesstype (e.g., DMAC and instruction prefetch)
e MCU access area (e.g., internal ROM and internal RAM)
* A signal state on one or more of the four external probes
» Delay cycles after an event

The complex event system can be used to control the following functions of the emulator:
196
RENESAS



323 Breaks

Use breaks to interrupt program execution when a specified event, or sequence of events, is activated. For
example, you can set up abreak to halt execution when the program reads from one address, and then writesto
another address. The break can also optionally be delayed by up to 65535 bus cycles.

324 Timing

Y ou can set up two events and then measure the execution time of the program between the activation of the first
event and second event.

33 Har dwar e Features

331 Memory

The emulator provides standard emulation memory as the substitute for internal ROM memory and internal
RAM memory. When a device type or device mode without an internal ROM or internal RAM is selected, the
standard emulation memory is disabled. When debugging with only the emulator and the user program and data
are stored in an externa address space, an optional SIMM memory module must be used. The optiona SIMM
memory modules can be separately purchased.

The emulation memory can be mapped in 64-byte units to any number of separate memory blocksin the MCU
address space. Each memory block can be specified using the memory mapping function as user (Target) or
emulator (SIMM memory module) and, in each case, the access can be specified as read-write, read-only, or
guarded.

The definition of each type of memory isasfollows:

Table3.1 Memory Types

Memory Type Description

On-chip Uses the MCU internal memory.

User Accesses the user system memory.

Emulator Accesses the emulator SIMM memory module.

The contents of a specified block of memory can be displayed using the memory function. The contents of
memory can be modified at any time, even during program execution and the results are immediately reflected in
all other appropriate windows.

Note that modifying memory contents during program execution has the following time requirements:

1. MCU interna ROM or RAM, or emulator SSIMM memory module
The emulator modifies the memory contents by temporarily switching the memory bus to the emulator side
without stopping the user program execution. Therefore, the emulator uses the memory bus for up to 80 psin
reading of 256 bytes (25 MHz, internal ROM).

2. MCU internal 1/0, DTCRAM, or user system memory
The emulator stops the user program execution, then modifies the memory contents. Therefore, the user
program stops for a maximum of 2 msin reading 256 bytes (25 MHz, emulation memory).
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332 Clocks

The clock can be specified as emulator internal clock or target clock. The frequenciesthat can be specified as
the emulator internal clock depend onthe MCU. For details, refer to section 8, Software Specifications Specific
to This Product.

333 Probes

External probes 1 and 2 (EXT1 and EXT2) can be connected to the emulator, to make use of signals on the user
system for break or trace. The signal for external probe 1 can be set as the condition for the event detection
system depending on the low or high level. Sincethe signal for external probe 2 outputs high level when the
trigger setting (1 to 4) condition is matched in the bus monitor function, the signal can be used for the trigger
condition for such as an oscilloscope.

3.4 Stack Trace Function

The emulator uses the stack’ sinformation to display the name of the calling function for afunction at which the
program counter is currently pointing. This function can be used only when the load module that has the
Dwarf2-type debugging information is loaded. For the usage of thisfunction, refer to section 6.17, Stack Trace
Function.

3.5 OnlineHelp

An online help explains the usage of each function or the command syntax that can be entered from the
command line window.

Select [Emulator Help] from the [Help] menu to view the emulator help.
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Section 4 Preparation before Use

41 Workspaces, Projects, and Files

Just as aword processor allows you to create and modify documents, HEW allows you to create and modify
workspaces. A workspace can be thought of as a container of projects and, similarly, a project can be thought of
as acontainer of project files. Thus, each workspace contains one or more projects and each project contains one
or morefiles. Figure 4.1 illustrates this graphically.

[~

WORKSPACE

PROJECT

PROJECT

Figure4.1 Workspaces, Projects, and Files

Workspaces allow you to group related projects together. For example, you may have an application that needs
to be built for different processors or you may be developing an application and library at the same time. Projects
can aso belinked hierarchically within aworkspace, which means that when one project is built al of its“child”
projects are built first.

We need to add a project to a workspace and then add files to that project before we can actually do anything.
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4.2 Method for Activating HEW
To activate the HEW, follow the procedure listed below.

1. Connect the emulator to the host computer.

2. Connect the user system interface cable to the connector of the emulator if you use the user system interface
cable. Thisis not necessary when you do not use the user system interface cable.

3. Turn on the emulator. Be sure to turn on the user system before supplying power to the emulator if you use
the user system.

4. Activate the HEW from [Programg] in the [Start] menu.

The [Welcome!] dialog box is displayed.

o

‘elcame!

— O ptionz: ok

' ‘Cieate a new project workspace Cancel

% ") Mpen arecent project workspace; Administration...

| i

[t

=

g {~ Browse to another project workspace

Figure4.2 [Welcome!] Dialog Box
[Create a new project workspace] radio button: Creates a new workspace.

[Open arecent project workspace] radio button: Uses an existing workspace and displays the history of the
opened workspace.

[Browse to another project workspace] radio button: Uses an existing workspace; this radio button is used when
the history of the opened workspace does not remain.

In this section, we describe the following three ways to start up the HEW:

* [Create anew project workspace] - atoolchain isnot in use

e [Create anew project workspace] - atoolchainisin use

e [Browse to another project workspace]

The method to create a new workspace depends on whether atoolchain isor isnot in use. Note that this emulator
product does not include atoolchain. Use of atoolchain is available in an environment where the H8S, H8/300

series C/C++ compiler package has been installed. For details on this, refer to the manua attached to the H8S,
H8/300 series C/C++ compiler package.
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421 Creating a New Workspace (Toolchain Not Used)

1. Inthe[Welcome!] dialog box that is displayed when the HEW is activated, select [Create a new project
workspace] radio button and click the [OK] button.

2%

— O ptionz: ok

' ‘Cieate a new project workspace Cancel

% ") Mpen arecent project workspace; Administration...

| i

Fl

g {~ Browse to another project workspace

Figure4.3 [Welcome!] Dialog Box
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2. Creation of anew workspace is started. The following dialog box is displayed.

Mews Proj ace 21

Frojects

Debugger only - EG000 Emul... [

Isample

Broject Name:

Isample

Cirectony:

IC: SHew 3 zample Browsze. |

LCPLU Farnily:
[ HB5 HB/300 =l

Toal chain:

INnne j

Froperties. .. |

Ok I Cancel

Figure4.4 [New Project Workspace] Dialog Box

[Workspace Name] edit box: Enter the new workspace name.

[Project Name] edit box: Enter the project name. When the project name is the same as the workspace name,
it needs not be entered.

[Directory] edit box: Displaysthe directory in which the workspace will be created. Click the [Browse...]
button to select a directory name or enter adirectory name in the [Directory] edit box.

Other list boxes are used for setting the toolchain; the fixed information is displayed when the toolchain has not
been installed.
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3. Makethe required setting for the toolchain. When the setting has been completed, the following dialog box
isdisplayed.

21|

— Targets
(w]wyyy EG000 Emulator GPL 2000

AO00 Emulator SR 2600

Taraet type : I."-‘-.II Targets j

< Back I Heut » I Finizh | Cancel |

Figure4.5 [New Project —Step 7] Dialog Box

The target for the session file used when the HEW is activated must be selected here. Check the box
against the target platform and then click the [Next] button. For details on the session file, refer to section
4.4, Debug Sessions.
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4. Set the configuration file name. The configuration file saves the state of HEW except for the emulator.

Target name ;

G000 E mulatar SPU 2000

Configuration name :
|Debug_yvyy E6G000_Emulator GP

— Detail options :

Item | Walue |

T ity |

< Back I Hewt » I Finizh | Cancel |

Figure4.6 [New Project — Step 8] Dialog Box

If multiple target platforms were selected in the [New Project — Step 7] dialog box shown in figure 4.5, set
the name of a configuration file for each of them, each time pressing the [Next] button to proceed to the next
target.

Setting of the configuration file nameis the end of the emulator settings.

Click the [Finish] button to display the [Summary] dialog box. Pressing the [OK] button activates the HEW.

5. After the HEW has been activated, the emulator is automatically connected. The message “ Connected” is
displayed on the [Debug] tab in the [Output] window to indicate the completion of connection.
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4.2.2 Creating a New Workspace (Toolchain Used)

1. Inthe[Welcome!] dialog box that is displayed when the HEW is activated, select [Create a new project
workspace] radio button and click the [OK] button.

2%

— O ptionz: ok

' ‘Cieate a new project workspace Cancel

% ") Mpen arecent project workspace; Administration...

| i

Fl

g {~ Browse to another project workspace

Figure4.7 [Welcome!] Dialog Box
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2. Creation of anew workspace is started. The following dialog box is displayed.

Mew Proj ace 2] x|
Frojects |
' ip N Wiorkspace Mame:
@ Azzembly Application ISEITII:'|E
o .

Demnnstlat.lnn_ Project Name:

@ Ermpty Application

1@ Import M akefile IS‘E"-'.":'I'3

ﬂ Library Cirectony:
ID:'\Hew3\sample Browsze. |
LCPLU Farnily:
[ HB5 HB/300 =l
Toal chain:
[ Hitachi HB5 HB/300 Standard =l

Froperties. .. |

Ok I Cancel

Figure4.8 [New Project Workspace] Dialog Box

[Workspace Name] edit box: Enter the new workspace name. Here, enter ‘test’.

[Project Name] edit box: Enter the project name. When the project name is the same as the workspace name,

it needs not be entered.

[Directory] edit box: Displays the directory in which a workspace will be created. Click the [Browse...]

button to select a directory or enter the name of a directory in the [Directory] edit box.

[CPU family] combo box: Select the target CPU family.

[Tool chain] combo box: Select the target toolchain name when using the toolchain. Otherwise, select
[None].

[Project type] list box: Select the project type to be used.

Notes: 1. When [Demonstration] is selected in the emulator, note the followings:
The [Demongtration] is a program for the simulator attached to the H8S, H8/300 compiler package.
To use the generated source file, delete the Printf statement in the sourcefile.
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3. Makethe required setting for the toolchain. When the setting has been completed, the following dialog box
isdisplayed.

21|

— Targets
(w]wyyy EG000 Emulator GPL 2000

AO00 Emulator SR 2600

Taraet type : I."-‘-.II Targets j

< Back I Heut » I Finizh | Cancel |

Figure4.9 [New Project —Step 7] Dialog Box

The target for the session file used when the HEW is activated must be selected here. Check the box against
the target platform and then click the [Next] button. For details on the session file, refer to section 4.4, Debug
Sessions.
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4. Set the configuration file name. The configuration file saves the state of HEW except for the emulator.

d B

Target name ;

Configuration name :

|Debug_yvyy E6G000_Emulator GP

— Detail options :

Item | Walue |

T ity |

< Back I Hewt » I Finizh | Cancel |

Figure4.10 [New Project — Step 8] Dialog Box

If multiple target platforms were selected in the [New Project — Step 7] dialog box shown in figure 4.9, set
the name of a configuration file for each of them, each time pressing the [Next] button to proceed to the next
target.

Setting of the configuration file nameis the end of the emulator settings.

Complete the creation of a new workspace according to the instructions on the screen. This activates the
HEW.

5. After the HEW has been activated, connect the emulator. However, it is not necessary to connect the
emulator immediately after the HEW has been activated.
Select either of the following two ways to connect the emulator: connecting the emulator after the setting at
emulator activation or without the setting at emulator activation. For details on the connection of the
emulator, refer to section 4.5, Connecting the Emulator.
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4.2.3 Selecting an Existing Workspace

1. Inthe[Welcome!] dialog box that is displayed when the HEW is activated, select [Browse to another project

workspace] radio button and click the [OK] button.

2| x]
— O ptionz:
" Create a new project workspace Cancel |
") Mpen arecent project workspace; Administration... |
= | ]
g ¢ Browse to another project workspace

Figure4.11 [Welcome!] Dialog Box

2. The[Open Workspace] dialog box isdisplayed. Select adirectory in which you have created a workspace.
After that, select the workspace file (.hws) and press the [Open] button.

21

Lok, jr: I@ zample j = IC:F -

sample

File name: |sample.hws Open I
Files of twpe: IWorkspaces [ hwz) j Cancel |
S

Figure4.12 [Open Workspace] Dialog Box

3. Thisactivates the HEW and recovers the state of the selected workspace at the time it was saved.
When the saved state information of the selected workspace includes connection to the emulator, the
emulator will automatically be connected. To connect the emulator when the saved state information does not
include connection to the emulator, refer to section 4.5, Connecting the Emulator.
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4.3 Setting at Emulator Activation

When the emulator is activated, the command chain can automatically be executed. It isalso possible to register
multiple load modules to be downloaded. The registered load modules are displayed on the workspace window.

1. Select [Debug Settings...] from the [Options] menu to open the [Debug Settings] dialog box.

Debug Settings ed b
IDefauItSession | Target | Options |
------ [ sample Target:

Default Debug Farmat:

<nones j
Download Modules:
File MName | Qffzet Address | Farm: Add...

l | i

Figure4.13 [Debug Settings] Dialog Box ([Target] Page)

2. Select the product name to be connected in the [Target] combo box.

3. Select the format of the load module to be downloaded in the [Default Debug Format] combo box, then
register the corresponding download module in the [Download Modules] list box.

4. Click the[Options] tab.
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IDefauItSession j Target Options
""" E sample Command batch file load timing:
I.&t target connection ﬂ

Command Line Batch Processing:

[~ Connect up to target o debug go
¥ Download modules after build

™ Resst CPU after download module

Cancel |

Figure4.14 [Debug Settings] Dialog Box ([Options] Page)

The command chain that is automatically executed at the specified timing is registered. The following three
timings are available:

* At connecting the emulator
* Immediately before downloading
* Immediately after downloading

Specify the timing for executing the command chain in the [Command batch file load timing] combo box. In
addition, register the command-chain file that is executed at the specified timing in the [Command Line Batch
Processing] list box.
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44 Debug Sessions

The HEW stores all of your builder optionsinto aconfiguration. In asimilar way, the HEW stores your
debugger optionsin asession. The debugging platforms, the programs to be downloaded, and each target
platform’ s options can be stored in a session.

Sessions are not directly related to a configuration. This means that multiple sessions can share the same
download module and avoid unnecessary program rebuilds.

Each session’s data should be stored in a separate file in the HEW project. Debug sessions are described in
detail below.

44.1 Selecting a Session
The current session can be selected in the following two ways:

* From the toolbar
Select a session from the combo box (figure 4.15) in the toolbar.

JJ g ||Debug j ||Defau|tSession j | Jt |@ P31 ‘

Figure4.15 Toolbar Selection

* From the dialog box
1. Select [Options -> Debug Sessions...]. Thiswill open the [Debug Sessions] dialog box (figure 4.16).

Debug sessions: ok

DefaultSession
Sessionyyyy_EG000_Emulatar_CP Cancel
Sessionwecs_EB000_Emulator_CP

|x

Add...
Bemove
Save as...

Eroperties

il

Current session:
Default5ession j

Figure4.16 [Debug Sessions] Dialog Box

2. Select the session you want to use from the [Current session] combo box.
3. Click the [OK] button to set the session.
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442 Adding and Removing Sessions
A new session can be added by copying settings from another session or removing a session.

e Toadd anew empty session

Select [Options -> Debug Sessions...] to display the [Debug Sessions] dialog box (figure 4.16).
Click the[Add...] button to display the [Add new session] dialog box (figure 4.17).

Check the [Add new session] radio button.

Enter a name for the session.

Click the [OK] button to close the [Debug Sessions] dialog box.

This creates a file with the name entered in step 4. If afile with this name already exists, an error is
displayed.

I A

Add new

Mame:
Cancel

21
' Add new session oK I

* Use an existing session file

M ame:

Isample
Session file path:

I Browze |

v ‘Open and maintain link to session fils

[~ Make session file link read only

Figure4.17 [Add new session] Dialog Box
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e Toimport an existing session into a new session file

1

ok w DN

6.

Select [Options -> Debug Sessions...] to display the [Debug Sessions] dialog box (figure 4.16).
Click the[Add...] button to display the [Add new session] dialog box (figure 4.17).

Check the [Use an existing session file] radio button.

Enter a name for the session.

Enter the file name of an existing session file that you would like to import into the current project or
click the [Browse...] button to select the file location.

If the [Open and maintain link to session file] check box is not checked, the imported new session fileis
generated in the project directory.

If the [Open and maintain link to session file] check box is checked, anew session fileis not generated in
the project directory but islinked to the current session file.

If the [Make session file link read only] check box is checked, the linked session fileis used as read-only.
Click the [OK] button to close the [Debug Sessions] dialog box.

¢ Toremoveasesson

1
2.
3.

4.

Select [Options -> Debug Sessions...] to display the [Debug Sessions] dialog box (figure 4.16).
Select the session you would like to remove.

Click the [Remove] button.

Note that the current session cannot be removed.

Click the [OK] button to close the [Debug Sessions] dialog box.

* Toview the session properties

1
2.
3.

Select [Options -> Debug Sessions...] to display the [Debug Sessions] dialog box (figure 4.16).
Select the session you would like to view the properties for.
Click the [Properties] button to display the [Session Properties] dialog box (figure 4.18).

sion Properties
Hame: Segzionmooo_ EE000_Emulator_CP { |
Location; C\Hew2hzamplet zampletS ezsionooc:_ EE000 c I
Lastmodiied:  17:37:11, Thursday, December 12, 2002 4”“3
[~ Eead only

214

Figure4.18 [Session Properties] Dialog Box

RENESAS




To make a session read-only

1

5.

Select [Options -> Debug Sessions...] to display the [Debug Sessions] dialog box (figure 4.16).

2. Select the session you would like to make read-only.
3.
4. Check the [Read only] check box to make the link read-only. Thisisuseful if you are sharing debugger-

Click the [Properties] button to display the [Session Properties] dialog box (figure 4.18).

setting files and you do not want data to be modified accidentally.
Click the [OK] button.

To save a session with a different name

1

ok w DN

Select [Options -> Debug Sessions...] to display the [Debug Sessions] dialog box (figure 4.16).

Select the session you would like to save.

Click the [Save as] button to display the [Save Session] dialog box (figure 4.19).

Specify the location to save the new file.

If you want to export the session file to another location, leave the [Maintain link] check box unchecked.

If you would like the HEW to use thislocation instead of the current session location, check the
[Maintain link] check box.

Click the [OK] button.

2%

Save_in:l@ zample j - IC:F -

|_1 Debug Sessionxoo _E000_Emulatar_CP.hsf
I_1 Debug_wwwy_ES000_Emulatar_CP

|1 Debug_seees_ES000_Emulatar_CP

-1 Release

DefaultSession.hsf

Sessionyyyy_E6O00_Emulator_CP.hsf

File name: | Save I
Save as upe: ISessions [*.hsf] j Cancel |

™ Maintain link

P

4.4.3

Figure4.19 [Save Session] Dialog Box

Saving Session Information

To save a session
Select [File -> Save Session)].

215
RENESAS




4.5 Connecting the Emulator
Select either of the following two ways to connect the emulator:

(a) Connecting the emulator after the setting at emulator activation

Select [Debug Settings...] from the [Options] menu to open the [Debug Settings] dialog box. It is possible to
register the download module or the command chain that is automatically executed at activation. For details
on the [Debug Settings] dialog box, refer to section 4.3, Setting at Emulator Activation.

When the dialog box is closed after setting the [Debug Settings] dialog box, the emulator will automatically
be connected.

(b) Connecting the emulator without the setting at emulator activation
Connect the emulator by simply switching the session file to one in which the setting for the emulator use has
been registered.

=loixi

Fils Edt View Project Options Buld Tools Window Help

DFdd |2 re2eliTallowoslasfcn o 2 | =] S & 5 [rl =7 |
& |8 e & o Alseriorzz o Emiao =% & (G 2 |[|Gfe & S 2 @ ||t &% 4 ||FEEDS ¢ HE

=l
=
B sample

E1-E3 € saurce file
dbscte
intpra.c
reselpra.c
samplee
sbrk.c

-3 Dependencies
sbrkh

stackseth

) I Projects | & Templates | <1 Mavigation

E|

4> T Build } Debug /Find in Files , ersion Cantrol /

Ready

ms T om

Figure4.20 Selecting the Session File

In thelist box that is circled in figure 4.20, select the session name including the character string that has been
set in the [Target name] text box in figure 4.10, [New Project — Step 8] dialog box. The setting for using the
emulator has been registered in this session file.

After the session name s selected, the emulator will automatically be connected. For details on the session file,
refer to section 4.4, Debug Sessions.
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4.6 Reconnecting the Emulator
When the emulator is disconnected, use the following way for reconnection:
Select [Build -> Debug -> Connect] or click the [Connect] toolbar button (5). The emulator is connected.

Note: Before reconnecting the emulator, aload module must be registered to the HEW. For registration, refer
to section 4.3, Setting at Emulator Activation.

4.7 Ending the Emulator
When using the toolchain, the emulator can be exited by using the following two methods:

» Canceling the connection of the emulator being activated
» Exiting the HEW

(1) Canceling the connection of the emulator being activated
Select [Disconnect] from the [Debug] menu or click the [Disconnect] toolbar button (- ).
(2) Exiting the HEW

Select [Exit] from the [File] menu.

A message box isdisplayed. If necessary, click the [Yes] button to save asession. After saving a session, the
HEW exits. If not necessary, click the [No] button to exit the HEW.

High-performance Embedd <5 x|
& Session has been modified - do wou want ko save it

es Mo | Cancel |

Figure4.21 [Session hasbeen modified] Message Box
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Section 5 Debugging
This section describes the debugging operations and their related windows and dialog boxes.
51 Setting the Environment for Emulation

511 Opening the [Configuration Properties] Dialog Box

Selecting [Options -> Emulator -> System...] or clicking the [Emulator System] toolbar button (IEI) opensthe
Configuration Properties] dialog box.

21x
General |
Device: |Jzer Signalz
EEICE: ¥ User Beset enable
Mode: I?' [advanced mode, single chip) j ¥ User NMI enable
¥ Sirgle chin made ™| Wser Standby enatile
g s ¥ User Bus Reguest enable
Clock: | Main10MHz, Subi32kHz =l
Tirner Resolution: |125ns j

Flash emon: Eontrol; I vl

¥ Enable read and wiite on the fly
¥ Break on access eror
™ Enable intermal ROM area write

User WECC Thisshold = 400V 4 | [ |

Diriver: |EBDDD LISE Driver
[ Change driver in start up

Ok, I Cancel |

Figure5.1 [Configuration Properties] Dialog Box ([General] Page)

This didog allows the user to set conditions for the target MCU before downloading a program to the emulator.
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[General] page

[Device] Selects the MCU to be emulated. To use an MCU not included in the list,
select CUSTOM to specify the functions required for this MCU. See the
hardware manual for details.

[Mode] Selects the MCU's operating mode.

[Clock] Selects the speed of the MCU'’s clock and sub-clock.

[Timer Resolution]

Selects the resolution of the timer for use in execution time measurement.
The value 20 ns, 125 ns, 250 ns, 500 ns, 1 us, 2 us, 4 us, 8 us, or 16 us
can be selected.

The timer for execution time measurement has a 40-bit counter.

At 20 ns the maximum time that can be measured is about six hours, and
at 16 ps the maximum time is about 200 days.

When the counter overflows, the maximum time possible for
measurement will be displayed with prompt “>” that indicates that the
counter has overflowed.

[Enable read and write on the
fly]

When this box is checked, it is possible to access the target system
memory while the user program is running. Do not check this check box if
you require realtime emulation.

[Break on access error]

When this box is checked, a break (the user program stops) occurs if
your program accesses a guarded memory area or writes to a write-
protected area.

[Enable internal ROM area write]

When this box is checked, writing to the internal ROM area is enabled.
For the result of writing, see the [Extended Monitor] window.

[User VCC Threshold]

Sets the voltage level for the user system.

[User Signals]

When this box is checked, the reset, NMI, standby, and bus request
signals from the user system are enabled.

[Driver]

Displays the E6000 driver that is currently installed.

[Change driver in start up]

When this box is checked, selection of a driver will be available next time
the emulator is connected.

Note: Theitemsthat can be set in this dialog box vary according to the emulator in use. For details, refer to
section 8, Software Specifications Specific to This Product, or the online help.
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512 Selectingan MCU Not Included in the List

Selecting [Custom] in [Device] of the [Configuration Properties] dialog box adds the [Custom Device] page to
the dialog box.

General  Custom Device

ROM: -
RéM:  |16kB |
Fin  [120128Pe |
Modules
¥ Enable DTC v Enable I A/D Converter
v
W Enable DA& Converter W Enable lICO ~ ;reg
Iz
W Enable Refresh Contraller v Enable [1C1 d
¥ Enable DMAL ¥ Enable w071 501 Select
W Enable TPU35 W Enable TMRZ-3 (" sCind
" SCI0-2
v Enable Piaitd14 " SCI0-3
W Enable MuliPracesserComunication [SCI11-4] * SCI0-4

Ok, | Cancel

Figure5.2 [Configuration Properties] Dialog Box ([Custom Device] Page)

Use this page to specify functions for an MCU not included in the list of MCUs. The items are adopted by the
device last selected.

[Custom Device] page

[ROM] Specify the internal ROM area size.

[RAM] Specify the internal RAM area size.

[Pin] Specify the product package.

[Modules] Check this box to validate internal peripherals.

Note: Theitemsthat can be set in this dialog box vary according to the emulator in use. Some emulators may
not support the [Custom Device] function. For details, refer to section 8, Software Specifications
Specific to This Product, or the online help.
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513 Selecting the I nterface to be Connected

Checking [Change driver in start up] on the [Configuration Properties] dialog box allows a selection of the driver
next time the emulator is connected.

EAQ00 Driver Details

Driver: (==

r— Details

Interface: IUSB interface ﬂ

Channel: IEBDDD USE Interface j

r— Configuratian

[Canfigure... |
[" Change driver in start up

Figure5.3 [Driver Details] Dialog Box
[Driver]: Selects the driver that connects the HEW and the emulator.
[Details): Setsthe details of the driver being connected.

[Interface]: The name of the interface to be connected. This should not be changed in this
emulator.

[Channdl]: Channel for the selected interface. This should not be changed in this emul ator.
[Configuration]: Driver setting.

[Configure...]: A dialog box for setting will be displayed when the driver supports the configuration
dialog. Note that thisitem is not available with this emulator.

[Change driver in start up]:
Checking this box selects the driver when the emulator is connected the next time.
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514 Opening the [Memory Mapping] Dialog Box

Selecting [Options -> Emulator -> Memory Resource...] or clicking the [Emulator Memory Resource] toolbar
button ) opens the [Memory Mapping] diaog box.

Mernory Mapping ﬂ J

*

Systern Memorny Resources From  To t apping Add...
SIhdbd M odule: J 00000000 - 00ZFFEE_On Chip Read-only
TMEB SikH fitted 00040000 - DOFFAFFF User Guarded
Fam Bases: OO0FFEO00 - DOFFEFBF On Chip Read-write
0 hiot wzed QOFFEFCO - OOFFFFFF User Guarded
1: nat uzed O0FFFE00 - DOFFFFFF O Chip Read-write Beset
2 not uged
3 not uged Close
[]

Target Device Configuration

00000000 - Q003FFFF Internal ROM J
DOFFEO0D - OOFFEFEF Internal RAR

DOFFF300 - QOFFFF3F Internal 10

DOFFFFG0 - DOFFFFBF Internal 10

OOFFFFCO - OOFFFFFF Internal RAM

|

Figure5.4 [Memory Mapping] Dialog Box

This diaog box displays the current memory map. The E6000 H8S or H8/300 series supports four blocks of user
memory. These can be 256 kbyte or 1 Mbyte each, depending on the SIMM fitted. Each block can be placed in
the address space on a 256-kbyte or 1-Mbyte boundary.

The memory mapping has agranularity of H'40 (D'64) byte. Each 64-byte block can be set to the internal
(emulation) or external memory and can be guarded (access-prohibited), write-protected or read-write.

The H8/300 series E6000 generally incorporates an emulation memory.

In the memory map, the memory can be set asan internal (emulation) or external, guarded (access-prohibited),
write-protected, or read/write in a byte unit.

[Add...]: Displays the [Edit Memory Mapping] dialog box, allowing the user to modify the address
range and attributes of a memory map.

[Modify...]: Displays the [Edit Memory Mapping] dialog box, allowing the user to modify the address
range and attributes of a memory map.

[Reset]: Resets the map memory to its default settings.

[Closg]: Closes the dialog box.

The memory configuration of the device being emulated is displayed by the [Memory] sheet in the [Status]
window.

Note:  Some emulators may not support the emulation memory or the memory mapping function. For details,
refer to section 8, Software Specifications Specific to This Product, or the online help.
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515 Changing the Memory Map Setting

Clicking the[Add...] button on the [Memory Mapping] dialog box or clicking the [Modify...] button after
selecting the information on the memory map setting you want to change opens the [Edit Memory Mapping]

dialog box.

Edit Memary Mapping llﬂ
Memony Mapping
i I Cancel |

To I

Setting: I On Chip Read-vwrite j

Figure5.5 [Edit Memory Mapping] Dialog Box

Use this dialog box to change the address range and attributes of a memory map.

[From]: Enter the start address of the map range.
[To]: Enter the end address of the map range.
[Setting]: Enter the memory map setting.

The choices given are listed below. The User (external memory) and Emulator (emulation
memory) attributes can be modified.
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On-chip Read-write (Cannot be changed)

On-chip Read-only (Cannot be changed)

On-chip Guarded (Cannot be changed)

User Read-write (Cannot be selected when the single chip mode is selected.)
User Read-only (Cannot be selected when the single chip mode is selected.)
User Guarded

Emulator Read-write

Emulator Read-only

Emulator Guarded
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5.2 Downloading a Program
This section describes how to download a program and view it as source code or assembly-language mnemonics.

Note: After abreak occurs, the HEW displays the location of the program counter (PC) on the editor. In most
cases, for example if an Elf/Dwarf2 based project is moved from its origina path (at the build), the
source file may not be automatically found. In thiscase, the HEW will open a source file browser dialog
box to alow you to manually locate the file. This path will then be used to update any other source files
in this debug project.

521 Downloading a Program
A load module to be debugged must be downloaded.

To download a program, select the load module from [Debug -> Download] or select [Download] from the
popup menu opened by clicking the right-hand mouse button on the load module in [Download modules] of the
[Workspace] window.

Note: Before downloading a program, it must be registered to the HEW as aload module. For registration,
refer to section 4.3, Setting at Emulator Activation.
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522 Viewing the Source Code

Select a source file name in the [Workspace] window and click [Open] in the popup menu to make the HEW
open the source filein the integrated editor. It isalso possibleto display your source files by double-clicking on
their names in the [Workspace] window.

w® Tutorial.cpp =10l =]
Qx00001038 wvolid tutorial{void) j
0=00001044 i

long a[l10]:;

long 3:

int 1i:

clas=s Samnple *p_sam;
0=00001046 | 4 |hg| @ p_=amn= Sample:;
0xz0000104e | +& g for{ i=0; 1<10; i++ }{
D=00001050 |-& (|2 j = rand():
0x00001058 |2 if{j < 03
0=0000105a |2 3 e Ca| S

b

0=0000105c | o> ali] = 7:

b
0=z00001070 p_=am—:sort(a):
0=0000107a p_samn—>change{a);
0=z00001082 p_san—:=0=a[0];
0=0000108a p_=samn—r=l=a[l]:; -

KN [

Figure5.6 Source Window
In thiswindow, the following items are shown on the left as information on lines.

e First column (Source address column): Displays the address information for the source line
e Second column (Event column): Event information (break)

e Third column (EXT.2 Trigger column): EXT.2 Trigger information

e Fourth column (Editor column): PC, bookmark, and breakpoint information

The Editor window is displayed in the right part of the Source window.
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Sour ce addr ess column

When a program is downloaded, an address for the current source file is displayed on the Source address column.
These addresses are hel pful when setting the PC value or a breakpoint.

Event column
The Event column displays the following items:
& - Address condition break by an event or arange channel
*®: Starts time measurement by an event channel
“&: Ends time measurement by an event channel
= Starts a point-to-point range trace
&' Ends a point-to-point range trace
" Hatstrace
These are also set by using the popup menu.
EXT.2 Trigger column
The EXT.2 Trigger column displays the following items:
;. EXT.2-1 trigger condition
#ha: EXT.2-2 trigger condition
. EXT.2-3 trigger condition
s EXT.2-4 trigger condition
"-: Two or more EXT.2 trigger conditions
It isalso possible to set them by using the popup menu.
Editor column
Editor column displays the following items:
O: A bookmark is set.
®: A PC Break is set.
=*: PC location
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To switch off acolumnin al sourcefiles

Right-click on the [Editor] window or select the [Edit] menu.

Click the [Define Column Format...] menu item.

The [Global Editor Column States] dialog box is displayed.

A check box indicates whether the column is enabled or not. If it is checked, the column is enabled. If
the check box is gray, the column is enabled in some files and disabled in others. Deselect the check box
of acolumn you want to switch off.

Click the [OK] button for the new column settings to take effect.

Global Editor Column Stakes

[WwE=T.2 Trigger

[w] Event
Editar Cancel |
[w] Source Address

Figure5.7 [Global Editor Column States] Dialog Box

2 To switch off acolumn in one sourcefile

1

2.

228

Click the right-hand mouse button on the [Editor] window which contains the column you want to
remove to display the popup menu.

Click the [Columns] menu item to display a cascaded menu item. The columns are displayed in this
popup menu. If acolumnisenabled, it hasatick mark next to itsname. Clicking the entry will toggle
whether the column is displayed or not.
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523 Viewing the Assembly-L anguage Code

If there is an address at the cursor position in the [Editor] window, selecting [Go to Disassembly] in the pop-up
menu opens the [Disassembly] window.

Thefirst address displayed in the [ Disassembly] window is the address where the cursor is placed in the [Editor]
window.

If you do not have a sourcefile, but wish to view code in the assembly-language level, either choose [View ->
Disassembly...], or click on the [Disassembly] window’ s toolbar button ).

embly =10] =]
© woid main(woid) ﬂ
24 while (13{
0o00103e 40FC ERA @ _main:8
26 ¥
27}
28
29 woid tutorial(woid)
tutorial 01006DF3 HOW L ER3, @-ER7
0000103C 01206DF4 STH.L (ER4-ERG ), @-5F
Qooo1040 79370028 SUB.W #¥H'0028,R7
a0 {
goooio44 OFF3 HOW L ER7 ER3
31l long a[107]:
32 long 3.
33 int 1i;
34 claz=s Sanple *p =am;
35
36 O =am= new Sample:
¢ 00001048 1A80 SUE.L ER0.ERD
Q0001048 SE0ODZ2000 JSR @Sample: (Samnplel): 24
oo0o0104C OF8E How . L ER0.ERE
a7 for({ i1=0; 1<10; i++ )4
0000104E 1944 SUEB.W R4 R4
38 7 = randi):
00001050 SEOOLIL1EE JSR @ _rand: 24 -
A a

Figure5.8 [Disassembly] Window

524 Modifying the Assembly-L anguage Code

Y ou can modify the assembly-language code by double-clicking on the instruction that you want to change. The
[Assembler] dialog box will be opened.

Assembler 2 x|

Addrezz Code Iremonic;
00001040 79370028 SUB. W

Ok, | Cancel |

Figure5.9 [Assembler] Dialog Box
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The address, instruction code, and mnemonic are displayed. Enter the new instruction or edit the old instruction
in the [Mnemonics] field. Pressing the [Enter] key will replace the memory content with the new instruction and
move on to the next instruction. Clicking the [OK] button will replace the memory content with the new
ingtruction and close the dialog box. Clicking the [Cancel] button or pressing the [Esc] key will close the dialog
box without modifying the memory contents.

Note: The assembly-language code being displayed is the current memory content. If the memory contents are
changed the [Assembler] dialog box and the [ Disassembly] window will show the new assembly-
language code, but the source file displayed in the [Editor] window will be unchanged. Thisis the same
even if the source file contains an assembler.

525 Viewing a Specific Address

When you are viewing your program in the [ Disassembly] window, you may wish to look at another area of your
program's code. Rather than scrolling through alot of code in the program, you can go directly to a specific
address. Select [Set Address...] from the popup menu, and the dialog box shown in figure 5.10 is displayed.

Set Address ﬂﬂ

Address

_main
Cahicel

i

Figure5.10 [Set Address] Dialog Box

Enter the address in the [Address] edit box and either click on the [OK] button or press the Enter key. A label
name can aso be specified as the address. The [Disassembly] window will be updated to show the code at the
new address. When an overloaded function or aclass name is entered, the [Select Function] dialog box opens for
you to select afunction. For details, refer to section 5.13.3, Supporting Duplicate Labels.

5.2.6 Viewing the Current Program Counter Address

Wherever you can enter an address or value into the HEW, you can also enter an expression. If you enter a
register name prefixed by the hash character, the contents of that register will be used asthe valuein the
expression. Therefore, if you open the [Set Address] dialog box and enter the expression #pc, the [Source] or
[Disassembly] window will display the current PC address. It also allows the offset of the current PC to be
displayed by entering an expression with the PC register plus an offset, e.g., #PC+0x100.
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53 Debugging with the Command Line I nterface

Use the [Command Line] window to enter text-based commands instead of window menus and commands.

531 Opening the [Command Line] Window

Choose [View -> Command Line] or click the [Command Line] toolbar button ) to open the [Command
Line] window.

wf- Carrmand Line:no batch File:na log Files 10| =]

Figure5.11 [Command Line] Window

Thiswindow allows the user to control the debugging platform by sending text-based commands. A series of
predefined command lines can be called from afile and the output can be recorded in a file. The command can
be executed by pressing the [Enter] key after the command isinput a the prompt (<) on the last line. For
information on the available commands, refer to appendix G, Command Lines, and the on-line help.

If available, the window title displays the current batch and log file names separated by colons.

Pressing the Ctrl + 1 or Ctrl + | keyson thelast line displays the command line previously executed.

532 Specifying a Command File

It is useful to use acommand file when a series of predefined command lines need to be executed. Create a
command file by atext editor and write necessary command lines. The default extension of acommand file
is.hdc.

Choose [Set Batch File...] from the popup menu to open the [Set Batch File] dialog box, in which the name of a
command file (*.hdc) can be specified. Clicking the [OK] button displays the specified command file name as
the window title. Clicking the [Cancel] button closes the dialog box without changing the setting.
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Set Batch File EHE3

|| [ 3 Browse,. ok

Cance| |

Figure5.12 [Set Batch File] Dialog Box

533 Executing a Command File

Click the [Play] button in the [Set Batch File] dialog box or choose [Play] from the popup menu to execute the
command file. The [Play] menuisdisplayed in gray while the file is running and can be used when the command
file execution stops and control returns to the user.

534 Stopping Command Execution

Choose [Stop] from the popup menu to stop command execution. The [Stop] menu becomes valid during
command execution.

535 Specifyinga Log File

Choose [Set Log File...] from the popup menu to open the [Open Log File] dialog box, in which alog fileto
store the command execution results can be specified.

Open Log File EHE

Loge File:

I LI Browse,. | —

Figure5.13 [Open Log File] Dialog Box

Enter the name of alog file (*.log). The logging option is automatically set and the name of the fileis shown on
the window title bar.

Opening apreviouslog file will ask the user if they wish to append or overwrite the current log.

5.3.6 Starting or Stopping L ogging

Choose [Logging] from the popup menu to toggle logging to file on and off. When logging is active, the button
becomes effective. Note that the contents of the log file cannot be viewed until logging is completed, or
temporarily disabled by clearing the check box. Re-enabling logging will append to the log file.

5.3.7 Entering a Full Path to the File

It is recommended that the full path to afile is specified as afile name in the [Command line] window because
the current directory can be moved. However, care must be taken to enter the correct full path to afilewhenitis
entered from the keyboard. To save thistrouble, a full path can be easily specified by browsing through files.
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Choose [Browse...] from the popup menu to open the [Browse] dialog box. Select afile and click [Open] to paste
the full path to the selected file to the cursor location. This option can only be used when the cursor islocated on
thelast line.

5.3.8 Pasting a Placeholder

Select a placeholder from the [Placeholder] submenu in the popup menu to paste the selected placeholder to the
cursor location. This function is only available when the cursor islocated on the last line.
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54 Viewing the Registers

If you are debugging at assembly-language level, then you will find it useful to see the contents of the CPU's
general registers. Y ou can do this by using the [Register] window.

54.1 Opening the [Register] Window

To open the [Register] window, choose [View->CPU->Registers] or click the [Register] toolbar button ).
The [Register] window opens showing all of the CPU's general registers and the values, displayed in
hexadecimal.

eqister B [
|Reglster Hane IRegister Value |
RO H'00000000
RL H'00000000
RZ2 H'00000000
R3 H'00000000
R4 H'00000000
RS H'00000000
RGO H'00000000
R7 H'000000L0
PC H'000000
CCE H'E0 I0------
4 H'07 === 111

Figure5.14 [Register] Window

54.2 Expanding a Bit Register

If aregister is used as a set of flags at the bit level for the control of state, its one-character symbol rather than its
state indicate each bit. Double-click on the register’s name to display the [Register] dialog box and switch each
bit on or off. Checking the box for any bit specifiesit as holding a 1, while removing the check specifiesit asaO.

Walue:

[ lImaszk. ﬂ

[ Uzer/Imazk Cancel |
[ Half-carmy

[ 1zer LI

Figure5.15 Expanding a Bit Register
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543 Choosing a Register to be Displayed

To choose aregister to be displayed in the [Register] window, choose [Settings...] from the pop-up menu. This
dialog box is shown in figure 5.16.

Setkings ﬂ ﬂ

Reaqizsters:

ERD L
[WIER1

Egg Cancel |
WIER4

[WIERG

WIERE

WIERT

[wIFC

[WICCR

Figure5.16 [Settings] Dialog Box

5.4.4 Splitting Up the Window Display

To vertically divide the [Register] window display into two, select [Split] from the pop-up menu and move the
split-up bar.
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545 Modifying Register Contents
To change aregister's content, open the [Register] dialog box in one of the following methods:

» Double-click the register you want to change.
» Select the register you want to change, and choose [Edit...] from the popup menu.

Reqgister - [ERO] 7] x|

Walue:

|H'uuuuuuuu
Setds: Cancel |

IWhnIe Regizter j

Figure5.17 [Register] Dialog Box

Y ou can enter anumber or C/C++ expression in the [Value] field. Y ou can choose whether to modify the whole
register contents, a masked area, floating or flag bits by selecting an option from the combo box (the contents of
thislist depend on the CPU model and selected register).

When you have entered the new number or expression, click the [OK] button or pressthe [Enter] key; the dialog
box closes and the new value is written into the register.

5.4.6 Using Register Contents

Use the value contained in a CPU register by specifying the register name prefixed by the “#" character, e.g.:
#R1, #PC, #R6L, or #ER3 when you are entering a value elsewhere in the HEW, for example when displaying a
specified addressin the [ Disassembly] or [Memory] windows. Available register names depend on the target
MCU being emulated.

54.7 Saving the Currently Displayed Contents

The contents currently displayed in the window can be saved in atext file. Select [Save to File...] from the pop-
up menu.
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55 Operating Memory

This section describes how to control memory contents, such as viewing amemory areain different formats,
filling and moving amemory block, and loading and verifying aload modulefile.

55.1 Viewinga Memory Area

Tolook at a memory area, choose [View -> CPU ->Memory...] or click the[View Memory] toolbar button
to open the [Memory] window. Thiswill open the [Format] dialog box shown in figure 5.18.

Jed
LCancel |

End:

|H'DDDDDDFF

Format:
[Byte (x1) =l

Dizplay Walue As:
I.&NSI character j

Bytez Count For One Line:
[16 Byte =l

Figure5.18 [Format] Dialog Box

Enter the range you want to display as an address value or an equivalent symbol in the [Begin] and [End] fields.
Select the data size and format for the display from the [Display Value As] and [Format] drop-down lists,
respectively. Select the number of bytes displayed in one line from the [Bytes Count For One Line] drop-down
list. Click the [OK] button or press the Enter key, and the dialog box closes and the [Memory] window opens.
The display can be scrolled within the range of the entered display start and end addresses.
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Ox00000000
Ox00000010
Ox000000zZ0
Ox00000030
Ox 00000040
Ox00000050
0x00000060
0x00000070
0x00000080
0x00000030
0x000000A0
0x000000E0
Ox000000CO
0x 00000000
0x000000ED
0x000000F0

oo
4B
oz
F3
S0
CEB
co
T4
41
ac
o1
0z
oo
F3
o1
55

Figure5.19 [Memory] Window

Note: Each item in the [+n] column is called as the memory unit.

There are three display columns:

[Address]:

[+n]

[Value]:

First address of the memory data displayed on this row.

Memory data read from [Address] and ‘n’ means the offset value from thefirst address of the
row. Datais read from the debugging platform’s physical memory in the access width, and then
converted to the display width.

Datadisplayed in an aternative format.

55.2 Displaying Data in Different Formats

If you want to change the display format of the [Memory] window, select [Format] from the popup menu. The
dialog box shown in figure 5.20 is displayed.

Jed
LCancel |

[H'Do0000FF

Format:

[Byte (x1) =l
Dizplay Walue As:

I.&NSI character j

Bytez Count For One Line:
[16 Byte =l

Figure5.20 [Format] Dialog Box

To display and edit memory in different widths, use the [Display Data As| combo box. For example, choose the
[Byte] option and the display will be updated to show the memory area asindividual bytes.
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The data can be converted into different formats, as shown in the [Value] column. The list of formats depends on
the data selection.

To change the number of bytes displayed on one line, use the [Bytes Count For One Line] drop-down list. For
example, choose the [8 Byte] option and the display will be updated to show the 8-byte data on oneline.

553 Splitting Up the Window Display

To vertically divide the [Memory] window display into two, select [Split] from the popup menu and move the
split-up bar.

55.4 Viewing a Different Memory Area

To change the memory area displayed in the [Memory] window, use the scroll bars. To quickly look at a new
address, use the [Format] dialog box. This can be opened by choosing [Format] from the popup menu.

Enter the new address value, and click the [OK] button or press the [Enter] key. The dialog box closes and the
[Memory] window display is updated with the data at the new address. When an overloaded function or a class
name is entered, the [Select Function] dialog box opens for you to select a function.

555 Modifying the Memory Contents

The memory contents can be modified via the [Edit Memory] dialog box. Move the cursor on the memory unit
(according to the [Memory] window display choice) that you wish to change. Either double-click on the memory
unit or press the [Enter] key. The dialog box shown in figure 5.21 is displayed.

Current W alue:

[HFF

LCancel |
Mew W alue:

Figure5.21 [Edit Memory] Dialog Box

A number or C/C++ expression can be entered in the [New Value] field. After you have entered the new number
or expression, click the [OK] button or pressthe [Enter] key. Then the dialog box closes and the new valueis
written into memory.

The memory contents can a so be modified by moving the cursor on the memory unit and entering the new value
in hexadecimal through the keyboard.

55.6 Selectinga Memory Range

If the memory address range isin the [Memory] window, you can select the range by clicking on the first
memory unit (according to the [Memory] window display choice) and dragging the mouse to the last unit. The
selected range is highlighted.
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55.7 Finding a Valuein Memory

To find avaue in memory, open the [Memory] window and select [Search...] from the popup menu or from the
[Memory] drop-down menu. The [Search Memory] dialog box shown in figure 5.22 is displayed.

Data:

Search Data ds:
IEly'te 1) LI

[+ Search Egual Data I~ Search Backward

Figure5.22 [Search Memory] Dialog Box

Enter the start and end addresses of the range in which to search and the data value to search for, and select the
search format. If pattern search is selected as the search format, a byte string of up to 256 bytes can be searched
for. The end address can aso be prefixed by aplus (+); the end address will become the (start address) + (entered
value).

Search conditions other than pattern search are data match/mismatch and search direction. Note that only data
match and forward direction can be selected with pattern search.

Click the [OK] button or press the Enter key. The dialog box closes and the HEW searches the range for the
specified data. If the datais found, it is highlighted.

If the data could not be found, the [Memory] window display remains unchanged and a message box informing
that the data could not be found is displayed.

If [Search Next] is selected from the popup menu in the state where data has been found, the search will continue
from the next address.
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55.8 Fillinga Memory Areawith a Value
A value can be st as the contents of a memory address range using the memory fill function.

To fill amemory range with the same value, select [Fill...] from the popup menu of the [Memory] window or
from the [Memory] drop-down menu. The [Fill Memory] dialog box is shown in figure 5.23.

21x
I LCancel |
End:
Data:
Format:
[Byte (x1) =l
[~ Werify

Figure5.23 [Fill Memory] Dialog Box

If an address range has been selected in the [Memory] window, the specified start and end addresses will be
displayed. Select aformat from the [Format] combo box and enter the datavalue in the [Data] field. On clicking
the [OK] button or pressing the [Enter] key, the dialog box closes and the new value is written into the memory
range.

5.5.9 CopyingaMemory Area

Y ou can copy a memory area using the memory copy function. Select [Copy...] from the popup menu of the
[Memory] window or from the [Memory] drop-down menu. The [Copy Memory] dialog box is opened (figure
5.24).

Begir:
|

I Cancel |
End:

Degtination:

Format:

IEly'te 13 :I

I~ Werify

Figure5.24 [Copy Memory] Dialog Box
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The source start address and end address selected in the [Memory] window will be displayed in the [Begin] and
[End] fields. Checking the [Verify] check box enables copying while comparing the copy source and copy
destination. The copy unit can be selected in the [Format] combo box. Enter the destination start addressin the
[Destination] field and click the [OK] button or press the [Enter] key. Thiswill close the dialog box and copy the
memory block to the new address.

55.10 Savingand VerifyingaMemory Area

A memory areain the address space can be saved into a disk file using the memory save function. Open the
[Save Memory As] dialog box by choosing [File -> Save memory...].

e Memory 4s ﬂﬂ
IBinar_l,J j
Cahicel |

File name:
| =1

Start address:
IH'DDDDDDDD

End Address:
[HD0OFFFFF

ACCess size

|‘| vI

Figure5.25 [Save Memory As] Dialog Box

Enter the start and end addresses of the memory block that you wish to save, and a name and format for the file.
The [File name] combo box contains the previous four file names used for saving memory.

Clicking the[...] button can open the standard [File Save As] dialog box. On clicking the [OK] button or
pressing the [Enter] key, the diaog box closes and the memory block will be saved into the disk as afile of the
specified format type. The access size for saving data can be selected from the [Access Size] drop-down list.
When the datais saved in memory with little endian, the order of data depends on the access size.
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A memory areain the address space can be verified using the memory verify function. Open the [Verify
Memory] dialog box by choosing [File -> Verify Memory...]. The access size at verification can be selected from
the [Access Size] drop-down list.

21x
-
Cahicel |
File name:

| =1
Offget address:

Arccess size:

|‘| vI

Figure5.26 [Verify Memory] Dialog Box

55.11 Disabling Update of the Window Contents

Automatic update of the [Memory] window contents, which is performed when user program execution stops
and in other cases, can be disabled. Thisisdone by checking [Lock Refresh] in the popup menu. The [Memory]
window will be grayed.

5.5.12 Updating the Window Contents

The [Memory] window contents can be forcibly updated. Thisis done by checking [Refresh] in the popup menu.
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55.13 Comparing the Memory Contents

The contents of two memory blocks can be compared. Open the [Compare Memory] dialog box by selecting
[Memory -> Compare...] from the main menu or by selecting [Compare...] from the popup menu of the
[Memory] window.

Compare Memary

Start Compare:

Format:

I Buwte 13 LI

Figure5.27 [Compare Memory] Dialog Box

Enter the comparison format ([Format]), the start address ([Begin]) and end address ([End]) of the source
memory area, and the start address ([ Start Compare]) of the destination memory area. If the memory block is
aready highlighted in the [Memory] window, the start and end addresses will be automaticaly filled in when the
[Compare Memory] dialog box is opened.

If there is amismatch, the address where it was found is displayed in a message box.
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55.14 LoadingaMemory Areafrom aFile

A file can be loaded to the debugging platform’s memory. Select [Load...] from the popup menu of the
[Memory] window to open the [Load Program] dialog box.

Load Program 2 x|

File name:

Qffzet address:
|H'nnnnnnnn

Access size:
I‘] vl

[~ Perform memory verify during download

Figure5.28 [Load Program] Dialog Box

Enter the file format ([Format]) and the file name ([File name]). If the load address value is to be changed, enter
the offset value in the offset field ([Offset address]), otherwise enter zero.
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5.6 Viewing the /O Memory

A microcomputer containsinterna periphera modules. The exact number and type of peripheral modules differ
between devices but the typical modules are a DMA controller, serial communicationsinterface, A/D converter,
integrated timer unit, bus state controller, and watchdog timer. Registers that are mapped to the microcomputer’s
address space controls the internal peripheral modules.

The [Memory] window enables you to look at datain continuous memory addresses as byte, word, longword,
single-precision floating-point, double-precision floating-point, or ASCII values. However, registers of different
sizes are dlocated to non-continuous memory addresses in the 1/0O memory. To handle this memory, the HEW
has the [10] window to facilitate checking and setting up of these kinds of registers.

56.1 Opening the [IO] Window

To open the [I10] window, select [View -> CPU -> 10] or click the [View Q] toolbar button ). Modules that
match the internal peripheral modules organize the 1/O register information. When the [10] window is first
opened, only alist of module namesis displayed.

OO0FEEDE?
OO0FEEDES

#-[1] Interrupt Controller
#-[1] Bus_Controller

#-[]] Data Transfer Control
F-[1] If0 Port_1

F-[1] If0_Port_3

F-[1] If0_Port_4

H-[1] If0_Port_7

F-[1] If0_Port_3

F-[1] If0 Port R

#-[1] If0_Port_B

F-[1] If0_Port_C

.77 TAN Dot N =
1| | 2]

Figure5.29 [IO] Window

5.6.2 Expanding the I/O Register Display

To display the names, addresses, and values of the 1/0 registers, click the [+] mark at the left of the module name
or select the module name by clicking on it or using the cursor keys and press the [->] key. The module display
will expand to show theindividual registers of that peripheral module and their names, addresses, and values.
Clicking the [-] mark at the left of the expanded module name or pressing the [<-] key will close the I/O register

display.

For adisplay in the bit level, click the [+] mark at the left of the register name or select the register name by
clicking on it or using the cursor keys and pressthe [->] key. The register display will expand to show the names
of register bits and values. Clicking the [-] mark at the left of the expanded register name or pressing the [<-] key
will close the register bits display.
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5.6.3 Manually loading an 10 file

To manually load an 10 fileright click on the [IO] window and select the “Load 1O file...” menu item on the IO
window pop-up. A standard file browser isinvoked. Simply select the file you require to load and click OK.
ThelO file will be loaded into the window.

5.6.4 M odifying the I/O Register Contents

To edit the valuein an |/O register, double-click or press the [Enter] key on the register to open a dialog box to
modify the register contents. When you have entered the new number or expression, click the [OK] button or
press the [Enter] key; the dialog box closes and the new value is written into the register.

5.6.5 Saving the Currently Displayed Contents

The contents currently displayed in the window can be saved in atext file. Select [Save to File...] from the pop-
up menu.
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5.7 Viewing the Current Status

Choose [View -> CPU -> Status] or click the [View Status] toolbar button (i) to open the [Status] window and
see the current status of the debugging platform.

_|ol x|
Ttem I Etatus I

Target Device Configquration oooooooo - O001FFFF  Internal RBOIM
OOFFEOOO - OOFFEFEF Internal BAM
OOFFF200 - OOFFFF3F Internal IO
OOFFFFEO - OOFFFFEF Internal IO
OOFFFFCO - OOFFFFFF Internal BAM
System Memory Resources STMM Module:
1IME SIMM fitted
Bam Bases:
0: not used
1: not used
Z: not used
2: not used

Program Name Memory Loaded hrea

- ..ator_cpiTutorial. abs H'Oooooooo - H'OoOoooooz
H'O0000400 - H'000004Z5
H'O000l000 - H'OOOOLEFS
H'O0O0Z000 - H'0000Z139

| 4] %' Memony £ Flatiorm } Events f

Figure5.30 [Status] Window

The [Status] window has three sheets:

e [Memory] sheet
Contains information about the current memory status including the memory mapping resources and the
areas used by the currently loaded object file.

» [Platform] sheet
Contains information about the current status of the debugging platform, typically including CPU type and
mode; and run status.

e [Events] sheet
Contains information about the current event (breakpoint) status, including resource information.

Note: Theitemsthat can be set in this dialog box vary according to the emulator in use. For details, refer to
section 8, Software Specifications Specific to This Product, or the online help.
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5.8 Reading and Displaying the Emulator Information Regularly

Use the [Extended Monitor] window to know the changing information on the emulator no matter the user
program isrunning or hated.

Note:  The Extended Monitor function does not affect the execution of the user program since it monitors the
user system or the signal output from the MCU in the emulator by using the emulator’s hardware circuit.

58.1 Opening the [Extended Monitor] Window

Selecting [View -> CPU -> Extended Monitor] or clicking the [Extended Monitor] toolbar button displays
thiswindow. Theinterval of updating the display is approximately 100 ms during user program execution or
1,000 ms while breaking, respectively.

=10l x|
Item Value I
Uzer Standby Inactive
User NMI Inactive
User Reset Inactive
User Wait Inactive

Uzer System Voltage 0OE
Uzer System VoltageZ Dowm

User Cable Not Commected
Punning status Ereak = Ready
DOM Write No

Target Made 7

Target Clock No Clock
Target Sub Clock No Clock

Figure5.31 [Extended Monitor] Window
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5.8.2 Selecting Itemsto be Displayed

Selecting [Properties...] from the popup menu displays the [Extended Monitor Configuration] dialog box.

nided Monitor Configuration
— pdate millzecaond
Bunning: 100 Breal: I 1000
Settingz:
Item | Walue -
Uger Standby Inactive
Lzer MM Inactive
Usger Reset Inactive
1 zer W ait Inactive
Usger Syztem Yolage ok |
Uzer Syztem Voltage2 Do
Usger Cable Mot Connected
Running ztatus Break = Ready _ILI
<] | »

Figure5.32 [Extended Monitor Configuration] Dialog Box
This diaog box allows the user to set the items to be displayed in the [Extended Monitor] window.

Note: Theitemsthat can be set in this dialog box vary according to the emulator in use. For details, refer to
section 8, Software Specifications Specific to This Product, or the online help.
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5.9 Displaying Memory Contentsin Realtime

Use the [Monitor] window to monitor the memory contents during user program execution. In the Monitor
function, the realtime operation is retained since the bus monitoring circuit of the emulator sets the read/write
signal of the MCU as atrigger and holds the address bus and data bus values to update the displayed contents of
the memory.

Up to eight points can be set by using the eight monitoring channels on the bus monitoring circuit. 1 to 256 bytes
can be monitored at one point. It is possible that a part or all of monitoring ranges is overlapped.

Note: Monitoring isimpossible for an area, such as an internal timer counter, where no interna read/write
signal is generated to update avalue.

591 Opening the [Monitor] Window

To open the [Monitor] window, select [View -> CPU -> Monitor -> Monitor Setting...] or click the [Monitor]
toolbar button ) to display the [Monitor Settings] dialog box.

Manitor Setting ﬂ ﬂ
Monitor Setting |
Name: |manitart
— Optionz
Address: IH'DDFFEF&D
Size [byte]: |H'2D =]
Access [Format]: IEYTE [BSCI ﬂ

v Auto-Refresh at rate [mz) : ID'EIEIEEIU

[+ Reading the Initial ¥alus

— Color
LChange Indicator: Il:hange j
Foreground: [N |~ Background: |:||v|
[ Maptly
— Detail
IDETﬁIL HOT SUFFPORTED! Detail |
— Higtony

| [ |
Ok, I Cancel |

Figure5.33 [Monitor Setting] Dialog Box
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[Name]:

[Optiong]:

[Coalor]:

[Detail]:

[History]:

[Address]:

[Size]:

[Access):

[Auto-Refresh at rate (ms)]:

[Reading the Initia Value]:

[Change Indicator]:

[Foreground]:
[Background)]:

[Mayfly]:

Decides the name of the monitor window.

Sets monitor conditions.

Sets the start address for monitoring.

Sets the range for monitoring.

Sets the access size to be displayed in the monitor window.

Setsthe interval for acquisition by monitoring (500 ms at minimum).

Selects reading of the values in the monitored area when the monitor
window is opened.

Sets the method to update monitoring and the attribute of colors.

Selects how to display the values that have changed during monitoring
(available when [Reading the Initial Value] has been selected).
No change: No color change.

Change: Color is changed according to the [Foreground] and [Background]
options.

Gray: Those data with values that have not been changed are displayed in
gray.

Appear: A valueisonly displayed after changed.

Sets the color used for display (available when [Change] has been selected).

Sets the background color (available when [Change] has been selected).

A check in this box selects restoration of the color of those data which have
not been updated in a specified interval to the color selected in the
[Background] option. The specified interval istheinterval for monitor
acquisition (available when [Change], [Gray], or [Appear] has been selected).

Sets the items specific to the emulator. Not used with this emulator.

Displays the previous settings.

Notes: 1. Inthisemulator, odd addressees cannot be specified as the start addresses for monitoring.
2. Selection of the foreground or background color may not be available depending on the operating

systemin use.

After setting, clicking the [OK] button displays the [Monitor] window.
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«f-monitar: monitorl - HOOFFEFAD = IDIﬂ

address | 40| #1| +2 | +3] +a| +5] 45| 47| Value |
0xOOFFEFAD 00 00 10 23 00 00 08 93 ... ...
0xOOFFEFAE 00 02 12 24 00 00 00 00 ...§....
0xOOFFEFED 57 70 00 00 00 0Ol 80 74 Wp..... &
0xOOFFEFEE 00 00 10 36 00 00 04 1E ...6....

Figure5.34 [Monitor] Window
During user program execution, the display is updated according to the setting value of the auto-update interval.

Note:  Select [Refresh] from the popup menu when datais not displayed correctly after changing the address or
content of memory.

5.9.2 Changing the Monitor Settings

Selecting [Monitor Setting...] from the popup menu of the [Monitor] window displays the [Monitor Setting]
dialog box, which alows the settingsto be changed.

Colors, the size of accesses, and the display format can be easily changed from [Color] or [Access] of the popup
menu.

593 Temporarily Stopping Update of the M onitor

During user program execution, the display of the [Monitor] window is automatically updated according to the
auto-update interval. Select [Lock Refresh] from the popup menu of the [Monitor] window to stop the update of
display. The characters in the address section are displayed in black, and the update of display is stopped.

Selecting [Lock Refresh] again from the popup menu cancels the stopped state.

5.9.4 Deleting the Monitor Settings

Selecting [Close] from the popup menu of the [Monitor] window to be deleted closes the [Monitor] window and
deletes the monitor settings.

595 Monitoring Variables
Using the [Watch] window refersto the value of any variables.

When the address of the variable registered in the [Watch] window exists within the monitoring range that has
been set by the Monitor function, the value of the variable can be updated and displayed.

This function allows checking the content of a variable without affecting the realtime operation.

For the [Watch] window, refer to section 5.14.3, [Watch] Window.
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5.9.6 Hiding the [Monitor] Window

When using the Monitor function to monitor the value of a variable from the [Watch] window, hide the
[Monitor] window for the effective use of the screen.

The current monitoring information is listed as the submenu when selecting [Display -> CPU -> Monitor]. The
list consists of the [Monitor] window name and the address to start monitoring.

When the left of the list is checked, the [Monitor] window is being displayed.

Selecting items of the [Monitor] window you want to hide from the monitor setting list displays no [Monitor]
window and removes the check mark at the |eft of the list.

To display the [Monitor] window again, select the hidden the [Monitor] window.

[ 2 Monitor Setting... Shift+Chil+E

| v monitor2 - HODFFEODS
monitor] - H'OOFFEFS0

Windows Select. .

Figure5.35 Monitor Setting List

59.7 Managing the [M onitor] Window

Selecting [Display -> CPU -> Monitor -> Windows Select...] displays the [Windows Select] dialog box. In this
window, the current monitoring condition is checked and the new monitoring condition is added, edited, and
deleted in succession.

Selecting multiple monitoring conditions enables atemporary stop of update, hiding, and deletion.

Name Address
monitor2 H'00FFBODS
monitorl H'00FFEF80

Add...

Edit...

Lock Refresh?

Hide?

Bemove

Close |

Figure5.36 Selectionin the[Monitor] Window
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[Add]: Adds a new monitoring condition.

[Edit]: Changes the settings of the selected [Monitor] window (disabled when selecting multiple
items).
[Lock Refresh/Unlock Refresh]:

Automatically updates or stops updating the display of the selected [Monitor] window.
[Hide/UnHide]: Displays or hides the selected [Monitor] window.
[Remove]: Removes the selected monitoring conditions.

[Close]: Closes this dia og box.

RENESAS
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510 ViewingtheLabels

When the user program that includes the debugging information is loaded, the labels are registered at that time.
The [Disassembly] window shows the first eight characters of each label instead of the corresponding address or
as apart of an instruction operand.

Note:  When alabel value matches an operand, the corresponding instruction operand is replaced by the label.
If two or more |abels have the same value, the one that comes first in alphabetical order is displayed.

5.10.1 ListingLabes

Choose [View -> Symbol -> Labels] or click the [View Labels] toolbar button ) tolist al labels defined in
the current debug session.

e

EP I Address I Name -
H'00001000 _sbrk
H'00001034 _main
H'00001038 tutoriall)
H'00001104 _ahort
H'0o0ool1oc _ INITECT
H'0000Ll1zZ loopl
H'0000Ll1zC loopZ
H'000011ZE next_loopZ
H'00001132 next_loopl
H'00001144 loop3
H'0000Ll152 loopd
H'00001153 next_loopd
H'0000115C next_loop3
H'oooolles operator newiunsigned long!
H'0000L11EE _ CALL_INIT
H'0000L1ED _ CALL_END
H'Q00011E4 operator delete(void *)
H'0000L1EE _rand
H'0000lZze _srand
H'00001Z32 $DIVLE3
H'00001z3C not_negx -

A | v

Figure5.37 [Label] Window

Y ou can view symbols sorted either alphabetically (by ASCII code) or by address vaue by clicking on the
respective column heading.

Double-clicking in the [BP] column can set or clear a software breakpoint at the start of the function.
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5.10.2 Addingalabel

Choose [Add..] from the popup menu and open the [Add Label] dialog box to add alabel:

Add Label HE

MHame: || ;I oK I
Address: [HonAanonD =l Gancel |

Figure5.38 [Add Label] Dialog Box

Enter the new label name into the [Name] field and the corresponding value into the [Address] field and press
[OK]. The[Add Label] dialog box closes and the label list is updated to show the new label. When an
overloaded function or a class name is entered in the [Address] field, the [Select Function] dialog box opens for
you to select afunction. For details, refer to section 5.13.3, Supporting Duplicate Labels.

5.10.3 Editingalabel

Choose [Edit...] from the popup menu and open the [Edit Label] dialog box to edit alabel:

Edit Label _main

Mame: |_ma in ;I QK I

Address: [HonaaoToT2] | Gancel |

Figure5.39 [Edit Label] Dialog Box

Edit the label name and value as required and then press [OK] to save the modified version in the label list. The
list display is updated to show the new label details. When an overloaded function or a class nameis entered in
the [Address] field, the [Select Function] dialog box opens for you to select a function. For details, refer to
section 5.13.3, Supporting Duplicate Labels.
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5.104 DeletingalLabel

To delete alabel, select the label and choose [Delete] from the popup menu. A confirmation message box
appears:

Confirmation Feg

Delete Label BTEL

I~ Don't ask this question again

0K I Cancel i

Figure5.40 Message Box for Confirming L abel Deletion
If you click [OK], the label is removed from the list and the window display is updated. If the message box is not
necessary then check the [Don't ask this question again] check box.
5.105 Deleting All Labels

To delete all the labels from the list, choose [Delete All] from the popup menu. A confirmation message box
appears:

Confirmation Fequest

Delete All Labels

I Don't ask this question asain

Figure5.41 Message Box for Confirming All Label Deletion

If you click [OK], al the labels are removed from the HEW system’s symbol table and the list display will be
cleared. If the message box is not necessary then check the [Don’'t ask this question again] check box.
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5.106 LoadingLabelsfrom aFile

A symbol file can be loaded and merged into the HEW's current symbol table. Choose [Load...] from the popup
menu to open the [Load Symbols] diaog box:

Load Symbols EE3

Loak jn: |¢3H83tut j gl E.-..
ttonal. spm

File narme: Im_l,l_cnde. aum Open I
Files of lwpe: IS_I,Ime| Files [*.spm)] j Cancel |

Figure5.42 [Load Symbols] Dialog Box

The dialog box operates like a standard Windows® [open file] dialog box; select the file and click [Open] to start
loading. The standard file extension for symbol filesis*.sym”.

5.10.7 SavingLabelsintoaFile

Choose [Save As...] from the popup menu to open the [Save Symbols] dialog box. The [Save Symbols] dialog
box operates like a standard Windows® [Save File Ag] dialog box. Enter the name for the file in the [File name]
field and click [Save] to save the HEW's current label list to a symbal file. The standard file extension for
symbol filesis*.sym”.

See appendix E, Symbol File Format, for the symbol file format.

Once afileis specified by the [Save As...] menu, the current symbal table can be saved in the same symbol file
just by choosing [Save] from the popup menu.

5.10.8  Searching for aLabel

Choose [Find...] from the popup menu to open the [Find Label] dialog box:

Find Label H

Mame: I LI QK I
[ Match Caze I LI Cancel |

Figure5.43 [Find Label] Dialog Box

Enter al or part of the label name that you wish to find into the edit box and click [OK] or press the [Enter] key.
The HEW searchesthe label list for alabel name containing the text that you entered.
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Note: Only the label is stored by 1024 characters of the start, therefore the label name must not overlap
mutually in 1024 characters or less. Labels are case sensitive.

5.109  Searching for the Next Label

Choose [Find Next] from the popup menu to find the next occurrence of the label containing the text that you
entered.

5.10.10 Viewing the Source Corresponding to a L abel

Select alabel and choose [View Source] from the popup menu to open the [Source] or [Disassembly] window
containing the address corresponding to the label.
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511  Executing Your Program

This section describes how you can execute your program's code. Y ou will learn how to do this by either running
your program continuously or stepping single or multiple instructions at atime.

5.11.1 Running from Reset

To reset your user system and run your program from the reset vector address, choose [ Debug->Reset Go], or
click the [Go Reset] toolbar button ([EL]).

The program will run until it hits a breakpoint or abreak condition is met. Y ou can stop the program manually
by choosing [Debug->Halt], or by dlicking the [Stop] toolbar button (@]).

Note: The program will start running from whatever addressis stored in the Reset Vector location. Therefore it
isimportant to make sure that thislocation contains the address of your startup code.

5.11.2 Continuing Run

When your program is stopped, the HEW will display an yellow arrow mark in the gutter of the line in the editor
and [Disassembly] windows that correspond to the CPU's current program counter (PC) addressvalue. Thiswill
be the next instruction to be executed if you perform a step or continue running.

To continue running from the current PC address, click the [Go] toolbar button , or choose [Debug->Go].

To continue running from a specified address which is not the stop address, change the PC valuein one of the
following ways, and click the [Go] toolbar button (L)) or choose [Debug->Ga.

» Change the PC vdue in the [Register] window. Refer to section 5.4.3, Modifying Register Contents.
» Place the text cursor (not the mouse cursor) to atarget linein the [Source] or [Disassembly] window, and
choose [Set PC Here] from the popup menu.

5.11.3 Running to the Cursor

Sometimes as you are going through your application you may want to run only asmall section of code, that
would require many single steps to execute. Y ou can do this using the Go To Cursor feature.

2 How to use the Go To Cursor

1. Make surethat a[Source] or [Disassembly] window is open showing the address at which you wish to stop.

2. Position the text cursor on the address at which you wish to stop by either clicking in the [Address] field or
using the cursor keys.

3. Choose [Go To Cursor] from the popup menu.

The debugging platform will run your code from the current PC value until it reaches the address indicated by
the cursor's position.

Notes: 1. If your program never executes the code at this address, the program will not stop. If this happens,
code execution can be stopped by pressing the Esc key, choosing [Debug->Halt], or clicking on the
[Stop] toolbar button (&)
2. The Go To Cursor feature requires a PC breakpoint - if you have already used all those available, then
the feature will not work.
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5.11.4  Running from a Specified Address

The [Run Program] dialog box allows the user to run the program from any address. Choose [Debug -> Run...]
to open the [Run Program] dialog box.

Run Program ﬂﬂ

PBrogram Gounter:

|H'DDDDDDDD|
Beset Go
Temporary PG Breakpoints:

Cancel

iy

Figure5.44 [Run Program] Dialog Box
The following execution conditions can be specified in this dialog box:

[Program Counter]: Instruction address to start execution. Theinitial valueis
the current PC vaue.

[Temporary PC Breakpoints]: A temporary PC breakpoint. When execution started
by this dialog box stops, this breakpoint is cleared.

Note: The[Temporary PC Breakpoints] feature requires a PC breakpoint - if you have already used all those
available then the feature will not work.

Clicking the [Go] button starts execution according to the settings. Clicking the [Reset Go] button starts
execution from the reset vector. Clicking the [Cancel] button closes this dialog box without executing
ingtructions.
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5.11.5 Single Step

To debug your codeit isvery useful to be able to step asingle line or instruction at a time and examine the effect
of that instruction on the system. In the [Source] window, then a step operation will step asingle sourceline. In
the [Disassembly] window, a step operation will step a single assembly-language instruction. If the instruction
calls another function or subroutine, you have the option to either step into or step over the function. If the
instruction does not perform a call, then either option will cause the debugger to execute the instruction and stop
at the next instruction.

e Stepping Into a Function
If you choose to step into the function the debugger will execute the call and stop at the first line or instruction of
the function. To step into the function either click the [Step In] toolbar button (), or choose [Debug->Step In].

e Stepping Over a Function Call

If you choose to step over the function the debugger will execute the call and all of the code in the function (and
any function callsthat that function may make) and stop at the next line or instruction of the calling function. To
step over the function either click the [Step Over] toolbar button ), or choose [Debug->Step Over].

*  Stepping Out of a Function

There are occasions when you may have entered a function, finished stepping through the instructions that you
want to examine and would like to return to the calling function without tediously stepping through al the
remaining code in the function. Or aternatively you may have stepped into a function by accident, when you
meant to step over it and so want to return to the calling function without stepping all the way through the
current function. Y ou can do this with the Step Out feature.

To step out of the current function either click the [Step Out] toolbar button (), or choose [Debug->Step Out].
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5.11.6 Multiple Steps

You can step severd instructions at atime by using the [Step Program] dialog box. The dialog box aso provides
an automated step with a selectable delay between steps. Open it by choosing [Debug-> Step...].

The [Step Program] dialog box is displayed:

Skep Program ﬂ ll

Steps: [H'D0000DDT ok I
Qe|a}':|2.533c:nnds ﬂ Cancel |

[ Step owver calls

[ Source level step

Figure5.45 [Step Program] Dialog Box

[Steps): Number of steps to be executed.

[Delay (seconds)]: Delay between steps when the program is automatically stepped.
0 to 3 seconds can be selected in 0.5 second units.

[Step Over Callg]: Selecting this box steps over function calls.

[Source Level Step]: Selecting thisbox steps the program at the source level.

Clicking the [OK] button or pressing the [Enter] key starts step execution.
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512  Stopping Your Program

This section describes how you can halt execution of your application's code. This section describes how to do
thisdirectly by using the [Stop] button and by setting breakpoints at specific locationsin your code.

5.12.1  Stoppingthe Program by the [Stop] Toolbar Button

When your program is running, the [Stop] toolbar button is enabled (ared STOP sign), and when the
program has stopped it is disabled (I:l) (the STOP sign is grayed out). Click on the [Stop] toolbar button, or
choose [Debug->Halt Program].

When the program has been stopped by [Stop], "User Break" is displayed in the [Debug] sheet of the [Output]
window.

5.12.2 Standard Breakpoints (PC Breakpoints)

When you are trying to debug your program you will want to be able to stop the program running when it
reaches a specific point or pointsin your code. You can do this by setting a PC breakpoint on the line or
instruction at which to want the execution to stop. The following instructions will show you how to quickly set
and clear simple PC breakpoints. If more complex breakpoint operation is required, use the [Event] window,
which can be opened by clicking the ) button or choosing [View -> Code -> Eventpoints]. For details, refer
to section 5.15, Using the Event Points.

e To set aPC breskpoint in the [Source] window

1. Make surethat the [Disassemble] or a[Source] window is open at the place you want to set aPC
breakpoint.

2. Choose [Toggle Breakpoint] from the popup menu, or press F9, at the line showing the address at which
you want the program to stop.

3. Youwill seeared circle appear in the gutter to indicate that a PC breakpoint has been set.

4. The current breakpoint set can be enabled or disabled by using [Enable/Disable Breakpoint] in the popup
menu.

Now when you run your program and it reaches the address at which you set the PC breakpoint, execution halts
with the message "PC Break" displayed in the [Debug] sheet of the [Output] window, and the [Source] or
[Disassembly] window is updated with the PC breakpoint line marked with an arrow in the gutter.

Note:  When abreak occurs, the program stops just beforeiit is about to execute the line or instruction at which
you set aprogram PC breakpoint. If you choose Go or Step after stopping at the PC breakpoint, then the
line marked with an arrow will be the next instruction to be executed.
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e Toset aPC breakpoint by using the [Breakpoints] dialog box
Selecting [Edit -> Source Breakpoaint...] displaysthe [Breakpoints] dialog box.

Breakpoints

Cancel |
Edit Code |
Remaove |
Remaove All |

Figure5.46 [Breakpoints] Dialog Box

The [Breakpoints] dialog box allows the user to view the current breakpoints set. Clicking the [Edit Code] button
displays the source where each breakpoint is set. The [Remove] or [Remove All] button deletes one or all
breakpoints, respectively. The check box of each breakpoint enables or disables the breakpoint.

» Totoggle PC breakpoints
It is possible to toggle the [PC Breakpoints] setting by either double-clicking in the [BP] column of the line
where the PC breakpoint is set or placing the cursor on the line and pressing the [F9] key. The setting to be
toggled depends on the debugging platform.
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513 Elf/Dwarf2 Support

The HEW supports the Elf/Dwarf2 object file format for debugging applications written in C/C++ and assembly

language for Renesas microcomputers.
Key Features

» Sourcelevel debugging

e C/C++ operators

e C/C++ expression (casting, pointers, references, etc.)
*  Ambiguous function names

e Overlay memory loading

» Watch - locals, and user defined

e Stack Trace

5131 C/C++ Operators
The C/C++ language operators are available:
L& N S>> <%, (), <, >, <=5, =5, 15, &4, |

Buf fer_start + 0x1000

#R1 | B 10001101

((pointer + (2 * increnent_size)) & H FFFF0O000) >> D 15
I(flag » #ER4)

5.13.2 C/C++ Expressions

Expression Examples

oj ect . val ue //Specifies direct reference of amember (C/C++)
p_oj ect - >val ue /ISpecifies indirect reference of amember (C/C++)
Cl ass: :val ue //Specifies reference of a member with class (C++)
*val ue //Specifies apointer (C/C++)

&val ue /ISpecifies areference (C/C++)

array|[ 0] /ISpecifies an array (C/C++)

oj ect . *val ue //Specifies reference of a member with pointer (C++)
::g_val ue /ISpecifies reference of aglobal variable (C/C++)

O ass::function(short) //Specifiesamember function (C++)

(struct STR) *val ue //Specifies cast operation (C/C++)
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5.13.3  Supporting Duplicate Labels

In some languages, for example C++ overloaded functions, alabel may represent more than one address. When
such alabel nameisentered in adialog box, the HEW will display the [Select Function] dialog box to display
overloaded functions and member functions.

Seleck Funckion ﬂﬂ

Select Function Mame Set Function Mame

{5 ample::sortilong 1 N
{Sample:sort{lang #, shart] |

— Counter
All Function Select Function Set Function

|2 Functions |2 Functions ID Functions

Cahicel

Figure5.47 [Select Function] Dialog Box

Select overloaded functions or member functionsin the [Select Function] dialog box. Generally, one function
can be selected at one time; only for setting breakpoints, multiple functions can be selected. This dialog box has
three areas.

[Select Function Name]: Displays the same-name functions or member functions and
their detailed information.

[Set Function Name]: Displays the function to be set and their detailed information.

[Counter]: [AIl Function] Displays the number of same-name functions
or member functions.
[Select Function] Displays the number of functions displayed
in the [Select Function Name] list box.
[Set Function] Displays the number of functions displayed
in the [Set Function Name] list box.

Selecting a Function

Click the function you wish to select in the [Select Function Name] list box, and click the [>] button. Y ou will
see the selected function in the [Set Function Name] list box. To select all functionsin the [Select Function
Name] list box, click the [>>] button.

Deselecting a Function

Click the function you wish to deselect from the [Set Function Name] list box, and click the [<] button. To
deselect all functions, click the [<<] button. The deselected function will be moved from [Set Function Name]
list box back to the [Select Function Name] list box.
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Setting a Function

Click the [OK] button to set the functions displayed in the [Set Function Name] list box. The functions are set
and the [Select Function] dialog box closes.

Clicking the [Cancel] button closes the dialog box without setting the functions.

5.13.4 Debugging an Overlay Program
This section explains the settings for using the overlay functions.
Displaying Section Group

When the overlay modeis used, that is, when several section groups are assigned to the same address range, the
address ranges and section groups are displayed in the [Overlay] dialog box.

Open the [Overlay] dialog box by choosing [Memory->Configure Overlay].

el B3

Addrezs: Section Marme:
QOFFES00 - DOFFEEDE oK I
Cancel |

Figure5.48 [Overlay] Dialog Box (at Opening)

This didog box hastwo areas: the [Address] list box and the [Section Name] list box.
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The [Address] list box displays the address ranges used in the overlay mode. Click to select one of the address
ranges in the [Address] list box.

Section Marme:

R_zample [k |
F_zot

R_change Cancel |

Figure5.49 [Overlay] Dialog Box (Address Range Selected)
The [Section Name] list box displays the section groups assigned to the selected address range.
< Setting section group

When using the overlay function, the highest-priority section group must be selected in the [Overlay] dialog box;
otherwise the HEW will operate incorrectly.

First click one of the address ranges displayed in the [Address] list box. The section groups assigned to the
selected address range will then be displayed in the [Section Name] list box.

Click to select the section group with the highest-priority among the displayed section groups.

el B3
Addrezs: Section Marme:
00FFES00 - DOFFER0E ok, I
- Cancel |

Figure5.50 [Overlay] Dialog Box (Highest-Priority Section Group Selected)

After selecting a section group, clicking the [OK] button stores the priority setting and closes the dialog box.
Clicking the [Cancel] button closes the dialog box without storing the priority setting.

Note:  Within the address range used by the overlay function, the debugging information for the section
specified in the [Overlay] dialog box is referred to. Therefore, the same section of the currently loaded
program must be selected in the [Overlay] dialog box.
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514  ViewingtheVariables

This section describes how you can look at variables in the source program.

5.14.1 Tooltip Watch
The quickest way to look at avariablein your program isto use the Tooltip Watch feature.
2 To use Tooltip Watch:

Open the [Source] window showing the variable that you want to examine.
Rest the mouse cursor over the variable name that you want to examine - atooltip will appear near the variable
containing basic watch information for that variable.

& o_=am= Sample;
=3 for{ 1=0; i<10; i4++ 3 {
i = rand(): [H'OOD3]
(3 ¢ 03]
1 = -1

al1] = 3.

Figure5.51 Tooltip Watch

5.14.2 Instant Watch

Open the [Source] window showing the variable that you want to examine.
Rest the mouse cursor over the variable name that you want to examine and choose [Instant Watch...] from the
popup menu; the [Instant Watch] dialog box will appear and display the variable at the cursor location.

Inztant Watch

st {0x7c000088 | istruct strB)

Figure5.52 [Instant Watch] Dialog Box

“+” shown to the | eft of the variable name indicates that the information may be expanded by clicking on the
variable name, and “-” indicates that the information may be collapsed. Clicking [Add] registers the variable in
the [Watch] window. Clicking [Close] closes the window without registering the variable in the [Watch] window.
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5.143 [Watch] Window
Y ou can view any vaue in the [Watch] window.
Opening a [Watch] Window

To open a[Watch] window, choose [View->Symbol->Watch] or click on the [Watch] toolbar button ifitis
vishble. A [Watch] window opens. Initially the contents of the window will be blank.

- Watch ;IQI ll
Mame I Walue I Twpe
o-R a { 0=7c000024 | tint[T0]}

..... R [0 H'O0000000 { Ox7c000024 | {int}

..... R[] H'O0000000 { Ox7c000028 | {int}

..... R [ H'O0000000 { Ox7c00002c | {int}

..... R [A] H'O0000000 { Ox7c000030 | {int}

..... R [4] H'O0000000 { Ox7c000034 | {int}

..... R [E] H'O0000000 { Ox7c000038 | {int}

..... R [5] H'O0000000 { Ox7c00003c | {int}

..... R [7] H'O0000000 { Ox7c000040 | {int}

..... R [E] H'O0000000 { Ox7c000044 | {int}

..... R [ H'O0000000 { Ox7c000048 | {int}
...... B max H'OO0A0000 { 0=7=00004c } tint}

Figure5.53 [Watch] Window

Thiswindow allows the user to view and modify C/C++-source level variables. The contents of this window are
displayed only when the debugging information available in the absolute file (*.abs) includes the information on
the C/C++ source program. The variable information is not displayed if the source program informationis
excluded from the debugging information during optimization by the compiler. In addition, the variables that are
declared as macro cannot be displayed.

Thefollowing items are displayed.
[Name]: Name of the variable

[Value]: Value and assigned location.
The assigned location isenclosed by { }.

[Type]: Type of the variable
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The [R] mark shows that the value of the variable can be updated during user program execution.

For updating of the content of the variable that has been registered in the [Watch] window, there are the
following three methods:

1. Usethe Monitor function without halting the user program
The read/write signd of the MCU is set as atrigger and holds the address bus and data bus values to update the
value of the variable.

Note:  Although the realtime operation is retained, the size and number points to be monitored are limited. For
the Monitor function, refer to section 5.9, Displaying Memory Contentsin Realtime.

2. Read the memory content directly from the HEW to update the values without halting the user program since
the bus mastership is owned by the emulator

Note:  While the emulator reserves the bus mastership, the realtime operation is disabled because the CPU stops
operation. This method is only available for accessing the interna ROM, internal RAM, and emulation
memory.

The area used here or this method may not be available depending on the emulator in use. For details,
refer to section 8, Software Specifications Specific to This Product, or [Enable read and write on the fly]
on the [General] page of the [Configuration Properties] dialog box in the online help.

3. Temporarily stops the user program and reads the memory contents

Note: The realtime operation is disabled because the user program is stopped temporarily. This method is only
available for accessing the areas (internal 1/0, DTCRAM, and user memory) other than thosein item 2
mentioned above.

It is possible to recognize the method for updating the value during user program execution according to the
color of the [R] mark.

Blue-outline[R]:  The variable's address is within the range that has been set for the monitoring function and
the datais readable by using the monitoring function.

Blue [R]: An updated value of the data at this |ocation has been read by the monitoring function.

Black-outline[R]: The variable's addressis outside the range that has been set for the monitoring function and
the dataiis not readable by using the monitoring function.

Black [R]: A value has been updated by reading the normal data.

Notes: 1. Thisfunction can be set per variable or per element or body for structures of data.
2. Thecolor of an [R] in the [Name] column changes according to the trace and monitoring settings.
3. A variablethat is alocated to aregister cannot be selected for monitoring.

273
RENESAS



Adding a Watch Item
Use the [Add Watch] dialog box in the [Watch] window to add Watch items to the [Watch] window.
2 To use Add Watch from a [Watch] window:

Open the [Watch] window.
Choose [Add Watch] from the popup menu.
The [Add Watch] dialog box opens:

Add Wiatch 21

Wariable or expression;

I

a LCancel

Figure5.54 [Add Watch] Dialog Box

Enter the name of the variable that you wish to watch and click [OK]. The variable is added to the [Watch]

window. A variable can be dragged from the [Source] window and dropped into the [Watch] window.

Note: If the variable that you have added isalocal variable that is not currently in scope, the HEW will add it

to the [Watch] window but its value will be ‘Not available now'.
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Expanding a Watch Item

If awatch itemisapointer, array, or structure, then you will see aplus sign (+) expansion indicator to left of its
name, this means that you can expand the watch item. To expand a watch item, double click on it. Theitem
expands to show the elements (in the case of structures and arrays) or data vaue (in the case of pointers)
indented by one tab stop, and the plus sign changesto aminussign (-). If the elements of the watch item also
contain pointers, structures, or arraysthen they will aso have expansion indicators next to them.

Expansion
indlicator
M ----- B [0 H DDDDDF[E { DxDfoefBD }
----- B 1] H'000015fb § 0x00fef34 }
----- B & H'0000167e { Dx00f=f33
----- B 3 H'00001 cfb § 0x00fefde
----- B 4 H'00002781 { Dx00ffef30
----- E A H'00003f54 § 0x00fef34 }
----- E [F] H'000041 6 { 0x00ff=f33
----- B [ H'00004466 { 0x00fef3c
----- B A H'000053&2 { Ox00ffefa0 }
----- B 9 H'0000734b { 0x00ffefad
Collapsedwatch 5 { OWONFefB0 }
1| | ¥

Figure5.55 Expanding a Watch Item

To collapse an expanded watch item, double click on the item again. The item's elements will collapse back to
the single item and the minus sign changes back to a plus sign.

The watch item can be expanded for the number of levels when anumerica key from 1to 9 is pressed while a
watch item is selected.
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Editing a Watch Item's Value

Y ou may wish to change the value of awatch variable, e.g. for testing purposes or if the value isincorrect due to
abug in your program. To change a watch item's val ue use the Edit VValue function.

< Editing awatch item's value:
Enter avalue directly in the window.

In another way, select the item to edit by clicking on it, you will see a flashing cursor on the item.
Choose [Edit Value] from the popup menu.
The [Edit Value] dialog box opens:

Expression: I[D]

Current H'00000KE { 0+00ffefa0

Wallue ok I
Mew ' alue: I

LCancel

Figure5.56 [Edit Value] Dialog Box

Enter the new value or expression in the [New Value] field and click [OK]. The [Watch] window is updated to
show the new value.
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Deleting a Watch Item

To delete awatch item, select it and choose [Delete] from the popup menu. The item is deleted and the [Watch]
window is updated.

To delete all watch items, choose [Delete All] from the popup menu. All items are deleted and the [Watch]
window is updated.

Specifying Realtime Update

The R mark shown to the left of each variable indicates whether the variable is updated in real time. Whenan R
mark is displayed in bold face, the value of the corresponding variable will be updated in realtime during user
program execution.

A popup menu containing the following optionsis available in the [Watch] window:

e Auto Update
Marks the selected variable with abold R and updates the variable in rea time.
* Auto Update All
Marks al variables with bold Rs and updates al variablesin real time.
» Delete Auto Update
Marks the sel ected variable with an outlined R and cancels realtime update.
* Delete Auto Update All
Marks all variables with outlined Rs and cancels reatime update.

M odifying the Radix
The radix for the selected variable display can be modified by choosing [Radix] from the popup menu.
Saving the [Watch] Window Contentsin a File

To save the contents of the [Watch] window, choose [Save As...] from the popup menu; the Save As dialog box
opens. It allows the user to specify the name of afile and to save the contents of the [Watch] window in thefile.
If the [Append] check box is selected, the window contents are appended to the existing file, and if it is not
selected, the exigting file is overwritten.

Opening a [Memory] Window

The contents of the memory area to which the selected variable is assigned can be displayed in the [Memory]
window. Choose [Go To Memory...] from the popup menu; the [Set Address] dialog box opens, showing the
information (start address, end address, and size) of the selected variable as default. Clicking [OK] opensthe
[Memory] window.
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5.144 [Locals] Window
Thelocal variables and their values can be displayed in the [Locals] window.
Opening the [L ocals] Window

To open the [Locals] window, choose [View->Symbol->Locals] or click the [Locals] toolbar button .

-1l =

i H'00ffefE0 { ERS } Iong]

-------- : H'000a { Fid } fint)
""" p_zam Ox00ffL0dS § ERE } [class Sample”)

Figure5.57 [Locals] Window

If alocal variableis not initialized when defined, then the value of the local variable will be incorrect until
another value is assigned to the local variable.

Thelocal variable values and the radix for local variable display can be modified in the same manner asin the
[Watch] window.
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515 Usingthe Event Points

The emulator has the event point function that performs breaking, tracing, and execution time measurement by
specifying higher-level conditions along with the PC breakpoints standard for the HEW.

5.15.1 PC Breakpoints
When the instruction of the specified address is fetched, the user program is stopped. Up to 256 points can be set.

Note that, however, only one PC breakpoint can be set in the ROM area of the user system. This particular
breakpoint is called the on-chip breakpoint, which stops the user program after executing the instruction of the
specified address.

When it is necessary to set two or more PC breakpoints to the external ROM area of the user system, allocate
this area to the emulation memory, copy the code, and then set the PC breakpoints.

5.15.2 Event Points

Event points can be used for higher-level conditions such as the data condition as well as specification of the
single address. Up to 12 event points can be set by using event channels and range channels in the event
detection system.

When the condition is satisfied, event points are also used as the start/end conditions for execution time
measurement or trace acquisition in addition to halting the user program. Several event points can be used to set
more complex conditions.

Note: Event points acquire the data, test conditions, and execute an action (such as halting the user program)
by the hardware circuit of the emulator. Therefore, adelay of severa cycleswill occur from the
satisfaction of the condition to the execution of an action.

5.15.3 Event Detection System

In addition to the 4 range channels, the emulator also has 8 event channels. The event channels have more
functions (such as sequencing or counting) than the range channels.

Event Channels (Ch1to Ch8):

The emulator has 8 event channels. The event channel can be defined as a combination of one or more of the
followings:

e Anaddress or an address range

e QOutside of an addressrange

* A read, awrite, or either

»  Datawith amask specification

* Busstate

e Area

e Thevalue of four external probe signas

»  Thenumber of times the event has occurred

e Thenumber of delay cycles after the event has occurred

A maximum of eight points can be used as a combination in a sequence. The program is activated or halted by an
occurrence of the previous event in each sequence.
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Range Channels (Ch9 to Ch12):
The emulator has 4 range channels. The range channel can be defined as a combination of one or more of the
followings:

e Anaddress or an address range

e QOutside of an address range

* Aread, awrite, or either

«  Datawith amask specification

e Busdtate

* Area

e Thevalue of four external probe signas

e Thenumber of delay cycles after the event has occurred

5.154 Signalsto Indicate Bus Statesand Areas

In the event detection system, signals indicating the MCU'’ s bus states and the accessed areas can be specified as
the event detection condition.

These signals are output from the MCU on the emulator; the signals to be acquired will vary according to the
emulator in use.

The signals to indicate bus states and areas are used to set the [Bus/Area] condition of the event point. They can
also be acquired as the trace information.

The bus state signals are al'so used to set the condition not to acquire the trace ([Suppress] option) and in the
Access Count Of Specified Range Measurement mode for measuring the hardware performance ([Access Type]
option).

For the trace function, refer to section 5.16, Viewing the Trace Information. For the hardware performance
function, refer to section 5.20, Analyzing Performance.

The following tables show examples of signals to indicate the bus states and areas that can be acquired by the
emulator.

Table5.1 Bus State Signals Acquired by the Emulator

Bus State Trace Display (Status) Description
CPU Prefetch PROG CPU prefetch cycles
CPU Data DATA CPU data access cycles
Refresh REFRESH Refresh cycles
DMAC DMAC DMAC cycles
DTC DTC DTC cycles
Other OTHER Others
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Table5.2 AreaSignalsAcquired by the Emulator

Area Trace Display (Status) Description
On-chip ROM ROM ROM

On-chip RAM RAM RAM

On-chip 1/0O 16bit 1/0-16 16-bit 1/0

On-chip 1/O 8bit 1/10-8 8-bit I/0

External /0 16bit EXT-16 16-bit EXT (external)
External 1/0 8bit EXT-8 8-bit EXT (external)
DTC RAM RAM/DTC DTCRAM

Note: The signals to indicate the bus states and areas vary according to the emulator in use. For details, refer to
section 8, Software Specifications Specific to This Product, or the online help.

5.155 Opening the [Event] Window

Select [View -> Code -> Eventpoints] or click the [Eventpoints] toolbar button to open the [Event] window.

The [Event] window has the following three sheets:

[Breakpoint] sheet: Displays the settings made for PC breakpoints. It is also possible to set, modify, and
cancel PC breakpoints.

[Event] sheet: Displays or sets event points.

[Trigger] sheet: Displays or setstrigger points.

5.15.6  Setting PC Breakpoints

It is possible to display, modify, and add PC breakpoints on the [Breakpoint] sheet.

1ol x]
Type State Condition Action

Program Enable PC=H'O000105CiTutorial.cpp/dz) Break

Program Enable PC=H'OOOOlO0CETutorial.cpp/53) EBreak

Program Enable PC=H'OO001772 Break

s |
A [+ [, Breakpoint £ Event i Trigger f

Figure5.58 [Event] Window ([Breakpoint] Sheet)
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Select [Add...] or the PC breakpoint displayed in this window and then select [Edit...] from the popup menu to
display the [Breakpoint/Event Properties] dialog box.

Brealpoink/Event Properties 21|
General |
~Tupe Addrezs
€ Don'tCare ¢ Addiess € Bange
Address Lo [
£ Event = . |H00000000
Address H 00000000
[ Outside Fange
r Data Compare Direction—
[ Compare [T Lze bask " Head
Walue [
- IHD £ wite
% Bute £ wiod
Mask IH,D g ElthEl

ak I Cancel |

Figure5.59 [Breakpoint/Event Properties] Dialog Box (Setting a PC Break)
In this dialog box, select the address condition to set PC breakpoints.

[Typel: Select the type of a breakpoint. Note that the [Breakpoint/Event Properties] dialog box is used
for setting PC breakpoints and event points. Selecting a particular type of breakpoint enables
or disables other pages and parts of the dialog according to the options available to that type of
breakpoint.

[PC Break]: Only asingle address with a program fetch can be selected. Other options are invalid.

[Event]: Set conditionsin detail with other options on this page, or on the [Bus/Ared],
[Signalg], or [Action] page.

[Address]: Set address conditions.

[AdderessLo]: Select asingle address where a PC breakpoint will be set.
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5.15.7  Setting Event Points

On the [Event] sheet, the settings for event points are displayed, modified, and added.

ol
Ty¥pe dtate Condition I Action -
Chl (E) Enable Address=H'0000106&4 (Tutorial.cpp/37) address bus prefetch  Trace

Chz (E) Enahle Address=H'0O000107E (Tutorial.cpp/45) address bus prefetch  Trace

Ch3 (E) Enahle Address=H'00001040 (Tutorial.cpp/49) address area ROM Trace

Chd (E) Enable Address=H'00001140 address area ROM Trace

Chs (E) Enpty

Chiés (E) Eunpty

Ch7 (E) Enpty

Chi (E) Enpty

Ch9 (R) Eunpty

Chld(R) Enpty -
4| | 3|
4|+ ' Breakpoint p Event A Trigger f

Figure5.60 [Event] Window ([Event] Sheet)

Select [Add...] or the event point displayed in this window and then select [Edit...] from the popup menu to
display the [Breakpoint/Event Properties] dialog box.

The conditions for the event point are set on the [General], [Bus/Area], [Signas], and [Action] pages. The search
condition for the event point is set by multiple conditions set on these pages.

Notes: 1. Channel 8 hasthe trigger output function. When the condition on channel 8 is satisfied, the low-level
signal will be output from the external probe 1 (EXT1) for abus cycle.

2. When the event point is used as the condition for acquiring the trace information, select [Trace
Acquisition...] from the popup menu. For the trace function, refer to section 5.16, Viewing Trace
Information.

3. If acondition that is unavailable for arange channel is set in editing of the range channels (Ch9 to
Ch12), the selected channel is automatically replaced by an unused event channel (Chl to Ch8).

Table5.3 Conditions Unavailable for a Range Channel

Condition Related Options

Selecting outside the [Outside Range] on the [General] page
specified address range

Selecting the start or [Start Timer] and [Stop Timer] on the [Action] page
end of the execution
time measurement

Specifying the count [Required number of event occurrences] on the [Action] page
when an event occurs
(twice or more)

Specifying sequencing [Enable Sequencing] on the [Action] page
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(1) [General] page

The address and data conditions are set.

Ereakpaint/Event Properties 2 x|
General |Bus / twea | Signals | Action |
— Type Address
" PC Break " Don't Care © Addrezs ¢ Range
AddressLe |H 00000000
Address Hi [H 00000000
[T Outside Fange
— Data Compare Direction——
™ Compare = Wse Mask " Read
Walue [
- IHD € Write
¢ Bute & Word
Mask IH'D * Either
Ok, I Cancel |

[Type]: Select the type of a breakpoint. Note that the [Breakpoint/Event Properties] dialog box is used
for setting PC breakpoints and event points. Selecting a particular type of breakpoint enables
or disables other pages and parts of the dialog according to the options available to that type of
breakpoint.

[PC Break]: Only asingle address with a program fetch can be selected. Other options are invalid.

[Event]: Set conditionsin detail with other options on this page, or on the [Bus/Ared],
[Signalg], or [Action] page.

[Address]: Sets the address condition.

[Don't care]: Sets no address condition.

[Address]: Allows asingle address to be selected.

[Range]: Allows an address range to be selected.

[AdderessLo]: Set asingle address or the start of an address range (available when [Address] or
[Range] has been selected).

[AdderessHi]:  Set the end of an address range (available when [Range] has been selected).

[Outside Range]: Used to negate the range (i.e., the event will occur when the addressis outside the
range). Thisis available when [Address] or [Range] has been selected.
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[Data Compare]: Sets the data condition.
[Compare]: Checking this box compares data.
[Use Mask]: Sets amask condition (available when [Compare] has been selected).

[Value]: Specifies the data bus value as numerics. The size of data for access can also be
selected (available when [Compare] has been selected).

[Byte]: Sets access in bytes as the condition (available when [Compare] has been selected).
[Word]: Sets access in words as the condition (available when [Compare] has been selected).
[Mask]: Sets avalue to be masked. Thisvalue will be ANDed with the value of the data bus

and data condition. The result will be used to compare data (available when [Use
Mask] has been selected).

[Direction]: Selects a condition with read or write cycles.
[Read]: Sets read cycles as the condition.
[Write]: Sets write cycles as the condition.
[Either]: Sets either read or write cycles as the condition.
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(2) [Bug/Area] page

Use this page to set the bus status and the memory area being accessed.

Breakpoint/Event Froperties 2 x|

General Bus/Area | Signalsl Actionl

— Bus State —hrea

I~ CFU Frefetch = On-chip BOK

[T CRU Data [ On-chip Bat

[ Befiesh [™ | On-chip 40 16 bit
[T DHMAC [T Or-chip 14008 kit
[~ DIc [™ External 16 bit

™ Other = Esternal & bit

I~ DL Rk

¥ Don't Care

Ok, I Cancel |

Figure5.62 [Breakpoint/Event Properties] Dialog Box ([Bug/Area] Page)

[Bus State]: Sets the bus status as the condition. When the [Don't care] check box is checked, the event will
be satisfied with any bus status.

[Area]: Specifies the area for searching. When the [Don't care] check box is checked, the event will be
satisfied in any area.

Note: Items set for the bus state and memory access area vary according to the emulator in use. For details,
refer to section 5.15.4, Signalsto Indicate Bus States and Areas.
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(3) [Signals] page

Use this page to set external signals.

Breakpoint/Event Froperties 2 x|

General I Bus /évea  Signals |.t’-‘n.cti0n|

— Probe 4 — Probe 3
" High " High
 Low  Low
i (¢ Don't Care
~Probe 2 —Probe 1
" High " High
 Low  Low
& Don't Care & Don't Care

Ok, I Cancel |

Figure5.63 [Breakpoint/Event Properties] Dialog Box ([Signals] Page)

[Probed]: Detects the status of the input probe signal 4
[High]: Detects the high level of the input probe signal
[Low]: Detectsthe low level of the input probe signal

[Don't care]: The status of the input probe signal is not detected

[Probe3]: Detects the status of the input probe signal 3
[High]: Detects the high level of the input probe signal
[Low]: Detectsthe low level of the input probe signal

[Don't care]: The status of the input probe signal is not detected

[Probe2]: Detects the status of the input probe signal 2
[High]: Detects the high level of the input probe signal
[Low]: Detectsthe low level of the input probe signal

[Don't care]: The status of the input probe signal is not detected
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[Probel]: Detects the status of the input probe signal 1
[High]: Detects the high level of the input probe signal
[Low]: Detectsthe low level of the input probe signal

[Don't care]: The status of the input probe signal is not detected

(4) [Action] page

Use this page to decide what action the emulator takes when the defined event occurs.

Breakpoink/Event Properties 2 x|

General | Bus / &rea | Signaks  Action

Actions
~ &

[ élarlTimer
[ Stop Tirmer

Delay after detection before break occurs
oo

bus cycles

Required number of event ocourences
|01

[~ Enable Sequencing |

Ok, | Cancel

Figure5.64 [Breakpoint/Event Properties] Dialog Box ([Action] Page)

[Action]: Selects an action that occurs when the event is satisfied. This cannot be used for an
event point being used as the trace acquisition condition.
[Break]: Causes abreak (stop) in the user program when the event occurs. Thisis the
default action.
[Start Timer]: Starts the run timer (the run timer value is displayed in the [ Status] window).
[Stop Timer]: Stops the run timer (the run timer value is displayed in the [Status] window).

[Delay after detection before break occurs):
Sets a 16-bit delay (in bus cycles) after the event has occurred before the action is
taken. The delay is only applicable to break events and thereis only one delay counter
in hardware, therefore only one breakpoint can have a non-zero delay. The range of
valuesis D’0to D’65,535 (only available when [Break] has been selected). This
cannot be used for an event point being used as the trace acquisition condition.
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[Required number of event occurrences):

[Enable Sequencing]:

[Configure Sequence...]:

Allows a 16-hit pass count to be set. The event must occur the specified number of
times before the action istaken. The range of valuesis D’0 to D’65,535.

Allows the event to take part in a sequence of events (setting this requires the event to
use an event detector).

Displays the [Event Sequencing] dialog box to allow the event sequencing to be
configured (only available when [Enable Sequencing] has been selected).

(5) [Event Sequencing] dialog box

This diaog box allows the user to define which events are triggered by other events. If thisdialog box is
accessed (directly or indirectly) from [Trace Acquisition...], only those events assigned to the trace subsystem
are displayed. If accessed from the [Eventpoint] window, only the breakpoint or timer events are shown.

Event Sequencing

Event

" |3 Beset By The fallowing events: Cahicel |

%' |3 Armed By [~ Mo occurence of

[ 1 [E]H1038 address

[~ 2 [EJH105C address count D10
[~ 3[EJH10FE address count D'2
™ 4 [E]H10FC address

™| undefined arunavaiable

™| undefined arunavaiable

™| undefined arunavaiable

™| undefined or unayailatble

O

[Event]:
[Is Armed By]:
[Is Reset By]:

[No occurrence of]:

Figure5.65 [Event Sequencing] Dialog Box

Selects an event point to be set.
Arms the selected event.
Resets the selected event.

Arms an event when the set of events being selected does not occur (only available
when [Is Armed By] has been selected).

Thetest of conditions on event pointsis started with the execution of the user program. The conditions on event
points have not been satisfied immediately after the execution of the user program is started.

Satisfaction of the condition on an event point allows a transition of the state to that where the conditionis

satisfied.
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The state where the condition is satisfied is retained until the user program is stopped or the event point is reset.

When the condition on the event point is satisfied, no action will be taken even if the condition is satisfied again.
If you want the action to be taken again, reset the event point so that the state transits to that where no condition
is satisfied.

When the user program is stopped, the states of al the event pointstrangit to that where no condition is satisfied.

When an event point must be in the state where its condition is satisfied or not (when [No occurrence of] is
selected) as the satisfaction condition of another event point, this event point is called the arm event.

An event point can reset the tested states of conditions of other event points or itself by satisfying the condition.
Thisevent point is called areset event.

A reset event resets event points regardless of their states where the condition is satisfied or not (e.g., resetting
the pass count).

Select an event point from the [Event] combo box. To set an arm event on the selected event point, select [Is
Armed By] and check the box corresponding to each event. The [No occurrence of] check box isused to set a
condition that the arm event isin the state where its condition is not satisfied.

To set areset event on the selected event point, select [Is Reset By] and check the box corresponding to each
event.

At the bottom of the screen is a diagram showing the current sequencing of the events (figure 5.65). The Sinput
sets (arms) an event and the R input resetsit. The legend ~S indicates the event is set (armed) by the non-
occurrence of the input events.

Figure 5.65 is an example that Chl isthe arm event for Ch2, Ch3, and Ch4. Ch3 isthe arm event for Ch4. Ch2
and Ch4 are the reset events for Chl and Ch2, respectively.

To satisfy the condition of the event point having an arm event, the arm event must be in the state where the
condition is satisfied or not (when [No occurrence of] is selected). When multiple arm events exist on one event
point, one of the arm events must be in the state where the condition is satisfied or not (when [No occurrence of]
selected) to satisfy the condition of the event point.

As the condition of the arm event on one event point, either of the states where the condition is satisfied or not
should be set.

To reset an event point with areset event, the condition of the reset event must be satisfied. While the condition
of thereset point is satisfied, no event point is reset even if the condition of the reset event is satisfied again.

When multiple reset events exist on one event point, the event point is reset when the condition of one of reset
eventsis satisfied.
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5.15.8  Setting Trigger Points

Thetrigger point is an event to output a trigger when the specified address has been accessed. Up to four trigger
points can be set by using the trigger outputs (four channels) on the bus monitoring circuit of the emulator.

The settings of the trigger point are displayed and modified on the [Trigger] sheet.

_{o)x]
Type I state I Condition | Action

[EXT.Z-1 Enahle Address=H'O0FFDEEQO Trigger ocutput

[ExT.2-2 Enahle Address=H'O0FFD404 Trigyger ocutput

[ExT.2-3 Enahle Address=H'00001140 Trigger output

[EXT.Z-4 Enahle Address=H'O0FFEFSC Trigger ocutput

| | I
A | k% Breakpoint 4 Event 4 Trigger

Figure5.66 [Event] Window ([Trigger] Sheet)

Selecting [Add...] or the event point and [Edit...] from the popup menu in this window displays the [Set Address
For Trigger] dialog box.

Set Address For Trigger

Address

¥ Trigger: IH'DDFFDEED Carcel |

¥ Trigger: IH'DDFFD4D4

v TriggerZ: IH'DDDD‘I 140

I¥ Triggers: [Ho0FFEFaC

Figure5.67 [Set AddressFor Trigger] Dialog Box

This dialog box allows the user to specify the address to be accessed as the trigger output condition during the
user program execution. Enable or disable the trigger output point by checking the check box on the left in the
screen.

[Triggerl]: Enables the output of trigger channel 1.
[Trigger2]: Enables the output of trigger channel 2.
[Trigger3]: Enables the output of trigger channel 3.
[Triggerd]: Enables the output of trigger channel 4.
[Address]: Sets the address condition of the channel.
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Notes: 1. When the condition set for the trigger output (1 to 4) is satisfied, the high-level signal will be output
from the corresponding pin (1 to 4) of the externa probe 2 (EXT2) during reading or writing.

2. Some emulators may not support the trigger point. For details, refer to section 8, Software
Specifications Specific to This Product, or the online help.

5.15.9 Editing Event Points

Handlings for settings other than PC breakpoints, event points, and trigger points are common. The following
describes examples of such handling.

5.15.10 Modifying Event Points

Select an event point to be modified, and choose [Edit...] from the popup menu to open the dialog box that
corresponds the event, which alows the user to modify the event conditions. The [Edit...] menuisonly available
when one event point is selected.

5.15.11 Enabling an Event Point

Select an event point and choose [Enable] from the popup menu to enable the selected event point.

5.15.12 Disabling an Event Paint

Select an event point and choose [Disable] from the popup menu to disable the selected event point. When an
event point is disabled, the event point will remain in the list, but an event will not occur when the specified
conditions have been satisfied.

5.15.13 Deleting an Event Point

Select an event point and choose [Delete] from the popup menu to remove the selected event point. To retain the
event point but not have it cause an event when its conditions are met, use the [Disable] option (see section
5.15.12, Disabling an Event Point).

Note: No trigger point can be deleted. Use the [Disable] option to clear the settings.

5.15.14 Deleting All Event Points
Choose [Delete All] from the popup menu to remove all event points.

Note: No trigger point can be deleted. If [Delete All] is selected, the settings of all channels become disabled.

5.15.15 Viewing the SourceLinefor an Event Point

Select an event point and choose [Go to Source] from the popup menu to open the [Source] or [Disassembly]
window at address of event point. The [Go to Source] menu is only available when one event point that has the
corresponding source file is selected.
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516  Viewingthe TraceInformation

The emulator acquires the results of each instruction execution into the trace buffer as trace information and
displaysit in the [Trace] window. The conditions for the trace information acquisition can be specified in the
[Trace Acquisition] dialog box.

Since trace information in bus-cyclesis acquired by the hardware circuit and stored in the trace buffer, the
realtime operation is retained. The [Trace] window displays the content of the trace buffer, which records up to
32,768 bus cycles from the last program run and is aways updated.

5.16.1 Openingthe[Trace] Window

To open the [Trace] window, choose [View -> Code -> Trace] or click the [Trace] toolbar button .

5.16.2 Acquiring Trace Information

When the emulator does not set the acquisition condition of the trace information, all bus cycles are acquired by
default without any condition (free trace mode).

In the free trace mode, trace acquisition is started with the execution of the user program and stopped by halting
the user program. The acquired trace information is displayed in the [ Trace] window.

: g =TS
PTR ress | Instruction \ Datal R/m\ Area \ sca:us\ Clock \ Probes \ Nm| IRQ7-0 Tinestamp | Source Label Tinestamp-Difference |£|
-05550 000000 o0on RD ROM DATA 1 1111 1 11111111
-05549 000002 0400 RD ROM DATA 1 1111 1 11111111
-05548 000400 MOV. L #H'O0F... 7a07 RD ROM PROG 1 1111 1 11111111 __entry(v... Power...

-05547 000402 O0EE  RD ROM PROG 1 1111 1 11111111
-05546 000404 efc0 RD ROM PROG 1 1111 1 11111111
-05545 000408 ORC.B #H'80,CCR 0480 RD  ROM PROG 1 1111 1 11111111 et ...
-05544 000408 J5R B__INI... 5e00 RD FROM PROG 1 1111 1 11111111 _INIT...
-05543 00040a 1l0e RD ROM PROG 1 1111 1 11111111
-05542 00110e MOV. W RZ,H-ERT &dE2 RD ROM PROG 1 1111 1 11111111 __INI...
-05541 ffefbc 0000 WE R... DATA 1 1111 1 11111111
-05540 ffefbe 040c WR R... DATA 1 1111 1 11111111
-05539 001110 STH.L (ER4-E... 0120 RD ROM PROG 1 1111 1 11111111
-05538 ffefba 5770 WR  R... DATA 1 1111 1 11111111
-05537 00llle 6df4 RD ROM PROG 1 1111 1 11111111
-05536 001114 HOV. L #H'000... 7a00 RD ROM PROG 1 1111 1 11111111
-05535 ffefbd 5770 WR  R... DATA 1 1111 1 11111111 ;I
Figure5.68 [Trace] Window
Thiswindow displays the following trace information items:
[PTR]: Cycle number in the trace buffer. When the most recent record is record O, earlier

record numbers go backwards (-1, -2, ...). If adelay count has been set, the cycle
number where the trace stop condition has been satisfied is record 0. For the cycle
(during delay) executed until the trace has stopped, earlier record numbers go forward
(+1, +2, ...) the most recent record.

[Address]: Address (6-digit hexadecimal)

[Instruction]: Disassembled code of the executed instruction

[Data]: Data bus value, displayed as 2-digit or 4-digit hexadecimal

[RIW]: Whether access was read (RD) or write (WR)

[Area]: Memory area being accessed; ROM, RAM, 8- or 16-hit I/O, 8- or 16-bit EXT

(external), or DTC RAM (not available when atime stamp is acquired)
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[Status]:

[Clock]:

[Probes]:

[NMI]:
[IRQ7-0]:

[Timestamp]:

[Source]:
[Label]:

[Timestamp-Difference]:

Bus status during this cycle; DTC operation, PROG (prefetch), Data (CPU data access
cycle), Refresh (refresh cycle), or DMAC (DMAC cycle) (not available when atime
stamp is acquired)

Number of clock cyclesin buscycleas 1 to 8. To indicate more clock cycles, “OVR”
isdisplayed (not available when atime stamp is acquired).

A 4-bit binary number showing the four probe pinsin the order of Probe 4, Probe 3,
Probe 2, and Probe 1 from the | eft (not available when atime stamp is acquired).

Status of the NMI input (not available when atime stamp is acquired)
Status of eight IRQ inputs (not available when atime stamp is acquired)

Time stamp of the record. Time stamps start from zero each time the user programis
executed. The timer resolution depends on the time stamp clock rate selected in the
trace acquisition (only available when atime stamp is acquired).

Source program
Label information that corresponds to the address (if defined)

Displays the difference from the timestamp val ue shown on the previous line (only
available when atime stamp is acquired).

Note: Itemsother than [PTR], [Address], [Instruction], [Data], [R/W], [Area], [Status], [Probes], [Timestamp],
[Source], [Label], and [Timestamp-Difference] vary according to the emulator in use. For details, refer to
section 8, Software Specifications Specific to This Product, or the online help.

It is possible to hide any column not necessary in the [Trace] window. Selecting a column you want to hide from
the popup menu displayed by clicking the right-hand mouse button on the header column hides that column. To
display the hidden column, select the column from the said popup menu again.
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5.16.3  Specifying Trace Acquisition Conditions

The capacity of the trace buffer islimited. When the buffer becomes full, the oldest trace information is
overwritten. Setting the trace acquisition condition allows acquisition of useful trace information and effective
use of the trace buffer. The condition is enabled by the event point to control starting, stopping, and ending the
trace acquisition. For event points, refer to section 5.15, Using the Event Points.

The trace acquisition condition is set in the [Trace Acquisition] dialog box that is displayed by selecting
[Acquisition...] from the popup menu.

The [Trace Acquisition] dialog box has the following pages:

Table5.4 [TraceAcquisition] Dialog Box Pages

Page Item

[General] Sets trace acquisition conditions.

[Stop] Sets trace stop conditions (without a delay).

[Delayed Stop] Sets trace stop conditions (with a delay).

[1] to [4] Sets the range trace (only available when the free trace mode is
disabled).

(1) [General] page

Sets trace acquisition conditions.

Trace Acquisition ﬂll
Geneal |Stop | DelayedStop] 1 |2 |3 |4 ]
~Suppresz—————— Time Stamp
™ Free Trace

Cliock:

[ DIC Cycles IDisabIed vI

[ Eefresh Cpcles

— Trace Events
Event:
[10(R)H1092 address |
Add. | Ed. Sequence.. Delete |  Delan |

QK. I Cancel |

Figure5.69 [Trace Acquisition] Dialog Box ([General] Page)
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[Suppress): Acquires no trace information of the specified types of bus cycle.
[Time Stamp]:  Setsacondition for time stamping.

[Clock]: Select either from Disabled, 125 ns, 250 ns, 500 ns, 1 us, 2 us, 4 us, 8 us, 16 us, or
100 us as the resolution for time stamping. A time stamp has a 32-bit counter. At 125
ns the maximum time that can be measured is about 9 minutes, and at 100 ps the
maximum time is about 5 days.

When the counter overflows, its content will be cleared to continue counting. No time
stamp information will be acquired when Disabled is selected.

[Free Trace]: Checking this box enables the free trace mode.

When the free trace mode is enabled: Starts acquiring the dataimmediately after program
execution has been started. Only the trace halt condition is available. Therangetraceis
unavailable and four range-trace pages (1 to 4) become disabled.

When the free trace mode is disabled: Setsthe start and halt conditions of trace acquisition.

[Trace Events]: Setsevent pointsto be used as trace acquisition conditions.

[Event]: Liststhe event points to be used as trace acquisition conditions.
[Add...]: Adds anew event point.
[Edit...]: Changes the setting for the selected event point.

[Sequence...]:  Configures an event sequence for the event point being used as a trace acquisition
condition. To set up the sequence, an event must have been set.

[Delete]: Deletes the selected event point.

[Del All]: Deletes all event points.

Notes: 1. The bus cyclesthat can be specified by the [Suppress] option vary according to the emulator in use.
For details, refer to section 5.15.4, Signals to Indicate Bus States and Areas.
2. Thetrace buffer is used for the time stamp information and some of the trace information. Therefore,
when the time stamp is acquired, it isimpossible to acquire the trace information other than PTR,
Address, Instruction, Data, R/W, Source, Label, Timestamp, and Timestamp-Difference.
3. If an event that is used for the range trace or trace stop function is deleted, that function becomes
disabled.
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(2) [Stop] page

Setstrace stop conditions. It is possible to set trace stop conditions with and without delay, with both allowed
simultaneoudly.

Trace Acquisition ﬂﬂ

General Stop | Delayed Stopl 1 I 2 I 3 I 4 I

— Stop Withaut Delay

— Events
[T undefined ar unavailable

[T undefined ar unavailable
[T undefined ar unavailable
[T undefined ar unavailable
[T undefined or unavailable
[T undefined or unavailable
[~ 7[EJH107E address
[ 8(E]H1084 address
[T undefined or unavailable
W 10[R]H'1092 address
[T undefined or unavailable
[T undefined or unavailable

ak. I Cahicel |

Figure5.70 [Trace Acquisition] Dialog Box ([Stop] Page)

[Stop Without Delay]: Defines atrace stop condition.
[Enable]: Checking this box enables atrace stop.

[Events]: Liststhe event points where trace acquisition conditions have been set. If the
box that corresponds to an event point is checked, trace acquisition will be
stopped when that event is satisfied (only available when [Enable] has been
selected).
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(3) [Delayed Stop] page

Setstrace stop conditions. It is possible to set trace stop conditions with and without delay, with both allowed
simultaneoudly.

Trace Acquisition ﬂﬂ

General I Stop  Delaped Stop |1 I 2 I 3 I 4 I

— Stop with Delay

Delay Count ID"I

— Events
I™ 1 [E]H'D address

I= 2 [E]HD address

= 3 (E]HD address

= 4 [E]HD address

[T B(E]HD address

[T EB(E]HD address

[~ 7 [EJH107E address
[ 8(E]H1084 address
[T undefined or unavailable
[T undefined or unavailable
[T undefined or unavailable

[T undefined or unavailable

ak. I Cahicel |

Figure5.71 [Trace Acquisition] Dialog Box ([Delayed Stop] Page)

[Stop With Delay]: Defines atrace stop condition.

[Enable]: Checking this box enables atrace stop.

[Delay Count]: Setsthe delay count (in bus cycles, range 1 to 65535). This function alows
you to acquire anumber of trace records after any of the specified events
occur.

[Events]: Liststhe event points where trace acquisition conditions have been set. If the

box that corresponds to an event point is checked, trace acquisition will be
stopped when that event is satisfied (only available when [Enable] has been
selected).
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(4) [1] to [4] pages

Setsarange trace. Thisisonly available when the free trace mode is disabled. Select either of the following four
modes: [Disabled], [Point to Point], [Range], and [Event].

* Disabled

Disables arange trace.

Trace Acquisition e

General I Stop I Delayed Stop 1 |2 I 3 I 4 I

— Conditions

* Dizahled € Paint to Point " Range € Ewent

Figure5.72 Range Trace Setting (Disabled)
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¢ Point to Point

Acquires trace information in the specified range.

Trace Acquisition ﬂﬂ

Gerneral I Stop I Delayed Stop 1 |2 I 3 I 4 I
— Conditions

" Disabled & Puint to Point " Range " Ewent

Start Addrezs

H'0000107E

Stop Address

|H'DDDD‘I 084,

¥ Cyclic

Cahicel
Figure5.73 Range Trace Setting (Point to Point)
[Start Address]:  Address where trace acquisition starts
[Stop Address]:  Address where trace acquisition stops
[Cydlic]: When this box is checked, the event sequencing is configured so that the events reset

themsel ves which causes tracing to be restarted when the start event occurs after the stop event.

Sets the event points that are required to start or stop trace acquisition when the start or end address is accessed,
respectively.

Point to Point mode is an easy method to set up the event mode. The event to start or sop trace acquisition isan
access to asingle address.

Select [Cyclic] to continue acquisition of the trace information only in the specified address range.

Note: Thisfunction automatically configures a sequence of event points. Note, however, that an unexpected
result may arise. In such cases, modify the setting of the sequence in the [Event Sequencing] dia og box.
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* Range

Only acquires the trace information that satisfies the specified condition.

Trace Acquisition 71 x|
Gerneral I Stop I Delayed Stop 1 |2 I 3 I 4 I
— Conditions

" Disabled " Puint to Point & Range " Ewent

Range Event Edi... |

|7 [EYH'107E address =l

Cahicel

Figure5.74 Range Trace Setting (Range)

[Range Event]:  Selects an event point for which atrace acquisition condition has been set.
[Edit...]: Changes the setting for the selected event point.

Only acquires trace information from all bus cycles that matches the condition set in the selected event. This
mode uses one event channel or range channel.
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e Event

Acquires trace information, controlling the start and end of trace acquisition with the specified condition.

Trace Acquisition 71 x|
Gerneral I Stop I Delayed Stop 1 |2 I 3 I 4 I
— Conditions

" Disabled " Puint to Point " Range & Event

[

|7 [EYH'107E address

Start Event Edit... |
_ e |

Staop Event Edi...

|2 [E)H'108& address =l

¥ Cyclic

Cahicel

Figure5.75 Range Trace Setting (Event)

[Start Event]: Selects the event point for which the condition to start trace acquisition has been set.

[Stop Event]: Selects the event point for which the condition to stop trace acquisition has been set.
[Edit...]: Changes the setting for the selected event point.
[Cyclic]: When this box is checked, the event sequencing is configured so that the events reset

themsel ves which causes tracing to be restarted when the start event occurs after the stop event.

Starts and stops trace acquisition when the conditions for starting and ending are satisfied, respectively. Selecting
[Cyclic] alows a continuous acquisition of trace information that can be acquired with the specified condition.
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5.16.4  Searching for a Trace Record

Use the [Trace Find] dialog box to search for atrace record. To open this dialog box, choose [Find...] from the
popup menu.

The [Trace Find] dialog box has the following options:

Table5.5 [TraceFind] Dialog Box Pages

Page Description

[General] Sets the range for searching.

[Address] Sets an address condition.

[Data] Sets a data condition.

[R/W] Selects the type of access cycles.

[Area] Selects the area being accessed (not available when a time stamp is
acquired).

[Status] Selects the status of a bus (not available when a time stamp is acquired).

[Probes] Selects the status of four probe signals (not available when a time stamp
is acquired).

[IRQ7-0] Selects the status of eight probe input signals (not available when a time

stamp is acquired).

[Timestamp] Specify the time stamp value for bus cycles (only available when a time
stamp is acquired).
Note: Items other than [General], [Address], [Data], [R/W], [Area], [Status], [Probes], and [Timestamp] vary
according to the emulator in use. For details, refer to section 8, Software Specifications Specific to This
Product or the online help.

Clicking the [OK] button after setting conditions in those pages stores the settings and starts searching. Clicking
the [Cancel] button closes this dialog box without setting of conditions.

When atrace record that matches the search conditionsis found, the line for the trace record will be highlighted.
When no matching trace record is found, a message dialog box will appear.

Only the trace information that satisfies all the conditions set in above pages will be searched.

If afind operation is successful, selecting [Find Next] from the popup menu will move to the next found item.
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(1) [General] page
Set the range for searching.

x

Status I Frobes I IRQ7-0
General | Address I Data I R I Area
Trace search rangs
N ri [ Upward search
Start PTR : |-32767
EndFTR: ID

0k I Cancel | Apply |

Figure5.76 [TraceFind] Dialog Box ([General] Page)
[Trace search range]: Sets the range for searching.

[Not designation]: Searches for information that does not match the conditions set in other
pages when this box is checked.

[Upward search]: Searches upwards when this box is checked.
[Start PTR]: Enters a PTR vaue to start asearch.
[End PTR]: Enters a PTR value to end a search.

Note:  Along with setting the range for searching, PTR values to start and end searching can be set in the [Start
PTR] and [End PTR] options, respectively.
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(2) [Address] page
Set an address condition.

x
Status | Prabes I IRGT-0
General Address | Data I R I Area

Setting
’7Ealue 2 IH'FFEFBD

0k I Cancel | Apply |

Figure5.77 [TraceFind] Dialog Box ([Address] Page)
[Don't care]: Detects no address when this box is checked.
[Setting]: Detects the specified address.

[Value]: Enter the address vaue (not available when [Don’t care] has been checked).
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(3) [Data] page

Set adata condition.
x
Status I Frobes I IRQ7-0
General I Address Data | R I Area

Setting
(Ealue : |H'DDDD

0k I Cancel | Apply |

Figure5.78 [Trace Find] Dialog Box ([Data] Page)
[Don't care]: Detects no data when this box is checked.
[Setting]: Detects the specified data.

[Value]: Enter the data value (not available when [Don't care] has been checked).
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(4) [RIW] page
Select the type of access cycles.

x

Status I Prabes | IRGT-0
General I Address I Data R | Area
I Dont care
Setting
Strirg : I RD j

0k I Cancel | Apply |

Figure5.79 [Trace Find] Dialog Box ([R/W] Page)

[Don't care]: Detects no read/write condition when this box is checked.
[Setting]: Detects the specified read/write condition.
[String]: Select a read/write condition (not available when [Don’t care] has been checked).
RD: Read cycle
WR: Write cycle
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(5) [Area] page
Select the area being accessed. The selection is not available when atime stamp is acquired.

x

Status I Prabes I IRGT-0 |
General I Address I Data I R Area
I Dont care
Setting
String : I ROM j

0k I Cancel | Apply |

Figure5.80 [TraceFind] Dialog Box ([Area] Page)

[Don't care]: Detects no area condition when this box is checked.
[Setting]: Detects the specified area condition.
[String]: Select an area condition (not available when [Don't care] has been checked).

Note: Available areas vary according to the emulator in use. For details, refer to section 5.15.4, Signalsto
Indicate Bus States and Areas.
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(6) [Status] page
Select the status of a bus. The selection is not available when atime stamp is acquired.

x

Gerneral | Address I Data I R M I Area
Stas | Probes | IRG70
I Dont care
Setting
String : I PROG j

0k I Cancel | Apply |

Figure5.81 [TraceFind] Dialog Box ([Status] Page)

[Don't care]: Detects no bus condition when this box is checked.
[Setting]: Detects the specified bus condition.
[String]: Select abus condition (not available when [Don’t care] has been checked).

Note:  Available bus conditions vary according to the emulator in use. For details, refer to section 5.15.4,
Signals to Indicate Bus States and Aress.
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(7) [Probes] page
Select the status of four probe signals. The selection is not available when atime stamp is acquired.

x

Gerneral I Addressz | Data | R M I Area
Status Probes | IRGF-0

— Setting

Probed IDnn'l care'l Probe3 IDon'l care'l
Probe2 IDon'l care 'I Prabel IDnn't cale'l

0k I Cancel | Apply |

Figure5.82 [TraceFind] Dialog Box ([Probes| Page)
[Don't care]: Detects no probe signal condition when this box is checked.
[Setting]: Detects the specified probe signal condition.
[Probed] to [Probel]: Select probe conditions (not available when [Don’t care] has been checked).
Don't care: Detects no selected probe condition.
High: The status of the probe signal is high.

Low: The status of the probe signal islow.
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(8) [IRQ7-0] page

Select the status of IRQ signals. The selection is not available when atime stamp is acquired.

Trace Filter x|
Gerneral I Addressz I Data R M | Area |
Status I Frobes IRE7-0
IRE7 IDon't care "I IRQE Daon't care ™
IRQ5 IDon't care "I IRO4 IDDn't care 'I
IRQ3 IDnn'l care 'I IRE2 IDDn't care 'I
IR IDnn'l care 'I [=Twli] IDon't care "I
QK I Cancel | Apply |

Figure5.83 [Trace Find] Dialog Box ([IRQ7-0] Page)

[Don't carel: Detects no IRQ input condition when this box is checked.
[Setting]: Detects the specified IRQ input condition.
[IRQ7] to [IRQQ]: Select IRQ input conditions (not available when [Don’t care] has been

checked).
Don't care: Detects no selected IRQ input condition.
High: The status of the IRQ input is high.

Low: The status of the IRQ input islow.
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(9) [Timestamp] page
Specify the time stamp value for bus cycles. The specification is not available when atime stamp is acquired.

x
Generall .t’-‘n.ddlessl Data I Ry Timestamp |

0k I Cancel | Apply |

Figure5.84 [TraceFind] Dialog Box ([Timestamp] Page)

[Don't care]: Detects no time stamp value when this box is checked.
[Setting]: Detects the specified time stamp value. (Every field must be filled in.)
[Value]: Enter the time stamp value.

Theformat is as follows:
hour: h, minute: min, second: s, millisecond: ms, microsecond: us, nanosecond: ns

(Not available when [Don't care] has been checked.)

5.16.5 Clearingthe Tracelnformation

Select [Clear] from the popup menu to empty the trace buffer that stores the trace information. If severa [Trace]
windows are open, al [Trace] windows will be cleared as they all access the same buffer.

5.16.6  Savingthe TraceInformation in aFile

Select [Save...] from the popup menu to open the [Save Ag] file dialog box, which allows the user to save the
information displayed in the [Trace] window as atext file. A range can be specified based on the [PTR] number
(saving the complete buffer may take several minutes). Note that this file cannot be reloaded into the [Trace]
window.

Note: In filtering of trace information, the range to be saved cannot be selected. All the trace information
displayed in the [Trace] window after filtering will be saved. Select afiltering range on the [General]
page in the [Trace Filter] dialog box if you want to save the selected range. For details on the filtering
function, refer to section 5.16.12, Extracting Records from the Acquired Information.
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5.16.7 Viewing the [Source] Window
The [Source] window corresponding to the selected trace record can be displayed in the following two ways:

» Select atrace record and choose [View Source] from the popup menu.
» Double-click atrace record

The [Source] or [Disassembly] window opens and the selected line is marked with a cursor.

5.16.8 Trimming the Source
Choose [Trim Source] from the popup menu to remove the white space from the | eft side of the source.

When the white space is removed, a check mark is shown to the left of the [Trim Source] menu. To restore the
white space, choose [Trim Source] while the check mark is shown.

5.16.9  Acquiring a Snapshot of the Trace Information

A snapshot can be acquired when you need to check the trace information during execution of the user program.
Thisisuseful for checking time stamping or probe input signals. To acquire a snapshot of trace information,
select [Snapshot] from the popup menu. Trace acquisition istemporarily stopped to display arecord of the latest
trace information, and then restarted. A snapshot of trace information is only acquired during execution of the
user program.

5.16.10 Temporarily Stopping Trace Acquisition

To temporarily stop trace acquisition during execution of the user program, select [Halt] from the popup menu.
This stops trace acquisition and updates the trace display. Use this method to check the trace information without
stopping execution of the user program.

5.16.11 Restarting Trace Acquisition

To restart trace acquisition being stopped during execution of the user program, select [Restart] from the popup
menu.
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5.16.12 Extracting Recordsfrom the Acquired I nformation

Use thefiltering function to extract the records you need from the acquired trace information. The filtering
function allows the trace information acquired by hardware to be filtered by software. Unlike the settings made
inthe [Trace Acquisition] dialog box for acquiring trace information by conditions, changing the settings for
filtering severa timesto filter the acquired trace information allows easy extraction of necessary information,
whichisuseful for analysis of data. The content of the trace buffer will not be changed even when the filtering
function is used. Acquiring useful information as much as possible by the [Trace Acquisition] settings improves
the efficiency in analysis of data because the capacity of the trace buffer islimited.

Use thefiltering function in the [ Trace Filter] dialog box. To open the [Trace Filter] dialog box, select [Filter...]
from the popup menu.

The [Trace Filter] dialog box has the following pages:

Table5.6 [TraceFilter] Dialog Box Pages

Page Description

[General] Selects the range for filtering.

[Address] Sets address conditions.

[Data] Sets data conditions.

[R/W] Selects the type of access cycles.

[Area] Selects the area being accessed (not available when a time stamp is
acquired).

[Status] Sets the status of a bus (not available when a time stamp is acquired).

[Probes] Selects the states of four probe signals (not available when a time stamp
is acquired).

[IRQ7-0] Selects the states of eight IRQ input signals (not available when a time

stamp is acquired).

[Timestamp] Specifies the time stamp value for bus cycles (only available when a time
stamp is acquired).
Note: Items other than [General], [Address], [Data], [R/W], [Area], [Status], [Probes], and [Timestamp] vary
according to the emulator in use. For details, refer to section 8, Software Specifications Specific to This
Product or the online help.

Set filtering conditions and then press the [OK] button. This starts filtering according to the conditions. Clicking
the [Cancel] button closes the [Trace Filter] dialog box, which holds the settings at the time when the dialog box
was opened.

In filtering, only the trace information that satisfies one or more filtering conditions set in the above pages will
be displayed in the [ Trace] window.

Filtering conditions can be changed several times to analyze data because the content of the trace buffer is not
changed by filtering.
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(1) [General] page
Set the range for filtering.

Trace Filter x|
Status I Frobes I IRQ7-0

General | Addiess | Data | Rew | fea

I i [ Enabls Filter

™ Mot designation
Trace display range
Start PTH: I

End FTR :

QK I Cancel | Apply |

Figure5.85 [TraceFilter] Dialog Box ([General] Page)

[Don't care other pages]: Only selects the cycle number when this box is checked. Other options become

invaid.

[Enable Filter]: Enables the filter when this box is checked.

[No]: Filters information that does not match the conditions set in those pages when this
box is checked.

[Trace display range]: Sets the range for filtering.
[Start PTR]: Enters a PTR value to start filtering.
[End PTR]: Entersa PTR value to end filtering.

Note:  Along with setting the range for filtering, PTR valuesto start and end filtering can be set in the [Start
PTR] and [End PTR] options, respectively.

315
RENESAS




(2) [Address] page
Set address conditions.

Trace Filter x|
Status | Prabes I IRGT-0
General Address | Data I R I Area

[ Don't care
Setting
& Point © Bange

From ; IH'

To: I

QK I Cancel | Apply |

Figure5.86 [TraceFilter] Dialog Box ([Address] Page)

[Don't care]: Detects no address when this box is checked.
[Setting]: Detects the specified address.
[Point]: Specifies asingle address (not available when [Don’t care] has been checked).
[Range]: Specifies an address range (not available when [Don’t care] has been checked).
[From]: Enter asingle address or the start of the address range (not available when [Don’t
care] has been checked).
[To]: Enter asingle address or the end of the address range (only available when [Range]
has been selected).

Note:  Along with setting the address range, the start and end of the address range can be set in the [From] and
[To] options, respectively.

316
RENESAS



(3) [Data] page
Set adata condition.

Trace Filter x|
Status I Frobes I IRQ7-0

General I Address Data | R I Area

Setting
& Point © Bange

From ; IH'

To: I

QK I Cancel | Apply |

Figure5.87 [TraceFilter] Dialog Box ([Data] Page)

[Don't carel: Detects no data when this box is checked.

[Setting]: Detects the specified data.
[Point]: Specifies single data (not available when [Don't care] has been checked).
[Range]: Specifies adata range (not available when [Don't care] has been checked).
[From]: Enter single data or the minimum value of the data range (not available when [Don’t

care] has been checked).

[To]: Enter the maximum value of the datarange (only available when [Range] has been
selected).

Note:  Along with setting the data range, the minimum and maximum vaues can be set in the [From] and [To]
options, respectively.
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(4) [RIW] page
Select the type of access cycles.

Trace Filter x|

Status I Prabes | IRGT-0
General I Address I Data R | Area

— Setting

[IRD
[TwhR

QK I Cancel | Apply |

Figure5.88 [TraceFilter] Dialog Box ([R/W] Page)
[Don't carel: Detects no read/write condition when this box is checked.
[Setting]: Detects the specified read/write condition.

RD: Detects read cycles when this box is checked (not available when [Don't care] has
been checked).

WR:  Detects write cycles when this box is checked (not available when [Don’t care] has
been checked).
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(5) [Area] page
Select the area being accessed. The selection is not available when atime stamp is acquired.

Trace Filter x|

Status I Prabes I IRGT-0 |
General I Address I Data I Rifws Area

IS
— Setting
[JROM -
[CIRaM

1016

I8

[JEXT-16

[JExT-2

[IRAM/DTC hd|

QK I Cancel | Apply |

Figure5.89 [TraceFilter] Dialog Box ([Area] Page)
[Don't care]: Detects no area condition when this box is checked.
[Setting]: Detects the specified area condition (not available when [Don't care] has been checked).

Note: Available area conditions vary according to the emulator in use. For details, refer to section 5.15.4,
Signals to Indicate Bus States and Aress.
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(6) [Status] page
Select the status of a bus. The selection is not available when atime stamp is acquired.

Trace Filter x|
Gerneral | Address I Data I R M I Area
Status | Probes I IRET-0
i :

— Setting
[IPROG
[ IDATA
[ |REFRESH
[ ]DMALC
[DTC
[JOTHER

QK I Cancel | Apply |

Figure5.90 [TraceFilter] Dialog Box ([Status] Page)
[Don't care]: Detects no bus condition when this box is checked.
[Setting]: Detects the specified bus condition (not available when [Don’t care] has been checked).

Note: Available bus conditions vary according to the emulator in use. For details, refer to section 5.15.4,
Signals to Indicate Bus States and Aress.
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(7) [Probes] page
Select the status of four probe signals. The selection is not available when atime stamp is acquired.

Trace Filter x|
Gerneral I Addressz | Data | R M I Area
Status Probes | IRGF-0

— Setting

Probed IDnn'l care'l Probe3 IDon'l care'l
Probe2 IDon'l care 'I Prabel IDnn't cale'l

QK I Cancel | Apply |

Figure5.91 [TraceFilter] Dialog Box ([Probes] Page)
[Don't carel: Detects no probe signal condition when this box is checked.
[Setting]: Detects the specified probe signal condition.
[Probed] to [Probel]: Select probe conditions (not available when [Don't care] has been checked).
Don't care: Detects no selected probe condition.
High: The status of the probe signal is high.

Low: The status of the probe signal islow.
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(8) [IRQ7-0] page

Select the status of IRQ signals. The selection is not available when atime stamp is acquired.

Trace Filter x|
Gerneral I Addressz I Data R M | Area |
Status I Frobes IRE7-0
IRE7 IDon't care "I IRQE Daon't care ™
IRQ5 IDon't care "I IRO4 IDDn't care 'I
IRQ3 IDnn'l care 'I IRE2 IDDn't care 'I
IR IDnn'l care 'I [=Twli] IDon't care "I
QK I Cancel | Apply |

Figure5.92 [Trace Filter] Dialog Box ([IRQ7-0] Page)

[Don't carel: Detects no IRQ input condition when this box is checked.
[Setting]: Detects the specified IRQ input condition.
[IRQ7] to [IRQQ]: Select IRQ input conditions (not available when [Don't care] has been
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checked).
Don't care: Detects no selected IRQ input condition.
High: The status of the IRQ input is high.

Low: The status of the IRQ input islow.
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(9) [Timestamp] page
Specify the time stamp value for bus cycles. The specification is not available when atime stamp is acquired.

Trace Filker x|

Generall .-’-‘«ddressl Data I FAw  Timestamp

Setting
¢ Paint ¢ Range

Bom [ b [ e[ I_msl_usl_ns
o ™ e

S

s

E]

To ng

0k I Cancel | Apply |

Figure5.93 [TraceFilter] Dialog Box ([Timestamp] Page)
[Don't care]: Detects no time stamp value when this box is checked.
[Setting]: Detects the specified time stamp value.
[Point]: Specifies asingle time stamp (not available when [Don't care] has been checked).
[Range]: Specifies atime stamp range (not available when [Don't care] has been checked).

[From]: Enter a single time stamp value or the minimum value of the time stamp range.
Theformat is asfollows:
hour: h, minute: min, second: s, millisecond: ms, microsecond: us, nanosecond: ns
(Not available when [Don't care] has been checked.)

[To]: Enter the maximum value of the time stamp range.
Theformat is as follows:
hour: h, minute: min, second: s, millisecond: ms, microsecond: us, nanosecond: ns
(Only available when [Range] has been selected.)

Note:  Along with setting the time stamp range, the minimum and maximum time stamp values can be set in the
[From] and [To] options, respectively.
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5.16.13 Calculating the Differencein Time Stamping

Select [Timestamp Difference...] from the popup menu to calculate the time difference between the two points
selected by the result of tracing in acquisition of time stamp information.

Timestarmp Difference 2 x|

— Select 2 line

Firzt PTR - |'32?54 Second PTR : ID

[Timestamp difference information :

Timeztamp Difference

0000k 000rmin 000z 003ms 897us B75ns Get Difference
Clear |

( | ] o |

Figure5.94 [Timestamp Difference] Dialog Box
[Select 2 lin€]: Select trace records to calculate the time stamp difference.

[First PTR]: Specifies the first pointer to measure the difference. The pointer of the line
selected on the Trace window is displayed by default.

[Second PTR]: Specifies the second pointer to measure the difference.

[Timestamp Difference]: Displays the results of calculation.

[Get Difference]: Calculates the difference between the specified two points and display itsresult in the
[Timestamp Difference] list.

[Clear]: Clears all the resultsin the [Timestamp Difference] list.

[OK]: Closes the dialog box. All the results in the [ Timestamp Difference] list are cleared.
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5.16.14 Analyzing Statistical I nformation

Choose [Statistic] from the popup menu to open the [Statistic] dialog box and analyze statistical information
under the specified conditions.

c 21x
— Statiztic Analysis
= Default © Fanoe get
Item |<None> ﬂ
Hew
Start I
Eesult |
End :I
Clear |
Result :
Condition | Amount | FTR
N I i
Close |

[Statistic Analysis):
[Default]:
[Range]:
[Item]:

[Start]:

[End]:

[Set]:
[New]:
[Result]:
[Clear]:

[Close]:

Figure5.95 [Statistic] Dialog Box
Setting required for analysis of statistical information.
Setsasingle input value or character string.
Setsthe input value or character string as arange.
Setstheitem for analyss.

Setsthe input value or character string. To set arange, the start value must be
specified here.

Specify the end value if arange has been set (only available when [Range] has been

selected).

Adds anew condition to the current one.

Creates anew condition.

Obtains the result of statistical information analysis.

Clears all conditions and results of statistical information analysis.

Closes thisdialog box. All the results displayed in the [Result] list will be cleared.
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Thisdiaog box alows the user to analyze statistical information concerning the trace information. Set the target
of analysisin [Item] and the input value or character string by [Start] and [End)]. Click the [Result] button after
setting a condition by pressing the [New] or [Add] button to analyze the statistical information and display its
result in the [Result] list.

Note: In thisemulator, only [PTR] can be set asarange. Each of other items must be specified as a character
string. In analysis of statistical information, character strings are compared with those displayed in the
[Trace] window. Only those that completely match are counted. Note, however, that thistest is not case
sensitive. The number of blankswill not be cared either.

5.16.15 Extracting Function Callsfrom the Acquired Trace Information

To extract function calls from the acquired trace information, select [Function Call...] from the popup menu.
The [Function Call Display] dialog box will be displayed.

Furiction Call Display x|
Setting
Enable ta dizplay trace information with function
call only 7
o g " Dizable
0K | LCancel |

Figure5.96 [Function Call Display] Dialog Box

[Setting]: Selects whether or not to extract function calls.
[Enable]: Extracts function calls.
[Disable]: Does not extract function calls.

When [Enable] is selected, only the cycles that include function calls are extracted for display from the acquired
trace information. The content of the trace buffer is not changed by extraction of function cals. Using this
function for the result of the free trace or the trace information that includes function calls allows the user to
know the order of function calls.

326
RENESAS




5.17  Viewingthe Function Call History

The [Stack Trace] window shows the function call history.

5.17.1 Openingthe[Stack Trace] Window

To open the [Stack Trace] window, choose [View -> Code -> Stack Trace] or click the [Stack Trace] toolbar

button ().

Eind| Name VYalue

F func3 {short *) { 000000094 1}

P param 3 000003 ffa { O0x00003£d8 } (short*)
L local 3 '3 { Ox00003fd4 } {unsigned long)
F funcs (short *) { Ox0O0000072

=] param Z 0x00003ffa { 0x00003fed } (short*)
L local Z D'Z { Ox00003fed } {unsigned long)
F funcl {short *) { 00000003 }

=] param 1 0x00003ffa { Ox00003£f0 } (short*)
L local_1 D'l { 0x00003fez } (unsigned long)
F mainf) { O0x0000001Z }

L start D"103 { 0xx00003ffa } {=zhort)

Figure5.97 [Stack Trace] Window

Thefollowing items are displayed.

[Kind]: Indicates the type of the symbol.
F: Function
P: Function parameter
L: Local variable
[Name]: Indicates the symbol name.
[Value]: Indicates the value, address, and type of the symbol.

5.17.2  Viewing the Source Program

Select afunction and choose [Go to Source] from the popup menu to display, in the [Source] window, the source

program corresponding to the selected function.
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5.17.3  Specifying the View

Choose [View Setting...] from the popup menu to open the [Stack Trace Setting] dialog box, which alows the
user to specify the [Stack Trace] window settings.

Mest level (1-64) Iim =

— Display =vmbol
[~ Parameter
[~ Local Variable

— Diaplay Radix
* Hexadecimal
" Decimal
" Octal QK
" Binary

Cancel |

Figure5.98 [Stack Trace Setting] Dialog Box
[Nest level]: Specifies the level of function call nesting to be displayed in the [Stack Trace] window.
[Display symbol]:  Specifies the symbol typesto be displayed in addition to functions.

[Display Radix]: Specifies the radix for displaysin the [Stack Trace] window.
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518

Displaying Memory Contentsas an | mage

The memory contents can be displayed as an image in the [Image View] window.

5181

Opening the [Image View] Window

Choose [View -> Graphic -> Image...] or click the [Image] toolbar button (|i|) to open the [Image Properties]
dialog box shown in figure 5.99.

Irnage Properties

21

— Colar Information:

Eit/Fise! IBbil[|nde:-: Color’ 'I
Sarmpliti: I‘Hi‘1r 'I
Format: I chunky e I

r— Buffer Infomation:

Data Address: IH'UUUUUDDD

=

Palette Address: IH'DDDDDUUD

]

wWidth/Height Size[Fixel]:
fidth; I
Height; I

EBuffer Size:

I H'00000000  Byte

—Wiew [nformation;
—Yiew Mode:——— — Fosition;

* Full Size 2 Position: I 0
" Part Size ' Positicr: I 0

— Start Pozition:
& Tap yid
" Battam Height:

—"WidthdHeaht SizelFirel ————

—
—

OF. I LCancel |

The [Image Properties] dialog box is used to specify the display method of the [Image View] window.

Figure5.99 [Image Properties| Dialog Box
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The following items are to be specified:

[Color Information]:

[Mode]:

[Bit/Pixd]:
[Sampling]:
[Format]:

[Buffer Information]:

[Data Address]:

[Palette Address):

Specifies the color information of theimage to be displayed.

Specifies the format.
[MONOCHROME]: Black and white.

[RGB]: R (red), G (green), and B (blue)
[BGR]: B (blue), G (green), and R (red)
[YCbCr]: Y (luminance), Cb (color difference for blue),

and Cr (color difference for red)
Specifies bits/pixel (valid when RGB or BGR is selected).
Specifies the format of sampling (valid when Y CbCr is selected).
Specifies chunky/planar (valid when Y CbCr is selected).
Specifies the area to store data, size, and the address of the palette.

Specifies the first addressin memory of the areafor display asimage data (in
hexadecimal notation).

Specifies the first address in memory of the color-pal ette data
(in hexadecimal notation; valid when “8Bit” has been selected for RGB or BGR).

[Width/Height Size]: Specifies the width and height of the image.

[View Information]:

[View Mode]:

[Start Position]:

[Position]:

330

[Width (Pixe))]: Specifies the width of theimage (unlessa
prefix isincluded, values are treated as
decima numbers).

[Height (Pixel)]: Specifies the height of the image (unless a
prefix isincluded, values are treated as
decima numbers).

[Buffer Size): Displays the size of the buffer required for
image display as obtained from the width and
height (in hexadecimal notation).

Specifies the location, size, and data start location of the part to be
displayed among the entireimage.

Specifies whether display ison al or part of the screen.

[Full Size]: Theimage is displayed on the whole screen.

[Part Size]: Theimage is displayed on part of the screen.

[Top]: Display of data starts at the upper-left
position.

[Bottom]: Display of data starts at the lower-left
position.

Specifies the position on the screen from which image display isto start (valid when
[Part Size] is selected).
[X Position]: Specifies the X-coordinate of the start
position (unless a prefix isincluded, values
are treated as decimal numbers).
[Y Position]: Specifies the Y-coordinate of the start
location (unless a prefix isincluded, values
are treated as decimal numbers).
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[Width/Height Size]: Specifies the height and width of an image to be displayed on part of the screen.
[Width (Pixel)]: Specifies the width of the display (unlessa
prefix isincluded, values are treated as
decimal numbers).
[Height (Pixel)]: Specifies the height of the display (unlessa
prefix isincluded, values are treated as
decimal numbers).

After the settings have been made in the [Image Properties] dialog box, clicking the [OK] button opens the
[Image View] window.

Even after the [Image View] window is displayed, the display contents can be modified by opening thisdialog
box by choosing [Properties...] from the popup menu.

Figure5.100 [Image View] Window

The memory content is displayed as an image.

5182 Automatically Updating the Window Contents

Checking [Auto Refresh] in the popup menu will alow the window contents to be automatically updated when
user program execution stops.
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5.183 Updating the Window Contents

Selecting [Refresh Now] from the popup menu immediately updates the window contents.

5.18.4 Displaying the Pixel Information

Double-clicking within the window displays information on the pixel on which the mouse pointer islocated in
the [Pixel Information] dialog box.

Pixel InFarmation i' ﬂ

Index Calor

Color mode;

Fixel: Ihdes Mo.195

Pazition

Buffer Size ‘width: I Height: I

Image Size ‘width: Height:

Figure5.101 [Pixe Information] Dialog Box
This diaog box displays pixel information on the cursor location.

[Color Mode]:  Displays the format of theimage.

[Pixe]: Displays color information on the pixel under the cursor (in decimal notation).
[Position]: Displays the cursor location as X and Y coordinates (in decimal notation).
[X]: X coordinate of the cursor.
[Y]: Y coordinate of the cursor.

[Buffer Size]:  Displays the buffer sizein decimal notation.
[Width]: Width of the buffer.
[Height]: Height of the buffer.

[Image Size]:  Displaysthe width and height of the display in decima notation.
[Width]: Width of the display.
[Height]: Height of the display.
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519 Displaying Memory Contents as Waveforms

Memory contents can be displayed aswaveformsin the [Waveform View] window.

5.19.1 Opening the Waveform View Window

Choose [View -> Graphic -> Waveform...] or click the [Waveform] toolbar button to open the [Waveform
Properties] dialog box shown in figure 5.102.

Wavefarm Properties
Data Address:  [H'0000000D |
DataSize:  ahit ] Cancel |
LChannel:
’7 £ Mono " Stereo
Buffer Size:  [H'D0000000 4

Figure5.102 [Waveform Properties] Dialog Box
Specifies the waveform format. The following items can be specified.
[Data Address]: Specifies the start address of datain memory (displayed in hexadecimal).
[Data Size]: Selects 8Bit or 16Bit.
[Channd]: Selects Mono or Stereo.
[Buffer Size]:  Specifies the buffer size of data (displayed in hexadecimal).

After the settings have been made in the [Waveform Properties] dialog box, clicking the [OK] button opens the
[Waveform View] window.

Even after the [Waveform View] window is displayed, the display contents can be modified by opening this
dialog box by choosing [Properties...] from the popup menu.
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i Wavefarm Wiew -|of x|

L H‘HH]I;““
HULRm =

Figure5.103 [Waveform View] Window

Displays the memory contents as waveforms. The X axis shows the number of sampling dataand the Y axis
shows the sampling value.

5.19.2 Automatically Updating the Window Contents

Checking [Auto Refresh] in the popup menu will allow the window contents to be automatically updated when
user program execution stops.

5.19.3 Updating the Window Contents

Selecting [Refresh Now] from the popup menu immediately updates the window contents.

5.19.4  Zoom-In Display

Selecting [Zoom In] from the popup menu displays the waveforms with the horizontal axis enlarged.

5.195 Zoom-Out Display

Selecting [Zoom Out] from the popup menu displays the waveforms with the horizontal axis reduced.

5.19.6 Resetting the Zoom Display

Selecting [Reset Zoom] from the popup menu displays the waveformsin its original size.

5.19.7  Setting the Zoom M agnification

In the [Zoom Magpnification] submenu of the popup menu, the zoom magnification can be selected from 2, 4, or
8.

5.19.8  Setting the Horizontal Scale

In the [XScale] submenu of the popup menu, the size of the X axis can be selected from 128, 256, or 512 pixels.
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5.19.9 Non-Display of Cursor

Selecting [Clear Cursor] from the popup menu hides the cursor display.

5.19.10 Displaying the Sampling I nfor mation

Selecting [Sample Information...] from the popup menu displays the [Sample Information] dialog box.

Sample Information i 3

Data Size: I Bhit
Channel: I fdono

¥ | H'0000310
Walue

v | H'23

Figure5.104 [SampleInformation] Dialog Box

Displays the sampling information of the cursor location in the [Waveform View] window. The following
information is displayed.

[Data Size]:
[Channd]:

[Value]: [X]
[Y]

Displays 8bit or 16hit.
Displays the data channel.

Displaysthe X axis of cursor location.

Displaysthe Y axis of cursor location (displays Y axes for both the upper and
lower plots when Stereo is selected).
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520 Analyzing Performance

Use the performance analysis function to measure the rate of execution time. The performance analysis function
allows the amount of time spent in user-selected areas of memory during the last program run to be shown as
percentages and as a histogram.

The E6000 Emulator does not count every access to the specified the performance analysis range, it is samples at
arate that is dependent on the host PCs speed.

5.20.1 Opening the [Performance Analysis] Window

Choose [View -> Performance -> Performance Analysis] or click the [PA] toolbar button ) to open the
[Select Performance Analysis Type] dialog box.

Select Performance Analysis Tvpe

Perfarmance Analysis: EE000 Perfarmance Analysis

LCancel

Figure5.105 [Select Performance Analysis Type] Window

Select [E6000 Performance Analysis] and then click the [OK] button to open the [Performance Analysis]
window.

«# Performance An. 1ol x|
Index Hame Range Time Count I % I Histogram I -
u] Standby mode u] 0%

1 Watch mode o 0%

Z Hedium mode o 0%

) Sub Sleep mode o] 0%

4 Sleep mode o] 0%

5 Sub Active mode o 0%

[ CPUT mode 27 100% FEEEEEEEEERRERRRRRRES

7 Other Addresses 26 953 FEEFETFFFTFFFFFFFTS

g datal H'000005ZE-H'0000093E 1 4%

Figure5.106 [Performance Analysis] Window

Thiswindow displays the rate of execution timein the area selected by the user during the last program runin
percentages, histogram, or numerical values.

Note: The[Performance Analysis] window has ranges for performance analysis that cannot be deleted. This
range varies depending on the emulator in use. For details, refer to section 8, Software Specifications
Specific to This Product, or the online help.

It is possible to hide any column not necessary in the [Performance Analysis] window. Selecting a column you
want to hide from the popup menu displayed by clicking the right-hand mouse button on the header column
hides that column. To display the hidden column, select the column from the said popup menu again.
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5.20.2  Setting Conditionsfor Measurement

Conditions for measurement can be displayed and changed in the [Performance Analysis] window. Select a point
where a condition isto be set, and then select [Set...] from the popup menu to display the [Add PA Range]
dialog box.

The [Performance Analysis] window has a support function to enter the address range of afunction
automatically if the name of the function is entered to set an address range. Entering a function name in the
[Input Function Range] dialog box displayed by clicking the[...] button on the [Add PA Range] dialog box
automatically enters the address range of the function.

Inpuk Function Range

2l
Function

Sample:: Cancel

Figure5.107 [Input Function Range] Window

Notes: 1. Entering the name of an overload function or a class opens the [Select Function] dialog box. Select a
function in this dialog box. For details on the dialog box, refer to section 5.13.3, Supporting
Duplicate Labels.

2. The addresses figured out are just for reference. In some cases, the end address of a function may be
different. Check the last instruction of the function in the [Disassembly] window to correct the value
set in [End Address] so that it will be the address of the last instruction (in general, the last instruction
of afunctionisaRTS instruction). A label name or an expression can be entered instead of an
address value in boxes where an address should be entered.

5.20.3 Starting Performance Data Acquisition

Execute the [ANALY SIS] command in the [Command Line] window to enable measurement of the execution
time rate. Executing the user program automatically starts measuring the rate of execution time. Stopping the
user program displays the result of measurement in the [Performance Analysis] window.

Note: For detailson the [ANALY SIS] command, refer to the online help.

5.20.4 Deleting a Measurement Condition

Select [Reset] from the popup menu with a measurement condition selected to del ete the condition.

5.20.5 Deleting All Measurement Conditions

Choose [Reset All] from the popup menu to delete all the conditions that have been set.
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Section 6 Tutorial

6.1 Introduction
The following describes the main functions of the emulator by using atutorial program.

Thetutorial program is based on the C++ program that sorts ten random dataitemsin ascending or descending
order. Thetutorial program performs the following actions:

e Thenai n function repeatedly callsthet ut ori al function to repeat sorting.

e Thetutorial function generatesrandom datato be sorted and callsthesort andt ut ori al functions
in order.

e Thesort function entersthe array where the random data generated by thet ut or i al function are stored,
and sorts them in ascending order.

* Thechange function then sorts the array, which was sorted in ascending order by thesor t function, in
descending order.

Thefilet ut ori al . cpp contains source code for the tutorial program. Thefile Tut ori al . abs isa
compiled load module in the Dwarf2 format.

Notes: 1. After recompilation, the addresses may differ from those given in this section.

2. Thissection describes general usage examples for the emulator. For the specifications of particular
products, refer to section 8, Software Specifications Specific to This Product, or the online help.

3. Theoperation address of Tut ori al . abs attached to each product differs according to products.
Replace the address used in this section with the relevant address in each product after checking that
it is placed on the corresponding line of the source program.

4. Inthistutorial, the H8S/2633 E6000 emulator is taken as an example. File paths or the appearance of
figures differs according to products.
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6.2 Runningthe HEW

Open aworkspace by following the procedure listed in section 4.2.3, Selecting an Existing Workspace.

Select the following directory:
HEW install ation destination directory\Tool s\Renesas\DebugComp\Platform\E6000\2633\ T utorial

Note: Thefile path differs depending on the product. Refer to section 8.2.1, Environment for Execution of the
Tutorial Program.

Then select the file indicated below.

21

Lok, jr: I@ Tutarial j - IC:F -

Debug_H&5_2237_EA000_Emulator _CP
SoUrce

File name: |Tutorial.hws Open I
Files of twpe: IWorkspaces [® hws) j Cancel |
S

Figure6.1 [Open Workspace] Dialog Box

Opening this workspace automatically connects the emulator.
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6.3 Downloading the Tutorial Program

6.3.1 Downloading the Tutorial Program
Download the object program to be debugged.

»  Select [Download module] from the popupmenu opened by clicking the right-hand mouse button on
[Tutorial .abs] of [Download modules].

EI@ Tutorial
=-[E Tutorial

B2 C source file

o [H] dbscte
C Y] shike
B2 T+ sounce file
| = Q resetprg. cpp
----- Q zort.cpp
= ] tutorial.cpp
EIE Download modules
Ela Dependenci BEI Dovanload module
..... =] shik.h Davsnload module (debug data anlky)
zort.h Unlead module
E] stacksctk

Configure Wiew, ..

’T Al Docking
Hide:
| |

Figure6.2 Downloading the Tutorial Program
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6.3.2 Displaying the Sour ce Program

The HEW allows the user to debug a user program at the source level.

» Double-click [Tutorial.cpp] under [C++ source fil€].

2=l . . .
El@ Tutoral woid main{woid)
E-[E Tutorial 0=00001036 while (13{
B3 T source file 0=00001034 tutorial():
. +
}
0z00001038 woid tutorial{woid)
2] resetprg.cpp Oz00001044
] sontcpp long all10]:
long 3
int 1:;
Dowrload modules class Sample #p_sam;
Tutorial.abs -
Dependencies 0=00001046 [_=amn= Sanple:
bk ki 0=0000104= for({ i=0: i<10; i++ J{
i 0=00001050 j = rand():
sart 000001058 if(3 ¢ 004
stackscth 000001052 i= -1
0=0000105c alil = 3:
0=z00001070 p =amn—:zort{al);
0=0000107a p_=an-:changeial
O=z00001082 r_san—:=0=a[0]
0=z0000108a r_san—:sl=all]
0=z00001096 p_san—:=2=ala]
O=z000010a2 p_=samn—:=3=al3]:
0=z000010a= P_san—:sd=al4d]:
0=z000010ba p =am—:=E5=a[5]:
0z000010cE p =amn—rz=b=alb]
0xz000010d2 p =amn—:=7=al[7]
0=000010de p =am—:=8=a[8]
0=z000010=a p =an—:z=9=a[9]
Oxz000010£f4 p_samn;
O=000010fc T

Figure 6.3 [Source] Window (Displaying the Sour ce Program)

» Select afont and size that are legible if necessary. For details, refer to section 4, Using the Editor in the HEW
part.

Initially the [Source] window shows the start of the user program, but the user can use the scroll bar to scroll
through the user program and look at the other statements.
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6.4 Setting a PC Breakpoint

A PC breakpoint is a simple debugging function.

The [Source] window provides avery simple way of setting a PC breakpoint at any point in a program. For
example, to set a PC breakpoint at thesor t function call:

» Select by double-clicking the [Editor] column on the line containing the sor t function call.

=111

E@ Tutarial

E-0E Tutorial

-2 T source file

i e[ dhscto
4] sbrk.c
C++ zource file
E resetprg.cpp
E sort.cpp
kL 3
Download modules
e [1] Tutorial abs
Dependencies
g] sbikh
sorkh
E| stackscth

0=00001038
0x00001044

0=00001046
0=z0000104e
0=00001050
0=0000105%8
0=0000105a

0=0000105c

0=00001070
0=0000107a

0=00001082
0=0000108a
0=00001096
0=000010a2
0=z000010ae
0=000010ba
0=000010c6
O=000010d2
0=000010de
0x000010ea
O=000010f6
0=000010fc

wold tutorial (wvoid)
{
long a[10]:
long 3:
int i
cla=z=s Sanple *p_=zam:

O_=amns= Sanple;
for{ i=0; 1<10; i++ ){
J = rand():
1f(3 < 034
1= -1
1

afi] = 3:

p_samn—:=ort{al;
p_samn—:changefa) ;

p_=an—:=0=a[0]
p =an—r=l=a[1]
p =an—:=2=al2]
p_san—r=3=al3];
r_=an—rz=d=a[4]:
p_=san—r=5=a[5]
p_=san—rs=h=a[6]
p_=san—:=7=a[7]
p_san—:=8=a[8]
P san—:=9=a[9]
p_sam;

I

Figure6.4 [Source] Window (Setting a PC Breakpoint)

The symbol « will appear on theline containing the sor t function. This shows that a PC breakpoint has

been set.
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6.5 Setting Registers
Set avalue of the program counter before executing the program.

* Select [Regigters] from the [CPU] submenu of the [View] menu. The [Register] window is displayed.

egister -0l x|
| Register Name | Register Value I
RO H'0ooooooo
RL H'oooooooo
RZ2 H'0ooooooo
R3 H'oooooooo
R4 H'0ooooooo
RS H'oooooooo
RGO H'0ooooooo
R7 H'0oooooo1o
PC H'0oo400
CCE H'&0 I0------
4 H'0?7  ——--- 111

Figure6.5 [Register] Window

» To change the value of the program counter (PC), double-click the value areain the [Register] window with
the mouse. The following dialog box is then displayed, and the value can be changed. Set the program
counter to H’00000400 in thistutorial program, and click the [OK] button.

Register - [PC] 2=l
Walue:
IH'DDDADD
Set b Cancel |
I\N'hnle Reqizter ﬂ

Figure 6.6 [Register] Dialog Box (PC)
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6.6 Executingthe Program

Execute the program as described in the following:

» To execute the program, select [Go] from the [Debug] menu, or click the [Go] button on the toolbar.

Figure6.7 [Go] Button

While the program is executing, the current address bus value and the operating state of the MCU are displayed

on the status bar.

The program will be executed up to the breakpoint that has been inserted, and an arrow will appear on the
[Editor] column in the [Source] window to show the position that the program has halted, with the message

[ Br eak = PCBr eak] in the status bar.

Note:  When the sourcefile is displayed after abreak, a path of the source file may be inquired. The location of

the sourcefileisasfollows:

HEW installation destination directory\Tool s\Renesas\DebugComp\Platform

\E6000\2633\Tutorial\source

Thefile path differs according to products. If necessary, replace \2633 with another name.

0x00001038
O=00001044

0=00001046
0=0000104=
0=00001050
0=00001058
0=0000105=

0=0000105<

O0=00001070 L=
00000107

0=z00001082
0=z0000108a
0=z00001096
O=z000010=2
0=z000010a=
0=z000010ba
0=z000010cz6
O=z00001042
0=z000010de
0=z000010=a
0=z000010f6
0=z000010fc }

wold tutorial (woid)

long a[10]:

long 3

int 1

cla=s Sanple *p =an:

po=am= Sanple;
for({ 1=0; 1<10; i++ )9
i = randi):
1f03 <« 0){
1 = 1.
ali] = 3:

p_=an—=zort(a):
p_=amn—rchangel(al;

p =am—r=0=a[0]
p o=am—r=l=a[l]
p =am—r=2=al2]
p o=amn—r=3=al 3]
p =am—r=4=a[4];
p_=an—>=5=a[5]:
p =am—r=h=al[6];
p o=amn—r=7=al[7]
p =am—r=d=a[8]
p o=amn—r=9=a[9]
p_=amn;

Figure 6.8 [Source] Window (Break Status)
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The user can see the cause of the break that occurred last time in the [Status] window.

Select [Status] from the [CPU] submenu of the [View] menu. After the [Status] window is displayed, open
the [Platform] sheet, and check the St at us of Cause of | ast break.

_ (O] x|
Iten I Status I
Connected To: H2S5/2EZ37 ES000 Ewmulator CPU Z000 (Ewulator PCI Card Driver)
CPUT Ha5/ 2237

Mode 7

Clock =zource Main: 10MH=, Subk:3ZkHz

Dun status Ereak

Cause of last break PC EBreak

Event Time Count 00k O0min 00s 000ms 000us 000ns

Purn Time Count 00k O0min 00s 000ms 9EZ5us £Zfns

4] :IH Wemary  Platform £ Events J

Figure6.9 [Status] Window

Note: Theitemsthat can be displayed in this window differ depending on the product. For the itemsthat can
be displayed, refer to section 8, Software Specifications Specific to This Product, or the online help.
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6.7 Reviewing Breakpoints
The user can see dl the breakpoints set in the program in the [Event] window.

*  Select [Eventpoints] from the [Code] submenu of the [View] menu. The [Event] window is displayed. Select
the [Breakpoint] sheet.

1=
Type State | Condition I Action I

Program Enabhle PC=H'O0001070iTutorial.cpp/4d)] Break

| 4[> Breakpoint £ Event }, Trioger /

Figure6.10 [Event] Window

The popup menu, opened by clicking the [Event] window with the right-hand mouse button, allows the user
to set or change breakpoints, define new breakpoints, and delete, enable, or disable breakpoints.
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6.8 Referringto Symbols
The [Label] window can be used to display the information on symbolsin modules.

Select [Label] from the [Symbol] submenu of the [View] menu. The [Label] window is displayed so that the user
can refer to the addresses of symbolsin modules.

=10 x|
EP Ija.ddress IName I -

H'ooooog00 PowerON_Reset i)

H'Oooolooo _sbrk

H'O0O001034 _main

H'O0O001038 tutorial )

H'O0OO001104 _abort

H'Oooolloc _ INITECT

H'OOO011Ez loopl

H'O0OO011ZC loopz

H'OOO0O11ZE next_loopZ

H'0000113z next_loopl oo

H'O0O001144 loop3

H'OO0O0l1&z loopd

H'O00o0llss next_loopd

H'Oooollsc next_loop3

H'Oo00lles operator new{unsigned lorng)

H'O0OO011EBE _ CALL_TNIT

H'OOOO11EO _ CALL_END

H'OOOOl1E4 operator delete{woid *)

H'O0OO011EE _rand

H'OOO0lzZ& _srand

H'O00O0lz3z $DIVLES

H'Ooooolz3c not_negk

H'oooolz44 not_neg¥

H'00O0124E not_negs LI

Figure6.11 [Label] Window

348
RENESAS




6.9 Viewing Memory

When the label name is specified, the user can view the memory contents that the label has been registered in the
[Memory] window. For example, to view the memory contents corresponding to _nai n in byte size:

e Select [Memory ...] from the [CPU] submenu of the [View] menu to enter _nmai n in the [Start address] edit
box and # f inthe [End address] edit box, respectively, and to select Byt e in the [Format] combo box.

2|

Begin:

I_main

i

LCancel
End:

|+ff

FEormat;

[Byte [x1) =l
Dizplay Walue Az

I.-’-‘«NSI character j

Bytes Count For One Line:
16 Byte =l

Figure6.12 [Format] Dialog Box

e Click the [OK] button. The [Memory] window showing the selected area of memory is displayed.

=0l x|
|
0x00001034 55 0z 40 FC o1 oo &I F3 o1 z0 &D Fa 73 37 oo Zg T E...m...m.¥7. 0
0x00001044 OF F3 1k a0 SE o0 20 {ul] aF =13 13 44 EE oa 11 FO R ) L
0x00001054 17 FO aF a5 4 0z 17 EBE 17 F4 aF co 10 70 o4 EQ R P p..
0x00001064 01 an &3 a5 1)) 54 73 24 an ok 4D E0 oF ES OF 1 50 8ho o Bifio ol o oo o
0x00001074 OF E0 EE oa 0 1] aF Dl aF E0 EE an 20 D& o1 an AT T
0x00001084 &3 0 ol oa 63 E0 oL {ul] &F L0 oa 04 o1 oa &F E0 iP. di...0P..._.0O.
Ox00001094 00 04 o1 on &F 5o on os o1 [aln] &F EO oo os o1 oo [ - Y - P
Ox0000104d EF £o oo ac 01 oo EF EO oo ac o1 oo EF En oo 1o L= =1
0x000010B4 01 oo &F E0 oo 1o oL oo &F 50 oo 14 01 oo &F E0 ooBcoooo oF....o.
0x000010C4 00 14 o1 oo &F 50 oo 13 01 oo &F E0 oo 1z oL oo cooo@scco@ocooo
0x000010D4 &6F Lo oo ic 01 oo &F EO oo ic o1 oo EF 50 oo zo oF... . 0., ... [=1
0x000010E4 01 oo &F E0 oo z0 oL oo &F 55 oo Z4 o1 oo &F ES [ = PR ol §. .0,
0x000010F4 00 24 aF E0 SE o0 11 Eg 73 17 oa g o1 Z0 &l 76 SELTLT. L lmw
0x00001104 01 an &l 73 54 70 54 70 11 70 &D FZ o1 20 &D F4 L .usTpTpTpm. . _m.
0x00001114 74 an [al) oa 15 D4 Th o1 an [al) 15 oC Fh oa 40 10 Hooooo Hooooooo @.
0x00001184 01 an &l 0 a1 o0 & o5 40 0z -1 Di 1F D4 45 Fi .m...w.@.1._ _E.

Figure6.13 [Memory] Window
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6.10 Watching Variables

Asthe user steps through a program, it is possible to watch that the values of variables used in the user program
are changed. For example, set awatch on the long-type array a declared at the beginning of the program, by
using the following procedure:

» Click the left of displayed array a in the [Source] window to position the cursor.

e Select [Instant Watch...] with the right-hand mouse button.

Thefollowing dialog box will be displayed.

Instant Wakeh ﬂ ﬂ
- a § 0x00ffef80 } [long(10]] Cloze I
Add

Figure6.14 [Instant Watch] Dialog Box

e Click the [Add] button to add a variable to the [Watch] window.

(4 x T watch1 £ WatchZ J Wiatch3 j, Watchd J

Figure6.15 [Watch] Window (Displaying the Array)
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The user can also add a variable to the [Watch] window by specifying its name.

e Click the [Watch] window with the right-hand mouse button and select [Add Watch...] from the popup menu.

The following dialog box will be displayed.

Add watch

Wariable or expression;

i Cancel

=
|x

Figure6.16 [Add Watch] Dialog Box

* Input variablei to[Variable or expression] edit box and click the [OK] button.

The [Watch] window will now also show the int-type variablei .

o ] 54
Mame Walue Tupe I
=R a { 0x00ffefB0 } (lonal10])
------ i H'000a {4} [int]
|4 wwatch1 /4 Waich2 } Waich3 J Waichd [
Figure6.17 [Watch] Window (Displaying the Variable)
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The user can click mark ‘+' at the | eft side of array a in the [Watch] window to watch all the elements.

- \atkch

=10l

(lang[ 1001
(lang]
[long)
(lang]
(lang]
[long)
(lang]
(lang]
[long)
(lang]
(lang]
[int]

=B a { 0x00ffef30 }
B [0 H'O00041 o6 { 0w00ffefa0 }
B ] H'00007 67 { 0x00ffef34 }
B 2 H'00002731 { 0x00ffef3a }
- H'O000446b { 0x00ffefEe }
B[] H'0000734b { 0=00ffefa0 }
- [5] H'00001 56 { 0=00ff=f34 }
R [E] H'000059e2 { 0x00ffef38 }
B 7 H'00007 efb { Ox00fefde §
B [l H!DDD03154 { C00ffefal }
B [ H'O0000KE § DwO0ffefad |
i H'000a{ R4 }
|4 E T watch1 £ WWalchZ j Watch3 Ji Wiatchd J

Figure 6.18 [Watch] Window (Displaying Array Elements)

352
RENESAS




6.11 Displaying Local Variables

The user can display locd variablesin a function using the [Locals] window. For example, we will examine the
local variablesinthet ut ori al function, which declaresfour local variables: a,j ,i ,and p_sam

» Select [Locals] from the [Symbol] submenu of the [View] menu. The [Locals] window is displayed.
The [Locals] window shows the local variables in the function currently pointed to by the program counter,

along with their values. Note, however, that the [Locals] window isinitially empty because local varigbles are
yet to be declared.

H'00fefa0 { ERS }
-------- i H'O00a { R4 } (irt)
- p_sam 0+00ffb0d8 { ERE } [class Sample”)

Figure6.19 [Locals] Window

e Click mark ‘+' at the left side of array a in the [Locals] window to display the elements.
» Refer to the elements of array a before and after the execution of the sor t function, and confirm that
random data is sorted in descending order.
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6.12 Stepping Through a Program
The HEW provides arange of step menu commands that allow efficient program debugging.

Table6.1 Step Option

Menu

Command Description

Step In Executes each statement, including statements within functions.

Step Over Executes a function call in a single step.

Step Out Steps out of a function, and stops at the statement following the statement in the
program that called the function.

Step... Steps the specified times repeatedly at a specified rate.

6.12.1 Executing the[Step In] Command
The [Step In] command steps into the called function and stops at the first statement of the called function.

* To sep throughthesort function, select [Step In] from the [Debug] menu, or click the [Step In] button in
the toolbar.

™

Figure6.20 [Step In] Button
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Qx00002000 Sample: (Sample()
i

0=00002006
0x0000201c =0=0;
0=00002026 =s1=0;
0x0000202c =2=0;
0=00002032 s3=0;
0x00002038 =4=0;
0=z0000203e =5=0;
0x00002044 =h=0;
0=z0000204a =7=0;
O0x00002050 =8=0;
0=00002056 =9=0;
O0x00002060 1
0x000020643 orvold Sample: i=ortilong *a)
0=00002070 i
long t:
int i, j. k. gap:
0=00002072 gap = &;
0x=00002078 while{ gap » 0 }{
0=00002078 for{ k=0; k<gap: k++)q
0x0000207c for{ i=k+gap: 1<10; i=i+gap }{
0=00002080 for{j=i-gap: jr=k; j=j—gap)q
Ox00002084 if{aljlsalj+gapl i
t =al1]:
0x000020=4 alj]l = alj+gap]:
0=000020a8 al[j+gap] = t:
b
=l==
break;
¥
b
¥
0=000020c0 gap = gap-2;
0x000020cc 1

Figure6.21 [Source] Window (Step In)

» Thehighlighted line moves to the first statement of the sor t function in the [Source] window.
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6.12.2 Executing the [Step Out] Command

The [Step Out] command steps out of the called function and stops at the next statement of the calling statement
inthe mai n function.

» Tostepout of thesort function, select [Step Out] from the [Debug] menu, or click the [Step Out] button in
the toolbar.

Figure6.22 [Step Out] Button

bec 5]
ject  Optons Buld Debug Memory Tooks Window Help

=10l
b Fle Edt mEIE

Dedd|g:weloTalerDls|@scne ¢ |[# % EH|E | EET Y
wE A HJ@fﬁﬁ % |[Debua_£E000_HES_2237 x| | [Sessioriton_Has 2227 =] | 74 s | [ [ “ﬁ;@. & & i@ ‘ Midh i T & |

BRessBwase e |8er n=|o|faeanpeeo. |r =7 |
x|

0=0000104% D_san- Sanple:
= Tutorial 0=0000104e for{ i=0; i¢l0: i++ 3 ZI
=[5 Tutorial 0=00001050 j = rand():
B 23 C source fle 0200001053 if¢3 < 03
i dbisct 0200001052 ] i= -3
; sbik . .
£ E3 Cov sowce e 0x0000105e ) alil =4
i resetpra.cpp 0200001070 ® p_san—»sort(a):
sort.cpp 0200001072 -3 [_san—>change(a):
: 0200001082 p_san—>s0=a[0]:
3 Download modules 0%0000108a P_san—>sl=a[1]:
4ot Tutarial abs 0=00001096 p_san—=s2=al2]:
=3 Dependencies 0200001022 P_san—>s3=a[3]:
: 020000102 P_san—>s4=a[4]:
Sbrrhh 0=000010ba F_san—»>s5-a[5]
€l 0x000010c6 p_san—>s6=al6]:
stackscth 0x000010d2 p_san—>s7=al[7]:
0=000010d= P_san—>s8=a[8]
0=000010=a P_san—>s3=a[3]
0=000010£6 p_san:

0x000010fc ¥ =
kil _’l_l

T @pr. [ETe.. | <dna " tioridlopp |2 sotepp |

[ Name [ Value [ Type

i EE { D00f=fE0 } {longl10]
B [0 HIOOODDH { 000130 } {long)
B M HO00015tb § 0400fefdd } {lonal
R [ 000167 { 0wD0fet8 } {long)
B [ HO0001 efb { D400t } {lonal
B[4 0002781 { 0wD0fef30 } {long)
B [ HO0O0354 { D400fef4 } {lonal
B [ 000416 { 0wD0fel35 } {lonal
B 7 HO0004466 { 0wD0fetSe } long)
B [ HO0005322 { 0wD0ffef=0 } {lonal
=] HO000734b { 0wD0ffetas } long)
i HO00s { R4 } {int)

[A[F]Watch1 £ Waich2 J\ Walchd ), Waichd J
Break = Stepping Completed [Read-write  [45/69 17 s NUM

Figure6.23 [HEW] Window (Step Out)

The data of variable a displayed in the [Watch] window is sorted in ascending order.
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6.12.3 Executing the [Step Over] Command

The [Step Over] executes afunction call as a single step and stops at the next statement of the main program.

To step through all statementsin the change function at asingle step, select [Step Over] from the [Debug]
menu, or click the [Step Over] button in the toolbar.

Figure6.24 [Step Over] Button

O Fle Edit View Project

Options Buld Debug Memory Inoks Window Help
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=181x|
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= |
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T 0=00001046 p_san= Sanple: j
& Tuto ) 0x=0000104= for{ i=0; i<10; i++ ){ =
=-0F Tutorial 000001050 3 = rand():
E-E3 Csource file 0x00001058 if¢3 < 03
dbsctc 0200001052 ) i= -3
sbik.c .
E1E3 Cov ompenfio 0=0000105c ali] = j:
resetpra.cpp 0200001070 . p_san—>sort(a):
0200001072 p_san—>change(s):
i 0=00001082 & p_san—>s0=5[0]
4 Downlosd modules 0200001082 PR Frplepyia]
Tutorial abs 000001096 p_san—>s2=a[2]
{23 Dependencies 0=000010a2 P_san—>s3=a[3]:
ik h 00000102 P_san—>sd=a[4]:
" 0x000010ba P_san—>s5=a[5]:
€ 0=000010ck p_san—>sh=alf]
stackscth 0=000010d2 p_san—>=7=a[7]
0=000010de p_san—>sB=a[8]
0=000010ea p_san—>s3=a[3]
0=000010£6 p_san.
0=000010fc i =
Kl _’I_I
" e [ETe. | dna. G Worislepp |5 swepp |
[ Wame [ value | Type
T[=-rTa {Dx00fef0 | {long[10]
Rl H000734b { 000ft=f80 } llang]
B H000059%2 { 0x00f=f4 } llang]
=Nl HO000446b { 000 eiE8 } {long)
ENE 00004126 { 000fefec } llang]
R [ H00003154 { D400ffet90 } (long)
R[5 HO0002781 { 000ffef34 } llang]
R I8 HO00D1fb { D400ffeto8 } llang]
R M HO00D167e { 000feie } {long)
R I8 HO000150b { D400ifefan } llang]
R [ 000006 { 0x00fefad } (long)
i HO00= (R4} {irt)
A * ] Watch1 £ Watcha i vwatch3 i waiena

Break = Stepping Completed

[Read-write  [+8/69

1 ms [ M g

Figure6.25 [HEW] Window (Step Over)
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6.13 Forced Breaking of Program Executions
The HEW can force a break in the execution of a program.
* Cancd all the breaks.

» To execute the remaining sections of thet ut or i al function, select [Go] from the [Debug] menu or the
[Go] button on the toolbar.

Ell

Figure6.26 [Go] Button

» The program goes into an endless loop. To force abreak in execution, select [Halt] from the [Debug] menu
or the [Stop] button on the toolbar.

Figure6.27 [Stop] Button

6.14 Resettingthe MCU

Resetting the MCU initializes the internal 1/0 registers and makes the program counter jump to the address set in
the reset vector.

To reset the MCU, select [Reset CPU] from the [Debug] menu or the [Reset CPU] button on the toolbar.

Ejj

Figure6.28 [Reset CPU] Button

To execute the program from the reset vector, select [Reset Go] from the [Debug] menu or the [Reset Go] button
on the toolbar.

Figure6.29 [Reset Go] Button

Note: Thistutorial program is executable from the reset vector.
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6.15 Break Function

The emulator’s break functions are of two types: PC breaks and breaks at event points. PC breakpoints and
event points are set in the HEW' s [Event] window.

An overview and setting of the break function are described below.

6.15.1 PC Break Function
The emulator can set up to 256 PC breakpoints.

»  Select [Eventpoints] from the [Code] submenu of the [View] menu. The [Event] window is displayed.
» Select the [Breakpoint] sheet.

ol Event —|O0]| x
wevet =10l x|

Tvpe dtate | Condition I Action I

[ 4]+ ] Breakpoint £ Event }, Trigger /

Figure6.30 [Event] Window (Before Setting a PC Breakpoint)

* Click the [Event] window with the right-hand mouse button and select [Add...] from the popup menu.
» The[Breakpoint/Event Properties] diaog box is displayed.

RENESAS
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Breakpoint/Event Properties

General

— Tupe
" P[EBreak

" Evert

21

Address
 Donb Care %) &ddrezs © Hange

bddress Lo 400001082
Address il 400000000

[T Outside Range

- Data Compare [irection—;
[ Compare = Wse ask | Bead
Walue [

- IHD 1 wiite
& Bute. £ wiod
Hask IH'D * Either

o]

Cancel

Figure6.31 [Breakpoint/Event Properties] Dialog Box

»  Check the [PC Break] radio button in the [ Type] group box.

» Usethe[Source] window to refer to the address on the line that has ‘' p_sam->s0=a[0];" within the
tutorial functionand enter thisaddressin the [Address Lo] edit box of the [Address] group box. In this

example, enter H 00001082.

Note: Thisdiaog box differs according to the product. For theitems of each product, refer to section 8,

Software Specifications Specific to This Product, or the online help.

e Click the [OK] button.

The PC breakpoint that has been set is displayed in the [Event] window.

Type State Condition

Program Enable

PC=H'00001082 (Tutorial.cpp/47)

| 4] =T Breakpoint /£ Event ) Trigger J

Figure6.32 [Event] Window (PC Breakpoint Setting)

Note: Theitemsthat can be displayed in this window differ depending on the product. For the itemsthat can
be displayed, refer to section 8, Software Specifications Specific to This Product, or the online help.
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* Close the [Event] window.

* To stop thetutorial program at the breakpoint, select [Reset Go] from the [Debug] menu.

The program runs until it stops at the breakpoint that has been set.

0=00001038
0x00001044

0=00001046
0=0000104e
0=00001050
O0=00001058
0x0000105&a

0=0000105z

0=00001070
0=0000107a

Ox00001082
0=0000108a
0x000010%96
0=000010a2
0x000010as
0=000010ba
0x000010ce
0=000010d2
0x000010de
0=z000010ea
0x000010fe
0=000010f=

wvolid tutorial{void)

1

¥

long a[l10]:;

long 3:

int 1i:

clas=s Samnple *p_sam;

p_=amn= Sample:;
for{ i=0; 1<10; i++ }{
] = rand():
1f(3 < 03{
1 = -1
ali1] = 3:

p_sam—r=ort(a):
p_samn—>change{a):

p_san—>=0=a[0]:
p_=samn—r=l=a[l]:;
p_san—:=2=al[2]:
p_samn—r=3=al[3]:
p_san—r=d=ald]:
p_=sam—:r=5=a[5]:
p_san—rzb=al[b]:
p_samn—:=7=a[7]:
p_san—>=8=a[8]:
p_samn—:=9=a[9]:
P_sam;

Figure 6.33 [Source] Window at Execution Stop (PC Break)

The [Status] window displays the following contents:

- Status

=0l x|

Ttem IStatus I

Connected To:

Mode 7
Clock source
Dun status Break

Event Time Count
Dun Time Count

Main: 10MH=,

Cause of last break PC Break
00k O0min O00s O00Oms O0COus O000ns
00k O0min O0s O0lms O02Zus S00ns

H22/2237 E&E000 Emulator CPU 2000 (Emulator PCI Card Driver)
CPTT HES/ 2237

Sub: 3ZkH=

4] Memary }, Platform # Events f

Figure 6.34 Displayed Contents of the [Status] Window (PC Break)

Note: Theitemsthat can be displayed in this window differ depending on the product. For the itemsthat can
be displayed, refer to section 8, Software Specifications Specific to This Product, or the online help.
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6.15.2 Breaking Execution at Event Points

Setting up of an event point on event channel 1 (Ch1) such that abreak is triggered when the event point’s
conditions have been satisfied five timesis explained as an example of the use of event points.

*  Select [Eventpoints] from the [Code] submenu of the [View] menu. The [Event] window is displayed.

» Thebreakpoint that has been previously set must be deleted. Click the [Breakpoints] window with the right-
hand mouse button and select [Delete All] from the popup menu to delete all the breakpoints that have been
set

e Click the [Event] tab.

Up to 12 event points (eight event channels and four range channels) can be set up as independent conditions. In
this example, we are setting the condition for event channel 1.

=1

Ch% (R) Eupty
Chlo(R) Ewpty
Chll (R} Eupty
Chlz (R) Ewpty

4[> T, Breakpoint ), Event /£ Trigoer f

Figure6.35 [Event] Window (Event Channel 1 [Ch1])

* Select thelinefor Chlin the [Event] window. Double-click on thislinethat is highlighted.

* The[Breakpoint/Event Properties] diaog box is displayed.

* Make the following settingsin the boxes on the [General] page:
Select the [Event] radio button in the [Type] group box.
Select the [Address] radio button in the [Address] group box. Then use the [Source] window to refer to the
address on the line that has ‘g[i]=j;" withinthet ut ori al function and enter this addressin the [Address
Lo] edit box. In this example, enter H 0000105c.

* Enter D' 5 asthe number of times the event condition isto be satisfied in the [Required number of event
occurrences] edit box on the [Action] page.
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Breakpoint/Event Froperties 2=

General |Bus / twea | Signals | Action |

— Type Address
" PC Break " Don't Care @ Addiess ¢ Fange

Address Lo [
& Evert = . | H'00001 05

Address B [H00000000

[T Outside Fange

— Data Compare Direction——
[ Compare 7| Wse Mask " Read
Walue [
- IHD £ Wdrite
¢ Bute € Word
pask IH'D * Either

Ok, I Cancel |

Figure6.36 [General] Page ([Breakpoint/Event Properties] Dialog Box)

* Click the [OK] button. The [Event] window is displayed, as shown below.

_lglx
Type State Condition I Action I
Chl (E) Enable Address=H'0000105C (Tutorial.cpp/d2) address count 'S Break

Chz (E) Enpty

Chi (E) Enpry

Chd (E) Enpty

Chs (E) Enpty

Cht (E) Enpry

Ch7? (E) Enpty

Chi (E) Enpty

ChY (R] Enpry

Chl0(R) Enpty

Chll (R} Eupty

ChlZ (R} Eupty

A>T Breakpaoint p Event £ Trigoer f

Figure 6.37 [Event] Window (Setting Completed)

Note: Theitemsthat can be displayed in this window differ depending on the product. For the items that can be
displayed, refer to section 8, Software Specifications Specific to This Product, or the online help.

Select [Reset Go] from the [Debug] menu to stop the tutorial program at breakpoints.

The program runs then stops at the condition specified under Ch1.
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0=00001038

0=z00001044

long a[107]:

long 3@

int 1

claz=z Sanple *p _=am;
0=00001046 D_=am= Sample;
0=z0000104e for{ i=0; 1<10; i++ ){
0=z00001050 i = randi):
O=z00001058 if{3 < 03
0=z0000105& i = =3

1

0=z0000105: | d o> al[i] = 3:

wold tutorial{void)

0=00001070 p =am—r=ortia);
0=0000107a p_=zan—:>change(a);
O=z00001082 p_=zan—:=0=a[0];
0=0000108a p =am—r=l1=a[l]:
0=00001096 p_=zan—:=2=al[2];
0=000010a2 p =am—r=3=al[3];
0=z000010as p_=zan—>sd=ald];
0=000010ba p =am—r=5=a[5];
0=z000010ck p_=zan—:s=6=al&];
O0=000010d2 p =am—r=7=al[7].
0=z000010de p_=zan—:>=8=a[8]:
0=000010ea p =am—r=9=a[9];
0=z000010f6 p_=amn;
0=z000010fc ¥

Figure 6.38 [Source] Window at Execution Stop

The [Status] window displays the following contents.

Ttem IStatus

=101 x|

Connected To:
CPUT

Mode

Clock source
Lun status

Event Time Count
Lun Time Count

H22,72227 E6000 Emulator CPU 2000 (Emulator PCI Card Driwver)

H35/ 2237

7

Main:10MH=, Sub:3ZkH=
Ereak

Canse of last break Complex Ewvent Svystem

O0h O0min 00s 000ms O000us O000ns
O0h O0min 00s 000ms 738us 750ns

AT Memaory ) Platform f Events /

Figure 6.39 Displayed Contentsof the [Status] Window

Refer to the [Watch] window for the value of variablei . The valueis 4, indicating that the break occurred after
the condition had been satisfied five times.

Note: Theitemsthat can be displayed in this window differ depending on the product. For the items that can be
displayed, refer to section 8, Software Specifications Specific to This Product, or the online help.

Remove the event point. Clicking the right-hand mouse button on the [Event] window displays a popup menu.

Select [Remove All] from this menu to remove all event points.
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6.16 Trace Functions

The trace functions of the emulator use the realtime trace buffer, which is able to store the information on up to
32,768 bus cycles. The content of this buffer, which is constantly updated during execution, is displayed in the
[Trace] window.

Select [Trace] from the [Code] submenu of the [View] menu to display the [Trace] window.

b Generic Trace -|0Of x
=10 ]

PTR | Address Instructlonl Datal BAW | Area‘ dtatus | Clack | Probes‘ HMI ‘ IR07-0 | Timestamp | Source Label | Timestamp-Difference |

Figure6.40 [Trace] Window

When trace information is displayed in the [Trace] window, clicking the right-hand mouse button on the [Trace]
window displays a popup menu. Select [Clear] from this menu to clear the trace information.

The following sections give an overview of the trace functions and methods for setting them.
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6.16.1 Displaying a Trace (when Time Stamping isnot Available)

The method used to specify an address as an event condition for the tracing of read/write cycles and display the
traceis described below.

(1) Clicking the right-hand mouse button on the [Trace] window displays a popup menu. Select [Acquisition...]
from this menu to display the [Trace Acquisition] dialog box.

Trace Acquisition il il

General IStop I Delayed Stopl

—Suppress—————— Tirme Stamp
¥ Free Trace

Clock:

[~ DIC Cycles I Dizabled - l

[~ Befrash Cycles

r Trace Ewent:

Exwent:

~

add.. | Edi. Semuence.. Delee | | Dl |

ak. I Cancel

Figure6.41 [Trace Acquisition] Dialog Box
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(2) Regigter an address as an event condition for trace acquisition. Click the [Add...] button in the [Trace
Events] group box on the [General] page to display the [Breakpoint/Event Properties] dialog box.

Breakpoint/Event Properties 2=

Gieneral |Bus / twea | Signals | Action |

— Type Address
) EC Break " Don't Care @ Address ¢ Range
............... Address Lo [

& Evert . |H00000000

Address B [H00000000

[T Outside Fange

— Data Compare Direction——
[ Compare 7| Wse Mask " Read
Walue [
- IHD £ Wdrite
¢ Bute € Word
pask IH'D * Either

Ok, I Cancel

Figure6.42 [Breakpoint/Event Properties] Dialog Box

(3) Use the [Source] window to refer to the address on the line that has‘[i]=j;’ withinthet ut ori al function
and enter this addressin the [Address L o] edit box of the [Address] group box on the [General] page of the
[Breakpoint/Event Properties] dialog box. In this example, enter H 0000105c. This address has thus been
set. Click the [OK] button to close the [Breakpoint/Event Properties] dialog box.

Breakpoint/Event Properties 2=

Gieneral |Bus / twea | Signals | Action |

~ Twpe Address
) EC Break " Don't Care @ Address ¢ Range

AddressLa |H'0000 05C

{* Ewent .
Address B [H00000000
[T Outside Fange
— Data Compare Direction——
[ Compare 7| Wse Mask " Read
Walue IH'D

£ Wdrite

¢ Bute € Word
bask|HD

Ok, I Cancel |

Figure 6.43 [Breakpoint/Event Properties] Dialog Box (after Setting an Event)
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(4) The event that has been set is now displayed in the [Event] combo box of the [Trace Events] group box on
the [General] page of the [Trace Acquisition] dialog box.

Trace Acquisition ﬂﬂ
General | Stop | Delayed Stop |
—Suppress————— Time Stamp
¥ Eree Trace
[~ DMAL Cycles Clack:
I DIC Cycles IDisabIed M|
[ Eefresh Cycles
— Trace Events
Ewent:
{3 (R] H105C address |
Edit... Sequence,.. Delete | Del &l |
ak. | Cahicel |

Figure6.44 [Trace Acquisition] Dialog Box (Adding an Event)
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(5) To enable the event condition that has been set, uncheck the [Free Trace] check box on the [General] page.
Thiswill add pages[1] to [4] to the [Trace Acquisition] dialog box.

Trace Acquisition ilil
General |Stop | DelapedStop| 1 |2 |3 |4 |
—Suppress———————— Time Stamp

[~ DMAC Cycles Clack:

[~ DIC Cycles IDisabIed 'l

[ Refresh Cycles

 Trace Events

Exent:
|9 [R] H'105C address =]
bgd.. | Ed. Sequence.. Delte | Delal |

0K I Cancel |

Figure6.45 [Trace Acquisition] Dialog Box (Pages Added)
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(6) Select page [1] and click the [Range] radio button in the [Conditions] group box. Thiswill display the [Range
Event] combo box and the [Edit...] button.

Trace Acquisition 2l x|
General | Stop I Delayed Stop 1 |2 I 3 I 4 I

r— Conditions

" Disabled " Paint to Point

Fianae Ewent

0K I Cancel |

Figure6.46 [Trace Acquisition] Dialog Box (Displaying Page [1])
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(7) Select the event you have registered from the [Range Event] combo box. The event is now enabled. Click the
[OK] button to complete the trace setting.

Trace Acquisition ﬂﬂ

Gerneral I Stop I Delayed Stop 1 |2 I 3 I 4 I
r— Conditions

" Disabled " Puint to Point ' Range " Ewent

Range Event Edi... |

ak. I Cahicel |

Figure 6.47 [Trace Acquisition] Dialog Box (Setting Completed)

(8) Make the setting such that the break occurs after the instruction at the address on the line that has *&i]=j;’
withinthet ut ori al function (H 0000105C in this example) has been executed five times (for details on
this, refer to section 6.15.2, Breaking Execution at Event Points).

(9) Select [Reset Go] from the [Debug] menu. Processing stops when the break condition is satisfied, and the
[Trace] window then displays the following content.

o Generic Trace =] 54|
PTR | Address | Instruction | Data| B/W | Area | Status | Clock | Probes | WNI | IR07-0 | Timestaup | Source | Label | Timesteup-Difference |
-00004 0010Sc  EXTS.L KR4 1764 ED  ROM  PROG 1 11 alil = 4
0000 00l0Sc  EXTS.L  ER4 1764 BD  ROM  PROG 1 1111 1 11111 alil = 3
-0000Z D0L0Sc  EXTS.L KR4 1764 BD  ROM  PROG 1 11 1 aril = 1
-0D001 0D10Sc  EXTS.L KR4 1764 RD  ROM  PROG 1 1111 1 alil = 1
+00000 Q0105¢ EXTS.L  ER4 1764 RD  ROM  PROG 1 1111 1 11111 alil = 3

Figure 6.48 [Trace] Window (Displaying the Result)

If you have trouble viewing a column, drag the header (vertical) bars below the title bar to adjust the width
of the column.

(10) Remove the event points that have been set and clear the trace information. Click the right-hand mouse
button on the [Event] window to display a popup menu. Select [Delete All] from this menu to remove all of
the event points that have been set. Click the right-hand mouse button on the [Trace] window to display a
further popup menu. Select [Clear] from this menu to clear the trace information.
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6.16.2 Displaying a Trace (when Time Stamping is Available)

Thefollowing procedure is for obtaining and displaying, with time stamps, trace information on cycles of
writing to memory locations in the specified address range.

(2) Clicking the right-hand mouse button on the [Trace] window displays a popup menu. Select [Acquisition...]
from this menu to display the [Trace Acquisition] dialog box (see figure 6.41, [Trace Acquisition] dialog
box).

(2) Regigter the address range for trace acquisition as an event condition. Click the [Add...] button in the [Trace
Events] group box on the [General] page to display the [Breakpoint/Event Properties] dialog box (see figure
6.42, [Breakpoint/Event Properties] dialog box).

(3) Click the [Range] radio button in the [Address] group box on the [General] page of the [Breakpoint/Event
Properties] dialog box. Use the [Locals] window to refer to the address on the line where variable a, which is
defined withinthet ut ori al function, isalocated (H OOFFEF80 in this example) and enter this address
in the [Address Lo] edit box. Then enter an address, which is H' 27 added to that entered in the [Address L o]
edit box (H O0FFEFAY in thisexample), in the [Address Hi] edit box. This procedure sets the memory
range for variable a of thet ut ori al function.

(4) Click the [Write] radio button in the [Direction] group box to set awrite cycle for the specified range. This
completes the setting of a memory range. Click the [OK] button to close the [Breakpoint/Event Properties]
dialog box.

Breakpoint/Event Properties 2x|

General |Bus /&uea | Signals | Action |

™ Type Address
¢ PCBreak | | © DonftCare © Addiess & Range

Address Lo [H'0OFFEFAD

&' Event _
AddressHi - [H'OOFFEFAT
[ Outside Fange
— Data Compare Diirection——
[~ Compare [ Wze bask " Read
Walle IH'D

) Bute. £ Wwiord
Hask IH'D

ak I Cancel |

Figure6.49 [Breakpoint/Event Properties] Dialog Box (after Setting an Event)
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(5) The event that has been set in the [Event] combo box of the [Trace Events] group box on the [General] page

of the[Trace Acquisition] dialog box is displayed.

Trace Acq

General I Stop I Delayed Stopl
— Suppress Tirme Stamp
[~ DMAC Cycles
[~ DIC Cycles

[~ Befrash Cycles

Clock:

IDisabIed 'l

¥ Free Trace

2|

r Trace Ewent:

Exwent:

IS [R) H'FFEF20 range to H'FFEFAT write

Edit... Seguence,..

Delete |

pelal |

~

ok |

Cancel |

Figure6.50 [Trace Acquisition] Dialog Box (Adding an Event)

(6) To enable time stamping, select 125ns from the [Clock] combo box of the [ Time Stamp] group box.

Trace Acq

General I Stop I Delayed Stopl
— Suppress Tirme Stamp
[~ DMAC Cycles
[~ DIC Cycles

[~ Befrash Cycles

Clock:

¥ Free Trace

2|

r Trace Ewent:

Exwent:

IS [R) H'FFEF20 range to H'FFEFAT write

~

sdd.. | Ede. Semuence.. Delte | Delal |
Ok I Cancel |

Figure6.51 [Trace Acquisition] Dialog Box (Time Stamping is Available)
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(7) To enable the event condition that has been set, uncheck the [Free Trace] check box on the [General] page.
Thiswill add pages[1] to [4] (see figure 6.45, [Trace Acquisition] dialog box).

(8) Select page [1] and click the [Range] radio button in the [Conditions] group box. Thiswill display the [Range
Event] combo box and the [Edit...] button (see figure 6.46, [Trace Acquisition] dialog box).

(9) Click the [Range Event] combo box to select the event you have registered. The event is now enabled. Click
the [OK] button to complete the trace setting.

2l
General I Stop I Delayed Stop 1 |2 I 3 I 4 I
— Conditions

" Dizabled

= Paint to Point {* Hange " Ewent

Range Event

3 [R) H'FFEFS0 range to H'FFEF,

[ o |

Cancel |

Figure6.52 [Trace Acquisition] Dialog Box (Setting Completed)

(10) Make the setting such that the break occurs after the instruction at the address on the line that has ‘p_sam-
>30=g[0];" withinthet ut ori al function (H 00001082 in thisexample) (for details on this, refer to
section 6.15.1, PC Break Function).

(11) Select [Reset Go] from the [Debug] menu. Processing stops when the break condition is satisfied, and the
[Trace] window then displays the following content.

® Generic Trace (=] 5|
PTR | Address| I..| Data| R/W | area| 5...| clock | P...[mMI | 1R07-0 | Timesteup | 5..) L..| Timestanp-Difference |~
-00087 ££e£80 ooon TR 0000K000TiNO00S0N0Ns 744us375ns 0000hON0W1N0ADSON0MsN0MUSON0nS
00086 Efefsz ale6 R 0000K000RiN0005000ns744us500ns 0000KD00R1N0002000Rs000WS1250s
-00085 £fefBd ooon TR 0000KA00TANO00S000us 764us8T5ns 0000hON0M1N0ADSON0NsN20us375ns
00084 E£efs6 167 R 0000K000RiN0005000Rs 76 54s000ns 0000KD00R1N0002000RS000US1Z5ns
-00083 ££ef8H ooon TR 0000KA00TANO00S000us 765us375ns 0000hON0M1N0ADSON0NsN20us375ns
00082 Efef8a 2781 R 0000K000RiN0005000ns 785u500ns 0000KD00R1N0002000RS000US1Z5ns
00081 £fefBe ooon TR 0000KA00TiNO00S0N0usE05USET5ns 0000hON0M1N0ADSON0NsN20us375ns
00080 Efefse a46b R 0000K000RiN0005000nsB05U000ns 0000KD00R1N0002000RS000US1Z5ns
-00079 ££e£80 ooon TR 0000KO00TANO00S0N0usB26us375ns 0000hON0M1N0ADSON0NsN20us375ns
-00078 Efefoz 794b R 0000K000RiN0005000ns 526U 500ns 0000KD00R1N0002000RS000US1Z5ns
-00077 £fefad ooon TR 0000K000TANO00S0N0us F46uSET5ns 0000hON0M1N0ADSON0NsN20us375ns
00076 E£e£96 15tb R 0000K000RiN0005000ns54Tus000ns 0000KD00R1N0002000RS000US1Z5ns
-00075 ££e£95 ooon TR 0000KA00MANO00S0N0usEETUs375ns 0000hON0M1N0ADSON0NsN20us375ns
-00074 £fef9a 5%e2 TR 0000h000Rin000s000ms857us500ns 0000h000min000s000ms000us125ns
nnnes freran nonn_im NA0NKNNNNANN=NNNmaRATH2ATSna T ]|

Figure6.53 [Trace] Window (Displaying the Result)

If you have trouble viewing a column, drag the header (vertical) bars below the title bar to adjust the width

of the column.
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(12) Remove the event points that have been set and clear the trace information. Clicking the right-hand mouse
button on the [Breakpoints] window displays a popup menu. Select [Delete All] from this menu to remove
all the event points that have been set. Clicking the right-hand mouse button on the [ Trace] window
displays afurther popup menu. Select [Clear] from this menu to clear the trace information. To disable time
stamping, select Disabled in the [Clock] combo box of the [Time Stamp] group box on the [General] page
of the[Trace Acquisition] dialog box.

6.16.3 Statistics
The number of times the internal RAM has been written to can be included in the acquired trace information.

(1) Make the setting such that a break occurs at the address on the line that has ‘p_sam->s0=a[0];" within the
tutorial function (H 00001082 in thisexample) (for details on this, refer to section 6.15.1, PC Break
Function).

(2) Select [Reset Go] from the [Debug] menu. Processing stops when the break condition is satisfied, and the
[Trace] window then displays trace information.

(3) Select [Statigtic...] from the popup menu that is displayed when you click the right-hand mouse button on

the [Trace] window. A message box appears, indicating that the trace datais being loaded, and the
[Statistic] dialog box will be displayed.

: 21
r— Statistic: Analysis
K Set
ltem |<Nnne> j
Start : I
Eiesult |
End :I
[Clear |
Result :
Condition | ArnoLint | PTR
KN I i
Cloze |

Figure6.54 [Statistic] Dialog Box
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(4) Select R/W in the [Item] combo box and enter WR in the [Start] edit box. After that, click the [New] button.
“R/W=WR”" is now displayed in the [Condition] column of the [Result] list box.

! 21x
— Statiztic Analysis
{* Default © Fange Set
ltem IF!N\-" ﬂ
Start : IWH
Bezult |
End :I
Clear |
Result :
Condition | Amount | FTR
R =R
KN I i
Close |

Figure6.55 [Statistic] Dialog Box (New Condition)
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(5) Then, select Areafrom the [Item] combo box and enter RAM in the [Start] edit box. After that, click the
[Add] button; the new condition is now added to the “R/W=WR” display in the [Condition] column of the
[Result] list box, so that it now shows*“R/W=WR & Area=RAM". This completes setting of the condition.

— Statiztic Analysis

{* Default © Fange

ltem : farea |
Start : IHAM

End |

Result:

Candition | Amount | PTR

RAw'=wR & Area=RaM

K i
Close |

Figure6.56 [Statistic] Dialog Box (Condition Added)
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(6)

To start statistical analysis of the specified condition, press the [Result] button. The number of write
operations that satisfy the condition and the PTR values will be displayed.

: 21x]
— Statiztic Analysis
¢ Default © Hanoe Set
ltem I.&rea ﬂ
Start : IHﬂM
End : |
Clear |
Result :
Condition | Amount | FTR
RAw'=w R Area=RAM 1114 -09063,-09058,-0905:
N I i
Close |

@)
()

378

Figure6.57 [Statistic] Dialog Box (Result of Analysis)

Click the [Close] button to close the [Statistic] dialog box.

Remove the event points that have been set and clear the trace information. Clicking the right-hand mouse
button on the [Event] window displays a popup menu. Select [Delete All] from this menu to remove al the
event points that have been set. Clicking the right-hand mouse button on the [Trace] window displays a
further popup menu. Select [Clear] from this menu to clear the trace information.
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6.16.4 Function Calls
This mechanism is used to only collect trace information on the function calls.

(1) Make the setting such that a break occurs at the address on the line that has ‘p_sam->s0=a[0];” within the
tutorial function (H 00001082 in thisexample) (for details on this, refer to section 6.15.1, PC Break
Function).

(2) Select [Reset Go] from the [Debug] menu. Processing stops when the break condition is satisfied, and the

[Trace] window then displays trace information.
(3) Select [Function Call...] from the popup menu displayed by clicking the right-hand mouse button on the
[Trace] window. The [Function Call Display] diaog box will be displayed.

Furiction Call Display e |
Setting

Enable ta dizplay trace information with function
call only 7

{~ Enable

0K | LCancel |

Figure 6.58 [Function Call Display] Dialog Box

(4) Click the [Enable] radio button and then the [OK] button. Only the information on function callsis now
displayed in the [Trace] window (the [Label] column’s right-side boundary has been moved to the left in the
[Trace] window to show the function calls).

Wl GEneric Trace _I_I— o 5'
Label | PR | add...| Instruction | pata| /| Area| Status | Clock | Probes | mmMr | IRo7-0 |-
PowerOl_Reseti) -09108 000400 MOV.L #H'00FFEFCO,ER? 7a07 FD EROM  PROG 1 1111 1 11111111
_main -03582 001034 BSR Btutorialij:s 550z FD EROM  PROG 1 1111 1 11111111
tutorial|) -03578 001038 MOV.L ER3,B-ER7 0100 R ROM  PROG 1 1111 1 11111111
Sample: :Sauple(] ~03558 002000 MOV.L ERZ,B-ER7 0100 RD ROM  PROG 1 1111 1 11111111
_shrk 03369 001000 STHLL (ER2-ER3),B-5P 0Ll0 RD ROM PROG 1 1111 1 11111111
Sawple::sortilong *) -01667 002068 STM.L (ERZ-ER3) ,@-5P 0110 ED ROM PROG 1 1111 1 11111111
Sawple: :change (long %) -00469 002046 MOV.L ER3,B-ER7 0lo0 RD ROM PROG 1 1111 1 11111111
| |

Figure6.59 [Trace] Window (Function Calls)

(5) Toreturnthedisplay in the [Trace] window to its previous state, follow the procedurein (3) to display the
[Function Call Display] dialog box. Click the [Disable] button and then the [OK] button.

(6) Remove the event points that have been set and clear the trace information. Clicking the right-hand mouse
button on the [Breakpoints] window displays a popup menu. Select [Delete All] from this menu to remove
all the event points that have been set. Clicking the right-hand mouse button on the [ Trace] window displays
afurther popup menu. Select [Clear] from this menu to clear the trace information.
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6.17 Stack Trace Function
The emulator uses the information on the stack to display the function call history.

Notes: 1. Thisfunction can be used only when the load module that has the Dwarf2-type debugging
information isloaded. Such load module is supported in H8S, H8/300 C/C++ compiler V4.0 or later.

2. For details on the stack trace function, refer to the online help.

* Double-click the [Editor] columninthesort function and set a PC breakpoint.

0=00002068 wold Sample: isortlong *a)
O=00002070 i
long t;
int 1., j. k. gap:
Oxz00002072 gap = 5:
0=x00002076 while{ gap > 0 )4
0=00002078 for{ k=0: k<gap: k++){
0x000020%7c for{ i=k+gap; 1<10; i=i+gap }{
0z00002080 for{j=i—gap; j:=k. j=j-gap){
0=z00002084 » if{aljlrali+gapli{

t = aldil:
0x000020a4 ali] = alj+gapl:
0x000020a8 alj+gap] = t;

h

else

brealk
1
h
H

0=z000020=0 Jqap = gaps2:
0=z000020cc T

Figure 6.60 [Source] Window (PC Breakpoint Setting)

* Select [Reset Go] from the [Debug] menu.

» After the break in program execution, select [Stack Trace] from the [Code] submenu of the [View] menu to
open the [Stack Trace] window.

=10l x|
Kind |Name |Value |
F Sanple: sort(long *) { 0=00002084 %
F tutorial() { 0=x0000107a 7}
F maini) { 0=00001036
F PowverON_Re=et () { 0=0000041e

Figure6.61 [Stack Trace] Window

Figure 6.61 shows that the position of the program counter is currently at the selected line of thesor t ()
function, and that thesor t () functioniscaled fromthet ut ori al () function.

To remove the PC breakpoint, double-click the [Editor] columninthesort function again.
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6.18 Monitor Function

The emulator allows monitoring of the content of specified addresses in memory during execution of the user

program. In this example, we monitor the content of the address range where variable a of thet ut ori al

function is stored.

(1) Select the [CPU] submenu from the [View] menu. Then selecting [Monitor Setting...] from the [Monitor]
submenu displays the [Monitor Setting] dialog box.

21|
Manitor Setting I
Mame: |rnonitor1
— Dptiohz
Address: |H'DDDDDDDD
Size [byte): |Hzn =]
Access [Eormat): I BYTE [ASLCI) ﬂ

[V Auto-Refresh at rate [ms] : ID'DDEDD

[V Reading the Initial alue

r— Colar
Change Indicatar: I Change j
Foreground: [N |~ Backgound: [ ] IvI
[ gy
— Detail
lDETAIL MWOT SUPPORTED! Detail |
— Histary

Ok I Cancel |

Figure6.62 [Monitor Setting] Dialog Box
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(2) Set theitemsin the [Monitor Setting] dialog box as follows:
e Enter monitorl in the [Name] edit box.
e Setthe parametersin the [Options] group box as follows:
(@) Usethe[Locas] window to refer to the address on the line where variable a, which is defined within

thet ut ori al function, isdlocated and enter this address in the [Address] edit box. In this example,
enter H OOFFEF80.

(b) Enter H 50 inthe[Size] edit box.
(c) Select BYTE (HEX) from the [Access| combo box.
(d) Check the [Auto-refresh at rate] check box and enter D' 00500.
(e) Check the [Reading the Initial Vaue] check box.
e Setthe parametersin the [Color] group box as follows:
(a) Select Change from the [Change Indicator] combo box.
(b) Select red and white in the [Foreground] and [Background] combo boxes, respectively.
(c) Check the [Mayfly] check box.

Note: Depending on the operating system in use, the foreground and background colors may not be selectable.

Monitor Setking 2x|
M anitar Setting |
Mame: Imonitnr'l
— Optionz
Address: |H'DDFFEF8IZI
Size (byte]: [H'50 =]
Aecess [Fomat]: IBYTE HEX] j

¥ Auto-Refresh at rate [ms) : ID'DDEDD

[¥ Reading the Initial Yalue

— Colar
Change Indicator: IEhange ﬂ
Foreground: _Ivl B ackground: |:||v|
v Maptly
— Detail
lDETﬁIL MOT SUPPORTED! [Deta |
— Histary

| |
ak I Cancel |

Figure6.63 [Monitor Setting] Dialog Box (Setting Completed)

382
RENESAS




(3) Click the [OK] button to open the [Monitor] window.

onibor: monitorl - H'OOFFEFS0 i m
iddress | +0| +1] +2 | +3| +4| +5] 46| +7| 48| +3] 42| +B| +c| tp] 4| 7]
OxQJOFFEFS0 0o Qo 792 4B 00 OO0 5% EZ 00 00 44 gB 00 00 41 C&
OxQJOFFEF20 00 Qo 3F &4 00 OO0 27 81 0o Qo 1 FB 00 00 1é TE
Ox0JOFFEFAO 0o Qo 15 FB OO0 OO0 OF F&e 00 0z 1l E& 00 00 OO0 40
Ox0JOFFEFEOD B9 70 0Qo 00 0o 0Ol £80 78 00 Q0o 1o 36 00 00 04 1E
OxOJOFFEFCO g4 19 &A 18 SA 18 ©6A 1% €A 18 g4 18 &A 18 &A 12

Figure6.64 [Monitor] Window

(4) Select [Reset Go] from the [Debug] menu. When the content of the address range changes with execution,
the updated values are red (i.e. the color that was selected in the [Foreground] and [Background] combo
boxes). Values will be displayed in black if they have not been updated or a certain period of time has
elapsed since the last update.

tor: monitorl - HOOFFEFSD =[Ol x|
Address | +0| +1] +2| +3| +a| +5| 46| +7| +8| +2] +a| +B| +c| 4D | +E| +F]
OxOOFFEFS0 00 00 0z SE OO0 00 1® 05 00 00 2D &3 00 00 36 73
OxOOFFEFS0 00 00 3 E 00 00 3B D3 00 00 41 FC 00 00 EE B3
DxOOFFEFAD 00 00 &4 0z OO0 00 €F 4 00 02z 12 24 00 00 AL AR
OxOOFFEFED 57 70 00 00 00 0Ol S0 T4 00 00 10 36 00 00 04 1E
DxOOFFEFCO A 1% 6A 1% 6k 13 ek 13 €A 13 eA 13 64 13 64 18

Figure6.65 [Monitor] Window (during Execution)

(5) After you have finished checking the statesin the [Monitor] window, select [Halt Program] from the [Debug]
menu to halt the program’s execution.

6.19 What Next?
Thistutorial has described the mgjor features of the emulator and the use of the HEW.

Sophisticated debugging can be carried out by using the emulation functions that the emulator offers. This
provides for effective investigation of hardware and software problems by accurately isolating and identifying
the conditions under which such problems arise.
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Section 7 Hardware Specifications Specific to This Product

This section describes the hardware specifications on the H8/300 and 300L E6000 emulator.

7.1 H8/300 and 300L E6000 Emulator Specifications

The H8/300 and 300L E6000 emulator supports the system development using the following microcomputers:

* H8/330 group

» HB8/350 group

» H8/338 and H8/329 groups

* HB8/3334 group

e HB8/3257 and H8/325 groups

» H8/3437, H8/3337Y, H8/3297, H8/3522, and H8/3534 groups
» H8/3217, H8/3318, and H8/3502 groups
* HB8/3834 and H8/3814 groups

e HB8/3637 and H8/3877 groups

* HB8/3927 group

e HB8/3857 group

* HB8/3854 group

* H8/3657 and H8/3644 groups

711 Supported Items

Table 7.1 lists device groups supported by different combinations of the E6000 emulator, evaluation chip, and
expansion /O board.

Table7.1 Hardware Combinations

E6000 Emulator Evaluation Chip Expansion I/O Board Supported Device Group

HS3008EPI60H HS3308EVI60H H8/330 group
HS3508EVI60H H8/350 group
HS3398EVI60H H8/338 and H8/329 groups
HS3334EVI60H H8/3334 group
HS3257EVI60H H8/3257 and H8/325 groups
HS3437EVI60H H8/3437, H8/3337Y, H8/3297,
H8/3522, and H8/3534 groups
HS3318EVI60H H8/3217, H8/3318, and H8/3502
groups
HS3LO8EPI6OH HS3834EVI60H H8/3834 and H8/3814 groups
HS3834EVI60H HS3857EI060H H8/3857 group
HS3834EVI60H HS3854EI060H H8/3854 group
HS3876EVI60H H8/3637 and H8/3877 groups
HS3927EVI60H H8/3927 group

HS3644EPI60H

H8/3657 and H8/3644 groups

For notes on the user system interface cables and the expansion 1/O board, refer to the user’s manual provided

for each of them.

See the development support tool catalog for the MCU type names and packages supported by the E6G000
emulator and for the combination of the E6000 user system interface cables and optiona boards.

RENESAS



712 Operating Voltage and Frequency Specifications

Table 7.2 shows the MCU operating voltage and frequency specifications supported by the EG000 emulator. If
the emulator is used in an environment that exceeds the operating voltage range and operating frequency range
guaranteed for the MCU operation, normal emulator operation is not guaranteed. Note that the operation with
low voltage or high frequency is not supported in some MCUs.

Table7.2 Operating Voltage and Frequency Specifications

No. MCU Type Operating Voltage (V)  Operating Frequency () (MHz)
H8/330 group 4.5-5.5 0.5-10.0
H8/350 group 4.5-5.5 4.0-10.0
H8/338 group 2.7-5.5 0.5-5.0

4.5-5.5 0.5-10.0

4 H8/329 group 2.7-5.5 0.5-5.0

4.5-5.5 0.5-10.0

5 H8/3332 group 2.7-5.5 0.5-5.0
H8/3334 group 4555 0.5-10.0

6 H8/3257 group 2.7-5.5 2.0-5.0

4.5-5.5 2.0-10.0
H8/325 group 45-55 0.5-10.0
H8/3437 group 2.7-5.5 2.0-10.0
4.0-5.5 2.0-12.0
4.5-5.5 2.0-16.0
9 H8/3337Y group 2.7-5.5 2.0-10.0
4.0-5.5 2.0-12.0
4.5-5.5 2.0-16.0

10 H8/3534 group 4.5-55 2.0-10.0

11 H8/3522 group 4.5-55 2.0-10.0

12 H8/3297 group 2.7-5.5 2.0-10.0

4.0-5.5 2.0-12.0
4.5-5.5 2.0-16.0

13 H8/3217 group 2.7-5.5 2.0-10.0

4.0-5.5 2.0-12.0
4.5-5.5 2.0-16.0

14 H8/3218 group 2.7-5.5 2.0-10.0

4.0-5.5 2.0-12.0
4.5-5.5 2.0-16.0

15 H8/3502 group 4.5-55 4.0-10.0

16 H8/3834 group 4.5-55 0.5-5.0

17 H8/3814 group 2.7-5.5 0.5-2.5

4.0-5.5 0.5-5.0
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Table7.2 Operating Voltage and Frequency Specifications (cont)

No. MCU Type Operating Voltage (V)  Operating Frequency () (MHz)
18 H8/3857 group 3.0-4.0 0.5-2.5
4.0-5.5 0.5-5.0
19 H8/3854 group 3.0-4.0 0.5-2.5
4.0-5.5 0.5-5.0
20 H8/3637 group 2.7-3.0 0.5-2.5
3.0-4.5 0.5-4.0
4.5-5.5 0.5-5.0
21 H8/3877 group 2.7-4.0 0.5-2.5
4.0-5.5 0.5-5.0
22 H8/3927 group 2.7-4.0 0.5-2.5
4.0-5.5 0.5-5.0
23 H8/3657 group 2.7-4.0 0.5-2.5
4.5-5.5 0.5-5.0
24 H8/3644 group 2.7-4.0 0.5-5.0
4.5-5.5 0.5-8.0

NOTE

For details on the operating voltage and frequency specifications,
refer to the MCU hardware manual.
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7.2 Ingtalling the Evaluation Chip
Follow the procedure listed below to install the evaluation chip on the E6000 emulator.

(1) Turn off the emulator’ s power switch and remove the AC adapter from AC outlet.

(2) Remove the four screws at the side of the emulator and lift up the cover.

(3) Lift up the IC socket lever and insert the evaluation chip. Be sure to align pin 1 location of the evaluation
chip, asshown in figure 7.1.

Align pin 1
(pointed corner) of the
evaluation chip with

pin 1 mark () on the >
emulator
-
1 1
I i)
Lift up the lever Lift up the lever
(open) (‘ (open)
[ / L 7
Push down the Push down the a
lever (close) lever (close)
H8/300 (HS3008EPI60H) H8/300L (HS3LO8EPI6OH)

Figure7.1 Evaluation Chip Installation
(4) Push down the IC socket lever.
(5) Turn the four screws at the side of the emulator and fix the cover.
7.3 User System Interface

All user system interface signals are directly connected to the MCU in the emulator with no buffering.

731 Signal Protection

All user system interface signals are protected from over- or under-voltage by use of diode arrays except for the
AVcc and analog port signals.

Pull-up resistors are connected to the port signals except for the analog port signals.

The emulator monitors the signals at the head of the user system interface cable to detect whether the user
systemis connected or not.
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732 User System Interface Circuits of the H8/300 Group Evaluation Chip (HS3308EV160H)

All user system interface signals are directly connected to the evaluation chip in the emulator with no buffering
except for those listed below which are connected to the evaluation chip through control circuits:

+ RES
* NMI
« MDO
+ MD1
*+ EXTAL

The circuits that interface the evaluation chip in the emulator to the user system include pull-up resistors that
cause signal delays. Note that when an input terminal isin the high-impedance state, the pull-up resistor forces
the terminal to be at a high level. Adjust the user system hardware to compensate for these effects. The delay
caused by the user system interface cable is about 3 ns.

The following diagrams show the user system interface signal circuits.

Default:

Vce

Evaluation 470 KQ
chip User system
47 Q interface cable

Figure7.2 Default User System Interface Circuit

RES, NMI, and MDO: These signals areinput to the evaluation chip viaHD151015. Therefore, the
rising/falling time must be within 8 nsor less.

User system
47 Q interface cable

HD151015

Figure7.3 User System Interface Circuit for RES, NMI, and MDO

MD1: Includesa12-V detection circuit for supporting microcomputers including flash memory.

12-V
detection User system
circuit interface cable

MD1
monitor

register
27 kQ

Figure7.4 User System Interface Circuit for MD1
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EXTAL: Clock oscillator circuit is on the user system interface cable.

Vce

User system

47 Q interface cable

HD151015

Figure7.5 User System Interface Circuit for EXTAL

STBY: Hardware standby cannot be used.

10 kQ
Evaluation
chip

Figure7.6 User System Interface Circuit for STBY

ANO/P70to AN7/P7T:

Evaluation l AAM——0 Usersystem
chip 470 interface cable

Figure7.7 User System Interface Circuit for ANO/P70to AN7/P77

AVccand AVss:
Evaluation chip
AVce * . ¢ 0
0.1 uF _L 27 KO _User system
interface cable
AVss
Figure7.8 User System Interface Circuit for AVcc and Avss
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733 User System Interface Circuits of the H8/350 Group Evaluation Chip (HS3508EV160H)

All user system interface signals are directly connected to the evaluation chip in the emulator with no buffering

except for those listed below which are connected to the evaluation chip through control circuits:

+ RES
* NMI
« MDO
+ MD1
*+ EXTAL

The circuits that interface the evaluation chip in the emulator to the user system include pull-up resistors that

cause signal delays. Note that when an input terminal isin the high-impedance state, the pull-up resistor forces
the terminal to be at a high level. Adjust the user system hardware to compensate for these effects. The delay
caused by the user system interface cable is about 3 ns.

The following diagrams show the user system interface signal circuits.

Default:

Evaluation
chip

Vce

470 kQ
User system
47 Q interface cable

Figure7.9 Default User System Interface Circuit

RES, NMI, and MDO: These signals areinput to the evaluation chip via HD151015. Therefore, the

rising/falling time must be within 8 nsor less.

HD151015

Vcce

User system
47 Q interface cable

Figure7.10 User System Interface Circuit for RES, NMI, and MDO

MD1: Includesa12-V detection circuit for supporting microcomputers including flash memory.

12-V
detection
circuit

MD1
monitor
register

User system
interface cable

27 kQ

Figure7.11 User System Interface Circuit for MD1
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EXTAL: Clock oscillator circuit is on the user system interface cable.

Vce

User system

47 Q interface cable

HD151015

Figure7.12 User System Interface Circuit for EXTAL

STBY: Hardware standby cannot be used.

10 kQ
Evaluation
chip

Figure7.13 User System Interface Circuit for STBY

ANO/P70to AN7/P7T:

Evaluation l AAM——0 Usersystem
chip 470 interface cable

Figure7.14 User System Interface Circuit for ANO/P70 to AN7/P77

AVccand AVss:
Evaluation chip
AVce * . ¢ 0
0.1 uF _L 27 KO _User system
interface cable
AVss
Figure7.15 User System Interface Circuit for AVccand AVss
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734 User System Interface Cir cuits of the H8/338, H8/329 Group Evaluation Chip (HS3398EVI60H)

All user system interface signals are directly connected to the evaluation chip in the emulator with no buffering
except for those listed below which are connected to the evaluation chip through control circuits:

+ RES
* NMI
« MDO
+ MD1
+ EXTAL

The circuits that interface the evaluation chip in the emulator to the user system include pull-up resistors that
cause signal delays. Note that when an input terminal isin the high-impedance state, the pull-up resistor forces
the terminal to be at ahigh level. Adjust the user system hardware to compensate for these effects. The delay
caused by the user system interface cable is about 3 ns.

The following diagrams show the user system interface signal circuits.

Default:

Vce

Evaluation 470 kQ
chip User system
47 Q interface cable

Figure7.16 Default User System Interface Circuit

RES, NMI, and MDO: These signals areinput to the evaluation chip via HD151015. Therefore, the
rising/falling time must be within 8 nsor less.

Vcce

User system

47 Q interface cable
HD151015

Figure7.17 User System Interface Circuit for RES, NMI, and MDO
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MD1: Includesa12-V detection circuit for supporting microcomputers including flash memory.

12-V
detection User system
circuit interface cable

MD1
monitor

register
27 kQ

Figure7.18 User System Interface Circuit for MD1

EXTAL: Clock oscillator circuit ison the user system interface cable.

Vcce

User system

47 Q interface cable
HD151015

Figure7.19 User System Interface Circuit for EXTAL

STBY: Hardware standby cannot be used.

10 kQ
Evaluation
chip

Figure7.20 User System Interface Circuit for STBY

ANO/P70to AN7/P77:

Evaluation l AAM——0 Usersystem
chip 470 interface cable

Figure7.21 User System Interface Circuit for ANO/P70to AN7/P77
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AVccand AVss:

Evaluation chip

AVce 0

0.1 pF Af 27 kg Usersystem

interface cable
AVss

Figure7.22 User System Interface Circuit for AVccand AVss

7.35 User System I nterface Cir cuits of the H8/3334 Group Evaluation Chip (HS3334EVI160H)

All user system interface signals are directly connected to the evaluation chip in the emulator with no buffering
except for those listed below which are connected to the evaluation chip through control circuits:

+ RES
« NMI
+ MDO
+ MD1
+ EXTAL

The circuits that interface the evaluation chip in the emulator to the user system include pull-up resistors that
cause signal delays. Note that when an input terminal isin the high-impedance state, the pull-up resistor forces
the terminal to be at ahigh level. Adjust the user system hardware to compensate for these effects. The delay
caused by the user system interface cable is about 3 ns.

The following diagrams show the user system interface signal circuits.

Default:

Vcce

Evaluation 470 kO
chip User system
47 Q interface cable

Figure7.23 Default User System Interface Cir cuit

RES, NMI, and MDO: These signals areinput to the evaluation chip via HD151015. Therefore, the
rising/falling time must be within 8 ns or less.

Vcce

User system
47 Q interface cable

HD151015

Figure7.24 User System Interface Circuit for RES, NMI, and MDO
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MD1: Includesa12-V detection circuit for supporting microcomputers including flash memory.

12-V
detection User system
circuit interface cable

MD1
monitor

register
27 kQ

Figure7.25 User System Interface Circuit for MD1

EXTAL: Clock oscillator circuit ison the user system interface cable.

Vcce

User system

47 Q interface cable
HD151015

Figure7.26 User System Interface Circuit for EXTAL

STBY: Hardware standby cannot be used.

10 kQ
Evaluation
chip

Figure7.27 User System Interface Circuit for STBY

ANO/P70to AN7/P77:

Evaluation l AAM——0 Usersystem
chip 470 interface cable

Figure7.28 User System Interface Circuit for ANO/P70to AN7/P77
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AVccand AVss:

Evaluation chip

AVce 0

0.1 pF Af 27 kg Usersystem

interface cable
AVss

Figure7.29 User System Interface Circuit for AVccand AVss

7.3.6  User System Interface Circuits of the H8/3257, H8/325 Group Evaluation Chip (HS3257EVI60H)

All user system interface signals are directly connected to the evaluation chip in the emulator with no buffering
except for those listed below which are connected to the evaluation chip through control circuits:

+ RES
« NMI
+ MDO
+ MD1
+ EXTAL

The circuits that interface the evaluation chip in the emulator to the user system include pull-up resistors that
cause signal delays. Note that when an input terminal isin the high-impedance state, the pull-up resistor forces
the terminal to be at ahigh level. Adjust the user system hardware to compensate for these effects. The delay
caused by the user system interface cable is about 3 ns.

The following diagrams show the user system interface signal circuits.

Default:

Vcce

Evaluation 470 kO
chip User system
47 Q interface cable

Figure7.30 Default User System Interface Circuit

RES, NMI, and MDO: These signals areinput to the evaluation chip via HD151015. Therefore, the
rising/falling time must be within 8 ns or less.

Vcce

User system
47 Q interface cable

HD151015

Figure7.31 User System Interface Circuit for RES, NMI, and MDO

397
RENESAS




MD1: Includesa12-V detection circuit for supporting microcomputers including flash memory.

12-V
detection User system
circuit interface cable

MD1
monitor

register
27 kQ

Figure7.32 User System Interface Circuit for MD1

EXTAL: Clock oscillator circuit ison the user system interface cable.

Vcce

User system

47 Q interface cable
HD151015

Figure7.33 User System Interface Circuit for EXTAL

STBY: Hardware standby cannot be used.

10 kQ
Evaluation
chip

Figure7.34 User System Interface Circuit for STBY

P70to P77:
Evaluation l AAM——0 Usersystem
chip 470 interface cable
Figure7.35 User System Interface Circuit for P70 to P77
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AVccand AVss:

Evaluation chip

AVce 0

0.1 pF Af 27 kg Usersystem

interface cable
AVss

Figure7.36 User System Interface Circuit for AVccand AVss

7.3.7 User System I nterface Circuits of the H8/3437, H8/3337Y, H8/3297 Group Evaluation Chip
(HS3437EVI60H)

All user system interface signals are directly connected to the evaluation chip in the emul ator with no buffering
except for those listed below which are connected to the evaluation chip through control circuits:

+ RES

* NMI

+ MDO

« MD1

* FVpp

* EXTAL

The circuits that interface the evaluation chip in the emulator to the user system include pull-up resistors that
cause signal delays. Note that when an input terminal isin the high-impedance state, the pull-up resistor forces

the terminal to be at ahigh level. Adjust the user system hardware to compensate for these effects. The delay
caused by the user system interface cable is about 3 ns.

The following diagrams show the user system interface signal circuits.

Default:

Vcce

Evaluation 470 kQ

chip User system
47 Q interface cable

Figure7.37 Default User System Interface Cir cuit

RES, NMI, and MDO: These signals areinput to the evaluation chip via HD151015. Therefore, the
rising/falling time must be within 8 nsor less.

Vcce

User system
47 Q interface cable

HD151015

Figure7.38 User System Interface Circuit for RES, NMI, and MDO
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MD1and FVpp: Includesa12-V detection circuit for supporting microcomputers including flash memory.

12-V
detection User system
circuit interface cable

MD1 and FVpp
monitor register

Figure7.39 User System Interface Circuit for MD1 and FVpp

EXTAL: Clock oscillator circuit is on the user system interface cable.

Vcce

User system

47 Q interface cable
HD151015

Figure7.40 User System Interface Circuit for EXTAL

STBY: Hardware standby cannot be used.

10 kQ
Evaluation
chip

Figure7.41 User System Interface Circuit for STBY

P70/ANO to P77/ANT:

Evaluation l AAM——0 Usersystem
chip 470 interface cable

Figure7.42 User System Interface Circuit for P70/ANO to P77/AN7
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AVccand AVss:

Evaluation chip

AVce 0

0.1 pF Af 27 kg Usersystem

interface cable
AVss

Figure7.43 User System Interface Circuit for AVccand AVss

7.3.8 User System Interface Circuits of the H8/3217, H8/3318 Group Evaluation Chip
(HS3318EVI60H)

All user system interface signals are directly connected to the evaluation chip in the emul ator with no buffering
except for those listed below:

+ RES
« NMI
+ MDO
+ MD1
+ EXTAL

The circuits that interface the evaluation chip in the emulator to the user system include pull-up resistors that
cause signal delays. Note that when an input terminal isin the high-impedance state, the pull-up resistor forces
the terminal to be at ahigh level. Adjust the user system hardware to compensate for these effects. The delay
caused by the user system interface cable is about 3 ns.

The following diagrams show the user system interface signal circuits.

Default:

Vcce

Evaluation 470 kQ

chip User system
47 Q interface cable

Figure7.44 Default User System Interface Circuit

RES, NMI, and MDO: These signals areinput to the evaluation chip via HD151015. Therefore, the
rising/falling time must be within 8 ns or less.

Vcce

User system
47 Q interface cable

HD151015

Figure7.45 User System Interface Circuit for RES, NM| and MDO
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MD1: Includesa12-V detection circuit for supporting microcomputers including flash memory.

12-V
detection User system
circuit interface cable

MD1
monitor

register
27 kQ

Figure7.46 User System Interface Circuit for MD1

EXTAL: Clock oscillator circuit ison the user system interface cable.

Vcce

User system

47 Q interface cable
HD151015

Figure7.47 User System Interface Circuit for EXTAL

STBY: Hardware standby cannot be used.

10 kQ
Evaluation
chip

Figure7.48 User System Interface Circuit for STBY

P70/ANO to P77/AN7 (H8/3318 group only):

Evaluation l AAM——0 Usersystem
chip 470 interface cable

Figure7.49 User System Interface Circuit for P70/ANO to P77/AN7
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AVccand AVss:

Evaluation chip

AVce 0

0.1 pF Af 27 kg Usersystem

interface cable
AVss

Figure7.50 User System Interface Circuit for AVccand AVss

7.3.9 User System I nterface Cir cuits of the H8/3834, H8/3814 Group Evaluation Chip
(HS3834EVI60H)

All user system interface signals are directly connected to the evaluation chip in the emul ator with no buffering
except for those listed below:

+ RES
+ MDO
+ 0OsC1
« X1
« TEST

The circuits that interface the evaluation chip in the emulator to the user system include pull-up resistors that
cause signal delays. Note that when an input terminal isin the high-impedance state, the pull-up resistor forces
the terminal to be at ahigh level. Adjust the user system hardware to compensate for these effects. The delay
caused by the user system interface cable is about 3 ns.

The following diagrams show the user system interface signal circuits.

Default:

Vcce

Evaluation 470 kQ

chip User system
47 Q interface cable

Figure7.51 Default User System Interface Circuit

Note:  470-kQ pull-up resistors are connected to the COM 1 to COM4 and SE1 to SEG40 signals. When
evaluating these signals, remove the corresponding pull-up resistor network (MRGCO09X 470kj
manufactured by Tama Electric Co., Ltd.) listed in table 7.3 from the socket. Only the corresponding
resistors must be removed. Do not remove any other resistors. When installing the removed resistor
again into the socket, be sure to align pin 1 locations of the resistor and the socket.

Pin 1 on the

resistor network ~

Pin 1 indication

on the board \>I |

Figure7.52 Default User System Interface Cir cuit
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Table7.3 Resistor Network Numbers

470-kQ Resistor Network Number

(Number Printed on the Upper Board) Signal Name
N18 COM1 to COM4
N21 SEG1 to SEG8
N23 SEG9 to SEG16
N15 SEG17 to SEG24
N14 SEG25 to SEG32
N17 SEG33 to SEG40

RES, NMI, and MDO: These signals areinput to the evaluation chip via HD151015. Therefore, the
rising/falling time must be within 8 ns or less.

Vcce

User system
47 Q interface cable

HD151015

Figure7.53 User System Interface Circuit for RES, NM| and MDO

OSC1and X1: Thesesigndsareinput to the evauation chip viaHD151015. Therefore, the rising/falling time
must be within 8 nsor less.

—l— Vce
4.7 kQ
User system
47 Q interface cable

HD151015

Figure7.54 User System Interface Circuit for OSC1 and X1

P70/ANO to P77/ANT:

Evaluation AAA o User system
chip 470 interface cable

Figure7.55 User System Interface Circuit for P70/ANO to P77/AN7

AVccand AVss:
Evaluation chip
AVce * . ¢ 0
0.1 uF _L 27 KO _User system
interface cable
AVss
Figure7.56 User System Interface Circuit for AVccand AVss
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P20 to P27:

Evaluation
chip

° AN o User system

interface cable
%,100 ko  47Q

Figure7.57 User System Interface Circuit for P20 to P27

V1,V2 and V3:

Evaluation
chip

% Vce
AN o User system
é 470 interface cable

Figure7.58 User System Interface Circuit for V1, V2, and V3

7.3.10 User System Interface Circuits of the H8/3637, H8/3877 Group Evaluation Chip

(HS3876EVI60H)

All user system interface signals are directly connected to the evaluation chip in the emulator with no buffering

except for those listed below which are connected to the evaluation chip through control circuits:

+ RES

* NMI (H8/3877 group only)
* 0OSC1

« X1

e TEST

The circuits that interface the evaluation chip in the emulator to the user system include pull-up resistors that

cause signal delays. Note that when an input terminal isin the high-impedance state, the pull-up resistor forces
the terminal to be at ahigh level. Adjust the user system hardware to compensate for these effects. The delay
caused by the user system interface cable is about 3 ns.

The following diagrams show the user system interface signal circuits.

Default:

Evaluation
chip

Vce

470 kQ
User system
47 Q interface cable

Figure7.59 Default User System Interface Cir cuit
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RES, TEST, NMI (NMI isonly for the H8/3877 group): These signals are input to the evaluation chip via
HD151015. Therefore, the rising/falling time must be within 8 nsor less.

Vcce

User system

47 Q interface cable
HD151015

Figure7.60 User System Interface Circuit for RES, TEST, NMI

OSC1 and X1: These signals are input to the evaluation chip viaHD151015. Therefore, the rising/falling time
must be within 8 nsor less.

Vce
4.7 kQ
User system
47 Q interface cable

HD151015

Figure7.61 User System Interface Circuit for OSC1 and X1

PBO/ANO to PB7/AN7 (PB4/AN4 to PB7/ANY areonly for the H8/3877 group):

Evaluation l AAM——0 Usersystem
chip 470 interface cable

Figure7.62 User System Interface Circuit for PBO/ANO to PB7/AN7

AVcc, AVss, AVref and Vtref (AVref isonly for the H8/3877 group):

Evaluation chip

AVce * . ¢ 0

0.1 pF AS 27kq User system

interface cable
AVss

Figure7.63 User System Interface Circuit for AVcc, AVss, AVref and VTref

P20 to P27:
Evaluation ° AMV o User system
chi interface cable
: %,100 ko A7Q
Figure7.64 User System Interface Circuit for P20 to P27
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V1, V2, and V3 (H8/3877 group only):

% Vce
Evaluation ANV o User system

chip é 470 interface cable

Figure7.65 User System Interface Circuit for V1, V2, and V3

TONED and TONEM (TONEM isonly for the H8/3877 group):

VTref
Evaluation % o User system

chip interface cable

Figure7.66 User System Interface Circuit for TONED and TONEM

7.3.11 User System Interface Circuits of the H8/3927 Group Evaluation Chip (HS3927EVI160H)

All user system interface signals are directly connected to the evaluation chip in the emulator with no buffering
except for those listed below which are connected to the evaluation chip through control circuits:

+ RES
« NMI
. 0sC1
. X1
« TEST

The circuits that interface the evaluation chip in the emulator to the user system include pull-up resistors that
cause signal delays. Note that when an input terminal isin the high-impedance state, the pull-up resistor forces
the terminal to be at a high level. Adjust the user system hardware to compensate for these effects. The delay
caused by the user system interface cable is about 3 ns.

The following diagrams show the user system interface signal circuits.

Default:

Vcce

Evaluation 470 kQ
chip User system
47 Q interface cable

Figure7.67 Default User System Interface Cir cuit
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RES, TEST, and NMI: These signals are input to the evaluation chip viaHD151015. Therefore, the
rising/falling time must be within 8 nsor less.

Vcce

User system
47 Q interface cable

HD151015

Figure7.68 User System Interface Circuit for RES, TEST, and NMI

OSC1 and X1: These signals are input to the evaluation chip viaHD151015. Therefore, the rising/falling time
must be within 8 nsor less.

Vce
4.7 kQ
User system
47 Q interface cable

HD151015

Figure7.69 User System Interface Circuit for OSC1 and X1

PBO/ANO to PB7/AN7 and PCO/DAO to PC3/DA3:

Evaluation l AAM——0 Usersystem
chip 470 interface cable

Figure7.70 User System Interface Circuit for PBO/ANO to PB7/AN7 and PCO/DAO to PC3/DA3

AVccand AVss:
Evaluation chip
AVce * * 0
0.1 uF _L 27 kQ _User system
interface cable
AVss
Figure7.71 User System Interface Circuit for AVccand AVss
P40 to PAT:
Evaluation ° AMV o User system
chip interface cable
%,100 ko A7Q
Figure7.72 User System Interface Circuit for P40 to P47
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7.3.12 User System Interface Circuits of the H8/3644, H8/3657 Group E6000 Emulator
(HS3644EPI60H)

All signalsaredirectly connected to the evaluation chip in the emulator with no buffering except for those listed

below:

« RESET
« 0SC1

« X1

» TEST

The circuits that interface the evaluation chip in the emulator to the user system include pull-up resistors that
cause signal delays. Note that when an input terminal isin the high-impedance state, the pull-up resistor forces
the terminal to be at ahigh level. Adjust the user system hardware to compensate for these effects. The delay
caused by the user system interface cable is about 8 ns.

The following diagrams show the user interface signal circuits.

Default:

Vcce

Evaluation 470 kO
chip User system
47 Q) interface cable

Figure7.73 Default User System Interface Cir cuit

RESET and TEST: These signals are input to the evaluation chip viaHD151015. Therefore, the rising/falling
must be performed within 8 nsor less.

Vcce

User system
47 Q interface cable

HD151015

OSC1land X1:

Figure7.74 User Interface Circuit for RESET and TEST

Vce
4.7 kQ
User system
47 Q interface cable

HD151015

Figure7.75 User Interface Circuit for OSC1 and X1
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PBO/ANO to PB7/AN7:

Evaluation - AAM——0 User system
chip 470 interface cable

Figure7.76 User Interface Circuit for PBO/ANO to PB7/AN7

AVccand AVss:

Evaluation chip

AVce *+ *+ 0
1 User system

. 27kQ
0.1uF interface cable
AVss

Figure7.77 User Interface Circuit for AVcc and AVss

Vpp/P90 and TEST (Terminalstowhich 12-V Voltageis Applied at Flash Memory Write): Flash memory
is not supported by this emulator. Therefore, when debugging the H8/3644 or H8/3657 group microcomputer
with flash memory, do not apply 12-V voltage to the Vpp/P90 or TEST terminal. Otherwise, the emulator detects
test mode. The user system interface cable provides the protection circuits against 12-V input to the Vpp/P90 or
TEST terminal. For details, refer to each manual for the user system interface cables.

P60 to P67 (CMOS Large Current Ports): The P60 to P67 CMOS large current port function for the H8/3644
group is supported by the user system interface cable. For details, refer to H8/3644 Group User System Interface
Cable User’'sManual.

74 Differ ences between M CU and Emulator

When the emulator is turned on or initialized, or the system is reset, there are some differencesin the initial
valuesin some of the general registers between the MCU and the emulator as shown in table 7.4.

Table7.4 Initial Value Differences between MCU and Emulator

Status Register E6000 Emulator MCU
Power-on/ PC Undefined Reset vector value
initialized RO to R6 H'00 Undefined
R7 (SP) H'10 Undefined
CCR The | mask is set to 1 and the The | mask is set to 1 and the
other bits are undefined other bits are undefined
Reset command PC Reset vector value Reset vector value
RO to R6 Undefined Undefined
R7 (SP) H'10 Undefined
CCR The | mask is set to 1 and the The | mask is set to 1 and the
other bits are undefined other bits are undefined

741 A/D Converter
Due to the use of auser system interface cable there is a dlight degradation in the A/D resolution and above that

quoted in the hardware manual for the MCU being emulated.
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Section 8 Software Specifications Specific to This Product

This section describes the software specifications of the H8/300 and 300L E6000 emulator.

8.1 Softwar e Specifications of the H8/300 and 300L E6000 Emulator

Information specific to this emulator is given below.

811 Target Hardware

This emulator software conforms to the H8/300 and 300L E6000 emulator (HS3008EPI60H, HS3L08EPI60H, or
HS3664EPI60H).

812 Selectable Platforms
The debugging platforms selectable in this emulator are listed below.

Table8.1 Selectable Target Platforms

Debugging Platform Remark
H8/300 E6000 Emulator CPU 300 For emulation of the following MCUs that have the H8/300 CPU
as the core.

HS3308EVI60H: H8/330
HS3508EVI60H: H8/350

HS3398EVI60H: H8/338, H8/337, H8/336, H8/329, H8/328,
H8/327, and H8/326

HS3334EVI60H: H8/3334 and H8/3332

HS3257EVI60H: H8/3257, H8/3256, H8/325, H8/324, H8/323,
and H8/322

HS3437EVI60H: H8/3534, H8/3522, H8/3437, H8/3437F,
HB8/3436, H8/3434, H8/3434F, H8/3397, H8/3396, H8/3394,
H8/3337Y, H8/3337YF, H8/3336Y, H8/3334Y, H8/3334YF,
H8/3297, H8/3296, H8/3294, and H8/3292

HS3318EVI60H: H8/3502, H8/3318, H8/3315, H8/3217,
H8/3216, H8/3214, H8/3212, and H8/3202

H8/300L E6000 Emulator CPU 300L For emulation of the following MCUs that have the H8/300L CPU
as the core.

HS3834EVI60H: H8/3837, H8/3836, H8/3835, H8/3834,
H8/3833, H8/3832, H8/3814, H8/3813, and H8/3812

HS3834EVI60H with HS3857EIO60H: H8/3857, H8/3857F,
H8/3856, and H8/3855

HS3834EVI60H with HS3854EI060H: H8/3854, H8/3854F,
H8/3853, and H8/3852

HS3876EVI60H: H8/3877, H8/3876, H8/3875, H8/3637,
H8/3636, H8/3635, H8/3627, H8/3626, H8/3625, H8/3624,
H8/3623, and H8/3622

HS3927EVI60H: H8/3927, H8/3926, H8/3925, and H8/3924

HS3644EPI60H: H8/3657, H8/3656, H8/3655, H8/3654,
HB8/3653, H8/3652, H8/3644, HB8/3644F, H8/3643, H8/3643F,
H8/3642, H8/3642F, H8/3641, and H8/3640
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8.1.3 [Configuration Properties] Dialog Box ([General] Page)

Items that can be set in this dialog box are listed below.

Configuration Properties ﬂ ll
General |
Davioe: Uzer Sienals
Device: [w User Peset enable
. [w User NMI enable
Clock: {11z ¥ Uzer Standby enable

[ lser Bus Request ensble

SubGlock:  [32.760kHz

Ll L Lol

Timer Resalution: |1 25nz

[# Erable read and write an the fly
[# Break on access errar

[~ Enable internal ROM area write
[¥ Tramsit to active mode at break

User YOG Threshold = 270V 4] [ i

Diriver: |Emu|atc-r PCI Gard Driver
[~ Chanee driver in start up

oK I Cancel

Figure8.1 [Configuration Properties] Dialog Box ([General] Page)
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[General] page

[Device] Selects the MCU to be emulated. See the hardware manual for details.

[Mode] The CPU operating mode, which can be selected from the three modes.
With the H8/300 series, selectable modes depend on the MCU. With the
H8/300L series, only mode 3 is available.

[Clock] Selects the speed of the MCU'’s clock.

[SubClock] Selects the speed of the MCU'’s sub-clock. Selection of the sub-clock is

only available with the H8/300L series.

[Timer Resolution]

Selects the resolution of the timer for use in execution time measurement.
The value 20 ns, 125 ns, 250 ns, 500 ns, 1 us, 2 us, 4 us, 8 us, or 16 us
can be selected.

The timer for execution time measurement has a 40-bit counter.

At 20 ns the maximum time that can be measured is about six hours, and
at 16 ps the maximum time is about 200 days.

When the counter overflows, the maximum time possible for
measurement will be displayed with prompt “>” that indicates that the
counter has overflowed.

[Enable read and write on the fly]

When this box is checked, it is possible to access the target system
memory while the user program is running. Do not check this box if you
require realtime emulation.

Note:

When the content of the memory is modified during the user program
execution (e.g. modification in the [Memory] window or by the
MEMORY_EDIT command), HEW reads the content to update the value.

HEW also reads the memory content when the content has been updated
by operations such as selecting [Memory -> Refresh]. In this case, the
content of memory is read and then updated in each of the windows.

To prevent unnecessary reading of the memory content, close the
window displaying the memory content (such as the [Memory] or
[Disassembly] window) or make the settings so that the content will not
be updated.

The [Monitor] window, or the [Watch] window that satisfies the conditions
listed below displays the memory content. Note that, however, opening
these windows does not prevent realtime operation because the method
of updating the memory content in these windows is different.

Conditions:
1. Registered symbols are only allocated to general-purpose registers.

2. Registered symbols are only allocated to the monitor range set by the
[Monitor] function (the mark R is colored in blue).

3. Registered symbols are comprised of those with the conditions 1 and 2
listed above.
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[General] page (cont)

[Break on access error]

When this box is checked, a break (the user program stops) occurs if
your program accesses an access-prohibited area or writes to a write-
protected area.

[Enable Boot Mode]

When this box is checked, the boot-programming mode of flash memory
will be set. (Execute Go Reset to actually use this mode.) This option is
selectable only when an MCU with flash memory is in use.

[User VCC Threshold]

Sets the voltage level for the user system. [Down] will be displayed in
[User System Voltage] of the [Extended Monitor] window when the actual
user VCC of the target system is lower than the specified value.

[User Signals]

When this box is checked, the reset and NMI signals from the user
system are enabled.

[Driver]

Displays the E6000 driver that is currently installed.

[Change driver in start up]

When this box is checked, selection of a driver will be available next time
the emulator is connected.
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The MCUs selectable by the [Device] option and options that depend on the MCUs are listed below. To emulate
an MCU with a description in the Expansion Hardware column, connect the correct expansion hardware.

Table8.2 Environment for the H8/300 E6000 Emulator CPU 300 Debugging Platform

Evaluation [SubClock] Expansion
Hardware Chip Set [Device] Option [Clock] Option  Option Hardware

HS3008EPIGOH HS3308EVIGOH  H8/330 2.5MHz None None

HS3508EVIGOH  H8/350 AMHz
5MHz

HS3398EVIGOH  H8/338 aMHz
H8/337 10MHz
H8/336 Target
H8/329 Target/2
H8/328
H8/327
H8/326

HS3334EVI6OH  H8/3334
H8/3332

HS3257EVI60OH  H8/3257
H8/3256
H8/325
H8/324
H8/323
H8/322

HS3437EVI60OH  H8/3534
H8/3522

H8/3437 2.5MHz
H8/3437F 4AMHz
H8/3436 5MHz
H8/3434 8MHz
H8/3434F 10MHz
H8/3397 16MHz
H8/3396 Target
H8/3394 Target/2
H8/3337Y

H8/3337YF

H8/3336Y

H8/3334Y

H8/3334YF

H8/3297

H8/3296

H8/3294

H8/3292

Note: Target and Target/2 in [Clock] are only available when the target system is connected.
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Table8.2 Environment for the H8/300 E6G000 Emulator CPU 300 Debugging Platform (cont)
Evaluation [SubClock] Expansion
Hardware Chip Set [Device] Option [Clock] Option  Option Hardware
HS3008EPI6GOH HS3318EVI6OH  H8/3502 2.5MHz None None
4MHz
5MHz
8MHz
10MHz
Target
Target/2
H8/3318 2.5MHz
H8/3315 4MHz
H8/3217 5MHz
H8/3216 8MHz
H8/3214 10MHz
H8/3212 16MHz
H8/3202 Target
Target/2

Note:
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Table8.3 Environment for the H8/300L E6000 Emulator CPU 300L Debugging Platform

Evaluation [SubClock] Expansion
Hardware Chip Set [Device] Option [Clock] Option  Option Hardware

HS3LO8EPIGOH HS3834EVI6OH  H8/3837 2.5MHz 32kHz None
H8/3836 AMHz Target
H8/3835 5MHz
H8/3834 8MHz
H8/3833 10MHz
H8/3832 Target
H8/3814 Target/2
H8/3813
H8/3812

H8/3857 HS3857EI060H
H8/3857F

H8/3856

H8/3855

H8/3854 HS3854EI060H
H8/3854F

H8/3853

H8/3852

HS3876EVI6OH  H8/3877 None
H8/3876
H8/3875
H8/3637
H8/3636
H8/3635
H8/3627
H8/3626
H8/3625
H8/3824
H8/3623
H8/3622

HS3927EVI6OH  H8/3927
H8/3926
H8/3925
H8/3924

HS3644EPIGOH None H8/3657
H8/3656
H8/3655
H8/3654
H8/3653
H8/3652
H8/3644
H8/3643
H8/3642
H8/3641
H8/3640

H8/3644F 2.5MHz

H8/3643F 4AMHz

H8/3642F 5MHz
8MHz
10MHz
16MHz
Target
Target/2

Note: Target/2 in [Clock] and Target in [SubClock] are only available when the target system is connected.
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8.14 Memory Mapping Function

This function allows the external memory area (H8/300 mode 1 and mode 2 only) or the reserved (access-
prohibited) areas to be mapped in one-byte units. Each memory block can be set in memory on the user system
and the access can be specified as read-write, read-only, or access-prohibited in each case. It isnot possible to
change the attributes of memory incorporated in the MCU (internal ROM, internal RAM, or internal 1/0).

8.15 [Status] Window

Selecting [View -> CPU -> Status] or clicking the [Status Display] toolbar button displays the [Status] window.
The [Status] window has three sheets. This emulator displays the following items.

(1) [Memory] Sheet
Selecting the [Memory] tab on the [Status] window displays this sheet.

Table8.4 [Memory] Sheet Items

[Item] Column [Status] Column
Target Device Configuration Displays memory mapping.
System Memory Resources Displays the memory resource of the emulator hardware.
Program Name Displays the program file name.
418

RENESAS



(2) [Platform] Sheet
Selecting the [Platform] tab on the [Status] window displays this sheet.
Table85 [Platform] Sheet Items

[Item] Column [Status] Column

Connected To: Displays emulator name (driver used).
CPU Displays the target MCU name.

Mode Displays the selected mode.

Clock source Displays the selected clock.

Subclock source Displays the selected sub-clock.

Run status Displays the execution status.

Break: The user program breaks
Running: The user program is running

Cause of last break Displays the cause of the emulator stopped at a break. If a program
breaks in the sub-active state, '(SubActive)' will be displayed after the
cause of the break.

Ready: User program not executed (immediately after starting the HEW)
User Break: Break by the user

PC Break: Break by program breakpoint

On Chip Break A: Break by hardware PC Break

Complex Event System: Break by complex event system

Stepping Completed: Break by stepping completed

Stepping Aborted: Break by stepping aborted

ROM Write Access Break: Break by writing to ROM

Write-protect Access Break: Break by writing to a read-only memory
Unused Area Access Break: Break by accessing to a guarded memory
Stack In I/O Area: Break by a stack in the 1/0 area

Invalid breakpoint: Break by a break instruction without PC Break

Event Time Count Displays the measured result of the timer between events.

Run Time Count Displays the total execution time of the program.

(3) [Events] Sheet
Selecting the [Events] tab on the [Status] window displays this sheet.
Table8.6 [Events] Sheet Item

[Item] Column [Status] Column

Resources Displays the resource information and the information on events such as
the breakpoint.
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8.1.6 Extended Monitor Function

Selecting [View -> CPU -> Extended Monitor] or clicking the [Extended Monitor] toolbar button displays the
[Extended Monitor] window. This emulator displays the following items.

Table8.7 [Extended Monitor] Window Items

[Item] Column

[Value] Column

User NMI

Displays the status of the NMI pin.

User Reset

Displays the status of the reset pin.

User System Voltage

Displays whether or not the user VCC is equal to or exceeds the value set in
[User VCC Threshold] on the [General] page of the [Configuration Properties]
dialog box.

User Cable

Displays whether or not the user cable is connected.

Running status

Displays the address bus value in the MCU and the status of the CPU while
the user program is running, and the cause of a break while the user program
is halted.

Break = <Cause of break>: Displays the cause of a break.

Address = <Address bus value>:
Displays the address bus value during the user program execution. While in
subactive mode, ‘(SubActive)’ is displayed after the address bus value.

Status = <Status of the CPU>: Displays the status of the CPU.

H8/300 series:
CPU: CPU instruction cycles
CPU_PREFETCH: CPU instruction prefetch cycles
CPU_WORD: CPU word access cycles
DTU: DTU cycles

H8/300L series:
CPU: CPU instruction cycles
CPU_PREFETCH: CPU instruction prefetch cycles
SUB_ACTIVE_DATA: Subactive data access cycles
SUB_ACTIVE_PREFETCH: Subactive instruction prefetch cycles
CPU_MEDIUM_DATA: CPU data access cycles (medium-speed mode)
CPU_MEDIUM_PREFETCH:
CPU instruction prefetch cycles (medium-speed mode)

Target Mode

Displays the mode input from the user system.

Note: In this emulator, the update interval in the [Extended Monitor] window cannot be selected or changed.
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8.1.7 Signalsto Indicate Bus States and Areas

The following tables show examples of signalsto indicate the bus states and areas that can be acquired by the

emulator.

Table8.8 Bus State Signals Acquired by the Emulator (H8/300 Series)

Bus State Trace Display (Status) Description

CPU CPU CPU instruction cycles
CPU Prefetch CPU_PREFETCH CPU prefetch cycles
CPU Data CPU_WORD CPU word access cycles
DTU DTU DTU cycles

Table8.9 Bus State Signals Acquired by the Emulator (H8/300L Series)

Bus State Trace Display (Status) Description

CPU CPU CPU instruction cycles (high-speed mode)
CPU Prefetch CPU_PREFETCH CPU prefetch cycles (high-speed mode)
CPU Medium CPU_MEDIUM_PREFETCH  CPU prefetch cycles (medium-speed mode)
Prefetch

CPU Medium Data

CPU_MEDIUM_DATA

CPU data access cycles (medium-speed mode)

Sub Active Prefetch

SUB_ACTIVE_PREFETCH

Subactive prefetch cycles

Sub Active Data

SUB_ACTIVE_DATA

Subactive data access cycles

Table8.10 Area Signals Acquired by the Emulator (H8/300 Series)

Area Trace Display (Area) Description

On-chip ROM IN-ROM Internal ROM

On-chip RAM IN-RAM Internal RAM

On-chip I/0 lfe} 110
Expansion

Table8.11 AreaSignals Acquired by the Emulator (H8/300L Series)

Area Trace Display (Area) Description

On-chip ROM IN-ROM Internal ROM
On-chip RAM IN-RAM Internal RAM
On-chip 1/0 1/0 1/0

LCD/MTG-RAM

LCD/MTG-RAM

Note: The signalsto indicate bus states and areas are used to set the [Bus/Area] condition of the event paint.
They can a so be acquired as the trace information. The bus state signals are also used to set the
condition not to acquire the trace ([Suppress] option).

421

RENESAS



8.1.8  Monitoring Function

This emulator does not incorporate the bus monitoring circuit. To use the monitoring function, the bus monitor
board (HS6000EBRO1H) is required.

8.1.9 Trigger Points

This emulator does not incorporate the bus monitoring circuit. Connecting the bus monitor board
(HS6000EBRO1H) alows use of trigger points that can be set on the [Trigger] sheet in the [Event] window.

8.1.10 Tracelnformation

Selecting [View -> Code -> Trace] or clicking the [Trace] toolbar button displays the [Trace] window. Trace
information that can be acquired by the emulator and trace information items to be displayed are as listed below.

[PTR] Cycle number in the trace buffer. When the most recent record is record 0, earlier
record numbers go backwards (-1, -2, ...). If a delay count has been set, the cycle
number where the trace stop condition has been satisfied is record 0. For the cycle
(during delay) executed until the trace has stopped, earlier record numbers go
forward (+1, +2, ...) the most recent record.

[Address] Address (6-digit hexadecimal)

[Instruction] Disassembled code of the executed instruction

[Data] Data bus value, displayed as 2-digit or 4-digit hexadecimal

[R/W] Whether access was read (RD) or write (WR)

[Area] Memory area being accessed.
H8/300 series: Internal ROM, internal RAM, I/O, or expansion memory
H8/300L series: Internal ROM, internal RAM, I/O, or LCD/MTG-RAM
(This item is not available when a time stamp is acquired.)

[Status] Bus status during this cycle.
H8/300 series:
CPU (CPU instruction cycles), CPU_PREFETCH (prefetch cycles), CPU_WORD
(CPU word access cycles), or DTU (DTU cycles)
H8/300L series:
CPU (CPU instruction cycles), CPU_PREFETCH (prefetch cycles),
SUB_ACTIVE_DATA (subactive data access cycles), SUB_ACTIVE_PREFETCH
(subactive prefetch cycles), CPU_MEDIUM_DATA (data access cycles in medium-
speed mode), or CPU_MEDIUM_PREFETCH (prefetch cycles in medium-speed
mode)
(This item is not available when a time stamp is acquired.)

[Clock] Number of clock cycles in bus cycles (not available when a time stamp is acquired)

[Probes] A 4-bit binary number showing the four probe pins in the order of Probe 4, Probe 3,
Probe 2, and Probe 1 from the left (not available when a time stamp is acquired).

[NMI] Status of the NMI input signal (not available when a time stamp is acquired)

[Timestamp]

Time stamp of the record. Time stamps start from zero each time the user program
is executed. The timer resolution depends on the time stamp clock rate selected in
the trace acquisition (only available when a time stamp is acquired).

[Source] Source program
[Label] Label information for the address (if defined)
[Timestamp- Difference from the timestamp value shown on the previous line (only available
Difference] when a time stamp is acquired)
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8.1.11 Searching for a Trace Record

While using the emulator, the [ Trace Find] dialog box has the following pages:

Table8.12 [TraceFind] Dialog Box Pages

Page Description

[General] Sets the range for searching.

[Address] Sets an address condition.

[Data] Sets a data condition.

[R/W] Selects the type of access cycles.

[Area] Selects the area being accessed (not available when a time stamp is
acquired).

[Status] Selects the status of a bus (not available when a time stamp is acquired).

[Probes] Selects the status of four probe signals (not available when a time stamp
is acquired).

[Timestamp] Specify the time stamp value for bus cycles (only available when a time

stamp is acquired).

8.1.12 TraceFiltering Function

While using the emulator, the [Trace Filter] dialog box has the following pages:

Table8.13 [TraceFilter] Dialog Box Pages

Page Description

[General] Selects the range for filtering.

[Address] Sets address conditions.

[Data] Sets data conditions.

[R/W] Selects the type of access cycles.

[Area] Selects the area being accessed (not available when a time stamp is not
acquired).

[Status] Sets the status of a bus (not available when a time stamp is not
acquired).

[Probes] Selects the states of four probe signals (not available when a time stamp
is not acquired).

[Timestamp] Specifies the time stamp value for bus cycles (only available when a time

stamp is acquired).

8.1.13 [Performance Analysis] Window

For the H8/300 and H8/300L there are the performance analysis ranges for the following states which cannot be

deleted.

H8/300: Standby, DTU, Sleep, CPU, Other Addresses
H8/300L: Standby, Watch, Medium, Sub Sleep, Sleep, Sub Active, CPU, Other Addresses
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8.2 Note on Usage of the H8/300 and 300L E6000 Emulator

There isthe following note on usage of the emulator.

821 Environment for Execution of the Tutorial Program

To execute the tutorial program, specify “ Tutorial.hws’ stored in the following directory:
HEW install ation destination directory\Tool s\Renesas\DebugComp\Pl atform\E6000\300\ T utorial

8.2.2 Notes on Use of the H8/300 Group Evaluation Chip Set (HS3308EV160H)

* 1/O Register Differences Between Actual M CU and Emulator

In the EG000H emulator, one evaluation chip emul ates several types of MCU. Therefore, there are some
differencesin 1/O registers between an actual MCU and the emulator as shown in table 8.14. Note these
differences when accessing the I/O registers.

The /O portisin theinput state at default. The 1/O register contents indicate the emulator port status. When the
user system interface cable is not connected, the read value is 1 due to pull-up resistors. When 0 is written to the
1/0 register with no user system interface cable connected, the voltage level of the 1/0 port reaches 2.0V in
approximately 10 ps and the read value becomes 1.

Table8.14 Differencesin I/O Registers

1/0 Address H8/330 Group Note

FFDF X

FFE9 X Accessing these registers will change the contents of the A/D
FFEB % converter control register. Do not access these registers.

Note: X indicates that a register that does not exist in the actual MCU can be accessed in the emulator.

. Accessto the Reserved Area
When accessing the reserved area, note the following:

1. Part of the reserved area (specified in each MCU’s memory map) can be used as an external address area
when the RAME hit of the SYSCR iscleared to 0. On Board or Emulator can be specified for this areawith
the Configuration settings.

2. If thereserved area other than that described in item 1 above is used, the operation in the actual MCU cannot
be guaranteed.

e Useof Internal RAM Area asExternal Memory

Theinternal RAM area cannot be used as an external address area even when the RAME bit of the SYSCR is
cleared to 0.

. User Program Execution by the Go Reset Command

When the user program is executed by the Go Reset command, areset signal isinput for about 16 to 17 system
clock (@) cyclesto the evaluation chip from the emulator. For the execution time measurement result, the time
for reset signal input is added.
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8.2.3 Noteson Use of the H8/350 Group Evaluation Chip Set (HS3508EVI60H)

. User Program Execution by the Go Reset Command

When the user program is executed by the Go Reset command, areset signal isinput for about 16 to 17 system
clock () cycles to the evaluation chip from the emulator. For the execution time measurement result, the time
for reset signal input is added.

8.24 Noteson Use of the H8/338, H8/329 Group Evaluation Chip Set (HS3398EV160H)

. 1/0 Register Differences Between Actual MCU and Emulator

In the EGO00H emulator, one evaluation chip emul ates several types of MCU. Therefore, there are some
differencesin 1/O registers between an actual MCU and the emulator as shown in table 8.15. Note these
differences when accessing the I/0O registers.

1/0 port isin theinput state at default. The I/0 register contents indicate the emulator port status. When the user
system interface cable is not connected, the read value is 1 due to pull-up resistors.

Table8.15 Differencesin I/O Registers

1/0 Address H8/338 Group H8/329 Group Note

FF8F X (0]

FFDF X X

FFE9 X X Accessing these registers will change the
FFEB X x zggéizt?hgs??eAinSDt ecr(;r.werter register. Do not
FFFO X (0]

FFF2-FFFF X (0]

Note: X indicates that a register that does not exist in the actual MCU can be accessed in the emulator.

. Accessto the Reserved Area
When accessing the reserved area, note the following:

1. Part of the reserved area (specified in each MCU’s memory map) can be used as an external address area
when the RAME hit of the SYSCR iscleared to 0. On Board or Emulator can be specified for this area with
the Configuration settings.

2. If thereserved area other than that described in item 1 above is used, the operation in the actual MCU cannot
be guaranteed.

. Use of Internal RAM Area as External Memory

Theinternal RAM area cannot be used as an external address area even when the RAME bit of the SYSCR is
cleared to 0.

. User Program Execution by the Go Reset Command

When the user program is executed by the Go Reset command, areset signal isinput for about 16 to 17 system
clock () cyclesto the evaluation chip from the emulator. For the execution time measurement result, the time
for reset signal input is added.
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8.25 Noteson Use of the H8/3334 Group Evaluation Chip Set (HS3334EV160H)

* 1/O Register Differences Between Actual M CU and Emulator

In the EGO00H emulator, one evaluation chip emul ates several types of MCU. Therefore, there are some
differencesin 1/O registers between an actual MCU and the emulator as shown in table 8.16. Note these
differences when accessing the I/O registers.

1/0 port isin theinput state at default. The I/O register contents indicate the emulator port status. When the user
system interface cable is not connected, the read value is 1 due to pull-up resistors.

Table8.16 Differencesin I/O Registers

MCU Group
1/0 Address H8/3332  H8/3334  Note
FFAA-FFAB X X Accessing these registers will change the contents of addresses
FFA8 to FFA9; do not access these registers.
FFDF X X
FFE1 X X Accessing these registers will change the contents of the A/D
FFE3 X X converter control register; do not access these registers.
FFES X X
FFE7 X X
FFE9 X X
FFEB X X

Note: X indicates that a register that does not exist in the actual MCU can be accessed in the emulator.

* Accessto the Reserved Area
When accessing the reserved area, note the following:

1. Part of the reserved area (specified in each MCU’s memory map) can be used as an external address area
when the RAME bit of the SYSCR iscleared to 0. On Board or Emulator can be specified for this area with
the Configuration settings.

2. If thereserved area other than that described in item 1 above is used, the operation in the actual MCU cannot
be guaranteed. If the user program extends to the reserved area during debugging, select the MCU having
the largest memory capacity (for example, debug the H8/3332 program in the H8/3334 mode).

e Useof Internal RAM Area as External Memory
Theinternal RAM area cannot be used as an external address area even when the RAME bit of the SYSCR is
cleared to 0.

e User Program Execution by the Go Reset Command

When the user program is executed by the Go Reset command, areset signal isinput for about 16 to 17 system
clock () cyclesto the evaluation chip from the emulator. For the execution time measurement result, the time
for reset signal input is added.
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8.26  Noteson Use of the H8/3257, H8/325 Group Evaluation Chip Set (HS3257EVI60H)

* 1/O Register Differences Between Actual M CU and Emulator

In the EGO00H emulator, one evaluation chip emul ates several types of MCU. Therefore, there are some
differencesin 1/O registers between an actual MCU and the emulator as shown in table 8.17. Note these
differences when accessing the I/O registers.

1/0 port isin theinput state at default. The 1/O register contents indicate the emulator port status. When the user
system interface cable is not connected, the read value is 1 due to pull-up resistors.

Table8.17 Differencesin I/O Registers

MCU Group
/0 Address  H8/3256  H8/3257  H8/322 H8/323 H8/324 H8/325 Note
FFDF X X X X X X Registers that do not
FFES X X X X X X exist in the actual MCU

can be read in the
emulator. Write access
is ignored.

Note: X indicates that a register that does not exist in the actual MCU can be accessed in the emulator.

. Accessto the Reserved Area
When accessing the reserved area, note the following:

1. Part of the reserved area (specified in each MCU’s memory map) can be used as an external address area
when the RAME bit of the SYSCR iscleared to 0. On Board or Emulator can be specified for this area with
the Configuration settings.

2. If thereserved area other than that described in item 1 above is used, the operation in the actual MCU cannot
be guaranteed. If the user program extends to the reserved area during debugging, select the MCU having
the largest memory capacity (for example, debug the H8/322 program in the H8/325 mode).

. Use of Internal RAM Area as External Memory

Theinternal RAM area cannot be used as an external address area even when the RAME bit of the SYSCR is
cleared to 0.

. User Program Execution by the Go Reset Command

When the user program is executed by the Go Reset command, areset signal isinput for about 16 to 17 system
clock () cyclesto the evaluation chip from the emulator. For the execution time measurement result, the time
for reset signal input is added.

. E-Clock-Synchronous I nstructions
To execute E-clock-synchronous instructions (M OV FPE and MOV TPE), note the following:

1. E-clock-synchronous instructions can be executed only when User is specified as the external address area. If
On chip or Emulator is specified, these instructions will not be correctly executed.

2. When an E-clock-synchronous instruction (M OV FPE or MOV TPE) is executed, trace information on
instruction execution cycles being displayed will be incorrect.
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8.2.7

. 1/0 Register Differences Between Actual MCU and Emulator

Notes on Use of the H8/3437, H8/3437Y, H8/3297 Group Evaluation Chip Set (HS3437EVI60H)

In the EGO00H emulator, one evaluation chip emul ates several types of MCU. Therefore, there are some
differencesin 1/O registers between an actual MCU and the emulator as shown in table 8.18. Note these
differences when accessing the I/O registers.

1/0 port isin theinput state at default. The I/0 register contents indicate the emulator port status. When the user

system interface cable is not connected, the read value is 1 due to pull-up resistors.

Table8.18 Differencesin I/O Registers

MCU Group

110 H8/3434F H8/3334YF  H8/3397  HB8/3297

Address  H8/3437  H8/3437F  H8/3337Y  H8/3337YF _ HB8/3534  H8/3522  Note

FF80 X A X A X (0] These registers can only be

FF82 X JAY X JAY X (0] used in the microcomputers

FF83 X TAY X JAY X (0] including flash memory. They
cannot be accessed in the
H8/3297 group.

FF8F X X X X X o

FF91 JAY JAY JAY JA) JA) JAY

FFAA (0] (0] X X X o Ports A and B can only be used

FFBC o o X X X (e} in the H8/3437 and H8/3434F
group. These registers cannot
be accessed in the H8/3297
group.

FFC3 o o o o o JA)

FFD8 o o o o X o The 1ICbus cannot be used in

FFD9 (0] (0] (0] (0] X (0] the actual H8/3397 group.

FFDE o o o o X o

FFDF JA) JA) JA) JA) X JA)

FFFO o o o o X o The HIF cannot be used in the

FFF4 (0] (0] (0] (0] X (0] actual H8/3397 group. These

FFF5 (0] (0] (6] (6] X (e] registers cannot be accessed in

FFF6 (0] (0] (0] (0] X (0] the H8/3297 group.

FFF8 o o o o X o The D/A converter cannot be

FFF9 o o o o X o used in the actual H8/3397

FFFA (0] (0] (0] (0] X (0] group. These registers cannot
be accessed in the H8/3297
group.

FFFC (0] (0] (0] (0] X (0] The HIF cannot be used in the

FFFD o (0] (6] (6] X (6] actual H8/3397 group. These

FFFE (0] (0] (0] (0] X (0] registers cannot be accessed in
the H8/3297 group.

Note: O indicates the same specifications as the actual MCU.

X indicates that a register that does not exist in the actual MCU can be accessed in the emulator.
A indicates that the initial value of the register differs between the actual MCU and the emulator.
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. Accessto the Reserved Area
When accessing the reserved area, note the following:

1. Part of the reserved area (specified in each MCU’s memory map) can be used as an external address area
when the RAME bit of the SYSCR iscleared to 0. On Board or Emulator can be specified for this area with
the Configuration settings.

2. If thereserved area other than that described in item 1 above is used, the operation in the actual MCU cannot
be guaranteed. If the user program extends to the reserved area during debugging, select the MCU having
the largest memory capacity (for example, debug the H8/3434 program in the H8/3437 mode).

. Use of Internal RAM Area as External Memory

Theinternal RAM area cannot be used as an external address area even when the RAME bit of the SYSCR is
cleared to 0.

. User Program Execution by the Go Reset Command

When the user program is executed by the Go Reset command, areset signal isinput for about 16 to 17 system
clock () cyclesto the evaluation chip from the emulator. For the execution time measurement result, the time
for reset signal input is added.

. Boot-M ode Emulation for MCUs I ncluding Flash Memory
For the MCUs including flash memory (H8/3434F, H8/3437F, H8/3334Y F, H8/3337Y F, and H8/3394F), the
boot-programming mode can be emulated in the following procedure.

1. Setting Up the System
Connect the user system to the emulator because data is transferred between the host computer and the
emulation memory through the TXD1 and RXD1 in boot-programming mode.
If boot-programming mode emulation is started without the user system, the evaluation chip cannot
communicate with the host computer and continues to wait for the host computer response. In this case,
initialize the HEW, turn off the emulator, connect the user system, and then restart the emulator.

2. Setting the emulator configuration
0 Select [Option -> Emulator -> System...] or click the [Emulator System] toolbar button () to open the

[Configuration Properties] dialog box.

O In[Device], select the target MCU including flash memory (e.g. [H8/3337YF]).
O For emulation in the boot mode, check [Enable Boot Mode].
0 Closethe [Configuration Properties] dialog box.

3. Starting emulation in boot mode
Select [Debug -> Reset Go] or click the [Reset Go] toolbar button () to start program execution from the
reset state. The evaluation chip isreset and boot-programming mode emulation starts. (During emulation in
boot-programming mode, the write protection of the internal ROM areais disabled.)
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8.28 Noteson Use of the H8/3217, H8/3318 Group Evaluation Chip Set (HS3318EVI60H)

* 1/O Register Differences Between Actual M CU and Emulator

In the EGO00H emulator, one evaluation chip emul ates several types of MCU. Therefore, there are some
differencesin 1/O registers between an actual MCU and the emulator as shown in table 8.19. Note these
differences when accessing the I/O registers.

1/0 port isin theinput state at default. The I/O register contents indicate the emulator port status. When the user
system interface cable is not connected, the read value is 1 due to pull-up resistors.

Table8.19 Differencesin I/O Registers

MCU Group
H8/3202

1/0 Address H8/3318 H8/3217 HB8/3212 H8/3502 Note

FF8F X o o o

FF91 [ [ [ [

FF9A to FFOE (0] (0] (0] X The TMRX cannot be used in the H8/3202
and H8/3502.

FFIF (0] (0] (0] X The timer connection cannot be used in the
H8/3202 and H8/3502.

FFA1 [ o o o

FFA4 to FFA7 (0] (0] (0] X The IIC1 cannot be used in the H8/3202 and
H8/3502.

FFA8 (0] o (0] X The timer connection cannot be used in the
H8/3202 and H8/3502.

FFCDto FFCF O (0] (0] X The PWM cannot be used in the H8/3202
and H8/3502.

FFD5 (0] (0] (0] X The PWM cannot be used in the H8/3202
and H8/3502.

FFDF X X X X

FFEO to FFE5 o (0] X (0] The SCI1 cannot be used in the H8/3212.

FFE7 ¢} X X X

FFFO to FFFF (0] (0] X (0] The HIF cannot be used in the H8/3212.

The PWM cannot be used in the H8/3202
and H8/3502.

Note: O indicates the same specifications as the actual MCU.
X indicates that a register that does not exist in the actual MCU can be accessed in the emulator.
A indicates that the initial value of the register differs between the actual MCU and the emulator.

. Accessto the Reserved Area
When accessing the reserved area, note the following:

1. Part of the reserved area (specified in each MCU’s memory map) can be used as an external address area
when the RAME bhit of the SYSCR iscleared to 0. On Board or Emulator can be specified for this area with
the Configuration settings.

2. If thereserved area other than that described in item 1 above is used, the operation in the actual MCU cannot
be guaranteed. If the user program extends to the reserved area during debugging, select the MCU having
the largest memory capacity (for example, debug the H8/3214 program in the H8/3217 mode).

. Use of Internal RAM Area as External Memory

Theinternal RAM area cannot be used as an external address area even when the RAME bit of the SYSCR is
cleared to 0.
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. User Program Execution by the Go Reset Command

When the user program is executed by the Go Reset command, areset signal isinput for about 16 to 17 system
clock () cyclesto the evaluation chip from the emulator. For the execution time measurement result, the time
for reset signal input is added.

8.2.9 Notes on Use of the H8/3834, H8/3814 Group Evaluation Chip Set (HS3834EVI60H)

. 1/0 Register Differences Between Actual MCU and Emulator

In the E6G000 emul ator, one evaluation chip emulates several types of MCU. Therefore, there are some
differencesin 1/0O registers between an actual MCU and the emulator as shown in table 8.20. Note these
differences when accessing the I/0O registers.

1/0 port isinput at default. The I/O register contents indicate the emulator port status. When the user system
interface cable is not connected, the read valueis 1 due to pull-up resistors.

Table8.20 Differencesin I/O Registers

MCU Group

1/0 Address H8/3834 Group  H8/3814 Group  Note

FF4A to FFA7 o X The H8/3814 group does not have bits 0
to 4.

FFAE to FFAF X X

FFB2 (0] X The H8/3814 group does not have bits 0
to2and?7.

FFB3 o X

FFB4 (0] X The H8/3814 group does not have bits 0
to2and5to 7.

FFB5 (e} X

FFB6 JAY JAY

FFBC JAY JAY

FFBF X X

FFC2, FFC3 X X

FFC7 X X

FFC8 (0] X The H8/3814 group does not have bit 5.

FFC9 (0] X The H8/3814 group does not have bits 2
and 5.

FFCA (0] X The H8/3814 group does not have bits 3
to 7.

FFCD, FFCE X X

FFDO (0] X The H8/3814 group does not have bits 2
to 7.

FFD1 (0] X The H8/3814 group does not have bits 6
and 7.

FFD2 (0] X The H8/3814 group does not have bits 0
to 7.

FFD3 X X

FFD4 JAY JAY

Note: O indicates the same specifications as the actual MCU.
X indicates that a register that does not exist in the actual MCU can be accessed in the emulator.
A indicates that the initial value of the register differs between the actual MCU and the emulator.
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Table8.20 Differencesin I/0O Registers(cont)

MCU Group

1/0 Address H8/3834 Group  H8/3814 Group  Note

FFD6to FFDD & JAY

FFE4to FFED & JAY

FFEE, FFEF X X

FFF4 (0] X The H8/3814 group does not have bits 0,
1, and 5.

FFF5 X X

FFF7 (0] X The H8/3814 group does not have bits 0,
1, and 5.

FFF8 X X

FFFAto FFFF X X

Note: O indicates the same specifications as the actual MCU.
X indicates that a register that does not exist in the actual MCU can be accessed in the emulator.
A indicates that the initial value of the register differs between the actual MCU and the emulator.

. Accessto the Reserved Area

1. Thereserved areaH' FF80 to H’ FFOF in the H8/3814 group is used by the emulator. If this areais assigned to
the emulation memory by the map setting, operation cannot be guaranteed. Do not use this area.

2. Thereserved area H' FOOO to H' F73F in the H8/3834 group or the H8/3814 group is used by the emulator. If
this areais assigned to the emulation memory by the map setting, operation cannot be guaranteed. Do not use

this area.

. User Program Execution by the Go Reset Command
When the user program is executed by the Go Reset command, areset signal isinput for about 500 psto the
evaluation chip from the emulator. For the execution time measurement result, the time for reset signal input is

added.
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8.210 Noteson Use of the H8/3637, H8/3877 Group Evaluation Chip Set (HS3876EV160H)

* 1/O Register Differences Between Actual M CU and Emulator

In the EGO00H emulator, one evaluation chip emul ates several types of MCU. Therefore, there are some
differencesin 1/O registers between an actual MCU and the emulator as shown in tables 8.21 and 8.22. Note
these differences when accessing the I/O registers.

Thel/O portisintheinput state at default. The 1/O register contents indicate the emulator port status. When the
user system interface cable is not connected, the read valueis 1 due to pull-up resistors.

Table8.21 Differencesin I/O Registers (H8/3637 Group)

1/0 Address H8/3637 Group Note

FF90 to FF97

FF9A Bits 0, 1, and 3 to 7 do not exist.

FFA4 Bits 1 to 7 do not exist.

FFA5 Bits 6 and 7 do not exist.

FFAG

FFA7

FFAE, FFAF

FFB4, FFB5

FFB6

FFBC

FFBF to FFC3

FFC7toFFCC

FFDO to FFD2

FFD3 Bits 0, 1, and 4 to 7 do not exist.

FFD4

FFD6, FFD7

FFD8 to FFDC

FFDD Bits 4 to 7 do not exist.

FFDE Bits 0 to 3 do not exist.

FFDF to FFE2

FFE3 Bits 0, 1, and 4 to 7 do not exist.

FFE4 to FFES

FFE®6, FFE7

FFES8 to FFEC

FFED Bits 4 to 7 do not exist.

FFEE, FFEF

FFF5

FFF6 Bit 5 does not exist.

FFF8

XIXIDI X XIDID X DD XDDDXIDDXXXDDXXXDD DD X

FFFA to FFFF

Note: X indicates that a register that does not exist in the actual MCU can be accessed in the emulator.
A indicates that the initial value of the register differs between the actual MCU and the emulator.
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Table8.22 Differencesin I/O Registers (H8/3877 Group)

1/0 Address

H8/3877 Group

Note

FF95 to FF97

FF98

Bit 4 does not exist.

FFOA

FFA4 to FFA7

FFAE, FFAF

FFB4, FFB5

FFB6

FFBC

FFBF

FFC2, FFC3

FFC7 to FFD1

FFD2

FFD3

Bits 4 to 7 do not exist.

FFD4

FFD6, FFD7

FFD8 to FFDC

FFDD

Bits 4 to 7 do not exist.

FFDF to FFE1

FFE2

FFE3 Bits 4 to 7 do not exist.
FFE4, FFE5

FFF6, FFE7

FFES8 to FFEC

FFED Bits 4 to 7 do not exist.
FFEE, FFEF

FFF4 Bits 0 and 1 do not exist.
FFF5

FFF6 Bit 5 does not exist.
FFF7 Bits 0 and 1 do not exist.
FFF8

FFFA to FFFF

XIXIDID XID|X DD XDDDXDIDXD DD XXXD DX XX XD X

Note: X indicates that a register that does not exist in the actual MCU can be accessed in the emulator.
A indicates that the initial value of the register differs between the actual MCU and the emulator.

e User Program Execution by the Go Reset Command

When the user program is executed by the Go Reset command, areset signal isinput for about 500 ps to the
evaluation chip from the emulator. For the execution time measurement result, the time for reset signd input is

added.
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8.211 Noteson Use of the H8/3927 Group Evaluation Chip Set (HS3927EV160H)

* 1/O Register Differences Between Actual M CU and Emulator

In the EGO00H emulator, one evaluation chip emul ates several types of MCU. Therefore, there are some
differencesin 1/O registers between an actual MCU and the emulator as shown in table 8.23. Note these
differences when accessing the I/O registers.

Thel/O portisintheinput state at default. The 1/O register contents indicate the emulator port status. When the
user system interface cable is not connected, the read valueis 1 due to pull-up resistors.

Table8.23 Differencesin I/O Registers

1/0 Address H8/3927 Group Note

F771

F777 Bits 5 to 7 do not exist.

FFA4 to FFA7 Bits 5 to 7 do not exist.

FFA8 to FFAF

FFCO, FFC1

FFC4 Bits 4 and 5 do not exist.

FFC7

FFDO Bits 1 to 7 do not exist.

FFD1 Bits 6 and 7 do not exist.

FFD2

FFD3

FFD4

FFD5

FFD6

FFD8 to FFDB

FFDC

FFDF to FFE1

FFE4

FFES

FFEG6 to FFEB

FFEC

FFF7 Bit 4 does not exist.

DD X[D|XIDXIXDD XD XDDD XD XXDDD

FFF8

FFFA, FFFB X

Note: X indicates that a register that does not exist in the actual MCU can be accessed in the emulator.
& indicates that the initial value of the register differs between the actual MCU and the emulator.

*  User Program Execution by the Go Reset Command

When the user program is executed by the Go Reset command, a reset signal isinput for about 500 pis to the
evaluation chip from the emulator. For the execution time measurement result, the time for reset signal input is
added.
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8.212 Noteson Use of the H8/3644, H8/3657 Group Emulator (HS3644EPI60H)

. 1/0 Register Differences Between Actual MCU and Emulator

In the E6G000 emul ator, one evaluation chip emulates several types of MCU. Therefore, there are some
differencesin 1/O registers between an actual MCU and the emulator as shown in table 8.24. Note these
differences when accessing the I/O registers.

1/0 port isinput at default. The I/O register contents indicate the emulator port status. When the user system
interface cable is not connected, the read valueis 1 due to pull-up resistors.

Table8.24 Differencesin I/O Registers

MCU Group

1/0 Address H8/3644 Group  H8/3657 Group  Note

F740 to F744 X X

F771 JAY JAY

FFA4 to FFA7 X X

FFAE to FFAF X X

FFB4 to FFB7 X X

FFCO to FFC3 X X

FFC7to FFCF X X

FFDO to FFD2 JAY JAY

FFD3 X X

FFD4 JAY JAY The H8/3644 group does not have bits 1
to 3.

FFD5 JAY JAY The H8/3644 group does not have bits 3
to 7.

FFD6 TAY TAY The H8/3644 group does not have bits 3
to7.

FFD7 X X

FFDA TAY TAY The H8/3644 group does not have bits 0
to 2.

FFDC JAY JAY The H8/3644 group and H8/3657 group

do not have bit 5.

Note: X indicates that a register that does not exist in the actual MCU can be accessed in the emulator.
A indicates that the initial value of the register differs between the actual MCU and the emulator.
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Table8.24 Differencesin I/0O Registers(cont)

MCU Group

1/0 Address H8/3644 Group

H8/3657 Group

Notes

FFDE-FFE3 X

X

FFE4 JAY JAY The H8/3644 group does not have bits 1
to 3.

FFES5 JAY JAY The H8/3644 group does not have bits 3
to 7.

FFE6 JAY JAY The H8/3644 group does not have bits 3
to 5.

FFE7 X X

FFEA TAY TAY The H8/3644 group does not have bits 0
to 2.

FFEB-FFEC JAY JAY

FFED TAY TAY The H8/3644 group does not have bits 1
to 3.

FFEE JAY JAY The H8/3644 group does not have bits 3
to 5.

FFF7 JAY JAY

FFFA-FFFB X X

FFFE X X

Note: X indicates that a register that does not exist in the actual MCU can be accessed in the emulator.

. Accessto the Reserved Area

A indicates that the initial value of the register differs between the actual MCU and the emulator.

The reserved area H' FF80 to H' FFOF is used by the emulator. If this areais assigned to the emulation memory
by the map setting, operation cannot be guaranteed. Do not use this area.

. User Program Execution by the Go Reset Command

When the user program is executed by the Go Reset command, areset signal isinput for about 500 psto the

evaluation chip from the emulator. For the execution time measurement result, the time for reset signal input is

added.
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Appendix A Troubleshooting

| have clicked the “ Stop Build” button or selected [Build->Stop Build] to abort a build but the build
process has not stopped.
The HEW will stop the build after it has built the current file (or executed the current single phase). If the
builder does not respond after alonger period of time you can select [Build->Terminate Current Tool]
which will attempt to forcibly terminate the current process. Do NOT assume that any output from the tool
you terminated isvalid. It is recommended that you delete any output files produced and ensure that the
phase is executed again.

| have atext file in the editor but it does not show any syntax coloring.
Ensure that you have named the file (i.e. saved it) and that the “ Enable syntax coloring” check box is set on
the “Editor” tab of the “Tools Options’ dialog, which islaunched via[Tools->Options...]. HEW checksa
file group to which the file's extension belongs and decides whether the file is colored. To view the current
defined extensions and their file groups, use the “File Extensions’ dialog which islaunched via [Project-
>File Extensions...]. To view coloring information, use the “Format” tab of the “Tools Options’ dialog,
which islaunched via[Tools->Options...]. (See the “ Syntax Coloring” section in chapter 4, “Using the
Editor” for details.)

| want to change the settings of a tool but the [Tools->Administration...] menu option cannot be selected.
[Tools->Administration...] cannot be selected while a workspace is open. To enter the “ Tool
Administration” dialog first close the current workspace.

| did not edit any of the project files. But some of files were built again when | selected [Build->Build].
A fileisbuilt again if any of the following conditions holds:
1. Theoptionsfor the current file have been modified since the last build.
If any of the output files are missing.
Any of the source files have a newer date than the phase’s output files.
Any of the dependent files have a newer date than the phase' s output files.
In auser-defined custom build phase, the “Don’t check for input file(s) existence before executing”
check box is checked. To see the status of this check box, select [Options->Build Phases...], select the
phase in the “Build Phase Order” list in the “Build Order” tab, and click the “Modify...” button. Then
you will seethe “Don’t check for input file(s) existence before executing” check box on the “Command”
tab.
6. A subcommand fileis selected in Optimizing Linkage Editor.

| want to exclude a filein a project from build temporarily.
Push the right button of your mouse on the file in the “Projects’ tab of the “Workspace” window, and select
[Exclude Build <file>], where <file> is the selected file. Then the file is excluded from build. To include the
filein build again, push the right button of your mouse on the file, and select [I nclude Build <file>].

| opened a workspace from my PC, and one of my colleagues opened the same workspace simultaneoudy
from another PC. | changed the settings of the workspace and saved it. He or she saved the workspace
after me. | opened the workspace again and found that the settings of the workspace differed from what |
had set before.
The settings saved last are enforced. Once HEW opens aworkspace, it is updated inside the memory. HEW
does not save the settings into a file until a user saves the workspace intentionally.

ok~ wDN

439
RENESAS



?

| want HEW to automatically specify default optionsto a file, which is newly added to a project.
Y ou can specify default options to a phase if the phase is a multiple build phase. Select a phase from the
[Options] menu. If the phaseisamultiple build phase, afilelist isdisplayed on the left-hand side of the
optionsdialog (figure A.1). Inthefilelist, open afolder of afile group to which you want to specify your
default options. Y ou will find a“ Default Options” icon in the folder. Select the icon, specify options on the

right-hand side of the options dialog, and click “OK”. The options specified here will be given to any new
file of that file group when it isfirst added to the project.

S8 CAC++ sounce file
B2 C source file
E1-423 C++ source file

Default Options

?
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Figure A.1: Options Dialog File List

| selected [Build->Build All], but the dependenciesin the “ Projects’ tab of the “Workspace” window is
not updated while selecting [Build->Build] updates the dependencies.

[Build->Build All] does not update the dependencies in the “ Projects’ tab of the “Workspace” window. To
update the dependencies, select [Build->Update All Dependencies)].
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Appendix B Regular Expressions

The High-performance Embedded Workshop editor allows you to include special charactersin search strings
when performing a find or replace operation. These characters are listed in table B.1 and are detailed in the
following pages.

TableB.1: Regular Expression Characters

Character

Meaning

Matches one or more occurrences of the preceding item, except in a bracket expression. For
example, a+ matches a, aa, aaa, and so on.

Matches zero or more occurrences of the preceding item, except in a bracket expression. For
example, a* matches the empty string, a, aa, and so on.

Matches zero or one occurrence(s) of the preceding item, except in a bracket expression. For
example, a? matches the empty string and a.

{and }

Specify a cardinality range, formed as follows: {m,n}. This construct matches between m and n
occurrences of the preceding item. For example, a{2,3} matches aa and aaa.

This construct can also be formed using {m,} and {m}. The first matches m or more occurrences of
the preceding item. For example, a{2,} matches aa, aaa, aaaa, and so on. The second matches
exactly m occurrences of the preceding item. For example, a{2} matches aa.

[and]

Create a bracket expression. Bracket expressions create a set of items, any of which may be
matched. For example, [abc] matches a, or b, or c.

Within a bracket expression all regular expression special characters are treated as normal, non-
special characters, except:

- specifies a range of character values, based on their bit pattern. For example, [A-Za-z] matches
all uppercase and lowercase English characters. To indicate - as a character in the bracket
expression, it must be the first or last character in the set; for example, [-a-z] or [A-Z-].

A is special only when placed in the first character position within the bracket set. Using  in the
first position complements the set of items to be matched. For example, [*a-z] matches all
characters except for lowercase English letters.

Finally, in order to include a ] as a character in the bracket set, you must include it as the first
character in the set, as in [Jabc] or [Aabc].

(and)

Group regular expression items into subexpressions, which are treated as a single unit. For
example, whereas ab* matches a, ab, abb, and so on, (ab)* matches the empty string, ab, abab,
and so on. (and ) are not treated as special characters inside a bracket expression.

Escapes a regular expression character, causing it to be treated as a regular character. For
example, whereas (ab) indicates a subexpression consisting of ab, \(ab\) denotes the sequence
of characters (, a, b, and ).

Note: To specify the \ character in C++ source code, you must specify \\, as the C++ compiler
treats the \ character as special, denoting the beginning of an escape sequence embedded in the
C++ source code. In data files, or text controls in dialog boxes, however, the double backslash is
not necessary.

Indicates that a regular expression or subexpression is anchored at the beginning of the input
string. For example, Aab matches ab and abc, but not cab. Recall that / is treated differently in
bracket expressions.
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TableB.1: Regular Expression Characters (cont)

‘ Character ‘ Meaning

$ Indicates that a regular expression or subexpression is anchored at the end of the input string. For
example, ab$ matches ab and cab, but not abc.

| Denotes alternation, or the creation of a set of equally valid, alternate expressions or
subexpressions, each of which can be matched. For example, ab | cd matches ab or cd.

‘. ‘ Matches any code unit, except for those which indicate the logical end of a line.

442
RENESAS




Appendix C Placeholders
This appendix describes how to use the placeholders, a feature provided by several of the HEW components.

ci1 What is a Placeholder ?

A placeholder isa special string, inserted into text, which is replaced at some subsequent time for the actual
vaue. For example, one of the HEW placeholdersis $(FULLFILE) which represents afile with afull path.
Suppose that you have an editor in c:\myedit\myeditor.exe, which can take the file to edit as a parameter. When
invoking the editor the following shortcut could be made, e.g.:

c:\myeditimyeditor.exe c:\files\filel.c

if you wanted to open FILEL.C from the directory c:\files. However, what happensif you want the HEW to open
any file through this editor? The problem isthat the command above is specific to “c:\files\filel.c’. What we
want to be able to do isto tell the HEW to use the editor specified but to open the file that | have chosen at that
time. To do this, you can replace the specific name of thefile for ageneral placeholder, i.e.:

c:\myedit\myeditor.exe $(FULLFILE)

Now whenever the HEW launches the editor with afile, it knowsthat it has to replace $(FULLFILE) with the
file you have selected.

Cc.2 Inserting a Placeholder

Placeholders can only be entered into three specific edit fields within the HEW (figures C.1, C.2 and C.3). There
are four ways a placeholder can be entered:

In thefirst example, place the insertion cursor at the point you would like to insert the placeholder and then
select the required placehol der from the popup menu to the right of the edit field.

File:
o projectymyprojecthouputhfile 7 out [ 3 |

FigureC.1 Placeholder Popup Menu

In the second example, select the required placeholder other than [Custom directory] from the combo box and
specify a sub-directory relative to the directory shown by the placeholder. If you select [Custom directory],
specify an absolute directory path in the [Sub-Directory] field.

Relative to :

ICnnfiguralion directary ﬂ

Sub-Directory :

FigureC.2 Placeholder Combo Box and Sub-Directory Field
Note: The[Sub-Directory] field may be written as the [File path] field.

In the third example, place the insertion cursor at the point you would like to insert the placeholder, select the
required placeholder from the combo box and then click the [Insert] button.
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Placeholder:

Configuration directony j Inzert |

Figure C.3 Placeholder Combo Box

In the fourth example, type the placeholder into the field directly. Ensure that you type the placeholder namein
uppercase and that it is preceded by $( and followed by ), i.e.

Thisis correct:
$(FILEDIR)

These are incorrect:
$(Filedir)

$( FILEDIR )
$FILEDIR
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C3 Available Placeholders

Table C.1 lists the placeholders and their meanings.

TableC.1 Placeholders

Placeholder Meaning
$(FULLFILE) Filename (including full path)
$(FILEDIR) File directory

$(FILENAME)

Filename (excluding path and including extension)

$(FILELEAF)

Filename (excluding path and extension)

$(EXTENSION)

File extension

$(WORKSPDIR)

Workspace directory

$(WORKSPNAME) Workspace name
$(PROJDIR) Project directory
$(PROJECTNAME) Project name

$(CONFIGDIR)

Configuration directory

$(CONFIGNAME)

Configuration name

$(HEWDIR) HEW installation directory

$(TCINSTALL) Toolchain install directory (on option dialog)
$(TOOLDIR) Tool installation directory (Tools Administration)
$(TEMPDIR) Temp directory

$(WINDIR) Windows® directory

$(WINSYSDIR) Windows® system directory

$(EXEDIR) Command directory

$(USERNAME) User login (Version control)
$(PASSWORD) User password (Version control)

$(VCDIR) “Virtual” version control directory
$(COMMENT) Comment (Version control)

$(LINE) Line number of an error/warning

RENESAS
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For example, the placeholders will be expanded as shown in table C.2.

TableC.2 Placeholder Expansions (Example)

Placeholder Expanded placeholder (example)
$(FULLFILE) c:\hew\workspace\project\file.src
$(FILEDIR) c:\hew\workspace\project
$(FILENAME) file.src

$(FILELEAF) file

$(EXTENSION)

src

$(WORKSPDIR)

c:\hew\workspace

$(WORKSPNAME) workspace

$(PROJDIR) c:\hew\workspace\project
$(PROJECTNAME) project

$(CONFIGDIR) c:\hew\workspace\project\debug
$(CONFIGNAME) debug

$(HEWDIR) c:\hew

$(TCINSTALL) c:\hew\toolchains\hitachi\sh\511
$(TOOLDIR) c:\hew\toolchains\hitachi\sh\511
$(TEMPDIR) c\Temp

$(WINDIR) c:\Windows

$(WINSYSDIR) c:\Windows\System

$(EXEDIR) v:\ve\win32

$(USERNAME) JHARK

$(PASSWORD) 214436

$(VCDIR) “c:\project” is mapped to “x:\vc\project”
$(COMMENT) “Please Enter Comment” dialog is invoked
$(LINE) 12

In table C.2, we are assuming that

afile path is*“c:\hew\workspace\project\file.src”.

aworkspace named “workspace” islocated at “c:\hew\workspace”.

aproject named “project” islocated at “ c:\hew\workspace\project”.

a configuration named “debug” has a configuration directory located at “c:\hew\workspace\project\debug”.
HEW.EXE isinstalled in “c:\hew".

a*.HRF file of atoolchain (i.e. compiler, assembler, linker) islocated at “c:\hew\tool chain\hitachi\sh\511".
Thisisreferred to as $(TCINSTALL) on the option setting dialogs of the [Options] menu and as
$(TOOLDIR) on the “ Tools Administration” dialog.

the Windows® operating system isinstalled in “c:\Windows” and the Windows® system directory is
“c:\Windows\System”.

aversion control executable path is “v:\wc\win32\ss.exe”, auser name and its password to login the version
control system are “JHARK” and “214436" respectively, (COMMENT) is specified in acommand line to
the version control executable, and “c:\project” is mapped to “x:\vc\project” on the “Projects” tab of the
“Version Control Setup” dialog, which isinvoked via[Tools->Version Control->Configure...].

an error of compiler or assembler occurred at line 12.
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Note:  Not all of the placeholders are relevant in every field. For example, the $(LINE) placeholder has no
meaning when specifying a dependent files location. $(USERNAME), $(PASSWORD), $(VCDIR), and
$(COMMENT) placeholders are acceptable only in version contral. If you enter a placeholder into an
edit field where it is not acceptable you might be informed.

(o] Placeholder Tips
Placeholders are there to allow you to create flexible paths to the various files used by the system.

* If thereis aplaceholder popup menu ([k]) next to an edit field into which you are about to enter a path or file,
you should consider how you can use a placeholder to make that path or file definition flexible.

 If you use several configurations, then the §(CONFIGDIR) placeholder is very useful to ensure that files can
be written to and from the current configuration’s directory.

*  Wherever possible, use a placeholder. They can always be removed or added later so don't be afraid to
experiment.
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Appendix D 1/0 File Format

HEW formats the [IO] window based on information it findsin an I/O Register definition file. When you select a
debugging platform, HEW will look for a“<device>.10" file corresponding to the selected device and load it if

it exigts. Thisfile isaformatted text file that describes the 1/0 modules and the address and size of their registers.
Y ou can edit thisfile, with atext editor, to add support for memory mapped registers or peripherals you may
have specific to your application (e.g. registersin an ASIC device mapped into the microcomputer's address

space).

The following describes two formats of the “<device>.10” file that supports or not the bit field.

D.1 Fileformat (Bit Field Not Supported)

Each module name must be defined in the [M odules] definition section and the numbering of each module must
be sequential. Each module corresponds to a register definition section and within the section each entry defines
an |/O regigter.

The [BaseAddress] definition is for devices where the location of 1/0 registers moves in the address space
depending on the CPU mode. In this case, the [BaseAddress] value is the base address of the 1/O registersin one
specific mode and the addresses used in the register definitions are the address locations of the registersin the
same mode. When the 1/0O register file is actually used, the [BaseAddress] value is subtracted from the defined
register address and the resultant offset added to the relevant base address for the selected mode.

The [Register] definition entry is entered in the format <name> = <address> [<size> [<absolute>]].
1. <name> register name to be displayed.
2. <address> address of the register.
3. <size> which may be B, W or L for byte, word, or longword (default is byte).

4, <absolute> which can be set to A if the register is at an absolute address. Thisisonly relevant
if the 1/0 area address range moves about on the CPU in different modes. In this case, if a
register is defined as absol ute the base address offset calculation is not performed and the
specified addressis used directly.

Comment lines are dlowed and must start with a*“;” character.

An example is shown below.
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Example:

; H8S/2655 Series 1/0 Register Definitions File

[Modules]

BaseAddress=0

Module Modulel=Power_Down_Mode_Registers
definition Module2=DMA_Channel_Common

Module3=DMA_Channel_0

Comment

Module42=Bus_Controller
Module43=System_Control
Module44=Interrupt_Controller

[DMA_Channel_Common]
DMAWER=0xffff00 B A
DMATCR=0xffff01 B A
DMACROA=0x{fff02 B A
DMACROB=0x{fff03 B A
DMACR1A=0x{fff04 B A
DMACR1B=0x{fff05 B A
DMABCRH=0xffff06 B A
DMABCRL=0Xffff07 B A

Register
definition

[DMA_Channel_0]
MAROAH=0xfffeeO W A
MAROAL=0xfffee2 W A
I0OAROA=0xfffeed W A
ETCROA=0xfffee6 W A
MAROBH=0xfffee8 W A
MAROBL=0xfffeea W A
I0OAROB=0xfffeec W A

Register name
ETCROB=0xfffeee W A

Address
Size
Absolute address flag
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D.2 Fileformat (Bit Field Supported)

Each module name must be defined in the [M odules] definition section and the numbering of each module must
be sequential. Each module corresponds to a register definition section and within the section each entry defines
an |/O regiter.

The user must define “FileVersion=2" at the start of the section. It meansthat this 1/O register file is described
with the version that supports the bit field.

The [BaseAddress] definition isfor devices where the location of 1/0 registers moves in the address space
depending on the CPU mode. In this case, the [BaseAddress] value is the base address of the 1/0 registersin one
specific mode and the addresses used in the register definitions are the address locations of the registersin the
same mode. When the 1/0O register file is actually used, the [BaseAddress] value is subtracted from the defined
register address and the resultant offset added to the relevant base address for the selected mode.

Each module has a section that defines the registers forming it along with an optional dependency. The
dependency is checked to seeif the module is enabled or not. Each register name must be defined in the section
and the numbering of each register must be sequentia. The dependency is entered in the section as dep=<reg>
<bit> <value>.

1. <reg>istheregister id of the dependency.
2. <bit> isthe bit position within the register.
3. <vaue> isthe value that the bit must be for the module to be enabled.

The [Register] definition entry is entered in the format id=<name> <address> [<size>
[<absolute>[<format>[<bitfields>]1]].

1. <name> register name to be displayed.
2. <address> address of the register.
3. <size>which may be B, W or L for byte, word, or longword (default is byte).

4, <absolute> which can be set to A if the register is at an absolute address. Thisisonly relevant
if the 1/0 area address range moves about on the CPU in different modes. In this case, if a
register is defined as absol ute the base address offset calculation is not performed and the
specified addressis used directly.

5. <format> format for register output. Valid values are H for Hexadecimal, D for decimal, and
B for binary.

6. <bitfields> section defining the bits within the register.

Bitfield sections define the bits within aregister each entry is of the type bit<no>=<name>.
1. <no>isthebit number.
2. <name> isasymbolic name of the bit.

Comment lines are allowed and must start with a*“;” character.

An example is shown below.
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Example:
Comment ; H8S/2655 Series 1/0 Register Definitions File
[ [Modules]
FileVersion=2
BaseAddress=0
Modulel=Power_Down_Mode_Registers
Module2=DMA_Channel_Common
Module3=DMA_Channel_0
Module
Module42=Bus_Controller
Module43=System_Control
Module44=Interrupt_Controller

[DMA_Channel_Common]

reg0=regDMAWER

regl=regDMATCR

quglfe reg2=regDMACROA

_ definition | reg3=regDMACROB
reg4=regDMACR1A
reg5=regDMACR1B
reg6=regDMABCRH
reg7=regDMABCRL

L dep=regMSTPCRH 7 0

Register name

Bit

Value

Register [regDMAWER]

__definition id=DMAWER 0xffff00 B A H dmawer_bitfields

Register name |

Address

Size

Absolute address flag

Format

Bit field
[dmawer_bitfields]

Bit-field bit3=WE1B

definition bit2=WE1A
bit1=WEOB
bitO=WEOA
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Appendix E  Symbol File Format

To decode the symbol file correctly, the file must be formatted as a Pentica-B file:
1. Thefile must be aplain ASCII text file.
2. Thefile must start with the word “BEGIN”.

3. Each symbol must be on a separate line with the vaue firgt, in hexadecimal terminated by an
“H", followed by a space then the symbol text.

4. Thefile must end with theword “END”.
Example:

BEG N

11FAH Synbol _nane_1
11FCH Synbol _nane_2
11FEH Synbol _nane_3
1200H Synbol _nane_4
END
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Appendix F HMAKE User Guide

F.1 Command line

The following section describes the command line that should be used to execute the hmake program on afile
using none or more of the available options.

F.1.1  Bascstructure
The command line must be of the following syntax:

hmake <make file you wish to execute> <paraneter |ist>

If afileis specified without an extension then “.mak” will be appended to it. The parameter list may include
none or more of the parameterslisted in the following section. The parameters list may appear before the make
file nameif you wish. Each parameter must be separated by at least one white space character. Parameters are
not case sensitive. If no parameters are given and no fileis given then help information will be displayed.

F.1.2 Exit codes
If there are any syntax errorsin the make file being executed or if any process executed whilst running the make

file returns an invalid error code then hmake will exit with code 1. Otherwise hmake will exit with code 0 (See
below for file syntax and how to specify exit code conditions).

F.1.3 Parameters
The following table shows the avail able parameters and their function:

TableF.1; hmake's parametersand functions

Parameter Function

/A Execute all commands regardless of input/output file status. Equivalent to a Build All.

/N Use status of input/output files to calculate what commands need to be executed (as
normal) and then display the commands but do not execute them.

1? Display help info.
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F.2 File syntax

There are four basic types of statement used in a hmake file, the variable declaration the description block, the
comment and the message command. These can be combined in any order to produce a hmake file but avariable
must be declared in avariable declaration beforeit is used in a description block or other variable declaration.
Thefirst “al” statement used in nmake filesis not required in a hmake file. Commands are executed in order, as
they appear in the makefile.

Note: the* - character is used to show were atab character must be used in order to keep the make file
syntactically correct.

F.21 Variable declarations

A variable declaration declares a variable which can then be used in any statement throughout the rest of the
hmake file. A declaration has the following syntax:

<vari abl e name> = <val ue>

Any number of white space characters are allowed between the variable name and the ‘=’ sign and the value and
the ‘=" sign. The value may be split over several linesusing a“‘\' character. If the value contains ‘\' characters
within the main text then these are taken literally. Only ‘\’ characters followed by anew line are considered to
indicate a value wrapping over more than oneline.

There follows some examples of valid variable declarations:

EXECUTABLE = c:\dir\prog. exe
QUTPUT = c:\dir2\filel. out
INPUT = c:\dir2\filel.c
DEPEND = c:\dir2\file2.h \
c:\dir2\file3. h\
c:\dir2\filed.h

In order to use avariable later in the hmake file write the variable name with “$(” added to the front and “)”
added to the back. The variable name (along with the “$()” characters) will be substituted with the variables
value. For examples of this see later under description blocks. Only alphanumeric characters and underscore
characters are allowed in variable names. It is possible to use a variable inside the declaration of a different
variable but all variables must be declared before they are used.
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F.3 Description blocks

F.3.1 Basic outline

A description block specifies one or more targets, zero or more dependants and alist of commands which should
be executed if the newest dependent is newer than the newest target. If none of the targets exist and/or none of
the dependants exist then the commands will always be executed. It is not necessary to specify any dependants if
you wish the commands to always be executed. A description block has the following syntax:

<target1> <target2> ...: <dependant1> <dependant2> ..
- <commandl>
- <command2>
- <commandn>

Any number of white space characters are allowed between the last target and the *:’ character and the first
dependant and the ‘" character. No white space is allowed before the first target. Each target and each dependant
must be separated by at |east one white space character. A tab character must be present at the start of aline
containing a command. Variables may be used in a description block using the syntax specified above under
variable declarations.

There follows some examples of valid description blocks (one of which uses the variable specified above under
variable declarations):

c:\dirl\filel.obj : c:\dirl\filel.c c:\dir1\filel. h
- gcc c:\dirl\filel.c

$(OUTPUT) : $(I NPUT) $( DEPEND)

~  $(EXECUTABLE) $(I NPUT)

F.3.2 Special commands

There are two special commands which can be used in a description block. The "cd" command changes the
current directory and the "set" command sets an environment variable which will then be in use for the duration
of the make file execution. Both are used in the same way as the DOS equivalents.

There follows some examples of valid description blocks which use these commands:

CHANGEDI R :

- cd c:\dirl\dir2
SETENV:

- set VARl=val uel
- set VAR2=val ue2
- set VAR3=val ue3

It does not matter that CHANGEDIR and SETENV are not file names. They will be treated asfiles that do not
exist and so the commands will always be executed.
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F.3.3 Sub command files

If you wish hmake to generate a sub command file for you then the command part of the description block
should be specified as follows (this replaces <commandn> above):

- <command start> <<

- <sub commandl>,

- <sub command2>,

- <sub commandn>

<<<command end>
Thiswill generate a sub command file, in the windows temporary directory, which will contain the lines <sub
commandl>, <sub command2> etc. This command file will be deleted once the make process has compl eted.

The name of the command file will be substituted for all the text between the two “<<"’s. You do not have to
worry about the name of the sub command file. Thisis generated by hmake.

For example:

c:\dirl\filel.obj : c:\dirl\filel.c c:\dir1\filel.h

- gcc @<<
- -c -oc:\dirl\filel.obj c:\dirl\filel.c
<<”

If the sub command file generated has the name “ c:\temp\hmk111.cmd” then the following would be executed
by hmake (assuming c:\dir1\filel.obj is out of date):

gcc @c:\tenp\ hnk111l. cnd”
The command file (c:\temp\hmk111.cmd) would contain:

-c -o c:\dirl\filel.obj c:\dirl\filel.c

It is possible to include more than one command in the description block and to use combinations of the standard,
and sub command file commands.
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F.4 Comments

A ‘# character signifiesacomment. When this character appears as the first character on aline the rest of the
line (up until the next new line character) isignored. There follows examples of valid comments:

# My hnake file

# Vari abl e decl aration

QUTPUT= c:\dir1\filel. obj

# Descri ptor

$(QUTPUT) : c:\dirl\filel.c c:\dirl\filel.h
- set VARl=val uel

- gcc c:\dirl\filel.c

A comment must occupy its own line in the hmake file. It is not possible to put comments on the end of other
statements.

F.5 M essage commands

The message command is used to output a line of text to standard out whilst amake file is executing. These text
lines will be output in the order they appear in the make file, in amongst output from any executables being
executed as appropriate. No buffering of output text will take place. A message command has the following
syntax:

| MESSAGE <text to output>

A new line character is assumed to come after the last character in <text to output>. Any white space
between 'MESSAGE and <text to output> will be ignored. There follows an example of avalid message
command:

| MESSAGE Executing C Conpil er
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Appendix G Menus

Table G.1 shows GUI menus.

TableG.1 GUI Menus

Toolbar
Menu Option Shortcut  Button Remarks
View Disassembly Ctrl + D Opens the [Disassembly]
window.
Command Line Ctrl + L Opens the [Command Line]
window.
TCL toolkit Shift + ) Opens the [Console] window.
Curl+L o
Workspace Alt + K Opens the [Workspace]
window.
Output Alt+U Opens the [Output] window.
Difference Opens the [Difference]
window.
CPU Registers Ctrl + R Opens the [Registers] window.
Memory... Ctrl + M Opens the [Memory] window.
10 Ctrl + 1 Opens the [I0] window.
Status Ctrl+ U Opens the [Status] window.
Extended Monitor Opens the [Extended Monitor]
= window.
Monitor  Monitor Shift + Opens the [Monitor] window.
Setting... Ctrl+E
Windows Opens the [Windows Select]
Select... dialog box to list, add, or edit
the [Monitor] window.
Sym-  Labels Shift + Opens the [Labels] window.
bol Ctrl + A
Watch Ctrl + W Opens the [Watch] window.
Locals Shift + Opens the [Locals] window.
Ctrl + W
Code  Eventpoints Ctrl+ E Opens the [Eventpoints]
window.
Trace Ctrl+T Opens the [Trace] window.
Stack Trace Ctrl + K Opens the [Stack Trace]
window.
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TableG.1 GUI Menus (cont)

Menu

Option

Toolbar
Shortcut  Button

Remarks

View
(cont)

Gra- Image...
phic

Shift + E
Ctrl+ G

Opens the [Image] window.

Waveform...

Shift +
Ctrl +V

Opens the [Waveform]
window.

Per- Performance
form-  Analysis
ance

Shift +
Ctrl + P

Opens the [Performance
Analysis] window.

Options

Debug Sessions...

Opens the [Debug Sessions]
dialog box to list, add, or
remove the debug session.

Debug Settings...

Opens the [Debug Settings]
dialog box to set the
debugging conditions or
download modules.

Radix  Hexadecimal

Uses a hexadecimal for
displaying a radix in which the
numerical values will be
displayed and entered by
default.

Decimal

&

Uses a decimal for displaying
a radix in which the numerical
values will be displayed and
entered by default.

Octal

Uses an octal for displaying a
radix in which the numerical
values will be displayed and
entered by default.

Binary

Uses a binary for displaying a
radix in which the numerical
values will be displayed and
entered by default.

Emu-  System...
lator

E

Opens the [Configuration]
dialog box allowing the user to
modify the debugging platform
settings.

Memory
Resource...

Opens the [Memory Mapping]
dialog box allowing the user to
view and edit the debugging
platform's current memory
map.
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TableG.1 GUI Menus (cont)

Menu Option

Toolbar
Shortcut  Button

Remarks

Debug Reset CPU

Resets the target hardware and
sets the PC to the reset vector
address.

Go Starts executing the user
program at the current PC.
Reset Go Resets the target hardware and

executes the user program from
the reset vector address.

Go To Cursor

Starts executing the user
program at the current PC until
the PC reaches the address
indicated by the current text
cursor position.

Set PC To Cursor

Sets the PC to the address at
the row of the text cursor.

Run...

Launches the [Run Program]
dialog box allowing the user to
enter the PC or PC breakpoint
during executing the user
program.

Display PC

Opens the Editor or
Disassembly window at the
address of the PC.

Step In

Executes a block of user
program before breaking.

Step Over

Executes a block of user
program before breaking. If a
subroutine call is reached, then
the subroutine will not be
entered.

Step Out

Shift +
F11

Executes the user program to
reach the end of the current
function.

Step...

Launches the [Step Program]
dialog box allowing the user to
modify the settings for stepping.

Step Auto
Mode

Steps only one source line when
the [Source] window is active.
When the [Disassembly] window
is active, stepping is executed in
a unit of assembly instructions.

Assembly

Executes stepping in a unit of
assembly instructions.

Source

Steps only one source line.

RENESAS

463



TableG.1 GUI Menus (cont)

Toolbar
Menu Option Shortcut  Button Remarks
Debug Halt Program Esc Stops the execution of the user
(cont) program.
Connect Connects the debugging
= platform.

Initialize Disconnects the debugging
platform and connects it again.

Disconnect Disconnects the debugging
platform.

Download Modules Downloads the object program.

Unload Modules Unloads the object program.

Memory  Search... Searches for the specified value
from the specified memory area.

Copy... Copies the specified memory
area to the specified address.

Compare... Compares the specified two
memory areas.

Fill... Fills the specified value in the

specified memory area.

Test... Tests the specified memory

area.

Refresh Forces a manual update of the
contents of all the [Memory]
windows open.

Configure Overlay... Selects the target section group
when the overlay function is
used.
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Appendix H Command Lines

TableH.1 liststhe HEW commands.

TableH.1 HEW Commands

No. Command Name

Abbreviation Function

1 ! - Comment

2 ADD_FILE AF Adds a file to the current project

3  ANALYSIS AN Enables or disables performance analysis

4 ANALYSIS_RANGE AR Sets or displays a performance analysis range

5 ANALYSIS_RANGE_ AD Deletes a performance analysis range
DELETE

6 AUTO_COMPLETE AC Enables or disables command complement function

7  ASSEMBLE AS Assembles instructions into memory

8 ASSERT - Checks if an expression is true or false

9 BREAKPOINT BP Sets a breakpoint at an instruction address

10 BREAKPOINT_CLEAR BC Deletes breakpoints

11 BREAKPOINT_ BD Displays a list of breakpoints
DISPLAY

12 BREAKPOINT_ENABLE BE Enables or disables a breakpoint

13 BREAKPOINT_ BS Sets sequential breakpoints
SEQUENCE

14 BUILD BU Starts a build operation on the current project

15 BUILD_ALL BL Starts a build all operation on the current project

16 CHANGE_ CcC Sets the current configuration
CONFIGURATION

17 CHANGE_PROJECT CP Sets the current project

18 CHANGE_SESSION CS Changes the session of the current project

19 CLOCK CK Set the CPU clock rate in the emulator

20 CONFIGURE_ CPF Sets the debugging environment for the emulator
PLATFORM

21 DEFAULT_OBJECT_ DO Sets the default object (program) format
FORMAT

22 DEVICE_TYPE DE Selects a device type to emulate

23 DISASSEMBLE DA Disassembles memory contents

24 ERASE ER Clears the [Command Line] window

25 EVALUATE EV Evaluates an expression

26 EXMONITOR_DISPLAY EXMD Displays the content of the expansion monitor

27 EXMONITOR_SET EXMS Selects whether or not to display the items in the

expansion monitor

28 EXMONITOR_ EXMSR Sets the time to update the expansion monitor during
SETRATE emulation or a break

29 FILE_LOAD FL Loads an object (program) file

30 FILE_SAVE FS Saves memory to a file

31 FILE_UNLOAD FU Unloads a file

32 FILE_VERIFY FV Verifies file contents against memory
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TableH.1 HEW Commands (cont)

No. Command Name Abbreviation Function
33 GENERATE_MAKE_ GM Creates a makefile to be built outside the HEW
FILE

34 GO GO Executes user program

35 GO_RESET GR Executes user program from reset vector

36 GO_TILL GT Executes user program until temporary breakpoint

37 HALT HA Halts the user program

38 HELP HE Displays the syntax of a command

39 INITIALIZE IN Initializes the debugging platform

40 LOG LO Controls command output logging

41 MAP_DISPLAY MA Displays memory mapping

42 MAP_SET MS Sets memory mapping

43 MEMORY_COMPARE MC Compares memory contents

44 MEMORY_DISPLAY MD Displays memory contents

45 MEMORY_EDIT ME Modifies memory contents

46 MEMORY_FILL MF Modifies the content of a memory area by specifying
data

47 MEMORY_FIND M Searches for data within the memory range

48 MEMORY_MOVE MV Moves a block of memory

49 MEMORY_TEST MT Tests a block of memory

50 MODE MO Sets or displays the CPU mode

51 MODULES MU Sets up or displays the on-chip peripheral functions

52 MONITOR_CLEAR MOC Deletes a monitor point

53 MONITOR_DISPLAY MOD Displays the content of the monitor

54 MONITOR_REFRESH MOR Controls an automatic update of the content of the
monitor

55 MONITOR_SET MOS Sets or displays a monitor point

56 OPEN_WORKSPACE OW Opens a workspace

57 QUIT QU Exits HEW

58 RADIX RA Sets default input radix

59 REFRESH RF Updates windows related to memory

60 REGISTER_DISPLAY RD Displays CPU register values

61 REGISTER_SET RS Sets CPU register contents

62 RESET RE Resets CPU

63 REMOVE_FILE REM Deletes the specified file from the current project

64 SLEEP - Delays command execution

65 SAVE_SESSION SE Saves the session of the current project

66 STEP ST Steps program (by instructions or source lines)

67 STEP_MODE SM Sets the step mode

68 STEP_OUT SP Steps out of the current function

69 STEP_OVER SO Steps program, not stepping into functions

70 STEP_RATE SR Sets or displays rate of stepping
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TableH.1 HEW Commands (cont)

No. Command Name Abbreviation Function

71 SUBMIT SuU Executes a command file

72 SYMBOL_ADD SA Defines a symbol

73 SYMBOL_CLEAR SC Deletes a symbol

74 SYMBOL_LOAD SL Loads a symbol information file

75 SYMBOL_SAVE SS Saves a symbol information file

76 SYMBOL_VIEW SV Displays symbols

77 TCL - Enables or disables the TCL

78 TIMER TI Sets or displays the timer resolution

79 TOOL_INFORMATION TO The information on the tool registered is outputted by
the file

80 TRACE TR Displays trace information

81 TRACE_ACQUISITION TA Sets or displays trace acquisition parameters

82 TRACE_BINARY_ TBC Compares a trace binary file with the current trace
COMPARE information

83 TRACE_BINARY_SAVE TBV Outputs trace information into a binary file

84 TRACE_FILTER TF Filter the trace information

85 TRACE_STATISTIC TST Analyzes statistic information

86 TRIGGER_CLEAR TGC Deletes the trigger output condition for EXT.2

87 TRIGGER_DISPLAY TGD Displays the trigger output condition for EXT.2

88 TRIGGER_SET TGS Sets the trigger output condition for EXT.2

89 UPDATE_ALL_ ub Updates the dependencies for the current project
DEPENDENCIES

90 USER_SIGNALS us Enables or disables the user signal information

For the syntax of each command, refer to the online help.
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Appendix | Diagnostic Test Procedure
This section describes the diagnostic test procedure using the E6000 test program.

1.1 System Set-Up for Test Program Execution

To execute the test program, use the following hardware; do not connect the user system interface cable, user
system, or expansion |/O board.

For the H8/300 series E6000 emulator :
» E6000 emulator (HS3008EPI60H)

» HB8/300 series evaluation chip set which is one of the followings:
H8/300 group evaluation chip set (HS3308EV160H)
H8/350 group evaluation chip set (HS3508EV160H)
H8/338, H8/329 group eva uation chip set (HS3398EV160H)
H8/3334 group evaluation chip set (HS3334EVI160H)
H8/3257, H8/325 group evaluation chip set (HS3257EV160H)
H8/3437, H8/3337Y, H8/3297 group evaluation chip set (HS3437EVI60H)
H8/3217, H8/3318 group evaluation chip set (HS3318EVI60H)

For the H8/300L series E6000 emulator:
» E6000 emulator (HS3LO8EPI60H)

e HB8/300L series evaluation chip set which is one of the followings:
H8/3834, H8/3814 group evaluation chip set (HS3834EVI60H)
H8/3637, H8/3877 group evaluation chip set (HS3876EV I60H)
H8/3927 group evaluation chip set (HS3927EV160H)

For the H8/3664 E6000 emulator:
» E6000 emulator (HS3664EPI60H)

Hardwarerequired for each emulator:

e Host computer

*  The E6000 PC interface board (select either from the followings according to the PC interface
specifications):
PCI businterface board (HS6000EICO1H or HS6000EI CO2H)
PCMCIA interface card (HS6000EIPO1H)

1. Install the E6000 PC interface board in the host computer and connect the supplied PC interface cable to the
board.

2. To usethe H8/300 series E6000 emulator or the H8/300L series E6000 emulator, install an evaluation chip in
the emulator.

Connect the PC interface cable to the emul ator.

Connect the supplied AC adapter to the emulator.

Initiate the host computer to make it enter DOS prompt command input wait state.
Turn on the emulator power switch.

o 0k~ w
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1.2 Diagnostic Test Procedure Using Test Program

Insert the CD-R (HS3008EPI60SR supplied with the emulator) into the CD-ROM drive of the host computer
move the current directory to one of those listed below with a command prompt.

HS3308EV160H: <Drive>:\Diag\HS3308EV |60H
HS3508EV160H: <Drive>:\Diag\HS3508EV |60H
HS3398EVI60H: <Drive>:\Diag\HS3398EV160H
HS3334EV160H: <Drive>:\Diag\HS3334EV |60H
HS3257EV160H: <Drive>:\Diag\HS3257EV |60H
HS3437EV160H: <Drive>:\Diag\HS3437EV160H
HS3318EV160H: <Drive>:\Diag\HS3318EV I60H
HS3834EV160H: <Drive>:\Diag\HS3834EV |60H
HS3876EV160H: <Drive>:\Diag\HS3876EV160H
HS3927EV160H: <Drive>:\Diag\HS3927EV |60H
HS3644EPI60H: <Drive>:\Diag\HS3644EPI60H

Enter one of the following commands according to the PC interface board in use to initiate the test program:

1. PCI businterface board (HS6000EICO1H or HSG6000EICO2H)
HS3308EV160H: > TM330 —PCI (RET)
HS3508EV160H: > TM350 —PCI (RET)
HS3398EVI60H: > TM339 —PCI (RET)
HS3334EVI160H: > TM3334 —PCl (RET)
HS3257EVI60H: > TM3257 —PCI (RET)
HS3437EVI60H: > TM3437 —PCI (RET)
HS3318EVI60H: > TM3318 —PCl (RET)
HS3834EV160H: > TM3834 —PCl (RET)
HS3876EVI60H: > TM3876 —PCI (RET)
HS3927EVI60H: > TM3927 —PCI (RET)
HS3644EPI60H: > TM 3644 —PCl (RET)

2. PCMCIA interface card (HS6000EIPO1H)
HS3308EV160H: > TM330 —PCCD (RET)
HS3508EV160H: > TM350 -PCCD (RET)
HS3398EV160H: > TM339 —PCCD (RET)
HS3334EV160H: > TM3334 —PCCD (RET)
HS3257EVI60H: > TM3257 -PCCD (RET)
HS3437EV160H: > TM3437 —-PCCD (RET)
HS3318EVI60H: > TM3318 —-PCCD (RET)
HS3834EVI60H: > TM3834 —-PCCD (RET)
HS3876EV160H: > TM3876 —PCCD (RET)
HS3927EV160H: > TM3927 —-PCCD (RET)
HS3644EPI60H: > TM3644 —PCCD (RET)

The HEW must be installed before the test program is executed.

Be sureto initiate the test program from <Drive>:\Diag\HS3437EVI60H. Do not initiate it from adirectory
other than <Drive>:\Diag\HS3437EV160H, such as > <Drive>:\Diag\HS3437EV|60H\TM 3437 —PCI (RET). If
the test program is initiated when the current directory is not <Drive>:\Diag\HS3437EV60H, the test program
will not operate correctly.

Notes: 1. <Drive>isadrive name for the CD-ROM drive.
2. Do not remove the CD-R from the CD-ROM drive during test program execution.
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The following messages are displayed during the test. This example assumes that the HS3437EVI60H isin use.
M essage Description

E6000 HB8/ 300 EMULATI ON BOARD Tests Vx. X Test program start
message. X.Xx shows the
ver si on nunber.

Searching for interface card ........... ..., XK Shows that the PC
interface board is
correctly installed in
the host conputer.

Checking enulator is connected .................cvouinon.. XK Shows that the E6000 is
correctly connected to
the host conputer.

Enul ator Board | nformation: Shows the | D nunber of
Mai n Board | D H1 the | ower board of the
E6000 (al ways 1).

Enul ation Board ID H 1 Shows the | D nunber of
the upper board of the
E6000 (al ways 1).

Revi si on H x Shows the revision
nunber of the upper
board of the E6000.

Downl oading firmware ........ Loadi ng the test
program

01) Testing Register : Shows the check results
IDR RegiSter .........coovuiiniinn.. K for the registers in the
BOC control register ............... K E6000 (nor nal
MODER regi Ster ...........c.oouuuunn.. oK conpl etion).

02) Testing Dual -Port RAM : Shows the results of
Decode Test .........ouiiiiiiinin... [0 decodi ng test and
Marching Test ...................... oK marching test for the

dual -port RAMin the
E6000 (nor nal
conpl etion).

03) Testing Firmware RAM : Shows the results of
Decode Test. page H 7xx of range H 700 - H 71f ... decoding test for the
Decode Test. page range H 700 - H 71f .......... XK firmmare RAM in the

E6000 (nor nal
conpl etion).

Mar ching Test. page H 7xx of range H 700 - H 71f ... Shows the results of
Mar ching Test. page range H 700 - H 71f .......... XK marching test for the
firmare RAMin the
E6000 (nor nal
conpl etion).
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Downl oading firmware ........

04) Testing Trace RAM:
Decode Test. page H Oxx of range H 000
Decode Test. page range H 000 - H 04f

Marching Test. page H Oxx of range H 000
Mar ching Test. page range H 000 - H 04f

05) Testing Mappi ng RAM :
Decode Test. page H 2xx of range H 200
Decode Test. page range H 200 - H 21f

Marching Test. page H 2xx of range H 200
Marching Test. page range H 200 - H 21f

06) Testing Enul ation RAM :
Decode Test ..................co.... K
Marching Test ...................... XK

07) Testing STEP Operation :

Mbde 1. Single Step Operation ...... (03¢
Mbde 1. Step Into Operation ........ XK
Mbde 2. Single Step Operation ...... XK
Mbde 2. Step Into Operation ........ (03¢

08) Testing Key Break :
Key Break .......................... (03¢

09) Testing Enul ati on RAM Hardware Break :
GRD Break ..........c.oiiiiiiiiiiiinn. K
WPT Break ................ .. K
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Loadi ng the test
program

Shows the results of
decoding test for the
trace RAMin the E6000
(normal conpl etion)

Shows the results of
marching test for the
trace RAMin the E6000
(normal conpl etion)

Shows the results of
decoding test for the
mappi ng RAMin the E6000
(normal conpl etion).

Shows the results of
marching test for the
mappi ng RAMin the E6000
(normal conpl etion)

Shows the results of
decodi ng test and

mar ching test for

emul ation nmenory in the
E6000 (norna

conpl etion).

Shows the check results
for the step execution
controlling circuits in
the E6000 (normal

conpl etion).

Shows the check results
for the forced break
controlling circuits in
the E6000 (normal

conpl etion).

Shows the check results
for the illegal access
break controlling
circuits in the E6000
(normal conpl etion).



10) Internal ROM Wite-Protect : Shows the check results
Wite-Protect ...................... K for the internal ROM
write-protection
controlling circuits in
the E6000 (normal
conpl etion).

11) Testing Double Stack, I/0O Stack Test : Loadi ng the test
Setting up, please wait.. program
Double Stack ....................... K Shows the check results
1/O0Stack ... XK for the stack

controlling circuits in
the E6000 (normal
conpl etion).

0 total errors Total nunber of errors.

Tests passed, enulator functioning correctly Shows that the E6000 is
correctly operating.

When detecting an error, the test program displays ERROR and stops execution. In such cases, the emulator
hardware may be malfunctioning. Inform a Renesas sa es office of the test resultsin detail.

473
RENESAS



474
RENESAS



Renesas Microcomputer Development Environment System

User's Manual
H8/300 and 300L E6000 Emulator

Publication Date: Rev.1.00, October 13, 2004

Published by: Sales Strategic Planning Div.
Renesas Technology Corp.

Edited by: Technical Documentation & Information Department
Renesas Kodaira Semiconductor Co., Ltd.

[J 2004. Renesas Technology Corp., All rights reserved. Printed in Japan.



RenesaSTeChnOIOgy Corp. Sales Strategic Planning Div. Nippon Bldg., 2-6-2, Ohte-machi, Chiyoda-ku, Tokyo 100-0004, Japan

LENESANS
RENESAS SALES OFFICES

http://www.renesas.com

Refer to "http://www.renesas.com/en/network" for the latest and detailed information.

Renesas Technology America, Inc.
450 Holger Way, San Jose, CA 95134-1368, U.S.A
Tel: <1> (408) 382-7500, Fax: <1> (408) 382-7501

Renesas Technology Europe Limited
Dukes Meadow, Millboard Road, Bourne End, Buckinghamshire, SL8 5FH, U.K.
Tel: <44> (1628) 585-100, Fax: <44> (1628) 585-900

Renesas Technology Hong Kong Ltd.
7th Floor, North Tower, World Finance Centre, Harbour City, 1 Canton Road, Tsimshatsui, Kowloon, Hong Kong
Tel: <852> 2265-6688, Fax: <852> 2730-6071

Renesas Technology Taiwan Co., Ltd.
10th Floor, No.99, Fushing North Road, Taipei, Taiwan
Tel: <886> (2) 2715-2888, Fax: <886> (2) 2713-2999

Renesas Technology (Shanghai) Co., Ltd.
Unit2607 Ruijing Building, No.205 Maoming Road (S), Shanghai 200020, China
Tel: <86> (21) 6472-1001, Fax: <86> (21) 6415-2952

Renesas Technology Singapore Pte. Ltd.
1 Harbour Front Avenue, #06-10, Keppel Bay Tower, Singapore 098632
Tel: <65> 6213-0200, Fax: <65> 6278-8001

Colophon 2.0



H8/300 and 300L E6000 Emulator
User’s Manual

LENESAS

Renesas Electronics Corporation
1758, Shimonumabe, Nakahara-ku, Kawasaki-shi, Kanagawa 211-8668 Japan REJ10B0155-0100H



	Cover
	Keep safety first in your circuit designs!
	Notes regarding these materials
	IMPORTANT INFORMATION
	SAFETY PAGE
	Introduction
	About This Manual
	Contents
	HEW Part
	1.	Overview
	1.1	Workspaces, Projects and Files
	1.2	The Main Window
	1.2.1	The Title Bar
	1.2.2	The Menu Bar
	1.2.3	The Toolbars
	1.2.4	The Workspace Window
	1.2.5 The Editor Window
	1.2.6	The Output Window
	1.2.7	The Status Bar

	1.3	The Help System
	1.4	Launching the HEW
	1.5	Exiting the HEW
	1.6	Component System Overview

	2. Build Basics
	2.1	The Build Process
	2.2	Project Files
	2.2.1	Adding Files to a Project
	2.2.2	Removing Files from a Project
	2.2.3	Excluding a Project File from Build
	2.2.4	Including a Project File in Build

	2.3	File Extensions and File Groups
	2.4	Specifying How to Build a File
	2.5	Build Configurations
	2.5.1	Selecting a Configuration
	2.5.2	Adding and Deleting Configurations

	2.6	Building a Project
	2.6.1	Building a Project
	2.6.2	Building Individual Files
	2.6.3	Stopping a Build
	2.6.4	Building Multiple Projects
	2.6.5	The Output Window
	2.6.6	Controlling the Content of the Output Window
	2.6.7	Displaying out of date files in the workspace window

	2.7	File Dependencies
	2.8	Configuring the Workspace Window
	2.8.1	Show Dependencies under Each File
	2.8.2	Show Standard Library Includes
	2.8.3	Show File Paths
	2.8.4	Sort files by time order

	2.9	Setting the Current Project
	2.10	Inserting a Project into a Workspace
	2.11	Specifying Dependencies between Projects
	2.12	Removing a Project from a Workspace
	2.13	Loading/unloading a Project into/from a Workspace
	2.14	Relative projects paths in the workspace
	2.15	User folders in the workspace

	3.	Advanced Build Features
	3.1	The Build Process Revisited
	3.1.1	What is a Build?

	3.2	Creating a Custom Build Phase
	3.3	Ordering Build Phases
	3.3.1	Build Phase Order
	3.3.2	Build File Phase Order

	3.4	Setting Custom Build Phase Options
	3.4.1	Options Tab
	3.4.2	Output Files Tab
	3.4.3	Dependent Files Tab

	3.5	File Mappings
	3.6	Controlling the Build
	3.7	Logging Build Output
	3.8	Changing Toolchain Version
	3.9	Using an External Debugger
	3.10	Generating a Makefile
	3.11	Using a makefile inside the HEW system
	3.12	Customizing the HEW linkage order

	4.	Using the Editor
	4.1	The Editor Window
	4.2	Working with Multiple Files
	4.2.1	The Editor Toolbars
	4.2.2	Editor Toolbar Buttons
	4.2.3	Search Toolbar Buttons
	4.2.4	Bookmarks Toolbar Buttons
	4.2.5	Templates Toolbar Buttons

	4.3	Standard File Operations
	4.3.1	Creating a New File
	4.3.2	Saving a File
	4.3.3	Saving all Files
	4.3.4	Opening a File
	4.3.5	Closing Files

	4.4	Editing a File
	4.5	Searching and Navigating through Files
	4.5.1	Finding Text
	4.5.2	Finding Text in Multiple Files
	4.5.3	Replacing Text
	4.5.4	Jumping to a Specified Line

	4.6	Bookmarks
	4.7	Printing a File
	4.8	Configuring Text Layout
	4.8.1	Page Set-up
	4.8.2	Changing Tabs
	4.8.3	Auto Indentation

	4.9	Splitting a Window
	4.10	Configuring Text
	4.10.1	Changing the Editor Font

	4.11	Syntax Coloring
	4.12	Templates
	4.12.1	Defining a Template
	4.12.2	Deleting a Template
	4.12.3	Inserting a Template
	4.12.4	Brace Matching.

	4.13 	Editor Column management
	4.14 	Enable tooltip watch

	5.	Tools Administration
	5.1	Tool Locations
	5.2	HEW Registration Files (*.HRF)
	5.3	Registering Components
	5.3.1	Searching Drives for Components
	5.3.2	Registering a Single Component

	5.4	Unregistering Components
	5.5	Viewing and Editing Component Properties
	5.6	Uninstalling Components
	5.7	Technical Support Issues
	5.8 On-Demand components
	5.9	Custom Project Types

	6.	Customizing the Environment
	6.1	Customizing the Toolbar
	6.2	Customizing the Tools Menu
	6.3	Configuring the Help System
	6.4	Specifying Workspace Options
	6.4.1	Open last workspace at start-up
	6.4.2	Restore the files on opening workspace
	6.4.3	Display workspace information dialog on opening workspace
	6.4.4	Save workspace before executing any tools
	6.4.5	Prompt before saving workspace
	6.4.6	Prompt before saving session
	6.4.7	Save auto-recovery info
	6.4.8	Default directory for new workspaces

	6.5	Using an External Editor
	6.6	Customizing File Save
	6.6.1	Save files before executing any tools
	6.6.2	Prompt before saving files

	6.7	Using Custom Placeholders
	6.8	Using the workspace and project log facilities
	6.9	Using the virtual desktop

	7.	Version Control
	7.1	Selecting a Version Control System

	8.	Using the Custom Version Control System
	8.1	Defining Version Control Menu Options
	8.1.1	System menu options and toolbar buttons
	8.1.2	User menu options

	8.2	Defining Version Control Commands
	8.2.1	Executable return code

	8.3	Specifying Arguments
	8.3.1	Specifying File Locations
	8.3.2	Specifying Environment
	8.3.3	Specifying Comments
	8.3.4	Specifying a User Name and Password

	8.4	Controlling Execution
	8.4.1	Prompt before executing command
	8.4.2	Run in DOS Window
	8.4.3	Use forward slash ‘/’ as version control directory delimiter

	8.5	Importing and exporting a Set-up

	9.	Using Visual SourceSafe
	9.1	Attaching Visual SourceSafe to a Workspace
	9.1.1	Selecting Visual SourceSafe
	9.1.2	Adding files to Visual SourceSafe

	9.2	Visual SourceSafe commands
	9.2.1	Removing a File from Version Control
	9.2.2	Getting a Read Only Copy of a File from Version Control
	9.2.3	Checking Out a Writable Copy of a File from Version Control
	9.2.4	Checking In a Writable Copy of a File into Version Control
	9.2.5	Undoing a Check Out Operation
	9.2.6	Viewing the Status of a File
	9.2.7	Viewing the History of a File

	9.3	Visual SourceSafe Integration Options

	10.	Network Facilities
	10.1	Overview
	10.1.1	Enabling network access
	10.1.2	Setting the administrator user’s password
	10.1.3 Adding new users to the system
	10.1.4 Changing your password
	10.1.5 Using the network HEW service


	11.	Difference View
	12.	Technical Support
	13.	Navigation facilities
	13.1	C++ Navigation component
	13.2	C Function and #defines navigation components

	14.	Smart Editor

	Emulator Debugger Part
	Section 1   Overview
	1.1	Features
	1.2	Warnings
	1.3	Environmental Conditions
	1.4	Emulator External Dimensions and Mass

	Section 2   Preparation before Use
	2.1	Emulator Preparation
	2.2	Installing Emulator’s Software
	2.3	Connecting to the User System
	2.3.1	Example of Connecting the User System Interface Cable Head to the User System
	2.3.2	Plugging the User System Interface Cable Body into the Emulator
	2.3.3	Plugging the User System Interface Cable Body into the Cable Head

	2.4	Power Supply
	2.4.1	AC Adapter
	2.4.2	Polarity
	2.4.3	Power Supply Monitor Circuit

	2.5	Hardware Interface
	2.5.1	Signal Protection on the emulator
	2.5.2	User System Interface Circuits
	2.5.3	Clock Oscillator
	2.5.4	External Probe/Trigger Output
	2.5.5 Voltage Follower Circuit

	2.6 System Check
	2.7	Communication Problems
	2.8	Other Methods for Activating the Emulator
	2.9	Uninstalling the Emulator’s Software

	Section 3   E6000 Emulator Functions
	3.1	Debugging Features
	3.1.1	Breakpoints
	3.1.2	Trace
	3.1.3	Execution Time Measurements
	3.1.4	Performance Analysis
	3.1.5	Bus Monitoring

	3.2	Complex Event System (CES)
	3.2.1	Event Channels
	3.2.2	Range Channels
	3.2.3	Breaks
	3.2.4	Timing

	3.3	Hardware Features
	3.3.1	Memory
	3.3.2	Clocks
	3.3.3	Probes

	3.4 Stack Trace Function
	3.5 Online Help

	Section 4   Preparation before Use
	4.1	Workspaces, Projects, and Files
	4.2 Method for Activating HEW
	4.2.1	Creating a New Workspace (Toolchain Not Used)
	4.2.2 Creating a New Workspace (Toolchain Used)
	4.2.3 Selecting an Existing Workspace

	4.3	Setting at Emulator Activation
	4.4	Debug Sessions
	4.4.1	Selecting a Session
	4.4.2	Adding and Removing Sessions
	4.4.3	Saving Session Information

	4.5 Connecting the Emulator
	4.6 Reconnecting the Emulator
	4.7 Ending the Emulator

	Section 5   Debugging
	5.1	Setting the Environment for Emulation
	5.1.1	Opening the [Configuration Properties] Dialog Box
	5.1.2	Selecting an MCU Not Included in the List
	5.1.3	Selecting the Interface to be Connected
	5.1.4	Opening the [Memory Mapping] Dialog Box
	5.1.5	Changing the Memory Map Setting

	5.2 Downloading a Program
	5.2.1	Downloading a Program
	5.2.2	Viewing the Source Code
	5.2.3	Viewing the Assembly-Language Code
	5.2.4	Modifying the Assembly-Language Code
	5.2.5	Viewing a Specific Address
	5.2.6	Viewing the Current Program Counter Address

	5.3	Debugging with the Command Line Interface
	5.3.1	Opening the [Command Line] Window
	5.3.2	Specifying a Command File
	5.3.3	Executing a Command File
	5.3.4	Stopping Command Execution
	5.3.5	Specifying a Log File
	5.3.6	Starting or Stopping Logging
	5.3.7	Entering a Full Path to the File
	5.3.8	Pasting a Placeholder

	5.4	Viewing the Registers
	5.4.1	Opening the [Register] Window
	5.4.2	Expanding a Bit Register
	5.4.3	Choosing a Register to be Displayed
	5.4.4	Splitting Up the Window Display
	5.4.5	Modifying Register Contents
	5.4.6	Using Register Contents
	5.4.7	Saving the Currently Displayed Contents

	5.5	Operating Memory
	5.5.1	Viewing a Memory Area
	5.5.2	Displaying Data in Different Formats
	5.5.3	Splitting Up the Window Display
	5.5.4	Viewing a Different Memory Area
	5.5.5	Modifying the Memory Contents
	5.5.6	Selecting a Memory Range
	5.5.7	Finding a Value in Memory
	5.5.8	Filling a Memory Area with a Value
	5.5.9	Copying a Memory Area
	5.5.10	Saving and Verifying a Memory Area
	5.5.11	Disabling Update of the Window Contents
	5.5.12	Updating the Window Contents
	5.5.13	Comparing the Memory Contents
	5.5.14	Loading a Memory Area from a File

	5.6	Viewing the I/O Memory
	5.6.1	Opening the [IO] Window
	5.6.2	Expanding the I/O Register Display
	5.6.3	Manually loading an IO file
	5.6.4	Modifying the I/O Register Contents
	5.6.5	Saving the Currently Displayed Contents

	5.7	Viewing the Current Status
	5.8	Reading and Displaying the Emulator Information Regularly
	5.8.1	Opening the [Extended Monitor] Window
	5.8.2	Selecting Items to be Displayed

	5.9	Displaying Memory Contents in Realtime
	5.9.1	Opening the [Monitor] Window
	5.9.2	Changing the Monitor Settings
	5.9.3	Temporarily Stopping Update of the Monitor
	5.9.4	Deleting the Monitor Settings
	5.9.5	Monitoring Variables
	5.9.6	Hiding the [Monitor] Window
	5.9.7	Managing the [Monitor] Window

	5.10	Viewing the Labels
	5.10.1	Listing Labels
	5.10.2	Adding a Label
	5.10.3	Editing a Label
	5.10.4	Deleting a Label
	5.10.5	Deleting All Labels
	5.10.6	Loading Labels from a File
	5.10.7	Saving Labels into a File
	5.10.8	Searching for a Label
	5.10.9	Searching for the Next Label
	5.10.10	Viewing the Source Corresponding to a Label

	5.11	Executing Your Program
	5.11.1	Running from Reset
	5.11.2	Continuing Run
	5.11.3	Running to the Cursor
	5.11.4	Running from a Specified Address
	5.11.5	Single Step
	5.11.6	Multiple Steps

	5.12	Stopping Your Program
	5.12.1	Stopping the Program by the [Stop] Toolbar Button
	5.12.2	Standard Breakpoints (PC Breakpoints)

	5.13	Elf/Dwarf2 Support
	5.13.1	C/C++ Operators
	5.13.2	C/C++ Expressions
	5.13.3	Supporting Duplicate Labels
	5.13.4	Debugging an Overlay Program

	5.14	Viewing the Variables
	5.14.1	Tooltip Watch
	5.14.2	Instant Watch
	5.14.3	[Watch] Window
	5.14.4	[Locals] Window

	5.15	Using the Event Points
	5.15.1	PC Breakpoints
	5.15.2	Event Points
	5.15.3	Event Detection System
	5.15.4	Signals to Indicate Bus States and Areas
	5.15.5	Opening the [Event] Window
	5.15.6	Setting PC Breakpoints
	5.15.7	Setting Event Points
	5.15.8	Setting Trigger Points
	5.15.9	Editing Event Points
	5.15.10	Modifying Event Points
	5.15.11	Enabling an Event Point
	5.15.12	Disabling an Event Point
	5.15.13	Deleting an Event Point
	5.15.14	Deleting All Event Points
	5.15.15	Viewing the Source Line for an Event Point

	5.16	Viewing the Trace Information
	5.16.1	Opening the [Trace] Window
	5.16.2	Acquiring Trace Information
	5.16.3	Specifying Trace Acquisition Conditions
	5.16.4	Searching for a Trace Record
	5.16.5	Clearing the Trace Information
	5.16.6	Saving the Trace Information in a File
	5.16.7	Viewing the [Source] Window
	5.16.8	Trimming the Source
	5.16.9	Acquiring a Snapshot of the Trace Information
	5.16.10	Temporarily Stopping Trace Acquisition
	5.16.11	Restarting Trace Acquisition
	5.16.12	Extracting Records from the Acquired Information
	5.16.13	Calculating the Difference in Time Stamping
	5.16.14	Analyzing Statistical Information
	5.16.15	Extracting Function Calls from the Acquired Trace Information

	5.17	Viewing the Function Call History
	5.17.1	Opening the [Stack Trace] Window
	5.17.2	Viewing the Source Program
	5.17.3	Specifying the View

	5.18	Displaying Memory Contents as an Image
	5.18.1	Opening the [Image View] Window
	5.18.2	Automatically Updating the Window Contents
	5.18.3	Updating the Window Contents
	5.18.4	Displaying the Pixel Information

	5.19	Displaying Memory Contents as Waveforms
	5.19.1	Opening the Waveform View Window
	5.19.2	Automatically Updating the Window Contents
	5.19.3	Updating the Window Contents
	5.19.4	Zoom-In Display
	5.19.5	Zoom-Out Display
	5.19.6	Resetting the Zoom Display
	5.19.7	Setting the Zoom Magnification
	5.19.8	Setting the Horizontal Scale
	5.19.9	Non-Display of Cursor
	5.19.10	Displaying the Sampling Information

	5.20	Analyzing Performance
	5.20.1	Opening the [Performance Analysis] Window
	5.20.2	Setting Conditions for Measurement
	5.20.3	Starting Performance Data Acquisition
	5.20.4	Deleting a Measurement Condition
	5.20.5	Deleting All Measurement Conditions


	Section 6   Tutorial
	6.1 Introduction
	6.2 Running the HEW
	6.3 Downloading the Tutorial Program
	6.3.1 Downloading the Tutorial Program
	6.3.2 Displaying the Source Program

	6.4 Setting a PC Breakpoint
	6.5 Setting Registers
	6.6 Executing the Program
	6.7 Reviewing Breakpoints
	6.8 Referring to Symbols
	6.9 Viewing Memory
	6.10 Watching Variables
	6.11 Displaying Local Variables
	6.12 Stepping Through a Program
	6.12.1 Executing the [Step In] Command
	6.12.2 Executing the [Step Out] Command
	6.12.3 Executing the [Step Over] Command

	6.13 Forced Breaking of Program Executions
	6.14 Resetting the MCU
	6.15 Break Function
	6.15.1 PC Break Function
	6.15.2 Breaking Execution at Event Points

	6.16 Trace Functions
	6.16.1 Displaying a Trace (when Time Stamping is not Available)
	6.16.2 Displaying a Trace (when Time Stamping is Available)
	6.16.3	Statistics
	6.16.4	Function Calls

	6.17 Stack Trace Function
	6.18 Monitor Function
	6.19 What Next?

	Section 7   Hardware Specifications Specific to This Product
	7.1	H8/300 and 300L E6000 Emulator Specifications
	7.1.1	Supported Items
	7.1.2	Operating Voltage and Frequency Specifications

	7.2 Installing the Evaluation Chip
	7.3 User System Interface
	7.3.1	Signal Protection
	7.3.2	User System Interface Circuits of the H8/300 Group Evaluation Chip (HS3308EVI60H)
	7.3.3	User System Interface Circuits of the H8/350 Group Evaluation Chip (HS3508EVI60H)
	7.3.4 User System Interface Circuits of the H8/338, H8/329 Group Evaluation Chip (HS3398EVI60H)
	7.3.5	User System Interface Circuits of the H8/3334 Group Evaluation Chip (HS3334EVI60H)
	7.3.6	User System Interface Circuits of the H8/3257, H8/325 Group Evaluation Chip (HS3257EVI60H)
	7.3.7 User System Interface Circuits of the H8/3437, H8/3337Y, H8/3297 Group Evaluation Chip (HS3437EVI60H)
	7.3.8 User System Interface Circuits of the H8/3217, H8/3318 Group Evaluation Chip (HS3318EVI60H)
	7.3.9	User System Interface Circuits of the H8/3834, H8/3814 Group Evaluation Chip (HS3834EVI60H)
	7.3.10	User System Interface Circuits of the H8/3637, H8/3877 Group Evaluation Chip (HS3876EVI60H)
	7.3.11 User System Interface Circuits of the H8/3927 Group Evaluation Chip (HS3927EVI60H)
	7.3.12 User System Interface Circuits of the H8/3644, H8/3657 Group E6000 Emulator (HS3644EPI60H)

	7.4	Differences between MCU and Emulator
	7.4.1	A/D Converter


	Section 8   Software Specifications Specific to This Product
	8.1	Software Specifications of the H8/300 and 300L E6000 Emulator
	8.1.1	Target Hardware
	8.1.2	Selectable Platforms
	8.1.3 [Configuration Properties] Dialog Box ([General] Page)
	8.1.4	Memory Mapping Function
	8.1.5	[Status] Window
	8.1.6	Extended Monitor Function
	8.1.7	Signals to Indicate Bus States and Areas
	8.1.8 Monitoring Function
	8.1.9 Trigger Points
	8.1.10	Trace Information
	8.1.11	Searching for a Trace Record
	8.1.12	Trace Filtering Function
	8.1.13	[Performance Analysis] Window

	8.2 Note on Usage of the H8/300 and 300L E6000 Emulator
	8.2.1	Environment for Execution of the Tutorial Program
	8.2.2	Notes on Use of the H8/300 Group Evaluation Chip Set (HS3308EVI60H)
	8.2.3 Notes on Use of the H8/350 Group Evaluation Chip Set (HS3508EVI60H)
	8.2.4	Notes on Use of the H8/338, H8/329 Group Evaluation Chip Set (HS3398EVI60H)
	8.2.5 Notes on Use of the H8/3334 Group Evaluation Chip Set (HS3334EVI60H)
	8.2.6 Notes on Use of the H8/3257, H8/325 Group Evaluation Chip Set (HS3257EVI60H)
	8.2.7	Notes on Use of the H8/3437, H8/3437Y, H8/3297 Group Evaluation Chip Set (HS3437EVI60H)
	8.2.8 Notes on Use of the H8/3217, H8/3318 Group Evaluation Chip Set (HS3318EVI60H)
	8.2.9	Notes on Use of the H8/3834, H8/3814 Group Evaluation Chip Set (HS3834EVI60H)
	8.2.10	Notes on Use of the H8/3637, H8/3877 Group Evaluation Chip Set (HS3876EVI60H)
	8.2.11 Notes on Use of the H8/3927 Group Evaluation Chip Set (HS3927EVI60H)
	8.2.12	Notes on Use of the H8/3644, H8/3657 Group Emulator (HS3644EPI60H)


	Appendix A   Troubleshooting
	Appendix B   Regular Expressions
	Appendix C   Placeholders
	C.1	What is a Placeholder?
	C.2	Inserting a Placeholder
	C.3	Available Placeholders
	C.4	Placeholder Tips

	Appendix D   I/O File Format
	D.1	File format (Bit Field Not Supported)
	D.2	File format (Bit Field Supported)

	Appendix E   Symbol File Format
	Appendix F   HMAKE User Guide
	F.1	Command line
	F.1.1	Basic structure
	F.1.2	Exit codes
	F.1.3	Parameters

	F.2	File syntax
	F.2.1	Variable declarations

	F.3	Description blocks
	F.3.1	Basic outline
	F.3.2	Special commands
	F.3.3	Sub command files

	F.4	Comments
	F.5	Message commands

	Appendix G   Menus
	Appendix H   Command Lines
	Appendix I   Diagnostic Test Procedure
	I.1	System Set-Up for Test Program Execution
	I.2	Diagnostic Test Procedure Using Test Program


	Colophon

