To our customers,

Old Company Name in Catalogs and Other Documents

On April 1st, 2010, NEC Electronics Corporation merged with Renesas Technology Corporation, and Renesas Electronics Corporation took over all the business of both companies. Therefore, although the old company name remains in this document, it is a valid Renesas Electronics document. We appreciate your understanding.

Renesas Electronics website: http://www.renesas.com

April 1st, 2010
Renesas Electronics Corporation

Issued by: Renesas Electronics Corporation (http://www.renesas.com)

Send any inquiries to http://www.renesas.com/inquiry.
Notice

1. All information included in this document is current as of the date this document is issued. Such information, however, is subject to change without any prior notice. Before purchasing or using any Renesas Electronics products listed herein, please confirm the latest product information with a Renesas Electronics sales office. Also, please pay regular and careful attention to additional and different information to be disclosed by Renesas Electronics such as that disclosed through our website.

2. Renesas Electronics does not assume any liability for infringement of patents, copyrights, or other intellectual property rights of third parties by or arising from the use of Renesas Electronics products or technical information described in this document. No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights of Renesas Electronics or others.

3. You should not alter, modify, copy, or otherwise misappropriate any Renesas Electronics product, whether in whole or in part.

4. Descriptions of circuits, software and other related information in this document are provided only to illustrate the operation of semiconductor products and application examples. You are fully responsible for the incorporation of these circuits, software, and information in the design of your equipment. Renesas Electronics assumes no responsibility for any losses incurred by you or third parties arising from the use of these circuits, software, or information.

5. When exporting the products or technology described in this document, you should comply with the applicable export control laws and regulations and follow the procedures required by such laws and regulations. You should not use Renesas Electronics products or the technology described in this document for any purpose relating to military applications or use by the military, including but not limited to the development of weapons of mass destruction. Renesas Electronics products and technology may not be used for or incorporated into any products or systems whose manufacture, use, or sale is prohibited under any applicable domestic or foreign laws or regulations.

6. Renesas Electronics has used reasonable care in preparing the information included in this document, but Renesas Electronics does not warrant that such information is error free. Renesas Electronics assumes no liability whatsoever for any damages incurred by you resulting from errors in or omissions from the information included herein.

7. Renesas Electronics products are classified according to the following three quality grades: “Standard”, “High Quality”, and “Specific”. The recommended applications for each Renesas Electronics product depends on the product’s quality grade, as indicated below. You must check the quality grade of each Renesas Electronics product before using it in a particular application. You may not use any Renesas Electronics product for any application categorized as “Specific” without the prior written consent of Renesas Electronics. Further, you may not use any Renesas Electronics product for any application for which it is not intended without the prior written consent of Renesas Electronics. Renesas Electronics shall not be in any way liable for any damages or losses incurred by you or third parties arising from the use of any Renesas Electronics product for an application categorized as “Specific” or for which the product is not intended where you have failed to obtain the prior written consent of Renesas Electronics. The quality grade of each Renesas Electronics product is “Standard” unless otherwise expressly specified in a Renesas Electronics data sheets or data books, etc.

“Standard”: Computers; office equipment; communications equipment; test and measurement equipment; audio and visual equipment; home electronic appliances; machine tools; personal electronic equipment; and industrial robots.

“High Quality”: Transportation equipment (automobiles, trains, ships, etc.); traffic control systems; anti-disaster systems; anti-crime systems; safety equipment; and medical equipment not specifically designed for life support.

“Specific”: Aircraft; aerospace equipment; submersible repeaters; nuclear reactor control systems; medical equipment or systems for life support (e.g. artificial life support devices or systems), surgical implantations, or healthcare intervention (e.g. excision, etc.), and any other applications or purposes that pose a direct threat to human life.

8. You should use the Renesas Electronics products described in this document within the range specified by Renesas Electronics, especially with respect to the maximum rating, operating supply voltage range, movement power voltage range, heat radiation characteristics, installation and other product characteristics. Renesas Electronics shall have no liability for malfunctions or damages arising out of the use of Renesas Electronics products beyond such specified ranges.

9. Although Renesas Electronics endeavors to improve the quality and reliability of its products, semiconductor products have specific characteristics such as the occurrence of failure at a certain rate and malfunctions under certain use conditions. Further, Renesas Electronics products are not subject to radiation resistance design. Please be sure to implement safety measures to guard them against the possibility of physical injury, and injury or damage caused by fire in the event of the failure of a Renesas Electronics product, such as safety design for hardware and software including but not limited to redundancy, fire control and malfunction prevention, appropriate treatment for aging degradation or any other appropriate measures. Because the evaluation of microcomputer software alone is very difficult, please evaluate the safety of the final products or system manufactured by you.

10. Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental compatibility of each Renesas Electronics product. Please use Renesas Electronics products in compliance with all applicable laws and regulations that regulate the inclusion or use of controlled substances, including without limitation, the EU RoHS Directive. Renesas Electronics assumes no liability for damages or losses occurring as a result of your noncompliance with applicable laws and regulations.

11. This document may not be reproduced or duplicated, in any form, in whole or in part, without prior written consent of Renesas Electronics.

12. Please contact a Renesas Electronics sales office if you have any questions regarding the information contained in this document or Renesas Electronics products, or if you have any other inquiries.

(Note 1) “Renesas Electronics” as used in this document means Renesas Electronics Corporation and also includes its majority-owned subsidiaries.

(Note 2) “Renesas Electronics product(s)” means any product developed or manufactured by or for Renesas Electronics.
To all our customers

Regarding the change of names mentioned in the document, such as Hitachi Electric and Hitachi XX, to Renesas Technology Corp.

The semiconductor operations of Mitsubishi Electric and Hitachi were transferred to Renesas Technology Corporation on April 1st 2003. These operations include microcomputer, logic, analog and discrete devices, and memory chips other than DRAMs (flash memory, SRAMs etc.) Accordingly, although Hitachi, Hitachi, Ltd., Hitachi Semiconductors, and other Hitachi brand names are mentioned in the document, these names have in fact all been changed to Renesas Technology Corp. Thank you for your understanding. Except for our corporate trademark, logo and corporate statement, no changes whatsoever have been made to the contents of the document, and these changes do not constitute any alteration to the contents of the document itself.

Renesas Technology Home Page: http://www.renesas.com

Renesas Technology Corp.
Customer Support Dept.
April 1, 2003
Cautions

Keep safety first in your circuit designs!

1. Renesas Technology Corporation puts the maximum effort into making semiconductor products better and more reliable, but there is always the possibility that trouble may occur with them. Trouble with semiconductors may lead to personal injury, fire or property damage. Remember to give due consideration to safety when making your circuit designs, with appropriate measures such as (i) placement of substitutive, auxiliary circuits, (ii) use of nonflammable material or (iii) prevention against any malfunction or mishap.

Notes regarding these materials

1. These materials are intended as a reference to assist our customers in the selection of the Renesas Technology Corporation product best suited to the customer's application; they do not convey any license under any intellectual property rights, or any other rights, belonging to Renesas Technology Corporation or a third party.

2. Renesas Technology Corporation assumes no responsibility for any damage, or infringement of any third-party's rights, originating in the use of any product data, diagrams, charts, programs, algorithms, or circuit application examples contained in these materials.

3. All information contained in these materials, including product data, diagrams, charts, programs and algorithms represents information on products at the time of publication of these materials, and are subject to change by Renesas Technology Corporation without notice due to product improvements or other reasons. It is therefore recommended that customers contact Renesas Technology Corporation or an authorized Renesas Technology Corporation product distributor for the latest product information before purchasing a product listed herein. The information described here may contain technical inaccuracies or typographical errors. Renesas Technology Corporation assumes no responsibility for any damage, liability, or other loss rising from these inaccuracies or errors. Please also pay attention to information published by Renesas Technology Corporation by various means, including the Renesas Technology Corporation Semiconductor home page (http://www.renesas.com).

4. When using any or all of the information contained in these materials, including product data, diagrams, charts, programs, and algorithms, please be sure to evaluate all information as a total system before making a final decision on the applicability of the information and products. Renesas Technology Corporation assumes no responsibility for any damage, liability or other loss resulting from the information contained herein.

5. Renesas Technology Corporation semiconductors are not designed or manufactured for use in a device or system that is used under circumstances in which human life is potentially at stake. Please contact Renesas Technology Corporation or an authorized Renesas Technology Corporation product distributor when considering the use of a product contained herein for any specific purposes, such as apparatus or systems for transportation, vehicular, medical, aerospace, nuclear, or underwater repeater use.

6. The prior written approval of Renesas Technology Corporation is necessary to reprint or reproduce in whole or in part these materials.

7. If these products or technologies are subject to the Japanese export control restrictions, they must be exported under a license from the Japanese government and cannot be imported into a country other than the approved destination. Any diversion or reexport contrary to the export control laws and regulations of Japan and/or the country of destination is prohibited.

8. Please contact Renesas Technology Corporation for further details on these materials or the products contained therein.
Contents

Contents ...................................................................................................... i
Cautions ...................................................................................................... iii
Preface ...................................................................................................... iv
Abbreviations .......................................................................................... v
Document Conventions .............................................................................. vi

Chapter 1 Introduction .............................................................................. 1
  1.1 Key Features .......................................................................................... 1
  1.2 New Features ........................................................................................ 1

Chapter 2 System Overview ...................................................................... 3
  2.1 User Interface .......................................................................................... 3
  2.2 Help ......................................................................................................... 10
  2.3 Hot Keys ................................................................................................. 10

Chapter 3 Basic Operation ....................................................................... 13
  3.1 Starting FDT ........................................................................................... 13
  3.2 Creating a New Workspace ..................................................................... 13
  3.3 Saving a Workspace ................................................................................. 19
  3.4 Closing a Workspace .............................................................................. 19
  3.5 Exiting FDT ............................................................................................ 19
  3.6 Programming the Data to the FLASH ROM .......................................... 19
  3.7 Erasing Data from the FLASH ROM ....................................................... 21
  3.8 Reading the FLASH ROM Data ............................................................... 22

Chapter 4 Configuring the User Interface ............................................... 23
  4.1 Arranging Windows ............................................................................... 23
  4.2 Locating Currently Open Windows ....................................................... 23
  4.3 Enabling/disabling the Status Bar ......................................................... 24
  4.4 Enabling/disabling the Toolbar ............................................................. 24
  4.5 Enabling/disabling the Workspace ....................................................... 24
  4.6 Enabling/disabling the Message Log .................................................... 24
  4.7 Enabling/disabling the Dependency Log ............................................. 24
  4.8 Customising the Toolbar ...................................................................... 25

Chapter 5 Menus ...................................................................................... 27
  5.1 File ........................................................................................................ 27
  5.2 Edit ....................................................................................................... 28
  5.3 View ..................................................................................................... 29
  5.4 Project .................................................................................................. 29
  5.5 Device .................................................................................................. 30
  5.6 Image ................................................................................................... 31
  5.7 Tools .................................................................................................... 32
  5.8 Window ................................................................................................. 32
  5.9 Help .................................................................................................... 33

Chapter 6 Windows .................................................................................. 35
<table>
<thead>
<tr>
<th>Section</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>6.1</td>
<td>Workspace window</td>
<td>35</td>
</tr>
<tr>
<td>6.2</td>
<td>Workspace</td>
<td>36</td>
</tr>
<tr>
<td>6.3</td>
<td>Project</td>
<td>37</td>
</tr>
<tr>
<td>6.4</td>
<td>Device Image - Sub Folder</td>
<td>39</td>
</tr>
<tr>
<td>6.5</td>
<td>Device Image - Sub-Project Properties</td>
<td>39</td>
</tr>
<tr>
<td>6.6</td>
<td>Target files - Sub Folder</td>
<td>40</td>
</tr>
<tr>
<td>6.7</td>
<td>Target files - Sub-Project Properties</td>
<td>40</td>
</tr>
<tr>
<td>6.8</td>
<td>Device Image</td>
<td>41</td>
</tr>
<tr>
<td>6.9</td>
<td>S-Record Files</td>
<td>42</td>
</tr>
<tr>
<td>6.10</td>
<td>Workspace Properties</td>
<td>42</td>
</tr>
<tr>
<td>6.11</td>
<td>Project Properties</td>
<td>43</td>
</tr>
<tr>
<td>6.12</td>
<td>Device Image Properties</td>
<td>48</td>
</tr>
<tr>
<td>6.13</td>
<td>S-Record Properties</td>
<td>50</td>
</tr>
<tr>
<td>6.14</td>
<td>Output Window</td>
<td>51</td>
</tr>
<tr>
<td>6.15</td>
<td>Editor Window</td>
<td>52</td>
</tr>
<tr>
<td>6.16</td>
<td>Erase Blocks</td>
<td>54</td>
</tr>
<tr>
<td>6.17</td>
<td>Customise - Toolbars</td>
<td>55</td>
</tr>
<tr>
<td>6.18</td>
<td>Customise - Commands</td>
<td>56</td>
</tr>
<tr>
<td>6.19</td>
<td>Customise – Output Window</td>
<td>57</td>
</tr>
<tr>
<td>6.20</td>
<td>Customise - General</td>
<td>59</td>
</tr>
<tr>
<td>6.21</td>
<td>Simple Interface</td>
<td>60</td>
</tr>
</tbody>
</table>
Cautions

1. Hitachi neither warrants nor grants licenses of any rights of Hitachi’s or any third party’s patent, copyright, trademark, or other intellectual property rights for information contained in this document. Hitachi bears no responsibility for problems that may arise with third party’s rights, including intellectual property rights, in connection with use of the information contained in this document.

2. Products and product specifications may be subject to change without notice. Confirm that you have received the latest product standards or specifications before final design, purchase or use.

3. Hitachi makes every attempt to ensure that its products are of high quality and reliability. However, contact Hitachi’s sales office before using the product in an application that demands especially high quality and reliability or where its failure or malfunction may directly threaten human life or cause risk of bodily injury, such as aerospace, aeronautics, nuclear power, combustion control, transportation, traffic, safety equipment or medical equipment for life support.

4. Design your application so that the product is used within the ranges guaranteed by Hitachi particularly for maximum rating, operating supply voltage range, heat radiation characteristics, installation conditions and other characteristics. Hitachi bears no responsibility for failure or damage when used beyond the guaranteed ranges. Even within the guaranteed ranges, consider normally foreseeable failure rates or failure modes in semiconductor devices and employ systemic measures such as fail-safes, so that the equipment incorporating Hitachi product does not cause bodily injury, fire or other consequential damage due to operation of the Hitachi product.

5. This product is not designed to be radiation resistant.

6. No one is permitted to reproduce or duplicate, in any form, the whole or part of this document without written approval from Hitachi.

Contact Hitachi’s sales office for any questions regarding this document or Hitachi semiconductor products.
Preface

About this guide

This guide explains the use of the Hitachi FLASH Development Toolkit (hereafter referred to as FDT).

Chapter 1, Introduction, provides a brief explanation to the tool and lists its key features.

Chapter 2, System Overview, describes how the different facilities make up the FDT Graphical User Interface.

Chapter 3, Basic Operation, describes how FDT is activated and the FLASH ROM is written.

Chapter 4, Configuring the User Interface, provides a way to configure the FDT Graphical User Interface.

Chapter 5, Menus, and chapter 6, Windows, give reference information about the operations and facilities available through these respective areas.

Assumptions

It is assumed that the reader is experienced in using Microsoft Windows applications on PC-compatible computers.
## Abbreviations

<table>
<thead>
<tr>
<th>Abbreviation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device</td>
<td>Refers to programmable microcontroller or microcomputers</td>
</tr>
<tr>
<td>DLL</td>
<td>Dynamic Linked Library</td>
</tr>
<tr>
<td>FDT</td>
<td>Flash Development Toolkit</td>
</tr>
<tr>
<td>F-ZTAT</td>
<td>FLASH ZTAT</td>
</tr>
<tr>
<td>HEW</td>
<td>Hitachi Embedded Workshop</td>
</tr>
<tr>
<td>HMSE</td>
<td>Hitachi Micro Systems Europe</td>
</tr>
<tr>
<td>PC</td>
<td>Personal Computer</td>
</tr>
<tr>
<td>ZTAT</td>
<td>Zero Turn-Around Technology</td>
</tr>
</tbody>
</table>
Document Conventions

This manual uses the following typographic conventions:

<table>
<thead>
<tr>
<th>CONVENTION</th>
<th>MEANING</th>
</tr>
</thead>
<tbody>
<tr>
<td>[Menu-&gt;Menu Option]</td>
<td>Bold text with ‘-&gt;’ is used to indicate menu options (for example, [File-&gt;Save As…]).</td>
</tr>
<tr>
<td>dialog name'</td>
<td>The ‘’ is used to indicate the name of a dialog box or menu.</td>
</tr>
<tr>
<td>FILENAME.C</td>
<td>Uppercase names are used to indicate filenames.</td>
</tr>
<tr>
<td>“enter this string”</td>
<td>Used to indicate text that must be entered (excluding the “” quotes).</td>
</tr>
<tr>
<td>Key+Key</td>
<td>Used to indicate required key presses. For example. Ctrl+N means press the Ctrl key and then, whilst holding the Ctrl key down, press the N key.</td>
</tr>
<tr>
<td>⚾️ (The “how to” symbol)</td>
<td>When this symbol is used, it is always located in the left-hand margin. It indicates that the text to its immediate right is describing “how to” do something.</td>
</tr>
</tbody>
</table>

Windows® is a registered trademark of Microsoft Corporation.

F-ZTAT is a trademark of Hitachi, Ltd.
Chapter 1 Introduction

The Hitachi FLASH Development Toolkit (FDT) is an on-board FLASH programming tool for Hitachi F-ZTAT microcomputers that provides a high-performance and user-friendly Graphical User Interface (GUI).

Embedded software development projects created using the Hitachi Embedded Workshop (HEW) may be programmed into Hitachi F-ZTAT devices using FDT.

FDT may also be used as a general purpose S-Record or Binary editor.

1.1 Key Features

- Standard window operation based on the 32-bit Windows® GUI.
- Various online help functions.
- Selectable messaging levels.
- Simple programming environment using an adapter board.
- Serial communication: maximum 115,200 bits/s.

1.2 New Features

FDT 2.2 has the following new features:-

- USB communications directly to selected target devices.
Chapter 2  System Overview

FDT is a modular software system, utilising self-contained modules for specific tasks. These modules are linked to a general purpose Graphical User Interface, which provides a common look & feel independent of the particular modules with which the system is configured.

FDT employs a hierarchical structure so that work can be organised in a logical manner. The top level of the structure is the workspace.

To be useful, the workspace must contain at least one project. In order to create a project, a workspace must be created first.

Each project specifies its own target device configuration (specified when creating the project) and set of target files (S-Record / Binary) that can be used to program the device.

The project settings for the target device connection need only be set once, as they are stored between sessions.

A single project within the workspace is active at any point in time. The Active project is the context to which all Device Menu, Project Menu and Project Toolbar commands will be directed.

When a project has been created, target files can be added to it. These files may be:

- Used to program the device.
- Used to build a Device Image.
- Opened in the binary editor.

The files added to a project are automatically copied from their original source location. In copying a file, a dependency link is created such that if the original source file is modified then the copied version in the project may be updated upon request.

When using a project it is possible to take advantage of the following FDT features:

- Target file dependency checking.
- Advanced messaging levels.
- Device Image builder.
- Uploading data from the target device.

2.1 User Interface

The FDT Graphical User Interface is a Windows® application that presents a work environment, which allows the user to program FLASH memory.
Menu bar

Commands are grouped into related areas on the Menu bar as indicated by the menu titles. Using the mouse, the user can select a command operation, invoke a dialog box or a window to interact with the system. Clicking the left mouse button on a menu title will pull down that menu, from which a selection can be made.

If a menu item does not perform an action directly, but instead displays a dialog box or window for further user interaction, then its name is appended with an ellipsis (three dots, …).

If a menu item can also be invoked by pressing a hot key (a combination of keys), then the hot key is displayed to the right of the item.
If a menu item toggles a feature ON or OFF then a check mark (✓) will be displayed next to its text when it is ON:

![Menu Items]

If a menu item has the symbol (▼) next to it then a cascading or hierarchical menu is available. Clicking on the menu item will reveal the cascading menu:

![Cascading Menu]

Menus can also be selected directly from the keyboard by pressing the ALT key followed by the corresponding key of the underlined letter or number for the menu item that the user wants to select, e.g. press ALT+F, O in sequence to open a project ([File->Open]).

**Toolbars**

FDT has several toolbars located below the Menu bar. This provides quick access to FDT features by clicking the respective button with the mouse.

![Toolbars]

The buttons on each toolbar are arranged in associated groups.

To find out the function of the button, move the mouse over the button and a hint will be displayed next to the button and in the status bar.

The toolbar buttons can be customised to provide a button for the majority of the features available in FDT and can be arranged in an order that the user finds convenient.

For more details about changing the arrangement of the toolbar buttons and a detailed description of each button’s function, see chapter 4, Configuring the User Interface.
Workspace toolbar

New Workspace - launches the ‘New Workspace’ dialog box.
Open Workspace - launches the ‘Open’ dialog box.
Save Workspace - saves the current Workspace.
New Project - launches the ‘Project Wizard’ dialog box.
Active Project - sets a new active project from those available in the workspace.

Properties - launches the ‘Project Properties’ dialog box.

Add S-Record Files - launches the ‘Open’ dialog box so that S-Record files may be added to the project as a target file.

Build Image - builds the open Device Image file into a binary image file for downloading the target FLASH memory.

Download Device Image - downloads the current device image.

Connect - connects the device to the interface.

Disconnect - disconnects the device from the interface.

Erase Blocks - launches the ‘Erase Block’ dialog box to erase all or individual blocks of the device FLASH memory.

Blank Check - checks whether or not the FLASH section of the target device is blank.

Upload Data - launches the ‘Upload Image’ dialog box to allow data to be obtained from the target device.

Cancel FLASH Operation - cancels the FLASH operations Download, Upload, Erase or connection attempt.
Open file - launches the ‘Open’ dialog box.
Save file - Saves the current active file.
Save all - Saves all files that have not been saved on the Editor window.
Cut - removes the highlighted block to the clipboard.
Copy - copies the highlighted block to the clipboard.
Paste - copies the contents of the clipboard to the window at the cursor position.
Create Selection - selects a block of the specified size in the active file.
Undo - reverses the previous editing operation.
Redo - reverses the previous Undo operation.
View as Bytes - view the file data as 8 bit bytes.
View as Words - view the file data as 16 bit words.
View as DWords - view the file data as 32 bit double words.
**Toggle ASCII** - turns ASCII data ON or OFF

**Align view to 8 bytes** - data is displayed on each line as 8 bytes. The number of bytes that can be accommodated on each line is dependent upon the size of the window.

**Find** - launches the ‘Find’ dialog box.

**Find and Replace** - launches the ‘Replace’ dialog box.

**Fill selection** - launches the ‘Fill’ dialog box.

**Download active file** - downloads the current active file in the Editor window to the target FLASH memory.

### Status Bar

The Status Bar is located at the bottom of the FDT application window. It provides the user with information about what the application is doing or the last action performed.

The left section of the Status Bar describes the action of the Toolbar items as the mouse arrow key is positioned over an item.

The next section indicates whether the interface is connected to the device and the port used. It also indicates what action is taking place.

When an action is being performed, the third section gives an increasing percentage display.

The last section of the bar indicates the state of the Caps Lock key.

### Pop-up menus

Many windows have local pop-up menus in order to make commonly used features easier to access. These menus are invoked by clicking the right mouse button in the window (or pressing `SHIFT+F10`) and then selecting the required menu option. An example pop-up menu is:

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Exit</td>
<td>Ctrl+X</td>
</tr>
<tr>
<td>Copy</td>
<td>Ctrl+C</td>
</tr>
<tr>
<td>Paste</td>
<td>Ctrl+V</td>
</tr>
<tr>
<td>Undo</td>
<td>Ctrl+Z</td>
</tr>
<tr>
<td>Redo</td>
<td>Ctrl+Y</td>
</tr>
</tbody>
</table>

The contents and operation of specific pop-up menus are explained in detail in the description of each FDT window, see the chapter 6, *Windows*. 

[RENE S]
Data entry

When entering data in the ‘Find’, ‘Replace’ or ‘Fill’ dialog boxes only hexadecimal or ASCII values can be used, based on the ASCII Search check box. When entering hexadecimal values a preceding ‘0x’ is fixed in the entry text box, so hexadecimal values are appended.

2.2 Help

FDT has a standard Windows context sensitive help system. This provides on-line information for using the system.

Help can be invoked by pressing the F1 key or via the Help menu. Additionally, some windows and dialog boxes have a dedicated help button to launch the help file at the appropriate location.

Context Sensitive Help

To get help on a specific item in the FDT graphical interface, a help cursor can be used. To enable the help cursor press SHIFT+F1.

Your cursor then changes to include a question mark. You can then click on the item for which you require help and the help system will be opened at the appropriate location, if help information exists. Help can be invoked through the Help menu.

2.3 Hot Keys

There are various hot keys for frequently used operations. These are as follows by category:

<table>
<thead>
<tr>
<th>Description</th>
<th>Hot Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Help</td>
<td>F1</td>
</tr>
<tr>
<td>Context Sensitive Help</td>
<td>Shift+F1</td>
</tr>
<tr>
<td>File Commands</td>
<td></td>
</tr>
<tr>
<td>Open</td>
<td>Ctrl+O</td>
</tr>
<tr>
<td>New Workspace</td>
<td>Ctrl+N</td>
</tr>
<tr>
<td>Open Workspace</td>
<td>Ctrl+W</td>
</tr>
<tr>
<td>Save Workspace</td>
<td>Ctrl+E</td>
</tr>
<tr>
<td>Save</td>
<td>Ctrl+S</td>
</tr>
<tr>
<td>Project</td>
<td></td>
</tr>
<tr>
<td>New Project</td>
<td>Alt+N</td>
</tr>
<tr>
<td>Add File to Project</td>
<td>Ctrl+A</td>
</tr>
<tr>
<td>Build Device Image</td>
<td>Ctrl+B</td>
</tr>
<tr>
<td>Download Device Image</td>
<td>Ctrl+Shift+P</td>
</tr>
<tr>
<td>Freshen all Target Files</td>
<td>Ctrl+T</td>
</tr>
<tr>
<td>Properties</td>
<td>Alt+Shift+R</td>
</tr>
<tr>
<td>Command</td>
<td>Shortcut</td>
</tr>
<tr>
<td>----------------------------------------</td>
<td>------------</td>
</tr>
<tr>
<td>Remove File to Project</td>
<td>Ctrl+R</td>
</tr>
<tr>
<td><strong>Edit Commands</strong></td>
<td></td>
</tr>
<tr>
<td>Undo</td>
<td>Ctrl+Z</td>
</tr>
<tr>
<td>Redo</td>
<td>Ctrl+Y</td>
</tr>
<tr>
<td>Cut</td>
<td>Ctrl+X</td>
</tr>
<tr>
<td>Copy</td>
<td>Ctrl+C</td>
</tr>
<tr>
<td>Paste</td>
<td>Ctrl+V</td>
</tr>
<tr>
<td>Find</td>
<td>Ctrl+F</td>
</tr>
<tr>
<td>Replace</td>
<td>Ctrl+H</td>
</tr>
<tr>
<td>Create Selection</td>
<td>Ctrl+M</td>
</tr>
<tr>
<td><strong>Device</strong></td>
<td></td>
</tr>
<tr>
<td>Connect/Disconnect</td>
<td>Alt+C</td>
</tr>
<tr>
<td>Erase FLASH Blocks</td>
<td>Alt+R</td>
</tr>
<tr>
<td>Upload Image</td>
<td>Alt+U</td>
</tr>
<tr>
<td>Blank Check</td>
<td>Alt+B</td>
</tr>
<tr>
<td>Caged FLASH Operation</td>
<td>Ctrl+Break</td>
</tr>
<tr>
<td>Fill</td>
<td>Ctrl+L</td>
</tr>
<tr>
<td>Download Image</td>
<td>Ctrl+P</td>
</tr>
<tr>
<td><strong>Window</strong></td>
<td></td>
</tr>
<tr>
<td>View as ASCII</td>
<td>Alt+A</td>
</tr>
<tr>
<td>View as Bytes</td>
<td>Alt+1</td>
</tr>
<tr>
<td>View as Word</td>
<td>Alt+2</td>
</tr>
<tr>
<td>View as DWORD</td>
<td>Alt+4</td>
</tr>
<tr>
<td>Align to 8 Bytes</td>
<td>Alt+8</td>
</tr>
<tr>
<td><strong>Simple Interface</strong></td>
<td></td>
</tr>
<tr>
<td>Enter Simple Interface Mode</td>
<td>Shift+Ctrl+F11</td>
</tr>
</tbody>
</table>
Chapter 3  Basic Operation

3.1  Starting FDT

To start FDT, open the ‘Start’ menu of Windows® and select ‘Hitachi’ from ‘Program’, ‘FLASH Development Toolkit 2.2’, and the FDT shortcut. The ‘Welcome to the FLASH Development Toolkit’ dialog box will open by default.

To create a new workspace, select ‘Create a new Workspace’ and click the ‘OK’ button. To open a recent workspace, select ‘Open an existing Workspace’ and the workspace to be opened from the list box, and click the ‘OK’ button.

3.2  Creating a New Workspace

(1) Enter the workspace name, then click the ‘OK’ button. (Specify whether or not a directory is to be created and a location.)
(2) If you want to run the Project Wizard, click the ‘Yes’ button.

(3) Enter the project name, then click the ‘Next’ button.
(4) Select the device you wish to use from the drop-down list. If there exists a user-created kernel in addition to the default path, select “Other…” to specify the kernel file (.fcf). It is possible to have more than one kernel option displayed, and double clicking on a kernel will open an optional “readme.txt” file that has information about the kernel (such as the device, version number and the compilers it was created with).

(5) Select a port and baud rate from the drop-down lists, then click the ‘Next’ button. In addition to the serial ports, there is also an option to use USB.

Note: For the serial port baud rate, refer to the hardware manual and select a rate where the variance is within 3% for the clock frequency used.
Supplementary:

1. Use Default Baud Rate

Set this option only when the HMSE Evaluation Board or Evaluation Development Kit is used.
(6) Enter the numerical values for the input clock, select the main or peripheral multiplier from the drop-down list, and click the ‘Next’ button.

Supplementary:

1. CPU Crystal Frequency
   Enter the frequency of the CPU clock or the crystal generator as integers or in a format such as xx.xx. You can only input two digits to the right of the decimal point.

2. Clock Mode
   A clock mode needs to be selected depending on the target device. Select a value from the drop-down list.

3. Multiplier for CKM
   Select the multiplier of the system clock (master clock) for the input clock.

4. Multiplier for CKP
   The frequency rate (CKP) selected depends on the target device. Enter the multiplier of the peripheral clock for the input clock.

Note To enter the clock mode, input clock, and frequency rate, refer to the hardware manual and confirm the range to be set.
(7) Select the operating mode, then click the ‘Next’ button. If the target is connected directly to the host computer, the connection interface should be selected to ‘Direct Connection’.

(8) Select the protection level for programming the FLASH ROM and the messaging level, then click the ‘Finish’ button.
3.3 Saving a Workspace

When the [File -> Save Workspace] menu option is selected, the FDT workspace can be saved.

3.4 Closing a Workspace

Select [File -> Close Workspace] to close the FDT workspace. If the workspace or its project has changed, a dialog box asks if the user wishes to save the project. Select “Yes” if the workspace is to be saved, “No” if the workspace is not to be saved, and “Cancel” to return to the workspace.

3.5 Exiting FDT

To exit FDT, select [File -> Exit], press the Alt + F4 key, or select the ‘Close’ option from the system menu (the system menu can be opened by clicking the icon in the upper-left area of the title bar).

3.6 Programming the Data to the FLASH ROM

(1) When the target file (S-Record file) is downloaded:

1. Select [Project -> Add Files to Project] or press the Ctrl + A key to add the file to be downloaded to the project.
2. Click the right mouse button on the file (*.mot) displayed in the workspace window, and select ‘Download File to Device’.
3. Programming will be completed when ‘Image successfully written to device’ is displayed in the message log window.
When the device image is downloaded:

1. Add the target file to the project. (Same as item 1 of (1) above.)
2. Click the right mouse button on 'Device Image' displayed in the workspace window, and select 'Build Device Image'.
3. The creation of the device image is complete when ‘Build Complete – Saving Image…’ is displayed in the message window.
4. Click the right mouse button on the file (*.fpr) displayed in the workspace window, and select ‘Download Image to Device’.
5. Programming is complete when ‘Image successfully written to device’ is displayed in the message window.
3.7 Erasing Data from the FLASH ROM

1. Select [Device -> Erase FLASH blocks...] to display the ‘Erase Blocks’ dialog box.
2. Select the block to be erased. (When Name of the block is clicked, the block name is inversely displayed.)
3. Click the ‘Erase’ button to start erasure.
4. When ‘Erase complete’ is displayed in the message window, erasure is completed.

<table>
<thead>
<tr>
<th>Name</th>
<th>Written</th>
<th>Start</th>
<th>End</th>
<th>Size</th>
</tr>
</thead>
<tbody>
<tr>
<td>EB1</td>
<td>No</td>
<td>1000</td>
<td>1ff</td>
<td>4 K</td>
</tr>
<tr>
<td>EB2</td>
<td>No</td>
<td>2000</td>
<td>2ff</td>
<td>4 K</td>
</tr>
<tr>
<td>EB3</td>
<td>No</td>
<td>3000</td>
<td>3ff</td>
<td>4 K</td>
</tr>
<tr>
<td>EB4</td>
<td>No</td>
<td>4000</td>
<td>4ff</td>
<td>4 K</td>
</tr>
<tr>
<td>EB5</td>
<td>No</td>
<td>5000</td>
<td>5ff</td>
<td>4 K</td>
</tr>
<tr>
<td>EB6</td>
<td>No</td>
<td>6000</td>
<td>6ff</td>
<td>4 K</td>
</tr>
<tr>
<td>EB7</td>
<td>No</td>
<td>7000</td>
<td>7ff</td>
<td>4 K</td>
</tr>
<tr>
<td>EB8</td>
<td>No</td>
<td>8000</td>
<td>8ff</td>
<td>32 K</td>
</tr>
<tr>
<td>EB9</td>
<td>No</td>
<td>9000</td>
<td>9ff</td>
<td>64 K</td>
</tr>
<tr>
<td>EB10</td>
<td>No</td>
<td>10000</td>
<td>1ff</td>
<td>64 K</td>
</tr>
<tr>
<td>EB11</td>
<td>No</td>
<td>20000</td>
<td>2ff</td>
<td>64 K</td>
</tr>
<tr>
<td>EB12</td>
<td>No</td>
<td>30000</td>
<td>3ff</td>
<td>64 K</td>
</tr>
<tr>
<td>EB13</td>
<td>No</td>
<td>40000</td>
<td>4ff</td>
<td>64 K</td>
</tr>
<tr>
<td>EB14</td>
<td>No</td>
<td>50000</td>
<td>5ff</td>
<td>64 K</td>
</tr>
<tr>
<td>EB15</td>
<td>No</td>
<td>60000</td>
<td>6ff</td>
<td>64 K</td>
</tr>
</tbody>
</table>

**Note**  To erase all blocks, clicking the ‘Select All’ button inversely displays all blocks. To erase the programmed block, clicking the ‘Select Written’ button inversely displays the target block.
3.8 Reading the FLASH ROM Data

1. Display the ‘Upload Image’ dialog box from [Device -> Upload Image…].
2. Enter the start and end addresses.
3. Click the ‘Upload’ button to start reading.
4. When ‘Upload operation complete’ is displayed in the message window, reading is complete.

If the user specifies an Absolute image, the uploaded data will be placed in an image the size of the FLASH memory at the same address it was uploaded from. Use an Absolute Image if the uploaded data needs to be added to the project. It is not possible to upload a region outside of the FLASH into an Absolute Image.

Note When FDT is started in boot mode, the flash memory data has already been erased.
Chapter 4 Configuring the User Interface

When the user interface for FDT was designed an attempt was made to make frequently used operations quickly accessible and have related operations grouped in a logical order. However, when the user is in the middle of a long session he may find it more useful to have a different arrangement of the user interface items. FDT facilitates this user customisation. This chapter describes how the user interface can be arranged and how various aspects of the display can be customised.

4.1 Arranging Windows

Minimising windows

When an operation is finished on an open Editor window but it may be necessary to look at it in its current state later, it can be reduced to an icon, this is called minimising the window. To minimise a window either click on the ‘minimise’ button of the window, or select [Minimise] from the window drop-down menu.

The window is minimised to an icon at the bottom of the Editor window.

Note The icon may not be visible if there is another window open over the bottom of the screen.

To restore the icon back to a window either double click on the icon, or click once to pop up the icon menu and select [Restore], or select required window from the Menu bar [Window] drop-down menu.

Tiling windows

After some time there may be many windows open on the screen. All the windows can be arranged in a tile format with none of them overlapping each other using the “Tile Windows” option. To invoke this select the [Window->Tile Windows] menu option.

All currently open windows are arranged in a tile format. Windows that are minimised to icons are not affected.

4.2 Locating Currently Open Windows

When many windows are open in the FDT application window it is quite easy to lose one of them behind the others.

Locating a specific window

There are two methods to find the lost window.

1. To select a specific window, invoke the [Window] menu. Click on the required window from the list of open windows at the bottom of the menu. The currently selected window will have a check mark next to it in the window list. The window selected will be brought to the front of the display. If it is minimised the icon is restored to a window.

2. If the [Window->Workbook View] menu item is checked, a specific window can also be selected by clicking on the tab containing the file name at the bottom of the Editor window. If the window is not minimised it will be brought to the front of the display. If it is minimised, the minimised icon will be brought to the front of the display.
4.3 Enabling/disabling the Status Bar

The user has the option to enable or disable the Status Bar. By default, the Status Bar is displayed at the bottom of the FDT application window. To disable the display of the Status Bar, select the [View->Status Bar] menu option.

If the disable option is selected, the Status Bar will be disabled and removed from the FDT application window display. To re-enable the Status Bar display, select the [View->Status Bar] menu option again. The Status Bar will be enabled and added to the FDT application window display and the menu option checked.

4.4 Enabling/disabling the Toolbar

The user has the option to enable or disable the Toolbar. By default, the Toolbar is displayed at the top of the FDT application window. To disable the display of the Toolbar, select the [View->Toolbar] menu option.

If the disable option is selected, the Toolbar will be disabled and removed from the FDT application window display. To re-enable the Toolbar display, select the [View->Toolbar] menu option again. The Toolbar will be enabled and added to the FDT application window display and the menu option checked.

4.5 Enabling/disabling the Workspace

The user has the option to enable or disable the Workspace. By default, the Workspace is displayed. To disable display of the Workspace, select the [View->Workspace] menu option.

If the disable option is selected, the Workspace will be disabled and removed from the FDT application window display. To re-enable the Workspace display, select the [View->Workspace] menu option again. The Workspace will be enabled and added to the FDT application window display and the menu option checked.

4.6 Enabling/disabling the Message Log

The user has the option to enable or disable the Message Log. By default, the Message Log is displayed. To disable display of the Message Log, select the [View->Message log] menu option.

If the disable option is selected, the Message log will be disabled and removed from the FDT application window display. To re-enable the Message log display, select the [View->Message log] menu option again. The Message log will be enabled and added to the FDT application window display and the menu option checked.

4.7 Enabling/disabling the Dependency Log

The user has the option to enable or disable the Dependency Log. By default, the Dependency Log is displayed. To disable display of the Dependency Log, select the [View->Dependency Log] menu option.

If the disable option is selected, the Dependency Log will be disabled and removed from the FDT application window display. To re-enable the Dependency Log display, select the [View->Dependency Log] menu option again. The Dependency Log will be enabled and added to the FDT application window display and the menu option checked.
4.8 Customising the Toolbar

The selection and arrangement of buttons displayed on the Toolbar can be customised to suit a user’s requirements. To change the display invoke the [Tools->Customise...] menu option.

The ‘Customise FLASH Development Toolkit’ dialog box will be displayed:

![Customise FLASH Development Toolkit dialog box](image)

The ‘Customise FLASH Development Toolkit’ dialog box has four tabs, Toolbars, Commands, Output Window and General, which are further described in chapter 6, Windows.

**Toolbars**

The Toolbars tab allows the user to select a group (e.g. workspace) and to select the functions for that group.

A check mark in the **Show Tooltips** box indicates that the action of the button will be displayed when the mouse arrow is pointing to the button. If the box is unchecked no action is displayed.

A check mark in the **Cool Look** box removes the border around all menu and toolbar items. If the box is unchecked the borders are present.

If the **Large Buttons** box is checked, the size of the buttons is increased.

The **New...** button launches the ‘Toolbar Name’ dialog box which allows the user to name and generate a new toolbar. After entering the new name and clicking on **OK**, the new name will be added to the Toolbars list and an empty toolbar is displayed on the interface.

Selecting the Commands tab allows the user to select and add buttons to the new toolbar. The user can place the new toolbar anywhere on the GUI by dragging it with the mouse.

When a user created toolbar is selected in the Toolbars list, the **Reset** button is renamed to **Delete**. Clicking on this button will remove the new toolbar from the list and from the GUI.

The **Reset** button resets the selected toolbar to its default settings.
Commands

This tab shows the buttons and describes the action for each button in each group and allows the user to customise the toolbar according to an individual application.

Clicking on an item in the Categories box displays the buttons available for that category.

The Buttons area displays a picture for each button in the selected category.

To obtain a description of the action of a button, click on that button. The description will appear in the Description area.

Adding a button to the Toolbar

To add a button to the Toolbar:

1. Select the button from the appropriate category, by pointing the mouse pointer at the button and press the left mouse button.
2. Drag the button to the required position in the Toolbar.
3. Release the mouse button.

Positioning a button in the Toolbar

To move a button position in the Toolbar order:

1. Select the appropriate button on the Toolbar to move with the mouse as above.
2. Drag the button to the required position on the toolbar.
3. Release the mouse button.

Removing a button from the Toolbar

To remove a button from the Toolbar:

1. Select the button with the mouse as above.
2. Drag the button to the ‘Customise FLASH Development Toolkit’ dialog box.
3. Release the mouse button.
Chapter 5  Menus

This document follows the standard Microsoft menu naming convention:

5.1 File

The ‘File’ menu is used for aspects of the program that access data files.

Open…

Launches the ‘Open’ dialog box allowing the user to open an existing file. The file may be an S-Record file (.rec, .mot, .a20, .a37), a Device Image file (.fpr) or a FDT Workspace file (.fdt).

New Workspace

Launches the ‘New Workspace’ dialog box allowing the user to specify the name and location of a new workspace and creates a new workspace directory.

Open Workspace…

Launches the ‘Open’ dialog box allowing the user to open an existing FDT Workspace file (.fdt).

Save Workspace

Saves the details of the currently active Workspace.

Close Workspace

Closes the currently active Workspace.

Save

Saves the current active file.

Save As…

Launches the ‘Save As’ dialog box allowing the user to save and name the uploaded Device Image file with a .fpr extension, or if an S-Record file is active to rename and save that file.
Save All
Saves all files that have not been saved on the Editor window.

Close File
Closes the current active file.

Recent Workspaces
Provides a cascaded menu listing recently used workspaces allowing the user to select one.

Recent Files
Provides a cascaded menu listing recently used files allowing the user to select one.

Exit
Closes and exits the FDT application.

5.2 Edit
The ‘Edit’ menu is used for aspects of the program that access or alter data in the Editor window.

Undo
Allows the user to reverse the previous editing operation.

Redo
Allows the user to reverse the previous Undo operation.

Create Selection…
Launches the ‘Create Selection’ dialog box allowing the user to create a selection area by entering its start address, end address and length. The selected area can be used in conjunction with the Clipboard, Fill or Search and Replace.

Cut
This will remove the contents of the highlighted block from the window and place it on the clipboard in the standard Windows manner. This option is only available if a block is highlighted.

Copy
This will copy the contents of the highlighted block to the clipboard in the standard Windows manner. This option is only available if a block is highlighted.

Paste
This will copy the contents of the Windows clipboard into the child window at the current cursor position.

Note   If more than one byte is selected, the Paste option is not available.
Find…
This will launch the ‘Find’ dialog box allowing the user to enter either hexadecimal or ASCII data. The scope of the search is bounded by the area selected, for the active file in the Editor window. If a match is found, the Editor window is updated to display the found data.

Replace…
This will launch the ‘Replace’ dialog box allowing the user to enter either the hexadecimal or ASCII data to be found and the replacement data, in the same format. The scope of the search is bounded by the area selected, for the active file in the Editor window. If a match is found, the Editor window is updated to display the found data, click on the now enabled Replace button to replace the data.

5.3 View
The ‘View’ menu is used to display or remove FDT GUI features, such as displaying child windows and toolbars.

Toolbar
Toggles the toolbar feature on and off. If the feature is active then a check mark will be displayed to the left of the menu text.

Status Bar
Toggles the status bar feature on and off. If the feature is active then a check mark will be displayed to the left of the menu text.

Workspace
Toggles the Workspace on and off. If the feature is active then a check mark will be displayed to the left of the menu text.

Message Log
Toggles the Message Log on and off. If the feature is active then a check mark will be displayed to the left of the menu text.

Dependency Log
If this item is checked, the Dependency Log is available as a tab for the Output window.

5.4 Project
The ‘Project’ menu provides high level control and facilities for projects within the workspace.

New Project…
Launches the ‘Project Wizard’ dialog box allowing the user to create a new project and enter any comments. When an FDT project is created all its project details are maintained in a project file. The project file is named after the project with a file extension of .cpp.
Add Files to Project…
Launches the ‘Open’ dialog box allowing the user to add S-Record files (.rec, .mot, .a20, .a37) to the project.

Remove File from Project…
Removes the selected file from the project.

Set Active Project
Provides a cascaded menu listing projects within the currently open workspace allowing the user to designate one as the active project.

Insert Project…
Launches the ‘Open’ dialog box allowing the user to open FDT created Projects (.cpj files).

Build Device Image
Builds the target files into a binary image file (Device Image) for subsequent downloading to the target FLASH memory.

Download Device Image
Loads the open Device Image file into the target FLASH memory.

Freshen all Target files
Updates the files contained in project to the current contents of their original source files.

Properties…
Launches the ‘Project Properties’ dialog box for the current project. This dialog box contains seven tabs - Project, Kernel, Communications, Device, Programmer, Modules and Comments. Double clicking on an item may allow the value to be edited.

5.5 Device
The ‘Device’ menu provides control facilities for interacting with the target device.

Connect to Device/Disconnect from Device
This connects the GUI to the device if it is not connected or disconnects if it is connected. Messages will appear in the Message log if the connection can not be made. The Status Bar will indicate whether or not the device is connected.

Erase FLASH blocks…
This launches the ‘Erase Blocks’ dialog box.

The ‘Erase Blocks’ dialog box allows the user to specify which blocks are to be erased. The Written column indicates whether data is present in the block.

To start the operation, select the required block names in the list and then click the Erase button.

Note Whilst blocks that contain no data need not be erased. FDT will erase all specified blocks.
Upload Image...

This launches the ‘Upload Image’ dialog box, which enables the uploading of a range of data from the target device. This is intended for access with FLASH memory. The data is placed in the Editor window.

Blank check

This launches a blank check on the device FLASH and reports back both to the Message log and a status window.

Download ‘file name’

This downloads the current active file into the target FLASH memory.

User Boot Area

This menu is enabled for 0.18\(\text{m}\) devices. When User Boot Area is selected (enabled), FDT specifies to write the data to the this area of flash ROM, to upload image and to blank check in the user boot area of the 0.18\(\text{m}\) device before programming. The User Boot Area may be used to provide user defined boot sequences different from the factory sequence.

Cancel FLASH Operation

Cancels the current FLASH operations of Download, Upload, Erase or a connection attempt, if they are active.

5.6 Image

The ‘Image’ menu provides facilities for displaying and maintaining the contents of the active file in the Editor window.

Fill...

Launches the ‘Fill’ dialog box for the currently active file, allowing a selected area to be filled with the specified data. The data to be filled can be an ASCII character via the ASCII Fill check box.

View ASCII

Toggles the ASCII representation of the data On and Off.

View as Bytes

Allows the user to view the data as 8 bit bytes.

View as Words

Allows the user to view the data as 16 bit words.

View as DWords

Allows the user to view the data as 32 bit double (long) words.

Align to 8 Bytes

Data is displayed on each line as 8 bytes. The number of bytes that can be accommodated on each line is dependent upon the size of the window.
Download ‘file name’
Downloads the current active file into the target FLASH memory.

5.7 Tools
The ‘Tools’ menu is used to launch additional FDT features, which are not related to either projects or target devices.

Simple Interface…
Writes the created project to the flash memory by using one button.

UPB Diagnostics…
(Feature not currently available)

JTAG Development System…
(Feature not currently available)

Advanced Configuration…
(Feature not currently available)

Kernel Build Assistant…
(Feature not currently available)

Customise…
Launches the ‘Customise FLASH Development Toolkit’ dialog box allowing the user to customise the toolbar and commands.

5.8 Window
The ‘Window’ menu is used to alter the display of currently open windows within the FDT GUI. Files displayed in the Editor window are appended to the following list, these files are identified by their filename and the currently active file is denoted by check mark.

Workbook View
If the Workbook View is checked, tabs for each current window are located at the bottom of the Editor window. If it is unchecked the tabs are hidden. Clicking on a tab will make that file active.

Docking Views
With this option checked the Workspace window and the Editor window are positioned side by side. With the option unchecked the Editor window is positioned behind the Workspace window. Clicking on a window will bring it to the top of the display.
Tile Windows

Arranges the child windows in the standard tile manner, i.e. each window is sized such that all are displayed without overlapping.

‘file name’

This option becomes active when a file name is selected and checked.

5.9 Help

The ‘Help’ menu is used to access additional information on how to use the functionality provided by FDT.

Help Topics

Launches the Help system for FDT. The ‘Help Topics’ dialog box for FDT is displayed, enabling help to be accessed on required FDT subjects through several methods.

About…

Launches the ‘About FLASH Development Toolkit’ dialog box, through which additional information regarding FDT can be accessed:

- FDT version.
- Library descriptions, build dates and versions for each of the FDT components.
- FDT supported communication interfaces.
- Submit Bug Report.
Chapter 6  Windows

This chapter describes each child window type, the features each supports and the options available through their associated pop-up menus.

There are three main windows - Workspace window, Editor window and Output window.

Most windows have local pop-up menus in order to make commonly used features easier to access. These menus are invoked by clicking the right mouse button within the window (or pressing \texttt{SHIFT+F10}) and then selecting the required menu option.

Windows may also be launched from a number of the main menu items.

6.1  Workspace window

The Workspace window contains details of the items in the workspace including the workspace name, projects contained in the workspace and for each project their Device Image files and Target files.

Invoking certain menu items from a pop-up menu in the Workspace window will launch additional windows.

The Workspace window pop-up menu has the following items:

Docking View

With this option checked the Workspace window and the Editor window are positioned side by side. With the option unchecked the Editor window is positioned behind the Workspace window, such that the Workspace window is a floating window. Clicking on a window will bring it to the top of the display.

Hide

Invoking \texttt{Hide} conceals the Workspace window. It is restored by [\texttt{View->Workspace}].
6.2 Workspace

The Workspace is the first item in the window, in the following example this is “Workspace ‘Industrial Controller’”:

The pop-up menu for Workspace has the following items:

New Project…

Launches the ‘Project Wizard’ dialog box allowing the user to create a new project and enter project comments.

Insert Project into Workspace…

Launches the ‘Open’ dialog box allowing the user to insert an existing project into the Workspace.

Open Workspace…

Launches the ‘Open’ dialog box allowing the user to open an existing FDT Workspace file (.fdt). This will close an open Workspace and load the specified replacement.

Save Workspace

Saves the details of the current workspace and its project(s).

Close Workspace

Closes the current workspace.
Properties...

Launches the ‘Workspace Properties’ dialog box which shows the following details:

- the Workspace Name,
- its filename and path,
- the time and date when the workspace was last saved,
- if the workspace has been modified and not yet saved,
- the number of projects in the workspace,
- the name of the current active project.

6.3 Project

The Project is the next item in the hierarchy below the Workspace. In the following example, both “Display” and “Motor Control” are Project names.

![Image of workspace with project and pop-up menu]

The pop-up menu for Project has the following items:

Add Files to Project…

Launches the ‘Open’ dialog box allowing the user to add S-Record files to the project.

Set as Active Project

Sets the highlighted project as the active project.

Remove Project

Remove the highlighted project from the Workspace.

Connect to Device / Disconnect

This connects the GUI to the device if it is not connected or disconnects if it is connected. Messages will appear in the Message log if the connection can not be made. The Status Bar will indicate whether or not the device is connected.
Erase FLASH blocks…

This launches the ‘Erase Blocks’ dialog box.

The ‘Erase Blocks‘ dialog box allows the user to specify which blocks are to be erased. The Written column indicates whether data is present in the block.

To start the operation, select the required block names in the list and then click the Erase button.

Note: Whilst blocks that contain no data need not be erased, FDT will erase all specified blocks.

Upload Image…

This launches the ‘Upload Image‘ dialog box, which enables the uploading of a range of data from the target device.

Blank check

This launches a blank check on the device FLASH and reports back both to the Message log and a status window.

Cancel FLASH Operation

Cancels the current FLASH operations of Download, Upload, Erase or connection attempt, if they are active.

Build Device Image

Builds the target files into a binary image file (Device Image) for subsequent downloading to the target FLASH memory.

Freshen all Target files

Updates the files contained in project with the current contents of their original source files.

Properties…

Launches the ‘Project Properties‘ dialog box for the current project. This dialog box contains seven tabs - Project, Kernel, Communications, Device, Programmer, Modules and Comments. Double clicking on an item may allow the value to be edited.
6.4 **Device Image - Sub Folder**

This contains the Device Image file the project.

The Device Image - Sub Folder pop-up menu has the following items:

**Build Device Image**

Builds the target files into a binary image file (Device Image) for subsequent downloading to the target FLASH memory.

**Freshen all Target files**

Updates the files contained in project with the current contents of their original source files.

**Properties…**

Launches the ‘Project Properties’ dialog box for the current project. This dialog box contains seven tabs - Project, Kernel, Communications, Device, Programmer, Modules and Comments. Double clicking on an item may allow the value to be edited.

6.5 **Device Image - Sub-Project Properties**

With the ‘Project Properties’ dialog box invoked from the Device Image - Sub Folder pop-up menu, clicking the left mouse button will launch the ‘Sub-Project Properties ‘Device Image’” dialog box.
6.6 Target files - Sub Folder

This contains the S-Record files for the project that will be used to build the Device image.

The Target files - Sub Folder pop-up menu has the following items:

Add Files to Project…
Launches the ‘Open’ dialog box allowing the user to add S-Record files to the project.

Freshen all Target files
Updates the files contained in project with the current contents of their original source files.

Properties…
Launches the ‘Project Properties’ dialog box for the current project. This dialog box contains seven tabs - Project, Kernel, Communications, Device, Programmer, Modules and Comments. Double clicking on an item may allow the value to be edited.

6.7 Target files - Sub-Project Properties

With the ‘Project Properties’ dialog box invoked from the Target file - Sub Folder pop-up menu, clicking the left mouse button will launch the ‘Sub-Project Properties “Target files”’ dialog box.
6.8 Device Image

The Device Image is the item contained in Device Image - Sub Folder. In the following example, “Display.fpr” is the Device Image file for the project “Display”.

The pop-up menu for Device Image has the following items:

**Edit**
Displays the Device Image file in the Editor window to allow the user to carry out modifications.

**Remove File from Project**
Removes the device image file from the project.

**Block usage…**
Launches the ‘Device Image Properties’ dialog box and displays the Block usage tab.

**Rebuild Image**
Rebuilds the binary image file (Device Image) with its constituent target files, for subsequent downloading to the target FLASH memory.

**Download Image to Device**
Downloads the Device Image to the device FLASH memory.

**Properties…**
Launches the ‘Device Image Properties’ dialog box. This contains three tabs - File properties, Dependencies and Block usage.
6.9 S-Record Files

S-Record files are the items contained in Target files - Sub Folder. In the following example, “LCD.mot”, “Keyboard.mot” and “Comms.mot” are target files for the project “Display”.

Each S-Record file pop-up menu has the following items:

**Edit**
Displays the S-Record file in the Editor window to allow the user to carry out modifications.

**Remove File from Project**
Removes the selected S-Record file from the project.

**Download File to Device**
Downloads the selected S-Record file to the device FLASH memory.

**Freshen Local File**
Updates the files contained in project with the current contents of their original source files.

**Properties…**
Launches the ‘S-Record Properties’ dialog box. This contains three tabs - File properties, Dependency and Block usage.

6.10 Workspace Properties

Invoked from the Workspace pop-up menu item **Properties…**.

The ‘Workspace Properties’ dialog box shows details of:

- the Workspace Name,
- its filename and path,
- the time and date when the workspace was last saved.
• if the workspace has been modified and not yet saved,
• the number of projects in the workspace,
• the name of the current active project.

6.11 Project Properties

The ‘Project Properties’ dialog box can be invoked from the Properties… item of the pop-up menus in Project, Device Image - Sub Folder, Target files - Sub Folder, and also the main menu [Project->Properties…].

Project

This shows the name of the project, the location and the filename of the project file, its creation date and time, and also the target device and configuration file.
Kernel

This shows the frequency, protocol, multiplier, and clock mode.

Communications

This shows the default and current baud rates and the current port. It also allows the user to change the Port and Baud Rate.

COM Port

This drop-down list provides the user with a list of supported COM ports available for connection to the device. This list includes the USB port.

Use default baud

If this is checked, the default Baud Rate will be used. (This option should be set only when the HMSE Evaluation Board or Evaluation Development Kit is used.)

Target Baud Rate

If the Use default baud is unchecked, the Target Baud Rate provides a drop-down list of Baud Rates between 2400 and 115200 bits/s for the user to select.
Device

This shows the device information. It also allows the user to select **BOOT Mode** or **USER Program Mode** and the ‘Direct Connection’ interface. In addition, it can specify whether or not the kernel is in the target device.

**BOOT Mode**

This connection type specifies that the on-board programming BOOT mode sequence is to be initiated if a kernel cannot be found running on the target device. This will cause the entire FLASH memory to be erased and a kernel loaded.

If a kernel is already resident the FLASH is not erased, rather information regarding the block usage is obtained to help prevent accidental overwriting.

**USER Program Mode**

This connection type specifies that the on-board programming USER Program mode sequence is to be initiated by a previously loaded user program that is used to reprogram the FLASH memory.

**Select Interface**

If the target is connected directly to the host computer, the connection interface should be selected to ‘Direct Connection’.

**Kernel already resident**

This check box is specified when a main kernel is already resident on the target device.
Programmer

This shows the state of the Function Map and allows the user to select the Device Protection Option of Automatic, Interactive, or None and the message level option of Advanced or Standard.

Device Protection

This allows the user to select either automatic protection (Automatic) or interactive protection (Interactive) to protect the FLASH device from accidental over-erasure and over-programming. Automatic protection will erase blocks from the device prior to programming, as necessary. Interactive protection will ask the user before an erase occurs. FDT can be forced to write to a block containing data. In addition, None can be selected to disable device protection.

Whilst connected to a device FDT keeps track of the state of the FLASH blocks and is able to determine when a programming operation will over-program a region of FLASH memory.

Note If device protection is disabled the user is responsible for erasing the device prior to programming.

Message level

The user can select either Standard or Advanced message levels. A Standard message level generates general FDT/target device status messages regarding high-level communications details. An Advanced message level generates more detailed information regarding lower level communications details.
Modules
This shows each Kernel file name.

Comments
This allows the user to insert any project comments. Clicking with the right mouse button provides a drop-down menu for editing facilities.

Undo
Reverses the last edit operation in the Comment window.

Cut
Removes the selected text in the Comment window and places it in the Windows® clipboard.

Copy
Copies the selected text in the Comment window to the Windows® clipboard.

Paste
Pastes the contents of the Windows® clipboard into the Comment window at the cursor position.

Delete
Deletes the selected text in the Comment window.
Select All
Selects all the text in the Comment window.

6.12 Device Image Properties

Invoked from the Device Image pop-up menu item ‘Properties...’.

File properties

The ‘Device Image Properties’ dialog box shows details of the Device Image location and its filename, the time and date the image file was last saved, if the image file has been modified and not yet saved, if the image file is currently open in the Editor window, and also the FLASH memory size.

Dependencies

This shows the S-Record files and their status associated with the Device image.

Rebuild Now

If the device image is out of date as indicated by the general device image status message, it can be rebuilt by clicking on this button.
Block usage

This shows the starting, finishing address and sizes of the blocks contained in specified file.

If the file is open in the editor window, double clicking on a range highlights the selected data.
6.13 S-Record Properties

The 'S-Record Properties' dialog box is invoked from the S-Record pop-up menu item 'Properties…' and the Editor window pop-up menu option 'Properties…' and contains three tabs:

File properties

The ‘S-Record Properties’ dialog box shows details of the S-Record filename and its location, the time and date the file was last saved, if the file has been modified and not yet saved, and also if the file is currently open in the Editor window, and also the FLASH memory size.

Dependencies

This shows the S-Record File, whether it has dependencies, and if it has, the Dependency path. Clicking on Change… launches the ‘Open’ dialog box that allows the user to select a new path. The Dependency tab also shows if the S-Record file is up-to-date and when the file and the Dependency were last modified.
Block usage

This shows the starting, finishing address and size of the blocks contained in specified file.

If the file is open in the editor window, double clicking on a range highlights the selected data.

6.14 Output Window

The Output window is one of the main windows contained in the FDT GUI.

The window has available pop-up menu that contains the following items:

Copy
Copies the contents of the active log to the Windows® clipboard.

Clear Messages
Clears the active log.

Save Messages...
Launches the ‘Save As’ dialog box allowing the user to save the contents of the active log in the Output window as a .txt file.

Allow Docking
With this option checked the Output window is capable of being docked within the FDT application window. With the option unchecked the Output window is a floating window.

Hide
Invoking Hide conceals the Message log. It is restored by [View->Message log].
6.15 Editor Window

The Editor window is one of the main windows contained in the FDT GUI.

The window has available pop-up menu that contains the following items:

Cut
This will remove the contents of the highlighted block from the window and place it on the clipboard in the standard Windows® manner. This is only available if a block is highlighted.

Copy
This will copy the contents of the highlighted block to the clipboard in the standard Windows® manner. This is only available if a block is highlighted.

Paste
This will copy the contents of the Windows® clipboard into the child window at the current cursor position.

Note If more than one byte is selected, the Paste option is not available.
Undo
Reverses the last editing operation on the selected data.

Redo
Reverses the last undo operation.

Display Unit
Invokes the cascaded menu as follows:

- **Byte** - view the data as 8-bit bytes.
- **Word** - view the data as 16-bit words.
- **DWord** - view the data as 32-bit double words.

Align to 8 Bytes
Data is displayed on each line as 8 bytes. The number of bytes that can be accommodated on each line is dependent upon the size of the window.

Create Selection…
Launches the ‘Create Selection’ dialog box allowing the user to create a selection area by entering its start address, end address and length. The selected area can be used in conjunction with the Clipboard, Fill or Search and Replace.

Fill…
Launches the ‘Fill’ dialog box for the current active file to write the specified data to the selected area. When the ‘ASCII Fill’ check box is selected, the data to be written can be specified with ASCII characters.

Find…
This will launch the ‘Find’ dialog box allowing the user to enter either hexadecimal or ASCII data. The scope of the search is bounded by the area selected, for the active file in the Editor window. If a match is found, the Editor window is updated to display the found data.

Replace…
This will launch the ‘Replace’ dialog box allowing the user to enter either the hexadecimal or ASCII data to be found and the replacement data, in the same format. The scope of the search is bounded by the area selected, for the active file in the Editor window. If a match is found, the Editor window is updated to display the found data, click on the now enabled Replace button to replace the data.

Properties…
Launches the ‘S-Record Properties’ dialog box. Double clicking on an item may allow the value to be edited.
6.16 Erase Blocks

Invoked by [Device->Erase FLASH blocks...], the Workspace Project pop-up menu item Erase FLASH blocks…, the Toolbar Erase Blocks and the Erase FLASH blocks… command from the FLASH Controller.

The ‘Erase Blocks’ dialog box allows the user to specify which blocks to erase. The Written column indicates whether data exists in the block.

Select All

Clicking on Select All will select all the blocks of the device FLASH memory.

Select Written

Clicking on Select Written will select only those blocks that are not empty.

Erase

Clicking on Erase will erase the data in the selected blocks and removes the ‘Erase Block’ dialog box.

Cancel

Clicking on Cancel removes the ‘Erase Blocks’ dialog box without performing an erase operation.

Note  Whilst blocks that contain no data need not be erased, FDT will erase all the specified blocks.
6.17 Customise - Toolbars

Invoked by [Tools->Customise…] in the ‘Customise FLASH Development Toolkit’ dialog box.

Show Tooltips

A check mark in the Show Tooltips box indicates that the action of the button will be displayed when the mouse arrow is pointing to the button. If the box is unchecked, no action is displayed.

Cool Look

A check mark in the Cool Look box removes the border around all menu and toolbar items. If the box is unchecked, the borders are visible.

Large Buttons

Checking the Large Buttons box increases the size of the buttons.

New…

The New… button launches the ‘Toolbar Name’ dialog box which allows the user to name and generate a new toolbar. After entering the new name and clicking on OK, the new name will be added to the Toolbars list and an empty toolbar is displayed on the interface.

Selecting the Commands tab allows the user to select and add buttons to the new toolbar. The user can place the new toolbar anywhere on the GUI by dragging it with the mouse.

Reset

The Reset button resets the toolbar to the default.
Toolbar name

Reflects the toolbar selected in the list.

OK

Clicking on **OK**, in the ‘Toolbar Name’ dialog box adds the new name to the Toolbars list on the Toolbars window and invokes a blank toolbar on the GUI.

Clicking on **OK** in the ‘Customise FLASH Development Toolkit’ dialog box saves any changes made and closes the dialog box.

Delete

If a new toolbar has been added to the Toolbars list and it is selected, the **Reset** button is renamed to **Delete**. Clicking on this button will remove the new toolbar from the list and from the GUI.

Cancel

Clicking on **Cancel** removes the ‘Customise FLASH Development Toolkit’ dialog box without saving any changes made.

6.18 Customise - Commands

Invoked by [Tools->Customise...] and then select the Commands tab in the ‘Customise FLASH Development Toolkit’ dialog box.

![Customise FLASH Development Toolkit dialog box]

Categories

Clicking on a Category from the list displays the buttons available for that category.
**Buttons**

The **Buttons** area displays a picture of each button available for the selected category.

**Description**

To obtain a description of the action of a button, click on that button.

**OK**

Clicking on **OK** removes the ‘Customise FLASH Development Toolkit’ dialog box and saves any changes made.

**Cancel**

Clicking on **Cancel** removes the ‘Customise FLASH Development Toolkit’ dialog box without saving any changes made.

**6.19 Customise – Output Window**

Invoked by [Tools->Customise...] and then select the Output Window tab in the ‘Customise FLASH Development Toolkit’ dialog box.
Messages

*Change Colour*

Clicking on **Change Colour**... invokes the ‘Colour’ dialog box. This button allows the colour of the message to be changed.

*Change Font*

Clicking on **Change Font**... invokes the ‘Font’ dialog box. This button allows the font of the message to be changed.

*Tabs*

*Change Font*

Clicking on **Change Font**... invokes the ‘Font’ dialog box. This button allows the font of the message-window tab to be changed.

**OK**

Clicking on **OK** saves any changes made and closes the ‘Customise FLASH Development Toolkit’ dialog box.

**Cancel**

Clicking on **Cancel** closes the ‘Customise FLASH Development Toolkit’ dialog box without saving any changes made.
6.20 Customise - General

Invoked by [Tools->Customise...] and then select the General tab in the ‘Customise FLASH Development Toolkit’ dialog box.

Programming

Read-back verification

The options are that it will prompt to determine if a read-back verification takes place (Query) or that it always will verify (Yes) or never (No).

Reset on disconnect

(Feature not currently available)

Automation

Reload last Workspace at startup

Checking this option allows the last used Workspace to be loaded when running FDT.

Download active project Device Image at startup

Checking this option allows FDT to automatically write the device image of the active project to the FLASH memory.

OK

Clicking on OK closes the ‘Customise FLASH Development Toolkit’ dialog box and saves any changes made.
Cancel

Clicking on **Cancel** closes the ‘Customise FLASH Development Toolkit’ dialog box without saving any changes made.

### 6.21 Simple Interface

Invoked by **[Tools->Simple Interface…]**. Clicking on **EXIT** displays the previous screen.

**Flash Program**

Clicking on **Flash Program** allows FDT to download the specified file to the FLASH memory.

**Note**  The Alt-C keyboard shortcut is available for connecting and disconnecting from the device whilst in Simple Interface Mode.