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ご注意書き 

 

１． 本資料に記載されている内容は本資料発行時点のものであり、予告なく変更することがあります。当社製品

のご購入およびご使用にあたりましては、事前に当社営業窓口で最新の情報をご確認いただきますとともに、

当社ホームページなどを通じて公開される情報に常にご注意ください。 
2. 本資料に記載された当社製品および技術情報の使用に関連し発生した第三者の特許権、著作権その他の知的

財産権の侵害等に関し、当社は、一切その責任を負いません。当社は、本資料に基づき当社または第三者の

特許権、著作権その他の知的財産権を何ら許諾するものではありません。 
3. 当社製品を改造、改変、複製等しないでください。 
4. 本資料に記載された回路、ソフトウェアおよびこれらに関連する情報は、半導体製品の動作例、応用例を説

明するものです。お客様の機器の設計において、回路、ソフトウェアおよびこれらに関連する情報を使用す

る場合には、お客様の責任において行ってください。これらの使用に起因しお客様または第三者に生じた損

害に関し、当社は、一切その責任を負いません。 
5. 輸出に際しては、「外国為替及び外国貿易法」その他輸出関連法令を遵守し、かかる法令の定めるところに

より必要な手続を行ってください。本資料に記載されている当社製品および技術を大量破壊兵器の開発等の

目的、軍事利用の目的その他軍事用途の目的で使用しないでください。また、当社製品および技術を国内外

の法令および規則により製造・使用・販売を禁止されている機器に使用することができません。 
6. 本資料に記載されている情報は、正確を期すため慎重に作成したものですが、誤りがないことを保証するも

のではありません。万一、本資料に記載されている情報の誤りに起因する損害がお客様に生じた場合におい

ても、当社は、一切その責任を負いません。 
7. 当社は、当社製品の品質水準を「標準水準」、「高品質水準」および「特定水準」に分類しております。また、

各品質水準は、以下に示す用途に製品が使われることを意図しておりますので、当社製品の品質水準をご確

認ください。お客様は、当社の文書による事前の承諾を得ることなく、「特定水準」に分類された用途に当

社製品を使用することができません。また、お客様は、当社の文書による事前の承諾を得ることなく、意図

されていない用途に当社製品を使用することができません。当社の文書による事前の承諾を得ることなく、

「特定水準」に分類された用途または意図されていない用途に当社製品を使用したことによりお客様または

第三者に生じた損害等に関し、当社は、一切その責任を負いません。なお、当社製品のデータ・シート、デ

ータ・ブック等の資料で特に品質水準の表示がない場合は、標準水準製品であることを表します。 
標準水準： コンピュータ、OA 機器、通信機器、計測機器、AV 機器、家電、工作機械、パーソナル機器、

産業用ロボット 
高品質水準： 輸送機器（自動車、電車、船舶等）、交通用信号機器、防災・防犯装置、各種安全装置、生命

維持を目的として設計されていない医療機器（厚生労働省定義の管理医療機器に相当） 
特定水準： 航空機器、航空宇宙機器、海底中継機器、原子力制御システム、生命維持のための医療機器（生

命維持装置、人体に埋め込み使用するもの、治療行為（患部切り出し等）を行うもの、その他

直接人命に影響を与えるもの）（厚生労働省定義の高度管理医療機器に相当）またはシステム

等 
8. 本資料に記載された当社製品のご使用につき、特に、最大定格、動作電源電圧範囲、放熱特性、実装条件そ

の他諸条件につきましては、当社保証範囲内でご使用ください。当社保証範囲を超えて当社製品をご使用さ

れた場合の故障および事故につきましては、当社は、一切その責任を負いません。 
9. 当社は、当社製品の品質および信頼性の向上に努めておりますが、半導体製品はある確率で故障が発生した

り、使用条件によっては誤動作したりする場合があります。また、当社製品は耐放射線設計については行っ

ておりません。当社製品の故障または誤動作が生じた場合も、人身事故、火災事故、社会的損害などを生じ

させないようお客様の責任において冗長設計、延焼対策設計、誤動作防止設計等の安全設計およびエージン

グ処理等、機器またはシステムとしての出荷保証をお願いいたします。特に、マイコンソフトウェアは、単

独での検証は困難なため、お客様が製造された最終の機器・システムとしての安全検証をお願いいたします。 
10. 当社製品の環境適合性等、詳細につきましては製品個別に必ず当社営業窓口までお問合せください。ご使用

に際しては、特定の物質の含有･使用を規制する RoHS 指令等、適用される環境関連法令を十分調査のうえ、

かかる法令に適合するようご使用ください。お客様がかかる法令を遵守しないことにより生じた損害に関し

て、当社は、一切その責任を負いません。 
11. 本資料の全部または一部を当社の文書による事前の承諾を得ることなく転載または複製することを固くお

断りいたします。 
12. 本資料に関する詳細についてのお問い合わせその他お気付きの点等がございましたら当社営業窓口までご

照会ください。 
 
注 1. 本資料において使用されている「当社」とは、ルネサスエレクトロニクス株式会社およびルネサスエレク

トロニクス株式会社がその総株主の議決権の過半数を直接または間接に保有する会社をいいます。 
注 2. 本資料において使用されている「当社製品」とは、注 1 において定義された当社の開発、製造製品をいい

ます。 
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ご注意

1. 本書に記載の製品及び技術のうち「外国為替及び外国貿易法」に基づき安全保障貿易管理関連貨物・技術に該
当するものを輸出する場合，または国外に持ち出す場合は日本国政府の許可が必要です。

2. 本書に記載された情報の使用に際して，弊社もしくは第三者の特許権，著作権，商標権，その他の知的所有権
等の権利に対する保証または実施権の許諾を行うものではありません。また本書に記載された情報を使用した
事により第三者の知的所有権等の権利に関わる問題が生じた場合，弊社はその責を負いませんので予めご了承
ください。

3. 製品及び製品仕様は予告無く変更する場合がありますので，最終的な設計，ご購入，ご使用に際しましては，
事前に最新の製品規格または仕様書をお求めになりご確認ください。

4. 弊社は品質・信頼性の向上に努めておりますが，宇宙，航空，原子力，燃焼制御，運輸，交通，各種安全装置，
ライフサポート関連の医療機器等のように，特別な品質・信頼性が要求され，その故障や誤動作が直接人命を
脅かしたり，人体に危害を及ぼす恐れのある用途にご使用をお考えのお客様は，事前に弊社営業担当迄ご相談
をお願い致します。

5. 設計に際しては，特に最大定格，動作電源電圧範囲，放熱特性，実装条件及びその他諸条件につきましては，
弊社保証範囲内でご使用いただきますようお願い致します。
保証値を越えてご使用された場合の故障及び事故につきましては，弊社はその責を負いません。
また保証値内のご使用であっても半導体製品について通常予測される故障発生率，故障モードをご考慮の上，
弊社製品の動作が原因でご使用機器が人身事故，火災事故，その他の拡大損害を生じないようにフェールセー
フ等のシステム上の対策を講じて頂きますようお願い致します。

6. 本製品は耐放射線設計をしておりません。

7. 本書の一部または全部を弊社の文書による承認なしに転載または複製することを堅くお断り致します。

8. 本書をはじめ弊社半導体についてのお問い合わせ，ご相談は弊社営業担当迄お願い致します。



はじめに

本マニュアルについて
本マニュアルは、日立 FLASH開発ツールキット（以下 FDTと略します）の使用法について説明します。
第１章「概要」では、本ツールの概要について簡単に紹介し、おもな特長を示します。
第２章「システムの概要」では、FDTグラフィカルユーザインタフェースの機能構成を説明します。
第３章「基本操作」では、FDTの起動からフラッシュ ROMへの書き込みまでを簡単に説明します。
第４章「ユーザインタフェースの設定」では、FDTグラフィカルユーザインタフェースをカスタマイズする
方法を説明します。
第５章「メニュー」と第６章「ウィンドウ」の各章は、それぞれの操作方法や機能を説明しています。

前提
本マニュアルでは、ユーザに、IBM-PC互換コンピュータでのWindowsアプリケーションの使用経験がある

ことを前提としています。

マニュアルの表記法
本マニュアルには、以下の表記法を用います。

表 1　表記法
表記 意味

[Menu->MenuOption] ‘->’の付いた太字は、メニューオプションを示します
（例： [File->Save As...])。

‘ダイアログ名’ 引用符‘’は、ダイアログボックスやメニューの名前を示します。

FILENAME.C 大文字の名前は、ファイル名を示します。

“文字列の入力” 下線は入力する文字列を示します
（引用符“ ”は除く）。

Key+Key キー入力を示します。たとえば、CTRL+N は、CTRLキーを押したまま
Nキーを押すことを意味します。

Ü

（操作方法記号）

この記号が左端にあるとき、右の文章は操作方法を示します。

IBM は米国 International Business Machines Corporationの登録商標です。
Windowsは米国 Microsoft Corporationの登録商標です。
F-ZTATは(株)日立製作所の商標です。
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1 概要

日立 FLASH 開発ツールキット(FDT)は、高機能でかつ使い勝手の良いグラフィカルユーザインタ
フェースをもつ日立 F-ZTATマイコン用オンボード FLASH書き込みツールです。

FDTは、Hitachi Embedded Workshop(HEW)とともに使用することで、日立の F-ZTATマイコンを使
用している組み込みソフトウェア開発者に一貫した環境を提供します。

また、FDTは汎用の Sレコード形式またはバイナリファイルのエディタとして使用することもで
きます。

1.1 おもな特長
32ビットWindows GUIに基づく標準的なウィンドウ操作
充実したオンラインヘルプ機能
メッセージ出力レベルを選択可能
アダプタボードによる容易な書き込み環境
最大 115200bit/sのシリアル通信
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2 システムの概要

FDTはモジュール方式のソフトウェアシステムで、それぞれのタスクに独立したモジュールを使用します。
これらのモジュールは汎用グラフィカルユーザインタフェースへリンクされており、これにより、システムを
構成するモジュールに関係なく共通した操作性が得られます。

FDTは階層構造をとっており、論理的に構成できるようになっています。最上位は、ワークスペースです。

FDTを使用するには、ワークスペースにプロジェクトが少なくとも１つ含まれている必要があります。プロ
ジェクトを作成する前に、ワークスペースを作成します。

プロジェクト作成時に、それぞれのプロジェクト特定のターゲットデバイス情報の設定とデバイスに書き込
む際に用いるターゲットファイル（Sレコードまたはバイナリ）の指定を行ないます。

ターゲットデバイスに接続するためのプロジェクトの設定は、一度行なってしまえば、セッションを変えて
もそのまま保存されます。

ワークスペース内では、プロジェクトは常に１つだけアクティブになります。Deviceメニュー、Projectメニ
ュー、Project ツールバーは、すべてアクティブなプロジェクトに対してのみ機能します。

プロジェクトを作成したあと、ターゲットファイルを指定できます。ターゲットファイルは以下のように用
いられます。

デバイスの書き込みに用いる
デバイスイメージをビルドするのに用いる
バイナリエディタで開く

プロジェクトに指定したファイルは、コピー元の場所から自動的にコピーされます。コピーの際、依存性リ
ンクが作成されるので、元ファイルが変更された場合、プロジェクト内のコピー版のファイルをユーザの指示
により更新できます。

プロジェクトを用いると、次のような FDTの便利な機能を使うことができます。

ターゲットファイルの依存性チェック
高度なメッセージレベル
デバイスイメージビルダ
ターゲットデバイスからのデータのアップロード
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2.1 ユーザインタフェース
FDTグラフィカルユーザインタフェースは、Windows対応のアプリケーションで、フラッシュメモリに書き

込むための作業環境を提供します。

図 2.1　FDTグラフィカルユーザインタフェース

メニューバー
メニューバーでは、コマンドがいくつかのグループに分類されて、関連するメニュータイトルに割り当
てられています。ユーザはマウスを用いてコマンドを選択したり、ダイアログボックスやウィンドウを
呼び出してシステムの動作を指示することができます。メニュータイトル上でマウスの左ボタンをクリ
ックすると、プルダウンメニューが開きます。ここからメニューオプションを選択できます。

メニューオプションによっては、すぐに動作を行なわず、ダイアログボックスやウィンドウを開いて、
ユーザに指示を求めるものもあります。このようなメニューオプションは、名前のうしろに省略記号
（３つのピリオド：…）がついています。

ショートカットキー（複数のキーの組み合わせ）で呼び出せるメニューオプションもあります。この場
合、メニューオプションの右側に、ショートカットキーが表示されます。

ワーク
スペース
ウィンドウ

エディタ
ウィンドウ

メニューバー

ツールバー

ステータス
バー

メッセージ
ログ
ウィンドウ
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機能のオン／オフを切り替えるメニューオプションの場合、その機能がオン（有効）になっていると、
メニューオプションの横にチェックマーク（ü）が表示されます。

メニューオプションの横に三角記号（8）がついているものは、カスケード（階層）メニューを使用で
きます。メニューオプションをクリックすると、カスケードメニューが表示されます。

キーボードから直接メニューを選択することもできます。ALTキーを押しながら、メニューオプショ
ン名の下線部の文字または数字のキーを押すと、メニューが選択できます。たとえば、プロジェクトを
開く場合（[File->Open]）、ALTキーを押しながらFキー、Oキーの順に押します。

ツールバー
FDTでは、メニューバーの下に、数種類のツールバーがあります。マウスでボタンをクリックすると、
FDTの対応する機能にすばやくアクセスすることができます。

ボタンは、関連するグループに分けて、各ツールバーに配置されています。

ボタンの機能を知りたい場合は、ボタンの上にマウスを置くと、ボタンの横とステータスバーにボタン
機能の概要が表示されます。

ツールバーはカスタマイズできます。FDTのほとんどの機能をボタンとして追加することができ、ボタ
ンの配置も使いやすいように変更することができます。

ツールバーボタンの配置の変更や、各ボタンの機能の詳細については、４章「ユーザインタフェースの
設定」を参照してください。
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ワークスペースツールバー

New Workspace ：‘New Workspace’ダイアログボックスを開きます。

Open Workspace ：‘Open’ダイアログボックスを開きます。

Save Workspace ：現在のワークスペースを保存します。

New Project ：‘Project Wizard’ダイアログボックスを開きます。

New Workspace
Open Workspace
Save Workspace
New Project
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プロジェクトツールバー

Active project ：ワークスペース内のプロジェクトから、１つを選んでアクティブにしま
す。

Properties ：‘Project Properties’ダイアログボックスを開きます。

Add S-Record Files ：‘Open’ダイアログボックスを開き、ターゲットファイルとしてSレコード
ファイルをプロジェクトに追加します。

Build Image ：開いているデバイスイメージファイルをバイナリイメージファイルにビル
ドし、ターゲットのフラッシュメモリにダウンロードできるようにしま
す。

Download Device Image ：現在開いているファイルをダウンロードします。

Connect ：デバイスをFDTインタフェースに接続します。

Disconnect ：デバイスをFDTインタフェースから切断します。

Erase Blocks ：‘Erase Block’ダイアログボックスを開き、デバイスのフラッシュメモリの
特定ブロックまたは全ブロックを消去します。

Blank Check ：ターゲットデバイスのフラッシュ部が空白である／ないをチェックしま
す。

Upload Data ：‘Upload Image’ダイアログボックスを開き、ターゲットデバイスからデー
タをアップロードします。

Cancel FLASH Operation ：FLASH操作（ダウンロード、アップロード、消去）を取り消します。

Active Project
Properties
Add S-Record Files
Build Image
Download Device Image
Connect
Disconnect
Erase Blocks
Blank Check
Upload Data
Cancel FLASH Operation
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標準ツールバー

Open file ：‘Open’ダイアログボックスを開きます。

Save file ：現在のアクティブファイルを保存します。

Save all ：エディタウィンドウに開いている未保存なファイルを全て保存します。

Cut ：反転表示しているブロックを削除し、クリップボードにコピーします。

Copy ：反転表示しているブロックをクリップボードにコピーします。

Paste ：クリップボードの内容をウィンドウのカーソル位置に貼り付けます。

Create Selection ：アクティブファイル内の指定サイズブロックを選択します。

Undo ：直前の編集操作を取り消し、元にもどします。

Redo ：直前のUndo操作を取り消します。

View as Bytes ：データをバイト（8ビット）単位で表示します。

View as Words ：データをワード（16ビット）単位で表示します。

View as DWords ：データをダブル（ロング）ワード（32ビット）単位で表示します。

Toggle ASCII ：データをASCIIで表示する／しないを切り替えます。

Align view to 8 bytes ：8バイトずつに分けて表示します。各行に表示できるバイト数は、ウィンドウ
サイズによって異なります。

Find ：‘Find’ダイアログボックスを開きます。

Find and Replace ：‘Replace’ダイアログボックスを開きます。

Fill selection ：‘Fill’ ダイアログボックスを開きます。

Open file

Save file
Save all
Cut
Copy
Paste
Create Selection
Undo
Redo
View as Bytes
View as Words
View as DWords
Toggle ASCII
Align view to 8 bytes
Find
Find and Replace
Fill selection
Download active file
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Download active file ：エディタウィンドウ内の現在のアクティブファイルを、ターゲットのフラッ
シュメモリにダウンロードします。ファイルがプロジェクトに登録されてい
ない場合は、‘FLASH Controller’ダイアログボックスが開きます。

ステータスバー
FDTアプリケーションウィンドウの下部に、ステータスバーがあります。ステータスバーは、アプリケ
ーションの実行状況や完了した最後の動作についての情報を表示します。

ステータスバーの一番左の部分には、ツールバーボタンの機能を示します。各ツールバーボタンにマウ
スポインタを置くと、その機能を表示します。

その右側の部分は、FDTインタフェースがデバイスと接続されているかどうかと使用中のポートを表示
します。また、現在の実行中の動作を表示します。

さらにその次の部分は、実行中の動作の進捗割合（パーセント）を示します。

一番右の部分は、Caps Lockキーの状態を示します。

ポップアップメニュー
ウィンドウには、ローカルポップアップメニューがあり、よく使う機能が簡単にアクセスできるように
なっています。ウィンドウ上でマウスの右ボタンをクリックするか、SHIFT+F10キーを押すと、ポッ
プアップメニューが開くので、必要なメニューオプションを選択できます。以下に、ポップアップメニ
ューの例を示します。

各ポップアップメニューの内容と機能の詳細については、第６章「ウィンドウ」の各FDTウィンドウの
説明を参照してください。

データ入力
‘Find’、‘Replace’、‘Fill’ ダイアログボックスでデータを入力する際は、１６進数とASCII文字（ASCII
Searchチェックボックスを選択した場合）のみ入力できます。１６進数を入力する場合、テキストボッ
クスには、先頭に“0x”が固定で入力されていますので、そのうしろに１６進の値だけを入力してくだ
さい。
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2.2 ヘルプ
FDTには、Windows標準の状況対応型ヘルプシステムがあります。システムの使用に関するオンラインヘル

プ情報を表示します。

F1キーを押すか、Helpメニューを選択して、ヘルプを呼び出すことができます。さらに、一部のウィンドウ

やダイアログボックスには、専用のヘルプボタン  があり、適切なヘルプを表示できます。

状況対応型ヘルプ
FDT グラフィカルインタフェースの特定の項目に関するヘルプを表示するには、ヘルプカーソルを用
います。ヘルプカーソルを表示するには、SHIFT+F1キーを押してください。

カーソルが  に変わります。この状態で、ヘルプを参照したい項目上でクリックすると適切なヘルプ

が表示されます。Helpメニューからヘルプを表示することもできます。

2.3 ショートカットキー

よく使用する機能には、以下のようにショートカットキーが割り当てられています。

ヘルプ F1

Open Ctrl+O

New Workspace Ctrl+N

Open Workspace Ctrl+W

Save Workspace Ctrl+E

Save Ctrl+S

Undo Ctrl+Z

Redo Ctrl+Y

Cut Ctrl+X

Copy Ctrl+C

Paste Ctrl+V

Find Ctrl+F

Replace Ctrl+H

New Project Alt+N

Add File to Project Ctrl+A

Build Device Image Ctrl+B

Download Device Image Ctrl+Shift+P

Freshen all Target Files Ctrl+T

Properties Alt+Shift+R

Erase FLASH Blocks Alt+R

Upload Image Alt+U

Blank Check Alt+B

Cancel FLASH Operation Ctrl+Break

Fill Ctrl+L

View as ASCII Alt+A

View as Bytes Alt+1

View as Word Alt+2

View as DWord Alt+4

Align to 8 Bytes Alt+8

Download Image Ctrl+P
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3 基本操作

3.1 ＦＤＴを起動する
FDTを起動するにはWindowsの“スタート”メニューから“プログラム”、"Hitachi"、“FLASH

Development Toolkit X.X”を選択し、FDTのショートカットを選びます。デフォルトで‘Welcome to the FLASH
Development Toolkit’ダイアログボックスが開きます。

新規ワークスペースを作成するには“Create a new Workspace”を選択し、“OK”ボタンをクリックしてく
ださい。最近開いたワークスペースを開くには“Open an existing Workspace”を選択し、リストボックスから
開きたいワークスペースを選択し、“OK”ボタンをクリックしてください。

3.2 新規ワークスペースを作成する

①ワークスペース名を入力します。入力完了後、“OK”ボタンをクリックしてください。
（必要ならば、ディレクトリ生成の有無、位置を指定してください。）
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②プロジェクトウィザードの実行ＯＫならば、“はいはいはいはい(Y)”ボタンをクリックしてください。

③プロジェクト名を入力します。入力完了後、“次へ次へ次へ次へ(N)＞＞＞＞”ボタンをクリックしてください。
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④デバイスをドロップリストより選択します。もし、デフォルトパス以外にユーザー作成のカーネルが存在
する場合には、“Other...”を選択し、カーネル設定ファイル(.fcf)を指定してください。
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⑤ポート、ボーレートをドロップリストより選択します。入力完了後、“次へ次へ次へ次へ(N)＞＞＞＞”ボタンをクリックして
ください。

注注注注 ボーレートは、ハードウェアマニュアルを参照し、誤差が３％以内となる値を選択してください。

補足：
1. Use Default Baud Rate

HMSE Evaluation Board 使用時のみ設定してください。
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⑥入力クロックは数値を入力し、逓倍比（メイン、ペリフェラル）はドロップリストから選択します。入力
完了後、“次へ次へ次へ次へ(N)＞＞＞＞”ボタンをクリックしてください。

補足：
1. CPU Crystal Frequency
マイコンに入力しているクロックまたはマイコンに接続している水晶発振子の周波数を入力してくださ
い。整数または○○.○○の形式で入力します。小数点以下 2 桁まで有効です。

2. Clock Mode
マイコンによってはクロックモードを選択する必要があります。ドロップリストから適切な値を選択し
てください。

3. Multiplier for CKM
入力クロックに対するシステムクロック（マスタクロック）の逓倍比を入力してください。

4. Multiplier for CKP
マイコンによっては周波数比（ＣＫＰ）を選択することができます。入力クロックに対する周辺クロッ
クの逓倍比を入力してください。

注注注注 クロックモード、入力クロックおよび周波数比の入力に際しては、ハードウェアマニュアルを参照し、
設定可能範囲を確認してください。
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⑦動作モードを選択します。入力完了後、次へ次へ次へ次へ(N)＞＞＞＞”ボタンをクリックしてください。
  （インタフェースは“Direct Connection”固定）
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⑧フラッシュ ROM書込み時の保護レベル、メッセージ出力レベルの選択をします。入力完了後、“完了完了完了完了”ボ
タンをクリックしてください。

3.3 ワークスペースを保存する

[File->Save Workspace]メニューオプションを選ぶと、FDTのワークスペースが保存できます。

3.4 ワークスペースを閉じる

FDTのワークスペースを閉じるには、[File->Close Workspace]を選んでください。ワークスペースまたはそ
のプロジェクトに変更があった場合は、保存する／しないを選んでください。

3.5 ＦＤＴを終了する

FDTを終了するには[File->Exit ]を選ぶか、Alt+F4 キーを押下するか、システムメニューから“閉じる閉じる閉じる閉じる”オ
プションを選んでください（システムメニューは FDTタイトルバーの最も左上側にあるアイコンをクリックす
ると開きます）。
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3.6 フラッシュＲＯＭにデータを書き込む

① ターゲットファイル（Ｓレコードファイル）をダウンロードする場合

1. [Project->Add Files to Project]又は、Ctrl+A キーにてダウンロードするファイルをプロジェクトに追加し
ます。

2. ワークスペースウィンドウに表示されているファイル（*.mot）上で右クリック後、“Download File to
Device”を選択します。

3. メッセージログウィンドウに“Image successfully written to device”が出力されたら書込み完了です。
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② デバイスイメージ（バイナリイメージファイル）をダウンロードする場合

1. ターゲットファイルをプロジェクトに追加します。（①の 1.と同様）
2. ワークスペースウィンドウに表示されている“Device Image”上で右クリック後、“Build Device Image””””
を選択します。

3. メッセージウィンドウに“Build Complete – Saving Image…”が出力されたらデバイスイメージ作成完了
です。

4. ワークスペースウィンドウに表示されているファイル（*.fpr）上で右クリック後、“Download Image to
Device””””を選択します。

5. メッセージウィンドウに“Image successfully written to device”が出力されたら書込み完了です。
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3.7 フラッシュＲＯＭのデータを消去する

1. [Device->Erase FLASH blocks…]を選択し、‘Erase Blocks’ダイアログボックスを表示します。
2. 消去対象ブロックを選択します。（ブロックの Nameをクリックすると、反転表示となる）*1

3.“Erase”ボタンをクリックし、消去開始します。
4. メッセージウィンドウに“Erase complete”が出力されたら消去完了です。

　*1  全ブロックを消去する場合には、“Select All”ボタンをクリックすると全ブロックが反転表示となり
ます。又、書き込み済みのブロックを消去したい場合には、“Select Written”ボタンをクリックすると対
象ブロックが反転表示となります。

3.8 フラッシュＲＯＭのデータを読み込む

1.  [Device->Upload Image…]で‘Upload Image’ダイアログボックスを表示させます。
2. 開始／終了アドレスを入力します。
3. “Upload”ボタンをクリックし、読み込み開始します。
4. メッセージウィンドウに“Upload operation complete”が出力されたら読み込み完了です。
(注) ブ ー ト モ ー ド で 立ち 上げ た 場合は 、 フ ラ ッ シ ュ メ モ リ の デ ー タ は あ ら か じ め 、 消去さ れ て い ま す 。
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4 ユーザインタフェースの設定

FDTユーザインタフェースは、頻繁に行う操作にすばやくアクセスできるように、関連のある操作を論理的
にグループ分けしています。しかし、ユーザインタフェース項目の配置をユーザが作業しやすいように、変更
したい場合もあります。このため、ユーザインタフェースはカスタマイズできます。本章では、ユーザインタ
フェースの配置の変更と表示形式のカスタマイズについて説明します。

4.1 ウィンドウの配置
ウィンドウの最小化

エディタウィンドウ上で開いたウィンドウを終了する際、あとから現在の状態でもう一度表示したい場
合は、そのウィンドウをアイコン化することができます。つまり、ウィンドウの最小化ができます。ウ
ィンドウを最小化するには、ウィンドウの“最小化最小化最小化最小化”ボタンをクリックするか、ウィンドウのドロップ
ダウンメニューから[最小化最小化最小化最小化]を選択してください。

ウィンドウが最小化され、エディタウィンドウの下部にアイコンとして表示されます。

注注注注 画面の下部に開いているウィンドウがあると、このアイコンが見えない場合があります。

アイコンをウィンドウに復元するには、アイコンをダブルクリックするか、一度クリックしてアイコン
のメニューを表示してから[元のサイズに戻す元のサイズに戻す元のサイズに戻す元のサイズに戻す]を選択するか、メニューバーの[Window]ドロップダウン
メニューから該当するウィンドウを選択します。

ウィンドウの整列
画面上に多くのウィンドウが開いている場合があります。Tile 機能を使用すれば、どのウィンドウも他
のウィンドウと重ならないように、タイルフォーマットですべてのウィンドウを配置することができま
す。これを行うには、[Window->T ile Windows]メニューオプションを選択します。

現在開いているすべてのウィンドウが、タイルフォーマットで配置されます。最小化されアイコンとな
っているウィンドウは影響を受けません。

4.2 現在開いているウィンドウの検索
FDTアプリケーションの中に多くのウィンドウが開いていると、他のウィンドウの後ろにウィンドウが隠れ

てしまうことがあります。

特定のウィンドウを見つけるには
隠れてしまったウィンドウを見つけるには、2 つの方法があります。

1. 特定のウィンドウを選択するには、[Window]メニューを選び、メニューの一番下にある開いているウィ
ンドウのリストの中から、必要なウィンドウをクリックします。ウィンドウリストでは、現在選択され
ているウィンドウの横にチェックマークが付いています。
選択したウィンドウが画面の手前に表示されます。そのウィンドウが最小化されている場合は、アイコ
ンがウィンドウに復元されます。

2. [Window->W orkbook View]メニューオプションにチェックマークがついているときは、エディタウィン
ドウの下部にある、ファイルネームを含んだタブをクリックして、特定のウィンドウを選択することも
できます。ウィンドウが最小化されていない場合、選択したウィンドウが画面の手前に表示されます。
最小化されている場合は、そのアイコンが画面の手前に表示されます。
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4.3 ステータスバーの表示／非表示
ステータスバーを表示するかどうかを選択できます。デフォルトでは、FDTアプリケーションウィンドウの

下部にステータスバーを表示します。

ステータスバーを非表示にするには、[View->Status Bar]メニューオプションを選択します。ステータスバー
が、FDTアプリケーションウィンドウの表示から削除されます。ステータスバーを再表示するには、もう一度
[View->Status Bar]メニューオプションを選択します。ステータスバーが、FDTアプリケーションウィンドウの
表示に追加され、[View->Status Bar]メニューオプションにチェックマークが付きます。

4.4 ツールバーの表示／非表示
ツールバーの表示／非表示を選択できます。デフォルトでは、FDTアプリケーションウィンドウの上部にツ

ールバーを表示します。

ツールバーを非表示にするには、[View->Toolbar] メニューオプションを選択します。ツールバーが、FDTア
プリケーションウィンドウの表示から削除されます。ツールバーを再表示するには、もう一度[View->Toolbar]
メニューオプションを選択します。ツールバーが、FDTアプリケーションウィンドウの表示に追加され、
[View->Toolbar]メニューオプションにチェックマークが付きます。

4.5 ワークスペースの表示／非表示
ワークスペースの表示／非表示を選択できます。デフォルトでは、ワークスペースを表示します。ワークス

ペースを非表示にするには、[View->Workspace] メニューオプションを選択します。

ワークスペースが、FDTアプリケーションウィンドウの表示から削除されます。ワークスペースを再表示す
るには、もう一度[View->Workspace]メニューオプションを選択します。ワークスペースが、FDTアプリケーシ
ョンウィンドウの表示に追加され、[View->Workspace]メニューオプションにチェックマークが付きます。

4.6 メッセージログの表示／非表示
メッセージログの表示／非表示を選択できます。デフォルトでは、メッセージログを表示します。メッセー

ジログを非表示にするには、[View->M essage log] メニューオプションを選択します。

メッセージログが、FDTアプリケーションウィンドウの表示から削除されます。メッセージログを再表示す
るには、もう一度[View->M essage log]メニューオプションを選択します。メッセージログが、FDTアプリケー
ションウィンドウの表示に追加され、[View->M essage log]メニューオプションにチェックマークが付きます。

4.7 依存性ログの表示／非表示
依存性ログの表示／非表示を選択できます。デフォルトでは、依存性ログを表示します。依存性ログを非表

示にするには、[View->Dependency Log] メニューオプションを選択します。

依存性ログが、FDTアプリケーションウィンドウの表示から削除されます。依存性ログを再表示するには、
もう一度[View->Dependency Log]メニューオプションを選択します。依存性ログが、FDTアプリケーションウ
ィンドウの表示に追加され、[View->Dependency Log]メニューオプションにチェックマークが付きます。
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4.8 ツールバーのカスタマイズ
ツールバーに表示されるボタンの種類と配列を、ユーザの好みにカスタマイズすることができます。表示を

変更するには、[Tools->Customise…]メニューオプションを選択します。

‘Customise FLASH Development Toolkit’ダイアログボックスが開きます。

‘Customise FLASH Development Toolkit’ダイアログボックスにはToolbars、Commands、Output Window、
Generalの４つのタブがあります。それぞれのタブについては、第６章「ウィンドウ」で詳しく説明します。

ツールバー
Toolbarsタブでは、グループ（たとえばワークスペース）とそのグループの機能を選択できます。

Show Tooltipsを選択してチェックマークを付けると、ボタンの上にマウスポインタ（矢印）を置いた
ときに、そのボタンの機能説明を表示します。チェックマークをはずすと、説明を表示しません。

Cool Lookを選択してチェックマークを付けると、メニューオプションやツールバー項目のまわりの枠
線を表示しません。チェックマークをはずすと、枠線を表示します。

Large Buttonsを選択してチェックマークを付けると、大きいボタンを表示します。

New…ボタンをクリックすると、‘Toolbar Name’ダイアログボックスが開きます。このダイアログボッ
クスで、ユーザが新しいツールバーを作ることができます。新しい名前を入力してOKをクリックする
と、Toolbarsリストに新しい名前が追加され、画面に空のツールバーが表示されます。

Commandsタブを選択すると、新しいツールバーにボタンを追加できます。新しいツールバーは、マウ
スでドラッグして、画面上の好きな場所に置くことができます。

Toolbarsリストで、ユーザが作成したツールバーを選択すると、ResetボタンがDeleteボタンに変わりま
す。Deleteボタンをクリックすると、新しいツールバーがリストと画面の両方から消えます。

Resetボタンをクリックすると、選択したツールバーをデフォルトの設定にリセットします。

コマンド
このタブでは、グループごとにボタンとその機能を表示し、ユーザがアプリケーションごとにツールバ
ーをカスタマイズできるようにします。

Categoriesボックスから項目を選んでクリックすると、そのカテゴリに属するボタンを表示します。
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Buttonsの枠内には、選択したカテゴリに属するボタンの絵を表示します。

各ボタンをクリックすると、ボタンの動作についての説明をDescriptionの枠内に表示します。

ツールバーへのボタンの追加
Ü ツールバーにボタンを追加するには

1. 該当するカテゴリから、追加したいボタンを選び、マウスの左ボタンを押します。
2. ツールバー上の好きな場所までボタンをドラッグします。
3. マウスボタンを離します。

ツールバーのボタンの位置変更
Ü ツールバーのボタン位置を変更するには

1. ツールバー上の、位置を変更したいボタンを選択します。
2. ツールバー上の好きな場所までボタンをドラッグします。
3. マウスボタンを離します。

ツールバーからのボタンの削除
Ü ツールバーからボタンを削除するには

1. ボタンをマウスで選択します。
2. ‘Customise FLASH Development Toolkit’ダイアログボックスまでボタンをドラッグします。
3. マウスボタンを離します。
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5 メニュー

このマニュアルでは、標準的なMicrosoftメニュー命名規約を使用しています。

5.1 File
‘File’メニューは、データファイルにアクセスする場合に用います。

Open…
‘Open’ダイアログボックスを開きます。このダイアログボックスで、既存のファイルを開くことができ
ます。開くことができるのは、Sレコードファイル（.rec、.mot、.a20、.a37）、デバイスイメージファ
イル（.fpr）、FDTワークスペースファイル（.fdt）です。

New Workspace
‘New Workspace’ダイアログボックスを開きます。このダイアログボックスで、新しいワークスペース
の名前と場所を指定し、新しいワークスペースを作ることができます。

Open Workspace…
‘Open’ダイアログボックスを開きます。このダイアログボックスで、既存のFDTワークスペースファイ
ル（.fdt）を開くことができます。

Save Workspace
現在のアクティブワークスペースの情報を保存します。

Close Workspace
現在のアクティブワークスペースを閉じます。

Save
現在のアクティブファイルを保存します。

Save As…
‘Save As’ダイアログボックスを開きます。このダイアログボックスで、現在アップロードされているデ
バイスイメージを、拡張子.fprのついた名前をつけて保存することができます。また、Sレコードファイ
ルがアクティブな場合、そのファイルに新しい名前をつけて保存することができます。

Save All
エディタウィンドウに開いている未保存なファイルを全て保存します。

カスケード
メニュー

チェック
マーク

ショートカット
キー

省略記号

ドロップダウン
メニュー

メニュー
オプション

メニュー
バー

メニュー
タイトル
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Close File
現在のアクティブファイルを閉じます。

Recent Workspaces
最近使ったワークスペースのリストを、カスケードメニュー形式で表示します。ここから、必要なワ
ークスペースを選択できます。

Recent Files
最近使ったファイルのリストを、カスケードメニュー形式で表示します。ここから、必要なファイルを
選択できます。

Exit
FDTアプリケーションを閉じて終了します。

5.2 Edit
‘Edit’メニューは、エディタウィンドウのデータをアクセスしたり変更したりする場合に用います。

Undo
直前の編集操作を取り消し、元に戻します。

Redo
直前のUndo操作を取り消します。

Create Selection…
‘Create Selection’ダイアログボックスを開きます。このダイアログボックスで、開始アドレス、終了ア
ドレス、長さを指定して、選択領域を作ることができます。この選択領域は、クリップボード、Fill、
Find、Replaceで使うことができます。

Cut
反転表示しているブロックの内容をウィンドウから削除し、クリップボードに格納します（Windows

標準の方法）。ブロックが反転表示されている場合にのみ使用できます。

Copy
反転表示しているブロックの内容をクリップボードにコピーします（Windows標準の方法）。ブロッ
クが反転表示されている場合にのみ使用できます。

Paste
Windowsのクリップボードの内容を子ウィンドウの現在のカーソル位置にコピーします。

Find…
‘Find’ダイアログボックスを開きます。このダイアログボックスで、１６進数またはASCIIデータを入
力できます。検索範囲は、エディタウィンドウのアクティブファイル内の選択領域です。一致するデー
タを見つけると、エディタウィンドウを更新し、一致したデータが表示されるようにします。

Replace…
‘Replace’ダイアログボックスを開きます。このダイアログボックスで、検索したい１６進数または
ASCIIデータを入力できます。また、置換するデータも同じフォーマットで入力できます。検索範囲
は、エディタウィンドウのアクティブファイル内の選択領域です。一致するデータを見つけると、エデ
ィタウィンドウを更新し、一致したデータが表示されるようにします。Replaceボタンが有効になるの
で、これをクリックすると、データが置換されます。



5　メニュー

26

5.3 View
‘View’メニューは FDTの GUIを表示したり削除したりする場合、たとえば、子ウィンドウやツールバーを表

示する場合に用います。

Toolbar
ツールバーの表示／非表示を切り替えます。ツールバーが表示になっている場合は、メニューテキスト
の左にチェックマークが表示されます。

Status Bar
ステータスバーの表示／非表示を切り替えます。ステータスバーが表示になっている場合は、メニュー
テキストの左にチェックマークが表示されます。

Workspace
ワークスペースの表示／非表示を切り替えます。ワークスペースが表示になっている場合は、メニュー
テキストの左にチェックマークが表示されます。

Message Log
メッセージログの表示／非表示を切り替えます。メッセージログが表示になっている場合は、メニュー
テキストの左にチェックマークが表示されます。

Dependency Log
このメニューオプションを選択してチェックマークを付けると、出力ウィンドウに、依存性ログのタブ
が表示されます。

5.4 Project
‘Project’メニューには、ワークスペース内のプロジェクトを高度に管理する機能があります。

New Project…
‘Project Wizard’ダイアログボックスを開きます。このダイアログボックスで、新しいプロジェクトを作
り、自由にコメントを付けることができます。FDTプロジェクトを作成すると、プロジェクトの情報は
プロジェクトファイルに保管されます。プロジェクトファイルの名前は、プロジェクト名に拡張子.cpj
を付けたものになります。

Add Files to Project…
‘Open’ダイアログボックスを開きます。このダイアログボックスで、プロジェクトにSレコードファイ
ル（.rec、.mot、.a20、.a37）を追加できます。

Remove File from Project…
選択したファイルをプロジェクトから削除します。

Set Active Project
現在開いているワークスペースにあるプロジェクトのリストを、カスケードメニュー形式で表示しま
す。ここから、必要なプロジェクトをアクティブプロジェクトに指定することができます。

Insert Project…
‘Open’ダイアログボックスを開きます。このダイアログボックスで、作成済みのFDTプロジェクト
（.cpjファイル）を開くことができます。

Build Device Image
ターゲットファイルをバイナリイメージファイル（デバイスイメージ）にビルドし、後でターゲットの
フラッシュメモリにダウンロードできるようにします。

Download Device Image
開いているデバイスイメージファイルをターゲットのフラッシュメモリにダウンロードします。

Freshen all Target files
プロジェクト内のすべてのファイルを、元のソースファイルの最新の内容に更新します。
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Properties…
現在のプロジェクトについての‘Project Properties’ダイアログボックスを開きます。このダイアログボッ
クスには、Project、Kernel、Communications、Device、Programmer、Modules、Commentsの７つのタブが
表示されます。

5.5 Device
‘Device’メニューには、ターゲットデバイスと FDTのやりとりを管理する機能があります。

Connect to Device/Disconnect from Device
GUIがデバイスと接続されていない場合は、これを接続し、接続されている場合は切断します。接続で
きない場合は、メッセージログにメッセージを表示します。デバイスの接続状態は、ステータスバーに
表示されます。

Erase FLASH blocks…
‘Erase Blocks’ダイアログボックスを開きます。

このダイアログボックスで、消去するブロックを指定できます。Writtenの欄は、対応するブロックに
データがあるかどうかを示します。

消去するには、リストから消去したいブロック名を選択し、次にEraseボタンをクリックします。

注注注注 データのないブロックは消去する必要はありませんが、FDTは指定されたブロックはすべて消去しま
す。

Upload Image…
‘Upload Image’ダイアログボックスを開きます。このダイアログボックスで、データをターゲットデバ
イスからアップロードできます。フラッシュメモリへのアクセス用の機能です。データはエディタウィ
ンドウに表示されます。

Blank check
フラッシュデバイスの空白チェックを行ない、結果をメッセージログとステータスウィンドウに表示し
ます。

Download 'ファイル名'
現在のアクティブファイルをターゲットのフラッシュメモリにダウンロードします。

User Boot Area
0.18umデバイスで有効なメニューです。User Boot Areaをチェック(有効に)することでFDTは0.18umデバ
イスのユーザブートエリアにデータを書き込んだり、アップロード、空白チェックを操作可能です。

Cancel FLASH Operation
実行中のフラッシュ操作（ダウンロード、アップロード、消去）をキャンセルします。

5.6 Image
‘Image’メニューには、エディタウィンドウに表示されているアクティブファイルを表示、操作する機能があ

ります。

Fill…
現在のアクティフファイルに対する‘Fill’ ダイアログボックスを開きます。このダイアログボックス
で、選択した領域に指定したデータを書き込むことができます。ASCII Fill チェックボックスを選択す
ると、書き込むデータをASCII文字で指定できます。

View ASCII
データをASCIIで表示するかどうかを切り替えます。

View as Bytes
データをバイト（8ビット）単位で表示します。
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View as Words
データをワード（16ビット）単位で表示します。

View as DWords
データをダブル（ロング）ワード（32ビット）単位で表示します。

Align to 8 Bytes
8バイトずつに分けて表示します。各行に表示できるバイト数は、ウィンドウサイズによって異なりま
す。

Download 'ファイル名'
現在のアクティブファイルをターゲットのフラッシュメモリにダウンロードします。

5.7 Tools
‘Tools’メニューには、個々のプロジェクトやターゲットデバイスに関係しない FDT機能があります。

Simple Interface…
Simple interface は 、 一度作成し た プ ロ ジ ェ ク ト を １ ボ タ ン で フ ラ ッ シ ュ 書き 込み す る イ ン タ ー フ ェ ー ス で す 。

UPB Diagnostics…
（現バージョンではサポートしていません。）

JTAG Development System…
（現バージョンではサポートしていません。）

Advanced Configuration…
（現バージョンではサポートしていません。）

Kernel Build Assistant…
（現バージョンではサポートしていません。）

Customise…
‘Customise FLASH Development Toolkit’ダイアログボックスを開きます。このダイアログボックスで、ツ
ールバーやコマンドをカスタマイズできます。

5.8 Window
‘Window’メニューは、現在開いている FDT GUIのウィンドウ表示を変更する場合に使用します。以下のメニ

ューオプションのほかに、現在エディタウィンドウに表示されているファイル名のリストも表示されます。現
在のアクティブファイルには、チェックマークが付きます。

Workbook View
Workbook Viewを選択してチェックマークを付けると、現在開いているウィンドウのタブがエディタウ
ィンドウの下部に表示されます。チェックマークをはずすと、タブが消えます。タブをクリックする
と、そのファイルがアクティブになります。

Docking Views
この項目を選択してチェックマークを付けると、ワークスペースウィンドウとエディタウィンドウが横
に並んで表示されます。チェックマークをはずすと、エディタウィンドウはワークスペースウィンドウ
の裏に表示されます。ウィンドウをクリックすると、クリックしたウィンドウが画面の一番手前に表示
されます。

Tile Windows
子ウィンドウを標準のタイル形式で（各ウィンドウが、それぞれ重なり合わないような大きさで）表示
します。

'ファイル名'
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ファイル名を選択してチェックマークを付けると、アクティブになります。

5.9 Help
‘Help’メニューは、FDTの操作方法を表示します。

Help Topics
FDTのヘルプ機能を起動します。FDTの‘Help Topics’ダイアログボックスが開き、FDTの各項目につい
てのヘルプを参照することができます。

About…
‘About FLASH Development Toolkit’ダイアログボックスが開き、以下のようなFDT情報を参照できま
す。
• FDTのバージョン
• ライブラリ情報、FDTの各部分のビルド日付とバージョン
• FDTがサポートするデバイス
• FDTがサポートする通信インタフェース
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6 ウィンドウ

本章では、各ウィンドウの種類と、それぞれがサポートしている機能、および関連ポップアップメニューに
より使用できるオプションについて説明します。

FDTには、ワークスペースウィンドウ、エディタウィンドウ、出力ウィンドウの３つのメインウィンドウが
あります。

ウィンドウには、ローカルポップアップメニューがあり、よく使う機能が簡単にアクセスできるようになっ
ています。ウィンドウ上でマウスの右ボタンをクリックするか、SHIFT+F10キーを押すと、ポップアップメニ
ューが開くので、必要なメニューオプションを選択します。

ウィンドウは、メインメニューオプションから開くこともできます。

6.1 ワークスペースウィンドウ
ワークスペースウィンドウは、ワークスペースの内容を表示します。表示する項目は、ワークスペース名、

ワークスペースに含まれるプロジェクト、各プロジェクトのデバイスイメージファイルとターゲットファイル
です。

ワークスペースウィンドウのポップアップメニューからメニューオプションを選択すると、選択した機能の
ウィンドウが開きます。

ワークスペースウィンドウ用のポップアップメニューには、以下のメニューオプションがあります。

Docking View
このオプションを選択してチェックマークを付けると、ワークスペースウィンドウとエディタウィンド
ウが横に並んで表示されます。チェックマークをはずすと、エディタウィンドウはワークスペースウィ
ンドウの裏に表示され、ワークスペースウィンドウの位置を自由に動かすことができます。ウィンドウ
をクリックすると、そのウィンドウが画面の一番手前に表示されます。

Hide
Hideを選択すると、ワークスペースウィンドウを隠します。 [View->Workspace]を選択すると、ワーク
スペースウィンドウを再び表示します。
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6.2 ワークスペース
ウィンドウの最上部に、ワークスペースを表示します。次の例では、Workspace ‘Rocket Launcher’がワークス

ペースです。

ワークスペース用のポップアップメニューには、以下のオプションがあります。

New Project…
‘Project Wizard’ダイアログボックスを開きます。ここで新しいプロジェクトを作成し、プロジェクトの
コメントが入力できます。

Insert Project into Workspace…
‘Open’ダイアログボックスを開きます。ここで既存のプロジェクトをワークスペースに追加できます。

Open Workspace…
‘Open’ダイアログボックスを開きます。ここで既存のFDTワークスペースファイル（.fdt）を開くこと
ができます。これにより、現在開いているワークスペースが閉じ、新しく選択したワークスペースがロ
ードされます。

Save Workspace
現在のワークスペースとそれに属するプロジェクトの詳細情報を保存します。

Close Workspace
現在のワークスペースを閉じます。

Properties…
‘Workspace Properties’ダイアログボックスを開きます。このダイアログボックスには、以下の情報を表
示します。
ワークスペース名
ワークスペースのファイル名とパス
ワークスペースを最後に保存した日付と時間
ワークスペースに変更を加えたか、その変更を保存したか
ワークスペース内のプロジェクト数
現在のアクティブプロジェクト名
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6.3 プロジェクト
ワークスペースの下に、プロジェクトが表示されます。次の例では、Azimuth Controllerと Launch Sequencer

がプロジェクトの名前です。

プロジェクト用のポップアップメニューには、以下のオプションがあります。

Add Files to Project…
‘Open’ダイアログボックスを開きます。ここで、Sレコードファイルをプロジェクトに追加できます。

Set as Active Project
反転表示しているプロジェクトをアクティブプロジェクトに指定します。

Remove Project
反転表示しているプロジェクトをワークスペースから削除します。

Connect to Device / Disconnect
GUIがデバイスと接続されていない場合は、これを接続し、接続されている場合は切断します。 接続で
きない場合は、メッセージログにメッセージを表示します。デバイスの接続状態は、ステータスバーに
表示します。

Erase FLASH blocks…
‘Erase Blocks’ダイアログボックスを開きます。

このダイアログボックスで、消去するブロックを指定できます。Written欄は、対応するブロックにデ
ータがあるかどうかを示します。

消去するには、まずリストから消去したいブロック名を選択し、次にEraseボタンをクリックします。

注注注注 データのないブロックは消去する必要はありませんが、FDTは指定されたブロックはすべて消去しま
す。

Upload Image…
‘Upload Image’ダイアログボックスを開きます。ここで、データをターゲットデバイスからアップロー
ドできます。フラッシュメモリ以外はアクセスできません。データはエディタウィンドウに表示されま
す。
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Blank check
フラッシュデバイスの空白チェックを行ない、結果をメッセージログとステータスウィンドウに表示し
ます。

Cancel FLASH Operation
実行中のフラッシュ操作（ダウンロード、アップロード、消去）をキャンセルします。

Build Device Image
ターゲットファイルをバイナリイメージファイル（デバイスイメージ）にビルドし、後でフラッシュメ
モリにダウンロードできるようにします。

Freshen all Target files
プロジェクト内のすべてのファイルを、元のソースファイルの最新の内容に更新します。

Properties…
現在のプロジェクトについての‘Project Properties’ダイアログボックスを開きます。このダイアログボッ
クスには、Project、Kernel、Communications、Device、Programmer、Modules、Commentsの７つのタブが
表示されます。

6.4 Device Imageサブフォルダ
このサブフォルダには、プロジェクトのデバイスイメージファイルが格納されています。

Device Imageサブフォルダ用のポップアップメニューには、以下のオプションがあります。

Build Device Image
ターゲットファイルをバイナリイメージファイル（デバイスイメージ）にビルドし、後でフラッシュメ
モリにダウンロードできるようにします。

Freshen all Target files
プロジェクト内のすべてのファイルを、元のソースファイルの最新の内容に更新します。

Properties…
現在のプロジェクトについての‘Project Properties’ダイアログボックスを開きます。このダイアログボッ
クスには、Project、Kernel、Communications、Device、Programmer、Modules、Commentsの７つのタブが
表示されます。
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6.5 Device Image - Sub-Project Propertiesダイアログ
Device Imageサブフォルダのポップアップメニューから‘Project Properties’ダイアログボックスを呼び出し、マ

ウスの左ボタンをクリックすると、‘Sub-Project Properties 'Device Image'’ダイアログボックスが開きます。

6.6 Target filesサブフォルダ
このサブフォルダには、プロジェクトの Sレコードファイルが格納されています。Sレコードファイルは、

デバイスイメージのビルドに使用されます。

Target filesサブフォルダ用のポップアップメニューには、以下のオプションがあります。

Add Files to Project…
‘Open’ダイアログボックスを開きます。ここで、Sレコードファイルをプロジェクトに追加できます。

Freshen all Target files
プロジェクト内のすべてのファイルを、元のソースファイルの最新の内容に更新します。

Properties…
現在のプロジェクトについての‘Project Properties’ダイアログボックスを開きます。このダイアログボッ
クスには、Project、Kernel、Communications、Device、Programmer、Modules、Commentsの７つのタブが
表示されます。

6.7 Target files - Sub-Project Propertiesダイアログ
Target fileサブフォルダのポップアップメニューから‘Project Properties’ダイアログボックスを呼び出し、マウ

スの左ボタンをクリックすると、‘Sub-Project Properties 'Target files'’ダイアログボックスが開きます。
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6.8 デバイスイメージ
デバイスイメージは、Device Imageサブフォルダ内にある項目です。次の例では、Azimuth Controller.fprが

Azimuth Controllerプロジェクトのデバイスイメージです。

デバイスイメージ用のポップアップメニューには、以下のオプションがあります。

Edit
デバイスイメージファイルをエディタウィンドウに表示します。ここで、ファイル内容の編集が行なえ
ます。

Remove File from Project
デバイスイメージファイルをプロジェクトから削除します。

Block usage…
‘Device Image Properties’ダイアログボックスを開き、Block usageタブを表示します。

Rebuild Image
対応するターゲットファイルを用いて、バイナリイメージファイル（Device Image）を再ビルドし、後
でフラッシュメモリにダウンロードできるようにします。

Download Image to Device
デバイスイメージをデバイスのフラッシュメモリにダウンロードします。

Properties…
‘Device Image Properties’ダイアログボックスを開きます。このダイアログボックスには、File
properties、Dependencies、Block usageの３つのタブが表示されます。
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6.9 Sレコードファイル
Sレコードファイルは、Target filesサブフォルダ内にある項目です。次の例では、azEVT.motと azLUT.motが

Azimuth Controllerプロジェクトのターゲットファイルです。

Sレコードファイル用のポップアップメニューには、以下のオプションがあります。

Edit
Sレコードファイルをエディタウィンドウに表示します。ここで、ファイル内容の編集が行なえます。

Remove File from Project
選択したSレコードファイルをプロジェクトから削除します。

Download File to Device
選択したSレコードファイルをデバイスのフラッシュメモリにダウンロードします。

Freshen Local File
プロジェクト内のファイルを、元のソースファイルの最新の内容に更新します。

Properties…
‘S-Record Properties’ダイアログボックスを開きます。このダイアログボックスには、File properties、
Dependency、Block usageの３つのタブが表示されます。
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6.10 Workspace properties
ワークスペース用のポップアップメニューオプション Properties…から呼び出します。
‘Workspace Properties’ダイアログボックスは、以下の情報を表示します。

ワークスペース名
ワークスペースのファイル名とパス
ワークスペースを最後に保存した日付と時間
ワークスペースに変更を加えたか、その変更を保存したか
ワークスペース内のプロジェクト数
現在のアクティブプロジェクト名



6　ウィンドウ

38

6.11 Project Properties
‘Project Properties’ダイアログボックスは、Project、Device Imageサブフォルダ、Target filesサブフォルダのい

ずれかのポップアップメニューから、Properties…オプションを選んで呼び出します。また、メインメニューの
[Project->Properties…]でも、呼び出すことができます。

(1)Project
このタブには、プロジェクト名、プロジェクトファイルの場所とファイル名、ファイルを作成した日付
と時間、ターゲットデバイス名、コンフィグレーションファイル名が表示されます。

(2)Kernel
このタブには、周波数、プロトコル、逓倍比、クロックモードが表示されます。
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(3)Communications
このタブには、デフォルトの転送速度と現在の転送速度、現在のポートが表示されます。また、ここ
で、ポートと転送速度を変更することもできます。

COM Port
デバイスとの接続が可能なCOMポートのドロップダウンリストです。

Use default baud
このチェックボックスを選択すると、デフォルトの転送速度を使用します。
（HMSE Evaluation Board 使用時のみ設定してください。）

Target Baud Rate
Use default baudを選択しないとき、Target Baud Rateのドロップダウンリストから、2400～115200bit/sの
範囲の転送速度を選択できます。

(4)Device
このタブには、デバイスに関する情報が表示されます。ここで、接続モード（BOOT Modeまたは
USER Program Mode）とインタフェース（“Direct Connection”固定）も選択できます。また、ターゲ
ットデバイスにすでにカーネルがあるかどうかも指定できます。

BOOT Mode
これを選択すると、ターゲットデバイス上にカーネルが見つからない場合、オンボード書き込みのブー
トモードシーケンスを開始します。このモードでは、フラッシュメモリをすべて消去し、カーネルをロ
ードします。
カーネルがすでにある場合は、フラッシュは消去せず、ブロックの使用状況の情報を読み出し、誤って
フラッシュが上書きされることのないようにします。

USER Program Mode
これを選択すると、オンボード書き込みのユーザプログラムモードシーケンスを開始します。このモー
ドでは、以前ロードされたユーザプログラムを用いて、フラッシュメモリに再書き込みします。
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Select Interface
インタフェースは、デバイスとの直接接続（Direct Connection）のみとなります。

Kernel already resident
このチェックボックスは、ターゲットデバイスに、既にカーネルが存在しているときに指定します。

(5)Programmer
このタブには、機能マップの状態が表示されます。また、デバイス保護オプション（Automatic、
Interactive、None）とメッセージレベルオプション（Advanced、Standard）を選択できます。

Device Protection
フラッシュメモリの誤消去・誤書き込みを防ぐものとして、自動消去（Automatic）または確認消去
（Interactive）を選択できます。自動消去では、必要に応じて、書き込みの前にブロックを消去しま
す。確認消去では、消去の前にユーザに確認を行います。ユーザの選択によっては、データが存在する
ブロックに書き込む場合もあります。
また、選択技にはもう１つ、無効（None）があります。これは、デバイス保護を無効とします。

デバイスに接続されているあいだ、FDTは常にフラッシュメモリのブロックの状況を記録し、どの時点
でフラッシュメモリに書き込まれたのかがわかるようになっています。

注 デバイス保護を無効にした場合、書き込み前の消去は、ユーザが自分で行なわなくてはなりません。

Message level
メッセージレベルとして、標準（Standard）または高度（Advanced）を選択できます。標準メッセージ
レベルでは、上位通信に関する、一般的なFDTおよびターゲットデバイス状態のメッセージを表示しま
す。高度メッセージレベルでは、下位通信に関する、より詳細な情報を表示します。

(6)Modules
このタブには、カーネルのファイル名が表示されます。
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(7)Comments
このタブでは、プロジェクトについてのコメントを書くことができます。マウスの右ボタンをクリック
すると、編集機能のドロップダウンメニューが開きます。

元に戻す
Commentウィンドウでの、最後の編集操作を取り消し、元にもどします。

切り取り
Commentウィンドウで選択したテキストを削除し、Windowsのクリップボードにコピーします。

コピー
Commentウィンドウで選択したテキストをWindowsのクリップボードにコピーします。

貼り付け
Windowsのクリップボードの内容をCommentウィンドウの現在のカーソル位置にコピーします。

削除
Commentウィンドウで選択したテキストを削除します。

すべて選択
Commentウィンドウのテキストをすべて選択します。

日本語入力－オン(オフ)
Commentウィンドウへの日本語入力を可能(不可)にします。

再変換
Commentウィンドウで選択したテキストの再変換を行います。
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6.12 Device Image Properties
Device Imageポップアップメニューオプション Properties…から呼び出します。

(1)File properties
‘Device Image Properties’ダイアログボックスは、デバイスイメージファイルの場所と名前、イメージフ
ァイルを最後に保存した日付と時間、その後変更を加えたか（その変更を保存したか）、現在エディタ
ウィンドウでイメージファイルを開いているか、イメージファイルの保存が必要か、更にフラッシュメ
モリのサイズを表示します。

(2)Dependencies
このタブには、Sレコードファイル名と、それぞれのファイルとデバイスイメージとの対応状況を表示
します。

Rebuild Now
デバイスイメージ状態メッセージに、デバイスイメージのバージョンが古いと表示された場合、このボ
タンをクリックすると、デバイスイメージを再ビルドできます。
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(3)Block usage
このタブには、指定したファイル内のブロックについて、開始アドレス、終了アドレス、ブロックサイ
ズが表示されます。

6.13 S-Record Properties
‘S-Record Properties’ダイアログボックスは、Sレコードポップアップメニューオプション Properties…または

エディタウィンドウポップアップメニューオプション Properties…から呼び出します。このダイアログボックス
には、以下の３つのタブがあります。

(1)File properties
‘S-Record Properties’ダイアログボックスは、Sレコードファイルの名前と場所、ファイルを最後に保存
した日付と時間、その後変更を加えたか（その変更を保存したか）、現在エディタウィンドウでファイ
ルを開いているか、ファイルの保存が必要か、更にフラッシュメモリのサイズを表示します。

(2)Dependency
このタブには、Sレコードファイル名と、そのファイルが依存関係を持っているかどうかを表示しま
す。依存関係がある場合、依存関係パスも表示します。Change…ボタンをクリックすると、‘Open’ダ
イアログボックスが開き、新しいパスを選択できます。また、Dependencyタブには、Sレコードファイ
ルが最新であるかどうか、ファイルと依存関係が最後に変更された日付と時間も表示されます。
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(3)Block usage
このタブには、指定したファイル内のブロックについて、開始アドレス、終了アドレス、ブロックサイ
ズが表示されます。

6.14 出力ウィンドウ
出力ウィンドウは、FDT GUIのメインウィンドウの１つです。

出力ウィンドウではポップアップメニューが使用でき、以下のオプションを選択できます。

Copy
アクティブログの内容をWindowsのクリップボードにコピーします。

Clear Messages
アクティブログをクリアします。

Save Messages…
‘Save As’ダイアログボックスを開きます。出力ウィンドウのアクティブログの内容を.txtファイルに保
存できます。

Allow Docking
このオプションを選択してチェックマークを付けると、出力ウィンドウを、FDTアプリケーションウィ
ンドウのなかに固定（ドッキング）することができます。チェックマークをはずすと、出力ウィンドウ
の位置を自由に動かすことができます。

Hide
Hideを選択すると、メッセージログを隠します。 [View->M essage log]を選択すると、メッセージログ
を再び表示します。
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6.15 エディタウィンドウ
エディタウィンドウは、FDT GUIのメインウィンドウの１つです。

エディタウィンドウでは、ポップアップメニューが使用でき、以下のオプションを選択できます。

Cut
反転表示しているブロックの内容をウィンドウから削除し、クリップボードに格納します（Windows

標準の方法）。ブロックが反転表示されている場合にのみ使用できます。

Copy
反転表示しているブロックの内容をクリップボードにコピーします（Windows標準の方法）。ブロッ
クが反転表示されている場合にのみ使用できます。

Paste
Windowsのクリップボードの内容を子ウィンドウの現在のカーソル位置にコピーします。

Undo
選択したデータに対する直前の編集操作を取り消し、元に戻します。

Redo
直前のUndo操作を取り消します。

Display Unit
以下のメニューをカスケード形式で表示します。

Byte ：データをバイト（8ビット）単位で表示します。

Word ：データをワード（16ビット）単位で表示します。

DWord：データをダブル（ロング）ワード（32ビット）単位で表示します。



6　ウィンドウ

46

Align to 8 Bytes
8バイトずつに分けて表示します。各行に表示できるバイト数は、ウィンドウサイズによって異なりま
す。

Create Selection…
‘Create Selection’ダイアログボックスを開きます。このダイアログボックスで、開始アドレス、終了ア
ドレス、長さを指定して、選択領域を作ることができます。この選択領域は、クリップボード、Fill、
Find、Replaceで使うことができます。

Fill…
現在のアクティフファイルに対する‘Fill’ ダイアログボックスを開きます。このダイアログボックス
で、選択した領域に指定したデータを書き込むことができます。ASCII Fill チェックボックスを選択す
ると、書き込むデータをASCII文字で指定できます。

Find…
‘Find’ダイアログボックスを開きます。このダイアログボックスで、１６進数またはASCIIデータを入
力できます。検索範囲は、エディタウィンドウのアクティブファイル内の選択領域です。一致するデー
タを見つけると、エディタウィンドウを更新し、一致したデータが表示されるようにします。

Replace…
‘Replace’ダイアログボックスを開きます。このダイアログボックスで、検索したい１６進数または
ASCIIデータを入力できます。また、置換するデータも同じフォーマットで入力できます。検索範囲
は、エディタウィンドウのアクティブファイル内の選択領域です。一致するデータを見つけると、エデ
ィタウィンドウを更新し、一致したデータが表示されるようにします。Replaceボタンが有効になるの
で、これをクリックすると、データが置換されます。

Properties…
‘S-Record Properties’ダイアログボックスを表示します。



6　ウィンドウ

47

6.16 Erase Blocks
‘Erase Blocks’ダイアログボックスは、[Device->Erase FLASH blocks…]、ワークスペースのプロジェクト用ポ

ップアップメニューオプション Erase FLASH blocks…、ツールバーの Erase Blocks、フラッシュコントローラ
の Erase FLASH blocksコマンドのいずれかで呼び出します。

‘Erase Blocks’ダイアログボックスで、消去するブロックを指定できます。Writtenの欄は、対応するブロック
にデータがあるかどうかを示します。

Select All
Select Allをクリックすると、デバイスのフラッシュメモリ内の全ブロックを選択します。

Select Written
Select Writtenをクリックすると、空白でないブロックのみを選択します。

Erase
Eraseをクリックすると、選択したブロックのデータを消去し、‘Erase Blocks’ダイアログボックスを閉
じます。

Cancel
Cancelをクリックすると、消去を行なわずに‘Erase Blocks’ダイアログボックスを閉じます。

注注注注 データのないブロックは消去する必要はありませんが、FDTは指定されたブロックはすべて消去しま
す。
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6.17 Flash Controller
‘FLASH Controller’ダイアログボックスを開くには、まず、現在開いているプロジェクトに属していない Sレ

コードまたはバイナリイメージファイルを、エディタで開きます。次に、[Image->Download ファイル名]を選択
して、‘FLASH Controller’ダイアログボックスを開きます。

‘FLASH Controller’ダイアログボックスを用いると、ファイルを簡単にすばやくターゲットデバイスにダウン
ロードできます。

Device Selection
ドロップダウンリストから、ターゲットデバイスを選択できます。また、フラッシュメモリとRAMの
サイズも表示します。

Commands
Connect/Disconnect
選択したデバイスにFDTインタフェースを接続/切断します。

Blank check
デバイスのフラッシュメモリに、空白チェックを行ないます。

Erase FLASH blocks
‘Erase Blocks’ダイアログボックスを開きます。

User settings
デフォルトの転送速度を使うように指示できます。または、転送速度を選択し、使用する通信ポートを
指定することもできます。

Connection
接続モード（BOOT ModeまたはUSER Program Mode）とインタフェース（“Direct Connection” 固
定）を選択できます。
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BOOT Mode
これを選択すると、ターゲットデバイス上にカーネルが見つからない場合、オンボード書き込みのブ
ートモードシーケンスを開始します。このモードでは、フラッシュメモリをすべて消去し、カーネル
をロードします。
カーネルがすでにある場合は、フラッシュは消去せず、ブロックの使用状況の情報を読み出し、誤っ
てフラッシュが上書きされることのないようにします。

USER Program Mode
これを選択すると、オンボード書き込みのユーザプログラムモードシーケンスを開始します。このモ
ードでは、以前ロードされたユーザプログラムを用いて、フラッシュメモリに再書き込みします。

Select Interface
インタフェースは、デバイスとの直接接続（Direct Connection）のみとなります。

Kernel already resident
このチェックボックスは、ターゲットデバイスに、既にカーネルが存在しているときに指定します。

Kernel
周波数、逓倍比、通信プロトコルを選択できます。

Download file 'ファイル名' to device
このボタンをクリックすると、対応するイメージファイルを、デバイスのフラッシュメモリにダウンロ
ードします。
フラッシュコントローラでは、対話式のデバイス保護方式を採っています（オンラインヘルプ参照）。
すでに書き込まれているフラッシュメモリの領域に対して書き込もうとした場合、書き込み動作の前
に、ユーザに確認を行ないます。
フラッシュコントローラを起動すると、出力ウィンドウが開き、ここにメッセージが表示されます。こ
のメッセージを保存したい場合は、対応するイメージファイルを閉じる前にメッセージを保存してくだ
さい。

6.18 Customise - Toolbars
‘Customise FLASH Development Toolkit’ダイアログボックスの Toolbarsタブは、[Tools->Customise…]を選択し

て呼び出します。
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Show Tooltips
Show Tooltipsを選択してチェックマークを付けると、ボタンの上にマウスポインタ（矢印）を置いた
ときに、そのボタンの機能説明を表示します。チェックマークをはずすと、説明を表示しません。

Cool Look
Cool Lookを選択してチェックマークを付けると、メニューとツールバーの項目から、枠線が消えま
す。チェックマークをはずすと、枠線を表示します。

Large Buttons
Large Buttonsを選択してチェックマークを付けると、大きいボタンを表示します。

New…
New…ボタンをクリックすると、‘Toolbar Name’ダイアログボックスが開きます。このダイアログボッ
クスで、新しいツールバーを作ることができます。新しい名前を入力してOKをクリックすると、
Toolbarsリストに新しい名前が追加され、画面に空のツールバーが表示されます。
Commandsタブを選択して、新しいツールバーにボタンを追加できます。新しいツールバーは、マウス
でドラッグして、画面上の好きな場所に置くことができます。

Reset
Resetボタンをクリックすると、選択したツールバーをデフォルトの設定にリセットします。

Toolbar name
リストで選んだツールバーの名前を表示します。

OK
‘Toolbar Name’ダイアログボックスのOKボタンをクリックすると、ToolbarsタブのToolbarsリストに新し
い名前が追加され、画面に空のツールバーが表示されます。

‘Customise FLASH Development Toolkit’ダイアログボックスのOKボタンをクリックすると、変更内容を
保存してダイアログボックスを閉じます。

Delete
新しいツールバーがToolbarsリストに追加されたあと、その名前を選択すると、Reset ボタンがDeleteボ
タンに変わります。Deleteボタンをクリックすると、新しいツールバーがリストと画面の両方から消え
ます。

キャンセル
キャンセルキャンセルキャンセルキャンセルボタンをクリックすると、変更内容を保存せずに‘Customise FLASH Development Toolkit’ダイ
アログボックスを閉じます。
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6.19 Customise - Commands
‘Customise FLASH Development Toolkit’ダイアログボックスの Commandsタブは、[Tools->Customise…]を選択

してから、Commandsタブをクリックして、開きます。

Categories
Categoriesリストから、カテゴリを選んでクリックすると、そのカテゴリに属するボタンを表示しま
す。

Buttons
Buttonsには、選択したカテゴリに属するボタンの絵が表示されます。

Description
ボタンをクリックすると、ボタンの動作についての説明が表示されます。

OK
OKボタンをクリックすると、変更内容を保存して‘Customise FLASH Development Toolkit’ダイアログボ
ックスを閉じます。

キャンセル
キャンセルキャンセルキャンセルキャンセルボタンをクリックすると、変更内容を保存せずに‘Customise FLASH Development Toolkit’ダイ
アログボックスを閉じます。
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6.20 Customise - Output Window
‘Customise FLASH Development Toolkit’ダイアログボックスの Output Windowタブは、[Tools->Customise…]を

選択してから、Output Windowタブをクリックして、開きます。

Messages
Change Colour

Change Colour…ボタンをクリックすると、‘色’ダイアログボックスが開きます。このダイアログボッ
クスで、選択した出力メッセージの色を変更する事ができます。

Change Font
Change Font…ボタンをクリックすると、‘フォント’ダイアログボックスが開きます。このダイアログ
ボックスで、選択した出力メッセージのフォントを変更する事ができます。

Tabs
Change Font

Change Font…ボタンをクリックすると、‘フォント’ダイアログボックスが開きます。このダイアログ
ボックスで、出力メッセージウィンドウのタブのフォントを変更する事ができます。

OK
OKボタンをクリックすると、変更内容を保存して‘Customise FLASH Development Toolkit’ダイアログボ
ックスを閉じます。

キャンセル
キャンセルキャンセルキャンセルキャンセルボタンをクリックすると、変更内容を保存せずに‘Customise FLASH Development Toolkit’ダイ
アログボックスを閉じます。
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6.21 Customise - General
‘Customise FLASH Development Toolkit’ダイアログボックスの Generalタブは、[Tools->Customise…]を選択し

てから、Generalタブをクリックして、開きます。

Programming
Read-back verification
リードバックベリフィケーションを確認してから行うか（Query）、常に行うか（Yes）、あるいは行
わないか（No）を指定します。

Reset on disconnect
（現バージョンではサポートしていません）

Automation
Reload last Workspace at startup
チェックマークを付けると、FDTは起動時に最後に使用されたワークスペースをロードします。

Download active project Device Image at startup
チェックマークを付けると、FDTは起動時に自動的にアクティブプロジェクトのデバイスイメージを
フラッシュメモリに書き込むよう動作します。

OK
OKボタンをクリックすると、変更内容を保存して‘Customise FLASH Development Toolkit’ダイアログボ
ックスを閉じます。

キャンセル
キャンセルキャンセルキャンセルキャンセルボタンをクリックすると、変更内容を保存せずに‘Customise FLASH Development Toolkit’ダイ
アログボックスを閉じます。
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6.22 Simple Interface
‘Simple Interface’ダイアログボックスは、[Tools->Simple Interface…]を選択して呼び出します。また、EXIT

ボタンをクリックすると、前画面に戻ります。

Flash Program
Flash Programボタンをクリックすると、指定したファイルをフラッシュにダウンロードします。
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