e² studio
Integrated Development Environment
User’s Manual: Quick Start Guide

RENESAS MCU
RX, RL78, RH850 Family

All information contained in these materials, including products and product specifications, represents information on the product at the time of publication and is subject to change by Renesas Electronics Corp. without notice. Please review the latest information published by Renesas Electronics Corp. through various means, including the Renesas Electronics Corp. website (http://www.renesas.com).
Notice

1. Descriptions of circuits, software and other related information in this document are provided only to illustrate the operation of semiconductor products and application examples. You are fully responsible for the incorporation or any other use of the circuits, software, and information in the design of your product or system. Renesas Electronics disclaims any and all liability for any losses and damages incurred by you or third parties arising from the use of these circuits, software, or information.

2. Renesas Electronics hereby expressly disclaims any warranties against and liability for infringement or any other claims involving patents, copyrights, or other intellectual property rights of third parties. By incorporating the use of Renesas Electronics products or technical information described in this document, including but not limited to, the product data, drawings, charts, programs, algorithms, and application examples.

3. No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights of Renesas Electronics or others.

4. You shall be responsible for determining what licenses are required from any third parties, and obtaining such licenses for the lawful import, export, manufacture, sales, utilization, distribution or other disposal of any products incorporating Renesas Electronics products, if required.

5. You shall not alter, modify, copy, or reverse engineer any Renesas Electronics product, whether in whole or in part. Renesas Electronics disclaims any and all liability for any losses or damages incurred by you or third parties arising from such alteration, modification, copying or reverse engineering.

6. Renesas Electronics products are classified according to the following two quality grades: “Standard” and “High Quality”. The intended applications for each Renesas Electronics product depends on the product’s quality grade, as indicated below.

   Standard*: Computers; office equipment; communications equipment; test and measurement equipment; audio and visual equipment; home electronic appliances; machine tools; personal electronic equipment; industrial robots; etc.

   "High Quality": Transportation equipment (automobiles, trains, ships, etc.); traffic control (traffic lights); large-scale communication equipment; key financial terminal systems; safety control equipment; etc.

Unless expressly noted as a high reliability product or a high harsh environments in a Renesas Electronics data sheet or other Renesas Electronics products, Renesas Electronics shall have absolutely no liability arising from any vulnerability or security breach, including but not limited to any unauthorized access to or use of a Renesas Electronics product or a system that uses a Renesas Electronics product. RENESAS ELECTRONICS DOES NOT WARRANT OR GUARANTEE THAT RENESAS ELECTRONICS PRODUCTS, OR ANY SYSTEMS CREATED USING RENESAS ELECTRONICS PRODUCTS, ARE FREE FROM CORRUPTION, ATTACK, VIRUSES, INTERFERENCE, HACKING, DATA LOSS OR THEFT, OR OTHER SECURITY INTRUSION (“Vulnerability Issues”). RENESAS ELECTRONICS DISCLAIMS ANY AND ALL RESPONSIBILITY OR LIABILITY ARISING FROM OR RELATED TO ANY VULNERABILITY ISSUES. FURTHERMORE, TO THE EXTENT PERMITTED BY APPLICABLE LAW, RENESAS ELECTRONICS DISCLAIMS ANY AND ALL WARRANTIES, EXPRESS OR IMPLIED, WITH RESPECT TO THIS DOCUMENT AND ANY RELATED OR ACCOMPANYING SOFTWARE OR HARDWARE, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, OR FITNESS FOR A PARTICULAR PURPOSE.

8. When using Renesas Electronics products, refer to the latest product information (data sheets, user’s manuals, application notes, “General Notes for Handling and Using Semiconductor Devices” in the reliability handbook, etc.), and ensure that usage conditions are within the ranges specified by Renesas Electronics with respect to maximum ratings, operating power supply voltage range, heat dissipation characteristics, installation, etc. Renesas Electronics disclaims any and all liability for any malfunctions, failure or accident arising out of the use of Renesas Electronics products outside of such specified ranges.

9. Although Renesas Electronics endeavors to improve the quality and reliability of Renesas Electronics products, semiconductor products have specific characteristics, such as the occurrence of failure at a certain rate and malfunctions under certain use conditions. Unless designated as a high reliability product or a product for harsh environments in a Renesas Electronics data sheet or other Renesas Electronics document, Renesas Electronics products are not subject to radiation resistance design. You are responsible for implementing safety measures to guard against the possibility of bodily injury, injury or damage caused by fire, and/or danger to the public in the event of a failure or malfunction of Renesas Electronics products, such as safety design for hardware and software, including but not limited to redundancy, fire control and malfunction prevention, appropriate treatment for aging degradation or any other appropriate measures. Because the evaluation of microcomputer software alone is very difficult and impractical, you are responsible for evaluating the safety of the final products or systems manufactured by you.

10. Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental compatibility of each Renesas Electronics product. You are responsible for carefully and sufficiently investigating applicable laws and regulations that regulate the inclusion or use of controlled substances, including without limitation, the EU RoHS Directive, and using Renesas Electronics products in compliance with all these applicable laws and regulations. Renesas Electronics disclaims any and all liability for damages or losses occurring as a result of your noncompliance with applicable laws and regulations.

11. Renesas Electronics products and technologies shall not be used for or incorporated into any products or systems whose manufacture, use, or sale is prohibited under any applicable domestic or foreign laws or regulations. You shall comply with any applicable export control laws and regulations promulgated and administered by the governments of any countries asserting jurisdiction over the parties or transactions.

12. It is the responsibility of the buyer or distributor of Renesas Electronics products, or any other party who distributes, disposes of, or otherwise sells or transfers the product to a third party, to notify such third party in advance of the contents and conditions set forth in this document.

13. This document shall not be translated, reproduced or duplicated in any form, in whole or in part, without prior written consent of Renesas Electronics.

14. Please contact a Renesas Electronics sales office if you have any questions regarding the information contained in this document or Renesas Electronics products.

(Rev.5.0-1 October 2020)

Corporate Headquarters
TOYOSU FORESIA, 3-2-24 Toyosu,
Koto-ku, Tokyo 135-0061, Japan
www.renesas.com

Contact information
For further information on a product, technology, the most up-to-date version of a document, or your nearest sales office, please visit: www.renesas.com/contact/

Trademarks
Renesas and the Renesas logo are trademarks of Renesas Electronics Corporation. All trademarks and registered trademarks are the property of their respective owners.

© 2023 Renesas Electronics Corporation. All rights reserved.
General Precautions in the Handling of Microprocessing Unit and Microcontroller Unit Products

The following usage notes are applicable to all Microprocessing unit and Microcontroller unit products from Renesas. For detailed usage notes on the products covered by this document, refer to the relevant sections of the document as well as any technical updates that have been issued for the products.

1. Precaution against Electrostatic Discharge (ESD)
   A strong electrical field, when exposed to a CMOS device, can cause destruction of the gate oxide and ultimately degrade the device operation. Steps must be taken to stop the generation of static electricity as much as possible, and quickly dissipate it when it occurs. Environmental control must be adequate. When it is dry, a humidifier should be used. This is recommended to avoid using insulators that can easily build up static electricity. Semiconductor devices must be stored and transported in an anti-static container, static shielding bag or conductive material. All test and measurement tools including work benches and floors must be grounded. The operator must also be grounded using a wrist strap. Semiconductor devices must not be touched with bare hands. Similar precautions must be taken for printed circuit boards with mounted semiconductor devices.

2. Processing at power-on
   The state of the product is undefined at the time when power is supplied. The states of internal circuits in the LSI are indeterminate and the states of register settings and pins are undefined at the time when power is supplied. In a finished product where the reset signal is applied to the external reset pin, the states of pins are not guaranteed from the time when power is supplied until the reset process is completed. In a similar way, the states of pins in a product that is reset by an on-chip power-on reset function are not guaranteed from the time when power is supplied until the power reaches the level at which resetting is specified.

3. Input of signal during power-off state
   Do not input signals or an I/O pull-up power supply while the device is powered off. The current injection that results from input of such a signal or I/O pull-up power supply may cause malfunction and the abnormal current that passes in the device at this time may cause degradation of internal elements. Follow the guideline for input signal during power-off state as described in your product documentation.

4. Handling of unused pins
   Handle unused pins in accordance with the directions given under handling of unused pins in the manual. The input pins of CMOS products are generally in the high-impedance state. In operation with an unused pin in the open-circuit state, extra electromagnetic noise is induced in the vicinity of the LSI, an associated shoot-through current flows internally, and malfunctions occur due to the false recognition of the pin state as an input signal become possible.

5. Clock signals
   After applying a reset, only release the reset line after the operating clock signal becomes stable. When switching the clock signal during program execution, wait until the target clock signal is stable. When the clock signal is generated with an external resonator or from an external oscillator during a reset, ensure that the reset line is only released after full stabilization of the clock signal. Additionally, when switching to a clock signal produced with an external resonator or by an external oscillator while program execution is in progress, wait until the target clock signal is stable.

6. Voltage application waveform at input pin
   Waveform distortion due to input noise or a reflected wave may cause malfunction. If the input of the CMOS device stays in the area between $V_{IL}$ (Max.) and $V_{IH}$ (Min.) due to noise, for example, the device may malfunction. Take care to prevent chattering noise from entering the device when the input level is fixed, and also in the transition period when the input level passes through the area between $V_{IL}$ (Max.) and $V_{IH}$ (Min.).

7. Prohibition of access to reserved addresses
   Access to reserved addresses is prohibited. The reserved addresses are provided for possible future expansion of functions. Do not access these addresses as the correct operation of the LSI is not guaranteed.

8. Differences between products
   Before changing from one product to another, for example to a product with a different part number, confirm that the change will not lead to problems. The characteristics of a microprocessing unit or microcontroller unit products in the same group but having a different part number might differ in terms of internal memory capacity, layout pattern, and other factors, which can affect the ranges of electrical characteristics, such as characteristic values, operating margins, immunity to noise, and amount of radiated noise. When changing to a product with a different part number, implement a system-evaluation test for the given product.
# Table of Contents

Corporate Headquarters ........................................................................................................................... 1

Contact information ................................................................................................................................. 1

Trademarks .................................................................................................................................................. 1

1. General .................................................................................................................................................. 1
  1.1 System Configuration ....................................................................................................................... 1
  1.2 System Requirements ...................................................................................................................... 1
  1.3 Supported Toolchains ....................................................................................................................... 2
  1.4 Supported Emulator Device ............................................................................................................. 2
  1.5 Supported Simulator ........................................................................................................................... 2

2. Installation ............................................................................................................................................. 3
  2.1 Installation of e² studio IDE (64-bit version) ..................................................................................... 3
  2.2 Installation of e² studio IDE (32-bit version) .................................................................................... 9
  2.3 Un-installation of e² studio IDE ........................................................................................................ 13
  2.4 Installation of Compiler Package ...................................................................................................... 13

3. Project generation .................................................................................................................................. 15
  3.1 New Project Generation ................................................................................................................... 15
  3.2 New Debug Only Project Generation ............................................................................................... 19
  3.3 Importing a sample project .............................................................................................................. 22
  3.4 Import Existing Projects into Workspace ....................................................................................... 23
    3.4.1 Download and import sample projects in Smart Browser view .................................................. 28

4. Build ....................................................................................................................................................... 29
  4.1 Build Option Settings ...................................................................................................................... 29
  4.2 Build A Sample Project .................................................................................................................... 32
  4.3 Export Build Configuration Settings ................................................................................................. 33

5. Debug .................................................................................................................................................... 34
  5.1 Change Existing Debug Configurations ........................................................................................ 34
  5.2 Create New Debug Configurations ................................................................................................. 38
  5.3 Launch Bar ....................................................................................................................................... 39
  5.4 Basic Debugging Features .............................................................................................................. 40
    5.4.1 Breakpoints View ....................................................................................................................... 41
    5.4.2 Expressions View ....................................................................................................................... 42
    5.4.3 Registers View ........................................................................................................................... 44
    5.4.4 Memory View ............................................................................................................................. 45
    5.4.5 Disassembly View ....................................................................................................................... 47
    5.4.6 Variables View ............................................................................................................................ 49
    5.4.7 Eventpoints View ....................................................................................................................... 50
    5.4.8 IO Registers View ....................................................................................................................... 53
    5.4.9 Trace View .................................................................................................................................. 54
    5.4.10 Memory Usage View ............................................................................................................... 57

6. Help ....................................................................................................................................................... 61
1. General

Renesas e² studio is the Integrated Development Environment for Renesas embedded microcontrollers. e² studio is based on the industry-standard open-source Eclipse IDE framework and the C/C++ Development Tooling (CDT) project, covering build (editor, compiler, and linker control) and debug phases with an extended GNU Debug (GDB) interface support.

This document describes the usage of e² studio IDE to develop applications for the RX family series microcontrollers as an example.

1.1 System Configuration

Below is an example of a typical system configuration.

![Figure 1-1 System Configuration](image)

1.2 System Requirements

Hardware Environment:
- Processor: x64-based processor, at least 2GHz (support hyper-threading/multi-core CPU)
- Main Memory: At least 4GB, recommended 8GB of free memory space.
- Hard disk Capacity: At least 2GB of free space
- Display: Resolution at least 1,024 x 768; at least 65,536 colors
- Interface: USB 2.0 (High-speed/Full-speed). High-speed is recommended.

[Windows PC]
  (32-bit Windows is supported with e² studio V7.8.0)

[Linux PC]
- Supported OS: Ubuntu 20.04 LTS Desktop (64-bit version)
  Ubuntu 22.04 LTS Desktop (64-bit version)

Note: Supported features of Linux versions are different from Windows versions. Please refer to the Release Note for details. Project build features are not supported for the compiler products which do not have Linux support versions (such as CC-RX, CC-RL and CC-RH). Please use Windows for those compiler projects.

This document is described based on Windows version. Please refer to e² studio Release Note or FAQ page (mentioned in the Release Note) for installation in Linux PC. Operations after installation are very similar to Windows version.
1.3 Supported Toolchains

- Renesas C/C++ compiler package for RX family (CC-RX)
- Renesas C compiler package for RL78 family (CC-RL)
- Renesas C compiler package for RH850 family (CC-RH)
- LLVM and GCC for Renesas RL78 Toolchain
- GCC for Renesas RX Toolchain

**Note 1**: Two types of packages (with CS+ and without IDE) for each CC-RX, CC-RL and CC-RH are available. Any of those can be applied to e² studio.

**Note 2**: For RH850, the e² studio can be used to debug load modules in the ELF/DWARF format which were built with the IAR Embedded Workbench from IAR Systems or the MULTI IDE from Green Hills Software.

1.4 Supported Emulator Device

- E1(Note 1), E2, E2 Lite, E20(Note 2), or J-Link from Segger (RX)

**Note 1**: E1 emulator is EOL product.
**Note 2**: The E20 does not support RH850-family MCUs with the next-generation G4MH core, such as those of the RH850/E2x series. The E2 emulator is available for use with them.

1.5 Supported Simulator

- Renesas Simulator (RX, RL78)
- GDB Simulator (RH850)
2. Installation

The latest e² studio IDE installer package, available in 32-bit (earlier than V7.8.0) and 64-bit (later than 2020-04) versions, can be downloaded from Renesas website for free. It is recommended to install the 64-bit version on 64-bit PC.

Please check detailed information from https://www.renesas.com/e2studio. Note that user must log in to the Renesas account (on MyRenesas page) for the software download.

This chapter describes the installation and un-installation for the e² studio IDE.

Please uninstall the earlier versions before installation. Alternatively, install new e² studio into a new folder if you would like to keep earlier versions. Although upgrade installation is available, upgrading between incompatible versions is not allowed such as from V7.8.0 to 2020-04, 2022-10 to 2023-01. Please install into the new folder if failed.

The detailed information is described below.

2.1 Installation of e² studio IDE (64-bit version)

1. Double-click on e² studio installer to invoke the e² studio installation wizard page. Click [Install].

   Note: If e² studio was installed on your PC, the option to modify, remove the existing version or install e² studio to a different location will be displayed.

![Figure 2-1 64-bit e² studio Installation Wizard](image-url)
2. Welcome page

The install folder can be changed by clicking [Change…]. Click [Next] to continue.

**Note1:** If you would like to have multiple versions of e² studio, please specify new folder here.

**Note2:** Multi-byte characters cannot be used for e² studio installation folder name.

3. Device Families

Select all Devices Families you will use. Click [Next] to continue.

**Note:** Unchecked device families will not support any build features (project creation, import and build), nor debug features. Please be sure to select device family possibly be used.
4. Extra Features

Select Extra Features (i.e. Language packs, Git support, RTOS support…) to install. For non-English language menu, please select Language packs at this step.

Click [Next] to continue.

![Figure 2-4 Installation of 64-bit e² studio – Extra Features](image)

5. Customise Features

Select the components to install and click the [Next] button to continue.

![Figure 2-5 Installation Of 64-Bit e² studio – Features](image)
6. Additional Software

Select additional software (i.e. compilers, utilities, QE…) and click [Next] to continue.

**Note:** With no Internet access available, additional software installation can be skipped because software catalog cannot be downloaded. The additional software can be installed later.

![Figure 2-6 Installation Of 64-Bit e² studio – Additional Software](image)

7. License Agreement

Read and accept the software license agreement. Click the [Next] button. Please note that user must accept the license agreement, otherwise installation cannot be continued.

![Figure 2-7 Installation Of 64-Bit e² studio – Licenses](image)
8. Shortcuts

Select shortcut name (not mandatory) for start menu and click [Next] button to continue.

Note: If e² studio was installed in another location, it is recommended to rename to distinguish from the other e² studio(s).

![Figure 2-8 Installation Of 64-Bit e² studio – Shortcuts](image)

9. Summary

Components list to be installed is shown. Please confirm the contents and click the [Install] button to install the Renesas e² studio IDE.

![Figure 2-9 Installation Of 64-Bit e² studio – Summary](image)
10. Installing…

The installation is performed. Based on selected items of Addition Software, new dialogs are opened to proceed with installation for the software.

11. Results

Installation results are listed here. Please note if any errors are shown.

Click [OK] button to complete the installation.

![Figure 2-10 Installation Of 64-Bit e² studio – Results](image)
2.2 Installation of e² studio IDE (32-bit version)

1. Double-click on e² studio installer to invoke the e² studio installation wizard page. Click [Install].

   **Note:** If e² studio was installed in your PC, the option to modify, remove the existing version or install e² studio to a different location will be displayed. If you would like to have multiple versions of e² studio, please specify “Install to a different location” here. Click [Next] to continue.

   ![Figure 2-11 32-Bit e² studio Installation Wizard](image)

2. Welcome page

   Click [Next] to continue.

   ![Figure 2-12 Installation Of 32-Bit e² studio – Welcome Page](image)
3. Install Folder

The default installation location is set to: “C:\Renesas\e2_studio”. Enter folder name directly in the textbox or click [Browse...] button to modify it. Click [Next] to continue.

**Note1:** If you would like to have multiple versions of e² studio, please specify new folder here.

**Note2:** Multi-byte characters cannot be used for e² studio installation folder name.

![Figure 2-13 Installation Of 32-Bit e² studio – Install Folder](image)

4. Device Families

Select Devices Families to install. Click [Next] to continue.

![Figure 2-14 Installation Of 32-Bit e² studio – Device Families](image)
5. Extra Components

Select Extra Components (i.e. Language packs, SVN & Git support, RTOS support…) to install. For non-English language users, please select Language packs at this step.

Click the [Next] button to continue.

Figure 2-15 Installation Of 32-Bit e² studio – Extra Components

6. Components

Select the components to install and click the [Next] button to continue.

Figure 2-16 Installation Of 32-Bit e² studio – Components
7. Additional Software

Select additional software (i.e. compilers, utilities, QE…) and click [Next] to continue.

![Figure 2-17 Installation Of 32-Bit e² studio – Additional Software](image)

8. License Agreement, Shortcuts, Summary, Installing… and Results

The steps for these pages are the same as installation of e² studio 64-bit version.

Please refer to Chapter 2.1, step 7 onwards.
2.3 Un-installation of e² studio IDE

User can uninstall e² studio program following the typical steps to uninstall a program in Window OS.

1. Search for [Apps & features] in Window Search Box. Click on the search result to go to [Apps & features].
2. From the currently installed programs list, choose “e² studio” and click the [Uninstall] button.
3. Click the [Uninstall] button again to confirm the deletion of e² studio.

At the end of the un-installation, e² studio IDE will be deleted from the installed location and Windows short-cuts menu are removed.

Note: If you have installed e² studio at multiple locations, you may not find the uninstaller in “Apps & features” of Control Panel. In such cases, launch e² studio uninstaller located at: [e² studio installed folder]/uninstall/uninstall.exe.

2.4 Installation of Compiler Package

As mentioned above in installation procedure, compiler packages can be installed with e² studio when you have access to the Internet. Please install compiler packages separately from e² studio in the environment with no Internet access.

Compiler packages are found in the following Web sites. Please read descriptions in the Web sites for how to install them.

- Renesas Compiler for RX: http://www.renesas.com/rx_c
- Renesas Compiler for RL78: http://www.renesas.com/r78_c
- Renesas Compiler for RH850: http://www.renesas.com/rh850_c
- LLVM and GNU toolchain for RL78: https://llvm-gcc-renesas.com/rl78-download-toolchains/
- GNU toolchain for RX: https://llvm-gcc-renesas.com/rx-download-toolchains/
Open “Renesas Toolchain Management” dialog ([Help] menu -> [Add Renesas Toolchains]) to confirm which toolchains are installed and integrated. The checked toolchains are integrated into e² studio. Click [Add] button to add new toolchain installed path if it is not found in this list.

![Figure 2-18 Renesas Toolchain management](image)

You can also click [Download] button to install new toolchain when you have Internet connection.
3. Project generation

In e² studio, "Project" is a basic unit to perform build and debug operations. This chapter describes the creation of new project and import of existing e² studio project, High-performance Embedded Workshop IDE (described as “HEW” below) project and CS+ project to e² studio IDE.

Note: 1. To install and use the e² studio on your PC, you must install the compiler package provided separately.

2. Multi-byte characters cannot be used for e² studio installation folder name, project name and its folder, and source file name.

3.1 New Project Generation

To create a new project, invoke e² studio IDE from the Windows ([Start] menu) and specify a workspace directory.

1. Click [File] → [New] → [C/C++ Project] to open new project creation wizard.

![Figure 3-1 Open New Project Creation Wizard](image)

2. Select template for the new project (For e.g., Renesas RX: “Renesas CC-RX C/C++ Executable Project”). If the target device family or the toolchain were not listed, you may need to run e² studio installer to add “Build/Debug support plugins” for the target device family. Click [Next] to proceed.

![Figure 3-2 New Project Creation Wizard (1/6)](image)
3. Enter the project name. Click [Next] to proceed.

![Figure 3-3 New Project Creation Wizard (2/6)](image)


**Note:**

- "E1" or “E2” can be selected in the same way as E2 Lite in the Hardware Debug Configuration pull down menu.
- Please select “C++” as Language when you use C++ source files in the project.

![Figure 3-4 New Project Creation Wizard (3/6)](image)
5. Coding Assistant feature can be applied if necessary. Click [Next] to proceed.

**Note:**

- **Peripheral Code Generator (CG)** supports the generation of driver and peripheral function code based on GUI settings. Functions are provided as APIs and are not limited to initialization of peripheral function.
- **FIT** provides drivers and codes higher layer than CG, such as communication protocol stack and sample application programs using peripheral functions. All FIT modules are interchangeable because they are implemented with common interfaces.
- **Smart Configurator** supports a single user interface that combines the functionalities of Code Generator and FIT Configurator. Smart Configurator encompasses unified clock configuration view, interrupt configuration view and pin configuration view.

Peripheral Code Generator and Smart Configurator may not be available for some devices.

**Figure 3-5 New Project Creation Wizard (4/6)**

6. Keep the "Use Renesas Debug Virtual Console" unchecked and click [Next] to proceed.

**Figure 3-6 New Project Creation Wizard (5/6)**
7. A project summary is displayed. Click [Finish] to generate the project.

![Figure 3-7 New Project Creation Wizard (6/6)](image)

8. A new C project named “Tutorial” is created.

![Figure 3-8 New C Project Created](image)

This project consists of an application file “Tutorial.c” and standard start-up files (e.g. “dbsct.c”, “intprg.c”, “sbrk.c” etc). All these project and source files listed in the [Project Explorer] panel reflect the folder structure of the project, just as seen on the standard file explorer.

**Notes for backing up projects:**

- Project properties are stored in files or folders which filenames or folder names are prefixed with a '.' (dot), for example “.project” and “.cproject”. It is necessary to include these files or folders when archiving the project for back-up purpose.

- In order to restore properties shared among projects, for instance when one project makes reference to another project's files, please backup the whole workspace folder.
3.2 New Debug Only Project Generation

Creating a debug only project allows user to debug an existing executable which user has already built. This feature will automatically create a project and debug configuration for user.

**Note:** The e² studio can be used to debug load modules in the ELF/DWARF format which were built with the IAR Embedded Workbench from IAR Systems or the MULTI IDE from Green Hills Software.

To create a debug only project,

1. Click [File] → [New] → [C/C++ Project] to open new project creation wizard.

   ![Figure 3-9 Open New Project Creation Wizard](image)

2. Select template for the new project: [Renesas Debug] → [Renesas Debug Only Project]. Click [Next] to proceed.

   ![Figure 3-10 Specify The Project Template](image)
3. Enter the project name. Click [Next] to proceed.

![Figure 3-11 Specify Project Name](image)

4. Select debug hardware (e.g. “E2 (RH850)”), target device (e.g. R7F701007xFAP). Note that these settings should be consistent with the settings to build the executable file. Then specify the location of prebuilt executable file (i.e. executable file built in other IDEs) which should be built as ELF/DWARF format to be recognized by debugger. Click [Finish] to create the project.

![Figure 3-12 Specify Project Settings](image)
5. The project named “DebugOnly_Tutorial” is created. User can only modify the debug configuration of this project and start the debugging.

![Figure 3-13 Debug Only Project Is Created](image)

Figure 3-13 Debug Only Project Is Created
3.3 Importing a sample project

e² studio can search and import sample projects on Renesas Web site.
Open “File” menu and select “Import...” to launch Import Wizard. Then select “Sample Project on Renesas Website”.

![Sample Project Import Wizard](image1)

**Figure 3-14 Sample Project Import**

Select target device family in Online or Local category, then select device. Sample projects will be listed for the device. Click [Finish] to import the selected project. Please refer to the following chapters for the operations after project import.

![Sample Projects of Target Device](image2)

**Figure 3-15 Sample Projects of Target Device**
3.4 Import Existing Projects into Workspace

The migration guideline between integrated development environments (i.e. import CS+/HEW projects to e² studio, or export to CS+) can be found at the following site.


To import an existing e² studio project to current workspace, please follow below instructions. These steps import a sample project from Renesas website for demonstrating debugging features in section 5.

1. Download the sample code for RX64M by searching for “RX64M Renesas Starter Kit Sample Code for e² studio” from Renesas website: https://www.renesas.com.

2. “Tutorial” project is included in the download file.
3. In e² studio, select [File] → [Import]

![Figure 3-18 Import The Sample Project](image)

4. In the [Import] dialog, select [General] → [Existing Projects into Workspace]. Click [Next].

![Figure 3-19 Select Import Wizard](image)
5. In the [Import Projects] dialog, select “Select archive file”. Click [Browse] then select the downloaded zip file

![Figure 3-20 Select Project Location To Import](image)

6. The project “Tutorial” will be listed in “Projects”. Check “Tutorial” then click [Finish]

![Figure 3-21 Complete Project Import](image)
7. Right click on the imported project and select “Upgrade Legacy e2 studio Projects…”

8. Select “Tutorial” project and click [Finish]
9. Open the project properties, select [C/C++ Build] → [Settings] in the left pane. Select tab [Toolchain] and select the latest toolchain for the project. Click [Apply and Close].

![Figure 3-24 Update Project Toolchain](image)

10. Build the project and make sure that it is successful.
3.4.1 Download and import sample projects in Smart Browser view

You can also download sample projects from Renesas Web site through Smart Browser view. Open “Renesas Views” -> “Solution Toolkit” -> “Smart Browser” menu (or via “Window” -> “Show View”) to open the view. Right-Click on an item listed in [Application Notes] tab and select “Sample Code (import projects)” to import a sample project into current workspace. The Application Notes marked as “available” in “Sample Code” column are provided with sample projects.

Figure 3-25 Application Notes in Smart Browser view
4. **Build**

This chapter describes the build configurations and key build features for e² studio IDE.

4.1 **Build Option Settings**

A new project built with default option can work properly. However, if user would like to change build options (e.g. toolchain version, optimization options, etc.), please follow the following steps before building the project.

1. Right click on project “Tutorial” and select [Properties] to open the Properties window.

Properties window is supported at workspace, project and source level. Properties window for project supports more configurations which apply across all the files within the same project workspace.

![Figure 4-1 Open The Properties Window](image)

**Figure 4-1 Open The Properties Window**
2. Click [C/C++ Build] → [Settings] → [Toolchain] to view or change toolchain version. Click the “Versions” option to change toolchain version (if additional toolchain is installed).

![Figure 4-2 Change Toolchain Version](image)

3. Click [C/C++ Build] → [Environment] to set build option and add or edit the environment variables.

![Figure 4-3 Build Environment Settings](image)
4. Setting Build Options

Right click on a project in the Project Explorer and select [Properties] to open the Properties window.

Build options for compiler and linker, etc. can be set on "C/C++ Build" → "Settings" → “Tool Setting” tab.

User could set all build settings under ‘Tool Settings’ tab.

The “Build configuration” can be switched via “Configuration:” dropdown list at the top of the window. Each build configuration manages a set of build options.

Click [Apply and Close] to save the build setting changes.

![Figure 4-4 Build Option Settings](image)

The detail of build option is described in compiler user manual which is stored at "{Compiler installation directory}\doc". For example, it can be found in "C:\Program Files (x86)\Renesas\RX\3_2_0\doc\".

**Note:** There is "Toolchain Editor" under "C/C++ Build", please do not change the configuration. The Toolchain editor is used for toolchains which are NOT supported by Renesas build support plugins.
4.2 Build A Sample Project

A project can be built by the steps below:

1. Right click on the project and select [Build Project].

2. Check the [Console] pane shows ‘Build complete.’ message to indicate a successful build.

   At the end of this build, files output to the ${CONFIGDIR} directory consists of “makefile”, “Tutorial.abs”, “Tutorial.map”, “Tutorial.mot”, “Tutorial.x” etc.

   “Tutorial.abs” is a Renesas standard load module in ELF/DWARF format (*.abs) used for the debugging. Because GDB supports a load module format with different ELF/DWARF specification (*.x or *.elf), hence “Tutorial.abs” has to be converted to “Tutorial.x” for the debugging in e² studio IDE.

3. In some cases, the build can be unsuccessful. The console window will show error messages, please check it and revise the source code or configuration and rebuild the project.
4.3 Export Build Configuration Settings

The Project Reporter feature can export project and build configuration settings from e² studio IDE to a file for easy checking and comparison of project/build environment settings.

1. Right-click at [Project Explorer] to pop up the context menu.

Figure 4-8 Project Reporter
5. Debug

This chapter describes the usage of debug configuration and key debugging features for e² studio. The following illustration refers to “Tutorial” project built (in Chapter 4.2) and based on hardware configuration E2 emulator Lite and RSK RX64M board.

Firstly, open “Tutorial” project workspace in e² studio IDE and click [Debug] perspective.

![Figure 5-1 Switch To [Debug] Perspective](image)

Perspective defines the layout views (related to development tools) in the Workbench window. Each perspective consists of a combination of views, menus and toolbars that enable user to perform specific task.

For instance, [C/C++] perspective has views that help user to develop C/C++ programs and [Debug] perspective has views that enable user to debug the program. If user attempts to connect the debugger in the [C/C++] perspective, IDE will prompt users to switch to the [Debug] perspective.

One or more perspectives can exist in a single Workbench window. User can customize them or add new perspective.

Note: For more information on debug, please refer to “e2 studio User Guide” as described in chapter 6.

5.1 Change Existing Debug Configurations

The debug configuration has to be configured when debugging for the first time and it just needs to be done once. An existing debug configuration can be changed as follows.


   Click [Run] → [Debug Configurations…] or ![icon](image) → [Debug Configurations…] to open the “Debug Configurations” window.

![Figure 5-2 Open Debug Configurations Window](image)
2. In “Debug Configurations” windows, go to [Renesas GDB Hardware Debugging] → [Tutorial HardwareDebug]. Click on the [Main] tab to ensure the load module is “Tutorial.x”.

![Figure 5-3 Select Load Module](image)

3. Switch to the [Debugger] tab, set “E2 Lite (RX)” as the debug hardware and “R5F564ML” as the target device.

![Figure 5-4 Select Target Device](image)

4. Under the [Debugger] tab, go to the [Connection Settings] sub tab which is related to emulator connection. The following example is based on the environment with E1 emulator and RSK RX64M board:
   - Clock
     - Main Clock Source = “EXTAL”
     - Extal Frequency(MHz) = “24.0000”
   
   **Note**: Extal frequency is the value printed on the oscillator device on your board.

   - Connection with Target Board
     - Connection Type = “JTag”
- JTAG Clock Frequency [MHz] = “6.00”
- Hot plug = “No”

Hot plugin feature is only available with the device which has the capability. Please refer to device Hardware manual for "On chip debugger" specifications for the details.

- **Power**
  - Power Target From The Emulator (MAX 200mA) = “No”
    
    Choose "Yes" if you would like to supply power through an emulator, when external power is unplugged. Choose "No" if external power is plugged.

- **Communication Mode**
  - Mode = “Debug Mode”

Another communication mode "Write On Chip Flash Memory" is used for flashing codes including ID code area, however debugger will be disconnected after flash.

**Note:** This debug configuration in Figure 5-5 is shown as an example. The wrong settings may cause malfunction or damage to the hardware. So, be cautious to verify the board and emulator settings before connection.

**Figure 5-5 Change Connection Setting**
5. Switch to [Debug Tool Settings] sub tab which is related to debugger behavior, please refer to the e² studio Help content at "e² studio User Guide" → "Debugging Projects" for the details.

- **Memory**
  - **Endian** = “Little Endian”
    
    Endian setting of debugger memory reference. This configuration does not affect to target program behavior.
  
    - “Internal Flash Memory Overwrite”, "External Memory Areas"

    These configuration control to allow/deny flashing blocks upon module downloads. Uncheck specific memory blocks if you would like to reserve the contents.

6. Click [Apply] button to confirm the settings. Then click [Debug] to launch debugger.

7. For a successful connection, [Debug] view to show target debugging information in a tree hierarchy. The program entry point is set at “PowerON_Reset() in “resetprg.c”.

![Figure 5-6 Change Debug Tool Settings](image)

![Figure 5-7 User Target Connection In The [Debug] View](image)
5.2 Create New Debug Configurations

The simplest way to create a new debug configuration is by duplicating an existing one. It can be done by the following steps.

1. Repeat step 1 in section 5.1 to open “Debug Configurations” window.

2. Select a debug configuration (e.g. “Tutorial HardwareDebug”) and then click icon (Duplicates the currently selected launch configuration). A new debug launch configuration (e.g. “Tutorial HardwareDebug (1)”) is created. User can rename it to identify the settings by typing in the “Name” textbox then click [Apply] button.

3. The debug launch configuration can be configured as described in chapter 5.1. For example, change the Debug Hardware to “E2 Lite (RX)”. 

4. If the launch configuration was added with [local] and * (red star) marker, it is not yet attached to any project. Then please specify the project name in the Common tab.
5.3 Launch Bar

This section explains the usage of ‘Launch Bar’ in the toolbar area of e² studio main window. This interface is hidden by default in some of e² studio versions.

The interface shown below builds and debugs for the selected launch target. (May or may not be the same project as active project in Project Explorer.)

![Launch Bar Interface](image)

Launch Bar buttons behave as follows:

- ![button](image) button builds the load module of the selected launch configuration.
  
  **Note:** There is another build button ![button](image) in the "File toolbar" that builds active build configuration of Project Explorer, while the launch bar does not reflect the active state in Project Explorer.

- ![button](image) buttons are trigger of debugger launch and terminate the selected launch target.

Launch Bar and build button can be shown or hidden through the following dialog:

- Click [Window] menu → [Preferences], then click [Run/Debug] → [Launching] → [Launch Bar]
5.4 Basic Debugging Features

This section explains the typical Debug views supported in e² studio IDE.

- Standard GDB Debug (supported by Eclipse IDE framework): Breakpoints, Expressions, Registers, Memory, Disassembly and Variables
- Renesas Extension to Standard GDB Debug: Eventpoints, IO Registers and Trace.

The following are some useful buttons exist in the [Debug] view:

![Figure 5-11 Useful Toolbars In Debug Views](image)

The program is run by clicking button or pressing [F8].

The program can be paused by breakpoint or by clicking button. When program is paused, user can perform the following operations:

- button or [F5] can be used for stepping into the next method call at the currently executing line of code.
- button or [F6] can be used for stepping over the next method call (executing but without entering it) at the currently executing line of code.
- button can be clicked again to resume running.

To stop the debugging process, button is clicked to end the selected debug session and/or process or button is clicked to disconnect the debugger from the selected process.

The other operations are as following:

- button can be clicked to start new debug session.
- button can be clicked to reset the program to entry point at the PowerOn Reset.
- button is used for re-downloading the binary file to target system.

Note: To demonstrate the features in following section, please use the sample code for RX64M from Renesas website as instruction in section 3.3.
5.4.1 Breakpoints View

The Breakpoints view stores the breakpoints that were set on executable lines of a program. If a breakpoint is enabled during debugging, the execution suspends before that line of code executes. e² studio allows software and hardware breakpoints to be set explicitly in the IDE. Any breakpoints added via double click on the marker bar are by default hardware breakpoints. If the hardware resources are not there then the breakpoint setting will fail. In case of a hardware breakpoint setting failure, an error message will prompt the user to switch to a software breakpoint.

To select a default Hardware or Software breakpoint type:

- Right-click on the marker bar to pop up the context menu. For a hardware breakpoint, select [Breakpoint Types] → [e² studio Breakpoint]. For a software breakpoint, select [Breakpoint Types] → [C/C++ Breakpoints].

To set a breakpoint:

1. Open “r_cg_main.c”, double-click on the marker bar located in the left margin of the [C/C++ Editor] pane to set a breakpoint. A dot (Hardware breakpoint) or (Software breakpoint) is displayed in the marker bar depending on the [Breakpoint Type] selected. [Breakpoint Type] is hardware breakpoint by default.

2. Alternatively, right-click at the marker bar to choose [Toggle Hardware Breakpoint] or [Toggle Software Breakpoint] to set a hardware breakpoint or a software breakpoint.

3. Click [Windows] → [Show View] → [Breakpoints] or icon (or use shortcut key [ALT] + [Shift] + [Q], [B]) to open the [Breakpoints] view to view the corresponding software breakpoints set. Software breakpoints can be enabled and disabled in the [Breakpoints] view.

To disable breakpoints, users can choose to disable specific breakpoints or to skip all breakpoints:

1. To disable a specific breakpoint, right-click on the Software breakpoint or Hardware breakpoint located in the left margin of the [C/C++ Editor] pane and select [Disable Breakpoint], or uncheck the related line in the Breakpoints view. A disabled breakpoint is displayed as a white dot ( or ).

2. To skip all breakpoints, click on the icon in the Breakpoints view. A blue dot with a backslash will appear in the editor pane as well as in the Breakpoints view.

Figure 5-12 [Breakpoints] View
5.4.2 Expressions View

Expressions view monitors the value of global variable, static variable or local variable during debugging. For all RX debuggers, these variables (including the local variables in scope) can be set for real-time refresh.

![Figure 5-13 [Expressions] View](image)

To watch a global variable,

1. Click [Window] → [Show View] → [Expressions] or icon to open the [Expressions] view.
2. Drag and drop a global variable over to the [Expressions] view. (Alternatively, right-click at the global variable to select “Add Watch Expression…” menu item to add it to the [Expressions] view).
3. In the [Expressions] view, right-click to select “Real-time Refresh” menu item. This refresh the expression value in real-time when program is running. The character “R” indicates that this global variable will be updated in real-time.
4. To disable the “Real-time Refresh”, simply right-click to select “Disable Real-time Refresh” menu item.
Local variables can be added with the same way. However, the watch is not available when the program is running out of the scope of the variable.

Figure 5-14 Add Local Variable To Expression View
5.4.3 Registers View

Registers view lists the information about the general registers of the target device. Changed values are highlighted when the program stops.

![Figure 5-15 [Registers] View](image)

To view the general register “r0”,
1. Click [Window] → [Show View] → [Registers] or icon to open the [Registers] view.
2. Click “r0” to view the values in different radix format.

Values that have been changed are highlighted (e.g. in yellow) in the [Registers] view when the program stops.
5.4.4 Memory View

Memory view allows users to view and edit the memory presented in “memory monitors”. Each monitor represents a section of memory specified by its location called “base address”. The memory data in each memory monitor can be presented in different “memory renderings”, which are the predefined data formats (e.g. Hex integer, signed integer, unsigned integer, ASCII, image etc.).

To view memory of a variable (e.g. “adc_count”),

1. Click [Window] → [Show View] → [Memory] or icon to open the [Memory] view.

2. Click the icon to open [Monitor Memory] dialog box. Enter the address of the variable “adc_count”.

The global variable “adc_count” is presented in memory renderings of “Hex Integer” format.

Figure 5-16 [Memory] View (1/2)
To add new renderings format (e.g. Raw Hex) for the variable “adc_count”,

1. Click the tab to select “Raw Hex” to add the rendering

This creates a new tab named “&adc_count < Raw Hex>” next to the tab “&adc_count<Hex Integer>”.

Figure 5-17 [Memory] View (2/2)
5.4.5 Disassembly View

Disassembly view shows the loaded program as assembler instructions mixed with the source code for the comparison. Current executing line is highlighted by an arrow marker in the view. In the [Disassembly] view, user can set breakpoints at the assembler instruction, enable or disable these breakpoints, step through the disassembly instructions and even jump to a specific instruction in the program.

![Figure 5-18 [Disassembly] View](image)
To view both C and assembly codes in a mixed mode,

1. Click [Window] → [Show View] → [Disassembly] or icon to open the [Disassembly] view
2. Click icon to enable the synchronization between assembly source and the C source (active debug context).
3. In [Disassembly] view, right-click at the address column to select “Show Opcodes” and “Show Function Offsets”.
4. You can enable source addresses within the editor using the context menu.

![Figure 5-19 Source Addresses Menu](image)

![Figure 5-20 Source Addresses Displayed In Editor](image)
5.4.6 Variables View

Variables view displays all the valid local variables in the current program scope.

Please refer to ‘Expressions’ view to watch global variables or external variables out of current program scope.

To observe a local variable (e.g. “position” for function “R_LCD_Display()”),

1. Click [Window] → [Show View] → [Variables] or icon to open the [Variables] view.
2. Step into the function “R_LCD_Display()” to view the value of local variable “position”.

Note:
The variables which optimized out or temporary allocated to accumulator registers may not appear in this view. Please refer to Disassembly view if necessary.
By disabling optimization, variables would become visible in most of the cases. However, it means to give up all benefits of optimization such as memory efficiency, code size reduction and performance improvement.
5.4.7 Eventpoints View

An event refers to a combination of conditions set for executing break or trace features during program execution. [Eventpoints] view enables user to set up or view defined events of different category e.g. trace start, trace stop, trace record, event break, before PC, performance (timer) start and performance (timer) stop.

The number of events that can be set and the setting conditions differ with each MCU. These are two (2) types of events:

- Execution address: The emulator detects execution of the instruction at the specified address by the CPU. It can be a “before PC” break (e.g. with event condition is satisfied immediately before execution of the instruction at the specified address) or other events (e.g. with event condition is satisfied immediately after execution of the instruction at the specified address).
- Data access: The emulator detects access under a specified condition to specified address or specified address range. This allows to setup complex address and data matching criteria.

Event combination (e.g. OR, AND (cumulative) and Sequential) can be applied to two (2) or more events.

To set an event break for a global variable when address/data is matched (e.g. when adc_count = ’0x6’),

1. Click [Window] → [Show View] → [Eventpoints] or icon to open the [Eventpoints] view.
3. Click [Add…] button to continue.

![Figure 5-22](image-url)
4. Select “Data Access” as the eventpoint type.

5. Go to the [Address Settings] tab, click the icon to browse for the symbol "&_adc_count". (The address of this global variable is "&_adc_count")
6. Next, switch to the [Data Access Settings] tab, enable the [Compare Settings] checkbox and set the compare value equals to "0x6". Click [OK] to proceed.

7. Ensure that the event break for “adc_count = 0x6” is set and enabled in the [Eventpoints] view. Reset to execute the program from the start. Press SW1 6 times.

![Figure 5-24 Execution Of Event Break](image)

Figure 5-24 Execution Of Event Break

Figure 5-24 shows that when adc_count reaches the value of 6 (or 0x6), the program stops at code line No.140 (right after the line of code increasing adc_count).
5.4.8 IO Registers View

IO Registers is also known as the Special Function Registers (SFR). The IO Register view displays all the registers set defined in a target-specific IO file, including their address, hex and binary value. User can further customize own IO registers view by adding IO registers selectively to the Selected Registers pane.

To view selected IO registers (e.g. PDR and PCR in PORT0),

1. Click [Windows] → [Show View] → [Others…]. In “Show View” dialog, click [IO Registers] under [Debug] or icon to open the IO Registers view.

2. Under the [All Registers] tab, locate [PORT0] in the IO Registers view. Expand the PORT0 IO register list. You could also use Search button in the IO Register toolbar to quickly search by name.

3. Drag and drop the “PDR” and “PCR” to the Selected Registers pane. A green dot besides the IO register indicates the status of being the selected register(s).

4. Switch to the [Selected Registers] tab to view “PDR” and “PCR” of the “PORT0” IO register.

The expanded IO register list may take a longer time to load in the [All Registers] pane. Hence, it is advisable to customize and view multiple selected IO registers from the [Selected Registers] pane.
5.4.9 Trace View

Tracing means the acquisition of bus information per cycle from the trace memory during user program execution. The acquired trace information is displayed in the [Trace] view. It helps user to track the program execution flow to search for and examine the points where problems arise.

The trace buffer is limited (with size of 1 to 32 Mbytes), oldest trace data is overwritten with the new data after the buffer has become full.

![Figure 5-26 [Trace] View (1/2)](image-url)
To set a point-to-point trace between the two (2) functions (e.g. tracing from function “main()” to “R_LCD_Display()”),

1. Click [Windows] → [Show View] → [Others…]. In “Show View” dialog, click [Trace] under [Debug] or icon to open the [Trace] view.

2. Turn on the Trace view by selecting the icon.

3. Click icon (Acquisition) to set
   - Trace Mode: “Fill until stop”
   - Trace Type: “Branch”
   - Bus Master Of Data Access: “CPU”

4. Click [OK] to proceed.

Figure 5-27 [Trace] View (2/2)
6. Under the [Start] tab, add the 1st event point at “main()” function (by the execution address “&main”).
7. Then, switch to [Stop] tab, add the 2nd event point at “R_LCD_Display()” function (by the execution address “&R_LCD_Display”).
8. Next, execute the program after reset.

The figure above shows the trace result from function “main()” to “R_LCD_Display()”. The trace result can be filtered by the key trace parameters (e.g. branch type, address range) and saved to the .xml format (with the inclusion of bus, assembly and source information).

Note: External trace feature of RX device with E20 emulator works only through Mictor-38pin interface. However, it is not available through 14pin JTAG/FINE interface, even with E20 emulator. RX emulator interface specifications can be downloaded at the following site.

https://www.renesas.com/search/keyword-search.html#q=R20UT0399
5.4.10 Memory Usage View

Memory view allows users to view the total memory size, usage of ROM and RAM ratio and detailed information of sections, objects, symbols, module, vector and cross reference used in project.

To view the memory usage of a project,

1. Click [Window] → [Show View] → [Other…] → [Debug] → [Memory Usage] to open the memory usage view.
2. The default display of memory usage view is different for each kind of project.

   a. The GUI of memory usage view for executable project which uses Renesas Toolchain includes 3 regions: (1) Group size region, (2) RAM/ROM Usage region/Device Memory Usage region, (3) Detail table region. The map file location is shown at bottom bar.

   ![Figure 5-29 Executable Project - Renesas Toolchain](image1)

   ![Figure 5-30 Executable Project - GCC Toolchain](image2)

   b. For executable project which uses GCC Toolchain, “Memory region usage” region (2) will be displayed instead of RAM/ROM usage region:
c. For library project which uses Renesas Toolchain, “Library information view” will be displayed instead of “Group size view”

**Note:** Only available for Renesas CCRX or CCRL toolchains.

![Figure 5-31 Library Project - Renesas Toolchain](image)

---

d. Memory usage view is not available for library project which uses GCC Toolchain.

**Group size view:**

Displays the total size of Program, Constant, Initialized Data, Uninitialized Data, Data, Stack and Other according to the selected map file.

**Note:** This view only displays for executable project of supported toolchains.

**Library information view:**

Displays the information of selected library list file. The information to be visualized on this region consists of:
- The name of the selected library
- The type of CPU specified by the project
- Endian
- Attribute
- Number of module.

**RAM/ROM usage region:**

Shows percentage of RAM/ROM usage by numerical value and status of bar. Color of bar is based on percentage value.
- If percentage < 75%: Green.
- If percentage >= 75% and percentage < 90%: Orange.
- If percentage >= 90%: Red.

**Memory region usage region:**

Display feature of this region is similar to RAM/ROM usage region.
Device memory usage region:

Device Memory Usage region shows device memory of selected project's device. Each memory area shows name, start address, end address, used size and size.

Figure 5-32 Device Memory Usage Region

Expand memory area to see all sections. Color of sections corresponds with that of Group Size Region.

Figure 5-33 Expand Memory Area

Detail table region:

Display the map file information of an active project or the opened map file.

- “Section” tab: contains “Linkage map” table which displays the list of Sections analyzed from map file and its detailed information.
- “Object” tab: contains “Object” table which displays the list of Objects analyzed from map file and its detailed information.
- “Symbol” tab: contains “Symbol” table which displays the list of Symbols analyzed from map file and its detailed information.
- “Vector” tab: displays the vector table information that is retrieved from map file. This tab is only available for executable project that is configured to work with Renesas CC-RX/CC-RL/CC-RH toolchains.
- “Cross Reference” tab: displays the cross reference information that is retrieved from map file. This tab is only available for executable project.

- “Module” tab: contains “Module” table. “Module” tab is only available for library project that is configured to work with Renesas CC-RX/CC-RL/CC-RH toolchains.

**Map file location:**

Memory Usage will display the information of (*.map) file or library list file (*.lbp) from project. User can see the relative path of selected map file or library list file at the bottom of Memory Usage view.
6. Help

The help system allows users to browse, search, bookmark and print help documentation from a separate Help window or Help view within the workbench. Users can also access an online forum dedicated to the e² studio from here.

Click on [Help] tab to open the Help menu.

Quick Help Tips:

1. Click [Welcome] for an overview of the e² studio and to view Release Notes.
2. Click [Help Contents] to open a separate Help window with a search function.
   
   There are many useful topics under the [Help Contents]. Example, the “Debugging Projects” topic which provides useful information such as debug configuration, supported number of breakpoints, etc. It can be launched by clicking on the [Help] menu → [Help Contents] → “e² studio User Guide”.

3. Click [Show Contextual Help] to open the Help view within the workbench.
4. Click [RenesasRulz Community Forum] to go an online forum that is dedicated to topics and discussions related to the e² studio (Internet connection is required).
<table>
<thead>
<tr>
<th>Rev.</th>
<th>Date</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.00</td>
<td>June 21, 2023</td>
<td>First edition for RX, RL78, RH850 based on e² studio 2023-04</td>
</tr>
</tbody>
</table>
RX/RL/RH Family