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• The information in this document is current as of May, 2009. The information is subject to change 
without notice. For actual design-in, refer to the latest publications of NEC Electronics data 
sheets or data books, etc., for the most up-to-date specifications of NEC Electronics products. 
Not all products and/or types are available in every country. Please check with an NEC Electronics 
sales representative for availability and additional information. 

• No part of this document may be copied or reproduced in any form or by any means without the prior 
written consent of NEC Electronics. NEC Electronics assumes no responsibility for any errors that may 
appear in this document. 

• NEC Electronics does not assume any liability for infringement of patents, copyrights or other intellectual 
property rights of third parties by or arising from the use of NEC Electronics products listed in this 
document or any other liability arising from the use of such products. No license, express, implied or 
otherwise, is granted under any patents, copyrights or other intellectual property rights of NEC Electronics 
or others. 

• Descriptions of circuits, software and other related information in this document are provided for 
illustrative purposes in semiconductor product operation and application examples. The incorporation of 
these circuits, software and information in the design of a customer's equipment shall be done under the 
full responsibility of the customer. NEC Electronics assumes no responsibility for any losses incurred by 
customers or third parties arising from the use of these circuits, software and information. 

• While NEC Electronics endeavors to enhance the quality, reliability and safety of NEC Electronics 
products, customers agree and acknowledge that the possibility of defects thereof cannot be eliminated 
entirely. To minimize risks of damage to property or injury (including death) to persons arising from 
defects in NEC Electronics products, customers must incorporate sufficient safety measures in their 
design, such as redundancy, fire-containment and anti-failure features. 

• NEC Electronics products are classified into the following three quality grades: "Standard", "Special" and 
"Specific". 
The "Specific" quality grade applies only to NEC Electronics products developed based on a customer-
designated "quality assurance program" for a specific application. The recommended applications of an 
NEC Electronics product depend on its quality grade, as indicated below. Customers must check the 
quality grade of each NEC Electronics product before using it in a particular application. 
"Standard": Computers, office equipment, communications equipment, test and measurement  
  equipment, audio and visual equipment, home electronic appliances, machine tools,  
  personal electronic equipment and industrial robots. 
"Special": Transportation equipment (automobiles, trains, ships, etc.), traffic control systems,  
  anti-disaster systems, anti-crime systems, safety equipment and medical equipment  
  (not specifically designed for life support). 
"Specific": Aircraft, aerospace equipment, submersible repeaters, nuclear reactor control  
  systems, life support systems and medical equipment for life support, etc. 

The quality grade of NEC Electronics products is "Standard" unless otherwise expressly specified in NEC 
Electronics data sheets or data books, etc. If customers wish to use NEC Electronics products in applications 
not intended by NEC Electronics, they must contact an NEC Electronics sales representative in advance to 
determine NEC Electronics' willingness to support a given application. 

(Note) 
(1) "NEC Electronics" as used in this statement means NEC Electronics Corporation and also includes its 
majority-owned subsidiaries. 
(2) "NEC Electronics products" means any product developed or manufactured by or for NEC Electronics (as 
defined above). 
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1. Introduction 
 
The Data FLASH Editor is a windows based tool that allows to visualize and modify the EEPROM emulation 
data of a Data FLASH memory image of a V850E/ES microcontroller. The Data FLASH Editor does support 
memory images in the Intel-hex or Motorola-S record file format. The corresponding memory image can be 
generated by the Data FLASH Converter or it can be uploaded from a V850E/ES based in-circuit emulator 
by using the IAR, GHS or NEC debugger. 
 
The Data FLASH Editor supports to view, modify and to save EEPROM emulation data of an existing Data 
FLASH memory image. In addition, the Data FLASH Editor supports to add or remove EEPROM emulation 
data entries to respectively from a existing Data FLASH memory image. 
 

1.1 Main features of Data FLASH Editor 
 
• .NET Framework 2.0 based application 
 
• User friendly and intuitive windows based graphical user interface. 

 
• Visualization of EEPROM emulation data of a Data FLASH memory image. 

 
• Modification of EEPROM emulation data entries: ADD, MODIFY or REMOVE. 
 
• Loading of Data FLASH memory images generated by the Data FLASH Converter or IAR, GHS, NEC 

debuggers. 
 

• Restoring of modified EEPROM emulation data to an existing Data FLASH memory image. 
 
 
 

1.2 Trademarks 
 
Green Hills, the Green Hills logo, CodeBalance, GMART, GSTART, INTEGRITY, and MULTI are registered 
trademarks of Green Hills Software, Inc. AdaMULTI, EventAnalyzer, G-Cover, GHnet, GHnetLite, Green 
Hills Probe,Integrate, ISIM, PathAnalyzer, Quick Start, ResourceAnalyzer, Safety Critical Products, Slingshot, 
SuperTrace Probe, TimeMachine, and TotalDeveloper are trademarks of Green Hills Software, Inc. 
 
IAR Embedded Workbench, visualSTATE, IAR MakeApp and C-SPY are registered trademarks of IAR 
Systems AB. Microsoft and Windows are registered trademarks of Microsoft Corporation. Adobe and 
Acrobat Reader are registered trademarks of Adobe Systems Incorporated.  
 
Windows and Windows Vista are either registered trademarks or trademarks of Microsoft Corporation in the 
United States and/or other countries. 
 
PC/AT is a trademark of International Business Machines Corporation. 
 
All other company, product, or service names mentioned in this documentation may be trademarks or 
service marks of their respective owners. 
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2. Documents / References 
 
For more details on the EEPROM emulation concept of the 32-bit Single-Chip V850E/ES microcontroller 
family and the corresponding tools, please refer also to the documents below. 
 
 

Doc number Title Doc Type 
U18005EE1V2AN00 32-bit Single-Chip Microcontrollers V850 

EEPROM Emulation Library 
 

Application Note 
 

U18042EE1V2AN00 32-Bit Single-Chip Microcontroller V850 
Library for the Data Flash Access Layer 
 

Application Note 
 

U19003EE1V0UM00 Data FLASH Converter Conversion tool for 
data flash memory image generation 
 

Users Manual 
 

        Table 1: Documents / References 
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3. Input files / formats 
 
The Data FLASH Editor does support Data FLASH memory images in the Intel-hex and Motorola-S record 
file format. 
 
 

4. Output file / formats 
 
The output format of the Data FLASH Editor is always the same as the chosen input file format of a loaded 
Data FLASH memory image, the Intel-hex or respectively the Motorola-S record file format. 
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5. EEPROM emulation data  
 
In opposite to a classical EEPROM, where the data is stored on a fixed address and so can always be found 
on the same location, EEPROM emulation need to store data on changing locations. From the different 
options to find the data during Read operations, the NEC EEPROM emulation uses the way to bundle a 
certain set of data with one ID, that is then searched in memory on data Read. Writing new data sets is 
easily done, by appending the data to the data pool. 
 
Furthermore, the write granularity differs between real EEPROM and the Data FLASH used for EEPROM 
emulation. While the EEPROM can usually be written in 8-bit or 16-bit units, the Data FLASH must be written 
in 32-bit units (+1Bit for the ID-Tag, see below). 
 

 
 Figure 1: EEPROM Data set Representation 

 
The approach of using IDs to identify a set of data is in-line with AUTOSAR, as well as the ID size of 16 bits 
and length information of 16 bits. 
 
Differing from Code FLASH with 32-bit width, the currently implemented NEC Data FLASH is 33-bit wide. 
The 33-rd bit is called the ID-Tag, indicating, that the word is information and not part of the data set itself. 
The current implementation in the EEPROM emulation layer sets this on the bottom ID-L, while keeping it 
un-set on the data bits and on the top ID-L. Dedicated hardware on the Data FLASH macro can search for a 
certain ID by using this ID-Tag. 
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5.1 Overview 
 
A EEPROM emulation Data FLASH section consists of 3 parts: 
 

→ Section Header 
→ Data Zone 
→ ID Zone 

 

 
         Figure 2: EEPROM Emulation Section Overview 
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5.2 Section Header 
 
Section header size is 16 Bytes (4 Words), where currently 3 words are used to define the current section 
status. 
 

 
                    Figure 3: Section Header 

 
The erase counter word consists of the 16-bit counter and a 16-bit inverse value for protection. It describes 
the number of erase cycles on the data section. 
 
The active marker and / or the consumed marker have the value 0x55555555. The value of a marker which 
is cleared is 0xFFFFFFFF (Blank Word). The following section states are possible: 
 
The following section states are possible: 
 

→ Prepared: 
 
The section has been erased. In the section header the erase counter is written. Active marker and 
consumed marker are cleared. This section is ready for activation by a Refresh operation. 

 
→ Active: 

 
The section contains the latest data sets. The EEPROM emulation can read and write data to 
this section. In the section header, additionally to the erase counter, also the active marker is set. 
Consumed marker is cleared. 

 
→ Consumed: 

 
The section is full, no more space was available to Write new data sets. After activating the next 
section and copying the latest data sets there, the Refresh operation marked the full section 
consumed. In the section header additionally, to the erase counter and active marker, also the 
consumed marker is set. Next step is to Prepare the section. 

 
→ Invalid: 

 
This is no valid state. During operation it can only occur in case of interruption of a FLASH operation 
like erase to this section. The section header may contain any other data except as described in the 
three states before. Also a completely erased FLASH (default factory delivery state) is invalid from 
EEPROM emulation point of view. 

 
 
The normal section state transitions are: 
 
Prepared --> Active --> Consumed --> Prepared -->... 
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5.3 ID zone 
 
The ID-zone is a list of IDs of the data sets written to the section so far. The ID-list is dynamically generated 
during writing new data sets into the section. An ID-List is required in order to simplify and to speed up 
Refresh operations (copying data sets from a full data section to a prepared one). The solution to keep the 
ID-list dynamically in the EEPROM Emulation FLASH space instead of keeping it statically in the Code 
FLASH area has been chosen, in order to allow new/added applications to store data sets with new IDs. The 
ID-zone grows by time in case of writing new data sets with new IDs. 
 
 

5.4 Data zone 
 
The data zone contains the data sets. New data sets are simply appended after the last written data set. So 
the data zone grows down in the address space. The section is full and a Refresh is required, when there is 
no more enough erased space between ID zone and data zone for the data set to be written. 
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6. Software Installation 
 
The Data FLASH Editor requires a Windows 2000, Windows XP or Windows Vista operating system 
installed on your personal computer. In additional, the .NET framework 2.0 must be installed on your 
personal computer to execute the Data FLASH Editor. To start the installation, please run the “setup.exe” 
installation program. During initialization phase of the setup program a progress bar is shown. 
 
 

 
Figure 4: Install preparation  

 
After the setup program has finished initialization a welcome screen appears. Click the Next button to 
continue the installation. 
 

 
Figure 5: Welcome screen 
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In the next step of installation, the License Agreement window appears. Please read the Software Program 
License Agreement carefully. To continue the installation accept the License agreement and click the Next 
button. If you not accepted the license agreement the installation procedure exits. 
 

 
Figure 6: License Agreement window 

 
The Destination Folder window appears. You might exit the installation by clicking the Cancel button. You 
can click the Change button to be able to change the installation destination path. Press the Next button to 
proceed with the installation. 
 

 
Figure 7: Choose Destination Folder window 
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After everything has been setup for installation, press the Install button to start the copy process and to 
finalize the installation. 
 
 

 
Figure 8: Ready to Install window 

 
On the installation progress window you can follow the installation. You can always abort the installation by 
pressing the Cancel button. 
 
 

 
Figure 9: Installation progress window 
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When the installation is complete, the following message window appears. 
 
 

 
Figure 10: Installation completion window 

 
The program has been installed successfully and an entry has been made into the program menu to start 
the Data FLASH Editor software. 
 
The installation process is complete now and the setup utility has installed a new program folder which holds 
the Data FLASH Editor GUI Software and a Data FLASH Editor uninstall icon which allows you to remove 
the Data FLASH Editor software from your personal computer. 
 
 

 
Figure 11: Program folder after installation 
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7. Data FLASH Editor, GUI 
 
The graphical user interface of the Data FLASH Editor allows an easy and an intuitive visualisation and 
modification of the EEPROM emulation data of a loaded Data FLASH memory image. When starting the 
Data FLASH Editor GUI a screen similar to the following one will appear. Some commands and functions 
may be unavailable when the GUI is started for the first time, depending on Data FLASH area definition or 
the loaded Data FLASH memory image. 
 
 
 

 
Figure 12: Data FLASH Editor main window 

 

 

<5> Status bar <4> Process window 

<1> Menu bar <2> Toolbar <3> Data FLASH window 
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The main window consists of the following areas. 
 
 

 Name Displayed items 
<1> Menu bar Menu items executable by the Data FLASH Editor 
<2> Toolbar Frequently used commands 
<3> Data FLASH window Shows the EEPROM emulation data of an loaded 

Data FLASH memory image, allows editing of 
EEPROM emulation data 

<4> Process window Shows tool command and process information 
<5> Status bar Show current status and configuration of the Data 

FLASH Editor 

Table 2: Main window composition 
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7.1 Toolbar 
 
The toolbar contains buttons to configure the Data FLASH Editor. The following buttons and corresponding 
functions are offered by the Data FLASH Editor. 
 
 

 
Setup Data FLASH area 

 

Display all EEPROM emulation data entries in 
8-bit data format (byte format) 

 

Display all EEPROM emulation data entries in 
16-bit data format (half-word format) 

 

Display all EEPROM emulation data entries in 
32-bit data format (word format) 

 

Figure 13: Toolbar Buttons 

7.2 The Menu 
 
Analogue to the Toolbar the main menu of the Data FLASH Editor allows the configuration and execution of 
all Data FLASH Editor functions. 
 

7.2.1 File menu 
 
By using the File menu a Data FLASH memory image can be loaded, stored or if necessary closed. 
Additionally, the memory mapping of the Data FLASH area can be controlled via the File menu. 
 
 

 
Figure 14: File menu 

 

(1) 

(2) 

(3) 

(4) 

(5) 
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(1) Open… 
 
 

The Open… menu allows selecting and loading an existing Data FLASH memory image by 
the Data FLASH Editor. After loading the Data FLASH memory image the corresponding Data 
FLASH entries are shown in the Data FLASH window. 
 
 

 
Figure 15: Open dialog 

 
Note: When loading a Data FLASH memory image it must fit to the chosen Data FLASH start address 
 and the Data FLASH size. Otherwise the file loading will be aborted and a corresponding error 

message is generated. 
 
 
The most recently used directory a file has been loaded from will be offered in this file open menu. The Data 
FLASH memory image can be loaded in two different formats, the Intel-hex or Motorola-S record file format. 
 

 

 



Data FLASH Editor  

User’s Manual U19829EE1V0UM00                                                                       22 

 
After a Data FLASH memory image is loaded, the corresponding EEPROM emulation data entries, including 
ID-tag, length and data record information were displayed in the Data FLASH window of the editor. 
 
 

 
         Figure 16: Data FLASH window 

 
 
Additional to the Data FLASH memory the file reading process and the corresponding file and address map 
information are displayed in the process window. 
 

 
          Figure 17: Process window 
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(2) Close… 
 
 

Via the Close… menu the working on a Data FLASH memory image can be finished and the 
corresponding Data FLASH memory image will be closed. In case the Data FLASH memory 
image was changed a file save dialog offers the possibility to save the last changes. 
 
 

 

(3) Save as… 
 
 

The Save as… menu allows saving of a modified Data FLASH memory image by the Data 
FLASH Editor. 
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(4) Setup Data FLASH 
 

 
The Setup Data FLASH menu allows to setup the start address and the size of the Data 
FLASH area. By selecting this menu item the following dialog window appears and offers the 
possibility to specify the Data FLASH mapping. 
 
 

 
 

 
       Figure 18: Setup Data FLASH, start address 

 
 
Within the Setup Data FLASH dialog the start address of the Data FLASH area must be specified. Only 
hexadecimal input values are permissible. The entered start address should be equal to the physical start 
address of the Data FLASH area of the corresponding V850E/ES device. The size of the Data FLASH can 
be specified by the pull-down menu. Supported sizes are 4 KByte, 8 KByte, 16 KByte and 32 KByte. 
 

 
  Figure 19: Setup Data FLASH, size 
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(5) Exit… 
 

 
Via the Exit… menu the Data FLASH Editor can be closed. In case the Data FLASH memory 
image was changed a file save dialog offers the possibility to save the last changes. 
 
In addition, the actual Data FLASH Editor configuration is stored in the “CurrentSettings.xml” 
configuration file. The configuration file is located in the installation folder of the Data FLASH 
Editor. By restarting the Data FLASH Editor the latest settings are restored. 
 
Note:  Write permissions to the installation folder and to the “CurrentSettings.xml” 

File are required to allow the storage of the current configuration settings by 
the Data FLASH Editor. 
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7.2.2 View menu 
 
By using the View menu the configuration of the Data FLASH Editor can be changed. The following 
functions are offered by the View menu. 

 
Figure 20: View menu 

 
The functionality of each View menu items is described in the following table. 
 
 

(1) Toolbar 
Enables / Disables Toolbar 
 

(2) Statusbar 
Enables / Disables Statusbar 
 

(3) Byte 
Display all EEPROM emulation data entries in 
8-bit data format (byte format) 

(4) Half-word 
Display all EEPROM emulation data entries in 
16-bit data format (half-word format) 

(5) Word 
Display all EEPROM emulation data entries in 
32-bit data format (word format) 

Table 3: View menu 

 
 

(1) 

(2) 

(3) 

(4) 

(5) 
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7.2.3 Settings menu 
 
The Settings menu controls the format on how a Data FLASH memory image and the corresponding 
EEPROM emulation data entries should be displayed. Two formats are supported by the Data FLASH Editor, 
the Decimal and the Hexadecimal format. 

 
     Figure 21: Settings menu 

 
Only by loading a new Data FLASH memory image the selected data format will be taken under 
consideration. Changing the display format within the Settings menu after a Data FLASH memory was 
loaded has no influence and does not change the global format of the represented EEPROM emulation data 
entries. You can change the display format of an individual EEPROM emulation data entry in the Edit menu 
by double-clicking on it or using the “Edit” button within the Data FLASH window.  
 
 

7.2.4 Tools menu 
 
The Tools menu controls the refreshing of the active Data FLASH section. In case EEPROM emulation data 
entries have been modified, remove or added, the “Refresh” function updates the active Data FLASH section 
and makes the changes valid. 

 
Figure 22: Tools menu 
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7.2.5 Help menu 
 
Clicking the Help menu displays the following pull-down menu. 

 
Figure 23: Help menu 

 
The About DataFLASHEditor… command opens the “About DataFLASHEditor” window as shown below 
and indicates the program version. 
 

 
Figure 24: About Data FLASH Editor window 
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7.3 Data FLASH window 
 
The Data FLASH window visualizes the EEPROM emulation data records of a loaded Data FLASH memory 
image. The Data FLASH window supports the following functions: 
 

→ Display of EEPROM emulation data records, including: 
 

o ID tag 
o Length information 
o Data 
o Format 

 
→ Modification of EEPROM emulation data: 

 
o Adding new EEPROM emulation data record 
o Editing of existing EEPROM emulation data record 
o Deleting existing EEPROM emulation data record 

 
 
The Data FLASH window is shown in the figure below. 
 

 
           Figure 25: Data FLASH window 

 
The meaning of the different colours of the displayed EEPROM data records can be found in the following 
table. 
 
 

BLUE Original / unchanged EEPROM data record 
GREEN Modified EEPROM data record 
RED Added / new EEPROM data record 

    Table 4: EEPROM data record colouring 

 
By using the “Refresh” function in the Tools menu, all changes that have been done will be written to the 
active Data FLASH section. After the active Data FLASH section has been updated successfully, all 
EEPROM data records are displayed in blue colour. 
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The functionality of each corresponding Data FLASH window button is described in the following table. 
 
 

 

 
Add new EEPROM emulation data entry 
 

  

 
Edit existing EEPROM emulation data entry 
 

 

 
Delete existing EEPROM emulation data entry 
 

     Table 5: Data FLASH window buttons 
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7.3.1 Add new EEPROM emulation data entry 
 
To add a new EEPROM data record, please press the “Add” button. The following screen does appear. 
 

 
Figure 26: Add new data set menu 

 
The functionality of each Add menu item is described in the following table. 
 
 

(1) ID 
Identifier of the data record (ID tag). Only decimal 
values are supported 

(2) Length 

Length definition of the data record. The minimum 
data length is equal to four bytes. The length can 
be specified in 4 Byte *n steps. Only decimal 
values are supported. 

(3) Data 
Specifies the data record, any hexadecimal or 
decimal value. The data record must fit to the 
specified Length and format. 

(4) Format 
Specifies the input and display format of the data 
record. 

(5) Size 

Specifies the display size of the data record, the 
following sizes are supported: 
 

→   8-bit data format (byte format) 
→ 16-bit data format (half-word format) 
→ 32-bit data format (word format) 

 

Table 6: Add new data set items 

 

(1) 

(2) 

(3) 

(4) 

(5) 
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After a new EEPROM emulation data record has been entered, please press the <OK> button. 
 

 
Figure 27: Example 1, add new data set 

 
The new EEPROM data record is now visible, highlighted in red colour, in the Data FLASH window. 
 

 
Figure 28: Example 1, Data FLASH window (Add Function) 

 
To make the changing valid and finally add the new EEPROM data record to the active Data FLASH section, 
please execute the “Refresh” function within the Tools menu. 
 
 

 
     Figure 29: Example 1, refresh data set 
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After the active Data FLASH section has been updated successfully, the new EEPROM data record is 
displayed in blue colour. 
 

 
Figure 30: Example 1, added new EEPROM data record  
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7.3.2 Edit EEPROM emulation data entry 
 
To edit an EEPROM data record, please mark the corresponding entry in the Data FLASH window and 
press the “Edit” button. Analogue to this, you can double-click on the corresponding EEPROM data record. 
The following screen does appear. 
 
 

 
Figure 31: Edit data set menu 

 
The Edit menu does only support the modification of the data record, the format and the size. The ID and 
Length of the corresponding data record can not be changed. The functionality of each Edit menu item is 
described in the following table. 
 
 

(1) ID 
Current identifier of the data record (ID tag). 
Can not be modified. 

(2) Length 
Current length of the data record. 
Can not be modified. 

(3) Data 
Specifies the data record, any hexadecimal or 
decimal value. The data record must fit to the 
specified Length and format. 

(4) Format 
Specifies the input and display format of the data 
record. 

(5) Size 

Specifies the display size of the data record, the 
following sizes are supported: 
 

→   8-bit data format (byte format) 
→ 16-bit data format (half-word format) 
→ 32-bit data format (word format) 

 

Table 7: Edit data set items 

 
 

(1) 

(2) 

(3) 

(4) 

(5) 
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After an EEPROM emulation data entry has been modified, please press the <OK> button. 
 

 
Figure 32: Example 2, edit new data set 

 
The modified EEPROM data record is now visible, highlighted in green colour, in the Data FLASH window. 
 

 
Figure 33: Example 2, Data FLASH window (Edit function) 

 
To make the changing valid and finally add the new EEPROM data record to the active Data FLASH section, 
please execute the “Refresh” function in the Tools menu. 
 
 

 
Figure 34: Example 2, refresh data set 
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After the active Data FLASH section has been updated successfully, the new EEPROM data record is 
displayed in blue colour. 
 

 
Figure 35: Example 2, modified EEPROM data record 

 
 
 

7.3.3 Delete EEPROM emulation data entry 
 
To delete an EEPROM data record, please mark the corresponding entry in the Data FLASH window and 
press the “Delete” button. 
 

 
Figure 36: Delete data set 

 
To delete the selected EEPROM data record, please press the <OK> button. To remove the selected 
EEPROM data record finally from the active Data FLASH selection, please execute the “Refresh” function in 
the Tools menu. 
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7.4 Process window 
 
The process window shows the executed tool commands and process information. Additionally it stores the 
command history. You can use the scroll bar to navigate through the command history. 
 

 
Figure 37: Process window 

 
 

7.5 Status bar 
 
The status bar shows the actual status and configuration of the Data FLASH Editor. 
 

 
 

(*) = Only by loading a new Data FLASH memory image the selected data format will be taken under 
consideration. Changing the display format within the Settings menu after a Data FLASH memory 
was loaded has no influence and does not change the global format of the represented EEPROM 
emulation data entries. You can change the display format of an individual EEPROM emulation data 
entry in the Edit menu by double-clicking on it or using the “Edit” button within the Data FLASH window. 

 

Figure 38: Status bar 

 
 

 

 

Status information Data type 

Data size 

Data format (*) 
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8. Error Messages  
 
Error messages will be output in the error dialog boxes of the Data FLASH Editor. 
 

 
Figure 39: Error message, dialog box 

 
 
The following table shows the error messages generated by the Data FLASH Editor. 
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Error 
Number 
 

Message / Description 

[E002] Could not open FLASH file! 
[E003] Could not read FLASH file! 
[E004] Could not save FLASH file! 
[E005] Could not read program settings XML file! 
[E006] Could not write program settings XML file! 
[E008] The FLASH file contains checksum error! 
[E009] The FLASH file contains unknown lines! 
[E010] The FLASH file contains wrong Intel HEX lines! 
[E011] The FLASH file contains wrong Motorola SREC lines! 
[E012] The FLASH file contains wrong information! 
[E013] The data record could not be found! 
[E014] Active flash sector error when searching sector 0! 
[E015] Active flash sector error when searching sector 1! 
[E016] The active flash sector could not be found! 
[E017] Error during memory copy! 
[E018] FLASH file do not include data for RecordID <id>! 
[E019] The RecordID <id> has been deleted. A refresh is needed before it can 

be used again! 
[E020] The RecordID <id> is already used! 
[E021] Illegal character, must be an integer value, use digits 0-9! 
[E022] Error during decimal conversion, element=<id>! 
[E023] Error during hexadecimal conversion, element=<id>! 
[E024] The new data set does not fit in current flash! 
[E025] Problem to update empty flash space size! 
[E026] The length must be 4-65532 
[E027] Error when ID should be inserted! 
[E028] Error when data should be inserted! 
[E029] No inactive sector found! 
[E030] The sector is consumed and needs to be erased! 
[E031] The sector is already active! 
[E032] The length must be a multiple of 4! 
[E033] Error the data is not valid, element=<id>! 
[E034] Could not find the start address for the eeprom emulation area in the file! 

File address: <id1> - <id2> 
Setup eeprom emulation area: start address=<id3>, size=<id4> 

[E035] Could not find the complete eeprom emulation area in the file! 
File address: <id1> - <id2> 
Setup eeprom emulation area: start address=<id3>, size=<id4> 

[E036] The id must be a value from 1 to 65535! 
[E037] The file data exceeds the configured eeprom emulation area! 

File address: <id1> - <id2> 
Setup eeprom emulation area: start address=<id3>, size=<id4> 

[E038] The file is too big. Please only import the data flash area! 
[E040] Wrong data FLASH base address specified. Please insert data FLASH base 

address as hexadecimal value! (for instance, Base address: 0x001F8000) 
[E041] Wrong data FLASH base address specified. The value has been updated 

according to alignment rules! 
[E042] A data set must be selected! 
[E043] Illegal start address! 

Table 8: Error Messages 
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