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License Notice 

IDT’s Inductive Coil Design Tool software (the Software) is licensed for use solely in designs that will employ an IDT inductive position sensor (IPS) IC, and any 
other use will constitute a material breach of the license. Further, the licensee shall not himself/herself, and shall not authorize or permit any other third party to, 
(i) copy or use the Software in any manner not expressly authorized herein; (ii) distribute, sell, license, provide or otherwise make available the Software to third
parties; (iii) use the Software to perform services for, or otherwise on behalf of, third parties, whether on a service bureau, SaaS, time sharing basis or otherwise;
(iv) reverse engineer or decompile, decrypt, disassemble or otherwise reduce the Software or any portion thereof; (v) modify or create derivative works based upon
the Software; (vi) use the Software or any portion thereof in any way that is in violation of any applicable laws; (vii) defeat or circumvent any access or security
controls of the Software; or (viii) use any documentation provided with and related to the Software, except in support of authorized use of the Software.
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1. Introduction

This document describes how to use IDT’s Inductive Coil Design Tool software to design coils used in applications for the ZMID520x Inductive 
Position Sensor IC. There are three design options available: linear, arc and rotary. 

Important: This design tool produces designs that are not optimized, and the results could have an approximate FS error up to 5% without 
linearization. 

The linearization can improve the FS error by a factor of up to 0.5; therefore the expected FS error is approximately 2.5%. For linearization 
procedures, refer to the ZMID520x Datasheet and manuals for the ZMID520x evaluation kits. 

The main features of the tool are visual representation of the coil designs, help diagrams, and Gerber files. 

Recommendation: Read the ZMID520x Datasheet first. 

2. Software Setup

2.1 System Requirements 

In order to use the Inductive Coil Design Tool software, the following software is required: 

 Microsoft Windows Vista® / Microsoft Windows® 7 / Microsoft Windows® 8 / Microsoft Windows® 10

 Microsoft .NET 4.5.1

2.2 Software Installation 

The Inductive Coil Design Tool software is provided as a zip file on the www.IDT.com product page for the specific ZMID520x product: 

 www.IDT.com/zmid5201

 www.IDT.com/zmid5202

 www.IDT.com/zmid5203

Follow these steps to install the Inductive Coil Design Tool software on the user’s computer: 

1. Navigate to the product page and download this file: ZMID520x_ICDT_[YYYYMMDD].zip, where YYYYMMDD is the date of the current
version of the file. Extract the contents.

2. Activate the installation by clicking on the setup.exe file. Installation is automatic. If Microsoft .NET 4.5.1 is not installed on the user’s
computer, the setup wizard displays a message to install it from the Microsoft website. The setup wizard will automatically create a
desktop icon that can be used to activate the Inductive Coil Design Tool software.

3. Activate the software. The main window is displayed as described in section 3.

3. Main Window

The main window is divided into three main sections: the configuration panel, illustration panel, and information panel. 

 The configuration panel contains the design parameter options. The “Design Option” drop-down menu in this section is used to select the
coil design type.

 The illustration panel shows a drawing of the design for illustration purposes only.

 The information panel shows some of the basic design characteristics.

http://www.idt.com/
http://www.idt.com/zmid5201
http://www.idt.com/zmid5202
http://www.idt.com/zmid5203
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See Figure 1 for an example showing the main window for a linear position sensing coil design. Figure 2 is an example of the coil design for 
arc position sensing, and Figure 3 shows a coil design for rotary position sensing. 

Figure 1. Main Window – Linear Design Example 
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Figure 2. Main Window – Arc Design Example 
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Figure 3. Main Window – Rotary Design Example 
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3.1 The Configuration Panel 

The configuration parameters in the configuration panel are divided into two groups: 

 Basic:

o Transmitter Coil Width (linear coil designs only; see Figure 1)

o Transmitter Coil Length (linear coil designs only; see Figure 1)

o Outer Radius (arc and rotary coil designs only; see Figure 2 and Figure 3)

o Inner Radius (arc and rotary coil designs only; see Figure 2 and Figure 3)

o Motion Range (linear and arc coil designs only; see Figure 1 and Figure 2)

o Target Length (linear coil designs only; see Figure 1)

o Target Angle (arc coil designs only; see Figure 2)

o Receiver Coil Periods (rotary coil designs only; see Figure 3)

o Nominal Air Gap

o Maximal Air Gap

o Optimization Options
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 Advanced (to view these options, check the “Show advanced configuration parameters” box):

o Transmitter Windings

o Distance TX-RX

o Guard Distance (linear and arc designs only)

o Trace Width

o Clearance

o Via Pad Radius

o Via Hole Radius

3.2 The Information Panel 

The maximum size of the design is calculated and shown in the fields “Maximum Coil Size X” and “Maximum Coil Size Y” in the information 
panel. These dimensions should be taken just as a general indication. 

The “Target Length in Percent” field shows the size of the target as a percent of the length of one period of the receiver coil. 
Recommendation: Select a target length in the range of 20% to 80% of the length of one period of the receiver coil. 

The “Help Diagram” button displays a diagram where most of the configuration parameters are defined. Examples of the different help diagrams 
for the three coil design types are shown in Figure 4, Figure 5, and Figure 6. 

If the resulting design is not feasible, an error message might appear. Table 1 lists possible error messages. 

Table 1. List of Possible Errors 

Error Code Error Text Steps to Solve 

11, 33, 55 "The design is too dense!" Increase the size of the design. 

31 "The whole structure cannot be bigger than 360 degrees!" Reduce motion range or target angle of the design. 

32, 51 "Receiver coil width too small! This is not a valid design." Increase the size of the design. 

34, 52, 56 "Outer radius too small! This is not a valid design." Increase the outer radius. 

35, 57 "Receiver coils overlap transmitter coils! This is not a valid design." Increase the size of the design. 

36 "Transmitter wires are too close! This is not a valid design." Reduce the motion range or target angle of the design. 

54 "Not enough space for connections for receiver coils!" Increase the size of the design. 

58 "Connections not properly placed." Increase the size of the design. 

71 "There are no transmitter coils!" An error has occurred during generation; change the 
parameters of the design. 
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Figure 4. Linear Design Help Diagram 

Figure 5. Arc Design Help Diagram 
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Figure 6. Rotary Design Help Diagram 

4. Initial Set up

Follow these steps to configure the tool depending on the type of coil design: 

1. Under the “Design Option” drop-down menu in the configuration panel, select the design option for the type of the position
measurement: linear, rotary, or arc. The display changes according to the selected design option.

2. In the configuration panel, enter the design parameters according to the descriptions given in section 3.1. Ensure that the design
requirements have been met.

5. Generation of the Design Files

The design can be exported in two ways: 

 Click the File->Save Parameters menu option. The values for all fields are exported as design parameters that can be imported later in
the software by choosing “Import Design” from the “File” menu.

 Click the “Export Gerber” button. The list of coordinates is exported as Gerber files that can be imported in other software.
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6. Converting the Gerber File to a *.PcbDoc File in Altium Designer®

 Open Altium Designer® (trademark of Altium Limited) and create a new CAM document. Select File -> New -> CAM Document. Right
click on the document and select Save to name and save it.

 Import the Gerber files in the CAM document: File -> Import -> Gerber.

 Go to the exported files directory and ensure that all file formats are displayed by selecting All Files(*.*) on the bottom right corner of the
window.

 Select all files to be exported to the printed circuit board (PCB) including any Gerber *.txt drill files.

 The “Import Gerber(s) Options” dialog window opens. Usually no additional changes are needed. An example for the “Start Units” value is
given for reference in case previous settings have been made or the defaults are set differently. The Gerber file format should be RS-
274-X. The “Start units” value and the options in the menu accessed by clicking the “Settings” button might differ in each case.

 After checking settings, click the “OK” button.

Figure 7. Import Gerber(s) – Options Window 

If the file is not imported properly, change the file format to RS-274 or Fire9000 and check the options selected under the “Load Options” button 
as shown in Figure 8.  

Figure 8. Import Gerber Options Window 

 Click the “OK” button in the “Import Gerber(s) Options” window. This shows the log of the file loading. Check for any errors or warnings
and then close the window.
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 Open the CAM document and select Tables -> Layers. In the “Type” column, the Gerber drill *.txt file will be a “Temporary” layer. Change
it to a “Drill Top” layer.

Figure 9. Example of the “Layers Table” Window 

 Click the “OK” button to close the “Layers Table” window. Select Tables -> Layers Order. Set the layer’s physical order in the “Layer
Physical Order” column, and click the “OK” button.

Figure 10. Example of the “Create / Update Layers Order” Window 

 Go to Tables -> NC Tools to open the “Tool Table” window (see Figure 11). In the “Size” column, manually enter the size in millimeters
for the first tool and press the “Enter” button or click on another cell to update the table. The code in the “Ref. DCode” column is generated
automatically. Click on the Ref. DCode cell to select the exact tool. Check the “Plated” box if it is not checked. Click the “OK” button to
close and save the table.

Figure 11. Tool Table Window 

 Generate a netlist by selecting Tools -> Netlist -> Extract.

 If a problem occurs with the drill layer, try building a drill layer. First, select View -> NC Editor. Build the layer by selecting Place -> Drill -
> Build Drill Layer (PTH). If this is done, the hole size should be set from PCB inspector in the generated PCB.

 When the netlist is extracted, the file is ready to be exported to a PCB. Select File -> Export -> Export to PCB. The new *.PcbDoc file is
generated in the same directory as the CAM document, and its name is the same as the CAM file.
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7. Revision History

Revision Date Description of Change 

February 23, 2018 Initial release 

Corporate Headquarters 

6024 Silver Creek Valley Road 
San Jose, CA 95138 
www.IDT.com  

Sales 

1-800-345-7015 or 408-284-8200
Fax: 408-284-2775
www.IDT.com/go/sales

Tech Support 

www.IDT.com/go/support 

DISCLAIMER Integrated Device Technology, Inc. (IDT) and its affiliated companies (herein referred to as “IDT”) reserve the ri ght to modify the products and/or specifications described herein at any time, 
without notice, at IDT's sole discretion. Performance specifications and operating parameters of the described products are determined in an independent state and  are not guaranteed to perform the same 
way when installed in customer products. The information contained herein is provided without representation or warranty of any kind, whether express or implied, including, but not limited to, the suitability 
of IDT's products for any particular purpose, an implied warranty of merchantability, or non -infringement of the intellectual property rights of others. This document is presented only as a guide and does not 
convey any license under intellectual property rights of IDT or any third parties.  

IDT's products are not intended for use in applications involving extreme environmental conditions or  in life support systems or similar devices where the failure or malfunction of an IDT product can be 
reasonably expected to significantly affect the health or safety of users. Anyone using an IDT product in such a manner does so at their own risk, absent an express, written agreement by IDT. 

Integrated Device Technology, IDT and the IDT logo are trademarks or registered trademarks of IDT and its subsidiaries in the  United States and other countries. Other trademarks used herein are the 
property of IDT or their respective third party owners. For datasheet type definitions and a glossary of common terms, visit www.idt.com/go/glossary. All contents of this document are copyright of Integrated 
Device Technology, Inc. All rights reserved. 

http://www.idt.com/
http://www.idt.com/go/sales
http://www.idt.com/go/support
http://www.idt.com/go/glossary


Corporate Headquarters
TOYOSU FORESIA, 3-2-24 Toyosu,
Koto-ku, Tokyo 135-0061, Japan
www.renesas.com

Contact Information
For further information on a product, technology, the most 
up-to-date version of a document, or your nearest sales 
office, please visit www.renesas.com/contact-us/. 

Trademarks
Renesas and the Renesas logo are trademarks of Renesas 
Electronics Corporation. All trademarks and registered 
trademarks are the property  of their respective owners.

IMPORTANT NOTICE AND DISCLAIMER

RENESAS ELECTRONICS CORPORATION AND ITS SUBSIDIARIES (“RENESAS”) PROVIDES TECHNICAL 
SPECIFICATIONS AND RELIABILITY DATA (INCLUDING DATASHEETS), DESIGN RESOURCES (INCLUDING 
REFERENCE DESIGNS), APPLICATION OR OTHER DESIGN ADVICE, WEB TOOLS, SAFETY INFORMATION, AND 
OTHER RESOURCES “AS IS” AND WITH ALL FAULTS, AND DISCLAIMS ALL WARRANTIES, EXPRESS OR IMPLIED, 
INCLUDING, WITHOUT LIMITATION, ANY IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A 
PARTICULAR PURPOSE, OR NON-INFRINGEMENT OF THIRD-PARTY INTELLECTUAL PROPERTY RIGHTS.

These resources are intended for developers who are designing with Renesas products. You are solely responsible for (1) 
selecting the appropriate products for your application, (2) designing, validating, and testing your application, and (3) 
ensuring your application meets applicable standards, and any other safety, security, or other requirements. These 
resources are subject to change without notice. Renesas grants you permission to use these resources only to develop an 
application that uses Renesas products. Other reproduction or use of these resources is strictly prohibited. No license is 
granted to any other Renesas intellectual property or to any third-party intellectual property. Renesas disclaims 
responsibility for, and you will fully indemnify Renesas and its representatives against, any claims, damages, costs, losses, 
or liabilities arising from your use of these resources. Renesas' products are provided only subject to Renesas' Terms and 
Conditions of Sale or other applicable terms agreed to in writing. No use of any Renesas resources expands or otherwise 
alters any applicable warranties or warranty disclaimers for these products.

(Disclaimer Rev.1.01)

© 2025 Renesas Electronics Corporation. All rights reserved.

https://www.renesas.com/contact-us
https://www.renesas.com

	1. Introduction
	2. Software Setup
	2.1 System Requirements
	2.2 Software Installation

	3. Main Window
	3.1 The Configuration Panel
	3.2 The Information Panel

	4. Initial Set up
	5. Generation of the Design Files
	6. Converting the Gerber File to a *.PcbDoc File in Altium Designer®
	7. Revision History

