H8,H8S,H8SX Integrated Development Environment for RL78 Family

Migration to New Integrated Development Environment “CubeSuite+”: Onchip Debug
Introduction

This document describes how to migrate from the High-performance Embedded Workshop for H8,H8S Family to CubeSuite+ for RL78 and how to operate E1 and E20 emulators in the CubeSuite+ environment, this explanation is based on CubeSuite+ V1.02.00.

For toolchains, refer to the following three materials.
- Integrated Development Environment for RL78 Family Migration to Integrated Development Environment “CubeSuite+”: Build,
- Integrated Development Environment for RL78 Family Migration to Integrated Development Environment “CubeSuite+”: Coding,
- Integrated Development Environment for RL78 Family Migration to Integrated Development Environment “CubeSuite+”: Starting,

Also refer to the tutorial guide provided by CubeSuite+ for how to use tools. The tutorial guide is available by selecting [Help] -> [Tutorial] from the CubeSuite+ menu.
Contents

1. Integrated Development Environment and Emulators
2. Differences between the Target Interfaces (for OCD)
3. Changing the Debugger
4. Entering an ID Code
5. Securing Resources
6. Setting the On-Chip Debugging Option Byte
7. Where Do We Make Settings when Connecting an Emulator?
8. Connecting an Emulator
9. Disconnecting the Emulator
10. Downloading a Program
11. Registering Additional Download Files
12. Starting/Stopping a Program
13. Difference in MCU Operation during a Break (Peripheral Break Function)
14. Viewing/Changing Memory Data and Variables While the Program Is Running
15. Automatically Updating Memory Data and Variables While the Program Is Running
16. Setting Breakpoints
17. Causing a Break on Access to a Variable
18. Filling Memory
19. Saving Memory Data
20. Flash Self-Programming
21. How to program to check Operation on the Stand-Alone MCU
22. Action Event (Printf Event)
23. Viewing Lists of Variables and Functions
24. Analytical Graphs
25. Debugging Functions of Emulators (OCD)
### 1. Integrated Development Environment and Emulators

<table>
<thead>
<tr>
<th>Integrated Development Environment (IDE)</th>
<th>H8, H8S, H8SX</th>
<th>RL78</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>High-performance Embedded Workshop</strong></td>
<td>E8a (H8,H8S)</td>
<td>CubeSuite+</td>
</tr>
<tr>
<td></td>
<td>E10A-USB (H8S,H8SX)</td>
<td>A new integrated development environment that supports 8- to 32-bit MCUs from Renesas</td>
</tr>
<tr>
<td><strong>On-chip Debuggers (OCD)</strong></td>
<td>E6000H (H8SX)</td>
<td>Provides basic debugging functions at a low price</td>
</tr>
<tr>
<td><strong>Full-spec. Emulators</strong></td>
<td>E6000 (H8,H8S)</td>
<td>High-performance full-spec. emulators with more advanced debugging functions</td>
</tr>
<tr>
<td></td>
<td>E100 (H8S)</td>
<td></td>
</tr>
</tbody>
</table>

*This document describes about On-chip Debuggers.*
2. Differences between the Target Interfaces (for OCD)

The RL78 and E1 emulator are connectable via the 14-pin connectors listed below.

<table>
<thead>
<tr>
<th>Type Number</th>
<th>Manufacturer</th>
<th>Specification</th>
</tr>
</thead>
<tbody>
<tr>
<td>7814-6002</td>
<td>Sumitomo 3M Limited</td>
<td>14-pin straight type (Japan)</td>
</tr>
<tr>
<td>2514-6002</td>
<td>3M Limited</td>
<td>14-pin straight type (other countries)</td>
</tr>
</tbody>
</table>

Although these are the same connectors as for the E8a and E10A-USB for H8, H8S, and H8SX products, the communications interface is different.

The E8a (for H8, H8S) is connected via four lines.

The E10A-USB (for H8S,H8SX) is connected via five lines.

The E1 (for RL78) communicates via a single line.

The circuits for connection also vary with the MCU. For details, see E1/E20 Emulator Additional Document for User's Manual (Notes on Connecting RL78).
3. Changing the Debugger

The HEW allowed users to select a debugger (E8a, E10A-USB emulator or simulator) in the process of changing the debug session or the target shown in the [Debug Settings] dialog box. The CubeSuite+, on the other hand, allows users to select a debugger on the project tree. The procedure to change the debugger is described on the following pages.
3. Changing the Debugger

(1) The debug tool name (debug tool) on the project tree panel indicates the currently selected debugger. The following example shows that the E1 Emulator is selected:
3. Changing the Debugger

(2) To change the debugger, right-click the debug tool name (debug tool) to open a pop-up menu. Select [Using Debug Tool] from the pop-up menu to select the debug tool you want to use.
4. Entering an ID Code

Both the H8/H8S/H8SX and RL78 require entering of an ID code. However, there are some differences regarding the setting and authentication of the ID code and the action that is taken if the ID code does not match.

<table>
<thead>
<tr>
<th></th>
<th>ID code size</th>
<th>Address of the ID Code</th>
<th>Setting the ID Code</th>
<th>Authenticating the ID Code</th>
<th>Action Taken When the ID Code Does Not Match</th>
<th>Valid for the On-board Programmer?</th>
</tr>
</thead>
<tbody>
<tr>
<td>H8</td>
<td>H8: 2 bytes</td>
<td>Not open to users</td>
<td>Enter a code in a dialog box when the debugger is started up.</td>
<td>Enter a code in a dialog box when the debugger is started up.</td>
<td>All data in the flash memory are erased.</td>
<td>No (only valid during debugging)</td>
</tr>
<tr>
<td>H8S</td>
<td>H8S,H8SX: 4 bytes</td>
<td>Enter an ID code for the debugger in advance.</td>
<td>Depends on the setting of the on-chip debugging option byte*</td>
<td>No (only valid during debugging)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>H8SX</td>
<td>10 bytes</td>
<td>0xC4 to 0xCD</td>
<td>Embed the code in the user program when building.</td>
<td>Enter an ID code for the debugger in advance.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

For details, see *E1/E20 Emulator Additional Document for User's Manual (Notes on Connecting RL78).*
4. Entering an ID Code

In the HEW, the [ID Code verification] dialog box opens at startup if an ID code has been written in the MCU. In CubeSuite+, on the other hand, an ID code must be set on the [Property] panel before the emulator is started up.

Set an ID code by referring to the following figures:

Example: [ID Code] dialog box of the E8a for the H8
5. Securing Resources

When in use with the RL78, OCD takes up some user resources. These areas should not be used by the user program so keep them reserved (e.g. by using the build tool).

Reserved areas to be used by E1/E20 (RL78)*

For how to allocate resources through CubeSuite+, see the next page.

Comparison with the H8, H8S, and H8SX

<table>
<thead>
<tr>
<th></th>
<th>Does OCD Take up Resources?</th>
<th>Size</th>
<th>What Should be Used to Allocate the User Resources?</th>
</tr>
</thead>
<tbody>
<tr>
<td>H8 (E8a)</td>
<td>Yes (depending on the MCU)</td>
<td>Up to 4 Kbytes of ROM, 2 Kbytes of RAM, 4 bytes of stack, and some vectors</td>
<td>Build tool (setting up the linkage editor to avoid the areas to be taken up by OCD)</td>
</tr>
<tr>
<td>H8S, H8SX</td>
<td>No</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>(E10a-USB)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>RL78 (E1/E20)</td>
<td>Yes</td>
<td>See the figure at left.</td>
<td>Build tool (through the GUI of CubeSuite+)</td>
</tr>
</tbody>
</table>

*For details, see E1/E20 Emulator Additional Document for User’s Manual (Notes on Connecting RL78).
5. Securing Resources

The address of the area for monitoring by the debugger can be specified on the [Link Options] sheet of the [Property] panel of the build tool.
6. Setting the On-Chip Debugging Option Byte

The on-chip debugging option byte can be set on the [Link Options] sheet of the [Property] panel of the build tool.
7. Where Do We Make Settings when Connecting an Emulator?

In the HEW, the [Emulator Setting] dialog boxes open to make settings when connecting an emulator. In the CubeSuite+, on the other hand, you need to make settings on the [Property] panel before connecting an emulator by taking the following procedure.

Double-click the debug tool name (debug tool) on the [Project Tree] panel to open the Properties window of the debug tool.
7. Where Do We Make Settings when Connecting an Emulator?

In the case of HEW, settings required for connection are made in the [Emulator Setting] dialog box during the process of connecting the emulator. In the case of CubeSuite+, on the other hand, these settings must be made in the [Property] panel of the debugger before connecting the emulator.


Example: [Emulator Setting] dialog box of the E8a for the H8

On CubeSuite+, the device needs to be selected during the process of creating a project.
7. Where Do We Make Settings when Connecting an Emulator?

(2) [Configuration] dialog box of the HEW corresponds to the [Debug Tool Settings] tab of the CubeSuite+.

Example:
[Configuration] dialog box of the E8a for the H8
8. Connecting an Emulator

Select [Debug] -> [Connect to Debug Tool] from the CubeSuite+ menu to establish connection to the selected emulator (debug tool). Upon completion of the connection, the debug tool name appears on the status bar at the bottom right of the window.

Note: If an ID code has been written in the MCU, set an ID code in advance according to “2. Entering an ID Code.”
9. Disconnecting the Emulator

To disconnect the emulator, select [Disconnect from Debug Tool] from the menu or click the button on the debug toolbar.
10. Downloading a Program

Selecting [Debug] -> [Download] from the menu or clicking the button on the debug toolbar starts downloading specified files.

Selecting [Debug] -> [Build & Download] from the menu or clicking the button on the debug toolbar builds a project and then starts downloading the specified files.

If no debug tool is connected, CubeSuite+ connect debug tool automatically before downloading.
11. Registering Additional Download Files

(1) Select [Download files] and click […] button on the right.
(2) The [Download Files] dialog box opens. Click the [Add] button.
11. Registering Additional Download Files

(3) Specify the file name and file type in the [Download file information] field and then click the [OK] button.

Note: When downloading is performed, all of the registered files are downloaded. To download only desired files, set [Download object] and [Download symbol information] to “Yes” in this window only for files you want to download.
11. Registering Additional Download Files

(4) The available file formats (extensions) for the H8/H8S/H8SX and for the RL78 are not the same. For details, see the table below.

<table>
<thead>
<tr>
<th></th>
<th>Load Module Format</th>
<th>Hexadecimal File</th>
<th>Binary File</th>
</tr>
</thead>
<tbody>
<tr>
<td>H8, H8S, H8SX</td>
<td>*.abs</td>
<td>*.mot *.hex</td>
<td>*.bin</td>
</tr>
<tr>
<td>RL78</td>
<td>*.lmf</td>
<td>*.hex</td>
<td>*.bin</td>
</tr>
</tbody>
</table>

| Purpose           | To be downloaded for source-level debugging | To be used for writing by a ROM programmer, etc. | Data file |
12. Starting/Stopping a Program

You can start or stop a program and reset the CPU from the menu or toolbar in the same way as the HEW (see below).

CubeSuite+ menu

<table>
<thead>
<tr>
<th>Debug</th>
<th>Tool</th>
<th>Window</th>
<th>Help</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Download</td>
<td></td>
<td></td>
<td></td>
<td>F6</td>
</tr>
<tr>
<td>Build &amp; Download</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Connect to Debug Tool</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Hot Plug-in</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Upload...</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Disconnect from Debug Tool</td>
<td></td>
<td></td>
<td></td>
<td>Shift+F6</td>
</tr>
</tbody>
</table>

- **Stop**: Shift+F5
- **Go**: F5
- **Ignore Break and Go**: F8
- **Step In**: F11
- **Step Over**: F10
- **Return Out**: Shift+F11
- **CPU Reset**: Ctrl+F5
- **Restart**: Shift+F5

**CubeSuite+ toolbar**:
- **Stop**
- **Step out**
- **Step in**
- **Step over**
- **Reset CPU**
- **Run**
- **Run without break**
- **Restart (reset go)**
13. Difference in MCU Operation during a Break (Peripheral Break Function)

While timers and serial communication interfaces in the H8/H8S/H8SX continue to operate while CPU breaks in execution by the emulator, CubeSuite+ for the RL78 allows you to use the [Debug Tool Settings] sheet to select whether or not those modules are to be stopped while CPU breaks.

In the case of HEW for the H8/H8S/H8SX, you need to use the Start/Stop functions to create and embed code that will stop the peripheral modules if this is required.

Selectable on CubeSuite+ for the RL78
14. Viewing/Changing Memory Data and Variables While the Program Is Running

To view or change memory data and variables while the program is running in CubeSuite+, make settings on the [Property] panel by using the following procedure:

2. Set [Access by stopping execution] in the [Access Memory While Running] field to [Yes]. Memory data and variables can be viewed while the program is running.

If [No] is selected, “**” is displayed on the memory panel while the program is running.
15. Automatically Updating Memory Data and Variables While the Program Is Running

To automatically update memory data and variables via CubeSuite+, make settings on the [Property] panel by using the following procedure:
(1) Open the [Debug Tool Settings] sheet on the [Property] panel of the debug tool.
(2) Set [Access by stopping execution] and [Update display during execution] in the [Access Memory While Running] field to [Yes].
Information displayed on the memory and watch panels is automatically updated while the program is running.
To change the update interval, modify the [Display update interval] value.
16. Setting Breakpoints

(1) You can set breakpoints in the main area (enclosed by a red line in the figure below) on the editor panel of CubeSuite+.
Set break points: Single-clicking a line with an address.
Delete break points: Single-clicking a line for which a breakpoint has been set.

```c
void sort(long *a)
{
  long t;
  int i, j, k, gap;
  gap = 5;
  while (gap > 0) {
    for (k = 0; k < gap; k++) {
      for (i = k + gap, i < 10, i = i + gap) {
        for (j = i - gap, j > k, j = j - gap) {
          if (a[j] > a[i + gap]) {
            t = a[i];
            a[j] = a[i + gap];
            a[i] = t;
            gap = gap / 2;
          }
        }
      }
    }
  }
}
```
16. Setting Breakpoints

(2) Select a breakpoint type (software break or hardware break) for [First using type of breakpoint] in the [Debug Tool Settings] sheet on the [Property] panel. (Software break is selected in the example below.)

Set a breakpoint type to be preferentially used.

(3) If the number of breakpoints of the selected type exceeds the limit, the other type of breakpoints are used.
Event marks indicate the types of breakpoints.

Software break  Hardware break
16. Setting Breakpoints

(4) You can check the breakpoint setting on the [Events] panel. Select [View] -> [Event] from the CubeSuite+ menu to open the [Events] panel. Unnecessary breakpoints can be deleted or disabled on the [Events] panel.
17. Causing a Break on Access to a Variable

You can use the watch or editor panel to make a setting to break on access to a specific variable.

(1) On the watch or editor panel, right-click the variable that you want to set a break when it is accessed.
(2) Select [Access Break] (or [Break Settings] on the editor panel) and select [Set Read Combination Break to], [Set Write Combination Break to], or [Set R/W Combination Break to].
17. Causing a Break on Access to a Variable

(3) Enter a value to set a data condition (or leave the box blank if no data condition is needed).

Enter a data condition if necessary.

Note: Enter a decimal number here. When entering a hexadecimal number, add “0x” to the head (e.g. 0xAA).
18. Filling Memory

Memory can be filled (batch change) by using the [Memory Initialize] dialog box.
(1) Right-click on the [Memory] panel to open a pop-up menu, and select [Fill] from the pop-up menu.
(2) The [Memory Initialize] dialog box opens. Enter addresses (start address and end address) and initialization data, and then click the [OK] button.

Right-click here to open a pop-up menu and select [Fill].

Enter a start address, end address, and initialization data. This example shows filling 0x0000 to 0x0FFF with 0xAA.

Note: Enter decimal numbers here. When entering hexadecimal numbers, add “0x” to the head of each number.
19. Saving Memory Data

[Data Save] dialog box is used to save memory data. Select [Debug] -> [Upload...] from the menu. The [Data Save] dialog box opens. Specify the file name, type, and range of memory data you want to save, and then click the [Save] button.

![Data Save dialog box](image)

- **Enter the name of a file to be saved.**
- **Specify a file type (Intel Hex, Motorola S, or binary).**
- **Specify a memory range.**

Note: Enter decimal numbers here. When entering hexadecimal numbers, add “0x” to the head of each number.
20. Flash Self-Programming

The RL78 supports a self-programming feature for the rewriting of data in flash memory by user programs. This is accomplished for user applications by using the self-programming library for the RL78.

In the case of HEW for the H8/H8S/H8SX, you essentially need to place the debugger in a special mode and create a flash-rewriting program.

In the case of CubeSuite+ for the RL78, on the other hand, you need to install the self-programming library (provided for free) in the project. For details on how to install the library, visit the following URL: http://www.renesas.com/products/tools/flash_prom_programming/flash_libraries/index.jsp

To add the flash self-programming file, right-click on [File] in [Project Tree] on CubeSuite+ and select [Add -> Add File] from the list, then click on the [Files of type] pull-down menu and select the file type.
21. How to program to check Operation on the Stand-Alone MCU

If you wish to check operation on the RL78 MCU as a stand-alone device after debugging, use the Renesas Flash Programmer (flash programming software) to program the data to the flash memory instead of using CubeSuite+.

In the case of HEW for the H8/H8S/H8SX, you need to select the mode that is suitable for debugging and also equivalent to the on-chip programmer.

The Renesas Flash Programmer is software that is used to program to the flash memory of Renesas MCUs and is specialized for easy operation and functionality for programming.
22. Action Event (Printf Event)

CubeSuite+ allows the setting of a Printf event as an action event. A Printf event is used to stop the program momentarily at a specified address and make software execute the printf command. When a Printf event is set in the [Action Event] dialog box, the program stops before execution of the instruction at the address where the event is set, and CubeSuite+ outputs the value of the variables to the [Output] panel.

To insert code that is equivalent to
printf("Sample: g_count = %d, P6 = %d\n", g_count, P6)
at this address -> Set an action event.

The result is output to the [Output] panel.
23. Viewing Lists of Variables and Functions

CubeSuite+ can automatically display lists of variables and functions used in the project. Select [View -> Program Analyzer] from the menu.

Clicking on a variable or function name opens the corresponding source file.
24. Analytical Graphs

CubeSuite+ has an analytical graphing feature, which shows line graphs indicating the relationships between the values of variables, registers, and addresses and time. The graphs shown by CubeSuite+ during on-chip debugging of the RL78 are based on data acquired through the pseudo-RRM function.
# 25. Debugging Functions of Emulators (OCD)

<table>
<thead>
<tr>
<th>Debugging Function</th>
<th>RL78 (E1/E20)</th>
<th>H8, H8S (E8a)</th>
<th>H8S, H8SX (E10A-USB)</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Breaks</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Software breaks</td>
<td>2000 points</td>
<td>255 points</td>
<td>255 points</td>
</tr>
<tr>
<td>Hardware breaks</td>
<td>1 to 2 points shared between instruction-execution and access events*</td>
<td>1 to 10 points shared between instruction-execution and access events*</td>
<td>2 to 10 points shared between instruction-execution and access events*</td>
</tr>
<tr>
<td>Forced breaks</td>
<td>Supported</td>
<td>Supported</td>
<td>Supported</td>
</tr>
<tr>
<td><strong>Events</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Number of event points</td>
<td>1 to 2 points shared between instruction-execution and access events*</td>
<td>1 to 2 points*</td>
<td>2 points*</td>
</tr>
<tr>
<td>Usage of events</td>
<td>For hardware breaks only</td>
<td>For hardware breaks only</td>
<td>For hardware breaks only</td>
</tr>
<tr>
<td><strong>Tracing</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Measurement item</td>
<td>Branch trace*</td>
<td>Branch trace*</td>
<td>Branch trace/ Bus trace*</td>
</tr>
<tr>
<td><strong>Performance measurement</strong></td>
<td>From the start to the end of execution</td>
<td>From the start to the end of execution</td>
<td>From the start to the end of execution</td>
</tr>
<tr>
<td>Performance</td>
<td>Resolution: 100 μs Measurement time: Up to 100 hours</td>
<td>Resolution: 1 ms Note: A timer in the host machine is required as a resource.</td>
<td>Resolution: 1 ms Note: A timer in the host machine is required as a resource.</td>
</tr>
<tr>
<td><strong>Pseudo realtime RAM monitor (RRM)</strong></td>
<td>Supported; the CPU is occupied during monitoring.</td>
<td>Supported; the CPU is occupied during monitoring.</td>
<td>Supported; the CPU is occupied during monitoring.</td>
</tr>
<tr>
<td><strong>Dynamic memory modification (DMM)</strong></td>
<td>Supported; the CPU is occupied during modification.</td>
<td>Supported; the CPU is occupied during modification.</td>
<td>Supported; the CPU is occupied during modification.</td>
</tr>
<tr>
<td><strong>Hot plug-in</strong></td>
<td>Not supported</td>
<td>Not supported</td>
<td>Not supported</td>
</tr>
<tr>
<td><strong>Security</strong></td>
<td>Authentication of 10-byte ID**</td>
<td>Authentication of 2- or 4-byte ID**</td>
<td>Authentication of 4-byte ID**</td>
</tr>
<tr>
<td>Number of pins taken up</td>
<td>1 (TOOL0)</td>
<td>4</td>
<td>5</td>
</tr>
<tr>
<td>Peripheral breaks</td>
<td>Supported</td>
<td>Not supported</td>
<td>Not supported</td>
</tr>
</tbody>
</table>

* Varies with the MCU.
** For details on differences in specifications of the ID code, refer to 4. Entering an ID Code in this document.