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Notice 
1. All information included in this document is current as of the date this document is issued. Such information, however, is 

subject to change without any prior notice. Before purchasing or using any Renesas Electronics products listed herein, please 
confirm the latest product information with a Renesas Electronics sales office. Also, please pay regular and careful attention to 
additional and different information to be disclosed by Renesas Electronics such as that disclosed through our website. 

2. Renesas Electronics does not assume any liability for infringement of patents, copyrights, or other intellectual property rights 
of third parties by or arising from the use of Renesas Electronics products or technical information described in this document.  
No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights 
of Renesas Electronics or others. 

3. You should not alter, modify, copy, or otherwise misappropriate any Renesas Electronics product, whether in whole or in part. 
4. Descriptions of circuits, software and other related information in this document are provided only to illustrate the operation of 

semiconductor products and application examples.  You are fully responsible for the incorporation of these circuits, software, 
and information in the design of your equipment.  Renesas Electronics assumes no responsibility for any losses incurred by 
you or third parties arising from the use of these circuits, software, or information. 

5. When exporting the products or technology described in this document, you should comply with the applicable export control 
laws and regulations and follow the procedures required by such laws and regulations.  You should not use Renesas 
Electronics products or the technology described in this document for any purpose relating to military applications or use by 
the military, including but not limited to the development of weapons of mass destruction.  Renesas Electronics products and 
technology may not be used for or incorporated into any products or systems whose manufacture, use, or sale is prohibited 
under any applicable domestic or foreign laws or regulations. 

6. Renesas Electronics has used reasonable care in preparing the information included in this document, but Renesas Electronics 
does not warrant that such information is error free.  Renesas Electronics assumes no liability whatsoever for any damages 
incurred by you resulting from errors in or omissions from the information included herein. 

7. Renesas Electronics products are classified according to the following three quality grades:  “Standard”, “High Quality”, and 
“Specific”.  The recommended applications for each Renesas Electronics product depends on the product’s quality grade, as 
indicated below.  You must check the quality grade of each Renesas Electronics product before using it in a particular 
application.  You may not use any Renesas Electronics product for any application categorized as “Specific” without the prior 
written consent of Renesas Electronics.  Further, you may not use any Renesas Electronics product for any application for 
which it is not intended without the prior written consent of Renesas Electronics.  Renesas Electronics shall not be in any way 
liable for any damages or losses incurred by you or third parties arising from the use of any Renesas Electronics product for an 
application categorized as “Specific” or for which the product is not intended where you have failed to obtain the prior written 
consent of Renesas Electronics.  The quality grade of each Renesas Electronics product is “Standard” unless otherwise 
expressly specified in a Renesas Electronics data sheets or data books, etc. 

“Standard”: Computers; office equipment; communications equipment; test and measurement equipment; audio and visual 
equipment; home electronic appliances; machine tools; personal electronic equipment; and industrial robots. 

“High Quality”: Transportation equipment (automobiles, trains, ships, etc.); traffic control systems; anti-disaster systems; anti-
crime systems; safety equipment; and medical equipment not specifically designed for life support. 

“Specific”:  Aircraft; aerospace equipment; submersible repeaters; nuclear reactor control systems; medical equipment or 
systems for life support (e.g. artificial life support devices or systems), surgical implantations, or healthcare 
intervention (e.g. excision, etc.), and any other applications or purposes that pose a direct threat to human life. 

8. You should use the Renesas Electronics products described in this document within the range specified by Renesas Electronics, 
especially with respect to the maximum rating, operating supply voltage range, movement power voltage range, heat radiation 
characteristics, installation and other product characteristics. Renesas Electronics shall have no liability for malfunctions or 
damages arising out of the use of Renesas Electronics products beyond such specified ranges. 

9. Although Renesas Electronics endeavors to improve the quality and reliability of its products, semiconductor products have 
specific characteristics such as the occurrence of failure at a certain rate and malfunctions under certain use conditions. Further, 
Renesas Electronics products are not subject to radiation resistance design.  Please be sure to implement safety measures to 
guard them against the possibility of physical injury, and injury or damage caused by fire in the event of the failure of a 
Renesas Electronics product, such as safety design for hardware and software including but not limited to redundancy, fire 
control and malfunction prevention, appropriate treatment for aging degradation or any other appropriate measures.  Because 
the evaluation of microcomputer software alone is very difficult, please evaluate the safety of the final products or system 
manufactured by you. 

10. Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental 
compatibility of each Renesas Electronics product.  Please use Renesas Electronics products in compliance with all applicable 
laws and regulations that regulate the inclusion or use of controlled substances, including without limitation, the EU RoHS 
Directive.  Renesas Electronics assumes no liability for damages or losses occurring as a result of your noncompliance with 
applicable laws and regulations. 

11. This document may not be reproduced or duplicated, in any form, in whole or in part, without prior written consent of Renesas 
Electronics. 

12. Please contact a Renesas Electronics sales office if you have any questions regarding the information contained in this 
document or Renesas Electronics products, or if you have any other inquiries. 

(Note 1) “Renesas Electronics” as used in this document means Renesas Electronics Corporation and also includes its majority-
owned subsidiaries. 

(Note 2) “Renesas Electronics product(s)” means any product developed or manufactured by or for Renesas Electronics. 
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HEW 
Stack Analysis of using HEW Call Walker (CallWalker) 

Introduction 
This application note provides: 

1. A general view on stack information file (*.sni) or profile information file (*.pro) for new user 

2. How to create stack information file (*.sni) or profile information file (*.pro) 

3. Using call walker to display stack or profile information file 

4. Usefulness and purpose of stack or profile information file 

 

Call Walker is a stack analysis tool that reads a stack information file (*.sni), which has been output by an optimising linkage editor 
or a profile information file (*.pro), which has been output by a debugging interface and displays its stack amount used. The 
information can be added or modified by using the edit function. 

 

 

Target Device 
All 
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1. Overview 
Call Walker opens stack or profile information file and displays call information (e.g. symbol classification), symbol details (e.g. 
symbol name, attribute, address, size, stack size and source).  
Overview of linkage of each file related to Call Walker is shown below in Figure 1. 

 

Figure 1  Linkage of each file related to Call Walker  
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2. How to Create a Stack or Profile Information File 
There are two methods of creating a stack analysis file. Below explained how they can be obtained. 

2.1 Creating a Stack Information File from HEW2 
With existing working codes in a project in HEW2, by selecting [Options->Link/Library], for “Category:”, drop down list, 
and select “Other”. Click on “Stack information output” and “ok”. Build the project again, a stack information file will be 
created at the working project’s subfolder named Debug with an extension file of .sni. 

 

2.2 Creating a Profile Information File from HDI/HEW2-Simulator 
Making use of HDI or HEW2 Simulator from above project, after setting system Memory Resources found in Simulator 
Memory Resource, next download the compiled project file. In order to create profile Information file (*.pro), 1st select 
[view->Performance->Profile], or “shift + Crtl + F”, a Profile Window is displayed. Right click mouse on the profile display, 
click on “Enable Profiler”. Run the program, profile information will be displayed at the window. Right click mouse again to 
select “Output Profile Information files”, select the file that is displayed and click “save” then “close”. Profile information 
file had been created at the working project’s sub-folder named Debug with an extension of .pro.  
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3. Invoking Call Walker  
In the “program” folder of the “start” menu of the Windows®, under Renesas High-performance Embedded Workshop, one of its 
submenus content display “Call Walker”, and click unto it.  

The Call Walker will be invoked and the main frame will be opened. To view a stack or profile file, click [File->Import Stack 
file], “Ctrl + I” or icon to select the directory where the stack or profile file is saved. 
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Figure 2  Call Walker Window 

The above Call Walker window can only open one stack or profile file at a time.  
Below explains the details of each information obtained from stack or profile information file. 
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3.1 Explanation on Usage of Call Information View  
1. Symbol display 

Display of the Symbol classification signs between link-level structure and symbols are explained below: 
A. : Editing file 

B. : Assembler label 

C. : C/C++ function 

D. : Recursive call function or a circulating function 

E. : RTOS function 

F. : Functions that the reference source is unknown 

G. : Omitted symbol 

The level structure can be edited by moving a symbol (drag and drop is used). That means, from the below Figure 3 shows 
that symbol ‘_main’ contains 5 other symbols displayed on the right frame window (includes symbols ‘_longway’, 
‘_quick’, ‘_shortway’, ‘_recur’ and ‘$MVN$3'). 

  

Figure 3  Call Walker Window 
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By dragging and then dropping ‘_recur’ symbol to ‘_shortway’ at the left frame window, the new linked-level structure 
becomes: 

 

Figure 4  Call Walker Window After Dragging 

Figure 4 shows that ‘_recur’ symbol had moved to ‘_shortway’ symbol. Notice that the numerical value within ( ) attached 
to ‘_shortway’ symbol increase from 6 to 18 since ‘_recur’ symbol stack size is 12. 

However, symbols cannot be moved to the recursive call, cyclic function or omitted functions. 

 

 

Figure 5  Recursive and Circulation Functions 

How the above-mentioned figure 5 features may help in the development stage of a program? 

In cases where stack size used maybe too large, e.g. when functions calling functions and so on. By dragging symbols to 
various locations could let the programmer to have a better view of estimating stack size allocation or maybe better idea of 
modifying the codes in saving stack size. E.g. reducing unnecessary multiple steps of functions calling functions will 
reduce stack size significantly. 
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2. Omitted Symbols 

Symbols can be omitted when the program is very large. Below figure 6 shows the different types of display. Right side 
shows all symbols while left side shows simple symbols (as some symbols are omitted).  

 

Figure 6  Display of All and Simple Symbols 

To show all symbols, click [View->Show All Symbols]. To show simple symbols, click [View->Show Simple Symbols]. 

“Simple symbols” display is useful when the program is very large and an overview of whole structure is summarized. 

“All symbols” display is useful when the viewer needs to look into the details of each symbol that are linked. 
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3. Stack size displays  

Numerical values in ( ) attached to the symbol name specify the stack amount used. Stack size can be displayed in 2 types, 
namely Show Required Stack and Show Used Stack.  

A. Understanding ‘Show Required Stack’ 

Click on [View->Show Required Stack] or  icon to show required stack format. Values in ( )  in figure 
7 on the left indicates the number of stack size required to execute the symbol that is attached to it. 

 
Note: Stand-alone symbols without calling other function display the ‘real’, independent stack size 

value. In figure 7, ‘sub1’, ‘sub21’, ‘sub22’ and ‘ext_sub’ symbols display the ‘real’, exact stack size 
being used. 

 

 

 

Figure 7  Show Required Stack Format  Figure 8     Individu

How the values of stack size is obtained or calculated in the above figure 7? 

Values in ( ) in Figure 8 displays the stack size that is only used by the symbol that is attached t
found on symbol detail view on the right window, by clicking call/editing file (*.cal) on the top
information view. Example stack size used by ‘main’ symbol is 8, ‘sub1’ is 16, ‘sub2’ is 4 and 

Figure 7 displays the ‘Show Required Stack’ format, lets start to view the values from the lowe
‘sub21’ and ‘sub22’ which contain 6 and 10 stack size respectively. To calculate the stack size 
execute ‘sub2’ symbol, choosing the largest stack size value in its calling symbol, in this case is
stack size is 10, adding its own stack size value 4 (showed in figure 8) will obtain the result 14.

‘main’ symbol required stack size 24 is obtained by choosing from ‘sub1’ and ‘sub2’ symbols w
value, which is 16 from ‘sub1’ symbol. Adding ‘main’ symbol stack value of 8 and 16 will get 
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B. Understanding ‘Show Used Stack’ 

Click on [View->Show Used Stack] or  icon to show used stack format. Values in ( ) in figure 9 on the 
left indicates the total number of stack size needed to be used to execute that  particular symbol.  

Note: For easy reading, figure 10 is exactly same as figure 8. 
 

8 

Figure 9  Show Stack Format            Figure 10       Individu

How the values of stack size is obtained or calculated in the above figure 9? 

Figure 9 displays the ‘Show Used Stack’ format, lets start to view the values from the top. To c
size that is used to execute ‘sub1’ symbol, where ‘sub1’ stack size is 16, adding ‘main’ symbol
obtain result 24. 

Total stack size of 12 in ‘sub2’ symbol is obtained by adding ‘main’ value 8 and ‘sub2’ value 4

Total stack size of 18 in ‘sub21’ symbol is obtained by adding ‘sub2’ total value 12 and ‘sub21
figure 10). 

Total stack size of 22 in ‘sub22’ symbol is obtained by adding ‘sub2’ total value 12 and ‘sub22
figure 10). 

Note: For recursive call function or circulating function, the stack size is not displa
cannot be measured. 
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3.2 Explanation on Usage of Symbol Detail View  
Symbol details view on the right window displays the symbol information that is being selected in the call information 
view, namely Symbol, Attribute, Address, Size, Stack size and Source. 

 1. Symbol: 

Displays its calling symbols that are same as those displayed in call information view. 

Advantage: 

• Clear view of the selected symbol’s calling symbols/functions. 

2. Attributes: 

Display of symbol attributes are explained below: 

A. R (Runtime Library) Runtime library 

B. O (Created by Optimization) Optimization-creating function 

C. I (Interrupt) Interrupt function 

D. S (Static) Static function 

E. V (Virtual) Virtual function 

F. L (Use Local Stack) Function used by local stack 

Advantage: 

• From the above information given, user can have an instant view of every symbol function type without 
looking through all the codes. 

3. Address: 

Displaying symbol’s address. 

Advantages: 

A. Able to amend values stored in particular symbol address without recompiling the codes again. E.g. 
changing initialise data section D’s or could be constant data section C’s specific variable’s value. 

B. To have an overview of how section data are allocated in the memory area after compiling. 

C. Confirming that the symbols are stored in the correct address. E.g. Symbols not “overflow” to the 
unused area or being overlap to other undesired area. 

D. Able to create with a new section “close” or next to the existing one to save address space. E.g. In 
HEW2, under section assignment: 

Address Section 

P 0x0000800 

C 

D 0x0001000 

B 

: : 

 : 

)

 

0x0000980 (Information obtained from map file 
with starting given ‘C’ address added to given size
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4. Size: 

Displays symbol size. 

Advantages: 

A. Program optimization could then be focus on larger code size symbol. 

B. Have an overview of the size of sections ‘B’, ‘C’, ‘R’, ‘D’ etc. If size is too large at e.g. ‘D’ or ‘C’, 
unnecessary initialization can be omitted. 

5. Stack size: 

Display stack size that is only used by the symbol that is attached to it. Figures 8 or 10 (above) are its display. 

Note: An empty space will be displayed if the stack size value is 0xffffffff. 
Advantages: 

• User can have an idea of how much stack size is being occupied to execute each symbol without tediously 
needed to trace/monitor every symbol’s stack size used manually (seeing the changes in the stack register, 
register R7 for H8 series and R15 for SH series). 

6. Source: 

Display source file name that stores the symbolic source. 

Advantages: 

• Being able to know the calling function/symbol’s source file helps user to save time to search for it 
especially if the program is very large and contains many source files.  

 
Notes: 1. The stack amount calculated in the stack information file, may be larger than the actual value when 

optimization option is used. 
2. The stack amount for the interrupt function does not include the stack size used by the interrupt 

controller for saving context switchings when an interrupt occurs. Refer to the device hardware 
manual and calculate the required amount. 

3. The stack amount for the interrupt function does not include the saved extended register (EXR). 
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4. “Stack Calculation” Selection in HEW2 

4.1 Getting into “Stack Calculation” 
Two ways to approach “Stack Calculation” dialog: 

4.1.1 When Creating a New Project  
Each time a new project is created, user will come to “Option Setting” dialog box shown below in Figure 11. A drop-
down list from the “Stack Calculation” displays small, medium and large that specifies the stack size range. 

 

Figure 11  Stack Calculation Setting When Creating A New Project 
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4.1.2 Under Menu Bar Section  
After a project had been built, to view or change “Stack Calculation” selection, click [Options->Hitachi H8 Tiny/SLP 
Toolchain->CPU], for “Stack Calculation:” drop-down list to select suitable size as shown below in Figure 12.  

Note: Above Toolchain type is dependent on the type of CPU Series being chosen. 

 

Figure 12  Stack Calculation Setting After A Project Been Built 
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4.2 Descriptions  
When “Stack Calculation” is being selected as: 

1. small: Stack addresses are operated in 1-byte units. 

 2. medium: Stack addresses are operated in 2-byte units. 

 3. large: Stack addresses are operated in 4-byte units. 

  The above option should be specified for the whole program. 

If the stack address operation is performed with an address larger than the specified size, the program will not operate 
correctly, however the compiler does not output an error or warning. 

  

 

Figure 13  Stack Calculation = Small 
 

4.3 Explanations on Data Memory Format  
Memory data formats are classified into 3 types, mainly bytes, words and long words. Byte data can be accessed from any 
address. Word data can only be accessed from an even-numbered address of 2n. Long word data can be accessed only from 
an even-numbered address of 4n. Errors will occur if the above rules are not followed, also data accessed is not guaranteed. 

 

Figure 14  Memory Data Format 
 

4.4 Information on Different Register being used as Stack Pointer in various CPU 
Series  

Hardware stack area is referred to by hardware stack pointer, SP. One of the general registers will have dual functions, 
which means can be used as data register or stack pointer (SP). Depending on the CPU Series being chosen, eg. H8/SLP 
and Tiny Series CPU uses register R7 to also be function as SP while SH Series CPU uses R15 . 
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1. These materials are intended as a reference to assist our customers in the selection of the Renesas 
Technology Corporation product best suited to the customer's application; they do not convey any 
license under any intellectual property rights, or any other rights, belonging to Renesas Technology 
Corporation or a third party.

2. Renesas Technology Corporation assumes no responsibility for any damage, or infringement of any 
third-party's rights, originating in the use of any product data, diagrams, charts, programs, 
algorithms, or circuit application examples contained in these materials.

3. All information contained in these materials, including product data, diagrams, charts, programs and 
algorithms represents information on products at the time of publication of these materials, and are 
subject to change by Renesas Technology Corporation without notice due to product improvements 
or other reasons.  It is therefore recommended that customers contact Renesas Technology 
Corporation or an authorized Renesas Technology Corporation product distributor for the latest 
product information before purchasing a product listed herein. 
The information described here may contain technical inaccuracies or typographical errors. 
Renesas Technology Corporation assumes no responsibility for any damage, liability, or other loss 
rising from these inaccuracies or errors. 
Please also pay attention to information published by Renesas Technology Corporation by various 
means, including the Renesas Technology Corporation Semiconductor home page 
(http://www.renesas.com).

4. When using any or all of the information contained in these materials, including product data, 
diagrams, charts, programs, and algorithms, please be sure to evaluate all information as a total 
system before making a final decision on the applicability of the information and products.  Renesas 
Technology Corporation assumes no responsibility for any damage, liability or other loss resulting 
from the information contained herein.

5. Renesas Technology Corporation semiconductors are not designed or manufactured for use in a 
device or system that is used under circumstances in which human life is potentially at stake.  
Please contact Renesas Technology Corporation or an authorized Renesas Technology Corporation 
product distributor when considering the use of a product contained herein for any specific 
purposes, such as apparatus or systems for transportation, vehicular, medical, aerospace, nuclear, 
or undersea repeater use.

6. The prior written approval of Renesas Technology Corporation is necessary to reprint or reproduce 
in whole or in part these materials.

7. If these products or technologies are subject to the Japanese export control restrictions, they must 
be exported under a license from the Japanese government and cannot be imported into a country 
other than the approved destination. 
Any diversion or reexport contrary to the export control laws and regulations of Japan and/or the 
country of destination is prohibited.

8. Please contact Renesas Technology Corporation for further details on these materials or the 
products contained therein.

1. Renesas Technology Corporation puts the maximum effort into making semiconductor products 
better and more reliable, but there is always the possibility that trouble may occur with them. Trouble 
with semiconductors may lead to personal injury, fire or property damage. 
Remember to give due consideration to safety when making your circuit designs, with appropriate 
measures such as (i) placement of substitutive, auxiliary circuits, (ii) use of nonflammable material or 
(iii) prevention against any malfunction or mishap.

Keep safety first in your circuit designs! 

Notes regarding these materials
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