Introduction

This application note describes the basic usage of the Smart Configurator for RZ (hereafter called the Smart Configurator)

Target Devices and Compilers

Refer to the following URL for the range of supported devices and compilers:

https://www.renesas.com/smart-configurator

Contents

1. Overview .............................................................................................................. 3
  1.1 Purpose ........................................................................................................ 3
  1.2 Features ....................................................................................................... 3

2. Creating a Smart Configurator project ................................................................. 3

3. Operating the Smart Configurator ...................................................................... 4
  3.1 Procedure for Operation ............................................................................. 4
  3.2 File to be saved as Project Information ...................................................... 4
  3.3 Window ........................................................................................................ 5
    3.3.1 MCU Package view ............................................................................. 6
    3.3.2 Console view ....................................................................................... 6
    3.3.3 Configuration Problems view .............................................................. 7
  3.4 Pin Settings .................................................................................................. 7
    3.4.1 Assigning pins using the MCU Package view ..................................... 9
    3.4.2 Exporting pin settings ....................................................................... 10
    3.4.3 Importing pin settings ....................................................................... 11
    3.4.4 Pin filter feature ................................................................................ 11
  3.5 MCU migration feature ................................................................................ 12

4. Generating Source Code ................................................................................... 14
  4.1 Generating a Source File ......................................................................... 14
  4.2 Folder Structure and output files ................................................................. 15

5. Generating Report on Smart Configurator ......................................................... 16
  5.1 Report on Device Configurations ............................................................... 16
  5.2 Configuration of Pin Function List and Pin Number List (in csv Format) .......... 17
  5.3 Image of MCU Package (in png format) ................................................... 17

6. Help .................................................................................................................. 18
7. Documents for Reference................................................................. 18

Website and Support.............................................................................. 18
1. Overview

1.1 Purpose
This application note describes the basic usage of the Smart Configurator tool for the RZ device family.

1.2 Features
The Smart Configurator is a utility for configuring pin multiplexing settings, resolving conflicts and generating pin initialization code.

2. Creating a Smart Configurator project
The following describes the procedure for creating a Smart Configurator project.

(1) Launch the Smart Configurator and select [File] → [New].
(2) Select a device, for example, R8A77450 from the left panel of the [New Smart Configuration File] dialog box.
(3) Specify a [File name] and click [Finish] button as shown below.

![Creating a New Smart Configurator File](image)

Figure 2-1 Creating a New Smart Configurator File
3. Operating the Smart Configurator

3.1 Procedure for Operation

Figure 3-1 shows the procedure for using the Smart Configurator to set up pin settings, generating source code and report.

![Diagram of the procedure for operations]

3.2 File to be saved as Project Information

The Smart Configurator saves the setting information such as the target MCU for the project, build tool, peripheral modules, and pin functions in a project file (*.scfg), and refers to this information. The project file from the Smart Configurator is saved in this following format “<project name>.scfg”.
3.3 Window

The configuration of the Smart Configurator perspective is shown in Figure 3-2 Smart Configurator Perspective.

![Smart Configurator Perspective](image)

**Figure 3-2 Smart Configurator Perspective**

1) Smart Configurator editor with Board & Pins page
2) MCU Package view
3) Console view
4) Configuration Problems view
### 3.3.1 MCU Package view

The states of pins are displayed on the figure of the MCU package. The settings of pins can be modified from here.

Two types of package view can be switched between [Assigned] and [Default Board]. [Assigned] displays the assignment status of the pin setting, and [Default Board] displays the initial pin setting information of the board. The initial pin setting information of the board is the pin information of the board selected by [Board:] on the [Board] page (refer to “3.3.4 MCU Package View”).

![MCU Package View](image)

**Figure 3-3  MCU Package View**

Select [Window] → [Show View] → [Smart Configurator] → [MCU Package] to open the MCU Package View.

### 3.3.2 Console view

The Console view displays details of changes to the configuration made in the Smart Configurator or MCU Package view.

![Console View](image)

**Figure 3-4  Console View**

Select [Window] → [Show View] → [General] folder dropdown menu and → [Console] from the [Show View] dialog box in the Smart Configurator to open the Console View.
3.3.3 Configuration Problems view

The Configuration Problems view displays the details if there is any problem related to pin assignment.

![Figure 3-5 Configuration Problems View](image)

Select [Window] → [Show View] → [Smart Configurator] folder dropdown menu and → [Configuration Problems] from the [Show View] dialog box in the Smart Configurator to open the Configuration Problems view.

3.4 Pin Settings

The [Pins] page is used for assigning pin functions. Click on the [Pin Function] and [Pin Number] tabs to switch between the 2 pages. The [Pin Function] list shows the pin functions for each of the peripheral functions, and the [Pin Number] list shows all pins in order of pin number.

![Figure 3-6 Pins Page ([Pin Function])](image)
When you select a board on the [Board] page, the initial pin setting information of the board is displayed in [Default Function].

**Figure 3-7  [Pins] Page ([Pin Number])**

<table>
<thead>
<tr>
<th>Pin Number</th>
<th>Pin Name</th>
<th>Function</th>
<th>Direction</th>
<th>Remarks</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>A1</td>
<td>VSS</td>
<td>-</td>
<td>-</td>
<td>Read only</td>
<td></td>
</tr>
<tr>
<td>A2</td>
<td>GPIO_12/D12/HSCF2_HRIS#/HSCF1_TXD_C_/</td>
<td>Not assigned</td>
<td>None</td>
<td></td>
<td></td>
</tr>
<tr>
<td>A3</td>
<td>GPIO_2/2/3/HSCF1_HTXI/HSCF1_SDA_B</td>
<td>Not assigned</td>
<td>None</td>
<td></td>
<td></td>
</tr>
<tr>
<td>A4</td>
<td>GPIO_4/4/2/3_SDA_A/HSCF5_TXD_B</td>
<td>Not assigned</td>
<td>None</td>
<td></td>
<td></td>
</tr>
<tr>
<td>A5</td>
<td>GPIO_2/2/3/HSCF3_TXD_B</td>
<td>Not assigned</td>
<td>None</td>
<td></td>
<td></td>
</tr>
<tr>
<td>A6</td>
<td>M0A12</td>
<td>Not assigned</td>
<td>None</td>
<td></td>
<td></td>
</tr>
<tr>
<td>A7</td>
<td>M0A6</td>
<td>-</td>
<td>None</td>
<td>Read only</td>
<td></td>
</tr>
<tr>
<td>A8</td>
<td>M0A10</td>
<td>-</td>
<td>None</td>
<td></td>
<td></td>
</tr>
<tr>
<td>A9</td>
<td>M0A11</td>
<td>-</td>
<td>None</td>
<td></td>
<td></td>
</tr>
<tr>
<td>A10</td>
<td>M0A1</td>
<td>-</td>
<td>None</td>
<td>Read only</td>
<td></td>
</tr>
<tr>
<td>A11</td>
<td>M0A2</td>
<td>-</td>
<td>None</td>
<td></td>
<td></td>
</tr>
<tr>
<td>A12</td>
<td>M0A15</td>
<td>-</td>
<td>None</td>
<td></td>
<td></td>
</tr>
<tr>
<td>A13</td>
<td>VSS</td>
<td>-</td>
<td>Read only</td>
<td></td>
<td></td>
</tr>
<tr>
<td>A14</td>
<td>M0C0#</td>
<td>-</td>
<td>None</td>
<td></td>
<td></td>
</tr>
<tr>
<td>A15</td>
<td>M0C0</td>
<td>-</td>
<td>None</td>
<td>Read only</td>
<td></td>
</tr>
<tr>
<td>A16</td>
<td>VSS</td>
<td>-</td>
<td>Read only</td>
<td></td>
<td></td>
</tr>
<tr>
<td>A17</td>
<td>M0DS1#</td>
<td>-</td>
<td>None</td>
<td></td>
<td></td>
</tr>
<tr>
<td>A18</td>
<td>M0DS1</td>
<td>-</td>
<td>None</td>
<td></td>
<td></td>
</tr>
<tr>
<td>A19</td>
<td>VSS</td>
<td>-</td>
<td>Read only</td>
<td></td>
<td></td>
</tr>
<tr>
<td>A20</td>
<td>M0DS9#</td>
<td>-</td>
<td>None</td>
<td></td>
<td></td>
</tr>
<tr>
<td>A21</td>
<td>M0DS9</td>
<td>-</td>
<td>None</td>
<td></td>
<td></td>
</tr>
<tr>
<td>A22</td>
<td>VSS</td>
<td>-</td>
<td>Read only</td>
<td></td>
<td></td>
</tr>
<tr>
<td>A23</td>
<td>M0DQ6</td>
<td>-</td>
<td>None</td>
<td></td>
<td></td>
</tr>
<tr>
<td>A24</td>
<td>M0DO7</td>
<td>-</td>
<td>None</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

When you select a board on the [Board] page, the initial pin setting information of the board is displayed in [Default Function].
3.4.1 Assigning pins using the MCU Package view

The Smart Configurator visualizes the pin assignment in the MCU Package view. You can save the MCU Package view as an image file, rotate it, and zoom in to and out from it.

Follow the procedure below to assign pins in the MCU Package view.

1. Zoom in to the view by clicking the [Zoom in] button or scrolling the view with the mouse wheel.
2. Right-click on the target pin.
3. Select the signal to be assigned to the pin.
4. The color of the pins can be customized through [Preferences Setting...].

![Assigning Pins Using the MCU Package View](image_url)
3.4.2 Exporting pin settings

The pin settings can be exported for later reference. Follow the procedure below to export the pin settings.

(1) Click on the [Export pin assignments] button on the [Pins] page.

(2) Select the output location and specify a name for the file to be exported.

The exported XML file can be imported to another project having the same device part number.

The Smart Configurator can also export the pin settings to a CSV file. Click on the [Save the list to .csv file] button on the [Pins] page.
3.4.3 Importing pin settings

To import pin settings into the current project, click on the [Import pin assignments] button and select the XML file that contains the desired pin settings. After the settings specified in this file are imported to the project, the settings will be reflected in the [Pin configuration] page.

![Figure 3-10 Importing Pin Settings from an XML File](image)

3.4.4 Pin filter feature

The filter range on the [Pin Function] tab and [Pin Number] tab on the [Pins] page can be used to filter out pin functions and numbers for easy search.

![Figure 3-11 Filter for [Pin Function] tab](image)

![Figure 3-12 Filter for [Pin Number] tab](image)
3.5 MCU migration feature

The MCU migration feature helps to convert user project settings from device A to device B. Conversion of project settings can be done within the same family as follows.

Note: Project settings may change due to device change. It is recommended to back up the smart configurator project file (*.scfg) before executing the device change.


![Device Selection]

2. Click on this icon and select the target device from the device dropdown menu list.

![Select target device]

3. Select Save and continue or Continue to change to another target device. (E.g., change to RZ/G1H).
Figure 3-15  Confirm device change

(4) Migration report will be generated, the report information is displayed in console window.

![Smart Configurator Output](image)

Figure 3-16  Output Migration report

(5) The migration report can be opened by clicking the hyperlink string in the console window. The reports content will show the pin configuration porting status.

![SmartConfigurator MCU migration report](image)

Figure 3-17  Migration report content
4. Generating Source Code

4.1 Generating a Source File

Output the source file for the configured details by clicking on the [Generate Code] button in the Smart Configurator view.

![Image of Smart Configurator view]

Figure 4-1 Generating a Source File

If a file of the same name exists in the output folder, the existing source code is moved to the folder “/trash/<yyyy-mm-dd-hh-mm-ss>/src/smc_gen/dts/”.

The generated file can be opened directly by clicking on the link of the file from the Console view.
4.2 Folder Structure and output files

Figure 4-2 shows the folders and file output by Smart Configurator. The root folder can be found in “C:\Users\<username>\smartconfigurator\workspace.pinmux\”.

For the RZ/G2x device series, a single *.dtsi file is generated in the device tree syntax for Linux.

![Folder Structure Diagram]

**Figure 4-2 Configuration of Generated Files and File Names**

<table>
<thead>
<tr>
<th>Folder</th>
<th>File</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>src/smce_gen/dts</td>
<td>This folder is always generated. It consists of only r8axxxx_pinconf.dtsi file.</td>
<td></td>
</tr>
<tr>
<td>r8axxxx_pinconf.dtsi</td>
<td>This file is always generated. It represents a set of text files in the Linux kernel source tree that describe the hardware of the RZ/G2 device tree.</td>
<td></td>
</tr>
</tbody>
</table>

The generated source code feature is valid only for the RZ/G2x and RZ/G1x device series. For RZ/A1x device, no *.dtsi file is generated.
5. Generating Report on Smart Configurator

The Smart Configurator generates a report on the configurations that the user works on. Follow the procedure below to generate a report.

5.1 Report on Device Configurations

A report is output by clicking on the [ ] (Generate Report) button in the Smart Configurator view.

![Device selection dialog box](image1)

Figure 5-1 Output of a Report on the Configuration (as a Text File)

![Generate report of configurations dialog box](image2)

Figure 5-2 Dialog Box for Output of a Report
5.2 Configuration of Pin Function List and Pin Number List (in csv Format)

A list of the configuration of pin functions and pin numbers is output by clicking on the [Save the list to .csv file] button on the [Pins] page of the Smart Configurator view.

![Smart Configurator](image)

**Figure 5-3** Output of a List of Pin Functions or Numbers (in csv Format)

5.3 Image of MCU Package (in png format)

An image of the MCU package is output by clicking on the [Save Package View to external image file] button of the [MCU Package] view.

![MCU Package](image)

**Figure 5-4** Output an image of the MCU Package (in png Format)
6. Help

Refer to the help dropdown menu for detailed information on the Smart Configurator.

![Help Menu](image)

**Figure 6-1  Help Menu**

7. Documents for Reference

User’s Manual: Hardware
Obtain the latest version of the manual from the Renesas Electronics website.

Technical Update/Technical News
Obtain the latest information from the Renesas Electronics website.

Website and Support

Renesas Electronics Website
http://www.renesas.com/

Inquiries
http://www.renesas.com/contact/
## Revision History

<table>
<thead>
<tr>
<th>Rev.</th>
<th>Date</th>
<th>Page</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.00</td>
<td>July 31, 2020</td>
<td>-</td>
<td>First edition issued</td>
</tr>
</tbody>
</table>
1. Handling of Unused Pins
   Handle unused pins in accordance with the directions given under Handling of Unused Pins in the manual.
   - The input pins of CMOS products are generally in the high-impedance state. In operation with an unused pin in the open-circuit state, extra electromagnetic noise is induced in the vicinity of LSI, an associated shoot-through current flows internally, and malfunctions occur due to the false recognition of the pin state as an input signal become possible. Unused pins should be handled as described under Handling of Unused Pins in the manual.

2. Processing at Power-on
   The state of the product is undefined at the moment when power is supplied.
   - The states of internal circuits in the LSI are indeterminate and the states of register settings and pins are undefined at the moment when power is supplied.
   In a finished product where the reset signal is applied to the external reset pin, the states of pins are not guaranteed from the moment when power is supplied until the reset process is completed.
   In a similar way, the states of pins in a product that is reset by an on-chip power-on reset function are not guaranteed from the moment when power is supplied until the power reaches the level at which resetting has been specified.

3. Prohibition of Access to Reserved Addresses
   Access to reserved addresses is prohibited.
   - The reserved addresses are provided for the possible future expansion of functions. Do not access these addresses; the correct operation of LSI is not guaranteed if they are accessed.

4. Clock Signals
   After applying a reset, only release the reset line after the operating clock signal has become stable. When switching the clock signal during program execution, wait until the target clock signal has stabilized.
   - When the clock signal is generated with an external resonator (or from an external oscillator) during a reset, ensure that the reset line is only released after full stabilization of the clock signal. Moreover, when switching to a clock signal produced with an external resonator (or by an external oscillator) while program execution is in progress, wait until the target clock signal is stable.

5. Differences between Products
   Before changing from one product to another, i.e. to a product with a different part number, confirm that the change will not lead to problems.
   - The characteristics of Microprocessing unit or Microcontroller unit products in the same group but having a different part number may differ in terms of the internal memory capacity, layout pattern, and other factors, which can affect the ranges of electrical characteristics, such as characteristic values, operating margins, immunity to noise, and amount of radiated noise. When changing to a product with a different part number, implement a system-evaluation test for the given product.