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RX72M Group  
Communications Board PROFINET Startup Manual 
Introduction 
This application note is a quick start guide for PROFINET communication with the RX72M communication board for 
industrial network evaluation. 
 

This stack runs on E-Force's real-time OS "μC3 (micro-C-cube)" and TCP/IP protocol stack "μNet 3 (micro-net-cube)". 

 

Target Device 
RX72M Group 

 
 

 

Sample program 
This sample program uses the evaluation version of PROFINET stack of our partner: JSL Technology Co., Ltd. 

 

Please contact JSL Technology Corporation for the purchase of the official version and the specifications of the sample 
program. 

JSL Technology Co., Ltd .: https://jslt.co.jp/ 

 

 

【Restrictions】 

The evaluation version of the PROFINETIP stack is a library file built with the following functional restrictions, and 
can only be used for evaluation. It cannot used for integration into the product. In that case, please consider purchasing 
the official version. 

- The PROFINET stack is provided as a library 

- e-Force's real-time OS “μC3” uses a time-limited evaluation version 
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1. Operating Environment 
The sample program in this manual assumes the following environment. 

 

Table 1.1 Operating Environment 

Item Description 
Board RX72M communications board 

TS-TCS07298 from Tessera Technology  
CPU RX CPU (RXv3) 

R5F572MNDxBD 
Operating frequency CPU clock (CPUCLK): 240 MHz 
Operating voltage 3.3 V 
Operating modes • Single chip mode 
Device requirements R5F572MNDDBD 

• Code flash memory 
Capacity: 4 Mbytes 
ROM cache: 8 Kbytes 

• Data flash memory 
Capacity: 32 Kbytes 

• RAM/extended RAM 
Capacity: 512 Kbytes/512 Kbytes 

Communications protocol PROFINET (Version 5.4.3.0) 
Available port CN2, CN3 
Integrated development environment e2Studio V7.5.0 or later 
Tool chain C/C ++ compiler package V3.01.00 or later for RX family 
Emulator (ICE) Renesas E2 Lite 

 
 

1.1 Stack compatible specifications 
The supported stack specifications are as follows. 

 

・PNIO Device Stack  V5.4.3.0 

・Test Bundle “2018-09-25_PN-test”対応 
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1.2 Sample program folder structure 
The release folder structure is described below. 

 

[pnet_dev] 

 | 

 |-[lib]：library 

 | 

 |-[prj_rx72m_e]：e² studio folder 

 | 

 |-[src]：Source folder 

     |-[app] 

     |   |-[rx72m] 

     |       |-[Gsdmi]：PROFINET Stack Configuration Data 

     |       |-[uC3]：uC3 main, driver 
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2. Setting up and Connecting the Evaluation Board 
For detailed information on the board, refer to the RX72M Group Communications Board Hardware Manual. 

 

 

 

 

Figure 2.1 Configuration of the RX72M Communications Board 
 
 

2.1 Setting up the Board 
Before supplying power to the board, set up jumpers and connect the cables. In addition, make settings for the JTAG 
configuration mode. This mode is normally used with a short circuit between jumper pins 2 and 3.  

For the detailed locations of the related parts, refer to the RX72M Communications Board Hardware Manual. 

 

 

Figure 2.2 Setting up Jumper Pins 
 

 

2.2 Selecting the Power Source 
Power to the RX72M can be supplied from a 5-V DC power source or through the USB port. Use whichever is suitable 
for the configuration of your operating environment. 

RESET 
Switch 

USB Serial 
(power supply) 

DC5V Power 
Supply 

Power LED 
Ether IN 

Jumper Pin 
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3. Installing the e2 studio 
Download RX72M compatible e2studio (V7.5.0 or later) from the following website. 

https://www.renesas.com/e2studio_download 
 
 

3.1 Installing the CC-RX Compiler V3.01.00 
The compiler selection screen appears while installing e2studio. By selecting [Renesas CCRX v3.0 1.00] and selecting 
[Next], CC-RX V3.0 1.00 compiler compatible with RX72M will be installed together. 
 

 

 
 
To start e2studio, please run "e2studio.exe" located in the installed folder below. 
 

e2_studio_rx72m\eclipse 

 
  

https://www.renesas.com/e2studio_download
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3.2 Registering the Tool Chain 
Register the CC-RX compiler v3.01.00 so that it can be used with the e2 studio for RX72M. 

(1) Start the e2 studio for RX72M. 
 

(2) Select [File] → [New] → [C/C++Project] → [Next].  

 

 
 
(3) In the [Templates for New C/C++ Project] dialog box, select [Renesas RX] → [Renesas CC-RX C/C++ Executable 

Project] → [Next].  

 

 
(4) In the [New Renesas CC-RX C/C++ Executable Project] dialog box, enter a desired project name and select [Next]. 
 
 

(5) In the [Select toolchain, device & debug settings] dialog box, select [Toolchain Management] under [Toolchain 
Settings]. 
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(6) In the [Renesas Toolchain Management] dialog box, select [Add] → [Browse...] to refer to the installation folder 

"C:¥Renesas¥RX¥3_0_1".  
The registration was successful if "v3.01.00 has been added under "Renesas CCRX". 
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4. Evaluation environment construction method 
The following describes method to build a development environment. 
 
4.1 Preparing the evaluation environment 
(1) Preparing the environment folder 

Release environment in an optional folder. 

ex：C:\proj\pnet_dev 

 

(2) GSDML File 
Use the GDSML file in the following folder for the GDSML file.  

              pnet_dev\src\app\rx72m\Gsmdl 
・GSDML-V2.33-Renesas_RX72M_Dev-Sample-20******.xml 

 
 

 

4.2 Execution procedure 
Describes the procedure to execute communication in the sample application.  

 

(1) After starting e2studio, click "File"-> "Import". 

 

(2) In the "Select" dialog, select "General" → "To an existing project to workspace" and click "Next". 
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(3) Select the "Select root directory" check box in the "Import project" dialog and click "Browse". Select 
“prj_rx72m_e” and click “Open”. Click Finish to complete the project import. 

 

 

 

 

(4) Select the "main" project in the [Project Explorer] field, select the arrow next to the [Build] button (hammer icon), 
and select [HardwareDebug] from the drop-down menu. 
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(5) e2studio builds the project. Once the build is complete, you can start debugging by selecting the arrow next to the 
Debug button (bug icon) and selecting "Debug Configuration". 

 

 

 

(6) Select “main HardwareDebug” and select [Debug] to download the program to the target. 
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(7) If a firewall warning is displayed for "e2-server-gdb.exe", check the checkbox for [Private networks, such as my 

home or work network] and select [Allow access].  
 
(8) The User Account Control (UAC) dialog box may appear. Enter the administrator's password and select [Yes].  
 
(9) If the Confirm Perspective Switch dialog box appears prompting you to switch the perspective, check the 

checkbox for [Remember my decision] and select [Yes].  
 
(10) The green "ACT" LED on the E2 Lite debugger will be continuously lit.  
 
(11) After downloading the code, select the [Resume] button to run the code. The code will break at the address where 

the main function starts. Select the [Resume] button again to continue to run the code. 
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5. Confirmation of sample project operation 
This chapter describes the sample project operation check using the CODESYS software PLC. 

Connect the communication board and PC according to “5.1 Connection Configuration”. Connecting the PC and USB 
Serial of the communication board turns on the power to the communication board. 

 

 

Figure 5.1 Connection configuration 
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5.1 Starting the CODESYS and Creating a New Project 
 

5.1.1 Starting the CODESYS 
Select “All Programs” > 3S CODESYS > CODESYS > CODESYS Vx.x (x.x represents the version number) from the 
Windows start menu. 

You can also startup the program by double-clicking on the "CODESYS" icon, which will be created on the desktop 
after the installation of the program. 

 

5.1.2 Creating a New Project 
Select "New Project" from the "File" menu to create a new project. 

 

 

In the "New Project" window, select "Projects" from the "Categories" section and "Standard project" from the 
"Templates" section.  
Then, specify the name of the project and its location and click on "OK". 
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In the "Standard Project" window, select the controller and programming language you wish to use from the drop-down  
lists for "Device" and "PLC_PRG in". For this example, select "CODESYS Control Win V3" and "Structured Text (ST)",  
respectively. (If the 64-bit version is installed on the PC, select "CODESYS Control Win V3 x64") 
 After that, click on "OK" to open the new project 

 

 
The "Device" tree for the newly created project will be displayed as shown below.  

The components that belong to "Device (CODESYS Control Win V3)" are managed in a tree structure. 
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5.1.3 Starting the Gateway Server 
Check the state of the gateway server on the system tray. If the server is down, click on the " " icon and select "Start  
Gateway" to start the server up. Usually, the server will automatically be started as a standard service on booting of  
Windows and its status is indicated in the system tray in the lower-right corner of the desktop. 
 

 

 
 
5.1.4 Starting the Software PLC 

Check the state of the software PLC on the system tray. If the program is stopped, click on the " " icon and select  
"Start PLC" to start the program up. Usually, the program will automatically be started as a standard service on booting  
of Windows and its status is indicated in the system tray in the lower-right corner of the desktop 
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5.1.5 Configuring a Device Network 
This section describes device configuration, including the setting of an IP address for use in a network of devices. 

 
Setting the Host IP Address 

Set the IP address before configuring the device. 

Open "Network Connection". 

 

 
In the "Local Area Connection Status" window, select "Properties". 
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In the "Local Area Connection Properties" window, highlight "Internet Protocol Version 4 (TCP/IPv4)" then click on the  
"Properties" button. 

 

 
Select the radio button "Use the following IP Address" and set IP and subnet mask. However, the network IP address 
should match with Device IP. 

 

 
This is the end of the configuration. 
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5.2 Connection setting with CODESYS 
5.2.1 Select device 
Make connection settings for connecting the software PLC service from your development environment. Double-click on  
the "Device (CODESYS Control Win V3) in the "Device" tree. On the "Device" tabbed page, select "Connection settings"  
and click on the "Scan network…" button. 

 

 
The "Select Device" window opens and a search for available devices that can use the local network automatically 
starts. Finding a software PLC service constitutes success and the name of the corresponding PC will be indicated. 
Double-click on the PC name to make a connection.  
If the service will not be found, check the settings described in previous sections, (1)Starting the Gateway Server and 
(2)Starting the Software PLC. 
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5.2.2 Installing the Device Information 
Install an GSD (General Station Description) file which contains a description of the PROFINET slave device. A file 
for use with PROFINET is provided with the released stack. 

 

Select "Device Repository…" from the "Tools" menu of the CODESYS program. 
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In the dialog box, click on the "Install" button to produce the dialog box where you are to enter the name of the provided  
GSD file. Specify "GSDML-V2.33-Renesas_RX72M_Dev-Sample-xxxx.xml". The result of installation will be indicated  

under the file name. An icon " " appears in the case of normal installation, as is shown within the blue rectangle in the  
figure below 
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5.2.3 Adding PROFINET Device 
Add necessary devices to the "Device" tree. 
 
(1) Adding Ethernet 

Right-click on "Device (CODESYS Control Win V3)" in the "Device" tree and select "Add Device". 
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The "Add Device" dialog box opens. Select "Ethernet" under "Fieldbusses", "Profinet IO", then "Ethernet Adapter" and 
click on the "Add Device" button. 
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You can see that "Ethernet" has been added under "Device (CODESYS Control Win V3)" in the "Device" tree. 

 

 
 
(2) Adding PN controller 

Right-click on "Ethernet (Ethernet)" in the "Device" tree and select "Add Device". 
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The "Add Device" dialog box opens. Select "PN-Controller" under "Fieldbusses", "Profinet IO", then "Profinet IO 
Master" and click on the "Add Device" button. 
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You can see that "PN-Controller" has been added under "Ethernet" in the "Device" tree. 

 

 
 
(3) Adding PROFINET Device 

Right-click on "PN-Controller" in the "Device" tree and select "Add Device”. 

 

 
The "Add Device" dialog box opens. Select " Renesas RX72M sample device " under "Fieldbusses", "Profinet IO", then 
"Profinet IO Slave" and click on the "Add Device" button.  
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You can see that " Renesas_RX72M_sample_device " has been added under "PN-Controller" in the "Device" tree. 

 

 
(4) Configuring the Ethernet 
Double-click on "Ethernet (Ethernet)" in the "Device" tree to open the configuration window. In the "General" tabbed 
page, click on the icon next to the text box for "Interface" section as shown in a red rectangle below 

 

 
In the "Network Adapters" window, select the interface you wish to use from among the interfaces offered for  
connection. 
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Confirm that the correct IP address is set for the interface you have selected 

 

 
(5) Setting of PN-Controller 
Double-click on "PN-Controller (PN-Controller)" in the "Device" tree to open the configuration window. Select  
the "General" tab in the window. Here, if you have configured an IP address as described in the previous  
section, (2) Configuring the Ethernet, if there are any applicable IP addresses, "adjust" will be indicated next  
to the corresponding IP address range, as shown in the red rectangle below. Clicking on this indication leads  
to automatic setting of the applicable IP address 
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(6) Renesas_PROFINET_Device 

Double-click on "Renesas_PROFINET_Device (Renesas_PROFINET_Device)" in the "Device" tree to open the 
configuration window. Then, select the "General" tab.  

As the IP settings, specify the address ranges from "First IP address" to "Last IP address" you have configured 
according to the description in the previous section, (3) PN-Controller. 

The PROFINET system recognizes slave devices by the names specified in the "Station name" section of this page. 
Enter the station name set within the slave device 

 

 
  

dut 
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5.3 Connection confirmation with CODESYS 
This section describes how to run a program on the CODESYS development environment and how to ensure connection 
of the device. 

 

Select "Build" from the "Build" menu. 

 

 
Select "Login" from the "Online" menu 

 

 
Select "Start" from the "Debug" menu. The project will automatically start on Windows 
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The states of connection will be indicated next to each device name. Successful connection is indicated by the " " icon  
as shown in the tree view below 

 

 
 
The icons indicating status of each device is listed below. 

 : The application is connected to the PLC and is running. 

 : The application is connected to the PLC but is not running. 

 : Error. Check the error contents and the settings of the device. 

 
: There is no device information in the device repository. Review the device information file and re-

install it. 
 

 
 
 
  



RX72M Group Communications Board PROFINET Startup Manual 

R01AN4885EJ0104  Rev.1.04  Page 33 of 36 
Aug. 31, 2021  

6. Debug function 
The debug function is described below. 

 

6.1 Terminal software settings 
Debug logs can be output via USB Serial (CN4). 

 

(1) Start the "Tera Term", press the "new connection" in the "File", and then select the COM port. 

 

 

 

(2) Select the USB serial port for log output. 

 

 

note 
It is different from the port for 

communication. 
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(3) Set serial communication parameters from "Serial Port" in "Settings". 

 

 

 

(4) Configure the serial port settings as shown in Figure 5.14. 
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6.2 MAC address / IP Address confirmation method 
The MAC Address / IP Address confirmation method is described below. 

 

The following command  

“ipconfig” 

MAC Address / IP Address can be confirmed by typing from the console. 

 

■ipconfig displayed terminal. 

======================================= 

ipconfig 

IPAddr  = 192.168.0.50 

NetMask = 255.255.255.0 

Gateway = 192.168.0.50 

======================================= 

 

 

6.3 Heap confirmation method 
The Heap confirmation method is described below. 

 

The following command 

“Heapstat” 

Heap can be confirmed by typing from the console. 

 

■Heapstat displayed terminal  

======================================= 

Heapstat 

PNET free memory = 51672 / 262144 byte 

OSW free memory = 32297 / 32768 byte 

 ======================================= 
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7. Test Option 
Describe the test options. 
 
When the option "PROFINET_IO_DEBUG_IN_TO_OUT" of the following file is enabled, the data written in the input 
buffer of periodic communication is written to the output buffer as it is. 
This option is disabled (0) by default. 
 
pnet_dev\src\app\rx72m\Application\pniod_app_api.h 
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General Precautions in the Handling of Microprocessing Unit and Microcontroller 
Unit Products 
The following usage notes are applicable to all Microprocessing unit and Microcontroller unit products from Renesas. For detailed usage notes on the 
products covered by this document, refer to the relevant sections of the document as well as any technical updates that have been issued for the products. 

1. Precaution against Electrostatic Discharge (ESD) 

A strong electrical field, when exposed to a CMOS device, can cause destruction of the gate oxide and ultimately degrade the device operation. Steps 

must be taken to stop the generation of static electricity as much as possible, and quickly dissipate it when it occurs. Environmental control must be 

adequate. When it is dry, a humidifier should be used. This is recommended to avoid using insulators that can easily build up static electricity. 

Semiconductor devices must be stored and transported in an anti-static container, static shielding bag or conductive material. All test and 

measurement tools including work benches and floors must be grounded. The operator must also be grounded using a wrist strap. Semiconductor 

devices must not be touched with bare hands. Similar precautions must be taken for printed circuit boards with mounted semiconductor devices. 
2. Processing at power-on 

The state of the product is undefined at the time when power is supplied. The states of internal circuits in the LSI are indeterminate and the states of 

register settings and pins are undefined at the time when power is supplied. In a finished product where the reset signal is applied to the external reset 

pin, the states of pins are not guaranteed from the time when power is supplied until the reset process is completed. In a similar way, the states of pins 

in a product that is reset by an on-chip power-on reset function are not guaranteed from the time when power is supplied until the power reaches the 

level at which resetting is specified. 
3. Input of signal during power-off state 

Do not input signals or an I/O pull-up power supply while the device is powered off. The current injection that results from input of such a signal or I/O 

pull-up power supply may cause malfunction and the abnormal current that passes in the device at this time may cause degradation of internal 

elements. Follow the guideline for input signal during power-off state as described in your product documentation. 
4. Handling of unused pins 

Handle unused pins in accordance with the directions given under handling of unused pins in the manual. The input pins of CMOS products are 

generally in the high-impedance state. In operation with an unused pin in the open-circuit state, extra electromagnetic noise is induced in the vicinity of 

the LSI, an associated shoot-through current flows internally, and malfunctions occur due to the false recognition of the pin state as an input signal 

become possible. 
5. Clock signals 

After applying a reset, only release the reset line after the operating clock signal becomes stable. When switching the clock signal during program 

execution, wait until the target clock signal is stabilized. When the clock signal is generated with an external resonator or from an external oscillator 

during a reset, ensure that the reset line is only released after full stabilization of the clock signal. Additionally, when switching to a clock signal 

produced with an external resonator or by an external oscillator while program execution is in progress, wait until the target clock signal is stable. 
6. Voltage application waveform at input pin 

Waveform distortion due to input noise or a reflected wave may cause malfunction. If the input of the CMOS device stays in the area between VIL 

(Max.) and VIH (Min.) due to noise, for example, the device may malfunction. Take care to prevent chattering noise from entering the device when the 

input level is fixed, and also in the transition period when the input level passes through the area between VIL (Max.) and VIH (Min.). 
7. Prohibition of access to reserved addresses 

Access to reserved addresses is prohibited. The reserved addresses are provided for possible future expansion of functions. Do not access these 

addresses as the correct operation of the LSI is not guaranteed. 
8. Differences between products 

Before changing from one product to another, for example to a product with a different part number, confirm that the change will not lead to problems. 

The characteristics of a microprocessing unit or microcontroller unit products in the same group but having a different part number might differ in terms 

of internal memory capacity, layout pattern, and other factors, which can affect the ranges of electrical characteristics, such as characteristic values, 

operating margins, immunity to noise, and amount of radiated noise. When changing to a product with a different part number, implement a system-

evaluation test for the given product. 

 
 
 ・Arm® and Cortex® are registered trademarks of Arm Limited (or its subsidiaries) in the EU and/or elsewhere.  

All rights reserved.  
・Ethernet is a registered trademark of Fuji Xerox Co., Ltd. 
・IEEE is a registered trademark of the Institute of Electrical and Electronics Engineers Inc  
・TRON is an acronym for "The Real-time Operation system Nucleus. 
・ITRON is an acronym for "Industrial TRON.  
・μITRON is an acronym for "Micro Industrial TRON. 
・TRON, ITRON, and μITRON do not refer to any specific product or products.  
・PROFINET is a trademark of ODVA. 
・Additionally all product names and service names in this document are a trademark or a registered trademark 

which belongs to the respective owners. a trademark or a registered trademark which belongs to the respective 
owners. 
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Notice 
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product or system. Renesas Electronics disclaims any and all liability for any losses and damages incurred by you or third parties arising from the use 
of these circuits, software, or information. 
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or other intellectual property rights of third parties, by or arising from the use of Renesas Electronics products or technical information described in this 
document, including but not limited to, the product data, drawings, charts, programs, algorithms, and application examples.  

3. No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights of Renesas Electronics 
or others. 

4. You shall not alter, modify, copy, or reverse engineer any Renesas Electronics product, whether in whole or in part. Renesas Electronics disclaims any 
and all liability for any losses or damages incurred by you or third parties arising from such alteration, modification, copying or reverse engineering. 

5. Renesas Electronics products are classified according to the following two quality grades: “Standard” and “High Quality”. The intended applications for 
each Renesas Electronics product depends on the product’s quality grade, as indicated below. 
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disclaims any and all liability for any damages or losses incurred by you or any third parties arising from the use of any Renesas Electronics product 
that is inconsistent with any Renesas Electronics data sheet, user’s manual or other Renesas Electronics document. 

6. When using Renesas Electronics products, refer to the latest product information (data sheets, user’s manuals, application notes, “General Notes for 
Handling and Using Semiconductor Devices” in the reliability handbook, etc.), and ensure that usage conditions are within the ranges specified by 
Renesas Electronics with respect to maximum ratings, operating power supply voltage range, heat dissipation characteristics, installation, etc. Renesas 
Electronics disclaims any and all liability for any malfunctions, failure or accident arising out of the use of Renesas Electronics products outside of such 
specified ranges. 

7. Although Renesas Electronics endeavors to improve the quality and reliability of Renesas Electronics products, semiconductor products have specific 
characteristics, such as the occurrence of failure at a certain rate and malfunctions under certain use conditions. Unless designated as a high reliability 
product or a product for harsh environments in a Renesas Electronics data sheet or other Renesas Electronics document, Renesas Electronics 
products are not subject to radiation resistance design. You are responsible for implementing safety measures to guard against the possibility of bodily 
injury, injury or damage caused by fire, and/or danger to the public in the event of a failure or malfunction of Renesas Electronics products, such as 
safety design for hardware and software, including but not limited to redundancy, fire control and malfunction prevention, appropriate treatment for 
aging degradation or any other appropriate measures. Because the evaluation of microcomputer software alone is very difficult and impractical, you are 
responsible for evaluating the safety of the final products or systems manufactured by you. 

8. Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental compatibility of each Renesas 
Electronics product. You are responsible for carefully and sufficiently investigating applicable laws and regulations that regulate the inclusion or use of 
controlled substances, including without limitation, the EU RoHS Directive, and using Renesas Electronics products in compliance with all these 
applicable laws and regulations. Renesas Electronics disclaims any and all liability for damages or losses occurring as a result of your noncompliance 
with applicable laws and regulations. 

9. Renesas Electronics products and technologies shall not be used for or incorporated into any products or systems whose manufacture, use, or sale is 
prohibited under any applicable domestic or foreign laws or regulations. You shall comply with any applicable export control laws and regulations 
promulgated and administered by the governments of any countries asserting jurisdiction over the parties or transactions. 

10. It is the responsibility of the buyer or distributor of Renesas Electronics products, or any other party who distributes, disposes of, or otherwise sells or 
transfers the product to a third party, to notify such third party in advance of the contents and conditions set forth in this document. 

11. This document shall not be reprinted, reproduced or duplicated in any form, in whole or in part, without prior written consent of Renesas Electronics. 
12. Please contact a Renesas Electronics sales office if you have any questions regarding the information contained in this document or Renesas 

Electronics products. 

(Note1) “Renesas Electronics” as used in this document means Renesas Electronics Corporation and also includes its directly or indirectly controlled 
subsidiaries. 

(Note2) “Renesas Electronics product(s)” means any product developed or manufactured by or for Renesas Electronics. 
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