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RX72M Group  
Communications Board DeviceNet (Slave) Startup Manual 
Introduction 
This is a quick start guide to running DeviceNet™ communications on the RX72M communications board for 
evaluating industrial networks. 

 

Target Device 
RX72M Group 

 

Sample Program 
This sample program uses the evaluation version of the DeviceNet stack produced by one of our partners, 
M2M craft Co., Ltd. The stack's major communications specifications are as follows. 

• Communications protocol: Compliant with DeviceNet Specifications Release 2.0 
• Transfer rate: 500 kbps, 250 kbps, 125 kbps 
• MAC ID: 0 to 63 
 
For purchase of the official version of the stack and the specifications of the sample program, contact     
M2M craft Co., Ltd. 

M2M craft Co., Ltd. Web site: http://m2mcraft.co.jp/ 

 

[Restrictions] 
The evaluation version of the DeviceNet stack consists of library files which were built with the functional 
limitations as listed below. This version is only made available for purposes of evaluation. 

• The numbers of communications services and types are fixed. 
• The number of objects that can be registered in the object dictionary has a limit of 15. 
• The evaluation stack automatically stops running after 60 minutes. Re-starting the program requires 

resetting the device. 
 
Please note that the evaluation stack cannot be used in commercial products. Purchasing the official version 
of the DeviceNet stack is required if it is to be used in a commercial product. 
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1. Operating Environment 
The sample program covered in this manual runs in the environment below. 

 

Table 1.1 Operating Environment 

Item Description 
Board RX72M communications board 

TS-TCS07298 from Tessera Technology  
CPU RX CPU (RXv3) 
Operating frequency CPU clock (CPUCLK): 240 MHz 
Operating voltage 3.3 V 
Operating modes Single chip mode 
Device requirements R5F572MNDDBD 

• Code flash memory 
Capacity: 4 Mbytes 
ROM cache: 8 Kbytes 

• Data flash memory 
Capacity: 32 Kbytes 

• RAM/extended RAM 
Capacity: 512 Kbytes / 512 Kbytes 

Communications protocol DeviceNet 
Integrated development environment e2 studio (V7.5.0 or later) with the CC-RX compiler (V3.01.00) 
Emulator (ICE) Renesas E2 Lite 
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2. Setting up and Connecting the Evaluation Board 
For detailed information on the board, refer to the RX72M Group Communications Board Hardware Manual.  

 

 
 
 

 
 
 

Figure 2.1 Configuration of the RX72M Communications Board 

 
Table 2.1 CAN Interface (J5) 

Pin Number I/O Signal Name 
1 I/O CANH 
2 I/O CANL 
3 — GND 

 
  

 

 

 

RESET switch 

Power LED 

CAN I/F (J5) 

 

 

DC5V power  
supply 

USB serial 
(power supply) 
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2.1 Setting up the Board 
Before supplying power to the board, set up jumpers and connect the cables. In addition, make settings for 
the JTAG configuration mode. This mode is normally used with a short circuit between jumper pins 2 and 3.  

 

For the detailed locations of the related parts, refer to the RX72M Communications Board Hardware Manual. 

 

 
 
 

Figure 2.2 Setting up Jumper Pins 

 

2.2 Selecting the Power Source 
Power to the RX72M can be supplied from a 5-V DC power source or through the USB port. Use whichever 
is suitable for the configuration of your operating environment. 

  

 

Jumper pins 
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3. Installing the e2 studio 
Download the e2 studio for RX72M (V7.5.0 or later) from the Web site below. 

https://www.renesas.com/e2studio_download 
 

3.1 Installing the CC-RX Compiler V3.01.00 
The compiler selection dialog box appears while installing the e2 studio. Click [Renesas CCRX v3.01.00] and 
select [Next]. CC-RX V3.01.00 Compiler for RX72M will be installed with the e2 studio. 

 

 

To start the e2 studio, execute "e2studio.exe" in the following installation folder. 

e2_studio_rx72m\eclipse 
 

3.2 How to check the registered Compiler 
(1) Start the e2 studio. 
 
(2) Select [File] → [New] → [C/C++Project] → [Next].  

 

  

https://www.renesas.com/e2studio_download
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(3) In the [Templates for New C/C++ Project] dialog box, select [Renesas RX] → [Renesas CC-RX C/C++ 
Executable Project] → [Next].  

 

 
(4) In the [New Renesas CC-RX C/C++ Executable Project] dialog box, enter a desired project name and 

select [Next]. 
 
(5) In the [Select toolchain, device & debug settings] dialog box, select [Manage Toolchains...] under 

[Toolchain Settings]. 
 
(6) In the [Renesas Toolchain Management] dialog box, the registration was successful if "v3.01.00” has 

been added under "Renesas CCRX". 
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4. Connections 
(1)Connect the CAN interface to the CAN bus. For details, see section 7.1.1 Configuration of Connections 
(2)Connect the E2 Emulator Lite to the JTAG connector on the communications board with the user interface 

cable. 
(3)Connect the E2 Emulator Lite to a USB port of the PC you are using. The "ACT" LED on the E2 Emulator 

Lite starts to blink. 
(4)The "Found new hardware" wizard appears. Follow the procedure described below to install the driver. 

Installation on a PC running WindowsTM 7, 8, or 8.1 requires logging in with a user name that has 
administrator rights. 

WindowsTM 7/8/8.1: A notice appears on the Windows taskbar when the installation is finished. 
WindowsTM 10: A button for device configuration appears on the Windows taskbar and 

installation is automatic. 
(5)Supply power to the communications board from a 5-V DC power source or through the USB port. 
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5. Importing a Sample Project to the e2 studio 
(1) Select [File] → [Import]. 
 
(2) In the [Select] dialog box, select [General] → [Existing Projects into Workspace] and select [Next]. 

 

 

(3) In the [Import Projects] dialog box, check the "Select archive file:" button, then select [Browse...]. 
 
(4) Select "RX72M_DnetSlave.zip" as a sample project file for the communications board, and select [Open]. 

 
 
Check "RX72M_DnetSlave(RX72M_DnetSlave/)" under the "Projects" label and select [Next]. The project 
will be imported into the workspace. 
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6. Programming and Debugging 
(1) Select the "RX72M_DnetSlave" project in the Project Explorer view. Select the arrow next to the build 

button (hammer icon) and select [HardwareDebug] from the drop-down menu.  

 

 
(2) e2 studio will build the project. After the build is completed, select the arrow next to the debug button (bug 

icon). You can start debugging by selecting [Debug Configurations...].  
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(3) Select the file "RX72M_DnetSlave HardwareDebug" and download the program to the target device. Click 
on the [Debug] button to start debugging.  

 

 
(4) If a firewall warning is displayed for "e2-server-gdb.exe", check the checkbox for [Private networks, such 

as my home or work network] and select [Allow access]. 
 
(5) The User Account Control (UAC) dialog box may appear. Enter the administrator's password and select 

[Yes]. 
 
(6) If the Confirm Perspective Switch dialog box appears prompting you to switch the perspective, check the 

checkbox for [Remember my decision] and select [Yes]. 
 
(7) The green "ACT" LED on the E2 Lite debugger will be continuously lit. 
 
After downloading the code, select the [Resume] button to run the code. The code will break at the address 
where the main function starts. Select the [Resume] button again to continue to run the code. 
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7. Appendix 
7.1 Verifying Operation of the Sample Program 
Operation of the sample program can be verified as follows. 

7.1.1 Configuration of Connections 

 

Figure 7.1 Configuration of Connections 
 

Table 7.1 List of Devices 

Item Description 
DeviceNet slave device RX72M communications board (with this sample program already written to it) 

TS-TCS02796 from Tessera Technology 
DeviceNet master device DeviceNet USB Interface (hereinafter referred to as SST-DN4-USB) (Molex) *1  
PC software DeviceNet Remote Diagnostic (Molex) *1  

Note: 1. For how to obtain the device and PC software and related support information, contact Molex.  
 
  

USB cable 

DeviceNet Remote Diagnostic 

RX72M Communications Board 

PC DC24V output AC adapter 

DeviceNet USB Interface 

CAN_H 

CAN_L 

24V      0V 
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7.1.2 Connecting the SST-DN4-USB 
DeviceNet handles transfer of data based on the CAN communications protocol. Connect the CAN connector 
of the SST-DN4-USB to the CAN interface (J5) on the RX72M communications board. The SST-DN4-USB is 
required to supply power for communications. Input 24-V DC through CAN connector pins 1 (red label) and 5 
(black label) of the SST-DN4-USB. 

 
Table 7.2 CAN Interface Connection 

Signal Name 
Pin Number of the CAN Connector of 
SST-DN4-USB  

Pin Number of the CAN Interface (J5) of 
the RX72M Communications Board 

CANH 4 (white label) 1 
CANL 2 (blue label) 2 

 
7.1.3 Configuring the DeviceNet Remote Diagnostic 
7.1.3.1 Starting the Tool 
From the Start menu of your PC, select [SST] → [DeviceNet Remote Diagnostic]. 
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7.1.3.2 Registering Card Alias 
First, select the [Config] tab on the right side of the console window and select [Search USB Adapter]. 

 

 
Next, confirm that information related to the currently connected SST-DN4-USB is displayed under the 
[Found Remote Scanners] label. 
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After that, select [Add to Config]. Confirm that "DN4-USB-0001" has been registered as a card alias under 
the [Current Configuration] label. 

Note: This step is only required the first time the procedure is followed because, once registered, the alias 
information is retained. 

 

 
7.1.3.3 Scanning the Network 
Select [Network] → [Auto-Detect Network Configuration…]. 
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In the [Scanner Settings] dialog box, select the following settings and then select [OK]. 

• Card Name: DN4-USB-0001 
• Baud Rate: 500 kbits/sec 
• MAC ID: 1 
 

 
 
After scanning has finished, confirm that a slave (MAC ID = 0x05, Name = TestProduct) has been detected. 
You can see that the slave is displayed linked with the master in the form of a tree structure. At this point, 
both icons in the tree are grayed out. 
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7.1.3.4 Connection with the Slave 
Select [Network] → [Go Online]. 

 
 
Select the [Network] tab on the right side of the console window, then confirm that the upper mark under the 
[Scanner Status] label has turned green, indicating that the current status is "Online", and that "Baud Rate 
(kbps)" is indicated as "500". 
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Next, select [Network] → [Start Scan]. 

 
 
Following successful connection of the master and slave, both icons in the tree turn from gray to fully colored 
as shown below. 

 

 
  



RX72M Group Communications Board DeviceNet (Slave) Startup Manual 

R01AN4738EJ0101  Rev.1.01  Page 19 of 21 
Jan. 31, 2020  

7.1.4 Verifying the I/O Operations 
Select the slave icon in the tree structure and then select the [Send Explicit] tab on the right side of the 
console window. 

Specify values as parameters for "Service", "Class", "Instance", and "Service Data" and select [Send]. The 
values are sent to the slave and, in return, the slave responds with the given values. 

The log of communications between the master and slave is displayed under the [Response] label at the 
bottom, with new lines always added to the top of the log. 
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7.1.4.1 Obtaining a Vendor ID 
The following shows the procedure for obtaining a vendor ID for the slave. 

Specify the following values as parameters for "Service", "Class", "Instance", and "Service Data" and select 
[Send]. 

• Service:   0x0E (Get_Attribute_Single) 
• Class:  0x01 (Identity Object) 
• Instance:   0x01 
• Service Data: 01 
 
The value of the vendor ID (1478) is returned from the slave, and "Service: 8E" and "Data: C6 05" is 
displayed in the log. 
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Website and Support 
Renesas Electronics Website 
http://www.renesas.com/ 
 
Inquiries 
http://www.renesas.com/contact/ 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
All other logos and trademarks are the property of the respective trademark owners. 

http://www.renesas.com/
http://www.renesas.com/contact/
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General Precautions in the Handling of Microprocessing Unit and Microcontroller 
Unit Products 
The following usage notes are applicable to all Microprocessing unit and Microcontroller unit products from Renesas. For detailed usage notes on the 
products covered by this document, refer to the relevant sections of the document as well as any technical updates that have been issued for the products. 

1. Precaution against Electrostatic Discharge (ESD) 

A strong electrical field, when exposed to a CMOS device, can cause destruction of the gate oxide and ultimately degrade the device operation. Steps 

must be taken to stop the generation of static electricity as much as possible, and quickly dissipate it when it occurs. Environmental control must be 

adequate. When it is dry, a humidifier should be used. This is recommended to avoid using insulators that can easily build up static electricity. 

Semiconductor devices must be stored and transported in an anti-static container, static shielding bag or conductive material. All test and 

measurement tools including work benches and floors must be grounded. The operator must also be grounded using a wrist strap. Semiconductor 

devices must not be touched with bare hands. Similar precautions must be taken for printed circuit boards with mounted semiconductor devices. 
2. Processing at power-on 

The state of the product is undefined at the time when power is supplied. The states of internal circuits in the LSI are indeterminate and the states of 

register settings and pins are undefined at the time when power is supplied. In a finished product where the reset signal is applied to the external reset 

pin, the states of pins are not guaranteed from the time when power is supplied until the reset process is completed. In a similar way, the states of pins 

in a product that is reset by an on-chip power-on reset function are not guaranteed from the time when power is supplied until the power reaches the 

level at which resetting is specified. 
3. Input of signal during power-off state 

Do not input signals or an I/O pull-up power supply while the device is powered off. The current injection that results from input of such a signal or I/O 

pull-up power supply may cause malfunction and the abnormal current that passes in the device at this time may cause degradation of internal 

elements. Follow the guideline for input signal during power-off state as described in your product documentation. 
4. Handling of unused pins 

Handle unused pins in accordance with the directions given under handling of unused pins in the manual. The input pins of CMOS products are 

generally in the high-impedance state. In operation with an unused pin in the open-circuit state, extra electromagnetic noise is induced in the vicinity of 

the LSI, an associated shoot-through current flows internally, and malfunctions occur due to the false recognition of the pin state as an input signal 

become possible. 
5. Clock signals 

After applying a reset, only release the reset line after the operating clock signal becomes stable. When switching the clock signal during program 

execution, wait until the target clock signal is stabilized. When the clock signal is generated with an external resonator or from an external oscillator 

during a reset, ensure that the reset line is only released after full stabilization of the clock signal. Additionally, when switching to a clock signal 

produced with an external resonator or by an external oscillator while program execution is in progress, wait until the target clock signal is stable. 
6. Voltage application waveform at input pin 

Waveform distortion due to input noise or a reflected wave may cause malfunction. If the input of the CMOS device stays in the area between VIL 

(Max.) and VIH (Min.) due to noise, for example, the device may malfunction. Take care to prevent chattering noise from entering the device when the 

input level is fixed, and also in the transition period when the input level passes through the area between VIL (Max.) and VIH (Min.). 
7. Prohibition of access to reserved addresses 

Access to reserved addresses is prohibited. The reserved addresses are provided for possible future expansion of functions. Do not access these 

addresses as the correct operation of the LSI is not guaranteed. 
8. Differences between products 

Before changing from one product to another, for example to a product with a different part number, confirm that the change will not lead to problems. 

The characteristics of a microprocessing unit or microcontroller unit products in the same group but having a different part number might differ in terms 

of internal memory capacity, layout pattern, and other factors, which can affect the ranges of electrical characteristics, such as characteristic values, 

operating margins, immunity to noise, and amount of radiated noise. When changing to a product with a different part number, implement a system-

evaluation test for the given product. 
 
 
 
 
 
 

-  DeviceNetTM is a trademark of ODVA, Inc.. 
-  Additionally, all product names and service names in this document are the trademarks or registered 

trademarks which belong to the respective owners. 
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Notice 
1. Descriptions of circuits, software and other related information in this document are provided only to illustrate the operation of semiconductor products 

and application examples. You are fully responsible for the incorporation or any other use of the circuits, software, and information in the design of your 
product or system. Renesas Electronics disclaims any and all liability for any losses and damages incurred by you or third parties arising from the use 
of these circuits, software, or information. 

2. Renesas Electronics hereby expressly disclaims any warranties against and liability for infringement or any other claims involving patents, copyrights, 
or other intellectual property rights of third parties, by or arising from the use of Renesas Electronics products or technical information described in this 
document, including but not limited to, the product data, drawings, charts, programs, algorithms, and application examples.  

3. No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights of Renesas Electronics 
or others. 

4. You shall not alter, modify, copy, or reverse engineer any Renesas Electronics product, whether in whole or in part. Renesas Electronics disclaims any 
and all liability for any losses or damages incurred by you or third parties arising from such alteration, modification, copying or reverse engineering. 

5. Renesas Electronics products are classified according to the following two quality grades: “Standard” and “High Quality”. The intended applications for 
each Renesas Electronics product depends on the product’s quality grade, as indicated below. 
 "Standard": Computers; office equipment; communications equipment; test and measurement equipment; audio and visual equipment; home 

electronic appliances; machine tools; personal electronic equipment; industrial robots; etc. 
 "High Quality": Transportation equipment (automobiles, trains, ships, etc.); traffic control (traffic lights); large-scale communication equipment; key 

financial terminal systems; safety control equipment; etc. 
Unless expressly designated as a high reliability product or a product for harsh environments in a Renesas Electronics data sheet or other Renesas 
Electronics document, Renesas Electronics products are not intended or authorized for use in products or systems that may pose a direct threat to 
human life or bodily injury (artificial life support devices or systems; surgical implantations; etc.), or may cause serious property damage (space 
system; undersea repeaters; nuclear power control systems; aircraft control systems; key plant systems; military equipment; etc.). Renesas Electronics 
disclaims any and all liability for any damages or losses incurred by you or any third parties arising from the use of any Renesas Electronics product 
that is inconsistent with any Renesas Electronics data sheet, user’s manual or other Renesas Electronics document. 

6. When using Renesas Electronics products, refer to the latest product information (data sheets, user’s manuals, application notes, “General Notes for 
Handling and Using Semiconductor Devices” in the reliability handbook, etc.), and ensure that usage conditions are within the ranges specified by 
Renesas Electronics with respect to maximum ratings, operating power supply voltage range, heat dissipation characteristics, installation, etc. Renesas 
Electronics disclaims any and all liability for any malfunctions, failure or accident arising out of the use of Renesas Electronics products outside of such 
specified ranges. 

7. Although Renesas Electronics endeavors to improve the quality and reliability of Renesas Electronics products, semiconductor products have specific 
characteristics, such as the occurrence of failure at a certain rate and malfunctions under certain use conditions. Unless designated as a high reliability 
product or a product for harsh environments in a Renesas Electronics data sheet or other Renesas Electronics document, Renesas Electronics 
products are not subject to radiation resistance design. You are responsible for implementing safety measures to guard against the possibility of bodily 
injury, injury or damage caused by fire, and/or danger to the public in the event of a failure or malfunction of Renesas Electronics products, such as 
safety design for hardware and software, including but not limited to redundancy, fire control and malfunction prevention, appropriate treatment for 
aging degradation or any other appropriate measures. Because the evaluation of microcomputer software alone is very difficult and impractical, you are 
responsible for evaluating the safety of the final products or systems manufactured by you. 

8. Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental compatibility of each Renesas 
Electronics product. You are responsible for carefully and sufficiently investigating applicable laws and regulations that regulate the inclusion or use of 
controlled substances, including without limitation, the EU RoHS Directive, and using Renesas Electronics products in compliance with all these 
applicable laws and regulations. Renesas Electronics disclaims any and all liability for damages or losses occurring as a result of your noncompliance 
with applicable laws and regulations. 

9. Renesas Electronics products and technologies shall not be used for or incorporated into any products or systems whose manufacture, use, or sale is 
prohibited under any applicable domestic or foreign laws or regulations. You shall comply with any applicable export control laws and regulations 
promulgated and administered by the governments of any countries asserting jurisdiction over the parties or transactions. 

10. It is the responsibility of the buyer or distributor of Renesas Electronics products, or any other party who distributes, disposes of, or otherwise sells or 
transfers the product to a third party, to notify such third party in advance of the contents and conditions set forth in this document. 

11. This document shall not be reprinted, reproduced or duplicated in any form, in whole or in part, without prior written consent of Renesas Electronics. 
12. Please contact a Renesas Electronics sales office if you have any questions regarding the information contained in this document or Renesas 

Electronics products. 

(Note1) “Renesas Electronics” as used in this document means Renesas Electronics Corporation and also includes its directly or indirectly controlled 
subsidiaries. 

(Note2) “Renesas Electronics product(s)” means any product developed or manufactured by or for Renesas Electronics. 
 

(Rev.4.0-1  November 2017) 
 

Corporate Headquarters  Contact information 
TOYOSU FORESIA, 3-2-24 Toyosu, 
Koto-ku, Tokyo 135-0061, Japan 
www.renesas.com 

 For further information on a product, technology, the most up-to-date 
version of a document, or your nearest sales office, please visit: 
www.renesas.com/contact/. 

Trademarks   
Renesas and the Renesas logo are trademarks of Renesas Electronics 
Corporation. All trademarks and registered trademarks are the property 
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