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RX72M Group 
Communication Board EtherCAT Startup Manual 
Introduction 

This application note is a quick start guide for EtherCAT® communication with the RX72M communication 
board for industrial network evaluation. 

 

Target Device 
RX72M 
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1. Operating environment 
The sample program in this manual assumes the following environment. 

 

 

Table 1.1 Operating environment 
Item Detailed content 
Evaluation board RX72M Communication Board 

TS-RX72M-COM from TESSERA TECHNOLOGY INC. 
CPU RX CPU (RXv3) 
Operating frequency CPU Clock (CPUCLK)：240MHz  
Operating voltage 3.3V 
Operation mode • Single chip mode 

• Boot mode (SCI interface) 
• Boot mode (USB interface) 
• Boot mode (FINE interface) 

Device R5F572MNDDBD 
• Code flash memory 

Capacity: 4 Mbytes 
ROM cache: 8 Kbytes 

• Data flash memory 
Capacity: 32 Kbytes 

• RAM/extended RAM 
Capacity: 512 Kbytes / 512 Kbytes 

Communication protocol EtherCAT 
IDE CCRX compiler (V3.05.00 or later) + e2Studio(2025-04 or later) 

IAR Embedded Workbench for Renesas RX (V5.10.1 or later) 
Smart Configurator for RX (V2.19.0 or later) 

Emulator Renesas Electronics 
E2 Lite 

SSC Tool EtherCAT Technology Group (ETG)  
Slave Stack Code (SSC) Tool Version 5.13 or later 

SoftwarePLC Beckhoff Automation  
TwinCAT® 3 (Download from Beckhoff web site) 

 

Note). SSC Tool, the installation of the software PLC shall have been completed. 
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2. Setting up and connecting the Communication board 
For detailed information on the evaluation board, refer to "RX72M Communication Board Hardware Manual". 

 

 

Figure 1.1  RX72M Communication board configuration 

 

 

2.1 Communication board setting 
Before powering on the evaluation board, make jumper settings and connect each cable. Configure the 
configuration mode of JTAG. Usually it is used at 2-3 short of jumper pin. To use the hot plug-in function, 
change it to 1-2 short and use it. 

For more information about the position of the relevant parts, refer to the [RX72M communication board 
hardware manual]. 

 

Figure 1.2 Jumper pin setting 
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2.2 Power supply selection 
This board can supply power for RX 72 M by inputting DC 5 V by DC Jack or USB. select either. 

 

 

2.3 Connection of communication board 
Connect each cable as follows. 

(1) Connect Ethernet cable (category 5 or higher recommended) to Ether port (CN 2 IN). 

(2) Connect JTAG connector of ICE to JTAG Connector, USB connection with host computer. 

(3) Connect DC 5 V from DC Jack or USB and turn on the power. 
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3. Installation of e2studio 
Download the e2 studio for RX72M (2023-10 or later) from the Web site below. 

https://www.renesas.com/e2studio_download 
 

3.1 Installing the CC-RX Compiler V3.05.00 
The device families selection dialog box appears while installing the e2 studio. Click [RX] and install. CC-RX 
V3.05.00 Compiler for RX72M will be installed with the e2 studio. 

 

 

3.2 How to check the registered Compiler 
(1) Start the e2 studio from the Windows Start menu. 
 
(2) Select [File] → [New] → [C/C++Project] → [Next].  

 

  

https://www.renesas.com/e2studio_download
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(3) In the [Templates for New C/C++ Project] dialog box, select [Renesas RX] → [Renesas CC-RX C/C++ 
Executable Project] → [Next].  

 

 
(4) In the [New Renesas CC-RX C/C++ Executable Project] dialog box, enter a desired project name and 

select [Next]. 
 
 
(5) In the [Select toolchain, device & debug settings] dialog box, select [Manage Toolchains...] under 

[Toolchain Settings]. 
 
 
(6) In the [Renesas Toolchain Management] dialog box, the registration was successful if "v3.05.00” has 

been added under "Renesas CCRX". 
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4. Connection 
 
(1) Connect the LAN cable to "CN2 IN" side. 
 
(2) Connect the E2 emulator Lite to the JTAG connector of the communication board with the user interface 

cable. 
 
(3) Connect the E2 emulator Lite to the USB port of the computer. The "ACT" LED of E2 emulator Lite 

flashes. 
 
(4) "Found New Hardware" wizard will be displayed. Follow the steps below to install the driver. For 

WindowsTM 7/8 / 8.1, administrator authority is required. 
WindowsTM 7/8 / 8.1: When the installation is completed, the completion is notified to the Windows task 

bar. 
WindowsTM 10: The device setting button is displayed on Windows Taskbar and it is automatically 

installed. 
 
(5) Supply power to the communication board. 
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5. Import EtherCAT slave stack code into Sample Program 
* EtherCAT slave stack code is not included in this sample project. 
* "EtherCAT Slave Stack Code (SSC) Tool" is required to generate EtherCAT slave stack code. 
* SSC Tool is available from the ETG Association. 
 
This sample program is provided in the form of "ecat_demo_comrx72m.zip", so unzip it in any folder in 
advance. 
 
(1) Start the SSC Tool by clicking [EtherCAT Slave Stack Code] → [SSC Tool] from the Windows start 

menu. 
 
(2) In the New Project dialog, click Import, select the following SSC Tool configuration file in the sample 

program folder, and click [OK]. 
ecat_demo_comrx72m\utilities\ssc_config\ Renesas_RX72M_config.xml 

 
(3) Check the [Custom] check box and select "Renesas RX 72 M <Renesas Electronics Corp>" from the list 

and click [OK]. 

 

 

(4) Click [File] -> [Save] and save the project with an arbitrary project file name. (It becomes "RX 72 M 
EtherCAT.esp" by default) 
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(5) Click [Project] → [Create New Slave Files] Click [Start] on the [Current new Slave Files] dialog. 

 

 

(6) Source code is generated, and when it succeeds "New Files created successfully" is displayed, so click 
[OK]. 
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(7) Move the generated EtherCAT slave stack code to the EtherCAT application source folder.  

The sampleappl.c and sampleappl.h are stored in the destination “\application\ecat” folder.  
When moving the slave stack code to the applicaiotn folder, be careful not to delete these files. 
Remove the Src code from the folder or exclude the Src code from the build target in e2studio. 

 
Source folder:  
ecat_demo_comrx72m\utilities\ssc_config\Src 
 
Move destination folder:  
ecat_demo_comrx72m\project\src\application\ecat\beckhoff  

 
 
 

6. Import EtherCAT FIT module into e2studo 
The EtherCAT FIT module is not included in the RX Driver package, so if you want to use it as a software 
component of the smart configurator other than the sample project, you need to manually install it in e2 
studio. 
 
For details, refer to Chapter 6.2 of ''r01an4881xx0131-rx-ecat.pdf'' in advance and incorporate the module. 

 
  



RX72M Group Communication Board EtherCAT Startup Manual 

R01AN4672EJ0106  Rev.1.06  Page 12 of 28 
May 23, 2025  

7. Import sample projects into e2studio 
(1) Click [File] → [Import]. 

 

(2) In the [Select] dialog, select [General] → [Move existing project to workspace] and click [Next]. 

 

 

(3) Select the [Select root directory] check box in the [Import Project] dialog box and click [Browse]. 

 

(4) Select "ecat_demo_comrx72m" which is a sample project for communication board and click [Open]. 

 

 

(5) Check "ecat_demo_comrx72m" in [Project] and click [Next] to import the project. 
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8. Programming and Debugging   
(1) In the Project Explorer, Double-click on the "ecat_demo_comrx72m.scfg", and execute [Generate Code]  

 

 
 

(2) In the Project Explorer, left click on the "ecat_demo_comrx72m" project, and select [Build Project] to 
execute the build. 
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(3) When the build is completed, select [Debug Configuration] from the [Debug] button. 

 

 
 
(4) Click "ecat_demo_comrx72m Hardware Debug" to download the program to the target and start by 

pressing the debug button.  
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(5) Firewall warning of 'e2 - server - gdb.exe' may be displayed. Check the checkbox of [Private network 

such as home or workplace network] and click <Allow access>.  
 
(6) User Account Control (UAC) dialog may be displayed. Enter the administrator password and click [Yes].  
 
(7) When a dialog recommending the change of perspective is displayed on the confirmation dialog of 

perspective switching, check the [Always use this setting] checkbox and click [Yes].  
 
(8) Green "ACT" LED of the E2 Lite debugger will always on.  
 
(9) After downloading the code, click the <resume> button and execute the code until the first line of the 

main function main (). Click the <resume> button again to execute the target with the rest of the code. 
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9. Connection with TwinCAT 
This section explains how to operate the sample program using TwinCAT3. 
 

9.1 Preparation of ESI file 
Before starting TwinCAT please copy the ESI file included in the sample program to the prescribed location 
of TwinCAT (\TwinCAT\3.x\Config\IO\EtherCAT).  

 
ecat_demo_comrx72m\utilities\esi\ Renesas EtherCAT RX72M.xml 
 
 

9.2 Starting TwinCAT 
(1) From the start menu, select [Beckhoff] → [TwinCAT 3] → [TwinCAT XAE (VS 20 xx)]. 
 
(2) After starting the program, create a new project of type TwinCAT XAE Project as [File] → [New] → 

[Project]. 
 
 

9.3 Scanning the network 
(1) In the System Manager tree, right-click [I / O] → [Devices] and select [Scan]. 
 
(2) Click [OK] on the [HINT: Not all types of devices can be found automatically] dialog 
 
(3) In the [new I / O devices found] dialog box, select the check box of the Ethernet adapter to be scanned 

and click [OK]. 
 
(4) Clicking [Yes] in the [Scan for Boxes] dialog starts scanning and the devices in the EtherCAT segment 

are automatically recognized. 
 
(5) "Active Free Run" dialog is displayed and click [Yes]. 

In the system manager tree, if Box is added as "Device1" → "Box1" under "I/O" → "Devices",                 
it is normal.  
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9.4 Writing of SII EEPROM 
* Because the EEPROM is blank at the time of shipment of the communication board, be sure to perform 
writing. 
* If the EEPROM has been written, the processing in this section is unnecessary. 
 

If the EEPROM is blank, it is displayed as "Box 1 (PFFFFFFFF RFFFFFFFF)" in the system manager tree. 
 

(1) Double-click [Box 1] in the System Manager tree, the panel will be displayed on the right side.  
 
(2) Select the [EtherCAT] tab and click the [Advanced Settings] button. 
 
(3) Select [ESC Access] -> [EEPROM] -> [Hex Editor] in the left tree of the Advanced Settings dialog. 
 
(4) In the [Hex Editor] dialog, select "Download from list".  
 
(5) In the [Write EEPROM] dialog box, select [Renesas Electronics Corp.] → [Renesas RX 72 M Group] → 

[Renesas EtherCAT RX 72 M]] and click [OK]. The EEPROM is written. 
 
(6) After writing, restart the communication board (turn the power supply on again or reset), so that the 

rewritten data is reflected in the operation of the microcomputer.  
 
 

9.5  Rescan of the device 
(1) Press the [Restart TwinCAT (Config Mode)] button. 
 
(2) In the [RestartTwinCAT Sysytem in Config Mode] dialog box, click [OK]. 
 
(3) In the [Load I / O Devices] dialog box, click [Yes]. 
 
(4) Click [Yes] in the [Active Free Run] dialog. 

It is OK if "Box 1" in the system manager tree is "Box 1 (Renesas EtherCAT RX 72 M)". 
 

 

9.6 I/O operation confirmation 
(1) Double-click "Box 1" in the System Manager tree, the panel will be displayed on the right side.  
 
(2) Select the "Online" tab and make sure "Current Status" is "OP". 
  
(3) Expand the + next to "Box 1" in the System Manager tree. 
 
(4) Select "TxPDO-Map" → "Input Counter" and select the "Online" tab on the right-side panel to display 

"Value". 
Check that the value is set by DIP SW 5. 

 
(5) Select "RxPDO - Map" -> "Output Counter" in the system manager tree and "Value" is displayed when 

you        select the "Online" tab on the right panel. 
Make sure that "0" is displayed. 

 
(6) Click [Write] and enter an arbitrary numerical value in the "Set Value Dialog" dialog. 
 
(7) Click "OK" and confirm that the value "Value" is the entered value. 

Lower 4 bits of the entered value is displayed on LED4-1 of the communication board.  
(LED lights up when bit = 1) 
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10. Appendix Conversion procedure to the IAR project 
Download and install IAR Embedded Workbench for Renesas RX (V5.10.1 or later) for RX72M from the IAR 
Systems website. 

https://www.iar.com/jp/ 

Also, Download and install Smart Configurator for RX (V2.19.0 or later) from the following website. 

      https://www.renesas.com/jp/ja/software-tool/rx-smart-configurator 

This section describes the procedure for converting an e2 studio version project to an IAR project. 
 

(1) Start IAR Embedded Workbench for Renesas RX. 
 

(2) Click "Tools >> Convert To IAR for RX ...". 
 

(3) Select "ecat_demo_comrx72" in the e2 studio version sample program directory in the Root directory 
of source project. 

 
(4) Select the "Enable" check box for Project file conversion.  

 
(5) Select "Renesas e2studio for RX" in Project type.  

 
(6) Uncheck the check box of "Enable" in the Source code substitution.  

 
(7) Click “Execute”  

 

  

https://www.iar.com/jp/
https://www.renesas.com/jp/ja/software-tool/rx-smart-configurator
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(8) In the Choose destination directory window, select the "Operate on a copy of the source code in the 

following directory" checkbox. Please freely select the destination directory. 

 

 
(9) Click "OK" in the Report window.  

 

Please leave IAR Embedded Workbench for Renesas RX running 
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(10) Then start Smart Configurator for RX. 

The EtherCAT FIT module is not included in the RX Driver package, so you need to manually install in 
the Smart Configurator for RX when you start it for the first time. 

For details, refer to Chapter 6.3 of ``r01an4881xx0131-rx-ecat.pdf'' in advance and incorporate the 
module. 

(11) Click "File >> Open” and select iccrx_ecat_demo_comrx72m.scfg in the destination directory. 

 

(12) When the configuration window is displayed, execute “Generate Code”. 
You can exit the Smart Configurator for RX. 

(13) Return to IAR Embedded Workbench for Renesas RX. 
Click "File >> Open Workspace " to open the .eww file in the destination directory for the IAR project.  

(14) Click "Project >> Add Project Connection ". 
Select “IAR Project Connection File” as the connection to use and click “OK”. 
Select buildinfo.ipcf and click "Open". 
The file generated by Smart Configurator for RX will be imported. 
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(15) Right click on the project and click "Options".  

 
(16) Select "Target" on the General Options tab.  

 
(17) Select "Device to use". In case of RX72M, it is “R5F572MN_DUAL” 
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(18) Select "Preprocessor" in the C / C ++ Compiler tab and set the same include path as the CCRX 

project.  

 

 

Set up under \ src  according to the project directory. 

$PROJ_DIR$\src\application\ecat\beckhoff\Src 

$PROJ_DIR$\src\application\ecat\renesas 
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(19) Select "Settings" on the Linker tab. Set the "Default Override" checkbox in the linker configuration file. 

Next, select ".icf file of target device". Please set "lnkrx700.icf" for RX72M. 
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(20) Select "Settings" on the debugger tab. Select "Emulator" in the driver. RX72M is "E2 Lite / EZ-

CUBE2". ‥Select "Default Override" in the device description file. RX72M is “ior5f572mn_dual.ddf”. 

 

 
 

(21) Click “Project >> Rebuild All”. 

(22) Click "E2 / E2 Lite >> Hardware Settings ...".  

(23) Set the following items in the Hardware Setup window and click OK. 
Check “EXTAL frequency” and set the frequency to 24MHz. 

(24) Click "Project >> Download and Debug".  
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11. Appendix e2studio setting information 
This section describes the e2 studio settings for configuring the sample program. 

Please use it as a reference when creating a new project and adding the functions of the sample program. 

 

11.1 FIT module Structure 
 
The sample program consists of the following FIT modules. 
 
 

Table 10-1 FIT Module Structure 

Type Module name FIT module name 

Board Support 
Package 

Board Support Package (BSP) r_bsp 

Device Driver Compare Match Timer (CMT) r_cmt_rx 

Device Driver Serial Communication Interface (SCI) r_sci_rx 

Middleware Byte Type Queue buffer (BYTEQ) r_byteq 

Device Driver EtherCAT r_ecat_rx 

 

11.2 Configuration options 
The configuration file of the FIT module has been changed.  
And the definitions for pins assignment of DIP switch input and LED output used in the EtherCAT application 
has been changed.  
The changes to the configuration options are shown below. 
 
(1) EtherCAT FIT module settings change 

Set the PHY LSI to be used to the KSZ8081MNX mounted on the communication board. 
Also, set the PHY reset waiting time to 500 μs. 

【 r_config/r_ecat_config.h 】 

Macro Name Setting 

ECAT_CFG_USE_SUPPORTED_PHY 2 

ECAT_CFG_PHY_DELAY_RESET 500 

 

(2) SCI FIT module settings change 

Set CH6 and send completion interrupts to enable. 

【 r_config/r_sci_rx_config.h 】 

Macro Name Setting 

SCI_CFG_CH6_INCLUDED 1 

SCI_CFG_TEI_INCLUDED 1 

 

 

 

(3) EtherCAT application settings change 



RX72M Group Communication Board EtherCAT Startup Manual 

R01AN4672EJ0106  Rev.1.06  Page 26 of 28 
May 23, 2025  

Set the DIP switch input and LED output pins assignment for the communication board. 

【 application/ecat/sampleappl.c 】 

Macro Name Setting 

APPL_CFG_LED_SW 2 

 

11.3 Pin configuration 
You can import the pin settings to run the sample program on the communication board. 
Click the [Import the board setting] button on the [Pins] tab of the Smart Configurator. 

Then select  ”ecat_demo_comrx72m_board.xml” . 

The xml file is included in the sample program. 

 

 

 

Enable the pins used by the FIT module in the [Resources] property of the [Components] tab. 

 

Components Resources to enable Pins to enable 

r_ecat\rx ESC 

ESC_MII0 

ESC_MII1 

All pins 

r_sci_rx SCI6 RXD6/SMISO6 pin 

TXD6/SMOSI6 pin 
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11.4 Build configuration 
The settings when building the sample program are shown below. 

 

Table 10-2  Setting Tool Tab 

Item Changing Contents Description 

Compiler  

- Source 

Include path by 

[Include・File・Directory] 

 

 

In each FIT module, for the setting please add the 
required include path.  

When installed each FIT module by using [FIT 
Configuration] it will be automatically set. 

Add the include path of sample program. In this 
project, “application\ecat\beckhoff\Src” and  
"application\ecat\renesas” are added. 

< Example Setting > 

 
Compiler  

– Optimization 

Change optimization level 

Level 1: Implement a part of the 
optimization 

To prevent the building by optimization from some 
code that generate by SSC, set optimization level 1 

 

 

 

11.5 Debug configuration 
The settings for debugging the sample program on the communication board are shown below. 

 

Table 10-3 Debug configuration 

Tab Item Changing Contents Description 

Debugger – 
Connection 
Settings 

Set the EXTAL frequency to 24MHz and don’ t turned on the 
power from the emulator. 

< Setting >  
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Revision History 

Rev. Date 
Description 

Page Summary 
1.00 Nov 1, 2019 ― First edition issued 
1.01 Apr 30,2020 3 Table 1.1 Operating environment is revised 

11 5.(7) Change destination folder of EtherCAT slave stack code 
18-24 Add “9. Appendix Conversion procedure to IAR project” 

1.02 Aug 31,2020 22 Step (15) include path is revised 
1.03 Aug 31,2021 Program Supports EtherCAT FIT module version 1.20 

25-27 Add “10. Appendix e2studio setting information” 
1.04 Jan 31,2023 Program Supports EtherCAT FIT module version 1.30 

Added utilities and project folders to separate SSC-related files 
and project-related files 
Supports e2 studio 64-bit version 
Supports SSC 5.13 

9,11,15,27 Change folder name due to folder structure change 
22,25 Removed r_sys_time_rx module from FIT module configuration 

as it is no longer used 
1.05 Nov 30, 2023 Program Modify ESI file to support CTT V2.4.0 

18-24 Change “10. Appendix Conversion procedure to IAR project” 
3 Add “Smart Configurator for RX” to Table 1.1 “Operating 

environment”  
3, 6, 7, 18 Update the version of each tool. 

1.06 May 23, 2025 Program Supports EtherCAT FIT module version 1.32 
 
 
 



 

 

General Precautions in the Handling of Microprocessing Unit and Microcontroller 
Unit Products 
The following usage notes are applicable to all Microprocessing unit and Microcontroller unit products from Renesas. For detailed usage notes on the 
products covered by this document, refer to the relevant sections of the document as well as any technical updates that have been issued for the products. 

1. Precaution against Electrostatic Discharge (ESD) 

A strong electrical field, when exposed to a CMOS device, can cause destruction of the gate oxide and ultimately degrade the device operation. Steps 

must be taken to stop the generation of static electricity as much as possible, and quickly dissipate it when it occurs. Environmental control must be 

adequate. When it is dry, a humidifier should be used. This is recommended to avoid using insulators that can easily build up static electricity. 

Semiconductor devices must be stored and transported in an anti-static container, static shielding bag or conductive material. All test and 

measurement tools including work benches and floors must be grounded. The operator must also be grounded using a wrist strap. Semiconductor 

devices must not be touched with bare hands. Similar precautions must be taken for printed circuit boards with mounted semiconductor devices. 
2. Processing at power-on 

The state of the product is undefined at the time when power is supplied. The states of internal circuits in the LSI are indeterminate and the states of 

register settings and pins are undefined at the time when power is supplied. In a finished product where the reset signal is applied to the external reset 

pin, the states of pins are not guaranteed from the time when power is supplied until the reset process is completed. In a similar way, the states of pins 

in a product that is reset by an on-chip power-on reset function are not guaranteed from the time when power is supplied until the power reaches the 

level at which resetting is specified. 
3. Input of signal during power-off state 

Do not input signals or an I/O pull-up power supply while the device is powered off. The current injection that results from input of such a signal or I/O 

pull-up power supply may cause malfunction and the abnormal current that passes in the device at this time may cause degradation of internal 

elements. Follow the guideline for input signal during power-off state as described in your product documentation. 
4. Handling of unused pins 

Handle unused pins in accordance with the directions given under handling of unused pins in the manual. The input pins of CMOS products are 

generally in the high-impedance state. In operation with an unused pin in the open-circuit state, extra electromagnetic noise is induced in the vicinity of 

the LSI, an associated shoot-through current flows internally, and malfunctions occur due to the false recognition of the pin state as an input signal 

become possible. 
5. Clock signals 

After applying a reset, only release the reset line after the operating clock signal becomes stable. When switching the clock signal during program 

execution, wait until the target clock signal is stabilized. When the clock signal is generated with an external resonator or from an external oscillator 

during a reset, ensure that the reset line is only released after full stabilization of the clock signal. Additionally, when switching to a clock signal 

produced with an external resonator or by an external oscillator while program execution is in progress, wait until the target clock signal is stable. 
6. Voltage application waveform at input pin 

Waveform distortion due to input noise or a reflected wave may cause malfunction. If the input of the CMOS device stays in the area between VIL 

(Max.) and VIH (Min.) due to noise, for example, the device may malfunction. Take care to prevent chattering noise from entering the device when the 

input level is fixed, and also in the transition period when the input level passes through the area between VIL (Max.) and VIH (Min.). 
7. Prohibition of access to reserved addresses 

Access to reserved addresses is prohibited. The reserved addresses are provided for possible future expansion of functions. Do not access these 

addresses as the correct operation of the LSI is not guaranteed. 
8. Differences between products 

Before changing from one product to another, for example to a product with a different part number, confirm that the change will not lead to problems. 

The characteristics of a microprocessing unit or microcontroller unit products in the same group but having a different part number might differ in terms 

of internal memory capacity, layout pattern, and other factors, which can affect the ranges of electrical characteristics, such as characteristic values, 

operating margins, immunity to noise, and amount of radiated noise. When changing to a product with a different part number, implement a system-

evaluation test for the given product. 

 
 
 ・Arm® and Cortex® are registered trademarks of Arm Limited (or its subsidiaries) in the EU and/or elsewhere.  

All rights reserved.  
・Ethernet is a registered trademark of Fuji Xerox Co., Ltd. 
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