RX Family
Manually Importing Firmware Integration Technology Modules

Introduction
This application note explains how to import Firmware Integration Technology (FIT) modules downloaded from the Renesas Electronics Corporation website into Smart Configurator.

Target Products
RX Family MCUs (excluding products not compatible with Smart Configurator)

Related Documents
• Firmware Integration Technology User’s Manual (R01AN1833)
• RX Smart Configurator User’s Guide: e² studio (R20AN0451)
• RX Smart Configurator User’s Guide: CS+ (R20AN0470)
• RX Smart Configurator User’s Guide: IAREW (R20AN0535)

Contents
1. Overview ................................................................................................................................. 2
2. Manually Importing FIT Modules .......................................................................................... 3
  2.1 Downloading FIT Modules ................................................................................................. 3
  2.2 Importing Downloaded FIT Modules ................................................................................ 5
    2.2.1 Using e² studio .......................................................................................................... 5
    2.2.2 Using CS+ or IAR ................................................................................................... 8
3. Reference Information ......................................................................................................... 11
  3.1 Changing the Version of Previously Added Components ................................................. 11
  3.2 Downloading Old Versions of RX Driver Package .......................................................... 14

Revision History ..................................................................................................................... 16
1. Overview

This document explains how to import FIT modules downloaded from the Renesas Electronics Corporation website into Smart Configurator.
2. Manually Importing FIT Modules

The example used in the description that follows is based on the Renesas website as of July 12, 2021, e² studio, version 2021-07, and Renesas Smart Configurator, version 2.10.1.

2.1 Downloading FIT Modules

1. On the Renesas Electronics Corporation website (https://www.renesas.com/), click the [DESIGN & SUPPORT] tab at the top of the page, then click [SOFTWARE & TOOLS].

3. On the [RX Driver Package page under Release Information, Other downloads], click [LIST OF FIT MODULES].

4. On the [List of FIT Modules] page, click on any FIT modules you need to download.
2.2 Importing Downloaded FIT Modules

2.2.1 Using e² studio

1. Launch e² studio.

2. After e² studio starts, select [Window] → [Preferences].

3. In the Preferences window, select [Renesas] → [Module Download], then click [Location (RX)].
4. Into the folder that is displayed, copy all of the files contained in the [FITModules] folder, which is among the items downloaded in the procedure described in [2.1, Downloading FIT Modules].

5. Restart e² studio.

6. Open the file [〈project name〉.scfg] contained in a project of your choice.
7. Open the [Components] tab of the newly opened [<project name>.scfg] file, then click the [Add Components] button.

8. Clear the box next to [Show only latest version] and confirm that the newly added FIT module is displayed. If it is not shown, clear the box next to [Hide items that have duplicated functionality] and confirm once more.

For subsequent operations, refer to the user’s manual listed in Related Documents.
2.2.2 Using CS+ or IAR

1. Launch Renesas Smart Configurator.

2. After Renesas Smart Configurator starts, select [Window] → [Preferences].

3. In the Preferences window, select [Module Download], then click [Location (RX)].
4. Into the folder that is displayed, copy all of the files contained in the [FITModules] folder, which is among the items downloaded in the procedure described in [2.1, Downloading FIT Modules].

Downloaded files

Folder displayed after clicking Location (RX)

5. Restart Renesas Smart Configurator.

6. Select [File] → [Open…], and open the file [<project name>.scfg] for a project of your choice.
7. Open the [Components] tab of the newly opened [<project name>.scfg] file, then click the [Add Components] button.

8. Clear the box next to [Show only latest version] and confirm that the newly added FIT module is displayed. If it is not shown, clear the box next to [Hide items that have duplicated functionality] and confirm once more.

For subsequent operations, refer to the user’s manual listed in Related Documents.
3. Reference Information

3.1 Changing the Version of Previously Added Components

The example used in the description that follows is based on e² studio, version 2021-07.

1. Open the [<project name>.scfg] file containing the component whose version you wish to change. If you are using CS+ or IAR, open the [<project name>.scfg] file in Renesas Smart Configurator.

2. Open the [Components] tab of the newly opened [<project name>.scfg] file.
3. In the [Components] window, right-click the component whose version you wish to change and select [Change version…].

4. For [Available versions:], select the version you wish to use, then click the [Next >] button.
5. Check the information shown under [Setting Overview], then click the [Finish] button.
3.2 Downloading Old Versions of RX Driver Package

1. On the Renesas Electronics Corporation website (https://www.renesas.com/), click the [DESIGN & SUPPORT] tab at the top of the page, then click [SOFTWARE & TOOLS].

2. On the Software and Tools page under [Software], click [RX Driver Package (FIT)].
3. On the [RX Driver Package] page, scroll down to [Previous Versions] and click [Read More].

4. Click the link in the [Download] column corresponding to the old version of RX Driver Package you wish to download.
## Revision History

<table>
<thead>
<tr>
<th>Rev.</th>
<th>Date</th>
<th>Page</th>
<th>Description</th>
<th>Summary</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.00</td>
<td>Sep. 2, 2021</td>
<td></td>
<td></td>
<td>First edition issued</td>
</tr>
</tbody>
</table>
General Precautions in the Handling of Microprocessing Unit and Microcontroller Unit Products

The following usage notes are applicable to all Microprocessing unit and Microcontroller unit products from Renesas. For detailed usage notes on the products covered by this document, refer to the relevant sections of the document as well as any technical updates that have been issued for the products.

1. Precaution against Electrostatic Discharge (ESD)
   A strong electrical field, when exposed to a CMOS device, can cause destruction of the gate oxide and ultimately degrade the device operation. Steps must be taken to stop the generation of static electricity as much as possible, and quickly dissipate it when it occurs. Environmental control must be adequate. When it is dry, a humidifier should be used. This is recommended to avoid using insulators that can easily build up static electricity. Semiconductor devices must be stored and transported in an anti-static container, static shielding bag or conductive material. All test and measurement tools including work benches and floors must be grounded. The operator must also be grounded using a wrist strap. Semiconductor devices must not be touched with bare hands. Similar precautions must be taken for printed circuit boards with mounted semiconductor devices.

2. Processing at power-on
   The state of the product is undefined at the time when power is supplied. The states of internal circuits in the LSI are indeterminate and the states of register settings and pins are undefined at the time when power is supplied. In a finished product where the reset signal is applied to the external reset pin, the states of pins are not guaranteed from the time when power is supplied until the reset process is completed. In a similar way, the states of pins in a product that is reset by an on-chip power-on reset function are not guaranteed from the time when power is supplied until the power reaches the level at which resetting is specified.

3. Input of signal during power-off state
   Do not input signals or an I/O pull-up power supply while the device is powered off. The current injection that results from input of such a signal or I/O pull-up power supply may cause malfunction and the abnormal current that passes in the device at this time may cause degradation of internal elements. Follow the guideline for input signal during power-off state as described in your product documentation.

4. Handling of unused pins
   Handle unused pins in accordance with the directions given under handling of unused pins in the manual. The input pins of CMOS products are generally in the high-impedance state. In operation with an unused pin in the open-circuit state, extra electromagnetic noise is induced in the vicinity of the LSI, an associated shoot-through current flows internally, and malfunctions occur due to the false recognition of the pin state as an input signal become possible.

5. Clock signals
   After applying a reset, only release the reset line after the operating clock signal becomes stable. When switching the clock signal during program execution, wait until the target clock signal is stabilized. When the clock signal is generated with an external resonator or from an external oscillator during a reset, ensure that the reset line is only released after full stabilization of the clock signal. Additionally, when switching to a clock signal produced with an external resonator or by an external oscillator while program execution is in progress, wait until the target clock signal is stable.

6. Voltage application waveform at input pin
   Waveform distortion due to input noise or a reflected wave may cause malfunction. If the input of the CMOS device stays in the area between $V_{IL}$ (Max.) and $V_{IH}$ (Min.) due to noise, for example, the device may malfunction. Take care to prevent chattering noise from entering the device when the input level is fixed, and also in the transition period when the input level passes through the area between $V_{IL}$ (Max.) and $V_{IH}$ (Min.).

7. Prohibition of access to reserved addresses
   Access to reserved addresses is prohibited. The reserved addresses are provided for possible future expansion of functions. Do not access these addresses as the correct operation of the LSI is not guaranteed.

8. Differences between products
   Before changing from one product to another, for example to a product with a different part number, confirm that the change will not lead to problems. The characteristics of a microprocessing unit or microcontroller unit products in the same group but having a different part number might differ in terms of internal memory capacity, layout pattern, and other factors, which can affect the ranges of electrical characteristics, such as characteristic values, operating margins, immunity to noise, and amount of radiated noise. When changing to a product with a different part number, implement a system-evaluation test for the given product.
Notice

1. Descriptions of circuits, software and other related information in this document are provided only to illustrate the operation of semiconductor products and application examples. You are fully responsible for the incorporation or any other use of the circuits, software, and information in the design of your product or system. Renesas Electronics disclaims any and all liability for any losses and damages incurred by you or third parties arising from the use of these circuits, software, or information.

2. Renesas Electronics hereby expressly disclaims any warranties against and liability for infringement or any other claims involving patents, copyrights, or other intellectual property rights of third parties, by or arising from the use of Renesas Electronics products or technical information described in this document, including but not limited to, the product data, drawings, charts, programs, algorithms, and application examples.

3. No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights of Renesas Electronics or others.

4. You shall be responsible for determining what licenses are required from any third parties, and obtaining such licenses for the lawful import, export, manufacture, sales, utilization, distribution or other disposal of any products incorporating Renesas Electronics products, if required.

5. You shall not alter, modify, copy, or reverse engineer any Renesas Electronics product, whether in whole or in part. Renesas Electronics disclaims any and all liability for any losses, or modification, copying or reverse engineering.

6. Renesas Electronics products are classified according to the following two quality grades: “Standard” and “High Quality”. The intended applications for each Renesas Electronics product depend on the product’s quality grade, as indicated below.
   - “Standard”: Computers; office equipment; communications equipment; test and measurement equipment; audio and visual equipment; home electronic appliances; machine tools; personal electronic equipment; industrial robots; etc.
   - “High Quality”: Transportation equipment (automobiles, trains, ships, etc.); traffic control (traffic lights); large-scale communication equipment; key financial terminal systems; safety control equipment; etc.

7. No semiconductor product is absolutely secure. Notwithstanding any security measures or features that may be implemented in Renesas Electronics hardware or software products, Renesas Electronics shall have absolutely no liability arising out of any vulnerability or security breach, including but not limited to any unauthorized access to or use of a Renesas Electronics product or a system that uses a Renesas Electronics product. Renesas ELECTRONICS DOES NOT WARRANT OR GUARANTEE THAT RENESAS ELECTRONICS PRODUCTS, OR ANY SYSTEMS CREATED USING RENESAS ELECTRONICS PRODUCTS WILL BE INNUVULNERABLE OR FREE FROM CORRUPTION, ATTACK, VIRUSES, INTERFERENCE, HACKING, DATA LOSS OR THEFT, OR OTHER SECURITY INTRUSION (“Vulnerability Issues”). RENESAS ELECTRONICS DISCLAIMS ANY AND ALL RESPONSIBILITY OR LIABILITY ARISING FROM OR RELATED TO ANY VULNERABILITY ISSUES. FURTHERMORE, TO THE EXTENT PERMITTED BY APPLICABLE LAW, RENESAS ELECTRONICS DISCLAIMS ANY AND ALL WARRANTIES, EXPRESS OR IMPLIED, WITH RESPECT TO THIS DOCUMENT AND ANY RELATED OR ACCOMPANYING SOFTWARE OR HARDWARE, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, OR FITNESS FOR A PARTICULAR PURPOSE.

8. When using Renesas Electronics products, refer to the latest product information (data sheets, user’s manuals, application notes, "General Notes for Handling and Using Semiconductor Devices" in the reliability handbook, etc.), and ensure that usage conditions are within the ranges specified by Renesas Electronics with respect to maximum ratings, operating power supply voltage range, heat dissipation characteristics, installation, etc. Renesas Electronics disclaims any and all liability for any malfunctions, failure or accident arising out of the use of Renesas Electronics products outside of such specified ranges.

9. Although Renesas Electronics endeavors to improve the quality and reliability of Renesas Electronics products, semiconductor products have specific characteristics, such as the occurrence of failure at a certain rate and malfunctions under certain use conditions. Unless designated as a high reliability product or a product for harsh environments in a Renesas Electronics data sheet or other Renesas Electronics document, Renesas Electronics products are not intended or authorized for use in products or systems that may pose a direct threat to human life or bodily injury (artificial life support devices or systems; surgical implantations; etc.), or may cause serious property damage (space systems; underwater repeaters; nuclear power control systems; aircraft control systems; key plant systems; military equipment; etc.). Renesas Electronics disclaims any and all liability for any damages or losses incurred by you or any third parties arising from the use of any Renesas Electronics product that is inconsistent with any Renesas Electronics data sheet, user’s manual or other Renesas Electronics document.

10. Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental compatibility of each Renesas Electronics product. You are responsible for carefully and sufficiently investigating applicable laws and regulations that regulate the inclusion or use of controlled substances, including without limitation, the EU RoHS Directive, and using Renesas Electronics products in compliance with all these applicable laws and regulations. Renesas Electronics disclaims any and all liability for damages or losses occurring as a result of your noncompliance with applicable laws and regulations.

11. Renesas Electronics products and technologies shall not be used for or incorporated into any products or systems whose manufacture, use, or sale is prohibited under any applicable domestic or foreign laws or regulations. You shall comply with any applicable export control laws and regulations promulgated and administered by the governments of any countries asserting jurisdiction over the parties or transactions.

12. It is the responsibility of the buyer or distributor of Renesas Electronics products, or any other party who distributes, disposes of, or otherwise sells or transfers the product to a third party, to notify such third party in advance of the contents and conditions set forth in this document.

13. This document shall not be reprinted, reproduced or duplicated in any form, in whole or in part, without prior written consent of Renesas Electronics.

Corporate Headquarters
TOYOSU FORESIA, 3-2-24 Toyosu,
Koto-ku, Tokyo 135-0061, Japan
www.renesas.com

Contact information
For further information on a product, technology, the most up-to-date version of a document, or your nearest sales office, please visit: www.renesas.com/contact/

Trademarks
Renesas and the Renesas logo are trademarks of Renesas Electronics Corporation. All trademarks and registered trademarks are the property of their respective owners.

© 2021 Renesas Electronics Corporation. All rights reserved.