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Introduction

The purpose of this Application Note is to show the user how to add the associated RL78/G13 sample code to a new or
existing IAR Embedded Workbench workspace; as well as give an explanation of what the sample code does.

The sample code provided with this Application Note demonstrates usage of the 12C Interface in Master Mode. The
program runs on the RL78/G13 RSK and demonstrates usage of the 12C interface in Master Mode, by reading and
writing to an EEPROM device.

Target Device

RL78/G13
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RL78/G13 Utilising 12C in Master Mode (Using IAR Toolchain)

1. Installation

This section assumes IAR Embedded Workbench (IAR EW) IDE is already installed on the user’s personal computer
(PC). Create a new folder and name it as ‘RSKRL78G13_Workspace’. Copy the zipped file IIC_MASTER.zip,
available in the Application Note package downloaded from the website, to this folder. Extract the IC_MASTER.zip
file to the RSKRL78G13_Workspace folder.

2. Creating the Project Workspace

Run IAR Embedded Workbench IDE by clicking the Windows Start button, select All Programs > IAR Systems > IAR
Embedded Workbench for Renesas RL78 1.10. This will automatically open IAR Information Centre for RL78.
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From the menu bar select File > New > Workspace as shown below:
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IAR EW will open an empty workspace.
To add the sample code select ‘Project > Add Existing Project’” from the menu bar as hown below:
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A new window titled ‘Add Existing Project to Current Workspace’ will appear. Navigate to the
RSKRL78G13 Workspace folder and open the 1IC_MASTER folder. Locate the IAR EW project file
IIC_MASTER.ewp. Single-click the project file to select it. Click the < Open > button on the ‘Add Existing Project to
Current Workspace’window to add the project to the workspace.

Save the workspace by selecting File > Save Workspace
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A ‘Save Workspace As’ window will appear. Open the ‘RSKRL78G13_Workspace’ folder from within the window’s
view and specify the ‘File name’.
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Save the workspace by selecting File > Save Workspace.

Note:

If a workspace already exists, open the workspace. Add the sample code project by selecting ‘Project > Add Existing
Project...” from the menu bar. Locate the IIC_MASTER.ewp file and double click on the file’s name to add to the

workspace. Save the workspace.
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3. Opening Sample Code and Source Files

Once the project has been added, the source code and all dependant files can be opened in the editor by expanding the
folders in the Workspace window and double clicking the files in the folders.
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Each source file listed in Workspace window in IAR EW can be expanded to reveal its dependant files ; as well as the
output files.

4. Source Code

The source code project is specifically written to run on the appropriate RSK. However this source code can be useful
as an example even without the RSK.

The project was written using source files containing API functions generated using Applilet. The project will contain a
C source file ‘r_main.c’. This source file will include the C function main(). All source files and dependant files whose
filenames are prefixed with ‘r_’ were generated using Applilet.

5. Code Execution
This sample code requires an external 5V regulated power supply.

Works with the Renesas R1IEX24xxx series, 16Kbit EEPROM and compatible devices. The EEPROM device should be
in a circuit recommended by the manufacturer to ensure it is operational. By default, the project is configured to work
with another RSKRL78/G13 running the slave program. The user can select the appropriate slave device by the
inclusion or exclusion of the macro definition '#define SLAVE_RL78/G13, which is found in the r_cg_userdefine.h
header file.

1. Connect the 5V regulated power supply.
2. Build and download the sample code to the RSK.
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3. Connect a compatible EEPROM memory device as follows:
EEPROM | RSK

SDA -> SDA (JAL, pin 25)
SCL -> SCL (JA1, pin 26)
GND -> Any ground point.

4. Click 'Go’ to start the program execution. The name of the sample will by displayed on the debug LCD.

5. Press switch SW1 to perform a write operation. If the write is successful, the data written will be displayed on the
debug LCD. Repress SW1 to do another write.

6. Press switch SW3 to perform a read operation. If the read is successful, the data read will be displayed on the debug
LCD. Repress SW3 to repeat the read instruction.

7. Press SW2 to recall the last data written to the EEPROM slave device.

8. If data written and data read differ, information will be displayed on the debug LCD to inform of this occurrence. A
write operation should always precede a read operation. If the first operation carried out is a read operation, the debug
LCD will ask the user to press SW1 followed by a press on SW3.

Note: In the case of the RSKRL78/G13 becoming unresponsive, stop the sample and disconnect power to the RSK,
recheck the EEPROM connections, then reconnect power and start from step 1 again.

6. Website, Inquiries and Support

Renesas Electronics Website
http://www.renesas.com/
Inquiries
http://www.renesas.com/inquiry
Support
http://www.renesas.com/rskrl78g13
All trademarks and registered trademarks are the property of their respective owners.
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General Precautions in the Handling of MPU/MCU Products

The following usage notes are applicable to all MPU/MCU products from Renesas. For detailed usage notes on the
products covered by this manual, refer to the relevant sections of the manual. If the descriptions under General
Precautions in the Handling of MPU/MCU Products and in the body of the manual differ from each other, the
description in the body of the manual takes precedence.

1.

Handling of Unused Pins

Handle unused pins in accord with the directions given under Handling of Unused Pins in the manual.

— The input pins of CMOS products are generally in the high-impedance state. In operation with an
unused pin in the open-circuit state, extra electromagnetic noise is induced in the vicinity of LSI, an
associated shoot-through current flows internally, and malfunctions occur due to the false
recognition of the pin state as an input signal become possible. Unused pins should be handled as
described under Handling of Unused Pins in the manual.

Processing at Power-on

The state of the product is undefined at the moment when power is supplied.

— The states of internal circuits in the LSI are indeterminate and the states of register settings and
pins are undefined at the moment when power is supplied.

In a finished product where the reset signal is applied to the external reset pin, the states of pins
are not guaranteed from the moment when power is supplied until the reset process is completed.
In a similar way, the states of pins in a product that is reset by an on-chip power-on reset function
are not guaranteed from the moment when power is supplied until the power reaches the level at
which resetting has been specified.

Prohibition of Access to Reserved Addresses

Access to reserved addresses is prohibited.

— The reserved addresses are provided for the possible future expansion of functions. Do not access
these addresses; the correct operation of LSl is not guaranteed if they are accessed.

Clock Signals

After applying a reset, only release the reset line after the operating clock signal has become stable.

When switching the clock signal during program execution, wait until the target clock signal has

stabilized.

— When the clock signal is generated with an external resonator (or from an external oscillator)
during a reset, ensure that the reset line is only released after full stabilization of the clock signal.
Moreover, when switching to a clock signal produced with an external resonator (or by an external
oscillator) while program execution is in progress, wait until the target clock signal is stable.

Differences between Products

Before changing from one product to another, i.e. to one with a different type number, confirm that the

change will not lead to problems.

— The characteristics of MPU/MCU in the same group but having different type numbers may differ
because of the differences in internal memory capacity and layout pattern. When changing to
products of different type numbers, implement a system-evaluation test for each of the products.




Notice

1. All information included in this document is current as of the date this document is issued. Such information, however, is subject to change without any prior notice. Before purchasing or using any Renesas
Electronics products listed herein, please confirm the latest product information with a Renesas Electronics sales office. Also, please pay regular and careful attention to additional and different information to
be disclosed by Renesas Electronics such as that disclosed through our website.

2. Renesas Electronics does not assume any liability for infringement of patents, copyrights, or other intellectual property rights of third parties by or arising from the use of Renesas Electronics products or
technical information described in this document. No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights of Renesas Electronics or
others.

3. You should not alter, modify, copy, or otherwise misappropriate any Renesas Electronics product, whether in whole or in part.

4. Descriptions of circuits, software and other related information in this document are provided only to illustrate the ion of i ictor products and icati You are fully responsible for

the incorporation of these circuits, software, and information in the design of your equipment. Renesas Electronics assumes no responsibility for any losses incurred by you or third parties arising from the
use of these circuits, software, or information.

5. When exporting the products or technology described in this document, you should comply with the applicable export control laws and regulations and follow the procedures required by such laws and
regulations. You should not use Renesas Electronics products or the technology described in this document for any purpose relating to military applications or use by the military, including but not limited to

the development of weapons of mass destruction. Renesas Electronics products and technology may not be used for or incorporated into any products or systems whose manufacture, use, or sale is

prohil under any i domestic or foreign laws or regulations.

6. Renesas Electronics has used reasonable care in preparing the information included in this document, but Renesas Electronics does not warrant that such information is error free. Renesas Electronics
assumes no liability whatsoever for any damages incurred by you resulting from errors in or omissions from the information included herein.

7. Renesas Electronics products are classified according to the following three quality grades: "Standard", "High Quality", and "Specific". The recommended applications for each Renesas Electronics product
depends on the product's quality grade, as indicated below. You must check the quality grade of each Renesas Electronics product before using it in a particular application. You may not use any Renesas
Electronics product for any application categorized as "Specific” without the prior written consent of Renesas Electronics. Further, you may not use any Renesas Electronics product for any application for
which it is not intended without the prior written consent of Renesas Electronics. Renesas Electronics shall not be in any way liable for any damages or losses incurred by you or third parties arising from the
use of any Renesas Electronics product for an application categorized as "Specific” or for which the product is not intended where you have failed to obtain the prior written consent of Renesas Electronics.
The quality grade of each Renesas Electronics product is "Standard" unless otherwise expressly specified in a Renesas Electronics data sheets or data books, etc.

"Standard": Computers; office equipment; communications i ; test and measurement i ; audio and visual equipment; home electronic appliances; machine tools;

personal electronic equipment; and industrial robots.

"High Quality": Transportation equipment (automobiles, trains, ships, etc.); traffic control systems; anti-disaster systems; anti-crime systems; safety equipment; and medical equipment not specifically
designed for life support.

"Specific": Aircraft; aerospace equipment; submersible repeaters; nuclear reactor control systems; medical equipment or systems for life support (e.g. artificial life support devices or systems), surgical
implantations, or healthcare intervention (e.g. excision, etc.), and any other applications or purposes that pose a direct threat to human life.

8. You should use the Renesas Electronics products described in this document within the range specified by Renesas Electronics, especially with respect to the maximum rating, operating supply voltage
range, movement power voltage range, heat radiation characteristics, installation and other product characteristics. Renesas Electronics shall have no liability for malfunctions or damages arising out of the
use of Renesas Electronics products beyond such specified ranges.

9. Although Renesas Electronics endeavors to improve the quality and reliability of its products, semiconductor products have specific characteristics such as the occurrence of failure at a certain rate and
malfunctions under certain use conditions. Further, Renesas Electronics products are not subject to radiation resistance design. Please be sure to implement safety measures to guard them against the
possibility of physical injury, and injury or damage caused by fire in the event of the failure of a Renesas Electronics product, such as safety design for hardware and software including but not limited to
redundancy, fire control and malfunction prevention, appropriate treatment for aging degradation or any other appropriate measures. Because the evaluation of microcomputer software alone is very difficult,
please evaluate the safety of the final products or system manufactured by you.

10. Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental compatibility of each Renesas Electronics product. Please use Renesas Electronics
products in compliance with all applicable laws and regulations that regulate the inclusion or use of controlled substances, including without limitation, the EU RoHS Directive. Renesas Electronics assumes
no liability for damages or losses occurring as a result of your noncompliance with applicable laws and regulations.

11. This document may not be reproduced or duplicated, in any form, in whole or in part, without prior written consent of Renesas Electronics.

12. Please contact a Renesas Electronics sales office if you have any questions regarding the information contained in this document or Renesas Electronics products, or if you have any other inquiries.

(Note 1) "Renesas Electronics" as used in this document means Renesas Electronics Corporation and also includes its majority-owned subsidiaries.

(Note 2) "Renesas Electronics product(s)" means any product developed or manufactured by or for Renesas Electronics.
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