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RL78 Family 
How to change devices in the sample project for the DSP Library and the Security Library 

Introduction 
This document describes the procedures for migrating the driver and middleware sample code projects 
shown in the table below to other RL78 family devices. 

Table 1. Target driver and middleware 

Category Driver and Middleware Name Document Number Target Device 
DSP Library RL78 Family RL78 Digital Signal Controller 

Library - Filter Note1 
R01AN1665 RL78/G16 

RL78/G22 

RL78/G24 

RL78/L23 

RL78 Family FFT Library Note1 R20AN0150 RL78/G16 
RL78/G22 
RL78/G24 

RL78/L23 
Security Library RL78 Family AES Library R20AN0151 RL78/G16 

RL78/G22 
RL78/G24 
RL78/L23 

RL78 Family RSA Library R20AN0326 RL78/G24 
RL78/L23 

RL78 Family SHA Hash Function Library R20AN0211 RL78/G15 
RL78/G16 
RL78/G22 
RL78/G24 
RL78/L23 

RL78/G23 Unique ID Read Driver R20AN0615 RL78/G22 
RL78/G24 
RL78/L23 

RL78 Family True Random Number 
Generator (TRNG) Software Driver 

R20AN0617 RL78/G22 
RL78/G24 
RL78/L23 

Notes: 1. When changing a sample project to a different device, use a sample project from a device that 
belongs to the same CPU core category as the target device.  
 - S2 Core : When changing to RL78/G16, use a sample project for RL78/G15. 
 - S3 Core : When changing to RL78/G22, RL78/G24, or RL78/L23, use a sample project for 
RL78/G23. 
For more information on CPU core classification, please refer to the following document. 
 - RL78 Family User’s Manual: Software (R01US0015) 

 
The sample code included in the migration source project may not be usable as is because the ROM/RAM 
capacity of the migration destination device is not sufficient. In such cases, please change the sample code 
to fit into the ROM/RAM capacity of the migration destination device. See "2.1 Sample Code Size 
Adjustment" for an example of changing sample codes. 
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Target Device 
RL78/G15, RL78/G16, RL78/G22, RL78/G24, RL78/L23 

When using this application note with other Renesas devices, careful evaluation is recommended after 
making modifications to comply with the alternate devices. 

 

The versions of the development tools used in reviewing the procedures in this document are as follows. 
 

RL78/G15 

• CS+ for CC V8.14.00 
• e2 studio 2025-12 
• CC-RL V1.15.01 
• LLVM for Renesas RL78 17.0.1.202512 
• IAR Embedded Workbench for Renesas RL78 version 5.20.2 
• IAR C/C++ Compiler for Renesas RL78 : 5.20.2.2949 
• Smart Configurator for RL78 V1.15.0 
 

RL78/G16 

• CS+ for CC V8.14.00 
• e2 studio 2025-12 
• CC-RL V1.15.01 
• LLVM for Renesas RL78 17.0.1.202512 
• IAR Embedded Workbench for Renesas RL78 version 5.20.2 
• IAR C/C++ Compiler for Renesas RL78 : 5.20.2.2949 
• Smart Configurator for RL78 V1.15.0 
 

RL78/G22 

• CS+ for CC V8.14.00 
• e2 studio 2025-12 
• CC-RL V1.15.01 
• LLVM for Renesas RL78 17.0.1.202512 
• IAR Embedded Workbench for Renesas RL78 version 5.20.2 
• IAR C/C++ Compiler for Renesas RL78 : 5.20.2.2949 
• Smart Configurator for RL78 V1.15.0 
 

RL78/G24(DSP Libraries) 

• CS+ for CC V8.14.00 
• e2 studio 2025-12 
• CC-RL V1.15.01 
• LLVM for Renesas RL78 17.0.1.202512 
• IAR Embedded Workbench for Renesas RL78 version 5.20.2 
• IAR C/C++ Compiler for Renesas RL78 : 5.20.2.2949 
• Smart Configurator for RL78 V1.15.0 
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RL78/G24(Security Libraries) 

• CS+ for CC V8.09.00 
• e2 studio 2023-04 
• CC-RL V1.12.00 
• LLVM for Renesas RL78 10.0.0.202306 
• IAR Embedded Workbench for Renesas RL78 version 4.21.4 
• IAR C/C++ Compiler for Renesas RL78 : 4.21.1.2409 
• Smart Configurator for RL78 V1.6.0 
 

RL78/L23 

• CS+ for CC V8.14.00 
• e2 studio 2025-12 
• CC-RL V1.15.01 
• LLVM for Renesas RL78 17.0.1.202512 
• IAR Embedded Workbench for Renesas RL78 version 5.20.2 
• IAR C/C++ Compiler for Renesas RL78 : 5.20.2.2949 
• Smart Configurator for RL78 V1.15.0 
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1. Project Migration Procedure 
Describes how to use each IDE's features to migrate a sample code project created for a specific RL78 
family device to other RL78 family devices. 

Open a migration source project in each IDE and change the device. Change source code, build settings, 
and debug settings according to the changed device. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 1-1   Project Migration Procedure 
  

 

Device dependent changes 

CS+ for CC: See”1.1.1 Opening a migration source project” 

e2 studio: See”1.2.1 Importing a migration source project” 

IAR Embedded Workbench for Renesas RL78: 

See”1.3.1 Opening a migration source project” 

 

Opening a migration source project 

Changing the device 

CS+ for CC: See”1.1.2 Changing the device” 

e2 studio: See”1.2.2 Changing the device” 

IAR Embedded Workbench for Renesas RL78: 

See”1.3.2 Changing the device” 

 

CS+ for CC: See”1.1.3 Device dependent changes” 

e2 studio: See”1.2.3 Device dependent changes” 

IAR Embedded Workbench for Renesas RL78: 

See”1.3.3 Device dependent changes” 
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1.1 CS+ for CC 
Use the [Change Microcontroller] function to change the device. 

If necessary, make a backup by manually copying a folder containing a migration source project file(.mtpj). 

 

1.1.1 Opening a migration source project 
 

(1) Click [Project] -> [Open Project] to display the Explorer for selecting a project file. 

 

Figure 1-2   Opening a migration source project (1/2) 
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(2) In the Explorer that appears, select a migration source project file and click [Open] to open the project. 

 

Figure 1-3   Opening a migration source project (2/2) 
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1.1.2 Changing the device 
 

(1) Right-click on the Microcontroller item in the project tree and click [Change Microcontroller]. 

 

Figure 1-4   Changing the device (1/4) 
 

(2) The message dialog appears confirming the project overwrite. Click [OK] to overwrite the migration 
source project. 

 

Figure 1-5   Changing the device (2/4) 
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(3) After the migration source project is overwritten and saved, the Change Microcontroller dialog appears. 
Select the migration destination device (in this example, explained in R5F12068xSP) and click [OK]. 

 

Figure 1-6   Changing the device (3/4) 
 
(4) Confirm that the Microcontroller item in the project tree has been changed to the migration destination 

device. 

 

Figure 1-7   Changing the device (4/4) 
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1.1.3 Device dependent changes 
Change the source code and debug settings depending on the device. 

Change the debug settings according to the operating environment. 

For information on how to configure debug settings, please refer to the following document. 

 CS+ Integrated Development Environment User’s Manual: RL78 Debug Tool (R20UT5136) 
 

When using the Smart Configurator, refer to section 2.2, “Smart Configurator Change Procedure,” to 
generate source code. 
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1.2 e2 studio 
Use the MCU migration feature to change the device. 

If necessary, make a backup by manually copying a folder containing a migration source project file. 

 

1.2.1 Importing a migration source project 
Import a migration source project into the migration destination workspace. If necessary, specify a new 
workspace directory or switch a workspace. 

 

(1) Click [File] -> [Import] to open the project import window. 

 

Figure 1-8   Importing a migration source project (1/4) 
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(2) Select [General] -> [Existing Project to Workspace] and click [Next] to proceed to the next screen. 

 

Figure 1-9   Importing a migration source project (2/4) 
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(3) Select a migration source project and import it into the workspace. 
Click [Browse] and select a migration source project folder. 
Confirm that the migration source project is selected and click [Finish]. 

 

Figure 1-10   Importing a migration source project (3/4) 
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(4) Confirm that the migration source project has been imported into the workspace. 

 

Figure 1-11   Importing a migration source project (4/4) 
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1.2.2 Changing the device 
 
(1) Select the project and click [Project] -> [Change Device] to display the device change screen. 

 

Figure 1-12   Changing the device (1/5) 
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(2) Click the button to the right of [Target Device] and select the migration destination device (in this 
example, explained in R5F12068xSP). 
Click [Next] to proceed to the next screen. 

 

Figure 1-13   Changing the device (2/5) 
  



RL78 Family  
How to change devices in the sample project for the DSP Library and the Security Library 

R01AN6716EJ0105  Rev.1.05  Page 17 of 39 
Dec.22,25  

(3) You may be warned to back up your project, as changes to the device cannot be undone. If necessary, 
make a backup by manually copying a folder containing a migration source project file. 
Click [Next] to proceed to the next screen. 

 

Figure 1-14   Changing the device (3/5) 
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(3-1) If the toolchain used in the migration source project is not registered, an error will occur. 
To resolve the error, you need to either register the version of that toolchain or change the toolchain used 
in the migration source project. 
This section explains how to change the toolchain used in the migration source project. 
Click [Cancel].  
If no error occurs, proceed to step (4).  

 

Figure 1-15 Changing the Toolchain (1/5) 
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(3-2) Click [Project] → [Change Toolchain Version] to open the Change Toolchain Version screen. 

 

Figure 1-16 Changing the Toolchain (2/5) 
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(3-3) Select the registered toolchain in [Toolchain Version]. 
Click [Next] to proceed to the next screen.  

 

Figure 1-17 Changing the Toolchain (3/5) 
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(3-4) Since the change of toolchain version cannot be undone, a warning will appear prompting you to back 
up the project. 
If necessary, manually copy the folder containing the migration source project file to create a backup. 
Click [Next] to proceed to the next screen. 

 

Figure 1-18 Changing the Toolchain (4/5) 
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(3-5) The changes made to the project will be displayed. 
Click [Finish]. 
Please perform the device change again from “1.2.2 Changing the device” 

 

Figure 1-19 Changing the Toolchain (5/5) 
 
 
 
  



RL78 Family  
How to change devices in the sample project for the DSP Library and the Security Library 

R01AN6716EJ0105  Rev.1.05  Page 23 of 39 
Dec.22,25  

(4) Project changes is displayed. Click [Finish]. 

 

Figure 1-20 Changing the device (4/5) 
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(5) Open the project properties (right click on the project -> [Properties]) and confirm that [Current Device] 
under [C/C++ Build] -> [Settings] -> [Device] has been changed to the migration destination device. 

 

Figure 1-21 Changing the device (5/5) 
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1.2.3 Device dependent changes 
Change the source code and debug settings depending on the device. 

Change the debug settings according to the operating environment. 

For information on how to configure debug settings, please refer to the following document. 

 e2 studio Integrated Development Environment User’s Manual: Getting Started Guide (R20UT4819) 
 

When using the Smart Configurator, refer to section 2.2, “Smart Configurator Change Procedure,” to 
generate source code. 
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1.2.4 Migration of LLVM Projects 
When migrating an LLVM project, you may encounter link errors after building. In such cases, please modify 
the linker_script.ld file. 

 
1.2.4.1 Handling Link Errors (rodata Section)  

After migrating to a new device, the following link errors may occur during the linking process: 
 
ld.lld: error: Error: rodata section start address is too large. 
Move the text section after the rodata section to ensure that correct data is added to the MIRROR  
area. 
 
ld.lld: error: Error: rodata section size exceeds length of the MIRROR area. 
These errors are caused by the .rodata section exceeding the size or placement constraints of the 
MIRROR area. You can avoid this by placing the .text section after the .rodata section. This ensures 
that the contents of .rodata fit correctly within the MIRROR area, preventing link errors. 
 

Below is an example of how to modify the .text section—move it to follow the .rodata section. 
 
 

 

 

 

 

 

 

 

 

 

 

Figure 1-22 Example of .text Section Placement After .rodata 
 
 
 
  

 .rodata MAX(., (CONSTANT(MIRRORAREASTART)+0x3000)): 

{ 

  // content omitted 

} >ROM 

 

.text (. + __romdatacopysize):  
{ 
  // content omitted 
} >ROM AT>ROM 
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1.2.4.2 Handling Memory Overlap Errors Between .data and .ocd_traceram Sections 

After migrating to a new device, the following link error may occur during the linking process. 
(Note: The addresses shown in the error are examples.) 

 

ld.lld: error: section .data virtual address range overlaps with .ocd_traceram 
>>> .data range is [0xF7F00, 0xF88B5] 
>>> .ocd_traceram range is [0xF8300, 0xF86FF] 
 

This error occurs because the .data section and the .ocd_traceram section are placed in the same RAM 
area.To resolve this error, change the starting address of the .ocd_traceram section so that it does not 
overlap with the .data section. 
Below is an example of changing the starting address of the .ocd_traceram section from 0xF8300 to 
0xFBF00. 

 

 

 

 

 

 

Figure 1-23 Example of Changing the Starting Address of the .ocd_traceram Section 

  

 
.ocd_traceram 0xFBF00 (NOLOAD) : 

{ 

 KEEP(*(.ocd_traceram)) 

} >RAM 
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1.3 IAR Embedded Workbench for Renesas RL78 
Change the device in the project options settings. 

If necessary, make a backup by manually copying a folder containing a migration source project file(.ewp). 

 

1.3.1 Opening a migration source project 
 
(1) Click [Project] -> [Add Existing Project] to display the Explorer for selecting a project file. 

 

Figure 1-24   Opening a migration source project (1/2) 
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(2) In the Explorer that appears, select a migration source project file, and click [Open] to open the project. 

 

Figure 1-25   Opening a migration source project (2/2) 
 

If the following screen appears when opening a project, click [Yes]. 

 

Figure 1-26   Confirmation of project file conversion 
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1.3.2 Changing the device 
 

(1) Right-click on the project and click [Options] to open the options screen. 

 

Figure 1-27   Changing the device (1/2) 
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(2) Open [General Options] -> [Target] and click the button to the right of [Device] to select the migration 
destination device (in this example, explained in [RL78 - R5F12068]). 
Confirm that the migration destination device is selected and click [OK]. 

 

Figure 1-28   Changing the device (2/2) 
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1.3.3 Device dependent changes 
Change source code, build settings, and debug settings depending on the device. 

If the sample project does not use the Smart Configurator, step (1) is not necessary. 

 

(1) Changing source code 
Refer to "1.3.4 Smart Configurator Settings" to generate source code. 

 
(2) Changing build settings 

Change the stack size according to the migration destination device. 
On the options screen, open [General Options] -> [Stack/Heap] and change the [Stack size (bytes)]. 

 

Figure 1-29   Change stack size 

 
(3) Changing debug settings 

Change the debug settings according to the operating environment. 
For more information on how to configure debug settings, please refer to the relevant documentation from 
IAR. 
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1.3.4 Smart Configurator Settings 
This procedure is only necessary when migrating a project that uses the Smart Configurator. 

When the Smart Configurator opens the configuration file(.scfg) of a migration source project and generates 
the source code, the project is overwritten to the newly created state. Therefore, a new configuration file for 
the migration destination device must be created and manually linked to the project. 
 
(1) Create a configuration file for the migration destination device in the Smart Configurator. 

See "2.2 Smart Configurator Change Procedure" for details on Smart Configurator settings. 
 
(2) Delete the Renesas_SC folder and the IAR project connection file(.ipcf) from the project. 

 

Figure 1-30   Smart Configurator Settings (1/5) 
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(3) Open the project folder in Explorer and replace the src\smc_gen folder with the one generated in step (1). 

 

Figure 1-31   Smart Configurator Settings (2/5) 
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(4) Link the project to the configuration file created in step (1). 
 

(4)-1 Click [Project] -> [Add Project Connection] to display the Add Project Connection screen. 

 

Figure 1-32   Smart Configurator Settings (3/5) 
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(4)-2 Select [IAR Project Connection]. Click [OK] to open the Explorer for IAR project connection file 
selection. 

 

Figure 1-33   Smart Configurator Settings (4/5) 
 

(4)-3 In the Explorer that appears, select the IAR project connection file(.ipcf) generated in step (1) and 
click [Open]. 
Make sure that the Renesas_SC folder and the IAR project connection file(.ipcf) are added to the 
project. 

 

Figure 1-34   Smart Configurator Settings (5/5) 
 
(5) To configure the settings for "RL78 Family True Random Number Generator (TRNG) Software Driver", 

make the following changes. 
 

Refer to Config_UART0.c and Config_UART0.h in the src\smc_gen\Config_UART0 folder of the migration 
source project and add the declaration and definition of the putchar and send functions to any source 
files. 
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2. Appendix 
2.1 Sample Code Size Adjustment 
The sample code included in the migration source project may not be usable as is because the ROM/RAM 
capacity of the migration destination device is not sufficient. In such cases, please change the sample code 
to fit into the ROM/RAM capacity of the migration destination device. 

Examples can be adjusted in the following ways. 

• Leave only the functions you want to check in the sample code. 
• Increase the level of compiler optimization. 
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2.2 Smart Configurator Change Procedure 
If your project uses the Smart Configurator, make the following changes in the Smart Configurator. 

 

Please refer to the following document for detailed Smart Configurator operation procedures. 

• RL78 Smart Configurator User's Guide: CS+ (R20AN0580) 
• RL78 Smart Configurator User's Guide: e² studio (R20AN0579) 
• RL78 Smart Configurator User’s Guide: IAREW (R20AN0581) 
 

(1) Change the device selected on the [Board] page to the migration destination device. 
 
(2) Change the settings on the [Clocks] and [System] pages according to the debugging environment. 
 
Note: When configuring RL78/G15 or RL78/G16 group devices, select a value lower than or equal to the 

supply voltage of the operating environment for the [Reset generation level(VSDR)] on the [System] 
page. 

 

Figure 2-1   Reset generation level(VSDR) setting 
 

(3) To configure settings for "RL78/G23 Unique ID Read Driver" and "RL78 Family True Random Number 
Generator (TRNG) Software Driver" for IAR Embedded Workbench for Renesas RL78, please add UART 
communication components on the [Components] page. For details on UART communication component 
settings, please refer to the application notes for the respective middleware. 

 
(4) On the [Components] page, change the version of the BSP SIS module (r_bsp component) to the version 

corresponding to the migration destination device. 
 
(5) Generate source code. 
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Revision History 
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• Added middleware category to Table 1. 
• Added RL78/G22 to the Target Device. 

28 1.3.4 Smart Configurator Settings 
Added procedures for configuring settings for the "RL78 
Family True Random Number Generator (TRNG) Software 
Driver". 

30 2.2 Smart Configurator Change Procedure 
Added procedures for configuring settings for "RL78/G23 
Unique ID Read Driver" and "RL78 Family True Random 
Number Generator (TRNG) Software Driver" for IAR 
Embedded Workbench for Renesas RL78. 

1.02 Jun 05, 2023 - Added RL78/G16 to the Target Device. 
1.03 Aug 01, 2023 - Added RL78/G24 to the Target Device. 
1.04 Jun 02, 2025 - Added RL78/L23 to the Target Device. 

10 1.1.3.2 When Smart Configurator Is Not Used 
Added procedures for projects that do not use Smart 
Configurator. 

12 1.2 Change backup method. 

14 1.2.1 Correct step (3). 

19 Added Handling When Toolchain Is Not Registered in Source 
Project 

26 1.2.3.2 When Smart Configurator Is Not Used 
Added procedures for projects that do not use Smart 
Configurator. 

27 1.2.4 When Migrating LLVM Projects 
Added handling methods for the following two cases in LLVM 
sample projects: 
1.2.4.1 Handling Link Errors (rodata section) 
1.2.4.2 Handling Memory Overlap Errors Between .data 

Section and .ocd_traceram 
1.05 Dec. 22, 2025 - Added RL78/G24 to the target devices for the DSP Libraries. 

1 Remove Note 2 from Table 1. 
Updated Note 1. 

3, 4 Updated development tools for the target devices (RL78/G15, 
RL78/G16, RL78/G22, RL78/L23). 
Updated the target devices to list RL78/G24 separately for the 
DSP Libraries and the Security Libraries. 

10 1.1.3.2 When Smart Configurator Is Not Used 
Deleted procedures for projects that do not use Smart 
Configurator. 

25 1.2.3.2 When Smart Configurator Is Not Used 
Deleted procedures for projects that do not use Smart 
Configurator. 

 



 

 

General Precautions in the Handling of Microprocessing Unit and Microcontroller 
Unit Products 
The following usage notes are applicable to all Microprocessing unit and Microcontroller unit products from Renesas. For detailed usage notes on the 
products covered by this document, refer to the relevant sections of the document as well as any technical updates that have been issued for the products. 

1. Precaution against Electrostatic Discharge (ESD) 

A strong electrical field, when exposed to a CMOS device, can cause destruction of the gate oxide and ultimately degrade the device operation. Steps 

must be taken to stop the generation of static electricity as much as possible, and quickly dissipate it when it occurs. Environmental control must be 

adequate. When it is dry, a humidifier should be used. This is recommended to avoid using insulators that can easily build up static electricity. 

Semiconductor devices must be stored and transported in an anti-static container, static shielding bag or conductive material. All test and 

measurement tools including work benches and floors must be grounded. The operator must also be grounded using a wrist strap. Semiconductor 

devices must not be touched with bare hands. Similar precautions must be taken for printed circuit boards with mounted semiconductor devices. 
2. Processing at power-on 

The state of the product is undefined at the time when power is supplied. The states of internal circuits in the LSI are indeterminate and the states of 

register settings and pins are undefined at the time when power is supplied. In a finished product where the reset signal is applied to the external reset 

pin, the states of pins are not guaranteed from the time when power is supplied until the reset process is completed. In a similar way, the states of pins 

in a product that is reset by an on-chip power-on reset function are not guaranteed from the time when power is supplied until the power reaches the 

level at which resetting is specified. 
3. Input of signal during power-off state 

Do not input signals or an I/O pull-up power supply while the device is powered off. The current injection that results from input of such a signal or I/O 

pull-up power supply may cause malfunction and the abnormal current that passes in the device at this time may cause degradation of internal 

elements. Follow the guideline for input signal during power-off state as described in your product documentation. 
4. Handling of unused pins 

Handle unused pins in accordance with the directions given under handling of unused pins in the manual. The input pins of CMOS products are 

generally in the high-impedance state. In operation with an unused pin in the open-circuit state, extra electromagnetic noise is induced in the vicinity of 

the LSI, an associated shoot-through current flows internally, and malfunctions occur due to the false recognition of the pin state as an input signal 

become possible. 
5. Clock signals 

After applying a reset, only release the reset line after the operating clock signal becomes stable. When switching the clock signal during program 

execution, wait until the target clock signal is stabilized. When the clock signal is generated with an external resonator or from an external oscillator 

during a reset, ensure that the reset line is only released after full stabilization of the clock signal. Additionally, when switching to a clock signal 

produced with an external resonator or by an external oscillator while program execution is in progress, wait until the target clock signal is stable. 
6. Voltage application waveform at input pin 

Waveform distortion due to input noise or a reflected wave may cause malfunction. If the input of the CMOS device stays in the area between VIL 

(Max.) and VIH (Min.) due to noise, for example, the device may malfunction. Take care to prevent chattering noise from entering the device when the 

input level is fixed, and also in the transition period when the input level passes through the area between VIL (Max.) and VIH (Min.). 
7. Prohibition of access to reserved addresses 

Access to reserved addresses is prohibited. The reserved addresses are provided for possible future expansion of functions. Do not access these 

addresses as the correct operation of the LSI is not guaranteed. 
8. Differences between products 

Before changing from one product to another, for example to a product with a different part number, confirm that the change will not lead to problems. 

The characteristics of a microprocessing unit or microcontroller unit products in the same group but having a different part number might differ in terms 

of internal memory capacity, layout pattern, and other factors, which can affect the ranges of electrical characteristics, such as characteristic values, 

operating margins, immunity to noise, and amount of radiated noise. When changing to a product with a different part number, implement a system-

evaluation test for the given product. 
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Notice 
1. Descriptions of circuits, software and other related information in this document are provided only to illustrate the operation of semiconductor products 

and application examples. You are fully responsible for the incorporation or any other use of the circuits, software, and information in the design of your 
product or system. Renesas Electronics disclaims any and all liability for any losses and damages incurred by you or third parties arising from the use 
of these circuits, software, or information. 

2. Renesas Electronics hereby expressly disclaims any warranties against and liability for infringement or any other claims involving patents, copyrights, 
or other intellectual property rights of third parties, by or arising from the use of Renesas Electronics products or technical information described in this 
document, including but not limited to, the product data, drawings, charts, programs, algorithms, and application examples. 

3. No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights of Renesas Electronics 
or others. 

4. You shall be responsible for determining what licenses are required from any third parties, and obtaining such licenses for the lawful import, export, 
manufacture, sales, utilization, distribution or other disposal of any products incorporating Renesas Electronics products, if required. 

5. You shall not alter, modify, copy, or reverse engineer any Renesas Electronics product, whether in whole or in part. Renesas Electronics disclaims any 
and all liability for any losses or damages incurred by you or third parties arising from such alteration, modification, copying or reverse engineering. 

6. Renesas Electronics products are classified according to the following two quality grades: “Standard” and “High Quality”. The intended applications for 
each Renesas Electronics product depends on the product’s quality grade, as indicated below. 
 "Standard": Computers; office equipment; communications equipment; test and measurement equipment; audio and visual equipment; home 

electronic appliances; machine tools; personal electronic equipment; industrial robots; etc. 
 "High Quality": Transportation equipment (automobiles, trains, ships, etc.); traffic control (traffic lights); large-scale communication equipment; key 

financial terminal systems; safety control equipment; etc. 
Unless expressly designated as a high reliability product or a product for harsh environments in a Renesas Electronics data sheet or other Renesas 
Electronics document, Renesas Electronics products are not intended or authorized for use in products or systems that may pose a direct threat to 
human life or bodily injury (artificial life support devices or systems; surgical implantations; etc.), or may cause serious property damage (space 
system; undersea repeaters; nuclear power control systems; aircraft control systems; key plant systems; military equipment; etc.). Renesas Electronics 
disclaims any and all liability for any damages or losses incurred by you or any third parties arising from the use of any Renesas Electronics product 
that is inconsistent with any Renesas Electronics data sheet, user’s manual or other Renesas Electronics document. 

7. No semiconductor product is absolutely secure. Notwithstanding any security measures or features that may be implemented in Renesas Electronics 
hardware or software products, Renesas Electronics shall have absolutely no liability arising out of any vulnerability or security breach, including but 
not limited to any unauthorized access to or use of a Renesas Electronics product or a system that uses a Renesas Electronics product. RENESAS 
ELECTRONICS DOES NOT WARRANT OR GUARANTEE THAT RENESAS ELECTRONICS PRODUCTS, OR ANY SYSTEMS CREATED USING 
RENESAS ELECTRONICS PRODUCTS WILL BE INVULNERABLE OR FREE FROM CORRUPTION, ATTACK, VIRUSES, INTERFERENCE, 
HACKING, DATA LOSS OR THEFT, OR OTHER SECURITY INTRUSION (“Vulnerability Issues”). RENESAS ELECTRONICS DISCLAIMS ANY AND 
ALL RESPONSIBILITY OR LIABILITY ARISING FROM OR RELATED TO ANY VULNERABILITY ISSUES. FURTHERMORE, TO THE EXTENT 
PERMITTED BY APPLICABLE LAW, RENESAS ELECTRONICS DISCLAIMS ANY AND ALL WARRANTIES, EXPRESS OR IMPLIED, WITH 
RESPECT TO THIS DOCUMENT AND ANY RELATED OR ACCOMPANYING SOFTWARE OR HARDWARE, INCLUDING BUT NOT LIMITED TO 
THE IMPLIED WARRANTIES OF MERCHANTABILITY, OR FITNESS FOR A PARTICULAR PURPOSE. 

8. When using Renesas Electronics products, refer to the latest product information (data sheets, user’s manuals, application notes, “General Notes for 
Handling and Using Semiconductor Devices” in the reliability handbook, etc.), and ensure that usage conditions are within the ranges specified by 
Renesas Electronics with respect to maximum ratings, operating power supply voltage range, heat dissipation characteristics, installation, etc. Renesas 
Electronics disclaims any and all liability for any malfunctions, failure or accident arising out of the use of Renesas Electronics products outside of such 
specified ranges. 

9. Although Renesas Electronics endeavors to improve the quality and reliability of Renesas Electronics products, semiconductor products have specific 
characteristics, such as the occurrence of failure at a certain rate and malfunctions under certain use conditions. Unless designated as a high reliability 
product or a product for harsh environments in a Renesas Electronics data sheet or other Renesas Electronics document, Renesas Electronics 
products are not subject to radiation resistance design. You are responsible for implementing safety measures to guard against the possibility of bodily 
injury, injury or damage caused by fire, and/or danger to the public in the event of a failure or malfunction of Renesas Electronics products, such as 
safety design for hardware and software, including but not limited to redundancy, fire control and malfunction prevention, appropriate treatment for 
aging degradation or any other appropriate measures. Because the evaluation of microcomputer software alone is very difficult and impractical, you are 
responsible for evaluating the safety of the final products or systems manufactured by you. 

10. Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental compatibility of each Renesas 
Electronics product. You are responsible for carefully and sufficiently investigating applicable laws and regulations that regulate the inclusion or use of 
controlled substances, including without limitation, the EU RoHS Directive, and using Renesas Electronics products in compliance with all these 
applicable laws and regulations. Renesas Electronics disclaims any and all liability for damages or losses occurring as a result of your noncompliance 
with applicable laws and regulations. 

11. Renesas Electronics products and technologies shall not be used for or incorporated into any products or systems whose manufacture, use, or sale is 
prohibited under any applicable domestic or foreign laws or regulations. You shall comply with any applicable export control laws and regulations 
promulgated and administered by the governments of any countries asserting jurisdiction over the parties or transactions. 

12. It is the responsibility of the buyer or distributor of Renesas Electronics products, or any other party who distributes, disposes of, or otherwise sells or 
transfers the product to a third party, to notify such third party in advance of the contents and conditions set forth in this document. 

13. This document shall not be reprinted, reproduced or duplicated in any form, in whole or in part, without prior written consent of Renesas Electronics. 
14. Please contact a Renesas Electronics sales office if you have any questions regarding the information contained in this document or Renesas 

Electronics products. 

(Note1) “Renesas Electronics” as used in this document means Renesas Electronics Corporation and also includes its directly or indirectly controlled 
subsidiaries. 

(Note2) “Renesas Electronics product(s)” means any product developed or manufactured by or for Renesas Electronics.  
(Rev.5.0-1  October 2020)  

Corporate Headquarters  Contact information 
TOYOSU FORESIA, 3-2-24 Toyosu, 
Koto-ku, Tokyo 135-0061, Japan 
www.renesas.com 

 For further information on a product, technology, the most up-to-date 
version of a document, or your nearest sales office, please visit: 
www.renesas.com/contact/. 

Trademarks   
Renesas and the Renesas logo are trademarks of Renesas Electronics 
Corporation. All trademarks and registered trademarks are the property 
of their respective owners. 
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