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Renesas Synergy™ Platform 

Migrating Existing e2 studio Projects to 
IAR Embedded Workbench® for Renesas Synergy™ 
Introduction 
This application note will show you how to migrate a project from e2 studio to IAR Embedded Workbench® for Renesas 
Synergy™ (IAR EW for Synergy). The migration process is straightforward. In this application note, making use of the 
WeatherPanel project and the SK-S7G2 Synergy MCU Group board because it is a complex application and describes 
most of the migration tasks a project will require.  

IMPORTANT: Notice that the IAR IDE project needs to be placed exactly in the same folder from the e2 studio project. 
Make sure you know the exact path to the WeatherPanel project shown in Figure below.  

 

 

Figure 1   Directory location 

Required Software 
The following tools are used for this application note. All tools are available in the Synergy Gallery 
(https://synergygallery.renesas.com/). 

• IAR Embedded Workbench for Renesas Synergy (v7.71.1 or later) 
• SSP v1.2.0 or later. Consult the migration guide to SSP v1.2.0 since it might be that SSP v1.1.3 is required for the 

SSP conversion process. If the project has been upgraded to the latest SSP in e2 studio you don’t have to worry 
about the previous SSP versions. 

• SSC v5.2.1.016 or later 
• GUIX Studio™ v5.3.0.1 or later 
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1.  Create a Basic Project in the IAR EW for Synergy IDE 
1. Open EW for Synergy by clicking on the IAR Embedded Workbench icon in the Windows Start menu: All 

Programs > IAR Systems > IAR Embedded Workbench for Renesas Synergy folder. 
2. Start a new project by clicking on the Renesas Synergy menu: New Renesas Synergy Project. 

 

 

Figure 2   Create new project 

2. Migrate Project 
1. Define the location and name for the IAR workspace to be migrated. Select the destination folder as the folder 

from the WeatherPanel project. Enter a name for the workspace in the filename text field, for example panel. 
Save the workspace to start the Synergy configurator wizard.  

 

 

Figure 3   Save workspace 
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2. If the License file and the SSC/SSP folder are already configured, the License area and SSC/SSP location of 
the form will look like the figure below. If it does, skip to step 9. 

 

 

Figure 4   License area 

3. If it is empty or not pointing to C:\Renesas\Synergy\SSC_vx_x_xxx for example SSC_v5_2_1_016 
for v5.2.1.016, continue with the steps below (4-10). These settings only need to be done once.  

4. Click the browse … button for the SSC/SSP location. The EW for Synergy will display the Open Dialog box.  
 
Note:  If you installed the SSC/SSP to the default location, then the SSC/SSP folder is located in directory: 

C:\Renesas\Synergy\SSC_vx_x_xxx. 
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Figure 5   SCC/SSP location 

 
5. Click Choose to set the SSC/SSP location. 
6. Click the browse … button for the license file. The IEW for Synergy IDE will display the Open Dialog box. 

Note: The SSP license is located in C: 
C:\Renesas\Synergy\SSC_vx_x_xxx \intenal\projectgen\arm\Licenses directory. 

7. Select SSP_License_Example_EvalLicence_*.xml or 
SSP_Development_and_Production_License_*.xml located in the directory. 
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Figure 6   Select license file 

8. Click Open to set the License file and confirm the configuration window with OK. 
9. Select the destination folder of the WeatherPanel project and enter a new name for the IAR IDE project in the 

File name text field, for example panel. Save the project by confirming with Save. 
 

 

Figure 7   Save IAR IDE project 

10. The configurator will be loaded with all preexisting settings. There is no need to select a board or even select 
the SSP package.  

11. Navigate in the Threads and Component tabs and notice the existing threads and selected components. 
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Figure 8   Threads panel 

12. Click on the Generate Project Content button to update the project files in the IAR IDE based on the 
preexisting .xml and .pincfg files. 

 

 

Figure 9   Generate Project Content button 

Note:  When migrating a project from e2 studio to IAR IEW for Synergy, delete the synergy folder if it exists, before 
generating the files for IAR. The problem is that SSC (Standalone Synergy Configurator) will add the IAR files 
on top of the GCC files used in e2 studio). This will cause linker-goo errors at the end of the build process. This 
process of deleting the synergy is also required when switching the tools back and forth. 

 
13. Close the Configurator. Notice this step if optional. Once you switch to the IAR IDE view the files will be 

generated automatically. 
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Figure 10   Closing the Configurator 

14. In the IAR IDE you will see the project structure in the IDE. 
 

 

Figure 11   Project structure 

15. Save all files through the Save All icon at the IDE or through File > Save All. 
 

 

Figure 12   Save All 
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16. Before you can build the WeatherPanel project, it is also necessary to regenerate the GUIX Studio files for 
IAR. 

17. Open GUIX Studio by clicking the desktop icon or by clicking on the GUIX icon in the Windows Start menu: 
All Programs > Express Logic > GUIX Studio 5.3.0.1 folder. 

18. Open the GUIX Studio project weather.gxp for the Weather panel 
at  ..\WeatherPanel\guix_studio\ You should also be able to open the GUIX Studio and WeatherPanel 
project by double-clicking on the weather.gxp file. It’s possible to add the .gxp file to the project then to 
start GUIX Studio by double-clicking the file in the IDE. The steps required for the integration are described at 
the end of the application note.  

 

 

Figure 13   Weather project icon 
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19. Go to the Configure > Project/Displays tab and change the toolchain to IAR. Confirm and save the new 
settings with Save. 

 

Figure 14   Set toolchain 

20. The final step from GUIX Studio is to generate the new output files for IAR. The new files can be generated 
through Project > Generate All Output Files. 
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Figure 15   Generate all output files 

21. Confirm with OK when all files have been updated. 
 

 

Figure 16   Confirm output files 

22. Make sure that the folder structure of your project and IAR project files look like Figure below, especially 
the .ewp files. 
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Figure 17   IAR project files 

23. If your project is not following the e2 studio structure you will probably get build errors since the references to 
the header files and source code will be wrong. 

24. Build the project via Project > Make or shortcut key F7. Alternatively, you can also use Project > Rebuild All. 
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Figure 18   Make or rebuild project 

Note 1: If this project was built by e2 studio before this step, the following errors may be seen: 
Error[Li005]: no definition for "__StackLimit" 
Error[Li005]: no definition for "__StackTop" 
Error[Li005]: no definition for "__RAM_segment_used_end__" 
 
These errors occur because the IAR linker finds the libraries built by e2 studio and links them instead of linking those 
built by IAR EW for Synergy. To avoid this condition, delete the libraries built by e2 studio and build again. The easiest 
way to delete the libraries built by e2 studio is to delete the entire synergy folder in the project. 

Note 2: In case of getting the following linker build error:  
Fatal Error[Lp049]: there was no reference to __iar_data_init3, but it is needed to initialize section .bss   
 
Please make sure that the latest SSP v1.2.0 is selected in the BSP settings from the SSC. The following workaround will 
be required in case a previous version of SSP v1.1.x is required with IAR EW for Synergy v7.71 and SSC v5.2.1.016. 
Override the following line in the linker script file (for example S7G2.icf) located in the scripts folder from: 

do not initialize   { section .noinit }; 

to 

do not initialize   { zeroinit }; 

 
25. Before programming the WeatherPanel application to the target, make sure that the SK-S7G2 Synergy MCU 

Group is connected to your PC or desktop via the USB cable. The USB_DEBUG connector (J19) with the J-
Link On-Board will be used for this example. 

26. Make sure to select the correct driver for your debug probe. J-Link is the On-Board probe on the SK-S7G2 
Synergy MCU Group board that you can also make use of the I-jet and I-jet Trace from the IAR Systems if you 
have one of these probes. 
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Figure 19   Select J-Link/J-Trace driver 
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Figure 20   Verify download 

27. You can program the target via Project > Download and Debug (shortcut is CTRL+D). 
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Figure 21   Program target 

28. You might get a pop-up asking for the source code of ThreadX®. You can just ignore it by clicking Skip. 
 

 

Figure 22   Skip pop-up 

29. Leave the application running and notice the WeatherPanel in the display of the board. Is it working? Just like 
out of the box? Congratulations! You did it! 

 

 

Figure 23   Running weather panel application 
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3. Extension and shortcut for GUIX Studio project in IAR EW for Synergy 
It is possible to add the GUIX Studio project into the IAR EW for Synergy project by just adding the file with the 
extension .gxp into the project tree.  

1. Select the project and add the file in Options > Add > Add Files…: *.gxp. Notice that all files should be 
displayed otherwise you only have access by default to the .C and .H files. 

 

 

Figure 24   Add .gxp files 

2. The IDE will only recognize the .gxp extension and the correct viewer after adding the .gxp in the viewer 
options in Tools > Configure Viewers. 

 

 

Figure 25   Configure viewers 

3. Then in New > File Extension, add .gxp with the option Use file Explorer Associations. Confirm with OK. 
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Figure 26   Add file extension 

4. From now on, double-clicking on the .gxp file will start the GUIX Studio and load the associated project file. 
 

 

Figure 27   Starting GUIX Studio 
This concludes the migration of the weather panel. 
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Website and Support 
Support https://synergygallery.renesas.com/support           

 

Technical Contact Details 

• America:  https://renesas.zendesk.com/anonymous_requests/new 
• Europe: http://www.renesas.eu/support/index.jsp 
• Japan:  http://japan.renesas.com/contact/index.jsp 
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1. Descriptions of circuits, software and other related information in this document are provided only to illustrate the operation of semiconductor products and application examples. You are fully responsible for
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examples.

3. No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights of Renesas Electronics or others.
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incurred by you or third parties arising from such alteration, modification, copy or otherwise misappropriation of Renesas Electronics products.

5. Renesas Electronics products are classified according to the following two quality grades: "Standard" and "High Quality". The intended applications for each Renesas Electronics product depends on the

product’s quality grade, as indicated below.
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equipment; and industrial robots etc.

"High Quality": Transportation equipment (automobiles, trains, ships, etc.); traffic control (traffic lights); large-scale communication equipment; key financial terminal systems; safety control equipment; etc.

Renesas Electronics products are neither intended nor authorized for use in products or systems that may pose a direct threat to human life or bodily injury (artificial life support devices or systems, surgical
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Electronics disclaims any and all liability for any damages or losses incurred by you or third parties arising from the use of any Renesas Electronics product for which the product is not intended by Renesas

Electronics.

6. When using the Renesas Electronics products, refer to the latest product information (data sheets, user’s manuals, application notes, "General Notes for Handling and Using Semiconductor Devices" in the

reliability handbook, etc.), and ensure that usage conditions are within the ranges specified by Renesas Electronics with respect to maximum ratings, operating power supply voltage range, heat radiation

characteristics, installation, etc. Renesas Electronics disclaims any and all liability for any malfunctions or failure or accident arising out of the use of Renesas Electronics products beyond such specified
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7. Although Renesas Electronics endeavors to improve the quality and reliability of Renesas Electronics products, semiconductor products have specific characteristics such as the occurrence of failure at a

certain rate and malfunctions under certain use conditions. Further, Renesas Electronics products are not subject to radiation resistance design. Please ensure to implement safety measures to guard them

against the possibility of bodily injury, injury or damage caused by fire, and social damage in the event of failure or malfunction of Renesas Electronics products, such as safety design for hardware and

software including but not limited to redundancy, fire control and malfunction prevention, appropriate treatment for aging degradation or any other appropriate measures by your own responsibility as warranty

for your products/system.  Because the evaluation of microcomputer software alone is very difficult and not practical, please evaluate the safety of the final products or systems manufactured by you.

8. Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental compatibility of each Renesas Electronics product. Please investigate applicable laws and

regulations that regulate the inclusion or use of controlled substances, including without limitation, the EU RoHS Directive carefully and sufficiently and use Renesas Electronics products in compliance with all

these applicable laws and regulations.  Renesas Electronics disclaims any and all liability for damages or losses occurring as a result of your noncompliance with applicable laws and regulations.

9. Renesas Electronics products and technologies shall not be used for or incorporated into any products or systems whose manufacture, use, or sale is prohibited under any applicable domestic or foreign laws

or regulations. You shall not use Renesas Electronics products or technologies for (1) any purpose relating to the development, design, manufacture, use, stockpiling, etc., of weapons of mass destruction,

such as nuclear weapons, chemical weapons, or biological weapons, or missiles (including unmanned aerial vehicles (UAVs)) for delivering such weapons, (2) any purpose relating to the development,

design, manufacture, or use of conventional weapons, or (3) any other purpose of disturbing international peace and security, and you shall not sell, export, lease, transfer, or release Renesas Electronics

products or technologies to any third party whether directly or indirectly with knowledge or reason to know that the third party or any other party will engage in the activities described above. When exporting,

selling, transferring, etc., Renesas Electronics products or technologies, you shall comply with any applicable export control laws and regulations promulgated and administered by the governments of the

countries asserting jurisdiction over the parties or transactions.

10. Please acknowledge and agree that you shall bear all the losses and damages which are incurred from the misuse or violation of the terms and conditions described in this document, including this notice,

and hold Renesas Electronics harmless, if such misuse or violation results from your resale or making Renesas Electronics products available any third party.

11. This document shall not be reprinted, reproduced or duplicated in any form, in whole or in part, without prior written consent of Renesas Electronics.

12. Please contact a Renesas Electronics sales office if you have any questions regarding the information contained in this document or Renesas Electronics products.

(Note 1) "Renesas Electronics" as used in this document means Renesas Electronics Corporation and also includes its majority-owned subsidiaries.

(Note 2) "Renesas Electronics product(s)" means any product developed or manufactured by or for Renesas Electronics.
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