Introduction
AgileReview is a plugin of Eclipse which user can do code reviews. e² studio is an integrated development environment based on Eclipse, so that e² studio is possible to realize work with external tool using plugin of Eclipse. This document describes how to install and use AgileReview plugin in e² studio.

Contents
1. Introduction ................................................................................................................... 2
   1.1 e² studio with AgileReview .......................................................................................... 2
   1.2 Environment.............................................................................................................. 2
2. Install AgileReview plugin ............................................................................................. 3
   2.1 Prerequisites installation ............................................................................................. 3
   2.2 AgileReview installation instruction ............................................................................ 3
3. Usage ............................................................................................................................. 7
   3.1 Workflow of AgileReview operation in e² studio ............................................................ 7
   3.2 Create new Review Source Project ............................................................................ 7
   3.2.1 Create new Review Source Project ........................................................................ 7
   3.2.2 Active AgileReview source project ........................................................................ 8
   3.3 Create Review ........................................................................................................... 10
   3.3.1 Create new Review .............................................................................................. 10
   3.3.2 Active review ....................................................................................................... 11
   3.4 Create new comment .............................................................................................. 11
   3.5 Modify Comment ...................................................................................................... 12
   3.5.1 Edit comment information .................................................................................... 12
   3.5.2 Revert to Comment .............................................................................................. 13
   3.5.3 Relocate Comment .............................................................................................. 14
   3.6 Delete Comment ...................................................................................................... 15
   3.7 Delete Review .......................................................................................................... 16
   3.8 Sharing comments and reviews ................................................................................ 16
4. Reference Information ................................................................................................. 17
   4.1 Web Site................................................................................................................... 17
   4.2 Reference ................................................................................................................. 17
1. Introduction

1.1 e² studio with AgileReview

e² studio is an integrated development environment based on Eclipse, so that AgileReview plugin which is a plugin of Eclipse, also works in e² studio. AgileReview plugin provides a friendly user interface to user in order to do code review in e² studio easily. By using AgileReview, user can comment and discuss code without leaving the e² studio and the code.

1.2 Environment

This document is described based on environment as the following:

- e² studio: 2.1.0.xx
- AgileReview: 0.8.4
- OS: Windows 7
2. **Install AgileReview plugin**

2.1 **Prerequisites installation**

This section describes how to install the AgileReview plug-in to e² studio. But at first, we need to prepare environments as below:

- e² studio is installed correctly
  
  This document does not describe how to install e² studio.

2.2 **AgileReview installation instruction**

AgileReview can be simply installed from e² studio using update manager. All what the user should do is just point update manager to the remote update site. To install AgileReview:

1. Start e² studio and select menu item 'Help' > 'Install New Software...'

2. Press the 'Add' button
3. On the 'Add Repository' dialog, enter the URL to the AgileReview update site. (can be found on [http://agilereview.sourceforge.net/update](http://agilereview.sourceforge.net/update))

4. Select AgileReview

6. Press the 'Next >' button.
7. Accept terms of license agreement and click the 'Finish' button in order to start the download of selected features.
8. Press the 'Yes' button to apply installation changes and restart e2 studio.
9. You can find AgileReview perspective and views in correspondent dialogs
   — To open AgileReview views: ‘Window’ > ‘Show View’ > ‘Other...’ > AgileReview

   — To open AgileReview perspective: ‘Window’ > ‘Open Perspective’ > ‘Other...’ > AgileReview
Perspective of AgileReview contains three main views:

- Review Explorer
- Comments Summary
- Comment Details
3. Usage

3.1 Workflow of AgileReview operation in e² studio

![Workflow Diagram]

Figure 1: Workflow of AgileReview operation in e² studio

3.2 Create new Review Source Project

3.2.1 Create new Review Source Project

Review Source Project stores reviews and comments. To create review source project:

2. Input the name for AgileReview source project > select ‘use this project after creation’ to active project

3. Press the 'Finish' button. Review source project should be created.

3.2.2 Active AgileReview source project

When create new review, the review will be added in active AgileReview source project.

To active AgileReview source project:

- On ‘Project Explorer’ view:
  - Select inactive AgileReview source project > right click to open context menu > select ‘Active AgileReview Source Project’
• On the ‘Review Explorer’ view:
  1. Select ‘Switch AgileReview Source Project’ button

![Switch AgileReview Source Project](image1)

  2. On the ‘No AgileReview Source Project’ dialog, select a AgileReview Source Project

![No AgileReview Source Project](image2)

  3. Selected AgileReview Source Project will be active

![Project Explorer](image3)
3.3 Create Review

3.3.1 Create new Review

Review is a set of comments. In additional, review includes information like person in charge or description about itself. To create review:

1. On menu bar of e2 studio, navigate ‘Window’ > ‘Open Perspective’ > ‘Other...’ > ‘AgileReview’
2. On 'Review Explorer' view, select 'Create new review' from context menu or press the 'Create a new review' button on tool bar
3. On the 'New Review' dialog, input name of review in 'Review-Name*:.' text box
4. Press the 'Finish' button to create successfully
3.3.2 Active review

The comment must be added to a review which review is active.

To active a review: Open the ‘Review Explorer’ view > select an inactive review > press the ‘Activate selected review’ button

![Review Explorer](image)

3.4 Create new comment

To create new comment:

1. On editor of e2 studio, select the code line(s)/section where comment should be placed
2. Open the ‘Comments Summary’ view > press the ‘Add new comment (Ctrl+Shift++)’ button in the top right corner of local toolbar items or press ‘Ctrl + Shift + '+' key combination

![Comments Summary](image)

3. Comment will be added on editor successfully

![Code Editor](image)
3.5 Modify Comment
3.5.1 Edit comment information
To edit comment information:

1. Open comment on ‘Comment Details’ view
2. On the ‘Comment Details’ view, modify information of comment:
   a. Status: modify status of comment
   b. Priority: set priority of comment
   c. Recipient: input recipient
   d. Description: input description
   e. Add reply for comment by press ‘Alt + Shift + ‘+’’ key combination or click ‘Add new reply’ on the top right corner

3. Leave the ‘Comment Details’ view to save the modification. The ‘Comments Summary’ view is updated.
3.5.2 Revert to Comment

When user edits comment, the ‘revert’ button is enable. Press the ‘revert’ button. The comment will go back to previous information (information before editing).

To revert to comment:

1. Open comment on the ‘Comment Details’ view > edit information of comment
2. Press the ‘revert’ button

3. The comment will be revert successfully
3.5.3 Relocate Comment

To relocate comment:

1. On editor of e² studio, select the code line(s)/ section where comment should be relocated

2. Open ‘Comment Details’ view of comment which should be relocated > Click the ‘Relocate’ button on the top right corner of local toolbar items

3. Select the ‘Relocate’ button for confirming

4. The comment should be moved to new location successfully
3.6 Delete Comment

To delete the comment, user can delete on the ‘Comments Summary’ view or on the ‘Comment Details’ view.

- On the ‘Comments Summary’ view:
  1. Select a comment in Comment table > press the ‘Delete comments’ button in the top right corner of local toolbar items

![Comments Summary screenshot](image)

2. Press the ‘OK’ button on the ‘Comments Summary – Delete’ dialog to delete comment

![Comments Summary - Delete dialog](image)

- On the ‘Comment Details’ view
  1. Open ‘Comment Details’ view of a comment, press the ‘Delete shown resource (Alt+Shift+Delete)’ button in the top right corner of local toolbar items

![Comment Details screenshot](image)

2. Press the ‘OK’ button on the ‘Comment Details – Delete’ dialog to delete comment

![Comment Details - Delete dialog](image)
3.7 Delete Review
To delete review:
1. On the ‘Review Explorer’ view, right click a review to open context menu > Delete

2. Press the ‘OK’ button on the ‘Review Explorer – Delete’ dialog to delete review

3.8 Sharing comments and reviews
Using SVN in combination with the Eclipse Subversive plug-in the sharing can be achieved as follows:

1. Select the Review Source Project that stores the review data.
2. Select context menu ‘Team’ > ‘Share Project’ and share the project into an existing SVN repository.
3. Commit the commented code.

Other review can then participate in the review process by simply checking out code and the Review Source Project.

After the initial steps for sharing, you can proceed with reviewing. Be sure to
a). select the file(s) you commented as well as the folder that contains the review data in the Package Explorer and commit them to the SVN repository.
b). update the file(s) you want to review as well as the folder that contains the review data before proceeding, as other authors might have added comments and reviews.
4. Reference Information

4.1 Web Site
AgileReview home page URL:
http://www.agilereview.org
Eclipse AgileReview plugin home page URL:
http://marketplace.Eclipse.org/content/agilereview/metrics

4.2 Reference
“Agile Review – User Guide – v0.8.1”
Website and Support

Renesas Electronics Website
http://www.renesas.com/

Inquiries
http://www.renesas.com/contact/

All trademarks and registered trademarks are the property of their respective owners.
General Precautions in the Handling of MPU/MCU Products

The following usage notes are applicable to all MPU/MCU products from Renesas. For detailed usage notes on the products covered by this document, refer to the relevant sections of the document as well as any technical updates that have been issued for the products.

1. Handling of Unused Pins
   Handle unused pins in accordance with the directions given under Handling of Unused Pins in the manual.
   - The input pins of CMOS products are generally in the high-impedance state. In operation with an unused pin in the open-circuit state, extra electromagnetic noise is induced in the vicinity of LSI, an associated shoot-through current flows internally, and malfunctions occur due to the false recognition of the pin state as an input signal become possible. Unused pins should be handled as described under Handling of Unused Pins in the manual.

2. Processing at Power-on
   The state of the product is undefined at the moment when power is supplied.
   - The states of internal circuits in the LSI are indeterminate and the states of register settings and pins are undefined at the moment when power is supplied.
     In a finished product where the reset signal is applied to the external reset pin, the states of pins are not guaranteed from the moment when power is supplied until the reset process is completed.
     In a similar way, the states of pins in a product that is reset by an on-chip power-on reset function are not guaranteed from the moment when power is supplied until the power reaches the level at which resetting has been specified.

3. Prohibition of Access to Reserved Addresses
   Access to reserved addresses is prohibited.
   - The reserved addresses are provided for the possible future expansion of functions. Do not access these addresses; the correct operation of LSI is not guaranteed if they are accessed.

4. Clock Signals
   After applying a reset, only release the reset line after the operating clock signal has become stable.
   - When switching the clock signal during program execution, wait until the target clock signal has stabilized.
     - When the clock signal is generated with an external resonator (or from an external oscillator) during a reset, ensure that the reset line is only released after full stabilization of the clock signal.
     Moreover, when switching to a clock signal produced with an external resonator (or by an external oscillator) while program execution is in progress, wait until the target clock signal is stable.

5. Differences between Products
   Before changing from one product to another, i.e. to a product with a different part number, confirm that the change will not lead to problems.
   - The characteristics of an MPU or MCU in the same group but having a different part number may differ in terms of the internal memory capacity, layout pattern, and other factors, which can affect the ranges of electrical characteristics, such as characteristic values, operating margins, immunity to noise, and amount of radiated noise. When changing to a product with a different part number, implement a system-evaluation test for the given product.
1. Descriptions of circuits, software and other related information in this document are provided only to illustrate the operation of semiconductor products and application examples. You are fully responsible for the incorporation of these circuits, software, and information in the design of your equipment. Renesas Electronics assumes no responsibility for any losses incurred by you or third parties arising from the use of these circuits, software, or information.

2. Renesas Electronics has used reasonable care in preparing the information included in this document, but Renesas Electronics does not warrant that such information is error free. Renesas Electronics assumes no liability whatsoever for any damages incurred by you resulting from errors or omissions from the information included herein.

3. Renesas Electronics does not assume any liability for infringement of patents, copyrights, or other intellectual property rights of third parties by or arising from the use of Renesas Electronics products or technical information described in this document. No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights of Renesas Electronics or others.

4. You should not alter, modify, copy, or otherwise misappropriate any Renesas Electronics product, whether in whole or in part. Renesas Electronics assumes no responsibility for any losses incurred by you or third parties arising from such alteration, modification, copy or otherwise misappropriation of Renesas Electronics product.

5. Renesas Electronics products are classified according to the following two quality grades: “Standard” and “High Quality”. The recommended applications for each Renesas Electronics product depends on the product's quality grade, as indicated below:

   “Standard”: Computers, office equipment, communications equipment, test and measurement equipment, audio and visual equipment; home electronic appliance; machine tools; personal electronic equipment; and industrial robots etc.

   “High-Quality”: Transportation equipment (automobiles, train, ships, etc.); traffic control systems; anti-disaster systems; anti-crime systems; and safety equipment etc.

Renesas Electronics products are neither intended nor authorized for use in products or systems that may pose a direct threat to human life or bodily injury (artificial life support devices or systems, surgical implantation etc.), or may cause serious property damages (nuclear reactor control systems, military equipment etc.). You must check the quality grade of each Renesas Electronics product before using it in a particular application. You may not use any Renesas Electronics product for any application for which it is not intended. Renesas Electronics shall not be in any way liable for any damages or losses incurred by you or third parties arising from the use of any Renesas Electronics product for which the product is not intended by Renesas Electronics.

6. You should use the Renesas Electronics products described in this document within the range specified by Renesas Electronics, especially with respect to the following maximum ratings, operating supply voltage range, movement power voltage range, heat radiation characteristics, installation and other product characteristics. Renesas Electronics shall have no liability for malfunctions or damages arising out of the use of Renesas Electronics products beyond such specified ranges.

7. Although Renesas Electronics endeavors to improve the quality and reliability of its products, semiconductor products have specific characteristics such as the occurrence of failure at a certain rate and malfunctions under certain use conditions. Further, Renesas Electronics products are not subject to radiation resistance design. Please be sure to implement safety measures to guard against the possibility of physical injury, and injury or damage caused by fire in the event of the failure of a Renesas Electronics product, such as safety design for hardware and software including but not limited to redundancy, fire control and malfunction prevention, appropriate treatment for aging degradation or any other appropriate measures. Because the evaluation of micropcderware software alone is very difficult, please evaluate the safety of the final products or systems manufactured by you.

8. Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental compatibility of each Renesas Electronics product. Please use Renesas Electronics products in compliance with all applicable laws and regulations that regulate the inclusion or use of controlled substances, including without limitation, the EU RoHS Directive. Renesas Electronics assumes no liability for damages or losses occurring as a result of your noncompliance with applicable laws and regulations.

9. Renesas Electronics products and technology may not be used for or incorporated into any products or systems whose manufacture, use, or sale is prohibited under any applicable domestic or foreign laws or regulations. You should not use Renesas Electronics products or technology described in this document for any purpose relating to military applications or use by the military, including but not limited to the development of weapons of mass destruction. When exporting the Renesas Electronics products or technology described in this document, you should comply with the applicable export control laws and regulations and follow the procedures required by such laws and regulations.

10. It is the responsibility of the buyer or distributor of Renesas Electronics products, who distributes, disposes of, or otherwise places the product with a third party, to notify that third party in advance of the contents and conditions set forth in this document. Renesas Electronics assumes no responsibility for any losses incurred by you or third parties as a result of unauthorized use of Renesas Electronics products.

11. This document may not be reproduced or duplicated in any form, in whole or in part, without prior written consent of Renesas Electronics.

(Note 1) “Renesas Electronics” as used in this document means Renesas Electronics Corporation and also includes its majority-owned subsidiaries.

(Note 2) “Renesas Electronics products” or “products” means any product developed or manufactured by or for Renesas Electronics.