REN ESAS Application Note

Integrated Development Environment e? studio
How to use CUnit in e? studio (CC-RX)

Introduction

CUnit is a simple framework for writing, administering, and running unit tests in C.

This document describes how to use CUnit to automate unit testing using a project for CC-RX created in €2
studio.
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Integrated Development Environment e? studio How to use CUnit in e? studio (CC-RX)

1. Overview

This section shows the purpose of this document and operating environment for procedures.

1.1 Purpose

e? studio is an integrated development environment for Renesas microcontrollers based on the open source
n H "
Eclipse".

CUnit is a simple framework for writing, administering, and running unit tests in C.
Test code is written in C, built as a static library, and then linked with the user's target program for execution.

CUnit provides a simple API for defining the structure of test suites and test cases, along with a rich set of
assertion functions for validating common data types. In addition, it offers multiple interfaces for executing
tests and generating test reports - such as console output and XML - enabling flexible test operations
according to different needs.

This document describes how to use CUnit to automate unit testing using a project for CC-RX created in €2
studio.

[Notes]

*  This document uses a project that employs the CC-RX and a CC-RX simulator as an example for
explanation.

*  CUnit can also be used to perform unit testing in projects that use other device families or
toolchains. If you are using CUnit with different device families, compilers, or debugging
environments, please refer to "3.2 When using other devices or compiler or debugger".

1.2 Operation Environment
Renesas have confirmed the operating procedure explained in this document in the following environment.

Renesas does not warrant the general behavior of those tools with e? studio. Because it is Open-Source
Software which we cannot manage. We really appreciate you're understanding in advance.

0S Windows 11
Tool e? studio 2025-12
CUnit 2.1.2
Project Device RX610
Toolchain C/C++ Compiler Package for RX Family CC-RX V3.07.00

In advance, please install the e? studio and toolchain to your PC.
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2. Getting started with CUnit

This section shows how to setup CUnit to e? studio.

[Important notes]

. Download and use CUnit-2.1-2. CUnit--2.1-3 has some problems which causes build errors.
Besides, CUnit-2.1-2 package lacks header file “ExampleTests.h”. Don’t build examples.

*  The compiler (and Windows system) does not support “curse” module. Don’t build “curse”.

2.1 Building CUnit library
CUnit can be built to be a static library to be linked to user’s code. This section shows how to build the static
library.
1) Download CUnit-2.1.2 from https://sourceforge.net/projects/cunit/files/CUnit/2.1-2/. Extract compressed
file to get CUnit package.
2) Launch e? studio. In "C/C++" perspective, click [File] > [New] > [Renesas C/C++ Project] > [Renesas
RX].
3) Inthe [New C/C++ Project - Templates for Renesas RX Project] dialog, choose "Renesas CC-RX
C/C++ Library Project" and click [Next >] button.
e New C/C++ Project O
Templates for Renesas RX Project
Renesas CC-RX C/C++ Executable Project
C/C++ ===~ A G/C++ Project for Renesas RX using the Renesas CCRX toolchain.
Renesas CC-RX C/C++ Library Project
=™ A G/C++ Library Project for Renesas RX using the Renesas
CCRX tooichain.
< >
e cance
Figure 1 New C/C++ Library Project
4) In [Project name:] enter the name "CUnit" and click [Next >] button.
5) Inthe [New Renesas CC-RX Library Project - Select toolchain, device & debug settings] page, enter the

following information (other values can remain at default):

J Toolchain:

"Renesas CC-RX"

. Toolchain Version:

e.g. "v3.07.00”

e Target Device:

e.g. "R5F56107VxFP"
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New Renesas CC-RX Library Project —_—

Select toclchain, device & debug settings

Toolchain Settings

Language: Oc Oc++
Toolchain: Renesas CC-RX N
Toolchain Version: v3.07.00 &7
Manage Toolchains...
Device Settings Configurations
Target Board: | Custom ™ | Create Debug Configuration

Download additional boards...
- (] Create Release Configuration

Target Device:  RSFS6104VxFP

Unlock Devices...

Endian: Little ~

Bank Mode

@ < Back Next = Cancel

Figure 2 Toolchain and device settings

6) Click [Finish] button.

7) In the [Project Explorer] view, expand the CUnit project and delete files (sample1.c, sample2.c and
sample3.s) in the folder "src".

8) From the CUnit directory, downloaded and extracted previously, copy “Headers” into the “src” folder in
CUnit library project. Then, copy “Basic” and “Framework” of “Sources” subdirectories in CUnit into the
"src" folder in CUnit library project. This can be accomplished, in Windows, using either the clipboard or
by drag and drop from a File Explorer into e? studio.

9) The project should resemble the figure below:

- a X

B Project Explorer x =h : a

v &5 CUnit

& Includes
= (4
= Basic
= Framework
& Headers

Figure 3 Copied files to e? studio projectg

10) Open project properties, select [C/C++ Build] > [Settings], [Compiler] > [Source], then in [Include file
directories (-include)] click [Add...] button and add include file directory
"${workspace_loc:/${ProjName}/src/Headers}".
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= Properties for CUnit

type filter text Settings cTeT
> Resource
Builders
~ C/C++ Build Configuration: |Debug [ Active ] ~ | Manage Configurations...
Build Variables
Environment . -
Logging ® Tool Settings Toolchain Device #* Build Steps Build Artifact [m Binary Parsers @ Error Parsers
Settings ~ B Common Include file directories (-include) S8 &858
Stack Analysi 2
ack Analysls &Py ${TCINSTALL}/include
Tool Chain Editor & PIC/PID “${workspace_loc/${ProjName}/src/Headers}”
» C/C++ General & Miscellaneous
Project Natures ~ % Compiler
Project References ~ (& Source
Renesas QF & Advanced
Run/Debug Settings 2 Object
Task Tags & List
Validation ~ (& Optimization

@

Cancel

Apply and Close

Figure 4 Add CUnit Header files directory to build setting

11) Select [Compiler] > [Source] > [Advanced], then select “C99” in [C source file (-lang)]. Next click [Apply
and Close] button.

< Properties for CUnit O X
type filter text Settings - -
Resource R
Builders
v C/C++ Build Configuration: Debug [ Active ] | Manage Configurations...
Build Variables
Environment : =
Logging ® Tool Settings Toolchain Device ./ Build Steps Build Artifact b Binary Parsers @ Ermror Parsers
Settings v & Common C source file (-lang) C99 -
Stack Analysis & cPU
Tool Chain Editor 2 PIC/PID C++ source file (-lang (C++)) C++ ~
C/C++ General & Miscellaneous Character code of an input program (-euc/-sjis/-latin1/-utf8/-big5/-gb2312) UTF-8 code »
Project Natures v & Compiler Checks the compatibility with an existi rogram (-check) None ~
Project References « (& Source P g prog
Renesas QF = Advanced Suppress information-level message output (-message/-nomessage)
Run/Debug Settings & Object Suppress number of information message (-nomessage)
Task Tags ¢ List [] Changes the waming-level messages to information-level messages (-change_message=information)
Velidation ~ (2 Optimization M aaraes v b £ chrarrmes e armn_infrarmamtinm <o mkore v
@ =
Figure 5 Change language setting
12) Create the following new files in “src\Headers” folder since CC-RX does not support “time.h”:
* time.h
#ifndef TIME H
#define TIME H
typedef int clock t;
#define CLOCKS PER SEC 1000
#define clock() (0)
#endif
/* TIME H */
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13) Build the project. The file “CUnit.lib” will appear inside the “Debug” folder, as shown in the figure below.

R Project Explorer X
v 5 CUnit [Debug
» Includes
8 src
v (= Debug
& src
CUnit_l.ud
CUnitlbp
sy CUnitlib
CUnitudm
LinkerCUnit.tmp
LinkerSubCommand.tmp
makefile
makefile.init
object.mk
udSubCommand.tmp
CUnit.rcpc

Figure 6 Output static library

The CUnit library file, “CUnit.lib”, can now be used in any C/C++ project to provide a CUnit test framework.

2.2 Performing unit testing using CUnit
1) In"C/C++" perspective, click [File] > [New] > [Renesas C/C++ Project] > [Renesas RX].

2) Inthe [New C/C++ Project - Templates for Renesas RX Project] dialog, choose "Renesas CC-RX
C/C++ Executable Project" and click [Next >] button.

e New C/C++ Project O X

Templates for Renesas RX Project

Renesas CC-RX C/C++ Executable Project N
C/C++ FE=™ A C/C++ Project for Renesas RX using the Renesas CCRX toolchain.

Renesas CC-RX C/C+ + Library Project
FE==™ A G/C++ Library Project for Renesas RX using the Renesas
CCRX toolchain.

Figure 7 New Executable C/C++ Project
3) In[Project name:] enter the name "SampleCUnit" and click [Next >] button.

4) Inthe [New Renesas CC-RX Executable Project - Select toolchain, device & debug settings] page,
enter the following information (other values can remain at default):

*  Toolchain: "Renesas CC-RX"

e Toolchain Version: e.g. "v3.07.00"

e Target Device: e.g. "R56F56107VxFP"

*  Uncheck [Create Hardware Debug Configuration]

*  Check [Create Debug Configuration] for “RX Simulator”.
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New Renesas CC-RX Executable Project —

Select toolchain, device & debug settings

Toolchain Settings

Language: Oc Oc++
Toolchain: Renesas CC-RX v
Toolchain Version: v3.07.00 R
Manage Toolchains...
RTOS: None R
RTOS Version:
Device Settings Configurations
Target Board: |Custom ~ | [ Create Hardware Debug Configuration
Download additional boards... E2 Lite (RX) v

Target Device: | R5F56104VxFP
Create Debug Configuration
Unlock Devices...
RX Simulator ~
Endian: Little ~

Bank Mode [C] Create Release Configuration

@ < Back Finish Cancel

Figure 8 Toolchain and device settings

5) Keep clicking [Next >] button until the [New Renesas CC-RX Executable Project - Settings The
Contents of Files to be Generated] page is reached. Check [Use Renesas Debug Virtual Console]. Click
[Finish] button.

¢ ] g
New Renesas CC-RX Executable Project f—
Settings The Contents of Files to be Generated

What kind of initialization routine would you like to create?

Use Renesas Debug Virtual Console
Size of I/O Stream Buffer:
E -

-

@ < Back Next > Cancel

Figure 9 Settings The Contents of Files to be Generated
6) Create the following new files to be tested in “src” folder:

. source.h

#ifndef SOURCE H
#define SOURCE H_

int add(int a, int b);
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int subtract (int a, int b):

#endif
/* SOURCE H */

* source.c

#include "source.h"
int add(int a, int b) {

return a + b;

int subtract(int a, int b) {
return a - b;

. testsource.c

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <assert.h>
#include "CUnit.h"
#include "source.h"

static void test Add 01 (void) {
// Equal Assertion is used in this test case.

// 1If expected value is not same, assertion occurs.

// We can refer the Reference document for the other useful
assertion.

CU_ASSERT EQUAL(1l, add(1l,0));
}

static void test Add 02 (void) {
CU_ASSERT EQUAL (10, add(1,9));
}

static void test Subtract (void) {

// 1If expected value is not same, assertion occurs.
CU_ASSERT EQUAL (0, subtract(l,1));
}

// This is a test suite

static CU TestInfo tests Add[] = {
// Register test case to test suite
{"test Add 01", test Add 01},
{"test Add 02", test Add 02},
CU TEST INFO NULL,

}i

static CU TestInfo tests Subtract[] = {

// This 1is a test case used to test add() function in source.

C

// 1 is expected value, and add(l,0) is actual return value.

// This is a test case used to test subtract() function in source.c

// 0 is expected value, and subtract(l,1) is actual return value.

R20AN0322EJ0103 Rev.1.03
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{"test Subtract", test Subtract},
CU_TEST INFO NULL,
}s

// Declare the test suite in SuitelInfo

static CU SuiteInfo suites[] = {
{"TestSimpleAssert AddSuite", NULL, NULL, tests Add},
{"TestSimpleAssert SubtractSuite", NULL, NULL, tests Subtract},
CU_SUITE INFO NULL,

}i

void AddTests (void) {
// Retrieve a pointer to the current test registry

assert (NULL != CU get registry()):;

// Flag for whether a test run is in progress
assert (!CU_is test running());

// Register the suites in a single CU SuiteInfo array

if (CU_register suites(suites) != CUE_SUCCESS) {
// Get the error message
printf ("Suite registration failed - %s\n", CU get error msg());

exit (EXIT FAILURE) ;
}

7) Replace the contents of the existing source file, “SampleCUnit.c”, and add code to run the test.

*  SampleCUnit.c

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include "Basic.h"

void exit (long) ;

void abort (void) ;

int main (void) ;

extern void AddTests();

int main (void)

{
// Define the run mode for the basic interface
// Verbose mode - maximum output of run details
CU BasicRunMode mode = CU BRM VERBOSE;

// Define error action

// Runs should be continued when an error condition occurs (if
possible)

CU ErrorAction error action = CUEA IGNORE;

// Initialize the framework test registry
if (CU _initialize registry()) {
printf ("Initialization of Test Registry failed.\n");
}
else {
// Call add test function

R20AN0322EJ0103 Rev.1.03 Page 9 of 14
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AddTests () ;

// Set the basic run mode, which controls the output during test
runs
CU basic set mode (mode) ;

// Set the error action
CU _set error action(error action);

// Run all tests in all registered suites
printf ("Tests completed with return value %d.\n",
CU basic run tests());

// Clean up and release memory used by the framework
CU cleanup registry();
}

return 0;

void abort (void) {}
void exit (long exitcode) {}

8) Replace the contents of the existing header file “sbrk.h” in “generate” folder.
* sbrk.h

/* size of area managed by sbrk */
#define HEAPSIZE 0x800

9) Open project properties, select [C/C++ Build] > [Settings], [Compiler] > [Source], then in [Include file
directories (-include)] click [Add...] button and add the include file directory from the CUnit project,
"${workspace_loc:/CUnit/src/Headers}".

e Properties for SampleCUnit

type filter text Settings v v §

Resource

Builders =
v C/C++ Build Configuration: |Debug [ Active | || Manage Configurations..
Build Variables

Environment .
® Tool Settings Toolchain Device # Build Steps Build Artifact Binary Parsers @ Error Parsers

Logging
Settings + B Common Include file directories (-include) L= B~
Stack Analysis & CcpPu ${TCINSTALL}/include
Tool Chain Editor & PIC/PID ${ProjDirPath}/generate
C/C++ General # Miscellaneous “${waorkspace_loc;/CUnit/src/Headers}”
Project Natures ~ & Compiler
Project References ~ (% Source
Renesas QF (& Advanced
Run/Debug Settings £ Object
Task Tags = List
Validation ~ (& Optimization b

@ Apply and Close Cancel

Figure 10 Add CUnit header files to build
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10) In [Linker] > [Input], [Relocatable files, object files and library files (-input/-library/-binary)], add the CUnit
library "${workspace_loc:/CUnit/Debug/CUnit.lib}".

= Properties for SampleCUnit - =
type filter text Settings . o
Resource & .
Builders
v C/C++ Build Configuration: Debug [ Active ] ~ Manage Configurations...
Build Variables
Environment : : =
Logging ® Tool Settings Toolchain Device . Build Steps  Build Artifact & Binary Parsers @ Error Parsers
Settings % Common Relocatable files, object files and library files (-input/-library/-binary) S8 858
Stack Analysi "$iworkspace loc/CUnit/Debug/CUnitliby™ |
ack Analysis ¥ Compiler “${workspace loc;/CUnit/Debug/CUnitlib}"
Tool Chain Edit B Assembler
C/C++ General ~ % Linker
Project Natures ~ (2 Input
Project References & Advanced
Renesas QF ~ & Qutput
Rum/Mishiin Sattineg ® Advanced M

Cancel

@ Apply and Close

Figure 11 Add CUnit library to linker

11) In [Library Generator] > [Standard Library], choose “C99” in [Library configuration (-lang)] and check
[ctype.h (C89/C99): Character classification routines (-head=ctype)] checkbox. Then, click [Apply and
Close] button.

< Properties for SampleCUnit O X
type filter text Settings v v
Resource ~ X ) .
Builders & Common Library configuration (-lang) ' C99 v
~v C/C++ Build & Compiler runtime: Runtime routines (-head=runtime)
Build Variables & ﬁssembler ctype.h (C89/C99): Character classification routines (-head=ctype)
® Link
& Linker
Environment i "I math.h {(C89/C99): Numerical calculation library (-head=math)
) ~ & Library Generator ; o )
Logging = Mode [ mathfh (C89/C99): Numerical calculation library (float type function) (-head=mathf)
- =
Settings = = [ stdarg.h (C89/C99): Variable argument functions (-head=stdarg)
. (*2 Standard Library
Stack Analysis & Object stdio.h (C89/C99): Input/Qutput (-head=stdio)

Tool Chain Edit
C/C++ General
Project Natures
Project References
Renesas QE

<

Run/Nahin Satting

~ (& Optimization
2 Advanced
(2 Miscellaneous
2 User
~ B Converter
(2 Output

stdlib.h (C89/C99): General purpose library features (-head=stdlib)
stning.h (C89/C99): Stnng handling operations (-head=string)

[ios (EC++): Input/OQutput streams (-head=ios)

new (EC++): Memory allocation and deallocation routines (-head=new)
[l complex.h (EC++): Complex number operations (-head=complex)

etrimms AC 0 1\ Chrimm mmmmimisl adinm mmarntinme | hand _cmmeteinad

@

12)
13)

14)

Build the project.

Apply and Close

Cancel

Figure 12 Check Optimization setting

Then, click [Debug] button.

15)
16)

can see that your program stops at the “void Excep_BRK(void){ wait(); }".

To run the test harness use Renesas Simulator Debugging. To do this, select menu [Run] > [Debug
Configurations...].

In the [Debug Configurations] dialog, choose [Renesas Simulator Debugging] > [SampleCUnit Debug].

Simulator is executed. Select menu [Renesas Views] > [Debug] > [Renesas Debug Virtual Console].

[Renesas Debug Virtual Console] view is displayed. Select menu [Run] > [Resume] several times. You

R20AN0322EJ0103 Rev.1.03
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17) At that time, the test result is displayed in the [Renesas Debug Virtual Console] view, as shown in the

figure below:

= Renesas Debug Virtual Console x

CUnit - A unit testing framework for C - Version 2.1-2
http://cunit.sourceforge.net/

Suite: TestSimpleAssert_AddSuite
Test: test_Add_@1 ...passed
Test: test_Add_@2 ...passed

Suite: TestSimpleAssert_SubtractSuite
Test: test_Subtract ...passed

Run Summary: Type Total Ran Passed Failed Inactive
suites 2 2 n/a <] 2]
tests 3 3 3 2] 2]
asserts 3 3 3 2] n/a
Elapsed time = 0.000 seconds

Tests completed with return value @.

Figure 13 Executing test program in Terminal view

R20AN0322EJ0103 Rev.1.03

Jan.28.26

RENESAS

Page 12 of 14



Integrated Development Environment e? studio How to use CUnit in e? studio (CC-RX)

3. Reference information
3.1 Website and Support
« e?studio
https://www.renesas.com/software-tool/e-studio
*  CuUnit

https://cunit.sourceforge.net/

https://sourceforge.net/projects/cunit/

3.2 When using other devices or compiler or debugger

This document assumes an environment that combines CC-RX simulation environment and printf, but in the
debugger for Arm cores, console output is possible by semi-hosting function etc. In addition, even if the
emulator does not have a console output function and output with printf cannot be performed, it is possible to
display on the console by using "Dynamic printf"

You can see how to use "Dynamic printf" in the video on the following page.

e? studio Tips - How to Use Printf Debugging Without Changing the Source Code (Using Dynamic Printf) |
Renesas

[Example]

If you create your own printf as shown below and specify "Dynamic printf" there, you can get the same result
as in this document.

e xprintf.h

#ifndef XPRINTF H
#define XPRINTF H

#define printf xPrintf

void xPrintf (const char* format, ...);
#endif

e Xxprintf.c
void xPrintf (const char* format, ...);

void xPrintf (const char* format, ...)

{
static char szBuf[512];
va_ list ap;
va_start (ap, format);

vsprintf (szBuf, format, ap):;

va_end (ap) ; /* here place Dynamic Printf as "%s",szBuf */

R20AN0322EJ0103 Rev.1.03 Page 13 of 14
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Revision History

Description
Rev. Date Page Summary
1.02 Jul 12, 2022 Page 2 - Update the operation environment of e? studio.
Page 14 - Add the explanation of “Dynamic printf”.
1.03 Jan 28, 2026 All - Update “1. Overview”. Because this document target is not

only CC RX.

- Replace version-dependent descriptions with the latest
version information.

R20AN0322EJ0103 Rev.1.03

Jan.28.26

Re Page 14 of 14
RENESAS




General Precautions in the Handling of Microprocessing Unit and Microcontroller
Unit Products

The following usage notes are applicable to all Microprocessing unit and Microcontroller unit products from Renesas. For detailed usage notes on the
products covered by this document, refer to the relevant sections of the document as well as any technical updates that have been issued for the products.
1. Precaution against Electrostatic Discharge (ESD)
A strong electrical field, when exposed to a CMOS device, can cause destruction of the gate oxide and ultimately degrade the device operation. Steps
must be taken to stop the generation of static electricity as much as possible, and quickly dissipate it when it occurs. Environmental control must be
adequate. When it is dry, a humidifier should be used. This is recommended to avoid using insulators that can easily build up static electricity.
Semiconductor devices must be stored and transported in an anti-static container, static shielding bag or conductive material. All test and
measurement tools including work benches and floors must be grounded. The operator must also be grounded using a wrist strap. Semiconductor

devices must not be touched with bare hands. Similar precautions must be taken for printed circuit boards with mounted semiconductor devices.
2. Processing at power-on

The state of the product is undefined at the time when power is supplied. The states of internal circuits in the LSI are indeterminate and the states of
register settings and pins are undefined at the time when power is supplied. In a finished product where the reset signal is applied to the external reset
pin, the states of pins are not guaranteed from the time when power is supplied until the reset process is completed. In a similar way, the states of pins
in a product that is reset by an on-chip power-on reset function are not guaranteed from the time when power is supplied until the power reaches the

level at which resetting is specified.
3. Input of signal during power-off state

Do not input signals or an 1/0 pull-up power supply while the device is powered off. The current injection that results from input of such a signal or I/0
pull-up power supply may cause malfunction and the abnormal current that passes in the device at this time may cause degradation of internal

elements. Follow the guideline for input signal during power-off state as described in your product documentation.
4. Handling of unused pins

Handle unused pins in accordance with the directions given under handling of unused pins in the manual. The input pins of CMOS products are
generally in the high-impedance state. In operation with an unused pin in the open-circuit state, extra electromagnetic noise is induced in the vicinity of
the LSI, an associated shoot-through current flows internally, and malfunctions occur due to the false recognition of the pin state as an input signal

become possible.
5. Clock signals

After applying a reset, only release the reset line after the operating clock signal becomes stable. When switching the clock signal during program
execution, wait until the target clock signal is stabilized. When the clock signal is generated with an external resonator or from an external oscillator
during a reset, ensure that the reset line is only released after full stabilization of the clock signal. Additionally, when switching to a clock signal

produced with an external resonator or by an external oscillator while program execution is in progress, wait until the target clock signal is stable.
6. Voltage application waveform at input pin

Waveform distortion due to input noise or a reflected wave may cause malfunction. If the input of the CMOS device stays in the area between V.
(Max.) and Vi (Min.) due to noise, for example, the device may malfunction. Take care to prevent chattering noise from entering the device when the

input level is fixed, and also in the transition period when the input level passes through the area between Vi. (Max.) and Vix (Min.).
7. Pronhibition of access to reserved addresses

Access to reserved addresses is prohibited. The reserved addresses are provided for possible future expansion of functions. Do not access these

addresses as the correct operation of the LSl is not guaranteed.
8. Differences between products

Before changing from one product to another, for example to a product with a different part number, confirm that the change will not lead to problems.
The characteristics of a microprocessing unit or microcontroller unit products in the same group but having a different part number might differ in terms
of internal memory capacity, layout pattern, and other factors, which can affect the ranges of electrical characteristics, such as characteristic values,
operating margins, immunity to noise, and amount of radiated noise. When changing to a product with a different part number, implement a system-
evaluation test for the given product.



Notice

1.

12.

13.
14.

(Note1)

Descriptions of circuits, software and other related information in this document are provided only to illustrate the operation of semiconductor products
and application examples. You are fully responsible for the incorporation or any other use of the circuits, software, and information in the design of your
product or system. Renesas Electronics disclaims any and all liability for any losses and damages incurred by you or third parties arising from the use
of these circuits, software, or information.
Renesas Electronics hereby expressly disclaims any warranties against and liability for infringement or any other claims involving patents, copyrights,
or other intellectual property rights of third parties, by or arising from the use of Renesas Electronics products or technical information described in this
document, including but not limited to, the product data, drawings, charts, programs, algorithms, and application examples.
No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights of Renesas Electronics
or others.
You shall be responsible for determining what licenses are required from any third parties, and obtaining such licenses for the lawful import, export,
manufacture, sales, utilization, distribution or other disposal of any products incorporating Renesas Electronics products, if required.
You shall not alter, modify, copy, or reverse engineer any Renesas Electronics product, whether in whole or in part. Renesas Electronics disclaims any
and all liability for any losses or damages incurred by you or third parties arising from such alteration, modification, copying or reverse engineering.
Renesas Electronics products are classified according to the following two quality grades: “Standard” and “High Quality”. The intended applications for
each Renesas Electronics product depends on the product’s quality grade, as indicated below.

"Standard": Computers; office equipment; communications equipment; test and measurement equipment; audio and visual equipment; home

electronic appliances; machine tools; personal electronic equipment; industrial robots; etc.
"High Quality": Transportation equipment (automobiles, trains, ships, etc.); traffic control (traffic lights); large-scale communication equipment; key
financial terminal systems; safety control equipment; etc.

Unless expressly designated as a high reliability product or a product for harsh environments in a Renesas Electronics data sheet or other Renesas
Electronics document, Renesas Electronics products are not intended or authorized for use in products or systems that may pose a direct threat to
human life or bodily injury (artificial life support devices or systems; surgical implantations; etc.), or may cause serious property damage (space
system; undersea repeaters; nuclear power control systems; aircraft control systems; key plant systems; military equipment; etc.). Renesas Electronics
disclaims any and all liability for any damages or losses incurred by you or any third parties arising from the use of any Renesas Electronics product
that is inconsistent with any Renesas Electronics data sheet, user's manual or other Renesas Electronics document.
No semiconductor product is absolutely secure. Notwithstanding any security measures or features that may be implemented in Renesas Electronics
hardware or software products, Renesas Electronics shall have absolutely no liability arising out of any vulnerability or security breach, including but
not limited to any unauthorized access to or use of a Renesas Electronics product or a system that uses a Renesas Electronics product. RENESAS
ELECTRONICS DOES NOT WARRANT OR GUARANTEE THAT RENESAS ELECTRONICS PRODUCTS, OR ANY SYSTEMS CREATED USING
RENESAS ELECTRONICS PRODUCTS WILL BE INVULNERABLE OR FREE FROM CORRUPTION, ATTACK, VIRUSES, INTERFERENCE,
HACKING, DATA LOSS OR THEFT, OR OTHER SECURITY INTRUSION (“Vulnerability Issues”). RENESAS ELECTRONICS DISCLAIMS ANY AND
ALL RESPONSIBILITY OR LIABILITY ARISING FROM OR RELATED TO ANY VULNERABILITY ISSUES. FURTHERMORE, TO THE EXTENT
PERMITTED BY APPLICABLE LAW, RENESAS ELECTRONICS DISCLAIMS ANY AND ALL WARRANTIES, EXPRESS OR IMPLIED, WITH
RESPECT TO THIS DOCUMENT AND ANY RELATED OR ACCOMPANYING SOFTWARE OR HARDWARE, INCLUDING BUT NOT LIMITED TO
THE IMPLIED WARRANTIES OF MERCHANTABILITY, OR FITNESS FOR A PARTICULAR PURPOSE.
When using Renesas Electronics products, refer to the latest product information (data sheets, user’'s manuals, application notes, “General Notes for
Handling and Using Semiconductor Devices” in the reliability handbook, etc.), and ensure that usage conditions are within the ranges specified by
Renesas Electronics with respect to maximum ratings, operating power supply voltage range, heat dissipation characteristics, installation, etc. Renesas
Electronics disclaims any and all liability for any malfunctions, failure or accident arising out of the use of Renesas Electronics products outside of such
specified ranges.
Although Renesas Electronics endeavors to improve the quality and reliability of Renesas Electronics products, semiconductor products have specific
characteristics, such as the occurrence of failure at a certain rate and malfunctions under certain use conditions. Unless designated as a high reliability
product or a product for harsh environments in a Renesas Electronics data sheet or other Renesas Electronics document, Renesas Electronics
products are not subject to radiation resistance design. You are responsible for implementing safety measures to guard against the possibility of bodily
injury, injury or damage caused by fire, and/or danger to the public in the event of a failure or malfunction of Renesas Electronics products, such as
safety design for hardware and software, including but not limited to redundancy, fire control and malfunction prevention, appropriate treatment for
aging degradation or any other appropriate measures. Because the evaluation of microcomputer software alone is very difficult and impractical, you are
responsible for evaluating the safety of the final products or systems manufactured by you.

. Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental compatibility of each Renesas

Electronics product. You are responsible for carefully and sufficiently investigating applicable laws and regulations that regulate the inclusion or use of
controlled substances, including without limitation, the EU RoHS Directive, and using Renesas Electronics products in compliance with all these
applicable laws and regulations. Renesas Electronics disclaims any and all liability for damages or losses occurring as a result of your noncompliance
with applicable laws and regulations.

. Renesas Electronics products and technologies shall not be used for or incorporated into any products or systems whose manufacture, use, or sale is

prohibited under any applicable domestic or foreign laws or regulations. You shall comply with any applicable export control laws and regulations
promulgated and administered by the governments of any countries asserting jurisdiction over the parties or transactions.

It is the responsibility of the buyer or distributor of Renesas Electronics products, or any other party who distributes, disposes of, or otherwise sells or
transfers the product to a third party, to notify such third party in advance of the contents and conditions set forth in this document.

This document shall not be reprinted, reproduced or duplicated in any form, in whole or in part, without prior written consent of Renesas Electronics.
Please contact a Renesas Electronics sales office if you have any questions regarding the information contained in this document or Renesas
Electronics products.

“Renesas Electronics” as used in this document means Renesas Electronics Corporation and also includes its directly or indirectly controlled
subsidiaries.

(Note2)

Corporate Headquarters
TOYOSU FORESIA, 3-2-24 Toyosu,
Koto-ku, Tokyo 135-0061, Japan
www.renesas.com

Trademarks

Renesas and the Renesas logo are trademarks of Renesas Electronics
Corporation. All trademarks and registered trademarks are the property
of their respective owners.

“Renesas Electronics product(s)” means any product developed or manufactured by or for Renesas Electronics.

(Rev.5.0-1 October 2020)

Contact information

For further information on a product, technology, the most up-to-date
version of a document, or your nearest sales office, please visit:
www.renesas.com/contact/.

© 2026 Renesas Electronics Corporation. All rights reserved.
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