Renesas Synergy™ Platform

GUIX "Hello World" for SK-S7G2 and PK-S5D9

Introduction
This application note guides you through the process of creating a simple two-screen GUI using GUIX Studio™ for the SK-S7G2 and PK-S5D9 kits for the Synergy MCU family. This application project demonstrates how you can create and configure a new application using the Renesas Synergy™ Software Package (SSP).

The Synergy Software Package includes Express Logic’s ThreadX® real-time operating system (RTOS), the X-Ware™ suite of stacks (NetX™, USBX™, GUIX™, and FileX®), and a set of hardware drivers unified under a single robust framework. This powerful suite of tools provides a comprehensive integrated framework for rapid development of complex embedded applications.

The Hello World application was developed within e² studio using the Renesas Synergy™ Platform.

Target Device
- SK-S7G2 Starter Kit for Synergy MCUs v3.1
- PK-S5D9 Evaluation Kit Synergy MCUs v1.0

Minimum PC
- Microsoft® Windows® 7
- Intel® Core™ family processor running at 2.0 GHz or higher (or equivalent processor)
- 8-GB memory
- 250-GB hard disk or SSD
- USB 2.0
- Internet connection.

Installed Software
- Synergy™ e² studio Integrated Solution Development Environment (ISDE) Version 2021 (21.7.0) or later
- Synergy™ Software Package (SSP) v2.2.0 or later
- GUIX Studio v6.1.8 or later

Note: If you do not have one of these software applications, you should install it before continuing. You can download the required software from the Renesas Synergy™ Gallery at:
www.renesas.com/synergy/software

Source Files Provided
- guiapp_event_handlers.c
- main_thread_entry.c
- lcd_setup.c
- lcd.h

Note: You can use the Source_SK or Source_PK files, depending on your project.

Purpose
This guide takes you through the setup of a GUIX touch screen interface Hello World application in e² studio, where you configure hardware functions (LCD, SPI, and I²C interface), threads, as well as message passing, interrupts, the LCD driver, and the touchscreen. It covers initial project setup in e² studio, along with basic debugging operations. It also instructs you in creating a simple GUI interface using the GUIX Studio editor. Once the application is running, it responds to touchscreen actions using the Touch Panel V2 Framework on sf_touch_panel_v2 framework, presenting a basic graphical user interface (GUI).
Intended Audience
The intended audience are developers designing GUI applications

Contents
1. Overview.................................................................................................................................... 3
2. Importing the project into e² studio ............................................................................................ 3
3. Creating the project in e² studio................................................................................................. 3
4. Configuring the project in e² studio.......................................................................................... 10
5. Creating the GUIX Interface using GUIX Studio...................................................................... 30
6. Adding code for custom interface controls and building the project ........................................ 43
7. Running the application........................................................................................................... 45
8. Appendix.................................................................................................................................. 48

Revision History.............................................................................................................................. 50
1. Overview

This application note shows how to set up a project and develop a simple GUI-based application using GUIX Studio.

2. Importing the project into e² studio

Note: This step is included to give you the ability to skip the development steps and start at the point of verifying a working project on the SK-S7G2 Synergy MCU Group or the PK-S5D9 Synergy MCU Group. You can skip this step and proceed to section 3 to create a project in e² studio. If you do import the project, skip to section 7, Running the application.

To skip the development walkthrough in this document and open a completed project in e² studio, see Renesas Synergy™ Project Import Guide (RENR11an0023eu0121-synergy-ssp-import-guide_APN_20181022.pdf) in this package. It contains instructions on importing the project into e² studio and building the project. The included GUIX_Hello_World_SK-S7G2.zip and GUIX_Hello_World_PK-S5D9.zip files contain the completed project.

3. Creating the project in e² studio

Start by creating a new project in e² studio.

1. Open e² studio by clicking the e² studio icon in the Windows Start Menu > All Programs > Renesas Electronics e² studio folder.
2. If the Workspace Launcher dialog box appears, click OK to use the default workspace.

![Figure 1. Workspace Launcher Dialog](#)

3. Create a new workspace:
   From the File drop-down menu, select Switch Workspace > Other…
4. Append a workspace name:
   In the Workspace Launcher window, add text to the end of the workspace name to make it unique, such as GUI_APP. If you installed at the default location, the new workspace name will be C:\Users\[User name]e2_studio\workspace\GUI_APP.
5. Click OK to create the new workspace.
6. Proceed past the **Welcome** screen by closing the **Welcome** tab.

![Figure 2. Close the Welcome Window by clicking in the Workbench Area](image)

7. Start a new project by clicking the drop-down menu next to the **New** icon in the Tool Bar.

![Figure 3. Start a New Project](image)

8. Select **Synergy C/C++ Project** from the menu.

![Figure 4. Select Synergy C/C++ Project in the drop-down menu](image)
9. Select **Renesas Synergy C Executable Project**.

![Project type selection](image)

**Figure 5. Project type selection**

10. Enter a name for the project in the **Project name** text field. For example, **GUIApp**.

![Enter a project name](image)

**Figure 6. Enter a project name**

11. On the top right of this page, verify that the **Toolchains** option is set to **GCC ARM Embedded**.

![Verify GCC ARM Embedded Toolchain](image)

**Figure 7. Verify GCC ARM Embedded Toolchain**

12. Click the **Next** button to continue.
13. Under **Device Selection** (top left), select **SSP version** as v2.1.0 (or later).
14. For **Board** field, select **S7G2 SK**. The **Device** field updates automatically.

![Figure 8. SK-S7G2 Device Selection](image)
15. For the **Board** field, select **S5D9 PK** if using PK-S5D9 board. The **Device** field updates automatically.

![Figure 9. PK-S5D9 Device selection](image)

16. Click the **Next button** to continue.
17. In the **Project Configuration** dialog, select the option **BSP**.

![Figure 10. Select BSP](image)

18. Click the **Finish** button.

19. If you have not directed e² studio to remember your perspectives, e² studio displays the **Open Associated Perspective?** Dialog box. If opened, click **Yes** to acknowledge and close.

![Figure 11. Open Associated Perspective dialog box](image)
When the project is created, e² studio displays the following screen.

![GUIApp project](image)

**Figure 12. GUIApp project**

Note: The settings applicable for PK-S5D9 Synergy MCU Group are the same as SK-S7G2 Synergy MCU Group unless explicitly specified.
4. Configuring the project in e² studio

Once successfully created in the e² studio ISDE, the project can be configured for the GUI application.

1. Open the Synergy Configuration, if not already open, by double-clicking the configuration.xml file in the Project Explorer window.

![Selecting the configuration.xml file in Project Explorer](image1)

2. In the Synergy Configuration window, click the Threads tab.

![Synergy Configuration Threads tab](image2)


![Create a New Thread](image3)

4. Click New Thread to display the properties.
5. Edit the Properties to match the following.

![Configure Main Thread Properties](image4)
6. Back in the Synergy Configuration window, Threads tab, Main Thread Stacks area, click New. Note: Be sure that Main Thread is selected before adding new modules.

Figure 17. Main Thread Stacks


Figure 18. Adding Touch Panel framework

8. Configure the following properties.

Figure 19. Configure Touch Panel properties
9. In the **Synergy Configuration** window > **Threads** tab > **Main Thread Stacks** area, click on **Add Touch Driver** > **New** > **Touch_panel_chip_sx8654**.

10. Configure the **Touch_panel_chip_sx8654** Properties as shown.
Notice that the Synergy Configurator has already created the external IRQ framework and has a placeholder for the external IRQ and I²C driver stacks. The Touch Panel V2 Framework module scans data from a touch controller and invokes the user registered touch panel callback when a touch event occurs. (If the user callback is not registered, the `sf_touch_panel_v2_api_t::touchDataGet` API function can be used to retrieve the data). The SF External Interrupt is a framework layer used by the touch controller driver as shown below.

**Figure 22.** Configure the properties for External IRQ Framework Stack

11. Select **External IRQ Driver on r_icu**. Configure the properties for the new module as shown. Hint: **Change the Channel first!**

**Figure 23.** Configure the properties for IRQ Driver on r_icu
12. In the **Synergy Configuration** window > **Threads** tab > **Main Thread Stacks** area, click on `g_sf_i2c_device0 I2C Framework Device on sf_i2c`. Configure the properties for `g_sf_i2c_device0 I2C Framework Device on sf_i2c`.

![](image1.png)

**Figure 24.** Configure the properties for `g_sf_i2c_device0 I2C Framework Device on sf_i2c`.

13. In the **Synergy Configuration** window > **Threads** tab > **Main Thread Stacks** area, click `g_sf_i2c_bus0 I2C Framework Shared Bus on sf_i2c`. Configure the properties for `g_sf_i2c_bus0 I2C Framework Shared Bus on sf_i2c`.

![](image2.png)

**Figure 25.** Configure `g_sf_i2c_bus0 I2C Framework Shared Bus on sf_i2c`
14. In the **Synergy Configuration window > Threads tab > Main Thread Stacks area**, click on **Add I2C Driver > New > I2C Master Driver on r_rlic**.

![Figure 26. Add I2C Master Driver on r_rlic](image)

15. In the **Synergy Configuration Window > Threads tab > Main Thread Stacks area**, click on **I2C Master Driver on r_rlic** and configure the properties for **I2C Master Driver on r_rlic**.

![Figure 27. Configuring I2C Driver](image)
16. In the **Synergy Configuration** window > **Threads** tab > **Main Thread Stacks** area, click on **g_transfer4 Transfer Driver on r_dtc SCI7 TXI** and configure the properties for **g_transfer4 Transfer Driver on r_dtc SCI7 TXI**.

![Figure 28. Configure the Properties of g_transfer4 Transfer Driver on r_dtc SCI7 TXI](image)

17. In the **Synergy Configuration** window > **Threads** tab > **Main Thread Stacks** area, click on **g_transfer5 Transfer Driver on r_dtc SCI7 RXI** and configure the properties for **g_transfer4 Transfer Driver on r_dtc SCI7 RXI**.

![Figure 29. Configure the Properties of g_transfer5 Transfer Driver on r_dtc SCI7 RXI](image)
18. Under **Main Thread Stacks**, select **New Stack**, then **X-Ware > GUI > GUIX on gx**.

**Figure 30. Adding Framework for GUIX on gx**

Notice that the Synergy Configurator has already created the **GUI Port on sf_el_gx framework**, **Display Driver** and has a placeholder for the JPEG decode and D/AVE hardware accelerator stacks.

19. Select **GUIX on gx** and configure the following **Properties**.

**Figure 32. GUIX on gx Properties**
20. Add JPEG Common to the Decode Driver on r_jpeg_decode.

![Figure 33. JPEG Common module]

21. Select GUIX Port on sf_el_gx and configure the following properties.

![Figure 34. Configure GUIX Port property]

22. Select the JPEG Decode Driver on r_jpeg and configure the following interrupt properties. Note that Priority 3 is just an arbitrary number.

![Figure 35. JPEG Decode Driver on r_jpeg properties]
23. Under **Main Thread Stacks**, select **D/AVE 2D Port on sf_tes_2d_drw** and configure the following properties.

<table>
<thead>
<tr>
<th>Property</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Work memory size for display lists in bytes</td>
<td>32768</td>
</tr>
<tr>
<td>DRW Interrupt Priority</td>
<td>Priority 3 (CM4: valid, CM0+: lowest - not valid if using ThreadX)</td>
</tr>
</tbody>
</table>

**Figure 36. D/AVE 2D Port Properties**

24. Under **Main Thread Stacks**, select **Display Driver on r_glcd** and configure the following interrupt properties.

<table>
<thead>
<tr>
<th>Property</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line Detect Interrupt Priority</td>
<td>Priority 3 (CM4: valid, CM0+: lowest - not valid if using ThreadX)</td>
</tr>
<tr>
<td>Underflow 1 Interrupt Priority</td>
<td>Priority 3 (CM4: valid, CM0+: lowest - not valid if using ThreadX)</td>
</tr>
<tr>
<td>Underflow 2 Interrupt Priority</td>
<td>Priority 3 (CM4: valid, CM0+: lowest - not valid if using ThreadX)</td>
</tr>
</tbody>
</table>

**Figure 37. Interrupt Properties**

25. Configure the following properties for **Graphics Screen 1**.

<table>
<thead>
<tr>
<th>Module</th>
<th>Display Driver on r_glcd</th>
<th>Name</th>
<th>g_display</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name of display callback function to be defined by user</td>
<td>NULL</td>
<td>Internal clock(GLCDCLK)</td>
</tr>
<tr>
<td>Input - Panel clock source select</td>
<td>Input - Graphics screen1</td>
<td>Used</td>
<td></td>
</tr>
<tr>
<td>Input - Graphics screen1 frame buffer name</td>
<td>Input - Graphics screen1 frame buffer</td>
<td>hbg_background</td>
<td></td>
</tr>
<tr>
<td>Input - Number of Graphics screen1 frame buffer</td>
<td>Input - Graphics screen1 input horizontal size</td>
<td>2</td>
<td>256</td>
</tr>
<tr>
<td>Input - Section where Graphics screen1 frame buffer allocated</td>
<td>Input - Graphics screen1 input vertical size</td>
<td>bss</td>
<td>320</td>
</tr>
<tr>
<td>Input - Graphics screen1 input horizontal stride (not bytes but pixels)</td>
<td>Input - Graphics screen1 input format</td>
<td>256</td>
<td>16 bits RGB555</td>
</tr>
<tr>
<td>Input - Graphics screen1 input line descending</td>
<td>Input - Graphics screen1 input line descending</td>
<td>Not used</td>
<td></td>
</tr>
<tr>
<td>Input - Graphics screen1 input lines repeat</td>
<td>Input - Graphics screen1 input lines repeat times</td>
<td>Off</td>
<td></td>
</tr>
<tr>
<td>Input - Graphics screen1 layer coordinate X</td>
<td>Input - Graphics screen1 layer coordinate X</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Input - Graphics screen1 layer coordinate Y</td>
<td>Input - Graphics screen1 layer coordinate Y</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Input - Graphics screen1 layer background color alpha</td>
<td>Input - Graphics screen1 layer background color Red</td>
<td>255</td>
<td>255</td>
</tr>
<tr>
<td>Input - Graphics screen1 layer background color Green</td>
<td>Input - Graphics screen1 layer background color Blue</td>
<td>255</td>
<td>255</td>
</tr>
<tr>
<td>Input - Graphics screen1 layer fading control</td>
<td>Input - Graphics screen1 layer fading control</td>
<td>None</td>
<td>None</td>
</tr>
<tr>
<td>Input - Graphics screen1 layer fade speed</td>
<td></td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

**Figure 38. Graphics Screen 1 properties**
26. Configure the following output properties.

<table>
<thead>
<tr>
<th>Property</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output - Horizontal total cycles</td>
<td>320</td>
</tr>
<tr>
<td>Output - Horizontal active video cycles</td>
<td>240</td>
</tr>
<tr>
<td>Output - Horizontal back porch cycles</td>
<td>6</td>
</tr>
<tr>
<td>Output - Horizontal sync signal cycles</td>
<td>4</td>
</tr>
<tr>
<td>Output - Horizontal sync signal polarity</td>
<td>Low active</td>
</tr>
<tr>
<td>Output - Vertical total lines</td>
<td>320</td>
</tr>
<tr>
<td>Output - Vertical active video lines</td>
<td>320</td>
</tr>
<tr>
<td>Output - Vertical back porch lines</td>
<td>4</td>
</tr>
<tr>
<td>Output - Vertical sync signal lines</td>
<td>4</td>
</tr>
<tr>
<td>Output - Vertical sync signal polarity</td>
<td>Low active</td>
</tr>
<tr>
<td>Output - Format</td>
<td>16 bits RGB565</td>
</tr>
<tr>
<td>Output - Endian</td>
<td>Little endian</td>
</tr>
<tr>
<td>Output - Color order</td>
<td>RGB</td>
</tr>
<tr>
<td>Output - Data Enable Signal Polarity</td>
<td>High active</td>
</tr>
<tr>
<td>Output - Sync edge</td>
<td>Rising edge</td>
</tr>
<tr>
<td>Output - Background color alpha channel</td>
<td>255</td>
</tr>
<tr>
<td>Output - Background color R channel</td>
<td>0</td>
</tr>
<tr>
<td>Output - Background color G channel</td>
<td>0</td>
</tr>
<tr>
<td>Output - Background color B channel</td>
<td>0</td>
</tr>
</tbody>
</table>

**Figure 39** Output Screen 2 properties

27. Configure the following TCON pins and clock.

<table>
<thead>
<tr>
<th>Property</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>TCON - Hsync pin select</td>
<td>LCD_TCON2</td>
</tr>
<tr>
<td>TCON - Vsync pin select</td>
<td>LCD_TCON1</td>
</tr>
<tr>
<td>TCON - DataEnable pin select</td>
<td>LCD_TCON0</td>
</tr>
<tr>
<td>TCON - Panel clock division ratio</td>
<td>1/32</td>
</tr>
</tbody>
</table>

**Figure 40** TCON settings

28. Under Main Thread Stacks, select **New Stack > Driver > Connectivity > SPI Driver on r_sci_spi**.

**Figure 41** Adding Simple SPI (on SCI) Driver
29. Configure the following properties.

<table>
<thead>
<tr>
<th>Property</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>g_spi_lcdc</td>
</tr>
<tr>
<td>Channel</td>
<td>0</td>
</tr>
<tr>
<td>Operating Mode</td>
<td>Master</td>
</tr>
<tr>
<td>Clock Phase</td>
<td>Data sampling on even edge, data variation on odd edge</td>
</tr>
<tr>
<td>Clock Polarity</td>
<td>High when idle</td>
</tr>
<tr>
<td>Mode Fault Error</td>
<td>Disable</td>
</tr>
<tr>
<td>Bit Order</td>
<td>MSB First</td>
</tr>
<tr>
<td>Bitrate</td>
<td>100000</td>
</tr>
<tr>
<td>Bit Rate Modulation Enable</td>
<td>Enable</td>
</tr>
<tr>
<td>Receive Interrupt Priority</td>
<td>Priority 3 (CM4: valid, CM5: lowest - not valid if using ThreadX)</td>
</tr>
<tr>
<td>Transmit Interrupt Priority</td>
<td>Priority 3 (CM4: valid, CM5: lowest - not valid if using ThreadX)</td>
</tr>
<tr>
<td>Transmit End Interrupt Priority</td>
<td>Priority 3 (CM4: valid, CM5: lowest - not valid if using ThreadX)</td>
</tr>
<tr>
<td>Error Interrupt Priority</td>
<td>Priority 3 (CM4: valid, CM5: lowest - not valid if using ThreadX)</td>
</tr>
</tbody>
</table>

Figure 42. Configure Simple SPI (on SCI) properties

30. Click each `g_transfer` drive and remove it by clicking **Remove** since it is not needed for the LCD.

Figure 43. Remove Transfer Drivers

31. After removing the drivers, the placeholders for adding drivers remain as shown in the following figure.

Figure 44. Transfer Drivers Placeholders
32. In the **Synergy Configuration** window, **Threads** tab, make sure the **Main thread** is still selected.

33. Under the **Main Thread Objects**, click **New Object > Semaphore**.

34. Configure the following properties.
35. In the **Synergy Configuration** window, select the **Pins** tab

![Configuration Pins](image)

**Figure 48. Configuration Pins**

36. Select **Peripherals > Connectivity:SPI > SPI0** in **Pin Selection** and change **Operation Mode** to **Disabled** in **Pin Configuration** of **SPI0**. This must be disabled to free the pins it shares with the **SCI** module.

![Disable SPI0_Pin_Option_A in Pin Configuration](image)

**Figure 49. Disable SPI0_Pin_Option_A in Pin Configuration**

37. Select **Peripherals > Connectivity:SCI > SCI0** in **Pin Selection** and make the following configuration in **Pin Configuration** of the **SCI0** module.

![Configure SCI0 Pin Configuration](image)

**Figure 50. Configure SCI0 Pin Configuration**
38. Select **Peripherals > Connectivity: IIC > IIC2** as the **Pin Selection** and enable the IIC2 module in the **Pin Configuration**.

![Figure 51. Configure IIC2 Pin Configuration](image)

39. Select **Ports > P1 > P115** in **Pin Selection** and configure **GPIO** in **Pin Configuration**. This pin is connected with the LCD panel on the SK-S7G2 board to control data access timing from LCD_WR signal.

![Figure 52. P115 configuration](image)
40. Select **Ports > P6** in **Pin Selection** and configure **P609** (RESET# for Touch Panel), **P610** (LCD_RESET), and **P611** (LCD_CS) with output mode of **GPIO**.

![Figure 53. P609, P610 and P611 configurations](image)

41. Configure **Drive Capacity** to **High** for all pins related to **GLCDC_Controller_Pin_Option_B** as shown in Figure 54. There are two methods for setting the **Drive Capacity to High**. You may pick either one (A or B).

A. You can confirm which pins would be used for **GLCDC_Controller_Pin_Option_B** by referring to Figure 54. through Figure 56.

![Figure 54. Example of Drive Capability configuration for GLCDC](image)
Figure 55. Pin assignment for GLCD_Controller_Pin_Option_B
Figure 56. Pin assignment for GLCD_Controller_Pin_Option_B (continued)
B. You can also set the pins by port. Below is an ordered list of the pins that must have the Drive Capacity set to High. You can access these ports by going to Ports > PX > PXYZ, where X is the second digit of the port from the list, and PXYZ is the entire port. Once the port is selected, set the Drive Capacity to High as shown in Figure 57.

<table>
<thead>
<tr>
<th>S7G2 Pin</th>
</tr>
</thead>
<tbody>
<tr>
<td>P313</td>
</tr>
<tr>
<td>P314</td>
</tr>
<tr>
<td>P315</td>
</tr>
<tr>
<td>P606</td>
</tr>
<tr>
<td>P607</td>
</tr>
<tr>
<td>P615</td>
</tr>
<tr>
<td>P802</td>
</tr>
<tr>
<td>P803</td>
</tr>
<tr>
<td>P804</td>
</tr>
<tr>
<td>P900</td>
</tr>
<tr>
<td>P901</td>
</tr>
<tr>
<td>P905</td>
</tr>
<tr>
<td>P906</td>
</tr>
<tr>
<td>P907</td>
</tr>
<tr>
<td>P908</td>
</tr>
<tr>
<td>PA00</td>
</tr>
<tr>
<td>PA01</td>
</tr>
<tr>
<td>PA08</td>
</tr>
<tr>
<td>PA09</td>
</tr>
<tr>
<td>PA10</td>
</tr>
</tbody>
</table>

Figure 57. Ordered list of ports to configure as high drive capacity

42. Save the project by pressing Ctrl + s on the keyboard.
43. Click the Generate Project Content button to update the project files.
44. In the **Project Explorer** window, right-click **src** and select **New > Folder** to bring up the **New Folder** dialog box.

![Creating a New Folder](image1)

**Figure 59. Creating a New Folder**

45. Enter the name of the new folder, **hardware**, in the **Folder name:** text box.

![New Folder Dialog](image2)

**Figure 60. New Folder Dialog**

46. Click the **Finish** button.
47. The folder appears in **Project Explorer** shown below.

![Hardware folder](image3)

**Figure 61. Hardware folder**
48. Open Windows Explorer and navigate to where you put the files included with this application note. Locate the file `Source_PK` or `Source_SK Files\lcd.h`. Now drag the file from the Windows Explorer window into the new hardware folder inside the e² studio Project Explorer window.

49. When prompted to import the selected files, click OK to copy the files.

![File Operation dialog](image)

**Figure 62. File Operation dialog**

Note: This file contains the command definitions to control LCD panel.

50. Open Windows Explorer and navigate to where you put the files included with this application note. Locate the file `Source_PK` or `Source_SK Files\lcd_setup.c`. Now drag the file from the Windows Explorer window into the hardware folder inside the e² studio Project Explorer window.

51. When prompted to import the selected files, click OK to copy the files.

Note: This file contains command protocol through SPI to LCD panel and the initialization sequence.

52. Open Windows Explorer and navigate where you put the files included in this application note. Locate the file `Source Files\main_thread_entry.c`. Now drag the file from the Windows Explorer window into the src folder inside the e² studio Project Explorer window.

53. When prompted to import the selected files, click OK to copy the files.

54. When prompted to overwrite, click Yes.

Note: This file contains the Main Thread event handling code. It reads low level touchscreen events from the queue and transforms them to graphical user interface actions.

5. Creating the GUIX Interface using GUIX Studio

Now that the base project is set up, you can start adding the GUIX components.

1. Create a new folder named gui inside the src by right clicking on the src folder and selecting New > Folder.

![Creating a gui folder under the src folder](image)

**Figure 63. Creating a gui folder under the src folder**
2. Create another new folder named **guix_studio** in the root folder of the project by right-clicking **GUIApp** and selecting **New > Folder**. The final folder layout should look like the figure below.

![Figure 64. Final Folder list](image)

3. Open GUIX Studio by clicking the desktop icon or by clicking the **GUIX Studio** icon in the **Windows Start menu, All Programs > Express Logic > GUIX Studio 6.1.8.0** folder.

![Figure 65. Start GUIX Studio](image)

4. In the **Recent Projects** dialog, click **Create New Project**…

![Figure 66. Create New Project](image)

5. Name the project **guiapp**.

Important: Filenames are generated by appending names to the project name. Be aware that the project name is case-sensitive. Later, files will be added to the project that you have named **guiapp**.

6. For the project path, browse to the location of the folder we created earlier called **guix_studio**.

Note: If you installed the tools into the default directories, the folder will be located at

```plaintext
C:\Users\[User]\e2_studio\workspace\GUIAPP\GUIApp\guix_studio
```

![Figure 67. Create a New GUIX project](image)

7. Click **Save**.
8. Change the **Directories** for all three options to `..\src\gui`.

![Figure 68. Correct the file Locations](image)

**Important:** Make sure you put in two periods `..` in the directories above.

9. Change the **Target CPU** setting to **Renesas Synergy**.
10. Change the **Toolchain** setting to **GNU** and select the latest **GUIX Library Version**.

![Figure 69. Target and GUIX version settings](image)

11. Click **Advanced Settings**. A dialog will appear.
12. Enable the **2D Drawing Engine** and **Hardware JPEG Decoder** as shown in the following screen.

![Figure 70. Synergy Advanced Settings](image)

13. Click **Save**.
14. Setup the Display Configuration as shown below.

![Display Configuration Image]

Figure 71. Configure Project

15. Click Save to generate the project.
16. Right-click display_1 in the Project View.
17. Select Insert > Window > Window.

![Project View Image]

Figure 72. New Window
18. Modify the properties by selecting the new window and editing the **Properties View**. Update the current settings to match the following. Notice the **Event Function** field. This is the event that will be initiated when the touch screen is pressed in window1.

![Properties View for window1]

**Figure 73. Configure window1 properties**

19. Notice the window does not occupy the entire display. This is expected when working with GUIX with small screens and does affect the display once the application is running.

20. In the **Project View** window, right-click **display_1** and create another window by selecting **Insert > Window > Window**.

21. Modify the properties to match the following. Notice the **Event Function** field. This is the event that will be initiated when the touch screen is pressed in window2.

![Properties View for window2]

**Figure 74. Configure window2 properties**
22. In the **Project View**, right-click **window1** and insert a Text Button by selecting **Insert > Button > Text Button**.

![Figure 75. Add a New Text Button](image)

23. In the **Project View**, right-click **window1** and insert a Button Checkbox by selecting **Insert > Button > Checkbox**.

![Figure 76. Add a New Checkbox](image)
24. In the **Project View**, right-click **window1** and Insert a Text Prompt by selecting **Insert > Text > Prompt**.

![Figure 77. Adding New Prompt](image)

25. In the **Project View**, right-click **window1** and Insert another **Text Prompt**.

26. In the **Project View**, right-click **window2** and Insert a **Text Prompt**.

27. In the **Project View**, right-click **window2** and Insert another **Text Prompt**.

28. If you have followed these directions correctly, your **Project View** should look like the following screen.

![Figure 78. GUIX Project View](image)

29. Expand the **Strings** menu by clicking +.

![Figure 79. Strings Button](image)
30. Double-click any of the strings to open the **String Table Editor**.
31. Delete the existing strings by selecting them, then click the **Delete String** button in the **String Table Editor**.
32. Add the following **Strings** using the **Add String** button:

![String Table Editor](image)

**Figure 80. New Strings**

33. When completed, click **Save**.
34. In the **Project View** under **window1**, click the button and then modify the properties in the **Properties View** to match the following.

![Properties View](image)

**Figure 81. Configure windowchanger Button properties**
35. In the **Project View** under **window1**, click the checkbox, then modify the properties in the **Properties View** to match the following screen.

![Configure Buttonenabler Checkbox properties](image)

**Figure 82. Configure Buttonenabler Checkbox properties**
36. In the **Project View** under **window1**, click **Prompt**, then modify the properties to match the following.

![Figure 83. Configure Prompt properties](image1)

37. In the **Project View** under **window1**, click **prompt_1**, then modify the properties to match the following screen.

![Figure 84. Configure Window Text properties](image2)
38. In the **Project View** under **window2**, click **prompt_2**, then modify the properties to match the following.

![Figure 85. Configure Hello Text Prompt properties](image)

39. In the **Project View** under **window2**, click **prompt_3**, then modify the properties to match the following.

![Figure 86. Configure Window Text properties](image)
After these configuration steps, the two windows should look similar to the following images.

**Figure 87. Configured window1**

**Figure 88. Configured window2**

40. **Save** the project.

**Figure 89. Save project**

41. From the **Project** tab select **Generate All Output Files**.

**Figure 90. Generate All Output Files**
42. Click **Generate**.

![Select Export Resources](image)

**Figure 91. Select Export Resources**

43. Return to e² studio.
6. Adding code for custom interface controls and building the project

1. Open Windows Explorer and navigate to where you put the files included with this application note. Locate the file Source_PK or Source_SK Files\guiapp_event_handlers.c. Drag the file from the Windows Explorer window into the src folder inside the e² studio Project Explorer window.

2. When prompted to import the selected files, click OK to copy the files.

Note: This file contains the event management functions for the different graphical elements created in GUIX Studio (window1, window2).

GUIX handles the events that are required at a system level, but to handle custom commands like screen transitions and button actions, the event handler needs to be defined. Shown below is the event handler for window1.

```c
UINT window1_handler(GX_WINDOW *widget, GX_EVENT *event_ptr)
{
  UINT result = gx_window_event_process(widget, event_ptr);

  switch (event_ptr->gx_event_type)
  {
   case GX_SIGNAL(ID_BUTTONENABLER, GX_EVENT_TOGGLE_ON):
     button_enabled = true;
     update_text_id(widget->gx_widget_parent, ID_WINDOWCHANGER, 
     GX_STRING_ID_BUTTON_ENABLED);
     update_text_id(widget->gx_widget_parent, ID_INSTRUCTIONS, 
     GX_STRING_ID_INSTRUCT_BUTTON);
     break;
   case GX_SIGNAL(ID_BUTTONENABLER, GX_EVENT_TOGGLE_OFF):
     button_enabled = false;
     update_text_id(widget->gx_widget_parent, ID_WINDOWCHANGER, 
     GX_STRING_ID_BUTTON_DISABLED);
     update_text_id(widget->gx_widget_parent, ID_INSTRUCTIONS, 
     GX_STRING_ID_INSTRUCT_CHECKBOX);
     break;
   case GX_SIGNAL(ID_WINDOWCHANGER, GX_EVENT_CLICKED):
     if(button_enabled){
       show_window((GX_WINDOW*)&window2, (GX_WIDGET*)widget, true);
     }
     break;
   default:
     gx_window_event_process(widget, event_ptr);
   break;
  }

  return result;
}
```

Events can be routed based on the ID of the widget and the signal from GUIX. For example, the checkbox ID_BUTTONENABLER can have two states: GX_EVENT_TOGGLE_ON and GX_EVENTS_TOGGLE_OFF. When the box is unchecked and then pressed, the event GX_EVENT_TOGGLE_ON is sent to the handler after the box is checked.
3. Turn optimization off:
   A. Right-click GUIApp in the Project Explorer window and select Properties from the context menu.
   B. Within the properties window, expand the C/C++ Build tree element.
   C. Select Settings.
   D. In the Tool Settings tab, click Optimization.
   E. Change the Optimization Level to None (-O0).
   F. Click OK to save these changes.

![Figure 92. Disabling Compiler Optimizations](image)

4. Build the project by clicking the Hammer icon below the menu bar.

![Figure 93. Build the project](image)

If you followed these steps, there will be no errors reported in the build output, as the following figure shows.
7. Running the application

1. Connect the SK-S7G2 or PK-S5D9 Synergy MCU Groups (J19) to the PC with the micro USB cable.  
   Note: The application is not yet ready to be run on the target hardware. The following steps are necessary to run it.
2. Click the drop-down menu for the debug icon.
3. Select the Debug Configurations... option.
4. Under the **Renesas GDB Hardware Debugging** section, select **GUIApp Debug**.

5. Click the Debug button to start debugging.

   **Note:** If the **Debug** button is greyed out, then it is likely that there is an issue with the build. Check all steps for mismatched options.

---

4. Under the **Renesas GDB Hardware Debugging** section, select **GUIApp Debug**.

5. Click the Debug button to start debugging.

   **Note:** If the **Debug** button is greyed out, then it is likely that there is an issue with the build. Check all steps for mismatched options.

---

If asked to confirm a **Perspective Switch**, click **Yes**. (If you have previously instructed e² studio to remember your decision, this dialog box will not be displayed.).
7. Press F8 or the Resume button to start the application. It will stop at main.

![Resume Button](image)

**Figure 98. Resume Button**

8. Press F8 or the Resume button to run the code.
   Note: The GUI created earlier should display on the screen.


![Window1](image)

**Figure 99. Window1**

A. The preceding figure shows **Window1**. In this window are four elements:
   - **Button – Checkbox**: Use this button to enable navigating to **Window2**. Text is set to **Press Me!** and it is unchecked. When you click within the **Checkbox** active area, the event **window1_handler** is activated. This event is picked up inside `guiapp_event_handlers.c`, where the code toggles the checkbox then sets the text in **Text –Prompt 1** and **Button – Text Box** to the appropriate message.
   - **Button – Text Box**: This box shows which window you will go to if you press outside the **Text – Prompt 1** area. (See **Button – Checkbox** for how it is changed.) Click this area to activate the **window1_handler** event that is picked up by `guiapp_event_handlers.c`, where the code changes the window to **window2**.
   - **Text – Prompt 1**: This area instructs you how to control the demo. (See **Button – Checkbox** for how it is changed.)
   - **Text – Prompt 2**: This Prompt is used to show you what window you are in. It never changes (always shows **window1**).
B. The preceding figure shows **Window2**. In this window are two elements:

- **Text – Prompt 1**: This area presents **Hello World**. Clicking in this area initiates the `window2_handler` event which is picked up by `guiapp_event_handlers.c` and changes the active window to `window1`.

- **Text – Prompt 2**: This prompt shows you which window you are in. It never changes (always shows **window2**).

10. Press **Ctrl + F2** or the **Stop** button to end the debug session.

---

**Figure 101. Stop Button**

This concludes the GUIX "Hello World" demo for SK-S7G2 and PK-S5D9 Synergy MCU Groups.

### 8. Appendix

The GUIX image resources files are by default stored in the internal code flash. The resource files can also be stored in the external flash such as QSPI. Refer the Knowledgebase link ([https://en-support.renesas.com/knowledgeBase/18054800](https://en-support.renesas.com/knowledgeBase/18054800)) to know more about using QSPI for storing the image resource files.

Note: Users are required to set the QSPI pins drive capacity to High instead of Low when QSPI is used for external storage (on the DK-S7G2 board).
Website and Support

Visit the following URLs to learn about key elements of the Synergy Platform, download components and related documentation, and get support.

Synergy Platform MCUs  www.renesas.com/renesas-synergy-platform-mcus
Synergy Software Package  www.renesas.com/synergy/ssp
Software add-ons  www.renesas.com/synergy/addons
SSP Components  www.renesas.com/synergy/sspcomponents
MCU Components  www.renesas.com/synergy/components-synergy-mcus
Kits  www.renesas.com/synergy/kits

Synergy Solutions Gallery  www.renesas.com/synergy/solutionsgallery
Partner projects  www.renesas.com/synergy/partnerprojects
Application projects  www.renesas.com/synergy/applicationprojects

Self-service support resources:
Knowledgebase  www.renesas.com/synergy/knowledgebase
Forums  www.renesas.com/synergy/forum
Training  www.renesas.com/synergy/training
Videos  www.renesas.com/synergy/videos
Chat and web ticket  www.renesas.com/synergy/resourcelibrary
## Revision History

<table>
<thead>
<tr>
<th>Rev.</th>
<th>Date</th>
<th>Description</th>
<th>Summary</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.00</td>
<td>Jan.22.16</td>
<td>—</td>
<td>Initial version</td>
</tr>
<tr>
<td>1.01</td>
<td>Apr.12.16</td>
<td>Updated lcd_setup.c to correct semaphore naming issue</td>
<td></td>
</tr>
<tr>
<td>1.10</td>
<td>Aug.30.16</td>
<td>—</td>
<td>Update to SSP v1.1.0</td>
</tr>
<tr>
<td>1.11</td>
<td>Nov.18.16</td>
<td>—</td>
<td>Minor Format Changes</td>
</tr>
<tr>
<td>1.12</td>
<td>Jan.06.17</td>
<td>—</td>
<td>Updated to SSP v1.2.0.b.1</td>
</tr>
<tr>
<td>1.13</td>
<td>Feb.28.17</td>
<td>—</td>
<td>Updated to SSP v1.2.0</td>
</tr>
<tr>
<td>1.14</td>
<td>Sep.20.17</td>
<td>—</td>
<td>Updated to SSP v1.3.0</td>
</tr>
<tr>
<td>1.15</td>
<td>Feb.28.18</td>
<td>—</td>
<td>Updated to SSP v1.4.0</td>
</tr>
<tr>
<td>1.16</td>
<td>Jun.18.18</td>
<td>—</td>
<td>Sample codes updated</td>
</tr>
<tr>
<td>1.17</td>
<td>Sep.07.18</td>
<td>—</td>
<td>Updated to SSP v1.5.0</td>
</tr>
<tr>
<td>1.18</td>
<td>Mar.22.19</td>
<td>—</td>
<td>Updated to SSP v1.6.0</td>
</tr>
<tr>
<td>1.19</td>
<td>Aug.11.21</td>
<td>—</td>
<td>Updated for SSP v1.6.0 “Touch Panel V2 Framework”</td>
</tr>
<tr>
<td>1.20</td>
<td>Oct.14.21</td>
<td>—</td>
<td>Updated for latest SSP, e² studio, and SSC</td>
</tr>
<tr>
<td>1.21</td>
<td>Nov.11.21</td>
<td>—</td>
<td>Updated to SSP v2.1.0</td>
</tr>
<tr>
<td>1.22</td>
<td>Apr.21.23</td>
<td>—</td>
<td>Removed licensing and messaging framework content</td>
</tr>
</tbody>
</table>
General Precautions in the Handling of Microprocessing Unit and Microcontroller Unit Products

The following usage notes are applicable to all Microprocessing unit and Microcontroller unit products from Renesas. For detailed usage notes on the products covered by this document, refer to the relevant sections of the document as well as any technical updates that have been issued for the products.

1. Precaution against Electrostatic Discharge (ESD)
   A strong electrical field, when exposed to a CMOS device, can cause destruction of the gate oxide and ultimately degrade the device operation. Steps must be taken to stop the generation of static electricity as much as possible, and quickly dissipate it when it occurs. Environmental control must be adequate. When it is dry, a humidifier should be used. This is recommended to avoid using insulators that can easily build up static electricity. Semiconductor devices must be stored and transported in an anti-static container, static shielding bag or conductive material. All test and measurement tools including work benches and floors must be grounded. The operator must also be grounded using a wrist strap. Semiconductor devices must not be touched with bare hands. Similar precautions must be taken for printed circuit boards with mounted semiconductor devices.

2. Processing at power-on
   The state of the product is undefined at the time when power is supplied. The states of internal circuits in the LSI are indeterminate and the states of register settings and pins are undefined at the time when power is supplied. In a finished product where the reset signal is applied to the external reset pin, the states of pins are not guaranteed from the time when power is supplied until the reset process is completed. In a similar way, the states of pins in a product that is reset by an on-chip power-on reset function are not guaranteed from the time when power is supplied until the power reaches the level at which resetting is specified.

3. Input of signal during power-off state
   Do not input signals or an I/O pull-up power supply while the device is powered off. The current injection that results from input of such a signal or I/O pull-up power supply may cause malfunction and the abnormal current that passes in the device at this time may cause degradation of internal elements. Follow the guideline for input signal during power-off state as described in your product documentation.

4. Handling of unused pins
   Handle unused pins in accordance with the directions given under handling of unused pins in the manual. The input pins of CMOS products are generally in the high-impedance state. In operation with an unused pin in the open-circuit state, electromagnetic noise is induced in the vicinity of the LSI, an associated shoot-through current flows internally, and malfunctions occur due to the false recognition of the pin state as an input signal become possible.

5. Clock signals
   After applying a reset, only release the reset line after the operating clock signal becomes stable. When switching the clock signal during program execution, wait until the target clock signal is stabilized. When the clock signal is generated with an external resonator or from an external oscillator during a reset, ensure that the reset line is only released after full stabilization of the clock signal. Additionally, when switching to a clock signal produced with an external resonator or by an external oscillator while program execution is in progress, wait until the target clock signal is stable.

6. Voltage application waveform at input pin
   Waveform distortion due to input noise or a reflected wave may cause malfunction. If the input of the CMOS device stays in the area between \( V_{IL} \) (Max.) and \( V_{IH} \) (Min.) due to noise, for example, the device may malfunction. Take care to prevent chattering noise from entering the device when the input level is fixed, and also in the transition period when the input level passes through the area between \( V_{IL} \) (Max.) and \( V_{IH} \) (Min.).

7. Prohibition of access to reserved addresses
   Access to reserved addresses is prohibited. The reserved addresses are provided for possible future expansion of functions. Do not access these addresses as the correct operation of the LSI is not guaranteed.

8. Differences between products
   Before changing from one product to another, for example to a product with a different part number, confirm that the change will not lead to problems. The characteristics of a microprocessing unit or microcontroller unit products in the same group but having a different part number might differ in terms of internal memory capacity, layout pattern, and other factors, which can affect the ranges of electrical characteristics, such as characteristic values, operating margins, immunity to noise, and amount of radiated noise. When changing to a product with a different part number, implement a system-evaluation test for the given product.
1. Descriptions of circuits, software and other related information in this document are provided only to illustrate the operation of semiconductor products and application examples. You are fully responsible for the incorporation or any other use of the circuits, software, and information in the design of your product or system. Renesas Electronics disclaims any and all liability for any losses and damages incurred by you or third parties arising from the use of the circuits, software, or information.

2. Renesas Electronics hereby expressly disclaims any warranties against and liability for infringement or any other claims involving patents, copyrights, or other intellectual property rights of third parties, by or arising from the use of Renesas Electronics products or technical information described in this document, including but not limited to, the product data, drawings, charts, programs, algorithms, and application examples.

3. No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights of Renesas Electronics or others.

4. You shall be responsible for determining what licenses are required from any third parties, and obtaining such licenses for the lawful import, export, manufacture, sales, utilization, distribution or other disposal of any products incorporating Renesas Electronics products, if required.

5. You shall not alter, modify, copy, or reverse engineer any Renesas Electronics product, whether in whole or in part. Renesas Electronics disclaims any and all liability for any losses or damages incurred by you or third parties arising from such alteration or modification, copying or reverse engineering.

6. Renesas Electronics products are classified according to the following two quality grades: “Standard” and “High Quality”. The intended applications for each Renesas Electronics product depends on the product’s quality grade, as indicated below.

   - “Standard”: Computers; office equipment; communications equipment; test and measurement equipment; audio and visual equipment; home electronic appliances; machine tools; personal electronic equipment; industrial robots; etc.
   - “High Quality”: Transportation equipment (automobiles, trains, ships, etc.); traffic control (traffic lights); large-scale communication equipment; key financial terminal systems; safety control equipment; etc.

   Unless expressly designated as a high reliability product or a product for harsh environments in a Renesas Electronics data sheet or other Renesas Electronics document, Renesas Electronics products are not intended or authorized for use in products or systems that may pose a direct threat to human life or bodily injury (artificial life support devices or systems; surgical implants; etc.), or may cause serious property damage (space systems; underwater repeaters; nuclear power control systems; aircraft control systems; key plant systems; military equipment; etc.). Renesas Electronics disclaims any and all liability for any damages or losses incurred by you or any third parties arising from the use of any Renesas Electronics product that is inconsistent with any Renesas Electronics data sheet, user’s manual or other Renesas Electronics document.

7. No semiconductor product is absolutely secure. Notwithstanding any security measures or features that may be implemented in Renesas Electronics hardware or software products, Renesas Electronics shall have absolutely no liability arising out of any vulnerability or security breach, including but not limited to any unauthorized access to or use of a Renesas Electronics product or a system that uses a Renesas Electronics product. RENESAS ELECTRONICS DOES NOT WARRANT OR GUARANTEE THAT RENESAS ELECTRONICS PRODUCTS, OR ANY SYSTEMS CREATED USING RENESAS ELECTRONICS PRODUCTS WILL BE INVULNERABLE OR FREE FROM CORRUPTION, ATTACK, VIRUSES, INTERFERENCE, HACKING, DATA LOSS OR THEFT, OR OTHER SECURITY INTRUSION (“Vulnerability Issues”). RENESAS ELECTRONICS DISCLAIMS ANY AND ALL RESPONSIBILITY OR LIABILITY ARISING FROM OR RELATED TO ANY VULNERABILITY ISSUES. FURTHERMORE, TO THE EXTENT PERMITTED BY APPLICABLE LAW, RENESAS ELECTRONICS DISCLAIMS ANY AND ALL WARRANTIES, EXPRESS OR IMPLIED, WITH RESPECT TO THIS DOCUMENT AND ANY RELATED OR ACCOMPANYING SOFTWARE OR HARDWARE, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, OR FITNESS FOR A PARTICULAR PURPOSE.

8. When using Renesas Electronics products, refer to the latest product information (data sheets, user’s manuals, application notes, “General Notes for Handling and Using Semiconductors Devices” in the reliability handbook, etc.), and ensure that usage conditions are within the ranges specified by Renesas Electronics with respect to maximum ratings, operating power supply voltage range, heat dissipation characteristics, installation, etc. Renesas Electronics disclaims any and all liability for any malfunctions, failure or accident arising out of the use of Renesas Electronics products outside of such specified ranges.

9. Although Renesas Electronics endeavors to improve the quality and reliability of Renesas Electronics products, semiconductor products have specific characteristics, such as the occurrence of failure at a certain rate and malfunctions under certain use conditions. Unless designated as a high reliability product or a product for harsh environments in a Renesas Electronics data sheet or other Renesas Electronics document, Renesas Electronics products are not subject to radiation resistance design. You are responsible for implementing safety measures to guard against the possibility of bodily injury, injury or damage caused by fire, and/or danger to the public in the event of a failure or malfunction of Renesas Electronics products, such as safety design for hardware and software, including but not limited to redundancy, fire control and malfunction prevention, appropriate treatment for aging degradation or any other appropriate measures. Because the evaluation of microcomputer software alone is very difficult and impractical, you are responsible for evaluating the safety of the final products or systems manufactured by you.

10. Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental compatibility of each Renesas Electronics product. You are responsible for carefully and sufficiently investigating applicable laws and regulations that regulate the inclusion or use of controlled substances, including without limitation, the EU RoHS Directive, and using Renesas Electronics products in compliance with all these applicable laws and regulations. Renesas Electronics disclaims any and all liability for damages or losses occurring as a result of your noncompliance with applicable laws and regulations.

11. Renesas Electronics products and technologies shall not be used for or incorporated into any products or systems whose manufacture, use, or sale is prohibited under any applicable domestic or foreign laws or regulations. You shall comply with any applicable export control laws and regulations promulgated and administered by the governments of any countries asserting jurisdiction over the parties or transactions.

12. It is the responsibility of the buyer or distributor of Renesas Electronics products, or any other party who distributes, disposes of, or otherwise sells or transfers the product to a third party, to notify such third party in advance of the contents and conditions set forth in this document.

13. This document shall not be reprinted, reproduced or duplicated in any form, in whole or in part, without prior written consent of Renesas Electronics.

14. Please contact a Renesas Electronics sales office if you have any questions regarding the information contained in this document or Renesas Electronics products.

(Rev.5.0-1  October 2020)