e® studio 2.2
Installing into Existing Eclipse Environment

Introduction

Renesas e2 studio can be installed as a set of plugins into an existing Eclipse environment. This guide details the process
for installing these plugins and the required Eclipse environment. It also details the procedure for updating e? studio
plugins already installed into an Eclipse environment.
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e? studio 2.2 Installing into Existing Eclipse Environment

1. Requirements

1.1 Eclipse
e’ studio 2.2 has been developed for use with Eclipse 3.8.2. While installation into later versions of Eclipse may be
possible, full functionality cannot be guaranteed.

This installation procedure has been tested in Eclipse 3.8.2 & 4.2.2. While installing into Eclipse 4.2 is possible, e
studio has not been fully tested in this environment and issues may be encountered.

There are known issues using e studio plugins in 64 bit versions of Eclipse. On 64 bit operating systems use of the 32
bit version of Eclipse is recommended.

111 CDT

e? studio 2.1 uses a modified version of CDT 8.2.1 which includes additional features and bug-fixes not included in the
standard CDT 8.2.1 release. Use of this CDT is a requirement for using e? studio plugins. This CDT is available from
the e studio Update Site and will be installed along with the e? studio plugins. The full SDK for the modified CDT,
including full source code, is available from the e studio Update Site.

If you already have CDT installed it may be necessary to manually update to the e? studio version before installation,
please see section 5.1 for instructions. This is required if the CDT SDK is installed.

1.2 Code Generation Feature

The Code Generation feature of e studio 2.2 requires .Net Framework 4. It is recommended that you do not select the
Code Generation feature unless .Net Framework 4 or 4.5 is installed.

Important: Installing the Code Generation feature requires Administrative privileges. If you have User Account
Control enabled, or are using a non-administrative account, you will be prompted for permissions as part of the
installation process.

2. Installation Methods

Renesas e’ studio plugins are available either as an internet accessible Eclipse Update Site or as a set of downloadable
archive update sites.
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e? studio 2.2

Installing into Existing Eclipse Environment

3. Installation Procedure

3.1  Adding e®studio Update Sites
1. Go to Help -> Install New Software...

@
%;.

[

Welcome

Help Contents
Search

Dynamic Help

Key Assist... Ctrl+Shift+L
Tips and Tricks...
Add Renesas Toolchains

Update Renesas Components

Cheat Sheets...
Check for Updates
Install Mew Software...

About e2Studio

2. Click the “Add” button to add the e? studio Update Sites
You will need to add the following sites:

Name

Location

e’ studio Update Site

http://tool-support.renesas.com/e2studio/

e’ studio CDT Update Site

http://tool-support.renesas.com/e2studio/e2studio?2/cdt/

(Required only if CDT already installed)

3. Enter the e” studio Update Sites Details

& Add Reposite
pository

MName: &2 studic Update Site

|21

Location:  http://tool-support.renesas.com,/e2studio/ Archive..,
@:‘ l ’ Cancel ]
4. Click OK
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e? studio 2.2 Installing into Existing Eclipse Environment

3.2 Installing e? studio Plugins

Open Install New Software
Select the e? studio Update Site
3. Select the Renesas Plugins you wish to install

@ Install @

N

Available Software

Check the items that you wish to install

|

Work with: €2 studio Update Site - http://tool-support.renesas.com/e2studio; - Add..

Find more software by working with the “Available Software Sites” preference:

Version

Select All Deselect All

Details

Hide items that are already installed

What s aleady installed?

7] Contact all update sites during install to find required software

?

| Canced |

Select “Group items by category”. Not doing so can result in e studio branding being installed into your
Eclipse environment.

Installing e? studio plugins may require the installation of additional plugins from the Eclipse Update
Site, for example EMF. To allow this please ensure “Contact all update sites during install” is checked.

You must select the following Features. To install all e studio features select all categories except “CDT
Optional Features”.
Category Feature
e’ studio CDT Required Features C/C++ Development Tools
C/C++ GDB Hardware Debugging
C/C++ Memory View Enhancements
CDT Common GDB Support

Renesas Core Feature Renesas Core Feature
Renesas Core Model Feature Renesas Core Model Feature
4. Click Next
5. Check Install Details

Verify that the following plugins are not included

* “Add-on Function for p2” — org.eclipse.equinox.p2.extras.feature.feature.group
* “e2studio” — com.renesas.product

6. Click Next and Accept the License Agreements
@ I accept the terms of the license agreements

(0 Tdo not accept the terms of the license agreements

7. Click Finish then wait for installation process to complete
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e? studio 2.2 Installing into Existing Eclipse Environment

S Install ], e S
Install Details

Review the items to be installed. :)-L_J

Name Version Id S
» 4 C/C+~ Development Teols 1201311181559  org.eclipse.cdt.feats P
[k C/C++ GDB Hardware Debugging 7.20.201311181559 rg.eclipse.cdt.debug.gdbjtag.feature.
(gt C/C++ Memory View Enhancements 0201311181550 org.eclipse.cdt.debug.ui yfestu| _
(g CDT Common GDB Support 7.21.201311181550  org.eclipse.cdt.gdb feature.group 1
G Code Generation Feature 00201311182025 ¢
L Debugger Services Framework Communication 101.201311182025  com.micrium.plugin.eclipse.ucprobe.l
L+ Direct JLink 1.01.2013111820, . mi I lipse.ucprobell
L+ €2 studio Integration Service Feature 0.2013111820, c P
[ EPL Source 0.0.2013111820; com.renesas.epl.sour
(- GDB Server Feature 11.0.201311182025  com.renesas.qdb. group
(i Green Hills MULTI for Eclipse (VB00) 217 ghs.multivB00 feature.group
L IAR Common Components 100201310181559  com.iar.commonfeature feature.groug
L IAR Common Compenents (Renesas targets) 100201310181559  com.iar.common.renesas feature featu

» i IAR Toolchain for RL78 010.201310181559 rmiar.cdtrl7

» i IAR Toelchain for RX 010.201310181559 rm.iar.cdt, ¥

» [k I4R Toolchain for V850 0.0.201310181559 m.iar.cdt.v850.
(gt 10 View Feature 11.0.201311182025  comn.renesas.cdt.debug
(gt Japanese Support 11.0.201311182025  comn.renesas.j g
L KPIT ARM-RZ Toolchain Integration 1002013118205 « dt.
G Renesas ADM Feature 1102011118205  «c d -

8. Restart when prompted
& Software Updates (S|

You will need to restart Eclipse SDK for the changes to take effect. Would you like to
restart now?

-

9. Wait while e? studio Installation is completed & Restart again
& Restart e2studio (eS|

It is mandatory to restart e2studio after e2studio update is completed

[ ok [ cancel |

You can enable notification of future updates in Preferences -> Install/Update -> Automatic Updates.
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e? studio 2.2 Installing into Existing Eclipse Environment

4. Updating from previous versions
Updating from a previous version of e’ studio plugins is supported for versions 2.0 SR2 (2.0.2) — 2.2.

1. Go to Help -> Check For Updates

2. Select all e? studio plugins

3. Continue though the wizard and restart when prompted
4. Allow the support files update to take place then restart
5. Install new e’ studio features using the instructions in 3.2

To install all new e? studio features click Select All then unselect CDT Optional Features.

It is recommended that you add the following features:

Category Feature
Renesas RX Common Features RX Common Feature
Support Tools Features RX EZCUBE Support

RX Simulator Support

SH E10A Support

RL78 - Debug Support RL78 Common Feature

Renesas e2 Solution Toolkit Renesas Smart Manual

Install the following for RZ Support:

Category Feature

Segger GDB Segger GDB Hardware Debug Core Feature
RZ JLink RZ J-Link GDB Hardware Debug Feature
KPIT RZ Toolchain Integration KPIT ARM-RZ Toolchain Integration

Install the following for Code Generation Support (See 1.2 before installing):

Category Feature
Renesas Code Generation Feature Code Generation Feature
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5. Resolving Dependency Problems

Due to the nature of the Eclipse Platform you may encounter errors when installing e? studio plugins due to conflicting
dependencies. Workarounds for common dependency problems are listed below.

5.1 CDT

Add the e? studio CDT Update Sites using the instructions in section 3.1.
Go to Window -> Preferences

8. Select Install/Update -> Available Software Sites

Disable all Update Sites except e? studio CDT Update Site

~No

© Preferences 8| %
type filter text Available Software Sites B
General
> ::"p type filter text
4 Install/Update Neme E Location Add.. |
AutomaticUpdates [¥] 9l e2 studio CDT Update Site http://tool-
Jav:“‘“h" Softuee Sites [7] ¥l €2 studio Update Site hn;://Iec\rsuppon.venesas com/e2studio/ [ e |
R — ] S1EPP Juno Package Repository | / P !:Rmm ]
Run/Debug ] lJuno htp://download.eclipse.org/releases/juno
o | ¥ The Eclipse Project Updates http://download.eclipse.org/eclipse/updates/38 Reload |
Disable |
Import..
Export..
« D
‘ i D
9. Click OK to Apply the changes
10. Go to Help -> Check For Updates
11. Select all CDT plugins and Click Next
& Available Updates = =
Available Updates -
("
Check the updates that you wish to install. 7 J)l-—
b, 3
Name Wersion Id
G Autotools support for COT 3.01.201307181744  org.eclipse.cdt.autotools.feature.group
4L C/C++ Development Toals 81.2201307181744  org.eclipse.cdt.feature.group
Ecrce+ Development Tools SDK 8.1.2.201307181744  org.eclipse.cdt.sdk feature.group
. C/Ce+ GCC Cross Compiler Support 1.1.0.201307181744  org.eclipse.cdt.build.crossgec.feature.gro...
G C/C++ GDB Hardware Debugging 7.00.201307181744  org.eclipse.cdt.debug.gdbjtag.feature.gr...
Ec/ce+ Memery View Enhancements 2.20.201307181744  org.eclipse.cdt.debug.ui.memory.feature...
(4 C/C++ Remote Launch 6.00.201307181744  org.eclipse.cdt.launch.remote feature.gr...
G C/C+ Unit Testing Support 7.0.0.201307181744  org.eclipse.cdt.testsrunner.featurefeatur...
[ CDT Visual C++ Support 1.0.0.201307181744  org.eclipse.cdt.msw.feature.group
Select All | | Deselect Al
Details
@ < Back Next » B

12. Review and the Click Next
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e? studio 2.2 Installing into Existing Eclipse Environment

r b
£ Available Updates o

Update Details 7
Review and confirm the updates. h " Dl--
Name Version Id
(i Autotools support for COT 301201307181744  org.eclipse.cdt.autotaslsfeature.group
. [k C/C++ Development Tools 81.2201307181744  org.eclipse.cdt.festure.group
. [t C/C++ Development Toels SDK 8.1.2201307181744  org.eclipse.cdt.sdk.feature.group
f“B C/C++ GCC Cross Compiler Support 11.0.201307181744  org.eclipse.cdt.build.crossgec.festure.group
(it C/C++ GDB Hardware Debugging 7.00.201307181744  org.eclipse.cdt.debug.gdbjtag feature.gro...
Lt T/CT++ Memory View Enhancements 2.20.201307181744  org.eclipse.cdt.debug.ui.memory.feature...
L C/C++ Remate Launch 6.0.0.201307181744  org.eclipse.cdtlaunch.remote feature.group
Lk C/C++ Unit Testing Support 7.00.201307181744  org.eclipse.cdttestsrunnerfeaturefeature...,
QB CDT Visual C++ Support 1.0.0.201307181744  org.eclipse.cdt.msw.feature.group

Size: 58,697 KB

Details

@ ez ][ i
13. Accept the License Agreements & Click Finish

@ I accept the terms of the license agreements

I do not accept the terms of the license agreements

14. Wait for the Installation Process to Finish then Restart
15. Repeat Steps 3 & 4 but enable any updates sites you disabled
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e? studio 2.2 Installing into Existing Eclipse Environment

6. Known Issues

Below is a list of issues which specifically effect usage after installing into an Eclipse environment. For a full list of
known issues in e” studio 2.2 please see the main release notes.

ID Description

3804 Code Generator not fully installed if it is added after installation of other e’ studio plugins.

If installing the Code Generation Feature after installing other e’ studio plugins you may need to
manually register the COM service before Code Generation becomes available during Project
Generation.

To do this create a new CCRX, GNURX or GNURL78 project, then select “New Code Generator”
from the toolbar.

2 ®-&-& N gé @

o 53 = B g typedefine.h [l 1.0,
3884 HEW Project Converter does not function in a 64-bit Eclipse Environment
3888 Code Generator does not function in a 64-bit Eclipse Environment
3899 Emulator Selection does not function in a 64-bit Eclipse Environment

- Issues may be encountered if any part the Eclipse or Project path contains spaces.
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