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Smart Configurator for RZ 

User’s Guide 

Introduction 

This application note describes the basic usage of the Smart Configurator for RZ (hereafter called the Smart 

Configurator)  

Target Devices and Compilers 

Refer to the following URL for the range of supported devices and compilers: 

https://www.renesas.com/smart-configurator 
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1. Overview 

1.1 Purpose 

This application note describes the basic usage of the Smart Configurator tool for the RZ device family.  

 

1.2 Features 

The Smart Configurator is a utility for configuring pin multiplexing settings, resolving conflicts and generating pin 

initialization code. 

 

2. Creating a Smart Configurator project 

The following describes the procedure for creating a Smart Configurator project. 

(1) Launch the Smart Configurator and select [File] → [New]. 

(2) Select a device, for example, R8A77450 from the left panel of the [New Smart Configuration File] dialog box. 

(3) Specify a [File name] and click [Finish] button as shown below.  

 

Figure 2-1  Creating a New Smart Configurator File 

 

 

 

 

 

 

 

 

(1) 

(2) 

(3) 
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3. Operating the Smart Configurator 

3.1 Procedure for Operation 

Figure 3-1 shows the procedure for using the Smart Configurator to set up pin settings, generating source code and report.  

 

Figure 3-1  Procedure for Operations 

 

3.2 File to be saved as Project Information 

The Smart Configurator saves the setting information such as the target MCU for the project, build tool, peripheral 

modules, and pin functions in a project file (*.scfg), and refers to this information. The project file from the Smart 

Configurator is saved in this following format “<project name>.scfg”. 

 

 

  

 

Start the Smart Configurator launch 

Create and load a Smart Configurator project 

file 

Configure pins 

Generate source code 

Generate reports 

Refer to section 3.4. Pin Settings. 

Refer to chapter 4. Generating Source Code. 

Refer to chapter 5. Generating Report 

Refer to chapter 2. Creating a Smart 

Configurator project 
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3.3 Window  

The configuration of the Smart Configurator perspective is shown in Figure 3-2 Smart Configurator Perspective. 

 

Figure 3-2  Smart Configurator Perspective 

 

1) Smart Configurator editor with Board & Pins page 

2) MCU Package view 

3) Console view 

4) Configuration Problems view 

 

  

 1)  2) 

 3)  4) 
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3.3.1 MCU Package view 

The states of pins are displayed on the figure of the MCU package. The settings of pins can be modified from here.  

Two types of package view can be switched between [Assigned] and [Default Board]. [Assigned] displays the 

assignment status of the pin setting, and [Default Board] displays the initial pin setting information of the board. The 

initial pin setting information of the board is the pin information of the board selected by [Board:] on the [Board] page 

(refer to "3.3.4 MCU Package View").   

 

Figure 3-3  MCU Package View    

Select [Window] → [Show View] → [Smart Configurator] → [MCU Package] to open the MCU Package View. 

 

 

3.3.2 Console view 

 

The Console view displays details of changes to the configuration made in the Smart Configurator or MCU Package view. 

 

 

Figure 3-4  Console View 

Select [Window] → [Show View] → [General] folder dropdown menu and→ [Console] from the [Show View] dialog 

box in the Smart Configurator to open the Console View. 
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3.3.3 Configuration Problems view 

 

The Configuration Problems view displays the details if there is any problem related to pin assignment. 

 

Figure 3-5  Configuration Problems View 

Select [Window] → [Show View] → [Smart Configurator] folder dropdown menu and → [Configuration Problems] 

from the [Show View] dialog box in the Smart Configurator to open the Configuration Problems view. 

 
 

3.4 Pin Settings 

The [Pins] page is used for assigning pin functions. Click on the [Pin Function] and [Pin Number] tabs to switch 

between the 2 pages. The [Pin Function] list shows the pin functions for each of the peripheral functions, and the [Pin 

Number] list shows all pins in order of pin number. 

Figure 3-6  [Pins] Page ([Pin Function]) 

 

 

 

 

 

Display switching 
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Figure 3-7  [Pins] Page ([Pin Number]) 

When you select a board on the [Board] page, the initial pin setting information of the board is displayed in [Default 

Function]. 

 

  



RZ Smart Configurator  

R20AN0574ES0100  Rev.1.00  Page 9 of 22 

July 31, 2020  

3.4.1 Assigning pins using the MCU Package view 

 

The Smart Configurator visualizes the pin assignment in the MCU Package view. You can save the MCU Package view 

as an image file, rotate it, and zoom in to and out from it. 

Follow the procedure below to assign pins in the MCU Package view. 

(1) Zoom in to the view by clicking the [  (Zoom in)] button or scrolling the view with the mouse wheel. 

(2) Right-click on the target pin.  

(3) Select the signal to be assigned to the pin. 

(4) The color of the pins can be customized through [Preferences Setting...]. 

 

           

 

Figure 3-8  Assigning Pins Using the MCU Package View  

       

  

(1) 

(2) 

(3) 

(4) 
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3.4.2 Exporting pin settings 

The pin settings can be exported for later reference. Follow the procedure below to export the pin settings. 

(1) Click on the [  (Export pin assignments)] button on the [Pins] page. 

(2) Select the output location and specify a name for the file to be exported.  

The exported XML file can be imported to another project having the same device part number. 

 

Figure 3-9  Exporting Pin Settings to an XML File 

The Smart Configurator can also export the pin settings to a CSV file. Click on the [  (Save the list to .csv file)] 

button on the [Pins] page. 

  

(1) 
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3.4.3 Importing pin settings 

 

To import pin settings into the current project, click on the [  (Import pin assignments)] button and select the XML 

file that contains the desired pin settings. After the settings specified in this file are imported to the project, the settings 

will be reflected in the [Pin configuration] page. 

 

Figure 3-10  Importing Pin Settings from an XML File   

 
 

3.4.4 Pin filter feature 

 

The filter range on the [Pin Function] tab and [Pin Number] tab on the [Pins] page can be used to filter out pin functions 

and numbers for easy search. 

 

Figure 3-11  Filter for [Pin Function] tab   

 

Figure 3-12  Filter for [Pin Number] tab   
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3.5 MCU migration feature 

The MCU migration feature helps to convert user project settings from device A to device B. Conversion of project 

settings can be done within the same family as follows. 

Note: Project settings may change due to device change. It is recommended to back up the smart configurator project 

file (*.scfg) before executing the device change. 

 

(1) Open the [Device Selection] page by clicking on the [Board] tab view. 

 

Figure 3-13  [Device Selection]   

(2)  Click on this icon     and select the target device from the device dropdown menu list. 

 

Figure 3-14  Select target device 

 

(3) Select Save and continue Or Continue to change to another target device. (E.g. change to RZ/G1H). 
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Figure 3-15  Confirm device change 

 

(4) Migration report will be generated, the report information is displayed in console window. 

 

 

Figure 3-16  Output Migration report 

(5) The migration report can be opened by clicking the hyperlink string in the console window. The reports content 

will show the pin configuration porting status. 

 

Figure 3-17  Migration report content 
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4. Generating Source Code 

4.1 Generating a Source File 

Output the source file for the configured details by clicking on the [  (Generate Code)] button in the Smart 

Configurator view. 

 

Figure 4-1  Generating a Source File 

If a file of the same name exists in the output folder, the existing source code is moved to the folder “/trash/<yyyy-mm-

dd-hh-mm-ss>/src/smc_gen/dts/”. 

The generated file can be opened directly by clicking on the link of the file from the Console view.  
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4.2 Folder Structure and output files  
 

Figure 4-2 shows the folders and file output by Smart Configurator. The root folder can be found in “C:\Users\<user 

name>\smartconfigurator\workspace.pinmux\”. 

For the RZ/G2x device series, a single *.dtsi file is generated in the device tree syntax for Linux.  

 

  

Figure 4-2  Configuration of Generated Files and File Names 

 

 

 

 

 

 

 

 

 

The generated source code feature is valid only for the RZ/G2x and RZ/G1x device series. For RZ/A1x device, no *.dtsi 

file is generated.  

 

 
  

Folder File Description 

src/smc_gen/dts  This folder is always generated. 

It consists of only r8axxxx_pinconf.dtsi file. 

r8axxxx_pinconf.dtsi This file is always generated. 

It represents a set of text files in the Linux kernel source tree 

that describe the hardware of the RZ/G2 device tree. 

smc_gen 

dts 

r8axxxx_pinconf.dtsi 

src 
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5. Generating Report on Smart Configurator 

The Smart Configurator generates a report on the configurations that the user works on. Follow the procedure below to 

generate a report. 

 

5.1 Report on Device Configurations 

A report is output by clicking on the [ (Generate Report)] button in the Smart Configurator view. 

 

 
 

Figure 5-1 Output of a Report on the Configuration (as a Text File) 

  

Figure 5-2  Dialog Box for Output of a Report 
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5.2 Configuration of Pin Function List and Pin Number List (in csv Format) 

 

A list of the configuration of pin functions and pin numbers is output by clicking on the [  (Save the list to .csv file)] 

button on the [Pins] page of the Smart Configurator view. 

 

Figure 5-3  Output of a List of Pin Functions or Numbers (in csv Format) 

 

5.3 Image of MCU Package (in png format) 

An image of the MCU package is output by clicking on the [  (Save Package View to external image file)] button 

of the [MCU Package] view. 

 

Figure 5-4  Output an image of the MCU Package (in png Format) 
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6. Help 

Refer to the help dropdown menu for detailed information on the Smart Configurator. 

 

Figure 6-1  Help Menu 

 

 

 

  

7. Documents for Reference 

User’s Manual: Hardware  

Obtain the latest version of the manual from the Renesas Electronics website. 

 

Technical Update/Technical News 

Obtain the latest information from the Renesas Electronics website. 

 

Website and Support  

Renesas Electronics Website 

http://www.renesas.com/ 

Inquiries 

http://www.renesas.com/contact/ 
 

http://www.renesas.com/
http://www.renesas.com/contact/
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1.  Handling of Unused Pins 

Handle unused pins in accordance with the directions given under Handling of Unused Pins in the 

manual. 

⎯ The input pins of CMOS products are generally in the high-impedance state. In operation with 

an unused pin in the open-circuit state, extra electromagnetic noise is induced in the vicinity of 

LSI, an associated shoot-through current flows internally, and malfunctions occur due to the 

false recognition of the pin state as an input signal become possible. Unused pins should be 

handled as described under Handling of Unused Pins in the manual. 

2.  Processing at Power-on 

The state of the product is undefined at the moment when power is supplied. 

⎯ The states of internal circuits in the LSI are indeterminate and the states of register settings 

and pins are undefined at the moment when power is supplied. 

In a finished product where the reset signal is applied to the external reset pin, the states of 

pins are not guaranteed from the moment when power is supplied until the reset process is 

completed. 

In a similar way, the states of pins in a product that is reset by an on-chip power-on reset 

function are not guaranteed from the moment when power is supplied until the power reaches 

the level at which resetting has been specified. 

3.  Prohibition of Access to Reserved Addresses 

Access to reserved addresses is prohibited. 

⎯ The reserved addresses are provided for the possible future expansion of functions. Do not 

access these addresses; the correct operation of LSI is not guaranteed if they are accessed. 

4.  Clock Signals 

After applying a reset, only release the reset line after the operating clock signal has become 

stable. When switching the clock signal during program execution, wait until the target clock signal 

has stabilized. 

⎯ When the clock signal is generated with an external resonator (or from an external oscillator) 

during a reset, ensure that the reset line is only released after full stabilization of the clock 

signal. Moreover, when switching to a clock signal produced with an external resonator (or by 

an external oscillator) while program execution is in progress, wait until the target clock signal 

is stable. 

5.  Differences between Products 

Before changing from one product to another, i.e. to a product with a different part number, confirm 

that the change will not lead to problems. 

⎯ The characteristics of Microprocessing unit or Microcontroller unit products in the same group 

but having a different part number may differ in terms of the internal memory capacity, layout 

pattern, and other factors, which can affect the ranges of electrical characteristics, such as 

characteristic values, operating margins, immunity to noise, and amount of radiated noise. 

When changing to a product with a different part number, implement a system-evaluation test 

for the given product. 

 

  



 

 

 

 

Notice
1. Descriptions of circuits, software and other related information in this document are provided only to illustrate the operation of semiconductor products and application examples.  You are fully responsible for

the incorporation of these circuits, software, and information in the design of your equipment.  Renesas Electronics assumes no responsibility for any losses incurred by you or third parties arising from the use

of these circuits, software, or information.

2. Renesas Electronics has used reasonable care in preparing the information included in this document, but Renesas Electronics does not warrant that such information is error free.  Renesas Electronics

assumes no liability whatsoever for any damages incurred by you resulting from errors in or omissions from the information included herein.

3. Renesas Electronics does not assume any liability for infringement of patents, copyrights, or other intellectual property rights of third parties by or arising from the use of Renesas Electronics products or

technical information described in this document.  No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights of Renesas Electronics or

others.

4. You should not alter, modify, copy, or otherwise misappropriate any Renesas Electronics product, whether in whole or in part.  Renesas Electronics assumes no responsibility for any losses incurred by you or

third parties arising from such alteration, modification, copy or otherwise misappropriation of Renesas Electronics product.

5. Renesas Electronics products are classified according to the following two quality grades: "Standard" and "High Quality".  The recommended applications for each Renesas Electronics product depends on

the product's quality grade, as indicated below.

"Standard": Computers; office equipment; communications equipment; test and measurement equipment; audio and visual equipment; home electronic appliances; machine tools; personal electronic

equipment; and industrial robots etc.

"High Quality": Transportation equipment (automobiles, trains, ships, etc.); traffic control systems; anti-disaster systems; anti-crime systems; and safety equipment etc.

Renesas Electronics products are neither intended nor authorized for use in products or systems that may pose a direct threat to human life or bodily injury (artificial life support devices or systems, surgical

implantations etc.), or may cause serious property damages (nuclear reactor control systems, military equipment etc.).  You must check the quality grade of each Renesas Electronics product before using it

in a particular application.  You may not use any Renesas Electronics product for any application for which it is not intended.  Renesas Electronics shall not be in any way liable for any damages or losses

incurred by you or third parties arising from the use of any Renesas Electronics product for which the product is not intended by Renesas Electronics.

6. You should use the Renesas Electronics products described in this document within the range specified by Renesas Electronics, especially with respect to the maximum rating, operating supply voltage

range, movement power voltage range, heat radiation characteristics, installation and other product characteristics.  Renesas Electronics shall have no liability for malfunctions or damages arising out of the

use of Renesas Electronics products beyond such specified ranges.

7. Although Renesas Electronics endeavors to improve the quality and reliability of its products, semiconductor products have specific characteristics such as the occurrence of failure at a certain rate and

malfunctions under certain use conditions.  Further, Renesas Electronics products are not subject to radiation resistance design.  Please be sure to implement safety measures to guard them against the

possibility of physical injury, and injury or damage caused by fire in the event of the failure of a Renesas Electronics product, such as safety design for hardware and software including but not limited to

redundancy, fire control and malfunction prevention, appropriate treatment for aging degradation or any other appropriate measures.  Because the evaluation of microcomputer software alone is very difficult,

please evaluate the safety of the final products or systems manufactured by you.

8. Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental compatibility of each Renesas Electronics product.  Please use Renesas Electronics

products in compliance with all applicable laws and regulations that regulate the inclusion or use of controlled substances, including without limitation, the EU RoHS Directive.  Renesas Electronics assumes

no liability for damages or losses occurring as a result of your noncompliance with applicable laws and regulations.

9. Renesas Electronics products and technology may not be used for or incorporated into any products or systems whose manufacture, use, or sale is prohibited under any applicable domestic or foreign laws or

regulations.  You should not use Renesas Electronics products or technology described in this document for any purpose relating to military applications or use by the military, including but not limited to the

development of weapons of mass destruction.  When exporting the Renesas Electronics products or technology described in this document, you should comply with the applicable export control laws and

regulations and follow the procedures required by such laws and regulations.

10. It is the responsibility of the buyer or distributor of Renesas Electronics products, who distributes, disposes of, or otherwise places the product with a third party, to notify such third party in advance of the

contents and conditions set forth in this document, Renesas Electronics assumes no responsibility for any losses incurred by you or third parties as a result of unauthorized use of Renesas Electronics

products.

11. This document may not be reproduced or duplicated in any form, in whole or in part, without prior written consent of Renesas Electronics.

12. Please contact a Renesas Electronics sales office if you have any questions regarding the information contained in this document or Renesas Electronics products, or if you have any other inquiries.

(Note 1) "Renesas Electronics" as used in this document means Renesas Electronics Corporation and also includes its majority-owned subsidiaries.

(Note 2) "Renesas Electronics product(s)" means any product developed or manufactured by or for Renesas Electronics.

http://www.renesas.com

Refer to "http://www.renesas.com/" for the latest and detailed information.
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