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Notice 
1. Descriptions of circuits, software and other related information in this document are provided only to illustrate the operation of

semiconductor products and application examples. You are fully responsible for the incorporation or any other use of the circuits,
software, and information in the design of your product or system. Renesas Electronics disclaims any and all liability for any losses and
damages incurred by you or third parties arising from the use of these circuits, software, or information.

2. Renesas Electronics hereby expressly disclaims any warranties against and liability for infringement or any other claims involving patents,
copyrights, or other intellectual property rights of third parties, by or arising from the use of Renesas Electronics products or technical
information described in this document, including but not limited to, the product data, drawings, charts, programs, algorithms, and
application examples.

3. No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights of Renesas
Electronics or others.

4. You shall not alter, modify, copy, or reverse engineer any Renesas Electronics product, whether in whole or in part. Renesas Electronics
disclaims any and all liability for any losses or damages incurred by you or third parties arising from such alteration, modification,
copying or reverse engineering.

5. Renesas Electronics products are classified according to the following two quality grades: “Standard” and “High Quality”. The intended
applications for each Renesas Electronics product depends on the product’s quality grade, as indicated below.
“Standard”: Computers; office equipment; communications equipment; test and measurement equipment; audio and visual equipment; 

home electronic appliances; machine tools; personal electronic equipment; industrial robots; etc. 
“High Quality”: Transportation equipment (automobiles, trains, ships, etc.); traffic control (traffic lights); large-scale communication 

equipment; key financial terminal systems; safety control equipment; etc. 
Unless expressly designated as a high reliability product or a product for harsh environments in a Renesas Electronics data sheet or other 
Renesas Electronics document, Renesas Electronics products are not intended or authorized for use in products or systems that may pose a 
direct threat to human life or bodily injury (artificial life support devices or systems; surgical implantations; etc.), or may cause serious 
property damage (space system; undersea repeaters; nuclear power control systems; aircraft control systems; key plant systems; military 
equipment; etc.). Renesas Electronics disclaims any and all liability for any damages or losses incurred by you or any third parties arising 
from the use of any Renesas Electronics product that is inconsistent with any Renesas Electronics data sheet, user’s manual or other 
Renesas Electronics document. 

6. When using Renesas Electronics products, refer to the latest product information (data sheets, user’s manuals, application notes, “General
Notes for Handling and Using Semiconductor Devices” in the reliability handbook, etc.), and ensure that usage conditions are within the
ranges specified by Renesas Electronics with respect to maximum ratings, operating power supply voltage range, heat dissipation
characteristics, installation, etc. Renesas Electronics disclaims any and all liability for any malfunctions, failure or accident arising out of
the use of Renesas Electronics products outside of such specified ranges.

7. Although Renesas Electronics endeavors to improve the quality and reliability of Renesas Electronics products, semiconductor products
have specific characteristics, such as the occurrence of failure at a certain rate and malfunctions under certain use conditions. Unless
designated as a high reliability product or a product for harsh environments in a Renesas Electronics data sheet or other Renesas
Electronics document, Renesas Electronics products are not subject to radiation resistance design. You are responsible for implementing
safety measures to guard against the possibility of bodily injury, injury or damage caused by fire, and/or danger to the public in the event
of a failure or malfunction of Renesas Electronics products, such as safety design for hardware and software, including but not limited to
redundancy, fire control and malfunction prevention, appropriate treatment for aging degradation or any other appropriate measures.
Because the evaluation of microcomputer software alone is very difficult and impractical, you are responsible for evaluating the safety of
the final products or systems manufactured by you.

8. Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental compatibility of each
Renesas Electronics product. You are responsible for carefully and sufficiently investigating applicable laws and regulations that regulate
the inclusion or use of controlled substances, including without limitation, the EU RoHS Directive, and using Renesas Electronics
products in compliance with all these applicable laws and regulations. Renesas Electronics disclaims any and all liability for damages or
losses occurring as a result of your noncompliance with applicable laws and regulations.

9. Renesas Electronics products and technologies shall not be used for or incorporated into any products or systems whose manufacture, use,
or sale is prohibited under any applicable domestic or foreign laws or regulations. You shall comply with any applicable export control
laws and regulations promulgated and administered by the governments of any countries asserting jurisdiction over the parties or
transactions.

10. It is the responsibility of the buyer or distributor of Renesas Electronics products, or any other party who distributes, disposes of, or
otherwise sells or transfers the product to a third party, to notify such third party in advance of the contents and conditions set forth in this
document.

11. This document shall not be reprinted, reproduced or duplicated in any form, in whole or in part, without prior written consent of Renesas
Electronics.

12. Please contact a Renesas Electronics sales office if you have any questions regarding the information contained in this document or
Renesas Electronics products.

(Note 1) “Renesas Electronics” as used in this document means Renesas Electronics Corporation and also includes its directly or indirectly 
controlled subsidiaries. 

(Note 2) “Renesas Electronics product(s)” means any product developed or manufactured by or for Renesas Electronics. 

(Rev.4.0-1  November 2017) 



How to Use This Manual

This manual describes the role of the CS+ integrated development environment for developing applications and sys-
tems for RX family, RL78 family, and provides an outline of its features.

CS+ is an integrated development environment (IDE) for RX family, RL78 family, integrating the necessary tools for the 
development phase of software (e.g. design, implementation, and debugging) into a single platform.

By providing an integrated environment, it is possible to perform all development using just this product, without the 
need to use many different tools separately.

Readers This manual is intended for users who wish to understand the functions of the CS+ and 
design software and hardware application systems.

Purpose This manual is intended to give users an understanding of the functions of the CS+ to use 
for reference in developing the hardware or software of systems using these devices.

Organization This manual can be broadly divided into the following units.

1.GENERAL
2.FUNCTIONS
A.WINDOW REFERENCE

How to Read This Manual It is assumed that the readers of this manual have general knowledge of electricity, logic 
circuits, and microcontrollers.

Conventions Data significance: Higher digits on the left and lower digits on the right
Active low representation: XXX (overscore over pin or signal name)
Note: Footnote for item marked with Note in the text
Caution: Information requiring particular attention
Remark: Supplementary information
Numeric representation: Decimal ... XXXX

Hexadecimal ... 0xXXXX

All trademarks or registered trademarks in this document are the property of their respective owners.
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1.  GENERAL

CS+ is an integrated development environment used to carry out tasks such as design, coding, build and debug for 
developing application systems.

This chapter gives an overview of the Code Generator.

1.1  Overview

The Code Generator, which is one of the components provided by CS+, enables you to output the pin assignment of the 
microcontroller (device list view and device top view) by configuring various information using the GUI.

1.2  Features

The Code Generator has the following features.

(1) Reporting function
You can output configured information using the Code Generator as files in various formats for use as design 
documents.
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2.  FUNCTIONS

This chapter describes the key functions provided by the Code Generator along with operation procedures.

Remark In this chapter, an example where an RL78/G1E (ROM: 32KB) R5F10FLC(64pin) is the target device is 
used to explain the key functions.

2.1  Overview

The Code Generator is used to output report files such as a device list view and a device top view.
The following sections describe the operation procedures for Code Generator.

(1) Start CS+
Launch CS+ from the [Start] menu of Windows.

(2) Create/Open project
Create a new project (that defines a kind of project, microcontroller to be used, build tools to be used, etc.) or load 
an existing project.

(3) Open Device List View Panel
Open the Device List View panel, where you enter information on the pins of the microcontroller.

(4) Open Device Top View Panel
Open the Device Top View panel, where you can confirm the information entered for the pins.

(a) Select color
Allows you to select colors used to distinguish the type of pins whose information is displayed in the Device Top 
View panel.

(5) Output Report Files
Output report files (files containing configured information using Code Generator: device list view and device top 
view) to the specified folder.

(a) Output device list view
Output a device list view.

(b) Output device top view
Output a device top view.

(6) Save project
Save a project.
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2.2  Open Device List View Panel

Open the Device List View panel, where you enter information on the pins of the microcontroller.
To open the Device List View panel, double-click [Project name (Project)] >> [Code Generator (Design Tool)] >> [Pin 

View] >> [Device List View] in the Project Tree panel.

Figure 2.1 Open Device List View Panel

Remark 1. If an unsupported microcontroller is defined in the project for Code Generator, then "[Code Generator 
(Design Tool)] node" will hide under [Project name (Project)] in the Project Tree panel.

Remark 2. The Device List View panel consists of two tabs. Selecting one of the tabs changes the order in which 
"information on each pin of the microcontroller" is displayed.

- [Pin Number] tab
Information on each pin of the microcontroller is displayed in the order of pin number.

- [Pin Function] tab
Information on each pin of the microcontroller is displayed in the order it was grouped into peripheral 
functions.
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2.3  Open Device Top View Panel

Open the Device Top View panel, where you can confirm the information entered for the pins of the microcontroller.
To open the Device Top View panel, double-click [Project name (Project)] >> [Code Generator (Design Tool)] >> [Pin 

View] >> [Device Top View] in the Project Tree panel.

Figure 2.2 Open Device Top View Panel
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2.3.1  Select color

Select the colors used to distinguish the type of pins whose information is displayed in the Device Top View panel which 
is opened as described in “2.3  Open Device Top View Panel”.

To select the color to be displayed, click [Device Top View Settings] tab >> [Device top view color setting] in the Prop-
erty panel and select the color.

Figure 2.3 Select Color

Remark Select the colors to be displayed for the following six types of items.

Device Selects the display color of the microcontroller.

Device group text Selects the display color of the device group.

Device part number text Selects the display color of the device part number.

Macro highligh Selects the background color of pins selected in the Device List View 
panel, on the [Pin Function] tab.

Selected pin Selects the background color of a pin selected in the Device List View 
panel, on the [Pin Number] tab.

Unused pins Selects the display color for unused pins (dual-use pins with no use set 
in the Device List View panel).



R20UT3105EJ0110  Rev.1.10 Page 10 of 31
Nov 01, 2017

CS+ Code Generator 2.  FUNCTIONS

2.4  Output Report Files

Output report files (files containing information configured using Code Generator: device list view and device top view) 
to the specified folder.

2.4.1  Output device list view

Select [File] menu >> [Save List View] to output a report file (a file containing information configured using Code 
Generator: device list view).

The destination folder for the device list view is specified in the Save As dialog box which opens by selecting [File] menu 
>> [Save List View].

Figure 2.4 Output Device List View

Remark The output format for the device list view is limited to CSV.
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2.4.2  Output device top view

Select [File] menu >> [Save Top View] to output a report file (a file containing information configured using Code 
Generator: device top view).

The destination folder for the device top view is specified in the Save As dialog box which opens by selecting [File] 
menu >> [Save Top View].

Figure 2.5 Output Device Top View

Remark The output format for the device top view is limited to PNG.
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A.  WINDOW REFERENCE

This appendix explains in detail the functions of the windows, panels and dialog boxes of the Code Generator.

A.1  Overview

The Code Generator has the following windows, panels and dialog boxes.

Table A.1 Window/Panel/Dialog Box List

Window/Panel/Dialog Box Name Function

Main window This is the first window to open when CS+ is launched. This window is used 
to operate various components (design tool, build tool, etc.) provided by 
CS+.

Project Tree panel This panel displays the components of the project (microcontroller, design 
tool, build tool, etc.) in a tree structure.

Property panel This panel allows you to view the information on and change the setting for 
the node selected in the Project Tree panel.

Device List View panel This panel allows you to enter information on each pin of the 
microcontroller.

Device Top View panel This panel displays the information entered in the Device List View panel.

Output panel This panel displays operation logs for various components (design tool, 
build tool, etc.) provided by CS+.

Save As dialog box This dialog box allows you to name and save a file.
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This is the first window to open when CS+ is launched. This window is used to operate various components (design tool, 
build tool, etc.) provided by CS+.

Figure A.1 Main Window

The following items are explained here.

- [How to open]

- [Description of each area]

[How to open]

- From the [start] menu, select [All Programs] >> [Renesas Electronics CS+] >>[CS+].

[Description of each area]

(1) Menu bar
This area consists of the following menu items.

(a) [FIle] menu

Main window
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(b) [Edit] menu

(c) [View] menu

Save List View Device List View panel-dedicated item
Opens the Save As dialog box for naming and saving a report file (a file 
containing information configured using Code Generator: device list view).

Save Top View Device Top View panel-dedicated item
Opens the Save As dialog box for naming and saving a report file (a file 
containing information configured using Code Generator: device top view).

Save Output-Tab Name Output panel-dedicated item
Saves the message corresponding to the specified tab overwriting the existing 
file.

Save Output-Tab Name 
As...

Output panel-dedicated item
Opens the Save As dialog box for naming and saving the message correspond-
ing to the specified tab.

Undo Property panel-dedicated item
Cancels the effect of an edit operation to restore the previous state.

Cut Property panel-dedicated item
Sends the character string or lines selected with range selection to the clip-
board and deletes them.

Copy Property panel/Output panel-dedicated item
Sends the character string or lines selected with range selection to the clip-
board.

Paste Property panel-dedicated item
Inserts the contents of the clipboard at the caret position.

Delete Property panel-dedicated item
Deletes the character string or the lines selected with the range selection.

Select All Property panel/Output panel-dedicated item
Selects all the strings displayed in the item being edited or all the strings dis-
played in the Message area.

Search... Device List View panel/Output panel-dedicated item
Opens the Search and Replace dialog box for searching strings with the [Quick 
Search] tab selected.

Replace... Output panel-dedicated item
Opens the Search and Replace dialog box for replacing strings with the [Whole 
Replace] tab selected.

Project Tree Project Tree panel-dedicated item
Opens the Project Tree panel.

Property Property panel-dedicated item
Opens the Property panel.

Output Output panel-dedicated item
Opens the Output panel.
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(d) [Help] menu

(2) Panel display area
This area consists of multiple panels, each dedicated to a different purpose.
See the following sections for details on this area.

- Project Tree panel

- Property panel

- Device List View panel

- Device Top View panel

- Output panel

Open Help for Project Tree 
Panel

Project Tree panel-dedicated item
Displays the help of Project Tree panel.

Open Help for Property 
Panel

Property panel-dedicated item
Displays the help of Property panel.

Open Help for [Device List 
View] panel

Device List View panel-dedicated item
Displays the help of Device List View panel.

Open Help for [Device Top 
View] panel

Device Top View panel-dedicated item
Displays the help of Device Top View panel.

Open Help for Output 
Panel

Output panel-dedicated item
Displays the help of Output panel.
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This panel displays components of the project (microcontroller, design tool, build tool, etc.) in a tree structure.

Figure A.2 Project Tree Panel

The following items are explained here.

- [How to open]

- [Description of each area]

- [Context menu]

[How to open]

- From the [View] menu, select [Project Tree].

[Description of each area]

(1) Project tree area
This area displays components of the project (microcontroller, design tool, build tool, etc.) in a tree structure.

(a) Code Generator (Design Tool) - Pin View
This node consists of the following pin nodes.

[Context menu]

Project Tree panel

Device List View Opens the Device List View panel.

Device Top View Opens the Device Top View panel.

Property Opens the Property panel corresponding to the selected node.



CS+ Code Generator A.  WINDOWS REFERENCE

R20UT3105EJ0110  Rev.1.10 Page 17 of 31
Nov 01, 2017

This panel allows you to view the information on and change the setting for the node selected in the Project Tree panel.

Figure A.3 Property Panel

Caution 1.

The following items are explained here.

- [How to open]

- [Description of each area]

- [Context menu]

[How to open]

- On the Project Tree panel, select [Project name (Project)] >> [Code Generator (Design Tool)] >> [Pin View], and then 
select [Property] from the [View] menu.

- On the Project Tree panel, select [Project name (Project)] >> [Code Generator (Design Tool)] >> [Pin View], and then 
select [Property] from the context menu.

- On the Project Tree panel, select [Project name (Project)] >> [Code Generator (Design Tool)] >> [Pin View] >> 
[Device List View], and then select [Property] from the [View] menu.

- On the Project Tree panel, select [Project name (Project)] >> [Code Generator (Design Tool)] >> [Pin View] >> 
[Device List View], and then select [Property] from the context menu.

- On the Project Tree panel, select [Project name (Project)] >> [Code Generator (Design Tool)] >> [Device Top View], 
and then select [Property] from the [View] menu.

- On the Project Tree panel, select [Project name (Project)] >> [Code Generator (Design Tool)] >> [Device Top View], 
and then select [Property] from the context menu.

Remark 1. If this panel is already open, selecting a different [Pin View] in the Project Tree panel changes the content 
displayed accordingly.

Remark 2. If this panel is already open, selecting a different [Device List View] in the Project Tree panel changes the 
content displayed accordingly.

Remark 3. If this panel is already open, selecting a different [Device Top View] in the Project Tree panel changes the 
content displayed accordingly.

[Description of each area]

(1) Detail information display/change area
This area allows you to view the information on and change the setting for the node selected in the Project Tree 
panel.
The content displayed in this area differs depending on the node selected in the Project Tree panel.

Property panel
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(2) Tab selection area
In this panel, following tabs are contained (see the section explaining each tab for details on the display/setting on 
the tab).

- [Pin View Information] tab

- [Device List View Information] tab

- [Device Top View Settings] tab

[Context menu]

Undo Cancels the effect of an edit operation to restore the previous state.

Cut Sends the character string or lines selected with range selection to the clipboard and 
deletes them.

Copy Sends the character string or lines selected with range selection to the clipboard.

Paste Inserts the contents of the clipboard at the caret position.

Delete Deletes the character string or the lines selected with the range selection.

Select All Selects all strings displayed in the item being edited.
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[Pin View Information] tab

This tab displays information (Product Information) on the [Pin View)] selected in the Project Tree panel.

Figure A.4 [Pin View Information] Tab

The following items are explained here.

- [How to open]

- [Description of each area]

[How to open]

- On the Project Tree panel, select [Project name (Project)] >> [Code Generator (Design Tool)] >> [Pin View], and then 
select [Property] from the [View] menu.

- On the Project Tree panel, select [Project name (Project)] >> [Code Generator (Design Tool)] >> [Pin View], and then 
select [Property] from the context menu.

Remark If this panel is already open, selecting a different [Pin View] in the Project Tree panel changes the content 
displayed accordingly.

[Description of each area]

(1) [Product Information] category
This area displays product information (Version and Release date) on Code Generator.

Release date Displays the release date of Code Generator (Code Generator 2 Plug-in).

Version Displays the version of Code Generator (Code Generator 2 Plug-in).
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[Device List View Information] tab

This tab displays information (Product Information) on the [Device List View] selected in the Project Tree panel.

Figure A.5 [Device List View Information] Tab

The following items are explained here.

- [How to open]

- [Description of each area]

[How to open]

- On the Project Tree panel, select [Project name (Project)] >> [Code Generator (Design Tool)] >> [Pin View] >> 
[Device List View], and then select [Property] from the [View] menu.

- On the Project Tree panel, select [Project name (Project)] >> [Code Generator (Design Tool)] >> [Pin View] >> 
[Device List View], and then select [Property] from the context menu.

Remark If this panel is already open, selecting a different [Device List View] in the Project Tree panel changes the 
content displayed accordingly.

[Description of each area]

(1) [Product Information] category
This area displays product information (Release date and Version) on Code Generator.

Release date Displays the release date of Code Generator (Code Generator 2 Plug-in).

Version Displays the version of Code Generator (Code Generator 2 Plug-in).
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[Device Top View Settings] tab

This panel allows you to view the information (Device top view color setting) on and change the setting for the node 
selected in the Project Tree panel.

Figure A.6 [Device Top View Settings] Tab

The following items are explained here.

- [How to open]

- [Description of each area]

[How to open]

- On the Project Tree panel, select [Project name (Project)] >> [Code Generator (Design Tool)] >> [Pin View] >> 
[Device Top View], and then select [Property] from the [View] menu.

- On the Project Tree panel, select [Project name (Project)] >> [Code Generator (Design Tool)] >> [Pin View] >> 
[Device Top View], and then select [Property] from the context menu.

Remark If this panel is already open, selecting a different [Device Top View] in the Project Tree panel changes the 
content displayed accordingly.
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[Description of each area]

(1) [Device top view color setting] category
Select the display colors to differentiate the pin groups (Device, Device group text, etc.) in the device top view.

Conflict pins Selects the display color of the conflict pins (same pin to which multiple functions 
are set).

Device Selects the display color of the microcontroller.

Device group text Selects the display color of the device group.

Device part number text Selects the display color of the device part number.

Macro highligh Selects the background color of pins selected in the Device List View panel, on 
the [Pin Function] tab.

Alternate function pins Selects the background color of a pins selected in the Device List View panel, on 
the [Pin Number] tab.

Unused pins Selects the display color for unused pins (dual-use pins with no use set in the 
Device List View panel).

Used pins Selects the display color for used pins (dual-use pins with a use set in the Device 
List View panel).

Warning pins Selects the diplay color for used pins (dual-use pins with a use and not set func-
tion parameters in the Device List View panel).
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This panel allows you to enter information on each pin of the microcontroller.

Figure A.7 Device List View Panel

The following items are explained here.

- [How to open]

- [Description of each area]

[How to open]

- On the Project Tree panel, double-click [Project name (Project)] >> [Code Generator (Design Tool)] >> [Pin View] >> 
[Device List View].

- On the Project Tree panel, select [Project name (Project)] >> [Code Generator (Design Tool)] >> [Pin View] >> 
[Device List View], and then press the [Enter] key.

- From the [View] menu, select [Code Generator 2] >> [Device List View].

[Description of each area]

(1) Toolbar
This area consists of the following buttons.

(2) Device list view area
This area displays the "device list view" for entering information on the pins of the microcontroller.

(3) Tab selection area
Selecting the tab changes the order in which "information on each pin of the microcontroller" is displayed.
This panel has the following tabs:

- [Pin Number] tab
This tab displays information on each pin of the microcontroller in the order of pin number.

- [Pin Function] tab
This tab displays information on each pin of the microcontroller in the order it was grouped into peripheral func-
tions.

Device List View panel

Opens the Save As dialog box for naming and saving a report file (a file 
containing information configured using Code Generator: device list view).
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[Pin Number] tab

This tab displays information on each pin of the microcontroller in the order of pin number.

Figure A.8 [Pin Number] Tab

The following items are explained here.

- [How to open]

- [Description of each area]

[How to open]

- On the Project Tree panel, double-click [Project name (Project)] >> [Code Generator (Design Tool)] >> [Pin View] >> 
[Device List View].

- On the Project Tree panel, select [Project name (Project)] >> [Code Generator (Design Tool)] >> [Pin View] >> 
[Device List View], and then press the [Enter] key.

- From the [View] menu, select [Code Generator 2] >> [Device List View].

[Description of each area]

(1) Device list view area
This area displays the “device list view” for entering information on the pins of the microcontroller.
The device list view in this area is organized in the order of pin number.
The following are the columns comprising the device list view.

Pin no. Displays the pin number of the pin.

Pin name This area allows you to select “which function to use” when the pin has more than 
one functions.

Pin function Displays the summary of function of the pin.

Pin direction Displays the pin direction of the pin.

Pin remarks Displays the precaution on using the pin.

Comment
(maximum 200 characters)

Displays the comment of the pin
Comments can be arbitrarily set up by 200 characters or less



CS+ Code Generator A.  WINDOWS REFERENCE

R20UT3105EJ0110  Rev.1.10 Page 25 of 31
Nov 01, 2017

[Pin Function] tab

This tab displays information on each pin of the microcontroller in the order it was grouped into peripheral functions.

Figure A.9 [Pin Function] Tab

The following items are explained here.

- [How to open]

- [Description of each area]

[How to open]

- On the Project Tree panel, double-click [Project name (Project)] >> [Code Generator (Design Tool)] >> [Pin View] >> 
[Device List View].

- On the Project Tree panel, select [Project name (Project)] >> [Code Generator (Design Tool)] >> [Pin View] >> 
[Device List View], and then press the [Enter] key.

- From the [View] menu, select [Code Generator 2] >> [Device List View].

[Description of each area]

(1) Device list view area
This area displays the “device list view” for entering information on the pins of the microcontroller.
The device list view in this area is organized in the order the pins were grouped into peripheral functions.
The following are the columns comprising the device list view.

Pin name Displays the pin name of the pin.

Available assignment Displays the summary of function of the pin.

Pin no. Displays the pin number of the pin.

Pin direction Displays the pin direction of the pin.

Pin remarks Displays the precaution on using the pin.

Comment
(maximum 200 characters)

Displays the comment of the pin
Comments can be arbitrarily set up by 200 characters or less
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This panel displays the information entered in the Device List View panel.

Figure A.10 Device Top View Panel

The following items are explained here.

- [How to open]

- [Description of each area]

[How to open]

- On the Project Tree panel, double-click [Project name (Project)] >> [Code Generator (Design Tool)] >> [Pin View] >> 
[Device Top View].

- On the Project Tree panel, select [Project name (Project)] >> [Code Generator (Design Tool)] >> [Pin View] >> 
[Device Top View], and then press the [Enter] key.

- From the [View] menu, select [Code Generator 2] >> [Device Top View].

Device Top View panel
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[Description of each area]

(1) Toolbar
This area consists of the following buttons.

(2) Device top view area
This area displays the pin assignment of the microcontroller.
Settings of the pin assignment are displayed using the colors specified by selecting [Device Top View Settings] tab 
>> [Device top view color setting] in the Property panel.

Opens the Save As dialog box for naming and saving a report file (a file 
containing information configured using Code Generator: device top view).

Rotates the content in the Device top view area 90 degrees clockwise.

Rotates the content in the Device top view area 90 degrees counter-clockwise.

Expands the content in the Device top view area.

Reduces the content in the Device top view area.
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This panel displays operation logs for various components (design tool, build tool, etc.) provided by CS+.
The messages are classified by the message origination tool and displayed on the individual tabs.

Remark The Message area can be zoomed in and out by  in the tool bar, or by operating the mouse 
wheel while holding down the [Ctrl] key.

Figure A.11 Output Panel

The following items are explained here.

- [How to open]

- [Description of each area]

- [Context menu]

[How to open]

- From the [View] menu, select [Output].

[Description of each area]

(1) Message area
The output messages of each tool are displayed.
Note that the character colors/background colors of the message differ with the type of output message (and 
depend on the settings in the [General - Font and Color] category in the Option dialog box).

(2) Tab selection area
Select the tab that indicates the origin of message.
The following tabs are available for the Code Generator.

Caution Even if a new message is output on a deselected tab, tab selection will not automatically switch. In 
this case, " * " mark will be added in front of the tab name, indicating that a new message has been 
output. 

Output panel

All Messages Displays operation logs for all components (design tool, build tool, etc.) provided 
by CS+ in order of output.

Code Generator Display only operation logs for the Code Generator out of those for various com-
ponents (design tool, build tool, etc.) provided by CS+.

(1)

(2)
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[Context menu]

Copy Sends the character string or lines selected with range selection to the clipboard.

Select All Selects all the messages displayed on the Message area.

Clear Deletes all the messages displayed on the Message area.

Tag Jump Jumps to the caret line in the editor indicated by the message (file, line, and column).

Open Help for Message Displays help for the message on the current caret location.
This only applies to warning messages and error messages.
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This dialog box allows you to name and save a file.

Figure A.12 Save As Dialog Box

The following items are explained here.

- [How to open]

- [Description of each area]

- [Function buttons]

[How to open]

- From the [File] menu, select [Save List View].

- Click the  button in the Device List View panel.

- From the [File] menu, select [Save Top View].

- Click the  button in the Device Top View panel.

- From the [File] menu, select [Save Output-Tab Name].

- From the [File] menu, select [Save Output-Tab Name As...].

Save As dialog box

(1)

(2)

[Function buttons]

(3)

(4)
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[Description of each area]

(1) Folder location
This is for selection of the output destination folder (folder name).

(2) List of files
This area displays a list of files matching the conditions selected in Folder location and [Save as type].

(3) [File name]
Specify the name of the file (file name).

(4) [Save as type]
Select the type of the file (file type).

[Function buttons]

Save Outputs a file having the name specified in the [File name] and [Save as type] to the 
folder specified in the Folder location.

Cancel Ignores the setting and closes this dialog box.



Revision Record

Rev. Date Description

Page Summary

1.00 Aug 01, 2014 - First Edition issued

1.10 Nov 01, 2017 14 Removed the description of Code Generator 2

22 Added the description of Conflict pins and Warning pins

24 Added the description of Comment (maximum 200 characters)

25 Added the description of Comment (maximum 200 characters)



CS+ Code Generator Integrated Development Environment User's 
Manual: Pin View

Publication Date: Rev.1.10 Nov 01, 2017

Published by: Renesas Electronics Corporation



http://www.renesas.com
Refer to "http://www.renesas.com/" for the latest and detailed information.

Renesas Electronics America Inc.
1001 Murphy Ranch Road, Milpitas, CA 95035, U.S.A.
Tel:  +1-408-432-8888, Fax: +1-408-434-5351
Renesas Electronics Canada Limited
9251 Yonge Street, Suite 8309 Richmond Hill, Ontario Canada L4C 9T3
Tel: +1-905-237-2004
Renesas Electronics Europe Limited
Dukes Meadow, Millboard Road, Bourne End, Buckinghamshire, SL8 5FH, U.K
Tel: +44-1628-651-700, Fax: +44-1628-651-804
Renesas Electronics Europe GmbH
Arcadiastrasse 10, 40472 Düsseldorf, Germany
Tel: +49-211-6503-0, Fax: +49-211-6503-1327
Renesas Electronics (China) Co., Ltd.
Room 1709 Quantum Plaza, No.27 ZhichunLu, Haidian District, Beijing, 100191 P. R. China
Tel: +86-10-8235-1155, Fax: +86-10-8235-7679
Renesas Electronics (Shanghai) Co., Ltd.
Unit 301, Tower A, Central Towers, 555 Langao Road, Putuo District, Shanghai, 200333 P. R. China
Tel: +86-21-2226-0888, Fax: +86-21-2226-0999
Renesas Electronics Hong Kong Limited
Unit 1601-1611, 16/F., Tower 2, Grand Century Place, 193 Prince Edward Road West, Mongkok, Kowloon, Hong Kong
Tel: +852-2265-6688, Fax: +852 2886-9022
Renesas Electronics Taiwan Co., Ltd.
13F, No. 363, Fu Shing North Road, Taipei 10543, Taiwan
Tel: +886-2-8175-9600, Fax: +886 2-8175-9670
Renesas Electronics Singapore Pte. Ltd.
80 Bendemeer Road, Unit #06-02 Hyflux Innovation Centre, Singapore 339949
Tel: +65-6213-0200, Fax: +65-6213-0300
Renesas Electronics Malaysia Sdn.Bhd.
Unit 1207, Block B, Menara Amcorp, Amcorp Trade Centre, No. 18, Jln Persiaran Barat, 46050 Petaling Jaya, Selangor Darul Ehsan, Malaysia
Tel: +60-3-7955-9390, Fax: +60-3-7955-9510
Renesas Electronics India Pvt. Ltd.
No.777C, 100 Feet Road, HAL 2nd Stage, Indiranagar, Bangalore 560 038, India
Tel: +91-80-67208700, Fax: +91-80-67208777
Renesas Electronics Korea Co., Ltd.
17F, KAMCO Yangjae Tower, 262, Gangnam-daero, Gangnam-gu, Seoul, 06265 Korea
Tel: +82-2-558-3737, Fax: +82-2-558-5338

SALES OFFICES

© 2018 Renesas Electronics Corporation. All rights reserved.
Colophon 5.0



CS+ Code Generator

R20UT3105EJ0110


	COVER
	How to Use This Manual
	1. GENERAL
	1.1 Overview
	1.2 Features

	2. FUNCTIONS
	2.1 Overview
	2.2 Open Device List View Panel
	2.3 Open Device Top View Panel
	2.3.1 Select color

	2.4 Output Report Files
	2.4.1 Output device list view
	2.4.2 Output device top view


	A. WINDOW REFERENCE
	A.1 Overview
	Main window
	Project Tree panel
	Property panel
	[Pin View Information] tab
	[Device List View Information] tab
	[Device Top View Settings] tab

	Device List View panel
	[Pin Number] tab
	[Pin Function] tab

	Device Top View panel
	Output panel
	Save As dialog box


	Revision Record

