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RZ/T1グループ

R-IN Engine搭載製品　初期設定

要旨

本アプリケーションノートでは、RZ/T1 の R-IN Engine 搭載製品　初期設定を行うサンプルプログラムに

ついて説明します。

R-IN Engine 搭載製品　初期設定サンプルプログラムの特長を以下に示します。

• Cortex-R4 コアはリセット解除後に初期設定を行い、Cortex-M3 コアのリセット解除処理を行います。そ

の後 CPU 間割り込みを発生させ、一定周期で LED0 の点滅処理を行います。

• Cortex-M3 コアはリセット解除後に初期設定を行い、Cortex-R4 からの CPU 間割り込み要求を待ちます。

CPU 間割り込み要求を受け付けた後は、LED1 を点灯させます。

• スイッチ SW2 を押下すると、Cortex-R4 コアは外部端子割り込み処理により、LED0 の点灯／消灯の状態

を LED データとして共有メモリ領域に書き込みます。一方 Cortex-M3 コアは常に共有メモリの LED
データを読み込み、点灯／消灯状態を LED1 に反映させます。

対象デバイス

RZ/T1 グループ

本アプリケーションノートを他のマイコンへ適用する場合、そのマイコンの仕様にあわせて変更し、十分

評価してください。
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1. 仕様
表 1.1 に使用する周辺機能と用途を、図 1.1 に動作環境を示します。

表1.1 使用する周辺機能と用途

周辺機能 用途

クロック発生回路（CPG） CPUクロックおよび低速オンチップオシレータで使用

割り込みコントローラ（ICUA） 外部割り込み入力端子（IRQ5）、CPU間割り込みで使用

拡張内蔵RAM 共用メモリ領域（拡張内蔵 Instruction RAM（以降、RAM Iと略す）および

Cortex-M3用プログラム領域メモリ（拡張内蔵Data RAM（以降、RAM Dと

略す）で使用

エラーコントロールモジュール（ECM） ERROROUT#端子の初期化

汎用入出力ポート LEDの点灯および消灯のための端子制御に使用

注 1. 別途お客様でご用意いただく必要があります。

図 1.1 動作環境
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2. 動作環境
本アプリケーションノートのサンプルプログラムは、以下の環境を想定しています。

表2.1 動作環境

項目 内容

使用マイコン RZ/T1グループ

動作周波数 CPUCLK = 450MHz（Cortex-R4）、
ICLK = 150MHz（Cortex-M3）

動作電圧 3.3V

統合開発環境 IARシステムズ製
Embedded Workbench® for Arm Version 8.20.2
Arm製
DS-5TM 5.26.2
RENESAS製
e2studio 6.1.0

動作モード SPIブートモード

16ビットバスブートモード

使用ボード RZ/T1 Evaluation Board
（RTK7910022C00000BR）

使用デバイス

（ボード上で使用する機能）

• NORフラッシュメモリ （CS0、CS1空間に接続）

メーカ名 : Macronix International Co..、型名 : MX29GL512FLT2I-10Q
• SDRAM（CS2、CS3空間に接続）

メーカ名 : Integrated Silicon Solution Inc、型名 : IS42S16320D-7TL
• シリアルフラッシュメモリ

メーカ名 : Macronix International Co..、型名 : MX25L51245G
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3. 関連アプリケーションノート
本アプリケーションノートに関連するアプリケーションノートを以下に示します。併せて参照してくださ

い。

• RZ/T1 グループ初期設定
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4. 周辺機能説明
クロック発生回路（CPG）、割り込みコントローラ（ICUA）、エラーコントロールモジュール（ECM）、拡

張内蔵 RAM、汎用入出力ポートについての基本的な内容は、RZ/T1 グループ・ユーザーズマニュアル ハー

ドウェア編を参照してください。
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5. ハードウェア説明

5.1 ハードウェア構成例

図 5.1 にハードウェア構成例を示します。

5.2 使用端子一覧

表 5.1 に使用端子と機能を示します。

図 5.1 ハードウェア構成例

表5.1 使用端子と機能

端子名 入出力 内容

MD0 入力 動作モードの選択

MD0=”L”、MD1=”L”、MD2=”L” （SPIブートモード）

MD0=”L”、MD1=”H”、MD2=”L” （16ビットバスブートモード）
MD1 入力

MD2 入力

IRQ5 入力 SW2（IRQ端子割り込み）

PF7 出力 LED0の点灯および消灯

P56 出力 LED1の点灯および消灯

拡張内蔵RAM I/O Port

ICUA
(Interrupt Control Unit A) Cortex-R4 消費電力低減機能

レジスタライト

プロテクション機能
Cortex-M3

RZ/T1

LED0 LED1

PF7 P56
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6. ソフトウェア説明
以降、特に明記しない場合は EWARM（IAR 社製）を使用した場合について説明を行います。

6.1 動作概要

本サンプルプログラムでは、Cortex-R4 コアと Cortex-M3 コアによる初期設定を行います。

① Cortex-R4 コア側のプログラムは、電源投入後に初期設定を行い Cortex-M3 コアのプログラムコードを

         外付けフラッシュメモリから拡張内蔵 RAM へコピーし（RAM 実行版はコピー処理をしません）、

         Cortex-M3 コアのリセット解除を行います。その後、LED 制御用のポート設定や割り込みを設定し、

         CPU 間割り込みを発生させて Cortex-M3 側へ初期化の完了を通知します。

② Cortex-M3 コア側のプログラムは、ソフトウェアリセット 2 解除後に初期設定を行い Cortex-R4 コア

         からの CPU 間割り込みを待ちます。

③ Cortex-R4 コア側は、LED0 を一定周期で点滅させます。また、スイッチ SW2 の押下を検出すると、

         共用メモリ領域（拡張内蔵 RAM）に LED データとして LED0 の点灯状態（点灯／消灯）を書き込みま

         す。一方、Cortex-M3 コア側は常時共用メモリの LED データの値を読み込み、その値に応じて LED1 の

         点灯表示を行います（初期値は点灯）。例えば LED0 が消灯時に SW2 を押下すると、LED1 にも点灯状

         態が反映され消灯状態になります。

図 6.1 に R-IN Engine 搭載製品　初期設定処理の概要動作を示します。

図 6.1 R-IN Engine 搭載製品　初期設定処理の概要動作
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6.1.1 使用準備

使用するプロジェクトによって、RZ/T1 Evaluation Board（RTK7910022C00000BR）上にある SW4 の設定

が異なります。表 6.1 に SW4 の設定を示します。SW4 の各設定につきましては、RZ/T1 Evaluation Board　
RTK7910022C00000BR ユーザーズマニュアルに記載しています。詳細は、8.　参考ドキュメントを参照して

ください。

6.2 メモリマップ

RZ/T1 グループのアドレス空間と RZ/T1 評価ボードのメモリマッピングについては、アプリケーション

ノート「RZ/T1 グループ初期設定」およびユーザーズマニュアル　ハードウエア編に記載しています。

6.2.1 サンプルプログラムのセクション配置

表 6.2 に使用するセクション、図 6.2 にセクション配置（16 ビットバスブート版の例）を示します。

Cortex-R4 のセクションの詳細については、アプリケーションノート「RZ/T1 グループ初期設定」に記載

しています。

注1. RAM実行版では、存在しません。

注2. 16ビットバスブートモード版では、NORフラッシュメモリ、SPIブートモード版では、シリアル・フラッシュメモリとなり

ます。

注3. RAM実行版では存在しません。代わりにCortex-M3のセクション配置に基づいて開発ツールで直接、実行領域である拡張内

蔵RAM I にダウンロードされます。

表6.1 SW4の設定

サンプルプログラム SW4-1 SW4-2 SW4-3 SW4-4 SW4-5 SW4-6

16ビットバスブートモード版 ON OFF ON ON ON OFF

SPIブートモード版 ON ON ON ON ON OFF

RAM実行版 上記いずれかの SW4 設定

表6.2 使用するセクション（Cortex-R4）

領域の名前 内容 タイプ ロード領域 実行領域

VECTOR_WBLOCK リセット、例外ベクタテーブル Code — ATCM

USER_PRG_WBLOCK ユーザアプリケーションプログラム領域（実行用） Code — ATCM

USER_DATA_WBLOCK ユーザアプリケーションプログラム用変数領域（実行用） Data — ATCM

CSTACK スタック領域 Data — ATCM

SVC_STACK スーパバイザ（SVC）モードのスタック領域 Data — ATCM

IRQ_STACK IRQモードのスタック領域 Data — ATCM

FIQ_STACK FIQモードのスタック領域 Data — ATCM

UND_STACK 未定義（UND）モードのスタック領域 Data — ATCM

ABT_STACK アボート（ABT）モードのスタック領域 Data — ATCM

LDR_DATA_WBLOCK ローダプログラム用変数領域（実行用） Data — BTCM

LDR_PRG_WBLOCK ローダプログラム領域（実行用） Code — BTCM

ldr_param ローダ用パラメータ注1 Data FLASH注2 —

LDR_PRG_RBLOCK ローダプログラム領域（格納用）注1 Code FLASH注2 —

LDR_DATA_RBLOCK ローダプログラム用変数領域（格納用）注1 Data FLASH注2 —

VECTOR_RBLOCK リセット、例外ベクタテーブル領域（格納用）注1 Code FLASH注2 —

USER_PRG_RBLOCK ユーザアプリケーションプログラム領域（格納用）注1、
Cortex-M3用ユーザアプリケーションプログラム領域（格納用）注3

Code FLASH注2 —

USER_DATA_RBLOCK ユーザアプリケーションプログラム用変数領域（格納用）注1 Data FLASH注2 —
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表6.3 使用するセクション（Cortex-M3）

領域の名前 内容 タイプ ロード領域 実行領域

vectors ベクタ領域 Code 拡張内蔵RAM I 拡張内蔵RAM I
readonly ユーザアプリケーションプログラム領域 Code 拡張内蔵RAM I 拡張内蔵RAM I
_SHARED_MEM 共用メモリ領域 Data 拡張内蔵RAM D 拡張内蔵RAM D
readwrite ユーザアプリケーションプログラム用変数領域 Data 拡張内蔵RAM D 拡張内蔵RAM D
HEAP ヒープ領域 Data 拡張内蔵RAM D 拡張内蔵RAM D
CSTACK スタック領域 Data 拡張内蔵RAM D 拡張内蔵RAM D
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注 1. SPI ブート版の場合は、シリアルフラッシュ（SPIBSC 領域）に相当します。

アドレスも 1000 0000h が先頭番地になるように読み替えてください。

注 2. ローダ用パラメータ（ldr_param セクション）はブート処理で使用されます。

詳細については RZ/T1 ユーザーズマニュアル ハードウェア編を参照してください。

図 6.2 セクション配置（Cortex-R4, 16 ビットバスブートの例）
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6.2.2 MPU の設定

MPU の設定は、アプリケーションノート「RZ/T1 グループ初期設定」に記載しています。

6.2.3 例外処理ベクタテーブル

例外処理のベクタテーブルは、アプリケーションノート「RZ/T1 グループ初期設定」に記載しています。

注 1. 拡張内蔵 RAM I のセクションは CM3_SECTION として Cortex-R4 によりコピーされます。

図 6.3 セクション配置（Cortex-M3）
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6.3 使用割り込み一覧

表 6.4 にサンプルプログラムで使用する割り込みを示します。

6.4 固定幅整数一覧

表 6.5 にサンプルプログラムで使用する固定幅整数を示します。

表6.4 サンプルプログラムで使用する割り込み

割り込み（Source ID） 優先度 処理概要

CPU間割り込み（IRQ1） 15 Cortex-R4からCortex-M3へ初期化設定の完了を通知します（Cortex-R4、
Cortex-M3）。

IRQ端子割り込み5（IRQ9） 15 SW2が押されるとLED0の点灯状態（点灯／消灯）が共用メモリに書き込まれ

ます（Cortex-R4コアのみ）。

表6.5 サンプルプログラムで使用する固定幅整数

シンボル 内容

int8_t 8ビット整数、符号あり（標準ライブラリにて定義）

int16_t 16ビット整数、符号あり（標準ライブラリにて定義）

int32_t 32ビット整数、符号あり（標準ライブラリにて定義）

int64_t 64ビット整数、符号あり（標準ライブラリにて定義）

uint8_t 8ビット整数、符号なし（標準ライブラリにて定義）

uint16_t 16ビット整数、符号なし（標準ライブラリにて定義）

uint32_t 32ビット整数、符号なし（標準ライブラリにて定義）

uint64_t 64ビット整数、符号なし（標準ライブラリにて定義）
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6.5 定数／エラーコード一覧

表 6.6 にサンプルプログラムで使用する定数を示します。Cortex-R4 コアのプログラムの詳細については

アプリケーションノート「RZ/T1 グループ初期設定」に記載しています。

6.6 構造体／共用体／列挙型一覧

図 6.4 にサンプルプログラムで使用する構造体／共用体／列挙型を示します。Cortex-R4 コアのプログラ

ムの詳細についてはアプリケーションノート「RZ/T1 グループ初期設定」に記載しています。

表6.6 サンプルプログラムで使用する定数

定数名 設定値 内容

LED_OUTPUT_HIGH (1) LED点灯表示用の出力データ

SHM_SUCCESS (0) 共用メモリドライバの正常制御フラグ

SHM_ERR (-1) 共用メモリドライバの異常制御フラグ

SHM_SEMFNO_TOTAL (8) 共用メモリドライバ用セマフォフラグの総数

SHM_ SEMFNO_0 (0) 共用メモリドライバ用セマフォフラグ0
SHM_ SEMFNO_1 (1) 共用メモリドライバ用セマフォフラグ1
SHM_ SEMFNO_2 (2) 共用メモリドライバ用セマフォフラグ2
SHM_ SEMFNO_3 (3) 共用メモリドライバ用セマフォフラグ3
SHM_ SEMFNO_4 (4) 共用メモリドライバ用セマフォフラグ4
SHM_ SEMFNO_5 (5) 共用メモリドライバ用セマフォフラグ5
SHM_ SEMFNO_6 (6) 共用メモリドライバ用セマフォフラグ6
SHM_ SEMFNO_7 (7) 共用メモリドライバ用セマフォフラグ7

/* Shared memory struct */
/* Size MAX 4KB */
struct st_shm
{
    uint32_t LED_DATA;
};

/* struct of [SYSTEM.SYTSEMFn] register */
typedef struct
{
          union
           {
                           unsigned long LONG;
                           struct
                            {
                                          unsigned long SEMF:1;
                                          unsigned long :31;
                             } BIT;
           } SYTSEMF;
} st_sytsemf;

図 6.4 サンプルプログラムで使用する構造体／共用体／列挙型
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6.7 大域変数一覧

表 6.7 に大域変数を示します。Cortex-R4 コアのプログラムの詳細についてはアプリケーションノート

「RZ/T1 グループ初期設定」に記載しています。

6.8 関数一覧

表 6.8 に関数を示します。Cortex-R4 コアのプログラムの詳細についてはアプリケーションノート「RZ/T1
グループ初期設定」に記載しています。

注 . 特に記載がない関数は各コアで共通に使用します。

表6.7 大域変数一覧

型 変数名 内容 使用関数

uint8_t g_ready_flag Cortex-R4初期化完了フラグ init_main.c （Cortex-M3）
uint32_t g_led_data LED表示用データ変数 main.c（Cortex-R4）

init_main.c（Cortex-M3）

表6.8 関数一覧

関数名 ページ番号

R_SHM_Init 17

R_SHM_memcpy 17

R_SHM_Load_uint32 17

R_SHM_Load_int32 18

R_SHM_Load_uint16 18

R_SHM_Load_int16 18

R_SHM_Load_uint8 19

R_SHM_Load_int8 19

main（Cortex-R4） 19

init_cm3（Cortex-R4） 20

R_IRQ9_isr（Cortex-R4） 20

main（Cortex-M3） 20

IRQ_INTERCPU_IRQHandler（Cortex-M3） 21 
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6.9 関数仕様

サンプルプログラムの関数仕様を示します。

6.9.1 R_SHM_Init

6.9.2 R_SHM_memcpy

6.9.3 R_SHM_Load_uint32

R_SHM_Init

概　要 共用メモリドライバ初期化処理

宣　言 int32_t R_SHM_Init (uint32_t semfno)

説　明 共用メモリドライバを使用するために指定したセマフォレジスタの初期設定を行いま

す。

引　数 uint32_t semfno 初期化するセマフォレジスタ番号を指定します。

設定可能範囲（0 ～ 7）

リターン値 SHM_SUCCESS：成功

SHM_ERR：失敗

補足 なし

R_SHM_memcpy

概　要 共用メモリ領域用メモリコピー処理

宣　言 int32_t R_SHM_memcpy(void *dst, void *src, size_t size)

説　明 共用メモリ領域に対する多バイトデータのコピー処理を行います。

引　数 void *dst 転送先メモリ領域のポインタアドレス

void *src 転送元メモリ領域のポインタアドレス

size_t size 転送メモリのサイズ

リターン値 SHM_SUCCESS：成功

SHM_ERR：失敗

補足 なし

R_SHM_Load_uint32

概　要 共用メモリ領域用 uint 4 バイトデータロード処理

宣　言 int32_t R_SHM_Load_uint32(uint32_t *dst, uint32_t *src)

説　明 共用メモリ領域に対する uint 4 バイトデータのロード処理を行います。

引　数 uint32_t *dst 転送先メモリ領域のポインタアドレス

uint32_t *src 転送元メモリ領域のポインタアドレス

リターン値 なし

補足 なし
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6.9.4 R_SHM_Load_int32

6.9.5 R_SHM_Load_uint16

6.9.6 R_SHM_Load_int16

R_SHM_Load_int32

概　要 共用メモリ領域用 int 4 バイトデータロード処理

宣　言 int32_t R_SHM_Load_int32(int32_t *dst, int32_t *src)

説　明 共用メモリ領域に対する int 4 バイトデータのロード処理を行います。

引　数 int32_t *dst 転送先メモリ領域のポインタアドレス

int32_t *src 転送元メモリ領域のポインタアドレス

リターン値 なし

補足 なし

R_SHM_Load_uint16

概　要 共用メモリ領域用 uint 2 バイトデータロード処理

宣　言 int32_t R_SHM_Load_uint16(uint16_t *dst, uint16_t *src)

説　明 共用メモリ領域に対する uint 2 バイトデータのロード処理を行います。

引　数 uint16_t *dst 転送先メモリ領域のポインタアドレス

uint16_t *src 転送元メモリ領域のポインタアドレス

リターン値 なし

補足 なし

R_SHM_Load_int16

概　要 共用メモリ領域用 int 2 バイトデータロード処理

宣　言 int32_t R_SHM_Load_int16(int16_t *dst, int16_t *src)

説　明 共用メモリ領域に対する int 2 バイトデータのロード処理を行います。

引　数 int16_t *dst 転送先メモリ領域のポインタアドレス

int16_t *src 転送元メモリ領域のポインタアドレス

リターン値 なし

補足 なし
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6.9.7 R_SHM_Load_uint8

6.9.8 R_SHM_Load_int8

6.9.9 main（Cortex-R4）

R_SHM_Load_uint8

概　要 共用メモリ領域用 uint 1 バイトデータロード処理

宣　言 int32_t R_SHM_Load_uint8(uint8_t *dst, uint8_t *src)

説　明 共用メモリ領域に対する uint 1 バイトデータのロード処理を行います。

引　数 uint8_t *dst 転送先メモリ領域のポインタアドレス

uint8_t *src 転送元メモリ領域のポインタアドレス

リターン値 なし

補足 なし

R_SHM_Load_int8

概　要 共用メモリ領域用 int 1 バイトデータロード処理

宣　言 int32_t R_SHM_Load_int8(int8_t *dst, int8_t *src)

説　明 共用メモリ領域に対する int 1 バイトデータのロード処理を行います。

引　数 int8_t *dst 転送先メモリ領域のポインタアドレス

int8_t *src 転送元メモリ領域のポインタアドレス

リターン値 なし

補足 なし

main

概　要 メイン処理

宣　言 int main (void)

説　明 Cortex-R4 コア用ユーザアプリケーションプログラムです。

引　数 なし

リターン値 なし

補足 なし
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6.9.10 init_cm3（Cortex-R4）

6.9.11 main（Cortex-M3）

6.9.12 R_IRQ9_isr（Cortex-R4）

init_cm3

概　要 Cortex-M3 コア初期化処理

宣　言 void init_cm3(void)

説　明 Cortex-M3 用プログラムコードを外付け Flash から拡張内蔵 RAM へコピーし、

Cortex-M3 のリセット解除を行います。

引　数 なし

リターン値 なし

補足 RAM 実行版では、Cortex-M3 のリセット解除のみを行い、プログラムのコピーは行い

ません。

main

概　要 メイン処理

宣　言 int main(void)

説　明 Cortex-M3 コア用ユーザアプリケーションプログラムです。

引　数 なし

リターン値 なし

補足 なし

R_IRQ9_isr

概　要 IRQ9 割り込み（IRQ 端子割り込み 5）処理

宣　言 void R_IRQ9_isr(void)

説　明 LED0 の点灯状態を共有メモリに書き込みます。

引　数 なし

リターン値 なし

補足 なし
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6.9.13 IRQ_INTERCPU_IRQHandler
IRQ_INTERCPU_IRQHandler

概　要 CPU 間割り込み処理

宣　言 void IRQ_INTERCPU_IRQHandler(void)

説　明 Cortex-R4 コアからの割り込み要求通知による割り込み処理です。g_ready_flag を

セットします。

引　数 なし

リターン値 なし

補足 なし
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6.10 フローチャート

6.10.1 共用メモリドライバ初期化処理

図 6.5 に共用メモリドライバ初期化処理のフローチャートを示します。

注 1. Cortex-R4 のみ実行

図 6.5 共用メモリドライバ初期化処理

R_SHM_Init

戻り値 = SHM_SUCCESS

semfnoが範囲外?

戻り値 = SHM_ERR

Yes

No

セマフォレジスタの再定義 SEMFREG ← semfno番号のSYTSEMFnレジスタのポインタ

リードクリア機能を有効

リソース空き状態に設定

SYTSEMFEN.SEMFEN ← 1
SYTSEMFn.SEMFn  ←  1

注1



R01AN2989JJ0131 Rev.1.31 Page 23 of 46
2018.07.13

RZ/T1グループ R-IN Engine搭載製品　初期設定

6.10.2 共用メモリ領域用メモリコピー処理

図 6.6 に共用メモリ領域用メモリコピー処理のフローチャートを示します。

図 6.6 共用メモリ領域用メモリコピー処理

R_SHM_memcpy

戻り値 = SHM_SUCCESS

Yes

リソース空き状態に設定 SYTSEMFn.SEMFn  ←  1

リソース空き状態?

メモリコピー処理

No
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6.10.3 共用メモリ領域用 uint 4 バイトデータロード処理

図 6.7 に共用メモリ領域用 uint 4 バイトデータロード処理のフローチャートを示します。

6.10.4 共用メモリ領域用 int 4 バイトデータロード処理

フローチャートは図 6.7 を参照してください。但し、ロードするデータは int 4 バイトです

6.10.5 共用メモリ領域用 uint 2 バイトデータロード処理

フローチャートは図 6.7 を参照してください。但し、ロードするデータは uint 2 バイトです

6.10.6 共用メモリ領域用 int 2 バイトデータロード処理

フローチャートは図 6.7 を参照してください。但し、ロードするデータは int 2 バイトです

6.10.7 共用メモリ領域用 uint 1 バイトデータロード処理

フローチャートは図 6.7 を参照してください。但し、ロードするデータは uint 1 バイトです

6.10.8 共用メモリ領域用 int 1 バイトデータロード処理

フローチャートは図 6.7 を参照してください。但し、ロードするデータは int 1 バイトです

図 6.7 共用メモリ領域用 uint 4 バイトデータロード処理

R_SHM_Load_uint32

戻り値 = SHM_SUCCESS

Yes

No

リソース空き状態に設定

リソース空き状態?

uint 4バイトデータをロード
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6.10.9 メイン処理（Cortex-R4）
図 6.8 にメイン処理（Cortex-R4）のフローチャートを示します。

図 6.8 メイン処理（Cortex-R4）

main

共用メモリドライバ

初期化処理

Cortex-M3コア

初期化処理

LEDに接続しているPORT（PF7、P56）の初期設定を行います。

PF7 : 出力ポート

P56 : 出力ポート

共用メモリへLED点灯

表示データをロード

共用メモリのLED_DATAにLED点灯を示すデータを

uint 4バイトでロード

    LED_DATA ← LED_OUTPUT_DATA 

ポート設定

ECM設定

割り込み設定 CPU間割り込み(IRQ1）、外部端子割り込み(IRQ5）の設定を行います。

CPU間割り込みを発生 CPUINT.CM3INT ← 1

LED0の点滅処理 PF7トグル出力

セマフォレジスタ0の初期化を行います。
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6.10.10 Cortex-M3 コア初期化処理

図 6.9 に Cortex-M3 コア初期化処理のフローチャートを示します。

注 1. RAM 実行版では、実行しません。

図 6.9 Cortex-M3 コア初期化処理

init_cm3

Cortex-M3プログラムの

コピー処理

外付けFlashから拡張内蔵RAM I に
Cortex-M3のプログラムのコピーを行います。

注1

ソフトウェアリセット2を解除
ソフトウェアリセット2を解除して、

Cortex-M3コアをリセット解除します。

SWRR2 ← 0000 0000H

return
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6.10.11 メイン処理（Cortex-M3）
図 6.10 にメイン処理（Cortex-M3）のフローチャートを示します。

図 6.10 メイン処理（Cortex-M3）

main

共用メモリのLED_DATAからLED表示データを

uint 4バイトでロード

   g_led_data ← LED_DATA 

P56 をHigh出力(LED_DATA)

LED点灯表示データに応じて

LED1を出力制御

割り込み設定 CPU間割り込み（IRQ1）の設定を行います。

共用メモリドライバ

初期化処理
セマフォレジスタ0の初期化を行います。

共用メモリからLED
点灯表示データをロード

Yes

NoCPU間割り込みが発生?
（g_ready_flag = 1 ?）

LED1を点灯表示

共用メモリのLED_DATAからLED表示データを

uint 4バイトでロード

   g_led_data ← LED_DATA 
共用メモリからLED

点灯表示データをロード

P56 ：　LED_DATAに応じて High/Low出力
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6.10.12 R_IRQ9 割り込み（IRQ 端子割り込み 5）処理

図 6.11 に R_IRQ9 割り込み（IRQ 端子割り込み 5）処理のフローチャートを示します。

6.10.13 CPU 間割り込み処理

図 6.12 に CPU 間割り込み処理のフローチャートを示します。

図 6.11 R_IRQ9 割り込み（IRQ 端子割り込み 5）処理

図 6.12 CPU 間割り込み処理

R_IRQ9_isr

return

LED0の点灯状態を読み込み

LED表示データを共用メモリのLED_DATAへ
uint 4バイト書き込み

LED_DATA ← g_led_data

共用メモリへLED点灯

表示データを書き込み

g_ready_flag ← PORTF.PODR.BIT.B7

IRQ_INTERCPU_IRQHandler

return

g_ready_flagをセット
CPU間割り込み発生を示すフラグをセット

g_ready_flag ← 1
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7. サンプルプログラム
サンプルプログラムは、ルネサス エレクトロニクスホームページから入手してください。
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8. 参考ドキュメント
• ユーザーズマニュアル：ハードウェア

RZ/T1 グループ ユーザーズマニュアル ハードウェア編 
（最新版をルネサス エレクトロニクスホームページから入手してください。）

RZ/T1 Evaluation Board RTK7910022C00000BR ユーザーズマニュアル 
（最新版をルネサス エレクトロニクスホームページから入手してください。）

• テクニカルアップデート／テクニカルニュース

（最新の情報をルネサス エレクトロニクスホームページから入手してください。）

• ユーザーズマニュアル：開発環境

IAR 統合開発環境（IAR Embedded Workbench for Arm）に関しては、IAR ホームページから入手してく

ださい。

（最新版を IAR ホームページから入手してください。）

Arm 統合開発環境（Development Studio 5）に関しては、最新版を Arm ホームページから入手してくだ

さい。
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付録 1.各開発環境における補足内容
ここでは、本サンプルプログラムを各開発環境で Cortex-R4 コアと R-IN エンジン（Cortex-M3 コア）のデ

バッグを行う際の設定やデバッグ手順を説明します。

（EWARM : IAR 社製）

■サンプルプログラムのデバッグ手順例（SPI ブートモードの場合）

（1）EWARM を起動し、[File] → [Open] → [Workspace] で RZ_T1_init_cm3.eww を指定して Cortex-M3 用プロ

ジェクトを起動します。

（2）[Project] → [Rebuild All] を実行すると、バイナリファイル RZ_T1_init_cm3.bin が生成されます。

（3）(1) とは別の EWARM を起動し、[File] → [Open] → [Workspace] で RZ_T1_init_serial.eww を指定し、

Cortex-R4 用プロジェクトを起動します。また、[Project] → [Rebuild All] でビルドを実行します。

（4）RZ/T1 評価ボードと I-jet を接続した状態で、Cortex-R4 用プロジェクトで [Project] → [Download and 
Debug] を選択します。続けて Cortex-M3 用プロジェクトで [Project] → [Attach to Running Target] を選択

します。

注 . この時点で、Cortex-M3 コアはリセット状態のため、Cortex-M3 用プロジェクトのデバッグ実行は禁止です。

Cortex-R4 用プロジェクトのデバッグのみ実行可能です。
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（5）Cortex-R4 用プロジェクトの init_cm3 関数内の Cortex-M3 のリセット解除処理 を実行すると、Cortex-M3
コアがリセット解除され Cortex-M3 用プロジェクトのデバッグが可能になります。

（6）本サンプルプログラムでは Cortex-R4 コアから Cortex-M3 コアへ CPU 間割り込みを使用しています。実

際の動作と同じ順序でデバッグするには、先に Cortex-M3 用プロジェクトを実行させて割り込み設定や

共用メモリのデータロードを行います。次に Cortex-R4 用プロジェクトで CPU 間割り込みを発生させま

す。

（7）以降は、各コアのデバッグを継続して実行可能です。

Cortex-M3用プロジェクトの
デバッグが可能になります。

先にwhileまで

処理を進めます。CPU間割り込みの発生
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■サンプルプログラムのプロジェクト設定

R-IN Engine 搭載製品　初期設定サンプルプログラムに関する EWARM の設定を以下に示します。Cortex-
R4 用プロジェクトの詳細設定はアプリケーションノート「RZ/T1 グループ初期設定」を参照してください。

注1. Cortex-M3用バイナリイメージを セクション CM3_SECTIONに取り込みます。

注2. EWARM V8.10.1以降から必要になります。

オプションの詳細については IAR 社 C-SPY デバッグガイドの「C-SPY マクロ」や関連するドキュメント

を参照してください。

表 サンプルプログラムのプロジェクト設定（Cortex-R4）

ビルドアクション

ビルドアクション

設定

プリビルドコマンドライン cmd /c "copy /Y "$PROJ_DIR$¥..¥..¥Cortex-
M3¥Device¥Renesas¥RIN_Engine¥Source¥Project¥Init¥IAR¥Debug¥
Exe¥RZ_T1_init_cm3.bin" "$PROJ_DIR$¥cm3.bin¥RZ_T1_init_cm3.bin"" 

リンカ

入力注1 シンボルキープ CM3_SECTION

ローバイナリイメージ ファイル : $PROJ_DIR$¥cm3.bin¥RZ_T1_init_cm3.bin
シンボル : CM3_SECTION
セクション : CM3_SECTION
アラインメント : 4

デバッガ

追加オプション コマンドラインオプションの使用 チェックする

同期 非同期

--drv_default_breakpoint=1
--macro_param_etm_rute=2
--jet_emu_param=UseCTI=0注2

--drv_default_breakpoint=1
--macro_param_etm_rute=2
--jet_sigprobe_opt=shared

マルチコア 対称型マルチコア コアの数：1

非対称型マルチコア

マルチコアマスターモードの有効化

同期 非同期

チェックする

ポート：53461
スレーブワークスペース：
$PROJ_DIR$\..\..\Cortex-
M3\Device
\Renesas\RIN_Engine\Project\Init
\IAR\RZ_T1_init_cm3.eww
スレーブプロジェクト：
RZ_T1_init_cm3
スレーブ構成：Debug
スレーブを実行中のターゲットに

アタッチ：

チェックする

チェックしない

表 サンプルプログラムのプロジェクト設定（Cortex-M3）

出力コンバータ

出力 追加出力ファイルを生成 チェックする：

　出力フォーマット：バイナリ

出力ファイル

デフォルトのオーバライド

チェックする：

　$PROJ_DIR$¥RZ_T1_init_cm3.bin

デバッガ

追加オプション コマンドラインオプションの使用 同期 非同期

--drv_default_breakpoint=1 --drv_default_breakpoint=1
--jet_sigprobe_opt=shared
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（DS-5 : Arm 社製）

■サンプルプログラムのデバッグ手順例（SPI ブートモードの場合）

（1）ご利用 PC 上にサンプルプログラムを格納するためのワークスペースとして空のフォルダを作成しま

す。

（2）DS-5 を起動し、ワークスペースに①で作成したフォルダを指定します。

（3）[File] → [Import…] でインポート画面を開き、[General] → [Exiting Projects into Workspace] を選択して

[Next」を押します。
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（4）[Select archive file:] のラジオボタンにチェックを付け、[Browse…] を選択し、圧縮されたサンプルプロ

グラム（RZ_T1_R-IN_init_sflash.zip）を選択し、[Finish] を押します。

（5）[Project] → [Build All] を実行後、[Run] → [Debug Configurations] を選択します。

（6）RZ/T1 評価ボードと ULINK2 を接続した状態で、[DS-5 Debugger] → [sflash] を選択しデバッグ構成画面

を表示します。次に下記画面の [Browse] を選択し接続ブラウザを開きます。検出されたターゲット接

続を選択後、デバッグ構成画面の [Debug] を選択し Cortex-R4 コアのデバッグを開始します。

備考

RAM 実行版の場合は、以降の手順 (7)、(8)、(9) の代わりにデバッグ接続 ram（Cortex-R4）の接続解除の

みを行います。
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（7）ターゲット接続後、自動で ¥RZ_T_sflash_sample¥script_sflash フォルダにあるシリアルフラッシュ書き込

み用のスクリプトファイル RZ_T_sflash_sample.ds が実行されます。

(1)

(2)

(3)
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（8）スクリプトによるフラッシュ書き込みが完了すると、アプリケーションコンソール画面に「Flash 
Programming Complete」が表示され外付けフラッシュへの書き込みが完了します。

（9）System Reset を実行し、init_cm3 関数内の Cortex-M3 のリセット解除処理の直前にハードウェアブレー

クポイントを設定し、その処理まで実行します（ハードウェアブレークポイントは対象の処理の行番号

を右クリックし [DS-5 Breakpoints] → [Toggle Hardware Breakpoint] を選択することで設定します）。

（10）次に [Run] → [Debug Configurations…] で Debug Configurations 画面を開き、[DS-5 debugger] → [cm3_dual]
を選択し、⑥と同様に ULINK2 のターゲット接続を選択してデバッグ接続を行います（この時、スクリ

プトファイル：RZ_T_cm3.ds によって Cortex-M3 にリセットベクタキャッチが設定されます）。
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注 . この時点では Cortex-M3 コアはリセット状態のため、Cortex-M3 用プロジェクトのデバッグ実行は禁止です。

注 . Cortex-M3 に接続時に上記ダイアログが表示されることがありますが、”Run in Background” を選択してくださ

い。
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（11）次にデバッグ接続 sflash（Cortex-R4）にて Cortex-M3 のリセット解除処理を実行すると、Cortex-M3 コ

アがリセット解除され cm3_dual 接続（Cortex-M3）のデバッグが可能になります（⑩でのリセットベク

タキャッチ設定によって、リセットハンドラでブレークします）。

（12）この後は（EWARM : IAR 社製）■サンプルプログラムのデバッグ手順例 ⑥ 以降と同様の手順で各コア

のデバッグが可能です。

備考

デバッグ接続 cm3_single を使用することで、Cortex-M3 コア単体でのデバッグが可能です。ただし Debug 
Configurations で ULINK2 のターゲット接続の選択は必要です。
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■サンプルプログラムのプロジェクト設定

R-IN Engine 搭載製品　初期設定サンプルプログラムに関する DS-5 の設定を以下に示します。

注1. Cortex-M3用バイナリイメージをセクション CM3_SECTION として取り込みます。

オプションの詳細については Arm 社の関連するドキュメントを参照してください。

（e2studio : RENESAS 社製）

■サンプルプログラムのデバッグ手順例（SPI ブートモードの場合）

（1）ご利用 PC 上にサンプルプログラムを格納するためのワークスペースとして空のフォルダを作成しま

す。

（2）e2studio を起動し、ワークスペースに①で作成したフォルダを指定します。

（3）[File] → [Import…] でインポート画面を開き、[General] → [Exiting Projects into Workspace] を選択して

[Next」を押します。

（4）[Select archive file:] のラジオボタンにチェックを付け、[Browse…] を選択し、圧縮されたサンプルプロ

グラム（RZ_T1_R-IN_init_sflash.zip）を選択し、[Finish] を押します。

表 サンプルプログラムのプロジェクト設定（Cortex-R4）

Project->Properties-> C/C++ Build -> Settings

Build Steps注1 Pre-build steps Command: fromelf --bin --output =../cm3.bin 
../../RZ_T_cm3_sample/Debug/RZ_T_cm3_sample.axf

Post-build steps Command: after_build.bat ${ProjName} 
（RAM実行版は指定なし）
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（5）[Project] → [Build All] を実行後、[Run] → [Debug Configurations…] を選択し、Debug Configurations 画面

を開きます。

（6）RZ/T1 評価ボードと J-Link を接続した状態で、[Renesas GDB Hardware Debugging] → [sample_cr4 
HardwareDebug] を選択後、[Debug] を押すことで、Cortex-R4 コアのデバッグを開始します。



R01AN2989JJ0131 Rev.1.31 Page 42 of 46
2018.07.13

RZ/T1グループ R-IN Engine搭載製品　初期設定



R01AN2989JJ0131 Rev.1.31 Page 43 of 46
2018.07.13

RZ/T1グループ R-IN Engine搭載製品　初期設定

（7）ターゲット接続後、[Resume] を実行し Cortex-M3 のプログラム書き込み処理の前まで実行します。

（8）次に [Run] → [Debug Configurations…] で Debug Configurations 画面を開き、[Renesas GDB Hardware 
Debugging] → [sample_cm3 HardwareDebug] を選択し、[Debug] を押します。

この時点では Cortex-M3 コアのプログラムが書き込まれていないため、Cortex-M3 用プロジェクトのデ

バッグ実行は禁止です。

注 . [Debug] を押すと、既に実行しているデバッグ接続を切断するかどうかを選択する

下記ダイアログが表示されます。今回は Cortex-R4 コアと R-IN エンジン（Cortex-M3 コア）の制御を行うた

め “NO” を選択してください。

①

②
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（9）[Debug] ビューの「Sample_cr4.x」内の「Thread #xxx」にフォーカスがある状態で [Run] → [Step Over F6]
を押して、Cortex-M3 のプログラム書き込み処理を実行します。

（10）[Debug] ビューの「Sample_cm3.x」内の「Thread #xxx」を選択した状態で [Resume] を実行すると、

Cortex-M3 コアのデバッグが可能になります。

備考

デバッグ時にはデバッガから Cortex-M3 のリセット解除を行います。この後に Cortex-R4 によって再度リ

セット解除処理が実行されることになりますが、問題ありません

（デバッガを使用しない場合は、Cortex-R4 のリセット解除処理によって Cortex-M3 のリセットが解除されま

す）。

（11）この後は（EWARM : IAR 社製）■サンプルプログラムのデバッグ手順例 ⑥ 以降と同様の手順で各コア

のデバッグが可能です。

備考

「Sample_cr4.x」内の「Thread #xxx」を選択した場合は Cortex-R4 側のデバッグが、「Sample_cm3.x」内の

「Thread #xxx」を選択した場合は Cortex-M3 側のデバッグが可能になります。
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■サンプルプログラムのプロジェクト設定

R-IN Engine 搭載製品　初期設定サンプルプログラムに関する e2studio の設定を以下に示します。

注1. Cortex-R4のプロジェクトをビルドする際、自動的にCortex-M3のプロジェクトをビルドします。

注1. Cortex-R4側でCortex-M3用バイナリイメージをセクション .cm3 として取り込むためにバイナリデータをコピーします。

注1. "_PowerON_Reset"は各プロジェクトのエントリポイントです。エントリポイントが異なる場合は置き換えてください。

表 サンプルプログラムのプロジェクト設定（Cortex-R4）

Project->Properties->Project References

Project references for ‘sample_cr4’ 注1 sample_cm3 チェック

表 サンプルプログラムのプロジェクト設定（Cortex-M3）

Project->Properties-> C/C++ Build -> Settings

Build Steps注1 Post-build steps Command: arm-none-eabi-objcopy -I elf32-littlearm -O binary sample _cm3.x cm3.bin &
arm-none-eabi-objcopy -I binary -O elf32-littlearm -B arm --rename-section 
.data =.cm3, alloc, data, readonly,load,contents cm3.bin cm3.o & copy / Y 
cm3.o ..¥..¥sample_cr4¥cm3.bin¥cm3.o

表 サンプルプログラムのデバッグ構成

Run -> Debug Configurations

Debugger -> 
Connection Settings 
-> Connection

Reset on connection “NO”

Reset before run 【sample_cr4 HardwareDebug】
“YES”

【sample_cm3 HardwareDebug、
sample_cm3 HardwareDebug Load modules】
“NO”

Startup Runtime Options 【sample_cr4 HardwareDebug、sample_cm3 HardwareDebug】
「Set break point at:」にチェックつけ、

「_PowerON_Reset」を設定注1

Run Commands 【sample_cm3 HardwareDebug】
「set $pc=&_PowerON_Reset」を設定注1
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ホームページとサポート窓口

ルネサス エレクトロニクスホームページ

http://japan.renesas.com/

お問合せ先

http://japan.renesas.com/contact/
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Rev. 発行日
改訂内容

ページ ポイント

1.00 2015.10.15 — 初版発行

1.10 2016.02.15 全般

— ”デュアルコア制御”を、”R-IN Engine搭載製品　初期設定”へ記述変更

2. 動作環境

5 表2.1 動作環境　統合開発環境　一部修正

6. ソフトウェア説明

9 説明文追加

15 6.2.4　必要メモリサイズ　表6.7 タイトル一部追加、表6.8、表6.9 追加

付録1.各開発環境における補足内容

33 付録1.各開発環境における補足内容、一部記述変更

36 ～ 48 （DS-5 : ARM 社製）、（e2studio : RENESAS 社製）　全面改訂

1.20 2017.08.03 全体 Cortex-R4F → Cortex-R4に変更

2.　動作環境

5 表2.1 動作環境　統合開発環境の内容変更

6. 　ソフトウェア説明

— 6.2.4 必要メモリサイズ　削除

付録1.各開発環境における補足内容

31 (EWARM：IAR 社製 )　■サンプルプログラムのデバッグ手順例 (SPIブートモードの場合)　
(4)を変更：[Debug without Downloading] → [Attach to Running Target]

33 (EWARM：IAR 社製 )　■サンプルプログラムのプロジェクト設定　(表 )サンプルプログラム

のプロジェクト設定 (Cortex-R4)：変更、注2, 注3を削除

44 (e2studio : RENESAS 社製 )　■サンプルプログラムのデバッグ手順例(SPIブートモードの場

合 )　(7)：説明を変更、図を変更

44 (e2studio : RENESAS 社製 )　■サンプルプログラムのデバッグ手順例(SPIブートモードの場

合 )　(8)：説明を追加

45 (e2studio : RENESAS 社製 )　■サンプルプログラムのデバッグ手順例(SPIブートモードの場

合 )　(9)：説明を変更、図を削除

46 (e2studio : RENESAS 社製 )　■サンプルプログラムのプロジェクト設定　(表)サンプルプロ

グラムのデバッグ構成を変更、注1を追加

1.30 2018.04.27 全般 ARM→Arm に変更

2. 動作環境

5 表2.1 動作環境

統合開発環境の内容を変更、IARシステムズ製統合開発環境のバージョンを変更

6. ソフトウェア説明

11 表6.3 使用するセクション (Cortex-M3)
HEAPを readwriteの下に移動、MAIN_STACK領域を削除

13 図6.3 セクション配置 (Cortex-M3)　 HEAPを readwriteの下に移動

13 6.3 セクション配置 (Cortex-M3)　 MAIN_STACK領域を削除

16  表6.7 大域変数一覧　型 (uint32_t)の使用関数を変更

付録1. 各開発環境における補足内容

31, 32 (EWARM : IAR社製 ) サンプルプログラムのデバッグ手順例 (4)～ (6)の図を変更

33 (表 )サンプルプログラムのプロジェクト設定 (Cortex-R4)
デバッガ／追加オプションの同期を変更、注2.を追加

36 (DS-5 : ARM社製) サンプルプログラムのデバッグ手順例 (7)の説明、および図を変更

45 (表 )サンプルプログラムのプロジェクト設定 (Cortex-M3)　変更

45 (表 )サンプルプログラムのデバッグ構成　Startup／Run Commandsの説明を変更

1.31 2018.07.13 — サンプルプログラムの更新にともなう改版

すべての商標および登録商標は、それぞれの所有者に帰属します。

改訂記録
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