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Summary
This document explains about RZ/T1 Encoder I/F FA-CODER application package.

To use this application package, please obtain release package of "RZ/T1 Encoder I/F Configuration Library".

If you require detailed specifications of FA-CODER protocol and Tamagawa-Seiki encoder, please contact
Tamagawa-Seiki Co to obtain them.

Device that FA-CODER functionality is checked
RZ/T1 CPU Board (RTK7910018C00000BE)

Version History

Ver. Date Content Note
1.30 | April 2018 Updated sample program to Ver.1.3.
(1) Added ID macro definition for chl.
(2) Added the SCIFA sample program.
Update the RZ/T1 Group FA-CODER Interface (FAC) User's Manual.
1.20 February Updated sample program.
2017 (1) Improved the stability of the module stop release operation.
1.1 December Updated sample program.
2016 (1) Changed interrupt handler
1.0 October Updated sample program to Ver.1.1.
2016 (1) Updated the processing when EEPROM access reception busy state is 1.
Updated Configuration Data to Ver.1.3.
(1) Updated the error processing of EEPROM access.
Update the RZ/T1 Group FA-CODER Interface (FAC) User's Manual.
Update the RZ/T1 Group FA-CODER Sample Program Application Note.
0.7 October Newly created
2015
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RZ/T1 Group

Encoder I/F FA-CODER application package

1. Contents of package

Contents of this package are described in this chapter.

Configuration data and sample programs included in this package support only 1 channel of Encoder I/F. In order to
use 2 channels of Encoder I/F, obtain the RZ / T1 group Encoder | / F 2ch Tool (RO1AN4306) and change the
Configuration Data and sample program.

1.1 Software
* Source code
No. Title Version
1 A set of RZ/T1 FA-CODER sample driver code 1.3
- Configuration data
No. Title Version
1 RZ/T1 Encoder I/F Configuration Data(FA-CODER) 1.3
1.2 Document
No. Document name Ver. File name
1 RZ/T1 Encoder I/F FA-CODER 1.30 (English)

application package release note r01an3558ej0130-rzt1.pdf (this document)
(Japanese)
r01an3558jj0130-rztl.pdf

2 RZ/T1 Group FA-CODER Interface 1.20 (English)

(FAC)User’s Manual r01uh0621ej0120 rztl fa-coder.pdf
(Japanese)
r01uh0621jj0120 rzt1l fa-coder.pdf

3 RZ/T1 Group FA-CODER Sample 1.10 (English)

Program Application Note r01an2949ej0110 rztl fa-coder.pdf
(Japanese)
r01an2949jj0110 _rzt1l fa-coder.pdf

RO1AN3558EJ0130 Rev.1.30
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RZ/T1 Group Encoder I/F FA-CODER application package

2. File Structures
File structures and contents of this package are described below.

Top
—r01an3558ej0130-rzt1.pdf
—r01an3558jj0130-rzt1.pdf
L—workspace

—Software
|  F—armcc

L—RZ_T1_fac.zip : A set of RZ/T1 FA-CODER sample driver code (DS-5)

F—iccarm

\
|
| | “—RZ_T1 fac.zip : A setof RZ/T1 FA-CODER sample driver code (IAR)
|  —kpitgcc
\ L—RZ_T1_fac.zip : A set of RZ/T1 FA-CODER sample driver code (e2 studio)
L—Documentation

F—r01an2949ej0110_rztl_fa-coder.pdf

F—r01an2949jj0110_rzt1_fa-coder.pdf

F—r01uh0621ej0130_rztl_fa-coder.pdf

L—r01uh0621jj0130_rztl_fa-coder.pdf

The file structures of "RZ_T1_fac.zip" are shown in Figure 2.1 File Structure.

=  Top folder

©  common
< Common sources including initial settings
S drv
= scifa_uart
<l SCIFA sample program

o fac
i r_fac_rztl_config.h FA-CODER common driver file
< r_fac_rztl.c FA-CODER common driver file
o sample
¢ main.c Sample program

r_fac_rztl dat.s Linker setting file of the Configuration data *1

siochar.c SCIFA Sample program

siorw.c SCIFA Sample program

= inc

il iodefine.h RZ/T1 register definition file

i iodefine_fac.h FA-CODER register definition file

i r_fac_rztl_dat.h r_fac_rztl.dat header file

i r_fac_rztl_if.h FA-CODER common driver header file
o lib

(= ecl

4 r_fac_rztl.dat Multi-Protocol Encoder IF(FA-CODER mode) Configuration data

5 src

Note 1: file for DS-5 and e2 studio
DS-5: r_fac_rztl_dat.s
e2 studio: r_fac_dat_asm

Figure 2.1 File Structure

RO1AN3558EJ0130 Rev.1.30
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RZ/T1 Group

Encoder I/F FA-CODER application package

3. Information about FA-CODER sample program

This chapter describes information to use a set of FA-CODER sample driver.

3.1 Software information

3.1.1 Operating System

This software is independent from operating system.

3.1.2 Memory footprint

Memory Size
Section name IAR DS-5 e2 studio
[bytes] [bytes] [bytes]
FA-CODER Code 1352 2020 3904
sample driver Data (with initial value) 0 28 0
Data (without initial value) 78 52 80
Constant Data 40 40 44
Stack size R_FAC_Open 44 44 72
of function | R_FAC_Close 20 28 20
R_FAC_Control 20 48 72
R_FAC_GetVersion 0 0 0
facO_int_isr 112+n*1 | 56+n *1 64+n *1
FA-CODER Code 0 0 0
Configuration data Data (with initial value) 0 0 0
Data (without initial value) 0 0 0
Constant Data 9836 9836 9836
Sample program Code 3368 4556 6928
Data (with initial value) 80 55 40
Data (without initial value) 268 256 273
Constant Data 1780 129 1766

Note 1. "n" is the Maximum stack size of user defined callback functions that are registered to R_FAC_Control

function.

RO1AN3558EJ0130 Rev.1.30
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RZ/T1 Group Encoder I/F FA-CODER application package

3.2 Hardware information

3.2.1 Device
RzZ/T1

3.2.2 Target Board

(1) Board name
RZ/T1 CPU Board (RTK7910018C00000BE)

(2) Settings of CPU Board
SW4-1: ON
SW4-2: ON in case of serial flash memory is used, OFF in case of NOR flash memory is used
SW4-3: ON
SW4-4: ON
SW4-5: ON
SW4-6: OFF
JP2: 2-3 Connect
JP7: 1-2 Connect

RO1AN3558EJ0130 Rev.1.30 Page 6 of 13
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RZ/T1 Group Encoder I/F FA-CODER application package

3.3 Procedure on Development Environments

3.3.1 Preparation for the execution of the sample program
This sample program communicates with the PC. And for setting the PC, please refer to 6.1.2 Preparations of

"RZ/T1 Group FIFO Integrated Serial Communication Interface (SCIFA) Application Note".

3.3.2 EWARM from IAR systems
>  Build environment

IAR Embedded Workbench for ARM v7.80.2
>  Execution environment
I-jet
»  How to build sample program
1.  Extract files from RZ_T1_fac.zip and copy the files to arbitrary holder
2. Copy the following files of "RZ/T1 Encoder I/F Configuration Library" (for AR EWARM) to each folder
lib\ecl\r_ecl rztl.a
inc\r_ecl_rztl _if.h
3. Launch EWARM
4.  Select [File]menu -> [Open] -> [Workspace]
5. OpenRZ_T1 fac\RZ_T1_fac_****_ boot.eww

NOR version RZ_T1 fac_nor_boot.eww

Serial Flash version RZ_T1 fac_serial_boot.eww

6.  Select [Projectlmenu -> [Rebuild all]
Following file is generated.
Rz _T1 fac\Debug\Exe\RZ_T1 fac_**** boot.out
NOR version RZ_T1 fac_nor_boot.out

Serial Flash version RZ_T1 fac_serial _boot.out

»  How to execute sample program

After executing "How to build sample program", connect the target board and the debugger properly, and
execute the following operations.

1.  Select [Project] menu-> [Download and Debug]
2. Select [Debug] menu->[Go]

»  Execution result of sample program

After executing a sample program, input the command to "Terminal 1/0™ window.
Please refer to RZ/T1 Group A-format Sample Program Application Note about the command.

RO1AN3558EJ0130 Rev.1.30 Page 7 of 13
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RZ/T1 Group

Encoder I/F FA-CODER application package

3.3.3 DS-5 from ARM
> Build environment

ARM Development Studio 5 (DS-5) Version 5.25.0
ARM Compiler 5.06 update 3

>  Execution environment
ULINK2 (v2.01)

»  How to build sample program

1.  Extract files from RZ_T1_fac.zip and copy the files to arbitrary holder
2. Copy the following files of "RZ/T1 Encoder I/F Configuration Library"” (for ARM DS-5) to each folder
lib\ecl\r_ecl_rztl.a
inc\r_ecl_rztl_if.h
3. Launch DS-5
4.  Select [Window]menu -> [Show View] -> [Project Explorer]
5.  Click right button on [Project Explorer]view and then select [Import] of popup menu
6. Select [General] -> [Existing Projects into Workspace] of [Import] dialog and then click [Next] button
7. Click [Browse...] of [Import] dialog
8.  Select holder (the arbitrary holder of procedure 1 above) in [Browse For Folder] dialog and then click
[OK].
9. Select [Copy projects into workspace] of [Import] dialog
10. Click [Finish] of [Import] dialog
11. Select [Project] menu -> [Build All]
Following file is generated.
Debug\RZ_T_nor_sample.axf
(In case of serial flash, use the "RZ_T_sflash_sample.axf" instead of the "RZ_T_nor_sample.axf")
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RZ/T1 Group Encoder I/F FA-CODER application package

>  How to execute sample program

After executing "How to build sample program", connect the target board and the debugger properly, and
execute the following operations.

1. Open the debug configuration from the [Run] -> [Debug Configurations...], select the configuration
window for "RZ_T_nor_DL_and_Debug". (In case of serial flash, use the "RZ_T_sflash_DL_and_Debug"
instead of the "RZ_T_nor_DL_and_Debug")

Select "Debug Cortex-R4" of "RZ/T1 R75910x18 (Generic)" in [Select target].

Select the ULINK?2 of [Target Connection] in [Connection] tab, click on [Browse] and select the target
connection from the list in the window. Click on [Debug] in the debug configurations window and start

debugging.
< Debug Configurations (B
Create, manage, and run configurations _ w
- Y
= X | E &~ Name: RZ_T_nor_DL_and_Debug
| - Connection ™[ Files| £ Debugger| f OS Awareness | ¢9= Arguments | I Environment
[£] ©/C++ Application .
. Select target
[E] C/C++ Attach to Application . .
[£] C/C++ Postmortem Debugger Select the manufacturer, board, project type and debug operation to use. Currently selected:
Renesas / RZ/T1 R75910x18 (Generic) / Bare Metal Debug / Debug Cortex-R4
[£] C/C++ Remote Application
4 & DS-5 Debugger Filter platforms
£5 RZ_T_ner_ConnectOnly
I #%# RZ_T_nor_DL_and_Debug I (1) ' RZJ'Ti ::zzigxi: (EEHE”CJ
5 RZ_T_nor_SymLoad_and_Debug ’ ) R?Sglnxls (GEHEHCJ
&' IronPython Run “ IX b( eneric)
&’ IronPython unittest # Bare Metal Debug
Debug Cortex-M3
E4 Java Applet o
[31 Java Application s
» RZ/T1 RTK7910018500000BE
Ju JUnit -
A7 Jython run )
B Launch Group DTSL Options Edit: Configure ULINK2 trace or other target options. Using "default” configuration options
B3 ryDev Djange
L3 PyDev Google App Run DS-5 Debugger will connect to a ULINKZ to debug a bare metal application.
@ Python Run -
& Python unittest CEEEETTS =
% femete Java Applcaten Bare Metal Debug | Connection S
« m 3
Apply Revert
Filter matched 21 of 21 items = =
(5]
\/':7:' I[ Debug ]l [ Close
RO1AN3558EJ0130 Rev.1.30 Page 9 of 13
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RZ/T1 Group
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2.

On completion of writing to the flash memory by the script, the message "Flash Programming Complete"

appears in the application console window. Debugging can then start.

4 3 Cortex-R4 #1 stopped on breakpoint

W& RZT_nor DL and Debug connected
9
No O Support

Calculating Data Size...

Hum Enb Low Addr High Addr Attributes

+set var $CP1S::SSystem::$CP1S_AUXILIARY CONTROL.ATCMPCEN = 1
Target has been reset

Execution stopped in SVC mede due to a breakpoint or watchpoin
@xFFFFB008  LDR pe,[pc,#24] ; [@xFFFFBB28] =
+set var $CP15::$System: :$CP15_AUXTLTARY_CONTROL.BBTCMPCEN = 1

+file ".\RZ_T_nor_sample\DebughRZ T nor_sample.axf” s

. i »

Command:

BxFFFFe@48 (=

== Locals

[

S DS-5 Debug - Eclipse Platform [EER=T
File Edit Mavigate Search Project Run Window Help
= BEHE 2 » L i s e Quick Access | [ | B
5 Debug C... 53 [75 ProjectE.. g RemoteS.. = B | Commands i & G B8 >8 ®=Va. 3 i = A8
= | £ Sﬁ‘ Q- vl m = = ¢ ) - 7<§|, Linked: RZ_T_nor_DL_and_Debug = $ -
- ARNTHG (CHD t running - %, Linked: RZ T _nor DL_and Debug =
+reset
4 @& RZ_T_nor_DL_and_Debug connected +info memory Name LElia ilype|SatntSeelii

0 variables

= OxFFFF0000 1: y APB:@x@@80088 APE:@xFFFFFEFF rw, nobp, nohbp, nocache (= File Static Variables 0 of 31 variables
2: y  AHB:@xB@EEBER AHE:8xFFFFFEFF rw, nobp, nohbp, nocache (= Globals 0 of 3 variables
3: y  ©OxB000E000 @xFFFFFFFF rw, nocache, verify

B App Console 32 & e &E = =g
G, Linked: RZ_T_nor_DL_and_Debug + o
loop=2, file=LOADER_RESET_HANDLER, flash address=@x48688200. -

ﬁ) Linked: RZ_T_nor_DL_and_Debug ~

Dats Size is 3308 @ E]J ~ <Next Instruction> 100

Programing Flash... Address | Opcode | Disassembly

Verifying Flash... . % @xFFFFo0ee LDR pc,[pca#24] 5 =~
loop=2, Flash Programming Success!! OxFFFFREEL LDR pe, [pe,#24] ;[2
loop=3, file:LOADEiLIILROOT, flash address=ex40006200. BxFFFFBEes LDR pc, [pc,#24] 3
Calculating Data Size... BxFFFFBaac LDR pc,[pc,#24] ;
Data Size is 192 BxFFFFB810 LDR pe, [pe,#24] ;
Programing Flash... OxFFFFB014 LDR pc, [pe,#24] ;
verifying Flash... . OxFFFF@o1s LDR pc,[pc,#24] ;
loop=3, F}ash Programming Success!! BxFEEFBRLC LDR pe, [pc,824] ;
loop=4, ‘f11e=INIT,‘ﬂash address=0x48020000. L BxFFFFRA2e DCI axffffeesna ; ?
Calculating Data Size... 3 BxFFFFBe24 DCI exffffee7e ; 2
Data Size is 41508 oxFFFF@828 DCT exffffee7a ; ?
Programing Flash... exFFFFOR2C la exffffeers ; ?
Verifying Flash... . BxFFFFB030 DCI exffffee7c ; ?
loop=4, Flash Programming Succe§s!! BxFFFFBE34 DCI exffffeese ; ?
loop=5, Could not open file. Exiting. 2
Flash Programming Complete - 1 i v

Q RZ_T_nor_DL_and_Debug connected (Renesas - RZ/T1 RTK7910022C00000BR)

»  Execution result of sample program

After executing a sample program, input the command to "Terminal 1/0" window.

Please refer to “RZ/T1 Group FA-CODER Sample Program Application Note” about the command.

RO1AN3558EJ0130 Rev.1.30
April 2, 2018
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RZ/T1 Group Encoder I/F FA-CODER application package
3.34 e2 studio from RENESAS
> Build environment
RENESAS e2 studio 5.2.0.020
KPIT GNUARM-NONE-EABI Toolchain v16.01

»  Execution environment
J-Link BASE
»  How to build sample program
1.  Extract files from RZ_T1_fac.zip and copy the files to arbitrary holder
2. Copy the following files of "RZ/T1 Encoder I/F Configuration Library" (for KPIT GCC) to each folder
lib\ecl\r_ecl_rztl.a
inc\r_ecl_rztl_if.h
Launch the e2studio
Select [Window]menu -> [Show View] -> [Project Explorer]
Click right button on [Project Explorer]view and then select [Import] of popup menu
Select [General] -> [Existing Projects into Workspace] of [Import] dialog and then click [Next] button
Click [Browse...] of [Import] dialog

© N o o A w

Select holder (the arbitrary holder of procedure 1 above) in [Browse For Folder] dialog and then click
[OK].

9. Select [Copy projects into workspace] of [Import] dialog
10. Click [Finish] of [Import] dialog
11. Select [Project] menu -> [Build All]

Following file is generated.

HardwareDebug\ RZ_T_nor_sample.x

(In case of serial flash, use the "RZ_T_sflash_sample.x" instead of the "RZ_T_nor_sample.x")

RO1AN3558EJ0130 Rev.1.30 Page 11 of 13
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RZ/T1 Group Encoder I/F FA-CODER application package

>  How to execute sample program

After executing "How to build sample program", connect the target board and the debugger properly, and
execute the following operations.

1.  Select [Run] from the [Project] menu and then select [Debug Configurations].

2. Select the [RZ_T_nor_sample_HardwareDebug] in the following screen. Click the [Debug] and start the
download to flash memory.

(In case of serial flash, use the [RZ_T_sflash_sample_HardwareDebug] instead of the
[RZ_T_nor_sample_HardwareDebug])

Debug Configurations

Create, manage, and run configurations

; =
B A=
= —T

Name: RZ_T_nor_sample HardwareDebug

Eype filter text [E Main™._%s Debugger| = Startup| . Source| 5] Commeon

C/C++ Application
Praject:

[E7] Debug-only RZ_T_nor_sample | Browse... |

5
[E] C/C++ Remote Application
||
[e]

[£] GDB Hardware Debugging
» [c7] GDB Simulator Debugging (RL78, SH, RH850)
= Launch Group

C/C++ Application:

HardwareDebug¥RZ_T_nor_sample.x

4 [c7 Renesas GDB Hardware Debugging Variables... | | Search Project... | | Browse... |

I [£7 RZ_T_nor_sample HardwareDebug I

[c7] RZ_T_sflash_sample HardwareDebug

Build (if required) before launching

[&7] Renesas Simulater Debugging (RX) Build configuration: |U5e Active v|
Enable auto build Disable auto build
@ Use workspace settings Configure Workspace Settings...
Pl 1 3

Filter matched 12 of 14 items e i

.::?:. I Debug I | Close

3. Click the [Resume] from the [Run] to start execution of the sample program.

»  Execution result of sample program

After executing a sample program, input the command to "Terminal 1/0" window.
Please refer to RZ/T1 Group FA-CODER Sample Program Application Note about the command.

ile Edit Setup Control Window Help

RO1AN3558EJ0130 Rev.1.30 Page 12 of 13
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RZ/T1 Group

Encoder I/F FA-CODER application package

4. Restriction

None.

5. Note

Available time for user processing of Encoder I/F FA-CODER sample program in a control loop is as follows.

Please confirm that there are no problems in your environment.

The example of the case that the control cycle is 62.5us is indicated below.

The time used by the sample program is about 8.1 us (13%) of 62.5us, and available time for user processing is about

54.4 us (87%).
Processing Time Occupancy rate
FA-CODER sample Time sgtt!ng registers for | about 4.6 us about 8.1us 13%
processing *2 transmission
Interrupt time about 3.5 us
Available time for user processing about 54.4 us *1 87%

Note 1. Communication time with the encoder (when the number of data fields is three) is 35us of available time for
user processing. For more information, refer to the "RZ/T1 Group FA-CODER Interface (FAC) User's Manual".

Note2. Initial setting time is not included.
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