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Integrated Development Environment e2 studio 
e2 studio with Trac and Mylyn Trac Connector plug-in 

Introduction 
Trac is an enhanced wiki and issue tracking system for software development projects. Mylyn Trac Connector is a plug-
in for Eclipse. It provides the connector to access task repository of Trac from Eclipse. e2 studio is an integrated 
development environment based on Eclipse, so that e2 studio is possible to realize work with external tool using plugin 
of Eclipse. This document describes how to utilize Trac from e2 studio using Mylyn Trac Connector plugin 
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1. Introduction 

1.1 e2 studio with Trac and Mylyn Trac Connector plug-in 
Mylyn is a task-focused interfaced of Eclipse to keep track of the tasks. The tasks can be stored in local workspace or 
share with other thought task repositories. A task repository is a bug/ticket/issue tracker such as Bugzilla, Trac, JIRA, 
and other.  

The Mylyn Trac Connector provides Eclipse integration for accessing Trac issues including offline editing and access to 
attachments. e2 studio is an integrated development environment based on Eclipse, so that e2 studio is possible to 
realize work with external tool using plugin of Eclipse. 

 

1.2 Environment 
This document is described based on environment as the following: 

 e2 studio:  2.1.0.xx 

 Mylyn:    3.9.0 

 Trac:    1.0 

 Mylyn Trac Connector: 3.9.0 

 OS:   Windows 7 
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2. Install Mylyn Trac Connector plugin 

2.1 Prerequisites installation 
This section describes how to install the Mylyn Trac Connector plug-in to e2 studio. But at first, we need to prepare 
environments as below: 

• e2 studio is installed correctly 
• The Mylyn Task List is installed correctly 
• Trac is installed on server correctly 
 
This document will not describe use mylyn task list, how to install mylyn task list and e2 studio. 

2.2 Mylyn Trac Connector installation instruction 
Mylyn Trac Connector can be simply installed from within e2 studio using update manager. All what the user should do 
is just point update manager to the remote or local update-site. To install Mylyn Trac Connector: 

1. Start e2 studio and select menu item 'Help’ > ‘Install New Software...’ the ‘Install’ wizard opens. 
2. On ‘Work with’ field, direct to Mylyn update-site (http://download.eclipse.org/mylyn/releases/latest).  
 

 
 
3. Select ‘Mylyn Tasks Connector: Trac” item to install. 
4. Press the 'Next >' button.  
5. Accept terms of license agreement and click the 'Finish' button in order to start the download of selected features.  
6. To apply installation changes and restart e2 studio, press on the 'Yes' button.  
 

http://download.eclipse.org/mylyn/releases/latest
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3. Usage  

3.1 Workflow of connection from Trac issue to Mylyn Task List 

 
 
 
 
 
 
 

 

 

 
 
 
 
 
 
 

 

 

 

 

 

 

 

 

 

 
 

Figure 1   Workflow of connection from Trac issue to Mylyn task list 
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3.2 Architecture of Trac and e2 studio co-operation  

 
 

 
 
 

 

 
 
 

 
 
 

Figure 2: Architecture of Trac and e2 studio co-operation  
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3.3 Create Trac Task Repository 
To create a new Trac Task Repository: 

1. On the menu item of e2 studio, navigate to ‘Window’ > ‘Show view’ > ‘Other…’ > ‘Mylyn’ > ‘Task Repositories’ 
2. On the ‘Task Repositories’ view, right click to open context menu > ‘Add Task Repository…’ 
3.  The ‘Add Task Repository’ dialog will be shown, select a task repository type is ‘Trac’ > press the ‘Next’ button 
 

 
4. Modify settings: 
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a. Server: Specifies an URL server’s address  
b. Label: Specifies label will be used for Trac repository 
c. User name, password: uncheck ‘Anonymous’ and input username password (optional) 
d. Access Type: select method access repository:  

• XML-RCP: This access method offers editing of tasks in a rich editor, attachment support and offline editing. 
It requires the XmlRpcPlugin for Trac to be enabled for the accessed repository. (Please refer http://trac-
hacks.org/wiki/XmlRpcPlugin#Installation for installation instructions) 

• Web: the standard Trac web interface is used for repository access  
e. Keystore file, keystore password: input keystore file and keystore password by check on ‘Enable certificate 

authentication’ (optional) 
 
5. Press the ‘Finish’ button  
6. The ‘Add new query’ question dialog will be shown. Press the ‘Yes’ if user want to add a query to Task List for this 

repository. 
 

 
 
7. Trac task repository is created successfully 
 

 
 
 

3.4 New query 
To create new query for Trac task repository: 
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1. On the menu items of e2 studio, navigate to ‘Window’ > ‘Show view’ > ‘Other…’ > ‘Mylyn’ > ‘Task Repositories’  
2. Select a Trac task repository > right click to open context menu > select ‘New Query…’ 
3. The ‘Edit query’ dialog will be shown > modify the ‘Title’ field > edit query parameter 
 

 
 
4. Press the ‘Finish’ button to create new query of Trac successfully 
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3.5 New task (new ticket on Trac) 
To create new task for Trac task repository:  

1. On the menu item of e2 studio, navigate to ‘Window’ > ‘Show view’ > ‘Other…’ > ‘Mylyn’ > ‘Task Repositories’  
2. Select a Trac task repository > right click to open context menu > select ‘New Task…’ 
 

 
 
3. e2 studio invokes web-interface to create new ticket on Trac 
 

 
 
4. Modify information > Save 
5. Ticket will be created successfully 
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3.6 Set private for a task of Trac 
Set private for a task of Trac is only effective for e2 studio data. It does not change data on task repository of Trac. To 
set private for a task of Trac:  

1. On the menu items of e2 studio, navigate to ‘Window’ > ‘Show view’ > ‘Other …’ > ‘Mylyn’ > ‘Task List’ 
2. Select a task in category query of Trac task repository > ‘Open’  
3. On the ‘Private’ tab, set schedule, due day, estimate hour, make a note for task 

 
3.7 Open existing repository task 
To open existing repository task: 
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1. On the menu item of e2 studio, navigate to ‘Window’ > ‘Show view’ > ‘Other…’ > ‘Mylyn’ > ‘Task Repositories’ 
2. Select a task repository, right click > ‘Open Repository Task…’ 
 

 
 
3. The ‘Open Repository Task’ dialog will be shown > enter Key/ID to find repository task 
 

 
 
4. Press the ‘OK’ button to open repository task 
 



Integrated Development Environment e2 studio e2 studio with Trac and Mylyn Trac 
Connector plug-in 

R20AN0265EJ0100  Rev.1.00  Page 12 of 14 
Oct 01, 2013  

 

3.8 Synchronize task repository 
To ‘Synchronize task repository’:  

1. On the menu items of e2 studio, navigate to ‘Window’ > ‘Show view’ > ‘Other…’ > ‘Mylyn’ > ‘Task Repositories’ 
2. Right click on task repository > ‘Synchronize All Tasks’ 
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4. Reference Information 

4.1 Web Site 
Eclipse Mylyn plug-in home page URL: 

http://eclipse.org/mylyn  

Eclipse home page URL: 

http://eclipse.org  

Mylyn Documentation URL: 

http://wiki.eclipse.org/index.php/Mylyn/User_Guide  

How to install xml-rpc plugin URL: 

http://trac-hacks.org/wiki/XmlRpcPlugin#Installation  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

http://eclipse.org/mylyn
http://eclipse.org/
http://wiki.eclipse.org/index.php/Mylyn/User_Guide
http://trac-hacks.org/wiki/XmlRpcPlugin#Installation
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Website and Support <website and support,ws> 
Renesas Electronics Website 

http://www.renesas.com/ 
 
Inquiries 

http://www.renesas.com/contact/ 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
All trademarks and registered trademarks are the property of their respective owners. 

http://www.renesas.com/
http://www.renesas.com/contact/


 

A-1 

General Precautions in the Handling of MPU/MCU Products 
The following usage notes are applicable to all MPU/MCU products from Renesas. For detailed usage notes on the 
products covered by this document, refer to the relevant sections of the document as well as any technical updates that 
have been issued for the products. 

1. Handling of Unused Pins 
Handle unused pins in accord with the directions given under Handling of Unused Pins in the manual. 
 The input pins of CMOS products are generally in the high-impedance state. In operation with an 

unused pin in the open-circuit state, extra electromagnetic noise is induced in the vicinity of LSI, an 
associated shoot-through current flows internally, and malfunctions occur due to the false 
recognition of the pin state as an input signal become possible. Unused pins should be handled as 
described under Handling of Unused Pins in the manual. 

2. Processing at Power-on 
The state of the product is undefined at the moment when power is supplied. 
 The states of internal circuits in the LSI are indeterminate and the states of register settings and 

pins are undefined at the moment when power is supplied. 
In a finished product where the reset signal is applied to the external reset pin, the states of pins 
are not guaranteed from the moment when power is supplied until the reset process is completed. 
In a similar way, the states of pins in a product that is reset by an on-chip power-on reset function 
are not guaranteed from the moment when power is supplied until the power reaches the level at 
which resetting has been specified. 

3. Prohibition of Access to Reserved Addresses 
Access to reserved addresses is prohibited. 
 The reserved addresses are provided for the possible future expansion of functions. Do not access 

these addresses; the correct operation of LSI is not guaranteed if they are accessed. 
4. Clock Signals 

After applying a reset, only release the reset line after the operating clock signal has become stable. 
When switching the clock signal during program execution, wait until the target clock signal has 
stabilized. 
 When the clock signal is generated with an external resonator (or from an external oscillator) 

during a reset, ensure that the reset line is only released after full stabilization of the clock signal. 
Moreover, when switching to a clock signal produced with an external resonator (or by an external 
oscillator) while program execution is in progress, wait until the target clock signal is stable. 

5. Differences between Products 
Before changing from one product to another, i.e. to a product with a different type number, confirm 
that the change will not lead to problems. 
 The characteristics of an MPU or MCU in the same group but having a different part number may 

differ in terms of the internal memory capacity, layout pattern, and other factors, which can affect 
the ranges of electrical characteristics, such as characteristic values, operating margins, immunity 
to noise, and amount of radiated noise. When changing to a product with a different part number, 
implement a system-evaluation test for the given product. 



 

 

Notice
1. Descriptions of circuits, software and other related information in this document are provided only to illustrate the operation of semiconductor products and application examples.  You are fully responsible for

the incorporation of these circuits, software, and information in the design of your equipment.  Renesas Electronics assumes no responsibility for any losses incurred by you or third parties arising from the

use of these circuits, software, or information.

2. Renesas Electronics has used reasonable care in preparing the information included in this document, but Renesas Electronics does not warrant that such information is error free.  Renesas Electronics

assumes no liability whatsoever for any damages incurred by you resulting from errors in or omissions from the information included herein.

3. Renesas Electronics does not assume any liability for infringement of patents, copyrights, or other intellectual property rights of third parties by or arising from the use of Renesas Electronics products or

technical information described in this document.  No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights of Renesas Electronics or

others.

4. You should not alter, modify, copy, or otherwise misappropriate any Renesas Electronics product, whether in whole or in part.  Renesas Electronics assumes no responsibility for any losses incurred by you or

third parties arising from such alteration, modification, copy or otherwise misappropriation of Renesas Electronics product.

5. Renesas Electronics products are classified according to the following two quality grades: "Standard" and "High Quality".  The recommended applications for each Renesas Electronics product depends on

the product's quality grade, as indicated below.

       "Standard": Computers; office equipment; communications equipment; test and

       equipment; and industrial robots etc.

       "High Quality": Transportation equipment (automobiles, trains, ships, etc.); traffic control systems; anti-disaster systems; anti-crime systems; and safety equipment etc.

       Renesas Electronics products are neither intended nor authorized for use in products or systems that may pose a direct threat to human life or bodily injury (artificial

       implantations etc.), or may cause serious property damages (nuclear reactor control systems, military equipment etc.).  You must check the quality grade of each Renesas Electronics product before using it

in a particular application.  You may not use any Renesas Electronics product for any application for which it is not intended.  Renesas Electronics shall not be in any way liable for any damages or losses

incurred by you or third parties arising from the use of any Renesas Electronics  product for which the product is not intended by Renesas Electronics.

6. You should use the Renesas Electronics products described in this document within the range specified by Renesas Electronics, especially with respect to the maximum rating, operating supply voltage

range, movement power voltage range, heat radiation characteristics, installation and other product characteristics.  Renesas Electronics shall have no

       use of Renesas Electronics products beyond such specified ranges.

7. Although Renesas Electronics endeavors to improve the quality and reliability of its products, semiconductor products have specific characteristics such as the occurrence of failure at a certain rate and

malfunctions under certain use conditions.  Further, Renesas Electronics products are not subject to radiation resistance design.  Please be sure to implement

       possibility of physical injury, and injury or damage caused by fire in

      redundancy, fire control and malfunction prevention, appropriate treatment for aging degradation or any other appropriate measures.  Because the evaluation of microcomputer software alone is very difficult,

please evaluate the safety of the final products or systems manufactured by you.

8. Please contact a Renesas Electronics sales office for details as to

       products in compliance with all applicable laws and regulations that regulate the inclusion or use of controlled substances, including without limitation, the EU RoHS Directive.  Renesas Electronics assumes

no liability for damages or losses occurring as a result of your noncompliance with applicable laws and regulations.

9. Renesas Electronics products and technology may not be used for or incorporated into any products or systems whose manufacture, use, or sale is prohibited under any applicable domestic or foreign laws or

regulations.  You should not use Renesas Electronics products or technology described in this document for any purpose relating to military applications or use by the military, including but not limited to the

development of weapons of mass destruction.  When exporting the Renesas

       regulations and follow the procedures required by such laws and regulations.

10. It is the responsibility of the buyer or distributor of Renesas Electronics products, who distributes, disposes of, or otherwise places the product with a third party, to notify such third party in advance of the

contents and conditions set forth in this document, Renesas Electronics assumes no responsibility for any losses incurred by you or third parties as a result of unauthorized use of Renesas Electronics

products.

11. This document may not be reproduced or duplicated in any form, in whole or in part, without prior written consent of Renesas Electronics.

12. Please contact a Renesas Electronics sales office if you have any questions regarding the information contained in this document or Renesas Electronics products, or if you have any other inquiries.

(Note 1) "Renesas Electronics" as used in this document means Renesas Electronics Corporation and also includes its majority-owned subsidiaries.

(Note 2) "Renesas Electronics product(s)" means any product developed or manufactured by or for Renesas Electronics.

the event of the failure of a Renesas Electronics product, such as safety design for hardware and software including but not limited to

environmental matters such as the environmental compatibility of each Renesas Electronics product.  Please use Renesas Electronics

liability for malfunctions or damages arising out of the

safety measures to guard them against the

life support devices or systems, surgical

http://www.renesas.com

11F., Samik Lavied' or Bldg., 720-2 Yeoksam-Dong, Kangnam-Ku, Seoul 135-080, Korea
Tel: +82-2-558-3737, Fax: +82-2-558-5141

Unit 906, Block B, Menara Amcorp, Amcorp Trade Centre, No. 18, Jln Persiaran Barat, 46050 Petaling Jaya, Selangor Darul Ehsan, Malaysia
Tel: +60-3-7955-9390, Fax: +60-3-7955-9510

80 Bendemeer Road, Unit #06-02 Hyflux Innovation Centre Singapore 339949
Tel: +65-6213-0200, Fax: +65-6213-0300

13F, No. 363, Fu Shing North Road, Taipei, Taiwan
Tel: +886-2-8175-9600, Fax: +886 2-8175-9670

Unit 1601-1613, 16/F., Tower 2, Grand Century Place, 193 Prince Edward Road West, Mongkok, Kowloon, Hong Kong
Tel: +852-2886-9318, Fax: +852 2886-9022/9044

Unit 204, 205, AZIA Center, No.1233 Lujiazui Ring Rd., Pudong District, Shanghai 200120, China
Tel: +86-21-5877-1818, Fax: +86-21-6887-7858 / -7898

7th Floor, Quantum Plaza, No.27 ZhiChunLu Haidian District, Beijing 100083, P.R.China
Tel: +86-10-8235-1155, Fax: +86-10-8235-7679

Arcadiastrasse 10, 40472 D
Tel: +49-211-65030, Fax: +49-211-6503-1327

üsseldorf, Germany

Dukes Meadow, Millboard Road, Bourne End, Buckinghamshire, SL8 5FH, U.K
Tel: +44-1628-651-700, Fax: +44-1628-651-804

1101 Nicholson Road, Newmarket, Ontario L3Y 9C3, Canada
Tel: +1-905-898-5441, Fax: +1-905-898-3220

2880 Scott Boulevard Santa Clara, CA 95050-2554, U.S.A.
Tel: +1-408-588-6000, Fax: +1-408-588-6130

Refer to "http://www.renesas.com/" for the latest and detailed information.
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measurement equipment; audio and visual equipment; home electronic appliances; machine tools; personal electronic

Electronics products or technology described in this document, you should comply with the applicable export control laws and
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