LENESANS RELEASE NOTE

RO1AN3595EJ0110
RZ/T1 Group SEJ0LL0
Encoder I/F HIPERFACE DSL application package September 27, 2018
Summary

This document explains about RZ/T1 Encoder I/F HIPERFACE DSL application package.
To use this application package, obtain release package of “RZ/T1 Encoder I/F Configuration Library” on the

Renesas Electronics website.

Device that HIPERFACE DSL functionality is checked
RZ/T1 CPU Board (RTK7910018C00000BE)
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RZ/T1 Group

Encoder I/F HIPERFACE DSL application package

Version History

Ver.

Date

Description

Note

1.10

September
2018

Updated User’s Manual to Ver.1.31
Refer to the REVISION HISTORY

Updated sample program

® Fixed the iodefine_hfdsl.h file
® Changed the operation procedure of DS-5 and e2 studio.

1.00

April
2018

Updated User’s Manual to Ver.1.30
Refer to the REVISION HISTORY

Updated sample program to Ver.1.5

®  Fixed interrupt processing

Updated note of this document

®  Fast position after protocol initialization

0.94

February
2018

Updated User’s Manual to Ver.1.30 (Preliminary version)
Refer to the REVISION HISTORY

Updated sample program to Ver.1.4

®  Fixed the protocol initialization processing
®  Fixed interrupt processing
®  Supported the EXLEN, EXTRA register

Updated configuration data to Ver.1.3
®  Supported the EXTRA bit

0.93

December
2017

Updated User’s Manual to Ver.1.11

®  Added register that set stuffing processes
®  Added descriptions of short message

0.92

December
2017

Updated sample program to Ver.1.3

®  Fixed the protocol initialization processing
®  Fixed interrupt processing

Updated configuration data to Ver.1.2

®  Fixed data of the quality monitor

® Fixed data of the equalization

® Fixed frame output timing in SYNC mode

®  Fixed so that the stuffing value does not exceed the upper limit

Updated Application Note to Ver.1.20
Refer to the REVISION HISTORY

0.9

September
2017

Updated sample program to Ver.1.20

®  Fixed the protocol initialization processing

Updated configuration data to Ver.1.1

Fixed RSSI processing

Fixed line delay processing

Fixed update timing of MAXDEVR register

Fixed estimator processing

Fixed the abnormal data output processing of RAW_FIFO function
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RZ/T1 Group

Encoder I/F HIPERFACE DSL application package

Ver.

Date

Description

Note

0.8

June 2017

Updated sample program to Ver.1.0
® Be compatible with EWARM form IAR systems and DS-5 from ARM

Updated configuration data to Ver.1.0

® Corresponds to all functions described in user's manual from Ver.0.1

Updated User’s Manual to Ver.1.10
Refer to the REVISION HISTORY

Newly created Application Note

0.1

January 2017

Newly created
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RZ/T1 Group Encoder I/F HIPERFACE DSL application package
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RZ/T1 Group

Encoder I/F HIPERFACE DSL application package

1. Contents of package

Contents of this package are described in this chapter.

1.1 Software
= Source code
No. Title Version
1 A set of RZ/T1 HIPERFACE DSL sample driver code 15
- Configuration data
No. Title Version
1 RZ/T1 Encoder I/F Configuration Data (HIPERFACE DSL) 1.3
1.2 Document
No. Document name Ver. File name
1 RZ/T1 Encoder I/F HIPERFACE DSL 1.10 (English)

application package release note r01an3595ej0110-rzt1.pdf (this document)
(Japanese)
r01an3595jj0110-rztl.pdf

2 RZ/T1 Group HIPERFACE DSL (HFDSL) 1.31 (English)

Interface User's Manual r01uh0731ej0131-rzt1-hfdsl.pdf
(Japanese)
r01uh0731jj0131-rzt1-hfdsl.pdf
(Chinese)
r01uh0731cj0131-rztl1-hfdsl.pdf

3 RZ/T1 Group HIPERFACE DSL Sample 1.30 (English)

Program APPLICATION NOTE r01an3869ej0130-rzt1-hfdsl.pdf
(Japanese)
r01an3869jj0130-rzt1-hfdsl.pdf
(Chinese)
r01an3869cj0130-rzt1-hfdsl.pdf
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RZ/T1 Group Encoder I/F HIPERFACE DSL application package
2. File Structures

File structures and contents of this package are described below.

Top
F—r01an3595ej0110-rzt1.pdf
F—r01an3595jj0110-rzt1.pdf
L—workspace

—Software
|  F—iccarm

| | “—RZ_T1_hfdsl.zip ‘A set of RZ/T1 HIPERFACE DSL sample driver code (IAR)
|  F—armcc
| | “—RZ_T1_hfdsl.zip :A set of RZ/T1 HIPERFACE DSL sample driver code (DS-5)
|  —kpitgcc
| L—RZ_T1_hfdsl.zip ‘A set of RZ/T1 HIPERFACE DSL sample driver code (e2 studio)
L—Documentation

F—r01an3869cj0130-rzt1-hfdsl.pdf

F—r01an3869ej0130-rzt1-hfdsl.pdf

—r01an3869jj0130-rzt1-hfdsl.pdf

F—r01uh0731cj0131-rzt1-hfdsl.pdf

F—r01uh0731ej0131-rzt1-hfdsl.pdf

L—r01uh0731jj0131-rzt1-hfdsl.pdf

The file structures of “RZ_T1_hfdsl.zip” are indicated below.

= Top folder
= inc
v iodefine.h RZ/T1 register definition file
' iodefine_hfdsl.h HIPERFASE DSL register definition file
v r_hfdsl_rztl_dat.h r_hfdsl_rztl.dat header file
v r_hfdsl_rztl_if.h HFDSL sample driver header file

= lib
= ecl
<4 r_hfdsl_rztl.dat Multi-Protocol Encoder IF (HIPERFASE DSL mode) Configuration data
o src
=  common
¢ Common sources including initial settings
= drv
& hfdsl
¢ r_hfdsl_rzl.c HIPERFACE DSL sample program
v r_hfdsl_rz1_config.h HIPERFACE DSL sample program
= scifa_uart
¢} scifa_uart.c SCIFA sample driver
¢1  scifa_uart_userdef.c SCIFA sample driver
& sample
¢ main.c Sample program
¢ hfdsl_dat.asm Linker setting file of the Configuration data *1
] siorw.c SCIFA Sample program
] siochar.c SCIFA Sample program

Note 1: file for DS-5 / e2 studio
DS-5: hfdsl_dat.s
e2 studio: hfdsl_dat_asm
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RZ/T1 Group

Encoder I/F HIPERFACE DSL application package

3. Information about HIPERFACE DSL sample program

This chapter describes information to use a set of HIPERFACE DSL sample driver.

3.1 Software information

3.11

Operating System

This software is independent from operating system.

3.1.2 Memory footprint
Memory Size
Section name IAR DS-5 e2 studio
[bytes] [bytes] [bytes]
HFDSL Code 3052 3980 5752
sample driver Data (with initial value) 8 34 8
Data (without initial value) 87 64 96
Constant Data 96 96 108
Stack size R_HFDSL_Open 60 60 88
of function | R_HFDSL _Close 16 28 56
R_HFDSL _Control 48 120 128
R_HFDSL _GetVersion 0 0 4
hfdsl_int_nml_isr 128+n*1 | 56+n *1 80+n *1
hfdsl_int_err_isr 112+n*1 | 48+n*1 56+n *1
HFDSL Code 0 0 0
Configuration data Data (with initial value) 0 0 0
Data (without initial value) 0 0 0
Constant Data 43908 43908 43908
Sample program Code 1904 2580 3716
Data (with initial value) 32 59 30
Data (without initial value) 316 288 320
Constant Data 908 40 901

Note 1. "n" is the Maximum stack size of user defined callback functions that are registered to R_HFDSL_Control

function.
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RZ/T1 Group Encoder I/F HIPERFACE DSL application package

3.2 Hardware information

3.2.1 Device
RzZ/T1

3.2.2 Target Board
(1) Board name

RZ/T1 CPU Board (RTK7910018C00000BE)

(2) Settings of CPU Board
SW4-1: ON
SW4-2: ON in case of serial flash memory is used, OFF in case of NOR flash memory is used
SW4-3: ON
SW4-3: ON
SW4-4: ON
SW4-5: ON
SW4-6: OFF
JP2: 2-3 Connect
JP7: 1-2 Connect
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RZ/T1 Group Encoder I/F HIPERFACE DSL application package

3.3 Procedure on Development Environments

3.3.1 Preparation before the execution of the sample program

This sample program communicates with the PC. And for setting the PC, please refer to 6.1.2 Preparations of "RZ/T1
Group FIFO Integrated Serial Communication Interface (SCIFA) Application Note". Download the latest version of
USB serial port driver for PC from the link below.

https://www.renesas.com/jp/ja/software/D6000699.html

3.3.2 EWARM from IAR systems
> Build environment

IAR Embedded Workbench for ARM v8.20.2
> Execution environment
I-jet
»  How to build sample program
1.  Extract files from RZ_T1_hfdsl.zip and copy the files to arbitrary holder
2. Copy the following files of “RZ/T1 Encoder I/F Configuration Library” (for AR EWARM) to each folder
lib\ecl\r_ecl rztl.a
inc\r_ecl_rztl_if.h
3. Launch EWARM
4.  Select [File]menu -> [Open] -> [Workspace]
5. Open RZ_T1_hfdsl_boot\RZ_T1_hfdsl_**** boot.eww

NOR version RZ_T1_hfdsl_nor_boot.eww

Serial Flash version RZ_T1_hfdsl_serial_boot.eww

6. Select [Project]menu -> [Rebuild all]

Following file is generated.

RZ_T1 hfdsl_boot\Debug\Exe\RZ_T1_hfdsl_**** hoot.out
NOR version RZ_T1 _hfdsl_nor_boot.out

Serial Flash version RZ_T1 hfdsl_serial_boot.out

>  How to execute sample program

After executing “How to build sample program”, connect the target board and the debugger properly, and
execute the following operations.

1.  Select [Project] menu-> [Download and Debug]

2. Select [Debug] menu-> [Go]
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RZ/T1 Group Encoder I/F HIPERFACE DSL application package

>

Execution result of sample program

After executing a sample program, input the command to "Terminal 1/0" window.
Please refer to “RZ/T1 Group HIPERFACE DSL Sample Program Application Note” about the console
command.

M COM4 - Tera Term VT - O >
File Edit Setup Contrel Window Help

HFDSL sample program start A
htds| *HFDSL samele program start
hfds| »pos
Fast position
Fotations @ (00000083
bngle » Ux002243809
Safe position
Rotations @ 0x00000433
fngle » 00224806
Error information

EVENT_ERRE  : 000010040
hfds| >vel

Motor rotation speed
Speed . [xFFFFFFFB

Error information

EVENT_ERRE = 000070040

hfdsl »Imsg
Feceived data
FIFO_MSGRLOO] = 0x0D04
FIFO_MSGRLO1] : 00800
FIFO_MSGRLO2] @ 00000
FIFO_MSGRL03] & 00002
FIFO_MSGRL04] @ 0x0BO7
FIFO_MSGRIO5] @ 0x0305
Error information

EVENT_ERE @ 000010040

hfds| »shub
RAW data
Sensor Hub @ 0=00FE

Error information

EVENT_ERR 000070040
hfdsl >
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RZ/T1 Group Encoder I/F HIPERFACE DSL application package

3.3.3 DS-5 from ARM
> Build environment

ARM Development Studio 5 (DS-5) Version 5.26.2
ARM Compiler 5.06 update 4

> Execution environment
ULINK2 (v2.01)

»  How to build sample program

1.  Startup the DS-5 environment. Go to [File] > [Import]. On the [Import] window, select [Existing Projects into
Workspace] in the [General] folder and click the [Next] button.

2. Select the [Select archive file:] radio button and click on the [Browse...] button. Select the compressed program
file “RZ_T1_hfdsl.zip” on the list in the window and click on the [Finish] button.

3. Copy the following files of “RZ/T1 Encoder I/F Configuration Library” (for ARM DS-5) to each folder imported
and expanded.

lib\ecl\r_ecl_rztl.a
inc\r_ecl_rztl_if.h
4.  Select [Project] menu -> [Build All]
Following file is generated.
Debug\RZ_T_nor_sample.axf

(In case of serial flash, use the “RZ_T_sflash_sample.axf” instead of the “RZ_T_nor_sample.axf™)
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RZ/T1 Group

Encoder I/F HIPERFACE DSL application package

>  How to execute sample program

After executing “How to build sample program”, connect the target board and the debugger properly, and
execute the following operations.

1.

Open the debug configuration from the [Run] -> [Debug Configurations...], select the configuration
window for “RZ_T_nor_DL_and_Debug”. (In case of serial flash, use the “RZ_T_sflash_DL_and_Debug”
instead of the “RZ_T_nor_DL_and_Debug”)

Select “Debug Cortex-R4” of “RZ/T1 R75910x18 (Generic)” in [Select target].

Select the ULINK?2 of [Target Connection] in [Connection] tab, click on [Browse] and select the target
connection from the list in the window. Click on [Debug] in the debug configurations window and start

debugging.

% Debug Configurations

Create, manage, and run configurations

€] ¢/C++ Application
] C/C++ Attach to Application
[T] C/C++ Postmortem Debugger
[©] C/C++ Remote Application
#% DS-5 Debugger

#5 RZ_T_nor_ConnectOnly

[N

I #% RZ_T_nor_DL_and_Debug I{l}

#5 RZ_T_nor_SymLoad_and_Debug

A’ IronPython Run

@ IronPython unittest
il Java Applet

31 Java Application

Ju JUnit

A7 Jython run

& Jython unittest

= Launch Group

[0 PyDev Diange

43 PyDev Google App Run
& Python Run

& Python unittest

&, Remote Java Application

4 1

Filter matched 21 of 21 items

®@

Name: RZ_T_nor_DL_and_Debug

=jt= Connection Ijn_.-} Files| £ Debugger | ‘& 05 Awareness| (4= Arguments | f Environment

Select target

Select the manufacturer, board, project type and debug operation to use. Currently selected:
Renesas [ RZ/T1 R75910x18 (Generic) / Bare Metal Debug / Debug Cortex-R4

Filter platforms

- RZ/T1 R75910x16 (Generic)
> RZ/T1 R75910x17 (Generic)
4 RZ/T1 R75910x18 (Generic)

4 Bare Metal Debug
Debug Cortex-M3

Debug Cortex-R4 | (2)

> RZ/T1 RTK7910018500000BE

Target Connection ULINKZ v (@

DTSL Options Edit...

DS-5 Debugger will connect to a ULINK2 to debug a bare metal application.

Connections

Configure ULINK2 trace or other target options. Using "default” configuration options

Bare Metal Debug| connection ‘S

Browse...

ll [ Close
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RZ/T1 Group Encoder I/F HIPERFACE DSL application package

2. On completion of writing to the flash memory by the script, the message “Flash Programming Complete”
appears in the application console window. Debugging can then start.

< DS-5 Debug - Eclipse Platform [r=- [l
File Edit Mavigate Search Project Run Window Help
o P [ e i e ik rceess [ 1 | B
B Command: 33 & G B8 >8 ®=Va. 3 i = A8
%, Linked: RZ_T_nor_DL_and_Debug - $ -
ARNING(CMD31S): T2 running o <5, Linked: RZ_T_nor_DL_and_Debug =
+reset
4 @& RZ_T_nor_DL_and_Debug connected +info memory Name Value Type|Count Size Lo
4 $iit Cortex-R4 #1 stopped on breakpoint Mum Enb Low Addr High Addr Attributes B Locals 0 variables
= OxFFFF0000 1: y APB:0x2@888800 APE:@xFFFFFFFF rw, nobp, nohbp, nocache (= File Static Variables 0 of 31 variables
- 2: y  AHB:@xBBBBBEBB AHB:@xFFFFFFFF rw, nobp, nohbp, nocache (= Globals 0 of 3 variables
3: y  ©x00000000 BXFFFFFFFF rw, nocache, verify

+set var $CP15::3System: :3CP15_AUXILIARY_CONTROL.ATCMPCEN = 1
Target has been reset
Execution stopped in SVC mede due to a breakpoint or watchpoin

@xFFFF@e08  LDR pc,[pe,#24] ; [@xFFFF@@28] = BxFFFFB040 |5

+set var $CP15::3System: :$CP15_AUXILIARY_CONTROL.B@TCMPCEN = 1

+file ".\RZ_T_nor_sample\DebughRZ T nor_sample.axf” s

4 I » 1 I} r

W& RZT_nor DL and Debug connected
g

No 05 Support Command:
& App Console &2 B, Bk 5F = = n
4G, Linked: RZ_T_nor_DL_and_Debug = P
loop=2, file=LOADER_RESET_HANDLER, flash address=@x48688200. -

<§) Linked: RZ_T_nor_DL_and_Debug ~
Calculating Data Size...

Data Size is 3388 B & ~ <NetInstruction> 100
Programing Flash...

Address | Opcode | Disassembly
Verifying Flash...

. % @xFFFFoeo0 LDR pc,[pc,#24] ; »
loop=2, Flash Programming Success!! OxFFFFREEL LDR pe, [pe,#24] ;[2
loop=3, file:LOADEiLIN ROOT, flash address=0x40806208. BxFFFFBEes LDR pc, [pc,#24] 5
Calculating Data Size... BxFFFFBaac LDR pc,[pc,#24] ;
Data Size is 192 BxFFFFBa1e LDR pe, [pe,#24] 5
Programing Flash... OxFFFFB014 LDR pc, [pe,#24] ;
Verifying Flash... . oxFFFF@218 LDR pc,[pc,#24] ;
loop=3, F}ash Programming Success!! BxFEEFBRLC LDR pe, [pc,824] ;
loop=4, f11e=INIT,‘f1ash address=0x48020000 . L BxFFFFR@28 DCI exffffeess ; 7
Calculating Data Size... 3 BxFFFFBe24 DCI exffffee7e ; 2
Data Size is 41508 OxFFFFE028 DCT exffffeo7a ; ?
Programing Flash... exFFFFOR2C la exffffeers ; ?
Verifying Flash... . BxFFFFB030 DCI exffffee7c ; ?
loop=4, Flash Programming Succe§s!! BxFFFFBE34 DCI exffffeese ; ?
loop=5, Could not open file. Exiting. | T 2
Flash Programming Complete - 1 i v

Q RZ_T_nor_DL_and_Debug connected (Renesas - RZ/T1 RTK7910022C00000BR)
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RZ/T1 Group Encoder I/F HIPERFACE DSL application package

>  Execution result of sample program

After executing a sample program, input the command to "Terminal 1/0" window.
Please refer to “RZ/T1 Group HIPERFACE DSL Sample Program Application Note” about the console

command.

T COM4 - Tera Term VT — O x
File Edit Setup Contrel Window Help
HFOSL sample program start A
hfds| *HFDSL sample program start
hfds| »pos

Fast position
Rotations @ (00000083
brzle » Ux002243809
Safe position
Rotations @ 0x00000433
brgle » 00224806
Error information

EVENT_ERR 000010040

hfds| »vel
Motor rotation speed
Speed . [xFFFFFFFB

Error information

EVENT_ERR = 000070040

hfdsl »Imse

Feceived data
FIFO_MSGRLOO] = 0x0D04
FIFO_MSGRLO1] : 00800
FIFO_MSGRLO2] @ 00000
FIFO_MSGRL03] : 00002
FIFO_MSGRL0O4] @ 0x0BO07
FIFO_MSGRIOS] @ 0x0305

Error information

EVENT_ERE @ 000010040

hfds| »shub
FAW data
Sensor Hub @ 0x00FE

Error information

EVENT_ERR 000070040
hfd=l >
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3.34 e2 studio from RENESAS
> Build environment

RENESAS e2 studio 6.1.0.020
KPIT GNUARM-NONE-EABI Toolchain v16.01

>  Execution environment
J-Link BASE

»  How to build sample program

1.  Start up the e2 studio environment. In the workspace, go to [File] > [Import]. On the [Import] window, select
[Existing Projects into Workspace] in the [General] folder and click the [Next] button.

2. Select the [Select archive file:] radio button and click on the [Browse..] button. Select the compressed program
file “RZ_T1_hfdsl.zip” on the list in the window and click on the [Finish] button.

3. Copy the following files of “RZ/T1 Encoder I/F Configuration Library” (for KPIT GCC) to each folder imported
and expanded.

lib\ecl\r_ecl_rztl.a
inc\r_ecl_rztl_if.h
4.  Select [Project] menu -> [Build All]
Following file is generated.
HardwareDebug\ RZ_T_nor_sample.x

(In case of serial flash, use the “RZ_T_sflash_sample.x” instead of the “RZ_T_nor_sample.x”)
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Encoder I/F HIPERFACE DSL application package

>  How to execute sample program

After executing “How to build sample program”, connect the target board and the debugger properly, and

execute the following operations.

1. Select [Run] from the [Project] menu and then select [Debug Configurations].

2. Select the [RZ_T_nor_sample_HardwareDebug] in the following screen. Click the [Debug] and start the

download to flash memory.

(In case of serial flash, use the [RZ_T_sflash_sample_HardwareDebug] instead of the
[RZ_T_nor_sample_HardwareDebug])

Debug Configurations

Create, manage, and run configurations

o X| B 3 -
type filter text
[€] C/C++ Application
[£] C/C++ Remote Application
[£7 Debug-only
[£] GDB Hardware Debugging
» [£7] GDB Simulator Debugging (RL78, SH, RH850)
= Launch Group
4 [t7 Renesas GDB Hardware Debuqgging
I@ RZ_T_nor_sample HardwareDebug I
[E1 RZ_T_sflash_sample HardwareDebug
[£7 Renesas Simulator Debugging (RX)

<[ T 3

Filter matched 12 of 14 items

i~
@

Mame: RZ_T_nor_sample HardwareDebug
[Z Main

Project:

%5 Debugger| = Startup| & Source| [ Common

RZ_T_nor_sample ’ Browse... ]
C/C++ Application:
HardwareDebug¥RZ_T_nor_sample.x
Variables... l l Search Project... l ’ Browse... ]

Build (if required) before launching

Build configuration: ’Use Active

(71 Enable auto build

@ Use workspace settings

() Disable auto build

Configure Workspace Settings...

Apply

_n
[j+]
[15]

I Debug I [

Close

3. Click the [Resume] from the [Run] to start execution of the sample program.
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RZ/T1 Group Encoder I/F HIPERFACE DSL application package

>

Execution result of sample program

After executing a sample program, input the command to "Terminal 1/0" window.
Please refer to “RZ/T1 Group HIPERFACE DSL Sample Program Application Note” about the console
command.

M COM4 - Tera Term VT - O >
File Edit Setup Contrel Window Help

HFDSL sample program start A
htds| *HFDSL samele program start
hfds| »pos
Fast position
Fotations @ (00000083
bngle » Ux002243809
Safe position
Rotations @ 0x00000433
fngle » 00224806
Error information

EVENT_ERRE  : 000010040
hfds| >vel

Motor rotation speed
Speed . [xFFFFFFFB

Error information

EVENT_ERRE = 000070040

hfdsl »Imsg
Feceived data
FIFO_MSGRLOO] = 0x0D04
FIFO_MSGRLO1] : 00800
FIFO_MSGRLO2] @ 00000
FIFO_MSGRL03] & 00002
FIFO_MSGRL04] @ 0x0BO7
FIFO_MSGRIO5] @ 0x0305
Error information

EVENT_ERE @ 000010040

hfds| »shub
RAW data
Sensor Hub @ 0=00FE

Error information

EVENT_ERR 000070040
hfdsl >
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RZ/T1 Group Encoder I/F HIPERFACE DSL application package

4. Restriction

None.
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RZ/T1 Group Encoder I/F HIPERFACE DSL application package

5. Note

5.1 Processing time
Available time for user processing of Encoder I/F HFDSL sample program in a control loop is as follows.
Please confirm that there are no problems in your environment.
The example of the case that the control cycle is 62.5us is indicated below.

The time used by the sample program is about 4 us (6.1%) of 62.5 us, and available time for user processing is about
58.5 us (92.6%).

Processing Time Occupancy rate
HFDSL sample processing #2 | Time obtaining fast position | about 2 us about 4 us 6.1%

Interrupt time*3 about 2 us
Available time for user processing about 58.5 us *1 93.9%

Note 1. Communication time with the encoder (when the number of data fields is three) is 11.5 us of available
time for user processing. For more information, refer to the "RZ/T1 Group HFDSL Interface (HFDSL)
User's Manual".

Note2. Initial setting time is not included.

Note3. Time in the case of POS_RDY bit only interrupt enabled.

5.2 Fast position after protocol initialization

Fast position is corrected by the safe position and speed data. However, the fast position of 8 times after protocol
initialization is not corrected.

Example
| sync | | sync | | sync | sync sync
INIT_END I
POS_UPD 1 2 3 4 5 6 7 8 9
POS_RDY(PRDY=1) I | | | | | | I |
POS_RDY(PRDY=0) I | |
\_'_J \ r ]
Initialization of the Protocol Uncorrected the fast position @ H-frame
- stuffing
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