LENESAS RELEASE NOTE

RZ/T1 Group RO1AN3635EJ0230

Rev.2.30
Encoder I/F A-format application package October 1, 2019
Summary

This document explains about RZ/T1 Encoder I/F A-format application package.
To use this application package, please obtain release package of “RZ/T1 Encoder I/F Configuration Library”.

If you require detailed specifications of A-format™ industry standard and Nikon encoder, please contact Nikon
corporation to obtain them.

Device that A-format functionality is checked
RZ/T1 CPU Board (RTK7910018C00000BE)
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RZ/T1 Group

Encoder I/F A-format application package

Version History

Ver.

Date

Content

Note

2.30

October
2019

Update the RZ/T1 A-format sample driver code.

(1) Fixed bug of disables input of the ELC event triggers
processing.
(2) Fixed bug initialization of the internal variables.

2.20

August
2018

Update the RZ/T1 A-format sample driver code.

(1) Supported bypass reception for chl.

(2) Fixed bug of bypass reception processing.

(3) Changed the operation procedure of DS-5 and e2 studio.
(4) Added restriction

2.10

April 2018

Update the RZ/T1 A-format sample driver code.

(1) Added ID macro definition for chl.
(2) Changed register definition for chl.

Update the RZ/T1 Group A-format Interface User’s Manual.

2.00

April 2017

Update the RZ/T1 A-format sample driver code.
(1) Supported the Configuration Data Ver.1.8.

Updated Configuration Data to Ver.1.8.

(1) Added the bypass transmission and reception function using
FIFO.

(2) Added the received data setting completion Interrupt.

(3) Added the ELC Event Input Trigger.

Update the RZ/T1 Group A-format Interface User’s Manual.

Update the RZ/T1 Group A-format Sample Program Application
Note.

1.01

January
2017

Update the RZ/T1 A-format sample driver code.

(1) Improved the stability of the module stop release operation.

1.0

September
2016

Fixed bug of interrupt routine of sample program.

Update the RZ/T1 Group A-format Interface User’s Manual.

Update the RZ/T1 Group A-format Sample Program Application
Note.

0.8

June

2016

Fixed bug of macro value of sample program.
Fixed bug of interrupt routine of sample program.
Fixed bug of terminal screen display of sample program.

Changing the input method of the console commands of the
sample program.

Update the RZ/T1 Group A-format Interface User’s Manual.

Update the RZ/T1 Group A-format Sample Program Application
Note (Japanese).

Added the RZ/T1 Group A-format Sample Program Application
Note (English).

0.7

October
2015

Newly created
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RZ/T1 Group

Encoder I/F A-format application package

1. Contents of package

Contents of this package are described in this chapter.

Configuration data and sample programs in this package support only 1 channel of Encoder I/F. In order to use 2
channels of Encoder I/F, obtain the RZ/T1 group Encoder I/F 2ch Tool (R0O1AN4306) and change the Configuration

Data and sample program.

1.1 Software
- Source code
No. Title Version
1 A set of RZ/T1 A-format sample driver code 2.5
- Configuration data
No. Title Version
1 RZ/T1 Encoder I/F Configuration Data(A-format) 1.8
1.2 Document
No. Document name Ver. File name
1 RZ/T1 Encoder I/F A-format application 2.30 (English)

package release note r01an3635ej0230-rzt1.pdf (this document)
(Japanese)
r01an3635jj0230-rzt1.pdf

2 RZ/T1 Group A-format Interface 2.10 (English)

User’s Manual r01uh0604ej0210-rzt1-a-format.pdf
(Japanese)
r01uh0604jj0210-rzt1-a-format.pdf

3 RZ/T1 Group A-format Sample Program 2.00 (English)

Application Note r01an2948ej0200_rzt1_a-format.pdf
(Japanese)
r01an2948jj0200_rzt1_a-format.pdf

RO1AN3635EJ0230 Rev.2.30
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RZ/T1 Group Encoder I/F A-format application package

2. File Structures
File structures and contents of this package are described below.

Top
—r01an3635ej0230-rzt1.pdf
—r01an3635jj0230-rzt1.pdf
L—workspace
—Software
|  F—armcc
| | —RZ T1 _a_as.zip : A setof RZ/T1 A-format sample driver code (DS-5)
|  F—iccarm
| | —RZ _T1_a_as.zip : A setof RZ/T1 A-format sample driver code (IAR)
|  L—kpitgcc
| L—RZ T1_a_as.zip : A set of RZ/T1 A-format sample driver code (e2 studio)
L—Documentation
F—r01uh0604ej0210-rzt1-a-format.pdf
F—r01uh0604jj0210-rzt1-a-format.pdf
—r01an2948ej0200_rzt1_a-format.pdf
L—r01an2948jj0200 _rzt1_a-format.pdf

The file structures of “RZ_T1_a_as.zip” are shown in Figure 2.1 File Structure.

= Top folder

D lib

D ed

»  r_a_as_rztl.dat Multi-Protocol Encoder IF (a_as mode) Configuration data

o inc

1 jodefine.h RZ/T1 register definition file

»  iodefine_a_as.h A-format register definition file

»  r_a_as_rzt1_dath r_a_as_rzt1.dat header file

» r_a_as_rzt1_ifh A_AS common driver header file
o src

S  common
¢l Common sources including initial settings
5 drv
= scifa_uart
¢ SCIFA Sample program

o a_as
xl r_a_as_rzt1_config.h A_AS common driver file
x  r_a_as_rzt1_private.h A_AS common driver file
¢ r_a_ as_rztl.c A_AS common driver file

=@  a_format
1 r_a_format_rzt1_config.h A-format driver file
1 r_a_format_rzt1_private.h A-format driver file

¢ r_a_format_rztl.c A-format driver file
= sample
¢ main.c A-format Sample program
a_as_dat.s Linker setting file of the Configuration data *1
¢l siochar.c SCIFA Sample program
¢ siorw.c SCIFA Sample program
RN_CommClass_RZ_T1.inf USB serial port driver for PC

Note 1 : file for DS-5 and e2 studio
DS-5:a_as_dat.s
e2 studio : a_as_dat_asm

Figure 2.1 File Structure
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RZ/T1 Group

Encoder I/F A-format application package

3. Information about A-format sample program

This chapter describes information to use a set of A-format sample driver code.

3.1 Software information
3.1.1 Independent from Operating System
This software is independent from operating system.
3.1.2 Memory footprint
Memory Size
Section name IAR DS-5 e2 studio
[bytes] [bytes] [bytes]
A-format driver | Code 6400 8440 16236
Data (with initial value) 16 26 16
Data (without initial value) 1160 1152 1164
Constant Data 132 132 140
Stack size of | R_A_AS_Open 60 68 144
function R_A_AS_Close 16 28 84
R_A_AS_Control 64 88 192
R_A_AS_GetVersion 0 16 72
a_as0_int_isr 168+n *1 116+n *1 156+n *1
a_as0 _fss_isr 160+n *1 100+n *1 132+n *1
A-format Code 0 0 0
Configuration Data (with initial value) 0 0 0
data Data (without initial value) 0 0 0
Constant Data 21932 21932 21932
Sample program | Code 6008 8676 14244
Data (with initial value) 136 152 136
Data (without initial value) 1829 1816 1836
Constant Data 2168 328 2138

Note 1. “n” is the Maximum stack size of user defined callback functions that are registered to R_A AS Control

function.

RO1AN3635EJ0230 Rev.2.30
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RZ/T1 Group Encoder I/F A-format application package

3.2 Hardware information

3.21 Device
RZ/T1

3.2.2 Target Board

» Board name

RZ/T1 CPU Board (RTK7910018C00000BE)

(2) Settings of CPU Board
SW4-1: ON
SW4-2: ON in case of serial flash memory is used, OFF in case of NOR flash memory is used
SW4-3: ON
SW4-4: ON
SW4-5: ON
SW4-6: OFF
JP2: 2-3 Connect
JP7: 1-2 Connect
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RZ/T1 Group Encoder I/F A-format application package

3.3 Procedure on Development Environments

3.3.1 Preparation for the execution of the sample program
This sample program communicates with the PC. And for setting the PC, please refer to 6.1.2 Preparations of

"RZ/T1 Group FIFO Integrated Serial Communication Interface (SCIFA) Application Note".

3.3.2 EWARM from IAR systems

»  Build environment
IAR Embedded Workbench for ARM v8.40.1
»  Execution environment
I-jet
»  How to build sample program
1.  Extract files from RZ_T1 a as.zip and copy the files to arbitrary holder
2. Copy the following files of “RZ/T1 Encoder I/F Configuration Library” (for IAR EWARM) to each folder
lib\ecl\r_ecl rztl.a
inc\r_ecl _rztl _ifh
3.  Launch EWARM
4.  Select [Filelmenu -> [Open] -> [Workspace]
5. OpenRZ Tl a as boot\RZ T1 a as **** boot.eww

NOR version RZ T1 a as nor boot.eww

Serial Flash version RZ T1 a as_serial boot.eww

6.  Select [Projectmenu -> [Rebuild all]
Following file is generated.

RZ T1 a as boot\Debug\Exe\RZ T1 a as **** boot.out

NOR version RZ T1 a as nor boot.out

Serial Flash version RZ T1 a as_serial boot.out

»  How to execute sample program

After executing “How to build sample program”, connect the target board and the debugger properly, and
execute the following operations.

1. Select [Project] menu-> [Download and Debug]
2. Select [Debug] menu-> [Go]

RO1AN3635EJ0230 Rev.2.30 Page 8 of 16
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RZ/T1 Group Encoder I/F A-format application package

»  Execution result of sample program

After executing a sample program, input the command to " Terminal I/O" window.
Please refer to RZ/T1 Group A-format Sample Program Application Note about the command.

{% COMS9:115200baud - Tera Term VT L= | B |t

File Edit Setup Control Window Help
A-Format sample program start e
aas >
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RZ/T1 Group Encoder I/F A-format application package

3.3.3 DS-5 from ARM

»  Build environment
ARM Development Studio 5 (DS-5) Version 5.29.2
ARM Compiler 5.06 update 6

»  Execution environment
ULINK2 (v2.01)

»  How to build sample program

1. Startup the DS-5 environment. Go to [File] > [Import]. On the [Import] window, select [Existing
Projects into Workspace] in the [General] folder and click the [Next] button.

2. Select the [Select archive file:] radio button and click on the [Browse...] button. Select the
compressed program file “RZ _T1 a as.zip” on the list in the window and click on the [Finish] button.

3. Copy the following files of “RZ/T1 Encoder I/F Configuration Library” (for ARM DS-5) to each
folder imported and expanded.

lib\ecl\r_ecl rztl.a
inc\r_ecl rztl ifh
4.  Select [Project] menu -> [Build All]
Following file is generated.
Debug\RZ T nor_sample.axf

(In case of serial flash, use the “RZ T sflash_sample.axf” instead of the “RZ_T nor_sample.axf”)
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RZ/T1 Group Encoder I/F A-format application package

»  How to execute sample program

After executing “How to build sample program”, connect the target board and the debugger properly, and
execute the following operations.

1. Open the debug configuration from the [Run] -> [Debug Configurations...], select the configuration
window for “RZ T nor DL and Debug”. (In case of serial flash, use the “RZ T sflash DL _and Debug”
instead of the “RZ T nor DL and Debug”)

Select “Debug Cortex-R4” of “RZ/T1 R7S910x18 (Generic)” in [Select target].

Select the ULINK?2 of [Target Connection] in [Connection] tab, click on [Browse] and select the target
connection from the list in the window. Click on [Debug] in the debug configurations window and start

debugging.
© Debug Configurations 5
Create, ge, and run configurati ﬁ\'
X B3~ Name: RZ_T_nor_DL_and_Debug
| < Connection ._[{gj} Files| £ Debugger | Tz OS Awareness| ¢4+ Arguments| B Environment
[€] C/C++ Application T — -
€] C/C++ Attach to Application Lo

=]

. Select the manufacturer, board, project type and debug operation to use. Currently selected:
C/C++ Postmortem Debugger .
— A u9g Renesas [ RZ/T1 R7S910x18 (Generic) / Bare Metal Debug / Debug Cortex-R4

=]

[t] C/C++ Remote Application
# DS-5 Debugger
&% RZ_T_nor_ConnectOnly
75 RZ_T_nor_DL_and_Debug | (1) RZ/T1 R75910x16 (Generic) a
L’mmebug RZ/T1 R75910x17 (Generic)
a* TronPython Run 4 RZ/T1R75910x18 (Generic)
& ITronPython unittest 4 Bare Metal Debug
5 Java Applet Debug Cortex-M3

Debug Cortex-R4 | (2)
) Java Applcation @

RZ/T1 RTK7910018500000BE

.
e

Filter platforms

m

Ju JUnit »
@° Jython run
& Jython unittest prgat Comnacian ®
& Launch Group DTSL Options -rEcIIt.,.‘ Configure ULINK2 trace or other target options. Using "default” configuration options
[0 PyDev Django =
£3 PyDev Google App Run DS-5 Debugger will connect to a ULINK2 to debug a bare metal application.
@ Python Run (4)
& Python unittest Connecuons s
= 1
Z, Remote Java Appliation Bare Meta! Debug | Connection SR [Browse..]

4 I »

Filter matched 21 of 21 items
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RZ/T1 Group Encoder I/F A-format application package

2. On completion of writing to the flash memory by the script, the message “Flash Programming Complete”
appears in the application console window. Debugging can then start.

> D5-5 Debug - Eclipse Platform E]E
File Edit Mavigate Search Project Run  Window Help
m gl NP B = L SR g e Quick Access || 55 | ERER)
£ Debug C.. 57 [ ProjectE.. gfRemcteS. = [0 | Commands 12 & Hiot 3 t B ERED-#H =0 v 2 =n
SIS I R R E;;;i 4, Linked: RZ_T_ner_DL_and_Debug = xS -
- ARNTNG (CHD Target s not ruanding & 94, Linked: RZ_T_nor_OL_and_Debug =
+reset 5
- u RZ_T_nor_DL_and_Debug connected +info memory Hame Vafue | Type|Count |Size Lo
4 i Cortex-R4 #1 stopped on breakpoint Kum Enb Low Addr High Addr Attributes B Locals 0 variables
= 0xFFFFO000 1: y APB:@x00000000 APE:@xFFFFFFFF rw, nobp, nohbp, nocache Bt (= File Static Variables 0 of 31 variables
2y AHB:@xFFFFFFFF rw, nobp, nchbp, nocache & (= Globals 0 of 3 variables

3: oy OxDO000De0 @xFFFFFFFF rw, nocache, verify

+set var $CP15::§System::$CPLS_AUXILIARY_CONTROL.ATCMPCEN = 1

Target has been reset

Execution stopped in SVC mode due to a breakpoint or watchpoin |

exFFEFE@RR  LDR pc,[pc,#24] ; [BxFFFFO@28] = @xFFFFOR4E &

+set var SCP1S::$System::SCP1S_AUXILIARY _CONTROL.BOTCMPCEN = 1

+file " \RTT_nor_semple\Debug\RZT _nor_ssmple.asf” i

. m ) ¥ ] I "

Q RZ_T_nor_DL_and_Debug connected

No OS5 Support Command: ' 4 e t [Subml] Browse...
B App Console 12 Mgl =0 mom [ M € - = = m
T, Linked: RZ_T_nor_DL_and_Debug = &
loop=2, filesLOADER_RESET_HANDLER, flash address=8x42000208. - 4, Linked: RZ_T_nor_DL_snd_Debug =
Calculating Data Size... - Y EeSe ST
Data Size is 3388 B @ = <Netnstruction> 100
Programing Flash... e e

Verifying Flash...

loop=2, Flash Programming Success!! ® :ﬁ:i:m x :::E::::;:} ::
loope=3, file=LOADER_IN_ROOT, flash address=@x40006200. exFFFFE088 LOR pe.[pe,e2s] ;0
calcul_atlng Data Size... BxFEFEROOC LDR pe,[pc,524] ;
Data Size is 192 BxFFFFRQLQ LDR pe,[pe,224] ;
Programing Flash... @xFFFFROLS LOR pc,[pc,#28] ;
Verifying Flash... . exFFFFRaLS LOR pe,[pe,=24] ;
loop=3, Flash Programming Success!! BxFFFFRQLC LOR pec.[pe,m28] ;
loop=a, file-mIT,_Fiash address=0x40020000. |3 OxFEEFRA20 (79 § ex;fffa'eae ; "
Calculating Data Size... e BxFFFFRQ24 Dcl axffffeare ; ?
Data Size is 41508 OxFRFFO02E e exfiffears ; ?
Programing Flash... exFFFFRa2C ber exffffeers ; ?
Verifying Flash... exFFFFRO3Q [i1a 4 exffffeere ; ?
loop=2, Flash Programming Success!l @xFFEFOO3S oI exffffoese ; ?
loops5, Could not open file. Exiting. : =
Flash Prograsming Complete sl " afll X

& RZ_T_nor_DL_snd_Debug connected (Renesas - RZ/T1 RTK7910022C00000BR)

»  Execution result of sample program

After executing a sample program, input the command to " Terminal I/O" window.
Please refer to RZ/T1 Group A-format Sample Program Application Note about the command.

File Edit Setup Control Window Help
A-Format sample program start e
aas >
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RZ/T1 Group Encoder I/F A-format application package

3.34 e2 studio from RENESAS

»  Build environment

RENESAS e2 studio 7.5.0

KPIT GNUARM-NONE-EABI Toolchain v16.01
»  Execution environment

J-Link BASE
»  How to build sample program

1. Start up the e2 studio environment. In the workspace, go to [File] > [Import]. On the [Import]
window, select [Existing Projects into Workspace] in the [General] folder and click the [Next] button.

2. Select the [Select archive file:] radio button and click on the [Browse..] button. Select the compressed
program file “RZ_T1 a as.zip” on the list in the window and click on the [Finish] button.

3. Copy the following files of “RZ/T1 Encoder I/F Configuration Library” (for KPIT GCC) to each
folder imported and expanded.

lib\ecl\r_ecl rztl.a
inc\r_ecl rztl ifh
4. Select [Project] menu -> [Build All]
Following file is generated.
HardwareDebug\ RZ T nor_sample.x

(In case of serial flash, use the “RZ_T sflash_sample.x” instead of the “RZ T nor_sample.x”)

RO1AN3635EJ0230 Rev.2.30 Page 13 of 16
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RZ/T1 Group Encoder I/F A-format application package

»  How to execute sample program

After executing “How to build sample program”, connect the target board and the debugger properly, and
execute the following operations.

1. Select [Run] from the [Project] menu and then select [Debug Configurations].

2. Select the [RZ T nor sample HardwareDebug] in the following screen. Click the [Debug] and start the
download to flash memory.

(In case of serial flash, use the [RZ_T sflash_sample HardwareDebug] instead of the
[RZ T nor sample HardwareDebug])

le?| Debug Configurations =
Create, manage, and run configurations ﬁv

_ X | B B~ Name: RZ_T_nor_sample HardwareDebug
type filter text [) Main %5 Debugger| ¢ Startup| & Source| [] Common

[€] C/C++ Application

- N Project:

[€] C/C++ Remote Application Broject

[c*] Debug-only RZ_T_nor_sample [ Browse... ]
[€] GDB Hardware Debugging C/C++ Application:

» [c*] GDB Simulator Debugging (RL78, SH, RH850)
# Launch Group

4 [c7] Renesas GDB Hardware Debuggin | Variables... | [ Search Project... ] [ Browse... ‘
I £l RZ_T_nor_sample HardwareDebug I Build (if required) before launching

[c"] RZ_T_sflash_sample HardwareDebug

HardwareDebug¥RZ_T_nor_sample.x

€7 Renesas Simulator Debugging (RX) Build configuration: [USE Active ']
Enable auto build Disable auto build
@ Use workspace settings Configure Workspace Settings...

] m »

Filter matched 12 of 14 items

3. Click the [Resume] from the [Run] to start execution of the sample program.

»  Execution result of sample program

After executing a sample program, input the command to " Terminal I/O" window.
Please refer to RZ/T1 Group A-format Sample Program Application Note about the command.

[ . COM9:115200baud - Tera Term VT ‘ _E‘é‘g
[Fle Edt Setp Contol Window Hep |
A-Format sample program start =
a_as > i
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RZ/T1 Group

Encoder I/F A-format application package

4. Restriction

4.1 RZ/T1 A-format sample driver

»  When bypass reception is enabled, member variable "rxbpende" of structure "r_a_as req_t" sets enable or
disable of FSS_UPD interrupt request by FSS.RXEND bit = 1. If set to disable, A-format sample driver
will not operate properly. Therefore, member variable "rxbpende" of structure "r_a as_req_t" must be

fixed to "true".

5. Note

5.1 Processing time

Available time for user processing of Encoder I/F A-format sample program in a control loop is as follows.

Please confirm that there are no problems in your environment.

The example of the case that the control cycle is 62.5us and the connection type is one to one is indicated below.

In the case of normal reception, the time used by the sample program is about 9 us (15%) of 62.5us, and available
time for user processing is about 53.5 us (85%).

In the case of bypass reception, the time used by the sample program is about 6 us (10%) of 62.5us, and available
time for user processing is about 56.5 us (90%).

processing

Processing Time Occupancy rate
A-format sample | Dormal reception Time setting registers for | about 4 us about 9 us 15%
processing *2 transmission
Interrupt time about 5 us
Available time for user about 53.5 us *1 85%
processing
bypass reception Time setting registers for | about 4 us about 6 us 10%
transmission
Interrupt time about 2 us
Available time for user about 56.5 us *1 90%

Note 1. Communication time with the encoder (when the bitrate is 8Mbps and the command to be sent is CDF0
which is individual transmission command) is 17.75us of available time for user processing. For more information,
refer to the “RZ/T1 Group A-format Interface User's Manual”.

Note2. Initial setting time is not included.

RO1AN3635EJ0230 Rev.2.30
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RZ/T1 Group Encoder I/F A-format application package

5.2 About mistake of Application Note
The following mistake is existing in "RZ/T1 Group A-format Sample Program Application Note Rev.2.00".

» Table5.4 Results of Transmission and Reception Stored in Each Array Element in Bypass Reception
Correct:

Array Number  Content

pbp_result[0] Result of transmission and reception for the encoder section ENC1 when the setting of received data is
complete(RXSET).

pbp_result[1] Result of transmission and reception for the encoder section ENC2 when the setting of received data is
complete(RXSET).

pbp_result[2] Result of transmission and reception for the encoder section ENC3 when the setting of received data is
complete(RXSET).

pbp_result[3] Result of transmission and reception for the encoder section ENC4 when the setting of received data is
complete(RXSET).

pbp_result[4] Result of transmission and reception for the encoder section ENC5 when the setting of received data is
complete(RXSET).

pbp_result[5] Result of transmission and reception for the encoder section ENC6 when the setting of received data is
complete(RXSET).

pbp_result[6] Result of transmission and reception for the encoder section ENC7 when the setting of received data is
complete(RXSET).

pbp_result[7] Result of transmission and reception for the encoder section ENC8 when the setting of received data is
complete(RXSET).

pbp_result[8] Result of transmission and reception when the transmission and reception of data has been
completed(RXEND)™.

Notel. The result is invalid when the interrupt source RXEND is disabled.

Incorrect:

Array Number  Content

pbp_result[0] Result of transmission and reception for the encoder section ENC1 when the setting of received data is
complete(RXSET).

pbp_result[1] Result of transmission and reception for the encoder section ENC2 when the setting of received data is
complete(RXSET).

pbp_result[2] Result of transmission and reception for the encoder section ENC3 when the setting of received data is
complete(RXSET).

pbp_result[3] Result of transmission and reception for the encoder section ENC4 when the setting of received data is
complete(RXSET).

pbp_result[4] Result of transmission and reception for the encoder section ENC5 when the setting of received data is
complete(RXSET).

pbp_result[5] Result of transmission and reception for the encoder section ENC6 when the setting of received data is
complete(RXSET).

pbp_result[6] Result of transmission and reception for the encoder section ENC7 when the setting of received data is
complete(RXSET).

pbp_result[7] Result of transmission and reception when the transmission and reception of data has been
completed(RXEND)™.

Notel. The result is invalid when the interrupt source RXEND is disabled.

»  Table 5.20 Static Variables Used in the Sample Program

Correct: a_as bp resultfA AS BP RESULT NUM]
Incorrect: a_as bp resultfA AS ENC NUM]
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