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Renesas RA Family 

QE for BLE Usage for IAR EWARM 
Introduction 
This document explains how to generate QE BLE code in e² studio and copy the generated code to IAR EW 
for ARM for Renesas RA Microcontrollers. 

Target Device 
EK-RA4W1 Evaluation Kit for RA4W1 group 

Operating Environment 
IDE IAR Embedded Workbench for Arm version 9.20.2 or later 

e2 studio version 2021-10 is used for BLE Custom Profile creation and code 
generation 

Configuration Tool Smart Configurator (RA SC) v2021-10 and FSP v3.5.0 

Toolchains GNU Arm Embedded Toolchain: 10.3-2021.10 
(GNU ARM Embedded 10.3.1.20210824) 

QE Renesas QE for BLE[RA,RE,RX] V1.4.0 

 
Note:  Please download and install tools from the following URL in advance. 

• Renesas QE download site: 
https://www.renesas.com/software-tool/qe-tools-particular-applications  

• FSP with e2 studio installer download site:  
https://github.com/renesas/fsp/releases 

• IAR EW for ARM download site:  
https://www.iar.com/products/architectures/arm/iar-embedded-workbench-for-arm 

 

 

 

Figure 1.   Configuration Diagram when using QE for BLE[RA,RE,RX] with IAR EWARM 

  

https://www.renesas.com/software-tool/qe-tools-particular-applications
https://github.com/renesas/fsp/releases
https://www.iar.com/products/architectures/arm/iar-embedded-workbench-for-arm
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1. Creating a Project in e2 studio 
A project generation wizard is available in e2 studio to generate a RA project with a project name and the 
associated device and board, including board-level drivers. 

Start the e2 studio application and choose a workspace folder in the Workspace Launcher. To create a new 
RA project, follow these steps. 

1. Select File > New > C/C++ Project 
2. Select Renesas RA: Renesas RA C/C++ Project template. Click Next to continue.  

  

Figure 2.   Templates Selection 

3. In the next dialog box, enter a project name and click Next. 

 

Figure 3.   Project Name and Location 
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4. In the device selection dialog, enter device and tool information: 
 Board: EK-RA4W1 
 Device: Auto selected 
 Language: C 
 Toolchain version: Latest GNU Arm Embedded Toolchain approved for use with Renesas RA (for 

example, GNU ARM Embedded 10.3.1.20210824) 
 Debugger: J-link ARM 

Click Next to continue. 

 

Figure 4.   Create New Project For EK-RA4W1 

5. Build Artifact Selection: Executable 
RTOS Selection: No RTOS 

 

Figure 5.   Build Artifact and RTOS Selection   
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6. In the project template dialog, select Bare Metal - Minimal and click Finish. 

 

Figure 6.   Project Template Selection 

7. e2 studio creates a project with the FSP Configuration perspective open and ready for project 
configuration. 

 

Figure 7.   New Project is Opened with FSP Configuration Perspective 
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2. Creating BLE Custom Profile in e2 studio 
1. If QE for BLE[RA,RE,RX] has not been installed, select Renesas Views > Renesas Software Installer 

from the menu of e2 studio to install it. 
2. In the Renesas Software Installer dialog box, select Renesas QE, then click Next. 
3. Select QE for BLE[RA,RE,RX] and click Finish to install it. 

 

Figure 8.   Install QE for BLE[RA,RE,RX] 

4. From the menu of e2 studio, select Renesas Views > Renesas QE > R_BLE Custom Profile 
RA,RE,RX (QE) to open the main perspective for configuring BLE custom profile to the project. 

 

Figure 9.   Open R_BLE Custom Profile RA,RE,RX (QE) 
 



Renesas RA Family QE for BLE Usage for IAR EWARM 

R20AN0609EJ0110  Rev.1.10  Page 7 of 24 
Feb.18.22  

5. In the R_BLE Custom Profile RA,RE,RX (QE) pane, select the project to configure the BLE custom 
profile by using the pull-down tab and selecting the RA_BLE_Example project as shown below. 

 

Figure 10.   Select Project  

6. Select Profile, then click the Add button and select Add Service to add new BLE service. 

   

Figure 11.   Add New Service 

7. Type LED in the filter box and select LED Switch Service. Click OK. 

 

Figure 12.   Add LED Switch Service 
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8. Click Generate Code button to generate code. 

 

Figure 13.   Generate Code 

9. In the Project Explorer window, you will see that new folders and source files have been added to 
Project > qe_gen > ble folder. These files contain the necessary information to enable BLE using the 
drivers of FSP.  

 

Figure 14.   QE for BLE sources 
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3. Creating a Project in IAR EWARM 
1. Install the IAR Embedded Workbench for ARM version 9.20.2 from 

https://www.iar.com/products/architectures/arm/iar-embedded-workbench-for-arm. 
2. Install the Smart Configurator (RA SC) from https://www.renesas.com/smart-configurator.  

Note: Please check the version of the Smart Configurator installer. If the FSP is not v3.5.0, download 
and install the latest version from https://github.com/renesas/fsp/releases.  

3. To create a third-party IDE project with the Smart Configurator, run the “rasc.exe” application. In the New 
Renesas RA FSP Project wizard, enter the Project Name and Location. 

 

Figure 15.   Project Name and Location 
 

https://www.iar.com/products/architectures/arm/iar-embedded-workbench-for-arm
https://www.renesas.com/smart-configurator
https://github.com/renesas/fsp/releases
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4. In the device selection dialog, enter device and IDE information: 
 Board: EK-RA4W1 
 Device: Auto selected 
 Language: C 
 IDE Project Type: IAR EWARM Version 8 
 Toolchains: IAR Toolchain for ARM 

Click Next to continue. 

 

Figure 16.   Board Selection for EK-RA4W1 

5. RTOS Selection: No RTOS. Click Next to continue. 

 

Figure 17.   RTOS Selection 
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6. Project Template Selection: Bare Metal – Minimum. Click Finish to create project. 

 

Figure 18.   Template Selection 

7. After creating the project, the Smart Configurator window will pop-up. 

 

Figure 19.   Smart Configurator Window 
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8. In Windows Explorer, navigate to the folder you entered in 3.3. and see that the main workspace (IAR 
EWARM *.eww file) exists. Close the Smart Configurator window, then double-click on the main 
workspace to open the project. 

 

Figure 20.   Project Location 

9. Project is opened by IAR EWARM. Right-click on the project and select Rebuild All. The project should 
be built without error. 

 
 

 

 

 

Figure 21.   Project is Built Successfully 
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10. After a project created with the Smart Configurator has been opened in IAR EWARM, its FSP 
configuration can be changed by relaunching the Smart Configurator from the IDE. Follow the 
instructions below to reopen the Smart Configurator. 

11. In the menu of IAR EWARM, select Tools > Configure Tools… Then, select New and fill in the fields as 
follows. 
Menu Text: RA Smart Configurator 
Command: Select Browse… and navigate to rasc.exe 
Argument: -compiler IAR configuration.xml 
Initial Directory: $PROJ_DIR$ 

 

Figure 22.   How To Use Smart Configurator in IAR EWARM 

12. Now, a FSP configuration of a created project can be reopened by select Tool > RA Smart 
Configurator in IAR EWARM.  

 

Figure 23.   RA Smart Configurator Has Been Added 
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4. Adding BLE Driver in IAR EWARM 
1. Open Smart Configurator, go to Stacks tab. Select New Stack > Networking > BLE Abstraction 

(rm_ble_abs). 

 

Figure 24.   Add BLE Abstraction Driver 

2. Click on Add BLE Library for Network and select New > BLE Driver (r_ble_extended). 

 

Figure 25.   Add Network Driver 
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3. Click on Add Timer Driver and select New > Timer, Low-Power (r_agt). 

 

Figure 26.   Add Timer Driver  

4. Select the r_agt driver, in the Property window, enable the Underflow Interrupt Priority by changing it 
to priority 4. 

 

Figure 27.   Enable AGT interrupt   
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5. Click on Add GPT Driver and select New > Timer, General PWM (r_gpt). 

  

Figure 28.   Add GPT Driver  
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6. Select the r_gpt driver, in the Property window, enable the Overflow/Crest Interrupt Priority by 
changing it to priority 2. 

 

Figure 29.   Enable GPT Interrupt  
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7. Click on BSP tab, in the Property window, change Heap size to 0x2000. 

 

Figure 30.   Change Heap Size  

8. Click on the Generate Project Content button to generate source file.  

 

Figure 31.   Generate Project Content 



Renesas RA Family QE for BLE Usage for IAR EWARM 

R20AN0609EJ0110  Rev.1.10  Page 19 of 24 
Feb.18.22  

5. Copying QE files to IAR EWARM 
1. In e2 studio, right-click the ble folder, select Copy from the menu, and paste it into the IAR EWARM 

project folder. 

 

         
 

Figure 32.   Copy ble Folder to IAR 

2. In IAR EWARM, right-click on the project name and select Add > Add Group…  Enter the group name 
“ble” and click OK.  

                 

Figure 33.   Create New Group 
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3. Continue to add two more groups: discovery and profile_cmn in ble.  

 

Figure 34.   New Groups in the Project Tree  

4. Right-click on ble group and select Add > Add Files… Select all the source files inside the ble folder and 
click Open to add them to the project. 

 
 
 

Figure 35.   Add Source Files for ble Group 
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5. Do the same to add source files to discovery and profile_cmn group. Finally, the project should look like 
this. 

 

Figure 36.   All Source Files have been Added 

6. Right click on project name and select Options…. In the Options dialog, select C/C++ Compiler > 
Preprocessor. Click on the […] button to add include directory. 

 

Figure 37.   Open Project Option 
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7. Click on the empty row and add the ble folder to the list of include directories. The triangle button can be 
used to change the absolute path to relative path. Click OK to close the dialog. 

 

Figure 38.   Add ble to List of Include Directories 

8. Right-click on the project and select Rebuild All. The project should be built without error. 

 

Figure 39.   Build Successfully 
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Website and Support 
Visit the following vanity URLs to learn about key elements of the RA family, download components and 
related documentation, and get support. 

RA Product Information  www.renesas.com/ra  
RA Product Support Forum  www.renesas.com/ra/forum  
RA Flexible Software Package www.renesas.com/FSP 
Renesas Support  www.renesas.com/support 

 

  

http://www.renesas.com/ra
https://www.renesas.com/ra/forum
http://www.renesas.com/FSP
https://www.renesas.com/support
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Revision History 

Rev. Date 
Description 
Page Summary 

1.00 Feb.26.21 — First release document 

1.10 Feb.18.22 

1 Update to Operating Environment 
— Changed version FSP to v3.5.0 
— Changed version QE for BLE V1.4.0 
12 3.8. Added Smart Configurator Close 
19 5.1. Added ble folder copy operation 

 

 



 

 

General Precautions in the Handling of Microprocessing Unit and Microcontroller 
Unit Products 
The following usage notes are applicable to all Microprocessing unit and Microcontroller unit products from Renesas. For detailed usage notes on the 
products covered by this document, refer to the relevant sections of the document as well as any technical updates that have been issued for the products. 

1. Precaution against Electrostatic Discharge (ESD) 

A strong electrical field, when exposed to a CMOS device, can cause destruction of the gate oxide and ultimately degrade the device operation. Steps 

must be taken to stop the generation of static electricity as much as possible, and quickly dissipate it when it occurs. Environmental control must be 

adequate. When it is dry, a humidifier should be used. This is recommended to avoid using insulators that can easily build up static electricity. 

Semiconductor devices must be stored and transported in an anti-static container, static shielding bag or conductive material. All test and 

measurement tools including work benches and floors must be grounded. The operator must also be grounded using a wrist strap. Semiconductor 

devices must not be touched with bare hands. Similar precautions must be taken for printed circuit boards with mounted semiconductor devices. 
2. Processing at power-on 

The state of the product is undefined at the time when power is supplied. The states of internal circuits in the LSI are indeterminate and the states of 

register settings and pins are undefined at the time when power is supplied. In a finished product where the reset signal is applied to the external 

reset pin, the states of pins are not guaranteed from the time when power is supplied until the reset process is completed. In a similar way, the states 

of pins in a product that is reset by an on-chip power-on reset function are not guaranteed from the time when power is supplied until the power 

reaches the level at which resetting is specified. 
3. Input of signal during power-off state 

Do not input signals or an I/O pull-up power supply while the device is powered off. The current injection that results from input of such a signal or I/O 

pull-up power supply may cause malfunction and the abnormal current that passes in the device at this time may cause degradation of internal 

elements. Follow the guideline for input signal during power-off state as described in your product documentation. 
4. Handling of unused pins 

Handle unused pins in accordance with the directions given under handling of unused pins in the manual. The input pins of CMOS products are 

generally in the high-impedance state. In operation with an unused pin in the open-circuit state, extra electromagnetic noise is induced in the vicinity 

of the LSI, an associated shoot-through current flows internally, and malfunctions occur due to the false recognition of the pin state as an input signal 

become possible. 
5. Clock signals 

After applying a reset, only release the reset line after the operating clock signal becomes stable. When switching the clock signal during program 

execution, wait until the target clock signal is stabilized. When the clock signal is generated with an external resonator or from an external oscillator 

during a reset, ensure that the reset line is only released after full stabilization of the clock signal. Additionally, when switching to a clock signal 

produced with an external resonator or by an external oscillator while program execution is in progress, wait until the target clock signal is stable. 
6. Voltage application waveform at input pin 

Waveform distortion due to input noise or a reflected wave may cause malfunction. If the input of the CMOS device stays in the area between VIL 

(Max.) and VIH (Min.) due to noise, for example, the device may malfunction. Take care to prevent chattering noise from entering the device when the 

input level is fixed, and also in the transition period when the input level passes through the area between VIL (Max.) and VIH (Min.). 
7. Prohibition of access to reserved addresses 

Access to reserved addresses is prohibited. The reserved addresses are provided for possible future expansion of functions. Do not access these 

addresses as the correct operation of the LSI is not guaranteed. 
8. Differences between products 

Before changing from one product to another, for example to a product with a different part number, confirm that the change will not lead to problems. 

The characteristics of a microprocessing unit or microcontroller unit products in the same group but having a different part number might differ in 

terms of internal memory capacity, layout pattern, and other factors, which can affect the ranges of electrical characteristics, such as characteristic 

values, operating margins, immunity to noise, and amount of radiated noise. When changing to a product with a different part number, implement a 

system-evaluation test for the given product. 
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Notice 
1. Descriptions of circuits, software and other related information in this document are provided only to illustrate the operation of semiconductor products 

and application examples. You are fully responsible for the incorporation or any other use of the circuits, software, and information in the design of your 
product or system. Renesas Electronics disclaims any and all liability for any losses and damages incurred by you or third parties arising from the use 
of these circuits, software, or information. 

2. Renesas Electronics hereby expressly disclaims any warranties against and liability for infringement or any other claims involving patents, copyrights, 
or other intellectual property rights of third parties, by or arising from the use of Renesas Electronics products or technical information described in this 
document, including but not limited to, the product data, drawings, charts, programs, algorithms, and application examples. 

3. No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights of Renesas Electronics 
or others. 

4. You shall be responsible for determining what licenses are required from any third parties, and obtaining such licenses for the lawful import, export, 
manufacture, sales, utilization, distribution or other disposal of any products incorporating Renesas Electronics products, if required. 

5. You shall not alter, modify, copy, or reverse engineer any Renesas Electronics product, whether in whole or in part. Renesas Electronics disclaims any 
and all liability for any losses or damages incurred by you or third parties arising from such alteration, modification, copying or reverse engineering. 

6. Renesas Electronics products are classified according to the following two quality grades: “Standard” and “High Quality”. The intended applications for 
each Renesas Electronics product depends on the product’s quality grade, as indicated below. 
 "Standard": Computers; office equipment; communications equipment; test and measurement equipment; audio and visual equipment; home 

electronic appliances; machine tools; personal electronic equipment; industrial robots; etc. 
 "High Quality": Transportation equipment (automobiles, trains, ships, etc.); traffic control (traffic lights); large-scale communication equipment; key 

financial terminal systems; safety control equipment; etc. 
Unless expressly designated as a high reliability product or a product for harsh environments in a Renesas Electronics data sheet or other Renesas 
Electronics document, Renesas Electronics products are not intended or authorized for use in products or systems that may pose a direct threat to 
human life or bodily injury (artificial life support devices or systems; surgical implantations; etc.), or may cause serious property damage (space 
system; undersea repeaters; nuclear power control systems; aircraft control systems; key plant systems; military equipment; etc.). Renesas Electronics 
disclaims any and all liability for any damages or losses incurred by you or any third parties arising from the use of any Renesas Electronics product 
that is inconsistent with any Renesas Electronics data sheet, user’s manual or other Renesas Electronics document. 

7. No semiconductor product is absolutely secure. Notwithstanding any security measures or features that may be implemented in Renesas Electronics 
hardware or software products, Renesas Electronics shall have absolutely no liability arising out of any vulnerability or security breach, including but 
not limited to any unauthorized access to or use of a Renesas Electronics product or a system that uses a Renesas Electronics product. RENESAS 
ELECTRONICS DOES NOT WARRANT OR GUARANTEE THAT RENESAS ELECTRONICS PRODUCTS, OR ANY SYSTEMS CREATED USING 
RENESAS ELECTRONICS PRODUCTS WILL BE INVULNERABLE OR FREE FROM CORRUPTION, ATTACK, VIRUSES, INTERFERENCE, 
HACKING, DATA LOSS OR THEFT, OR OTHER SECURITY INTRUSION (“Vulnerability Issues”). RENESAS ELECTRONICS DISCLAIMS ANY AND 
ALL RESPONSIBILITY OR LIABILITY ARISING FROM OR RELATED TO ANY VULNERABILITY ISSUES. FURTHERMORE, TO THE EXTENT 
PERMITTED BY APPLICABLE LAW, RENESAS ELECTRONICS DISCLAIMS ANY AND ALL WARRANTIES, EXPRESS OR IMPLIED, WITH 
RESPECT TO THIS DOCUMENT AND ANY RELATED OR ACCOMPANYING SOFTWARE OR HARDWARE, INCLUDING BUT NOT LIMITED TO 
THE IMPLIED WARRANTIES OF MERCHANTABILITY, OR FITNESS FOR A PARTICULAR PURPOSE. 

8. When using Renesas Electronics products, refer to the latest product information (data sheets, user’s manuals, application notes, “General Notes for 
Handling and Using Semiconductor Devices” in the reliability handbook, etc.), and ensure that usage conditions are within the ranges specified by 
Renesas Electronics with respect to maximum ratings, operating power supply voltage range, heat dissipation characteristics, installation, etc. Renesas 
Electronics disclaims any and all liability for any malfunctions, failure or accident arising out of the use of Renesas Electronics products outside of such 
specified ranges. 

9. Although Renesas Electronics endeavors to improve the quality and reliability of Renesas Electronics products, semiconductor products have specific 
characteristics, such as the occurrence of failure at a certain rate and malfunctions under certain use conditions. Unless designated as a high reliability 
product or a product for harsh environments in a Renesas Electronics data sheet or other Renesas Electronics document, Renesas Electronics 
products are not subject to radiation resistance design. You are responsible for implementing safety measures to guard against the possibility of bodily 
injury, injury or damage caused by fire, and/or danger to the public in the event of a failure or malfunction of Renesas Electronics products, such as 
safety design for hardware and software, including but not limited to redundancy, fire control and malfunction prevention, appropriate treatment for 
aging degradation or any other appropriate measures. Because the evaluation of microcomputer software alone is very difficult and impractical, you are 
responsible for evaluating the safety of the final products or systems manufactured by you. 

10. Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental compatibility of each Renesas 
Electronics product. You are responsible for carefully and sufficiently investigating applicable laws and regulations that regulate the inclusion or use of 
controlled substances, including without limitation, the EU RoHS Directive, and using Renesas Electronics products in compliance with all these 
applicable laws and regulations. Renesas Electronics disclaims any and all liability for damages or losses occurring as a result of your noncompliance 
with applicable laws and regulations. 

11. Renesas Electronics products and technologies shall not be used for or incorporated into any products or systems whose manufacture, use, or sale is 
prohibited under any applicable domestic or foreign laws or regulations. You shall comply with any applicable export control laws and regulations 
promulgated and administered by the governments of any countries asserting jurisdiction over the parties or transactions. 

12. It is the responsibility of the buyer or distributor of Renesas Electronics products, or any other party who distributes, disposes of, or otherwise sells or 
transfers the product to a third party, to notify such third party in advance of the contents and conditions set forth in this document. 

13. This document shall not be reprinted, reproduced or duplicated in any form, in whole or in part, without prior written consent of Renesas Electronics. 
14. Please contact a Renesas Electronics sales office if you have any questions regarding the information contained in this document or Renesas 

Electronics products. 

(Note1) “Renesas Electronics” as used in this document means Renesas Electronics Corporation and also includes its directly or indirectly controlled 
subsidiaries. 

(Note2) “Renesas Electronics product(s)” means any product developed or manufactured by or for Renesas Electronics.  
(Rev.5.0-1  October 2020)  

Corporate Headquarters  Contact information 
TOYOSU FORESIA, 3-2-24 Toyosu, 
Koto-ku, Tokyo 135-0061, Japan 
www.renesas.com 

 For further information on a product, technology, the most up-to-date 
version of a document, or your nearest sales office, please visit: 
www.renesas.com/contact/. 

Trademarks   
Renesas and the Renesas logo are trademarks of Renesas Electronics 
Corporation. All trademarks and registered trademarks are the property 
of their respective owners. 
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