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ご注意書き 

 

１． 本資料に記載されている内容は本資料発行時点のものであり、予告なく変更することがあります。当社製品

のご購入およびご使用にあたりましては、事前に当社営業窓口で最新の情報をご確認いただきますとともに、

当社ホームページなどを通じて公開される情報に常にご注意ください。 
2. 本資料に記載された当社製品および技術情報の使用に関連し発生した第三者の特許権、著作権その他の知的

財産権の侵害等に関し、当社は、一切その責任を負いません。当社は、本資料に基づき当社または第三者の

特許権、著作権その他の知的財産権を何ら許諾するものではありません。 
3. 当社製品を改造、改変、複製等しないでください。 
4. 本資料に記載された回路、ソフトウェアおよびこれらに関連する情報は、半導体製品の動作例、応用例を説

明するものです。お客様の機器の設計において、回路、ソフトウェアおよびこれらに関連する情報を使用す

る場合には、お客様の責任において行ってください。これらの使用に起因しお客様または第三者に生じた損

害に関し、当社は、一切その責任を負いません。 
5. 輸出に際しては、「外国為替及び外国貿易法」その他輸出関連法令を遵守し、かかる法令の定めるところに

より必要な手続を行ってください。本資料に記載されている当社製品および技術を大量破壊兵器の開発等の

目的、軍事利用の目的その他軍事用途の目的で使用しないでください。また、当社製品および技術を国内外

の法令および規則により製造・使用・販売を禁止されている機器に使用することができません。 
6. 本資料に記載されている情報は、正確を期すため慎重に作成したものですが、誤りがないことを保証するも

のではありません。万一、本資料に記載されている情報の誤りに起因する損害がお客様に生じた場合におい

ても、当社は、一切その責任を負いません。 
7. 当社は、当社製品の品質水準を「標準水準」、「高品質水準」および「特定水準」に分類しております。また、

各品質水準は、以下に示す用途に製品が使われることを意図しておりますので、当社製品の品質水準をご確

認ください。お客様は、当社の文書による事前の承諾を得ることなく、「特定水準」に分類された用途に当

社製品を使用することができません。また、お客様は、当社の文書による事前の承諾を得ることなく、意図

されていない用途に当社製品を使用することができません。当社の文書による事前の承諾を得ることなく、

「特定水準」に分類された用途または意図されていない用途に当社製品を使用したことによりお客様または

第三者に生じた損害等に関し、当社は、一切その責任を負いません。なお、当社製品のデータ・シート、デ

ータ・ブック等の資料で特に品質水準の表示がない場合は、標準水準製品であることを表します。 
標準水準： コンピュータ、OA 機器、通信機器、計測機器、AV 機器、家電、工作機械、パーソナル機器、

産業用ロボット 
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維持を目的として設計されていない医療機器（厚生労働省定義の管理医療機器に相当） 
特定水準： 航空機器、航空宇宙機器、海底中継機器、原子力制御システム、生命維持のための医療機器（生

命維持装置、人体に埋め込み使用するもの、治療行為（患部切り出し等）を行うもの、その他

直接人命に影響を与えるもの）（厚生労働省定義の高度管理医療機器に相当）またはシステム

等 
8. 本資料に記載された当社製品のご使用につき、特に、最大定格、動作電源電圧範囲、放熱特性、実装条件そ

の他諸条件につきましては、当社保証範囲内でご使用ください。当社保証範囲を超えて当社製品をご使用さ

れた場合の故障および事故につきましては、当社は、一切その責任を負いません。 
9. 当社は、当社製品の品質および信頼性の向上に努めておりますが、半導体製品はある確率で故障が発生した

り、使用条件によっては誤動作したりする場合があります。また、当社製品は耐放射線設計については行っ

ておりません。当社製品の故障または誤動作が生じた場合も、人身事故、火災事故、社会的損害などを生じ

させないようお客様の責任において冗長設計、延焼対策設計、誤動作防止設計等の安全設計およびエージン
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10. 当社製品の環境適合性等、詳細につきましては製品個別に必ず当社営業窓口までお問合せください。ご使用

に際しては、特定の物質の含有･使用を規制する RoHS 指令等、適用される環境関連法令を十分調査のうえ、

かかる法令に適合するようご使用ください。お客様がかかる法令を遵守しないことにより生じた損害に関し

て、当社は、一切その責任を負いません。 
11. 本資料の全部または一部を当社の文書による事前の承諾を得ることなく転載または複製することを固くお

断りいたします。 
12. 本資料に関する詳細についてのお問い合わせその他お気付きの点等がございましたら当社営業窓口までご

照会ください。 
 
注 1. 本資料において使用されている「当社」とは、ルネサスエレクトロニクス株式会社およびルネサスエレク

トロニクス株式会社がその総株主の議決権の過半数を直接または間接に保有する会社をいいます。 
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1. 本資料は、お客様が用途に応じた適切なルネサス テクノロジ製品をご購入いただく
ための参考資料であり、本資料中に記載の技術情報についてルネサス テクノロジが
所有する知的財産権その他の権利の実施、使用を許諾するものではありません。

2. 本資料に記載の製品データ、図、表、プログラム、アルゴリズムその他応用回路例
の使用に起因する損害、第三者所有の権利に対する侵害に関し、ルネサス テクノロ
ジは責任を負いません。

3. 本資料に記載の製品データ、図、表、プログラム、アルゴリズムその他全ての情報
は本資料発行時点のものであり、ルネサス テクノロジは、予告なしに、本資料に記
載した製品または仕様を変更することがあります。ルネサス テクノロジ半導体製品
のご購入に当たりましては、事前にルネサス テクノロジ、ルネサス販売または特約
店へ最新の情報をご確認頂きますとともに、ルネサス テクノロジホームページ
(http://www.renesas.com)  などを通じて公開される情報に常にご注意ください。

4. 本資料に記載した情報は、正確を期すため、慎重に制作したものですが万一本資料
の記述誤りに起因する損害がお客様に生じた場合には、ルネサス テクノロジはその
責任を負いません。

5. 本資料に記載の製品データ、図、表に示す技術的な内容、プログラム及びアルゴリ
ズムを流用する場合は、技術内容、プログラム、アルゴリズム単位で評価するだけ
でなく、システム全体で十分に評価し、お客様の責任において適用可否を判断して
ください。ルネサス テクノロジは、適用可否に対する責任は負いません。

6. 本資料に記載された製品は、人命にかかわるような状況の下で使用される機器ある
いはシステムに用いられることを目的として設計、製造されたものではありません｡
本資料に記載の製品を運輸、移動体用、医療用、航空宇宙用、原子力制御用、海底
中継用機器あるいはシステムなど、特殊用途へのご利用をご検討の際には、ルネサ
ス テクノロジ、ルネサス販売または特約店へご照会ください。

7. 本資料の転載、複製については、文書によるルネサス テクノロジの事前の承諾が必
要です。

8. 本資料に関し詳細についてのお問い合わせ、その他お気付きの点がございましたら
ルネサス テクノロジ、ルネサス販売または特約店までご照会ください。

1. 弊社は品質、信頼性の向上に努めておりますが、半導体製品は故障が発生したり、
誤動作する場合があります。弊社の半導体製品の故障又は誤動作によって結果とし
て、人身事故、火災事故、社会的損害などを生じさせないような安全性を考慮した
冗長設計、延焼対策設計、誤動作防止設計などの安全設計に十分ご留意ください。

安全設計に関するお願い

本資料ご利用に際しての留意事項



はじめに

本マニュアルについて
本マニュアルは、ルネサス FLASH開発ツールキット（以下 FDTと略します）の使用法について説明します。
第１章「概要」では、本ツールの概要について簡単に紹介し、おもな特長を示します。
第２章「システムの概要」では、FDTグラフィカルユーザインタフェースの機能構成を説明します。
第３章「基本操作」では、FDTの起動からフラッシュ ROMへの書き込みまでを簡単に説明します。
第４章「Wait For Script」
第５章「アクセス権」では、ユーザ名とパスワードの設定を説明します。
第６章「ユーザインタフェースの設定」では、FDTグラフィカルユーザインタフェースをカスタマイズする
方法を説明します。
第７章「メニュー」と第８章「ウィンドウ」の各章は、それぞれの操作方法や機能を説明しています。
第９章「Simple Interface Mode」では、凝縮した FDTグラフィカルユーザインタフェースの使用法について説

明します。
第１０章「FDT3.2へのアップグレード」では、FDT3.2へアップグレードする際の注意事項を説明しています。

前提
本マニュアルでは、ユーザはWindows アプリケーションの使用経験があることを前提としています。

略称

Target/Device プログラミング用の PCに接続された、プログラミング可能なマイクロコントローラあるいはマイクロコ
ンピュータ

DLL Dynamic Linked Library

FDT Flash Development Toolkit

F-ZTAT Flexible Zero Turn-Around Time

HEW ルネサス High-performance Embedded Workshop

PC パーソナルコンピュータ

USB Universal Serial Bus

FDM Flash Development Module（USBインタフェースボード）

UPB Universal Programming Board – プロトコル A (Legacy)カーネルと共に使用する Legacy HMSEインタフェ
ースボード

HMSE Hitachi Micro Systems Europe Ltd. – Renesas Technology Europe Engineering Divisionの一部の以前の名
称

FCF Flash Configuration File – デバイスおよびフラッシュの特性に関する情報を保存するために使用

Kernel デバイスを制御し、機能の再プログラミングが可能なコード。時々、デバイスにダウンロードされます。

Micro Kernel 初めに実行したカーネルの一部で、最初のコンフィグレーションおよびメインカーネルのダウンロードが
可能です。

Main Kernel マイクロカーネルがダウンロードしたカーネルの一部で、（必要であれば）リード、ライト、ブランクチ
ェック、消去などの機能を行う追加モジュールをダウンロードします。



マニュアルの表記法
本マニュアルには、以下の表記法を用います。

表 1   表記法
表記 意味

[Menu->MenuOption] ‘->’の付いた太字は、メニューオプションを示します
（例： [File->Save As...])。

‘ダイアログ名’ 引用符‘’は、ダイアログボックスやメニューの名前を示します。

‘Filename.ext’ 太字の Courierフォントは、ファイル名を示します。

“文字列の入力” 下線は入力する文字列を示します
（引用符“ ”は除く）。

Key+Key キー入力を示します。たとえば、CTRL+N は、CTRLキーを押したまま
Nキーを押すことを意味します。

（操作方法記号）

この記号が左端にあるとき、右の文章は操作方法を示します。

•  Windows は米国Microsoft Corporationの登録商標です。
•  F-ZTATは（株）ルネサス テクノロジの商標です。
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1 概要

ルネサス FLASH 開発ツールキット(FDT)は、高機能でかつ使い勝手の良いグラフィカルユーザイン
タフェースをもつルネサス F-ZTATマイコン用オンボード FLASH書き込みツールです。

FDTは、ルネサス High-performance Embedded Workshop(HEW)とともに使用することで、ルネサス
の F-ZTATマイコンを使用している組み込みソフトウェア開発者に一貫した環境を提供します。

また、FDTは汎用の Sレコード形式または 16進数ファイルのエディタとして使用することもでき
ます。

1.1 おもな特長
•  32ビットWindows  GUIに基づく標準的なウィンドウ操作
•  充実したオンラインヘルプ機能
•  メッセージ出力レベルを選択可能
•  アダプタボードを任意に制御する容易な書き込み環境
•  最大 115200bit/sの直接的なシリアル通信（FDMを使用する場合は、さらに速い速度が可能）
•  FDM（USBインタフェースボード）経由でサポートした USB通信
•  選択したターゲットデバイスへの直接的な USB通信

1.2 新しい特長
FDT3.2には、以下の新しい特長があります。

•  スクリプトファイルの自動実行
•  16進数エディタでファイルを開くためのコマンドラインのサポート
•  Simple Interface Modeのアクセス権パスワードによるセキュリティ機能サポート
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2 システムの概要

FDTは、ルネサスフラッシュデバイスからの書き込み、消去、読み出し方法を提供します。ワークスペースお
よびプロジェクトは、異なる設定間で簡単に切り替えられるよう、セッション間の設定を保存するために使用さ
れ、経験のあるユーザが経験の少ないオペレータのために設定を構築することができます。FDTは、書き込まれ
る実デバイスに関係なく共通した操作性が得られます。

FDTは階層構造をとっており、論理的に構成できるようになっています。最上位は、ワークスペースです。

FDTを使用するには、ワークスペースにプロジェクトが少なくとも１つ含まれている必要があります。プロジ
ェクトを作成する前に、ワークスペースを作成します。

プロジェクト作成時に、それぞれのプロジェクト特定のターゲットデバイス情報の設定とデバイスに書き込む
際に用いるターゲットファイル（Sレコード、16進数、またはバイナリ）の指定を行ないます。

ターゲットデバイスに接続するためのプロジェクトの設定は、一度だけ行ないます。プロジェクトを保存する
ことで、セッションが変わっても設定をそのまま保存することができます。

ワークスペース内では、プロジェクトは常に１つだけアクティブになります。’Device’メニュー、’Project’メニ
ュー、’Project’ツールバーは、すべてアクティブなプロジェクトに対してのみ機能します。

プロジェクトを作成したあと、ターゲットファイルを指定できます。ターゲットファイルは以下のように用い
られます。

•  デバイスの書き込みに用いる
•  デバイスイメージをビルドするのに用いる
•  16進数エディタで開く
•  User Boot Areaを目的とする（これをサポートするデバイスのみ）
•  チェックサムを計算させる
•  データブロックの使用法を表示させる

プロジェクトを用いると、次のような FDTの便利な機能を使うことができます。

•  高度なメッセージレベル
•  デバイスイメージビルダ
•  ターゲットデバイスからのデータのアップロード
•  アップロードしたデータをビッグエンディアン、リトルエンディアン、浮動小数点表示で見る
•  シンプルインタフェースモード（プロジェクト構築後、ユーザインタフェースを単純にするため）
•  プロジェクトを開いたとき、ファイルの非フラッシュ領域を自動マスク
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2.1 ユーザインタフェース
FDTグラフィカルユーザインタフェースは、Windows 対応のアプリケーションで、フラッシュメモリに書き

込むための作業環境を提供します。

図 2-1　FDTグラフィカルユーザインタフェース

メニューバー
メニューバーでは、コマンドがいくつかのグループに分類されて、関連するメニュータイトルに割り当
てられています。ユーザはマウスを用いてコマンドを選択したり、ダイアログボックスやウィンドウを
呼び出してシステムの動作を指示することができます。メニュータイトル上でマウスの左ボタンをクリ
ックすると、プルダウンメニューが開きます。ここからメニューオプションを選択できます。

メニューオプションによっては、すぐに動作を行なわず、ダイアログボックスやウィンドウを開いて、
ユーザに指示を求めるものもあります。このようなメニューオプションは、名前のうしろに省略記号
（３つのピリオド：…）がついています。

ワークスペース
ウィンドウ

エディタ
ウィンドウ

メニューバー
ツールバー

ステータスバー

ワークスペース

アクティブ
プロジェクト

追加
プロジェクト

User Area

デバイスイメージ

16進数エディタで
開くファイル

タイトルバー

16進数エディタ
アドレスカラム

出力ウィンドウ

Sレコード
プロパティ
ダイアログ

フラッシュプロパティ
ウィンドウ（ドッキング）
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図 2-2　メニューの省略記号

ショートカットキー（複数のキーの組み合わせ）で呼び出せるメニューオプションもあります。この場
合、メニューオプションの右側に、ショートカットキーが表示されます。

機能のオン／オフを切り替えるメニューオプションの場合、その機能がオン（有効）になっていると、
メニューオプションの横にチェックマーク（ ）が表示されます。

図 2-3　チェックしたメニュー項目

メニューオプションの横に三角記号（8）がついているものは、カスケード（階層）メニューを使用で
きます。メニューオプションをクリックすると、カスケードメニューが表示されます。

図 2-4　カスケードメニュー

キーボードから直接メニューを選択することもできます。ALTキーを押しながら、メニューオプション
名の下線部の文字または数字のキーを押すと、メニューが選択できます。たとえば、アクティブファイ
ルを保存する場合（[File->Save]）、ALTキーを押しながらFキー、Sキーの順に押します。

ツールバー
FDTでは、メニューバーの下に、数種類のツールバーがあります。マウスでボタンをクリックすると、
FDTの対応する機能にすばやくアクセスすることができます。

図 2-5　FDTツールバー
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ボタンは、関連するグループに分けて、各ツールバーに配置されています。

ボタンの機能を知りたい場合は、ボタンの上にマウスを置くと、ボタンの横とステータスバーにボタン
機能の概要が表示されます。

ツールバーはカスタマイズできます。FDTのほとんどの機能をボタンとして追加することができ、ボタ
ンの配置も使いやすいように変更することができます。

ツールバーボタンの配置の変更や、各ボタンの機能の詳細については、６章を参照してください。
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エディットツールバー

図 2-6　エディットツールバー

Save File ：現在のファイルを保存します。

Cut ：クリップボードにデータをカットします。

Copy ：クリップボードにデータをコピーします。

Paste ：クリップボードからデータをペーストします。

Open an S-Record ：Ｓレコードファイルまたはデータファイルを開きます。

Save File
Cut
Copy
Paste
Open an S-Record
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FDTツールバー

図 2-7　FDTツールバー

Connect ：デバイスをFDTインタフェースに接続します。

Disconnect ：デバイスをFDTインタフェースから切断します。

Erase Blocks ：‘Erase Block’ダイアログボックスを開き、デバイスのフラッシュメモリの特
定ブロックまたは全ブロックを消去します。

Blank Check ：ターゲットデバイスのフラッシュ部が空白である／ないをチェックしま
す。

Upload ：‘Upload Image’ダイアログボックスを開き、ターゲットデバイスからデータ
をアップロードします。

Download Active File ：16進数エディタでアクティブなファイルをダウンロードします。

Checksum ：フラッシュメモリのデータのチェックサムを返します。

Go from Address ：実行アドレスを選択するダイアログボックスを開きます。

Cancel ：現在のFLASH操作を取り消します。

Flash area Context for non-write operations ：非書き込み（アップロード、ブランクチェックなど）操
作が行われるフラッシュ領域を設定します。

Configure Flash Project ：‘Project Properties’ダイアログボックス（プロジェクトが未構築の場合は
Project Wizard）を開きます。

Connect
Disconnect
Erase Blocks
Blank Check
Upload
Download Active File
Checksum
Go from Address
Cancel
Flash area Context for non-write operations
Configure Flash Project
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Sレコードツールバー

図 2-8　Sレコードツールバー

View as Bytes ：データをバイト（8ビット）単位で表示します。

View as Words ：データをワード（16ビット）単位で表示します。

View as DWords ：データをダブルワード（32ビット）単位で表示します。

Align view to 8 bytes ：8バイトずつに分けて表示します。各行に表示できるバイト数は、ウィンドウ
サイズによって異なります。

Toggle ASCII ：データをASCIIで表示する／しないを切り替えます。

Find ：‘Find’ダイアログボックスを開きます。

Find and Replace ：‘Replace’ダイアログボックスを開きます。

Create Selection ：アクティブファイル内の指定サイズブロックを選択します。

Fill selection ：‘Fill’ダイアログボックスを開きます。

Properties ：現在のファイル情報のあるダイアログボックスを開きます。

View as Bytes

View as Words
View as DWords
Align view to 8 bytes
Toggle ASCII
Find
Find and Replace
Create Selection
Fill Selection
Properties
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サーチツールバー

図 2-9　サーチツールバー

Find in Files ：選択したファイルの選択したデータを検索します。

Data ：検索に使用します。

Find ：現在のファイル中のデータを検索します。

Find Next ：次の検索位置を選択します。

Find Previous ：前の検索位置を選択します。

ステータスバー
FDTアプリケーションウィンドウの下部に、ステータスバーがあります。ステータスバーは、アプリケ
ーションの実行状況を表示します。

ステータスバーの一番左の部分には、ツールバーボタンの機能を示します。各ツールバーボタンにマウ
スポインタを置くと、動作のステータス情報を表示するのと同様に、その機能を表示します。

アクションを実行中、現在の動作の進捗割合を示すバーが表示されます。

バーの最後の部分は、Caps Lock、Insert、Number Lockキーなど、切り替え用のキーボードキーの状態を
示します。

ポップアップメニュー
ウィンドウには、ローカルポップアップメニューがあり、よく使う機能が簡単にアクセスできるように
なっています。ウィンドウ上でマウスの右ボタンをクリックするか、SHIFT+F10キーを押すと、ポップ
アップメニューが開くので、必要なメニューオプションを選択できます。以下に、ポップアップメニュ
ーの例を示します。

図 2-10　ポップアップメニュー

各ポップアップメニューの内容と機能の詳細については、第８章「ウィンドウ」の各FDTウィンドウの

Find in Files
Data
Find
Find Next
Find Previous
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説明を参照してください。

2.2 ヘルプ
FDTには、標準的なWindows のヘルプシステムがあり、システムの使用に関するオンラインヘルプ情報を表

示します。

F1キーを押すか、Helpメニューを選択して、ヘルプを呼び出すことができます。

2.3 ショートカットキー

よく使用する機能には、以下のようにカテゴリによって、ショートカットキーが割り当てられています。

内容 ショートカットキー

ヘルプ

ヘルプ F1

ファイルコマンド

Close File Ctrl+F4

Open S-Record Ctrl+R

Save All Ctrl+ Shift+H

Save Ctrl+S

Exit Alt+F4

エディットコマンド

Undo Ctrl+Z

Redo Ctrl+Y

Cut Ctrl+X

Copy Ctrl+C

Paste Ctrl+V

Select All Ctrl+A

Find Ctrl+F

Find In Files F4

Replace Ctrl+H

ツールコマンド

Login Ctrl+ Shift+U

シンプルインタフェースコマンド

Login Ctrl+ Shift+U

ビュー

Workspace Alt+K

Output Alt+U

ウィンドウ

View as ASCII Alt+A

View as Bytes Alt+1

View as Word Alt+2

View as Dword Alt+4

Align to 8 Bytes Alt+8

デバイス

Connect Ctrl+Alt+C

Erase Flash Blocks Ctrl+Alt+E

Blank Check Ctrl+Alt+B

Upload Image Ctrl+Alt+U

Download Active File Ctrl+Alt+P

Flash Checksum Ctrl+Alt+S

Go From Address Ctrl+Alt+G

Cancel Operation Ctrl+Break

Configure Flash Project Alt+Shift+R
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3 基本操作

3.1 クイックスタート
デバイスの書き込みには以下の手順が必要です。
1. FDTを起動します（3.3章参照）。
2. ワークスペースとプロジェクトを作成してください（3.4.1章参照）。
3. フラッシュプロジェクトウィザードを使用してプロジェクトを構築します（デバイス、カーネル、ポート、
モードなどの選択）（3.4.2 ～ 3.4.9章、汎用ブートについては 3.5章を参照）。

4. プロジェクトにダウンロードしたいファイルを追加してください（3.9章参照）。個々のファイルをダウン
ロードすることも、複数のファイルをデバイスイメージに統合してからダウンロードすることもできます。

3.2 バックグラウンド情報

3.2.1 User Area、User Boot Areaとは？
ルネサスデバイスの（内蔵）フラッシュメモリ領域は、ユーザプログラムに対してUser Areaとして知ら
れています。これは、デバイスがUser Modeでリセット後に実行されるユーザプログラムを保存してお
く領域です。通常、User Areaは、Boot ModeあるいはUser Mode接続から書き込みができます。

いくつかのデバイスにおいて、User Boot Areaとして知られるフラッシュメモリ領域があります。これ
は、デバイスがUser Boot Modeでリセット後に実行されるユーザプログラムを保存しておく領域です。
User Boot Areaは、User Areaよりさらに小さくなりがちで、主に代替スタブを保存するために使用され、
他の通信メディア/プロトコル経由で通信を確立します。通常、User AreaとUser Boot Areaは、どちらも
同じアドレスから開始します。これは、どちらか一方のみがメモリマッピングされるために可能なこと
です。User Boot Areaは、User Modeではなく、Boot Modeからのみ書き込むことができます。

3.2.2 Boot Modeと User Modeの違いは？
ルネサスフラッシュデバイスには異なる動作モードがあり、デバイスがリセットされるときにモード端
子の状態を制御する必要があります。ほとんどのデバイスには、非同期シリアルBoot Mode、User
Mode、User Program Modeがあります。

一般的に、（非同期シリアル）Boot Mode接続は、自動転送速度で開始し、ある転送速度で初期通信を
確立するための同期化データパケットを送信します。さらに、ほとんどのデバイスでは、接続プロセス
の一部としてフラッシュ全体が消去されるため、デバイス上のプログラムコードがBoot Modeから読み出
されないようになっています。

User Mode接続について、FDTと対話ができ、書き込みを許可するコードによって、デバイス上にユーザ
プログラムが既に書き込みされていなければなりません。ほとんどのカーネルには、User Modeマイクロ
カーネルおよびテストプログラム（*通常、”uGenU.mot”および”XXXXtest.mot”と呼ばれます）が提供
されています。このようなファイルはUser Mode書き込みをデモンストレーションし、デバイスに書き込
まれたり、FDTがUser Modeへの接続を試みる前に実行されていなければなりません。User Modeは、通
常、接続中にフラッシュを強制消去せず、自動転送速度で初期通信をセットアップしません。User Mode
テストプログラムのデモンストレーションには、転送速度9600で初期通信をセットアップするため、テ
ストプログラムに準拠したビットレートレジスタ値があります。したがって、User Modeカーネルを異な
るクロック周波数で再ビルドする必要があります。

*組み込みモニタの一部としてファイルを使用する場合、User Modeカーネルファイルも、リセットベク
タを存在させずにバイナリファイル（.cde）として出力されることがあります。いくつかのカーネル
は、User Modeテストプログラム（例えば、Protocol Cカーネル）に単一ファイルのみを使用します。
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3.2.3 User Modeと User Program Modeの違いは？
いくつかのデバイスには追加モード端子があり、フラッシュを誤って書き込んだり消去したりすること
を防ぎます。この端子は、ハイレベルで書き込み可能あるとき、’Flash Write Enable’端子（FWE）として
知られています。また、ローレベルで書き込み可能あるとき、’Flash Write Protect’端子（FWP）として知
られています。これらのデバイスで、この端子は、’User Mode’と’User Program Mode’を区別します。
FDT User Mode接続は、書き込みと消去の点においては、デバイスがUser Program Modeにあることが望
まれます。FDMを使用している場合、接続を解除したとき、書き込んだコードを実行するためにデバイ
スをUser Modeにリセットすることができます。

3.2.4 ‘Protocol A’、‘Protocol B’、‘Protocol C’カーネルとは？
‘Protocol A’：FDT 1.5タイプのカーネルを使用する0.8µm、0.6µm、0.35µmフラッシュデバイス用です。

FDTインストーラではサポートされず、同梱されないレガシーカーネルです。Protocol Aカーネルは、
FDT日本語バージョンでは利用できません。UPBは使用できますが、FDMはサポートしていません。カ
ーネルは、Boot Mode、User Modeにおいて、異なる水晶周波数に対して再ビルドし、UPBを使用してい
る場合はPMODE端子を変更するために再ビルドする必要があります。カーネルに添付される補足情報の
ドキュメントを参照してください。

‘Protocol B’：0.35µmデバイス用です。FDMをサポートしますが、UPBはサポートしません。

Boot Mode – カーネル（Boot Mode Micro Kernel、Boot Mode Main Kernel、書き込みモジュール、消去モジ
ュールから構成されます）は、PC上で保持され、必要に応じてダウンロードされます。Boot Modeカー
ネルは、異なる水晶周波数に対して再ビルドする必要はありません。この情報はFDTプロジェクトに保
存され、実行時にダウンロードされます。また、自動転送速度により、初期通信を実現します（デバイ
スが0x00データと同期するまでFDTはこのデータを送信します）。

User Mode – User Mode Test Program、および User Mode Micro-Kernelは、デバイス上で既に書き込まれ、
実行している必要があります。Bit Rate Registerの初期値は’gentest.h’ファイルに保存され、User Mode
Test Programにコンパイルされます。これにより、カーネルは、シリアルコミュニケーションインタフ
ェースの転送速度を 9600に初期化することができます。クロック周波数がデフォルト値から変化する
と、’gentest.h’（通常、MA_BRR_SCIあるいはMA_BRR_SCI1）における Bit Rate Registerの初期設定を
変更し、カーネルを再コンパイルする必要があります。User Mode Main Kernel、書き込みモジュール、
消去モジュールは、PC上で保持され、必要に応じてダウンロードされます。

‘Protocol C’：組み込みカーネル（現在は0.18µm）を持つデバイス用です。FDMをサポートしますが、UPBはサポ
ートしません。

Boot Mode – コンフィグレーションファイルは、デバイスの詳細をFDTへ提供するPC上で保存されます
が、カーネル（書き込みモジュール、消去モジュールを含みます）はデバイス内部に存在します。Boot
Modeでは、異なるクロック周波数に対して再ビルドする必要はありません。この情報はFDTプロジェク
トに保存され、実行時にダウンロードされます。また、自動転送速度により、初期通信を実現します
（デバイスが0x00データと同期するまでFDTはこのデータを送信します）。
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3.2.5 fcfファイル、fdmファイルとは何ですか？編集は可能ですか？
他のカーネルファイルと一緒に保存されているファイル.fcf (Flash Configuration File)および.fdm (Flash
Development Module)は、デバイスとカーネルの詳細を保持しています。各カーネルディレクトリでサポ
ートされるデバイスには、それぞれ、.fcfファイルと.fdmファイルがあります。RAMサイズ、フラッシュ
サイズ、Erase Block Registerの詳細、デフォルトの転送速度および水晶周波数などの情報は.fcfファイル
に保存されます。FDMに有効な端子設定の詳細は、FDMファイルに保存されます。これらの各ファイル
はチェックサムで保護されているため、編集すると無効となり、FDTに検出されます。.fcfファイルまた
は.fdmファイルの無効なチェックサムを検出すると、FDTはユーザに警告を発します。

3.2.6 自分の PCにローカルマシン管理者の権限がなくても FDTを使えますか？
はい、使えますが、FDTを一度だけインストールし、構築してください。FDTおよび様々なコンフィグ
レーションタスクをインストールするには、ローカル管理者の権限が必要です。それは、設定のいくつ
かがHKEY_LOCAL_MACHINEレジストリ領域に保存されているためです。一度FDTをインストール
し、構築すると、制限付きで使用することができます。カーネルの新規エントリをProject Wizardで将来
利用できるようにレジストリに追加するコンフィグレーションタスクは、ローカルマシン管理者の権限
を必要とします。これには、Prior Generic Deviceエントリの追加も含まれます（管理者は、Prior Generic
Deviceエントリの作成が可能になるように、最初にGeneric Deviceに接続しなければなりません）。さら
に、タイムアウトの微調整など、設定の変更に使用するFDT Advanced Setupユーティリティは、設定を
保存するため、ローカルマシン管理者の権限を必要とします。パスワード管理にも、ローカルマシン管
理者の権限が必要です。

3.2.7 カーネルはどのように再コンパイルするのですか？
オリジナルのカーネルを別のディレクトリにコピーし、このコピーを編集して、オリジナルには手を加
えないことをお薦めします。カーネルを最初に使うとき、.fcfファイルを検索するため、代わりの場所を
ブラウズする必要があります。

HEWを使用してカーネルが書き込まれると、カーネルのプロジェクトサブディレクトリに HEWのワー
クスペースファイルが生成されます。これは HEWから開きます。

コマンドラインからのコンパイルに基づいてカーネルが書き込まれた場合、環境変数をコンパイラにセ
ットアップし、コンパイラをコマンドラインから実行できるようにしてから、buildall.batファイルを
DOSシェルセッションから実行する必要があります。この実行方法に関する詳細は、コンパイラのマニ
ュアルを参照してください。ルネサス製 H8コンパイラバージョン 4.0aに環境設定する際の環境バッチ
ファイルの例を以下に示します。
Setenv.bat:
SET CH38=C:\hew\tools\Renesas\h8\4_0_A\INCLUDE

PATH=%PATH%;C:\hew\tools\Renesas\h8\4_0_A\bin

set DOS16M= @1M-31M

SET CH38TMP=c:\TEMP

注注注注 オペレーティングシステムによっては（Windows  2000など）、command.comより cmd.exeを使いま
す。
上記バッチファイルは、お使いのコンピュータのパスを反映するため、変更する必要があります。
指定のテンポラリディレクトリが存在し、書き込み可能であることを確認してください。
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3.2.8 User Mode Kernelのデモンストレーションはどのように使うのですか？
User Modeカーネルのデモンストレーションを使用するには、まず、User Mode Micro KernelおよびUser
Mode Test Programをカーネルディレクトリ（”uGenU.mot”および”XXXXtest.mot”）からBoot Mode
Projectへ追加し、User Area Device Imageをビルドしてください。次に、Boot Modeで接続し、イメージを
デバイスへ書き込み、User Modeでデバイスを切り離し、リセットしてください。ワークスペースに別の
プロジェクトを作成しますが、User Mode Connection Typeとして設定し、User Modeで接続してくださ
い。FDTは9600bpsでUser Mode Test Programと通信を開始し、プロジェクトに設定した転送速度に変更し
ます。User Modeで接続している間、デバイスは自動的に消去されないことに注意してください。コード
の再書き込みをフラッシュから実行している間はフラッシュを再書き込みできないため、FDTと通信を
続ける必要のあるすべてのカーネルモジュールをRAMにコピーし、フラッシュROMを再書き込み可能な
ままにしておきます。このため、フラッシュ全体を消去し、ユーザモードで再書き込みすることが可能
ですが、消去後、再書き込みされる前にデバイスをリセットする場合、デバイスがUser Mode Micro
KernelおよびUser Mode Test ProgramをBoot Modeに再書き込みするまで、User Modeで接続を再開するこ
とはできません。

3.2.9 異なるクロック周波数を User Modeカーネルに使用することはできますか？
オリジナルのカーネルを別のディレクトリにコピーし、このコピーを編集して、オリジナルには手を加
えないことをお薦めします。カーネルを最初に使うとき、.fcfファイルを検索するため、代わりの場所を
ブラウズする必要があります。

異なるクロック周波数を使用しようとする場合、User Mode カーネルを再ビルドする必要があります。
Bit Rate Registerの初期値は’gentest.h’ファイルに保存され、User Mode Test Programにコンパイルされま
す。これにより、カーネルは、シリアルコミュニケーションインタフェースの転送速度を9600に初期化
することができます。クロック周波数がデフォルト値から変化すると、’gentest.h’（通常、MA_BRR_SCI
あるいはMA_BRR_SCI1）におけるBit Rate Registerの初期設定を変更し、カーネルを再コンパイルする必
要があります。Bit Rate Registerの値の計算方法については、デバイスのハードウェアマニュアルを参照
してください。

3.3 ＦＤＴを起動する

3.3.1 セキュリティとシンプルインタフェースモードを無効にしてＦＤＴを起動す
る

FDTを起動するにはWindows の ‘スタート’メニューから ‘プログラム’、‘Renesas’、‘FLASH
Development Toolkit 3.2’を選択し、’FLASH Development Toolkit 3.2’のショートカットを選びます。デフォ
ルトで‘Welcome!’ダイアログボックスが開きます。

新規ワークスペースを作成するには ‘Create a new project workspace’ を選択し、‘OK’ボタンをクリック
してください（詳細は、3.4.1章を参照）。最近開いたワークスペースを開くには ‘Open a recent project
workspace’およびリストボックスから開きたいワークスペースを選択してください。最近使用したワーク
スペースのリストにない作成済みのワークスペースを開くには ‘Browse to another project workspace’ を選
択します。最後に‘OK’ボタンをクリックしてください。

図 3-1　Welcome!ダイアログボックス
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3.3.2 ワークスペースファイルをダブルクリックしてＦＤＴを起動する
Windows のエクスプローラでワークスペースファイルをダブルクリックすると FDTを起動できます。

起動時に、FDTは選択したワークスペースをロードします。

3.3.3 データファイルをダブルクリックしてＦＤＴを起動する
Windows のエクスプローラで登録されたデータファイルをダブルクリックすると FDTを起動できま

す（インストール時にこのデフォルトオプションが非選択でなかった場合）。起動時に、FDTは選択し
たデータファイルをロードします。

3.3.4 スクリプトコンフィグレーションファイル(. w4f)をダブルクリックしてＦＤＴ
を起動する

Windows のエクスプローラでスクリプトコンフィグレーションファイル(.w4f)をダブルクリックする
と FDTを起動できます。FDTはWait For Scriptモードで起動し、選択したコンフィグレーションをロー
ドします。

3.3.5 シンプルインタフェースモードを有効にしてＦＤＴを起動する
Simple Interface Mode（9章参照）から FDTを終了した場合、FDTは再び同じモードに戻ります。

3.3.6 アクセス権パスワードのセキュリティを有効にしてＦＤＴを起動する
アクセス権パスワードのセキュリティを有効にした場合、FDTはワークスペースを開く前にログイン

ダイアログボックスを表示します。詳細は、5章を参照してください。

3.3.7 コマンドラインからＦＤＴを起動する

コマンドラインからデータファイルを開く
“<FDT path>\FDT.exe” /DISCRETESTARTUP "osre \"< Filename >\""
eg:
"C:\Program Files\Renesas\FDT3.2\FDT.exe" /DISCRETESTARTUP "osre \"C:\Program
Files\Renesas\files\myfile.mot\""

コマンドラインからワークスペースファイルを開く
“<FDT path>\FDT.exe” /DISCRETESTARTUP "ow \"<Long Path Workspacename>\""
eg
"C:\Program Files\Renesas\FDT3.2\FDT.exe" /DISCRETESTARTUP "ow \"C:\Program
Files\Renesas\FDT3.2\Workspaces\1234\1234.AWS\""

アクセス権パスワードのセキュリティを有効にしてコマンドラインからデータファイルを開く
“<FDT path>\FDT.exe” “arl \“<Username>\” \“<Password>\”” “osre \“< Filename >\””
eg
“C:\Program Files\Renesas>"C:\Program Files\Renesas\FDT3.2\FDT.exe" "arl \"Admini
strator\" \"password\"" "osre \"C:\Program Files\Renesas\files\myfile.mot\""

コマンドラインからw4fスクリプトコンフィグレーションファイルを開く
“<FDT path>\FDT.exe” /DISCRETESTARTUP "w4fRun \"<filename>\""
eg
"C:\Program Files\Renesas\FDT3.2\FDT.exe" /DISCRETESTARTUP "ow \"C:\Program
Files\Renesas\FDT3.2\myconfig.w4f\""

アクセス権パスワードのセキュリティを有効にしてコマンドラインからw4fスクリプトコンフィグレーションフ
ァイルを開く

“<FDT path>\FDT.exe” “arl \“<Username>\” \“<Password>\”” /DISCRETESTARTUP "w4fRun
\"<filename>\""
eg
"C:\Program Files\Renesas\FDT3.2\FDT.exe" "arl \"Administrator\" \"password\"" /DISCRETESTARTUP
"ow \"C:\Program Files\Renesas\FDT3.2\myconfig.w4f\""
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注注注注 コマンドラインから FDTの各コマンド（書き込み、消去等）を制御すること、および FDTを終了する
ことは行えません。
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3.4 新規ワークスペースとプロジェクトを作成する

3.4.1 New Project Workspace
ワークスペース名を入力します（プロジェクト名はデフォルトで同じです）。入力完了後、‘OK’ボタンをクリ

ックしてください。
ディレクトリを変更、作成したい場合は、ディレクトリ名を入力するか、’Browse…’ボタンを使用してくださ

い。

図 3-2　新規ワークスペース
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3.4.2 デバイスとカーネルの選択（汎用ブート以外*）
デバイスをドロップリストより選択します。
カーネルオプションを 1つ以上表示させることができます。また、カーネル上でダブルクリックすると、カー

ネルに関する情報（カーネルとともに作成されたデバイス、バージョン番号、コンパイラなど）を含む
“readme.txt”ファイルを開きます。
表示されたリストから必要なカーネルを選択してください。あるいは、リストにない別の代替カーネルがある

場合には、’Other…’を選択し、カーネルフラッシュコンフィグレーションファイル（.fcf）を指定してください。

* Generic Boot Deviceとの接続については、「ルネサスの汎用ブートデバイスとしてプロジェクトを構築す
る」の章を参照してください。

図 3-3　デバイスとカーネルの選択
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3.4.3 通信ポート
ポート（利用できる場合はインタフェースも）をドロップリストより選択し、‘次へ(N)＞’ボタンをクリックし

てください。シリアルポートのほかに、FDM（USBインタフェースボード）を使用するオプションもあることに
注意してください。いくつかのカーネルでは、USB Direct（2215UF用など）のようなほかのポートオプションも
あります。Protocol A (legacy)カーネルでは、直接接続のほかに、’HMSE UPB’インタフェースが利用できます。

図 3-4　通信ポート
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3.4.4 デバイスの設定
デバイス設定用の値を入力してください。クロックを入力したあと、ドロップリストからメインクロックおよ

び周辺クロックの逓倍比を選択し、‘次へ(N)＞’ボタンをクリックしてください。

図 3-5　デバイスの設定

補足：
1. CPU Crystal Frequency
マイコンに入力しているクロックまたはマイコンに接続している水晶発振子の周波数を入力してください。小数点以

下 4 桁まで有効です。ターゲットデバイス、カーネル、クロックモードによって有効な範囲が決定します。

2. Clock Mode
有効な場合、ドロップリストから必要な値を選択してください。

3. Multiplier for CKM
有効な場合、入力クロックに対するマスタクロック（システムクロック）の入力クロック逓倍比を選択してください。有効

なオプションは、ターゲットデバイス、カーネル、クロックモードに依存します。

4. Multiplier for CKP
有効な場合、周辺クロックに対する入力クロック逓倍比を選択してください。有効なオプションは、ターゲットデバイス、

カーネル、クロックモードに依存します。

注注注注 クロックモード、入力クロックおよび逓倍比の入力に際しては、ハードウェアマニュアルを参照し、必
要な値を確認してください。
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3.4.5 接続の種類
‘Connection Type’ダイアログボックスで、Boot Mode用の接続か、User Mode用の接続かを選択してください。

さらに、デバイス上で以前のセッションから実行が継続しているカーネルとの接続においては、’Kernel already
running’チェックボックスを選択してください。次に、デフォルト値が正しくない場合、あるいは存在しない場
合、通信速度（bps）を選択してください。ターゲットの誤差が 4%以上、あるいは、FDMの誤差が 0%以外の速
度は、推奨リストから自動的に削除されます。FDMを FDT3.2カーネルと共に使用している場合、’User
Specified’接続速度オプションが有効になります。これを選択すると、ユーザは、標準ではない転送速度を指定す
ることができます。表示される誤差には、ターゲットの周辺クロックレート、ターゲットのビットレートレジス
タ計算式、FDMの特性が考慮されています。

‘次へ(N)＞’ボタンをクリックしてください。

図 3-6　接続の種類

‘Use Default’は、ルネサスの評価ボードまたは評価開発キットと使用することが目的です。ビットレートを手
動で選択する場合、このチェックを外すと、ビットレートを手動で選択できます。
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3.4.6 プログラミングオプション
フラッシュ ROM書込み時の保護レベル、メッセージ出力レベルの選択をします。入力完了後、‘完了’ボタン

をクリックしてください。FDMが選択されている場合、‘次へ(N)＞’ボタンをクリックしてください。

図 3-7　プログラミングオプション
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3.4.7 FDM端子設定
[FDMが選択された場合のみ] ‘Operating Mode’および’Clock Mode’を選択してください。’User Defined’の場合は、

FDM端子を設定してください。[‘Boot Mode’プロジェクトでは、必要なモードに’Boot Mode Outputs’および’Boot
Mode Setting’を設定し、’User Mode’プロジェクトでは、必要なモードに’User Mode Outputs’、’User Mode
Setting’、’User Program Mode Setting’を設定してください。] ‘次へ(N)＞’ボタンをクリックしてください。’*Mode
Outputs’は、FDMで駆動する端子を設定します。’*Mode Setting’は、出力端子が High（チェックあり）または
Low（チェックなし）のどちらかであるかを設定します。

注注注注 FDMを使用してモード端子を設定するには、注意が必要です。デフォルト設定が有効であっても、端子
の設定をハードウェアマニュアルで確認してください。いくつかのデバイスでは、モード端子の設定を
変更すると、最大供給電圧が変わることに注意してください。

図 3-8　FDM端子設定
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3.4.8 リセット端子設定
[FDMが選択された場合のみ] ‘Operating Mode’および’Clock Mode’を選択してください。’User Defined’の場合は、

リセット端子を設定してください。接続が解除された直後、必要なモードに’Reset Outputs’および’Reset Setting’を
設定してください。‘完了’ボタンをクリックしてください。

’*Mode Outputs’は、FDMで駆動する端子を設定します。’*Mode Setting’は、出力端子が High（チェックあり）
または Low（チェックなし）のどちらかであるかを設定します。

注注注注 FDMを使用してモード端子を設定するには、注意が必要です。デフォルト設定が有効であっても、端子
の設定をハードウェアマニュアルで確認してください。いくつかのデバイスでは、モード端子の設定を
変更すると、最大供給電圧が変わることに注意してください。

図 3-9　リセット端子設定
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3.5 ルネサスの汎用ブートデバイスとしてプロジェクトを構築する
ルネサスの汎用ブートデバイスと接続することも可能です。ユーザは、カーネルやコンフィグレーションファ

イルをインストールする必要がなく、代わりに FDTはデバイス自信から必要な情報を引き出します。このため、
プロジェクトを作成するときは、デバイスが接続され、Boot Modeに設定されなければなりません。汎用ブート
デバイスを選択した場合、一連の画面に問い合わせた関数の結果が表示されます。デバイスとクロックモードを
選択する必要があります（1つのブートプログラムは、複数のデバイスに共有されるかもしれません）。

3.5.1 New Project Workspace
ワークスペース名を入力します。入力完了後、‘OK’ボタンをクリックしてください。
（ディレクトリを作成するかどうか、および場所を指定してください。)

図 3-10　新規ワークスペース



3　基本操作

29

3.5.2 汎用ブート – デバイスとカーネルの選択
‘Generic Boot Device’を選択し、’次へ(N)’をクリックしてください。

図 3-11　汎用ブートデバイスの選択

3.5.3 汎用ブート – 通信ポート
ポート（利用できる場合はインタフェースも）をドロップリストより選択し、‘次へ(N)＞’ボタンをクリックし

てください。シリアルポートのほかに、FDM（USBインタフェースボード）を使用するオプションもあることに
注意してください。
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図 3-12　通信ポート

3.5.4 汎用ブート – FDM端子設定（FDM接続のみ）
FDMが選択されると、以下の画面が表示されます。デバイスを Boot Modeにするのに必要なモード端子を設

定してください。その後、’OK’をクリックしてください。

図 3-13　汎用デバイス FDM端子設定

注注注注 FDMを使用してモード端子を設定するには、注意が必要です。デフォルト設定が有効であっても、端子
の設定をハードウェアマニュアルで確認してください。いくつかのデバイスでは、モード端子の設定を
変更すると、最大供給電圧が変わることに注意してください。
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‘Select USB Device’ダイアログボックスが表示された場合、接続を設定するために使用する FDMユニットを選
択しなければなりません。

図 3-14　 USBデバイスの選択

3.5.5 汎用ブート – 確認
FDTは、デバイスが接続され、電源が入ったことをユーザが確認するのを待ちます。FDMを使用していない

場合は、Boot Modeで待ちます。ユーザが’OK’をクリックすると、FDTはデバイスに接続しようとします。

図 3-15　汎用ブートの確認

このあと、FDTは進行状況を表示します。汎用ブートプロセスの間、ユーザは、デバイスの詳細を選択し、確認
する必要があります。詳しくは、以下を参照してください。
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3.5.6 汎用ブート – デバイスの選択
いくつかのデバイスはブートプログラムを共有するため、サポートされるデバイスのリストが提供されます。

リストから正確なデバイスを選択し、’OK’をクリックしてください。

図 3-16　汎用ブート – デバイス
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3.5.7 汎用ブート – クロックモードの選択
いくつかのデバイスには多数のクロックモードがあるため、すべての可能なクロックモードのリストが提供さ

れます。リストから正確なクロックモードを選択し、’OK’をクリックしてください。正確なモードが選択された
ことをハードウェアマニュアルやターゲットボードマニュアルで確認してください。

図 3-17　クロックモード

3.5.8 汎用ブート – セットアップの完了
クロックモードを選択すると、以下のように Genericウィザードが完了します。

図 3-18　汎用ブートセットアップの完了
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プロジェクトウィザードが残りのページに続きます。

3.5.9 汎用ブート – デバイスの設定
3.4.4章を参照してください。

3.5.10 汎用ブート – 接続の種類
3.4.5章を参照してください。

3.5.11 汎用ブート – プログラミングオプション
3.4.6章を参照してください。

3.5.12 汎用ブート – リセット端子設定[FDM接続のみ]
3.4.8章を参照してください。

3.5.13 汎用ブート – 接続オプションでの再確認
‘Flash Properties’ダイアログボックスの’Programmer’タブで、FDTは接続ごとに汎用デバイスを再確認するかど

うかを決めることができます。デフォルトは’いいえ’に設定されているため、一度接続が確立すると、FDTは、
最初に問い合わせたデバイスから集めたデータを再利用します。このオプションが’はい’に変更されると、FDT
は、Boot Modeで接続するたびにデバイスの詳細をデバイスに確認します。これは、汎用ブートプロジェクトが
いかなる汎用ブートデバイスとも動作できることを意味します。

3.5.14 以前の汎用デバイス
‘Prior Generic Device’を選択すると、’Generic Boot Device’を使用して前回のデバイスと接続することができま

す。’Generic Boot Device’を使用して最初に接続したときに生成した.fcfファイルを使用します。

3.6 ワークスペースを保存する

[File->Save Workspace]メニューオプションを選ぶと、FDTのワークスペースが保存できます。

3.7 ワークスペースを閉じる

FDTのワークスペースを閉じるには、[File->Close Workspace]を選んでください。ワークスペースまたはその
プロジェクトに変更があった場合は、プロジェクトを保存したいかをダイアログボックスで聞かれます。ワーク
スペースを保存する場合は ‘はい’ を、保存しない場合は ‘いいえ’ を選んでください。また、ワークスペースに戻
る場合は ‘キャンセル’ をクリックしてください。セッションを保存するように指示された場合は’はい’を選んで
ください。これらの指示は、[Tools->Options]ダイアログボックスのWorkspaceタブの設定を変更することにより、
オンとオフが切り替わります。

3.8 ＦＤＴを終了する

FDTを終了するには[File->Exit]を選ぶか、Alt+F4キーを押下するか、システムメニューから‘閉じる’オプシ
ョンを選んでください（システムメニューは FDTタイトルバーの最も左上側にあるアイコンをクリックすると
開きます）。
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3.9 フラッシュＲＯＭにデータを書き込む

3.9.1 User Area（通常のフラッシュ領域）に個別ファイルを書き込む
1. [Project->Add Files…]または、INSキーにてダウンロードするファイルをプロジェクトに追加します。
2. ワークスペースウィンドウに表示されているファイル上で右クリック後、‘Download File’ を選択します。
出力ウィンドウに ‘Image successfully written to device’ が出力されたら書込み完了です。

3.9.2 User Area（通常のフラッシュ領域）に複数ファイルを書き込む
1. [Project->Add Files…]または、INSキーにてターゲットファイルをプロジェクトに追加します。複数のファ
イルは、’Add File(s)’ダイアログボックスから追加できます。

2. [Project->Rebuild Image->User]を選択し、User Areaにデバイスイメージをビルドしてください（すべての
ターゲットファイルをマージした結果のファイルを作成してください）。

3. ワークスペースウィンドウに表示されているデバイスイメージファイル（<ProjectName>.fpr）上で右クリッ
ク後、‘Download User Image’ を選択します（あるいは[Project->Download Image->User]を選択します）。

4. 出力ウィンドウに ‘Image successfully written to device’ が出力されたら書込み完了です。

3.9.3 User Boot Areaに個別ファイルを書き込む
1. [Project->Add Files…]または、INSキーにてダウンロードするファイルをプロジェクトに追加します。
2. ワークスペースウィンドウに表示されているファイル上で右クリック後、‘User Boot Area File’ を選択し、
このファイルが User Boot Area用であることを示します。

3. ワークスペースウィンドウに表示されているファイル上で右クリック後、‘Download File to [User Boot
Area]’ を選択します。出力ウィンドウに ‘Image successfully written to device’ が出力されたら書込み完了です。

3.9.4 User Boot Areaに複数ファイルを書き込む
1. [Project->Add Files…]または、INSキーにてターゲットファイルをプロジェクトに追加します。複数のファ
イルは、’Add File(s)’ダイアログボックスから追加できます。

2. ワークスペースウィンドウに表示されているファイル上で右クリック後、‘User Boot Area File’ を選択し、
このファイルが User Boot Area用であることを示します。

3. [Project->Rebuild Image->User Boot]を選択し、User Boot Areaにデバイスイメージをビルドしてください
（すべてのターゲットファイルをマージした結果のファイルを作成してください）。

4. ワークスペースウィンドウに表示されているデバイスイメージファイル（<ProjectName>_UserBoot.fpr）上
で右クリック後、‘Download User Boot Image’ を選択します（あるいは[Project->Download Image->User
Boot]を選択します）。

5. 出力ウィンドウに ‘Image successfully written to device’ が出力されたら書込み完了です。

3.9.5 User Areaに複数ファイル、User Boot Areaにその他のファイルを書き込む
1. [Project->Add Files…]または、INSキーにてターゲットファイルをプロジェクトに追加します。複数のファ
イルは、’Add File(s)’ダイアログボックスから追加できます。

2. ワークスペースウィンドウに表示されているファイル上で右クリック後、‘User Boot Area File’ を選択し、
このファイルが User Boot Area用であることを示します。

3. [Project->Rebuild Image->Both]を選択し、User Boot Areaにデバイスイメージをビルドしてください（すべ
てのターゲットファイルをマージした結果のファイルを作成してください）。

4. [Project->Rebuild Image->Both]を選択してください。
5. User Areaと User Boot Areaの出力ウィンドウに ‘Image successfully written to device’ が出力されたら書込み完
了です。
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3.10 フラッシュＲＯＭのデータを消去する

1. [Device->Erase FLASH blocks…]を選択し、’Erase Blocks’ダイアログボックスを表示します。
2. 消去対象ブロックを選択します。（行をクリックすると、反転表示となる）*

3. ‘Erase’ボタンをクリックし、消去開始します。
4. 出力ウィンドウに ‘Erase complete’ が出力されたら消去完了です。

図 3-19　Erase Blocksダイアログボックス

注注注注 全ブロックを消去する場合には、‘Select All’ボタンをクリックすると全ブロックが反転表示となります。
また、書き込み済みのブロックを消去したい場合には、‘Select Written’ボタンをクリックすると対象ブ
ロックが反転表示となります。



3　基本操作

37

3.11 フラッシュＲＯＭのデータを読み込む

1.  [Device->Upload Image…]で’Upload Image’ダイアログボックスを表示させます。
2. 開始／終了アドレス、あるいは開始アドレスとデータ長を入力します。
3.  ‘Upload’ボタンをクリックし、読み込み開始します。
4. 出力ウィンドウに ‘Upload operation complete’ が表示され、アップロードしたデータが 16進数エディタに表
示されたら読み込み完了です。

Absoluteイメージを指定した場合、アップロードしたデータは、そのデータがアップロードされたときと同
じアドレスにあるフラッシュメモリのサイズのイメージになります。アップロードしたデータにプロジェク
トを追加する必要がある場合は、Absolute Imageを使ってください。フラッシュメモリ外の領域を Absolute
Imageへアップロードすることはできません。

注注注注 ブートモードで立ち上げた場合は、フラッシュメモリのデータはあらかじめ、消去されています。

図 3-20　Upload Imageダイアログボックス
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4 Wait For Script

4.1 Wait For Scriptの概要
本モードでは、FDTは、コマンドスクリプトを含むテキストファイルによって自動的に実行されます。FDT

は、所定の場所にファイルが存在しない場合、ポーリングします。このファイルが見つかると、FDTは、各コマ
ンドを順に実行します。実行が終わると、スクリプトファイルを任意に削除、移動することができるため、次の
スクリプトファイルを検索できる状態になります。簡単なテキストファイルを使用することにより、外部アプリ
ケーションの制御下で、FDTは接続、書き込み、消去、ブランクチェックなどを行うことができます。（FDT以
外のコマンドには対応しておりません）

出力ウィンドウのメッセージは、後の分析、および調査用に、任意にログファイルにすることができます。ま
た、現在および以前のスクリプトプロセスの状態に関する情報を持つステータスファイルを作成します。このス
テータスファイルは、スクリプトが正常に処理されているかどうかを決定する外部アプリケーションが使用しま
す。

FDTのWait For Scriptをセットアップするには、コンフィグレーションファイルを作成する必要があり、スク
リプトファイルのサーチパス、および、ログやステータスファイルなどを設定する他のパラメータを指定します。
また、エラーの処理方法も指定します。

4.2 Wait For Script – New Configuration…
[Tools]->[Wait For Script]->[New Configuration…]メニューから起動します。

4.2.1 [Script File]ページ

図 4-1　[Script File]ページ

これは、wait for scriptコンフィグレーションの主要なページです。

Description
任意のテキスト表示であり、誰がファイルを作成したか、何故ファイルを作成したか、何のファイル
か、などについて記述します。これは、表示以外に使用されません。
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Script Path
唯一、必須のフィールドです。このエディットボックスで、実行するスクリプトファイルを検索する場
所を設定できます。これは、特定のファイル（例：c:\Scripts\MyScript.fsf）、あるいは、ディレクトリと
ワイルドカードの組み合わせ（例：c:\Scripts\*.fsf）のどちらも可能です。

編集フィールドの右側にある[File…]ボタンは、ユーザが使用したいファイルを検索できるダイアログボ
ックスを起動します。ワイルドカード編集フィールドの右側にある[Wildcard…]ボタンは、標準の
Windowsディレクトリを選択するダイアログボックスを起動します。このダイアログボックスでディレ
クトリを選択すると、ユーザの都合に合わせて、パスの末尾に‘\*.fsf’（fsfは、デフォルトのスクリプト
拡張子です）も追加されます。このフィールドも手動で編集することができます。

Timings
スクリプトファイルを見つけ、アクセスした後、FDTがスクリプトファイルをポーリングする頻度、お
よび処理前にFDTが待つ時間を制御することができます。

Save
FDT Script Configurationファイル（デフォルト拡張子：.w4f）を保存します。FDTは、保存したスクリプ
トをすぐ実行したいかどうかをユーザに尋ねます。

4.2.2 [Log File]ページ
任意のページです。ログファイルが必要でない場合、このフィールドを空白にしておいてください。既存のフ

ァイルを追加したり、上書きすることができます。

図 4-2　[Log File]ページ

Log File Directory
任意のログファイルを作成するディレクトリを入力してください。FDTは、区切り文
字 %U、%M、%D、%Tを使用して、ユーザ名、マシン名、日付、時間など詳細情報をディレクトリパス
へ追加します。

Log File Name
任意のログファイル名を入力してください。FDTは、区切り文字 %U、%M、%D、%Tを使用して、ユー
ザ名、マシン名、日付、時間など詳細情報をファイル名へ追加します。

Save
FDT Script Configurationファイル（デフォルト拡張子：.w4f）を保存します。FDTは、保存したスクリプ
トをすぐ実行したいかどうかをユーザに尋ねます。
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4.2.3 [Status File]ページ
任意のページです。ステータスファイルが必要でない場合、[Enable status output to file]チェックボックスをチ

ェックしないでください。ステータスファイルの内容については、4.7章を参照してください。

図 4-3　[Status File]ページ

Status File Directory
任意のステータスファイルを作成するディレクトリを入力してください。FDTは、区切り文字 %U、%M
を使用して、ユーザ名、マシン名など詳細情報をディレクトリパスへ追加します。

Status File Name
任意のステータスファイル名を入力してください。FDTは、区切り文字 %U、%Mを使用して、ユーザ
名、マシン名、日付、時間など詳細情報をファイル名へ追加します。

Save
FDT Script Configurationファイル（デフォルト拡張子：.w4f）を保存します。FDTは、保存したスクリプ
トをすぐ実行したいかどうかをユーザに尋ねます。

4.2.4  [Error Handling]ページ
任意のページです。

図 4-4　[Error Handling]ページ
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On Script Fail
Abort：エラーが発生したとき、FDTにスクリプト処理を中止させるため、[On Script Fail]ラジオボタン
は、デフォルトの[Abort]に設定しておいてください。

Continue：FDTはエラーの発生を無視し、スクリプト処理を続けます。

Run Script：エラーが発生したとき、FDTに強制的に処理させます。手動で、または[Browse…]ボタンを
使って、On Script Failを実行するスクリプトファイルを入力ボックスに入力することができます。通
常、失敗したスクリプトにはDisconnectコマンド、Alertコマンド、およびAbortコマンドが含まれます。

# エラー発生時に実行するスクリプト処理[例 1]

# デバイスと非接続する
Disconnect

# 出力ウィンドウにメッセージを出力する
Alert output|******************************************************************
Alert output|********** THE CURRENT SCRIPT PROCESSING HAS FAILED **************
Alert output|******************************************************************
Alert output|**   The script which was being processed will now be deleted.  **
Alert output|**   Please reset the board and regenerate the script to retry  **
Alert output|******************************************************************

# スクリプトファイルを削除する
delete $script

# エラー発生時に実行するスクリプト処理[例 2]

# デバイスと非接続する
Disconnect

# 出力ウィンドウにメッセージを出力する
Alert output|******************************************************************
Alert output|********** THE CURRENT SCRIPT PROCESSING HAS FAILED **************
Alert output|******************************************************************
Alert output|**        Wait For Script Processing will now be aborted        **
Alert output|**            To retry, use ‘Tools’, ‘Wait for Script’,         **
Alert output|**      ‘Run configuration...’ and select the configuration     **
Alert output|******************************************************************

# スクリプト処理を中止する
Abort

Save
FDT Script Configurationファイル（デフォルト拡張子：.w4f）を保存します。FDTは、保存したスクリプ
トをすぐ実行したいかどうかをユーザに尋ねます。

4.3 Wait For Script – Edit Configuration…
[Tools]->[Wait For Script]->[Edit Configuration…]メニューから起動します。また、コンフィグレーションファイ

ルの設定を編集できます。
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4.4 Wait For Script – Run Configuration…
[Tools]->[Wait For Script]->[Run Configuration…]メニューから起動します。また、必要なWait For Script

Configurationファイル（.w4f）を参照して選択することができます。これによって、FDTはWait For Scriptモー
ドに入ります。

図 4-5　Wait For Scriptの実行

4.5 Wait For Script – スクリプトコマンド
スクリプトファイルは、FDTが認識する一連のコマンドを 1行ごとに含むテキストファイルと同じです。また、

各コマンドには、同じ行に、関連する一連の引数があります。これらのスクリプトファイルには、デフォルトで、
‘.fsf’拡張子が付きます。

スクリプト行のシンタックスは、「コマンド+スペース+必要な引数（演算子‘|’で区切られます）」です。任意
の特別な引数が後に続き、任意の順に配置されます。

通常、スクリプトファイルは、‘delete $script’コマンドで終了します。これにより、一度処理が終了すると、
FDTはスクリプトを削除し、同じスクリプトファイルを二回以上処理しないようにします。こうして FDTは、
次のスクリプトファイルの検索を開始します。代わりに、moveコマンドを用いて、一度処理した代替ディレク
トリにスクリプトファイルを移動することができます。

各スクリプトコマンドは、テキストファイルの別の行に書く必要があります。それは、FDTが、DOSや UNIX
形式の行ブレーク（CRまたは CR LF）に対応するためです。スクリプトファイル内のファイルパスには、ドラ
イブ文字あるいはネットワークパス（IPアドレスを含む）を入れることができます。
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4.5.1 Workspace
説明：指定したワークスペースを FDTへロードします（注：有効なワークスペースおよび作成したプロジェ

クトを開き、デバイスに関連するコマンドを使用しなければなりません。）

引数：

<Workspace Path> 必須 ワークスペースへのパス

例：
Workspace C:\Workspaces\3069serial\3069serial.AWS

NB：FDTは、このワークスペースからアクティブプロジェクトを使用します。スクリプトからのアクティブ
プロジェクトを変更する機能は、現在ありません。

4.5.2 Connect
説明：デバイスに接続します。

引数：

<PORT> 任意 指定したポートがプロジェクトのポ
ート設定に合っていない場合、コマ
ンドは失敗します。USB直接接続、
FDM接続を行なうためには、“USB”

に設定する必要があります。

“USB”|<USB PID>|<USB BID> 任意 USBを使用している場合、通常の
[Select Device connection]ダイアログボ
ックスをこの設定にすることができ
ます。（FDMを使用している場合、
PIDは‘FDM’に、BIDはFDMのシリア
ル番号に続いて‘SN:’に設定されま
す）

接続はプロジェクトのポート設定でのみ行なわれ、接続に使用するポートを変更する訳ではありません。本コ
マンドでポートを指定すると、プロジェクトがこの設定に合っていない場合は失敗します。また、PID/BIDまた
は FDM、およびシリアル番号を事前に選択して、USBデバイス用の[Select Device connection]ダイアログボック
スを抑止します。

例：
Connect
Connect USB|0x000D|0
Connect USB|FDM|SN: 93506
Connect COM1



4　Wait For Script

45

4.5.3 Download
説明：選択したプロジェクトイメージをデバイスにダウンロードします。

引数：

“image” デバイスイメージをダウンロードしま
す。

<filename>
必須（一方）

名前を付けたファイルをダウンロード
します。

“user” ユーザイメージをダウンロードしま
す。また、ユーザ領域へダウンロード
します。

“userboot” ユーザブートイメージをダウンロード
します。また、ユーザブート領域へダ
ウンロードします。

“both”

必須（一方）

ユーザイメージおよびユーザブートイ
メージをダウンロードします（‘image’

を指定したときのみ有効です）。

“norebuild” 任意 一つまたは複数のイメージが無効であ
っても、ダウンロード前に再ビルドし
ないでください（‘image’を指定したと
きのみ有効です）。

“verify” 任意 ダウンロードが完了すると、リードバ
ック検証を行います。

例：
Download image|user|norebuild|verify
Download C:\files\MySrecord.mot|userboot

4.5.4 Erase
説明：指定したフラッシュブロックをデバイス上で消去します。

引数：

<block num(s)> 消去するブロック番号のリストです。

“device”
必須（一方）

デバイス全体を消去します。

例：
Erase 0|1|4|7
Erase device
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4.5.5 BlankCheck
説明：デバイスが空白かどうかをチェックします。

引数：

“userboot” 任意 フラッシュのユーザブート領域をチェ
ックすることをFDTに伝えます（サポ
ートしている場合）。

“stoponwritten” 任意 デバイスが空白でない場合、スクリプ
トの処理を中止します。

“stoponblank” 任意 デバイスが空白である場合、スクリプ
トの処理を中止します。

例：
BlankCheck
BlankCheck userboot|stoponwritten

4.5.6 Upload
説明：データをデバイスからアップロードします。

引数：

<filename> 必須 アップロードを書き込むファイルで
す。必要な場合、作成されるか、上書
きされます。必要でない場合、‘none’

を指定してください。

<start address> 必須 アップロードを開始する16進数の開始
アドレスです。

<length> 必須 アップロードするバイト数（16進数）
です。

“noabsolute” 任意 絶対イメージをアップロードしないで
ください。

“userboot” 任意 ユーザブート領域からアップロードし
てください（サポートされている場
合）。

例：
upload none|0|0x6000
upload c:\upload\uploadtest.mot|0x100|0x200|userboot|noabsolute
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4.5.7 Checksum
説明：デバイス上でチェックサムを行います。

引数：

“device” 必須 デバイスのチェックサムを行います。

例：
Checksum device

4.5.8 Disconnect
説明：デバイスと非接続にします。FDTが接続されていない場合でも、Disconnectコマンドの発行が可能です。

接続を行なう前に、FDTが非接続状態であることを確認するのに便利です。

引数：

“reset” 任意 非接続の一部として、リセットする
ことをFDTに伝えます。

例：
Disconnect
Disconnect reset

4.5.9 RebuildImage
説明：指定したイメージをプロジェクトのターゲットファイルから再ビルドします。

引数：

“user” ユーザイメージを再ビルドします。

“userboot” ユーザブートイメージを再ビルドしま
す。

“both”

必須（一方）

ユーザイメージおよびユーザブートイ
メージを再ビルドします。

例：
RebuildImage user
RebuildImage both

4.5.10 #Comment
説明：行の初めに挿入し、残りの行にコメントを書きます。

引数：

NONE - -

例：
# これはコメント行です。
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4.5.11 Alert
説明：何かが起こったことをユーザに知らせます。

引数：

“beep” FDTは警告音を発します。

“output”
必須（一方）

FDTは、アクティブプロジェクトタブ
にメッセージを出力します。

例：
Alert output|Please make sure the board is connected

4.5.12 Pause
説明：指定したミリ秒の間、スクリプトファイルの実行を中断します。

引数：

<time> 必須 中断するミリ秒の数

例：
Pause 2000

4.5.13 Delete
説明：スクリプトファイルを削除します。NB：削除する前、FDTは、この行においてスクリプトを処理しま

す。

引数：

“$script” 必須 スクリプトファイルを削除します。

例：
Delete $script

4.5.14 Move \ Copy
説明：スクリプトファイルを移動、コピーします。NB： FDTは、この行においてスクリプトを処理します。

引数：

“$script” 必須 このスクリプトファイルをコピー、
移動、名称変更します。

<filename>

<directory>
必須 ソースファイルがコピー、移動、名

称変更されるファイルまたはディレ
クトリです。

例：
Move $script |\\server\networkfiles\done.txt
Copy $script|C:\backups\
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4.5.15 Abort
説明：スクリプトの処理を中止し、不良を返します。NB：このコマンドは、もとは、エラー処理のスクリプ

トにおいて使用するために設計されています。

引数：

NONE - -

例：
Abort

4.6 Wait For Script – スクリプトファイルの例
FDTのスクリプトファイルがどのようなものか、以下に例を示します。有効なコマンドを強調し、それがどのよ
うに使われるか、ヒントを与えています。

# スクリプトファイルの例(H8S/2215UF)
# ワークスペースおよび関連するプロジェクトを開く
workspace C:\Workspaces\2215usbdirect\2215UsbDirect.AWS

# デバイスと非接続する(前の状態によっては非接続になっていないことも考えられるので)
disconnect

# デバイスと接続する
connect USB|0x000D|0

# フラッシュ ROMが空白かどうかをチェックする
blankcheck

# フラッシュ ROMに Sレコードデータを書き込む
download C:\2215uAuto.mot|user|verify

# フラッシュ ROMのデータを読み込む
upload c:\UPLOADS\upload.mot|0x0|0x1000

# フラッシュ ROMの全ブロックデータを消去する
erase device

# フラッシュ ROMが空白かどうかをチェックする(空白でない場合はスクリプト処理を中止)
blankcheck stoponwritten

# イメージデータをビルド/再ビルドする
RebuildImage user

# フラッシュ ROMにイメージデータを書き込む
download image|user

# フラッシュ ROMのチェックサム計算を行う
checksum device

# 100ミリ秒間、スクリプトファイルの実行を中断する
pause 100

# デバイスと非接続する
disconnect

# 出力ウィンドウにメッセージを表示する
alert output|This text will be displayed in the output window and the log file

# スクリプトファイルを削除する
delete $script
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4.7 Wait For Script – ステータスファイル形式
FDTがWait For Scriptモードに入っている間、リモートユーザは、現在、アプリケーションがどの状態にある

かを知りたいかもしれません。これは、FDTがアクションを行うときに書き込みするステータスファイルがあれ
ば実現できます。ステータスファイルは、外部ユーザが読むことができます。これのオプションを以下に示しま
す。

デフォルトでは、ステータスファイルの書き込みはできません。[Enable]チェックボックスを選択すると、編
集用に Directory、Nameのフィールドが開き、ステータスファイルを作成する場所を指定できるようになります。

[FDT Script Status v1.0] ⇐  コンフィグレーションファイルのバージョン。
CurrentScript = ⇐ 実行中の現在のスクリプトの場所、あるいは、待ち状態で使用されるサー

チパス。
UserID= ⇐  このファイルに FDTの書き込みをコピーしているユーザの名前。
Machine= ⇐  FDTのコピーが実行されているマシンの名前。
LastUpdate= ⇐  このファイルが最後に更新された日時。
CurrentStatus = ⇐  FDTの現在の状態。‘waiting’（FDTがスクリプトを検索している場

合）、‘processing’（FDTがスクリプトを発見し、使用している場合）、
‘error processing’（スクリプトのどこかが間違っている場合）、‘waiting for
user input’（ダイアログボックスが、ユーザの介入を待っている場合）のいず
れかになります。FDTがファイルモードの待ち状態を正常に終了した場合、
このエントリは空白となります。

PreviousScript= ⇐  以前実行したスクリプトの場所。
PreviousState= ⇐  以前実行したスクリプトの結果。‘COMPLETED’あるいは‘FAILED’のいず

れかになります。
JobNo= ⇐  実行が成功して完了した回数。この数は、32,768になると、0に戻ります。

ステータスの書き込みを有効にして、FDTがWait For Fileセッションを開始すると、指定したファイルがある
ことを最初にチェックします。ファイルが見つからなかった場合は作成され、FDTはセッションを継続します。
ファイルが見つかった場合、そのファイルを開いてチェックします。CurrentStatusが空白の場合（以前のセッシ
ョンが正常に終了し、誰もそのファイルを使用していないことを意味します）、FDTはセッションを継続します。
CurrentStatusに入力されている（例えば、‘処理’）場合、FDTはメッセージボックスを利用して、以前のセッシ
ョンが強制終了した可能性があるか、別のコピーを実行中でこのファイルも使用していることをユーザに警告し
ます。オプションによって値を保持、上書きしたり、処理を中止したりします。
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5 アクセス権

5.1 アクセス権の概要
デバイスの書き込みに FDTを使用しているとき（特に、マルチユーザ環境で）、設定を誤って変更してしま

うのを防ぐため、別のユーザが異なるレベルでアクセスするように、アクセス権によって、ユーザ名とパスワー
ドを作成することができます。一般的に、アクセス権には 3つのレベルがあります。

Administratorレベルでは、ユーザアカウントを作成し、変更することができます。

Supervisorレベルでは、プロジェクトの作成および編集ができます。

SIM Userレベルでは、ユーザが、Simple Interface Modeからデバイスイメージを書き込む権利があります。
SIM Userが FDTを使用する前に、スーパーバイザは、プロジェクトを作成する必要があります。

5.2 アクセス権を有効にする
FDTは、指定されたユーザアカウントがデフォルトで提供されていますが、パスワードは設定されていません。

内部の Administratorアカウントのパスワードを設定してアクセス権を有効にするまで、FDTにログインする必要
はありません。これは、[Tools]->[Access Rights]->[Administration…]メニューによって実現します。最初の実行時、
Administratorアカウントのパスワードを入力するように指示されます。

5.3 アクセス権の管理
[Tools]->[Access Rights]->[Administration…]メニューによって実現します。

図 5-1　[User Admin]ダイアログボックス
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5.3.1 Disable All
すべてのユーザアカウントを無効にし、アクセス権パスワードのセキュリティをオフにします。

5.3.2 Modify User
[Modify User]ダイアログボックスを起動し、選択したユーザの設定を変更することができます。

図 5-2　[User Admin]ダイアログボックス

以下のアクセスオプションが有効です。
AccessRights:Admin：ユーザアカウントおよびパスワードを管理することができます。

FDT:Project Edit：FDTプロジェクトを編集することができます。Simple Interface Modeにおいて、[Back to
Project]ボタンを有効にします。

SimpleInterface:Exit：FDTを終了させることができます。Simple Interface Modeにおいて、[Exit]ボタンを有効
にします。

SimpleInterface:Download File：ダウンロードするファイルをユーザが選択できます。Simple Interface Modeの
[Download File]セクションを有効にします。

SimpleInterface:Download Project Image：一つまたは複数のプロジェクトイメージをダウンロードすることが
できます。Simple Interface Modeの[Download Project Image]セクションを有効にします。

5.3.3 Add User
新規ユーザアカウントを作成することができます。FDTはユーザ名とパスワードの入力を促し、[Modify
User]ダイアログボックスを起動します。

5.3.4 Delete User
ユーザアカウントを削除することができます。
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5.3.5 Reset Pwd
選択したユーザのパスワードを設定することができます。

5.3.6 Close
[User Admin]ダイアログボックスを閉じます。
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6 ユーザインタフェースの設定

FDTユーザインタフェースは、頻繁に行う操作にすばやくアクセスできるように、関連のある操作を論理的に
グループ分けしています。しかし、ユーザインタフェース項目の配置をユーザが作業しやすいように、変更した
い場合もあります。このため、ユーザインタフェースはカスタマイズできます。本章では、ユーザインタフェー
スの配置の変更と表示形式のカスタマイズについて説明します。

6.1 ウィンドウの配置

6.1.1 ウィンドウの最小化
エディタウィンドウ上で開いたウィンドウを終了する際、あとから現在の状態でもう一度表示したい場
合は、そのウィンドウをアイコン化することができます。つまり、ウィンドウの最小化ができます。ウ
ィンドウを最小化するには、ウィンドウの‘最小化’ボタンをクリックしてください。

ウィンドウが最小化され、エディタウィンドウの下部にアイコンとして表示されます。

注注注注 画面の下部に開いているウィンドウがあると、このアイコンが見えない場合があります。

アイコンをウィンドウに復元するには、アイコンをダブルクリックするか、一度クリックしてアイコン
のメニューを表示してから[元のサイズに戻す元のサイズに戻す元のサイズに戻す元のサイズに戻す]を選択するか、メニューバーの[Window]ドロップダウン
メニューから該当するウィンドウを選択します。

6.1.2 ウィンドウの整列
画面上に多くのウィンドウが開いている場合があります。Tile Windowsオプションを使用すれば、どの
ウィンドウも他のウィンドウと重ならないように、タイルフォーマットですべてのウィンドウを配置す
ることができます。これを行うには、[Window->Tile Horizontally]または[Window->Tile Vertically]メニ
ューオプションを選択します。

現在開いているすべてのウィンドウが、タイルフォーマットで配置されます。最小化されアイコンとな
っているウィンドウは影響を受けません。

6.1.3 ウィンドウのカスケード
Tile Windowsオプションを使用して、開いているウィンドウをカスケード状態に配置することができま
す。これを行うには、[Window->Cascade]メニューオプションを選択します。

6.2 現在開いているウィンドウの検索
FDTアプリケーションの中に多くのウィンドウが開いていると、他のウィンドウの後ろにウィンドウが隠れて

しまうことがあります。

6.2.1 特定のウィンドウを見つけるには
隠れてしまったウィンドウを見つけるには、2 つの方法があります。

1. 特定のウィンドウを選択するには、[Window]メニューを選び、メニューの一番下にある開いているウィ
ンドウのリストの中から、必要なウィンドウをクリックします。ウィンドウリストでは、現在選択されて
いるウィンドウの横にチェックマークが付いています。
選択したウィンドウが画面の手前に表示されます。そのウィンドウが最小化されている場合は、アイコン
がウィンドウに復元されます。

2. エディタウィンドウの下部にある、ファイルネームを含んだタブをクリックして、特定のウィンドウを選
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択することもできます。ウィンドウが最小化されていない場合、選択したウィンドウが画面の手前に表示
されます。最小化されている場合は、そのアイコンが画面の手前に表示されます。

6.3 ツールバーの表示／非表示
ツールバーの表示／非表示を選択できます。デフォルトでは、FDTアプリケーションウィンドウの上部にツー

ルバーを表示します。

ツールバーを表示、非表示にするには、[Tools->Customise] メニューオプションを使用するか、ツールバー領
域を右クリックしてください。

6.4 ワークスペースウィンドウの表示／非表示
ワークスペースの表示／非表示を選択できます。デフォルトでは、ワークスペースを表示します。ワークスペ

ースを非表示にするには、[View->Workspace]メニューオプションを選択します。

非表示オプションを選択すると、ワークスペースが、FDTアプリケーションウィンドウの表示から削除されま
す。ワークスペースを再表示するには、再度、[View->Workspace]メニューオプションを選択します。ワークス
ペースが、FDTアプリケーションウィンドウの表示に追加され、メニューオプションが選択されます。

6.5 出力ウィンドウの表示／非表示
出力ウィンドウの表示／非表示を選択できます。デフォルトでは、出力ウィンドウを表示します。出力ウィン

ドウを非表示にするには、[View-> Output]メニューオプションを選択します。

非表示オプションを選択すると、出力ウィンドウが非表示となり、FDTアプリケーションウィンドウの表示か
ら削除されます。出力ウィンドウを再表示するには、再度、[View-> Output]メニューオプションを選択します。
出力ウィンドウが、FDTアプリケーションウィンドウの表示に追加され、メニューオプションが選択されます。
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6.6 ツールバーのカスタマイズ
ツールバーに表示されるボタンの種類と配列を、ユーザの好みにカスタマイズすることができます。表示を変

更するには、[Tools->Customise…]メニューオプションを選択します。デフォルトでは、Editor、Search、FDT、S-
Recordのツールバーが表示されています。S-Recordツールバーオプションが有効なのは、データファイルが開い
ているときのみであることに注意してください。

‘Customise’ダイアログボックスが開きます。

図 6-1　FDTのカスタマイズ

‘Customise’ダイアログボックスには多くのタブがあります。それぞれのタブについては、第8章「ウィンド
ウ」で詳しく説明します。

6.6.1 Toolbarsタブ
Toolbarsタブでは、表示させるツールバーを選択できます。デフォルトでは、Editor、Search、FDTのツ
ールバーのみが表示されています。

‘New…’ボタンをクリックすると、‘Toolbar Name’ダイアログボックスが開きます。このダイアログボッ
クスで、ユーザが新しいツールバーを作ることができます。新しい名前を入力して‘OK’をクリックする
と、‘Toolbars’リストに新しい名前が追加され、画面に空のツールバーが表示されます。

Commandsタブを選択すると、新しいツールバーにボタンを追加できます。新しいツールバーは、マウス
でドラッグして、GUI上の好きな場所に置くことができます。

‘Toolbars’リストで、ユーザが作成したツールバーを選択すると、‘Reset’ボタンが‘Delete’ボタンに変わり
ます。‘Delete’ボタンをクリックすると、新しいツールバーがリストとGUIの両方から消えます。

‘Reset’ボタンをクリックすると、選択したツールバーをデフォルトの設定にリセットします。
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6.6.2 Commandsタブ
このタブでは、グループごとにボタンとその機能を表示し、ユーザがアプリケーションごとにツールバ
ーをカスタマイズできるようにします。

‘Categories’ボックスから項目を選んでクリックすると、そのカテゴリに属するボタンを表示します。

‘Buttons’の枠内には、選択したカテゴリに属するボタンの絵を表示します。

各ボタンをクリックすると、ボタンの動作についての説明を‘Description’の枠内に表示します。

ツールバーへのボタンの追加
 ツールバーにボタンを追加するには

1. 該当するカテゴリから、追加したいボタンを選び、マウスの左ボタンを押します。
2. ツールバー上の好きな場所までボタンをドラッグします。
3. マウスボタンを離します。

ツールバーのボタンの位置変更
 ツールバーのボタン位置を変更するには

1. ツールバー上の、位置を変更したいボタンを選択します。
2. ツールバー上の好きな場所までボタンをドラッグします。
3. マウスボタンを離します。

ツールバーからのボタンの削除
 ツールバーからボタンを削除するには

1. ボタンをマウスで選択します。
2. ‘Customise’ダイアログボックスまでボタンをドラッグします。
3. マウスボタンを離します。
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7 メニュー

このマニュアルでは、標準的なMicrosoftメニュー命名規約を使用しています。

図 7-1　FDTメニュー

7.1 Fileメニュー
‘File’メニューは、データファイルにアクセスする場合に用います。

7.1.1 Close
エディタウィンドウの現在のファイルを閉じます。

7.1.2 New Workspace…
 ‘New Workspace’ダイアログボックスを開きます。このダイアログボックスで、新しいワークスペースの
名前と場所を指定し、新しいワークスペースディレクトリを作ることができます。

7.1.3 Open Workspace…
 ‘Open’ダイアログボックスを開きます。このダイアログボックスで、既存のFDTワークスペースファイ
ル（.aws）を開くことができます。

7.1.4 Save Workspace
現在のアクティブワークスペースの情報を保存します。

7.1.5 Close Workspace
現在のアクティブワークスペースを閉じます。

7.1.6 Open an S-Record…
‘Open an S-Record’ダイアログボックスを開きます。このダイアログボックスで、既存のファイルを開く
ことができます。開くことができるのは、Sレコードファイル（.rec、.mot、.a20、.a37）、デバイスイメ
ージファイル（.fpr）、バイナリファイル（.bin、.cde）です。

カスケードメニュー

ショートカットキー

省略記号

ドロップダウン
メニュー

メニューオプション

メニューバー メニュー
タイトル
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7.1.7 Save
現在のアクティブファイルを保存します。

7.1.8 Save As…
‘Save As’ダイアログボックスを開きます。このダイアログボックスで、現在開いているファイルを保存
し、名前をつけることができます。

7.1.9 Exit
FDTアプリケーションを閉じて終了します。

7.2 Editメニュー
‘Edit’メニューは、エディタウィンドウのデータをアクセスしたり変更したりする場合に用います。

7.2.1 Undo
直前の編集操作を取り消し、元に戻します。

7.2.2 Redo
直前のUndo操作を取り消します。

7.2.3 Cut
反転表示しているブロックの内容をウィンドウから削除し、クリップボードに格納します（Windows 標
準の方法）。ブロックが反転表示されている場合にのみ使用できます。

7.2.4 Copy
反転表示しているブロックの内容をクリップボードにコピーします（Windows 標準の方法）。ブロック
が反転表示されている場合にのみ使用できます。

7.2.5 Paste
Windows のクリップボードの内容を子ウィンドウの現在のカーソル位置にコピーします。

7.2.6 Select All
エディタウィンドウのアクティブファイルの情報をすべて選択します。

7.2.7 Find…
‘Find’ダイアログボックスを開きます。このダイアログボックスで、16進数またはASCIIデータを入力で
きます。検索範囲は、エディタウィンドウのアクティブファイル内の選択領域です。一致するデータを
見つけると、エディタウィンドウを更新し、一致したデータが表示されるようにします。

7.2.8 Find In Files…
アクティブファイルの外にあるファイルにデータを配置するダイアログボックスを開きます。

7.2.9 Replace…
‘Replace’ダイアログボックスを開きます。このダイアログボックスで、検索したい16進数またはASCIIデ
ータを入力できます。また、置換するデータも同じフォーマットで入力できます。検索範囲は、エディ
タウィンドウのアクティブファイル内の選択領域です。一致するデータを見つけると、エディタウィン
ドウを更新し、一致したデータが表示されるようにします。Replaceボタンが有効になるので、これをク
リックすると、データが置換されます。
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7.3 Viewメニュー
‘View’メニューは、ワークスペースウィンドウ、出力ウィンドウなど、FDT GUIの特長を表示、削除する場合

に用います。

7.3.1 Workspace
ワークスペースウィンドウを再表示します。

7.3.2 Output
出力ウィンドウを再表示します。

7.4 Projectメニュー
‘Project’メニューには、ワークスペース内のプロジェクトを高度に管理する機能があります。

7.4.1 Set Current Project
ワークスペースに複数のプロジェクトがあるアクティブプロジェクトを選択します。

7.4.2 Insert Project…
新規プロジェクトを作成し、ワークスペースへ追加します。

7.4.3 Add Files…
‘Open’ダイアログボックスを開きます。このダイアログボックスで、プロジェクトにデータファイルを
追加できます。

7.4.4 Remove Files…
選択したファイルをプロジェクトから削除します。

7.4.5 File Extensions…
FDTに認識させるファイル拡張子を選択し、これらの拡張子をどのように扱うか設定することができま
す。

図 7-2　File Extensionsダイアログボックス
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File Extensions Add…
‘Add…’を選択すると、FDTは新しい種類の拡張子を扱えるようになります。

図 7-3　Add File Extensionダイアログボックス

File Extensions Modify…
‘Modify…’を選択すると、この種類の拡張子を持つファイルをFDTがどのように扱うか、選択することが
できます。

図 7-4　Modify File Extensionダイアログボックス
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7.4.6 Rebuild Image
イメージを再ビルドすることにより、プロジェクトに含まれない、選択したフラッシュ領域のすべての
ファイルをマージします。デフォルトのROM領域はUser Areaですが、いくつかのデバイスにもUser Boot
Areaがあります。コンポーネントファイルがオーバラップした場合、FDTは警告を出します。書き込み
をしたいデータが別のコンポーネントファイルで構成される場合（特に異なるファイルのデータが同じ
消去ブロックに存在する場合）、イメージのビルドは効果的です。それは、自動保護を使用している場
合、各コンポーネントファイルを別々にダウンロードすると、二度目のダウンロードをする前にデバイ
スがブロックを消去することになるためです。

User User Areaにイメージをビルド/再ビルドします。
User Boot User Boot Areaにイメージをビルド/再ビルドします。
Both User Areaおよび User Boot Areaにイメージをビルド/再ビルドします。

7.4.7 Download Image
User User Areaにイメージをダウンロードします。
User Boot User Boot Areaにイメージをダウンロードします。
Both User Areaおよび User Boot Areaにイメージをダウンロードします。

7.5 Toolsメニュー
‘Tools’メニューには、個々のプロジェクトやターゲットデバイスに関係しない FDT機能があります。

7.5.1 Administration…
異なるカテゴリにおいて、ユーザが利用できるツールのあるダイアログボックスを表示します。

7.5.2 Customise…
FDTをカスタマイズします。詳細については、8.10章「Customise - Toolbars」を参照してください。

7.5.3 Options…
追加機能へアクセスできます。このうちいくつかは、将来強化するために予約されています。Workspace
タブは、最も使いやすいタブです。最後に使用したワークスペースを起動時に開くかどうか、ワークス
ペースやセッションを保存する前に設定するか、デフォルトディレクトリを新規ワークスペースに設定
するか、などのオプションをユーザが指定できます。

7.5.4 Format Views…
別のウィンドウの外観を変更します。

7.5.5 Simple Interface…
FDTの外観を単純化します。詳細については、8.17章を参照してください。

7.5.6 Wait For Script
Wait For Scriptコンフィグレーションを作成、編集、実行することができます。詳細については、4章を参

照してください。

7.5.7 Access Rights

Access Rights – Login…
FDTにログインしているユーザを切り替えることができます。ショートカットキーCtrl + Shift + Uでも、
ログインダイアログボックスを起動できます。詳細は、5章を参照してください。

Access Rights – Change Password…
現在ログインしているユーザは、パスワードを変更することができます。詳細は、5章を参照してくださ
い。
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Access Rights – Administration…
FDTへのアクセスを制限するためのユーザ名およびパスワードを設定することができます。詳細は、5章
を参照してください。

7.6 Windowメニュー
‘Window’メニューは、現在開いている FDT GUIのウィンドウ表示を変更する場合に使用します。以下のメニ

ューオプションのほかに、現在エディタウィンドウに表示されているファイル名のリストも表示されます。現在
のアクティブファイルには、チェックマークが付きます。

7.6.1 Cascade
各ファイルが見えるように、複数のウィンドウをずらして表示します。

7.6.2 Tile Horizontally
ウィンドウを、最大限可能な幅で表示します。

7.6.3 Tile Vertically
ウィンドウを、最大限可能な高さで表示します。

7.6.4 Arrange Icons
画面の下部で、ファイルアイコンを並べます。

7.6.5 Close All
エディタウィンドウに開いているファイルを閉じます。

7.6.6 ‘ファイル名’
ファイル名を選択してチェックマークを付けると、アクティブになります。

7.7 Deviceメニュー
‘Device’メニューには、ターゲットデバイスと FDTのやりとりを管理する機能があります。

7.7.1 Connect to Device
GUIがデバイスと接続されていない場合は、これを接続します。接続されると、出力ウィンドウにメッ
セージを表示します。

7.7.2 Disconnect
GUIがデバイスと接続されている場合は、これを切断します。接続できない場合は、出力ウィンドウに
メッセージを表示します。

7.7.3 Erase FLASH blocks
‘Erase Blocks’ダイアログボックスを開きます。

このダイアログボックスで、消去するブロックを指定できます。Writtenの欄は、対応するブロックにデ
ータがあるかどうかを示します。

消去するには、リストから消去したいブロック名を選択し、次にEraseボタンをクリックします。

7.7.4 Blank check
フラッシュデバイスの空白チェックを行ない、結果を出力ウィンドウに表示します。
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7.7.5 Upload Image
‘Upload Image’ダイアログボックスを開きます。このダイアログボックスで、データをターゲットデバイ
スからアップロードできます。フラッシュメモリへのアクセス用の機能です。データはエディタウィン
ドウに表示されます。

7.7.6 Download Active File
現在のアクティブファイルをターゲットのフラッシュメモリにダウンロードします。

7.7.7 FLASH Checksum
フラッシュデバイスのチェックサム計算を行い、結果を出力ウィンドウに表示します。これは、フラッ
シュの範囲内でバイト値を単純に32ビット加算したEPROMチェックサムで、0xFFデータを次のEPROM
サイズ（例：64kビット、128kビットなど）に埋めます。

7.7.8 Go From Address…
ダイアログボックスを起動し、プログラムを実行するアドレスを選択します。間接アドレスモードを選
択するオプションがあるため、参照先のアドレスは、プログラムを実行する場所のアドレスそのものと
なります。

7.7.9 Flash Area for non write operations 8 User Area/User Boot Area
このカスケードメニューは、FDTツールバー上のドロップダウンボックスと同様、書き込みをしないフ
ラッシュ領域を選択する場合に使われます。相互に排他的なオプションは、User AreaとUser Boot Area
です。User Boot Areaを持たないデバイスには、User Areaオプションのみ存在します。User Boot Areaを
チェック(有効に)することでFDTは、Upload、Blank Check、Checksumの操作をデフォルトにします。
Boot Modeで最初に接続している間、User Boot Areaは消去されることに注意してください。一度FDTと
接続すると、User Boot Areaを消去することはできません。User Area、User Boot Areaの詳細について
は、3.2章を参照してください。

7.7.10 Cancel Operation
実行中のフラッシュ操作をキャンセルします。

7.7.11 Configure Flash Project
Flash Propertiesウィンドウの表示/非表示を切り替えます。

7.8 Helpメニュー
‘Help’メニューは、FDTの操作方法を表示します。

7.8.1 Help Topics
FDTのヘルプ機能を起動します。FDTの‘Help Topics’ダイアログボックスが開き、FDTの各項目について
のヘルプを参照することができます。

7.8.2 Technical Support
FDTの問題の報告、または、最新のアップデート用にウェブサイトのチェックができます。

7.8.3 About…
‘About FLASH Development Toolkit’ダイアログボックスが開き、以下のようなFDT情報を参照できます。
•  FDTのバージョン
•  著作権情報
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8 ウィンドウ

本章では、各ウィンドウの種類と、それぞれがサポートしている機能、および関連ポップアップメニューによ
り使用できるオプションについて説明します。

FDTには、ワークスペースウィンドウ、エディタウィンドウ、出力ウィンドウの３つのメインウィンドウがあ
ります。

ウィンドウには、ローカルポップアップメニューがあり、よく使う機能が簡単にアクセスできるようになって
います。ウィンドウ上でマウスの右ボタンをクリックするか、SHIFT+F10キーを押すと、ポップアップメニュ
ーが開くので、必要なメニューオプションを選択します。

ウィンドウは、メインメニューオプションから開くこともできます。

8.1 ワークスペースウィンドウ
ワークスペースウィンドウは、ワークスペースの内容を表示します。表示する項目は、ワークスペース名、ワ

ークスペースに含まれるプロジェクト、各プロジェクトのデバイスイメージファイルとターゲットファイルです。

8.1.1 ワークスペース
ウィンドウの最上部に、ワークスペースを表示します。次の例では、Workspace ‘Industrial Controller’がワーク

スペースです。

図 8-1　ワークスペースウィンドウ

ワークスペースウィンドウのポップアップメニューからメニューオプションを選択すると、選択した機能のウ
ィンドウが開きます。

ワークスペースウィンドウ用のポップアップメニューには、以下のメニューオプションがあります。

Insert Project…
本ダイアログボックスを開くと、プロジェクトをワークスペースに追加できます。

Allow Docking
このオプションを選択すると、ウィンドウをドッキングするか、メインウィンドウの周囲に表示するか
を選択できます。

Hide
Hideを選択すると、ワークスペースウィンドウを隠します。[View->Workspace]を選択すると、ワーク
スペースウィンドウを再び表示します。
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Properties
ファイルパスを含むワークスペースの情報を表示します。

図 8-2　ワークスペースプロパティ

8.1.2 プロジェクト
ワークスペースの下に、プロジェクトが表示されます。次の例では、ワークスペースは’Industrial Controller’と

呼ばれ、2つのプロジェクトがあります。1つは、同じように’Industrial Controller’、もう 1つは’User Mode
Reprogramming’と呼ばれます。

図 8-3　ワークスペースプロジェクト

ワークスペースのポップアップメニューである Allow Docking、Hideメニューのほかに、プロジェクト用のポ
ップアップメニューには、以下のオプションがあります。
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Add Files…
‘Open’ダイアログボックスを開きます。ここで、Sレコードファイルをプロジェクトに追加できます。

Remove Files…
ダイアログボックスを開き、削除するファイルを選択します。

Add Folder…
フォルダをプロジェクトに追加します。

Allow Docking
8.1.1章を参照してください。

Hide
8.1.1章を参照してください。

Properties
Project Propertiesダイアログボックスを表示します。これは、FDTツールバーまたはデバイスメニューか
らConfigure Flash Projectを選択することによって開くFlash Propertiesダイアログボックスとは異なること
に注意してください。

Set as current Project
反転表示しているプロジェクトを現在のアクティブプロジェクトとして設定します。反転表示している
プロジェクトがすでにアクティブプロジェクトの場合、本オプションは使用できません。

Remove Project
反転表示されたプロジェクトをワークスペースから削除します。反転表示しているプロジェクトがアク
ティブプロジェクトの場合、本オプションは使用できません。

Unload Project
反転表示されたプロジェクトをワークスペースからアンロードします。反転表示しているプロジェクト
がアクティブプロジェクトの場合、本オプションは使用できません。プロジェクトがアンロードされる
と、最後に保存してから行った変更は保存されないことに注意してください（FDTは、アップロード前
の変更を保存しようとしません）。

Add Files From Kernel Dir…
現在のカーネルディレクトリからファイルを選択し、現在のプロジェクトに追加します。

8.1.3 Device Image - フォルダ
このフォルダには、プロジェクトのデバイスイメージファイルが格納されています。User Areaデバイスイメ

ージはプロジェクトと同じように呼ばれますが、拡張子.fprが付きます。User Boot Areaデバイスイメージはプロ
ジェクトと同じように呼ばれますが、’UserBoot.fpr’が付きます。

図 8-4　デバイスイメージフォルダ

ワークスペースのポップアップメニューである Allow Docking、Hideメニューのほかに、デバイスイメージの
サブフォルダのポップアップメニューには、以下のオプションがあります。

Remove Folder
フォルダを削除します。
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Rename Folder
フォルダの名前を更新します。

8.2 Device File
デバイスファイルは、デバイスへフラッシュ書き込みするデータを含むオプションです。

図 8-5　デバイスファイル

デバイスファイル用のポップアップメニューには、以下のオプションがあります。

8.2.1 Open ‘ファイル名’
選択したファイルを開きます。

8.2.2 Add Files…
追加ファイルをプロジェクトに追加します。

8.2.3 Remove Files…
ファイルをプロジェクトから削除します。

8.2.4 Allow Docking
ワークスペースウィンドウをドッキングまたはフローティングします。

8.2.5 Hide
ワークスペースウィンドウを隠します。

8.2.6 Properties…
‘Device File Properties’ダイアログボックスを開きます。

8.2.7 Display Block usage…
‘S-Record Properties’ダイアログボックスを開きます。このダイアログボックスには、Block usageタブが
表示されます。
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8.2.8 Exclude ‘ファイル名’
ファイルをエクスクルードする場合、Rebuild Imageが選択されていると、イメージのビルドには使用し
ません。マウスの右ボタンを使用して、一度エクスクルードとして選択すると、“’ファイル名’をイン
クルードする”ことができます。

8.2.9 User Boot Area File
このオプションを選択する（チェックする）と、User Boot Area用として使用します。チェックされてい
ない場合、User Areaがデフォルトになります。

8.2.10 Download File to [User Area]/[User Boot Area]
選択したファイルを、デバイスのフラッシュメモリにダウンロードします。使用するフラッシュ領域
は、ファイルがUser Boot Areaファイル用であるかどうかによって決定します。

8.2.11 File Checksum
ファイルチェックサムは、カーネル（EPROMスタイル）のアルゴリズムを使用して、ファイルのチェッ
クサム、およびローチェックサムを返します。ローチェックサムは、フラッシュの範囲内でバイト値を
単純に32ビット加算したものです。EPROMのチェックサムでは、チェックサムを計算する前に、0xFFデ
ータを次のEPROMサイズ（例：64kビット、128kビットなど）に埋めます。結果は、出力ウィンドウに
表示されます。
以下に例を示します。

File Checksum:  0x007F8000 (EPROM style),
Raw Checksum:  0x00000000 (over address range 0x00000000 - 0x00017FFF)

* 計算方法
例：デバイスの ROMサイズが 96kBの場合
(1)”File Checksum”は、128kBのサム値(96kB以降を 0xFFで計算)
(2)”Raw Checksum”は、96kBのサム値(データのない領域は 0xFFで計算)

8.2.12 Compare Flie->Device Checksum
選択したファイルのチェックサムをデバイスのチェックサムと比較します。出力ウィンドウでは、ファ
イル、およびデバイスのチェックサム結果を表示します。これにより、双方の結果が同じであることを
確認できます。
以下に例を示します。

Calculating device checksum
Flash Checksum: 0x007F8000 (User Area)
File Checksum:  0x007F8000 (EPROM style),
Raw Checksum:  0x00000000 (over address range 0x00000000 - 0x00017FFF)

* 計算方法
8.2.11章を参照(“Flash Checksum”の計算方法は”File Checksum”と同じ)



8　ウィンドウ

72

8.3 Workspace properties
ワークスペース用のポップアップメニューオプション Properties…から呼び出します。「Properties」の章も参

照してください。
‘Workspace Properties’ダイアログボックスは、以下の情報を表示します。

•  ワークスペース名
•  ワークスペースのファイル名とパス
•  ワークスペースを最後に保存した日付と時間

図 8-6　Workspace Properties

8.4 Project Properties
プロジェクトのポップアップメニューProperties…により呼び出します。’Properties’ダイアログボックスは、以

下の情報を表示します。
•  プロジェクト名
•  プロジェクトファイルの場所とファイル名
•  最後に修正した日付と時間

図 8-7　Project Properties
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8.5 Configure Flash Project (Flash Properties)
‘Configure Flash Project’ダイアログボックスは、Configure Flash Projectツールバーボタンあるいはデバイスメ

ニューより呼び出します。これは、デフォルトでは FDTウィンドウの下部にドッキングされていますが、他の
場所にドッキングしたり、フローティングするためにドラッグが可能です。非意図的なドッキングをしないため
に、ドラッグ中は Ctrlキーを押してください。

8.5.1 Kernelタブ
このタブには、カーネルパス、周波数、プロトコル、クロック逓倍比、クロックモードが表示されま
す。非接続時にこれらのエントリをダブルクリックすると、画面上のProject Wizardを呼び出します。

図 8-8　Kernel Properties

Kernel Path
カーネルのパスが表示されます。

Frequency
入力クロックが表示されます。

Protocol
通信プロトコルの種別（B：0.35μmデバイス、C：0.18μmデバイス）が表示されます。

CKM
入力クロックに対するシステムクロック（マスタクロック）の逓倍比が表示されます。

CKP
入力クロックに対する周辺クロックの逓倍比が表示されます。

Clock Mode
クロックモードが表示されます。
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8.5.2 Communicationsタブ
このタブには、デフォルトの転送速度と現在の転送速度、現在のポートが表示されます。また、非接続
時に、ここでポートと転送速度を変更することもできます。

図 8-9　Communications Properties

Port
デバイスとの接続で使用するCOMポートのリストが表示されます。USBポートオプションも含まれま
す。

Baud Rate
現在選択している転送速度が表示されます。ダブルクリックすると、このオプションを編集できるプロ
ジェクトウィザードが起動します。

Default Baud Rate
デフォルトの転送速度が表示されます。

Use Default Baud
デフォルトの転送速度を使用します。（ルネサス評価ボードまたは評価開発キットを使用するときのみ
設定します。）

FDM Pins [FDM only]
リセット時の接続、非接続用に、FDM制御モード端子の向きと状態を表示します。
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8.5.3 Deviceタブ
このタブには、デバイスに関する情報が表示されます。ここで、接続モード（BOOT ModeまたはUSER
Program Mode）とインタフェース（‘Direct Connection’固定）も選択できます。また、ターゲットデバイ
スにすでにカーネルがあるかどうかも指定できます。

図 8-10　Device Properties

Device
アクティブデバイスの名前を表示します。ダブルクリックすると、このオプションを編集できるプロジ
ェクトウィザードを起動します。

RAM Size, FLASH Size, Flash Start
表示のみで編集はできません。

Connection
BOOT Mode：オンボード書き込みのBOOTモードシーケンスを開始します。このモードでは、フラッシ
ュメモリをすべて消去し、カーネルをロードします。

USER (Program) Mode ：オンボード書き込みのUSER Programモードシーケンスを開始します。このモー
ドでは、以前ロードされたユーザプログラムを用いて、フラッシュメモリに再書き込みします。

Interface
ターゲットがホストコンピュータと直接接続されている場合、接続インタフェースは、’Direct
Connection’のみとなります。代替オプションにはFDMがあり、Protocol A (legacy)カーネルには、UPBが
あります。ダブルクリックすると、このオプションを編集できるプロジェクトウィザードを起動しま
す。

Kernel Resident
FDTと接続する前に、ターゲットデバイスに既にメインカーネルが存在していることを指定します。ダ
ブルクリックすると、このオプションを編集できるプロジェクトウィザードを起動します。

User Boot Area
非書き込み操作をUser Boot Area上で行うかどうかを指定します。ダブルクリックすると、’はいはいはいはい’と’いいいいいいいい
ええええ’を切り替えます。User Boot Areaを持たないデバイスでは、このオプションはN/Aに設定されます。

Available RAM, Free RAM
表示のみで編集はできません。

Buffer Size
フラッシュメモリへの１回の書き込みサイズが表示されます。

Device ID
通信プロトコルＢ，Ｃでは使われません。



8　ウィンドウ

76

8.5.4 Programmerタブ
このタブには、機能マップの状態が表示されます。また、デバイス保護オプション（Automatic、
Interactive、None）とメッセージレベルオプション（Advanced、Standard）を選択できます。

図 8-11　Programmer Properties

Device Protection
フラッシュメモリの誤消去・誤書き込みを防ぐものとして、自動消去（Automatic）または確認消去
（Interactive）を選択できます。自動消去では、必要に応じて、書き込みの前にブロックを消去します。
確認消去では、消去の前にユーザに確認を行います。
また、選択技にはもう１つ、無効（None）があります。これは、デバイス保護を無効とします。ダブル
クリックすると、設定を編集できます。

デバイスに接続されている間、FDTは常にフラッシュメモリのブロックの状況を記録し、どの時点でフ
ラッシュメモリに書き込まれたのかがわかるようになっています。

注注注注 デバイス保護を無効にした場合、書き込み前の消去は、ユーザが自分で行なわなくてはなりません。

Message level
メッセージレベルとして、標準（Standard）または高度（Advanced）を選択できます。標準メッセージレ
ベルでは、上位通信に関する、汎用のFDTおよびターゲットデバイス状態のメッセージを表示します。
高度メッセージレベルでは、下位通信に関する、より詳細な情報を表示します。ダブルクリックする
と、設定を編集できます。

Readback Verification
プログラミング後、FDTは、リードバック検証を行うことにより、データの書き込みが成功したことを
検証できます。確認後、常にリードバック検証を行うか否かを決めるときに、このオプションを使用し
てください。ダブルクリックすると、設定を編集できます。
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Reset on Disconnect
FDTをデバイスから取り外し、UPBやFDMと組み合わせて使用すると、ターゲットハードウェアをリセ
ットすることができます。確認後、常にデバイスをリセットするか否かを決めるときに、このオプショ
ンを使用してください。ダブルクリックすると、設定を編集できます。

Connection Reset
User ModeでFDMと接続しているとき、FDTがモード端子を設定し、リセットするかどうかを制御しま
す。以下にオプションを示します。

Default – デフォルト設定（Set Reset & Mode Pins）を使用します。レジストリ設定のまま保持されます。

Reset & Mode – リセットを行い、モード端子を設定します。

Mode Only – リセットを抑止しますが、モード端子を設定します。このことがデバイスにダメージを与え
ず、予期しない動作が起こらないことを保証しなければなりません。本オプションは、主に、User Mode
とUser Program Modeの間で遷移をするときに使用されます。

None – リセット、およびモード端子の設定を抑止します。

Reinterrogate on Disconnect
FDTは、汎用ブートデバイスが接続されていることを強制的に再確認します。このオプションで”No”
（デフォルト）に設定されていると、デバイスの設定内容は、自動的に生成されたfcfファイルに保存さ
れ、再度使用されます。”Yes”に設定されていると、FDTは、接続の詳細を常にデバイスに再確認しま
す。これにより、1つのプロジェクトが複数の汎用ブートデバイスとともに動作することができます。オ
プションが”Query”に設定されていると、FDTは、デバイスに再確認するかどうかを選択するようにユー
ザに要求します。ダブルクリックすると、設定を編集できます。

Function Map
Protocol A (Legacy)のみに使われます。

8.5.5 Modulesタブ
このタブには、カーネルのファイル名が表示されます。カーネルのほとんどはモジュールすべてを使用
しないため、いくつかのエントリは空白の場合があります。

図 8-12　Module Properties
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8.6 S-Record Propertiesウィンドウ
16進数エディタウィンドウで開いているファイルが選択されると、Propertiesツールバーボタンをクリックす

るか、Propertiesメニューを右クリックすることによってこのダイアログボックスを呼び出します。

8.6.1 Block Usageタブ
このタブには、アクティブファイル内のデータブロックについて、開始アドレス、終了アドレス、ブロ
ックサイズが表示されます。ファイルをエディタウィンドウで開く場合、範囲をダブルクリックする
と、選択したデータを強調表示します。

図 8-13　S Record Properties – Block Usage

8.6.2 Cursor Valueタブ
このタブでは、カーソル位置のデータを何通りかに表示します。表示単位がByte、Word、Dwordのどれ
であるかによって、表示が変わります。例えば、カーソルがDwordにある場合、表示単位サイズのデー
タ配列を仮定しているため、同じ値が表示されます。

図 8-14　S Record Properties – Cursor Value
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8.6.3 Selection Valueタブ
このタブでは、現在選択しているデータを何通りかに表示します。Byte、Word、Dwordのどれを選択し
たかによって、表示が変わります。

図 8-15　S Record Properties – Selection Value

8.7 出力ウィンドウ
出力ウィンドウは、FDT GUIのメインウィンドウの１つです。

図 8-16　出力ウィンドウ

出力ウィンドウではポップアップメニューが使用でき、以下のオプションを選択できます。

8.7.1 Clear Window
アウトプットウィンドウをクリアします。

8.7.2 Allow Docking
このオプションを選択してチェックマークを付けると、出力ウィンドウを、FDTアプリケーションウィ
ンドウの中に固定（ドッキング）することができます。チェックマークをはずすと、出力ウィンドウの
位置を自由に動かすことができます。

8.7.3 Hide
Hideを選択すると、出力ウィンドウを隠します。[View->Output]を選択すると、出力ウィンドウを再び
表示します。
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8.8 16進数エディタウィンドウ
16進数エディタウィンドウは、FDT GUIのメインウィンドウの１つです。開いたファイルを閉じるには、そ

のファイルの右上の角にある X印をクリックしてください。ファイルが保存されていない場合、FDTはユーザに、
開いたファイルを保存するかどうか尋ねます（ただし、Shiftキーを押しながら X印をクリックした場合を除
く）。ファイルを保存して閉じた後、現在のプロジェクトにこのファイルが含まれていない場合は、FDTはユー
ザにこのファイルを追加するかどうか尋ねます。

図 8-17　16進数エディタウィンドウ

16進数エディタウィンドウでは、ポップアップメニューが使用でき、以下のオプションを選択できます。

8.8.1 Cut
反転表示しているブロックの内容をウィンドウから削除し、クリップボードに格納します（Windows 標
準の方法）。ブロックが反転表示されている場合にのみ使用できます。

8.8.2 Copy
反転表示しているブロックの内容をクリップボードにコピーします（Windows 標準の方法）。ブロック
が反転表示されている場合にのみ使用できます。

8.8.3 Paste
Windows のクリップボードの内容を子ウィンドウの現在のカーソル位置にコピーします。

注注注注 1バイト以上を選択すると、Pasteオプションを使用できません。

8.8.4 Undo
選択したデータに対する直前の編集操作を取り消し、元に戻します。

8.8.5 Redo
直前のUndo操作を取り消します。
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8.8.6 Display Unit
以下のメニューをカスケード形式で表示します。

Byte ：データをバイト（8ビット）単位で表示します。

Word ：データをワード（16ビット）単位で表示します。

DWord：データをダブルワード（32ビット）単位で表示します。

8.8.7 Align to 8 Bytes
8バイトずつに分けて表示します。各行に表示できるバイト数は、ウィンドウサイズによって異なりま
す。

8.8.8 Toggle ASCII Column
ASCIIカラムを削除、あるいは表示します。

8.8.9 Create Selection…
‘Create Selection’ダイアログボックスを開きます。このダイアログボックスで、開始アドレス、終了アド
レス、長さを指定して、選択領域を作ることができます。この選択領域は、クリップボード、Fill、
Search、Replaceで使うことができます。

8.8.10 Fill…
現在のアクティブファイルに対する‘Fill’ダイアログボックスを開きます。このダイアログボックスで、
選択した領域に指定したデータを書き込むことができます。‘ASCII Fill’チェックボックスを選択する
と、書き込むデータをASCII文字で指定できます。

8.8.11 Find…
‘Find’ダイアログボックスを開きます。このダイアログボックスで、16進数またはASCIIデータを入力で
きます。検索範囲は、エディタウィンドウのアクティブファイル内の選択領域です。一致するデータを
見つけると、エディタウィンドウを更新し、一致したデータが表示されるようにします。

8.8.12 Replace…
‘Replace’ダイアログボックスを開きます。このダイアログボックスで、検索したい16進数またはASCIIデ
ータを入力できます。また、置換するデータも同じフォーマットで入力できます。検索範囲は、エディ
タウィンドウのアクティブファイル内の選択領域です。一致するデータを見つけると、エディタウィン
ドウを更新し、一致したデータが表示されるようにします。Replaceボタンが有効になるので、これをク
リックすると、データが置換されます。

8.8.13 Properties…
‘S-Record Properties’ダイアログボックスを表示します。

8.8.14 Add to Active Project
ファイルをアクティブプロジェクトに追加します。ファイルが既にプロジェクトに追加されている場
合、このメニューは無効です。

8.8.15 Data Entry Note
データを’Find’、’Replace’、’Fill’ダイアログボックスに入力するとき、ASCII Searchチェックボックスに
もとづき、16進数またはASCII値のみが使用できます。16進数を入力する場合、エントリテキストボック
スには、最初の部分に’0x’がデフォルトで表示されるため、16進数を続けて入力します。
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8.8.16 Goto Address
アドレスカラム上でダブルクリックすると、Goto Addressダイアログボックスを表示します。これによ
り、16進数エディタのカーソル位置を設定するための16進数アドレスの入力が可能になります。これ
は、類似のカーネルコマンド名’Go From Address’とは全く別のものであることに注意してください。

8.9 Erase Blocks
[Device->Erase FLASH blocks]、ツールバーの Erase Blocksのいずれかで呼び出します。

‘Erase Blocks’ダイアログボックスで、消去するブロックを指定できます。Writtenの欄は、対応するブロックに
データがあるかどうかを示します。

図 8-18　Erase Blocks

8.9.1 Select All
Select Allをクリックすると、デバイスのフラッシュメモリ内の全ブロックを選択します。

8.9.2 Select Written
Select Writtenをクリックすると、空白でないブロックのみを選択します。

8.9.3 Erase
Eraseをクリックすると、選択したブロックのデータを消去し、‘Erase Blocks’ダイアログボックスを閉じ
ます。

8.9.4 Cancel
Cancelをクリックすると、消去を行なわずに‘Erase Blocks’ダイアログボックスを閉じます。

注注注注 データのないブロックは消去する必要はありませんが、FDTは指定されたブロックはすべて消去します。
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8.10 Customise - Toolbars
‘Customise’ダイアログボックスの[Tools->Customise…]を選択して呼び出します。

図 8-19　Customiseダイアログボックス（Toolbarsタブ）

8.10.1 Show Tooltips
‘Show Tooltips’を選択してチェックマークを付けると、ボタンの上にマウスポインタ（矢印）を置いたと
きに、そのボタンの機能説明を表示します。チェックマークをはずすと、説明を表示しません。

8.10.2 New…
‘New…’ボタンをクリックすると、‘Toolbar Name’ダイアログボックスが開きます。このダイアログボッ
クスで、新しいツールバーを作ることができます。新しい名前を入力して‘OK’をクリックすると、
‘Toolbars’リストに新しい名前が追加され、画面に空のツールバーが表示されます。
‘Commands’タブを選択して、新しいツールバーにボタンを追加できます。新しいツールバーは、マウス
でドラッグして、画面上の好きな場所に置くことができます。

8.10.3 Reset
‘Reset’ボタンをクリックすると、選択したツールバーをデフォルトの設定にリセットします。

8.10.4 Toolbar name
リストで選んだツールバーの名前を表示します。

8.10.5 OK
‘Toolbar Name’ダイアログボックスの‘OK’ボタンをクリックすると、‘Toolbars’ウィンドウの‘Toolbars’リ
ストに新しい名前が追加され、画面に空のツールバーが表示されます。

‘Customise’ダイアログボックスの‘OK’ボタンをクリックすると、変更内容を保存してダイアログボック
スを閉じます。

8.10.6 Delete
新しいツールバーが‘Toolbars’リストに追加されたあと、その名前を選択すると、‘Reset’ボタンが‘Delete’
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ボタンに変わります。‘Delete’ボタンをクリックすると、新しいツールバーがリストと画面の両方から消
えます。

8.11 Customise - Commands
‘Customise’ダイアログボックスの‘Commands’タブは、[Tools->Customise…]を選択してから、‘Commands’ タブ

をクリックして開きます。

図 8-20　Customiseダイアログボックス（Commandsタブ）

8.11.1 Categories
‘Categories’リストから、カテゴリを選んでクリックすると、そのカテゴリに属するボタンを表示しま
す。

8.11.2 Buttons
‘Buttons’には、選択したカテゴリに属するボタンの絵が表示されます。

8.11.3 Description
ボタンをクリックすると、ボタンの動作についての説明が表示されます。

8.11.4 OK
‘OK’ボタンをクリックすると、変更内容を保存して‘Customise’ダイアログボックスを閉じます。
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8.12 Customise - Menu
‘Customise’ダイアログボックスの‘Menu’タブは、[Tools->Customise…]を選択してから、‘Menu’タブをクリック

して開きます。

図 8-21　Customiseダイアログボックス（Menuタブ）

 新規メニューオプションを追加するには
1. [Tools->Customise…]を選択すると、上記ダイアログボックスが表示されます。‘Menu’タブを選択して

ください。
最初に、ワークスペースすべてに有効なグローバルアプリケーションワイドツール（‘Application wide
tools:’）を追加するか、あるいは、現在のワークスペースのみに有効なワークスペースワイドツール
（‘Workspace wide tools:’）を追加するかを決めてください。一度決めたら、そのダイアログボックス
に関連するセクションを選んでください。

2. ‘Add…’ボタンをクリックしてください。既存のシステムツールをメニューに追加したい場合、‘Select
from existing system tools’ラジオボタンを選択してください。次にドロップダウンリストからツールを
選び、‘OK’をクリックしてください。また、ユーザ独自のツールを追加したい場合、以下のステップ
にしたがってください。

3. ツールの名前を‘Name’フィールドに入力してください。
4. 引数以外のコマンドを‘Command’フィールドに入力してください。
5. コマンドへ渡したい引数を‘Arguments’フィールドに入力してください。
6. ツールを実行させたい初期ディレクトリを‘Initial directory’フィールドに入力してください。
7. ‘OK’をクリックすると、メニューオプションが[Tools]メニューに追加されます。
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図 8-22　Add Toolダイアログボックス

新規メニューオプションがリストの下部（ツールメニューの下部）にデフォルトで追加されます。[Tools]メニ
ューのメニューオプションの順序は変更できます。

 メニューオプションを変更するには
1. [Tools->Customise…]を選択すると、以下のダイアログボックスが表示されます。‘Menu’タブを選択

してください。
1. 変更したいメニューオプションを選択し、‘Modify…’ボタンをクリックしてください。
2. ‘Modify Tool’ダイアログボックスで変更し、‘OK’をクリックしてください。

図 8-23　Modify Toolダイアログボックス

 メニューオプションを削除するには
1. [Tools->Customise…]を選択すると、図8-19に示すダイアログボックスが表示されます。‘Menu’タブを

選択してください。
2. 削除したいメニューオプションを選択し、‘Remove’ボタンをクリックしてください。
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9 Simple Interface Mode

‘Simple Interface’ダイアログボックスは、[Tools->Simple Interface…]を選択して呼び出します。いったんプロジ
ェクトを作成したあと、FDTの Look & Feelを簡略化するために使用されます。ユーザ名、およびパスワードと
併用する場合については、第 5章「アクセス権」を参照してください。

図 9-1　FDT Simple Interface

9.1.1 Options, Login… Menu
FDTにログインしているユーザを切り替えることができます。ショートカットキーCtrl + Shift + Uでも、
ログインダイアログボックスを起動できます。

9.1.2 Back to Project
FDT全体の画面に戻ります。現在FDTにログインしているユーザが、‘FDT:Project Edit’アクセスをしてい
ない場合、このボタンは無効です。[詳細については、5章を参照してください。]

9.1.3 Exit
クリックするとFDTを終了します。次にロードされたときには、FDTはSimple Interface Modeで起動しま
す。現在FDTにログインしているユーザが、‘SimpleInterface:Exit’アクセスをしていない場合、このボタ
ンは無効です。[詳細については、5章を参照してください。]
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9.1.4 Download Project image / Download File radio buttons
両方を同時に指定することはできません。ユーザはProject Imageまたは他のファイルのどちらをダウンロ
ードするか指定することができます。現在FDTにログインしているユーザが、‘SimpleInterface:Download
File’または‘SimpleInterface:Download Project Image’アクセスをしていない場合、このラジオボタンは無効
です。[詳細については、5章を参照してください。]

9.1.5 Project Image / Download File Area
ユーザブート領域を持つデバイスで‘Download Project Image’ラジオボタンを選択すると、ユーザは‘User
Area’、‘User Boot Area’、または‘Both’のどのイメージをダウンロードするか選択することができます。
User Boot Areaのあるデバイスでは、‘Download File’ラジオボタンを選択すると、ファイルをUser Areaま
たはUser Boot Areaのどちらにダウンロードするか選択することができます。

9.1.6 Program Flash
‘Program Flash’ボタンをクリックすると、指定したファイルをフラッシュメモリにダウンロードします。

9.1.7 Disconnect
‘Disconnect’ボタンをクリックすると、FDTの接続を解除します。
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10 FDT3.2へのアップグレード

FDT3.2のインストールが他バージョンの FDTのインストールに悪影響を与えないようにしなくてはなりませ
ん。FDT3.2をインストールすると USBドライバがアップグレードされますが、これは唯一の共有コンポーネン
トです。FDTの各バージョンは独自のカーネル一式をインストールし、独自の設定を保持します。FDT3.2をイ
ンストールすると、いくつかの旧バージョンの FDTのサポート eメールアドレスも更新します。

すでに FDTを使用していて、既存のプロジェクトを FDT3.2に移行させる必要がある場合は、以下の留意事項
があります。

旧バージョンの FDTで提供されたカーネル（または、古いバージョンがベースのカスタマイズされたカーネ
ル）をプロジェクトが具体的に要求してきた場合、“Other”オプションによって、“User Defined”カーネルを
選ぶことができます。ただし、可能な限り最新のカーネルを使用することをお薦めします。旧バージョンの FDT
のカーネルを使用すると、機能が低下する場合があります（例えば、FDT3.1および FDT3.2のカーネルは非同期
シリアルエラーの割合を計算するよう要求する情報を含んでいますが、FDT3.1以前に提供されたカーネルを使
用すると、この機能が使用できなくなります）。

FDT3.0以前の FDTバージョンを使用したプロジェクトでは、新しいワークスペースとプロジェクトはウィザ
ードを使って作成する必要があります。これにより、FDTの要求する新しい設定が生成されます。Project Wizard
を使用するとこのプロセスは非常に簡単です。FDT3.0以降では機能が強化されているため、バージョン 3.0以前
の FDTが使用しているワークスペースファイルは FDT3.2と互換性を持ちません。

FDTの以前のバージョン（FDT3.0以降）からのワークスペースは FDT3.2でも開くことができますが、アップ
グレードされた後は再び元のバージョンで開かないでください。この場合、‘SyntaxHighlightingFile.dbs’に関連す
るエラーは無視されます。旧フォーマットのワークスペースを開くと、ツールバーの位置と状態にも影響するこ
とがあります。プロジェクトがアップグレードされ、選択したファイルをダブルクリックによって開き、ダウン
ロードすることができるようになると、ファイルの関連付けを設定する必要があるかもしれません。

FDT3.2には、以下の新しい特長があります。

•  スクリプトファイルの自動実行
•  16進数エディタでファイルを開くためのコマンドラインのサポート
•  Simple Interface Modeのアクセス権パスワードによるセキュリティ機能サポート
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