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ご注意書き 

 

１． 本資料に記載されている内容は本資料発行時点のものであり、予告なく変更することがあります。当社製品

のご購入およびご使用にあたりましては、事前に当社営業窓口で最新の情報をご確認いただきますとともに、

当社ホームページなどを通じて公開される情報に常にご注意ください。 
2. 本資料に記載された当社製品および技術情報の使用に関連し発生した第三者の特許権、著作権その他の知的

財産権の侵害等に関し、当社は、一切その責任を負いません。当社は、本資料に基づき当社または第三者の

特許権、著作権その他の知的財産権を何ら許諾するものではありません。 
3. 当社製品を改造、改変、複製等しないでください。 
4. 本資料に記載された回路、ソフトウェアおよびこれらに関連する情報は、半導体製品の動作例、応用例を説

明するものです。お客様の機器の設計において、回路、ソフトウェアおよびこれらに関連する情報を使用す

る場合には、お客様の責任において行ってください。これらの使用に起因しお客様または第三者に生じた損

害に関し、当社は、一切その責任を負いません。 
5. 輸出に際しては、「外国為替及び外国貿易法」その他輸出関連法令を遵守し、かかる法令の定めるところに

より必要な手続を行ってください。本資料に記載されている当社製品および技術を大量破壊兵器の開発等の

目的、軍事利用の目的その他軍事用途の目的で使用しないでください。また、当社製品および技術を国内外

の法令および規則により製造・使用・販売を禁止されている機器に使用することができません。 
6. 本資料に記載されている情報は、正確を期すため慎重に作成したものですが、誤りがないことを保証するも

のではありません。万一、本資料に記載されている情報の誤りに起因する損害がお客様に生じた場合におい

ても、当社は、一切その責任を負いません。 
7. 当社は、当社製品の品質水準を「標準水準」、「高品質水準」および「特定水準」に分類しております。また、

各品質水準は、以下に示す用途に製品が使われることを意図しておりますので、当社製品の品質水準をご確

認ください。お客様は、当社の文書による事前の承諾を得ることなく、「特定水準」に分類された用途に当

社製品を使用することができません。また、お客様は、当社の文書による事前の承諾を得ることなく、意図

されていない用途に当社製品を使用することができません。当社の文書による事前の承諾を得ることなく、

「特定水準」に分類された用途または意図されていない用途に当社製品を使用したことによりお客様または

第三者に生じた損害等に関し、当社は、一切その責任を負いません。なお、当社製品のデータ・シート、デ

ータ・ブック等の資料で特に品質水準の表示がない場合は、標準水準製品であることを表します。 
標準水準： コンピュータ、OA 機器、通信機器、計測機器、AV 機器、家電、工作機械、パーソナル機器、

産業用ロボット 
高品質水準： 輸送機器（自動車、電車、船舶等）、交通用信号機器、防災・防犯装置、各種安全装置、生命

維持を目的として設計されていない医療機器（厚生労働省定義の管理医療機器に相当） 
特定水準： 航空機器、航空宇宙機器、海底中継機器、原子力制御システム、生命維持のための医療機器（生

命維持装置、人体に埋め込み使用するもの、治療行為（患部切り出し等）を行うもの、その他

直接人命に影響を与えるもの）（厚生労働省定義の高度管理医療機器に相当）またはシステム

等 
8. 本資料に記載された当社製品のご使用につき、特に、最大定格、動作電源電圧範囲、放熱特性、実装条件そ

の他諸条件につきましては、当社保証範囲内でご使用ください。当社保証範囲を超えて当社製品をご使用さ

れた場合の故障および事故につきましては、当社は、一切その責任を負いません。 
9. 当社は、当社製品の品質および信頼性の向上に努めておりますが、半導体製品はある確率で故障が発生した

り、使用条件によっては誤動作したりする場合があります。また、当社製品は耐放射線設計については行っ

ておりません。当社製品の故障または誤動作が生じた場合も、人身事故、火災事故、社会的損害などを生じ

させないようお客様の責任において冗長設計、延焼対策設計、誤動作防止設計等の安全設計およびエージン

グ処理等、機器またはシステムとしての出荷保証をお願いいたします。特に、マイコンソフトウェアは、単

独での検証は困難なため、お客様が製造された最終の機器・システムとしての安全検証をお願いいたします。 
10. 当社製品の環境適合性等、詳細につきましては製品個別に必ず当社営業窓口までお問合せください。ご使用

に際しては、特定の物質の含有･使用を規制する RoHS 指令等、適用される環境関連法令を十分調査のうえ、

かかる法令に適合するようご使用ください。お客様がかかる法令を遵守しないことにより生じた損害に関し

て、当社は、一切その責任を負いません。 
11. 本資料の全部または一部を当社の文書による事前の承諾を得ることなく転載または複製することを固くお

断りいたします。 
12. 本資料に関する詳細についてのお問い合わせその他お気付きの点等がございましたら当社営業窓口までご

照会ください。 
 
注 1. 本資料において使用されている「当社」とは、ルネサスエレクトロニクス株式会社およびルネサスエレク

トロニクス株式会社がその総株主の議決権の過半数を直接または間接に保有する会社をいいます。 
注 2. 本資料において使用されている「当社製品」とは、注 1 において定義された当社の開発、製造製品をいい

ます。 



資料中の「日立製作所」、「日立XX」等名称の株式会社ルネサス テクノロジへの変更について

　2003年4月1日を以って三菱電機株式会社及び株式会社日立製作所のマイコン、ロジック、

アナログ、ディスクリート半導体、及びDRAMを除くメモリ（フラッシュメモリ・SRAM等）を含む

半導体事業は株式会社ルネサス テクノロジに承継されました。従いまして、本資料中には 

「日立製作所」、「株式会社日立製作所」、「日立半導体」、「日立XX」といった表記が残っておりま

すが、これらの表記は全て「株式会社ルネサス テクノロジ」に変更されておりますのでご理

解の程お願い致します。尚、会社商標・ロゴ・コーポレートステートメント以外の内容につい

ては一切変更しておりませんので資料としての内容更新ではありません。

ルネサステクノロジ ホームページ （http://www.renesas.com）

2003年4月1日

株式会社ルネサス テクノロジ

カスタマサポート部

お客様各位



ご注意

安全設計に関するお願い

1. 弊社は品質、信頼性の向上に努めておりますが、半導体製品は故障が発生したり、誤

動作する場合があります。弊社の半導体製品の故障又は誤動作によって結果として、

人身事故、火災事故、社会的損害などを生じさせないような安全性を考慮した冗長設

計、延焼対策設計、誤動作防止設計などの安全設計に十分ご留意ください。

本資料ご利用に際しての留意事項

1. 本資料は、お客様が用途に応じた適切なルネサス テクノロジ製品をご購入いただく

ための参考資料であり、本資料中に記載の技術情報についてルネサス テクノロジが

所有する知的財産権その他の権利の実施、使用を許諾するものではありません。

2. 本資料に記載の製品データ、図、表、プログラム、アルゴリズムその他応用回路例の

使用に起因する損害、第三者所有の権利に対する侵害に関し、ルネサス テクノロジ

は責任を負いません。

3. 本資料に記載の製品データ、図、表、プログラム、アルゴリズムその他全ての情報は

本資料発行時点のものであり、ルネサス テクノロジは、予告なしに、本資料に記載

した製品または仕様を変更することがあります。ルネサス テクノロジ半導体製品の

ご購入に当たりましては、事前にルネサス テクノロジ、ルネサス販売または特約店

へ最新の情報をご確認頂きますとともに、ルネサス テクノロジホームページ

(http://www.renesas.com)などを通じて公開される情報に常にご注意ください。

4. 本資料に記載した情報は、正確を期すため、慎重に制作したものですが万一本資料の

記述誤りに起因する損害がお客様に生じた場合には、ルネサス テクノロジはその責

任を負いません。

5. 本資料に記載の製品データ、図、表に示す技術的な内容、プログラム及びアルゴリズ

ムを流用する場合は、技術内容、プログラム、アルゴリズム単位で評価するだけでな

く、システム全体で十分に評価し、お客様の責任において適用可否を判断してくださ

い。ルネサス テクノロジは、適用可否に対する責任は負いません。

6. 本資料に記載された製品は、人命にかかわるような状況の下で使用される機器あるい

はシステムに用いられることを目的として設計、製造されたものではありません。本

資料に記載の製品を運輸、移動体用、医療用、航空宇宙用、原子力制御用、海底中継

用機器あるいはシステムなど、特殊用途へのご利用をご検討の際には、ルネサス テ

クノロジ、ルネサス販売または特約店へご照会ください。

7. 本資料の転載、複製については、文書によるルネサス テクノロジの事前の承諾が必

要です。

8. 本資料に関し詳細についてのお問い合わせ、その他お気付きの点がございましたらル

ネサス テクノロジ、ルネサス販売または特約店までご照会ください。
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ご注意

1 本書に記載の製品及び技術のうち「外国為替及び外国貿易法」に基づき安全保障貿易管理関連貨
物・技術に該当するものを輸出する場合，または国外に持ち出す場合は日本国政府の許可が必要
です。

2 本書に記載された情報の使用に際して，弊社もしくは第三者の特許権，著作権，商標権，その他
の知的所有権等の権利に対する保証または実施権の許諾を行うものではありません。また本書に
記載された情報を使用した事により第三者の知的所有権等の権利に関わる問題が生じた場合，弊
社はその責を負いませんので予めご了承ください。

3 製品及び製品仕様は予告無く変更する場合がありますので，最終的な設計，ご購入，ご使用に際
しましては，事前に最新の製品規格または仕様書をお求めになりご確認ください。

4 弊社は品質・信頼性の向上に努めておりますが，宇宙，航空，原子力，燃焼制御，運輸，交通，
各種安全装置， ライフサポート関連の医療機器等のように，特別な品質・信頼性が要求され，そ
の故障や誤動作が直接人命を脅かしたり，人体に危害を及ぼす恐れのある用途にご使用をお考え
のお客様は，事前に弊社営業担当迄ご相談をお願い致します。

5 設計に際しては，特に最大定格，動作電源電圧範囲，放熱特性，実装条件及びその他諸条件につ
きましては，弊社保証範囲内でご使用いただきますようお願い致します。

   保証値を越えてご使用された場合の故障及び事故につきましては，弊社はその責を負いません。
また保証値内のご使用であっても半導体製品について通常予測される故障発生率，故障モードを
ご考慮の上，弊社製品の動作が原因でご使用機器が人身事故，火災事故，その他の拡大損害を生
じないようにフェールセーフ等のシステム上の対策を講じて頂きますようお願い致します。

6 本製品は耐放射線設計をしておりません。

7 本書の一部または全部を弊社の文書による承認なしに転載または複製することを堅くお断り致し
ます。

8 本書をはじめ弊社半導体についてのお問い合わせ，ご相談は弊社営業担当迄お願い致します。



商標
Windows® およびWindows®95、Windows®98、WindowsNT®、Windows®2000は、米国マイクロ

ソフトコーポレーションの米国およびその他の国における登録商標です。

IBM PCは、米国 IBM 社により管理されている計算機の名称です。

ELF/DWARFは、the Tool Interface Standards Committee で開発された、オブジェクトフォーマット
の名称です。

本チュートリアルで使用されているすべての製品名またはブランド名は、それぞれの会社の商標ま
たは登録商標です。



まえがき

本チュートリアルは、Hitachi Embedded Workshop（以下、HEWと略します）および Hitachi Debugging
Interface（以下、HDIと略します）の簡単な使用方法を述べたものです。HEWチュートリアルでは
HEWの起動、プロジェクトの作成・編集方法から、アプリケーションの作成および HDI との連動に
いたる一連のプログラム作成作業について説明します。また、HDI チュートリアルではシミュレー
タ・デバッガを用いて、サンプルプログラムのデバッグ方法について説明します。各ツールについて
は、下記のマニュアルを参照してください。

• Hitachi Embedded Workshop　ユーザーズマニュアル
• SuperH™ RISC engine C/C++コンパイラ、アセンブラ、最適化リンケージエディタ ユーザー
ズマニュアル

• SuperH™ RISC engine シミュレータ・デバッガ　ユーザーズマニュアル

SuperH™ RISC engineマイコンの詳細については、該当品種のプログラミングマニュアルおよびハ
ードウェアマニュアルを参照してください。

なお、説明は SuperH™ RISC engine C/C++コンパイラパッケージに含まれる全てのツールをインス
トールした状態で進めます。

チュートリアルの規約
本チュートリアルに記載している画面は英語版Windows®上で取得したものです。日本語版

Windows®では一部日本語表示します。また、本チュートリアルではディレクトリ区切り子としてバ
ックスラッシュを使用していますが、日本語版Windows®上ではバックスラッシュの代わりに円記号
を使用してください。

表記上の規約
本書には、以下の表記上の規約があります。

表 1　表記上の規約
表　記 意　　　味

[Menu->Menu Option] ’->’の付いた太字の表記は、メニューオプションを指定する場合に使用
します

(例： [File->Save As...])。
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1. HEWチュートリアル

1.1 HEWの起動
HEWのインストーラは、インストール正常終了時、Windows®のスタートメニューのプログラムフ

ォルダの下に Hitachi Embedded Workshopという名称のフォルダを作成し、そのフォルダ内に HEWの
実行プログラムである Hitachi Embedded Workshopの他、各種サポート情報のショートカットを登録
します（図 1.1）。
なお、スタートメニューの表示内容は、ツールのインストール状況により異なる場合があります。

図 1.1  スタートメニューによる HEWの起動
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このスタートメニューで、Hitachi Embedded Workshopをクリックすると起動メッセージを表示し、
引き続きWelcome!ダイアログボックス（図 1.2）を表示します。なお、前の作業で開いていたプロ
ジェクトを直接開きたい場合などは、[Tools->Options]で作業環境の設定変更が可能です。詳しくは、
「Hitachi Embedded Workshopユーザーズマニュアル」の「第６章　環境のカスタマイズ」を参照し
てください。

図 1.2  Welcome!ダイアログボックス

HEWを初めて使用する場合や、新たにプロジェクトを作成して作業を開始する場合は、[Create a
new project workspace]を選択して[OK]をクリックしてください。既に作成したプロジェクトで作業す
る場合は、[Open a recent project workspace]または[Browse to another project workspace]を選択して[OK]
をクリックしてください。
ここでは、[Create a new project workspace]を選択して[OK]をクリックします。
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1.2 プロジェクトの作成
Welcome!ダイアログボックスで[Create a new project workspace]を選択して[OK]をクリックすると、

新しいワークスペースとプロジェクト作成用の New Project Workspaceダイアログボックス（図 1.3）
を表示します（HEWの起動後は、[File -> New Workspace…]でも表示できます）。このダイアログボ
ックスでワークスペース名（新規作成時はプロジェクト名も同名です）や CPUの種類、プロジェク
トタイプなどを設定します。

HEWが標準サポートするプロジェクトジェネレータでは表 1.1のプロジェクトタイプを扱ってい
ます。
ここでは、ワークスペース名として“tutorial”を入力し、Project typeとして Applicationを選択し

ます。[Name]に“tutorial”と入力すると、[Directory]も“c:¥tutorial”となり、このディレクトリ以下
にプロジェクトが生成されます。
なお、ワークスペースとして使用するディレクトリを変更する場合は、[Browse...]をクリックして

ディレクトリを選択するか、直接[Directory]に入力してください。

図 1.3  New Project Workspaceダイアログボックス
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表 1.1  プロジェクトタイプ
プロジェクトタイプ 説明

Application C/C++言語またはアセンブリ言語で記述した初期ルーチンファイルを含むプログラ
ム開発用プロジェクト

Demonstration C/C++言語またはアセンブリ言語で記述したデモンストレーションプログラム作成
用プロジェクト（「1.5.2 Demonstrationプロジェクト」）

Empty Application プログラム開発用プロジェクト（生成ファイルはありません。ツールのオプション
設定のみ行います。）

Library ライブラリファイル作成用プロジェクト（生成ファイルはありません。ツールのオ
プション設定のみ行います。）

1.2.1 CPUの選択
New Project Workspaceダイアログボックスで[OK]をクリックすると、プロジェクトジェネレータを

起動し、Step1画面（CPUの設定）を表示します（図 1.4）。この画面では、開発の対象となる CPU
を選択します。
ここでは、[CPU Series]で“SH-1”を選択し、[CPU Type]から“SH7020”を選択し、[Next >]をクリ

ックしてください。クリックすると Step2画面（CPU固有のオプション設定）を表示します。

図 1.4  プロジェクトジェネレータの CPU設定画面（Step1）
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[CPU Type:]は、[CPU Series:]で選択した CPUシリーズに含まれる製品（以下、CPUタイプと呼び
ます）です。

[CPU Series:]の選択により、標準ライブラリ構築ツール、C/C++コンパイラおよびアセンブラの CPU
種別オプションを設定します。また、[CPU Series:]および[CPU Type:]の選択により、生成するファイ
ルが異なります。開発するプログラムの対象となる CPUタイプを選択してください。選択したい CPU
タイプがない場合は、ハードウェア仕様の近い CPUタイプまたは“Other”を選択してください。

[Next >]をクリックすると、次の画面を表示します。
[< Back]をクリックすると、この画面を表示する前の画面またはダイアログボックスに戻ります。
[Finish]をクリックすると、Summaryダイアログボックスが開きます。
[Cancel]をクリックすると、New Project Workspaceダイアログボックスに戻ります。
[< Back]、[Next >]、[Finish]および[Cancel]の機能は、プロジェクトジェネレータで共通の機能です。

1.2.2 CPU固有のオプションの設定
Step1画面で[Next >]をクリックすると、図 1.5に示す画面を表示します。
この画面で、CPU固有で、かつ全プロジェクトファイルで共通のオプションを設定します。
ここでは、設定を変更しないで[Next >]をクリックします。クリックすると、Step3画面（生成ファ

イルの設定）を表示します。

図 1.5  プロジェクトジェネレータの CPU固有オプション設定画面（Step2）
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Step1および Step2の画面設定により、以下のオプションを設定します。
プロジェクト作成後に設定を変更する場合は、下記ツールのオプション設定ダイアログ（HEWの

[Options -> ]）で変更してください。

＜C/C++ コンパイラ＞（＜標準ライブラリ構築ツール＞も同様）
CPU
除算の方式
メモリのバイト並び（エンディアン種別）
FPU
丸め方向
非正規化数の扱い
プログラムセクションポジションインディペンデント
double -> float変換
例外処理機能
実行時型情報

＜アセンブラ＞
CPU
エンディアン種別
丸め方向
非正規化数の扱い

＜最適化リンケージエディタ＞
出力形式（プロジェクトタイプにより決定）
ライブラリファイルの指定（DSPライブラリのみ）

Step1画面で選択した CPUシリーズによりサポートしていないオプションのコントロールは、設定
変更ができないようになっています。本チュートリアルでは Step1画面で“SH-1”を選択したため、
[Treat double as float]、[Use try, throw and catch of C++]および[Enable/disable runtime type information ]以
外の表示がグレーになっており、これらのオプションを設定することはできません。
プロジェクトタイプが Libraryの場合は、他に設定する項目はありません。[Finish]を選択してくだ

さい。
プロジェクトタイプが Demonstrationの場合は、[Next >]をクリックすると、「1.2.7　生成ファイル

名の変更」に示す Step6画面を表示します（Demonstrationの場合は、ダイアログボックスのタイトル
が Step3になります）。
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1.2.3 生成ファイルの設定
Step2画面で[Next >]をクリックすると、図 1.6に示す画面を表示します。

図 1.6  プロジェクトジェネレータの生成ファイル設定画面（Step3）

この画面で、生成するファイルを決定します。
ここでは、設定を変更しないで[Next >]をクリックします。クリックすると、Step4（標準ライブラ

リの設定）画面を表示します。

[Use I/O Library]のチェックを付けると、標準入出力ライブラリを活用できます。このとき、[Number
of I/O Streams:]は 20で固定です。
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[Use Heap Memory]のチェックを付けると、ヒープ領域の管理用の関数 sbrk()を活用できます。この
とき、[Heap Size:]で、管理するヒープ領域のサイズを設定できます。

[Heap Size:]は、16進数または 10進数で入力することができます。以下のように、入力してくださ
い。

H’ABCDE：16進数
0xABCDE：16進数
1234     ：10進数

プロジェクト作成後に、[Heap Size]を変更する場合は、sbrk.hの以下の箇所の数値を変更してくだ
さい。

#define  HEAPSIZE  0x400

[Generate main() Function]では、main関数の生成方法（C、C++、生成なし）を設定します。
[I/O Register Definition Files]のチェックを付けると、C言語で記述した I/Oレジスタの定義ファイル

を生成します。このとき、[Generate Hardware Setup Function]の設定が可能になります。

この画面の設定およびプロジェクトタイプにより生成するファイルが異なります。各コントロール
の設定により生成するファイルを表 1.2に示します。

表 1.2　生成ファイル画面の設定内容と生成ファイル
コントロール 状態 生成ファイル

[Use I/O Library] チェック lowlvl.src

lowsrc.c

[Number of I/O Streams:] 入力不可能 －

[Use Heap Memory] チェック sbrk.c

[Heap Size:] 入力可能 sbrk.h

[Generate main() Function] C source file

C++ source file

None

tutorial.c

tutorial.cpp

－

（生成時、プロジェクト名がファイル名
になります）

[I/O Register Definition Files] チェック iodefine.h

[Generate Hardware Setup Function] None

Assembly source file

C/C++ source file

－

hwsetup.src

hwsetup.c (または、cpp)

（main関数ファイルと同じ拡張子）

注意　既に作成した関数 main（_main）を使用する場合は、[Generate main() Function]のチェックを
はずしてプロジェクトを作成し、該当するファイルをプロジェクトに追加してください。なお、
使用する関数名が異なる場合、resetprg.srcの関数呼び出し部分を修正する必要があります。
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1.2.4 標準ライブラリの設定
Step3画面で[Next >]をクリックすると、図 1.7に示す画面を表示します。

図 1.7  プロジェクトジェネレータの標準ライブラリ設定画面（Step4）

この画面で、プロジェクトで使用する標準ライブラリを設定します。ビルド実行時、[Library]でチ
ェックした項目をもとに標準ライブラリが構築されます。
プロジェクト作成後に設定を変更する場合は、標準ライブラリ構築ツールのオプション設定ダイア

ログ（HEWの[Options -> SH Library Generator…]）で変更してください。
ここでは、設定を変更しないで[Next >]をクリックします。クリックすると、Step5（スタック領域

の設定）画面を表示します。
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1.2.5 スタック領域の設定
Step4画面で[Next >]をクリックすると、図 1.8に示す画面を表示します。

図 1.8  プロジェクトジェネレータのスタック領域設定画面（Step5）

この画面で、スタック領域を設定します。
ここでは、設定を変更しないで[Next >]をクリックします。クリックすると、Step6（ベクタ定義の

設定）画面を表示します。

[Stack Pointer Address:]および[Stack Size:]には、16進数または 10進数で入力することができます。
以下のように、入力してください。

H’ABCDE：16進数
0xABCDE：16進数
1234     ：10進数
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[Stack Size:]の設定は、stacksct.srcに反映されます。また、[Stack Pointer Address:]および[Stack Size:]
の設定により、最適化リンケージエディタのスタートオプションで、スタックのセクションのアドレ
スを決定します。スタックセクションの開始アドレスは、以下のように決定します。

スタックセクション名：Stack
スタックセクションアドレス ＝ [Stack Pointer Address:]の値 － [Stack Size:]の値

プロジェクト作成後にスタックサイズを変更する場合は、stacksct.srcのスタック領域サイズを変更
し、最適化リンケージエディタのオプションダイアログ（HEWの[Options -> Optlinker…]）のスター
トオプションで、スタックセクションのアドレスを変更してください。

stacksct.src

        .section      Stack,STACK
        .export     _PowerON_Reset_SP
        .export     _Manual_Reset_SP
StackEND:            .res.b  H'100          -----> スタック領域サイズ
_PowerON_Reset_SP:  .equ $
_Manual_Reset_SP:    .equ $
        .end



１. HEWチュートリアル

12

1.2.6 ベクタの設定
Step5画面で[Next >]をクリックすると、図 1.9に示す画面を表示します。

図 1.9  プロジェクトジェネレータのベクタ定義設定画面（Step6）

この画面では、ベクタを設定します。
ここでは、設定を変更しないで[Next >]をクリックします。クリックすると、Step7（生成ファイル

名の確認）画面を表示します。

[Vector Definition Files]のチェックを付けると、ベクタテーブル定義ファイルを生成します。このと
き、[Vector Handlers:]でリセットベクタを変更することができます。

[Vector Handlers:]の[Handler]列はリセットベクタのハンドラプログラム名を、[Vector]列にはベクタ
の説明を表示しています。自作のハンドラプログラムを使用する場合は、変更するハンドラプログラ
ム名を選択してクリック後、自作のハンドラプログラム名を入力してください。
なお、[Vector Handlers:]のハンドラ名を変更すると、リセットプログラム用ファイル（resetprg.src）

は生成しません。
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[Vector Definition Files]のチェックを付けると、以下のファイルを生成します。
vecttbl.c（SH3,4系は、vecttbl.src）
intprg.c（SH3,4系は、intprg.src）
vect.h（SH3,4系は、vect.inc）
resetprg.src
vhander.src（SH3,4系のみ）

プロジェクト作成後に、割込みプログラムを編集または他のプログラムに変更する場合は、以下の
手順でソースファイルを変更してください。

（1） 割込みプログラムを編集
• リセットプログラムは resetprg.srcにアセンブリ言語で記述しています。セクションの初期化
やスタックレジスタの設定（SH3,4系のみ）等の簡単な初期設定のみですので、必要に応じ
て処理を追加してください。

• 割込みプログラムは、SH1,2系は intprg.cに C言語で、また、SH3,4系は intprg.srcにアセン
ブリ言語で記述しています。どちらも、プログラム名のみで処理内容は記述していませんの
で、必要な処理を追加してください。

（2） 割込みプログラムを他のプログラムと変更
• SH1,2系の割込みプログラムを変更するには、定義ファイル（vect.h）内で変更対象である割
込みベクタ用の関数を変更します。さらに、割込み関数ファイル（intprg.c）から同関数を削
除し、新たに割込みプログラムとして使う関数を追加します。

例：ベクタ 4のプログラム（INT_Illegal_code）を void UserIntProg4(void)に変更

vect.h
    .
    .
// 4 Illegal code
#pragma interrupt INT_Illegal_code       --->     #pragma interrupt UserIntProg4  に変更。
extern void INT_Illegal_code(void);        --->     extern void UserIntProg4 (void);  に変更。
    .
    .

intprg.c
    .
    .
// 4 Illegal code
void INT_Illegal_code(void){/* sleep(); */}   --->    削除し、void UserIntProg4(void)を記述。
    .                                         void UserIntProg4(void)は、別のファイル
    .                                         への記述も可。
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• SH3,4系の割込みプログラムを変更するには、定義ファイル（vect.inc）内で変更対象である
割込み要因に対応するラベル（アセンブリモジュール名）を変更します。さらに、割込み関
数ファイル（intprg.src）から同関数名を削除し、新たに割込みプログラムとして使う関数を
追加します。

例：割込み要因コード H’040のプログラム（_INT_TLBMiss_Load）を _UserIntProg040に変更

vect.inc
            .
            .
    ;H'040 TLB miss/invalid (load)
    .global     _INT_TLBMiss_Load      --->    .global     _UserIntProg040  に変更。
            .
            .

intprg.src
            .
            .
;H'040 TLB miss/invalid (load)
_INT_TLBMiss_Load                     ---> 削除し、_UserIntProg040を記述したファイル
            .                               をプロジェクトに追加。
            .

vecttbl.src
            .
            .
    ;H'040 TLB miss/invalid (load)
    .data.l  _INT_TLBMiss_Load          --->    .data.l  _UserIntProg040  に変更。
            .
            .
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1.2.7 生成ファイル名の変更
Step6画面で[Next >]をクリックすると、図 1.10に示す画面を表示します。

図 1.10  プロジェクトジェネレータの生成ファイル名確認画面（Step7）

この画面が New Projectウィザードダイアログボックスの最終画面になります。これまでの画面の
設定により生成されるファイルをリストに表示しています。リストの[File Name]列はファイル名を、
[Extension]列は拡張子を、[Description]列はファイルの説明を表示しています。ファイル名は、変更す
ることができます。変更する場合は、ファイル名を選択してクリック後、入力してください。

ここでは、設定を変更しないで[Finish]をクリックします。クリックすると、Summaryダイアログ
ボックスを表示します。

注意  [Extension]が“h”または“inc”のファイルは、インクルードファイルです。これらのファイ
ル名を変更した場合、インクルードしているファイルの include文も変更する必要があります。
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1.2.8 設定確認
Step7画面で[Finish]をクリックすると、図 1.11に示すダイアログボックスを表示します。

図 1.11  プロジェクトジェネレータの Summaryダイアログボックス

[Project Summary:]に、これまでの設定内容を表示しています。内容を確認して[OK]をクリックして
ください。設定を変更したい場合は、[Cancel]をクリックしてください。

表示している内容は、テキストファイル（Readme.txt）として出力します。出力しない場合は、
[Generate Readme.txt as a summary file in the project directory]のチェックをはずしてください。

[OK]をクリックすると、プロジェクトを作成します。
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HEWはプロジェクトジェネレータが生成したファイルを組み込んだプロジェクトを開きます。
HEWの初期ウィンドウ状態は、図 1.12に示すように、プロジェクトの内容を示すワークスペース

ウィンドウ（図中の左側）と、ビルドやファイル間の文字列検索などの結果を表示するアウトプット
ウィンドウ（図中の下側）と、テキストファイル編集用のエディタウィンドウ（図中の右側）に分割
されています。HEWのウィンドウの状態を変更する場合や、エディタを含めた各種ウィンドウの機
能については、「Hitachi Embedded Workshopユーザーズマニュアル」を参照してください。

図 1.12  HEWのウィンドウ構成
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また、プロジェクトジェネレータにより作成したプロジェクトは、ライブラリ構築ツール、C/C++
コンパイラ、アセンブラ、最適化リンケージエディタなどのビルドに使うツールに対して基本的なオ
プションを設定しています。そのため、プロジェクト作成直後に[Build->Build]によりビルドすること
も可能です（図 1.13）。
なお、ビルドはツールバー上の

ボタンをクリックしても実行できます。
また、これらの基本的なオプションは、各ツールのデフォルト設定として定義していますので、以

後プロジェクトにファイルを追加してもそのファイルに個別に設定するオプションを除いて、新たに
オプションを設定する必要はありません。

図 1.13  ビルド実行時のウィンドウ
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1.3 プロジェクトの編集
プロジェクトジェネレータを使用してプロジェクトを作成するとリセットルーチンやRAMの初期

化ルーチンなどの基本的なプログラムが生成されプロジェクトに組み込まれます。ここでは、生成さ
れたファイルの修正や、新たなファイルのプロジェクトへの登録方法などについて説明します。

1.3.1 ソースファイルの編集と作成
プロジェクトに組み込まれたテキストファイルをワークスペースウィンドウの[Projects]タブで選

択してダブルクリックすると、エディタウィンドウで編集することができます。ここでは、“tutorial.c”
を開きます（図 1.14）。

図 1.14  プロジェクトファイルのオープン
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エディタウィンドウに開いたファイルは編集可能となり、編集するとウィンドウタイトルに表示す
るファイル名の右にアスタリスク（‘*’）が付きます(図 1.15)。編集を終了し、ファイルを保存す
るとアスタリスクが消えます。

図 1.15  プロジェクトファイルの編集

また、既存のファイルを開く場合は、[File->Open]で、新規にファイルを作成する場合は、[File->New]
でエディタウィンドウにテキストファイルを開くことができます。
ここでは、[File->New]で新規ファイルを開き、次の 3行を入力し、[File->Save As...]により

“newprog.c”の名称でファイルを保存します。

void NewProgram(void)
{
}
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1.3.2 プロジェクトへのファイル追加と削除
次に既存のファイルをプロジェクトに追加する方法について説明します。ここでは、例として前節

で新しく作成した“newprog.c”をプロジェクトに追加します。
  [Project->Add Files...]により、Add File(s)ダイアログボックス（図 1.16）を表示します。追加する

ファイル（ここでは、“newprog.c”）を選択し、[Add]をクリックするとプロジェクトに追加されま
す。

図 1.16  プロジェクトへのファイルの追加
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プロジェクトに追加したファイルは、図 1.17に示すようにワークスペースウィンドウの[Projects]
タブに表示されます。

図 1.17  ファイルを追加したプロジェクト
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次に、プロジェクトで不要となったファイルの削除方法を説明します。[Project->Remove File...]に
より、Remove Project Filesダイアログボックス（図 1.18）を表示します。ここで、削除したいファ
イルを選択（複数も可能）して[Remove]をクリックすると[Project files]のリストからファイル名が削
除されます。[OK]をクリックすると実際にプロジェクトからファイルが削除されます。[Cancel]をク
リックすると削除は無効になります。
また、ワークスペースウィンドウの[Projects]タブでファイルを選択して[Delete]キーを押下しても

プロジェクトからファイルは削除されます。ただし、この場合は削除の取り消しができません。
なお、ファイルをプロジェクトから削除するのではなく、一時的にビルドから外したい場合は、

「1.4.4　プロジェクトファイルの除外」を参照してください。

図 1.18  Remove Project Filesダイアログボックス
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1.3.3 プロジェクトで使えるファイルの種類
プロジェクトジェネレータによりＣ言語とアセンブリ言語で記述したファイルをプロジェクトに

登録しました。例えば、“*.c”はＣ言語ソースファイルに属し、“*.src”はアセンブリソースファイ
ルに属します。
次に、プロジェクトに追加できるファイルの種類について説明します。
HEWは、ファイルの種類をその内容ではなく拡張子で識別します。[Project->File Extensions...]によ

り、File Extensionsダイアログボックス（図 1.19）を表示します。ここで、プロジェクトで使用でき
るファイルの拡張子を確認できます。すべての拡張子はファイルグループにより分類され、このファ
イルグループ単位でビルド時に使うツールを決めることができます。
ユーザが独自に使用している拡張子を HEWで使用したい場合は、[Add...]をクリックして新たな拡

張子を定義する必要があります。
また、[Extension]列で表示されているアイコンはファイルを開くためのツールを示しています。
ここで、アイコンが

で表示されている拡張子のファイルは HEWのエディタで開けるテキストファイルを表わします。

図 1.19  File Extensionsダイアログボックス（初期画面）
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File Extensionsダイアログボックスで[Add]をクリックすると、Define File Extensionダイアログボッ
クス（図 1.20）を表示します。このダイアログボックスの[File extension]に新たに定義する拡張子名
を入力し、[File group]を設定します。既存のグループへの追加であれば[Existing group]を選択し、下
のドロップダウンリストボックスから該当するグループを選択します。
また、新しいグループを作成する場合は、[New group]を選択し、下の入力エリアにグループ名を

入力します。
ここでは、拡張子“asm”を[File extension]に指定し、ドロップダウンリストから“Assembly source

file”を選択します。[OK]をクリックすると、“*.asm”ファイルも“Assembly source file”グループ
としてプロジェクトに追加することができるようになります（図 1.21）。

図 1.20  Define File Extensionダイアログボックス

図 1.21  File Extensionsダイアログボックス（追加後）
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1.3.4 ワークスペースウィンドウのカスタマイズ
ワークスペースウィンドウの[Projects]タブ上でマウスの右ボタンをクリックし、表示されるポップ

アップメニューで[Configure View...]を選択すると、Configure Viewダイアログボックス（図 1.22）を
表示します。ここでの設定で、ファイルごとのインクルード関係やファイルグループ単位での表示（図
1.23）などが可能になります。

図 1.22  Configure Viewダイアログボックス

図 1.23  ワークスペースウィンドウの表示形式
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1.4 オブジェクトの作成

1.4.1 ビルドの機能
オブジェクトの作成には、２種類の方法があります。コンパイル、アセンブル、リンクなどの一連

のオブジェクト作成処理を、すべてのソースファイルに対して実施する全ビルドと、前回のオブジェ
クト作成以降に修正したソースファイル（または、インクルードファイルを修正したソースファイル）
だけに対して実施するビルドの２種類です。
（ビルドは、ソースファイルなどの修正だけでなく、オプションの設定変更やプロジェクトファイ

ルの構成を変更することにより影響を受けるファイルも対象になります）
ビルドは、[Build->Build]で実行を開始し、全ビルドは[Build->Build All]で実行を開始します。
なお、単一ファイルをコンパイル、または、アセンブルする場合は、ワークスペースウィンドウで

ファイルを選択し、[Build->Build File]を選択します。

注意 1. ビルド実行開始時、エディタウィンドウの環境設定により、編集中のファイルはすべて保
存されることがあります。編集したファイルで保存しないものについては、あらかじめフ
ァイルを閉じておいてください。
エディタ機能およびエディタウィンドウのカスタマイズについては、「Hitachi Embedded
Workshopユーザーズマニュアル」を参照してください。

2. プロジェクトに関連するファイルはビルド処理と競合する可能性があります。このような
ファイルは、ビルド中に保存しないでください。
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1.4.2 オプション設定
次にオプションの変更方法を説明します。
プロジェクトジェネレータでプロジェクトを作成することにより、ビルドで必要となる基本的なオ

プションは設定されています。新たにオプションを変更する場合は、[Options-> <ツール名>]により表
示する各ツールごとのオプション設定ダイアログボックスで設定します。
図 1.24に C/C++コンパイラのオプション設定ダイアログボックスを示します。ダイアログボック

スは、左側のプロジェクトファイルリストと右側のカテゴリごとのオプション設定部分で構成されて
います。左側のファイルリストでファイルを選択すればそのファイル固有のオプションが設定でき、
ファイルグループのフォルダを選択すればファイルグループに登録されているプロジェクトファイ
ルで共通のオプションを設定できます。複数ファイルのオプションを同時に設定する場合は、[Ctrl]
キーまたは[Shift]キーを押しながらマウスで該当するファイルを選択してください。
また、“Default Options”を選択すれば、ファイルグループのオプションの初期設定が変更できま

す。“Default Options”はファイルグループごとに設定できます。“Default Options”に設定したオプ
ションは、そのファイルグループの拡張子を持つファイルをプロジェクトに追加した時に自動的に設
定されます。
例えば、拡張子‘C’を持つファイル（“*.C”）をプロジェクトに追加すると、そのファイルには

“C source file”の“Default Options”が設定されます。
なお、各オプション内容の詳細については、クロスソフトのユーザーズマニュアルを参照してくだ

さい。

図 1.24  C/C++コンパイラのオプション設定ダイアログボックス
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1.4.3 コンフィグレーションのカスタマイズ
前項で、プロジェクトファイルのオプション設定について説明しましたが、HEWでは、同じプロ

ジェクトファイルに対して複数の組み合わせでオプションを設定することが可能です。
プロジェクトジェネレータは、[Debug]と[Release]の２種類のコンフィグレーション（デバッグオプ

ションの有無が異なる）を作成します。コンフィグレーションを変更する場合は、[Options->Build
Configurations...]により Build Configurationsダイアログボックス（図 1.25）を表示し、[Current
configuration]ドロップダウンリストから使用するコンフィグレーションを選択し[OK]をクリックし
ます。HEWのツールバーにあるドロップダウンリストからもコンフィグレーションの選択は可能で
す。
また、Build Configurationsダイアログボックスでは、コンフィグレーションの新規作成や削除もで

きます。詳しくは、「Hitachi Embedded Workshopユーザーズマニュアル」の「第２章　ビルドの基
本」を参照してください。

図 1.25  Build Configurationsダイアログボックス
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1.4.4 プロジェクトファイルの除外
次にプロジェクトからファイルを除外する方法を説明します。これはプロジェクトからファイルを

削除するのではなく、コンフィグレーション単位でファイルをビルドから外す場合に使います。
ワークスペースウィンドウ上で除外したいファイルを選択後、マウスの右ボタンをクリックし表示

されるポップアップメニューから[Exclude Build <ファイル名>]を選択します。図 1.26に示すように、
ファイルのアイコンに赤いバツ印が付けられ、ビルドから除外されます。
なお、除外したファイルを再びビルドに入れる場合は、削除時と同様にポップアップメニューから

[Include Build <ファイル名>]を選択します。

図 1.26  プロジェクトファイルの除外
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1.4.5 ビルド時のエラー修正
次に、オブジェクトの作成処理中にコンパイラなどでエラーが発生した場合の対処について説明し

ます。
図 1.27にエラー行を含むファイルをビルドした例を示します。ビルド実行により、アウトプット

ウィンドウにビルド結果（ここではコンパイル結果）が表示され、エラーが発生したことが分かりま
す。ここで、アウトプットウィンドウの[Build]タブ上のエラーメッセージ表示行をダブルクリックす
ると、エディタウィンドウ上にエラーが発生したファイルを開き、エラー行にカーソルが移動します。
ただし、エラー原因の対策でファイルの行数が変わった場合、カーソルの移動先がずれることがあ

ります。

図 1.27  ビルド時のエラー修正
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1.5 HDIインタフェース

1.5.1 HDIとの連動
HEWは HDI（バージョン 4.0以降）と連動して使うことができます。[Tools->Customize...]より Tools

Customizeダイアログボックス（図 1.28）を開き、[Debugger]タブで設定します。[HDI location(V4.0 or
greater)]で HDIの実行ファイルを指定し、[Session file]に HDI で生成したセッションファイルを指定
します。セッションファイルの生成方法は、「SuperH RISC engineシミュレータデバッガユーザー
ズマニュアル」を参照してください。
この設定により HEWのツールバーボタン

で、HDIの起動とセッションファイルの実行まで可能となります。
また、[Download module]に HDI にダウンロードするモジュール（プログラム）を指定後、ビルド

によりダウンロードモジュールを更新すると、HEWから HDI に自動的に制御が移るようになります。

図 1.28  Tools Customizeダイアログボックス（Debuggerタブ）
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HDI のソースウィンドウ（図 1.29）上の行をダブルクリックすると、HEWのエディタウィンドウ
でソースファイルを開き、ダブルクリックした行にカーソルを移動します。
図 1.30には、HDI のソースウィンドウ上で“tutorial.c”の「void main(void)」の行をダブルクリッ

クした時の HEWの表示結果を示します。

図 1.29  HDIソースウィンドウ
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図 1.30  HEWと HDIの連動
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1.5.2 Demonstrationプロジェクト
プロジェクト作成時に New Project Workspaceダイアログボックス（図 1.31）でプロジェクトタイ

プとして Demonstrationを選択すると、HDI シミュレータデバッガの Simulated I/O機能を組込んだ、
サンプルプロジェクトを作成することができます。このプロジェクトでは、main関数にプログラム
の進行状況やデータを表示するために、標準出力関数の一つである printfを使用しています。

Simulated I/O機能を使う場合は、HDI でデバッグ環境を整えた後に図 1.31で示す System
Configurationダイアログボックス（[Setup -> Configure Platform…]で表示）の設定が必要です。
このダイアログボックスの System Call Addressの[Enable]をチェックし、HEWが生成した lowlvl.src

で定義している SIM_IOの値をアドレスとして入力します（CPUの種類によりアドレス値が異なる場
合があります）。

  SIM_IO:  .EQU       H'0000     （この場合は、アドレスに 0を入力）

HDI の Simulated I/O Windowを開き（[View -> Simulated I/O]で開く）、プログラムを実行すれば
Simulated I/O機能を用いたデバッグが可能となります。
詳細は、「SuperH RISC engineシミュレータデバッガユーザーズマニュアル」を参照してくださ

い。

図 1.31  HDIの System Configurationダイアログボックス
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1.6 HEWの終了
通常、HEWは[File->Exit]で終了します。終了時、使用していたワークスペースの内容を保存する

か確認するメッセージボックス（図 1.32）が表示されます。この終了時の設定や HEW再起動時の設
定は[Tools->Options...]で変更できます。詳しくは、「Hitachi Embedded Workshopユーザーズマニュ
アル」を参照してください。
なお、HDIや他のユーザ登録ツールは、HEWが終了しても連動して終了しませんので個別に終了

させてください。

図 1.32  HEW終了時の確認
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2. HDIチュートリアル

2.1 HDIを使ったデバッグ
HDI と共に使われるシミュレータ・デバッガの主な特徴を紹介するために、サンプルプログラムを

用いて説明します。

2.1.1 サンプルプログラム
このサンプルプログラムは、10個のランダムデータを昇順にソートした後、降順にソートする C

プログラムに基づいています。
サンプルプログラムでは、以下の処理を行います。

• main関数でソートするランダムデータを生成します。
• sort関数では main関数で生成したランダムデータを格納した配列を入力し、昇順にソートし
ます。

• change関数では、sort関数で生成した配列を入力し、降順にソートします。

サンプルプログラムは、インストールディスクの sort.cファイルで提供しています。コンパイルし
たバージョンのチュートリアルは、sort.absファイルで提供しています。

2.1.2 HDIの実行
HDI の機能をサンプルプログラムを用いて説明するため、HEWからではなく、HDI 単独で起動し

ます。

• HDI を実行するには、[HDI for SH series simulator]アイコンをダブルクリックしてください。

図 2.1 HDI for SH series simulatorアイコン

2.1.3 ターゲットの選択
HDI は複数のターゲットプラットフォームをサポートしています。現在のセッションのプラットフ

ォームを選択するように指示します。
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図 2.2　Select Sessionダイアログボックス

• このチュートリアルでは、SH1 Simulatorを選択し、[OK]ボタンをクリックしてください。

[File]メニューから [New Session…]を選択すれば、いつでもターゲットプラットフォームを変更で
きます。ただし、プラットフォームを１つしかインストールしていなければ、このメニューオプショ
ンは使えません。
シミュレータ・デバッガを正しく設定していれば、ステータスバーの"Link up"メッセージと共に、

Hitachi Debugging Interfaceウィンドウを表示します。次ページにウィンドウの機能を示します。
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図 2.3 Hitachi Debugging Interfaceウィンドウ

メニューバー HDIデバッガを使うための HDIコマンドへのアクセスを示します。

ツールバー 最もよく使う HDIコマンドのショートカットとして便利なボタンです。ツールボタ
ンは、各メニューごとにブロック化しています。ツールボタンの配置はクリック・ド
ラッグ操作により設定することができます。また、表示/非表示は [Setup]メニュー
の [Customize] サブメニューのうち [Toolbar] オプションで設定することができま
す。

ソースウィンドウ デバッグしているプログラムのソースを表示します。

ステータスバー シミュレータ・デバッガの状態やダウンロードの進捗状況を表示します。

ヘルプボタン HDIユーザインタフェースの特徴に関する文脈依存ヘルプを起動します。

2.1.4 メモリリソースの確保
次のステップでは、開発しているアプリケーションを動作させるためにメモリリソースの確保を行

います。

• [Memory]メニューから [Configure Map...]を選択し、現在のメモリマップを表示してくださ
い。
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図 2.4　Memory Mapダイアログボックス

[Add]ボタンをクリックすると、System Memory Resource Modifyダイアログボックスを表示します。

図 2.5　System Memory Resource Modify ダイアログボックスダイアログボックスダイアログボックスダイアログボックス

[Access type]には、以下の３つのアクセス種別の１つを指定できます。

アクセス種別 説明

Read 読み出しのみ可能

Write 書き込みのみ可能

Read/Write 読み出し/書き込み可能

本チュートリアルでは、H'00000000から H'00003FFFのメモリリソースを読み出し／書き込み可能
領域として確保してください。

• [Start address]フィールドに H'00000000、[End address]フィールドに H'00003FFF、[Access type]
を [Read/Write]に設定し、[OK]ボタンをクリックしてください。
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Memory Mapダイアログボックスは変更した範囲を表示します。

• [Close]ボタンをクリックしてダイアログボックスを閉じてください。

2.1.5 チュートリアルプログラムのダウンロード
• [File]メニューから [Load Program...]を選択して、Load Programダイアログボックスを開い
てください。

図 2.6　Load Programダイアログボックス

• [File name]に sort.absファイルの存在するディレクトリのパス名を入力するか、[Browse...]
ボタンをクリックしてください。[Browse...]ボタンをクリックすると Openダイアログボッ
クスが開くので、sort.absを選択後 [Open]ボタンをクリックしてください。

図 2.7　Openダイアログボックス（[Load Program...]）
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• Load Programダイアログボックスの [Open]ボタンをクリックしてください。

ファイルをロードすると、以下のダイアログボックスに、プログラムコードが書き込まれたメモリ
エリアに関する情報を表示します。

図 2.8　HDIダイアログボックス

• [OK]ボタンをクリックしてください。

2.1.6 ソースプログラムの表示
HDI では、ソースレベルでプログラムをデバッグできます。したがって、デバッグするときに、C

プログラムのリストをマシンコードと並べて見ることができます。そのためには、オブジェクトファ
イルに対応する Cソースファイルを読み込ませてください。

• [View]メニューから [Source…]を選択してください。
• ロードしたオブジェクトファイルに対応する Cソースファイルを選択してください。

図 2.9　Openダイアログボックス（[Source...]）



2.  HDIチュートリアル

43

• sort.cファイルを選択し、[Open]ボタンをクリックして Sourceウィンドウを表示してくださ
い。

図 2.10　Sourceウィンドウ（ソースプログラムの表示）

• 必要ならば、[Setup]メニューの [Customize]サブメニューから [Font]オプションを選択し、
コンピュータに合ったフォントとサイズを選択してください。

Sourceウィンドウは、最初はメインプログラムの先頭を表示しますが、スクロールバーを使ってプ
ログラムをスクロールし、他の部分を見ることができます。

2.1.7 PCブレークポイントの設定
Sourceウィンドウによって、ブレークポイントを簡単に設定できます。たとえば、以下のようにし

て sort関数のコール箇所にブレークポイントを設定します。

• sort関数コールを含む行の [BP]コラムをダブルクリックしてください。



2.  HDIチュートリアル

44

図 2.11　Source ウィンドウウィンドウウィンドウウィンドウ（ブレークポイントの設定）（ブレークポイントの設定）（ブレークポイントの設定）（ブレークポイントの設定）

sort関数コールを含む行に ●を表示し、そのアドレスに PCブレークポイントを設定したことを
示します。

2.1.8 トレース情報取得条件の設定
• [View]メニューから [Trace]を選択して、Traceウィンドウを開いてください。さらに、Trace
ウィンドウ上で右クリックしてポップアップメニューを表示し、[Acquisition...]を選択してく
ださい。

以下の Trace Acquisitionダイアログボックスを表示します。
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図 2.12　Trace Acquisitionダイアログボックス

• Trace Acquisitionダイアログボックスの [Trace start/Stop]を [Enable]に設定し、[OK]ボタン
をクリックしてトレース情報取得を有効にしてください。

2.1.9 パフォーマンス・アナリシスの設定
• [View]メニューから [Performance Analysis]を選択して、Performance Analysisウィンドウを開
いてください。さらに、Performance Analysisウィンドウ上で右クリックしてポップアップメ
ニューを表示し、[Add Range...]を選択してください。

以下の Performance Optionダイアログボックスを表示します。

図 2.13　Performance Optionダイアログボックス
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• Performance Optionダイアログボックスの [Function Name]に "sort(long*)"を設定し、[OK]
ボタンをクリックしてください。

Performance Analysisウィンドウの [Function]に " sort(long*)"を設定します。

図 2.14　Performance Analysisウィンドウ（設定）

• Performance Analysisウィンドウ上で右クリックしてポップアップメニューを表示し、
[Analysis Enabled]を選択して、パフォーマンス・アナリシス情報取得を有効にしてください。

• タイトルバーの[××××]をクリックしてウィンドウを閉じてください。

2.1.10 スタックポインタの設定
プログラムを実行するために、スタックポインタを設定してください。

• [View]メニューから [Registers]を選択して、Registersウィンドウを開いてください。
• スタックポインタ（R15）の値を変えるには、Registersウィンドウで [R15]に対する[Value]
コラムをダブルクリックしてください。

以下のダイアログボックスによって値を変更できます。

図 2.15　Registerダイアログボックス

• 本サンプルプログラムでは、H'4000を設定し、[OK]ボタンをクリックしてください。
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2.1.11 プログラムの実行
• プログラムを実行するには、[Run]メニューから [Go]を選択するか、またはツールバー上の

[Go]ボタンをクリックしてください。

図 2.16　Goボタン

プログラムはブレークポイントを設定したところまで実行します。プログラムが停止した位置を示
すために Sourceウィンドウ中でステートメントを強調表示します。また [Break=PC Breakpoint]メッ
セージをステータスバーに表示します。

図 2.17　Sourceウィンドウ（ブレーク状態）

HEWの Launch Debuggerボタン（｢1.5 HDIインタフェース｣を参照）から HDI を起動した場合、
Sourceウィンドウ中の [Source]コラムをダブルクリックすることにより、ソースウィンドウに表示し
ているソースファイルを HEWのテキストエディタで表示、編集することが可能です。
本チュートリアルのサンプルプログラムでは sort.cを HEWでコンパイル、リンクすることにより、

本機能が使用できるようになります。

System Statusウィンドウで停止要因が確認できます。
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• [View]メニューから [Status]を選択して、System Statusウィンドウを開いてください。さら
に、System Statusウィンドウのうち [Platform]シートを表示してください。

図 2.18　System Statusウィンドウ

これは、以下の実行内容を表示します。
① ブレークの原因は PCブレーク
② パイプラインリセットからの実行
③ GOコマンドでの実行命令数は600命令
④ パイプラインリセットからの実行サイクル数は1,472サイクル

Registersウィンドウでレジスタの値が確認できます。

• [View]メニューから [Registers]を選択してください。
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図 2.19　Registersウィンドウ

プログラム停止時の各レジスタの値を確認することができます。

2.1.12 トレースバッファの使い方
トレースバッファを使って、命令実行の履歴を知ることができます。

• [View]メニューから [Trace]を選択して、Traceウィンドウを開いてください。ウィンドウの
最上部までスクロールアップしてください。

• 必要ならば、[Setup]メニューの [Customize]サブメニューから [Font]オプションを選択し、
コンピュータに合ったフォントとサイズを選択してください。

図 2.20　Traceウィンドウ（トレース情報の表示）

トレースディスプレイの 0000000000サイクル（PIPELINE RESET）から main関数を実行したこ
とがわかります。
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2.1.13 トレースサーチの実行
最初に、Traceウィンドウ上で右クリックしてポップアップメニューを表示し、[Find...]を選択して、

Trace Searchダイアログボックスを開いてください。

図 2.21　Trace Searchダイアログボックス

サーチ項目 [Item]とサーチ内容 [Value]を設定して [OK]ボタンをクリックすると、トレースサー
チを実行します。該当するトレース情報があった場合、該当する最初の行を強調表示します。同じサ
ーチ内容 [Value]でトレースサーチを続ける場合は、Traceウィンドウ上で右クリックしてポップアッ
プメニューを表示し、[Find Next]を選択してください。次に該当する行を強調表示します。

図 2.22　Traceウィンドウ（サーチ結果）

2.1.14 ブレークポイントの確認
プログラムに設定した全てのブレークポイントのリストを Breakpointsウィンドウで確認すること

ができます。

• [View]メニューから [Breakpoints]を選択してください。
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図 2.23　Breakpointsウィンドウ

Breakpointsウィンドウによって、ブレークポイントの設定、新しいブレークポイントの定義、およ
びブレークポイントの削除ができます。

• Breakpointsウィンドウを閉じてください。

2.1.15 メモリ内容の確認
メモリブロックの内容を Memoryウィンドウで確認することができます。たとえば、ワードサイ

ズで main列に対応したメモリを確認する場合の手順を以下に示します。

• [View]メニューから [Memory…]を選択し、[Address]フィールドに "main"を入力し、
[Format]を "Word"に設定してください。

図 2.24　Open Memory Windowダイアログボックス

• [OK]ボタンをクリックして、指定したメモリ領域を示す Memoryウィンドウを開いてくださ
い。
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図 2.25　Word Memoryウィンドウ

2.1.16 変数の参照
変数の値をWatchウィンドウで見ることができます。

プログラムの始めに宣言した long型の配列 a を見る場合：

• Sourceウィンドウの a の左にカーソルを置いてください。
• Sourceウィンドウ上で右クリックしてポップアップメニューを表示し、 [Instant Watch...]を
選択してください。

以下のダイアログボックスを表示します。

図 2.26　Instant Watchダイアログボックス

• [Add Watch]をクリックし、Watchウィンドウに変数を加えてください。
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図 2.27　Watchウィンドウ（配列の表示）

また、変数名を指定して、Watchウィンドウに変数を加えることができます。

• Watchウィンドウ上で右クリックしてポップアップメニューを表示し、[Add Watch...]を選択
してください。

以下のダイアログボックスを表示します。

図 2.28　Add Watchダイアログボックス

• 変数 "max" をタイプし、[OK]ボタンをクリックします。

Watchウィンドウに、int型の変数 max を表示します。

図 2.29　Watchウィンドウ（変数の表示）

Watchウィンドウの配列 a の前にあるシンボル＋をダブルクリックすると、配列を拡張して各要
素を参照することができます。
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図 2.30　Watchウィンドウ（配列要素の表示）

2.1.17 プログラムのステップ実行
シミュレータ・デバッガは、プログラムのデバッグに有効な各種のステップメニューを備えていま

す。

メニュー 説明

Step In 各ステートメントを実行します（関数内のステートメントを含む）。

Step Over 関数コールを１ステップとして、ステップ実行します。

Step Out 関数を抜け出し、関数を呼び出したプログラムにおける次のステートメントで停止します。

Step… 指定した速度で指定回数分ステップ実行します。

プログラムのステップをデモンストレーションするために、アドレス H'00000038の sort関数ステ
ートメントまで実行していることを確認してください。
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図 2.31　Sourceウィンドウ（ステップ実行）

なお、Watchウィンドウのタイトルバーにある [◇◇◇◇] ボタンをクリックすると、Watchウィンドウ
は図 2.31のような位置へ自動的に配置します。

(1) [Step In]の実行

[Step In]はコール関数の中に入り、コール関数の先頭のステートメントで停止します。

• sort関数の中に入るために、[Run]メニューから [Step In]を選択するか、またはツールバー
の [Step In]ボタンをクリックしてください。

図 2.32　Step Inボタン
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図 2.33　Sourceウィンドウ（Step In）

• Sourceウィンドウの強調表示が、sort関数の先頭のステートメントに移動します。

(2) [Step Out] の実行

[Step Out]はコール関数の中から抜け出し、コール元プログラムの中の次のステートメントで停止
します。

• sort関数の中から抜け出すために、[Run]メニューから [Step Out]を選択するか、またはツー
ルバーの [Step Out]ボタンをクリックしてください。

図 2.34　Step Outボタン
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図 2.35　Sourceウィンドウ（Step Out）

• Watchウィンドウに表示した変数 a のデータを昇順にソートします。Watchウィンドウでは、
変更した変数の値を赤字で表示します。

• 次に[Step In]により、２ステップ実行してください。



2.  HDIチュートリアル

58

図 2.36　Sourceウィンドウ（Step Out→Step In）

• Watchウィンドウに表示した maxを、データの最大値に変更します。

(3) [Step Over] の実行

[Step Over]は関数コールを１ステップとして実行して、メインプログラムの中の次のステートメン
トで停止します。

• [Step Over]をデモンストレーションするために、change関数ステートメントまで２ステップ
実行してください。
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図 2.37　Sourceウィンドウ（Step Over実行前）

change関数中のステートメントを一度にステップ実行するために、[Run]メニューから[Step Over]
を選択するか、またはツールバーの [Step Over]ボタンをクリックしてください。

図 2.38　Step Overボタン
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図 2.39　Sourceウィンドウ（Step Over）

change関数の最後のステートメントを実行すると、Watchウィンドウに表示した変数 a のデータ
を降順に変更します。

2.1.18 ローカル変数の表示
Localsウィンドウを使って関数内のローカル変数を表示させることができます。例として、main

関数のローカル変数を調べます。この関数は、５つのローカル変数 a、j、i、min、maxを宣言してい
ます。

• [View]メニューから [Locals]を選択することによって Localsウィンドウを開いてください。
• ローカル変数が存在しない場合、Localsウィンドウは何も表示しません。
• [Run]メニューから [Step In]を選択して、もう１ステップ実行してください。
• Localsウィンドウは、ローカル変数とその値を表示します。

図 2.40　Localsウィンドウ



2.  HDIチュートリアル

61

• Localsウィンドウの配列 a の前にあるシンボル＋をダブルクリックし、配列 a の構成要素
を表示させてください。

• sort関数実行前と実行後の配列 a の要素を参照し、ランダムデータを昇順、降順にソートし
たことを確認してください。

2.1.19 パフォーマンス・アナリシスの確認
パフォーマンス・アナリシスの測定結果を Performance Analysisウィンドウで確認することができ

ます。

• [View]メニューから [Performance Analysis]を選択してください。

図 2.41　Performance Analysisウィンドウ（確認）

Performance Analysisウィンドウの [Cycle]には、sort関数の累計実行サイクルを、[%]にはプログラ
ム全体の実行サイクル数に占める sort関数の実行サイクル数の割合を表示します。

Performance Analysisウィンドウによって、パフォーマンス・アナリシス測定の許可または禁止、新
たにパフォーマンス・アナリシスを測定する関数の設定、および削除ができます。

• Performance Analysisウィンドウを閉じてください。

2.1.20 セッションの保存
終了する前に、今回のデバッグセッションを保存すれば、次回のデバッグセッションで同一の状態

からデバッグを再開することができます。

• [File]メニューから [Save Session]を選択してください。
• [File]メニューから [Exit]を選択して、HDI を終了させてください。
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