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(1)

(2)

"NEC Electronics" as used in this statement means NEC Electronics Corporation and also includes its 
majority-owned subsidiaries.
"NEC Electronics products" means any product developed or manufactured by or for NEC Electronics (as 
defined above).

Computers, office equipment, communications equipment, test and measurement equipment, audio
and visual equipment, home electronic appliances, machine tools, personal electronic equipment
and industrial robots.
Transportation equipment (automobiles, trains, ships, etc.), traffic control systems, anti-disaster
systems, anti-crime systems, safety equipment and medical equipment (not specifically designed
for life support).
Aircraft, aerospace equipment, submersible repeaters, nuclear reactor control systems, life
support systems and medical equipment for life support, etc.

"Standard":

"Special":

"Specific":
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PREFACE

Target Readers This manual is intended for user engineers who design and develop application systems
of the 78K Series.

Purpose This manual is intended for users to understand the functions of the SM78Kx in the
organization below.

Organization This manual consists of the following chapters:

• OVERVIEW
• STARTING AND TERMINATING
• ASSOCIATION WITH PM plus
• FUNCTIONS OF SM78Kx
• OPERATION
• WINDOW REFERENCE
• COMMAND REFERENCE

How to Use This Manual It is assumed that the readers of this manual have general knowledge of electrical
engineering, logic circuits, microcontrollers, C language, and assemblers.

For users who are using this manual for products other than SM78K0
→  The SM78K0 is treated as the representative product unless there are

differences in function.
As required, take the SM78K0 as other products in the SM78K Series.

To understand the functions of the 78K Series
→ Refer to Hardware User's Manual for each product.

To understand the instruction functions of the 78K Series
→ Refer to 78K Series Instructions User's Manual.

Conventions Data significance: Higher digits on the left and lower digits on the right
Note: Footnote for item marked with Note in the text
Caution: Information requiring particular attention
Remark: Supplementary information
Numerical representation: Binary … XXXX or XXXXB

Decimal ... XXXX
Hexadecimal … 0xXXXX

Prefix indicating the power of 2 (address space, memory capacity):
K (Kilo):  210 = 1024
M (Mega):  220 = 10242

G (Giga):  230 = 10243



User’s Manual  U16768EJ1V0UM 7

Related Documents Refer to the documents listed below when using this manual.
The related documents indicated in this publication may include preliminary versions.
However, preliminary versions are not marked as such.

Documents related to development tools (User's Manuals) (78K0 Series)

Document Name Document No.

IE-78K0-NS In-Circuit Emulator U13731E

IE-78K0-NS-A In-Circuit Emulator U14889E

IE-78K0-NS-PA Performance Board To be prepared

IE-78K0-NS-P01 I/O Board To be prepared

IE-78K0-NS-P02 I/O Board To be prepared

Operation U16629E

Assembly Language U16630E

RA78K0 Assembler Package

Structured Assembly Language U11789E

Operation U16613ECC78K0 C Compiler Package Ver. 3.50 or later

Language U16628E

ID78K0-NS Ver. 2.52 Integrated Debugger Operation U16488E

SM78K Ver. 2.52 Series System Simulator Operation This manual

PM plus Ver.5.10 U16569E

Documents related to development tools (User's Manuals) (78K0S Series)

Document Name Document No.

IE-78K0S-NS In-Circuit Emulator U13549E

IE-78K0S-NS-A In-Circuit Emulator U15207E

Operation U16656E

Assembly Language U16657E

RA78K0S Assembler Package

Structured Assembly Language U11623E

Operation U16654ECC78K0S C Compiler Package Ver. 1.50 or later

Language U16655E

ID78K0S-NS Ver. 2.52 Integrated Debugger Operation U16584E

SM78K Series Ver. 2.52 System Simulator Operation This manual

PM plus Ver.5.10 U16569E
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Documents related to development tools (User's Manuals) (78K4 Series)

Document Name Document No.

IE-78K4-NS In-Circuit Emulator U13356E

Operation U16708E

Assembly Language U15255E

RA78K4 Assembler Package

Structured Assembler Preprocessor U11743E

Operation U16707ECC78K4 C Compiler Package Ver. 2.40 or later

Language U15556E

ID78K4-NS Ver. 2.52 Integrated Debugger Operation U16632E

SM78K Series Ver.2.52 System Simulator Operation This manual

PM plus Ver.5.10 U16569E
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CHAPTER 1  OVERVIEW

CHAPTER 1  OVERVIEW

1. 1    Overview

The system simulator SM78Kx for the SM78K Series (hereafter referred to as the SM78Kx) is a software

tool developed for NEC Electronics's SM78K Series of 8-bit microcontrollers for embedded control.  This

software tool is intended to enable efficient debugging/simulation of user programs.  

The SM78Kx implements the functions of an emulator and target system by software.  

By preparing the SM78Kx on the host machine, therefore, data can actually be input to the user program

and the output resulting from execution of the user program can be displayed.  

As a result, the program can be logically debugged at an early stage, even before the emulator and target

system are ready.

The SM78Kx runs on a host machine that uses WindowsTM as the operating system and employs an

easy-to-understand, easy-to-use GUI (Graphical User Interface).  

The commands that are often used are displayed as buttons, so that they can be executed with a single

mouse click. In this way, an environment with excellent operability can be provided.  

1. 2    Features

The SM78Kx has the following features.  

(1) Source debugging

A C source program and source program in assembly language can be debugged.  

(2) Target-less evaluation

By simulating the operations of the target device, including those of the internal peripheral units and 

interrupt processing, as well as CPU operations, the logic of the user program can be debugged at an 

early stage, without an in-circuit emulator.

(3) Support of integrated debugging environment

The operability is similar to that of an in-circuit emulator.

(4) Various simulation functions provided

a) External components

By supplying standard "external components" such as LEDs, key matrixes, and motors that use the 

GUI, a dummy environment of the target system can be easily configured.  Data can be input to or 

output from the external components during simulation.  

b) configuring user system

The user logic block in the target system can be configured (programmed) by the user, by using the 

user open interface.
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c) Data input function

Data with timing information created with two types of input editors can be input during simulation.  The 

output result can be displayed on a timing chart.  

d) SFR event & action setting function

An interrupt can be generated at any time or data can be set by using an event set to a SFR or 

address.

(5) Monitor function (automatic display updating function when execution is stopped)

If execution of the user program is stopped, the values of the window displayed on the screen are 

automatically updated.  

(6) Saving/restoring debugging environment

The debugging environment including information on setting of breakpoints and events, downloading 

files, and display status and position of windows can be saved to a file (project file).  

By loading this project file, the debugging environment can be restored.  

(7) Function expansion by TIP (SM78K4 only)

By combining with a task debugger (RD) and system performance analyzer (AZ) that support TIP (Tool 

Interface Protocol), the efficiency of user program debugging using a real-time OS (RX) can be 

drastically improved.

(8) Batch execution by command and creation of custom window

A console window that allows batch processing on the command line and creation of the user's own 

custom window has been added.  

1. 3    System Configuration

The SM78Kx executes debugging/simulation by downloading the object file of the target device in the

load module format to the target memory of the SM78Kx.

The SM78Kx consists of a debugger part that has debugging functions and a simulator part that

simulates the operations of the target device and target system.

1. 3. 1    Example of system configuration

Figure 1-1 shows an example of the system configuration of the SM78Kx.  
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Figure 1-1　Example of SM78Kx System Configuration

1. 3. 2    Internal configuration of SM78Kx

The SM78Kx consists of the following:

•  Debugger

•  Simulator

When the SM78Kx is started, the main window of the debugger and the main window of the simulator are

automatically opened. (The main window of the simulator is displayed as a button on the Windows task

bar).  

Each window and dialog box are opened from these main windows.

1. 4     Operating Environment

The SM78Kx has the following hardware and software requirements:  

1. 4. 1    Hardware environment

(1)  Host machine

•  IBM PC/AT TM -compatible machine

1. 4. 2     Software environment

(1) Operating system (any of the following)

Windows98, Windows2000, Windows NTTM4.0, Windows Me, Windows XP Home Edition, Windows 

XP Professional  

Caution: Regardless of which of the OSs above is used, we recommend that the latest Service

Pack is installed.  

(2) Device file

The device file of the target device to be used.  
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1. 5    Notes on Source-Level Debugging

To perform source-level debugging, specify an option (-g option) to generate debug information when the

source file is compiled. (The -g option is specified by default.)  

If this option is not specified, the source file cannot be debugged at the source level.
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CHAPTER 2  STARTING AND TERMINATING

CHAPTER 2  STARTING AND TERMINATING

This chapter explains the procedure of starting and terminating the SM78Kx.  

2. 1     Starting

Start the SM78Kx as follows: 

1   Turn on the power to the PC.

2 Select [Start] -> [Program] -> [NEC Tools32] -> [SM78Kx] from the Windows start menu to start the

SM78Kx.  The Configuration dialog box will be opened.  

3 Set the items related to the operating environment of the SM78Kx in the Configuration dialog box.

After setting each item, click the <OK> button in the dialog box.  

Figure 2-1　Configuration Dialog Box

4 The Main window will be opened and the SM78Kx can be operated.  Mainly use this window for

debugging.  At the same time, the main window of the simulator "78Kx Simulator GUI" (Figure 2-3)

will be opened and displayed on the Windows task bar.  This window is used to perform simulator

operations, such as those related to peripheral simulation and external components.  
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Figure 2-2　Main Window

Figure 2-3　  78Kx Simulator GUI Window

2. 2    Terminating

Terminate the SM78Kx as follows:  

1 Select the [File] menu -> [Exit] on the Main window or the [File] menu -> [Exit from Simulator] on

the 78Kx Simulator GUI window.  The following Exit Debugger dialog box will be opened:   

Figure 2-4　Exit Debugger Dialog Box

If the above operation is performed while the user program is being executed, the dialog box shown in 

Figure 2-5 is opened.  

In this case, clicking the <Yes> button opens the Exit Debugger dialog box.  
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Figure 2-5　Message Box for Confirmation of Stopping Execution

2 To save the current debugging environment to a project file, click the <Yes> button.  

If the <No> button is clicked, all the windows are closed and the SM78Kx is terminated.  
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CHAPTER 3  ASSOCIATION WITH PM plus

This chapter explains the procedure and points to be noted when a function to associate the PM plus is

used.  

The SM78Kx can automatically perform a series of operations in development processes, such as

creating source files -> compiling -> debugging -> correcting source files, in association with the PM

plus.  

The operation explained in this chapter requires a PM plus(V5.00 or later).  

 Caution: If a load module file is created by using the Windows command prompt, the function to

associate the SM78Kx with the PM plus cannot be used.  

3. 1    Setting Build Mode

To debug the load module file created by the PM plus on the SM78Kx at the source level, build to output

symbol information for debugging must be performed to create a load module file.  This setting can be

performed by selecting [Debug Build] on the PM plus.  

3. 2    Registering Debugger to PM plus Project

The debugger to be used or the load module files to be downloaded can be specified for each project in

the PM plus.  

Select a debugger using the following procedure:

3. 2. 1    Selecting debugger

The procedure for selecting the debugger is as follows: 

Creating a new workspace

1 Select [File] menu -> [New Workspace...] on the PM plus.  

-> This opens the dialog box to create a new workspace using the wizard format.  

2 Creating the necessary settings for the workspace with the wizard, the [New Workspace - Step 7/8

(Select Debugger)] dialog box will be opened.  Specify [SM78Kx 78Kx System Simulator] in this

dialog box. 

-> For details of the setting, refer to the PM plus online help or user's manual.  

Using an existing workspace

1 Select [Tool] menu -> [Debugger Settings...] on the PM plus.  

-> The Debugger Settings dialog box will be opened.  

2 Specify [SM78Kx 78Kx System Simulator] and click the <OK> button in this dialog box.  

The SM78Kx is registered as the debugger of the active project.  

The SM78Kx icon is displayed on the toolbar of the PM plus.  
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3. 3    To Start SM78Kx from PM plus

The SM78Kx can be started from the PM plus as follows:

• Click the SM78Kx starting button on the toolbar of the PM plus.

• Select the [Build] menu -> [Debug] on the PM plus.  

• Select the [Build] menu -> [Build and Debug] on the PM plus.  

• Select the [Build] menu -> [Rebuild and Debug] on the PM plus.  

If the debugging environment of the SM78Kx is saved to a project file currently being used by the PM

plus, it will be started in the debugging environment saved in the project file.  

If the debugging environment of the SM78Kx is not saved to a project file being used by the PM plus, the

Configuration dialog box is opened.  At this time, the device type (Chip name) cannot be changed.  

3. 3. 1    Restoring debugging environment

The previous debugging environment can be restored by the following procedure when the SM78Kx is

started from the PM plus:  

1 Create a new workspace (project file : e.g., sample.prj) on the PM plus.  

Caution: In the SM78Kx and PM plus, the environment information is saved to a project file and

referenced.  The extension of the project file that can be used by the SM78Kx and PM

plus is prj.  For the information that is saved or restored by the project file, refer to the

online help or the user's manual of each product.

2 Start the SM78Kx from the PM plus.  Because a new project file is created, set items other than the

device type (Chip name) in the Configuration dialog box in the same manner as when only the

SM78Kx is started.  

3 Download the load module file to be debugged with the Download dialog box of the SM78Kx.  

4 Debug the load module file on the SM78Kx.

5 Click the <Yes> button on the Exit Debugger dialog box when the SM78Kx is terminated.  

-> The debugging environment is saved to the project file (sample.prj) for the PM plus when the

SM78Kx is terminated. (The debug environment can also be saved to the sample.prj file by

overwriting the project file).

6 When the SM78Kx is next started up after the sample.prj file is read by PM plus, the debug

environment at the point when the project file was saved is automatically restored.  

3. 4    Auto Load

If a bug is found while the load module file is being debugged by the SM78Kx, correct the source file

using the following procedure.  Compiling and re-downloading the file can be automatically executed (Refer

to "Auto load by correcting source code (p.23)").  

The load module is downloaded again to the SM78Kx by compiling and linking the file on the PM plus
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with the activated SM78Kx (refer to "Auto load by starting debugger (p.23)").  

3. 4. 1    Auto load by correcting source code

Correct the source file for auto load as follows:  

1  Open the source file to be corrected in the Source window.  Select [File] menu -> [Open] and

specify the file to be corrected on the SM78Kx (if the file is already open in the Source window, that

window is displayed in the forefront).  

-> The specified file will be opened in the Source window.  

2 Select [Edit] menu -> [Correct Source] on the SM78Kx.  

-> An editor will be opened and the specified source file will be read.  

3 Correct the source file on the editor.

4 Terminate the editor.

 Caution: The CPU reset is not performed when the load module file is automatically downloaded.

The debug window that was opened when the editor was called, and each event setting

will be restored.  If the previously used line or symbol has been deleted as a result of

correcting the source file, the following happens:

- A variable that was displayed is dimmed.

- The event mark of an event condition is displayed in yellow.

5 Select [Build] menu -> [Build and Debug], or [Build] -> [Rebuild and Debug] on the PM plus.  

3. 4. 2     Auto load by starting debugger

If the following operation is performed on the PM plus with the SM78Kx started, the load module will be

automatically downloaded to the SM78Kx.

• Selecting the [Build] menu -> [Build and Debug] on the PM plus.  

• Selecting the [Build] menu -> [Rebuild and Debug] on the PM plus.  

When downloading is completed, the CPU is automatically reset. 
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CHAPTER 4  FUNCTIONS OF SM78Kx 

This chapter explains the basic debugging functions and the original simulation functions of the SM78Kx.  

Simulation functions of SM78Kx

•  External Parts

•  Data Input Function

•  SFR Event & Action Setting Function

Debugging functions

•  Debugging functions of SM78Kx

•  Setting Debugging Environment

•  Program Execution Function

•  Event function

•  Break function

•  Trace function

•  Coverage Measurement Function

•  Snapshot Function

•  Stub Function

•  Register Manipulation Function

•  Memory Manipulation Function

•  Watch Function

•  Time Measurement Function

•  Load/Save Function

•  Real-Time internal RAM Sampling Function

4. 1    External Parts

The SM78Kx provides standard external parts that input/output data to/from peripheral I/O via a GUI,

enabling the configuration of a dummy target system.  
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Figure 4-1　Examples of External Parts of SM78Kx

The SM78Kx provides the following external parts:  

Table 4-1　External Parts of SM78Kx and Setting Dialog Boxes

External Component Contents

Button Can be connected to any pin.  By clicking the displayed button, a value 
can be input to the pin.
->Buttons window

Key matrix A key matrix can be connected to any pin, and data can be input using two 
or more keys. 
->Key Matrixes window

Built-in LCD The output state of the pin to which the built-in LCD controller/driver of the 
device selected for debugging is connected can be displayed with a 
picture or a character.
->LCDs window

Built-in FIP The output state of the pin to which the built-in FIP controller/driver of the 
device selected for debugging is connected can be displayed with a 
picture or a character.
->FIPs window

LED An LED can be connected to any pin, and the output from the pin can be 
indicated by lighting or extinguishing the LED.
->LEDs window

Level gauge Any value within a specified range can be assigned to a pin connected to 
an A/D converter.  
->Level Gauges window
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Note: To issue the buzzer sound, a sound board and a speaker are required.  

Remark: Some external parts cannot be selected, depending on the target device.

4. 1. 1    Creating external parts

External parts are created in the Parts window.  

Selecting the [Parts] menu in the Parts window or clicking a button on the tool bar opens a setting dialog

box.  The connection information on a external component and a pin can be specified in this dialog box.  

For details, refer to the explanation of each dialog box (e.g. Buttons window).  

7-segment LED Any 8 pins (7 pins for figures and 1 pin for decimal point) can be assigned 
to a 7-segment LED, with one pin assigned to the digit signal, and the 
display on the 7-segment LED can be changed by the value of each pin. 
When output from the pin assigned to the digital signal is active, the 7-
segment LED lights or turns off. 
->7seg LEDs window

DC motor A DC motor can be connected to any pin.  The output value from the pin is 
indicated by revolution or stoppage of the DC motor.  The total time for 
which the active value has been output is counted from the start of 
simulation and displayed.  
->DC Motors window

Buzzer Note A buzzer can be connected to any pin, and the output status can be 
indicated by the buzzer sound or a bitmap.  
->Buzzers window

Reset button By clicking the displayed reset button, the hardware reset can be 
performed.  

14-segment LED Any 15 pins (14 pins for figures and 1 pin for decimal point) can be 
assigned to a 14-segment LED, with one pin assigned to the digit signal, 
and the display on the 14-segment LED can be changed by the value of 
each pin.  
When output from the pin assigned to the digital signal is active, the 14-
segment LED lights or turns off.  
->14seg LEDs window

Internal interrupt button A button can be connected to any internal interrupt.  By clicking the 
displayed button, an internal interrupt can be generated.  
->Internal Interrupt Button window

Setting pull-up/down 
resistor

Whether a pin is connected to a pull-up/down resistor can be specified.  
->Pull-Up / Pull-Down window

Serial GUI The operation mode and I/O information of the serial interface can be 
displayed.  
->Serial GUI window

Table 4-1　External Parts of SM78Kx and Setting Dialog Boxes

External Component Contents
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Figure 4-2　Parts Window (With Menu Displayed)

4. 1. 2    I/O operation of external parts and displaying I/O result

External parts set in each dialog box are displayed in the Parts window and can be used as the pins of

signals during simulation.  By using a displayed external component, the result of input/output can be

checked or a value can be input to the simulator.  

For details on the I/O operation of each external component, refer to the explanation of the setting dialog

box of each external component.  Note that I/O operations can be performed with the Parts window in the

execution mode.  

4. 1. 3    Operation of external parts at CPU reset

Table 4-2 shows the operation of each external component when a CPU reset is generated from the

debugger.  

Table 4-2　Operation of External Parts at CPU Reset

External Component External Parts at CPU Reset

Button All buttons are inactive.  

Key All keys are not pressed.

LCD The entire screen is white. In the custom mode, all the statuses are "No 
display".

FIP The entire screen is white. In the custom mode, all the statuses are "No 
display".

LED All LEDs are inactive.  

Level gauge All level gauges are displayed in white.  

7/14segment LED The input value is 0.  The scroll thumb of the scroll bar is at the leftmost 
position.  The operating point of the dial is at the lower left part.  
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4. 1. 4    Editing in Parts window

The Parts window can be edited by operations such as moving components, drawing characters, lines,

and rectangles, and pasting the bitmap of an external component.  

To edit the Parts window, select [Mode] -> [Edit] form the menu bar on the Parts window.  As a result, the

Parts window is set in the placement mode and the window can be edited.  

In the placement mode, the mouse cursor changes to "+" and a window that indicates the mouse pointer

position by coordinates (x and y) pops up.  

For details on the editing, refer to the Parts window.  

4. 2    Data Input Function

The SM78Kx can input data during simulation that contains the timing information for input pins created

using two types of input editors.  In addition, the output result from the simulator can be saved to a file, or a

timing chart can be displayed.  

4. 2. 1    Creating/editing input data

A data file with timing information can be created and edited on the Input 0/1 Editor window or Input

timing Chart Editor window.  

(1) Input 0/1 Editor window

This window is used to set the input data of any pin by a numeric value in 1-bit units, at any timing.  A 

wait value (input timing) and a input data can be set by using a loop.  

DC motor All DC motors are inactive.  The total number of clocks is 0.  

Buzzer A buzzer is inactive.  

Internal interrupt button All buttons are not pressed.

Serial GUI Initialized

Table 4-2　Operation of External Parts at CPU Reset

External Component External Parts at CPU Reset
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Figure 4-3　 Input 0/1 Editor Window

(2) Input timing Chart Editor window

This window is used to set the input timing and input data on a timing chart.  Data can be set by setting 
a wait value (input timing) or a time axis.  

Figure 4-4　 Input timing Chart Editor Window

The created data is saved as an input data file.  Specify any of the following extensions and the timing 

of the wait value when saving the data:  
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4. 2. 2    Downloading input data file

An input data file is downloaded with the Down Load dialog box.  

Figure 4-5　Down Load Dialog Box

By downloading the input data file (.i_x), a signal input from an external source to the pin is set.  

Files of the same file name except the file identifier can be simultaneously downloaded and simulated.

Up to five files (including an event condition file) can be downloaded.  

A file can be downloaded at any time, except while the CPU is operating.  

The priority of the input data set later is higherNote.  

Note: If an input data file is downloaded while an external component for input is being

displayed, input from the input data file takes precedence.  If an external component for

input is displayed while an input data file is being downloaded, input from the external

component takes precedence.  

4. 2. 3    Processing when input data is not set

If a pin whose value is undefined because no description is made in the input data file (.i_x) and because

the pin is not pulled up is accessed during program execution, the value of the pin is initialized to 0.  In this

case, a default value message is displayed in the message area of the 78Kx Simulator GUI window.  

Table 4-3　Timing of Wait Value

Extension

.i_0 File in which the timing of data input is described at the execution timing of an 
instruction that accesses a certain pin.  
The set wait value in this file is ignored.

.i_1 The timing of the data input is described in CPU clock units in this file.  
The CPU clock unit and main clock unit are the same.

.i_2 The timing of the data input is described in units of 1/4 main clocks in this file.  

.i_3 The timing of the data input is described in units of main clocks in this file.
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Figure 4-6　78Kx Simulator GUI Window (With Message Displayed)

So that this message is not output, connect a pull-up/down resistor to the pin in advance in the Pull-Up /

Pull-Down window.  

Figure 4-7　Pull-Up / Pull-Down Dialog Box

4. 2. 4    Outputting data to file and displaying data

The output status can be output to a file with the Output Setting dialog box.  

If output of a timing chart is specified in the Output Setting dialog box, the Output Timing Chart window is

opened and the output status can be displayed on a timing chart.  

An identifier (.out) is automatically appended to the output file.  
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Figure 4-8　Output Timing Chart Window

In addition to the data output from a SFR, the data input to a SFR can also be saved to the output file, so

that the SFR status can be checked later.  

4. 3    SFR Event & Action Setting Function  

The SM78Kx can generate an interrupt at specified time after an event condition has been satisfied by

using an event set to a SFR or any address as a trigger.  It can also set data to any address, SFR, or pin,

and reflect this data during simulation.  

4. 3. 1    Setting event and action 

An event condition and the operation (action) to be performed after the event condition has been satisfied

are set in the SFR Event & Action window.  

Figure 4-9　SFR Event & Action Setting Dialog Box
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An event condition can be specified by any address, register name, access status, access size, data

condition, or mask condition.  By specifying the timing as an action, an interrupt can be generated or data

can be set in a specified area (an address, SFR, or pin).  

The set event condition and action are saved to an event condition file (.evn).  

4. 3. 2    Downloading event condition file

The set event condition file can be downloaded with the Down Load dialog box.  

Figure 4-10　Down Load Dialog Box

By downloading the event condition file (.evn), the event is registered to the simulator, and the event can

be checked during simulation.  

4. 4    Debugging functions of SM78Kx

The debugging functions of the SM78Kx are almost equivalent to those of the ID78Kx-NS, but there are

slight differences because the SM78Kx does not use an in-circuit emulator and implements debugging by

software.  

(1) Mapping function

The SM78Kx virtually manages a contiguous memory space the same as that of the target device 

specified in the Configuration dialog box, by securing an alternate memory on the host machine.  

Consequently, the size of the internal ROM/RAM area can be changed or any memory area can be 

mapped as an emulation ROM/RAM area.  

Figure 4-11 shows the target memory space if the µ PD78001 is specified in the Configuration dialog 

box as the CPU to be used.  
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Figure 4-11　Memory Space Managed by SM78Kx (With µ PD78001)

(2) Event function

The following features are available:

•  Event conditions of the same name can be used for multiple various event conditions.  

•  Setting external sense data is invalid.

•  A pass count can be set.

(3) Break function

The following features are available:

•  Software break event conditions cannot be set.

•  Up to 64 break event conditions can be set

(4) Timer function

The following features are available:

•  Eight timer event conditions can be set.

•  The average, maximum, minimum, and total execution time of a zone specified by a timer event
condition can be measured.

•  The maximum execution measurement time is about 7 minutes 9 seconds (resolution: 0.1 us).

(5) Trace function

The following features are available:

•  Trace capacity can be specified (0 frame to 16M frames).

•  Block information is displayed.
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•  Types of trace modes are displayed.
A: All trace or section trace
Q: Qualify trace
S: Step execution trace

•  Branch source address is displayed.

4. 5    Setting Debugging Environment

Set a debugging environment with the Configuration dialog box that is opened when the debugger is

started, or the Extended Option dialog box or Debugger Option dialog box.  

By creating a file (project file) to which the current debugging environment is saved during debugging,

and loading this file, the debugging environment when the project file is saved can be restored.  

To manipulate the project file, use the Project File Save dialog box and Project File Load dialog box.  

After the project file has been loaded, the size and position of the displayed window are returned to the

previous size and status (refer to "Contents Saved to Project File (p.96)").  

To load the project file when starting up the debugger, press the <Project...> button in the Configuration

dialog box.  It can also be specified that the project file is automatically loaded each time the debugger is

started up (refer to "To automatically load a project file").  

4. 6    Program Execution Function

The program execution function is used to start execution of the user program by the CPU and operation

of the tracer.  

These functions can be executed by selecting the [Run] menu or the corresponding function button, and

the execution formats are classified into real-time execution and non-real-time execution. 

4. 6. 1    Real-time execution function

The following real-time execution functions are available:

• [Go]

• [Ignore break points and Go]

• [Start From Here] (Start function)

• [Go & Go]

• [Come Here] (Come function)

• [Restart]

(1) [Go]

The user program is executed starting from the address indicated by the current PC register and is 

stopped if a set break event condition is satisfied.  Each analyzer prepares for operation as soon as 

execution of the user program is started, and is executed or stopped by a condition set as an event 

condition (break event condition or trace event condition).  
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(2) [Ignore break points and Go]

This command executes the user program starting from the address indicated by the current PC 

register.  Execution of the user program continues, ignoring set breakpoints.  

(3) [Start From Here] (Start function)

This command executes the user program starting from the specified address. Execution of the user 

program is stopped when a set break event condition is satisfied.  

(4) [Go & Go]

This command executes the user program starting from the address indicated by the current PC 

register. When the set breakpoint conditions are realized, execution of the user program is paused, 

and after the contents of the various windows have been updated, execution of the user program is 

resumed from the address where execution was paused. This operation is repeated until the user 

executes [Stop]. 

(5) [Come Here] (Come function)

The user program is executed from the address indicated by the current PC register to the address 

selected in the line/address display area of the Source window or the Assemble window, and then a 

break occurs.

While the user program is being executed, the break event currently set does not occur.

(6) [Restart]

The CPU is reset and the user program is executed starting from address 0.  

This is the same operation as "resetting the CPU before execution of the user program and executing 

[Go]".  

4. 6. 2    Non-real-time execution function

The following non-real-time execution functions are available:

• [Step In]

• [Next Over]

• [Slow Motion]

(1) [Step In]

The operation differs depending on whether this function is executed in the Source window or the 

Assemble window. 

In the Source window

Step execution of one line of the source text is performed starting from the current PC register value 

and the contents of each window are updated.  

In the Assemble window

One instruction is executed from the current PC register value and the contents of each window are 

updated.  
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(2) [Next Over]

The operation differs depending on whether the instruction to be executed is the call/callt/callf 

instruction or another instruction. 

call/callt/callf instruction

Next step execution is performed, assuming the function or subroutine called by the call/callt/callf 

instruction is one step. (Step execution continues until the nesting level becomes the same as when 

the call/callt/callf instruction was executed.) 

Instruction other than call/callt/callf

The same processing as [Step In] is performed. 

(3) [Slow Motion]

Step execution of one line is performed from the address indicated by the current PC register value in 

the source mode.  In the instruction mode, step execution of one instruction is performed. The contents 

of each window are updated each time step execution is performed.  This operation is repeated until 

the user executes [Stop].  

4. 7    Event function

An event is a specific status of the target system during user program execution, such as "address

0x1000 is fetched" or "data is written to address 0x2000".  

The SM78Kx uses an event to trigger an action of functions such as break and trace functions.  An event

function is used to set, delete, and reference a specific status of the target system that triggers an action

(debugging action) as an event condition.  

4. 7. 1    Using event function

So that an action that is triggered by an event function in accordance with the user's debugging aim, the

following various event conditions must be set.  

Table 4-4　Various Event Conditions

Set Condition Setting Dialog Box Contents

Break event Break dialog box Condition in which the execution of the user program or 
the operation of the tracer is stopped.  

Trace event Trace dialog box Condition in which the process of user program 
execution is saved to the trace memory.  

Snapshot event Snap Shot dialog box Condition in which the timing of executing a snapshot is 
specified.  
The following three snap data items can be registered:
- Register value
- SFR value
- Memory contents
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These various event conditions are set independently as an "Event condition" or "Event link condition", or

as a combination of these.  To use the event function of the SM78Kx, therefore, first create the necessary

"Event condition" and "Event link condition", and set the various event conditions shown in the Table 4-4 by

using these conditions.  

4. 7. 2    Event condition

Create an event condition in the Event dialog box.  

Set an address condition, status condition, and data condition in this dialog box.  Specify a combination of

these as one event condition and name and register this event condition.  The registered event condition

can be used to set various event conditions.  However, the number of event conditions that can be set is

limited.  

The event condition that is created when a breakpoint is set in the Source window or the Assemble

window can also be used (Breakpoint setting/deletion function (p.134)).  

4. 7. 3    Event link condition

An event link condition specifies sequential constraints for each event, so that two or more events are

treated as a single event.  

To create an event link condition, use the Event Link dialog box.  

By arranging already registered event conditions in this dialog box, one event link condition can be

named and registered.  The registered event link condition can be used to set various event conditions in

the same manner as the event condition.  However, the number of event conditions that can be set is

limited.

4. 7. 4    Setting of various event conditions

Various event conditions listed in Table 4-4 are individually created in the corresponding dialog box.  

To create various event condition, drag and drop the event icon of an event condition or event link

condition registered on the Event Manager to the condition area of each setting dialog box.  

The created various event condition is set by clicking the <Set> or <OK> button in the setting dialog box.

The mark of the event that has been set is displayed in red.  After the event has been set, a debugging

action occurs as various event condition.  

Up to 256 various event conditions can be registered.  The number of various event conditions that can

Stub event Stub dialog box Condition in which the timing of inserting the program is 
specified when the stub function is used.  
(To return from a specified function if a stub event 
occurs, be sure to describe the RETB instruction in the 
function.) 

Timer event Timer dialog box Condition in which the timing of starting and stopping 
time measurement is specified when zone 
measurement is performed.  

Table 4-4　Various Event Conditions

Set Condition Setting Dialog Box Contents
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be "set" differs depending on the various event condition (refer to "Table 6-30  Maximum number of Events

Usable for Event Conditions (p.254)").  

4. 8    Break function

The break function is used to stop execution of the user program by the CPU and operation of the tracer.  

The following types of break functions are available:

• Event detection break

• Break by Come function

• Break on satisfaction of condition of step execution

• Forced break

• Fail-safe break

Caution: The event detection break  are not performed when [Come Here], [Step In], [Return

Out], or [Next Over] described in "Program Execution Function" is executed.  

(1) Event detection break

Event detection break is a function used to stop execution of the user program by detecting a set break 

event condition.  This break is valid for [Go], [Go & Go], [Start From Here], and [Restart].  

In the case of [Go & Go], however, the contents of each window are updated and the user program is 

executed again after the event detection break has occurred.  Set a break event as follows:

•  Set as an execution event in the Source window or Assemble window (refer to "Breakpoint setting/
deletion function (p.134)").  

•  Set in the Break dialog box.

(2) Break by Come function

The Break by Come function is used to stop the user program that is executed by the [Come Here] 

command, by detecting an address specified in the Source window or Assemble window.  When 

execution of the user program has been stopped, the breakpoint by the Come function is eliminated.  

While the user program is being executed by using this function, a break event that has been set does 

not occur.  

(3) Break on satisfaction of condition of step execution

Break on satisfaction of condition of step execution is a function used to stop execution of the user 

program when the end condition of each command ([Step In], [Next Over], [Return Out], and 

[Slowmotion]) is satisfied.  

Because one instruction is executed, stopped, and the condition is confirmed at one time, the 

processing time is longer than that of real-time execution.  

(4) Forced break

Forced break is a function used to forcibly stop execution of the user program.  It is valid for all the 
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program execution commands.  Force break includes the following:

•  [Stop] command: Forcibly stops execution of the user program.  

(5) Fail-safe break

A fail-safe break is a function for forcibly stopping the user program when the user program has 

executed a prohibited action on the memory and registers.  

The types of fail-safe break functions are as follows: 

Note that if a fail-safe break occurs, there may be a problem with the user program or the set 

environment of the SM78Kx may be wrong.  

4. 9    Trace function

The trace function is used to save the history of the data indicating the execution process of the user

program to the trace memory.  

The trace data saved to the trace memory can be checked in the Trace window.  

The item to be displayed in the Trace window can be selected in the Trace Data Select dialog box.  

To use the trace function, check that the trace function is valid by selecting the [Option] menu -> [Tracer

ON].  The trace function is valid in the default status, and all data is unconditionally traced (unconditional

trace) when the program is executed.  

4. 9. 1    Operation of trace

The trace memory of the SM78Kx is a ring buffer with a capacity of 4K frames.  The frame size can be

changed in the Extended Option dialog box.

The operation of the tracer differs as indicated in (1) to (3) below, depending on the style of execution of

the user program.  

(1) Operation during real-time execution

The operation of the tracer differs depending on the specified trace mode.

Non-map break This break occurs if an attempt is made to access a non-map area. 

Write-protect break This break occurs if an attempt is made to write to memory that must 
not be written to, such as ROM.  

SFR Illegal access break This break occurs if an attempt is made to access SFR illegally.  

Stack Overflow This break occurs as the result of stack overflow. 

Relocation Break This break occurs if a location instruction different from the default 
setting was executed.

Uninitialize Mem read This break occurs if an attempt to read non-initialized memory is 
made.

Security Protect This break occurs if an attempt is made to access to a security 
protection area.
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These trace modes can be set by selecting the [Run] menu -> [Conditional Trace /Unconditional 

Trace].  

(2) Operation during Step In execution

The tracer operates every step execution, and trace data of one step is successively added to the trace 

memory.  

(3) Operation during Next Over execution

The operation of the tracer differs depending on the instruction to which Next Over is to be executed.  

4. 9. 2    Trace condition setting function

The following setting types of trace condition are available:  

(1) Setting trace mode

Two trace modes, unconditional trace and conditional trace, are available.

(2) Setting of tracer control mode

The tracer has a ring structure.  

The following operation modes of the tracer can be selected from the [Run] menu:

All trace
(Unconditional trace)

Trace is started when real-time execution of the program is specified, 
and ends when a break occurs.  

Conditional trace Trace is started or stopped by the condition set in the Trace dialog 
box (if a break occurs while a trace is being executed, however, trace 
is stopped immediately).  

Table 4-5　Operation of Tracer (During Next Over Execution)

Instruction Tracer Operation

call/callt/callf instruction The call/callt/callf instruction and the subroutine that was called are 
traced.

Other instructions The same operation as that during Step In execution is performed.

Non-Stop Goes around the trace memory and overwrites data from the oldest frame 
(default).  

Full Stop Goes around the trace memory and then stops the tracer.

Full Break Goes around the trace memory and then stops the tracer and program 
execution.

Delay Trigger Stop Traces data by the number of delay count frames and stops the tracer 
when a delay trigger event has occurred. 

Delay Trigger Break Traces data by the number of delay count frames and stops the tracer and 
program execution when a delay trigger event has occurred. 
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(3) Setting trace event condition

A trace event condition triggers starting/stopping trace execution when a conditional trace is set.  

A trace event condition is set in the Trace dialog box.  

The following types of trace event conditions can be specified: 

4. 10    Coverage Measurement Function 

Coverage is a function used to record the status (such as execution, read, and write) for each address

when the user program is executed.  

Coverage measurement can be performed by selecting the [Option] menu -> [Coverage ON], and the

status of each address is recorded in the coverage memory by executing the program.  

The coverage results can be checked in the Coverage window.  This window displays the results of

coverage executed in the 1 MB space specified in the Coverage-Address dialog box.  

The efficiency of the coverage can be checked in the Coverage-Efficiency View dialog box that is opened

by clicking the <View> button on the Coverage-Condition Setting dialog box.

4. 11    Snapshot Function 

Snapshot is a function used to save the contents of registers, memory, and SFR to the trace memory as

snap data while the user program is being executed.  

A snap event condition specifies the trigger by which a snapshot is to be executed.  

The snap event condition can be set in the Snap Shot dialog box.  

The following snap data can be collected:  

• Register value (general-purpose register, control register)

• SFR value

• Memory contents

One snap event condition can specify collection of up to 16 snap data.

Section trace Executes a trace between two specified conditions (in a specific zone).  
A section trace (zone trace) can be executed by setting a trace start event 
and trace end event and executing a conditional trace.  

Qualify trace Executes a trace only when a condition is satisfied.  
If two or more events are set as qualify trace events, a qualify trace can be 
executed by executing a conditional trace.  
A qualify trace can be executed by setting a qualify trace event and 
executing a conditional trace.  

Delay trigger trace Executes a trace by the number of delay counts after a condition has been 
satisfied.  
A delay trigger trace can be executed by setting a delay trigger event 
condition, setting a delay count in the Delay Count dialog box, and 
executing a conditional trace.  
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4. 12    Stub Function

The stub function is used to execute the user program (sub-program) that has been downloaded or

written by online assembly to a vacant memory area in advance when an event occurs.  

A stub event condition is a trigger by which the stub function is to be executed.  The snap event condition

can be set in the Stub dialog box.  

Append the RETB instruction to the end of the sub-program that is executed when a stub event occurs,

otherwise, malfunction may occur.  

Use the stub function in the "after" break mode.  If it is used in the "before" break mode, only the sub-

program is repeated.  

Figure 4-12　Flow of Stub Function

If stub function is not used

 (1) and (2) are executed.

If stub function is used

1 (1) is executed.

2 A stub event occurs in (3) and a break occurs.  

3 The simulator fabricates a call stack with the present PC in (4), and rewrites the PC value to the

entry address of the sub-program.  

4 (5) is executed.

5 Execution is returned to the main program by the RETB instruction at the end of the sub-program in

(6).  

4. 13    Register Manipulation Function

The register manipulation function is used to display or change the contents of the general-purpose

registers, control registers, and SFR.  

This function can be used in the Register window or SFR window.  To change the register to be displayed

Main program

Sub-program

RETB instruction

(3)
(4)

(1)

(2)

(6)

(5)
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in each window, use the SFR Select dialog box.  

A user-defined I/O port can be displayed or changed by registering it to the Add I/O Port dialog box.    

4. 14    Memory Manipulation Function

As a memory manipulation function, the memory contents can be displayed or changed by using

mnemonic codes, hexadecimal codes, and ASCII codes.  

This function can be used in the Memory window or Assemble window.  The contents of memory can be

copied, initialized, and compared.  

4. 15    Watch Function

Data (variable) values can be checked or changed in the Watch window.  

Local variables can be checked or changed in the Local Variable window.  

The contents of a variable value can be easily referenced in the Source window or Assemble window by

placing the mouse cursor on the selected variable (balloon watch function).  

4. 16    Time Measurement Function

The time measurement function is used to measure the full execution time from the start of execution of

the user program to the occurrence of a break (or the execution time of the user program in a specific zone

by using a timer event)execution time for the section that is subject to section trace.  

A timer event condition specifies the trigger by which time measurement is started or stopped.  Set a

timer event condition in the Timer dialog box.  The time from the start of execution of the user program to

the occurrence of a break can be easily measured by using the Run-Break event registered in advance.

To use the timer function, select the [Option] menu -> [Timer On] to set the timer to ON.  If the timer is set

to OFF, the timer does not operate.  However, the Run-Break event is not affected regardless of whether the

timer is set to ON or OFF.  

To stop the timer currently in operation during simulation, select the [Run] menu -> [Timer Stop].  To

operate the timer when it is stopped, select the [Run] menu -> [Timer Start].  These two menus are toggled

and alternately displayed depending on the current timer status.

4. 17    Load/Save Function

The load/save function is used to load/save each file. 

The SM78Kx loads/saves each file individually.  

These three types of files can be handled: 

view files File recording the screen information when it is saved.  By loading this file, a 
reference file is opened in the Source window.  

Information file File recording the set data and debugging environment as information on the 
user program and debugger.  
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4. 17. 1    View files

The list of the view files to be handled is shown below: 

These files can be manipulated in the View File Load dialog box and View File Save dialog box.  

4. 17. 2    Information files

The list of the information files to be handled is shown below.  

Environment files File recording the window information.  

Table 4-6　 List of View Files

File Type Contents

Source Text (*.SVW) Source window view file
Records the source text in the Source window.  

Assemble (*.DIS) Assemble window view file
Records the assembly information in the Assemble window.  

Memory (*.MEM) Memory window view file
Records the memory information in the Memory window.  

Register (*.RGW) Register window view file
Records the register information in the Register window.  

Local Variable (*.LOC) Local Variable window view file
Records the local variable information in the Local Variable window.  

Stack Trace (*.STK) Stack Trace window view file
Records the stack trace information in the Stack Trace window.  

Trace (*.TVW) Trace window view file
Records the trace information in the Trace window.  

Watch (*.WCH) Watch window view file
Records the watch information in the Watch window. 

SFR (*.SFR) SFR window view file
Records the SFR information in the SFR window.

Coverage (*.COV) Coverage window view file
Records the coverage information in the Coverage window.  

Console (*.LOG) Console window view file
Records the information in the Console window.  

Table 4-7　 List of Information Files

File Name (Extension) Contents Dialog Box

Object file
(*.HEX)

Stores the object codes of the user 
program.

Download dialog box,
Upload dialog box

Load module file
(*.LNK, .LMF)

Stores the object codes, symbols, and 
source information of the user program.  

Download dialog box

Project File
(*.PRJ)

Stores the debugging environment  Project File Load dialog box,
Project File Save dialog box
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A project file sets the display information, size, and display position of a window or dialog box, and

restores the debugging environment to the previous status (when the project file was saved) when it is

loaded.  

4. 17. 3    Environment files

The list of the environment files to be handled is shown below: 

These files can be manipulated in the Environment File Load dialog box and Environment File Save

dialog box.  

4. 18    Real-Time internal RAM Sampling Function

The following real-time RAM sampling function is available.

• Real-time internal RAM sampling function

The real-time RAM sampling function is used to read and display the memory contents, even during user

program execution, if a variable allocated to a range in which the memory contents can be read, or the

memory contents are displayed.  

This function can be checked in the Watch window or Memory window.  

Settings related to this function are performed in the Extended Option dialog box.  

Binary file
(*.BIN)

Records data in binary format.  Download dialog box,
Upload dialog box

Coverage result file
(*.CVB)

Stores the coverage results. Download dialog box,
Upload dialog box

Table 4-7　 List of Information Files

File Name (Extension) Contents Dialog Box

Table 4-8　Types of Environment Files Handled

File Name (Extension) Contents

Watch environment file
(*.WCH)

Stores the watch setting contents of the Watch window.  

SFR environment file
(*.OR)

Stores the SFR setting contents of the SFR window.  

Event environment file
(*.EVN)

Stores the event setting contents of the Event Manager.  
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CHAPTER 5  OPERATION

This chapter explains the flow of basic debugging operations using the SM78Kx and the following

functions:

• Flow of Debugging Operations

• Active Status and Static Status

• Jump Function

• Trace Result with Linking Window

5. 1    Flow of Debugging Operations

(1) Setting debugging environment

Prepare for debugging.

-> Configuration dialog box

Download a load module file to be debugged.

-> Download dialog box

(2) Displaying source program

By downloading a load module file with debug information, the corresponding source file is 

automatically displayed.  

-> Source window

(3) Displaying disassemble result

The disassembled result of the downloaded user program is displayed.  

-> Assemble window

(4) Setting breakpoint

Breakpoints can be set easily in the Source window, Assemble window, and Watch window.  

-> Breakpoint setting/deletion function

-> To set a breakpoint for read/write access to a variable

(5) Setting event

Register event conditions and event link conditions.

-> Event dialog box, Event Link dialog box

Setting of various event conditions

Set a various event condition by using the Event Manager or an event icon in the event manager area 

on each various event setting dialog box.  

Each various event condition corresponds to the following various event setting dialog box.  

Break event condition -> Break dialog box

Trace event condition -> Trace dialog box

Snap event condition -> Snap Shot dialog box 
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Stub event condition -> Stub dialog box

Timer event condition -> Timer dialog box

Checking setting status of various event conditions

-> Event dialog box or the event manager area in each various event setting dialog box

(6) Executing user program

By executing the user program, the PC advances to the set breakpoint, break event, or forced 

breakpoint (refer to "Program Execution Function (p.35)").

Use the execution control button or [Run] menu to execute the user program.  

(7) Checking trace data

-> Trace window

(8) Editing, checking, and changing memory contents

-> Memory window, Memory Copy dialog box, Memory Fill dialog box, Memory Compare dialog box, 

Memory Compare Result dialog box

(9) Registering, checking, and changing variable value

-> Watch window, Quick Watch dialog box, Add Watch dialog box, Change Watch dialog box, Local 

Variable window

(10) Checking stack contents

-> Stack Trace window

(11) Checking and changing of registered contents of register value

-> Register window

The value of the PC register can also be checked in the Source window and Assemble window.

(12) Checking and changing SFR value

-> SFR window, SFR Select dialog box

(13) Registering, checking, and changing user-defined I/O port value

-> Add I/O Port dialog box, SFR window

(14) Changing mnemonic and executing online assembly (Assemble window only)

-> Assemble window, Source window

(15) Checking execution time of user program

-> Timer dialog box, Timer Result dialog box, Trace window

(16) Checking coverage measurement result

-> Coverage window, Coverage-Clear dialog box, Coverage-Condition Setting dialog box, Coverage-
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Efficiency View dialog box

(17) Searching character string in each window

By clicking the < Search...> button in the window in which searching is to be executed, the following 

types of searching dialog boxes are opened:

Source Search dialog box, Assemble Search dialog box, Memory Search dialog box, Trace Search 

dialog box, Coverage Search dialog box

(18) Manipulating view file

-> View File Save dialog box, View File Load dialog box

(19) Uploading memory contents and coverage result

-> Upload dialog box

(20) Saving debugging environment to file

-> Project File Save dialog box, Environment File Save dialog box

(21) Organizing dummy target system

Set or display external parts (such as buttons and LEDs connected to pins).  

-> Setting dialog box of each part, Parts window

(22) I/O data of pin during simulation

a) Creating and editing input data

-> Input 0/1 Editor window, Input timing Chart Editor window

b) Downloading input data

-> Down Load dialog box

c) Outputting output data to file and displaying data

-> Output Setting dialog box, Output Timing Chart window

(23) Taking action after satisfaction of event condition

a) Setting event and action (creating event condition file)

   -> SFR Event & Action window

b) Downloading event condition file

   -> Down Load dialog box

(24) Terminating SM78Kx

-> Exit Debugger dialog box

5. 2    Active Status and Static Status

The Source window, Assemble window, and Memory window, and Coverage window have the following

two window statuses:
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Because two or more static windows can be opened, the current status of the windows can be temporarily

held.  

5. 3    Jump Function

The jump function is used to jump to Source window, Assemble window, or Memory window, or Coverage

window from a jump pointer that is the line or address on which the cursor is placed, and display the

contents of the jump destination window from the jump pointer.  

You can jump among the above windows, or from Trace window, Stack Trace window, Event Manager,

and Register window to the above windows.  

Jump method

1 Move the cursor to the line or address that is to be used as the jump pointer, on the window from

which jumping is possible (select an event icon on the Event Manager).  

2 Select the following menu item to which execution is to jump from the [Jump] menu.  

Source window->Select [Source].

Assemble window->Select [Assemble].

Memory window->Select [Memory].

Coverage window->Select [Coverage]. 

Caution: If a program code does not exist on the line at the cursor position, the first address of

the line with a program code above or below that line is used as the jump pointer.  

Details of jump source address

To jump from the following windows, the jump destination is as follows:

•  To jump from the Trace window to the Memory window or Coverage window, the jump source
address differs depending on the cursor position in the trace result display area.  

Active status The display position and contents of the window in the active status are 
automatically updated in association with the current PC value.  
This window is also the jump destination of the jump function.  If this window is 
linked with the Trace window, the contents displayed in the active window are 
updated in association with the Trace window.  Only one window can be opened 
in the active status.  
Select this status by the [Window] menu.  

Static status The display position of the window in the static status does not move in 
association with the current PC value, but the displayed contents are updated.  
The static window is not used as the jump destination of the jump function.  In 
addition, it is not linked with the Trace window.  
If an active window is already open, the next window is opened in the static 
status.  Two or more static windows can be opened at the same time.  
Select this status by the [Window] menu.  

If the cursor is at an access address, access data, or access 
status 

-> Access address 

Other than above -> Fetch address 
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•  To jump from the Register window, move the cursor to a register value.  

•  To jump from the Stack Trace window, the jump destination is as follows:  

[With current function]

•  If the jump destination is the Source window -> Jumps to the current PC line.  

•  If the jump destination is a window other than the Source window -> Jumps to the current PC
address.  

[With function other than current function]

•  If the jump destination is the Source window 
-> Jumps to the line that calls a nested function.

•  If the jump destination is a window other than the Source window
-> Jumps to the address next to the instruction that calls a nested function.

5. 4    Trace Result with Linking Window

By linking Trace window with each window (Source window, Assemble window,  Memory window, or

Coverage window), the corresponding part can be displayed on the linked window, by using the address at

the cursor position on the Trace window as a pointer.  

If the cursor is moved on the Trace window, the corresponding part on the linked window is highlighted or

indicated by the cursor position.  

To link a window

1 Set the Trace window as the current window.  

2 Select a window to be linked with the [View] menu -> [Window Synchronize].  

Source window  ->Select [Source].

Assemble window  ->Select [Assemble].

Memory window  ->Select [Memory].

Coverage window  ->Select [Coverage]. 

3 Move the cursor to the line to be linked in the trace result display area of the Trace window.  

4 Using the address of the line selected in 3 as a pointer, the corresponding part is highlighted (or

indicated by the cursor position) in the display area of the window selected in 2.  

Caution: The linking source address differs as follows depending on the cursor position in the

trace result display area if the Memory window or Coverage window is linked.  

Access address, access data, access status -> Access address

Others -> Fetch address

When the Source window or Assemble window is linked, the fetch address is always

used as the pointer.  

To jump to the Source window or Assemble window -> Fetch address 
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CHAPTER 6  WINDOW REFERENCE 

This chapter explains the details of the window/dialog box functions of the SM78Kx.

6. 1    Window List

Table 6-1 and Table 6-2 lists the windows of the SM78Kx.

Table 6-1　SM78Kx Window List 

Window Name Contents

Main window (refer to p.57) This window is displayed first, when the debugger is started.  
It controls execution of the user program.  Various windows are 
opened from this window.

Configuration dialog box (refer to p.77) Displays and sets the debugger operation environment.

Extended Option dialog box (refer to 
p.82)

This dialog box is used to display and set the extended options of the 
debugger.

Debugger Option dialog box (refer to 
p.86)

Displays and sets options.

Font dialog box (refer to p.94) Displays the types of fonts displayed in the Source window and sets 
the size of the font.

Project File Save dialog box (refer to 
p.96)

Saves the debug environment.

Project File Load dialog box (refer to 
p.99)

Loads the debug environment.

View File Save dialog box (refer to 
p.101)

Saves the contents of the current window to a view file or event setting 
file.

View File Load dialog box (refer to 
p.105)

Reads the view file or source event setting file of each window.

Environment File Save dialog box (refer 
to p.108)

Saves the contents of the current window to a environment file or event 
setting file.

Environment File Load dialog box (refer 
to p.110)

Reads the environment file or source event setting file of each window.

Download dialog box (refer to p.112) Loads an object file and binary file.

Upload dialog box (refer to p.116) Saves the memory contents to a file.

Browse dialog box (refer to p.119) Debugger Option dialog box, Select the file to be set in Source Search 
dialog box.

Source Text Move dialog box (refer to 
p.123)

This dialog box is used to specify a file to be displayed in Source 
window and the position from which displaying the file is to be started.

Address Move dialog box (refer to p.121) Specifies the start address to display the contents of the Memory 
window, Assemble window or Coverage window.  

Trace Move dialog box (refer to p.126) Specifies the start address to display the contents of the Trace window.  

Symbol To Address dialog box (refer to 
p.129)

Displays the addresses and symbol values of variables and functions.  

Source window (refer to p.132) Displays a source file or text file.

Source Search dialog box (refer to 
p.145)

Searches for a character string in a source file.  
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Assemble window (refer to p.148) Disassembles the program and executes online assembly.

Assemble Search dialog box (refer to 
p.155)

Searches the contents of the Assemble window.  

Memory window (refer to p.158) Displays and modifies the contents of memory.  

Memory Search dialog box (refer to 
p.163)

Searches the contents of the Memory window.  

Memory Fill dialog box (refer to p.166) Initializes the memory contents with specified data.

Memory Copy dialog box (refer to p.168) Copies the memory.

Memory Compare dialog box (refer to 
p.170)

Compares the memory.  

Memory Compare Result dialog box 
(refer to p.172)

Displays the result of comparing the memory.  

Pseudo DMM dialog box (refer to p.174) Sets addresses and data subject to DMM.

Watch window (refer to p.176) Displays and modifies variables.

Quick Watch dialog box (refer to p.183) Temporarily displays and changes the value of a variable.

Add Watch dialog box (refer to p.187) Registers a variable to be displayed in the Watch window.  

Change Watch dialog box (refer to 
p.191)

Changes a variable to be displayed in the Watch window.  

Local Variable window (refer to p.194) Displays and changes the local variable in the current function.  

Stack Trace window (refer to p.197) Displays and changes the stack contents of the current user program.

Register window (refer to p.201) Displays and changes the contents of the registers (general-purpose 
registers and control registers).

SFR window (refer to p.207) Displays and changes the contents of the SFR.

SFR Select dialog box (refer to p.213) Selects a SFR or I/O port to be displayed in the SFR window.  

Add I/O Port dialog box (refer to p.216) Registers an I/O port to be displayed in the SFR window.  

Trace window (refer to p.219) Displays trace results.

Trace Search dialog box (refer to p.229) Searches trace data.

Trace Data Select dialog box (refer to 
p.236)

Selects items to be displayed in the Trace window.  

Coverage window (refer to p.239) Displays the coverage results.  

Coverage Search dialog box (refer to 
p.244)

Searches coverage results.

Coverage-Clear dialog box (refer to 
p.247)

Clears the coverage results.

Coverage-Condition Setting dialog box 
(refer to p.249)

Sets a coverage efficiency measurement range.

Coverage-Efficiency View dialog box 
(refer to p.252)

Displays the coverage results in terms of efficiency.

Event Manager (refer to p.254) Displays, enables/disables, and deletes each event condition.  

Event dialog box (refer to p.263) Registers and displays event conditions.

Event Link dialog box (refer to p.273) Registers and displays event link conditions.  

Table 6-1　SM78Kx Window List 

Window Name Contents
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Break dialog box (refer to p.279) Registers, sets, and displays break event conditions.

Trace dialog box (refer to p.283) Registers, sets, and displays trace event conditions.

Snap Shot dialog box (refer to p.289) Registers, sets, and displays snapshot event conditions.

Stub dialog box (refer to p.297) Registers, sets, and displays stub event conditions.

Timer dialog box (refer to p.302) Displays execution time measurement result, and registers, sets, and 
displays timer event conditions.

Timer Result dialog box (refer to p.308) Displays execution time measurement results.

Delay Count dialog box (refer to p.310) Sets the delay count of a trace.

Reset Debugger dialog box (refer to 
p.312)

Initializes the SM78Kx, target CPU, and symbol information.  

About dialog box (refer to p.314) Displays the version of the SM78Kx.  

Exit Debugger dialog box (refer to p.316) Terminate the SM78Kx.  

Console window (refer to p.318) Inputs commands.  

Error/Warning dialog box Displays error/warning messages.

Table 6-2　SM78Kx Window List (Simulator)

Window Name Contents

78Kx Simulator GUI window (refer to 
p.319)

Main window of simulator (SM78Kx)

SFR Event & Action window (refer to 
p.322)

Sets and displays an event and action for a SFR or any address.

Input 0/1 Editor window (refer to p.326) Sets an input value (0 or 1) to an input pin.

Input timing Chart Editor window (refer 
to p.332)

Sets an input value (in timing chart format) to an input pin specified 
with the Input timing Chart Editor window.  

Pin Setting dialog box (refer to p.337) Sets a pin name to be displayed in the Input 0/1 Editor window, Input 
timing Chart Editor window and Output Timing Chart window.  

Down Load dialog box (refer to p.340) Downloads an input file and event condition file.

Output Setting dialog box (refer to p.342) Saves a file of output results from output pins and sets timing chart 
display.

Output Timing Chart window (refer to 
p.345)

Displays the I/O data and interrupt signals of pins in a timing chart.

Search window (refer to p.349) Searches I/O data.

Parts window (refer to p.352) Sets and displays external parts.

Buttons window (refer to p.363) Sets information on connection between the buttons to be displayed in 
the Parts window and pins.  

Key Matrixes window (refer to p.367) Sets information on connection between the key matrixes to be 
displayed in the Parts window and pins.  

LCDs window (refer to p.371) Sets the device's internal LCD display. 

LCD Panel window (refer to p.374) Displays bitmap image of LCD.

Table 6-1　SM78Kx Window List 

Window Name Contents



CHAPTER 6  WINDOW REFERENCE

User’s Manual  U16768EJ1V0UM 55

6. 2    Explanation of Windows

This section explains each debug window as follows:

Set LCD Pin dialog box (refer to p.383) Sets the drawing and pin connection information displayed in the LCD 
Panel window

FIPs window (refer to p.387) Sets the device's internal FIP display. 

FIP Panel window (refer to p.390) Displays bitmap image of FIP.

Set FIP Pin dialog box (refer to p.399) Sets the drawing and pin connection information displayed in the FIP 
Panel window.

LEDs window (refer to p.403) Sets information on connection between the LEDs to be displayed in 
the Parts window and pins.  

7seg LEDs window (refer to p.406) Sets information on connection between the 7-segment LEDs to be 
displayed in the Parts window and pins.  

14seg LEDs window (refer to p.410) Sets information on connection between the 14-segment LEDs to be 
displayed in the Parts window and pins.  

Level Gauges window (refer to p.414) Sets information on connection between the level gauges to be 
displayed in the Parts window and pins.  

DC Motors window (refer to p.417) Sets information on connection between the level gauges to be 
displayed in the Parts window and pins.  

Buzzers window (refer to p.420) Sets information on connection between the buzzers to be displayed in 
the Parts window and pins.  

Internal Interrupt Button window (refer to 
p.423)

Sets information on connection between the internal interrupt buttons 
to be displayed in the Parts window and pins.  

Pull-Up / Pull-Down window (refer to 
p.426)

Sets information on the pin connection of the pull-up/down resistors to 
be displayed in the Parts window.  

Serial GUI window (refer to p.429) Displays the I/O information on the serial interface.

Bitmap Entry window (refer to p.432) Registers or deletes the bit map file of the external component to be 
displayed in the Parts window.  

Open dialog box (refer to p.437) Specifies a file to be manipulated.

Save As dialog box (refer to p.439) Saves the file subject to operation.

Table 6-2　SM78Kx Window List (Simulator)

Window Name Contents
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Window/dialog name

Briefly explains the function of the window or dialog box and points to be noted.  

In addition, the display image of the window or dialog box is also illustrated.  

Items of related operation are also explained.  

Opening

Explains how to open the window or dialog box.  

If two or more methods of opening are listed, the window or dialog box can be opened by any of them.  

Explanation of each area

Explains items to be set to or displayed in each area of the window or dialog box.  

Functions often used (right-click menu)

Explains the context menu that is displayed in the window when the right mouse button is clicked.  

From the context menu, convenient functions often used in this window can be selected with a single 

action (window only).  

Function buttons

Explains the operation of each button in the window or dialog box.  

Related operations

Explains the operation of a window or dialog box related to this window or dialog box.  
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Main window

This window is automatically opened when the SM78Kx is started up and initialized.  It exists on the

screen until the SM78Kx is terminated.  Other windows are manipulated from this window.  Execution of the

user program is controlled in this window.

Execution of the user program is controlled in the following three modes:

The auto mode is set when the debugger is started up.

Figure 6-1　Main Window

This section explains the following items:

• Toolbar

• Menu bar

• Window display area

• Status bar

Toolbar

The toolbar is a collection of buttons that can execute often-used commands with a single action.  Each

button is graphically displayed to indicate the image of its function.  This toolbar can be displayed in the

Source mode Debugs the user program at the source level.

Instruction mode Debugs the user program at the instruction level.

Auto mode Automatically selects the source mode or instruction mode.
Step execution is performed at the source level when the Source 
window is active (except in the mixed display mode), and at the 
instruction level when the Assemble window is active. When neither of 
these windows is active, step execution is performed at the source level.
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following two modes.  The modes are selected in Debugger Option dialog box.

Figure 6-2　Toolbar with Only Graphics (default)

Figure 6-3　Toolbar with Graphics and Characters

Whether the toolbar is displayed or not can be specified by selecting [Option] -> [Tool Bar] from the menu

bar.  This toolbar can be moved inside or outside the main window by dragging and dropping with the

mouse.

  The meaning of each button on the toolbar is as follows.  When the mouse cursor is placed on a button

of the toolbar, a tool hint pops up several seconds later.

Stop

Stops execution of the user program.
Same function as [Run] -> [Stop] on the menu bar.

ReGo

Resets the CPU and executes the user program.
Same function as [Run] -> [Restart] on the menu bar.

Go

Executes the user program from the current PC without resetting the CPU.
Same function as [Run] -> [Go] on the menu bar.

Go

Executes the user program without a break occurrence. 
Same function as [Run] -> [Ignore break points and Go] on the menu bar.

Ret

The user program is real-time executed until execution returns.
Same function as [Run] -> [Return Out] on the menu bar
(This command is used for a function described in C language.)

Step

Step execution (executes instructions in the program one by one.)
If a function or subroutine is called, its instructions are executed one by one.
Same function as [Run] -> [Step In] on the menu bar.

Over
Next step execution (executes the program, assuming a function/call statement as one 
step.)
If a function or subroutine is called, its instructions are not executed on a step-by-step 
basis.
Same function as [Run] -> [Next Over] on the menu bar.

Res
Resets the CPU.
Same function as [Run] -> [CPU Reset] on the menu bar.

Back
Backtracks the user program.
Same function as [Run] -> [Step Back] on the menu bar.

Open
Opens View File Load dialog box.
Same function as [File] -> [Open...] on the menu bar.

Load
Opens Download dialog box.
Same function as [File] -> [Download...] on the menu bar.

Proj
Opens Project File Load dialog box.
Same function as [File] -> [Project] -> [Open...] on the menu bar.
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Menu bar

The menu bar consists of the following menus:

(1)　 [File] menu

Src
Displays the source text.
Opens Source window.
Same function as [Browse] -> [Source Text] on the menu bar.

Asm
Displays the disassemble results.
Opens Assemble window.
Same function as [Browse] -> [Assemble] on the menu bar.

Mem
Displays the contents of the memory.
Opens Memory window.
Same function as [Browse] -> [Memory] on the menu bar.

Wch

Displays the watch contents.
Opens Watch window.
Same function as [Browse] -> [Watch] on the menu bar.

Reg
Displays the register contents.
Opens Register window.
Same function as [Browse] -> [Register] on the menu bar.

Sfr
Displays the contents of the SFR.
Opens SFR window.
Same function as [Browse] -> [Sfr] on the menu bar.

Loc
Displays the local variable contents.
Opens Local Variable window.
Same function as [Browse] -> [Local Variable] on the menu bar.

Stk
Displays the stack contents.
Opens Stack Trace window.
Same function as [Browse] -> [Stack Trace] on the menu bar.

TrW
Displays the trace results.
Opens Trace window.
Same function as [Browse] -> [Trace] on the menu bar.

Cov
Displays coverage measurement results.
Opens Coverage window.
Same function as [Browse] -> [Coverage] on the menu bar.

Mgr
Opens Event Manager.
Same function as [Event] -> [Event Manager] on the menu bar.

Evn
Registers and sets events.
Opens Event dialog box.
Same function as [Event] -> [Event...] on the menu bar.

Brk
Registers and sets break events.
Opens Break dialog box.
Same function as [Event] -> [Break...] on the menu bar.

Trc
Registers and sets trace events.
Opens Trace dialog box.
Same function as [Event] -> [Trace...] on the menu bar.

Tim
Registers and sets timer events. 
Opens Timer dialog box.
Same function as [Event] -> [Timer...] on the menu bar.



60 User’s Manual  U16768EJ1V0UM

CHAPTER 6  WINDOW REFERENCE

(2)　 [Edit] menu

(3)　 [View] menu

(4)　 [Option] menu

(5)　 [Run] menu

(6)　 [Event] menu

(7)　 [Browse] menu

(8)　 [Jump] menu

(9)　 [Window] menu

(10)　 [Help] menu

(1) [File] menu

Open... Loads a view file, source file, or text file.
Opens View File Load dialog box.
The operation differs depending on the extension of the file selected in the 
dialog box.

Save As... Saves the contents displayed on the current window to the file whose name is 
specified.
Opens View File Save dialog box.

Close Closes the current window.

Download... Downloads a program.
Opens Download dialog box.

Upload... Uploads a program.
Opens Upload dialog box.

Project Manipulates a project file.

Open... Opens a project file.
Opens Project File Load dialog box.

Save Overwrites the current status to the project file currently being read to the 
debugger.

Save As... Saves the current status to a specified project file.
Opens Project File Save dialog box.

Environment Manipulates a environment file.
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(2) [Edit] menu

(3) [View] menu

This menu displays different items depending on the window that is active.  The following items may be 

displayed:

•  Common items

•  Source window-dedicated items

Open... Opens a environmet file.
Opens Environment File Load dialog box.

Save As... Saves the current status to a specified environmet file.
Opens Environment File Save dialog box.

Debugger Reset... Initializes the target CPU, symbols, and debugger.
Opens Reset Debugger dialog box.

Exit Terminates the debugger.
Opens Exit Debugger dialog box.

(Open file) Lists the names of the files opened.

Cut Cuts a selected character string and saves it to the clipboard buffer.

Copy Copies a selected character string and saves it to the clipboard buffer.

Paste Pastes the contents of the clipboard buffer to the text cursor position.

Write in Writes the modified contents to the target.

Restore Cancels the modification.

Memory Manipulates the memory contents.

Fill... Initializes the memory.
Opens Memory Fill dialog box.

Copy... Copies the memory.
Opens Memory Copy dialog box.

Compare... Compares the memory.
Opens Memory Compare dialog box.

Modify... Rewrites the memory contents almost in real time during RUN.
Opens Pseudo DMM dialog box.

Edit Source Opens the source file displayed in the active Source window with the editor 
specified by the PM plus when the PM plus runs.
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•  Assemble window-dedicated items

•  Memory window-dedicated items

•  Watch window-dedicated items

•  Register window-dedicated items

•  SFR window-dedicated items

•  Local Variable window-dedicated items, Stack Trace window-dedicated items

•  Trace View window-dedicated items

•  Coverage window-dedicated items

•  Event Manager-dedicated items

Common items

Search... Performs a search.
Opens the search dialog box corresponding to the current window.
Same operation as the <Search> button.
However, this item cannot be selected when the Trace window is open. 

Move... Moves the display position.
Opens the specification dialog box corresponding to the current window.

Quick Watch... Temporarily displays the contents of the specified data.
Opens Quick Watch dialog box.

Add Watch... Registers the specified data to the Watch window.
Opens Add Watch dialog box.

View Watch Adds the selected data to the Watch window.
If the data is a symbol, it is added in accordance with the setting of Debugger 
Option dialog box.

Change Watch... Changes the data on the line selected by the Watch window.
Opens Change Watch dialog box.
This menu is valid only when a variable is selected in Watch window.

Delete Watch Deletes the selected watch point from the Watch window.  This menu is valid 
only when a variable is selected in Watch window.

Symbol... Displays the address of the specified variable or function, or the value of the 
specified symbol.
Opens Symbol To Address dialog box.
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Source window-dedicated items

Assemble window-dedicated items

Memory window-dedicated items

Create Break Event Creates a break event by using the selected variable.

Break when Access
to this Variable

Creates a break event that can be accessed for read/write.

Break when Write to
this Variable

Creates a break event that can be accessed for write.

Break when Read
from this Variable

Creates a break event that can be accessed for read.

Clear Deletes a break event corresponding to the selected variable.  

Event? Displays the event information of a line at the cursor position or a selected 
variable name.  
If an event is set, Event dialog box is opened.

Mix Specifies whether the results of assembly are displayed in mixed display 
mode, or not displayed.
Checked: Mixed display
Not checked: No display (default)

Event? Displays the event information of the address at the cursor position.
If an event is set, Event dialog box is opened.

Bin Displays binary numbers.

Oct Displays octal numbers.

Dec Displays decimal numbers.
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Watch window-dedicated items

Only "selected items" can be manipulated in the Watch window.

Hex Displays hexadecimal numbers (default).

Nibble Displays in 4-bit units.

Byte Displays in 8-bit units (default).

Word Displays in 16-bit units.

Double Word Displays in 32-bit units.

Ascii Selects whether ASCII characters are displayed or not.
Checked: Displayed
Not checked: No display (default)

Little Endian Displays in little endian (default).

Big Endian Displays in big endian.

Create Break Event Creates a break event by using the selected item.

Break when Access
to this Variable

Creates a break event that can be accessed for read/write.

Break when Write to
this Variable

Creates a break event that can be accessed for write.

Break when Read
from this Variable

Creates a break event that can be accessed for read.

Clear Deletes a break event corresponding to the selected item.  

Event? Displays the event information of the variable selected.  If an event is 
set, Event dialog box is opened.

Bin Displays binary numbers.

Oct Displays octal numbers.

Dec Displays decimal numbers.

Hex Displays octal numbers.
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Register window-dedicated items

SFR window-dedicated items

String Displays character strings.

Proper Displays the default value of each variable.
Symbols are displayed in accordance with the setting of Debugger 
Option dialog box (default).

Byte Displays in 8-bit units.

Word Displays in 16-bit units.

General Displays in 24-bit units(SM78K4 only).

Double Word Displays in 32-bit units.

Adaptive Displays the default value of each variable.
Only this item is valid for a symbol in C language.
Symbols are displayed in accordance with the setting of Debugger 
Option dialog box (default).

Up Moves up one line.

Down Moves down one line.

Compulsion Read Forcibly reads the data of SFRs that are read-protected because their 
values change when they are read, or the data of I/O ports and I/O 
protect areas (SM78K0, SM78K4 only) added in the Add I/O Port dialog 
box.

Bin Displays binary numbers.

Oct Displays octal numbers.

Dec Displays decimal numbers.

Hex Displays hexadecimal numbers (default).

Absolute Name Displays register names as absolute names.

Functional Name Displays register names as function names (default).
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Local Variable window-dedicated items, Stack Trace window-dedicated items

Trace View window-dedicated items

Bin Displays binary numbers.

Oct Displays octal numbers.

Dec Displays decimal numbers.

Hex Displays hexadecimal numbers (default).

Sort By Name Displays in alphabetical order.

Sort By Address Displays in address order (default).

Unsort Does not sort.

Attribute Displays or does not display an attribute field (Attribute).
Checked: Displayed (default)
Not checked: Not displayed

Pick Up Displays only the registers selected in SFR Select dialog box.
Checked: Displays only the selected register.
Not checked: Displays all the registers (default).

Select... Opens SFR Select dialog box.

Compulsion Read Forcibly reads the data of SFRs that are read-protected because their 
values chang when they are read, or the data of the I/O ports added in 
the Add I/O Port dialog box.

Bin Displays binary numbers.

Oct Displays octal numbers.

Dec Displays decimal numbers.

Hex Displays octal numbers.

String Displays character strings.

Proper Displays the default value of each variable (default).
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Coverage window-dedicated items

Event Manager-dedicated items

Select... Selects the contents to be displayed.
Opens Trace Data Select dialog box.

Pick Up Performs the setting for pickup display.

Off Does not pick up and display (default).

Search Picks up and displays a frame that satisfies the search condition.

Snap Picks up and displays a snap frame.

BRM1 Picks up and displays the first M1 fetch frame after a program branch.

Mix Specifies whether the results of assembly are displayed in mixed display 
mode, or not displayed.
Checked: Mixed display
Not checked: No display (default)

Window Synchronize Sets linking between Trace window and the following windows.
A checked window is linked.

Source Text Links Source window.

Assemble Links Assemble window.

Memory Links Memory window.

Coverage Links Coverage window.

1Byte Displays in 1-byte units (default).

64Bytes Displays in 64-byte units.

1024Bytes Displays in 1024-byte units (SM78K4 only).

Select All Event Selects all the events registered to the Event Manager.

Delete Event Deletes a selected event.

Sort By Name Displays icons in the order of event names.
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(4) [Option] menu

Sort By Kind Displays icons in the order of event types.

Unsort Does not sort icons (default).

Detail Detailed display

Overview List display (default)

Tool Bar Selects whether the tool bar is displayed (default) or not.

Status Bar Selects whether the status bar is displayed (default) or not.

Button Selects whether the buttons on each window are displayed (default) or not.

Source Mode Executes step execution at the source level (in line units).

Instruction Mode Executes step execution at the instruction level (in instruction units).

Auto Mode Automatically selects step execution at the source level or step execution at 
the instruction level (default).
Step execution is performed at the source level (in a mode other than mixed 
display mode) if Source window is active.  It is performed at the instruction 
level if Assemble window is active.  If neither window is active, step execution 
is performed at the source level.

Configuration... Sets the environment.
Opens Configuration dialog box.

Extended Option... Sets extended functions.
Opens Extended Option dialog box.

Debugger Option... Sets debugger options.
Opens Debugger Option dialog box.

Add I/O Port... Adds user-defined I/O ports.
Opens Add I/O Port dialog box.

Trace Clear Clears the trace data.
This item is displayed only when Trace window is active.

Coverage Opens the following dialog boxes related to coverage measurement.
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(5) [Run] menu

Clear... Clears the coverage measurement results.
Opens Coverage-Clear dialog box.

Condition... Sets a coverage efficiency measurement condition.
Opens Coverage-Condition Setting dialog box.

Efficiency... Displays coverage efficiency.
Opens Coverage-Efficiency View dialog box.

Coverage ON Turns ON/OFF coverage measurement (default: ON).
This item cannot be selected during user program execution.

Timer ON Turns ON/OFF timer measurement (default: ON).
This item cannot be selected during user program execution.
The timer measuring Run-Break time cannot be stopped.

Tracer ON Turns ON/OFF tracer (default: ON).
This item cannot be selected during user program execution.

Back Step ON Enables/disables back step execution (default: OFF).
ON/OFF switching is possible even during emulation.

Restart Resets the CPU and executes the program.
Same operation as the ReGo button

Stop Forcibly stops program execution.
Same operation as the Stop button

Go Executes the program from the current PC.
Same operation as the Go button

Ignore break points and Go Executes the program, ignoring break points being set.  
Same operation as the GoN button
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Return Out The user program is real-time executed until execution returns.
Same operation as the Ret button
This menu item is available only for a function described in C 
language.  

Step In Executes the instructions in the program one by one (step execution).
If a function or subroutine is called, its instructions are executed one by 
one.
Same operation as the Step button

Next Over Executes the instructions in the program one by one (Next step 
execution).
If a function or subroutine is called, its instructions are not executed on 
a step-by-step basis.
Same operation as the Over button

Start From Here Executes the program from the cursor position on Source window or 
Assemble window (Start function).

Come Here Executes the program from the current PC to the cursor position in the 
Source window or Assemble window (Come function).

Step Back Performs back execution using the unit set in the Extended Option 
dialog box. 
Same operation as the Back button

Go Back Performs back execution from the current PC until the Source window 
or Assemble window.

Go & Go Continues executing the program.
If a break occurs because a break condition is satisfied, the window is 
updated and the program is executed again.
Each time a break has occurred, the same operation as clicking the 
Go button is performed.

Slowmotion Continues step execution.
Each time step execution has been performed, the window is updated 
and then step execution is performed again.
Same operation as clicking the Step each time a break has occurred.

CPU Reset Resets the CPU.
Same operation as the Res button

Change PC Sets the address at the cursor position in the Source window or 
Assemble window to the PC.

Break Point Sets or cancels a breakpoint at the cursor position in the Source 
window or Assemble window.

Uncond. Trace ON Validates unconditional trace so that trace can always be executed 
during program execution (default).
The trace mode cannot be changed while the tracer is activated.

Cond. Trace ON Validates conditional trace and traces in accordance with the trace 
condition during program execution.
The trace mode cannot be changed while the tracer is activated.

Tracer Control Mode Selects settings related to the tracer from the following menus:
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(6) [Event] menu

Non Stop Goes around the trace memory and overwrites data from the oldest 
frame (default).

Full Stop Goes around the trace memory and then stops the tracer.

Full Break Goes around the trace memory and then stops the tracer and program 
execution

Delay Trigger Stop Traces data by the number of delay count frames and stops the tracer 
when a delay trigger event has occurred. 

Delay Trigger Break Traces data by the number of delay count frames and stops the tracer 
and program execution when a delay trigger event has occurred. 

Coverage Start/
Coverage Stop

Starts coverage measurement when it is stopped, or stops it when it is 
in progress.
This item is invalid if the program is not being executed or if the 
coverage function is OFF (if [Option] -> [Coverage ON] is not 
checked).  Immediately after program execution has been started with 
the coverage function ON, coverage measurement is in progress.

Timer Start/
Timer Stop

Starts timer measurement when it is stopped, or stops it when it is in 
progress.
This item is invalid if the program is not being executed, if a timer event 
is not used, and if the timer function is OFF (if [Option] -> [Timer ON] is 
not checked).  Immediately after program execution has been started 
with the timer function ON, timer measurement is in progress.

Tracer Start/
Tracer Stop 

Starts the tracer when it is stopped, or stops it when it is in progress.
This item is invalid if the program is not being executed and if the trace 
function is OFF (if [Option] -> [Tracer ON] is not checked).  
Immediately after program execution has been started with the tracer 
function ON, the tracer is executed.

Event Manager Manages various event conditions.
Opens Event Manager.
Same operation as the Mgr button

Event... Registers an event condition.
Opens Event dialog box.
Same operation as the Evn button

Event Link... Registers an event link condition.
Opens Event Link dialog box.

Break... Registers and sets a break condition.
Opens Break dialog box.
Same operation as the Brk button
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(7) [Browse] menu

Trace... Registers and sets a trace event condition.
Opens Trace dialog box.
Same operation as the Trc button

Snap Shot... Registers and sets a snap event condition.
Opens Snap Shot dialog box.

Stub... Registers and sets a stub event condition.
Opens Stub dialog box.

Timer... Registers and sets a timer event condition.
Displays a timer value.
Opens Timer dialog box.
Same operation as the Tim button

Delay Count... Sets a delay count and displays the delay value.
Opens Delay Count dialog box.

Source Text Displays a source text.
Opens Source window.
Same operation as the Src button
If there is a Source Text window already open in the active status, it is 
opened in the static status.

Assemble Displays the disassemble results.
Opens Assemble window.
Same operation as the Asm button
If there is a Assemble window already open in the active status, it is 
opened in the static status.

Memory Displays the contents of the memory.
Opens Memory window.
Same operation as the Mem button
If there is a Memory window already open in the active status, it is 
opened in the static status.

Watch Displays the watch contents.
Opens Watch window.
Same operation as the Wch button

Register Displays the register contents.
Opens Register window.
Same operation as the Reg button

SFR Displays the contents of the SFR.
Opens SFR window.
Same operation as the SFR button
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(8) [Jump] menu

Local Variable Displays the local variable.
Opens Local Variable window.
Same operation as the Loc button

Stack Trace Displays the stack trace results.
Opens Stack Trace window.
Same operation as the Stk button

Trace Displays the trace results.
Opens Trace window.
Same operation as the TrW button

Coverage Displays coverage measurement results.
Opens Coverage window.
Same operation as the Cov button.

Console Opens Console window.

Others Displays other windows.
Displays a user-defined window list.
Refer to 7. 6 Expansion window(refer to p.444) and APPENDIX B 
EXPANSION WINDOWS (refer to p.489) for details.

Source Text Displays the corresponding source text and source line, using the data value 
selected in the current window as the jump destination address.
If no line information is at the jump destination address, however, you cannot 
jump.
Opens Source window.
If an active Source window is open, that window is displayed in the forefront (so 
that it can be manipulated).

Assemble Disassembles and displays the results from the jump destination address 
specified by the data value selected in the current window.
Opens Assemble window.
If an active Assemble window is open, that window is displayed in the forefront 
(so that it can be manipulated).

Memory Displays the memory contents from the jump destination address specified by the 
data value selected in the current window.
Opens Memory window.
If an active Memory windowis open, that window is displayed in the forefront (so 
that it can be manipulated).

Coverage Displays coverage measurement results from the jump destination address 
specified by the data value selected in the current window.
Opens Coverage window.
If an active Coverage windowis open, that window is displayed in the forefront 
(so that it can be manipulated).
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(9) [Window] menu

(10) [Help] menu

New Window Opens a new window displaying the same contents as those of the current 
window.  This menu is valid only when the current window is Source window, 
Assemble window,  Memory window, or Coverage window.

Cascade Cascade display of the windows in the Main window.

Tile Tile display of the windows in the Main window.

Arrange Icons Rearranges the icons in the Main window.

Close All Closes all windows, except the Main window.

Refresh Updates the contents of the window with the latest data.

Active Sets the window in the active status.
If the window is already in the active status, a check mark is shown on the left of 
this item.

Static Sets the window in the static status.
If the window is already in the static status, a check mark is shown on the left of 
this item.

(Open Window) Lists the windows that are open.
The window with the check mark shown on the side of the figure is the current 
window.  By selecting a window name, the selected window is used as the 
current window.

SM78Kx Help Displays the help of SM78Kx .

Command Reference Opens the Help window of COMMAND REFERENCE.

Main Window Help Displays the help of the Main window.

Current Window Help Displays the help of the current window.
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Window display area

This area (at the center) displays various debug windows.

The displayed window can be changed in size or an icon can be created in this area.

Status bar

The status bar is displayed at the bottom of the window and indicates the status of the debugger and In-

circuit emulator.

While the user program is being executed, the status bar is displayed in red.

Whether the status bar is displayed or not can be selected by selecting [Option] -> [Status Bar] from the

menu bar.

Figure 6-4　Status Bar

About... Displays the version of the debugger.
Opens About dialog box.

(1) Program name Displays the program file name indicated by the PC value.

     Source name Displays the source file name indicated by the PC value.

     Line number Displays the line number indicated by the PC value.

(2) Function name Displays the function name indicated by the PC value.

(3) PC value Displays the current PC value.

(4) CPU status Displays the status of the CPU (target device).
(If there are two or more CPU statuses, they delimited with '|' and displayed.)
STANDBY...Standby mode
HALT...Hold mode
STOP...Stop mode

(5) IE status Displays the status of the simulator.
(If there are two or more the statuses, they delimited with '/' and displayed.)
RUN...User program execution in progress (the color of the status bar 
changes).
STEP...Step execution in progress
TRC...Tracer operating
TIM..Timer operating
BACK RUN...Back execution in progress.
BACK STEP...Back step execution in progress.
BREAK...Break occurring.

(6) Break Cause Displays Table 6-3  Break Cause.
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Caution: If the screen resolution is small (800 x 600, etc.), all the statuses may not be displayed.

(7) STEP mode Displays the step execution mode.
Displays that the following modes are selected from the [Option] menu:
SRC...Source mode
INST...Instruction mode
AUTO...Automatic mode

(8) Key input mode Displays the key input mode.
INS... Insertion mode
OVR...Overwrite mode
The Memory window is fixed to OVR mode.

Table 6-3　Break Cause

Display Meaning

Manual Break Forced break

Temporary Break Temporary break

Event Break Break by event

Trace Full Break Break due to trace full

Non Map Break Non-mapped area is accessed.

Write Protect An attempt has been made to write to a write-protected area.

SFR Illegal An illegal access is made to a peripheral SFR.

Stack Overflow Break due to stack overflow 

Relocation Break A location instruction different from the default setting was 
executed (SM78K4 only).

Uninitialize Mem read Loaded non-initialized memory.

Write Back Break Back break that occurs for write-related function

Security Protect A security protected area is accessed.
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Configuration dialog box

This dialog box is used to display and set the operating environment of the simulator.

This dialog box is automatically displayed after the debugger is started up.  

To use the debugger, the operating environment of the simulator must be first set in this dialog box.  

However, no setting is required to read a project as the results of reading the project file are reflected in

this dialog box.  

Figure 6-5　Configuration Dialog Box

This section explains the following items:  

• Opening

• Explanation of each area

•  Setting of memory mapping

• Function buttons
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Opening

This dialog box can be opened as follows:

• Automatically opens when the debugger is started up while PM plus is running

• If starting up from PM plus, when using the debugger for the first time for that project

• Select [Option] -> [Configuration...] from the menu bar.
 (or press Alt+O, and C in that order)

Explanation of each area  

The Configuration dialog box consists of the following areas:

(1)　Chip (CPU selection area)

(2)　 Internal ROM/RAM (internal ROM/internal RAM setting area)

(3)　 Location (Location setting area) (SM78K4 only)

(4)　Clock (CPU clock source selection area)

(5)　Memory Mapping (mapping setting area)

(1) Chip (CPU selection area)

This area is used to select the CPU.

Only the chip names registered to a registry by the DFINST utility are listed.  

Specify a chip name either from the drop-down list under Name, or directly type in the chip name.

A chip name can be specified only when the debugger is started up.  The chip name selected at the 

previous startup is selected by default.  If the chip name is not stored, the top chip name that is 

registered is selected by default.  

(2) Internal ROM/RAM (internal ROM/internal RAM setting area)

This area is used to set the size of the internal RAM and internal ROM of the CPU.  

The default value is automatically displayed with "*" suffixed, when Chip is selected.  

To change the size of the internal RAM and internal ROM, select the size from the drop-down list under 

Internal RAM and Internal ROM.  

If the selected size cannot be implemented because of the constraints of the simulator, the debugger 

automatically adjusts the size (therefore, a size larger than that previously specified may be displayed 

when the Configuration dialog box is displayed again).  

The settable sizes are as follows: 
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 [SM78K0, SM78K0S]

Internal ROM: 0, 4, 8, 12, 16, 20, 24, 28, 32, 36, 40, 44, 48, 52, 56, 60

Internal RAM: 64 to 1024

 [SM78K4]

Internal ROM: 0 to 1024

Internal RAM: 256 to 32000

Caution: If the internal ROM/RAM size of the selected chip does not match any of the above

sizes, that size will also be displayed on the list.

(3) Location (Location setting area) (SM78K4 only)

This area is used to set the location.

2 locations, 00H or 0fH, can be set.  Select one of them according to the user environment.

A relocation break occurs when a location instruction that differs from this setting is executed.  

If a load module file has been loaded, the location is automatically set again according to the location 

information in that load module file.

(4) Clock (CPU clock source selection area)

This area is used to select a clock source to be input to the CPU.

Input a number of clock from the keyboard, or select one from the drop-down list.

.

(5) Memory Mapping (mapping setting area)

This area is used to set mapping by specifying the memory attribute, and address.  

Main (MHz) Specifies the number of main clocks.

Sub (KHz) Specifies the number of sub clocks.
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Memory Attribute (mapping attribute specification)

The following mapping attributes can be selected.  Select a mapping attribute according to the usage  .  

Mapping Address (mapping address specification)

Specify the address to be mapped.  

Input the higher and lower addresses from the keyboard.

Setting of memory mapping

Specify Memory Attribute and Mapping Address and then click the <Add> button.  

-> The attribute of Memory Attribute, address range of Memory Mapping, and memory mapping 

corresponding to the data of the bus width are set and displayed on a list.  

The mapping unit is as follows:

The mapping unit varies depending on the address to be mapped (SM78K4 only).  The mapping unit is 

shown below.

Deleting memory mapping

Select mapping to be deleted from the list and click the <Delete> button.  

-> This deletes the selected mapping.  

Emulation ROM Selects the simulator alternate ROM (SM78K0, SM78K4 only).

Emulation RAM Selects the simulator alternate RAM (SM78K0, SM78K4 only).

Stack Selects the memory of the area assumed as stack. 
If stack operation is performed encroaching on this area, a stack 
overflow error results.

Table 6-4　Mapping Unit in Configuration Dialog Box

Mapping Area Mapping Unit

Stack 1 byte
The internal RAM area can be set as Stack.

Emulation ROM
Emulation RAM

4K byte

Table 6-5　Mapping Unit in Configuration Dialog Box

Mapping Area Mapping Unit

0x000000-0x00ffff 4K byte

0x010000-0x0fffff 64K byte

0x0100000-0xffffff 1M byte
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Function buttons  

OK Validates the current environment.  
Sets the environment and closes this dialog box.  

Cancel Cancels the changes and closes this dialog box.

Restore Restores the previous environment settings status before this dialog box was 
opened.

Project... Opens the Project File Load dialog box.  If an error occurs while a project file is being 
opened or read, the debugger can no longer continue and is terminated.  

Help Opens the Help window.  
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Extended Option dialog box

This dialog box is used to display and set the extended options of the debugger.  

Figure 6-6　Extended Option Dialog Box

This section explains the following items:  

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

• Select [Option] ->[Extended Option...] from the menu bar. 
(or press Alt+O, and X in that order.)

Explanation of each area

The Extended Option dialog box consists of the following areas:  

(1)　Trace Size (trace buffer size setting area)

(2)　Add Up Timetag (total time tag specification area)

(3)　Trace Timetag Count Rate (trace time tag counter division ratio selection area)

(4)　 Internal RAM Monitor Redraw (real-time internal RAM sampling time setting area)

(5)　Break condition (break mode setting area)

(6)　Break Sound (beep sound specification area)

(7)　Verify Check (verify specification area)

(8)　Back Step (back execution type selection area)

(9)　Project Save Level (project save level selection area)
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(1) Trace Size (trace buffer size setting area) 

This area is used to set the size (frame units) in which execution of the user program is to be traced.  

The following sizes can be set:

(2) Add Up Timetag (total time tag specification area)

This area is used to specify whether time tags of trace data are totaled or not.  

This check box is not checked by default, and the time tags are not totaled.

(3) Trace Timetag Count Rate (trace time tag counter division ratio selection area) 

This area is used to set the division ratio of the counter used for time tag display in Trace window.  

If the division ratio is set, the number of clocks necessary for counting up the counter displayed for time 

tag is changed.  

The division ratio that can be set ranges from 1 (default) to 65536. 

(4) Internal RAM Monitor Redraw (real-time internal RAM sampling time setting area) 

This area is used to specify the sampling time (msec) for real-time internal RAM sampling.  

The internal RAM area can be sampled in real time during emulation.  

The variables and data allocated to this area can be displayed in close to real time in Watch window 

and Memory window.  

The sampling time can be specified in a range of 0 to 65500 in units of 100 msec.  If 0 is specified, or if 

this area is blank, the sampling time is not displayed in real time.

(5) Break condition (break mode setting area)

This area is used to select whether a break occurs before or after the instruction of a breakpoint is 

executed.   This setting affects only hardware breaks.  

Frame Size Setting Unit

0 to 64K 4K

64K to 1M 64K

1M to 16M 1M
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(6) Break Sound (beep sound specification area)

This area is used to specify whether a beep sound is issued upon the occurrence of a break.  

If the check box is checked, a beep sound is issued when a break occurs (default).

(7) Verify Check (verify specification area)

This area is used to specify whether a verify check is performed when data has been written to 

memory.  

If the check box is checked, a verify check is performed when download, memory fill, or memory copy 

is executed (default).  A verify check is also performed when a variable or data is changed in Watch 

window or Memory window and is written to memory.

(8) Back Step (back execution type selection area)

Select the back execution type from the drop-down list.

(9) Project Save Level (project save level selection area) 

This area is used to select the save level of a project file related to the simulator.  

Before Sets a Run event as an event before executing (default).  
The event occurs before the instruction is executed.

After Sets a Run event as an event after executing.  
The event occurs after the instruction is executed.  

Instruction Enables back execution of all the executed instructions (default).

Break Enables back execution of only those locations where program 
execution breaks occurred.

Branch Enables back execution of only the locations where the program 
execution branched due to a CALL instruction, BR instruction, or 
interrupt.

Event Enables execution of only the locations where an event occurred.

Basic Saves only the user-set debug environment (such as window status 
and event setting status) (default).  
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Function buttons  

Normal Saves the contents of Basic and the status of the internal instructions 
of the simulator (project information such as instructions, memory, 
registers, and SFR), which are stopped.  

Full Saves contents of Normal and all debug information generated 
during simulation (such as trace and coverage results).  

OK Validates the settings and closes this dialog box.  

Cancel Cancels the settings and closes this dialog box.

Restore Restores the previous settings before this dialog box was opened.

Help Opens the Help window.  
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Debugger Option dialog box

This dialog box is used to display and set the extended options of the debugger.  

Figure 6-7　Debugger Option Dialog Box

This section explains the following items:  

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

• Select [Option] -> [Debugger Option...] from the menu bar   
 (or press Alt+O, and G in that order).  

Explanation of each area  

The Debugger Option dialog box consists of the following areas:

(1)　Source Path (source path specification area)
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(2)　Default Extension (default extension specification area)

(3)　Open File History (open file history setting area)

(4)　Font (display font setting area)

(5)　Project File (project file setting area)

(6)　Tool Bar Pictures (toolbar display button setting area)

(7)　Kanji (Kanji code setting area)

(8)　Tab Size (tab size setting area)

(9)　Startup Routine (start-up symbol setting area)

(10)　DisAssemble  (offset display setting area)

(11)　Watch Default (watch symbol setting area)

(1) Source Path (source path specification area)

This area is used to specify the directory in which a source file or text file is searched.  

A path can be input from the keyboard or set by the <Browse...> button.  A relative path can also be 

specified.  

The directory that is the basis of a relative path is displayed on the right of Base:.  The base directory is 

determined in the following sequence:  

•  Directory to which the project file has been loaded  

•  Directory to which a load module or hex file has been loaded last  

•  Current directory of Windows

To delimit paths, use ";" (semicolon) or "," (comma).  

Japanese characters can be specified in a source path (Japanese version only).  

Example: If a source is in the following directory  

B:\src

C:\asm

The source path is specified as follows:

B:\src; C:\asm

Clicking the <Browse...> button displays the Add Source Path dialog box shown in Figure 6-8, and a 

source path can be added.  

Reference: Immediately after the Debugger Option dialog box has been opened, the base directory is

selected and opened. When the dialog box is opened the second and subsequent times, the

previously displayed directory is recorded and displayed again.

If the selected directory has already been set for the source path, a source path is not added.  
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Figure 6-8　Add Source path Dialog Box

(2) Default Extension (default extension specification area)  

Delimit extensions with " " (blank),";" (semicolon) or "," (comma).  

(3) Open File History (open file history setting area)  

This area is used to set the number of histories (0 to 10) of the open file displayed in the bottom field of 

the [File] menu.  If 0 is set, no history is displayed on the menu.  

The default value is 4.  

Source File Set the extension of a source file that is displayed when the Browse 
dialog box is opened by selecting [File] -> [Open...] from the menu 
bar.  
The default extension is "*.C, *.S, *.ASM".  

Load Module Set the extension of a load module that is displayed when Download 
dialog box is opened.  
The default extension is "*.LNK, *.LMF".  
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(4) Font (display font setting area)  

This area is used to specify the font displayed on the Source window.  Clicking the <Font> button 

opens the Font dialog box in which the font to be displayed and its size can be set.  

(5) Project File (project file setting area)  

This area is used to set automatic saving and loading of the project file.   

Auto save

Sets whether the project file is automatically saved at the SM78Kx termination.  

Auto Load

Sets whether the project file is automatically loaded at the SM78Kx start up.  

Load Project File

Specify the project file to be loaded automatically.  

This item can be specified only when On is specified for Auto Load.  

Set a project file name by inputting from the keyboard or clicking the <Browse...> button.  Clicking the 

<Browse...> button displays Browse dialog box.  

On Automatically saves the project file at the SM78Kx termination.   

Off Does not automatically save the project file at the SM78Kx 
termination.   

Query Displays the Exit Debugger dialog box at the SM78Kx termination 
(default).  

On Automatically loads the project file at the SM78Kx start up.  
Sets whether the Load Project File is automatically loaded.  

Off Does not automatically loads the project file at the SM78Kx start up 
(default).
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(6) Tool Bar Pictures (toolbar display button setting area)  

This area sets the buttons to be displayed on the toolbar.  

(7) Kanji (Kanji code setting area)  

This area is used to specify Kanji codes to be displayed in the Source window and Trace window.  

Kanji codes can be specified only on the Japanese Windows.  

(8) Tab Size (tab size setting area)  

This area is used to set the tab size for each extension when files are displayed.  

Extension

Set an extension.  Input an extension from the keyboard, or select one from the drop-down list.  

Tab Size

Select the tab size.  Select how many spaces are displayed as a tab code.  

Pictures and Text Displays a button on which a graphic and character are displayed.

Pictures only Displays a button with only graphic (default).  

Sjis Uses SJIS as Kanji codes (default).  

Euc Uses EUC as Kanji codes.  

2 Displays two spaces.  

4 Displays four spaces.  

8 Displays eight spaces (default).  
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Tab List

Displays the tab size set for each extension.  

To change the tab size setting,  

select Extension and Tab Size and click the <Add> button.  

The selected tab size is changed to the tab size set in Extension.  

To delete the tab size setting,  

select the setting to be deleted from Tab List and click <Delete> button.  

The setting of the extension currently selected will be deleted.  

(9) Startup Routine (start-up symbol setting area)  

This area is used to specify the first address and end address of the text area (code area) of the start-

up routine by symbols.  

Specify the symbol of the first address as Begin label, and the symbol of the last address as  End label.  

In this way, the source file can be automatically opened if an object file in the load module format is 

downloaded in Download dialog box.  Specify the source file to be displayed at this time as  main( ) 

label, as a display start symbol.  

If the specified symbol is not correct, the source file cannot be opened until the PC reaches the 

address range of the corresponding source file.  In addition, the start-up routine cannot be skipped by 

step execution.  

Caution: Be sure to specify this area.  If this area is blank, the dialog box cannot be closed.  

(10) DisAssemble  (offset display setting area)  

Performs the setting for disassemble display.  

Show Offset

Specifies whether an offset (symbol + offset) is displayed during disassemble display.  

When the offset is not displayed, only a symbol that matches a numeric value is displayed, if any.  If no 

matching symbol is found, the numeric value is displayed as a hexadecimal number unchanged.  

Begin label Symbol of first address (default: _@cstart)  

End label  Symbol of end address (default: _@cend)

main() label Display start symbol (default: _main)
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Register Name (register name display selection area)

This area is used to select the method of displaying register names in mnemonics during disassemble 

display.  

(11) Watch Default (watch symbol setting area)  

This area is used to specify a symbol to be watched.  

Size (default size specification)  

Sets the display size of data if [Adaptive] is selected in Watch window.  

Radix (default radix specification)

Sets the default radix in which data is to be displayed if [Proper] is specified in Watch window.  

Show Variable Type (display/non-display of variable type)  

Selects whether the type of a variable is displayed or not.  

Label Specifies whether the offset is displayed in the Label field.  
This check box is not checked in the default condition, and the offset 
is not displayed.  

Mnemonic Specifies whether the offset is displayed in the Mnemonic field.  
This check box is checked in the default condition, and the offset is 
displayed.  

Function Name Displays register names as function names or nicknames.  

Absolute Name Displays register names as absolute names.  

Byte 8-bit display(default)

Word 16-bit display

Double Word 32-bit display

Hex Displays data in hexadecimal numbers (default).

Dec Displays data in decimal numbers.

Oct Displays data in octal numbers.

Bin Displays data in binary numbers.

String Character string
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Language (display/non-display of type of variable)  

Selects the display format of the base number.   

Function buttons

On Displays the type of a variable.

Off Does not display the type of a variable (default).  

C Displays a C-like base number (default).  

ASM Displays an assembly language-like base number.  

OK Validates the settings and closes this dialog box.  

Cancel Cancels the settings and closes this dialog box.

Restore Restores the previous settings before this dialog box was opened.

Help Opens the Help window.  



94 User’s Manual  U16768EJ1V0UM

CHAPTER 6  WINDOW REFERENCE

Font dialog box

This dialog box is used to select the font to be displayed in the Source window.  

Figure 6-9　Font Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

• Click the <Font> button in Debugger Option dialog box.  

Explanation of each area

The Font dialog box consists of the following areas:

(1)　Font Face: (font name specification area)

(2)　Size: (font size specification area)

(3)　Sample (sample display area)
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(1) Font Face: (font name specification area)

This area is used to select a font from the fonts currently usable.  

Only fonts with equal width (fonts with a constant stroke width and a fixed pitch) are enumerated.  

When a font name is selected from the list, the font name is displayed in the text box, and the font size 

that can be used with that font is displayed under Size.  

(2) Size: (font size specification area)

This area is used to specify the font size.  

On the drop-down list, the font size usable for the font specified in Font Face is displayed in point units.  

When the font size is selected from the drop-down list, the selected font size is displayed in this area.  

The font size can also be directly input to the text box from the keyboard.  

(3) Sample (sample display area)

This area displays a sample character string of the specified font and size.  

Function buttons

OK Changes the font and its size in the Source window as specified, and closes 
this dialog box.

Cancel Closes the dialog box without changing the font.
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Project File Save dialog box

Saves the debug environment.

It is used to save a new project file or an existing file with the file name changed (refer to "Setting

Debugging Environment (p.35)").  

When a file is saved, the size and position of the window that has been displayed are also saved.  

Figure 6-10　Project File Save Dialog Box

The following contents are saved to the project file:

Table 6-6　Contents Saved to Project File

Window Name Set Data

Configuration dialog box All items (target device, clock setting, pin mask setting, 
mapping information)  

Main window Display position, tool bar/status bar/button display 
information, execution mode, information, trace on/off 
information, coverage on/off information

Download dialog box File information to be downloaded

Extended Option dialog box, 
Debugger Option dialog box

Set information

Source window Display information, font information of window

Assemble window, 
Memory window

Display information of window, display start address
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This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

• Related operations

•  To automatically save a project file

Opening

This dialog box can be opened as follows:

• Select [File] -> [Project] -> [Save As...] from the menu bar
 (or press Alt+F, J and A in that order).

To save a file of same name as a project file previously loaded or saved

• Select [File] -> [Project] -> [Save...] on the menu bar
 (or press Alt+F, J and S in that order).

Stack Trace window, 
SFR window, 
Local Variable window, 
Trace window, 
Event Manager, 
Coverage window,
Console window, 
Expansion window

Display information of window

Event dialog box Display information of window, event information

Event Link dialog box Display information of window, link event information

Break dialog box Display information of window, break event information

Trace window Display information of window, trace event information

Snap Shot dialog box Display information of window, snap event information

Stub dialog box Display information of window, stub event information

Timer dialog box Display information of window, timer event information 

Register window Display information of window, display bank information 

Watch window Display information of window, watch registration information

Add I/O Port dialog box Added I/O port information  

Delay Count dialog box Delay count value

78Kx Simulator GUI window, 
Parts window, 
Output Timing Chart window

Display information of window, pin status

Table 6-6　Contents Saved to Project File

Window Name Set Data
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Explanation of each area

The Project File Save dialog box consists of the following areas:

(1)　Save in:, File name: (file selection area)

(2)　Save as type: (extension selection area)

(1) Save in:, File name: (file selection area)

This area is used to specify a file name.  A file name can be directly input from the keyboard, or 

selected from the list at the upper part of this area.  

Up to 64 character string with a extension can be specified.  

(2) Save as type: (extension selection area)

This area is used to specify the extension (.PRJ) of the project file to be loaded.

If the extension is omitted, .PRJ is appended as the default extension.

Function buttons

Related operations

To automatically save a project file

Use Project File (project file setting area) in Debugger Option dialog box that is opened when [Option] 

-> [Debugger Option...] is selected from the menu bar.

Select On for Auto Save in this area.  The current environment will be automatically saved to the 

project file when the dialog box is closed.

Save Saves the project information to the selected file.  After saving, the dialog box is 
closed.

Cancel Closes this dialog box without saving the file.

Help Opens the Help window.
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Project File Load dialog box

This dialog box is used to return the debug environment to the previous environment.  

After a file has been loaded, the size and position of the window is returned to the previous status (status

saved to a project file) (refer to "Setting Debugging Environment (p.35)").  

After a project file has been loaded, it is displayed on the top of an active Source window if any.  

By loading the project file, the items to be saved in Table 6-6  Contents Saved to Project File (p.96) are

set.

Caution: If a project file different from the target device after the debugger has been loaded is

loaded, the debugger loads the project file after it has been reset (the debugger is then

used as the target device specified by the project file).  

Figure 6-11　Project File Load Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

• Related operations

•  To automatically load a project file

Opening

This dialog box can be opened as follows:
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• Click the Proj button.

• Select [File] -> [Project] -> [Open...] on the menu bar
 (or press Alt+F, J and O in that order).

Explanation of each area

The Project File Load dialog box consists of the following areas:

(1)　 Look In: , File name: (file selection area)

(2)　Files of type: (extension selection area)

(1) Look In: , File name: (file selection area)

This area is used to specify a file name.  A file name can be directly input from the keyboard, or 

selected from the list at the upper part of this area.  

Up to 64 character string with a extension can be specified.  

(2) Files of type: (extension selection area)

This area is used to specify the extension (.PRJ) of the project file to be loaded.  

Function buttons

Related operations

To automatically load a project file

Use Project File (project file setting area) in Debugger Option dialog box that is opened when [Option] 

-> [Debugger Option...] is selected from the menu bar.  

Select On for Auto Load in this area and specify the name of the project file to be loaded automatically 

in the Load Project File area.  The specified project file will be automatically loaded when the system is 

started next time.

Open Loads the selected file.  After loading the file, this dialog box is closed.

Cancel Closes this dialog box without loading the file.

Help Opens the Help window.
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View File Save dialog box

This dialog box is used to save the contents of the current window to a view file or event setting file when

a dialog box is opened.  

Figure 6-12　View File Save Dialog Box
View File Save Dialog Box (Example: to Save Assemble Window)

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

• Reference information

•  Regarding files saved in the View File Save dialog box

Opening

This dialog box can be opened as follows:

• When the window to be saved is the current window
Select [File] -> [Save As...] from the menu bar
 (or press Alt+F and A in that order).
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Explanation of each area

This dialog box consists of the following areas:

(1)　Save in:, File name: (file selection area)

(2)　Save as type: (extension selection area)

(3)　Save range (save range setting area)

(1) Save in:, File name: (file selection area)

This area is used to specify a file name.  A file name can be directly input from the keyboard, or 

selected from the list at the upper part of this area.  

(2) Save as type: (extension selection area)

This area is used to specify the type (extension) of the file.

The extension of the file corresponding to the current window is displayed as follows:

(3) Save range (save range setting area)

This area is displayed if the current window to be saved is the Assemble window, Memory window, 

Coverage window, Source window, or Trace window.  

Specify the range of data to be saved by selecting any of the following:

Table 6-7　Extension Corresponding to Current Window

File Type (Extension) Current Window Name

Source Text (*.SVW) Source window

Assemble (*.DIS) Assemble window

Memory (*.MEM) Memory window

Watch(*.WCH) Watch window

Register (*RGW) Register window

SFR (*.SFR) SFR window

Local Variable (*.LOC) Local Variable window

Stack Trace (*.STK) Stack Trace window

Trace (*.TVW) Trace window

Coverage (*.COV) Coverage window

Console (*.LOG) Console window

All (*.*) All files
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Specify Line (if current window is Source window)

Specify the range of the line numbers to be saved.  The default radix for inputting a numeric value is 

decimal.  

If the Source window is in the mixed display mode, the mixed displayed part on the specified line is 

also saved.

If a range of 100 lines or more is specified, a message dialog box is displayed to indicate the progress 

of saving.  To stop saving midway, click the <Stop> button in the message dialog box.  

Specify Frame (if current window is Trace window)

Specify the range of trace frames to be saved (for how to specify, refer to "Trace Move dialog box").  

The default radix for inputting a numeric value is hexadecimal.  

If a range of 100 frames or more is specified, a message dialog box is displayed to indicate the 

progress of saving.  To stop saving midway, click the <Stop> button in the message dialog box.  

Specify Address (if current window is Assemble window, Memory window, or Coverage window)

This area is used to specify the address range in which data is to be saved to the file.  An address can 

be also specified by a symbol or expression (refer to "Table 6-15  Specifying Symbols (p.130)").  The 

default radix for inputting a numeric value is hexadecimal.  

If a range of 256 bytes or more is specified, a message dialog box is displayed to indicate the progress 

of saving.  To stop saving midway, click the <Stop> button in the message dialog box.  

All Saves the entire range, from the first line to the last line.

Screen shot Saves the area visible on the screen, from the top line on the screen to 
the bottom line.  If the Source window is in the mixed display mode, 
however, the window contents are saved from the source line that 
includes the area visible on the screen.

Specify Line
Specify Frame
Specify Address
above any

Specify the start line and end line of the area to be saved.  If the start line 
and end line are omitted, the first line and last line are assumed.  For 
details, it is as follows.
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Function buttons

Reference information

Regarding files saved in the View File Save dialog box

Files are saved in the View File Save dialog box in text format. Therefore, these files can be displayed 

and printed with a regular text editor.  

Save Saves the information of the current dialog box to the selected file.  After 
saving, the dialog box is closed.  

Cancel Closes this dialog box without saving the file.  

Help Opens the Help window.

Restore Restores the status before this dialog box was opened.
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View File Load dialog box

This dialog box is used to read the view file, source file, text file, event setting file, watch setting file, or

SFR setting file saved in the View File Save dialog box, and open a window.

The window to be opened and its status differ as follows, depending on the file to be loaded.

Loading source file to which symbol information has been read

If there is a Source window in the active status, it is opened in the static status; otherwise, the Source 

window is opened in the active status.

Loading source file to which symbol information has not been read, or view file

A window of text-format files is opened in the Source window in the static status.

Caution: If an environment file is opened in the View File Load dialog box, it is opened as a text-

format file in a static Source Text window.

Figure 6-13　View File Load Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

• Click the Open button.
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• Select [File] -> [Open...] on the menu bar
 (or press Alt+F and O in that order, or press Ctrl+O).

Explanation of each area

This dialog box consists of the following areas:

(1)　 Look In: , File name: (file selection area)

(2)　Files of type: (extension selection area)

(1) Look In: , File name: (file selection area)

This area is used to specify a file name.  A file name can be directly input from the keyboard, or 

selected from the list at the upper part of this area.  

Up to 64 character string with a extension can be specified.  

(2) Files of type: (extension selection area)

This area is used to specify the type (extension) of the file to be loaded.

Table 6-8　Type of File That Can Be Loaded on View File Load Dialog Box

File Type (Extension) Meaning

Source (*.C, *.S, *.ASM) Source file
The extension of the source (c, s, asm) can be changed in 
Debugger Option dialog box.

Text (*.TXT) Text file

Source Text (*.SVW) Source windowView files

Assemble (*.DIS) Assemble window view files

Watch (*.WCH) Watch window setting files

Memory (*.MEM) Memory window view files

Register (*.RGW) Register window view files

SFR (*.SFR) SFR window setting files

Local Variable (*.LOC) Local Variable window view files

Stack Trace (*.STK) Stack Trace window view files

Trace (*.TVW) Trace window view files

Coverage (*.COV) Coverage window view files 

Console (*.LOG) Console window

All (*.*) All files
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Function buttons

Open Loads the selected file.  After loading the file, this dialog box is closed.

Cancel Closes this dialog box without loading the file.

Help Opens the Help window.
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Environment File Save dialog box

This dialog box is used to save the setting contents of the window that was current when this dialog box

was opened (Watch window, SFR window, Event Manager) to an environment file.

Figure 6-14　Environment File Save Dialog Box
Environment File Save Dialog Box (Example: to Save Watch window)

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

• When the window to be saved is the current window
Select [File] -> [Environment] -> [Save As...] from the menu bar
 (or press Alt+F, E and A in that order).

Explanation of each area

This dialog box consists of the following areas:

(1)　Save in:, File name: (file selection area)

(2)　Save as type: (extension selection area)
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(1) Save in:, File name: (file selection area)

This area is used to specify a file name.  A file name can be directly input from the keyboard, or 

selected from the list at the upper part of this area.  

(2) Save as type: (extension selection area)

This area is used to specify the type (extension) of the file.

The extension of the file corresponding to the current window is displayed as follows:

Function buttons

Table 6-9　Extension Corresponding to Current Window

File Type (Extension) Current Window Name

Watch(*.WCH) Watch window

SFR (*.SFR) SFR window

Event(*.EVN) Event Manager

Save Saves the information of the current dialog box to the selected file.  After 
saving, the dialog box is closed.  

Cancel Closes this dialog box without saving the file.  

Help Opens the Help window.
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Environment File Load dialog box

This dialog box is used to read the Watch window, SFR window, or Event Manager environment file

saved in the Environment File Save dialog box and open a window.

The window to be opened and its status differ as follows, depending on the file to be loaded.

Loading event environment file

The Event Manager is opened, and the event setting contents will return to the previous environment.

Loading watch environment file

The Watch window is opened, and the watch setting contents will return to the previous environment.

Loading SFR environment file

The SFR window is opened, and the peripheral I/O register setting contents will return to the previous 

environment.

Caution: If a view file is opened, an "Ff104: Illegal project file format" error occurs.

Figure 6-15　Environment File Load Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons
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Opening

This dialog box can be opened as follows:

• Click the Open button.

• Select [File] -> [Environment] -> [Open...] on the menu bar
 (or press Alt+F, E and O in that order).

Explanation of each area

This dialog box consists of the following areas:

(1)　 Look In: , File name: (file selection area)

(2)　Files of type: (extension selection area)

(1) Look In: , File name: (file selection area)

This area is used to specify a file name.  A file name can be directly input from the keyboard, or 

selected from the list at the upper part of this area.  

Up to 64 character string with a extension can be specified.  

(2) Files of type: (extension selection area)

This area is used to specify the type (extension) of the file to be loaded.

Function buttons

Table 6-10　Type of File That Can Be Loaded on Environment File Load Dialog Box

File Type (Extension) Meaning

Watch (*.WCH) Watch window environment files

SFR (*.SFR) SFR window environment files

Event (*.EVN) Event environment file

Open Loads the selected file.  After loading the file, this dialog box is closed.

Cancel Closes this dialog box without loading the file.

Help Opens the Help window.
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Download dialog box

This dialog box is used to select the name and format of a file to be downloaded, and downloads memory

contents or coverage results to the simulator.

If an object file in the load module format has been downloaded, the corresponding source file is

searched, and Source window is automatically opened.

Format of file that can be downloaded

•  NEC load module format (XCOFF (.LNK, .LMF))

•  Intel Hex format (standard, extended)

•  Motorola Hex format S type (S0, S2, S3, S7, S8)

•  Extended Tektronix Hex format

•  Binary data format

•  Coverage result

Caution: If a file other than an object file in the load module format is loaded, source debugging

cannot be executed.

Figure 6-16　Download Dialog Box

This section explains the following items:

• Opening

• Explanation of each area
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• Function buttons

• Cancel processing

Opening

This dialog box can be opened as follows:

• Click the Load button.

• Select [File] -> [Download...] on the menu bar
 (or press Alt+F, and D in that order).

Explanation of each area

(1)　 Look In: , File name: (file selection area)

(2)　Files of type: (extension selection area)

(3)　Offset Address: (offset setting area)

(4)　 Load (load condition specification area)

(5)　Reset (reset condition specification area)

(1) Look In: , File name: (file selection area)

This area is used to specify a file name.  A file name can be directly input from the keyboard, or 

selected from the list at the upper part of this area.  

Up to 64 character string with a extension can be specified. 

(2) Files of type: (extension selection area)

This area is used to specify the type (extension) of the file to be downloaded.  

The contents displayed on the drop-down list are as follows:  

Reference: These are default extensions; other extensions can also be used.  

The default extension of the displayed load module can also be specified under Default

Extension (default extension specification area) in Debugger Option dialog box.  

Table 6-11　Type of File That Can Be Downloaded

Contents (extension) Format

Load Module(*.LNK, *.LMF) Load module format

Hex Format(*.HEX) Hex format (automatic format identification)

Binary Data(*.BIN) Binary data format

Coverage (*.CVB) Coverage result
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(3) Offset Address: (offset setting area)

This area is used to specify the offset address that is used when a file is loaded (for binary data, 

specify the start address).  An address can be also specified by a symbol or expression (refer to "Table 

6-15  Specifying Symbols (p.130)").  The default radix for inputting a numeric value is hexadecimal.

(4) Load (load condition specification area)

This area is used to set a load condition.  

This setting is valid only if a file in the load module format is specified.  

(5) Reset (reset condition specification area)

This area is used to set a reset condition.  

This setting is valid only if a file in the load module format is specified.  

Function buttons

Symbol Specifies whether symbol information is read (when checked, default) or not.

Object Specifies whether object information is read (when checked, default) or not.

Symbol Specifies whether symbol information is reset (when checked, default) or not.    

CPU Specifies whether the CPU is reset or not (not checked, default).

Open Loads the selected file.  After loading the file, this dialog box is closed.  

Cancel Closes this dialog box without loading the file.

Help Opens the Help window.

Restore Restores the input data to the original status.
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Cancel processing

The following dialog box appears while downloading and the downloading can be cancelled at any time.

The progress of the download is displayed in the dialog box.  

This dialog box is closed automatically after completing downloading.  

If an error occurs during the download, an error message will be displayed in a new window.

Figure 6-17　The Progress of Download
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Upload dialog box

This dialog box is used to set the name and format of the file to which memory contents or coverage

results are to be saved.

Format of specifiable file

•  Intel Hex format (standard ... 16-bit address(SM78K0, SM78K0S), expanded ... 20-bit
address(SM78K4))

•  Motorola Hex format (S0, S2, S8 ... 24-bit address)

•  Extended Tektronix Hex format

•  Binary data format

•  Coverage result

Figure 6-18　Upload Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

• Select [File] -> [Upload...] on the menu bar
 (or press Alt+F, and U in that order).
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Explanation of each area

The Upload dialog box consists of the following areas:

(1)　Save in:, File name:  (saved file name specification area)

(2)　Save as type: (extension selection area)

(3)　Save Address: (save range setting area)

(1) Save in:, File name:  (saved file name specification area)

This area is used to specify a file name.  A file name can be directly input from the keyboard, or 

selected from the list at the upper part of this area.  

Up to 64 characters can be specified including the extension.  

(2) Save as type: (extension selection area)

This area is used to specify the type (extension) of the file.  The format of the data to be saved to the 

file is determined by the extension.

If "All (*. *)" is selected, however, the default Intel extended Hex format is selected.  The contents 

displayed on the drop-down list are as follows:

Reference: These are default extensions; other extensions can also be used.  

(3) Save Address: (save range setting area)

This area is used to specify the address range in which data is to be saved to the file.  An address can 

be also specified by a symbol or expression (refer to "Table 6-15  Specifying Symbols (p.130)").  

The default radix for inputting a numeric value is hexadecimal.  

Table 6-12　Type of File That Can Be Uploaded

Contents (extension) Format

Intel Hex (*.HEX) Intel standard Hex format (SM78K0, SM78K0S), Intel 
expanded Hex format (SM78K4)

Motorola Hex (*.HEX) Motorola Hex format

Tektro Hex (*.HEX) Extended Tektronix Hex format

Binary Data (*.BIN) Binary data format

Coverage (*.CVB) Coverage result

All (*.*) All files
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Function buttons

Save Saves data in the specified address range to the specified file and closes this 
dialog box.  
Closes this dialog box.  The font of the Source window is changed to the 
specified font face and font size, and then the dialog box is closed

Cancel Closes this dialog box without saving the data to the file.

Help Opens the Help window.

Restore Restores the input data to the original status.
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Browse dialog box

This dialog box is used to select the file to be set in the Source Search dialog box or the Source Text

Move dialog box.  

Reference: If this dialog box is opened for the first time after the system has been started up, the

directory first specified by the source path is displayed.  When the dialog box is opened the

second and subsequent times, the previously displayed directory is recorded and displayed

again.  If the <Cancel> button is pressed, however, the previously displayed directory is not

recorded.  

Figure 6-19　Browse Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

• Click the <Browse...> button in the Source Search dialog box or the Source Text Move dialog box.
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Explanation of each area

The Browse dialog box consists of the following areas:

(1)　 Look In: , File name: (file selection area)

(2)　Files of type: (extension selection area)

(1) Look In: , File name: (file selection area)

This area is used to specify a file name.  A file name can be directly input from the keyboard, or 

selected from the list at the upper part of this area.  

Up to 64 character string with a extension can be specified.  

(2) Files of type: (extension selection area)

This area is used to specify the type (extension) of the file to be opened.  

Function buttons

Table 6-13　Type of File That Can Be Displayed in Browse Dialog Box

File Type (Extension) Meaning

Source (*.C, *.S, *.ASM) Source file
The extension of the source (c, s, asm) can be changed in Debugger 
Option dialog box.

Text(*.TXT) Text file

All(*.*) All files

Open Sets the selected file.  After setting the file, closes this dialog box.

Cancel Does not set the file and closes this dialog box.

Help Opens the Help window.
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Address Move dialog box

This dialog box is used to specify the address from which displaying memory contents, results of

disassembly, results of coverage, or SFR are to be displayed.  This dialog box is displayed if [View] ->

[Move] is selected from the menu bar while the Memory window, the Assemble window, the Coverage

window, or the SFR window is opened, and enables the display start address of data to be changed.

Figure 6-20　Address Move Dialog Box
(Example: When Memory Window Is Open)

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

When the Memory window, Assemble window, Coverage window, or SFR window is opened

• Select [View] -> [Move...] from the menu bar 
(or press Alt+V and V in that order, or press Ctrl+J).

Explanation of each area

The Address Move dialog box consists of the following areas:

(1)　To (address specification area)

(1) To (address specification area)

This area is used to specify an address.  In the default condition, the string selected in the window that 

called this dialog box, the current PC value (Memory window, Assemble window, Coverage window), 

or blank (SFR window) is displayed.   

An address can be also specified by a symbol or expression (refer to "Table 6-15  Specifying Symbols 
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(p.130)").  The default radix for inputting a numeric value is hexadecimal.  

By displaying the input history, the contents previously input can be reused.  

Up to 16 input histories can be recorded.

Function buttons

OK Displays the memory contents, results of disassembly, results of coverage, or 
SFR.  

Cancel Closes this dialog box.

Restore Restores the input data to the original status.

Help Opens the Help window.
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Source Text Move dialog box

This dialog box is used to specify a file to be displayed in the Source window and the position from which

displaying the file is to be started.  

This dialog box is selected if [View] -> [Move...] is selected from the menu bar while the Source window is

open, and enables the display start position of a file to be changed (a new window is not opened).  

Figure 6-21　Source Text Move Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Specifying

•  Specifying a display start position by an address (or symbol).

•  Specifying a file to be displayed in the Source window

• Function buttons

Opening

This dialog box can be opened as follows:

When the Source window is active

• Select [View] -> [Move...] 
(or press Alt+V and V in that order, or press Ctrl+J).

Explanation of each area

The Source Move dialog box consists of the following areas:

(1)　Option (input mode selection area)

(2)　To (file/address specification area)
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(1) Option (input mode selection area)

This area is used to select the input mode when the display start position is specified.  

(2) To (file/address specification area)

This area is used to specify the file name or address to be displayed.  In the default condition, the 

character string selected in the window that called this dialog box is displayed in this area.  If no 

character string has been selected, the first character string of the input history is displayed.  If no input 

history is available, the current PC is displayed.  As necessary, the character string displayed in this 

area can be changed by directly inputting a character string from the keyboard.  

By displaying the input history, the contents previously input can be reused.  Up to 16 input histories 

can be recorded.

Specifying

On this dialog box, the following two items can be specified.  

• Specifying a display start position by an address (or symbol).

• Specifying a file to be displayed in the Source window

Specifying a display start position by an address (or symbol).

Select Address/Symbol under Option and specify the address from which display is to be started for 

To.  

An address can be also specified by a symbol or expression (refer to "Table 6-15  Specifying Symbols 

(p.130)").  The default radix for inputting a numeric value is hexadecimal.  

Clicking the <OK> button displays the source text so that the source line corresponding to the specified 

address value can be viewed.  

Specifying a file to be displayed in the Source window  

Select Line/File under Option and specify the name of the file to be displayed in the Source window for 

To.  Specification can be mode using only the file name, or using an absolute path or relative path.

If only the file name is specified, or if a relative path is specified, the files in the directory of the source 

path specified in Debugger Option dialog box  are sequentially searched.  The file that is found first as 

a result of searching is displayed.  

In addition to a file name, a line number can be also specified as follows:  

Address/Symbol If the display start position is specified by an address (or symbol)  

Line/File If the display start position is specified by a line number (or file name)  
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<<path name>file name#>line number

Delimit the file name from the line number with "#".  Specify the line number in decimal.  The file name 

may be omitted.  The default radix for inputting a numeric value is hexadecimal.  

Clicking the <OK> button displays the specified file with the specified line number as the first line.  If 

the file name omitted, the file being displayed is displayed starting from the specified line.  If the line 

number is omitted, the file is displayed starting from its first line.

Function buttons

Browse... Opens the Browse dialog box.

OK Starts displaying the source text from the specified position.

Cancel Closes this dialog box.

Restore Restores the input data to the original status.

Help Opens the Help window.



126 User’s Manual  U16768EJ1V0UM

CHAPTER 6  WINDOW REFERENCE

Trace Move dialog box

This dialog box is used to specify the position from which displaying the Trace window is started.  

This dialog box is displayed if [View] -> [Move...] is selected from the menu bar while the Trace window is

open, and enables the display start position of the trace results to be changed.  

Figure 6-22　Trace Move Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

When the Trace window is displayed

• Select [View] -> [Move...] 
(or press Alt+V and V in that order, or press Ctrl+J).

Explanation of each area

The Trace Move dialog box consists of the following areas:

(1)　Frame selection area

(2)　Frame number specification area
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(1) Frame selection area

This area is used to specify the frame at the destination.

(2) Frame number specification area

This area is used to specify a frame number if Frame No. is selected in the frame selection area.  In the 

default condition, the character string selected in the window that called this dialog box or "Last" is 

selected.  As necessary, however, this can be changed by directly inputting a character string from the 

keyboard.  

The default radix for inputting a numeric value is hexadecimal.  

A frame number can also be specified in the following format.  The uppercase and lowercase 

characters of the input character string are not distinguished.  In addition, a frame number can also be 

specified in abbreviated form.  

1st frame of last block Moves the display start position to the to first frame in the newest 
block of trace data.  

Trigger frame of last block Moves the display start position to a trigger frame in the newest 
block frame of trace data.

Last frame of last block Moves the display start position to the last frame of trace data.

Frame No. Moves the display start position to the specified frame number.
If 0 is specified, the display start position is moved to the first frame 
of trace data.  
If this item is checked, the focus moves to the text box on the side.  

Table 6-14　Frame Number Specification Format

Specification Abbreviation Contents

+numeric value None Moves backward (downward on screen) the display start 
position from the frame at the cursor by the specified number 
of frames (numeric value).  

-numeric value None Moves forward (upward on screen) the display start position 
from the frame at the cursor by the specified number of 
frames (numeric value).  

Top O Moves the display start position to the first frame of trace 
data.

First S Moves the display start position to the first frame of the 
current trace block.  

Trigger T Moves the display start position to the trigger frame of the 
current trace block.  
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By displaying the input history, the contents previously input can be reused.  Up to 16 input histories 

can be recorded.  

Function buttons

Last L Moves the display start position to the last frame of the 
current trace block.  

Bottom B Moves the display start position to the last frame of trace 
data.

OK Starts trace display from the specified position.  

Cancel Closes this dialog box.  

Restore Restores the input data to the original status.  

 Help Opens the Help window.

Table 6-14　Frame Number Specification Format

Specification Abbreviation Contents
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Symbol To Address dialog box

Displays the address of the specified variable or function, or the value of the specified symbol.  

Figure 6-23　Symbol To Address Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

• Select [View] -> [Symbol...] from the menu bar
 (or press Alt+V and Y in that order).

Explanation of each area

The Symbol To Address dialog box consists of the following areas:

(1)　Symbol: (symbol specification and conversion result display areas)  

(2)　Radix (display radix specification area) 

(1) Symbol: (symbol specification and conversion result display areas)

The upper area (symbol specification area) is used to specify the variable, function name, symbol 

name, or line number to be converted.  

In addition, an I/O port name, SFR name, register name, PSW flag name, or expression can be also 

specified.  

In the lower area (conversion result display area), the variable, address of the function, value of the 
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symbol, address of the line number, or value of the expression specified under Symbol is displayed.  

The address value of an I/O port name or SFR name, the register contents of a register name, or flag 

value of a PSW flag name is displayed.  The specification method is indicated below.

Remark: var: Variable name, func: Function name, file: File name, label: Label name, portname: I/O

port name, sfrname: SFR name, regname: Register, pswname: PSW flag name, no: Line

number of source file  

"#" is used as a separator for file names, variables, function names, and line numbers.  

If a specified symbol is not found in the scope, all symbols (static variables, static functions, local 

labels) are searched.  

In the default status, a symbol name takes precedence.  To temporarily change the priority, prefixing 

"$" to a symbol gives the priority to a register name.  

In the default condition, the character string selected in the window that called this dialog box is 

displayed.  As necessary, input data from the keyboard to change the character string.  The default 

radix for inputting a numeric value is decimal.  

To change the contents of the symbol specification area, click the <OK> button.  The conversion result 

will be displayed in the conversion result display area.  

By displaying the input history, the contents previously input can be reused.  Up to 16 input histories 

can be recorded.  

(2) Radix (display radix specification area)

This area is used to specify the radix of the data to be displayed in the conversion result display area.  

Table 6-15　Specifying Symbols

Conversion Target Specification Method

Variable var
file#var (to specify a static function with file name)
func#var (to specify a static function with function name)
file#var (to specify a static function with file name and function name)

Function func
file#func (to specify a static function with file name)

Label label
file#label(to specify a local label with file name)

Line number of source file prog$file#var
file#no

I/O Port portname

SFR sfrname

Register regname

PSW Flag pswname
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Function buttons

Hex Hexadecimal number (default).

Dec Decimal number

Oct Octal number

Bin Binary number

OK If the contents of the symbol specification area have been changed, converts 
the symbol.  
After conversion, closes the dialog box if the contents of the symbol 
specification area have not been changed.  

Cancel Closes this dialog box.

Restore Restores the input data to the original status.  
If the <OK> button has already been clicked, the data is restored to the status 
immediately after the <OK> button was clicked.  

Help Opens the Help window.
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Source window

This window displays source files or text files.  

In Mixed display mode, the program can be disassembled and displayed and online assembly can be

executed while source files are being displayed.  

The Source window that is displaying the source file to which symbol information is read may be in two

statuses: Active Status and Static Status.  

Caution: If program codes is described in an include file and these codes are included in multiple

files, the line numbers and addresses do not correspond on a one-to-one bases.  In

such an include file, function that indicates the correspondence relationship between

line numbers and addresses dose not correctly operate.  

Figure 6-24　Source Window

This section explains the following items:  

• Opening

• Explanation of each area

•  Breakpoint setting/deletion function

• Functions often used (right-click menu)

• Function buttons

• Related operations
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Concerning display  

•  Mixed display mode

•  To set a source path

•  To change the display start position

•  To display another source file

•  To specify the default extension of a source file

•  To convert a symbol

•  To specify the symbol of a start-up routine

•  To set an opened file history

•  To set a beep sound to be issued upon break

•  To change the displayed font

•  To change the displayed tab size

Concerning operation 

•  Start function

•  Come function

•  Program counter setting function

•  Jump function

•  Watch function (referencing data value)

•  To search in a source program

•  To set event after execution

•  Drag & drop function (line/address)

•  Drag & drop function (character string)

Opening

This window can be opened as follows:

• This window is automatically opened if the corresponding source file exists after the download module
file has been downloaded.  

• Click the Src button.  

• Select [Browse] -> [Source] from the menu bar 
 (or press Alt+B, and S in that order).

• Select [Jump] -> [Source] from the menu bar 
 (or press Alt+J and S in that order, or press Ctrl+U).

• Click the <Open> button with selecting a source file or text file in the View File Load dialog box.  

Explanation of each area  

The Source window consists of the following areas:

(1)　Point mark area

(2)　Current PC mark area
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(3)　 Line number/address display area

(4)　Source text display area

(1) Point mark area 

This area displays the Breakpoint setting/deletion function, Event setting status, and Program code.

Breakpoint setting/deletion function

By clicking this area with the mouse, a breakpoint can be set or deleted.    

Setting a breakpoint

A breakpoint can be set on a line for which "*" is displayed in the point mark area (if "*" is not displayed 

for the line, the breakpoint is set on the line above or below the line, whichever has "*" displayed).  

When a breakpoint has been set, 'B (red: Hardware break point (after execution))', 'B (green: Hardware 

break point (before execution))', or 'B (black: Hardware break point (registered but not used))' is 

displayed.   

If a breakpoint is set on a line on which an event breakpoint has already been set, "A" indicating that 

multiple events have been set is displayed.  

Deleting a breakpoint

Click the position at which the breakpoint to be deleted is set.  

If right-click menu -> [Breakpoint] is selected, "B (red: Hardware break point)", "B (green: Hardware 

break point (before execution))", and "B (black: Hardware break point (registered but not used))" are 

deleted.  If another event remains, however, the mark of that event is displayed.  

The 'B' mark is displayed in the following colors, depending on the type and status of the breakpoint.  

A breakpoint becomes valid as soon as it has been set in the point mark area. 

Table 6-16　Details of Setting/Deleting Breakpoint

Display Status of Line Operation on clicking

Blank or with mark other than B Sets a hardware breakpoint
Blank
-> Displays B (red) mark
Other than B mark
-> Displays A mark (indicating setting of multiple events)

With B (red, green, black) mark
(Hardware breakpoint setting status)

Deletes a hardware breakpoint.
->Blank
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Event setting status

The setting status of various events can be displayed.  

If an execution event or access event is set on the corresponding line, a mark corresponding to the 

type of event is displayed.  

If an address range is specified as the address condition of the event, the lower addresses of the range 

are displayed.  

The mask specification of the address condition is not reflected.

Program code

The line marked '*' in the point mark area indicates that a program code corresponding to the line 

number exists.  This program code is displayed only if a load module has been downloaded and 

symbol information has been read.  

(2) Current PC mark area

Table 6-17　Display Color of Breakpoint and Its Meaning

Display Color Meaning

B (red) Valid hardware breakpoint (after execution) is set.

B (green) Valid hardware breakpoint (before execution) is set.
This breakpoint is set, taking precedence over the hardware breakpoint after 
execution.

B (black) Invalid hardware breakpoint is set (registered but not used).
This hardware breakpoint can be validated on the Event Manager or in the 
Break dialog box.

Table 6-18　Meaning of Event Display Mark

Mark Meaning

E Setting of event condition

L Setting of event for event link condition

B Setting of break event

T Setting of trace event

Ti Setting of timer event

S Setting of snapshot event

U Setting of stub event

A Setting of multiple events
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The mark '>', which indicates the current PC value (PC register value), is displayed in this area.  

Clicking this mark with the mouse displays a pop-up window that shows the PC register value.  

By double-clicking the current PC mark area, the program can be executed up to a specified line.  

(3) Line number/address display area

This area displays the line numbers of a source file or text file.  

If a Program code corresponding to a line number of the source file exists, the character of the line 

number is displayed in red.  If a program code does not exist, the character of the line number is 

displayed in black.  

In the mixed display mode, disassembled addresses are displayed.  The characters of an address are 

displayed in gray.  

In this area, any position can be selected (highlighted) by clicking the mouse button.  The selected line 

number of an address can be dragged to another window or area, so that its variable value can be 

displayed or the line number of the address can be specified as an event condition (refer to "Drag & 

drop function (line/address) (p.142)").  

(4) Source text display area

This area displays source files or text files.  

A data value can be temporarily displayed by selecting (highlighting) a character string and placing the 

mouse cursor over it (Balloon watch function).  

The current PC line and the line on which a breakpoint is set are emphasized for display, as follows:  

In the mixed display mode, the color of only the disassemble display line is changed (the source line is 

displayed in the normal color). 

In this area, the following functions can be used on the line or address on which the cursor is placed 

(start address of program code):  

-> Start function

-> Come function

Current PC line
(Yellow)

This line is the source line or disassemble display line corresponding 
to the current PC value (indicated by '>').  
In the mixed display mode, the color of only the disassemble display 
line is changed (the source line is displayed in the normal color).

Breakpoint setting line
 (red)

This line is the source line or a disassemble display line on which a 
valid breakpoint is set (indicated by a 'B' mark in red or green). 
In the mixed display mode, the color of only the disassemble display 
line is changed (the source line is displayed in the normal color).
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-> Program counter setting function

-> Jump function

Caution: If a Program code does not exist on the source line, the top address of the line above or

below the line on which a program code exists is manipulated by these functions.  

These functions cannot be performed in the following cases.  The corresponding menu

will be dimmed and cannot be selected.  

If a file other than a source file is displayed

While the user program is being executed

A character string selected in this area can be dragged and dropped to another window or dialog box 

(refer to "Drag & drop function (character string) (p.143)").  

Caution: Up to 319 characters can be displayed on 1 line.

Functions often used (right-click menu)

In this window, functions that are often used can be selected from the menu that is displayed by clicking

the right mouse button.  In this way, the same function can be used more easily than with the normal

procedure.

Move... Moves the display position.
Opens the Source Text Move dialog box.  

Mix Turns on/off mixed display of disassembly.  
Checked: Mixed display
Not checked: No display (default)

Add Watch Adds the specified data to the Watch window.
Opens the Add Watch dialog box.  

Symbol Displays the address of the specified variable or function, or the value of 
the specified symbol.  
Opens the Symbol To Address dialog box.  

Break when Access to
this VariableNote

Creates a break event for a read/write access.  

Break when Write to this
VariableNote

Creates a break event for a write access.  

Break when Read from
this VariableNote

Creates a break event for a read access.  

Clear Deletes the selected break event condition.  

Event? Selects a line or variable name. 

Come Here Executes the program from the current PC to the cursor position (Come 
function).

Change PC Sets the address at the cursor position to the PC.  
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Note: No breakpoint can be set for structure and union members, array members, bit field 
members, etc. In such a case, get the address in the Symbol To Address dialog box and then 
set a breakpoint for that address.

Function buttons  

Break Point Sets or deletes a breakpoint at the cursor position.

Assemble Disassembles and displays starting from the jump destination address 
specified by the data value at the cursor position.  
Opens the Assemble window.  
If an active Assemble window is open, that window is displayed in the 
forefront (so that it can be manipulated).  

Memory Displays the memory contents starting from the jump destination address 
specified by the data value at the cursor position.  
Opens the Memory window.  
If an active Memory window is open, that window is displayed in the 
forefront (so that it can be manipulated).  

Coverage Displays the coverage measurement results starting from the jump 
destination address specified by the data value at the cursor position.  
Opens the Coverage window.  
If an active Coverage window is open, that window is displayed in the 
forefront (so that it can be manipulated).  

Search... Opens the Source Search dialog box and searches a character string of the 
source text.  
If a character string is selected in the source text display area, the Source 
Search dialog box is opened to search the character string.  If no character 
string is selected, the Source Search dialog box is opened with nothing 
specified to be searched.  
Specify a search method in the Source Search dialog box.  The result of search 
is highlighted in the Source window.  
This is the same operation as selecting [View] -> [Search...] from the menu bar.  
This button is invalid while the user program is executed.  

<< Searches forward (upward on screen) for the text that satisfies the search 
condition set in the Source Search dialog box, starting from the address at the 
cursor position.  
This button is displayed as the <Stop> button during a search.  
This button is invalid while the user program is executed.  

>> Searches backward (downward on screen) for the text that satisfies the search 
condition set in the Source Search dialog box, starting from the address at the 
cursor position.  
This button is displayed as the <Stop> button during a search.  
This button is invalid while the user program is executed.  

Stop
 (during search)

Stops searching.

Watch Adds the variables selected in the source text display area to the Watch 
window.  If the Watch window is not opened, it is opened.  
If no text is selected in the source text display area, the Watch window is only 
opened.  
This is the same operation as selecting [View] -> [View Watch] from the menu 
bar.  
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Related operations

Mixed display mode

The normal display mode and mixed display mode can be alternately selected by selecting [View] -> 

[Mix] from the menu bar.  

Normal display mode

In the normal display mode, general text files can be displayed as well as source files.  

Mixed display mode

In the mixed display mode, disassembly of programs combined with source files is displayed and 

online assembly is carried out. (This mode is valid only when a load module is being downloaded and 

symbol information is being read, and the source file that corresponds to the downloaded load module 

is displayed).  

If a program code corresponds to the line of the displayed source file, the disassembly line is displayed 

next to the source line.  In the disassembly line, an address label, a code data, and a disassembled 

mnemonic are displayed (the starting position for display of the mnemonic can be adjusted by the tab 

size setting value).  

To execute online assembly, move the cursor to a mnemonic.  The results of online assembly are also 

reflected in the Memory window.  

The contents displayed in the mixed display mode can be saved as a view file.  

Caution: If it scrolls by the cursor key at the time of mixed display mode, excessive scrolling may

occur.

By the cursor key, it may be unable to scroll to the last line.

Quick... Temporarily displays the contents, such as a variable, selected in the source 
text display area in the Quick Watch dialog box.  Opens the Quick Watch dialog 
box.  If no text is selected in the source text display area, the Quick Watch 
dialog box is only opened.  
This is the same operation as selecting [View] -> [Quick Watch] from the menu 
bar.

Refresh Updates the contents of the window with the latest data.  

Close Closes this window.
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To set a source path

Set a source path under Source Path (source path specification area) in the Debugger Option dialog 

box that is opened by selecting [Option] -> [Debugger Option] from the menu bar.  

To change the display start position

Change the display start position in the Source Text Move dialog box that is opened when right-click 

menu  -> [Move...] is selected in the Source window.  

To display another source file

Select [File] -> [Open] from the menu bar and specify a file.  

To specify the default extension of a source file

Set a source path under Default Extension (default extension specification area) in the Debugger 

Option dialog box that is opened by selecting [Option] -> [Debugger Option] from the menu bar.  

To convert a symbol

Convert symbols in the Symbol To Address dialog box that is opened when right-click menu -> 

[Symbol...] is selected in the Source window.  

To specify the symbol of a start-up routine

Specify the symbol of a start-up routine under Startup Routine (start-up symbol setting area) in the 

Debugger Option dialog box that is opened by selecting [Option] -> [Debugger Option...] from the 

menu bar.  If the setting in this area is wrong, the source file cannot be opened.  

To set an opened file history

Set an opened file history under Open File History (open file history setting area) in the Debugger 

Option dialog box that is opened by selecting [Option] -> [Debugger Option...] from the menu bar.  The 

number of a history display of the opened files can be specified in this area.  

To set a beep sound to be issued upon break

Set the beep sound under Break Sound (beep sound specification area) in the Extended Option dialog 

box that is opened by selecting [Option] -> [Extended Option...] from the menu bar.  

To change the displayed font

Change the displayed font in the Font dialog box that can be opened by clicking the <Font...> button in 

the Debugger Option dialog box that is opened when [Option] -> [Debugger Option...] is selected from 

the menu bar.  

To change the displayed tab size

The displayed tab size can be specified for each file extension under Tab Size (tab size setting area) in 

the Debugger Option dialog box that is opened when [Option] -> [Debugger Option...] is selected from 

the menu bar.  

Start function

This function is used to execute the user program from the line on which the cursor is placed.

Method
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Move the cursor to the line from which the program is to be executed, and select right-click menu -> 

[Start From Here].  

Come function

This function is used to execute the user program to the line on which the cursor is placed (while the 

user program is being executed in this mode, the break event currently set does not occur).  

Method

Move the cursor to the line on which the break is to occur, and select right-click menu -> [Come Here].  

Program counter setting function

This function is used to set the address of the line on which the cursor is placed to the program counter 

(PC).  

Method

Move the cursor to the line that is to be set to the PC, and select [Run] -> [Change PC] from the menu 

bar.  

Jump function

This function is used to jump to the Memory window,using the selected variable as a jump pointer.  

The jump destination window will be displayed from the vicinity of the jump pointer.  

1 Select the name of variable as a jump pointer with the mouse.  

2 In the Main window, to jump to the Memory window 

Select [Jump] -> [Memory] from the menu bar.  

 (or press Alt+J and E in that order, or press Ctrl+M).  

• To jump from the Trace window to the Memory window or Coverage window, the jump source address
differs as follows, depending on the cursor position in the trace result display area: 

• To jump from the Register window, move the cursor to a register value.  

• To jump from the Stack Trace window, the jump destination is as follows:  

[With current function]

- If the jump destination is the Source window

 -> Jumps to the current PC line.

- If the jump destination is a window other than the Source window

 -> Jumps to the current PC address. 

[With function other than current function]

- If the jump destination is the Source window 

 -> Jumps to the line that calls a nested function. 

- If the jump destination is a window other than the Source window

 -> Jumps to the address next to the instruction that calls a nested function.

If the cursor is at an access address, access data, or access 
status 

-> Access address 

Other than above -> Fetch address 

To jump to the Source window or Assemble window -> Fetch address 
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Watch function (referencing data value)

Data values can be displayed as follows: 

To temporarily display a value

The following two methods can be used:

•  Select (highlight) a character string and put the mouse cursor on it then the data value is displayed
(Balloon watch function).  

•  Select (highlight) a character string and click the <Quick> button.  The Quick Watch dialog box will
be opened to display the data value.  

To trace the change of a data value

Register a variable or symbol to the Watch window in either of the following ways: 

•  Select (highlight) the character string whose data value is to be displayed, click the <Watch> button,
or drag the character string to the Watch window and register it to the window (refer to "Drag & drop
function (character string) (p.143)").  

•  Select (highlight) the character string whose a data value is to be displayed and register the data
value from the Add Watch dialog box that is opened when right-click menu -> [Add Watch] is
selected.  

To search in a source program

 Use the Source Search dialog box that is opened by clicking the <Search...> button in the Source 

window.  

If the character string to be searched exists in the window, select that character string and click the 

<Search...> button.  The selected character string will be opened in the specified format.  

To set event after execution 

Set an event after execution under Break condition (break mode setting area) in the Extended Option 

dialog box that is opened by selecting [Option] -> [Extended Option...] from the menu bar.  If a normal 

hardware breakpoint is set after this setting was performed, the hardware breakpoint is set as an event 

after execution.  This setting only affects hardware breakpoints.  In the default condition, an event 

before execution is set.

Drag & drop function (line/address)

The line number or address selected and highlighted can be dragged to another window or area.  

If the position of the line number or address selected in this area is dragged with the left mouse button, 

the shape of the mouse cursor changes from an arrow to '-'.  When the cursor is moved to the window 

or area in which they can be dropped, the mouse cursor changes to 'OK'.  

In the window in which the line number of the address has been dropped, an operation is performed on 

the dropped address or the address that is obtained from the dropped line number.  The operation to 

be performed after dropping the line number or address differs, depending on the window or area in 

which the line number or address has been dropped.  
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Caution: The various event setting dialog boxes includes the Event dialog box, Event Link dialog

box, Break dialog box, Trace dialog box, Snap Shot dialog box, Stub dialog box, and

Timer dialog box.

Drag & drop function (character string)

A selected text can be moved to another window or area by dragging and dropping.  

1 If the selected text is dragged by using the left mouse button, the shape of the mouse cursor

changes from an arrow to '-'. 

2 When the cursor is moved to the window or area in which the text can be dropped, the mouse

cursor changes to 'OK'.

The operation to be performed after dropping the text differs, depending on the window or area in 

which the text has been dropped.  

Table 6-19　Details of Drag & Drop Function (Line/Address)

Window/Area to Drop to Operation After Drop

The Event Manager or the event 
manager area in each various 
event setting dialog box

Automatically creates an execution event condition by using 
the dropped line number or address as an address condition.  
Event condition names are automatically created as 
Evt00001, Evt00002, and so on.  An external sense data 
condition and pass count are not specified.  
The address condition is set for the closest symbol in the 
format of symbol name + offset value.  

Condition setting area in each 
various event setting dialog box 
(other than address and data 
setting areas)

Automatically creates an execution event condition by using 
the dropped line number or address as an address condition.  
The automatically created event condition is set in each 
condition setting area in which the line number or address has 
been dropped.  
Event condition names are automatically created as 
Evt00001, Evt00002, and so on.  An external sense data 
condition and pass count are not specified.  
The address condition is set for the closest symbol in the 
format of symbol name + offset value.  

Condition setting area in each 
various event setting dialog box 
(address and data setting areas)

The text of the dropped line number or address is set in the 
area in which the line number or address has been dropped.  
The address condition is set for the closest symbol in the 
format of symbol name + offset value.  
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Caution: The various event setting dialog boxes includes the Event dialog box, Event Link dialog

box, Break dialog box, Trace window, Snap Shot dialog box, Stub dialog box, and Timer

dialog box.  

Table 6-20　Details of Drag & Drop Function (Character String)

Window/Area to Drop to Operation After Drop

The Event Manager or the event 
manager area in each various 
event setting dialog box

If the dropped text can be converted as a symbol into an 
address value, an event condition in the Access status (all 
access statuses) or Execute status is automatically created, 
using the converted address value as an address condition.  
Event condition names are automatically created as 
Evt00001, Evt00002, and so on.  An external sense data 
condition and pass count are not specified.
The address condition is set by the dropped text.
The relationship between the event condition to be created 
and the symbol is as follows: 
           Symbol                                     Status      
           Variable                                 Access(R/W)
           Function                                Execute
      Symbol in the data section         Access(R/W)
      Symbol in the code section        Execute
           Other                                     Access(R/W)

Condition setting area in each 
various event setting dialog box 
(other than address and data 
setting areas)

If the dropped text can be converted as a symbol into an 
address value, an event condition in the Access status (all 
access statuses) or Execute status is automatically created, 
using the converted address value as an address condition.  
The automatically created event condition is set in each 
condition setting area in which the line number or address has 
been dropped. 
Event condition names are automatically created as 
Evt00001, Evt00002, and so on.  An external sense data 
condition and pass count are not specified.
The address condition is set by the dropped text.
The relationship between the event condition to be created 
and the symbol is as follows: 
          Symbol                                     Status      
           Variable                                 Access(R/W)
           Function                                Execute
      Symbol in the data section         Access(R/W)
      Symbol in the code section        Execute
           Other                                     Access(R/W)

Condition setting area in each 
various event setting dialog box 
(address and data setting areas)

The dropped text is set in the area. 

Watch window If the dropped text is recognizable as a symbol, the contents 
of the symbol are displayed.
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Source Search dialog box

This dialog box is used to search for the character string in the Source window.  

By setting each item and then clicking the <Find Next> button, searching can be started.  

By clicking the <Set Find> button, the direction buttons ("<<" and ">>") in the Source windowcan be used

for the search.  

Figure 6-25　Source Search Dialog Box

This section explains the following items: 

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

When Source window is displayed

• Click the <Search> button.  
 (or press Ctrl and G in that order).

• Select [View] -> [Search...]  
 (or press Alt+V, and S in that order).

Explanation of each area

The Source Search dialog box consists of the following areas:

(1)　Find What (search data specification area)

(2)　Match Case (search condition specification area)

(3)　Direction (search direction specification area)
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(1) Find What (search data specification area)

This area is used to specify the data to be searched.  

In the default condition, the character string selected in the window that called this dialog box is 

displayed.  As necessary, input data from the keyboard to change the character string.  

Up to 256 character string can be specified.  

By displaying the input history, the contents previously input can be reused.  Up to 16 input histories 

can be recorded.  

(2) Match Case (search condition specification area)

This area is used to specify whether uppercase and lowercase characters are distinguished, before 

searching is started.  

(3) Direction (search direction specification area)

This area is used to specify the direction of the search.  

Function buttons

Checked Distinguished (default)

Not checked Not distinguished

Up Forward search.
Searches data forward (upward on screen) from the current position 
of the cursor.  

Down Backward search (default).
Searches data backward (downward on screen) from the current 
position of the cursor.  

Find Next Searches the specified data in accordance with a given condition.  
If the specified character string is found as a result of a search, it is highlighted.  
To continue searching, click this button again.  

Set Find Sets the specified condition as the search condition and closes this dialog box.  

Stop
 (during search)

Stops searching.
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Cancel Closes this dialog box.  
This button is displayed as the <Stop> button while data is being searched.  

Help Opens the Help window.  
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Assemble window

This window is used to disassemble and display programs.  It is also used to execute online assembly.  

To execute online assembly, move the cursor to a mnemonic.  The results of online assembly are also

reflected in the Memory window.  

The Assemble window has two statuses: Active Status and Static Status.

Figure 6-26　Assemble Window

This section explains the following items:  

• Opening

• Explanation of each area

• Functions often used (right-click menu)

• Function buttons

• Related operations

• Cautions

Concerning display  

•  To change the display start position

•  To change the displayed offset and register name

Concerning operation 

•  Start function

•  Come function

•  Program counter setting function

•  Jump function

•  To change the disassembled contents
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•  Watch function (referencing data value)

•  To search in the Assemble window

•  To set event after execution

•  Drag & drop function (line/address)

•  Drag & drop function (character string)

Opening

This window can be opened as follows:  

• Click the Asm button.

• Select [Browse] -> [Assemble] from the menu bar 
 (or press Alt+B, and A in that order).

• Select [Jump] -> [Assemble] from the menu bar
 (or press Alt+J and A in that order, or press Ctrl+D).  

Explanation of each area  

The Assemble window consists of the following areas:

(1)　Point mark area

(2)　Current PC mark area

(3)　Address specification area

(4)　Disassemble display area

(1) Point mark area 

This area is displayed the Breakpoint setting/deletion function and the Event setting status.  

(2) Current PC mark area

The mark '>', which indicates the current PC value (PC register value), is displayed in this area.   

By double-clicking the current PC mark area, the program can be executed up to a specified line.  
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(3) Address specification area 

This area displays the disassembly start address.  When this area is clicked, an address highlighted 

and selected.  

This area has the Drag & drop function (line/address) (refer to p.142) and the Trace Result with Linking 

Window (refer to p.51) function.  

Caution: The end address (0xFFFF) is not displayed.

(4) Disassemble display area 

This area displays the labels and code data of addresses, and disassembled mnemonics.  

The current PC line and breakpoint setting line are displayed in different colors for emphasis (refer to 

"Source text display area (p.136)").  

The disassembled mnemonics displayed in the mnemonic field can be changed (refer to "To change 

the disassembled contents (p.153)").  

If the number of new instruction bytes is less than the number of previous instruction bytes as a result 

of changing, as many 'NOP' instructions as necessary are inserted.  If the number of new instruction 

bytes is more than the number of previous instruction bytes, the next instruction is overwritten.  In this 

case also, as many 'NOP' instructions as necessary are inserted.  The same applies to instructions 

that straddle over source lines.  

In this area, the following functions can be used on the line or address on which the cursor is placed 

(start address of program code):  

-> Start function

-> Come function

-> Program counter setting function

-> Jump Function

A character string selected in this area can be dragged and dropped in another window or dialog box 
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(refer to "Drag & drop function (character string) (p.143)").  

Caution: Up to 319 characters can be displayed on 1 line.

Functions often used (right-click menu)

In this window, functions that are often used can be selected from the menu that is displayed by clicking

the right mouse button.  In this way, the same function can be used more easily than with the normal

procedure.

Move... Moves the display position.
Opens the Address Move dialog box.  

Add Watch Adds the specified data to the Watch window.  
Opens the Add Watch dialog box.  

Symbol Displays the address of the specified variable or function, or the value of the 
specified symbol.  
Opens the Symbol To Address dialog box.  

Come Here Executes the program from the current PC to the cursor position (Come 
function).  

Change PC Sets the address at the cursor position to the PC.  

Break Pont Sets or deletes a breakpoint at the cursor position.  

Source Text Displays the corresponding source text and source line, using the data value 
at the cursor position as the jump destination address.  
If no line information exists at the jump destination address, however, you 
cannot jump.  
Opens the Source window.  
If an active Source window is open, that window is displayed in the forefront 
(so that it can be manipulated).  

Memory Displays the memory contents starting from the jump destination address 
specified by the data value at the cursor position.  
Opens the Memory window.  
If an active Memory window is open, that window is displayed in the forefront 
(so that it can be manipulated).  

Coverage Displays the coverage measurement results starting from the jump 
destination address specified by the data value at the cursor position.  
Opens the Coverage window.  
If an active Coverage window is open, that window is displayed in the 
forefront (so that it can be manipulated).  
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Function buttons  

Related operations

To change the display start position

Change the display start position in the Address Move dialog box, which is opened when right-click 

menu -> [Move...] is selected in the Assemble window.  

To change the displayed offset and register name

Change the display offset or register name under DisAssemble  (offset display setting area) in the 

Debugger Option dialog box that is opened when [Option] -> [Debugger Option...] is selected from the 

menu bar.  A function name or an absolute name can be selected as a register name.  

Start function

For the operation, refer to "Start function (p.140)" in the Source window.  

Search... Opens the Assemble Search dialog box and searches for a character string of 
mnemonics.  
If a character string is selected in the disassemble display area, the Assemble 
Search dialog box is opened to search for the character string.  If no character 
string is selected, the Assemble Search dialog box is opened with nothing 
specified to be searched.  
Specify a search method in the Assemble Search dialog box.  The result of search 
is highlighted in the Assemble window.  
This is the same operation as selecting [View] -> [Search...] from the menu bar.  

<< Searches forward (upward on screen) for the contents that satisfy the search 
condition set in the Assemble Search dialog box, starting from the address at the 
cursor position.  
This button is displayed as the <Stop> button during a search.  

>> Searches backward (downward on screen) for the contents that satisfy the search 
condition set in the Assemble Search dialog box, starting from the address at the 
cursor position.  
This button is displayed as the <Stop> button during a search.  

Stop
 (during search)

Stops searching.

Watch Adds the symbols selected in the disassemble display area to the Watch window.  
If the Watch window is not opened, it is opened.  
If no text is selected in the disassemble display area, the Watch window is only 
opened.  
This is the same operation as selecting [View] -> [View Watch] from the menu bar.  

Quick... Temporarily displays the contents, such as symbols, selected in the disassemble 
display area on the Quick Watch dialog box.  Opens the Quick Watch dialog box.  
If no text is selected in the disassemble display area, the Quick Watch dialog box 
is only opened.  
This is the same operation as selecting [View] -> [Quick Watch...] from the menu 
bar.

Refresh Updates the contents of the window with the latest data.  

Close Closes this window.
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Come function

For the operation, refer to "Come function (p.141)" in the Source window.  

Program counter setting function

For the operation, refer to "Program counter setting function (p.141)" in the Source window.  

Jump function

For the operation, refer to "Jump function (p.141)" in the Source window.  

To change the disassembled contents

To change the disassembled contents, move the cursor to the mnemonic field (the overwrite and 

insertion modes are alternately selected by pressing the Insert key).  

If an attempt is made to move the cursor to another line after the disassembled contents have been 

changed in the mnemonic field, the new contents are checked.  If the new contents are illegal. the code 

data on the line where the contents have been changed is indicated as '*'.  In this case, the new 

contents are not written to memory even if the cursor is moved to another line.  

The contents changed in the mnemonic field are written into the memory by pressing the Enter key.  

When the Enter key is pressed, the new contents are checked and, if they are illegal, the code data on 

the illegal line is indicated by '*'.  If even one line is illegal, the new contents are not written into the 

memory.  

In this case, correct the contents.  To discard the contents, press the ESC key.  If the contents are 

correct and if the Enter key is pressed, the contents are written into the memory, and then the cursor 

moves to the next line in the mnemonic field, so that the data on the next line can be changed.  

Watch function (referencing data value)

For the operation, refer to "Watch function (referencing data value)" in the Source window.  

To search in the Assemble window

Use the Assemble Search dialog box, which can be opened by clicking the <Search...> button in the 

Assemble window.  If the character string to be searched is existed in the window, select that character 

string and click the <Search...> button.  The selected character string is opened in the specified format.  

To set event after execution

For the operation method, refer to "To set event after execution (p.142)" in the Source window.

Drag & drop function (line/address)

For the operation, refer to "Drag & drop function (line/address) (p.142)" in the Source window.  

Drag & drop function (character string)

For the operation, refer to "Drag & drop function (character string) (p.143)" in the Source window.  

Cautions

When moving the display contents forward (upward) by scrolling forward or searching, the contents 

may not be displayed correctly at the boundary between the previously-displayed topmost address and 
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the contents.  In this case, try displaying again from the correct section start address or symbol by 

moving the address.



CHAPTER 6  WINDOW REFERENCE

User’s Manual  U16768EJ1V0UM 155

Assemble Search dialog box

This dialog box is used to search the contents of Assemble window.  

Successive character strings included in an input character string and disassembler character string are

compared as one blank character.  

By setting each item and then clicking the <Find Next> button, searching can be started.  

By clicking the <Set Find> button, the direction buttons ("<<" and ">>") in the Assemble windowcan be

used for the search.  

Figure 6-27　Assemble Search Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

When Assemble windowis the current window

• Click the <Search> button.  
 (or press Ctrl+G).

• Select [View] -> [Search...]  
 (or press Alt+V, and S in that order).

Explanation of each area

The Assemble Search dialog box consists of the following areas:

(1)　Find What (search data specification area)

(2)　Match Case (search condition specification area)

(3)　Scan Whole Region (search condition specification area)

(4)　Direction (search direction specification area)

(5)　Address (search range specification area)
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(1) Find What (search data specification area)

This area is used to specify the data to be searched.  

In the default condition, the character string selected in the window that called this dialog box is 

displayed.  As necessary, input data from the keyboard to change the character string.  

Up to 256 character string can be specified.  

By displaying the input history, the contents previously input can be reused.  Up to 16 input histories 

can be recorded.  

(2) Match Case (search condition specification area)

This area is used to specify whether uppercase and lowercase characters are distinguished, before 

searching is started.  

(3) Scan Whole Region (search condition specification area) 

This area is used to specify whether the specified range is fully searched or not.

(4) Direction (search direction specification area)

This area is used to specify the direction of the search.  

Checked Distinguished (default)

Not checked Not distinguished

Checked Searches the entire range.

Not checked Searches the remaining part of the range (default)

Up Forward search.
Searches data forward (upward on screen) from the current position 
of the cursor.  

Down Backward search (default).
Searches data backward (downward on screen) from the current 
position of the cursor.  
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(5) Address (search range specification area)

This area is used to specify the address to be searched.  

An address can be also specified by a symbol or expression (refer to "Table 6-15  Specifying Symbols 

(p.130)").  The default radix for inputting a numeric value is hexadecimal.  

Function buttons

Find Next Searches the specified data in accordance with a given condition.  
If the specified character string is found as a result of a search, it is highlighted.  
To continue searching, click this button again.  

Set Find Sets the specified condition as the search condition and closes this dialog box.  

Stop 
(during search)

Stops searching.

Cancel Closes this dialog box.  
This button is displayed as the <Stop> button while data is being searched.  

Help Opens the Help window.  
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Memory window

This window is used to display and change the memory contents.

The display start position when the Memory window is opened is as follows:  

Even while the program is being executed, the range set in the Extended Option dialog box can be

displayed in real time.  

The Memory window has two statuses: Active Status and Static Status.  

Figure 6-28　Memory Window

This section explains the following items:  

• Opening

• Explanation of each area

• Functions often used (right-click menu)

• Function buttons

• Related operations

•  To change the memory contents

•  To change the display start position

•  To search in the Memory window

•  To display ASCII characters

•  To initialize the memory contents with a specified code

First time Display starts from the first address of the internal RAM area.

Second and subsequent 
times

Display starts from the address at which an active status window was 
closed 
(if an active status window has never been closed, display starts from 
the first display start position).
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•  To copy the memory contents

•  To compare the memory contents

•  To verify and check a memory write

Opening

This window can be opened as follows:

• Click the Mem button.

• Select [Browse] -> [Memory...] from the menu bar 
 (or press Alt+B, and M in that order).

• Select [Jump] -> [Memory...] from the menu bar 
 (or press Alt+J, and M in that order).

Explanation of each area  

The Memory window consists of the following areas:

(1)　Addr (address display area)

(2)　+0 +1 +2....(memory display area)

(3)　 0 1 2 3.... (ASCII display area)

(1) Addr (address display area)

This area displays memory addresses. 

Address width changes at the time of memory bank use (SM78K0 only).

(2) +0 +1 +2....(memory display area)  

This area is used to display and change the memory contents.  

Data into which the current memory contents are to be changed is displayed in red and is actually 

written to the target when the Enter key is pressed.  The contents (displayed in red) can be canceled 

by the ESC key.  Up to 256 bytes can be specified at one time.
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This area is also used as a jump pointer of the jump function.  In addition, it also has the Trace Result 

with Linking Window function.  

(3) 0 1 2 3.... (ASCII display area)

This area is used to display and change the memory contents in ASCII characters.  

This area is displayed when right-click menu -> [Ascii] is selected.  Display of this area can be turned 

on/off by this menu item.  

Data can be changed in this area in the same manner as in the memory display area.  

This area is also used as a jump pointer of the jump function.  

Caution: Even if the cursor is placed on this area, once the focus is lost, the cursor position

returns to the memory display area. 

Functions often used (right-click menu)

In this window, functions that are often used can be selected from the menu that is displayed by clicking

the right mouse button.  In this way, the same function can be used more easily than with the normal

procedure.  

Move... Moves the display position.
Opens the Address Move dialog box.  

Bin Displays binary numbers.

Oct Displays octal numbers.

Dec Displays decimal numbers.

Hex Displays hexadecimal numbers (default).

Nibble Displays in 4-bit units.

Byte Displays in 8-bit units (default).

Word Displays in 16-bit units.

Double Word Displays in 32-bit units.

Ascii Turns on/off display of ASCII characters.  
Checked: Displayed
Not checked: No display (default)
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Function buttons  

Related operations

To change the memory contents

To change the memory contents, move the cursor to the memory display area or ASCII display area in 

the window, and write data directly from the keyboard.  The amount of memory contents that can be 

changed at one time is 256 bytes or less.  To set the change, press the return key.  To cancel the 

change, press the ESC key.  

To change the display start position

Use the Address Move dialog box, which can be opened by selecting right-click menu -> [Move] in the 

Memory window.  

To search in the Memory window

Use the Memory Search dialog box, which can be opened by clicking the <Search...> button in the 

Memory window.  If the character string to be searched exists in the window, select that character 

string and click the <Search...> button.  The selected character string is opened in the specified format.  

Non-mapped, SFR, and I/O protect areas are not searched.  

To display ASCII characters

The memory contents are displayed in ASCII characters when right-click menu -> [Ascii] is selected in 

the Memory window.  

Search... Opens the Memory Search dialog box and searches for character strings from 
the displayed memory contents, or memory contents.  
Selected data (a memory value) is displayed in the Memory Search dialog box 
as data to be searched.  If the Memory Search dialog box is opened without 
data specified, specify data from the keyboard.  
The result of the search is highlighted in the Memory window.  

<< Searches the memory contents satisfying the search condition set in the 
Memory Search dialog box, forward (upward on screen) from the address at the 
cursor position.  
This button is displayed as the <Stop> button during a search.  

>> Searches the memory contents satisfying the search condition set in the 
Memory Search dialog box, backward (downward on screen) from the address 
at the cursor position.  
This button is displayed as the <Stop> button during a search.  

Stop 
(during search)

Stops searching.

Refresh Updates the contents of the window with the latest data.  

Modify... Opens the Pseudo DMM dialog box.  
This button is invalid at a break.  

Close Closes this window.
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To turn off display of ASCII characters, select [Ascii] again to remove the check mark.  

To initialize the memory contents with a specified code

Initialize the memory contents with a specified code in the Memory Fill dialog box, which can be 

opened by selecting [Edit] -> [Memory] -> [Initialize] from the menu bar.  

If verify check is enabled in the Extended Option dialog box, verify check is executed after initialization.  

To copy the memory contents

Copy the memory contents in the Memory Copy dialog box, which can be opened by selecting [Edit] -> 

[Memory] -> [Copy] from the menu bar.  

If verify check is enabled in the Extended Option dialog box, verify check is executed after copy.  

To compare the memory contents

Compare the memory contents in the Memory Compare dialog box, which can be opened by selecting 

[Edit] -> [Memory] -> [Compare] from the menu bar.  

If a difference is found as a result of comparison, the Memory Compare Result dialog box is opened 

and the details are displayed in this dialog box.  

To verify and check a memory write

Use the Extended Option dialog box, which is opened by selecting [Option] -> [Extended Option] from 

the menu bar.  To execute a verify check, check the [Verify] check box.  
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Memory Search dialog box

This dialog box is used to search the memory contents of the part of Memory window at which the cursor

is located.  

If the cursor is in the memory display area, the memory display area is searched for specified data, which

is assumed to be a binary data string.  If the cursor is in the ASCII display area, the ASCII display area is

searched for specified data, which is assumed to be an ASCII character string.  

By setting each item and then clicking the <Find Next> button, searching can be started.  

By clicking the <Set Find> button, the direction buttons ("<<" and ">>") in the Memory window can be

used for the search.  

Non-mapped, SFR, and I/O protect areas are not searched.  

Figure 6-29　Memory Search Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

When Memory windowis the current window

• Click the <Search> button.  
 (or press Ctrl+G).

• Select [View] -> [Search...]  
 (or press Alt+V, and S in that order).

Explanation of each area

The Memory Search dialog box consists of the following areas:
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(1)　Find What (search data specification area)

(2)　Unit (search condition specification area)

(3)　Scan Whole Region (search condition specification area)

(4)　Direction (search direction specification area)

(5)　Address (search range specification area)

(1) Find What (search data specification area)

This area is used to specify the data to be searched.  

In the default condition, the character string selected in the window that called this dialog box is 

displayed.  As necessary, input data from the keyboard to change the character string.  

When searching the memory display area, up to 16 data items can be specified.  Delimit each data 

with a "blank character".  When searching the ASCII display area, data of up to 256 characters can be 

specified.  A "blank character" in the data is treated as a blank character.  

By displaying the input history, the contents previously input can be reused.  Up to 16 input histories 

can be recorded.  

(2) Unit (search condition specification area)

This area is used to specify the number of bits of the data to be searched in the memory display area.  

(3) Scan Whole Region (search condition specification area) 

This area is used to specify whether the specified range is fully searched or not.

(4) Direction (search direction specification area)

This area is used to specify the direction of the search.  

Byte Searches the data as 8-bit data (default).

Word Searches the data as 16-bit data.

Double Word Searches the data as 32-bit data.

Checked Searches the entire range.

Not checked Searches the remaining part of the range (default)
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(5) Address (search range specification area)

This area is used to specify the address to be searched.  

An address can be also specified by a symbol or expression (refer to "Table 6-15  Specifying Symbols 

(p.130)").  The default radix for inputting a numeric value is hexadecimal.  

Function buttons

Up Forward search.
Searches data forward (upward on screen) from the current position 
of the cursor.  

Down Backward search (default).
Searches data backward (downward on screen) from the current 
position of the cursor.  

Find Next Searches the specified data in accordance with a given condition.  
If the specified character string is found as a result of a search, it is highlighted.  
To continue searching, click this button again.  

Set Find Sets the specified condition as the search condition and closes this dialog box.  

Stop
 (during search)

Stops searching.

Cancel Closes this dialog box.  
This button is displayed as the <Stop> button while data is being searched.  

Help Opens the Help window.
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Memory Fill dialog box

This dialog box is used to initialize the memory contents in the Memory window with specified codes.  

Figure 6-30　Memory Fill Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

• Select [Edit] -> [Memory] -> [Fill] from the menu bar.
 (or press Alt+E, M and F in that order).

Explanation of each area

The Memory Fill dialog box consists of the following areas:

(1)　Address (address range specification area)

(2)　 fill code (data specification area)

(1) Address (address range specification area)

This area is used to specify the memory address range whose contents are to be initialized.  

An address can be also specified by a symbol or expression (refer to "Table 6-15  Specifying Symbols 

(p.130)").  The default radix for inputting a numeric value is hexadecimal.  

Input the first address to be initialized and then the last address to be initialized.  
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(2) fill code (data specification area)

This area is used to specify the data with which the memory contents are to be initialized.  

Up to 16 binary data strings (byte data strings) can be specified.  

Delimit each data with a "blank character".  

Function buttons

OK Initializes the memory.  

Stop 
(during initialization)  

Stops initialization.  
While initialization is in progress, the <Cancel> button is replaced by the 
<Stop> button.

Cancel Closes this dialog box.  
While memory contents are being initialized, this button is replaced by the 
<Stop> button.

Restore Restores the input data to the original status.  

Help Opens the Help window.  
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Memory Copy dialog box

This dialog box is used to copy the memory contents in the Memory window.  

Figure 6-31　Memory Copy Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

• Select [Edit] -> [Memory] -> [Copy] from the menu bar.
 (or press Alt+E, M and C in that order).

Explanation of each area

The Memory Copy dialog box consists of the following area:

(1)　Address (address range specification area)

(1) Address (address range specification area)

This area is used to specify the copy source and copy destination addresses.  

An address can be also specified by a symbol or expression (refer to "Table 6-15  Specifying Symbols 

(p.130)").  The default radix for inputting a numeric value is hexadecimal.  
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Function buttons

From Specify the address range of the copy source.  
Input the first address of the copy source and then the end address.

To Specify the first address of the copy destination.

OK Copies the memory.

Stop
(during copying)

Stops copying.
While copying is in progress, the <Cancel> button is replaced by the <Stop> 
button.

Cancel Closes this dialog box.  
While copying is in progress, this button is replaced by the <Stop> button.

Restore Restores the input data to the original status.  

Help Opens the Help window.  
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Memory Compare dialog box

This dialog box is used to compare the memory contents in the Memory window.  

Figure 6-32　Memory Compare Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

• Select [Edit] -> [Memory] -> [Compare] from the menu bar.
 (or press Alt+E, M and P in that order).

Explanation of each area

The Memory Compare dialog box consists of the following area:

(1)　Address (comparison range specification area)

(1) Address (comparison range specification area)

This area is used to specify the comparison source address and comparison destination address.  

An address can be also specified by a symbol or expression (refer to "Table 6-15  Specifying Symbols 

(p.130)").  The default radix for inputting a numeric value is hexadecimal.  
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Function buttons

Mem1 Specify the address range of the comparison source.
Input the first address of the comparison source and then the end address.  

Mem2 Specify the first address of the comparison destination.

OK Compares the memory.  
If no difference is found as a result of comparison, a confirmation dialog box is 
displayed.  If a difference is found, Memory Compare Result dialog box is 
opened.  

Figure 6-33　Confirmation Dialog Box

Clicking the <OK> button ends memory comparison.

Stop
(during comparison)

Stops memory comparison.  
While comparison is in progress, the <Cancel> button is replaced by the 
<Stop> button.

Cancel Closes this dialog box.  
While comparison is in progress, this button is replaced by the <Stop> button.

Restore Restores the input data to the original status.  

Help Opens the Help window.  
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Memory Compare Result dialog box

Displays the result of comparing the memory.  

This dialog box is displayed if any difference is found in the memory contents when the memory has been

compared in Memory Compare dialog box.  

Figure 6-34　Memory Compare Result Dialog Box

This section explains the following items:

• Explanation of each area

• Function buttons

Explanation of each area

The Memory Compare Result dialog box consists of the following area:

(1)　Mem1, Mem2 (comparison result display area)

(1) Mem1, Mem2 (comparison result display area)

This area displays the results of comparing the memory.  Only differences that have been found as a 

result of comparison are displayed.  
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Address width changes at the time of memory bank use (SM78K0 only).

Function buttons

Mem1 Addr Displays a comparison source address in which a difference has been found.  

Memory Displays the data in which a difference has been found.  
Left: Comparison source data
Right: Comparison destination data

Mem2 Addr Displays the comparison destination address at which a difference has been 
found.  

Close Closes this dialog box.  

Help Opens the Help window.  
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Pseudo DMM dialog box

This dialog box is used to set addresses and data for DMM (Dynamic Memory Modification).  

DMM is used to rewrite the memory contents in real time while the user program is being executed.  

Because this function is implemented by software emulation, however, the user program under execution

is temporarily stopped and then executed again.  

Caution: The following points must be noted when using the DMM function.

- If the program is stopped immediately before rewriting the memory because a break

event is generated, the generated break event is invalid because program execution is

resumed, regardless of the break event.

- Verify check is always invalid.  

Figure 6-35　Pseudo DMM Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

• Select [Edit] -> [Memory] -> [Modify] from the menu bar.
 (or press Alt+E, M and M in that order).

• Click the <Modify> button in the Memory window.

Explanation of each area

The Pseudo DMM dialog box consists of the following areas:

(1)　Address (address setting area)

(2)　Data (data setting area)
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(3)　Data Size (data size setting area)

(1) Address (address setting area)

This area is used to specify the address to which data is to be written.  

An address can be also specified by a symbol or expression (refer to "Table 6-15  Specifying 

Symbols").  The default radix for inputting a numeric value is hexadecimal.  

(2) Data (data setting area)

This area is used to specify the data to be written to the memory address specified in Address.  

One binary data string can be specified at one time.  Specify the data size in Data Size.  Specify the 

data size in Data Size.  The default radix for inputting a numeric value is hexadecimal.  

(3) Data Size (data size setting area)

This area is used to specify the size of the data to be written.  

Function buttons

Byte Writes data specified in Data as 8-bit data.  

Word Writes data specified in Data as 16-bit data.  

Double Word Writes data specified in Data as 32-bit data.  

OK Writes the data.

Cancel Closes this dialog box.  

Restore Restores the input data to the original status.  

Help Opens the Help window.  
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Watch window

This window is used to display and change specified data.  

The result of updating and rewriting data in this window will be reflected in the Memory window.  

This window can also display wide-ranging data (such as global variables and public symbols) in real time

even during program execution, in the same way as the Memory window.  

To set a breakpoint for read/write access to a variable can be performed by a single action from the menu

that is displayed by clicking the right mouse button.  

Caution: If a local variable and a global variable exist with the same name, the local variable

takes priority. 

Figure 6-36　Watch Window

This section explains the following items:  

• Opening

• Explanation of each area

• Functions often used (right-click menu)

• Function buttons

• Related operations

•  To add/delete displayed data (variable)

•  To change data on the selected line

•  To temporarily display a data (variable) value

•  To display/change a local variable value

•  To set a breakpoint for read/write access to a variable

•  To change displayed radix/size
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Opening

This window can be opened as follows:

• Click the Wch button.
Select [Browse] -> [Watch] from the menu bar, 
(or press Alt+B, and W in that order).  

Select data in the Source window or Assemble window, 

• Select [View] -> [View Watch] from the menu bar,
 (or press Alt+ V, and I in that order),  
or click the <Watch> button.  

In the Quick Watch dialog box or Add Watch dialog box dialog box,

• Click the <Add> button.

Explanation of each area  

The Watch window consists of the following areas:

(1)　 Left field (symbol name display area)

(2)　Right field (data value display/setting area)

(1) Left field (symbol name display area) 

This area is used to display variable names, symbol names and types, and tag names of structures or 

unions.

Refer to "Name (symbol specification area)" in the Add Watch dialog box for details on the displayed 

contents.  

'+' is prefixed to the displayed arrays, pointer variables, and structures or unions.  These variables are 

expanded and displayed as follows when they are double-clicked:

Array All the elements of the variable are displayed in accordance with the type 
of the array variable.
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'+' of the variable that has been expanded and displayed changes to '-'.  If the variable is double-

clicked in this status, the expanded display is canceled.  Expanded display can be also specified or 

canceled by selecting a variable with the arrow keys and then pressing the Enter key.  

If an access breakpoint is set for a variable or a symbol in the Watch window, the symbol name display 

area is highlighted in gold.  

Caution: Up to 319 characters can be displayed on 1 line.

Reference: If an array has too many variables and takes too long to expand, a warning message is

displayed.  

(2) Right field (data value display/setting area)

This area is used to display and change data values.  

A value is updated when execution is stopped.  To save a value, select [File ] -> [Save As...] from the 

menu bar when the Save window is the current window.  This area is blank if getting data has failed.  

'?' is displayed for data that has been invalidated because of a change in the scope or optimized 

compiling.  The contents of the change are written into the target when the Enter key is pressed.  The 

previous value can be canceled by the ESC key.  

The display format is as follows:  

Pointer variable The data indicated by the pointer is displayed.

Structure/union All the members of the structure/union are displayed in accordance with 
the type of the member variable. 
If a structure or union is defined in the structure or union, the structure 
name or union name of the internal structure or union is also displayed.
The internal structure or union can be also expanded by using '+'.
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The size and radix of a data value can be specified on the [View] menu for each variable.  

However, the display size cannot be selected if the display size is fixed, such as for variables in C or 

registers of the assembler.  

If [View] -> [Adaptive] or [View] -> [Proper] from the menu bar is selected, the size and radix specified 

in the Debugger Option dialog box are used for display (refer to "To change displayed radix/size").  

Functions often used (right-click menu)

In this window, functions that are often used can be selected from the menu that is displayed by clicking

the right mouse button.  In this way, the same function can be used more easily than with the normal

procedure.  

Table 6-21　Data Display Format (Watch-Related) 

Display Data Contents

Integer Displayed in the same manner as the language specified in the 
Debugger Option dialog box.  
C-like (value: xxxx)
Hexadecimal (0xxxxx)
Decimal (xxxx)
Octal (0xxxx)
Binary (0bxxxx)
Assembly language-like  (value: xxxx)
Hexadecimal (xxxxH) 
Decimal (xxxxT)
Octal (xxxxQ)
Binary (0bxxxxY)

Enumeration type Member name

If scope is specified Displayed in accordance with specified scope

Floating-point type Single precision/double precision supported
The input/display format is as follows:  
[ + | - ] inf
[ + | - ] nan
[ + | - ] integer e [ + | - ]exponent
[ + | - ] integer.fraction [e [ + | - ]exponent

Break when Access
to this VariableNote

Creates a break event that occurs if the selected variable is accessed for 
read/write.  

Break when Write to
this VariableNote

Creates a break event that occurs if the selected variable is accessed for 
write.

Break when Read
from this VariableNote

Creates a break event that occurs if the selected variable is accessed for 
read.

Clear Deletes the break event corresponding to the selected variable.   

Event? Displays the event information of the line at the cursor position or the 
selected variable.  
If an event is set, Event dialog box is opened.  
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Note: No breakpoint can be set for structure and union members, array members, bit field members, 
etc. In such a case, get the address in the Symbol To Address dialog box and then set a 
breakpoint for that address. 

Function buttons  

Change Watch... Changes the selected data.

Delete Watch Deletes the selected watch point from the window.  

Bin Displays the selected line in binary numbers.

Oct Displays the selected line in octal numbers.

Dec Displays the selected line in decimal numbers.

Hex Displays the selected line in hexadecimal numbers.

String Displays the selected line as a character string.

Proper Displays the selected line as the default value of each variable.
Symbols are displayed in accordance with the setting of Debugger Option 
dialog box (default).

Byte Displays the selected line in 8-bit units.

Word Displays the selected line in 16-bit units.

General Displays the selected line in 24-bit units (SM78K4 only).

Double Word Displays the selected line in 32-bit units.

Adaptive Displays the selected line as the default value of each variable.
Only this item is valid for a symbol in C language.
Symbols in assembly language are displayed in accordance with the setting 
of Debugger Option dialog box (default).  

Up Moves the selected line one line up.

Down Moves the selected line one line down.

Add... Opens the Add Watch dialog box.  
If data is specified and the <Add...> button is clicked in the Add Watch dialog 
box, the specified data is added to the Watch window.  

Delete Deletes the specified data from the Watch window.
The DEL key performs the same operation.

Up Moves the selected data one line up.

Down Moves the selected data one line down.

Refresh Updates the contents of the window with the latest data.  

Close Closes this window.
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Related operations

To add/delete displayed data (variable)

Addition method (any of the following)

•  Select a variable name or symbol name and click the <Watch> button in the Source window or
Assemble window.

•  Select a variable name or symbol name in the Source window or Assemble window, and drag it to
the Watch window.

•  Specify a variable name or symbol name and click the <Add> button in the Quick Watch dialog box
or Add Watch dialog box.

Deletion method

•  Click a variable name or symbol name (two or more variable or symbol names can be selected
using the Shift or Ctrl key), and click the <Delete> button.  A line with an expanded hierarchy, such
as the elements of an array, and members of structures and unions cannot be changed.  

To change data on the selected line

To change data (variables), select a line to be changed in the Watch window and select right-click 

menu -> [Change Watch...].  The Change Watch dialog box will be opened to change the data.  

A line with an expanded hierarchy, such as the elements of an array, and members of structures and 

unions cannot be deleted.  

To temporarily display a data (variable) value

A data (variable) value can be temporarily displayed in the following two ways:

To display using the balloon watch function

Select data (a variable name) in the Source window or Assemble window.  Then place the mouse 

cursor on the selected character string.  The value of the selected data will be displayed.  

To display in the Quick Watch dialog box

Select data (a variable name) in the Source window or Assemble window.  Then click the <Quick...> 

button.  The value of the selected data will be displayed in the Quick Watch dialog box.

To display/change a local variable value

A local variable value can be checked or changed in the Local Variable window, which is opened when 

the Loc button is clicked.  

In this window, the local variable in the current function is automatically displayed and the displayed 

variable cannot be added or deleted.  

To change a local variable value, move the cursor to the local variable value display/changing area on 

the window and write a value in this area directly from the keyboard.  

To determine the displayed contents, use the Enter key.  To cancel, use the ESC key.

To set a breakpoint for read/write access to a variable 

Select a variable in the Watch window and select [Break when Access to this Variable], [Break when 

Write to this Variable] or [Break when Read from this Variable] from the right-click menu.  In this way, a 

hardware break event will be created in the valid status in accordance with the selected item.  

Whether the event has been correctly created can be confirmed on the Event Manager.  
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To change displayed radix/size

Changing each data (variable) at any time

Select a data (variable) name to be changed in the Watch window or Quick Watch dialog box, and 

select the radix and size from the right-click menu.  

Specifying default condition

Adaptive (when display size is specified) or Proper (when display radix is specified) for watching a 

symbol that specifies a default value can be set as the default assumption.  

This is done in the Watch Default area of the Debugger Option dialog box, which is opened when 

[Option] -> [Debugger Option...] is selected from the menu bar.  

The size specified under Size is displayed when Adaptive is specified, and the radix specified under 

Radix is displayed when Proper is specified.  
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Quick Watch dialog box

This dialog box is used to temporarily display or change specified data.  

Figure 6-37　Quick Watch Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:  

• Select [View] -> [Quick Watch...]  
 (or press Alt+V, and Q in that order).  

• Click the <Quick> button in Source window.
 (or press Ctrl+W).

• Click the <Quick> button in Assemble window.
 (or press Ctrl+W).

Explanation of each area  

The Quick Watch dialog box consists of the following areas:

(1)　Name (symbol specification area)

(2)　Symbol name display area

(3)　Data value display/setting area

(4)　Display radix selection area (upper left field)
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(5)　Display size selection area (second upper left field)

(6)　Number (display number specification area)

(1) Name (symbol specification area) 

This area is used to specify the data to be displayed.

In the default condition, the character string selected in the window that called this dialog box is 

displayed.  As necessary, input data from the keyboard to change the character string.  This area is 

blank if no character string is selected.  

By displaying the input history, the contents previously input can be reused.  Up to 16 input histories 

can be recorded.  

If the contents of Name have been changed, the data specified in Name can be displayed in the field 

below by clicking the <View> button.  

(2) Symbol name display area

This area is used to display the variable name and the symbol name.  

The displayed contents are the same as those of Name (symbol specification area) in the Add Watch 

dialog box.  

Caution: Up to 319 characters can be displayed on 1 line.

(3) Data value display/setting area  

This area is used to display and change data values.  The displayed contents and display method are 

the same as those of Watch window.  

The displayed contents are the same as those of Right field (data value display/setting area) in the 

Watch window.  
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(4) Display radix selection area (upper left field)  

This area is used to select the display radix.

The display radix of the data name selected in the symbol name display area will be changed.  

(5) Display size selection area (second upper left field)

This area is used to select the display size.  

The display size of the data selected in the symbol name display area will be changed.   

If the display size is fixed, such as when a variable in C or register is to be displayed, it cannot be 

changed.  

(6) Number (display number specification area)

This area is used to specify the number of data to be displayed.  

Specify blank or a number of 1 to 256.  

If this area is blank, data is displayed as a simple variable.  

If a number of 1 or more is specified, data is displayed as an array variable.  

If an array variable is displayed, '+' is prefixed to the data.  By double-clicking this '+', all the elements 

of the data are expanded and displayed in accordance with the type of the data ('-' is prefixed to the 

Proper Variable
The default value of each variable is displayed.  
Symbol
Displays data with the radix set in Debugger Option dialog box.  

Hex Displays data in hexadecimal numbers (0xxxxx)  

Dec Displays data in decimal numbers (xxxx)

Oct Displays data in octal numbers (0xxxx)

Bin Displays data in binary numbers (0bxxxx)

String Displays character strings.

Adaptive Variable
The default value of each variable is displayed.  
Symbol
Displays data with the size set in Debugger Option dialog box.  

Byte Displays data in 8 bits.

Word Displays data in 16 bits.

General Displays data in 24 bits (SM78K4 only).

Double Word Displays data in 32 bits.
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expanded data.  If this '-' is double-clicked, the expanded display is canceled).  

If the number of data to be displayed is fixed, such as when a variable in C or register is to be 

displayed, the specified number of data is invalid.  

Function buttons

View Displays the data specified in Name in the field below.  

Add Displays the data specified in Name to the Watch window.  

Close Closes this dialog box.  
Data that has not actually been written to the target will be canceled.  
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Add Watch dialog box

This dialog box is used to register data to be displayed in the Watch window.  

Multiple data with the same symbol name can be registered. 

Figure 6-38　Add Watch Dialog Box
[SM78K0, SM78K0S]

[SM78K4]

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:  

• Select [View] -> [Add Watch...] from the menu bar   
 (or press Alt+V, and W in that order).  

• Click the <Add> button in Watch window.  
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Explanation of each area  

The Add Watch dialog box consists of the following areas:  

(1)　Name (symbol specification area)

(2)　Radix (display radix selection area)

(3)　Size (display size specification area)

(4)　Number (display number specification area)

(1) Name (symbol specification area)  

This area is used to specify data to be added to the Watch window.  

In the default condition, the character string selected in the window that called this dialog box is 

displayed.  As necessary, input data from the keyboard to change the character string.  This area is 

blank if no character string is selected.  

By displaying the input history, the contents previously input can be reused.  Up to 16 input histories 

can be recorded.  

The format in which a variable can be input and how a variable is handled when a scope is specified 

are as follows:  

•  Variable Name in C language

Variable expression : Variable Name

|Variable expression[Constant value | Variable Name]      Elements of array

|Variable expression . Member name         Entity members of structure/union  

|Variable expression -> Member name       Members of structure/union indicated by pointer 

|*Variable expression                                  Value of pointer variable  

|&Variable expression                                 Address where variable is located 

•  Register name

•  SFR name, SFR bit name

•  Label and address of immediate value

•  Register name . bit

•  Label name . bit , address of immediate value . bit

•  Specification of scope

Scope Specification Program name File name Function name Variable 
Name

prog$file#func#var prog file func var

prog$file#var prog file Global var

prog$func#var prog Global func var

prog$var prog Global Global var
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(2) Radix (display radix selection area)

This area is used to change the radix of the data to be displayed.  

(3) Size (display size specification area)

[SM78K0, SM78K0S]

[SM78K4]

This area is used to change the size of data to be displayed.  

If the display size is fixed, such as when a variable in C or register of the assembler is to be displayed, 

it cannot be changed.  

file#func#var Current file func var

file#var Current file Global var

func#var Current Current func var

var Current Current Current var

Proper Variable
The default value of each variable is displayed.
Symbol
Displays data with the radix set in Debugger Option dialog box.

Hex Displays data in hexadecimal numbers (0xxxxx)

Dec Displays data in decimal numbers (xxxx)

Oct Displays data in octal numbers (0xxxx)

Bin Displays data in binary numbers (0bxxxx)

String Displays character strings.

Adaptive Variable
The default value of each variable is displayed.
Symbol
Displays data with the size set in Debugger Option dialog box.

Byte Displays data in 8 bits.

Word Displays data in 16 bits.

General Displays data in 24 bits (SM78K4 only).

Scope Specification Program name File name Function name Variable 
Name
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(4) Number (display number specification area)

This area is used to specify the number of data to be displayed.  

Specify blank or a number of 1 to 256.  

If this area is blank, data is displayed in Watch window as a simple variable.  

If a number of 1 or more is specified, data is displayed in the Watch window as an array variable.  

The maximum number of lines that can be displayed in the Watch window is 10,000.

If an array variable is displayed, '+' is prefixed to the data.  By double-clicking this '+', all the elements 

of the data are expanded and displayed in accordance with the type of the data ('-' is prefixed to the 

expanded data.  If this '-' is double-clicked, the expanded display is canceled).  

If the number of data to be displayed is fixed, such as when a variable in C or register is to be 

displayed, the number of data is invalid in the Watch window even if it has been changed.  

Function buttons

Double Word Displays data in 32 bits.

Add Adds the specified data to the Watch window.  
The dialog box remains open.

OK Adds the specified data to the Watch window.  
Closes this dialog box.  

Cancel Closes this dialog box.  

Restore Restores the input data to the original status.  

Help Opens the Help window.  
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Change Watch dialog box

This window is used to change the data on a line selected in the Watch window.  

A line with an open hierarchy, such as the elements of an array, and members of structures and unions

cannot be changed.  

When watch data is changed, the contents of the selected line are replaced with the new data.  

The symbol name can be changed even if it results in duplication of a name already in use with existing

data.

Figure 6-39　Change Watch Dialog Box
[SM78K0, SM78K0S]

[SM78K4]

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

When the Watch window is open or a line is selected  
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• Select [View] -> [Change Watch...] from the menu bar   
 (or press Alt+V, and G in that order).

Explanation of each area  

The Change Watch dialog box consists of the following areas:

(1)　Name (symbol specification area)

(2)　Radix (display radix selection area)

(3)　Size (display size specification area)

(4)　Number (display number specification area)

(1) Name (symbol specification area)  

This area is used to change a symbol name.

By displaying the input history, the contents previously input can be reused.  Up to 16 input histories 

can be recorded.  

The format in which a symbol name can be input is the same as that of Name (symbol specification 

area) in the Add Watch dialog box.  

(2) Radix (display radix selection area)

This area is used to change the radix of data to be displayed.  

(3) Size (display size specification area)

[SM78K0, SM78K0S]

Proper Variable
The default value of each variable is displayed.  
Symbol
Displays data with the radix set in Debugger Option dialog box.  

Hex Displays data in hexadecimal numbers (0xxxxx)  

Dec Displays data in decimal numbers (xxxx)

Oct Displays data in octal numbers (0xxxx)

Bin Displays data in binary numbers (0bxxxx)

String Displays character strings.
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[SM78K4]

Displays and modifies variables.  

If the display size is fixed, such as when a variable in C or register is to be displayed, it cannot be 

changed.  

(4) Number (display number specification area)

This area is used to specify the number of data to be displayed.  

Specify blank or a number of 1 to 256.  

If this area is blank, data is displayed in Watch window as a simple variable.  

If a number of 1 or more is specified, data is displayed in the Watch window as an array variable.  

The maximum number of lines that can be displayed in the Watch window is 10,000.

If an array variable is displayed, '+' is prefixed to the data.  By double-clicking this '+', all the elements 

of the data are expanded and displayed in accordance with the type of the data ('-' is prefixed to the 

expanded data.  If this '-' is double-clicked, the expanded display is canceled).  

f the number of data to be displayed is fixed, such as when a variable in C or register is to be 

displayed, the number of data is invalid in the Watch window even if it has been changed.  

Function buttons

Adaptive Variable
The default value of each variable is displayed.  
Symbol
Displays data with the size set in Debugger Option dialog box.

Byte Displays data in 8 bits.

Word Displays data in 16 bits.

General Displays data in 24 bits (SM78K4 only).

Double Word Displays data in 32 bits.

Add Cannot be selected.

OK Replaces the registration contents currently selected with the specified data, 
and then closes this dialog box.  
Closes this dialog box.  

Cancel Closes this dialog box.  

Restore Restores the input data to the original status.  

Help Opens the Help window.  
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Local Variable window

This window is used to display and change the local variable in the current function.  

This window automatically displays the local variable in the current function.  It is linked with the jump

function of the Stack Trace window, and displays the local variable in the function jumped when jumping to

the Source window.  Variables cannot be added or deleted.  

Figure 6-40　 Local Variable Window,

This section explains the following items:  

• Opening

• Explanation of each area

• Functions often used (right-click menu)

• Function buttons

Opening

This window can be opened as follows:

• Click the Loc button.

• Select [Browse] -> [Local Variable] from the menu bar,  
 (or press Alt,+B, and L in that order).  

Explanation of each area  

The Local Variable window consists of the following areas:

(1)　 Left field (local variable name display area)

(2)　Right field (local variable value display/setting area)
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(1) Left field (local variable name display area) 

This area displays local variable name.  

Auto, internal Static, and Register variables can be displayed.  

The display format is the same as that of the Watch window.

This area cannot be edited directly.  

Caution: Up to 319 characters can be displayed on 1 line.

(2) Right field (local variable value display/setting area)

This area displays local variable values.  

The display format of the variable value is the same as that of the Watch window.

The display radix of variables can be switched by the menu selection in accordance with each variable.  

The new value is written into the target when the Enter key is pressed.  The previous value can be 

canceled by the ESC key.  

Functions often used (right-click menu)

In this window, functions that are often used can be selected from the menu that is displayed by clicking

the right mouse button.  In this way, the same function can be used more easily than with the normal

procedure.  

Add Watch Registers a selected character string to the Watch window.
Opens the Add Watch dialog box.  
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Function buttons  

Bin Displays the selected line in binary numbers.

Oct Displays the selected line in octal numbers.

Dec Displays the selected line in decimal numbers.

Hex Displays the selected line in hexadecimal numbers.

String Displays the selected line as a character string.

Proper Displays the selected line as the default value of each variable.
Symbols are displayed in accordance with the setting of Debugger 
Option dialog box (default).

Refresh Updates the contents of the window with the latest data.  

Close Closes this window.
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Stack Trace window

This window is used to display or change the current stack contents of the user program.  

From this window, you can also jump to the Source window, Assemble window,  Memory window, and

Coverage window corresponding to the stack contents. 

Caution: The stack trace display function may not operate correctly if there is a frame pointer in

a stack (function that does not push HL (SM78K0, SM78K0S), WHL (SM78K4) (noauto,

norec function, etc.)), or if the -qf option has been set as an optimization option during

compiling.  In addition, [ERROR] may be displayed during prologue or epilogue

processing of a function.

Figure 6-41　Stack Trace Window

This section explains the following items:  

• Opening

• Explanation of each area

• Functions often used (right-click menu)

• Function buttons

Opening

This window can be opened as follows:

• Click the Stk button.

• Select [Browse] -> [Stack Trace] from the menu bar, 
 (or press Alt+B , and K in that order).
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Explanation of each area  

The Stack Trace window consists of the following areas:

(1)　 Left field (stack frame number display area)

(2)　Center field (stack frame contents display area)

(3)　Right field (stack contents display/setting area)

(1) Left field (stack frame number display area)

This area assigns numbers to and displays the stack contents.  

A stack frame number is a natural number starting from 1.  The shallower the nesting of the stack, the 

higher the number.  This means that a function having stack number one higher than that of a certain 

function is the function that calls the certain function. 

(2) Center field (stack frame contents display area) 

This area displays the stack frame contents.

It displays function names or local variable names.  Note, however, that this area cannot be directly 

edited.  

If the stack contents consist of a function, they are displayed as follows: 

 program name$file name#function name (argument list) #line number

If this line is double-clicked, the operation will be the same as jumping to the Source window of the 

jump function (i.e., the local variable in the function to which execution has jumped will be displayed in 

the Local Variable window).  

If the function has a local variable, the local variable will be displayed on the next and subsequent 

lines.  

If the stack contents consist of a local variable, its type and name are displayed.  These are displayed 

in the same manner as in the Watch window.  Note that the internal Static and Register variables are 
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not displayed.  

Caution: Up to 319 characters can be displayed on 1 line.

(3) Right field (stack contents display/setting area)

This area is used to display or change the stack contents.  

'-' or a local variable value is displayed.  If the stack contents are a function '-' is displayed and the 

function cannot be changed.  

If the stack contents are a local variable, the variable value is displayed in the same manner as in the 

Watch window.  

The display radix of variables can be switched by the menu selection in accordance with each variable.  

A variable value can be changed.  The new value is written into the target when the Enter key is 

pressed.  The previous value can be canceled by the ESC key.  

This area is used as the jump source area of the jump function.

Functions often used (right-click menu)

In this window, functions that are often used can be selected from the menu that is displayed by clicking

the right mouse button.  In this way, the same function can be used more easily than with the normal

procedure.  

Bin Displays the selected line in binary numbers.

Oct Displays the selected line in octal numbers.

Dec Displays the selected line in decimal numbers.

Hex Displays the selected line in hexadecimal numbers.

String Displays the selected line as a character string.

Proper Displays the selected line as the default value of each variable.
Symbols are displayed in accordance with the setting of Debugger Option dialog 
box (default).
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Function buttons  

Source Text Displays the corresponding source text and source line from the jump 
destination address specified by the data value at the cursor position (the local 
variable in the function to which you have jumped is displayed in the Local 
Variable window).  
If no line information exists at the jump destination address, however, you 
cannot jump.  
Opens the Source window.  
If an active Source window is open, that window is displayed in the forefront (so 
that it can be manipulated).  

Assemble Disassembles and displays starting from the jump destination address specified 
by the data value at the cursor position.  
Opens the Assemble window.  
If an active Assemble window is open, that window is displayed in the forefront 
(so that it can be manipulated).  

Memory Displays the memory contents starting from the jump destination address 
specified by the data value at the cursor position.  
Opens the Memory window.  
If an active Memory window is open, that window is displayed in the forefront (so 
that it can be manipulated).  

Coverage Displays the coverage measurement results starting from the jump destination 
address specified by the data value at the cursor position.  
Opens the Coverage window.  
If an active Coverage window is open, that window is displayed in the forefront 
(so that it can be manipulated).  

Refresh Updates the contents of the window with the latest data.  

Shrink<<< Collapses the local variable list of the selected function.  

Expand>>> Displays the local variable list of the selected function. 

Close Closes this window.
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Register window

This window is used to display and change the contents of registers (general-purpose registers and

control registers).  

Figure 6-42　Register Window
[SM78K0, SM78K4]

[SM78K0S]

This section explains the following items:  

• Opening

• Explanation of each area

• Functions often used (right-click menu)

• Function buttons

• Related operations

•  To change a register value
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Opening

This window can be opened as follows:

• Click the Reg button.

• Select [Browse] -> [Register] from the menu bar, 
 (or press Alt+B, and R in that order).

Explanation of each area  

The Register window consists of the following areas:

(1)　Register bank setting area (SM78K0, SM78K4 only)

(2)　Upper left field (general-purpose register display area)

(3)　 Lower left field (control register display area)

(1) Register bank setting area (SM78K0, SM78K4 only)

This area is used to display or change the bank number of the general-purpose registers.  

(2) Upper left field (general-purpose register display area)

This area is used to display or change the register of the bank number displayed in the Register Bank 

field in the register bank setting area.   

The new value is written into the target when the Enter key is pressed.  The previous value can be 

canceled by the ESC key.  

This area is also used as a jump pointer of the jump function.

When displaying in register pairs, the value of WP, UUP, TDE, WHL, RG4, RG5, RG6, or RG7 is a 

jumper pointer for the jump from the area of VP, UP, DE, HL, RP4, RP5, RP6, or RP7, respectively.

For the general-purpose register display method, absolute name display and function name display 

can be switched with [View] in the menu bar. 

Register Bank Displays and sets the register bank to be displayed in the general-purpose 
register display area.

Current Bank Displays the register bank number that is currently set as the target (current 
bank).
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Caution: If the width of the data value display/setting area is too narrow, display problems may

occur. In this case, increase the width of the window. 

[SM78K0, SM78K0S]

Function Name Absolute Name 

Pair Register Register Pair Register Register

ax x rp0 r0

a r1

bc c rp1 r2

b r3

de e rp2 r4

d r5

hl l rp3 r6

h r7
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[SM78K4]

When selecting [View] -> [Function Name] from the menu bar, this area is used to display or change 

the register of the bank number displayed in the Register Bank field in the register bank setting area of 

A, X, B, C, AX, and BC according to the RSS bit value.

Function Name Absolute Name

Pair Register Register Pair Register Register

ax x rp0 r0

a r1

bc c rp1 r2

b r3

ax_ x_ rp2 r4

a_ r5

bc_ c_ rp3 r6

b_ r7

vvp v rg4 v

vp r8 rp4 r8

r9 r9

uup u rg5 u

up r10 rp5 r10

r11 r11

tde t rg6 t

de d rp6 r12

e r13

whl w rg7 w

hl h rp7 r14

l r15

Register RSS=0 RSS=1

R0 X X_

R1 A A_

R2 C C_

R3 B B_

R4 X_ X

R5 A_ A

R6 C_ C
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(3) Lower left field (control register display area)

This area is used to display or change the contents of control registers.  

The new value is written into the target when the Enter key is pressed.  The previous value can be 

canceled by the ESC key.  

If the name of a register with '+' prefixed is double-clicked, the names and values of its flags are 

displayed, and '+' changes to '-'.  This '+' can be also changed to '-' by selecting a register name with 

the arrow keys and pressing the Enter key.  

When a memory bank is used, the address width of the PC register value increases by 8 bits (SM78K0 

only).

This area is also used as a jump pointer of the jump function.  

Caution: If the width of the data value display/setting area is too narrow, display problems may

occur. In this case, increase the width of the window. 

Functions often used (right-click menu)

In this window, functions that are often used can be selected from the menu that is displayed by clicking

the right mouse button.  In this way, the same function can be used more easily than with the normal

procedure.  

R7 B_ B

RP0 AX AX_

RP1 BC BC_

RP2 AX_ AX

RP3 BC_ BC

Add Watch Registers a selected character string to the Watch window.
Opens the Add Watch dialog box.  

Bin Displays the selected line in binary numbers.

Oct Displays the selected line in octal numbers.

Dec Displays the selected line in decimal numbers.

Hex Displays the selected line in hexadecimal numbers (default).

Register RSS=0 RSS=1
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Function buttons  

Related operations

To change a register value 

To change the value of a register, move the cursor to the control register display area or general-

purpose register display area in the window, and directly write a value from the keyboard.  

Press the return key to set the new value.  To cancel the change, press the ESC key.  

Refresh Updates the contents of the window with the latest data.  

Close Closes this window.
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SFR window

This window is used to display and change the contents of SFR and the I/O ports that have been

registered in the Add I/O Port dialog box. 

Note, however, that the values of read-only SFR and I/O ports cannot be changed.  In addition, the SFR

and I/O ports that cause the device to operate when they are read are read-protected and therefore cannot

be read.

To read these registers, select a register, and select and execute [Compulsion Read] from the right-click

menu. 

Figure 6-43　SFR Window
[SM78K0, SM78K0S]

[SM78K4]

This section explains the following items:



208 User’s Manual  U16768EJ1V0UM

CHAPTER 6  WINDOW REFERENCE

• Opening

• Explanation of each area

• Functions often used (right-click menu)

• Function buttons

• Related operations

•  To change a SFR value

•  To select a SFR or I/O port to be displayed

•  To change the display sequence

•  To change the display radix

•  To add, change the contents of, and delete a user-defined I/O port

•  To change the display start position

Opening

This window box can be opened as follows:

• Click the SFR button.

• Select [Browse] -> [SFR] from the menu bar 
 (or press Alt,+B, and F in that order).

Explanation of each area

The SFR window consists of the following areas:

(1)　Name (SFR name display area)

(2)　Attribute (attribute display area)

(3)　Value (SFR contents display area)

(1) Name (SFR name display area)

This area displays the names of SFR and I/O ports. 

If the value of an I/O port address is not defined, the I/O port name displayed in light color.
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(2) Attribute (attribute display area)

[SM78K0, SM78K0S]

[SM78K4]

This area displays the read/write attributes, access types, and absolute addresses of the SFR and I/O 

ports.  when the bit SFR is displayed, bit-offset value is also displayed.  

It can be specified whether this area is displayed or not, by selecting [View] -> [Attribute] from the 

menu bar.  As an attribute, the following contents are displayed.

Read/Write Attribute

R Read only

W Write only

R/W Read/write

* To read this attribute directly from a SFR, execute [View] ->  [Compulsion Read] from 
the menu bar.  
Even a write-only SFR can also be read via an emulation register.  
However, some devices do not support this function.  

Access Type

1 Can be accessed in bit units.

8 Can be accessed in byte units.
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(3) Value (SFR contents display area) 

This area is used to display and change the contents of a SFR and I/O port.

The contents are displayed differently as follows, depending on the attribute:

The new value is written into the target when the Enter key is pressed.  The previous value can be 

canceled by the ESC key.  

The value of read-protected SFR and I/O ports can be read by selecting right-click menu -> 

[Compulsion Read].  

Caution: If the width of this area is too narrow, display problems may occur. In this case,

increase the width of the window.

Functions often used (right-click menu)

In this window, functions that are often used can be selected from the menu that is displayed by clicking

the right mouse button.  In this way, the same function can be used more easily than with the normal

procedure.  

16 Can be accessed in word units.

32 Can be accessed in double word units.

Black Display Read only or read/write

-- Write only

** Value changes if read

Move... Moves the display position.
Opens the Address Move dialog box.  

Add Watch Registers a selected character string to the Watch window.
Opens the Add Watch dialog box.  

Add I/O Port ... Adds user-defined I/O ports.
Opens the Add I/O Port dialog box.  
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Function buttons  

Bin Displays the selected line in binary numbers.

Oct Displays the selected line in octal numbers.

Dec Displays the selected line in decimal numbers.

Hex Displays the selected line in hexadecimal numbers (default).

Sort By Name Displays in alphabetical order.

Sort By Address Displays in address order (default).

Unsort Does not sort.

Attribute Displays or does not display an attribute area (Attribute).  
Checked: Displayed (default)
Not checked: Not displayed

Pick Up Displays only the registers selected in SFR Select dialog box.  
Checked: Displays only the selected register.
Not checked: Displays all the registers (default).

Select... Opens the SFR Select dialog box.  

Compulsion Read Forcibly reads the SFR that are disabled from being read because their 
values will be changed, or the data of the I/O ports and I/O protect area 
added in Add I/O Port dialog box.  

Refresh Updates the contents of the window with the latest data.  

Close Closes this window.
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Related operations

To change a SFR value

To change the contents of a SFR or I/O port, move the cursor to the Value area on the window, and 

write a value directly from the keyboard.  

Press the return key to set the new value.  To cancel the change, press the ESC key.  

Note that the values of read-only SFR and I/O ports cannot be changed.

To select a SFR or I/O port to be displayed

Use the SFR Select dialog box, which can be opened by selecting right-click menu -> [Select...] in the 

SFR window.  

To change the display sequence

The display sequence can be changed by selecting right-click menu -> [Sort By Name/Sort By 

Address/Unsort].  

To change the display radix

Select the line whose radix is to be changed, and select right-click menu ->  [Bin/Oct/Dec/Hex].  

To add, change the contents of, and delete a user-defined I/O port 

To manipulate an I/O port, use the Add I/O Port dialog box, which can be opened by selecting right-

click menu -> [Add I/O Port...] in the SFR window.  

To change the display start position

Use the Address Move dialog box, which can be opened by selecting right-click menu -> [Move...] in 

the SFR window.  
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SFR Select dialog box

This dialog box is used to select SFR and I/O ports that are not displayed the SFR window.  

It is also used to specify the sequence in which registers and ports are displayed.  

Figure 6-44　SFR Select Dialog Box

This section explains the following items:  

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

When SFR window is the current window

• Select [View] -> [Select...] from the menu bar 
 (or press Alt+V, and E in that order).

Explanation of each area  

The SFR Select dialog box consists of the following areas and buttons:

(1)　Display, Pick Up, No Display (display SFR selection area)

(2)　Arrange (display sequence specification button)

(3)　Sort by (No Display list display sequence change button)
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(1) Display, Pick Up, No Display (display SFR selection area) 

This area is used to select registers and I/O ports that are displayed or not displayed on the SFR 

window.  

To display or not display a register or I/O port in the SFR window, select the name of the register or I/O 

port from these lists, and click the <<<Show> or <Hide>>> button.  To display all the peripheral I/O 

registers, click the <<<Show All> button; to not display any of the registers, click the <Hide All>>> 

button.  

When selecting a SFR from the list, two or more registers can be selected by clicking any of the above 

buttons with the Ctrl or Shift key held down.  

(2) Arrange (display sequence specification button)

This button sets the sequence in which the registers and I/O ports are displayed in the Display list.  

A SFR or I/O port selected in the Display list can be moved to the top of the list by pressing the <Top> 

button, or to the bottom of the list by pressing the <Bottom> button.  The <Up> button moves the 

Display Registers and I/O ports are displayed in the SFR window

No Display Registers and I/O ports are not displayed in the SFR window

<< Show Moves the register or I/O port selected from the No Display list to Display.  

Hide >> Moves the register or I/O port selected from the Display list to No Display.  

<< Show All Moves all the registers and I/O ports to Display.  

Hide All >> Moves all the registers and I/O ports to No Display.  
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register or port one line up.  The <Down> button moves the register or port one line down.  

(3) Sort by (No Display list display sequence change button)

This button selects the sequence in which SFR and I/O ports are displayed in the No Display list.  

Pressing the <Name> button sorts the registers and ports into alphabetical order.  The <Address> 

button sorts them into address order.

Function buttons  

Top Moves the selected SFR or I/O port to the top of the list.

Up Moves the selected SFR or I/O port one line up.

Down Moves the selected SFR or I/O port one line down.

Bottom Moves the selected SFR or I/O port to the bottom of the list.

Name Displays in alphabetical order.

Address Displays in address order.

OK Reflects the selection in this dialog box in SFR window and closes this dialog 
box.

Cancel Cancels the changes and closes this dialog box.

Restore Restores the original status.

Help Opens the Help window.  
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Add I/O Port dialog box

This dialog box is used to register an I/O port to be added to the SFR window.

Figure 6-45　Add I/O Port Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

• Select [Option] ->[Add I/O Port...] from the menu bar 
 (or press Alt+O, and P in that order).

Explanation of each area

The Add I/O Port dialog box consists of the following areas:

(1)　 I/O Port List: (I/O port selection area)

(2)　Name: (I/O port name specification area)

(3)　Address: (I/O port address specification area)

(4)　Access (access size specification area)

(5)　Read / Write (access attribute specification area)
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(1) I/O Port List: (I/O port selection area)

This area lists the I/O ports currently registered.

If a new I/O port is registered, it is added to this list.  In addition, an I/O port already registered can be 

selected and changed or deleted.

(2) Name: (I/O port name specification area)

This area is used to specify an I/O port name to be added.  An I/O port name can be up to 15 

characters long.

(3) Address: (I/O port address specification area)

This area is used to specify the address of the I/O port to be added.

Only an address in one of these areas can be specified: Target area, SFR area any of these areas. 

An address can be also specified by a symbol or expression (refer to "Table 6-15  Specifying Symbols 

(p.130)").  The default radix for inputting a numeric value is hexadecimal.

(4) Access (access size specification area)

This area is used to specify the access size of the I/O port to be added.

Only SFR or external SFR (SM78K0, SM78K4), or SFR (SM78K0S) can specify Word access.

Byte 8 bits (default)

Word 16 bits
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(5) Read / Write (access attribute specification area) 

This area is used to specify the access attribute of the I/O port to be added.

In the default condition, all the attributes are not checked (i.e., the I/O port can be both read and 

written).

Function buttons

Read Only Read only

Write Only Write only

Read Protect Read-protected

OK Reflects the result of addition in SFR window and closes this dialog box.

Cancel Cancels changes and closes this dialog box.

Restore Restores the original status.

Help Opens the Help window.

Add Adds an I/O port of the specified address.

Change Changes the setting of the I/O port selected in I/O Port List.

Delete Deletes the I/O port selected in I/O Port List.
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Trace window

The Trace window displays the trace results.  

This window is only in the active status and is updated when a break occurs or step execution is

performed.  The source file can also be displayed with the trace results (refer to "Normal display and mixed

display (p.223)").  

A horizontal line (Block information) is displayed to indicate the end of program execution.  The cause of

stopping the program is displayed when the tracer is stopped (refer to "Table 6-24  Status When Tracer Is

Stopped").

The tracer is enabled by selecting [Option] -> [Tracer On] from the menu bar.  

To manipulate the tracer during program execution, select [Run] -> [Tracer Start/Stop] from the menu bar.  

For details of the trace function, refer to "Trace function (p.40)".  

Figure 6-46　Trace Window

This section explains the following items:  

• Opening

• Explanation of each area

• Functions often used (right-click menu)

• Function buttons

• Related operations

•  To make the trace function usable

•  To set trace control mode

•  To set a section trace event and quality trace event

•  To change the display start position
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•  To search trace data

•  To clear trace data

•  To turn on/off the tracer during program execution

•  For pick up display

•  To display the source text (mixed display mode)

•  To select the display item and change the display radix

•  To set a time tag counter, count rate, and total time tag

Opening

This window can be opened as follows:

• Click the TrW button.

• Select [Browse] -> [Trace] from the menu bar 
 (or press Alt+B, and T in that order).

Explanation of each area  

The Trace window consists of the following areas:

(1)　Point mark display area

(2)　Trace mode display area

(3)　Trace result display area

(1) Point mark display area

This area displays Event setting status.  

If an execution event or access event is set at the corresponding trace address, the mark 

corresponding to the type of the event is displayed.  

The mark displayed is not that during trace but an event mark that is set when the trace result is 

displayed.  

(2) Trace mode display area

This area displays the types of trace modes.

"T" is also displayed in the frame where the display trigger occurred.

If a qualify trace condition is satisfied while a section trace condition is satisfied, 'Q' is displayed.

A Fully or section traced frame

Q Qualify traced frame

S Step executed frame

T Delay trigger frame 



CHAPTER 6  WINDOW REFERENCE

User’s Manual  U16768EJ1V0UM 221

(3) Trace result display area 

This area displays the trace results.  

This area has two display modes: Normal display and mixed display.  In addition, Jump Function and 

Trace Result with Linking Window can be used in this area.  

Whether each of the following sub-areas is displayed or not can be selected in the Trace Data Select 

dialog box.  

(a) Frame (trace frame number display)

This area displays trace frame numbers.  

(b) Time (time tag display)

This area displays how many clocks the target chip has required since execution of the preceding trace 

contents was started until execution of the current trace contents is started.  As the display contents, 

display of the number of clocks or display of time can be selected in the Trace Data Select dialog box.  

In addition, the division rate of the number of counts can be selected up to 1M in the Extended Option 

dialog box.  

The SM78Kx can count the time tag value up to 16777215. If the time tag value overflows, 16777215 is 

displayed for the clock count display, or in the case of time display, the value in the max: field in the 

trace time tag counter division ratio selection area of the Extended Option dialog box is displayed. 

The number of clocks and time tag value correspond as follows: 

If <Add Up Timetag> is checked, the total is displayed.

Table 6-22　Number of Clocks and Time Tag Value 

Number of 
Clocks

Time Tag Value 

Division rate 1 Division rate 2 Division rate 4 Division rate 8

1 1 1 1 1

2 2 2 2 2

3 3 2 2 2

4 4 3 2 2

5 5 3 2 2

6 6 4 3 2

7 7 4 3 2

8 8 5 3 2

9 9 5 3 2
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(c) Address Data Status (fetch access display) 

This area displays the result of fetching the program.

The display contents of Address and Data differ depending on the Status display.  

Status

The following types of statuses are available:

Address Data

Displays addresses and data.  The display contents differ as follows, depending on the Status display.  

Program fetch display

BRM1 Fetching of first byte of first instruction after branch
A line is displayed in blue for emphasis if the fetched address is the top of a 
symbol.  

M1 Fetching of first byte of instruction
A line is displayed in blue for emphasis if the fetched address is the top of a 
symbol.  

OP Opcode fetch of 2nd and subsequent bytes 

IF Invalid fetch or status unknown 

Snap display

SNAP Snap display

No display

Other Nothing is displayed. (Blank line is displayed.) 

Program fetch display

Address Displays the fetch address

Data Displays the fetch data

Snap display

Item Snap Type Display Contents

Address Register Register name

SFR SFR name

Memory Memory address

Data Register Register value

SFR SFR value

Memory Memory contents
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(d) Address Data Status (data access display)

This area displays the result of accessing data.

(e) Jmpaddr (branch source address display)

The last address of the branch source is displayed only when the status is BRM1.

(f) DisAsm (mnemonic display)

This area displays the result of disassembly (only when the status of fetch access display is BRM1 or 

M1).

Block information

Block information is written if the previous and current execution modes are as follows:

If previous execution mode is real-time execution

-> If the current execution mode is real-time execution (if execution has been stopped once) or step 

execution.  

If previous execution mode is step execution

-> If the current execution mode is real-time execution or step execution with execution address 

changed.  

Normal display and mixed display

In the normal display mode, only the trace result is displayed.  

In the mixed display mode, the source file is also displayed along with the trace result.  

If a program code corresponds on the program fetch address to be displayed, a source file line is 

displayed before the line indicating the result of tracing that program fetch address.  

Status

VECT Vector read 

RW Memory read/write (SM78K0, SM78K0S only)

R Memory read (SM78K0, SM78K0S only)

W Memory write (SM78K0, SM78K0S only)

RWP Memory read/write via user program (SM78K4 only)

RP Memory read via user program (SM78K4 only)

WP Memory write via user program (SM78K4 only)

RWM Memory read/write via macro service (SM78K4 only)

RM Memory read via macro service (SM78K4 only)

WM Memory write via macro service (SM78K4 only)
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The source file line is displayed, emphasized in green.  

The display mode can be alternately changed by selecting [View] -> [Mix] from the menu bar.  

Caution: The mixed display mode is valid only when the load module has been downloaded

and symbol information is read, and when a fetch address, fetch data, fetch status, or

result of disassembly is displayed.

Jump function

This function allows you to jump to the Source window, Assemble window, Memory window or 

Coverage window, using the cursor position as a jump pointer (refer to "Jump Function (p.50)").   

To jump from the Trace window, the jump pointer changes as follows, depending on the area in which 

the cursor is positioned:

Cause of stopping tracer

The tracer may be stopped by the following types of causes:

Table 6-23　Cursor Position and Jump Pointer

Cursor Position Jump Pointer

Access Address Display Area Access address
(If the jump destination is the Source window or Assemble 
window, the fetch address is always used as the jump pointer.)Access Data Display Area

Access Status Display Area

Other Fetch address

Table 6-24　Status When Tracer Is Stopped

Cause Meaning

Event Break Break by event

Trace Full Break Break due to trace full

Uninitialize Memory read Loaded non-initialized memory.

Non Map Break A non-mapped break has been accessed.

Write Protect An attempt has been made to write to a write-protected area.

SFR Illegal An illegal access is made to a SFR.
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Functions often used (right-click menu)

In this window, functions that are often used can be selected from the menu that is displayed by clicking

the right mouse button.  

In this way, the same function can be used more easily than with the normal procedure.  

Relocation Break A relocation instruction different from the initial setting has been 
executed.

Stack Overflow Break by stack overflow

Time Over Break Break because execution time is over.

Security Protect A security protected area is accessed.

Step Break Step execution break

Compulsory Break Manual break

Trace Stop Trace stop

Move... Moves the display position.
Opens the Trace Move dialog box.  

Trace Clear Clears the trace data.

Select Selects the contents to be displayed.
Opens the Trace Data Select dialog box.  

Pick Up Performs the setting for pickup display.

Off Does not pick up and display (default).

Search Picks up and displays a frame that satisfies the search condition.

BRM1 Picks up and displays the first M1 fetch frame after a program branch.

Mix Specifies whether the results of assembly are displayed in mixed display 
mode, or not displayed.
Checked: Mixed display
Not checked: No display (default)

Window Synchronize Links the Trace window with the following windows:

Source Text Links the Source window.

Assemble Links the Assemble window.

Memory Links the Memory window.

Coverage Links the Coverage window.

Table 6-24　Status When Tracer Is Stopped

Cause Meaning
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Function buttons  

Related operations

To make the trace function usable

Select and check [Option] -> [Tracer On] from the menu bar.  To invalidate the tracer, select [Tracer On] 

again and remove the check mark.  

To set trace control mode 

Select [Run] -> [Tracer Control Mode] from the menu bar and select one of the following modes: 

Source Text Displays the corresponding source text and source line, using the data value 
at the cursor position as the jump destination address.  
If no line information exists at the jump destination address, however, you 
cannot jump.  
Opens the Source window.  
If an active Source window is open, that window is displayed in the forefront 
(so that it can be manipulated).  

Assemble Disassembles and displays starting from the jump destination address 
specified by the data value at the cursor position.  
Opens the Assemble window.  
If an active Assemble window is open, that window is displayed in the 
forefront (so that it can be manipulated).  

Memory Displays the memory contents starting from the jump destination address 
specified by the data value at the cursor position.  
Opens the Memory window.  
If an active Memory window is open, that window is displayed in the 
forefront (so that it can be manipulated).  

Coverage Displays the coverage measurement results starting from the jump 
destination address specified by the data value at the cursor position.  
Opens the Coverage window.  
If an active Coverage window is open, that window is displayed in the 
forefront (so that it can be manipulated).  

Search... Opens the Trace Search dialog box and searches or picks up trace results.  
The searched result will be highlighted in the Trace window. 
This button cannot be selected when a snap frame or BRM1 frame is picked up and 
displayed.
This is the same operation as selecting [View] -> [Search...] from the menu bar.  

<< Searches forward (upward on screen) for a trace result that satisfies the search 
condition set in the Trace Search dialog box.  
This button cannot be selected while pickup display is being performed.  

>> Searches backward (downward on screen) for a trace result that satisfies the search 
condition set in the Trace Search dialog box.  
This button cannot be selected while pickup display is being performed.  

Refresh Updates the contents of the window with the latest data.  

Close Closes this window.



CHAPTER 6  WINDOW REFERENCE

User’s Manual  U16768EJ1V0UM 227

To set a section trace event and quality trace event

Use the Trace dialog box which can be opened by clicking the Trc button.

To change the display start position

Use the Trace Move dialog box that can be opened by selecting right-click menu -> [Move...] in the 

Trace window.  

To search trace data

Select right-click menu -> [Pick Up] -> [Off] in the Trace window and click the <Search...> button.  The 

Trace Search dialog box will be opened, enabling trace results to be searched.  

To clear trace data 

Select the right-click menu -> [Trace Clear] in the Trace window.  

This will clear the trace buffer (display contents of the Trace window).  

To turn on/off the tracer during program execution

To temporarily stop coverage, select [Run] -> [Tracer Stop] from the menu bar during program 

execution.  To resume tracer operation, select [Tracer Start].  

This operation can be performed only while the program is being executed.

It cannot be performed if the tracer function is disabled (when [Option] -> [Tracer On] is not checked).  

For pick up display

Only specific trace data can be picked up and displayed in the Trace window.  

A snap frame, M1 fetch frame, and picking up a frame that satisfies a given search condition can be 

selected as pickup conditions.  

To pick up and display a snap frame or M1 fetch frame

Select right-click menu-> [Snap/BRM1] in the Trace window.  A snap frame or M1 fetch frame will be 

picked up and displayed in the Trace window.  

To pick up and display only a frame that satisfies the search condition

Select right-click menu -> [Search] in the Trace window and click the <Search> button.  The Trace 

Search dialog box will be opened, enabling data to be picked up to be set.  

To display the source text (mixed display mode) 

Select the right-click menu -> [Mix] in the Trace window.  

Non Stop Goes around the trace memory and overwrites data from the oldest 
frame (default).  

Full Stop Goes around the trace memory and then stops the tracer.

Full Break Goes around the trace memory and then stops the tracer and 
program execution

Delay Trigger Stop Traces data by the number of delay count frames and stops the tracer 
when a delay trigger event has occurred. 

Delay Trigger Break Traces data by the number of delay count frames and stops the tracer 
and program execution when a delay trigger event has occurred. 
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To select the display item and change the display radix 

Use the Trace Data Select dialog box, which can be opened by selecting the right-click menu -> 

[Select...] in the Trace window.  

The display radix can be changed in the fetch data display area and access data display area.  

To set a time tag counter, count rate, and total time tag 

Use the Extended Option dialog box, which can be opened by selecting [Option] -> [Expanded 

Option...] from the menu bar.
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Trace Search dialog box

This dialog box is used to search or pick up trace data in Trace window.  

This dialog box is used to search trace data if it is opened by selecting [View] -> [Pick Up] -> [Off] from the

menu bar.  It is used to pick up and display trace data if it is opened by selecting [View] -> [Pick Up] ->

[Search] from the menu bar.

By setting each item and then clicking the <Find Next> button, searching can be started.  

By clicking the <Set Find> button, the direction buttons ("<<" and ">>") in the Trace window can be used

for the search.  

Caution: The Trace Search dialog box cannot be called if picking up snap frames and the first

M1 fetch frame (BRM1) after program branch is specified using the menu bar or in

Trace Data Select dialog box.  

Figure 6-47　Trace Search Dialog Box 

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

When Trace window is the current window

• Click the <Search> button.
 (or press Ctrl+G).

• Select [View] -> [Search...]  
 (or press Alt+V, and S in that order).
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Explanation of each area

The Trace Search dialog box consists of the following areas:

(1)　Event Status (status selection area)

(2)　Access Size (access size selection area)

(3)　Address, Mask (address setting area)

(4)　Data, Mask (data setting area)

(5)　Scan Whole Region (search condition specification area)

(6)　Direction (search direction specification area)

(7)　Frame (search range specification area)

(1) Event Status (status selection area)

This area is used to set and select a status condition.  

A status condition can also be specified in abbreviated form.  Uppercase and lowercase characters are 

not distinguished.  

If a status condition is omitted, all frames (All status) are searched.  

Table 6-25　Types of Status Conditions

Status Abbreviation Meaning

All status ALL All frames (default)

BRM1 Fetch BRM1 First M1 fetch after program branch 

M1 Fetch M1 M1 fetch (including BRM1)

Opcode Fetch OP Opcode fetch (including M1 and BRM1) 

R/W RW Memory read/write (including R, W (SM78K0, SM78K0S), 
or RM, RP, WM, WP (SM78K4))

Read R Memory read (SM78K4 only)

Write W Memory write (SM78K4 only)

R/W by Macro RWM Memory read/write via macro service (including RM and 
WM) (SM78K4 only)

Read by Macro RM Memory read via macro service (SM78K4 only)

Write by Macro WM Memory write via macro service (SM78K4 only)

R/W by Program RWP Memory read/write via program (including RM and WM) 
(SM78K4 only)

Read by Program RP Memory read via program (SM78K4 only)

Write by Program WP Memory write via program (SM78K4 only)

Vector Read VECT Vector read via interrupt
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(2) Access Size (access size selection area)

This area is used to set and select an access size condition.  

By specifying an access size condition, the access width of a data condition to be detected by an 

access event is determined.  

An access size condition can also be specified in abbreviated form.  Uppercase and lowercase 

characters are not distinguished.  

Caution: If an access event is specified as a status condition, the alternative of Bit is not

displayed.  If Bit or 1 is specified, an error occurs.  

If no access size condition is specified, a judgment is automatically made from the address condition 

and data condition, and the following is set:  

•  Bit if the address condition is set in bit units

•  Byte if the data condition is set in 8-bit units

•  Word if the data condition is set in 16-bit units

•  No Condition if no data condition is specified

Table 6-26　 List of Access Size Conditions (Trace)

Size Abbreviation Meaning

Byte B Searches for a data condition with 8-bit width (only during 8-bit 
access).  

Word W Searches for a data condition with 16-bit width (only during 16-bit 
access).  

No Condition NC Does not search based on access size (nothing can be input to 
the Data area).

Bit 1 Searches for a data condition with 1-bit width (only during 8-bit 
access).  
In this case, a search is made for a data condition with 1-bit 
width.  Because of the operation of the simulator, access to a bit 
is not directly detected; the simulator searches a dummy bit 
access by internally setting address conditions and data 
conditions as follows:  

Input example:
Address: FE20.1
Data: 1

Setting of trace search
Address: FE20
Data: 00000010B
Mask: 11111101B

If another bit of the same address is accessed or if all the 8 bits 
of the same address are accessed, therefore, an event is 
detected in accordance with the specified status if the address 
and bit match the specified value of [address.bit].  
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(3) Address, Mask (address setting area)

Address, which sets an address value and Mask, which sets the mask value of an address value, are 

set as address conditions.  

An address can be also specified by a symbol or expression (refer to "Table 6-15  Specifying Symbols 

(p.130)").  The default radix for inputting a numeric value is hexadecimal.  

Both the address and mask may be omitted.  

The following can be set:

Address

Set an address condition.  

The following can be set:  

Mask

Set a mask value for an address value (only when a point is specified).  

The address value of a bit whose mask value is 1 may be 0 or 1.  

Table 6-27　Settable Range of Address Condition

Settable range Condition

0 =< address value =< 0xFFFF
0 =< mask value =< 0xFFFF

 (SM78K0S)

0 =< address value =< 0xFFFF
0 =< mask value =< 0xFFFF

When not using bank (SM78K0)

0 =< address value =< (n<<16) | 0xFFFF
0 =< mask value =< (n<<16) | 0xFFFF
n is the maximum value of the bank number 
to be used.

When using bank (SM78K0)

0 =< address value =< 0xFFFFFF
0 =< mask value =< 0xFFFFFF

Execution type events, fetch type events (SM78K4)

0 =< address value =< 0xFFFFFFFF
0 =< mask value =< 0xFFFFFFFF

Data access type events (SM78K4)

Set Point Set a value to only the lower address, or set the same value to the lower 
address and the higher address.  
Mask can be set.

Set Range Set a value to the lower address and the higher address.  
Mask cannot be set.

Setting of Bit Set a value to only the lower address, or set the same value to the lower 
address and the higher address.  Specify a value in the form of 
address.bit.  
Mask cannot be set.
The value of bit, which indicates the bit position, must be 0 =< bit =< 7.  
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Example 1:

With this setting, addresses 0x4000 to 0x40FF satisfy the condition.  

Example 2:

With this setting, addresses 0x4000, 0x4001, 0x4100, and 0x4101 satisfy the condition.

(4) Data, Mask (data setting area)

Data, which sets an data value, and Mask, which sets the mask value of an data value, are set as data 

conditions.  

The default radix for inputting a numeric value is hexadecimal.  

Both the data and mask may be omitted.  

The settable range differs as follows depending on the access size condition specified in the Access 

Size area.  

Data

Set a data value.  Specify a value within the settable range.  

A symbol or expression can be also specified by a symbol or expression (refer to "Table 6-15  

Specifying Symbols (p.130)").  

Mask

Set a mask value for the data value.

When a mask is set, the data value for the bit whose mask value is 1 may be 0 or 1.  

The data value for a bit whose mask value is 1 may be 0 or 1.  

Example 1:

Address 0x4000 to 0x4000

Mask 0xFF

Address 0x4000 to 0x4000

Mask 0x101

Table 6-28　Settable Range of Data Condition

Access Size Settable range

Byte 0 =< data value =< 0xFF
0 =< mask value =< 0xFF  

Word 0 =< data value =< 0xFFFF  
0 =< mask value =< 0xFFFF  

Bit Data value = 0 or 1
Mask value = Cannot be specified.

Data 0x4000 
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With this setting, addresses 0x4000 to 0x40FF satisfy the condition.  

Example 2:

With this setting, addresses 0x4000, 0x4001, 0x4100, and 0x4101 satisfy the condition.  

(5) Scan Whole Region (search condition specification area)   

This area is used to specify whether the specified range is fully searched or not.  

(6) Direction (search direction specification area)

This area is used to specify the direction of the search.  

(7) Frame (search range specification area)

This area is used to specify a frame number to be searched.  

For how to specify a frame number, refer to "Table 6-14  Frame Number Specification Format (p.127)".  

The default radix for inputting a numeric value is decimal.  

Mask 0xFF

Data 0x4000 

Mask 0x101

Checked Searches the entire range.  

Not checked Searches the remaining part of the range (default)  

Up Forward search.
Searches data forward (upward on screen) from the current position 
of the cursor.  

Down Backward search (default).
Searches data backward (downward on screen) from the current 
position of the cursor.  
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Function buttons

Find Next Searches the specified data in accordance with a given condition.  
If the specified frame is found as a result of a search, it is highlighted.  To 
continue searching, click this button again.  

Set Find Sets the specified condition as the search condition and closes this dialog 
box.  

Pick Up
(Stop (during search))

Picks up according to the specified condition of data search.  
If a frame that satisfies the condition is found as a result of a search, it is 
picked up.  To pick up a frame that satisfies a different condition, press this 
button again.  

Cancel Closes this dialog box.  

Help Opens the Help window.  
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Trace Data Select dialog box

This dialog box is used to select items to be displayed in the Trace window.  

Figure 6-48　Trace Data Select Dialog Box

This section explains the following items:  

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

When Trace window is the current window

• Select [View] -> [Select...] from the menu bar 
 (or press Alt+ V, and E in that order).  

Explanation of each area  

The Trace Data Select dialog box consists of the following areas:

(1)　 Item (trace display item selection area)

(2)　Radix (trace display radix selection area)

(3)　Pick Up (pickup selection area)
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(1) Item (trace display item selection area)

This area is used to select items to be displayed in the Trace window.  Displaying the following items 

may or may not be selected.  The field checked is displayed.  

(2) Radix (trace display radix selection area)

This area is used to select the radix in which data is to be displayed.  Displaying the following items 

may or may not be selected.

Frame Frame number display field

Timetag Time tag display field
Whether the clock or time is displayed can be selected.  
Clock...Clock display (default)
Time...Time display

Instruction Fetch Address Fetch address display field

Instruction Fetch Data Fetch data display field

Instruction Fetch Status Fetch status display field

Memory Access Address Access address display field

Memory Access Data Access data display field

Memory Access Status Access status display field

Jump Address Branch source address display field 

DisAssemble Disassemble display field
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Display field

Display radix

(3) Pick Up (pickup selection area)

This area is used to select a pick up condition.  

Function buttons  

Instruction Fetch Data Fetch data display field

Memory Access Data Access data display field

HEX Hexadecimal display

DEC Displays decimal numbers.

OCT Displays octal numbers.

BIN Displays binary numbers.

Pick Up Off No pick up display

Pick Up Search Frame Picks up and displays a frame that satisfies the search condition.

Pick Up Snap Frame Picks up and displays a snap frame.

Pick Up BRM1 Frame Picks up and displays the first M1 fetch frame after a program branch .

OK Reflects the results of selection in this dialog box in Trace window.

Cancel Closes this dialog box.  

Restore Restores the original status.

Help Opens the Help window.  
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Coverage window

This window displays the coverage results.  

Coverage measurement is performed by selecting [Option] -> [Coverage ON].  While the program is

executed, coverage measurement is manipulated by [Run] -> [Coverage Start/Stop] from the menu bar.  

The Coverage window has two window statuses: Active Status and Static Status.  

Figure 6-49　Coverage Window

This section explains the following items:  

• Opening

• Explanation of each area

• Functions often used (right-click menu)

• Function buttons

• Related operations

•  To make the coverage measurement function usable

•  To change the display start position

•  To set and display the coverage efficiency display condition

•  To turn on/off coverage during program execution

•  To search the coverage results

•  To clear the overage result

•  To change the display bytes

Opening

This window can be opened as follows:

• Click the Cov button.

• Select [Browse] -> [Coverage] from the menu bar
 (or press Alt+B, and O in that order).  
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• Select [Jump] -> [Coverage] from the menu bar
(or press Alt+J and C in that order, or Ctrl+I).  

Explanation of each area  

The Coverage window consists of the following areas:

(1)　Addr (address display area)

(2)　 01234... (coverage display area)

(1) Addr (address display area)

This area displays coverage addresses.  

(2) 01234... (coverage display area)

This area displays the coverage results.  

To select a display mode, use the [View] menu.  

Table 6-29　Status List of Coverage Data

In 1-byte display mode

Display Meaning

． Neither execute, read, nor write

X Execute only

R Read only

W Write only
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Caution: 1024 bytes are supported only by the SM78K4.

This area has a jump function and a function to link the trace display.  

Functions often used (right-click menu)

In this window, functions that are often used can be selected from the menu that is displayed by clicking

the right mouse button.  In this way, the same function can be used more easily than with the normal

procedure.  

A Read and write only

$ Execute and read only

# Execute and write only

% Execute, read, and write

In 64/1024-byte display mode

Display Meaning

． Neither execute, read, nor write any addresses in the 64/1024-byte range

X Execute all addresses in the 64/1024-byte range

R Read all addresses in the 64/1024-byte range

W Write all addresses in the 64/1024-byte range

A Read and write all addresses in the 64/1024-byte range

$ Execute and read all addresses in the 64/1024-byte range

# Execute and write all addresses in the 64/1024-byte range

% Execute, read, and write all addresses in the 64/1024-byte range

Move... Moves the display position.
Opens the Address Move dialog box.  

1Byte Displays in 1-byte units (default).

64Bytes Displays in 64-byte units.

1024Bytes Displays in 1024-byte units (SM78K4 only).

Table 6-29　Status List of Coverage Data

In 1-byte display mode

Display Meaning
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Function buttons  

Source Text Displays the corresponding source text and source line, using the data value at 
the cursor position as the jump destination address.  
If no line information exists at the jump destination address, however, you cannot 
jump.  
Opens the Source window.  
If an active Source window is open, that window is displayed in the forefront (so 
that it can be manipulated).  

Assemble Disassembles and displays starting from the jump destination address specified 
by the data value at the cursor position.  
Opens the Assemble window.  
If an active Assemble window is open, that window is displayed in the forefront 
(so that it can be manipulated).  

Memory Displays the memory contents starting from the jump destination address 
specified by the data value at the cursor position.  
Opens the Memory window.  
If an active Memory window is open, that window is displayed in the forefront (so 
that it can be manipulated).  

Clear... Clears the coverage measurement results.
Opens the Coverage-Clear dialog box.  

Condition... Sets a coverage efficiency measurement condition.
Opens the Coverage-Condition Setting dialog box.  

Efficiency... Displays coverage efficiency.
Opens the Coverage-Efficiency View dialog box.  

Search... Opens the Coverage Search dialog box and searches a coverage result.  
The searched result will be highlighted in the Coverage window.  
This button is valid only in the 1-byte display mode.

<< Searches forward (upward on screen) for a coverage result that satisfies the 
search condition set in the Coverage Search dialog box, starting from the 
address at the cursor position.  
This button is displayed as the <Stop> button during a search.  
This button is valid only in the 1-byte display mode.

>> Searches backward (downward on screen) for a coverage result that satisfies 
the search condition set in the Coverage Search dialog box, starting from the 
address at the cursor position.
This button is displayed as the <Stop> button during a search.  
This button is valid only in the 1-byte display mode.

Stop (during search) Stops searching.

Refresh Updates the contents of the window with the latest data.  

Close Closes this window.
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Related operations

To make the coverage measurement function usable

Select and check [Option] -> [Coverage On] from the menu bar.  To disable coverage, select 

[Coverage On] again.  

To change the display start position

Use the Address Move dialog box that can be opened by selecting right-click menu -> [Move...] in the 

Coverage window.  

To set and display the coverage efficiency display condition

Use the Coverage-Condition Setting dialog box, which can be opened by selecting right-click menu -> 

[Condition...] in the Coverage window.

As the address condition in which coverage efficiency is to be measured, an address range or a 

function can be specified.  

The coverage efficiency status is displayed in the Coverage-Efficiency View dialog box, which can be 

opened by selecting right-click menu -> [Efficiency...] in the Coverage window.  

To turn on/off coverage during program execution

To temporarily stop coverage, select [Run] -> [Coverage Stop] from the menu bar during program 

execution.  To resume operation, select [Coverage Start].  

This operation can be performed only while the program is being executed.  

It cannot be performed if the coverage function is disabled (when [Option] -> [Coverage On] is not 

checked).  

To search the coverage results

Use Coverage Search dialog box, which can be opened by clicking the <Search...> button in the 

Coverage window.  Data is not searched in a non-mapped area.  

To clear the overage result

Use the Coverage-Clear dialog box that can be opened by selecting right-click menu -> [Clear...] in the 

Coverage window.  

When the coverage measurement result is cleared, the contents of the Coverage window and 

Coverage-Efficiency View dialog box are initialized.  

To change the display bytes

The display bytes can be changed by selecting right-click menu ->  [1Byte/64Byte/1024] in the 

Coverage window.

Caution: 1024 bytes are supported only by the SM78K4.
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Coverage Search dialog box

This dialog box is used to search coverage results in the Coverage window.  

This dialog box can be called only in the 1-byte display mode.  

By setting each item and then clicking the <Find Next> button, searching can be started.  

By clicking the <Set Find> button, the direction buttons ("<<" and ">>") in the Coverage window can be

used for the search.

Searching cannot be executed in a non-mapped area.  

Figure 6-50　Coverage Search Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:  

When the Coverage window is the current window

• Click the <Search...> button.
 (or press Ctrl+G).

• Select [View] -> [Search...]  
 (or press Alt+V, and S in that order).

Explanation of each area  

The Coverage Search dialog box consists of the following areas:

(1)　Search data specification area

(2)　Scan Whole Region (search condition specification area)
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(3)　Direction (search direction specification area)

(4)　Address (search range specification area)

(1) Search data specification area

Specify a search condition by checking any of the check boxes in this area.  

If two or more check boxes are checked, the specified address is searched when any of the conditions 

of the check boxes is satisfied (OR search).  

(2) Scan Whole Region (search condition specification area)   

This area is used to specify whether the specified range is fully searched or not.  

(3) Direction (search direction specification area)

This area is used to specify the direction of the search.  

No Use [.] Neither execute, read, nor write

Read [R] Read only

Write [W] Write only

Read x Write [A] Read and write

Execute [X] Execute only

Execute x Read[$] Execute and read

Execute x Write [#] Execute and write

Execute x Read x Write [%] Execute, read, and write

Checked Searches the entire range.  

Not checked Searches the remaining part of the range (default)  

Up Forward search.
Searches data forward (upward on screen) from the current position 
of the cursor.  
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(4) Address (search range specification area)

This area is used to specify the address to be searched.  

An address can be also specified by a symbol or expression (refer to "Table 6-15  Specifying Symbols 

(p.130)").  The default radix for inputting a numeric value is hexadecimal.  

Function buttons

Down Backward search (default).
Searches data backward (downward on screen) from the current 
position of the cursor.  

Find Next Searches the specified data in accordance with a given condition.  
If the specified character string is found as a result of a search, it is 
highlighted.  To continue searching, click this button again.  

Set Find Sets the specified condition as the search condition and closes this dialog 
box.

Stop (during search) Stops searching.

Cancel Closes this dialog box.  
This button is displayed as the <Stop> button while data is being searched.  

Help Opens the Help window.  
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Coverage-Clear dialog box

This dialog box is used to clear the coverage measurement results in a specified address range.  

As a result, the contents of the Coverage window and Coverage-Efficiency View dialog box are initialized.  

Figure 6-51　Coverage-Clear Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:  

• Select [Option] -> [Coverage] -> [Clear...] from the menu bar
 (or press Alt+O, O, and L in that order).

Explanation of each area  

The Coverage-Clear dialog box consists of the following areas:

(1)　Address Range (address specification area)

(1) Address Range (address specification area)

This area is used to specify the addresses whose coverage results are to be cleared.  

An address can be also specified by a symbol or expression (refer to "Table 6-15  Specifying Symbols 

(p.130)").  The default radix for inputting a numeric value is hexadecimal.  
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Function buttons

OK Clears the coverage result in the address range specified in Address Range.

Stop (while cleared) Stops clearing the coverage result.

Cancel Closes this dialog box.  
This button is displayed as the <Stop> button while the coverage result is 
being cleared.

Restore Restores the input data to the original status.  

Help Opens the Help window.  
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Coverage-Condition Setting dialog box

This dialog box is used to specify the contents (condition) to be displayed in the Coverage-Efficiency View

dialog box  

Up to 16 conditions can be registered.  

Figure 6-52　Coverage-Condition Setting Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Specifying

• Function buttons

Opening

This dialog box can be opened as follows:  

• Select [Option] -> [Coverage] -> [Condition...] from the menu bar  
 (or press Alt+O, O, and O in that order).  

• Click the <Condition> button in Coverage-Efficiency View dialog box.  

Explanation of each area  

The Coverage-Condition Setting dialog box consists of the following areas:

(1)　Survey List (selected list display area)

(2)　Address Range, Function (address condition specification area)

(3)　Survey Condition (status condition specification area)
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(1) Survey List (selected list display area)

This area displays a list of the conditions currently selected.  

(2) Address Range, Function (address condition specification area)  

This area specifies an address condition for the coverage efficiency.  

An address condition can be specified in two ways.  To specify a condition as an address range, use 

Address Range.  To specify a condition as a function, use Function.  

(3) Survey Condition (status condition specification area)  

This area is used to select a status condition for the coverage efficiency.  

Address An address can be also specified by a symbol or expression (refer to 
"Table 6-15  Specifying Symbols (p.130)").  The default radix for 
inputting a numeric value is hexadecimal.  

Function A function can be specified by selecting from the drop-down list or by 
inputting from the keyboard.  Specify a function name that has been 
registered to the load module file.  

Execute Percentage of program execution

Read Percentage of memory read

Write Percentage of memory write

All Percentage of program execution, or memory read or write
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Specifying

To set a display condition for the coverage efficiency

1 Open the Coverage-Condition dialog box.  

Select [Option] -> [Coverage] -> [Condition...] from the menu bar  

2 Specify Survey Condition (in Survey Condition (status condition specification area)).

Select Execute if a function is specified.  

3 Specify Survey Condition (in Address Range, Function (address condition specification area)).  

Specify Address Range or Function (in the address condition specification area).

4 Click the <Insert> button.  

To delete a display condition for the coverage efficiency  

1 Opens Coverage-Efficiency View dialog box.  

Select [Option] -> [Coverage] -> [Condition...] from the menu bar  

2 Select the condition to be deleted from Survey List (Survey List (selected list display area)).  

3 Click the <Delete> button.  

Function buttons

OK Closes this dialog box.  

View Displays coverage efficiency.
Opens Coverage-Efficiency View dialog box.  

Restore Restores the input data to the original status.  

Help Opens the Help window.  

Clear Clears the contents of Survey List Survey List (selected list display area).

Delete Deletes the selected address range or function name from Survey List Survey 
List (selected list display area).

Insert Registers the address range or function name specified in Address Range or 
Function Address Range, Function (address condition specification area) to 
Survey List Survey List (selected list display area).
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Coverage-Efficiency View dialog box

This dialog box displays the coverage efficiency of the coverage results in the range specified in the

Coverage-Condition Setting dialog box.  

Figure 6-53　Coverage-Efficiency View Dialog Box  

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:  

• Select [Option] -> [Coverage] -> [Efficiency...] from the menu bar  
 (or press Alt+O, O, and E in that order).

• Click the <View> button in Coverage-Condition Setting dialog box.  

Explanation of each area  

The Coverage-Efficiency View dialog box consists of the following areas:  

(1)　Survey List (coverage range display area)

(2)　Results(%) (coverage efficiency display area)
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(1) Survey List (coverage range display area)

This area displays the coverage efficiency measurement range.  

The area specified in Coverage-Condition Setting dialog box is displayed in this area.  

If a function name is specified, "program name$file name#function name" is displayed.  

(2) Results(%) (coverage efficiency display area)

This area displays the coverage efficiency.  

The coverage efficiency indicates how many specified statuses (execution, read, and write) are 

included in the measurement range, as a percentage (refer to "Table 6-29  Status List of Coverage 

Data (p.240)").  

Function buttons

OK Closes this dialog box.  

Condition Sets the displayed contents of the coverage efficiency.  
Opens Coverage-Condition Setting dialog box.  

Help Opens the Help window.  
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Event Manager

This window is used to display, enable or disable, and delete various event conditions.  

It is also used to register the various event conditions and manage the event conditions for setting them.  

Up to 256 conditions can be registered as event conditions or various event conditions.  However, the

number of event conditions that can be used (enabled) at the same time is limited as follows:

Figure 6-54　Event Manager

This section explains the following items:  

• Opening

• Explanation of each area

• Functions often used (right-click menu)

• Function buttons

• Related operations

•  To save/restore event information

•  To enable/disable an event

•  To change the display sequence of event icons

•  To display details of event condition

•  To delete an event

•  To create an event condition

•  To create an event link condition

•  To set an event condition and event link condition as various event condition

Table 6-30　Maximum number of Events Usable for Event Conditions

Product Name
Event

Event link Break Trace Snap
shot Stub Timer DMM

Execution Access

SM78Kx 64 16 64 64 8 1 8 -
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Opening

This window can be opened as follows:

• Click the Mgr button.

• Select [Event] -> [Event Manager] from the menu bar   
 (or press Alt+N, and M in that order).  

In the Source window 

Move the cursor to the source line in the source text display area where an event is set, or to the

disassemble line in the mixed display mode. 

• Select [View] -> [Event?] from the menu bar 
 (or press Alt+V, and E in that order).

In the Assemble window 

Move the cursor to the line in the mnemonic display/change area where an event is set.

• Select [View] -> [Event?] from the menu bar 
 (or press Alt+V, and E in that order).

In the Event dialog box 

• Click the <Manager> button  
 (or press Alt+G). 

In the Event dialog box

• Click the <Manager> button.  
 (or press Alt+M).  

Explanation of each area  

The Event Manager consists of the following areas:

(1)　Event display area

(2)　Event details display area

(1) Event display area

[When list is displayed] 

The event display area displays the icons (event icons) of the registered event, event link, break event, 
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and trace event, snapshot event, stub event, and timer event conditions.  

An event icon consists of a mark indicating the type of event, and an event name.  

By selecting the right click menu -> [Detail], the details can be displayed (refer to "Event details display 

area (p.258)").  

The meaning of each mark is as follows:

The color of the character on the mark indicates the set status of the event.  

This area also has the following four functions:

Jump function

If the selected icon is that of an event condition, you can jump to the Source window, Assemble 

window, Memory window, or Coverage window, using an address condition as the jump pointer.  You 

can jump easily by using the right click menu.  

The jump pointer will be as follows, depending on the set address condition.  

Table 6-31　Marks of Event Icon

Mark Meaning

E. Event condition

L. Event link condition

B. Break event condition 

T. Trace event condition 

S. Snapshot event condition

U. Stub event condition

Ti. Timer event condition 

Table 6-32　Color of Character on Mark and its Meaning

Character 
Color Mark Meaning

Red E. L. Indicates that the various event condition using this event condition 
or event link condition is enabled.  

B. T.Ti.US. Indicates that this various event condition is enabled.  
This various event occurs when its condition is satisfied.  

Black E. L. Indicates that this various event condition using this event condition 
or event link condition is disabled.  

B. T.Ti.US. Indicates that this various event condition is disabled.  
This various event does not occur even when its condition is 
satisfied.  

Yellow E. L. Indicates that the symbol specified for this event is held pending 
because it cannot be recognized by the program currently loaded.  

B. T.Ti.US. Indicates that this various event is held pending.  
The various event does not occur even when its condition is 
satisfied.  
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The jump destination window will be displayed from the jump pointer.  

Open function

Opens the event setting dialog box corresponding to the selected event condition.  Each setting dialog 

box displays the contents of the selected event condition.  

Operation

•  Double-click the icon, or click the <Open> button with selecting the icon.  

Enable/disable status switch function

Enables/disables events corresponding to the selected icon.  

The break, trace, snapshot, stub, and timer events (but not the event and event link conditions) can be 

manipulated via their icons.  

Operation

1 Click on the mark of the icon using the left mouse button.

2 Click the <Enable> or <Disable> button.  

If the event was enabled, it is disabled (black). If the event was disabled, it is enabled (red). The 

<Enable> button is displayed when an icon that has been disabled is selected. The <Disable> button is 

displayed when an icon that has been enabled is selected.  

Deletion function

The registered event and set contents of the selected icon can be deleted.  

Operation

1 Select an icon.  Two or more icons can be selected by using Shift and Ctrl keys.  To select all the

icons, select [View] -> [Select All] from the menu bar.  

2 Click the <Delete> button or press the DEL key.  

Caution: An event condition or event link condition can be deleted only when it is not being

used for another event condition.  If it is being used for another event, delete the event

that is using the event condition or event link condition, and then delete the event

condition or event link condition.  

Table 6-33　Address Condition and Jump Pointer

Setting of Address Condition Jump Pointer

Setting as a point  Specified address

Setting as a range  Lower address
(Point address before the mask if a mask is specified)

Setting as a bit  Address at the bit position
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(2) Event details display area

[In detailed display mode]  

This area displays the detailed information corresponding to each event icon.  

This area is displayed only in the detailed display mode.  

Contents are displayed by using the following key information as a separator.  

Table 6-34　Separator for Displaying Event Details

Key Information Contents

Event condition

[S] Status condition

[Z] Access size condition

[A] Address condition 
Symbol or expression: (actual address)

[R] Register condition

[B] Register bank condition (SM78K0, SM78K4 only)

[D] Data condition 
Symbol or expression: (actual address)

[P] Pass count condition

[M] Mask condition 

Event link condition

[P1] - [P4] Event link condition on "n"th line

[D] Disable condition

[P] Pass count condition

Break condition

[B] Break condition

Trace condition 

[M] Trace mode

[T] Delay trigger condition

[S] Trace start condition 

[E] Trace end condition 

[Q] Qualify trace condition

Timer condition
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Functions often used (right-click menu)

In this window, functions that are often used can be selected from the menu that is displayed by clicking

the right mouse button.  In this way, the same function can be used more easily than with the normal

procedure.  

[S] Timer measurement start condition 

[E] Timer measurement end condition

[U] Timer measurement unit

snapshot condition

[SN] Snapshot condition

[R] Register condition

[B] Register bank condition (SM78K0, SM78K4 only)

[M] Memory condition
Symbol or expression: (actual address)

[Z] Access size condition

[F] SFR condition

Stub condition

[SU] Stub condition

[A] Jump address
Symbol or expression: (actual address)

Sort By Name Displays icons in the order of event names.

Sort By Kind Displays icons in the order of event types.

Unsort Does not sort icons (default).

Detail Displays the details.

Overview Displays a list (default).

Source Text Displays the corresponding source text and source line, using the position of the 
selected event as the jump destination address.
If no line information exists at the jump destination address, however, you cannot 
jump.  
Opens the Source window.  
If an active Source window is open, that window is displayed in the forefront (so 
that it can be manipulated).  

Assemble Displays the Assemble window from the position of the selected event, which is 
used as the jump destination address.
Opens the Assemble window.  
If an active Assemble window is open, that window is displayed in the forefront 
(so that it can be manipulated).  

Table 6-34　Separator for Displaying Event Details

Key Information Contents
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Function buttons  

Memory Displays the memory contents from the position of the selected event, which is 
used as the jump destination address.
Opens the Memory window.  
If an active Memory window is open, that window is displayed in the forefront (so 
that it can be manipulated).  

Coverage Displays the coverage measurement result from the position of the selected 
event, which is used as the jump destination address. 
Opens the Coverage window.  
If an active Coverage window is open, that window is displayed in the forefront (so 
that it can be manipulated).  

New... Opens the dialog box to create new event condition.  
By clicking each button, the corresponding event setting dialog box can be 
opened (with the new event name set).  After the event setting dialog box has 
been opened, this dialog box is closed.  

Open Opens the event setting dialog box corresponding to the selected event condition.  
Each setting dialog box displays the contents of the selected event condition.  
This button is invalid if no event condition is selected or if two or more event 
conditions are selected.  
The Enter key performs the same operation.  

Enable/
Disable

Enables or disables the selected various event condition (except event conditions 
and event link conditions).  
This button is invalid if an enabled/disabled event condition is not selected.  

Delete Deletes the selected event condition.  
When an event condition or an event link condition is to be deleted, an error 
occurs and the event condition or event link condition cannot be deleted if the 
event is used as a various event condition.  
This button is invalid if no event condition is selected.  

Delete All Deletes all event conditions.

Info... Opens the Select Display Information dialog box.  
This dialog box is used to change the display mode and rearrange event names.  

Sort by 
Name

Sorts events into name order.  

Sort by Kind Sorts events into type order.

Unsort Displays events in the order in which they have been registered without sorting 
the events.  

Detail Sets the detailed display mode.

Overview Sets the list display mode.

Cancel Closes this dialog box (same as ESC key).

Close Closes this window.
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Related operations

To save/restore event information

Use this window as the current window, and open the Environment File Save dialog box by selecting 

[File] -> [Environment] -> [Save As...] from the menu bar.  

To restore the set status of an event, open the Environment File Load dialog box by clicking the Open 

button.  By loading an event setting file (*.evn), the previously set event information can be restored.  

To enable/disable an event

An event can be enabled or disabled by clicking the mark of the event to be changed. By clicking 

Enable (red), the event is disabled (black); by clicking Disable (black), the event is enabled (red).

This change can be also performed on the Event Manager or in each event setting dialog box.  

To change the display sequence of event icons 

Select the right-click menu -> [Sort B Name/Sort By Kind/Unsort] on the Event Manager.  

To display details of event condition

Select the right-click menu -> [Detail] on the Event Manager.  

By selecting [Overview], the list can be displayed again.  

To delete an event 

Select the icon of the event to be deleted, and click the <Delete> button.  

Caution: An event condition or event link condition cannot be deleted if it is being used for an

event.  Delete the event first, and then delete the event condition or event link

condition.  

To create an event condition

Create an event condition in the Event dialog box, which can be opened by clicking the Evn button.  In 

addition, an event condition that is created when a hardware break is set in the source can also be 

used (refer to "Breakpoint setting/deletion function (p.134)").  

To create an event link condition

Create an event link condition in the Event Link dialog box, which can be opened by selecting [Event] -

> [Event Link] from the menu bar.  

To set an event condition and event link condition as various event condition

Set an event condition or event link condition as a various event condition in the Break dialog box, 

Trace dialog box, Snap Shot dialog box, Stub dialog box, or Timer dialog box, which can be opened by 

clicking the corresponding button, such as <Break...> and <Trace...> in the Event dialog box or Event 

Link dialog box.  

By dragging and dropping the event condition to be set from the Event Manager area at the lower part 

of the screen to the condition setting area on each event setting dialog box, the event condition can be 

easily set.  
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Each event setting dialog box can also be opened by selecting from the [Event] menu.  
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Event dialog box

Registers and displays event conditions.

An event condition registered in this dialog box will be automatically registered to the Event Manager.  

As an event condition, one event can be set for two or more event conditions (break, trace, snapshot,

timer, stub, and event link).  

Up to 256 event conditions can be registered.  However, the number of event conditions that can be

simultaneously used is limited (refer to "Table 6-30  Maximum number of Events Usable for Event

Conditions (p.254)"). 

Caution: Event conditions used for break , snapshot and stub cannot be used for trace and timer,

including those that are used via event link.  Similarly, the event conditions used for

trace and timer cannot be used for break , snapshot and stub, including those that are

used via event link.

An event condition for which an address range is specified internally uses two event

conditions.  Therefore, the number of event conditions that can be used decreases by

the number of event conditions for which an address range is specified. 

Figure 6-55　  Event Dialog Box
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[SM78K0, SM78K4; When Register Write, Register Selected]

This section explains the following items:  

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:  

In normal mode  

If the Event dialog box is opened as follows, an event condition can be registered without its purpose 

being specified.  

•  Click the Evn button.  

•  Select [Event] -> [Event...] from the menu bar   
 (or press Alt+N, and E in that order).  

In select mode  

If the <OK> button is pressed when the Event dialog box has been opened as follows, an event 

condition can be registered in the setting dialog box from which this dialog box was opened.  

•  In each event setting dialog box  
Click the <Add Event> button.  
 (or press Alt and E in that order).  
In the select mode, the setting dialog box from which the Event dialog box was opened is displayed
on the title bar.  
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Explanation of each area  

The Event dialog box consists of the following areas:  

(1)　Event Name (event name setting area)

(2)　Event Status (status selection area)

(3)　Access Size (access size selection area)

(4)　Address, Mask (address setting area)

(5)　Register Name, Register Bank (register setting area) (When Register Write, Register selected)

(6)　Data, Mask (data setting area)

(7)　Pass Count (pass count setting area)

(8)　Event Manager (event manager area)

(1) Event Name (event name setting area)

This area is used to set a event name.  

Directly input an alphanumeric string of up to eight characters as a name.  

To display the contents of an already created event condition, select from the drop-down list.  

In the select mode, the selected event condition can be set in the event condition setting area of the 

setting dialog box that called the Event dialog box.  

The mark on the left of this area indicates the utilization status of events (refer to "Table 6-32  Color of 

Character on Mark and its Meaning (p.256)").  The gray E. mark indicates that the event condition is 

being edited and has not been registered yet.  

(2) Event Status (status selection area)

This area is used to select a status condition.  

By specifying a status condition, the type of the execution event and an access event is determined (if 

an execution event is specified, nothing can be input to the Access Size, Address Mask, and Data 

areas).  

The status conditions that can be specified are listed below.  A status condition can also be specified in 

abbreviated form.  

Uppercase and lowercase characters are not distinguished in the input status condition.  

Table 6-35　 List of Status Conditions  

<Execution event>

Status Abbreviation Meaning

Execution EX Program execution
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Note: The event condition of Register or Memory status can be used for Phase1 of the event link. It 
cannot be used except for Phase1 of break, trace, snapshot, stub, timer, or event link. These 
statuses can be used as events of AND condition by being set to Phase1 of event link. Events 
of AND condition are functions generate events when event conditions set to Phase1 of event 
link are activated simultaneously. Then event conditions of Execution status can be combined. 
In case just an event condition of Register or Memory status is set to Phase1 of event link, 
event conditions of Register status are the same operation as Register Write and those of 
Memory status are the same operation as Write. 

(3) Access Size (access size selection area)

This area is used to set and select an access size condition.  

By specifying an access size condition, the access width of a data condition to be detected by an 

access event is determined.  

The access size conditions that can be specified are listed below.  An access size condition can also 

be specified in abbreviated form.  Uppercase and lowercase characters are not distinguished in the 

input access size condition.  

<Access event>

Status Abbreviation Meaning

Opcode Fetch OP Opcode fetch (including prefetch)

R/W RW Memory read/write

Read R Memory read

Write W Memory write

R/W by Macro RWM Memory read/write via macro service (SM78K4 only)

Read by Macro RM Memory read via macro service (SM78K4 only)

Write by Macro WM Memory write via macro service (SM78K4 only)

R/W by Program RWP Memory read/write via program (SM78K4 only)

Read by Program RP Memory read via program (SM78K4 only)

Write by Program WP Memory write via program (SM78K4 only)

Vector Read VECT Vector read via interrupt

Access AC All access statuses

Register Write REGW Register write

Register REG RegisterNote

Memory MEM MemoryNote
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Caution: If operation code fetch or vector read access event is specified as the status condition,

no bit selection alternatives are displayed. Also, an error is output even if "Bit" or "1" is

specified.

Because of the operation of the device, all the 8 bits are read or written when writing bits, but if Read or 

R/W is specified as the status condition, an event occurs for this read operation if the address and bit 

match the specified value of [address.bit].

If no access size is specified, judgment is automatically made from the address condition and data 

condition, and the following is set:  

•  Bit if the address condition is set in bit units  

•  Byte if the address condition is set in 8-bit units  

•  Word if the address condition is set in 32-bit units  

•  No Condition if no data condition is specified

(4) Address, Mask (address setting area)  

Table 6-36　List of Access Size Conditions (Event)  

Size Abbreviation Meaning

Byte B Detects data condition with 8-bit width (only during 8-bit access).  

Word W Detects data condition with 32-bit width (only during 32-bit 
access).  

No Condition NC Does not detect access size (nothing can be input to the Data 
area).  

Bit 1 Detects data condition with 1-bit width (only during 8-bit access).  
In this case, a data condition is detected with 1-bit width.  
Because of the operation of the simulator, access to a bit is not 
directly detected; the simulator detects a dummy bit access by 
internally setting address conditions and data conditions as 
follows:  

Input example:
Address: fe20  
Data: 1  

Setting to simulator)  
Address: fe20
Data: 00000010B
Mask: 11111101B

If another bit of the same address is accessed or if all the 8 bits 
of the same address are accessed, therefore, an event is 
detected in accordance with the specified status if the address 
and bit match the specified value of [address.bit].  
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Address, which sets the address value, and Mask, which sets the mask value of the address value, are 

set as the address conditions.

Both the Address and the Mask settings may be omitted. 

An address can be also specified by a symbol or expression (refer to "Table 6-15  Specifying Symbols 

(p.130)").  The default radix for inputting a numeric value is hexadecimal.  

Settable range

[SM78K0]

(When not using bank)

0 =< address value =< 0xFFFF

0 =< mask value =< 0xFFFF

(When using bank)

0 =< address value =< (n<<16) | 0xFFFF

0 =< mask value =< (n<<16) | 0xFFFF

[SM78K0S]

0 =< address value =< 0xFFFF

0 =< mask value =< 0xFFFF

[SM78K4]

(Execution type event)

0 =< address value =< 0xFFFFF

0 =< mask value =< 0xFFFFF

(Access type event)

0 =< address value =< 0xFFFFFF

0 =< mask value =< 0xFFFFFF

Address

Set an address condition (lower address - higher address).  

The following can be set:  

Mask

Set a mask value for the address value.  

When a mask is set, the data value for the bit whose mask value is 1 may be 0 or 1.  

The data value for a bit whose mask value is 1 may be 0 or 1.  

Set Point Set a value to only the lower address, or set the same value to the lower 
address and the higher address.Mask can be set.  

Set Range Set a value to the lower address and the higher address.  
Mask cannot be set.

Set Bit Set a value to only the lower address, or set the same value to the lower 
address and the higher address.  Specify a value in the form of 
address.bit.  
Mask cannot be set.  
The value of bit, which indicates the bit position, must be 0 =<bit =<7.  
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Example 1:

With this setting, addresses 0x4000 to 0x40FF satisfy the condition.  

Example 2:

With this setting, addresses 0x4000, 0x4001, 0x4100, and 0x4101 satisfy the condition.  

(5) Register Name, Register Bank (register setting area) (When Register Write, Register selected)

If Register Write (REGW) or Register (REG) is selected in Event Status (status selection area) , 

Address, Mask (address setting area) changes to this area.  

In the case of SM78K0, SM78K4, there are two types of register conditions, Register for setting 

registers, and Bank for setting register banks. In the case of the SM78K0S, there is only Register.

Register Name

Sets the register name. Either input the register name directly in the text box, or select it from the drop-

down list.  

Either a single or a pair of general-purpose registers can be specified. Also, the function name and 

absolute name can both be specified. 

To specify all registers, either select All from the drop-down list or specify all registers directly in the 

text box. 

Uppercase and lowercase are not distinguished for input characters.

Register Bank (SM78K0, SM78K4 only)

Sets the register bank. Either input the register name directly in the text box, or select it from the drop-

down list.  

Settable range

[SM78K0]

0 =< register bank =< 3

[SM78K4]

0 =< register bank =< 7

To specify the current bank, either select "Current" from the drop-down list, or type "Current" or "C" 

directly in the text box. If the register bank specification is omitted, the current bank will be specified.

For newly created event conditions, the register name and register bank input columns are both blank.

Address 0x4000-0x4000

Mask 0xFF

Address 0x4000-0x4000

Mask 0x101
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(6) Data, Mask (data setting area)

Data, which sets an data value, and Mask, which sets the mask value of an data value, are set as data 

conditions.  

The default radix for inputting a numeric value is hexadecimal.  

Both the data and mask may be omitted.  

The setting range is as follows.

Data

Set a data value.  Specify a value within the settable range.  

A symbol or expression can be also specified by a symbol or expression (refer to "Table 6-15  

Specifying Symbols (p.130)").  

Mask

Set a mask value for the data value.

When a mask is set, the data value for the bit whose mask value is 1 may be 0 or 1.  

The data value for a bit whose mask value is 1 may be 0 or 1.  

Example 1:

With this setting, addresses 0x40 to 0x4F satisfy the condition.  

(7) Pass Count (pass count setting area)  

The pass count condition is set in this area (settable range: 1 to 32767).  

Pass Count is an area that specifies the number of times that an event condition must be satisfied in 

order to satisfy a condition during user program execution.

If 1 is specified, the condition is satisfied when the event condition is satisfied.

Omitting this setting means 1 is specified.

Table 6-37　Settable Range of Data Condition  

Access Size Settable range

Byte 0 =< data value =< 0xFF  
0 =< mask value =< 0xFF  

Data 0x40

Mask 0x0F
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(8) Event Manager (event manager area)  

This area displays a list of event link, break, trace, snap shot, stub, timer and other registered events.  

In this area, the following operations can be performed.  

Displaying set contents  

Select an event and click the <Open> button or double-click the event.  The setting dialog box 

corresponding to the selected event will be opened and the set contents of the event will be displayed.  

Delete

A selected event can be deleted by selecting the icon of the event and clicking the <Delete> button or 

pressing the DEL key while focussing on the event manager area.

Changing display mode and sorting  

The display mode of and sorting in the event manager area can be selected by clicking the <Info...> 

button.  

Function buttons  

Setting-related buttons  

OK Automatically registers the event condition being edited, if any, and closes this 
dialog box.  
In the select mode  
An event condition is selected and the setting dialog box (indicated on the title 
bar) that called the Event dialog box is displayed again.  If the calling dialog box 
has already been closed, the select mode is returned to the normal mode, and 
the Event dialog box is not closed.  Otherwise, this dialog box will be closed.  

New Newly creates an event condition in this dialog box.  
An event name is automatically created and a new event condition is prepared.  

Set
(when a new 
event is created 
or an event is 
changed)  

Registers each event condition.  Because the dialog box is not closed even 
after an event has been registered, new event conditions can be registered.  
In the select mode  
An event condition is selected.  If there is an event being edited, it is 
automatically registered and selected.  

Clear
(when an event is 
not edited)  

Clears the contents of the event condition.  
This button is displayed when an event condition has not been edited.  
This button and the <Restore> button are alternately displayed.  

Restore
(when an event is 
edited)  

Restores the contents of an edited event condition.  
If an event condition not registered is displayed, all the fields other than the 
event name field are blank or the default values are set.  
This button and the <Clear> button are alternately displayed.  
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Cancel
Close

Closes this dialog box.  
Even if an event condition is being edited, it is not registered and the dialog box 
is closed.  
<Cancel> is displayed if a condition is not created, changed, or deleted; 
<Close> is displayed if it is.  

Help Opens the Help window.  

Buttons for opening each event setting dialog box

Event Link... Opens the Event Link dialog box.  

Break... Opens the Break dialog box.  

Trace... Opens the Trace dialog box.  

Snap Shot... Opens the Snap Shot dialog box.

Stub... Opens the Stub dialog box.

Timer... Opens the Timer dialog box.  

Manager Opens the Event Manager.  

Buttons in event manager area

Shrink <<<
(When area is 
displayed)

Turns off display of the event manager area.  
At this time, the size of the dialog box is reduced.  

Expand >>>
(When area is not 
displayed)

Displays the event manager area.  
At this time, the size of the dialog box is expanded.  

Open
(When only one 
event is selected)  

Opens the event setting dialog box corresponding to the selected event 
condition.  Each setting dialog box displays the contents of the selected event 
condition.  
The Enter key performs the same operation.  

Remove
(When event is 
selected)

Deletes the selected event condition.  
When an event condition or an event link condition is to be deleted, an error 
occurs and the event condition or event link condition cannot be deleted if the 
event is used as an event condition.  

Info... Opens the Select Display Information dialog box.  
This dialog box is used to change the display mode and rearrange event 
names.  

Sort by Name Sorts events into type order.  

Sort by Kind Sorts events into type order.

Unsort Displays events in the order in which they have been registered without sorting 
the events.  

Detail Sets the detailed display mode.

Overview Sets the list display mode.。

Cancel Closes this dialog box (same as ESC key).
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Event Link dialog box

This dialog box is used to register and display event link conditions.  

A event link condition registered in this dialog box will be automatically registered to the Event Manager.  

An event link condition is an event condition that is generated only if the user program is executed in the

sequence specified by a set event condition.  

Up to four sequences can be specified.However, if a disable condition is detected in the middle of the

sequence, the satisfied event conditions up to that time are initialized, and detection will start from the first

event condition.  Note that if an event link condition and a disable condition are detected at the same time,

the disable condition has priority.

An event link condition can be used for multiple various event conditions.  The following various event

conditions can use event link conditions:  

Up to 256 event link conditions can be registered.  However, the number of event link conditions that can

be simultaneously used (valid) is limited (refer to "Table 6-30  Maximum number of Events Usable for Event

Conditions (p.254)").  The maximum number of event link conditions simultaneously usable includes the

valid event link conditions used for break, trace, snapshot , and stub event condition.

Figure 6-56　Event Link Dialog Box

Table 6-38　Various Event Conditions for Which Event Link Condition Can Be Use

Product name

Break 
condition

(execution 
break only)

Trace 
condition

Snapshot 
condition

Stub 
condition

Timer 
condition

SM78Kx OK OK OK OK OK
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This section explains the following items:  

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:  

In normal mode  

If the Event Link dialog box is opened as follows, an event link condition can be registered without its 

purpose being specified.  

•  Select [Event] -> [Event Link...] from the menu bar   
 (or press Alt+N, and L in that order).  

In select mode  

If the <OK> button is pressed when the Event Link dialog box has been opened as follows, an event 

link condition can be registered in the setting dialog box from which this dialog box was opened.  

•  In each various event setting dialog box  
Click the <Add Link...> button.  
 (or press Alt+L, and L in that order).
In the select mode, the setting dialog box from which the Event Link dialog box was opened is
displayed on the title bar.  

Explanation of each area  

The Event Link dialog box consists of the following areas:

(1)　 Link Name (event link name setting area)

(2)　Phase1, Phase2, Phase3, Phase4 (link condition setting area)

(3)　Disable (disable condition setting area)

(4)　Pass Count (pass count setting area)

(5)　Event Manager (event manager area)

(1) Link Name (event link name setting area)

This area is used to set a event link name.  

Directly input an alphanumeric string of up to eight characters as a name.  

To display the contents of an already created event link condition, select from the drop-down list.  

In the select mode, the selected event condition can be set in the event kink condition setting area of 

the setting dialog box that called the Event Link dialog box.  

The mark on the left of this area indicates the utilization status of event link condition (refer to "Table 6-
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32  Color of Character on Mark and its Meaning (p.256)").  The mark "L" in gray indicates that an event 

link condition is being edited and has not been registered yet.  

(2) Phase1, Phase2, Phase3, Phase4 (link condition setting area)

This area is used to specify the sequence in which event conditions and events are detected.  

Set Phase 1 -> Phase 2 -> Phase 3 -> Phase 4, in that order.  Phase 4 does not have to be set.  

in this case, an event occurs when the event condition set for the last phase has been detected.  An 

event condition can be set for only Phase 1 or the same event condition can be set for two or more 

Phases.  

When setting a Register (REG) or Memory (MEM) status event condition in Phase 1, it becomes an 

AND condition event.  The AND condition event sets one or more of either the Register status or the 

Memory status event conditions in Phase 1.  At this time, it is possible to combine with the Execution 

(EX) status event conditions.  The event occurs at the point when the event conditions set in Phase 1 

are established simultaneously.  Register and Memory status event conditions cannot be set except in 

Phase 1.

The number of event conditions that can be set for each Phase in this area is up to 10.  However, the 

total number of event conditions settable in this area, including those set in the Disable area, is 22 (14 

execution events* and eight access events)64.

Setting event condition in each area

Select an event condition in the Event Manager area, and click the <Add> button or drag and drop an 

event condition.  An event link condition can also be set by dragging and dropping not only in this 

dialog box, but also in the Event Manager area of each various event setting dialog box or the Event 

Manager.  

In addition, the Event dialog box can be opened in "select mode" by clicking the <Add Event...> button, 

and the event condition to be set can be selected.  

In the event condition setting area in this dialog box, an event condition can be alternately copied or 

moved by dragging and dropping.  

•  If an event condition is dropped only by the mouse, it is moved.  

•  If an event condition is dropped with the Shift key held down, it is moved.  

•  If an event condition is dropped with the Ctrl key held down, it is copied.  
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(3) Disable (disable condition setting area)

This area is used to set an event condition that invalidates the event conditions that have so far been 

satisfied (refer to "Setting event condition in each area").  

The number of event conditions that can be set in this area is up to 10.

(4) Pass Count (pass count setting area)

This area is used to set a pass count condition (settable range: 1 to 32767).  

A pass count condition specifies how many times an event condition must be satisfied during user 

program execution before a given condition is satisfied.  

If the pass count is set to 1, the condition is satisfied as soon as the event condition is satisfied.  

If no pass count is specified, 1 is assumed.

(5) Event Manager (event manager area)  

This area displays a list of event link, break, trace , snap shot, stub, timer and other registered various 

event conditions.  

For details, refer to "Event Manager (event manager area) (p.271)".  

Function buttons  

Setting-related buttons  

OK Automatically registers the event condition being edited, if any, and closes this 
dialog box.  
In the select mode  
An event condition is selected and the setting dialog box (indicated on the title 
bar) that called the Event Link dialog box is displayed again.  If the calling 
dialog box has already been closed, the select mode is returned to the normal 
mode, and the Event dialog box is not closed.  Otherwise, this dialog box will be 
closed.  
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New Newly creates an event link condition in this dialog box.  
An event link condition name is automatically created and a new event link 
condition is prepared.  

Set
(when a new 
event link is 
created or an 
event link is 
changed)  

Registers the various event condition.  Because the dialog box is not closed 
even after an event has been registered, new event link conditions can be 
registered.  
In the select mode  
An event condition is selected.  If there is an event being edited, it is 
automatically registered and selected.  

Clear
(when an event is 
not edited)  

Clears the contents of the event link condition.  
This button is displayed when an event link condition has not been edited.  
This button and the <Restore> button are alternately displayed.  

Restore
(when an event is 
edited)  

Restores the contents of an edited event link condition.  
If an event link condition not registered is displayed, all the fields other than the 
event name field are blank or the default values are set.  
This button and the <Clear> button are alternately displayed.  

Cancel
Close

Closes this dialog box.  
Even if an event link condition is being edited, it is not registered and the dialog 
box is closed.  
<Cancel> is displayed if a condition is not created, changed, or deleted; 
<Close> is displayed if it is.  

Help Opens the Help window.  

Buttons for opening each event setting dialog box

Add Event... Opens the Event dialog box in the select mode, and selects or newly creates an 
event condition to be set.  The event condition will be added to the area 
selected when the < Add Event...> button is pressed.  

Other... Opens the dialog box for selecting the event type.  
By pressing each of the above buttons, each event setting dialog box can be 
opened in the new creation status.  

Buttons in event manager area

Shrink <<<
(When area is 
displayed)

Turns off display of the event manager area.  
At this time, the size of the dialog box is reduced.  

Expand >>>
(When area is not 
displayed)

Displays the event manager area.  
At this time, the size of the dialog box is expanded.  

Open
(When only one 
event is selected)  

Opens the event setting dialog box corresponding to the selected event 
condition.  Each setting dialog box displays the contents of the selected event 
condition.  
The Enter key performs the same operation.  

Remove
(When event is 
selected)

Deletes the selected event condition.  
When an event condition or an event link condition is to be deleted, an error 
occurs and the event condition or event link condition cannot be deleted if the 
event is used as a various event condition.  

Info... Opens the Select Display Information dialog box.  
This dialog box is used to change the display mode and rearrange event 
names.  
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Sort by Name Sorts events into type order.  

Sort by Kind Sorts events into type order.

Unsort Displays events in the order in which they have been registered without sorting 
the events.  

Detail Sets the detailed display mode.

Overview Sets the list display mode.

Cancel Closes this dialog box (same as ESC key).
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Break dialog box

This dialog box is used to register, set, and display break event conditions.  

A break event condition registered in this dialog box will be automatically registered to the Event

Manager.  

A break event condition automatically becomes valid when it has been registered.  

Up to 256 break event conditions can be registered.  However, the number of break event conditions that

can be simultaneously used is limited (refer to "Table 6-30  Maximum number of Events Usable for Event

Conditions (p.254)").  If the maximum number of break event conditions that can be used at the same time

is exceeded or if the number of event conditions or event link conditions used exceeds the maximum limit,

therefore, register a break event condition in the disabled state.  

If [Run] -> [Ignore Break Point] is selected from the menu bar, a break event condition does not operate

even if it is valid.  

Figure 6-57　Break Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:  

• Click the Brk button.  
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• Select [Event] -> [Break...] from the menu bar   
 (or press Alt+N, and B in that order).

Explanation of each area  

The Break dialog box consists of the following areas:

(1)　Break Name (break event name setting area)

(2)　Break Event (break condition setting area)

(3)　Event Manager (event manager area)

(1) Break Name (break event name setting area)  

This area is used to set a break event name.  

Directly input an alphanumeric string of up to eight characters as a name.  

To display the contents of an already created event condition, select from the drop-down list.  

The mark on the left of this area indicates the utilization status of events (refer to "Table 6-32  Color of 

Character on Mark and its Meaning (p.256)").  The gray mark indicates that an event condition is being 

edited and has not been registered yet.  

By clicking the left mark, an event condition can be validated or invalidated.  

(2) Break Event (break condition setting area)  

This area is used to set an event condition for break.  

The number of event conditions that can be set in this area, combining execution events and access 

events, is as follows:  

The number of event link conditions is up to the maximum number of events that can be used for 

various event conditions, as long as the used event conditions do not exceed the number that can be 

simultaneously used. 

Setting event condition and event link condition in each area

Select an event condition or event link condition in the Event Manager area, and click the <Add> 

Table 6-39　Number of Events Settable in Break Condition Setting Area

Product Name Total (execution/access)

SM78Kx 64
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button or drag and drop an event condition or event link condition.  An event condition or event link 

condition can also be set by dragging and dropping not only in this dialog box, but also in the Event 

Manager area of each event setting dialog box and from the Event Manager.  

In addition, Event dialog box or Event Link dialog box can be opened in "select mode" by clicking the 

<Add Event...> or <Add Link...> button, and the event condition or event link condition to be set can be 

selected.  

In the event condition setting area in this dialog box, an event condition can be alternately copied or 

moved by dragging and dropping.  

•  If an event condition is dropped only by the mouse, it is moved.  

•  If an event condition is dropped with the Shift key held down, it is moved.  

•  If an event condition is dropped with the Ctrl key held down, it is copied.  

(3) Event Manager (event manager area)

This area displays a list of event link, break, trace, snap shot, stub, timer and other registered events.  

For details, refer to "Event Manager (event manager area) (P271)".

Function buttons

Setting-related buttons

OK Automatically registers the event condition being edited, if any, and closes this 
dialog box.  The event condition becomes valid as soon as it has been 
registered.  

New Newly creates an event condition in this dialog box.  
An event name is automatically created and a new event condition is prepared.  

Set
(when a new 
event is created 
or an event is 
changed)  

Registers each event condition. Because the dialog box is not closed even after 
an event has been registered, new event conditions can be registered.  Each 
event condition becomes valid as soon as it has been registered.  
If an already registered event condition is displayed, the <Enable> or <Disable> 
button is alternately displayed.  

Enable/Disable  
(when a 
registered event is 
displayed)  

Validates (enables) or invalidates (disables) the selected event condition.  
However, event conditions and event link conditions cannot be enabled or 
disabled.  
This button and the <Set> button are alternately displayed.  

Clear
(when an event is 
not edited)  

Clears the contents of the event condition.  
This button is displayed when an event condition has not been edited.  
This button and the <Restore> button are alternately displayed.  
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Restore
(when an event is 
edited)  

Restores the contents of an edited event condition.  
If an event condition not registered is displayed, all the fields other than the 
event name field are blank or the default values are set.  
This button and the <Clear> button are alternately displayed.  

Cancel
Close  

Closes this dialog box.  
Even if an event condition is being edited, it is not registered and the dialog box 
is closed.  
<Cancel> is displayed if a condition is not created, changed, or deleted; 
<Close> is displayed if it is.  

Help Opens the Help window.  

Buttons for opening each event setting dialog box

Add Event... Opens the Event dialog box in the select mode, and selects or newly creates an 
event condition to be set.  The event condition will be added to the area 
selected when the < Add Event...> button is pressed.  

Add Link... Opens the Event Link dialog box in the select mode, and selects or newly 
creates an event link condition.  The event link condition will be added to the 
area selected when the <Add Link...> button is pressed.  

Other... Opens the Select Event Type dialog box.  
By pressing each of the above buttons, each event setting dialog box can be 
opened in the new creation status.  

Buttons in event manager area

Shrink <<<
(When area is 
displayed)

Turns off display of the event manager area.  
At this time, the size of the dialog box is reduced.  

Expand >>>
(When area is not 
displayed)

Displays the event manager area.  
At this time, the size of the dialog box is expanded.  

Open
(When only one 
event is selected)  

Opens the event setting dialog box corresponding to the selected event 
condition.  Each setting dialog box displays the contents of the selected event 
condition.  
The Enter key performs the same operation.  

Remove
(When event is 
selected)

Deletes the selected event condition.  
When an event condition or an event link condition is to be deleted, an error 
occurs and the event condition or event link condition cannot be deleted if the 
event is used as an event condition.  

Info... Opens the Select Display Information dialog box.  
This dialog box is used to change the display mode and rearrange event 
names.  

Sort by Name Sorts events into name order.  

Sort by Name Sorts events into type order.  

Unsort Displays events in the order in which they have been registered without sorting 
the events.  

Detail Sets the detailed display mode.

Overview Sets the list display mode.

Cancel Closes this dialog box (same as ESC key).
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Trace dialog box

This dialog box is used to register, set, and display trace event conditions.  

In this dialog box, the following types of trace event conditions can be set: 

• Event condition for delay trigger

• Event condition for starting section trace

• Event condition for ending section trace

• Event condition for qualify trace

To use the above trace event conditions, select [Run] -> [Cond. Trace ON] from the menu bar.  

A trace event condition registered in this dialog box will be automatically registered to the Event Manager.  

A trace event condition automatically becomes valid when it has been registered.  

Up to 256 trace event conditions can be registered.  However, the number of trace event conditions that

can be simultaneously used is only 64 (refer to "Table 6-30  Maximum number of Events Usable for Event

Conditions (p.254)").  

If the maximum number of trace event conditions that can be used at the same time is exceeded or if the

number of event conditions or event link conditions used exceeds the maximum limit, therefore, register a

trace event condition in the disabled state.  

Figure 6-58　Trace Dialog Box

This section explains the following items:  

• Opening

• Explanation of each area

• Function buttons

• Related operations
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•  To set delay count

Opening

This dialog box can be opened as follows:  

• Click the Trc button.

• Select [Event] -> [Trace...] from the menu bar   
 (or press Alt+N, and T in that order).  

• Click the <Trace> button in the Event dialog box
 (or press Alt+T in that order).  

Explanation of each area  

The Trace dialog box consists of the following areas:

(1)　Trace Name (trace event name setting area)

(2)　Delay Trigger (delay trigger condition setting area)

(3)　Section Start, Section End (section trace range condition setting area)

(4)　Qualify (qualify trace condition setting area)

(5)　Event Manager (event manager area)

(1) Trace Name (trace event name setting area)

This area is used to set a trace event name.  

Directly input an alphanumeric string of up to eight characters as a name.  

To display the contents of an already created event condition, select from the drop-down list.  

The mark on the left of this area indicates the utilization status of events (refer to "Table 6-32  Color of 

Character on Mark and its Meaning (p.256)").  The gray mark indicates that an event condition is being 

edited and has not been registered yet.  

By clicking the left mark, an event condition can be validated or invalidated.  

(2) Delay Trigger (delay trigger condition setting area)

This area is used to set an event condition for a delay trigger.

To set a delay count, use Delay Count dialog box that can be opened by selecting [Event] -> [Delay 

Count...] from the menu bar.  

The number of event conditions that can be set in this area, combining execution events and access 
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events, is as follows:  

The number of event link conditions explained in Maximum number of Events Usable for Event 

Conditions can be used as long as the number of event conditions does not exceed the maximum 

number of event conditions simultaneously usable.

  To set an event condition, drag the icon of the event to be set from the Event Manager area, and drop 

it in this area.  For details, refer to "Setting event condition and event link condition in each area".  

(3) Section Start, Section End (section trace range condition setting area) 

This area is used to set event conditions for starting and stopping a section trace. 

By setting a trace start event condition as Section Start and a trace end event condition as Section 

End, a section trace (zone trace) can be performed.  

The number of event conditions that can be set in this area, combining execution events and access 

events, is as follows: 

The number of event link conditions explained in Maximum number of Events Usable for Event 

Conditions can be used as long as the number of event conditions does not exceed the maximum 

number of event conditions simultaneously usable.

To set an event condition, drag the icon of the event to be set from the Event Manager area, and drop 

it in this area.  For details, refer to "Setting event condition and event link condition in each area 

(p.280)".  

(4) Qualify (qualify trace condition setting area)

This area is used to set an event condition for a qualify trace.

In a qualify trace, a trace is performed only when a trace condition is satisfied.  

If two or more events are set, trace is performed when each event occurs.

Product NameIE Using Total (execution/access)

SM78Kx 64

Product Name Total (execution/access)

SM78Kx 64
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The number of event conditions that can be set in this area, combining execution events and access 

events, is as follows:  

The number of event link conditions explained in Maximum number of Events Usable for Event 

Conditions can be used as long as the number of event conditions does not exceed the maximum 

number of event conditions simultaneously usable.  

Note that an event link condition cannot be set.

To set an event condition, drag the icon of the event to be set from the Event Manager area, and drop 

it in this area.  For details, refer to "Setting event condition and event link condition in each area 

(p.280)".  

(5) Event Manager (event manager area)  

This area displays a list of event link, break, trace, snap shot, stub, timer  and other registered various 

event conditions.  

For details, refer to "Event Manager (event manager area) (p.271)".  

Function buttons  

Product Name Total (execution/access)

SM78Kx 64

Setting-related buttons  

OK Automatically registers the event condition being edited, if any, and closes this 
dialog box.  The event condition becomes valid as soon as it has been 
registered.  

New Newly creates an event condition in this dialog box.  
An event condition name is automatically created and a new event condition is 
prepared.  

Set
(when a new 
event link is 
created or an 
event link is 
changed)  

Registers the various event condition.  Because the dialog box is not closed 
even after an event has been registered, new event conditions can be 
registered.  Each event condition becomes valid as soon as it has been 
registered.  
If an already registered event condition is displayed, the <Enable> or <Disable> 
button is alternately displayed.  
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Enable/Disable  
(when a 
registered event is 
displayed)  

Validates (enables) or invalidates (disables) the selected event condition.  
However, event conditions and event link conditions cannot be enabled or 
disabled.  
This button and the <Set> button are alternately displayed.  

Clear
(when an event is 
not edited)  

Clears the contents of the event condition.  
This button is displayed when an event condition has not been edited.  
This button and the <Restore> button are alternately displayed.  

Restore
(when an event is 
edited)  

Restores the contents of an edited event condition.  
If an event condition not registered is displayed, all the fields other than the 
event name field are blank or the default values are set.  
This button and the <Clear> button are alternately displayed.  

Cancel
Close

Closes this dialog box.  
Even if an event condition is being edited, it is not registered and the dialog box 
is closed.  
<Cancel> is displayed if a condition is not created, changed, or deleted; 
<Close> is displayed if it is.  

Help Opens the Help window.  

Buttons for opening each event setting dialog box

Add Event... Opens the Event dialog box in the select mode, and selects or newly creates an 
event condition to be set.  The event condition will be added to the area 
selected when the < Add Event...> button is pressed.  

Add Link... Opens the Event Link dialog box in the select mode, and selects or newly 
creates an event link condition.  The event link condition will be added to the 
area selected when the <Add Link...> button is pressed.  

Other... Opens the dialog box for selecting the event type.  
By pressing each of the buttons, each various event setting dialog box can be 
opened in the new creation status.  

Buttons in event manager area

Shrink <<<
(When area is 
displayed)

Turns off display of the event manager area.  
At this time, the size of the dialog box is reduced.  

Expand >>>
(When area is not 
displayed)

Displays the event manager area.  
At this time, the size of the dialog box is expanded.  

Open
(When only one 
event is selected)  

Opens the various event setting dialog box corresponding to the selected event 
condition.  Each setting dialog box displays the contents of the selected event 
condition.  
The Enter key performs the same operation.  

Remove
(When event is 
selected)

Deletes the selected event condition.  
When an event condition or an event link condition is to be deleted, an error 
occurs and the event condition or event link condition cannot be deleted if the 
event is used as a various event condition.  

Info... Opens the Select Display Information dialog box.  
This dialog box is used to change the display mode and rearrange event 
names.  
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Related operations

To set delay count

To set a delay count, use Delay Count dialog box, which can be opened by selecting [Event] -> [Delay 

Count...] from the menu bar.  

The set delay count is valid for trace event conditions for which a delay trigger event is set.

Sort by Name Sorts events into type order.  

Sort by Kind Sorts events into type order.

Unsort Displays events in the order in which they have been registered without sorting 
the events.  

Detail Sets the detailed display mode.

Overview Sets the list display mode.。

Cancel Closes this dialog box (same as ESC key).
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Snap Shot dialog box

This dialog box is used to register, set, and display snapshot event conditions.  

A snapshot event condition registered in this dialog box will be automatically registered to the Event

Manager.  

A snapshot event condition automatically becomes valid when it has been registered.  

Up to 256 snapshot event conditions can be registered.  However, the number of snapshot event

conditions that can be simultaneously used is eight (refer to "Table 6-30  Maximum number of Events

Usable for Event Conditions (p.254)").

Therefore, if the number of snapshot events that can be used at the same time is exceeded, or if the

number of used event conditions exceeds the number that can be used at the same time, register a

snapshot event condition in the disabled state.  

Caution: To leave only the snapshot event result in the trace, set a dummy trace event for which

no event occurs and perform a conditional trace.  

Figure 6-59　Snap Shot Dialog Box (with Register Selected)  

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons
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Opening

This dialog box can be opened as follows:  

• Select [Event] -> [Snap Shot...] from the menu bar   
 (or press Alt+N, and S in that order).  

• Click the <Snap Shot...> button in the Event dialog box.  
 (or press Alt and S in that order).

Explanation of each area  

The Snap Shot dialog box consists of the following areas:

(1)　Snap Name (snapshot event name setting area)

(2)　Snap Event (snapshot condition setting area)

(3)　Select (snap data selection area)

(4)　Snap data setting area (When Register is selected, When Sfr is selected, When Memory is 

selected)

(5)　Snap Entry (snap data display area)

(6)　Event Manager (event manager area)

(1) Snap Name (snapshot event name setting area)

This area is used to set a snapshot event name.  

Directly input an alphanumeric string of up to eight characters as a name.  

To display the contents of an already created event condition, select from the drop-down list.  

The mark on the left of this area indicates the utilization status of events (refer to "Table 6-32  Color of 

Character on Mark and its Meaning (p.256)").  The gray mark indicates that an event condition is being 

edited and has not been registered yet.  

Clicking this mark enables/disables the event condition.  

(2) Snap Event (snapshot condition setting area)

This area is used to set an event condition for the snapshot.  

Only one event condition can be set in the snapshot condition setting area.  

To set an event condition or event link condition, drag the icon of the event to be set from the Event 

Manager area, and drop it in this area.  For details, refer to "Setting event condition and event link 

condition in each area (p.280)".



CHAPTER 6  WINDOW REFERENCE

User’s Manual  U16768EJ1V0UM 291

(3) Select (snap data selection area)

This area is used to select type of data subject to snapshot.  

By selecting a data type, the item to be displayed in the snap data setting area on the right of this area 

changes in accordance with the selected area.  

(4) Snap data setting area

This area is used to register, change, or delete snap data.  

The snap data registered, changed, or deleted in this area is reflected in the Snap Entry area.  

If snap data is selected in the Snap Entry area, the contents of the selected snap data are displayed in 

this area.  

As snap data, up to 16 registers, SFR, and memory addresses each can be registered; therefore, a 

total of 48 registers, SFR, and memory addresses can be registered.  

This area displays different items, as follows, depending on the item selected in the Select field.  

When Register is selected

[SM78K0, SM78K4]

[SM78K0S]

Register Name (register name setting area)

This area is used to specify a register name.  

To specify a register name, select a register name from the drop-down list.  

General-purpose registers and control registers can be specified.  Uppercase and lowercase 

Data Type Contents Item in Right Area (Snap Data Setting Area)

Register A register can be registered. Register Name, Register Bank (SM78K0, 
SM78K4 only)

Sfr A SFR can be registered. Sfr Name

Memory Memory can be registered. Memory Address , Memory Display
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characters are not distinguished.  

A register name can be specified as both a function name and an absolute name.  

All the register names are displayed in uppercase in the Trace window, in the form of 'absolute name' 

for the SM78K0 and SM78K0S, 'function name' in the case of the registers (X, A, C, B, AX, BC) 

changed by the Register Set Select flag (RSS) for the SM78K4, and 'absolute name' in all other cases.

To specify all the registers, either select All from the drop-down list, or directly input "All" in the text box.

Register Bank (register bank setting area) (SM78K0, SM78K4 only)

This area is used to specify a register bank.  

To specify a register bank, either directly input the register bank in the text box, or select it from the 

drop-down list. 

To specify the current bank, either select "Current" from the drop-down list, or directly input "Current" or 

the abbreviation "C" in the text box. If this setting is omitted, the current bank is specified.  

Settable range

[SM78K0]

0 <= register bank <= 3

[SM78K4]

0 <= register bank <= 7

When Sfr is selected

Sfr Name (SFR name setting area)

This area is used to specify a SFR name.  

To specify a register name, either directly input one to the text box, or select one from the drop-down 

list.  

Only the SFR that can be read can be specified.  Uppercase and lowercase characters are not 

distinguished.  

The SFR bit names and the I/O port name registered in the Add I/O Port dialog box cannot be 

specified.  

Note that all the register names are displayed in uppercase characters in the Trace window.  

When Memory is selected  

Memory Address (memory address setting area)

This area is used to specify an address range of the memory.  

[SM78K0, SM78K0S]
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settable range: 0 <= address <= 0xFFFF

[SM78K4]

settable range: 0 <= address <= 0xFFFFFF

Start address - End address

If a value is input as only the start address and specifying the end address is omitted, it is assumed 

that the same value as the start address is specified as the end address.  If the specified address 

range cannot be divided by the access size, the address range is rounded up to a range that can be 

divided by the access size.  

An address can be also specified by a symbol or expression (refer to "Table 6-15  Specifying Symbols 

(p.130)").  The default radix for inputting a numeric value is hexadecimal.  

If addresses are registered or changed in this area by using expressions or symbols, the converted 

address values are displayed in the Snap Entry area along with the specified expressions and 

symbols.  

In the Trace window, only the converted address values are displayed.  

Memory Display (memory display size setting area)

This area is used to specify the access size of memory snap data.  

To specify the access size, either directly input the size or select the size from the drop-down list.  

Uppercase and lowercase characters are not distinguished.  

Buttons to manipulate snap data

The following buttons are used to register, change, and delete snap data.  

Access Size Abbreviation Contents

Byte B Snapshot of memory in 8-bit units 

Word W Snapshot of memory in 16-bit units 

Double Word DW Snapshot of memory in 32-bit units 

Insert Registers snap data.
The registered snap data is inserted and displayed at the selected position in 
the Snap Entry area.  

Change Changes the contents of the snap data selected in the Snap Entry area to 
the contents of the snap data specified in this area.  

Delete Deletes the snap data selected in the Snap Entry area.
The DEL key performs the same operation.  

Restore Restores the contents in the Snap Entry area.  
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(5) Snap Entry (snap data display area)

This area displays a list of registered snap data.  

The registered snap data is written into the tracer when a snapshot event occurs.  

If snap data is selected in this area, the contents of the selected snap data are displayed in each 

setting area.  

Snap data is displayed as follows:

(6) Event Manager (event manager area)  

This area displays a list of event linkbreak, trace, snap shot, stub, timer and other registered various 

event conditions.  

For details, refer to "Event Manager (event manager area) (p.271)".  

Function buttons  

Register snap data:

R1
R3(SP)

Register name

SFR snap data:

P0
P1

SFR name

Memory snap data:

0xFE00,HW
0xFE10-0xFE1F

Start address <symbol expression> - End address <symbol 
expression>, Access size

Setting-related buttons  
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OK Automatically registers the event condition being edited, if any, and closes this 
dialog box.  The event condition becomes valid as soon as it has been 
registered.  

New Newly creates an event condition in this dialog box.  
An event condition name is automatically created and a new event condition is 
prepared.  

Set
(when a new 
event link is 
created or an 
event link is 
changed)  

Registers the various event condition.  Because the dialog box is not closed 
even after an event has been registered, new event conditions can be 
registered.  Each event condition becomes valid as soon as it has been 
registered.  
If an already registered event condition is displayed, the <Enable> or <Disable> 
button is alternately displayed.  

Enable/Disable
(when a 
registered event is 
displayed)  

Validates (enables) or invalidates (disables) the selected event condition.  
However, event conditions and event link conditions cannot be enabled or 
disabled.  
This button and the <Set> button are alternately displayed.  

Clear
(when an event is 
not edited)  

Clears the contents of the event condition.  
This button is displayed when an event condition has not been edited.  
This button and the <Restore> button are alternately displayed.  

Restore
(when an event is 
edited)  

Restores the contents of an edited event condition.  
If an event condition not registered is displayed, all the fields other than the 
event name field are blank or the default values are set.  
This button and the <Clear> button are alternately displayed.  

Cancel
Close

Closes this dialog box.  
Even if an event condition is being edited, it is not registered and the dialog box 
is closed.  
<Cancel> is displayed if a condition is not created, changed, or deleted; < 
Close> is displayed if it is.

Help Opens the Help window.  

Buttons for opening each event setting dialog box

Add Event... Opens the Event dialog box in the select mode, and selects or newly creates an 
event condition to be set.  The event condition will be added to the area 
selected when the <Add Event...> button is pressed.  

Add Link... Opens the Event Link dialog box in the select mode, and selects or newly 
creates an event link condition.  The event condition will be added to the area 
selected when the <Add Link...> button is pressed.  

Other... Opens the dialog box for selecting the event type.  
By pressing each of the buttons, each various event setting dialog box can be 
opened in the new creation status.  

Buttons in event manager area

Shrink <<<
(When area is 
displayed)

Turns off display of the event manager area.  
At this time, the size of the dialog box is reduced.  

Expand >>>
(When area is not 
displayed)

Displays the event manager area.  
At this time, the size of the dialog box is expanded.  

Open
(When only one 
event is selected)  

Opens the various event setting dialog box corresponding to the selected event 
condition.  Each setting dialog box displays the contents of the selected event 
condition.  
The Enter key performs the same operation.  
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Remove
(When event is 
selected)

Deletes the selected event condition.  
When an event condition or an event link condition is to be deleted, an error 
occurs and the event condition or event link condition cannot be deleted if the 
event is used as a various event condition.  

Info... Opens the Select Display Information dialog box.  
This dialog box is used to change the display mode and rearrange event 
names.  

Sort by Name Sorts events into type order.  

Sort by Kind Sorts events into type order.

Unsort Displays events in the order in which they have been registered without sorting 
the events.  

Detail Sets the detailed display mode.

Overview Sets the list display mode.。

Cancel Closes this dialog box (same as ESC key).
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Stub dialog box

This dialog box is used to register, set, and display stub event conditions.  

A stub event condition registered in this dialog box will be automatically registered to the Event Manager.  

A stub event condition automatically becomes valid when it has been registered.  

Up to 256 stub event conditions can be registered.  However, the number of stub event conditions that

can be simultaneously used is one (refer to "Table 6-30  Maximum number of Events Usable for Event

Conditions(p.254)").  If the maximum number of stub event conditions that can be used at the same time is

exceeded or if the number of event conditions or event link conditions used exceeds the maximum limit,

therefore, register a stub event condition in the disabled state.  

Caution: To use the stub event, set After (break after execution) under Break condition (break

mode setting area) in the Extended Option dialog box. 

Note that the SM78Kx uses hardware breaks to control the operation of the stub from

the host computer.  The time during which real-time execution is disrupted depends on

the load of Windows on the host computer.  

Figure 6-60　Stub Dialog Box

This section explains the following items:  

• Opening

• Explanation of each area

• Function buttons
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Opening

This dialog box can be opened as follows:

• Select [Event] -> [Stub...] from the menu bar   
 (or press Alt+N, and U in that order).

• Click the <Stub...> button in the Event dialog box.  
 (or press Alt+U).

Explanation of each area  

The Stub dialog box consists of the following areas:

(1)　Stub Name (stub event name setting area)

(2)　Stub Event (stub condition setting area)

(3)　Go to (jump address setting area)

(4)　Event Manager (event manager area)

(1) Stub Name (stub event name setting area)

This area is used to set a stub event name.  

Directly input an alphanumeric string of up to eight characters as a name.  

To display the contents of an already created event condition, select from the drop-down list.  

The mark on the left of this area indicates the utilization status of events (refer to "Table 6-32  Color of 

Character on Mark and its Meaning").  The gray mark indicates that an event condition is being edited 

and has not been registered yet.  

By clicking the left mark, an event condition can be validated or invalidated.  

(2) Stub Event (stub condition setting area)

This area is used to set an event condition for the stub.  

In the stub condition setting area, only one event condition and one event link condition can be set.  

To set an event condition, drag the icon of the event to be set from the Event Manager area, and drop 

it in this area.  For details, refer to "Setting event condition and event link condition in each 

area(p.280)".  
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(3) Go to (jump address setting area)

This area is used to specify the top address of the function that is executed when a stub event occurs.  

[SM78K0, SM78K0S]

Settable range :  0 <= top address of function <= 0xFFFF

[SM78K4]

Settable range :  0 <= top address of function <= 0xFFFFF

An address can be also specified by a symbol or expression (refer to "Table 6-15  Specifying 

Symbols(p.130)").  The default radix for inputting a numeric value is hexadecimal.  

To return from the specified function when a stub event occurs, describe 'RETB instruction' in the 

function.  

(4) Event Manager (event manager area)  

This area displays a list of event link, break, trace, snap shot, stub, timer and other registered various 

event conditions.  

For details, refer to "Event Manager (event manager area) (p.271)".  

Function buttons  

Setting-related buttons  

OK Automatically registers the event condition being edited, if any, and closes this 
dialog box.  The event condition becomes valid as soon as it has been 
registered.  

New Newly creates an event condition in this dialog box.  
An event condition name is automatically created and a new event condition is 
prepared.  

Set
(when a new 
event link is 
created or an 
event link is 
changed)  

Registers the various event condition.  Because the dialog box is not closed 
even after an event has been registered, new event conditions can be 
registered.  Each event condition becomes valid as soon as it has been 
registered.  
If an already registered event condition is displayed, the <Enable> or <Disable> 
button is alternately displayed.  
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Enable/Disable  
(when a 
registered event is 
displayed)  

Validates (enables) or invalidates (disables) the selected event condition.  
However, event conditions and event link conditions cannot be enabled or 
disabled.  
This button and the <Set> button are alternately displayed.  

Clear
(when an event is 
not edited)  

Clears the contents of the event condition.  
This button is displayed when an event condition has not been edited.  
This button and the <Restore> button are alternately displayed.  

Restore
(when an event is 
edited)  

Restores the contents of an edited event condition.  
If an event condition not registered is displayed, all the fields other than the 
event name field are blank or the default values are set.  
This button and the <Clear> button are alternately displayed.  

Cancel
Close

Closes this dialog box.  
Even if an event condition is being edited, it is not registered and the dialog box 
is closed.  
<Cancel> is displayed if a condition is not created, changed, or deleted; 
<Close> is displayed if it is.  

Help Opens the Help window.  

Buttons for opening each event setting dialog box

Add Event... Opens the Event dialog box in the select mode, and selects or newly creates an 
event condition to be set.  The event condition will be added to the area 
selected when the < Add Event...> button is pressed.  

Add Link... Opens the Event Link dialog box in the select mode, and selects or newly 
creates an event link condition.  The event link condition will be added to the 
area selected when the <Add Link...> button is pressed.  

Other... Opens the dialog box for selecting the event type.  
By pressing each of the buttons, each various event setting dialog box can be 
opened in the new creation status.  

Buttons in event manager area

Shrink <<<
(When area is 
displayed)

Turns off display of the event manager area.  
At this time, the size of the dialog box is reduced.  

Expand >>>
(When area is not 
displayed)

Displays the event manager area.  
At this time, the size of the dialog box is expanded.  

Open
(When only one 
event is selected)  

Opens the various event setting dialog box corresponding to the selected event 
condition.  Each setting dialog box displays the contents of the selected event 
condition.  
The Enter key performs the same operation.  

Remove
(When event is 
selected)

Deletes the selected event condition.  
When an event condition or an event link condition is to be deleted, an error 
occurs and the event condition or event link condition cannot be deleted if the 
event is used as a various event condition.  

Info... Opens the Select Display Information dialog box.  
This dialog box is used to change the display mode and rearrange event 
names.  
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Sort by Name Sorts events into type order.  

Sort by Kind Sorts events into type order.

Unsort Displays events in the order in which they have been registered without sorting 
the events.  

Detail Sets the detailed display mode.

Overview Sets the list display mode.。

Cancel Closes this dialog box (same as ESC key).
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Timer dialog box

This dialog box is used to display the execution time measurement result, and register and set timer

event conditions.

A timer event condition that has been registered in this dialog box is automatically registered to the Event

Manager.  

The execution time measurement result is displayed when the set timer event condition is selected.  

A timer event condition automatically becomes valid when it has been registered.

Up to 256 timer event conditions can be registered.  However, the number of timer event conditions that

can be simultaneously used is eight (refer to "Table 6-30  Maximum number of Events Usable for Event

Conditions (p.254)").

If the maximum number of timer event conditions that can be used at the same time is exceeded or if the

number of event conditions used exceeds the maximum limit, therefore, register a timer event condition in

the disabled state.

Run-Break event

Run-Break is a timer event name given to a timer event condition that measures the execution time 

from execution to break.  This timer event name is registered in the default condition and the execution 

time can be displayed by selecting it in the Timer Name area in this dialog box.  

The Run-Break event is not included in the number of timer events simultaneously usable, and can 

therefore always be used.

A timer event condition is satisfied only when the timer is valid.

Figure 6-61　Timer Dialog Box
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This section explains the following items:  

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:  

• Click the Tim button.

• Select [Event] -> [Timer...] from the menu bar   
 (or press Alt+N, and I in that order).  

• Click the <Timer... > button in the Event dialog box.  
 (or press Alt+I).  

Explanation of each area  

The Timer dialog box consists of the following areas:

(1)　Timer Name (timer event name setting area)

(2)　Start Event, End Event (timer condition setting area)

(3)　Time (timer display unit selection area) 

(4)　Execution time display area

(5)　Event Manager (event manager area)

(1) Timer Name (timer event name setting area)

This area is used to set a timer event name.  

Directly input an alphanumeric string of up to eight characters as a name.

To display the contents of an already created event condition, select from the drop-down list.

The timer event name [Run-Break] that displays from execution to break is registered in the default 

condition, but is not displayed on the Event Manager.  

The mark on the left of this area indicates the utilization status of events (refer to "Table 6-32  Color of 

Character on Mark and its Meaning (p.256)").  The gray mark indicates that an event condition is being 

edited and has not been registered yet.  

Clicking this mark enables/disables the event condition.
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(2) Start Event, End Event (timer condition setting area)

This area is used to set an event condition for the timer.

The number of event conditions that can be registered to the timer condition setting area is 1 for the 

start condition and 1 for the end condition. 

To set an event condition, drag the icon of the event to be set from the Event Manager area, and drop 

it in this area.  For details, refer to "Setting event condition and event link condition in each area 

(p.280)".

(3) Time (timer display unit selection area)

This area is used to select the unit in which the timer measurement result is to be displayed.  

(4) Execution time display area

This area displays the result of measuring the execution time of the program.  

Start Event Sets the event condition for starting time measurement.

End Event Set the event condition that stops time measurement.  

nsec Nanoseconds (default)

usec Microseconds

msec Milliseconds

sec Seconds

min Minutes

clock Displays measurement result using clock count.

Pass Pass countNote 1

(measurable execution count: 4294967295 max.)
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Notes1. Cannot be measured in the case of Run-Break

2. Resolution: 0.1 µ s

The execution time display area is blank if measurement is not performed or the measurement result 

has been cleared.  

Buttons to manipulate execution time display area

(5) Event Manager (event manager area)  

This area displays a list of event link, break, trace, snap shot, stub, timer and other registered various 

event conditions.  

For details, refer to "Event Manager (event manager area) (p.271)".

Function buttons  

Total Total execution time in the measurement zone specified by start event and end 
event conditions
(measurable execution time: Approx. 7 minutes 9 seconds max. Note2 )

Average Average execution timeNote 1

Max Maximum execution timeNote 1

Min Minimum execution timeNote 1

Initialize Clears the measurement results.

Copy Copies the measurement result to the clipboard in text format.

View Always Displays the Timer Result dialog box in which the selected timer event 
condition or the measurement result of Run-Break is displayed.  

Setting-related buttons  

OK Automatically registers the event condition being edited, if any, and closes this 
dialog box.  The event condition becomes valid as soon as it has been 
registered.  

New Newly creates an event condition in this dialog box.  
An event condition name is automatically created and a new event condition is 
prepared.  
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Set
(when a new 
event link is 
created or an 
event link is 
changed)  

Registers the various event condition.  Because the dialog box is not closed 
even after an event has been registered, new event conditions can be 
registered.  Each event condition becomes valid as soon as it has been 
registered.  
If an already registered event condition is displayed, the <Enable> or <Disable> 
button is alternately displayed.  

Enable/Disable  
(when a 
registered event is 
displayed)  

Validates (enables) or invalidates (disables) the selected event condition.  
However, event conditions and event link conditions cannot be enabled or 
disabled.  
This button and the <Set> button are alternately displayed.  

Clear
(when an event is 
not edited)  

Clears the contents of the event condition.  
This button is displayed when an event condition has not been edited.  
This button and the <Restore> button are alternately displayed.  

Restore
(when an event is 
edited)  

Restores the contents of an edited event condition.  
If an event condition not registered is displayed, all the fields other than the 
event name field are blank or the default values are set.  
This button and the <Clear> button are alternately displayed.  

Cancel
Close

Closes this dialog box.  
Even if an event condition is being edited, it is not registered and the dialog box 
is closed.  
<Cancel> is displayed if a condition is not created, changed, or deleted; 
<Close> is displayed if it is.  

Help Opens the Help window.  

Buttons for opening each event setting dialog box

Add Event... Opens the Event dialog box in the select mode, and selects or newly creates an 
event condition to be set.  The event condition will be added to the area 
selected when the < Add Event...> button is pressed.  

Add Link... Opens the Event Link dialog box in the select mode, and selects or newly 
creates an event link condition.  The event link condition will be added to the 
area selected when the <Add Link...> button is pressed.  

Other... Opens the dialog box for selecting the event type.  
By pressing each of the buttons, each various event setting dialog box can be 
opened in the new creation status.  

Buttons in event manager area

Shrink <<<
(When area is 
displayed)

Turns off display of the event manager area.  
At this time, the size of the dialog box is reduced.  

Expand >>>
(When area is not 
displayed)

Displays the event manager area.  
At this time, the size of the dialog box is expanded.  

Open
(When only one 
event is selected)  

Opens the various event setting dialog box corresponding to the selected event 
condition.  Each setting dialog box displays the contents of the selected event 
condition.  
The Enter key performs the same operation.  

Remove
(When event is 
selected)

Deletes the selected event condition.  
When an event condition or an event link condition is to be deleted, an error 
occurs and the event condition or event link condition cannot be deleted if the 
event is used as a various event condition.  

Info... Opens the Select Display Information dialog box.  
This dialog box is used to change the display mode and rearrange event 
names.  
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Sort by Name Sorts events into type order.  

Sort by Kind Sorts events into type order.

Unsort Displays events in the order in which they have been registered without sorting 
the events.  

Detail Sets the detailed display mode.

Overview Sets the list display mode.

Cancel Closes this dialog box (same as ESC key).
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Timer Result dialog box

This dialog box displays the result of measuring the execution time.

It displays the timer event condition set in the Timer dialog box and the result of measuring the execution

time of [Run-Break].  

The Timer Result dialog box corresponds to a timer event condition or [Run-Break] on a one-to-one

basis, and two or more of this dialog box can be simultaneously opened.  Up to 257 Timer Result dialog

boxes can be opened, of which 256 correspond to timer event conditions and one corresponds to [Run-

Break].

However, the maximum number of timer event conditions that can be simultaneously measured is the

number of timer event conditions that can be simultaneously used plus one corresponding to [Run-Break]

(refer to "Table 6-30  Maximum number of Events Usable for Event Conditions (p.254)").  

Figure 6-62　Timer Result Dialog Box

This section explains the following items:  

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

• Select a timer event condition or Run-Break in the Timer dialog box
Click the <View Always> button.
 (or press Alt+V). 

Explanation of each area  

The Timer Result dialog box consists of the following areas:

(1)　Execution time display area
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(1) Execution time display area

This area displays the result of measuring the execution time of the program (refer to the section 

describing the Execution time display area (p.304) of the Timer dialog box).

Function buttons  

Initialize Clears the measurement results.

Copy Copies the measurement result to the clipboard in text format.

Close Closes this dialog box.  

Help Opens the Help window.  
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Delay Count dialog box

This dialog box is used to set or display delay count values.  

By setting a delay count, it is possible, following the occurrence of a stop condition event, to perform trace

the number of times corresponding to the specified delay count value, execute the program, and stop the

tracer.

Figure 6-63　Delay Count Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

• Select [Event ] -> [Delay Count...] from the menu bar 
 (or press Alt+N and Y in that order).

Explanation of each area  

This dialog box consists of the following areas:  

(1)　Delay Count (delay count setting area)

(1) Delay Count (delay count setting area)

This area is used to set or display a delay count value (unit: frames).  

The delay count can be set between 0 (default) and 32767.
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Function buttons

OK Sets the specified delay count and closes this dialog box.  

Restore Restores the previous delay count.  

Cancel Closes this dialog box.  

Help Opens the Help window.  
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Reset Debugger dialog box

This dialog box is used to initialize the debugger, CPU, and symbol information.

Specify what is to be initialized by using the check box.  In the default condition, the debugger is

initialized.  

Figure 6-64　Reset Debugger Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

• Select [File] -> [Debugger Reset...] on the menu bar
 (or press Alt+F, and R in that order).

Explanation of each area

The Reset Debugger dialog box consists of the following areas:

(1)　Reset subject selection area

(1) Reset subject selection area

This area is used to select what is to be initialized.  

Debugger Initializes the debugger (default).
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Function buttons

Symbol Initializes the symbol information.

Target CPU Initializes the  CPU.

OK Initializes the debugger, symbol information, or CPU.

Cancel Ignores the setting and closes this dialog box.

Help Opens the Help window.  
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About dialog box

This dialog box displays the version information of the debugger and simulator (the year is displayed in 4

digits).

The following version information is displayed:

• Product version of debugger

• Version of device file

• Version of GUI

• Version of debugger DLL

• Version of assembler DLL

• Version of executor

Figure 6-65　About Dialog Box

This section explains the following items:

• Opening

• Function buttons

Opening

This dialog box can be opened as follows:

• Select [Help]->[About]
 (or press Alt+H, and A in that order).
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Function buttons

OK Closes this dialog box.
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Exit Debugger dialog box

This dialog box is used to select whether the current debug environment is saved to a project file or not

before terminating the debugger.  

It can be specified in the Debugger Option dialog box that the debugger is terminated without this

confirmation dialog box being opened.  

Figure 6-66　Exit Debugger Dialog Box

Reference: If an attempt is made to terminate the debugger while the user program is being executed,

the following message is displayed and the program execution can be stopped.  

<Yes> button is selected

Execution of the user program is stopped and then the Exit Debugger dialog box is displayed.  

If it is specified in the Debugger Option dialog box that the Exit Debugger dialog box is not to

be displayed, however, the debugger is terminated.  

<No> button is selected

Execution of the user program is not stopped and the Exit Debugger dialog box is not

displayed.  The debugger is not terminated.  

This section explains the following items:  

• Opening

• Function buttons

Opening

This dialog box can be opened as follows:  
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• Select [File] -> [Exit] from the menu bar
(or press Alt+F, and X in that order).

• Press the Alt+F4 keys simultaneously.

• If forcible termination, such as to terminate the application, has been executed on the task list that
terminates Windows.  

Function buttons  

Yes Saves the current debug environment to a project file, closes all the windows, and 
terminates the debugger.  
If a project file name is not specified, the Project File Save dialog box is opened.  If 
the < Cancel> button is selected on the Project File Save dialog box, the 
environment is neither saved to a project file nor is the debugger terminated.  
If a project file is loaded or saved during debugger operation, this button has the 
default focus.  

No Closes all the windows and terminates the debugger.
If a project file is not loaded or saved during debugger operation, this button has the 
default focus.

Cancel Closes this dialog box without executing anything.
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Console window

This window is used to input commands that control the debugger.  

Because the key bind is Emacs-like, the accelerator key is not acknowledged if the Console window is

active.  

However, the F1 key displays the help of the Console window.  

While the Console window is open, an error message window with only an <OK> button is displayed in

the Console window.  

Refer to "CHAPTER 7 COMMAND REFERENCE (p.441)" for details on the command specifications.  

Figure 6-67　Console window

This section explains the following items:  

• Opening

Opening

This window can be opened as follows:

• Select [Browse] -> [Console] from the menu bar 
 (or press Alt+B, and N in that order).
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78Kx Simulator GUI window

This is the main window of the simulator. 

Windows related to the peripheral simulator and external parts are opened from this window.

This window is opened when the SM78Kx is started and remains on the screen until the simulator is

terminated. 

If this window is closed, the SM78Kx is terminated.

Figure 6-68　78Kx Simulator GUI window

This section explains the following items:

• Opening

• Menu bar

• Message display area (at center of window)

• Area to display name of file to be simulated (lower part of window)

Opening

This window box can be opened as follows:

• Click the <78Kx Simulator GUI> button on the Windows task bar.

Menu bar

The menu bar consists of the following menus:

(1)　 [File] menu

(2)　 [External Parts] menu

(3)　 [External Circuit] menu

(4)　 [Option] menu

(5)　 [Help] menu

(1) [File] menu

Select this menu to create a file for data input to the SFRs (.i_x) or an event condition file (.env), 
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download these files, specify output from the simulator, and terminate the simulator.

(2) [External Parts] menu 

Select this menu to open Parts window. 

(3) [External Circuit] menu

Cannot be selected.

New Opens a new window.
If this menu is selected when the Input 0/1 Editor window or Input timing Chart 
Editor window has already been opened, the window already open pops up. 

0/1... Opens the Input 0/1 Editor window.

Timing... Opens the Input timing Chart Editor window.

Event... Opens the SFR Event & Action window.

Open Opens a file saved previously.  
Specify a file in the Open dialog box.
If this menu is selected when the Input 0/1 Editor windowor Input timing Chart 
Editor window is opened, a file newly specified in the already opened window is 
specified and pops up. 

0/1... Opens the Input 0/1 Editor window.

Timing... Opens the Input timing Chart Editor window.

Event... Opens the SFR Event & Action window.

Download... Opens the Down Load dialog box.
The specified input data file (.i_x) or event condition file (.evn) is downloaded.
Clicking the <OK> button in the Down Load dialog box starts downloading of the 
specified file. 
However, this operation is not possible while the CPU is operating.

Output... Opens the Output Setting dialog box.
If "Output to file" is selected in the Output Setting dialog box, the output data is 
output to a file.  If "Enable timing chart" is selected, the Output Timing Chart 
window is opened.

Exit... Opens the Exit Debugger dialog box.
Select <OK> in this dialog box to terminate the SM78Kx.

Panel Window... Opens the Parts window.  
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(4) [Option] menu 

Cannot be selected.

(5) [Help] menu

Message display area (at center of window)

This area displays the default message if initialization is executed with no input message set.

No input data is set during simulation.  If a request is received to read the input data from a pin to which a

pull-up resistor is not connected, the value of the pin is initialized to 0.  In this case, a message is displayed

in this area.

Area to display name of file to be simulated (lower part of window)

This area displays the following information:

SM78Kx Help Opens the Help window of SM78Kx.

This Window Displays the help window of this window.

Down Load File: Displays the name of the input data file currently downloaded.  The identifier is 
.i_x.
To specify a file, select [File] -> [Download] from the menu bar, or select the 
<Download> button in the Input timing Chart Editor window, Input 0/1 Editor 
window, or SFR Event & Action window. 

Output Data File: Displays the name of the file in which the data output by the simulator is to be 
stored.  The identifier is .out.
To specify a file, select [File] -> [Output...] from the menu bar.
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SFR Event & Action window

This window is used to set and display the event conditions of the SFRs and an action (such as

occurrence of an interrupt at a specified timing and data input) to be performed after a given event condition

has been satisfied.

A created event condition and action can be saved to an event condition file (.evn), and can be

downloaded when the CPU is not in operation.  When an event condition file is downloaded, the events in

the file are registered to the simulator so that they can be checked.

Up to 20 events and actions can be registered to one event condition file.

Figure 6-69　SFR Event & Action Window

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This window can be opened as follows:

• In the 78Kx Simulator GUI window
Select [File] -> [New] -> [Event...] from the menu bar
 (or press Alt+F, N and E in that order).
Select [File] -> [Open] -> [Event...] from the menu bar
 (or press Alt+F, O and E in that order).
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Explanation of each area

The SFR Event & Action window consists of the following areas:

(1)　Event No (event number setting area)

(2)　File Name: (event condition file name display area)

(3)　Event Set (event setting area)

(4)　Action Set (action setting area)

Caution: It is not possible to move among fields with the TAB key.

(1) Event No (event number setting area)

Select the ID number (0 -19) to be assigned to an event & action from the drop-down list.  If the event 

has not been set yet, the input field is displayed in the default condition.  If an event ID already set is 

selected, its contents are displayed in each area.

(2) File Name: (event condition file name display area)

This area displays the name of the file that is currently open and can be saved.

This area is not displayed if a new file is created.  When the file is saved (by clicking the <Save> 

button), a name is given to the file. 

To read the contents of a file previously saved, specify the file by using the <Open> button.

(3) Event Set (event setting area)

This area is used to set event conditions.  Specify the following items in this area:

Valid If the Valid check box is checked, the event of Event No currently selected becomes valid.
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(4) Action Set (action setting area)

This area is used to set the action to be performed when an event occurs.  Specify when the action is 

to be started and what action is to be performed.

Address
Sfr

Specify the memory area where the event is to occur.
Select either Address or Sfr by using the option button.
Address
If Address is selected, input an address. The event occurs when this address is 
accessed.  The addresses in the entire memory space can be specified.
Sfr
If SFR is selected, specify a SFR name.  The event occurs when this register is 
accessed.
Select an address or register from the drop-down list, or input an address or 
register name from the keyboard (default).
For the specifiable SFR names, refer to the user's manual of the device used.

Status Specify the access status in which an event occurs.
Select an access status from FETCH (default), READ, WRITE, or READ/WRITE 
from the drop-down list, or input a status from the keyboard.

Access Size Specify the access size by which an event occurs.
Select access size from NO DATA (default), 1 BYTE, 2 BYTE, or 4 BYTE from 
the drop-down list, or input a size from the keyboard.

Data Specify the data condition in which an event occurs.
This setting is invalid if NO DATA is specified for Access Size .  If 1 BYTE, 2 
BYTE or 4 BYTE is specified, a data condition can be specified in a given range.

Data Mask Specify the data mask condition in which an event occurs.
A value of up to 4 bytes can be specified.
This setting is invalid if NO DATA is specified for Access Size .

Pass Count Specify how many times the above event condition (specified in the Event Set 
area) is to be satisfied. 
A value of up to 2 bytes can be specified.  If 1 (default) is set, it is assumed that 
an event occurs when the event condition is satisfied once.

Timing Val Specify the start timing of the action (in Timing Unit units).
A value of up to 2 bytes can be specified.  The default value is 0, which means 
that the action is started as soon as an event has occurred.
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Function buttons 

Timing Unit Specify the unit for Timing Val. 
Select a unit from the drop-down list (refer below) or input a unit from the 
keyboard.
CLOCK CPU clock unit (default)Note

M-CLK  Main clock unit
INS  Instruction unit
Note: The CPU clock unit and main clock unit are the same.

Interrupt If this check box is checked, an interrupt signal is generated as an action.
Select an interrupt name from the drop-down list, or input from the keyboard.
For the specifiable interrupt names, refer to the user's manual of the device 
used.

Set Data If this check box is checked, a value is input to a specified address, SFR, or pin 
as an action. 
Use the option button for specification.
Address
Specify the address to which data is to be input.
The addresses in the entire memory space can be specified.
Sfr
Specify the SFR to which data is to be input.  Select a register from the drop-
down list, or input a register from the keyboard.
Pin
Specify the name of the pin to which data is to be input.  Select a register from 
the drop-down list, or input a register from the keyboard.
For the specifiable pin names and SFR names, refer to the user's manual of the 
device used.

Data Specify the data to be input to a specified address, SFR, or pin.
If Address or Sfr above is selected, a value of up to 4 bytes can be specified.  If 
Pin is specified, a value of 0 or 1 can be specified.

Open Opens the Open dialog box
The specified event condition file (.evn) is read. 

Save Opens the Save As dialog box
The set window to be performed are saved to an event condition file (.evn).
When specifying a file name in the Save As dialog box, be sure to use four  characters 
followed by 0000.evn (e.g., abcd0000.evn or 
efgi0000.evn).abcd0000.evn,efgi0000.evn etc.)

Down Load Opens the Down Load dialog box
The specified file is downloaded to the simulator.

Clear Opens a dialog box that asks you if the data should be initialized.
If the <OK> button is selected, data being created and not saved to a file is initialized.
Use this button to start editing the file again from where data was last saved to the file. 

Cancel Opens a dialog box that inquires asks you if the window should be closed.
If the <OK> button is selected, the window is closed.

Help Opens the Help window.
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Input 0/1 Editor window

This is one of the input editor windows and is used to set input data of any timing to an input pin as a

numeric value.

The following data can be displayed in this window:

• Newly created input data

• Previously created input data (to be edited)

• File simulated previously and saved to an output file

Input data can be saved to an input data file (.i_x).  By downloading this file, an input signal can be

generated from a pin during simulation.

Figure 6-70　 Input 0/1 Editor Window

This section explains the following items:

• Opening

• Explanation of each area

• Operation

• Function buttons

Opening

This window can be opened as follows:

• In the 78Kx Simulator GUI window
Select [File] -> [New] -> [0/1...] from the menu bar
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 (or press Alt+F, N and 0 in that order).
Select [File] -> [Open] -> [0/1...] from the menu bar
 (or press Alt+F, O and 0 in that order).

Explanation of each area

The Input 0/1 Editor window consists of the following areas:

(1)　File Name: (input data file name display area)

(2)　Wait Count Type: (wait display selection area)

(3)　Mark, Wait, Pin (input data setting table)

(1) File Name: (input data file name display area)

This area displays the name of the file that is currently open and can be saved.

This area is not displayed if a new file is created.  When the file is saved (by clicking the <Save> 

button), a name is given to the file. 

(2) Wait Count Type: (wait display selection area)

This button selects display of the timing (wait) at which data is to be input during simulation.  Select the 

start of the wait time by using the option button.

Rel. (Relative display)
Wait time starts with the input of the previous data.

Abs  (Absolute display)
Wait time starts with the start of simulation.
If wait is displayed for absolute display (Abs), the carry from the top in the edit/display 
area is displayed in the form of XXXXXXxxxxx in the lower part of the Wait field.
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(3) Mark, Wait, Pin (input data setting table)

This table is used to set or display data to be input to a specified pin.

When the wait time specified in the Wait field has expired, the data set for each pin in the Pin field is 

input from each pin. 

Eight pins are displayed in 10 stages in the default condition. Up to 48 pins can be specified.  The size 

of this window can be varied.

Mark Displays or sets loop information.
By clicking this field, loop information is set by using the following symbols (X indicates 
an order such as ABC, and Y indicates a numeric value).
By this the information in the specified area can be input repeatedly.
X-SStart position of the loop specified as the Xth.
X-YEnd position of the Xth loop.
      This loop is repeated Y times (1 <= Y <= 99).
      Actually, the loop is repeated Y+1 times.
X-F End position of the Xth loop.
      This loop is repeated until simulation ends.
Each time the left button of the mouse is clicked, X-S, X-F, and X-Y are selected in that 
order.  The value of Y is incremented by one each time the right mouse button is clicked 
when X-Y is selected.  It is decremented by one each time the right mouse button is 
clicked with the Shift key held down.
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Operation

Setting input data

On the setting table of input data, 0 (LOW), 1 (HIGH), or Z (high impedance) can be set for an input 

pin.  For an analog input pin, a numeric value in the range of the number of bits of the A/D converter 

can be setNote.

To set a new pin, set a pin name in the Pin field.  "EOF" will be set on the first stage of the data setting 

table. By clicking this  "EOF", one line of the input data can be inserted.

Note: This differs depending on the device used.

Wait Set the timing of inputting the data in the Pin field to a specified pin, as a wait value.
An integer of 1 to 65535 can be specified.  If 65535 is exceeded, use one more stage 
for setting.  Directly write a numeric value to this field from the keyboard.
Select the unit of Wait from the following when the file is to be saved (to save the file, 
use the <Save> button):
.i_0   ist (instruction unit)
        The set wait value in this file is ignored.
.i_1  clock (CPU clock unit)
        The CPU clock unit and main clock unit are the same.
.i_2  1/4m-clk (1/4 main clock unit)
.i_3  m-clk (main clock unit)
If abs. is specified for Wait Count Type, the carry from the top stage in the Wait field is 
displayed in the lower part of this field in the form of XXXXXxxxxxx. 
Example:
In the following figure, the wait value at the top stage is 108001.  Therefore, the wait 
value at the bottom stage is 108010. 

Pin Specify the name of the pin to which data is to be input and the data to be input 
according to the timing specified in the Wait field.
For the pin name, either open Pin Setting dialog box by using the <Pin Set> button and 
create a new pin name, or read a pin setting information file (.pin) by using the <Read> 
button on that dialog box.  To edit an input data file (.i_x) previously saved, specify a file 
name using the <Read> button and read the file.
If the left mouse button is clicked in the pin name display area where a pin name is set, 
the displayed pin name changes color from black to purple, indicating that the pin has 
been selected.
If this input data file is downloaded, the data of only the selected pin is downloaded. 
If a display name is set, the display name* is displayed instead of a pin name.
For the display name, refer to the explanation of the Pin Setting dialog box.



330 User’s Manual  U16768EJ1V0UM

CHAPTER 6  WINDOW REFERENCE

• Setting of input pin

• Setting of analog input pin 

• With analog output pin
If the output signal does not change, "^" indicating that the data is the same as that on the above line is
displayed.
Displayed when an output data file (.out) is read.

When an existing input data file is read and edited, input data can be added or changed by the same 

operation as above.

Selecting pin to which data is to be downloaded

If the pin name displayed in the Pin field is clicked, the color of the clicked pin changes from black to 

purple, indicating that the pin has been selected.

By saving and downloading this input data file, the data of only the selected pin (in purple) can be 

downloaded.  Here is an example:

Example:

If the above file is downloaded, data is input to pin P10, as follows: 

Mouse operation Meaning

Left click Value changes in the order of 0, 1, and Z.

Mouse operation Meaning

Left click Value is incremented by one.

Right click Value is decremented by one.

While holding down the Shift key
(Left/right) click

Value changes by 10.
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Function buttons

Pin Set Opens the Pin Setting dialog box
The specified pin will be set in the Pin field.

Generation Cannot be selected.

Search Opens the Search window
Data in the input data file can be searched.

Clear Initializes the contents being created and not yet saved to a file.
Use this button to start editing the file again from where data was last saved to 
the file. 

Read Opens the Open dialog box
The specified input data file (.i_x) will be read.

Save Opens the Save As dialog box
The contents of the set window are saved as an input data file (.i_x). 
When specifying a file name in the Save As dialog box, be sure to use four 
characters followed by 0000.i_x (e.g., abcd0000.i_0 or efgi0000.i_1).

DownLoad Opens the Down Load dialog box
The specified file is downloaded to the simulator.

Help Opens the Help window.

Cancel Ignores the setting and closes this window.
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Input timing Chart Editor window

This is one of the editor windows and is used to set an input timing chart and input data in 1-bit units to an

input pin. 

The following data can be displayed in this window:

• Newly created input data

• Previously created input data (to be edited)

• File simulated previously and saved to an output file

Input data can be saved to an input data file (.i_x).  By downloading this file, an input signal can be

generated from a pin during simulation.

Figure 6-71　 Input timing Chart Editor Window

This section explains the following items:

• Opening

• Explanation of each area

• Operation

• Function buttons

Opening

This window can be opened as follows:

• In 78Kx Simulator GUI window
Select [File] -> [New] -> [Timing...] from the menu bar
 (or press Alt+F, N and T in that order).
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Select [File] -> [Open] -> [Timing...] from the menu bar
 (or press Alt+F, O and T in that order).

Explanation of each area

The Input timing Chart Editor window consists of the following areas:

(1)　File Name: (input data file name display area)

(2)　Wait Value (wait value setting area)

(3)　 Information (information display area)

(4)　Timing chart setting area

(1) File Name: (input data file name display area)

This area displays the name of the file that is currently open and can be saved.  This area is not 

displayed if a new file is created.  A name is given to the file when it is saved.

(2) Wait Value (wait value setting area)

This area is used to set the timing (wait) at which data is input during simulation.

(3) Information (information display area)

This area displays the first wait value if the time axis is not displayed. 

Double-clicking near the character scale displays time axis cursor S and time axis marker E in the 

timing chart setting area, and the following values are displayed in the information display area:

Wait Value Select a wait value (timing of data input) from the drop-down list 
(1, 2, 4, 8, 16, 32, 64, 128, 256, or 512).  This value is used as one division of the 
scale.
Select the unit of Wait from the following when the file is to be saved (to save the 
file, use the <Save> button):
.i_0   ist (instruction unit)
        The set wait value in this file is ignored.
.i_1  clock (CPU clock unit)
        The CPU clock unit and main clock unit are the same.
.i_2  1/4m-clk (1/4 main clock unit)
.i_3  m-clk (main clock unit)

S Wait value from the beginning of the file to the location indicated by S

E Wait value from the beginning of the file to the location indicated by E
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Remark: The time axis can be moved by dragging the character S or E.

(4) Timing chart setting area

This area is used to set an input timing chart and input data for a specified pin.

The data of only an input pin can be edited.  Nine pins are displayed in the default condition.  Up to 48 

signals can be displayed.

The size of this window can be varied.

S(PC) PC value of the address at which the output value at the location indicated by S is 
generated (if .out file is read)

E-S Wait value from the location indicated by S to the location indicated by E

Pin Specify the name of the pin to which data is to be input.
For the pin name, either open the Pin Setting dialog box by using the <Pin 
Set> button and create a new pin name, or read a pin setting information 
file (.pin) by using the <Read> button on that dialog box.
To edit an input data file (.i_x) previously saved, specify a file name using 
the <Read> button and read the file.
If the left mouse button is clicked in the pin name display area where a pin 
name is set, the displayed pin name changes color from black to purple, 
indicating that the pin has been selected.
If this input data file is downloaded, the data of only the selected pin is 
downloaded. 
If a display name is set, the display name is displayed instead of a pin 
name.
For the display name, refer to the Pin Setting dialog box.

Time axis cursor, 
time axis marker

Double-clicking near the character Scale displays a solid line and a dotted 
line.
The solid line is the time axis cursor (S) and the dotted line is the time axis 
marker (E).  After the time axis cursor and time axis marker have been 
displayed, each can be moved by dragging it with the mouse.
If the time axis cursor or time axis marker has been moved to the left in the 
timing chart setting area and therefore cannot be displayed in the area, S 
or E is displayed at the upper left part of the Scale field.  If the axis or 
marker has been moved to the right in the timing chart setting area and 
cannot be displayed in the area, S or E is displayed at the upper right part 
of the Scale field.
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Operation

Setting input data/timing

To set new data, set a pin name in the Pin field and double-click at any location in the timing chart 

setting area.  A waveform can be input.  If data has been fully set in the timing chart setting area, data 

of one division of the Scale can be added by clicking "EOF" displayed at the rightmost position of the 

Scale field with the right mouse button.Note .

The set waveform can be changed by using the mouse as follows in the timing chart setting area:

Caution: The horizontal scroll bar is also displayed.

• With input pin

• With analog input pin

If the right button of the mouse is clicked in this area, the name and value of the pin clicked at the lower 

right part of the information display area (Information) are displayed.

When an existing input data file is read and edited, input data can be added or changed by the same 

operation as above.

Selecting pin to which data is to be downloaded

If the pin name displayed in the Pin field is clicked, the color of the clicked pin changes from black to 

purple, indicating that the pin has been selected.  By saving and downloading this input data file, the 

data of only the selected pin (in purple) can be downloaded.

Operation Modification

Double-clicking left button One division changes to HIGH.

Double-clicking right button One division changes to LOW.

Double-clicking left button with 
Shift key held down

One division changes to high impedance.

Operation Modification

Double-clicking left button Value of one division incremented by one.

Double-clicking right button Value of one division decremented by one.

Double-clicking left button with 
Shift key held down

Value of one division changes by 10.

Dragging horizontal line of 
timing chart with mouse

Value changes by up and down movement.
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Function buttons

Pin Set Opens the Pin Setting dialog box
The specified pin will be set in the Pin field.

Generation Cannot be selected.

Search Opens the Search window
Data in the input data file can be searched.

Clear Initializes the contents being created and not yet saved to a file.
Use this button to start editing the file again from where data was last saved to 
the file. 

Read Opens the Open dialog box
The specified input data file (.i_x) will be read.

Save Opens the Save As dialog box
The contents of the set window are saved as an input data file (.i_x). 
When specifying a file name in the Save As dialog box, be sure to use four 
characters followed by 0000.i_x (e.g., abcd0000.i_0 or efgi0000.i_1). 

DownLoad Opens the Down Load dialog box
The specified file is downloaded to the simulator.

Help Opens the Help window.

Cancel Ignores the setting and closes this window.
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Pin Setting dialog box

This dialog box is used to set a pin to be displayed in the Input 0/1 Editor window, Input timing Chart

Editor window, and  Output Timing Chart window.  A pin name can be set in this dialog box. The set pin

name can be saved to or read from a file (.pin).

In addition, a name (display name) can be also given to the pin.

Figure 6-72　Pin Setting Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This window box can be opened as follows:

• Click the <Pin Set> button in the Input 0/1 Editor window

• Click the <Pin Set> button in the Input timing Chart Editor window

• Click the <Pin Set> button in the Output Timing Chart window

• Click the <Pin Set> button in the Search window

Explanation of each area

This dialog box consists of the following areas:

(1)　Pin number display area

(2)　Pin name setting area
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(1) Pin number display area

This area displays the numbers of the pins.

To set more than five pins, update the pin numbers by clicking the <Next> button.

Up to 48 pins can be set.

(2) Pin name setting area

This area is used to specify the pin name that corresponds to a pin number.

Select a pin name from the drop-down list, or input a name from the keyboard.

To set the selected pin name, use the TAB key or <Previous> or <Next> button.

If the pin name "PXX" is specified in the field immediately before, the pin name next to PXX is 

displayed in the drop-down list of the next field.  Once a pin has been set, it is not displayed in the 

drop-down list.

Giving display name to pin

In addition, a name (display name) can be also given to the pin.

The display name of the pin is displayed in the Pin field of the window that has called this dialog box.

To give the display name "XXXXXXX", for example, set the pin name in the pin name setting area, 

erase the pin name, and input "@XXXXXXXX".  

To clear a display name, erase the pin name in the pin name setting area, and input "@".

Referencing display name

A display name is not displayed in the pin name setting area even if a display name has been set for a 

pin.  Erase the pin name, input "@@", and move the input focus by using the TAB key.

Function buttons

Previous Displays setting information on four pin numbers preceding the pin currently displayed.

Next Displays setting information on four pin numbers following the pin currently displayed.

OK Validates the setting and closes the dialog box.
The pin name (or display name) is set in the Pin field of the window that has called this 
dialog box

Save Opens the Save As dialog box.
The displayed contents will be saved to a pin information file. A pin information file has 
the extension (.pin).

Open Opens the Open dialog box.
The pin setting information of a specified file (.pin) will be read.
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Clear Ignores the setting and closes the window.
Use this button to start editing the file again from where data was last saved to the file. 

Cancel Ignores the setting and closes this window.
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Down Load dialog box

This dialog box is used to check the name and type of the file to be downloaded, and download the file.

Up to five files of the same name, except the extension, can be downloaded while the CPU is not in

operation.

Data input to the simulator that has been specified more recently has the higher priority.

Caution: If an input data file is downloaded while an external component for input is being

displayed, input from the input data file takes precedence.  If an external component

for input is being displayed while an input file is being downloaded, input from the

external component is enabled  At this time, an information dialog box indicating that

the connection destination has been changed is opened.

Figure 6-73　Down Load Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

• In the 78Kx Simulator GUI window
Select [File] -> [DownLoad...] on the menu bar
 (or press Alt+F, and D in that order).

• In the SFR Event & Action window 
Click the <Down Load> button.

• In the Input 0/1 Editor window
Click the <Down Load> button.
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• In the Input timing Chart Editor window
Click the <Down Load> button.

Explanation of each area

This dialog box consists of the following areas:

(1)　Down Load Filename: (file name specification area)

(2)　Down Load File: (file type specification area)

(1) Down Load Filename: (file name specification area)

This area is used to input the name of the file to be downloaded.

Input a file name from the keyboard, or select one from the Open dialog box, which can be opened by 

using the <Browse> button.

(2) Down Load File: (file type specification area)

This area is used to specify the type of the file to be downloaded.  The file type can be specified by 

using a checkbox. 

Up to five types of files can be simultaneously downloaded. If two or more files are specified, they are 

sequentially downloaded starting from the top.  If the same pin is used for input in two or more files, the 

input of the file downloaded later becomes valid.

If no file type is selected, a message box with the message "All downloaded data will be cleared." pops 

up.  If the <OK> button is clicked, nothing will be downloaded.

Function buttons

Browse Opens the Open dialog box.
This area is used to select the file to be download.

OK Validates the setting, downloads the specified file, and closes the dialog box.

Cancel Ignores the setting and closes this window.
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Output Setting dialog box

This dialog box is used to perform the settings necessary for saving the data of the pin being simulated to

an output file.

  It is also used to select whether the Output Timing Chart window is to be displayed.

Figure 6-74　Output Setting Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

• In the 78Kx Simulator GUI window
 Select [File] -> [Output...] on the menu bar
 (or press Alt,+F, and U in that order).

Explanation of each area

This dialog box consists of the following areas:

(1)　File output specification area

(2)　Timing chart output specification area
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(1) File output specification area

This area is used to select whether the data of the pin being simulated is to be saved to a file.

(2) Timing chart output specification area

This area is used to select whether the data of the pin being simulated is output as a timing chart.

Editing .out file as input data

1 Read a file (.out) by using the <Read> button in either the Input 0/1 Editor window or Input timing

Chart Editor window. 

2 The data is not displayed only by reading it.  Specify the name of a pin whose data has been saved

to the file (.out), by using the <Pin Set> button in the Input 0/1 Editor window.  The contents of the

file will be then displayed.

3 After editing the data, save the data to an input data file by using the <Save> button.

At this time, the identifier of the file must be .i_2. 

Function buttons

Output to file To save the data, check this check box.
To specify a file name (.out), click the <Browse> button and search a file name, 
or input a file name from the keyboard.
Remove the check from this check box if the data is not to be saved to a file, or to 
abort output of the data to the file.
Information on all the pins is output to the file (this is independent of timing chart 
output).

Enable timing chart Check this check box to output data in the form of a timing chart.
The data is displayed in the Output Timing Chart window.
Remove the check from the check box to not display the data as a timing 
chart.

Contents: Specify the contents to be displayed on a timing chart by using the option 
button.
output only  Saves information on the output pin.
Input/output  Saves information on the input/output pin.

Browse Opens the Open dialog box.
The specified file will be the output destination file.
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OK Validates the setting and closes the dialog box.
If "Output to file" is selected, the pin information is saved to a specified file.  If "Enable 
timing chart" is selected, the Output Timing Chart window is opened and the specified 
contents are displayed.

Cancel Ignores the setting and closes this dialog box.
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Output Timing Chart window

This window displays a timing chart of the data output from the program currently simulated and related

input data and interrupt signals.  It also displays the data from all the SFR on one window.

This window supports the project files of the debugger.

This window displays the data from all the SFR on one window.

Figure 6-75　Output Timing Chart Window

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This window can be opened as follows:

1 In the 78Kx Simulator GUI window

 Select [File] -> [Output...] from the menu bar

 (or press Alt+F, and U in that order).

2 In the Output Setting dialog box

Check [Enable timing chart] and click the <OK> button.

Explanation of each area

The Output Timing Chart window consists of the following areas:
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(1)　Wait Value: (wait value setting area)

(2)　 Information: (information display area)

(3)　Timing chart display area

(1) Wait Value: (wait value setting area)

Select a wait value (timing of display data) from the drop-down list 

The selected value will be one division of the Scale (unit: 1/4 main clock).

The values that can be selected from the drop-down list are: 16, 32, 64, 128, 256, 512,1024, 2048, 

4096, and 8192.

(2) Information: (information display area)

This area displays the wait value from the beginning of simulation to the part executed last, and the pin 

change point if the time axis is not displayed.  Double-clicking near the character Scale displays time 

axis cursor S and time axis marker E in the timing chart display area, and the following values:

Reference 1. Double-clicking in this area selects the "Display Off (non display)" and increases the

execution speed of simulation.  To turn the display on, double click again.

2. The wait value is displayed in units of 1/4 main clocks (1/4m-clk).

  The figure at the lower right part of this area indicates the change point of a pinNote.

Up to 1350 pin change points can be displayed.  If 1350 is exceeded, the information in the buffer is 

sequentially overwritten by the latest information, starting from the information at the beginning of the 

buffer (the displayed number of change points will not increase from 1350).  If two or more pins change 

at the same time, it is counted as only one change point.

Note: A change point means the location at which the data of a pin changes (H to L, L to H, or

between H/L and Z).

S Wait value from the beginning of simulation to the location indicated by S

E Wait value from the beginning of simulation to the location indicated by E

S(PC) PC value of the address at which the output value at the location indicated by the 
time axis cursor is generated

E-S Wait value from the location indicated by S to the location indicated by E
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(3) Timing chart display area

This area displays changes in the data of a specified pin as a timing chart.

A scroll bar that is used to scroll the timing chart up, down, to the left, and to the right is also displayed.

The HIGH and LOW signals are displayed in green.  The high-impedance signal is displayed in red at 

the center.  The information in a range not buffered is displayed in blue at the center.

In the default condition, nine signals are displayed.  Up to 48 signals can be displayed.

The size of this window can be varied.

Reference: Double-clicking in this area selects "Display Off (non display)" and increases the execution

speed of simulation.  To turn the display on, double click again.

Since the waveform of an input signal from external supplied to an input pin is displayed at

the CPU side reception timing (timing at which port is read by program or peripheral macro

reads input pin value), the waveform display timing may be slightly off compared to the

actual input timing.

To select pin to be buffered

By selecting All Pins or Selected Pins, which is displayed at reset, the information to be output to the 

output buffer during execution can be specified.

Pin Displays the name of the pin that has generated the timing chart, and 
interrupt signal pins.
For the pin name, either open the Pin Setting dialog box by using the <Pin 
Set> button and create a new pin name, or read a pin setting information 
file (.pin) by using the <Read> button on that dialog box.

Time axis cursor, 
time axis marker

Double-clicking near the character Scale displays a solid line and a dotted 
line.
The solid line is the time axis cursor (S) and the dotted line is the time axis 
marker (E).  After the time axis cursor and time axis marker have been 
displayed, each can be moved by dragging it with the mouse.
If the time axis cursor or time axis marker has been moved to the left in the 
timing chart setting area and therefore cannot be displayed in the area, S 
or E is displayed at the upper left part of the Scale field.  If the axis or 
marker has been moved to the right in the timing chart setting area and 
cannot be displayed in the area, S or E is displayed at the upper right part 
of the Scale field.
The time axis can be moved by dragging the character E or S.  If the time 
axis has been moved to a part that does not have data, "[]" is displayed on 
S or E.
If INT is specified as a pin name, an interrupt waveformNote is displayed.  If 
an interrupt occurs, the waveform is displayed as HIGH.

Note: An interrupt waveform is displayed as, for example, "+P0" if interrupt 
INTP0 occurs (if the interrupt request flag is set), and as "-P0" if that 
interrupt has been processed (if the interrupt request flag is cleared).  
If two or more interrupts occur at the same time, "+P0+P1" is 
displayed.  While two or more interrupts are occurring, the waveform 
changes its color from green to red.
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To turn off display of Function buttons and Information: (information display area)

The double rectangle at the lower left of the window is a toggle switch that is used to change the 

display object in the Output Timing Chart window. 

This toggle switch can be used to reduce the Output Timing Chart window.

If this toggle switch is clicked while the function buttons and the Information area are displayed, the 

display is changed as follows: 

Function buttons

Selecting All Pins Information on all the pins of the target device is output to the output 
buffer (default).

Selecting Selected Pins Only the information displayed in the Pin field of the Output Timing 
Chart window is output to the output buffer.

Clicking once Turns off display of the function buttons.

Clicking twice Turns off display of the function buttons and Information area.

Clicking three times Displays all (restores the originals status).

Pin Set Opens the Pin Setting dialog box
The specified pin will be set in the Pin field.

Search Opens the Search window
Data in the output data file can be searched.

Cancel Opens a confirmation dialog box.  If the <OK> button is clicked, closes the 
Output Timing Chart window.

Help Opens the Help window.
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Search window

This window is used to search data in an input data file or output buffer.

  It searches data displayed in the Input 0/1 Editor window, Input timing Chart Editor window, and Output

Timing Chart window.

Note that interrupt signals and analog input/output signals cannot be searched.

Once the set data has been searched, it is held until the simulator is terminated.  If this window is closed

once and then opened again, the previous information is displayed.

Figure 6-76　Search Window

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This window can be opened as follows:

• Click the <Search> button in the Input 0/1 Editor window

• Click the <Search> button in the Input timing Chart Editor window

• Click the <Search> button in the Output Timing Chart window

Explanation of each area

The Search window consists of the following areas:

(1)　Search data setting table
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(1) Search data setting table

This area is used to set the pattern of the data to be searched for each pin.

Eight pins are displayed in five stages in the default condition.  The number of pins and stages 

displayed can be changed.

In the search data setting table, 1 (HIGH), Z (high impedance), 0 (LOW), or - (don't care) can be set.

An analog input pin, analog output pin, and interrupt signal cannot be searched.

Searching data

1 Set data to be searched.

If a pin name is set in the Pin field, EOF is set in the data setting table.  By clicking this EOF, one

line of data to be searched can be inserted.  In the clicked field, data is set with the pin status on the

immediately preceding line changed to the next alternative (1, Ｚ ,  -, and 0, in that order).  In the

other fields, data with the same status as that on the immediately preceding line is set.

The data to be searched can be changed in the order of 1, Z, -, and 0, by clicking the mouse.

2 Start searching.

In the Input timing Chart Editor window or, Output Timing Chart window
The searching can be started by clicking the <B Search> or <F Search> button. 

The data that matches the specified data is indicated by a red line.

By clicking the <S Mark Set> or <E Mark Set> button at this time, a time axis can be set at the

matching data.

Once matching data has been found, searching is started again from that part, unless the data to

be searched is changed or the display is scrolled.

In the Input 0/1 Editor window
The searching can be started by clicking the <U Search> or <D Search> button. 

The data that matches specified data is displayed at the top.  No red line is displayed in this case.

To set new data to be searched

Erase the old data by clicking the <Clear> button and then set new data.

Two windows cannot be opened at the same time.

Function buttons

Pin Specify the name of the pin whose data is to be searched.
For the pin name, either open the Pin Setting dialog box by using the <Pin Set> 
button and create a new pin name, or read a pin setting information file (.pin) by 
using the <Open> button on that dialog box.  If a display name is set for the pin, the 
display name is displayed.

B Search Searches for matching data from the end of the part currently displayed toward the 
beginning.
To search data in the Input 0/1 Editor window, this button is replaced by the <U 
Search> button.
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F Search Searches for matching data from the beginning of the part currently displayed 
toward the end.
To search data in the Input 0/1 Editor window, this button is replaced by the <D 
Search> button.

Pin Set Opens the Pin Setting dialog box
The specified pin will be set in the Pin field.

Clear Clears all the set contents.

S Mark Set This button can be selected if data that matches the specified data has been found 
as a result of a search.
When this button is selected, the time axis cursor S moves to the position of the 
matching data.
This button is valid only if data is searched in the Input timing Chart Editor window or 
Output Timing Chart window.

E Mark Set This button can be selected if data that matches the specified data has been found 
as a result of a search.
When this button is selected, the time axis marker E moves to the position of the 
matching data.
This button is valid only if data is searched in the Input timing Chart Editor window or 
Output Timing Chart window.

Cancel Closes this window.

Help Opens the Help window.
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Parts window

This window is used to configure a dummy target system.  It displays external parts.

The Parts window can be used to configure a dummy target system by setting external parts.  The set

external parts are displayed in this window, and are used as pins of signals during simulation in the

execution mode.

In addition, these components can also be moved in the window in the placement mode.

Information on the component placed in the window can be saved to a file (.pnl).  In addition, the saved

file can be read.

Caution: For the operation of the I/O panel when the CPU is reset, refer to "4. 1. 3 Operation of

external parts at CPU reset".

Figure 6-77　Parts Window

This section explains the following items:

• Opening

• Toolbar

• Menu bar

• Setting
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Opening

This window can be opened as follows:

• In the 78Kx Simulator GUI window
Select [External Parts] -> [Panel Window...] from the menu bar 
 (or press Alt+E, and P in that order).

Toolbar

The toolbar is used to open each external component setting window (except the Serial GUI window).

The same operation can be also performed by selecting the [Parts] menu.

Display of the toolbar can be alternately turned on or off by selecting [Option] -> [Tool Bar] from the menu

bar.

Figure 6-78　Toolbar (Parts Window)

Opens the Buttons window.

Opens the Key Matrixes window.

Opens the LCDs window.

Opens the FIPs window.

Opens the LEDs window.

Opens the 7seg LEDs window.

Opens the Level Gauges window.

Opens the DC Motors window.

Opens the Buzzers window.

Displays a reset button in the window.

Opens the 14seg LEDs window.

Opens the Internal Interrupt Button window.

Opens the Pull-Up / Pull-Down window.
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Menu bar

Displaying the menu bar can be turned on or off by selecting [MENU Valid] in the control menu box of this

window.

(1) [File] menu

Select this menu to save information on the Parts window to a file (.pnl) or read saved information from 

a file.

(2) [Mode] menu

This menu is used to select the mode in which simulation is executed (execution mode) or the mode in 

which an external component can be connected to a pin or the placement of an external pin can be 

changed (placement mode), in the window.

Cannot be selected.

Cannot be selected.

Cannot be selected.

Cannot be selected.

Cannot be selected.

Cannot be selected.

Cannot be selected.

Open... Opens the Open dialog box.
Information on the Parts window can be read from a specified file (.pnl).

Save Overwrites and saves the current information on the Parts window to the file 
currently being read (.pnl).

Save As... Opens the Save As dialog box.
The current information on the Parts window can be saved to a specified file 
(.pnl).

eXit Closes this window.



CHAPTER 6  WINDOW REFERENCE

User’s Manual  U16768EJ1V0UM 355

(3) [Edit] menu

This menu is used to move or edit the external part displayed on the Parts window, so that the user can 

freely create the image of a system.

This menu can be selected only in the placement mode. 

Edit Displays a dialog box that indicates the position (x and y coordinates) of the 
mouse cursor and sets the window in the placement mode.
This menu is used to move or edit the external component displayed on the Parts 
window, can be select the [Edit] menu.

Simulation Sets the window in the execution mode.
The simulation of parts is possible (default).

Draw Cannot be selected.

seT Cannot be selected.

Undo Restores the original status after a change, such as moving a component, 
has been made in the window.

Delete If this is selected when a component has been selected by the mouse, the 
selected component is deleted.

cuT Cannot be selected.

Copy Cannot be selected.

Paste Cannot be selected.

Import from File... Cannot be selected.

teXt Opens a dialog box for inputting characters.
In this dialog box, input a character, click the location at which the character 
is to be placed, and then click the <OK> button.
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(4) [Parts] menu

Select this menu to set the connection relationship with the supplied external parts.

When setting is complete, the corresponding component is displayed in this window and is used as the 

pin for inputting/outputting signals during simulation.

If the submenu is selected, the corresponding setting window is opened and the environment of the 

connection between pins and external parts can be set.

Line Select this to draw a straight line in the window.
Select any of the following from the submenu:

Solid Draws a solid line.

Dash Draws a dashed line.

dOt Draws a dotted line.

dAshdot Draws an alternate long and short dash line.

Rectangle Select this to draw a rectangle in the window.
Select any of the following from the submenu:

Solid Draws a rectangle in solid line.

Dash Draws a rectangle in dashed line.

dOt Draws a rectangle in dotted line.

dAshdot Draws a rectangle in an alternate long and short dash line.

Bitmap Select this to change the bitmap of the component displayed in the window 
(button and DC motor only).
Open the Bitmap window and select a bitmap (the selected bitmap will be 
highlighted).  Click the position at which a new bitmap is to be pasted.

Suspend Select this to stop editing such as input and to move, delete, or undo the 
editing of a component.

Button... Opens the Buttons window

 button’s operation is the same as clicking this button. 
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Key Matrix... Opens the Key Matrixes window

 button’s operation is the same as clicking this button. 

built in LCD... Opens the LCDs window

 button’s operation is the same as clicking this button. 
Can be selected only when LCD built-in device is selected.

built in FIP... Opens the FIPs window

 button’s operation is the same as clicking this button. 
Can be selected only when FIP built-in device is selected.

LED... Opens the LEDs window

 button’s operation is the same as clicking this button. .

7Seg LED... Opens the 7seg LEDs window

 button’s operation is the same as clicking this button. .

Level Gauge... Opens the Level Gauges window

 button’s operation is the same as clicking this button. 
Note that this item can be selected only with a device that includes an 
internal A/D converter.

DC Motor... Opens the DC Motors window

 button’s operation is the same as clicking this button. 

BuZzer... Opens the Buzzers window

 button’s operation is the same as clicking this button. 

Reset... Displays a reset button in the window.
If the reset button is clicked during simulation, a reset signal is input to the 
simulator.

 button’s operation is the same as clicking this button. 

14Seg LED... Opens the 14seg LEDs window

 button’s operation is the same as clicking this button. 

Internal Interrupt... Opens the Internal Interrupt Button window

 button’s operation is the same as clicking this button. 

Pull Up/Pull DoWn... Opens the Pull-Up / Pull-Down window

 button’s operation is the same as clicking this button. 

PLL... Cannot be selected.

Serial GUI... Opens the Serial GUI window of the corresponding channel when the 
submenu is selected. 
The submenu differs depending on the device.
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(5) [Bitmap] menu

(6) [Customize] menu 

Select this menu to load the file (.dll) necessary for using the external component created by the user.

Caution: If the Parts window is closed with information on the user DLL saved or loaded to a

project file, the position of the user custom component displayed in the Parts window

is different from the position that was saved to the file, even if the user DLL is read by

opening a load or project file.

(7) [Draw] menu

Cannot be selected.

(8) [Option] menu

Bitmap ENtry Opens the Bitmap Entry window

Load... Opens the Read dialog box.
The specified user DLL file will be read.  Up to 6 files can be read.

Unload Invalidates all the user DLL files currently loaded.

Tool Bar Turns on or off display of the toolbar.  If this is checked, the toolbar is displayed 
(default).

Group Cannot be selected.

Ungroup Cannot be selected.
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(9) [Help] menu

Setting

Input operation from external parts

An input operation from an external parts is enabled if the Parts window is in the execution mode.  For 

details, refer to the setting dialog box page of each component.

Displaying external parts

The external parts displayed in the setting dialog box of each external parts is displayed in the Parts 

window according to the following rules:

•  If components are cascade displayed, the component displayed first is shown in front.  Therefore, a
component newly created may be hidden behind the component displayed first.   In this case, move
the new component forward.

•  If components that are cascade displayed are saved to the information file (.pnl) or project file (.prj)
of the window and then the components are displayed by reading information from these files, the
components are displayed in this order: Button -> Key matrix -> LED -> 7-segment LED -> Level
gauge -> DC motor -> Buzzer -> Reset button -> 14-segment LED -> Internal interrupt button.

Scroll bar

If the components do not fit in the Parts window while they are connected, a scroll bar is displayed.

By using this scroll bar, even components that are larger than the screen can be created.  In addition, 

the screen can also be reduced so that only the desired component is viewed.

The scroll bar can be manipulated regardless of the mode.

Editing in Parts window

The following editing modes of the Parts window can be used when the window is in the placement 

mode:

•  <Moving external parts, characters, lines, and rectangles>

•  <Deleting external parts, characters, lines, and rectangles>

Pen... Cannot be selected.

Brush... Cannot be selected.

Font.... Cannot be selected.

Raise Cannot be selected.

Lower Cannot be selected.

SM78Kx Help Opens the Help window of SM78Kx.

This Window Opens the Help window.
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•  <Restoring modification>

•  <Input characters>

•  <Inputting lines>

•  <Inputting rectangles>

•  <Re-pasting bitmaps>

•  <Stopping editing>

•  <Other>

In the placement mode, the following window indicated by the mouse position and the coordinates is 

displayed.

Figure 6-79　Mouse Position and Coordinates

<Moving external parts, characters, lines, and rectangles>

1 Click the component (external componentNote, character, line, or rectangle) to be moved.

-> The selected external component is indicated by a blue dotted line.  If a character, line, or

rectangle is selected, the display color changes from black to blue.

2 While holding down the left mouse button on the selected component, move (drag) the component.

Release the mouse button when the component has reached the desired position.

-> The selected component will move to the specified position.

To move two or more components at the same time, click the second component while holding

down the Shift key, and drag and drop it, still holding down the Shift key.

Up to 16 components can be selected at the same time.

Note: An external component can be moved in units of the pin connected to it.

A 7-segment LED or 14-segment LED can be moved in component units.

<Deleting external parts, characters, lines, and rectangles>

1 Click the component (external componentNote, character, line, or rectangle) to be moved.

-> The selected external component is indicated by a blue dotted line.  If a character, line, or

rectangle is selected, the display color changes from black to blue.

2 Select [Edit] -> [Delete] from the menu bar.

->The selected component will be deleted.

To delete two or more components at the same time, click the second component while holding

down the Shift key, and select [Edit] -> [Delete] from the menu bar.  

Note: An external component is deleted in units of the pin connected to it.

A 7-segment LED or 14-segment LED is deleted in component units.
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<Restoring modification>

If any modification has been made on the Parts window, one status before the modification can be 

restored by selecting [Edit] -> [Undo] from the menu bar.

Modifications cannot be restored retrogressively.

<Input characters>

Up to 20 character strings can be written in the window.

1 Select [Edit] -> [TeXt] from the menu bar.

-> A dialog box requesting input of characters will be opened.

1 Click the part of the Parts window where characters are to be input.

->The clicked part is marked.

2 Move the cursor to the character input dialog box, and input a character string from the keyboard.

The number of characters that can be input at one time is 20 characters.

3 Click the <OK> button.

-> The input character string will be written at the position specified in 2.

<Inputting lines>

Up to 20 lines can be drawn in the window.

1 Select [Edit] -> [Line] from the menu bar.  Select the line type from the submenu.

2 Determine the start position using the left mouse button.

3 If the mouse is moved, a straight line will be displayed from the start and end points of the mouse

movement.

4 Determine the end point of the line by clicking the left mouse button.

->The start point and end point will be connected with a straight line (the thickness of the line is

fixed).

<Inputting rectangles>

Up to 20 rectangles can be drawn in the window.

1 Select [Edit] -> [Rectangle] from the menu bar.  Select the line type from the submenu.

2 Determine the position of the upper left corner of the rectangle using the left mouse button.

3 Move the mouse.  A rectangle will be displayed, with the current mouse position assumed as the

lower right corner.
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4 Determine the lower right corner of the rectangle by clicking the left mouse button.

->A rectangle will be displayed between the upper left corner previously specified and the current

position of the mouse (the thickness of the lines is fixed).

<Re-pasting bitmaps>

The bitmap of an external component (button and DC motor only) can be replaced with another bitmap 

that has already been registered.

For how to register a bitmap file, refer to the explanation of the Bitmap Entry window.  Note that the 

bitmap window explained below and the Bitmap Entry dialog box cannot be manipulated at the same 

time.

1 Select [Edit] -> [Bitmap] from the menu bar.

->The bitmap window will open.

2 Click the bitmap to be replaced from the bitmap window that has been opened.

->The selected bitmap will be highlighted.

3 Click the external component that is to be replaced in the Parts window.

->The bitmap selected in 2 will be replaced by the external component in the Parts window.

If a button is replaced with another bitmap, the function name is not displayed.

<Stopping editing>

To move, delete, or restore a component after a character, line, or rectangle has been input or a bitmap 

has been replaced, select [Edit] -> [Suspend] from the menu bar.  [Suspend] on the pull-down menu 

will be checked, and the component being edited can be moved, deleted, or restored.

This field is also checked immediately after the mode has been changed to the placement mode.

<Other>

When inputting a character, line, or rectangle, or when a bitmap box is selected, the editing function 

currently selected persists until another editing function, such as inputting another character, line, or 

rectangle, or selecting another bitmap, or stopping editing, is selected.
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Buttons window

This window is used to set or change the connection information of the button to be displayed in the Parts

window.  

Data can be input to the simulator from the displayed button.  

The connection information can be saved to a file (.btn).  In addition, the saved file can be read.

Caution: To set a button, follow these steps:

1.  Set a pull-up/down resistor (refer to "Pull-Up / Pull-Down window" ).

2.  Set a button.

If a button has been set first, open the Buttons dialog box again after setting a pull-up/

down resistor, and click the <OK> button.

When the button is pressed, the value specified by the [Active] option button in the

connection information area is input to the input pin connected to the button.

When the button is not pressed, the value specified in the Pull-Up / Pull-Down windowis

assumed.

When a pull-up/down resistor is not set, the simulator assumes that the value when the

button is not pressed is 0.

Figure 6-80　Buttons window

This section explains the following items:

• Opening

• Explanation of each area

• Setting

• Function buttons
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Opening

This window can be opened as follows:

1 In the 78Kx Simulator GUI window

Select [External Component] -> [Parts...] from the menu bar 

 (or press Alt+E, and P in that order).

2 Click the  button in the Parts window.

 or select [Parts] ->  [Button...] from the menu bar 

 (or press Alt+P, and B in that order).

Explanation of each area

The Buttons window consists of the following areas:

(1)　Button ID display area

(2)　Connection information setting area

(3)　Hold Time (hold time setting area)

(1) Button ID display area

This area displays the ID number to be assigned to the button to be set.

To set five or more buttons, click the <Next Page> button.  The set information will be cleared and the 

ID number will be updated.

Up to 32 ID numbers can be set.

(2) Connection information setting area 

This area is used to set or display information on the connection between a button and a pin.  

Set each field in this area.  

Function This check box specifies whether the button is provided with a toggle function or a 
push function.
If this check box is checked, the toggle function is provided.  When the push 
function is provided, a hold time must be set.

BMP ID Specify the registration number of the bitmap when the button is displayed on the 
Parts window, in numerals.  
If an ID number does not exist or if no ID number is specified, a bitmap with 
registration number 3 is selected as default (refer to "Bitmap Entry window").
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(3) Hold Time (hold time setting area)

This area sets the hold time of a button for which the push function is specified.  

The settable range is 0.001 ms to 999 ms.  The default value is 0.5 ms.

Setting

Input operation of button

By pressing the displayed button, data can be input to the pin connected to the button.

Display example:

The data that can be input differs depending on whether the toggle or push function is provided for the 

button.

<Button with toggle function>

Each time the button is pressed, the information at that point is loaded to the simulator.  The input 

value is retained and simulation continues until the button is pressed again.

<Button with push function>

By pressing the button, the information at that point is loaded to the simulator.  The input value is 

retained for the hold time of the button and simulation continues.  When the hold time has expired, the 

value returns to the original value.

Name Specify the character string to be displayed above the button.  Up to 8 characters 
can be input in characters.  

Pin Specify the name of the pin to be connected to the button.  
Up to eight characters can be input.
For the specifiable pin names, refer to the user's manual of the device used.

Active Specify the active status of the set button by using the option button.  The default 
status is active-high (H).
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Function buttons

Previous Displays the setting four ID numbers before the ID number currently displayed, 
in each area.

Next Displays the setting four ID numbers after the ID number currently displayed, in 
each area.

OK Checks for errors in the set connection information.
If an error or warning has occurred, a message is displayed on the dialog box.  
If an error or warning has not occurred, control is transferred to the Parts 
window, and the set external component is displayed.

Open Opens the Open dialog box.
Connection information will be read from a previously saved file (.btm).

Save Opens the Save As dialog box.
The displayed connection information will be saved to a file (.btm).

Clear Clears the set contents.

Cancel Ignores the setting and closes this window.

Help Opens the Help window.
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Key Matrixes window

This window is used to set or change the connection information of the button to be displayed in the Parts

window.  

Data can be input to the simulator from the displayed button.  

A key matrix consisting of input and output pins can be specified in units of 4-4, and a matrix of up to 16-

16 can be specified. 

The connection information can be saved to a file (.key).  In addition, the saved file can be read.

Caution: To set a key matrix, follow these steps:

1.   Set a pull-up/down resistor (refer to "Pull-Up / Pull-Down window" ).

2.   Set a key matrix.

If a key matrix has been set first, open the Key Matrixes dialog box again after setting a

pull-up/down resistor, and click the <OK> button.

When a key is pressed, the output value of the output pin connected to that key is input

to the input pin connected to the key.

When the key is not pressed, the value specified in the Pull-Up / Pull-Down windowis

assumed.

If a pull-up/down resistor is not set, the simulator assumes the value when the key is

not pressed is 0. 

Figure 6-81　Key Matrixes window

This section explains the following items:

• Opening

• Explanation of each area

• Setting

• Function buttons
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Opening

This window can be opened as follows:

1 In the 78Kx Simulator GUI window

Select [External Parts] -> [Panel Window...] from the menu bar 

 (or press Alt+E, and P in that order).

2 Click the  button in the Parts window.

 or select [Parts] -> [Key Matrix...] from the menu bar 

 (or press Alt+P, and K in that order).

Explanation of each area

The Key Matrixes window consists of the following areas:

(1)　 In Pin, Out Pin (input/output pin setting area)

(2)　Key name setting area

(3)　Hold Time (hold time setting area)

(4)　Set NO. (successive setting area)

(5)　Set position display area

(1) In Pin, Out Pin (input/output pin setting area)

This area is used to set the name of the input pin (pin input to the simulator: " Ix" (x indicates a 

numeral) is displayed in the default condition) and the name of the output pin (pin output by the 

simulator: "Ox" is displayed in the default condition) that constitute a key matrix.

Up to eight characters can be input.

Caution: For the specifiable pin names, refer to the user's manual of the device used.
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(2) Key name setting area

This area is used to specify the character string that is displayed above a key when a key matrix is 

displayed on the Parts window. 

Up to 6 characters can be input.  

In the default condition, the set number "Nx" (x indicates a numeral) is displayed in each setting area.

(3) Hold Time (hold time setting area)

This area is used to specify the time for which the input value is to be held.  The settable range is 0.001 

to 999 ms.  The default value is 0.5 ms.

If two or more keys that are input to input pins of the same name are clicked within the specified hold 

time, the key clicked last is valid.

(4) Set NO. (successive setting area)

This area is used to set pin and key names successively.

Select the default set number (Ix,Ox,Nx) from the pull-down menu, and input the corresponding pin 

name or key name to the text area on the right and press the return key.  The input pin name or key 

name will be then reflected in the setting area below.

(5) Set position display area

This area indicates the position of the currently displayed key matrix in the 16-16 key matrix setting 

area by a white area.

To move the set position, use the following four buttons:

Up Displays the set contents with the input setting pin shifted four positions up, 
without the output setting pin being affected.
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Setting

To operate two or more keys simultaneously

Click one of the keys to be input simultaneously with the right mouse button to set in the wait status 

(displayed in red).  Next, click the other key with the left mouse button.  This releases the first key from 

the wait status, enabling both the keys to be input at the same time.  By setting two or more keys in the 

wait status, more than two keys can be input simultaneously.  If the keys are input to the same input 

pin, however, the key input last is valid.

To lock input value of key

If a key is clicked with the left mouse button with the right button held down, the input value of that key 

at that time is locked (displayed in green).  If a key that is input to the same input key as the locked key 

is clicked at this time, the input value of the key input last is valid.  If the hold time of that key has 

elapsed, however, the input value while the key is locked is assumed again.

If the locked key is clicked with the left mouse button, the key is unlocked.  If it is clicked with the right 

mouse button, the key is placed in the wait status (displayed in red).

Function buttons

Down Displays the set contents with the input setting pin shifted four positions 
down, without the output setting pin being affected.

Right Displays the set contents with the input setting pin shifted four positions to 
the right, without the output setting pin being affected.

Left Displays the set contents with the input setting pin shifted four positions to 
the left, without the output setting pin being affected.

OK Checks for errors in the set connection information.
If an error or warning has occurred, a message is displayed on the dialog box.  
If an error or warning has not occurred, control is transferred to the Parts 
window, and the set external component is displayed.

Open Opens the Open dialog box.
Connection information will be read from a previously saved file (.key).

Save Opens the Save As dialog box.
The displayed connection information will be saved to a file (.key).

Clear Clears the set contents.

Cancel Ignores the setting and closes this window.

Help Opens the Help window.
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LCDs window

This window makes settings related to the LCD.

Either the LCD Display window or the LCD Panel window can be displayed by selecting the appropriate

LCD display image (Bit Image/Customize).

The setting information can be saved to a file (.sld), and information saved to a file can be read.

Figure 6-82　 LCDs window

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This window can be opened as follows:

1 In the 78Kx Simulator GUI window

Select [External Parts] -> [Panel Window...] from the menu bar 

 (or press Alt+E, and P in that order).

2 Click the  button in the Parts window.

 or select [Parts] -> [built in LCD...] from the menu bar 

 (or press Alt+P, and C in that order).

Explanation of each area

The LCDs window consists of the following areas:
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(1)　Disp (LCD display image selection area)

(2)　Bias (Bias method selection area)

(3)　Time Div (Time division count selection area)

(4)　Segment NO. (Display segment number setting area)

(1) Disp (LCD display image selection area)

This area selects the LCD display image.

(2) Bias (Bias method selection area)

This area selects the bias method.  Setting this allows the displayed image to be changed.

The default is "-" (hyphen), which fixes the displayed image.

(3) Time Div (Time division count selection area)

This area selects the number of time divisions. Setting this allows the display timing of the common 

signals to be changed.

The default is "static".

(4) Segment NO. (Display segment number setting area)

This area sets the range of the segment numbers that are to be displayed. Setting this allows display of 

only the desired segments. Either of the text boxes can be used to specify the number of the segment 

from which display will start.

Bit Image Displays a bit image.
Select Bit Image and click the <OK> button. The LCD Display window is then
opened displaying a bit image of the common and segment signal matrix.

Customize Customized display.
Select Customize and click the <OK> button. The LCD Panel window is then
opened.
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Function buttons

OK Displays the LCD Display window as a bit image of the common and segment 
signal matrix when Bit Image is selected in the LCD display image selection 
area.
Opens the LCD Panel window when Customize is selected in the display area.

Open Opens the Open dialog box.
Connection information will be read from a previously saved file (.sld).

Save Opens the Save As dialog box.
The displayed connection information will be saved to a file (.sld).

Clear Clears the set contents.

Cancel Ignores the setting and closes this window.

Help Opens the Help window.
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LCD Panel window

This window displays the output of the pins connected to the device’s internal LCD controller/driver as bit

and graphic images.

The LCD Panel window creates and edits LCD images.

During simulation, return to the Parts window by selecting [Mode] -> [Simulation] on the menu bar.

Figure 6-83　 LCD Panel window

This section explains the following items:

• Opening

• Toolbar

• Menu bar

• Setting

Opening

This window can be opened as follows:

1 In the 78Kx Simulator GUI window

Select [External Parts] -> [Panel Window...] from the menu bar 

 (or press Alt+E, and P in that order).

2 Click the  button in the Parts window.

 or select [Parts] -> [built in LCD...] from the menu bar 

 (or press Alt+P, and C in that order).

3 In the LCDs window

Select Customize under Disp

Toolbar

Display of the toolbar can be alternately turned on or off by selecting [Option] -> [Tool Bar] from the menu

bar.
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Figure 6-84　Toolbar (LCD Panel Window)

Menu bar

Displaying the menu bar can be turned on or off by selecting [MENU Valid] in the control menu box of this

window.

(1) [File] menu

Select this menu to save information on the LCD Pnel window to a file (.lcd) or read saved information 

from a file.

(2) [Mode] menu

In the case of the LCD Panel window, this menu can be used to move, group, or modify the size of 

Arbitrary character strings can be described.
This cannot be selected when the Parts window is active.

Straight lines of arbitrary length can be drawn.
This cannot be selected when the Parts window is active.

Rectangles of arbitrary size can be drawn.
This cannot be selected when the Parts window is active.

Ellipses of arbitrary size can be drawn.
This cannot be selected when the Parts window is active.

Pies of arbitrary size can be drawn.
This cannot be selected when the Parts window is active.

Polygons of arbitrary size can be drawn.
This cannot be selected when the Parts window is active.

Open... Opens the Open dialog box.
Information on the LCD Panel window can be read from a specified file (.lcd).

Save Overwrites and saves the current information on the LCD Panel window to the 
file currently being read (.lcd).

Save As... Opens the Save As dialog box.
The current information on the LCD panel window can be saved to a specified 
file (.lcd).

eXit Closes this window.
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graphics (edit mode), to draw graphics (draw mode), or to connect pins to the customized LCD 

graphics (set mode).

Also, by selecting [Simulation], the window is changed to the Parts window at the moment the 

simulation mode is set.

(3) [Edit] menu

This menu is used to move or edit the external part displayed on the LCD Panel window, so that the 

user can freely create the image of a system.

This menu can be selected only in the placement mode. 

Edit Displays a dialog box that indicates the position (x and y coordinates) of the 
mouse cursor and sets the window in the placement mode.
This menu is used to move or edit the external component displayed on the Parts 
window, can be select the [Edit] menu.

Simulation Sets the window in the execution mode.
The simulation of parts is possible. (default)

Draw Sets the window in the draw mode, in which LCD display image graphics can be
drawn using the [Draw] menu.

seT Sets the window in the set mode, in which the display timing and display 
segment connections can be set for the LCD display image graphics.
If this mode is selected, the [Edit], [Draw], and [Option] menus become 
unselectable.

Undo Restores changes in the window, such as movement of graphics or character 
strings, to the status immediately before.

Delete If a graphic or character string is selected with the mouse and [Delete] is 
clicked, the selected graphic or character string is deleted.
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(4) [Parts] menu

Select this menu to set the connection relationship with the supplied external parts.

Refer to the description of the [Parts] menu in the Parts window for an explanation of this menu.

(5) [Bitmap] menu

Cannot be selected.

(6) [Customize] menu

Cannot be selected.

(7) [Draw] menu

This menu can be used to draw LCD display image graphics in the LCD Panel window.

This menu can be selected only in the draw mode.

cuT If a graphic or character string is selected with the mouse and [cuT] is 
clicked, the selected graphic or character string is deleted and copied to the 
clipboard.

Copy If a graphic or character string is selected with the mouse and [Copy] is 
clicked, the selected graphic or character string is copied to the clipboard.

Paste The data copied to the clipboard is pasted to the upper left corner of the LCD 
Panel window.

Import from File... Opens the Open dialog box. Pastes the specified bitmap file (.bmp) to the 
upper left corner of the LCD Panel window.

teXt Cannot be selected.

Line Cannot be selected.

Rectangle Cannot be selected.

Bitmap Cannot be selected.

Suspend Cannot be selected.

Text Arbitrary character strings of up to 40 characters per string can be described.

 button’s operation is the same as clicking this button.

7Segment Displays a 7-segment numerical LED. Each of these segments becomes an 
LCD display segment.
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(8) [Option] menu

14SeGment Displays a 14-segment alphanumerical LED. Each of these segments 
becomes an LCD display segment.

Line Straight lines of arbitrary length can be drawn.

 button’s operation is the same as clicking this button.

Rectangle Rectangles of arbitrary size can be drawn.

 button’s operation is the same as clicking this button.

Elipse Circles of arbitrary size can be drawn.

 button’s operation is the same as clicking this button.

Pie Pies of arbitrary size can be drawn.

 button’s operation is the same as clicking this button.

POlygon Polygons of arbitrary size can be drawn.

 button’s operation is the same as clicking this button.

EDit Drawn graphics can be selected. This function can be selected when graphic 
drawing is aborted in the draw mode.

Tool Bar Turns on or off display of the toolbar.  If this is checked, the toolbar is displayed 
(default).

Group Several LCD graphics can be edited as a single graphic (grouping). This function is 
not available for 7- and 14-segment LEDs.

Ungroup Returns grouped graphics to their original state.

Pen... Changes the status of the line being drawn or the graphic currently selected. The 
color, width, and type of the line can be specified in the opened dialog box.

Brush... Changes the brush of the graphic being drawn or the graphic currently selected. The 
style, color, and size of the brush can be specified in the opened dialog box.

Font.... Changes the font of the character string being typed or the character string currently 
selected. The font and font size can be specified in the opened dialog box.

Raise Places the selected graphic in the front of the cascaded graphics.

Lower Places the selected graphic at the back of the cascaded graphics.
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(9) [Help] menu

Refer to the description of the [Help] menu in the Parts window for an explanation of this menu.

Setting

Editing in LCD Panel window

The following editing modes of the LCD Panel window can be used when the window is in the 

placement mode:

•  <Moving graphics>

•  <Cutting, copying and deleting graphics>

•  <Pasting graphics>

•  <Importing graphic from file>

•  <Changing graphic size>

•  <Character insertion>

•  <Drawing 7/14 segments>

•  <Drawing lines>

•  <Drawing rectangles, circles, and pies>

•  <Drawing polygons>

•  <Grouping>

•  <Ungrouping>

•  <Raising>

•  <Lowering>

In the placement mode, the following window indicated by the mouse position and the coordinates is 

displayed.

Figure 6-85　Mouse Position and Coordinates

<Moving graphics>

1 Click the gurafic to be moved.

-> Marks appear at the vertices and midpoints of the box around the selected graphic.

2 While holding down the left mouse button on the selected graphic, move (drag) the graphic.

Release the mouse button when the graphic has reached the desired position.

-> The selected graphic will move to the specified position.

To move two or more graphics at the same time, click the second graphic while holding down the

Shift key, and drag and drop it, still holding down the Shift key.

Up to 16 graphics can be selected at the same time.
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<Cutting, copying and deleting graphics>

1 Click the graphic to be cut, copied, or deleted.

-> Marks appear at the vertices and midpoints of the box around the selected graphic.

2 Select [cuT], [Delete], or [Copy] from the [Edit] menu.

-> The selected part will be cut, copied, or deleted.

Alternatively, if there is more than one part to be edited, click the relevant parts while holding down

the Shift key, and then cut, copy, or delete using procedure 2 above. 

<Pasting graphics>

1 Select either the Windows paintbrush, or [cuT]/[Copy] from the [Edit] menu.

-> The selected graphic is copied to the clipboard.

2 Select [Paste] from the [Edit] menu.

-> The data on the clipboard is pasted to the lower right of the cut or copied graphic.

<Importing graphic from file>

Up to 20 character strings can be written in the window.

1 Create a bitmap file using the image editor (etc.).

2 Select [Import from File...] from the [Edit] menu.

-> The Open dialog box is opened.

3 Select the bitmap file to be imported from the dialog box.

-> The bitmap image of the selected bitmap file is pasted to the upper left corner of the LCD Panel

window.

<Changing graphic size>

1 Click the graphic whose size is to be changed.

-> Marks appear at the vertices and midpoints of the box around the selected graphic.

2 Click the mouse on a mark and drag the graphic until the desired size is reached.

-> The graphic is enlarged/reduced.

<Character insertion>

1 Select [Text] from the [Draw] menu.

-> A dialog box for inputting characters opens when the mouse is clicked at the desired display

position.

2 Type the character string to be displayed in this dialog box and click anywhere outside the text box

in the LCD Panel window.

<Drawing 7/14 segments>

1 Select [7Segment] or [14seGment] from the [Draw] menu.
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2 Click the mouse at the desired display position in the LCD Panel window.

-> The selected segment image is displayed at the position where the mouse was clicked.

<Drawing lines>

1 Select [Line] from the [Draw] menu.

2 Click the mouse where the line is to start.

3 Move the mouse. A straight line appears where the mouse is moved.

4 Click the mouse button where the line is to end.

-> The start and end points are connected by a straight line.

<Drawing rectangles, circles, and pies>

1 Select [Rectangle], [Ellipse], or [Pie] from the [Draw] menu.

2 Click the mouse where the rectangle, circle, or pie is to be drawn and hold the button down on a

vertex.

3 Drag the mouse. A rectangle appears from the vertex from which the mouse is dragged.

4 Release the mouse button when the rectangle has reached the desired size. In the case of circles

or pies, these will be drawn inside this rectangle.

<Drawing polygons>

1 Select [POlygon] from the [Draw] menu.

2 Click the mouse where the polygon is to be drawn and set a vertex.

3 Move (or drag) the mouse to the next vertex. A line (curve) appears from the vertex from which the

mouse is moved (dragged).

4 Click the mouse after arriving back at the original vertex. A polygon will be drawn with the lines

connected in the order clicked.

<Grouping>

1 Click the graphics to be grouped (to select two or more graphics, click the relevant graphics while

holding down the Shift key).

-> Marks appear at the vertices and midpoints of the box around the selected graphic.

2 Select [Group] from the [Option] menu.

-> The selected graphics become one, and marks appear at the vertices and midpoints of the box

around the grouped graphics.

<Ungrouping>

1 Click the graphic to be ungrouped.

-> Marks appear at the vertices and midpoints of the box around the selected graphic.

2 Select [Ungroup] from the [Option] menu.

-> The selected graphic returns to its pregrouped state, and marks appear at the vertices and

midpoints of the boxes around each graphic.
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<Raising>

1 Click the graphic to be displayed in front of the cascaded graphics.

-> Marks appear at the vertices and midpoints of the box around the selected graphic.

2 Select [Raise] from the [Option] menu.

-> The selected graphic is displayed in the front. The order of the other cascaded graphics does not

change.

<Lowering>

1 Click the graphic to be displayed at the back of the cascaded graphics.

-> Marks appear at the vertices and midpoints of the box around the selected graphic.

2 Select [Lower] from the [Option] menu.

-> The selected graphic is displayed at the back. The order of the other cascaded graphics does

not change.
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Set LCD Pin dialog box

This dialog box connects the bitmaps and graphics in the LCD Panel window to the LCD output pins.

If LCD output pin signals are already connected to the selected graphic, this connection information will

be displayed in the dialog box, enabling the user to check the graphic/signal connections. Note that the

active status of each signal is active high.

Figure 6-86　Set LCD Pin dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

• Cautions

Opening

This dialog box can be opened as follows:

1 In the LCD Panel window

Select [Mode] -> [seT...] from the menu bar 

 (or press Alt+M, and T in that order).

2 Click the graphic or bitmap to be connected.

Explanation of each area

The Set LCD Pin dialog box consists of the following areas:

(1)　Segment (Segment signal setting area)

(2)　Common (Common signal setting area)

(3)　Segment display image display area
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(1) Segment (Segment signal setting area)

This area specifies the name of the LCD output pin to be set as the segment pin.

If the specified segment output signal data is "1" during simulation, a bitmap is displayed. When more 

than one pin is selected, if the signal data from any of the pins is "1", a bitmap is displayed.

To specify the LCD output pin name, click in the text box on the left, and after positioning the cursor, 

select the name from the drop-down list on the right. The name will then be added and displayed in the 

text box (multiple specifications are automatically displayed delimited with a comma ","). Names can 

also be typed directly into the text box. In this case, be sure to delimit multiple specifications with a 

comma ",". Up to 20 pin names can be set.

(2) Common (Common signal setting area)

This area specifies the LCD output pins to be set as common pins.

If the result of ANDing the output signal data of the specified common and segment is "1", a bitmap is 

displayed. Up to 20 pin names can be set.

Names are specified in the same way as in the segment signal setting area.

(3) Segment display image display area

The graphic selected in the LCD Panel window is displayed as a 7-segment display image in the case 

of a 7-segment LED, and a 14-segment display image in the case of a 14-segment LED. If graphics 

other than these are selected, nothing will be displayed.

When the data is set by clicking the <OK> button, the red part of the 7-segment display image/14-

segment display image is moved, and that segment enters the setting input wait state.

Function buttons

OK Sets the specified data. Connects the data in the Set LCD Pin dialog box to the 
graphic and closes the dialog box. If a 7- or 14-segment LED has been 
connected, the red part of the segment display image is moved, and that 
segment enters the setting input wait state.

Cancel Ignores the setting and closes this dialog box.

Clear Clears the set contents.

Help Opens the Help window.
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Cautions

Connect LCD output pins to the graphics in the LCD Panel window

Use the following procedure to connect LCD output pins to the graphics (including bitmaps and 

characters) in the LCD Panel window.

1 Select [seT] from the [Mode] menu.

2 Click the graphic to be connected. The Set LCD Pin dialog box will open.

3 Specify the LCD output pins to be set as the segment and common pins in the Set LCD Pin dialog

box.

Click in the text box on the left, and after positioning the cursor, select the name from the drop-

down list on the right. The selected name will then be added and displayed in the text box. Names

can also be typed directly into the text box. In this case, be sure to delimit multiple specifications

with a comma ",".

4 Click the <OK> button to set the data.

-> The data and graphics in the Set LCD Pin dialog box are connected, and the dialog box closes.

If a 7-or 14-segment LED has been connected, the red part of the segment display image is

moved, and that segment enters the setting input wait state.

LCD display

There are two types of LCD display: the one in the LCD Display window when a bit image is selected, 

and the customized LCD display when a custom is selected in the LCD Panel window.

•  LCD Display window
A bit image is displayed as vertical common signals and horizontal segment signals. The segment
signals that are active for the active common signals are black. Inactive signals are white.

•  Customized LCD display
Selecting [Simulation] from the [Mode] menu in the LCD Panel window starts a simulation
operation. At this time, the customized LCD display in the LCD Panel window is not displayed
because the connected pins are inactive. A customized LCD display not connected to segment pins
is also not displayed.

The display timing for a customized LCD is as follows.

•  When values of the common pin and segment pin signals set in the Set LCD Pin dialog box are both
"1", the corresponding graphic is displayed.
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•  The graphic retains the same display status (displayed/not displayed) as long as the value of the
segment signal corresponding to the current common signal does not change.

•  Cascaded graphics are displayed in order of small segment signals to large segment signals.

•  Graphics not connected to segment pins are displayed continuously.
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FIPs window

This window makes settings related to the FIP.

Either the FIP Display window or the FIP Panel window can be displayed by selecting the appropriate FIP

display image (Bit Image/Customize).

The setting information can be saved to a file (.sld), and information saved to a file can be read.

Figure 6-87　FIPs window

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This window can be opened as follows:

1 In the 78Kx Simulator GUI window

Select [External Parts] -> [Panel Window...] from the menu bar 

 (or press Alt+E, and P in that order).

2 Click the  button in the Parts window.

 or select [Parts] -> [built in FIP...] from the menu bar 

 (or press Alt+P, and F in that order).

Explanation of each area

The FIPs window consists of the following areas:

(1)　Disp (FIP display image selection area)
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(2)　Segment NO. (Display segment number setting area)

(3)　Time NO. (Display timing number setting area)

(1) Disp (FIP display image selection area)

This area selects the FIP display image.

(2) Segment NO. (Display segment number setting area)

This area sets the range of the segment numbers that are to be displayed. Setting this allows display of 

only the desired segments. Either of the text boxes can be used to specify the number of the segment 

from which display will start.

(3) Time NO. (Display timing number setting area)

This area sets the range of the timing numbers that are to be displayed. Setting this allows display of 

only the desired timings. Either of the text boxes can be used to specify the number of the timing from 

which display will start.

Function buttons

Bit Image Displays a bit image.
Select Bit Image and click the <OK> button. The FIP Display window is then
opened displaying a bit image of the timing and segment signal matrix.

Customize Customized display.
Select Customize and click the <OK> button. The FIP Panel window is then
opened.

OK Displays the FIP Display window as a bit image of the timing and segment 
signal matrix when Bit Image is selected in the FIP display image selection 
area.
Opens the FIP Panel window when Customize is selected in the display area.

Open Opens the Open dialog box.
Connection information will be read from a previously saved file (.sfp).
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Save Opens the Save As dialog box.
The displayed connection information will be saved to a file (.sfp).

Clear Clears the set contents.

Cancel Ignores the setting and closes this window.

Help Opens the Help window.
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FIP Panel window

This window displays the output of the pins connected to the device’ s internal FIP controller/driver as bit

and graphic images.

The FIP Panel window creates and edits FIP images.

During simulation, return to the Parts window by selecting [Mode] -> [Simulation] on the menu bar.

Figure 6-88　FIP Panel window

This section explains the following items:

• Opening

• Toolbar

• Menu bar

• Setting

Opening

This window can be opened as follows:

1 In the 78Kx Simulator GUI window

Select [External Parts] -> [Panel Window...] from the menu bar 

 (or press Alt+E, and P in that order).

2 Click the  button in the Parts window.

 or select [Parts] -> [built in FIP...] from the menu bar 

 (or press Alt+P, and C in that order).

3 In the FIPs window

Select Customize under Disp

Toolbar

Display of the toolbar can be alternately turned on or off by selecting [Option] -> [Tool Bar] from the menu

bar.
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Figure 6-89　Toolbar (FIP Panel Window)

Menu bar

Displaying the menu bar can be turned on or off by selecting [MENU Valid] in the control menu box of this

window.

(1) [File] menu

Select this menu to save information on the FIP Pnel window to a file (.fip) or read saved information 

from a file.

(2) [Mode] menu

In the case of the FIP Panel window, this menu can be used to move, group, or modify the size of 

Arbitrary character strings can be described.
This cannot be selected when the Parts window is active.

Straight lines of arbitrary length can be drawn.
This cannot be selected when the Parts window is active.

Rectangles of arbitrary size can be drawn.
This cannot be selected when the Parts window is active.

Ellipses of arbitrary size can be drawn.
This cannot be selected when the Parts window is active.

Pies of arbitrary size can be drawn.
This cannot be selected when the Parts window is active.

Polygons of arbitrary size can be drawn.
This cannot be selected when the Parts window is active.

Open... Opens the Open dialog box.
Information on the FIP Panel window can be read from a specified file (.fip).

Save Overwrites and saves the current information on the FIP Panel window to the 
file currently being read (.fip).

Save As... Opens the Save As dialog box.
The current information on the FIP panel window can be saved to a specified file 
(.fip).

eXit Closes this window.
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graphics (edit mode), to draw graphics (draw mode), or to connect pins to the customized FIP graphics 

(set mode).

Also, by selecting [Simulation], the window is changed to the Parts window at the moment the 

simulation mode is set.

(3) [Edit] menu

This menu is used to move or edit the external part displayed on the FIP Panel window, so that the 

user can freely create the image of a system.

This menu can be selected only in the placement mode. 

Edit Displays a dialog box that indicates the position (x and y coordinates) of the 
mouse cursor and sets the window in the placement mode.
This menu is used to move or edit the external component displayed on the Parts 
window, can be select the [Edit] menu.

Simulation Sets the window in the execution mode.
The simulation of parts is possible (default).

Draw Sets the window in the draw mode, in which FIP display image graphics can be
drawn using the [Draw] menu.

seT Sets the window in the set mode, in which the display timing and display 
segment connections can be set for the FIP display image graphics.
If this mode is selected, the [Edit], [Draw], and [Option] menus become 
unselectable.

Undo Restores changes in the window, such as movement of graphics or character 
strings, to the status immediately before.

Delete If a graphic or character string is selected with the mouse and [Delete] is 
clicked, the selected graphic or character string is deleted.
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(4) [Parts] menu

Select this menu to set the connection relationship with the supplied external parts.

Refer to the description of the [Parts] menu in the Parts window for an explanation of this menu.

(5) [Bitmap] menu

Cannot be selected.

(6) [Customize] menu

Cannot be selected.

(7) [Draw] menu

This menu can be used to draw FIP display image graphics in the FIP Panel window.

This menu can be selected only in the draw mode.

cuT If a graphic or character string is selected with the mouse and [cuT] is 
clicked, the selected graphic or character string is deleted and copied to the 
clipboard.

Copy If a graphic or character string is selected with the mouse and [Copy] is 
clicked, the selected graphic or character string is copied to the clipboard.

Paste The data copied to the clipboard is pasted to the upper left corner of the FIP 
Panel window.

Import from File... Opens the Open dialog box. Pastes the specified bitmap file (.bmp) to the 
upper left corner of the FIP Panel window.

teXt Cannot be selected.

Line Cannot be selected.

Rectangle Cannot be selected.

Bitmap Cannot be selected.

Suspend Cannot be selected.

Text Arbitrary character strings of up to 40 characters per string can be described.

 button’s operation is the same as clicking this button.

7Segment Displays a 7-segment numerical FIP. Each of these segments becomes an 
FIP display segment.
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(8) [Option] menu

14SeGment Displays a 14-segment alphanumerical FIP. Each of these segments 
becomes an FIP display segment.

Line Straight lines of arbitrary length can be drawn.

 button’s operation is the same as clicking this button.

Rectangle Rectangles of arbitrary size can be drawn.

 button’s operation is the same as clicking this button.

Elipse Circles of arbitrary size can be drawn.

 button’s operation is the same as clicking this button.

Pie Pies of arbitrary size can be drawn.

 button’s operation is the same as clicking this button.

POlygon Polygons of arbitrary size can be drawn.

 button’s operation is the same as clicking this button.

EDit Drawn graphics can be selected. This function can be selected when graphic 
drawing is aborted in the draw mode.

Tool Bar Turns on or off display of the toolbar.  If this is checked, the toolbar is displayed 
(default).

Group Several FIP graphics can be edited as a single graphic (grouping). This function is 
not available for 7- and 14-segment LEDs.

Ungroup Returns grouped graphics to their original state.

Pen... Changes the status of the line being drawn or the graphic currently selected. The 
color, width, and type of the line can be specified in the opened dialog box.

Brush... Changes the brush of the graphic being drawn or the graphic currently selected. The 
style, color, and size of the brush can be specified in the opened dialog box.

Font.... Changes the font of the character string being typed or the character string currently 
selected. The font and font size can be specified in the opened dialog box.

Raise Places the selected graphic in the front of the cascaded graphics.

Lower Places the selected graphic at the back of the cascaded graphics.
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(9) [Help] menu

Refer to the description of the [Help] menu in the Parts window for an explanation of this menu.

Setting

Editing in FIP Panel window

The following editing modes of the FIP Panel window can be used when the window is in the 

placement mode:

•  <Moving graphics>

•  <Cutting, copying and deleting graphics>

•  <Pasting graphics>

•  <Importing graphic from file>

•  <Changing graphic size>

•  <Character insertion>

•  <Drawing 7/14 segments>

•  <Drawing lines>

•  <Drawing rectangles, circles, and pies>

•  <Drawing polygons>

•  <Grouping>

•  <Ungrouping>

•  <Raising>

•  <Lowering>

In the placement mode, the following window indicated by the mouse position and the coordinates is 

displayed.

Figure 6-90　Mouse Position and Coordinates

<Moving graphics>

1 Click the gurafic to be moved.

-> Marks appear at the vertices and midpoints of the box around the selected graphic.

2 While holding down the left mouse button on the selected graphic, move (drag) the graphic.

Release the mouse button when the graphic has reached the desired position.

-> The selected graphic will move to the specified position.

To move two or more graphics at the same time, click the second graphic while holding down the

Shift key, and drag and drop it, still holding down the Shift key.

Up to 16 graphics can be selected at the same time.
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<Cutting, copying and deleting graphics>

1 Click the graphic to be cut, copied, or deleted.

-> Marks appear at the vertices and midpoints of the box around the selected graphic.

2 Select [cuT], [Delete], or [Copy] from the [Edit] menu.

-> The selected part will be cut, copied, or deleted.

Alternatively, if there is more than one part to be edited, click the relevant parts while holding down

the Shift key, and then cut, copy, or delete using procedure 2 above. 

<Pasting graphics>

1 Select either the Windows paintbrush, or [cuT]/[Copy] from the [Edit] menu.

-> The selected graphic is copied to the clipboard.

2 Select [Paste] from the [Edit] menu.

-> The data on the clipboard is pasted to the lower right of the cut or copied graphic.

<Importing graphic from file>

Up to 20 character strings can be written in the window.

1 Create a bitmap file using the image editor (etc.).

2 Select [Import from File...] from the [Edit] menu.

-> The Open dialog box is opened.

3 Select the bitmap file to be imported from the dialog box.

-> The bitmap image of the selected bitmap file is pasted to the upper left corner of the FIP Panel

window.

<Changing graphic size>

1 Click the graphic whose size is to be changed.

-> Marks appear at the vertices and midpoints of the box around the selected graphic.

2 Click the mouse on a mark and drag the graphic until the desired size is reached.

-> The graphic is enlarged/reduced.

<Character insertion>

1 Select [Text] from the [Draw] menu.

-> A dialog box for inputting characters opens when the mouse is clicked at the desired display

position.

2 Type the character string to be displayed in this dialog box and click anywhere outside the text box

in the FIP Panel window.

<Drawing 7/14 segments>

1 Select [7Segment] or [14seGment] from the [Draw] menu.
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2 Click the mouse at the desired display position in the FIP Panel window.

-> The selected segment image is displayed at the position where the mouse was clicked.

<Drawing lines>

1 Select [Line] from the [Draw] menu.

2 Click the mouse where the line is to start.

3 Move the mouse. A straight line appears where the mouse is moved.

4 Click the mouse button where the line is to end.

-> The start and end points are connected by a straight line.

<Drawing rectangles, circles, and pies>

1 Select [Rectangle], [Ellipse], or [Pie] from the [Draw] menu.

2 Click the mouse where the rectangle, circle, or pie is to be drawn and hold the button down on a

vertex.

3 Drag the mouse. A rectangle appears from the vertex from which the mouse is dragged.

4 Release the mouse button when the rectangle has reached the desired size. In the case of circles

or pies, these will be drawn inside this rectangle.

<Drawing polygons>

1 Select [POlygon] from the [Draw] menu.

2 Click the mouse where the polygon is to be drawn and set a vertex.

3 Move (or drag) the mouse to the next vertex. A line (curve) appears from the vertex from which the

mouse is moved (dragged).

4 Click the mouse after arriving back at the original vertex. A polygon will be drawn with the lines

connected in the order clicked.

<Grouping>

1 Click the graphics to be grouped (to select two or more graphics, click the relevant graphics while

holding down the Shift key).

-> Marks appear at the vertices and midpoints of the box around the selected graphic.

2 Select [Group] from the [Option] menu.

-> The selected graphics become one, and marks appear at the vertices and midpoints of the box

around the grouped graphics.

<Ungrouping>

1 Click the graphic to be ungrouped.

-> Marks appear at the vertices and midpoints of the box around the selected graphic.

2 Select [Ungroup] from the [Option] menu.

-> The selected graphic returns to its pregrouped state, and marks appear at the vertices and

midpoints of the boxes around each graphic.
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<Raising>

1 Click the graphic to be displayed in front of the cascaded graphics.

-> Marks appear at the vertices and midpoints of the box around the selected graphic.

2 Select [Raise] from the [Option] menu.

-> The selected graphic is displayed in the front. The order of the other cascaded graphics does not

change.

<Lowering>

1 Click the graphic to be displayed at the back of the cascaded graphics.

-> Marks appear at the vertices and midpoints of the box around the selected graphic.

2 Select [Lower] from the [Option] menu.

-> The selected graphic is displayed at the back. The order of the other cascaded graphics does

not change.
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Set FIP Pin dialog box

This dialog box connects the bitmaps and graphics in the FIP Panel window to the FIP output pins.

If FIP output pin signals are already connected to the selected graphic, this connection information will be

displayed in the dialog box, enabling the user to check the graphic/signal connections. Note that the active

status of each signal is active high.

Figure 6-91　Set FIP Pin dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

• Cautions

Opening

This dialog box can be opened as follows:

1 In the FIP Panel window

Select [Mode] -> [seT...] from the menu bar 

 (or press Alt+M, and T in that order).

2 Click the graphic or bitmap to be connected.

Explanation of each area

The Set FIP Pin dialog box consists of the following areas:

(1)　Segment (Segment signal setting area)

(2)　Timing (Timing signal setting area)

(3)　Segment display image display area
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(1) Segment (Segment signal setting area)

This area specifies the name of the FIP output pin to be set as the segment pin.

If the specified segment output signal data is "1" during simulation, a bitmap is displayed. When more 

than one pin is selected, if the signal data from any of the pins is "1", a bitmap is displayed.

To specify the FIP output pin name, click in the text box on the left, and after positioning the cursor, 

select the name from the drop-down list on the right. The name will then be added and displayed in the 

text box (multiple specifications are automatically displayed delimited with a comma ","). Names can 

also be typed directly into the text box. In this case, be sure to delimit multiple specifications with a 

comma ",". Up to 20 pin names can be set.

(2) Timing (Timing signal setting area)

This area specifies the FIP output pins to be set as timing pins.

If the result of ANDing the output signal data of the specified segment and timing is "1", a bitmap is 

displayed. Up to 20 pin names can be set.

Names are specified in the same way as in the segment signal setting area.

(3) Segment display image display area

The graphic selected in the FIP Panel window is displayed as a 7-segment display image in the case of 

a 7-segment LED, and a 14-segment display image in the case of a 14-segment LED. If graphics other 

than these are selected, nothing will be displayed.

When the data is set by clicking the <OK> button, the red part of the 7-segment display image/14-

segment display image is moved, and that segment enters the setting input wait state.

Function buttons

OK Sets the specified data. Connects the data in the Set FIP Pin dialog box to the 
graphic and closes the dialog box. If a 7- or 14-segment LED has been 
connected, the red part of the segment display image is moved, and that 
segment enters the setting input wait state.

Cancel Ignores the setting and closes this dialog box.

Clear Clears the set contents.

Help Opens the Help window.
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Cautions

Connect FIP output pins to the graphics in the FIP Panel window

Use the following procedure to connect FIP output pins to the graphics (including bitmaps and 

characters) in the FIP Panel window.

1 Select [seT] from the [Mode] menu.

2 Click the graphic to be connected. The Set FIP Pin dialog box will open.

3 Specify the FIP output pins to be set as the segment and common pins in the Set FIP Pin dialog

box.

Click in the text box on the left, and after positioning the cursor, select the name from the drop-

down list on the right. The selected name will then be added and displayed in the text box. Names

can also be typed directly into the text box. In this case, be sure to delimit multiple specifications

with a comma ",".

4 Click the <OK> button to set the data.

-> The data and graphics in the Set FIP Pin dialog box are connected, and the dialog box closes. If

a 7-or 14-segment LED has been connected, the red part of the segment display image is moved,

and that segment enters the setting input wait state.

FIP display

There are two types of FIP display: the one in the FIP Display window when a bit image is selected, 

and the customized FIP display when a custom is selected in the FIP Panel window.

•  FIP Display window
A bit image is displayed as vertical timing signals and horizontal segment signals. Only the active
timing signals light up in blue in the timing output numbers. The segment signals that are active for
the timing signals are black. Inactive signals are white.

•  Customized FIP display
Selecting [Simulation] from the [Mode] menu in the FIP Panel window starts a simulation operation.
At this time, the customized FIP display in the FIP Panel window is not displayed because the
connected pins are inactive. A customized FIP display not connected to segment pins is also not
displayed.

The display timing for a customized FIP is as follows.



402 User’s Manual  U16768EJ1V0UM

CHAPTER 6  WINDOW REFERENCE

•  When values of the timing pin and segment pin signals set in the Set FIP Pin dialog box are both
"1", the corresponding graphic is displayed.

•  The graphic retains the same display status (displayed/not displayed) as long as the value of the
segment signal corresponding to the current timing signal does not change.

•  Cascaded graphics are displayed in order of small segment signals to large segment signals.

•  Graphics not connected to segment pins are displayed continuously.
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LEDs window

This window is used to set or change the connection information of the LED to be displayed in the Parts

window.

The displayed LED lights or turns off, indicating the status of the output from the simulator. 

The connection information can be saved to a file (.led).In addition, the saved file can be read.

Figure 6-92　 LEDs window

This section explains the following items:

• Opening

• Explanation of each area

• Setting

• Function buttons

Opening

This window can be opened as follows:

1 In the 78Kx Simulator GUI window

Select [External Parts] -> [Panel Window...] from the menu bar 

 (or press Alt+E, and P in that order).

2 Click the  button in the Parts window.

 or select [Parts] -> [LED...] from the menu bar 

 (or press Alt+P, and E in that order).

Explanation of each area

The LEDs window consists of the following areas:
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(1)　 LED ID display area

(2)　Display format setting area

(3)　Connection information setting area

(1) LED ID display area

This area displays the ID number to be assigned to the LED to be set. 

To set five or more LEDs, click the <Next> button and update the ID number.

Up to 32 ID numbers can be set.

(2) Display format setting area

This area is used to specify a display format in the Parts window.  A figure or bitmap can be selected.  

The default format is a bitmap in the shape of a light bulb.

(3) Connection information setting area 

This area is used to specify the connection information of a pin.

B/P If this check box is checked, the figure specified in the Picture field is displayed; 
if it is not checked, the bitmap specified in the BMP ID field is displayed.

BMP ID If the B/P check box is not checked, specify the registration number of the 
bitmap to be displayed, in numerals.
If no ID number exists or is specified, the default bitmap of registration number 1 
(figure of bulb) is selected (for how to register a bitmap, refer to "Bitmap Entry 
window (p.432)").

Picture If the B/P check box is checked, specify the figure to be displayed.  
A total of 6 patterns of rectangles or circles in red, green, or yellow, can be 
selected for the figure from the drop-down list.

Name Specify the character string to be displayed.
Up to 8 characters can be input.  

Pin Specify the name of an output pin to be connected.  
Up to eight characters can be input.  
For the specifiable pin names, refer to the user's manual of the device used.

Active Specify the active status of the set LED by using the option button.
The default status is active-high (H).
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Setting

LED display

The output status (active/inactive) of the connected pin is displayed real-time by two types of bitmaps.

Display example:

If a figure such as a rectangle or circle is selected as the display format, the figure is displayed in the 

specified color if the output status is active.  If the output status is inactive, only the frame of the figure 

is displayed.

Function buttons

Previous Displays the setting four ID numbers before the ID number currently displayed, 
in each area.

Next Displays the setting four ID numbers after the ID number currently displayed, in 
each area.

OK Checks for errors in the set connection information.
If an error or warning has occurred, a message is displayed on the dialog box.  
If an error or warning has not occurred, control is transferred to the Parts 
window, and the set external component is displayed.

Open Opens the Open dialog box.
Connection information will be read from a previously saved file (.led).

Save Opens the Save As dialog box.
The displayed connection information will be saved to a file (.led).

Clear Clears the set contents.

Cancel Ignores the setting and closes this window.

Help Opens the Help window.
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7seg LEDs window

This window is used to set or change the connection information of the 7-segment LED pin to be

displayed in the Parts window.  

The displayed 7-segment LED displays the status of the output from the simulator.

The connection information can be saved to a file (.seg).  In addition, the saved file can be read.

Figure 6-93　 7seg LEDs window

This section explains the following items:

• Opening

• Explanation of each area

• Setting

• Function buttons

Opening

This window can be opened as follows:

1 In the 78Kx Simulator GUI window

Select [External Parts] -> [Panel Window...] from the menu bar 

 (or press Alt+E, and P in that order).

2 Click the  button in the Parts window.

 or select [Parts] -> [7Seg LED...] from the menu bar 

 (or press Alt+P, and S in that order).
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Explanation of each area

The 7seg LEDs window consists of the following areas:

(1)　Segment signal setting area

(2)　Segment H/L (segment signal active status display area)

(3)　Digit signal setting area

(4)　Digit H/L  (digit signal active status display area)

(1) Segment signal setting area 

This area is used to specify the name of the pin to be connected to the segment signal of the 7-

segment LED.

Up to eight characters can be input.  

Caution: For the specifiable pin names, refer to the user's manual of the device used.

(2) Segment H/L (segment signal active status display area)

This area is used to specify the active status of the segment signal via the option button.

The default status is active-high (H).
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(3) Digit signal setting area

This area is used to specify the name of a pin that is connected to the digit signal of the 7-segment 

LED.

Up to eight characters can be input.  

To set nine digits or more, click the <Next> button and update the digit.Up to 16 digits can be set.

For the set signal, successively specify connection pins, starting from the lowest digit.

Caution: For the specifiable pin names, refer to the user's manual of the device used.

(4) Digit H/L  (digit signal active status display area)

This area is used to specify the active status of the digit signal via the option button.

The default status is active-high (H).

Setting

7-segment LED display

The output information of the connected pin is received as the result of one simulation, and the 7-

segment LED is displayed according to that value.

Until the value of the digit signal changes, the segment that lights remain lit, and the segment that turns 

off remains dark.  When the value of the digit signal changes, the display is updated in accordance with 

the changes in the segment signal.

The segment that lights is indicated in red and the segment that remains dark is indicated in white (only 

a frame is displayed).
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Display example:

Function buttons

Previous Displays the set contents eight digit signals before the digit signal currently 
displayed, in each area.

Next Displays the set contents eight digit signals after the digit signal currently 
displayed, in each area.

OK Checks for errors in the set connection information.
If an error or warning has occurred, a message is displayed on the dialog box.  
If an error or warning has not occurred, control is transferred to the Parts 
window, and the set external component is displayed.

Open Opens the Open dialog box.
Connection information will be read from a previously saved file (.seg).

Save Opens the Save As dialog box.
The displayed connection information will be saved to a file (.seg).

Clear Clears the set contents.

Cancel Ignores the setting and closes this window.

Help Opens the Help window.
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14seg LEDs window

This window is used to set or change the connection information of the 14-segment LED pin to be

displayed in the Parts window.

The displayed 14-segment LED displays the status of the output from the simulator.

The connection information can be saved to a file (.s14).  In addition, the saved file can be read.

Figure 6-94　 14seg LEDs window

This section explains the following items:

• Opening

• Explanation of each area

• Setting

• Function buttons

Opening

This window can be opened as follows:
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1 In the 78Kx Simulator GUI window

Select [External Parts] -> [Panel Window...] from the menu bar 

 (or press Alt+E, and P in that order).

2 Click the  button in the Parts window.

 or select [Parts] -> [14Seg LED...] from the menu bar 

 (or press Alt+P, and D in that order).

Explanation of each area

The 14seg LEDs window consists of the following areas:

(1)　Segment signal setting area

(2)　Segment H/L (segment signal active status display area)

(3)　Digit signal setting area

(4)　Digit H/L  (digit signal active status display area)

(1) Segment signal setting area 

This area is used to specify the name of the pin to be connected to the segment signal of the 14-

segment LED.

Up to eight characters can be input.  

Caution: For the specifiable pin names, refer to the user's manual of the device used.
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(2) Segment H/L (segment signal active status display area)

This area is used to specify the active status of the segment signal via the option button.

The default status is active-high (H).

(3) Digit signal setting area

This area is used to specify the name of a pin that is connected to the digit signal of the 14-segment 

LED.

Up to eight characters can be input.  

To set six digits or more, click the <Next> button and update the digit.  Up to 10 digits can be set.  For 

the set signal, successively specify connection pins, starting from the lowest digit.

Caution: For the specifiable pin names, refer to the user's manual of the device used.

(4) Digit H/L  (digit signal active status display area)

This area is used to specify the active status of the digit signal via the option button.

The default status is active-high (H).

Setting

14-segment LED display

The output information of the connected pin is received as the result of one simulation, and the 14-

segment LED is displayed according to that value.

Until the value of the digit signal changes, the segment that lights remain lit, and the segment that turns 

off remains dark.  When the value of the digit signal changes, the display is updated in accordance with 

the changes in the segment signal.

The segment that lights is indicated in red and the segment that remains dark is indicated in white (only 
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a frame is displayed).

Display example:

Function buttons

Previous Displays the set contents five digit signals before the digit signal currently 
displayed, in each area.

Next Displays the set contents five digit signals after the digit signal currently 
displayed, in each area.

OK Checks for errors in the set connection information.
If an error or warning has occurred, a message is displayed on the dialog box.  
If an error or warning has not occurred, control is transferred to the Parts 
window, and the set external component is displayed.

Open Opens the Open dialog box.
Connection information will be read from a previously saved file (.s14).

Save Opens the Save As dialog box.
The displayed connection information will be saved to a file (.s14).

Clear Clears the set contents.

Cancel Ignores the setting and closes this window.

Help Opens the Help window.
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Level Gauges window

This window is used to set or change the connection information of the level gauge to be displayed in the

Parts window.

Data can be input to the simulator from the displayed level gauge (scroll bar or dial).  However, only

analog input pins can be connected to the level gauge.

The connection information can be saved to a file (.lev).  In addition, the saved file can be read.

Caution: The Level Gauges dialog box can be selected only for a device with an internal A/D

converter.  For the specifiable pin names, refer to the user's manual of the device used.

Figure 6-95　 Level Gauges window

This section explains the following items:

• Opening

• Explanation of each area

• Setting

• Function buttons

Opening

This window can be opened as follows:

1 In  the78Kx Simulator GUI window

Select [External Parts] -> [Panel Window...] from the menu bar 

 (or press Alt+E, and P in that order).

2 Click the  button in Parts window.

 or select [Parts] ->  [Level Gauge...] from the menu bar 

 (or press Alt+P, and L in that order).
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Explanation of each area

The Level Gauges window consists of the following areas:

(1)　 Level gauge ID display area

(2)　Connection information setting area

(3)　AVref (reference voltage value setting area)

(1) Level gauge ID display area 

This area displays the ID number to be assigned to the level gauge to be set.  To set nine or more level 

gauges, click the <Next> button and update the ID number.  Up to 16 ID numbers can be set.

(2) Connection information setting area 

This area is used to set or display information on the connection between a level gauge and a pin. 

This check box specifies the type of the level gauge to be displayed.

(3) AVref (reference voltage value setting area)

This area is used to set the reference voltage value of the A/D converter.

The reference voltage can be set within the range of the operating supply voltage to the first decimal 

place (the default value is 5.0 V).

  This reference voltage determines the operation range of the scroll bar or dial displayed in the Parts 

window.

Setting

Inputting from level gauge

By operating the displayed scroll bar or dial, an analog signal can be input from the level gauge.  The 

SB/D This check box specifies the type of the level gauge to be displayed.
If this box is checked, the level gauge is displayed as a dial; if it is not checked, the 
level gauge is displayed as a scroll bar. 

Name Specify the character string to be displayed on the side of the level gauge.  Up to 
eight characters can be input.  

In Pin This area is used to specify the name of the analog input pin to be connected to 
the level gauge.  Up to eight characters can be input.  
For the specifiable pin names, refer to the user's manual of the device used.



416 User’s Manual  U16768EJ1V0UM

CHAPTER 6  WINDOW REFERENCE

maximum value of the analog signal that can be input is the value specified in the AVref area.

Two types of level gauges are available: a scroll bar and a dial.

Display example:

<Inputting via scroll bar>

By moving the scroll thumb, the analog value, which is displayed in black, can be changed.

When the analog value has reached the value to be input, click the right button of the mouse on the 

scroll bar.  In this way, the displayed analog value can be input.  At this time, the value is displayed in 

red.

The scroll thumb can be moved by dragging or clicking the left mouse button at any position.

<Inputting via dial>

By moving the <red> mark (operating point) on the dial, the analog value, which is displayed in black, 

can be changed.

When the analog value has reached the value to be input, click the right button of the mouse on the 

dial.

In this way, the displayed analog value can be input.  At this time, the value is displayed in red.

The operating point can be moved by dragging or clicking the left mouse button at any position.

Function buttons

Previous Displays the setting eight ID numbers before the ID number currently displayed, in each 
area.

Next Displays the setting eight ID numbers after the ID number currently displayed, in each 
area.

OK Checks for errors in the set connection information.
If an error or warning has occurred, a message is displayed on the dialog box.  
If an error or warning has not occurred, control is transferred to the Parts window, and 
the set external component is displayed.

Open Opens the Open dialog box.
Connection information will be read from a previously saved file (.lev).

Save Opens the Save As dialog box.
The displayed connection information will be saved to a file (.lev).

Clear Clears the set contents.

Cancel Ignores the setting and closes this window.

Help Opens the Help window.
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DC Motors window

This window is used to set or change the connection information of the DC motor to be displayed in the

Parts window.

The displayed DC motor displays the output status of the connected pin as a bitmap or as the number of

revolutions.

The connection information can be saved to a file (.mtr).  In addition, the saved file can be read.

Figure 6-96　DC Motors window

This section explains the following items:

• Opening

• Explanation of each area

• Setting

• Function buttons

Opening

This window can be opened as follows:

1 In the 78Kx Simulator GUI window

Select [External Parts] -> [Panel Window...] from the menu bar 

 (or press Alt+E, and P in that order).

2 Click the  button in the Parts window.

 or select [Parts] -> [DC Motor...] from the menu bar 

 (or press Alt+P, and M in that order).
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Explanation of each area

The DC Motors window consists of the following areas:

(1)　DC motor ID display area

(2)　Connection information setting area

(1) DC motor ID display area

This area displays the ID number to be assigned to the DC motor to be set.  To set five or more DC 

motors, click the <Next> button and update the ID number.

Up to 32 ID numbers can be set.

(2) Connection information setting area 

This area is used to set or display information on the connection between a DC motor and pins.

Setting

DC motor display

The value of the output pin connected to the DC motor is displayed on a bitmap, in accordance with its 

active status (active-high or active-low).  The output value is displayed in brown if the DC motor is 

active, and displayed in gray if the motor is inactive.

In addition, the total number of clocks during which the motor remains active from the beginning of 

simulation is also displayed.

The total number of clocks is counted up to 10 digits.  After the10th digit, the count value is returned to 

0.

BMP ID Specify the registration number of the bitmap when the button is displayed on the 
Parts window, in numerals.  
If an ID number does not exist or if no ID number is specified, a bitmap with 
registration number 4 is selected as default( refer to "Bitmap Entry window").

Name Specify the character string to be displayed.  Up to eight characters can be input.   

Pin Specify the name of the port pin or multiplexed pin to be connected to the DC motor.
Up to eight characters can be input.  
For the specifiable pin names, refer to the user's manual of the device used.

Active Specify the active status of the set DC motor via the option button.
The default status is active-high (H).
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Display example:

Function buttons

Previous Displays the setting four ID numbers before the ID number currently displayed, 
in each area.

Next Displays the setting four ID numbers after the ID number currently displayed, in 
each area.

OK Checks for errors in the set connection information.
If an error or warning has occurred, a message is displayed on the dialog box.  
If an error or warning has not occurred, control is transferred to the Parts 
window, and the set external component is displayed.

Open Opens the Open dialog box.
Connection information will be read from a previously saved file (.mtr).

Save Opens the Save As dialog box.
The displayed connection information will be saved to a file (.mtr).

Clear Clears the set contents.

Cancel Ignores the setting and closes this window.

Help Opens the Help window.



420 User’s Manual  U16768EJ1V0UM

CHAPTER 6  WINDOW REFERENCE

Buzzers window

This window is used to set or change the connection information of the buzzer to be displayed in the

Parts window.

The output status is indicated by a bitmap or buzzer sound. 

The connection information can be saved to a file (.buz).  In addition, the saved file can be read.

Figure 6-97　Buzzers window

This section explains the following items:

• Opening

• Explanation of each area

• Setting

• Function buttons

Opening

This window can be opened as follows:

1 In 78Kx Simulator GUI window

Select [External Parts] -> [Panel Window...] from the menu bar 

 (or press Alt+E, and P in that order).

2 Click the  button in Parts window.

 or select [Parts] -> [Buzzer...] from the menu bar 

 (or press Alt+P, and Z in that order).

Explanation of each area

The Buzzers window consists of the following areas:

(1)　Buzzer (buzzer output format setting area)
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(2)　Pin, Active (buzzer connection pin setting area)

(1) Buzzer (buzzer output format setting area)

This area is used to specify the output format of the buzzer via a check box.  Both Sound Output and 

Bitmap display can be specified.

(2) Pin, Active (buzzer connection pin setting area)

This area is used to set information on the pin to be connected to the buzzer.

Setting

Buzzer display

The active-level output of the pin connected to the buzzer is indicated by a bitmap and/or buzzer 

sound.

The output value (active/inactive) of the pin is displayed on the bitmap, as follows:

Display example:

The buzzer sound is issued if the connected pin outputs the value of the active level (when the level of 

the pin changes from the inactive level to the active level). 

Beep If this check box is checked, the output from a pin is indicated by a 
sound.
To use this function, a sound board and a speaker are necessary.

Bitmap If this check box is checked, the output from a pin is displayed as a 
bitmap.

Pin Input the name of the pin to be connected to the buzzer from the keyboard.
Up to eight characters can be input.  
For the specifiable pin names, refer to the user's manual of the device used.

Active Select the active status of the set buzzer via the option button.
The default status is active-high (H).
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Function buttons

OK Validates the setting and transfers control to the Parts window.
When a bitmap display is specified, the output status is displayed on a bitmap.

Open Opens the Open dialog box.
Connection information will be read from a previously saved file (.buz).

Save Opens the Save As dialog box.
The displayed connection information will be saved to a file (.buz).

Clear Clears the set contents.

Cancel Ignores the setting and closes this window.

Help Opens the Help window.
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Internal Interrupt Button window

This window is used to set or change the connection information of the internal interrupt button to be

displayed in the Parts window.

An interrupt can be issued to the simulator from the displayed button.

The connection information can be saved to a file (.itr).  In addition, the saved file can be read.

Figure 6-98　 Internal Interrupt Button window

This section explains the following items:

• Opening

• Explanation of each area

• Setting

• Function buttons

Opening

This window can be opened as follows:

1 In the 78Kx Simulator GUI window

Select [External Parts] -> [Panel Window...] from the menu bar 

 (or press Alt+E, and P in that order).

2 Click the  button in the Parts window.

 or select [Parts] -> [Internal Interrupt...] from the menu bar 

 (or press Alt+P, and I in that order).
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Explanation of each area

The Internal Interrupt Button window consists of the following areas:

(1)　 Internal interrupt button ID display area

(2)　 Interrupt (internal interrupt name setting area)

(1) Internal interrupt button ID display area

This area displays the ID number to be assigned to the button to be set.

To set five or more buttons, click the <Next> button and update the ID number.

Up to 20 ID numbers can be set.

(2) Interrupt (internal interrupt name setting area)

Select the name of the internal interrupt to be connected from the drop-down list in this area.

Caution: For the specifiable interrupt names, refer to the user's manual of the device used.

Setting

Input operation of internal interrupt button 

By clicking the displayed button, an internal interrupt can be generated.

Display example:

By clicking the displayed button, an internal interrupt can be generatedNote.  That this button does not 

have a function to set the input timing.

Note: For the timing at which interrupts can be acknowledged, refer to the user's manual of the

device used.

Function buttons

Previous Displays the setting four ID numbers before the ID number currently displayed, 
in each area.
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Next Displays the setting four ID numbers after the ID number currently displayed, in 
each area.

OK Checks for errors in the set connection information.
If an error or warning has occurred, a message is displayed on the dialog box.  
If an error or warning has not occurred, control is transferred to the Parts 
window, and the set external component is displayed.

Open Opens the Open dialog box.
Connection information will be read from a previously saved file (.itr).

Save Opens the Save As dialog box.
The displayed connection information will be saved to a file (.itr).

Clear Clears the set contents.

Cancel Ignores the setting and closes this window.

Help Opens the Help window.
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Pull-Up / Pull-Down window

This window is used to set information on the pin to be connected to a pull-up/down resistor.

If a pull-up/down resistor is connected to a pin that sets the button or key matrix of an external

component, set a pull-up/down resistor in this dialog box before setting the pin to be connected in each

connection dialog box.  The connection information can be saved to a file (.pud).  In addition, the saved file

can be read.

Figure 6-99　Pull-Up / Pull-Down window

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This window can be opened as follows:

1 In the 78Kx Simulator GUI window

Select [External Parts] -> [Panel Window...] from the menu bar 

 (or press Alt+E, and P in that order).

2 Click the  button in the Parts window.

 or select [Parts] -> [Pull Up/Pull Down...] from the menu bar 

 (or press Alt+P, and W in that order).
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Explanation of each area

The Pull-Up/Pull-Down window consists of the following areas: 

(1)　Pull-up/down ID display area

(2)　Connection information setting area

(1) Pull-up/down ID display area

This area displays the ID number to be assigned to the pin to which a pull-up/down resistor is to be 

connected.  

To set five or more pins, click the <Next> button and update the ID number.

Up to 40 ID numbers can be set.

(2) Connection information setting area 

This area is used to set or display information on the connection between a pull-up/down resistor and a 

pin.

Function buttons

Pin Specify the name of the pin to be connected to a pull-up/down resistor.
Up to eight characters can be input.  
For the specifiable pin names, refer to the user's manual of the device used.

PULL-UP/DOWN Select whether the initial status of the pin is to have a pull-up resistor 
connected (default) or a pull-down resistor connected via the option button.

Previous Displays the setting four ID numbers before the ID number currently displayed, in each 
area.

Next Displays the setting four ID numbers after the ID number currently displayed, in each 
area.

OK Checks for errors in the set connection information.
If an error or warning has occurred, a message is displayed on the dialog box.  
If an error or warning has not occurred, control is transferred to the Parts window, and the 
set external component is displayed.

Open Opens the Open dialog box.
Connection information will be read from a previously saved file (.pud).

Save Opens the Save As dialog box.
The displayed connection information will be saved to a file (.pud).

Clear Clears the set contents.
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Cancel Ignores the setting and closes this window.

Help Opens the Help window.
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Serial GUI window

The operation mode and I/O information of the serial interface can be displayed.

The Serial GUI window displays the operation mode and I/O information of each channel of the serial

interface selected from the submenu.  Serial GUI windows of different channels can be simultaneously

opened.

Figure 6-100　Serial GUI Window

This section explains the following items:

• Opening

• Explanation of each area

• Menu bar

Opening

This window can be opened as follows:

1 In the 78Kx Simulator GUI window

Select [External Parts] -> [Panel Window...] from the menu bar 

 (or press Alt+E, and P in that order).

2 In the Parts window

Select [Parts] -> [Serial GUI...] -> [Submenu (differs depending on the device)] from the menu bar.

Explanation of each area

The Serial GUI window consists of the following areas:

(1)　Operation information display area

(2)　 Input Data, Output Data (I/O information display area)
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(1) Operation information display area

The first line of this area displays the operation mode of the serial interface.  Depending on the 

operation of the serial interface, "Serial Start" or "Operation Stop Mode" is displayed.

The second line indicates whether the serial interface operates as the master or a slave.  When the 

interface operates as the master, the number of operating clocks is also displayed.

(2) Input Data, Output Data (I/O information display area)

This area displays the data input to (received by) or output (transmitted) from the serial interface.  The 

data is displayed when all the bits of data have been completely received or transmitted.

The number of data that can be displayed is five in the default condition, but it can be increased to up 

to 20 by changing the size of the windowNote.

It can be also specified, by using the [Digit] menu, whether the data is displayed as hexadecimal or 

binary numbers.

Note: The scroll bar can also be used to specify the number of data.  However, use the scroll bar only

when simulation is stopped.

Menu bar

(1) [File] menu

(2) [Digit] menu

Exit Closes this window.



CHAPTER 6  WINDOW REFERENCE

User’s Manual  U16768EJ1V0UM 431

(3) [Help] menu

Hex Displays the data in the I/O information display area as hexadecimal 
numbers (default).

Binary Displays the data in the I/O information display area as binary 
numbers.

SM78Kx Help Opens the Help window of SM78Kx.

This Window Opens the Help window.
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Bitmap Entry window 

This window is used to register the bitmap file of the external component to be displayed in the Parts

window.

In this dialog box, a bitmap file newly created by the user can be registered or an unnecessary bitmap file

can be deleted. 

A registration number is assigned to a newly registered bitmap file.  This bitmap file can be used to

display the bitmap of an external component for which the bitmap display can be changed.

Up to 384 bitmap files can be registered.

The connection information can be saved to a file (.bit).

Figure 6-101　Bitmap Entry window 

This section explains the following items:

• Opening

• Explanation of each area

• Setting

• Function buttons

Opening

This window can be opened as follows:

1 In the  78Kx Simulator GUI window

Select [External Parts] -> [Panel Window...] from the menu bar 

 (or press Alt+E, and P in that order).
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2 In the Parts window Select [Bitmap] -> [Bitmap Entry] from the menu bar 

 (or press Alt+B, and N in that order).

Explanation of each area

The Bitmap Entry window consists of the following areas:

(1)　Bitmap File Name (bitmap file name specification area)

(2)　 LIST (registered bitmap file display area)

(1) Bitmap File Name (bitmap file name specification area)

This area specifies the bitmap file names to be registered and whether each bitmap file is active or 

inactive.

Select in which status, active or inactive, a bitmap file is to be registered, via the option button.  Search 

and specify a file name using the <Search> button, or directly input a file name.

Note that a path is ignored even if the file name is specified with a full path.  

(2) LIST (registered bitmap file display area)

This area displays the bitmap file names already registered in the following format:

(1) Registration number

(2) Active status file name

(3) Inactive status file name

In the default condition, five bitmap files (with registration numbers 1 to 5) are registered.

If this area is selected by the mouse, a sample is displayed at the lower part of the dialog box as 

follows:

 1. lampact.bmp : lampoff.bmp

(1)       (2)                     (3)
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Setting

Registering bitmap file

To register a bitmap file, follow these steps: 

1 Click the <Path> button. A dialog box will open. In this dialog box, specify the path to the directory

where the bitmap file to be registered exists.Up to 128 characters can be input.  

If a path is not specified, it is assumed that the file exists in the directory where the bitmap file of the

simulator exists.

Table 6-40　Relationship between Registration Number and Bitmap File

Registration No. Active status Inactive Status

1 lampact.bmp lampoff.bmp

2 scract.bmp scroff.bmp

3 btmact.bmp btmoff.bmp

4 motact.bmp motoff.bmp

5 buzact.bmp buzoff.bmp
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To set the path, click the <OK> buttonNote1.  Only one path can be setNote2.

Note1. To cancel the path that has been set, click the <Cancel> button.

2. If a new path is set after a path has already been set, the path set first becomes invalid.

If the <OK> button is clicked with nothing specified, however, the path already set becomes valid

as is.

2 Click the active option button.  Search a file name to be specified as an active bitmap using the

<Search> button, or directly input a file name from the keyboard.

In the same manner, register an inactive bitmap file.  If a file is not registered, nothing is displayed

in the inactive statusNote.

Note: A bitmap file in only the inactive state cannot be registered.

3 Click the <Add> button.  A registration number will be assigned to the specified bitmap file, and the

bitmap file will be displayed as a sample.

 If no bitmap file exists when registration information is read from a project file (.prj) or by using the

<Open> button, an error bitmap prepared by the system is displayed.

Figure 6-102　Error Bitmap File

Deleting registered bitmap file

To delete a registered bitmap file, follow these steps:

1 Select the registration number to be deleted from the registration list by clicking the mouse.

2 Click the <Remove> button.

The deleted bitmap registration number will be missing.  Registration numbers 1 to 5 cannot be 

deleted.
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Function buttons

OK Validates the registration or deletion and transfers control to the Parts window.

Save Opens the Save As dialog box.
The displayed registration information will be saved to a file (.bit).

Open Opens the Open dialog box.
Registration information will be read from a specified file (.bit).

Search Opens the Browse dialog box.  Search and specify the bitmap file name to be 
registered.

Add Registers the specified bitmap file and displays it as a sample.

Remove Deletes the specified bitmap file from the registration list.
The bitmap number of the deleted file will be missing.
The default registration files cannot be deleted.

Cancel Ignores the setting and closes this window.

Path Sets a path to the directory where the bitmap file to be registered exists.

Help Opens the Help window.
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Open dialog box

This dialog box is used to specify or select a file to be manipulated.  This dialog box uses the standard

dialog box of Windows. 

In this dialog box, the specified file is searched from the drive or directory where the specified file exists,

by the file type, and the file is opened. 

Figure 6-103　Open Dialog Box

This section explains the following items: 

• Explanation of each area

• Function buttons

Explanation of each area

The Open dialog box consists of the following areas: 

(1)　 Look in: (File location selection area)

(2)　File name: and Files of type: (File name specification area)

(1) Look in: (File location selection area)

Select the drive or directory where the specified file exists from the drop-down list.

The file at the specified location is displayed in the field at the lower part of the area.
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(2) File name: and Files of type: (File name specification area)

Function buttons

File name Input the name of the file to be specified from the keyboard.  A file 
name can also be selected from the above field or by specifying a 
wildcard.

Files of type Select the type of the specified file from the drop-down list. 
When the file type has been selected, the specified file is displayed in 
the field above the file name specification area.

Open Opens the specified file.

Cancel Ignores the setting and closes the dialog box.
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Save As dialog box

This dialog box is used to specify or select a file to be saved.  This dialog box uses the standard dialog

box of Windows. 

On this dialog box, a file can be named and saved to a specified directory.

Figure 6-104　Save As Dialog Box

This section explains the following items:

• Explanation of each area

• Function buttons

Explanation of each area

This section explains the following items:

(1)　Save in: (Save in selection area)

(2)　File name: and Save as type: (File name specification area)

(1) Save in: (Save in selection area)

Select the drive or directory to which the file is to be saved from the drop-down list.  The file at the 

specified location is displayed in the field at the lower part of the area.
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(2) File name: and Save as type: (File name specification area)

Function buttons

File name Input the name of the file to be specified from the keyboard.
In the default condition, an extension suitable for the window from which this 
dialog box was opened is displayed.
To overwrite an existing file, select the file from the field above this area, or 
search the file using a wildcard. 
When .evn or .i_x is specified, be sure to specify four characters followed by 
0000.i_x as the file name (e.g., abcd0000.i_0 or efgi0000.evn).

Save as type Select the type of the file to be saved from the drop-down list.
If this dialog box has been opened from the Input 0/1 Editor window or Input 
timing Chart Editor window, specify a wait unit in this field.

Save Saves the file contents under the specified file name at the specified location.

Cancel Ignores the setting and closes the dialog box.
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CHAPTER 7  COMMAND REFERENCE

This section explains the command functions of the SM78Kx in detail.

7. 1    Command Line Rules

The specification of command lines has the following rules: 

• Command name, option, and argument are specified for command line.  

• To divide words, a space (space key or tab key) is used.  

• At the end of a line, a line feed character or a semicolon is used.  

• When a command name and an option are entered to the point of identifiability, they are recognized.  

• In script, command names have to be entered completely.  

Command format 

command -options arg1 arg2 arg3 ... 

7. 2    Command List

The list of SM78Kx commands is shown in Table 7-1 and Table 7-2 .  

Table 7-1　List of Debugger Control Commands

Command Name Function

address Evaluation of address expression  
Converts the address expression specified with expression into address.  

assemble Disassemble/line assemble (a)  
Assembles the character strings specified with code from the address 
specified with address.  

batch Executing batch (with echo)  
Executes in batch displaying files specified with scriptname on the screen.   

breakpoint Setting/deletion of breakpoint (b)  
Operates breakpoint specified with options and address.  

dbgexit Terminating debugger
Terminates the debugger.  

download Download of files (l) 
Downloads files specified with filename according to options.  

extwin Creation of expansion window
Creates expansion window with scriptfile.  

finish Returning from function
Executes until it returns to the program that called the current function.  

go Continuous execution (g) 
Executes program continuously.  

help Display of help 
Displays help of Dcl.  
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hook Setting of hook 
Sets the procedure for hook with scriptfile.  

jump Jump to window (j) 
Displays the window specified with options.  

map Setting/deletion of memory mapping 
Sets, deletes, and displays memory mapping.   

mdi Setting of expansion window 
Sets the size and title name of the expansion window.  

memory Display/setting of memory (m) 
Sets value in the memory of the address specified with address according to 
options.  

module Display of the list of files and functions 
Displays the list of files and functions of the load module specified with 
progname.  

next Procedure step (n) 
Executes the procedure steps.  

refresh Redrawing of window 
Redraws the window and updates the data.   

register Display/setting of register value and I/O register value 
Sets value in the register specified with regname.  

reset Reset 
Resets CPU, debugger or symbols.  

run Reset and execution of CPU (r) 
Resets program and executes it.  

step Step execution (s)  
Executes step execution.  

stop Stop execution 
Stops the program forcibly.  

upload Upload 
Saves the memory data or coverage data within the specified range in a file.  

version Display of the version information 
Displays the version information of the debugger.  

watch Display/setting of variables (w) 
Displays and sets the variables.  

where Trace of stack 
Executes the back-trace of the stack.  

wish Start of Tclet 
Starts the script using Tk (Tclet).   

xcoverage Operation of coverage 
Operates coverage.

xtime Operation of timer  
Operates timer.  

xtrace Operation of tracer 
Operates tracer.  

Table 7-1　List of Debugger Control Commands

Command Name Function
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Table 7-2　 List of Console/Tcl Commands 

Command Name Function

alias Creation of another name 

cd Change of directory 

clear Clears the screen 

echo Echo 

exit Close/end 

history Display of history 

ls Display of files 

pwd Check of the directory 

source Execution of batch 

time Measurement of time for commands 

tkcon Console control 

unalias Deletion of another name 

which Display of the command path or another name 

Other commands Based on Tcl/Tk 8.1 
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7. 3    List of Variables 

• dcl(chip) - Chip name read only

• dcl(prjfile) - Project file name read only

• dcl(srcpath) - Source path read only

• dcl(ieid) - IE type read only

• dcl(iestat) - IE status read only

• dcl(bkstat) - Break status read only

• env(LANG) - Language 

• dcl_version - Dcl version read only

7. 4    List of Packages 

• tcltest - Restoration test 

• cwind - Automatic window control 

• BWidget - Toolkit 

7. 5    Key Bind 

• tcsh + emacs like 

• Complement of command name [Tab] 

• Complement of file name [Tab] 

• HTML help [F1] 

7. 6    Expansion window

The expansion windows can be created using Tk.  

In the expansion windows, Widget is allocated with '.dcl' as a root instead of '.'.  

When the following script files are allocated in bin/idtcl/tools/, an expansion window is added on selecting

[Browse] -> [Others] from the menu bar.  

The mdi command, an exclusive command for expansion windows, has been added.  

In expansion windows, Tk menu commands cannot be used because of the restrictions of MDI windows.  

7. 7    Callback Procedure

Expansion windows can hold dcl_asyncproc procedures called by asynchronous messages.  

# Sample.tcl
wm protocol .dcl WM_DELETE_WINDOW { exit }
mdi geometry 100 50
button .dcl.b -text Push -command exit
pack .dcl.b
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The asynchronous message ID is passed for the argument of the dcl_asyncproc procedure.  

The message IDs are shown below:  

7. 8    Hook Procedure 

A hook can be set in the debugger using the hook procedure.   

The hook procedures are shown below:   

proc dcl_asyncproc {mid} {
if {$mid == 19} {

redraw
}

}

Table 7-3　Message ID 

Message ID Meaning

9 After changing configuration 

10 After registering event 

11 After deleting event 

12 Before executing 

13 After breaking 

14 After resetting CPU 

15 After resetting debugger 

17 After changing extended option 

18 After changing debugger option 

19 After downloading 

20 After changing memory or register 

36 Before starting tracer 

37 After stopping tracer 

38 Before starting coverage

39 After stopping coverage

40 Before starting timer 

41 After stopping timer

42 After clearing trace 

45 After resetting symbol 

BeforeDownload Hook before downloading 

AfterDownload Hook after downloading
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By using hook procedures, register values can be changed before downloading programs or after

resetting the CPU.   

An actual example of the procedure is shown below.  A hook is valid till the debugger is closed.  

[When hook is set with debugger control command] 

1 Create script fileNote with an editor.  

Note: Be sure that the script file name is the same as the project file.  

Example:

The script file corresponding to test.prj is test.tcl.  

Allocate test.prj, test.pri, and test.tcl in the same directory. 

2 Start up the SM78Kx, select [Browse] menu -> [Console], and open the Console window.  

3 If the script file is executed in the window as below, the hook in the script file is set.  

%hook test.tcl

[When hook is set on downloading of project file] 

1 Create script fileNote with an editor.  

Note: Be sure that the script file name is the same as the project file.  

2 Start up the SM78Kx and read test.prj.  

The hook in the script file is set.  

 An example of the contents of a script file is shown as below.  

AfterCpuReset Hook after resetting CPU 

BeforeCpuRun Hook before starting execution 

AfterCpuStop Hook after breaking 

proc BeforeDownload {} {
register MM 0x7
register PMC8 0xff
register PMC9 0xff
register PMCX 0xe0

}

proc AfterCpuReset {} {
register MM 0x7
register PMC8 0xff
register PMC9 0xff
register PMCX 0xe0

}
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7. 9    Related Files  

• Executes when the aliases.tcl console is opened.  
Sets the default alias etc.  

• Executes when the project file name.tcl project is opened.   
The hook of BeforeDownload, AfterCpuReset, BeforeCpuRun and AfterCpuStop can be used.  

• Executes when the load module name.tcl load module is downloaded.  
The hook of BeforeDownload, AfterCpuReset, BeforeCpuRun and AfterCpuStop can be used.  

7. 10    Cautions 

• The separator for file and path is a slash (/).  

• When a console or an expansion window is active, the accelerator key cannot be acknowledged.  

• When a console is open, error messages are output to the console.  

• When the [F1] key on the console is pressed, the HTML format help is opened (not opened from the
menu).  

• To terminate the command forcibly, close the console.  

• The execution of external commands (DOS commands) is OFF by default.  
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7. 11    Commands 

In this section, each command is explained using the format shown below.  

Command name 

Gives a brief explanation of the function of the command.  

Name

Describes the command name.  

Input format

Describes the input format of the command.  

Functions  

Explains the functions of the command.  

Usage example  

Shows an example of the usage of the command.  
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address

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

address - Evaluation of address expression  

Input format  

address expression

Functions

Converts the address expression specified by expression into address.  

Usage example

(IDCON) 1 % address main

0xaa

(IDCON) 2 % address main+1

0xab
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assemble

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

assemble - Disassemble/line assemble  

Input format  

assemble ?options? address ?code?

Functions

Assembles the character strings specified by code from the address specified by address.   

When '.' is specified for address, it is understood as an address continuing from the immediately previous

assemble.   

When code is omitted, it is assembled from the address specified by address.   

The followings are options.  They are ignored for assembly.  

Usage example

(IDCON) 1 % assemble -n 5 main

0x000000aa  B7              PUSH  HL

0x000000ab  B1              PUSH  AX

0x000000ac  891C          MOVW  AX,SP

0x000000ae  D6              MOVW  HL,AX

0x000000af  A100           MOV   A,#0H

(IDCON) 2 % assemble main mov a,b

(IDCON) 3 % assemble . mov a,b

-code Command code is also displayed.  It is ignored for assembly.  

-number number number line is displayed.  It is ignored for assembly.  
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batch

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

batch - Executing batch (with echo)

Input format  

batch scriptname

Functions

Executes in batch with displaying files specified by scriptname on the screen.   

Nesting is possible.  

Usage example

(IDCON) 1 % clear

(IDCON) 2 % batch bat_file.tcl

(IDCON) 3 % tkcon save a:/log.txt
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breakpoint

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

breakpoint - Setting/deletion of breakpoint 

Input format  

breakpoint ?options? ?address1? ?address2?

breakpoint -delete brkno

breakpoint -enable brkno

breakpoint -disable brkno

breakpoint -information

Functions

Operates the breakpoint specified by options and address.  

If a breakpoint can be set correctly, the breakpoint number is returned.  

The following are options:  

 

-software A software break is specified. 

-hardware A hardware break is specified (default).  

-execute The address execution break is set (default).  

-beforeexecute The break before address execution is set.  

-read An address memory read break is set.  

-write An address memory write break is set.  

-access An address memory access break is set.  

-size size The access size is set (8, 16, or 32).  

-data value The data condition is set.  

-datamask value The data mask is set.  

-passvalue The pass count is set.  
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Usage example

(IDCON) 1 % breakpoint main

1

(IDCON) 2 % breakpoint -i

1 Brk00001 enable rammon.c#17

(IDCON) 3 % breakpoint -software sub

2

(IDCON) 4 % breakpoint -i

1 Brk00001 enable rammon.c#17

2 Brk00001 enable rammon.c#8

(IDCON) 5 % breakpoint -disable 2

(IDCON) 6 % breakpoint -i

1 Brk00001 enable rammon.c#17

2 Brk00001 disable rammon.c#8

(IDCON) 7 % breakpoint -delete 1

2 Brk00001 disable rammon.c#8

-information The list of breakpoints is displayed.  

-delete The breakpoint whose number is specified is deleted.  

-disable The breakpoint whose number is specified is disabled.  

-enable The breakpoint whose number is specified is enabled.  
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dbgexit

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

dbgexit - Terminating debugger  

Input format  

dbgexit ?options?

Functions

Terminates the debugger.   

The following are options:  

 

Usage example

(IDCON) 1 % dbgexit -saveprj

-saveprj Project is saved on terminating debugger.  
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download

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

download - Download of files  

Input format  

download ?options? filename ?offset?

Functions

Downloads file specified by filename according to options.   

If offset is specified, the address is shifted by the offset (if the data is in binary format, the load start

address is specified for offset).  

Usage example

(IDCON) 1 % download test.lmf

-binary Binary format data is downloaded.  

-coverage Coverage data is downloaded. 

-append Additional download is executed.  

-nosymbol Download is executed.  Symbol information is not read.  

-symbolony Symbol information only is read.

-reset CPU is reset after download.  

-information Download information is displayed.  
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extwin

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

extwin - Creation of expansion window 

Input format  

extwin scriptfile

Functions

Creates expansion window with scriptfile.  

Usage example

(IDCON) 1 % extwin d:/foo.tcl
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finish

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

finish - Returning from function 

Input format  

finish

Functions

Executes until it returns to the program that called the current function.  

Usage example

(IDCON) 1 % finish
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go

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

go - continuous execution  

Input format  

go ?options?

Functions

Executes the program continuously.  When -waitbreak is specified, it waits for the program to stop.   

The following are options:  

Usage example

(IDCON) 1 % go -w

-ignorebreak Breakpoint is ignored.  

-waitbreak The command waits for the program to stop.  
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help

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

help - Display of help  

Input format  

help

Functions

Displays Dcl help.  

Usage example

(IDCON) 1 % help
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hook

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

hook - Setting of hook  

Input format  

hook scriptfile

Functions

Sets the procedure for hook with scriptfile.  

Usage example

(IDCON) 1 % hook d:/foo.tcl
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jump

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

jump - Jump to window  

Input format  

jump -source -line filename ?line?

jump ?options? address

Functions

Displays the window specified by options.    

Usage example

(IDCON) 1 % jump -s main

(IDCON) 2 % jump -s -l mainfile.c 10

(IDCON) 3 % jump -m array

-source The Source window is displayed from the address specified by address.  

-assemble The Assemble window is displayed from the address specified by 
address.  

-memory The Memory window is displayed from the address specified by 
address.  

-coverage The Coverage window is displayed from the address specified by 
address. 

-line The command is moved to the line specified by ine.  
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map

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

map - Setting/deletion of memory mapping  

Input format  

map options address1 address2 ?accsize?

Functions

Sets, deletes, and displays memory mapping.  

The access size of 8, 16, or 32 is specified by accsize (the default is 8).  

The following are options:  

Usage example

(IDCON) 1 % map -i

1: 0 0x7fff 8 {IROM}

2: 0x8000 0x87ff 8 {Target RRM}

3: 0x8800 0x9fff 8 {Target}

4: 0xa000 0xf7ff 8 {NonMap}

5: 0xf800 0xfaff - {NonMap}

-erom Alternate ROM is mapped.  

-eram Alternate RAM is mapped.  

-stack Stack area is mapped.

-protect I/O protect area is mapped.  

-clear All the settings for the mapping are deleted.  

-information Refer to the setting for the mapping.  



CHAPTER 7  COMMAND REFERENCE

User’s Manual  U16768EJ1V0UM 463

6: 0xfb00 0xfedf 8 {Saddr}

7: 0xfee0 0xfeff 8 {Register}

8: 0xff00 0xffff 8 {SFR}

(IDCON) 2 % map -erom 0x100000 0x10ffff

(IDCON) 3 % map -c
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mdi

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

mdi - Setting of expansion window  

Input format  

mdi geometry ?x y? width height 

mdi title string

Functions

Sets the size and title name of the expansion window.  

The command can be used only from the expansion window.  

Usage example

(IDCON) 1 % mdi geometry 0 0 100 100 

(IDCON) 2 % mdi title foo
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memory

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

memory - Display/setting of memory  

Input format  

memory ?options? address ?value? 

memory ?options? -fill address1 address2 value 

memory ?options? -copy address1 address2 address3

Functions

Sets value in the memory of the address specified by address according to options.   

If value is omitted, display the value of the memory of the address specified by address.   

If -fill is specified, value is filled from address1 to address2.   

If -copy is specified, data from address1 to address2 is copied to address3.   

The following are options:   

 

Usage example

(IDCON) 1 % memory 100 

0x10 

(IDCON) 2 % memory 100 2 

(IDCON) 3 % memory 100 

-byte Displayed/set in one-byte units (default).  

-word Displayed/set in word units.   

-fill The data is filled in.  

-copy The data is copied.   

-noverify Verification is not executed on writing.   
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0x02 

(IDCON) 4 % memory -fill 0 1ff 0
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module

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

module - Display of the list of files and functions  

Input format  

module progname ?filename?

Functions

Displays the list of files and functions of the load module specified by progname.  

If filename is not specified, the list of files is displayed.  

If filename is specified, the list of functions of the specified files is displayed.  

Usage example

(IDCON) 1 % module rammon.lmf 

1: rammon.c 

(IDCON) 2 % module rammon.lmf rammon.c 

1: rammon.c sub1 

2: rammon.c main
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next

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

next - Procedure step

Input format  

next ?options?

Functions

Executes the procedure steps.  If functions are called, the step stops after executing function.  

 The following are options:  

Usage example

(IDCON) 1 % next -i 

(IDCON) 2 % next -s

-source Command is executed in source line units (default).  

-instruction Command is executed in command units.  
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refresh

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

refresh - Redrawing of window  

Input format  

refresh

Functions

Redraws the window and updates the data.  

Usage example

(IDCON) 1 % batch foo.tcl 

(IDCON) 2 % refresh
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register

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

register - Display/setting of register value and I/O register value  

Input format  

register ?options? regname ?value?

Functions

Sets value in the register specified with regname.  

If value is omitted, displays the value of the register specified by regname.   

The following are options:   

Usage example

(IDCON) 1 % register pc 

0x100 

(IDCON) 2 % register pc 200 

(IDCON) 3 % register pc 

0x200

-force Compulsory reading is executed.  

-bankno bankno A bank number is specified.
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reset

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

reset - Reset

Input format  

reset ?options?

Functions

Resets the CPU, debugger or symbols.   

If options are omitted, the CPU is reset.   

The following are options:   

Usage example

(IDCON) 1 % reset

-cpu CPU is reset (default).  

-debugger Debugger is reset.   

-symbol Symbol is reset.  

-event Event is reset.  
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run

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

run - Reset and execution of CPU  

Input format  

run  ?options?

Functions

Resets the program and executes it.  

If -waitbreak is not specified, the command does not wait until the program stops.   

The following are options:   

Usage example

(IDCON) 1 % run 

(IDCON) 2 % run -w

-waitbreak The command waits for the program to stop.  
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step

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

step - Step execution

Input format  

step ?options?

Functions

Executes step execution.  

If functions are called, the command stops at the head of the functions.   

The following are options:  

 

Usage example

(IDCON) 1 % step -i 

(IDCON) 2 % step -s

-source The command is executed in source line units (default).  

-instruction The command is executed in command units.  
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stop

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

stop - Stop executing  

Input format  

stop

Functions

Stops the program forcibly.  

Usage example

(IDCON) 1 % run 

(IDCON) 2 % stop
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upload

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

upload - Upload  

Input format  

upload ?options? filename address1 address2

Functions

Saves the memory data or coverage data within the specified range in a file.   

The following are options:   

Usage example

(IDCON) 1 % upload -b foo.hex 0 0xffff 

(IDCON) 2 % upload -c -f foo.cov 0 0xffff

-binary The data is saved in binary format.   

-coverage The coverage data is saved. 

-intel The data is saved in Intel standard HEX format or expanded HEX 
format (default).  

-motorola The data is saved in Motorola HEX format.  

-tektronix The data is saved in Tektronix HEX format.  

-force The file is overwritten.   
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version

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

version - Display of the version information  

Input format  

version

Functions

Displays the version information of the debugger.  

Usage example

(IDCON) 1 % version 

GUI : E2.00y [31-May-99] 

Devicefile : 78K0[uPD780034] E1.01a 

Debugger : 78K/0 Debugger E2.50c [02-Apr-99] 

Executer : 78K/0 Executer E1.3c 

Packet translator : 78K/0 Packet E2.00w 

Assembler : 78K/0 Asm/Disasm E1.15a [01-Apr-99] 

Tcl/Tk : 8.1.1
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watch

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

watch - Display/setting of variables  

Input format  

watch ?options? variable ?value?

Functions

Displays and sets the variables.   

The following are options:  

Usage example

(IDCON) 1 % watch var 

0x10 

(IDCON) 2 % watch -d var 

16 

(IDCON) 3 % watch array\[0\] 0xa

-binary The value is displayed in binary digits.   

-octal The value is displayed in octal digits.  

-decimal The value is displayed in decimal digits.   

-hexdecimal The value is displayed in hexdecimal digits.   

-string The value is displayed in character strings.  

-sizeof The size, instead of the value, of variables is displayed in decimal digits.   
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where

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

where - Trace of stack  

Input format  

where

Functions

Executes the back-trace of the stack.  

Usage example

(IDCON) 1 % where 

1: test2.c#sub2(int i)#13 

2: test.c#num(int i)#71 

3: test.c#main()#82
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wish

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

wish - Startup of Tclet  

Input format  

wish scriptname

Functions

Starts up the script using Tk (Tclet).   

The expansion window can be created with Tclet.  

Usage example

(IDCON) 1 % wish test.tcl
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xcoverage

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

xcoverage - Operation of coverage  

Input format  

xcoverage option

Functions

Operates coverage.   

The following are options:  

Usage example

(IDCON) 1 % xcoverage -start 

(IDCON) 2 % xcoverage -stop 

(IDCON) 3 % xcoverage -clear

-start The coverage starts on executing the program.  

-stop The coverage stops on executing the program.   

-clear The coverage memory is cleared.   
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xtime

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

xtime - Operation of timer  

Input format  

xtime option

Functions

Operates timer.   

The following are options:  

Usage example

(IDCON) 1 % xtime -start 

(IDCON) 2 % xtime -stop

-start Timer starts on executing the program.   

-stop Timer stops on executing the program.   
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xtrace

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

xtrace - Operation of tracer  

Input format  

xtrace -dump ?-append? frameno ?filename? 

xtrace -start 

xtrace -stop 

xtrace -clear 

xtrace -addup bool 

xtrace -mode mode

Functions

Operates tracer.   

The following are options:  

-start The tracer starts on executing the program.   

-stop The tracer stops on executing the program.    

-clear The trace data is dumped (default).   

-dump The dump result is redirected to the console window.   
If the file name is specified, the dump result is written in the file.   

-append The dump result is added to a file.  

-addup bool Whether the time tag is integrated or not is selected.   

-mode mode The trace control mode (any one of: all, cond, nonstop, fullstop, 
fullbreak, delaystop, delaybreak) is selected.  
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Usage example

(IDCON) 1 % xtrace -start 

(IDCON) 2 % xtrace -stop 

(IDCON) 3 % xtrace -dump 3 

_01685 2 000000BC M1 br _sub2+0x2 

_01686 4 0000009A BRM1 st.w r6, 0x8[sp] 

_01687 3 0000009E BRM1 st.w r0, 0x0[sp] 

(IDCON) 4 % xtrace -clear 

(IDCON) 5 % xtrace -addup true
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APPENDIX A  INPUT CONVENTIONS

 This appendix explains the input conventions of the following items:

• Character set

• Symbols

• Numeric Values

• Expressions and Operators

• File Names

A. 1    Character set 

The characters listed in Table A-1 can be used as the character set. 

The characters listed in Table A-2 can be used as special characters.

Specify a line number as an integer constant, starting from 1.

Table A-1　Usable Character Set

Classification Character

Alphabetic 
characters

Uppercase characters: A B C D E F G H I J K L M N O P Q R S T U V X W Z
Lowercase characters: a b c d e f g h I j k l m n o p q r s t u v x w z

Numerals 0123456789

Character 
equivalent to 
alphabetic 
character

@?_

Table A-2　List of Special Characters

Character Name Usage

( Left parenthesis Changes operation order.

) Right parenthesis Changes operation order.

+ Plus Addition operator or positive sign

- Minus Subtraction operator or negative sign

* Asterisk Multiplication operator or indirect reference operator

/ Slash Division operator

% Percent Remainder operator

~ Tilde Complement operator

| Vertical line Bit sum operator

^ Circumflex Bit difference operator

& Ampersand Bit product operator or address operator
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A. 2    Symbols

The following rules apply to symbols:

1 A symbol consists of characters A to Z, a to z, @, _ (underbar), . (period), ?, and 0 to 9.

2 A symbol must start with a character other than numerals 0 to 9.

3 Uppercase characters (A to Z) and lowercase characters (a to z) are distinguished.

4 A symbol must be no more than 2048 characters long (if a symbol of more than 256 characters is

defined, only the first 2048 characters are valid).

5 A symbol is defined by loading a load module file.

6 Symbols are classified into the following types by the valid range:

- Global symbol (assembly language, C language)

- Static symbol (C language)

 In-file static symbol

 In-function static symbol

- Local symbol (C language)

 In-module local symbol (assembly language)

 In-file local symbol

 In-function local symbol

 In-block local symbol

7 The following symbols are available for each language used:

- Assembly language

 Label name, constant name, bit symbol name

- C language

 Variable name (including pointer function name, enumeration type variable name, array name,

structure name, and union name)

 Function name, label name 

 Array element, structure element, union element, bit field (if the symbol is an array, structure, or

union)

8 A symbol can be described instead of an address or numeric value.

9 The valid range of a symbol is determined based on the source debug information when the source

file is assembled or compiled.

10 Describe only the symbol name of a global symbol.

11 A local symbol is expressed in pairs with a file name.

[ Left bracket Array subscript operator or base register specification symbol

] Right bracket Array subscript operator or base register specification symbol

. Period Direct member operator or bit position specifier

, Comma Delimiter between operands

Table A-2　List of Special Characters

Character Name Usage



486 User’s Manual  U16768EJ1V0UM

APPENDIX A  INPUT CONVENTIONS

A. 3    Numeric Values

The following four types of numeric values can be used.  The input format of each type is as shown

below.

The suffix (bold) and the alphabetic characters of hexadecimal numbers may be uppercase or lowercase

characters.  If the first character is A to F, 0 must be prefixed to it.  

In the input field of the debugger, decimal numbers or hexadecimal numbers are alternately selected,

depending on the default radix.

A. 4    Expressions and Operators

Expressions

An expression consists of constants, register names, SFR names, and symbols coupled by operators.

If an SFR name, label name, function name, or variable name is described as a symbol, an address is 

calculated as the value of the symbol.

The elements making up an expression, except operators, are called terms (constants and labels).  

Terms are called the first term, the second term, and so on, starting from the left.

Operators

The following operators of the C language can be used:

Table A-3　 Input Format of Numeric Values

numeric value Input format

Binary number nY
n...nY (n=0,1)

Octal number nO
n...nO (n=0,1,2,3,4,5,6,7)
nQ
n...nQ (n=0,1,2,3,4,5,6,7)

Decimal number n
n...n
nT
n...nT (n=0,1,2,3,4,5,6,7,8,9)

Hexadecimal numbers n
n...n
nH
n...nH
0xn
0xn...n (n=0,1,2,3,4,5,6,7,8,9,A,B,C,D,E,F)

Table A-4　 List of Operators

Symbol Meaning Explanation

Operators

+ Addition Returns the sum of the first and second terms.
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Rules of operation 

Operations are performed according to the priority of the operators.

- Subtraction Returns the difference between the first and second terms..

* Multiplication Returns the product of the first and second terms.

/ Division Divides the value of the first term by the value of the 
second term, and returns the integer of the result.

MOD
%

Remainder Divides the value of the first term by the value of the 
second term, and returns the remainder of the result.

- sign Unary operator 
(negative)

Returns 2's complement of the value of the term.

+ sign Unary operator 
(positive)

Returns the value of the term.

Logical operator

NOT
~

Negation Logically negates each bit of the term, and returns the 
result.

AND
&

Logical product Obtains the logical product of the values of the first and 
second terms on each bit, and returns the result.

OR
|

Logical sum Obtains the logical sum of the values of the first and 
second terms on each bit, and returns the result.

XOR
^

Exclusive logical 
sum

Obtains the exclusive logical sum of the values of the first 
and second terms on each bit, and returns the result.

Shift operator

SHR
>>

Right shift Shifts the value of the first term by the value (number of 
bits) of the second term to the right, and returns the result.  
As many 0s as the number of shifted bits are inserted in the 
higher bits.

SHL
<<

Left shift Shifts the value of the first term by the value (number of 
bits) of the second term to the left, and returns the result.  
As many 0s as the number of shifted bits are inserted in the 
lower bits.

Byte separation operator

HIGH Higher byte Of the lowest 16 bits of the term, returns the higher 8 bits.

LOW Lower byte Of the lowest 16 bits of the term, returns the lower 8 bits.

Word separation operator

HIGHW Higher word Of the 32 bits of the term, returns the higher 16 bits.

LOWW Lower word Of the 32 bits of the term, returns the lower 16 bits.

Other

( Left parenthesis Performs the operation in ( ) before the operation outside ( 
).
'(' and ')' are always used in pairs.) Right parenthesis

Table A-4　 List of Operators

Symbol Meaning Explanation
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•  If the priorities of the operators are the same, the operation is performed from the left toward the
right.

•  Performs the operation in ( ) before the operation outside ( ).

•  Each term in an operation is treated as unsigned 32-bit data.

•  All operation results are treated as unsigned 32-bit data.

•  If an overflow occurs during operation, the lower 32 bits are valid, and the overflow is not detected.

Terms

To describe a constant for a term, the following numeric values can be described.

A. 5    File Names

The following rules apply to source file names and execution module file names. 

1 Source file names and execution module file names consist of any combination of A to Z, a to z, _

(underbar), and 0 to 9. 

2 Uppercase characters (A to Z) and lowercase characters (a to z) are not distinguished. 

Table A-5　Operator Priority

Priority Operators

1                  Higher (, )

2 + sign, - sign, NOT, ~, HIGH, LOW, HIGHW, LOWW

3 *, /, MOD, %, SHR, >>, SHL, <<

4 +, -

5 AND, &

6                  Lower OR, |, XOR, ^

Table A-6　Range of Radixes

Radix Range

Binary number 0Y <= value <= 1111111111111111111111111111111Y (32 digits)

Octal number 0O <= value <= 37777777777O

Decimal number -2147483648 <= value <= 4294967295
(A negative decimal number is internally converted into a 2's 
complement.) 

Hexadecimal numbers 0H <= value <= 0FFFFFFFH
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APPENDIX B  EXPANSION WINDOWS

This chapter explains the following item about Expansion Window.

• Overview

• Activation

• Explanation of each sample window

B. 1    Overview

With theSM78Kx, the user can create custom windows in addition to the existing windows.

The Tcl (Tool Command Language) interpreter and the commands for controlling the debugger are

implemented in the SM78Kx. Users can create windows using this Tcl.

The SM78Kx is supplied with samples of the following expansion windows.

Caution: When the SM850 (SP850 Ver.3.0 or later) is installed, the "RRM Window" and 
"Memory Mapped I/O Window" can be selected.  However, these windows cannot be 
used in the SM78Kx.

B. 2    Activation

The expansion window can be activated by selecting List, Grep, RRM, Hook, or Memory in [Others] on

the [Browse] menu.

Reference: Each .tcl file is installed in NECTools32\BIN\idtcl\tools.

B. 3    Explanation of each sample window

Table B-1　List of Expansion Window

Window Name Function

List window Displays a list of the source files and functions.

Grep window Searches a character string.

Hook window Sets the hook procedure.
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List window

The lists of the source files and functions are displayed in a tree format in this window. When a function

name in the list is clicked, the corresponding source is displayed.

Figure B-1  List Window
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Grep window

Search for a character string is performed in the files under the source path.

When the search result is clicked, the corresponding source is displayed.

Figure B-2  Grep Window

Object Function

Pattern Input the character string to be searched.

<Mark> button Marks the searched character string.

<Clear> button Clears the marking

<Jump> button Put the cursor on a section in the search result and click this button to open 
the corresponding file

Match Case Select whether or not to distinguish uppercase and lowercase.

Filter Specify the type of the file to be searched.
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Hook window

This window is used to set a hook to the debugger, using a hook procedure.

The hook procedure enables changing the register value before downloading a program, or after a CPU

reset.

On this window, a hook can be set by using the following four tabs.

[BeforeDownload] tab: Hook before downloading

[AfterCpuReset] tab: Hook after CPU resetr

[BeforeCpuRun] tab: Hook before start of execution

[AfterCpuStop] tab: Hook after break

By setting a SFR by using the [BeforeDownload] tab before downloading the load module, for example,

downloading can be executed at high speeds. Access to the external memory is also facilitated by using this

tab.

In addition, please make reference Following URL (microcomputer home page FAQ) about a setup of

SFR.

http://www.necel.com/micro/

If the setting is saved as "project-file-name.tcl" in the directory where the project is stored, the setting is

executed when the project is next opened.

Figure B-3  Hook Window

Object Function

[BeforeDownload] tab Hook before downloading
Before downloading is performed, the register values input to the tab are 
automatically overwritten by the specified value.

[AfterCpuReset] tab Hook after resetting CPU
After resetting CPU, the register values input to the tab are automatically 
overwritten by the specified value.

[BeforeCpuRun] tab Hook before starting execution
Before starting execution, the register values input to the tab are 
automatically overwritten by the specified value.
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Caution: Specify the program register and the SFR for the register name.

[AfterCpuStop] tab Hook after breaking
After breaking, the register values input to the tab are automatically 
overwritten by the specified value.

<Test> button All the commands described on the tabs are tested.

<Save> button Saves all the tab contents to a file.
If the SM78Kx was activated from a project file, the file is saved as 
"project-file-name.tcl".

<Clear> button Clears all the descriptions on the tabs.

Object Function
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APPENDIX C  TERMINOLOGY

The major terms used throughout this manual are as follows:  

• Current window

• Delimiter (separator)

• Program

• File

• Function

• Structure

• Stack frame number

• Line

C. 1    Terminology

Current window

The current window is the window you are now in and operating by means of key input and menu 

selection.

Delimiter (separator)

The following separators can be used as the delimiter of file names, function names, variable names, 

and line numbers.

Program

A program is the execution unit to be debugged.  The debugger manages each one of the load module 

files specified on downloading as a program. 

To specify a program name, use a load module file name on downloading.

Current program

The current program is the program that contains the instruction currently breaking execution 

(instruction indicated by the PC).

When specifying a file in the current program, the program name may be omitted.

File 

Up to 127 characters can be handled in a file name with path.

Depending on the type of file, however, a file name of more than 127 characters can be specified.

Table C-1　Delimiter

Delimiter Meaning

# Used as a separator of file names, variable names, function names, and line 
numbers.

$ Used as a separator of load module names, file names, variable names, and 
function names.
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Current file

The current file is the source file that contains the instruction currently breaking execution (instruction 

indicated by the program counter (PC)). 

When specifying a line or function in the current file, the file name may be omitted.

Function

Indicates the functions constituting a C source program.

Current function

The current function is the function that contains the instruction currently breaking execution 

(instruction indicated by the program counter (PC)).

When accessing a local variable in the current function, specifying the function name may be omitted.

Structure

Structures and unions in C language are called structures.

The name structure is used if a structure or union variable is used without members explicitly specified.

Stack frame number

The stack frame number is a decimal integer starting from 1 and is assigned to the stack contents.  The 

shallower the nesting level of the stack, the higher the number.  A function having a stack number one 

less than that of a certain function is the function that calls the certain function.

Line

A line is specified in order to identify one line in the source file. 

Specify a line number as an integer constant, starting from 1.
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APPENDIX D  MESSAGES

This appendix explains the messages displayed in the Error/Warning dialog box of the simulator.  

D.1    Error/Warning Messages from Debugger Part

D. 1. 1    Display format of  debugger

Messages from the debugger part are generated and output to the Error/Warning dialog box when

"information that should be informed to users (fatal error, syntax error, and warning or questions)" is

detected while the debugger is executing processing.  

The product name is displayed on the title bar of the dialog box.  

Figure D-1 Error/Warning Messages from Debugger Part

There are three types of messages in the debugger (fatal error message, syntax error message, and

warning message or question message).  

A : Fatal error messages

When a fatal error is detected in the debugger, a message is output to the Error dialog box

before aborting the processing and terminating the debugger.  

F : Syntax error messages

When a syntax error is detected in the debugger, a message is output to the Error dialog box

before aborting the processing.  At this time, opened windows and dialog boxes are closed.  

W : Warning message or question message

When a warning or question is detected in the debugger, a message is output to the Warning

dialog box before aborting the processing.  

D. 1. 2    Fatal error messages

A list of the messages that are output when fatal errors are detected while the debugger is executing

processing is shown below in numerical order.  

Table D-1  Fantal error messages of SM78Kx (debugger part)

Error No. Message

A0101 Can not find initialization file (expc.ini).
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A0102 Host name not found.

A0105 [SM78K0,SM78K0S]
Failed in reading device file (d0xxx.78k).
[SM78K4]
Failed in reading device file (d4xxx.78k).
Countermeasure: Necessary files may be damaged.  Reinstall the device file.

A01a1 Failed in reading EX78K4.OM0 (SM78K4 only).

A01a6 Executor is running.

A01a7 [SM78K0,SM78K0S]
Failed in reading micro program file (m0xxx.78k).
[SM78K4]
Failed in reading micro program file (m4xxx.78k).

A01a8 Failed in reading initialization file (expc.ini).

A01d0 Failed in starting simulator.

A01d1 Not enough memory in starting simulator.

A04a1 Not enough memory for emulation. 

A0600 Not enough memory for buffer.
Countermeasure:  There is not enough system memory.  Close the applications being executed 

and the open files.

A1001 No entry exists for specified number.

A1002 Can not relocate internal RAM.

A1005 Illegal relocation address.

A1008 Not enough memory for tables.
Countermeasure:  There is not enough system memory.  Close the applications being executed 

and the open files.

A1009 Already initialized.

A100a Not initialized.

A1dbe Error occurred inside debugger.

A2001 Illegal address.

A2009 Device file is damaged or error is in file.

A200b Can not copy.

A200c Not enough memory.
Countermeasure:  There is not enough system memory.  Close the applications being executed 

and the open files.

A2222 Illegal condition.

A3012 Not enough memory. 
Countermeasure:  There is not enough system memory.  Close the applications being executed 

and the open files.

A4011 Not enough memory.
Countermeasure:  There is not enough system memory.  Close the applications being executed 

and the open files.

A4018 Not enough memory.
Countermeasure:  There is not enough system memory.  Close the applications being executed 

and the open files.

Table D-1  Fantal error messages of SM78Kx (debugger part)

Error No. Message
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A5000 Illegal device file type.

A5001 Not enough memory. 
Countermeasure:  There is not enough system memory.  Close the applications being executed 

and the open files.

A5002 Can not open device file.

A5003 Reading of device file went wrong.

A5004 Can not close device file.

A5005 Illegal device file format.
Countermeasure:  Necessary files may be damaged.  Reinstall the device file.

A5007 Device file has broken or error is in a file.

A500c Failed in reading expc.ini.

A500d Not enough memory.
Countermeasure:  There is not enough system memory.  Close the applications being executed 

and the open files.

A5300 Illegal device file type.

A5301 Not enough memory.
Countermeasure:  There is not enough system memory.  Close the applications being executed 

and the open files.

A5302 Can not open database file.
Countermeasure:  Necessary files may be damaged.  Reinstall the simulator and device file.

A5303 Reading of database file went wrong.

A5304 Can not close database file.

A5305 Illegal database file format.
Countermeasure:  Necessary files may be damaged.  Reinstall the debugger or simulator, and 

device file.

A5306 Database information has been already initialized.

A5307 Database information does not exist.

A7012 Not enough memory.
Countermeasure:  There is not enough system memory.  Close the applications being executed 

and the open files.

A70fe Bus hold error.
Countermeasure:  CPU is in the bus-hold status.  Reset the debugger.

A7f03 Failed in canceling RUN/STEP.

A9000 Specified register symbol does not exist.

A9001 Specified register symbol ID does not exist.

A9003 Illegal condition.

A9004 Too large register size.

Aa005 Not enough memory.
Countermeasure:  There is not enough system memory.  Close the applications being executed 

and the open files.

Aa00b Can not close file.

Aa00c Failed in reading file.
Countermeasure:  The file is damaged or does not exist.  Recreate the file.

Table D-1  Fantal error messages of SM78Kx (debugger part)

Error No. Message
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Aa013 Reading of file went wrong.

Ab009 Not enough memory.
Countermeasure:  There is not enough system memory.  Close the applications being executed 

and the open files.

Ab00d Current function does not exist.

Ab00e Current line does not exist.

Ab00f Tag not found.

Ab010 Failed in loading symbol table.

Ab011 Illegal line number.

Ab015 Reading of file went wrong.
Countermeasure:  The file is damaged or does not exist.  Recreate the file.

Ab016 Can not open file.
Countermeasure:  The file is damaged or does not exist.  Recreate the file.

Ab017 Failed in writing file.
Countermeasure:  The file is damaged or does not exist.  Recreate the file.

Ab019 Reading of file went wrong.

Ab01a Can not close file.

Ab01c Too many entries of the task kind .

Ab023 Current stack frame is not active.

Ab024 Different section.

Ab031 Already set in memory.

Ab032 Out of scope.

Ab033 LP is not stored.

Ab039 Failed in loading debug information.

Ab03a No more section information.

Ab041 Specified file is not load module.

Ac002 Can not close file.

Ac003 Reading of file went wrong.
Countermeasure:  The file is damaged or does not exist.  Recreate the file.

Ac004 Reading of file went wrong.

Ac009 Not enough memory.
Countermeasure:  There is not enough system memory.  Close the applications being executed 

and the open files.

Ad000 Error occurred inside debugger.

Ad001 Not enough memory.
Countermeasure:  There is not enough system memory.  Close the applications being executed 

and the open files.

Ad002 Failed in reading initialization file (expc.ini).

Ae008 Not enough memory
Countermeasure:  There is not enough system memory.  Close the applications being executed 

and the open files.

Table D-1  Fantal error messages of SM78Kx (debugger part)

Error No. Message
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D. 1. 3    Syntax error messages

A list of the messages that are output when syntax errors are detected while the debugger is executing

processing is shown below in numerical order.  

Af000 Not enough memory.
Countermeasure:  There is not enough system memory.  Close the applications being executed 

and the open files.

Table D-1  Fantal error messages of SM78Kx (debugger part)

Error No. Message

Table D-2  Syntax srror messeages of SM78Kx (debugger part)

Error No. Message

F0002 This feature is not supported.

F01a0 [SM78K0]
No response from the emulation CPU. Please confirm the signal of the CLOCK or RESET and so 
on.
[SM78K0S]
No response from the emulation CPU. Please confirm the signal of the CLOCK or RESET,WAIT 
and so on.
[SM78K4]
No response from the emulation CPU. Please confirm the signal of the CLOCK or 
RESET,WAIT,HLDRQ and so on.

F0200 No mapped address was accessed.
Countermeasure:  External memory could not be accessed, as it is not set.  Change the register 

values necessary for accessing the external memory using the SFR window 
or Hook Procedure before download.  

F02a0 Bus hold error.
Countermeasure:  CPU is in the bus-hold status.  Reset the debugger.

F02a2 CPU is in the bus-hold status.  Reset the debugger.

F02d2 Not enough memory for trace-buffer.

F0300 User program is running.

F0301 User program is being breaked.

F0302 User program is being traced.

F0303 Not traced.

F0304 Trace memory is not set.

F0306 No trace block exists.

F0307 No event condition exists.

F0308 No timer measurement is done.

F0309 No trigger frame exists.

F030a Tracer is being stopped.

F030b Specified snap-event has not been registered.

F030c Specified stub-event has not been registered.

F030d Timer is running.

F030e Memory copy area is overlapped.
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F030f Trace has been already set.

F0310 Event condition is not set.

F0311 Too many valid timer event conditions.

F0312 Specified timer event is not set.

F0313 illegal map range.
Countermeasure:  Check the setting in "Memory Mapping (mapping setting area)" in the 

Configuration dialog box.  When mapping to external memory has been 
performed, change the register values necessary for accessing the external 
memory using the SFR window or Hook Procedure before download.

F0315 Delay trigger cannot set with trace full mode.

F03a1 Step execution is being done.

F03a2 Timer and Tracer are running.

F03a3 Linking events and BRS events are mixed (SM78K0,SM78K0S only).

F03d0 Back-trace is being executed.

F03d1 Back-trace is being stopped.

F03d2 Back-trace execution point overrun oldest frame.

F03d3 Register status or Memory status cannot be set up other than Phase1 of event link.

F03d4 No back-trace information exists.

F03d5 Last command can not be backstepped.

F0400 Illegal condition.
Countermeasure:  Settings of the used in-circuit emulator and those of the Configuration dialog 

box may not match.  Check the Chip selection of "Chip (CPU selection area)".

F0401 Result of timer measurement overflowed.

F0402 Too many event conditions with pass count.

F0403 Too many address range conditions.

F0404 Too many simultaneously-usable-event conditions.

F0405 Too many snap-events.

F0406 Too many stub-events.

F0407 Too many initialization data.

F0408 Too large search data (> 16 byte).

F0409 Too large search data (> search range).

F040a Too many Linking-event conditions.

F04a0 Too many software breaks (> 100).

F04a2 Too many partition of bus size.

F04a3 Too many execution-event conditions.

F04a4 Too many bus-event conditions.

F0b61 Section Trace event conditions overflow.

F1003 Illegal relocation address.

F1004 Illegal condition

Table D-2  Syntax srror messeages of SM78Kx (debugger part)

Error No. Message
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F1006 Illegal address.

F100b User program is running.

F100c Different bus size has been already specified.

F100d Too large bus size.

F100e Too large bus partition size.

F1010 Illegal map range. 

F1011 Failed in setting internal ROM and RAM.

F1012 This feature is not supported.

F1013 No terminal name.

F1017 I/O Protect mapping is possible a target attribute only.

F1018 Illegal Internal ROM size.

F1019 Illegal Internal ROM size or Internal RAM size.

F2000 Illegal SFR name.

F2002 User program is running.

F2003 Illegal SFR number.

F2004 Illegal bit number.

F2006 Hidden SFR was specified.

F2007 SFR of ban read/write was specified.

F2008 SFR not existing was specified.

F200a Illegal value specified for SFR.

F3000 No mapped address was accessed.
Countermeasure:  The allocation addresses of the program and the addresses of the debugger 

may not match.  
Set the mapping to the external memory in "Memory Mapping (mapping 
setting area)" in the Configuration dialog box according to the allocation 
addresses specified in the link directive file on compilation.  When mapping to 
external memory has been executed, change the register values necessary 
for accessing the external memory using the SFR window or Hook Procedure 
before download.

F3001 Memory has different value.

F3002 Illegal start address.

F3003 Illegal end address

F3004 Illegal start address and end address.

F3005 Illegal condition.

F3006 User program is running.

F3007 Verification error.

F3008 No condition specified.

F3009 Parameter size does not align with access size alignment.

F300a Specified address does not align with access size alignment.

F300b Source address does not align with access size alignment.

Table D-2  Syntax srror messeages of SM78Kx (debugger part)

Error No. Message
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F300c Destination address does not align with access size alignment.

F300d Illegal end address.

F300e Different access size in specified area.

F300f Different access size both in source and destination areas.

F3010 Different access size in destination area.

F3011 Different access size, source & destination.

F3013 Failed in writing DMM.

F3014 Oveflowed mapping area.

F3015 Processing was interrupted.

F3016 This feature is not supported.

F4000 Can not delete specified event.
Countermeasure:  The specified event cannot be deleted as it is being used under another 

condition.  Invalidate it for other usages before deleting.

F4001 Illegal table number.

F4002 Illegal start address.

F4003 Illegal end address.

F4004 Illegal status.

F4005 Illegal data.

F4006 Specified event number has been already used.

F4007 Too many same events are registered.

F4008 Specified event has not been registered.

F4009 Illegal data size.

F400a Illegal mode.

F400b Setting value is inaccurate.

F400c Event link conditions cannot be used for section trace conditions.

F400d Too many identical events are registered (>= 32767).

F400e Specified event condition does not exist.

F400f Illegal event link condition.

F4010 Function not found.

F4012 Timer is being disabled.

F4014 Can not use software break.

F4015 Can not use event condition specifying address range.

F4016 Can not change event condition.

F4017 Can not access word at odd address.

F4019 This feature is not supported.

F401a No Event.

F401b Can not use tag-event.

Table D-2  Syntax srror messeages of SM78Kx (debugger part)

Error No. Message
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F401d Start event and end event of timer are not made to the same setup.

F401e Too many trace-events.

F401f Pass count cannot be set up.

F4020 Address range cannot be set up in event before execution.

F4021 Event conditions number overflow.

F4022 Software DMM conditions number overflow.

F4023 Real-time call conditions number overflow.

F4024 Software break call conditions number overflow.

F4318 Illegal memory bank setting.

F5008 Can not open device file.
Countermeasure:  Necessary files may be damaged.  Reinstall the device file.

F5009 Can not open EX78K4.OM0 (SM78K4 only).

F500a Specified device file is illegal version.
Countermeasure:  Necessary files may be damaged.  Reinstall the device file.

F5308 Can not open specified database file.
Countermeasure:  Necessary files may be damaged.  Reinstall debugger or simulator.

F5309 Specified database file is illegal version.
Countermeasure:  Necessary files may be damaged.  Reinstall the debugger or simulator, and 

the device file.

F6000 Current function does not exist.

F6001 Illegal symbol name.

F6002 Illegal condition.

F6003 Illegal function name.

F6004 Overflowed output buffer size.

F6005 Illegal expression.

F7000 Illegal mode.

F7001 User program is running.

F7002 User program has been stopped.

F7003 Trace enabled.

F7004 Trace memory is not set.

F7005 Function return address does not exist, can not do step execution.

F7801 End waiting state of step execution was canceled.

F7802 End waiting state of step execution was canceled.

F7f00 Aborted step execution.

F7f02 Suspended step execution.

F7f04 Can not execute non-mapped area.

F7f05 This feature is not supported.

F8000 Specified file was not found.

Table D-2  Syntax srror messeages of SM78Kx (debugger part)

Error No. Message



APPENDIX D  MESSAGES

User’s Manual  U16768EJ1V0UM 505

F8001 Illegal line number.

F8002 Current information is not set.

F8003 Illegal address.

F8004 This feature is not supported.

F9002 Illegal value.

F9005 This feature is not supported.

Fa001 Illegal expression.

Fa002 Start address is bigger than the end address.

Fa003 Illegal source path.

Fa004 Too long expression.

Fa006 Illegal argument.

Fa007 Illegal program number.

Fa008 Source path is not set.

Fa009 File not found.

Fa00a Can not open file.
Countermeasure:  The file is damaged or does not exist.  Recreate the file.

Fa00d Not source file of load module.

Fa00e Illegal line number.

Fa00f Variable does not exist.

Fa011 Can not access register.

Fa012 Can not access memory.

Fa014 It was going to open the binary file.

Fa015 Can not get temporary path.
Countermeasure:  The disk is full.  Delete or move unnecessary files and increase the available 

memory in the disk.

Fa016 Can not create temporary file.
Countermeasure:  The disk is full.  Delete or move unnecessary files and increase the available 

memory in the disk.

Fa017 Can not remove temporary file.

Fa020 This feature is not supported.

Fa021 Symbol assigned to register cannot be specified.

Fb000 Illegal command line.

Fb001 Program information does not exist in specified load module file.

Fb002 File not found.

Fb003 Function not found.

Fb004 Selected load module different from kind(Chip) was loaded.

Fb005 Symbol not found.
Countermeasure:  The address could not be found.  Specify a location holding address 

information.

Table D-2  Syntax srror messeages of SM78Kx (debugger part)
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Fb008 Illegal expression.

Fb00a Illegal symbol in load module file.

Fb00b Current program does not exist.

Fb00c Current file does not exist.

Fb012 Too large line number.

Fb01b Too long load module file name.

Fb01d Address not found.

Fb01f Can not find structure member.

Fb020 Can not find value.

Fb021 No debug information exists in load module file.
Countermeasure:  To create a load module with appended debug information, execute build in 

build mode of Debug Build.

Fb022 Illegal line number.

Fb026 Too many array dimensions (> 4).

Fb027 Found end of file.
Countermeasure:  The specified file may be damaged.  Recreate the file.

Fb028 This feature is not supported.

Fb029 Illegal address.

Fb02b Can not stack trace with current PC value.

Fb02c Too many blocks for one function.

Fb02d Illegal argument.

Fb02e The file does not exist in the SOURCE PATH.
Countermeasure:  On stopping the program, the source that the debugger tried to display could 

not be found.  Check if the path connects to the source (using "Source Path 
(source path specification area)" in the Debugger Option dialog box), or 
check if the source is in the same directory as the out file.  Refer to the 
Assemble window on which the error message is displayed, and check if the 
corresponding path connects.

Fb02f Information has been deleted because of optimization.

Fb034 Return execution from present PC position cannot be performed.

Fb037 Too Many Line-Numbers Information.

Fb038 Compiler version mismatch.
Countermeasure:  Recreate the load module with the latest compiler.

Fb040 Specified file is not load module.
Countermeasure:  This is not a linker output file.  Source debug cannot be executed with the 

load module before output from the linker.  Specify the load module output 
from the linker.

Fb32e Illegal port number.

Fb32f Illegal port name.

Fb330 Illegal port position.

Fb331 Illegal increment number.

Fb332 Port for memory bank is not set.

Table D-2  Syntax srror messeages of SM78Kx (debugger part)
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Fb333 Illegal bank number.

Fb334 Area for memory bank is not set.

Fc001 Can not open file.
Countermeasure:  The file is damaged or does not exist.  Recreate the file.

Fc005 Illegal file type.

Fc006 Kind(Chip) of load module is illegal.

Fc007 Specified file is not load module.
Countermeasure: This is not a linker output file.  Source debug cannot be executed with the 

load module before output from the linker.  Specify the load module output 
from the linker.

Fc008 Specified load module file (COFF) is old version.

Fc00a No mapped address was accessed.

Fc00b Load module is not loaded.

Fc00c Illegal argument.

Fc00d User program is running.

Fc00e User program is being traced.

Fc00f Interrupted.

Fc011 Illegal load module file format.

Fc012 Check sum error.

Fc013 Too wide address range to upload (> 1M byte).

Fc014 Failed in writing file.
Countermeasure:  The file is damaged or does not exist.  Recreate the file.

Fc015 Illegal program number.

Fc016 Load information is full.

Fc018 Specified file is not load module.
Countermeasure:  This is not a linker output file.  Source debug cannot be executed with the 

load module before output from the linker.  Specify the load module output 
from the linker.

Fc019 Failed in writing memory.

Fc01a No mapped address was accessed.

Fc100 This feature is not supported.

Fd004 Can not find Dynamic Link Library.

Fe000 Illegal argument.

Fe001 Illegal start address.

Fe002 Illegal end address.

Fe003 Too large size.

Fe004 Can not open file.
Countermeasure:  The file is damaged or does not exist.  Recreate the file.

Fe005 Failed in reading file.
Countermeasure:  The file is damaged or does not exist.  Recreate the file.

Fe006 Reading of file went wrong.

Table D-2  Syntax srror messeages of SM78Kx (debugger part)
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Fe007 Failed in writing file.
Countermeasure:  The file is damaged or does not exist.  Recreate the file.

Fe009 Illegal file format.

Fe00a Verification error.

Fe010 This feature is not supported.

Ff001 [XXX] not found.

Ff004 Missing parameter.

Ff005 Illegal function name.

Ff006 Illegal number.

Ff007 Start address is bigger than end address.

Ff008 Illegal symbol or expression.

Ff009 [XXX] This file is illegal type.

Ff100 Disk cannot write or full.

Ff101 File not found.

Ff102 File not Create.

Ff103 Old project file version.

Ff104 Illegal project file format.

Ff105 This file is a project file for [XXX].Please select a correct file.

Ff201 Memory mapping error.

Ff202 Verify error.
Countermeasure:  External memory could not be accessed, as it is not set. 

Ff301 The symbol being used on the event condition can't be evaluated.

Ff306 This name is too long.

Ff307 There is the same name in other kinds.

Ff308 An address can't be omitted.

Ff309 Illegal address mask.

Ff30a Illegal data mask.

Ff30b Illegal ext probe mask.

Ff30c Illegal ext probe data.

Ff30d Illegal pass count.

Ff30e Illegal register name.

Ff30f Illegal register bank.

Ff310 Illegal delay count.

Ff312 [XXX] is already there.

Ff313 Event number already exist.

Ff314 Event name is not set.

Ff315 [XXX] is already there.

Table D-2  Syntax srror messeages of SM78Kx (debugger part)
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Ff316 Max number of enabled [XXX] event is over. Please disable other enabled [YYY] event.

Ff317 Max number of set event is over.

Ff31e Illegal start address.

Ff31f Illegal end address.

Ff322 Illegal count rate.

Ff323 Illegal time out break count.

Ff324 Section and Qualify can not be specified at the same time.

Ff350 There is a phase which event are not in the middle.

Ff351 The same event is contained in Link and Disable.

Ff352 An event isn't specified.

Ff357 AND event is in Phase.

Ff400 Coverage mapping error.

Ff500 Illegal symbol.

Ff501 Illegal value.

Ff502 Illegal parameter.

Ff503 Max number of symbol is over.

Ff504 This variable cannot be set as a break.
Countermeasure:  Break cannot be set for the following variables.

• Local variables, static variables

• Array variables, member variables of structures/unions

• Register/SFR

• Variable expressions

Ff800 Configuration of Memory Bank is not set.

Ff801 BANK address must be in target memory.

Ff802 All events are deleted. because the use of external probe was changed.

Ff803 This event address is invalid on current configuration.

Ff804 Invalid PC value.

Ff805 Cannot set temporary break on this address.

Ff806 External data is being used by Debugger.

Ff900 Illegal I/O port name.

Ff901 Memory mapping error.
Countermeasure:  The specification of the address is illegal.  The addresses that can be 

specified are in either the Target area or SFR area.  Check in "Address: (I/O 
port address specification area)" in the Add I/O Port dialog box.

Ff902 Illegal access size.

Ff903 Illegal access type.

Ff904 There is the same name.
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D. 1. 4    Warning message or question message

A list of the messages that are output when warnings or questions are detected while the debugger is

executing processing is shown below in numerical order.  

Ffa00 The [XXX] function of current program in PC position not found.
Countermeasure:  The symbol specified in main() label: in "Startup Routine (start-up symbol 

setting area)" in the Debugger Option dialog box could be found.  Set a 
symbol of the main routine of the program.  Default is _main.

Ffa01 The line information on PC position not found.
Countermeasure:  The source file corresponding to program counter (PC) value when the 

program was stopped could not be found.  The following reasons are 
possible.

1 The source file exists in a location that the source path does not connect to.

2 The program stopped where the source files, such as library or RX, do not exist.

3 The program looped, jumped to an address that is not used by the program, and
stopped there.

Ffc00 Help window cannot be started.  Please install HTML Help environment with reference to a users 
manual.

Fffff Interrupted.

Table D-2  Syntax srror messeages of SM78Kx (debugger part)
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W1014 Data is not exist.

W2005 SFR of Read Protect attribute was specified.

W200d No initialize data for SFR.

W4013 Access size is different from its mapped bus size.

W401c Software break can not be set on this area.

W500b Specified device file does not relocate IRAM.

W7010 No source information exists.

W7011 Unknown result of step execution.

Wb01e No debug information (not compiled in Debug Build mode).

Wb036 Out of variable region.

Wb042 Symbol module is not initialized.

Wb335 Too long symbol name.

Wc017 Symbol information is duplicated, please reset symbols.

Wc01d Selected load module different from kind(Chip) was loaded.

Wf002 Not found [XXX]. Search from the beginning?

Wf003 Already exceed search region.

Wf106 CPU in the Project File was Changed.  You must exit the debugger for the new CPU.  Do you exit 
the Debugger?
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Wf107 CPU in the Project File was Changed.  Do you start the Debugger with this CPU?

Wf108 Selected project file different [YYY] from chip [XXX] was opened.  Does it open, although the chip 
cannot be changed?

Wf109 Project Manager cannot be used with the debugger of this version.  Please use PMplus.

Wf200 No differences encountered.

Wf203 When a program is running, while rewriting a memory, program execution stops for a moment.  
Do you wish to rewrite a memory?

Wf300 Would you like to save the changes made in [XXX]?

Wf302 Delete: [XXX]

Wf303 [XXX] is edited. Delete: [YYY]?

Wf304 [XXX] is edited. Save: [YYY]?

Wf305 [XXX] is already exist. Do you replace it?

Wf311 Only one [XXX] can be enabled.  Do you make this [YYY] to enable?

Wf401 Clear coverage?

Wf600 Save project file?

Wf700 Do you want to download Load Module File?

Wf905 [XXX] is already exist. Do you replace it?

Wf906 Would you like to register the change made in [XXX]?

Wfb00 User program is running. Do you want to stop user program?

Wfe0b It shift to the flash mode. Is it completely cleared but is the present event.

Table D-3  Warning message or question message of SM78Kx (debugger part)

Error No. Message



512 User’s Manual  U16768EJ1V0UM

APPENDIX D  MESSAGES

D.2    Error/Warning Messages From The Simulator Part

D. 2. 1    Display format of simulator

Simulator messages are generated and output to the Error/Warning dialog box when "information to be

reported to users (error or warning)" is detected while the simulator is executing processing.  

"Error" or "Warning" is displayed on the title bar of the dialog box.  

Figure D-2 Simulator Error/Warning Dialog Box

There are two types of simulator messages (error messages and warning messages).  

E : Error messages

With the debugger, when an error is detected, a message is output to the Error dialog box and

the processing is stopped.  

W : Warning message

With the debugger, when a warning is detected, a message is output to the Warning dialog box

and the processing is continued.  

D. 2. 2    Error messages

A list of messages that are output when errors are detected while the simulator is executing processing is

shown in numerical order.  

Table D-4  Fantal error messages of SM78Kx (simulator part)

Error No. Message

E10000 Could not allocate input data buffer.
Countermeasure: Area for input data buffer could not be secured on downloading.  Close other 

applications and secure memory.

E10001 Could not allocate system memory for input data loading.
Countermeasure: System memory for input data loading could not be secured.  Close other 

applications and secure memory.

E10002 Could not allocate output data buffer.
Countermeasure: Area for output data buffer could not be secured.  Close other applications 

and secure memory.

E10003 Failed to load input data.
Countermeasure: Input data could not be loaded.  Close other applications and secure memory.

E10004 The main clock and sub clock cannot be set to 0Hz at the same time.
Countermeasure: 0 Hz is set for both for main clock and subclock.  Set another value for either 

the main clock or subclock.
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E10005 An error occurred during output file operation. Simulation stopped.
Countermeasure: An error occurred in an output file operation.  Check the disk status to 

generate a correct file.

E10006 An error occurred in output data display. Simulation stopped.
Countermeasure: An error occurred in an output data display operation of the Output Timing 

Chart window.  Check the disk status to generate a correct file.

E10007 Failed to open output file.
Countermeasure: Output file could not be opened.  Check the disk status to generate a correct 

file.

E10008 Failed to write to output file.
Countermeasure: Writing operation to output file failed.  Check the disk status to generate a 

correct file.

E10009 Could not allocate memory.
Countermeasure: Memory could not be secured.  Close other applications and secure memory.

E1000a The file name is not correct.
Countermeasure: An incorrect file name was specified.  Specify a correct file name.

E1000b The file name or the path is not correct.
Countermeasure: A non-existent file name was specified.  Specify a correct file name or path 

name.

E1000c Cannot overwrite file.
Countermeasure: Writing to file failed.  Check the disk status to generate a correct file.

E1000d Cannot read file.
Countermeasure: Reading from file failed.  Verify that the file exists or check the contents of the 

file.

E1000e Cannot create file.
Countermeasure: File could not be created in the Down Load dialog box.  Check the disk status 

to generate a correct file.

E1000f The file type is not correct.
Countermeasure: An attempt was made to save the file with an incorrect extension.  Specify a 

correct extension to save the file.

E10010 Cannot search output signal.
Countermeasure: An attempt was made to edit output signal search data in the Search window.  

Check the message and operation.

E10011 Cannot search interrupt data.
Countermeasure: An attempt was made to edit interrupting signal search data in the Search 

window.  Check the message and operation.

E10012 Cannot search analog output data.
Countermeasure: An attempt was made to edit analog output signal search data in the Search 

window.  Check the message and operation.

E10013 Cannot search analog input data.
Countermeasure: An attempt was made to edit analog input signal search data in the Search 

window.  Check the message and operation.

E10014 Could not find searching data.
Countermeasure: The data matching the Search window data does not exist.  Check the 

message.

E10015 Search window is already displayed.
Countermeasure: An attempt was made to open two Search windows at the same time. Cancel 

the existing Search window and open a new one.

E10016 There is no data for loading in input data file.
Countermeasure: Input data file was loaded to the end.  Add the information you want to enter 

in the input data file.

Table D-4  Fantal error messages of SM78Kx (simulator part)

Error No. Message
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E10017 Data cannot be input from external devices during backtrace execution.
Countermeasure: On executing back-trace, An attempt was made to enter data from external 

parts.  Do not enter from external parts during back trace.

E10018 Address(xxxxxxxx) is not correct.
Countermeasure: The address value entered in the SFR Event & Action dialog box is outside 

the settable range.  Enter a settable address value.

E1001a STATUS(xxxxxxxx) is not correct.
Countermeasure: The status entered in the SFR Event & Action window is incorrect.  Enter a 

settable status.

E1001b Access Size(xxxxxxxx) is not correct.
Countermeasure: The access size entered in the  SFR Event & Action dialog box is incorrect.  

Enter a settable access size.

E1001c Data(xxxxxxxx) is not correct.
Countermeasure: The data value entered in  SFR Event & Action dialog box is outside the 

settable range.  Enter a settable data value.

E1001d Data Mask(xxxxxxxx) is not correct.
Countermeasure: The data mask value entered in the  SFR Event & Action dialog box is outside 

the settable range.  Enter a settable data mask value.

E1001e Pass Count(xxxxxxxx) is not correct.
Countermeasure: The path count value entered in the  SFR Event & Action dialog box is outside 

the settable range.  Enter a settable path count value.

E1001f Timing Value(xxxxxxxx) is not correct.
Countermeasure: The timing value entered in the SFR Event & Action dialog box is outside the 

settable range.  Enter a settable timing value.

E10020 Interrupt name(xxxxxxxx) is not correct.
Countermeasure: The unit of timing entered in the  SFR Event & Action dialog box is incorrect.  

Enter a settable unit of timing.

E10021 Interrupt name(xxxxxxxx) is not correct.
Countermeasure: The interrupt request name entered in the  SFR Event & Action dialog box is 

incorrect.  Enter a settable interrupt request name.

E10022 Pin name(xxxxxxxx) is not correct.
Countermeasure: An incorrect pin name was set.  Set a correct pin name.

E10024 SFR name(xxxxxxxx) is not correct.
Countermeasure: The SFR name entered in the  SFR Event & Action dialog box is incorrect.  

Enter a settable SFR name.

E10025 The data is empty.
Countermeasure: An attempt was made to save an empty file.  Create data.

E10026 This function is not supported in this version.
Countermeasure: An attempt was made to use an unsupported function.  Check the message 

and operation.

E10027 Editing the interrupt data is not permitted.
Countermeasure: An attempt was made to edit interrupt signal data.  Check the message and 

operation.

E10028 Editing the analog output data is not permitted.
Countermeasure: An attempt was made to edit analog output signals.  Check the message and 

operation.

E10029 Please input file name.
Countermeasure: The OK button was clicked without entering a file name.  Enter a file name.

E1002a The File name has been changed to (xxxxxxxx).
Countermeasure: The file name entered in the Down Load dialog box is incorrect.  Check the 

message and operation.

Table D-4  Fantal error messages of SM78Kx (simulator part)

Error No. Message
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E1002b This will overwrite download data of pin (xxxxxxxx).
Countermeasure: Data to the same pin were set for multiple files in the Down Load dialog box.  

Check the message and operation.

E1002c Illegal pin name (xxxxxxxx) exists.
Countermeasure: An incorrect pin name is set.  Set a correct pin name.

E1002d Pin name (xxxxxxxx) is not correct.
Countermeasure: An incorrect pin name is set.  Set a correct pin name.

E1002e Pin name (xxxxxxxx) has already been set.
Countermeasure: The same pin was set more than once in the Pin Setting dialog box.  Specify 

one pin for one place.

E1002f The connection to the pin(xxxxxxxx) will change.
Countermeasure: An event that would change the destination of data captured at the pin 

occurred, or an external part was connected to the pin.  Check the message.

E10030 Editing the output data is not permitted.
Countermeasure: An attempt was made to edit output signal data.  Check the operation.

E10031 Failed to open trace file.
Countermeasure: Trace file could not be opened.  Check the disk status.

E10032 Failed to write to trace file.
Countermeasure: Writing to the trace file failed.  Check the disk status.

E10033 Mismatch database-file(simulator) format. xxxx is expected version.
Countermeasure: Database file for simulator is incorrect.  Obtain the latest device file and 

database file and reinstall them.

E10034 Can not open data-basefile (simulator).
Countermeasure: Database file for simulator cannot be opened.  Check the disk status and 

reinstall a device file and a database file.

E10035 Unexpected contents of database-file (simulator).
Countermeasure: Database file for simulator is incorrect.  Obtain the latest device file and 

database file and reinstall them.

E10036 Creating file name (xxxx).
Countermeasure: Outputting to a file now.  Cancel the current file output and specify the file 

output again.

E10037 Please input file name.
Countermeasure: Output file name is not specified.  Specify an output file name.

E10038 Cannot display window.
Countermeasure: Window handle is lacking.  Close other applications to acquire a window 

handle and restart the simulator.

E10100 The selected pin name does not exist.
Countermeasure: The set pin does not exist.  Set a pin name that exists on the target device.

E10101 The pin name is a 2-byte name.
Countermeasure: The set pin name is described with 2-byte characters.  Describe the pin name 

with 1-byte characters.

E10102 No Key Matrix present.
Countermeasure: No input pin or output pin is set in the Key Matrixes window.  Set at least one 

input pin and one output pin.

E10103 Hold time is invalid.
Countermeasure: Retention time is not set within the settable range or is not a numerical value.  

Set the retention time within the range 999msec to 0.001msec.

E10104 Segment signal setting is invalid.
Countermeasure: Pin names for segments are not described or the setting is not complete.  Set 

all the eight (or fifteen) pins for segments.

Table D-4  Fantal error messages of SM78Kx (simulator part)
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E10105 Disit signal setting is invalid.
Countermeasure: Pin names for digit signals are not described, or are set discontinuously.  Set 

the pins for digit signals from the lowest digit continuously.

E10106 The selected pin is not an analog input pin.
Countermeasure: Pin name of a pin not for analog data was set.  Set a pin for analog data.

E10107 AVref is above/under operating voltage range.
Countermeasure: AVref is not within the range of operating voltage.  Set it within the range of 

operating voltage.

E10108 The segment/grid setting is above/under the range.
Countermeasure: The range for the display segment is not set or the range for the display 

timing output is not set.  Set the range for the display segment or display 
timing output.

E10109 FIP segment/grid setting is invalid.
Countermeasure: The settings of the range for the display segment and display timing output 

are not correct.  Set the range for the display segment and display timing 
output.

E1010a The selected bit map file does not exist.
Countermeasure: The bitmap file name of active/inactive status in the Bitmap Entry dialog box 

does not exist.  Set an existing bitmap file name.

E1010c The selected bit map file is invalid.
Countermeasure: A bitmap file specified in the  Bitmap Entry dialog box is incorrect.  Set a 

bitmap format file.

E1010d The number of associated bit maps exceeded 384.
Countermeasure: The registered bitmap files are more than the maximum number, 384, in the 

Bitmap Entry dialog box.  Make the number of files registered 384 or fewer.

E1010e The bit map ID is a 2-byte ID.
Countermeasure: The bitmap numbers are described with 2-byte characters in the  Bitmap 

Entry dialog box.  Set the bitmap number with 1-byte characters.

E1010f The number of associated text/line/rectangle exceeded 20.
Countermeasure: The sum of the character strings, lines, or rectangles is over 20 in the Parts 

window.  Stop entering characters, lines, or rectangles.

E10110 Could not get address of user's function.
Countermeasure: The function names specified in functions called from user DLL 

(UpCallFuncName, UpLoadProjName, UpSaveProjName, 
UpResetFuncName) did not exist or were not exported.  Create the function 
names specified in simulation call function, or declare EXPORTS in def file.

E10111 An error occurred during 7 Segment LED Port Setting Window creation.
Countermeasure: Window handle is lacking.  Close other applications to acquire a window 

handle and restart the simulator.

E10112 An error occurred during Button Port Setting Window creation.
Countermeasure: Window handle is lacking.  Close other applications to acquire a window 

handle and restart the simulator.

E10113 An error occurred during Internal Interrupt Button Setting Window creation.
Countermeasure: Window handle is lacking.  Close other applications to acquire a window 

handle and restart the simulator.

E10114 An error occurred during Buzzer Select Window creation.
Countermeasure: Window handle is lacking.  Close other applications to acquire a window 

handle and restart the simulator.

E10115 An error occurred during FIP Select Window creation.
Countermeasure: Window handle is lacking.  Close other applications to acquire a window 

handle and restart the simulator.

Table D-4  Fantal error messages of SM78Kx (simulator part)
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E10116 An error occurred during Key Port Setting Window creation.
Countermeasure: Window handle is lacking.  Close other applications to acquire a window 

handle and restart the simulator.

E10117 An error occurred during LCD Port Setting Window creation.
Countermeasure: Window handle is lacking.  Close other applications to acquire a window 

handle and restart the simulator.

E10118 An error occurred during LED Port Setting Window creation.
Countermeasure: Window handle is lacking.  Close other applications to acquire a window 

handle and restart the simulator.

E10119 An error occurred during Port Level Gauge Setting Window creation.
Countermeasure: Window handle is lacking.  Close other applications to acquire a window 

handle and restart the simulator.

E1011a An error occurred during DC Motor Port Setting Window creation.
Countermeasure: Window handle is lacking.  Close other applications to acquire a window 

handle and restart the simulator.

E1011d Could not make buzzer sound.
Countermeasure: A soundboard and a speaker are lacking.  Mount a soundboard and a 

speaker.

E1011e Could not create Buzzer Display Window.
Countermeasure: Window handle is lacking.  Close other applications to acquire a window 

handle and restart the simulator.

E1011f Could not create DC Motor Display Window.
Countermeasure: Window handle is lacking.  Close other applications to acquire a window 

handle and restart the simulator.

E10120 Could not allocate FIP display table.
Countermeasure: Memory could not be secured.  Close other applications and secure memory.

E10121 Could not allocate LCD display table.
Countermeasure: Memory could not be secured.  Close other applications and secure memory.

E10122 Could not allocate LED display table.
Countermeasure: Memory could not be secured.  Close other applications and secure memory.

E10123 Could not create LED Display Window.
Countermeasure: Window handle is lacking.  Close other applications to acquire a window 

handle and restart the simulator.

E10124 The selected pin name is already set.
Countermeasure: An attempt was made to re-set a pin that had already been set in the Buttons 

dialog box.  Do not set a pin that has been already set.

E10125 Could not create Reset Button Window.
Countermeasure: Window handle is lacking.  Close other applications to acquire a window 

handle and restart the simulator.

E10126 An error occurred during the creation of the brush for the 7 segment LED.
Countermeasure: The brush handle could not be secured.  Close other applications and restart 

the simulator.

E10127 An error occurred during the creation of the pen for the 7 segment LED.
Countermeasure: The pen handle could not be secured.  Close other applications and restart 

the simulator.

E10128 An error occurred during covering of the 7 segment LED.
Countermeasure: The drawing of the 7-segment display was not correct.  Close other 

applications and restart the simulator.

E10129 An error occurred during the selection of the pen for the 7 segment LED.
Countermeasure: The drawing of the 7-segment display was not correct.  Close other 

applications and restart the simulator.

Table D-4  Fantal error messages of SM78Kx (simulator part)
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E1012a An error occurred during the selection of the brush for the 7 segment LED.
Countermeasure: The drawing of the 7-segment display was not correct.  Close other 

applications and restart the simulator.

E1012b An error occurred during drawing of the 7 segment LED.
Countermeasure: The drawing of the 7-segment display was not correct.  Close other 

applications and restart the simulator.

E1012c Could not create 7 Segment LED Display Window.
Countermeasure: Window handle is lacking.  Close other applications to acquire a window 

handle and restart the simulator.

E1012d An error occurred during usre's dll loading.
Countermeasure: An attempt was made to read a user DLL that is incorrect.  Use a correct user 

DLL.

E1012e An error occurred during usre's dll opening.
Countermeasure: An attempt was made to read a user DLL that is incorrect.  Use a correct user 

DLL.

E1012f An error occurred during GDI object creating.
Countermeasure: Failed to secure a correct bitmap format drawing in placement mode in the 

Parts window.  Close other applications and restart the simulator.

E10130 An error occurred during the creation of the brush for the 14 segment LED.
Countermeasure: The brush handle could not be secured.  Close other applications and restart 

the simulator.

E10131 An error occurred during the creation of the pen for the 14 segment LED.
Countermeasure: The pen handle could not be secured.  Close other applications and restart 

the simulator.

E10132 An error occurred during covering of the 14 segment LED.
Countermeasure: The drawing of the 14-segment display was not correct.  Close other 

applications and restart the simulator.

E10133 An error occurred during the selection of the pen for the 14 segment LED.
Countermeasure: The drawing of the 14-segment display was not correct.  Close other 

applications and restart the simulator.

E10134 An error occurred during the selection of the brush for the 14 segment LED.
Countermeasure: The drawing of the 14-segment display was not correct.  Close other 

applications and restart the simulator.

E10135 An error occurred during drawing of the 14 segment LED.
Countermeasure: The drawing of the 14-segment display was not correct.  Close other 

applications and restart the simulator.

E10136 Could not create 14 Segment LED Display Window.
Countermeasure: Window handle is lacking.  Close other applications to acquire a window 

handle and restart the simulator.

E10137 The path is illegal.
Countermeasure: On registering a bitmap, an incorrect path was specified.  Specify a correct 

path.

E10138 An error occurred during memory allocation.
Countermeasure: Memory could not be secured.  Close other applications and secure memory.

E10139 Allocation error.
Countermeasure: Memory could not be secured.  Close other applications and secure memory.

E1013a An error occurred during PLL Information Window creation.
Countermeasure: Window handle is lacking.  Close other applications to acquire a window 

handle and restart the simulator.

Table D-4  Fantal error messages of SM78Kx (simulator part)
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E1013b An error occurred during Serial Information Window creation.
Countermeasure: Window handle is lacking.  Close other applications to acquire a window 

handle and restart the simulator.

E1013c Setting Data is invalid.
Countermeasure: An incorrect frequency was set in the PLL information window.  Set a correct 

frequency.

E1013d Cannot Group 7/14 Segment.
Countermeasure: Selected and tried to group a 7/14 segment.  Deselect a 7/14 segment for 

grouping.

E1013e An error occurred during Pull-Up / Pull-Down Setting Window creation.
Countermeasure: Window handle is lacking.  Close other applications to acquire a window 

handle and restart the simulator.

E1013f Register class entry error.
Countermeasure: Window class could not be registered.  Close other applications and secure 

memory.

E10140 Could not allocate DC motor display table.
Countermeasure: Memory could not be secured.  Close other applications and secure memory.

E10141 This function is not supported in this device.
Countermeasure: An attempt was made to use an unsupported function.  Select a function 

supported by the target device.

E10142 The number of loaded usre's dll is over max number.
Countermeasure: The user DLL read functions are more than the maximum number, 6. Make 

read functions 6 or fewer.

E10143 An error occurred during memory allocation.
Countermeasure: Memory could not be secured.  Close other applications and secure memory.

E10144 An error occurred during memory locking.
Countermeasure: Memory could not be secured.  Close other applications and secure memory.

E10145 Illegal Bit Pattern.Illegal Bit Pattern.
Countermeasure: The register settings related to interrupts are incorrect.  Verify the register 

settings related to interrupts.

E10146 CPU-clk is fxt/2,but you set SCC.
Countermeasure: The setting that stops subclock oscillation was set, although the CPU is 

running with the subclock.  Run the subclock.

E10147 By Vector simulator returned state not expected.Vector Simulator running?
Countermeasure: The CAN simulator is not running or has stopped.  Start the CAN simulator or 

change it to the run status.

E10148 Write access violation.
Countermeasure: The write-protected FCAN register was written to.  Stop the write operation.

E10149 Read access violation.
Countermeasure: An attempt was made to read the read-protected FCAN register.  Stop the 

read operation.

E1014a Writing to CxBRP/CxSYNC is only possible in INIT mode.
Countermeasure: CxBRP/CxSYNC was written to when it was not in INIT mode.  Write in INIT 

mode.

E1014b Loading Interface file to Vector 'NecSim.Dll' failed.
Countermeasure: NecSim.Dll, which is necessary for communication with the CAN simulator, is 

not on the path.  Set the path for NecSim.Dll on the system.

E1014c Determining functions in Vector Interface Library failed.
Countermeasure: NecSim.Dll may be damaged, or the version may be old.  Reinstall the latest 

simulator.

Table D-4  Fantal error messages of SM78Kx (simulator part)
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E1014d An error occurred in communication with a CAN simulator.
Countermeasure: A system error occurred in communication with the CAN simulator.  Check the 

executing environment of the CAN simulator.

E10200 The active H/L is not HIGH or LOW.
Countermeasure: The described active H/L is a value other than HIGH or LOW.  Describe HIGH 

or LOW in the active H/L.

E10201 The channel number is not 4 or 8.
Countermeasure: The described number of the channels is a value other than 4 or 8.  Describe 

4 or 8 for the number of the channels according to the number of the pins.

E10202 The phase is not 0 or 1.
Countermeasure: The described excitation value is a value other than 0 or 1.  Describe 0 or 1 

for excitation according to the excitation method.

E10203 The minimum step angle does not divide to 360.
Countermeasure: The described minimum step angle is a value that cannot divide 360 evenly.  

Describe an integer value that can divide 360 evenly for the minimum step 
angle.

E10204 The picture type is not PIC_RECT or PIC_ELL.
Countermeasure: The described value for the type of figure in the parameter is a value other 

than macro PIC_RECT or PIC_ELL.  Describe PIC_RECT or PIC_ELL for the 
type of figures.

E10205 The color type is not PIC_RED or PIC_YELLOW or PIC_GREEN.
Countermeasure: The described value for the type of color in the parameter is a value other 

than macro PIC_RED, PIC_YELLOW, or PIC_GREEN.  Describe one of 
PIC_RED, PIC_YELLOW, or PIC_GREEN for the type of color.

E10206 The view type is no 0 or 1.
Countermeasure: The described value of the figure style is a value other than 0 or 1.  Describe 

0 or 1 for the parameter figure style.

E10207 The first bit of serial input data is not MSB or LSB.
Countermeasure: The described value of the first bit of the parameter is a value other than 1 or 

0.  Describe 1 or 0 for the first bit of the parameter.

E10208 The active H/L of output1 is not HIGH or LOW.
Countermeasure: The described value of the active H/L of output 1 for the parameter is a value 

other than HIGH or LOW.  Describe HIGH or LOW for the active H/L of output 
1 for the parameter.

E10209 The active H/L of output2 is not HIGH or LOW.
Countermeasure: The described value of the active H/L of output 1 for the parameter is a value 

other than HIGH or LOW.  Describe HIGH or LOW for the active H/L of output 
1 for the parameter.

E1020a The port name is a 2-byte name.
Countermeasure: The port name of the parameter is described with 2-byte characters.  

Describe the port name of the parameter with 1-byte characters.

E1020b The selected port name does not exist.
Countermeasure: A nonexistent port name is described as the port name of the parameter.  

Describe a port name existing on a target device.

E1020c The parameter is NULL pointer.
Countermeasure: An incorrect parameter is described in a function.  Describe a correct 

parameter.

E1020d The function xxxx can not set in UOxxx.dll.
Countermeasure: This function was described in UOxxx.dll.  Use it in UPxxx.dll.

E1020e The function xxxx can not set in UPxxx.dll.
Countermeasure: This function was described in UPxxx.dll.  Use it in UOxxx.dll.

Table D-4  Fantal error messages of SM78Kx (simulator part)

Error No. Message



APPENDIX D  MESSAGES

User’s Manual  U16768EJ1V0UM 521

D. 2. 3    Warning message

Here is a list of the messages that are output when warnings are detected while the simulator is executing

processing, in numerical order.  

E1020f The function xxxx does not set previous.
Countermeasure: A necessary notification function was not notified previously.  Call the 

necessary notification function previously.

E10210 The register type is not REG_PC or REG_PSW or REG_SP.
Countermeasure: A register other than the control register was specified.  Do not specify a 

register other than the control register.

E10211 Illegal parameter.
Countermeasure: The parameter of the setting for a memory access event is incorrect.  Check 

the parameter.

E10212 Too many Memory-event condition.
Countermeasure: The number of memory access events is more than the maximum settable 

number, 32.  Set 32 or fewer.

E1ffff Error Occurred.
Countermeasure: An internal error occurred.  Notify the manufacturer.

Table D-4  Fantal error messages of SM78Kx (simulator part)
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W10080 Could not open input data file.  Do you want to continue simulation?
Countermeasure: Input data file could not be opened.  Check the disk status and specify a 

correct file name.

W10081 Accessed a port used as address/data bus.  Do you want to continue simulation?
Countermeasure: A pin used as an address/data bus was accessed as a port.  Access a pin 

accessible as a port.

W10082 Accessed a port used as data bus. Do you want to continue simulation?
Countermeasure: A pin used as a data bus was accessed as a port.  Access a pin accessible as 

a port.

W10083 Accessed a port used as control signal output. Do you want to continue simulation?
Countermeasure: A pin used as a control signal output function was accessed as a port.  

Access a pin accessible as a port.

W10084 A pin not supported in the chip under simulation was accessed.\nDo you want to continue 
simulation?
Countermeasure: A pin that was not in the device under simulation was accessed.  Use a pin 

that exists in the device under simulation

W10085 Failed to restore input file pointer during backtrace execution. Do you want to continue 
simulation?
Countermeasure: On executing back-trace, the input file pointer could not be restored.  Check 

the disk status to generate a correct file.

W10086 Failed to restore output file pointer during backtrace execution. Do you want to continue 
simulation?
Countermeasure: On executing back-trace, the output file pointer could not be restored.  Check 

the disk status to generate a correct file. 
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W10088 This will initialize all data.This will initialize all data.
Countermeasure: The <Clear> button was clicked.  Check the message and operation.

W10089 This will overwrite present data.
Countermeasure: On editing data, the button which performes overwite was clicked.  Check the 

message and operation.

W1008a This will end Input 0/1 Editor.
Countermeasure: The <Cancel> button in the Input 0/1 Enter window was clicked.  Check the 

message and operation.

W1008b This will end Input Timing Chart Editor.
Countermeasure: The <Cancel> button in the Input Timing Chart Editor window was clicked.  

Check the message and operation.

W1008c This will end output timing chart.
Countermeasure: The <Cancel> button in the Output Timing Chart Editor window was clicked.  

Check the message and operation.

W1008d This will initialize all download data.
Countermeasure: The file type to be loaded was not selected in the Down Load dialog box.  

Check the message and operation.

W1008e This will end SFR Event & Action Setting Dialog.
Countermeasure: The <Cancel> button in the IOR Event & Action dialog box was clicked.  

Check the message and operation.

W10090 Creation of output file discontinued.
Countermeasure: The specification to create output file was cleared.  Check the message and 

operation.

W10180 Hold time is not set.  Hold time is set to 0.5 msec.
Retention time is not set.  Set the retention time.

W10181 AVref is not set. AVref is set 5.0v,continue?
Countermeasure: AVref is not set.  Set AVref.

W10182 The active and inactive bit map file names are the same,continue?
Countermeasure: The specification of an active bitmap file name and an inactive bitmap file 

name is the same in the Bitmap Entry dialog box.  Set different names for an 
active and an inactive bitmap files.

W10183 The created bitmap is canceled, continue?
Countermeasure: The created bitmap information is not saved in a file.  Save the created 

bitmap in a file with a paint tool etc.

W10184 Save input/output panel information to file?
Countermeasure: Termination of the I/O panel was selected.  Check the message and 

operation.

W10280 Data cannot be input from external devices during backtrace execution.
Countermeasure: Data input during back-trace is prohibited.  Do not input data while executing 

back-trace.

Table D-5  Fantal error messages of SM78Kx (simulator part)

Error No. Message



APPENDIX E  KEY FUNCTION LIST

User’s Manual  U16768EJ1V0UM 523

APPENDIX E  KEY FUNCTION LIST

Debugging can be efficiently executed by using special function keys.  

Note that, in the following explanation, ordinary key representation (generic key representation) is used

because the key representation differs depending on the type of keyboard.  

Table E-1 through Table E-8 list the functions of the respective keys.  

E. 1    Function List of Special Function Keys

Table E-1　Function List of Special Function Keys

Key Function

BackSpace Deletes one character before the cursor and moves the cursor to the position of 
the deleted character.
At this time, the character string following the cursor moves forward.

Delete Deletes one character after the cursor and move the character string following the 
cursor forward. 
Deletes a various event condition selected in the Event Manager or each event 
dialog box.  
Deletes the data selected in the Watch window.

Insert Alternately selects the insert mode and overwrite mode in the Source window and 
Assemble window.  However, this key is invalid in the Memory, Register, and SER 
windows, and only the overwrite mode can be used as an input mode.  

PrintScreen Loads the entire display screen to the clipboard as a bitmap image (function of 
Windows).

Esc Closes the pull-down menu.
Closes the modal dialog box.
Restores the input data.

Alt Moves the cursor to the menu bar.

End Moves the cursor to the end of the line.

Home Moves the cursor to the beginning of the line.

PageUp Scrolls the screen one screen up.  The cursor also moves up to the top of the 
screen.

PageDown Scrolls the screen one screen down.  The cursor also moves up to the top of the 
screen.

Space Inserts one blank character.

Tab Moves the cursor to the next item.

Up arrow key Moves the cursor up.
If the cursor is at the bottom of the screen, scrolls the screen up one line at a time.

Down arrow key Moves the cursor down.
If the cursor is at the top of the screen, scrolls the screen down one line at a time.

Right arrow key Moves the cursor to the left.
If the cursor is at the leftmost position on the screen, scrolls the screen one column 
to the right.
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E. 2    Function List of Function Keys

E. 3    Function List of Special Function Keys (Shift + key) 

Left arrow key Moves the cursor to the right.
If the cursor is at the rightmost position on the screen, scrolls the screen one 
column to the left.

Enter Sets the input data.
Presses the default push button.

Table E-1　Function List of Special Function Keys

Key Function

Table E-2　Function List of Function Keys 

Key Function

F1 Opens the Help window.  

F2 Forcibly stops program execution.
Same function as [Run] ->  [Stop] on the menu bar.  

F3 Resets the CPU.
Same function as [Run] -> [CPU Reset] on the menu bar.  

F4 Resets the CPU and executes the program.
Same function as [Run] -> [Restart] on the menu bar.

F5 Executes the program.
Same function as [Run] -> [Go] on the menu bar.

F6 Executes the program to the cursor position in the Source or Assemble window.
Same function as [Run] -> [Come Here] on the menu bar

F7 The user program is real-time executed until execution returns.   
Same function as [Run] -> [Return Out] on the menu bar

F8 Step execution.
Same function as [Run] -> [Step In] on the menu bar.  

F9 Sets a breakpoint at cursor position in Source or Assemble window.
Same function as [Run] -> [Break Point] on the menu bar.  

F10 Next step execution.
Same function as [Run] -> [Next Over] on the menu bar.  

Table E-3　Function List of Special Function Keys (Shift + key) 

Key Function

End Expands the selection range to the end of the line.

Home Expands the selection range to the beginning of the line.

Left arrow key Expands the selection range one character to the left.

Right arrow key Expands the selection range one character to the right.
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E. 4    Function List of Function Keys (Shift + key)

E. 5    List of Special Function Keys (Ctrl + key)

E. 6    Function List of Function Keys (Ctrl + key)

Table E-4　Function List of Function Keys (Shift + key)

Key Function

F6 Executes the program from the cursor position in the Source or Assemble window.
Same function as [Run] -> [Start From Here] on the menu bar.  

F9 Resets the CPU.
Same function as [Run] -> [CPU Reset] on the menu bar.  

Table E-5　List of Special Function Keys (Ctrl + key)

Key Function

End Displays the last line.
The cursor will also move to the last line.

Home Displays the first line.
The cursor will also move to the first line.

Left arrow key Moves the cursor one word to the left.
If the cursor at the leftmost position on the screen, scrolls the screen one column 
to the right.

Right arrow key Moves the cursor one word to the right.
If the cursor at the rightmost position on the screen, scrolls the screen one column 
to the left.

Table E-6　Function List of Function Keys (Ctrl + key)

Key Function

F5 Ignores break points being set, and executes the program.  
Same function as [Run] -> [Ignore break points and Go] on the menu bar.  

F9 Sets the address at the cursor position in the Source window or Assemble window 
to the PC.
Same function as [Run] -> [Change PC] on the menu bar.  
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E. 7    Function List of Control Keys (Ctrl + key)

Table E-7　Function List of Control Keys (Ctrl + key)

Key Function

A Selects all the events registered to the Event Manager.
Same function as [View] -> [Select All Event] on the menu bar in the Event Manager.  

C Copies a selected character string and saves it to the clipboard buffer.

D Disassembles and displays the results from the jump destination address specified by 
the data value selected in the current window.Opens the Assemble window.  
Same function as [Jump] -> [Assemble] on the menu bar.  

E Opens the source file displayed in the active Source window with the editor specified 
by the PM plus when the PM plus is running.  
Same function as [Edit] -> [Edit Source] on the menu bar.  

G Performs a search.Opens the search dialog box corresponding to the current window.
Same function as [View] -> [Search...] on the menu bar.  

I Displays the memory contents from the jump destination address specified by the data 
value selected in the current window.Opens the Coverage window.  
Same function as [Jump] -> [Coverage] on the menu bar.  

J Moves the display position.  Opens the Source Move, Address Move, or Trace Move 
dialog box, depending on the current window.
Same function as [View] -> [Move...] on the menu bar. 

M Displays the memory contents from the jump destination address specified by the data 
value selected in the current window.  Opens the Memory window.
Same function as [Jump] -> [Memory...] on the menu bar.  

O Loads a view file, source file, or text file.
Opens the View File Load dialog box.  The operation will differ depending on the 
extension of the file.
view file: Displays the file in the corresponding window.
Others: Displays the file in the Source window.
Same function as [File] -> [Open...] on the menu bar.  

S Saves the data displayed in the current window to the view file.
Same function as [View] -> [Save...] on the menu bar.  

U Displays the corresponding source text and source line, using the data value selected 
in the current window as the jump destination address.  Opens the Source window. 
Same function as [Jump] -> [Source Text] on the menu bar.  

V Pastes the contents of the clipboard buffer to the text cursor position.

W Temporarily displays the contents of the specified data.
Opens the Quick Watch dialog box. 
Same function as [View] -> [Quick Watch...] on the menu bar.  

X Cuts a selected character string and saves it to the clipboard buffer.
Same function as [Edit] -> [Cut...] on the menu bar.  
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E. 8    List of Special Function Keys (Ctrl + Shift + key)

Table E-8　List of Special Function Keys (Ctrl + Shift + key)

Key Function

Left arrow key Expands the selection range one word to the left.

Right arrow key Expands the selection range one word to the right.
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