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ご注意書き 

 

１． 本資料に記載されている内容は本資料発行時点のものであり、予告なく変更することがあります。当社製品

のご購入およびご使用にあたりましては、事前に当社営業窓口で最新の情報をご確認いただきますとともに、

当社ホームページなどを通じて公開される情報に常にご注意ください。 
2. 本資料に記載された当社製品および技術情報の使用に関連し発生した第三者の特許権、著作権その他の知的

財産権の侵害等に関し、当社は、一切その責任を負いません。当社は、本資料に基づき当社または第三者の

特許権、著作権その他の知的財産権を何ら許諾するものではありません。 
3. 当社製品を改造、改変、複製等しないでください。 
4. 本資料に記載された回路、ソフトウェアおよびこれらに関連する情報は、半導体製品の動作例、応用例を説

明するものです。お客様の機器の設計において、回路、ソフトウェアおよびこれらに関連する情報を使用す

る場合には、お客様の責任において行ってください。これらの使用に起因しお客様または第三者に生じた損

害に関し、当社は、一切その責任を負いません。 
5. 輸出に際しては、「外国為替及び外国貿易法」その他輸出関連法令を遵守し、かかる法令の定めるところに

より必要な手続を行ってください。本資料に記載されている当社製品および技術を大量破壊兵器の開発等の

目的、軍事利用の目的その他軍事用途の目的で使用しないでください。また、当社製品および技術を国内外

の法令および規則により製造・使用・販売を禁止されている機器に使用することができません。 
6. 本資料に記載されている情報は、正確を期すため慎重に作成したものですが、誤りがないことを保証するも

のではありません。万一、本資料に記載されている情報の誤りに起因する損害がお客様に生じた場合におい

ても、当社は、一切その責任を負いません。 
7. 当社は、当社製品の品質水準を「標準水準」、「高品質水準」および「特定水準」に分類しております。また、

各品質水準は、以下に示す用途に製品が使われることを意図しておりますので、当社製品の品質水準をご確

認ください。お客様は、当社の文書による事前の承諾を得ることなく、「特定水準」に分類された用途に当

社製品を使用することができません。また、お客様は、当社の文書による事前の承諾を得ることなく、意図

されていない用途に当社製品を使用することができません。当社の文書による事前の承諾を得ることなく、

「特定水準」に分類された用途または意図されていない用途に当社製品を使用したことによりお客様または

第三者に生じた損害等に関し、当社は、一切その責任を負いません。なお、当社製品のデータ・シート、デ

ータ・ブック等の資料で特に品質水準の表示がない場合は、標準水準製品であることを表します。 
標準水準： コンピュータ、OA 機器、通信機器、計測機器、AV 機器、家電、工作機械、パーソナル機器、

産業用ロボット 
高品質水準： 輸送機器（自動車、電車、船舶等）、交通用信号機器、防災・防犯装置、各種安全装置、生命

維持を目的として設計されていない医療機器（厚生労働省定義の管理医療機器に相当） 
特定水準： 航空機器、航空宇宙機器、海底中継機器、原子力制御システム、生命維持のための医療機器（生

命維持装置、人体に埋め込み使用するもの、治療行為（患部切り出し等）を行うもの、その他

直接人命に影響を与えるもの）（厚生労働省定義の高度管理医療機器に相当）またはシステム

等 
8. 本資料に記載された当社製品のご使用につき、特に、最大定格、動作電源電圧範囲、放熱特性、実装条件そ

の他諸条件につきましては、当社保証範囲内でご使用ください。当社保証範囲を超えて当社製品をご使用さ

れた場合の故障および事故につきましては、当社は、一切その責任を負いません。 
9. 当社は、当社製品の品質および信頼性の向上に努めておりますが、半導体製品はある確率で故障が発生した

り、使用条件によっては誤動作したりする場合があります。また、当社製品は耐放射線設計については行っ

ておりません。当社製品の故障または誤動作が生じた場合も、人身事故、火災事故、社会的損害などを生じ

させないようお客様の責任において冗長設計、延焼対策設計、誤動作防止設計等の安全設計およびエージン

グ処理等、機器またはシステムとしての出荷保証をお願いいたします。特に、マイコンソフトウェアは、単

独での検証は困難なため、お客様が製造された最終の機器・システムとしての安全検証をお願いいたします。 
10. 当社製品の環境適合性等、詳細につきましては製品個別に必ず当社営業窓口までお問合せください。ご使用

に際しては、特定の物質の含有･使用を規制する RoHS 指令等、適用される環境関連法令を十分調査のうえ、

かかる法令に適合するようご使用ください。お客様がかかる法令を遵守しないことにより生じた損害に関し

て、当社は、一切その責任を負いません。 
11. 本資料の全部または一部を当社の文書による事前の承諾を得ることなく転載または複製することを固くお

断りいたします。 
12. 本資料に関する詳細についてのお問い合わせその他お気付きの点等がございましたら当社営業窓口までご

照会ください。 
 
注 1. 本資料において使用されている「当社」とは、ルネサスエレクトロニクス株式会社およびルネサスエレク

トロニクス株式会社がその総株主の議決権の過半数を直接または間接に保有する会社をいいます。 
注 2. 本資料において使用されている「当社製品」とは、注 1 において定義された当社の開発、製造製品をいい

ます。 



www.renesas.com

U
ser’s M

anual

デバッギングエクステンション
ユーザーズマニュアル
HS6400IWIN1SJ

Rev.1.00　2003.09

ルネサスマイクロコンピュータ開発環境システム



ご注意
安全設計に関するお願い

1. 弊社は品質、信頼性の向上に努めておりますが、半導体製品は故障が発生したり、誤動作する場合があります。弊社

の半導体製品の故障又は誤動作によって結果として、人身事故、火災事故、社会的損害などを生じさせないような安

全性を考慮した冗長設計、延焼対策設計、誤動作防止設計などの安全設計に十分ご留意ください。

本資料ご利用に際しての留意事項

1. 本資料は、お客様が用途に応じた適切なルネサス テクノロジ製品をご購入いただくための参考資料であり、本資料中

に記載の技術情報についてルネサス テクノロジが所有する知的財産権その他の権利の実施、使用を許諾するものでは

ありません。

2. 本資料に記載の製品データ、図、表、プログラム、アルゴリズムその他応用回路例の使用に起因する損害、第三者所

有の権利に対する侵害に関し、ルネサス テクノロジは責任を負いません。

3. 本資料に記載の製品データ、図、表、プログラム、アルゴリズムその他全ての情報は本資料発行時点のものであり、

ルネサス テクノロジは、予告なしに、本資料に記載した製品または仕様を変更することがあります。ルネサス テクノ

ロジ半導体製品のご購入に当たりましては、事前にルネサス テクノロジ、ルネサス販売または特約店へ最新の情報を

ご確認頂きますとともに、ルネサス テクノロジホームページ(http://www.renesas.com)などを通じて公開される情報に

常にご注意ください。

4. 本資料に記載した情報は、正確を期すため、慎重に制作したものですが万一本資料の記述誤りに起因する損害がお客

様に生じた場合には、ルネサス テクノロジはその責任を負いません。

5. 本資料に記載の製品データ、図、表に示す技術的な内容、プログラム及びアルゴリズムを流用する場合は、技術内

容、プログラム、アルゴリズム単位で評価するだけでなく、システム全体で十分に評価し、お客様の責任において適

用可否を判断してください。ルネサス テクノロジは、適用可否に対する責任は負いません。

6. 本資料に記載された製品は、人命にかかわるような状況の下で使用される機器あるいはシステムに用いられることを

目的として設計、製造されたものではありません。本資料に記載の製品を運輸、移動体用、医療用、航空宇宙用、原

子力制御用、海底中継用機器あるいはシステムなど、特殊用途へのご利用をご検討の際には、ルネサス テクノロジ、

ルネサス販売または特約店へご照会ください。

7. 本資料の転載、複製については、文書によるルネサス テクノロジの事前の承諾が必要です。

8. 本資料に関し詳細についてのお問い合わせ、その他お気付きの点がございましたらルネサス テクノロジ、ルネサス販

売または特約店までご照会ください。
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はじめに

デバッギングエクステンション（以下、DX と略します）は、「High-performance Embedded Workshop」（以下、HEW
と略します）に、リアルタイムオペレーティングシステム（以下、RTOSと略します）用のマルチタスクデバッグ機能を
付加するソフトウェアです。
本マニュアルでは、DXの使用方法について説明します。
ご使用になる前に本マニュアルを良く読んで理解してください。また、下記の関連マニュアルもお読みの上、理解し

てください。

〈マニュアルの構成〉
本マニュアルは、以下の章と付録から構成されています。

• 第１章では、DXの概説を記載しています。
• 第２章では、例を用いて DX の操作方法を説明しています。
• 第３章では、DXの機能概略を説明しています。
• 第４章では、留意・制限事項を説明しています。
• 付録では、トラブルシューティングを記載しています。

特に第特に第特に第特に第 4章の章の章の章の「留意「留意「留意「留意・制限事項」は、・制限事項」は、・制限事項」は、・制限事項」は、DX を使用する前に必ずお読みください。を使用する前に必ずお読みください。を使用する前に必ずお読みください。を使用する前に必ずお読みください。
なお、DXの機能の詳細については、オンラインヘルプを参照してください。

〈関連マニュアル〉
本 DXに関連する以下の製品のマニュアルも、あわせて参照してください。

• High-performance Embedded Workshop（HEW）ユーザーズマニュアル
• 使用する RTOSのユーザーズマニュアル
• 使用するコンパイラのユーザーズマニュアル
• 使用するマイコンのハードウェアマニュアル、プログラミングマニュアル

〈本マニュアルで使用する記号などの意味〉
[メニュー -> メニュー
オプション]

 ‘->‘ はメニューオプションを示します ( 例 [ファイル->新規作成] )

H’と D’ “H’”は 16進数、”D’”は 10進数を意味するプリフィックスです。プリフィックス
の無い場合は 10進数です。

なお、日本語環境でないホストマシンでは、ディレクトリ区切り記号「￥」が「＼」と表示される場合があります。
読み替えてご使用ください。
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1. 概　説

1.1 概　要
DX は RTOS用に作成されたアプリケーションのデバッグを行うためのソフトウェアです。HEWおよび RTOSのシス

テムに組み込んで使用します。

図1.1　 DX概要

1.2 特　長
(1) グラフィカルユーザインタフェース

タスクなどのオブジェクト状態の参照、変更が、ウィンドウやダイアログボックスを通して行え、HEWの環境でマル
チタスクアプリケーションをデバッグできます。

(2) サービスコールトレース情報の表示

RTOSのサービスコール履歴をグラフィカルに表示できます。また、その履歴から必要な項目だけを選択して表示する
ことも可能です。
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1.3 使用前の準備
以下を行うことにより DXを使用したデバッグが可能となります。

(1) インストール

インストーラに従って DXをインストールします。

(2) RTOSのコンフィギュレーション

使用する RTOSのシステムを DX 用に構築します。構築例は「2. チュートリアル」を参照してください。

(3) HEWの起動

HEWを起動します。
プログラムをビルドした後、マルチタスクデバッグが可能となります。DX の使用例は「2. チュートリアル」を参照し

てください。また、機能については「3. 機　能」およびオンラインヘルプを参照してください。
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2. チュートリアル

本章では、RTOSとして HI7000/4シリーズを例に用い、DX の操作例について説明します。詳しい操作方法は、オンラ
インヘルプを参照してください。

ここでは、以下の環境を前提にしています。
• RTOS ：HI7700/4
• マイコン ：SH7729
• デバッガ ：SuperH RISC engine シミュレータ・デバッガ

2.1 チュートリアルの構築
HI7700/4が提供するサンプルを使用します。構築に関する詳細は、HI7000/4シリーズ ユーザーズマニュアルの「5. コ

ンフィギュレーション」を参照してください。

2.1.1 コンフィギュレータ
HI7700/4が提供するサンプル HCFファイル(hiuser¥sh7729¥7729.hcf)を使って構築ファイルを生成します。
コンフィギュレータの設定項目の中で、特に以下の項目を設定してください。

• CFG_ACTIONをチェックしてください。
• CFG_TRACEをチェックしてください。
• CFG_TRCTYPEを「エミュレータトレース」に設定してください。（本設定によりシミュレータにおいても DX
の RTOSトレースが使用できます）

• CFG_MAXTSKIDは 7以上を設定してください。
• CFG_STSTKIDは 5以下を設定してください。
• CFG_MAXTSKPRIは 7以上を設定してください。
• CFG_MAXFLGIDは 6以上を設定してください。
• 以下のサービスコールを組み込んでください。

cre_tsk, ext_tsk, cre_flg, wai_flg, set_flg

2.1.2 ビ ル ド
HI7700/4の一括リンクによりビルドします。
サンプルの hios.hwsを HEWで開き、プロジェクトとして 7729_mixを選択してください。[Options->SuperH RISC engine

Standard Toolchain…]の[C/C++]ページの[Optimize]カテゴリの[Gbr relative logic operation]を[User]に設定してください。
[Build->Build]によりビルドを行ってください。
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2.2 例題プログラムの内容
例題プログラムのソースは、hiuser¥tutorial¥task.cです。ここには、MainTaskと Task7の 2つのタスクがあります。
MainTaskは、以下の条件でコンフィギュレータによって生成・起動が指定されているので、システムを起動すると自

動的に MainTaskが実行されます。
• タスク ID：6
• 初期優先度：6
• 開始アドレス：MainTask( )
• 初期状態：READY (TA_ACT属性指定)

一方、Task7は以下の条件で MainTaskによって動的に生成されます。
• タスク ID：7
• 初期優先度：7
• 開始アドレス：Task7( )
• 初期状態：READY (TA_ACT属性指定)

優先度は、MainTaskの方が高い設定になっています。

MainTaskは、ID 6のイベントフラグと Task7を生成し、wai_flgサービスコールで ID 6のイベントフラグがセットされ
るのを待ちます。その後、del_flgサービスコールで ID6のイベントフラグを削除し、ext_tskサービスコールで終了しま
す。

Task7は、set_flgサービスコールで ID 6のイベントフラグをセットし、その後 while(1);文で無限ループに入ります。
なお、本例題プログラムはカーネルの動作および DX の操作を習得するためだけに作られたプログラムであり、処理内

容には何の意味もありません。
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2.3 例題プログラムの実行

(1) シミュレータ・デバッガを起動します。HEWの[Options>Debug Settings…]の左のリストから 7729_mixを選択
し、[Target]ページで[SH3-DSP Simulator]、[Add…]ボタンにより HI7000/4の hiuser¥obj_big¥7729_mix.absを選択
してださい。

図2.1　 Debug Settingsダイアログ

(2) DXを起動します。[Project->Components…]の[RTOS HI7000_4DX ECX]を選択し、[Load]ボタンおよび[OK]ボ
タンを押してください。

図2.2　 Component Galleryダイアログ
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(3) シミュレータ・デバッガの設定を行います。[Options->Simulator->System…]の[Enable Timer]をチェックし、
[Execution Mode]を[Continue]に設定してください。

図2.3　 Simulator Systemダイアログの Systemページ

(4) Simulator Systemダイアログの[Memory]ページにおいて、表 2.1に示すメモリリソースを確保してください。

表2.1 シミュレータ・デバッガのメモリリソース
開始アドレス 終了アドレス 属性

H’00000000 H’0000FFFF Read
H’0C000000 H’0C0FFFFF Read/Write

図2.4　 Simulator Systemダイアログの Memoryページ
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(5) ロードモジュールをダウンロードします。[Debug->Download Modules]の hiuser¥obj_big¥7729_mix.absを選択
してください。

図2.5　ロードモジュールのダウンロード
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(6) RTOSトレースの設定を行います。[View->RTOS->Trace]を選択してください。[RTOS Trace]ウィンドウで右
クリックし、ポップアップメニューから[Set trace options...]を選択してください。

図2.6　RTOSトレースの設定

(7) [Scale Type]を[Cycle]に、[Scale List]を[*100 Cycle]に設定してください。

図2.7　Trace Optionsダイアログ
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(8) プログラムを実行します。[Debug->Reset Go]を選択してください。

図2.8　プログラムの実行
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(9) プログラムを停止します。[Debug->Halt Program]を選択してください。

図2.9　プログラムの停止
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(10) 図 2.10のように、Task7の中の while(1);文で停止します。

　
図2.10　プログラム停止時のソースウィンドウ

(11) どのようにプログラムが実行されたのかを、サービスコールトレースで確認します。ダイアグラム表示を見やす
くするために、MainTask(タスク ID 6)と Task7(タスク ID 7)が表示されるようにします。[RTOS Trace]ウィンドウで
右クリックし、ポップアップメニューから[Select Diagram Object...]を選択してください。タスク ID 6と 7を追加し
てダイアログボックスを閉じてください。

　図2.11　[Select Diagram Object]ダイアログボックス
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(12) タスク ID 6と 7が[RTOS Trace Diagram]ウィンドウに表示されるようになります。MainTaskが wai_flgを発行
した後に Task7にタスクスイッチしたことが分かります。[RTOS Trace Text]ウィンドウのサービスコールが表示さ
れている行をダブルクリックすることで対応するソースウィンドウを開くことができます。

　図2.12　[RTOS Trace]ウィンドウ



2. チュートリアル

13

(13) [Task]ウィンドウで MainTaskと Task7がどのような状態になっているかを確認してみます。 [View->RTOS-
>Task]を選択すると、[Task]ウィンドウが開きます。MainTaskは DORMANT状態、Task7は RUN状態であること
が分かります。

図2.13　[Task]ウィンドウ
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(14) 今度は、MainTaskの優先度を Task7よりも低くして実行してみることにしましょう。そのために、まずは
MainTask, Task7を削除して初期状態に戻すことにします。MainTaskを削除するには、[Task]ウィンドウで MainTask
を選択(ハイライト)し、右ボタンクリックによるポップアップメニューから[Action->Delete Task…]選択してください。

図2.14　[Task]ウィンドウのポップアップメニュー

(15) 確認ダイアログボックスで[OK]ボタンを押してください。

　
図2.15　[Delete Task]ダイアログボックス
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(16) 一方、Task7はまだ RUN状態なので、強制終了させてから削除する必要があります。Task7を強制終了させる
には、[Task]ウィンドウで Task7を選択(ハイライト)させ、右ボタンクリックによるポップアップメニューから
[Action->Terminate Task…]を選択すると、[Terminate Task]ダイアログボックスが開きますので、[OK]を押してくだ
さい。その後、MainTaskと同様にして Task7を削除してください。

　
図2.16　[Terminate Task]ダイアログボックス

(17) タスクの強制終了や削除といったカーネルオブジェクトの操作の結果は、[View->RTOS->Action Result]で確認
できます。しかし、今[Action Result]ウィンドウを開いても、何も表示されません。カーネルオブジェクトの操作は
DXからカーネルへサービスコールの実行を依頼することによって実現されています。このため、カーネルが実行し
た後、実際にタスクが削除されます。結果を得るために、[Debug->Go]によりターゲットの実行を再開させてくださ
い。自動的に結果が表示されます。その後、[Task]ウィンドウのポップアップメニューより[Refresh task sheet]を選
択すると、MainTask(タスク ID 6)と Task7(タスク ID 7)が NOEXS状態になっていることがわかります。

　
図2.17　オブジェクト操作結果
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(18) [Debug->Halt Program]によりプログラムを停止してください。MainTaskを Task7よりも低い優先度(8)で生成・
起動します。[Task]ウィンドウでタスク ID 6を選択(ハイライト)させ、ポップアップメニューから[Action->Create
Task…]を選択すると、[Create Task]ダイアログボックスが開きます。ここでは、図 2.18のように入力してください。

　
図2.18　[Create Task]ダイアログボックス

(19) [Task]ウィンドウおよび[Action Result]ウィンドウのポップアップメニューから[Hide]を選択して、ウィンドウを
閉じてください。再実行する前に Task7の while(1);文まで実行したら停止するようにブレークポイントを設定してお
きます。図 2.19の丸で囲んだ部分をダブルクリックしてブレークポイントを設定してください。

　
図2.19　ブレークポイントの設定
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(20) ターゲットを再実行させると、MainTaskが起動され、先ほど設定した Task7の while(1);文のブレークポイント
で停止します。どのように実行されたのかをサービスコールトレースの表示情報を更新して確認してみてください。
MainTaskの cre_tsk後に Task7にスイッチしたので、MainTaskはまだ wai_flgを発行していないことが分かります。

　
図2.20　[RTOS Trace Diagram]ウィンドウと[RTOS Trace Text]ウィンドウ
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3. 機　能

本章では、DXの機能概要について簡単に説明します。機能の詳細は、オンラインヘルプを参照してください。

3.1 オブジェクト状態の参照
[View->RTOS]メニューからタスク等の各オブジェクトを選択すると、図 3.1のようにオブジェクトの状態を表示するウ

ィンドウが開きます。

図3.1　タスク状態の表示例

3.2 オブジェクトの操作
各オブジェクトのウィンドウからは、オブジェクトの操作をカーネルに要求することができます。この機能を使用す

るには、使用する RTOSにおいて DX のオブジェクト操作を行うための構築をする必要があります。
オブジェクト操作の要求は、図 3.2に示すように各オブジェクトウィンドウのポップアップメニューから開いたダイア

ログボックスで行えます。

図3.2　オブジェクト操作の要求例
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オブジェクト操作要求はターゲット側に伝えられ、対応するサービスコールが発行されます。DX は、その結果を図 3.3
に示す[Action Result]ウィンドウに表示します。

図3.3　オブジェクト操作の結果

オブジェクト操作要求は、ターゲット実行時に初めて処理されます。ターゲット停止中は、オブジェクト操作の要求
は可能ですが、その実行は次にターゲットを実行するまで待たされます。
オブジェクト操作要求は、ターゲットメモリ上にキューイングされ、[Action Result]ウィンドウに結果が表示されるこ

とで、キューイングから外れます。キューイングの最大数は 4です。
ターゲット停止中のオブジェクト操作要求を行っても、次にターゲットを実行するまで決して[Action Result]ウィンド

ウに結果が表示されることは無いので、ターゲット停止中は同時に要求できるオブジェクト操作要求は 4回になります。
なお、[Action Result]ウィンドウは、以下のタイミングで表示が更新されます。

(1) ターゲット実行中（周期的）
(2) [Action Result]ウィンドウの右ボタンクリックによるポップアップメニューから[Refresh]を選択したとき
(3) ターゲットシステムがブレーク（停止）したとき
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3.3 サービスコールトレースの表示
[View->RTOS->Trace]を選択すると、図 3.4に示すようにサービスコールの履歴をダイアグラムおよびテキストで表示

します。この機能を使用するには、使用する RTOSにおいて DX のサービスコールトレースを表示するための構築を行う
必要があります。
サービスコールトレースの履歴情報の元となるデータは、ツール（シミュレータ・デバッガ、エミュレータ）または

ターゲットメモリどちらか選択できます。コンフィギュレータによっては「ツール」ではなく、「エミュレータ」と表示
されている場合がありますが、シミュレータ・デバッガでも使用可能です。
また、取得された情報をファイルに保存し、そのファイルを読み出して表示することもできます。

図3.4　[RTOS Trace Diagram]ウィンドウと[RTOS Trace Text]ウィンドウ
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3.4 機 能 一 覧

3.4.1 メニュー
DX をインストールすると、HEWの [View]メニューに表 3.1の項目が追加されます。これらから DX の機能にアクセ

スできます。

表3.1　HEWの [View]メニューに追加される内容
プルダウンメニュー サブメニュー 機　能

Task [Task]ウィンドウのオープン

Semaphore [Semaphore]ウィンドウのオープン

EventFlag [EventFlag]ウィンドウのオープン

DataQueue [DataQueue]ウィンドウのオープン

Mailbox [Mailbox]ウィンドウのオープン

Mutex [Mutex]ウィンドウのオープン

MessageBuffer [MessageBuffer]ウィンドウのオープン

V-MemoryPool [V-MemoryPool]ウィンドウのオープン

F-MemoryPool [F-MemoryPool]ウィンドウのオープン

Timer [Timer]ウィンドウのオープン

Interrupt [Interrupt]ウィンドウのオープン

Trap [Trap]ウィンドウのオープン

Cyclic [Cyclic]ウィンドウのオープン

Alarm [Alarm]ウィンドウのオープン

Extended SVC [Extended SVC]ウィンドウのオープン

Action Result [Action Result]ウィンドウのオープン

RTOS

Trece [Trece]ウィンドウのオープン

また、[View->CPU->Status]を選択することにより、HEW共通の[Status]ウィンドウに DX の状態を表示します。

なお、使用する RTOSによってはサポートされない機能があります。
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3.4.2 ウィンドウとダイアログボックス
表 3.2に、DXのウィンドウ、ダイアログボックスの一覧を示します。ウィンドウ、ダイアログボックスの詳細につい

てはオンラインヘルプを参照してください。オンラインヘルプは、[Help->RTOS Help]を選択することによりオープンで
きます。

表3.2　ウィンドウとダイアログボックス一覧
分類 ウィンドウ名称 機　能

[Task]ウィンドウ ・全タスクの状態表示

・全タスク優先度の待ちタスク行
列の表示

・全タスクのロックされているミ
ューテックスの表示

[Task Detail Information]ウィンドウ タスクの詳細情報表示

[Create Task]ダイアログボックス*1 タスクの生成

[Delete Task]ダイアログボックス*1 タスクの削除

[Activate Task]ダイアログボックス*1 タスクの起動

[Cancel Activate Task]ダイアログボックス*1 起動要求の無効化

[Start Task]ダイアログボックス*1 タスクの起動（起動コード指定）

[Terminate Task]ダイアログボックス*1 タスクの強制終了

[Release Wait]ダイアログボックス*1 待ち状態の強制解除

[Suspend Task]ダイアログボックス*1 強制待ちへの移行

[Resume Task]ダイアログボックス*1 強制待ち状態タスクの再開

[Wakeup Task]ダイアログボックス*1 タスクの起床

[Cancel Wakeup Task]ダイアログボックス*1 起床要求の無効化

[Change Task Priority]ダイアログボックス*1 タスク優先度の変更

[Set Task EventFlag]ダイアログボックス*1 タスク付属イベントフラグのセッ
ト

[Clear Task EventFlag]ダイアログボックス*1 タスク付属イベントフラグのクリ
ア

[Rotate Ready Queue]ダイアログボックス*1 レディキューの回転

[Raise Task Exception Routine]ダイアログボックス*1 タスク例外処理の要求

[Start Overrun Handler]ダイアログボックス*1 オーバーランハンドラの動作開始

タスク

[Stop Overrun Handler]ダイアログボックス*1 オーバーランハンドラの動作停止

【注】 *1 使用する RTOSにおいてオブジェクト操作のための構築をしなかった場合は使用できません。
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表 3.2　ウィンドウとダイアログボックス一覧（続き）
分類 ウィンドウ名称 機　能

[Semaphore]ウィンドウ ・全セマフォの状態表示

・全セマフォの待ちタスク行列の表
示

[Increment Semaphore Count]ダイアログボックス*1 セマフォカウントの増加

セマフォ

[Decrement Semaphore Count]ダイアログボックス*1 セマフォカウントの減少

[EventFlag]ウィンドウ ・全イベントフラグの状態表示

・全イベントフラグの待ちタスク行
列の表示

[Set EventFlag]ダイアログボックス*1 イベントフラグのセット

イベント

フラグ

[Clear EventFlag]ダイアログボックス*1 イベントフラグのクリア

[DataQueue]ウィンドウ ・全データキューの状態表示

・全データキューの受信データの表
示

[Send Data to DataQueue]ダイアログボックス*1 データキューへのデータ送信

データ

キュー

[DataQueue Wait Task Queue]ウィンドウ 全データキューの待ちタスク行列の
表示

[Mailbox]ウィンドウ ・全メイルボックスの状態表示

・全メイルボックスの待ちタスク行
列の表示

・全メイルボックスの受信メッセー
ジ行列の表示

[Send Message to Mailbox]ダイアログボックス*1 メイルボックスへのメッセージ送信

メイル

ボックス

[Receive Message from Mailbox]ダイアログボックス*1 メイルボックスからのメッセージ受
信

ミュー

テックス

[Mutex]ウィンドウ ・全ミューテックスの状態表示

・全ミューテックスの待ちタスク行
列の表示

[MessageBuffer]ウィンドウ ・全メッセージバッファの状態表示

・全メッセージバッファの待ちタス
ク行列の表示

・全メッセージバッファの受信メッ
セージ行列

メッセージ

バッファ

[Send Message to MessageBuffer]ダイアログボックス*1 メッセージバッファへのメッセージ
送信

[Variable-size MemoryPool]ウィンドウ ・全可変長メモリプールの状態表示

・全可変長メモリプールの待ちタス
ク行列の表示

[Get Variable-size MemoryPool]ダイアログボックス*1 可変長メモリブロックの獲得

可変長

メモリ

プール

[Release Variable-size MemoryPool]ダイアログボックス*1 可変長メモリブロックの返却

【注】 *1 使用する RTOSにおいてオブジェクト操作のための構築をしなかった場合は使用できません。
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表 3.2　ウィンドウとダイアログボックス一覧（続き）
分類 ウィンドウ名称 機　能

[Fixed-size MemoryPool]ウィンドウ ・全固定長メモリプールの状態表
示

・全固定長メモリプールの待ちタ
スク行列の表示

[Get Fixed-size MemoryPool]ダイアログボックス*1 固定長メモリブロックの獲得

固定長

メモリプール

[Release Fixed-size MemoryPool]ダイアログボックス*1 固定長メモリブロックの返却

[Timer]ウィンドウ ・システム時刻の表示

・タイマへの待ち行列の表示

タイマ

[Set Time]ダイアログボックス*1 システム時刻の変更

割込みハンド
ラ, 例外処理
ルーチン

[Interrupt Handler]ウィンドウ 全割込みハンドラ, 例外処理ルーチ
ンの状態表示

トラップ例外

処理ルーチン

[Trap Routine]ウィンドウ 全トラップ例外処理ルーチンの状
態表示

[Cyclic Handler]ウィンドウ 全周期ハンドラの状態表示

[Start Cyclic Handler]ダイアログボックス*1 周期ハンドラの動作開始

周期ハンドラ

[Stop Cyclic Handler]ダイアログボックス*1 周期ハンドラの動作停止

[Alarm Handler]ウィンドウ 全アラームハンドラの状態表示

[Start Alarm Handler]ダイアログボックス*1 アラームハンドラの動作開始

アラーム

ハンドラ

[Stop Alarm Handler]ダイアログボックス*1 アラームハンドラの動作停止

拡張 SVC

ルーチン

[Extended SVC Routine]ウィンドウ 全拡張 SVCルーチンの状態表示

結果 [Action Result]ウィンドウ*1 オブジェクト操作結果の表示

[RTOS Trace Diagram]ウィンドウ ・オブジェクトアイテムリストの
表示

・トレース情報の表示（図）

[RTOS Trace Text]ウィンドウ ・オブジェクトアイテムリストの
表示

・トレース情報の表示（テキスト）

[RTOS Trace Options]ダイアログボックス トレースの各種設定

[Select Diagram Object]ダイアログボックス トレースダイアグラム表示の対象
オブジェクトの登録

[Select Text Object]ダイアログボックス カーネルリソースのトレース情報
の登録

[Load RTOS Trace Information File]ダイアログボックス トレース情報ファイルの入力

[RTOS Trace Statistics]ダイアログボックス プログラム実行内容の集計表示

[RTOS Trace Find]ウィンドウ イベント情報の検索

トレース

[Save As]ダイアログボックス トレース情報をファイルへ出力

【注】 *1 使用する RTOSにおいてオブジェクト操作のための構築をしなかった場合は使用できません。
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4. 留意・制限事項

4.1 ターゲットシステムのリアルタイム性と周期ハンドラ
DX は、ターゲットシステムのメモリ内容を参照あるいは更新することで、その機能を実現しています。ターゲットシ

ステムが実行中に、以下の機能を使用するとメモリアクセスが発生して、リアルタイム性がなくなります。
• ウィンドウをオープン、更新したとき
• ダイアログボックスで[OK]ボタンを押し、オブジェクト操作を行ったとき

また、使用する RTOSにおいて DX のオブジェクト操作を行うための構築をした場合、自動的に一定周期の DX 用の周
期ハンドラがひとつシステムに組み込まれるため、ターゲットのスループットがわずかに低下します。

4.2 表示内容の整合性
DX は、ターゲットシステムのメモリ内容を直接読み出すことでオブジェクトの状態参照機能を実現しています。この

ため、メモリ内容の読み出しが RTOSカーネル実行中に行われた場合、DX は正しい情報を表示しない場合があります。
また、オブジェクトの状態参照をカーネル初期化完了前に行った場合は、DX は正しい情報を表示できません。
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付録A　  トラブルシューティング

A.1  [Action Result]ウィンドウの結果表示
ダイアログボックスからオブジェクトの操作を要求し、ターゲットシステムを実行した後、結果が表示されない場合、

DX 用の周期ハンドラが正しく動作していないことが考えられます。その原因と対策を以下に示します。

(1) タイマ割込みが入らない

• タイマ割込みが発生していない。
タイマドライバを見直し､タイマ割込みが発生するようにしてください。

• タイマ割込みは発生しているが受け付けられない。
次の場合には、タイマ割込みが受け付けられません。

− タイマ割込みより高いレベルの割込みの発生頻度が高すぎる。
− タイマ割込みレベルでマスクされた状態が長く続いている。
タイマ割込みレベル以上の割込みマスク期間はなるべく短くしてください。

(2) システムダウンが発生した

システムがダウンすると、タイマ割込みが受け付けられない場合があります。
システムダウンが発生しないように対策してください。
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