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ご注意書き 

 

１． 本資料に記載されている内容は本資料発行時点のものであり、予告なく変更することがあります。当社製品

のご購入およびご使用にあたりましては、事前に当社営業窓口で最新の情報をご確認いただきますとともに、

当社ホームページなどを通じて公開される情報に常にご注意ください。 
2. 本資料に記載された当社製品および技術情報の使用に関連し発生した第三者の特許権、著作権その他の知的

財産権の侵害等に関し、当社は、一切その責任を負いません。当社は、本資料に基づき当社または第三者の

特許権、著作権その他の知的財産権を何ら許諾するものではありません。 
3. 当社製品を改造、改変、複製等しないでください。 
4. 本資料に記載された回路、ソフトウェアおよびこれらに関連する情報は、半導体製品の動作例、応用例を説

明するものです。お客様の機器の設計において、回路、ソフトウェアおよびこれらに関連する情報を使用す

る場合には、お客様の責任において行ってください。これらの使用に起因しお客様または第三者に生じた損

害に関し、当社は、一切その責任を負いません。 
5. 輸出に際しては、「外国為替及び外国貿易法」その他輸出関連法令を遵守し、かかる法令の定めるところに

より必要な手続を行ってください。本資料に記載されている当社製品および技術を大量破壊兵器の開発等の

目的、軍事利用の目的その他軍事用途の目的で使用しないでください。また、当社製品および技術を国内外

の法令および規則により製造・使用・販売を禁止されている機器に使用することができません。 
6. 本資料に記載されている情報は、正確を期すため慎重に作成したものですが、誤りがないことを保証するも

のではありません。万一、本資料に記載されている情報の誤りに起因する損害がお客様に生じた場合におい

ても、当社は、一切その責任を負いません。 
7. 当社は、当社製品の品質水準を「標準水準」、「高品質水準」および「特定水準」に分類しております。また、

各品質水準は、以下に示す用途に製品が使われることを意図しておりますので、当社製品の品質水準をご確

認ください。お客様は、当社の文書による事前の承諾を得ることなく、「特定水準」に分類された用途に当

社製品を使用することができません。また、お客様は、当社の文書による事前の承諾を得ることなく、意図

されていない用途に当社製品を使用することができません。当社の文書による事前の承諾を得ることなく、

「特定水準」に分類された用途または意図されていない用途に当社製品を使用したことによりお客様または

第三者に生じた損害等に関し、当社は、一切その責任を負いません。なお、当社製品のデータ・シート、デ

ータ・ブック等の資料で特に品質水準の表示がない場合は、標準水準製品であることを表します。 
標準水準： コンピュータ、OA 機器、通信機器、計測機器、AV 機器、家電、工作機械、パーソナル機器、

産業用ロボット 
高品質水準： 輸送機器（自動車、電車、船舶等）、交通用信号機器、防災・防犯装置、各種安全装置、生命

維持を目的として設計されていない医療機器（厚生労働省定義の管理医療機器に相当） 
特定水準： 航空機器、航空宇宙機器、海底中継機器、原子力制御システム、生命維持のための医療機器（生

命維持装置、人体に埋め込み使用するもの、治療行為（患部切り出し等）を行うもの、その他

直接人命に影響を与えるもの）（厚生労働省定義の高度管理医療機器に相当）またはシステム

等 
8. 本資料に記載された当社製品のご使用につき、特に、最大定格、動作電源電圧範囲、放熱特性、実装条件そ

の他諸条件につきましては、当社保証範囲内でご使用ください。当社保証範囲を超えて当社製品をご使用さ

れた場合の故障および事故につきましては、当社は、一切その責任を負いません。 
9. 当社は、当社製品の品質および信頼性の向上に努めておりますが、半導体製品はある確率で故障が発生した

り、使用条件によっては誤動作したりする場合があります。また、当社製品は耐放射線設計については行っ

ておりません。当社製品の故障または誤動作が生じた場合も、人身事故、火災事故、社会的損害などを生じ

させないようお客様の責任において冗長設計、延焼対策設計、誤動作防止設計等の安全設計およびエージン

グ処理等、機器またはシステムとしての出荷保証をお願いいたします。特に、マイコンソフトウェアは、単

独での検証は困難なため、お客様が製造された最終の機器・システムとしての安全検証をお願いいたします。 
10. 当社製品の環境適合性等、詳細につきましては製品個別に必ず当社営業窓口までお問合せください。ご使用

に際しては、特定の物質の含有･使用を規制する RoHS 指令等、適用される環境関連法令を十分調査のうえ、

かかる法令に適合するようご使用ください。お客様がかかる法令を遵守しないことにより生じた損害に関し

て、当社は、一切その責任を負いません。 
11. 本資料の全部または一部を当社の文書による事前の承諾を得ることなく転載または複製することを固くお

断りいたします。 
12. 本資料に関する詳細についてのお問い合わせその他お気付きの点等がございましたら当社営業窓口までご

照会ください。 
 
注 1. 本資料において使用されている「当社」とは、ルネサスエレクトロニクス株式会社およびルネサスエレク

トロニクス株式会社がその総株主の議決権の過半数を直接または間接に保有する会社をいいます。 
注 2. 本資料において使用されている「当社製品」とは、注 1 において定義された当社の開発、製造製品をいい

ます。 



資料中の「日立製作所」、「日立XX」等名称の株式会社ルネサス テクノロジへの変更について

　2003年4月1日を以って三菱電機株式会社及び株式会社日立製作所のマイコン、ロジック、

アナログ、ディスクリート半導体、及びDRAMを除くメモリ（フラッシュメモリ・SRAM等）を含む

半導体事業は株式会社ルネサス テクノロジに承継されました。従いまして、本資料中には 

「日立製作所」、「株式会社日立製作所」、「日立半導体」、「日立XX」といった表記が残っておりま

すが、これらの表記は全て「株式会社ルネサス テクノロジ」に変更されておりますのでご理

解の程お願い致します。尚、会社商標・ロゴ・コーポレートステートメント以外の内容につい

ては一切変更しておりませんので資料としての内容更新ではありません。

ルネサステクノロジ ホームページ （http://www.renesas.com）

2003年4月1日

株式会社ルネサス テクノロジ

カスタマサポート部

お客様各位



ご注意

安全設計に関するお願い

1. 弊社は品質、信頼性の向上に努めておりますが、半導体製品は故障が発生したり、誤

動作する場合があります。弊社の半導体製品の故障又は誤動作によって結果として、

人身事故、火災事故、社会的損害などを生じさせないような安全性を考慮した冗長設

計、延焼対策設計、誤動作防止設計などの安全設計に十分ご留意ください。

本資料ご利用に際しての留意事項

1. 本資料は、お客様が用途に応じた適切なルネサス テクノロジ製品をご購入いただく

ための参考資料であり、本資料中に記載の技術情報についてルネサス テクノロジが

所有する知的財産権その他の権利の実施、使用を許諾するものではありません。

2. 本資料に記載の製品データ、図、表、プログラム、アルゴリズムその他応用回路例の

使用に起因する損害、第三者所有の権利に対する侵害に関し、ルネサス テクノロジ

は責任を負いません。

3. 本資料に記載の製品データ、図、表、プログラム、アルゴリズムその他全ての情報は

本資料発行時点のものであり、ルネサス テクノロジは、予告なしに、本資料に記載

した製品または仕様を変更することがあります。ルネサス テクノロジ半導体製品の

ご購入に当たりましては、事前にルネサス テクノロジ、ルネサス販売または特約店

へ最新の情報をご確認頂きますとともに、ルネサス テクノロジホームページ

(http://www.renesas.com)などを通じて公開される情報に常にご注意ください。

4. 本資料に記載した情報は、正確を期すため、慎重に制作したものですが万一本資料の

記述誤りに起因する損害がお客様に生じた場合には、ルネサス テクノロジはその責

任を負いません。

5. 本資料に記載の製品データ、図、表に示す技術的な内容、プログラム及びアルゴリズ

ムを流用する場合は、技術内容、プログラム、アルゴリズム単位で評価するだけでな

く、システム全体で十分に評価し、お客様の責任において適用可否を判断してくださ

い。ルネサス テクノロジは、適用可否に対する責任は負いません。

6. 本資料に記載された製品は、人命にかかわるような状況の下で使用される機器あるい

はシステムに用いられることを目的として設計、製造されたものではありません。本

資料に記載の製品を運輸、移動体用、医療用、航空宇宙用、原子力制御用、海底中継

用機器あるいはシステムなど、特殊用途へのご利用をご検討の際には、ルネサス テ

クノロジ、ルネサス販売または特約店へご照会ください。

7. 本資料の転載、複製については、文書によるルネサス テクノロジの事前の承諾が必

要です。

8. 本資料に関し詳細についてのお問い合わせ、その他お気付きの点がございましたらル

ネサス テクノロジ、ルネサス販売または特約店までご照会ください。
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ご注意
1 本書に記載の製品及び技術のうち「外国為替及び外国貿易法」に基づき安全保障貿易管理関連貨
物・技術に該当するものを輸出する場合，または国外に持ち出す場合は日本国政府の許可が必要
です。

2 本書に記載された情報の使用に際して，弊社もしくは第三者の特許権，著作権，商標権，その他
の知的所有権等の権利に対する保証または実施権の許諾を行うものではありません。また本書に
記載された情報を使用した事により第三者の知的所有権等の権利に関わる問題が生じた場合，弊
社はその責を負いませんので予めご了承ください。

3 製品及び製品仕様は予告無く変更する場合がありますので，最終的な設計，ご購入，ご使用に際
しましては，事前に最新の製品規格または仕様書をお求めになりご確認ください。

4 弊社は品質・信頼性の向上に努めておりますが，宇宙，航空，原子力，燃焼制御，運輸，交通，
各種安全装置， ライフサポート関連の医療機器等のように，特別な品質・信頼性が要求され，そ
の故障や誤動作が直接人命を脅かしたり，人体に危害を及ぼす恐れのある用途にご使用をお考え
のお客様は，事前に弊社営業担当迄ご相談をお願い致します。

5 設計に際しては，特に最大定格，動作電源電圧範囲，放熱特性，実装条件及びその他諸条件につ
きましては，弊社保証範囲内でご使用いただきますようお願い致します。
保証値を越えてご使用された場合の故障及び事故につきましては，弊社はその責を負いません。
また保証値内のご使用であっても半導体製品について通常予測される故障発生率，故障モードを
ご考慮の上，弊社製品の動作が原因でご使用機器が人身事故，火災事故，その他の拡大損害を生
じないようにフェールセーフ等のシステム上の対策を講じて頂きますようお願い致します。

6 本製品は耐放射線設計をしておりません。
7 本書の一部または全部を弊社の文書による承認なしに転載または複製することを堅くお断り致し
ます。

8 本書をはじめ弊社半導体についてのお問い合わせ，ご相談は弊社営業担当迄お願い致します。



はじめに

Hitachi Embedded Workshop（以下、HEWと略します）は、日立マイクロコンピュータの組み込み
用アプリケーションの開発を強力にサポートするツールです。特徴をまとめると次のようになります。

• 使い勝手の良いインタフェースを活用したコンパイラ、アセンブラ、リンケージエディタな
どのオプションが設定できるカスタマイズ可能なプロジェクトビルドシステム。

• プログラムを読みやすくするシンタックス色付け機能を持つ統合テキストエディタ。
• ユーザ独自のツールを実行するための環境設定。
• バージョン管理サポート。
• 日立デバッギングインタフェース(HDI)など HEW拡張機能の追加。

HEWは二つの目的で設計されています。一つはユーザに強力な開発ツールを提供すること、そし
てもう一つは、それらのツール類を統合して使いやすくすることです。HEWを HDI（日立デバッギ
ングインタフェース）と共に使用することにより、完備された統合開発ツールを提供することを意図
しています。



このマニュアルについて
このマニュアルでは HEWシステムの使用方法を述べています。第 1章「概要」では、HEWの機

能を紹介します。2章「ビルドの基本」ではビルドの動作、つまりファイルの操作方法、オプション
の設定方法などを示します。3章「エディタの使用」ではエディタについて説明します。4章「ビル
ドの応用」ではビルド機能の詳細とカスタムビルドについて、5章「ツール管理」では HEWのツー
ル管理、6章「環境のカスタマイズ」では環境設定の方法、7章「バージョン管理」、8章「カスタ
ムバージョン管理システム」および 9章「Visual SourceSafeを使う」では HEWと共に使用するバー
ジョン管理ツールの設定方法を説明します。

このマニュアルでは C/C++言語、アセンブリ言語の書き方や、オペレーティングシステムの使い方、
個々のデバイスに適したプログラムの書き方などについては説明していません。それらについては、
各々のマニュアルを参照してください。

【注】 本マニュアルに記載されている HEWの画面は英語版Windows®上で取得したものです。日
本語版Windows®では一部日本語表示されます。また、本マニュアルではディレクトリ区切
り子としてバックスラッシュ‘\’を使用していますが、日本語版Windows®上ではバックス
ラッシュの代わりに円記号を使用してください。

Microsoft, MS-DOS, Windows, Windows NTは米国Microsoft社の米国およびその他の国にお
ける登録商標です。
Visual SourceSafe は Microsoft社の米国およびその他の国における商標です。
IBMは International Business Machines Corporationの登録商標です。
その他、記載されている製品名は各社の商標または登録商標です。

このマニュアルの記号
このマニュアルで使われている記号の意味を説明します。

表 1　記号一覧
記号 意味

[Menu->Menu Option] 太字と ‘->‘ はメニューオプションを示します ( 例 [File->Save As...] )

FILENAME.C 大文字の名前はファイル名を示します

“文字列の入力” 下線は入力する文字列を示します ( “” を省く)

Key + Key キー入力を示します。例えば、CTRL+N キーでは CTRL キーと N キーを
同時に押します

 
(「操作方法」マーク)

このマークが左端にあるとき、その右の文章は何かの操作方法を示します
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1. 概要

この章では HEWの基本概念を説明します。Windows®アプリケーションに慣れていないユーザの
ために、次章以降で必要となる情報を提供します。

1.1 ワークスペース、プロジェクト、ファイル
ワードプロセッサでドキュメントを作成、修正できるのと同じように、HEWではワークスペース

を作成、修正できます。
ワークスペースはプロジェクトを入れる箱と考えることができます。同じように、プロジェクトは

プロジェクトファイルを入れる箱と考えることができます。したがって各ワークスペースにはプロジ
ェクトが一つ以上あり、各プロジェクトにはファイルが一つ以上あります。この構成を図 1.1に示し
ます。

ワークスペース�

プロジェクト�

プロジェクト�

プロジェクト�

ファイル�

ファイル�

ファイル�

図 1.1　ワークスペース、プロジェクト、ファイル

ワークスペースでは関連したプロジェクトを一つにまとめることができます。例えば、異なるプロ
セッサに対して一つのアプリケーションを構築しなければならない場合、または、アプリケーション
とライブラリを同時に開発している場合などに便利です。さらに、ワークスペース内でプロジェクト
を階層的に関連づけることができます。つまり、一つのプロジェクトを構築すると、その子プロジェ
クトが最初に構築されます。

ワークスペースを活用するには、ユーザは、まずワークスペースにプロジェクトを追加して、その
プロジェクトにファイルを追加しなければなりません。



1. 概要

2

1.2 メインウィンドウ
HEW のメインウィンドウを図 1.2に示します。

タイトルバー�

メニューバー�

ツールバー�

ワークスペース�
ウィンドウ�

エディタ�
ウィンドウ�

アウトプット�
ウィンドウ�

ステータス�
バー�

図 1.2　HEWメインウィンドウ

HEWにはメインウィンドウが 3つあります。ワークスペースウィンドウ、エディタウィンドウ、
アウトプットウィンドウです。ワークスペースウィンドウには現在そのワークスペースにあるプロジ
ェクトやファイルを示します。エディタウィンドウではファイルを表示、編集できます。アウトプッ
トウィンドウにはさまざまな処理結果（ビルド、バージョン管理コマンドなど）を表示します。

1.2.1 タイトルバー
タイトルバーには現在、開いているワークスペース、プロジェクト、ファイルが表示されます。ま

た、“最小化”ボタン、 “最大化”ボタン、“閉じる”ボタンがあります。“最小化”ボタンをクリ
ックすると HEWがアイコンになります。“最大化”ボタンをクリックすると HEW がフルスクリー
ンに表示されます。“閉じる”ボタンをクリックすると HEWを閉じることができます（これは
[File->Exit]を選ぶか ALT+F4キーを押すのと同じです）。

1.2.2 メニューバー
メニューバーには次の 8つのメニューがあります。 “File”, “Edit”, “Project”, “Options”, “Build”,

“Tools”, “Window”, “Help”です。メニューのオプションはすべてこれら 8つのメニューの下にグルー
プ化されています。例えば、ファイルを開きたいときには“File”メニューの下のオプションを選びま
す。ツールのセットアップをしたいときには、“Tools”メニューを選びます。メニューのオプション
の機能については後の章で説明します。ここでは、各オプションの簡単な紹介をします。
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1.2.3 ツールバー
ツールバーにより、使う頻度の高いオプションを簡単に利用できます。デフォルトでは“Editor”、

“Standard”、”Search”、”Bookmarks”、”Templates”、“Version Control”、の六つのツールバーがあ
ります（図 1.3～図 1.8参照）。ツールバーの作成や変更は [Tools->Customize…] メニューオプショ
ンで指定できます(詳細については「6.　環境のカスタマイズ」を参照してください)。

新規ファイル�

ファイルを開く�

ファイルの保存�

すべての�
ファイルの保存�

ファイル間検索�

かっこの組み合わせ�
テンプレートの挿入�

ファイル�
の印刷�

カット�

コピー�

貼りつけ�

検索�
ブックマークの�
設定と解除�

図 1.3　Editorツールバー

ビルドファイル� ビルド中止�

ビルド�

全ビルド�

現在のコンフィグレーション� エディタ起動�

アウトプットウィンドウ�

ワークスペースウィンドウ�

デバッガ起動�

図 1.4　Standardツールバー

検索文字�
後ろを検索�

前を検索�

ファイル間検索�

図 1.5　Searchツールバー

次のブックマーク�

ブックマーク追加�

前のブックマーク�

全ブックマーク解除�

図 1.6　Bookmarkツールバー
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テンプレート選択�
テンプレート挿入�テンプレート設定�

図 1.7　Templateツールバー

ファイル追加�

ファイル削除�

ファイルの状態�

ファイルチェックイン�

ファイルチェックアウト�

ファイル取得�

図 1.8　Version Controlツールバー
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メニューバーまたはツールバーがドッキング（連結）状態のとき、図 1.9.iに示すコントロールバ
ーが表示されます。ドッキング状態のメニューバーまたはツールバーの位置を移動したいときはコン
トロールバーを移動先までドラッグします（ドラッグとは、マウスの左ボタンを押下したまま目的の
場所まで移動してからボタンを離すことをいいます）。図 1.9.i がドッキング状態、図 1.9.ii がフロ
ーティング（浮遊）状態のメニューバーを示します。

ii.

i.

コントロールバー�

図 1.9　メニューバーのドッキング／フローティング状態

図 1.10.i にドッキング状態の“Standard”ツールバーを、図 1.10.ii にフローティング状態の
“Standard”ツールバーを示します。

i.

ii.

図 1.10　Standardツールバーのドッキング／フローティング状態

メニューバーまたはツールバーをドッキング状態にするには

フローティング状態のメニューバーまたはツールバーのタイトルバーをダブルクリックし
てください。

または

フローティング状態のメニューバーまたはツールバーのタイトルバーを、ドッキング状態の
ウィンドウ、メニューバー、ツールバー、またはHEWメインウィンドウの端までドラッグし
ます。バーの形が変わります。

メニューバーまたはツールバーをフローティング状態にするには

ドッキング状態のメニューバーまたはツールバーのコントロールバーをダブルクリックし
てください。

または

ドッキング状態のメニューバーまたはツールバーのコントロールバーを、HEWのメインウィ
ンドウまたはその他のドッキング状態のウィンドウ、メニューバー、またはツールバーの端
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から外れるように、ドラッグしてください。

1.2.4 ワークスペースウィンドウ
ワークスペースウィンドウにはタブが二つあります。“Projects”タブには現在のワークスペース、

プロジェクト、ファイルを示します（図 1.11）。アイコンをダブルクリックしてプロジェクトファイ
ルや個々のファイルを開くことができます。

Navigationタブ�

Projectsタブ�

図 1.11　Workspaceウィンドウ　Projectsタブ

“Navigation”タブによりプロジェクトファイルの中のテキスト部へジャンプできます。
“Navigation”タブに実際に表示される内容は、現在、何がインストールされているかによって異なり
ます。図 1.12 には例えば ANSI規格 の C 関数一覧を示します。ワークスペースウィンドウの詳細
については「2.　ビルドの基本」を参照してください。

図 1.12　Workspace ウィンドウ　Navigation タブ
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ワークスペースウィンドウやアウトプットウィンドウでドッキングが許されていれば、それらをド
ッキング（連結）状態やフローティング（浮遊）状態にすることができます。ドッキングが許されて
いない場合、ワークスペースウィンドウやアウトプットウィンドウは HEWメインウィンドウの通常
のウィンドウです。

ワークスペースウィンドウやアウトプットウィンドウでドッキングを許すには

ウィンドウ上で右マウスボタンをクリックしてください。すると、ポップアップメニューが
表示されます。ここで [Allow Docking] にチェック印が付いている場合、ドッキングが許さ
れています。チェック印が外れている場合、ドッキングは許されていません。 [Allow Docking]
を選択するとチェック印が付いたり外れたりします。

[Allow Docking] にチェック印が付いている場合、ウィンドウを HEWメインウィンドウや他のド
ッキング状態のウィンドウ、ツールバー、またはメニューバーの端に連結できます。同じく[Allow
Docking] にチェック印が付いている場合、ウィンドウを他の HEWのウィンドウ上や HEWメインウ
ィンドウの外でフローティング状態にすることができます。図 1.13.i にはドッキング状態のワークス
ペースウィンドウ、図 1.13.ii にはフローティング状態のワークスペースウィンドウを示します。

i. ii.

図 1.13　ワークスペースウィンドウのドッキング／フローティング状態

ワークスペースウィンドウやアウトプットウィンドウがドッキング状態のとき、図 1.14に示すコ
ントロールバーが表示されます。ドッキング状態のウィンドウを移動したいとき、コントロールバー
を移動先までドラッグしてください。

“閉じる”ボタン�

図 1.14　ドッキング状態ウィンドウのコントロールバー
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ワークスペースウィンドウやアウトプットウィンドウをドッキング状態にするには

ワークスペースウィンドウやアウトプットウィンドウをドッキング状態にするにはポップ
アップメニューで[Allow Docking] にチェック印が付いている必要があります。（ポップアッ
プメニューはウィンドウ上でマウスの右ボタンをクリックすると表示されます。）その上で、
フローティング状態のウィンドウのコントロールバーをダブルクリックしてください。

または

フローティング状態のウィンドウのタイトルバーを、移動先のドッキング状態のウィンド
ウ、メニューバー、ツールバー、またはHEWのメインウィンドウの端までドラッグしてくだ
さい。フローティング状態のウィンドウの形が変わります。

ワークスペースウィンドウやアウトプットウィンドウをフローティング状態にするには

ワークスペースウィンドウやアウトプットウィンドウをフローティング状態にするにはポ
ップアップメニューで[Allow Docking] にチェック印が付いている必要があります。（ポップ
アップメニューはウィンドウ上でマウスの右ボタンをクリックすると表示されます。）その
上で、

ドッキング状態のウィンドウのコントロールバーをダブルクリックしてください。

または

ドッキング状態のウィンドウのコントロールバーを、HEWのメインウィンドウや他のドッキ
ング状態のウィンドウ、メニューバー、ツールバーの端から外れるようにドラッグしてくだ
さい。

ワークスペースウィンドウやアウトプットウィンドウを隠すには

ウィンドウの右上端にある“閉じる”ボタンをクリックしてください。または固定していな
いウィンドウの中で右マウスボタンをクリックし、ポップアップメニューから [Hide] を選
んでください。

ワークスペースウィンドウやアウトプットウィンドウを表示するには

ワークスペースウィンドウを表示するには[Window-> Workspace] を、 アウトプットウィン
ドウを表示するには[Window->Output]を選んでください。
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1.2.5 エディタウィンドウ
エディタウィンドウではプロジェクトのファイルを操作します。同時に複数のファイルを開いたり、

任意の順序にファイルを切り替えたり、並べ替えたり、編集したりできます。デフォルトでは、エデ
ィタウィンドウはノートブック形式で表示されます。各テキストファイルにはタブがあります（図
1.15）。

図 1.15　エディタウィンドウ

エディタウィンドウは“Tools Options”ダイアログボックスでカスタマイズできます。“Tools
Options”ダイアログボックスは [Tools->Options...] メニューオプションから開くことができます。
“Tools Options”ダイアログボックスでは、フォントやテキストの色やタブ文字の変更などができます。
HEWエディタ以外のエディタを使う場合は、使用するエディタを“Tools Options”ダイアログボック
スで指定してください。エディタの使用方法や構築については、「3.　エディタの使用」を参照して
ください。
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1.2.6 アウトプットウィンドウ
アウトプットウィンドウ(図 1.16)には最大三つのタブが表示されます。“Build”タブには任意のビ

ルド実行（コンパイラ、アセンブラなど）の出力を示します。ソースファイルにエラーがある場合、
“Build”タブにはエラーとソースファイル名と行番号が表示されます。エラーをダブルクリックする
と、ソースファイルの行にジャンプするので、エラー箇所をすばやく発見できます。

図 1.16　アウトプットウィンドウ

“Find in Files”タブには最後の“Find in Files”操作の結果を示します。“Find in Files”を使用するに
は、 [Edit->Find in Files…]
メニューオプションを選ぶか、ツールバーの“Find in Files”ボタンをクリックしてください。“Find

in Files”の使い方の詳細については、「3.　エディタの使用」を参照してください。
“Version Control”タブにはバージョン管理操作の結果を示します。このタブは、バージョン管理シ

ステムを使っているときだけ表示されます。バージョン管理の詳細については、「7.　バージョン管
理」を参照してください。
カレントタブの内容のクリア、カレントタブに表示されているテキスト文字列のWindows®クリッ

プボードへのコピー、アウトプットウィンドウに表示されるフォントの設定ができます。

アウトプットウィンドウのカレントタブの表示を消すには

カレントタブの中で右マウスボタンをクリックし、アウトプットウィンドウポップアップメ
ニュー(図1.17)から [Clear] を選んでください。

アウトプットウィンドウのカレントタブのテキスト文字列をWindows®クリップボードへコ
ピーするには

カレントタブの文字列を選択してください。CTRL+Cキーを押下するか、カレントタブの中
で右マウスボタンをクリックしアウトプットウィンドウポップアップメニュー(図1.17)から
[Copy] を選んでください。
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図 1.17　アウトプットウィンドウポップアップメニュー、Version Controlタブ

アウトプットウィンドウのフォントを設定するには

カレントタブの中で右マウスボタンをクリックし、アウトプットウィンドウポップアップメ
ニュー(図1.17)から [Set Font…] を選んでください。すると、”Set Font”ダイアログボックス
(図1.18)が表示されます。”Font”ドロップダウンリストからフォントを選択し、”Size”ドロ
ップダウンリストからフォントサイズを選択してください。設定を有効にするには”OK”ボ
タンを押してください。

【注】 日本語Windows®上で英語フォントを選択してもデフォルトの日本語フォントが有効になり
ます。

図 1.18　Set Fontダイアログボックス

1.2.7 ステータスバー
ステータスバーは六つの領域に分かれており、現在の HEWの状態を表示します。図 1.19 にステ

ータスバーを示します。

カラム�

行/行の総数� Caps Lock

挿入モード� Num Lockメッセージ�

図 1.19　ステータスバー
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1.3 ヘルプ機能
“Help”メニューは HEWメニューバーの右端にあります。“Help”メニューには“Contents”オプシ

ョンがあり、“Contents”オプションを選ぶと、HEWヘルプウィンドウのメイン画面が表示されます。
特定のダイアログボックスに関するヘルプを参照したいときは、各ダイアログボックスの右上端に

あるコンコンテキスト依存ヘルプボタンをクリックしてください（図 1.20）。

コンテキスト依存ヘルプボタン�

キャンセルボタン�

図 1.20　Help ボタン

コンテキスト依存ヘルプボタンをクリックすると、マウスポインタが？(クエスチョンマーク)付き
のポインタに変わります。この状態で、ダイアログボックスの一部をクリックすると、その部分に関
するヘルプを表示できます。
または、ある部分を選んで F1キーを押下すると、その部分のヘルプを表示します。

1.4 HEWを起動する
HEWを起動するにはWindows®の“スタート”メニューを開き、“プログラム”を選択し、 “Hitachi

Embedded Workshop”を選択し、HEWのショートカットを選びます。デフォルトで図 1.21にしめす
“Welcome!”ダイアログボックが開きます。

図 1.21　Welcome! ダイアログボックス

新規ワークスペースを作成するには“Create a new project workspace”を選択し、“OK”をクリックし
てください。最近開いたワークスペースを開くには“Open a recent project workspace”を選択し、ドロ
ップダウンリストから開きたいワークスペースを選択し、“OK”をクリックしてください。ワークス
ペースファイルを指定してワークスペースを開くには“Browse to another project workspace”を選択し、
“OK”をクリックしてください。HEWにツールを登録したり、HEWからツールの登録を外したりす
るには“Administration”ボタンをクリックしてください（詳細は「5.　ツール管理」を参照してくだ
さい）。ワークスペースを開かないで HEWを使うには“Cancel”をクリックしてください。
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1.5 新規ワークスペースを作成する
新規にワークスペースを作成するには

1. “Welcome!”ダイアログボックス（図1.21）から“Create a new project workspace”オプション
を選び、“OK”をクリックするか、[File->New Workspace...]を選んでください。“New Project
Workspace ”ダイアログボックスが表示されます（図1.22）。

図 1.22　New Project Workspace ダイアログボックス

2. “Name”フィールドに新規ワークスペース名を入力してください。新規ワークスペース名は
32文字以内で、半角英数字、半角下線を使用できます。ワークスペース名を入力すると、
自動的にワークスペースのサブディレクトリが“Directory”フィールドのディレクトリパス
に追加されます。このディレクトリパスを使用する代わりに“Browse…”ボタンをクリック
してワークスペースを作成するディレクトリを選んだり、“Directory”フィールドに、ワー
クスペースを作成するディレクトリを手入力することもできます。

3. ワークスペースの基盤となるCPU ファミリおよびツールチェインを選んでください。これ
らはワークスペースを作成した後で変更することができないので注意してください。

4. 新規ワークスペースを作成するとき、HEWは自動的に同じ名前のプロジェクトを作成して、
新規ワークスペースに追加します。“Project types”リストには、使用可能なプロジェクトの
種類（アプリケーション、ライブラリなど）を表示します。作成するプロジェクトの種類
をリストから選んでください。

5. “OK”をクリックすると、新規のワークスペースとプロジェクトが作成されます。
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【注】 同一ディレクトリにすでにワークスペースが存在する場合は、ワークスペースを作成できま
せん。

1.6 ワークスペースを開く
ワークスペースを開くには

1. “Welcome!”ダイアログボックス（図1.21）から“Browse to another project workspace”オプショ
ンを選んで“OK”をクリックするか、 [File->Open Workspace…].を選んでください。“Open
Project Workspace”ダイアログボックスが表示されます。

2. 開きたいワークスペースファイルを選びます（.HWS ファイルのみ）。
3. “Open”をクリックしてワークスペースを開いてください。ワークスペースを開くときに情報

を表示するように設定されている場合、”Workspace Properties” ダイアログボックスが表示
されます（図1.23）。”OK”をクリックするとワークスペースを開きます。
もし、ワークスペースのプロジェクトをビルドするときに使うツールチェーンのバージョン
がなければ、”Toolchain Missing Version”ダイアログボックスが表示されます（図1.24）。ツ
ールチェーンの既存のバージョンを使ってワークスペースを開くには、”Available versions”
ドロップダウンリストからバージョンを選び、”OK”をクリックしてください。ワークスペ
ースを開きます。
“Workspace Properties” ダイアログボックスが表示されるかどうかはワークスペースプロパ
ティダイアログボックスの“Show workspace informationon workspace open” チェックボック
ス、または、“Tools Options”ダイアログボックス“Workspace”タブの “Display workspace
information dialog on opening workspace” チェックボックスのチェックの有無によります。詳
細は「6.　環境のカスタマイズ」のワークスペースオプションの設定に関する説明を参照し
てください。”Workspace Properties” ダイアログボックスで“OK”をクリックするとワーク
スペースを開きます。“Cancel”をクリックするとワークスペースを開きません。

図 1.23　Workspace Properties ダイアログボックス
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図 1.24　Toolchain Missing Versionダイアログボックス

HEWでは、最近開いたファイル 5つまでを“File”メニューの“Recent Workspaces”サブメニューに
追加します。最近利用したファイルを再び開きたいときに便利です。

最近使ったワークスペースを開くには

“Welcome!”ダイアログボックスから“Open a recent project workspace”を選び、ドロップダウ
ンリストからワークスペース名を選び、“OK”をクリックします。または、[File->Recent
Workspace]メニューオプションを選び、そのサブメニューからワークスペース名を選びます。

【注】 HEWでは、一度に一つのワークスペースしか開けません。したがって、すでに開いている
ワークスペースがあるときに別のワークスペースを開こうとすると、すでに開いているワー
クスペースを閉じてから新しいワークスペースを開きます。

1.7 ワークスペースを保存する
[File->Save Workspace]メニューオプションを選ぶと、HEWのワークスペースが保存できます。

1.8 ワークスペースを閉じる
HEWのワークスペースを閉じるには、 [File->Close Workspace]を選んでください。ワークスペー

スまたはそのプロジェクトに変更があった場合は、保存するかどうかを選んでください。
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1.9 HEWを終了する
HEWを終了するには [File->Exit]を選ぶか、 Alt+F4キーを押下するか、システムメニューから“閉

じる”オプションを選んでください（システムメニューは HEWタイトルバーの最も左上側にあるア
イコンをクリックすると開きます）。ワークスペースが開いているときは、前節で説明したワークス
ペースを閉じる操作を行います。
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2. ビルドの基本

この章では HEWの一般的な機能を説明します。より高度な機能については「4.　ビルドの応用」
を参照してください。

2.1 ビルド処理
ビルド処理の一般例を図 2.1に示します。HEWのインストール時に提供されるツールによってビ

ルド処理は変わるので、図 2.1の例とは少し異なるかもしれません（例えば、コンパイラが無いなど）。
いずれにせよ、原則は同じです。ビルドの各ステップまたはフェーズにおいて、1セットのプロジェ
クトファイルについてビルド処理を行います。それが完了すると、次のステップまたはフェーズに移
ります。

コンパイラ

アセンブラ

リンケージ
エディタ

ビルド

Cソース
ファイル

アセンブリ言語
ソースファイル

ライブラリ
ファイル

プロジェクト

オブジェクト
ファイル

ロードモジュール

図 2.1　ビルド処理の一般例

図 2.1に示す例では、第一のフェーズがコンパイラ、第二のフェーズがアセンブラ、そして最後の
フェーズがリンケージエディタです。コンパイラのフェーズでは、プロジェクトの Cソースファイル
を順次コンパイルします。アセンブラのフェーズでは、アセンブリ言語のソースファイルを順次アセ
ンブルします。リンケージエディタのフェーズでは、すべてのライブラリファイルと、コンパイラフ
ェーズとアセンブラフェーズからの出力ファイルをリンクして、ロードモジュールを作成します。
ビルド処理をカスタマイズする方法はいくつかあります。例えば、独自のフェーズを追加したり、

あるフェーズを無効にしたり、フェーズを削除できます。これらのビルド実行の応用については、「4.
ビルドの応用」を参照してください。
この章では、ビルドの一般的な原則や基本機能を説明します。
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2.2 プロジェクトファイル
HEWを使ってアプリケーションをビルド処理するには、まず、どのファイルをプロジェクトに追

加して、各ファイルをどのようにビルド処理すべきかを指定しなければなりません(図 2.2）。

C
ソースファイル

アセンブリ言語
ソースファイル

ライブラリファイル

プロジェクト

プロジェクトファイルの追加

プロジェクトファイルの削除

デバッグ：ON
最適化：OFF

リストファイル：YES

デバッグ：OFF
最適化：OFF

リストファイル：YES

デバッグ：ON
サイレント：YES

マップファイル：YES

コンパイラオプションの設定

アセンブラオプションの設定

リンケージエディタの
オプションの設定

図 2.2　プロジェクトの編集

2.2.1 プロジェクトにファイルを追加する
アプリケーションをビルド実行する前に、まず、アプリケーションを構成するファイルを指定しな

ければなりません。

プロジェクトにファイルを追加するには

1. [Project->Add Files...]を選ぶか、ワークスペースウィンドウのポップアップメニューから
[Add Files…] を選ぶ（図2.3参照）か、ワークスペースウィンドウを選んでINSキーを押下
してください。



2. ビルドの基本

19

図 2.3　Projectポップアップメニュー

2. “Add”ダイアログボックスが表示されます。
3. 追加するファイルを選び“Add”ボタンをクリックしてください。

【注】 プロジェクトに追加できるファイルは、HEWが認識できる形式のファイルでなければなり
ません。プロジェクトにファイルを追加するとき、HEWはファイルの拡張子をチェックし
て、追加を許可するかどうか判断します。現在、定義されている拡張子については、“File
Extensions”ダイアログボックスをご覧ください（この章の後半にある「ファイルの拡張子と
ファイルグループ」を参照してください）。

2.2.2 プロジェクトからファイルを削除する
プロジェクトからファイルを削除できます。ファイルの削除は、一つでも、複数でも、すべてのフ

ァイルをまとめてでもできます。

プロジェクトからファイルを削除するには

1. [Project->Remove Files...] を選択するか、“Projects”タブのポップアップメニューから
[Remove Files…] を選択 (図2.4) してください。“Remove Project Files”ダイアログボックス
が表示されます（図2.5）。
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図 2.4　Project ポップアップメニュー

図 2.5　Remove Project Files ダイアログボックス

2. “Project files”リストから削除したいファイルを選んでください。複数のファイルを選ぶこと
もできます。

3. 選んだファイルを削除するには“Remove”ボタンをクリックしてください。すべてのプロジ
ェクトファイルを削除するには“Remove All”ボタンをクリックしてください。

4. “OK”をクリックするとプロジェクトからファイルを削除します。
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選んだファイルをプロジェクトから削除するには

1. ワークスペースウィンドウの“Projects”タブで削除したいファイルを選んでください。複数
のファイルを選ぶときはSHIFTキーまたはCTRLキーを押下してください。

2. DELキーを押してください。選んだファイルが削除されます。

2.2.3 ビルドからプロジェクトファイルを除外する
プロジェクトのファイルは、個々にビルドから除外することができます。

ビルドからプロジェクトのファイルを除外するには

1. ワークスペースウィンドウの“Projects”タブで、ビルドから除外したいファイルを右マウス
ボタンでクリックしてください。

2. ポップアップメニュー（図2.4）から[Exclude Build <ファイル名>]を選んでください。する
と、ファイルのアイコンに赤いバツ印がつけられ、ビルドから除外されます。

2.2.4 ビルドへプロジェクトファイルを入れる
除外したプロジェクトのファイルは再びビルドに入れることができます。

除外したファイルをビルドに再び入れるには

1. ワークスペースウィンドウの“Projects” タブでファイルを右マウスボタンで選んでくださ
い。

2. ポップアップメニューから[Include Build <ファイル名>]を選んでください。 赤いバツ印が
外され、ファイルがビルド可能になります。

2.3 ファイル拡張子とファイルグループ
HEWは拡張子エディタでファイルを識別します。拡張子は使用するツールによって定義されます。

例えば、コンパイラを使用すると拡張子.cが“C source file”グループに入り、コンパイラのフェーズ
に入力されます (図 2.1参照)。さらに、独自の拡張子を定義することもできます。例えば、プロジェ
クトでアセンブリ言語ソースファイルを使っている場合、デフォルトの拡張子が.srcだとすると、違
う拡張子（例:  .asm）を使うとき、新しい拡張子を定義してそれを.srcファイルと同様に扱うように
HEWに要求できます。
ファイルの拡張子は、“File Extensions”ダイアログボックスで表示、変更できます(図 2.6)。このダ

イアログボックスを表示するには [Project->File Extensions...]を選んでください。このダイアログボッ
クスには現在のワークスペースで定義されたすべての拡張子とファイルグループを表示します。
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図 2.6　FileExtensions ダイアログボックス

図 2.6に示す“File Extensions”リストは 2列に分かれています。左の列にはファイル拡張子、右の
列にはファイルグループを表示します。図 2.7に示すように、同じグループに多くのファイル拡張子
が存在する場合があります。例えば、一つのプロジェクト内でアセンブリ言語のソースファイルにい
くつかの拡張子がある場合があります (例: .src, .asm, .mar など)。

.SRC .ASM .MOT .C .LIB .LPF

アセンブリ言語ソースファイル Cソースファイル ライブラリファイル

図 2.7　ファイル拡張子とファイルグループ

新しい拡張子を作成するときは、その拡張子がすでに定義されたファイルグループに属するのか、
新しいファイルグループを作成する必要があるのか検討してください。新しい種類のファイルを追加
するときには新しいファイルグループを作成してください。作成方法を以下に説明します。

新規ファイルグループに新規ファイル拡張子を作成するには

1. メニューバーから[Project->File Extensions...] を選んでください。“File Extensions”ダイアロ
グボックスが表示されます（図2.6）。

2. “Add…”ボタンをクリックしてください。“Define File Extension”ダイアログボックスが表
示されます（図2.8）。

3. “File Extension”フィールドに定義する拡張子を入力してください。ピリオド ( . ) の入力は
不要です。

4. “New Group”オプションを選んで新しいファイルグループを定義する名前を入力してくだ
さい。
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5. 拡張子を定義するファイルの種類がテキスト形式の場合は“Text based file”をチェックして
ください。そうでない場合はチェックしません。

6. “OK”をクリックすると“File Extension”リストに拡張子が追加されます。

図 2.8　Define File Extension ダイアログボックス(新規グループ)

あるフェーズ内で、ビルダに認識されない拡張子をもつファイル使っているときは、新しい拡張子
を作成し、（例えば、アセンブリ言語ソースファイルの拡張子が.asmでビルダの認識する拡張子が.src
のとき）新しい拡張子を既存のファイルグループに追加することが必要です。追加方法を下記に説明
します。

新規ファイル拡張子を既存のファイルグループに追加するには

1. メニューバーから [Project->File Extensions...] を選んでください。“File Extensions”ダイア
ログボックスが表示されます（図2.6）。

2. “Add…”ボタンをクリックすると “Define File Extension”ダイアログボックスが表示されま
す(図2.9）。

3. “File extension”フィールドに定義する拡張子を入力してください。 ピリオド ( . ) の入力は
不要です。

4. “Existing group”オプションを選んでこの新しい拡張子をどのファイルグループに追加する
か指定してください。

5. “OK”をクリックすると“File Extensions”リストに拡張子が追加されます。
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図 2.9　Define File Extension ダイアログボックス (既存グループ)

新しいファイルグループを作成するとき、“Text based file”をチェックすると、このファイルグル
ープのファイルをエディタと関連付けできます(ワークスペースウィンドウの“Projects”タブでこのフ
ァイルをダブルクリックするとエディタでファイルを開きます)。“Text based file”チェックボックス
をチェックしないと、このファイルはエディタでは開きません。“File Extensions”ダイアログボック
スでは、エディタでファイルを開く指定だけでなく、ファイルグループとアプリケーションとの関連
付けができます。これを行うと、ワークスペースウィンドウの“Projects”タブでファイルをダブルク
リックすると、適切なアプリケーションでファイルを開きます。図 2.10にワードプロセッサと拡張
子.DOCの関連付けを示します。

テキストエディタ�

ワードプロセッサ�

ライブラリアン�

アプリケーションなし�

図 2.10　ファイルグループとアプリケーション
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アプリケーションとファイルグループを関連付けるには

1. “File Extensions”ダイアログボックスで関連付けるファイルグループを選んでください（図
2.10）。

2. “Open with…”ボタンをクリックしてください。 “Associate Application”ダイアログボックス
が表示されます（図2.11）。

図 2.11　Associate Application ダイアログボックス

3. 関連付けをしない場合は“None”を選びます。HEWのエディタまたは他のエディタでこの
種類のファイルを開くには“Editor”を選びます。特定のアプリケーションでこの種類のフ
ァイルを開くには“Other”を選びます。“Other”を選ぶと、すでに定義されたアプリケーシ
ョンをドロップダウンリストから選ぶか、または、新しいアプリケーションを定義するこ
とができます。

4. 新しいアプリケーションを定義する場合は“Add...”をクリックしてください。“Add
Application”ダイアログボックスが表示されます（図2.12）。

図 2.12　Add Application ダイアログボックス
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5. “Name”フィールドにアプリケーション名を入力します。“Command”フィールドにアプリ
ケーションのフルパスを入力します(パラメータは含めません)。“Parameters”フィールドに
ファイルを開くのに必要なパラメータを入力します。必ず$(FULLFILE) プレースホルダを
使って入力ファイルを指定してください(プレースホルダの詳細と使用方法については「付
録B　プレースホルダ」を参照してください)。“Initial directory”フィールドにアプリケーシ
ョンを実行させる初期ディレクトリを入力します。“OK”をクリックするとアプリケーシ
ョンが定義されます。

6. アプリケーションを変更するには“Modify…”ボタンを押してください。“Modify
Application”ダイアログボックスが表示されます。このダイアログボックスは、“Name”フ
ィールドが変更できないことを除いて“Add Application”ダイアログボックスと同じです。
設定を変更してから“OK”をクリックします。

7. “OK”をクリックすると選んだファイルグループに対するアプリケーションが関連付けら
れます。

2.4 ビルドフェーズにオプションを設定する
プロジェクトに必要なファイルを追加したら、次のステップは HEWに各ファイルのビルドを指示

することです。このためには、“Options”メニューからメニューオプションを選ばなければなりませ
ん。このメニューの内容は使用するツールによって異なります。例えば、コンパイラ、アセンブラ、
リンケージエディタを使う場合、それぞれに対応する三つのメニューオプションがあります。

ビルドフェーズにオプションを設定するには

1. オプションを変更するフェーズを“Options”メニューから選んでください。
2. オプションを指定するダイアログボックスが表示されます。
3. オプションを設定して、“OK”をクリックしてください。

詳細は、コンテキスト依存のヘルプボタンをクリックするか、ヘルプを参照したい場所を選び F1
キーを押下してください。

2.5 ビルドのコンフィグレーション
HEWでは、ビルドのコンフィグレーションの中に、すべてのビルドのオプションを格納できます

（図 2.13）。つまり、すべてのオプションを格納してそれらに名前を付けることができます。後にそ
のコンフィグレーションを選ぶと、各ビルドフェーズの各オプションを復帰させることができます。
図 2.13に“Default”、“MyDebug”、“MyOptimized”の 3つのビルドコンフィグレーションを示し

ます。“Default”ビルド構成では、各フェーズ（コンパイルとアセンブル）が標準設定されています。
“MyDebug”ビルド構成では、各ファイルがデバッグ情報付きでビルドされています。“MyOptimized”
ビルド構成では、各ファイルが最大限に最適化されデバッグ情報はありません。このプロジェクトの
開発者は、オプションを設定するダイアログボックスに戻ってこれらを設定することなく、これらの
ビルドコンフィグレーションのうちどれでも選ぶことができます。



2. ビルドの基本

27

デバック:ON

最適化:OFF

リストファイル:

NOC

ソースファイル

アセンブリ言語

ソースファイル

デバック:ON

最適化:OFF

リストファイル:

NO

デバック:ON

最適化:OFF

リストファイル:

NO

デバック:OFF

最適化:OFF

リストファイル:

YES

デバック:OFF

最適化:OFF

リストファイル:

YES

デバック:OFF

最適化:OFF

リストファイル:

NO

"Default"
コンフィグレーション

"MyDebugt"
コンフィグレーション

"MyOptimized"
コンフィグレーション

C:\MyProject\Default C:\MyProject\MyDebug C:\MyProject\MyOptimised

図 2.13　ビルドコンフィグレーションとファイルオプション

2.5.1 ビルドコンフィグレーションを選択する
使用するビルドコンフィグレーションを設定する方法には二つあります。
ツールバーのドロップダウンリストボックス（図 2.14）から選んでください。

図 2.14　ツールバーの選択

または

1. [Options->Build Configurations…]を選ぶと、“Build Configurations”ダイアログボックスが表示
されます（図2.15）。

図 2.15　Build Configurations ダイアログボックス
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2. “Current configuration”から使用するビルド構成を選んでください。
3. “OK”をクリックするとビルドコンフィグレーションが選ばれます。

2.5.2 ビルドコンフィグレーションを追加、削除する
ビルドコンフィグレーションの設定を他のビルドコンフィグレーションからコピーして追加した

り、ビルドコンフィグレーションを削除できます。これらの操作を以下に説明します。

ビルドコンフィグレーションを追加するには

1. [Options->Build Configurations…] を選ぶと“Build Configurations”ダイアログボックスが表示
されます（図2.15）。

2. “Add…”ボタンをクリックすると“Add Configuration”ダイアログボックスが表示されます
（図2.16）。

図 2.16　Add Configuration ダイアログボックス

3. “Configuration name”フィールドに新しいビルドコンフィグレーション名を入力してくださ
い。 入力すると、下に表示されるディレクトリがビルドコンフィグレーションに使われる
ディレクトリに変わります。“Based on configuration”フィールドのドロップダウンリストの
既存コンフィグレーションの中から、コンフィグレーションの設定をコピーする元となる
コンフィグレーションを選びます。両方のダイアログボックスの“OK”をクリックすると
新しいビルドコンフィグレーションが作成されます。

ビルドコンフィグレーションを削除するには

1. [Options->Build Configurations…] を選ぶと“Build Configurations”ダイアログボックスが表示
されます（図2.15）。

2. 削除するビルドコンフィグレーションを選び“Remove”ボタンをクリックしてください。
3. “OK”をクリックすると“Build Configurations”ダイアログボックスを閉じます。
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2.6 プロジェクトをビルド実行する
ビルド実行の概要は図 2.1を参照してください。

2.6.1 プロジェクトをビルド実行する
“Build”オプションでは前回のビルド実行後に変更のあったファイルだけをコンパイルまたはア

センブルします。さらに、前回のビルド実行以後に変更のあったファイルに依存するソースファイル
を再ビルド実行します。例えば、 “test.c”にファイル “header.h”が含まれており“header.h”が前回のビ
ルド実行以後に変更された場合、ファイル“test.c”が再コンパイルされます。

ビルド実行するには

[Build->Build] を選ぶか、“ビルド”ツールバーボタン( ) をクリックするか、F7キーを押
下してください。または、ワークスペースウィンドウの“Projects”タブのプロジェクトアイ
コン上で右マウスボタンをクリックしてポップアップメニューから[Build]を選んでくださ
い。

“Build All”オプションでは変更の有無に関わらず、すべてのソースファイルをコンパイルまたは
アセンブルして、新しく作成されたオブジェクトファイルをすべてリンクします。

“Build All” 処理を実行するには

[Build->Build All] を選ぶか、“全ビルド”ツールバーボタン ( )をクリックしてください。
または、ワークスペースウィンドウの“Projects”タブのプロジェクトアイコン上で右マウス
ボタンをクリックしてポップアップメニューから[Build All]を選んでください。

プロジェクトファイルのどれかにエラーが起こると、“Build”処理も“Build All”処理も終了します。

2.6.2 一つのファイルをビルド実行する
プロジェクトにある一つのファイルをビルド実行できます。

一つのファイルをビルド実行するには

1. プロジェクトウィンドウからビルド実行するファイルを選んでください。
2. [Build->Build File]を選ぶか、“ビルドファイル”ツールバーボタン ( ) をクリックするか、

CTRL+F7キーを押してください。または、ワークスペースウィンドウの“Projects”タブの
プロジェクトアイコン上で右マウスボタンをクリックして、ポップアップメニューから
[Build <ファイル名>]を選んでください。
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2.6.3 ビルド実行を中止する
ビルド実行を途中で中止できます。

ビルド実行を中止するには

1. [Build->Stop Build] を選ぶか、“ビルド中止”ツールバーボタン ( )をクリックしてくだ
さい。その時点のファイルのビルド実行を完了後、ビルド実行は中止されます。

2. アウトプットウィンドウに“Build Finished”というメッセージが表示されるのを確認してか
ら操作を続けてください。

ビルド実行中のツールを強制的に中止するには

1. [Build->Terminate Current Tool]を選んでください。ビルダはツールの実行をすぐに中止しま
す。

【注】 中止したツールによって出力されたファイルは有効ではない場合があります。作成した出力
ファイルをすべて削除して、そのフェーズを再実行してください。

2.6.4 アウトプットウィンドウ
ツール（コンパイラ、アセンブラ、リンケージエディタなど）が実行されると、その出力がアウト

プットウィンドウに表示されます。エラーまたはウォーニングが起きると、エラーメッセージまたは
ウォーニングメッセージと、ソースファイル名と行番号が表示されます。すぐにエラーまたはウォー
ニングが発生したところをエディタで見るには、表示されたエラーメッセージまたはウォーニングメ
ッセージをダブルクリックします。

2.6.5 アウトプットウィンドウの内容の制御
ビルド実行の途中に低レベル情報（ファイルに適用したコマンドラインオプションなど）を表示す

ると便利です。HEWでは、“Build”、 “Build All” 、 “Build File”処理中、アウトプットウィンドウに
そのオプションを表示するかどうかを“Tools Options”ダイアログボックスで指定できます。

ビルド実行中に低レベル情報の表示の有無を指定するには

1. [Tools->Options...]を選ぶと“Tools Options”ダイアログボックスが表示されます。
2. “Build”タブ（図2.17）を選んでください。
3. “Show”グループのチェックボックスを以下のように設定します。 “Command line”にはツー

ル実行時のコマンドライン表示の有無を指定します。“Environment”にはツール実行時の環
境変数の表示の有無を指定します。“Initial directory”にはツールが起動されるディレクトリ
パスの表示の有無を指定します。
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図 2.17　Tools Optionsダイアログボックス Buildタブ

2.7 ファイル依存関係
多くの場合プロジェクトにはファイル間の依存関係があります。例えば、一つの Cファイルはい

くつかのヘッダファイルをインクルードします。複雑なプロジェクトでは、ソースファイルが他のイ
ンクルードファイルに依存するため、 管理が難しくなります。しかし、HEWにはファイル依存関係
をスキャンする機能があり、そのプロジェクトにあるすべてのファイルの依存関係をチェックできま
す。スキャンが完了すると、プロジェクトのファイル依存関係を示す最新のリストをプロジェクトウ
ィンドウに表示します。

プロジェクトのファイル依存関係を更新するには

[Build->Update All Dependencies]を選んでください。または、ワークスペースウィンドウの
“Projects”タブのプロジェクトアイコンを右マウスボタンでクリックしてポップアップメニ
ューから[Update All Dependencies]を選んでください。

最初に、すべてのファイル依存は“Dependencies”フォルダに含まれています（図 2.18.i）。
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2.8 ワークスペースウィンドウの構成
ワークスペースウィンドウの“Projects”タブの中を右マウスでクリックすると、ポップアップメニ

ューが表示されます。その中から、[Configure View...]メニューオプションを選び、以下の情報の表示
方法を設定してください。 以下に、“Configure View”ダイアログボックスの各オプションについて
説明します。

2.8.1 各ファイルの下に依存を表示する
“Show dependencies under each file”を選ぶと、依存ファイルがそれをインクルードするソースファ

イルの下に平坦な構造で表示されます（ファイル自体がフォルダになります）。これを図 2.18.iiに示
します。このオプションを選ばないと、別のフォルダにすべてのファイル依存を示します（図 2.18.i）。

i. ii.

図 2.18　各ファイルの依存
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2.8.2 標準ライブラリファイルのインクルードを表示する
デフォルトでは、標準インクルードパスの依存ファイルは表示されません（図 2.19.i）。例えば、

Cコードで#include <stdio.h>などのインクルード文を書くと、“stdio.h”は依存ファイルとして表示さ
れません。そのようなシステムインクルードファイルを表示するには、“Show standard library includes”
オプションを選んでください（図 2.19.ii）。

i. ii.

図 2.19　標準ライブラリファイルのインクルード

2.8.3 ファイルのパスを表示する
“Show file paths”を選ぶと、ワークスペースウィンドウのすべてのファイルがフルパス（ドライブ

名からのパス）で表示されます（図 2.20）。

図 2.20　ファイルのパスの表示
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2.8.4 ファイルグループを個別のフォルダに表示する
“Show file groups in separate folders”を選ぶと、ワークスペースに表示されるプロジェクトファイル

を、ファイルの種類ごとにフォルダに入れることができます（図 2.21.ii）。また、すべてのプロジェ
クトファイルを一つのフォルダに入れることもできます（図 2.21.i）。

i. ii.

図 2.21　ファイルとフォルダ

2.9 カレントプロジェクトを設定する
ワークスペースには複数のプロジェクトを含めることができますが、ひとつだけがカレントプロジ

ェクトです。プロジェクトがカレントのとき、そのフォルダを開いたり、プロジェクトファイルを参
照したり、ビルド処理をするなどアクティブになります。ワークスペースでカレントプロジェクトを
設定することができます。カレントプロジェクト名は太字で表示されます。

プロジェクトをカレントプロジェクトにするには

1. ワークスペースウィンドウの “Projects”タブからカレントでないプロジェクトを選んでく
ださい。

2. 右マウスボタンをクリックしてポップアップメニューから[Set as Current Project] オプショ
ンを選んでください。

または

非カレントのプロジェクトを [Project->Set Current Project] サブメニューから選んでくださ
い。
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2.10 ワークスペースにプロジェクトを追加する
ワークスペースを作成したとき、最初はプロジェクトが一つしかありません。しかし、後で、新し

いプロジェクトや既存のプロジェクトを追加することができます。

ワークスペースに新しいプロジェクトを追加するには

1. [Project->Insert Project…]を選んでください。 “Insert Project” ダイアログボックス（図2.22）
が表示されます。

2. “New Project” オプションを設定してください。
3. “OK”をクリックしてください。 “Insert New Project” ダイアログボックス（図2.23）が表示

されます。
4. “Name” フィールドにプロジェクト名を入力してください。32文字以内で、半角英数字、半

角下線が入力できます。プロジェクト名を入力すると、HEWは自動的にサブディレクトリ
を追加します。これは不要であれば削除できます。

5. “Browse…”ボタンをクリックしてプロジェクトを作成するディレクトリを選んでくださ
い。または、 “Directory” フィールドにディレクトリを入力できます。

6. “Project type” リストには使用可能なプロジェクトの種類を示します（アプリケーション、
ライブラリなど）。このリストから作成するプロジェクトの種類を選んでください。

7. “OK”をクリックすると、プロジェクトが作成されワークスペースに追加されます。

【注】 新しいプロジェクトを作成するとき、CPUやツールチェインは指定できません。これらのプ
ロパティはワークスペースにより定義されています。つまり、同じワークスペース内のすべ
てのプロジェクトは同じ CPUとツールチェインであることになります。

図 2.22　Insert Projectダイアログボックス
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図 2.23　Insert New Projectダイアログボックス

既存のプロジェクトをワークスペースに追加するには

1. [Project->Insert Project…]を選んでください。 “Insert Project” ダイアログボックス（図2.22）
が表示されます。

2. “Existing Project” オプションを設定してください。
3. プロジェクトデータベースファイル（.HWPファイル）へのフルパスを入力するか、

“Browse…”ボタンをクリックしてプロジェクトデータベースファイルを指定してくださ
い。

4. “OK” をクリックするとそのプロジェクトがワークスペースに追加されます。

【注】 既存のプロジェクトをワークスペースに追加するとき、プロジェクトの CPUとツールチェ
インがワークスペースのものと一致しなければなりません。一致しない場合、そのプロジェ
クトはワークスペースに追加できません。
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2.11 プロジェクト間の依存関係を指定する
ワークスペースのプロジェクトは、他のプロジェクトに依存することができます。ビルド処理をす

ると、依存プロジェクトが最初にビルドされます。これは、ワークスペースのプロジェクトが他のプ
ロジェクトに使用されているときなどに便利です。例えば、ワークスペースに二つのプロジェクトが
あるとします。一つはライブラリプロジェクト、もう一つはそのライブラリを使用しているアプリケ
ーションだとします。このとき、ライブラリプロジェクトを依存プロジェクトに指定すると、アプリ
ケーションをビルドするときにライブラリが先にビルドされます。
依存プロジェクトをビルドするとき、カレントプロジェクトの現在のコンフィグレーションと同じ

名前のコンフィグレーションが選択されます。もし、依存プロジェクト内に同じコンフィグレーショ
ン名がない場合、依存プロジェクトはプロジェクトを最後に閉じたときのコンフィグレーションにな
ります。上記の例では、アプリケーションプロジェクトがカレントプロジェクトの場合、アプリケー
ションプロジェクトを “Debug”コンフィグレーションにすると、ライブラリプロジェクトも、“Debug”
コンフィグレーションとなります。ライブラリプロジェクトに “Debug” コンフィグレーションがな
い場合は、ライプラリプロジェクトが最後に閉じたときのコンフィグレーションが選択されます。

依存プロジェクトを作るには

1. [Project->Dependent Projects]を選んでください。 “Dependent Projects” ダイアログボックス
（図2.24）が表示されます。

2. 依存させたいプロジェクトを選んでください。 “Dependent projects” リストに（選択したプ
ロジェクト以外の）ワークスペース内のすべてのプロジェクトが表示されます。

3. “Dependent projects”リストには各プロジェクトにチェックボックスがあります。選んでプロ
ジェクトが依存するプロジェクトのチェックボックスをチェックしてください。

4. “OK”をクリックしてください。

【注】 カレントプロジェクトから 1レベルの依存関係が有効です。カレントプロジェクトをビルド
したとき子プロジェクトはビルドされますが、孫プロジェクトはビルドされません。

図 2.24　Dependent Projectsダイアログボックス
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2.12 ワークスペースからプロジェクトを削除する
ワークスペースからプロジェクトを削除するには

1. ワークスペースウィンドウの “Projects” タブを選び、右マウスボタンでポップアップメニ
ューを表示してください。

2. [Remove Project] オプションを指定してください。

または

1. ワークスペースウィンドウの “Projects” タブからプロジェクトを選んでください。
2. DEL キーを押してください。

【注】 ワークスペースから現在使用中のプロジェクトを削除することはできません。

2.13 ワークスペースへ(から)プロジェクトをロード(アンロー
ド)する

ワークスペースにプロジェクトをロードすると、プロジェクト内のフォルダで現在のフォルダ以外
のものを開くことができ、そのプロジェクトファイルを“Workspace”ウィンドウの“Projects”タブに
表示することができます。プロジェクトが現在のプロジェクトではなく、変更されていない場合、ロ
ードされたプロジェクトをワークスペースからアンロードできます。アンロードされたプロジェクト
のアイコンは“Workspace”ウィンドウの“Projects”タブに灰色表示されます。

ワークスペースにプロジェクトをロードするには

1. “Workspace”ウィンドウの“Projects”タブで、ロードするプロジェクトをマウスボタンで右
クリックしてください。ポップアップメニュー（図2.25 i）が表示されます。

2. ポップアップメニューから [Load Project] を選んでください。

【注】 [Load Project] メニュー項目はロードされていないプロジェクトの場合のみアクティブです。
ロードされていないプロジェクトのアイコンは灰色です。

ワークスペースからプロジェクトをアンロードするには

1. “Workspace”ウィンドウの“Projects”タブで、アンロードするプロジェクトをマウスボタン
で右クリックしてください。ポップアップメニュー（図2.25 ii）が表示されます。

2. ポップアップメニューから [Unload Project] を選んでください。

【注】 [Unload Project] メニュー項目はロードされているプロジェクトで変更がなく現在のプロジ
ェクトではない場合のみアクティブです。
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ii.i.

図 2.25　プロジェクトポップアップメニュー

2.14 ワークスペースやプロジェクトの名前変更
ワークスペースやプロジェクトを作成した後に名前を変更することができます。

ワークスペース名を変更するには

1. “Workspace”ウィンドウの“Projects”タブで、ワークスペースをマウスで右クリックしてく
ださい。ポップアップメニューが表示されます。

2. ポップアップメニューから [Properties] を選んでください。“Workspace Properties” ダイ
アログボックス (図2.26) が表示されます。

3. “Name”編集ボックスでワークスペース名を変更してください。名前は32文字以内で、半角
英数字と半角下線を使用できます。

4. “OK” をクリックするとワークスペース名が変更されます。

【注】 ワークスペース名を変更しても、ワークスペースのディレクトリ名は変更されません。
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図 2.26　Workspace Propertiesダイアログボックス

プロジェクト名を変更するには

1. “Workspace”ウィンドウの“Projects”タブで、プロジェクトをマウスで右クリックしてくだ
さい。ポップアップメニューが表示されます。

2. ポップアップメニューから [Properties] を選んでください。 “Properties” ダイアログボッ
クス (図 2.27) が表示されます。

3. “Name” 編集ボックスでプロジェクト名を変更してください。名前は32文字以内で、半角英
数字と半角下線を使用できます。

4. “OK” をクリックするとワークスペース名が変更されます。

【注】 プロジェクト名を変更しても、プロジェクトのディレクトリ名は変更されません。

図 2.27　Project Properties ダイアログボックス
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3. エディタの使用

この章では HEWが提供するエディタの使い方を説明します。

3.1 エディタウィンドウ
エディタウィンドウ (には、表示中や編集中のファイルウィンドウが含まれます（図 3.1）。
常に一つのウィンドウだけがアクティブです。それをアクティブウィンドウ（または現在のウィン

ドウ）と呼びます。アクティブウィンドウのタイトルバーは他のウィンドウとは色が異なります（図
3.1では“sbrk.c”がアクティブウィンドウです）。文字入力やテキスト貼りつけなどのテキスト操作
はアクティブウィンドウでのみ行うことができます。
アクティブウィンドウから他のウィンドウへ切り替えるには（他のウィンドウをアクティブウィン

ドウにする場合）、以下の方法があります。
(a) そのウィンドウが表示されていればそれをクリックする
(b) CTRL+TABキーを押下して順次ウィンドウをアクティブにする
(c) “Window”メニューからウィンドウ名を選ぶ
(d) エディタウィンドウの下の該当するタブを選ぶ。

ファイルが変更されている場合、ファイル名のタイトルバーにアスタリスク（＊）が追加されます。
アスタリスクはファイルを保存するまで表示されます。

“Notebook” タブ�

図 3.1　エディタウィンドウ
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3.2 複数のファイルを使う
プロジェクトのファイルを操作するときにはエディタウィンドウを使います。エディタによって、

一度に複数のファイルを開いたり、ファイル間の切り替えをしたり、異なる構成に並べ替えたり、任
意の順序に編集できます。ウィンドウ上での操作はWindows®のアプリケーションの一般的な機能で
あり、[Window]メニューから選ぶことができます。

[Window->Cascade]
開いているすべてのウィンドウの左上が見えるように重ねて並べます。

[Window->Tile]
開いているすべてのウィンドウが互いに重ならずにエディタウィンドウの全体を占めるように並
べます。

[Window->Arrange Icons]
すべてのアイコン化したウィンドウをエディタウィンドウの下に並べます。

[Window->Close All]
開いているエディタウィンドウをすべて閉じます。

また、エディタのファイルはノートブック形式で表示することができます。つまり、各ファイルに
タブが付いていてファイル間の行き来を容易にできます。

ファイルをノートブック形式で表示するには

1. [Tools->Options…]を選んでください。“Tools Options”ダイアログボックスが表示されるの
で “Editor”タブを選んでください。

2. “Show files in notebook” チェックボックスをチェックしてください。
3. “OK” をクリックしてください。

3.3 エディタツールバー
エディタ関連のツールバーは、編集、検索、ブックマーク、テンプレートの 4つあります（図 1.3、

図 1.5～図 1.7）。これらによって、頻繁に使う機能を簡単に選ぶことができます。ツールバーのボ
タンは以下のものがあります。

3.3.1 エディタツールバーボタン
新規ファイル
クリックすると、新規のソースファイルウィンドウをデフォルト名で作成します。ファイル
を保存するときにファイルの名前を変えることができます。

ファイルを開く
クリックすると、ファイルを開きます。標準のファイル選択用ダイアログボックスが表示さ
れます。開きたいファイルを選び“開く”をクリックします。

ファイルの保存
クリックすると、アクティブウィンドウのソースファイルを保存します。
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すべてのファイルの保存
クリックすると、開いているすべてのファイルを保存します。

ファイルの印刷
クリックすると、現在のアクティブウィンドウの内容を印刷します。

カット
クリックすると、選択されたテキストを削除してWindows® のクリップボードにコピーしま
す（貼りつけ操作をすると、再びファイルに貼りつけることができます）。

コピー
クリックすると、選択されたテキストを Windows® のクリップボードにコピーします。

貼りつけ
クリックすると、アクティブウィンドウのカーソル位置にクリップボードの内容をコピーし
ます。

検索
クリックすると、現在のファイルを指定された文字列で検索します。“Find”ダイアログボッ
クスが表示されるので、検索パラメータを指定してください。

ファイル間検索
クリックすると、複数のファイルを指定された文字列で検索します。検索結果はすべてアウ
トプットウィンドウの“Find in Files”タブに表示します。詳細は、この章の後半の「複数のフ
ァイル間でのテキスト検索」を参照してください。

かっこの組み合わせ
かっこ{ }, [ ] , ( )内のテキストをハイライト表示します。これは、開きかっこ（{）で始まり
閉じかっこ（}）で終わる C/C++言語のコードの構造を知りたいときに便利です。始まりのか
っこを選択するか、始まりのかっこの前にカーソルを置いて、このボタンをクリックしてく
ださい。かっこの組み合わせの詳細については、この章の後半の「かっこの組み合わせ」を
参照してください。

テンプレートの挿入
クリックすると、あらかじめ決められたテンプレートを現在のカーソル位置に挿入します。
“Insert Template”ダイアログボックスが表示されます。テンプレート番号を選び、“OK”をク
リックしてください。テンプレートの挿入の詳細については、この章の後半の「テンプレー
ト」を参照してください。

ブックマークの設定と解除
HEWはブックマーク機能を提供します。ブックマークを設定するには、行を選び、このボタ
ンをクリックしてください（デフォルトでは行が緑色になります）。ブックマークを解除す
るには、行を選び、このボタンをクリックしてください（行が普通のテキストに戻ります）。
ブックマークの詳細については、この章の後半の「ブックマーク」を参照してください。
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3.3.2 検索ツールボタン

次を検索

現在の検索文字列の次の出現を検索します。

前を検索

現在の検索文字列の直前の出現を検索します。

ファイル間検索

複数のファイルにおいて文字列を検索します。“Output” ウィンドウの“Find in Files” タブに、
検索結果を表示します。詳細は、この章の後半の「検索とファイル内の移動」を参照してく
ださい。

3.3.3 ブックマークツールバーボタン

ブックマークの設定と解除
現在の行にブックマークを設定します。または、現在の行のブックマークを解除します。

次のブックマーク
現在の行から現在のファイルの次のブックマークに飛びます。

前のブックマーク
現在の行から現在のファイルの前のブックマークに飛びます。

全ブックマーク解除
現在のファイルのすべてのブックマークを解除します。

3.3.4 テンプレートツールバーボタン

テンプレートの定義
挿入するテンプレートテキストを定義します。

テンプレートの挿入
ドロップダウンリストで選んだテンプレートを現在のカーソル位置に挿入します。
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3.4 標準のファイル操作

3.4.1 新規ファイルの作成
新しいエディタウィンドウを作成するには

[File->New] を選択するか、“新規ファイル”ツールバーボタン ( ) をクリックするか、
CTRL+Nキーを押下してください。

新しいウィンドウにはデフォルトで名前がつきます。ファイルを保存するときに名前を変更できま
す。

3.4.2 ファイルの保存
エディタウィンドウの内容を保存するには

1. 内容を保存するウィンドウがアクティブであることを確認してください。
2. [File->Save] を選択するか、“ファイルの保存”ツールバーボタン ( ) をクリックするか、

CTRL+Sキーを押下してください。
3. ファイルを新規に保存する場合、名前を付けて保存するダイアログボックスが表示されま

す。ファイル名とディレクトリを指定して、“保存”をクリックしてください。
4. すでに保存したことのあるファイルの場合は、ダイアログボックスを表示せずにファイル

が更新されます。

エディタウィンドウの内容を新しい名前で保存するには

1. 内容を保存するウィンドウがアクティブであることを確認してください。
2. [File->Save As...]を選んでください。
3. 名前を付けて保存するダイアログボックスが表示されます。ファイル名とディレクトリを

指定して“保存”をクリックしてください。

3.4.3 全ファイルの保存
すべての開いているエディタウィンドウの内容を保存するには

1. [File->Save All] を選ぶか、“すべてのファイルの保存”ツールバーボタン ( )をクリック
してください。

2. 新規にファイルを保存する場合、名前を付けて保存するためのダイアログボックスが表示
されます。ファイル名とディレクトリを指定してください。

3. すでに保存したことのあるファイルの場合は、ダイアログボックスを表示せずにファイル
が更新されます。
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3.4.4 ファイルを開く
ファイルを開くには

1. [File->Open...] を選ぶか、“ファイルを開く”ツールバーボタン ( ) をクリックするか、
CTRL+Oキーを押下してください。

2. ファイルを開くダイアログボックスが表示されます。右のディレクトリブラウザを使って、
開きたいファイルのあるディレクトリに移動してください。“Files of type”コンボボックス
でファイルの種類を選んでください(“All Files” (*.*) を指定すると、そのディレクトリのす
べてのファイルが表示されます)。

3. ファイルを選んで“開く”をクリックしてください。

開いた最新のファイル 5つは“File”メニューの“Recent Files”サブメニューに追加されます。この
機能は最近開いたファイルを再び開きたいときに便利です。

最近利用したファイルを開くには

[File->Recent File] メニューオプションを選択してこのサブメニューから開きたいファイル
を選択してください。または、ワークスペースウィンドウの“Projects”タブで開きたいファ
イルをダブルクリックするか、ファイルを選び、右マウスボタンをクリックしてポップアッ
プメニューから[Open <ファイル名>]オプションを選んでください。

3.4.5 ファイルを閉じる
個別にファイルを閉じるには、以下のいずれかの方法で閉じます。

• エディタウィンドウのシステムメニュー（“最大化”表示されていないときの各ウィンドウ
の左上）をダブルクリックする。

• エディタウィンドウのシステムメニュー（“最大化”表示されていないときの各ウィンドウ
の左上）をクリックして“Close”メニューオプションを選ぶ。

• アクティブウィンドウであることを確認後 CTRL+F4キーを押下する。
• アクティブウィンドウであることを確認後[File->Close]を選ぶ。
• “閉じる”ボタン（“最大化”表示されていないときの各ウィンドウの右上）をクリックする。

すべてのウィンドウを閉じるには

[Windows->Close All]を選んでください。
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3.5 ファイルを編集する
HEWエディタは標準的な編集機能をサポートします。通常の方法（メニュー、ツールバー、キー

ボードのショートカット）で編集できるほか、各エディタウィンドウにあるポップアップメニュー（ま
たはローカルメニューという）でも編集することができます。ポップアップメニューを表示するには、
開いたウィンドウにポインタを置き、マウスの右ボタンをクリックしてください。表 3.1に編集の基
本操作を示します。

表 3.1　編集の基本操作
名称 機能 操作

カット ハイライト表示されたテキストを削除し
Windows®クリップボードに貼りつける

• “Cut”ツールバーボタンをクリック

• [Edit->Cut]を選択

• [Cut] -ローカルメニューを選択

• CTRL+Xキーを押下

コピー ハイライト表示されたテキストをコピーし
Windows®クリップボードに貼りつける

• “Copy ”ツールバーボタンをクリック

• [Edit->Copy] を選択

• [Copy] -ローカルメニューを選択

• CTRL+Cキーを押下

貼りつけ Windows®クリップボードの内容をコピーし
てアクティブウィンドウのカーソル位置に貼
りつける

• “Paste ”ツールバーボタンをクリック

• [Edit->Paste]を選択

• [Paste] - ローカルメニューを選択

• CTRL+Vキーを押下

削除 ハイライト表示されたテキストを削除する
（Windows®クリップボードに貼りつけない）

• [Edit->Clear] を選択

• [Clear] -ローカルメニューを選択

• Delete キーを押下

すべて選択 アクティブウィンドウの内容すべてを選択（ハ
イライト表示）する

• [Edit->Select All] を選択

• [Select All] -ローカルメニューを選択

取り消し 最新の編集操作を取り消す • [Edit->Undo] を選択

• [Undo] -ローカルメニューを選択

• CTRL+Zキーを押下

やり直し 最新の取り消した編集操作をやり直す • [Edit->Redo] を選択

• [Redo] -ローカルメニューを選択

• CTRL+Yキーを押下
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3.6 検索とファイル内の移動
HEWには、検索、置換、ファイル間の操作の機能があります。次の 3節にそれらの機能の使い方

を示します。

3.6.1 テキストの検索
現在のファイルのテキストを検索するには

1. 内容を検索するウィンドウがアクティブウィンドウであることを確認してください。
2. 検索開始位置にカーソルを置いてください。
3. [Edit->Find...]を選ぶか、CTRL+Fキーを押下するか、エディタウィンドウのローカルメニュ

ーから “Find...”を選ぶか、“Find”ツールバーボタン( )をクリックしてください。“Find”
ダイアログボックスが表示されます（図3.2）。

図 3.2　Find ダイアログボックス

4. “Text to find”フィールドに検索するテキストを入力するか、ドロップダウンリストボックス
から以前検索した文字列を選んでください。ファイルウィンドウでテキストを選んでから
“Find”ダイアログボックスを開くと、選んだテキストが自動的に“Text to find”フィールド
に入ります。

5. 大文字と小文字を識別したいときは“Match case”チェックボックスをチェックしてくださ
い。

6. 正規表現を使ってテキストを検索する場合“Regular expressions”チェックボックスをチェッ
クしてください。詳細は「付録A　正規表現」を参照してください。

7. “Direction”ラジオボタンにより、検索する方向を指定できます。“Forward”を選ぶと、カー
ソル位置からファイルの下の方向に検索します。“Backwards”を選ぶと、カーソル位置か
ら上の方向に検索します。

8. “Start”ボタンをクリックすると検索を始めます。該当する文字列を見つけると“Find”スト

リップ ダイアログボックスを表示します（図3.3）。“Find Next” または次を検索ツール

バーボタン ( )をクリックすると検索を続けます。“Find Previous” または前を検索ツー

ルバーボタン ( )をクリックすると前の文字列に戻ります。 検索を終了するには“Cancel”

をクリックしてください。
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図 3.3　Findストリップダイアログボックス

また、複数のファイル間での検索もできます。

3.6.2 複数のファイル間でのテキスト検索
複数のファイルでテキストを検索するには

1. [Edit->Find in Files...]を選ぶか、エディタウィンドウのローカルメニューから“Find in Files...”
を選ぶか、“Find in Files”ツールバーボタン ( )をクリックしてください。“Find in Files”
ダイアログボックスが表示されます（図3.4）。

図 3.4　Find in Files ダイアログボックス

2. “Find”フィールドに検索するテキストを入力するか、ドロップダウンリストボックスから以
前検索した文字列を選んでください。ファイルウィンドウでテキストを選んでから“Find in
Files”ダイアログボックスを開くと、そのテキストが自動的に“Find”フィールドに入ります。

3. “In files/types”フィールドに、検索するファイルの拡張子を指定してください。複数の拡張
子を指定するときは、コンマで区切ってください（例：*.c, *.h）。

4. “Directory”フィールドに検索するファイルのディレクトリを指定してください。または、
“Browse... ”ボタンをクリックして画面上で検索するファイルを指定してください。

5. 指定したディレクトリとその下のディレクトリすべてを検索したいときは、“Search sub
directories”チェックボックスをチェックしてください。“Directory”フィールドで指定した
ディレクトリだけを検索したいときは、“Search sub directories”チェックボックスがチェッ
クされていないことを確認してください。

6. 大文字と小文字を識別したいときは“Match case”チェックボックスをチェックしてくださ
い。

7. 正規表現を使ってテキストを検索したいときは、“Regular expressions”チェックボックスを
チェックしてください。 詳細は「付録A　正規表現」を参照してください。
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8. “Find”ボタンをクリックすると検索を始めます。 検索結果はアウトプットウィンドウの
“Find in Files”タブに表示されます。アウトプットウィンドウの文字列をダブルクリックす
ると、ファイルの当該文字列にジャンプします。

3.6.3 テキストを置換する
テキストの置換は前節で説明したテキストの検索に似ています。異なる点は、テキスト検索後、他

のテキストに置き換えるところです。

ファイルのテキストを置換するには

1. 内容を置換するウィンドウがアクティブであることを確認してください。
2. 検索を始める位置にカーソルを置いてください。
3. [Edit->Replace...]を選ぶか、CTRL+Hキーを押下するか、エディタウィンドウのローカルメ

ニューから“Replace...”を選んでください。“Replace”ダイアログボックスが表示されます
（図3.5）。

4. “Text to find”フィールドに置換前のテキストを入力してください。または、ドロップダウン
リストボックスから以前に検索した文字列を選んでください。ファイルウィンドウでテキ
ストを選んでから“Replace”ダイアログボックスを開くと、選んだテキストが自動的に“Text
to find”フィールドに入ります。

5. “Text to replace”フィールドに置換後のテキストを入力してください。または、ドロップダ
ウンリストボックスから以前に検索した文字列を選んでください。

図 3.5　Replace ダイアログボックス

6. 大文字と小文字を識別したいときは“Match case”チェックボックスをチェックしてくださ
い。

7. 正規表現を使ってテキストを検索したいときは、“Regular expressions”チェックボックスを
チェックしてください。 詳細は「付録A　正規表現」を参照してください。

8. “Direction”ラジオボタンにより、検索方向を指定できます。“Forward”を選ぶと、カーソル
位置からファイルの下の方向に検索します。“Backwards”を選ぶと、カーソル位置から上
の方向に検索します。
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9. “Start”ボタンをクリックすると、対話式に検索します。つまり、置換する各々のテキストで
いったん停止し、置換するかどうか判断を待ちます。“Replace All”をクリックすると、停
止せずに該当するすべてのテキストを置換します。

10. “Start”をクリックすると、置換するテキストを検索します。テキストを見つけると、
“Replace”確認 ダイアログボックス（図3.6）を表示して置換を確認します。“Ignore”をク
リックするとそのテキストを置換しません。“Replace”をクリックするとそのテキストを置
換します。“Replace All”をクリックすると、該当するすべてのテキストを置換します。
“Cancel”をクリックすると、置換操作を停止します。

図 3.6　Replace確認ダイアログボックス

3.6.4 指定した行にジャンプする
ファイルの指定した行にジャンプするには

1. ファイルがアクティブであることを確認してください。
2. [Edit->Goto Line...]を選ぶか、CTRL+Gキーを押下するか、エディタウィンドウのローカル

メニューから“Goto Line...”を選んでください。“Goto”ダイアログボックスが表示されます
（図3.7）。

3. ダイアログボックスに指定する行番号を入力して、“OK”をクリックしてください。
4. カーソルが指定した行の先頭に移ります。

図 3.7　Gotoダイアログボックス
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3.7 ブックマーク
一度に多くの大容量のファイルを扱うとき、必要な行や領域を見つけるのが難しくなります。ブッ

クマークをあらかじめ特定の行に設定しておくと、後でその行にジャンプできます。例えば、行数の
多い C言語ファイルの各関数の定義位置にブックマークを設定すると便利です。ブックマークは、解
除するまでか、設定したファイルを閉じるまで有効です。

ブックマークを設定するには

1. カーソルを設定する行に置いてください。
2. [Edit->Bookmarks->Toggle Bookmark]を選ぶか、CTRL+F2キーを押下するか、ローカルメニ

ューから[Bookmarks->Toggle Bookmark] を選ぶか、“ブックマークの設定と解除”ツール
バーボタン ( )をクリックしてください。

3. ブックマークが設定されると、その行はハイライト表示されます。

ブックマークを解除するには

1. カーソルを解除する行に置いてください。
2. [Edit->Bookmarks->Toggle Bookmark] を選ぶか、CTRL+F2キーを押下するか、ローカルメニ

ューから[Bookmarks->Toggle Bookmark] を選ぶか、“ブックマークの設定と解除”ツール
バーボタン( ) をクリックしてください。

3. 解除されると行は通常のテキスト表示に戻ります。

次のブックマークにジャンプするには

1. カーソルが検索するファイルの中にあることを確認してください。
2. [Edit->Bookmarks->Next Bookmark]を選ぶか、F2キーを押下するか、ローカルメニューから

[Bookmarks->Next Bookmark] を選ぶか、次のブックマークツールボタン ( )を選んでくだ
さい。

同じファイルの一つ前のブックマークに戻るには

1. カーソルが検索するファイルの中にあることを確認してください。
2. [Edit->Bookmarks->Previous Bookmark]を選ぶか、SHIFT+F2 キーを押下するか、ローカルメ

ニューから [Bookmarks->Previous Bookmark] を選ぶか、前のブックマークツールバーボタ
ン ( )を選んでください。

ファイルの中のすべてのブックマークを解除するには

すべてのブックマークを解除するファイルのウィンドウをアクティブにしてください。
[Edit->Bookmarks->Clear All Bookmarks]を選ぶか、ローカルメニューから [Bookmarks-> Clear
All Bookmarks] を選ぶか、全ブックマーク解除ツールバーボタン( )を選んでください。
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3.8 ファイルを印刷する
ファイルを印刷するには

1. 印刷するファイルのウィンドウをアクティブにしてください。
2. [File->Print...]を選ぶか、“ファイルの印刷”ツールバーボタン ( ) をクリックするか、

CTRL+Pキーを押下してください。

3.9 テキストのレイアウト
この章では、エディタウィンドウの中でテキストのレイアウトを設定する方法を説明します。

3.9.1 ページ設定
HEWエディタからファイルを印刷するとき、印刷ダイアログボックスの設定により、印刷方法が

変わります（例えば、片面印刷、両面印刷など）。また、“Page Setup”ダイアログボックスでは、印
刷するテキストの余白（上下左右）を指定できます。プリンタによっては、A4サイズの端まで印刷
できない場合があるので、この指定が必要です。また、用紙の左端にとじしろを残したい場合などに
も便利です。

ページの余白を設定するには

1. [File->Page Setup...]を選んでください。“Page Setup”ダイアログボックスが表示されます（図
3.8）。

2. “編集”フィールドに必要な余白を入力してください（“Inch”または “mm”ラジオボタンを
選んでください）。

3. “OK”をクリックすると余白が設定されます。

図 3.8　Page Setup ダイアログボックス
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3.9.2 タブを変更する
タブの文字数を変更するには

1. [Tools->Options...]を選んでください。“Tools Options”ダイアログボックスが表示されます。
“Editor”タブを選びます（図3.9）。

2. “Tab size”フィールドに必要なタブの文字数を指定してください。
3. “OK”をクリックするとタブの文字数が設定されます。

図 3.9　Tools Optionsダイアログボックス、Editorタブ

TAB キーを押下すると、通常、タブ文字がファイルに入力されます。しかし、タブ文字のかわり
に空白文字列を入力したほうがよい場合があります。“Tools Options”ダイアログボックスの“Editor”
タブで、タブ文字を空白文字列として指定できます。

タブ文字の代わりに空白文字列を使用するには

1. [Tools->Options...]を選んでください。“Tools Options”ダイアログボックスが表示されます。
“Editor”タブを選んでください（図3.9）。

2. タブ文字の代わりに空白文字列を使用する場合は “Use spaces as tabs” チェックボックスを
チェックしてください。

3. “OK” をクリックすると設定内容が有効になります。
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3.10 自動インデント
標準のエディタでリターンキーを押下すると、カーソルは次の行の左端に移ります。自動インデン

トを設定すると、カーソルは、次の行の、前行の最初の文字の下に移ります。したがって、自分でタ
ブや空白を入力することなく、C/C++言語またはアセンブリ言語のコードをより速く見やすく入力で
きます。
図 3.10に２つの例を示します。 (i) は自動インデントの設定をしなかったときにリターンキーを

押した場合の例を示します。カーソルは次の行の左端に移ります。int z=20の行は、上の２行とそろ
っていません。(ii)は自動インデントを設定してリターンキーを押下した場合の例を示します。カーソ
ルは前行の iの下に移ります。したがって、int z=20行を入力すると、テキストは自動的に前の行と
整列（つまり、自動インデント）します。

void myfunction(void)

{

          int x=5;

          int y=10;

int z=20;

void myfunction(void)

{

          int x=5;

          int y=10;

          int z=20;

(i) 自動インデントなし� (ii) 自動インデントあり�

図 3.10　自動インデント

自動インデントを設定するには

1. [Tools->Options...]を選んでください。“Tools Options”ダイアログボックスが表示されます。
“Editor”タブを選んでください（図3.9）。

2. “Enable auto indentation”チェックボックスをチェックしてください。
3. “OK”をクリックすると、自動インデントが設定されます。
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3.11 ウィンドウを分割する
HEWでは、テキストウィンドウを２つに分割できます。図 3.11に、テキストウィンドウの右上に

ある“閉じる”ボタンのすぐ下にある スプリットバーボタン を示します。

図 3.11　スプリットバー ボタン

ウィンドウを分割するには

スプリットバーボタンをダブルクリックしてウィンドウを二つに分割するか、スプリットバ
ーボタンを押したままマウスを下に移動して分割したい位置でマウスボタンを離してくだ
さい。

スプリットバーの位置を調節するには

スプリットバーボタンを押したままマウスを下に移動して分割したい位置でマウスボタン
を離してください。

ウィンドウの分割を解除するには

スプリットバーボタンをダブルクリックするか、スプリットバーボタンをウィンドウの一番
上か一番下に移動してください。
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3.12 テキストの表示の変更方法
この節では、エディタウィンドウのテキスト表示の変更方法を説明します。

3.12.1 エディタのフォントを変更する
HEWではエディタのフォントを指定できます。ファイルの種類にかかわらず、エディタウィンド

ウはすべて同じフォントを使用します。

エディタのフォントを変えるには

1. [Tools->Options...]を選んでください。“Tools Options”ダイアログボックスが表示されます。
“Format”タブを選んでください（図3.12）。

2. “Font”リストからフォントの種類を選んでください。
3. “Size”リストからフォントの大きさを選んでください。
4. “OK”をクリックするとフォントの種類と大きさが設定されます。

図 3.12　Tools Optionsダイアログボックス、Formatタブ
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3.13 シンタックスを色づけする
コードをより読みやすくするため、指定した文字列（キーワードなど）を異なる色で表示できます。

例えば、Cソースコードのコメントを緑色で、C言語の型（intなど）を青色で表示できます。
色づけの方法は、ファイルグループ単位で指定できます。例えば、Cソースファイル、テキストフ

ァイル、マップファイル、自分のファイルでそれぞれ異なった色づけ方法を定義できます。

シンタックスを色づけするには

1. [Tools->Options...]を選んでください。“Tools Options” ダイアログボックスが表示されます。
“Editor” タブを選んでください。

2. “Enable syntax coloring” チェックボックスをチェックしてください。
3. “OK” をクリックするとシンタックスが色づけされます。

既存の色を変えるには

1. [Tools->Options...]を選んでください。“Tools Options”ダイアログボックスが表示されます。
“Format”タブを選んでください。（図3.12）。

2. “File group”リストから、シンタックスの色付けをするファイルの種類を選んでください。
このとき、“Keyword group”リストの内容が、選んだファイルの種類に応じて変わります。

3. “Keyword group”リストからキーワードグループを選んでください。“Foreground”リストと
“Background”リストには選んだキーワードグループの現在の文字色と背景色を示します。

4. “Foreground”リストと“Background”リストの色を変更してください。“System”を選択する
とコントロールパネルで現在設定してある文字色と背景色になります。

5. “OK”をクリックすると新しい設定になります。

新規のキーワードグループやキーワードを作るには

1. [Tools->Options...]を選んでください。“Tools Options”ダイアログボックスが表示されます。
“Format”タブを選んでください（図3.12）。

2. “File group”リストからシンタックスを色づけするファイルの種類を選んでください。この
とき、“Keyoword group”リストには現在の設定が表示されます。

3. “Add…”をクリックすると新しいキーワードグループを作ることができます。 “Define
Keywords”ダイアログボックスが表示されます（図3.13）。
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図 3.13　Define Keywordsダイアログボックス

4. “Keyword group”フィールドにキーワードグループ名を入力してください。
5. キーワードをが追加するには“Add…”ボタンをクリックしてください。すると“Add

Keyword”ダイアログボックスが表示されます（図3.14）。“Keyword”フィールドにキーワ
ードを指定し“OK”ボタンを押してダイアログを閉じてください。“Define Keywords”ダイ
アログボックスの“Keywords”リストからキーワードを削除するにはキーワードを選択して
“Remove”ボタンをクリックしてください。

図 3.14　Add Keywordダイアログボックス

6. キーワードグループの変更をしたら“Define Keywords”ダイアログボックスで“OK”をクリ
ックしてください。

7. 新規キーワードグループを選択し、“Foreground”リストと“Background”リストの色を変更
してください。“System”を選択するとコントロールパネルで現在設定してある文字色と背
景色になります。

8. シンタックスの色付けを定義したら“Tools Options”ダイアログボックスで“OK”をクリッ
クしてください。
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既存のキーワードグループのキーワードを変更するには

1. [Tools->Options...]を選んでください。“Tools Options”ダイアログボックスが表示されます。
“Format”タブを選んでください（図3.12）。

2. “File group”リストからシンタックスを色づけするファイルの種類を選んでください。この
とき、“Keyoword group”リストには現在の設定が表示されます。

3. 変更するキーワードグループを選んで“Keywords…”ボタンをクリックしてください。
“Define Keywords”ダイアログボックスが表示されます（図3.15）。

図 3.15　Define Keywordsダイアログボックス

4. キーワードをが追加するには“Add…”ボタンをクリックしてください。すると“Add
Keyword”ダイアログボックスが表示されます（図3.14）。“Keyword”フィールドにキーワ
ードを指定し“OK”ボタンを押してダイアログを閉じてください。“Define Keywords”ダイ
アログボックスの“Keywords”リストからキーワードを削除するにはキーワードを選択して
“Remove”ボタンをクリックしてください。

5. キーワードグループの変更をしたら“Define Keywords”ダイアログボックスで“OK”をクリ
ックしてください。

6. シンタックスの色付けを定義したら“Tools Options”ダイアログボックスで“OK”をクリッ
クしてください。

新規ファイルを作成すると、デフォルトではファイルの拡張子がないためシンタックスの色付けは
行いません（エディタが自動的に新規ファイルに付ける名前には拡張子がありません）。新規ファイ
ルにシンタックスの色付けをするには、上記の拡張子をもつ名前でファイルを保存してください。
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シンタックスの色付けを有効／無効にするには

1. [Tools->Options...]を選んでください。“Tools Options”ダイアログボックスが表示されます。
“Editor”タブを選んでください。（図3.9）。

2. “Enable syntax coloring”チェックボックスをチェックすると有効になり、チェックしないと
無効になります。設定後、“OK”ボタンをクリックしてください。

3.14 テンプレート
ソフトウェア開発時、同じテキストを繰り返し入力する場合がよくあります。例えば、関数定義、

ループ、関数の機能のコメント欄などです。HEWでは、現在アクティブなエディタウィンドウに、
定型テキスト（テンプレート）を挿入できます。テンプレート設定後は定型テキストを、手作業で入
力するかわりに、簡単に挿入できるようになります。

3.14.1 テンプレートを設定する
テンプレートを設定するには

1. [Edit->Templates->Define Templates...]を選ぶか、ローカルメニューから [Templates->Define
Templates...]を選ぶか、CTRL+T を押下するか、“Define Template”ツールバーボタン ( )
を選んでください。図3.16に示すダイアログボックスが表示されます。

2. “Template number”ドロップダウンメニューから変更するテンプレートを選んでください
（最大10個のテンプレートが設定できます）。

3. “Template text”テキストエリアにテキストを入力してください。他のエディタウィンドウか
らテキストをコピーしてCTRL+Vキーを押下してこのダイアログボックスに貼りつけるこ
とができます。

4. テンプレートを設定するとき、次のキーワードを使うことができます。

[TIME] テンプレートが挿入される時間
[DATE_DMY] 現在の日/月/年
[DATE_MDY] 現在の月/日/年
[DATE_YMD] 現在の年/月/日
[DATE_TEXT] 現在の年月日をテキスト表示

5. カレット ‘^’ を入力すると、テンプレートが挿入された後のカーソルはこの位置になりま
す。カレット ‘^’ を設定しないと、テンプレートが挿入された後のカーソルはテンプレー
ト最後の文字の後ろになります（通常の貼りつけ操作と同じ）。
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図 3.16　Define Template ダイアログボックス

3.14.2 テンプレートを挿入する
テンプレートを挿入するには

1. “Insert Template”ツールバーボタン( )をクリックするか、 [Edit->Templates->Insert
Template...]を選ぶか、ローカルメニューから [Templates->Insert Templates...]を選んでくださ
い。“Insert Template”ダイアログボックスが表示されます（図3.17）。または、ALTキーと
設定するテンプレートの番号を同時に押下してください（例えば、 ALT+4 キーを押下す
るとテンプレート 4が設定されます）。あるいは、テンプレートツールバーのドロップダ
ウンリストからテンプレートを選び、“Insert Template”ツールバーボタン( )をクリックし
てください。

図 3.17　Insert Templateダイアログボックス

2. “Template”ドロップダウンリストからテンプレートの番号を選んで“OK”ボタンをクリック
してください。
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3.15 かっこの組み合わせ
複雑なソースコードは扱いにくいことがあります。特に、C言語のブロックが互いに深いネスト構

造になっている場合や、if 文で複雑な論理文が表現されている場合などです。HEWでは、そのよう
な場合のために、かっこの種類{ }, ( ) , [ ]ごとにかっこの間のテキストをハイライト表示できます（図
3.18）。

図 3.18　かっこの組み合わせ

かっこの組み合わせを見つけるには

1. かっこの始めをハイライト表示するか、カーソルをかっこの前に置いてください。
2. “Match Brace”ツールバーボタン( )をクリックするか、 CTRL+Bキーを押下するか、

[Edit->Match Braces]を選ぶか、 ローカルメニューから[Match Braces] を選んでください。

ファイル全体の構造をチェックするために、カーソルをファイルの始めに置いて、かっこの組み合
わせの操作を繰り返し行ってください。組み合わせがなくなるまで、かっこの組み合わせごとに次々
とハイライト表示されます。
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4. ビルドの応用

この章ではより高度なビルドの概念を説明します。

4.1 ビルド実行の復習
「2.　ビルドの基本」では、ビルド実行をコンパイラ、アセンブラ、リンケージエディタを用いて

説明しました（図 2.1）。HEWではこれが一般的な実行環境です。しかし、ビルド実行を変更（フェ
ーズの追加や削除など）するためには、ビルドの機能についてさらに知ることが必要です。

4.1.1 ビルドとは?
プロジェクトのビルド実行とは、複数の特定の入力ファイルに複数のツールを適用して期待する出

力を得ることです。つまり、オブジェクトファイルを得るために、Cソースファイルにコンパイラを
適用したりアセンブリ言語のソースファイルにアセンブラを適用したりします。ビルドの各ステップ、
または、各「フェーズ」において、様々な入力ファイルの集まりに各種ツールを適用します。図 4.1
にビルド処理を示します。

フェーズ 1

フェーズ 2

フェーズ 3

フェーズ X

フェーズ 1
入力ファイル

フェーズ 2
入力ファイル

フェーズ 3
入力ファイル

フェーズ X
入力ファイル

フェーズ 1
出力ファイル

フェーズ 2
出力ファイル

フェーズ 3
出力ファイル

フェーズ X
出力ファイル

開始

終了

図 4.1　ビルド実行
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HEWではビルド処理を変更できます。 [Options->Build Phases…]を選んで“Build Phases”ダイアロ
グボックス（図 4.2）を表示します。左には現在のプロジェクトで定義されたフェーズを示します（図
4.2では標準のビルドフェーズを示します）。この章では“Build Phases” ダイアログボックスが提供
する様々な機能について説明します。

図 4.2　Build Phases ダイアログボックス
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4.2 カスタムビルドフェーズを作成する
標準のビルド実行の前後または途中に他のツールを実行する場合、独自のビルドフェーズ（カスタ

ムビルドフェーズ）を作成します。カスタムビルドフェーズを略してカスタムフェーズということが
あります。

[Options->Build Phases…] を選ぶと “Build Phases” ダイアログボックス（図 4.2）が表示されます。
“Add…” ボタンをクリックしてください。新しいビルドフェーズを作成するための“New Build Phase”
ダイアログボックス（図 4.3）が表示されます。
ステップ 1（図 4.3）では、カスタムビルドフェーズを新規に作成するか、システムビルドフェー

ズを追加するかを選択します。システムビルドフェーズは、使用しているツールチェイン（コンパイ
ラ、アセンブラ、リンケージエディタ、ライブラリアンなど）内で定義済みのすぐに使用できるフェ
ーズ、または、ユーティリティフェーズ（例えば、ファイルコピー、ソースコード複雑度解析ツール
など）です。システムフェーズがこれ以上ない場合、“Add an existing system phase”ボタンが非アク
ティブになります（システムビルドフェーズを略してシステムフェーズといいます）。
“Create a new custom phase”ボタンを選んでカスタムビルドフェーズを作成してください。

図 4.3　New Build Phaseダイアログボックス(ステップ 1)
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ステップ 2（図 4.4）では作成するフェーズの種類を選びます。二つの選択肢（“Multiple phase”ま
たは “Single phase”）があります。マルチプルフェーズを実行すると特定のファイルグループに属す
るプロジェクト内の各ファイルにコマンドが適用されます。例えば、“Select input file group”フィー
ルドに“C source file”を選ぶと、プロジェクト内の各ファイルに 1回ずつコマンドが実行されます。
シングルフェーズを選ぶとビルド実行中に一度だけ実行されます。

図 4.4　New Build Phaseダイアログボックス(ステップ 2)
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ステップ 3（図 4.5）では、新しいビルドフェーズについての基礎的な情報を入力します。 “Phase
name” フィールドにフェーズ名を入力します。 “Command” フィールドにプログラムファイルのパス
を入力します（コマンドラインオプションは含めません。オプションは HEWのメニューバーの
“Options”メニューで指定します）。“Default options”フィールドにフェーズのデフォルトのオプシ
ョンを指定します。デフォルトオプションはプロジェクトに新しいファイルを追加するときに付加さ
れるオプションです。“Initial directory” フィールドにはそのプログラムをどのディレクトリから実行
するか（つまり、ツール実行前にどこにカレントディレクトリを設定するか）を入力します。

図 4.5　New Build Phaseダイアログボックス(ステップ 3)
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最後のステップ 4（図 4.6）では、そのフェーズに必要な環境変数を指定します。

図 4.6　New Build Phaseダイアログボックス(ステップ 4)

新しい環境変数を追加するには、“Add…” ボタンをクリックしてください。図 4.7のダイアログ
ボックスが表示されます。新しい環境変数を追加するには“Variable” フィールドに環境変数名を入
力して “Value” フィールドに環境変数の値を入力して “OK”をクリックします。
環境変数を変更するには、ステップ 4のダイアログボックスのリストから変更する環境変数を選ん

で、“Modify…” ボタンをクリックします。 “Variable” フィールドと “Value” フィールドを変更し
て “OK” をクリックすると、リストに変更した変数が追加されます。
環境変数を削除するには、ステップ 4のダイアログボックスのリストから削除する環境変数を選ん

で、“Remove” ボタンをクリックします。

プレースホルダ�
ポップアップ�
メニュー�

図 4.7　Environment Variableダイアログボックス

指定した内容で新しいフェーズを作るには、“Finish” ボタンをクリックしてください。デフォル
トでは“Build Phases” ダイアログボックス（図 4.2）の“Build Order”タブの“Build Phase Order”リス
トの最後に新しいフェーズが追加されます。
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4.3 ビルドのフェーズ順序
図 4.8の標準的ビルドでは、①コンパイラの前、②アセンブラの前、③リンケージエディタの前、

④リンケージエディタの後、の四ヶ所にフェーズを追加できます。ビルドの順序の中で好きな場所に
カスタムフェーズを追加したりシステムフェーズを移動できます。ビルド処理を正しく実行させるた
めには、カスタムフェーズの出力が他のフェーズに入力される場合、フェーズの順序を正しく設定す
ることが必要です。

開始

終了

コンパイル

アセンブリ

リンク

図 4.8　標準的ビルド処理

“Build Phases” ダイアログボックスでビルドフェーズの順序を変更できます。このダイアログボ
ックスにはフェーズの順序に関するタブが二つあります。 “Build Order” タブと“Build File Order”タ
ブです。



4. ビルドの応用

72

4.3.1 ビルドのフェーズ順序
 “Build Order”タブ（図 4.9）は、“Build” ( )または“Build All” ( ) 操作で実行されるフェーズ

の現在の順序を示します。各フェーズの左のチェックボックスのチェックの有無はそのフェーズの有
効/無効を示します。このチェックボックスをチェックするとそのフェーズが実行されます。

図 4.9　Build Phasesダイアログボックス、Build Orderタブ

また、以下の操作ができます。

フェーズを削除するには

1. 削除するフェーズを選んでください。
2. “Remove” ボタンをクリックしてください。

システムフェーズのプロパティを表示するには

1. プロパティを表示するシステムフェーズを選んでください。
2. “Modify...”ボタンをクリックしてください。

フェーズを移動するには

1. 移動するフェーズを選んでください。
2. “Move Up” または “Move Down” ボタンをクリックすると上下に移動します。
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カスタムフェーズを変更するには

1. 変更するカスタムフェーズを選んでください。
2. “Modify…” ボタンをクリックしてください。“Modify MyPhase” ダイアログボックスの

“Command” タブが表示されます（図4.10）。
3. 必要に応じてフィールドの内容を変更してください。
4. 入力ファイルがなくてもフェーズの実行を中断したくない場合、“Don’t check for input file(s)

existence before executing” チェックボックスをチェックしてください。

図 4.10　Modify MyPhaseダイアログボックス Commandタブ

5. “Environment”タブ（図4.11）を選んでフェーズの環境設定を行ってください。
6. 環境変数の追加は “Add…”ボタン、変更は“Modify…” 削除は“Remove”ボタンを使用し

てください。操作は前節と同じです。
7. 変更後 “OK”をクリックしてください。
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図 4.11　Modify MyPhaseダイアログボックス Environment タブ

4.3.2 ビルドファイルのフェーズ順序
ワークスペースウィンドウから Cソースファイルを選んで[Build->Build File]を選ぶか、 を押す

と、ファイルがコンパイルされます。同じように、プロジェクトウィンドウからアセンブリ言語ソー
スファイルを選んで[Build->Build File]を実行すると、ファイルがアセンブルされます。ファイルグル
ープと実行するフェーズの関係は“Build Phases”ダイアログボックスの “Build File Order”タブ（図
4.12）で管理されています。

図 4.12　Build Phasesダイアログボックス Build File Orderタブ
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リストには、“File group”リストボックスのファイルグループに対してビルドファイル操作を選択
したとき実行されるすべての現在のフェーズを表示します。図 4.12では“C source file”ファイルグル
ープが選ばれており、“Compiler”フェーズと“MyPhase”フェーズが関連付けされています。
“Build Order”タブのリストに新しいエントリを追加すると、自動的に“Build File Order”タブの

“Phase order”リストに新しいエントリが追加されます。例えば、“C source file”を入力とするフェー
ズを追加します。このフェーズは“Build File”操作を“C source file”に適用する時に実行されるフェー
ズのリストに自動的に追加されます。[Build->Build File…]を選んだときに実行したくないフェーズが
ある場合、“Phase order”リストのフェーズ名の左のチェックボックスのチェックを外してください。

4.4 カスタムビルドフェーズのオプション設定
カスタムフェーズを定義後、フェーズ実行時に使用するコマンドラインオプションを指定します。

定義されたフェーズにはそれぞれ [Options]メニューにメニューオプションがあります。指定するフ
ェーズのオプションを選んでください。起動するダイアログボックスは、選んだカスタムフェーズが
シングルフェーズかマルチプルフェーズかによって異なります（図 4.4　“Single phase”/“Multiple
phase”ラジオボタン指定）。

Options Output Files Dependent Files

OK Cancel

Options Output Files Dependent Files

OK Cancel

MyFiles

File1.x

File1.x

File1.x

File1.x

File1.x

i. マルチプルフェーズ（例：コンパイラ、アセンブラ等）

ii. シングルフェーズ（例：リンケージエディタ、バッチファイル等）

図 4.13　カスタムフェーズのオプションダイアログボックス
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マルチプルフェーズの場合、図 4.13.iに示すダイアログボックスが表示されます。ここでは、カス
タムマルチプルフェーズに入力されるファイルのオプションを設定できます。左側にはファイルリス
トがあります。オプションを設定するファイルを選んでください。右側には三つのオプションタブが
あります。選んだファイルに適用するオプションを設定してください。
シングルフェーズの場合、図 4.13.iiに示すダイアログボックスが表示されます。このフェーズは

プロジェクトのファイルと関係ないので、ダイアログボックスの左側にファイルの選択がありません。
三つのオプションタブでオプションを設定してください。
シングルフェーズでもマルチプルフェーズでも同じオプションのタブが表示されます。これらのタ

ブについて詳細を以下に説明します。

4.4.1 Optionsタブ
“Options”タブ（図 4.14）ではフェーズに渡されるコマンドラインオプションを定義できます。

“Command”フィールドではフェーズを定義したときに入力したコマンドを表示します（図 4.5）。
“Options”フィールドにはコマンドに渡すコマンドライン引数を入力してください。プレースホルダ
を挿入する場合は、対応するプレースホルダを“Placeholder”ドロップダウンリストボックスから選び、
“Insert”ボタンをクリックしてください。プレースホルダの詳細については、「付録 B　プレースホ
ルダ」を参照してください。

プレースホルダ�
挿入ボタン�

図 4.14　カスタムフェーズのオプション、Optionsタブ
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4.4.2 Output Filesタブ
“Output Files”タブ（図 4.15）ではフェーズで作成される出力ファイルを指定します。HEWでは、

ファイルがこのフェーズを通過する前に、出力ファイルの日付が入力ファイルの日付より古いことを
チェックしています。出力ファイル作成後入力ファイルが変更された場合、入力ファイルに対してこ
のフェーズが実行されます。出力ファイルの日付が入力ファイルの日付より新しい場合(出力ファイ
ルが最新の場合)、入力ファイルに対してこのフェーズは実行されません。

【注】 出力ファイルを指定しない場合フェーズは常に実行されます。

図 4.15　カスタムフェーズのオプション、Output Filesタブ
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出力ファイルを追加するには

1. “Add…”をクリックしてください。“Add Output File” ダイアログボックスが表示されます
（図4.16）。

2. ファイル名を入力するか、“Browse…”ボタンで選んでください。
3. “OK”をクリックすると、リストに出力ファイルを追加します。

プレースホルダポップアップメニュー�

図 4.16　Add Output Fileダイアログボックス

出力ファイルを変更するには

1. 変更する出力ファイルを選んでください。
2. “Modify…”をクリックすると“Modify Output File”ダイアログボックスが表示されます（タ

イトル以外は図4.16と同様）。
3. フィールドを変更して “OK” ボタンをクリックしてください。変更した項目がリストに追

加されます。

出力ファイルを削除するには

1. 削除する出力ファイルを選んでください。
2. “Remove” ボタンをクリックしてください。
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4.4.3 Dependent Filesタブ
“Dependent Files”タブ（図 4.17）ではフェーズに必要な依存ファイルを指定します。HEWでは、

各ファイルがこのフェーズを通過する前に、依存ファイルの日付が入力ファイルの日付より新しいか
否かをチェックしています。チェック後、依存ファイルの日付が新しい場合（つまり、入力ファイル
作成後に依存ファイルが変更された場合）このフェーズでファイルが実行されます。依存ファイルの
日付が入力ファイルの日付より古い場合、このフェーズは実行されません。

図 4.17　カスタムフェーズのオプション Dependent Filesタブ

依存ファイルを追加するには

1. “Add…”ボタンをクリックしてください。“Add Dependent File”ダイアログボックスが表示
されます（図4.18）。

2. ファイル名を入力するか、“Browse…”ボタンで選んでください。
3. “OK”をクリックすると、リストに出力ファイルを追加します。

プレースホルダポップアップメニュー�

図 4.18　Add Dependent Fileダイアログボックス
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依存ファイルを変更するには

1. 変更する依存ファイルを選んでください。
2. “Modify…”をクリックすると “Modify Dependent File” ダイアログボックスが表示されます

（タイトル以外は図4.18と同じ）。
3. フィールドを変更して “OK” ボタンをクリックすると変更した項目がリストに追加され

ます。

依存ファイルを削除するには

1. 削除するファイルを選んでください。
2. “Remove” ボタンをクリックしてください。

4.5 ファイルのマッピング
デフォルトでは、フェーズに入力されるファイルはプロジェクトから取得したのものだけです。つ

まり、“New Build Phase”ダイアログボックス（図 4.4）の“Select input file group” ドロップダウンリ
ストに指定した種類のプロジェクトファイルだけです。もし前のフェーズから出力されたファイル
（中間ファイル）をフェーズで使いたい場合、“Build Phases” ダイアログボックス（図 4.19）の“File
Mappings”タブで定義してください。

図 4.19　Build Phasesダイアログボックス File Mappingsタブ

ファイルマッピングでは、あるフェーズ（出力元フェーズという）で作成したある種類の出力ファ
イル（中間ファイル）を、他のフェーズ（出力先フェーズという）に渡すように指定します。プロジ
ェクトファイルに加えて中間ファイルも渡されます。
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ファイルのマッピングを追加するには

1. “Add…”ボタンをクリックしてください。“Define File Mapping”ダイアログボックスが表示
されます（図4.20）。

2. “File group”ドロップダウンリストボックスから、フェーズ間で渡したいファイルグループ
を選んでください。

3. “Source phase”ドロップダウンリストボックスから出力元フェーズ（ファイルを作成するフ
ェーズ）を選んでください。

4. “Destination phase”ドロップダウンリストボックスから出力先フェーズ（ファイルを渡す先
のフェーズ）を選んでください。

5. “OK”をクリックすると新しいマッピングが追加されます。

図 4.20　Define File Mappingダイアログボックス

ファイルマッピングを変更するには

1. 変更するマッピングを選んでください。
2. “Modify…”ボタンをクリックしてください。“Define File Mapping”ダイアログボックスが表

示されます（図4.20）。
3. 必要に応じてオプションを変更してください。
4. “OK”をクリックすると変更が有効になります。
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4.6 ビルドを管理する
デフォルトでは、HEWはビルドのすべてのフェーズを実行し、途中で致命的なエラーが起こった

ときだけ中止します。これは “Tools Options”ダイアログボックスの“Build”タブ（図 4.21）で変更す
ることができます。

図 4.21　Define File Mappingダイアログボックス Buildタブ

[Tools->Options...]を選んでダイアログボックスを表示してください。ある一定の回数を超えるエラ
ーが起きた後にビルドを中止したいとき、“Stop build if the no. of errors exceed”チェックボックスをチ
ェックして右のフィールドにエラー数を入力してください。ある一定の数を超えるウォーニングが表
示されたときにビルドを中止したいとき、“Stop build if the no. of warnings exceed”チェックボックス
をチェックして右のフィールドにウォーニング数を入力してください。

【注】 上記設定にかかわらず、致命的エラーが発生した場合、ビルドは停止します。

“Build”タブでは、エラー数やウォーニング数の制限のほかに、コマンドライン、環境、初期ディ
レクトリの表示の有無を設定することができます。表示するには、それぞれのチェックボックスをチ
ェックしてください。
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4.7 ビルドの出力のログを取る
ファイルに各ビルドの結果を保存したいときには、[Tools-> Customize...] を選んで“Tools

Customize”ダイアログボックスを表示して“Log”タブを選んでください（図 4.22）。“Generate log file”
チェックボックスをチェックして、“Path”フィールドにログファイルのフルパスを入力するか、
“Browse…”ボタンをクリックしてパスを選択してください。

図 4.22　Tools Customizeダイアログボックス、Logタブ
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4.8 ツールチェインのバージョンを変更する
同じツールチェインの２つ以上のバージョンが HEWに登録されているとき図 4.23に示す

“Toolchain Upgrade”ダイアログボックスでバージョンを選択できます。このダイアログボックスを表
示されるには[Tools->Upgrade…]を選択してください。このダイアログボックスの“Toolchain version”
ドロップダウンリストからバージョンを選択し、“OK”ボタンをクリックしてください。

図 4.23　Toolchain Upgradeダイアログボックス

ツールチェインを構成するツールの情報を表示するには“Toolchain Upgrade”ダイアログボックス
の“Toolchain component”リストからツールを一つ選択し、“Information”ボタンをクリックしてくだ
さい。ツール情報ダイアログボックス（図 4.24）にそのツールの情報が表示されます。このダイアロ
グボックスを閉じるには“Close”ボタンをクリックしてください。

図 4.24　ツール情報 ダイアログボックス
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4.9 日立デバッギングインタフェース (HDI)を使う
HEWは日立デバッギングインタフェース (HDI)バージョン 4.0以上と連動します。もし他のデバ

ッガを使いたい場合は、“Tools”メニューに加えなければいけません。詳細は「6.　環境のカスタマ
イズ」を参照してください。
“Tools Customize”ダイアログボックス（図 4.25）の “Debugger”タブに HDI に関連する情報を設定

します。[Tools-> Customize…]を選んでダイアログボックスを表示させ、“Debugger”タブを選んでく
ださい。

図 4.25　Tools Customizeダイアログボックス Debuggerタブ

指定する項目は 3つあります。1つは HDI の実行ファイルの場所です。HDI はバージョン 4.0以降
のものを指定してください。そうでない場合、動作を保証できません。2つめはセッションファイル
の情報です。HDIに切り替わったとき、どのセッションをロードするかを HDI に伝えます。もう 1
つはダウンロードモジュールの場所です。これはビルド後にダウンロードモジュールが変更された場
合 HEWが自動的に HDIに切り替わるために必要です。
指定したセッションファイルで HDI を起動するには、次に示すツールバーボタンをクリックして

ください。

ビルド後、ダウンロードモジュールが更新された場合、HEWから HDIに戻り、すぐデバッグでき
るようになります。HDIを使用しているときにソースウィンドウのどれかをダブルクリックすると、
HEWに戻りダブルクリックした行のソースファイルを開いた状態になります。
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4.10 メイクファイルを生成する
HEWでは、メイクファイルを生成することができます。メイクファイルを使用すると、完全に HEW

をインストールしていなくても、現在のプロジェクトをビルドすることができます。HEWをインス
トールしていない相手にプロジェクトを送ったり、メイクファイルを含むビルド全体をバージョン管
理する場合に便利です。

カレントプロジェクトのメイクファイルを生成するには

1. メイクファイルを生成するプロジェクトが現在のプロジェクトであることを確認してくだ
さい。

2. プロジェクトをビルドするビルドコンフィグレーションが現在のコンフィグレーションで
あることを確認してください。

3. [Build->Generate Makefile]を選んでください。

HEWは現在のプロジェクトのディレクトリ内にサブディレクトリ “make” を作成してそこにメイ
クファイルを生成します。メイクファイルの名前は、現在のコンフィグレーションに拡張子.makを付
けたものです(例：debug.mak)。HEWにより生成されたメイクファイルは、HEWをインストールした
ディレクトリにある実行ファイル HMAKE.EXEで実行できます。ただし、ユーザが変更したメイク
ファイルは実行できません。

メイクファイルを実行するには

1. コマンドウィンドウを開き、メイクファイルが生成された“make”ディレクトリに移行して
ください。

2. HMAKEを実行してください。コマンドラインは HMAKE.EXE <メイクファイル名>です。

【注】 生成したメイクファイルが移動可能か否かは、プロジェクト自体が移動可能か否かに完全に
依存します。たとえば、出力ディレクトリやインクルードファイルディレクトリへのフルパ
スを含むコンパイラオプションがあると、異なるインストール環境下の別のユーザがビルド
した場合、失敗する可能性が高いでしょう。一般的に、できるだけプレースホルダを使用し
て、フルパス、または特定のパスの使用はなるべく避けてください。
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5. ツール管理

“Tools Administration”ダイアログボックスで HEWで使うツールを管理します(図 5.1)。このダイア
ログボックスは[Tools-> Administration…]で開くことができます。ワークスペースを閉じているときだ
け開くことができます。

図 5.1　Tools Administrationダイアログボックス

三種類の標準ツールがあります。
• ツールチェイン – 一連のビルドフェーズ（例:コンパイラ、アセンブラ、リンケージエディ
タ、ライブラリアン）。ビルド機能を実現。

• システムツール– “Tools”メニューから選ぶことのできるアプリケーション（.EXE）。ツール
チェインをサポートする追加のアプリケーションとして提供されることが多い（例: Hitachi
Debugging Interface （HDI）または対話式グラフィカルライブラリアン）。

• ユーティリティーフェーズ – 特定のビルド機能をサポートする、あらかじめ用意されたビ
ルドフェーズ（例: ソースコードの複雑度解析、ソースコードの行カウントなど）。特定の
ツールチェインに依存しない追加のビルド機能。
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5.1 ツールの位置
HEWでは、新しいツールがインストールされるたびに HEWとの連動に必要なツールの位置を自

動的に保持します。インストール後、HEWはそのツールに関する情報（位置を含む）を保持します。
これを登録と呼びます。初期登録は自動で行いますが、開発の途中で、プロジェクトのツールをより
効率良く利用するためにユーザ自身でツールを登録することが必要になることがあります。この章で
は登録について説明します。

5.2 HEW登録ファイル(* .HRF)
HEWと互換性のあるツール（ツールチェイン、システムツール、またはユーティリティフェーズ）

をインストールすると、拡張子.HRF（図 5.2.i）のファイルもインストールされます。この拡張子は
“HEW Registration File”の略であり、.HRFファイルには HEWへの登録に必要な情報が記述されてい
ます。登録するには、そのツールの.HRFファイルを“Tools Administration”ダイアログボックスにロ
ードします（図 5.2.ii）。

C:\

MyTool

MyTOOL.HRF

bin

etc

help

C:\

MyTool

MyTOOL.HRF

bin

etc

HEW

help

i.インストール ii.登録

図 5.2　HRFファイルの位置と登録

HEWでツールを使うには、まず登録が必要です。“Tools Administration”ダイアログボックス（図
5.1）は現在登録されているツールを表示します。このダイアログボックスを開くには、ワークスペ
ースがすべて閉じていることを確認して[Tools-> Administration…]を選んでください。
ツール情報は各マシンにローカルに保存されます。こうするのは、HEWでは、ワークスペースや

プロジェクトをツールのパスに依存しないようにするためです。つまり、プロジェクトはツールチェ
インの保存場所を含めずにそのツールチェインを参照できます。この保存場所情報は各マシンごとに
登録ツール情報から抽出されます。
図 5.3にこの原則を図式的に示します。三台のマシンが日立のコンパイラを使う共有のプロジェク

トを参照しています。コンパイラが各マシンの異なる場所に保存されていても同一プロジェクトを共
有できます。
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ローカル

ツール情報

C:\tools\hitachi\compiler d:\hew\hitachi\compiler f:\hitachi\compiler

ローカル

ツール情報

ローカル

ツール情報

共有のワークスペースとプロジェクト

ネットワーク

図 5.3　ツール情報のローカル保存

5.3 ツールを登録する
HEWは起動後にインストールしたすべてのツールを自動的に登録します。しかし、ときには、ユ

ーザがツールを登録する必要があります。

5.3.1 ドライブ内ツール検索
ドライブを検索して HEWに互換性のあるツールを見つけることは、HEWのツールインストール

情報が削除されたり破壊されたときなどに有益です。なぜなら、ツール情報を再びすぐに作成するこ
とができるからです。

ツールを検索するには

1. “Search Disk…”ボタンをクリックすると“Search Disk for Components”ダイアログボックスが
表示されます（図5.4）。
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図 5.4　Search Disk for Componentsダイアログボックス

2. “Select the directory in which to begin the search”フィールドに、検索するディレクトリを入力
してください。または、“Browse…” ボタンをクリックしてディレクトリを選んでくださ
い。

3. “Include subfolders”チェックボックスをチェックすると、指定したディレクトリとその下の
ディレクトリをすべて検索します。

4. “Start” ボタンをクリックすると検索を始めます。検索中、“Start”ボタンは “Stop”ボタン
に変わります。検索を途中で止めるときには “Stop” ボタンをクリックしてください。

5. “Located components” リストに検索結果を表示します。個別にツールを登録するにはそのツ
ールを選んで “Register”をクリックしてください。すべてのツールを登録するには
“Register All” をクリックしてください。

6. “Close”をクリックするとダイアログボックスを終了します。

5.3.2 ツールを一つ登録する
HEWでは、ツールを検索しなくても、ツールを一つずつ登録できます。HEW 登録ファイル(*.HRF)

はツールがインストールされたルートディレクトリにあります。

ツールを登録するには

1. “Register…”ボタンをクリックすると 標準のファイルを開くダイアログボックスが開きま
す。フィルタが “HEW Registration Files (*.hrf)”に設定されています。

2. 登録するファイルの.HRF ファイルをアクセスして選び、 “Select”をクリックしてくださ
い。
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3. 選んだツールに関する情報を示すダイアログボックスが表示されます。ツールを登録する
には “Register” をクリックしてください。登録しない場合は“Close” ボタンをクリックし
てください。

5.4 ツールの登録を取り消す
登録したツールによって、HEWは影響を受けます。例えば、新しいプロジェクト作成時に、登録

された互換性のあるすべてのシステムツールが、ツールメニューに追加されます。ときにはユーザに
とっては、これによって効率が下がったり使いにくいかもしれません。そのようなときは、登録を取
り消すことができます。“Tools Administration”ダイアログボックスでツールを選び “Unregister”ボタ
ンをクリックしてください。確認のダイアログボックスが表示されます。 登録を取り消す場合は
“Yes” をクリックしてください。

【注】 ツールの登録を取り消しても、ハードディスクからツールがなくなることはありません。単
に、HEWに格納されているそのツールに関する情報を削除するだけです（HEWから切断さ
れます）。この動作はいつでも元に戻すことができ、ツールを自分で再登録できます（前節
「ツールを登録する」参照）。ハードディスクからツールを削除（アンインストール）した
いときはこの章後半の「ツールのアンインストール」を参照してください。

5.5 ツールのプロパティの参照と編集
ツールに関する情報を参照するには、ツールを “Registered components”リストから選んで

“Properties” ボタンをクリックしてください。“General” タブを選んだ状態で（図 5.5）プロパティの
ダイアログボックスが表示されます。このタブでは、名前、バージョン、位置を示します。このタブ
は編集できません。

図 5.5　プロパティのダイアログボックス、Generalタブ
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ツールについての情報を参照するには “Information”タブをクリックしてください（図 5.6）。例え
ば、著作権、履歴、バグの修正、ユーザへのお知らせなどが表示されます。

図 5.6　プロパティのダイアログボックス、Informationタブ

ツールの環境設定を参照、編集するには “Environment” タブを選んでください（図 5.7）。

図 5.7　プロパティのダイアログボックス、Environmentタブ

新しい環境変数を追加するには、“Add…”ボタンをクリックしてください。図 5.8に示すダイアロ
グボックスが表示されます。“Variable”フィールドに変数名を入力して“Value”フィールドに変数の
値を入力して “OK”をクリックしてください。環境変数の値を柔軟に指定できるようにするため、プ
レースホルダポップアップメニューがあります。プレースホルダの詳細は「付録 B　プレースホルダ」
を参照してください。
環境変数を変更するには、“Environment”タブで変更する環境変数を選び“Modify…”ボタンをクリ

ックしてください。“Variable” フィールドと “Value”フィールドを必要に応じて変更して “OK”をク
リックすると、変更した環境変数が“Environment”タブに加わります。環境変数を削除するには、そ
の環境変数を選び “Remove” ボタンをクリックしてください。
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プレースホルダ�
ポップアップ�
メニュー�

図 5.8　Define Environment Variableダイアログボックス

5.6 ツールのアンインストール
HEWにはインストールされているツールをハードディスクから削除するための専用のアプリケー

ションがあります。 ツールのアンインストーラを起動するにはWindows®の“スタート”メニュー
を開き、“プログラム”を選択し、“Hitachi Embedded Workshop”を選択し、TUninst.EXEのショート
カットを選びます。すると、図 5.9のダイアログボックスが表示されます。

図 5.9　HEWツールのアンインストール

ツールをアンインストールするには

1. 一番上のフィールドに検索するディレクトリを入力するか、“Browse…” ボタンをクリッ
クしてディレクトリを指定してください。

2. “Include subfolders” チェックボックスをチェックすると、指定したディレクトリの下のディ
レクトリをすべて検索します。
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3. “Start” ボタンをクリックすると検索を始めます。検索中、 “Start”ボタンは “Stop”ボタンに
変わります。“Stop”ボタンをクリックすると、検索の途中でも検索を中止します。

4. 検索結果は“Located components”リストに表示されます。ツールを選んで“Uninstall”をク
リックするとツールをアンインストールします。

5. “Exit”をクリックしてダイアログボックスを終了してください。

現在 HEWで登録されていないツールのみアンインストールできます。登録されているツールをア
ンインストールしようとすると、図 5.10に示すダイアログボックスが表示されます。このようなと
きは、[Tools->Administration…]で HEW の“Tools Administration”ダイアログボックスに戻り、ツール
の登録を取り消してから、“TUninst.EXE”を再起動してください。

図 5.10　アンインストール不可のダイアログボックス

HEWから登録をはずしたツールを選んで“Unregister” ボタンをクリックすると、図 5.11に示す
確認のダイアログボックスが表示されます。このダイアログボックスには削除されるすべてのファイ
ルやフォルダが表示されます。これらのファイルやフォルダを削除してよいことを確認して“Yes”
ボタンをクリックしてください。アンインストールを中止するときは、“No” または“Cancel”ボタ
ンをクリックしてください。

図 5.11　Confirmationダイアログボックス
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5.7 テクニカルサポートについて
“Tools Administration”ダイアログボックスでは、“隠れている”システムツールに関する情報を表

示できます。これらのツールは HEWの一部であり、手動で登録または登録取り消しすることができ
ません。“Tools Administration”ダイアログボックスの“Show all components”チェックボックスをチェ
ックすると、隠れていたツールフォルダを表示します（図 5.12）。

図 5.12　すべてのツールの表示

テクニカルサポートを受ける際、ツールに関する詳細をお尋ねすることがあります。そのときには、
そのツールのフォルダを開き、ツールを選び、 “Properties”ボタンをクリックしてください。ここで
表示されるダイアログボックスはこの章の前半で説明したものと同じように動作します。ただし、
“Environment”タブはありません。
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6. 環境のカスタマイズ

6.1 ツールバーのカスタマイズ
HEWでは 2つのツールバーを標準で提供します。また、“Tools Customize”ダイアログボックス（図

6.1）を使用して、新しいツールバーを作成することができます。

図 6.1　Tools Customizeダイアログボックス、Toolbarsタブ

新しいツールバーを作るには

1. [Tools->Customize…]を選んでください。図6.1に示すダイアログボックスが表示されます。
2. “New...”ボタンをクリックしてください。図6.2に示すダイアログボックスが表示されます。
3. “Toolbar name”フィールドに新しいツールバー名を入力してください。
4. “OK”をクリックすると新しいツールバーが作成されます。
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図 6.2　New Toolbarダイアログボックス

作成した新しいツールバーにはボタンがなく、位置を固定せずに表示されます。

ツールバーにボタンを追加するには

1. [Tools->Customize…]を選んでください。図6.1に示すダイアログボックスが表示されます。
“Commands”タブを選んでください。（図6.3参照）。

2. “Categories”リストからボタンのカテゴリーを選び、使用できるボタンを参照してください。
“Buttons”エリアからボタンを選ぶとそのボタンの機能が表示されます。

3. ボタンをクリックしてダイアログボックスからツールバーにドラッグしてください。

図 6.3　Tools Customizeダイアログボックス、Commandsタブ
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ツールバーからボタンを削除するには

1. [Tools->Customize…]を選んでください。図6.1に示すダイアログボックスが表示されます。
“Commands”タブ（図6.3参照）を選んでください。

2. ボタンをツールバーから“Buttons”エリアへドラッグしてください。

ユーザ定義のツールバーを削除するには

1. [Tools->Customize…]を選んでください。図6.1に示すダイアログボックスが表示されます。
2. “Toolbars”リストからユーザ定義のツールバーを選ぶと図6.1の“Reset”ボタンが“Delete”

ボタンに変化します。“Delete” ボタンをクリックしてください。

標準のツールバーを初期状態に戻すには

1. [Tools->Customize…]を選んでください。図6.1に示すダイアログボックスが表示されます。
2. “Toolbars”リストから標準のツールバーを選んで“Reset”ボタンをクリックしてください。

ツールバーのツールチップを表示/非表示するには

1. [Tools->Customize…]を選んでください。図6.1に示すダイアログボックスが表示されます。
2. “Show Tooltips”チェックボックスをチェックすると表示、チェックしないと非表示になりま

す。

ユーザが作成したツールバーのツールバー名を変えるには

1. [Tools->Customize…]を選んでください。図6.1に示すダイアログボックスが表示されます。
2. “Toolbars”リストでユーザが作成したツールバーで名前を変更したいものを選んでくださ

い。
3. “Toolbar name” フィールドでツールバー名を変更してください。
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6.2 Toolsメニューのカスタマイズ
ツールメニューをカスタマイズして新しいメニューオプションを含めることができます。

新しいメニューオプションを追加するには

1. [Tools->Customize…]を選んでください。図6.1に示すダイアログボックスが表示されます。
“Menu”タブを選んでください（図6.4）。

図 6.4　Tools Customizeダイアログボックス、Menuタブ

2. “Add…” ボタンをクリックしてください。図6.5に示すダイアログボックスが表示されま
す。既存のシステムツールをメニューに追加するには、“Select from existing tools”ラジオボ
タンを選び、ドロップダウンリストからシステムツールを選び、“OK”をクリックしてく
ださい。また、新しいツールを追加するには、以下の手順に従ってください。

3. “Name” フィールドにツール名を入力してください。
4. “Command”フィールドにコマンドを入力してください。ただし、コマンドに渡す引数は入

力しないでください。
5. “Arguments”フィールドにコマンドに渡す引数を入力してください。
6. “Initial directory”フィールドにツールを実行する初期ディレクトリを入力してください。
7. “OK”をクリックするとメニューオプションが“Tools”メニューに追加されます。
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図 6.5　Add Toolダイアログボックス

デフォルトでは、新しいメニューオプションはリストの最後に追加されます（ツールメニューの一
番下）。“Tools”メニューのメニューオプションの順序は変更できます。

メニューオプションの順序を変えるには

1. [Tools->Customize…]を選んでください。図6.1に示すダイアログボックスが表示されます。
“Menu” タブ（図6.4参照）を選んでください。

2. 順序を変えるメニューオプションを選んで、上に移動する場合は “Move up”ボタンをクリ
ックして、下に移動する場合は“Move down”ボタンをクリックしてください。

3. “OK”をクリックすると順序が変わります。

メニューオプションを変更するには

1. [Tools->Customize…]を選んでください。図6.1に示すダイアログボックスが表示されます。
“Menu”タブ（図6.4参照）を選んでください。

2. 変更するメニューオプションを選んで“Modify…”ボタンをクリックしてください。
3. “Modify Tool”ダイアログボックス（図6.6）を変更後、“OK”をクリックしてください。
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図 6.6　Modify Toolダイアログボックス

メニューオプションを削除するには

1. [Tools->Customize…]を選んでください。図6.1に示すダイアログボックスが表示されます。
“Menu”タブ（図6.4参照）を選んでください。

2. 削除するメニューオプションを選んで“Remove”ボタンをクリックしてください。

6.3 ヘルプシステムを構築する
HEWではエディタウィンドウでコンテキスト依存ヘルプを提供します。エディタウィンドウでテ

キストを選び F1キーを押下すると、選んだテキストに関するヘルプを検索します。検索するヘルプ
ファイルは“Tools Customize”ダイアログボックスの“Help”タブに表示されます。

新しいヘルプファイルを追加するには

1. [Tools->Customize…]を選んでください。図6.1に示すダイアログボックスが表示されます。
“Help”タブ（図6.7参照）を選んでください。
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図 6.7　Tools Customizeダイアログボックス、Helpタブ

2. “Add…” ボタンをクリックしてください。 “Add Help File”ダイアログボックス（図6.8）が
表示されます。

3. “Title”フィールドにヘルプファイルの説明を入力してください。
4. “Path”フィールドにヘルプファイルへのフルパスを入力してください（または“Browse…”

ボタンをクリックしてファイルを選んでください）。
5. “OK”をクリックすると新しいヘルプファイルが定義されます。

図 6.8　Add Help Fileダイアログボックス

デフォルトのヘルプファイルを設定する場合は“Default help file”ドロップダウンリストからヘルプ
ファイルを選んでください。F1キーを押下したときに任意のヘルプファイルを参照するには“(None)”
を選んでください。
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6.4 ワークスペースオプションを指定する
HEWでは“Tools Options” ダイアログボックス（図 6.9）でワークスペースの様々なオプションを

設定することができます。 [Tools->Options...]の“Workspace”タブを選んでください。

図 6.9　Tools Optionsダイアログボックス、Workspaceタブ

次にこのタブで制御できるオプションを説明します。

6.4.1 Open last workspace at start-upチェックボックス
このチェックボックスをチェックすると、HEW起動時に、最後に開いたワークスペースを自動的

に開きます。

6.4.2 Restore the files on opening workspaceチェックボックス
HEWは、ワークスペースを閉じるとき、開いていたファイルを記憶します。そして、再びワーク

スペースを開くとき、HEWは同じファイルを復帰させる（つまり開く）ことができます。これによ
り、中断したセッションを引き続き行うことができます。このチェックボックスをチェックすると、
ワークスペースを開いたときに前回開いていたファイルを開きます。
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6.4.3 Display workspace information dialog on opening workspaceチェ
ックボックス

多くのワークスペースを使うと、各ワークスペースの内容を正確に覚えておくのは難しくなります。
この問題を解決するために、HEWでは、各ワークスペースの説明を入力しておくことができ、この
チェックボックスをチェックすると、それをワークスペースを開くときに表示することができます。

ワークスペースの説明を入力するには

1. “Workspace”ウィンドウの“Projects” タブからワークスペースのアイコンを選んでくださ
い。

2. マウスの右ボタンをクリックしてポップアップメニューを表示させ、“Properties”オプショ
ンを選んでください。図6.10に示すダイアログボックスが表示されます。

3. “Information”フィールドに説明を入力してください。
4. ワークスペースを開いたときにワークスペースプロパティダイアログボックスを開かせた

いときは“Show workspace information on workspace open”チェックボックスをチェックして
ください。このチェックボックスは“Tools Options”ダイアログボックスの“Workspace”タ
ブの“Display workspace information dialog on opening workspace”チェックボックスと同じ役
割を持っています。

図 6.10　ワークスペースプロパティダイアログボックス

HEWでは、ワークスペースを開くときにこの説明を表示することができます。したがって、その
ワークスペースが目的のワークスペースかどうかを判断することができます。この説明を表示するに
は、“Display workspace information dialog on opening workspace”チェックボックスをチェックしてくだ
さい。
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6.4.4 Save workspace before executing any phasesチェックボックス
このチェックボックスをチェックすると、ビルドフェーズを実行（“Build”、“Build All”、“Build

File”操作）する前や、バージョン管理コマンドを実行する前に、現在のワークスペースを保存します。

6.4.5 Prompt before saving workspaceチェックボックス
上記の“Save workspace before executing any phases”チェックボックスに加えてこのチェックボック

スをチェックすると、保存する前に確認の画面が表示されます。

6.4.6 Default directory for new workspacesエディットボックス
新しいワークスペースを作成すると “New Workspace” ダイアログボックスが起動します。このダ

イアログボックスにはその新しいワークスペースが作成されるディレクトリを入力するフィールド
があります。デフォルトでは、ルートディレクトリが入力してあります。しかし、他のディレクトリ
（例：“C:\Workspaces”）にデフォルトを変更したい場合、このフィールドにそのディレクトリを入
力するか、“Browse…”ボタンで位置を指定してください。

6.5 HEWエディタ以外のエディタを使う
HEWエディタ以外のエディタも使うことができます。外部のエディタを指定してあると、以下の

操作をしたときにそれが起動します。

• ワークスペースウィンドウの“Projects”タブのファイルをダブルクリックしたとき
• ワークスペースウィンドウの“Navigation”タブのエントリをダブルクリックしたとき
• アウトプットウィンドウの“Build” タブのエラーやウォーニングをダブルクリックしたとき
• アウトプットウィンドウの“Find in Files” タブのエントリをダブルクリックしたとき
• ワークスペースウィンドウのポップアップメニューから[Open <ファイル名>]を選んだとき

HEWエディタ以外のエディタを指定するには

1. [Tools->Options…]を選んでください。 “Tools Options”ダイアログボックスが表示されるの
で “Editor”タブ（図6.11）を選んでください。
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図 6.11　Tools Options ダイアログボックス、Editorタブ

2. “Use external editor”チェックボックスをチェックしてください。
3. “Modify…”ボタンをクリックしてください。“External Editor”ダイアログボックスが表示さ

れます（図6.12）。

図 6.12　External Editorダイアログボックス

4. “Command”フィールドに実行可能ファイルのパス（引数をのぞいて）を入力してください。
5. “Arguments to open file”フィールドにファイルを開くのに必要な引数を入力してください。

開くファイルのパスには$(FULLFILE)プレースホルダを使ってください。
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6. “Arguments to open file at line”フィールドにファイルの特定の行を開くのに必要な引数を入
力してください。開くファイルのパスには$(FULLFILE)プレースホルダを使ってください。
また、カーソルを最初に置く行の番号には$(LINE)プレースホルダを使ってください。

7. “OK”をクリックするとエディタが指定されます。

【注】 HEWエディタ以外のエディタを使う場合、以下のことに注意してください。

• どのように起動しても、外部エディタを起動するたびに、エディタは新規に起動します。
• ビルド操作（“Build”、“Build All”、“Build File”）を行う前にファイルを保存してください。

6.6 ファイルの保存をカスタマイズする
“Tools Options”ダイアログボックス（図 6.11）の“Editor”タブで、ファイルの保存方法をカスタマ

イズすることができます。[Tools->Options…]で“Editor”タブを選んでください。
ファイル保存に関するチェックボックスを以下に説明します。

6.6.1 Save files before executing any toolsチェックボックス
このチェックボックスをチェックすると、ビルドフェーズ（“Build”、“Build All”、“Build File”

操作）またはバージョン管理コマンドを実行する前に編集したファイルを保存します。

6.6.2 Prompt before saving filesチェックボックス
上記の“Save files before executing any tools”チェックボックスと、このチェックボックスをチェッ

クすると、保存する前に確認メッセージを表示します。
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7. バージョン管理

HEWはバージョン管理システムと接続することができます。プロジェクトでバージョン管理シス
テムを使用する理由を以下に示します。

• プロジェクト開発環境の統合性を維持するため
• プロジェクトのバージョンを記録･保存するため
• ソースファイルに対するバージョン管理を行い、複数のユーザが一つのプロジェクトを共同
開発できるようにするため

図 7.1にバージョン管理システムを使用するプロジェクトの一般例を示します。ここでは 3人のユ
ーザがソースコードを相互参照するために同じ共有ネットワークドライブを使用しています。バージ
ョン管理システムはソースファイルの参照や更新を管理するために使用します。

プロジェクト

ファイル ファイル ファイル

バージョン管理システム

ローカル ローカル ローカル

ネットワーク

図 7.1　バージョン管理
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7.1 バージョン管理システムを選択する
初期設定では、バージョン管理サブメニューが表示されます（図 7.2）。このとき、まだバージョ

ン管理システムが現在のワークスペースで有効でないため、[Version Control-> Select…]オプションだ
けが利用できます。

図 7.2　バージョン管理サブメニュー

バージョン管理システムを選ぶには

1. [Version Control->Select…]を選んでください。図7.3に示すダイアログボックスが表示され
ます。このダイアログボックスにはサポートするバージョン管理システムがすべて表示さ
れます。

2. “Version control systems”リストからバージョン管理システムを選んで“Select” ボタンをク
リックしてください。“Current version control system”には新しい設定が表示されます。

3. “OK”ボタンをクリックしてください。
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図 7.3　Select Version Control Systemダイアログボックス

【注】 HEWと共にインストールされたバージョン管理システムだけが“Select Version Control
System”ダイアログボックスに表示されます（図 7.3）。

バージョン管理システムを選択すると、[Version Control-> Configure…]オプションが使用できるよ
うになります。
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8. カスタムバージョン管理システム

HEWに加えて、カスタムのバージョン管理システムを構築できます。HEWにより、すでにマシン
にインストールされたバージョン管理システムと接続します。つまり、HEWがバージョン管理ツー
ル自体を提供するわけではなく、ワークスペースやプロジェクトで使用するバージョン管理システム
を統合する手段を提供するだけです。

8.1 バージョン管理メニューオプションの定義
カスタムのバージョン管理システムでは、[Tools->Version Control]サブメニューからオプションを

選ぶか、バージョン管理ツールバーボタンでバージョン管理コマンドを起動することができます。そ
うすると、関連するコマンドが実行され、出力がアウトプットウィンドウの“Version Control”タブに
表示されます。

バージョン管理システムを実行するには

1. ワークスペースウィンドウからバージョン管理コマンドを適用する項目（ワークスペース、
プロジェクト、フォルダ、ファイルなど）を選んでください。コマンドが選択されると、
すべてのファイルが選んだ項目から抽出され、バージョン管理コマンドに渡されます。例
えば、ワークスペースアイコンを選ぶと、そのプロジェクトのすべてのファイルがバージ
ョン管理コマンドに渡されます。

2. [Tools->Version Control]サブメニューからメニューオプションを選ぶか、バージョン管理ツ
ールバーボタンを選んでください。

カスタムバージョン管理のサポートにより、バージョン管理システムの指定がフレキシブルに構築
できます。 [Version Control->Configure…]を選んで “Version Control Setup”ダイアログボックスを表示
してください（図 8.1）。
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図 8.1　Version Control Setupダイアログボックス、Commandsタブ

“Commands”タブには 2つのメニューオプションのリストがあります。1つめのリスト“System
menu options and toolbar buttons”は常にバージョン管理サブメニューに表示されるメニューオプショ
ンです。これに対応するバージョン管理ツールバーがあります。2つめのリスト “User menu options”
はユーザ定義の追加オプションで、バージョン管理サブメニューの最後に追加されます。図 8.2にバ
ージョン管理サブメニューの構成を示します。
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システム定義オプション�

ユーザ定義オプション�

図 8.2　Version Controlサブメニュー

8.1.1 システムメニューオプションとツールバーボタン
ツールバーまたは[Tools->Version Control]サブメニューのシステム定義オプションからコマンドを

起動するには、まず、起動したときに実行する関連したコマンドを定義しなければなりません。オプ
ション名とその説明を表 8.1に示します。

表 8.1　システムメニューオプションとツールバーボタンの説明
オプション 説明

Add File(s) バージョン管理に選んだファイルを追加する

Remove File(s) バージョン管理から選んだファイルを削除する

Get File(s) バージョン管理から選んだファイルの読み取り専用ローカルファイルを取得する

Check Out File(s) バージョン管理から選んだファイルの書きこみ可能なローカルコピーを取得する

Check In File(s) バージョン管理を選んだファイルのローカルコピーで更新する

Status of File(s) 選んだファイルの状態を表示する

システムメニューやツールバーボタンを変更するには

1. [Version Control->Configure…]を選ぶと図8.1に示すダイアログボックスが表示されます。
2. “System menu options and toolbar buttons”リストから変更するオプションを選んで

“Modify…”ボタンをクリックすると図8.3に示すダイアログボックスが表示されます。図
8.3は”Add File(s)”を選択した場合の例です。

3. “Add…”ボタンでコマンドを追加してください。詳細はこの章の後半の「バージョン管理コ
マンドの定義」を参照してください。

4. “OK”をクリックして “Define Command for “<コマンド名>” ”ダイアログボックスを閉じて
ください。

5. “OK”をクリックして”Version Control Setup”ダイアログボックスを閉じてください。
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図 8.3　システムメニューオプションの変更（例）

8.1.2 ユーザ定義メニューオプション
ユーザ定義のメニューオプションはいくつでも作成できます。名前も自由につけられます。また、

メニューの順序も指定できます。ユーザ定義のメニューオプションはバージョン管理ツールバーには
表示されません。

新しいバージョン管理メニューオプションを作るには

1. [Version Control->Configure…]を選んでください。図8.1に示すダイアログボックスが表示さ
れます。

2. “Add...” ボタンをクリックしてください。図8.4に示すダイアログボックスが表示されます。
3. “Option” フィールドにメニューオプション名を入力してください。
4. “Add…”ボタンでメニューオプションにコマンドを追加してください。詳細は、この章の後

半の「バージョン管理コマンドを定義する」を参照してください。
5. “OK”をクリックして“Add Menu Option”ダイアログボックスを閉じてください。
6. “OK”をクリックして”Version Control Setup”ダイアログボックスを閉じてください。
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図 8.4　Add Menu Optionダイアログボックス

既存のバージョン管理メニューオプションを削除するには

1. [Version Control->Configure…]を選んでください。図8.1に示すダイアログボックスが表示さ
れます。

2. “User menu options” リストから削除するメニューオプションを選んで “Remove”ボタンを
クリックしてください。

3. “OK”をクリックして “Version Control Setup”ダイアログボックスを閉じてください。

既存のバージョン管理メニューオプションを変更するには

1. [Version Control->Configure…]を選んでください。図8.1に示すダイアログボックスが表示さ
れます。

2. “User menu options” リストから変更するメニューオプションを選び、リストの横の
“Modify…”ボタンをクリックしてください。図8.3に示すダイアログボックスが表示され
ます（ただしタイトルは“Modify Menu Option”です）。

3. メニューオプション名を変更して“OK”をクリックしてください。
4. “OK”をクリックして“Version Control Setup”ダイアログボックスを閉じてください。

バージョン管理メニューオプションの順序を変更するには

1. [Version Control->Configure…]を選んでください。図8.1に示すダイアログボックスが表示さ
れます。
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2. 移動するメニューオプションを選んで、上に移動するには“Move up”ボタンを、下に移動
するには“Move down”ボタンをクリックしてください。

3. “OK”をクリックして“Version Control Setup” ダイアログボックスを閉じてください。

8.2 バージョン管理コマンドを定義する
図 8.3や図 8.4で“Add...” や “Modify…”ボタンをクリックすると、コマンドを定義できます。ど

ちらの場合も、図 8.5に示すダイアログボックスが表示されます。

図 8.5　Add/Modify Commandダイアログボックス

コマンドを定義するには

1. “Version control executable”フィールドにコマンド実行ファイルのフルパスを入力するか、
“Browse…”ボタンをクリックしてコマンド実行ファイルの位置を指定してください。

2. “Arguments”フィールドにコマンドラインパラメタを入力してください。
3. “Initial directory”フィールドに実行ファイルを起動するディレクトリを入力するか、

“Browse…”ボタンをクリックして起動ディレクトリを指定してください。ただし、特に起
動ディレクトリを指定する必要がない場合は、“$(FILEDIR)”プレースホルダを指定してフ
ァイルのディレクトリと同じディレクトリでコマンドを実行してください。

4. “Executable return code”オプションを設定してください。オプションの設定は次節を参照し
てください。

5. “OK”をクリックすると新しいコマンドが定義されます。
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8.2.1 Executable return codeオプション
コマンドのリターンコードでエラーを示すことができるならば、“Command has failed if the return

code is”オプションを選択して右の 2つのフィールドを設定してください。
“Command has failed if the return code is” オプションが選択されている場合、HEWは各コマンドの

リターンコードをチェックしてエラーが起こったかどうか判定します。エラーが起こった場合、コマ
ンド実行は停止してそれに続くコマンド実行やコマンドの後に続く処理（例：ビルド）は実行されま
せん。
“Return code of executable is not meaningful” オプションが選択されている場合、HEWは各コマン

ドのリターンコードをチェックしません。したがって、すべてのコマンドが実行されます。

8.3 変数を指定する
変数は正しく指定しなければなりません。もし間違っていると、バージョン管理システムが正しく

動作しません。また、１つのバージョン管理コマンドを複数のファイルに適用する場合があるため、
変数をフレキシブルな方法で指定することが重要です。これを行うために、“Arguments”フィールド
にはプレースホルダボタンがあります（プレースホルダの詳細は「付録 B　プレースホルダ」を参照
してください）。プレースホルダボタンをクリックすると、使用できるプレースホルダがポップアッ
プメニューで表示されます（図 8.6）。表 8.2に各プレースホルダの説明と実際の値を示します。

図 8.6　変数フィールド、プレースホルダのポップアップメニュー
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表 8.2　変数フィールドのプレースホルダ
プレースホルダ 実際の値

User login name 現在のユーザログイン (“General”タブ)

User login password 現在のユーザパスワード (“General”タブ)

Version control directory 「仮想的」バージョン管理マップ (“Projects”タブ)

Comment コマンド実行前に指定したコメント

File path + name 操作するファイル名とそのフルパス

Filename 操作するファイル名（拡張子を含む）

File leaf 操作するファイル名（拡張子を含まない）

File extension 操作するファイルの拡張子

File directory 操作するファイルのディレクトリ

Configuration directory 現在のコンフィグレーションディレクトリ

Project directory 現在のプロジェクトのディレクトリ

Workspace directory 現在のワークスペースディレクトリ

Temp directory テンポラリディレクトリ

Command directory バージョン管理実行ディレクトリ

Windows directory Windows® がインストールされているディレクトリ

Windows system directory Windows®のシステムファイルがあるディレクトリ

Workspace name 現在のワークスペース名

Project name 現在のプロジェクト名

Configuration name 現在のコンフィグレーション名

8.3.1 ファイルの位置を指定する
ファイルの位置を指定するときには、プレースホルダを使用してください。そうでないと、そのコ

マンドは指定したファイルにしか適用できません。例えば、バージョンコントロールのアプリケーシ
ョンに–GETコマンドが使われていて、ファイルの読み出し専用コピーを作成するとします。このと
き、“Arguments”フィールドは以下のように指定できます。

-GET “c:\vc\files\project\main.c”

しかし、このコマンドを実行しても、ファイル MAIN.C しかコピーできません。この問題を解決す
るために、HEWにはプレースホルダとディレクトリのマッピングというシステムがあります。マッ
ピングにより、どの「作業中の」ディレクトリ（つまり、作業中のソースファイルがあるディレクト
リ）がどの「管理」ディレクトリ（つまり、バージョン管理システムに保存されているソースファイ
ルのディレクトリ）に対応するかを指定します。これら 2つのディレクトリ間のマッピングは、
“Version Control Setup”ダイアログボックスの“Projects”タブ（図 8.7）で指定できます。
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図 8.7　Version Control Setupダイアログボックス、Projectsタブ

新しいマッピングを定義するには

1. [Version Control->Configure…]を選んでください。図8.1に示すダイアログボックスが表示さ
れます。“Projects”タブを選んでください。図8.7に示すダイアログボックスが表示されま
す。

2. “Version control directory mappings”リストの横にある“Add…”ボタンをクリックしてくださ
い。図8.8に示すダイアログボックスが表示されます。

3. “Source directory”フィールドにもとの作業中のディレクトリを入力するか、“Browse…”ボ
タンでディレクトリを選んでください。

4. “Version control directory”フィールドにバージョン管理ディレクトリを入力してください。
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図 8.8　Version Control Directory Mapping、ダイアログボックス

既存のマッピングを変更するには

1. [Version Control->Configure…]を選んでください。図8.1に示すダイアログボックスが表示さ
れます。“Projects”タブを選んでください。図8.7に示すダイアログボックスが表示されま
す。

2. “Version control directory mappings”リストから変更するマッピングを選び、“Modify…”ボタ
ンをクリックしてください。図8.8に示すダイアログボックスが表示されます。

3. 二つのディレクトリを変更して“OK”をクリックしてください。

既存のマッピングを削除するには

1. [Version Control->Configure…]を選んでください。図8.1に示すダイアログボックスが表示さ
れます。“Projects”タブを選んでください。図8.7に示すダイアログボックスが表示されま
す。

2. “Version control directory mappings”リストから削除するマッピングを選んで“Remove”ボタ
ンをクリックしてください。

マッピングを定義すると、“Version control directory”プレースホルダ $(VCDIR)を使用してプロジ
ェクトファイルを保存するディレクトリを示すことができます。図 8.9に例を示します。ここではネ
ットワークを共有したバージョン管理ドライブ(X:\)と開発が行われているローカルドライブ(C: \)か
らマッピングされた 3つのディレクトリがあります。図 8.9のマッピングを参考にしてください。

ローカル - C:\ マッピング ネットワーク - X:\

C:\work\application\project1 X:\vc\sw\app\project1

X:\vc\sw\app\src

X:\vc\sw\shared

C:\work\application\src

C:\work\shared

図 8.9　マッピングの例
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例えば、–GET コマンドが使われていてファイルの読み出し専用コピーを作成するバージョンコン
トロールのアプリケーションが選ばれているとします。プロジェクトのすべてのファイルを取得する
には、次のコマンドを使用します。

-GET “$(VCDIR)\$(FILENAME)”

そのプロジェクトファイルのコマンドを実行すると、$(VCDIR) をファイルマッピングの中の対応
するバージョン管理ディレクトリに置き換えます。
例えば、FILE1.Cが C:\work\application\project1\file1.cにあるとします。FILE1.Cに-getコマンドが

適用されると、次のようになります。

❶ $(VCDIR)がX:\vc\sw\app\project1に置き換えられます。これはC:\work\application\project1のバ
ージョン管理ディレクトリマッピングに対応しているからです。

❷ FILE1.Cが$(FILENAME)に置き換えられます(図8.10)。

C:\work\application\project1\file1.c

$(VCDIR)\$(FILENAME)

X:\vc\sw\app\project1\file1.c

変数：�

プロジェクトファイル：�

コマンド：�

図 8.10　バージョン管理ディレクトリマッピング

8.3.2 環境変数の設定
現在の設定を確認するには“Version Control Setup”ダイアログボックスの“Projects” タブを表示し

てください（図 8.7）。
新しい環境変数エディタを追加するには、“Environment”リストの横にある“Add…”ボタンをクリ

ックしてください。図 8.11に示すダイアログボックスが表示されます。“Variable”フィールドに環
境変数名を、“Value”フィールドに環境変数の値を入力して“OK”をクリックしてください。
“Environment”リストに新しい環境変数が追加されます。

プレースホルダ�
ポップアップメニュー�

図 8.11　Environment Variable ダイアログボックス
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環境変数を変更するには、変更する環境変数を“Environment”リストから選んで、“Modify…”ボタ
ンをクリックしてください。“Variable”フィールドと“Value”フィールドを必要に応じて変更して“OK”
をクリックすると、変更した環境変数がリストに追加されます。
環境変数を削除するには、削除する環境変数を“Environment”リストから選んで、“Remove”ボタ

ンをクリックしてください。

8.3.3 コメントを指定する
コマンドに “$(COMMENT)”プレースホルダを含む場合、コマンド実行時に図 8.12に示すダイアロ

グボックスにコメントを入力してください。

図 8.12　Please Enter Comment ダイアログボックス

コメントは各コマンドごとに指定できます。また、“Apply comment to all files”チェックボックス
をチェックして “OK”をクリックすると、すべてのファイルに同じコメントが指定できます。

8.3.4 ユーザ名とパスワードを指定する
バージョン管理ツールでは一般的にユーザ名とパスワードの入力をコマンドラインで行う必要が

あります。これは、ファイルを保護し、どのファイルがどのユーザによって変更されたか記録するた
めです。バージョン管理システムでは 2つのプレースホルダ“User login name”, $(USERNAME),と“User
login password”, $(PASSWORD)をサポートします。コマンドを実行すると、これらのプレースホルダ
は“Version Control Setup”ダイアログボックスの“General”タブ（図 8.13）の現在の設定に置き換え
られます。
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図 8.13　Version Control Setupダイアログボックス、Generalタブ

プレースホルダ$(USERNAME) と $(PASSWORD)に値を設定するには、最初にログインの指定を
しておく必要があります。もしこれらのプレースホルダのうちのどちらかのプレースホルダを使うコ
マンドを実行する前にログイン指定をしていなかった場合、コマンド実行前にログインするよう要求
されます。

ユーザ名とパスワードを設定するには（ログインの指定）

1. “Log in…”ボタンをクリックしてください。図8.14に示すダイアログボックスが表示されま
す。

2. “User name”フィールドにユーザ名を入力してください。
3. “Password”フィールドにパスワードを入力してください。
4. “Confirm password by retyping it below”フィールドにパスワードを再入力してください。
5. “OK”をクリックすると新しいユーザ名とパスワードが設定されます。“Password”フィール

ドと“Confirm password by retyping it below”フィールドで異なるパスワードが入力された場
合はもう一度パスワードを入力するよう要求されます。
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図 8.14　Log inダイアログボックス

8.4 実行を制御する
“Version Control Setup”ダイアログボックスの“General”タブ（図 8.13）では、使用するバージョ

ン管理ツールと HEWを制御することができます。また、現在のバージョン管理コンフィグレーショ
ンファイルへのフルパスを表示します。

8.4.1 Prompt before executing commandチェックボックス
バージョン管理コマンドを実行する前にこのチェックボックスをチェックすると、図 8.15に示す

ダイアログボックスが表示されます。このダイアログボックスではコマンドの実行の有無を確認する
ことができます。チェックボックスのチェックを外すとそのコマンドは実行しません。“OK”をクリ
ックすると、選んだコマンドを実行します。“Cancel”をクリックするとコマンドは実行しません。

図 8.15　コマンドプロンプト ダイアログボックス（例）

8.4.2 Run in DOS Windowチェックボックス
デフォルトでは、バージョン管理コマンドの出力はアウトプットウィンドウの“Version Control”

タブに結果が表示されます。このチェックボックスをチェックすると、各コマンドを別の DOSウィ
ンドウで実行します。
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8.4.3 Use forward slash ‘/’ as version control directory delimiterチェック
ボックス

デフォルトでは、HEWがプレースホルダ$(VCDIR)を置き換えるときバックスラッシュ文字 ‘\’
（日本語Windows®では円記号）を使ってディレクトリを区切ります。しかし、お使いのバージョン
管理システム(例 Visual SourceSafe)で、ディレクトリを区切るときにスラッシュ文字‘/’を使う場合は 、
“Use forward slash ‘/’ as version control directory delimiter”チェックボックスをチェックしてスラッシ
ュ文字‘/’でディレクトリを区切ってください。

8.4.4 設定内容の保存と適用
ワークスペースごとに異なるバージョン管理設定を行うことができます。HEWではそれぞれのバ

ージョン管理設定を保存して他のワークスペースに適用することができます。これにより、複数のワ
ークスペースで何度も同じバージョン管理設定を行う必要がなく、時間を節約することができます。

バージョン管理設定を保存するには

1. [Version Control->Configure…]を選んでください。図8.1に示すダイアログボックスが表示さ
れます。

2. “Export…” ボタンをクリックしてください。標準のファイル保存ダイアログボックスが表
示されます。設定内容を保存するディレクトリを選んでください。

3. ファイル名を入力して “OK”をクリックしてください。

バージョン管理設定を適用するには

1. [Version Control->Configure…]を選んでください。図8.1に示すダイアログボックスが表示さ
れます。

2. “Import…” ボタンをクリックしてください。標準のファイルを開くダイアログボックスが
表示されます。適用するファイル（*.HVC）を選んでください。

3. “OK”をクリックしてください。
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9. Visual SourceSafeを使う

HEWは Visual SourceSafeバージョン管理システムをサポートします。現在、HEWは Visual
SourceSafeのバージョン 5と 6だけをサポートしています。それ以前のバージョンはサポートしませ
んが、それ以降のバージョンについては、将来サポートする予定です。

Visual SourceSafe バージョン管理システムでは、Visual SourceSafeデータベースのなかのプロジェ
クトとワークスペースのなかのプロジェクトを関連付けます。[Tools->Version Control] サブメニュー
からオプションを選ぶか、バージョン管理ツールバーボタンをクリックすることにより、標準コマン
ドをすばやく起動することができます。

9.1 ワークスペースに Visual SourceSafe を関連付ける
以下の節では、Visual SourceSafeと現在のワークスペースとを関連付ける方法を説明します。

9.1.1 Visual SoureSafeを選ぶ
まず、Visual SourceSafeをバージョン管理システムとして選びます。

Visual SourceSafe 5.0 または 6.0を使うには

1. [Tools->Version Control->Select…]を選んでください。 “Select Version Control System” ダイ
アログボックス (図7.3) に、サポートするバージョン管理システムを表示します。

2. バージョン管理システムのリストから “Visual SourceSafe 5.0/6.0” の項目を選び、“Select”
ボタンをクリックしてください。

3. “OK” をクリックしてください。“SourceSafe Login” ダイアログボックス (図 9.1)が表示
されます。

4. “Username” にVisual SourceSafeのログインを、“Password”にパスワードを入力してくださ
い。

5. プロジェクトを追加するVisual SourceSafeデータベース（つまりSRCSAFE.INI）へのフルパ
スを“Database path”フィールドに入力してください。

6. “OK”をクリックしてください。 “Create SourceSafe Project” ダイアログボックス (図9.2)が
表示されます。

7. “Project name”フィールドに、データベースに作成するプロジェクト名(つまりフォルダ)が表
示されます。プロジェクト名は変更できます。

8. “Project name”フィールド下のツリーにはステップ6で指定したデータベースの構造を示し
ます。“Project name”フィールドに指定したフォルダをどのフォルダ内に作成するかを選ん
でください。

9. “OK”をクリックしてください。
10. 現在のワークスペースにあるプロジェクトの数だけ、ステップ７～９を繰り返してくださ

い。
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図 9.1　SourceSafe Login ダイアログボックス

図 9.2　Create SourceSafe Projectダイアログボックス

HEWは、Visual SourceSafe内に必要なプロジェクトを作成して、迅速にアクセスできるように、
バージョン管理ツールバーやメニューを設定しました。Visual SourceSafeプロジェクト自体は作成し
ましたが、まだファイルは追加されていません。

9.1.2 Visual SoureSafeにファイルを追加する
前節では、ハードディスクのプロジェクトディレクトリ（つまり作業中のディレクトリ）と Visual

SourceSafeのプロジェクトディレクトリ（つまり管理されたディレクトリ）との間でマッピングを確
立しただけです。ハードディスクのプロジェクトディレクトリ（サブディレクトリを含む）に複数の
ソースファイルがあってもマッピング先のVisual SourceSafeのディレクトリには最初何もありません。

まず、バージョン管理システムとして Visual SourceSafeを選びます。

Visual SourceSafeにファイルを追加するには

1. Visual SourceSafeに追加するファイル(複数可)を選んでください。ファイルフォルダ、プロ
ジェクトフォルダ、ワークスペースフォルダ、またはそれらを混在して選ぶこともできま
す。
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2. ファイル追加ツールボタン  ( ) をクリックするか、[Tools->Version Control->Add Files]
メニューオプションを選んでください。

Visual SourceSafeにファイルを追加すると、ワーキングディレクトリのローカルバージョンは読み
取り専用になります。ファイルが追加されたことを確認したり、プロジェクト内のすべてのファイル
の状態を表示するには、

1. チェックしたいファイルのプロジェクトフォルダを選んでください。
ファイルの状態ツールボタン ( ) をクリックするか、 [Tools->Version Control->Status of
Files] メニューオプションを選んでください。

2. “Output”ウィンドウの“Version Control”タブに各ファイルの状態が表示されます。表示され
た情報により、ファイルがプロジェクトに追加されたかどうか、ファイルがチェックアウト
されたかどうか、また、誰によってチェックアウトされたかがわかります。

9.2 Visual SourceSafe コマンド
次の 8つの操作ができます。

• バージョン管理にファイルを追加する
• バージョン管理からファイルを削除する
• 読み取り専用ファイルを取得する
• 読み取り/書き込みファイルをチェックアウトする(編集するため)
• チェックアウトしたファイルをチェックインする（編集後 Visual SourceSafeを更新する）
• ファイルのチェックアウト操作をキャンセルする（編集結果をキャンセルする）*
• ファイルの状態を表示する
• ファイル履歴を表示する*

【注】* 他のコマンドは、ツールバーまたはメニューからアクセスできますが、これらのコマンドは
[Tools->Version Control] サブメニューからしかアクセスできません。

9.2.1 バージョン管理からファイルを削除する
HEWプロジェクトにファイルが表示(“Workspace”ウィンドウの“Projects”タブ)されても、それら

のファイルが Visual SourceSafeによって管理されているとは限りません。

Visual SourceSafeからファイルを削除するには

1. Visual SourceSafe.から削除するファイルを選んでください。ファイルフォルダ、プロジェク
トフォルダ、ワークスペースフォルダ、またはこれらを混在させて選ぶこともできます。

2. ファイル削除ツールバーボタン  ( ) をクリックするか、 [Tools->Version Control-
>Remove Files] メニューオプションを選んでください。
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9.2.2 バージョン管理から読み取り専用ファイルを取得する
Visual SourceSafeはソースファイルを保護して、管理しているファイルの書き込み可能なコピーを

一度に一人のユーザだけが取得できるようにします。しかし、どのユーザもすべてのファイルの読み
取り専用コピーを取得できます。

Visual SourceSafeから読み取り専用コピーを取得するには

1. Visual SourceSafeから取得するファイルを選んでください。ファイルフォルダ、プロジェク
トフォルダ、ワークスペースフォルダ、またはこれらを混在して選ぶこともできます。

2. ファイル取得ツールバーボタン ( ) をクリックするか [Tools->Version Control->Get
Files] メニューオプションを選んでください。

9.2.3 バージョン管理から書き込み可能ファイルをチェックアウトする
Visual SourceSafe はソースファイルを保護して、管理しているファイルの書き込み可能コピーを一

度に一人のユーザだけが取得できるようにします。チェックアウト操作をすると、Visual SourceSafe
からファイルの書き込み可能コピーをローカルドライブに取得します。これは、チェックアウトしよ
うとするファイルがすでに他のユーザによりチェックアウトされていない場合のみ可能です。

Visual SourceSafeからファイルの書き込み可能コピーをチェックアウトするには

1. Visual SourceSafeからチェックアウトしたいファイルを選んでください。ファイルフォル
ダ、プロジェクトフォルダ、ワークスペースフォルダ、またはこれらを混在して選ぶこと
もできます。

2. ファイルチェックアウトツールバーボタン ( ) をクリックするか [Tools->Version
Control->Check Out Files] メニューオプションを選んでください。

9.2.4 バージョン管理にファイルの書き込み可能コピーをチェックイン
する

Visual SourceSafe はソースファイルを保護して、管理しているファイルの書き込み可能コピーを一
度に一人のユーザだけが取得できるようにします。チェックアウト操作をすると、Visual SourceSafe
からファイルの書き込み可能コピーをローカルドライブに取得します。チェックアウトしたファイル
を編集してチェックインすると、編集結果を他のユーザが見られるようになります。

編集したVisual SourceSafeのファイルをチェックインする

1. Visual SourceSafeに再びチェックインするファイルを選んでください。複数のファイルを選
ぶことができます。ファイルフォルダ、プロジェクトフォルダ、ワークスペースフォルダ、
またはこれらを混在して選ぶこともできます。

2. ファイルチェックインツールバーボタン  ( ) をクリックするか [Tools->Version
Control->Check In] メニューオプションを選んでください。
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9.2.5 チェックアウト操作を取り消す
Visual SourceSafe はソースファイルを保護して、管理しているファイルの書き込み可能コピーを一

度に一人のユーザだけが取得できるようにします。チェックアウト操作をすると、Visual SourceSafe
からファイルの書き込み可能コピーをローカルドライブに取得します。チェックアウトしたファイル
を編集してチェックインすると、編集結果を他のユーザが見られるようになります。しかし、もしチ
ェックアウト操作を誤って行った場合、または、必要なくなった場合、チェックアウト操作を取り消
すことができます。

Visual SourceSafeからのファイルのチェックアウト操作を取り消すには

1. 以前のチェックアウト操作を取り消したいファイルを選んでください。ファイルフォルダ、
プロジェクトフォルダ、ワークスペースフォルダ、またはこれらを混在して選ぶこともで
きます。

2. [Tools->Version Control->Undo Check Out] メニューオプションを選んでください。

9.2.6 ファイルの状態を表示する
HEWプロジェクトにファイルが表示されても( “Workspace” ウィンドウの“Projects” タブ)、ファ

イルが Visual SourceSafeに管理されているとは限りません。Visual SourceSafeに管理されているファ
イルのうち、チェックインされたり、チェックアウト(ユーザが編集するため)されるものがあります。
状態コマンドは、現在のファイルの状態を表示します。

Visual SourceSafeのファイルの状態を表示するには

1. 状態を表示するファイルを選んでください。複数のファイルを選ぶこともできます。ファ
イルフォルダ、プロジェクトフォルダ、ワークスペースフォルダ、またはこれらを混在し
て選ぶことができます。

2. ファイルの状態ツールバーボタン ( ) をクリックするか [Tools->Version Control->Status
of Files] メニューオプションを選んでください。

9.2.7 ファイル履歴を表示する
Visual SourceSafe はプロジェクトのファイルへの編集を管理します。ファイルが最初にプロジェク

トに追加されたときからの編集内容の完全なファイル履歴を表示できます。

Visual SourceSafeのファイル履歴を表示する

1. ファイル履歴を表示するファイルを選んでください。複数のファイルを選ぶことができま
す。ファイルフォルダ、プロジェクトフォルダ、ワークスペースフォルダ、またはこれら
を混在して選ぶことができます。

2. [Tools->Version Control->Show History] メニューオプションを選んでください。
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9.3 Visual SourceSafe 統合化オプション
[Tools->Version Control->Configure…]を選ぶことにより、履歴コマンドや状態コマンドの表示方法

を変更できます。
履歴コマンドの結果をダイアログボックスで表示するには、“Display dialog box for history” チェッ

クボックスをチェックしてください。履歴コマンドの結果を“Output” ウィンドウの“Version Control”
タブで表示するには、“Display dialog box for history” チェックボックスのチェックをはずしてくださ
い。状態コマンドの結果をダイアログボックスで表示するには、“Display dialog box for file status”チ
ェックボックスをチェックしてください。状態コマンドの結果を“Output” ウィンドウの“Version
Control”タブで表示するには、“Display dialog box for file status”チェックボックスのチェックをはずし
てください。
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付録

A.　正規表現
HEWエディタでは検索・置換操作の際、文字列に特殊文字を指定できます。指定できる特殊文字

を表 A.1に示し、その詳細を以下に示します。

表 A.1　正規表現の文字
特殊文字 機能

? 任意の一文字 (改行文字を除く)に一致

* 任意の文字列（改行文字を除く）に一致

\n 改行文字に一致

\t タブ文字に一致

[ ] かっこ内に列挙した、または、かっこの範囲の任意の一文字に一致

\ 以下に続く正規表現文字を無視

【注】 バックスラッシュ文字 ‘\’ は日本語Windows®では円記号として表示されます。

特殊文字 ?

意味 改行文字以外の任意の一文字と一致します。

例 t?p は “top”や “tip” と一致するが “trap”とは不一致。

特殊文字 *

意味 改行文字以外の文字列（0個以上の文字列）と一致します。二行にまたがって一致す
ることはありません。* 文字は残りのパターンが一致するための最短文字列と一致し
ます。

例 t*o は“too”の“to”, “trowel”の“tro” , “sporty orange”の“ty o”と一致するが、“smartorange”
とは一致しない（*文字は二行にまたがって一致することはないため）。

特殊文字 \n

意味 改行文字と一致する。 \n は行の終わりや 2行にわたるパターンを検索するときに使
います。

例 1 ;\n
行末のセミコロンと一致する。

例 2 ;\nif
セミコロンと改行文字が続き次に if で始まる行が続く場合を検索する。
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特殊文字 \t

意味 タブと一致します。

例 1 \t8
タブの次に 8がある場合を検索する。

例 2 init\t
initの次にタブがある場合を検索する。

特殊文字 [ ]

意味 かっこ内の文字または文字の範囲の中の任意の一文字と一致します。かっこをネスト
することはできません。

[-]は文字の範囲を示します。例 [a-z]、[0-9]。範囲の始まりの文字は終わりの文字より
小さい ASCIIコードでなければなりません。

[~]は[~ と ]の間の文字以外の一文字と一致します。改行文字がこのかっこ内になけれ
ば、改行文字とも一致します。

例 1 [AEIOU]
大文字の母音をすべて検索する。

例 2 [<>?]
記号 <, > , ?を検索する。

例 3 [A-Za-z0-9_]
大文字、小文字、数字、下線を検索する。

例 4 [~0-9]
数字以外の文字を検索する。

例 5 [ \t\n]
空白、タブ、改行文字を検索する。

例 6 [\]]
\のすぐ後に]を置くと、記号 ] を検索する。

特殊文字 \

意味 正規表現を無視する特殊文字です。バックスラッシュの次の文字が正規表現のとき、
通常の文字として扱います。バックスラッシュの次が非正規表現のとき、バックスラ
ッシュは無視されます。

例 1 \*
アスタリスクをすべて検索します。

例 2 \\
バックスラッシュをすべて検索します。
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B.　プレースホルダ
プレースホルダは、HEWの複数のツールによって提供される機能です。この章ではプレースホル

ダの使い方を説明します。

B.1　プレースホルダとは?
プレースホルダとは一時的にテキストに挿入される特殊文字列です。後に実際の値に置き換えます。

例えば、HEWのプレースホルダのひとつに、$(FULLFILE)があります。これは、すべてのパス付き
のファイルを示します。パラメータとしてファイルを編集できるエディタが c:\myedit\myeditor.exe で
あるとします。c:\filesディレクトリのファイル FILE1.Cを開き、このエディタを起動するには、以下
のように直接指定することもできます。

c:\myedit\myeditor.exe c:\files\file1.c

しかし、このエディタを介して任意のファイルを開きたいとき、上記コマンドは“c:\files\file1.c”
を開くだけのものであるため、問題が起きます。指定したエディタを使うときにその時点で選んだフ
ァイルを開くことができるようにするには、特定のファイル名を一般的なプレースホルダに置き換え
ます。以下に例を示します。

c:\myedit\myeditor.exe $(FULLFILE)

これで、HEWがエディタでファイルを開くとき、$(FULLFILE)を選ばれたファイル名で置き換え
ます。

B.2　プレースホルダを挿入する
プレースホルダは HEWの三つの編集フィールドで指定できます(図 B.1、B.2、B.3)。プレースホ

ルダの指定方法には四つあります。

例 1
プレースホルダを挿入したい場所にカーソルを置いてください。次に、必要なプレースホルダを編

集フィールドの右のポップアップメニューから選んでください。

図 B.1　プレースホルダポップアップメニュー

例 2
“Custom directory”以外のプレースホルダをドロップダウンリストボックスから選び、プレースホ

ルダによって示されたディレクトリからの相対サブディレクトリを指定してください。“Custom
directory”を選んだ場合、“Sub-Directory”フィールドに絶対ディレクトリパスを指定してください。
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図 B.2　プレースホルダドロップダウンリストと Sub-Directoryフィールド

例 3
プレースホルダを挿入したい場所にカーソルを置いてください。次に、必要なプレースホルダをド

ロップダウンリストボックスから選んでください。そして、“Insert”ボタンをクリックしてください。

図 B.3　プレースホルダドロップダウンリストボックス

例 4
フィールドにプレースホルダを直接入力してください。大文字で入力して、$( で始めて ) で終わ

ってください。

正しい
$(FILEDIR)

誤り
$(Filedir)
$(  FILEDIR   )
$FILEDIR

B.3　使用できるプレースホルダ
表 B.1にプレースホルダと意味を示します。

表 B.1　プレースホルダ
プレースホルダ 意味

$(FULLFILE) ファイル名 (フルパスを含む)

$(FILEDIR) ファイルディレクトリ

$(FILENAME) ファイル名 (パスを除き拡張子を含む)

$(FILELEAF) ファイル名（パスと拡張子を除く）

$(EXTENSION) ファイルの拡張子

$(WORKSPDIR) ワークスペースディレクトリ

$(WORKSPNAME) ワークスペース名

$(PROJDIR) プロジェクトディレクトリ

$(PROJECTNAME) プロジェクト名

$(CONFIGDIR) コンフィグレーションディレクトリ
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プレースホルダ 意味

$(CONFIGNAME) コンフィグレーション名

$(HEWDIR) HEWインストールディレクトリ

$(TCINSTALL) ツールチェインインストールディレクトリ（オプションダイアログ上）

$(TOOLDIR) ツールインストールディレクトリ（Tools Administration上）

$(TEMPDIR) テンポラリディレクトリ

$(WINDIR) Windows® ディレクトリ

$(WINSYSDIR) Windows® システムディレクトリ

$(EXEDIR) コマンドディレクトリ

$(USERNAME) ユーザログイン（バージョン管理）

$(PASSWORD) ユーザパスワード（バージョン管理）

$(VCDIR) 「仮想的」バージョン管理ディレクトリ

$(COMMENT) コメント（バージョン管理）

$(LINE) エラー/ウォーニングの行番号

プレースホルダの使用例を以下に示します。

表 B.2　プレースホルダの展開（例）
プレースホルダ プレースホルダの展開例

$(FULLFILE) c:\hew\workspace\project\file.src

$(FILEDIR) c:\hew\workspace\project

$(FILENAME) file.src

$(FILELEAF) file

$(EXTENSION) src

$(WORKSPDIR) c:\hew\workspace

$(WORKSPNAME) workspace

$(PROJDIR) c:\hew\workspace\project

$(PROJECTNAME) project

$(CONFIGDIR) c:\hew\workspace\project\debug

$(CONFIGNAME) debug

$(HEWDIR) c:\hew

$(TCINSTALL) c:\hew\toolchains\hitachi\sh\511

$(TOOLDIR) c:\hew\toolchains\hitachi\sh\511

$(TEMPDIR) c:\Temp

$(WINDIR) c:\Windows

$(WINSYSDIR) c:\Windows\System

$(EXEDIR) v:\vc\win32

$(USERNAME) JHARK

$(PASSWORD) 214436

$(VCDIR) “c:\project” は “x:\vc\project” へマッピングされている

$(COMMENT)  “Please Enter Comment” ダイアログボックスが表示される

$(LINE) 12
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表 B.2では以下のことを仮定しています。

• ファイルパスは “c:\hew\workspace\project\file.src”
• ワークスペース名 “workspace”の位置は “c:\hew\workspace”
• プロジェクト名 “project” の位置は “c:\hew\workspace\project”
• コンフィグレーション名 “debug” にはコンフィグレーションディレクトリがあり、位置は
“c:\hew\workspace\project\debug”

• HEW.EXEが“c:\hew”インストールされている
• ツールチェイン（コンパイラ、アセンブラ、リンケージエディタ）の*.HRF ファイル の位
置は “c:\hew\toolchain\hitachi\sh\511”
このディレクトリは[Options]メニューのオプション設定ダイアログボックス上では
$(TCTINSTALL)として参照され、“Tools Administration”ダイアログボックス上では
$(TOOLDIR)として参照される

• Windows® 95オペレーティングシステムが c:\Windowsにインストールされており、
Windows® システムファイルが c:\Windows\Systemにインストールされている

• バージョン管理実行可能パスが v:\vc\win32\ss.exeである。バージョン管理システムにログイ
ンするユーザ名は JHARKでパスワードが 214436であり、バージョン管理実行可能ファイル
へのコマンドラインには$(COMMENT)が指定されている。c:\projectは[Tools->Version
Control->Configure…]で選ぶと表示される“Version Control Setup”ダイアログボックスの
“Projects”タブの x:\vc\projectにマッピングされている

• コンパイラまたはアセンブラのエラーが 12行目で起きた

【注】 どのフィールドでもすべてのプレースホルダを使用できるとは限りません。例えば、プレー
スホルダ$(LINE) は依存ファイルパスを指定するときには意味をもちません。プレースホル
ダ$(USERNAME)、$(PASSWORD)、$(VCDIR)、$(COMMENT)はバージョン管理でのみ受
け付けられます。各編集フィールドで、使用できないプレースホルダを指定すると、警告メ
ッセージが表示される場合があります。

B.4　プレースホルダを使うにあたって
プレースホルダによって、システムが使用する様々なファイルへのパスをフレキシブルに指定でき

ます。

• パスまたはファイル名を入力する編集フィールドのとなりにプレースホルダのポップアッ
プメニュー ( ) がある場合、プレースホルダをどのように使ってパスやファイルの指定を
フレキシブルにできるかご考慮ください。

• いくつかの構成を使うとき、プレースホルダ$(CONFIGDIR) を使うと、現在のコンフィグレ
ーションのディレクトリからファイルへの書き込みやそのファイルから現在のコンフィグ
レーションのディレクトリへの書き込みができるので、便利です。

• できるだけプレースホルダを利用してください。プレースホルダは後で削除したり追加した
りできるので、気軽に試すことができます。
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C.　HMAKE ユーザガイド
ここでは hmakeの仕様を説明します。次の節では、用意されたオプションの使用または不使用に

かかわらず、ファイルで hmakeプログラムを実行するときに使うコマンドラインを説明します。

C.1　コマンドライン

C.1.1　基本構成

コマンドラインのシンタックスを以下に示します。

hmake < メイクファイル> < パラメータリスト>

拡張子なしでファイルを指定した場合、.makが付加されます。パラメータリストには、次の節に
示す複数のパラメータを指定できます。また、パラメータは省略できます。パラメータリストはメイ
クファイル名の前に指定してもかまいません。各パラメータは、1つ以上の空白文字で区切ってくだ
さい。パラメータは、大文字と小文字を区別しません。パラメータとファイル名を指定しなかった場
合、ヘルプ情報が表示されます。

C.1.2　Exitコード

実行中のメイクファイルでシンタックスエラー発生時、またはメイクファイル実行中の処理で不当
エラーコードが返されたとき、hmakeはコード 1で終了します。その他の場合、hmakeはコード 0で
終了します（ファイルのシンタックスや exitコード条件の指定方法は、以下を参照してください）。

C.1.3　パラメータ

表 C.1に指定できるパラメータとその機能を示します。

表 C.1　hmakeのパラメータとその機能
パラメータ 機能

/A 入出力ファイル状態にかかわらず全コマンドを実行する。全ビルドと同じ。

/N 入出力ファイルの使用状態により、(ノーマルで)実行すべきコマンドを判断して、表示するが、
実行はしない。

/? ヘルプ情報の表示。

C.2　ファイルのシンタックス
hmakeファイルでは、基本的に 4種類の文（変数宣言、説明部分、コメント、メッセージコメント）

が使用されます。hmakeファイルの作成にあたって、これらの文はどのような順序でも使用できます。
ただし、変数を説明部分や他の変数宣言に使用する前に、変数宣言をしてください。nmakeファイル
で使用する最初の “all”文は、hmakeファイルでは必要ありません。メイクファイルでは、コマンド
は出現する順序で実行されます。“→”文字は、メイクファイルのシンタックスを正しくするために
タブ文字を使用すべきところを示すことに注意してください。
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C.2.1　変数宣言

変数宣言をした後、その変数は、hmakeファイルのすべての部分ですべての文で使うことができま
す。変数宣言のシンタックスは以下に示します。

<変数名> = < 値>

変数名と = 符号の間や、値と = 符号の間に、複数の空白文字を入れることができます。値は、 ‘\’
文字で区切って、数行にわたって書くことができます。メインテキスト内で値に ‘\’文字を含む場合
は文字どおり解釈されます。‘\’ 文字の後に新行が続くときのみ、値が次の行にわたっているとみな
されます。
変数宣言の例をいくつか示します。

EXECUTABLE = c:\dir\prog.exe

OUTPUT = c:\dir2\file1.out

INPUT = c:\dir2\file1.c

DEPEND = c:\dir2\file2.h \

c:\dir2\file3.h \

c:\dir2\file4.h

hmakeファイルの後半で変数を使うには、変数名の前に“$(を、後ろに“)”を加えてください。“$()
文字付きの変数名は、変数の値で置き換えられます。次の説明部分の節にその例を示します。変数名
には、半角英数文字と半角下線を使用することができます。別の変数宣言のなかで変数を使うことが
できますが、すべての変数は、使う前に宣言しなければなりません。

C.3　記述部

C.3.1　概要

説明部分には、1つ以上のターゲット、0以上の依存ファイル、そして最新のターゲットが最新の
依存ファイルより新しい場合に実行するコマンド一覧を指定します。ターゲット、依存ファイルのど
ちらか、またはいずれもない場合、コマンドは常に実行されます。コマンドを常に実行したいときに
は、依存ファイルを指定する必要はありません。説明部分のシンタックスを以下に示します。

<ターゲット 1> < ターゲット 2> … : < 依存ファイル 1> < 依存ファイル 2> …

→<コマンド 1>

→<コマンド 2>

→…

→<コマンド n>

最後のターゲットと‘:’ 文字の間や、最初の依存ファイルと‘:’文字の間に、複数の空白文字を入
れることができます。最初のターゲットの前に空白文字を入れないでください。各ターゲットと各依
存ファイルは、少なくとも 1つの空白文字で区切ってください。タブ文字はコマンドを含む行のはじ
めに必要です。変数宣言の後で、変数を上記シンタックスで説明部分に使うことができます。
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記述部の例（変数宣言の後に変数を使う例）を以下に示します。

c:\dir1\file1.obj : c:\dir1\file1.c c:\dir1\file1.h

→gcc c:\dir1\file1.c

$(OUTPUT) : $(INPUT) $(DEPEND)

→$(EXECUTABLE) $(INPUT)

$(EXECUTABLE)を置き換える CHANGEDIRと SETENVがファイル名でなくてもかまいません。
これらは存在しないファイルとして扱われてコマンドは常に実行されます。

C.3.2　サブコマンドファイル

hmakeでサブコマンドファイルを生成するには、説明部分のコマンド部分を以下のように指定して
ください(上記の<コマンド n>を置き換えます)。

→<コマンド開始> <<

→<サブコマンド 1>,

→<サブコマンド 2>,

→…

→<サブコマンド n>

→<<<コマンド終了>

これで、ウィンドウズの一時的ファイルに、<サブコマンド 1>、<サブコマンド 2>などの行を含む
サブコマンドファイルが生成されます。このコマンドファイルはメイク処理が終了すると削除されま
す。コマンドファイル名は 2つの“<<”の間のすべてのテキストで置き換えられます。サブコマンド
ファイル名は、自動的に hmakeにより付けられます。

例：
c:\dir1\file1.obj : c:\dir1\file1.c c:\dir1\file1.h

→gcc @<<

→-c -o c:\dir1\file1.obj c:\dir1\file1.c

<<

生成されたサブコマンドファイル名が “c:\temp\hmk111.cmd”の場合、hmakeは以下を実行します
(c:\dir1\file1.obj が更新されるとき)：

gcc @c:\temp\hmk111.cmd

サブコマンドファイル (c:\temp\hmk111.cmd) には以下を含みます。

-c -o c:\dir1\file1.obj c:\dir1\file1.c

記述部に 1つ以上のコマンドを含むことができ、標準とサブコマンドファイルコマンドを混在して
使用できます。
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C.4　コメント
‘#’ 文字はコメントを示します。この文字が行の最初にあると、（次の改行文字があるまで）そ

の行は無視されます。コメントの例を次に示します。

# My hmake file

# Variable declaration

OUTPUT= c:\dir1\file1.obj

# Descriptor

$(OUTPUT) : c:\dir1\file1.c c:\dir1\file1.h

→set VAR1=value1

→gcc c:\dir1\file1.c

hmakeファイルではコメントには専用の行が必要です。コメントを他の文の最後に付けることはで
きません。

C.5　メッセージコマンド
メッセージコマンドは、メイクファイル実行中にテキストの行を標準出力に出力します。これらの

テキスト行は、適切に実行されている実行ファイルの出力のなかで、メイクファイルに出現する順序
で出力されます。出力テキストのバッファリングは行いません。メッセージコマンドのシンタックス
を以下に示します。

!MESSAGE <出力するテキスト>

改行文字が<出力するテキスト>の最後の文字の後にあると想定します。!MESSGEと<出力するテ
キスト>の間の空白文字は無視されます。メッセージコマンドの例を以下に示します。

!MESSAGE Executing C Compiler
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