enesans WAN PLL

82V3911

EVALUATION BOARD USER’S GUIDE

INTRODUCTION

The 82V3911 evaluation board kit, including an evaluation board and
evaluation software, provides a platform to evaluate 82V3911.

The evaluation board kit contains the following components:

+ 82V3911 evaluation board ver 1.00 with all necessary components
+ 82V3911 evaluation GUI software ver 1.00

+ 82V3911 evaluation board user’s guide ver 1.0

FEATURES

« Professional evaluation software to configure and monitor the device
« Current configuration data can be saved as a file for later use

PC REQUIREMENTS

The 82V3911 evaluation software runs on Microsoft Windows. The
system requirements are as follows:;

Pentium 166 MMX or higher (recommended)

Minimum 500M bytes free hard disk space

Minimum 64M bytes memory

Display with the resolution of 1024x768, small font (recommended)
Operating System: Microsoft Windows 2000/XP/NT (English version
recommended) or newer OS version

Microsoft Windows compatible 2-button or 3-button mouse
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1 HARDWARE CONFIGURATION

Figure-1 82V3911 Evaluation Board lllustration
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1.1  ANNOTATION FOR FIGURE-1

[1] Output clock 1 - 5 [4] Crystal oscillator Master Clock

[2] 82V3911 chip [5] +5 V DC power supply

[3] Switch SW5: The function of this switch is described in [6] +3.3 V power supply for test purpose
Table-1. [7]+5 V power supply for test purpose

[8] Crystal oscillator for APLL1 and APLL?2

Table-1 Switch SW5 Function Description [9] OSCI: master clock input

Switch Function Description [11] 8 kHz or 1pps frame synchronization output
, Off: SDH [12] 2 kHz multi-frame or 1pps frame synchronization output
SW5-2 SDH/SONET selection On SONET [13] Output clock 6 (differential)
[14] Output clock 7 (differential)
SW5-3 not used [15] Output clock 8 (differential)
[16] Output clock 9 (differential)
SWo-4-6 not used [17] Input clock to APLL1 (differential)
Off: "0" [18] Input clock to APLL2 (differential)
SWa 12C_AD1 On: "1" [19] Input clock 1 (differential)
SW5-8 12C AD2 Off: "0" [20] Input clock 2 (differential)
I2C_AD1 and 12C_AD2 pins [21] Input clock 3-6
are the address bus of the|on: "1" [22] External frame sync 1 and 2 input
microprocessor interface. [23] USB communication port

[24] DPLL1 and DPLL2 DPLL lock indicator
[25] Reset button: Press to reset all devices on the board

EVALUATION BOARD USER'’S GUIDE © 2019 Renesas Electronics Corporation
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2 SOFTWARE CONFIGURATION

2.1 INSTALLATION

Double click on the “82v3911 VER1.00_SETUP.exe” file and follow the
screen prompts, you will finish the evaluation software installation. After
the installation, the evaluation software can be launched by choosing
Start>Programs>IDT WAN PLL>IDT WAN PLL 82V3911.

2.2 GENERAL INTRODUCTION
221 OVERVIEW

The 82V3911 evaluation software provides a friendly interface for users
to configure and control the 82V3911. As shown in Figure-2, the main
window includes:

¢ Menu bar
¢ Shortcut icon

¢ Main work area (the area with blue background)
- Input ports configuration area
— Monitor
— DPLL2 path configuration area
— DPLL1 path configuration area
— Output ports configuration area
- General configuration area
— DPLL1/ DPLL2 path selection and DPLL status indication area
— APLL1/2 configuration

¢ Status bar

To operate this evaluation software, we assume that you have a basic
familiarity with the 82V3911. If you have difficulties in understanding this
users’ manual, please refer to the 823911 datasheet.

2.2.2 CONVENTIONS USED

Users can operate this evaluation software by clicking on the menu bar,
the shortcut icons, the function blocks or the buttons. For easy explanation,
we have adopted a few simple conventions to describe these tools. See
the following table for details.

Name Image (Example) Convention Used
Window  Help . .
menu bar Maritor “Window > Monitor”

Buicket WWindaw
T4 Input

shortcut icon JI |

shortcuticon | #%|

function block “Monitor”

Monitaor

button “Ex Sync”

Ex Sync

REVISION 1 1/30/15
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input ports configuration

[ 1DT WANPLL Family - [IDT 82v3911]
) ]

menu bar

DPLL1 & DPLL2 path configuration

output ports configuration

shortcut icons —i;

77.76MHz
L GSM/GPS
J16E1/16T1

Input
#l Selector DPLL2

Oupt ors
_1] 'DELLL SOMy |
i] \DPLLL SNy |

MPU Interface Page 1 Registers
and Registers = io n

aumfef
ki
El il
05 9.4y & v ‘
@6 19.4aMv 9 v
APLLLH
min | \
work area Hs&
Phase Offset GSHOEEAL
P /16E1/16T1 o—
Tnput | 16E1/16T1 . aplL2
- "
12F1/GPS
[E3/T3
o]
Operation Mode ~ Current 1st 2nd 3rd Frenquency Phase
[0ot: FreeRun—— [None [None — [None  [None  [0.000000ppm  [000ns
status bar M m. m’ W‘ﬂ il "f

DPLL1/ DPLL2 path selection

223 DPLL1/DPLL2 PATH SELECTION

Since some registers are related to the input ports, the DPLL1 and the
DPLL? are shared paths, and users must select a path (DPLL1 or DPLL2)
before configuring these registers. See Figure-3 for details.

IDT 82V3911

@ @ ppLit click to select DPLL1 or DPLL2
@ C DpLL2 (currently selected: DPLL1 path)

Figure-3 DPLL1/DPLL2 Path Selection

[2C Mode, Com Port Not Selected, Auto Refesh Off
DPLL status indication

Figure-2 Graphic User Interface (GUI)

2.24 READ/WRITE THE CONFIGURATION DATA

Generally, once a configuration is made, the configuration data will be
directly written to device. But in the Register Set | dialog box, after config-
uring the registers, you need to click the “Write” or “Write All" button to
write the configuration data to device.

In the main work area or in the dialog boxes, you can click on the
“Refresh” button to read the register value from the device.

2.25 LOAD/SAVE THE CONFIGURATION DATA

To load or save the configuration data, please open the Register Set |
dialog box by selecting “Windows > Register Set I" or clicking on “MCU
Interface and Registers”. Or you can click on the Load or Save button in
the Main window. Refer to 2.9.1 Registers Configuration for details.

REVISION 1 1/30/15
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2.2.6 TIPS FOR THE PARAMETERS AND BUTTONS

The evaluation software provides tips for the parameters, shortcut icons
and buttons to help users make configurations. For example, when the
mouse focus is on a parameter, a tip will appear displaying the related
register’s name, address and hits. See Figure-4.

Divider
6.48M v [ Inverted

38.88M v [ Inwerted .

reg 73 (o—1ip for the division factor
19.4a0 v [ OUT1_TNY
sa.aem v [ Inverted
77.760 v [ Inverted

38,880 v [ Inverted

§§ SYNC

|Sh0w FRSYMC and MFRSYMC config windo

[E: T RETTES T

Output Table ]

W+__tip for the SYNC button

Figure-4 Tips for Parameters and Buttons

2.2.7 MENUBAR
The menu bar contains five menus as shown in the following:

= File “iew Tools ‘Window Help

* File Menu

File “iew Tools

pop up the Device and _
m close the graphic

Mode dialog box | ;
CDSE——user interface (GUI)
Exit

terminate the program

Figure-5 File Menu

* View Menu

Yiew Tools
v Toolbar
v Status Bar —t0ggle the status bar

toggle the shortcut icons

Figure-6 View Menu

¢ Tools Menu

Tools | Window  Help toggle auto refresh and

I —sclect refresh interval,

Shaw Last Error Code see Figure-8

IN3_IN4_Switch
iZurrent DPLL Status

Figure-7 Tools Menu

Eonlsd fnFRRE el toggle auto refresh

T (On: the GUI is auto
2 second
5 Second

gpnled Flercar refreshed in a selected

interval)

ING_IM4_Switch
Current DPLL Status

* 10 Second
20 Second

= ? ”' || — 1 Minulle
refresh interval selection

Figure-8 Auto Refresh Configuration

REVISION 1 1/30/15
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¢ Window Menu

The Window menu contains 13 sub-menus as shown in Figure-9. All
these sub-menus except “Register Set II” and “Hide All Popup” have the
same functions as their respective buttons/function blocks in the main
window. Refer to the corresponding sections for details.

Window Help

[Cronior

Bucket Window
DPLL2 Input

DPLL1 Input
Interrupt Window
DPLL2

DPLL1

Sync Control

PBO Phase Offset
Qutput Frame Sync

APLL1/2 Configuration
popupthe  Ragister Set T Ctrl+R
Register Set 1l - Register Set. Ti
dialog box, see :

. ' . hide all pop-up
Figure-34 Hide All Popup Ctrl+H Tdialog boxes
Figure-9 Window Menu

* Help Menu

provide evaluation THelp

software version and—jEEETa

related information

Figure-10 Help Menu

2.2.8 SHORTCUT ICONS
The functions of the shortcut icons are described in the following table:

Shortcut Icon Function
1k the same as menu “File > Open Device”
'ﬁ) | the same as menu “Help > About DPLL..."
a the same as menu “File > Exit"

229 STATUS BAR

The status bar shows the currently selected microprocessor interface
and communication port. See Figure-11 for details.

|Serial Mode, COM1: Opened, Auto Refresh OFf B _M’_'[

Indication of communication status
between PC and evaluation board

selected microprocessor
interface and COM port

Figure-11 Status Bar

REVISION 1 1/30/15
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2.3 INITIALIZATION

After the program is launched, the Device Port Selection dialog box
pops out as shown in Figure-12. Users can select a COM port in this
dialog box.

Click on “Detect”, and the status of the COM ports will be detected
and displayed in the lower part of this dialog. The evaluation software
will automatically select the port which successfully communicates with
the 82V3911 evaluation board.

Click on “OK”, and the evaluation board will be initialized and the
main window will appear as shown in Figure-2.

After initialization, users can re-open this dialog box by selecting “File
> Open Device” or clicking on the shortcut icon | % |

COM port selection click to confirm the configuration

x|
o
cancel
Detect |
T2C Device Addr; 1010000 -
Auto Device Detection: J
Open 12 port Sucessfully
| =l

|
COM ports status indication  click to detect COM ports status
Figure-12 Device Port Selection

24 INPUT PORTS STATUS AND CONFIGURATION

The input ports status and configuration interface is as shown in
Figure-13. Users can select frequency and priority for each of the 14
input ports in the corresponding pull-down list. The status of the input
ports are indicated by color LEDs.

click to extend
Mors' o !_ the input ports
frequency selection ————  Frequency  Priority configuration
®110.anEllc B interface
input clock status—g§ 2 19.44Mw 7  w —— priority setting
indication
@3 B8RKHz v 4 |w
@4 BKHz » 5
@5 19.44M~ 8 ¥
@6 19.44M~ 9 ¥
click to pop up
the Frame
Synchroniza-
2 l | tion Control
L dialog box
Figure-13 Input Configuration (Shrinked)

Click on “More >>", and the input configuration interface will be
extended to display all input-related status and configuration. See
Figure-14 for details.

REVISION 1 1/30/15
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leaky bucket configuration selection allow/dis-allow lock to the input clock (checked: allow)
lock 8k divider (checked: used) — input clock quality indication (checked: valid)
DivN divider (checked: used) o
priority setting hard frequency alarm indication (checked: has alarm)
no activity indication (checked: no activity)
clock frequency phase loss indication
selection (checked: phase loss)
input clock status Inpjit Ports (soft) (hard) .
indication -I rkemote  Input outof outof No Phase register address
Frequency  Priority Divn 8K Bucket1.D Valid Valid band band Active Lost | and bits
@1 19.4aM~v & ~ [ O ©° =~ O O O  R45(3:0)
@2 1%.44Mm~ 7 - O Od 0 - O O O R45(7:4)
@3 8KHz ¥ 4 ¥ O O 0 - O O O R44(3:0)
@4 8KHz ¥ 5 - O O 0 - O O O R44(7:4)
@5 19.44M¥ 8 ¥ [] [ O - O Od O Rr46(3:0)
@iol)1o.4aMEgNo RN (RN (B0 o d O  Rras7:4)
click to pop up the
Frame Synchronizing
Control dialog box
| L B _ click to pop up the
_ | o PIE LR L e Budets | ———— Bucket Configuration
revertive mode enable—— O dialog box
00 Go Directw s = i) ]
Rising Edge v 32767 | +l << Less ]
division fact l click to read all the
. ) i ivision factor i o i
master clock active edge selection INL/IN2 electrical | click to shrink this input [:lf?;i,ﬂ ;ﬁg'ztg;a?”d
level selection LA . i ion i
DivN divider selection configuration interface

HF divider enable

Figure-14 Input Configuration (Extended)
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2.4.1 LEAKY BUCKET CONFIGURATION

Click on “Buckets” or select “Window > Bucket Window". The buckets
dialog box pops up as shown in Figure-15. Users can set the four leaky
bucket configurations in this dialog box.

configuration 0 configuration 1 configuration 2 configuration 3

[ Buckets Il

leaky bucket size .
register address
upper threshold
PP slide to change the value
lower threshold
indicate the selected value
decay rate

click to exit this dialog box

click to read the configuration data from the device
Figure-15 Buckets Dialog Box

24.2 FRAME SYNCHRONIZATION CONTROL

Click on “Ex Sync”. The Frame synchronization Control dialog box
pops up as shown in Figure-16. In this dialog box, users can configure the
registers related to the external frame synchronization signal.

J‘ Frame Syncing Controls

external frame sync signal monitor range selection [ dternal Sync Selecti [Ex_svmcl willy

IN1L St

register address and bits

=

external frame sync. input signal - ; i
sampling margin control _
determine whether the external frame

sync. signal is used

external frame sync. signal frequency selection
click to read the registers listed in click to exit this dialog box

this dialog box and refresh the display

Figure-16 Frame Synchronization Control Dialog Box

REVISION 1 1/30/15 © 2019 Renesas Electronics Corporation
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2.5 MONITOR CONFIGURATION

Click on “Monitor” or select “Window > Monitor”. The Monitors dialog
box pops up as shown in Figure-17. In this dialog box, users can configure
the input clock quality monitor.

f Monitors
hard frequency alarm configuration el | register address and bits
frequency measurement of the accey ~

selected input clock (
-

frequency monitors clocked by master
clock / output clock from the DPLL1

(checked: master clock) checked: DPLLL_MAIN_REF_FAILED

interrupt flagged on the TDO pin

multi factor
phase lock alarm is cleared by
software or timeout

(checked: time out)

checked: phase loss alarm is
triggered when DPLL1/DPLL2
reaches the hard frequency alarm
threshold

timeout value

DPLL1/DPLL?2 hard frequency alarm limit

operation status indication

click to exit this dialog box

click to read all registers

listed in this dialog box click to pop up the Buckets Configuration dialog box

Figure-17 Monitors Dialog Box

REVISION 1 1/30/15 ’ © 2019 Renesas Electronics Corporation
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2.6 DPLL2 PATH CONFIGURATION
2.6.1 DPLL2INPUT SELECTOR

Click on “DPLL2 Input Selector” or select “Window > DPLL2 Input”. The
following dialog box pops out, allowing users to select an input to the
DPLL2.

DPLL2 input clock selection when DPLL2 locks independently from DPLL1
J) DPLL2 Inputs Selector |

register address
and bits

DPLL2 lock/not lock to
checked: lock to T0)

click to read register R51 and refresh the display of this dialog
Figure-18 DPLL2 Input Selector Dialog Box

2.6.2 DPLL2DPLL

Click on “DPLL2 PFD & LP" or select “Window > DPLL2". The DPLL2
dialog box pops out as shown in Figure-19. This dialog box allows users to
configure the DPLL2.

DPLL2 operating mode selection register address and bits

77.76MHz

GSM/GPS
/16E1/16T1

16E1/16T1

12E1/24T1
E3/T3

¥ ooLlo _..‘.;.

B . 04 DPLL2 SONET (622.08MHz)
| F0C DPLL2 ETH (625MHz)
¥ | 0D DPLL2 (625MHz*66/64)

Figure-19 DPLL2 Dialog Box

HS &
Phase Offset

Note: Before opening this dialog box, users must select the DPLL2
path (see 2.2.3 DPLL1/ DPLL2 Path Selection), otherwise the DPLL2
coarse/fine phase detector can not be configured.

REVISION 1 1/30/15
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2.6.3 DPLL2 DCO OUTPUT CLOCK FREQUENCY SELECTION

Click on “GSM/GPS/16E1/16T1", “16E1/16T1" and “12E1/24T1/E3/T3"
in the DPLL2 path to select the DCO output clock frequency. See Figure-
20 for details.

GEMIcES
JI6E R60{3:2) Mux

click to select
GSM/GPS/16E1/16T1

register address
and bits

01 16T1
0z G3M
03 GPS

16E1 selected

12E1
JE:

click to select _
1E|3E1/16T1 T ey | register address

. and bit
12E1f:
fE3f
—_  1i1.544 MHz (SONET) 2.048 MHz selected
click to select _ [izerrzars LTI
12E1/24T1/E3IT3 |_/E3  Reo(1:0) Mux register address and bits
ML 12E1 selected
ol 2471
B 05 ER
-| Sk Drin 0z T2

Figure-20 DPLL2 DCO Output Frequency Selection

2.64 DPLL2 SONET/GETH CONFIGURATION

Click on “SONET/GETH" to select an input source for the DPLL2
SONET/GETH. See Figure-21.

E3[T3

click to select

an input source RE0(7:4) Mux | register address
for DPLL2 APLL 00 opiLs soneT (ezzoamr—— and bits
l_ SONE 08 DPLLI ETH (625MHz)
I,;T;‘:;T;‘ 09 DPLL1 (625MHZ*56/64) D|:|>|_|_t2 d77'76 MH
* 04 DPLLD SONET (622.08MHz, selecte
! | HS & | OC DPLL2 ETH (625MHz)
1 Phase Offset , 0D DPLL2 (625MHz"66/64)

Figure-21 DPLL2 SONET/GETH Input Source Selection

REVISION 1 1/30/15
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2.7 DPLL1PATH CONFIGURATION

2.7.1 DPLL1INPUT SELECTOR

Click on “DPLL1 Input Selector” or select “Window > DPLL1 Input”. The
following dialog box pops out, allowing users to select an input for the
DPLLI.

DPLL1 Auto/Forced input clock selection

" Inut Sector i ) .
I register address and bits

DPLL1 Internal Fast/Slow input clock selection
(checked: Internal Fast Selection)

check to enable DPLL1 External Fast Switching
click to read the registers listed in this dialog box
click to exit this dialog box

Figure-22 DPLL1 Input Selector Dialog Box

2.7.2 DPLL1 Note: Before opening this dialog box, users must select the DPLL1
Click on “DPLL1 PED & LP" or select “Window > DPLL1". The DPLL1  path (see 2.2.3 DPLL1/ DPLL2 Path Selection), otherwise the DPLL1

dialog box pops out as shown in Figure-23. This dialog box allows usersto  coarse/fine phase detector can not be configured.

configure the DPLL1.

DPLL1 operation [
mode indication

DPLL1 operation

mode selection DPLL1 coarse phase lock detector

configuration

DPLL1 fine phase lock detector

DPLL1 bandwidth configuration
and damping factor
configuration
currently selected
path indication
DPLL1 Mini-Holdover
DPLL1 holdover : mode configuration
mode configuration

DPLL1 holdover frequency
configuration when in Manual
Holdover mode

click to read the registers - click to exit this dialog box
listed in this dialog box

Figure-23 DPLL1 Dialog Box

REVISION 1 1/30/15 ) © 2019 Renesas Electronics Corporation
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2.7.3 HS AND PHASE OFFSET CONFIGURATION

Click on "HS & Offset” or select “Window > HS Phase Offset”. The HS
and Phase Offset dialog box pops out as shown in Figure-24. This dialog
box allows users to configure HS & phase offset.

register address and bits

| x|
—HS Phase Offset |
HS configuration when [ HS Enabled on switching ] ROB(2)
input clock switches ~ L = frozen Ol ROB(S)
Does not feature 5% tolerance - RFE(7)
HS triggered when phase error Enables the phase transient monitar DI R7E(5)
is outside the phase transient limit T e e e e B O R7E(4)
L(igﬁnosttf?RliﬁéeNialpqsliTeg:?]D:it?o)r; 156 = the limit {ns) R78(3:0
phase transient limit configuration —— zozs ns : 0110 -
— Phase offset enable DI R7E(7)
inpm clock to OUtpm Cl(.)Ck gti?:spgféiggss:[tg::n] % 0.61 = the phase offset (ns) R74 7B(1:0)
phaSE offset COHfIgUFatIOH Flease input hex Format data (+f- 5113
~ + b *osl= [omons
st i i diig box = BT

click to exit this dialog box

Figure-24 HS and Phase Offset Dialog Box

2.7.4 DPLL1DCO OUTPUT CLOCK FREQUENCY SELECTION

Click on “GSM/OBSAI/16E1/16T1", “16E1/16T1" and “12E1/24T1/E3/
T3" in the DPLL1 path to select the DCO output clock frequency. See
Figure-25 for details.

click to select [esmcesat L LIEEEEH register address
ETH/3G_BTS/16E1/16T1  LUSELL  Rss(a:2) Mux —and bits
-| 16E1[1
12€1fz 01 1671
JES! 02 GSM
[~ em 03 OBSAT 16 E1 selected
El(l;ltzkltlcl)ﬁs'l?lle(:t —Freers RI Dgl(zl) - | register address
e — and bits
[l ¢ O: 2.048 MHz (SDH)

1: 1.544 MHz (SONET)

click to select

i 12E1j24T1 ]
12E1/24T1/E3F|'3_E545-(‘1_0)| Mux -f—feg'S“?f address

and bits

* 00 12F1
01 2471
02 E3
03 T3

1d Registe

Figure-25 DPLL1 DCO Output Frequency Selection

2.75 DPLL1 SONET/GETH CONFIGURATION

Click on “DPLL1 SONET/GETH" to select an input source for the
DPLL1 APLL. See Figure-26.

Click on “DPLL1 SONET/GETH" to select a bandwidth for the DPLL1
APLL. See Figure-27.

I:
click to select ————— 0 = ||
an input source

for DPLL1 SONET/
GETH

register address
and bits

[ m |flh (525}
0 DL (GISMHE"66/64)
04 DPLL? SONET (622.08MM1)
i O DPLLY ETH (625MHe)
00 DRLL (AFSMMr*06/61)

Figure-26 DPLL1 SONET/GETH Input Source Selection
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2.8  OUTPUT PORTS CONFIGURATION

The default output ports configuration interface is as shown in Figure-

; g division factor selection of the output clock
27. Click on “<< More”, and this interface extends to show all output- WSl | ! uipu

. . . . . . QOutput Ports Divider
related configuration information. See Figure-28 for details. (1] orii1 ol oG, low v [ Inverted—— checked: output inverted
il DPLLL SONw| 77.76M = [ Inverted
T T output port number il DPLL1 SONw|  38.88M ¥ [ Inverted
utput Po
DPLLL sOoMw . frequency selection [NEEED | GECH | =
2 | DPLL1 SOK = il DFLL1 SON ¥ 155.52M > [ fnverted
3 DPLL1 SOK w
| TR | 6| 155.52MHzly | LVEECL |v| Disabliw
Out6 LVDS/PECL
il DELLL SOl gy | electrical level selection ﬂ 77.76MHz v LVPECL |v Disabliw
() Reserved w
7| 77 10Mmz Out7 LVDS/PECL

electrical level selection

g | 155.52MHz w» LVPECL w Disabliw

g | rReserved |w il 77.76MHz w| LVPECL v | Disabldw

9 77.76MHZ - APLL1_CLK_FREQ_CFG

APLL1 CLK FREQ CFG DPLL1 S jg 77.76M g

DR APLL2_CLK_FREQ_CFG

APLL2_CIK_FREQ CFG DPLL]l S ¥ 38.88M =+«

DELL]1 S w
click to pop up the swe _ .

sne W/ : - click to refresh the display
FRSYNC dialog box — -
< 1 g > e Refresh of this dialog box
[
1 . . .
click to extend this output ports configuration interface click to shrink this output port

configuration interface

Figure-27 Output Ports Configuration (Shrinked) Figure-28 Output Ports Configuration (Extended)
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2.8.1 ETHERNET CLOCK CONFIGURATION FOR OUTPUT

PORTS

Following is an example using Ethernet clocks from the DPLL1
SONET/GETH (625 MHz) path to configure the output 6. The steps
below are performed from the main GUI (refer to Figure-2).

1. Click on "DPLL1 SONET/GEHT" to select "08 DPLL1 ETH (625

MHz)".

12E1/GPS

SONET/GFTH
R55(7:4) Mux

SOMETE

00 DPLL1 SONET (622.08MHz)

 OCITRINGETTINEE- Select ‘08 DPLLL ETH

09 DPLL1 (625MHz*66/64) (625 MHz)"

04 DPLL2 SONET (622.08MHz)
0C DPLL2 ETH (625MHz)
0D DPLL2 (625MHz*66/64) /

MPU Inte
and Regi

Figure-29 Selecting a DPLL1 Input Source

2. Click on "APLL1" or "APLL2" to configure the APLL interface, and
setting "19525" to PDSEL and "3124"to M

1 APLL configuration B E|

APLLZ

APLLY

’VCONF[G 0: Configurat ™

’;ONF[G 0: Configurat~¥

ouTfy
LN S
MUK

APLLI ROL APLLZ RB1
’7(LK SEL 1: sour v ’VCLK SEL 1: sour ¥
APLLT APLL1 ROZ/03i04/05 APLLZ RBZJE3[84(55
Pre Divider PoSEL 19525 PDSEL Pl i
Valug MUx Click
ickto

apLL apLLz S select
M Value PJ " 3125 APLLA
(FEB Divider and
vale) _— APLLZ

APLLE Frequency Select RBE
SEL_DOUBLER  0: Sing v

APLLI Frequency Select ROE AP:\U.;Z

SEL_DOUBLER  0: Sing ¥

MR_SYNC 0: Horm ¥

MR_STNC 0: Norm v
BYPASS 0: Norm v BYPASS 0: Norm v
SHUTOFF 0: Norm SHUTOFF 0: Norm ¥
FSEL 0: XTAL v FSEL 0: XTAL v
| l egisters
Apply Exit | oo

Figure-30 APLL Configuration Interface

3. Click on "<< More" in the output ports configuration interface to
show all output-related configuration information. Click on output
6 in the output ports configuration interface to select "25MHz/
125MHz/ 156.25MHz/ 312.5MHz/ 625MHz". The "Enable Output"
and "156.25MHz" clock on DPLL1 SONET/GETH Path should be
selected.

Output Ports
1 DPLL1 SON w

2 | DPLL1 SOM v
3 | DPLL1 SOM »
4 | DPLL1 SONw

5 | DPLL1 SON »

|6 | [P -
LI 125MHz

156.25MHz
312.5MHz
©25MHZ

Select ETH __|
clock on OUT6

Divider

ylow w [ Inverted
[~ Inverted
[~ Inverted
[ Inverted

[ Inverted

o}
DC,low w
C,low |w
DC,low w

156.25M =

LVPECL =

Enzble v ——Fnable Output

: Divide by 5
: Divide by 4
: Divide by 2
: Divide by 1

il 156.25MHz»  LVPECL |v Disabliw
ﬂ Reserved w LVPECL « Disabltw Selea
APLL1_CLK_FREQ_CFG 156.25MHz
DPLL; STv 156.25M = —C|0Ck on
DPLL1
APLL2_CLK_FREQ CFG SONET/GETH
DELLl S w DC,low = path
SYNC i
>> Less i Refresh !

Figure-31 DPLL1 APLL1 ETH Clock Selection for
Output 6
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2.8.2 FRAME AND MULTI-FRAME CONFIGURATION

Click on “SYNC" or select “Window > Output Frame Sync”. The Frame
and Multi-Frame configuration dialog box pops up as shown in Figure-32.

| b rrs¥NC

checked: 2 kHz/4 kHz/8 kHz

input clock inverted register address and bits

FRSYNC_8K & MFRSYNC_2K

- . . The falli d
output pulse position configuration e M

FRSYNC_8K output configuration MFRSYNC_2K output configuration

click to read the registers
listed in this dialog box

click to exit this dialog box

Figure-32 Frame/Multi-Frame Configuration Dialog Box
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29 OTHER CONFIGURATION

29.1 REGISTERS CONFIGURATION
* Register Set | Dialog Box

Click on “MPU Interface and Registers” or select “Window > Register
Set I". The Register Set dialog box pops up as shown in Figure-33.
Users can configure all registers or check the status of all registers in
this dialog box. Users can save the register configuration data as a file
(*.rgf) for later use, or load the configuration data from a file.

) register bits (b7-b0) register value display/input load configuration data
default value of the register (checked: the bit is set to “1”) (double-click to input the register value) from a file
ol x|
register address |"° e save configuration
register name . I ] ;
J Name Adde [Def (M8 | 6 | 5 | 4 [ 3 [ 2 | 1 [olse[Hex| Read _wiite ﬂ W/dataasaflle
currently selected —— B R |Iz B AN R ,I; oo Red | = adjust the layout
register NOMINAL FREQUOLCNG o o [ TT T T I T e T T T oo | s _~ of this dialog box
NOMINAL FREQ[15:8] CNFG v w0 OO0 O0EET « |55k Best Layout | _
NOMINAL_FREQ[23:16] CNFG o o | OO0 ONONOOIO] Write read register value
DPLL?_DPLL1_REG_SEL_CNFG (o7 (oo | OO [DDD [0 [T L [ oo | RS R Read Al——— from the device
PHASE_ALARM_TIME_OUT_CNFG e 2| 00IM FIOIDOIF O x| k5 Wrs 1 !
INPUT_MODE_CNFG o (2 W (OO E DML | SrEs ; : ;
— Ao o o TP T O B T [T o e l write conf|gurat_|on
mw.swl PROLONFG e ls | F DO ODRORE & wmm e data to the device
INTERRUPT_CNFG {oc [ | OO TOTOTE [T T | oz | BT 6
INTERRUPTS1_STS w # ¥ M M ¥V VM V F V & %} =)
T T R LT L 0T e N0 VY 22 O BT Y o S0 o Y o 55 5 00 PO ] L
"NOMINAL_FREQ[23:16] CNFG" -
Address (DG Drefault Value Ondid
Bit7-0 NOMINAL_FREC _VALLE[23:16] j
With NOMINAL_FREQ_VALUE [7:0] and NOMINAL_FREQ_VALUE [15:8] register, program the offset of crystal. L
This value Is 2" complement signed Integer offset W .l_ exit this dlalog box
The valug multiplied by 0.0000884 dec will give the value In ppm. ﬂ g
7
description of the current-selected register read the value of the corresponding

register from the device
Figure-33 Register Set | Dialog Box

* Register Set Il Dialog Box
Select “Window > Register Set II". The Register Set Il dialog pops up
as shown in Figure-34. This dialog box provides a convenient way to
access a group of registers that have related functions.

select a group of select a register in value of the
registers to configure the selected group selected register

Register et i x|

~ Register

Type |All Registers | =

Register 00 In
7 & S 4 3 2 1 o

5 o | o | RN S [ i

"o :I

Address 000 Default Value 0x38

Eit7-0  10[7:0]
See the ID[15:8] bits (ID[15:8], O1H).

I o

R_Tad i Write ’\ Close i y

description of the read the register value  writé the configured
selected register from the device value to the register

Figure-34 Register Set Il Dialog Box
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2.9.2 INTERRUPTS CONFIGURATION
Click on “Interrupt” or select “Window > Interrupt Window". The
Interrupt dialog box pops up as shown in Figure-35.

register address register bit (interrupt name) interrupt enable/disable (checked: enable)

f Internipts

interrupt source status indication
(red: status changed; green: status not changed)

interrupt polarity

selection
checked: INT_REQ pin high impedance enable

click to read the registers listed in
this dialog box and refresh the display reset all interrupt status bits click to exit this dialog box

Figure-35 Interrupt Dialog Box
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2.10 DPLL STATUS INDICATION

The DPLL status indication area is as shown in Figure-36. Users can
choose to show DPLL1 or DPLL2 status. Here shows the situation that
DPLL1 is selected.

i currently selected valid input clock valid input clock current DPLL frequency offset
fgﬁlr(réﬁt?;fgegt?&%lg[l?f I;;Iétzh)P ath input clock with the second with the third with respect to the
' to current DPLL highest priority highest priority crystal oscillator
(' @ @ ppluLt Operation Mode Current 1st 2 nd 3rd Frenquency Phase current phase of
e @  DpPLL2 |001: Free-Run |Nune |None |I'\Iune |None |0.DODGDD ppm |D.00 ns Turrent DPLL
S— Refresh I I r Load I Save I—I Read All 1—| Write All }

operation mode ofl valid input clock with
current DPLL the highest priority

read the configuration
data from the device and
refresh the display

load register configuration

data from a file data as a file

save register configuration

read configuration
data of this pane

save configuration
data of this pane

Figure-36 DPLL1/ DPLL2 Path Selection and DPLL Status Indication

2.10.1 CURRENT DPLL STATUS

Select “Tools>Current DPLL Status” from the menu bar. The pop-up
dialog box provides a convenient way to read CURRENT_D-
PLL_PHASE[15:0] and CURRENT_DPLL_FREQ[23:0] data.

Right click on either the Current Phase or the Current Frequency
graphic area in Figure-37, a list of context menu items pops out, as shown
in Figure-38. Select the “Setup” item, the Graphic Properties dialog box
then pops out as shown in Figure-39.

CURRENT DPLL_PHASE[15:0]

[ Current DPLL Status g

Currart Phasa [ns)

Save to file i

33000 =1

=10l x|

R68, R69

Phase & Frequency Data

0.000000
0.000000
0.000000
0.000000
0.000000
0.000000
0.000000
0.000000

+ 16500

F - 16500

-33000

100 200 300 500

& Yalue
f ;
320 Currart Fregquanca [ppm) 320 Raw Diaka
Delay: (ms)
& 160 160 ISU—
[=8
=3
T oad ]
o Clear 1
iz 160 160 .
i h L Stop j
320 -320
o 100 200 200 400 500 Eass i

L Data displays in decimal format
— Data displays in hexadecimal format

— Internal data reading interval

L Clear all the currently displayed data
— Restart data reading

CURRENT DPLL_FREQ[23:0]

v

R62, R63, R64

Figure-37 Current DPLL Status
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33000 Corrent:Phaseng) . i 33000

: T Phase Freq
G500 4 - -

o
1

L PHasze :ns

Right click the graphic area

m

o

=]

=]
1

-33000

Currart Fregquancs [ppm) 230

50

Freq :ppm

o] 100 200 300] 400 500

Printing the displayed graphics Refreshing data display Setting the graphic properties

Figure-38 Context Menu Items

Show/hide the grid lines

i Graphics Properties

Show/hide the scale numbers on. i Show Grid T Check this item to prevent graphic flicker
the right side of the diagram : -~ : :

Setting the data display range of X axis Range | Lange Setting the data display range of Y axis
Setting the data value precision of X axis Precisi ' | Setting the data value precision of Y axis
Setting the number of grid lines of X axis Setting the number of grid lines of Y axis
Setting the number of scale units of X axis Setting the number of scale units of Y axis

Figure-39 Graphic Properties Dialog Box
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2.11 PAGE 1 REGISTERS CONFIGURATION

Click the button of Page 1 Registers Access in the main window, the
user can configure the registers in the page 1. See Figure-40 for details.

Click on the button, then select the DFS enable

_F Pagel Registers Configuration

Phase Slope {

Limiting - _
Configuration 11: no limitatioly
for DPLL1 & ' '
DPLL2

DPLL2

1 Pulse
DPLL1 1 Pulse Per Second
Per Second

Configuration

Configuration 00: 0 degrelw | 1000: 100usv 100: 0 degrew = 1000: 100usy

Refresh Button Click the Close button to Exit this dialog box
Figure-40 Page 1 Register Configuration
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