RE N ESAS Application Note

e? studio Integrated Development Environment

Debugging Linux Applications Running on the R-Car (with the ETM as an
Analysis Tool)

Introduction

This application note introduces the procedure for acquiring R-Car V4H trace data and displaying it in the
ETM trace window using Linux running on R-Car V4H and e? studio for R-Car.

Target Device

R-Car V4H
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e2studio Integrated Development Environment

Debugging Linux Applications Running on the R-Car
(with the ETM as an Analysis Tool)

1. Environment

Table 1-1 lists the elements of the environment used in the descriptions in this application note.

Table 1-1 List of Environment Elements

Item

Details

R-Car V4H Reference Board

White Hawk [RTP8A779G0ASKBOFS0SA000]

HOST PC

* Windows 10 (As terminal display console)
 Ubuntu 20.04 LTS (e? studio. TFTP server. NFS server)

e? studio for R-Car

Version 2023-11
rcar-xos_tool_e2studio_ubuntu_2023-11.R20231110-1754 .tar.gz

R-Car V4H SDK

Vv3.20.0
rcar-xos_developer-adas-bootloader_v3.20.0_release.tar.gz

R-Car V4H yocto Linux
(Kernel version)

V5.10.147
rcar-xos_tool_yocto_linux_6.21.0.tar.gz

This application note describes the procedure for using an environment in which a Linux environment has
been set up for the R-Car on the reference board. For the procedure for setting up the Linux environment,
refer to the Start-Up guide (Linux Interface Specification Yocto recipe Start-Up Guide R-Car,
R11UZ0270EJ0621) included in the SDK.

2. Connection Diagram

Figure 2-1 shows connection diagram between the reference board for the R-Car V4H and a host PC.
The IP addresses for use between the host PC and the reference board are set as shown in the Figure 2-1.
Specify the IP addresses which are to be set to suit the environment you are using.

USB type Ato micro-USB cable

e’ studio Ethernet cable

R —

IP address:
192.168.0.20

IP address:
192.1686.0.1

Windows/LinuxHOSTPC : W
TFTP
NFS 55:3;: R-Car V4H Reference Board
SSH

Terminal software to display console

Figure 2-1 Connection between the Host PC and the reference Board
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e2studio Integrated Development Environment Debugging Linux Applications Running on the R-Car
(with the ETM as an Analysis Tool)

3. Starting Linux and Preparing file

3.1 Starting Linux for R-Car

Turn on the R-Car V4H Reference Board for which the Linux environment has been set up and start Linux for
R-Car.

An example of the boot log messages in the serial console is shown in Figure 3-1.

Using ethernet@e6800000 device

TFTP from server 192.168.0.1; our IP address is 192.168.0.20

Filename 'Image’'.

Load address: 0x48080000

Loading: #HHHHHHHHHHHHHHHHHHHHHHHH AR

R
4 MiB/s
done
Bytes transferred = 33839616 (2045a00 hex)
Using ethernet@e6800000 device
TFTP from server 192.168.0.1; our IP address is 192.168.0.20
Filename 'r8a779g0-whitehawk.dtb'.
Load address: 0x48000000
Loading: ##HHHHHHEHE
2.8 MiB/s

Done

Figure 3-1 Preparing Data (1)

After the Image of Linux running on the R-Car has been started, log in to Linux to confirm its version.

[ OK ] Started Target Communication Framework agent.
[ OK ] Started Avahi mDNS/DNS-SD Stack.
[ OK ] Reached target Multi-User System.
Starting Update UTMP about System Runlevel Changes...

[ OK ] Started Update UTMP about System Runlevel Changes.

Poky (Yocto Project Reference Distro) 3.1.11 v4x ttySCO

v4x login: root (Enter the user ID and press [Enter].)

root@véx:~#

root@v4x:~# uname -a (Enter the command and press [Enter].)

Linux v4x 5.10.147-yocto-standard #1 SMP PREEMPT Fri Mar 3 11:25:12 UTC 2023 aarch64 aarch64 aarch64 GNU/Linux

root@véx:~#

Figure 3-2 Preparing Data (2)
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e2studio Integrated Development Environment Debugging Linux Applications Running on the R-Car
(with the ETM as an Analysis Tool)

3.2 Preparing an Executable File for Acquiring Trace Data

When the e? studio is installed on the host PC, a pre-constructed stub file is stored in the support directory
(DebugComp/RCar) of the e? studio. The path name is given below.

“lhome/<user name>/.eclipse/com.renesas.platform_XXXXXXXXXX/DebugComp/RCar”

Select “perfmodule_5 10 _147.ko” and “saperfmon.elf’ corresponding to the version of Linux running on the
R-Car and the target board. Store these files in the desired working directory of Linux.

Use ” perfmodule_XXX.ko” that corresponds to the version of R-Car V4H Yocto Linux confirmed in the steps
of Figure 3-2.
The XXX part of “perfmodule_ XXX.ko” indicates the version of Yocto Linux.

XXXX@XXXXXp:~$ Is -alF (Enter the command and press [Enter].)

A EF XXXXXX

drwxrwxr-x 9 XXXX XXXX ~ XXXX MMM DD HH:MM ./

drwxrwxr-x 3 XXXX XXXX ~ XXXX MMM DD HH:MM ../

-rw-rw-r-- 1 XXXX XXXX 575584 MMM DD HH:MM perfmodule_5_10_147.ko

-rw-rw-r-- 1 XXXX XXXX 494048 MMM DD HH:MM perfstub.elf

XXXX@XXXXXp:~$

Figure 3-3 Preparing Data (3)

Store the files in the desired directory of Linux running on the R-Car and assign the executable right to the
files to be executed.

root@vax:~/XXXXXXXX# chmod 755 ./perfmodule-5_10_147.ko ./perfstub.elf (Enter the command and press [Enter].)
root@v4x: ~/ XXXXXXXX#

root@vax:~/XXXXXXXX# Is -alF (Enter the password and press [Enter].)

total XXXX

-rwxr-xr-x 1 root root XXXXXX HHH DD YYYY perfmodule_5 10_147.ko

-rwxr-xr--x 1 root root  XXXXXX HHH DD YYYY perfstub.elf

root@v4x: ~/ XXXXXXXX#

Figure 3-4 Preparing Data (4)
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e2studio Integrated Development Environment Debugging Linux Applications Running on the R-Car

(with the ETM as an Analysis Tool)

Notes:

The support directory path can be confirmed by following these steps:
Open the [About e2 studio for R-Car] dialog box.
And click on the [Installation Details] button by selecting the [About e? studio for R-Car] item from the [Help]

menu.

welcome

(@ Help Contents

%’ Search

X Show Context Help

Show Active Keybindings...

Cheat Sheets...

Renesas Help

& Renesas W —ILF —>DEBM
%8 perform Setup Tasks...

% Check for Updates
- Install New Software...

About e? studio for R-Car o &
Renesas e studio for R-Car

Version: 2023-03 (23.3.0)
Build I1d: R20230313-1010

Parts Copyright (C) 2010-2023 Renesas Electronics Corp.
All rights reserved.

e*studio IDE is an extension of software developed for
eclipse.org.

e*studio IDE is based on Eclipse Platform 4.26 (2022-12)
and CDT version 11.0.0.

Source code for the Eclipse Foundation plug-ins is available |
from www.eclipse.org, under the Eclipse Public License

I:I @ About e studio For R-Car

"EPL",

P T

Ry R T T N

cocEBs0P

@ |installation Details

Figure 3-5 Preparing Data (5)

The [e? studio for R-Car Installation Details] window will open. Select the [Support Folders] tab to confirm the

path to the support directories.

Installed Software | Installation History  Features | Plug-ins | Configuration Renesas Device 5upporl Support Foldersl |

e? studio for R-Car Installation Details o @ |

e*studio support area: file:/home/exec/.eclipse/com.renesas.platform 1815713838/ |

e*studio download area: file:/home/exec/.eclipse/com.renesas.platform download

|

Figure 3-6 Preparing Data (6)
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e2studio Integrated Development Environment Debugging Linux Applications Running on the R-Car
(with the ETM as an Analysis Tool)

3.3 Preparing the Target Project
Target project is used for acquiring trace data. It is created using e? studio.

3.3.1 Creating the Target Project
Create and build the project and generate the executable file.

This section describes an example of creating a project. The creation method described in this chapter is just
an example, so please refer to e2 studio Help for more details.

Select [Help] -> [Add Renesas Toolchain] to open the toolchain management window.
Make sure that desired version of Poky 64bit Embedded Linux is registered.

Select [File] -> [New] -> [C/C++ Project] to open the [New C/C++ Project] dialog box.

workspace - e

File Edit Source Refactor Mavigate Search Project RenesasViews Run Window Help

Shift+Alt+N  » ++ i b .
| New | Renesas CfC++ Project hection...
Open File... R-Car CMake Project
4 Open Projects from File System... E% Makefile Project with Existing Code
Recent Files ] [c

C/C++ Project

71

o

3 Source Folder
5 Folder
source File
Header File

o

=.

¥ File from Template
& Class
| Refresh 4 Example...

Convert Line Delimiters To ] 3 Other...

£ Import...
i3 Export...
Properties

Switch Workspace »

Figure 3-7 Example of creating Target Project (1)
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e2studio Integrated Development Environment

Debugging Linux Applications Running on the R-Car
(with the ETM as an Analysis Tool)

Select [C Managed Build] and click on the [Next] button, enter the desired Project name.

Select “Simple R-Car Poky Linux C Project” for Project type and “Poky Embedded Linux” for Toolchains,

then press the [Next] button.

New C/C++ Project

Templates for New C/C++ Project

All > C Managed Build
CMake { A C Project build using the CDT's managed build system.

Make
Renesas CVEngine

C++ Managed Build
Renesas Debug .@. A C++ Project build using the COT's managed build system.
Renesas R-Car

CMake Project

Empty or Existing CMake Project

over existing content.

e ]

A CMake project with a Hello World executable to get started.

Create a CMake project with no files. Can be used to create one

€ Project
Create C project of selected type

test1

@ Executable Poky Embedded Linux

® Empty Project
® Hello World GNU ARM Embedded C Project
® Hello world ANSIC Project
@ Hello world Arm CProject
¢=Shared Library
@ Static Library
@ Makefile project

Figure 3-8 Example of creating Target Project (2)

Check both “Debug” and “Release” in [Select Configurations] dialog box and press the [Finish] button to

complete the settings.

Select Configurations

& Debug
& Release

@

select platforms and configurations you wish to deploy on

Figure 3-9 Example of creating Target Project (3)
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e2studio Integrated Development Environment

Debugging Linux Applications Running on the R-Car

(with the ETM as an Analysis Tool)

Right-click the created project and select [New] -> [File] to open the “Create New File” dialog box. Specify
the “src” folder, enter desired file name, and create a program, then press the [Finish] button.

wo Create New File x
File Edit Source Refactor Navigate Search Project RenesasViews Run Window Help File
L S ® |3 Debug €7 etm_test Debug B v Y & New Ci Create a new file resource.
. Project Explorer x e Y § = @O
» &5 etm_test (in etm_looping_test testi/sr
¥ & MyTracingProject
O test_ETM g
" Eetm_test
v &5 test1 [Debug] & MyTracingProject
» 5 Includes & RemoteSystemsTempFiles
_ &S test1 [Debug]
» & Tracing New 4 [ Project.. (.settings
Go Into £ C/Ce+ Project -
& Tracing

Openin New Window File

ShowIn 3
Show in Local Terminal 3 C
& copy @ Class

n/ Header File
% Delete ¢l source File
Source 3 69 Source Folder
Move... [ Example...
Rename... [ other...
Lu Import...

Figure 3-10 Example of creating Target Project (4)

Right-click the created project and select [Build Project].

The project will be built, and an executable file (elf file) will be generated.

[&] Problems B Console x [ Properties L3 27—k + =27 JL =b System Performance -

File Edit Source Refactor Navigate Search Project Renesas Vi

4 || % | ® 1 Debug [ etm_test Debug

— CDT Build Console [test1]

New »

Gonto

& Project Explof
» |5 etm_test (il

» & MyTracingR make -r all

Openin New Window

Build Project

Close Project

00:49:45 **** Incremental Build of configuration Debug for project testl ****

Building file: ../src/main.c

3 test_ETM
Showln MW llBuilding target: testl.elf
WAl Binadles = SiEIn Locl Tarming " ||aarch64-poky-linux-objcopy -0 ihex "testl.elf" “testl.hex"
» & Includes Lo aarch64-poky-linux-size --format=berkeley “testl.elf"
o text data bss dec hex  filename
» [@ maing % Delete
Bilbmny | N 624 8 2343 927 testl.eld]
» & Tracing
Rename.. 00:49:45 Build Finished. @ errors, © warnings. (took 163ms)
s Import...
3 Export.

Figure 3-11

Example of creating Target Project (5)
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e2studio Integrated Development Environment Debugging Linux Applications Running on the R-Car
(with the ETM as an Analysis Tool)

4. Acquisition and Display of Trace Data

4.1 Preparation for Acquiring Trace Data

In order to acquire trace data, it is required to run the following commands under the directory (WORK
directory) where “perfmodule_5 10_147.ko” and “perfstub.elf’ are stored as described in “3.2 Preparing an
Executable File for Acquiring Trace Data”.

Run the command shown in Figure 4-1, to disable Sleep Entry (power down) on the Cortex A76 core.

root@v4x:~/XXX# echo "1" > /sys/devices/system/cpu/cpul/cpuidle/state1/disable (Enter the command and press [Enter].)
root@v4x:~/XXX# echo "1" > /sys/devices/system/cpu/cpul/cpuidle/state1/disable (Enter the command and press [Enter].)
root@v4x:~/XXX# echo "1" > /sys/devices/system/cpu/cpu2/cpuidle/state1/disable (Enter the command and press [Enter].)
root@véx:~/XXX# echo "1" > /sys/devices/system/cpu/cpu3/cpuidle/state1/disable (Enter the command and press [Enter].)
root@vax:~/XXX#

Figure 4-1 Steps to run command (1)

Load “perfmodule_5_10_147", which is a kernel object for tracing, to Linux.

It should be noted that if this kind of kernel object has already been loaded, an error message will be
displayed.

In such a case, unload operation can be conducted using “rmmod” command before conducting “insmod”
command.

root@v4x:~/XXXXXXXX# insmod ./perfmodule_5_10_147.ko (Enter the command and press [Enter].)
[ 9382.722569] Perfmodule - Board Type V4H detected (0x5¢c12)

root@v4x:~/ XXX XXXXX#

root@v4x:~/XXXXXXXX# insmod ./perfmodule_5_10_147.ko (Enter the command and press [Enter].)
insmod: ERROR: could not insert module ./perfmodule_5_10_147 .ko: File exists

root@vax:~/XXXXXXXX#

Figure 4-2 Steps to run command (2)

Run perfstub.elf to connect Linux on R-Car board to e? studio on the Host PC.

root@vax:~/XXXXXXXX# ./Iperfstub.elf (Enter the command and press [Enter].)
uio PMU driver 1 auto-detection: /dev/uio369
uio DBSC driver auto-detection: /dev/uio368

uio QOS driver auto-detection: /dev/uio367

Register in socket waiting for connection on port 9998...

Figure 4-3 Steps to run command (3)
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e2studio Integrated Development Environment

Debugging Linux Applications Running on the R-Car
(with the ETM as an Analysis Tool)

4.2 Operation on e? studio

4.2.1 Confirming the Trace Capture Range
This section describes how to check the address range for capturing trace data.

Start e? studio on the Host PC and open the target project created in "3.3.1 Create the Target Project".

Set the Debug configuration and start debugging the target project.

For details on setting the Debug configuration, please refer to “4. Connecting a Debugger” in “e? studio
Integrated Development Environment Debugging Linux Applications Running on the R-Car (Connection
Edition), R21AN0025EJ0100".

Select [Window] -> [Show View] -> [Disassembly] to display [Disassembly] window.

Check the address to start and stop capturing trace data in the [Disassembly] window. The address checked
here will be used in "4.2.3 Displaying Trace Data".

The address to start the capturing operation is called “Trigger address to start the capture”, and the address
to stop the capture is called “Trigger address to stop the capture”. “Start / end address of capture range”
specifes the area to capture data.

Figure 4-4 is an example of referencing the address when starting the capture with the mainstart function
and stopping the capture with the mainend function. Check the addresses of the range to be captured (red
frame in the figure) by referring to the function label.

Example of trace capture range:

e Trigger address to start / stop the capture: Oxaaaaaaaa0794 / Oxaaaaaaaa07b4

e Start/ end address of capture range: Oxaaaaaaaa0774 / Oxaaaaaaaa08a4

Make sure to set “Start / end address of capture range” to be wider than “Trigger address to start / stop the

capture”.

B80B0aaaaaaaad76t  Ldp x29, x30, [sp],#32 YUUUdddddddauool @
0000aaaaaaaad’6d ret 0000aaaaaaaads87o:
000023223333076€ oy
0000aaaaaaaad’?6e m,ﬁ 0000aaaazaaads’4:
s 0000aaaaaaaads7s:
0880aasaaaaad’’e b 0xa222222206€0 <register tm clones> 0000aaaaaaaab87c:
fnl: 0000aaaaaaaabBsn:
Start address of : i Stp x29, x30, [sp,#-16]! 0000aaaaaaaadsss:
capture range 000022222202077¢ mov  x29, sp 0000aaaaaaaabsss:
77¢  adrp X8, Oxaaaaaaaadooe 0000aaaaaaaadBssc:
000023aaaaaa078€  add x8, x8, #0x8b8
8080aaaaaaaalisd  pl 6xaaaaaaaab6s0 <puts@plt> 0000aaaaaaaadsgo:
00002a0a2a33078¢ nop 0000aaaaaaaabB9d:
08000a3233323078¢  1dp x29, x30, [spl,#16 0000aaaaaaaab89s:
0000aa2a222a079¢  ret 0000aaaaaaaab89c:
ainstart:
Trigger address SED %29, x30, [sp,#-16]! 9P0PaaaaaaaabBan:
to start the 00003aaaaaaald’9t mov x29, sp
B8080aaaaaaaad79c  adr X0, Oxaaaaaaaabeoe
copture w7 s e e R <o | |esevaazazaaaesad]
B000aaaaaaaadiad bl <put addaaaaabidas:
0000aaaaaaaad7at nop 0000aaaaaaaabBac:
pesnasngaasaR/a; 1op x29, x30, [sp].#16 0000aaaaaaaalsho:
00092222222207bE  ret 00BAaaaaaaaadbsbd :
= o ’:’r‘:"" o8, CERAAT 0000aaaaaaaadshs:
t::s._,: atheress 00003aaaaaaad7be  mov x29, sp 0060aaanaaaadBbc:
capture 0000aaaaaaaad7bc adrp  x0, 9xaaaananadaos 0000aaaaaaaad8co:
67cE  add X8, x0, #0x8d0 0b00aaaaaaaabs8cs:
B080aaaaaaaadicd bl Bxaaaaaaaal6S0 <puts@plt> 0000aaaaaaaab8cs:
0000aaaaaaaad7ct nop 0000aaaaaaaadscc:
benaanaRanaTCe  Ldp x29, x30, [sp].#16 0000aaaaaaaabsde:
PARSRAEARTON et 0000aaaaaaaansdd:
main:
0000aaaaaaaadldd  stp x29, x30, [sp,#-32]! 0000aaaaaaaadBds:
ABAAAAAAAAAAATHE  mau ¥39 _<n 0000aaaaaaaab8dc:

(£ etm_loop_test.c X

#include <stdio.h>
#include <stdint.h>
#include <stdbool.h>
#include <unistd.h>

— #define NUMBER_ELEMENTS 20

add

mov void fnl(void)

mov 3

blr printf(“fnl\n*);

cmp

b.ne =void mainstart(void)

Ldp :

dp printf("mainstart()\n");

1dp

ldp =~ void mainend(void)

ret

nop printf("mainend()\n");

__libc_csu
ret void main(void)
_fini:

stp uint3z t i;

mov printf("Starting ETM loop test program\n®});

1dp

ret mainstart();

st for (i = 0; i < NUMBER ELEMENTS; is+)

.inst

.inst fnl();

rsubhn2 }

.inst mainend() ;

.inst it }

.inst T UNUETIneq

rsubhn2 v13.8h, vll.4s, v9.4s

Ldnp w5, w27, [x19,#-224]

.inst

imet

0x00000029 ; undefined

BwBODBABAR . undafinad

Figure 4-4 Example of Addresses
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e2studio Integrated Development Environment Debugging Linux Applications Running on the R-Car
(with the ETM as an Analysis Tool)

4.2.2 Creating a “Tracing” Project
Select [File] -> [New] -> [Project...] to open the [New Project] dialog box.

File JEdit Source Refactor Navigate Search Project RenesasViews Run Window Help
New Shift+AlE+N P Renesas C/C++ Project » r
OpenFile... R-Car CMake Project
3 Open Projects from File System... [ Makefile Project with Existing Code
Recent Files » [E] C/C++ Project
lose Editor 9 Project...
“lose All Editors Project (Adds C/C++ Nature)
Save &g
save As % Folder

Figure 4-5 Operation for create Tracing Project (1)

Select [Tracing Project] in the [New Project] dialog box and click on the [Next] button.

When the [Tracing Project] dialog box appears, enter the desired project name and click on the [Finish]
button.

New Project o & Tracing Project o
Select a wizard = Tracing Project

Create a new Tracing project Create a Tracing Project]

Wizards: .
Project name:l R-CarV4H_sample_Tracing I

type filter text
Use default location
» (= General

b C/CH Location ome/exec/e2_studio/workspace/R-CarV4H_s
b (= Java 7| Create Birectorv For Proiect

il Tracing Project
Xamples

Show All wizards.

@ Ba Cancel Finis @ < Back lext > Cancel

Figure 4-6 Operation for create Tracing Project (2)
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e2studio Integrated Development Environment

(with the ETM as an Analysis Tool)

Debugging Linux Applications Running on the R-Car

Select “Fetch Remote Traces...” from the menu with right clicking your created Tracing project to open the
[Fetch Remote Traces] dialog box.

File Edit Source Refactor Navigate Search Project Renes|
% || ¥ @ ||% Debug 7] R-CarV4H_sample Debug

5 Project Explorer x BE% v § = 0
» =5 R-CarV4H_sample
~ 1=} R-Carv4H_sample_Tracing

% Experiments [0]

OpenTrace...

Open As Experiment... 3
Impork...

¥ New Folder...

¥ Clear

Import Trace Package...
£ Fetch Remote Traces...

Manage XML analyses...
Apply Time Offset...
Clear Time Offset

&1 Refresh

|

Figure 4-7 Operation for create Tracing Project (3)

Click on the [Manage Profiles] button to open the [Preferences (Filtered)] dialog box.

Fetch Remote Traces o X

Remote Profile

Select remote profile|

Profile name: | new profile ~ [ Manage Profiles

Nodes: remote_target_trace_location (ssh://root@192.168.0.20)

Into Folder: /R-Carv4H s

Options
Overwrite existing trace without warning

@' Ba Next > Cancel

Figure 4-8 Operation for create Tracing Project (4)
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e2studio Integrated Development Environment Debugging Linux Applications Running on the R-Car
(with the ETM as an Analysis Tool)

In the [Preferences (Filtered)] dialog box, set “Profile element details” for SSH connection as shown in Figure
4-9, Figure 4-10 and Figure 4-11 respectively.

e URI: Specify the root user name and IP address of the target (R-Car V4H reference board).

Preferences (Filtered) o @&
type filter text Remote Profiles

= Tracing
Remote Profiles pETRertes

~ & new profile

Add
= Qremote_target_trace_location (ssh://root@192.168.0.20)
= (& fhomefrootfe2studio (recursive) Remove
= -
Import

Profile element details:

Node name: remote_target_trace_location

URI: sshy/froot@192.168.0.20

?\ [ ,_ -.'.EJ' Cancel Apply and Close

Figure 4-9 Operation for create Tracing Project (5)

e Root path: Specify the desired directory of Linux running on the R-Car for use in remote tracing.
e Recursive: Select the checkbox.

Preferences (Filtered) o @
type filter text ® Remote Profiles

~ Tracing

Remote Profiles

= & new profile

Add
~ (¥ remote_target_trace_location (ssh//root@192.168.0.20)
~ & fhome/root/e2studio (recursive) Remove
.
Import

Profile element details:

Root path:  /home/froot/ezstudio

Recursive

Cancel Apply and Close

Figure 4-10 Operation for create Tracing Project (6)
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e2studio Integrated Development Environment

Debugging Linux Applications Running on the R-Car
(with the ETM as an Analysis Tool)

e Trace type: Select “Common Trace format: R-Car Performance Trace”.

type filter text

~ Tracing

Remote Profiles

Preferences (Filtered)

Remote Profiles

« & new profile
~ (® remote_target_trace_location (ssh:/froot@192.168.0.20)
« B fhomefrootfe2studio (recursive)

Add

Remove

Import

Profile element details:
File pattern: »

Tracetype: Common Trace Format : R-Car Performance Trace

Cancel

Apply and Close

Figure 4-11 Operation for create Tracing Project (7)

Click on the [Apply and Close] button in the [Preferences (Filtered)] dialog box to return to the [Fetch Remote

Traces] dialog box.
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4.2.3 Displaying Trace Data
Display the [C/C++] perspective.

v Q-

Q i\ B e =

Figure 4-12 Steps to view Trace Data (1)

Select [Window] -> [Show View] -> [Other] and select [Renesas R-Car Trace] -> [System Performance -
ETM Call Flow Trace] in the [Show View] dialog box.

n Window Help ( Show View x
New Window & New Connection... ~
Editor » =
type filter text
Appearance P RENESes YT
Show View » | ,: Build Targets 2 Renesas R-Car Trace
Perspective L Hal C/C++ Projects 7 QOS Control (Experimental)
Navigation 4 B console A System Performance - ARM Performance Mc
Preferences :‘ Include Browser 7rSystem Performance - Bus Monitor (QOS tra
o= Outline ArSystem Performance - Bus Monitor (QoS tra|
4 Problem Details & System Performance - DTA Trace
. i .
[ Problems 4 System Performance - DTA Trace (Experimet
& Project Explorer = System Performance-ETM Call Flow Trace
[ properties = System Performance - ETM Call Flow Trace (1
4" Search & Scripting
B System Management >Target Explorer Views
&] Tasks
& Terminal

B 2%—-F-7=a7l

= . =

Figure 4-13 Steps to view Trace Data (2)

After running “perfstub.elf’ as prepared in “4.1 Preparation for Acquiring Trace Data”, select the [Connect]
button in the [ETM Call Flow Trace] window and enter the target (R-Car V4H Reference board) IP address
and Port number “9999”. Select [OK] to connect to the R-Car board.

| E» System Performance - ETM Call Flow Trace x 4§ Remote Systems g

Connect

Figure 4-14 Steps to view Trace Data (3)

Connect to target

Configure Target connection

192.168.0.20

9999

Figure 4-15 Steps to view Trace Data (4)
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Select the [Configure] button in the [ETM Call Flow Trace] window to configure the ETM.
e ARM CoreSight ETM instruction trace -> check the checkbox.
. Path to trace files -> Select a folder to store trace data.

e Tracing Project -> Select the Tracing project created in “4.2.2 Creating a “Tracing” Project”.

L S System Performance - ETM Call Flow Trace X 4§ Remote Systems 5= Contro

Configure

Figure 4-16 Steps to view Trace Data (5)

Trace data collection settings

I /home NS orkspace/Tracing I
ITracing I
@
Figure 4-17 Steps to view Trace Data (6)
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(with the ETM as an Analysis Tool)

Select [Next] and configure ARM ETM Trace settings.

e  Symbol file -> Specify the executable file built in “3.3.1 Create the Target Project”.
o  GDB file -> Specify “DebugComp/RCar/aarch64-linux-gnu-gdb”.

e  Core filter -> Enable the Core to be traced.

e  Start stop address range filters -> Enter the “Trigger address to start / stop the capture” confirmed in
“4.2.1 Confirming the Trace Capture Range”. Select the [Add] button and enter all enable Cores.

e  Address range filters -> Enter “Start / end address of capture range” confirmed in “4.2.1 Confirming the
Trace Capture Range”. Select “Included” for Range.

fpa —

ARM ETM Trace
Specify collection options
I/home_/workspace/Dehug/test1‘elf I
I/home-/.eclipse/com.renesas.platform_1 7705047/DebugComp/RCar/aarché64-linux-gnu-gdb I
Core1
Core2
Core3
Start address End address Assigned Core
OXAAAAAAAAADTSS OXAAAAAAAADTBS 0
OXAAAAAAAAADTI4 OXAAAAAAAADTB4 1
Range Start address End address Assigned Core
Included OXAAAAAAAADTT4 OXAAAAAAAADBA4 0
Included OXAAAAAAAAODTTS OXAAAAAAAADBA4S 1
?

Figure 4-18 Steps to view Trace Data (7)

Select the [Finish] button to complete the settings.
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Select [Start trace collection] in the [ETM Call Flow Trace] window to start the trace.

= System Performance - ETM Call Flow Trace X #§ Remote Systems 5= Control

= i

Start Trace collection

Figure 4-19 Step to view Trace Data (8)

Display the [Debug] perspective and run the program with the [Resume] button.

Figure 4-20 Step to view Trace Data (9)

When the program finishes running, confirm the [ETM Call Flow Trace] window in the [C/C++] perspective.

Select [Stop Trace collection] to end trace.

o-

Sh System Performance - ETM Call Flow Trace X #§ Remote Systems 5= Control
»E

= IS

Stop Trace collection

Figure 4-21 Step to view Trace Data (10)
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e2studio Integrated Development Environment

Trace data is generated in the “Traces” directory within the Tracing project.
Double-click "trace_ YYYYMMDD_HHMMSS" to display the list of trace files.

Select [Views] -> [ARM ETM Trace Analysis Module] -> [System Performance — ETM Call Flow Trace] to
view ETM trace data.

File Edit Source Refactor

Navigate Search Project RenesasViews Run Window Help

trace_20231207_024923

| [cseadcoosseorsarse [ETv |

5V N I I

Jex=2, address=0xaaaaaaaad7ses

% | % || @ | % Debug [ etm_test Debug = = & New Connection. R iR iaigErQ- Q @ BS gfcss 4 Debug G Tracing
25 Project Explorer x =01 § = O & trace 20231207 031249 X = O g outline x =0
» 5 etm,_test (ir . e Core  Event Type Linked Core algorithm Algorithm Contents There is no active editor that provides an outline.
» & MyTracingProject
5 s
- & Tradi
b'T':aEmiHment; - 1697544933228858184 ETM ARM 2 arm_core_index=2, address=0x232232330794
lﬂT:::es I 1698246009987242824 ETM ARM 2 arm_core_index=2, address=0xaaaa22aa07a8
E 1698246009987242824 ETM ARM 2 arm_core_index=2, address=0xaaaaaaaal’ec

& trace_20231207_031248

1698246009989754184  ETM ARM 2 arm_core_index=2, address=0x33aaaaaa0rs
1698246009993478984 ETM ARM2 arm_core_index=2, address=0xa2aaaaaa0788
S system Performance - ETM Call Flow Trace Lemsnialinagialy ARMZ 2rm_core_index=2, address=0x2a22222a07f8
P Ty R eIl 1698246009995038024 ETM ARM2 arm_core . address=0x222223320788
b & QOS Trace Analysis Module 1698246009995038024 ETM ARM 2 arm_core. , address=0x2333333307f8
i 1698246009996474184  ETM ARM2 arm_core_| . address=0xa32223320788
. @ Stabistics 1698246009996474184  ETM ARM2 am_core i , address=0x322233330718
i 1698246009997925704 ETM ARM2 arm_core_index=2, address=0xa33aa2aa0788
2 1698246009997925704  ETM ARM2 arm_core_index=2, address=0xa23aa2aa0718
i M;R::g::w i 1698246009999407944  ETM ARM2 2, address=0xa28222320768
S e RS 1698246009999407944  ETM ARM2 , address=0x2222233a07F8
o = 1698246010001189704 ETM ARMZ , address=0xa32223320768
1698246010001189704  ETM ARM2 arm_core_index=2, address=0xa22aa22307f8
[#2 Problems & Console [ Properties &} A% —F « ¥=aFJL =- System Performance -ETM Call Flow Trace x 4 Remote Systems E= Control G L
F EE DEI B -l e oA~
T 15:00:09.985  15:00:09.990  1500:09.995  1500:10.000  1500:10.005  15:00:10.010  15:00:10015  15:00:10.020
¥ Unknown Source

 Unknown Symbol

Oxassssasa0788

[R———

Oxaaa22a220728 [ ]
Oxaasaaaaabec L]
rem—y
—

Figure 4-22

Step to view Trace Data (11)
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General Precautions in the Handling of Microprocessing Unit and Microcontroller
Unit Products

The following usage notes are applicable to all Microprocessing unit and Microcontroller unit products from Renesas. For detailed usage notes on the
products covered by this document, refer to the relevant sections of the document as well as any technical updates that have been issued for the products.
1. Precaution against Electrostatic Discharge (ESD)

A strong electrical field, when exposed to a CMOS device, can cause destruction of the gate oxide and ultimately degrade the device operation. Steps
must be taken to stop the generation of static electricity as much as possible, and quickly dissipate it when it occurs. Environmental control must be
adequate. When it is dry, a humidifier should be used. This is recommended to avoid using insulators that can easily build up static electricity.
Semiconductor devices must be stored and transported in an anti-static container, static shielding bag or conductive material. All test and
measurement tools including work benches and floors must be grounded. The operator must also be grounded using a wrist strap. Semiconductor

devices must not be touched with bare hands. Similar precautions must be taken for printed circuit boards with mounted semiconductor devices.
2. Processing at power-on

The state of the product is undefined at the time when power is supplied. The states of internal circuits in the LSI are indeterminate and the states of
register settings and pins are undefined at the time when power is supplied. In a finished product where the reset signal is applied to the external reset
pin, the states of pins are not guaranteed from the time when power is supplied until the reset process is completed. In a similar way, the states of pins
in a product that is reset by an on-chip power-on reset function are not guaranteed from the time when power is supplied until the power reaches the

level at which resetting is specified.
3. Input of signal during power-off state

Do not input signals or an I/0 pull-up power supply while the device is powered off. The current injection that results from input of such a signal or I/0
pull-up power supply may cause malfunction and the abnormal current that passes in the device at this time may cause degradation of internal

elements. Follow the guideline for input signal during power-off state as described in your product documentation.
4. Handling of unused pins

Handle unused pins in accordance with the directions given under handling of unused pins in the manual. The input pins of CMOS products are
generally in the high-impedance state. In operation with an unused pin in the open-circuit state, extra electromagnetic noise is induced in the vicinity of
the LSI, an associated shoot-through current flows internally, and malfunctions occur due to the false recognition of the pin state as an input signal

become possible.
5. Clock signals

After applying a reset, only release the reset line after the operating clock signal becomes stable. When switching the clock signal during program
execution, wait until the target clock signal is stabilized. When the clock signal is generated with an external resonator or from an external oscillator
during a reset, ensure that the reset line is only released after full stabilization of the clock signal. Additionally, when switching to a clock signal

produced with an external resonator or by an external oscillator while program execution is in progress, wait until the target clock signal is stable.
6. Voltage application waveform at input pin

Waveform distortion due to input noise or a reflected wave may cause malfunction. If the input of the CMOS device stays in the area between V.
(Max.) and Vi1 (Min.) due to noise, for example, the device may malfunction. Take care to prevent chattering noise from entering the device when the

input level is fixed, and also in the transition period when the input level passes through the area between Vi (Max.) and Vix (Min.).
7. Prohibition of access to reserved addresses

Access to reserved addresses is prohibited. The reserved addresses are provided for possible future expansion of functions. Do not access these

addresses as the correct operation of the LSl is not guaranteed.
8. Differences between products

Before changing from one product to another, for example to a product with a different part number, confirm that the change will not lead to problems.
The characteristics of a microprocessing unit or microcontroller unit products in the same group but having a different part number might differ in terms
of internal memory capacity, layout pattern, and other factors, which can affect the ranges of electrical characteristics, such as characteristic values,
operating margins, immunity to noise, and amount of radiated noise. When changing to a product with a different part number, implement a system-

evaluation test for the given product.



Notice

1. Descriptions of circuits, software and other related information in this document are provided only to illustrate the operation of semiconductor products
and application examples. You are fully responsible for the incorporation or any other use of the circuits, software, and information in the design of
your product or system. Renesas Electronics disclaims any and all liability for any losses and damages incurred by you or third parties arising from the
use of these circuits, software, or information.

2. Renesas Electronics hereby expressly disclaims any warranties against and liability for infringement or any other claims involving patents, copyrights,
or other intellectual property rights of third parties, by or arising from the use of Renesas Electronics products or technical information described in this
document, including but not limited to, the product data, drawings, charts, programs, algorithms, and application examples.

3. Nolicense, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights of Renesas Electronics
or others.

4. You shall be responsible for determining what licenses are required from any third parties, and obtaining such licenses for the lawful import, export,
manufacture, sales, utilization, distribution or other disposal of any products incorporating Renesas Electronics products, if required.

5. You shall not alter, modify, copy, or reverse engineer any Renesas Electronics product, whether in whole or in part. Renesas Electronics disclaims any
and all liability for any losses or damages incurred by you or third parties arising from such alteration, modification, copying or reverse engineering.

6. Renesas Electronics products are classified according to the following two quality grades: “Standard” and “High Quality”. The intended applications for
each Renesas Electronics product depends on the product’s quality grade, as indicated below.

"Standard": Computers; office equipment; communications equipment; test and measurement equipment; audio and visual equipment; home

electronic appliances; machine tools; personal electronic equipment; industrial robots; etc.
"High Quality": Transportation equipment (automobiles, trains, ships, etc.); traffic control (traffic lights); large-scale communication equipment; key
financial terminal systems; safety control equipment; etc.

Unless expressly designated as a high reliability product or a product for harsh environments in a Renesas Electronics data sheet or other Renesas
Electronics document, Renesas Electronics products are not intended or authorized for use in products or systems that may pose a direct threat to
human life or bodily injury (artificial life support devices or systems; surgical implantations; etc.), or may cause serious property damage (space
system; undersea repeaters; nuclear power control systems; aircraft control systems; key plant systems; military equipment; etc.). Renesas
Electronics disclaims any and all liability for any damages or losses incurred by you or any third parties arising from the use of any Renesas
Electronics product that is inconsistent with any Renesas Electronics data sheet, user’'s manual or other Renesas Electronics document.

7. No semiconductor product is absolutely secure. Notwithstanding any security measures or features that may be implemented in Renesas Electronics
hardware or software products, Renesas Electronics shall have absolutely no liability arising out of any vulnerability or security breach, including but
not limited to any unauthorized access to or use of a Renesas Electronics product or a system that uses a Renesas Electronics product. RENESAS
ELECTRONICS DOES NOT WARRANT OR GUARANTEE THAT RENESAS ELECTRONICS PRODUCTS, OR ANY SYSTEMS CREATED USING
RENESAS ELECTRONICS PRODUCTS WILL BE INVULNERABLE OR FREE FROM CORRUPTION, ATTACK, VIRUSES, INTERFERENCE,
HACKING, DATA LOSS OR THEFT, OR OTHER SECURITY INTRUSION (“Vulnerability Issues”). RENESAS ELECTRONICS DISCLAIMS ANY AND
ALL RESPONSIBILITY OR LIABILITY ARISING FROM OR RELATED TO ANY VULNERABILITY ISSUES. FURTHERMORE, TO THE EXTENT
PERMITTED BY APPLICABLE LAW, RENESAS ELECTRONICS DISCLAIMS ANY AND ALL WARRANTIES, EXPRESS OR IMPLIED, WITH
RESPECT TO THIS DOCUMENT AND ANY RELATED OR ACCOMPANYING SOFTWARE OR HARDWARE, INCLUDING BUT NOT LIMITED TO
THE IMPLIED WARRANTIES OF MERCHANTABILITY, OR FITNESS FOR A PARTICULAR PURPOSE.

8. When using Renesas Electronics products, refer to the latest product information (data sheets, user's manuals, application notes, “General Notes for
Handling and Using Semiconductor Devices” in the reliability handbook, etc.), and ensure that usage conditions are within the ranges specified by
Renesas Electronics with respect to maximum ratings, operating power supply voltage range, heat dissipation characteristics, installation, etc.
Renesas Electronics disclaims any and all liability for any malfunctions, failure or accident arising out of the use of Renesas Electronics products
outside of such specified ranges.

9. Although Renesas Electronics endeavors to improve the quality and reliability of Renesas Electronics products, semiconductor products have specific
characteristics, such as the occurrence of failure at a certain rate and malfunctions under certain use conditions. Unless designated as a high reliability
product or a product for harsh environments in a Renesas Electronics data sheet or other Renesas Electronics document, Renesas Electronics
products are not subject to radiation resistance design. You are responsible for implementing safety measures to guard against the possibility of bodily
injury, injury or damage caused by fire, and/or danger to the public in the event of a failure or malfunction of Renesas Electronics products, such as
safety design for hardware and software, including but not limited to redundancy, fire control and malfunction prevention, appropriate treatment for
aging degradation or any other appropriate measures. Because the evaluation of microcomputer software alone is very difficult and impractical, you
are responsible for evaluating the safety of the final products or systems manufactured by you.

10. Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental compatibility of each Renesas
Electronics product. You are responsible for carefully and sufficiently investigating applicable laws and regulations that regulate the inclusion or use of
controlled substances, including without limitation, the EU RoHS Directive, and using Renesas Electronics products in compliance with all these
applicable laws and regulations. Renesas Electronics disclaims any and all liability for damages or losses occurring as a result of your noncompliance
with applicable laws and regulations.

11. Renesas Electronics products and technologies shall not be used for or incorporated into any products or systems whose manufacture, use, or sale is
prohibited under any applicable domestic or foreign laws or regulations. You shall comply with any applicable export control laws and regulations
promulgated and administered by the governments of any countries asserting jurisdiction over the parties or transactions.

12. ltis the responsibility of the buyer or distributor of Renesas Electronics products, or any other party who distributes, disposes of, or otherwise sells or
transfers the product to a third party, to notify such third party in advance of the contents and conditions set forth in this document.

13. This document shall not be reprinted, reproduced or duplicated in any form, in whole or in part, without prior written consent of Renesas Electronics.

14. Please contact a Renesas Electronics sales office if you have any questions regarding the information contained in this document or Renesas
Electronics products.

(Note1) “Renesas Electronics” as used in this document means Renesas Electronics Corporation and also includes its directly or indirectly controlled

subsidiaries.
(Note2) “Renesas Electronics product(s)” means any product developed or manufactured by or for Renesas Electronics.

Corporate Headquarters
TOYOSU FORESIA, 3-2-24 Toyosu,
Koto-ku, Tokyo 135-0061, Japan

www.renesas.com

Trademarks

Renesas and the Renesas logo are trademarks of Renesas Electronics
Corporation. All trademarks and registered trademarks are the property
of their respective owners.

(Rev.5.0-1 October 2020)

Contact information

For further information on a product, technology, the most up-to-date
version of a document, or your nearest sales office, please visit:
www.renesas.com/contact/.
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