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Renesas RA Family 

Getting Started with CoreMark Benchmarking 
Introduction  
As processors in embedded systems become more complex, more sophisticated benchmarks are needed for 
a better understanding of performance and analysis.  

CoreMark is a modern and sophisticated benchmark that is recommended by ARM® and allows you to 
accurately measure the performance of a processor. Rather than using arbitrary and synthetic code, 
CoreMark uses basic data structures and algorithms that are common in any embedded application.  

Using CoreMark is encouraged due to its ANSI C compliance and the fact that it is designed to ensure that 
compilers cannot pre-compute numbers to influence the results and also so that it does not make any library 
calls during the benchmarked portion of the code.  

Running CoreMark produces a single-number score allowing users to make quick comparisons between 
processors. Results can be uploaded to the CoreMark website for certification as CoreMark has a standard 
format for reporting results. 

This document aims to present and explain the results and the process of benchmarking Renesas RA MCUs 
using CoreMark. 

This application note walks you through all the steps necessary to benchmark using CoreMark. 

Required Resources 
Development tools and software 

• e2 studio v2023-01 
• Renesas Flexible Software Package (FSP) v4.3.0 
• Arm Compiler 6.15 
• IAR Embedded Workbench v9.32.1 
 
Hardware 

• Renesas RA kit: EK-RA6M5 

Reference Manuals 
• RA Flexible Software Package Documentation Release v4.3.0 
• User’s Manual: Renesas RA6M5 Group User’s Manual Rev.1.10 
• Schematics: EK-RA6M5-v1.0 
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1. CoreMark Project 
The official CoreMark source is available at EEMBC GitHub. As we plan to use CoreMark on a bare-metal 
target, the source files we are going to use consist of the following C source and header files:  

• coremark.h  
• core_main.c  
• core_list_join.c  
• core_matrix.c  
• core_state.c  
• core_util.c  
• core_portme.c  
• core_portme.h  
• cvt.c 
• ee_printf.c 

 

The three key algorithms used are related to linked lists, matrix multiplication, and state machines.  

At EEMBC GitHub you will also find more information on the rules for building and running the CoreMark 
code.  

The procedure to create a CoreMark project for Renesas RA MCUs is as follows. 

• Create a Bare-Metal Minimal Project using e2 studio and Flexible Software Package (FSP) 
• Copy CoreMark source code to the “src” folder  
• Add a 32-bit general-purpose timer (GPT) to the project 
• Change the main stack size setting to 0x4000 to accommodate CoreMark benchmarking 
• Exclude the main.c generated by FSP from the build   
• Update project optimization with the maximum speed option 
• Port core_portme.h, core_portme.c to add necessary code for the GPT   
• Port ee_printf.c to print benchmarking result.  

This document explains the procedure for EK-RA6M5 but the same can be applied to other RA MCUs.   

2. Run CoreMark on Renesas RA MCUs 
Apart from the official CoreMark source, in order to be able to replicate exactly the process used in 
benchmarking the RA MCUs, you will need the e2 studio IDE together with FSP. You can download and 
install setup_fsp_v4_3_0_e2s_v2023-01.exe from https://github.com/renesas/fsp/releases 

Moreover, you will need the IAR Arm compiler available at https://www.iar.com/products/architectures/arm/ 
and the Arm compiler available at https://developer.arm.com/documentation/ka005198/latest. You can use 
Arm compiler in Keil MDK installation for CoreMark benchmarking.       

2.1 Integrating Toolchains with e2 studio 
2.1.1 IAR Embedded Workbench Plugin 
Download and install IAR Embedded workbench before you integrate IAR compiler with e2 studio.   

Start e2 studio, then select “Help -> IAR Embedded Workbench plugin manager” 

https://github.com/eembc/coremark
https://github.com/eembc/coremark
https://github.com/renesas/fsp/releases
https://www.iar.com/products/architectures/arm/
https://developer.arm.com/documentation/ka005198/latest
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Figure 1.   Select IAR Embedded Workbench Plugin Manager 
 

You choose the desired toolchain and press install. 

 

Figure 2.   Select IAR Plugin  
The bottom right corner of e2 studio IDE will show configuration progress. 

 

Figure 3.   IAR Configuration Progress  
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Press “Next”, then “Next”. Accept the terms of the license agreements then click “Finish”.  

 

Figure 4.   Install IAR Embedded Workbench Plugin 
The bottom right corner of e2 studio IDE will show the installation progress. 

 

Figure 5.  IAR Plugin Installation Process 
Wait for the plugin to be installed and click “Restart Now” to complete the installation process. 

 

Figure 6.  Restart e2 studio 

2.1.2 Integrate with Arm Compiler 
Download and install Arm compiler or Keil MDK before you integrate Arm compiler with e2 studio. 

Start e2 studio, then select “Window -> Preferences” to add toolchains to e2 studio. 
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Figure 7.  e2 studio Preferences  
Select the desired Arm Compiler toolchain, then click “Apply and Close” to add the Arm compiler to e2 
studio.    

 

Figure 8.   Add Arm Compiler to e2 studio 
If Arm compiler is not present in the Toolchains windows, click “Add”, then browse to the toolchain folder, 
e.g., C:\Keil_v5\ARM\\ARMCLANG\bin    
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Figure 9.  Add Toolchain’s Path 

2.2 Create CoreMark e2 studio Project Used for Benchmarking using IAR Compiler  
Ensure you integrated IAR compiler with e2 studio before creating a CoreMark project.  

On e2 studio, select “File -> New-> C/C++ Project, then click “Next”.  

 

 

Figure 10.   Select C/C++ Template 
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Name your project an appropriate name, e.g., RA6M5_CoreMark_IAR for EK-RA6M5 kit using IAR compiler.  

 

 

Figure 11.   Name Your Project 
Select the Board, Device, and Toolchain you want to use for benchmarking. 

 

Figure 12.   RA Project Options 
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Select Flat (Non-TrustZone) Project. 

 

Figure 13.   Flat Project Selection 
 

After this step, select Executable project type with No RTOS.  
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Figure 14.   Select No RTOS Project 
Select Bare Metal – Minimal Project Template. Click “Finish” to generate the project. 

 

Figure 15.   Bare Metal Minimal Option 
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2.3 Add CoreMark to e2 studio Project 
Copy CoreMark source code to the “src” folder in your newly created project. The project structure should 
look as follows. 

 

Figure 16.   CoreMark Project 
You now need to add a periodic timer and modify the core_portme.c source file in order to use the modified 
barebones_clock(), portable_init(core_portable *p, int *argc, char *argv[]) and portable_fini(core_portable *p)  
functions.  

To add a new periodic timer, open the configuration.xml file and go to Stacks. You should see something 
similar to the picture below. 

 

Figure 17.   Stack Configuration 

2.4 Add Timer for Benchmarking 
The next step is to add a New Stack, then select Timers and, finally Timer, General PWM(r_gpt). 
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Figure 18.   Add GPT Timer 
After adding the GPT timer, you need to edit the settings. Clicking on the block representing the newly added 
GPT timer, then go to Properties Window. You use this Properties window to change the timer’s name to 
g_timer_periodic, the period to 50, and the period unit to Seconds. You also need to expand the Interrupts 
block, add the Callback as timer_callback and set the Priority to 2. The following image captures the changes 
needed. 
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Figure 19.   GPT Configuration 

2.5 Update Main Stack   
Change the Main Stacks Size in BSP properties to 0x4000. 

 

Figure 20.   Change Main Stack Size 



Renesas RA Family Getting Started with CoreMark Benchmarking  

R11AN6876EU0100  Rev1.00  Page 14 of 29 
Mar.20.23  

Click “Generate Project Content”, then the next step is to modify the source files.  

Right click on the ra_gen\main.c and exclude it from the Build, so there is no conflict with the main from 
core_main.c. 

 

Figure 21.   Exclude main.c from Build 

2.6 Port CoreMark Code 
You modify the core_portme.h and the core_portme.c in the “src” folder.  

In core_portme.h, add “#include <stddef.h>” before the code “typedef size_t   ee_size_t;”, as shown below. 
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Figure 22.   Add “#include <stddef.h>” 
 

Also, in core_portme.h, modify the “#define COMPILER_FLAGS” depending on the toolchain used. If you 
use IAR Compiler version 9.32.1, change it to #define COMPILER_FLAGS "High Speed; No size 
constraints".  

The code should look as follows. 

 

Figure 23.  Modify core_portme.h 
In core_portme.c, before the barebones_clock() function, add below code. 

 

Figure 24.   Modify core_portme.c 
 

You can check and correct the CLOCKS_PER_SEC setting by getting the correct value from the 
clock_frequency, shown in the figure below when running the project for the first time.    
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Figure 25.   Check CLOCK_PER_SEC Setting  
Change the barebones_clock() functions as follows. 

 

Figure 26.   bareborns_clock() Function 
Then change the portable_fini(core_portable *p), portable_init(core_portable *p, int *argc, char *argv[]) to 
add the GPT timer that is needed for benchmarking.  
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Figure 27.   portable_init Function 
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Figure 28.   portable_fini Function 
 

At the end of the file, add the callback method function of the GPT timer. 

 

Figure 29.   Add timer_callback to core_portme.c 
 

In ee_printf.c, change the uart_send_char(char c) and add the below code for printing benchmarking results. 

 

Figure 30.   Add uart_send_char Function 
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In the project properties setting, add “ITERATIONS=8000” to IAR C/C++ Compiler for ARM->Preprocessor. 

 

Figure 31.   Preprocessor Setting 
In the project properties setting, change IAR C/C++ Compiler for ARM->Optimization to “High, Speed” with 
“No size constraints”. 
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Figure 32.   Optimization Setting 
 

Now you can build the project without errors. 

2.7 Create CoreMark e2 studio Project Used for Benchmarking using Arm Compiler  
Ensure you integrated the Arm compiler with e2 studio before creating a CoreMark project. Select the Board, 
Device, and Toolchain you want to use for benchmarking and process to create an Arm compiler-based 
project similar to the IAR compiler. Follows sections 2.3, 2.4, 2.5, and 2.6 to add the GPT module, configure 
your project, and port the CoreMark. Note that you need a commercial license to use “--lto” option in Arm 
Compiler. 



Renesas RA Family Getting Started with CoreMark Benchmarking  

R11AN6876EU0100  Rev1.00  Page 21 of 29 
Mar.20.23  

 

Figure 33.   Create An Arm Compiler - Based Project Options 
Also, in core_portme.h, modify the “#define COMPILER_FLAGS” depending on the toolchain used. In the 
case of Arm Compiler, change it to "-Omax".  

The code should look as follows. 

 

Figure 34.   Modify "#define COMPILER_FLAGS" 
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In the project’s Properties-> ARM C Compiler 6.15->Miscellaneous->Other flags, add “-Omax”. 

 

 

 

Figure 35.   Add “-Omax” Option to Project Settings 
In the project’s Properties-> ARM Linker  6.15->Miscellaneous->Other flags, add “--lto”. 

 

 

 

Figure 36.   Add “--lto” Option to Project Settings. 
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2.8 Run CoreMark Project  
2.8.1 Board Setup 
The EK-RA6M5 kit has a few switch settings which must be configured before running the projects 
associated with this application note. In addition to these switch settings, the boards also contain a USB 
debug port and connectors to access the J-Link® programming interface. 

Table 1. Switch settings for EK-RA6M5 
Switch Setting 
J8 Jumper on pins 1-2 
J9 Open 

 

 

Figure 37.   J8 and J9 on EK-RA6M5 
The figure below shows the picture of the EK-RA6M5 kit. 

 

Figure 38.   EK-RA6M5 
Connect the board to your PC using the USB cable into the port labeled “Debug1”.  
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2.8.2 Add Run Commands to Print Out Benchmarking Result.  
In Debug Configuration, add the below command.  

dprintf portable_fini,"%s",uart_buffer 

 

Figure 39.   Add dprint Command  

2.8.3 Run The e2 studio Project 
After successfully building the project, it can be debugged using Renesas GDB Hardware Debugging. Right 
click on the project -> Debug AS -> Renesas GDB Hardware debugging or “Debug Configurations…” and 
choose the desired one. 
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Figure 40.   Debug the Project 
The program should stop in the Reset_handler. 
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Figure 41.   Debug the Project (cont’d) 
Click the Resume button. The program will stop in main from core_main.c, click the Resume button again to 
run the project. 

After a while, the program will stop in portable_fini, and the CoreMark scores will be available in the 
Debugger Console window, as shown below. 

 

Figure 42.   CoreMark Score with IAR Compiler 

 

Figure 43.   CoreMark Score with Arm Compiler 
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3. Verify RA Benchmarking Results 
You can verify your results by referring to RA CoreMark results published on the EEMBC website, as shown 
below. 

 

 

Figure 44.   RA Coremark scores published on EEMBC website  
 

4. General Guidelines for CoreMark Benchmarking 
Since target devices that contain Arm processors may have a wide variety of memories and memory 
hierarchies, your CoreMark project should be compiled using memory correctly and efficiently. Depending on 
the compiler, you can achieve this by correctly editing your linker script or scatter files.  

Since CoreMark is a small benchmark, it should be run multiple times to obtain reproducible numbers. 

Arm recommends performing two validation runs followed by at least ten profile runs. The results can be 
calculated by the average for the profile runs. These steps are necessary to minimize the variation caused by 
inconsistent processor states.  

 

5. References 
EEMBC’s CoreMark®  https://www.eembc.org/coremark/ 
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Website and Support 
Visit the following vanity URLs to learn about key elements of the RA family, download components and 
related documentation, and get support.  

RA Product Information   www.renesas.com/ra   
RA Product Support Forum   www.renesas.com/ra/forum   
RA Flexible Software Package  www.renesas.com/FSP  
Renesas Support   www.renesas.com/support  
 
  

http://www.renesas.com/ra
https://www.renesas.com/ra/forum
http://www.renesas.com/FSP
https://www.renesas.com/support
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