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Renesas Synergy™ Platform 

Debugging ThreadX RTOS Applications  
Using TraceX  
ThreadX® is an RTOS from Express Logic which is based on a high-performance embedded kernel. This application 
note provides procedures to check ThreadX thread and object states (referred to as resources) during the development 
of applications in e2 studio for Renesas Synergy™. The procedure for starting TraceX® is also explained. For the 
ThreadX specifications and functions, visit the Express Logic (http://rtos.com/) website. For TraceX specifications and 
functions, visit the Synergy Software (https://www.renesas.com/us/en/products/synergy.html) page. Under the 
Development Tools tab, select TraceX. 

This application note explains examples using a project called Blinky with ThreadX that is available after installing 
the Renesas Synergy™ Software Package (SSP). For procedures covering operations with Blinky with ThreadX, see 
the Renesas Synergy™ e2 studio v6.2 or Greater Getting Started Guide available on the Synergy Solutions Gallery 
(https://www.renesas.com/us/en/products/synergy/gallery.html). This document describes general usage of e2 studio.  

This application note supports SSP version 1.4.0 and later and e2 studio version 6.2.0 and later. 

Target Environment 
The operations covered in this document were confirmed in the following environment. 

• Renesas SynergyTM Software Package (SSP) v1.4.0 or later 
• e2 studio for Renesas Synergy™ v6.2.0 or later 
• ThreadX (requires development/production license, see section 5.1, Licenses for ThreadX) 
• Development Kit for DK-S7G2 Synergy MCU Group 
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1. Blinky Project with ThreadX  
Using the Blinky Project with ThreadX for this module demonstrates TraceX usage to track threads, as well as the 
Debug view in e2 studio for executed functions.  

To create a new Blinky with ThreadX project, perform the following steps: 

1. Open Synergy Configuration e2 studio. Click File > New > Synergy C/C++ project. 

 

Figure 1   Creating a new project 
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2. Select the Renesas Synergy C Executable Project template (Figure 2). Click Next to continue.  

 
Figure 2   Selecting the Synergy C project template 
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3. Enter the name of the project, such as Blinky_DK_S7G2, as required in the dialog box (Figure 3). Click Next. 

4. Make sure the License file (Figure 3) is set to the new SSP version 1.4.0.  

  

Figure 3   Entering the project name and license file 
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5. Make sure the SSP version and the board values are correct in the Device Selection (Figure 4). Click Next to 
continue. 

 

Figure 4   Selecting the board and device version  
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6. Select the Project Template Selection type as Blinky with ThreadX (). Click Finish. 

 

 

Figure 5   Selecting a project template 
A new project is added into the project explorer window with the provided name.  
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2. Using TraceX 
TraceX is software that displays transitions of threads running under the ThreadX operating system on the PC. TraceX 
can be directly started from the e2 studio. The following procedures describe how to download, install, and start using 
TraceX. 

2.1 Installing TraceX 
1. Select TraceX under the Development Tools tab on the Renesas Synergy™ Gallery 

(https://synergygallery.renesas.com/) website (Figure 6).  

 

Figure 6   Navigating to the TraceX download page  
2. On the TraceX download page, click DOWNLOAD (Figure 7) to download and install TraceX on the PC. 

 

Figure 7   Downloading TraceX 
3. Once downloaded, unzip the application file. 

Note:  Always Run the installer setup as an Administrator when installing TraceX software. To become an 
Administrator, right-click the installer setup and select Run as Administrator from the drop-down menu. If the 
installer setup is not run as an Administrator, the installation will exit with an error, such as missing files. 

https://synergygallery.renesas.com/
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2.2 Procedure for Starting TraceX 
This procedure describes how to start TraceX from the e2 studio. 

1. Register the source code files for ThreadX in the e2 studio by using the configuration editor (Figure 8 and Figure 9) 
for the e2 studio version installed.  

2. Open the Threads tab page, specify items (1) to (5) in order, and register the source files. 

 

Figure 8   Registering source files for ThreadX (v5.3.1 and earlier versions of the e2 studio) 

 

Figure 9   Registering source files for ThreadX (v5.3.1 and later versions of e2 studio) 
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3. Disable the Show linkage warning shown in Figure 10 (e2 studio v6.2.0 or later). 

 

Figure 10   Disabling the Linkage Warning Error 
4. Check the Properties tab page and set the Event Trace to Enabled. Set the Trace Buffer Name, Trace Buffer 

Size, and Trace Buffer Number Registries (see Figure 11), then update and build the project. 

 

Figure 11   Setting the Event Trace 
Note:  The Trace Buffer Size on the S1 Devices is less than 16 KB and is based on the available RAM apart from the 

application. 
5. When building is completed, start the debugger and execute the program by selecting Run > Resume from the 

menu.  

If this process is repeated twice, an LED blinks on and off with an interval of one second. You may suspend 
execution of the program by selecting Run > Suspend from the menu bar. 

6. Use TraceX to check the result of the program’s execution. Set the method of starting TraceX. When the Run > 
Launch TraceX Debugging menu item (Figure 12) is selected, a dialog box to start TraceX opens (Figure 13). 

 

Figure 12    Setting the Start of TraceX Debugging 
Note: The parameters to launch TraceX in Figure 13 are the values specified in Figure 11.  
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Figure 13    Setting the parameters for starting TraceX 

7. Click OK. TraceX starts and transitions from the program executions that are displayed. Alternatively, the path to 
TraceX can be specified by opening the Preferences dialog box of the e2 studio from the Window > Preferences 
menu and selecting C/C++ > Renesas > TraceX. 

 

Figure 14   Setting the TraceX path 
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Figure 15   Starting TraceX 
8. After the program is executed from the Run > Resume menu, suspend execution of the program from the Run > 

Suspend menu, then start TraceX and check that the data was updated.  

When TraceX is started the second and subsequent times, you do not need to set the parameters again. Start TraceX 
from the Run > Update TraceX Data menu (Figure 16). 

 

Figure 16   Updating TraceX data 

 

Figure 17   Display after TraceX data is updated 
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3. Using the RTOS Resource View Function 
The e2 studio has an RTOS resource view function that displays the state of resources of ThreadX. This procedure 
describes how to use the RTOS resource view.  

Note:  If you are using the RTOS Resources function in e2 studio version 5.3.1 and later, refer to the 
following section. Set the Display of Executed Functions in Debut View, and set the RTOS 
Integration in Debug View to No. 

3.1 Displaying the RTOS Resources View 
Because the RTOS Resources view functions only with the debugger running, first you need to build a project, such as 
Blinky with ThreadX (see section 2.2), then start the debugger and select Renesas Views > Partner OS > RTOS 
Resources. When the Select OS dialog box displays, select ThreadX (R) as shown in Figure 18. The RTOS 
Resources view appears. 

 

Figure 18   Specifying the RTOS resources and the OS 
For e2 studio version 5.3.1 and later, select the OS in the RTOS Resources view (Figure 19 and Figure 20), rather than 
in the dialog box. 

 

Figure 19   Selecting the OS in v5.3.1 and later versions of the e2 studio 
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Figure 20   RTOS Resources view 
The tabbed pages from Thread to ReadyQueue(No.=Priority) show the state of each resource. Select a tabbed page to 
check the state of a given resource. 

Note: The Profile tab is reserved for future extensions. 
Table 1   Contents of each tabbed window 

Name of tabbed window 
in the RTOS Resources 
view 

Displayed information and 
selections Information to be displayed 

Thread 
(e2 studio v5.0.0 and 

earlier versions) 

Name Names of the threads 
Entry Functions that start each of the threads 
Status State of the thread 
Suspended Factor (Control Block*) Resource that is the source of 

suspension 
OwnedTX_MUTEX*(top) Acquired top mutex 
Priority Priority 
RunCount Number of times the thread is executed 
StackPointer Current stack pointer 
StackStart Address where the stack starts 
StackEnd Address where the stack ends 
StackSize(bytes) Stack size 

Thread 
(e2 studio v5.3.1 and later 

versions) 

Name Names of the threads 
Entry Functions that start each of the threads 
Status State of the thread 
Suspended Factor (Control Block*) Resource that is the source of 

suspension 
OwnedTX_MUTEX*(top) Acquired top mutex 
Priority Priority 
RunCount Number of times the thread has been 

executed 

Stack 
(e2 studio v5.3.1 and later 

versions) 

Name Names of the threads 
Entry Functions that started each of the 

threads 
StackPointer Current stack pointer 
StackStart Address where the stack starts 
StackEnd Address where the stack ends 
StackSize(bytes) Stack size 
MaxStackUsage(bytes) Maximum of the stack used currently 

MessageQueue 

Name Names of the message queues 
UsedCount Number of message queues in use 
FreeCount Number of available message queues 
TotalCount Total number of message queues 
MessageSize Message size 
SuspendedTX_THREAD*(top) Thread at the top of waiting threads in 

a queue 
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Name of tabbed window 
in the RTOS Resources 
view 

Displayed information and 
selections Information to be displayed 

SuspendedCount Number of suspended threads 
StartAddress Address where the message queue 

starts 
EndAddress Address where the message queue 

ends 

CountingSemaphore 

Name Names of the semaphores 
SemaphoreCount Number of semaphores 
SuspendedTX_THREAD*(top) Thread at the top of waiting threads in 

a queue 
SuspendedCount Number of suspended threads 

Mutex 

Name Names of the mutexes 
OwnerTX_THREAD* Acquiring thread 
OwnerCount Number of owners 
SuspendedTX_THREAD*(top) Thread at the top of waiting threads in 

a queue 
SuspendedCount Number of suspended threads 

EventFlag 

Name Names of the event flags 
Flag Current flag pattern 
SuspendedTX_THREAD*(top) Thread at the top of waiting threads in 

a queue 
SuspendedCount Number of suspended threads 

MemoryBlockPool 

Name Names of the memory blocks 
FreeCount Number of available blocks 
TotalCount Total number of blocks 
BlockSize(bytes) Block size 
TotalSize(bytes) Total size of memory block pools 
SuspendedTX_THREAD*(top) Thread at the top of waiting threads in 

a queue 
SuspendedCount Number of suspended threads 
StartAddress Top address of a memory block pool 

MemoryBytePool 

Name Names of the memory pools 
Free(bytes) Number of available bytes 
Total(bytes) Total size of memory byte pools 
FragmentCount Number of fragments 
SuspendedTX_THREAD*(top) Thread at the top of waiting threads in 

a queue 
SuspendedCount Number of suspended threads 
StartAddress Address where the memory byte pool 

starts 

Timer 
Name Names of the timers 
Remaining Tick Remaining time 
Re-initialization Tick Cycle time 

System SystemClock System clock 
ReadyQueue(No.=Priority) QueuedTX_THREAD*(top) Top ready thread 
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4. Displaying Executed Functions in the Debug View 
e2 studio version 5.3.1 and later has an additional feature which shows executed functions per thread (Figure 21). 

 

Figure 21   Displaying functions in thread units 
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4.1 Setting the Display of Executed Functions in the Debug View 
This feature is set in the Debug Configurations dialog box.  

1. Select the Run > Debug Configurations menu and open the Debug Configurations dialog box.  

2. Select the Debugger tab and the Debug Tool Settings tab.  

3. Set RTOS Integration in Debug View to Yes. If you select No, this feature is not available. This selection by 
default is set to Yes. 

 

Figure 22   Setting for the display of executed functions 
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4.2 Confirming the Display of Executed Functions 
This feature displays information on the following items: 

• Function names 
• Parameters and local variables 
• Register values 
In Figure 23, the blinky_thread_entry() function is selected in the Debug view, so the Variables view shows 
the local variables after the function is executed, and the Registers view shows the register values. 

 

Figure 23   Displaying local variables and registers while functions are running 

5. Appendix 
5.1 Licenses for ThreadX 
The RTOS resource functions and TraceX are available under the SSP evaluation license. However, the ThreadX source 
files are not accessible (Figure 24). To access to the ThreadX source files, the SSP development and production license 
must be registered using the following procedure. 

 

Figure 24   Source files for ThreadX are not accessible under evaluation license 

5.1.1 Registering and Storing the Development and Production License of the SSP 
Register the development and production license of the SSP by clicking Create a Developer/Production License on 
the SSP page of the Renesas Synergy website (https://www.renesas.com/us/en/products/synergy/software/ssp.html). 

https://www.renesas.com/us/en/products/synergy/software/ssp.html
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Figure 25   Checking of licenses 
If you have registered for a license, store the information in the license file. 

 

Figure 26   Displaying the license information 
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To store the license file, save the XML files for the target SSP on the PC. It is recommended that you copy these files to 
the following directory where the e2 studio is installed.  
…Renesas\e2_studio\internal\projectgen\arm\Licenses 

 

Figure 27 Storing license files 

5.1.2 Registering License Files with e2 studio 
Register the stored license files with the e2 studio. When registration is completed, the source files for ThreadX become 
accessible. When a new project is created, the license files are registered using the project wizard. If the project is 
already created, the license files are registered from the Window > Preferences menu. The following procedure 
describes registration of the Blinky with ThreadX project that is already created. 

1. Select the Window > Preferences menu to open the Properties dialog box and the C /C++> Renesas > Synergy 
License selection in the Preferences window (Figure 28). 

 

Figure 28   Selecting the Window > Preferences menu 
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2. Click the Browse (…) button and select the license file that was stored in section 5.1.1 When you click OK, the 
license file is registered.  

 

Figure 29   Registering the license in the dialog box 
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Website and Support 
Visit the following vanity URLs to learn about key elements of the Synergy Platform, download components and 
related documentation, and get support. 

 
Synergy Software    renesassynergy.com/software 
 Synergy Software Package  renesassynergy.com/ssp 
 Software add-ons   renesassynergy.com/addons 
 Software glossary   renesassynergy.com/softwareglossary 

Development tools  renesassynergy.com/tools 
 

Synergy Hardware   renesassynergy.com/hardware 
 Microcontrollers   renesassynergy.com/mcus 
 MCU glossary   renesassynergy.com/mcuglossary 
 Parametric search   renesassynergy.com/parametric 

Kits    renesassynergy.com/kits 
 

Synergy Solutions Gallery   renesassynergy.com/solutionsgallery 
 Partner projects   renesassynergy.com/partnerprojects 

Application projects  renesassynergy.com/applicationprojects 
 
Self-service support resources:  

Documentation    renesassynergy.com/docs 
Knowledgebase    renesassynergy.com/knowledgebase 
Forums     renesassynergy.com/forum 
Training     renesassynergy.com/training 
Videos    renesassynergy.com/videos 
Chat and web ticket   renesassynergy.com/support 
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product’s quality grade, as indicated below.
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equipment; industrial robots; etc.
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Unless expressly designated as a high reliability product or a product for harsh environments in a Renesas Electronics data sheet or other Renesas Electronics document, Renesas Electronics products are
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ranges.

7. Although Renesas Electronics endeavors to improve the quality and reliability of Renesas Electronics products, semiconductor products have specific characteristics, such as the occurrence of failure at a

certain rate and malfunctions under certain use conditions. Unless designated as a high reliability product or a product for harsh environments in a Renesas Electronics data sheet or other Renesas
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or damage caused by fire, and/or danger to the public in the event of a failure or malfunction of Renesas Electronics products, such as safety design for hardware and software, including but not limited to

redundancy, fire control and malfunction prevention, appropriate treatment for aging degradation or any other appropriate measures. Because the evaluation of microcomputer software alone is very difficult

and impractical, you are responsible for evaluating the safety of the final products or systems manufactured by you.

8. Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental compatibility of each Renesas Electronics product. You are responsible for carefully and

sufficiently investigating applicable laws and regulations that regulate the inclusion or use of controlled substances, including without limitation, the EU RoHS Directive, and using Renesas Electronics

products in compliance with all these applicable laws and regulations. Renesas Electronics disclaims any and all liability for damages or losses occurring as a result of your noncompliance with applicable

laws and regulations.
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(Note 2) “Renesas Electronics product(s)” means any product developed or manufactured by or for Renesas Electronics.
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