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ご注意書き 

 

１． 本資料に記載されている内容は本資料発行時点のものであり、予告なく変更することがあります。当社製品

のご購入およびご使用にあたりましては、事前に当社営業窓口で最新の情報をご確認いただきますとともに、

当社ホームページなどを通じて公開される情報に常にご注意ください。 
2. 本資料に記載された当社製品および技術情報の使用に関連し発生した第三者の特許権、著作権その他の知的

財産権の侵害等に関し、当社は、一切その責任を負いません。当社は、本資料に基づき当社または第三者の

特許権、著作権その他の知的財産権を何ら許諾するものではありません。 
3. 当社製品を改造、改変、複製等しないでください。 
4. 本資料に記載された回路、ソフトウェアおよびこれらに関連する情報は、半導体製品の動作例、応用例を説

明するものです。お客様の機器の設計において、回路、ソフトウェアおよびこれらに関連する情報を使用す

る場合には、お客様の責任において行ってください。これらの使用に起因しお客様または第三者に生じた損

害に関し、当社は、一切その責任を負いません。 
5. 輸出に際しては、「外国為替及び外国貿易法」その他輸出関連法令を遵守し、かかる法令の定めるところに

より必要な手続を行ってください。本資料に記載されている当社製品および技術を大量破壊兵器の開発等の

目的、軍事利用の目的その他軍事用途の目的で使用しないでください。また、当社製品および技術を国内外

の法令および規則により製造・使用・販売を禁止されている機器に使用することができません。 
6. 本資料に記載されている情報は、正確を期すため慎重に作成したものですが、誤りがないことを保証するも

のではありません。万一、本資料に記載されている情報の誤りに起因する損害がお客様に生じた場合におい

ても、当社は、一切その責任を負いません。 
7. 当社は、当社製品の品質水準を「標準水準」、「高品質水準」および「特定水準」に分類しております。また、

各品質水準は、以下に示す用途に製品が使われることを意図しておりますので、当社製品の品質水準をご確

認ください。お客様は、当社の文書による事前の承諾を得ることなく、「特定水準」に分類された用途に当

社製品を使用することができません。また、お客様は、当社の文書による事前の承諾を得ることなく、意図

されていない用途に当社製品を使用することができません。当社の文書による事前の承諾を得ることなく、

「特定水準」に分類された用途または意図されていない用途に当社製品を使用したことによりお客様または

第三者に生じた損害等に関し、当社は、一切その責任を負いません。なお、当社製品のデータ・シート、デ

ータ・ブック等の資料で特に品質水準の表示がない場合は、標準水準製品であることを表します。 
標準水準： コンピュータ、OA 機器、通信機器、計測機器、AV 機器、家電、工作機械、パーソナル機器、

産業用ロボット 
高品質水準： 輸送機器（自動車、電車、船舶等）、交通用信号機器、防災・防犯装置、各種安全装置、生命

維持を目的として設計されていない医療機器（厚生労働省定義の管理医療機器に相当） 
特定水準： 航空機器、航空宇宙機器、海底中継機器、原子力制御システム、生命維持のための医療機器（生

命維持装置、人体に埋め込み使用するもの、治療行為（患部切り出し等）を行うもの、その他

直接人命に影響を与えるもの）（厚生労働省定義の高度管理医療機器に相当）またはシステム

等 
8. 本資料に記載された当社製品のご使用につき、特に、最大定格、動作電源電圧範囲、放熱特性、実装条件そ

の他諸条件につきましては、当社保証範囲内でご使用ください。当社保証範囲を超えて当社製品をご使用さ

れた場合の故障および事故につきましては、当社は、一切その責任を負いません。 
9. 当社は、当社製品の品質および信頼性の向上に努めておりますが、半導体製品はある確率で故障が発生した

り、使用条件によっては誤動作したりする場合があります。また、当社製品は耐放射線設計については行っ

ておりません。当社製品の故障または誤動作が生じた場合も、人身事故、火災事故、社会的損害などを生じ

させないようお客様の責任において冗長設計、延焼対策設計、誤動作防止設計等の安全設計およびエージン

グ処理等、機器またはシステムとしての出荷保証をお願いいたします。特に、マイコンソフトウェアは、単

独での検証は困難なため、お客様が製造された最終の機器・システムとしての安全検証をお願いいたします。 
10. 当社製品の環境適合性等、詳細につきましては製品個別に必ず当社営業窓口までお問合せください。ご使用

に際しては、特定の物質の含有･使用を規制する RoHS 指令等、適用される環境関連法令を十分調査のうえ、

かかる法令に適合するようご使用ください。お客様がかかる法令を遵守しないことにより生じた損害に関し

て、当社は、一切その責任を負いません。 
11. 本資料の全部または一部を当社の文書による事前の承諾を得ることなく転載または複製することを固くお

断りいたします。 
12. 本資料に関する詳細についてのお問い合わせその他お気付きの点等がございましたら当社営業窓口までご

照会ください。 
 
注 1. 本資料において使用されている「当社」とは、ルネサスエレクトロニクス株式会社およびルネサスエレク

トロニクス株式会社がその総株主の議決権の過半数を直接または間接に保有する会社をいいます。 
注 2. 本資料において使用されている「当社製品」とは、注 1 において定義された当社の開発、製造製品をいい

ます。 
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コンパイラパッケージ 
Call Walker 

本ドキュメントでは、ルネサス製コンパイラパッケージ(SuperH, H8, M16C, R8C, および
RXファミリ)に同梱されているスタック情報解析ツール「Call Walker」の使い方について
説明します。 

 

目次 

1. スタック情報ファイルの作成方法 .................................................................................................... 2 

2. Call Walkerの起動 ............................................................................................................................. 4 

3. ファイルのオープンとCall Walkerの画面 ......................................................................................... 4 

4. スタック情報の編集 .......................................................................................................................... 8 

5. アセンブラプログラムのスタック使用量 ....................................................................................... 11 

6. スタック情報のマージ(連結)........................................................................................................... 12 

7. その他の機能................................................................................................................................... 14 

 



コンパイラパッケージ 
Call Walker 

RJJ06J0073-0200/Rev.2.00 2009.10 Page 2 of 17 

Call Walkerは、リンケージエディタが出力したスタック情報ファイル(*.sni)、またはシミュレータデバッ
ガ(SuperHファミリ, H8ファミリ, またはRXファミリのみ)が出力したプロファイル情報ファイル(*.pro)を読
み込んで、静的なスタック使用量を表示します。 

スタック情報ファイルに出力できないアセンブリプログラムのスタック使用量は、編集機能を用いて情報
を追加することが可能であり、システム全体のスタック使用量を求めることもできます。 

編集したスタック使用量に関する情報は、呼び出し情報ファイル(*.cal)として保存または読み込みが可能で
す。 

また、呼び出し情報ファイルをマージ(連結)することも可能です。 

 

1. スタック情報ファイルの作成方法 
 

1.1 SuperHファミリ, H8ファミリ, またはRXファミリ用コンパイラの場合 
以下の手順に従って、スタック情報ファイル、またはプロファイル情報ファイルのいずれかを作成します。 

 
■スタック情報ファイル(*.sni)の作成方法 

スタック情報ファイルは、「最適化リンカ」の以下のオプションにより作成することができます。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

ダイアログボックスメニュー： [最適化リンカ] - [カテゴリ] - [その他] - [スタック情報ファイル(sni)出力] 

コマンドライン            ： STACk 
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■プロファイル情報ファイル(*.pro)の作成方法 

以下のプロファイル機能により、ユーザプログラムを実行させます。 

実行終了後プロファイルウインドウで右クリックし、プロファイル情報の保存によりプロファイル情報
ファイル(*.pro)が作成されます。 

プロファイル情報作成方法の詳細は、シミュレータ／デバッガ ユーザーズマニュアル「プロファイル情報
を見る」を参照してください。 

 

【プロファイルウインドウ】 

[表示] -> [パフォーマンス] -> [プロファイル] 
 

 

 

 

 

 

 

 

 

 

 

 

 

1.2 M16Cファミリ, またはR8Cファミリ用コンパイラの場合 
High-performance Embedded Workshopでビルドしリンクした場合、何の設定もすることなく、常にスタック
情報ファイル(*.sni)は作成されます。ただし、コンパイル時に"-finfo"オプションを指定してください。"-finfo"
オプションを指定しないと、スタック情報ファイルに必要な情報が入りません。 

High-performance Embedded Workshopでビルドしていない場合は、スタック情報ファイル作成ツール
"gensni"を使用して生成します。"gensni"は、Windowsのコマンドプロンプトから起動します。"gensni"はアブ
ソリュートモジュールファイル(*.x30)を入力とし、スタック情報ファイルを出力します。 

 

【例】アブソリュートモジュールファイル test.x30からスタック情報ファイル test.sniを作成する場合 
>gensni test.x30 

 

【注】 1. M16Cファミリ, または R8Cファミリ用コンパイラの場合、プロファイル情報ファイルを使用で
きません。 

 2. Call Walkerの使用できる各製品のバージョンは次のとおりです。 
・ M16Cシリーズ, R8Cファミリ用Cコンパイラパッケージ[M3T-NC30WA]: V.5.42 Release 00以降 
・ M32Cシリーズ用 Cコンパイラパッケージ[M3T-NC308WA]: V.5.41 Release 00以降 
・ R32Cシリーズ用 Cコンパイラパッケージ: 全てのバージョンで使用可能 
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2. Call Walkerの起動 
以下のいずれかの方法で起動します。 

 

■スタートメニューから起動 

プログラム -> [Renesas] -> [High-performance Embedded Workshop] -> [Call Walker]をクリック 

 

■High-performance Embedded Workshopから起動 

[ツール] -> [Renesas Call Walker]をクリック 

 

【注】 M16Cファミリ, または R8Cファミリ用コンパイラの場合、スタートメニューは以下のように表示し
ます。 
プログラム -> [Renesas] -> パッケージ名 -> [Call Walker] 

 

3. ファイルのオープンとCall Walkerの画面 
Call Walkerを起動後、スタック情報ファイル(*.sni)またはプロファイル情報ファイル(*.pro)を[File] -> 

[Import Stack File...]でオープンします。 

[File] -> [Open...]は既存の編集ファイル(*.cal)をオープンする際に、使用します。 

オープンすると以下の画面が出力されます。 

 

【注】 SuperHファミリ, または H8ファミリ用コンパイラの場合、標準ライブラリ以外のアセンブラ関数は
スタック使用量が 0と表示されます。「4. スタック情報の編集」をご参照の上、スタック使用量を設
定してください。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

メニューバー
タイトルバー ツールバー

シンボル詳細
ビュー

ステータスバー

　左端　：各機能の説明表示

　中央枠：CPU 情報表示

　左軸　：シンボル検索情報

呼び出し情報
ビュー
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■呼び出し情報ビュー 

シンボル間のリンク階層構造を表示します。 

各シンボル名の右側に使用しているスタック使用量を表示しています。 

 

(1) シンボルの区分表示 

シンボル名の左側に、シンボルの種類をアイコンで表示しています。 

次の種類があります。 

 

   編集中のファイル 

 

   アセンブラのシンボル 

 

   C/C++の関数 

 

   再帰呼び出し(リカーシブコール)関数または循環関数 

(a) 再帰呼び出し(リカーシブコール) 

関数内で自関数を呼び出す場合に表示されます。 

【例】 

 

 

 

 

 

 

(b) 循環関数 

間接的に自関数を呼び出す場合に表示されます。 

【例】 

 

 

 

 

 

 

 

   RTOS関数 (ITRONなどのシンボル) 
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   参照元シンボル不明関数 

下記例の場合、関数 func1()で関数 Undef()を呼び出していますが、関数 Undef()の実体がない場合、 

関数 Undef()に本アイコンが表示されます。 

実際には実体のない関数呼び出しは、リンク時にエラーになりますが、リンクオプション 

change_messageを使用することにより、エラーをウォーニングに変更できます。 

ウォーニングにすると、ロードモジュールが作成できるので、スタック情報ファイルも作成されます。 

【例】 

 

 

 

 

   アドレス参照未解決関数 

下記のように、関数をテーブル呼び出ししている場合に表示されます。 

【例】 

 

 

 

 

 

   省略表示シンボル 

本ツールでは、リンク階層を全て表示するため、ユーザアプリケーションが大きい場合、表示量が膨大 

になります。そこで、各シンボルの階層表示について最初の 1つだけを表示し、省略表示シンボルで 

他の同様な部分は表示を省略します。 

この表示は、[View] -> [Show All Symbols / Show Simple Symbols]で切り替えることができます。 

【例】 

 

 

 

 

 

 

   RTOSハンドラ 

 

   RTOSタスク 

 

   可変個引数を持つ関数 

 

Show All Symbols Show Simple Symbols 
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■シンボル詳細ビュー 

 

 

 

 

 

 

 

 

 

 

各シンボルごとのアドレス、属性、スタック使用量を表示します。 

シンボルをクリック後、右クリックすると各編集コマンドを実行できます。 

 

■ステータスバー 

 
 

現在オープンしているスタック情報ファイルを作成した際の、CPU種別などを表示します。 

 

■最大スタック使用量 

 

 

 

現在オープンしているスタック情報ファイルの、静的な最大スタック使用量を表示します。 

 

■標準ライブラリバージョン選択(SuperHファミリ, または H8ファミリ用コンパイラ向け) 

 

 

 

現在オープンしているスタック情報ファイルを作成した際の、標準ライブラリバージョンを選択します。 

これにより、標準ライブラリ内アセンブラ関数のスタック使用量を表示します。 

 

【注】 M16Cファミリ, R8Cファミリ, または RXファミリ用コンパイラの場合、標準ライブラリバージョン
を選択する必要はありません。何が選択されていても影響ありません。 



コンパイラパッケージ 
Call Walker 

RJJ06J0073-0200/Rev.2.00 2009.10 Page 8 of 17 

4. スタック情報の編集 
ファイルをオープン中、右側のシンボル詳細ビューでシンボル名を選択し、EditメニューのAdd...、Modify...、
または Delete...コマンドで、シンボルの追加、変更、または削除ができます。 

シンボル詳細ビューで右クリックしても、同様の操作が行えます。 

本ツールは静的なスタック最大使用量を算出できますが、多重割り込みなどによる、動的な最大使用量を
調査するためには、ユーザ側で情報ファイルを編集する必要があります。 

また、左側の呼び出し情報ビューでシンボルをドラッグ＆ドロップすると、シンボルの位置を変更できま
す。 

シンボルの移動や編集をすると、以下のように左側の呼び出し情報ビューの該当シンボルに変更を示す
チェックが付きます。 

 

 

 

 

 

 

 

 

以降に、各コマンドの説明をします。 
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■Add...コマンド 

(1) 既存シンボルの追加 

Add...コマンドをクリックすると、以下のダイアログボックスが表示されます。右側の一覧は現在の
ファイル内のシンボルです。既存のシンボルを追加する場合は、このリストからシンボルを選択し OK
ボタンをクリックします。 

 

 

 

 

 

 

 

 

 

 

 

 

(2) 新規シンボルの追加 

左側のチェックボックスをチェックすると、シンボルを新規作成できます。 
その際に、シンボル名、シンボル区分、属性、アドレス、スタック使用量などを決定できます。 

 

 

 

 

 

 

 

 

 

 

 

 

既存シンボル一覧
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■Modify...コマンド 

情報を変更したいシンボルを選択し、Modify...コマンドをクリックすると、以下のダイアログボックスが
表示されます。ここで各種情報を変更することができます。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

■Delete...コマンド 

スタック使用量調査に不要なシンボルを選択し(左側、右側どちらでも良い)、Delete...コマンドをクリック
するとシンボルを削除できます。 

シンボル名 

シンボル区分 

アドレス 

関数のサイズ 

スタックサイズ 

シンボル属性 

オブジェクトファイル名 
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5. アセンブラプログラムのスタック使用量 
本章は、SuperHファミリ, H8ファミリ, および RXファミリ用コンパイラ向けの内容です。M16Cファミ
リ, または R8Cファミリ用コンパイラには該当しません。 

C/C++プログラムと違い、アセンブラプログラムは、アセンブルをしてもスタック使用量を自動で算出す
ることができません。 

そのため、Call Walker上でアセンブラプログラム関数のスタック使用量を編集する必要がありました。 

しかし、.STACK制御命令を使用すると、アセンブラプログラム関数内にスタック使用量を記述すること
ができます。Call Walkerは.STACK制御の数値を画面に表示します。 

 

■.STACK制御命令説明  

シンボルに対して、Call Walkerで参照するスタック使用量を定義します。1つのシンボルに対して定義で
きるスタック値は 1度のみ有効です。2度以上指定した場合は、その定義を無効とします。また、指定でき
るスタック値は、H'00000000～H'FFFFFFFEの範囲の 2の倍数のみとし、それ以外を指定した場合はその定
義を無効とします。 

・定数値を指定する。 

 かつ 

・前方参照シンボル外部参照シンボル、相対アドレスを使わずに指定する。 

 

■.STACKアセンブラ制御命令記述方法 

△.STACK△<シンボル>=<スタック値> 
 

■アセンブラプログラム例 

    .CPU        SH1 
    .EXPORT     _asm_symbol 
    .SECTION    P,CODE,ALIGN=4 
_asm_symbol: 
    .STACK      _asm_symbol=88 
              ： 
    RTS 
    .END 
 

■Call Walkerの表示例 

下記のように、Call Walker上で_asm_symbol関数のスタック使用量が、「88」と表示されるようになりま
す。 

 

 

 

 

 

■備考 

(1) .STACK制御命令は Call Walkerにスタックサイズを表示させる機能です。プログラムの動作に影響を
与えるものではありません。 

(2) 本制御命令は、SuperH RISC engineアセンブラでは Ver.7から、H8S,H8/300シリーズアセンブラでは
Ver.6.01から、RXファミリアセンブラでは V.1.00 Release 00からサポートしています。 

_asm_symbol関数のスタックサイズを「88」に設定 
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6. スタック情報のマージ(連結) 
保存後、または編集中のスタック情報ファイルと、他のスタック情報ファイルをマージ(連結)することが
できます。 

これにより、編集したスタック情報が、再ビルド後のスタック情報に上書きされません。 

 

■マージの例 

(1) test.cの内容 

 

 

 

 

(2) Call Walkerでスタック情報ファイルをオープン 

 

 

 

 

(3) 内容を変更(func1のスタック使用量を 100に変更) 

 

 

 

 

(4) test.cの内容を変更後にビルド(func2の呼び出しを追加) 

 

 

 

 

(5) Call Walkerで test.calを開いたまま test.sniをオープンします。 
このとき、ここをチェックし、開くボタンを押します。 
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(6) すると、(3)で変更した func1のスタック使用量を残しつつ、func2の情報が追加になります。 

これがスタック情報のマージ(連結)です。 
 

 

 

 

 

もし、(5)でチェックをしない場合は、以下のように(3)で変更した func1のスタック使用量は変更前の
値に戻ってしまいます。 

 

 

 

 

 

■マージの詳細オプション 

マージをする際の方法を変更することもできます。5通りの方法があります。 

詳細なマージ方法は、本ダイアログボックスの Descriptionを参照してください。 

 

【指定方法】 

[Tools] -> [Merge Option...] 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

■備考 

マージ機能は Call Walkerのバージョン 1.3以上で使用できます。 
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7. その他の機能 
 

■リスト出力 

スタック情報をテキスト形式で、ファイルに出力することができます。 

 

【指定方法】 

[File] -> [Output List...] 
 

■検索機能 

以下のダイアログボックスで、2通りの呼び出し情報ビューからの検索ができます。 

 

 

 

 

 

 

(1) スタック使用量が最大のパスを検索 

(2) シンボル名の検索 

 

【指定方法】 

[Edit] -> [Find...] 
[Edit] -> [Find Next...] (次を検索) 
[Edit] -> [Find Previous...] (前を検索) 

 

■呼び出し情報ビューの表示形式設定 

以下のコマンドで、スタック使用量の表示について 2通りの方法を選択できます。 

(1) Show Required Stack 

下から上にスタック使用量が積み重なっていきます。 
(2) Show Used Stack 

上から下にスタック使用量が積み重なっていきます。 
 

【指定方法】 

[View] -> [Show Required Stack] または [Show Used Stack] 
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■呼び出し情報ビューのツリー表示を展開するレベルの設定機能 

以下のダイアログボックスで、選択したシンボルのツリー表示を展開するレベルについて 2通りの方法を
選択できます。 

 

 

 

 

 

(1) Expansion Level 

選択したシンボルのツリー表示を展開するレベルを指定します。 
(2) Expand All 

選択したシンボルのツリー表示をすべて展開します。 
 
【指定方法】 

[View] -> [Expand…] 
 
【備考】 

呼び出し情報ビューのツリー表示を展開するレベルの設定機能は、Call Walkerのバージョン 2.00以上で使
用できます。 

 

■ユーザライブラリのスタック使用量の設定機能 

表示しているシンボルのスタックサイズを指定したスタック情報ファイルから読み込んだスタックサイズ
に置き換え、表示内容を更新します。以下のダイアログボックスで、ユーザライブラリのスタック情報ファ
イルを指定し、スタック使用量を設定できます。 

 

 

 

 

 

 

 

 

 

 

 

 

【指定方法】 

[Tool] -> [User Library Options…] 
 
【備考】 

ユーザライブラリのスタック使用量の設定機能は、Call Walkerのバージョン 2.00以上で使用できます。 
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ホームページとサポート窓口 
ルネサステクノロジホームページ 

http://japan.renesas.com/ 
 
お問合せ先 

http://japan.renesas.com/inquiry 
csc@renesas.com 

 
 

改訂記録 

改訂内容  
Rev. 

 
発行日 ページ ポイント 

1.00 2009.01.23 - 初版発行 
RXファミリの追加 2.00 2009.10.01 1, 2, 6, 7, 11, 15 
Call Walker バージョン 2.00の機能追加 
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