
 

 

U
ser M

an
u

al       

TK-78K0R/KE3L+USB 

16 16-bit Microcontroller Starterkit 

µPD78F1026       
            
            
            
            
            
            
 

All information contained in these materials, including products and product specifications, 
represents information on the product at the time of publication and is subject to change by 
Renesas Electronics Corp. without notice. Please review the latest information published by 
Renesas Electronics Corp. through various means, including the Renesas Technology Corp. 
website (http://www.renesas.com). 

R20UT0010ED0100, Rev. 1.00 
July 2010  

www.renesas.com



 

R20UT0010ED0100  1.00 Rev.  2 
User Manual 

Notice 

1. All information included in this document is current as of the date this document is issued. 
Such information, however, is subject to change without any prior notice. Before 
purchasing or using any Renesas Electronics products listed herein, please confirm the 
latest product information with a Renesas Electronics sales office. Also, please pay 
regular and careful attention to additional and different information to be disclosed by 
Renesas Electronics such as that disclosed through our website. 

2. Renesas Electronics does not assume any liability for infringement of patents, copyrights, 
or other intellectual property rights of third parties by or arising from the use of Renesas 
Electronics products or technical information described in this document. No license, 
express, implied or otherwise, is granted hereby under any patents, copyrights or other 
intellectual property rights of Renesas Electronics or others. 

3. You should not alter, modify, copy, or otherwise misappropriate any Renesas Electronics 
product, whether in whole or in part. 

4. Descriptions of circuits, software and other related information in this document are 
provided only to illustrate the operation of semiconductor products and application 
examples.  You are fully responsible for the incorporation of these circuits, software, and 
information in the design of your equipment.  Renesas Electronics assumes no 
responsibility for any losses incurred by you or third parties arising from the use of these 
circuits, software, or information. 

5. When exporting the products or technology described in this document, you should 
comply with the applicable export control laws and regulations and follow the procedures 
required by such laws and regulations.  You should not use Renesas Electronics products 
or the technology described in this document for any purpose relating to military 
applications or use by the military, including but not limited to the development of 
weapons of mass destruction.  Renesas Electronics products and technology may not be 
used for or incorporated into any products or systems whose manufacture, use, or sale is 
prohibited under any applicable domestic or foreign laws or regulations. 

6. Renesas Electronics has used reasonable care in preparing the information included in 
this document, but Renesas Electronics does not warrant that such information is error 
free.  Renesas Electronics assumes no liability whatsoever for any damages incurred by 
you resulting from errors in or omissions from the information included herein. 

7 .  Renesas Electronics products are classified according to the following three quality 
grades:  “Standard”, “High Quality”, and “Specific”.  The recommended applications for 
each Renesas Electronics product depends on the product’s quality grade, as indicated 
below.  You must check the quality grade of each Renesas Electronics product before 
using it in a particular application.  You may not use any Renesas Electronics product for 
any application categorized as “Specific” without the prior written consent of Renesas 
Electronics. Further, you may not use any Renesas Electronics product for any 
application for which it is not intended without the prior written consent of Renesas 
Electronics.  Renesas Electronics shall not be in any way liable for any damages or 
losses incurred by you or third parties arising from the use of any Renesas Electronics 
product for an application categorized as “Specific” or for which the product is not 
intended where you have failed to obtain the prior written consent of Renesas Electronics.  
 
 



 

R20UT0010ED0100  1.00 Rev.  3 
User Manual 

The quality grade of each Renesas Electronics product is “Standard” unless otherwise 
expressly specified in a Renesas Electronics data sheets or data books, etc. 

“Standard”: Computers; office equipment; communications equipment; test and 
measurement equipment; audio and visual equipment; home electronic 
appliances; machine tools; personal electronic equipment; and industrial 
robots. 

“High Quality”:  Transportation equipment (automobiles, trains, ships, etc.); traffic control 
systems; anti-disaster systems; anti- crime systems; safety equipment; and 
medical equipment not specifically designed for life support. 

“Specific”: Aircraft; aerospace equipment; submersible repeaters; nuclear reactor 
control systems;medical equipment or systems for life support (e.g. artificial 
life support devices or systems), surgical implantations, or healthcare 
intervention (e.g. excision, etc.), and any other applications or purposes 
that pose a direct threat to human life. 

8. You should use the Renesas Electronics products described in this document within the 
range specified by Renesas Electronics, especially with respect to the maximum rating, 
operating supply voltage range, movement power voltage range, heat radiation 
characteristics, installation and other product characteristics. Renesas Electronics shall 
have no liability for malfunctions or damages arising out of the use of Renesas 
Electronics products beyond such specified ranges. 

9. Although Renesas Electronics endeavors to improve the quality and reliability of its 
products, semiconductor products have specific characteristics such as the occurrence of 
failure at a certain rate and malfunctions under certain use conditions. Further, Renesas 
Electronics products are not subject to radiation resistance design. Please be sure to 
implement safety measures to guard them against the possibility of physical injury, and 
injury or damage caused by fire in the event of the failure of a Renesas Electronics 
product, such as safety design for hardware and software including but not limited to 
redundancy, fire control and malfunction prevention, appropriate treatment for aging 
degradation or any other appropriate measures.  Because the evaluation of 
microcomputer software alone is very difficult, please evaluate the safety of the final 
products or system manufactured by you. 

10. Please contact a Renesas Electronics sales office for details as to environmental matters 
such as the environmental compatibility of each Renesas Electronics product. Please 
use Renesas Electronics products in compliance with all applicable laws and regulations 
that regulate the inclusion or use of controlled substances, including without limitation, 
the EU RoHS Directive.  Renesas Electronics assumes no liability for damages or losses 
occurring as a result of your noncompliance with applicable laws and regulations. 

11. This document may not be reproduced or duplicated, in any form, in whole or in part, 
without prior written consent of Renesas Electronics. 

12. Please contact a Renesas Electronics sales office if you have any questions regarding 
the information contained in this document or Renesas Electronics products, or if you 
have any other inquiries. 

(Note 1) “Renesas Electronics” as used in this document means Renesas Electronics 
Corporation and also includes its majority- owned subsidiaries. 

(Note 2) “Renesas Electronics product(s)” means any product developed or manufactured 
by or for Renesas Electronics. 
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General Precautions in the Handling of MPU/MCU Products 

The following usage notes are applicable to all MPU/MCU products from Renesas. For detailed usage 
notes on the products covered by this manual, refer to the relevant sections of the manual. If the 
descriptions under General Precautions in the Handling of MPU/MCU Products and in the body of the 
manual differ from each other, the description in the body of the manual takes precedence. 

1. Handling of Unused Pins 
Handle unused pins in accord with the directions given under Handling of Unused Pins in the 
manual. 

The input pins of CMOS products are generally in the high-impedance state. In operation with 
an unused pin in the open-circuit state, extra electromagnetic noise is induced in the vicinity of 
LSI, an associated shoot-through current flows internally, and malfunctions occur due to the 
false recognition of the pin state as an input signal become possible. Unused pins should be 
handled as described under Handling of Unused Pins in the manual. 

2. Processing at Power-on 
The state of the product is undefined at the moment when power is supplied. 

The states of internal circuits in the LSI are indeterminate and the states of register settings and 
pins are undefined at the moment when power is supplied. 
In a finished product where the reset signal is applied to the external reset pin, the states of pins 
are not guaranteed from the moment when power is supplied until the reset process is 
completed. 
In a similar way, the states of pins in a product that is reset by an on-chip power-on reset 
function are not guaranteed from the moment when power is supplied until the power reaches 
the level at which resetting has been specified. 

3. Prohibition of Access to Reserved Addresses 
Access to reserved addresses is prohibited. 

The reserved addresses are provided for the possible future expansion of functions. Do not 
access these addresses; the correct operation of LSI is not guaranteed if they are accessed. 

4. Clock Signals 
After applying a reset, only release the reset line after the operating clock signal has become 
stable. When switching the clock signal during program execution, wait until the target clock 
signal has stabilized. 

When the clock signal is generated with an external resonator (or from an external oscillator) 
during a reset, ensure that the reset line is only released after full stabilization of the clock 
signal. Moreover, when switching to a clock signal produced with an external resonator (or by 
an external oscillator) while program execution is in progress, wait until the target clock signal is 
stable. 

5. Differences between Products 
Before changing from one product to another, i.e. to one with a different part number, confirm 
that the change will not lead to problems. 

The characteristics of MPU/MCU in the same group but having different part numbers may differ 
because of the differences in internal memory capacity and layout pattern. When changing to 
products of different part numbers, implement a system-evaluation test for each of the products. 



 

How to Use This Manual 

(1) Purpose and Target Readers 

This manual is designed to provide the user with an understanding of the 
hardware functions and electrical characteristics of the MCU. It is intended for 
users designing application systems incorporating the MCU. A basic knowledge 
of electric circuits, logical circuits, and MCUs is necessary in order to use this 
manual. The manual comprises an overview of the product; descriptions of the 
CPU, system control functions, peripheral functions, and electrical characteristics; 
and usage notes. 

Particular attention should be paid to the precautionary notes when using the 
manual. These notes occur within the body of the text, at the end of each section, 
and in the Usage Notes section. 

 

The revision history summarizes the locations of revisions and additions. It does 
not list all revisions. Refer to the text of the manual for details. 

 

The following documents apply to the xxx/xx Group. Make sure to refer to the 
latest versions of these documents. The newest versions of the documents listed 
may be obtained from the Renesas Electronics Web site. 

 

Document 
Type 

Description 
Document 
Title 

Document No. 

Data Sheet 
Hardware overview and 
electrical characteristics 

xxx/xx Group 
Datasheet 

R01DSxxxxEJxxxx

User’s 
manual for 
Hardware 

Hardware specifications (pin 
assignments, memory 
maps, peripheral function 
specifications, electrical 
characteristics, timing 
charts) and operation 
description. 

Note: Refer to the 
application notes for details 
on using peripheral 
functions. 

xxx/xx User’s 
manual for 
Hardware 

This User’s 
manual 

User’s 
manual for 
Software 

Description of CPU 
instruction set 

xxx/xx Series 

User’s 
manual for 
Software 

R01USxxxxEJxxxx

Application 
Note 

Information on using 
peripheral functions and 
application examples. 

Sample programs. 

Information on writing 
programs in assembly 
language and C. 

Available from Renesas 
Electronics Web site. 

Renesas 
Technical 
Update 

Product specifications, updates on 
documents, etc. 
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(2) Notation of Numbers and Symbols 

 

Conventions  

Data significance:  Higher digits on the left and lower digits on the right 

Active low representations: ××× (overscore over pin and signal name) 

Note:  Footnote for item marked with Note in the text 

Caution:  Information requiring particular attention 

Remark:  Supplementary information 

 

Numerical representations: 

Binary  ...×××× or ××××B 

Decimal  ...×××× 

Hexadecimal  ...××××H 

(3) List of Abbreviations and Acronyms 

Abbreviation Full Form 

CS78K C-Spy for 78K 

EW78K Embedded Workbench for 78K 

I/O Input/Output 

LSB Least Significant Bit 

MSB Most Significant Bit 

SFR Special Function Register 

USB Universal Serial Bus 
 

Acronyms Full Form 
  

  

 

All trademarks and registered trademarks are the property of their respective 
owners. 
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(4) Related Documents 

The related documents indicated in this publication may include preliminary 
versions. However, preliminary versions are not marked as such. 

 

Doc. Number Document Title 

R01AN0009ED0100 78K0R/KE3-L(USB) USB HID (Human Interface Device) 
Class Driver 

R01AN0008ED0100 78K0R/KE3-L(USB) USB CDC (Communication Device 
Class) Driver 

U20024EJ2V0UD00 User’s Manual 78K0R/Kx3-L 16-bit Single-Chip 
Microcontrollers 

Table 1 Related Documents 
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TK-78K0R/KE3L+USB Introduction 

Chapter 1 Introduction 

TK-78K0R/KE3L+USB is the evaluation kit for development with sound systems using "78K0R/KE3-L", 
Renesas Electronics 16bit all flash microcontroller. 

The user only needs to install the development tools and USB driver, and connect the host machine with 
the target board to start the code development, build, monitoring the output, and debugging code. 

(This demonstration kit uses the on-chip debug feature from the microcontroller itself, without emulator 
connection) 

 
Figure 1 Debug Configuration 

 

Overview This manual consists of the following contents.Read chapter 2 and 3 first for installing the 
development tools and using the sample programs. Read chapter 4-6 for customizing the 
sample programs and the hardware. 

Chapter 2: Preparations  

Install the development tools 

Chapter 3: Experiences  

Experience the basic operations of integrated development environment (Embedded 
Workbench) and integrated debugger (C-Spy) with using sample programs. 

Chapter 4: Hardware Specifications  

Explain the hardware of TK-78K0R/KE3L+USB 

Chapter 5: Troubleshooting  

Describe how to solve troubles you may face, such as errors when starting the integrated 
debugger (C-Spy) 

Chapter 6: Other Information  

Introduce other information, such as how to create a new workspace (project) on 
integrated development environment (Embedded Workbench, how to register additional 
source file, and some useful tips of the integrated debugger. The circuit diagrams of 
demonstration kit are included in this chapter. 

Reader  This manual is intended for development engineers who wish to become familiar with the 
development tools for the 78K0R. It is assumed that the readers have been familiar with 
basics of microcontrollers, C and Assembler languages, and the WindowsTM operating 
system. 

Purpose  This manual is intended to give users an understanding of the features, hardware 
configurations, development tools for the 78K0R.  
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TK-78K0R/KE3L+USB Preparation 

Chapter 2 Preparation 

This chapter describes following topics: 

- Overview and installation of development tools 

- Installation of development tools 

- Overview and preparation of sample programs 

 

Users can experience the development flow such as coding, build, debugging, and test, by using the 
development tools bundled with TK-78K0R/KE3L+USB. 

 

2.1 Development Tools / Software 
 

 Integrated Development Environment (IDE) Embedded Workbench for 78K V4.70 

The IDE works on Windows operation system. Users can develop a system efficiently by using 
the editor, compiler, and debugger. 

 C Compiler ICC78K0R V4.70.1 (code size limited version) 

C compiler for the 78K0R microcontrollers. The object code size is limited to 4 KB. This compiles 
C code for 78K0R and ANSI-C code program into object code. 

 Assembler RA78K0R V4.70.1 

Assembler for the 78K0R microcontrollers. This convert the assembler code for 78K0R into object 
code.  

 Integrated Debugger CS78K V4.70 

This is the tool for debugging the object program generated by C compiler and assembler. The 
debugger enables to do C source level debugging. With the debugger, you can debug the code 
easily and efficiently by referring and changing variables, using step-in debugging function, and 
so on. 

 Starter Kit USB Driver 

This is a software driver for PC to access to the USB interface of the kit. 

 HID Class Sample Program / USB Human Interface Device Class Sample Driver 

The 78K0R/KE3-L is detected as the HID device.This sample program behaves as a keyboard. 
And it is used in [chapter 2].Please refer to the "USB HID (Human Interface Device) Class Driver 
application note" for further details. 

 CDC Class Sample Program / USB Communication Device Class Sample Driver 

The 78K0R/KE3-L is detected as the CDC device.This sample program behaves as a COM port. 
Please refer to the "USB CDC (Communication Device Class) Driver application note" for further 
details. 
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TK-78K0R/KE3L+USB Preparation 

 

2.2 Installation of Development Tools  

2.2.1 Installation Package 

The attached CD-ROM includes the development tools and documentations. Users can use the installer 
to install those development tools and documentations 

 

2.2.2 Installation of Development Tools 

 

1) Please insert the CD-ROM in the drive. The installer will show up automatically. If it does not start 
automatically, please initiate it by double clicking ‘Aurorun.EXE’. 

 

 

2) Click ‘Install IAR Embedded Workbench for 78K’ 
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3) Click Install IAR Embedded Workbench for 78K’ 

 

 

 

4) Click ‘IAR online Registration’ 
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5) Complete the form and submit the registration. Within some minutes you will get the following 
email.  
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6) Click the Hyperlink to get your requested license key to continue the installation. 
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7) Click ‘Install IAR Embedded Workbench’ 

 

 

 

8) Click ‘Next’ 
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9) Read the license agreement, accept the terms and click ‘Next’ 

 

 

 

10) Complete the form and click ‘Next’ 
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11) Enter the license key by copy and paste, please take care that no linefeed character is included in 
the license key. Click ‘Next’ 

 

 

 

12) Select ‘Complete’ and click ‘Next’ 
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13) Use the default installation folder or choose any other folder and click ‘Next’ 

 

 

 

14) Click ‘Next’ 
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15) This is the last possibility to modify the installation options. Click ‘Install’ to start the installation. 

 

 

 

16) At the end of a successful installation please select whether you would like to read the release 
notes and/or to start the IAR Embedded Workbench. Click ‘Finish’ to close the installation tool. 

 

 

 

R20UT0010ED0100 Rev. 1.00  22 
User Manual 



TK-78K0R/KE3L+USB Preparation 

 

17) Click ‘Back’ to go to the IAR Installation Overview Window. Please feel free to test also the IAR 
Systems Visual State Design tool.  

 

 

  

18) Click ‘Exit’ to close the IAR Installation tool. 
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TK-78K0R/KE3L+USB Preparation 

2.2.3 Installation of WriteEZ5 Flash Programmer 

 

1) Click ‘Install WriteEZ5 Programmer’. 

 

 

2) Click ‘Yes’ to continue the installation 
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3) Click ‘I Agree’ to confirm that you accept the license agreement. 

 

 

4) Accept the default installation folder or use the ‘Browse’ function  to select any other folder of your 
choice. Click ‘Install’ to start the installation. 
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5) Click ‘Next’ to continue the installation. 

 

 

6) As the programmer shall not be started now, please unmark ‘Run WriteEZ5’ and click ‘Finish’ to 
close the installer. 
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2.2.4 Installation of Sample Applications 

 

 

1) Click ‘Install TK-78K0RKE3L+USB’ Sample Programs’. 

 

 

 

2) Read the license agreement and click ‘I Agree’ to accept the terms. 
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3) Please select the installation folder of the samples and click ‘Install’ 

 

 

   

4) Click ‘Close’ to finish the installation.  
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TK-78K0R/KE3L+USB Preparation 

 

2.3 USB Driver Installation 

 

"NEC Electronics Starter Kit Virtual UART" USB driver must be installed on PC before you start using the 
TK-78K0R/KE3L+USB. 

 

Please, follow the instruction below to install the driver. 

 

"Starter Kit USB Driver" must be installed on the PC. The driver is included in the Embedded Workbench 
package, please refer to "2.2 Installation of Development Tools" to install the Embedded Workbench first. 

 

CAUTION: Do not use a USB hub for connecting TK-78K0R/KE3L+USB. 

 

First, connect the TK-78K0R/KE3L+USB USB2 to PC with USB cable. 

 

 

 
Figure 2 USB Connection 

 

 

Depending on the version of Windows OS, the installation will be differed. Please check your Windows 
version, and follow the instructions 

 

- Windows XP  -> Chapter 2.3.1 Installation on Windows XP 

 

- Windows 2000 -> Chapter 2.3.2 Installation on Windows 2000 

 

After the installation, go to Chapter 2.3.3 Completion of USB Driver Installation
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2.3.1 Installation on Windows XP 

 

  

1) Select ‘Install from a list or a specific location (Advanced)’ and click ‘Next’. 

 

 

2) Mark ‘Include this location in the search’ and select the subfolder ‘78Kdrivers/renesas/MINICUBE’ 
of your Embedded Workbench installation folder. Click ‘Next’ 
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3) Click ‘Continue Anyway’ to continue the installation. 

 

 

4) Click ‘Finish’ to close the installation wizard. 

 

R20UT0010ED0100 Rev. 1.00  31 
User Manual 



TK-78K0R/KE3L+USB Preparation 

2.3.2 Installation on Windows 2000 

 

1) Click ‘Next’ to continue. 

 

 

 

2) Select ‘Search for a suitable driver for my device’ and click ‘Next’ 
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3) Mark ‘Specify a location’ and click ‘Next’ 

 

 

 

4) Select the subfolder ‘78Kdrivers/renesas/MINICUBE’ of your Embedded Workbench installation 
folder using the ‘Browse’-function and click ‘OK’. 
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5) Confirm the found driver by clicking ‘Next’ 

 

 

 

6) Click ‘Finish’ to close the installation wizard. 
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2.3.3 Completion of USB Driver Installation 

Check that the USB driver is installed correctly. 

Start "Device Manager", and find "NEC Electronics Starter Kit Virtual UART" (without "?" mark) under the 
"Ports (COM & LPT)". 

 

 
Figure 3 Device Manager Entry 

 

The screen above shows that the COM port number is "COM8". If IC-Spy is not in use, you can use this 
port number for connecting TK-78K0R/KE3L+USB. 

When you change the USB port connection, the COM port number will be changed as well. 

 

CAUTION 

Do not do “Hardware Modification Scan” when you communicate with the target device. 
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2.4 Sample Programs 
 

This section explains the overview and preparation of sample programs. For details about the sample 
programs, see the two corresponding application notes: 

Application Note USB HID (Human Interface Device) Class Driver   

Application Note USB CDC (Communication Device Class) Driver  

 

The sample programs consist of following directories: 

 
Figure 4 Sample Directories 

 

include: include file folder 

src: source file folder 

EW78K_project: project file folder (*.ewp: project file, *.eww Workspace file) 

inf: CDC USB driver folder 
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Chapter 3 Experiences 

In this chapter, you will experience how to use the development tools with using the sample programs. 
The development tools are: 

- Integrated Development Environment (IDE), Embedded Workbench for 78K 

- Integrated Debugger, C-Spy for 78K 

You will use the programs that you prepared in "2.2.4 Installation of Sample Applications”, as the sample 
programs for TK-78K0R/KE3L+USB. You will be able to understand how to use the development tools 
and the concept of project files which you need for producing application programs. 

 

The overall steps are as follows:  

 
Figure 5 Overall Steps to Start a Debug Session 
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3.1 Start Embedded Workbench for 78K 

Let's start using the development tools. 

First, start the Embedded Workbench 

Select "Windows Start Menu" -> "Program" -> "IAR Systems" -> "Embedded Workbench for Renesas 78K 
V4.70 Kickstart". 

EW78K 
starts... 

 

 

 

 

 

 
Figure 6 EW78K Start-Up 
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3.2 What is ‘Embedded Workbench for 78K’ ? 

In EW78K, application programs and environment setting are handled as a single project, and series of 
actions such as program creation using the editor, source management, build, and debugging are 
managed. One or more projects can be combined in one workspace. The same project may also be 
included in different workspaces. A workspace is a collection of projects containing on information about 
the configuration of each project. 

  

 

 

 

 

 

Menu Bar 
Tool Bar Editor Window 

Workspace Window 

Figure 7 EW78K Main Windows 

Message Window  

 

Workspace window: A window in which project names, source files, include file and generated output 
files are displayed using a tree structure. 

Message window:   A window in which the build execution messages are displayed. 

Editor window:  A window to create all kind of source files. 
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What is a project? 

A project is the unit that is managed by EW78K. A project refers to an application system and 
environment development based on EW78K. EW78K saves project information in a "project file". 

 

What is a project file? 

A project file contains project information that includes the source files, device name, tool options for 
compiler, assembler, linker and debugger.  The file name format is "xxxxx.ewp". 

Project files are created in the directory you specify when creating a new project. 

 

What is a workspace? 

A workspace is the unit used to manage all the projects required for one application system. 

A workspace file contains one or more project files. The file name format is "xxxxx.eww".  

Workspace files are created in the directory you specify when creating a new project. 
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3.3 Open Workspace 

 

In this section, you will use the workspace that you created in "2.2.4 Installation of Sample Applications" 

For creating a new workspace, refer to "Chapter 6 Other Information". 

Select ‘File -> Open -> Workspace…’ on the menu bar. 

Then, select " 78K0R_Kx3L(HID).eww " under the directory " TK-78K0RKE3L+USB\Samples78K0R Kx3L 
USB(HID) \EW78K_Project". 

   

 
Figure 8 EW78K Open Workspace 
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Figure 9 EW78K Open Workspace File Selection Dialogue 

 

 
Figure 10 EW78K Workspace Loaded 
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3.4 Build Application 

To build the application use either the ‘Make’ button of the tool bar, select the menu item ‘Project -> Make’ 
or use the keyboard and press ‘F7’ key.  

 

 
Figure 11 EW78K Make 

 

All build messages can be seen in the Messages Window.  

 

 
Figure 12 EW78K Message Window 

 

What is the difference between Make and Rebuild? 

Make and Rebuild are functions creating an executable file from source files in a project. Compiling, 
assembling, linking, and other processing actions are performed automatically. To reduce the time for the 
build, make detects and compiles/assembles only the files that have been updated from the previous 
build process, whereas rebuild compiles and assembles all the source files. 
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3.5 Tool Configuration 

After getting familiar with the development environment you can modify the configuration according to 
your needs. All options for the assembler, compiler, linker, and debugger can be modified in the menu 
‘Project->Options’.   

 

 
Figure 13 EW78K General Project Options 

 

 

 
Figure 14 EW78K Compiler Options 
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Figure 15 EW78K Linker Options 

 
 

 
Figure 16 EW78K Debugger Options 
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3.6 Check Board Settings 

Before connecting the PC and the TK-78K0R/KE3L+USB with USB, you should check the setting of 
switch and jumper pin on the board. Set the switch and the jumper pin on the TK-78K0R/KE3L+USB as 
follows. 

 

Jumper Position 

JP1 short 

JP2 1-2 short 

JP3 1-2 short 

JP4 Short 

SW4 Debug Writer 
Table 2 TK-78K0RKE3L+USB Jumper Setting 

 
SW1 

1 2 3 4 5 6 7 8 
ON ON ON ON ON OFF OFF OFF

Table 3 TK-78K0RKE3L+USB Switch SW1 Setting 

 
 

 
Figure 17 TK-78K0RKE3L+USB Jumper & Switches 

 
After the switch settings are completed, connect the PC to USB2 on TK-78K0R/KE3L+USB with USB 
cable. If the "Found New Hardware Wizard" is started, install USB driver with referring "2.3 USB Driver 
Installation". 
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3.7 Start C-Spy Debug Session 

To start the C-Syp debugger use either the ‘Download and Debug’ button of the tool bar, or  select the 
menu item ‘Project -> Download and Debug’ or use the keyboard and press ‘STRG+D’.  

 

 
Figure 18: IAR Embedded Workbench Download and Debug 

 

In case of starting a debug session for the first time, the following C-Spy Hardware Setup Dialogue is 
opened automatically. Later you can modify the configuration only in the debug session selecting the 
menu ‘ Emulator->Hardware Setup…’. 
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Figure 19 C-Spy Hardware Setup Dialogue 

 

 
Figure 20 C-Spy Debug Session 

 
After the download the application, is started automatically and stopped at the beginning of the main 
function. To disable the automatic start and run to main, please unmark this feature in the debugger 
options setting (see Figure 16). 
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3.8 Run Application Program 

To run the application program either press the ‘Go’ toolbar button, select the menu ‘Debug->Go’ or use 
the keyboard and press ‘F5’  

 
Figure 21 C-Spy 'Go' Button 

 
When the application is running, the ‘Go’ button and all single step buttons are disabled: 

 

 
Figure 22 C-Spy Application Control Buttons Run Mode 

 

 
Figure 23 C-Spy Application Control Buttons Stop Mode 
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Connect the PC to USB1 on TK-78K0R/KE3L+USB with USB cable while the application is running. 

 

 

 
Figure 24 TK-78K0RKE3L+USB USB connector USB1 

 

Start the Windows Notepad editor or any other text editor of your choice. 

The alphabet is entered by "SW2" operation to the up side; pushing "SW2" starts the new paragraph 
as follows. 

 
Figure 25 TK-78K0RKE3L+USB switch SW2 
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Figure 26 Notepad Editor 

 
Entering characters similar to Figure 25 confirms that the application is working correctly. 

For more information about the functions that are used in those sample program, see "USB HID (Human 
Interface Device) Class Driver application note". 

 

3.9 Stop Application Program 

To stop the application program either press the ‘Break’ toolbar button or select the menu ‘Debug->Break’.  

 
Figure 27 C-Spy 'Break' Button 
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3.10 Close C-Spy Debug Session 

To close a debug-session please press the ‘Stop Debugging’ toolbar button. 

 

 
Figure 28 C-Spy 'Stop Debugging' Button 

 
After closing the debug session, the Embedded Workbench is back in ‘Edit Mode’ 
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3.11 Close Embedded Workbench 

To close the Embedded Workbench please use the menu ‘File -> Exit’. 

 
Figure 29: IAR Embedded Workbench Close 
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Chapter 4 Hardware Specification 

In this chapter, the hardware of TK-78K0R/KE3L+USB will be explained. 

 

Microcontroller µPD78F1026  (78K0R/KE3-L) 

Clock 

External main system clock: 20MHz 

Subsystem clock: 32.768KHz 

Internal oscillation clock: 20, 8, 1MHz 

Audio 

PWM output 

Filter:LMV324M:NS(U13) 

AMP:LM4865M:NS(U14) 

Speaker:0.3W (for simplified monitoring) 

Jack:3.5mm monaural 

Filter ON/OFF Switchable (SW5) 

Output Volume (VR1) 

Interface 

USB MINI B (USB1) USB Function 

USB MINI B (USB2) Debug/Serial communication 

Expansion connector 50Pin socket x2 pad only(CN1,CN2) 

Connecter for MINICUBE2 (FP1) 

Power Supply Voltage 5V (USB or AC adapter) 

Input/output for operation 
check use 

The name in brackets is the 
name printed on the board 

·4 ways + center-push switch (SW2) 

·Dip switch (SW1) 

·7Seg-LED (U1,U2) 

·Reset switch (SW3) 
Table 4 TK-78K0RKE3L+USB Hardware Overview 
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4.1 Layout of hardware functions  

 
Figure 30 Troubleshooting 

 

4.2 Layout of solder-short pad and test pad  

 
Figure 31 TK-78K0RKE3L+USB pads 
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4.3 Hardware Functions 

4.3.1 SW1, SW4 

The bit 1-3 on SW1 are for debug mode settings, bit 4,5 are for mode settings and bit 6-8 are DIP 
switches connected to P41,P42,P17 pins in microcontroller. 

 

1) In case of using the C-Spy debugger use following settings: 

 
SW1 SW4 

1 2 3 4 5 6 7 8  
ON / 
OFF 

ON ON X X X X X Debug/Writer Side 

Table 5 C-Spy Debug Configuration 

 

SW1:1 

ON: The microcontroller runs the programs stored in the flash memory as soon as it gets power supply. 
OFF: The microcontroller stays being reset until C-Spy started. 

 

2) In case of running the programs stored in built-in flash memory without using C-Spy debugger or 
debugging the microcontroller with MINICUBE2, use following settings and re-supply power. 

 
SW1 SW4 

1 2 3 4 5 6 7 8  
OFF OFF OFF ON X X X X K0R-K0R USB Side or center 

Table 6 Standalone Configuration 

 

Set switch SW4 in position ‘center’, if you use P11 and P12 on the Expansion connector 

 

3) Bit4 is the switch for POWER LED. 

ON:  If CPU is supplied power, LED1 is turned on. 

OFF: If CPU is supplied power, LED1 isn't turned on. 

 

4) Bit5 is the switch for the audio mute. 

ON: Audio output is muted by P31output low. 

OFF: Non audio mute 

5) The bits 6-8 are connected to P41, P42, P17 pins of the microcontroller. ON means "Low" and OFF 
means "Open". When you need to use this, you need to set the microcontroller built-in pull-up 
resistor option registers (PU1, PU4) to ON. For details about settings of microcontroller built-in pull-
up resistor option registers, refer to 78K0R/KE3-L User's Manual (U19878E). 

 

SW1 
6 7 8 
P42 P43 P17 

Table 7 SW1 Bit 6-8 
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4.3.2 SW2 (INTP0) 

SW2 is a 4 ways + center-push switch. When the switch is moved to one of 4 ways or is pushed down, it 
sends the signal of "Low". When it is released, it becomes "Open" again. You need to set the pull-up 
resistor option register ON for this function. (For more information about the pull-up resistor option 
register, refer to the 78K0R/KE3-L user's manual, U19878E). 

 

SW2 Signal Name MCU Pin Name Operation 

1pin P70 P70 / KR0 UP 

2pin P71 P71 / KR1 CENTER PUSH 

3pin P72 P72 / KR2 LEFT 

4pin P74 P74 / KR4 / INTP8 RIGHT 

5pin GND GND  

6pin P73 P73 / KR3 DOWN 
Table 8 SW2 Pin Functions (ALPS SKRHADE010) 

 

4.3.3 SW3 (RESET SW) 

This is the reset switch. You can reset the microcontroller by pressing this switch. 

 

4.3.4 SW5 (Filter) 

SW5 is the slide switch to select use/not use of the Filter (LMV324M). When it sets to "OFF", it does not 
use the Filter and it inputs sound signals from microcontroller to AMP. 

 
Figure 32 SW5 Filter Setting 

 

4.3.5 JP1 

JP1 is the jumper switch pin for connecting the microcontroller and the filter.  

Please set the jumper switch pin short circuit. Please refer to the circuit diagram for further details. 
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4.3.6 JP2, JP3 

JP2, JP3 are jumper switch pin for selecting the power supply to the CPU. 

 

JP2 JP3  

1-2 short 1-2 short USB power supply from USB2 connecter 

2-3 short 2-3 short USB power supply from USB1 connecter 

- 2-3 short AC adapter power supply from CN3 connecter. 
Table 9: Power Supply Configuration 

4.3.7 JP4 

JP4 is the jumper switch pin for supplying the power to the audio circuit. 

Please set the jumper switch pin short circuit. Please refer to the circuit diagram for further details. 

 

4.3.8 LED1 (POWER) 

This is the POWER LED. It is lighted when it gets power supply. 

You can turn off the LED by setting the bit4 OFF on SW1. 
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4.3.9 U1, U2 (7-segment LED) 

U1and U2 are 7-segment LED. By setting the 7-segment LED output data in P20-P23 and setting P50-
P53 from Low to High, the data is latched and the 7-segment LED displays the data. 

 
Figure 33 7-Segment LEDs 

 

To display "1" on U1 and "2" on U2: 

P11_bit.no1 = 0;  

P11_bit.no1 = 1;    // Set P111 to Low, then High 

P2 = 0xa4;  

P5 = 0xa4>>4;       // Set data for "2" in P2 and P5 

P11_bit.no0 = 0;  

P11_bit.no0 = 1;    // Set P110 to Low, then High 

P2 = 0xf9;  

P5 = 0xf9>>4;       // Set data for "1" in P2 and P5 

PM11_bit.no0 = 0;  

PM11_bit.no1 = 0;   // Set P110, 111 to output mode 

PM5 = 0xf0;         // Set lower 4bit of P5 to output mode 

PM2 = 0xf0;         // Set ower 4bit of P2 to output 
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4.3.10 CN1, CN2 

These are the connecters for expansion connections. 

The connecter is not installed. (HIROSE ELECTRIC CO., LTD. HIF-3H-50DA-2.54DSA). 

 

4.3.11 CN3 

This is the connector for AC adapter. Please, connect the bundled AC adapter (+5V). 

Support plug: 2.1mm DC jack (center plus). 

 

4.3.12 J1 

This is the jack for external speakers. Connect a speaker when you play sound.  

Support jack: 3.5mm (monaural). 

 

4.3.13 VR1 

This is the audio output volume control. If the audio mute is set, then audio is not output. 

 

4.3.14 USB1 

This is the USB connecter for the USB function controller. 

 

4.3.15 USB2 

This is the USB connecter for the debug / serial communication. 

It is found as “NEC Electronics Starter Kit Virtual UART”. 

 

4.3.16 FP1 

This is the interface for connecting MINICUBE2. 

 

4.3.17 Solder-short pad label 

With using the solder-short pad to cut the circuit, users can customize the circuit. The solder-short pad 
looks like the picture below. To open, use cutter to cut the dent part. To short, put solder on the pad. 

Solder-short pad     Solder-short pad 

(Open)       (Short) 
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Solder-short pad name Before shipment Connection 

short 
P120 connected to USB1 bus power 
detecting signal P120 short 

open P120 used as multipurpose I/O 

short P16 is connected to audio circuit. 
P16 short 

open P16 used as multipurpose IO. 

short P31 is connected to audio muting circuit. 
P31 short 

open P31 used as multipurpose IO. 

short VDD = AVREF 
AVREF short 

open AVREF is separated from VDD 

short VDD = EVDD 
EVDD short 

open EVDD is separated from VDD 

short 
P110 and P111 are connected to 7-Segment 
LED data latch circuit. P110, P111 short 

open P110 and P111 used as multipurpose I/O 

short 
These ports are connected to 7-Segment 
LED data latch circuit. P20~P23, P50~P53 short 

open These ports used for multipurpose IO 

short 
External speaker output connecter J1 is 
connected as stereo connecter. RIGHT open 

open Connection for the monaural connecter 
Table 10 Solder Short Pad Description 

 

Note: All ground signals are connected. 
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Chapter 5 Troubleshooting 

5.1 If you cannot find USB driver when connecting the kit 

Check Point 1 If you use USB hub, do not use it. (USB hub is not supported) 

Check Point 2 Check if you installed "Starter Kit USB Driver" in "2.3 USB Driver Installation ". If not, 
install the driver. 

Check Point 3 If above two check points are confirmed, disconnect the USB cable from PC and re-
connect again. It should show the "Found New Hardware Wizard" wizard. Operate the 
installation with referring to "2.3 USB Driver Installation". After the installation, make sure 
you go through "2.3.3 Completion of USB Driver Installation" to confirm the USB driver 
installation 

 

5.2 Error when you start the debugger 

There could be several reasons to make errors happen. 

The solving processes differ depending on errors. Please check the error message first. 

 

5.2.1 "Can not communicate with Emulator..." (F0100 or A0109) 

Check Point 1 If you use USB hub, do not use it. (USB hub is not supported) 

Check Point 2 Check if the settings of switches on the kit are correct with referring "3.6 Check  Board 
Setting". 

Check Point 3  Confirm the USB driver installation with referring to "2.3.3 Completion of USB Driver 
Installation". 

Check Point 4 If above three check points are confirmed, close the debugger and disconnect the USB 
cable from PC. Re-connect USB cable properly to both the PC and the kit, and then re-
start the debugger. 

 

5.2.2 "Incorrect ID Code." (Ff603) 

This error occurs when the security ID stored on microcontroller built-in flash memory is different from the  

ID code you entered at the start of debugger. 

 
Figure 34 Security ID entry area at the start of debugger 

 

Check Point 1 Enter correct security ID and click OK on the configuration window. 

Check Point 2 If you forgot the security ID, you have to erase the microcontroller built-in flash memory. 
Before erasing, check if you actually set the security ID in your application. Also 
remember the code you set for the security ID. After this, erase the flash memory with 
referring to "5.4 Erase microcontroller built-in flash memory". 
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5.2.3 "On-chip debug function had been disabled in the device.” 
(F0c79) 

This error occurs when the value at address 00C3H (On-chip debug option byte) in microcontroller built-in 
flash memory is incorrect. You need to erase the flash memory. 

Check Point 1 Check if you actually set the correct on-chip debug option byte in your application. If it is 
not correct, then set correctly. 

Check Point 2 Erase the flash memory with referring to "5.4 Erase microcontroller built-in flash memory” 
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Chapter 6 Other Information 

This chapter explains some useful operation techniques of development tools and circuit diagram of the 
kit for developing of user programs. 

 

6.1 Create a new Workspace 

Now, create a new workspace and project. 

The Embedded Workbench allows you to create a new workspace with following "New Workspace" dialog. 

Select "File -> New Workspace...": 

 

 
Figure 35 EW78K Create new Workspace 
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6.2 Add one or multiple Projects to a new Workspace 

After creating a new workspace you can one or multiple existing projects or create a new project 

Select "Project -> Add existing Project...": 

 
Figure 36 EW78K Add existing Project 

 

Select the project-file (*.ewp) of the project you want to add: 

 
Figure 37 EW78K Add Existing Project Dialogue 
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Alternatively you can create a new project by selecting ‘Project->Create New Project…’ 

 
Figure 38 Create New Project 

 
In following dialogue you can select a template used for the new project. If you want to create a 
new project from scratch manually, please ‘Empty Project’ 
 

 
Figure 39 EW78K Create New Project  Dialogue 

 
After adding an existing project or creating a new project you have an titled Workspace which 
has to be saved by ‘File All”: 
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Figure 40 EW78K Untitled Workspace 

 

 
Figure 41 EW78K Save All 

 
In the following Dialogue you can specify the workspace name and the location where it shall be stored: 

R20UT0010ED0100 Rev. 1.00  67 
User Manual 



TK-78K0R/KE3L+USB Other Information 

 
Figure 42 EW78K Save Workspace As Dialogue 
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6.3 Add additional Source Files to a Project 

To add an additional source file to an existing project, please select ‘Project -> Add Files…’. 

 
Figure 43 EW78K Add Files 

 

In the following dialogue you can specify the source file to be added. Please keep mind that only files 
listed according to the selected extension filter: 

 
Figure 44 EW78K  Add Files Dialogue 
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6.4 Debugger Tips 

 

6.4.1 Set/delete breakpoints 

A breakpoint at a specific source line can be defined either by 

-  moving the cursor to the source code line and pressing the key ‘F9’ 

or 

-  moving the cursor to the source code line, open the pop-menu by right mouse button click and selecting 

  “Toggle Breakpoint (CODE)”. 

or  

-  using the Breakpoint Definition Dialogue 

An active breakpoint is marked by a filled red circle in the first row 

 
Figure 45 C-Spy active Breakpoint 

 

 

 

You get an overview about all defined breakpoints by selecting “View -> Breakpoints” 
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Figure 46 C-Spy Breakpoint Window 

 

Breakpoints can be delected or deactivated in Pop-up menu of the Breakpoint Window. A deactivated 
breakpoint is marked as a non-filled red circle in the source code window. 

 
Figure 47 C-Spy deactivated Breakpoint 
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6.4.2 Display global Variables 

Global variables are displayed in the Watch Window (select menu “View-> Watch”). Variables can be 
added either by entering the variable name manually, or by selecting the variable and using the Pop-up 
menu ‘Add to watch” or by simple “drag & drop” the symbol name from Source Code Window to Watch 
Window. 

 
Figure 48 C-Spy display global Variables 
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6.4.3 Display global Variables while Application is running 

The C-Spy Watch Window is not updated while the application is running. To display global variables 
while the application is running please use the Live-Watch Window (select menu “View -> Live Watch”). 

 
Figure 49 C-Spy display global Variables while Application is running 
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6.4.4 Display local Variables 

Local Variables are displayed automatically in the Local Watch Window (select menu ‘View -> Locals”). 

The variable list can not be modified manually, but is an automatically generated list according the 
currently executed function. 

 
Figure 50 C-Spy display local Variables 
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6.4.5 Display Memory Content 

The complete memory area (Flash and RAM area) is displayed in the memory window (select menu ‘View 
-> Memory). Changed values since the last break are marked in red. 

 
Figure 51 C-Spy display of Memory Content 
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6.4.6 Display Memory Content while Application is running 

 

Like the Watch Window the Memory Window is also only updated when the application is stopped. To 
display the memory content while the application is running the Live Memory Window has to be used 
(select Emulator -> Live Memory). Instead of the compete memory only up to 16 byte can be displayed. 

 

 
Figure 52 C-Spy Display of Memory Content while Application is running 
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6.4.7 Display of CPU- and I/O-Register Content 

The content of CPU- and I/O registers is displayed in the Register Window (select “View -> Register”).  

 
Figure 53 C-Spy Display of CPU- and I/O-Register Content 

Please use the list box at the top of the Register Window to select the registers to be displayed. 

 
Figure 54 C-Spy Register Window 
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6.5 Erase microcontroller built-in flash memory 

 

If the On-Chip Debug Option Byte is set to "Do not erase data of flash memory in case of failures in 
enabling on-chip debugging" and if you forget the security ID, you need to erase the flash memory 
completely. To erase the flash memory, please follow the steps below. 

WriteEZ5 is installed at "2.2.3 Installation of WriteEZ5 Flash Programmer". 

 

1) Start WriteEZ5 by selecting "Windows Start" menu, "Programs", "Renesas Electronics Tools", 
"WriteEZ5", "V1.00", and "WriteEZ5". 

 
Figure 55 WriteEZ5 
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2) Set the switch and the jumper pin on the TK-78K0R/KE3L+USB as follows. 

 
SW1 

1 2 3 4 5 6 7 8 
ON  ON ON ON ON OFF OFF OFF 

Table 11 WriteEZ5 Configuration 

 

Jumper Position 

JP1 short 

JP2 1-2 short 

JP3 1-2 short 

JP4 Short 

SW4 Debug Writer 
Table 12 WriteEZ5 Jumper Setting 

 

3) Then, please connect the PC to “USB2” on the TK-78K0R/KE3L+USB with the USB cable. 

 

 
Figure 56 TK-78K0RKE3L+USB Jumper & Switches 

R20UT0010ED0100 Rev. 1.00  79 
User Manual 



TK-78K0R/KE3L+USB Other Information 

 

4) Push the "Setup" button. 

 
Figure 57 WriteEZ5 Setup Button 

 
5) Push the "PRM File Read" button. 

 
Figure 58 WriteEZ5 Device Setup Dialogue 
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6) Please select the file “78F1026.prm” in the CD-ROM directory “WriteEZ5\PRM78F1026_V100” . 

 

 
Figure 59 WriteEZ5 Parameter File Selection Dialogue 

 

7) "Port" selects the COM port number where TK-78K0R/KE3L+USB is allocated. 

Only the COM port number that the personal computer has is displayed in this pull-down menu. 

 
Figure 60 WriteEZ5 COM-Port Selection 
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8) "Erase": The deletion of the flash memory begins when the button is pushed. 

 
Figure 61 WriteEZ5 Erase Button 

 

9) If Flash EEPROM has been erased successfully, “chip erase finish.” will be displayed. 

 
Figure 62 WriteEZ5 Erase completed successfully 
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6.6 Circuit Diagrams 
Please find the schematics attached to this document. To open the attachments view in the Adobe 
Reader press the paper clip in the lower left corner of the window. To open the attachment, double click 
the TK-78K0R_KE3L+USB_schematics.pdf. 
 


	Chapter 1 Introduction
	Chapter 2 Preparation
	2.1 Development Tools / Software
	2.2 Installation of Development Tools 
	2.2.1 Installation Package
	2.2.2 Installation of Development Tools
	2.2.3 Installation of WriteEZ5 Flash Programmer
	2.2.4 Installation of Sample Applications

	2.3 USB Driver Installation
	2.3.1 Installation on Windows XP
	2.3.2 Installation on Windows 2000
	2.3.3 Completion of USB Driver Installation

	2.4 Sample Programs

	Chapter 3 Experiences
	3.1 Start Embedded Workbench for 78K
	3.2 What is ‘Embedded Workbench for 78K’ ?
	3.3 Open Workspace
	3.4 Build Application
	3.5 Tool Configuration
	3.6 Check Board Settings
	3.7 Start C-Spy Debug Session
	3.8 Run Application Program
	3.9 Stop Application Program
	3.10 Close C-Spy Debug Session
	3.11 Close Embedded Workbench

	Chapter 4 Hardware Specification
	4.1 Layout of hardware functions 
	4.2 Layout of solder-short pad and test pad 
	4.3 Hardware Functions
	4.3.1 SW1, SW4
	4.3.2 SW2 (INTP0)
	4.3.3 SW3 (RESET SW)
	4.3.4 SW5 (Filter)
	4.3.5 JP1
	4.3.6 JP2, JP3
	4.3.7 JP4
	4.3.8 LED1 (POWER)
	4.3.9 U1, U2 (7-segment LED)
	4.3.10 CN1, CN2
	4.3.11 CN3
	4.3.12 J1
	4.3.13 VR1
	4.3.14 USB1
	4.3.15 USB2
	4.3.16 FP1
	4.3.17 Solder-short pad label


	Chapter 5 Troubleshooting
	5.1 If you cannot find USB driver when connecting the kit
	5.2 Error when you start the debugger
	5.2.1 "Can not communicate with Emulator..." (F0100 or A0109)
	5.2.2 "Incorrect ID Code." (Ff603)
	5.2.3 "On-chip debug function had been disabled in the device.” (F0c79)


	Chapter 6 Other Information
	6.1 Create a new Workspace
	6.2 Add one or multiple Projects to a new Workspace
	6.3 Add additional Source Files to a Project
	6.4 Debugger Tips
	6.4.1 Set/delete breakpoints
	6.4.2 Display global Variables
	6.4.3 Display global Variables while Application is running
	6.4.4 Display local Variables
	6.4.5 Display Memory Content
	6.4.6 Display Memory Content while Application is running
	6.4.7 Display of CPU- and I/O-Register Content

	6.5 Erase microcontroller built-in flash memory
	6.6 Circuit Diagrams





 !"#$!%&'!()*+,-./,01230/456758/


"/$)/"/


/


/


/


U
8
C


S
N


7
4
L
V


C
3
G


0
7
D


C
T


6
2


8 4


C
5
3


0
.4


7
u
F


R
5
5


1
M


12


E
V


D
D


R
4


1
.5


K


1
2


+
C


1
1


4
.7


u
F


/2
5
V


P24
P23
P22
P21
P20


U
S


B
1


U
X
6
0
A


-M
B


-5
S


T


V
B


U
S


1


D
-


2


D
+


3


ID
_
N


C
4


G
N


D
5


FG1
FG1FG2
FG2FG3
FG3FG4
FG4


P130


P27
P26
P25


P
1
2
0


P02


P140


P144
P143


P04
P03


L
1


B
L
M


4
1
P


G
7
5
0
S


P
1
2
0


C
1
3


0
.1


u
F


C
1
2


0
.1


u
F


U
S


B
V


D
D


2


P
4
0


P
4
1


T
P


3
L
C


-2


9
:
;/
4
:
7
6
;


P
4
2


T
it
le


S
iz


e
D


o
c
u
m


e
n
t 


N
u
m


b
e
r


R
e
v


D
a
te


:
S


h
e
e
t


o
f


T
S


-T
C


S
0
0
4
6
3


2
.0


T
K


-7
8
K


0
R


/K
E


3
C


+
U


S
B


A
3


1
4


T
u
e
s
d
a
y


, 
M


a
rc


h
 1


6
, 


2
0
1
0


R
2


2
7


1
2


R
3


2
7


1
2


P
4
3


P
1
7


P
1
2
0


C
3


0
.1


u
F


P31


C
9


0
.1


u
F


E
V


D
D


C
N


1


H
IF


3
H


-5
0
D


A
-2


.5
4
D


S
A


1 3 5 7 9 1
1


1
3


1
5


1
7


1
9


2
1


2
3


2
5


2
7


2
9


3
1


3
3


3
5


3
7


3
9


4
1


4
3


4
5


4
7


4
9


2 4 6 8
1
0


1
2


1
4


1
6


1
8


2
0


2
2


2
4


2
6


2
8


3
0


3
2


3
4


3
6


3
8


4
0


4
2


4
4


4
6


4
8


5
0


C
6


0
.4


7
u
F


C
1
0


0
.1


u
F


V
o
l
u
m
e
 
P
W
M


C
N


2


H
IF


3
H


-5
0
D


A
-2


.5
4
D


S
A


1 3 5 7 9 1
1


1
3


1
5


1
7


1
9


2
1


2
3


2
5


2
7


2
9


3
1


3
3


3
5


3
7


3
9


4
1


4
3


4
5


4
7


4
9


2 4 6 8
1
0


1
2


1
4


1
6


1
8


2
0


2
2


2
4


2
6


2
8


3
0


3
2


3
4


3
6


3
8


4
0


4
2


4
4


4
6


4
8


5
0


A
V


R
E


F


E
V


D
D


V
D


D
E


V
D


D


V
D


D


A
V


R
E


F


V
D


D
A


V
R


E
F


+
1
2
V


A
V


R
E


F


V
D


D


E
V


D
D


E
V


D
D


V
D


D


P
4
1


2


T
_
R


E
S


E
T


2


P
4
0


2


F
L
M


D
0


2


R
E


S
E


T
2


R
E


S
E


T


P
1
1
0


X
T
1


P
1
1
1


X
T
2


P
1
0


F
L
M


D
0


P
1
1


Y
1


H
C


M
4
9
-2


0
.0


0
0
M


A
B


J
-U


T


C
4


3
9
P


F
C


5
3
9
P


F


X
1


X
2


X
1


P
1
2


X
2


P
1
3


P
1
4


P
1
5


P
1
6


C
7


4
p
F


Y
2


S
S


P
-T


7
-F


L
 3


.7
p
F


R
1


0


X
T
1


X
T
2


C
8


3
p
F


P
1
7


9
:
;/
4
:
7
6
;


P
5
0


9
:
;/
4
:
7
6
;


9
:
;/
4
:
7
6
;


9
:
;/
4
:
7
6
;


P
5
1


P
5
2


P
5
3


P
1
1


2
P


1
2


2
 
!
"


#
!
"


P
1
6


3
$
%
&


U
5


U
P


D
7
8
F


1
0
2
6


P
1
2
0
/I


N
T
P


0
/E


X
L
V


I
1


P
4
3


2


P
4
2
/T


I0
4
/T


O
0
4


3


P
4
1
/T


O
O


L
1


4


P
4
0
/T


O
O


L
0


5


P
1
2
3
/X


T
1


8


V
D


D
1
5


P
1
2
2
/X


2
/E


X
C


L
K


1
0


V
S


S
1
3


R
E


G
C


1
2


R
E


S
E


T
6


P
1
2
4
/X


T
2


7


P60/SCL0
17


P61/SDA0
18


P62
19


P63
20


F
L
M


D
0


9


P77/KR7/INTP11
22


P76/KR6/INTP10
23


P75/KR5/INTP9
24


P74/KR4/INTP8
25


A
V


S
S


4
8


A
V


R
E


F
4
7


P73/KR3
26


P72/KR2
27


P71/KR1
28


P70/KR0
29


USBP
30


USBM
31


USBPUC
32


P
5
0
/I


N
T
P


1
3
3


P
5
1
/I


N
T
P


2
3
4


P
5
2
/T


O
0
0


3
5


P
5
3
/T


I0
0


3
6


P
1
7
/T


I0
2
/T


O
0
2


3
7


P
1
6
/T


I0
1
/T


O
0
1
/I


N
T
P


5
3
8


P
1
5
/R


T
C


D
IV


/R
T
C


C
L


3
9


P
1
4
/R


X
D


3
4
0


P
1
3
/T


X
D


3
4
1


P
1
2
/S


O
0
0
/T


X
D


0
4
2


P
1
1
/S


I0
0
/R


X
D


0
4
3


P
1
0
/S


C
K


0
0


4
4


P
1
1
0


4
5


P
1
1
1


4
6


P26/ANI6
50 P25/ANI5
51 P24/ANI4
52 P23/ANI3
53 P22/ANI2
54 P21/ANI1
55 P20/ANI0
56


P
1
2
1
/X


1
1
1


E
V


S
S


1
4


E
V


D
D


1
6


P31/TI03/TO03/INTP4
21


P27/ANI7
49


P143/SI20/RXD2/SDA20
62


P144/SO20/TXD2
61


P02/SO10/TxD1
60


P03/SI10/RXD1/SDA10
59


P04/SCK10/SCL10
58


P130
57


P142/SCK20/SCL20
63 P140/PCLBUZ0/INTP6
64


T
P


1
L
C


-2
T
P


2
L
C


-2


'
"
"


(
)
"


V
D


D


E
V


D
D


E
V


D
D


(L
E
F
T
)


(P
U


S
H


)


(U
P
)


(D
O


W
N


)


(R
IG


H
T
)


S
W


2


S
K


R
H


A
B


E
0
1
0
 


1 2 3
654


P
7
0


P
7
1


P
7
4


P
7
3


P
7
2


P
1
1
1


P
1
1
0


P
2
0


P
2
1


P
5
2


P
5
3


P
5
1


P
2
3


P
5
0


P
2
2


P
2
0


P
2
1


P
2
2


P
2
3


P
5
0


P
1
1
0


P
1
1
1


P142
P60
P61


E
V


D
D


U
1


L
A


-3
0
1
M


B


A
1


F
2


G
3


E
4


D
5


D
P


6


D
P


_
A


7


C
8


C
O


M
_
A


9
B


1
0


*
+
,
-
.


*
+
,
-
/


E
V


D
D


U
3


L
A


-3
0
1
M


B


A
1


F
2


G
3


E
4


D
5


D
P


6


D
P


_
A


7


C
8


C
O


M
_
A


9
B


1
0


U
4


S
N


7
4
L
V


C
5
7
4
A


D
G


V


D
1


2


D
2


3


D
3


4


D
4


5


D
5


6


D
6


7


D
7


8


D
8


9


C
L
K


1
1


O
E


1


Q
1


1
9


Q
2


1
8


Q
3


1
7


Q
4


1
6


Q
5


1
5


Q
6


1
4


Q
7


1
3


Q
8


1
2


VCC
20


GND
10


P
5
2


P
5
1


P
5
3


C
1


0
.1


u
F


1 2


E
V


D
D C


2
0
.1


u
F


1 2


E
V


D
D


M
R


1


C
N


1
F


8
K


-2
7
1


1
1
6


2
1
5


3
1
4


4
1
3


5
1
2


6
1
1


7
1
0


8
9


M
R


2


C
N


1
F


8
K


-2
7
1


1
1
6


2
1
5


3
1
4


4
1
3


5
1
2


6
1
1


7
1
0


8
9


E
V


D
D


E
V


D
D


U
2


S
N


7
4
L
V


C
5
7
4
A


D
G


V


D
1


2


D
2


3


D
3


4


D
4


5


D
5


6


D
6


7


D
7


8


D
8


9


C
L
K


1
1


O
E


1


Q
1


1
9


Q
2


1
8


Q
3


1
7


Q
4


1
6


Q
5


1
5


Q
6


1
4


Q
7


1
3


Q
8


1
2


VCC
20


GND
10


S
W


1
-6


C
H


S
-0


8
B


6
1
1


S
W


1
-7


C
H


S
-0


8
B


7
1
0


S
W


1
-8


C
H


S
-0


8
B


8
9


U
6


S
N


7
4
L
V


C
1
G


1
2
6
D


C
K


2
4


5
1


3


P
3
1


3


0
)
1


0
)
2


P
5
0


P
1
0


P
5
2


P
6
0


P
6
2


P
5
1


P
1
2


P
1
1


P
6
1


P
5
3


P
6
3


P
1
4


P
1
3
0


P
1
5


P
1
3


P
4
2


P
1
6


P
1
7


P
2
3


P
2
1


P
1
2
0


P
1
4
3


P
4
0


P70


P
4
1


P
4
3


P
2
2


P
2
0


P
1
4
4


P
1
4
2


P
1
1
0


P
2
7


P
2
5


P
2
4


P
2
6


P
0
4


P
1
4
0


P
7
2


P
7
0


P
1
1
1


P
7
6


P
7
4


T
_
R


E
S


E
T


F
L
M


D
0


P71


P
0
3


P
0
2


P
7
1


P
3
1


P
7
7


P
7
5


P
7
3


P72
P73
P74
P75
P76
P77


P62
P63







 !"#$!%&'!()*+,-./,01230/456758/


"/$</"/


/


/


/


U
8
A


S
N


7
4
L
V


C
3
G


0
7
D


C
T


1
7


8 4


F
L
M


D
0
U


U
8
B


S
N


7
4
L
V


C
3
G


0
7
D


C
T


3
5


8 4


T
x
D


6
U


S
B


T
it
le


S
iz


e
D


o
c
u
m


e
n
t 


N
u
m


b
e
r


R
e
v


D
a
te


:
S


h
e
e
t


o
f


T
S


-T
C


S
0
0
4
6
3


2
.0


T
K


-7
8
K


0
R


/K
E


3
C


+
U


S
B


A
3


2
4


W
e
d
n
e
s
d
a
y


, 
J
a
n
u
a
ry


 2
7
, 


2
0
1
0


R
x
D


6
U


S
B


P
D


1


P
D


0


P
D


2


P
D


5


P
D


6


U
9


U
P


D
7
8
F


0
7
3
0
M


C


P
3
0
/I


N
T
P


1
1


P
0
1
/T


I0
1
0
/T


O
0
0


2


P
0
0
/T


I0
0
0


3


P
1
2
0
/I


N
T
P


0
/E


X
L
V


I
4


R
E


S
E


T
5


F
L
M


D
0


6


P
1
2
2
/X


2
/E


X
C


L
K


/O
C


D
0
B


7


P
1
2
1
/X


1
/O


C
D


0
A


8


R
E


G
C


9


V
s
s


1
0


V
d
d


1
1


U
S


B
R


E
G


C
1
2


U
S


B
P


1
3


U
S


B
M


1
4


U
S


B
P


U
C


1
5


P
1
0
/S


C
K


1
0


3
0


P
1
1
/S


I1
0


2
9


P
1
2
/S


O
1
0


2
8


P
1
3
/T


x
D


6
2
7


P
1
4
/R


x
D


6
2
6


P
1
5


2
5


P
1
6
/T


O
H


1
2
4


P
1
7
/T


I5
0
/T


O
5
0


2
3


P
3
3
/T


I5
1
/T


O
5
1


2
2


E
V


s
s


2
1


E
V


d
d


2
0


P
3
1
/I


N
T
P


2
/O


C
D


1
A


1
9


P
3
2
/I


N
T
P


3
/O


C
D


1
B


1
8


P
6
0


1
7


P
6
1


1
6


C
2
0


0
.1


u
F


+
C


1
7


4
.7


u
F


/2
5
V


C
1
4


0
.1


u
F


C
2
4


0
.1


u
F


1 2


C
1
5


0
.1


u
F


R
1
9


1
.5


K


1
2


R
1
6


2
7


1
2


T
P


U
2


1


C
2
3


0
.1


u
F


1 2


R
1
5


1
.5


K
1


2


R
1
3


1
0
K


1
2


T
P


U
6


1


U
1
1


S
N


7
4
L
V


C
2
T
4
5
D


C
U


V
C


C
A


1


G
N


D


4


A
1


2
B


1
7


V
C


C
B


8


D
IR


5


A
2


3
B


2
6


U
S


B
2


U
X
6
0
A


-M
B


-5
S


T


V
B


U
S


1


D
-


2


D
+


3


ID
_
N


C
4


G
N


D
5


FG1
FG1FG2
FG2FG3
FG3FG4
FG4


R
9 1
.5


K


R
2
2


1
0
0
K


1
2


C
1
6


0
.4


7
u
F


T
P


U
7


1


T
P


U
4


1


R
8


1
0
K


1
2


T
P


U
8


1


R
1
4


1
0
0
K


R
2
0


1
0
0
K


3
4
5
#
6
7
7
8
4
5
9
+
/


:
"
,
;
<
-
=
%
>
?
@
,
>


U
7
B


S
N


7
4
L
V


C
2
G


1
2
5
D


C
U


5
3


8


7


4


C
1
8


0
.4


7
u
F


R
1
1


1
0
0


1
2


U
1
0


S
N


7
4
L
V


C
1
G


1
2
5
D


C
K


2
4


5


1


3


T
P


U
1


1


R
1
7


2
7


1
2


R
7


4
.7


K


R
1
0


1
0
0
K


L
2


B
L
M


4
1
P


G
7
5
0
S


T
P


U
9


1


R
1
8


1
0
K


12


C
1
9


0
.1


u
F


F
L
M


D
0
U


R
5


1
0
0
K


C
2
2


0
.1


u
F


S
W


3


S
K


Q
M


B
B


1
2


T
P


U
5


1


T
P


U
3


1


M
R


3


C
N


1
E


4
K


-1
0
5
J1


8
2


7
3


6
4


5


Y
3


C
S


T
C


E
1
6
M


0
V


5
3
-R


0


1 3


2


C
2
1


0
.1


u
F


R
1
2


1
0
K


1
2


R
6


1
.5


K


1 2


U
7
A


S
N


7
4
L
V


C
2
G


1
2
5
D


C
U


2
6


8


1


4


E
V


D
D


U
S


B
V


D
D


E
V


D
D


U
S


B
V


D
D


U
S


B
V


D
D


U
S


B
V


D
D


U
S


B
V


D
D


U
S


B
V


D
D


E
V


D
D


E
V


D
D


U
S


B
V


D
D


E
V


D
D


E
V


D
D


E
V


D
D


E
V


D
D


E
V


D
D


E
V


D
D


E
V


D
D


U
S


B
V


D
D


R
E


S
E


T
1


U
S


B
V


D
D


F
L
M


D
0


1


P
4
1


1


T
_
R


E
S


E
T


1


R
x
D


6
U


S
B


T
x
D


6
U


S
B


R
2
1


1
0
0
K


E
V


D
D


S
W


4


S
S


S
S


2
2
3
6
0
0


1 2 4 5 6 8


3 7


P
D


1
P


D
2


P
D


6


P
D


0


A
+
B
?
,
C
D
E


P
4
1


R
E


S
E


T


F
L
M


D
0


P
4
0


&
F
)
F
0
9
/
G
1
H
F
=
I


F
P


1


H
IF


3
F


C
-1


6
P


A
-2


.5
4
D


S
A


G
N


D
1


S
I


3


S
O


5


7
7


9
9


1
1


1
1


1
3


1
3


R
E


S
E


T
_
IN


1
5


R
E


S
2


V
D


D
4


6
6


8
8


1
0


1
0


1
2


1
2


F
L
0


1
4


C
L
K


_
IN


1
6E
V


D
D


S
W


1
-1


C
H


S
-0


8
B


1
1
6


S
W


1
-2


C
H


S
-0


8
B


2
1
5


S
W


1
-3


C
H


S
-0


8
B


3
1
4 P


4
0


1


P
1
1


1


P
1
2


1


#
G
+
G
 
H
+
%


R
E


S
E


T


P
D


5







 !"#$!%&'!()*+,-./,01230/456758/


"/$=/"/


/


/


/


/


R
5
3


0


R
5
0


1
0
K


1 2


R
4
6 2
0
K


1
2


C
4
5


1
.0


u
F


C
4
0


1
0
0
0
p
F


S
W


5


S
S


S
S


2
2
2
7
0
0


1
2


4
5


63


U
1
5


S
N


7
4
L
V


C
1
G


0
7
D


C
K


2
4


5 3


1


- +


U
1
3
B


L
M


V
3
2
4
M


56
7


4 11


C
4
4


1
.0


u
F


R
5
2


1
0
K


1 2


+
C


4
6


4
.7


u
F


/2
5
V


R
4
7 1
2
K


1
2


R
3
6


3
6
k


1
2


C
2
8


0
.1


u
F


R
2
5


2
2
K


1
2


R
5
1


1
K


1
2


A
G
N
D


C
2
9


2
2
0
0
p
F


C
4
1


6
8
0
0
p
F


R
2
3


3
3
K


1
2


C
3
9


1
8
0
0
p
F


R
3
4


2
4
K


1
2


N
F


1
N


F
M


4
1
P


C
2
0
4
F


1
H


3
1


2


3


R
3
5


3
6
K


1
2


R
4
3


1
0
K


1 2


A
V


D
D


A
V


D
D


A
V


D
D


A
V


D
D


A
V


D
D


A
V


D
D


A
V


D
D


A
V


D
D


A
V


D
D


A
V


D
D


E
V


D
D


A
V


D
D


A
V


D
D


P
1
6


1


A
V


D
D


A
V


D
D


P
3
1


1


A
G
N
D


V
o
l
u
m
e
 
P
W
M


A
G
N
D


J
1


L
G


Y
6
5
0
2
-0


9
0
0
F


C


123
R


IG
H


T


+
$
G
.
4
G
#
H
J
9
 
$
9
 


P
W
M
 
I
N


.
<
D
?
K


A
G
N
D


A
G
N
D


A
G
N
D


A
G
N
D


A
G
N
D


A
G
N
D


A
G
N
D


A
G
N
D


A
G
N
D


A
G
N
D


A
G
N
D


A
G
N
D


A
G
N
D


A
G
N
D


A
G
N
D


A
G
N
D


A
G
N
D


A
G
N
D


A
G
N
D


A
G
N
D


A
G
N
D


A
G
N
D


A
G
N
D


A
G
N
D


V
R


1


C
T
6
-E


P
1
0
K


(1
0
3
)


1
3


2


A
G
N
D


A
G
N
D


R
4
9


X
X
X


1
2


J
P


4


F
F


C
-2


A
M


E
P


1


1
2


A
G
N
D


'
K
C
<
L
,


A
G
N
D


S
W


1
-5


C
H


S
-0


8
B


5
1
2


J
3


C
O


N
2


1 2


P
3
1


J
P


1


F
F


C
-2


A
M


E
P


1


1
2


T
it
le


S
iz


e
D


o
c
u
m


e
n
t 


N
u
m


b
e
r


R
e
v


D
a
te


:
S


h
e
e
t


o
f


T
S


-T
C


S
0
0
4
6
3


2
.0


T
K


-7
8
K


0
R


/K
E


3
C


+
U


S
B


A
3


3
4


W
e
d
n
e
s
d
a
y


, 
J
a
n
u
a
ry


 2
7
, 


2
0
1
0


C
3
2


1
0
0
0
p
F


+


C
2
5


1
0
u
F


/2
5
V


R
4
1


3
6
K


1 2


C
3
4


1
0
0
0
p
F


R
4
2


2
4
K


1 2


R
3
3


2
4
K


1
2


R
3
7


1
0
K


1 2


R
2
4 3
3
K


1
2


C
3
0


2
2
0
0
p
F


+
C


2
6


4
.7


u
F


/2
5
V


C
3
3


1
0
0
0
p
F


- +


U
1
3
D


L
M


V
3
2
4
M


1
2


1
3


1
4


4 11


U
1
2


S
N


7
4
L
V


C
1
G


1
4
D


C
K


N
C


1


A
2


G
N


D
3


Y
4


V
C


C
5


- +


U
1
3
C


L
M


V
3
2
4
M


1
09


8


4 11


R
4
8 1
8
K


1
2


R
3
2


3
9
K


1
2


U
1
4


L
M


4
8
6
5
M


M


VDD
1


-V
in


2


H
P


 S
e
n
s
e


3


D
C


 V
o
l/
S


D
4


V
o
1


5


GND
6


B
y


p
a
s
s


7
V


o
2


8


C
3
5


1
0
0
0
p
F


- +


U
1
3
A


L
M


V
3
2
4
M


32
1


4 11


C
3
8


1
2
0
0
p
F


C
3
6


1
0
0
0
p
F


C
4
3


0
.2


2
u
F


C
3
1


2
2
0
0
p
F


P
1
6


R
3
1


3
9
K


1
2


R
4
5


1
0
K


1 2


R
4
4


1
0
K


1 2


C
4
2


0
.1


u
F


R
2
7


2
2
K


1 2


R
3
0


X
X
X


C
2
7


0
.1


u
F


R
3
9


3
9
K


1 2


R
2
9


2
0
K


1 2


R
3
8


1
2
K


1 2


C
3
7


1
0
0
0
p
F


C
4
7


0
.1


u
F


R
4
0


3
0
K


1 2


R
2
6


1
0
K


1 2


R
2
8


2
0
K


1 2







 !"#$!%&'!()*+,-./,01230/456758/


/


/


/


/


/


/


/


9
+
/
H
$
K
M
,
>


H
H
2
7
1
N
"
,
;
<
-
H
9
+
/


H
H
1
7
O
N
'
P
Q
5
H
9
+
/


T
it
le


S
iz


e
D


o
c
u
m


e
n
t 


N
u
m


b
e
r


R
e
v


D
a
te


:
S


h
e
e
t


o
f


T
S


-T
C


S
0
0
4
6
3


2
.0


T
K


-7
8
K


0
R


/K
E


3
C


+
U


S
B


A
3


4
4


W
e
d
n
e
s
d
a
y


, 
J
a
n
u
a
ry


 2
7
, 


2
0
1
0


+
C


5
1


1
0
u
F


/2
5
V


J
P


3


F
F


C
-3


A
M


E
P


1


2
1 3


+
C


5
0


1
0
u
F


/2
5
V


U
1
6


T
P


S
2
1
4
8
ID


G
N


O
U


T
1


1


V
IN


/S
W


IN
1


2
L
D


O
_
O


U
T


3


O
U


T
2


4


G
N


D
5


L
D


O
_
E


N
6


E
N


2
7


E
N


1
8


U
1
7


L
M


1
1
1
7
M


P
X
-3


.3


V
IN


3
V


O
U


T
2


GND
1


T
T
A


B


L
E


D
1


P
G


1
1
1
2
H


R
5
4


3
3
0


+
C


5
2


1
0
u
F


/2
5
V


C
4
9


0
.1


u
F


C
N


3
H


E
C


0
4
7
0
-0


1
-6


3
0


1 2 3J
P


2


F
F


C
-3


A
M


E
P


1


2
1 3


+
C


4
8


4
.7


u
F


/2
5
V


J
2


C
O


N
2


1 2


V
D


D


+
1
2
V


V
D


D


U
S


B
V


D
D


U
S


B
V


D
D


2


S
W


1
-4


C
H


S
-0


8
B


4
1
3


$
K
M
,
>


H
H
2
7
1
N
9
+
/


H
H
1
7
O
N
.
0
H
.
D
R
S
@
,
>


$
J
%
G
#


"/$>/"/





