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This document is intended to help new or existing developers quickly start evaluating the EVB and using SDK to 
develop Wi-Fi applications with the RA6W1 chipset.
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1.    Terms and Definitions
API  Application Program Interface
Arm  Advanced Risk Machine
Bluetooth LE  Bluetooth® Low Energy
COM  Communication Port
CPU  Central Processing Unit
DMP  Dynamic Power Management
EVB  Evaluation Board
EVK  Evaluation Kit
FSP  Flexible Software Package
GCC  GNU Compiler Collection
GPIO  General-Purpose Input/Output
IC  Integrated Circuit
IDE  Integrated Development Environment
MCU  Micro Controller Unit
PMGR  Power Manager
QSPI  Quad Serial Peripheral Interface
RAM  Random Access Memory
ROM  Read Only Memory
RTC  Real Time Clock
RTOS  Real Time Operating System
SD  Secure Digital
SDK  Software Development Kit
SMA  SubMiniature version A
SPI  Serial Peripheral Interface
UART  Universal Asynchronous Receiver/Transmitter
UDP  User Datagram Protocol
WLCSP  Wafer Level Chip Scale Package
WSL  Windows Subsystem for Linux 
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2.    References
 [1]   RA6W1 Datasheet, Renesas Electronics.
 [2]   RA6W1 DEVKT Electric Schematic, Renesas Electronics.
 [3]   RA6W1 EVK Hardware Description, Manual, Renesas Electronics.
 [4]   RA6W1 FSP Documentation, Renesas Electronics.

Note 1 References are for the latest published version, unless otherwise indicated.

3.    Overview
RA6W1 is a highly integrated ultra-low-power Wi-Fi system on chip (SoC)  that allows you to develop Wi - Fi solutions 
using a single chip. This Getting Started Guide provides an overview of setting up the RA6W1 EVK, Programming the 
released SDK images, instructions for importing and building images with the sample project template using e2 studio 
Integrated Development Environment (IDE).
The following are the quick guidelines to start using EVB:
 n RA6W1 EVB hardware (see Section 4 Evaluation Kit).
 n Setting up the evaluation board (see Section 5 Set Up RA6W1 EVK).
 n Programming firmware image (see Section 5.1  Firmware Image Programming).
 n Configuring EK- RA6W1 Serial Debug Interface image (see Section 5.2 Configure RA6W1 EVK Serial Debug 

Interface).
 n Provisioning Wi-Fi (see Section 5.3 Provision Wi-Fi).
 n Evaluating throughput with iPerf (see Section 6.1 Test Throughput with iPerf Traffic Generator).
 n Measuring current consumption (see Section 6.2 Measure Current Consumption).
 n Software Development Kit and Build Setup (see Section 7 Software Development Kit and Build Setup).
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4.    Evaluation Kit
The RA6W1 EVK is designed to test and develop Wi-Fi applications quickly. The EVK is provided to simplify the 
process of starting a project with the RA6W1.
The EVKcontains:
 n Evaluation kit (EVK): made by a motherboard with debugging and power measurement circuitry and a daterboard 

containing the RA6W1 chip and related needed circuitry.
 n USB cable.

4.1  RA6W1 EVK
Figure 1 shows the hardware configuration of the RA6W1 EVK and Table 1 shows EK-RA6W1 components and 
descriptions.
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Figure 1. RA6W1 EVK hardware configuration

Table 1. RA6W1 EVK components
No Name Description
1 USB302 – USB port Provides power  and data port for the RA6W1 EK.

2 U301 – USB HUB Connects  JTAG and UART interfaces to the PC.

3 J201/J203     – 
Signal/Power breakout 
headers

Exposes  all the pins of the Daughterboard and Motherboard to allow wiring for custom  
configurations as well as monitoring of the hardware signals. See Figure 2and Figure 3.

4 U201- daughterboard 
connector

The interface  mating connector for the Daughterboard.

5 J206/J207/J215/J216  - 
Arduino sockets 

The sockets  for plugging in Arduino interface add-on boards. See Figure 9.

6 J208/J209  - 
MikroBUS™ sockets 

Sockets  for plugging in MikroBUS™ interface add-on boards. It is multiplexed with  PMOD (to be 
used with DA1453x). See Figure 13.

7 J219  - PMOD The socket  for plugging in PMOD interface add-on boards. J319 is a header, No mounted.  J219 and 
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No Name Description
connectors J319 share some signals which are multiplexed with MikroBUS™. See  Figure 5.

8 J607 - Push-buttons J607  push-button used to reset Daughterboard, J608/J609/J610 push buttons for  general use. See 
Figure 11.

9 J2/J102  - Power 
selection

The  current sense circuit option. Using this current measurement circuit, you can  monitor the current 
consumption of Daughterboard through Smart Snippets  Toolbox software application.

10 J105/J106/J107  - I/O 
voltage selection 

Selects  the I/O voltage applied to the Daughterboard (1.8 V, 3.3 V).

11 U503 - Current sense The  current sense circuit.

12 J3 - SPI interface 
switch 

Selects  the I/O voltage generated for the Daughterboard board (1.8 V, 3.3 V). See Figure 14.

13 U302 - USB interface 
IC

Provides  communication between Daughterboard UART port and PC. It also transfers the  current 
measurement samples to PC.

14 U7 - Level translators  Transfers  the data between Daughterboard and FTDI (U302) in proper voltage level.

15 J405 - External J-link 
connector 

Provides access toWi-Fi SoC or Bluetooth LE SoC. See Figure 6.

16 U401 – MCU Place where  the SWD implementation of SEGGER applied.

17 J220 - SDIO header Must be mounted.

18 J601 – Trigger The trigger  signals monitored and presented on Smart Snippets Toolbox. See Figure 12.

19 U2/U6/U8/U9 -  Level 
translators 

For  the interface section (PMOD, Android and MikroBUS).

20 J611 – LEDs Four  LEDs are connected to this header. To enable an LED, a jumper wire must be  connected 
between a GPIO and one of the pins of J611.

21 U202 - PSRAM PSRAM.  See Figure 4.

22 J6 – AIN GND AIN  is a generic Analog Input which is accessible on J6 header.

23 Daughterboard  

Figure 2. Breakout header J201
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Figure 3. Breakout header J203

Figure 4. PSRAM

Figure 5. PMOD

Figure 6. External J-link connector
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Figure 7. Auxiliary UART

Figure 8. Programming RA4M2

Figure 9. Arduino Interface
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Figure 10. Daughter_Board Connector

Figure 11. Buttons
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Figure 12. Trigger

Figure 13. Micro BUS

Figure 14. J3
Figure 15 shows the hardware configuration of the daughterboard of RA6W1 EVK.
NOTE
Renesas recommends using a daughterboard with antenna.
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Figure 15. RTK RA6W1 daughterboard
Table 2 shows the components of EK-RA6W1  daughterboard.
Table 2. RA6W1 EVK daughterboard components
No Name Description
1 U101 – RA6W1 RA6W1 – WLCSP

2 U102 – Serial flash Serial flash – AT25SL641

3 Y101 – Crystal 40 MHz crystal

4 Y102 – Crystal 32.768 kHz crystal

5 U202 – J-flash connector J-link for SPI flash connector

6 J101 – SMA connector SMA connector for external antenna

7 J201 – Reset switch Switches to reset the RA6W1
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5.    Set Up RA6W1 EVK
Before setting up ensure that the Evaluation Kit (EVK) and the required software are properly connected and installed. 
Use the USB cable included in the EVK to connect the host computer and the EVK. When the EVB is connected to the 
USB port (USB302 on the RA6W1 EVK) USB Serial COM ports are created.
 n For Windows, three USB Serial COM ports are displayed in the device manager (see Figure 16).

Figure 16. Windows – COM ports
NOTE
If Windows Device Manager displays Unknown Device, the FTDI serial driver is not installed. Download the driver by following 
the URL and installing it manually: http://www.ftdichip.com/Drivers/.

The lower numbered J-Link CDC UART Port (COM7, in this case) is the onboard J-Link. The next USB Serial Port 
(COM8, in this case) is for the RA6W1 debug interface. The higher numbered USB Serial Port (COM9, in this case) is 
for the RA6W1 AT command interface or current consumption measurement. A serial terminal application can be used 
for debugging RA6W1.
The Tera Term terminal emulator program is recommended and can be downloaded from 
https://github.com/TeraTermProject/teraterm/releases/tag/v5.2.
 n For Linux, two Serial COM ports are created. It can be checked using the following command in Terminal.

developer:~$ ls /dev/ttyUSB*
developer:~$ /dev/ttyUSB0 /dev/ttyUSB1

The lower numbered USB Serial Port (/dev/ttyUSB0, in this case) is for the RA6W1 debug interface. The higher 
numbered USB Serial Port (/dev/ttyUSB1, in this case) is for the RA6W1 AT command interface or current 
consumption measurement. A serial terminal application can be used for debugging RA6W1.
Minicom is recommended for Linux and to install minicom on Linux, run this command:

developer:~$ sudo apt-get install minicom

When the terminal emulation application is installed, connect the USB cable to USB302 on the RA6W1 EVK and start 
the terminal emulation program. In the terminal emulation program, go to the Serial Port setup and select the preferred 
COM Port.

5.1   Firmware Image Programming
5.1.1    Program Firmware Images for Windows
Programming firmware images to the EVK requires the Renesas Flash Programmer (RFP) tool. The RFP provides a 
graphical interface to flash binary images into the RA6W1 EVK through the on-chip debug interface.
System requirements:
 n OS: Windows 11 (64 bit)
 n USB drivers (installed along with RFP setup)
 n Renesas Flash Programmer V3.21.00 or later
 n Hardware: RA6W1 EVK.
To program firmware:
 1. Download and launch the Renesas Flash Programmer installer.
 2. In the Software License Agreement dialog, select Agree, then click Next.

http://www.ftdichip.com/Drivers/
https://github.com/TeraTermProject/teraterm/releases/tag/v5.2
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 3. During installation, in the Windows Security dialog, to install the Renesas USB driver, select Always trust 
software from ″Renesas Solutions Corp.″, and click Install, and then click Next.

Figure 17. Windows Security prompt for USB driver installation
 4. After installation is completed, to exit the setup, click Finish.
 5. From the Windows Start menu, launch the Renesas Flash Programmer tool.

Figure 18. RFP GUI
 6. Connect the RA6W1 EVK to the PC using the USB debug interface.
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Figure 19. RA6W1 EVK hardware
 7. In the tool, to create a new project, go to File > New Project, and do the following:

 a. In Microcontroller, select the RA6W1, RA6W2 as the target microcontroller.

Figure 20. Selecting target microcontroller
 b. In Project Name, enter a project name and click Connect.
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Figure 21. Connecting RA6W1RA6W2 EVK
After the device is connected, the status message displays Operation completed.

Figure 22. Connection status – operation completed
 8. In the File Details dialog, to confirm the file selection, click OK.
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Figure 23. Confirming file selection
 9. In Renesas Flash Programmer, to flash the image, click Start.

Figure 24. Start programming
The Progress Report dialog appears, showing the running progress.
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Figure 25. Progress report
When the programming is completed, the status window displays ″Operation completed″, indicating that the 
firmware image is successfully written to the RA6W1 EVK.

Figure 26. Programming completed successfully

5.1.2    Program Firmware Images for Linux
Programming firmware images to EVK in Linux requires the CLI tool of Renesas Flash Downloader.
System requirements:
 n OS: Ubuntu 22.04.4 LTS or later.
 n J-Link Linux driver – J-Link Version 864 or later.
 n Renesas Flash Programmer V3.21.00 or later
 n Hardware: RA6W1RA6W2 EVK.
To program the firmware:
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 1. Extract the RFP_CLI_Linux_V32100_x64.tgz.

tar -xzf RFP_CLI_Linux_V32100_x64.tgz

 2. Go to the extracted folder and check the J-Link serial number.

cd linux-x64/
./rfp-cli -d RA6W1 -lt

 3. Program the firmware.

./rfp-cli -d RA6W1 -tool jlink:<jlink_serial_no> -if swd -s 25M -auto -bin 0 <path_to_.img 
file>

For example of successful operation, see Figure 27.

Figure 27. Programming of firmware in Linux

5.1.3    Program Firmware Images for macOS
Programming firmware images to EVK in macOS requires the CLI tool of Renesas Flash Downloader.
System requirements:
 n OS: Mac OS 14 (Sonoma) or later versions.
 n J-Link driver – J-Link Version 864 or later.
 n Renesas Flash Programmer V3.21.00 or later
 n Hardware: RA6W1 EVK.
To program firmware:
 1. Extract the RFP_CLI_macOS_V32100_arm64.zip.

tar -xzf RFP_CLI_macOS_V32100_arm64.zip

 2. Go to the extracted folder and check the J-Link serial number.

cd macos-arm64
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./rfp-cli -d RA6W1 -lt

 3. Program the firmware using this command:

./rfp-cli -d RA6W1 -tool jlink:<jlink_serial_number> -if swd -s 25M -auto -bin 0 <path_to_.img 
file>

For example of successful operation, see Figure 28.

Figure 28. Programming of firmware in macOS

5.2  Configure RA6W1 EVK Serial Debug Interface
The RA6W1 provides a command/debug interface on UART0 for performing configuration and diagnostic functions. 
Connect the USB cable to the USB302 on the RA6W1 EVK and start the terminal emulation program.

5.2.1    Configure Tera Term Serial Terminal Application for Windows
 1. In the Tera Term program, go to the Serial Port setup and select the lower numbered COM port (COM8, in this 

case) and configure it as in Table 3 and Table 4.
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Figure 29. Serial port setup
 2. Connect USB cable to RA6W1 EVK and pressing Enter. The following prompt appears in the UART console:

[/RA6W10
Table 3. Serial port configuration values

Settings Value
Baud Rate 115200

Data Bits 8

Parity None

Stop Bits 1

Flow Control (Hardware/Software) None
Table 4. Terminal settings

Settings Value
Receive LF

Transmit CR + LF

5.2.2    Configure Minicom for Linux
 1. Connect the USB cable to the USB302 on the RA6W1 EVK and open a terminal for the minicom.
 2. Start minicom using the following command:

developer:~$ sudo minicom -D /dev/ttyUSB0

 3. Enter the password. 
After entering the password, minicom terminal view opens, see Figure 30.
NOTE
/dev/ttyUSB0 is for the debug interface and /dev/ttyUSB1 is for the AT command interface
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Figure 30.  Minicom terminal view
 4. To configure minicom, press Ctrl+A followed by Z. It prompts a command summary as shown in Figure 31.

Figure 31. Minicom command summary
 5. When prompt appears, type O to select O for "cOnfigure Minicom..O".
 6. In the configuration prompt, select Serial port setup.
 7. Configure minicom values using letters as shown in Table 3 using letters to configure. For example, to select Baud 

rate, use E.

Figure 32. Setting minicom values
 8. After it is configured, use "setup as dfl" for saving as default. 
 9. Press Enter. 

The Configuration saved dialog appears.
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Figure 33. Configuration saved
 10. Click Exit.
 11. For proper minicom printing, press Ctrl+A followed by Z. It prompts the command summary in Figure 34.

Figure 34. Minicom command summary window
 12. Select U for Add Carriage Ret..U.
 13. To complete the configuration, press Enter. See Figure 35.

Figure 35. Successful configuration

5.2.3    Configure RA6W1 EVK AT Command Interface
5.2.3.1    AT Command Jumper Configuration

For using ATCommands, flash 8.0.2.0.X_rm_wifi_test_app_at_uart.img.
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The following jumper connections are necessary to facilitate the AT command UART connection, see Figure 36:
 n Connect P0_04 on J201 to FD0_SCLK_DA on J203
 n Connect P0_05 on J201 to FD1_DI_DA on J203
 n Connect FD3_CS on J3 to FD3_CS_D on J3
 n Connect FD2_DO on J3 to FD2_DO_D on J3
 n Connect FD1_DI on J3 to FD1_DI_D on J3
 n Connect FD0_SCLK on J3 to FD0_SCLK_D on J3
After connecting the jumpers, connect the RA6W1 to laptop through USB cable to access the AT command terminal.
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Figure 36. Jumper connections

5.2.3.2    AT Command Terminal Configuration

The RA6W1 provides an AT command interface on UART1 for performing configuration. Connect the USB cable to the 
USB302 on the RA6W1 EVK and start the terminal emulation program. In the terminal emulation program, go to the 
Serial Port setup and select the higher numbered COM port (COM9, in this case) and configure it as in Table 3  and  
Table 4.
When connecting USB cable to EK-RA6W1, the screen is initially blank. Enter the following command (which is hidden 
by default) in the blank screen to enable echo output:

ATE //(hidden)
Echo on //(command return)
OK

5.3  Provision Wi-Fi
Provisioning a Wi-Fi device is the process of setting up the device to connect to a network and function properly. This 
involves configuring network settings, ensuring secure authentication, and assigning necessary parameters.

5.3.1    Factory Reset (Optional)
Factory reset reverts the board to default configurations. To reset the board to default settings, enter: factory in the 
UART console window through Tera Term (or your console emulator).
After Factory Reset, the RA6W1 reboots. The Easy Setup Wi-Fi configuration wizard appears automatically.
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5.3.2    Setup for Station Mode
You can configure the Wi-Fi functions of the RA6W1 by running the Easy Setup Wi-Fi configuration wizard.
NOTE
In case of factory reset, the Easy Setup Wi-Fi configuration wizard appears and then follows the following prompts. If 
reconfiguring, complete the following step.

To configure the RA6W1 for operating in Station mode, open its debug console and run the setup command at the 
[/RA6W1] prompt. To complete the setup, follow the following prompts:

[/RA6W1-RRQ61001] # setup                        Start the Easy Setup Wizard.
 
Stop all services for the setting.
Are you sure ? [Yes/No] : Y                        Enter Y to stop the services.
 
[RA6W1-RRQ61001 EASY SETUP - V4]
 
Country Code List:
AD  AE  AF  AI  AL  AM  AN  AR  AS  AT  AU  AW  AZ  BA  BB  BD  BE  BF  BG  BH
BL  BM  BN  BO  BR  BS  BT  BY  BZ  CA  CF  CH  CI  CL  CN  CO  CR  CU  CX  CY
CZ  DE  DK  DM  DO  DZ  EC  EE  EG  ES  ET  EU  FI  FM  FR  GA  GB  GD  GE  GF
GH  GL  GP  GR  GT  GU  GY  HK  HN  HR  HT  HU  ID  IE  IL  IN  IR  IS  IT  JM
JO  JP  KE  KH  KN  KP  KR  KW  KY  KZ  LB  LC  LI  LK  LS  LT  LU  LV  MA  MC
MD  ME  MF  MH  MK  MN  MO  MP  MQ  MR  MT  MU  MV  MW  MX  MY  NG  NI  NL  NO
NP  NZ  OM  PA  PE  PF  PG  PH  PK  PL  PM  PR  PT  PW  PY  QA  RE  RO  RS  RU
RW  SA  SE  SG  SI  SK  SN  SR  SV  SY  TC  TD  TG  TH  TN  TR  TT  TW  TZ  UA
UG  UK  US  UY  UZ  VA  VC  VE  VI  VN  VU  WF  WS  YE  YT  ZA  ZW  ZZ
 
COUNTRY CODE ? [Quit] (Default KR, ZZ : for debug) : KR           Enter the country code.
 
SYSMODE(WLAN MODE) ?
        1. Station
        2. Soft-AP
        3. WiFi Direct
        4. WiFi Direct P2P GO Fixed
        5. Station & Soft-AP
MODE ?  [1/2/3/4/5/Quit] (Default Station) : 1                      Enter 1 for Station mode.
 
BAND ?
        1. 2.4 GHz
        2. 5 GHz
        3. AUTO
BAND ?  [1/2/3/Quit] (Default 3. AUTO) : 1                  Choose WiFi Frequency Band.
 
[ STATION CONFIGURATION ]
============================================================
[NO] [SSID]                         [SIGNAL] [CH] [SECURITY]
------------------------------------------------------------
[ 0] ASUS_TPT_24G                       -48   1         WPA2
[ 1] ASUS_KEYSGT_24G                    -50  11         WPA2
[ 2] SK_WiFiGIG_24G                     -54   6         WPA3
[ 3] ASUS_JIT_EAP_24G                   -56  6 WPA + WPA2 ENT
[ 4] DIRECT-GM2020                      -66  11  WPA2 + WPA3
[ 5] olleh_WiFi_B602                    -67   6         WPA2
[ 6] KT_GiGA_2G_Wave2_04A               -70   6         WPA2
[ 7] Vantest24g                         -79   6         OPEN
[ 8] [Hidden]                           -81   6         WPA2
------------------------------------------------------------
[Enter] Rescan
============================================================
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Select SSID ? (0~8/Manual/Quit) : 0                    Enter the SSID NO from the list.
 
 PSK-KEY(ASCII characters 8~63 or Hexadecimal characters 64) ? [Quit]
**********                                Enter the password for the AP.
 
Do you want to set advanced WiFi configuration ? [No/Yes/Quit] (Default No) : N                                                                                                        
                                                                     Enter N to skip this step.
Enable DPM (Dynamic Power Management) ? [Yes/No/Manual/Quit] : N
 
============================================
BAND        : 2.4 GHz
SSID        : ASUS_TPT_24G
Security    : WPA2PSK
ENCRYPTION  : AES(CCMP)
Password    : **********
PMF         : Default
============================================
WIFI CONFIGURATION CONFIRM ? [Yes/No/Quit] : Y                     Enter Y to confirm the 
configuration.
 
 
IP Connection Type ? [Automatic IP/Static IP/Quit] : A            Enter A for automatic DHCP IP 
address.
 
 
IP Connection Type: Automatic IP
IP CONFIGURATION CONFIRM ? [Yes/No/Quit] : Y                        Enter Y to confirm the 
configuration.
 
 
SNTP Client enable ? [Yes/No/Quit] : N                            Enter N to disable time sync.
 
 
[/RA6W1-RRQ61001] #
Connection COMPLETE to cc:28:aa:7f:02:48
 
>>> Network Interface (wlan0) : UP
         Assigned addr   : 192.168.50.130
               netmask   : 255.255.255.0
               gateway   : 192.168.50.1
         DHCP Server IP  : 192.168.50.1
         Lease Time      : 24h 00m 00s
         Renewal Time    : 12h 00m 00s
 

The configuration is now completed and stored in NVRAM.
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6.    Test Procedures
The following sections describe several tests that verify the proper operation of the RA6W1 and demonstrates its 
various features.
The tests include:
 n Throughput Test – demonstrates the Wi-Fi performance of the RA6W1.
 n Current Consumption Measurements – demonstrates the amount of power used when the RA6W1 is in various 

Sleep modes or in Operational DPM mode.

6.1  Test Throughput with iPerf Traffic Generator
iPerf is a free IP-based a traffic generator tool that can be used for active measurements of the maximum achievable 
bandwidth on IP networks.
iPerf 2.1.3 (recommended) for Windows and Linux can be downloaded from 
https://sourceforge.net/projects/iperf2/files/.
There are various test setup types that can be used for Wi-Fi throughput tests:
 n Conducted – uses RF cables to connect the communicating devices. This effectively eliminates issues caused by 

the wireless domain.
 n Wireless/Over the Air – uses antennas connected to the station and access point, as opposed to RF cables, thus 

introducing additional elements and better replicating real-life usage.
 n Hybrid (Wireless plus Attenuation Control) – is the same as a wireless test setup, using antennas, but digital 

attenuators are also introduced as part of the signal path between the AP’s RF ports and antennas. This allows for 
total control over the RSSI, replicating varying distance between the Access Point and Station.

The provided examples work in any of the above scenarios.
NOTE
For clean and accurate results, Renesas recommends using an anechoic RF chamber for any of the mentioned tests.
Also use a dedicated Access Point for tests. If iPerf does not work and the issue is related to firewall restrictions, contact IT 
department.

6.1.1    Configure Testbed
To configure the Testbed:
 1. Download iPerf 2.1.3 from https://sourceforge.net/projects/iperf2/files/.
 2. Create a folder called "iperf" in the C:\ directory.
 3. Unzip the downloaded iPerf file (if necessary) and move the contents to the "iperf" folder.
 4. Rename the downloaded iperf executable file from "iperf-2.1.3-win.exe" to "iperf.exe".
 5. To ensure stable iPerf testing, run the Windows Security APP and turn off the network firewall. It is recommended 

to disable the laptop from all network firewalls before attempting a test.
To set up the Test Environment after setting up the iPerf:
 1. Connect your computer to the LAN port of an Access Point (such as the Asus RT-AX88U) through an ethernet 

cable.
The computer should receive an automatic IP address from the Access Points DHCP server. If the Access Point is 
configured to not provide automatic IP addresses, make sure to manually configure your computer to use a 
suitable IP address and subnet mask. Make sure that the computer is not connected to any other networks over 
ethernet or Wi-Fi.

 2. Connect EK-RA6W1 EVK wirelessly to the same Access Point SSID (for instructions on how to configure the Wi-Fi 
connection for the RA6W1, see Section 5.3.2 Setup for Station Mode.

 3. To verify a properly configured connection, ping the RA6W1 from your computer or ping it from the RA6W1 to your 
computer.

net

https://sourceforge.net/projects/iperf2/files/
https://sourceforge.net/projects/iperf2/files/
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ping <destination IP address>

6.1.2    Configure RA6W1 EVK as iPerf Client
The provided UDP uplink iPerf example can be used to primarily evaluate TX throughput speeds.

Figure 37. UDP uplink iPerf example
To configure as iPerf server for Windows:
 1. Start an iPerf Server on your laptop by opening the command prompt and navigating to the directory in which iPerf 

is located.
 2. Type "ipconfig" in the command prompt to see your laptop’s IP address.

Figure 38. IP address
 3. Start the UDP server in the Windows command prompt.

iperf.exe –s -i1 -u

Figure 39. Start UDP
To run traffic from the RA6W1 EVK to the iPerf server on the Windows computer:
 1. Select the network Command mode, in the Tera Term console, by typing the net command.
 2. Start the UDP client:
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iperf -I WLAN0 -c <Server IP> -t 10 -i 1 -u

 3. Read the throughput measurements from the iPerf server window.

Figure 40. Measurements

6.1.3    Configure RA6W1 EVK as iPerf Server
The provided UDP downlink iPerf example can be used to primarily evaluate RX throughput speeds.

Figure 41. UDP downlink iPerf example
To configure RA6W1 EVK as iPerf Server:
 1. Select the network command mode, by typing the net command in the Tera Term console.
 2. Start the UDP server:

iperf -I WLAN0 -s -u -i 1
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Figure 42. Start UDP
 3. Close the existing command prompt on the laptop running the UDP server.
 4. Open the command prompt and navigate to the directory where iPerf is located.
 5. Start the UDP client in the Windows command prompt:

iperf.exe -c <Server IP> -t 10 -i 1 -u -b100m

Figure 43. Start UDP client

6.2  Measure Current Consumption
NOTE
Current consumption measurement through Smart snippet is possible only after releasing the latest Evaluation Kit.

There are numerous available methods to measure current consumption to evaluate the power save performance of 
different sleep and DPM configurations.
The following instructions explain how to perform such measurements using the SmartSnippets Toolbox (Section 
6.2.2 Measure with SmartSnippets) or a standard power analyzer (Section 6.2.3 Measure with Power Analyzer) and 
focus measuring current consumption in forced Sleep modes and DPM mode.

6.2.1    PMGR Sleep Mode CLI Commands
RA6W1 can be configured to temporarily enter Power Manager (PMGR) Sleep modes 2 to Sleep mode 3 for a 5 
second duration through CLI commands (custom durations are not yet supported):

[/RA6W1-RRQ61001/pmgr] # pmgr force
- Usage: force [lld_states: PMGR_LLD_POWER_MODE_SLEEP2, PMGR_LLD_POWER_MODE_SLEEP3, PMGR_LLD_POWER_
MODE_SLEEP4, PMGR_LLD_POWER_MODE_DPM,    PMGR_LLD_POWER_MODE_CPU_WFI, PMGR_LLD_POWER_MODE_AUTO]
[/RA6W1-RRQ61001/pmgr] #

Example:

pmgr force PMGR_LLD_POWER_MODE_SLEEP3

To prepare SmartSnippets Toolbox:
 1. Download and install the latest version of the SmartSnippets Toolbox for current measurement from the Renesas 

Product webpage or from the provided evaluation Software package.
NOTE
SmartSnippets support for RA6W1 is not publicly available yet – use a privately provided version: v5.0.27.4256.
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Figure 44. SmartSnippets toolbox
 2. Connect jumpers between the pins highlighted in red in Figure 45. LED light turns on when jumper J102 is set.
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Figure 45. Jumper setting
 3. Connect the EVK to your computer through USB.
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6.2.2    Measure with SmartSnippets
To measure the current consumption with SmartSnippets:
 1. Disassemble the RA6W1 daughterboard from the motherboard and power up the EVK through USB to your 

computer.
 2. Close any open instances of the UART COM port.
 3. Open SmartSnippets Toolbox on your computer.
 4. Select Board > Device > RA6W1.

Figure 46. RA6W1
 5. On the Chart View tab, select VBAT_WI-FI and CH1/CH2 Charge checkboxes.

Figure 47. Chart View tab
You should see the VBAT Wi-Fi – CH1/CH2 current measurement window.

 6. Identify the RA6W1 EVK -related COM ports through the Windows Device Manager.
 7. Based on the identified pair of COM ports belonging to the RA6W1 EVK (in this case COM5 and COM6), select the 

following configurations:
 a. Select Board > PowerProfiler > (Higher-numbered COM port).

Figure 48. Power profiler port
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 b. Select OffsetCalibration > CH1/CH2 in SmartSnippets.

Figure 49. Offset calibration
NOTE
Offset calibration is required to find the current consumption values of motherboard before inserting daughterboard. This 
way the measurement of daughterboard is accurate. Calibration takes 10 seconds, and the values are saved in the 
configuration.

 8. Connect the RA6W1 EVK daughterboard to the motherboard.
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Figure 50. EVK daughterboard to the motherboard connection
 9. Press down the RST_N (Reset) button on the RA6W1. If the board has previous connection to an AP, it 

automatically re-connects.

Figure 51. Reset button
 10. In SmartSnippets, select Start.
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 11. Connect to the console through UART using Tera Term, see Section 5.2 Configure RA6W1 EVK Serial Debug 
Interface.

 12. In the UART console, select the needed configuration:
Example:
Configure the RA6W1 as in Station + DPM mode (see Appendix A.2 Set up EVK  for Station plus Soft AP Mode ).
//OR//
Enter forced sleep modes (2 or 3) by using the following command syntax: "pmgr force <mode>"
pmgr force PMGR_LLD_POWER_MODE_SLEEP3

 13. When the needed DPM/Sleep mode is configured, close the instance of the UART console in Tera Term. This is 
important before you use the control functions in SmartSnippets, as both SmartSnippets and Tera Term use the 
same COM port.

 14. In SmartSnippets, select Stop.
 15. To measure the average current consumption over a selected period, on the Tools tab, click Measure.
 16. Click and drag the measurement cursor over the section that you want measure in the top screen (CH1/CH2 

Current – VBAT) and read the "Iav" measurement for the average current between the selected measurement 
points.

Figure 52. Measurement points
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6.2.3    Measure with Power Analyzer
To measure the current consumption with Power Analyzer:
 1. On the Power Analyzer, select the current measurement mode.
 2. Connect jumpers between the pins and connect the current measurement points to the power analyzer, see Figure 

53.
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Figure 53. Jumper connections between pins
 3. Assemble the daughterboard to the motherboard and turn on the EVK by connecting it to your computer through 

USB C.
 4. Connect to the console through UART using Tera Term, see Section 5.2 Configure RA6W1 EVK Serial Debug 

Interface.
 5. In the UART console, select the needed configuration:

Example:
Configure the RA6W1 as in Station + DPM mode (see Appendix A.3 Set up Station Mode with DPM Enabled).
//OR//
Enter forced Sleep modes (2 or 3) by using the following command syntax: "pmgr force <mode>"
pmgr force PMGR_LLD_POWER_MODE_SLEEP2

 6. Perform measurements with the power analyzer:
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Figure 54. Measurements
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6.2.4    Measure Sleep 1 Current Consumption
To measure the current consumption for Sleep 1 follow the same process as in Section 5.3.2 Setup for Station Mode 
and Appendix A.1 Set up Soft AP Mode, you do not need any configuration in the CLI.
The following modifications are needed in the test setup to force the device to Sleep 1 Mode:
 1. Remove the pull-up on the RST of the daughterboard.

Figure 55. Remove resistor
 2. Remove the J210 jumper on the motherboard.
 3. Connecting a jumper between the T_SWDIO_GND and J210 RST_N pins.
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Figure 56. Connecting jumper between pins
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7.    Software Development Kit and Build Setup
Wi-Fi applications can be developed for the RA6W1 using the RA6W1 FreeRTOS Software Development Kit (SDK) 
and the Renesas e2 studio IDE on either a Windows 10, Linux or macOS based development system.
To start developing applications for the RA6W1, complete the following steps:
 1. Install and configure the e2 studio IDE.

 2. Import the RA6W1 SDK into the e2 studio IDE and build an application.

 3. Download and test the application.
 4.  Use J-Link debugger to debug the application.
Figure 57 shows the typical e2 studio project for the RA6W1 FSP.

Figure 57. Project view
System requirements:
 n Windows 10 64 bit or later versions
 n Ubuntu 22.04 LTS or later versions
 n macOS 14 (Sonoma) or later versions
 n e2 studio installer-2025-07 or later versions.

7.1  Install e2 studio IDE for Windows
The following files are required for installation in Windows and can be found in RA6W1 Software release archive:
 n e2 studio installer – "e2studio_installer-2025-07_windows_host.exe".
 n RA6W1 FSP pack – "RAFW_FSP_Packs_1.0.0".
 n Sample project template – "8.0.2.0.X_rm_wifi_test_app.zip".
To install e2 studio IDE for Windows:
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 1. Run the installer, in the e2studio setup wizard, select Standard Install, and then select Next.

Figure 58. Standard installation
 2. On the Device Families step, select RA for Wireless.

Figure 59. Device families
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 3. On the Additional Software step, expand GCC Toolchains and Utilities, select the GNU ARM Embedded 10.3 
checkbox, and click Next.

Figure 60. Additional software
 4. On the Licenses step, accept the terms of the software agreement by selecting the checkbox, and click Next.
 5. On the Shortcuts step, click Next.
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Figure 61. Shortcuts
 6. On the Summary step, click Install.

Figure 62. Ready to install
 7. While installing e2 studio, GNU Arm® Embedded 10.3 toolchain installation initializes.
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Figure 63. Toolchain installation
 8. Complete the toolchain installation.

Figure 64. Toolchain setup wizard
 9. When the e2 studio is installed, select the Launch e2 studio checkbox and click OK.
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 10. Open e2 studio and continue with installing the RA6W1 FSP pack.

See Section 7.4 Install RA6W1 FSP Pack.

7.2  Install e2 studio IDE for Linux
The following files are required for installation in Linux and can be found in RA6W1 Software release archive:
 n e2 studio installer – "e2studio_installer-2025-07_linux_host.run".
 n RA6W1 FSP pack – "RAFW_FSP_Packs_1.0.0".
 n Sample project template – "8.0.2.0.X_rm_wifi_test_app.zip".
To install e2 studio IDE for Linux:
 1. Give the execution permissions to the e2 studio installer and run installer, see Figure 65.

Figure 65. Installer
 2. In the e2studio setup wizard, select Standard Install, and select Next.

Figure 66. Standard installation
 3. On the Device Families step, select RA for Wireless.
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Figure 67. Device families
 4. On the Additional Software step, expand GCC Toolchains and Utilities, select the GNU ARM Embedded 10.3 

checkbox, click Next > Install, see Figure 68.
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Figure 68. Device families
 5. After completing e2 studio installation, open e2 studio and continue with installing the RA6W1 FSP pack.

See Section 7.4 Install RA6W1 FSP Pack).

Figure 69. e2 studio
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7.3  Install e2 studio IDE for macOS
 n e2 studio installer – "e2studio_installer-2025-07_macosx_host.txz".
 n RA6W1 FSP pack – "RAFW_FSP_Packs_1.0.0".
 n Sample project template – "8.0.2.0.X_rm_wifi_test_app.zip".
 n Toolchain Installer – “arm-gnu-toolchain-13.3.rel1-darwin-arm64-arm-none-eabi.pkg”.
 n Python 3 Installer – “python-3.13.6-macos11.pkg”.
To install e2 studio IDE for macOS:
 1. In the downloaded archive, extract the E2studio.app file and move it to the application folder.
 2. In the application folder, double-click E2studio.app to start the e2 studio.

If the ["E2studio.ap" is damaged and can’t be opened. You should move it to the 
Trash.] error message appears when the e2 studio is started, open the terminal window and run the following 
command:

xattr -d com.apple.quarantine /Applications/E2studio.app

Figure 70. Error in Starting the e² studio
 3. In e2 studio, go to Help > Install New Software.

Figure 71. Install New Software
 4. In the Install dialog do the following, and click Next:
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 a. a. Select the following website to Work with https://www2.renesas.eu/_custom/software/ree_
eclipse/e2studio10/.

 b. Select both RA for Wireless components to install.
 c. Clear the Group items by category checkbox.

Figure 72. Additional components to install
 5. Accept the terms and click Finish.
 6. During installation, two dialogs appear: one for Trust Authority and another for Trust Artifacts. For both dialogs, 

select Select All and click Trust Selected.

https://www2.renesas.eu/_custom/software/ree_eclipse/e2studio10/
https://www2.renesas.eu/_custom/software/ree_eclipse/e2studio10/
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Figure 73. Trust Authorities

Figure 74. Trust Artifacts
After the Installation is completed, a dialog appears for restarting e2 studio.

 7. Restart e2 studio, by clicking Restart Now.
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 8. Install the Toolchain by double-clicking the installer.

Figure 75. Toolchain Installer
 9. After Toolchain Installation is successfully completed, in e2 studio, go to Help > Add Renesas Toolchains.

Figure 76. Add Renesas Toolchains
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 10. In the Renesas Toolchain Management dialog, click Add.

Figure 77. Renesas Toolchain Management
 11. In the Add New Toolchain dialog, click Browse.
 12. Go to Applications > ArmGNUToolchain > 13.3.rel1>arm-none-eabi, and click Open.
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Figure 78. Choose the Installed Toolchain
 13. In the Add New Toolchain dialog, click OK.
 14. In the Renesas Toolchain Management dialog, click Apply and Close.

Figure 79. Finalize Toolchain Settings
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 15. Install Python3 by double-clicking Installer – python-3.13.6-macos11.pkg.

Figure 80. Python3 Installer
 16. After Python3 installation is completed successfully, restart e2 studio using File >Restart.

7.4  Install RA6W1 FSP Pack
To build the SDK, install the RA6W1 FSP pack:
NOTE
The same procedure applies to both Windows  OS, Linux and macOS.
To install the latest RA6W1 FSP Release package:
 1. Unzip the RAFW_FSP_Packs_1.0.0.zip to the e2 studio install directory.
 2. To find the exact e2 studio install directory, click Help > About e2 studio. For macOS, click e2studio > About 

e2studio.
 3. In the About e2studio dialog, click Installation Details.
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Figure 81. e2 studio details

 4. In the e2 studio Installation Details dialog, select the Support Folders tab.
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Figure 82. e2 studio installation details

 5. To open the system file manager in the directory that corresponds to e2 studio install directory, click the e2 studio 
support area link.
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Figure 83. Support folders
 6. Extract the RAFW_FSP_Packs_1.0.0.zip file.
 7. Copy and paste the Internal folder to the e2 studio support folder.

In MacOS, select the Merge option when copying the internal folder.
 8. To restart e2 studio, click File > Restart.
NOTE
For updating/re-installing the RA6W1_FSP_Packs,  delete the following folders in the e2 studio support folder first.

 n DebugComp\rrq\  
 n internal\cmsis\data\rrq\
 n internal\devassist\rafw_fsp\
 n internal\projectgen\rafw_fsp\.
Then follow Step 5 and Step 9.

7.5  Load Project Template in e2 studio
8.0.2.0.X_rm_wifi_test_app.zip is a project template to create the default Wi-Fi image of the released version.
To load the project template:
 1. Extract the 8.0.2.0.X_rm_wifi_test_app.zip project template to a directory.
 2. To import project template, click File > Import.
 3. Under General, select Rename & Import Existing C/C++ Project into Workspace.
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Figure 84. Rename and import
 4. Go to the project template directory (unzip 8.0.2.0.X_rm_wifi_test_app.zip), and in the Project name field, enter 

the name and click Finish. 
 5. In the Project name field, enter the name and click Finish, see Figure 85.
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Figure 85. Finish import
 6. After import finishes, install python using the following steps in Windows:

 a. Right-click the project, click Show in Local Terminal > Terminal.
 b. In console, enter "python3".

NOTE
For Windows, if Python 3 is installed already and above terminal appears, for python Integration, see Appendix D Python 
Integration in e2 studio Windows.

 c. Microsoft store appears and to install Python 3, click Get.
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Figure 86. Install Python 3
 7. Go to configuration.xml and click Generate Project Content.

Figure 87. Configuration and generate project contents
 8. To build the project, right-click the project and click Build Project.
 9. To see the build progress, open the console window.
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Figure 88. Console window
Figure 89 shows the successful build.

Figure 89. Successful build
 10. If there is no ".img" file generated on Windows and Python 3 command does not show any error in console, follow 

the step 6.
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Figure 90. Image in Project Explorer tab
 11. To program the firmware images, see Section 5.1  Firmware Image Programming .

7.6  Flash and Debug using e2 studio
You can flash and debug in e2 studio using J-Link.
System Requirements:
 n e2 studio installer-2025-07 or later versions
 n Segger J-Link V878 or later.
To flash and debug in e2 studio:
 1. Install RA6W1 FSP Pack and Load Project Template in e2 studio.
 2. Build Debug for RA6W1.
 3. Go to Debug > Debug New_configuration.

Figure 91. Debug Configuration in e2 studio

 4. In Debug Configurations, select Renesas GDB Hardware Debugging, and then select Lauch Configuration.



RA6W1 Getting Started Guide

R19US0014EK0104 Rev 1.04 Page 62
Mar 26, 2026

Figure 92. Debug Configuration page
 5. On the Main tab, go to Browse > Choose Project > OK.

Figure 93. Main section of Debug Configuration
 6. On the Debugger tab, set up the target device as follows:

Figure 94. Device selection in Debugger
 7. On the Startup tab, and change load type of Program Binary to Symbols Only.
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Figure 95. Symbols only
 8. To add Download Module (.img.bin) from Debug, go to Add > Workspace > Project File > Debug > test_files 

> .img.bin.

Figure 96. Add Download Module
 9. Change Load Type of .img.bin into Raw Binary and Offset as a000000. Then click Apply > Debug.

Figure 97. Change Load type and Offset
 10. Click Switch.
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Figure 98. Confirm Perspective Switch and Segger J-Link
 11. On Debug page, click Play.

Figure 99. Debug Page
 12. By putting a breakpoint in a file you can debug normally using debug interface. Go to C/C++ > Choose a breakpoint 

> Debug > Resume button.

Figure 100. Debug by setting breakpoint



RA6W1 Getting Started Guide

R19US0014EK0104 Rev 1.04 Page 65
Mar 26, 2026

Appendix A Configuration Modes Setup

A.1 Set up Soft AP Mode
Soft AP mode allows you to provision the RA6W1 through the Wi-Fi interface using a mobile application and configure 
it by running the Easy Setup Wi-Fi configuration wizard.
To configure the RA6W1 for operating in Soft AP mode:
 1. Open the RA6W1 debug console and run the setup command in the [/RA6W1-RRQ61001] #] prompt.
 2. To complete the setup, complete the following prompts:

[/RA6W1-RRQ61001] #setup                        Start the Easy Setup Wizard.
 
Stop all services for the setting.
 Are you sure ? [Yes/No] : Y                    Enter Y to stop the running services.
 
[RA6W1 -RRQ61001 EASY SETUP - V4]
 
Country Code List:
AD  AE  AF  AI  AL  AM  AR  AS  AT  AU  AW  AZ  BA  BB  BD  BE  BF  BG  BH  BL
BM  BN  BO  BR  BS  BT  BY  BZ  CA  CF  CH  CI  CL  CN  CO  CR  CU  CX  CY  CZ
DE  DK  DM  DO  DZ  EC  EE  EG  ES  ET  EU  FI  FM  FR  GA  GB  GD  GE  GF  GH
GL  GP  GR  GT  GU  GY  HK  HN  HR  HT  HU  ID  IE  IL  IN  IR  IS  IT  JM  JO
JP  KE  KH  KN  KP  KR  KW  KY  KZ  LB  LC  LI  LK  LS  LT  LU  LV  MA  MC  MD
ME  MF  MH  MK  MN  MO  MP  MQ  MR  MT  MU  MV  MW  MX  MY  NG  NI  NL  NO  NP
NZ  OM  PA  PE  PF  PG  PH  PK  PL  PM  PR  PT  PW  PY  QA  RE  RO  RS  RU  RW
SA  SE  SG  SI  SK  SN  SR  SV  SY  TC  TD  TG  TH  TN  TR  TT  TW  TZ  UA  UG
UK  US  UY  UZ  VA  VC  VE  VI  VN  VU  WF  WS  YE  YT  ZA  ZW  ALL
 
 COUNTRY CODE ? [Quit] (Default KR) : US            Enter the country code.
 
SYSMODE(WLAN MODE) ?
        1. Station
        2. Soft-AP
        3. WiFi Direct
        4. WiFi Direct P2P GO Fixed
        5. Station & Soft-AP
 MODE ?  [1/2/3/4/5/Quit] (Default Station) : 2        Enter 2 for Soft-AP mode.
BAND ?
        1. 2.4 GHz
        2. 5 GHz
 MODE ?  [1/2/Quit] (Default 1. 2.4 GHz) : 1                  Enter 1 for 2.4 Band.
[ SOFT-AP CONFIGURATION ]
 
 SSID ? (Default RA6W1-RRQ61001_B0A977) : TEST_AP             Enter the SSID name.
 
 CHANNEL ? [1~11, Auto:0/Quit] (Default Auto) :        Enter to select Auto channel selection.
 
AUTHENTICATION ?
         1. OPEN
         2. WEP(Unsupported)
         3. WPA-PSK
         4. WPA2-PSK
         5. WPA/WPA2-PSK
         6. WPA3-SAE (WPA3-Personal)
         7. WPA2-PSK+WPA3-SAE (Recommend)
         8. WPA3-OWE
 AUTHENTICATION ? [1/3/4/5/6/7/8/Quit] : 4            Enter 4 to select WPA2-PSK authentication.
 
PSK-KEY(ASCII characters 8~63 or Hexadecimal characters 64) ? [Quit]
12345678                            Enter the password for the AP.
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 Do you want to set advanced WiFi configuration ? [No/Yes/Quit] (Default No) : N
                                Enter N to skip this step.
============================================
BAND        : 2.4 GHz
SSID        : TEST_AP
CHANNEL     : AUTO(ACS)
Security    : WPA2PSK
ENCRYPTION  : AES(CCMP)
Password    : 12345678
WIFI MODE   : 11b/g/n    (2.4 GHz)
PMF         : Default
 WIFI CONFIGURATION CONFIRM ? [Yes/No/Quit] : Y        Enter Y to confirm the WIFI
                                 configuration.
 
 IP ADDRESS ? [Quit] (Default 10.0.0.1) :            Enter to select the default IP Address.
 
 SUBNET ? [Quit] (Default 255.255.255.0) :               Enter to select the default Subnet.
 
 GATEWAY ? [Quit] (Default 10.0.0.1) :             Enter to select the default Gateway.
============================================
[WLAN1]
IP ADDRESS: 10.0.0.1
SUBNET    : 255.255.255.0
GATEWAY   : 10.0.0.1
============================================
 IP CONFIGURATION CONFIRM ? [Yes/No/Quit] : Y            Enter Y to confirm the IP configuration.
 
 DHCP SERVER CONFIGURATION ? [Yes/No/Quit] : Y        Enter Y to confirm the DHCP Server
                                 configuration.
 
 DHCP SERVER LEASE IP Count(MAX 10) ? [Quit] (Default 10) :
                                Enter to select the default Lease Count.
 
 DHCP SERVER LEASE TIME(60 ~ 86400 SEC) ? [Quit] (Default 1800) :
                                Enter to select the default Lease Time.
============================================
[DHCP SERVER]
Start IP  : 10.0.0.2
END IP    : 10.0.0.11
LEASE TIME: 1800
============================================
 
 DHCP SERVER CONFIGURATION CONFIRM ? [Yes/No/Quit] : Y    Enter Y to confirm the configuration.
 
[/RA6W1-RRQ61001] # >>> wpa_supplicant_deinit ...
[wpa_supplicant_deinit_iface] CTRL-EVENT-TERMINATING 
>>> Request Supplicant start 
>>> Renesas RA6W1-RRQ61001 wpa_supplicant 2.10 - Sep/2023
>>> Add SoftAP Inteface (softap1) ...
>>> MAC address (softap1) : 74:90:50:b0:a9:77
[init_net_ifaces]: Switching WiFi mode to: Soft-AP
[init_net_ifaces]: Setting up AP (wlan1)
Stop DHCP Server
 
INFO: DHCP Server is not running.
Start DHCP Server
>>> AP Operating Channel: AUTO
 
>>> DHCP Server Started
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Soft-AP is Ready (74:90:50:b0:a9:77) 
 

When all settings are completed, the configuration is saved, and the system reboots. Then, the Soft AP mode started 
successfully message appears.
When a station gets connected successfully, AP-STA-CONNECTED with M address of station message is printed.

 AP-STA-CONNECTED fa:87:d8:62:3d:a1
 

A.2 Set up EVK  for Station plus Soft AP Mode
To configure the RA6W1 for operating in Station + Soft AP mode:
 1. Open the RA6W1 debug console and run the setup command in the [/RA6W1-RRQ61001Y] prompt.
 2. To complete the setup, complete the following prompts:

[/RA6W1 -RRQ61001] # setup
 
Stop all services for the setting.
 Are you sure ? [Yes/No] : y
 
[RA6W1 -RRQ61001 EASY SETUP – V4]
 
Country Code List:
AD  AE  AF  AI  AL  AM  AN  AR  AS  AT  AU  AW  AZ  BA  BB  BD  BE  BF  BG  BH  
BL  BM  BN  BO  BR  BS  BT  BY  BZ  CA  CF  CH  CI  CL  CN  CO  CR  CU  CX  CY  
CZ  DE  DK  DM  DO  DZ  EC  EE  EG  ES  ET  EU  FI  FM  FR  GA  GB  GD  GE  GF  
GH  GL  GP  GR  GT  GU  GY  HK  HN  HR  HT  HU  ID  IE  IL  IN  IR  IS  IT  JM  
JO  JP  KE  KH  KN  KP  KR  KW  KY  KZ  LB  LC  LI  LK  LS  LT  LU  LV  MA  MC  
MD  ME  MF  MH  MK  MN  MO  MP  MQ  MR  MT  MU  MV  MW  MX  MY  NG  NI  NL  NO  
NP  NZ  OM  PA  PE  PF  PG  PH  PK  PL  PM  PR  PT  PW  PY  QA  RE  RO  RS  RU  
RW  SA  SE  SG  SI  SK  SN  SR  SV  SY  TC  TD  TG  TH  TN  TR  TT  TW  TZ  UA  
UG  UK  US  UY  UZ  VA  VC  VE  VI  VN  VU  WF  WS  YE  YT  ZA  ZW  ZZ  
 
 COUNTRY CODE ? [Quit] (Default KR, ZZ : for debug) : us
 
SYSMODE(WLAN MODE) ?
        1. Station
        2. Soft-AP
        3. WiFi Direct
        4. WiFi Direct P2P GO Fixed
        5. Station & Soft-AP
 MODE ?  [1/2/3/4/5/Quit] (Default Station) : 5
BAND ?
        1. 2.4 GHz
        2. 5 GHz
        3. AUTO
 MODE ?  [1/2/3/Quit] (Default 3. AUTO) : 1
[ STATION CONFIGURATION ]
============================================================================
[NO] [SSID]                                         [SIGNAL] [CH] [SECURITY]
----------------------------------------------------------------------------
[ 0] WiFi_Net_2.4G                                      -26   6     WPA2-ENT
[ 1] RenesasMatter                                      -26  10         WPA2
[ 2] REL-GLOBAL                                         -27   6     WPA2-ENT
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[ 3] NETGEAR81                                          -36   3         WPA2
[ 4] GGG_AP_2G                                          -36  11         WPA2
----------------------------------------------------------------------------
[Enter] Rescan
============================================================================
 Select SSID ? (1~5/M1~M5/Manual/Quit) : 1
 
 PSK-KEY(ASCII characters 8~63 or Hexadecimal characters 64) ? [Quit]
[123456789|123456789|123456789|123456789|123456789|123456789|1234]
:*********
 
 Do you want to set advanced WiFi configuration ? [No/Yes/Quit] (Default No) : n
 
BAND        : 2.4 GHz
SSID        : RenesasMatter
Security    : WAP2PSK
ENCRYPTION  : TKIP/AES(CCMP)
Password    :*********
PMF         : Default
============================================
 WIFI CONFIGURATION CONFIRM ? [Yes/No/Quit] : y
 
 IP Connection Type ? [Automatic IP/Static IP/Quit] : a
 
IP Connection Type: Automatic IP
 
 IP CONFIGURATION CONFIRM ? [Yes/No/Quit] : y
 
 SNTP Client enable ? [Yes/No/Quit] : n
 
[ SOFT-AP CONFIGURATION ]
 
 SSID ? (Default RA6W1 -RRQ61001_B0A977) : TEST_AP             Enter the SSID name.
 
 
AUTHENTICATION ?
         1. OPEN
         2. WEP(Unsupported)
         3. WPA-PSK
         4. WPA2-PSK
         5. WPA/WPA2-PSK
         6. WPA3-SAE (WPA3-Personal)
         7. WPA2-PSK+WPA3-SAE (Recommend)
         8. WPA3-OWE
 AUTHENTICATION ? [1/3/4/5/6/7/8/Quit] : 4            Enter 4 to select WPA2-PSK authentication.
 
 
PSK-KEY(ASCII characters 8~63 or Hexadecimal characters 64) ? [Quit] 
12345678                            Enter the password for the AP.
 
 Do you want to set advanced WiFi configuration ? [No/Yes/Quit] (Default No) : N
                                Enter N to skip this step.
============================================
BAND        : 2.4 GHz
SSID        : TEST_AP
Security    : WPA2PSK
ENCRYPTION  : AES(CCMP)
Password    : 12345678
PMF         : Default
 WIFI CONFIGURATION CONFIRM ? [Yes/No/Quit] : Y        Enter Y to confirm the WIFI
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                                 configuration.
 
 IP ADDRESS ? [Quit] (Default 10.0.0.1) :            Enter to select the default IP Address.
 
 SUBNET ? [Quit] (Default 255.255.255.0) :               Enter to select the default Subnet.
 
 GATEWAY ? [Quit] (Default 10.0.0.1) :             Enter to select the default Gateway.
============================================
[WLAN1]
IP ADDRESS: 10.0.0.1
SUBNET    : 255.255.255.0
GATEWAY   : 10.0.0.1
============================================
 IP CONFIGURATION CONFIRM ? [Yes/No/Quit] : Y            Enter Y to confirm the IP configuration.
 
 DHCP SERVER CONFIGURATION ? [Yes/No/Quit] : Y        Enter Y to confirm the DHCP Server
                                 configuration.
 
 DHCP SERVER LEASE IP Count(MAX 10) ? [Quit] (Default 10) :
                                Enter to select the default Lease Count.
 
 DHCP SERVER LEASE TIME(60 ~ 86400 SEC) ? [Quit] (Default 1800) :
                                Enter to select the default Lease Time.
============================================
[DHCP SERVER]
Start IP  : 10.0.0.2
END IP    : 10.0.0.11
LEASE TIME: 1800
============================================
 
 DHCP SERVER CONFIGURATION CONFIRM ? [Yes/No/Quit] : Y    Enter Y to confirm the configuration.
 
[/RA6W1-RRQ61001] # >>> wpa_supplicant_deinit ...
[wpa_supplicant_deinit_iface] CTRL-EVENT-TERMINATING 
>>> Request Supplicant start 
>>> Renesas RA6W1-RRQ61001 wpa_supplicant 2.10 - Sep/2023
>>> MAC address (sta0) : 74:90:50:b0:a9:76
>>> Add SoftAP Inteface (softap1) ...
>>> MAC address (softap1) : 74:90:50:b0:a9:77
 
>>> Start STA & SOFT-AP Concurrent mode...
[init_net_ifaces]: Switching WiFi mode to: Station & Soft-AP
[init_net_ifaces]: Setting up Concurrent mode (AP + STA)
Stop DHCP Server
 
INFO: DHCP Server is not running.
Start DHCP Server
>>> AP Operating Channel: 11(2462)
 
Soft-AP is Ready (74:90:50:b0:a9:77)
 
>>> DHCP Server Started
 
Connection COMPLETE to 34:0a:33:78:e5:68
 
>>> Network Interface (wlan0) : UP
         Assigned addr   : 192.168.0.104
             netmask   : 255.255.255.0
               gateway   : 192.168.0.1
         DHCP Server IP  : 192.168.0.1



RA6W1 Getting Started Guide

R19US0014EK0104 Rev 1.04 Page 70
Mar 26, 2026

         Lease Time      : 08h 00m 00s
         Renewal Time    : 04h 00m 00s 
 

When all settings are completed, the configuration is saved, and the  "Start STA & SOFT-AP Concurrent mode" 
message appears.

A.3 Set up Station Mode with DPM Enabled
Dynamic Power Management (DMP) is a synthesis of breakthrough in ultra-low-power technologies that enable 
extremely low-power operation of the RA6W1. DPM shuts down all microelements on the chip when not in use, which 
allows a near zero level of power consumption when not actively transmitting or receiving data. DPM also enables 
Ultra-low-power Transmit and Receive modes when the SoC needs to be awake to exchange information with other 
devices. Advanced algorithms enable the device to stay asleep until the exact required moment to wake up to 
Transmit or Receive mode.
By default, the DPM functionality is enabled upon the device’s connection to an Access Point. This can be 
reconfigured by running the Easy Setup Wi-Fi configuration wizard. DPM allows for considerably reduced power 
consumption by periodically entering various sleep modes when full functionality is not required.
To configure the RA6W1 for operating in Station + DPM mode:
 1. Open theRA6W1 debug console and run the setup command in the [/RA6W1-RRQ61001] prompt. 
 2. To complete the setup, complete the following prompts:

[/RA6W1 -RRQ61001/dpm] # setup
 
Stop all services for the setting.
 Are you sure ? [Yes/No] : y
 
 
[ RA6W1 -RRQ61001 EASY SETUP – V4 ]
 
Country Code List:
AD  AE  AF  AI  AL  AM  AN  AR  AS  AT  AU  AW  AZ  BA  BB  BD  BE  BF  BG  BH  
BL  BM  BN  BO  BR  BS  BT  BY  BZ  CA  CF  CH  CI  CL  CN  CO  CR  CU  CX  CY  
CZ  DE  DK  DM  DO  DZ  EC  EE  EG  ES  ET  EU  FI  FM  FR  GA  GB  GD  GE  GF  
GH  GL  GP  GR  GT  GU  GY  HK  HN  HR  HT  HU  ID  IE  IL  IN  IR  IS  IT  JM  
JO  JP  KE  KH  KN  KP  KR  KW  KY  KZ  LB  LC  LI  LK  LS  LT  LU  LV  MA  MC  
MD  ME  MF  MH  MK  MN  MO  MP  MQ  MR  MT  MU  MV  MW  MX  MY  NG  NI  NL  NO  
NP  NZ  OM  PA  PE  PF  PG  PH  PK  PL  PM  PR  PT  PW  PY  QA  RE  RO  RS  RU  
RW  SA  SE  SG  SI  SK  SN  SR  SV  SY  TC  TD  TG  TH  TN  TR  TT  TW  TZ  UA  
UG  UK  US  UY  UZ  VA  VC  VE  VI  VN  VU  WF  WS  YE  YT  ZA  ZW  ZZ  
 
 COUNTRY CODE ? [Quit] (Default KR, ZZ : for debug) : us
 
SYSMODE(WLAN MODE) ?
        1. Station
        2. Soft-AP
        3. WiFi Direct
        4. WiFi Direct P2P GO Fixed
        5. Station & Soft-AP
MODE ?  [1/2/3/Quit] (Default Station) : 1
BAND ?
        1. 2.4 GHz
        2. 5 GHz
        3. AUTO
 BAND ?  [1/2/3/Quit] (Default 3. AUTO) : 1
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[ STATION CONFIGURATION ]
============================================================================
[NO] [SSID]                                         [SIGNAL] [CH] [SECURITY]
----------------------------------------------------------------------------
[ 0] REL-GLOBAL_2.4G                                    -21   6     WPA2-ENT
[ 1] WiFi_Net_2.4G                                      -22   6     WPA2-ENT
[ 2] REL-GLOBAL                                         -22   6     WPA2-ENT
[ 3] WiFi_Public_2.4G                                   -23   6         WPA2
[ 4] RenesasMatter                                      -27  10         WPA2
----------------------------------------------------------------------------
[Enter] Rescan
============================================================================
 
 Select SSID ? (1~5/M1~M5/Manual/Quit) : 5
 
 PSK-KEY(ASCII characters 8~63 or Hexadecimal characters 64) ? [Quit]
:********
 
 Do you want to set advanced WiFi configuration ? [No/Yes/Quit] (Default No) : n
 
 Enable DPM (Dynamic Power Management) ? [Yes/No/Quit] : y
 
 DPM factors : Defaults ? [Yes/No/Quit] : y
 
============================================
DPM MODE           : Enable
Keep Alive Time    : 30000 ms
User Wakeup Time   : 0 ms
TIM Wakeup Count   : 10 dtim
============================================
 DPM CONFIGURATION CONFIRM ? [Yes/No/Quit] : y
 
============================================
BAND        : 2.4 GHz
SSID        : RenesasMatter
Security    : WAP2-PSK
ENCRYPTION  : TKIP/AES(CCMP)
Password    : ********
PMF         : Default
============================================
 WIFI CONFIGURATION CONFIRM ? [Yes/No/Quit] : y
 
 IP Connection Type ? [Automatic IP/Static IP/Quit] : a
 
IP Connection Type: Automatic IP
 
 IP CONFIGURATION CONFIRM ? [Yes/No/Quit] : y
 
 SNTP Client enable ? [Yes/No/Quit] : n
 
 
[/RA6W1-RRQ61001/dpm] # 
Connection COMPLETE to 34:0a:33:78:e5:68
 
>>> Network Interface (wlan0) : UP
         Assigned addr   : 192.168.0.104
               netmask   : 255.255.255.0
               gateway   : 192.168.0.1
         DHCP Server IP  : 192.168.0.1
         Lease Time      : 08h 00m 00s
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         Renewal Time    : 06h 40m 00s
 
>>> Start DPM Power-Down !!!  
 

When the RA6W1 is in DPM Sleep mode, user input is not accepted by the debug terminal. To re-enable the input, see 
Appendix A.4 Disable DPM Mode.

A.4 Disable DPM Mode
When RA6W1 enters DPM Sleep mode, the debug terminal does not accept the input because the UART interfaces 
are powered down. To exit this state and restart the setup process, complete the following steps:
 1. Copy the string PDM off to the clipboard.

For example, open Notepad, type dpm off, and then copy (Ctrl+C) the command string.
 2. To restart the EVB, use the RST_N button.
 3. After restarting, before the message >>> Start DPM Power-Down !!! appears on the console, paste the dpm off 

string in the terminal window, and press Enter.
When this procedure is done successfully, the UART console responds as normal. If DPM mode does not stop 
successfully, try the process again:

dpm off
 
[/RA6W1 -RRQ61001/dpm] # 
 
Rebooting...
 
 
Wakeup source is 0x4
 
        ******************************************************
        *              RA6W1-RRQ61001 SDK Information
        * ---------------------------------------------------
        *
        * - CHIP Name       : RA6W1-RRQ61001 (D3095B)
        * - SKU Type        : 0x20, Dual Band (2.4 + 5 GHz) WI-FI 6
        * - CPU Type        : Cortex-M33 (160MHz)
        * - Kernel Version  : FreeRTOS V11.1.0+
        * - SFLASH Type     : 8 MB (Renesas AT25SL)
        * - SDK Version     : V8.0.1.0.5 
        * - F/W Version     : RA6W1-RRQ61001-65f88bebf4-1
        * - Boot Index      : 0
        *
        ******************************************************
 
 
System Mode : Station Only (0)
Network init...OK
>>> Renesas RA6W1-RRQ61001 wpa_supplicant 2.10 - Sep/2023
>>> MAC address (sta0) : 74:90:50:b0:a9:76
>>> Start STA mode...
 
Connection COMPLETE to 34:0a:33:78:e5:68
 
>>> Network Interface (wlan0) : UP
         Assigned addr   : 192.168.0.104
               netmask   : 255.255.255.0
               gateway   : 192.168.0.1
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         DHCP Server IP  : 192.168.0.1
         Lease Time      : 08h 00m 00s
         Renewal Time    : 04h 00m 00s
 

DPM can be restarted at any time with the dpm on command.
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Appendix B AT Command Wi-Fi Provisioning
You can provision the Wi-Fi connection using AT commands through the AT command terminal. For AT command 
interface configuration, see Section Section 5.2.3 Configure RA6W1 EVK AT Command Interface. To provision a Wi-
Fi connection, complete the following steps:
 1. To see nearby apps, enable echo output and then initiate a Wi-Fi scan.

ATE
AT+WFSCAN

 2. Configure the desired Wi-Fi connection with the following command:
 l AT+WFJAP=<SSID>,<Security>,<Encryption>,<Passphrase>

 o <SSID>: AP SSID
 o <Security>: Security protocol.

0 (OPEN), 1 (WEP), 2 (WPA), 3 (WPA2), 4 (WPA+WPA2), 5 (WPA3 OWE), 6 (WPA3 SAE), 7 (WPA2 RSN 
and WPA3 SAE)

 o <Encryption>:
0 (TKIP), 1 (AES), 2 (TKIP+AES)

 o <Key>: Passphrase. 8 ~ 63 characters are allowed

Example:
If selecting Dlink_AP_24G_FZ, the configuration selected should be as follows:
 n <SSID>: Dlink_AP_24G_FZ
 n <Security>: 4 for WPA+WPA2 Security protocol.
 n <Encryption>: 2 for TKIP+AES encryption.
 n <Key>: 12345678 (password of AP).
The example of the command: AT+WFJAP=Dlink_AP_24G_FZ,4,2,12345678
The RA6W1 reboots and connects to the given SSID, with DPM enabled by default.
The procedure is similar for a 5 GHz connection. In this example, the only changes are to <Security> (changed to 
WPA3), and <Encryption> (changed to AES).
AT+WFJAP=R15-5G,6,1,12345678
The additional useful commands for Wi-Fi configuration:

AT+WFSTAT   // for getting the Wi-Fi configuration.
ATF    // for factory reset
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Appendix C Flash Using flash_img_downloader Script
Programming firmware images to the EVK requires the flash downloader. The flash downloader (flash_img_
downloader.zip) is provided with binary images (see Figure 101).

Figure 101. Flash downloader
System requirements:
 n §  OS (Windows 10 64 bit/Ubuntu 20.04 LTS 64 bit).
 n §  Python 3.12.x and pycryptodome package.
NOTE  
Install mandatory python library.
pycryptodome

 n For Windows
Open a Windows command prompt and enter the following commands:
python -m pip install pycryptodome

 n For Linux OS
Open a terminal window and enter the following commands:
python -m pip install pycryptodome

Check python version using python –version
Python 3.1.X

To program the firmware image through the UART, you have the following options:
 n For Windows, use flash_img_downloader_uart.bat batch file.
 n For Linux, use flash_img_downloader_uart.sh shell script file.
 n Hardware: RA6W1 EVK, see Figure 102.
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Figure 102. RA6W1 EVK hardware
 n This tool is for both Windows and Linux and the programming can be done automatically.
 n Software: Flash Downloader for UART.
To program the firmware image using Windows:
 1. Execute the batch script in the Windows command prompt.

Usage: flash_img_downloader_uart.bat [img full path]
Example: flash_img_downloader_uart.bat <full_path>/8.0.2.0.0_rm_wifi_test_app.img

Figure 103. Run flash downloader with UART
 2. Enter COM port to use (lowest numbered COM port).

NOTE  
Before running the flash downloader with UART, close any other instances of this COM port to make sure of COM port 
availability.

Figure 104. Enter COM port for UART
 3. If prompted, to start programming the firmware, press the RST_N (Reset) button on the RA6W1 EVK.

Figure 105. Reset RA6W1 EVK
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The script finishes programming the firmware image through UART.

Figure 106. Finished programming a firmware image with UART
 4. After firmware programming is completed, open the Terminal Emulator and configure Tera Term Serial Terminal 

Application for Windows, see Section 5.2.1 Configure Tera Term Serial Terminal Application for Windows. .
 5. Press the Reset button on the EVK.
 6. Check the booting status through UART.

C.1 Program Firmware Images for Windows

Figure 107. Flash boot with downloaded image

C.2 Program Firmware Images for Linux
To program the firmware image using Linux:
 1. Execute the Shell script in the Terminal.

Usage: flash_img_downloader_uart.sh [img full path]
Example: flash_img_downloader_uart.sh <full_path>/8.0.2.0.0_rm_wifi_test_app8.img

Figure 108. Run flash downloader with UART
NOTE  
While programming, make sure the port of RA6W1 interface should be /dev/ttyUSB0. Also close any other minicom 
instances of this port to make sure of port availability.

 2. If prompted, to start programming the firmware, press the RST_N (Reset) button on the RA6W1 EVK.

Figure 109. Reset RA6W1 EVK
The script finishes programming the firmware image through UART.
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Figure 110. Finished programming a firmware image with UART
 3. After firmware programming completes, open the Terminal Emulator and configure as in Section 5.2.2 Configure 

Minicom for Linux.
 4. On the EVK, press the Reset button.
 5. Check the booting status through UART.

Figure 111. Flash boot with downloaded image
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Appendix D Python Integration in e2 studio Windows
If Python 3 is already installed and it is not showing in the e2 studio terminal, follow the steps:
 1. In Windows, go to Apps > Advanced app settings > App execution aliases > python3.exe.

Figure 112. App execution aliases
 2. Create a python3.bat file with the following script.

@echo off
python %*

 3. Copy the python3.bat file to the already existing python3 installation location.
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Figure 113. Python3 Installation folder
 4. Restart e2 studio and check if Python 3 is properly integrated using the below command.

python3 --version
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Appendix E SFlash Memory Maps
This section describes the memory maps for the external SFlash device and how to change the SFlash device 
memory map used in the SDK.
NOTE
The RA6W1 SDK currently supports the following SFlash types:

 n 8-MB SFlash
 n Renesas - AT25SL641
To use a different type of SFlash with the RA6W1, contact Renesas Electronics to confirm compatibility.

The RA6W1 SDK supports 8-MB SFlash.
Table 5. 8-MB SFlash map for RA6W1
Address Name Description Size (kB)
0x0000_0000 Product  Header  4

0x0000_1000 Product  Header - Backup  4

0x0000_2000 RTOS  #0 (64*1024  * 40) 2560

0x0028_2000 Reserved RTOS  binary size – Expandable area 508

0x0030_0000 NVRAM NVRAM  VEE Segment #1 40

0x0030_A000 NVRAM Backup (Multiplier 8) 280

0x0035_0000 TLS_Cert_Base  704   

0x0035_2000 TLS  Certificate WPA_Enterprise CA 4  or Unused

0x0035_3000 Cert 4  or Unused

0x0035_4000 Private key 4  or Unused

0x0035_5000 Diffie-Hellmann key 4  or Unused

0x0035_6000 TLS Certificate OTA_Update CA 4  or Unused 

0x0035_7000 Cert 4  or Unused

0x0035_8000 Private key 4  or Unused

0x0035_9000 Diffie-Hellmann key 4  or Unused

0x0035_A000 TLS Certificate HTTPs Client Cert 4  or Unused

0x0035_B000 Private key 4  or Unused

0x0035_C000 Diffie-Hellmann key 4  or Unused

0x0035_D000 CA 4  or Unused

0x0035_E000 TLS Certificate HTTPs Server Cert 4  or Unused

0x0035_F000 Private key 4  or Unused

0x0036_0000 Diffie-Hellmann key 4  or Unused

0x0036_1000 Cert 4  or Unused

0x0036_2000 TLS Certificate MQTTs Client Cert 4  or Unused

0x0036_3000 Private key 4  or Unused

0x0036_4000 Diffie-Hellmann key 4  or Unused

0x0036_5000 CA 4  or Unused

0x0036_6000 TLS Certificate CoAPs Client Cert 4  or Unused

0x0036_7000 Private key 4  or Unused

0x0036_8000 Diffie-Hellmann key 4  or Unused

0x0036_9000 Cert 4  or Unused

0x0036_A000 TLS Certificate CoAPs Server CA 4  or Unused

0x0036_B000 Cert 4  or Unused
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Address Name Description Size (kB)
0x0036_C000 Private key 4  or Unused

0x0036_D000 Diffie-Hellmann key 4  or Unused

0x0036_E000 TLS Certificate AT-CMD #0 ~ #15 AT   command TLS Certificate Key #0 ~ #15 64  or Unused

0x0038_F000 TLS Certificate Matter  16  or Unused

0x003F_E000 Secure Asset Product Area  4  or Unused

0x0040_0000 RTOS  #1 (64*1024 * 40) 2560

0x0068_0000 Reserved RTOS  binary size – Expandable area 512

0x0070_0000 User  Area #1  1020

0x007F_F000 Partition  Table  4
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8.    Revision History
Revision Date Description
1.04 Mar 26, 2026 Updated the AT Command Jumper Configuration section.

1.03 Nov 28, 2025 Updated Mother-Board to RevE. Updated sections about EVK and its setup, test procedures, 
SDK and build setup. Added appendix about Python integration.

1.02 Aug 31, 2025 Updated sections about programming firmware images, station mode, SDK and bild setup, and 
flash_img_downloader.

1.01 May 30, 2025  n Updated sections about measuring Sleep 1 current consumption and SFlash memory maps.
 n Changed the chip name from RRQ61000 to RA6W1.

1.00 Mar 13, 2025 First release.
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DRAFT The content of this document is under review and subject to formal approval, which may result in modifications or additions. 

APPROVED
or unmarked
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RoHS Compliance

Renesas Electronics’ suppliers certify that its products are in compliance with the requirements of Directive 
2011/65/EU of the European Parliament on the restriction of the use of certain hazardous substances in electrical and 
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