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1. INTRODUCTION 

The M-Station baseboard (M-Station) is a base unit for use with NEC Electronics 78K0 and 78K0S 
micro-boards. A low-cost application development and debugging platform, the M-Station can be used 
to demonstrate and evaluate CPUs and on-chip peripheral functions of NEC Electronics 78K0 and 
78K0S microcontrollers (MCUs). 

Compatible with all of the device-specific 78K0 and 78K0S micro-boards, the M-Station has a flash 
programming capability that allows you to replace an application program at any point during 
development simply by reprogramming the M-Station’s on-chip flash memory. 

There are four ways to use M-Station for evaluating NEC Electronics flash devices. 

• Connecting it to a micro-board through the 100-pin J1 and J2 connectors.  In this mode, 
flash programming and debugging are done through the J1 and J2 connectors and all 
application hardware resources are available. 

• Connecting it to a micro-board through the 16-pin flash programming/debugging interface 
header. In this mode, the micro-board and M-Station are connected though a 16-pin ribbon 
cable (included) and program debugging/flash programming is done through a 16-pin flash 
programming/debugging header. (The M-Station’s hardware resources cannot be used 
in this configuration.) 

• Connecting it to the user target through a 16-pin ribbon cable. In this case, the M-Station is 
used for debugging and flash programming and you must have an on-board NEC 
Electronics microcontroller and a 16-pin header mounted on the target.  See Table 3 for 16-
pin header signals. (The M-Station’s hardware resources cannot be used in this 
configuration.) 

• Connecting it to the user target board and connecting the micro-board to the M-Station 
through 16-pin ribbon cables. To connect a micro-board to your target system, install the 
CPU pins on the micro-board and connect the micro-board to the target system (refer to the 
user’s guide for your selected micro-board).  In this case, the M-Station is used for 
debugging and flash programming. (The M-Station’s hardware resources cannot be 
used in this configuration.) 
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2. FEATURES 

• USB 2.0 high-speed host interface   

• Operating voltage (VDD): 2V to 5V in 0.5V increments   

• Flash programming voltage (VPP): 5.0, 6.8, 7.8, 8.8, and 10V   

• Application development hardware resources   

⎯ Seven-segment LED connecting to selected MCU port signals   
⎯ Two pushbutton switches connected to MCU port inputs 
⎯ Potentiometer connecting to selected MCU analog inputs  
⎯ RS-232 transceiver with optional DB9 connector  
⎯ Optional CAN transceiver and DB9 connector  
⎯ I2C interface connecting to 2 KB EEPROM  
⎯ Socket for optional LCD module   
⎯ Optional 64 KB SRAM footprints for external expansion memory   
⎯ User breadboarding area: 100 mil centered pin array  

• Optional clock module  

• Holder for three AAA-size batteries   

• 16-pin flash programming/debugging interface header  

• Board size of 3.5 × 5.5 inches  
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3. HARDWARE 

Figure 1. M-Station Baseboard 

 

Figure 2. Board Layout 
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Table 1. M-Station Connectors 
Connector Function 

J1 100-pin interface connector to micro-board 

J2 100-pin interface connector to micro-board 

J3 USB type B connector for host interface to PC  

J4 16-pin flash programming/debugging header  

J5 Optional DB9 CAN transceiver connector  

J6 Optional DB9 RS-232 transceiver connector  

J7 Optional clock module (main clock mounted on micro-board)  

J8 12V power adapter connector to center-positive, wall-mounted power supply 

 

Table 2. Jumper Descriptions 
Jumper Description Default Setting 

JP1 If micro-board does not supply VDE power, connect to VDD Open 

JP2 Power source select:  1–2 = power from regulators; 2–3 = battery power  1–2 (REG-VDD) 

JP3 Multiple VDD select (default VDD = 5V) 13–14 (VDD = 5V) 

JP4 Multiple VPP select (default VPP = 10V)  9-10 (VPP = 10V) 

JP5 Reserved for internal use  (USB bus-powered current measurement terminal)  1–2 

JP6 RS-232 transceiver loopback jumper (local RxD to local TxD) Open 

JP7 RS-232 transceiver loopback jumper (remote RTS to remote CTS)  1–2 

JP8 Host interface transmit data (TxD/SO) select (default USB TxD)  1–2 (UTXD to TXDSO) 

JP9 Host interface receive data (RxD/SI) select (default USB RxD)  1–2 (URXD to RXDSI) 
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3.1 J4 16-Pin Flash Programming and Debugging Header  

The 16-pin interface header is designed for compatibility with most NEC Electronics flash 
programmers, for example, the PG-FP4-E or the FlashMASTER. For confirmation, please refer to the 
user’s manual for your device.  Table 3 shows the signal assignments for connection. 

Figure 3. 16-Pin Header, Viewed from Solder Side (Underside) of Target 

 

Table 3. Pin Assignments for 16-Pin Header 
Signal 

Pin No. 
PG-FP4 M-Station 

Description 

1 GND GND Ground 

2 RESET_B RESET_B1 RESET_B1 reset for 78K0 or 78K0S real chip 

3 RxD/SI RxD/SI Serial I/O or UART data receive 

4 VDD VDD_FLASH VDD power to/from micro-board or target 

5 TxD/SO TxD/SO Serial I/O or UART data transmit 

6 VPP VPP Flash programming voltage 

7 SCK SCK Serial clock output from USB interface 

8 HS HS Handshake signal input 

9 CLK X1_OSC Optional clock from baseboard to micro-board (J7 clock circuit 
must be installed) 

10 VDE VDE Micro-board/target VDD detect, power for interface circuit 

11 VDD2 OPEN  

12 FLMD1 FLMD1 Flash programming mode 1 

13 RFU-1 USB_INTP Interrupt signal from USB interface 

14 FLMD0 FLMD0 Flash programming mode 0 

15 Not used OPEN  

16 Not used RESET_B2 Reset for V850ES/KG1 
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3.2 Flash Programming Connections 

The 16-pin J4 flash programming/debugging header can be used to program on-chip flash memory on 
the micro-boards without having to connect the board and M-Station through the 100-pin connectors.  

The 16-pin header also can be used for in-system programming of the MCU on your target system, 
provided the target has a 16-pin interface header to connect to the M-Station. Figure 4 shows the 
arrangement for the 16-pin cable connection.  

Please refer to the flash programming section of the user’s manual for your MCU for information about 
designing the target interface for flash programming. 

Figure 4. M-Station Connection to Flash Programmer 

 

3.3 JP2 VDD Power Source Selection 

The JP2 jumper selects the source of the VDD power on the M-Station. Connecting JP2 pins 1 to 2, 
marked as “REG” and “VDD” respectively on the board, supplies VDD from the on-board VDD_SEL 
voltage generated by the voltage regulator and selected by JP3.  

Connecting JP2 pins 2 to 3, marked as “VDD” and “BAT” respectively on the board, supplies VDD from 
the optional battery pack on the underside of the M-Station baseboard.  This allows the M-Station 
baseboard and attached micro-board to operate in standalone mode on battery power, rather than with 
the 12V power supply connected to the J8 power connector.  Operation is possible without the 12V 
power supply, but it is required for flash programming. 

When VDD power is supplied by the micro-board or target system, remove JP2 to avoid potential 
conflict between VDD levels. 
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3.4 JP3 VDD Voltage Generation 

The VDD for biasing MCU devices can be adjusted to a desired voltage level.  To set the desired VDD, 
select JP3 for the preset voltage level.  R10 is an optional footprint for through-hole resistor.  If VDD 
other than the preset values is desired, install R10 to adjust VDD, and do not insert a jumper in JP3.  To 
calculate the desired VDD, use the following equation.   

VDD_SEL = [1+(R1/R2)]*1.25 + (50µA)*R2 

Where R1 = 825Ω/ R10 and R2 = 500Ω.  

When there is no jumper inserted on JP3, VDD defaults to 2V to prevent VDD from rising to a high 
voltage if you accidentally remove JP3 while power is connected.  However, it is good practice to 
remove power from J8 (power jack) before changing JP3, JP4, or any other jumpers. 

Figure 5. JP3 Multiple VDD Generation 

 

3.5 JP1 VDE Target Voltage Detect Bypass 

When the M-Station baseboard is used for flash programming of a micro-board or target system, the 
VDE signal (pin 10 on the flash programming connector) is used to sense that power is applied on the 
micro-board or target system.  VDE is also used to power the interface circuit between the M-Station 
and micro-board to ensure compatible voltage levels. 

 7



M-Station Baseboard  
 

 

 

If the micro-board or target system does not supply VDE, the interface circuit has no power and 
communication for programming is impossible.  In this case, connect JP1 pins 1 to 2, marked as 
“VDD_FLASH” and “VDE” on the board, to connect VDE to VDD on the flash programming connector.  If 
VDD is supplied by the M-Station, then VDE will match the M-Station voltage level.  If VDD is supplied by 
the micro-board or target system (JP2 removed), then VDE matches the VDD supplied. Normally, the 
micro-board supplies VDE and JP1 should be left open. 

3.6 JP4 VPP Selection and Generation 

VPP for biasing MCUs can be adjusted to any voltage level required.  Select JP4 to set the preset 
voltage level. To set another value, install a resistor in the optional through-hole R11 footprint and 
adjust VPP accordingly, as calculated by the following equation.   

VPX = [1+(R1/R2)]*1.25 + (50µA)*R2 

Where R1 = 150Ω and R2 = R11. 

When there is no jumper in JP4, VPX defaults to the 12V power supply voltage.  Make sure that JP4 
is inserted, and the proper voltage level for the device being programmed is selected.  When 
changing the JP4 jumper, always make sure to remove power from the J8 power jack. 

Figure 6. JP4 VPP Selection and Generation 
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3.7 Optional Main Clock Module 

The main clock and subclock for the MCU are mounted on the micro-board as a standard.  The clock 
module on the M-Station is an optional feature for use when you require frequencies other than ones 
supplied by the micro-boards. 

Figure 7. Main Clock 

 

3.7.1 Mounting Crystal Oscillator 

A crystal oscillator can be mounted on J7 with component positions and connections as shown in the 
diagram above.  Please consult the specification for the crystal oscillator before selecting biasing 
resistors and capacitors.  It may be convenient to use a 14-pin socket and adapter module to install 
crystal oscillators with biasing resistors and capacitors.  In those cases, DigiKey part no. A401-ND 
(from Aries Electronics, Inc.) is the recommended 14-pin socket and DigiKey part no. A102-ND (also 
from Aries) is the recommended DIP header.   

3.7.2 Mounting Full-Size Oscillator 

J7 is designed to accept full-size oscillators in pins 1, 7, 8 and 14.  A full-size oscillator may be 
purchased from DigiKey.   

 9



M-Station Baseboard  
 

 

 
3.7.3 Inter-Board Connectors 

Two 100-pin connectors connect the M-Station’s and micro-board’s CPU signals, flash programming 
interface signals, and control signals.  Two 100-pin connectors also connect to the user breadboard 
area so that the CPU signals can be connected to the M-Station’s development hardware resources. 

3.7.4 User Bread-boarding Area 

The user breadboarding area is a 0.1-inch centered pin array consisting of eight rows of 32 pins per 
row.  Rows 1 and 2 are populated with "jumper posts" so that the signals on row 1 can be selectively 
connected to row 2.  All other rows are left unpopulated so that you may install jumper posts as 
necessary. 

Figure 8. Bread-Boarding Area 
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Row 2 is used to connect to several of the M-Station’s development hardware resources with CPU 
signals brought in to row 1. 

Table 4. Row 2 Hardware Resource Allocation 
Pin(s) Connected to Resource 

1 RS-232 RxD  UART transceiver interface 

2 RS-232 CTS  

3 RS-232 TxD  

4 RS-232 RTS  

5 Switch 2 General-purpose switch 

6 Switch 3  

7 Potentiometer Input to an analog input of the CPU 

8 Open  

9 SCL input of EEPROM  

10 SDA input of EEPROM  

11 to 16 Open  

17 to 24 LED 1 General-purpose numeric display 

25 to 32 LED 2  

3.7.5 Rows 8 and 12 

Row 8 is used for power and ground and LCD segment signals. 

Table 5. Row 8 Hardware Resource Allocation 
Pin(s) Connected to Resource 

1 to 4, 17 to 20 GND System ground (GND) 

9 to 14 VDE (VDD power of micro-board)  

23 to 32 LCD segment signals  

Row 12 is used to connect the LCD module to row 8 pins 23 to 32 for the MCU’s CPU, which has LCD 
segment drivers.  Otherwise, row 8 pins 23 to 32 and row 12 are left for general use. 

3.7.6 Row 0 

Row 0 is a three-pin "jumper post" connected to an optional CAN transceiver.  CAN transceiver 
footprints and a place for mounting DB9 are provided as optional features.   
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3.7.7 Row 1 

Row 1 is used to bring in CPU signals that can be jumper connected from the hardware resources on 
row 2.  When a micro-board is designed, the required UART or port signals are lined up with row 2 so 
that the necessary hardware resources may be used for application development and debugging. 

3.7.8 Row 3 

Row 3 is used to connect to optional 64 KB external expansion SRAM.  The signals for ports 4, 5, and 
6 of the CPU are connected to row 3. 

3.8 Connection to Micro-Board 

The CPU signals are connected to the 100-pin P1 and P2 connectors on the micro-board and the 100-
pin J1 and J2 connectors on the M-Station.  From J1 and J2, the CPU signals are routed to rows in the 
user breadboarding area. 

The signals that are necessary to be used for "Application Development Aid Hardware Resources" are 
pre-assigned so that they can be placed on row 1, where they can be jumper connected to row 2.  For 
example, UART signals are connected to row 1[1:4] so that row 2[1:4] can be jumper connected.  If 
there is an additional UART, the signal for the second UART will be connected to row 3[1:4].  At your 
option, row 2[1:4] can be connected to row 3[1:4].  Refer to the user’s manual for your micro-board. 

Figure 9. Example UART Connections 

 

1. UART0 and UART3 signals are connected to preset positions on P1/P2. 

2. UART0 and UART3 signals are routed to rows 1 and 3. 

3. Selected UART signals can be jumper-connected from row 2. 
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4. APPLICATION DEVELOPMENT AID HARDWARE RESOURCES 

This section describes various M-Station resources, including connection options, jumper settings, and 
part numbers with manufacturer and purchase sources. 

4.1 RS-232 Transceiver 

The RS-232 transceiver is mounted on the M-Station as a standard feature.  The optional DB9 (J6) 
connector has a footprint only on the M-Station.  SB26 and SB27 are solder-blobs (SBs) with closely 
spaced pads.  The default configuration connects SBs with 0Ω resistors that easily can be removed, if 
necessary. When you need to reconnect, use a sufficient amount of solder to short two pads (hence, it 
is a called “solder-blob"). 

Figure 10. RS-232 Transceiver 

 

Table 6. Jumper Settings 
Jumper Jumper Setting Description Default Setting 

JP6 User option Loopback jumper for RxD and TxD Open 

JP7 User option Loopback jumper for RTS and CTS 1 to 2 
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4.2 CAN Transceiver 

The CAN transceiver  in an 8-pin SO package (Linear Technology LT1796CS8) and its DB9 connector 
are optional features whose footprints are provided on the M-Station. The CAN transceiver inputs and 
outputs are connected to row 0.  

Table 7. Can Transceiver Inputs and Outputs 
Pin Signal Description 

1 TxD CAN transceiver 

2 RS CAN transceiver 

3 RxD CAN transceiver 

4.3 I2C and User EEPROM 

The 2 KB user EEPROM is installed in an 8-pin socket (Microchip Technology 24LC16B/P (2 KB); 
DigiKey part no. 24LC16B/P-ND).  EEPROM of other sizes also can be used in place.   

Table 8. Connection to EEPROM from Row 2 
Row Pin Signal Description 

2 9 SCL Clock for EEPROM  

2 10  SDA   Bidirectional data for EEPROM  

The SCL and SDA signals from the CPU, which support I2C functions, are connected to row 1 pins 9 
and 10.  To connect the EEPROM, insert jumpers between the corresponding pins of rows 1 and 2.  
Connect the CPU’s port signals to row 1 pins 9 and 10 so that I2C emulation through a general- 
purpose CPU port can be implemented.   

To enable EEPROM operations up to 400 kHz, the M-Station has 2 kΩ resistors to pull up the SCL and 
SDA lines to VDE for the 24LC16B/P. 

4.4 Seven-Segment LEDs 

The seven-segment LEDs are connected to row 2[17:24] for LED1 and row 2[25:32] for LED2, 
respectively.  Connect the selected I/O ports from the micro-board to row 1[17:24] and row 1[25;32] 
and then insert jumpers between corresponding rows 1 and 2 so that the CPU’s I/O port signals can 
drive seven-segment LEDs. 
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Figure 11. Seven-Segment LED 

 

4.5 Pushbutton Switches 

There are three pushbutton switches. 

Table 9. Function Description of Pushbutton Switches 
No. Description Function 

SW1 Reset switch System reset for M-Station and micro-board when micro-board is connected 

SW2 Connected to row 2, pin 5 General-purpose switch input to a port of the microcontroller CPU 

SW3 Connected to row 2, pin 6 General-purpose switch 

4.6 Potentiometer 

A potentiometer, R51 in the upper right of the M-Station, is connected to pin 6 of row 2. Its low voltage 
is GND, provided when the potentiometer shaft is turned counterclockwise to its full extent.  The high 
voltage is VDE, provided when the potentiometer shaft is turned clockwise to its full extent. 

Pin 6 of row 1 is connected to an analog input port of the micro-board.  By inserting a jumper between 
pin 6 on rows 1 and 2, you can test analog-to-digital (A/D) conversion using the potentiometer to 
supply a voltage between GND and VDE. 
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4.7 LCD Socket 

An optional pin socket can be mounted on row 8[23:31] and row 12, where an LCD module can be 
inserted.  The segment drive signals for the microcontroller CPU are connected to row 8[23:31] and 
row 12.  These pins are open for the CPUs, which do not support LCD segment drive. 

Figure 12. Four-Digit, Seven Segment LCD Module 

 

4.8 Optional Expansion Memory 

Optional footprints for 64 KB external expansion SRAM and its address latch are provided.  The 
address, data, and read/write control signals are connected to row 3 and are normally connected to 
address, data and control lines through solder blobs. 

Table 1 ional Expansion Memory Signals on ROW3 0. Opt
Description Name Row Connection 

Address and data  AD[0:7]    ROW3[16:24] Through SB[17:10]  

Address  A[8:15]    ROW3[25:32]   Through SB[9:2] 

Address latch ADDR_LD  ROW3[16] Through SB[18] 

Read SRAM_RDB ROW3[13] Through SB[21] 

Write SRAM_WRB ROW3[14] Through SB[20] 

Row 3 is free for other use if the optional memory and its address latch are not mounted.  If, however, 
the optional memory is mounted, the selected row 3 is dedicated for the external expansion memory.  
To disconnect row 3 from external expansion memory after the memory is mounted, remove the 0Ω 
resistors mounted on the solder blobs instead of removing memory.   
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5. JUMPER SETTINGS SUMMARY 

5.1 JP1: Micro-Board VDE Voltage Detect and Interface Power 

Leave JP1 open when the micro-board supplies VDE.  Insert JP1 to connect VDE to VDD_FLASH when 
the micro-board does not supply VDE. 

5.2 JP2 and JP3: Power Select 

Figure 13. JP2 and JP3 Settings 

 

Table 1  Settings 1.  JP2
Jumper Jumper Setting Description Default Setting 

1 to 2 Select VDD_SEL  1 to 2  

2 to 3 Select battery power from battery holder   

JP2 

Open VDD is supplied by micro-board  
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Table 1  Settings 2.  JP3
Jumper Jumper Setting Description Default Setting 

No jumper  VDD_SEL = 2.0V   

1 to 2 VDD_SEL = 2.5V   

3 to 4 VDD_SEL = 3.0V   

5 to 6 VDD_SEL = 3.3V   

7 to 8 VDD_SEL = 3.5V   

9 to 10 VDD_SEL = 4.0V   

11 to 12 VDD_SEL = 4.5V  

JP3 

13 to 14 VDD_SEL = 5.0V 13 to 14 

 R10 User-selected VDD (refer to Section 3.4)   

 

5.3 JP4: Multiple VDD Select 

Figure 14. JP4 Settings 

 

Table 1  Settings 3. JP4
Jumper Setting Description Default 

1 to 2 VPX = 5.0V  

3 to 4 VPX = 6.8V   

5 to 6 VPX = 7.8V   

7 to 8 VPX = 8.8V   

JP4 

9 to 10 VPX = 10V 9 to 10 

 R11 User-selected VPX  (refer to section 3.5)   
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5.4 JP5: USB Power Current Measurement Terminal 

Reserved for NEC Electronics use only. 

5.5 JP8 and JP9: Host Interface RxD_SI and TxD_SO Select 

RXD_SI is connected to 16-pin header and 100-pin inter-board connector.  It is then connected to TxD 
Input or serial output (SO) of microcontroller CPU on the micro-board.  Likewise, the TXD_SO 
connects to the 16-pin header and 100-pin inter-board connector, and then to RxD or serial input (SI) 
of the microcontroller CPU. 

Figure 15. JP8 and JP9 Settings 

 

Table 1  and JP9 Settings 4. JP8
Jumper Jumper Setting Description Default Setting 

1 to 2 Select TxD from USB host interface  1 to 2 (UTXD to TXDSO) 

2 to 3 Select serial output (SO) from USB host interface   

JP8 

2 to 4 Connect micro-board RxD to input from RS-232 
transceiver  

 

1 to 2 Select RxD from USB host interface  1 to 2 (URXD to RXDSI) 

2 to 3 Select serial input (SI) from USB host interface   

JP9 

2 to 4 Connect micro-board TxD output to RS-232 
transceiver  
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6. M-STATION SOFTWARE AND USB DRIVERS 

6.1 Software Features 

• Flash programming of the MCU on the micro-board or in the target system 

• Communication between the computer and a user program running on the micro-board or target 
system, through the M-Station serial port and terminal emulation software 

• Interactive debugging of the user program with a source-level debugger 

6.2 Software Modules 

• USB driver that provides communication through a standard USB port on the computer at USB 2.0 
speeds of 480 Mb/s or USB 1.1 speeds of 12 Mb/s. 

• OPTMST program that allows you to set the parameters necessary for MCU flash programming 

• FP4MST program that performs flash-programming operations on the MCU 

• MSTTERM program that provides a terminal-like interface to a user program running in the MCU 

• ID78K0-MON or ID78K0S-MON source-level debuggers for 78K0 and 78K0S MCUs, respectively, 
that communicate through the M-Station to a small debugging monitor compiled into the user 
program to allow 

⎯ Execution of the user program in real time 
⎯ Debugging in single steps and with breakpoints 
⎯ Pausing of the user program to allow examination of the contents of registers, 

peripherals, and memory  

The M-Station USB driver must be installed first, following the procedure outlined in section 6.3.  You 
can then install the OPTMST, FP4MST, and MSTTERM programs from the M-Station CD-ROM. 
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6.3 USB Driver 

The M-Station is supplied with drivers that allow it to operate on Microsoft Windows 98, Windows ME, 
Windows 2000, and Windows XP systems.  USB operation is not supported by the Windows 95 or 
Windows NT 4.0 operating systems. 

The M-Station USB driver consists of system-level files called usbmstnv1.sys (for Windows 2000 or 
Windows XP) and usbmstn1.sys (for Windows 98 or Windows ME).  Once installed, the driver file 
automatically loads whenever you connect the M-Station to a computer, automatically downloading 
firmware for the USB host interface on the M-Station and providing functions used by higher-level 
software for operation of the M-Station. 

1. Install the M-Station USB driver, following the directions for your particular operating 
system, before attempting to operate the M-Station. 

• X:\fscommand\Software\M-Station\Drivers\98-ME (for Windows 98 or Windows ME) 

• X:\fscommand\Software\M-Station\Drivers\2K-XP (for Windows 2000 or Windows XP) 

where X is the letter of your CD-ROM drive. 

2. In general, use the Windows Add New Hardware Wizard to copy the file from the CD-ROM 
to your system directory and to set registry entries to invoke the driver when you connect 
the M-Station.  In Windows 2000 and Windows XP systems, you must have an administrator 
account or administrator privileges to be able to perform the installation. 

3. Because of the way the Windows system keeps track of USB devices, when you install the 
driver, it is registered to a particular USB port.  If you plug the M-Station into that port again, 
the driver loads automatically.  If you plug the M-Station into a different USB port, then the 
driver is installed and registered again on that port.  This does not require recopying of the 
files from the CD-ROM, but it does require you to have administrator privileges on Windows 
2000 and Windows XP systems. 

4. If you connect the M-Station to multiple USB ports on your computer, we recommend that 
you perform the installation on one USB port on the computer and then, while still in the 
administrator account, plug the M-Station into the other USB ports to register the drivers for 
those ports. 

5. If you have installed the driver previously, and are upgrading it to a newer version, you must  
uninstall the previous one before installing the new.  The procedure for driver uninstallation 
is different depending on the operating system; please see the appropriate sections 
following. 
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6.3.1 USB Driver Installation for Windows 98 or Windows ME 

1. Insert the M-Station CD-ROM into the drive on your computer. 

2. Go to X:\fscommand\Software\M-Station\Drivers\98-ME (where x is the letter of your drive). 

3. Connect a USB cable to the USB ports on your computer and the M-Station. 

4. When the wixard appears, click Next>. 

 

5. Select the Search for the best driver... check box and click Next>. 

 

6. Select the Specify a location check box and click Next >. There already may be a location 
displayed. If so, disregard it and click Browse. 

 

 22



 M-Station Baseboard 
 
 
 

7. Go to X:\fscommand\Software\M-Station\Drivers\98-ME (where X is the letter of your CD-
ROM drive) and then click OK. 

 

8. When the wizard correctly shows the ..\98-ME directory, click Next>. 

 

9. Click Next> to continue. 
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10. You may or may not see this message. If you do, click OK. 

 

11. Click Finish to complete the installation process and begin using the driver. 

 

12. To verify installation, connect the M-Station to the system. 

13. Click Start → Control Panel → System. 

14. Select the Hardware tab and then the Device Manager tab. 

15. Expand the Universal Serial Bus controllers list, verify that NEC M-Station-USB-IF-1 is 
shown, and then click OK.  
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6.3.2 USB Driver Installation for Windows 2000 

You must have administrator privileges to be able to install this driver. 

1. Insert the CD-ROM into the drive on your computer. 

2. Go to X:\fscommand\Software\M-Station\Drivers\2K-XP (where X is the letter of your drive). 

3. Connect a USB cable to the USB ports on your computer and the M-Station to begin the 
installation. 

 

4. Click Next> to start the wizard. 

 

5. Select the Search for a suitable driver... check box and click Next>. 
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6. Select the Specify a location check box and click Next>. 

 

7. The next dialog box may or may not show a directory.  In either case, click Browse.   

 

8. Go to X:\fscommand\Software\M-Station\Drivers\2K-XP (where X is the letter of your CD-
ROM drive), select usbmstnv1.inf, and then click Open.   

 

9. Click OK.  

 

 26



 M-Station Baseboard 
 
 
 

10. Verify the path to the usbmstnv1.inf file and then click Next>. 

 

11. Click Finish to complete the installation and begin using the driver. 

 

12. To verify driver installation, connect the M-Station to the system. 

13. Click Start → Control Panel → System. 

14. Select the Hardware tab and then the Device Manager tab. 

15. Expand the Universal Serial Bus controllers list, verify that NEC M-Station-USB-IF-1 is 
shown, and then close the screen. 
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6.3.3 USB Driver Installation for Windows XP 

You must have administrator privileges to be able to install the driver. 

1. Insert the CD-ROM into the drive on your computer. 

2. Go to X:\fscommand\Software\M-Station\Drivers\2K-XP (where X is the letter of your drive). 

3. Connect a USB cable to the USB ports on your computer and the M-Station to initialize the 
wizard. 

4. Select the Install from a list or specific location... check box and click Next>. 

 

5. Clear the Search removable media check box 

6. Select the Search for the best driver in these locations check box and the  Include this 
location in the search check box 

7. There may or may not be a path shown in the box beside the Browse command button. In 
either case, click Browse. 
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8. Select X:\fscommand\Software\M-Station\Drivers\2K-XP (where X is the letter of your CD-
ROM drive) and click OK. 

 

9. When the wizard shows the ..\2K-XP directory, click Next>. 
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10. You will see a message warning that the NEC M-Station-USB-IF has not passed Windows 
Logo testing.  Click Continue Anyway. 

 

11. The wizard then begins to install the software. 

 

12. When you see the Completing the Found New Hardware Wizard message, click Finish. 
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13. If you have installed the driver by connecting to a low-speed USB port, you may at this point 
see a warning message. Refer to subsection 6.3.3.1. 

14. If you have installed the driver by connecting to a high-speed USB port, you may need to go 
through the installation steps again. Refer to 6.3.3.2. 

15. To verify driver installation, connect the M-Station to the system. 

16. Click Start → Control Panel → System. 

17. Select the Hardware tab and then the Device Manager tab. 

18. Expand the Universal Serial Bus controllers list. 

19. If the list shows the NEC M-Station-USB-IF-1 file, installation is complete and the driver is 
ready for use 
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6.3.3.1 Windows XP Warning Message For Non-High-Speed Ports 

After installation, if you attach the M-Station to a host USB port incapable of supporting USB 2.0 high-
speed operation, you may receive the following warning message.  

 

Because the M-Station operates properly in either a high- or non-high-speed port, you may disregard 
the message and click Close. 
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6.3.3.2 Re-install Windows XP Driver at High Speed From Non-High Speed 

If you install the driver on a non-high-speed port, and later attach the M-Station to a high-speed port, 
you will need to perform another installation. 

1. Initialize the wizard. 

2. Select the Install the software automatically... check box and click Next>. 

 

3. When you see the warning message, click Continue Anyway. 

 

4. If you have removed the CD-ROM from your drive, insert it and click OK. 
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5. Click Finish to complete the installation. 

 

If you then plug the M-Station into a high-speed port, you may briefly see the warning messages again, 
but they should disappear quickly after the M-Station initializes.  Please disregard them. 

6.3.4 Uninstalling the USB Driver 

If you installed the driver previously and now want to upgrade to a newer version, you must uninstall 
the previous one before installing the new.  The procedure for driver uninstallation varies according to 
operating system. 

Note that if you are upgrading the driver, you will need to delete the driver files as well, otherwise the 
Windows operating will reinstall the old driver the next time you connect the M-Station. 

6.3.4.1 Uninstalling the USB Driver for Windows 98 or ME 

1. Connect the M-Station to your computer. 

2. Click Start → Settings → Control Panel → System. 

3. Select the Device Manager tab. 

4. Expand the Universal Serial Bus controllers list. 

5. Select NEC M-Station-USB-IF-1 and click Remove. 

6. When you see the warning message, click OK to remove the device. 

7. Disconnect the M-Station from the system. 

This procedure alone does not remove the driver files from the system.  Therefore, before you can 
install an upgrade, you must do the following. 

1. Run Internet Explorer. 

2. Select the C:\WINDOWS directory. 
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3. Click Tools → Find → Files → Folders. 

4. Enter usbmst in the Search for files or folders named text box and then click Search. 

5. You should see these results: 

• USBMSTN1.INF  in C:\WINDOWS\INF 

• Micro...usbmstn1.inf in C:\WINDOWS\INF\OTHER 

• USBMSTN1.SYS  in C:\WINDOWS\SYSTEM32\DRIVERS 

6. Delete them, rename them, or move them to a different directory if you wish to save them. 

7. The USB driver is now uninstalled, and you may update or reinstall it following the 
procedure outlined in section 6.3.1. 

6.3.4.2 Uninstalling USB Driver for Windows 2000 

You must have administrator privileges to uninstall the driver. 

1. Connect the M-Station to your computer. 

2. Click Start → Settings → Control Panel → System. 

3. Select the Device Manager tab. 

4. Expand the Universal Serial Bus controllers list. 

5. Right-click NEC M-Station-USB-IF-1. 

6. Click Uninstall. 

7. When you see the warning message, click OK. 

8. At that point, the file name should disappear. 

9. Disconnect the M-Station from the system. 

This procedure alone does not remove the driver files from the system.  To do that, which is necessary 
before you can install an upgrade, you must do the following. 

1. Run Internet Explorer. 

2. Select the C:\WINNT\SYSTEM32 directory. 

3. Click File → Search. 

4. Enter usbmst in the Search for files or folders named text box and then click Search. 

5. You should see this result:  USBMSTNV1.SYS in C:\WINNT\SYSTEM32\DRIVERS 

6. Delete this file, rename it, or move it to a different location if you wish to save it. 

7. From Internet Explorer, select the C:\WINNT\INF directory. 

8. Click File → Search. 
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9. Enter oem*.inf in the Search for files or folders named text box. 

10. Enter usbmst in the Containing text box. 

11. Click Search. 

12.  You should see the oemxx.inf file, where "xx" is one or more decimal digits. 

13. Open the file with a text editor such as Notepad and make sure the file starts with this text: 

; Installation inf for the NEC USB to M-Station Interface 

14. Delete this file, rename it, or move it to a different directory if you wish to save it. 

15. The driver is now uninstalled, and you may update or reinstall it following the procedure 
outlined in section 6.3.2. 

6.3.4.3 Uninstalling USB Driver for Windows XP 

You must have administrator privileges to be able to uninstall the driver. 

1. Connect the M-Station to your computer. 

2. Click Start → Settings → Control Panel → System. 

3. Select the Hardware tab and then the Device Manager tab. 

4. Expand the Universal Serial Bus controllers list. 

5. Right-click NEC M-Station-USB-IF-1. 

6. Click Uninstall. 

7. When you see the warning message, click OK. 

8. Disconnect the M-Station from the system. 

This procedure alone does not remove the driver files from the system.  To do that, which is necessary 
before you can install an upgrade, you must do the following. 

1. Run Internet Explorer. 

2. Select C:\WINDOWS\SYSTEM3. 

3. Click File → Search. 

4. Enter usbmst in the Search for files or folders named text box and click Search. 

5. You should see this result: USBMSTNV1.SYS in C:\WINDOWS\SYSTEM32\DRIVERS 

6. Delete this file, rename it, or move it to a different location if you wish to save it. 

7. From Internet Explorer, select C:\WINDOWS\INF. 

8. Click File → Search. 

9. Enter oem*.inf in the Search for files or folders named text box. 
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10. Enter usbmst in the Containing text box. 

11. Click Search. 

12. You should see the oemxx.inf file, where "xx" will be one or more decimal digits. 

13. Open the file with a text editor such as Notepad and make sure it starts with this text: 

; Installation inf for the NEC USB to M-Station Interface 

14. Delete the file, rename it, or move it to a different directory if you wish to save it. 

15. The driver is now uninstalled, and you may update or reinstall it following the procedure in 
the section 6.3.4.3. 
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7. PREPARING THE M-STATION FOR OPERATION 

Before using the M-Station with a micro-board or target system, you must configure the M-Station to 
match the power configuration, voltage levels, and programming and communication methods of the 
micro-board or target system.  

1. Set JP1, JP2, JP3 and JP4 for the proper power configuration of the M-Station and micro-board or 
target. 

2. Set JP8 and JP9 for the proper flash programming and communication configuration.  

3. Set the jumpers connecting ROW1 and ROW2 on the M-Station if the micro-board will be using 
the M-Station application hardware. 

4. Set any necessary jumpers on the micro-board or target for power, flash programming, and 
communication options. 

5. Connect the M-Station to the micro-board without power supplied.  (Note: if battery power on the 
M-Station is to be used, JP2 should be out at this point.) 

6. Connect the M-Station to the computer using a standard USB cable.  Wait for the USB LED to be 
on steadily. 

7. Connect power to the M-Station or the target system by either connecting the AC adaptor 
supplying 12V to the J8 power connector, connecting JP2 to “BAT” to supply battery power, or 
powering the target system. 

At this point, the M-Station and micro-board are ready for operation and you can begin using the 
OPTMST, FP4MST, or MSTTERM programs. To power-down and disconnect the M-Station and micro-
board, first close any running software application and then reverse the preceding steps. 
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7.1 Configuration of M-Station and Micro-Board or Target System 

The M-Station baseboard can be connected to micro-boards or target systems in one of two ways. 

• For micro-boards such as the M-78F0138, connect the micro-board directly to the underside 
of the M-Station baseboard using the two 100-pin connectors mounted on each board. 
These connectors connect the  

⎯ Power, flash programming and communication signals 
⎯ CPU on the micro-board to the M-Station’s application hardware 

• For micro-boards such as the EV0338, connect the M-Station to the micro-board with a 
cable connected to the 16-pin J4 flash programming/communication port. 

⎯ This can be a 16-pin flat cable to connect to boards with a matching 16-pin flash 
programming connector (such as the EV0338), or a 10-pin flat cable for older boards 
with a 10-pin flash programming connector. 

⎯ In this case, the cable provides connections for power, flash programming and 
communication, but the micro-board does not have access to the application 
hardware on the M-Station baseboard. 

• For target systems, connect the M-Station baseboard through a 16-pin or 10-pin cable in the 
same way you connect the micro-boards.  Care needs to be taken when the target system 
supplies its own power and/or clock signals, and when the target system uses the flash 
programming and communication signals in its own hardware. 
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7.2 Power Supply Options, JP2 Settings 

Having the M-Station supply power to the micro-board or target system is the normal method of 
operation. When the M-Station supplies power to the micro-board, set JP2 to select the source of the 
VDD power to the micro-board. 

• Set JP2 to the “REG” position to supply VDD from the variable on-board VDD regulator, with 
the VDD voltage set by the JP3 jumper option.  In this case, the AC adaptor connected to the 
J8 power connector provides the M-Station’s power. 

• Set JP2 to the “BAT” position to select the battery power provided by the three AAA-size 
batteries mounted in the battery pack on the underside of the M-Station baseboard.  In this 
case, the batteries supply VDD and the AC adaptor is not required for standalone operation 
of the micro-board or for communication using the MSTTERM program.  Flash programming 
is not possible in this configuration. 

• When the target system supplies its own power, remove JP2 so that neither “BAT” nor 
“REG” is connected.  In this case, the target system supplies VDD through the flash 
programming and communication cable.  Removing JP2 in this situation prevents a power 
conflict between the M-Station power and the target power. 

7.3 Power Monitoring Options, JP1 Settings 

The M-Station can monitor VDD in the target system through the VDE signal on the flash programming 
connector or the 100-pin connectors to the micro-board.  The software uses the VDE signal to sense 
whether the target system has power or not.  The VDE signal also provides power to the interface 
circuits on the M-Station baseboard, to ensure a proper match between M-Station and target voltages. 

• When the micro-board or target system provides the VDE signal, don’t connect the JP1 
jumper. 

• When the target system or micro-board does not supply the VDE signal, the interface 
circuitry does not have power. This is the case with older boards, such as the K0RE9418, 
whose VDE voltage can be derived by connecting JP1 pins 1 and 2. 

⎯ JP1 connects the VDE signal to the VDD_FLASH signal on the flash programming 
connector. 

⎯ When JP1 is connected, the same source provides VDE and VDD_FLASH: either the 
power selected on the M-Station baseboard when JP2 is connected or from the target 
VDD through the flash programming connector when JP2 is not connected. 
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7.4 VDD and VPP Voltage-Level Options, JP3 and JP4 Settings 

With JP2 set to “REG”, VDD_SEL provides VDD voltage for the micro-board.  The jumpers at JP3 allow 
this voltage to be set from 2.0V (with no jumpers connected) up to 5.0V (with JP1 13–14 connected). 

Before connecting the M-Station baseboard to a micro-board or target system, refer to the user’s 
manuals for the micro-board and MCU and then check that VDD is set appropriately for the CPU chip.  
Some 78K0 and 78K0S MCUs can operate up to 5.0V, but others have a maximum VDD of 3.3V.  
Setting VDD at a voltage higher than the maximum for the CPU can result in damage to the CPU 
chip, micro-board, and/or target system. 

When you use the M-Station to flash program a CPU on a micro-board or in a target system, the M-
Station drives VPP. Use JP4 to set VPP to 5.0V, 6.8V, 7.8V, 8.8V or 10.0V.  JP4 should be set to select 
the VPP voltage that is appropriate for the chip being programmed.  Please refer to the User’s manual 
for the micro-board or to the microcontroller device documentation.  Setting VPP at a voltage that is 
higher than the maximum for the CPU chip can result in damage to the CPU chip.  Setting VPP 
at a voltage that is lower than the recommended level can result in unsuccessful flash 
programming of the device. 

Refer to Table 3 and Figure 5 for information about the settings of JP3 and JP4.  For the settings of 
your micro-board, refer to its companion user’s manual. 

7.5 Flash Programming Channel Choices, JP8 and JP9 Settings 

The M-Station can flash program NEC Electronics 78K0 or 78K0S MCUs using either the three-wire 
serial port method (SIO) or the UART method.  The choices available for a particular chip vary.  Some 
may support both methods, but only one on a certain set of pins. Other devices may only support one 
method of flash programming.  Please refer to the user’s manuals for the micro-board and MCU. 

1. When using the SIO method, set JP8 and JP9 for SIO configuration by connecting pins 2–3 
on each of JP8 and JP9. 

• For JP8, this connects the TXD_SO output signal on the flash programming interface to the 
SO output on the USB interface, labeled “USO” on the M-Station. 

• For JP9, this connects the RXD_SI input on the flash-programming interface to the SI input 
on the USB interface, labeled “USI”. 
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The SIO method also requires connection of the SCK serial clock, driven by the SCK output on 
the USB interface. 

2. When using the UART method, set JP8 and JP9 for UART configuration by connecting pins 
1–on each of JP8 and JP9. 

• For JP8, this connects the TXD_SO output signal on the flash-programming interface to the 
TXD UART output on the USB interface, labeled “UTXD” on the M-Station. 

• For JP9, this connects the RXD_SI input on the flash-programming interface to the RXD 
UART input on the USB interface, labeled “URXD”. 

With the UART method, it is not necessary to connect the SCK output on the flash 
programming interface to the CPU chip. 

When using either a source-level debugger or a micro-board to develop a program that communicates 
through a UART, use the UART method, if available, for convenient flash programming.  In this case, 
JP8 and JP9 are set to UART configuration rather than changed to SIO for flash programming and 
then back again for UART communication. 

The micro-board must have its flash programming jumpers set in a way that is compatible with the 
settinsg of the M-Station.  Refer to the user’s manuals for the micro-board and MCU. 

7.6 UART Communication, JP8 and JP9 Settings 

You can use the MSTTERM program to communicate with a user program in the flash device on a 
micro-board or target system.  In this configuration, the program communicates with the USB interface 
on the M-Station through the USB driver and cable; the USB interface then communicates through its 
UART port with a compatible UART on the micro-board’s CPU. 

For UART communication, set JP8 and JP9 to UART configuration with pins 1–2 connected on each 
jumper, so that TXD_SO connects to the UTXD UART output of the USB interface and RXD_SI 
connects to the URXD UART input of the USB interface. 

The jumpers on the micro-board should be set to connect the TXD_SO and RXD_SI signals to UART 
pins on the CPU device.  Refer to the user’s manual for the micro-board for appropriate settings. 
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7.7 Connection of Micro-Board or Target System 

After both the M-Station and the micro-board have been configured, connect the M-Station to the 
micro-board or target with power off.  If you are planning to power the micro-board using batteries on 
the M-Station, make sure that JP2 is not set to the “BAT” position at this point. 

• For micro-boards such as the M-78F0138, connect the micro-board to the underside of the 
M-Station using the 100-pin, high-density connectors.  These connectors are polarized, so 
there is only one possible connection orientation. 

• For micro-boards such as the EV0338 or EV9835, connect the 16-pin to 16-pin flat cable to 
connector J4 on the M-Station and to the 16-pin connector on the micro-board. 

• For older boards such as the K0RE9418 with a 10-pin flash programming connector, use the 
10-pin cable, connecting the 16-pin connector to J4 on the M-Station, and the 10-pin 
connector to the micro-board. 

• For target systems, use the appropriate cable for the flash-programming connector 
designed into the target system. 

7.8 Connection of USB Cable 

Connect the M-Station to the computer with a standard A-B USB cable.  The flatter A side of the cable 
will connect to a USB port on the PC, and the squarer B side of the cable will connect to the J3 USB 
connector on the M-Station. 

If the M-Station USB driver has been properly installed, the driver will load on the PC at this point, and 
will download firmware to the USB interface on the M-Station for initialization.  The green D1 LED, 
labeled “USB CONN”, just below the J3 connector, will flash on briefly once at the start of initialization.  
When initialization is complete, the green D1 LED will turn on and remain on steadily.  At this point, the 
M-Station is ready for communication with the PC, but operation will still require that power be applied. 

While the USB interface is being initialized, which takes 6 to 8 seconds, trying to run M-Station 
software such as FP4MST or MSTTERM may result in improper operation.  Do not run FP4MST or 
MSTTERM until the green D1 LED has come on and remained on. 

Note: The M-Station and micro-board can be operated as a standalone system, without connection to 
the PC, to operate a user program, but flash programming and terminal emulation will not be available.  
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7.9 Connection of Power 

1. To apply power to the M-Station, connect the supplied AC adapter to an AC power source. 

2. Connect the power connector on the adapter to the J8 power connector on the M-Station.  
This will provide 12VDC for operation of the M-Station. 

3. If you are using the batteries in the battery holder to power the micro-board, connect JP2 to 
the “BAT” position at this time. 

4. If you are using the target system to provide power to the CPU and the M-Station VDD 
and/or VDE power, turn on the target power at this point.  Make sure JP2 is removed when 
powering the M-Station interface from the target. 

5. When power is applied to the M-Station and available to power VDD on the micro-board, the 
red PWR LED D11 will light. 

6. The red D11 PWR LED indicates that VDD power is available on the M-Station, but does not 
necessarily indicate that VDD is “hot”. 

7. When running the FP4MST program, VDD from the M-Station is turned off except when 
actively performing a flash programming operation, but the red D11 LED will still be on.  This 
allows the connection of a FA-type flash adapter to the M-Station to program a loose device, 
and allows the socket on the adapter to be “cold” for changing of devices between 
operations. 

8. In all other instances, you should assume that VDD power is on when the red D11 PWR LED 
is on. At this point, the M-Station and micro-board are connected, powered, and ready for 
operation. 
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8. USING OPTMST TO SET FLASH PROGRAMMING OPTIONS 

When the M-Station is used to flash program an NEC Electronics 78K0 or 78K0S microcontroller, the 
details of the algorithms used to program the device are contained in a parameter file, with the 
extension .PRC, which is read in by the FP4MST program. 

There are options in flash programming that are not specified by the .PRC file, but instead must be set 
by you.  These options are stored in the system registry and are available to the FP4MST program 
when it is executed.  The OPTMST program is used to set the state of these options in the registry: 

• Source and frequency of the main clock for the microcontroller 

• Communication port and speed for flash programming 

• VDD and VPP voltage settings, for checking against selected .PRC file 

• Additional timing parameters for adjustment of algorithms 

• Whether to automatically load the .PRC file, or to prompt the user for it 

Usually the OPTMST program needs to be run only when first configuring the M-Station hardware and 
software for flash programming.  After the initial settings are made, the FP4MST program will run 
without adjustment of these settings. 
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To run the OPTMST program, click Start → Run → file name to display the OPTMST Flash 
Configuration dialog box. 

 

The main sections of the OPTMST window and the associated settings are explained in the sections 
following.  

Please refer to the user’s manual for your micro-board to learn about jumper settings and appropriate 
OPTMST selections. 
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8.1 Flash Clock Settings: Source and Frequency 

 

In the Flash Clock Source box, there are two option buttons that enable you to select whether the 
source of the main clock for the device being programmed is Host (driven by M-Station baseboard) or 
Target (supplied by the micro-board or target system). 

1. Normally the micro-board used with the M-Station has an on-board main clock crystal circuit 
and does not need a clock supplied from the M-Station.  In this case, click Target to disable 
the M-Station’s CLK clock output signal on the flash-programming interface. 

2. When an optional clock oscillator is mounted on the M-Station in the J7 location, the M-
Station can provide a driven main clock to the micro-board or target.  In this case, click Host 
to enable the M-Station to drive the CLK signal on the flash-programming interface. 

Jumpers may need to be changed on the micro-board for the driven clock to be used.  Also, 
if no oscillator circuit is mounted in J7, then the CLK line will not oscillate. 

3. Whether the main clock is provided on the target or driven by the M-Station, enter the 
frequency of the main clock in the Target Frequency text box.  The value is recorded in 
megahertz (MHz). For example, the M-78F0138’s on-board crystal provides a 10 MHz clock, 
so you should you type “10” or “10.0” for the frequency.  On the K0RE9418 board, the on-
board crystal is 4.9152 MHz and you should enter “4.9152”. 

The clock frequency value is used to initialize and calibrate operations on the M-Station side of the 
flash-programming interface, and internal operations of the flash microcontroller itself during 
programming.  Entering an incorrect value for the frequency may result in failure of communication 
between the M-Station and the flash device, or incorrect programming operations. 

8.2 Communication Interface Settings 

 

The Communication Interface box enables you to select the flash-programming communication 
channel and the rate at which communication takes place. 
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8.2.1 Port Box 

The Port box contains eight programming channels: four SIO channels and four UART channels. The 
channels available for a particular flash MCU may be limited to only one of the eight, or to a subset of 
the total possible.  Refer to the flash-programming section of your device documentation to determine 
which channel(s) may be used, and then select the appropriate one from the list. 

Once you select a channel, the VPP/FLMD0 Pulse box is updated to show the number of VPP or FLMD0 
pulses associated with that channel.  You may check the number of pulses shown against the 
information given in the flash MCU documentation, which will list the number of VPP pulses associated 
with a particular channel and pins. 

Note that the choice of channel may be dictated by which pins on the flash MCU are used for flash 
programming.  Often one set of pins is available for one SIO channel, and another set of pins is 
available for another SIO channel.  UART channels may or may not use the same pins as one of the 
SIO channels. 

When you select an SIO channel, set JP8 and JP9 in the SIO position, with pins 1–2 connected on 
each: USO-TXDSO on JP8 and USI-RXDSI on JP9.  When you select a UART channel, set JP8 and 
JP9 in the UART position, with pins 2–3 connected on each: TXDSO-UTXD on JP8 and RXDSI-URXD 
on JP9. 

8.2.2 Rate Box 

The Rate box contains a selection of available serial port rates that can be used in flash programming.  
For transfers of large amounts of data, such as when programming a large user program, or verifying a 
program of any size, setting a faster serial rate allows the operation to go more quickly. 

For SIO channels, you may select the serial I/O rate from a low of 2.5 kHz (2500 bits per second) to a 
high of 188 kHz (188,000 bits per second).  When you change from a UART channel to an SIO 
channel, the default rate is set to 50 kHz.  Depending on the main clock frequency of the device being 
programmed, devices may not be able to operate at the highest bit rates.  It is recommended that you 
start at 50 kHz; after successful programming is done at this rate, you may try faster rates. 

For UART channels, the rates for programming are 9600, 19200, 38400, and 76800 baud.  When 
switching from an SIO channel to a UART channel, the default rate is set at 9600.  Depending on the 
main clock frequency of the device being programmed, you may not be able to operate devices at the 
highest baud rate possible.  It is recommended that you start at 9600 or 19200 baud; after successful 
programming is done at these rates, you may try faster rates. 
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8.3 Voltage Settings 

 

The M-Station is capable of providing various VDD and VPP voltages to accommodate the various NEC 
Electronics flash-programmable MCUs.  Use JP3 and JP4 to set the appropriate voltage.  See sections 
3.4 and 3.6 of this user’s manual for the voltages and settings for these jumpers. 

When the FP4MST program reads in a .PRC file for a particular MCU, FP4MST can check the VDD and 
VPP voltages required by this device (contained in the .PRC file) against the settings of the jumpers on 
the M-Station, if those settings are recorded by OPTMST.  The M-Station software cannot directly 
check the voltage selected by the jumpers, but it can compare the required voltages against the 
recorded settings. 

After selecting the appropriate voltage levels for a device by setting JP3 and JP4 on the M-Station, set 
the JP3 Setting and JP4 Setting boxes to reflect the jumper connection used.  When you select a 
particular jumper setting, the associated VDD or VPP voltage is shown in the VDD Voltage and VPP 
Voltage boxes to the right of the jumper selection boxes. 

8.4 PRC User-Specified Parameter Settings 

 

The PRC User-Specified Parameters box enables you to adjust the timing parameters specified in 
the .PRC file. 

8.4.1 Additional Power On Time 

Normally the FP4MST software switches on the VDD power to the flash device being programmed, and 
then waits a specified amount of time to turn on VPP power and release reset.  The amount of time to 
wait after applying VDD power is specified in the .PRC file, with a minimum time of 30 milliseconds (ms). 

For systems where there are significant capacitors connected to the VDD power on the micro-board, or 
where a circuit is employed to hold down the RESET line for a period of time after VDD is applied, it 
may be necessary to have the FP4MST software wait an additional time after turning power on to VDD.  
For example, on the EV0338 board, an RC circuit generates a power-on reset, which may result in 
RESET being low past the 30 ms normally allowed for power-on time. 
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In such cases, entering an amount of milliseconds in the Additional Power On Time box results in an 
additional delay after VDD power is turned on before flash programming begins.  For the EV0338, an 
additional power-on time of 200 ms is recommended to allow the power-on reset to settle. 

8.4.2 Additional Write Time Per Word 

For some flash MCUs, you can adjust the write time per word specified in the .PRC file upward by 
providing an additional time.  If this is possible, the FP4MST program prompts you to specify the 
additional amount of time. The default amount can be set in this section of OPTMST.  Most devices do 
not require this parameter, but for those that do, a nominal value of 50 microseconds (µs) is 
suggested.  Select the Automatic check box if you want to avoid having to answer the prompt for this 
value each time the .PRC file is selected. 

8.4.3 Pre-Write Time Per Word 

For some flash MCUs, you can adjust the pre-write time (used in erasing) specified in the .PRC file 
upward.  If this is possible, the FP4MST program prompts you to specify the additional amount of time.  
The default amount can be set in this section of OPTMST. Most devices do not require this parameter, 
but for those that do, a nominal value of 50 µs is suggested.  Select the Automatic check box if you 
want to avoid having to answer the prompt for this value each time the .PRC file is selected. 

8.5 File Selections 

 

This box shows the current setting in the .PRC file for programming, based on the last-selected .PRC 
file when FP4MST was run.  Selecting the Automatically load on startup check box results in this 
.PRC file being automatically loaded and the .PRC file selection step being bypassed. 

 50



 M-Station Baseboard 
 
 
 

 

8.6 OK, CANCEL, HELP Command Buttons 

• The OK command button closes the OPTMST program and writes the options for flash 
programming into the system registry. 

• The CANCEL command button closes the OPTMST program without making changes to 
the flash programming options in the system registry. 

• The HELP command button currently shows the version, date, and copyright information for 
the OPTMST program. 

 

9. FP4MST PROGRAM: M-STATION FLASH PROGRAMMING 

The FP4MST (Flash Programming For M-Station) application allows the M-Station to be used to flash 
program NEC Electronics 78K0 and 78K0S flash-programmable MCUs on micro-boards or target 
systems. Refer to section 3 for information about configuring the M-Station and micro-board for flash 
programming, and to section 8 about using OPTMST to set flash-programming options. 

9.1 Starting FP4MST, Selection of PRC file 

Start the FP4MST program by clicking its shortcut in the Start menu.  The FP4MST – Select Flash 
Device PRC File box lists a directory and its .PRC files.  If this is the first time you have run FP4MST, 
the box shows the directory where FP4MST was installed (default is C:\NECTools32\BIN) and there 
may not be any .PRC files to list. 
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Using the navigation buttons, browse to the C:\NECTools32\PRC directory, where you should find the 
.PRC file for the device you wish to program.  For example, for the µPD78F0338 on the EV0338 micro-
board, you would find the file “78F0338.PRC”.  If you do not have the .PRC file for the flash device you 
wish to program, contact NEC Electronics America. 

Select the appropriate .PRC file so that its name shows in the File Name box and click Open.  Clicking 
Cancel at this point closes the FP4MST program without accessing the M-Station. 

9.1.1 Comparison of .PRC Settings to M-Station VDD and VPP Configuration 

Once you select the .PRC file, the FP4MST program checks the VDD and VPP voltages specified there 
against those set by the OPTMST program. If the values don’t match, then you will receive an error 
message stating that the recorded setting is incorrect: 

 

1. Disconnect power from the M-Station. 

2. Recheck the appropriate settings for VDD and VPP and correct the JP3 and JP4 jumpers if 
necessary.  

3. Run OPTMST and set the JP3 and JP4 options to match the settings on the M-Station. 

4. You may also correct the configuration by clicking Yes in response to the error messages. 

The FP4MST program cannot check the actual settings of JP3 and JP4 on the M-Station to verify 
voltages.  It can only check the settings in the flash-programming options set by OPTMST.  It checks 
these settings before applying power to the VDD or VPP lines on the M-Station. 

9.1.2 FP4MST Initialization and Signature Check of Flash Device 

After loading and checking the .PRC file information, the FP4MST program applies power to the flash- 
programming interface VDD and VPP lines, and attempts to initialize the flash device for operation. 
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The FP4MST program then checks the silicon signature in the device to verify that it matches the 
signature specified in the .PRC file.  If the signatures match, then the program continues. 

9.2 FP4MST Flash Programming 

The FP4MST Flash Programming box is the command window for flash programming. 

 

9.2.1 Filename: File To Be Programmed or Verified 

 

This box shows the selected user program object file for flash programming.  The NEC Electronics 
78K0 or 78K0S software development tools generally produce this file after compiling, assembling, and 
linking the user program.  The user program file must be in .HEX format produced by the OBJ2HEX 
program, or in a binary .BIN file format saved by the ID debugger program. 

If FP4MST has been run before and a file selected for programming, the location and file name are 
remembered from the last time and shown again.  This information is stored in the system registry. 

To select a new file, click the Browse... button to open a file. 
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Use the navigation buttons to browse to the directory where the file you wish to program is located. 
Select the file, verify that it appears in the File name text box, and click Open to open the file and 
return to the command window. 

Clicking Cancel returns to the command window without changing the file selection. 

9.2.2 Device Selected and Change Device Type 

 

The Device box shows the name of the flash device as read from the silicon signature contained in the 
device.  This name matches that read from the .PRC file. 

Click Change Device Type to open a different .PRC file.  Normally you would only need to do this 
when changing to a different type of device, by first disconnecting one micro-board and connecting to 
another.  You should not need to use this button under normal circumstances. 

9.2.3 Status 

 

The Status window is normally blank when the FP4MST program is between operations.  During a 
flash-programming operation, the Status line displays various messages indicating the progress or 
status of the operation. 

 54



 M-Station Baseboard 
 
 
 

 

9.2.4 Flash Programming Command Buttons 

 

There are six flash-programming command buttons: 

• Program Sequence that executes erase, program, and verify commands in sequence 

• Ssig Chk that checks and shows the device’s silicon signature 

• Blank Chk that checks whether the device is Blank (erased) or Not Blank (programmed) 

• Write that programs the selected user program file into flash memory 

• Erase that erases the flash device’s memory 

• Verify that compares the user program file to the contents of the flash device’s memory 

9.2.4.1 Program Sequence 

Clicking the Program Sequence command button causes the program to 

1. Power up and initialize the device, and then check the signature against the .PRC file 

2. Run a Blank Check to determine whether the device needs to be erased before 
programming 

3. Executes an Erase operation if the device needs to be erased 

4. Performs a Write operation to program the device with the selected file 

5. Finishes with a Verify operation to check programming after the device is written 

During the Program Sequence, the Status window displays the operation being performed and its 
progress.  At the end of the sequence, the Status window should show “Written and verified”. 
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9.2.4.2 SSig Chk 

Clicking the Ssig Chk command button initializes the device, reads its silicon signature, and then 
displays that information in the Device box. 

9.2.4.3 Blank Chk 

Clicking the Blank Chk command button executes a blank check operation on the flash device, after 
first initializing and checking the silicon signature.  The Status window displays the progress of the 
operation. 

If the device is blank (erased), the Status window displays “Blank” at the end of the operation.  If the 
device is not blank, the Status window displays “Not Blank” and you receive this warning: 

 

Click OK and then execute an Erase operation (subsection 9.2.4.4). 

9.2.4.4 Erase 

Clicking the Erase command button erases the flash device, after first initializing it and checking its 
silicon signature. For some flash devices, a pre-write operation is done.   After a pre-write operation (if 
any), an erase operation is performed.  This may take several seconds.  After erasing, some flash 
devices require an area write-back operation.  The Status window shows the progress of erasing. 

 

After completion, the Status window displays “Erased”. 
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9.2.4.5 Write 

Clicking the Write command button programs the selected object file into the flash device.  If you use 
the Write command button instead of Program Sequence, you should use Blank Chk to insure that 
the device is erased, and Erase if necessary before writing.  Writing of a non-blank device may result 
in incorrect data in the flash memory and a non-functional device. 

The Write operation first initializes the device and then reads its silicon signature, after which data in 
the selected file is written to the device.  The Status window displays progress displaying the number 
of bytes written with the total: 

 

The Write operation does not write the entire memory space, only the bytes from 0000 through the end 
of the block containing the highest byte of the user program. 

• For 78K0 devices, a block is 256 bytes.  If a 78K0 program starts at 0000H and ends at 
1234H, then the device is written from 0000–12FFH. The remainder is left in its erased 
state. 

• For 78K0S devices, a block is 128 bytes.  If a 78K0S program starts at 0000H and ends at 
1234H, then the device is written from 0000–127FH.  The remainder is left in its erased 
state. 

After writing, the program performs an internal verify operation to confirm that the data was written 
correctly. Upon completion, the Status window displays “Written and verified”. 

9.2.4.6 Verify 

Clicking the Verify command button runs a verify operation that checks the contents of the selected file 
against the contents of the flash device. For security of user programs, it is not possible to read out the 
contents of the flash device’s memory.  Instead, a verify operation consists of sending an entire image 
of what the flash memory should hold to the device, which compares the data against the actual 
contents of memory.  After the entire memory image is sent, the device will report whether the data 
verified or not. 

When the Verify button is clicked, it first initializes the flash device, and reads the silicon signature.  
Then a memory image is built of the user program by reading the specified program file, plus erased 
data values for all locations not specified in the program file. 
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The memory image is sent to the flash device, and the Status window reports the progress of the 
operation by displaying the current number of block sent and the total number of blocks.  For a 78K0 
device, a block is 256 bytes; for a 78K0S device, a block is 128 bytes. 

 

After the entire memory image is sent, if the data sent compares exactly with the data in the flash 
device, the Status window displays “Verified”. If the data sent does not compare exactly with the 
device, the Status window displays “Verify failed” and you receive this error message. 

 

9.3 Configure Command Button 

Clicking the Configure command button in the FP4MST Flash Programming box opens a 
Configuration box that is the same as the one for the OPTMST program described in section 8. 
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When you click OK to close the FP4MST Flash Configuration box, the flash device is initialized and 
its silicon signature read.  If you change parameters that cause initialization to fail, such as changing 
the communication port without changing necessary jumpers, you will receive a message and have the 
opportunity to revise the configuration. 

When changing the configuration from inside the FP4MST program, you should only change the 
communication rate (to try higher SIO or UART communication rates) or set the .PRC file to be 
automatically loaded. 

9.4 Help Command Button 

Clicking the Help command button displays the program name, version, date and copyright of the 
FP4MST program. 

 

9.5 Close Command Button 

Clicking the Close button exits the FP4MST program, reapplies VDD power to the flash device, and 
releases the RESET line, allowing the user program to run on the device. 
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10. MSTTERM PROGRAM: M-STATION TERMINAL EMULATION 

The MSTTERM program uses the USB interface on the computer and M-Station to communicate with 
a 78K0 or 78K0S MCU on a micro-board or in a target system. The USB interface on the M-Station 
provides a UART device that can be connected to the 78K0 or 78K0S MCU for flash-programming 
operations through a UART port.  Typically, the same physical connections used for flash programming 
also can be used for UART communication. 

The MSTTERM program allows characters typed on the computer keyboard to be sent through the 
USB channel to the USB interface device on the M-Station, and then transmitted from the UART of the 
USB interface device to a connected UART of the 78K0 or 78K0S MCU.  Characters sent from the 
UART of the 78K0 or 78K0S MCU are received by the UART on the USB interface device, read 
through the USB channel to the computer, and then displayed in the window of the MSTTERM terminal 
program. 

The MSTTERM program provides the following features: 

• Full- or half-duplex communication through the M-Station to the micro-board 

• Baud rates of 9600, 19200, 38400, and 76800 

• Selection of fixed-point fonts and characters sizes 

• Saving and restoring of parameters to and from .MST files 

• Copy and paste operations to transfer data to or from the micro-board 

• Optional capture of communication to text files, with pause and resume functions 

• Sending of a text file to the micro-board 

The MSTTERM program uses Microsoft .NET Framework version 1.1, and requires this software to be 
installed on the computer.  A file to install the Microsoft .NET Framework 1.1 is supplied on the CD-
ROM bundled with the M-Station baseboard, in the \Software\DotNET directory.  If your computer has 
access to the Internet, the Microsoft .NET Framework also can be installed from  

http://msdn.microsoft.com/netframework/howtoget/default.aspx

or by using the Windows Update feature of your Windows operating system. 
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10.1 Starting and Exiting the MSTTERM Program 

Before using the MSTTERM program, make sure that JP8 and JP9 on the M-Station are set for UART 
communication: TXDSO-UTXD on JP8 and RXDSI-URXD on JP9. Click the MSTTERM program 
shortcut in the Start menu to initialize the program and open the MST Terminal window, which displays 
any characters received by the M-Station USB interface.  There is no power cycling or reset of the 
micro-board upon starting, and the default rate for operation is 9600 baud. 

When you exit MSTTERM, the program resets the micro-board by turning VDD power off, restoring it, 
and then releasing the RESET line.  The user program then executes, the same as when you exit the 
FP4MST program. 

10.2 MST Terminal Window 

The MST Terminal window below shows example text to demonstrate communication with a possible 
user program in a micro-board or target system.  The actual interaction would depend on the program 
written for such a board. The window consists of a menu bar at the top, a status bar at the bottom, and 
a scrolling text window in between.  The window can be resized according to your preference. 
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The main portion of the window is the display area for characters received from the micro-board.  A 
received CR character (carriage return, 0x0D) results in a new starting line; received LF characters 
(line feed, 0x0A) are ignored.   Characters typed on the keyboard are sent to the micro-board through 
the M-Station USB interface, but are not displayed unless echoed by the micro-board, or unless you 
select Local Echo in the Properties box. 

As the micro-board receives new characters and lines through the M-Station, they are added to the 
bottom of the previously received lines.  When the terminal window is filled, lines are added at the 
bottom and previous lines are scrolled off the top. Lines scrolled off the top may be viewed again using 
the scroll arrows to the right of the window.  The window holds up to approximately 32,000 characters 
in a buffer that may be scrolled to show recent interactions.  After the buffer has reached its maximum, 
the oldest lines are dropped.  If you wish to keep a long record of interactions, click Transfer → 
Capture Text File to save the interactions to a text file. 

10.2.1 MST Terminal Menu 

 

The MST Terminal menu bar contains the File, Edit, Transfer, and Help menus.  Clicking a main 
menu name displays its associated commands.  You can also view a menu by pressing the ALT key 
and typing the first letter of the menu name you want to view.  For example, pressing ALT+F displays 
the File menu. Clicking a command name opens a dialog box.  For example, pressing ALT+F displays 
the File menu; pressing P opens the Properties box. 

When there are multiple commands with the same first letter (for example, Save and Save As… on the 
File menu), typing the first letter highlights the first such item but does not activate it.  Repeatedly 
entering the first letter cycles through command names that begin with that letter.  Select the command 
you want and press ENTER to activate it.  Many commands can be directly activated through shortcut 
keys. 

Table 1 rtcut Keys 5. Sho
Shortcut Key Submenu item 

CTRL+A Edit → Select All 

CTRL+C Edit → Copy 

CTRL+O File → Open (.MST file) 

CTRL+S File → Save (.MST file) 

CTRL+V Edit → Paste 

All other typed keys, including control characters, are sent to the M-Station.  If you want to send a 
shortcut character to the M-Station, click Transfer → Send binary key. 
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10.2.2 MSTTERM Status Bar 

 

The status bar at the bottom of the MST Terminal window shows the status of the MSTTERM program, 
displaying “Capturing” when the capture to a text file is active or “Capture paused” when the capture is 
active but paused. The status bar also shows the baud rate currently selected, a count of transmitted 
lines, and a count of received lines. 

10.3 File Menu 

 

The File menu contains the Open, Save, Save As…, Properties and Exit commands. 

• Clicking File → Open… (or pressing CTRL+O) loads a previously saved .MST configuration 
file containing MSTTERM properties.  The dialog box enables you to browse through and 
select from a list of available .MST files.  Selecting a file and clicking Open loads that file 
and sets the baud rate, local echo, line feeds with line ends, and filtering of characters to 7-
bit ASCII format according to what is specified in that file. 

• Clicking File → Save (CTRL+S) saves the current properties to an .MST configuration file.  
If an .MST file has not been selected by previous File → Open or File → Save As 
command sequences, then you are prompted to select a filename from the list of current 
.MST files. 

Entering a new file name creates a new file with that name and the .MST extension, and 
saves the current properties in that file.  Selecting a current .MST file overwrites the 
properties in that file with the current properties. 

If you have already selected an .MST configuration file by clicking File → Open or File → 
Save As…, then clicking File → Save saves the current properties to that file without 
prompting for a file name. 

• Clicking File → Save As… prompts for a new filename in which to save the current 
properties.  Entering a new file name will create that file with the .MST extension.  Selecting 
a currently existing .MST file overwrites that file. 

• Clicking File → Properties open the Properties box.  See subsection 10.4 for more 
information. 

• Clicking File → Exit closes the MSTTERM program, turns power off and then on to the M-
Station, and then releases the RESET to reset and rerun the user program.  Pressing 
ALT+F4 at any point also exits the MSTTERM program. 
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10.4 Properties Box 

 

The Properties box, opened when you click File → Properties, allows you to set various options for 
the MSTTERM program: local echo, whether line feeds should be sent with line ends, the baud rate for 
operation, and whether received characters should be filtered to 7-bit ASCII format. 

10.4.1 Local Echo 

Selecting the Local echo check box enables any character entered from the keyboard to be echoed to 
the screen and sent to the micro-board.  If the micro-board program also echoes characters, this will 
result in the typed key showing up two times on the screen. When you clear the check box, typed 
characters are sent to the micro-board through the USB interface, but are not echoed to the screen 
(unless echoed by the micro-board program).  

10.4.2 Send Line Ends with Line Feeds 

Selecting the Send line ends with line feeds check box sends the CRLF (0x0D, 0x0A) combination 
when you press the ENTER key.  When you clear the check box, pressing ENTER sends only a CR 
character. 

10.4.3 Bits Per Second 

• The Bits per second box shows the currently selected baud rate.  Clicking the Bits per 
second arrow enables to you select a different rate for the UART on the M-Station USB 
interface.  All transmitted characters after this are sent at the new baud rate, and any 
received characters are received at the new baud rate. 

This does not change the baud rate of the micro-board’s UART.  Setting a baud rate for the 
M-Station USB interface that does not match the baud rate of the micro-board result in 
incorrect communication and, most likely, nonsense characters on the screen. 
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• Selecting the Filter Receive – 7-bit check box masks received characters to 7 bits.  If the 
character is a non-printing ASCII character after masking (except for CR or LF handled 
above), it is displayed as “#”.   If you clear the check box, all received characters are 
displayed on the screen as is, except for CR and LF characters. CR starts a new line 
(handled as CRLF) and LF is ignored. 

• The Current Font box displays the currently selected font.  Clicking it opens a dialog box 
showing available fixed-point fonts and allows you to set the attributes (regular, bold, italic, 
bold italic) and point size of the font selected.  Selecting a new font or changing the 
attributes or size of the current one converts the entire contents of the window to the new 
settings. 

10.5 Edit Menu 

 

The Edit menu contains the Copy, Paste, Clear Screen, and Select All commands. 

• Clicking Edit → Copy (CTRL+C) copies currently selected and highlighted text to the 
Windows clipboard.  Position your cursor at the starting point and then click and drag it to 
select characters or lines you want to copy.  You may also use the arrows to move the 
cursor as well.  Text copied to the clipboard may be pasted into other Windows applications 
for documentation purposes. 

• Clicking Edit → Paste (CTRL+V) takes any characters in the Windows clipboard and 
transmits them to the micro-board through the USB interface.  This operation is the same as 
typing the characters on the keyboard; characters will not be echoed to the screen unless 
“local echo” is on, or unless echoed by the micro-board. 

• Clicking Edit → Clear Screen clears the current terminal window screen and history buffer.  
It does not affect characters that have been received to a capture file. 

• Clicking Edit → Select All (CTRL+A) selects all of the contents of the current buffer of 
received characters, including characters that have scrolled off the screen, but not 
characters that have been dropped from the history buffer after it reaches its maximum of 
32K characters.  Clicking Edit → Select All followed by Edit → Copy results in the entire 
history buffer being copied to the clipboard.  
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10.6 Transfer Menu 

The Transfer menu contains the Capture Text…, Send Text File…, and Send binary key 
commands. 

 

 

10.6.1 Capturing MSTTERM Interactions to a Text File 

1. The Capture Text… submenu contains the Select File, Pause, Resume, and Stop 
Capture commands.  Initially, only the Select File command is active and the others are 
unavailable.  When you first initialize the MSTTERM program, text is not captured to a file. 

 

2. Clicking Transfer → Capture Text → Select File opens the Select a text file to capture to 
box, allowing you to create a new text file or select a current one. 

 

3. The File name and Files of type boxes display the file name “capture.txt”.  Enter a new 
name or select an existing one and then click Open.  If you enter a new file name, the 
program creates that file with empty contents until it receives some text.  If you select an 
existing file, the text captured to that file is appended to the current contents. 

When the operation begins, the Status bar displays “Capturing”, and the Pause and Stop 
Capture commands become available; the Select File and Resume commands become 
unavailable. During the capture, all characters received are saved to the capture file, and all 
locally echoed transmitted characters are saved as well.  If local echo is off, then transmitted 
characters are not saved to the capture file.  If filtering is on, then the filtered and displayed 
characters are saved to the text file. 
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4. Clicking Transfer → Capture Text → Pause while capturing to a text file pauses the 

operation.  Received characters and locally echoed sent characters are not saved to the text 
file while capture is paused, the Resume and Stop Capture commands are available, and 
the Select File and Pause commands are unavailable. 

5. Clicking Transfer → Capture Text → Resume while the capture is paused resumes 
capturing text to the current file. The Pause and Stop Capture commands are available, 
and the Select File and Resume commands are unavailable. 

6. Clicking Transfer → Capture Text → Stop Capture while actively capturing, or while 
capturing is paused, will stop capture to the active file and close it.  At this point, the menu 
items return to the default state, with Select File enabled and all other items disabled. 

7. If you exit the MSTTERM program while the capture is active or paused, the text file closes. 

10.6.2 Sending Text File 

Clicking Transfer → Send Text File… opens a dialog box where you can select a .TXT file and click 
Open to transmit the contents of the file to the micro-board through the M-Station USB Interface.  
Clicking Cancel closes the dialog without sending the file. Characters in the text file are sent as if typed 
on the keyboard.  They are not echoed to the screen, unless echoed by the micro-board, or unless 
local echo is on. 

10.6.3 Sending a Binary Key Value 

Clicking Transfer→ Send binary key opens the bincode box. To transmit a specific binary value, 
enter its decimal value and click OK.  For example, entering a value of 10 sends a linefeed character 
(hexadecimal value 0x0A). 

 
10.7 Help Menu 

The Help menu displays the name, version, date, and copyright information for the MSTTERM 
program. 
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11. ERROR MESSAGES AND POSSIBLE CAUSES 

11.1 Possible FP4MST Error Messages and Causes 

Various conditions can prevent the FP4MST program from starting normally. 

• No USB connection.  If you attempt to start the FP4MST program without connecting the 
M-Station to the computer through a USB cable, you receive the following error message. 

 

Click OK. Check your hardware connections and then click Yes in response to the following: 

 

• Incorrect Settings for VDD or VPP. If the VDD or VPP voltage settings recorded by OPTMST 
do not match the required values in the .PRC file, the FP4MST program does not try to turn 
power on to the flash device, and instead displays the following message: 
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This could be the result of incorrectly setting the expected VDD and VPP voltages with 
OPTMST, or could be the result of selecting the wrong .PRC file.  Before proceeding, 
remove power from the M-Station, and recheck the voltages required by the flash device, 
the settings of JP3 and JP4 on the M-Station, the settings recorded for JP3 and JP4 in 
OPTMST, and that the proper .PRC file is being selected. 

• No power to M-Station. If the M-Station is connected to the PC, but there is no power on 
the VDE signal (detecting power on the micro-board or target), the following message will be 
shown: 

 

If the M-Station is supplying power, make sure the M-Station power supply is connected and 
that JP2 is inserted for the REG or BAT options.  If the VDE signal is not supplied by the 
micro-board or target system, insert JP1 to power VDE from the M-Station VDD power. 

If the target system is supplying power to VDD, make sure JP2 is not connected.  However, 
it is necessary to have the M-Station power supply connected to provide VPP power.  Make 
sure the target system is powered before starting FP4MST.  If the target system does not 
supply the VDE signal on the flash programming interface, insert JP1 to power VDE from the 
target system VDD power. 

• USB cable disconnected during FP4MST operation: When the USB cable is 
disconnected from the M-Station or PC, the M-Station USB driver is unloaded from memory, 
and programs can no longer communicate with the M-Station.  This may cause an error 
message from the FP4MST program. 

• Device Signature and .PRC file do not match: If the M-Station can initialize the flash 
device and read the silicon signature, but the signature in the device does not match the 
device, the following message is shown: 

 

This probably results from selecting the wrong .PRC file for the device.  Click Yes to select a 
different .PRC file. 
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• Device name in signature and .PRC file do not match. If the M-Station can initialize the 

flash device, and read the signature, and the signature matches the .PRC file except for the 
device name, the following message is shown: 

 

In this case, you may have selected a .PRC file for a device that is closely related to the one 
you want to use.  You should probably select “No” to not use this .PRC file, and then select 
“Yes” to select a different .PRC file. 

• Cannot initialize flash device: If the M-Station can supply power, but the target device 
does not initialize, you will see an error message such as this: 

 

There are several possible problems: 

⎯ Jumpers selecting flash programming interface incorrect on M-Station (JP8 and JP9) 
⎯ Jumpers selecting flash programming interface incorrect on micro-board 
⎯ Option for flash clock set incorrectly in OPTMST 
⎯ Frequency for clock set incorrectly in OPTMST 
⎯ Option for Flash Programming communication channel set incorrectly in OPTMST 
⎯ If using an FA-type adapter to program a loose device: 

� No device inserted 
� No clock driven on M-Station J7 
� Clock selection not set to “Host” in OPTMST 

Please recheck these items, and attempt to initialize the device again.  For NEC Electronics 
micro-boards, please try the configuration suggested in the appropriate appendix. 
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11.2 Possible MSTTERM Error Messages and Causes 

Various conditions can prevent the MSTTERM program from starting normally or functioning as 
expected. 

• No USB connection: If you attempt to start the MSTTERM program without connecting the 
M-Station to the computer through a USB cable, you receive the following error message. 

 

followed by: 

 

and 

 

Click OK to close the MSTTERM program. 

 71



M-Station Baseboard  
 

 

 

 

• No power to M-Station: If the M-Station is connected to the computer, but there is no 
power on the VDD signal to the micro-board, or on the VDE signal powering the interface 
logic, no characters are received or sent.  Check that the M-Station and the micro-board 
have power, and that JP1 and JP2 are set appropriately for the micro-board. 

• M-Station jumpers not set for UART communication: To use the UART on the M-Station 
USB interface for communication, JP8 must be set to connect pins 1-2 (TXDSO to UTXD) 
and JP9 must be set to connect pins 1–2 (RXDSI to URXD). 

• Micro-board jumpers not set for UART communication: Check that the jumpers on the 
micro-board are set in a configuration that connects UART pins to the TXDSO and RXDSI 
lines of the flash programming interface.  Please see the User’s Manual for the appropriate 
board. 

• No program in micro-board flash device: If the flash device on the micro-board has been 
erased, there will be no communication. 

• Program not initializing or using UART correctly: The flash device must have a program 
that properly initializes and operates the UART port.  Most micro-boards are shipped with a 
functioning monitor or test program that can communicate with the M-Station in the board’s 
default configuration; other demonstration programs are available for the micro-boards on 
the M-Station CD-ROM.  Check operation with one of these programs in the flash memory, 
or examine the code for UART operation to base your own program on. 

• USB cable disconnected during MSTTERM operation: When the USB cable is 
disconnected from the M-Station or computer, the M-Station USB driver is unloaded from 
memory, and programs can no longer communicate with the M-Station.  This may cause an 
error message from the MSTTERM program. 
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 The information in this document is current as of June 2004.  The information is subject to change without notice. For 

actual design-in, refer to the latest publications of NEC Electronics data sheets or data books, etc., for the most up-to-date 

specifications of NEC Electronics products. Not all products and/or types are available in every country. Please check with an NEC 

sales representative for availability and additional information. 
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 The quality grade of NEC Electronics products is “Standard” unless otherwise expressly specified in NEC Electronics data 
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subsidiaries. 
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