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majority-owned subsidiaries.
"NEC Electronics products" means any product developed or manufactured by or for NEC Electronics (as 
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Computers, office equipment, communications equipment, test and measurement equipment, audio
and visual equipment, home electronic appliances, machine tools, personal electronic equipment
and industrial robots.
Transportation equipment (automobiles, trains, ships, etc.), traffic control systems, anti-disaster
systems, anti-crime systems, safety equipment and medical equipment (not specifically designed
for life support).
Aircraft, aerospace equipment, submersible repeaters, nuclear reactor control systems, life
support systems and medical equipment for life support, etc.

"Standard":

"Special":

"Specific":



User’s Manual  U16632EJ2V0UM 5

Regional Information

•  Device availability

•  Ordering information

•  Product release schedule

•  Availability of related technical literature

•  Development environment specifications (for example, specifications for third-party tools and
   components, host computers, power plugs, AC supply voltages, and so forth)

•  Network requirements

In addition, trademarks, registered trademarks, export restrictions, and other legal issues may also vary
from country to country.

[GLOBAL SUPPORT]
         http://www.necel.com/en/support/support.html

NEC Electronics America, Inc. (U.S.)
Santa Clara, California
Tel: 408-588-6000
       800-366-9782

NEC Electronics Hong Kong Ltd.
Hong Kong
Tel: 2886-9318

NEC Electronics Hong Kong Ltd.
Seoul Branch
Seoul, Korea
Tel: 02-558-3737

NEC Electronics Shanghai, Ltd.
Shanghai, P.R. China
Tel: 021-6841-1138

NEC Electronics Taiwan Ltd.
Taipei, Taiwan
Tel: 02-2719-2377

NEC Electronics Singapore Pte. Ltd.
Novena Square, Singapore
Tel: 6253-8311

J03.4

NEC Electronics (Europe) GmbH
Duesseldorf, Germany
Tel:  0211-65 03 01

• Sucursal en España
Madrid, Spain
Tel:  091-504 27 87

Vélizy-Villacoublay, France
Tel:   01-30-67 58 00

• Succursale Française

• Filiale Italiana
Milano, Italy
Tel:  02-66 75 41

• Branch The Netherlands
Eindhoven, The Netherlands
Tel:   040-244 58 45

• Tyskland Filial
Taeby, Sweden
Tel:  08-63 80 820

• United Kingdom Branch
Milton Keynes, UK
Tel:  01908-691-133

Some information contained in this document may vary from country to country.  Before using any NEC 
Electronics product in your application, pIease contact the NEC Electronics office in your country to 
obtain a list of authorized representatives and distributors.  They will verify: 



User’s Manual  U16632EJ2V0UM6

PREFACE

Target Readers This manual is intended for user engineers who design and develop application systems
of the 78K4 Series.

Purpose This manual is intended for users to understand the functions of the ID78K4-NS in the
organization below.

Organization This manual consists of the following chapters:

• OVERVIEW
• STARTING AND TERMINATING
• ASSOCIATION WITH PM plus
• FUNCTIONS OF ID78K4-NS
• OPERATION
• WINDOW REFERENCE
• COMMAND REFERENCE

How to Use This Manual It is assumed that the readers of this manual have general knowledge of electrical
engineering, logic circuits, microcontrollers, C language, and assemblers.

To understand the functions of the 78K4 Series
→ Refer to Hardware User's Manual for each product.

To understand the instruction functions of the 78K4 Series
→ Refer to 78K/4 Series Instructions User's Manual (U10905E).

Conventions Data significance: Higher digits on the left and lower digits on the right
Note: Footnote for item marked with Note in the text
Caution: Information requiring particular attention
Remark: Supplementary information
Numerical representation: Binary … XXXX or XXXXB

Decimal ... XXXX
Hexadecimal … 0xXXXX

Prefix indicating the power of 2 (address space, memory capacity):
K (Kilo):  210 = 1024
M (Mega):  220 = 10242

G (Giga):  230 = 10243
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Related Documents Refer to the documents listed below when using this manual.
The related documents indicated in this publication may include preliminary versions.
However, preliminary versions are not marked as such.

Documents related to development tools (User's Manuals)

Document Name Document No.

IE-78K4-NS In-Circuit Emulator U13356E

Operation U16708E

Assembly Language U15255E

RA78K4 Assembler Package

Structured Assembler Preprocessor U11743E

Operation U16707ECC78K4 C Compiler Package

Language U15556E

ID78K4-NS Ver. 2.52 Integrated Debugger Operation This manual

SM78K Series Ver.2.52 System Simulator Operation To be prepared

Fundamental U10603ERX78K4 Real-Time OS

Installation U10604E

PM plus Ver.5.10 U16569E
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CHAPTER 1  OVERVIEW

CHAPTER 1  OVERVIEW

1. 1    Overview

The Integrated debugger ID78K4-NS for the 78K4 Series (hereafter referred to as the ID78K4-NS) is a

software tool developed for NEC Electronics's 78K4 Series of 8-bit microcontrollers for embedded control.

This software tool is intended to enable efficient debugging of user programs.  

The ID78K4-NS runs on a host machine that uses WindowsTM as the operating system and employs an

easy-to-understand, easy-to-use GUI (Graphical User Interface).  

The commands that are often used are displayed as buttons, so that they can be executed with a single

mouse click. In this way, an environment with excellent operability can be provided.  

1. 2    Features

The ID78K4-NS has the following features.  

(1) Source debugging

A C source program and source program in assembly language can be debugged.  

(2) Using functions of in-circuit emulator

By using the detailed event setting function of an in-circuit emulator, break events can be set and the 

user program can be traced.

(3) Monitor function (automatic display updating function when execution is stopped)

If execution of the user program is stopped, the values of the window displayed on the screen are 

automatically updated.  

(4) Saving/restoring debugging environment

The debugging environment including information on setting of breakpoints and events, downloading 

files, and display status and position of windows can be saved to a file (project file).  

By loading this project file, the debugging environment can be restored.  

(5) Function expansion by TIP

By combining with a task debugger (RD) and system performance analyzer (AZ) that support TIP (Tool 

Interface Protocol), the efficiency of user program debugging using a real-time OS (RX) can be 

drastically improved.

(6) Batch execution by command and creation of custom window

A console window that allows batch processing on the command line and creation of the user's own 

custom window has been added.  
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1. 3    System Configuration

The supplies a comfortable debugging environment for the user program and target system developed for

the 78K4 Series, by connecting the host machine and an in-circuit emulator with an interface board.

1. 3. 1    Example of system configuration

Figure 1-1 shows an example of the system configuration of the ID78K4-NS.  

Figure 1-1　Example of ID78K4-NS System Configuration

1. 4     Operating Environment

The ID78K4-NS has the following hardware and software requirements:  

1. 4. 1    Hardware environment

(1)  Host machine

•  IBM PC/AT TM -compatible machine

(2) In-circuit emulator (any of the following)

•  IE-78K4-NS

(3) Interface board (any of the following)

•  IE-70000-PCI-IF-A (for PCI bus)
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•  IE-70000-CD-IF-A (for PCMCIA card slot)

•  IE-70000-PC-IF-C (for ISA bus)

1. 4. 2     Software environment

(1) Operating system (any of the following)

Windows98, Windows2000, Windows NTTM4.0, Windows Me, Windows XP Home Edition, Windows 

XP Professional  

Caution Regardless of which of the OSs above is used, we recommend that the latest Service

Pack is installed.  

(2) Device file

The device file of the target device to be used.  

(3) Device driver

Device driver for interface board (supplied with the product) 

Remark The driver can also be downloaded from the Online Delivery Service (ODS).

1. 5    Notes on Source-Level Debugging

To perform source-level debugging, specify an option (-g option) to generate debug information when the

source file is compiled. (The -g option is specified by default.)  

If this option is not specified, the source file cannot be debugged at the source level.
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CHAPTER 2  STARTING AND TERMINATING

This chapter explains the procedure of starting and terminating the ID78K4-NS.  

2. 1     Starting

Start the ID78K4-NS as follows: 

1 Turn on the power to the in-circuit emulator, and then turn on the power to the target system.  

2 Select [Start] -> [Program] -> [NEC Tools32] -> [ID78K4-NS] from the Windows start menu to start

the ID78K4-NS.  The Configuration dialog box will be opened.  

3 Set the items related to the operating environment of the ID78K4-NS in the Configuration dialog

box.  After setting each item, click the <OK> button in the dialog box.  

Figure 2-1　Configuration Dialog Box

4 The Main window will be opened and the ID78K4-NS can be operated.  Mainly use this window for

debugging.  
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Figure 2-2　Main Window

2. 2    Terminating

Terminate the ID78K4-NS as follows:  

1 Select the [File] menu -> [Exit] on the Main window.  The following Exit Debugger dialog box will be

opened:   

Figure 2-3　Exit Debugger Dialog Box

If the above operation is performed while the user program is being executed, the dialog box shown in 

Figure 2-4 is opened.  

In this case, clicking the <Yes> button opens the Exit Debugger dialog box.  

Figure 2-4　Message Box for Confirmation of Stopping Execution

2 To save the current debugging environment to a project file, click the <Yes> button.  

If the <No> button is clicked, all the windows are closed and the ID78K4-NS is terminated.  
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CHAPTER 3  ASSOCIATION WITH PM plus

This chapter explains the procedure and points to be noted when a function to associate the PM plus is

used.  

The ID78K4-NS can automatically perform a series of operations in development processes, such as

creating source files -> compiling -> debugging -> correcting source files, in association with the PM

plus.  

The operation explained in this chapter requires a PM plus(V5.00 or later).  

 Caution If a load module file is created by using the Windows command prompt, the function to

associate the ID78K4-NS with the PM plus cannot be used.  

3. 1    Setting Build Mode

To debug the load module file created by the PM plus on the ID78K4-NS at the source level, build to

output symbol information for debugging must be performed to create a load module file.  This setting can

be performed by selecting [Debug Build] on the PM plus.  

3. 2    Registering Debugger to PM plus Project

The debugger to be used or the load module files to be downloaded can be specified for each project in

the PM plus.  

Select a debugger using the following procedure:

3. 2. 1    Selecting debugger

The procedure for selecting the debugger is as follows: 

Creating a new workspace

1 Select [File] menu -> [New Workspace...] on the PM plus.  

-> This opens the dialog box to create a new workspace using the wizard format.  

2 Creating the necessary settings for the workspace with the wizard, the [New Workspace - Step 7/8

(Select Debugger)] dialog box will be opened.  Specify [ID78K4-NS 78K/4 Integrated Debugger] in

this dialog box. 

-> For details of the setting, refer to the PM plus online help or user's manual.  

Using an existing workspace

1 Select [Tool] menu -> [Debugger Settings...] on the PM plus.  

-> The Debugger Settings dialog box will be opened.  

2 Specify [ID78K4-NS 78K/4 Integrated Debugger] and click the <OK> button in this dialog box.  

The ID78K4-NS is registered as the debugger of the active project.  

The ID78K4-NS icon is displayed on the toolbar of the PM plus.  
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3. 3    To Start ID78K4-NS from PM plus

The ID78K4-NS can be started from the PM plus as follows:

• Click the ID78K4-NS starting button on the toolbar of the PM plus.

• Select the [Build] menu -> [Debug] on the PM plus.  

• Select the [Build] menu -> [Build and Debug] on the PM plus.  

• Select the [Build] menu -> [Rebuild and Debug] on the PM plus.  

If the debugging environment of the ID78K4-NS is saved to a project file currently being used by the PM

plus, it will be started in the debugging environment saved in the project file.  

If the debugging environment of the ID78K4-NS is not saved to a project file being used by the PM plus,

the Configuration dialog box is opened.  At this time, the device type (Chip name) cannot be changed.  

3. 3. 1    Restoring debugging environment

The previous debugging environment can be restored by the following procedure when the ID78K4-NS is

started from the PM plus:  

1 Create a new workspace (project file : e.g., sample.prj) on the PM plus.  

Caution In the ID78K4-NS and PM plus, the environment information is saved to a project file

and referenced.  The extension of the project file that can be used by the ID78K4-NS

and PM plus is prj.  For the information that is saved or restored by the project file, refer

to the online help or the user's manual of each product.

2 Start the ID78K4-NS from the PM plus.  Because a new project file is created, set items other than

the device type (Chip name) in the Configuration dialog box in the same manner as when only the

ID78K4-NS is started.  

3 Download the load module file to be debugged with the Download dialog box of the ID78K4-NS.  

4 Debug the load module file on the ID78K4-NS.

5 Click the <Yes> button on the Exit Debugger dialog box when the ID78K4-NS is terminated.  

-> The debugging environment is saved to the project file (sample.prj) for the PM plus when the

ID78K4-NS is terminated. (The debug environment can also be saved to the sample.prj file by

overwriting the project file).

6 When the ID78K4-NS is next started up after the sample.prj file is read by PM plus, the debug

environment at the point when the project file was saved is automatically restored.  

3. 4    Auto Load

If a bug is found while the load module file is being debugged by the ID78K4-NS, correct the source file

using the following procedure.  Compiling and re-downloading the file can be automatically executed (Refer

to "Auto load by correcting source code (p.19)").  

The load module is downloaded again to the ID78K4-NS by compiling and linking the file on the PM plus
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with the activated ID78K4-NS (refer to "Auto load by starting debugger (p.19)").  

3. 4. 1    Auto load by correcting source code

Correct the source file for auto load as follows:  

1  Open the source file to be corrected in the Source window.  Select [File] menu -> [Open] and

specify the file to be corrected on the ID78K4-NS (if the file is already open in the Source window,

that window is displayed in the forefront).  

-> The specified file will be opened in the Source window.  

2 Select [Edit] menu -> [Correct Source] on the ID78K4-NS.  

-> An editor will be opened and the specified source file will be read.  

3 Correct the source file on the editor.

4 Terminate the editor.

 Caution The CPU reset is not performed when the load module file is automatically downloaded.

The debug window that was opened when the editor was called, and each event setting

will be restored.  If the previously used line or symbol has been deleted as a result of

correcting the source file, the following happens:

- A software break point may be deleted.

- A variable that was displayed is dimmed.

- The event mark of an event condition is displayed in yellow.

5 Select [Build] menu -> [Build and Debug], or [Build] -> [Rebuild and Debug] on the PM plus.  

3. 4. 2     Auto load by starting debugger

If the following operation is performed on the PM plus with the ID78K4-NS started, the load module will be

automatically downloaded to the ID78K4-NS.

• Selecting the [Build] menu -> [Build and Debug] on the PM plus.  

• Selecting the [Build] menu -> [Rebuild and Debug] on the PM plus.  

When downloading is completed, the CPU is automatically reset. 
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CHAPTER 4  FUNCTIONS OF ID78K4-NS 

This chapter explains the basic debugging functions of the ID78K4-NS.  

•  Mapping function

•  Setting Debugging Environment

•  Program Execution Function

•  Event function

•  Break function

•  Trace function

•  Register Manipulation Function

•  Memory Manipulation Function

•  Watch Function

•  Time Measurement Function

•  Load/Save Function

•  Real-Time internal RAM Sampling Function

4. 1    Mapping function

The following types of mapping functions that can be set in the Configuration dialog box are available: 

(1) Internal ROM

A memory area specified as the internal ROM is equivalent to the on-chip internal ROM of the target 

device.

The target device accesses the memory in the in-circuit emulator.on-chip internal ROM

If the target device writes data to this memory area, a write protect break occurs.

4. 2    Setting Debugging Environment

Set a debugging environment with the Configuration dialog box that is opened when the debugger is

started, or the Extended Option dialog box or Debugger Option dialog box.  

By creating a file (project file) to which the current debugging environment is saved during debugging,

and loading this file, the debugging environment when the project file is saved can be restored.  

To manipulate the project file, use the Project File Save dialog box and Project File Load dialog box.  

After the project file has been loaded, the size and position of the displayed window are returned to the

previous size and status (refer to "Contents Saved to Project File (p.78)").  

To load the project file when starting up the debugger, press the <Project...> button in the Configuration

dialog box.  It can also be specified that the project file is automatically loaded each time the debugger is

started up (refer to "To automatically load a project file").  
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4. 3    Program Execution Function

The program execution function is used to start execution of the user program by the CPU and operation

of the tracer.  

These functions can be executed by selecting the [Run] menu or the corresponding function button, and

the execution formats are classified into real-time execution and non-real-time execution. 

4. 3. 1    Real-time execution function

The following real-time execution functions are available:

• [Go]

• [Ignore break points and Go]

• [Start From Here] (Start function)

• [Go & Go]

• [Come Here] (Come function)

• [Restart]

(1) [Go]

The user program is executed starting from the address indicated by the current PC register and is 

stopped if a set break event condition is satisfied.  Each analyzer prepares for operation as soon as 

execution of the user program is started, and is executed or stopped by a condition set as an event 

condition (break event condition or trace event condition).  

(2) [Ignore break points and Go]

This command executes the user program starting from the address indicated by the current PC 

register.  Execution of the user program continues, ignoring set breakpoints.  

(3) [Start From Here] (Start function)

This command executes the user program starting from the specified address. Execution of the user 

program is stopped when a set break event condition is satisfied.  

(4) [Go & Go]

This command executes the user program starting from the address indicated by the current PC 

register. When the set breakpoint conditions are realized, execution of the user program is paused, 

and after the contents of the various windows have been updated, execution of the user program is 

resumed from the address where execution was paused. This operation is repeated until the user 

executes [Stop]. 

(5) [Come Here] (Come function)

The user program is executed from the address indicated by the current PC register to the address 

selected in the line/address display area of the Source window or the Assemble window, and then a 

break occurs.
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While the user program is being executed, the break event currently set does not occur.

(6) [Restart]

The CPU is reset and the user program is executed starting from address 0.  

This is the same operation as "resetting the CPU before execution of the user program and executing 

[Go]".  

4. 3. 2    Non-real-time execution function

The following non-real-time execution functions are available:

• [Step In]

• [Next Over]

• [Slow Motion]

(1) [Step In]

The operation differs depending on whether this function is executed in the Source window or the 

Assemble window. 

In the Source window

Step execution of one line of the source text is performed starting from the current PC register value 

and the contents of each window are updated.  

In the Assemble window

One instruction is executed from the current PC register value and the contents of each window are 

updated.  

(2) [Next Over]

The operation differs depending on whether the instruction to be executed is the call/callt/callf 

instruction or another instruction. 

call/callt/callf instruction

Next step execution is performed, assuming the function or subroutine called by the call/callt/callf 

instruction is one step. (Step execution continues until the nesting level becomes the same as when 

the call/callt/callf instruction was executed.) 

Instruction other than call/callt/callf

The same processing as [Step In] is performed. 

(3) [Slow Motion]

Step execution of one line is performed from the address indicated by the current PC register value in 

the source mode.  In the instruction mode, step execution of one instruction is performed. The contents 

of each window are updated each time step execution is performed.  This operation is repeated until 

the user executes [Stop].  
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4. 4    Event function

An event is a specific status of the target system during user program execution, such as "address

0x1000 is fetched" or "data is written to address 0x2000".  

The ID78K4-NS uses an event to trigger an action of functions such as break and trace functions.  An

event function is used to set, delete, and reference a specific status of the target system that triggers an

action (debugging action) as an event condition.  

4. 4. 1    Using event function

So that an action that is triggered by an event function in accordance with the user's debugging aim, the

following various event conditions must be set.  

These various event conditions are set independently as an "Event condition" or "Event link condition", or

as a combination of these.  To use the event function of the ID78K4-NS, therefore, first create the necessary

"Event condition" and "Event link condition", and set the various event conditions shown in the Table 4-1 by

using these conditions.  

4. 4. 2    Event condition

Create an event condition in the Event dialog box.  

Set an address condition, status condition, and data condition in this dialog box.  Specify a combination of

these as one event condition and name and register this event condition.  The registered event condition

can be used to set various event conditions.  However, the number of event conditions that can be set is

limited.  

The event condition that is created when a breakpoint is set in the Source window or the Assemble

window can also be used (Breakpoint setting/deletion function (p.116)).  

4. 4. 3    Event link condition

An event link condition specifies sequential constraints for each event, so that two or more events are

treated as a single event.  

To create an event link condition, use the Event Link dialog box.  

By arranging already registered event conditions in this dialog box, one event link condition can be

named and registered.  The registered event link condition can be used to set various event conditions in

the same manner as the event condition.  However, the number of event conditions that can be set is

limited.

Table 4-1　Various Event Conditions

Set Condition Setting Dialog Box Contents

Break event Break dialog box Condition in which the execution of the user program or 
the operation of the tracer is stopped.  

Trace event Trace dialog box Condition in which the process of user program 
execution is saved to the trace memory.  
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4. 4. 4    Setting of various event conditions

Various event conditions listed in Table 4-1 are individually created in the corresponding dialog box.  

To create various event condition, drag and drop the event icon of an event condition or event link

condition registered on the Event Manager to the condition area of each setting dialog box.  

The created various event condition is set by clicking the <Set> or <OK> button in the setting dialog box.

The mark of the event that has been set is displayed in red.  After the event has been set, a debugging

action occurs as various event condition.  

Up to 256 various event conditions can be registered.  The number of various event conditions that can

be "set" differs depending on the various event condition (refer to "Table 6-26  Maximum number of Events

Usable for Event Conditions (p.215)").  

4. 5    Break function

The break function is used to stop execution of the user program by the CPU and operation of the tracer.  

The following types of break functions are available:

• Event detection break

• Break by Come function

• Software break

• Break on satisfaction of condition of step execution

• Forced break

• Fail-safe break

Caution The event detection break and software break are not performed when [Come Here],

[Step In], [Return Out], or [Next Over] described in "Program Execution Function" is

executed.  

(1) Event detection break

Event detection break is a function used to stop execution of the user program by detecting a set break 

event condition.  This break is valid for [Go], [Go & Go], [Start From Here], and [Restart].  

In the case of [Go & Go], however, the contents of each window are updated and the user program is 

executed again after the event detection break has occurred.  Set a break event as follows:

•  Set as an execution event in the Source window or Assemble window (refer to "Breakpoint setting/
deletion function (p.116)").  

•  Set in the Break dialog box.

(2) Break by Come function

The Break by Come function is used to stop the user program that is executed by the [Come Here] 

command, by detecting an address specified in the Source window or Assemble window.  When 

execution of the user program has been stopped, the breakpoint by the Come function is eliminated.  

While the user program is being executed by using this function, a break event that has been set does 

not occur.  
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(3) Software break 

Software break is a function to replace the instruction at the specified address with a debugger-

dedicated software break instruction and stop the user program executed by the [Go], [Go & Go], [Start 

From Here], or [Restart] command.

As many software break events as necessary can be set (however, only 100 of them are valid).  

Because the instruction at the specified address is rewritten, however, a software break event cannot 

be set on the external ROM or stopped by the access timing of a variable.

While one event detection break uses one hardware resource per event condition, the feature of a 

software break is that a breakpoint is set at two or more addresses.

Set a software break event in the Source window or Assemble window (refer to "Breakpoint setting/

deletion function (p.116)").

The Software Break Manager manages software breaks (switching enable/disable, etc.).

(4) Break on satisfaction of condition of step execution

Break on satisfaction of condition of step execution is a function used to stop execution of the user 

program when the end condition of each command ([Step In], [Next Over], [Return Out], and 

[Slowmotion]) is satisfied.  

Because one instruction is executed, stopped, and the condition is confirmed at one time, the 

processing time is longer than that of real-time execution.  

(5) Forced break

Forced break is a function used to forcibly stop execution of the user program.  It is valid for all the 

program execution commands.  Force break includes the following:

•  [Stop] command: Forcibly stops execution of the user program.  

(6) Fail-safe break

A fail-safe break is a function for forcibly stopping the user program when the user program has 

executed a prohibited action on the memory and registers.  

The types of fail-safe break functions are as follows: 

Note that if a fail-safe break occurs, there may be a problem with the user program or the set 

environment of the ID78K4-NS may be wrong.  

Non-map break This break occurs if an attempt is made to access a non-map area. 

Write-protect break This break occurs if an attempt is made to write to memory that must 
not be written to, such as ROM.  

SFR Illegal access break This break occurs if an attempt is made to access SFR illegally.  

Stack Overflow This break occurs as the result of stack overflow. 

Relocation Break This break occurs if a location instruction different from the default 
setting was executed.
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4. 6    Trace function

The trace function is used to save the history of the data indicating the execution process of the user

program to the trace memory.  

The trace data saved to the trace memory can be checked in the Trace window.  

The item to be displayed in the Trace window can be selected in the Trace Data Select dialog box.  

To use the trace function, check that the trace function is valid by selecting the [Option] menu -> [Tracer

ON].  The trace function is valid in the default status, and all data is unconditionally traced (unconditional

trace) when the program is executed.  

4. 6. 1    Operation of trace

The trace memory of the ID78K4-NS is a ring buffer with a capacity of 32,768 frames. 

The operation of the tracer differs as indicated in (1) to (3) below, depending on the style of execution of

the user program.  

(1) Operation during real-time execution

The operation of the tracer differs depending on the specified trace mode.

These trace modes can be set by selecting the [Run] menu -> [Conditional Trace /Unconditional 

Trace].  

(2) Operation during Step In execution

The tracer operates every step execution, and trace data of one step is successively added to the trace 

memory.  

(3) Operation during Next Over execution

The operation of the tracer differs depending on the instruction to which Next Over is to be executed.  

4. 6. 2    Trace condition setting function

The following setting types of trace condition are available:  

All trace
(Unconditional trace)

Trace is started when real-time execution of the program is specified, 
and ends when a break occurs.  

Conditional trace Trace is started or stopped by the condition set in the Trace dialog 
box (if a break occurs while a trace is being executed, however, trace 
is stopped immediately).  

Table 4-2　Operation of Tracer (During Next Over Execution)

Instruction Tracer Operation

call/callt/callf instruction The call/callt/callf instruction and the subroutine that was called are 
traced.

Other instructions The same operation as that during Step In execution is performed.
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(1) Setting trace mode

Two trace modes, unconditional trace and conditional trace, are available.

(2) Setting of tracer control mode

The tracer has a ring structure.  

The following operation modes of the tracer can be selected from the [Run] menu:

(3) Setting trace event condition

A trace event condition triggers starting/stopping trace execution when a conditional trace is set.  

A trace event condition is set in the Trace dialog box.  

The following types of trace event conditions can be specified: 

4. 7    Register Manipulation Function

The register manipulation function is used to display or change the contents of the general-purpose

registers, control registers, and SFR.  

This function can be used in the Register window or SFR window.  To change the register to be displayed

in each window, use the SFR Select dialog box.  

A user-defined I/O port can be displayed or changed by registering it to the Add I/O Port dialog box.    

4. 8    Memory Manipulation Function

As a memory manipulation function, the memory contents can be displayed or changed by using

mnemonic codes, hexadecimal codes, and ASCII codes.  

This function can be used in the Memory window or Assemble window.  The contents of memory can be

copied, initialized, and compared.  

4. 9    Watch Function

Data (variable) values can be checked or changed in the Watch window.  

Local variables can be checked or changed in the Local Variable window.  

Non-Stop Goes around the trace memory and overwrites data from the oldest frame 
(default).  

Full Stop Goes around the trace memory and then stops the tracer.

Section trace Executes a trace between two specified conditions (in a specific zone).  
A section trace (zone trace) can be executed by setting a trace start event 
and trace end event and executing a conditional trace.  

Qualify trace Executes a trace only when a condition is satisfied.  
If two or more events are set as qualify trace events, a qualify trace can be 
executed by executing a conditional trace.  
A qualify trace can be executed by setting a qualify trace event and 
executing a conditional trace.  
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The contents of a variable value can be easily referenced in the Source window or Assemble window by

placing the mouse cursor on the selected variable (balloon watch function).  

4. 10    Time Measurement Function

The time measurement function is used to measure the execution time for the section that is subject to

section trace.  

The maximum execution measurement time is about 14 minutes 33 seconds (resolution: 203.45 ns).

4. 11    Load/Save Function

The load/save function is used to load/save each file. 

The ID78K4-NS loads/saves each file individually.  

These three types of files can be handled: 

4. 11. 1    View files

The list of the view files to be handled is shown below: 

These files can be manipulated in the View File Load dialog box and View File Save dialog box.  

view files File recording the screen information when it is saved.  By loading this file, a 
reference file is opened in the Source window.  

Information file File recording the set data and debugging environment as information on the 
user program and debugger.  

Setting files File recording the window information.  

Table 4-3　 List of View Files

File Type Contents

Source Text (*.SVW) Source window view file
Records the source text in the Source window.  

Assemble (*.DIS) Assemble window view file
Records the assembly information in the Assemble window.  

Memory (*.MEM) Memory window view file
Records the memory information in the Memory window.  

Register (*.RGW) Register window view file
Records the register information in the Register window.  

Local Variable (*.LOC) Local Variable window view file
Records the local variable information in the Local Variable window.  

Stack Trace (*.STK) Stack Trace window view file
Records the stack trace information in the Stack Trace window.  

Trace (*.TVW) Trace window view file
Records the trace information in the Trace window.  
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4. 11. 2    Information files

The list of the information files to be handled is shown below.  

A project file sets the display information, size, and display position of a window or dialog box, and

restores the debugging environment to the previous status (when the project file was saved) when it is

loaded.  

4. 11. 3    Environment files

The list of the environment files to be handled is shown below: 

These files can be manipulated in the Environment File Load dialog box and Environment File Save

dialog box.  

4. 12    Real-Time internal RAM Sampling Function

The following real-time RAM sampling function is available.

Watch (*.WCH) Watch window view file
Records the watch information in the Watch window. 

SFR (*.SFR) SFR window view file
Records the SFR information in the SFR window.

Console (*.LOG) Console window view file
Records the information in the Console window.  

Table 4-3　 List of View Files

File Type Contents

Table 4-4　 List of Information Files

File Name (Extension) Contents Dialog Box

Object file
(*.HEX)

Stores the object codes of the user 
program.

Download dialog box,
Upload dialog box

Project File
(*.PRJ)

Stores the debugging environment  Project File Load dialog box,
Project File Save dialog box

Binary file
(*.BIN)

Records data in binary format.  Download dialog box,
Upload dialog box

Table 4-5　Types of Environment Files Handled

File Name (Extension) Contents

Watch environment file
(*.WCH)

Stores the watch setting contents of the Watch window.  

SFR environment file
(*.OR)

Stores the SFR setting contents of the SFR window.  

Event environment file
(*.EVN)

Stores the event setting contents of the Event Manager.  
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• Real-time internal RAM sampling function

The real-time RAM sampling function is used to read and display the memory contents, even during user

program execution, if a variable allocated to a range in which the memory contents can be read, or the

memory contents are displayed.  

This function can be checked in the Watch window or Memory window.  

Settings related to this function are performed in the Extended Option dialog box.  
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CHAPTER 5  OPERATION

This chapter explains the flow of basic debugging operations using the ID78K4-NS and the following

functions:

• Flow of Debugging Operations

• Active Status and Static Status

• Jump Function

• Trace Result with Linking Window

5. 1    Flow of Debugging Operations

(1) Setting debugging environment

Prepare for debugging.

-> Mapping function

-> Configuration dialog box

Download a load module file to be debugged.

-> Download dialog box

(2) Displaying source program

By downloading a load module file with debug information, the corresponding source file is 

automatically displayed.  

-> Source window

(3) Displaying disassemble result

The disassembled result of the downloaded user program is displayed.  

-> Assemble window

(4) Setting breakpoint

Breakpoints can be set easily in the Source window, Assemble window, and Watch window.  

-> Breakpoint setting/deletion function

-> To set a breakpoint for read/write access to a variable

(5) Setting event

Register event conditions and event link conditions.

-> Event dialog box, Event Link dialog box

Setting of various event conditions

Set a various event condition by using the Event Manager or an event icon in the event manager area 

on each various event setting dialog box.  

Each various event condition corresponds to the following various event setting dialog box.  

Break event condition -> Break dialog box

Trace event condition -> Trace dialog box
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Checking setting status of various event conditions

-> Event dialog box or the event manager area in each various event setting dialog box

Checking setting status of software breakpoint

-> Software Break Manager 

(6) Executing user program

By executing the user program, the PC advances to the set breakpoint, break event, or forced 

breakpoint (refer to "Program Execution Function (p.21)").

Use the execution control button or [Run] menu to execute the user program.  

(7) Checking trace data

-> Trace window

(8) Editing, checking, and changing memory contents

-> Memory window, Memory Copy dialog box, Memory Fill dialog box, Memory Compare dialog box, 

Memory Compare Result dialog box

(9) Registering, checking, and changing variable value

-> Watch window, Quick Watch dialog box, Add Watch dialog box, Change Watch dialog box, Local 

Variable window

(10) Checking stack contents

-> Stack Trace window

(11) Checking and changing of registered contents of register value

-> Register window

The value of the PC register can also be checked in the Source window and Assemble window.

(12) Checking and changing SFR value

-> SFR window, SFR Select dialog box

(13) Registering, checking, and changing user-defined I/O port value

-> Add I/O Port dialog box, SFR window

(14) Changing mnemonic and executing online assembly (Assemble window only)

-> Assemble window, Source window

(15) Checking execution time of user program

-> Timer dialog box, Timer Result dialog box, Trace window

(16) Searching character string in each window

By clicking the < Search...> button in the window in which searching is to be executed, the following 
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types of searching dialog boxes are opened:

Source Search dialog box, Assemble Search dialog box, Memory Search dialog box, Trace Search 

dialog box

(17) Manipulating view file

-> View File Save dialog box, View File Load dialog box

(18) Uploading memory contents and coverage result

-> Upload dialog box

(19) Saving debugging environment to file

-> Project File Save dialog box, Environment File Save dialog box

(20) Terminating ID78K4-NS

-> Exit Debugger dialog box

5. 2    Active Status and Static Status

The Source window, Assemble window, and Memory window have the following two window statuses:

Because two or more static windows can be opened, the current status of the windows can be temporarily

held.  

5. 3    Jump Function

The jump function is used to jump to Source window, Assemble window, or Memory window from a jump

pointer that is the line or address on which the cursor is placed, and display the contents of the jump

destination window from the jump pointer.  

You can jump among the above windows, or from Trace window, Stack Trace window, Event Manager,

and Register window to the above windows.  

Active status The display position and contents of the window in the active status are 
automatically updated in association with the current PC value.  
This window is also the jump destination of the jump function.  If this window is 
linked with the Trace window, the contents displayed in the active window are 
updated in association with the Trace window.  Only one window can be opened 
in the active status.  
Select this status by the [Window] menu.  

Static status The display position of the window in the static status does not move in 
association with the current PC value, but the displayed contents are updated.  
The static window is not used as the jump destination of the jump function.  In 
addition, it is not linked with the Trace window.  
If an active window is already open, the next window is opened in the static 
status.  Two or more static windows can be opened at the same time.  
Select this status by the [Window] menu.  
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Jump method

1 Move the cursor to the line or address that is to be used as the jump pointer, on the window from

which jumping is possible (select an event icon on the Event Manager).  

2 Select the following menu item to which execution is to jump from the [Jump] menu.  

Source window->Select [Source].

Assemble window->Select [Assemble].

Memory window->Select [Memory].

Caution If a program code does not exist on the line at the cursor position, the first address of

the line with a program code above or below that line is used as the jump pointer.  

Details of jump source address

To jump from the following windows, the jump destination is as follows:

•  To jump from the Trace window to the Memory window, the jump source address differs depending
on the cursor position in the trace result display area.  

•  To jump from the Register window, move the cursor to a register value.  

•  To jump from the Stack Trace window, the jump destination is as follows:  

[With current function]

•  If the jump destination is the Source window -> Jumps to the current PC line.  

•  If the jump destination is a window other than the Source window -> Jumps to the current PC
address.  

[With function other than current function]

•  If the jump destination is the Source window 
-> Jumps to the line that calls a nested function.

•  If the jump destination is a window other than the Source window
-> Jumps to the address next to the instruction that calls a nested function.

5. 4    Trace Result with Linking Window

By linking Trace window with each window (Source window, Assemble window, or Memory window), the

corresponding part can be displayed on the linked window, by using the address at the cursor position on

the Trace window as a pointer.  

If the cursor is moved on the Trace window, the corresponding part on the linked window is highlighted or

indicated by the cursor position.  

To link a window

If the cursor is at an access address, access data, or access 
status 

-> Access address 

Other than above -> Fetch address 

To jump to the Source window or Assemble window -> Fetch address 
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1 Set the Trace window as the current window.  

2 Select a window to be linked with the [View] menu -> [Window Synchronize].  

Source window  ->Select [Source].

Assemble window  ->Select [Assemble].

Memory window  ->Select [Memory].

3 Move the cursor to the line to be linked in the trace result display area of the Trace window.  

4 Using the address of the line selected in 3 as a pointer, the corresponding part is highlighted (or

indicated by the cursor position) in the display area of the window selected in 2.  

Caution The linking source address differs as follows depending on the cursor position in the

trace result display area if the Memory window is linked.  

Access address, access data, access status -> Access address

Others -> Fetch address

When the Source window or Assemble window is linked, the fetch address is always

used as the pointer.  
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CHAPTER 6  WINDOW REFERENCE 

This chapter explains the details of the window/dialog box functions of the ID78K4-NS.

6. 1    Window List

Table 6-1 lists the windows of the ID78K4-NS.

Table 6-1　  Window List 

Window Name Contents

Main window (refer to p.40) This window is displayed first, when the debugger is started.  
It controls execution of the user program.  Various windows are 
opened from this window.

Configuration dialog box (refer to p.59) Displays and sets the debugger operation environment.

Extended Option dialog box (refer to 
p.65)

This dialog box is used to display and set the extended options of the 
debugger.

Debugger Option dialog box (refer to 
p.68)

Displays and sets options.

Font dialog box (refer to p.76) Displays the types of fonts displayed in the Source window and sets 
the size of the font.

Project File Save dialog box (refer to 
p.78)

Saves the debug environment.

Project File Load dialog box (refer to 
p.81)

Loads the debug environment.

View File Save dialog box (refer to p.83) Saves the contents of the current window to a view file or event setting 
file.

View File Load dialog box (refer to p.87) Reads the view file or source event setting file of each window.

Environment File Save dialog box (refer 
to p.90)

Saves the contents of the current window to a environment file or event 
setting file.

Environment File Load dialog box (refer 
to p.92)

Reads the environment file or source event setting file of each window.

Download dialog box (refer to p.94) Loads an object file and binary file.

Upload dialog box (refer to p.98) Saves the memory contents to a file.

Browse dialog box (refer to p.101) Debugger Option dialog box, Select the file to be set in Source Search 
dialog box.

Source Text Move dialog box (refer to 
p.105)

This dialog box is used to specify a file to be displayed in Source 
window and the position from which displaying the file is to be started.

Address Move dialog box (refer to p.103) Specifies the start address to display the contents of the Memory 
window, Assemble window or Coverage window.  

Trace Move dialog box (refer to p.108) Specifies the start address to display the contents of the Trace window.  

Symbol To Address dialog box (refer to 
p.111)

Displays the addresses and symbol values of variables and functions.  

Source window (refer to p.114) Displays a source file or text file.

Source Search dialog box (refer to 
p.128)

Searches for a character string in a source file.  

Assemble window (refer to p.131) Disassembles the program and executes online assembly.
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Assemble Search dialog box (refer to 
p.138)

Searches the contents of the Assemble window.  

Memory window (refer to p.141) Displays and modifies the contents of memory.  

Memory Search dialog box (refer to 
p.146)

Searches the contents of the Memory window.  

Memory Fill dialog box (refer to p.149) Initializes the memory contents with specified data.

Memory Copy dialog box (refer to p.151) Copies the memory.

Memory Compare dialog box (refer to 
p.153)

Compares the memory.  

Memory Compare Result dialog box 
(refer to p.155)

Displays the result of comparing the memory.  

Watch window (refer to p.157) Displays and modifies variables.

Quick Watch dialog box (refer to p.164) Temporarily displays and changes the value of a variable.

Add Watch dialog box (refer to p.168) Registers a variable to be displayed in the Watch window.  

Change Watch dialog box (refer to 
p.172)

Changes a variable to be displayed in the Watch window.  

Local Variable window (refer to p.175) Displays and changes the local variable in the current function.  

Stack Trace window (refer to p.178) Displays and changes the stack contents of the current user program.

Register window (refer to p.182) Displays and changes the contents of the registers (general-purpose 
registers and control registers).

SFR window (refer to p.187) Displays and changes the contents of the SFR.

SFR Select dialog box (refer to p.192) Selects a SFR or I/O port to be displayed in the SFR window.  

Add I/O Port dialog box (refer to p.195) Registers an I/O port to be displayed in the SFR window.  

Trace window (refer to p.198) Displays trace results.

Trace Search dialog box (refer to p.205) Searches trace data.

Trace Data Select dialog box (refer to 
p.212)

Selects items to be displayed in the Trace window.  

Event Manager (refer to p.215) Displays, enables/disables, and deletes each event condition.  

Event dialog box (refer to p.226) Registers and displays event conditions.

Event Link dialog box (refer to p.234) Registers and displays event link conditions.  

Break dialog box (refer to p.239) Registers, sets, and displays break event conditions.

Trace dialog box (refer to p.243) Registers, sets, and displays trace event conditions.

Timer dialog box (refer to p.248) Displays execution time measurement result, and registers, sets, and 
displays timer event conditions.

Timer Result dialog box (refer to p.251) Displays execution time measurement results.

Delay Count dialog box (refer to p.253) Sets the delay count of a trace.

Software Break Manager (refer to p.223) Display, enable or disable, and delete software breaks. 

Reset Debugger dialog box (refer to 
p.255)

Initializes the ID78K4-NS, target CPU, and symbol information.  

About dialog box (refer to p.257) Displays the version of the ID78K4-NS.  

Table 6-1　  Window List 

Window Name Contents
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6. 2    Explanation of Windows

This section explains each debug window as follows:

Exit Debugger dialog box (refer to p.259) Terminate the ID78K4-NS.  

Console window (refer to p.261) Inputs commands.  

Error/Warning dialog box Displays error/warning messages.

Table 6-1　  Window List 

Window Name Contents
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Window/dialog name

Briefly explains the function of the window or dialog box and points to be noted.  

In addition, the display image of the window or dialog box is also illustrated.  

Items of related operation are also explained.  

Opening

Explains how to open the window or dialog box.  

If two or more methods of opening are listed, the window or dialog box can be opened by any of them.  

Explanation of each area

Explains items to be set to or displayed in each area of the window or dialog box.  

Functions often used (right-click menu)

Explains the context menu that is displayed in the window when the right mouse button is clicked.  

From the context menu, convenient functions often used in this window can be selected with a single 

action (window only).  

Function buttons

Explains the operation of each button in the window or dialog box.  

Related operations

Explains the operation of a window or dialog box related to this window or dialog box.  
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Main window

This window is automatically opened when the ID78K4-NS is started up and initialized.  It exists on the

screen until the ID78K4-NS is terminated.  Other windows are manipulated from this window.  Execution of

the user program is controlled in this window.

Execution of the user program is controlled in the following three modes:

The auto mode is set when the debugger is started up.

Figure 6-1　Main Window

This section explains the following items:

• Toolbar

• Menu bar

• Window display area

• Status bar

Toolbar

The toolbar is a collection of buttons that can execute often-used commands with a single action.  Each

Source mode Debugs the user program at the source level.

Instruction mode Debugs the user program at the instruction level.

Auto mode Automatically selects the source mode or instruction mode.
Step execution is performed at the source level when the Source 
window is active (except in the mixed display mode), and at the 
instruction level when the Assemble window is active. When neither of 
these windows is active, step execution is performed at the source level.
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button is graphically displayed to indicate the image of its function.  This toolbar can be displayed in the

following two modes.  The modes are selected in Debugger Option dialog box.

Figure 6-2　Toolbar with Only Graphics (default)

Figure 6-3　Toolbar with Graphics and Characters

Whether the toolbar is displayed or not can be specified by selecting [Option] -> [Tool Bar] from the menu

bar.  This toolbar can be moved inside or outside the main window by dragging and dropping with the

mouse.

  The meaning of each button on the toolbar is as follows.  When the mouse cursor is placed on a button

of the toolbar, a tool hint pops up several seconds later.

Stop

Stops execution of the user program.
Same function as [Run] -> [Stop] on the menu bar.

ReGo

Resets the CPU and executes the user program.
Same function as [Run] -> [Restart] on the menu bar.

Go

Executes the user program from the current PC without resetting the CPU.
Same function as [Run] -> [Go] on the menu bar.

Go

Executes the user program without a break occurrence. 
Same function as [Run] -> [Ignore break points and Go] on the menu bar.

Ret

The user program is real-time executed until execution returns.
Same function as [Run] -> [Return Out] on the menu bar
(This command is used for a function described in C language.)

Step

Step execution (executes instructions in the program one by one.)
If a function or subroutine is called, its instructions are executed one by one.
Same function as [Run] -> [Step In] on the menu bar.

Over
Next step execution (executes the program, assuming a function/call statement as one 
step.)
If a function or subroutine is called, its instructions are not executed on a step-by-step 
basis.
Same function as [Run] -> [Next Over] on the menu bar.

Res
Resets the CPU.
Same function as [Run] -> [CPU Reset] on the menu bar.

Open
Opens View File Load dialog box.
Same function as [File] -> [Open...] on the menu bar.

Load
Opens Download dialog box.
Same function as [File] -> [Download...] on the menu bar.
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Menu bar

The menu bar consists of the following menus:

(1)　 [File] menu

Proj
Opens Project File Load dialog box.
Same function as [File] -> [Project] -> [Open...] on the menu bar.

Src
Displays the source text.
Opens Source window.
Same function as [Browse] -> [Source Text] on the menu bar.

Asm
Displays the disassemble results.
Opens Assemble window.
Same function as [Browse] -> [Assemble] on the menu bar.

Mem
Displays the contents of the memory.
Opens Memory window.
Same function as [Browse] -> [Memory] on the menu bar.

Wch

Displays the watch contents.
Opens Watch window.
Same function as [Browse] -> [Watch] on the menu bar.

Reg
Displays the register contents.
Opens Register window.
Same function as [Browse] -> [Register] on the menu bar.

Sfr
Displays the contents of the SFR.
Opens SFR window.
Same function as [Browse] -> [Sfr] on the menu bar.

Loc
Displays the local variable contents.
Opens Local Variable window.
Same function as [Browse] -> [Local Variable] on the menu bar.

Stk
Displays the stack contents.
Opens Stack Trace window.
Same function as [Browse] -> [Stack Trace] on the menu bar.

TrW
Displays the trace results.
Opens Trace window.
Same function as [Browse] -> [Trace] on the menu bar.

Mgr
Opens Event Manager.
Same function as [Event] -> [Event Manager] on the menu bar.

Evn
Registers and sets events.
Opens Event dialog box.
Same function as [Event] -> [Event...] on the menu bar.

Brk
Registers and sets break events.
Opens Break dialog box.
Same function as [Event] -> [Break...] on the menu bar.

Trc
Registers and sets trace events.
Opens Trace dialog box.
Same function as [Event] -> [Trace...] on the menu bar.

Tim
Registers and sets timer events. 
Opens Timer dialog box.
Same function as [Event] -> [Timer...] on the menu bar.
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(2)　 [Edit] menu

(3)　 [View] menu

(4)　 [Option] menu

(5)　 [Run] menu

(6)　 [Event] menu

(7)　 [Browse] menu

(8)　 [Jump] menu

(9)　 [Window] menu

(10)　 [Help] menu

(1) [File] menu

Open... Loads a view file, source file, or text file.
Opens View File Load dialog box.
The operation differs depending on the extension of the file selected in the 
dialog box.

Save As... Saves the contents displayed on the current window to the file whose name is 
specified.
Opens View File Save dialog box.

Close Closes the current window.

Download... Downloads a program.
Opens Download dialog box.

Upload... Uploads a program.
Opens Upload dialog box.

Project Manipulates a project file.

Open... Opens a project file.
Opens Project File Load dialog box.

Save Overwrites the current status to the project file currently being read to the 
debugger.

Save As... Saves the current status to a specified project file.
Opens Project File Save dialog box.

Environment Manipulates a environment file.
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(2) [Edit] menu

Open... Opens a environmet file.
Opens Environment File Load dialog box.

Save As... Saves the current status to a specified environmet file.
Opens Environment File Save dialog box.

Debugger Reset... Initializes the target CPU, symbols, and debugger.
Opens Reset Debugger dialog box.

Exit Terminates the debugger.
Opens Exit Debugger dialog box.

(Open file) Lists the names of the files opened.

Cut Cuts a selected character string and saves it to the clipboard buffer.

Copy Copies a selected character string and saves it to the clipboard buffer.

Paste Pastes the contents of the clipboard buffer to the text cursor position.

Write in Writes the modified contents to the target.

Restore Cancels the modification.

Memory Manipulates the memory contents.

Fill... Initializes the memory.
Opens Memory Fill dialog box.

Copy... Copies the memory.
Opens Memory Copy dialog box.

Compare... Compares the memory.
Opens Memory Compare dialog box.

Edit Source Opens the source file displayed in the active Source window with the editor 
specified by the PM plus when the PM plus runs.
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(3) [View] menu

This menu displays different items depending on the window that is active.  The following items may be 

displayed:

•  Common items

•  Source window-dedicated items

•  Assemble window-dedicated items

•  Memory window-dedicated items

•  Watch window-dedicated items

•  Register window-dedicated items

•  SFR window-dedicated items

•  Local Variable window-dedicated items, Stack Trace window-dedicated items

•  Trace View window-dedicated items

•  Event Manager-dedicated items

Common items

Search... Performs a search.
Opens the search dialog box corresponding to the current window.
Same operation as the <Search> button.
However, this item cannot be selected when the Trace window is open. 

Move... Moves the display position.
Opens the specification dialog box corresponding to the current window.

Quick Watch... Temporarily displays the contents of the specified data.
Opens Quick Watch dialog box.

Add Watch... Registers the specified data to the Watch window.
Opens Add Watch dialog box.

View Watch Adds the selected data to the Watch window.
If the data is a symbol, it is added in accordance with the setting of Debugger 
Option dialog box.

Change Watch... Changes the data on the line selected by the Watch window.
Opens Change Watch dialog box.
This menu is valid only when a variable is selected in Watch window.

Delete Watch Deletes the selected watch point from the Watch window.  This menu is valid 
only when a variable is selected in Watch window.

Symbol... Displays the address of the specified variable or function, or the value of the 
specified symbol.
Opens Symbol To Address dialog box.
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Source window-dedicated items

Assemble window-dedicated items

Memory window-dedicated items

Create Break Event Creates a break event by using the selected variable.

Break when Access
to this Variable

Creates a break event that can be accessed for read/write.

Break when Write to
this Variable

Creates a break event that can be accessed for write.

Break when Read
from this Variable

Creates a break event that can be accessed for read.

Clear Deletes a break event corresponding to the selected variable.  

Event? Displays the event information of a line at the cursor position or a selected 
variable name.  
If an event is set, Event dialog box is opened.

Mix Specifies whether the results of assembly are displayed in mixed display 
mode, or not displayed.
Checked: Mixed display
Not checked: No display (default)

Event? Displays the event information of the address at the cursor position.
If an event is set, Event dialog box is opened.

Bin Displays binary numbers.

Oct Displays octal numbers.

Dec Displays decimal numbers.
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Watch window-dedicated items

Only "selected items" can be manipulated in the Watch window.

Hex Displays hexadecimal numbers (default).

Nibble Displays in 4-bit units.

Byte Displays in 8-bit units (default).

Word Displays in 16-bit units.

Double Word Displays in 32-bit units.

Ascii Selects whether ASCII characters are displayed or not.
Checked: Displayed
Not checked: No display (default)

Little Endian Displays in little endian (default).

Big Endian Displays in big endian.

Create Break Event Creates a break event by using the selected item.

Break when Access
to this Variable

Creates a break event that can be accessed for read/write.

Break when Write to
this Variable

Creates a break event that can be accessed for write.

Break when Read
from this Variable

Creates a break event that can be accessed for read.

Clear Deletes a break event corresponding to the selected item.  

Event? Displays the event information of the variable selected.  If an event is 
set, Event dialog box is opened.

Bin Displays binary numbers.

Oct Displays octal numbers.

Dec Displays decimal numbers.

Hex Displays octal numbers.
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Register window-dedicated items

SFR window-dedicated items

String Displays character strings.

Proper Displays the default value of each variable.
Symbols are displayed in accordance with the setting of Debugger 
Option dialog box (default).

Byte Displays in 8-bit units.

Word Displays in 16-bit units.

General Displays in 24-bit units.

Double Word Displays in 32-bit units.

Adaptive Displays the default value of each variable.
Only this item is valid for a symbol in C language.
Symbols are displayed in accordance with the setting of Debugger 
Option dialog box (default).

Up Moves up one line.

Down Moves down one line.

Compulsion Read Forcibly reads the peripheral I/O registers that are disabled from being 
read because their values will be changed, or the data of the I/O ports 
and I/O protect area added in SFR window or Add I/O Port dialog box.

Bin Displays binary numbers.

Oct Displays octal numbers.

Dec Displays decimal numbers.

Hex Displays hexadecimal numbers (default).

Absolute Name Displays register names as absolute names.

Functional Name Displays register names as function names (default).
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Local Variable window-dedicated items, Stack Trace window-dedicated items

Trace View window-dedicated items

Bin Displays binary numbers.

Oct Displays octal numbers.

Dec Displays decimal numbers.

Hex Displays hexadecimal numbers (default).

Sort By Name Displays in alphabetical order.

Sort By Address Displays in address order (default).

Unsort Does not sort.

Attribute Displays or does not display an attribute field (Attribute).
Checked: Displayed (default)
Not checked: Not displayed

Pick Up Displays only the registers selected in SFR Select dialog box.
Checked: Displays only the selected register.
Not checked: Displays all the registers (default).

Select... Opens SFR Select dialog box.

Compulsion Read Forcibly reads the SFR that are disabled from being read because their 
values will be changed, or the data of the I/O ports and I/O protect area 
added in SFR window or Add I/O Port dialog box.

Bin Displays binary numbers.

Oct Displays octal numbers.

Dec Displays decimal numbers.

Hex Displays octal numbers.

String Displays character strings.

Proper Displays the default value of each variable (default).
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Event Manager-dedicated items

Select... Selects the contents to be displayed.
Opens Trace Data Select dialog box.

Pick Up Performs the setting for pickup display.

Off Does not pick up and display (default).

Search Picks up and displays a frame that satisfies the search condition.

BRM1 Picks up and displays the first M1 fetch frame after a program branch.

Mix Specifies whether the results of assembly are displayed in mixed display 
mode, or not displayed.
Checked: Mixed display
Not checked: No display (default)

Window Synchronize Sets linking between Trace window and the following windows.
A checked window is linked.

Source Text Links Source window.

Assemble Links Assemble window.

Memory Links Memory window.

Select All Event Selects all the events registered to the Event Manager.

Delete Event Deletes a selected event.

Sort By Name Displays icons in the order of event names.

Sort By Kind Displays icons in the order of event types.

Unsort Does not sort icons (default).

Detail Detailed display

Overview List display (default)
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(4) [Option] menu

Tool Bar Selects whether the tool bar is displayed (default) or not.

Status Bar Selects whether the status bar is displayed (default) or not.

Button Selects whether the buttons on each window are displayed (default) or not.

Source Mode Executes step execution at the source level (in line units).

Instruction Mode Executes step execution at the instruction level (in instruction units).

Auto Mode Automatically selects step execution at the source level or step execution at 
the instruction level (default).
Step execution is performed at the source level (in a mode other than mixed 
display mode) if Source window is active.  It is performed at the instruction 
level if Assemble window is active.  If neither window is active, step execution 
is performed at the source level.

Configuration... Sets the environment.
Opens Configuration dialog box.

Extended Option... Sets extended functions.
Opens Extended Option dialog box.

Debugger Option... Sets debugger options.
Opens Debugger Option dialog box.

Add I/O Port... Adds user-defined I/O ports.
Opens Add I/O Port dialog box.

Trace Clear Clears the trace data.
This item is displayed only when Trace window is active.
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(5) [Run] menu

Restart Resets the emulation CPU and executes the program.
Same operation as the ReGo button

Stop Forcibly stops program execution.
Same operation as the Stop button

Go Executes the program from the current PC.
Same operation as the Go button

Ignore break points and Go Executes the program, ignoring break points being set.  
Same operation as the GoN button

Return Out The user program is real-time executed until execution returns.
Same operation as the Ret button
This menu item is available only for a function described in C 
language.  

Step In Executes the instructions in the program one by one (step execution).
If a function or subroutine is called, its instructions are executed one by 
one.
Same operation as the Step button

Next Over Executes the instructions in the program one by one (Next step 
execution).
If a function or subroutine is called, its instructions are not executed on 
a step-by-step basis.
Same operation as the Over button

Start From Here Executes the program from the cursor position on Source window or 
Assemble window (Start function).

Come Here Executes the program from the current PC to the cursor position in the 
Source window or Assemble window (Come function).
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(6) [Event] menu

Go & Go Continues executing the program.
If a break occurs because a break condition is satisfied, the window is 
updated and the program is executed again.
Each time a break has occurred, the same operation as clicking the 
Go button is performed.

Slowmotion Continues step execution.
Each time step execution has been performed, the window is updated 
and then step execution is performed again.
Same operation as clicking the Step each time a break has occurred.

CPU Reset Resets the emulation CPU.
Same operation as the Res button

Change PC Sets the address at the cursor position in the Source window or 
Assemble window to the PC.

Break Point Sets or cancels a breakpoint at the cursor position in the Source 
window or Assemble window.

Software Breakpoint Sets or cancels a software breakpoint at the cursor position in the 
Source window or Assemble window. 

Delete All Breakpoints Deletes all software breakpoints that are set.

Uncond. Trace ON Validates unconditional trace so that trace can always be executed 
during program execution (default).
The trace mode cannot be changed while the tracer is activated.

Cond. Trace ON Validates conditional trace and traces in accordance with the trace 
condition during program execution.
The trace mode cannot be changed while the tracer is activated.

Tracer Start/
Tracer Stop 

Starts the tracer when it is stopped, or stops it when it is in progress.
This item is invalid if the program is not being executed and if the trace 
function is OFF (if [Option] -> [Tracer ON] is not checked).  
Immediately after program execution has been started with the tracer 
function ON, the tracer is executed.

Event Manager Manages various event conditions.
Opens Event Manager.
Same operation as the Mgr button

Software Break Manager Manages software break event conditions.
Opens the Software Break Manager. 
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(7) [Browse] menu

Event... Registers an event condition.
Opens Event dialog box.
Same operation as the Evn button

Event Link... Registers an event link condition.
Opens Event Link dialog box.

Break... Registers and sets a break condition.
Opens Break dialog box.
Same operation as the Brk button

Trace... Registers and sets a trace event condition.
Opens Trace dialog box.
Same operation as the Trc button

Timer... Displays a timer value.
Opens Timer dialog box.
Same operation as the Tim button

Delay Count... Sets a delay count and displays the delay value.
Opens Delay Count dialog box.

Source Text Displays a source text.
Opens Source window.
Same operation as the Src button
If there is a Source Text window already open in the active status, it is 
opened in the static status.

Assemble Displays the disassemble results.
Opens Assemble window.
Same operation as the Asm button
If there is a Assemble window already open in the active status, it is 
opened in the static status.

Memory Displays the contents of the memory.
Opens Memory window.
Same operation as the Mem button
If there is a Memory window already open in the active status, it is 
opened in the static status.

Watch Displays the watch contents.
Opens Watch window.
Same operation as the Wch button

Register Displays the register contents.
Opens Register window.
Same operation as the Reg button
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(8) [Jump] menu

SFR Displays the contents of the SFR.
Opens SFR window.
Same operation as the SFR button

Local Variable Displays the local variable.
Opens Local Variable window.
Same operation as the Loc button

Stack Trace Displays the stack trace results.
Opens Stack Trace window.
Same operation as the Stk button

Trace Displays the trace results.
Opens Trace window.
Same operation as the TrW button

Console Opens Console window.

Others Displays other windows.
Displays a user-defined window list.
Refer to 7. 6 Expansion window(refer to p.265) and APPENDIX B 
EXPANSION WINDOWS (refer to p.308) for details.

Source Text Displays the corresponding source text and source line, using the data value 
selected in the current window as the jump destination address.
If no line information is at the jump destination address, however, you cannot 
jump.
Opens Source window.
If an active Source window is open, that window is displayed in the forefront (so 
that it can be manipulated).

Assemble Disassembles and displays the results from the jump destination address 
specified by the data value selected in the current window.
Opens Assemble window.
If an active Assemble window is open, that window is displayed in the forefront 
(so that it can be manipulated).

Memory Displays the memory contents from the jump destination address specified by the 
data value selected in the current window.
Opens Memory window.
If an active Memory windowis open, that window is displayed in the forefront (so 
that it can be manipulated).
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(9) [Window] menu

(10) [Help] menu

New Window Opens a new window displaying the same contents as those of the current 
window.  This menu is valid only when the current window is Source window, 
Assemble window, or Memory window.

Cascade Cascade display of the windows in the Main window.

Tile Tile display of the windows in the Main window.

Arrange Icons Rearranges the icons in the Main window.

Close All Closes all windows, except the Main window.

Refresh Updates the contents of the window with the latest data.

Active Sets the window in the active status.
If the window is already in the active status, a check mark is shown on the left of 
this item.

Static Sets the window in the static status.
If the window is already in the static status, a check mark is shown on the left of 
this item.

(Open Window) Lists the windows that are open.
The window with the check mark shown on the side of the figure is the current 
window.  By selecting a window name, the selected window is used as the 
current window.

ID78K4-NS Help Displays the help of ID78K4-NS .

Command Reference Opens the Help window of COMMAND REFERENCE.

Main Window Help Displays the help of the Main window.

Current Window Help Displays the help of the current window.
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Window display area

This area (at the center) displays various debug windows.

The displayed window can be changed in size or an icon can be created in this area.

Status bar

The status bar is displayed at the bottom of the window and indicates the status of the debugger and In-

circuit emulator.

While the user program is being executed, the status bar is displayed in red.

Whether the status bar is displayed or not can be selected by selecting [Option] -> [Status Bar] from the

menu bar.

Figure 6-4　Status Bar

About... Displays the version of the debugger.
Opens About dialog box.

(1) Program name Displays the program file name indicated by the PC value.

     Source name Displays the source file name indicated by the PC value.

     Line number Displays the line number indicated by the PC value.

(2) Function name Displays the function name indicated by the PC value.

(3) PC value Displays the current PC value.

(4) CPU status Displays the status of the CPU (target device).
(If there are two or more CPU statuses, they delimited with '|' and displayed.)
STANDBY...Standby mode
RESET...Reset state

(5) IE status Displays the status of the in-circuit emulator.
(If there are two or more the statuses, they delimited with '/' and displayed.)
RUN...User program execution in progress (the color of the status bar 
changes).
STEP...Step execution in progress
TRC...Tracer operating
TIM..Timer operating
BREAK...Break occurring.

(6) Break Cause Displays Table 6-2  Break Cause.
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Caution If the screen resolution is small (800 x 600, etc.), all the statuses may not be displayed.

(7) STEP mode Displays the step execution mode.
Displays that the following modes are selected from the [Option] menu:
SRC...Source mode
INST...Instruction mode
AUTO...Automatic mode

(8) Key input mode Displays the key input mode.
INS... Insertion mode
OVR...Overwrite mode
The Memory window is fixed to OVR mode.

Table 6-2　Break Cause

Display Meaning

Manual Break Forced break

Temporary Break Temporary break

Event Break Break by event

Software Break Break due to software break event 

Non Map Break Non-mapped area is accessed.

Write Protect An attempt has been made to write to a write-protected area.

SFR Illegal An illegal access is made to a peripheral SFR.

Stack Overflow Break due to stack overflow 

Relocation Break A location instruction different from the default setting was 
executed.
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Configuration dialog box

This dialog box is used to display and set the operating environment of the in-circuit emulator.  

This dialog box is automatically displayed after the debugger is started up.  

To use the debugger, the operating environment of the in-circuit emulator must be first set in this dialog

box.  

However, no setting is required to read a project as the results of reading the project file are reflected in

this dialog box.  

For details of the mapping function, refer to "Mapping function (p.20)".

Caution Turn on the power to the target if even one of the following items is set in the

Configuration dialog box.

・・・・ If Target is selected in Voltage (operating power supply selection area).

・・・・ If mapping to Target is specified in Memory Mapping (mapping setting area).

Figure 6-5　Configuration Dialog Box

This section explains the following items:  

• Opening

• Explanation of each area

•  Setting of memory mapping
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• Function buttons

Opening

This dialog box can be opened as follows:

• Automatically opens when the debugger is started up while PM plus is running

• If starting up from PM plus, when using the debugger for the first time for that project

• Select [Option] -> [Configuration...] from the menu bar.
 (or press Alt+O, and C in that order)

Explanation of each area  

The Configuration dialog box consists of the following areas:

(1)　Chip (Emulation CPU selection area)

(2)　 Internal ROM/RAM (internal ROM/internal RAM setting area)

(3)　Location (Location setting area)

(4)　 Information (Information display area)

(5)　Clock (CPU clock source selection area)

(6)　Voltage (operating power supply selection area)

(7)　Mask (mask setting area)

(8)　Memory Mapping (mapping setting area)

(1) Chip (Emulation CPU selection area)

This area is used to select the Emulation CPU.

Only the chip names registered to a registry by the DFINST utility are listed.  

Specify a chip name either from the drop-down list under Name, or directly type in the chip name.

A chip name can be specified only when the debugger is started up.  The chip name selected at the 

previous startup is selected by default.  If the chip name is not stored, the top chip name that is 

registered is selected by default.  

(2) Internal ROM/RAM (internal ROM/internal RAM setting area)

This area is used to set the size of the internal RAM and internal ROM of the emulation CPU.  

Setting of the internal RAM cannot be performed (always dimmed).
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The default value is automatically displayed with "*" suffixed, when Chip is selected.  

To change the size of the internal RAM and internal ROM, select the size from the drop-down list under 

Internal RAM and Internal ROM.  

If the selected size cannot be implemented because of the constraints of the in-circuit emulator, the 

debugger automatically adjusts the size (therefore, a size larger than that previously specified may be 

displayed when the Configuration dialog box is displayed again).  

The settable sizes are as follows: 

Internal ROM:0 to 1024 (in 8KB units)

Caution If the internal ROM size of the selected chip does not match any of the above sizes, that

size will also be displayed on the list.

(3) Location (Location setting area)

This area is used to set the location.

2 locations, 00H or 0fH, can be set.  Select one of them according to the user environment.

(4) Information (Information display area)

This area is not displayed in the Configuration dialog box that appears immediately after the debugger 

is started up.  It is displayed when the Configuration dialog box is opened by selecting from the menu 

after the debugger is started.

.

(5) Clock (CPU clock source selection area)

This area is used to select a clock source to be input to the emulation CPU.  

(MEM) Size (number of bytes) of the mounted emulation memory

(TRC) ON: Trace memory is mounted
OFF: Trace memory is not mounted
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.

(6) Voltage (operating power supply selection area)

Select the power supply to be input to the emulation CPU.

Caution If Target is selected, be sure to connect a target (jig), and at the same time to apply the

same power supply as the target's to the TPI pin.  

If the setting is changed after startup, debugger reset is executed.

(7) Mask (mask setting area)

This area specifies a mask for the signal sent from the target.

The signal of the masked pin is not input to the in-circuit emulator.

Only mask pins when the operation of the target is unstable at the debugging stage.

The only pin whose signal can be masked is the RESET pin.

Internal Uses the clock on the in-circuit emulator as the CPU clock.

External Uses the target clock as the CPU clock. 
If External is selected, correctly set the parts board on the emulation 
board. Also, if External is selected  and the power to the target is OFF, 
"Wrong Target Status (Power Off)" is displayed. 

Internal
(default)

Uses the internal operating power supply of the in-circuit emulator
(The operating voltage is fixed to 5 V.)

Target Uses the target's power supply as the operating power supply.  
(The operating power supply can be varied within the device's 
specification range.) 
If Target is selected and the power to the target is OFF, "Wrong Target 
Status (Power Off)" is displayed.
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(8) Memory Mapping (mapping setting area)

This area is used to set mapping by specifying the memory attribute, and address.  

Memory Attribute (mapping attribute specification)

The following mapping attributes can be selected.  Select a mapping attribute according to the usage  . 

However, in the case of a device without an external space, the External ROM, External RAM, and I/O 

Protect areas cannot be selected. 

Caution The area set as I/O Protect cannot be read unless it has been registered as an I/O port

in the SFR window, or registered in the Watch window. If it is necessary to read this

area, execute a forcible read in these windows.

Mapping Address (mapping address specification)

Specify the address to be mapped.  

Input the higher and lower addresses from the keyboard.

Setting of memory mapping

Specify Memory Attribute and Mapping Address and then click the <Add> button.  

-> The attribute of Memory Attribute, address range of Memory Mapping, and memory mapping 

corresponding to the data of the bus width are set and displayed on a list.  

For mapping attributes other than I/O Protect, the mapping units are adjusted when the <Add> button 

is clicked.   If the mapping unit does not match, the minimum settable range including the specified 

address is mapped.

The mapping unit varies depending on the address to be mapped.  The mapping unit is shown below.

Emulation ROM Selects the in-circuit emulator alternate ROM.

Emulation RAM Selects the in-circuit emulator alternate RAM.

Target Selects the target memory.

I/O Protect Selects the I/O protect area. 
This area can be set only inside the area that is set as Target or 
inside the SFR area.
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The emulation ROM or RAM cannot be mapped at or after address 0x100000.  Perform mapping by 

selecting Target.

Deleting memory mapping

Select mapping to be deleted from the list and click the <Delete> button.  

-> This deletes the selected mapping.  

Function buttons  

Table 6-3　Mapping Unit in Configuration Dialog Box

Mapping Area Mapping Unit

0x000000-0x00ffff 4K byte

0x010000-0x0fffff 64K byte

0x0100000-0xffffff 1M byte

OK Validates the current environment.  
Sets the environment and closes this dialog box.  

Cancel Cancels the changes and closes this dialog box.

Restore Restores the previous environment settings status before this dialog box was 
opened.

Project... Opens the Project File Load dialog box.  If an error occurs while a project file is being 
opened or read, the debugger can no longer continue and is terminated.  

Help Opens the Help window.  
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Extended Option dialog box

This dialog box is used to display and set the extended options of the debugger.  

Figure 6-6　Extended Option Dialog Box

This section explains the following items:  

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

• Select [Option] ->[Extended Option...] from the menu bar. 
(or press Alt+O, and X in that order.)

Explanation of each area

The Extended Option dialog box consists of the following areas:  

(1)　Software Break (software break setting area)

(2)　 Internal RAM Monitor Redraw: (real-time internal RAM sampling time setting area)

(3)　Break Sound (beep sound specification area)

(4)　Flash Self Mode (Flash self mode setting area)

(5)　On Mouse Click (default break selection area)
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(1) Software Break (software break setting area)

This area is used to select whether a software break is used or not.

When using a software break, one vector address of the callt instruction must be released to the 

debugger.

(2) Internal RAM Monitor Redraw: (real-time internal RAM sampling time setting area) 

This area is used to specify the sampling time (msec) for real-time internal RAM sampling.  

The internal RAM area can be sampled in real time during emulation.  

The variables and data allocated to this area can be displayed in close to real time in Watch window 

and Memory window.  

The sampling time can be specified in a range of 0 to 65500 in units of 100 msec.  If 0 is specified, or if 

this area is blank, the sampling time is not displayed in real time.

(3) Break Sound (beep sound specification area)

This area is used to specify whether a beep sound is issued upon the occurrence of a break.  

If the check box is checked, a beep sound is issued when a break occurs (default).

(4) Flash Self Mode (Flash self mode setting area)

This area is used to set the flash self mode (default: Off).

In the flash self mode, since one access event, one execution event, and one event link are reserved, 

the number of the events which can be used decreases.  

When "On" is checked, all events will once become invalid, if at least one event is valid.

(5) On Mouse Click (default break selection area) 

This area is used to select whether a software breakpoint or hardware breakpoint is set as the default 

breakpoint if a breakpoint is set in the point mark area by clicking the mouse button in the Source 

windowor Assemble window.  

Soft Break Sets a software breakpoint
The mark of the breakpoint is displayed in blue.
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Function buttons  

Hard Break Sets a hardware breakpoint
The mark of the breakpoint is displayed in red.

OK Validates the settings and closes this dialog box.  

Cancel Cancels the settings and closes this dialog box.

Restore Restores the previous settings before this dialog box was opened.

Help Opens the Help window.  
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Debugger Option dialog box

This dialog box is used to display and set the extended options of the debugger.  

Figure 6-7　Debugger Option Dialog Box

This section explains the following items:  

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

• Select [Option] -> [Debugger Option...] from the menu bar   
 (or press Alt+O, and G in that order).  

Explanation of each area  

The Debugger Option dialog box consists of the following areas:
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(1)　Source Path (source path specification area)

(2)　Default Extension (default extension specification area)

(3)　Open File History (open file history setting area)

(4)　Font (display font setting area)

(5)　Project File (project file setting area)

(6)　Tool Bar Pictures (toolbar display button setting area)

(7)　Kanji (Kanji code setting area)

(8)　Tab Size (tab size setting area)

(9)　Startup Routine (start-up symbol setting area)

(10)　DisAssemble  (offset display setting area)

(11)　Watch Default (watch symbol setting area)

(1) Source Path (source path specification area)

This area is used to specify the directory in which a source file or text file is searched.  

A path can be input from the keyboard or set by the <Browse...> button.  A relative path can also be 

specified.  

The directory that is the basis of a relative path is displayed on the right of Base:.  The base directory is 

determined in the following sequence:  

•  Directory to which the project file has been loaded  

•  Directory to which a load module or hex file has been loaded last  

•  Current directory of Windows

To delimit paths, use ";" (semicolon) or "," (comma).  

Japanese characters can be specified in a source path (Japanese version only).  

Example: If a source is in the following directory  

B:\src

C:\asm

The source path is specified as follows:

B:\src; C:\asm

Clicking the <Browse...> button displays the Add Source Path dialog box shown in Figure 6-8, and a 

source path can be added.  

Reference Immediately after the Debugger Option dialog box has been opened, the base directory is

selected and opened. When the dialog box is opened the second and subsequent times, the

previously displayed directory is recorded and displayed again.

If the selected directory has already been set for the source path, a source path is not added.  
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Figure 6-8　Add Source path Dialog Box

(2) Default Extension (default extension specification area)  

Delimit extensions with " " (blank),";" (semicolon) or "," (comma).  

(3) Open File History (open file history setting area)  

This area is used to set the number of histories (0 to 10) of the open file displayed in the bottom field of 

the [File] menu.  If 0 is set, no history is displayed on the menu.  

The default value is 4.  

Source File Set the extension of a source file that is displayed when the Browse 
dialog box is opened by selecting [File] -> [Open...] from the menu 
bar.  
The default extension is "*.C, *.S, *.ASM".  

Load Module Set the extension of a load module that is displayed when Download 
dialog box is opened.  
The default extension is "*.LNK, *.LMF".  
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(4) Font (display font setting area)  

This area is used to specify the font displayed on the Source window.  Clicking the <Font> button 

opens the Font dialog box in which the font to be displayed and its size can be set.  

(5) Project File (project file setting area)  

This area is used to set automatic saving and loading of the project file.   

Auto save

Sets whether the project file is automatically saved at the ID78K4-NS termination.  

Auto Load

Sets whether the project file is automatically loaded at the ID78K4-NS start up.  

Load Project File

Specify the project file to be loaded automatically.  

This item can be specified only when On is specified for Auto Load.  

Set a project file name by inputting from the keyboard or clicking the <Browse...> button.  Clicking the 

<Browse...> button displays Browse dialog box.  

On Automatically saves the project file at the ID78K4-NS termination.   

Off Does not automatically save the project file at the ID78K4-NS 
termination.   

Query Displays the Exit Debugger dialog box at the ID78K4-NS termination 
(default).  

On Automatically loads the project file at the ID78K4-NS start up.  
Sets whether the Load Project File is automatically loaded.  

Off Does not automatically loads the project file at the ID78K4-NS start 
up. 
(default)
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(6) Tool Bar Pictures (toolbar display button setting area)  

This area sets the buttons to be displayed on the toolbar.  

(7) Kanji (Kanji code setting area)  

This area is used to specify Kanji codes to be displayed in the Source window and Trace window.  

Kanji codes can be specified only on the Japanese Windows.  

(8) Tab Size (tab size setting area)  

This area is used to set the tab size for each extension when files are displayed.  

Extension

Set an extension.  Input an extension from the keyboard, or select one from the drop-down list.  

Tab Size

Select the tab size.  Select how many spaces are displayed as a tab code.  

Pictures and Text Displays a button on which a graphic and character are displayed.

Pictures only Displays a button with only graphic (default).  

Sjis Uses SJIS as Kanji codes (default).  

Euc Uses EUC as Kanji codes.  

2 Displays two spaces.  

4 Displays four spaces.  

8 Displays eight spaces (default).  
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Tab List

Displays the tab size set for each extension.  

To change the tab size setting,  

select Extension and Tab Size and click the <Add> button.  

The selected tab size is changed to the tab size set in Extension.  

To delete the tab size setting,  

select the setting to be deleted from Tab List and click <Delete> button.  

The setting of the extension currently selected will be deleted.  

(9) Startup Routine (start-up symbol setting area)  

This area is used to specify the first address and end address of the text area (code area) of the start-

up routine by symbols.  

Specify the symbol of the first address as Begin label, and the symbol of the last address as  End label.  

In this way, the source file can be automatically opened if an object file in the load module format is 

downloaded in Download dialog box.  Specify the source file to be displayed at this time as  main( ) 

label, as a display start symbol.  

If the specified symbol is not correct, the source file cannot be opened until the PC reaches the 

address range of the corresponding source file.  In addition, the start-up routine cannot be skipped by 

step execution.  

Caution Be sure to specify this area.  If this area is blank, the dialog box cannot be closed.  

(10) DisAssemble  (offset display setting area)  

Performs the setting for disassemble display.  

Show Offset

Specifies whether an offset (symbol + offset) is displayed during disassemble display.  

When the offset is not displayed, only a symbol that matches a numeric value is displayed, if any.  If no 

matching symbol is found, the numeric value is displayed as a hexadecimal number unchanged.  

Begin label Symbol of first address (default: _@cstart)  

End label  Symbol of end address (default: _@cend)

main() label Display start symbol (default: _main)
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Register Name (register name display selection area)

This area is used to select the method of displaying register names in mnemonics during disassemble 

display.  

(11) Watch Default (watch symbol setting area)  

This area is used to specify a symbol to be watched.  

Size (default size specification)  

Sets the display size of data if [Adaptive] is selected in Watch window.  

Radix (default radix specification)

Sets the default radix in which data is to be displayed if [Proper] is specified in Watch window.  

Show Variable Type (display/non-display of variable type)  

Selects whether the type of a variable is displayed or not.  

Label Specifies whether the offset is displayed in the Label field.  
This check box is not checked in the default condition, and the offset 
is not displayed.  

Mnemonic Specifies whether the offset is displayed in the Mnemonic field.  
This check box is checked in the default condition, and the offset is 
displayed.  

Function Name Displays register names as function names or nicknames.  

Absolute Name Displays register names as absolute names.  

Byte 8-bit display(default)

Word 16-bit display

Double Word 32-bit display

Hex Displays data in hexadecimal numbers (default).

Dec Displays data in decimal numbers.

Oct Displays data in octal numbers.

Bin Displays data in binary numbers.

String Character string

On Displays the type of a variable.
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Language (display/non-display of type of variable)  

Selects the display format of the base number.   

Function buttons

Off Does not display the type of a variable (default).  

C Displays a C-like base number (default).  

ASM Displays an assembly language-like base number.  

OK Validates the settings and closes this dialog box.  

Cancel Cancels the settings and closes this dialog box.

Restore Restores the previous settings before this dialog box was opened.

Help Opens the Help window.  
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Font dialog box

This dialog box is used to select the font to be displayed in the Source window.  

Figure 6-9　Font Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

• Click the <Font> button in Debugger Option dialog box.  

Explanation of each area

The Font dialog box consists of the following areas:

(1)　Font Face: (font name specification area)

(2)　Size: (font size specification area)

(3)　Sample (sample display area)
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(1) Font Face: (font name specification area)

This area is used to select a font from the fonts currently usable.  

Only fonts with equal width (fonts with a constant stroke width and a fixed pitch) are enumerated.  

When a font name is selected from the list, the font name is displayed in the text box, and the font size 

that can be used with that font is displayed under Size.  

(2) Size: (font size specification area)

This area is used to specify the font size.  

On the drop-down list, the font size usable for the font specified in Font Face is displayed in point units.  

When the font size is selected from the drop-down list, the selected font size is displayed in this area.  

The font size can also be directly input to the text box from the keyboard.  

(3) Sample (sample display area)

This area displays a sample character string of the specified font and size.  

Function buttons

OK Changes the font and its size in the Source window as specified, and closes 
this dialog box.

Cancel Closes the dialog box without changing the font.



78 User’s Manual  U16632EJ2V0UM

CHAPTER 6  WINDOW REFERENCE

Project File Save dialog box

Saves the debug environment.

It is used to save a new project file or an existing file with the file name changed (refer to "Setting

Debugging Environment (p.20)").  

When a file is saved, the size and position of the window that has been displayed are also saved.  

Figure 6-10　Project File Save Dialog Box

The following contents are saved to the project file:

Table 6-4　Contents Saved to Project File

Window Name Set Data

Configuration dialog box All items (target device, clock setting, pin mask setting, 
mapping information)  

Main window Display position, tool bar/status bar/button display 
information, execution mode, information, trace on/off 
information, coverage on/off information

Download dialog box File information to be downloaded

Extended Option dialog box, 
Debugger Option dialog box

Set information

Source window Display information, font information of window

Assemble window, 
Memory window

Display information of window, display start address
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This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

• Related operations

•  To automatically save a project file

Opening

This dialog box can be opened as follows:

• Select [File] -> [Project] -> [Save As...] from the menu bar
 (or press Alt+F, J and A in that order).

To save a file of same name as a project file previously loaded or saved

• Select [File] -> [Project] -> [Save...] on the menu bar
 (or press Alt+F, J and S in that order).

Explanation of each area

The Project File Save dialog box consists of the following areas:

(1)　Save in:, File name: (file selection area)

Stack Trace window, 
SFR window, 
Local Variable window, 
Trace window, 
Event Manager, 
Console window, 
Expansion window

Display information of window

Event dialog box Display information of window, event information

Event Link dialog box Display information of window, link event information

Break dialog box Display information of window, break event information

Trace window Display information of window, trace event information

Timer dialog box Display information of window, timer event information 

Register window Display information of window, display bank information 

Watch window Display information of window, watch registration information

Add I/O Port dialog box Added I/O port information  

Software Break Manager Display information of window, software break information

Delay Count dialog box Delay count value

Table 6-4　Contents Saved to Project File

Window Name Set Data
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(2)　Save as type: (extension selection area)

(1) Save in:, File name: (file selection area)

This area is used to specify a file name.  A file name can be directly input from the keyboard, or 

selected from the list at the upper part of this area.  

Up to 64 character string with a extension can be specified.  

(2) Save as type: (extension selection area)

This area is used to specify the extension (.PRJ) of the project file to be loaded.

If the extension is omitted, .PRJ is appended as the default extension.

Function buttons

Related operations

To automatically save a project file

Use Project File (project file setting area) in Debugger Option dialog box that is opened when [Option] 

-> [Debugger Option...] is selected from the menu bar.

Select On for Auto Save in this area.  The current environment will be automatically saved to the 

project file when the dialog box is closed.

Save Saves the project information to the selected file.  After saving, the dialog box is 
closed.

Cancel Closes this dialog box without saving the file.

Help Opens the Help window.
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Project File Load dialog box

This dialog box is used to return the debug environment to the previous environment.  

After a file has been loaded, the size and position of the window is returned to the previous status (status

saved to a project file) (refer to "Setting Debugging Environment (p.20)").  

After a project file has been loaded, it is displayed on the top of an active Source window if any.  

By loading the project file, the items to be saved in Table 6-4  Contents Saved to Project File (p.78) are

set.

Caution If a project file different from the target device after the debugger has been loaded is

loaded, the debugger loads the project file after it has been reset (the debugger is then

used as the target device specified by the project file).  

Figure 6-11　Project File Load Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

• Related operations

•  To automatically load a project file

Opening

This dialog box can be opened as follows:
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• Click the Proj button.

• Select [File] -> [Project] -> [Open...] on the menu bar
 (or press Alt+F, J and O in that order).

Explanation of each area

The Project File Load dialog box consists of the following areas:

(1)　Look In: , File name: (file selection area)

(2)　Files of type: (extension selection area)

(1) Look In: , File name: (file selection area)

This area is used to specify a file name.  A file name can be directly input from the keyboard, or 

selected from the list at the upper part of this area.  

Up to 64 character string with a extension can be specified.  

(2) Files of type: (extension selection area)

This area is used to specify the extension (.PRJ) of the project file to be loaded.  

Function buttons

Related operations

To automatically load a project file

Use Project File (project file setting area) in Debugger Option dialog box that is opened when [Option] 

-> [Debugger Option...] is selected from the menu bar.  

Select On for Auto Load in this area and specify the name of the project file to be loaded automatically 

in the Load Project File area.  The specified project file will be automatically loaded when the system is 

started next time.

Open Loads the selected file.  After loading the file, this dialog box is closed.

Cancel Closes this dialog box without loading the file.

Help Opens the Help window.
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View File Save dialog box

This dialog box is used to save the contents of the current window to a view file or event setting file when

a dialog box is opened.  

Figure 6-12　View File Save Dialog Box
View File Save Dialog Box (Example: to Save Memory Window)

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

• Reference information

•  Regarding files saved in the View File Save dialog box

Opening

This dialog box can be opened as follows:

• When the window to be saved is the current window
Select [File] -> [Save As...] from the menu bar
 (or press Alt+F and A in that order).
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Explanation of each area

This dialog box consists of the following areas:

(1)　Save in:, File name: (file selection area)

(2)　Save as type: (extension selection area)

(3)　Save range (save range setting area)

(1) Save in:, File name: (file selection area)

This area is used to specify a file name.  A file name can be directly input from the keyboard, or 

selected from the list at the upper part of this area.  

(2) Save as type: (extension selection area)

This area is used to specify the type (extension) of the file.

The extension of the file corresponding to the current window is displayed as follows:

(3) Save range (save range setting area)

This area is displayed if the current window to be saved is the Assemble window, Memory window, 

Source window, or Trace window.  

Specify the range of data to be saved by selecting any of the following:

Table 6-5　Extension Corresponding to Current Window

File Type (Extension) Current Window Name

Source Text (*.SVW) Source window

Assemble (*.DIS) Assemble window

Memory (*.MEM) Memory window

Watch(*.WCH) Watch window

Register (*RGW) Register window

SFR (*.SFR) SFR window

Local Variable (*.LOC) Local Variable window

Stack Trace (*.STK) Stack Trace window

Trace (*.TVW) Trace window

Console (*.LOG) Console window

All (*.*) All files
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Specify Line (if current window is Source window)

Specify the range of the line numbers to be saved.  The default radix for inputting a numeric value is 

decimal.  

If the Source window is in the mixed display mode, the mixed displayed part on the specified line is 

also saved.

If a range of 100 lines or more is specified, a message dialog box is displayed to indicate the progress 

of saving.  To stop saving midway, click the <Stop> button in the message dialog box.  

Specify Frame (if current window is Trace window)

Specify the range of trace frames to be saved (for how to specify, refer to "Trace Move dialog box").  

The default radix for inputting a numeric value is hexadecimal.  

If a range of 100 frames or more is specified, a message dialog box is displayed to indicate the 

progress of saving.  To stop saving midway, click the <Stop> button in the message dialog box.  

Specify Address (if current window is Assemble window, Memory window)

This area is used to specify the address range in which data is to be saved to the file.  An address can 

be also specified by a symbol or expression (refer to "Table 6-13  Specifying Symbols (p.112)").  The 

default radix for inputting a numeric value is hexadecimal.  

If a range of 256 bytes or more is specified, a message dialog box is displayed to indicate the progress 

of saving.  To stop saving midway, click the <Stop> button in the message dialog box.  

All Saves the entire range, from the first line to the last line.

Screen shot Saves the area visible on the screen, from the top line on the screen to 
the bottom line.  If the Source window is in the mixed display mode, 
however, the window contents are saved from the source line that 
includes the area visible on the screen.

Specify Line
Specify Frame
Specify Address
above any

Specify the start line and end line of the area to be saved.  If the start line 
and end line are omitted, the first line and last line are assumed.  For 
details, it is as follows.



86 User’s Manual  U16632EJ2V0UM

CHAPTER 6  WINDOW REFERENCE

Function buttons

Reference information

Regarding files saved in the View File Save dialog box

Files are saved in the View File Save dialog box in text format. Therefore, these files can be displayed 

and printed with a regular text editor.  

Save Saves the information of the current dialog box to the selected file.  After 
saving, the dialog box is closed.  

Cancel Closes this dialog box without saving the file.  

Help Opens the Help window.

Restore Restores the status before this dialog box was opened.
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View File Load dialog box

This dialog box is used to read the view file, source file, text file, event setting file, watch setting file, or

SFR setting file saved in the View File Save dialog box, and open a window.

The window to be opened and its status differ as follows, depending on the file to be loaded.

Loading source file to which symbol information has been read

If there is a Source window in the active status, it is opened in the static status; otherwise, the Source 

window is opened in the active status.

Loading source file to which symbol information has not been read, or view file

A window of text-format files is opened in the Source window in the static status.

Caution If an environment file is opened in the View File Load dialog box, it is opened as a text-

format file in a static Source Text window.

Figure 6-13　View File Load Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:
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• Click the Open button.

• Select [File] -> [Open...] on the menu bar
 (or press Alt+F and O in that order, or press Ctrl+O).

Explanation of each area

This dialog box consists of the following areas:

(1)　Look In: , File name: (file selection area)

(2)　Files of type: (extension selection area)

(1) Look In: , File name: (file selection area)

This area is used to specify a file name.  A file name can be directly input from the keyboard, or 

selected from the list at the upper part of this area.  

Up to 64 character string with a extension can be specified.  

(2) Files of type: (extension selection area)

This area is used to specify the type (extension) of the file to be loaded.

Table 6-6　Type of File That Can Be Loaded on View File Load Dialog Box

File Type (Extension) Meaning

Source (*.C, *.S, *.ASM) Source file
The extension of the source (c, s, asm) can be changed in 
Debugger Option dialog box.

Text (*.TXT) Text file

Source Text (*.SVW) Source windowView files

Assemble (*.DIS) Assemble window view files

Watch (*.WCH) Watch window setting files

Memory (*.MEM) Memory window view files

Register (*.RGW) Register window view files

SFR (*.SFR) SFR window setting files

Local Variable (*.LOC) Local Variable window view files

Stack Trace (*.STK) Stack Trace window view files

Trace (*.TVW) Trace window view files

Console (*.LOG) Console window

All (*.*) All files
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Function buttons

Open Loads the selected file.  After loading the file, this dialog box is closed.

Cancel Closes this dialog box without loading the file.

Help Opens the Help window.
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Environment File Save dialog box

This dialog box is used to save the setting contents of the window that was current when this dialog box

was opened (Watch window, SFR window, Event Manager) to an environment file.

Figure 6-14　Environment File Save Dialog Box
Environment File Save Dialog Box (Example: to Save Watch window)

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

• When the window to be saved is the current window
Select [File] -> [Environment] -> [Save As...] from the menu bar
 (or press Alt+F, E and A in that order).

Explanation of each area

This dialog box consists of the following areas:

(1)　Save in:, File name: (file selection area)

(2)　Save as type: (extension selection area)
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(1) Save in:, File name: (file selection area)

This area is used to specify a file name.  A file name can be directly input from the keyboard, or 

selected from the list at the upper part of this area.  

(2) Save as type: (extension selection area)

This area is used to specify the type (extension) of the file.

The extension of the file corresponding to the current window is displayed as follows:

Function buttons

Table 6-7　Extension Corresponding to Current Window

File Type (Extension) Current Window Name

Watch(*.WCH) Watch window

SFR (*.SFR) SFR window

Event(*.EVN) Event Manager

Save Saves the information of the current dialog box to the selected file.  After 
saving, the dialog box is closed.  

Cancel Closes this dialog box without saving the file.  

Help Opens the Help window.

Restore Restores the status before this dialog box was opened.
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Environment File Load dialog box

This dialog box is used to read the Watch window, SFR window, or Event Manager environment file

saved in the Environment File Save dialog box and open a window.

The window to be opened and its status differ as follows, depending on the file to be loaded.

Loading event environment file

The Event Manager is opened, and the event setting contents will return to the previous environment.

Loading watch environment file

The Watch window is opened, and the watch setting contents will return to the previous environment.

Loading SFR environment file

The SFR window is opened, and the peripheral I/O register setting contents will return to the previous 

environment.

Caution If a view file is opened, an "Ff104: Illegal project file format" error occurs.

Figure 6-15　Environment File Load Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons
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Opening

This dialog box can be opened as follows:

• Click the Open button.

• Select [File] -> [Environment] -> [Open...] on the menu bar
 (or press Alt+F, E and O in that order).

Explanation of each area

This dialog box consists of the following areas:

(1)　Look In: , File name: (file selection area)

(2)　Files of type: (extension selection area)

(1) Look In: , File name: (file selection area)

This area is used to specify a file name.  A file name can be directly input from the keyboard, or 

selected from the list at the upper part of this area.  

Up to 64 character string with a extension can be specified.  

(2) Files of type: (extension selection area)

This area is used to specify the type (extension) of the file to be loaded.

Function buttons

Table 6-8　Type of File That Can Be Loaded on Environment File Load Dialog Box

File Type (Extension) Meaning

Watch (*.WCH) Watch window environment files

SFR (*.SFR) SFR window environment files

Event (*.EVN) Event environment file

Open Loads the selected file.  After loading the file, this dialog box is closed.

Cancel Closes this dialog box without loading the file.

Help Opens the Help window.
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Download dialog box

This dialog box is used to select the name and format of a file to be downloaded, and downloads memory

contents to the in-circuit emulator or the target.

If an object file in the load module format has been downloaded, the corresponding source file is

searched, and Source window is automatically opened.

Format of file that can be downloaded

•  NEC load module format (XCOFF (.LNK, .LMF))

•  Intel Hex format (standard, extended)

•  Motorola Hex format S type (S0, S2, S3, S7, S8)

•  Extended Tektronix Hex format

•  Binary data format

Caution If a file other than an object file in the load module format is loaded, source debugging

cannot be executed.

Figure 6-16　Download Dialog Box

This section explains the following items:

• Opening

• Explanation of each area
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• Function buttons

• Cancel processing

Opening

This dialog box can be opened as follows:

• Click the Load button.

• Select [File] -> [Download...] on the menu bar
 (or press Alt+F, and D in that order).

Explanation of each area

(1)　Look In: , File name: (file selection area)

(2)　Files of type: (extension selection area)

(3)　Offset Address: (offset setting area)

(4)　Load (load condition specification area)

(5)　Reset (reset condition specification area)

(1) Look In: , File name: (file selection area)

This area is used to specify a file name.  A file name can be directly input from the keyboard, or 

selected from the list at the upper part of this area.  

Up to 64 character string with a extension can be specified. 

(2) Files of type: (extension selection area)

This area is used to specify the type (extension) of the file to be downloaded.  

The contents displayed on the drop-down list are as follows:  

Reference These are default extensions; other extensions can also be used.  

The default extension of the displayed load module can also be specified under Default

Extension (default extension specification area) in Debugger Option dialog box.  

Table 6-9　Type of File That Can Be Downloaded

Contents (extension) Format

Load Module(*.LNK, *.LMF) Load module format

Hex Format(*.HEX) Hex format (automatic format identification)

Binary Data(*.BIN) Binary data format
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(3) Offset Address: (offset setting area)

This area is used to specify the offset address that is used when a file is loaded (for binary data, 

specify the start address).  An address can be also specified by a symbol or expression (refer to "Table 

6-13  Specifying Symbols (p.112)").  The default radix for inputting a numeric value is hexadecimal.

(4) Load (load condition specification area)

This area is used to set a load condition.  

This setting is valid only if a file in the load module format is specified.  

(5) Reset (reset condition specification area)

This area is used to set a reset condition.  

This setting is valid only if a file in the load module format is specified.  

Function buttons

Symbol Specifies whether symbol information is read (when checked, default) or not.

Object Specifies whether object information is read (when checked, default) or not.

Symbol Specifies whether symbol information is reset (when checked, default) or not.    

CPU Specifies whether the CPU is reset or not (not checked, default).

Open Loads the selected file.  After loading the file, this dialog box is closed.  

Cancel Closes this dialog box without loading the file.

Help Opens the Help window.

Restore Restores the input data to the original status.
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Cancel processing

The following dialog box appears while downloading and the downloading can be cancelled at any time.

The progress of the download is displayed in the dialog box.  

This dialog box is closed automatically after completing downloading.  

If an error occurs during the download, an error message will be displayed in a new window.

Figure 6-17　The Progress of Download
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Upload dialog box

This dialog box is used to set the name and format of the file to which memory contents or coverage

results are to be saved.

Format of specifiable file

•  Intel Hex format (expanded ... 20-bit address)

•  Motorola Hex format (S0, S2, S8 ... 24-bit address)

•  Extended Tektronix Hex format

•  Binary data format

Figure 6-18　Upload Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

• Select [File] -> [Upload...] on the menu bar
 (or press Alt+F, and U in that order).
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Explanation of each area

The Upload dialog box consists of the following areas:

(1)　Save in:, File name:  (saved file name specification area)

(2)　Save as type: (extension selection area)

(3)　Save Address: (save range setting area)

(1) Save in:, File name:  (saved file name specification area)

This area is used to specify a file name.  A file name can be directly input from the keyboard, or 

selected from the list at the upper part of this area.  

Up to 64 characters can be specified including the extension.  

(2) Save as type: (extension selection area)

This area is used to specify the type (extension) of the file.  The format of the data to be saved to the 

file is determined by the extension.

If "All (*. *)" is selected, however, the default Intel extended Hex format is selected.  The contents 

displayed on the drop-down list are as follows:

Reference These are default extensions; other extensions can also be used.  

(3) Save Address: (save range setting area)

This area is used to specify the address range in which data is to be saved to the file.  An address can 

be also specified by a symbol or expression (refer to "Table 6-13  Specifying Symbols (p.112)").  

The default radix for inputting a numeric value is hexadecimal.  

Table 6-10　Type of File That Can Be Uploaded

Contents (extension) Format

Intel Hex (*.HEX) Intel expanded Hex format

Motorola Hex (*.HEX) Motorola Hex format

Tektro Hex (*.HEX) Extended Tektronix Hex format

Binary Data (*.BIN) Binary data format

All (*.*) All files
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Function buttons

Save Saves data in the specified address range to the specified file and closes this 
dialog box.  
Closes this dialog box.  The font of the Source window is changed to the 
specified font face and font size, and then the dialog box is closed

Cancel Closes this dialog box without saving the data to the file.

Help Opens the Help window.

Restore Restores the input data to the original status.
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Browse dialog box

This dialog box is used to select the file to be set in the Source Search dialog box or the Source Text

Move dialog box.  

Reference If this dialog box is opened for the first time after the system has been started up, the

directory first specified by the source path is displayed.  When the dialog box is opened the

second and subsequent times, the previously displayed directory is recorded and displayed

again.  If the <Cancel> button is pressed, however, the previously displayed directory is not

recorded.  

Figure 6-19　Browse Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

• Click the <Browse...> button in the Source Search dialog box or the Source Text Move dialog box.
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Explanation of each area

The Browse dialog box consists of the following areas:

(1)　Look In: , File name: (file selection area)

(2)　Files of type: (extension selection area)

(1) Look In: , File name: (file selection area)

This area is used to specify a file name.  A file name can be directly input from the keyboard, or 

selected from the list at the upper part of this area.  

Up to 64 character string with a extension can be specified.  

(2) Files of type: (extension selection area)

This area is used to specify the type (extension) of the file to be opened.  

Function buttons

Table 6-11　Type of File That Can Be Displayed in Browse Dialog Box

File Type (Extension) Meaning

Source (*.C, *.S, *.ASM) Source file
The extension of the source (c, s, asm) can be changed in Debugger 
Option dialog box.

Text(*.TXT) Text file

All(*.*) All files

Open Sets the selected file.  After setting the file, closes this dialog box.

Cancel Does not set the file and closes this dialog box.

Help Opens the Help window.
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Address Move dialog box

This dialog box is used to specify the address from which displaying memory contents, results of

disassembly, results of coverage, or SFR are to be displayed.  This dialog box is displayed if [View] ->

[Move] is selected from the menu bar while the Memory window, the Assemble window, or the SFR window

is opened, and enables the display start address of data to be changed.

Figure 6-20　Address Move Dialog Box
(Example: When Memory Window Is Open)

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

When the Memory window, Assemble window, or SFR window is opened

• Select [View] -> [Move...] from the menu bar 
(or press Alt+V and V in that order, or press Ctrl+J).

Explanation of each area

The Address Move dialog box consists of the following areas:

(1)　To (address specification area)

(1) To (address specification area)

This area is used to specify an address.  In the default condition, the string selected in the window that 

called this dialog box, the current PC value (Memory window, Assemble window), or blank (SFR 
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window) is displayed.   

An address can be also specified by a symbol or expression (refer to "Table 6-13  Specifying Symbols 

(p.112)").  The default radix for inputting a numeric value is hexadecimal.  

By displaying the input history, the contents previously input can be reused.  

Up to 16 input histories can be recorded.

Function buttons

OK Displays the memory contents, results of disassembly, or SFR.  

Cancel Closes this dialog box.

Restore Restores the input data to the original status.

Help Opens the Help window.
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Source Text Move dialog box

This dialog box is used to specify a file to be displayed in the Source window and the position from which

displaying the file is to be started.  

This dialog box is selected if [View] -> [Move...] is selected from the menu bar while the Source window is

open, and enables the display start position of a file to be changed (a new window is not opened).  

Figure 6-21　Source Text Move Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Specifying

•  Specifying a display start position by an address (or symbol).

•  Specifying a file to be displayed in the Source window

• Function buttons

Opening

This dialog box can be opened as follows:

When the Source window is active

• Select [View] -> [Move...] 
(or press Alt+V and V in that order, or press Ctrl+J).

Explanation of each area

The Source Move dialog box consists of the following areas:

(1)　Option (input mode selection area)

(2)　To (file/address specification area)
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(1) Option (input mode selection area)

This area is used to select the input mode when the display start position is specified.  

(2) To (file/address specification area)

This area is used to specify the file name or address to be displayed.  In the default condition, the 

character string selected in the window that called this dialog box is displayed in this area.  If no 

character string has been selected, the first character string of the input history is displayed.  If no input 

history is available, the current PC is displayed.  As necessary, the character string displayed in this 

area can be changed by directly inputting a character string from the keyboard.  

By displaying the input history, the contents previously input can be reused.  Up to 16 input histories 

can be recorded.

Specifying

On this dialog box, the following two items can be specified.  

• Specifying a display start position by an address (or symbol).

• Specifying a file to be displayed in the Source window

Specifying a display start position by an address (or symbol).

Select Address/Symbol under Option and specify the address from which display is to be started for 

To.  

An address can be also specified by a symbol or expression (refer to "Table 6-13  Specifying Symbols 

(p.112)").  The default radix for inputting a numeric value is hexadecimal.  

Clicking the <OK> button displays the source text so that the source line corresponding to the specified 

address value can be viewed.  

Specifying a file to be displayed in the Source window  

Select Line/File under Option and specify the name of the file to be displayed in the Source window for 

To.  Specification can be mode using only the file name, or using an absolute path or relative path.

If only the file name is specified, or if a relative path is specified, the files in the directory of the source 

path specified in Debugger Option dialog box  are sequentially searched.  The file that is found first as 

a result of searching is displayed.  

Address/Symbol If the display start position is specified by an address (or symbol)  

Line/File If the display start position is specified by a line number (or file name)  
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In addition to a file name, a line number can be also specified as follows:  

<<path name>file name#>line number

Delimit the file name from the line number with "#".  Specify the line number in decimal.  The file name 

may be omitted.  The default radix for inputting a numeric value is hexadecimal.  

Clicking the <OK> button displays the specified file with the specified line number as the first line.  If 

the file name omitted, the file being displayed is displayed starting from the specified line.  If the line 

number is omitted, the file is displayed starting from its first line.

Function buttons

Browse... Opens the Browse dialog box.

OK Starts displaying the source text from the specified position.

Cancel Closes this dialog box.

Restore Restores the input data to the original status.

Help Opens the Help window.



108 User’s Manual  U16632EJ2V0UM

CHAPTER 6  WINDOW REFERENCE

Trace Move dialog box

This dialog box is used to specify the position from which displaying the Trace window is started.  

This dialog box is displayed if [View] -> [Move...] is selected from the menu bar while the Trace window is

open, and enables the display start position of the trace results to be changed.  

Figure 6-22　Trace Move Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

When the Trace window is displayed

• Select [View] -> [Move...] 
(or press Alt+V and V in that order, or press Ctrl+J).

Explanation of each area

The Trace Move dialog box consists of the following areas:

(1)　Frame selection area

(2)　Frame number specification area
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(1) Frame selection area

This area is used to specify the frame at the destination.

(2) Frame number specification area

This area is used to specify a frame number if Frame No. is selected in the frame selection area.  In the 

default condition, the character string selected in the window that called this dialog box or "Last" is 

selected.  As necessary, however, this can be changed by directly inputting a character string from the 

keyboard.  

The default radix for inputting a numeric value is hexadecimal.  

A frame number can also be specified in the following format.  The uppercase and lowercase 

characters of the input character string are not distinguished.  In addition, a frame number can also be 

specified in abbreviated form.  

1st frame of last block Moves the display start position to the to first frame in the newest 
block of trace data.  The display start position is moved to the first 
frame of the trace data when using an in-circuit emulator without a 
block frame.

Trigger frame of last block Moves the display start position to a trigger frame in the newest 
block frame of trace data.

Last frame of last block Moves the display start position to the last frame of trace data.

Frame No. Moves the display start position to the specified frame number.
If 0 is specified, the display start position is moved to the first frame 
of trace data.  
If this item is checked, the focus moves to the text box on the side.  

Table 6-12　Frame Number Specification Format

Specification Abbreviation Contents

+numeric value None Moves backward (downward on screen) the display start 
position from the frame at the cursor by the specified number 
of frames (numeric value).  

-numeric value None Moves forward (upward on screen) the display start position 
from the frame at the cursor by the specified number of 
frames (numeric value).  

Top O Moves the display start position to the first frame of trace 
data.

First S Moves the display start position to the first frame of the 
current trace block.  (Same as when Top is specified when 
using an in-circuit emulator without a block frame.)
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By displaying the input history, the contents previously input can be reused.  Up to 16 input histories 

can be recorded.  

Function buttons

Trigger T Moves the display start position to the trigger frame of the 
current trace block.  

Last L Moves the display start position to the last frame of the 
current trace block.  (Same as when Bottom is specified when 
using an in-circuit emulator without a block frame.)

Bottom B Moves the display start position to the last frame of trace 
data.

OK Starts trace display from the specified position.  

Cancel Closes this dialog box.  

Restore Restores the input data to the original status.  

 Help Opens the Help window.

Table 6-12　Frame Number Specification Format

Specification Abbreviation Contents
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Symbol To Address dialog box

Displays the address of the specified variable or function, or the value of the specified symbol.  

Figure 6-23　Symbol To Address Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

• Select [View] -> [Symbol...] from the menu bar
 (or press Alt+V and Y in that order).

Explanation of each area

The Symbol To Address dialog box consists of the following areas:

(1)　Symbol: (symbol specification and conversion result display areas)  

(2)　Radix (display radix specification area) 

(1) Symbol: (symbol specification and conversion result display areas)

The upper area (symbol specification area) is used to specify the variable, function name, symbol 

name, or line number to be converted.  

In addition, an I/O port name, SFR name, register name, PSW flag name, or expression can be also 

specified.  
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In the lower area (conversion result display area), the variable, address of the function, value of the 

symbol, address of the line number, or value of the expression specified under Symbol is displayed.  

The address value of an I/O port name or SFR name, the register contents of a register name, or flag 

value of a PSW flag name is displayed.  The specification method is indicated below.

Remark var: Variable name, func: Function name, file: File name, label: Label name, bitsym: Bit

symbol name, portname: I/O port name, sfrname: SFR name, regname: Register, pswname:

PSW flag name, no: Line number of source file  

"#" is used as a separator for file names, variables, function names, and line numbers.  

If a specified symbol is not found in the scope, all symbols (static variables, static functions, local 

labels) are searched.  

In the default status, a symbol name takes precedence.  To temporarily change the priority, prefixing 

"$" to a symbol gives the priority to a register name.  

In the default condition, the character string selected in the window that called this dialog box is 

displayed.  As necessary, input data from the keyboard to change the character string.  The default 

radix for inputting a numeric value is decimal.  

To change the contents of the symbol specification area, click the <OK> button.  The conversion result 

will be displayed in the conversion result display area.  

By displaying the input history, the contents previously input can be reused.  Up to 16 input histories 

can be recorded.  

(2) Radix (display radix specification area)

Table 6-13　Specifying Symbols

Conversion Target Specification Method

Variable var
file#var (to specify a static function with file name)
func#var (to specify a static function with function name)
file#var (to specify a static function with file name and function name)

Function func
file#func (to specify a static function with file name)

Label label
file#label(to specify a local label with file name)

Line number of source file prog$file#var
file#no

I/O Port portname

SFR sfrname

Register regname

PSW Flag pswname
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This area is used to specify the radix of the data to be displayed in the conversion result display area.  

Function buttons

Hex Hexadecimal number (default).

Dec Decimal number

Oct Octal number

Bin Binary number

OK If the contents of the symbol specification area have been changed, converts 
the symbol.  
After conversion, closes the dialog box if the contents of the symbol 
specification area have not been changed.  

Cancel Closes this dialog box.

Restore Restores the input data to the original status.  
If the <OK> button has already been clicked, the data is restored to the status 
immediately after the <OK> button was clicked.  

Help Opens the Help window.
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Source window

This window displays source files or text files.  

In Mixed display mode, the program can be disassembled and displayed and online assembly can be

executed while source files are being displayed.  

The Source window that is displaying the source file to which symbol information is read may be in two

statuses: Active Status and Static Status.  

Caution If program codes is described in an include file and these codes are included in multiple

files, the line numbers and addresses do not correspond on a one-to-one bases.  In

such an include file, function that indicates the correspondence relationship between

line numbers and addresses dose not correctly operate.  

Figure 6-24　Source Window

This section explains the following items:  

• Opening

• Explanation of each area

•  Breakpoint setting/deletion function

• Functions often used (right-click menu)

• Function buttons
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• Related operations

Concerning display  

•  Mixed display mode

•  To set a source path

•  To change the display start position

•  To display another source file

•  To specify the default extension of a source file

•  To convert a symbol

•  To specify the symbol of a start-up routine

•  To set an opened file history

•  To set a beep sound to be issued upon break

•  To change the displayed font

•  To change the displayed tab size

Concerning operation 

•  Start function

•  Come function

•  Program counter setting function

•  Jump function

•  Watch function (referencing data value)

•  To search in a source program

•  To set a default breakpoint

•  Drag & drop function (line/address)

•  Drag & drop function (character string)

Opening

This window can be opened as follows:

• This window is automatically opened if the corresponding source file exists after the download module
file has been downloaded.  

• Click the Src button.  

• Select [Browse] -> [Source] from the menu bar 
 (or press Alt+B, and S in that order).

• Select [Jump] -> [Source] from the menu bar 
 (or press Alt+J and S in that order, or press Ctrl+U).

• Click the <Open> button with selecting a source file or text file in the View File Load dialog box.  

Explanation of each area  

The Source window consists of the following areas:

(1)　Point mark area
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(2)　Current PC mark area

(3)　Line number/address display area

(4)　Source text display area

(1) Point mark area 

This area displays the Breakpoint setting/deletion function, Event setting status, and Program code.

Breakpoint setting/deletion function

By clicking this area with the mouse, a breakpoint can be set or deleted.  Whether a hardware 

breakpoint or software breakpoint is to be set or deleted can be selected by the right-click menu of this 

area (or by On Mouse Click in the Extended Option dialog box).   

Setting a breakpoint

A breakpoint can be set on a line for which "*" is displayed in the point mark area (if "*" is not displayed 

for the line, the breakpoint is set on the line above or below the line, whichever has "*" displayed).  

When a breakpoint has been set, 'B (blue: Software break point)', 'B (red: Hardware break point (after 

execution))', 'B (green: Hardware break point (before execution))', or 'B (black: Hardware break point 

(registered but not used))' is displayed.   

If a breakpoint is set on a line on which an event breakpoint has already been set, "A" indicating that 

multiple events have been set is displayed.  

Caution  A software breakpoint cannot be set in an externally mapped ROM area.

Deleting a breakpoint

Click the position at which the breakpoint to be deleted is set.  

If right-click menu -> [Software Breakpoint] is selected, "B (blue: Software break point)" is deleted. If 

right-click menu -> [Breakpoint] is selected, "B (red: Hardware break point)", "B (green: Hardware 

break point (before execution))", and "B (black: Hardware break point (registered but not used))" are 
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deleted.  If another event remains, however, the mark of that event is displayed.  

The 'B' mark is displayed in the following colors, depending on the type and status of the breakpoint.  

A breakpoint becomes valid as soon as it has been set in the point mark area. 

Event setting status

The setting status of various events can be displayed.  

If an execution event or access event is set on the corresponding line, a mark corresponding to the 

type of event is displayed.  

If an address range is specified as the address condition of the event, the lower addresses of the range 

are displayed.  

Table 6-14　Details of Setting/Deleting Breakpoint

Display Status of Line On Mouse Click
[right-click menu] Operation on clicking

Blank or with mark other 
than B

Soft Break
[Software Breakpoint]

Sets a software breakpoint.
Blank
-> Displays  B(blue) mark
Other than B mark
-> Displays A mark (indicating setting 
of two or more events)

Hard Break
[Breakpoint]

Sets a hardware breakpoint
Blank
-> Displays  B(red) mark
Other than B mark
-> Displays A mark (indicating setting 
of two or more events)

With B(blue) mark 
(Software breakpoint 
setting status)

Soft Break
[Software Breakpoint]

Deletes a software breakpoint
-> Blank

Hard Break
[Breakpoint]

Sets a hardware breakpoint
->  Displays A mark (indicating setting 
of two or more events)

With B(red, green, black) 
mark
(Hardware breakpoint 
setting status)

Soft Break
[Software Breakpoint]

Sets a software breakpoint.
->  Displays A mark (indicating setting 
of two or more events)

Hard Break
[Breakpoint]

Sets a software breakpoint
-> Blank

Table 6-15　Display Color of Breakpoint and Its Meaning

Display Color Meaning

B(blue) Software breakpoint is set.

B (red) Valid hardware breakpoint (after execution) is set.

B (green) Valid hardware breakpoint (before execution) is set.
This breakpoint is set, taking precedence over the hardware breakpoint after 
execution.

B (black) Invalid hardware breakpoint is set (registered but not used).
This hardware breakpoint can be validated on the Event Manager or in the 
Break dialog box.
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The mask specification of the address condition is not reflected.

Program code

The line marked '*' in the point mark area indicates that a program code corresponding to the line 

number exists.  This program code is displayed only if a load module has been downloaded and 

symbol information has been read.  

(2) Current PC mark area

The mark '>', which indicates the current PC value (PC register value), is displayed in this area.  

Clicking this mark with the mouse displays a pop-up window that shows the PC register value.  

By double-clicking the current PC mark area, the program can be executed up to a specified line.  

(3) Line number/address display area

This area displays the line numbers of a source file or text file.  

If a Program code corresponding to a line number of the source file exists, the character of the line 

number is displayed in red.  If a program code does not exist, the character of the line number is 

displayed in black.  

In the mixed display mode, disassembled addresses are displayed.  The characters of an address are 

displayed in gray.  

In this area, any position can be selected (highlighted) by clicking the mouse button.  The selected line 

number of an address can be dragged to another window or area, so that its variable value can be 

displayed or the line number of the address can be specified as an event condition (refer to "Drag & 

Table 6-16　Meaning of Event Display Mark

Mark Meaning

E Setting of event condition

L Setting of event for event link condition

B Setting of break event

T Setting of trace event

A Setting of multiple events
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drop function (line/address) (p.125)").  

(4) Source text display area

This area displays source files or text files.  

A data value can be temporarily displayed by selecting (highlighting) a character string and placing the 

mouse cursor over it (Balloon watch function).  

The current PC line and the line on which a breakpoint is set are emphasized for display, as follows:  

In the mixed display mode, the color of only the disassemble display line is changed (the source line is 

displayed in the normal color). 

In this area, the following functions can be used on the line or address on which the cursor is placed 

(start address of program code):  

-> Start function

-> Come function

-> Program counter setting function

-> Jump function

Caution If a Program code does not exist on the source line, the top address of the line above or

below the line on which a program code exists is manipulated by these functions.  

These functions cannot be performed in the following cases.  The corresponding menu

will be dimmed and cannot be selected.  

If a file other than a source file is displayed

While the user program is being executed

A character string selected in this area can be dragged and dropped to another window or dialog box 

(refer to "Drag & drop function (character string) (p.126)").  

Caution Up to 319 characters can be displayed on 1 line.

Functions often used (right-click menu)

In this window, functions that are often used can be selected from the menu that is displayed by clicking

the right mouse button.  In this way, the same function can be used more easily than with the normal

Current PC line
(Yellow)

This line is the source line or disassemble display line corresponding 
to the current PC value (indicated by '>').  
In the mixed display mode, the color of only the disassemble display 
line is changed (the source line is displayed in the normal color).

Breakpoint setting line
 (red)

This line is the source line or a disassemble display line on which a 
valid breakpoint is set (indicated by a 'B' mark in red or green, or 
blue). 
In the mixed display mode, the color of only the disassemble display 
line is changed (the source line is displayed in the normal color).
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procedure.

Note No breakpoint can be set for structure and union members, array members, bit field 
members, etc. In such a case, get the address in the Symbol To Address dialog box and then 
set a breakpoint for that address.

Move... Moves the display position.
Opens the Source Text Move dialog box.  

Mix Turns on/off mixed display of disassembly.  
Checked: Mixed display
Not checked: No display (default)

Add Watch Adds the specified data to the Watch window.
Opens the Add Watch dialog box.  

Symbol Displays the address of the specified variable or function, or the value of 
the specified symbol.  
Opens the Symbol To Address dialog box.  

Break when Access to
this VariableNote

Creates a break event for a read/write access.  

Break when Write to this
VariableNote

Creates a break event for a write access.  

Break when Read from
this VariableNote

Creates a break event for a read access.  

Clear Deletes the selected break event condition.  

Event? Selects a line or variable name. 

Come Here Executes the program from the current PC to the cursor position (Come 
function).

Change PC Sets the address at the cursor position to the PC.  

Break Point Sets or deletes a breakpoint at the cursor position.

Software Break Point Sets a software break point at the cursor position.  

Assemble Disassembles and displays starting from the jump destination address 
specified by the data value at the cursor position.  
Opens the Assemble window.  
If an active Assemble window is open, that window is displayed in the 
forefront (so that it can be manipulated).  

Memory Displays the memory contents starting from the jump destination address 
specified by the data value at the cursor position.  
Opens the Memory window.  
If an active Memory window is open, that window is displayed in the 
forefront (so that it can be manipulated).  
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Function buttons  

Related operations

Mixed display mode

The normal display mode and mixed display mode can be alternately selected by selecting [View] -> 

[Mix] from the menu bar.  

Normal display mode

Search... Opens the Source Search dialog box and searches a character string of the 
source text.  
If a character string is selected in the source text display area, the Source 
Search dialog box is opened to search the character string.  If no character 
string is selected, the Source Search dialog box is opened with nothing 
specified to be searched.  
Specify a search method in the Source Search dialog box.  The result of search 
is highlighted in the Source window.  
This is the same operation as selecting [View] -> [Search...] from the menu bar.  
This button is invalid while the user program is executed.  

<< Searches forward (upward on screen) for the text that satisfies the search 
condition set in the Source Search dialog box, starting from the address at the 
cursor position.  
This button is displayed as the <Stop> button during a search.  
This button is invalid while the user program is executed.  

>> Searches backward (downward on screen) for the text that satisfies the search 
condition set in the Source Search dialog box, starting from the address at the 
cursor position.  
This button is displayed as the <Stop> button during a search.  
This button is invalid while the user program is executed.  

Stop
 (during search)

Stops searching.

Watch Adds the variables selected in the source text display area to the Watch 
window.  If the Watch window is not opened, it is opened.  
If no text is selected in the source text display area, the Watch window is only 
opened.  
This is the same operation as selecting [View] -> [View Watch] from the menu 
bar.  

Quick... Temporarily displays the contents, such as a variable, selected in the source 
text display area in the Quick Watch dialog box.  Opens the Quick Watch dialog 
box.  If no text is selected in the source text display area, the Quick Watch 
dialog box is only opened.  
This is the same operation as selecting [View] -> [Quick Watch] from the menu 
bar.

Refresh Updates the contents of the window with the latest data.  

Close Closes this window.
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In the normal display mode, general text files can be displayed as well as source files.  

Mixed display mode

In the mixed display mode, disassembly of programs combined with source files is displayed and 

online assembly is carried out. (This mode is valid only when a load module is being downloaded and 

symbol information is being read, and the source file that corresponds to the downloaded load module 

is displayed).  

If a program code corresponds to the line of the displayed source file, the disassembly line is displayed 

next to the source line.  In the disassembly line, an address label, a code data, and a disassembled 

mnemonic are displayed (the starting position for display of the mnemonic can be adjusted by the tab 

size setting value).  

To execute online assembly, move the cursor to a mnemonic.  The results of online assembly are also 

reflected in the Memory window.  

The contents displayed in the mixed display mode can be saved as a view file.  

Caution If it scrolls by the cursor key at the time of mixed display mode, excessive scrolling may

occur.

By the cursor key, it may be unable to scroll to the last line.

To set a source path

Set a source path under Source Path (source path specification area) in the Debugger Option dialog 

box that is opened by selecting [Option] -> [Debugger Option] from the menu bar.  

To change the display start position

Change the display start position in the Source Text Move dialog box that is opened when right-click 

menu  -> [Move...] is selected in the Source window.  

To display another source file

Select [File] -> [Open] from the menu bar and specify a file.  

To specify the default extension of a source file

Set a source path under Default Extension (default extension specification area) in the Debugger 

Option dialog box that is opened by selecting [Option] -> [Debugger Option] from the menu bar.  

To convert a symbol

Convert symbols in the Symbol To Address dialog box that is opened when right-click menu -> 

[Symbol...] is selected in the Source window.  
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To specify the symbol of a start-up routine

Specify the symbol of a start-up routine under Startup Routine (start-up symbol setting area) in the 

Debugger Option dialog box that is opened by selecting [Option] -> [Debugger Option...] from the 

menu bar.  If the setting in this area is wrong, the source file cannot be opened.  

To set an opened file history

Set an opened file history under Open File History (open file history setting area) in the Debugger 

Option dialog box that is opened by selecting [Option] -> [Debugger Option...] from the menu bar.  The 

number of a history display of the opened files can be specified in this area.  

To set a beep sound to be issued upon break

Set the beep sound under Break Sound (beep sound specification area) in the Extended Option dialog 

box that is opened by selecting [Option] -> [Extended Option...] from the menu bar.  

To change the displayed font

Change the displayed font in the Font dialog box that can be opened by clicking the <Font...> button in 

the Debugger Option dialog box that is opened when [Option] -> [Debugger Option...] is selected from 

the menu bar.  

To change the displayed tab size

The displayed tab size can be specified for each file extension under Tab Size (tab size setting area) in 

the Debugger Option dialog box that is opened when [Option] -> [Debugger Option...] is selected from 

the menu bar.  

Start function

This function is used to execute the user program from the line on which the cursor is placed.

Method

Move the cursor to the line from which the program is to be executed, and select right-click menu -> 

[Start From Here].  

Come function

This function is used to execute the user program to the line on which the cursor is placed (while the 

user program is being executed in this mode, the break event currently set does not occur).  

Method

Move the cursor to the line on which the break is to occur, and select right-click menu -> [Come Here].  

Program counter setting function

This function is used to set the address of the line on which the cursor is placed to the program counter 

(PC).  

Method

Move the cursor to the line that is to be set to the PC, and select [Run] -> [Change PC] from the menu 

bar.  

Jump function

This function is used to jump to the Memory window,using the selected variable as a jump pointer.  
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The jump destination window will be displayed from the vicinity of the jump pointer.  

1 Select the name of variable as a jump pointer with the mouse.  

2 In the Main window, to jump to the Memory window 

Select [Jump] -> [Memory] from the menu bar.  

 (or press Alt+J and E in that order, or press Ctrl+M).  

• To jump from the Trace window to the Memory window, the jump source address differs as follows,
depending on the cursor position in the trace result display area: 

• To jump from the Register window, move the cursor to a register value.  

• To jump from the Stack Trace window, the jump destination is as follows:  

[With current function]

- If the jump destination is the Source window

 -> Jumps to the current PC line.

- If the jump destination is a window other than the Source window

 -> Jumps to the current PC address. 

[With function other than current function]

- If the jump destination is the Source window 

 -> Jumps to the line that calls a nested function. 

- If the jump destination is a window other than the Source window

 -> Jumps to the address next to the instruction that calls a nested function.

Watch function (referencing data value)

Data values can be displayed as follows: 

To temporarily display a value

The following two methods can be used:

•  Select (highlight) a character string and put the mouse cursor on it then the data value is displayed
(Balloon watch function).  

•  Select (highlight) a character string and click the <Quick> button.  The Quick Watch dialog box will
be opened to display the data value.  

To trace the change of a data value

Register a variable or symbol to the Watch window in either of the following ways: 

•  Select (highlight) the character string whose data value is to be displayed, click the <Watch> button,
or drag the character string to the Watch window and register it to the window (refer to "Drag & drop
function (character string) (p.126)").  

•  Select (highlight) the character string whose a data value is to be displayed and register the data
value from the Add Watch dialog box that is opened when right-click menu -> [Add Watch] is
selected.  

If the cursor is at an access address, access data, or access 
status 

-> Access address 

Other than above -> Fetch address 

To jump to the Source window or Assemble window -> Fetch address 
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To search in a source program

 Use the Source Search dialog box that is opened by clicking the <Search...> button in the Source 

window.  

If the character string to be searched exists in the window, select that character string and click the 

<Search...> button.  The selected character string will be opened in the specified format.  

To set a default breakpoint

Set a default breakpoint under On Mouse Click (default break selection area) in the Extended Option 

dialog box  that is opened when [Option] -> [Extended Option...] is selected from the menu bar.  In this 

way, a default breakpoint that is assumed when the point mark area is clicked can be set.   

Drag & drop function (line/address)

The line number or address selected and highlighted can be dragged to another window or area.  

If the position of the line number or address selected in this area is dragged with the left mouse button, 

the shape of the mouse cursor changes from an arrow to '-'.  When the cursor is moved to the window 

or area in which they can be dropped, the mouse cursor changes to 'OK'.  

In the window in which the line number of the address has been dropped, an operation is performed on 

the dropped address or the address that is obtained from the dropped line number.  The operation to 

be performed after dropping the line number or address differs, depending on the window or area in 

which the line number or address has been dropped.  

Caution The various event setting dialog boxes includes the Event dialog box, Event Link dialog

box, Break dialog box, and Trace dialog box.

Table 6-17　Details of Drag & Drop Function (Line/Address)

Window/Area to Drop to Operation After Drop

The Event Manager or the event 
manager area in each various 
event setting dialog box

Automatically creates an execution event condition by using 
the dropped line number or address as an address condition.  
Event condition names are automatically created as 
Evt00001, Evt00002, and so on.  An external sense data 
condition and pass count are not specified.  
The address condition is set for the closest symbol in the 
format of symbol name + offset value.  

Condition setting area in each 
various event setting dialog box 
(other than address and data 
setting areas)

Automatically creates an execution event condition by using 
the dropped line number or address as an address condition.  
The automatically created event condition is set in each 
condition setting area in which the line number or address has 
been dropped.  
Event condition names are automatically created as 
Evt00001, Evt00002, and so on.  An external sense data 
condition and pass count are not specified.  
The address condition is set for the closest symbol in the 
format of symbol name + offset value.  

Condition setting area in each 
various event setting dialog box 
(address and data setting areas)

The text of the dropped line number or address is set in the 
area in which the line number or address has been dropped.  
The address condition is set for the closest symbol in the 
format of symbol name + offset value.  
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Drag & drop function (character string)

A selected text can be moved to another window or area by dragging and dropping.  

1 If the selected text is dragged by using the left mouse button, the shape of the mouse cursor

changes from an arrow to '-'. 

2 When the cursor is moved to the window or area in which the text can be dropped, the mouse

cursor changes to 'OK'.

The operation to be performed after dropping the text differs, depending on the window or area in 

which the text has been dropped.  

Table 6-18　Details of Drag & Drop Function (Character String)

Window/Area to Drop to Operation After Drop

The Event Manager or the event 
manager area in each various 
event setting dialog box

If the dropped text can be converted as a symbol into an 
address value, an event condition in the Access status (all 
access statuses) or Execute status is automatically created, 
using the converted address value as an address condition.  
Event condition names are automatically created as 
Evt00001, Evt00002, and so on.  An external sense data 
condition and pass count are not specified.
The address condition is set by the dropped text.
The relationship between the event condition to be created 
and the symbol is as follows: 
           Symbol                                     Status      
           Variable                                 Access(R/W)
           Function                                Execute
      Symbol in the data section         Access(R/W)
      Symbol in the code section        Execute
           Other                                     Access(R/W)

Condition setting area in each 
various event setting dialog box 
(other than address and data 
setting areas)

If the dropped text can be converted as a symbol into an 
address value, an event condition in the Access status (all 
access statuses) or Execute status is automatically created, 
using the converted address value as an address condition.  
The automatically created event condition is set in each 
condition setting area in which the line number or address has 
been dropped. 
Event condition names are automatically created as 
Evt00001, Evt00002, and so on.  An external sense data 
condition and pass count are not specified.
The address condition is set by the dropped text.
The relationship between the event condition to be created 
and the symbol is as follows: 
          Symbol                                     Status      
           Variable                                 Access(R/W)
           Function                                Execute
      Symbol in the data section         Access(R/W)
      Symbol in the code section        Execute
           Other                                     Access(R/W)

Condition setting area in each 
various event setting dialog box 
(address and data setting areas)

The dropped text is set in the area. 

Watch window If the dropped text is recognizable as a symbol, the contents 
of the symbol are displayed.



CHAPTER 6  WINDOW REFERENCE

User’s Manual  U16632EJ2V0UM 127

Caution The various event setting dialog boxes includes the Event dialog box, Event Link dialog

box, Break dialog box, and Trace window.  
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Source Search dialog box

This dialog box is used to search for the character string in the Source window.  

By setting each item and then clicking the <Find Next> button, searching can be started.  

By clicking the <Set Find> button, the direction buttons ("<<" and ">>") in the Source windowcan be used

for the search.  

Figure 6-25　Source Search Dialog Box

This section explains the following items: 

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

When Source window is displayed

• Click the <Search> button.  
 (or press Ctrl and G in that order).

• Select [View] -> [Search...]  
 (or press Alt+V, and S in that order).

Explanation of each area

The Source Search dialog box consists of the following areas:

(1)　Find What (search data specification area)

(2)　Match Case (search condition specification area)

(3)　Direction (search direction specification area)
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(1) Find What (search data specification area)

This area is used to specify the data to be searched.  

In the default condition, the character string selected in the window that called this dialog box is 

displayed.  As necessary, input data from the keyboard to change the character string.  

Up to 256 character string can be specified.  

By displaying the input history, the contents previously input can be reused.  Up to 16 input histories 

can be recorded.  

(2) Match Case (search condition specification area)

This area is used to specify whether uppercase and lowercase characters are distinguished, before 

searching is started.  

(3) Direction (search direction specification area)

This area is used to specify the direction of the search.  

Function buttons

Checked Distinguished (default)

Not checked Not distinguished

Up Forward search.
Searches data forward (upward on screen) from the current position 
of the cursor.  

Down Backward search (default).
Searches data backward (downward on screen) from the current 
position of the cursor.  

Find Next Searches the specified data in accordance with a given condition.  
If the specified character string is found as a result of a search, it is highlighted.  
To continue searching, click this button again.  

Set Find Sets the specified condition as the search condition and closes this dialog box.  

Stop
 (during search)

Stops searching.
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Cancel Closes this dialog box.  
This button is displayed as the <Stop> button while data is being searched.  

Help Opens the Help window.  
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Assemble window

This window is used to disassemble and display programs.  It is also used to execute online assembly.  

To execute online assembly, move the cursor to a mnemonic.  The results of online assembly are also

reflected in the Memory window.  

The Assemble window has two statuses: Active Status and Static Status.

Figure 6-26　Assemble Window

This section explains the following items:  

• Opening

• Explanation of each area

• Functions often used (right-click menu)

• Function buttons

• Related operations

• Cautions

Concerning display  

•  To change the display start position

•  To change the displayed offset and register name

Concerning operation 

•  Start function

•  Come function

•  Program counter setting function

•  Jump function

•  To change the disassembled contents

•  Watch function (referencing data value)
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•  To search in the Assemble window

•  To set a default breakpoint

•  Drag & drop function (line/address)

•  Drag & drop function (character string)

Opening

This window can be opened as follows:  

• Click the Asm button.

• Select [Browse] -> [Assemble] from the menu bar 
 (or press Alt+B, and A in that order).

• Select [Jump] -> [Assemble] from the menu bar
 (or press Alt+J and A in that order, or press Ctrl+D).  

Explanation of each area  

The Assemble window consists of the following areas:

(1)　Point mark area

(2)　Current PC mark area

(3)　Address specification area

(4)　Disassemble display area

(1) Point mark area 

This area is displayed the Breakpoint setting/deletion function and the Event setting status.  

(2) Current PC mark area

The mark '>', which indicates the current PC value (PC register value), is displayed in this area.   

By double-clicking the current PC mark area, the program can be executed up to a specified line.  
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(3) Address specification area 

This area displays the disassembly start address.  When this area is clicked, an address highlighted 

and selected.  

This area has the Drag & drop function (line/address) (refer to p.125) and the Trace Result with Linking 

Window (refer to p.34) function.  

Caution The end address (0xFFFFF) is not displayed.

(4) Disassemble display area 

This area displays the labels and code data of addresses, and disassembled mnemonics.  

The current PC line and breakpoint setting line are displayed in different colors for emphasis (refer to 

"Source text display area").  

The disassembled mnemonics displayed in the mnemonic field can be changed (refer to "To change 

the disassembled contents (p.136)").  

If the number of new instruction bytes is less than the number of previous instruction bytes as a result 

of changing, as many 'NOP' instructions as necessary are inserted.  If the number of new instruction 

bytes is more than the number of previous instruction bytes, the next instruction is overwritten.  In this 

case also, as many 'NOP' instructions as necessary are inserted.  The same applies to instructions 

that straddle over source lines.  

In this area, the following functions can be used on the line or address on which the cursor is placed 

(start address of program code):  

-> Start function

-> Come function

-> Program counter setting function

-> Jump Function

A character string selected in this area can be dragged and dropped in another window or dialog box 
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(refer to "Drag & drop function (character string) (p.126)").  

Caution Up to 319 characters can be displayed on 1 line.

Functions often used (right-click menu)

In this window, functions that are often used can be selected from the menu that is displayed by clicking

the right mouse button.  In this way, the same function can be used more easily than with the normal

procedure.

Move... Moves the display position.
Opens the Address Move dialog box.  

Add Watch Adds the specified data to the Watch window.  
Opens the Add Watch dialog box.  

Symbol Displays the address of the specified variable or function, or the value of the 
specified symbol.  
Opens the Symbol To Address dialog box.  

Come Here Executes the program from the current PC to the cursor position (Come 
function).  

Change PC Sets the address at the cursor position to the PC.  

Break Pont Sets or deletes a breakpoint at the cursor position.  

Software Break Point Sets or cancels a software break point at the cursor position.  

Source Text Displays the corresponding source text and source line, using the data value 
at the cursor position as the jump destination address.  
If no line information exists at the jump destination address, however, you 
cannot jump.  
Opens the Source window.  
If an active Source window is open, that window is displayed in the forefront 
(so that it can be manipulated).  

Memory Displays the memory contents starting from the jump destination address 
specified by the data value at the cursor position.  
Opens the Memory window.  
If an active Memory window is open, that window is displayed in the forefront 
(so that it can be manipulated).  
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Function buttons  

Related operations

To change the display start position

Change the display start position in the Address Move dialog box, which is opened when right-click 

menu -> [Move...] is selected in the Assemble window.  

To change the displayed offset and register name

Change the display offset or register name under DisAssemble  (offset display setting area) in the 

Debugger Option dialog box that is opened when [Option] -> [Debugger Option...] is selected from the 

menu bar.  A function name or an absolute name can be selected as a register name.  

Start function

For the operation, refer to "Start function (p.123)" in the Source window.  

Search... Opens the Assemble Search dialog box and searches for a character string of 
mnemonics.  
If a character string is selected in the disassemble display area, the Assemble 
Search dialog box is opened to search for the character string.  If no character 
string is selected, the Assemble Search dialog box is opened with nothing 
specified to be searched.  
Specify a search method in the Assemble Search dialog box.  The result of search 
is highlighted in the Assemble window.  
This is the same operation as selecting [View] -> [Search...] from the menu bar.  

<< Searches forward (upward on screen) for the contents that satisfy the search 
condition set in the Assemble Search dialog box, starting from the address at the 
cursor position.  
This button is displayed as the <Stop> button during a search.  

>> Searches backward (downward on screen) for the contents that satisfy the search 
condition set in the Assemble Search dialog box, starting from the address at the 
cursor position.  
This button is displayed as the <Stop> button during a search.  

Stop
 (during search)

Stops searching.

Watch Adds the symbols selected in the disassemble display area to the Watch window.  
If the Watch window is not opened, it is opened.  
If no text is selected in the disassemble display area, the Watch window is only 
opened.  
This is the same operation as selecting [View] -> [View Watch] from the menu bar.  

Quick... Temporarily displays the contents, such as symbols, selected in the disassemble 
display area on the Quick Watch dialog box.  Opens the Quick Watch dialog box.  
If no text is selected in the disassemble display area, the Quick Watch dialog box 
is only opened.  
This is the same operation as selecting [View] -> [Quick Watch...] from the menu 
bar.

Refresh Updates the contents of the window with the latest data.  

Close Closes this window.
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Come function

For the operation, refer to "Come function (p.123)" in the Source window.  

Program counter setting function

For the operation, refer to "Program counter setting function (p.123)" in the Source window.  

Jump function

For the operation, refer to "Jump function (p.123)" in the Source window.  

To change the disassembled contents

To change the disassembled contents, move the cursor to the mnemonic field (the overwrite and 

insertion modes are alternately selected by pressing the Insert key).  

If an attempt is made to move the cursor to another line after the disassembled contents have been 

changed in the mnemonic field, the new contents are checked.  If the new contents are illegal. the code 

data on the line where the contents have been changed is indicated as '*'.  In this case, the new 

contents are not written to memory even if the cursor is moved to another line.  

The contents changed in the mnemonic field are written into the memory by pressing the Enter key.  

When the Enter key is pressed, the new contents are checked and, if they are illegal, the code data on 

the illegal line is indicated by '*'.  If even one line is illegal, the new contents are not written into the 

memory.  

In this case, correct the contents.  To discard the contents, press the ESC key.  If the contents are 

correct and if the Enter key is pressed, the contents are written into the memory, and then the cursor 

moves to the next line in the mnemonic field, so that the data on the next line can be changed.  

Watch function (referencing data value)

For the operation, refer to "Watch function (referencing data value)" in the Source window.  

To search in the Assemble window

Use the Assemble Search dialog box, which can be opened by clicking the <Search...> button in the 

Assemble window.  If the character string to be searched is existed in the window, select that character 

string and click the <Search...> button.  The selected character string is opened in the specified format.  

To set a default breakpoint

For details, refer to "To set a default breakpoint (p.125)" described in the Source window.  

Drag & drop function (line/address)

For the operation, refer to "Drag & drop function (line/address) (p.125)" in the Source window.  

Drag & drop function (character string)

For the operation, refer to "Drag & drop function (character string) (p.126)" in the Source window.  

Cautions

When moving the display contents forward (upward) by scrolling forward or searching, the contents 

may not be displayed correctly at the boundary between the previously-displayed topmost address and 
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the contents.  In this case, try displaying again from the correct section start address or symbol by 

moving the address.
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Assemble Search dialog box

This dialog box is used to search the contents of Assemble window.  

Successive character strings included in an input character string and disassembler character string are

compared as one blank character.  

By setting each item and then clicking the <Find Next> button, searching can be started.  

By clicking the <Set Find> button, the direction buttons ("<<" and ">>") in the Assemble windowcan be

used for the search.  

Figure 6-27　Assemble Search Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

When Assemble windowis the current window

• Click the <Search> button.  
 (or press Ctrl+G).

• Select [View] -> [Search...]  
 (or press Alt+V, and S in that order).

Explanation of each area

The Assemble Search dialog box consists of the following areas:

(1)　Find What (search data specification area)

(2)　Match Case (search condition specification area)

(3)　Scan Whole Region (search condition specification area)

(4)　Direction (search direction specification area)
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(5)　Address (search range specification area)

(1) Find What (search data specification area)

This area is used to specify the data to be searched.  

In the default condition, the character string selected in the window that called this dialog box is 

displayed.  As necessary, input data from the keyboard to change the character string.  

Up to 256 character string can be specified.  

By displaying the input history, the contents previously input can be reused.  Up to 16 input histories 

can be recorded.  

(2) Match Case (search condition specification area)

This area is used to specify whether uppercase and lowercase characters are distinguished, before 

searching is started.  

(3) Scan Whole Region (search condition specification area) 

This area is used to specify whether the specified range is fully searched or not.

(4) Direction (search direction specification area)

This area is used to specify the direction of the search.  

Checked Distinguished (default)

Not checked Not distinguished

Checked Searches the entire range.

Not checked Searches the remaining part of the range (default)

Up Forward search.
Searches data forward (upward on screen) from the current position 
of the cursor.  

Down Backward search (default).
Searches data backward (downward on screen) from the current 
position of the cursor.  
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(5) Address (search range specification area)

This area is used to specify the address to be searched.  

An address can be also specified by a symbol or expression (refer to "Table 6-13  Specifying Symbols 

(p.112)").  The default radix for inputting a numeric value is hexadecimal.  

Function buttons

Find Next Searches the specified data in accordance with a given condition.  
If the specified character string is found as a result of a search, it is highlighted.  
To continue searching, click this button again.  

Set Find Sets the specified condition as the search condition and closes this dialog box.  

Stop 
(during search)

Stops searching.

Cancel Closes this dialog box.  
This button is displayed as the <Stop> button while data is being searched.  

Help Opens the Help window.  
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Memory window

This window is used to display and change the memory contents.

The display start position when the Memory window is opened is as follows:  

Even while the program is being executed, the range set in the Extended Option dialog box can be

displayed in real time.  

The Memory window has two statuses: Active Status and Static Status.  

Figure 6-28　Memory Window

This section explains the following items:  

• Opening

• Explanation of each area

• Functions often used (right-click menu)

• Function buttons

• Related operations

•  To change the memory contents

•  To change the display start position

•  To search in the Memory window

•  To display ASCII characters

•  To initialize the memory contents with a specified code

First time Display starts from the first address of the real-time RAM sampling area.

Second and subsequent 
times

Display starts from the address at which an active status window was 
closed 
(if an active status window has never been closed, display starts from 
the first display start position).
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•  To copy the memory contents

•  To compare the memory contents

•  To verify and check a memory write

Opening

This window can be opened as follows:

• Click the Mem button.

• Select [Browse] -> [Memory...] from the menu bar 
 (or press Alt+B, and M in that order).

• Select [Jump] -> [Memory...] from the menu bar 
 (or press Alt+J, and M in that order).

Explanation of each area  

The Memory window consists of the following areas:

(1)　Addr (address display area)

(2)　+0 +1 +2....(memory display area)

(3)　0 1 2 3.... (ASCII display area)

(1) Addr (address display area)

This area displays memory addresses. 

Address width changes at the time of memory bank use.

(2) +0 +1 +2....(memory display area)  

This area is used to display and change the memory contents.  

Data into which the current memory contents are to be changed is displayed in red and is actually 

written to the target when the Enter key is pressed.  The contents (displayed in red) can be canceled 

by the ESC key.  Up to 256 bytes can be specified at one time.
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This area is also used as a jump pointer of the jump function.  In addition, it also has the Trace Result 

with Linking Window function.  

(3) 0 1 2 3.... (ASCII display area)

This area is used to display and change the memory contents in ASCII characters.  

This area is displayed when right-click menu -> [Ascii] is selected.  Display of this area can be turned 

on/off by this menu item.  

Data can be changed in this area in the same manner as in the memory display area.  

This area is also used as a jump pointer of the jump function.  

Caution Even if the cursor is placed on this area, once the focus is lost, the cursor position

returns to the memory display area. 

Functions often used (right-click menu)

In this window, functions that are often used can be selected from the menu that is displayed by clicking

the right mouse button.  In this way, the same function can be used more easily than with the normal

procedure.  

Move... Moves the display position.
Opens the Address Move dialog box.  

Bin Displays binary numbers.

Oct Displays octal numbers.

Dec Displays decimal numbers.

Hex Displays hexadecimal numbers (default).

Nibble Displays in 4-bit units.

Byte Displays in 8-bit units (default).

Word Displays in 16-bit units.

Double Word Displays in 32-bit units.

Ascii Turns on/off display of ASCII characters.  
Checked: Displayed
Not checked: No display (default)
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Function buttons  

Related operations

To change the memory contents

To change the memory contents, move the cursor to the memory display area or ASCII display area in 

the window, and write data directly from the keyboard.  The amount of memory contents that can be 

changed at one time is 256 bytes or less.  To set the change, press the return key.  To cancel the 

change, press the ESC key.  

To change the display start position

Use the Address Move dialog box, which can be opened by selecting right-click menu -> [Move] in the 

Memory window.  

To search in the Memory window

Use the Memory Search dialog box, which can be opened by clicking the <Search...> button in the 

Memory window.  If the character string to be searched exists in the window, select that character 

string and click the <Search...> button.  The selected character string is opened in the specified format.  

Non-mapped, SFR, and I/O protect areas are not searched.  

To display ASCII characters

The memory contents are displayed in ASCII characters when right-click menu -> [Ascii] is selected in 

the Memory window.  

To turn off display of ASCII characters, select [Ascii] again to remove the check mark.  

Search... Opens the Memory Search dialog box and searches for character strings from 
the displayed memory contents, or memory contents.  
Selected data (a memory value) is displayed in the Memory Search dialog box 
as data to be searched.  If the Memory Search dialog box is opened without 
data specified, specify data from the keyboard.  
The result of the search is highlighted in the Memory window.  

<< Searches the memory contents satisfying the search condition set in the 
Memory Search dialog box, forward (upward on screen) from the address at the 
cursor position.  
This button is displayed as the <Stop> button during a search.  

>> Searches the memory contents satisfying the search condition set in the 
Memory Search dialog box, backward (downward on screen) from the address 
at the cursor position.  
This button is displayed as the <Stop> button during a search.  

Stop 
(during search)

Stops searching.

Refresh Updates the contents of the window with the latest data.  

Close Closes this window.
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To initialize the memory contents with a specified code

Initialize the memory contents with a specified code in the Memory Fill dialog box, which can be 

opened by selecting [Edit] -> [Memory] -> [Initialize] from the menu bar.  

If verify check is enabled in the Extended Option dialog box, verify check is executed after initialization.  

To copy the memory contents

Copy the memory contents in the Memory Copy dialog box, which can be opened by selecting [Edit] -> 

[Memory] -> [Copy] from the menu bar.  

If verify check is enabled in the Extended Option dialog box, verify check is executed after copy.  

To compare the memory contents

Compare the memory contents in the Memory Compare dialog box, which can be opened by selecting 

[Edit] -> [Memory] -> [Compare] from the menu bar.  

If a difference is found as a result of comparison, the Memory Compare Result dialog box is opened 

and the details are displayed in this dialog box.  

To verify and check a memory write

Use the Extended Option dialog box, which is opened by selecting [Option] -> [Extended Option] from 

the menu bar.  To execute a verify check, check the [Verify] check box.  
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Memory Search dialog box

This dialog box is used to search the memory contents of the part of Memory window at which the cursor

is located.  

If the cursor is in the memory display area, the memory display area is searched for specified data, which

is assumed to be a binary data string.  If the cursor is in the ASCII display area, the ASCII display area is

searched for specified data, which is assumed to be an ASCII character string.  

By setting each item and then clicking the <Find Next> button, searching can be started.  

By clicking the <Set Find> button, the direction buttons ("<<" and ">>") in the Memory window can be

used for the search.  

Non-mapped, SFR, and I/O protect areas are not searched.  

Figure 6-29　Memory Search Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

When Memory windowis the current window

• Click the <Search> button.  
 (or press Ctrl+G).

• Select [View] -> [Search...]  
 (or press Alt+V, and S in that order).
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Explanation of each area

The Memory Search dialog box consists of the following areas:

(1)　Find What (search data specification area)

(2)　Unit (search condition specification area)

(3)　Scan Whole Region (search condition specification area)

(4)　Direction (search direction specification area)

(5)　Address (search range specification area)

(1) Find What (search data specification area)

This area is used to specify the data to be searched.  

In the default condition, the character string selected in the window that called this dialog box is 

displayed.  As necessary, input data from the keyboard to change the character string.  

When searching the memory display area, up to 16 data items can be specified.  Delimit each data 

with a "blank character".  When searching the ASCII display area, data of up to 256 characters can be 

specified.  A "blank character" in the data is treated as a blank character.  

By displaying the input history, the contents previously input can be reused.  Up to 16 input histories 

can be recorded.  

(2) Unit (search condition specification area)

This area is used to specify the number of bits of the data to be searched in the memory display area.  

(3) Scan Whole Region (search condition specification area) 

This area is used to specify whether the specified range is fully searched or not.

Byte Searches the data as 8-bit data (default).

Word Searches the data as 16-bit data.

Double Word Searches the data as 32-bit data.

Checked Searches the entire range.

Not checked Searches the remaining part of the range (default)
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(4) Direction (search direction specification area)

This area is used to specify the direction of the search.  

(5) Address (search range specification area)

This area is used to specify the address to be searched.  

An address can be also specified by a symbol or expression (refer to "Table 6-13  Specifying Symbols 

(p.112)").  The default radix for inputting a numeric value is hexadecimal.  

Function buttons

Up Forward search.
Searches data forward (upward on screen) from the current position 
of the cursor.  

Down Backward search (default).
Searches data backward (downward on screen) from the current 
position of the cursor.  

Find Next Searches the specified data in accordance with a given condition.  
If the specified character string is found as a result of a search, it is highlighted.  
To continue searching, click this button again.  

Set Find Sets the specified condition as the search condition and closes this dialog box.  

Stop
 (during search)

Stops searching.

Cancel Closes this dialog box.  
This button is displayed as the <Stop> button while data is being searched.  

Help Opens the Help window.
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Memory Fill dialog box

This dialog box is used to initialize the memory contents in the Memory window with specified codes.  

Figure 6-30　Memory Fill Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

• Select [Edit] -> [Memory] -> [Fill] from the menu bar.
 (or press Alt+E, M and F in that order).

Explanation of each area

The Memory Fill dialog box consists of the following areas:

(1)　Address (address range specification area)

(2)　 fill code (data specification area)

(1) Address (address range specification area)

This area is used to specify the memory address range whose contents are to be initialized.  

An address can be also specified by a symbol or expression (refer to "Table 6-13  Specifying Symbols 

(p.112)").  The default radix for inputting a numeric value is hexadecimal.  

Input the first address to be initialized and then the last address to be initialized.  
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(2) fill code (data specification area)

This area is used to specify the data with which the memory contents are to be initialized.  

Up to 16 binary data strings (byte data strings) can be specified.  

Delimit each data with a "blank character".  

Function buttons

OK Initializes the memory.  

Stop 
(during initialization)  

Stops initialization.  
While initialization is in progress, the <Cancel> button is replaced by the 
<Stop> button.

Cancel Closes this dialog box.  
While memory contents are being initialized, this button is replaced by the 
<Stop> button.

Restore Restores the input data to the original status.  

Help Opens the Help window.  
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Memory Copy dialog box

This dialog box is used to copy the memory contents in the Memory window.  

Figure 6-31　Memory Copy Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

• Select [Edit] -> [Memory] -> [Copy] from the menu bar.
 (or press Alt+E, M and C in that order).

Explanation of each area

The Memory Copy dialog box consists of the following area:

(1)　Address (address range specification area)

(1) Address (address range specification area)

This area is used to specify the copy source and copy destination addresses.  

An address can be also specified by a symbol or expression (refer to "Table 6-13  Specifying Symbols 

(p.112)").  The default radix for inputting a numeric value is hexadecimal.  
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Function buttons

From Specify the address range of the copy source.  
Input the first address of the copy source and then the end address.

To Specify the first address of the copy destination.

OK Copies the memory.

Stop
(during copying)

Stops copying.
While copying is in progress, the <Cancel> button is replaced by the <Stop> 
button.

Cancel Closes this dialog box.  
While copying is in progress, this button is replaced by the <Stop> button.

Restore Restores the input data to the original status.  

Help Opens the Help window.  
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Memory Compare dialog box

This dialog box is used to compare the memory contents in the Memory window.  

Figure 6-32　Memory Compare Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

• Select [Edit] -> [Memory] -> [Compare] from the menu bar.
 (or press Alt+E, M and P in that order).

Explanation of each area

The Memory Compare dialog box consists of the following area:

(1)　Address (comparison range specification area)

(1) Address (comparison range specification area)

This area is used to specify the comparison source address and comparison destination address.  

An address can be also specified by a symbol or expression (refer to "Table 6-13  Specifying Symbols 

(p.112)").  The default radix for inputting a numeric value is hexadecimal.  
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Function buttons

Mem1 Specify the address range of the comparison source.
Input the first address of the comparison source and then the end address.  

Mem2 Specify the first address of the comparison destination.

OK Compares the memory.  
If no difference is found as a result of comparison, a confirmation dialog box is 
displayed.  If a difference is found, Memory Compare Result dialog box is 
opened.  

Figure 6-33　Confirmation Dialog Box

Clicking the <OK> button ends memory comparison.

Stop
(during comparison)

Stops memory comparison.  
While comparison is in progress, the <Cancel> button is replaced by the 
<Stop> button.

Cancel Closes this dialog box.  
While comparison is in progress, this button is replaced by the <Stop> button.

Restore Restores the input data to the original status.  

Help Opens the Help window.  
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Memory Compare Result dialog box

Displays the result of comparing the memory.  

This dialog box is displayed if any difference is found in the memory contents when the memory has been

compared in Memory Compare dialog box.  

Figure 6-34　Memory Compare Result Dialog Box

This section explains the following items:

• Explanation of each area

• Function buttons

Explanation of each area

The Memory Compare Result dialog box consists of the following area:

(1)　Mem1, Mem2 (comparison result display area)

(1) Mem1, Mem2 (comparison result display area)

This area displays the results of comparing the memory.  Only differences that have been found as a 
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result of comparison are displayed.  

Function buttons

Mem1 Addr Displays a comparison source address in which a difference has been found.  

Memory Displays the data in which a difference has been found.  
Left: Comparison source data
Right: Comparison destination data

Mem2 Addr Displays the comparison destination address at which a difference has been 
found.  

Close Closes this dialog box.  

Help Opens the Help window.  



CHAPTER 6  WINDOW REFERENCE

User’s Manual  U16632EJ2V0UM 157

Watch window

This window is used to display and change specified data.  

The result of updating and rewriting data in this window will be reflected in the Memory window.  

This window can also display wide-ranging data (such as global variables and public symbols) in real time

even during program execution, in the same way as the Memory window.  

To set a breakpoint for read/write access to a variable can be performed by a single action from the menu

that is displayed by clicking the right mouse button.  

Caution If a local variable and a global variable exist with the same name, the local variable

takes priority. 

Figure 6-35　Watch Window

This section explains the following items:  

• Opening

• Explanation of each area

• Functions often used (right-click menu)

• Function buttons

• Related operations

•  To add/delete displayed data (variable)

•  To change data on the selected line

•  To temporarily display a data (variable) value

•  To display/change a local variable value

•  To set a breakpoint for read/write access to a variable

•  To change displayed radix/size
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Opening

This window can be opened as follows:

• Click the Wch button.
Select [Browse] -> [Watch] from the menu bar, 
(or press Alt+B, and W in that order).  

Select data in the Source window or Assemble window, 

• Select [View] -> [View Watch] from the menu bar,
 (or press Alt+ V, and I in that order),  
or click the <Watch> button.  

In the Quick Watch dialog box or Add Watch dialog box dialog box,

• Click the <Add> button.

Explanation of each area  

The Watch window consists of the following areas:

(1)　Left field (symbol name display area)

(2)　Right field (data value display/setting area)

(1) Left field (symbol name display area) 

This area is used to display variable names, symbol names and types, and tag names of structures or 

unions.

Refer to "Name (symbol specification area)" in the Add Watch dialog box for details on the displayed 

contents.  

'+' is prefixed to the displayed arrays, pointer variables, and structures or unions.  These variables are 

expanded and displayed as follows when they are double-clicked:

Array All the elements of the variable are displayed in accordance with the type 
of the array variable.
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'+' of the variable that has been expanded and displayed changes to '-'.  If the variable is double-

clicked in this status, the expanded display is canceled.  Expanded display can be also specified or 

canceled by selecting a variable with the arrow keys and then pressing the Enter key.  

If an access breakpoint is set for a variable or a symbol in the Watch window, the symbol name display 

area is highlighted in gold.  

Caution Up to 319 characters can be displayed on 1 line.

Reference If an array has too many variables and takes too long to expand, a warning message is

displayed.  

(2) Right field (data value display/setting area)

This area is used to display and change data values.  

A value is updated when execution is stopped.  To save a value, select [File ] -> [Save As...] from the 

menu bar when the Save window is the current window.  This area is blank if getting data has failed.  

'?' is displayed for data that has been invalidated because of a change in the scope or optimized 

compiling.  The contents of the change are written into the target when the Enter key is pressed.  The 

previous value can be canceled by the ESC key.  

The display format is as follows:  

Pointer variable The data indicated by the pointer is displayed.

Structure/union All the members of the structure/union are displayed in accordance with 
the type of the member variable. 
If a structure or union is defined in the structure or union, the structure 
name or union name of the internal structure or union is also displayed.
The internal structure or union can be also expanded by using '+'.
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The size and radix of a data value can be specified on the [View] menu for each variable.  

However, the display size cannot be selected if the display size is fixed, such as for variables in C or bit 

symbols or registers of the assembler.  

If [View] -> [Adaptive] or [View] -> [Proper] from the menu bar is selected, the size and radix specified 

in the Debugger Option dialog box are used for display (refer to "To change displayed radix/size").  

Functions often used (right-click menu)

In this window, functions that are often used can be selected from the menu that is displayed by clicking

the right mouse button.  In this way, the same function can be used more easily than with the normal

procedure.  

Table 6-19　Data Display Format (Watch-Related) 

Display Data Contents

Integer Displayed in the same manner as the language specified in the 
Debugger Option dialog box.  
C-like (value: xxxx)
Hexadecimal (0xxxxx)
Decimal (xxxx)
Octal (0xxxx)
Binary (0bxxxx)
Assembly language-like  (value: xxxx)
Hexadecimal (xxxxH) 
Decimal (xxxxT)
Octal (xxxxQ)
Binary (0bxxxxY)

Enumeration type Member name

If scope is specified Displayed in accordance with specified scope

Floating-point type Single precision/double precision supported
The input/display format is as follows:  
[ + | - ] inf
[ + | - ] nan
[ + | - ] integer e [ + | - ]exponent
[ + | - ] integer.fraction [e [ + | - ]exponent

Break when Access
to this VariableNote

Creates a break event that occurs if the selected variable is accessed for 
read/write.  

Break when Write to
this VariableNote

Creates a break event that occurs if the selected variable is accessed for 
write.

Break when Read
from this VariableNote

Creates a break event that occurs if the selected variable is accessed for 
read.

Clear Deletes the break event corresponding to the selected variable.   

Event? Displays the event information of the line at the cursor position or the 
selected variable.  
If an event is set, Event dialog box is opened.  
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Note No breakpoint can be set for structure and union members, array members, bit field members, 
etc. In such a case, get the address in the Symbol To Address dialog box and then set a 
breakpoint for that address. 

Function buttons  

Change Watch... Changes the selected data.

Delete Watch Deletes the selected watch point from the window.  

Bin Displays the selected line in binary numbers.

Oct Displays the selected line in octal numbers.

Dec Displays the selected line in decimal numbers.

Hex Displays the selected line in hexadecimal numbers.

String Displays the selected line as a character string.

Proper Displays the selected line as the default value of each variable.
Symbols are displayed in accordance with the setting of Debugger Option 
dialog box (default).

Byte Displays the selected line in 8-bit units.

Word Displays the selected line in 16-bit units.

General Displays the selected line in 24-bit units.

Double Word Displays the selected line in 32-bit units.

Adaptive Displays the selected line as the default value of each variable.
Only this item is valid for a symbol in C language.
Symbols in assembly language are displayed in accordance with the setting 
of Debugger Option dialog box (default).  

Up Moves the selected line one line up.

Down Moves the selected line one line down.

Add... Opens the Add Watch dialog box.  
If data is specified and the <Add...> button is clicked in the Add Watch dialog 
box, the specified data is added to the Watch window.  

Delete Deletes the specified data from the Watch window.
The DEL key performs the same operation.

Up Moves the selected data one line up.

Down Moves the selected data one line down.

Refresh Updates the contents of the window with the latest data.  

Close Closes this window.
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Related operations

To add/delete displayed data (variable)

Addition method (any of the following)

•  Select a variable name or symbol name and click the <Watch> button in the Source window or
Assemble window.

•  Select a variable name or symbol name in the Source window or Assemble window, and drag it to
the Watch window.

•  Specify a variable name or symbol name and click the <Add> button in the Quick Watch dialog box
or Add Watch dialog box.

Deletion method

•  Click a variable name or symbol name (two or more variable or symbol names can be selected
using the Shift or Ctrl key), and click the <Delete> button.  A line with an expanded hierarchy, such
as the elements of an array, and members of structures and unions cannot be changed.  

To change data on the selected line

To change data (variables), select a line to be changed in the Watch window and select right-click 

menu -> [Change Watch...].  The Change Watch dialog box will be opened to change the data.  

A line with an expanded hierarchy, such as the elements of an array, and members of structures and 

unions cannot be deleted.  

To temporarily display a data (variable) value

A data (variable) value can be temporarily displayed in the following two ways:

To display using the balloon watch function

Select data (a variable name) in the Source window or Assemble window.  Then place the mouse 

cursor on the selected character string.  The value of the selected data will be displayed.  

To display in the Quick Watch dialog box

Select data (a variable name) in the Source window or Assemble window.  Then click the <Quick...> 

button.  The value of the selected data will be displayed in the Quick Watch dialog box.

To display/change a local variable value

A local variable value can be checked or changed in the Local Variable window, which is opened when 

the Loc button is clicked.  

In this window, the local variable in the current function is automatically displayed and the displayed 

variable cannot be added or deleted.  

To change a local variable value, move the cursor to the local variable value display/changing area on 

the window and write a value in this area directly from the keyboard.  

To determine the displayed contents, use the Enter key.  To cancel, use the ESC key.

To set a breakpoint for read/write access to a variable 

Select a variable in the Watch window and select [Break when Access to this Variable], [Break when 

Write to this Variable] or [Break when Read from this Variable] from the right-click menu.  In this way, a 

hardware break event will be created in the valid status in accordance with the selected item.  

Whether the event has been correctly created can be confirmed on the Event Manager.  
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To change displayed radix/size

Changing each data (variable) at any time

Select a data (variable) name to be changed in the Watch window or Quick Watch dialog box, and 

select the radix and size from the right-click menu.  

Specifying default condition

Adaptive (when display size is specified) or Proper (when display radix is specified) for watching a 

symbol that specifies a default value can be set as the default assumption.  

This is done in the Watch Default area of the Debugger Option dialog box, which is opened when 

[Option] -> [Debugger Option...] is selected from the menu bar.  

The size specified under Size is displayed when Adaptive is specified, and the radix specified under 

Radix is displayed when Proper is specified.  
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Quick Watch dialog box

This dialog box is used to temporarily display or change specified data.  

Figure 6-36　Quick Watch Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:  

• Select [View] -> [Quick Watch...]  
 (or press Alt+V, and Q in that order).  

• Click the <Quick> button in Source window.
 (or press Ctrl+W).

• Click the <Quick> button in Assemble window.
 (or press Ctrl+W).

Explanation of each area  

The Quick Watch dialog box consists of the following areas:

(1)　Name (symbol specification area)

(2)　Symbol name display area

(3)　Data value display/setting area

(4)　Display radix selection area (upper left field)
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(5)　Display size selection area (second upper left field)

(6)　Number (display number specification area)

(1) Name (symbol specification area)  

This area is used to specify the data to be displayed.

In the default condition, the character string selected in the window that called this dialog box is 

displayed.  As necessary, input data from the keyboard to change the character string.  This area is 

blank if no character string is selected.  

By displaying the input history, the contents previously input can be reused.  Up to 16 input histories 

can be recorded.  

If the contents of Name have been changed, the data specified in Name can be displayed in the field 

below by clicking the <View> button.  

(2) Symbol name display area

This area is used to display the variable name and the symbol name.  

The displayed contents are the same as those of Name (symbol specification area) in the Add Watch 

dialog box.  

Caution Up to 319 characters can be displayed on 1 line.

(3) Data value display/setting area  

This area is used to display and change data values.  The displayed contents and display method are 

the same as those of Watch window.  

The displayed contents are the same as those of Right field (data value display/setting area) in the 

Watch window.  
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(4) Display radix selection area (upper left field)  

This area is used to select the display radix.

The display radix of the data name selected in the symbol name display area will be changed.  

(5) Display size selection area (second upper left field)

This area is used to select the display size.  

The display size of the data selected in the symbol name display area will be changed.   

If the display size is fixed, such as when a variable in C or register is to be displayed, it cannot be 

changed.  

(6) Number (display number specification area)

This area is used to specify the number of data to be displayed.  

Specify blank or a number of 1 to 256.  

If this area is blank, data is displayed as a simple variable.  

If a number of 1 or more is specified, data is displayed as an array variable.  

If an array variable is displayed, '+' is prefixed to the data.  By double-clicking this '+', all the elements 

of the data are expanded and displayed in accordance with the type of the data ('-' is prefixed to the 

Proper Variable
The default value of each variable is displayed.  
Symbol
Displays data with the radix set in Debugger Option dialog box.  

Hex Displays data in hexadecimal numbers (0xxxxx)  

Dec Displays data in decimal numbers (xxxx)

Oct Displays data in octal numbers (0xxxx)

Bin Displays data in binary numbers (0bxxxx)

String Displays character strings.

Adaptive Variable
The default value of each variable is displayed.  
Symbol
Displays data with the size set in Debugger Option dialog box.  

Byte Displays data in 8 bits.

Word Displays data in 16 bits.

General Displays data in 24 bits.

Double Word Displays data in 32 bits.
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expanded data.  If this '-' is double-clicked, the expanded display is canceled).  

If the number of data to be displayed is fixed, such as when a variable in C or register is to be 

displayed, the specified number of data is invalid.  

Function buttons

View Displays the data specified in Name in the field below.  

Add Displays the data specified in Name to the Watch window.  

Close Closes this dialog box.  
Data that has not actually been written to the target will be canceled.  
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Add Watch dialog box

This dialog box is used to register data to be displayed in the Watch window.  

Multiple data with the same symbol name can be registered. 

Figure 6-37　Add Watch Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:  

• Select [View] -> [Add Watch...] from the menu bar   
 (or press Alt+V, and W in that order).  

• Click the <Add> button in Watch window.  

Explanation of each area  

The Add Watch dialog box consists of the following areas:  

(1)　Name (symbol specification area)

(2)　Radix (display radix selection area)

(3)　Size (display size specification area)

(4)　Number (display number specification area)
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(1) Name (symbol specification area)  

This area is used to specify data to be added to the Watch window.  

In the default condition, the character string selected in the window that called this dialog box is 

displayed.  As necessary, input data from the keyboard to change the character string.  This area is 

blank if no character string is selected.  

By displaying the input history, the contents previously input can be reused.  Up to 16 input histories 

can be recorded.  

The format in which a variable can be input and how a variable is handled when a scope is specified 

are as follows:  

•  Variable Name

Variable expression : Variable Name

|Variable expression[Constant value | Variable Name]      Elements of array

|Variable expression . Member name         Entity members of structure/union  

|Variable expression -> Member name       Members of structure/union indicated by pointer 

|*Variable expression                                  Value of pointer variable  

|&Variable expression                                 Address where variable is located 

•  Register name

•  SFR name, SFR bit name

•  Label and address of immediate value

•  Register name . bit

•  Label name . bit , address of immediate value . bit

•  Specification of scope

Scope Specification Program name File name Function name Variable 
Name

prog$file#func#var prog file func var

prog$file#var prog file Global var

prog$func#var prog Global func var

prog$var prog Global Global var

file#func#var Current file func var

file#var Current file Global var

func#var Current Current func var

var Current Current Current var
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(2) Radix (display radix selection area)

This area is used to change the radix of the data to be displayed.  

(3) Size (display size specification area)

This area is used to change the size of data to be displayed.  

If the display size is fixed, such as when a variable in C or a bit symbol or register of the assembler is 

to be displayed, it cannot be changed.  

(4) Number (display number specification area)

This area is used to specify the number of data to be displayed.  

Specify blank or a number of 1 to 256.  

If this area is blank, data is displayed in Watch window as a simple variable.  

If a number of 1 or more is specified, data is displayed in the Watch window as an array variable.  

The maximum number of lines that can be displayed in the Watch window is 10,000.

If an array variable is displayed, '+' is prefixed to the data.  By double-clicking this '+', all the elements 

of the data are expanded and displayed in accordance with the type of the data ('-' is prefixed to the 

Proper Variable
The default value of each variable is displayed.
Symbol
Displays data with the radix set in Debugger Option dialog box.

Hex Displays data in hexadecimal numbers (0xxxxx)

Dec Displays data in decimal numbers (xxxx)

Oct Displays data in octal numbers (0xxxx)

Bin Displays data in binary numbers (0bxxxx)

String Displays character strings.

Adaptive Variable
The default value of each variable is displayed.
Symbol
Displays data with the size set in Debugger Option dialog box.

Byte Displays data in 8 bits.

Word Displays data in 16 bits.

General Displays data in 24 bits.

Double Word Displays data in 32 bits.
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expanded data.  If this '-' is double-clicked, the expanded display is canceled).  

If the number of data to be displayed is fixed, such as when a variable in C or register is to be 

displayed, the number of data is invalid in the Watch window even if it has been changed.  

Function buttons

Add Adds the specified data to the Watch window.  
The dialog box remains open.

OK Adds the specified data to the Watch window.  
Closes this dialog box.  

Cancel Closes this dialog box.  

Restore Restores the input data to the original status.  

Help Opens the Help window.  
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Change Watch dialog box

This window is used to change the data on a line selected in the Watch window.  

A line with an open hierarchy, such as the elements of an array, and members of structures and unions

cannot be changed.  

When watch data is changed, the contents of the selected line are replaced with the new data.  

The symbol name can be changed even if it results in duplication of a name already in use with existing

data.

Figure 6-38　Change Watch Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

When the Watch window is open or a line is selected  

• Select [View] -> [Change Watch...] from the menu bar   
 (or press Alt+V, and G in that order).

Explanation of each area  

The Change Watch dialog box consists of the following areas:

(1)　Name (symbol specification area)

(2)　Radix (display radix selection area)

(3)　Size (display size specification area)

(4)　Number (display number specification area)
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(1) Name (symbol specification area)  

This area is used to change a symbol name.

By displaying the input history, the contents previously input can be reused.  Up to 16 input histories 

can be recorded.  

The format in which a symbol name can be input is the same as that of Name (symbol specification 

area) in the Add Watch dialog box.  

(2) Radix (display radix selection area)

This area is used to change the radix of data to be displayed.  

(3) Size (display size specification area)

Displays and modifies variables.  

If the display size is fixed, such as when a variable in C or register is to be displayed, it cannot be 

changed.  

Proper Variable
The default value of each variable is displayed.  
Symbol
Displays data with the radix set in Debugger Option dialog box.  

Hex Displays data in hexadecimal numbers (0xxxxx)  

Dec Displays data in decimal numbers (xxxx)

Oct Displays data in octal numbers (0xxxx)

Bin Displays data in binary numbers (0bxxxx)

String Displays character strings.

Adaptive Variable
The default value of each variable is displayed.  
Symbol
Displays data with the size set in Debugger Option dialog box.

Byte Displays data in 8 bits.

Word Displays data in 16 bits.

General Displays data in 24 bits.

Double Word Displays data in 32 bits.
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(4) Number (display number specification area)

This area is used to specify the number of data to be displayed.  

Specify blank or a number of 1 to 256.  

If this area is blank, data is displayed in Watch window as a simple variable.  

If a number of 1 or more is specified, data is displayed in the Watch window as an array variable.  

The maximum number of lines that can be displayed in the Watch window is 10,000.

If an array variable is displayed, '+' is prefixed to the data.  By double-clicking this '+', all the elements 

of the data are expanded and displayed in accordance with the type of the data ('-' is prefixed to the 

expanded data.  If this '-' is double-clicked, the expanded display is canceled).  

f the number of data to be displayed is fixed, such as when a variable in C or register is to be 

displayed, the number of data is invalid in the Watch window even if it has been changed.  

Function buttons

Add Cannot be selected.

OK Replaces the registration contents currently selected with the specified data, 
and then closes this dialog box.  
Closes this dialog box.  

Cancel Closes this dialog box.  

Restore Restores the input data to the original status.  

Help Opens the Help window.  
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Local Variable window

This window is used to display and change the local variable in the current function.  

This window automatically displays the local variable in the current function.  It is linked with the jump

function of the Stack Trace window, and displays the local variable in the function jumped when jumping to

the Source window.  Variables cannot be added or deleted.  

Figure 6-39　 Local Variable Window,

This section explains the following items:  

• Opening

• Explanation of each area

• Functions often used (right-click menu)

• Function buttons

Opening

This window can be opened as follows:

• Click the Loc button.

• Select [Browse] -> [Local Variable] from the menu bar,  
 (or press Alt,+B, and L in that order).  

Explanation of each area  

The Local Variable window consists of the following areas:

(1)　Left field (local variable name display area)

(2)　Right field (local variable value display/setting area)
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(1) Left field (local variable name display area) 

This area displays local variable name.  

Auto, internal Static, and Register variables can be displayed.  

The display format is the same as that of the Watch window.

This area cannot be edited directly.  

Caution Up to 319 characters can be displayed on 1 line.

(2) Right field (local variable value display/setting area)

This area displays local variable values.  

The display format of the variable value is the same as that of the Watch window.

The display radix of variables can be switched by the menu selection in accordance with each variable.  

The new value is written into the target when the Enter key is pressed.  The previous value can be 

canceled by the ESC key.  

Functions often used (right-click menu)

In this window, functions that are often used can be selected from the menu that is displayed by clicking

the right mouse button.  In this way, the same function can be used more easily than with the normal

procedure.  

Add Watch Registers a selected character string to the Watch window.
Opens the Add Watch dialog box.  
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Function buttons  

Bin Displays the selected line in binary numbers.

Oct Displays the selected line in octal numbers.

Dec Displays the selected line in decimal numbers.

Hex Displays the selected line in hexadecimal numbers.

String Displays the selected line as a character string.

Proper Displays the selected line as the default value of each variable.
Symbols are displayed in accordance with the setting of Debugger 
Option dialog box (default).

Refresh Updates the contents of the window with the latest data.  

Close Closes this window.
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Stack Trace window

This window is used to display or change the current stack contents of the user program.  

From this window, you can also jump to the Source window, Assemble window, and Memory window

corresponding to the stack contents. 

Caution The stack trace display function may not operate correctly if there is a frame pointer in

a stack (function that does not push WHL (noauto, norec function, etc.)), or if the -qf

option has been set as an optimization option during compiling.  In addition, [ERROR]

may be displayed during prologue or epilogue processing of a function.

Figure 6-40　Stack Trace Window

This section explains the following items:  

• Opening

• Explanation of each area

• Functions often used (right-click menu)

• Function buttons

Opening

This window can be opened as follows:

• Click the Stk button.

• Select [Browse] -> [Stack Trace] from the menu bar, 
 (or press Alt+B , and K in that order).
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Explanation of each area  

The Stack Trace window consists of the following areas:

(1)　Left field (stack frame number display area)

(2)　Center field (stack frame contents display area)

(3)　Right field (stack contents display/setting area)

(1) Left field (stack frame number display area)

This area assigns numbers to and displays the stack contents.  

A stack frame number is a natural number starting from 1.  The shallower the nesting of the stack, the 

higher the number.  This means that a function having stack number one higher than that of a certain 

function is the function that calls the certain function.  

(2) Center field (stack frame contents display area) 

This area displays the stack frame contents.

It displays function names or local variable names.  Note, however, that this area cannot be directly 

edited.  

If the stack contents consist of a function, they are displayed as follows: 

 program name$file name#function name (argument list) #line number

If this line is double-clicked, the operation will be the same as jumping to the Source window of the 

jump function (i.e., the local variable in the function to which execution has jumped will be displayed in 

the Local Variable window).  

If the function has a local variable, the local variable will be displayed on the next and subsequent 

lines.  

If the stack contents consist of a local variable, its type and name are displayed.  These are displayed 

in the same manner as in the Watch window.  Note that the internal Static and Register variables are 
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not displayed.  

Caution Up to 319 characters can be displayed on 1 line.

(3) Right field (stack contents display/setting area)

This area is used to display or change the stack contents.  

'-' or a local variable value is displayed.  If the stack contents are a function '-' is displayed and the 

function cannot be changed.  

If the stack contents are a local variable, the variable value is displayed in the same manner as in the 

Watch window.  

The display radix of variables can be switched by the menu selection in accordance with each variable.  

A variable value can be changed.  The new value is written into the target when the Enter key is 

pressed.  The previous value can be canceled by the ESC key.  

This area is used as the jump source area of the jump function.

Functions often used (right-click menu)

In this window, functions that are often used can be selected from the menu that is displayed by clicking

the right mouse button.  In this way, the same function can be used more easily than with the normal

procedure.  

Bin Displays the selected line in binary numbers.

Oct Displays the selected line in octal numbers.

Dec Displays the selected line in decimal numbers.

Hex Displays the selected line in hexadecimal numbers.

String Displays the selected line as a character string.

Proper Displays the selected line as the default value of each variable.
Symbols are displayed in accordance with the setting of Debugger Option dialog 
box (default).
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Function buttons  

Source Text Displays the corresponding source text and source line from the jump 
destination address specified by the data value at the cursor position (the local 
variable in the function to which you have jumped is displayed in the Local 
Variable window).  
If no line information exists at the jump destination address, however, you 
cannot jump.  
Opens the Source window.  
If an active Source window is open, that window is displayed in the forefront (so 
that it can be manipulated).  

Assemble Disassembles and displays starting from the jump destination address specified 
by the data value at the cursor position.  
Opens the Assemble window.  
If an active Assemble window is open, that window is displayed in the forefront 
(so that it can be manipulated).  

Memory Displays the memory contents starting from the jump destination address 
specified by the data value at the cursor position.  
Opens the Memory window.  
If an active Memory window is open, that window is displayed in the forefront (so 
that it can be manipulated).  

Refresh Updates the contents of the window with the latest data.  

Shrink<<< Collapses the local variable list of the selected function.  

Expand>>> Displays the local variable list of the selected function. 

Close Closes this window.
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Register window

This window is used to display and change the contents of registers (general-purpose registers and

control registers).  

Figure 6-41　Register Window

This section explains the following items:  

• Opening

• Explanation of each area

• Functions often used (right-click menu)

• Function buttons

• Related operations

•  To change a register value

Opening

This window can be opened as follows:

• Click the Reg button.

• Select [Browse] -> [Register] from the menu bar, 
 (or press Alt+B, and R in that order).

Explanation of each area  

The Register window consists of the following areas:

(1)　Register bank setting area
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(2)　Upper left field (general-purpose register display area)

(3)　Lower left field (control register display area)

(1) Register bank setting area

This area is used to display or change the bank number of the general-purpose registers.  

(2) Upper left field (general-purpose register display area)

This area is used to display or change the register of the bank number displayed in the Register Bank 

field in the register bank setting area.   

The new value is written into the target when the Enter key is pressed.  The previous value can be 

canceled by the ESC key.  

This area is also used as a jump pointer of the jump function.

When displaying in register pairs, the value of WP, UUP, TDE, WHL, RG4, RG5, RG6, or RG7 is a 

jumper pointer for the jump from the area of VP, UP, DE, HL, RP4, RP5, RP6, or RP7, respectively.

For the general-purpose register display method, absolute name display and function name display 

can be switched with [View] in the menu bar. 

Caution If the width of the data value display/setting area is too narrow, display problems may

occur. In this case, increase the width of the window. 

Register Bank Displays and sets the register bank to be displayed in the general-purpose 
register display area.

Current Bank Displays the register bank number that is currently set as the target (current 
bank).
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When selecting [View] -> [Function Name] from the menu bar, this area is used to display or change 

the register of the bank number displayed in the Register Bank field in the register bank setting area of 

A, X, B, C, AX, and BC according to the RSS bit value.

Function Name Absolute Name

Pair Register Register Pair Register Register

ax x rp0 r0

a r1

bc c rp1 r2

b r3

ax_ x_ rp2 r4

a_ r5

bc_ c_ rp3 r6

b_ r7

vvp v rg4 v

vp r8 rp4 r8

r9 r9

uup u rg5 u

up r10 rp5 r10

r11 r11

tde t rg6 t

de d rp6 r12

e r13

whl w rg7 w

hl h rp7 r14

l r15

Register RSS=0 RSS=1

R0 X X_

R1 A A_

R2 C C_

R3 B B_

R4 X_ X

R5 A_ A

R6 C_ C

R7 B_ B
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(3) Lower left field (control register display area)

This area is used to display or change the contents of control registers.  

The new value is written into the target when the Enter key is pressed.  The previous value can be 

canceled by the ESC key.  

If the name of a register with '+' prefixed is double-clicked, the names and values of its flags are 

displayed, and '+' changes to '-'.  This '+' can be also changed to '-' by selecting a register name with 

the arrow keys and pressing the Enter key.  

This area is also used as a jump pointer of the jump function.  

Caution If the width of the data value display/setting area is too narrow, display problems may

occur. In this case, increase the width of the window. 

Functions often used (right-click menu)

In this window, functions that are often used can be selected from the menu that is displayed by clicking

the right mouse button.  In this way, the same function can be used more easily than with the normal

procedure.  

RP0 AX AX_

RP1 BC BC_

RP2 AX_ AX

RP3 BC_ BC

Add Watch Registers a selected character string to the Watch window.
Opens the Add Watch dialog box.  

Bin Displays the selected line in binary numbers.

Oct Displays the selected line in octal numbers.

Dec Displays the selected line in decimal numbers.

Hex Displays the selected line in hexadecimal numbers (default).

Register RSS=0 RSS=1
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Function buttons  

Related operations

To change a register value 

To change the value of a register, move the cursor to the control register display area or general-

purpose register display area in the window, and directly write a value from the keyboard.  

Press the return key to set the new value.  To cancel the change, press the ESC key.  

Refresh Updates the contents of the window with the latest data.  

Close Closes this window.
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SFR window

This window is used to display and change the contents of SFR and the I/O ports that have been

registered in the Add I/O Port dialog box. 

Note, however, that the values of read-only SFR and I/O ports cannot be changed.  In addition, the SFR

and I/O ports that cause the device to operate when they are read are read-protected and therefore cannot

be read.

To read these registers, select a register, and select and execute [Compulsion Read] from the right-click

menu. 

Figure 6-42　SFR Window

This section explains the following items:

• Opening

• Explanation of each area

• Functions often used (right-click menu)

• Function buttons

• Related operations

•  To change a SFR value

•  To select a SFR or I/O port to be displayed

•  To change the display sequence

•  To change the display radix

•  To add, change the contents of, and delete a user-defined I/O port

•  To change the display start position
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Opening

This window box can be opened as follows:

• Click the SFR button.

• Select [Browse] -> [SFR] from the menu bar 
 (or press Alt,+B, and F in that order).

Explanation of each area

The SFR window consists of the following areas:

(1)　Name (SFR name display area)

(2)　Attribute (attribute display area)

(3)　Value (SFR contents display area)

(1) Name (SFR name display area)

This area displays the names of SFR and I/O ports. 

If the value of an I/O port address is not defined, the I/O port name displayed in light color.

(2) Attribute (attribute display area)

This area displays the read/write attributes, access types, and absolute addresses of the SFR and I/O 

ports.  when the bit SFR is displayed, bit-offset value is also displayed.  

It can be specified whether this area is displayed or not, by selecting [View] -> [Attribute] from the 
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menu bar.  As an attribute, the following contents are displayed.

(3) Value (SFR contents display area) 

This area is used to display and change the contents of a SFR and I/O port.

The contents are displayed differently as follows, depending on the attribute:

The new value is written into the target when the Enter key is pressed.  The previous value can be 

canceled by the ESC key.  

The value of read-protected SFR and I/O ports can be read by selecting right-click menu -> 

[Compulsion Read].  

Read/Write Attribute

R Read only

W Write only

R/W Read/write

* Register that is read via an emulation register to prevent the device from operating 
when this register is read.  
To read this attribute directly from a SFR, execute [View] ->  [Compulsion Read] from 
the menu bar.  
Even a write-only SFR can also be read via an emulation register.  
However, some devices do not support this function.  

Access Type

1 Can be accessed in bit units.

8 Can be accessed in byte units.

16 Can be accessed in word units.

32 Can be accessed in double word units.

Black Display Read only or read/write

-- Write only

** Value changes if read
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Caution If the width of this area is too narrow, display problems may occur. In this case,

increase the width of the window.

Functions often used (right-click menu)

In this window, functions that are often used can be selected from the menu that is displayed by clicking

the right mouse button.  In this way, the same function can be used more easily than with the normal

procedure.  

Function buttons  

Move... Moves the display position.
Opens the Address Move dialog box.  

Add Watch Registers a selected character string to the Watch window.
Opens the Add Watch dialog box.  

Add I/O Port ... Adds user-defined I/O ports.
Opens the Add I/O Port dialog box.  

Bin Displays the selected line in binary numbers.

Oct Displays the selected line in octal numbers.

Dec Displays the selected line in decimal numbers.

Hex Displays the selected line in hexadecimal numbers (default).

Sort By Name Displays in alphabetical order.

Sort By Address Displays in address order (default).

Unsort Does not sort.

Attribute Displays or does not display an attribute area (Attribute).  
Checked: Displayed (default)
Not checked: Not displayed

Pick Up Displays only the registers selected in SFR Select dialog box.  
Checked: Displays only the selected register.
Not checked: Displays all the registers (default).

Select... Opens the SFR Select dialog box.  

Compulsion Read Forcibly reads the SFR that are disabled from being read because their 
values will be changed, or the data of the I/O ports and I/O protect area 
added in Add I/O Port dialog box.  

Refresh Updates the contents of the window with the latest data.  

Close Closes this window.
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Related operations

To change a SFR value

To change the contents of a SFR or I/O port, move the cursor to the Value area on the window, and 

write a value directly from the keyboard.  

Press the return key to set the new value.  To cancel the change, press the ESC key.  

Note that the values of read-only SFR and I/O ports cannot be changed.

To select a SFR or I/O port to be displayed

Use the SFR Select dialog box, which can be opened by selecting right-click menu -> [Select...] in the 

SFR window.  

To change the display sequence

The display sequence can be changed by selecting right-click menu -> [Sort By Name/Sort By 

Address/Unsort].  

To change the display radix

Select the line whose radix is to be changed, and select right-click menu ->  [Bin/Oct/Dec/Hex].  

To add, change the contents of, and delete a user-defined I/O port 

To manipulate an I/O port, use the Add I/O Port dialog box, which can be opened by selecting right-

click menu -> [Add I/O Port...] in the SFR window.  

To change the display start position

Use the Address Move dialog box, which can be opened by selecting right-click menu -> [Move...] in 

the SFR window.  
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SFR Select dialog box

This dialog box is used to select SFR and I/O ports that are not displayed the SFR window.  

It is also used to specify the sequence in which registers and ports are displayed.  

Figure 6-43　SFR Select Dialog Box

This section explains the following items:  

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

When SFR window is the current window

• Select [View] -> [Select...] from the menu bar 
 (or press Alt+V, and E in that order).

Explanation of each area  

The SFR Select dialog box consists of the following areas and buttons:

(1)　Display, Pick Up, No Display (display SFR selection area)

(2)　Arrange (display sequence specification button)

(3)　Sort by (No Display list display sequence change button)
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(1) Display, Pick Up, No Display (display SFR selection area) 

This area is used to select registers and I/O ports that are displayed or not displayed on the SFR 

window.  

To display or not display a register or I/O port in the SFR window, select the name of the register or I/O 

port from these lists, and click the <<<Show> or <Hide>>> button.  To display all the peripheral I/O 

registers, click the <<<Show All> button; to not display any of the registers, click the <Hide All>>> 

button.  

When selecting a SFR from the list, two or more registers can be selected by clicking any of the above 

buttons with the Ctrl or Shift key held down.  

(2) Arrange (display sequence specification button)

This button sets the sequence in which the registers and I/O ports are displayed in the Display list.  

A SFR or I/O port selected in the Display list can be moved to the top of the list by pressing the <Top> 

button, or to the bottom of the list by pressing the <Bottom> button.  The <Up> button moves the 

Display Registers and I/O ports are displayed in the SFR window

No Display Registers and I/O ports are not displayed in the SFR window

<< Show Moves the register or I/O port selected from the No Display list to Display.  

Hide >> Moves the register or I/O port selected from the Display list to No Display.  

<< Show All Moves all the registers and I/O ports to Display.  

Hide All >> Moves all the registers and I/O ports to No Display.  
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register or port one line up.  The <Down> button moves the register or port one line down.  

(3) Sort by (No Display list display sequence change button)

This button selects the sequence in which SFR and I/O ports are displayed in the No Display list.  

Pressing the <Name> button sorts the registers and ports into alphabetical order.  The <Address> 

button sorts them into address order.

Function buttons  

Top Moves the selected SFR or I/O port to the top of the list.

Up Moves the selected SFR or I/O port one line up.

Down Moves the selected SFR or I/O port one line down.

Bottom Moves the selected SFR or I/O port to the bottom of the list.

Name Displays in alphabetical order.

Address Displays in address order.

OK Reflects the selection in this dialog box in SFR window and closes this dialog 
box.

Cancel Cancels the changes and closes this dialog box.

Restore Restores the original status.

Help Opens the Help window.  



CHAPTER 6  WINDOW REFERENCE

User’s Manual  U16632EJ2V0UM 195

Add I/O Port dialog box

This dialog box is used to register an I/O port to be added to the SFR window.

Figure 6-44　Add I/O Port Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

• Select [Option] ->[Add I/O Port...] from the menu bar 
 (or press Alt+O, and P in that order).

Explanation of each area

The Add I/O Port dialog box consists of the following areas:

(1)　 I/O Port List: (I/O port selection area)

(2)　Name: (I/O port name specification area)

(3)　Address: (I/O port address specification area)

(4)　Access (access size specification area)

(5)　Read / Write (access attribute specification area)
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(1) I/O Port List: (I/O port selection area)

This area lists the I/O ports currently registered.

If a new I/O port is registered, it is added to this list.  In addition, an I/O port already registered can be 

selected and changed or deleted.

(2) Name: (I/O port name specification area)

This area is used to specify an I/O port name to be added.  An I/O port name can be up to 15 

characters long.

(3) Address: (I/O port address specification area)

This area is used to specify the address of the I/O port to be added.

Only an address in one of these areas can be specified: Target area, SFR area

An address can be also specified by a symbol or expression (refer to "Table 6-13  Specifying Symbols 

(p.112)").  The default radix for inputting a numeric value is hexadecimal.

(4) Access (access size specification area)

This area is used to specify the access size of the I/O port to be added.

Only SFR or external SFR can specify Word access.

Byte 8 bits (default)

Word 16 bits

Double Word 32 bits
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(5) Read / Write (access attribute specification area) 

This area is used to specify the access attribute of the I/O port to be added.

In the default condition, all the attributes are not checked (i.e., the I/O port can be both read and 

written).

Function buttons

Read Only Read only

Write Only Write only

Read Protect Read-protected

OK Reflects the result of addition in SFR window and closes this dialog box.

Cancel Cancels changes and closes this dialog box.

Restore Restores the original status.

Help Opens the Help window.

Add Adds an I/O port of the specified address.

Change Changes the setting of the I/O port selected in I/O Port List.

Delete Deletes the I/O port selected in I/O Port List.
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Trace window

The Trace window displays the trace results.  

This window is only in the active status and is updated when a break occurs or step execution is

performed.  The source file can also be displayed with the trace results (refer to "Normal display and mixed

display (p.201)").  

The tracer is enabled by selecting [Option] -> [Tracer On] from the menu bar.  

To manipulate the tracer during program execution, select [Run] -> [Tracer Start/Stop] from the menu bar.  

For details of the trace function, refer to "Trace function (p.26)".  

Figure 6-45　Trace Window

This section explains the following items:  

• Opening

• Explanation of each area

• Functions often used (right-click menu)

• Function buttons

• Related operations

•  To make the trace function usable

•  To set a section trace event and quality trace event

•  To change the display start position

•  To search trace data

•  To clear trace data

•  To turn on/off the tracer during program execution

•  For pick up display

•  To display the source text (mixed display mode)

•  To select the display item and change the display radix

•  
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Opening

This window can be opened as follows:

• Click the TrW button.

• Select [Browse] -> [Trace] from the menu bar 
 (or press Alt+B, and T in that order).

Explanation of each area  

The Trace window consists of the following areas:

(1)　Point mark display area

(2)　Trace mode display area

(3)　Trace result display area

(1) Point mark display area

This area displays Event setting status.  

If an execution event or access event is set at the corresponding trace address, the mark 

corresponding to the type of the event is displayed.  

The mark displayed is not that during trace but an event mark that is set when the trace result is 

displayed.  

(2) Trace mode display area

This area displays the types of trace modes.

"T" is also displayed in the frame where the display trigger occurred.

If a qualify trace condition is satisfied while a section trace condition is satisfied, 'Q' is displayed.

(3) Trace result display area 

This area displays the trace results.  

A Fully or section traced frame

Q Qualify traced frame

S Step executed frame

T Delay trigger frame 
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This area has two display modes: Normal display and mixed display.  In addition, Jump Function and 

Trace Result with Linking Window can be used in this area.  

Whether each of the following sub-areas is displayed or not can be selected in the Trace Data Select 

dialog box.  

(a) Frame (trace frame number display)

This area displays trace frame numbers.  

(b) Address Data Status (fetch access display) 

This area displays the result of fetching the program.

The display contents of Address and Data differ depending on the Status display.  

Status

The following types of statuses are available:

Address Data

Displays addresses and data.  The display contents differ as follows, depending on the Status display.  

(c) Address Data Status (data access display)

This area displays the result of accessing data.

Program fetch display

BRM1 Fetching of first byte of first instruction after branch
A line is displayed in blue for emphasis if the fetched address is the top of a 
symbol.  

M1 Fetching of first byte of instruction
A line is displayed in blue for emphasis if the fetched address is the top of a 
symbol.  

OP Opcode fetch of 2nd and subsequent bytes 

IF Invalid fetch or status unknown 

No display

Other Nothing is displayed. (Blank line is displayed.) 

Program fetch display

Address Displays the fetch address

Data Displays the fetch data

Status

VECT Vector read 

RWP Memory read/write via user program

RP Memory read via user program
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(d) DisAsm (mnemonic display)

This area displays the result of disassembly (only when the status of fetch access display is BRM1 or 

M1).

Normal display and mixed display

In the normal display mode, only the trace result is displayed.  

In the mixed display mode, the source file is also displayed along with the trace result.  

If a program code corresponds on the program fetch address to be displayed, a source file line is 

displayed before the line indicating the result of tracing that program fetch address.  

The source file line is displayed, emphasized in green.  

The display mode can be alternately changed by selecting [View] -> [Mix] from the menu bar.  

Caution The mixed display mode is valid only when the load module has been downloaded

and symbol information is read, and when a fetch address, fetch data, fetch status, or

result of disassembly is displayed.

Jump function

This function allows you to jump to the Source window, Assemble window or Memory window, using 

the cursor position as a jump pointer (refer to "Jump Function (p.33)").   

To jump from the Trace window, the jump pointer changes as follows, depending on the area in which 

the cursor is positioned:

WP Memory write via user program

RWM Memory read/write via macro service

RM Memory read via macro service

WM Memory write via macro service

Table 6-20　Cursor Position and Jump Pointer

Cursor Position Jump Pointer

Access Address Display Area Access address
(If the jump destination is the Source window or Assemble 
window, the fetch address is always used as the jump pointer.)Access Data Display Area

Access Status Display Area

Other Fetch address
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Cause of stopping tracer

The tracer may be stopped by the following types of causes:

Functions often used (right-click menu)

In this window, functions that are often used can be selected from the menu that is displayed by clicking

the right mouse button.  

In this way, the same function can be used more easily than with the normal procedure.  

Table 6-21　Status When Tracer Is Stopped

Cause Meaning

Event Break Break by event

Software Break Break by software event

Non Map Break A non-mapped break has been accessed.

Write Protect An attempt has been made to write to a write-protected area.

SFR Illegal An illegal access is made to a SFR.

Relocation Break A relocation instruction different from the initial setting has been 
executed.

Step Break Step execution break

Compulsory Break Manual break

Trace Stop Trace stop

Move... Moves the display position.
Opens the Trace Move dialog box.  

Trace Clear Clears the trace data.

Select Selects the contents to be displayed.
Opens the Trace Data Select dialog box.  

Pick Up Performs the setting for pickup display.

Off Does not pick up and display (default).

Search Picks up and displays a frame that satisfies the search condition.

BRM1 Picks up and displays the first M1 fetch frame after a program branch.

Mix Specifies whether the results of assembly are displayed in mixed display 
mode, or not displayed.
Checked: Mixed display
Not checked: No display (default)

Window Synchronize Links the Trace window with the following windows:

Source Text Links the Source window.

Assemble Links the Assemble window.

Memory Links the Memory window.
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Function buttons  

Related operations

To make the trace function usable

Select and check [Option] -> [Tracer On] from the menu bar.  To invalidate the tracer, select [Tracer On] 

again and remove the check mark.  

To set a section trace event and quality trace event

Use the Trace dialog box which can be opened by clicking the Trc button.

To change the display start position

Use the Trace Move dialog box that can be opened by selecting right-click menu -> [Move...] in the 

Trace window.  

Source Text Displays the corresponding source text and source line, using the data value 
at the cursor position as the jump destination address.  
If no line information exists at the jump destination address, however, you 
cannot jump.  
Opens the Source window.  
If an active Source window is open, that window is displayed in the forefront 
(so that it can be manipulated).  

Assemble Disassembles and displays starting from the jump destination address 
specified by the data value at the cursor position.  
Opens the Assemble window.  
If an active Assemble window is open, that window is displayed in the 
forefront (so that it can be manipulated).  

Memory Displays the memory contents starting from the jump destination address 
specified by the data value at the cursor position.  
Opens the Memory window.  
If an active Memory window is open, that window is displayed in the 
forefront (so that it can be manipulated).  

Search... Opens the Trace Search dialog box and searches or picks up trace results.  
The searched result will be highlighted in the Trace window. 
This button cannot be selected when a snap frame or BRM1 frame is picked up and 
displayed.
This is the same operation as selecting [View] -> [Search...] from the menu bar.  

<< Searches forward (upward on screen) for a trace result that satisfies the search 
condition set in the Trace Search dialog box.  
This button cannot be selected while pickup display is being performed.  

>> Searches backward (downward on screen) for a trace result that satisfies the search 
condition set in the Trace Search dialog box.  
This button cannot be selected while pickup display is being performed.  

Refresh Updates the contents of the window with the latest data.  

Close Closes this window.



204 User’s Manual  U16632EJ2V0UM

CHAPTER 6  WINDOW REFERENCE

To search trace data

Select right-click menu -> [Pick Up] -> [Off] in the Trace window and click the <Search...> button.  The 

Trace Search dialog box will be opened, enabling trace results to be searched.  

To clear trace data 

Select the right-click menu -> [Trace Clear] in the Trace window.  

This will clear the trace buffer (display contents of the Trace window).  

To turn on/off the tracer during program execution

To temporarily stop coverage, select [Run] -> [Tracer Stop] from the menu bar during program 

execution.  To resume tracer operation, select [Tracer Start].  

This operation can be performed only while the program is being executed.

It cannot be performed if the tracer function is disabled (when [Option] -> [Tracer On] is not checked).  

For pick up display

Only specific trace data can be picked up and displayed in the Trace window.  

A snap frame, M1 fetch frame, and picking up a frame that satisfies a given search condition can be 

selected as pickup conditions.  

To pick up and display M1 fetch frame

Select right-click menu-> [BRM1] in the Trace window.  A snap frame or M1 fetch frame will be picked 

up and displayed in the Trace window.  

To pick up and display only a frame that satisfies the search condition

Select right-click menu -> [Search] in the Trace window and click the <Search> button.  The Trace 

Search dialog box will be opened, enabling data to be picked up to be set.  

To display the source text (mixed display mode) 

Select the right-click menu -> [Mix] in the Trace window.  

To select the display item and change the display radix 

Use the Trace Data Select dialog box, which can be opened by selecting the right-click menu -> 

[Select...] in the Trace window.  

The display radix can be changed in the fetch data display area and access data display area.  
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Trace Search dialog box

This dialog box is used to search or pick up trace data in Trace window.  

This dialog box is used to search trace data if it is opened by selecting [View] -> [Pick Up] -> [Off] from the

menu bar.  It is used to pick up and display trace data if it is opened by selecting [View] -> [Pick Up] ->

[Search] from the menu bar.

By setting each item and then clicking the <Find Next> button, searching can be started.  

By clicking the <Set Find> button, the direction buttons ("<<" and ">>") in the Trace window can be used

for the search.  

Caution The Trace Search dialog box cannot be called if picking up the first M1 fetch frame

(BRM1) after program branch is specified using the menu bar or in Trace Data Select

dialog box.  

Figure 6-46　Trace Search Dialog Box 

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

When Trace window is the current window

• Click the <Search> button.
 (or press Ctrl+G).
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• Select [View] -> [Search...]  
 (or press Alt+V, and S in that order).

Explanation of each area

The Trace Search dialog box consists of the following areas:

(1)　Event Status (status selection area)

(2)　Access Size (access size selection area)

(3)　Address, Mask (address setting area)

(4)　Data, Mask (data setting area)

(5)　Scan Whole Region (search condition specification area)

(6)　Direction (search direction specification area)

(7)　Frame (search range specification area)

(1) Event Status (status selection area)

This area is used to set and select a status condition.  

A status condition can also be specified in abbreviated form.  Uppercase and lowercase characters are 

not distinguished.  

If a status condition is omitted, all frames (All status) are searched.  

Table 6-22　Types of Status Conditions

Status Abbreviation Meaning

All status ALL All frames (default)

BRM1 Fetch BRM1 First M1 fetch after program branch

M1 Fetch M1 M1 fetch (including BRM1)

Opcode Fetch OP Opcode fetch (including M1 and BRM1) 

R/W by Macro RWM Memory read/write via macro service (including RM and 
WM)

Read by Macro RM Memory read via macro service

Write by Macro WM Memory write via macro service

R/W by Program RWP Memory read/write via program (including RM and WM)

Read by Program RP Memory read via program

Write by Program WP Memory write via program

Vector Read VECT Vector read via interrupt 
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(2) Access Size (access size selection area)

This area is used to set and select an access size condition.  

By specifying an access size condition, the access width of a data condition to be detected by an 

access event is determined.  

An access size condition can also be specified in abbreviated form.  Uppercase and lowercase 

characters are not distinguished.  

Caution If an access event is specified as a status condition, the alternative of Bit is not

displayed.  If Bit or 1 is specified, an error occurs.  

If no access size condition is specified, a judgment is automatically made from the address condition 

and data condition, and the following is set:  

•  Bit if the address condition is set in bit units

•  Byte if the data condition is set in 8-bit units

•  Word if the data condition is set in 16-bit units

•  No Condition if no data condition is specified

Table 6-23　List of Access Size Conditions (Trace)

Size Abbreviation Meaning

Byte B Searches for a data condition with 8-bit width (only during 8-bit 
access).  

Word W Searches for a data condition with 16-bit width (only during 16-bit 
access).  

No Condition NC Does not search based on access size (nothing can be input to 
the Data area).

Bit 1 Searches for a data condition with 1-bit width (only during 8-bit 
access).  
In this case, a search is made for a data condition with 1-bit 
width.  Because of the operation of the emulator, access to a bit 
is not directly detected; the debugger searches a dummy bit 
access by internally setting address conditions and data 
conditions as follows:  

Input example:
Address: FE20.1
Data: 1

Setting of trace search
Address: FE20
Data: 00000010B
Mask: 11111101B

If another bit of the same address is accessed or if all the 8 bits 
of the same address are accessed, therefore, an event is 
detected in accordance with the specified status if the address 
and bit match the specified value of [address.bit].  
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(3) Address, Mask (address setting area)

Address, which sets an address value and Mask, which sets the mask value of an address value, are 

set as address conditions.  

An address can be also specified by a symbol or expression (refer to "Table 6-13  Specifying Symbols 

(p.112)").  The default radix for inputting a numeric value is hexadecimal.  

Both the address and mask may be omitted.  

The following can be set:

Address

Set an address condition.  

The following can be set:  

Mask

Set a mask value for an address value (only when a point is specified).  

The address value of a bit whose mask value is 1 may be 0 or 1.  

Example 1:

With this setting, addresses 0x4000 to 0x40FF satisfy the condition.  

Table 6-24　Settable Range of Address Condition

Settable range Condition

0 =< address value =< 0xFFFFFF
0 =< mask value =< 0xFFFFFF

Execution type events, fetch type events

0 =< address value =< 0xFFFFFFFF
0 =< mask value =< 0xFFFFFFFF

Data access type events

Set Point Set a value to only the lower address, or set the same value to the lower 
address and the higher address.  
Mask can be set.

Set Range Set a value to the lower address and the higher address.  
Mask cannot be set.

Setting of Bit Set a value to only the lower address, or set the same value to the lower 
address and the higher address.  Specify a value in the form of 
address.bit.  
Mask cannot be set.
The value of bit, which indicates the bit position, must be 0 =< bit =< 7.  

Address 0x4000 to 0x4000

Mask 0xFF
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Example 2:

With this setting, addresses 0x4000, 0x4001, 0x4100, and 0x4101 satisfy the condition.

(4) Data, Mask (data setting area)

Data, which sets an data value, and Mask, which sets the mask value of an data value, are set as data 

conditions.  

The default radix for inputting a numeric value is hexadecimal.  

Both the data and mask may be omitted.  

The settable range differs as follows depending on the access size condition specified in the Access 

Size area.  

Data

Set a data value.  Specify a value within the settable range.  

A symbol or expression can be also specified by a symbol or expression (refer to "Table 6-13  

Specifying Symbols (p.112)").  

Mask

Set a mask value for the data value.

When a mask is set, the data value for the bit whose mask value is 1 may be 0 or 1.  

The data value for a bit whose mask value is 1 may be 0 or 1.  

Example 1:

With this setting, addresses 0x4000 to 0x40FF satisfy the condition.  

Address 0x4000 to 0x4000

Mask 0x101

Table 6-25　Settable Range of Data Condition

Access Size Settable range

Byte 0 =< data value =< 0xFF
0 =< mask value =< 0xFF  

Word 0 =< data value =< 0xFFFF  
0 =< mask value =< 0xFFFF  

Bit Data value = 0 or 1
Mask value = Cannot be specified.

Data 0x4000 

Mask 0xFF
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Example 2:

With this setting, addresses 0x4000, 0x4001, 0x4100, and 0x4101 satisfy the condition.  

(5) Scan Whole Region (search condition specification area)   

This area is used to specify whether the specified range is fully searched or not.  

(6) Direction (search direction specification area)

This area is used to specify the direction of the search.  

(7) Frame (search range specification area)

This area is used to specify a frame number to be searched.  

For how to specify a frame number, refer to "Table 6-12  Frame Number Specification Format (p.109)".  

The default radix for inputting a numeric value is decimal.  

Function buttons

Data 0x4000 

Mask 0x101

Checked Searches the entire range.  

Not checked Searches the remaining part of the range (default)  

Up Forward search.
Searches data forward (upward on screen) from the current position 
of the cursor.  

Down Backward search (default).
Searches data backward (downward on screen) from the current 
position of the cursor.  

Find Next Searches the specified data in accordance with a given condition.  
If the specified frame is found as a result of a search, it is highlighted.  To 
continue searching, click this button again.  

Set Find Sets the specified condition as the search condition and closes this dialog 
box.  
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Pick Up
(Stop (during search))

Picks up according to the specified condition of data search.  
If a frame that satisfies the condition is found as a result of a search, it is 
picked up.  To pick up a frame that satisfies a different condition, press this 
button again.  

Cancel Closes this dialog box.  

Help Opens the Help window.  
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Trace Data Select dialog box

This dialog box is used to select items to be displayed in the Trace window.  

Figure 6-47　Trace Data Select Dialog Box

This section explains the following items:  

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

When Trace window is the current window

• Select [View] -> [Select...] from the menu bar 
 (or press Alt+ V, and E in that order).  

Explanation of each area  

The Trace Data Select dialog box consists of the following areas:

(1)　 Item (trace display item selection area)

(2)　Radix (trace display radix selection area)

(3)　Pick Up (pickup selection area)
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(1) Item (trace display item selection area)

This area is used to select items to be displayed in the Trace window.  Displaying the following items 

may or may not be selected.  The field checked is displayed.  

(2) Radix (trace display radix selection area)

This area is used to select the radix in which data is to be displayed.  Displaying the following items 

may or may not be selected.

Display field

Frame Frame number display field

Instruction Fetch Address Fetch address display field

Instruction Fetch Data Fetch data display field

Instruction Fetch Status Fetch status display field

Memory Access Address Access address display field

Memory Access Data Access data display field

Memory Access Status Access status display field

DisAssemble Disassemble display field

Instruction Fetch Data Fetch data display field

Memory Access Data Access data display field
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Display radix

(3) Pick Up (pickup selection area)

This area is used to select a pick up condition.  

Function buttons  

HEX Hexadecimal display

DEC Displays decimal numbers.

OCT Displays octal numbers.

BIN Displays binary numbers.

Pick Up Off No pick up display

Pick Up Search Frame Picks up and displays a frame that satisfies the search condition.

Pick Up BRM1 Frame Picks up and displays the first M1 fetch frame after a program branch 
.

OK Reflects the results of selection in this dialog box in Trace window.

Cancel Closes this dialog box.  

Restore Restores the original status.

Help Opens the Help window.  
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Event Manager

This window is used to display, enable or disable, and delete various event conditions.  

It is also used to register the various event conditions and manage the event conditions for setting them.  

Up to 256 conditions can be registered as event conditions or various event conditions.  However, the

number of event conditions that can be used (enabled) at the same time is limited as follows:

Notes1. One event reserved in flash self mode  

2. Two events reserved in flash self mode

Figure 6-48　Event Manager

This section explains the following items:  

• Opening

• Explanation of each area

• Functions often used (right-click menu)

• Function buttons

• Related operations

•  To save/restore event information

•  To enable/disable an event

•  To change the display sequence of event icons

•  To display details of event condition

•  To delete an event

Table 6-26　Maximum number of Events Usable for Event Conditions

IE Using
Event

Event link Break Trace Snapshot Timer DMM
Execution Access

IE-78K4-NS 4Note1 3Note1 1 7Note2 1 - - -
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•  To manage a software break event

•  To create an event condition

•  To create an event link condition

•  To set an event condition and event link condition as various event condition

Opening

This window can be opened as follows:

• Click the Mgr button.

• Select [Event] -> [Event Manager] from the menu bar   
 (or press Alt+N, and M in that order).  

In the Source window 

Move the cursor to the source line in the source text display area where an event is set, or to the

disassemble line in the mixed display mode. 

• Select [View] -> [Event?] from the menu bar 
 (or press Alt+V, and E in that order).

In the Assemble window 

Move the cursor to the line in the mnemonic display/change area where an event is set.

• Select [View] -> [Event?] from the menu bar 
 (or press Alt+V, and E in that order).

In the Event dialog box 

• Click the <Manager> button  
 (or press Alt+G). 

In the Event dialog box

• Click the <Manager> button.  
 (or press Alt+M).  

Explanation of each area  

The Event Manager consists of the following areas:

(1)　Event display area

(2)　Event details display area
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(1) Event display area

[When list is displayed] 

The event display area displays the icons (event icons) of the registered event, event link, break event, 

and trace event conditions.  

An event icon consists of a mark indicating the type of event, and an event name.  

By selecting the right click menu -> [Detail], the details can be displayed (refer to "Event details display 

area (p.219)").  

The meaning of each mark is as follows:

The color of the character on the mark indicates the set status of the event.  

Table 6-27　Marks of Event Icon

Mark Meaning

E. Event condition

L. Event link condition

B. Break event condition 

T. Trace event condition 

Table 6-28　Color of Character on Mark and its Meaning

Character 
Color Mark Meaning

Red E. L. Indicates that the various event condition using this event condition 
or event link condition is enabled.  

B. T. Indicates that this various event condition is enabled.  
This various event occurs when its condition is satisfied.  

Black E. L. Indicates that this various event condition using this event condition 
or event link condition is disabled.  

B. T. Indicates that this various event condition is disabled.  
This various event does not occur even when its condition is 
satisfied.  

Yellow E. L. Indicates that the symbol specified for this event is held pending 
because it cannot be recognized by the program currently loaded.  

B. T. Indicates that this various event is held pending.  
The various event does not occur even when its condition is 
satisfied.  
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This area also has the following four functions:

Jump function

If the selected icon is that of an event condition, you can jump to the Source window, Assemble 

window, or Memory window, using an address condition as the jump pointer.  You can jump easily by 

using the right click menu.  

The jump pointer will be as follows, depending on the set address condition.  

The jump destination window will be displayed from the jump pointer.  

Open function

Opens the event setting dialog box corresponding to the selected event condition.  Each setting dialog 

box displays the contents of the selected event condition.  

Operation

•  Double-click the icon, or click the <Open> button with selecting the icon.  

Enable/disable status switch function

Enables/disables events corresponding to the selected icon.  

The break and trace (but not the event and event link conditions) can be manipulated via their icons.  

Operation

1 Click on the mark of the icon using the left mouse button.

2 Click the <Enable> or <Disable> button.  

If the event was enabled, it is disabled (black). If the event was disabled, it is enabled (red). The 

<Enable> button is displayed when an icon that has been disabled is selected. The <Disable> button is 

displayed when an icon that has been enabled is selected.  

Deletion function

The registered event and set contents of the selected icon can be deleted.  

Operation

1 Select an icon.  Two or more icons can be selected by using Shift and Ctrl keys.  To select all the

icons, select [View] -> [Select All] from the menu bar.  

2 Click the <Delete> button or press the DEL key.  

Caution An event condition or event link condition can be deleted only when it is not being

used for another event condition.  If it is being used for another event, delete the event

that is using the event condition or event link condition, and then delete the event

Table 6-29　Address Condition and Jump Pointer

Setting of Address Condition Jump Pointer

Setting as a point  Specified address

Setting as a range  Lower address
(Point address before the mask if a mask is specified)

Setting as a bit  Address at the bit position
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condition or event link condition.  

(2) Event details display area

[In detailed display mode]  

This area displays the detailed information corresponding to each event icon.  

This area is displayed only in the detailed display mode.  

Contents are displayed by using the following key information as a separator.  

Functions often used (right-click menu)

In this window, functions that are often used can be selected from the menu that is displayed by clicking

the right mouse button.  In this way, the same function can be used more easily than with the normal

Table 6-30　Separator for Displaying Event Details

Key Information Contents

Event condition

[S] Status condition

[Z] Access size condition

[A] Address condition 
Symbol or expression: (actual address)

[D] Data condition 
Symbol or expression: (actual address)

[M] Mask condition 

Event link condition

[P1] - [P4] Event link condition on "n"th line

[D] Disable condition

Break condition

[B] Break condition

Trace condition 

[M] Trace mode

[S] Trace start condition 

[E] Trace end condition 

[Q] Qualify trace condition
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procedure.  

Function buttons  

Sort By Name Displays icons in the order of event names.

Sort By Kind Displays icons in the order of event types.

Unsort Does not sort icons (default).

Detail Displays the details.

Overview Displays a list (default).

Source Text Displays the corresponding source text and source line, using the position of the 
selected event as the jump destination address.
If no line information exists at the jump destination address, however, you cannot 
jump.  
Opens the Source window.  
If an active Source window is open, that window is displayed in the forefront (so 
that it can be manipulated).  

Assemble Displays the Assemble window from the position of the selected event, which is 
used as the jump destination address.
Opens the Assemble window.  
If an active Assemble window is open, that window is displayed in the forefront 
(so that it can be manipulated).  

Memory Displays the memory contents from the position of the selected event, which is 
used as the jump destination address.
Opens the Memory window.  
If an active Memory window is open, that window is displayed in the forefront (so 
that it can be manipulated).  

New... Opens the dialog box to create new event condition.  
By clicking each button, the corresponding event setting dialog box can be 
opened (with the new event name set).  After the event setting dialog box has 
been opened, this dialog box is closed.  

Open Opens the event setting dialog box corresponding to the selected event condition.  
Each setting dialog box displays the contents of the selected event condition.  
This button is invalid if no event condition is selected or if two or more event 
conditions are selected.  
The Enter key performs the same operation.  

Enable/
Disable

Enables or disables the selected various event condition (except event conditions 
and event link conditions).  
This button is invalid if an enabled/disabled event condition is not selected.  

Delete Deletes the selected event condition.  
When an event condition or an event link condition is to be deleted, an error 
occurs and the event condition or event link condition cannot be deleted if the 
event is used as a various event condition.  
This button is invalid if no event condition is selected.  

Delete All Deletes all event conditions.

Info... Opens the Select Display Information dialog box.  
This dialog box is used to change the display mode and rearrange event names.  
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Related operations

To save/restore event information

Use this window as the current window, and open the Environment File Save dialog box by selecting 

[File] -> [Environment] -> [Save As...] from the menu bar.  

To restore the set status of an event, open the Environment File Load dialog box by clicking the Open 

button.  By loading an event setting file (*.evn), the previously set event information can be restored.  

To enable/disable an event

An event can be enabled or disabled by clicking the mark of the event to be changed. By clicking 

Enable (red), the event is disabled (black); by clicking Disable (black), the event is enabled (red).

This change can be also performed on the Event Manager or in each event setting dialog box.  

To change the display sequence of event icons 

Select the right-click menu -> [Sort B Name/Sort By Kind/Unsort] on the Event Manager.  

To display details of event condition

Select the right-click menu -> [Detail] on the Event Manager.  

By selecting [Overview], the list can be displayed again.  

To delete an event 

Select the icon of the event to be deleted, and click the <Delete> button.  

Caution An event condition or event link condition cannot be deleted if it is being used for an

event.  Delete the event first, and then delete the event condition or event link

condition.  

To manage a software break event 

Use the Software Break Manager, which is opened by selecting [Event] -> [Software Break Manager] 

from the menu bar.  

To create an event condition

Create an event condition in the Event dialog box, which can be opened by clicking the Evn button.  In 

Sort by 
Name

Sorts events into name order.  

Sort by Kind Sorts events into type order.

Unsort Displays events in the order in which they have been registered without sorting 
the events.  

Detail Sets the detailed display mode.

Overview Sets the list display mode.

Cancel Closes this dialog box (same as ESC key).

Close Closes this window.
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addition, an event condition that is created when a hardware break is set in the source can also be 

used (refer to "Breakpoint setting/deletion function (p.116)").  

To create an event link condition

Create an event link condition in the Event Link dialog box, which can be opened by selecting [Event] -

> [Event Link] from the menu bar.  

To set an event condition and event link condition as various event condition

Set an event condition or event link condition as a various event condition in the Break dialog box, 

Trace dialog box, or Timer dialog box, which can be opened by clicking the corresponding button, such 

as <Break...> and <Trace...> in the Event dialog box or Event Link dialog box.  

By dragging and dropping the event condition to be set from the Event Manager area at the lower part 

of the screen to the condition setting area on each event setting dialog box, the event condition can be 

easily set.  

Each event setting dialog box can also be opened by selecting from the [Event] menu.  
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Software Break Manager 

This window is used to display, enable or disable, and delete software breaks.  

Up to 100 software break events can be enabled at the same time.  

Software breakpoints cannot be set in this window;  they can be set in the Source window or Assemble

window.  

Figure 6-49　Software Break Manager 

The section explains the following items:  

• Opening

• Explanation of each area

• Function buttons

Opening

This window can be opened as follows:

• Select [Event] -> [Software Break Manager] from the menu bar 
 (or press Alt+N, and M in that order).  

Explanation of each area  

The Software Break Manager consists of the following areas:

(1)　Name (event name display area)

(2)　Brk (break mark display area)

(3)　File#Line / Symbol+Offset (breakpoint display area)

(4)　Address (address display area)
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(1) Name (event name display area) 

This area displays the names of the registered events and the check boxes that indicate whether each 

event is enabled or disabled.   

An event name is displayed in the form of Swb+[number] in the default condition.  It can be changed 

to an alphanumeric string of up to 256 characters.  

To change an event name, select and click a name.  Then directly edit the name.  To set the editing, 

press the Enter key.  

When an event is enabled, the check box is checked.  

Furthermore, the name jumps to the Source window by double-clicking an event name if the event 

name corresponds to the source line, whereas the name jumps to the Assemble window if it does not 

correspond to the source line.  

Reference By clicking Name (on the label), the character strings of the displayed items can be

compared and sorted lexicographically (in alphabetical order).  Whether the character

strings are compared or sorted in ascending or descending order can be alternately

selected by clicking the mouse.  

(2) Brk (break mark display area)

The '>' mark is displayed for a software break event that is set at the current PC position (so that the 

software break event that caused a break can be easily identified).  

(3) File#Line / Symbol+Offset (breakpoint display area)  

This area displays the location at which a software break event was set as follows:

Events are evaluated based on this when a symbol is re-downloaded.  

If the event corresponds to the source line. Program$file name#line number

If the event dose not correspond to the source line. Program$file name#symbol+offset
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Reference By clicking File#Line/Symbol+Offset (on the label), the character strings of the displayed

items can be compared and sorted lexicographically (in alphabetical order).  Whether the

character strings are compared or sorted in ascending or descending order can be

alternately selected by clicking the mouse.  

(4) Address (address display area)

This area displays the address at which a software break event is set. 

Reference By clicking Address (on the label), the numeric values of the displayed items can be

compared and sorted.  Whether the values are compared or sorted in ascending or

descending order can be alternately selected by clicking the mouse.  

Function buttons  

Enable Enables the selected event.

Disable Disables the selected event.

Delete Deletes the selected event.

Delete ALL Deletes all the set software break events.

Close Closes this window.
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Event dialog box

Registers and displays event conditions.

An event condition registered in this dialog box will be automatically registered to the Event Manager.  

As an event condition, one event can be set for two or more event conditions (break, trace, and event

link).  

Up to 256 event conditions can be registered.  However, the number of event conditions that can be

simultaneously used is limited (refer to "Table 6-26  Maximum number of Events Usable for Event

Conditions (p.215)"). 

Caution Event conditions used for break cannot be used for trace, including those that are used

via event link.  Similarly, the event conditions used for trace cannot be used for break,

including those that are used via event link.

An event condition for which an address range is specified internally uses two event

conditions.  Therefore, the number of event conditions that can be used decreases by

the number of event conditions for which an address range is specified. 

Figure 6-50　  Event Dialog Box

This section explains the following items:  

• Opening

• Explanation of each area
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• Function buttons

Opening

This dialog box can be opened as follows:  

In normal mode  

If the Event dialog box is opened as follows, an event condition can be registered without its purpose 

being specified.  

•  Click the Evn button.  

•  Select [Event] -> [Event...] from the menu bar   
 (or press Alt+N, and E in that order).  

In select mode  

If the <OK> button is pressed when the Event dialog box has been opened as follows, an event 

condition can be registered in the setting dialog box from which this dialog box was opened.  

•  In each event setting dialog box  
Click the <Add Event> button.  
 (or press Alt and E in that order).  
In the select mode, the setting dialog box from which the Event dialog box was opened is displayed
on the title bar.  

Explanation of each area  

The Event dialog box consists of the following areas:  

(1)　Event Name (event name setting area)

(2)　Event Status (status selection area)

(3)　Access Size (access size selection area)

(4)　Address, Mask (address setting area)

(5)　Data, Mask (data setting area)

(6)　Pass Count (pass count setting area)

(7)　Event Manager (event manager area)

(1) Event Name (event name setting area)

This area is used to set a event name.  

Directly input an alphanumeric string of up to eight characters as a name.  

To display the contents of an already created event condition, select from the drop-down list.  

In the select mode, the selected event condition can be set in the event condition setting area of the 

setting dialog box that called the Event dialog box.  

The mark on the left of this area indicates the utilization status of events (refer to "Table 6-28  Color of 
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Character on Mark and its Meaning (p.217)").  The gray E. mark indicates that the event condition is 

being edited and has not been registered yet.  

(2) Event Status (status selection area)

This area is used to select a status condition.  

By specifying a status condition, the type of the execution event and an access event is determined (if 

an execution event is specified, nothing can be input to the Access Size, Address Mask, and Data 

areas).  

The status conditions that can be specified are listed below.  A status condition can also be specified in 

abbreviated form.  

Uppercase and lowercase characters are not distinguished in the input status condition.  

Note The address range can be specified, but the start address must be an even address and the 
end address must be an odd address.

Note The address of a space other than a 1 MB space cannot be specified.

Table 6-31　List of Status Conditions  

<Execution event>

Status Abbreviation Meaning

Execution EX Program executionNote

<Access event>

Status Abbreviation Meaning

Opcode Fetch OP Opcode fetch (including prefetch)Note

R/W RW Memory read/write

Read R Memory read

Write W Memory write

R/W by Macro RWM Memory read/write via macro service

Read by Macro RM Memory read via macro service

Write by Macro WM Memory write via macro service

R/W by Program RWP Memory read/write via program

Read by Program RP Memory read via program

Write by Program WP Memory write via program

Vector Read VECT Vector read via interrupt

Access AC All access statuses

External Trigger Trigger-1 External trigger (1 bit)
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(3) Access Size (access size selection area)

This area is used to set and select an access size condition.  

By specifying an access size condition, the access width of a data condition to be detected by an 

access event is determined.  

The access size conditions that can be specified are listed below.  An access size condition can also 

be specified in abbreviated form.  Uppercase and lowercase characters are not distinguished in the 

input access size condition.  

Because of the operation of the device, all the 8 bits are read or written when writing bits, but if Read or 

R/W is specified as the status condition, an event occurs for this read operation if the address and bit 

match the specified value of [address.bit].

If no access size is specified, judgment is automatically made from the address condition and data 

condition, and the following is set:  

•  Bit if the address condition is set in bit units  

•  Byte if the address condition is set in 8-bit units  

•  Word if the address condition is set in 32-bit units  

•  No Condition if no data condition is specified

Table 6-32　List of Access Size Conditions (Event)  

Size Abbreviation Meaning

Byte B Detects data condition with 8-bit width (only during 8-bit access).  

Word W Detects data condition with 32-bit width (only during 32-bit 
access).  

No Condition NC Does not detect access size (nothing can be input to the Data 
area).  

Bit 1 Detects data condition with 1-bit width (only during 8-bit access).  
In this case, a data condition is detected with 1-bit width.  
Because of the operation of the , access to a bit is not directly 
detected; the  detects a dummy bit access by internally setting 
address conditions and data conditions as follows:  

Input example:
Address: fe20  
Data: 1  

Setting to )  
Address: fe20
Data: 00000010B
Mask: 11111101B

If another bit of the same address is accessed or if all the 8 bits 
of the same address are accessed, therefore, an event is 
detected in accordance with the specified status if the address 
and bit match the specified value of [address.bit].  
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(4) Address, Mask (address setting area)  

Address, which sets the address value, and Mask, which sets the mask value of the address value, are 

set as the address conditions.

Both the Address and the Mask settings may be omitted. 

An address can be also specified by a symbol or expression (refer to "Table 6-13  Specifying Symbols 

(p.112)").  The default radix for inputting a numeric value is hexadecimal.  

Settable range  

(Execution type event)

0 =< address value =< 0xFFFFF

0 =< mask value =< 0xFFFFF

(Access type event)

0 =< address value =< 0xFFFFFF

0 =< mask value =< 0xFFFFFF

Address

Set an address condition (lower address - higher address).  

The following can be set:  

Mask

Set a mask value for the address value.  

When a mask is set, the data value for the bit whose mask value is 1 may be 0 or 1.  

The data value for a bit whose mask value is 1 may be 0 or 1.  

Example 1:

With this setting, addresses 0x4000 to 0x40FF satisfy the condition.  

Set Point Set a value to only the lower address, or set the same value to the lower 
address and the higher address.Mask can be set.  

Set Range Set a value to the lower address and the higher address.  
Mask cannot be set.

Set Bit Set a value to only the lower address, or set the same value to the lower 
address and the higher address.  Specify a value in the form of 
address.bit.  
Mask cannot be set.  
The value of bit, which indicates the bit position, must be 0 =<bit =<7.  

Address 0x4000-0x4000

Mask 0xFF
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Example 2:

With this setting, addresses 0x4000, 0x4001, 0x4100, and 0x4101 satisfy the condition.  

(5) Data, Mask (data setting area)

Data, which sets an data value, and Mask, which sets the mask value of an data value, are set as data 

conditions.  

The default radix for inputting a numeric value is hexadecimal.  

Both the data and mask may be omitted.  

The setting range is as follows.

Data

Set a data value.  Specify a value within the settable range.  

A symbol or expression can be also specified by a symbol or expression (refer to "Table 6-13  

Specifying Symbols (p.112)").  

Mask

Set a mask value for the data value.

When a mask is set, the data value for the bit whose mask value is 1 may be 0 or 1.  

The data value for a bit whose mask value is 1 may be 0 or 1.  

Example 1:

With this setting, addresses 0x40 to 0x4F satisfy the condition.  

(6) Pass Count (pass count setting area)  

The pass count condition is set in this area (settable range: 1 to 255).  

Pass Count is an area that specifies the number of times that an event condition must be satisfied in 

order to satisfy a condition during user program execution.

Address 0x4000-0x4000

Mask 0x101

Table 6-33　Settable Range of Data Condition  

Access Size Settable range

Byte 0 =< data value =< 0xFF  
0 =< mask value =< 0xFF  

Data 0x40

Mask 0x0F
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If 1 is specified, the condition is satisfied when the event condition is satisfied.

Omitting this setting means 1 is specified.

(7) Event Manager (event manager area)  

This area displays a list of break, trace and other registered events.  

In this area, the following operations can be performed.  

Displaying set contents  

Select an event and click the <Open> button or double-click the event.  The setting dialog box 

corresponding to the selected event will be opened and the set contents of the event will be displayed.  

Delete

A selected event can be deleted by selecting the icon of the event and clicking the <Delete> button or 

pressing the DEL key while focussing on the event manager area.

Changing display mode and sorting  

The display mode of and sorting in the event manager area can be selected by clicking the <Info...> 

button.  

Function buttons  

Setting-related buttons  

OK Automatically registers the event condition being edited, if any, and closes this 
dialog box.  
In the select mode  
An event condition is selected and the setting dialog box (indicated on the title 
bar) that called the Event dialog box is displayed again.  If the calling dialog box 
has already been closed, the select mode is returned to the normal mode, and 
the Event dialog box is not closed.  Otherwise, this dialog box will be closed.  

New Newly creates an event condition in this dialog box.  
An event name is automatically created and a new event condition is prepared.  

Set
(when a new 
event is created 
or an event is 
changed)  

Registers each event condition.  Because the dialog box is not closed even 
after an event has been registered, new event conditions can be registered.  
In the select mode  
An event condition is selected.  If there is an event being edited, it is 
automatically registered and selected.  

Clear
(when an event is 
not edited)  

Clears the contents of the event condition.  
This button is displayed when an event condition has not been edited.  
This button and the <Restore> button are alternately displayed.  
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Restore
(when an event is 
edited)  

Restores the contents of an edited event condition.  
If an event condition not registered is displayed, all the fields other than the 
event name field are blank or the default values are set.  
This button and the <Clear> button are alternately displayed.  

Cancel
Close

Closes this dialog box.  
Even if an event condition is being edited, it is not registered and the dialog box 
is closed.  
<Cancel> is displayed if a condition is not created, changed, or deleted; 
<Close> is displayed if it is.  

Help Opens the Help window.  

Buttons for opening each event setting dialog box

Event Link... Opens the Event Link dialog box.  

Break... Opens the Break dialog box.  

Trace... Opens the Trace dialog box.  

Timer... Opens the Timer dialog box.  

Manager Opens the Event Manager.  

Buttons in event manager area

Shrink <<<
(When area is 
displayed)

Turns off display of the event manager area.  
At this time, the size of the dialog box is reduced.  

Expand >>>
(When area is not 
displayed)

Displays the event manager area.  
At this time, the size of the dialog box is expanded.  

Open
(When only one 
event is selected)  

Opens the event setting dialog box corresponding to the selected event 
condition.  Each setting dialog box displays the contents of the selected event 
condition.  
The Enter key performs the same operation.  

Remove
(When event is 
selected)

Deletes the selected event condition.  
When an event condition or an event link condition is to be deleted, an error 
occurs and the event condition or event link condition cannot be deleted if the 
event is used as an event condition.  

Info... Opens the Select Display Information dialog box.  
This dialog box is used to change the display mode and rearrange event 
names.  

Sort by Name Sorts events into type order.  

Sort by Kind Sorts events into type order.

Unsort Displays events in the order in which they have been registered without sorting 
the events.  

Detail Sets the detailed display mode.

Overview Sets the list display mode.。

Cancel Closes this dialog box (same as ESC key).
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Event Link dialog box

This dialog box is used to register and display event link conditions.  

A event link condition registered in this dialog box will be automatically registered to the Event Manager.  

An event link condition is an event condition that is generated only if the user program is executed in the

sequence specified by a set event condition.  

Up to four sequences can be specified.  However, if a disable condition is detected in the middle of the

sequence, the satisfied event conditions up to that time are initialized, and detection will start from the first

event condition.  Note that if an event link condition and a disable condition are detected at the same time,

the disable condition has priority.

An event link condition can be used for multiple various event conditions.  The following various event

conditions can use event link conditions:  

Up to 256 event link conditions can be registered.  However, the number of event link conditions that can

be simultaneously used (valid) is limited (refer to "Table 6-26  Maximum number of Events Usable for Event

Conditions (p.215)").  

Figure 6-51　Event Link Dialog Box

Table 6-34　Various Event Conditions for Which Event Link Condition Can Be Use

Using IE
Break condition

(execution break only) Trace condition

IE-78K4-NS OK NG
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This section explains the following items:  

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:  

In normal mode  

If the Event Link dialog box is opened as follows, an event link condition can be registered without its 

purpose being specified.  

•  Select [Event] -> [Event Link...] from the menu bar   
 (or press Alt+N, and L in that order).  

In select mode  

If the <OK> button is pressed when the Event Link dialog box has been opened as follows, an event 

link condition can be registered in the setting dialog box from which this dialog box was opened.  

•  In each various event setting dialog box  
Click the <Add Link...> button.  
 (or press Alt+L, and L in that order).
In the select mode, the setting dialog box from which the Event Link dialog box was opened is
displayed on the title bar.  

Explanation of each area  

The Event Link dialog box consists of the following areas:

(1)　Link Name (event link name setting area)

(2)　Phase1, Phase2, Phase3, Phase4 (link condition setting area)

(3)　Event Manager (event manager area)

(1) Link Name (event link name setting area)

This area is used to set a event link name.  

Directly input an alphanumeric string of up to eight characters as a name.  

To display the contents of an already created event link condition, select from the drop-down list.  

In the select mode, the selected event condition can be set in the event kink condition setting area of 

the setting dialog box that called the Event Link dialog box.  

The mark on the left of this area indicates the utilization status of event link condition (refer to "Table 6-

28  Color of Character on Mark and its Meaning (p.217)").  The mark "L" in gray indicates that an event 

link condition is being edited and has not been registered yet.  
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(2) Phase1, Phase2, Phase3, Phase4 (link condition setting area)

This area is used to specify the sequence in which event conditions and events are detected.  

Set Phase 1 -> Phase 2 -> Phase 3 -> Phase 4, in that order.  Phase 4 does not have to be set.  

in this case, an event occurs when the event condition set for the last phase has been detected.  An 

event condition can be set for only Phase 1 or the same event condition can be set for two or more 

Phases.  

The number of event conditions that can be set for each phase in this area is only 1 for each phase.

  Caution Execution type events are the only type of event condition that can be set for each

phase.

Setting event condition in each area

Select an event condition in the Event Manager area, and click the <Add> button or drag and drop an 

event condition.  An event link condition can also be set by dragging and dropping not only in this 

dialog box, but also in the Event Manager area of each various event setting dialog box or the Event 

Manager.  

In addition, the Event dialog box can be opened in "select mode" by clicking the <Add Event...> button, 

and the event condition to be set can be selected.  

In the event condition setting area in this dialog box, an event condition can be alternately copied or 

moved by dragging and dropping.  

•  If an event condition is dropped only by the mouse, it is moved.  

•  If an event condition is dropped with the Shift key held down, it is moved.  

•  If an event condition is dropped with the Ctrl key held down, it is copied.  

(3) Event Manager (event manager area)  

This area displays a list of break, trace and other registered various event conditions.  

For details, refer to "Event Manager (event manager area) (p.232)".  
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Function buttons  

Setting-related buttons  

OK Automatically registers the event condition being edited, if any, and closes this 
dialog box.  
In the select mode  
An event condition is selected and the setting dialog box (indicated on the title 
bar) that called the Event Link dialog box is displayed again.  If the calling 
dialog box has already been closed, the select mode is returned to the normal 
mode, and the Event dialog box is not closed.  Otherwise, this dialog box will be 
closed.  

New Newly creates an event link condition in this dialog box.  
An event link condition name is automatically created and a new event link 
condition is prepared.  

Set
(when a new 
event link is 
created or an 
event link is 
changed)  

Registers the various event condition.  Because the dialog box is not closed 
even after an event has been registered, new event link conditions can be 
registered.  
In the select mode  
An event condition is selected.  If there is an event being edited, it is 
automatically registered and selected.  

Clear
(when an event is 
not edited)  

Clears the contents of the event link condition.  
This button is displayed when an event link condition has not been edited.  
This button and the <Restore> button are alternately displayed.  

Restore
(when an event is 
edited)  

Restores the contents of an edited event link condition.  
If an event link condition not registered is displayed, all the fields other than the 
event name field are blank or the default values are set.  
This button and the <Clear> button are alternately displayed.  

Cancel
Close

Closes this dialog box.  
Even if an event link condition is being edited, it is not registered and the dialog 
box is closed.  
<Cancel> is displayed if a condition is not created, changed, or deleted; 
<Close> is displayed if it is.  

Help Opens the Help window.  

Buttons for opening each event setting dialog box

Add Event... Opens the Event dialog box in the select mode, and selects or newly creates an 
event condition to be set.  The event condition will be added to the area 
selected when the < Add Event...> button is pressed.  

Other... Opens the dialog box for selecting the event type.  
By pressing each of the above buttons, each event setting dialog box can be 
opened in the new creation status.  

Buttons in event manager area

Shrink <<<
(When area is 
displayed)

Turns off display of the event manager area.  
At this time, the size of the dialog box is reduced.  

Expand >>>
(When area is not 
displayed)

Displays the event manager area.  
At this time, the size of the dialog box is expanded.  
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Open
(When only one 
event is selected)  

Opens the event setting dialog box corresponding to the selected event 
condition.  Each setting dialog box displays the contents of the selected event 
condition.  
The Enter key performs the same operation.  

Remove
(When event is 
selected)

Deletes the selected event condition.  
When an event condition or an event link condition is to be deleted, an error 
occurs and the event condition or event link condition cannot be deleted if the 
event is used as a various event condition.  

Info... Opens the Select Display Information dialog box.  
This dialog box is used to change the display mode and rearrange event 
names.  

Sort by Name Sorts events into type order.  

Sort by Kind Sorts events into type order.

Unsort Displays events in the order in which they have been registered without sorting 
the events.  

Detail Sets the detailed display mode.

Overview Sets the list display mode.

Cancel Closes this dialog box (same as ESC key).
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Break dialog box

This dialog box is used to register, set, and display break event conditions.  

A break event condition registered in this dialog box will be automatically registered to the Event

Manager.  

A break event condition automatically becomes valid when it has been registered.  

Up to 256 break event conditions can be registered.  However, the number of break event conditions that

can be simultaneously used is limited (refer to "Table 6-26  Maximum number of Events Usable for Event

Conditions (p.215)").  If the maximum number of break event conditions that can be used at the same time

is exceeded or if the number of event conditions or event link conditions used exceeds the maximum limit,

therefore, register a break event condition in the disabled state.  

If [Run] -> [Ignore Break Point] is selected from the menu bar, a break event condition does not operate

even if it is valid.  

Figure 6-52　Break Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:  

• Click the Brk button.  
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• Select [Event] -> [Break...] from the menu bar   
 (or press Alt+N, and B in that order).

Explanation of each area  

The Break dialog box consists of the following areas:

(1)　Break Name (break event name setting area)

(2)　Break Event (break condition setting area)

(3)　Event Manager (event manager area)

(1) Break Name (break event name setting area)  

This area is used to set a break event name.  

Directly input an alphanumeric string of up to eight characters as a name.  

To display the contents of an already created event condition, select from the drop-down list.  

The mark on the left of this area indicates the utilization status of events (refer to "Table 6-28  Color of 

Character on Mark and its Meaning (p.217)").  The gray mark indicates that an event condition is being 

edited and has not been registered yet.  

By clicking the left mark, an event condition can be validated or invalidated.  

(2) Break Event (break condition setting area)  

This area is used to set an event condition for break.  

The number of event conditions that can be set in this area, combining execution events and access 

events, is as follows:  

Note1. Two events reserved in flash self mode

2. One event reserved in flash self mode

The number of event link conditions is up to the maximum number of events that can be used for 

various event conditions, as long as the used event conditions do not exceed the number that can be 

Table 6-35　Number of Events Settable in Break Condition Setting Area

 IE Using Total (execution/access)

IE-78K4-NS 7Note1(4Note2/3Note2)
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simultaneously used. 

Setting event condition and event link condition in each area

Select an event condition or event link condition in the Event Manager area, and click the <Add> 

button or drag and drop an event condition or event link condition.  An event condition or event link 

condition can also be set by dragging and dropping not only in this dialog box, but also in the Event 

Manager area of each event setting dialog box and from the Event Manager.  

In addition, Event dialog box or Event Link dialog box can be opened in "select mode" by clicking the 

<Add Event...> or <Add Link...> button, and the event condition or event link condition to be set can be 

selected.  

In the event condition setting area in this dialog box, an event condition can be alternately copied or 

moved by dragging and dropping.  

•  If an event condition is dropped only by the mouse, it is moved.  

•  If an event condition is dropped with the Shift key held down, it is moved.  

•  If an event condition is dropped with the Ctrl key held down, it is copied.  

(3) Event Manager (event manager area)

This area displays a list of break, trace and other registered events.  

For details, refer to "Event Manager (event manager area) (P232)".

Function buttons

Setting-related buttons

OK Automatically registers the event condition being edited, if any, and closes this 
dialog box.  The event condition becomes valid as soon as it has been 
registered.  

New Newly creates an event condition in this dialog box.  
An event name is automatically created and a new event condition is prepared.  

Set
(when a new 
event is created 
or an event is 
changed)  

Registers each event condition. Because the dialog box is not closed even after 
an event has been registered, new event conditions can be registered.  Each 
event condition becomes valid as soon as it has been registered.  
If an already registered event condition is displayed, the <Enable> or <Disable> 
button is alternately displayed.  

Enable/Disable  
(when a 
registered event is 
displayed)  

Validates (enables) or invalidates (disables) the selected event condition.  
However, event conditions and event link conditions cannot be enabled or 
disabled.  
This button and the <Set> button are alternately displayed.  

Clear
(when an event is 
not edited)  

Clears the contents of the event condition.  
This button is displayed when an event condition has not been edited.  
This button and the <Restore> button are alternately displayed.  

Restore
(when an event is 
edited)  

Restores the contents of an edited event condition.  
If an event condition not registered is displayed, all the fields other than the 
event name field are blank or the default values are set.  
This button and the <Clear> button are alternately displayed.  
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Cancel
Close  

Closes this dialog box.  
Even if an event condition is being edited, it is not registered and the dialog box 
is closed.  
<Cancel> is displayed if a condition is not created, changed, or deleted; 
<Close> is displayed if it is.  

Help Opens the Help window.  

Buttons for opening each event setting dialog box

Add Event... Opens the Event dialog box in the select mode, and selects or newly creates an 
event condition to be set.  The event condition will be added to the area 
selected when the < Add Event...> button is pressed.  

Add Link... Opens the Event Link dialog box in the select mode, and selects or newly 
creates an event link condition.  The event link condition will be added to the 
area selected when the <Add Link...> button is pressed.  

Other... Opens the Select Event Type dialog box.  
By pressing each of the above buttons, each event setting dialog box can be 
opened in the new creation status.  

Buttons in event manager area

Shrink <<<
(When area is 
displayed)

Turns off display of the event manager area.  
At this time, the size of the dialog box is reduced.  

Expand >>>
(When area is not 
displayed)

Displays the event manager area.  
At this time, the size of the dialog box is expanded.  

Open
(When only one 
event is selected)  

Opens the event setting dialog box corresponding to the selected event 
condition.  Each setting dialog box displays the contents of the selected event 
condition.  
The Enter key performs the same operation.  

Remove
(When event is 
selected)

Deletes the selected event condition.  
When an event condition or an event link condition is to be deleted, an error 
occurs and the event condition or event link condition cannot be deleted if the 
event is used as an event condition.  

Info... Opens the Select Display Information dialog box.  
This dialog box is used to change the display mode and rearrange event 
names.  

Sort by Name Sorts events into name order.  

Sort by Name Sorts events into type order.  

Unsort Displays events in the order in which they have been registered without sorting 
the events.  

Detail Sets the detailed display mode.

Overview Sets the list display mode.

Cancel Closes this dialog box (same as ESC key).
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Trace dialog box

This dialog box is used to register, set, and display trace event conditions.  

In this dialog box, the following types of trace event conditions can be set: 

• Event condition for starting section trace

• Event condition for ending section trace

• Event condition for qualify trace

To use the above trace event conditions, select [Run] -> [Cond. Trace ON] from the menu bar.  

A trace event condition registered in this dialog box will be automatically registered to the Event Manager.  

A trace event condition automatically becomes valid when it has been registered.  

Up to 256 trace event conditions can be registered.  However, the number of trace event conditions that

can be simultaneously used is only 1 (refer to "Table 6-26  Maximum number of Events Usable for Event

Conditions (p.215)").  

If the maximum number of trace event conditions that can be used at the same time is exceeded or if the

number of event conditions or event link conditions used exceeds the maximum limit, therefore, register a

trace event condition in the disabled state.  

Figure 6-53　Trace Dialog Box

This section explains the following items:  

• Opening

• Explanation of each area

• Function buttons
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Opening

This dialog box can be opened as follows:  

• Click the Trc button.

• Select [Event] -> [Trace...] from the menu bar   
 (or press Alt+N, and T in that order).  

• Click the <Trace> button in the Event dialog box
 (or press Alt+T in that order).  

Explanation of each area  

The Trace dialog box consists of the following areas:

(1)　Trace Name (trace event name setting area)

(2)　Section Start, Section End (section trace range condition setting area)

(3)　Qualify (qualify trace condition setting area)

(4)　Event Manager (event manager area)

(1) Trace Name (trace event name setting area)

This area is used to set a trace event name.  

Directly input an alphanumeric string of up to eight characters as a name.  

To display the contents of an already created event condition, select from the drop-down list.  

The mark on the left of this area indicates the utilization status of events (refer to "Table 6-28  Color of 

Character on Mark and its Meaning (p.217)").  The gray mark indicates that an event condition is being 

edited and has not been registered yet.  

By clicking the left mark, an event condition can be validated or invalidated.  

(2) Section Start, Section End (section trace range condition setting area) 

This area is used to set event conditions for starting and stopping a section trace. 

By setting a trace start event condition as Section Start and a trace end event condition as Section 

End, a section trace (zone trace) can be performed.  

The number of event conditions that can be set in this area, combining execution events and access 

events, is as follows: 
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To set an event condition, drag the icon of the event to be set from the Event Manager area, and drop 

it in this area.  For details, refer to "Setting event condition and event link condition in each area 

(p.241)".  

(3) Qualify (qualify trace condition setting area)

This area is used to set an event condition for a qualify trace.

In a qualify trace, a trace is performed only when a trace condition is satisfied.  

If two or more events are set, trace is performed when each event occurs.

The number of event conditions that can be set in this area, combining execution events and access 

events, is as follows:  

To set an event condition, drag the icon of the event to be set from the Event Manager area, and drop 

it in this area.  For details, refer to "Setting event condition and event link condition in each area 

(p.241)".  

(4) Event Manager (event manager area)  

This area displays a list of break, trace and other registered various event conditions.  

For details, refer to "Event Manager (event manager area) (p.232)".  

IE Using Total (execution/access)

IE-78K4-NS 1

IE Using Total (execution/access)

IE-78K4-NS 4 (only access event can be used)
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Function buttons  

Setting-related buttons  

OK Automatically registers the event condition being edited, if any, and closes this 
dialog box.  The event condition becomes valid as soon as it has been 
registered.  

New Newly creates an event condition in this dialog box.  
An event condition name is automatically created and a new event condition is 
prepared.  

Set
(when a new 
event link is 
created or an 
event link is 
changed)  

Registers the various event condition.  Because the dialog box is not closed 
even after an event has been registered, new event conditions can be 
registered.  Each event condition becomes valid as soon as it has been 
registered.  
If an already registered event condition is displayed, the <Enable> or <Disable> 
button is alternately displayed.  

Enable/Disable  
(when a 
registered event is 
displayed)  

Validates (enables) or invalidates (disables) the selected event condition.  
However, event conditions and event link conditions cannot be enabled or 
disabled.  
This button and the <Set> button are alternately displayed.  

Clear
(when an event is 
not edited)  

Clears the contents of the event condition.  
This button is displayed when an event condition has not been edited.  
This button and the <Restore> button are alternately displayed.  

Restore
(when an event is 
edited)  

Restores the contents of an edited event condition.  
If an event condition not registered is displayed, all the fields other than the 
event name field are blank or the default values are set.  
This button and the <Clear> button are alternately displayed.  

Cancel
Close

Closes this dialog box.  
Even if an event condition is being edited, it is not registered and the dialog box 
is closed.  
<Cancel> is displayed if a condition is not created, changed, or deleted; 
<Close> is displayed if it is.  

Help Opens the Help window.  

Buttons for opening each event setting dialog box

Add Event... Opens the Event dialog box in the select mode, and selects or newly creates an 
event condition to be set.  The event condition will be added to the area 
selected when the < Add Event...> button is pressed.  

Add Link...
(Always disabled) 

Opens the Event Link dialog box in the select mode, and selects or newly 
creates an event link condition.  The event link condition will be added to the 
area selected when the <Add Link...> button is pressed.  

Other... Opens the dialog box for selecting the event type.  
By pressing each of the buttons, each various event setting dialog box can be 
opened in the new creation status.  

Buttons in event manager area

Shrink <<<
(When area is 
displayed)

Turns off display of the event manager area.  
At this time, the size of the dialog box is reduced.  

Expand >>>
(When area is not 
displayed)

Displays the event manager area.  
At this time, the size of the dialog box is expanded.  
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Open
(When only one 
event is selected)  

Opens the various event setting dialog box corresponding to the selected event 
condition.  Each setting dialog box displays the contents of the selected event 
condition.  
The Enter key performs the same operation.  

Remove
(When event is 
selected)

Deletes the selected event condition.  
When an event condition or an event link condition is to be deleted, an error 
occurs and the event condition or event link condition cannot be deleted if the 
event is used as a various event condition.  

Info... Opens the Select Display Information dialog box.  
This dialog box is used to change the display mode and rearrange event 
names.  

Sort by Name Sorts events into type order.  

Sort by Kind Sorts events into type order.

Unsort Displays events in the order in which they have been registered without sorting 
the events.  

Detail Sets the detailed display mode.

Overview Sets the list display mode.。

Cancel Closes this dialog box (same as ESC key).
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Timer dialog box

This dialog box is used to display the execution time measurement result.

About Section event

Section is a timer event name given to a timer event condition that measures the execution time from 

when a section trace starts until it ends.  This is registered by default.

Figure 6-54　Timer Dialog Box

This section explains the following items:  

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:  

• Click the Tim button.

• Select [Event] -> [Timer...] from the menu bar   
 (or press Alt+N, and I in that order).  

• Click the <Timer... > button in the Event dialog box.  
 (or press Alt+I).  

Explanation of each area  

The Timer dialog box consists of the following areas:

(1)　Timer Name (timer event name setting area)

(2)　Time (timer display unit selection area) 

(3)　Execution time display area
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(1) Timer Name (timer event name setting area)

In the case of the IE-78K4-NS,The timer event name cannot be set. It is fixed to Section.

The timer event name [Section] that displays the start and end of a section trace is registered in the 

default condition, but is not displayed on the Event Manager.  

(2) Time (timer display unit selection area)

This area is used to select the unit in which the timer measurement result is to be displayed.  

(3) Execution time display area

This area displays the result of measuring the execution time of the program.  

Note Resolution: 203.45ns

The following two methods are available to obtain the measurement results.

nsec Nanoseconds (default)

usec Microseconds

msec Milliseconds

sec Seconds

min Minutes

Pass Number of passes from when a section trace start condition occurs until the end 
condition or a break occurs.
(measurable execution count: 65535 max.)

Total Total execution time in the measurement zone specified by start event and end 
event conditions
(measurable execution time: Approx. 14 minutes 33seconds max. Note )

Average Average execution time
When step execution is performed, the same value as Total is displayed.
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•  In the case of step execution, the execution time for the last assembler instruction executed is
displayed.  Also, in the case of step execution, the execution count is always displayed as 1.

•  Measures the time from when a section trace start condition occurs until the end condition or a
break occurs.
The time is not measured if a section trace start condition does not occur.
The execution count is updated when a section trace start condition occurs.  However, if another
section trace start condition occurs during measurement (before a timer stop condition occurs), the
execution count is not updated.

  Buttons to manipulate execution time display area

Function buttons  

Copy Copies the measurement result to the clipboard in text format.

View Always Displays the Timer Result dialog box  is displayed.  

Setting-related buttons  

OK Automatically registers the event condition being edited, if any, and closes this 
dialog box.  The event condition becomes valid as soon as it has been 
registered.  

Help Opens the Help window.  
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Timer Result dialog box

This dialog box displays the result of measuring the execution time.

Figure 6-55　Timer Result Dialog Box

This section explains the following items:  

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

• In the Timer dialog box
Click the <View Always> button.
 (or press Alt+V). 

Explanation of each area  

The Timer Result dialog box consists of the following areas:

(1)　Execution time display area

(1) Execution time display area

This area displays the result of measuring the execution time of the program (refer to the section 

describing the Execution time display area (p.249) of the Timer dialog box).
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Function buttons  

Copy Copies the measurement result to the clipboard in text format.

Close Closes this dialog box.  

Help Opens the Help window.  
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Delay Count dialog box

This dialog box is used to set or display delay count values.  

By setting a delay count, it is possible to perform tracing of the number of frames corresponding to the

specified delay count value after a break condition occurs, and then stop program execution and tracer

operation. 

Figure 6-56　Delay Count Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

• Select [Event ] -> [Delay Count...] from the menu bar 
 (or press Alt+N and Y in that order).

Explanation of each area  

This dialog box consists of the following areas:  

(1)　Delay Count (delay count setting area)

(1) Delay Count (delay count setting area)

This area is used to set or display a delay count value (unit: frames).  

The delay count can be set between 0 (default) and 32767.
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Function buttons

OK Sets the specified delay count and closes this dialog box.  

Restore Restores the previous delay count.  

Cancel Closes this dialog box.  

Help Opens the Help window.  
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Reset Debugger dialog box

This dialog box is used to initialize the debugger, emulation CPU, and symbol information.

Specify what is to be initialized by using the check box.  In the default condition, the debugger is

initialized.  

Figure 6-57　Reset Debugger Dialog Box

This section explains the following items:

• Opening

• Explanation of each area

• Function buttons

Opening

This dialog box can be opened as follows:

• Select [File] -> [Debugger Reset...] on the menu bar
 (or press Alt+F, and R in that order).

Explanation of each area

The Reset Debugger dialog box consists of the following areas:

(1)　Reset subject selection area

(1) Reset subject selection area

This area is used to select what is to be initialized.  
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Function buttons

Debugger Initializes the debugger (default).

Symbol Initializes the symbol information.

Target CPU Initializes the emulation CPU.

OK Initializes the debugger, symbol information, or CPU.

Cancel Ignores the setting and closes this dialog box.

Help Opens the Help window.  
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About dialog box

This dialog box displays the version information of the debugger and in-circuit emulator (the year is

displayed in 4 digits).

The following version information is displayed:

• Product version of debugger

• Version of device file

• Version of GUI

• Version of debugger DLL

• Version of assembler DLL

• Version of executor

• Version of Packet DLL

Figure 6-58　About Dialog Box

This section explains the following items:

• Opening

• Function buttons

Opening

This dialog box can be opened as follows:

• Select [Help]->[About]
 (or press Alt+H, and A in that order).
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Function buttons

OK Closes this dialog box.
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Exit Debugger dialog box

This dialog box is used to select whether the current debug environment is saved to a project file or not

before terminating the debugger.  

It can be specified in the Debugger Option dialog box that the debugger is terminated without this

confirmation dialog box being opened.  

Figure 6-59　Exit Debugger Dialog Box

Reference If an attempt is made to terminate the debugger while the user program is being executed,

the following message is displayed and the program execution can be stopped.  

<Yes> button is selected

Execution of the user program is stopped and then the Exit Debugger dialog box is displayed.  

If it is specified in the Debugger Option dialog box that the Exit Debugger dialog box is not to

be displayed, however, the debugger is terminated.  

<No> button is selected

Execution of the user program is not stopped and the Exit Debugger dialog box is not

displayed.  The debugger is not terminated.  

This section explains the following items:  

• Opening

• Function buttons

Opening

This dialog box can be opened as follows:  
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• Select [File] -> [Exit] from the menu bar
(or press Alt+F, and X in that order).

• Press the Alt+F4 keys simultaneously.

• If forcible termination, such as to terminate the application, has been executed on the task list that
terminates Windows.  

Function buttons  

Yes Saves the current debug environment to a project file, closes all the windows, and 
terminates the debugger.  
If a project file name is not specified, the Project File Save dialog box is opened.  If 
the < Cancel> button is selected on the Project File Save dialog box, the 
environment is neither saved to a project file nor is the debugger terminated.  
If a project file is loaded or saved during debugger operation, this button has the 
default focus.  

No Closes all the windows and terminates the debugger.
If a project file is not loaded or saved during debugger operation, this button has the 
default focus.

Cancel Closes this dialog box without executing anything.
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Console window

This window is used to input commands that control the debugger.  

Because the key bind is Emacs-like, the accelerator key is not acknowledged if the Console window is

active.  

However, the F1 key displays the help of the Console window.  

While the Console window is open, an error message window with only an <OK> button is displayed in

the Console window.  

Refer to "CHAPTER 7 COMMAND REFERENCE (p.262)" for details on the command specifications.  

Figure 6-60　Console window

This section explains the following items:  

• Opening

Opening

This window can be opened as follows:

• Select [Browse] -> [Console] from the menu bar 
 (or press Alt+B, and N in that order).
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CHAPTER 7  COMMAND REFERENCE

This section explains the command functions of the ID78K4-NS in detail.

7. 1    Command Line Rules

The specification of command lines has the following rules: 

• Command name, option, and argument are specified for command line.  

• To divide words, a space (space key or tab key) is used.  

• At the end of a line, a line feed character or a semicolon is used.  

• When a command name and an option are entered to the point of identifiability, they are recognized.  

• In script, command names have to be entered completely.  

Command format 

command -options arg1 arg2 arg3 ... 

7. 2    Command List

The list of ID78K4-NS commands is shown in Table 7-1 and Table 7-2 .  

Table 7-1　List of Debugger Control Commands

Command Name Function

address Evaluation of address expression  
Converts the address expression specified with expression into address.  

assemble Disassemble/line assemble (a)  
Assembles the character strings specified with code from the address 
specified with address.  

batch Executing batch (with echo)  
Executes in batch displaying files specified with scriptname on the screen.   

breakpoint Setting/deletion of breakpoint (b)  
Operates breakpoint specified with options and address.  

dbgexit Terminating debugger
Terminates the debugger.  

download Download of files (l) 
Downloads files specified with filename according to options.  

extwin Creation of expansion window
Creates expansion window with scriptfile.  

finish Returning from function
Executes until it returns to the program that called the current function.  

go Continuous execution (g) 
Executes program continuously.  

help Display of help 
Displays help of Dcl.  
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hook Setting of hook 
Sets the procedure for hook with scriptfile.  

jump Jump to window (j) 
Displays the window specified with options.  

map Setting/deletion of memory mapping 
Sets, deletes, and displays memory mapping.   

mdi Setting of expansion window 
Sets the size and title name of the expansion window.  

memory Display/setting of memory (m) 
Sets value in the memory of the address specified with address according to 
options.  

module Display of the list of files and functions 
Displays the list of files and functions of the load module specified with 
progname.  

next Procedure step (n) 
Executes the procedure steps.  

refresh Redrawing of window 
Redraws the window and updates the data.   

register Display/setting of register value and I/O register value 
Sets value in the register specified with regname.  

reset Reset 
Resets CPU, debugger or symbols.  

run Reset and execution of CPU (r) 
Resets program and executes it.  

step Step execution (s)  
Executes step execution.  

stop Stop execution 
Stops the program forcibly.  

upload Upload 
Saves the memory data or coverage data within the specified range in a file.  

version Display of the version information 
Displays the version information of the debugger.  

watch Display/setting of variables (w) 
Displays and sets the variables.  

where Trace of stack 
Executes the back-trace of the stack.  

wish Start of Tclet 
Starts the script using Tk (Tclet).   

xtrace Operation of tracer 
Operates tracer.  

Table 7-1　List of Debugger Control Commands

Command Name Function



264 User’s Manual  U16632EJ2V0UM

CHAPTER 7  COMMAND REFERENCE

Table 7-2　 List of Console/Tcl Commands 

Command Name Function

alias Creation of another name 

cd Change of directory 

clear Clears the screen 

echo Echo 

exit Close/end 

history Display of history 

ls Display of files 

pwd Check of the directory 

source Execution of batch 

time Measurement of time for commands 

tkcon Console control 

unalias Deletion of another name 

which Display of the command path or another name 

Other commands Based on Tcl/Tk 8.1 
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7. 3    List of Variables 

• dcl(chip) - Chip name read only

• dcl(prjfile) - Project file name read only

• dcl(srcpath) - Source path read only

• dcl(ieid) - IE type read only

• dcl(iestat) - IE status read only

• dcl(bkstat) - Break status read only

• env(LANG) - Language 

• dcl_version - Dcl version read only

7. 4    List of Packages 

• tcltest - Restoration test 

• cwind - Automatic window control 

• BWidget - Toolkit 

7. 5    Key Bind 

• tcsh + emacs like 

• Complement of command name [Tab] 

• Complement of file name [Tab] 

• HTML help [F1] 

7. 6    Expansion window

The expansion windows can be created using Tk.  

In the expansion windows, Widget is allocated with '.dcl' as a root instead of '.'.  

When the following script files are allocated in bin/idtcl/tools/, an expansion window is added on selecting

[Browse] -> [Others] from the menu bar.  

The mdi command, an exclusive command for expansion windows, has been added.  

In expansion windows, Tk menu commands cannot be used because of the restrictions of MDI windows.  

7. 7    Callback Procedure

Expansion windows can hold dcl_asyncproc procedures called by asynchronous messages.  

# Sample.tcl
wm protocol .dcl WM_DELETE_WINDOW { exit }
mdi geometry 100 50
button .dcl.b -text Push -command exit
pack .dcl.b
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The asynchronous message ID is passed for the argument of the dcl_asyncproc procedure.  

The message IDs are shown below:  

7. 8    Hook Procedure 

A hook can be set in the debugger using the hook procedure.   

The hook procedures are shown below:   

proc dcl_asyncproc {mid} {
if {$mid == 19} {

redraw
}

}

Table 7-3　Message ID 

Message ID Meaning

9 After changing configuration 

10 After registering event 

11 After deleting event 

12 Before executing 

13 After breaking 

14 After resetting CPU 

15 After resetting debugger 

17 After changing extended option 

18 After changing debugger option 

19 After downloading 

20 After changing memory or register 

36 Before starting tracer 

37 After stopping tracer 

42 After clearing trace 

45 After resetting symbol 

BeforeDownload Hook before downloading 

AfterDownload Hook after downloading

AfterCpuReset Hook after resetting CPU 

BeforeCpuRun Hook before starting execution 

AfterCpuStop Hook after breaking 
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By using hook procedures, register values can be changed before downloading programs or after

resetting the CPU.   

An actual example of the procedure is shown below.  A hook is valid till the debugger is closed.  

[When hook is set with debugger control command] 

1 Create script fileNote with an editor.  

Note Be sure that the script file name is the same as the project file.  

Example:

The script file corresponding to test.prj is test.tcl.  

Allocate test.prj, test.pri, and test.tcl in the same directory. 

2 Start up the ID78K4-NS, select [Browse] menu -> [Console], and open the Console window.  

3 If the script file is executed in the window as below, the hook in the script file is set.  

%hook test.tcl

[When hook is set on downloading of project file] 

1 Create script fileNote a. with an editor.  

Note Be sure that the script file name is the same as the project file.  

2 Start up the ID78K4-NS and read test.prj.  

The hook in the script file is set.  

 An example of the contents of a script file is shown as below.  

7. 9    Related Files  

• Executes when the aliases.tcl console is opened.  
Sets the default alias etc.  

• Executes when the project file name.tcl project is opened.   
The hook of BeforeDownload, AfterCpuReset, BeforeCpuRun and AfterCpuStop can be used.  

proc BeforeDownload {} {
register MM 0x7
register PMC8 0xff
register PMC9 0xff
register PMCX 0xe0

}

proc AfterCpuReset {} {
register MM 0x7
register PMC8 0xff
register PMC9 0xff
register PMCX 0xe0

}
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• Executes when the load module name.tcl load module is downloaded.  
The hook of BeforeDownload, AfterCpuReset, BeforeCpuRun and AfterCpuStop can be used.  

7. 10    Cautions 

• The separator for file and path is a slash (/).  

• When a console or an expansion window is active, the accelerator key cannot be acknowledged.  

• When a console is open, error messages are output to the console.  

• When the [F1] key on the console is pressed, the HTML format help is opened (not opened from the
menu).  

• To terminate the command forcibly, close the console.  

• The execution of external commands (DOS commands) is OFF by default.  
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7. 11    Commands 

In this section, each command is explained using the format shown below.  

Command name 

Gives a brief explanation of the function of the command.  

Name

Describes the command name.  

Input format

Describes the input format of the command.  

Functions  

Explains the functions of the command.  

Usage example  

Shows an example of the usage of the command.  
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address

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

address - Evaluation of address expression  

Input format  

address expression

Functions

Converts the address expression specified by expression into address.  

Usage example

(IDCON) 1 % address main

0xaa

(IDCON) 2 % address main+1

0xab
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assemble

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

assemble - Disassemble/line assemble  

Input format  

assemble ?options? address ?code?

Functions

Assembles the character strings specified by code from the address specified by address.   

When '.' is specified for address, it is understood as an address continuing from the immediately previous

assemble.   

When code is omitted, it is assembled from the address specified by address.   

The followings are options.  They are ignored for assembly.  

Usage example

(IDCON) 1 % assemble -n 5 main

0x000000aa  B7              PUSH  HL

0x000000ab  B1              PUSH  AX

0x000000ac  891C          MOVW  AX,SP

0x000000ae  D6              MOVW  HL,AX

0x000000af  A100           MOV   A,#0H

(IDCON) 2 % assemble main mov a,b

(IDCON) 3 % assemble . mov a,b

-code Command code is also displayed.  It is ignored for assembly.  

-number number number line is displayed.  It is ignored for assembly.  
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batch

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

batch - Executing batch (with echo)

Input format  

batch scriptname

Functions

Executes in batch with displaying files specified by scriptname on the screen.   

Nesting is possible.  

Usage example

(IDCON) 1 % clear

(IDCON) 2 % batch bat_file.tcl

(IDCON) 3 % tkcon save a:/log.txt
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breakpoint

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

breakpoint - Setting/deletion of breakpoint 

Input format  

breakpoint ?options? ?address1? ?address2?

breakpoint -delete brkno

breakpoint -enable brkno

breakpoint -disable brkno

breakpoint -information

Functions

Operates the breakpoint specified by options and address.  

If a breakpoint can be set correctly, the breakpoint number is returned.  

The following are options:  

 

-software A software break is specified. 

-hardware A hardware break is specified (default).  

-execute The address execution break is set (default).  

-beforeexecute The break before address execution is set.  

-read An address memory read break is set.  

-write An address memory write break is set.  

-access An address memory access break is set.  

-size size The access size is set (8, 16, or 32).  

-data value The data condition is set.  

-datamask value The data mask is set.  

-extprobe value The external sense data condition is set.  
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Usage example

(IDCON) 1 % breakpoint main

1

(IDCON) 2 % breakpoint -i

1 Brk00001 enable rammon.c#17

(IDCON) 3 % breakpoint -software sub

2

(IDCON) 4 % breakpoint -i

1 Brk00001 enable rammon.c#17

2 Brk00001 enable rammon.c#8

(IDCON) 5 % breakpoint -disable 2

(IDCON) 6 % breakpoint -i

1 Brk00001 enable rammon.c#17

2 Brk00001 disable rammon.c#8

(IDCON) 7 % breakpoint -delete 1

2 Brk00001 disable rammon.c#8

-extprobemask value The external sense data mask is set.  

-passvalue The pass count is set.  

-information The list of breakpoints is displayed.  

-delete The breakpoint whose number is specified is deleted.  

-disable The breakpoint whose number is specified is disabled.  

-enable The breakpoint whose number is specified is enabled.  
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dbgexit

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

dbgexit - Terminating debugger  

Input format  

dbgexit ?options?

Functions

Terminates the debugger.   

The following are options:  

 

Usage example

(IDCON) 1 % dbgexit -saveprj

-saveprj Project is saved on terminating debugger.  
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download

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

download - Download of files  

Input format  

download ?options? filename ?offset?

Functions

Downloads file specified by filename according to options.   

If offset is specified, the address is shifted by the offset (if the data is in binary format, the load start

address is specified for offset).  

Usage example

(IDCON) 1 % download test.lmf

-binary Binary format data is downloaded.  

-append Additional download is executed.  

-nosymbol Download is executed.  Symbol information is not read.  

-symbolony Symbol information only is read.

-reset CPU is reset after download.  

-information Download information is displayed.  



CHAPTER 7  COMMAND REFERENCE

User’s Manual  U16632EJ2V0UM 277

extwin

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

extwin - Creation of expansion window 

Input format  

extwin scriptfile

Functions

Creates expansion window with scriptfile.  

Usage example

(IDCON) 1 % extwin d:/foo.tcl
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finish

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

finish - Returning from function 

Input format  

finish

Functions

Executes until it returns to the program that called the current function.  

Usage example

(IDCON) 1 % finish
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go

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

go - continuous execution  

Input format  

go ?options?

Functions

Executes the program continuously.  When -waitbreak is specified, it waits for the program to stop.   

The following are options:  

Usage example

(IDCON) 1 % go -w

-ignorebreak Breakpoint is ignored.  

-waitbreak The command waits for the program to stop.  
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help

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

help - Display of help  

Input format  

help

Functions

Displays Dcl help.  

Usage example

(IDCON) 1 % help
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hook

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

hook - Setting of hook  

Input format  

hook scriptfile

Functions

Sets the procedure for hook with scriptfile.  

Usage example

(IDCON) 1 % hook d:/foo.tcl
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jump

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

jump - Jump to window  

Input format  

jump -source -line filename ?line?

jump ?options? address

Functions

Displays the window specified by options.    

Usage example

(IDCON) 1 % jump -s main

(IDCON) 2 % jump -s -l mainfile.c 10

(IDCON) 3 % jump -m array

-source The Source window is displayed from the address specified by address.  

-assemble The Assemble window is displayed from the address specified by 
address.  

-memory The Memory window is displayed from the address specified by 
address.  

-line The command is moved to the line specified by ine.  
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map

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

map - Setting/deletion of memory mapping  

Input format  

map options address1 address2 ?accsize?

Functions

Sets, deletes, and displays memory mapping.  

The access size of 8, 16, or 32 is specified by accsize (the default is 8).  

The following are options:  

Usage example

(IDCON) 1 % map -i

1: 0 0x7fff 8 {IROM}

2: 0x8000 0x87ff 8 {Target RRM}

3: 0x8800 0x9fff 8 {Target}

4: 0xa000 0xf7ff 8 {NonMap}

5: 0xf800 0xfaff - {NonMap}

-erom Alternate ROM is mapped.  

-eram Alternate RAM is mapped.  

-target Target area is mapped.  

-protect I/O protect area is mapped.  

-clear All the settings for the mapping are deleted.  

-information Refer to the setting for the mapping.  
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6: 0xfb00 0xfedf 8 {Saddr}

7: 0xfee0 0xfeff 8 {Register}

8: 0xff00 0xffff 8 {SFR}

(IDCON) 2 % map -erom 0x100000 0x10ffff

(IDCON) 3 % map -c
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mdi

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

mdi - Setting of expansion window  

Input format  

mdi geometry ?x y? width height 

mdi title string

Functions

Sets the size and title name of the expansion window.  

The command can be used only from the expansion window.  

Usage example

(IDCON) 1 % mdi geometry 0 0 100 100 

(IDCON) 2 % mdi title foo
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memory

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

memory - Display/setting of memory  

Input format  

memory ?options? address ?value? 

memory ?options? -fill address1 address2 value 

memory ?options? -copy address1 address2 address3

Functions

Sets value in the memory of the address specified by address according to options.   

If value is omitted, display the value of the memory of the address specified by address.   

If -fill is specified, value is filled from address1 to address2.   

If -copy is specified, data from address1 to address2 is copied to address3.   

The following are options:   

 

Usage example

(IDCON) 1 % memory 100 

0x10 

(IDCON) 2 % memory 100 2 

(IDCON) 3 % memory 100 

-byte Displayed/set in one-byte units (default).  

-word Displayed/set in word units.   

-fill The data is filled in.  

-copy The data is copied.   

-noverify Verification is not executed on writing.   
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0x02 

(IDCON) 4 % memory -fill 0 1ff 0
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module

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

module - Display of the list of files and functions  

Input format  

module progname ?filename?

Functions

Displays the list of files and functions of the load module specified by progname.  

If filename is not specified, the list of files is displayed.  

If filename is specified, the list of functions of the specified files is displayed.  

Usage example

(IDCON) 1 % module rammon.lmf 

1: rammon.c 

(IDCON) 2 % module rammon.lmf rammon.c 

1: rammon.c sub1 

2: rammon.c main
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next

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

next - Procedure step

Input format  

next ?options?

Functions

Executes the procedure steps.  If functions are called, the step stops after executing function.  

 The following are options:  

Usage example

(IDCON) 1 % next -i 

(IDCON) 2 % next -s

-source Command is executed in source line units (default).  

-instruction Command is executed in command units.  
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refresh

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

refresh - Redrawing of window  

Input format  

refresh

Functions

Redraws the window and updates the data.  

Usage example

(IDCON) 1 % batch foo.tcl 

(IDCON) 2 % refresh
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register

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

register - Display/setting of register value and I/O register value  

Input format  

register ?options? regname ?value?

Functions

Sets value in the register specified with regname.  

If value is omitted, displays the value of the register specified by regname.   

The following are options:   

Usage example

(IDCON) 1 % register pc 

0x100 

(IDCON) 2 % register pc 200 

(IDCON) 3 % register pc 

0x200

-force Compulsory reading is executed.  

-bankno bankno A bank number is specified.
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reset

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

reset - Reset

Input format  

reset ?options?

Functions

Resets the CPU, debugger or symbols.   

If options are omitted, the CPU is reset.   

The following are options:   

Usage example

(IDCON) 1 % reset

-cpu CPU is reset (default).  

-debugger Debugger is reset.   

-symbol Symbol is reset.  

-event Event is reset.  
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run

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

run - Reset and execution of CPU  

Input format  

run  ?options?

Functions

Resets the program and executes it.  

If -waitbreak is not specified, the command does not wait until the program stops.   

The following are options:   

Usage example

(IDCON) 1 % run 

(IDCON) 2 % run -w

-waitbreak The command waits for the program to stop.  
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step

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

step - Step execution

Input format  

step ?options?

Functions

Executes step execution.  

If functions are called, the command stops at the head of the functions.   

The following are options:  

 

Usage example

(IDCON) 1 % step -i 

(IDCON) 2 % step -s

-source The command is executed in source line units (default).  

-instruction The command is executed in command units.  
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stop

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

stop - Stop executing  

Input format  

stop

Functions

Stops the program forcibly.  

Usage example

(IDCON) 1 % run 

(IDCON) 2 % stop
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upload

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

upload - Upload  

Input format  

upload ?options? filename address1 address2

Functions

Saves the memory data within the specified range in a file.   

The following are options:   

Usage example

(IDCON) 1 % upload -b foo.hex 0 0xffff 

(IDCON) 2 % upload -c -f foo.cov 0 0xffff

-binary The data is saved in binary format.   

-intel The data is saved in Intel HEX format (default).  

-motorola The data is saved in Motorola HEX format.  

-tektronix The data is saved in Tektronix HEX format.  

-force The file is overwritten.   
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version

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

version - Display of the version information  

Input format  

version

Functions

Displays the version information of the debugger.  

Usage example

(IDCON) 1 % version 

GUI                     : E2.00y [31-May-99] 

Devicefile            : 78K4[uPD784225] E1.01a 

Debugger            : 78K/4 Debugger E2.50c [02-Apr-99] 

Executer              : 78K/4 Executer E1.3c 

Packet translator : 78K/4 Packet E2.00w 

Assembler            : 78K/4 Asm/Disasm E1.15a [01-Apr-99] 

Tcl/Tk                    : 8.1.1
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watch

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

watch - Display/setting of variables  

Input format  

watch ?options? variable ?value?

Functions

Displays and sets the variables.   

The following are options:  

Usage example

(IDCON) 1 % watch var 

0x10 

(IDCON) 2 % watch -d var 

16 

(IDCON) 3 % watch array\[0\] 0xa

-binary The value is displayed in binary digits.   

-octal The value is displayed in octal digits.  

-decimal The value is displayed in decimal digits.   

-hexdecimal The value is displayed in hexdecimal digits.   

-string The value is displayed in character strings.  

-sizeof The size, instead of the value, of variables is displayed in decimal digits.   
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where

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

where - Trace of stack  

Input format  

where

Functions

Executes the back-trace of the stack.  

Usage example

(IDCON) 1 % where 

1: test2.c#sub2(int i)#13 

2: test.c#num(int i)#71 

3: test.c#main()#82
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wish

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

wish - Startup of Tclet  

Input format  

wish scriptname

Functions

Starts up the script using Tk (Tclet).   

The expansion window can be created with Tclet.  

Usage example

(IDCON) 1 % wish test.tcl
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xtrace

The following items are explained here.  

• Name

• Input format

• Functions

• Usage example

Name

xtrace - Operation of tracer  

Input format  

xtrace -dump ?-append? frameno ?filename? 

xtrace -start 

xtrace -stop 

xtrace -clear 

xtrace -addup bool 

xtrace -mode mode

Functions

Operates tracer.   

The following are options:  

-start The tracer starts on executing the program.   

-stop The tracer stops on executing the program.    

-clear The trace data is dumped (default).   

-dump The dump result is redirected to the console window.   
If the file name is specified, the dump result is written in the file.   

-append The dump result is added to a file.  

-addup bool Whether the time tag is integrated or not is selected.   

-mode mode The trace control mode (any one of: all, cond, nonstop, fullstop, 
fullbreak, delaystop, delaybreak, machine, or event) is selected.  
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Usage example

(IDCON) 1 % xtrace -start 

(IDCON) 2 % xtrace -stop 

(IDCON) 3 % xtrace -dump 3 

_01685 2 000000BC M1 br _sub2+0x2 

_01686 4 0000009A BRM1 st.w r6, 0x8[sp] 

_01687 3 0000009E BRM1 st.w r0, 0x0[sp] 

(IDCON) 4 % xtrace -clear 

(IDCON) 5 % xtrace -addup true
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APPENDIX A  INPUT CONVENTIONS

 This appendix explains the input conventions of the following items:

• Character set

• Symbols

• Numeric Values

• Expressions and Operators

• File Names

A. 1    Character set 

The characters listed in Table A-1 can be used as the character set. 

The characters listed in Table A-2 can be used as special characters.

Specify a line number as an integer constant, starting from 1.

Table A-1　Usable Character Set

Classification Character

Alphabetic 
characters

Uppercase characters: A B C D E F G H I J K L M N O P Q R S T U V X W Z
Lowercase characters: a b c d e f g h I j k l m n o p q r s t u v x w z

Numerals 0123456789

Character 
equivalent to 
alphabetic 
character

@?_

Table A-2　List of Special Characters

Character Name Usage

( Left parenthesis Changes operation order.

) Right parenthesis Changes operation order.

+ Plus Addition operator or positive sign

- Minus Subtraction operator or negative sign

* Asterisk Multiplication operator or indirect reference operator

/ Slash Division operator

% Percent Remainder operator

~ Tilde Complement operator

| Vertical line Bit sum operator

^ Circumflex Bit difference operator

& Ampersand Bit product operator or address operator
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A. 2    Symbols

The following rules apply to symbols:

1 A symbol consists of characters A to Z, a to z, @, _ (underbar), . (period), ?, and 0 to 9.

2 A symbol must start with a character other than numerals 0 to 9.

3 Uppercase characters (A to Z) and lowercase characters (a to z) are distinguished.

4 A symbol must be no more than 2048 characters long (if a symbol of more than 256 characters is

defined, only the first 2048 characters are valid).

5 A symbol is defined by loading a load module file.

6 Symbols are classified into the following types by the valid range:

- Global symbol (assembly language, C language)

- Static symbol (C language)

 In-file static symbol

 In-function static symbol

- Local symbol (C language)

 In-module local symbol (assembly language)

 In-file local symbol

 In-function local symbol

 In-block local symbol

7 The following symbols are available for each language used:

- Assembly language

 Label name, constant name, bit symbol name

- C language

 Variable name (including pointer function name, enumeration type variable name, array name,

structure name, and union name)

 Function name, label name 

 Array element, structure element, union element, bit field (if the symbol is an array, structure, or

union)

8 A symbol can be described instead of an address or numeric value.

9 The valid range of a symbol is determined based on the source debug information when the source

file is assembled or compiled.

10 Describe only the symbol name of a global symbol.

11 A local symbol is expressed in pairs with a file name.

[ Left bracket Array subscript operator or base register specification symbol

] Right bracket Array subscript operator or base register specification symbol

. Period Direct member operator or bit position specifier

, Comma Delimiter between operands

Table A-2　List of Special Characters

Character Name Usage
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A. 3    Numeric Values

The following four types of numeric values can be used.  The input format of each type is as shown

below.

The suffix (bold) and the alphabetic characters of hexadecimal numbers may be uppercase or lowercase

characters.  If the first character is A to F, 0 must be prefixed to it.  

In the input field of the debugger, decimal numbers or hexadecimal numbers are alternately selected,

depending on the default radix.

A. 4    Expressions and Operators

Expressions

An expression consists of constants, register names, SFR names, and symbols coupled by operators.

If an SFR name, label name, function name, or variable name is described as a symbol, an address is 

calculated as the value of the symbol.

The elements making up an expression, except operators, are called terms (constants and labels).  

Terms are called the first term, the second term, and so on, starting from the left.

Operators

The following operators of the C language can be used:

Table A-3　 Input Format of Numeric Values

numeric value Input format

Binary number nY
n...nY (n=0,1)

Octal number nO
n...nO (n=0,1,2,3,4,5,6,7)
nQ
n...nQ (n=0,1,2,3,4,5,6,7)

Decimal number n
n...n
nT
n...nT (n=0,1,2,3,4,5,6,7,8,9)

Hexadecimal numbers n
n...n
nH
n...nH
0xn
0xn...n (n=0,1,2,3,4,5,6,7,8,9,A,B,C,D,E,F)

Table A-4　 List of Operators

Symbol Meaning Explanation

Operators

+ Addition Returns the sum of the first and second terms.
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Rules of operation 

Operations are performed according to the priority of the operators.

- Subtraction Returns the difference between the first and second terms..

* Multiplication Returns the product of the first and second terms.

/ Division Divides the value of the first term by the value of the 
second term, and returns the integer of the result.

MOD
%

Remainder Divides the value of the first term by the value of the 
second term, and returns the remainder of the result.

- sign Unary operator 
(negative)

Returns 2's complement of the value of the term.

+ sign Unary operator 
(positive)

Returns the value of the term.

Logical operator

NOT
~

Negation Logically negates each bit of the term, and returns the 
result.

AND
&

Logical product Obtains the logical product of the values of the first and 
second terms on each bit, and returns the result.

OR
|

Logical sum Obtains the logical sum of the values of the first and 
second terms on each bit, and returns the result.

XOR
^

Exclusive logical 
sum

Obtains the exclusive logical sum of the values of the first 
and second terms on each bit, and returns the result.

Shift operator

SHR
>>

Right shift Shifts the value of the first term by the value (number of 
bits) of the second term to the right, and returns the result.  
As many 0s as the number of shifted bits are inserted in the 
higher bits.

SHL
<<

Left shift Shifts the value of the first term by the value (number of 
bits) of the second term to the left, and returns the result.  
As many 0s as the number of shifted bits are inserted in the 
lower bits.

Byte separation operator

HIGH Higher byte Of the lowest 16 bits of the term, returns the higher 8 bits.

LOW Lower byte Of the lowest 16 bits of the term, returns the lower 8 bits.

Word separation operator

HIGHW Higher word Of the 32 bits of the term, returns the higher 16 bits.

LOWW Lower word Of the 32 bits of the term, returns the lower 16 bits.

Other

( Left parenthesis Performs the operation in ( ) before the operation outside ( 
).
'(' and ')' are always used in pairs.) Right parenthesis

Table A-4　 List of Operators

Symbol Meaning Explanation
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•  If the priorities of the operators are the same, the operation is performed from the left toward the
right.

•  Performs the operation in ( ) before the operation outside ( ).

•  Each term in an operation is treated as unsigned 32-bit data.

•  All operation results are treated as unsigned 32-bit data.

•  If an overflow occurs during operation, the lower 32 bits are valid, and the overflow is not detected.

Terms

To describe a constant for a term, the following numeric values can be described.

A. 5    File Names

The following rules apply to source file names and execution module file names. 

1 Source file names and execution module file names consist of any combination of A to Z, a to z, _

(underbar), and 0 to 9. 

2 Uppercase characters (A to Z) and lowercase characters (a to z) are not distinguished. 

Table A-5　Operator Priority

Priority Operators

1                  Higher (, )

2 + sign, - sign, NOT,  , HIGH, LOW, HIGHW, LOWW

3 *, /, MOD, %, SHR, >>, SHL, <<

4 +, -

5 AND, &

6                  Lower OR, |, XOR, ^

Table A-6　Range of Radixes

Radix Range

Binary number 0Y <= value <= 1111111111111111111111111111111Y (32 digits)

Octal number 0O <= value <= 37777777777O

Decimal number -2147483648 <= value <= 4294967295
(A negative decimal number is internally converted into a 2's 
complement.) 

Hexadecimal numbers 0H <= value <= 0FFFFFFFH
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APPENDIX B  EXPANSION WINDOWS

This chapter explains the following item about Expansion Window.

• Overview

• Activation

• Explanation of each sample window

B. 1    Overview

With theID78K4-NS, the user can create custom windows in addition to the existing windows.

The Tcl (Tool Command Language) interpreter and the commands for controlling the debugger are

implemented in the ID78K4-NS. Users can create windows using this Tcl.

The ID78K4-NS is supplied with samples of the following expansion windows.

Caution When the ID850 (SP850 Ver.3.0 or later) is installed, the "RRM Window" and "Memory 
Mapped I/O Window" can be selected.  However, these windows cannot be used in 
the ID78K4-NS.

B. 2    Activation

The expansion window can be activated by selecting List, Grep, RRM, Hook, or Memory in [Others] on

the [Browse] menu.

Reference Each .tcl file is installed in NECTools32\BIN\idtcl\tools.

B. 3    Explanation of each sample window

Table B-1　List of Expansion Window

Window Name Function

List window Displays a list of the source files and functions.

Grep window Searches a character string.

Hook window Sets the hook procedure.
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List window

The lists of the source files and functions are displayed in a tree format in this window. When a function

name in the list is clicked, the corresponding source is displayed.

Figure B-1  List Window
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Grep window

Search for a character string is performed in the files under the source path.

When the search result is clicked, the corresponding source is displayed.

Figure B-2  Grep Window

Object Function

Pattern Input the character string to be searched.

<Mark> button Marks the searched character string.

<Clear> button Clears the marking

<Jump> button Put the cursor on a section in the search result and click this button to open 
the corresponding file

Match Case Select whether or not to distinguish uppercase and lowercase.

Filter Specify the type of the file to be searched.
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Hook window

This window is used to set a hook to the debugger, using a hook procedure.

The hook procedure enables changing the register value before downloading a program, or after a CPU

reset.

On this window, a hook can be set by using the following four tabs.

[BeforeDownload] tab: Hook before downloading

[AfterCpuReset] tab: Hook after CPU resetr

[BeforeCpuRun] tab: Hook before start of execution

[AfterCpuStop] tab: Hook after break

By setting a SFR by using the [BeforeDownload] tab before downloading the load module, for example,

downloading can be executed at high speeds. Access to the external memory is also facilitated by using this

tab.

In addition, please make reference Following URL (microcomputer home page FAQ) about a setup of

SFR.

http://www.necel.com/micro/

If the setting is saved as "project-file-name.tcl" in the directory where the project is stored, the setting is

executed when the project is next opened.

Figure B-3  Hook Window

Object Function

[BeforeDownload] tab Hook before downloading
Before downloading is performed, the register values input to the tab are 
automatically overwritten by the specified value.

[AfterCpuReset] tab Hook after resetting CPU
after resetting CPU, the register values input to the tab are automatically 
overwritten by the specified value.
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Caution Specify the program register and the SFR for the register name.

[BeforeCpuRun] tab Hook before starting execution
before starting execution, the register values input to the tab are 
automatically overwritten by the specified value.

[AfterCpuStop] tab Hook after breaking
After breaking, the register values input to the tab are automatically 
overwritten by the specified value.

<Test> button All the commands described on the tabs are tested.

<Save> button Saves all the tab contents to a file.
If the ID78K4-NS was activated from a project file, the file is saved as 
"project-file-name.tcl".

<Clear> button Clears all the descriptions on the tabs.

Object Function
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APPENDIX C  TERMINOLOGY

The major terms used throughout this manual are as follows:  

• Current window

• Delimiter (separator)

• Program

• File

• Function

• Structure

• Stack frame number

• Line

C. 1    Terminology

Current window

The current window is the window you are now in and operating by means of key input and menu 

selection.

Delimiter (separator)

The following separators can be used as the delimiter of file names, function names, variable names, 

and line numbers.

Program

A program is the execution unit to be debugged.  The debugger manages each one of the load module 

files specified on downloading as a program. 

To specify a program name, use a load module file name on downloading.

Current program

The current program is the program that contains the instruction currently breaking execution 

(instruction indicated by the PC).

When specifying a file in the current program, the program name may be omitted.

File 

Up to 127 characters can be handled in a file name with path.

Depending on the type of file, however, a file name of more than 127 characters can be specified.

Table C-1　Delimiter

Delimiter Meaning

# Used as a separator of file names, variable names, function names, and line 
numbers.

$ Used as a separator of load module names, file names, variable names, and 
function names.
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Current file

The current file is the source file that contains the instruction currently breaking execution (instruction 

indicated by the program counter (PC)). 

When specifying a line or function in the current file, the file name may be omitted.

Function

Indicates the functions constituting a C source program.

Current function

The current function is the function that contains the instruction currently breaking execution 

(instruction indicated by the program counter (PC)).

When accessing a local variable in the current function, specifying the function name may be omitted.

Structure

Structures and unions in C language are called structures.

The name structure is used if a structure or union variable is used without members explicitly specified.

Stack frame number

The stack frame number is a decimal integer starting from 1 and is assigned to the stack contents.  The 

shallower the nesting level of the stack, the higher the number.  A function having a stack number one 

less than that of a certain function is the function that calls the certain function.

Line

A line is specified in order to identify one line in the source file. 

Specify a line number as an integer constant, starting from 1.
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APPENDIX D  MESSAGES

This appendix explains the messages displayed in the Error/Warning dialog box of the debugger.  

D.1    Error/Warning Messages from 

D. 1. 1    Display format of 

Messages  are generated and output to the Error/Warning dialog box when "information that should be

informed to users (fatal error, syntax error, and warning or questions)" is detected while the debugger is

executing processing.  

The product name is displayed on the title bar of the dialog box.  

Figure D-1 Error/Warning Messages 

There are three types of messages in the debugger (fatal error message, syntax error message, and

warning message or question message).  

A : Fatal error messages

When a fatal error is detected in the debugger, a message is output to the Error dialog box

before aborting the processing and terminating the debugger.  

F : Syntax error messages

When a syntax error is detected in the debugger, a message is output to the Error dialog box

before aborting the processing.  At this time, opened windows and dialog boxes are closed.  

W : Warning message or question message

When a warning or question is detected in the debugger, a message is output to the Warning

dialog box before aborting the processing.  

D. 1. 2    Fatal error messages

A list of the messages that are output when fatal errors are detected while the debugger is executing

processing is shown below in numerical order.  

Table D-1  Fantal error messages

Error No. Message

A0101 Can not find initialization file (expc.ini).
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A0102 Host name not found.

A0105 Failed in reading device file (d4xxx.78k).
Necessary files may be damaged.  Reinstall the device file.

A0106 Illegal data received.
Countermeasure  Check the power of the in-circuit emulator, cable connections, and setting of 

the interface board and restart the debugger.

A01a1 Failed in reading EX78K4.OM0.

A01a2 Break board is not connected.

A01a3 Emulation board is not connected.

A01a4 Board configuration of ICE is not consistent.

A01a5 POD/EM1 board is not connected.

A01a6 Executor is running.

A01a7 Failed in reading micro program file (m4xxx.78k).

A01a8 Failed in reading initialization file (expc.ini).

A04a1 Not enough memory for emulation. 

A0600 Not enough memory for buffer.
Countermeasure  There is not enough system memory.  Close the applications being executed 

and the open files.

A1000 Failed in initializing ICE.

A1001 No entry exists for specified number.

A1002 Can not relocate internal RAM.

A1005 Illegal relocation address.

A1007 Not enough memory on ICE.

A1008 Not enough memory for tables.
Countermeasure  There is not enough system memory.  Close the applications being executed 

and the open files.

A1009 Already initialized.

A100a Not initialized.

A10ff Can not communicate with ICE.

A1dbe Error occurred inside debugger.

A2001 Illegal address.

A2009 Device file is damaged or error is in file.

A200b Can not copy.

A200c Not enough memory.
Countermeasure  There is not enough system memory.  Close the applications being executed 

and the open files.

A20ff Can not communicate with ICE.

A2222 Illegal condition.

A3012 Not enough memory. 
Countermeasure  There is not enough system memory.  Close the applications being executed 

and the open files.

Table D-1  Fantal error messages

Error No. Message
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A30ff Can not communicate with ICE.

A4011 Not enough memory.
Countermeasure  There is not enough system memory.  Close the applications being executed 

and the open files.

A4018 Not enough memory.
Countermeasure  There is not enough system memory.  Close the applications being executed 

and the open files.

A5000 Illegal device file type.

A5001 Not enough memory. 
Countermeasure  There is not enough system memory.  Close the applications being executed 

and the open files.

A5002 Can not open device file.

A5003 Reading of device file went wrong.

A5004 Can not close device file.

A5005 Illegal device file format.
Countermeasure  Necessary files may be damaged.  Reinstall the device file.

A5006 Failed in initializing ICE.

A5007 Device file has broken or error is in a file.

A500c Failed in reading expc.ini.

A500d Not enough memory.
Countermeasure  There is not enough system memory.  Close the applications being executed 

and the open files.

A5300 Illegal device file type.

A5301 Not enough memory.
Countermeasure  There is not enough system memory.  Close the applications being executed 

and the open files.

A5302 Can not open database file.
Countermeasure  Necessary files may be damaged.  Reinstall the  and device file.

A5303 Reading of database file went wrong.

A5304 Can not close database file.

A5305 Illegal database file format.
Countermeasure  Necessary files may be damaged.  Reinstall the debugger or simulator, and 

device file.

A5306 Database information has been already initialized.

A5307 Database information does not exist.

A7012 Not enough memory.
Countermeasure  There is not enough system memory.  Close the applications being executed 

and the open files.

A70fe Bus hold error.
Countermeasure  CPU is in the bus-hold status.  Reset the debugger.

A70ff Can not communicate with ICE.

A7f03 Failed in canceling RUN/STEP.

A9000 Specified register symbol does not exist.

Table D-1  Fantal error messages

Error No. Message
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A9001 Specified register symbol ID does not exist.

A9003 Illegal condition.

A9004 Too large register size.

Aa005 Not enough memory.
Countermeasure  There is not enough system memory.  Close the applications being executed 

and the open files.

Aa00b Can not close file.

Aa00c Failed in reading file.
Countermeasure  The file is damaged or does not exist.  Recreate the file.

Aa010 Can not communicate with ICE.

Aa013 Reading of file went wrong.

Ab009 Not enough memory.
Countermeasure  There is not enough system memory.  Close the applications being executed 

and the open files.

Ab00d Current function does not exist.

Ab00e Current line does not exist.

Ab00f Tag not found.

Ab010 Failed in loading symbol table.

Ab011 Illegal line number.

Ab015 Reading of file went wrong.
Countermeasure  The file is damaged or does not exist.  Recreate the file.

Ab016 Can not open file.
Countermeasure  The file is damaged or does not exist.  Recreate the file.

Ab017 Failed in writing file.
Countermeasure  The file is damaged or does not exist.  Recreate the file.

Ab019 Reading of file went wrong.

Ab01a Can not close file.

Ab01c Too many entries of the task kind .

Ab023 Current stack frame is not active.

Ab024 Different section.

Ab02a Can not communicate with ICE.

Ab030 Monitor timed out.
Countermeasure  Check the power of the in-circuit emulator, cable connections, and setting of 

the interface board and restart the debugger.

Ab031 Already set in memory.

Ab032 Out of scope.

Ab033 LP is not stored.

Ab039 Failed in loading debug information.

Ab03a No more section information.

Ab041 Specified file is not load module.

Table D-1  Fantal error messages

Error No. Message
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D. 1. 3    Syntax error messages

A list of the messages that are output when syntax errors are detected while the debugger is executing

processing is shown below in numerical order.  

Ac002 Can not close file.

Ac003 Reading of file went wrong.
Countermeasure  The file is damaged or does not exist.  Recreate the file.

Ac004 Reading of file went wrong.

Ac009 Not enough memory.
Countermeasure  There is not enough system memory.  Close the applications being executed 

and the open files.

Ac010 Can not communicate with ICE.

Ad000 Error occurred inside debugger.

Ad001 Not enough memory.
Countermeasure  There is not enough system memory.  Close the applications being executed 

and the open files.

Ad002 Failed in reading initialization file (expc.ini).

Ad003 ICE is not connected.

Ae008 Not enough memory
Countermeasure  There is not enough system memory.  Close the applications being executed 

and the open files.

Af000 Not enough memory.
Countermeasure  There is not enough system memory.  Close the applications being executed 

and the open files.

Table D-1  Fantal error messages

Error No. Message

Table D-2  Syntax srror messeages

Error No. Message

F0002 This feature is not supported.

F0100 Can not communicate with ICE. Please confirm the installation of the device driver for the PC 
interface board.

F0103 Data transfer to ICE is timed out. Please confirm the power of ICE, connection of the interface 
cable, or I/O address of the PC interface board.

F0104 Data receive from ICE is timed out. Please confirm the power of ICE, connection of the interface 
cable, or I/O address of the PC interface board.

F01a0 No response from the emulation CPU. Please confirm the signal.

F0200 No mapped address was accessed.
Countermeasure  External memory could not be accessed, as it is not set.  Change the register 

values necessary for accessing the external memory using the SFR window 
or Hook Procedure before download.  

F02a0 Bus hold error.
Countermeasure  CPU is in the bus-hold status.  Reset the debugger.

F02a2 CPU is in the bus-hold status.  Reset the debugger.

F0300 User program is running.
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F0301 User program is being breaked.

F0302 User program is being traced.

F0303 Not traced.

F0304 Trace memory is not set.

F0306 No trace block exists.

F0307 No event condition exists.

F0308 No timer measurement is done.

F0309 No trigger frame exists.

F030a Tracer is being stopped.

F030b Specified snap-event has not been registered.

F030c Specified stub-event has not been registered.

F030d Timer is running.

F030e Memory copy area is overlapped.

F030f Trace has been already set.

F0310 Event condition is not set.

F0311 Too many valid timer event conditions.

F0312 Specified timer event is not set.

F0313 illegal map range.
Countermeasure  Check the setting in "Memory Mapping (mapping setting area)" in the 

Configuration dialog box.  When mapping to external memory has been 
performed, change the register values necessary for accessing the external 
memory using the SFR window or Hook Procedure before download.

F0315 Delay trigger cannot set with trace full mode.

F03a1 Step execution is being done.

F03a2 Timer and Tracer are running.

F03d2 Back-trace execution point overrun oldest frame.

F03d3 Register status or Memory status cannot be set up other than Phase1 of event link.

F03d4 No back-trace information exists.

F03d5 Last command can not be backstepped.

F0400 Illegal condition.
Countermeasure  Settings of the used in-circuit emulator and those of the Configuration dialog 

box may not match.  Check the Chip selection of "Chip (Emulation CPU 
selection area)".

F0401 Result of timer measurement overflowed.

F0402 Too many event conditions with pass count.

F0403 Too many address range conditions.

F0404 Too many simultaneously-usable-event conditions.

F0405 Too many snap-events.

F0406 Too many stub-events.
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F0407 Too many initialization data.

F0408 Too large search data (> 16 byte).

F0409 Too large search data (> search range).

F040a Too many Linking-event conditions.

F04a0 Too many software breaks (> 100).

F04a2 Too many partition of bus size.

F04a3 Too many execution-event conditions.

F04a4 Too many bus-event conditions.

F0b00 Cannot open FPGA file(GXXXX.78K).

F0b01 Error is in form of FPGA file(GXXXX.78K).

F0b02 FPGA board Broken.

F0b03 No match device file of version.

F0b04 Target power mode mismatch.

F0b20 This event number can not be used.

F0b21 Timeout break condition has not set up.

F0b22 Timer event condition has not set up.

F0b23 Specified event has been already used at option/main.

F0b24 Cannot use the delay count and the software breaks at the same time.

F0b40 Can not execute specified tracer.

F0b60 External Trigger event conditions overflow.

F0b61 Section Trace event conditions overflow.

F0b62 Break before execute event conditions overflow.

F0b63 Specified event has been already use.

F0b64 Event conditions number overflow.

F0b65 Option/Main event conditions overflow.

F0b80 Reset by hardware error.

F1003 Illegal relocation address.

F1004 Illegal condition

F1006 Illegal address.

F100b User program is running.

F100c Different bus size has been already specified.

F100d Too large bus size.

F100e Too large bus partition size.

F100f Target is not turned on.

F1010 Illegal map range. 

F1011 Failed in setting internal ROM and RAM.
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F1012 This feature is not supported.

F1013 No terminal name.

F1017 I/O Protect mapping is possible a target attribute only.

F1018 Illegal Internal ROM size.

F1019 Illegal Internal ROM size or Internal RAM size.

F2000 Illegal SFR name.

F2002 User program is running.

F2003 Illegal SFR number.

F2004 Illegal bit number.

F2006 Hidden SFR was specified.

F2007 SFR of ban read/write was specified.

F2008 SFR not existing was specified.

F200a Illegal value specified for SFR.

F3000 No mapped address was accessed.
Countermeasure  The allocation addresses of the program and the addresses of the debugger 

may not match.  
Set the mapping to the external memory in "Memory Mapping (mapping 
setting area)" in the Configuration dialog box according to the allocation 
addresses specified in the link directive file on compilation.  When mapping to 
external memory has been executed, change the register values necessary 
for accessing the external memory using the SFR window or Hook Procedure 
before download.

F3001 Memory has different value.

F3002 Illegal start address.

F3003 Illegal end address

F3004 Illegal start address and end address.

F3005 Illegal condition.

F3006 User program is running.

F3007 Verification error.

F3008 No condition specified.

F3009 Parameter size does not align with access size alignment.

F300a Specified address does not align with access size alignment.

F300b Source address does not align with access size alignment.

F300c Destination address does not align with access size alignment.

F300d Illegal end address.

F300e Different access size in specified area.

F300f Different access size both in source and destination areas.

F3010 Different access size in destination area.

F3011 Different access size, source & destination.

F3013 Failed in writing DMM.
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F3014 Oveflowed mapping area.

F3015 Processing was interrupted.

F3016 This feature is not supported.

F4000 Can not delete specified event.
Countermeasure  The specified event cannot be deleted as it is being used under another 

condition.  Invalidate it for other usages before deleting.

F4001 Illegal table number.

F4002 Illegal start address.

F4003 Illegal end address.

F4004 Illegal status.

F4005 Illegal data.

F4006 Specified event number has been already used.

F4007 Too many same events are registered.

F4008 Specified event has not been registered.

F4009 Illegal data size.

F400a Illegal mode.

F400b Setting value is inaccurate.

F400c Event link conditions cannot be used for section trace conditions.

F400d Too many identical events are registered (>= 32767).

F400e Specified event condition does not exist.

F400f Illegal event link condition.

F4010 Function not found.

F4012 Timer is being disabled.

F4014 Can not use software break.

F4015 Can not use event condition specifying address range.

F4016 Can not change event condition.

F4017 Can not access word at odd address.

F4019 This feature is not supported.

F401a No Event.

F401b Can not use tag-event.

F401d Start event and end event of timer are not made to the same setup.

F401e Too many trace-events.

F401f Pass count cannot be set up.

F4020 Address range cannot be set up in event before execution.

F4021 Event conditions number overflow.

F4022 Software DMM conditions number overflow.

F4023 Real-time call conditions number overflow.
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F4024 Software break call conditions number overflow.

F4318 Illegal memory bank setting.

F5008 Can not open device file.
Countermeasure  Necessary files may be damaged.  Reinstall the device file.

F5009 Can not open EX78K4.OM0.

F500a Specified device file is illegal version.
Countermeasure  Necessary files may be damaged.  Reinstall the device file.

F5308 Can not open specified database file.
Countermeasure  Necessary files may be damaged.  Reinstall debugger or simulator.

F5309 Specified database file is illegal version.
Countermeasure  Necessary files may be damaged.  Reinstall the debugger or simulator, and 

the device file.

F6000 Current function does not exist.

F6001 Illegal symbol name.

F6002 Illegal condition.

F6003 Illegal function name.

F6004 Overflowed output buffer size.

F6005 Illegal expression.

F7000 Illegal mode.

F7001 User program is running.

F7002 User program has been stopped.

F7003 Trace enabled.

F7004 Trace memory is not set.

F7005 Function return address does not exist, can not do step execution.

F7801 End waiting state of step execution was canceled.

F7802 End waiting state of step execution was canceled.

F7f00 Aborted step execution.

F7f02 Suspended step execution.

F7f04 Can not execute non-mapped area.

F7f05 This feature is not supported.

F8000 Specified file was not found.

F8001 Illegal line number.

F8002 Current information is not set.

F8003 Illegal address.

F8004 This feature is not supported.

F9002 Illegal value.

F9005 This feature is not supported.

Fa001 Illegal expression.
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Fa002 Start address is bigger than the end address.

Fa003 Illegal source path.

Fa004 Too long expression.

Fa006 Illegal argument.

Fa007 Illegal program number.

Fa008 Source path is not set.

Fa009 File not found.

Fa00a Can not open file.
Countermeasure  The file is damaged or does not exist.  Recreate the file.

Fa00d Not source file of load module.

Fa00e Illegal line number.

Fa00f Variable does not exist.

Fa011 Can not access register.

Fa012 Can not access memory.

Fa014 It was going to open the binary file.

Fa015 Can not get temporary path.
Countermeasure  The disk is full.  Delete or move unnecessary files and increase the available 

memory in the disk.

Fa016 Can not create temporary file.
Countermeasure  The disk is full.  Delete or move unnecessary files and increase the available 

memory in the disk.

Fa017 Can not remove temporary file.

Fa020 This feature is not supported.

Fa021 Symbol assigned to register cannot be specified.

Fb000 Illegal command line.

Fb001 Program information does not exist in specified load module file.

Fb002 File not found.

Fb003 Function not found.

Fb004 Selected load module different from kind(Chip) was loaded.

Fb005 Symbol not found.
Countermeasure  The address could not be found.  Specify a location holding address 

information.

Fb008 Illegal expression.

Fb00a Illegal symbol in load module file.

Fb00b Current program does not exist.

Fb00c Current file does not exist.

Fb012 Too large line number.

Fb01b Too long load module file name.

Fb01d Address not found.
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Fb01f Can not find structure member.

Fb020 Can not find value.

Fb021 No debug information exists in load module file.
Countermeasure  To create a load module with appended debug information, execute build in 

build mode of Debug Build.

Fb022 Illegal line number.

Fb026 Too many array dimensions (> 4).

Fb027 Found end of file.
Countermeasure  The specified file may be damaged.  Recreate the file.

Fb028 This feature is not supported.

Fb029 Illegal address.

Fb02b Can not stack trace with current PC value.

Fb02c Too many blocks for one function.

Fb02d Illegal argument.

Fb02e The file does not exist in the SOURCE PATH.
Countermeasure  On stopping the program, the source that the debugger tried to display could 

not be found.  Check if the path connects to the source (using "Source Path 
(source path specification area)" in the Debugger Option dialog box), or 
check if the source is in the same directory as the out file.  Refer to the 
Assemble window on which the error message is displayed, and check if the 
corresponding path connects.

Fb02f Information has been deleted because of optimization.

Fb034 Return execution from present PC position cannot be performed.

Fb037 Too Many Line-Numbers Information.

Fb038 Compiler version mismatch.
Countermeasure  Recreate the load module with the latest compiler.

Fb040 Specified file is not load module.
Countermeasure  This is not a linker output file.  Source debug cannot be executed with the 

load module before output from the linker.  Specify the load module output 
from the linker.

Fb32e Illegal port number.

Fb32f Illegal port name.

Fb330 Illegal port position.

Fb331 Illegal increment number.

Fb332 Port for memory bank is not set.

Fb333 Illegal bank number.

Fb334 Area for memory bank is not set.

Fc001 Can not open file.
Countermeasure  The file is damaged or does not exist.  Recreate the file.

Fc005 Illegal file type.

Fc006 Kind(Chip) of load module is illegal.
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Fc007 Specified file is not load module.
Countermeasure  This is not a linker output file.  Source debug cannot be executed with the 

load module before output from the linker.  Specify the load module output 
from the linker.

Fc008 Specified load module file (COFF) is old version.

Fc00a No mapped address was accessed.

Fc00b Load module is not loaded.

Fc00c Illegal argument.

Fc00d User program is running.

Fc00e User program is being traced.

Fc00f Interrupted.

Fc011 Illegal load module file format.

Fc012 Check sum error.

Fc013 Too wide address range to upload (> 1M byte).

Fc014 Failed in writing file.
Countermeasure  The file is damaged or does not exist.  Recreate the file.

Fc015 Illegal program number.

Fc016 Load information is full.

Fc018 Specified file is not load module.
Countermeasure  This is not a linker output file.  Source debug cannot be executed with the 

load module before output from the linker.  Specify the load module output 
from the linker.

Fc019 Failed in writing memory.

Fc01a No mapped address was accessed.

Fc100 This feature is not supported.

Fd004 Can not find Dynamic Link Library.

Fe000 Illegal argument.

Fe001 Illegal start address.

Fe002 Illegal end address.

Fe003 Too large size.

Fe004 Can not open file.
Countermeasure  The file is damaged or does not exist.  Recreate the file.

Fe005 Failed in reading file.
Countermeasure  The file is damaged or does not exist.  Recreate the file.

Fe006 Reading of file went wrong.

Fe007 Failed in writing file.
Countermeasure  The file is damaged or does not exist.  Recreate the file.

Fe009 Illegal file format.

Fe00a Verification error.

Fe010 This feature is not supported.

Ff001 [XXX] not found.
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Ff004 Missing parameter.

Ff005 Illegal function name.

Ff006 Illegal number.

Ff007 Start address is bigger than end address.

Ff008 Illegal symbol or expression.

Ff009 [XXX] This file is illegal type.

Ff100 Disk cannot write or full.

Ff101 File not found.

Ff102 File not Create.

Ff103 Old project file version.

Ff104 Illegal project file format.

Ff105 This file is a project file for [XXX].Please select a correct file.

Ff201 Memory mapping error.

Ff202: Verify error.
Countermeasure  External memory could not be accessed, as it is not set. Change the register 

values necessary for accessing the external memory using the SFR window 
or Hook Procedure before download.

Ff301 The symbol being used on the event condition can't be evaluated.

Ff306 This name is too long.

Ff307 There is the same name in other kinds.

Ff308 An address can't be omitted.

Ff309 Illegal address mask.

Ff30a Illegal data mask.

Ff30b Illegal ext probe mask.

Ff30c Illegal ext probe data.

Ff30d Illegal pass count.

Ff30e Illegal register name.

Ff310 Illegal delay count.

Ff312 [XXX] is already there.

Ff313 Event number already exist.

Ff314 Event name is not set.

Ff315 [XXX] is already there.

Ff316 Max number of enabled [XXX] event is over. Please disable other enabled [YYY] event.

Ff317 Max number of set event is over.

Ff31e Illegal start address.

Ff31f Illegal end address.

Ff322 Illegal count rate.

Ff324 Section and Qualify can not be specified at the same time.
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Ff350 There is a phase which event are not in the middle.

Ff351 The same event is contained in Link and Disable.

Ff352 An event isn't specified.

Ff357 AND event is in Phase.

Ff500 Illegal symbol.

Ff501 Illegal value.

Ff502 Illegal parameter.

Ff503 Max number of symbol is over.

Ff504 This variable cannot be set as a break.
Countermeasure  Break cannot be set for the following variables.

• Local variables, static variables

• Array variables, member variables of structures/unions

• Register/SFR

• Variable expressions

Ff802 All events are deleted. because the use of external probe was changed.

Ff803 This event address is invalid on current configuration.

Ff804 Invalid PC value.

Ff805 Cannot set temporary break on this address.

Ff806 External data is being used by Debugger.

Ff900 Illegal I/O port name.

Ff901 Memory mapping error.
Countermeasure  The specification of the address is illegal.  The addresses that can be 

specified are in either the Target area or SFR area.  Check in "Address: (I/O 
port address specification area)" in the Add I/O Port dialog box.

Ff902 Illegal access size.

Ff903 Illegal access type.

Ff904 There is the same name.

Ffa00 The [XXX] function of current program in PC position not found.
Countermeasure  The symbol specified in main() label: in "Startup Routine (start-up symbol 

setting area)" in the Debugger Option dialog box could be found.  Set a 
symbol of the main routine of the program.  Default is _main.

Ffa01 The line information on PC position not found.
Countermeasure  The source file corresponding to program counter (PC) value when the 

program was stopped could not be found.  The following reasons are 
possible.

1 The source file exists in a location that the source path does not connect to.

2 The program stopped where the source files, such as library or RX, do not

exist.

3 The program looped, jumped to an address that is not used by the program,

and stopped there.
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D. 1. 4    Warning message or question message

A list of the messages that are output when warnings or questions are detected while the debugger is

executing processing is shown below in numerical order.  

Ffc00 Help window cannot be started.  Please install HTML Help environment with reference to a users 
manual.

Fffff Interrupted.

Table D-2  Syntax srror messeages
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W03a0 Target is not turned on.

W1014 Data is not exist.

W2005 SFR of Read Protect attribute was specified.

W200d No initialize data for SFR.

W4013 Access size is different from its mapped bus size.

W401c Software break can not be set on this area.

W500b Specified device file does not relocate IRAM.

W7010 No source information exists.

W7011 Unknown result of step execution.

Wb01e No debug information (not compiled in Debug Build mode).

Wb036 Out of variable region.

Wb042 Symbol module is not initialized.

Wb335 Too long symbol name.

Wc017 Symbol information is duplicated, please reset symbols.

Wc01d Selected load module different from kind(Chip) was loaded.

Wf002 Not found [XXX]. Search from the beginning?

Wf003 Already exceed search region.

Wf106 CPU in the Project File was Changed.  You must exit the debugger for the new CPU.  Do you exit 
the Debugger?

Wf107 CPU in the Project File was Changed.  Do you start the Debugger with this CPU?

Wf108 Selected project file different [YYY] from chip [XXX] was opened.  Does it open, although the chip 
cannot be changed?

Wf109 Project Manager cannot be used with the debugger of this version.  Please use PMplus.

Wf200 No differences encountered.

Wf203 When a program is running, while rewriting a memory, program execution stops for a moment.  
Do you wish to rewrite a memory?

Wf300 Would you like to save the changes made in [XXX]?

Wf302 Delete: [XXX]
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Wf303 [XXX] is edited. Delete: [YYY]?

Wf304 [XXX] is edited. Save: [YYY]?

Wf305 [XXX] is already exist. Do you replace it?

Wf311 Only one [XXX] can be enabled.  Do you make this [YYY] to enable?

Wf600 Save project file?

Wf601 When connecting the target system, please turn on the target system.
Countermeasure  When a target is not connected, simply click the <OK> button.

Wf602 Please change a MODE mask condition or connect the target system.

Wf700 Do you want to download Load Module File?

Wf905 [XXX] is already exist. Do you replace it?

Wf906 Would you like to register the change made in [XXX]?

Wfb00 User program is running. Do you want to stop user program?

Wfe0b It shift to the flash mode. Is it completely cleared but is the present event.
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APPENDIX E  KEY FUNCTION LIST

Debugging can be efficiently executed by using special function keys.  

Note that, in the following explanation, ordinary key representation (generic key representation) is used

because the key representation differs depending on the type of keyboard.  

Table E-1 through Table E-8 list the functions of the respective keys.  

E. 1    Function List of Special Function Keys

Table E-1　Function List of Special Function Keys

Key Function

BackSpace Deletes one character before the cursor and moves the cursor to the position of 
the deleted character.
At this time, the character string following the cursor moves forward.

Delete Deletes one character after the cursor and move the character string following the 
cursor forward. 
Deletes a various event condition selected in the Event Manager or each event 
dialog box.  
Deletes the data selected in the Watch window.

Insert Alternately selects the insert mode and overwrite mode in the Source window and 
Assemble window.  However, this key is invalid in the Memory, Register, and SER 
windows, and only the overwrite mode can be used as an input mode.  

PrintScreen Loads the entire display screen to the clipboard as a bitmap image (function of 
Windows).

Esc Closes the pull-down menu.
Closes the modal dialog box.
Restores the input data.

Alt Moves the cursor to the menu bar.

End Moves the cursor to the end of the line.

Home Moves the cursor to the beginning of the line.

PageUp Scrolls the screen one screen up.  The cursor also moves up to the top of the 
screen.

PageDown Scrolls the screen one screen down.  The cursor also moves up to the top of the 
screen.

Space Inserts one blank character.

Tab Moves the cursor to the next item.

Up arrow key Moves the cursor up.
If the cursor is at the bottom of the screen, scrolls the screen up one line at a time.

Down arrow key Moves the cursor down.
If the cursor is at the top of the screen, scrolls the screen down one line at a time.

Right arrow key Moves the cursor to the left.
If the cursor is at the leftmost position on the screen, scrolls the screen one column 
to the right.
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E. 2    Function List of Function Keys

E. 3    Function List of Special Function Keys (Shift + key) 

Left arrow key Moves the cursor to the right.
If the cursor is at the rightmost position on the screen, scrolls the screen one 
column to the left.

Enter Sets the input data.
Presses the default push button.

Table E-1　Function List of Special Function Keys

Key Function

Table E-2　Function List of Function Keys 

Key Function

F1 Opens the Help window.  

F2 Forcibly stops program execution.
Same function as [Run] ->  [Stop] on the menu bar.  

F3 Resets the emulation CPU.
Same function as [Run] -> [CPU Reset] on the menu bar.  

F4 Resets the emulation CPU and executes the program.
Same function as [Run] -> [Restart] on the menu bar.

F5 Executes the program.
Same function as [Run] -> [Go] on the menu bar.

F6 Executes the program to the cursor position in the Source or Assemble window.
Same function as [Run] -> [Come Here] on the menu bar

F7 The user program is real-time executed until execution returns.   
Same function as [Run] -> [Return Out] on the menu bar

F8 Step execution.
Same function as [Run] -> [Step In] on the menu bar.  

F9 Sets a breakpoint at cursor position in Source or Assemble window.
Same function as [Run] -> [Break Point] on the menu bar.  

F10 Next step execution.
Same function as [Run] -> [Next Over] on the menu bar.  

F11 Sets or deletes a software breakpoint.
Same function as [Run] -> [Software Break Point] on the menu bar .  

Table E-3　Function List of Special Function Keys (Shift + key) 

Key Function

End Expands the selection range to the end of the line.

Home Expands the selection range to the beginning of the line.

Left arrow key Expands the selection range one character to the left.
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E. 4    Function List of Function Keys (Shift + key)

E. 5    List of Special Function Keys (Ctrl + key)

E. 6    Function List of Function Keys (Ctrl + key)

Right arrow key Expands the selection range one character to the right.

Table E-3　Function List of Special Function Keys (Shift + key) 

Key Function

Table E-4　Function List of Function Keys (Shift + key)

Key Function

F6 Executes the program from the cursor position in the Source or Assemble window.
Same function as [Run] -> [Start From Here] on the menu bar.  

F9 Resets the emulation CPU.
Same function as [Run] -> [CPU Reset] on the menu bar.  

Table E-5　List of Special Function Keys (Ctrl + key)

Key Function

End Displays the last line.
The cursor will also move to the last line.

Home Displays the first line.
The cursor will also move to the first line.

Left arrow key Moves the cursor one word to the left.
If the cursor at the leftmost position on the screen, scrolls the screen one column 
to the right.

Right arrow key Moves the cursor one word to the right.
If the cursor at the rightmost position on the screen, scrolls the screen one column 
to the left.

Table E-6　Function List of Function Keys (Ctrl + key)

Key Function

F5 Ignores break points being set, and executes the program.  
Same function as [Run] -> [Ignore break points and Go] on the menu bar.  

F9 Sets the address at the cursor position in the Source window or Assemble window 
to the PC.
Same function as [Run] -> [Change PC] on the menu bar.  
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E. 7    Function List of Control Keys (Ctrl + key)

E. 8    List of Special Function Keys (Ctrl + Shift + key)

Table E-7　Function List of Control Keys (Ctrl + key)

Key Function

A Selects all the events registered to the Event Manager.
Same function as [View] -> [Select All Event] on the menu bar in the Event Manager.  

C Copies a selected character string and saves it to the clipboard buffer.

D Disassembles and displays the results from the jump destination address specified by 
the data value selected in the current window.Opens the Assemble window.  
Same function as [Jump] -> [Assemble] on the menu bar.  

E Opens the source file displayed in the active Source window with the editor specified 
by the PM plus when the PM plus is running.  
Same function as [Edit] -> [Edit Source] on the menu bar.  

G Performs a search.Opens the search dialog box corresponding to the current window.
Same function as [View] -> [Search...] on the menu bar.  

J Moves the display position.  Opens the Source Move, Address Move, or Trace Move 
dialog box, depending on the current window.
Same function as [View] -> [Move...] on the menu bar. 

M Displays the memory contents from the jump destination address specified by the data 
value selected in the current window.  Opens the Memory window.
Same function as [Jump] -> [Memory...] on the menu bar.  

O Loads a view file, source file, or text file.
Opens the View File Load dialog box.  The operation will differ depending on the 
extension of the file.
view file: Displays the file in the corresponding window.
Others: Displays the file in the Source window.
Same function as [File] -> [Open...] on the menu bar.  

S Saves the data displayed in the current window to the view file.
Same function as [View] -> [Save...] on the menu bar.  

U Displays the corresponding source text and source line, using the data value selected 
in the current window as the jump destination address.  Opens the Source window. 
Same function as [Jump] -> [Source Text] on the menu bar.  

V Pastes the contents of the clipboard buffer to the text cursor position.

W Temporarily displays the contents of the specified data.
Opens the Quick Watch dialog box. 
Same function as [View] -> [Quick Watch...] on the menu bar.  

X Cuts a selected character string and saves it to the clipboard buffer.
Same function as [Edit] -> [Cut...] on the menu bar.  

Table E-8　List of Special Function Keys (Ctrl + Shift + key)

Key Function

Left arrow key Expands the selection range one word to the left.
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Right arrow key Expands the selection range one word to the right.

Table E-8　List of Special Function Keys (Ctrl + Shift + key)

Key Function
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APPENDIX F  INDEX
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assemble  … 262, 271
Assemble Search dialog box  … 138
Assemble window  … 131
Auto Load  … 82
Auto load  … 18, 71
Auto save  … 71, 80

B
Balloon watch function  … 28, 119, 162
batch  … 262, 272
Break dialog box  … 239
Break function  … 24
breakpoint  … 262, 273
Breakpoint for read/write access  … 162
Breakpoint setting/deletion function  … 116
Browse dialog box  … 101
Build mode  … 17

C
Callback procedure  … 265
Cause of stopping tracer  … 202
Change Watch dialog box  … 172
Character set  … 303
Color of character on event mark  … 217
Come function  … 21, 24, 123
Command  … 12, 261
Command line  … 262
Command list  … 262
Command reference  … 262
Compulsion read  … 187, 189
conditional trace  … 26
Configuration dialog box  … 15, 59
Console window  … 261
Contents Saved to Project File  … 78
Control register  … 185
Current window  … 313

D
Data display format  … 160
dbgexit  … 262, 275
Debugger Option dialog box  … 68
Debugging environment  … 20
Delay count  … 253
Delimiter  … 313
Device file  … 14
Display color of breakpoint  … 117
Display files  … 28

Displaying Event Details  … 219
download  … 262, 276
Download dialog box  … 94
Drag & drop function  … 125, 126

E
Environment File Load dialog box  … 92
Environment File Save dialog box  … 90
Error message  … 315
Error/warning message  … 315
Event condition  … 23
Event dialog box  … 226
Event display mark  … 118
Event function  … 23
Event link condition  … 23
Event Link dialog box  … 234
Event Manager  … 215
Exit Debugger dialog box  … 259
Expansion windows  … 308
Expressions  … 305
Extended Option dialog box  … 65
extwin  … 262, 277

F
Fail-safe break  … 25
Fatal error message  … 315
File  … 313
finish  … 262, 278
Flow of debugging operations  … 31
Font  … 71
Font dialog box  … 76
Format of file that can be downloaded  … 94
Format of specifiable file  … 98
Full stop  … 27
Function  … 314

G
-g option  … 14
go  … 262, 279

H
help  … 262, 280
hook  … 263, 281
Hook procedure  … 266
Host machine  … 13

I
I/O Port  … 187, 195
Illegal access break  … 25
Information files  … 29
initialized  … 255
Input conventions  … 303
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J
jump  … 263, 282
Jump function  … 33, 123

K
Kanji code  … 72
Key function list  … 332

L
Linking window  … 34
Load/save function  … 28
Local Variable window,  … 175

M
Main window  … 15, 40
map  … 263, 283
mapping function  … 20
Mapping unit  … 64
Marks of Event Icon  … 217
mask  … 62, 209, 230, 231
Maximum number of valid events  … 215
mdi  … 263, 285
memory  … 263, 286
Memory Compare dialog box  … 153
Memory Compare Result dialog box  … 155
Memory Copy dialog box  … 151
Memory Fill dialog box  … 149
Memory manipulation function  … 27
Memory Search dialog box  … 146
Memory window  … 141
Menu bar  … 42
Messages  … 315

Display format  … 315, 331
Fatal error message  … 315
Syntax error message  … 315, 319
Warning message or question message  …

315, 330
Mixed display  … 121, 201
mnemonic  … 201
module  … 263, 288

N
next  … 263, 289
Non map break  … 25
Non-real-time execution function  … 22
Non-stop  … 27
Normal mode  … 227, 235

O
Offset setting  … 96
Online assembly  … 131
Operating environment  … 13
Operating system  … 14
Operators  … 305

P
Pick up  … 214

Pickup display  … 204
PM plus  … 17
Point mark area  … 116, 132
Program  … 313
Program code  … 118, 119
Program counter setting  … 123
Program execution function  … 21
Project file  … 20, 71, 259
Project File Load dialog box  … 81
Project File Save dialog box  … 78

Q
Qualify trace  … 27, 245
Quick Watch dialog box  … 164

R
Range of radixes  … 307
Real-time execution  … 21
real-time internal RAM sampling function  … 30
refresh  … 263, 290
register  … 263, 291
Register manipulation function  … 27
Register window  … 182
Registering debugger  … 17
reset  … 263, 292
Reset Debugger dialog box  … 255
Right-click menu  … 39
run  … 263, 293
Run menu  … 21

S
Section event  … 248
Section trace  … 27, 244
Select mode  … 227, 232, 235, 237
Selecting debugger  … 17
Setting event condition in each area  … 236
Setting files  … 29
SFR Select dialog box  … 192
SFR window  … 187
Show offset  … 73
software break  … 25
Software Break Manager  … 223
Source Move dialog box  … 105
Source Path  … 69
Source Search dialog box  … 128
Source window  … 114
Specification of scope  … 169
Specifying Symbols  … 112
Stack frame  … 179, 314
Start function  … 21, 123
Start-up symbol  … 73
Static status  … 33
Status bar  … 57
step  … 263, 294
stop  … 263, 295
Structure  … 314
Symbol To Address dialog box  … 111
Symbols  … 304
Syntax error message  … 315, 319
System simulator  … 12
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T
Tab size  … 72
Terminology  … 313
Time measurement function  … 28
Timer Result dialog box  … 251
Toolbar  … 40
Trace condition  … 26
Trace Data Select dialog box  … 212
Trace dialog box  … 243
Trace function  … 26
Trace memory  … 26
Trace Move dialog box  … 108
Trace Search dialog box  … 205
Trace window  … 198
Tracer control mode  … 27

U
Unconditional trace  … 26
upload  … 263, 296
Upload dialog box  … 98

V
version  … 263, 297
View file  … 28
View File Load dialog box  … 87
View File Save dialog box  … 83

W
Warning message  … 315
Warning message or question message  … 315,

330
watch  … 263, 298
Watch function  … 27, 124
Watch symbol setting  … 74
Watch window  … 157
where  … 263, 299
Window lists  … 36
Window reference  … 36
wish  … 263, 300
Write-protect break  … 25

X
xtrace  … 263, 301
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