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Notice

All information included in this document is current as of the date this document isissued. Such information, however, is
subject to change without any prior notice. Before purchasing or using any Renesas Electronics products listed herein, please
confirm the latest product information with a Renesas Electronics sales office. Also, please pay regular and careful atention to
additional and different information to be disclosed by Renesas Electronics such as that disclosed through our website.

Renesas Electronics does not assume any liability for infringement of patents, copyrights, or other intellectual property rights
of third parties by or arising from the use of Renesas Electronics products or technical information described in this document.
No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights
of Renesas Electronics or others.

Y ou should not alter, modify, copy, or otherwise misappropriate any Renesas Electronics product, whether in whole or in part.

Descriptions of circuits, software and other related information in this document are provided only to illustrate the operation of
semiconductor products and application examples. Y ou are fully responsible for the incorporation of these circuits, software,
and information in the design of your equipment. Renesas Electronics assumes no responsibility for any lossesincurred by
you or third parties arising from the use of these circuits, software, or information.

When exporting the products or technology described in this document, you should comply with the applicable export control
laws and regulations and follow the procedures required by such laws and regulations. Y ou should not use Renesas
Electronics products or the technology described in this document for any purpose relating to military applications or use by
the military, including but not limited to the devel opment of weapons of mass destruction. Renesas Electronics products and
technology may not be used for or incorporated into any products or systems whose manufacture, use, or sale is prohibited
under any applicable domestic or foreign laws or regulations.

Renesas Electronics has used reasonable care in preparing the information included in this document, but Renesas Electronics
does not warrant that such information is error free. Renesas Electronics assumes no liability whatsoever for any damages
incurred by you resulting from errorsin or omissions from the information included herein.

Renesas Electronics products are classified according to the following three quality grades: “Standard”, “High Quality”, and
“Specific”. The recommended applications for each Renesas Electronics product depends on the product’ s quality grade, as
indicated below. Y ou must check the quality grade of each Renesas Electronics product before using it in aparticular
application. You may not use any Renesas Electronics product for any application categorized as “ Specific” without the prior
written consent of Renesas Electronics. Further, you may not use any Renesas Electronics product for any application for
which it is not intended without the prior written consent of Renesas Electronics. Renesas Electronics shall not bein any way
liable for any damages or losses incurred by you or third parties arising from the use of any Renesas Electronics product for an
application categorized as “ Specific” or for which the product is not intended where you have failed to obtain the prior written
consent of Renesas Electronics. The quality grade of each Renesas Electronics product is “ Standard” unless otherwise
expressly specified in a Renesas Electronics data sheets or data books, etc.

“Standard”: Computers; office equipment; communications equipment; test and measurement equipment; audio and visual
equipment; home electronic appliances, machine tools; personal electronic equipment; and industrial robots.
“High Quality”: Transportation equipment (automobiles, trains, ships, etc.); traffic control systems; anti-disaster systems; anti-
crime systems; safety equipment; and medical equipment not specifically designed for life support.
“Specific”: Aircraft; aerospace equipment; submersible repeaters; nuclear reactor control systems; medical equipment or
systems for life support (e.g. artificial life support devices or systems), surgical implantations, or heathcare
intervention (e.g. excision, etc.), and any other applications or purposes that pose adirect threat to human life.
Y ou should use the Renesas Electronics products described in this document within the range specified by Renesas Electronics,
especialy with respect to the maximum rating, operating supply voltage range, movement power voltage range, heat radiation
characteristics, installation and other product characteristics. Renesas Electronics shall have no liability for malfunctions or
damages arising out of the use of Renesas Electronics products beyond such specified ranges.
Although Renesas Electronics endeavors to improve the quality and reliability of its products, semiconductor products have
specific characteristics such as the occurrence of failure at a certain rate and malfunctions under certain use conditions. Further,
Renesas Electronics products are not subject to radiation resistance design. Please be sure to implement safety measures to
guard them against the possibility of physica injury, and injury or damage caused by fire in the event of the failure of a
Renesas Electronics product, such as safety design for hardware and software including but not limited to redundancy, fire
control and malfunction prevention, appropriate treatment for aging degradation or any other appropriate measures. Because
the evaluation of microcomputer software alone is very difficult, please evaluate the safety of the final products or system
manufactured by you.

Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental
compatibility of each Renesas Electronics product. Please use Renesas Electronics products in compliance with all applicable
laws and regulations that regulate the inclusion or use of controlled substances, including without limitation, the EU RoHS
Directive. Renesas Electronics assumes no liability for damages or losses occurring as aresult of your noncompliance with
applicable laws and regulations.

This document may not be reproduced or duplicated, in any form, in whole or in part, without prior written consent of Renesas
Electronics.

Please contact a Renesas Electronics sdes office if you have any questions regarding the information contained in this
document or Renesas Electronics products, or if you have any other inquiries.

(Note 1) “Renesas Electronics’ as used in this document means Renesas Electronics Corporation and also includes its majority-

owned subsidiaries.

(Note 2) “Renesas Electronics product(s)” means any product developed or manufactured by or for Renesas Electronics.
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Keep safety first in your circuit designs!

. Renesas Technology Corp. puts the maximum effort into making semiconductor products better and
more reliable, but there is always the possibility that trouble may occur with them. Trouble with
semiconductors may lead to personal injury, fire or property damage.

Remember to give due consideration to safety when making your circuit designs, with appropriate
measures such as (i) placement of substitutive, auxiliary circuits, (ii) use of nonflammable material or
(iii) prevention against any malfunction or mishap.

Notes regarding these materials

. These materials are intended as a reference to assist our customers in the selection of the Renesas
Technology Corp. product best suited to the customer's application; they do not convey any license
under any intellectual property rights, or any other rights, belonging to Renesas Technology Corp. or
a third party.

. Renesas Technology Corp. assumes no responsibility for any damage, or infringement of any third-
party's rights, originating in the use of any product data, diagrams, charts, programs, algorithms, or
circuit application examples contained in these materials.

. All information contained in these materials, including product data, diagrams, charts, programs and
algorithms represents information on products at the time of publication of these materials, and are
subject to change by Renesas Technology Corp. without notice due to product improvements or
other reasons. It is therefore recommended that customers contact Renesas Technology Corp. or
an authorized Renesas Technology Corp. product distributor for the latest product information
before purchasing a product listed herein.

The information described here may contain technical inaccuracies or typographical errors.
Renesas Technology Corp. assumes no responsibility for any damage, liability, or other loss rising
from these inaccuracies or errors.

Please also pay attention to information published by Renesas Technology Corp. by various means,
including the Renesas Technology Corp. Semiconductor home page (http://www.renesas.com).

. When using any or all of the information contained in these materials, including product data,
diagrams, charts, programs, and algorithms, please be sure to evaluate all information as a total
system before making a final decision on the applicability of the information and products. Renesas
Technology Corp. assumes no responsibility for any damage, liability or other loss resulting from the
information contained herein.

. Renesas Technology Corp. semiconductors are not designed or manufactured for use in a device or
system that is used under circumstances in which human life is potentially at stake. Please contact
Renesas Technology Corp. or an authorized Renesas Technology Corp. product distributor when
considering the use of a product contained herein for any specific purposes, such as apparatus or
systems for transportation, vehicular, medical, aerospace, nuclear, or undersea repeater use.

. The prior written approval of Renesas Technology Corp. is necessary to reprint or reproduce in
whole or in part these materials.

. If these products or technologies are subject to the Japanese export control restrictions, they must
be exported under a license from the Japanese government and cannot be imported into a country
other than the approved destination.

Any diversion or reexport contrary to the export control laws and regulations of Japan and/or the
country of destination is prohibited.

. Please contact Renesas Technology Corp. for further details on these materials or the products
contained therein.







Preface

Thistutorial will introduce you to the basic usage of the High-Performance Embedded
Workshop 3 (hereafter referred to as HEW). The tutorial describes a series of usage such as how
to invoke the HEW, how to create and modify a project, how to build a program, and how to
invoke a simulator/debugger from the HEW. For details on the HEW, the C/C++ compiler,
assembler, optimizing linkage editor, and simulator/debugger, refer to the following manuals.

e SuperH™ RISC engine High-Performance Embedded Workshop 3 User’s Manual

e SuperH™ RISC engine C/C++ Compiler, Cross Assembler, Optimizing Linkage Editor
User’'s Manual

For details on the SuperH™ RISC engine CPU, refer to a programming manual or a hardware
manual of the corresponding CPU.

Microsoft®, Windows®, Windows® 98, Windows Me®, Windows NT®, Windows 2000° and
Windows® XP are registered trademarks of Microsoft Corporation in the United States and/or in
other countries.

All other brand or product names used in this manual are trademarks or registered trademarks of
their respective companies or organizations.



Thistutorial iswritten assuming that all the tools included in the SuperH™ RISC engine C/C++
compiler Package areinstalled.

If “->" iswritten inside [ and ], the left hand side of “->" means the menu title and the right hand
side of “->" means a menu option of the menu. For example, in figure 1, the menu option [EXit]
in the [File] menu is described as [File->Exit].
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Section 1 Invoking the HEW

After the installation of the HEW, the installer creates a folder whose name is [Renesas High-
Performance Embedded Workshop] in the [Program] folder of the [Start] menu of the Windows".
In the [Renesas High-Performance Embedded Workshop] folder, short cuts of the HEW support
fileswill be registered.

If you click [High-Performance Embedded Workshop 3] from the menu, the HEW will be
invoked and the [Welcome!] dialog box (figure 1.1) will be displayed. Y ou can open the project
promptly without the [Welcome!] dialog box if you change the setting via[Tools->Options]. For
details of this setting, refer to chapter 6, “ Customizing the Environment”, of the High-
Performance Embedded Workshop 3 User’s Manual.

Welcomel ]

— Optians;
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' Create a new project workspace Cirical
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g ™ Browse to another project workspace

Fll

Figurel.1 Welcome! Dialog Box

If you use the HEW for the first time or if you want to work on a new project, select the [Create
anew project workspace] radio button and click [OK]. If you want to work on an existing project,
select the [Open arecent project workspace] or [Browse to another project workspace] radio
button and click [OK].

In thistutorial, select the [Create a new project workspace] radio button and click [OK].






Section 2 Creating a Project

2.1 Creating a New Workspace

When you have selected the [Create a new project workspace] radio button and clicked [OK] on
the [Welcomel!] dialog box, the [New Project Workspace] dialog box (figure 2.1), which isused
to create a new workspace and project, will be launched. Y ou will specify a workspace name
(When anew workspace is created, the project name is the same as the default), a CPU family, a
project type, and so on, on this dialog box.

Enter “tutorial”, for example, in the [Workspace Name] field, then the [Project Name] field will
show “tutorial” and the [Directory] field will show “C:\Hew2\tutorial”. If you want to change the
project name, enter anew project name manually in the [Project Name] field. If you want to
change the directory used for the new workspace, click the [Browse...] button and specify a
directory, or enter adirectory path manually in the [Directory] field.

Mew Project Warkspace d |
Projects |

' &pplication whorkzpace Mame;

D emanstration ItUt':'"EII

@ Empty Application .
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IE:HHEWSHtutDriaI Browsze. . |
LCPU Farnily:
ISuperH RISC engine j
T ool chain:
IHitau:hi SuperH Standard j

Properties. .. |

]9 I Cancel

Figure2.1 New Project Workspace Dialog Box




Table2.1 Itemsof [Project type:]

Items of [Project type:] Description

Application This project is used to create a program that includes the initial
routine files written in C/C++ or assembly language.

Demonstration This project is used to create the program for demonstration
written in C/C++ or assembly language.

Empty Application This project is used to set up the toolchain (no file is to be
generated).

Library This project is used to create a library file (no file is to be
generated).

2.2 Selecting the Target CPU

When you click [OK] on the [New Project Workspace] dialog box, the project generator will be
invoked. Start by selecting the CPU that you will be using. CPU types shown in the [CPU Type]
list are classified into the CPU series shown in the [CPU Series] list.

The selected itemsin the [CPU Series:] list box and the [CPU Type] list box specify the filesto
be generated. Select the CPU type of the program to be developed. If the CPU type which you
want to select is not displayed in the [CPU Type:] list, select a CPU type with similar hardware
specifications or select [Other].

Clicking [Next>] moves to the next display. Clicking [<Back] moves to the previous display or
the previous dialog box. Clicking [Finish] opens the [Summary] dialog box. Clicking [Cancel]
returns the display to the [New Project Workspace] dialog box. [<Back], [Next>], [Finish], and
[Cancel] are common buttons of all the wizard dialog boxes.

In thistutorial, select [SH-1] in the [CPU Series:] list and select [SH7020] in the [CPU Type]
list (figure 2.2). Then click [Next >].



ojeck-1/9

ek Target CPL. Toolchain wersi 7] x|

T oolchain version :

|s0.1.0 =l

Which CPU da wau want ba uge far this
projecty

CPLU Sefies:

[f there iz no CPU type to be zelected,
zelect the "CPU Type" that a similar to
hardware specification or zelect "Other'’.

Finizh | Cancel

Figure2.2 Selectingthe Target CPU (Step 1)




2.3 Option Setting
Clicking the [Next>] button on the Step-1 screen opens the dialog box shown in figure 2.3.
On this screen, you can specify options common to all project files.

Settings for these options can be modified in correspondence with the CPU series selected in step
1 screen. To change the option settings after a project has been created, select the CPU page
from the [Options -> SuperH RISC engine Standard Toolchain] menu item of the HEW window.

Click the [Next>] button without changing the setting. The Step-3 screen will be displayed.
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Figure2.3 Option Setting (Step 2)
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24 Setting the Contents of Filesto be Generated

Click the [Next>] button on the Step-2 screen to display the screen shown in figure 2.4.
On this screen, specify information that is necessary to generate files.

If [Use I/O Library] is checked, the standard I/O library can be used.

If [Use Heap Memory] is checked, the function sbrk() for heap area management will be
generated. Specify the number of bytes of the heap areain the [Heap Size:] edit box.

Select whether or not to generate a sample code for the main function from the [ Generate main()
Function] drop-down list.

If [1/O Register Definition Files] is checked, an 1/0 register definition file, which iswritten in C
language, can be created. Then select whether or not to generate a sample code for the program
that makes initial settings of the 1/0 registers from the [ Generate Hardware Setup Function]
drop-down list.

In thistutorial, check [Use 1/O Library] and click [Next >].

NOTE

If you want to use an existing main function, uncheck [Generate main() Function], add the file of
the function after generating the project. If the name of the function differs from main, change
the caller of the function in resetprg.c. For the contents of such sample files as a vector table
definition file or 1/0 register definition file that will be generated by the project generator, check
the description in the hardware manual for the target CPU.
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Figure2.4 Setting the Contents of Filesto be Generated (Step 3)



2.5 Setting the Standard Library

The screen shown in figure 2.5 is displayed when the [Next>] button is clicked in the Step-3
screen. This screen is used to set details of compilation by the C/C++ compiler. To change the

standard library configuration after a project has been created, select the CPU pagein [Options -
> SuperH RISC engine Standard Toolchain] of the HEW. In thistutorial, click the [Next>]

button without changing the settings.
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[WlFuntime : mntime routines
[w]rew . Performs memaony allocation and
[Jctupe.h : Handles and checks charac
[Imath.h : Perfarmz numerical calculatio
[ Imathf.h : Performs numerical calculati
[Jztdarg.h : Supports access to vanable
[w]ztdio b : Performs inputdoutput handliv
[w]=tdlib. b : Performz C program standard
[w]=ztring.h ; Perfarms string comparizon, ©
[Jio=[EC++] ; Performs input/output pro:
[ Jcomplexs[EC++] : Performs comples nu
[ I=tring(E C++] : Performs string manipuls

| [

Enable al | Disable &l |

< Back | Mext » I Firizh | Cancel |

Figure2.5 Settingthe Standard Library (Step 4)

13



26  Setting the Stack Area

The screen shown in figure 2.6 is displayed when the [Next>] button is clicked in the Step-4
screen.

This screen is used to specify the stack area.

Theinitial value of the stack area differs depending on [CPU Type:] selected in the Step-1 screen.
To change the stack size after a project has been created, select the [Project -> Edit Project
Configuration] menu item of the HEW window. In this tutorial, since SH7020 has been selected
for [CPU Type] in the Step-1 screen, [Stack Pointer Address] is set to H' 7FFFFFFO and [Stack
Size?] isset to H'100. In thistutorial, click the [Next>] button without changing the settings.

Mew Project-5/8-5etking the Stack Are: ed |

What are the stack settings?

Stack Pointer Address:
[power-on reset]

H7FFFFFFO

Stack Size:
|H'1 ]

< Back | Mext » I Finizh | Cancel

Figure2.6 Settingthe Stack Area (Step 5)

The stack areais defined in stacksct.h that is generated by the HEW. If stacksct.h has been edited
in an editor, its modification after you have selected the [Project -> Edit Project Configuration]
menu item of the HEW will not be available.
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2.7 Setting the Vector

Clicking the [Next>] button in the Step-5 screen displays the screen shown in figure 2.7.

In this screen, avector is specified.

If [Vector Table Definition Files] is checked, the HEW creates a vector table definition file.

The [Handler] column of [Vector Handlers:] displays the handler program name, and the
[Vector] column displays the vector description. To change the handler program, click the name
of the handler program to be changed, and enter a new name.

If the handler name in the [Vector Handlers] list is changed, the HEW does not create the reset
program (resetprg.c).

In thistutorial, click the [Next>] button without changing the settings.
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Figure2.7 Settingthe Vector (Step 6)
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2.8 Setting the Target System for Debugging

When the [Next>] button is clicked in the Step-6 screen, the screen shown in figure 2.8 is
displayed. This screen is used to specify the target system for debugging. Select (check) the
target for debugging from the list under [Targets:]. Selection of no target or of multiple targetsis
alowed.

In thistutorial, select [SH-1 Simulator] and then click the [Next>] button.

Mew Project-7 thing khe Targe m For Debugging ﬂﬂ

— Targets

al | B

Target type : I 5HA1 j

¢ Back | M ext > I Finizh | Cancel |

Figure2.8 Settingthe Target System for Debugging (Step 7)

If you change [Target type:], you can specify the other target system for debugging.
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29 Setting the Debugger Options

When the [Next>] button is clicked in the Step-7 screen, the screen shown in figure 2.9 is
displayed. This screen is used to specify the optional settings for the selected target for
debugging.

By default, the HEW creates two configurations, [Release] and [Debug]. When atarget for
debugging is selected, the HEW creates another configuration (The name of the target is
included). The name of the configuration can be modified in [ Configuration name:]. Optionsto
do with the target for debugging are displayed under [Detail options:]. To change the settings,
select [Item] and then click [Modify]. When items for which modification is not possible are
selected, [Modify] remains grayed even if [I1tem] is selected.

In thistutorial, click the [Next>] button without changing the settings.

Target name
|5H-1 Simulator

Configuration name :

|SimDebug_SH-1

— Detail options :
Item | Setting
Simulator 1/0 enable
Sirnulator 1/0 addr. Ox0
Bus mode 0

Fmdify |

< Back | Mext » I Firizh | Cancel |

Figure2.9 Setting the Debugger Options (Step 8)
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210 Changingthe File Namesto be Created

When the [Next>] button is clicked in the Step-8 screen, the screen shown in figure 2.10 is
displayed.

The screen displays alist of files created by HEW according to the previous settings. The [File
Name] column in the list shows a file name, [Extension] shows an extension, and [ Description]
shows the description of afile. The file name can be changed. To change afile name, select it by
clicking it and change it to a new file name.

In thistutorial, click the [Finish] button without changing the settings. When the button is
clicked, the [Summary] dialog box will be displayed.

hanging the File Mames ko be Created ed |

The following source files will be

geherated:
File Mame | Eut... | Drezcription
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Figure2.10 Changing the File Namesto be Created (Step 9)

NOTE
A filewith an extension “h” or “inc” (shown in the [Extension] column) is an includefile.
If you change the file name of an includefile, the file name at the include directive have
to be modified.
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211  Confirming Settings (Summary Dialog Box)

The project generator shows alist of generated files on the [Summary] dialog box (figure 2.11).
Confirm the contents of the dialog box and click [OK].

When [Generate Readme.txt as a summary file in the project directory] checkbox is checked, the
project information displayed on the [Summary] dialog box will be stored in the project directory
under the text file name "Readme.txt".

Surnmary: il ﬂ
Project Surmmary:
-------- FROJECT GEMERATOR ------ -
PROJECT HAME : tutonal
FROJECT DIRECTORY : C:AHew3stutonialhutornial
CPU SERIES : SH-1
CPLU TY'PE : SHY020
TOOLCHAIM MARE Hitachi Superd RISC enaine Star

TOOLCHAIM YERSIOM : 2.01.0
GEMERATION FILES :
C:hHew3stutanialutanialhdbect. o
Setting of B.R Section
C:SHew3stutarialutorialhlawll zre
Program of Low level
C:SHew3stutanalutonalhlowsre. o
Program of /0 Stream
C:h\Hew3stutanialstutanialysbrk. o
Program of zbrk.
C:4Hew3stutanialutorialhiodefine b

Crefinition of 140 Fegister -
4 | 3

Click DK to generate the project or Cancel to abort.

[+ Generate Beadme.tst a3 a summanye file in the project directany

Cancel |

Figure2.11 Summary Dialog Box

Then the HEW will open a project generated by the project generator.
By default, the HEW has:

The [Workspace] window (on the left hand side of the HEW), which shows the contents of the
project, the [Output] window (on the lower side of the HEW), which shows outputs from a build
or astring search, and the editor window (on the right hand side of the window), which is used to
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edit text files. Refer to the High-Performance Embedded Workshop 3 User’s Manual for how to
change the state of the HEW and how to use each window such as the editor window.

6 tutorial - High-Performance Embedded Workshop
File Ecit View Project Options Buid Took Window Help

Title bar
/ Dede sy =elomallore]sEsEn s = e =% & |
Menu bar Zmﬁ::’dﬁm@@ﬁébgmg || rmrr— e [ R[]

EBEEE DT e | [E e |

Tool bar

oomEm |
e
=]
Workspace
Window

[Projects] sheet — ]

Editor Window
aea " Pprojects [ B vorpos | vgmen |
Output Wi ndow\iI
[Build] sheet
Status bar

Addy [
Figure2.12 Sub-windows of the HEW

The project generated by the project generator includes minimum options for the C/C++
compiler, the assembler, the inter-modul e optimizer and the object converter. Thus you can build
the project (figure 2.13) by selecting [Build->Build]. Selecting the button (shown below) on the

toolbar works in the same way as selecting [Build->Build].

Those minimum options are set by default for each tool. When you add a new file to the project,
the minimum options will automatically be added to thefile. Y ou do not have to specify options

other than those that are specific to each such file.
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I e

C@e. BT g
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= [Defauitt desktop | = s om

Figure2.13 TheHEW after Building a Project
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Section 3 Modifying the Project

When you create a project using the project generator, basic program such as reset routine and
initialization of RAM areawill already be given in the project. This tutorial describes how to
modify afile and how to add afileto the project.

31

Editing and Creating a Source Program File

To open and edit afile in the project, double click thefile in the [Projects] sheet of the
[Workspace] window. In thistutorial, double click “tutorial.c”. (figure 3.1)

Ele Edt Wew Project Options Buld Memory Tools Window Help

]

==l
=l=lx|

Dedd &l:=etra||loroe|@ztoe ¢ ®=n|a  Flmgw T

o7

WS || e X (e

=] |[Defeuisession

Hizra|EE &= ¢aal=|=|memnas |

EEEETTT -

=

=3 Dependencies
lowsich
sbikh
«[E] stackseth
veeth

I e

C@e. BT g

o woale |

#ifdef _ cplusplus
/f#include <ios>

#enaif

#ifdef _cplusplus
extern "C" {
#enaif

void short {void):
#ifdef _ cplusplus
¥

#endif

void main(void)
€

B

void abort (woid)
{

B

K|

//int ios_base::Init:iinit_ont;

5y ot l’ﬁ 7 5
E-[F tutorial ’ ! g Y
-3 Assembly source /* FILE :tutorial.c 7
g [ /% DATE 1Tue, Mar 23, 2004 iy
B8 Emume file /% DESCRIPTION :Main Program Y
dbscto /% CPU TYPE :18H7020 w
inlprg.c ’* o
/* This file is generated by Renesas Project Generator (Wer.3.1). =
reselpig.c I "
v /

// Remove the comment when you use ios
// Remove the comment hen you use ios

Build Finished
0 Errors, 0 Warnings

Phase Optlinker starting
Fhase Optlinker finished

d(Phase SH Assembler starting

Phase SH Assembler finished

—|C:\Hew3% tutorialttutorialylowlvl. src
Version Cartral
[ [Defaultl desktop  [Read-write D 1 ws [ o

Ready

Figure3.1 Opening aProject File
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Then you can edit the file opened. If you edit the file, an asterisk (*) will be added to the file path
shown on thetitle bar of the HEW (figure 3.2). If you save the file, the asterisk will disappear.

=[x
Tk Ele Edt Wiew Project Ot Buld Memory Iools Window Help e
Dedd &l:=etra||loroe|@ztoe ¢ ®=n|a  Flmgw T He |
WS || e X (e =] [Detautzession Hizra|EE &= ¢aal=|=|memnas |
ERENERENRGRTAE R e
lx
B ttorial " i |
£ tutorial / ! ﬁ/
E1-E3 Assembly source /% FILE rtutorial.c p
T lowlvlsic /% DATE :Tue, Mar 23, 2004 wy
183 C source fie /* DESCRIFTION :Main Program "
dbscte /% CPU TYPE 15H7020 =y
intprg.c ’ o
lowste.c /* This file is generated by Renesas Project Generator (Wer.3.1). "
reselpig.c I "
sbik.c / 7
wedttbl.c
o D e
B-& Droendercis pirams _cpusplus
5] sbrkh //#include <ios> // Remove the comment when you use ios
~[5] stackseth //int ios base::Initi:init_cat; // Remove the comment when you use ios
weeth #endif
#ifdef _ cplusplus
extern "C" {
#endif
void ebort {void):
#ifdef _cplusplus
+
#endif
void main(woid)
{
I
+
void abort {void)
{
+
I | LT >
“@e. [ET (9 |
=l[Fhoce 5 Aaseabler sterting H

C:\Hew3\tutoriall tutorialylowlvl. src
Phase SH Assembler finished

Phase Optlinker starting
Fhase Optlinker finished

Build Finished
0 Errors, 0 Varnings

Varsion Cortral

Ready [ [Defaultl desktop  [Read-write [esps4 4 ws [ o

Figure3.2 EditingaProject File

If you want to open an existing text file with the editor of the HEW, select [File->Open]. If you
want to edit a new text file with the editor, select [File->New]. In thistutorial, select [File-
>New], input the three lines shown below, select [File->Save As...] and save thefile as
“newprog.c”.

void NewProgram(void)
{
}
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3.2 Adding/Removing a File To/From a Project

This section describes how to add afile to a project and how to delete afile from aproject. In

thistutorial, add thefile, “newprog.c” created in the previous section to the project as follows.

Select [Project->Add Files...], then the [Add File(s)] dialog box (figure 3.3) will be launched.
Select afile, “newprog.c” in this example, to be added and click the [Add] button. Thus
“newprog.c” will be added to the project.

Add File(s) ZIx]|
Lookin: | ‘4 tutorial =] I |=j€| I
|1 Debug =#] ol 2rc =] shrk_h
|_1Release E| lovzre. o @ stackzct.h
I:I SimDebug SH-1 @ lowesrc. b @ tutorial.c
=] dbact.c a HEWENog. '?ﬂ wvecth
:@ intpro.c Fﬂ resetpro.c @ vectthl.c
i@ iodefine. h @ shrk.c
File narne: Inewprn:ng.n: Add
Filez of ype: lF'r-:uiect Files j Cancel |
[ Relative Path

Figure3.3 AddingaFile ToaProject
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The added file will be displayed on the [Projects] sheet of the [Workspace] window as shown in
figure 3.4.

(& - High-pe
File Edit Wiew Project
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#ifdef _ cplusplu
J//#include <iosy

wvoid NewProgram(void) -
8 ¢

)

stackscth //int ios_base::l
veeth #endif
#ifdef _ cplusplu
extern "C" {
#endiz
void abort (void)
#ifdef _ cplusplu
)
#endif
woid mainivoid)
i — ]
B Fe_ [ET (2 £ ttoridle” < newprog.c
[Phase SH Aosembler starting =
~|C:\Hem3% tutorialttutorialylowlvl. src
Phase SH Assembler finished
Phase Optlinker starting
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Build Finished
0 Errors, 0 Warnings
Find in Fls_J, Version Cantral
Ready [ [Defaultl desktop  [Read-write [era 2 ws [ o
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Next, how to delete afile from a project will be shown. Select [Project->Remove File...], then
the [Remove Project Files] dialog box (figure 3.5) will be displayed. Select one or more project
files on this dialog box and click the [Remove] button. Then the selected file(s) will disappear
from the list of the dialog box. Clicking [OK] actually removes the file(s) from the project.
Clicking [Cancel] instead will nullify the removal.

Y ou have another way to delete afile from a project. Select the file in the [Projects] sheet of the
[Workspace] window and pressthe [Delete] key. Then the file will be deleted from the project.

If you want to exclude afile from a build temporarily instead of removing the file from the
project, refer to section 4.4, “Excluding a Project File from Build”.

Remove Project Files

Froject files: Ok
dbzct.c [C:\Hew3htutonalstutorial]
intpro.c [C:\HewIhtutarialstutarial] Cancel
Il zrc [C:\Hew 3 tutarialstutarial]
lowesre.c [C:\Hew 2\ tutonialyhutorial

Bemove

Rl

S NEOInn C 4 Hew 34 tutonaltutoriall
resetprg.c [C:\Hew I tutorialstutorial]
shrk.c [C:\HewaIstutarialstutarial] Remove Al
tutarial. [C:%HewIhtutarialstutarial]
vectthlc [C:\Hew3htutonalstutorial]

1| I i

Figure3.5 Remove Project Files Dialog Box
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3.3 File Groups Used in a Project

In this section, afile group to which afile added to a project belongsis described. For example,
the project generator adds a file described in C language or assembly language to the project. A
filewith afile extension “.c” belongs to the [C source file] group, and afile with afile extension
“.src” belongs to the [Assembly source file] group.

The HEW identifies a group to which a file belongs by checking the file extension. Select
[Project->File Extensions...], then the [File Extensions] dialog box (figure 3.6) will be displayed.
File extensions used in the project are shown on this dialog box. Every file extension belongs to
afile group. A file group can be associated to atool in abuild process.

If you want to use your own file extension in the project, define a new file extension by clicking
the [Add...] button.

Theicon displayed in the [Extension] column of the [File Extensions] dialog box can show atool
which opensthefile. If theicon of afile extension is the same as the icon shown below, afile
with that file extension can be opened by the editor of the HEW.

File Extenzions [ 2] |

Estenzion | [Eroup - I

Jrahs  Absolute file

=] *inc Azzembly include file Carcel |

[E]=is Azzembly list file

k.
[E] = src Szzembly zource file Add. . |

_1%bin Binary file
C header file S

. C list file E—
C C zource file Uperr i |

C++ header file

Eermie

im —
| [ ] fuo] i
® ® o
FZ -

!
L
o
o
=)

*lpp C++ ligt file

[ [

.Cpp C++ zource file
.CpuU CPU information file

Fuwrnandead Aazeemhblin 2o |r|'~|=-!|:i||=-_|;|
8

Figure3.6 File ExtensionsDialog Box (Initial Screen)
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Click the[Add...] button on the [File Extensions] dialog box, then the [Add File Extension]
dialog box (figure 3.7) will be launched. Enter anew file extension in the [File extension] field
and specify the [File group] group box. If you want to add an extension to an existing file group,
select the [Extension belongs to an existing group] radio button and select a file group from the
drop-down list. If you want to create a new file group, select the [Extension belongs to a new
group] radio button and enter the name of the file group in the edit field.

In thistutorial, enter “asm” in the [File extension] field, select “ Assembly source file’ from the
drop-down list and click [OK]. Then afile with the extension, “*.asm”, will be treated as afilein
the [Assembly source file] group (figure 3.8).

&dd File Extensian ilil

— Eile extenzion: I
File extenzion or
) Iasrd vI

— File group:

Cancel |

{* Extension belongs to an existing group:
| &bsalute file =]

" Extension belongs to a new group:

— Azzaciated applicatian:

[Hpen graup with;

Editor =]

Auddl
t it |

Eemowve

Figure3.7 Add File Extension Dialog Box
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Figure3.8 File Extension Dialog Box (After Adding an File Extension)
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34 Customizing the Wor kspace Window

Click the right mouse button on the [ Projects] sheet of the [Workspace] window, then a pop-up
menu will be displayed. Select [Configure View...] on this menu, then [Configure View] dialog
box (figure 3.9) will be launched. On this dialog box, you can specify whether the file
dependencies are shown for each file or not, whether afileis shown in afile group folder (figure
3.10) or not, and so on.

Configure Yiew ﬂﬁl

[ Show dependencies under each file

di

[ Show standard libramy includes Cancel

[T Sot files in time order

Figure3.9 Configure View Dialog Box
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Section 4 Building a Project

4.1 Build Overview
The HEW provides two ways of building a project.
1. “Build All” ([Build->Build All])

The series of toolsincluding the compiler, assembler, and linkage editor are applied to all of the
source program files.

2. “Build” [Build->Build]

The series of tools are applied to a source program file updated after the last build. (The update
means not only the update of a source program file, but also an update of afileincluded by the
source program file and an update of an option applied to the source program file.)

If you want to compile or assemble a single source program file, select the file on the [Projects]
sheet of the [Workspace] window and select [Build->Build Filg].

If you want to execute “Build” or “Build All” for multiple programs or configurations, specify
the target by selecting the [Build -> Build Multiple] menu item.

CAUTION ON BUILD

1. Depending of the setting of the editor window, a file being edited might be saved
on executing a build. So close a file which you do NOT want to be saved
beforehand. For details of customizing the editor, refer to the High-Performance
Embedded Workshop 3 User’s Manual.

2. Do not save afile used in a project during the build because doing so might disturb
the build process.

4.2 Setting Options
In this section, overview of the option setting is described.

When the project generator generates a project, the minimum options required for a build are
already specified. If you want to modify the options, however, select [Options-> SuperH RISC
engine Standard Toolchain] and set options on the option dialog box.
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Figure 4.1 shows the option dialog box of a C/C++ compiler. On the |eft hand side of the dialog
box isafilelist, and on the right hand side are optional setting controls for each tool divided into
some pages. If you select afilein thefilelist, you can specify options only to the selected file. If
you select afile group folder in the file list, you can specify the same option to all the filesin the
file group. To specify the same options to specific files, select the files while pressing the [Ctrl]
key or the [Shift] key.

If you select [Default Options] in afile group folder, you can specify initial options for thefile
group. The HEW automatically adds the options specified to the [Default Options] to afile of the
corresponding file group of the corresponding file extension of the file. For example, if you add
afilewith an extension “C” (“*.C") to the project, the settings of the [Default Options] of the[C
source file] group will be added to the file automatically.

For the details of the optionsrefer to the SuperH RISC engine C/C++ Compiler, Cross
Assembler, or Optimizing Linkage Editor User’s Manual.

SuperH RISC engine S5tandard Toolchain HE
Configuratian ; CAC++ |.-'1'-.$seml:|l_l,ll Link.-"LiI:urar_l,lI Standard LiI:urar_l,lI CPU A I *I
IDEl:'uEI j Categorny : ISDU[CE j
E? I%Lnaded Praojects e eiee

MD C source file IInu:qu:Ie file directaries j

I:l C++ zource file
-2 Assembly source file

I:I Linkage symbal file
|mgerts.

Hemmve

i e

1L

il e d o

Optionz CAC++

-object="$[COMFIGDIR$FILELEAF). obi" -debug =

-tiinling -gbr=auto -chaincpath -errorpath r

P | |_,| -global_volatile=0 -opt_range=all -infinite_loop=0 ;I
Cancel

Figure4.1 Option Dialog Box of C/C++ Compiler
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4.3 Customizing the Configuration

In the previous section, how to set options to a project file is described. In this section, how to
create more than one suite of option settings for a build will be described. A suite of option
settings for abuild is called a configuration.

The project generator creates two configurations, [Debug] and [Release]. Difference between
them is only the setting of the debugging option. When atarget for debugging is selected, the
configuration for the target is also created. To switch the current configuration to another, launch
the [Build Configurations] dialog box (figure 4.2) by selecting [Options->Build
Configurations...], select a configuration from the [Current configuration] drop-down list, and
click [OK]. You can aso change the current configuration by selecting one from the drop-down
list on the toolbar.

On the [Build Configurations] dialog box, you can create a new configuration or delete a
configuration. For details, refer to chapter 2, “Build Basics’, of the High-Performance Embedded
Workshop 3 User’s Manual.

Build Configurations

Build configurations: 0K

Debug :
Relzaze Cancel
SimDebug_S5H-1

i,

an

ENVE

LCurrent configuration:

Debug __*_l

Figure4.2 Build Configurations Dialog Box
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4.4 Excluding a Project File from Build

In this section, how to exclude a project file from build will be described. Excluding a project
file from build does not delete the file from a project, but exclude a project file from build in
configuration by configuration basis.

Select afile on the [Projects] sheet of the [Workspace] window, click the right mouse button, and
select [Exclude Build <file>] on the pop-up menu. Then ared cross will be added to the icon of
thisfile as shown in figure 4.3. Thisfile will be excluded from a build.

To include an excluded file into build, select the file on the [Projects] sheet of the [Workspace]
window, click the right mouse button, and select [Include Build <file>] on the pop-up menu.
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4.5 Correcting Errorsin aBuild

In this section, how to jump to aline of afile which caused an error in compiling or assembling
will be described.

Figure 4.4 shows an example in which acompiler detected a syntax error in a source program
file. When you build a project, messages, including error messages, from atool in abuild will be
displayed on the [Output] window. If you double click the line of the error message on the
[Build] sheet of the [Output] window, the file which caused the error will be opened and the
cursor will be placed on the line which caused the error. (The cursor might not be placed on the
line which caused the error if you have already edited the file.) Placing the cursor on the error
line of the output window and pressing the [F1] key displays help of that error.
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Figure4.4 Correcting the Linewhich Caused an Error
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4.6 Customizing the Session
Y ou can save the options for debugger to the session file.

The project generator creates the session, [Default Session]. When atarget for debugging is
selected, the session for the target is also created. To use the atarget, launch the [Debug
Sessions] dialog box (figure 4.5) by selecting [Options->Debug Settings...], select a session
[SimSessionSH-1] from the [Current session] drop-down list, and click [OK]. You can also
change the current session by selecting one from the drop-down list on the toolbar.

On the [Debug Sessions] dialog box, you can create a new session or delete a session. For details,
refer to chapter 1.9, “Debugger Sessions’, of the High-Performance Embedded Workshop 3
User's Manual Simulator/Debugger Part.

Debug Sessions |
Sessions | Synchronized Del:uugl

Debug zessions:

DefaultSezsion dd
SimSesszionsH-1
Hemave

Have a8,

Eraperties

Bl

LCurrent zezzion:

| k. I Cancel

Figure 4.5 Debug Sessions Dialog Box
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Section 5 Debugging

51 Preparation

The basic functions of the simulator/debugger will be described in this section using a sample
program.

NOTE
Note that the contents of usage examples (figures) in this section will differ depending on the
compiler version.

511 Sample Program

The HEW demonstration program is used for the sample program and is written in C language It
first sorts ten random data in the ascending order, and then in the descending order. The sample
program:

(1) Generates random data for sorting using the main function.

(2) Inputs the array which stores the random data that is generated by the main function, then
sorts the data in the ascending order using the sort function.

(3) Inputs the array generated by the sort function, and sorts the data in the descending order
using the change function.

(4) Displays the random data and the sorted data using the printf function.

51.2 Creating the Sample Program
Create the HEW demonstration program by referring to sections 1 to 4, and note the following.

» Specify [Demonstration] for the [Project Type] in section 2.1, Creating a New Workspace.
e Specify [SH-1] for the [CPU Series].
»  Specify [SH-1 Simulator] for the [Target:].

+  Specify [SimDebug_SH-1] for the configuration | |5imD ebug_5H-1 =l | on the
toolbar before building the project.

» Specify [SimSession_SH-1] for the session ISimS eezionSH-1 j on the
toolbar.

Since section 5 explains the debugging function, [Demonstration] has not been optimized. Do
not change this setting.
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52 Settings for Debugging

521 Allocating the Memory Resource

The allocation of the memory resource is necessary to run the application being devel oped.
When using the demonstration project, the memory resourceis allocated automatically, so check
the setting.

e Select [Simulator->Memory Resource...] from the [Option] menu, and display the allocation
of the current memory resource.

Simulator Swstem ilil

Spstern  Memary |

temary E‘} e‘il g Iﬁﬂl temaony Besource: L“}’|I:15i Kil

Begin | End | Type | Size | Read | Bean | End | Attribute

Q000000 O5FFFEFF | EXT 16 1 aonoooao Q0007FFF Read '
O5FFFFOO O5FFFFFF 170 16 OSFFFFOO O5FFFFFF Read T
QE000000 OFFFDFFF | EXT 16 OFFFECQOO OFFFFFFF Read
OFFFEOOQD  OFFFFFFF  Rak 32
10000000 FFFFFFFF | EXT 16

—_ —t

a| | MHix | ©

0k I Cancel | Apply |

Figure5.1 Simulator System Dialog Box (M emory page)

The program areais allocated to the addresses H'00000000 to H'00007FFF. The stack areais
allocated to the addresses H'OFFFEOQO to H'OFFFFFFF, which can be read from or written to.

e Closethe dialog box by clicking [OK].

The memory resource can also be referred to or modified by using the [Simulator] page on the
[SuperH RISC engine Standard Toolchain] dialog box. Changes made in either of the dialog
boxes are reflected.
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522

Downloading the Sample Program

When using the demonstration project, the sample program to be downloaded is automatically
set, so check the settings.

» Open the [Debug Setting] dialog box by selecting [Debug Settings...] on the [Option] menu.

Debug Settings I

| SimS essionSH-1

hﬂ tukarial

_:’ Target | Dptiunsi

Drefault Debug Earmat:

|EI/Dwarf2

Diownload kodules:

File Marne

| Offzet Addiess

$COMFIGDIRINEL.. H'00000000

Add...

Hermaye

o |

Cancel

* Filesto be downloaded i

Figure5.2 Debug Settings Dialog Box

ssetin [Download Modules].

» Closethe [Debug Settings] dialog box by clicking the [OK] button.

» Download the sample program by selecting [Download Modules->All Download Modules)]

from the [ Debug] menu.
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523 Displaying the Sour ce Program

The source-level debugging is supported by the HEW. Refer to section 3.1, Editing and Creating
a Source Program File, and display the source file ("tutorial.c") in the [Source] window.

*  Open the [Source] window by double-clicking tutorial.c on the [Workspace] window.

=10l x|
'fﬁ‘ﬁ‘ﬁ‘TTﬁﬁ*t*******ﬁ‘ﬁ‘%‘%‘ﬁ‘ﬁ‘ﬁ‘TTﬁﬁﬁ********ﬁ‘ﬁ‘%‘%‘ﬁ‘ﬁ‘ﬁ‘TTﬁ1“ﬁ********ﬁﬁﬁﬁﬁttf?ﬁﬁﬁﬁﬁﬁf T
/* i —
/% FILE itutorial.c i
/% DATE :Tue, Mar 23, 2004 &y
/* DEICRIPTICON :Main Program @y
/* CPU TYPE B =/
i * *
/% This file i= generated by Benesas Project Generator (Ver.3.1). L
/* &
lfﬁ‘ﬁ‘ﬁ‘TTﬁﬁ*t*******ﬁ‘ﬁ‘%‘%‘ﬁ‘ﬁ‘ﬁ‘TTﬁﬁﬁ********ﬁ‘ﬁ‘%‘%‘ﬁ‘ﬁ‘ﬁ‘TTﬁ1“ﬁ********ﬁﬁﬁﬁﬁttf?ﬁﬁﬁﬁﬁﬁf
#include <stdio.h>
#include <math.h>
#include <stdlib.h>
void mwain(wvoid);
woid sort|long *a); -
woid change (long *a):
Ox0000138c vold main(void)
{
long a[10], min, max;
long 3j:
int i;
0x00001392 printf ("### Data Input ###in"):
O0x0000139e for{ i=0:; i<10; i++ )4
0x000013a6 J = randl():
O0x000013ae iftiy « o) ¢
0x000013k2 3= -3;
i
0x000013k4 alil = 3:
0x000013c2 printf ("a[sd]=%ld\n",i,a[i]);
i
O0x000013e8 sortia):
Ox000013ee printf ("***% Sorting results FFF\n")
O0x000013fa for{ i=0:; i<10; i++ )4
nnnni4nz nrintfiralsdl =z idin" . i.aM9i11 X
i S

Figure5.3 Source Window (Displaying the Sour ce Program)
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524 Setting a PC Breakpoint

Breakpoints can be set easily by the [Source] window. To set a breakpoint on aline that includes
the sort function call:

» Placethe cursor in the line that includes the sort function call and click the right mouse
button to launch the pop-up menu, and select [ Toggle Breakpoint] from the pop-up menu.

- tukorial.

Ox0000158e:

Ox00001382

0x0000135e
0x000013a6
Ox000013ae
Ox000013k2

Ox000013b4
Ox000013c2

0x000013ed
Ox000013ee
Ox000013f=
Ox00001402

Ox00001426
Ox00001428
Ox0000142a
Ox0000142c
Ox000014Z2e
Ox00001434
Ox00001436

Ox00001442

kIl

=10l x|
#include <stdio.h> j
#include <math.h>

#include <stdlib.h>

void main(void);
void sort (long *a);
void change (long *a);

wvoid main(void)

{
long a[10], min, max:
long j;
int i;

printf ("### Data Input #H#\n"):

for({ i=0; i<10; i++ 14
j = randf():
if{3 < 0){
J= -3
}
afi] = 3:
printfiTalzd]=sld\n",. i, a[1i]):
+
sort(a);
printf ("*** Sorting results *rEint);
for( i=0; i<10; i++ )J{ —
printf(®alsd]=3%1din",i,a[i]):

a[o];
a[9];
o;

max a;

change (a) ;
min al[9]:
MEX al0] ;

=

P

=
wononon

i

woid sort(long *a
{
long t:
int i, 3, k, gap: -

Figure5.4 Source Window (Setting the Breakpoint)

A [« ]isdisplayed at the line that includes the sort function call, indicating that the PC
breakpoint is set at the address.
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525 Setting the Profiler

Open the [Profile] window by selecting [Profile] from the [View->Performance] menu.

Prafile
Function/WVariable Fy/ | Address

Size Times Cycle ExXt mem I/0 area | Int men

4I:I\ListﬁTree}

Figure5.5 Profile Window

Open the pop-up menu by right clicking the mouse on the [Profile] window, and select
[Enable Profiler] to enable acquisition of the profile information.

46



5.2.6

Setting the Simulated 1/0

When the demonstration project is used, the simulated /O is automatically set, so check the
setting.

Open the [Simulator System] dialog box by selecting [ Simulator->System] from the [Option]

menu.

Sirulakar 2l
System | Memary |
LCPU:
:
Bit size: Simulated 140 Address: ¥ Enable
fpraz {Ha0000000 |
Endian Ezecution Madz
IBig Endian [stop | Detail.. |
Response: Found Maode
[040000 [Round To Nearest =l
Clock Fate
Peripheral Clock Rate: [ Enable Timer
1 =
akK I Cancel | Aippliy |

Figure5.6 Simulator System Dialog Box (System page)

Confirm that [Enable] in [System Call Address] is checked.
Click the [OK] button to enable the Simulated I/O

Select [Simulated 1/0O] from the [View->CPU] menu and open the [Simulated /O] window.

The Simulated I/0 will not be enabled if the [Simulated I/O] window is not open.

Simulated /0

Figure5.7 Simulated I/O Window
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5.2.7 Setting the Trace Information Acquisition Conditions
o Select [Trace] from the [View->Code] menu and open the [Trace] window. Open the pop-up

menu by right clicking the mouse on the [Trace] window, and select [Acquisition...] from the
pop-up menu.

The [Trace Acquisition] dialog box below will be displayed.

Trace Acquisition EHE
 Trace Stat/Stop—————————————
= i]8
" Dizable -

Cancel |

— |Instruction Type
& Instuction
" Subroutine

= Trace Buffer Full Handling
. Continue
" Break

—Trace Capacity——————————————
& 1024 recards
4096 recards
16384 records
¢ 32768 records

Figure5.8 Trace Acquisition Dialog Box

» Set [Trace start/Stop] to [Enable] in the [Trace Acquisition] dialog box, and click the [OK]
button to enable the acquisition of the trace information.

528 Setting the Stack Pointer and Program Counter

To execute the program, the program counter must be set from the location of the reset vector.

In the reset vector of the sample program, the PC value H'800 is written, and the SP value

H'OFFFFFFO is written.

e Select [Reset CPU] from the [Debug] menu, or click the [Reset CPU] button on the toolbar.

Set the program counter to H'800, and the stack pointer to H'OFFFFFFO from the reset vector.

Eij
Figure5.9 Reset CPU Button
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53 Start Debugging

531 Executing a Program

e Select [Go] from the [Debug] menu, or click the [Go] button on the toolbar.

El!
Figure5.10 Go Button

The program halts where a breakpoint is set. An arrow is displayed in the [Source] window,
indicating the location the execution has stopped. Asthe termination cause, [PC Breakpoint] is

displayed in the [Output] window.

< buborial.c
0x0000135e for{ i=0; i<10; i++ )1{
0x000013a6 3 = rand():
0x000013as if{3 « 0){
0x000013k2 3= -3
¥

0x000013b4 ali] = 3:
0x000013z2 printf ("al3dl=%1ld\vn",i,a[i]):

i
0x000013ed < sortial:
0x000013ee printf{"*** Sorting results ***4yn");
0x000013fa for{ i=0; i<10; i++ )1{
0x00001402 printf ("a[5d]=%ldyn",i,a[i]);

i
0x00001426 min = a[0]:
0x00001428 max = a[3]:
0x00001425 min = 0O
Ox0000142c max = 0:
Ox0000142e change (a) ;
0x00001434 min = a[3]:
0x00001436 max = a[0]:

i
Ox00001442 woid sort(long *a)
{
long t;

int i, 3, k, gap:

0x0000144a gap = 3}
0x0000144e while{ gap > 0 1{
0x00001450 for| k=0; k<gap; k++){
0x00001456 for | i=k+gap; i<10; i=i+gap ){
O0x00001462 for (j=i-gap; Jjr=k; j=i-gap)i
0x0000146= if(a[il>alj+gapl){
0x00001454 t = afil:
0x0000145e alil = a[j+gap]:
0x000014a6 ali+gap] = £
H
else
break;
H
H
}
<[]

Figure5.11 Source Window (Break Status)
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The termination cause can be displayed in the [ Status] window.

e Select [Status] from the [View->CPU] menu to open the [Status] window, and select the
[Patform] sheet in the [Status] window.

status x
Ttem I Status I
Conniected To 5H-1 Simulator

C P EH-1

Exec Mode Stop

Pun Status Ready

Erealk Cause PC Breakpoint
Execute From Pipeline Reset
Exec Instructions EE0E3

Cycles 114612

4 I :I;. Mernory }-.Platfnrm .f{. Ewents f‘

Figure5.12 Status Window
The above status window indicates that:

(1) The cause of break is a PC breakpoint

(2) Execution is performed from the pipeline reset

(3) The number of executed instructions by the GO command is 56,069
(4) The executed number of cycles from the pipeline reset is 114,612
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Register values can be checked in the [Register] window.

Register values when the program is terminated can be checked.

Select [Registers] from the [View->CPU] menu.

5.3.2

RPegister MName I Pegister Value -
RO H'oooooooh
Bl H'oooooooh
RE H'oooooooo
12k H'Oooooolz4
P4 H'OFFFFEG4
BEL H'0O0OO&1=2E
R H'OFFFE13%
B7 H'0oooooooo
B2 H'oooooooo
B3 H'oooooooo
R10 H'oooooooo hd
ol I AW

Figure5.13 Register Window

Using the Trace Buffer

The trace buffer can be used to clarify the history of instruction execution.

Select [Trace] from the [View->Code] menu and open the [Trace] window. Scroll up to the
very top of the window.

Trace

PTR | Cycle | Address | Pipeline | Instruction | Access Data | Source | Label
—0l0Ez ooo0llzess OD003EBZE £

-Qlozz Qoo0llze20 00003E44 FFDE-MW MOV.L @{0... RE<-OFFFEL33
-010z21 O00011ZE9E 0000ZE46E £D=EMW MOV.L @RL... DRE<-000000322
—-0l0z0 0o00l1lze94 00003EB42 FFD<E=M MOV.L ©R&,... OFFFEQ1C<-. ..
-01013 0000112696 00003EB4A4  £<D=EMW MOV.L @i0... RE<-0000000L1
-0lols 000011Z6598 00003E4C FFD<E= ADD #FF... Re<-00000000
—-0l017 aoooliz7oo0 OD003EB4E £<D=EM=>= MOV.L ©R&,... OFFFEQzZO=-...
-0101é 000011Z70E 000O03EE0  FFD<E=MWT MOV.L @Rl... DRE<-OFFFELS33
—-0l0lE oooolliz70ks OD003BEE £<D=<E Mow BE,... RE<-OFFFE133
-01014 Qooollz70e 00Q03ES4 FF=DE= ADD #0L... BRe<-0OFFFE124
-01013 oooollz708 O0002EEE f0=EM=> MOV.L PR&,... OFFFEQ1C<-._.
—-ololz oo0o0l1z710 O0003BEE FFD<E=M MOV.E RE,... OFFFEl55+-38

Ll b

Figure5.14 Trace Window (Trace I nformation Display)
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53.3

Click the right mouse button on the [Trace] window to launch the pop-up menu, and select

Performing Trace Search

[Find...] to open the [Trace Search] dialog box.

-~
i Address

% Instiuction

Cycle

Walle:

Ihrd

Cancel

Ix

Figure5.15 Trace Search Dialog Box

Setting the item to be searched to [Item] and the contents to be searched to [Value] and clicking

the [OK] button begins the trace search. When the searched item isfound, thefirst lineis
highlighted. To continue searching the same contents [Valug], click the right mouse button in
the [Trace] window to display the pop-up menu, and select [Find Next] from the pop-up menu.
The next searched lineis highlighted.

Trace

PTR | Cycle | Address | Pipeline | Instruction | Access Data | Source | Label
—-00974 0O00L1Z725 aoooloos FFhO-=<_ . MOV.W @i0... RE=<-0000

-00973 Qooo0l1z7a8s 00001004  f==<D=<E STSTEM CALL coo
—-0037z 0000112730 Q000100c  FF=-DE= NOP HOP
-00971 NO00L1E73Z Q000100E fD=E RTE PC<-0000118C LTS
-0os70 0000L1Z79E5 oooololo FF-D:E NOp HOP
—-009&e9 NO00L1E736 aooolisc FFDEx ADD #FF. .. PRlz<-00000_ _.

—-009&g 000011z7338 Q000118E fD+E How #00... RE<-00000000

—003&7 0000112733 00001130 FFDE= CMPAHI RE,... T=-(0)

—Qo2ge Qooollzs0l Qooollzz il+E ET goo... T}

—009&5 0000112802 Q0001194  FFDE=MIT MOW.L @i0... Re=<-00000001

i-00964 NO00L1Z204 aoo0ll9:s fL=E ERL aoo. .. PC=-0000115C

-0039&3 Qooo0l1ze07 Q00001138 FF-D=E Nop

L |» =
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Figure5.16 Trace Window (Sear ched Result)




534 Checking Simulated 1/0

Random data that is displayed by the printf function can be checked in the [Simulated 1/0]
window.

Simulated /0

### Data Input ###
a[0]=0
a[l]=21465
a[2]=99a8
a[3]=22117
a[4]=3495
a[5]=1639z27
a[B]=1l6045
a[7]=19741
a[d]=121z2z2
a[9]=5410

Figure5.17 Simulated 1/0 Window

» Do not close the [Simulated 1/O] window.

535 Checking the Breakpoints
A list of all the breakpointsthat are set in the program can be checked in the [ Event] window.

» Select [Eventpoints] from the [View -> Code] menu.

CE———— |
Type | Btate | Condition Action
EP Enahle PC=H'OO0OO01l3ES (tutorial. c/38) Stap

| i
4 }hSnﬂware Break A Software Event {‘

Figure5.18 Event Window

A breakpoint can be set, a new breakpoint can be defined, and a breakpoint can be deleted using
the [Event] window.

» Close the [Event] window.
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5.3.6 Watching Variables

It is possible to watch the values of variables used in your program and to verify that they change
in the way that you expected. For example, set awatch on the long-type array “a” declared at the
beginning of the program, by using the following procedure:

e Select [Watch] from the [View -> Symbol] menu and open the [Watch] window. And click
the right mouse button on the [Watch] window and choose [Add Watch...] from the pop-up
menu.

The following dialog box will be displayed.

Add Watch EH
Mariable or expression;
Ia LCancel |

Figure5.19 Add Watch Dialog Box
* Typearray a and click the [OK] button.

The [Watch] window will show the long-type array a.

Y ou can double-click the + symbol to the left of array “a” in the [Watch] window to expand the
variable and show the individual elementsin the array.

‘watgh A

M are Type
=N _ ) (longl1 0]]

LE [0] H'00000000 § D=0ffre0 (long]
.- 1] H'000053de: { 0=0ffbd } [long]
B [2] H'00002704 { Ox0FfELE } [lang)
LB H'00005EES § OxOfffbc } [lang]
- [4] H'00000daa § Ox0Ffffr=0 } [larg)
B [5] H'0000421¢ { OxQrtffEcd } [[Lgla]]
B [ H'00003ead { DxfffifcE } flong)
B [7] H'00004d1d { 0xOfffffcc } flong]
B [8] H'00002(5a { OxQrffEd0 } [long]
..... B[4 H'000020da { 0x0fffffda } (long]

4| | 2

Figure5.20 Watch Window

* Closethe [Watch] window.
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537

Executing the Program in Single Steps

The simulator/debugger has various stepping menus that are useful in debugging the program.

Menu Description

Step In Executes each statement (includes statements within the function)

Step Over | Executes a function call in a single step

Step Out Steps out of a function, and stops at the next statement of the program that called
the function

Step... Executes the specified number of steps at the specified speed
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[Step In]: Entersthe called function and stops at the statement at the start of the called function.

» To step in the sort function, select [Step In] from the [Debug] menu, or click the [Step In]
button on the toolbar.

Ox000013%e
Ox000013 a6
Ox000013ae
Ox000013k2

Ox000013kh4
Ox000013c2

Ox000013e8
Ox000013ee
Ox000013fa
Ox00001402

Ox00001426
Ox00001428
Ox000014z2a
Ox0000142¢c
Ox0000142e
Ox000014354
Ox0000143 6

Ox00001442

Ox0000144a
Ox0000144c
Ox00001450
Ox00001456
Ox00001462
Ox0000146a
Ox00001484
Ox0000148e
Ox000014a6

Ox000014c8

K1

¥

orvoid sort(long *a)

{

)

Figure5.21 Step In Button

=

for| i=0; i<10; i++ )4 ZI

i

j = randi):
if{y <« 04
J o= -3:
¥
afi] = 3¢
printf("alzd]l=%1dvn",i,a[i]):

sorti(a);
printf ("*F*% Sorting results FEF\RT)
fori i=0; i<10; i++ )4

printf("alsd]=51d\n",i,a[i]}:

min = a[0]:
max = a[9];
win = 0;
max = 0;
change (&)
min = a[9]:
max = al[0];

long t;

int

gap

while{ gap > 0 }4{

i, 3, k, gap:
= 5;

for| k=0: k<gap: k++){
fori isk+gap; 1<10; i=i+gap }{
for(j=i-gap; Ix=k; i=i-gap){

if(alilralj+gap]l ]
t = alil:
ali] = alj+gap]:
alj+gap] = t;

i

else
hreak:

i
}
gap = gap/2:

X4

Figure5.22 Source Window (Step In)

* ThePC location display (=>) in the [Source] window movesto the statement at the start of
the sort function.
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[Step Out]: Steps out of the called function and stops at the next statement in the called

program.

» Select [Step Out] from the [Debug] menu to exit the sort function, or click the [Step Out]
button on the toolbar.

{¥

Figure5.23 Step Out Button

Ox000013a6
0x000013&ae
0x000013kb2

Ox000013k4
Ox000013e2

0x000013ed
Ox000013ee
O0x000013fa
O0x00001402

Ox0000142 6
Ox00001428
Ox0000142 &
Ox0000142 ¢
Ox0000142 e
O0x0000143 4
O0x0000143 6

Ox00001442

Ox0000144a
Ox0000144c
Ox00001450
Ox00001456
0x00001462
Ox00001d6a
Ox00001454
Ox0000148e
0x000014a6

Ox000014e3

kil

o

i

® tutorial.c

j = randi():
if{j < 0)¢{
s

i

afi] = 3:

printf ("a[sd]=31ld\n",i,a[i]]:
i
Sortia)
printf("*** Sorting results ***yn");
for( i=0; i<10; i4+ )

printt ("a[sd]=31ld\n",i,a[i]l):

win = a[0]:
wax = a[3]:
wmin = 0O
max = 0;

change (a) 2
win = a[9]:
max af[0] :

woid sort(long %a)

{

long t;
int i, i, k. gap:

gap = 5:
while{ gap » 0 }{
for| k=0; k<gap: k++){
for | i=k+gap: i<10; i=i+gap ){
for(j=i-gap; J>=k: j=j-gap)i
if(alil=ali+gap]l ) {
t = alil;
ali]l = ali+gapl:
alj+gap] = t:
i
else
brealk;

}
i
gap = gap/2:

Figure5.24 Source Window (Step Out)
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[Step Over]: Executesafunction call in asingle step, and stops at the next statement in the

main program.

Select [Step Over] from the [Debug] menu or click the [Step Over] button on the toolbar to step

over the statements in the printf function.

o

Figure5.25 Step Over Button

=10l x|

wold main(void) :
woid sortilong *a);
void change (long *a) 2
Ox000013 8 wold main(void)
{
long a[10], min, max:
long 3
int i:
Ox00001392 printf ("H##H# Data Input #FE#\n");
0x0000159e fori i=0; i<10; i++ }{
O0x000013 a6 j = randi);
0x000013 e if (3 < 014
0x000013k2 3= -3:
i
Ox000013k4 ali]l = 3;
Ox000013c2 printfialsd]=51dvn",i,a[i]):
i
0x000013e8 - sortia):
Ox000013ee printf ("*** Sorting results #*F\n");
0x000013 £a o for| i=0; i<10; i++ j{
0x00001402 printfia[3d]=sldvn", i,a[i]):
i
Ox00001426 win = a[0]:
Ox000014Z8 mwax = a[9]:
Ox00001425 min = 0O:
Ox000014Zc max = 0;
Ox000014Ze change (a) ;
Ox00001434 min = a[9]:
0x00001436 wax = a[0]:
¥
Ox00001442 woid sort(long *a)
{
long t:
int i, 3, k, gap;
0x0000144&a gap = 5;
Ox0000144c while{ gap = 0 |{
Ox00001450 for( k=0; k<gap: k++1{
Ox00001456 for( i=k+gap; i<10; i=i4gap ) {
0x00001462 for (j=i-gap; Ji>=k: j=i-gap){
Ox0000146a if{alil=ali+gapl){
Ll

Figure5.26 Source Window (Step Over)

When the printf function has been executed, *** Sorting results *** will be displayed in the

[Simulated 1/0] window.
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5.3.8 Checking Profile Infor mation

The profile information can be checked in the [Profile] window.

» Clicking the [Go] button and continuing execution from the current PC executes the SLEEP

instruction and stops.

[List] Sheet: Displaysthe profileinformation asalist.

» Open the [Profile] window by selecting [Profile] from the [View->Performance] menu. The

[List] sheet will be displayed.

E|

Function/Varishle Frv | address Size | Times | Cycle |Ext... |Tro... [Inc... | -
_PowerON_Resst_FC T H'Oo000EdO H'... 1 43 [ a 1
_ freeptr v  H'OFFFESBC H'... 1 a a a 0
~ rmerr v H'OFFFESBE H' 21 i i i i
" erenc v H'OFFFESBD H'... 4 0 0 0 0
_flmod v H'OFFFElAC H'... 256 a a a 0
_sml_but Vv H'OFFFEL9E H'... 439 a a a 0
_ich v  H'OFFFEO0E H'... & a a a 0
mfiles v H'DOONENEC H'. . 47 i i i i
~ alockut ¥ H'O00D40E4 H'... L £ 1 0 13
Tetrlen T H'O00040B4 H'... 40 131z a a 145
_ flshimf T H'O0003AEQ H'... 243 33858 250 a 5725
0%0000333C F H'0000383C H'... 102 11322 @ a 0
OxONO0ETED F H'ooonsTEn H'. 10z 10488 @ i 3672
0xO000ZEEE F o H'O0003EEE H'... L0Z 11322 © o o
0%00002404 ¥ H'O00003404 H'... 10Z 2834 0 0 3672
02000024928 T H'0000343% H'... 76 1560 a a 435
0%00003454 T H'00003434 H'... 102 408 a a 102
0%00003450 F H 00003450 H'... 138 3174 a a 328
OEONONE430 F o H'O0003430 H' . &0 1840 i i 4a0
0200002474 ¥ H'O00003424 H'... 40 21z 0 0 163
_fputa T H'O00030BE H'... Z43 zeedz 249 a 3237
0%00003096 T H'00003086 H'... 124 zz10 a a 435
0%00003084 F H'O00003084 H'... ZE 308 a a zz
OXONOAENZE F o HO0O0302E H'. 107 10407 143 i zrze
0200002388 ¥ H'O0002Z3EE H'... 40 zgavz 492 0 elzs
_ fmtour F H'O00018EG H'... ZZ 24738 2lae a 3935
_ flopen ¥ H'00001 H... 3 747 57 a 36

flclose ¥ i H' £3 0 56
0x0000178C ¥ B B o
_remd F o H'O000L7EC H'... L0 330 50 o 40
Tprintf ¥ H'O0000171C H'... ZZ 1088 3 0 110
_frecpen F H'O000lEE4 H'... 2 2z 3 a 45
_folose P H'O00001570 H'... 3 138 3 a 1z
0%000015EC F H'O000LSEC H'... LB azz 54 a 78
OxONO0T SR ¥ HOOONISE4 H'. . & 337 45 i i
0200001540 ¥ H'oooolsar H'... L 2414 1z 0 372
_changs F H'O00014E0 H'... 1 572 a a 40
_sore F H'O0000l442 H'... 1 1634 a a 120
_main F H'O000013EC H'... 1 11z 54 a 100
— CLOZEALL ¥ HoooonlzEe H' . 1 1013 &5 i 74
—INIT_IoLIE ¥ H'OO00L1EZ H'... 1 1zz3 73 0 155 -
Twrite ¥ H'O0001154 H'... Z43 leazz 492 0 2738
_close F H'O000LOCE H'... 3 a4 3 a ‘ =
4 List f{ Tree

Figure5.27 Profile Window (List Sheet)

In above figure, it can be found that the __flclose function was called six times, the execution
cycle was 453, the external memory was accessed six times, and the internal memory was

accessed 66 times.

It is possible to search for the critical path, such as afunction that is called or accesses the

memory many times, for the program performance.
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[Tree] Sheet: Displaysthe profile information as atree diagram.

» Select the [Tree] sheet. Double-clicking the function name in the [Profile] window expands

or minimizes the tree structure.

E|

Function Address Size | Stack Size Times | Cycle I Extmem | 170 area | Int mem I
[l C:3Hew3itutorialitutoriali8inleb. . .
E‘ """ Power(ON_Peset PC H'O0000z00 H.. H'OOD0O0O00O00 1 49 & u} 1
Ox00001lE4C H'O00OLlE4C H.. H'OOD0O0O00O00 1 2414 1z u} 379
_main H'O00OLlzaC H.. H'OOD0O0O00O00 1 11z& B4 u} 100
__ CLOSEALL H'O0001ZE4 H.. H'OOD0O0O00O00 1 101z &g u} 24
Bl _felose H'00001670 H.. H'00000000 2 138 2 1] 1z
E| £ H'000017CC H.. H'00000000 3 315 3 lu} 45
H'O0O0OL0CE H.. H'OOD0O0O00O00 2 84 2 u}
|é| """ _ INIT IOLIE H'0O000L1EBEZ H.. H'OOD0O0O00O00 1 12232 73 u} 155
E‘ freopen H'00001cE4 H.. H'OOD0O0O00O00 2 ZZ8 & u} 45
H'000017CC H.. H'00000000 2 lzg [ ] z1
H'O0O0OL0CE H.. H'OOD0O0O00O00 o u} u} u} u}
H'O000127C H.. H'OOD0O0O00O00 2 747 57 u} 26

AN F List A Tree

Figure5.28 Profile Window (Tree Sheet)

In above figure, it can be found that the __ flclose function was called three times from the
_fclose function, the execution cycle was 309, the external memory was accessed three times,
and the internal memory was accessed 45 times.
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[Profile-Chart] Window: Displays the relation of callsfor a specific function.

» Select the  flclose function on the [Profile] window. Open the pop-up menu by right
clicking the mouse on the [Profile] window, and select [View Profile-Chart] to display the
[Profile-Chart] window.

Frofile-Chart

_ flclose

Figure5.29 Profile-Chart Window

In above figure, it can be found that the __ flclose function was called three times from the
_fclose and _freopen functions, and the _close function was called three times.

Thisisthe end of the tutorial using the simulator/debugger.
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Section 6 Exiting from the HEW

Selecting [File->Exit] will close the HEW. Depending on the setting, the message box

(figure 6.1) which asks you whether to save the session or not will be launched. Not only the
setting like this regarding exiting from the HEW but also setting regarding initiation of the HEW
can to specified via[Tools->Options...]. For details, refer to the High-Performance Embedded
Workshop 3 User’s Manual.

The other tools launched from the HEW will not be closed when the HEW is closed. Close the
tools by yourself.

High-performance Embedded Workshop

Mo Cancel

Figure6.1 Confirmation Dialog Box for Saving Session on Exiting from the HEW
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