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Preface

This tutorial will introduce you to the basic usage of the Hitachi Embedded Workshop 2
(hereafter referred to as HEW). The tutorial describes a series of usage such as how to invoke the
HEW, how to create and modify a project, how to build a program, and how to invoke a
simulator/debugger from the HEW. For details on the HEW, the C/C++ compiler, assembler,
optimizing linkage editor, and simulator/debugger, refer to the following manuals.

• SuperH™ RISC engine Hitachi Embedded Workshop 2 User’s Manual

• SuperH™ RISC engine C/C++ Compiler, Cross Assembler, Optimizing Linkage Editor
User’s Manual

For details on the SuperH™ RISC engine CPU, refer to a programming manual or a hardware
manual of the corresponding CPU.

Microsoft®, Windows®, Windows® 98, Windows Me®, Windows NT®, Windows 2000® and
Windows® XP are registered trademarks of Microsoft Corporation in the United States and/or in
other countries.

All other brand or product names used in this manual are trademarks or registered trademarks of
their respective companies or organizations.
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This tutorial is written assuming that all the tools included in the SuperH™ RISC engine C/C++
compiler Package are installed.

If “->” is written inside [ and ], the left hand side of “->” means the menu title and the right hand
side of “->” means a menu option of the menu. For example, in figure 1, the menu option [Exit]
in the [File] menu is described as [File->Exit].

Figure 1   A Menu of the HEW
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Section 1   Invoking the HEW

After the installation of the HEW, the installer creates a folder whose name is [Hitachi
Embedded Workshop 2] in the [Program] folder of the [Start] menu of the Windows. In the
[Hitachi Embedded Workshop 2] folder, short cuts of the HEW support files will be registered.
The contents of the [Start] menu and its submenus differ depending on your installation.

Figure 1.1   Invoking the HEW from the [Start] Menu
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If you click [Hitachi Embedded Workshop 2] from the menu, the HEW will be invoked and the
[Welcome!] dialog box (figure 1.2) will be displayed. You can open the project promptly without
the [Welcome!] dialog box if you change the setting via [Tools->Options]. For details of this
setting, refer to chapter 6, “Customizing the Environment”, of the Hitachi Embedded Workshop
2 User’s Manual.

Figure 1.2   Welcome! Dialog Box

If you use the HEW for the first time or if you want to work on a new project, select the [Create
a new project workspace] radio button and click [OK]. If you want to work on an existing
project, select the [Open a recent project workspace] or [Browse to another project workspace]
radio button and click [OK].

In this tutorial, select the [Create a new project workspace] radio button and click [OK].
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Section 2   Creating a Project

2.1 Creating a New Workspace

When you have selected the [Create a new project workspace] radio button and clicked [OK] on
the [Welcome!] dialog box, the [New Project Workspace] dialog box (figure 2.1), which is used
to create a new workspace and project, will be launched. You will specify a workspace name
(When a new workspace is created, the project name is the same as the default), a CPU family, a
project type, and so on, on this dialog box.

Enter “tutorial”, for example, in the [Workspace Name] field, then the [Project Name] field will
show “tutorial” and the [Directory] field will show “c:\hew2\tutorial”. If you want to change the
project name, enter a new project name manually in the [Project Name] field. If you want to
change the directory used for the new workspace, click the [Browse…] button and specify a
directory, or enter a directory path manually in the [Directory] field.
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Figure 2.1   New Project Workspace Dialog Box

Table 2.1 Items of [Project type:]

Items of [Project type:] Description

Application This project is used to create a program that includes the initial
routine files written in C/C++ or assembly language.

Demonstration This project is used to create the program for demonstration
written in C/C++ or assembly language.

Empty Application This project is used to set up the toolchain (no file is to be
generated).

Library This project is used to create a library file (no file is to be
generated).
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2.2 Selecting the Target CPU

When you click [OK] on the [New Project Workspace] dialog box, the project generator will be
invoked. Start by selecting the CPU that you will be using. CPU types shown in the [CPU Type:]
list are classified into the CPU series shown in the [CPU Series:] list.

The selected items in the [CPU Series:] list box and the [CPU Type:] list box specify the files to
be generated. Select the CPU type of the program to be developed. If the CPU type which you
want to select is not displayed in the [CPU Type:] list, select a CPU type with similar hardware
specifications or select [Other].

Clicking [Next>] moves to the next display. Clicking [<Back] moves to the previous display or
the previous dialog box. Clicking [Finish] opens the [Summary] dialog box. Clicking [Cancel]
returns the display to the [New Project Workspace] dialog box. [<Back], [Next>], [Finish], and
[Cancel] are common buttons of all the wizard dialog boxes.

In this tutorial, select [SH-1] in the [CPU Series:] list and select [SH7020] in the [CPU Type:]
list (figure 2.2). Then click [Next >].

Figure 2.2   Selecting the Target CPU (Step 1)
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2.3 Option Setting

Clicking the [Next>] button on the Step-1 screen opens the dialog box shown in figure 2.3.

On this screen, you can specify options common to all project files.

Settings for these options can be modified in correspondence with the CPU series selected in step
1 screen. To change the option settings after a project has been created, select the CPU page
from the [Options -> Hitachi SuperH RISC engine Standard Toolchain] menu item of the HEW
window.

Click the [Next>] button without changing the setting. The Step-3 screen will be displayed.

Figure 2.3   Option Setting (Step 2)
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2.4 Setting the Contents of Files to be Generated

Click the [Next>] button on the Step-2 screen to display the screen shown in figure 2.4.

On this screen, specify information that is necessary to generate files.

If [Use I/O Library] is checked, the standard I/O library can be used.

If [Use Heap Memory] is checked, the function sbrk() for heap area management will be
generated. Specify the number of bytes of the heap area in the [Heap Size:] edit box.

Select whether or not to generate a sample code for the main function from the [Generate main()
Function] drop-down list.

If [I/O Register Definition Files] is checked, an I/O register definition file, which is written in C
language, can be created. Then select whether or not to generate a sample code for the program
that makes initial settings of the I/O registers from the [Generate Hardware Setup Function]
drop-down list.

In this tutorial, check [Use I/O Library] and click [Next >].

NOTE
If you want to use an existing main function, uncheck [Generate main() Function], add the file of
the function after generating the project. If the name of the function differs from main, change
the caller of the function in resetprg.c. For the contents of such sample files as a vector table
definition file or I/O register definition file that will be generated by the project generator, check
the description in the hardware manual for the target CPU.
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Figure 2.4   Setting the Contents of Files to be Generated (Step 3)
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2.5 Setting the Standard Library

The screen shown in figure 2.5 is displayed when the [Next>] button is clicked in the Step-3
screen. This screen is used to set details of compilation by the C/C++ compiler. To change the
standard library configuration after a project has been created, select the CPU page in [Options -
> Hitachi SuperH RISC engine Standard Toolchain] of the HEW. In this tutorial, click the
[Next>] button without changing the settings.

Figure 2.5   Setting the Standard Library (Step 4)
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2.6 Setting the Stack Area

The screen shown in figure 2.6 is displayed when the [Next>] button is clicked in the Step-4
screen.

This screen is used to specify the stack area.

The initial value of the stack area differs depending on [CPU Type:] selected in the Step-1
screen. To change the stack size after a project has been created, select the [Project -> Edit
Project Configuration] menu item of the HEW window. In this tutorial, since SH7020 has been
selected for [CPU Type:] in the Step-1 screen, [Stack Pointer Address:] is set to H’7FFFFFF0
and [Stack Size:] is set to H’100. In this tutorial, click the [Next>] button without changing the
settings.

Figure 2.6   Setting the Stack Area (Step 5)

The stack area is defined in stacksct.h that is generated by the HEW. If stacksct.h has been edited
in an editor, its modification after you have selected the [Project -> Edit Project Configuration]
menu item of the HEW will not be available.
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2.7 Setting the Vector

Clicking the [Next>] button in the Step-5 screen displays the screen shown in figure 2.7.

In this screen, a vector is specified.

If [Vector Table Definition Files] is checked, the HEW creates a vector table definition file.

The [Handler] column of [Vector Handlers:] displays the handler program name, and the
[Vector] column displays the vector description. To change the handler program, click the name
of the handler program to be changed, and enter a new name.

If  the handler name in the [Vector Handlers:] list is changed, the HEW does not create the reset
program (resetprg.c).

In this tutorial, click the [Next>] button without changing the settings.

Figure 2.7   Setting the Vector (Step 6)
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2.8 Setting the Target System for Debugging

When the [Next>] button is clicked in the Step-6 screen, the screen shown in figure 2.8 is
displayed. This screen is used to specify the target system for debugging. Select (check) the
target for debugging from the list under [Targets:]. Selection of no target or of multiple targets is
allowed.

In this tutorial, select [SH-1 Simulator] and then click the [Next>] button.

Figure 2.8   Setting the Target System for Debugging (Step 7)

If you change [Target type:], you can specify the other target system for debugging.
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2.9 Setting the Debugger Options

When the [Next>] button is clicked in the Step-7 screen, the screen shown in figure 2.9 is
displayed. This screen is used to specify the optional settings for the selected target for
debugging.

By default, the HEW creates two configurations, [Release] and [Debug]. When a target for
debugging is selected, the HEW creates another configuration (The name of the target is
included). The name of the configuration can be modified in [Configuration name:]. Options to
do with the target for debugging are displayed under [Detail options:]. To change the settings,
select [Item] and then click [Modify]. When items for which modification is not possible are
selected, [Modify] remains grayed even if [Item] is selected.

In this tutorial, click the [Next>] button without changing the settings.

Figure 2.9   Setting the Debugger Options (Step 8)
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2.10 Changing the File Names to be Created

When the [Next>] button is clicked in the Step-8 screen, the screen shown in figure 2.10 is
displayed.

The screen displays a list of files created by HEW according to the previous settings. The [File
Name] column in the list shows a file name, [Extension] shows an extension, and [Description]
shows the description of a file. The file name can be changed. To change a file name, select it by
clicking it and change it to a new file name.

In this tutorial, click the [Finish] button without changing the settings. When the button is
clicked, the [Summary] dialog box will be displayed.

Figure 2.10   Changing the File Names to be Created (Step 9)

NOTE
A file with an extension “h” or “inc” (shown in the [Extension] column) is an include
file. If you change the file name of an include file, the file name at the include directive
have to be modified.
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2.11 Confirming Settings (Summary Dialog Box)

The project generator shows a list of generated files on the [Summary] dialog box (figure 2.11).
Confirm the contents of the dialog box and click [OK].

When [Generate Readme.txt as a summary file in the project directory] checkbox is checked, the
project information displayed on the [Summary] dialog box will be stored in the project directory
under the text file name "Readme.txt".

Figure 2.11   Summary Dialog Box

Then the HEW will open a project generated by the project generator.

By default, the HEW has:

The [Workspace] window (on the left hand side of the HEW), which shows the contents of the
project, the [Output] window (on the lower side of the HEW), which shows outputs from a build
or a string search, and the editor window (on the right hand side of the window), which is used to



24

edit text files. Refer to the Hitachi Embedded Workshop 2 User’s Manual for how to change the
state of the HEW and how to use each window such as the editor window.

Figure 2.12   Sub-windows of the HEW

The project generated by the project generator includes minimum options for the C/C++
compiler, the assembler, the inter-module optimizer and the object converter. Thus you can build
the project (figure 2.13) by selecting [Build->Build]. Selecting the button (shown below) on the
toolbar works in the same way as selecting [Build->Build].

Those minimum options are set by default for each tool. When you add a new file to the project,
the minimum options will automatically be added to the file. You do not have to specify options
other than those that are specific to each such file.

Title bar

Menu bar

Tool bar

Workspace

Window

[Projects] sheet

Editor Window

area

Output Window

[ Build] sheet

Status bar
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Figure 2.13   The HEW after Building a Project
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Section 3   Modifying the Project

When you create a project using the project generator, basic program such as reset routine and
initialization of RAM area will already be given in the project. This tutorial describes how to
modify a file and how to add a file to the project.

3.1 Editing and Creating a Source Program File

To open and edit a file in the project, double click the file in the [Projects] sheet of the
[Workspace] window. In this tutorial, double click “tutorial.c”. (figure 3.1)

Figure 3.1   Opening a Project File
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Then you can edit the file opened. If you edit the file, an asterisk (*) will be added to the file path
shown on the title bar of the HEW (figure 3.2). If you save the file, the asterisk will disappear.

Figure 3.2   Editing a Project File

If you want to open an existing text file with the editor of the HEW, select [File->Open]. If you
want to edit a new text file with the editor, select [File->New].  In this tutorial, select [File-
>New], input the three lines shown below, select [File->Save As…] and save the file as
“newprog.c”.

void NewProgram(void)

{

}
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3.2 Adding/Removing a File To/From a Project

This section describes how to add a file to a project and how to delete a file from a project. In
this tutorial, add the file, “newprog.c” created in the previous section to the project as follows.
Select [Project->Add Files…], then the [Add File(s)] dialog box (figure 3.3) will be launched.
Select a file, “newprog.c” in this example, to be added and click the [Add] button. Thus
“newprog.c” will be added to the project.

Figure 3.3   Adding a File To a Project
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The added file will be displayed on the [Projects] sheet of the [Workspace] window as shown in
figure 3.4.

Figure 3.4   Project With a File Added
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Next, how to delete a file from a project will be shown. Select [Project->Remove File…], then
the [Remove Project Files] dialog box (figure 3.5) will be displayed. Select one or more project
files on this dialog box and click the [Remove] button. Then the selected file(s) will disappear
from the list of the dialog box. Clicking [OK] actually removes the file(s) from the project.
Clicking [Cancel] instead will nullify the removal.

You have another way to delete a file from a project. Select the file in the [Projects] sheet of the
[Workspace] window and press the [Delete] key. Then the file will be deleted from the project.

If you want to exclude a file from a build temporarily instead of removing the file from the
project, refer to section 4.4, “Excluding a Project File from Build”.

Figure 3.5   Remove Project Files Dialog Box
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3.3 File Groups Used in a Project

In this section, a file group to which a file added to a project belongs is described. For example,
the project generator adds a file described in C language or assembly language to the project. A
file with a file extension “.c” belongs to the [C source file] group, and a file with a file extension
“.src” belongs to the [Assembly source file] group.

The HEW identifies a group to which a file belongs by checking the file extension. Select
[Project->File Extensions…], then the [File Extensions] dialog box (figure 3.6) will be
displayed. File extensions used in the project are shown on this dialog box. Every file extension
belongs to a file group. A file group can be associated to a tool in a build process.

If you want to use your own file extension in the project, define a new file extension by clicking
the [Add…] button.

The icon displayed in the [Extension] column of the [File Extensions] dialog box can show a tool
which opens the file. If the icon of a file extension is the same as the icon shown below, a file
with that file extension can be opened by the editor of the HEW.

Figure 3.6   File Extensions Dialog Box (Initial Screen)
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Click the [Add…] button on the [File Extensions] dialog box, then the [Add File Extension]
dialog box (figure 3.7) will be launched. Enter a new file extension in the [File extension] field
and specify the [File group] group box. If you want to add an extension to an existing file group,
select the [Extension belongs to an existing group] radio button and select a file group from the
drop-down list. If you want to create a new file group, select the [Extension belongs to a new
group] radio button and enter the name of the file group in the edit field.

In this tutorial, enter “asm” in the [File extension] field, select “Assembly source file” from the
drop-down list and click [OK]. Then a file with the extension, “*.asm”, will be treated as a file in
the [Assembly source file] group (figure 3.8).

Figure 3.7   Add File Extension Dialog Box



34

Figure 3.8   File Extension Dialog Box (After Adding an File Extension)

3.4 Customizing the Workspace Window

Click the right mouse button on the [Projects] sheet of the [Workspace] window, then a pop-up
menu will be displayed.  Select [Configure View…] on this menu, then [Configure View] dialog
box (figure 3.9) will be launched. On this dialog box, you can specify whether the file
dependencies are shown for each file or not, whether a file is shown in a file group folder (figure
3.10) or not, and so on.

Figure 3.9   Configure View Dialog Box
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Figure 3.10   Configuration of the Workspace Window
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Section 4   Building a Project

4.1 Build Overview

The HEW provides two ways of building a project.

1. “Build All” ([Build->Build All])

The series of tools including the compiler, assembler, and linkage editor are applied to all of the
source program files.

2. “Build” [Build->Build]

The series of tools are applied to a source program file updated after the last build. (The update
means not only the update of a source program file, but also an update of a file included by the
source program file and an update of an option applied to the source program file.)

If you want to compile or assemble a single source program file, select the file on the [Projects]
sheet of the [Workspace] window and select [Build->Build File].

If you want to execute “Build” or “Build All” for multiple programs or configurations, specify
the target by selecting the [Build -> Build Multiple] menu item.

CAUTION ON BUILD

1. Depending of the setting of the editor window, a file being edited might be saved
on executing a build. So close a file which you do NOT want to be saved
beforehand. For details of customizing the editor, refer to the Hitachi Embedded
Workshop 2 User’s Manual.

2. Do not save a file used in a project during the build because doing so might disturb
the build process.

4.2 Setting Options

In this section, overview of the option setting is described.

When the project generator generates a project, the minimum options required for a build are
already specified. If you want to modify the options, however, select [Options-> Hitachi SuperH
RISC engine Standard Toolchain] and set options on the option dialog box.
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Figure 4.1 shows the option dialog box of a C/C++ compiler. On the left hand side of the dialog
box is a file list, and on the right hand side are optional setting controls for each tool divided into
some pages. If you select a file in the file list, you can specify options only to the selected file. If
you select a file group folder in the file list, you can specify the same option to all the files in the
file group. To specify the same options to specific files, select the files while pressing the [Ctrl]
key or the [Shift] key.

If you select [Default Options] in a file group folder, you can specify initial options for the file
group. The HEW automatically adds the options specified to the [Default Options] to a file of the
corresponding file group of the corresponding file extension of the file.  For example, if you add
a file with an extension “C” (“*.C”) to the project, the settings of the [Default Options] of the [C
source file] group will be added to the file automatically.

For the details of the options refer to the SuperH RISC engine C/C++ Compiler, Cross
Assembler, or Optimizing Linkage Editor User’s Manual.

Figure 4.1   Option Dialog Box of C/C++ Compiler
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4.3 Customizing the Configuration

In the previous section, how to set options to a project file is described. In this section, how to
create more than one suite of option settings for a build will be described. A suite of option
settings for a build is called a configuration.

The project generator creates two configurations, [Debug] and [Release]. Difference between
them is only the setting of the debugging option. When a target for debugging is selected, the
configuration for the target is also created. To switch the current configuration to another, launch
the [Build Configurations] dialog box (figure 4.2) by selecting [Options->Build
Configurations…], select a configuration from the [Current configuration] drop-down list, and
click [OK]. You can also change the current configuration by selecting one from the drop-down
list on the toolbar.

On the [Build Configurations] dialog box, you can create a new configuration or delete a
configuration. For details, refer to chapter 2, “Build Basics”, of the Hitachi Embedded Workshop
2 User’s Manual.

Figure 4.2   Build Configurations Dialog Box
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4.4 Excluding a Project File from Build

In this section, how to exclude a project file from build will be described. Excluding a project
file from build does not delete the file from a project, but exclude a project file from build in
configuration by configuration basis.

Select a file on the [Projects] sheet of the [Workspace] window, click the right mouse button, and
select [Exclude Build <file>] on the pop-up menu. Then a red cross will be added to the icon of
this file as shown in figure 4.3. This file will be excluded from a build.

To include an excluded file into build, select the file on the [Projects] sheet of the [Workspace]
window, click the right mouse button, and select [Include Build <file>] on the pop-up menu.

Figure 4.3  Excluding a Project File from Build
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4.5 Correcting  Errors in a Build

In this section, how to jump to a line of a file which caused an error in compiling or assembling
will be described.

Figure 4.4 shows an example in which a compiler detected a syntax error in a source program
file. When you build a project, messages, including error messages, from a tool in a build will be
displayed on the [Output] window.  If you double click the line of the error message on the
[Build] sheet of the [Output] window, the file which caused the error will be opened and the
cursor will be placed on the line which caused the error. (The cursor might not be placed on the
line which caused the error if you have already edited the file.) Placing the cursor on the error
line of the output window and pressing the [F1] key displays help of that error.

Figure 4.4   Correcting the Line which Caused an Error
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4.6 Customizing the Session

You can save the options for debugger to the session file.

The project generator creates the session, [Default Session]. When a target for debugging is
selected, the session for the target is also created. To use the a target, launch the [Debug
Sessions] dialog box (figure 4.5) by selecting [Options->Debug Settings…], select a session
[SimSessionSH-1] from the [Current session] drop-down list, and click [OK]. You can also
change the current session by selecting one from the drop-down list on the toolbar.

On the [Debug Sessions] dialog box, you can create a new session or delete a session. For
details, refer to chapter 1.9, “Debugger Sessions”, of the Hitachi Embedded Workshop 2 User’s
Manual Simulator/Debugger Part.

Figure 4.5   Debug Sessions Dialog Box
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Section 5   Debugging

5.1 Preparation

The basic functions of the simulator/debugger will be described in this section using a sample
program.

NOTE
Note that the contents of usage examples (figures) in this section will differ depending on the
compiler version.

5.1.1 Sample Program

The HEW demonstration program is used for the sample program and is written in C language It
first sorts ten random data in the ascending order, and then in the descending order.  The sample
program:

(1) Generates random data for sorting using the main function.

(2) Inputs the array which stores the random data that is generated by the main function, then
sorts the data in the ascending order using the sort function.

(3) Inputs the array generated by the sort function, and sorts the data in the descending order
using the change function.

(4) Displays the random data and the sorted data using the printf function.

5.1.2 Creating the Sample Program

Create the HEW demonstration program by referring to sections 1 to 4, and note the following.

• Specify [Demonstration] for the [Project Type] in section 2.1, Creating a New Workspace.

• Specify [SH-1] for the [CPU Series:].

• Specify [SH-1 Simulator] for the [Target:].

• Specify [SimDebug_SH-1] for the configuration on the
toolbar before building the project.

• Specify [SimSession_SH-1] for the session on the toolbar.

Since section 5 explains the debugging function, [Demonstration] has not been optimized.  Do
not change this setting.
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5.2 Settings for Debugging

5.2.1 Allocating the Memory Resource

The allocation of the memory resource is necessary to run the application being developed.
When using the demonstration project, the memory resource is allocated automatically, so check
the setting.

• Select [Simulator->Memory Resource...] from the [Option] menu, and display the allocation
of the current memory resource.

Figure 5.1   Simulator Memory Resource Dialog Box

The program area is allocated to the addresses H'00000000 to H'00007FFF.  The stack area is
allocated to the addresses H'0FFFE000 to H'0FFFFFFF, which can be read from or written to.

• Close the dialog box by clicking [Close].

The memory resource can also be referred to or modified by using the [Simulator] page on the
[Hitachi SuperH RISC engine Standard Toolchain] dialog box.  Changes made in either of the
dialog boxes are reflected.
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5.2.2 Downloading the Sample Program

When using the demonstration project, the sample program to be downloaded is automatically
set, so check the settings.

• Open the [Debug Setting] dialog box by selecting [Debug Settings...] on the [Option] menu.

Figure 5.2   Debug Settings Dialog Box

• Files to be downloaded is set in [Download Modules].

• Close the [Debug Settings] dialog box by clicking the [OK] button.

• Download the sample program by selecting [Download Modules->All Download Modules]
from the [Debug] menu.
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5.2.3 Displaying the Source Program

The source-level debugging is supported by the HEW.  Refer to section 3.1, Editing and Creating
a Source Program File, and display the source file ("tutorial.c") in the [Source] window.

• Open the [Source] window by double-clicking tutorial.c on the [Workspace] window.

Figure 5.3   Source Window (Displaying the Source Program)
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5.2.4 Setting a PC Breakpoint

Breakpoints can be set easily by the [Source] window.  To set a breakpoint on a line that includes
the sort function call:

• Place the cursor in the line that includes the sort function call and click the right mouse
button to launch the pop-up menu, and select [Toggle Breakpoint] from the pop-up menu.

Figure 5.4   Source Window (Setting the Breakpoint)

A • is displayed at the line that includes the sort function call, indicating that the PC breakpoint
is set at the address.
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5.2.5 Setting the Profiler

• Open the [Profile] window by selecting [Profile] from the [View->Performance] menu.

Figure 5.5   Profile Window

• Open the pop-up menu by right clicking the mouse on the [Profile] window, and select
[Enable Profiler] to enable acquisition of the profile information.
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5.2.6 Setting the Simulated I/O

When the demonstration project is used, the simulated I/O is automatically set, so check the
setting.

• Open the [Simulator System] dialog box by selecting [Simulator->System] from the [Option]
menu.

Figure 5.6   Simulator System Dialog Box

• Confirm that [Enable] in [System Call Address] is checked.

• Click the [OK] button to enable the Simulated I/O

• Select [Simulated I/O] from the [View->CPU] menu and open the [Simulated I/O] window.
The Simulated I/O will not be enabled if the [Simulated I/O] window is not open.
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Figure 5.7   Simulated I/O Window

5.2.7 Setting the Trace Information Acquisition Conditions

• Select [Trace] from the [View->Code] menu and open the [Trace] window.  Open the pop-up
menu by right clicking the mouse on the [Trace] window, and select [Acquisition...] from the
pop-up menu.

The [Trace Acquisition] dialog box below will be displayed.

Figure 5.8   Trace Acquisition Dialog Box
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• Set [Trace start/Stop] to [Enable] in the [Trace Acquisition] dialog box, and click the [OK]
button to enable the acquisition of the trace information.

5.2.8 Setting the Stack Pointer and Program Counter

To execute the program, the program counter must be set from the location of the reset vector.
In the reset vector of the sample program, the PC value H'800 is written, and the SP value
H'0FFFFFF0 is written.

• Select [Reset CPU] from the [Debug] menu, or click the [Reset CPU] button on the toolbar.

Set the program counter to H'800, and the stack pointer to H'0FFFFFF0 from the reset vector.

Figure 5.9   Reset CPU Button
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5.3 Start Debugging

5.3.1 Executing a Program

• Select [Go] from the [Debug] menu, or click the [Go] button on the toolbar.

Figure 5.10   Go Button

The program halts where a breakpoint is set.  An arrow is displayed in the [Source] window,
indicating the location the execution has stopped.  As the termination cause, [PC Breakpoint] is
displayed in the [Output] window.

Figure 5.11   Source Window (Break Status)
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The termination cause can be displayed in the [Status] window.

• Select [Status] from the [View->CPU] menu to open the [Status] window, and select the
[Platform] sheet in the [Status] window.

Figure 5.12   Status Window

The above status window indicates that:

(1) The cause of break is a PC breakpoint

(2) Execution is performed from the pipeline reset

(3) The number of executed instructions by the GO command is 41,437

(4) The executed number of cycles from the pipeline reset is 86,726

Register values can be checked in the [Register] window.

• Select [Registers] from the [View->CPU] menu.
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Figure 5.13   Register Window

Register values when the program is terminated can be checked.

5.3.2 Using the Trace Buffer

The trace buffer can be used to clarify the history of instruction execution.

• Select [Trace] from the [View->Code] menu and open the [Trace] window.  Scroll up to the
very top of the window.

Figure 5.14   Trace Window (Trace Information Display)
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5.3.3 Performing Trace Search

Click the right mouse button on the [Trace] window to launch the pop-up menu, and select
[Find...] to open the [Trace Search] dialog box.

Figure 5.15   Trace Search Dialog Box

Setting the item to be searched to [Item] and the contents to be searched to [Value] and clicking
the [OK] button begins the trace search.  When the searched item is found, the first line is
highlighted.  To continue searching the same contents [Value], click the right mouse button in
the [Trace] window to display the pop-up menu, and select [Find Next] from the pop-up menu.
The next searched line is highlighted.

Figure 5.16   Trace Window (Searched Result)
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5.3.4 Checking Simulated I/O

Random data that is displayed by the printf function can be checked in the [Simulated I/O]
window.

Figure 5.17   Simulated I/O Window

• Do not close the [Simulated I/O] window.
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5.3.5 Checking the Breakpoints

A list of all the breakpoints that are set in the program can be checked in the [Break] window.

• Select [Breakpoints] from the [View -> Code] menu.

Figure 5.18   Break Window

A breakpoint can be set, a new breakpoint can be defined, and a breakpoint can be deleted using
the [Break] window.

• Close the [Break] window.

5.3.6 Watching Variables

It is possible to watch the values of variables used in your program and to verify that they change
in the way that you expected. For example, set a watch on the long-type array “a” declared at the
beginning of the program, by using the following procedure:

• Select [Watch] from the [View -> Symbol] menu and open the [Watch] window.  And click
the right mouse button on the [Watch] window and choose [Add Watch...] from the pop-up
menu.

The following dialog box will be displayed.

Figure 5.19   Add Watch Dialog Box

• Type array a and click the [OK] button.
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The [Watch] window will show the long-type array a.

You can double-click the + symbol to the left of array “a” in the [Watch] window to expand the
variable and show the individual elements in the array.

Figure 5.20  Watch Window

• Close the [Watch] window.

5.3.7 Executing the Program in Single Steps

The simulator/debugger has various stepping menus that are useful in debugging the program.

Menu Description

Step In Executes each statement (includes statements within the function)

Step Over Executes a function call in a single step

Step Out Steps out of a function, and stops at the next statement of the program that called
the function

Step... Executes the specified number of steps at the specified speed
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[Step In]:   Enters the called function and stops at the statement at the start of the called function.

• To step in the sort function, select [Step In] from the [Debug] menu, or click the [Step In]
button on the toolbar.

Figure 5.21   Step In Button

Figure 5.22   Source Window (Step In)

• The PC location display (=>) in the [Source] window moves to the statement at the start of
the sort function.
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[Step Out]:  Steps out of the called function and stops at the next statement in the called
program.

• Select [Step Out] from the [Debug] menu to exit the sort function, or click the [Step Out]
button on the toolbar.

Figure 5.23   Step Out Button

Figure 5.24   Source Window (Step Out)
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[Step Over]:  Executes a function call in a single step, and stops at the next statement in the
main program.

Select [Step Over] from the [Debug] menu or click the [Step Over] button on the toolbar to step
over the statements in the printf function.

Figure 5.25   Step Over Button

Figure 5.26   Source Window (Step Over)

When the printf function has been executed, *** Sorting results *** will be displayed in the
[Simulated I/O] window.
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5.3.8 Checking Profile Information

The profile information can be checked in the [Profile] window.

• Clicking the [Go] button and continuing execution from the current PC executes the SLEEP
instruction and stops.

[List] Sheet:  Displays the profile information as a list.

• Open the [Profile] window by selecting [Profile] from the [View->Performance] menu.  The
[List] sheet will be displayed.

Figure 5.27   Profile Window (List Sheet)

In above figure, it can be found that the __flclose function was called six times, the execution
cycle was 453, the external memory was accessed six times, and the internal memory was
accessed 66 times.

It is possible to search for the critical path, such as a function that is called or accesses the
memory many times, for the program performance.
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[Tree] Sheet:  Displays the profile information as a tree diagram.

• Select the [Tree] sheet.  Double-clicking the function name in the [Profile] window expands
or minimizes the tree structure.

Figure 5.28   Profile Window (Tree Sheet)

In above figure, it can be found that the __flclose function was called three times from the
_fclose function, the execution cycle was 309, the external memory was accessed three times,
and the internal memory was accessed 45 times.
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[Profile-Chart] Window:   Displays the relation of calls for a specific function.

• Select the __flclose function on the [Profile] window.  Open the pop-up menu by right
clicking the mouse on the [Profile] window, and select [View Profile-Chart] to display the
[Profile-Chart] window.

Figure 5.29   Profile-Chart Window

In above figure, it can be found that the __flclose function was called three times from the
_fclose and _freopen functions, and the _close function was called three times.

This is the end of the tutorial using the simulator/debugger.
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Section 6   Exiting from the HEW

Selecting [File->Exit] will close the HEW. Depending on the setting, the message box
(figure 6.1) which asks you whether to save the session or not will be launched.  Not only the
setting like this regarding exiting from the HEW but also setting regarding initiation of the HEW
can to specified via [Tools->Options…]. For details, refer to the Hitachi Embedded Workshop 2
User’s Manual.

The other tools launched from the HEW will not be closed when the HEW is closed. Close the
tools by yourself.

Figure 6.1   Confirmation Dialog Box for Saving Session on Exiting from the HEW
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