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with a Built-in R-IN Engine Not Utilizing the HW-RTOS 

Outline 
This application note describes the sample programs for enabling RZ/T1 group devices that are equipped with a built-in 

R-IN engine to serve as EtherCAT® slaves that are used to control industrial AC servo motors or other devices with 

EtherCAT communication via PLC. 

 

The features of the sample programs are as follows: 

• The sample programs run with the Cortex-R4 and Cortex-M3 cores. The Cortex-M3 core handles EtherCAT 
communication, and the Cortex-R4  core handles generation of data to be sent to the EtherCAT master and display 
of received data with LEDs. A shared memory driver is used for communication between the CPUs. 

• An EtherCAT communication program is created by using the Beckhoff SSC Tool (EtherCAT slave sample code 
generation tool). The SSC Tool project file and ESI file, and patch file that corrects the sample program coding 
(such as the sections that depend on the RZ/T1 hardware) are provided. 

• The following two sample programs are provided: 
(1) Simple I/O controller sample program for 32-bit I/O processing (hereafter, I/O controller sample program) 
(2) Sample program for verifying the CiA402 drive profile (hereafter, CiA402 sample program) 

• In these sample programs, the Cortex-M3 core does not utilize the HW-RTOS. 
 

Target Device 
RZ/T1 group devices with a built-in R-IN engine. 
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1. Specifications 
Table 1.1 lists the peripheral modules to be used and applications. Figure 1.1 shows the operating environment. 

 
Table 1.1 Peripheral Modules and Applications 

Peripheral Module Application 
Clock generator  Supplying the CPU clock and low-speed on-chip oscillator clock 
EtherCAT slave controller Handling EtherCAT communication 
Ethernet MAC (ETHERC) Handling EtherCAT communication 
Interrupt controller (ICUA) Handling EtherCAT Slave interrupts (EtherCAT, EtherCAT Sync0) 

and compare match interrupts (CMI0 and CMI1) 
Compare match timer (CMT) Handling the cycle counting of the compare match timer 
Extended internal RAM Shared memory area (Data RAM) and memory area for the 

program of the Cortex-M3 core (Instruction RAM) 
Error control module (ECM) Initializing the ERROROUT# pin 
General-purpose input/output ports Pins which control LED display and key entry 

 

 
Note 1. Indicates the device that the user needs to prepare. 

Figure 1.1 Operating Environment 
For connection with the EtherCAT master, use the LAN interface J1 (EtherCAT1 port). 
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2. Operating Environment 
The sample programs described in this application note assume the environment below. 

 
Table 2.1 Operating Environment 

Item Description 
Board RZ/T1 evaluation board 

RTK7910022C00000BR 
CPU RZ/T1 (with a build-in R-IN engine) 

R7S910017 
Operating frequency CPU clock (CPUCLK): 450 MHz (Cortex-R4) 

System clock (ICLK): 150 MHz (Cortex-M3) 
Operating voltage 3.3 V 
Operating mode 16-bit-bus boot mode 

SPI boot mode 
Devices  NOR flash memory 

  Macronix MX29GL512FLT2I-10Q 
Serial flash memory 
  Macronix MX25L51245GMI-10G 
EEPROM 
  Renesas R1EX24016ASAS0 
Ethernet PHY 
  Micrel KSZ8041TL 

Communication protocol EtherCAT® 
Integrated development environment IAR Systems Embedded Workbench® for ARM Version 8.20.2 
Emulator IAR Systems I-jet 
SSC Tool Slave Stack Code (SSC) Tool Version 5.12 provided by EtherCAT 

technology Group (ETG) 
Software PLC Beckhoff Automation TwinCAT®3 
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3. Peripheral Modules 
For the basics of the following items, refer to the RZ/T1 Group User's Manual: Hardware: 

Clock generator, EtherCAT slave controller, Ethernet MAC (ETHERC), Interrupt controller (ICUA), Compare match 
timer (CMT), Error control module (ECM), extended internal RAM, and general-purpose I/O ports. 
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4. Hardware 
4.1 Hardware Structure Example 
Figure 4.1 shows an example of the hardware structure for the I/O controller sample program. Figure 4.2 shows an 
example of the hardware structure for the CiA402 sample program. 
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Figure 4.1 Hardware Structure Example for the I/O Controller Sample Program 
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Figure 4.2 Hardware Structure Example for the CiA402 Sample Program 
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4.2 Pins Used 
Table 4.1 shows pins and functions. 

 
Table 4.1 Pins and Functions 

Item Input/Output Description 
MD0 Input Select the operating mode 

MD0 = L and MD1 = L and MD2 = L: SPI boot mode 
MD0 = L and MD1 = H and MD2 = L: 16-bit bus boot mode 

MD1 Input 
MD2 Input 
ETH_MDIO Input/output Management data signal input/output 
ETH_MDC Output Management interface clock output 
ETH0_RXC Input/output Receive clock I/O pins 
ETH1_RXC 
ETH0_RXER Input Reception data error signal input 
ETH1_RXER 
ETH0_RXDV Input Reception data enable signal input 
ETH1_RXDV 
ETH0_RXD0-3 Input Reception data signal input  
ETH1_RXD0-3 
ETH0_TXC Input 10 M/100 M transmission clock (2.5 MHz/25 MHz) input 
ETH1_TXC 
ETH0_TXER Output Transmission error signal output 
ETH1_TXER 
ETH0_TXEN Output Transmission enable signal output 
ETH1_TXEN 
ETH0_TXD0-3 Output Transmission data signal output 
ETH1_TXD0-3 
ETH0_COL Input Collision detection signal input 
ETH1_COL 
ETH0_CRS Input Carrier sense signal input 
ETH1_CRS 
CLKOUT25M0 Output External clock output for Ethernet PHY 
CLKOUT25M1 
PHYRESETOUT# Output PHY RESETOUT output 
PHYLINK0 Input PHY Link signal input for Ether Switch 
PHYLINK1 
ETHSWSECOUT Output Per-second Ether Switch event output 
ETH0_INT Input Ethernet PHY interrupt request signal input 
ETH1_INT 
CATI2CCLK Output EtherCAT EEPROM I2C clock signal output  
CATI2CDATA Input/output EtherCAT EEPROM I2C data signal input/output 
CATLINKACT1 Output EtherCAT Link/Activity LED signal output 
CATLINKACT0 
CATLEDRUN Output EtherCAT RUN LED signal output 
CATLEDSTER Output EtherCAT Dual-color state LED signal 
CATLEDERR Output EtherCAT Error LED signal output 
PF7 Output Switches LED0 on and off. 
P56 Output Switches LED1 on and off.  
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Item Input/Output Description 
P77 Output Switches LED2 on and off.  
PA0 Output Switches LED3 on and off. 
P35 Input SW1 input 
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5. Software 
5.1 Software Structure 
Figure 5.1 shows the software structure for the sample programs. 

 

 
Note 1. Renesas provides the EtherCAT SSC projects that has reflected the hardware-dependent 

processing and necessary modifications. 
Note 2. SSC Tool: EtherCAT control program generation tool provided by Beckhoff 

Figure 5.1 Software Structure Example 

 

5.2 Directory Configuration 
5.2.1 Directory Configuration of the Sample Programs for Cortex-M3 
The \workspace\iccarm\Cortex-M3 directory is the current directory of the sample programs for Cortex-M3. 

 
Table 5.1 Directory Structure of the Sample Programs for Cortex-M3 

Directory Description 
../CMSIS Directory storing the definitions related to Cortex-M3 

(CMSIS is used as is). 
../Device/Renesas/RIN_Engine/Include Directory storing include files 
../Device/Renesas/RIN_Engine/Library Directory storing libraries 
../Device/Renesas/RIN_Engine/Source/Board Directory storing board-dependent source files 
../Device/Renesas/RIN_Engine/Source/Driver Directory storing peripheral driver source files 
../Device/Renesas/RIN_Engine/Source/Project_D
ual/EtherCAT_SSC_DC-hwos 

Directory storing the projects for the I/O controller 
sample programs 

../Device/Renesas/RIN_Engine/Source/Project_D
ual/EtherCAT_SSC_CiA402-hwos 

Directory storing the projects for the CiA402 sample 
programs 

../Device/Renesas/RIN_Engine/Source/Templates Directory storing startup files 
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5.2.2 Directory Configuration of the Sample Programs for Cortex-R4 
The \workspace\iccarm\Cortex-R4 directory is the current directory of the sample programs for Cortex-R4. 

 
Table 5.2 Directory Structure of the Sample Programs for Cortex-R4 

Directory Description 
../ EtherCAT_SSC_DC Directory storing the projects for the I/O controller sample programs 
../ EtherCAT_SSC_CiA402 Directory storing the projects for the CiA402 sample programs 

 
 

5.3 Operation Overview 
5.3.1 I/O Controller Sample Program 
The program for the Cortex-R4 core makes initial settings after power is supplied to the core. First, the program copies 
the program code of the Cortex-M3 core, from the external flash memory to the extended internal RAM, to release the 
Cortex-M3 core from the reset state. Then, the program sets the LED-controlling port pins, initializes CMT0 and 
CMT1, and specifies the periodic event and interrupt settings. 

During EtherCAT communication, the program for the Cortex-R4 core reads the output counter in the shared memory 
by using CMT0 periodic events, and then outputs the values of the low-order four bits to LED3 to LED0. The program 
also increments the input counter by using CMT1 periodic events, and copies the value to the shared memory. 

The program for the Cortex-M3 core makes the initial setting for the board. It also makes the initial setting and other 
required settings for the EtherCAT protocol stack after the core is released from the reset state.  

In the main loop, the program for the Cortex-M3 core executes the main process of the EtherCAT protocol stack.  

The handler for EtherCAT interrupts and EtherCAT Sync0 interrupts copies the 32-bit output values from the 
EtherCAT master to the output counter in the shared memory. The handler also reads the value of the input counter in 
the shared memory, and sends the value to the EtherCAT master as 32-bit input. 
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Figure 5.2 Simple Flowchart of the I/O Controller Sample Program 
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5.3.2 CiA402 Sample Program 
Figure 5.3 shows a simple flowchart of the CiA402 sample program. 

The program for the Cortex-R4 core makes initial settings after power is supplied to the core. First, the program copies 
the program code of the Cortex-M3 core, from the external flash memory to the extended internal RAM, to release the 
Cortex-M3 core from the reset state. Then, the program sets the LED-controlling port pins, initializes CMT0, and 
specifies the periodic event and interrupt settings. 

In the main loop, the program checks whether an inter-CPU interrupt from the Cortex-M3 core has occurred. If an inter-
CPU interrupt has occurred, the program accesses the shared memory to read the TargetPosition value and copy the 
ActualPosition value. The program also performs input for SW1 and output for LED1. 

As pseudo motor control processing, CMT0 periodic events are used to increment the ActualPosition value until it 
becomes equal to the TargetPosition value while SW1 is being pressed. 

The program for the Cortex-M3 core makes the initial setting for the board. It also makes the initial settings and other 
required settings for the EtherCAT protocol stack and the CiA402 drive profile after the core is released from the reset 
state.  

In the main loop, the program for the Cortex-M3 core executes the main process of the EtherCAT protocol stack.  

The handler for EtherCAT interrupts and EtherCAT Sync0 interrupts changes the status of CiA402, reads the 
ActualPosition value from the shared memory, and then writes the TargetPosition value. The handler also generates an 
inter-CPU interrupt for the Cortex-R4 core. 
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Figure 5.3 Simple Flowchart of the CiA402 Sample Program 
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6. Procedure for Generating Sample Programs 
This section describes the procedure for generating sample programs. You need to prepare the EtherCAT Slave Stack 
Code Tool (SSC Tool) version 5.12 for this procedure. 

 

6.1 I/O Controller Sample Program 
(1) Start the SSC tool from the Windows start menu. 

[EtherCAT Salve Stack Tool] > [SSC Tool] 

(2) Create a new project. 
[File] > [New] 

(3) Press [Import], then select the SSC Tool configuration file for the I/O controller sample program. 
\workspace\iccarm\Cortex-M3\Device\Renesas\RIN_Engine\Source\Project_Dual\EtherCAT_SSC_DC-
hwos\RenesasSDK\CONFIG\Renesase_RZT1 config.xml 

 

The screenshot below shows that the configuration file has been imported. 

 

Figure 6.1 Importing SSC Tool Configuration File 
 

Imported files are registered in the custom list and will be selectable from the drop-down list from the next time. 

 

(1) Click [OK]. Follow the dialog and import the hardware processing file (renesashw.c). 
\workspace\iccarm\Cortex-M3\Device\Renesas\RIN_Engine\Source\Project_Dual\EtherCAT_SSC_DC-
hwos\RenesasSDK\renesashw.c 

(2) Select [Project] > [Create new Slave Files]. 

(3) Press [Start] for generation of EtherCAT Salve Stack Code. 

(4) [New files created successfully] will appear on the screen for a successful generation. 
\workspace\iccarm\Cortex-M3\Device\Renesas\RIN_Engine\Source\Project_Dual\EtherCAT_SSC_DC-
hwos\RenesasSDK\Src 
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6.2 CiA402 Sample Program 
(1) Start the SSC Tool by double-clicking on the SSC project for the target sample program. 

\workspace\iccarm\Cortex-M3\Device\Renesas\RIN_Engine\Source\Project_Dual\EtherCAT_SSC_CiA402-
hwos\RenesasSDK\ssc_project\RZT1-R EtherCAT demo CiA402.esp 

 

 

Figure 6.2 SSC Tool for the CiA402 Sample Program 
 

(2) Select [Project] > [Create new Slave Files]. 

(3) Press [Start] for generation of the EtherCAT Slave Stack Code. 

(4) [New  files created successfully] will appear on the screen for a successful generation. 
\workspace\iccarm\Cortex-M3\Device\Renesas\RIN_Engine\Source\Project_Dual\EtherCAT_SSC_CiA402-
hwos\RenesasSDK\ssc_project\Src 

(5) Prepare the patch command if you don’t have one yet. 

Prepare You need GNU Patch 2.5.9 or later. 
Download the patch command (version: 2.5.9) from the following web site, and then store the patch.exe file in a folder 
in a search path: 
http://gnuwin32.sourceforge.net/packages/patch.htm 

(6) Apply the patch. 

Right-click on the apply_patch.bat file and select [Run as administrator] > [OK]. 

The patch file includes the RZ/T1-related corrections for the SSC source files. 
 
Batch file: 

\workspace\iccarm\Cortex-M3\Device\Renesas\RIN_Engine\Source\Project_Dual 

\EtherCAT_SSC_CiA402-hwos\RenesasSDK\apply_patch.bat 

Patch file: 

\workspace\iccarm\Cortex-M3\Device\Renesas\RIN_Engine\Source\Project_Dual 

\EtherCAT_SSC_CiA402-hwos\RenesasSDK\SSC_CiA402_yyyymmdd.patch 

Note; yyyymmdd is the date of creation of the patch file. 
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Figure 6.3 Example of Executing the Patch Command 
 

After patching, the corrected source files are stored in the folder on the address shown below. 

\workspace\iccarm\Cortex-M3\Device\Renesas\RIN_Engine\Source\Project_Dual\EtherCAT_SSC_CiA402-
hwos\RenesasSDK\Src 
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7. Setup Needed for Connection with TwinCAT 
This section describes how to operate the sample programs by using TwinCAT3. 

Before you can start the sample programs that you created, build their source codes. 

 

7.1 Copying the ESI Files 
Before starting TwinCAT, copy the ESI files that are included in the sample programs to TwinCAT. The copy 
destination is \TwinCAT\3.x\Config\IO\EtherCAT. 

 
• For the I/O controller sample program 

\workspace\iccarm\Cortex-M3\Device\Renesas\RIN_Engine\Source\Project_Dual\EtherCAT_SSC_DC-
hwos\RenesasSDK\ESI_File\RZT1-R EtherCATdemo[DC].xml 

 
• For the CiA402 sample program 

\workspace\iccarm\Cortex-M3\Device\Renesas\RIN_Engine\Source\Project_Dual\EtherCAT_SSC_CiA402-
hwos\RenesasSDK\ ESI_File\RZT1-R EtherCAT CiA402.xml 

 

7.2 Connecting to TwinCAT 
Start TwinCAT3 by using the procedure described below. 

From the [Start] menu, select [Beckhoff] > [TwinCAT3] > [TwinCAT XAE (VS20XX)]. 

After the program is started, by selecting [File] > [New] > [Project], create a new project of the TwinCAT XAE Project 
type. The subsequent procedure is described below. 

 
7.2.1 Setup for Reloading ESI Files 
Load the ESI files of the sample program that you added from the TwinCAT. 

 

 

Figure 7.1 Reloading ESI Files 
Select [Reload Device Descriptions] as in the above figure. 
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7.2.2 Scanning I/O Devices 
 

 

Figure 7.2 Scanning I/O Devices 

 
As shown in the above figure, right-click [I/O Device] and select [Scan] from the menu to open a window. Execute scan 
in the window. After execution, perform operations as shown in Figure 7.3 and Figure 7.4. 

 

 

Figure 7.3 Settings for Scanning I/O Devices (1) 
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Figure 7.4 Settings for Scanning I/O Devices (2) 

 
7.2.3 Updating EEPROM Data 
If the data of another application has already been written to the EEPROM, replace the data. 

The following shows the procedure for replacing the data on the EEPROM: 

(1) Double-click [Box 1] to display a panel on the right side of the window as in Figure 7.5 
(2) Select the [EtherCAT] tab. 
(3) Click the [Advanced Setting] button. 
(4) Select [ESC Access] > [EEPROM] > [Hex Editor]. 
(5) Select [Download from list]. 
(6) Select [Available EEPROM Description]. 
• For the I/O controller sample program 

Select [Renesas Electronics Corp.] > [RZ/T1-R Slaves] > [RZ/T1-R EtherCAT Demo[DC]] 
• For the CiA402 sample program 

Select [Renesas Electronics Corp.] > [RZ/T1-R Slaves] > [RZ/T1-R EtherCAT CiA402] 
(7) Click the [OK] button. 

After the data is replaced, restart RZ/T1 (by turning it off and on, or resetting it) so that the new data is applied to 
the microcomputer. 

(8) Execute [Restart TwinCAT System]. 
 
  

 

This window appears only for 

the CiA402 sample program. 
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Figure 7.5 Procedure for Replacing the Data on the EEPROM (1) 
  

[1]

[2]

[3]

[4]

[5]
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Figure 7.6 Procedure for Replacing the Data on the EEPROM (2) 

 
7.2.4 Confirming the Communication Status 
Select the [Online] tab, and then confirm that the status has been changed to OP. 

 

 

Figure 7.7 Confirming the Communication Status 
Note: If the status has not been changed to OP, try [Activate Configuration], [Restart TwinCAT (Config Mode)], or 

another operation. 
  

[7]

[6]

[8]
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7.3 Sending/Receiving Data 
7.3.1 For the I/O Controller Sample Program 
(1) Checking 32-bit input 

Select [32-Bit Input] > [Online]. 
You can confirm that the value is updated (incremented) 

 

 

Figure 7.8 Checking 32-bit Input Values 

 
  

Incremented
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(2) Checking 32-bit input 

Select [32Bit Output] > [Online] > [Write]. 
Set a value for [Set Value Dialog], and then click the [OK] button. 
Four lower order bits of the value are applied to LED3 to LED0. (LEDs are lit when the corresponding bits are 
1.) 

 

 

Figure 7.9 Checking 32-bit Input Values 
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7.3.2 For the CiA402 Sample Program 
(1) Checking CiA402 status transition 

Select [Control Word], set the value to 7, and then change the value to 15. Then, select [Status Word], and 
confirm that the value is 0x1237, which means, "Operation Enabled". 

 

 
Note: For details about the status transition of CiA402, refer to the "CiA402 standards". 

Figure 7.10 CiA402 Status Transition 
 

  



RZ/T1 Group  

R01AN3173EJ0110  Rev.1.10  Page 26 of 29 
Aug 31, 2018  

EtherCAT Sample Program Implementation Guide for Devices 
with a Built-in R-IN Engine Not Utilizing the HW-RTOS 

(2) Pseudo motor operation 

For [Target Position], set any value as the target value. 
Then, press SW1 to change the value of [Actual Position]. While SW1 is being pressed, the value of [Actual 
Position] is incremented until reaching the value set for [Target Position]. When SW1 is turned off, the value of 
[Actual Position] is reset to 0. 
Note that while SW1 is being pressed, LED1 is lit. 

 

 

Figure 7.11 Pseudo Motor Operation 
 

  

Incremented
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8. Sample Programs 
Download the necessary sample programs from the Renesas Electronics website. 
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9. Reference Documents 
• User's Manual: Hardware 

RZ/T1 Group User's Manual: Hardware 
(Download the latest version from the Renesas Electronics website.) 

 
RZ/T1 Evaluation Board RTK7910022C00000BR User's Manual 
(Download the latest version from the Renesas Electronics website.) 

 
• Documents/Application Notes/Sample Codes 

RZ/T1 Group Application Note: Initial Settings 
(Download the latest version from the Renesas Electronics website.) 

 
RZ/T1 Group Application Note: Compare Match Timer (CMT) 
(Download the latest version from the Renesas Electronics website.) 

 
RZ/T1 Group Application Note: Procedure of EtherCAT Communication for Devices with a Built-in R-IN Engine 
(Download the latest version from the Renesas Electronics website.) 

 
• Technical Update/Technical News 

(Download the latest version from the Renesas Electronics website.) 
 
• User's Manual: Development Environment 

For documents of IAR Integrated Development Environment (Embedded Workbench® for ARM), download the 
latest version from the IAR Systems website. 
(Download the latest version from the IAR Systems website.) 
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Website and Support 
Renesas Electronics Website 

http://www.renesas.com/ 
 
Inquiries 

http://www.renesas.com/contact/ 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
All trademarks and registered trademarks are the property of their respective owners. 

http://www.renesas.com/
http://www.renesas.com/contact/
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General Precautions in the Handling of Microprocessing Unit and Microcontroller Unit Products 
 
The following usage notes are applicable to all Microprocessing unit and Microcontroller unit products from Renesas. 
For detailed usage notes on the products covered by this document, refer to the relevant sections of the document as 
well as any technical updates that have been issued for the products. 
 

1.  Handling of Unused Pins 
Handle unused pins in accordance with the directions given under Handling of Unused Pins in the 
manual. 
 The input pins of CMOS products are generally in the high-impedance state. In operation with 

an unused pin in the open-circuit state, extra electromagnetic noise is induced in the vicinity of 
LSI, an associated shoot-through current flows internally, and malfunctions occur due to the 
false recognition of the pin state as an input signal become possible. Unused pins should be 
handled as described under Handling of Unused Pins in the manual. 

2.  Processing at Power-on 
The state of the product is undefined at the moment when power is supplied. 
 The states of internal circuits in the LSI are indeterminate and the states of register settings and 

pins are undefined at the moment when power is supplied. 
In a finished product where the reset signal is applied to the external reset pin, the states of 
pins are not guaranteed from the moment when power is supplied until the reset process is 
completed. 
In a similar way, the states of pins in a product that is reset by an on-chip power-on reset 
function are not guaranteed from the moment when power is supplied until the power reaches 
the level at which resetting has been specified. 

3.  Prohibition of Access to Reserved Addresses 
Access to reserved addresses is prohibited. 
 The reserved addresses are provided for the possible future expansion of functions. Do not 

access these addresses; the correct operation of LSI is not guaranteed if they are accessed. 
4.  Clock Signals 

After applying a reset, only release the reset line after the operating clock signal has become 
stable. When switching the clock signal during program execution, wait until the target clock signal 
has stabilized. 
 When the clock signal is generated with an external resonator (or from an external oscillator) 

during a reset, ensure that the reset line is only released after full stabilization of the clock 
signal. Moreover, when switching to a clock signal produced with an external resonator (or by 
an external oscillator) while program execution is in progress, wait until the target clock signal is 
stable. 

5.  Differences between Products 
Before changing from one product to another, i.e. to a product with a different part number, confirm 
that the change will not lead to problems. 
 The characteristics of Microprocessing unit or Microcontroller unit products in the same group 

but having a different part number may differ in terms of the internal memory capacity, layout 
pattern, and other factors, which can affect the ranges of electrical characteristics, such as 
characteristic values, operating margins, immunity to noise, and amount of radiated noise. 
When changing to a product with a different part number, implement a system-evaluation test 
for the given product. 

 



 

 

- Arm and Cortex are registered trademarks of Arm Limited (or its subsidiaries) in the EU and/or  
elsewhere. All rights reserved.  

- Ethernet is a registered trademark of Fuji Xerox Co., Ltd. 
- IEEE is a registered trademark of the Institute of Electrical and Electronics Engineers Inc  
- TRON is an acronym for "The Real-time Operation system Nucleus. 
- ITRON is an acronym for "Industrial TRON.  
- μITRON is an acronym for "Micro Industrial TRON. 
- TRON, ITRON, and μITRON do not refer to any specific product or products.  
- EtherCAT® and TwinCAT® are registered trademark and patented technology, licensed by Beckhoff 

Automation GmbH, Germany. 
- Additionally all product names and service names in this document are a trademark or a registered  
trademark which belongs to the respective owners. 
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Notice
1. Descriptions of circuits, software and other related information in this document are provided only to illustrate the operation of semiconductor products and application examples. You are fully responsible for

the incorporation or any other use of the circuits, software, and information in the design of your product or system. Renesas Electronics disclaims any and all liability for any losses and damages incurred by

you or third parties arising from the use of these circuits, software, or information.

2. Renesas Electronics hereby expressly disclaims any warranties against and liability for infringement or any other claims involving patents, copyrights, or other intellectual property rights of third parties, by or

arising from the use of Renesas Electronics products or technical information described in this document, including but not limited to, the product data, drawings, charts, programs, algorithms, and application

examples.

3. No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights of Renesas Electronics or others.

4. You shall not alter, modify, copy, or reverse engineer any Renesas Electronics product, whether in whole or in part. Renesas Electronics disclaims any and all liability for any losses or damages incurred by

you or third parties arising from such alteration, modification, copying or reverse engineering.

5. Renesas Electronics products are classified according to the following two quality grades: “Standard” and “High Quality”. The intended applications for each Renesas Electronics product depends on the

product’s quality grade, as indicated below.

"Standard": Computers; office equipment; communications equipment; test and measurement equipment; audio and visual equipment; home electronic appliances; machine tools; personal electronic

equipment; industrial robots; etc.

"High Quality": Transportation equipment (automobiles, trains, ships, etc.); traffic control (traffic lights); large-scale communication equipment; key financial terminal systems; safety control equipment; etc.

Unless expressly designated as a high reliability product or a product for harsh environments in a Renesas Electronics data sheet or other Renesas Electronics document, Renesas Electronics products are

not intended or authorized for use in products or systems that may pose a direct threat to human life or bodily injury (artificial life support devices or systems; surgical implantations; etc.), or may cause

serious property damage (space system; undersea repeaters; nuclear power control systems; aircraft control systems; key plant systems; military equipment; etc.). Renesas Electronics disclaims any and all

liability for any damages or losses incurred by you or any third parties arising from the use of any Renesas Electronics product that is inconsistent with any Renesas Electronics data sheet, user’s manual or

other Renesas Electronics document.

6. When using Renesas Electronics products, refer to the latest product information (data sheets, user’s manuals, application notes, “General Notes for Handling and Using Semiconductor Devices” in the

reliability handbook, etc.), and ensure that usage conditions are within the ranges specified by Renesas Electronics with respect to maximum ratings, operating power supply voltage range, heat dissipation

characteristics, installation, etc. Renesas Electronics disclaims any and all liability for any malfunctions, failure or accident arising out of the use of Renesas Electronics products outside of such specified

ranges.

7. Although Renesas Electronics endeavors to improve the quality and reliability of Renesas Electronics products, semiconductor products have specific characteristics, such as the occurrence of failure at a

certain rate and malfunctions under certain use conditions. Unless designated as a high reliability product or a product for harsh environments in a Renesas Electronics data sheet or other Renesas

Electronics document, Renesas Electronics products are not subject to radiation resistance design. You are responsible for implementing safety measures to guard against the possibility of bodily injury, injury

or damage caused by fire, and/or danger to the public in the event of a failure or malfunction of Renesas Electronics products, such as safety design for hardware and software, including but not limited to

redundancy, fire control and malfunction prevention, appropriate treatment for aging degradation or any other appropriate measures. Because the evaluation of microcomputer software alone is very difficult

and impractical, you are responsible for evaluating the safety of the final products or systems manufactured by you.

8. Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental compatibility of each Renesas Electronics product. You are responsible for carefully and

sufficiently investigating applicable laws and regulations that regulate the inclusion or use of controlled substances, including without limitation, the EU RoHS Directive, and using Renesas Electronics

products in compliance with all these applicable laws and regulations. Renesas Electronics disclaims any and all liability for damages or losses occurring as a result of your noncompliance with applicable

laws and regulations.

9. Renesas Electronics products and technologies shall not be used for or incorporated into any products or systems whose manufacture, use, or sale is prohibited under any applicable domestic or foreign laws

or regulations. You shall comply with any applicable export control laws and regulations promulgated and administered by the governments of any countries asserting jurisdiction over the parties or

transactions.

10. It is the responsibility of the buyer or distributor of Renesas Electronics products, or any other party who distributes, disposes of, or otherwise sells or transfers the product to a third party, to notify such third

party in advance of the contents and conditions set forth in this document.

11. This document shall not be reprinted, reproduced or duplicated in any form, in whole or in part, without prior written consent of Renesas Electronics.

12. Please contact a Renesas Electronics sales office if you have any questions regarding the information contained in this document or Renesas Electronics products.

(Note 1) “Renesas Electronics” as used in this document means Renesas Electronics Corporation and also includes its directly or indirectly controlled subsidiaries.

(Note 2) “Renesas Electronics product(s)” means any product developed or manufactured by or for Renesas Electronics.
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